Windows Hardware Lab Kit

The Windows Hardware Lab Kit (Windows HLK) is a test framework used to test hardware devices for Windows 10. To qualify for the Windows Hardware Compatibility Program, your product must pass certain tests using the Windows HLK.

This guide provides information about the tests that are included in the Windows Hardware Lab Kit, and instructions on how to build a test environment, automate driver and system testing, and create a submission package required to participate in the Windows Hardware Compatibility Program.

If you’re developing for Windows 10, you need the latest Windows HLK. This kit helps you ensure that the drivers and the system you develop are certified as compatible with Windows 10.

NOTE

New for 1809: Certify using the Virtual HLK (VHLK)! The VHLK is the entire Hardware Lab Kit pre-installed and pre-configured on a VHDX, ready to boot as a virtual machine. Use the VHLK to save setup time, quickly stand up a controller, and run Windows Hardware Certification from a virtual machine.

To certify... | Download...
Windows 10, version 1809 | Windows HLK, version 1809 or Windows Virtual HLK (VHLK), version 1809 - NEW!
Windows 10, version 1803 | Windows HLK, version 1803
Windows 10, version 1709 | Windows HLK, version 1709
Windows 10, version 1703 Windows 10, version 1607 | Windows HLK, version 1703
Windows Server 2016 | Windows HLK, version 1607
NOTE

Windows HLK only supports testing on Windows 10 and Windows Server 2016 systems. For testing previous versions of Windows, use the Hardware Certification Kit for Windows 8.1.

Windows Hardware Compatibility Program

To qualify for the Windows Hardware Compatibility Program, your product must pass certain tests using the Windows HLK. For guidance on which kit to use for compatibility certification, see the Windows Hardware Compatibility Program and the Windows Hardware Certification Blog.

IMPORTANT

Certification for Windows Server 2016, Azure Stack, and SDDC must continue to meet the Windows Hardware Compatibility Requirements as stated in version 1607 of documentation; must use version 1607 of the HLK (build 14393) with matching playlist and supplemental content to generate logs; and must follow policies as stated in the Windows Server Policy document. Questions about the Azure Stack, SDDC programs, or how to submit the results for solution validation should be directed to the appropriate Microsoft technical account manager or partner management contact.

Download Windows Hardware Compatibility playlist

Get the official Windows Hardware Compatibility playlist so you can run the Windows HLK tests that ensure your hardware meets the requirements for compatibility with Windows 10.

  • Download the Windows Hardware Compatibility playlist

Watch the WinHEC video on HLK Playlists to learn more.

Download Windows HLK Filters

When there is a problem in either a Windows HLK test or in the operating system itself that causes certification tests to fail incorrectly, we create an errata that allows partners to bypass the problematic test. Most errata use filters to automatically filter the failure from the submission results. Filters are applied within Windows HLK Studio.

  • Download Windows HLK filters

Download Windows HLK Supplemental Test Content

Supplemental Content for Media, Graphics, Mean Time Between Failures (MTBF), and Private Cloud Simulator Tests

Supplemental test content downloads are required for some tests related to graphics, media, and mean time between failures (MTBF). Download these files to complete Windows HLK testing in these areas.

Required downloads for tests that use supplemental content:

Media

  • HLK_DXVA.iso (Windows 10, version 1809)
  • HLK_DXVA.iso (Windows 10, version 1803)
  • HLK_DXVA.iso (Windows 10, version 1607, 1703, and 1709)
  • HLK_HMFT.iso (Windows 10, version 1809)
  • HLK_HMFT.iso (Windows 10, version 1607, 1703, 1709, and 1803)
  • HLK_PERF.iso (Windows 10, version 1607, 1703, 1709, 1803, and 1809)

Graphics

  • HLK_GRFX_FOD.zip (Windows 10, version 1809)
  • HLK_GRFX_FOD.zip (Windows 10, version 1803)
  • HLK_GRFX_FOD.zip (Windows 10, version 1709)
  • HLK_GRFX_FOD.zip (Windows 10, version 1703)
  • HLK_GRFX_FOD.zip (Windows 10, version 1607)

Mobile

  • HLK_MOBILE.iso (Windows 10, version 1607, 1703, 1709)

Private Cloud Simulator (PCS)

This supplemental content package is required to pass the Device and Solutions PCS Tests. On the server that has the Windows HLK controller installed, place PCSFiles.vhd at the following location:

C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\amd64

  • Download PCSFiles.vhd (Windows Server 2016)

Download HLK Offline Documentation

This documentation is also available in .chm format for offline use.

  • Download HLK offline documentation


What's new in the Hardware Lab Kit

What's new in this release

Breaking changes

NOTE

With each new release, anyone who builds tools that utilize the HLK object model should rebuild those tools to use the latest versions of the object model files. In addition, be sure to always use the same version of each object model file (i.e. do not mix object model files from different kit releases).

Virtual Hardware Lab Kit (VHLK)

New for 1809! The Microsoft Virtual Hardware Lab Kit (VHLK) is the entire Hardware Lab Kit pre-installed and pre-configured on a VHDX, ready to boot. Use the VHLK to save setup time, quickly stand up a controller, and run Windows Hardware Certification from a virtual machine. For more details, check out the VHLK Getting Started Guide.

  • Ready to boot and use
  • Run the HLK Controller as a virtual machine
  • Host the HLK Controller virtual machine on developer machines instead of dedicated Controller hardware

Server support

HLK version | Compatable server OS versions
1809 | Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
1803 | Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
1709 | Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
1703 | Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
1607 | Windows Server 2008 R2 SP1, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
NOTE

Windows Server 2019 is not supported as a host OS for the 1809 HLK Controller. However, it is supported as a client OS.

Updated test content

Test content updated for better coverage for 1809 testing, across various architectures.

Known issues this release

HLK install fails with a database-related error

This error can occur when uninstalling and then reinstalling HLK. When the new instance of HLK is installed, one of the following error messages appears when installing and rolls back

  • There is already an object named DSLinkType in the database.
  • The database database_name already exists.
  • Failed to create SQL database.

When uninstalling HLK, database uninstall can fail if the database is locked by another process. The HLK uninstall reports success, but the database is left behind. To recover, follow these steps:

  1. From an elevated command prompt, run SQLCMD -E
  2. From the SQL Shell command line, enter the following:
  3. ALTER DATABASE WTTIdentity SET SINGLE_USER WITH ROLLBACK IMMEDIATE
  4. DROP DATABASE WTTIdentity
  5. GO
  6. ALTER DATABASE HLKJobs SET SINGLE_USER WITH ROLLBACK IMMEDIATE
  7. DROP DATABASE HLKJobs
  8. GO
  9. Verify that C:\Program Files\Microsoft SQL Server\MSSQL(sql version).MSSQLSERVER\MSSQL\DATA contains no files starting with WTTIdentity or HLKJobs
  10. Install the HLK

HLK does not update existing SQL database with latest security fix

If your existing SQL Server database is unpatched, installing the HLK will not update the database with the latest security fixes.

To patch SQL Server: Option 1: Uninstall SQL Server before installing the HLK. The HLK will install SQL Server and the most recent hotfix as of RTM. At this point, you may use Windows Update to keep your SQL Server instance updated. Option 2: Manually patch your existing SQL Server before HLK install.

What's new in previous releases

Improved playlist support

The process for loading and using playlists has been improved and simplified. For more information, see Step 6: Select and run tests in the Getting Started guide

Support for ARM64 desktop

HLK tests can now target ARM64 desktop machines.

Nano Server testing

HLK now includes tests for Nano Server.

Improved diagnosability of failed HLK tests

The Results tab now indicates when a test fails due to a system crash. The tab also shows information from the associated Bug Check along with a link to help documentation for further information.

See the following topics for more information:

  • Step 7: View test results and log files (Getting started guide)
  • HLK Studio - Results Tab
  • Troubleshooting Windows HLK Test Failures (system crashes)

Exporting failed HLK jobs

You can now export a failed job and re-run it on a machine that does not have the HLK Client installed. For more information, see Exporting a Failed HLK Job.

Support for Mobile testing

Mobile devices running Test and Health images are now supported for testing with the HLK. For more information, see HLK Proxy Client Getting Started Guide.

SQL Server 2012 Express SP2

The HLK setup process now installs SQL Server 2012 Express SP2 if no other SQL installation is present on the controller at the time of installation.

Scenario Testing

Test levels have been replaced by Development Phases to better align with the hardware and system development cycle. Tests are organized by their applicability during Bring Up, Development and Integration, Reliability, and Tuning and Validation.

Playlists

Playlists describe a collection of tests and can be created from the HLK Studio and Object Model to define custom test passes.

Video link

Learn more about playlists in the Getting Started Guide.

Windows Hardware Compatibility Program

Hardware certification is no longer required. Instead, the Windows Hardware Compatibility Program is an optional program in which you can participate. For more information, see Windows Hardware Compatibility Program.

  • Compatibility Playlist - Levels are no longer used to identify tests required for the Compatibility Program. To create a Compatibility Program test pass, download the official Hardware Compatibility Program Playlist and apply to your HLK project.
  • Windows Hardware Certification blog -This blog provides up-to-date news about the Windows Compatibility Program. Including Compatibility Playlist update announcements.

OS Support

The Hardware Lab Kit supports Windows 10 testing only. Use the Hardware Certification Kit for testing downlevel operating systems.

Merge .hckx Packages

To support unified driver submissions, results from HCK and HLK projects can be merged together using HLK Studio. When merging, open the HLK project or package first, and then merge in the HCK package(s).

Virtual machine support

The HLK Controller now supports installation and execution in a virtual machine. When configuring your virtual machines, ensure the virtual machine meets the minimum requirements for the HLK Controller.

Partial packaging

You can now package a subset of test results within an HLK project, tailoring the packaging experience to key scenarios. This allows you to capture, share, and diagnose test failures without having to run tests individually in a new project.

To use this feature, select one or more tests from the Test tab, right-click the selection, and choose Create Partial Package of Highlighted Tests. Note that this package will be saved as a partial package (.hlkp). This extension will be deprecated in future HLK releases.

Rate this Test

You can now provide feedback on tests in the HLK. To rate tests, you must opt-in to CEIP. To rate a test, right-click on the desired test in the Results Pane, and select Rate This Test.

Preview pane

The Preview pane in File Explorer provides project and package information including Name, Creation Date, Targets, and Type.

To use the Preview pane in File Explorer, choose the View menu group, and then choose Preview pane. You can then choose any .hlkx file to view details of the package.

64-bit SQL

The HLK now supports 64-bit SQL editions exclusively. Previously, the HCK supported only 32-bit SQL editions exclusively.


Windows HLK Getting Started

This section provides a basic introduction to using the kit. Once you are familiar with the tools and process, you can review the User's Guide for additional information.


Windows HLK Prerequisites

WARNING

The Windows Hardware Lab Kit (HLK) should only be installed on machines that are dedicated solely for testing purposes. Do not install any HLK component on a machine that is outside of a dedicated testing environment.

Windows HLK is comprised of two components: an HLK test server and one or more test systems.

  • HLK test server. Often referred to as the controller, a test server has two parts: Windows HLK Controller and Windows HLK Studio. The Controller software is the engine that manages tests that are run on test systems. The Studio software is the management tool that lets you select and schedule tests against any test system connected to the test server. Controller and Studio are installed from the Windows HLK installation source. After installation, the test server contains separate installers to install a remote Windows HLK Studio and Windows HLK Client.

    One controller governs a collection of client computers. Controllers can manage and access only the client computers that they govern.

  • Test system. Also referred to as a client computer, each test system can have a different configuration that's appropriate for various testing scenarios, including different hardware, operating systems, service packs, and drivers. Each test system can be associated with only one test server. You can configure each test system by running the Windows HLK Client software installer directly from a shared network location on the test server.

Before you begin testing, be sure that the test environment meets the necessary requirements.

  • Be sure to install .NET Framework 4.5 prior to controller setup. Controller setup will fail if .NET Framework 4.5 has not previously been installed.
  • You must uninstall any 32-bit SQL Server installation prior to installing the HLK. 32-bit SQL Server installations are not supported.
  • You must uninstall any SQL Server 2014 installations prior to installing the HLK. SQL Server 2014 is not supported.

Deployment scenarios

There are two deployment scenarios for Windows HLK:

  • Domain-joined environment. In a domain-joined environment, a domain controller is present and all computers designated for Windows HLK features are joined to the same domain controller. If you plan to deploy Windows HLK in a domain-joined environment, you need a minimum of three computers: a Windows domain controller, a Windows HLK test server, and at least one Windows HLK test system. Make sure that Microsoft Active Directory is configured and running on the domain controller. Your domain controller and HLK test server cannot be on the same box.

  • Workgroup environment. A workgroup environment has no domain controller. If you plan to deploy Windows HLK in a workgroup, you need at least two computers: a test server and a test system joined to the same workgroup. Don't use the Default Administrator account. In this configuration, you must enable the Guest account.

In addition, consider how you want to organize lab resources to best use the Windows HLK. You need to determine the number of test servers and the number of test systems connecting to them. These decisions are partly influenced by the type of devices or systems that you want to test.

To test systems and filter drivers, you need at least 1 test server and 1 test system.

To test external devices, you need at least 1 test server, 1 test system, and the external device(s) to be tested.

You can choose to allocate fewer controllers, each with multiple clients connected to them, if you want less overhead administering the controllers and clients. A maximum of 150 clients can be connected to a single controller. Alternately, you can allocate more controllers and connect fewer clients to them. This allows any given controller to be more responsive because it has fewer clients communicating with it. For more information, see HLK Controller and Client Organization.

The following image shows an example test environment.

example hlk test environment

System Requirements

Test server

Component | Minimum | Optimum
Processor | Single Intel or AMD-based x64 platform with a speed of 2.0 GHz | Multicore or multiple x64-based processors running in x64 mode with a speed of 2.0 GHz or faster
System memory | 2 GB main memory | 4 GB main memory
Hard disk capacity | 300 GB minimum to accommodate the volume of logs that can be generated. | RAID configuration
Network connection | 100 megabits per second (Mbps) | 1 gigabit per second (Gbps)
Operating system | English language and English local version of Windows Server 2012, Windows Server 2012 R2, or Windows Server 2016. |
NOTE

Windows Server 2019 is not supported as a host OS for the 1809 HLK Controller. However, it is supported as a client OS.

NOTE
  • Windows 10S users should test against Windows 10 Pro.
  • Controller isn't supported on Windows Server 2003, Windows Server 2008, Windows Vista, Windows XP, or Windows 2000.
  • Controller isn't supported on an installation that has already been set up as a domain controller.

Test system

Component Minimum

Processor

The recommended processor for the operating system that you install.

System memory

Refer to the recommended processor for the operating system that you install.

Hard disk capacity

300 GB minimum to accommodate the test files and logs that can be generated.

The client must be unique; you can't swap drives.

Network connection

100 Mbps

Operating system

Install the English language and English local version of the Windows operating system that you are testing against.

Test systems are not supported in a virtual PC or any third-party Hypervisor environment.

If you are testing against a Windows "N" edition, you must also manually install Media Feature Pack.

Windows 10S users should test against Windows 10 Pro.

Additional requirements

Many of the tests require a test system to restart--often more than once--to complete a test run. So, we recommend that you:

  • Configure test systems to boot from the regular boot sector of a hard drive and not from external devices, CDs, or DVD boot discs.

For Workgroup environments, you must enable the guest account.

  1. On each computer, create a new user account and add it to the Administrator group.

  2. On each computer, log on with the administrator account you just created and enable the Guest account.

Testing may also require:

  • HLK Filters.

  • Test-sign drivers.

  • Additional source code/Readme files that are requested at the end of package creation.

Optional remote/standalone Windows HLK Studio

Component Minimum

Processor

The recommended processor for the operating system that you install.

System memory

Refer to the recommended processor for the operating system that you install.

Hard disk capacity

300 GB minimum to accommodate the volume of logs that can be generated.

The client must be unique; you can't swap drives.

Network connection

100 Mbps

Operating system

  • Windows 10

  • Windows 8.1

  • Windows 8

  • Windows 7


Step 1 Install Controller and Studio on the test server

WARNING

The Windows Hardware Lab Kit should only be installed on machines that are dedicated solely for testing purposes. Do not install any HLK component on a machine that is outside of a dedicated testing environment.

In this step, you install Windows HLK software on the designated test server. The setup program installs the Windows HLK Controller and Studio, in addition to other resources.

The test server should be preinstalled with Windows Server 2012, Windows Server 2012 R2, or Windows Server 2016.

If you are upgrading your HLK environment to a later version, you must first uninstall the previous version of the HCK or HLK software from the test server and any connected test clients.

To install Windows HLK, do the following:

  1. Download the correct HLK version for the devices you wish to test. See the Windows Hardware Lab Kit topic for information about selecting the correct HLK.

    If you are downloading directly onto your server, you must disable the IE Enhanced Security Configuration (IE ESC).

  2. When prompted, select Run.

    WARNING

    Don't select the Save option. The Save option only downloads the setup file and not the complete kit.

  3. When the Specify Location screen appears, choose the appropriate option:

    1. Install option - choose Install the Windows Hardware Lab Kit to this computer, and then choose Install .

    2. Download option - choose Download the Windows Hardware Lab Kit for installation on a separate computer, and then choose Next.

  4. Select the Windows Hardware Lab Kit -- Controller + Studio option.

    If you are installing directly, you must open a port on your server. Choose Yes, to allow the installation to open a port.

  5. When the Join the Customer Experience Improvement Program (CEIP) screen appears, choose Yes or No, and then choose Next. If your network isn't connected to the Internet, choose No.

  6. Review the License Agreement, and then choose Accept to proceed.

    If you selected the download option, copy your download to your test server. Run HLKSetup.exe and repeat the installation instructions from Step 3 for installing to this computer.

    Installation takes about 45 minutes.

    NOTE

    If Microsoft .NET Framework 4.5 isn't already installed on the computer, follow the prompts to install it. After the computer restarts, you must repeat the installation instructions from Step 1 for installing to this computer.

Related topics

HLK Studio

Install a remote HLK Studio

Install standalone HLK Studio


Step 2 Install Client on the test system(s)

After you install the Windows Hardware Lab Kit (Windows HLK) on the test server, you are ready to add test systems to the environment. You must install the Windows HLK Client software on each test system. The Windows HLK Client software is stored on the Windows HLK test server.

If you are testing software, be sure to install the product on the test system first, and then install the Windows HLK Client software.

To install the Windows HLK Client

  1. On the test system, browse to the following location:

    \\<ControllerName>\HLKInstall\Client\Setup.cmd.
    (Replace <ControllerName> with the name of the test server.)

    If the following software is not already installed, it is installed during this step:

    • .NET Framework 4 (Client Profile and Extended)
    • Application Verifier
    • Windows Driver Test Framework (WDTF)
    • Windows Performance Toolkit (WPT).

    If the test system has a Server Core installation, then you should install the HLK client using the silent install option:

    \\<HLKController>\HLKInstall\Client\Setup.cmd /qn ICFAGREE=Yes

  2. The Windows Hardware Lab Kit Client Setup wizard appears. To start the wizard, choose Next.

  3. On the Internet Connection Firewall Agreement page, select Yes I will allow a port to be opened, and then choose Next.

    NOTE

    If the Internet Connection Firewall Agreement page doesn't appear, either Windows Firewall isn't installed, or another software firewall or hardware firewall is installed on the computer. If another firewall is installed, you must manually open TCP port 1771 to proceed with installation. Refer to the instructions that came with your firewall product to manually open a TCP port. If you continue without opening port 1771, the installation may fail or the Client software might not function properly.

  4. When the Ready to Install page appears, select Install.

  5. Click Finish to exit the wizard.

    TIP

    When installation completes, confirm its success by going to the Control Panel and choosing Uninstall a program. Windows Hardware Lab Kit Client should appear in the program list.

  6. Repeat steps 1-5 for each test system.


Step 3 Create a machine pool

A machine pool is a logical grouping of one or more test systems. After you install Windows HLK Client on each test system, the computers are automatically added to the default machine pool. Before you can work with a test system, you must move it to a working machine pool.

Every project needs a machine pool. A machine pool can be used for multiple projects. A project can reference multiple machine pools.

The following image shows the Studio Configuration page.

hlk studio configuration page

To create a machine pool

  1. In Windows HLK Studio, choose Configuration.

  2. To create the first new pool, right click on the $(Root) node and then choose Create Machine Pool. Change the default name, if desired, and then press Enter to finish.

    Once a new pool is created, you can also right click on it and chose Create Machine Pool. The Archive and Default pools have special roles, so they cannot be used to create a new pool.

  3. Choose Default Pool, and confirm that each test system appears in the main pane on the right. If you've installed the Client on multiple test systems, you can add any of them to the pool. A computer can only be in one pool at a time.

  4. Move a test system into the new pool by first selecting it and then dragging it onto the newly-created pool.

  5. In the pane on the right, right-click the test system under the Machines column, choose Change Machine Status, and then choose Ready.

    The Status column changes to Ready.

    WARNING
    • You cannot schedule a test against a computer with status equal to NotReady.
    • A computer cannot be set to Ready while in the Default pool.

  6. Repeat the previous two steps for each test system that you want to include in the pool.

  7. Once you've added all of the test systems to the desired machine pool, choose the back arrow to return to the main area of Windows HLK Studio.

After all of the test systems are placed in a pool, you're ready to conduct testing against those computers.

To learn more about the different options on this page including distributed and multi-device support, see HLK Studio - Configuration Page.


Step 4 Create a project

After you setup your test server and clients, you're ready to create a project. A project defines what you want to test. The most common project corresponds to the device you want to submit for certification.

You can create large projects that represent a wide range of scenarios. You can also create several smaller projects and merge the results into one package.

In the remaining examples, you create a project for a device and run all associated certification tests. Then, you create a single package for submission that contains all of the passing test results.

The following image shows the Studio Project tab.

hlk studio project tab

To create a project

  1. In Windows HLK Studio, choose the Project tab, and then choose Create project.

  2. Replace the default project name with the name of your project, and then press Enter.

    A project should have a meaningful name that indicates its contents, for example, "Fabrikam Multi-function Device Model Z".

    When the project name appears on the page, the project is created.

The right pane displays project details. More information is displayed here once you start testing your device. You can check the status of any project by loading it and referring to this pane.

To learn more about this page, see HLK Studio - Project Tab.


Step 5 Select target to test

Windows HLK Studio detects all features that a device implements. An individually testable feature is called a target. A device may contain multiple targets, represented by one or more hardware IDs. On the Selection tab, you can filter what you want to test by using the following views:

  • systems - used to test a complete client or server system.

  • devices and printers - used to test an external device that's connected to a test system. This device typically appears in Start > Devices and Printers on the test system.

  • device manager - used to test a component of a test system or external device, for example, a network card. This is the most detailed view.

  • software device - used to test filter drivers, firewalls, and antivirus software installed on the test system.

    NOTE

    Some software drivers are associated with a physical device. If you cannot find your driver listed in the software device view, use the search bar in the device manager view to find the device under which your software driver is associated.

The following image shows the Studio Selection tab.

hlk studio selection tab

Select a target to test

  1. In Windows HLK Studio, choose the Selection tab. In the machine pool dropdown, choose the pool that contains the devices that you want to test.

  2. In the left pane, select the view based on the device you want to test: systems, device and printers, device manager, or software device.

    A list of available targets is displayed in the center pane. If you select the device manager view, you can choose to show inbox and hidden features.

  3. In the center pane, check the box next to each target that you want to test.

    You must select all of the features of a specific product type for a device to receive certification.

    If you're testing a Web Services on Devices (WSD) device, there may be a delay before the required WSD targets are listed.

The show selected view in the left pane displays the targets that you've selected across all views. This view allows you to see just the areas you're testing. You also can filter a machine pool by category by using the category list. You can search for specific targets and features by using the search box.

To learn more about the different options on this page see HLK Studio - Selection Tab.


Step 6 Select and run tests

The Tests tab displays all of the tests that are associated with the features found on your device. In the HLK, test categories replace the level classifications previously used with the HCK. The HLK can be used throughout the product life cycle to test and measure quality at each stage of development.

You can filter and sort the listed tests in the following ways.

  • Test Phase Categorization
    • Bring Up
    • Development and Integration
    • Reliability
    • Tuning and Validation
    • Manufacturing
    • Support
  • Status
  • Test Name
  • Type (manual, non-distributed, special configuration, multiple machine)
  • Length
  • Target
  • Machine(s)
NOTE
  • You can hover over the test Type icons with your mouse for more information about the test Types.
  • Manual tests that require user input can interrupt the test process. We recommend that you run manual tests separately from automated tests.
  • Some tests require additional input before running. Windows HLK Studio prompts you for more info as needed.

The following image shows the Studio Tests tab.

hlk studio tests tab

Playlists

Playlists are collections of tests that you can use to define various scenarios in which to test your device. The Windows Hardware Compatibility Program uses an official playlist to determine which devices meet the requirements for compatibility with Windows 10.

Video link

You can load a playlist by choosing Load Playlist from within the Tests tab. You can load only one playlist at a time. To choose a different playlist, you must first unload the current playlist by choosing Unload Playlist from the Tests tab.

The following image shows the Load Playlist File dialog.

load playlist dialog

Once a playlist is loaded, only tests that are applicable to each target are shown in the UI.

Test results against all playlists for a specific target are kept until the target is removed from the project. When a playlist is loaded, any previous test results against that playlist are also loaded.

You can save an existing collection of tests as a playlist by choosing Save Selected As Playlist.

IMPORTANT

When using an official playlist, you must use the version of the playlist that matches the version of the kit you are using. For example, if using version 1607 of the HLK, you must also use version 1607 of the playlist.

Running a test

If using a playlist, be sure to load it before following these steps.

  1. Filter the test results by using the View By dropdown list.

  2. Check the box next to each test that you want to run.

  3. Run the selected tests by choosing Run Selected.

    If any additional input is needed, Windows HLK Studio will prompt you.

    A progress bar appears. A slight delay occurs when you run a test.

To learn more about any test, select the test from the list and press F1 key or right-click and select Test Description. To cancel any running test, right-click it and select Cancel.

As tests complete, the results are displayed in the Status column. A green checkmark means that it passed, while a red X means that it failed. The pane on the right displays project summary information, including target(s) selected, operating systems being tested, product types you qualify for, and status of all tests.

To learn more about the different options on this page, see HLK Studio - Tests Tab.


Step 7 View test results and log files

The Results tab displays detailed information about each test. As each test completes, the status column updates with the result--pass or fail.

The following image shows the Studio Results tab.

hlk studio results tab

Troubleshooting a failed test

If a test fails, you can expand the test details to review the associated log file.

  1. From the list, select a failed test, indicated by a red X or the system crash icon ( system crash icon).

  2. Expand the Test Name node, expand the Logs node, and then double-click the log file.

    You can review these log files:

    • .log file. Text dump.

    • .wtl file. Open to view error reports.

    • .xml file. Change file name extension to .wtl to view error reports.

Right-click any test to see additional test details, including:

  • Bugcheck Summary information for system crashes that occur during test runs

  • Task logs

  • Additional files

  • Applied filters

  • Errors

  • Infrastructure (gather and execution logs)

To learn more about the different options on this page, including distributed and multi-device support, see HLK Studio - Results Tab.

Exporting failed HLK jobs

You can now export a failed job and re-run it on a machine that does not have the HLK Client installed. For more information, see Exporting a Failed HLK Job.


Step 8 Create a submission package

NOTE

We highly encourage you to include driver symbols as part of package creation. Including symbols enables Microsoft to triage and root cause issues related to your driver.

After the device passes all of the necessary tests, you can create a submission package (.hlkx file) for submission.

Windows HLK Studio supports package creation, so you don't need to use a separate submission tool. It supports adding resource files (drivers, symbols, errata) necessary to complete certification. You can also merge multiple packages (.hlkx files) into one single package.

The following image shows the HLK Studio Package tab.

hlk studio package tab

To create a submission package

  1. Select the Package tab.

  2. If you used a special driver for a device (optional), submit it by doing this:

    1. Click Add Driver Folder > Browse to select the folder, and then click OK.

    2. In the Driver Properties dialog box, select the appropriate Products and Locales, and then click OK.

      IMPORTANT
      • Hardware Dev Center uses Locales to build the correct OS Language targeting for Windows Update. If you plan on publishing your driver to Windows Update, be sure to select all the languages you want it delivered to.
      • The default locale is English only. If you want to add another locale, you must add it now. After the driver package is created, you cannot change the locales.

  3. To add symbols (optional), right-click the driver folder, click Add Symbols > Browse to select the folder, and then click OK.

  4. To add a supplemental folder (optional), such as a Readme file, contingency message, errata, or manual filter, click Add Supplemental Folder > Browse to select the folder, and then click OK.

  5. Click Create Package.

  6. From the Signing Options dialog box, select one of these options:

    IMPORTANT

    All submissions must be digitally signed. Starting with Windows 10, you must also include an EV (extended validation) code signing certificate.

    • Do not sign to create an unsigned package, for example, to send to Support for debugging or to later merge with other packages into a single submission package.

    • Use the certificate store to create a digitally signed package--the most common scenario. This option requires an X509 certificate--for example a VeriSign certificate-- to be installed on the computer running Windows HLK Studio. From the Windows Security dialog box, select the appropriate code signing certificate.

    • Use a certificate file to create a digitally signed package by using a portable security file. This option asks you for an X509 certificate file (.cer file).

For additional information on packages, see the following topics:

  • HLK Studio - Package Tab

  • HLK Signing with an HSM

Next steps

Congratulations, you have completed the end-to-end testing of your device using the Windows HLK. Submit the signed package (.hlkx file) through the Windows Hardware Dev Center Dashboard. (For more details, see Windows Hardware Dev Center dashboard.)


VHLK Getting Started Guide

The Windows Virtual Hardware Lab Kit (VHLK) is an HLK Controller pre-configured on a VHD that can be booted as a VM in Hyper-V. The VHLK includes an Evaluation copy of Windows Server 2016, and can be downloaded from the Microsoft Eval Center

WARNING

After booting the VHLK, do not change the auto-generated computer name (i.e. WIN-xxxx).

NOTE

Generation 2 VM's are not supported by the VHLK

NOTE

Default login credentials are HLKAdminUser with password Testpassword,1

Physical (Host) Machine Specifications

Recommended:

  • 8-core, 64-bit processor with SLAT
  • 8GB RAM
  • Virtualization support turned on in BIOS / UEFI
  • 120GB HDD free space

Virtual Machine Settings

Recommended:

  • Memory: >= 4096MB
  • Processor: >= 2 Virtual processors

Hyper-V Setup Guide

  1. Enable Hyper-V
  2. Create a new external virtual switch
    • If you enable Hyper-V through Server Manager on Server 2016, it will prompt you to create a virtual switch
    • Otherwise follow these instructions
  3. Obtain a local copy of the VHLK from the Microsoft Eval Center
  4. Create a new virtual machine in Hyper-V
    • Create a name for the VM and select 'Next'
    • Select Generation 1 and select 'Next'
    • Use 4096MB or more of startup memory and select 'Next'
    • Select a network adapter and select 'Next' (This is generally the virtual switch create above)
    • Select "Use an existing virtual hard disk" and browse for the local HLK VHDX
    • Select Finish
  5. Edit Virtual Machine settings
    • Change processor to use at least 2 virtual processors
    • Modify other settings as needed
  6. Start up the VM
  7. Windows will boot up and automatically create an Administrator user named HLKAdminUser with password ‘Testpassword,1’. Log in.
  8. The VM will then run some HLK setup on first boot
    • Please wait for all cmd windows to finish before using the HLK
    • Note: Occasionally the screen will be all black before this. The VM is still running, it just sometimes takes a bit for the desktop to load if the VM is not using the recommended settings.
    • Do not rename the VM. If you change the computer name, you will not be able to connect to the HLK Controller.
  9. Once all the cmd windows have finished, you may wish to change the date/time settings.
    • By default, the server is set to "(UTC) Coordinated Universal Time", with "Set time zone automatically" and "Adjust for daylight savings time automatically" turned OFF. This may cause confusion when trying to align time stamps of various client / controller logs. To change:
      1. Click on the Date/Time section of the taskbar
      2. Select "Date and Time Settings" from the bottom of the flyout
      3. Specify the time zone you are in from the dropdown
      4. turn on "Adjust for daylight savings time automatically" (if you wish)
    • Time should now be synchronized with the various client devices and host machines.
  10. At this point you are finished, and the VHLK is ready to use.

Configuring Network Settings

On all systems, network discovery, and file sharing must be turned on. Occasionally, domain-joining a system will default these settings to off.

  1. Control Panel (icon view) -> Network and Sharing Center
  2. Go to "Change advanced sharing settings"
  3. On the current profile, set "Turn on network discovery", and "Turn on file and printer sharing"
  4. Verify these settings on the host system, virtual machine, and all desktop client systems. Verify these settings after any network change

When properly set up, the host system, virtual machine, and all client systems should be able to ping each other by both IP address and name.


VHLK - Domain Joining

This is a guide is to join the VHLK VM to a domain and add your domain username to the HLK datastores. Follow these steps after you have completed the setup guide. Joining the VHLK to a domain is completely optional, as the HLK will still work in a WORKGROUP configuration. However, joining to a domain gives the VM access to network resources.

Joining a Domain

To domain-join the VHLK, follow the following steps:

  1. Log in to your VHD as HLKAdminUser, password: Testpassword,1
  2. Open up "Settings" and navigate to "System"
  3. Go to "About" in the left navigation and click "Join a domain"
  4. In the prompt, enter the domain you would like to join
  5. Enter your domain username and password to authorize joining the VHLK to the domain (if your company IT allows. Otherwise, request IT to authorize adding the VM to the domain)
  6. Select "Administrator" in the drop-down menu
  7. Reboot the VHLK VM for the changes to take place.

Check Network Settings After Domain Joining

After joining a domain, policy changes can be applied to your network settings. Verify that network discovery, and file sharing are turned on.

  1. Control Panel (icon view) -> Network and Sharing Center
  2. Go to "Change advanced sharing settings"
  3. On the current profile, set "Turn on network discovery", and "Turn on file and printer sharing"

When properly set up, the host system, virtual machine, and all client systems should be able to ping each other by both IP address and name.

Add a Domain User to the HLK

This process requires that you have already followed the above steps for joining the VHD to the domain and rebooted the machine. Once domain-joined, log in as .\HLKAdminUser (password is "Testpassword,1"). You can use these steps to add your domain user to the HLK Manager to allow access to the HLK.

  1. Open HLK Manager
  2. Go to "Tools" in the top navigation and click "Management Console"
  3. Expand the datastore with the same name as the computer name and click "Users"
  4. Right-click on the "Users" or anywhere in the user list and click "New User..."
  5. Enter your "domain\username" in the top textbox and select "hlk_DSOwners"
  6. Now repeat steps 3-5 for the WTTIdentity datastore

Your domain user now has been successfully added to the HLK and you will have all the necessary permissions to access the HLK.


VHLK Connecting Desktop Clients

Before Starting

  • The desktop HLK Client is paired with the controller. For every new HLK Controller, HLK Client on your desktop client must be re-installed.
  • If the desktop client has previously had the HLK Client installed:
    • Uninstall Windows Hardware Lab Kit Client through "Add or Remove Programs"
    • Re-install from \\HLKInstall\Client\Setup.cmd.
  • Make sure network visibility and file & printer sharing is enabled, as described in the setup guide.
  • Make sure that your desktop device and the HLK Controller VM can ping each other by both IPV4 address and name.
  • Make sure that the HLK Controller computer name is resolved to an IPV4 address by your desktop device, and vice versa.

Start Testing

At this point, the VHLK and the traditional HLK can be treated as the same product and used in the same way. Follow the HLK Getting Started Guide from Step 2 onwards to connect your client devices and start testing.


HLK Proxy Client Getting Started Guide

The HLK Proxy Client enables full support for testing on Mobile devices and is the same client used internally by Microsoft for all at-scale phone testing.


HLK Proxy Client Prerequisites

WARNING

The Windows Hardware Lab Kit should only be installed on machines that are dedicated solely for testing purposes. Do not install any HLK component on a machine that is outside of a dedicated testing environment.

Before you begin testing, make sure that the test environment meets the necessary requirements.

  • A Battery Blank is required for Aries mobile testing in this release. For more information, see Battery Blank Information Guide.

  • Controller setup will fail if .NET Framework 4.5 has not previously been installed. Be sure to install .NET Framework 4.5 from the following location prior to controller setup. https://www.microsoft.com/net/download/framework

  • Proxy setup will fail if .NET Framework 4.6 has not previously been installed. .NET 4.6 is included with Windows 10 but must be installed separately on other versions of Windows. You can download .NET 4.6 from the following location: https://www.microsoft.com/net/download/framework

  • 32-bit SQL Server installations are not supported. You must uninstall any 32-bit SQL Server installation prior to installing the HLK.

  • SQL Server 2014 is not supported. You must uninstall any SQL Server 2014 installations prior to installing the HLK.

Testing Environment

The Windows HLK Mobile testing environment is comprised of three components: an HLK test server, an HLK Proxy system, and one or more test systems.

  • HLK test server. Often referred to as the controller, a test server has two parts: Windows HLK Controller and Windows HLK Studio. The Controller software is the engine that manages tests that are run on test systems. The Studio software is the management tool that lets you select and schedule tests against any test system connected to the test server. Controller and Studio are installed from the Windows HLK installation source. After installation, the test server contains separate installers to install a remote Windows HLK Studio, Window HLK Proxy Client and Windows HLK Client.

    One controller governs a collection of test systems through one or more Proxy systems. Controllers can manage and access only the clients that they govern.

  • HLK Proxy system. The Proxy system may be the same machine as the test server or a dedicated machine. The HLK Proxy client runs on the designated system and handles communication between the HLK Controller and the mobile test systems. Each Proxy system can be associated with only one test server. You can configure the HLK Proxy system by running the Windows HLK Proxy Client software installer directly from a shared network location on the test server.

  • Test system. Also referred to as a client, each test system can have a different configuration that's appropriate for various testing scenarios, including different hardware, operating systems, service packs, and drivers. Each test system can be associated with only one Proxy system. No configuration is required for mobile test systems.

Deployment scenarios

There are two deployment scenarios for Windows HLK:

  • Domain-joined environment. In a domain-joined environment, a domain controller is present and all computers designated for Windows HLK features are joined to the same domain controller. If you plan to deploy Windows HLK in a domain-joined environment, you need a minimum of three computers: a Windows domain controller, a Windows HLK test server, and at least one Windows HLK test system. Make sure that Microsoft Active Directory is configured and running on the domain controller. Your domain controller and HLK test server cannot be on the same box.

  • Workgroup environment. A workgroup environment has no domain controller. If you plan to deploy Windows HLK in a workgroup, you need at least two computers: a test server and a test system joined to the same workgroup. Don't use the Default Administrator account. In this configuration, you must enable the Guest account.

In addition, consider how you want to organize lab resources to best use the Windows HLK. You need to determine the number of test servers and the number of test systems connecting to them. These decisions are partly influenced by the type of devices or systems that you want to test.

Connection Types

Direct USB

The device is connected via a USB cable, with the cable serving as the physical layer for establishing a virtualized IP connection (i.e., IP over USB). This enables devices without an Ethernet connection to present themselves to the controller as an IP endpoint.

The Direct USB connection tethering method has known reliability and manageability issues that prevent it from being used in a large-scale lab environment. Flashing is supported over USB, but power cycling must be done manually. Furthermore, standard USB ports provide power in addition to a data connection, making simulating lower-power or battery-only testing impossible. Powered USB ports are also an issue for any tests with large power requirements as the test may drain the device's battery faster than it can be charged over USB.

Aries

Aries is a hardware connectivity component developed at Microsoft and provides the bridge between a single device and a host wishing to control the device. The device is an Ethernet-to-USB dongle that enables the at-scale mobile testing capabilities of the HLK. Mobile test systems are connected to the IP network via a 1:1 Ethernet-to-USB dongle, with the USB side connecting directly to the device target. Aries allows for independently addressable devices that can reside anywhere on the network, without a need to always be attached to the same USB port on the same HLK controller.

Small-Scale testing

Small-Scale test infrastructures are labs testing 1 or 2 mobile devices per controller. The limiting factor with this setup is the number of unique USB host controllers on the Test Server. Only one device should be connected per host controller for best results.

The following hardware is required per 2 devices under test on a single controller:

  • Test Server (Required)

Setup

Testing 1 or 2 devices can be achieved over USB directly. The limitation with this connection type is that power cycling is not available and accurate power testing cannot be done as USB ports are generally powered.

small scale testing diagram

Mid-Scale testing

Mid-Scale test infrastructures are labs testing 1 to 24 mobile devices per controller. The following hardware is required to support 24 devices under test on a single controller:

  • Test Server (Required)
  • Dedicated Proxy System (Optional)
  • Network Switch, 10/100 minimum (Optional)
  • 1 Aries dongle per device (Required)

Setup

Similar to the small-scale setup, the key difference in the mid-scale setup is that Aries is required for scale-out.

mid scale testing diagram

Large-Scale testing

Large-Scale test infrastructures are labs testing 1 to 150 mobile devices per controller. The following hardware is required to support 150 devices under test on a single controller:

  • Test Server (Required)
  • Dedicated Proxy Systems (Required)
  • Network Switches, 10/100 minimum (Required)
  • 1 Aries dongle per device (Required)

Setup

To manage the volume of devices in this scenario and handle the bandwidth, multiple subnets are highly recommended.

large scale testing diagram

System requirements

Test server

Component | Minimum | Optimum
Processor | Single Intel or AMD-based x64 platform with a speed of 2.0 GHz | Multicore or multiple x64-based processors running in x64 mode with a speed of 2.0 GHz or faster
System memory | 2 GB main memory | 4 GB main memory
Hard disk capacity | 300 GB minimum to accommodate the volume of logs that can be generated. | RAID configuration
Network connection | 100 megabits per second (Mbps) | 1 gigabit per second (Gbps)
Operating system

English language and English local version of Windows Server 2008 R2 64-bit with service pack (SP1), Windows Server 2012, or Windows Server 2012 R2. For information, see the Windows Server website.

Note

Controller isn't supported on Windows Server 2003, Windows Server 2008, Windows Vista, Windows XP, or Windows 2000.

Controller isn't supported on an installation that has already been set up as a domain controller.

Mobile test systems

Component | Minimum
Processor | The recommended processor for the operating system that you install.
System memory | Refer to the recommended processor for the operating system that you install.
Storage capacity | 4 GB flash storage minimum.
Operating system | Windows 10 or higher. The HLK supports Test images for general testing. Images must boot to flash mode by default.

Proxy system

Component | Minimum
Processor | The recommended processor for the operating system that you install.
System memory | Refer to the recommended processor for the operating system that you install.
Hard disk capacity | 300 GB minimum to accommodate the volume of logs that can be generated.
Operating system
  • Windows 8 Client
  • Windows 8.1 Client
  • Windows 10 Client
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows 7 Client
  • Windows Server 2008 R2

Optional remote/standalone Windows HLK Studio

Component | Minimum
Processor | The recommended processor for the operating system that you install.
System memory | Refer to the recommended processor for the operating system that you install.
Hard disk capacity

300 GB minimum to accommodate the volume of logs that can be generated.

The client must be unique; you can't swap drives.
Network connection | 100 Mbps
Operating system
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7


Battery Blank Information Guide

This guide provides information about the Battery Blank, including its purpose, along with a technical description. This information does not dictate design requirements and should not be used to establish such requirements. Because batteries differ greatly in form, design and function, it would be impractical for Microsoft to provide design requirements. Instead, this information guide should be used to assist in the process of determining how best to construct a battery blank.

  1. Why do I need a Battery Blank? Can't I just power my mobile device directly with an external power source?
    • A battery blank goes a step further than just direct power to a device by spoofing the elements of an actual battery which are often required by the device to power-on. This enables the device to be used for long-term testing in lab environments that may not normally be possible due to limited battery capacity. This is accomplished by allowing the mobile device to communicate normally with the battery even though current is being supplied by an external power source. In some very limited cases, you can get away with directly powering a mobile device from an external power source such as a 4.2vdc power supply. In most cases, however, the device may fail to operate correctly when it can't communicate with its own battery. The problems you may encounter include: Failure to power-on, failure to boot completely, premature or false low battery alarm, instant shut-down upon boot or many other types of behavior.
  2. How does a mobile device communicate with its own battery? What is a smart battery?
    • Most modern mobile devices communicate with the battery using a one-wire serial interface known as HDQ (see FAQ #5 for a description of the term HDQ). The on-board battery circuit monitors a voltage drop across a small current sense resistor connected in series with the battery output to determine charge and discharge activity of the battery. Compensations for battery age, temperature, self-discharge, and discharge rate are applied to the capacity measurements to provide available time-to-empty information across a wide range of operating conditions. Available battery capacity is automatically recalibrated, or learned, in the course of a discharge cycle from full to empty. These circuits communicate to the mobile device over an HDQ one-wire or I2C serial interface.
  3. Does a Battery Blank need to function EXACTLY like a battery? What are the actual requirements?
    • The Battery Blank is used only as a means to provide continuous external power to the device to enable long-term testing that would otherwise be impossible using the battery alone. It is not used as an instrument to test the operation or design of the actually battery. For the sake of simplicity, the battery blank should provide only what is normally required to power the phone in the same manner that the battery would. For example, if the device design requires communication with a battery-based HDQ or I2C circuit, then the battery blank should provide that capability. If the battery uses a known or expected resistance for ID, authentication or a thermistor (TH) circuit, the blank should provide that as well. Exactly how the required characteristics to mimic the battery are provided by the battery blank to the device are entirely up to the OEM.
  4. My battery uses an HDQ or I2C-based Fuel Gauge Circuit and my device requires this circuit to be present to boot-up. What is required to spoof this circuit so the battery blank can be used instead of the battery?
    • This is unknown to Microsoft since we didn't design the circuit. We expect the OEM hardware designers to understand these requirements since they have access to the schematics, design references and hardware specifications that would stipulate these requirements. We rely on these same designers to fabricate the battery blank and ensure it meets both the Chassis specifications and hardware requirements.
  5. What does the acronym HDQ mean when used in reference to batteries and fuel gauge circuits?
    • HDQ is a composite acronym used to describe the one-wire serial communications circuit between the battery and the mobile device. H in the acronym means High-speed, and DQ is a standardized electronics term that describes Data Input (D) and Data Output (Q) used with many different types of Flip-Flop circuits. Put together, you get High-speed Data Input / Data Output, or just HDQ for short.
  6. How difficult is it to make each type of Battery Blank? Are there any construction guidelines?
    • This depends on the complexity of the battery circuit used, and only the OEM or its assigned engineers have a complete understanding of the requirements necessary to mimic the original battery. As for the physical construction, there are many possible designs, most of which probably started out as an original battery that had the chemical cell removed leaving only the shell and the battery circuit board behind. In some designs where the battery doesn't provide I2C or HDQ 1-wire communications, construction may be as simple as routing external wires to the appropriate pads on the phone-side of the battery circuit board. In other cases, you may have to adjust the way your safety circuit operates or even remove it from the circuit. In still other cases, you may have to alter the software on the phone to accommodate the change to the battery. It really just depends on what the device expects to see from the battery to assume a genuine battery is being used instead of the battery blank. More on this specific point will be covered later in this document.
    • In most cases, removing the battery cell leaves behind a very flimsy and fragile battery frame. Once the wires are attached to the battery board and the required changes to the battery board electronics have been made (if any), we recommend that the blank we potted or filled with a stiff material that restores the rigidity to the plastic frame and makes the battery blank durable. Ideally, the wires would be potted as well, providing strain relief. Providing a battery blank without any strain relief on the wires is strongly discouraged. Batteries that have sheet metal cases are usually rigid enough but may cause other problems with the wires by exposing sharp edges that would cut into the wire insulation. Hot glue is a good option for holding wires and other required parts inside the frame (such as any needed capacitors). Keep in mind when designing your battery blank that it should be durable and able to handle multiple insertion and removal cycles without any damage to the blank. The blank should fit snug into the battery compartment, just like the original battery. It should never be so loose that it would fall out by itself, but it also shouldn't be too tight. The wires coming out of the battery blank should deflect out and away from the device. There should be no supplemental components protruding from the back of the battery blank that increase its thickness (like large electrolytic capacitors or other electronic components). If capacitors or other large components are required, please consider using surface-mount devices to keep the size down as much as possible. These specific points are covered in more detail later in this document.

Sample Battery Protection and Communication Circuits

sample battery protection and communication circuits

These battery circuits were removed from 11 different types of batteries. The cells to which they were once permanently attached have been removed and recycled and are not shown in this exhibit. The circuits showing the metal silver tabs on the left and right edges of the circuit board are where the battery cell connected. The other circuits showing 4 gold contacts are where the device would connect. The pin arrangement can vary greatly from battery-to-battery, but most include a minimum of 3 contacts to a maximum of 6 contacts. The pins usually provide +, -, HDQ, ID or TH, although this varies greatly from OEM to OEM. Some have fuel gauge chips and some don't. There is no magic done inside the actual battery cell that provides any kind of physical battery characteristics. This information is all fabricated, calculated, measured or guesstimated by the on-board electronics that are factory programmed (if needed) and permanently attached to factory-fresh batteries. These circuits are designed to see some amount of battery cell voltage 100% of the time for the entire life of the battery cell, even when the battery is technically discharged. Once removed from the battery, all of the information that has been recorded over the life of the attached battery cell can become invalidated or lost by the electronics.

As you can see, there are a wide variety of styles, shapes and circuitry available just inside the battery alone. As such, it would be impractical for Microsoft to dictate the specifics behind what exactly is needed by your device to make the battery blank function correctly, especially in cases where original battery electronics are recycled for use in battery blanks.

In many cases, these circuits also act to authenticate the attached device by communicating with it over the HDQ or I2C interface upon insertion into the device: If the device properly authenticates with the battery, the battery turns-on enabling full output power to the device, thus allowing it to power-up. Additionally, the fuel gauge circuit (if present) communicates with the mobile device over the HDQ (or I2C) one-wire serial interface to relay operational battery characteristics to the mobile device. Using this information, the battery electronics can provide a number of usage characteristics, including approximate battery life remaining, current power consumption, current voltage level, time-to-empty, number of charge cycles, etc. For mobile device batteries, a more common authentication method is to simply provide a fixed resistance from ground through an ID pin that is used by the phone to ensure a genuine battery is attached (as long as the resistance matches). This particular tactic goes both ways, as well - the battery can actually require a fixed resistance in the mobile device before turning on its primary output. Your battery blank should supply any of the needed parameters required to accurately simulate a real battery while allowing the device to be powered from an external power source.

WARNING

It is very important to remember that the circuits shown above were specifically designed to protect a physical battery cell. Once removed, the operational parameters of that battery cell may be lost or invalidated by the same circuit that communicates with the phone, and the operational information passed back to the phone may reflect that change and cause the device to behave differently. Likewise, the safety circuits normally expecting to see a constant voltage provided by the battery cell would now see voltage being switched on and off through the battery blank, and this could cause the safety circuits to fail or permanently trip which could in turn erroneously open the output of the battery blank during testing (we've seen this before). It may be prudent for you to consider bypassing any safety circuitry normally designed to protect a battery cell as these circuits will likely detect the on-and-off power cycles through the battery blank as problems with the battery. These unanticipated failures of the safety circuitry may not necessarily manifest themselves right away, either. The battery blank may appear to function normally from anywhere to 10 to hundreds of power cycles before they trip.

Designing a Battery Blank - An example

A large number of single-chip solutions that combine specially-designed battery protection electronics with the ability to trigger external FETs are currently available and are becoming more pervasive in the marketplace. The use of these electronics in battery blanks can occasionally cause more harm than good since they are being used outside of their designed intent and specifications and can therefore erroneously (and often unexpectedly) cause the output to open.

Since the OEM has the required confidential information (i.e., schematics and design specifications) needed to determine how best to bypass these safety circuits, we rely on them to provide any needed modifications to the battery blanks.

The following information is provided as a generalized example of how to construct a battery blank. It shows the evolution from what at first appears to be a good solution to what ultimately had to be changed to make the battery blank robust and reliable for use in the lab.

sample battery blank design

In the above picture, the OEM has elected to use the Dallas/Maxim DS2784, a popular single-cell, stand-alone fuel gauge IC. The fuel gauge provides accurate estimates of remaining capacity and reports timely voltage, temperature, and current-measurement data. Capacity estimates are calculated from a piecewise-linear model of the battery performance over load and temperature, and system parameters for full and empty conditions. The algorithm parameters are user programmable and can be modified in pack. Critical capacity and aging data are periodically saved to EEPROM in case of loss of power due to a short circuit or deep depletion.

That last bolded text is very important, since it indicates that this part is specifically designed to handle scenarios where the battery enters deep depletion, a characteristic somewhat matched by switching the power off to a battery blank. While comforting at first glance, the real-world application is far less obvious. The Typical Operating Circuit provided by the DS2784 Datasheet shows that the chip controls a dual-FET arrangement placed in series with POSITIVE lead to the device designed to interrupt the output as deemed appropriate by the DS2784:

typical operating circuit schematic

TYPICAL OPERATING CIRCUIT SCHEMATIC

The quick and easy way to make a Battery Blank in this case might first appear to be as simple as replacing the physical battery cell with the required Molex connector:

sample battery blank design

By simply replacing the battery cell with the Molex connector, you leave the FETs in series with the POSITIVE. The safety circuit is still intact and fully operational. Any error condition detected by the DS2784 could cause the FETs to trigger OPEN, even under normal operational test conditions. The DS2784 assumes a battery cell is connected, not an external power source, and proper operation of the DS2784 per its original design specification is no longer guaranteed. There are countless conditions that could cause a malfunction in this unnatural application of the DS2784, but ultimately the end result is that the Battery Blank stops working and power stops flowing to the mobile device.

There are a number of workarounds possible, but ultimately the designers of the battery and battery interface need to determine the best solution. In this particular example, the device explicitly requires the HDQ circuit to be connected to the phone. That means that simply bypassing the DS2784 entirely wouldn't work as it needs power itself to provide the required communications to the mobile device. That leaves several possible options:

  1. Disable the need for HDQ in the device through a software change and hardwire a bypass around the FET.
    • This option requires a software workaround coupled with a hardware change and is not ideal, especially if part of the device testing covers communications with the battery.
    • This is probably the least ideal option as it could lead to the discovery of non-real-world bugs and might also precipitate additional software problems in the device relating to charging or power management.
  2. Design your device to use HDQ if present but build-in an option to bypass this requirement if another operational parameter is met such as a fixed resistance to ground in place of HDQ.
    • This solution is very ideal but requires additional development and implementation during the hardware development cycle which may be too late at this point or simply not an option to begin with.
    • The idea here is that if a battery blank doesn't provide HDQ signaling because it has been removed from the blank that something else has been added (such as a fixed resistance) to trigger an HDQ requirement over-ride in the device allowing the device to operate normally as though the HDQ signal was present.
  3. Bypass only the FET so even if it does attempt to open, power will still flow to the P+ contact.
    • This option doesn't cover the changes or error conditions that the DS2784 might be reporting to the phone over the HDQ line which could still negatively impact operation of the device.
    • Unless the DS2784 is sending information over HDQ to the phone that impacts its operation, this is probably the best and easiest solution to implement.

Assuming Option #3 is ideal in this particular example, we only need to find a way to bypass the FET while leaving the DS2784 intact to do its thing. On some battery board designs where schematics and layout diagrams are not available, you may have to use a multi-meter to identify the direct wire to the P+ pad on the device-side of the battery board. In other cases, silk-screening may point you directly to the answer:

locating p+ pad via silk screening highlight

A P+ Test Pad is conveniently located on the component-side of the battery board. All that is required now is to bridge positive voltage being provided to B+ to this P+ Test Pad as well. This will provide voltage to the DS2784 allowing it to operate normally while also bypassing the FET if it should attempt to open.

The end result after modifying the battery board with a short around the FET:

battery blank after modifying board with short around the fet

Keep in mind that this was only an example using a popular Battery Management part. Every design is different, and the solution described above is only one possible example designed to make you think about the potential problems you may encounter in designing or building a battery blank. This represents one of the more complex examples seen in the field. For batteries that provide only a single-chip safety circuit that controls a FET, the solution is usually very simple: Just bypass the FET. No need to worry about sour grapes from the HDQ line because it doesn't exist. It is also important to note that the majority of safety interrupt circuits observed in the field actually interrupt the NEGATIVE lead, not the positive lead as used by the DS2784. The same bypass principles apply, however.

Building for Durability - Recommendation, Do's and Don'ts

As previously mentioned, once you peel away the labels and very carefully remove the chemical battery cell from a production battery, you're usually left with a flimsy, thin, open plastic frame. Not a picture of durability by any means, so in this section, we'll cover some recommendations that might guide you down a more rigid and durable path.

It is important to remember that you're building a battery blank for use in a lab environment. As such, it needs to be durable and able to resist excessive and often unreasonable working conditions. Although personnel are trained not to use the wires as a means to remove the battery blank, some people do so without thinking about it.

Potting

Although not listed as a specific requirement in the Chassis specification, your battery blank should closely approximate the designed durability of the production battery. There are a number of ways to do that. Most include potting (or filling) the entire empty cavity with epoxy, hot glue, silicon adhesive, rubber sheet or a plastic filler of some type. Whatever option you ultimately choose, try to build your blank in such a way that access to the actual battery board itself isn't permanently blocked. The reason for this request is that if you did have a problem with the design of your blank and it failed for some reason, it is nearly impossible to clear epoxy off the battery board without damaging the circuitry which would seriously inhibit any troubleshooting efforts. In this case, the OEM would be requested to provide fresh, working blanks to replace the ones that couldn't be repaired. Suggestions for this include adding a layer of Kapton tape between the battery board and the potting compound, or using a potting compound such as hot glue that can be cooled and fractured away from the battery board without damage to the components.

Some examples of Potting materials and compounds:

  • Air (i.e., no potting)

    • Advantages

      • None

    • Disadvantages

      • No strain relief for the wires connected to the battery board
      • Nothing to fill the flimsy plastic frame
      • Nothing to secure the battery board in place
      • Nothing to protect the interior electronics

  • Hot Glue

    • Advantages

      • Many different kinds available to cover most scenarios
      • Hot glue sticks are cheap
      • Easy to apply - heat and squirt, no mixing required
      • Usually easy to clean off unwanted residues
      • Doesn't chemically bond with anything else

    • Disadvantages

      • Can make a terrific mess if not carefully contained
      • Can easily and quickly burn the assembler
      • Can take anywhere from 2 minutes to 2 hours to solidify
      • Heat from the glue could soften and distort the thin, plastic frame

  • Epoxy

    • Advantages

      • Very dense material; extremely rigid when properly mixed and cured
      • Can be drilled or easily shaped as needed once cured
      • Comes in hand-mixable putties that work very well for this application and avoid some of the pitfalls associated with liquid-based, two-part epoxy mixes

    • Disadvantages

      • Can chemically bond to certain other materials making removal extremely difficult
      • Exothermic reaction when curing can release considerable heat that could soften and distort the thin, plastic frame
      • Two-part liquids usually fill every void possible as it thins considerably just before hardening
      • Take anywhere from 1 minute to 1 day to cure depending on the formula
      • Very tedious to remove if needed. Will usually damage the enclosure during the removal

  • Other Solid Filler Materials: Rubber, Plastic, Wood, Solid Cardboard

    • Advantages

      • Easily removable if needed
      • Generally holds shape well if cut precisely to fit case

    • Disadvantages

      • Can be tedious to cut depending on material
      • Can be hard to anchor wires to for strain relief purposes
      • Doesn't usually stick to the plastic frame and may require a tape wrap or other adhesive to hold the material in place inside the frame

Good and Bad Implementations

Some Battery Blanks require supplemental components such as capacitors to be placed within the battery frame. If needed (as determined by the OEM), these parts should fit entirely inside the battery cavity of the battery frame. Any protrusions other than the wires leading to the Molex connector could negatively impact overall device thickness and may hinder our ability to place the device into one of our automated testing instruments.

Here is an example of a poorly designed Battery Blank:

poorly designed battery blank poorly designed battery blank

The 2200uF capacitor shown above increased the thickness of the device by more than 13mm. In this case, laying the electrolytic capacitor on its side or using surface-mount tantalum capacitors instead of the style shown would have significantly reduced or even completely eliminated the extra thickness. Also note the lack of any reasonable strain relief on the wires. Even a small tug on a wire could pull it out of the hot glue or loosen it. We also discovered that the wiring hidden inside the sea of hot glue wasn't soldered together, it was only twisted creating a very unreliable electrical connection (see detail picture above right).

Here are examples of a well-designed Battery Blank:

On the right below note the secure connections to the cable and materials used ensuring a good fit to the device.

well designed battery blank well designed battery blank

On the left above, Note the uniform thickness throughout the battery. Sheet metal holds the frame together on top and bottom and keeps the entire assembly rigid. The area where the wires protrude is sealed with hot glue to provide solid strain relief and to keep the wires from being cut by the edge of the sheet metal. Electronically, the safety FET has been removed and replaced with solid wire. This is a solid, well-thought-out Battery Blank implementation that very closely mimics the original OEM battery.

Safety Considerations, General Guidelines and Warnings

There are 2 ways to create Battery Blanks:

  1. From Scratch: Microsoft strongly recommends that an OEM create their Battery Blanks from scratch to avoid the potential dangers and pitfalls associated with transforming actual device batteries into Battery Blanks. Doing so has been proven to generate safe, reliable Battery Blanks that are as durable and reliable as a production battery.
  2. Modifying Existing Batteries: Microsoft strongly recommends building the Battery Blank from scratch, however if the OEM does choose to transform existing batteries into battery blanks, please read the following section in its entirety.
NOTE

The information provided below is not inclusive of all of the potential dangers associated the disassembly of a sealed battery unit. Each battery design is different and will likely require a different disassembly method.

The general process is disassembly begins with careful removal of the labels on the battery. When removing the label(s), take care not to puncture or scratch the side of the battery cell with your tools.

Once the labels are removed, the cell is generally spot-welded to an in-line Polyfuse and then soldered (or spot welded) to the actual battery circuit board. When disconnecting the battery cell from the battery board, cut only 1 wire at a time and take extra measures to keep the wires from shorting together. Any short at this point could permanently damage the Battery Protection Circuitry that your device may require to function normally - you could easily Brick your Battery Blank.

Once the cells are removed from the battery frame, properly dispose of the cells. LiPol and Li-ION cells do NOT go in the regular trash and must be properly recycled. Most Office Supply Stores have battery recycling centers.

  • If at any time you witness a battery starting to balloon or swell up, discontinue the disassembly process immediately and verify that there are no shorts on the battery. Deal with this problem completely before continuing. Observe it in a safe place away from any combustible materials for at least 20 minutes.
  • When removing the wires (flat or round) from the battery cell, NEVER peel the spot-welded wires off the actual battery cell. Doing so may breach the wall of the cell causing the materials inside the cell to ignite.
  • Any battery cell that has been shorted or punctured may leak and spontaneously ignite. In the event of a puncture or breach, remove the battery for observation and place in a safe, open area away from any combustible material for approximately 20 minutes.
  • Batteries should remain at room temperature during the entire disassembly procedure. Cells that get warm or hot during removal usually indicate a short circuit which could ultimately cause an explosion and possible spontaneous ignition of the battery chemicals. **Always keep track of the exposed battery cells.**
  • Never store battery cells in areas with extreme temperatures and make sure they don't short-out to each other in the storage container.
  • Properly dispose of battery cells as soon as possible - do not collect them for several weeks.
  • Insulate the Positive plate of a battery cell with a durable material such as Kapton tape to prevent the cell from shorting out.
  • Never, under any circumstance, attempt to disassemble a sealed battery cell. It will ignite and start an uncontrollable, chemical fire as the Lithium metal reacts with oxygen and moisture in the air. Water will not extinguish a chemical fire of this type and will only cause a much more violent reaction. Have appropriate fire control equipment on hand and ready to use. Remember that metal fires (lithium batteries) require uncommon Class D fire extinguishers which are specifically designed to smother burning metal fires.


Step 1 Install the HLK Controller

WARNING

The Windows Hardware Lab Kit should only be installed on machines that are dedicated solely for testing purposes. Do not install any HLK component on a machine that is outside of a dedicated testing environment.

In this step, you install Windows HLK software on the designated test server. The setup program installs the Windows HLK Controller and Studio, in addition to other resources.

The test server should be preinstalled with Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, or Windows Server 2016.

If you are upgrading your HLK environment to a later version, you must first uninstall the previous version of the HCK or HLK software from the test server and any connected test clients.

To install Windows HLK, follow these steps:

  1. Download the HLK.

    If you are downloading directly onto your server, you must disable the IE Enhanced Security Configuration (IE ESC).

  2. When prompted, select Run.

    WARNING

    Don't select the Save option. The Save option only downloads the setup file and not the complete kit.

  3. When the Specify Location screen appears, choose the appropriate option:

    1. Install option - choose Install the Windows Hardware Lab Kit to this computer, and then choose Install .

    2. Download option - choose Download the Windows Hardware Lab Kit for installation on a separate computer, and then choose Next.

  4. Select the Windows Hardware Lab Kit -- Controller + Studio option.

    If you are installing directly, you must open a port on your server. Choose Yes, to allow the installation to open a port.

  5. When the Join the Customer Experience Improvement Program (CEIP) screen appears, choose Yes or No, and then choose Next. If your network isn't connected to the Internet, choose No.

  6. Review the License Agreement, and then choose Accept to proceed. If you selected the download option, copy your download to your test server. Run HLKSetup.exe and repeat the installation instructions from Step 3 for installing to this computer.

    Installation takes about 45 minutes.

    NOTE

    If Microsoft .NET Framework 4.5 isn't already installed on the computer, follow the prompts to install it. After the computer restarts, you must repeat the installation instructions from Step 1 for installing to this computer.


Step 2 Setup an HLK Proxy System

Before proceeding, be sure that the credentials of the user on the proxy system match those of an administrator on your HLK controller:

  • Local administrator account on proxy: <ProxyMachineName>\TestAdmin
  • Local administrator account on controller: <HLKControllerMachineName>\TestAdmin
  • Both with the same password

  1. On the Proxy system (which may be the same machine as the HLK Controller), run setup.exe from the following location:

    \\<ControllerName>\HLKInstall\ProxyClient\setup.exe

    (Replace <ControllerName> with the name of the test controller.)

  2. The WTT Proxy Setup wizard appears. Follow the instructions in the setup wizard to completion.

  3. Start the Proxy Service by double clicking on the WTT Proxy shortcut on the desktop of the proxy system or by navigating to %ProgramFiles(X86)%\WTTMobile\Client\ and running the following command from the elevated command prompt:

    WTTProxy.exe -console

  4. Leave the elevated command prompt window from the previous step open.


Step 3 Create a machine pool

A machine pool is a logical grouping of one or more test systems. Before you can work with a test system, you must move it to a working machine pool.

Every project needs a machine pool. A machine pool can be used for multiple projects. A project can reference multiple machine pools.

The following image shows the Studio Configuration page.

hlk studio configuration page

To create a machine pool

  1. In Windows HLK Studio, choose Configuration.

  2. Select an existing machine pool, and then choose Create Machine Pool. Alternatively, you can right-click on an existing machine pool, and choose Create Machine Pool.

    Change the default name, if desired, and then press Enter to finish.

    Machine Pools can be created at onboarding time for mobile devices.


Step 4 Onboard Mobile Test systems

After you install the Windows Hardware Lab Kit (Windows HLK) on the Controller system, and the Windows HLK Proxy Client on the Proxy system, you are ready to add mobile/IoT test systems to the environment.

Known Issues

Issue | Workaround
Device name reported in HLK as Windows Phone instead of the actual device name. | Reboot the device.

Onboarding USB connected devices

  1. On the Proxy system, launch an elevated command prompt window.
  2. Navigate to %ProgramFiles(x86)%\WTTMobile\Tools\

  3. Get the DeviceGUID for the connected device:

    1. Put the device in flashing mode.

    2. From the elevated command prompt, run the following command:

      ffutool.exe -list
      NOTE

      FFUTool.exe is included in the HLK at \\\HLKInstall\ProxyClient\FfuTool. Copy the entire contents of this directory to your proxy server.

      For more information on HLK mobile testing tools and utilities, see HLK Mobile Testing Tools and Utilities

      FFUTool.exe can be also installed with the ADK, by selecting the Imaging and Configuration Designer option during kit installation. For more information on the ADK, see Download the Windows ADK

  4. Run the following command from the elevated command prompt to put the device into mass storage mode:

    ffutool -MassStorage

  5. Unplug the device from the proxy system, then plug it back in. It will then be assigned a drive letter on the Proxy system. Use this as the <device drive> in the next step.

  6. Enable USB EEM protocol on boot options. From an elevated command prompt, run the following command:

    BCDEdit /store <device drive>:\EFIESP\efi\Microsoft\Boot\BCD /set {default} loadoptions "EEM"

    Example:

    BCDEdit /store G:\EFIESP\efi\Microsoft\Boot\BCD /set {default} loadoptions "EEM"

  7. Restart the device (if the image installed on the DUT is a lab or a health image, put the device in flashing mode).

  8. To onboard the device, from the elevated command prompt, run the following command:

    KitsDeviceDetector.exe /Physical:Fake_PC.dll /DeviceName:<DeviceName> /DeviceId:<DeviceGUID> /machinepool:<machine pool>

    Example:

    KitsDeviceDetector.exe /Physical:Fake_PC.dll /DeviceName:mydevice /DeviceId:00000015-c0fb-79c3-0000-000000000000 /machinepool:$\mypool

    • If testing with a Health image, include the following parameter: /imageprofile:health

    • If the image installed on the DUT is not a lab or a health image, include the following parameter: /SkipFFUCheck

    • The KitsDeviceDetector log can found at %ProgramFiles(x86)%\WTTMobile\Tools\KitsDeviceDetector.log

  9. Restart the proxy service in elevated mode.

    1. In the Proxy Service command prompt window, press CTRL + C to stop the service.

    2. Restart the Proxy Service double clicking on the "WTT Proxy" shortcut on the desktop of the Proxy System, or by navigating to %ProgramFiles(X86)%\WTTMobile\Client\ and running the following command from the elevated command prompt:

      WTTProxy.exe -console

  10. Validation: After running device detector (steps above), the device should be booted to a valid OS, and be a visible target that shows as Ready in HLK Manager and HLK Studio.

Onboarding Aries connected devices

  1. On the Proxy system, launch an elevated command prompt.
  2. Navigate to %ProgramFiles(x86)%\WTTMobile\Tools\

  3. To onboard the device, run the following command from the elevated command prompt:

    KitsDeviceDetector.exe /devicefilters:<aries name> /machinepool:<machine pool>

    Example:

    KitsDeviceDetector.exe /devicefilters:myaries /machinepool:$\mypool

    • The image on the device must be either a lab image or a health image.

    • If testing with a Health image, include the following parameter: /imageprofile:health

    • To flash an image on your device as part of the onboarding process, include the following parameter /ImagePath:<full path to the flash_lab.ffu image>

    Example:

    /ImagePath:C:\flash_lab.ffu

    • To find the name of the Aries dongles on the network, use %ProgramFiles(x86)%\WTTMobile\Tools\AriesUtil.exe . The command AriesUtil.exe Discover will return the full list of available devices. A firewall exception must be added for AriesUtil.exe prior to use. If no devices are detected, you may need to use the /Adapter parameter. The adapter type can be determined by opening the Networking and Sharing Center on the controller, the Adapter is listed under Connections. The most common Adapter value is Ethernet. Use the command AriesUtil.exe /? for a complete list of available commands.

    • The KitsDeviceDetector log can found at %ProgramFiles(x86)> %\WTTMobile\Tools\KitsDeviceDetector.log

    For more information on HLK mobile testing tools and utilities, see HLK Mobile Testing Tools and Utilities

  4. Restart the proxy service in elevated mode.

    1. In the Proxy Service command prompt window, press CTRL + C to stop the service.

    2. Restart the Proxy Service double clicking on the "WTT Proxy" shortcut on the desktop of the Proxy System, or by navigating to %ProgramFiles(X86)%\WTTMobile\Client\ and running the following command from the elevated command prompt:

      WTTProxy.exe -console

  5. [For Health image only] - After KitsDeviceDetector is complete, run the following commands from %ProgramFiles(x86)%\WTTMobile\Tools\

    AriesUtil.exe ResetDevice /Aries:<aries-name> [/Autoskip:true]

  6. Validation: After running device detector (steps above), the device should be booted to a valid OS, and be a visible target that shows as Ready in HLK Manager and HLK Studio.

Onboarding Ethernet connected devices

  1. On the Proxy system, launch an elevated command prompt.
  2. Navigate to %ProgramFiles(x86)%\WTTMobile\Tools\

  3. Get the connection string for your device:

    1. Boot the device and find the IP address.

    2. From the elevated command prompt, run the following command:

      KitsDeviceDetector.exe /rundevicediscovery

      This command will output all of the devices on the subnet that has Sirep running. Each string will look something like this:

      Name: 8CAE4CF5D6A5 | UniqueId: 00000000-0000-0000-0000-8cae4cf5d6a5 | Address: 10.131.2.211 | Connection: SirepBroadcast1 | Location:

  4. Find your device string (matching your IP address, and make note of the following fields:

    1. "Name:"
    2. "UniqueId:"

  5. To onboard the device, run the command from the elevated command prompt:

    KitsDeviceDetector.exe /machinepool:$\Pool /Physical:Fake_PC.dll /DeviceName:NAME_OF_DEVICE /DeviceId:<DeviceGUID> /SkipFFUCheck

    Example:

    KitsDeviceDetector.exe /machinepool:$\Test_Pool /Physical:Fake_PC.dll /DeviceName:8CAE4CF5D6A5 /DeviceId:00000000-0000-0000-0000-8CAE4CF5D6A5 /SkipFFUCheck

  6. Restart the proxy service in elevated mode.

    1. In the Proxy Service command prompt window, press CTRL + C to stop the service.

    2. Restart the Proxy Service double clicking on the "WTT Proxy" shortcut on the desktop of the Proxy System, or by navigating to %ProgramFiles(X86)%\WTTMobile\Client\ and running the following command from the elevated command prompt:

      WTTProxy.exe -console

  7. Validation: After running device detector (steps above), the device should be booted to a valid OS, and be a visible target that shows as Ready in HLK Manager and HLK Studio.


Step 5 Create a project

After you setup your test server and clients, you're ready to create a project. A project defines what you want to test. The most common project corresponds to the device you want to submit for certification.

You can create large projects that represent a wide range of scenarios. You can also create several smaller projects and merge the results into one package.

In the remaining examples, you create a project for a device and run all associated certification tests. Then, you create a single package for submission that contains all of the passing test results.

The following image shows the Studio Project tab.

hlk studio project tab

To create a project

  1. In Windows HLK Studio, choose the Project tab, and then choose Create project.

  2. Replace the default project name with the name of your project, and then press Enter.

    A project should have a meaningful name that indicates its contents, for example, "Fabrikam Multi-function Device Model Z".

    When the project name appears on the page, the project is created.

The right pane displays project details. More information is displayed here once you start testing your device. You can check the status of any project by loading it and referring to this pane.

To learn more about this page, see HLK Studio - Project Tab.


Step 6 Select target to test

Windows HLK Studio detects all features that a device implements. An individually testable feature is called a target. A device may contain multiple targets, represented by one or more hardware IDs. On the Selection tab, you can filter what you want to test by using the following views:

  • systems - used to test a complete client or server system.

  • devices and printers - used to test an external device that's connected to a test system. This device typically appears in Start > Devices and Printers on the test system.

  • device manager - used to test a component of a test system or external device, for example, a network card. This is the most detailed view.

  • software device - used to test filter drivers, firewalls, and antivirus software installed on the test system.

    NOTE

    Some software drivers are associated with a physical device. If you cannot find your driver listed in the software device view, use the search bar in the device manager view to find the device under which your software driver is associated.

The following image shows the Studio Selection tab.

hlk studio selection tab

Select a target to test

  1. In Windows HLK Studio, choose the Selection tab. In the machine pool dropdown, choose the pool that contains the devices that you want to test.

  2. In the left pane, select the view based on the device you want to test: systems, device and printers, device manager, or software device.

    A list of available targets is displayed in the center pane. If you select the device manager view, you can choose to show inbox and hidden features.

  3. In the center pane, check the box next to each target that you want to test.

    You must select all of the features of a specific product type for a device to receive certification.

    If you're testing a Web Services on Devices (WSD) device, there may be a delay before the required WSD targets are listed.

The show selected view in the left pane displays the targets that you've selected across all views. This view allows you to see just the areas you're testing. You also can filter a machine pool by category by using the category list. You can search for specific targets and features by using the search box.

To learn more about the different options on this page see HLK Studio - Selection Tab.


Step 7 Select and run tests

The Tests tab displays all of the tests that are associated with the features found on your device. In the HLK, test categories replace the level classifications previously used with the HCK. The HLK can be used throughout the product life cycle to test and measure quality at each stage of development. You can filter and sort the listed tests in the following ways:

  • Test Phase Categorization

    • Bring Up
    • Development and Integration
    • Reliability
    • Tuning and Validation
    • Manufacturing
    • Support

  • Status

  • Test Name
  • Type (manual, non-distributed, special configuration, multiple machine)
  • Length
  • Target
  • Machine(s)
NOTE
  • You can hover over the test type icons with your mouse for more information about the test types.
  • Manual tests that require user input can interrupt the test process. We recommend that you run manual tests separately from automated tests.
  • Some tests require additional input before running. Windows HLK Studio prompts you for more info as needed.

The following image shows the Studio Tests tab.

hlk studio tests tab

Playlists

Playlists are collections of tests that you can use to define various scenarios in which to test your device. The Windows Hardware Compatibility Program uses an official playlist to determine which devices meet the requirements for compatibility with Windows 10.

Video link

You can load a playlist by choosing Load Playlist from within the Tests tab. You can load only one playlist at a time. To choose a different playlist, you must first unload the current playlist by choosing Unload Playlist from the Tests tab.

The following image shows the Load Playlist File dialog.

load playlist dialog

Once a playlist is loaded, only tests that are applicable to each target are shown in the UI.

Test results against all playlists for a specific target are kept until the target is removed from the project. When a playlist is loaded, any previous test results against that playlist are also loaded.

You can save an existing collection of tests as a playlist by choosing Save Selected As Playlist.

Running a test

If using a playlist, be sure to load it before proceeding.

If you want to re-flash the device before running the test, set the ForceReflash_KitsTemplate parameter in HLK Studio to 1 and specifying the location of the ffu to flash to the device using the ImagePath_KitsTemplate parameter.

  1. Filter the test results by using the View By dropdown list.

  2. Check the box next to each test that you want to run.

  3. Run the selected tests by choosing Run Selected.

    If any additional input is needed, Windows HLK Studio will prompt you.

    A progress bar appears. A slight delay occurs when you run a test.

NOTE

To learn more about any test, select the test from the list and press F1 key or right-click and select Test Description. To cancel any running test, right-click it and select Cancel.

As tests complete, the results are displayed in the Status column. A green checkmark means that it passed, while a red X means that it failed. The pane on the right displays project summary information, including target(s) selected, operating systems being tested, product types you qualify for, and status of all tests.

To learn more about the different options on this page, see HLK Studio - Tests Tab.


Step 8 View test results and log files

The Results tab displays detailed information about each test. As each test completes, the status column updates with the result--pass or fail.

The following image shows the Studio Results tab.

hlk studio results tab

To troubleshoot a failed test

If a test fails, you can expand the test details to review the associated log file.

  1. From the list, select a failed test, indicated by a red X.

  2. Expand the Test Name node, expand the Logs node, and then double-click the log file.

    You can review these log files:

    • .log file. Text dump.

    • .wtl file. Open to view error reports.

    • .xml file. Change file name extension to .wtl to view error reports.

Right-click any test to see additional test details, including:

  • Task logs

  • Additional files

  • Applied filters

  • Errors

  • Infrastructure (gather and execution logs)

To learn more about the different options on this page including distributed and multi-device support, see HLK Studio - Results Tab.


HLK ARM64 Getting Started Guide

Setup and testing for ARM64 desktop machines largely follows the guidelines found in the HLK Getting Started Guide. Instructions specific to ARM64 are described in this topic.

This topic provides a basic introduction to using the Windows Hardware Lab Kit (HLK). Once you are familiar with the tools and process, you can review the HLK User's Guide for additional information.

Windows HLK Prerequisites

Prerequisites are the same for all desktop machines. See the HLK Prerequisites topic for more information.

Step 1: Install Controller and Studio on the test server

Test server setup is the same for all desktop testing. See Step 1: Install Controller and Studio on the test server for more information.

Step 2: Install Client on the test system(s)

After you install the HLK on the test server, you are ready to add test systems to the environment. You must install the HLK Client software on each test system. The HLK Client software is stored on the Windows HLK test server.

Testing for ARM64 Desktop requires the client systems to be set up differently than testing for x86/x64. ARM64 Desktop testing uses a different setup path. Also, a complete submission package requires testing to be done in two modes -- native ARM64 and x86 on ARM64. Testing can be done with multiple machines or a single machine, but using a single machine requires the HLK client to be uninstalled and reinstalled using the directions below to change the modes.

Depending on the scenario, it may be required that testing be done in native ARM64 mode, x86 on ARM64, or a combination of the two. The scenarios below will outline which mode(s) are required for testing.

Testing can be done with multiple machines or a single machine, but using a single machine requires the HLK client to be uninstalled and reinstalled using the directions below to change the modes.

Scenarios

Scenario | Mode
Audio Device | Native
Wireless Lan | Native and x86 on ARM64 mode
System | Native and x86 on ARM64 mode
NOTE

The mode required may change with new releases of the kit.

Once the mode for testing is identified the following instructions will walk you through client setup.

WARNING

If you are testing software, be sure to install the product on the test system first, and then install the HLK Client software.

NOTE

It is recommended that the client system is on A/C (plugged in) and that the Power Options are set to Never for Put the computer to sleep settings.

To install the Windows HLK Client

  1. Run client setup

    For x86/x64 client systems, on the test system, run the following:

    \\<ControllerName>\HLKInstall\Client\Setup.cmd

    For ARM64 Desktop client systems, there are two different install paths depending on the mode the client is being set up to test in.

    NOTE

    Because of the dual-mode nature of ARM64, a best practice is to use two (2) clients, one in native mode and one in emulated mode per the instructions below.

    Native Mode:

    On the test system, run the following:

    \\<controllername>\HLKInstall\CoreSystemClient\InstallWTTClient

    x86 on ARM64 Mode:

    On the test system, start a command prompt with administrator privileges, and run the following:

    \\<controllername>\HLKInstall\CoreSystemClient\InstallWTTClient UseEmulationForTestContent

    (Replace <ControllerName> with the name of the test server.)

  2. The Windows Hardware Lab Kit Client Setup wizard appears. To start the wizard, choose Next.

  3. On the Internet Connection Firewall Agreement page, select Yes I will allow a port to be opened, and then choose Next.

    NOTE

    If the Internet Connection Firewall Agreement page doesn't appear, either Windows Firewall isn't installed, or another software firewall or hardware firewall is installed on the computer. If another firewall is installed, you must manually open TCP port 1771 to proceed with installation. Refer to the instructions that came with your firewall product to manually open a TCP port. If you continue without opening port 1771, the installation may fail or the Client software might not function properly.

  4. When the Ready to Install page appears, select Install.

  5. Click Finish to exit the wizard.

    TIP

    When installation completes, confirm its success by going to the Control Panel and choosing Uninstall a program. Windows Hardware Lab Kit Client should appear in the program list.

  6. Repeat steps 1-5 for each test system.

Step 3: Create a machine pool

Machine pool creation is the same for all desktop testing. See Step 3: Create a machine pool for more information.

Step 4: Create a project

x86/x64 instructions: Step 4: Create a project

After you setup your test server and clients, you're ready to create a project. A project defines what you want to test. The most common project corresponds to the device you want to submit for certification.

You can create large projects that represent a wide range of scenarios. You can also create several smaller projects and merge the results into one package.

NOTE

For ARM64 Desktop testing, multiple projects are required to form a complete submission package (one for each mode). When testing is complete for each mode, create hlkx packages and then merge the packages together to make a single package for submission.

In the remaining examples, you create a project for a device and run all associated certification tests. Then, you create a single package for submission that contains all of the passing test results.

The following image shows the Studio Project tab.

Creating a project

  1. In Windows HLK Studio, choose the Project tab, and then choose Create project.
  2. Replace the default project name with the name of your project, and then press Enter. >[!NOTE]
    > A project should have a meaningful name that indicates its contents, for example, Fabrikam Multi-function Device Model Z.

When the project name appears on the page, the project is created.

The right pane displays project details. More information is displayed here once you start testing your device. You can check the status of any project by loading it and referring to this pane.

Step 5: Select target to test

Selecting targets is the same for all desktop testing. See Step 5: Select target to test for more information.

Step 6: Select and run tests

The Tests tab displays all of the tests that are associated with the features found on your device. In the HLK, test categories replace the level classifications previously used with the HCK. The HLK can be used throughout the product life cycle to test and measure quality at each stage of development. You can filter and sort the listed tests in the following ways:

  • Test Phase Categorization
    • Bring Up
    • Development and Integration
    • Reliability
    • Tuning and Validation
    • Manufacturing
    • Support
  • Status
  • Test Name
  • Type (manual, non-distributed, special configuration, multiple machine)
  • Length
  • Target
  • Machine(s)
NOTE
  • You can hover over the test type icons with your mouse for more information about the test types.
  • Manual tests that require user input can interrupt the test process. We recommend that you run manual tests separately from automated tests.
  • Some tests require additional input before running. Windows HLK Studio prompts you for more info as needed.

The following image shows the Studio Tests tab.

Playlists

Playlists are collections of tests that you can use to define various scenarios in which to test your device. The Windows Hardware Compatibility Program uses an official playlist to determine which devices meet the requirements for compatibility with Windows 10.

You can load a playlist by choosing Load Playlist from within the Tests tab. You can load only one playlist at a time. To choose a different playlist, you must first unload the current playlist by choosing Unload Playlist from the Tests tab.

The following image shows the Load Playlist File dialog.

Once a playlist is loaded, only tests that are applicable to each target are shown in the UI.

Test results against all playlists for a specific target are kept until the target is removed from the project. When a playlist is loaded, any previous test results against that playlist are also loaded.

You can save an existing collection of tests as a playlist by choosing Save Selected as Playlist.

IMPORTANT

When using an official playlist, you must use the version of the playlist that matches the version of the kit you are using. For example, if using version 1607 of the HLK, you must also use version 1607 of the playlist.

NOTE

ARM64 Desktop testing: There are two playlists, one for tests that run in Native mode and one for tests that run in x86 on ARM64 mode. Ensure that the appropriate playlist is being applied to the project that has the HLK client installation which matches the mode intended for testing.

Running a test

If using a playlist, be sure to load it before proceeding.

  1. Filter the test results by using the View By dropdown list.
  2. Check the box next to each test that you want to run.
  3. Run the selected tests by choosing Run Selected.

If any additional input is needed, Windows HLK Studio will prompt you.

A progress bar appears. A slight delay occurs when you run a test.

NOTE

To learn more about any test, select the test from the list, and press F1 key, or right-click, and select Test Description. To cancel any running test, right-click it and select Cancel.

As tests complete, the results are displayed in the Status column. A green checkmark means that it passed, while a red X means that it failed. The pane on the right displays project summary information, including target(s) selected, operating systems being tested, product types you qualify for, and status of all tests.

To learn more about the different options on this page, see HLK Studio - Tests Tab.

Step 7: View test results and log files

x86/x64 instructions: Step 7: View test results and log files

NOTE

Due to ARM64 Desktop having scenarios that involve multiple projects, it will be required that these projects be merged to have a complete HLK package for submission. For information on merging packages, see Merge packages.

Step 8: Create a submission package

Once any merging is complete, submitting packages is the same for all desktop machines. See Step 8: Create a submission package topic for more information.


Windows Hardware Lab Kit User's Guide

The Windows Hardware Lab Kit (Windows HLK) is a test framework used to test hardware devices for Windows 10. To qualify for the Windows Hardware Compatibility Program, your product must pass certain tests using the Windows HLK.

This guide provides information about the tests that are included in the Windows Hardware Lab Kit, and instructions on how to build a test environment, automate driver and system testing, and create a submission package required to participate in the Windows Hardware Compatibility Program.


HLK Product Type Matrix

The Windows 10 HLK Product Type Matrix lists all of the product types that can be included in the Windows Hardware Compatibility Program. Each product type defines features and requirements that must be met for program eligibility.

NOTE

Some of the product types from the HCK for Windows 8/8.1 have been deprecated and must be submitted as Other Devices on Sysdev. The deprecated product types are included to enable you to obtain a unified signed driver by merging HCK and HLK packages together.

Please reference the matrix below prior to merging HCK and HLK packages.

Category | Active/Deprecated | Product Type | Required Features
Device | Deprecated | 3D Printer | Device.Imaging.3DPrinter.Base
Device | Deprecated | Accelerometer Sensor | Device.Input.Sensor.Accelerometer Device.Input.Sensor.Base
System | Active | All In One | System.Client.Graphics System.Client.PCContainer System.Client.SystemConfiguration System.Client.SystemPartition System.Fundamentals.DebugPort System.Fundamentals.Firmware System.Fundamentals.Graphics System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.PowerManagement System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
Device | Active | Audio Device | Device.Audio.Base
Device | Active | Audio Processing Objects | Device.Audio.APO
Device | Active | Bluetooth Controller | Device.BusController.Bluetooth.Base
Device | Active | Bluetooth Controller Non USB | Device.BusController.Bluetooth.Base Device.BusController.Bluetooth.NonUSB
Device | Deprecated | Controller | Device.Audio.AudioController
System | Active | Convertible Tablet | System.Client.Digitizer.Touch System.Client.Graphics System.Client.PCContainer System.Client.SystemPartition System.Client.Tablet.Graphics System.Fundamentals.DebugPort System.Fundamentals.Firmware System.Fundamentals.Graphics System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.Input System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
System | Active | Desktop | System.Client.Graphics System.Client.PCContainer System.Client.SystemConfiguration System.Fundamentals.DebugPort System.Fundamentals.Firmware System.Fundamentals.Graphics System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
Device | Deprecated | Digital Media Renderer | Device.Media.DMR.Audio Device.Media.DMR.AV Device.Media.DMR.Base Device.Media.DMR.Image
Device | Active | Digital Still Cameras | Device.Portable.Core Device.Portable.DigitalCamera
Device | Active | Digital Video Cameras | Device.Portable.Core Device.Portable.DigitalVideoCamera
Device | Active | Enterprise WSD Multi-Function Printer | Device.Imaging.Printer.Base Device.Imaging.Printer.WSD Device.Imaging.Scanner.Base
Filter | Active | File System | Filter.Driver.FileSystem
Filter | Active | File System Anti Virus | Filter.Driver.AntiVirus
Device | Active | Finger Print Reader | Device.Input.FingerPrintReader
Device | Deprecated | Game Controller | Device.Input.GameController.CommonController
Device | Deprecated | Generic Controller | Device.Input.GameController.GenericController
Device | Active | Generic Portable Device | Device.Portable.Core
Device | Active | Graphics Adapter WDDM1.0 | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM.DisplayRender Device.Graphics.WDDM.Render
Device | Active | Graphics Adapter WDDM1.1 | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM.DisplayRender Device.Graphics.WDDM.Render Device.Graphics.WDDM11 Device.Graphics.WDDM11.Display Device.Graphics.WDDM11.DisplayRender Device.Graphics.WDDM11.Render
Device | Active | Graphics Adapter WDDM1.2 | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM.DisplayRender Device.Graphics.WDDM.Render Device.Graphics.WDDM11 Device.Graphics.WDDM11.Display Device.Graphics.WDDM11.DisplayRender Device.Graphics.WDDM11.Render Device.Graphics.WDDM12 Device.Graphics.WDDM12.Display Device.Graphics.WDDM12.DisplayRender Device.Graphics.WDDM12.Render
Device | Active | Graphics Adapter WDDM1.2 DisplayOnly | Device.Graphics.AdapterBase Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM11 Device.Graphics.WDDM11.Display Device.Graphics.WDDM12 Device.Graphics.WDDM12.Display Device.Graphics.WDDM12.DisplayOnly
Device | Active | Graphics Adapter WDDM1.2 RenderOnly | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Render Device.Graphics.WDDM11 Device.Graphics.WDDM11.Render Device.Graphics.WDDM12 Device.Graphics.WDDM12.Render Device.Graphics.WDDM12.RenderOnly
Device | Active | Graphics Adapter WDDM1.3 | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM.DisplayRender Device.Graphics.WDDM.Render Device.Graphics.WDDM11 Device.Graphics.WDDM11.Display Device.Graphics.WDDM11.DisplayRender Device.Graphics.WDDM11.Render Device.Graphics.WDDM12 Device.Graphics.WDDM12.Display Device.Graphics.WDDM12.DisplayRender Device.Graphics.WDDM12.Render Device.Graphics.WDDM13 Device.Graphics.WDDM13.DisplayRender Device.Graphics.WDDM13.Render
Device | Active | Graphics Adapter WDDM1.3 DisplayOnly | Device.Graphics.AdapterBase Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM11 Device.Graphics.WDDM11.Display Device.Graphics.WDDM12 Device.Graphics.WDDM12.Display Device.Graphics.WDDM12.DisplayOnly Device.Graphics.WDDM13
Device | Active | Graphics Adapter WDDM1.3 RenderOnly | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Render Device.Graphics.WDDM11 Device.Graphics.WDDM11.Render Device.Graphics.WDDM12 Device.Graphics.WDDM12.Render Device.Graphics.WDDM12.RenderOnly Device.Graphics.WDDM13
Device | Active | Graphics Tablet | Device.Input.Digitizer.Pen
Device | Deprecated | Gyroscope Sensor | Device.Input.Sensor.Base Device.Input.Sensor.Gyroscope
Device | Active | Hard Drive | Device.Storage.Hd
Device | Active | Hardware Multifunction Transforms | Device.Streaming.HMFT
Device | Active | Keyboard | Device.Input.Keyboard
Device | Active | Keyboard Video Mouse Switch | Device.Input.Keyboard Device.Input.PointDraw
Device | Active | LAN | Device.Network.DevFund Device.Network.LAN.Base Device.Network.LAN.PM
Device | Active | LAN (Server) | Device.Network.DevFund Device.Network.LAN.Base Device.Network.LAN.ChecksumOffload Device.Network.LAN.LargeSendOffload Device.Network.LAN.RSS
Device | Active | LAN CS | Device.Network.DevFund Device.Network.LAN.Base Device.Network.LAN.CS
Device | Active | LAN Virtual Machine (Server) | Device.Network.DevFund Device.Network.LAN.Base Device.Network.LAN.ChecksumOffload Device.Network.LAN.LargeSendOffload Device.Network.LAN.RSS Device.Network.LAN.SRIOV Device.Network.LAN.SRIOV.VF Device.Network.LAN.VMQ
System | Active | Laptop | System.Client.Graphics System.Client.PCContainer System.Client.SystemConfiguration System.Client.SystemImage System.Client.SystemPartition System.Fundamentals.DebugPort System.Fundamentals.Firmware System.Fundamentals.Graphics System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.Input System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
System | Active | Laptop with Touch | System.Client.Digitizer.Touch System.Client.Graphics System.Client.PCContainer System.Client.SystemConfiguration System.Client.SystemImage System.Client.SystemPartition System.Fundamentals.DebugPort System.Fundamentals.Firmware System.Fundamentals.Graphics System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.Input System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
Device | Active | LCD | Device.Display.Monitor
Device | Deprecated | Light Sensor | Device.Input.Sensor.ALS Device.Input.Sensor.Base
Device | Deprecated | Location Sensor | Device.Input.Sensor.Base Device.Input.Sensor.Location
Device | Active | Media Player | Device.Portable.Core Device.Portable.MediaPlayer
Device | Active | Mobile Broadband CDMA | Device.Network.DevFund Device.Network.MobileBroadband.CDMA
Device | Active | Mobile Broadband GSM | Device.Network.DevFund Device.Network.MobileBroadband.GSM
Device | Active | Mobile Phone | Device.Portable.Core Device.Portable.MobilePhone
Device | Active | Monitor | Device.Display.Monitor
System | Active | Motherboard | System.Client.PCContainer System.Fundamentals.DebugPort
Device | Deprecated | Motion Sensor Fusion | Device.Input.Sensor.Accelerometer Device.Input.Sensor.Compass Device.Input.Sensor.DeviceOrientation
Device | Active | Multi-Function Printer | Device.Imaging.Printer.Base Device.Imaging.Scanner.Base
Device | Active | Near Field Proximity | Device.BusController.NFC
Device | Deprecated | Network Media Device DMR Audio | Device.Media.DMR.Audio Device.Media.DMR.Base
Device | Deprecated | Network Media Device DMR AV | Device.Media.DMR.Audio Device.Media.DMR.AV Device.Media.DMR.Base Device.Media.DMR.Image
Device | Active | Optical Drive | Device.Storage.Optical
Device | Deprecated | Orientation Sensor | Device.Input.Sensor.Base Device.Input.Sensor.DeviceOrientation
Device | Active | Pen Digitizer | Device.Input.Digitizer.Pen
Device | Active | Pointing Drawing | Device.Input.PointDraw
Device | Active | Precision Touchpad | Device.Input.Digitizer.PrecisionTouchpad
Device | Deprecated | Presence Sensor | Device.Input.Sensor.Base Device.Input.Sensor.Presence
Device | Active | Printer | Device.Imaging.Printer.Base
Device | Active | Projector | Device.Display.Monitor
Device | Active | Removable Storage | Device.Storage.Hd.RemovableMedia
Device | Deprecated | Router | Device.Connectivity.Network.VerticalPairing Device.Network.Router
Device | Active | Scanner | Device.Imaging.Scanner.Base
Device | Deprecated | SDIO Controller | Device.BusController.SdioController
System | Active | Server | System.Client.PCContainer System.Fundamentals.DebugPort System.Fundamentals.Security System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS System.Server.Base System.Server.SMBIOS System.Server.SystemStress System.Server.Virtualization
System | Active | Server Virtualization Validation Program | System.Client.PCContainer System.Fundamentals.DebugPort System.Fundamentals.Security System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS System.Server.Base System.Server.SMBIOS System.Server.SystemStress System.Server.Virtualization
Device | Active | Signature Tablet | Device.Input.PointDraw
Device | Active | Smart Cards | Device.Input.SmartCardMiniDriver Device.Input.SmartCardReader
Device | Active | Smartcard Reader | Device.Input.SmartCardReader
Device | Deprecated | Specialized PC | System.Client.SpecializedPC
Device | Active | Storage Array | Device.Storage.Hd Device.Storage.Hd.RaidArray
Device | Active | Storage Controller | Device.Storage.Controller
Device | Active | Storage Spaces Adapter | Device.Storage.Controller Device.Storage.Controller.Flush Device.Storage.Controller.PassThroughSupport
Device | Active | Storage Spaces Drive | Device.Storage.Hd Device.Storage.Hd.DataVerification Device.Storage.Hd.Flush Device.Storage.Hd.MultipleAccess Device.Storage.Hd.MultipleAccess.PersistentReservation Device.Storage.Hd.PortAssociation Device.Storage.Hd.Scsi.ReliabilityCounters
Device | Active | Storage Spaces Enclosure | Device.Storage.Enclosure
Device | Deprecated | Switch | Device.Network.Switch.DAL-TOR
System | Active | Tablet | System.Client.Digitizer.Touch System.Client.Graphics System.Client.PCContainer System.Client.SystemPartition System.Client.Tablet.Graphics System.Fundamentals.DebugPort System.Fundamentals.Firmware System.Fundamentals.Graphics System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.Input System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
Device | Active | Touch | Device.Input.Digitizer.Touch
Device | Active | Touch Monitor | Device.Input.Digitizer.Touch Device.Display.Monitor
System | Deprecated | Ultra-Mobile PC | System.Client.Firewall System.Client.Graphics System.Client.PCContainer System.Client.SystemConfiguration System.Client.SystemPartition System.Client.UMPC.Graphics System.Fundamentals.DebugPort System.Fundamentals.Graphics System.Fundamentals.Graphics.Display System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.HAL System.Fundamentals.MarkerFile System.Fundamentals.PowerManagement System.Fundamentals.PXE System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
System | Deprecated | Ultra-Mobile PC with Touch | System.Client.Digitizer.Base System.Client.Digitizer.Touch System.Client.Firewall System.Client.Graphics System.Client.PCContainer System.Client.SystemConfiguration System.Client.SystemPartition System.Client.UMPC.Graphics System.Fundamentals.DebugPort System.Fundamentals.Graphics System.Fundamentals.Graphics.Display System.Fundamentals.Graphics.DisplayRender System.Fundamentals.Graphics.InternalDisplay System.Fundamentals.HAL System.Fundamentals.MarkerFile System.Fundamentals.PowerManagement System.Fundamentals.PXE System.Fundamentals.Reliability System.Fundamentals.SignedDrivers System.Fundamentals.SMBIOS
Device | Active | USB Controller | Device.BusController.UsbController
Device | Active | USB Hub | Device.Connectivity.UsbHub
Filter | Active | vSwitch Extension | Filter.Driver.vSwitchExtension
Device | Deprecated | WebCam | Device.Streaming.Webcam.Base
Device | Active | Windows Filtering Platform | Filter.Driver.WindowsFilteringPlatform
Device | Active | WLAN | Device.Network.DevFund Device.Network.WLAN.SupportConnectionToAP
Device | Deprecated | WLAN CSB | Device.Network.DevFund Device.Network.WLAN.CSBBase Device.Network.WLAN.CSBNLO Device.Network.WLAN.CSBSoftAP Device.Network.WLAN.CSBWiFiDirect Device.Network.WLAN.CSBWoWLAN
Device | Active | WSD Multi-Function Printer | Device.Imaging.Printer.Base Device.Imaging.Printer.WSD Device.Imaging.Scanner.Base
Device | Active | WSD Printer | Device.Imaging.Printer.Base Device.Imaging.Printer.WSD
Device | Active | WSD Scanner | Device.Imaging.Scanner.Base Device.Imaging.Scanner.WSD
Device | Active | Graphics Adapter WDDM2.0 | Device.Graphics.AdapterBase Device.Graphics.AdapterRender Device.Graphics.WDDM Device.Graphics.WDDM.Display Device.Graphics.WDDM.DisplayRender Device.Graphics.WDDM.Render Device.Graphics.WDDM11 Device.Graphics.WDDM11.Display Device.Graphics.WDDM11.DisplayRender Device.Graphics.WDDM11.Render Device.Graphics.WDDM12 Device.Graphics.WDDM12.Display Device.Graphics.WDDM12.DisplayRender Device.Graphics.WDDM12.Render Device.Graphics.WDDM13 Device.Graphics.WDDM13.DisplayRender Device.Graphics.WDDM13.Render Device.Graphics.WDDM20 Device.Graphics.WDDM20.DisplayRender
Device | Active | Mobile Printer | Device.Imaging.Printer.Mobile Device.Imaging.Printer.Mobile.WSD20
Device | Active | Net Switch | Device.Network.Switch.Manageability
Device | Active | BMC | Device.Connectivity.Server
Device | Active | Cluster | Device.Cluster
Device | Active | Camera | Device.Streaming.Camera.Base


HLK Tools Technical Reference

This section provides a technical description for the tools that are included in the HLK.


HLK Studio

The Windows Hardware Lab Kit (HLK) Studio is a test management console that allows you to organize tests into projects, view features and tests associated with a device, run selected tests, and create a submission package.

The following image shows an example Windows HLK Studio screen:

hlk studio layout screenshot

  • Tab Layout - The individual tabs along the top of the screen represent the flow of certification testing. You must create a project, make a selection, select a test, review results, and then create a package to complete the process.

  • Project Details - The right-pane displays project status and hardware details. As you test your device, you can monitor the test results. The Product Types field is an important field to review before testing. This value shows the devices that the kit detects and what tests the device can run. If the product type you want to qualify for does not appear, you must investigate whether the device is properly developed, or you might have to manually configure your product type. For more information, see Manually add features.

  • Main Detailed View - Displays detailed information for the respective tabs. In this area, you can right-click on an entry to see more options. You can click the F1 key to view context-sensitive help.

Features and Limitations

  • Windows HLK does not support the modification of the same project across multiple instances of Windows HLK studio.


HLK Studio - Project Tab

hlk studio project tab

A project defines the product that you want to test. The Test Levels feature lets you create projects that represent a wide range of scenarios. In addition, you can create several smaller projects and merge the results into one package. The most common project is the device that you want to submit for certification.

The right-pane (Project Summary) displays project information. The information pane is empty until you start to test the device. You can highlight the project, and the Project Summary automatically loads and displays the data for that project. You can load a project loaded, and still highlight other projects to see the information about those projects.

WARNING

Although the Project tab lets you load a project that is already opened, we recommend that you do not do this because the HLK Controller does not correctly handle the test results of a project that is simultaneously opened multiple times.

On this tab, you can perform the following tasks:

  • Create a project

  • Load an existing project

  • Delete or rename a project

  • View summary information about a project


HLK Studio - Selection Tab

hlk studio selection tab

The Selection tab displays all features that a device implements. Before you can see any features, you must first select a machine pool (drop-down list in the upper left corner). You can also search for specific features using the combination search drop-down list and search field.

The specific testable device is called the target. A device may contain multiple targets, represented by one or more hardware IDs. You can filter what you want to test by:

  • show selected - this option displays the targets that you've selected. This view allows you to see just the areas you're testing. You also can filter a machine pool by category by using the category list. You can search for specific targets/features by using the search box.

  • systems - test a complete client or server computer.

  • devices and printers - test an external device that's connected to a test computer. This device typically appears in Start > Devices and Printers on the test computer. This usually represents a collection of devices found on the Device Manager tab.

  • device manager - test a component of a test computer or external device, for example, a network card. This is the most detailed view.

  • software device - test filter drivers, firewalls, and antivirus software that's installed on the test computer.

    NOTE

    Some software drivers are associated with a physical device. If you cannot find your driver under software device, use the search bar on device manager to find the device under which your software driver is associated.

On this tab, you can do the following tasks:

  • Select targets to test

  • Select targets for distributed testing

  • Manually add features


Manually add features

Sometimes, features that are required for a product type aren't automatically detected on a device. In those cases, you must manually select the missing feature(s) that correspond to your product type. After all of the features have been selected, the product type appears. When you add features to your selection, the tests that are required for those features are automatically added to your list of tests.

  1. Find your product type in the Windows HLK Product Type Test Matrix.

  2. Determine the list of features that are required for your product type.

  3. In the Selection tab in HLK Studio, right-click your selection to see a list of features. The check boxes for features that have been automatically detected display as selected.

  4. Select the check box for any missing feature that corresponds to your product type.


Select targets for distributed testing

By default, the HLK tries to enable distributed testing by combining similar, selected targets. This is accomplished by matching similar targets under the same target family.

When two or more targets are considered similar, the set of tests for all the targets is reduced by removing duplicate distributable tests. Tests that are marked as non-distributable must be run on each target.

Targets that are in the same target family (distributed) have the notation [Group - XX] in the machine column. Targets that are in their own target family (non-distributed) have the machine name where the target was located.

The rules for determining whether two targets are similar include:

  • Target type must match

  • Target platform must match

  • Targets must be in the same machine pool

  • Targets cannot be from the same machine

  • Targets must have the same hardware Id or be in the same device family. See Device Families for more information

  • Drivers must match

NOTE

When there are multiple secondary matched targets on the same system, the target check box activation is retained from the previously displayed dialog for the same targets. This causes secondary targets to be grayed out. You can activate the grayed-out secondary targets by selecting and then de-selecting the checkbox for these targets.

Related topics

Configuration Page - Distributed and Multi-Device Options


HLK Studio - Tests Tab

hlk studio tests tab

The Tests tab displays all of the tests that are associated with the features that are found on a device. You can schedule a test by selecting its corresponding checkbox. You can press F1 key on any test name to get more information about that test.

You can filter and sort the test results by the following criteria:

  • Level (Basic, Functional, Reliability, Certification, Experiences, Optional)

  • Name

  • Type (manual, distributed, special configuration)

  • Length

NOTE

A grayed-out test indicates one of the following states:

  • The machine with the selected target is unavailable (debug mode or missing, etc.)

  • The project is opened from a package, which means the date is read-only.

Test Type Definition

The Type column provides additional information about each test. Some tests require additional configuration and/or manual interaction. Use this information in addition to F1 key to plan your testing strategy.

The View Details option defines each icon and displays the number of tests are found for each type. It is important that you review this information before you schedule any test, especially special configuration tests that require additional configuration before they can be run.

test type details dialog box

  • Special Configuration - this test requires hardware or software configuration changes before it is run; you must read the test documentation to determine what steps are needed.

  • Manual - this test requires manual interaction with the test on the target system while the test is running; you must read the test documentation to determine what input is required.

  • Non-Distributable - this test is required to run on each target in the target family.

Test Parameters

Some tests require additional parameters before they can be run. When you select a test that supports parameters, the following parameter dialog appears:

test parameter dialog box

NOTE

The parameter dialog displays only when you schedule (run) the test. If you schedule multiple tests that require parameter input, the parameter dialog displays all the parameters. For additional help on each parameter value, click the F1 key.

Related topics

Getting Started: Select and run tests


HLK Studio - Results Tab

windows hlk studio results tab

Figure 1 Results Tab

The Results tab displays detailed information about each test. When each test completes, the Status column updates with the result: Pass or Fail. You can expand any test in the Test Name column to see more information about that test.

The following list describes the Results Tab:

  • If you run a test more than one time, the HLK displays the results for each test run.

  • If you delete a test result, you must restart HLK Studio to refresh the test results.

NOTE

Any test that could be schedules as a multi-device test displays by using the multi-device icon. Multi-device-specific menu options let you reschedule a multi-device test to run as multiple non-multi-device test run equivalents, and let you see the system and targets against which the tests were scheduled. If a test run fails when it is run in multi-device mode and you suspect that one device that was consolidated into the single result is causing the failure, you can use this option to schedule each test device in its own test run (that is, without consolidating multiple devices into a single test run), to scope the failure down to a single device under test.

Test status

In the Detailed Test pane, the Status column shows you the status of each test that has run or is running.

Status Icon | Meaning | Description
queued status icon | Queued | The test is queued but not running. If the test is in this mode for a long time, it can indicate a network infrastructure or Windows HLK infrastructure problem. In most cases, this does not indicate an issue with the test itself.
running status icon | Running | The test is running. On the Tests tab, the Length column indicates the expected test runtime. This information is also available in the test reference topic for the specific test. If a device encounters issues during testing, the tests can run for three to four times the expected runtime.
test passed status icon | Passed | The test passed.
test passed with filters status icon | Passed with Filters | The test passed.
test failed status icon | Failed | The test failed.
test failed with filters status icon | Failed with Filters | The test failed.
test failed due to system crash status icon Failed due to system crash

The system crashed during the test run. You can right-click on this test to view Bugcheck information.

For more information about reviewing system crashes, see Troubleshooting Windows HLK Test Failures (system crashes).
test canceled status icon | Canceled | A user canceled the test, or a task has been canceled because the preceding task failed.
NOTE

If a filter is applied to a child library job, when all the tasks of the library job are filtered, the child library job itself can still show as unfiltered. This does not impact the submission package.

Test failures with system crashes

In the list of test results on the Results tab, a system crash icon ( system crash icon) is shown for each test that fails due to a system crash.

NOTE

This feature is available only for Desktop client and server machines.

sample results tab showing a test that failed due to system crash

When you right-click on one of these tests, the context menu now contains a Bugcheck Summary menu item.

context menu showing bugcheck summary option

Click on this menu item to display the Bugcheck Summary dialog. The dialog contains Bugcheck information along with a link to additional help documentation.

sample bugcheck summary information dialog

NOTE

If a crash dump file is available, the dialog contains a link to help documentation for working with crash debug information.

If a crash dump file is not present, the dialog contains instructions on how to enable crash dump collection. You'll need to re-run the test to obtain the crash dump file.

For more information on system crashes, including how to analyze crash dump files, see Troubleshooting Windows HLK Test Failures (system crashes).

Exporting failed HLK jobs

You can now export a failed job and re-run it on a machine that does not have the HLK Client installed. For more information, see Exporting a Failed HLK Job.

Diagnostic log files

In the case of a test failure, you can view the available diagnostic log files by right-clicking the target machine name in the Test Name column and then clicking Diagnostic logs, as shown in Figure 3 Diagnostic Log Files:

results tab showing diagnostic logs context menu option

Figure 3 Diagnostic Log Files

The displayed logs can be the following types, depending on the test:

  • Kernel crash dumps. Kernel crash dumps are disabled by default. To collect kernel crash dumps, see Manually Configure HLK Client Kernel Debugger Settings.

  • Event logs. Windows HLK collects all of the warning, error, and critical events that occurred during the test run:

    • System

    • Application

  • Setup logs:

    • Setup API. Windows HLK collects Setup API logs if they are available on a client machine during a test run. Windows HLK does not check to see if the file stamps for Setup API log files are in the same range as the test run.

    • Setup DEV

  • UMDF Diagnostic logs

    For machines that are running a client operating system version Windows 8 or later, the Windows HLK Infrastructure enables Microsoft Application Verifier on the UMDF host process (Wudfhost.exe) by using all basic tests and checks. The basic Application Verifier checks for the following:

    • Exceptions

    • Handles

    • Heaps

    • Leak Locks

    • Memory

    • SRWLock

    • Threadpool TLS

    If the UMDF driver fails any of these checks during device testing, an Application Verifier log is created that records the type of failure and the stack trace at the point where the failure occurs. Multiple Application Verifier logs are generated if the driver causes exceptions that crash WudfHost.exe. We recommend that you fix all reported failures for your UMDF driver.

    If the client machine is running under a kernel debugger, enabling Application Verifier on Wudfhost.exe causes a debug break when an error or exception occurs. You can use the !avrf extension to help analyze Application Verifier breaks. In addition, UMDF debugger extensions can be used to debug UMDF drivers; see Using UMDF Debugger Extensions for more information. The following diagnostic logs are copied to the controller for diagnosing UMDF driver failures.

    • Application Verifier logs

      Application Verifier logs in the form appverif_WUDFHost.exe.*.dat can be viewed by using an Application Verifier UI client. You can use the Application Verifier tool that is installed on the client machines. Copy logs to the directory %VERIFIER_LOG_PATH%\AppVerifierLogs before you run Appverif.exe - VERIFIER_LOG_PATH. The path variable is already set to %systemdrive% on the Windows HLK client. You can also add symbol paths to resolve the symbols in the stack frames where the errors or exceptions have occurred.

      NOTE

      The logs are generated in binary format and are architecture-specific. To view the logs, you must use an Application Verifier tool on a client that has the same architecture as the computers on which the logs were generated. See the Application Verifier tool Online Help for more information.

    • UMDF crash dumps

      UMDF dump files are of the form UM_<guid>.dmp and are created whenever a UMDF driver causes the Host Process to terminate.

Related topics

Getting Started: View test results and log files

Analyze test results in Excel


Exporting a Failed HLK Job

You can now export a failed job so that it can be run on a machine outside of the full HLK environment. For driver developers, this feature allows standalone execution of the test to simplify the process of reproducing failures.

An exported test environment closely simulates a dedicated HLK environment. This does not guarantee identical test execution, however. A user might need to handle any of the following circumstances:

  • Reboots are not handled by the test infrastructure. The user will have to manually restart the system in many cases.
  • There may be cases where the test reboots the system through the HLK Client infrastructure within a test task. For example, these reboots may not be captured in the batch file as prompts or reboots during standalone execution.
  • Non-uniquely named log files written to the same location by different tasks might result in some of these files being overwritten.
  • Parameters written to the batch file may differ when running on different systems. As an example, hardware instance IDs can differ for the same hardware and driver when moved to a different system, and the user will have to look up the corresponding target value (from Device Manager, for example) and update the batch file with the correct value.
  • Tests that depend on an associated configuration job to configure the system may not be prepared correctly as HLK only exports the test job itself.

Not all results can be exported. The following list describes the limitatons on the tests and test results that are exportable:

  • Tests must have been executed and complete with a passed, failed, or cancelled status.
  • The test run must successfully return infrastructure logs from the client system. These files are necessary to export the test.
  • Only single machine tests can be exported. Tests that require multiple machines to execute are not exportable.
  • Tests must be run using the HLK desktop client. Test runs on Windows Core or Proxy Mobile Client systems are not exportable.
  • Tests tagged as non-exportable due to known infrastructure issues or other reasons are not exportable.

  1. In the Results tab in HLK Studio, right-click on the failed result, and select Export Test Run.

    context menu when right-clicking a failed test result

  2. A save dialog appears. Save the exported job to a flash drive or other external location so that you can take the exported test to another machine. The same test cannot be exported to the same location more than once. A dialog will confirm that the export completed.

    success dialog after exporting a test result

  3. The test binaries and a batch file required to execute the test on a standalone system are exported to the specified directory. The exported test is saved in a subdirectory with the name and architecture of the failed job. Infrastructure components that must be installed to run the test is saved in a subdirectory called Infrastructure along with the name of the architecture to which the infrastructure is targeted.

    NOTE

    Infrastructure components should be installed only once on the target system. You do not need to reinstall these components for each failed job.

    As an example, saving a failed x64 job titled Set Render Target on the root of drive E:\ exports the job folder and the infrastructure installer using the following folder structure:

E:.
├───Infrastructure(X64)
└───Set_Render_Target(X64)
    ├───CoreClr
    ├───MinTe
    │   └───CoreClr
    ├───NetFx2.0
    ├───NetFx4.5
    ├───verifysupportfiles
    │   ├───CoreClr
    │   ├───MinTe
    │   │   └───CoreClr
    │   ├───NetFx2.0
    │   └───NetFx4.5
    └───[windir]
        └───system32

The exported test package contains several files and subfolders, including the following:

-   readme1st.txt - contains information for how to run the exported test
-   run.cmd - batch file that is used to run the test
-   binaries and other files required to run the test
-   setup(*architecture*).exe - install executable that is used to install the infrastructure

  1. Take the exported test folder to the new machine for testing. The path should not contain any spaces, as this will cause some tests to fail.

  2. Execute (save folder)\Infrastructure(architecture)\setup(architecture).exe to install the infrastructure components before running the test. The infrastructure installer will display a dialog box that indicates whether the install of the components was successful.

    NOTE

    Infrastructure components should be installed only once on the target system. You do not need to reinstall these components for each failed job.

    NOTE

    The architecture of the installer and the job must match the architecture of the target system on which it is installed.

  3. Within the batch file in the (save folder)(job name)(architecture) folder, you can make any necessary changes to the batch file to run on your test machine. As examples, you might make the following changes:

    • Commenting out lines that do not contribute to job failure
    • Changing parameter values to match the machine on which the exported test is run. For example, the instance ID of the same hardware often differs on two separate systems, so this would need to be updated before running the exported test.
    • Adding commands to connect a debugger
    NOTE

    If a task shows the error message "This test cannot be run as it might reboot the machine.", you must edit run.cmd, and append /rebootstatefile=(some_file_name) to the command line of the failing task, as shown in the example below:

    cmd /c TE.exe /inproc /enablewttlogging /appendwttlogging devfund_pcirootportsurpriseremovetest_wlk_certification.dll
/p:"MultiDeviceHardwareIdSdelQueryHardwareID=!MultiDeviceHardwareIdSdelQueryHardwareID!"
/p:"MultiDeviceInstanceIdSdelWDKDeviceID=!MultiDeviceInstanceIdSdelWDKDeviceID!" /p:"DQ=!DQ!"
/p:"TestCycles=!TestCycles!" /p:"IOPeriod=!IOPeriod!" /p:"WDTFREMOTESYSTEM=!WDTFREMOTESYSTEM!"
/p:"Wpa2PskAesSsid=!Wpa2PskAesSsid!" /p:"Wpa2PskPassword=!Wpa2PskPassword!"
/p:"DriverVerifierAdditionalDrivers=!DriverVerifierAdditionalDrivers!"
/p:"DriverVerifierExcludedFlags=!DriverVerifierExcludedFlags!"
/p:"DriverVerifierCustomizeConfiguration=!DriverVerifierCustomizeConfiguration!"
/rebootStateFile=rebootstatefile.xml

  4. Once you are finished with modifications, start a command prompt with administrative privileges, change to the test directory, and execute run.cmd. Each task in the batch file is associated with a task number that can be used as a starting point when running the batch file. By default, execution pauses in between tasks. The following execution modes are supported:

    • "Run" with no parameters starts execution at the beginning of the batch file, with a pause in between each task.
    • "Run 5" will start the batch file and skip to task 5.
    • "Run FAST" starts the batch file in fast mode (no pause in between tasks) at the beginning.
    • "Run 5 FAST" will start the batch file in fast mode (no pause in between tasks) at task 5.
    • "RebootResume" will start the batch file from the last reboot from the last execution of the script. The FAST flag is also supported.
    • "RerunLast" will start the batch file from the command that was running when the batch file last exited. This command can be used to re-run a task multiple times by pressing Control+C to exit the script during the task and running rerunlast.cmd to re-run the previous command. The FAST flag is also supported.

  5. Once you identify and fix the issue that is causing the test to fail, you can deploy the fix and verify that the job succeeds within the HLK environment.

    NOTE

    You cannot import successful results back into the HLK environment. You must re-run the job from within the environment.


Analyze test results in Excel

Using Management Tool PowerShell command, you can generate the aggregated list of test results for the project. You can then analyze the aggregated results in Excel.

Aggregate the list of test results

There are two ways to aggregate the list of test results for a project.

  1. Using the XML-based output files. An example of how you can merge XML-based test results from the Windows PowerShell session that is open on your Controller or test server is shown. In both examples, the use of the master.xml file is optional.

    dir -s "c:\temp\*.xml" | Merge-HwCertTestCollectionFromXml -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_1.xml"  -TestPassIdentifier "TP003"
dir -s "c:\temp\*.xml" | Merge-HwCertTestCollectionFromXml -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_2.xml"  -TestPassIdentifier "TP004"

  2. Using the project, .hlkx output files. An example of how you can merge .hlkx output files from the Windows PowerShell session that is open on your Controller or test server is shown.

    dir -s "c:\temp\*.hlkx" | Merge-HwCertTestCollectionFromPackage -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_1.xml" -TestPassIdentifier "TP003"
dir -s "c:\temp\*.hlkx" | Merge-HwCertTestCollectionFromPackage -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_2.xml" -TestPassIdentifier "TP004"

The aggregated list of test results (C:\temp\merged.xml) includes information for the full list of tests, not just the filtered list of tests. Because of this if any of the required tests were never run, the aggregated list of tests results will show that a required test was not run. Additionally, because all test results are merged, running multiple test runs with the same TestPassIdentifier attribute name value could create inconsistent results reporting. Instead, use a different name for each test pass.

Generate an Excel spreadsheet from the aggregated results

Once you have created an aggregated list of test results, you can generate an Excel spreadsheet by using commands in the Windows PowerShell session on the Controller or test server. An example of the commands that will create the Excel spreadsheet report is given below.

New-HwCertTestCollectionExcelReport ("C:\Temp\merged_1.xml", "C:\Temp\merged_2.xml" ) -ExcelPath 'c:\temp\report.xls' -ResultCount 1

Where ResultCount is defined as the maximum number of the most recent results, stored in the Excel report for each test.

An example of the output created after running the commands to create an Excel spreadsheet report is shown below.

hlk automation tool example of excel results

The resulting Excel report will contain the following headings:

  • Total Test - The total number of tests in this test pass.

  • Total Pass - The total number of results in this test pass

  • Total Pass With Filter - The total number of passes with an errata filter applied to the test.

  • Total Pass Percentage - Percentage of passing tests (Total Pass / Total Test).

  • Total Fail - The total number of fails in this test pass (Total Test - Total Pass).

  • N-1 Improvement - Between this test pass and the previous test pass (column to the left), how many new passes were achieved.

  • N-1 Regression - Between this test pass and the previous test pass (column to the left), how many new fails were encountered.

  • N-1 Not Changed - Between this test pass and the previous test pass (column to the left), how many tests did not have a change in result outcome.

  • N-1 Not Compared - Between this test pass and the previous test pass (column to the left), how many tests were not compared due to the test was only available in only one of the test passes.


HLK Studio - Package Tab

hlk studio package tab

The Package tab lets you package test results into a single HLK package (.hlkx file). Depending on your scenario, you can:

  • Create a submission package to get your device certified.

  • Create a package that you can merge with other packages later.

  • Create a package that can be shared with others (for example, troubleshooting with customer support).

  • Create driver only packages.

  • Merge packages.

IMPORTANT

To submit a package for certification, your package must be digitally signed.

On this tab, you can do the following tasks:

  • Digitally sign an .hlkx package

  • Create a driver only update package

  • Add driver and supplemental content to your package

  • Merge packages

Related topics

Getting Started: Create a submission package

HLK Signing with an HSM


Digitally sign an .hlkx package

HLK Studio supports three package types - one unsigned, two signed. All official submissions to Microsoft must be digitally signed. To create package:

  1. From HLK Studio, open a current project.

  2. Select Package tab, click Create Package and select the appropriate option.

    • Do not sign - To create an unsigned package, for example to send to support for debugging purposes or to later merge with other packages into a single submission package.

    • Use the certificate store. - To create a digitally signed package (most common scenario). This option requires an X509 certificate (i.e. VeriSign certificate) already installed on the computer running HLK Studio. From the Windows Security dialog, select the appropriate Code Signing certificate.

    • Use a certificate file - To create a digitally signed package using a portable security file. This option will ask you for an X509 certificate file (.cer). If you want to use a password protected .pfx file, you must install the file on your system with the password and select the certificate via the certificate store.

View signability results

When you include a driver with your package, HLK checks the signability of the driver. The Signability column in the Drivers Folder list has a green check mark for passing, or a red X mark for failed. To see signability errors and warnings, right-click the driver package folder and select Signability Results.

The Signability of a driver is different from signing a package. Signing a package for an official submission is done to the .hlkx package to verify the owner of the package. Signability of a driver checks that the driver content added to the package is acceptable for the submission.


HLK Signing with an HSM

Introduction

This topic describes some of the setup and configuration issues that can occur when using a third party network-based Hardware Security Module (HSM) to store Extended Validation (EV) Certificates.

Background

HLK Packaging

HLKX package files use the Open Packaging Conventions. The specification is part of a ISO working group, implying that HLKX files are not compatible with Signtool.

HLK Package Signing

When the HLK signs a package, the signature and relationships are placed in the package alongside the HLK data. This is the data that System.IO.Packaging.PackageDigitalSignature uses to validate the signature on the data in the package.

Cryptographic Service Providers

A cryptographic service provider (CSP) contains implementations of cryptographic standards and algorithms. At a minimum, a CSP consists of a dynamic-link library (DLL) that implements the functions in CryptoSPI (a system program interface). Most CSPs contain the implementation of all of their own functions. Some CSPs, however, implement their functions mainly in a Windows-based service program managed by the Windows service control manager. Others implement functions in hardware, such as a smart card or secure coprocessor. If a CSP does not implement its own functions, the DLL acts as a pass-through layer, facilitating the communication between the operating system and the actual CSP implementation.

Certificate Store and Registry

Certificates in the Certificate Store all map to a CSP DLL that will do the final signing. This can be seen in the registry entry below.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Defaults\Provider\Microsoft Enhanced DSS and Diffie-Hellman Cryptographic Provider]
"Image Path"="%SystemRoot%\\system32\\dssenh.dll"
"SigInFile"=dword:00000000
"Type"=dword:0000000d

HLKX Package Signing with a Certificate hosted by a Network-Based HSM

Controller Configuration

To set up an HLK controller to sign with an HSM certificate, the following must be present on the system:

  • A Certificate Authority (CA) from the HSM
  • A CSP file from the HSM

Instructions on how to configure an HSM client with these components should be documented by your HSM provider.

Signing with the HLK

If the controller is configured correctly, you should be able to point to the certificate from the HSM as you would a locally installed certificate from the HLK and sign the package.

Testing the HSM Configuration

Using Signtool

The first step to understand if we can sign is by trying to sign a file using signtool. This will allow us to verify that the signing workflow is functioning correctly. First we will sign a PE file (exe or dll). For example, signing using a name:

signtool sign /f HighValue.cer /csp "Hardware Cryptography Module" /kHighValueContainerMyControl.exe
signtool sign /n "My Company Certificate" MyFile.exe

or to sign using the SHA1 hash of the installed certificate:

signtool sign /sha1 0cf1d2f7befc7d143678f86963aef5572b710cf2 MyFile.exe

The certificate name is found in the Subject Information and the SHA1 hash is found in the Thumbprint. When using the hash remove all of the spaces and special characters that are in the hash so the format looks like the example above. You can also sign using a Personal Information Exchange (PFX) file. This is most likely not what you want to do, since a PFX file can contain the private key, where a certificate contains only the public key.

signtool sign /f certdata.pfx MyFile.exe

You can verify the signature using signtool

signtool verify /v /pa MyFile.exe

If you were able to sign and verify a file using anything except a PFX file, you can try to sign an HLK package. If you were unable to sign please look at the Troubleshooting section.

Using PackageDigitalSignature

There is a code example of signing using PackageDigitalSignature at the end of this document in the Code Samples section. You should have also gotten the complete C# file when you received this document. To use this example, you will need to provide a full path to your unsigned package and the thumbprint of the certificate you going to use for signing. If you were unable to sign please look at the Troubleshooting section.

Troubleshooting

The most likely cause is that there is not a certificate and associated CSP installed on your system from your HSM. Some of the things you could try are the following:

  • Can you sign on this system using just the tools supported by your HSM vendor?
  • Does your HSM vendor install a certificate and CSP on this system?
    • What are the certificate properties?
  • Does your HSM vendor support and document using signtool? If a file can be signed using Signtool with an HSM, this is an indicator that the system has been configured correctly and implies that the HLK can also sign HLKX packages.
  • When running the example code (HSM_example.cs) what is printed for the CspKeyContainerInfo.ProviderName
    • Does that provider name map to the correct vender supplied CSP DLL. That information can be found in the registry as shown above.

Code Samples

PackageDigitalSignatureManager

public static void Sign(string package, X509Certificate2 certificate)
{
  // Open the package to sign it
  Package packageToSign = Package.Open(package);

  // Specify that the digital signature should exist
  // embedded in the signature part
  PackageDigitalSignatureManager signatureManager = new PackageDigitalSignatureManager(packageToSign);

  signatureManager.CertificateOption = CertificateEmbeddingOption.InCertificatePart;

  // We want to sign every part in the package
  List<Uri> partsToSign = new List<Uri>();
  foreach (PackagePart part in packageToSign.GetParts())
  {
    partsToSign.Add(part.Uri);
  }

  // We will sign every relationship by type
  // This will mean the signature is invalidated if *anything* is modified in                           //the package post-signing
  List<PackageRelationshipSelector> relationshipSelectors = new List<PackageRelationshipSelector>();

  foreach (PackageRelationship relationship in packageToSign.GetRelationships())
  {
    relationshipSelectors.Add(new PackageRelationshipSelector(relationship.SourceUri, PackageRelationshipSelectorType.Type, relationship.RelationshipType));
  }

  try
  {
    signatureManager.Sign(partsToSign, certificate, relationshipSelectors);
  }
  finally
  {
    packageToSign.Close();
  }
}


Create a driver only update package

HLK Studio supports driver-only updates using the Connect option. This is commonly referred to as the Driver Update Acceptable (DUA) process.

  1. Sign into the Windows Hardware Dev Center Dashboard, and find the hardware submission that you want to update. Note that DUA is only available for submissions that include a driver file.

  2. Under Packages and signing properties, select Download DUA shell and download the file.

    1. If you don't have the current driver package, you can access the driver's INF files by downloading the signed driver files.

  3. Launch HLK Studio

    TIP

    Do not open the DUA shell package by double clicking the .hlkx file. You must open the package from within HLK studio.

  4. Select Package, and then select Browse to open the downloaded DUA shell package.

  5. Select Open as Driver Update package

    An image showing the driver update package notification

  6. Select Ok.

  7. Select the package tab, and right-click the appropriate driver folder. Then select Replace Driver

    An image showing the 'replace driver' window

  8. Find and select the folder where your driver updates are located.

    IMPORTANT

    The following filetypes are not allowed for DUA submissions:

    • .exe
    • .dll
    • .sys

    Typical acceptable filetypes include:

    • .inf
    • .txt
    • .pdf
    • .prd

  9. Select Create Package

    NOTE

    Submissions to the Hardware Dev Center require that you sign your package with an EV code signing certificate.

  10. Within the Hardware Dev Center Dashboard, create a new hardware submission, and upload your .hlkx file.


Add driver and supplemental content to your package

Adding a driver package

NOTE

We highly encourage you to include driver symbols as part of package creation. Including symbols enables Microsoft to triage and root cause issues related to your driver.

For device submissions, the driver(s) being used must be added. The purpose of adding the driver accomplishes two objectives, if the submission passes:

  • The driver(s) called the Driver Package are catalog-signed and returned. These are now the certified set of drivers.

  • The driver package can be posted on Windows Update, for broad distribution (as applicable).

Some device submissions (for example, devices which are certified for Server systems) also require debug symbols to be attached.

These requirements are explicitly called out in documentation. Unless specifically stated, driver symbols are not required.

To add a driver

  1. On the Package tab, click Add Driver Folder.

  2. Select folder where driver package is located.

  3. Click OK.

  4. When Driver Properties dialog appears, select appropriate Products and Locales for your package.

  5. Click OK to close Driver Properties dialog.

To add symbols

  1. Right-click selected driver.

  2. Select Add Symbols.

Adding supplemental content

Depending on the Device or System to be certified, additional information may be required. For example, devices being certified for SERVER systems must include the Static Driver Verifier (SDV) logs.

The requirements for these are covered in the necessary documentation. Unless explicitly called out, it is not necessary to add supplemental content.

To add supplemental content

  1. On the Package tab, click Add Supplemental Folder.

  2. Select folder where supplemental content is located.

  3. Click OK.


Merge packages

HLK Studio supports merging packages into a single package. This feature gives you the flexibility to distribute your tests across different projects, machine pools, and/or other HLK environments (other controllers).

For example, you want to create one submission for a system, filter, or device that applies to multiple versions of Windows and associated architectures. You can independently test against each version of Windows and later merge the packages into one submission package.

You can also test portions of a single-product (at the target family level) across different projects and later merge the packages into a single submission package. This concept of distributed feature and component testing is ideal for components that are expensive to setup and run. This is known as a deep merge. This merge support has the following limitations:

  • The targets must be for the same operating system and architecture.
  • The targets must be the same type (that is, System or Device).
  • You cannot deep merge software filter types.
  • The distinct set of features for all targets under a target family must match the distinct set of features in the target family from the merged package.
  • All distinct set of tests for all targets under a target family must match the distinct set of tests in the target family from the merged package.
  • (For device target types): the set of drivers must match.
  • (For device target types): the set of hardware Ids must match. (Note: this means that device families are not taken into consideration when matching hardware Ids)
  • When deep merging two packages, tests that are categorized as playlist tests in at least one package will also be categorized as playlist tests in the merged package.

When you open a package with an applied playlist in HLK Studio, only the playlist tests are shown in the UI.

NOTE

To guarantee that none of the tests are missed, we recommend that you create a package for the source project before you divide testing into separate projects. This package does not necessarily hold any test results; its purpose is to hold all required tests for all family targets. Later, this package can be merged with other packages into a single submission package. In this way, the submission package holds all required tests, regardless of whether the test has been executed.

Merging .hlkx packages

  1. Open an existing project or package.

  2. Click the Package tab, and then click Merge Package.

  3. Click Add and, in the Open dialog box, select an .hlkx package that you want to merge.

    NOTE

    If you accidentally selected the wrong package, select the package in the data grid and click Remove.

    Packages that were previously selected and saved (by clicking OK in the dialog box) can only be removed by clicking Reset on the main Package tab. These packages have a lock icon next to them.

  4. Repeat Steps 3 and 4 for each additional package that you want to merge. Note the Open dialog supports the selection of multiple packages at a time.

  5. Click OK to save your changes or Cancel to undo.

  6. Click Create Package.

Merging HLK and HCK Packages

HLK and HCK packages can be merged from the HLK OM or HLK Studio. When merging, ensure that the HLK package is opened first, and the HCK package(s) are merged into the HLK package.


HLK Studio - Configuration Page

hlk studio configuration machine management tab

The HLK Configuration Page contains the following:

  • Machine Management - use this option to create and manage machines and machine pools, and to configure Windows HLK Client Kernel Debugger settings.

  • Options - use this option to manage distributed target selections and multi-device testing.

  • Device Families - use this option to manage device families.

On this tab, you can perform the following tasks:

  • Create a machine pool

  • Manage machines

  • Manage device families

  • Manage distributed and multi-device options

  • Manually configure HLK Client kernel debugger settings


Configuration Page - Machine Management

hck studio configuration machine management tab

The Configuration page lets you manage your test clients and machine pools. A machine pool is a logical grouping of one or more test computers. After you install Windows HCK Client on each test computer, the computers are automatically added to the default pool. Before you can work with a test computer, you must move it to a working machine pool.

Every project needs a machine pool. A machine pool can be used for multiple projects, but each project can only be associated with one machine pool.

Create a machine pool

  1. In Windows HCK Studio, click Configuration.

  2. Select existing machine pool and click Create Machine Pool or right-click an existing machine pool, and select Create Machine Pool.

    The new pool is named "New Pool 1" by default. You can change that by typing a different name and then pressing Enter.

  3. Click Default Pool, and then confirm that each test computer appears in the main pane. If you've installed the Client software on multiple test computers, you can add any of them to the pool.

    NOTE

    A computer can't be in more than one pool at a time.

  4. Select the test computer, and then drag it to the newly created pool.

  5. Under Machines, right-click the test computer, click Change Machine Status, and then click Ready.

    The Status column changes to Ready.

    WARNING

    You cannot schedule a test against a computer with status equal to NotReady. A computer cannot be set to ready while in the Default pool.

  6. Repeat for each test computer that you want to include in the pool.

  7. Click the Back arrow to return to the main area of Windows HCK Studio.

After all of the test computers are assigned to a pool, you're ready to select targets and run tests against those computers.

Delete a test computer

There are several options for deleting a test computer from your HCK environment. You can delete a test computer from a project for reallocation to other projects or completely remove it from your environment.

If you are upgrading your Test Server to a newer version, you must uninstall and reinstall HCK Client on each test computer.

  1. Within a project on the Selection tab, unselect the targets associated with the test computer. This will disassociate the test computer from the project. The test computer is now available to other projects.

  2. Uninstall the HCK Client from the test computer.

  3. Delete the test computer from the machine pool.

NOTE

If you do not uninstall HCK Client after deleting a test computer from the machine pool, the test computer will reappear in the machine pool. Once you uninstall HCK Client, the association between tests and results are broken. The package will contain the test results, but no log files associated with that client.

Reinstalling Clients

If you need to reinstall HCK Client on a test computer, the test results will be lost. To preserve the test data, create a package before removing the test client. Create a new project and merge the package. For more information on merging, see Merge packages topic.


Configuration Page - Device Families

device family settings page

The Device Families page lets you manage device family and hardware Ids settings.

To enable distributed testing, similar targets must be selected. For targets to be considered similar, they must, among other things, have the same hardware Id. Device Families are used to "override" associate two devices with different hardware Ids but are, otherwise, similar

  • To create a device family, click Add Device Family. The new device family is named "Device Family 1" by default. You can change that by typing a different name and then pressing Enter.

  • To associate hardware Ids, click Add Hardware Id. The new hardware id is named "Device_Family_1_1" by default. You can change that by typing a different name and then pressing Enter.

NOTE

Note: A hardware Id can only exist in one Device Family for the entire controller. For more information on distributed testing, see Select targets for distributed testing.


Configuration Page - Distributed and Multi-Device Options

The Configuration Options page lets you configure target selection for distributed testing and multi-device support.

hck configuration options

Distributed Testing

By default, the HCK tries to enable distributed testing by combining similar selected targets. In HCK 2.0, this was accomplished by selecting each target individually and letting the HCK combine the targets together under the same target family. When checked, this feature provides a dialog to allow you to select all similar targets at the same time (rather than one at a time).

When the first target is selected, the UI will do a pre-scan of all targets to see if there are any similar targets that can be combined under the same target family for distributed testing. If there are other (non-selected) targets that are similar, the Distributed Target Selection dialog will appear and allow you to select one or more additional targets.

Additionally, the dialog lets you know if the target you selected would be added to an existing target family. If there is an existing target family and there are tests running, you have the option to check the Reschedule queued distributable tests to include selected targets option. This is known as dynamic pool growth. When this option is checked, the HCK will attempt to reschedule any queued (non-running) tests to the newly added target (machine).

For more information about how targets are matched and the selection dialog, see Select targets for distributed testing.

To enable distributed testing:

  1. In Windows HCK Studio, click Configuration.

  2. From the left-pane, select Options.

  3. Select Distributed Testing checkbox.

The feature is now configured. When you create a new project and select a target to test, the kit will prompt you if distributed testing is supported for that target. You have the option of specifying what computers to use for distributed testing.

hck selection distributed target selection dialog

Multi-Device Test Scheduling

This feature lets you run single instances of tests across multiple targets in a multi-device object. This feature is designed to reduce test time, especially for multi-function devices with many dev nodes, such as a multi-function printer. The following are limitations of the feature:

  • Test must support multi-device scheduling. This is indicated by the multi-device symbol ( multi-device icon).

  • Tests are identical but are associated with different targets on the same test device. You cannot consolidate different test.

  • Only one log file is generated for each group of test. The log file contains the results for all targets under test.

  • When one instance of the test fails against a single device node, all instances report failure. To troubleshoot specific dev node test failures, it may be necessary to either run tests one at a time, or disable multi-device testing to identify the root cause of the failure.

To enable multi-device scheduling:

  1. In Windows HCK Studio, click Configuration.

  2. From the left-pane, select Options.

  3. Select Allow Multi-Device Tests to run as one instance when possible checkbox.

Additionally, selecting Show notification when Multi-Device tests will be scheduled to run as one instance, will display a dialog after scheduling tests that gives a summary of tests scheduled in a multi-device fashion. This dialog will only show if Allow Multi-Device Tests to run as one instance when possible is checked.

Deselecting Dev Nodes on Eligible Devices

In addition to multi-device testing, you can further reduce test time on certain devices like multi-function printers, storage devices, and mobile broadband devices by deselecting some device nodes. Removing device nodes reduces the number of test run against the device. An eligible device must meet the following criteria:

  • The device exposes a child node of the parent type: USB Composite Device or Internal USB Hub.

    AND

  • The child node ONLY exposes DevFund types (i.e. only displays feature of type "Device.Devfund.*")

The parent nodes themselves (USB Composite Device or Internal USB Hub) must be tested and may not be deselected.

Part 1: Identify eligible devices that can be deselected.

  1. From your test client, open Device Manager, select View>Devices by connection.

  2. Find the parent nodes: USB Composite Device or Internal USB Hub node that represents your device.

  3. For each potential eligible device (child node) found, follow the instructions in Part 2 to determine if the child node meets the criteria and how to exclude it from testing.

Part 2: Determine if the device meets the criteria.

  1. On your controller, open HCK Studio and create a project for the device.

  2. Switch to the Selection tab and choose the Device Manager option in the left pane. HCK Studio displays a list of targets found on your device.

  3. Right-click on each target name identified in Part 1 and select Add/Modify Feature.

  4. Scroll through the list of features associated with that target to determine if the target can be excluded from testing.

    • If Device.Devfund features are the ONLY features selected (grey check mark), then this target can be deselected. Close the list box and deselect the target from the list. You will be prompted to confirm the deletion. Choose Yes.

    • If the list contains other non-Devfund features, then this target cannot be deselected.

  5. Repeat Steps 3 and 4 until all eligible devices are deselected.

    You can switch to the Test tab and schedule and run tests.


Manually Configure HLK Client Kernel Debugger Settings

During driver development, you might want to debug crashes in the kernel. To do this, you must enable kernel debugging.

From the computer on which you installed the debugger, follow these steps:

  1. Click Start, point to Programs, point to Debugging Tools for Windows, and click Debugging Help.

  2. Click the Search tab in the Debugging Tools for Windows window, type "Kernel-Mode Setup" (including quotes), and click Search.

  3. Read the topic Kernel-Mode Setup.

Configure HLK Crashdump collection settings

You can also configure the kernel crash dump collection setting in HLK Studio. This setting will force a setting of the kernel dump type on the client system when a crash occurs. When a crashed occurs, HLK will copy back the dump file and associate it with the underlying test.

NOTE

System and UMDF crash dump are not collected by default. You must enable this feature for each machine pool, and you must choose one of three dump types, which are Mini, Kernel, and Full. If server disk size is not an issue, we recommend that you use Full dumps. For more information about dump types, see Varieties of Kernel-Mode Dump Files.

The steps to configure this setting are as follows:

hlk configuration crashdump setting

  1. From HLK Studio, click Configuration option.

  2. Select a machine pool on which to apply the kernel crash dump setting.

  3. Right click on the machine pool.

  4. Select the dump setting from the following options:

    1. Disable

    2. Full

    3. Kernel

    4. Mini

The crash dump collection setting is set on all machines in the specified machine pool, but it is not set for machines in any child machine pools. If you select Disable, the machine's crash dump settings will persist on the client machine, but the crash dump collection for Windows HLK is disabled.


HLK Studio - Connect Page

The Connect option lets you view .hlkx files. This feature is useful if you need to share an .hlkx file with another person.

An .hlkx file is a compressed file format created by HLK Studio. An .hlkx file, also known as a submission package, is what you submit for certification. An .hlkx file must be digitally signed to be a valid submission package.

View an .hlkx package

HLK Studio supports viewing .hlkx packages. For example, if you want to troubleshoot a test offline, you can open an existing .hlkx package using the Connect option. In this mode, you can view all details of the project, including pass/fail results and log files.

IMPORTANT

You cannot open an .hlkx package created from a previous release of the HLK. The version of HLK Studio and the package you want to view must be the same.

  1. From HLK Studio, choose Connect.

  2. Select Package option, and then choose Browse to open an existing .hlkx package.

Related topics

Install standalone HLK Studio

Merge packages


HLK Controller

A test server has two parts: Windows HLK Controller and Windows HLK Studio. The Controller software is the engine that manages tests that are run on test systems. It is installed from the Windows HLK installation source. After installation, the test server contains separate installers to install a remote Windows HLK Studio and Windows HLK Client.

One controller governs a collection of client computers. Controllers can manage and access only the client computers that they govern.


HLK Controller and Client Organization

Before you install Windows HLK software in your lab, you should decide how you want to organize your lab's resources. Determine the number of controllers, the number of clients connecting to those controllers, and on which computer(s) to install Windows HLK Studio. These decisions are partly influenced by the type of devices and/or systems that you want to certify.

For example, to test specific devices, such as a USB-based flash-card reader, you might decide to allocate fewer controllers, each with more clients, because multiple testers can access the controllers, schedule jobs, and review job results, simultaneously.

NOTE

This release of Windows HLK does not support enterprise scenarios, wherein controllers communicate directly with each other to share clients and distribute scheduled jobs. That is, Windows HLK does not support load-balancing.

Typically, there are two ways to organize your controller and client lab resources:

  1. Allocate fewer controllers, each with many clients connected to them.

    • Advantages: You will have less overhead administering the controllers and clients. Also, the chances are higher for a client with the necessary hardware and software configuration to be available, or become available shortly, to execute a scheduled job.

    • Disadvantages: Adds more latency to the Windows HLK controller. Windows HLK Studio menu items will be slower to respond and jobs slower to launch.

  2. Allocate more controllers, each with fewer clients connected to them.

    • Advantages: Any given controller will be more responsive because it has fewer clients communicating with it. You can reduce overall latency.

    • Disadvantages: Adds more latency to the Windows HLK controller. Windows HLK Studio menu items will be slower to respond and jobs slower to launch.

If you configure your controllers to run on high performance/high resource hardware, they will be able to handle more clients.

NOTE

Multiple controllers are independent of each other.

Windows HLK puts a limit of 150 clients that can connect to a single controller. If you have a large lab that has more than 150 computers intended to be clients, you must allocate multiple controllers. Regardless of the size of your lab, you can allocate multiple controllers, each with any number of clients (up to 150 per controller) connected to a given controller.

NOTE

Installing Windows HLK Studio does not count toward the limit of 150 clients per controller.

The following table describes example scenarios for labs of different sizes.

Number of computers Minimum number of Windows HLK controllers to allocate Number of Windows HLK clients to allocate Configuration

2 to 10

1

1 to 9

Allocate a single controller that will have 1 to 9 clients connected to it.

The remaining computers all become clients of the controller.

11 to 151

1 or more

1 to 150

Allocate at least one controller, and possibly more.

For example, you can allocate one controller that can have up to 150 clients. Or, you can allocate two controllers and distribute the computers as their clients in an arbitrary manner.

The decision about the ratio in which to allocate clients to controllers is completely at your discretion.

152 or more

2 or more

150 or more

You must allocate at least two or more controllers for labs that contain more than 150 clients because this release of Windows HLK supports a maximum of 150 clients per controller.
NOTE

To use Windows HLK to obtain certification, all tests must be performed from a single controller. You cannot combine results from multiple controllers to obtain certification.


HLK Lab Security

Before you deploy Windows HLK, you should consider security requirements. There are two areas of certification testing that significantly affect security:

  • Enabling auto-logon functionality

    Do not change or create an autologon account, as this may cause Windows HLK to stop functioning properly. The Windows HLK handles this process automatically.

  • Running tests in an administrator role

Additional security precautions

In addition, be aware of the following security precautions and considerations:

  • Isolate Windows HLK computers on the network

    To prepare to deploy Windows HLK in your lab, you should isolate the computers that you intend to install it on. For example, do not allow those computers access to the Internet or your primary network. If any of your test systems can connect to a corporate network or the Internet, those connections should be disabled during testing. Alternately, put lab computers on their own private subnet. For more information about configuring a private subnet, search the Windows XP Professional Resource Kit for information about Configuring APIPA.

  • Use dedicated computers and reformat them before use

    Systems that are used for testing should not store sensitive data or be used (or have been used in the past) for company-provided services (such as a Web server, Dynamic Host Command Protocol [DHCP] server, or a backup domain controller [BDC]). If new systems are not available, then reformat and wipe clean all dedicated Windows HLK computers before installing Windows HLK and running the certification test to ensure that no sensitive information is inadvertently captured in the Windows HLK logs. For example, in the event of a kernel crash, the job log could record a full memory dump that might contain potentially sensitive information. For more information about cleaning your lab computers, see Fdisk and Format a Hard Disk. After you have cleaned the computer you must install the operating system you want the computer to run.

  • Use hardware and/or software firewalls

    When you install the Windows HLK controller and Windows HLK client, the installers will open TCP port 1771. Ensure that no other software running on a controller or client uses port 1771. The controller and client installers will prompt you to open this port in the Window's software firewall. However, if your lab includes non-Microsoft software firewalls or hardware firewalls, you must manually make sure that port 1771 is open. Otherwise, Windows HLK controllers will be unable to communicate with their clients and schedule them to run tests. If you use a hardware firewall, refer to the documentation that came with it to open TCP port 1771.

  • Set user permissions

    When you install the Windows HLK controller, its installer will create a network share and set the permissions for the share to allow access for Windows HLK clients. One folder inside the network share is for the Windows HLK client installer, and another folder is for the Windows HLK Studio installer. Another network share is created for clients to communicate job results back to the controller. You can increase security by allowing only testers and Windows HLK clients to connect to these shares across the network, which is another reason why you should isolate the computers of your lab on a private subnet.

  • Physically secure your lab

    You should enable auto-logon on Windows HLK clients. Therefore, wherever possible, test systems should be located in a locked room and should be physically available to testing and support personnel only. Enabling auto-logon is described in a bit more detail in the section that follows.

For more information about security and enabling automatic logon, see the following references:

  • Microsoft Security

  • Microsoft TechNet


Windows Hardware Lab Kit Filters

When Microsoft discovers a problem in either a Windows HLK test or in the operating system itself that causes certification tests to fail incorrectly, we create an errata that allows partners to pass the problematic test. Many errata use filters to automatically filter the failure from the submission results. Filters are applied within Windows HLK Studio.

  • Errata - These filters override tests that have errors that cause them to fail incorrectly. These filters apply to the test for all end users.

  • Contingency - These filters allow companies to pass certain tests based on a legal agreement with Microsoft to fix device or system bugs within an agreed time period. These are specific to a particular case.

  • Autotriage - These filters don't change the status of a test from fail to pass. They display information on common errors that can cause test failures.

To install filters

download image Download the latest HLK Filters

NOTE

If your HLK environment doesn't have access to the Internet, you can copy the file to your test server.

NOTE

Both HLK and HCK filters are stored in the same HCKFilterUpdates.cab filters file, there is no separate file for HLK.

  1. Review the ReadMe file to learn how to install the filters on the controller.

  2. Download HCKFilterUpdates.cab to your controller.

  3. Open the downloaded HCKFilterUpdates.cab file.

  4. Click and drag UpdateFilters.sql from the zip file to your desktop.

  5. Click and drag the UpdateFilters.sql file from your desktop to the %Program Files (x86)%\Windows Kits\<version>**\Hardware Lab Kit\Controller ** directory.

    Where <version> is the version of the HLK.

  6. Close all instances of HLK Studio.

  7. From that directory, run the UpdateFilters.exe command.

You can install more than one HCKFilterUpdates.cab file to your controller, and you can download and install the latest version of the HCKFilterUpdates.cab file whenever a new one is published.

To determine if the current .cab file is the latest one, see the time stamp in the ReadMe file, or use the RSS feed on the Hardware Dashboard to receive a notification whenever a new filter is available.

To apply filters

After you install a new HCKFilterUpdates.cab file, the new filters will be automatically applied to new results as they are generated.

For existing results, you must select the Apply Filters option on the Results tab to reapply the filters to the results.

Limitations

  • Existing test results, made prior to new filters being added, need to have new filters applied manually. To do this, load the project you want to apply the filters to, and click the Apply Filters button as described in the process above.

  • There is no notification that a filter has been applied, but you can view filter results in the test results.

  • If you open a package (.hlkx) in HLK Studio that previously contained a filter failed result, HLK Studio will display that result as failed. This is a known issue when opening a package.

Related topics


Manage HLK User Accounts

An HLK user account is automatically created for the person who installed the HLK Controller, and that account is granted administrator privileges within HLK. A person who has a HLK user account with administrator privileges is called a HLK administrator.

HLK administrators can create new HLK user accounts or modify the permissions of existing HLK user accounts.

IMPORTANT

To create an HLK user account for a domain user, as opposed to a user account for a local user, you must be logged on to the HLK Studio computer as a domain user with administrator rights on the local machine.

If you try to create an HLK user account for a domain user while you are logged on as a local user with administrator rights, an error message will appear informing you that the user for whom you are trying to set up permissions does not exist in the domain. The domain referred to in the error message is the local machine and not the domain to which it is connected.

Assigning Roles

When you create a new user account for an HLK user, you must also assign a datastore role for the user.

The following is a list of the HLK datastore roles that you can assign a user when you create the new user account.

Role Description

hlk_DSGuests

With a guest user account, you can log in without having a user account to access the HLK datastore. This level of access is very restricted and only allows the user to view the results of a job.

hlk_DSUsers

To obtain access to a Microsoft SQL Server database, you must have a corresponding user account for that database.

This user account allows the HLK user to perform several of the basic tasks associated with logo testing. See the permissions table that follows for more details

hlk_DSAdministrators

If a user is assigned this role, that user has administrator privileges on the local system and is able to install a system. Additionally, if the host computer is part of a Windows domain, the Administrator account usually has domain-wide privileges as well.

hlk_DSOwners

The datastore owner is a user that has permission to perform all activities in the database. See the permissions table that follows for more details.

To the HLK Studio user interface, the HLK_DSOwners and the HLK_DSAdministrators roles are the same. However, the level of access a user has to the HLK datastore itself when he or she is assigned the HLK_DSOwners role far surpasses the level of access a HLK_DSAdministrators user has. As such, you must only assign the HLK_DSOwners role to users who are very knowledgeable about Microsoft SQL Server.

Permissions Table

 | hlk_DSGuests | hlk_DSUsers | hlk_DSAdministrators | hlk_DSOwners
Schedule/Run jobs |  | X | X | X
Create Jobs |  | X | X | X
Edit Jobs |  | X | X | X
View Results | X | X | X | X
Delete Jobs |  |  | X | X
Cancel Jobs |  |  | X | X
Add Users |  |  | X | X
Remove Users |  |  | X | X

Creating a HLK User Account

  1. From your controller, select Start>All Programs> Windows Kits>Hardware Certification Kit>HLK Manager.

  2. Select Tool>Management Console.

  3. In the left pane, expand Console Root.

  4. For each of the listed datastores (WTTIdentity and HLKJobs), do the following:

    1. Expand the datastore, right-click Users, and then click New User.

    2. In the Datastore User Properties - New User dialog box, in the top pane, type the user name of the person you are creating a HLK user account for using the format domain\username, where domain is the user's domain or workgroup name, and username is the user's user name.

      NOTE

      If you are creating multiple user accounts, separate each user with a semicolon.

    3. In the Datastore Role pane, select the HLK_DSOwners check box.

      WARNING

      You can assign multiple roles to a new user at the same time. To grant this user administrator privileges, select the hlk_DSAdmins check box also.

    4. Click OK.

Granting Permissions

Complete the following procedure to grant a HLK user permission to run jobs on a machine pool.

  1. From your controller, select Start>All Programs> Windows Kits>Hardware Certification Kit>HLK Manager.

  2. Select Explorers>Job Monitor.

  3. Select your HLK controller from the drop-down list box at the upper-left corner.

  4. In the Machine Pool pane, expand the machine pool hierarchy, right-click the machine pool that you want the user to be able to run a job on, and then click Properties.

  5. On the Security tab, click Add.

  6. In the User List dialog box, click the user name, and then click OK.

    WARNING

    If the user name does not appear in the user list, the user does not have a HLK user account. Create the user account, and then give the user permission to run jobs.

  7. In the bottom pane of the Properties dialog box, select the Execute Jobs check box and clear any check boxes for permissions that you don't want the user to have, and then click OK.


Microsoft SQL Server Options

The Windows HLK provides SQL Server Express. If you would prefer to use a different edition of Microsoft SQL Server, the HLK supports 64-bit versions of SQL Server 2012 and SQL Server 2008R2.

Depending on your operating system, you might need to install additional service packs for SQL prior to installing the HLK.

WARNING
  • The HLK does not support SQL Server 2014. You must uninstall SQL Server 2014 prior to installing the HLK.
  • The HLK does not support 32-bit versions of SQL Server. Any 32-bit instance must be uninstalled prior to installing the HLK.

Install Microsoft SQL Server 2012

  1. Enable .NET 2.0/3.x feature from within Server Manager

  2. Install SQL using the setup application using the following command line for a unattended install. /QUIET and /HIDECONSOLE flags may be omitted to see any errors that may occur during install.

(setup application) /QUIET /HIDECONSOLE /ACTION=install /FEATURES=SQL,RS /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /AGTSVCACCOUNT="NT AUTHORITY\SYSTEM" /AGTSVCSTARTUPTYPE=Automatic /ASSVCACCOUNT="NT AUTHORITY\SYSTEM" /RSSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" "%USERDOMAIN%\%USERNAME%" /INSTANCENAME=MSSQLSERVER /TCPENABLED=1 /NPENABLED=1 /IAcceptSQLServerLicenseTerms=1

Install Microsoft SQL Server 2008R2

Follow the same procedure for installing Microsoft SQL Server 2012, but before installing SQL via the command line, be sure to do the following:

  1. Install SQL Server 2012 SharedManagementObjects.msi (64-bit) from the following link:
    http://go.microsoft.com/fwlink/p/?linkid=239659&clcid=0x409
  2. Install SQL Server 2012 SQLSysClrTypes.msi (64-bit) from the following link:
    http://go.microsoft.com/fwlink/p/?linkid=239644&clcid=0x409

Using the HLK with standalone SQL Server 2012

When using the HLK with standalone SQL Server 2012, be aware that some tests can make thousands of database calls. Be sure to choose the right backup configuration and recovery model so that your transaction logs do not grow to be too large.

When using standalone SQL Server 2012, you have a choice of recovery models:

  • Full recovery model enables point-in-time database recovery.
  • Simple recovery model can only restore a database from most recent backup. There is no point-in-time recovery.

When the database is configured to simple recovery, previous logs will be truncated and that space will be made available for reuse. When the database is configured to full recovery, the transaction log continues to grow until a backup is performed. This helps provide a point-in-time recovery, but if backups are infrequent, it could generate an extremely large transaction log. If there are enough transactions, the log can become large enough to consume all available storage memory and crash the server.

We recommend using the Simple Recovery model when using the HLK with standalone SQL Server 2012. If you use the Full Recovery model, be sure to perform backups frequently enough that the transaction log size remains manageable.

Related Topics

  • Transaction Log

  • Recovery Models


Install a remote HLK Studio

You can optionally install HLK Studio on a separate computer. The computer must be able to connect to the installation folder that is shared from the HLK Controller computer. Therefore, before you can install HLK Studio, you must have already installed HLK Controller.

Install remote HLK Studio

  • From your remote computer, click Start, click Run, type \\ControllerName\HLKInstall\Studio\Setup.exe, and then click Yes.

Replace ControllerName with the actual name of your controller. Completing this step will install, if not already present, .NET Framework 4.0 (Client Profile and Extended).

Configure additional user accounts

By default, the user account used to install the Controller is the only account that can run tests using HLK Studio. If you want to allow additional accounts to manage tests via remote HLK Studio, you must manually add each account to your Controller.

  1. On your Controller, add each account to the Administrator group.

  2. Open HLK Manager, click Tools > Management Console, and then expand the Users node.

  3. Right-click hlk_dsowners, select New User.

  4. Enter the account (DOMAIN\accountname) or MACHINE\account).

  5. Click OK.

(Optional): Configure Internet Connection Firewall (ICF)

If you choose to install HLK Studio on a computer other than the HLK Controller, you must configure the Internet Connection Firewall correctly on the HLK Controller, otherwise HLK Studio will be unable to connect to the HLK database.

This is only needed if the user account is correctly added, but is blocked by the firewall from connecting to the SQL server instance on a remote studio. This is usually in a workgroup scenario.

To configure ICF, complete the following task on the HLK Controller.

Option 2: Add an exception to ICF

  1. In the Control Panel, click System and Security, and then click Windows Firewall.

  2. On the left pane, click Advanced Settings.

  3. On the left pane, under Windows Firewall with Advanced Security on Local Computer, click Inbound Rules.

  4. On the right pane, under Actions, click New Rule to launch the New Inbound Rule Wizard.

  5. Make sure that the Program is selected, and then click Next.

  6. After the program path is selected, click Browse and browse to the location where SqlServr.exe is located. Usually that is: %Program Files (x86)\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn\sqlservr.exe

  7. Click OK, and then click OK again.


Install standalone HLK Studio

You can install a standalone Windows HLK Studio if you want to view .hlkx certification packages (including logs/results), either in-progress or finished, without installing the Windows HLK Controller. Installation only takes a few seconds, and enables you to complete the following scenarios:

  • View log files from the package.

  • View test results in the package.

  • Regenerate the package.

  • Merge with another package.

  • Add additional drivers to the package.

  • Add a DUA driver update to the package.

To install standalone Windows HLK Studio

  1. Download the Windows HLK to a location accessible to your test server.

  2. From HLKSetup.exe, select the Studio Only option.

  3. After installation, open HLK Studio.

  4. HLK Studio opens automatically on the Connect tab, which you can interact with just as you would with the full Windows HLK.

Limitations

Installing a standalone HLK Studio also installs HLK Manager to your system. However, you won't be able to access or use any of the features of HLK Manager.

Also, you should avoid installing a standalone HLK Studio on the same machine where a remote Studio (Studio installed from a Controller) has been installed. There are known limitations to this scenario, which may leave your system in an inoperable state.


Command-line options to install HLK

Installation and Uninstallation Examples

To install the Windows HLK Controller, Studio, Client and/or Manager (Unattended):

  • To install the Windows HLK Controller, use the following command from the root of the Windows HLK installation media:

    • HLKSetup.exe /q
    NOTE

    By installing one or all of the kits, you automatically install all prerequisites (Windows HLK Controller, .NET 4.5, SQL), so there is no need to individually install other Windows HLK features.

To install/uninstall Windows HLK Controller and HLK Studio (Unattended)

  • To uninstall the Windows HLK Controller and HLK Studio, use the following command from the root of the Windows HLK installation media:

    • HLKSetup.exe /uninstall /q

  • To install the Windows HLK Client:

    • \\HLKController\HLKInstall\Client\setup.cmd /qn ICFAGREE=Yes

  • To install the Windows HLK Studio:

    • \\HLKController\HLKInstall\Studio\setup.exe /qn

  • To uninstall the Windows HLK Client:

    • \\HLKController\HLKInstall\Client\setup.cmd /qn /uninstall

  • To uninstall the Windows HLK Studio:

    • \\HLKController\HLKInstall\Studio\setup.exe /qn /uninstall
    NOTE

    Replace "HLKController" with the name of the computer on which you installed the Controller.


HLK Manager

The HLK Manager provides additional test management functionality not supported in HLK Studio. HLK Manager is similar to the previous DTM test management console for Windows Logo Kit. Most of the task management functionality is the same but without the specific WLK test functionality.

windows hlk manager


HLK Automation Tool

This topic guides you through a series of scripting-supported steps to automate Windows HLK driver, system, and software device testing. This allows you to run the Windows HLK tests without using the Windows HLK user interface (UI).

NOTE

There is a known issue with the Windows HLK execution engine. When a test has halted or the system has stopped a machine and the Windows HLK Object Model interprets the test as still running, the Windows HLK execution engine does not recognize the condition and can continue to monitor the test execution indefinitely (or until the timeout value of the project is reached). The root cause for this issue is that Windows HLK execution engine gets the test result from the Windows HLK ObjectModel; in this case, it therefore thinks that the test is still running and does not start the machine monitor to wait for recovery.

We recommend that you manually cancel the job and reboot the machine to alert ObjectModel. You might need to rerun the failed/cancelled test by using a shortended test collection file, or run it manually by using Windows HLK Studio. This issue will be addressed in future releases.

The process for running the Windows HLK tests in a series of scripted steps follows a workflow that is similar to the Windows HLK Getting Started Guide.

hlk automation tools test process

The individual steps are as follows:

  • Windows HLK automation tools prerequisites

  • Step 1: Install Controller and supporting programs on the test server

  • Step 2: Install HLK Client on the test computer(s)

  • Step 3: Create a test Project Definition File on the Controller or test server

  • Step 4: Generate the full list of tests based on the Project Definition File on the Controller or test server

  • Step 5: Filter the full list of tests on the Controller

  • Step 6: Add filtered list of tests to the Project Definition File on the Controller

  • Step 7: Run the test project on the Controller

  • Step 8: Analyze the test results in Excel

  • PDEF reference

Windows HLK automation tools prerequisites

Before you begin testing, make sure that you are familiar with the Windows HLK automation concepts and hardware requirements. See Windows HLK Prerequisites.

Step 1: Install Controller and supporting programs on the test server

The test server computer should be installed with an operating system and configured as described in Windows HLK Prerequisites. You can then install the following programs:

  1. Windows HLK. For detailed instructions about how to install the Windows HLK, see Step 1: Install Controller and Studio on the test server.

  2. Windows PowerShell 3.0. See KB2506143.

  3. Microsoft Excel (Excel 2007, Excel 2010, or Excel 2013).

  4. Office Primary Interop Assemblies for Windows XP.

    IMPORTANT

    This specific version is required to export Excel.

  5. Download and copy office.dll and Microsoft.Office.Interop.Excel.dll to %WTTSTDIO%. Use these programs to support Step 8: Analyze the test results in Excel.

To verify the successful installation of the Windows HLK Controller software, check for the following programs in C:\Program Files (x86)\Windows Kits\8.1\Hardware Certification Kit\Studio on the test server:

  • hlkexecutionengine.exe

  • Microsoft.Windows.Kits.Hardware.Certification.Management.dll

  • Microsoft.Windows.Kits.Hardware.Certification.Project.dll

  • Microsoft.Windows.Kits.Hardware.Certification.Testcollection.dll

To verify the successful installation of Windows PowerShell 3.0, do the following:

Verify Windows PowerShell 3.0

  1. To open a Windows PowerShell 3.0 session, x86 version on a computer that is running Windows 7, click Start, click All Programs, click Accessories, click Windows PowerShell, right-click Windows PowerShell (x86), and then click Run as administrator.

    To open a Windows PowerShell 3.0 session, x86 version on a computer that is running Windows 8 or Windows Server 2012, follow the instructions at Starting the 32-Bit Version of Windows PowerShell.

  2. Type Get-Command -Module HardwareCertification to see the following list of Windows HLK automation cmdlets:

    Export-HwCertTestCollectionToXml

    Import-HwCertTestCollectionFromXml

    Merge-HwCertTestCollectionFromPackage

    Merge-HwCertTestCollectionFromXm

    New-HwCertTestCollectionExcelReport

    New-HwCertTestCollection

    New-HwCertProjectDefinitionFile

  3. You can optionally set debug message output with automatic continuation by using the following command:

    $DebugPreference = "Continue";

Step 2: Install HLK Client on the test system(s)

To install the HLK client on a test system, follow the instructions found in Step 2: Install Client on the test system(s).

NOTE

When you install Windows HLK Client software on a computer, the computer is automatically added into the Windows HLK Controller Default Pool. The Default Pool is only supported in the Project Definition File that you define in the next steps.

To locate the Hardware ID or Device Class of the testing device from the Device Manager of each test computer, see Discovering Hardware IDs and Device Setup Classes for your Devices.

Step 3: Create a test Project Definition File on the Controller or test server

Project Definition File (also referred as PDEF) defines the Target- and Machine-specific part of the testing project. The Test and Result-specific part is defined in the Test Collection File. Together, these files fully describe the project configuration, scope and results.

For a description of the PDEF file format and auxiliary PDEF information, see PDEF reference.

An example test Project Definition File, called C:\Temp\DefinitionFile\device-win8client-x64-auto.xml is shown here:

<ProjectDefinitionData Controller="controllername" Database="HLKJobs" Timeout="120" User="user">
    <Project Name="Project-win8client-x64">
        <SchedulerType>AdaptiveOrderOptimized</SchedulerType>
        <MultiDeviceTestGroup>true</MultiDeviceTestGroup>
        <TestStatusToSkip>Pass</TestStatusToSkip>
        <Product Name="Product-win8client-x64" OsPlatform="Windows 8 Client x64" MachinePool="Test">
            <Family Name="Family-win8client-x64">
                <Target TargetType="Device" Id="HWID"/>
            </Family>
            <Machine Name="TEST-CLIENT-A" Role="SUT"/>
            <Machine Name="TEST-CLIENT-B" Role="SUT"/>
        </Product>
        <Packages Path="C:\temp"/>
    </Project>
</ProjectDefinitionData>

The following tables define child elements and the attributes, grouped by the XML node in which they should be set.

Project

Xml Name Description

Attribute

Name

User-specified friendly name of the project.

Attribute

Controller

Name of the Controller.

Attribute

Database

Fixed name of the Controller database (for example, HLKJobs).

Attribute

Timeout

The time the execution tool will monitor for activity, expressed in hours. If the test pass runs longer than this value, the tool will stop all testing.

Element

SchedulerType

Optional enumeration value that is used for scheduling tests, to define the scheduling mode for the Execution Engine. Valid values are the following:

  • AdaptiveOrderOptimized - tests are scheduled strictly in the order that they are defined in the Test Collection xml.

  • AdaptiveResourceOptimized - tests are scheduled in the order they are defined in the Test Collection xml, with respect to the availability of the machines for the scheduling test target.

Element

MultiDeviceTestGroup

Boolean flag, set to TRUE to enable multi-device testing.

Element

TestStatusToSkip

Optional enumeration value that is used to define the skipping mode for the Execution Engine when scheduling tests. Valid values are Pass, Fail, or NoData.

Element

Product

The product for this project. There should be only one entry.

Element

Package

The path to which the .hlkx package for this project should be saved.

Product

Xml Name Description

Attribute

Name

Friendly name of the product you test.

Attribute

OSPlatform

Version of Windows for the product. All computers that are specified for this product that are running different versions of Windows will be ignored.

Attribute

MachinePool

Machine pool that contains the test computers that are specified for the product under test. This is an optional parameter. If it is not specified, the default machine pool is used.

If a machine pool is specified, it must refer to an existing machine pool. This parameter works together with the Machine parameter. If the MachinePool parameter is specified but no Machine parameter is specified, the test runs on all computers in the specified machine pool.

Element

Family

A set of target families that belongs to this product.

Element

Machine

One or more machines that will be used for testing. If this parameter is empty, all machines in the specified pool are matched and used for testing.

Family

Xml | Name | Description
Attribute | Name | Friendly name of the Target Family of Targets that you test in the project.
Element | Target | A set of targets that belongs to this family. target is device or driver that can be selected for testing.

Target

Xml | Name | Description
Attribute | TargetType | Type of Target. Valid values are Device, System, and TargetCollection.
Attribute | Id | Unique identifier of Target. For example, with the TargetType parameter set to the value, Device, the Id will be set to Hardware Id, HWID. If TargetType is set to the value System, the value for Id will be ignored.
Element | ManualSelectFeature | Specifies a manually added feature.

Machine

Xml Name Description

Attribute

Name

Name of the test computer. This is an optional parameter. If Machine Name is specified:

  • The specified Name must exist in the specified MachinePool.

  • Only specified computers specified by the Name parameter are used for testing the product.

  • Only computers specified by Name that are running the operating system that is specified by OSPlatform are used to test the product.

Attribute

Role

If the computer is a system under test (SUT), this attribute should be specified as SUT. If the computer is a secondary client that is used for multi-computer testing, the attribute should be specified as CLIENT. Not specifying this attribute will default to this computer being a system under test (SUT).

Package

Xml | Name | Description
Attribute | Path | Folder for the submission packages that are generated at project execution.

Generating the Project Definition File

You can create the PDEF by using any xml or text editor, or by using the management tool New-HwCertProjectDefinitionFile cmdlet. If you use the management tool cmdlet, you can generate a PDEF that has the restrictions listed below. You can manually or programmatically update the generated PDEF xml by using any changes that are valid against the PDEF file schema.

  • The generated PDEF can only have a single <Project> element and a single <Product> element for the project.

  • The <Path> attribute of the <Packages> element must be empty or set to the [PACKAGES] token.

  • The <TestCollectionStatusLocation> attribute of the <Project> element must be set to an empty string.

  • The <SchedulerType> element must be set to AdaptiveResourceOptimized.

  • The <OsPlatform> attribute of the <Product> element must be set to the OSPlatform value that is derived from the first machine in the specified pool for this project.

Parameters of the New- HwCertProjectDefinitionFile cmdlet are described below:

  • OutputAutomatedPdef - a Boolean flag that handles the automatic generation of the following PDEF xml attributes:

    • <Controller> = "[MACHINE]

    • <TestCollectionReadLocation> = "[FILTERED_TEST_COLLECTION]

    • <Path> = "[PACKAGES]"

  • TestCollectionFilePath - the full path to the test collection xml file that is stored in the <TestCollectionReadLocation> attribute of the <Project> element in the PDEF xml. If this value and OutputAutomatedPdef are not provided, the path is set to an empty string.

  • ControllerName - the name of the controller that is stored in the <Controller> attribute of the <ProjectDefinitionData> element of the PDEF xml. If this value and OutputAutomatedPdef are not provided, the controller name is set to name of the current machine.

  • PdefFilePath - the name of the output PDEF xml file. If not provided, the path is auto-generated with the following format:

    %userprofile%\\desktop\\PDEF_Files\\PDEF_{time_date}\\PDEF_{os_platform_name}_{time_date}.xml

  • ProjectName- the name of the project that is stored in the <Name> attribute of the <Project> element in the PDEF xml. If not provided, the name is auto-generated using the current date time stamp value.

  • EnableMultiDeviceTest - a Boolean flag that handles the multi-device scheduling for the project, stored in the <MultiDeviceTestGroup> element in the PDEF xml. If not specified, multi-device scheduling is not enabled.

  • SkipTestStatus - the skipping mode for scheduling tests, stored in the <TestStatusToSkip> element in the PDEF xml. Valid values are Pass, Fail, and NoData. If not provided, the default skipping mode is Pass.

  • EnableIsolateTargets - a Boolean flag that enables creation of an individual device family for each discovered target. If not specified, targets are grouped into the families by device classes.

The following two parameters specify the machine pool for the project. You must provide only one parameter. If you do not provide a parameter, or if you provide both parameters, you will get an error.

  • MachineList - specify machine names in a comma-delimited list. All specified machines must be in the same existing pool or in the default pool.

  • MachinePool - the name of the existing machine pool.

The following six parameters specify the type of the targets for the project. You must provide only one parameter. If you do not provide a parameter, or if you provide multiple parameters, you will get an error.

  • RunSystemTest - the project is for testing the whole system. One target family with a single TargetType = System is generated.

  • TestAllDevices - the project is for testing all targets discovered on the specified machines.

  • HwIdList - specify target hardware IDs in a comma-delimited list. Each hardware ID in the list can be partially-specified. In this case, the matching hardware IDs are identified by using the partially-specified value as a sub-string with respect to the hardware ID format. Strings are compared as case-insensitive ASCII.

  • DriverList - specify names of target drivers in a comma-delimited list. UMDF Drivers (.DLL) are not currently supported. These devices can still be discovered by using their HWID, as part of the Windows Device Class GUID, or all targets.

  • ContainerIdList - specify container ID values in a comma-delimited list. Each container Id value must be in GUID format.

  • ClassIdList - specify class ID values in a comma-delimited list. Each class ID value must be in GUID format.

Step 4: Generate the full list of tests based on the Project Definition File on the Controller or test server

You can use the Management Tool cmdlet, New-HwCertTestCollection, to generate the full list of tests that are required for testing targets in the project. An example of how to use the Management Tool cmdlet in the Windows Powershell session, is shown below. (This step is optional.)

New-HwCertTestCollection -ProjectDefinitionFile C:\Temp\DefinitionFile\device-win8client-x64-auto.xml | Export-HwCertTestCollectionToXml -Output c:\temp\master.xml -TestPassIdentifier "TP001"

If a target that is specified in the Project Definition File is no longer available, you will receive a warning and the test collection generation continues. In this case, we recommend the following to get the full list of tests:

  1. Create an auxiliary copy of Project Definition File that holds only those targets that were not available. Because tests list generation time depends on the number of specified targets, we strongly recommend that you keep only those targets that were not available at the previous run in the auxiliary copy.

  2. Fix the problem that caused the targets being not available; for example, certain machines in the pool are not in READY state.

  3. Generate an auxiliary list of tests by using the auxiliary copy of the Project Definition File.

  4. Merge the initial and auxiliary lists of tests. You can do this manually by adding <TestCollectionRecord> elements from the auxiliary list to the initial list.

An example of the generated output xml file (c:\temp\master.xml) is given below.

<?xml version="1.0" ?>
<ArrayOfTestCollectionRecord
               xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
               mlns:xsd="http://www.w3.org/2001/XMLSchema">
               <TestCollectionRecord
                               Name="Disk Stress (LOGO)"
                               Guid="738735f7-245a-4b39-9d81-20339ce31fd4"
                               TargetName="Disk"
                               TargetId="DiskId"
                               TargetType="Device"
                               HlkBuildVersion="10.000.10020.10020"
                               TestPassIdentifier="TP001"
                               OsPlatform="Windows 10 Client x64">
                               <ContentLevelSet>Reliability</ContentLevelSet>
                               <ContentLevelSet>Certification</ContentLevelSet>
                               <ScheduleOptionSet>Distributable</ScheduleOptionSet>
                               <ScheduleOptionSet>MultipleDEvices</ScheduleOptionSet>
                               <FeatureMapped>Device.Storage.Hd</FeatureMapped>
               </TestCollectionRecord>
</ArrayOfTestCollectionRecord>

Where the attributes are defined as:

  • TargetId - Hardware Id of the target on the test computer

  • TargetName - friendly name of the Target on the test computer

  • OSPlatform - version of Windows on the test computer for the specified Target

  • Guid - Job ID detected for testing the Target

  • Name - friendly name of the Job detected for testing the Target

  • TestPassIdentifier - string value, identifying the test pass.

  • TargetType - type of the product tested in the project (device, system, or filter)

  • Feature Mapped - feature that detected Job will test for the Target

  • ContentLevelSet - categories of the Job detected for testing the Target

  • ScheduleOptionSet - options for test scheduling. Valid values are:

    • Manual - test requires manual actions at execution time

    • Distributable - test can be scheduled for multiple computers and run on the first available computer.

    • MultipleDevices - test can be run on multiple devices simultaneously on the same computer

    • MultipleMachines - test can be scheduled to run on multiple computers with different roles

    • SpecialConfiguration - test requires special computer configuration in order to run the test

  • HLKBuildVersion - version of HLK that was used to generate the test collection

Step 5: Filter the full list of tests on the Controller

You can use the Management Tool PowerShell cmdlet, Import-HwCertTestCollectionFromXml, to filter the full list of tests by a specified attribute value. (This step is optional.) Any attribute of the generated output xml file, as listed in step 4, can be used for filtering the list. The output test collection test records should be arranged in the required order for scheduling. In the following example, the Basic test category is used for filtering and sorting the master list. Type the following command in a Windows PowerShell session:

Import-HwCertTestCollectionFromXml -Input C:\Temp\master.xml | ? { $_.ContentLevelSet.Contains("Basic") } | sort -Property GUID | Export-HwCertTestCollectionToXml -Output c:\temp\basic.xml

Step 6: Add filtered list of tests to the Project Definition File on the Controller

Use any text or xml editor to update the PDEF to add the location for the test collection input xml file and the location for the output test results. An example of the updated PDEF, C:\Temp\DefinitionFile\device-win8client-x64-auto-basic.xml, is given below.

<ProjectDefinitionData Controller="controllername" Database="HLKJobs" Timeout="120" User="user">
    <Project Name="Project-win8client-x64" TestCollectionReadLocation="C:\temp\basic.xml" TestCollectionStatusLocation="basic_collection_status.xml">
        <MultiDeviceTestGroup>true</MultiDeviceTestGroup>
        <TestStatusToSkip>Pass</TestStatusToSkip>
        <Product Name="Product-win8client-x64" OsPlatform="Windows 8 Client x64" MachinePool="Test">
            <Family Name="Family-win8client-x64">
                <Target TargetType="Device" Id="HWID"/>
            </Family>
            <Machine Name="TEST-CLIENT-A" Role="SUT"/>
            <Machine Name="TEST-CLIENT-B" Role="SUT"/>
        </Product>
        <Packages Path="C:\temp"/>
    </Project>
</ProjectDefinitionData>

Where the attributes are defined as:

  • TestCollectionReadLocation - path to the filtered test collection xml file

  • TestCollectionStatusLocation - path to the output xml file holding testing results

Step 7: Run the test project on the Controller

Run the following from a command line:

hlkexecutionengine.exe /Project "C:\Temp\DefinitionFile\device-win10client-x64-auto-basic.xml" /RunCollection

After the command completes, the following files are created:

  • A Package file name.hlkx is created for each test run at the location that is specified in the PackagePath attribute as defined in the PDEF (see Step 3: Create a test Project Definition File on the Controller or test server). The Package file name is composed from the Project friendly name and the Data and Time of the project run.

  • The results are presented in an XML file. An example results file (C:\temp\basic_collection_status.xml) is given below.

    <?xml version="1.0" ?>
<ArrayOfTestCollectionRecord
               xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
               mlns:xsd="http://www.w3.org/2001/XMLSchema">
               <TestCollectionRecord
                               Name="Disk Stress (LOGO)"
                               Guid="738735f7-245a-4b39-9d81-20339ce31fd4"
                               TargetName="Disk"
                               TargetId="DiskId"
                               TargetType="Device"
                               HlkBuildVersion="10.000.10020.10020"
                               TestPassIdentifier="TP001"
                               OsPlatform="Windows 8 Client x64">
                               <ContentLevelSet>Reliability</ContentLevelSet>
                               <ContentLevelSet>Certification</ContentLevelSet>
                               <ScheduleOptionSet>Distributable</ScheduleOptionSet>
                               <ScheduleOptionSet>MultipleDEvices</ScheduleOptionSet>
                               <FeatureMapped>Device.Storage.Hd</FeatureMapped>
                               <Result
                                              StartTime="2013-03-14T17:59:45.117-07:00"
                                              Status="Passed"
                                              FiltersAppliedCount="0"
                                              SourcePath="TEST-MACHINE-2A"
                                              InstanceId="67"
                                              FeatureDetected="Device.DevFund.CDA Device.DevFund.DriverFramework.AllDrivers Device.DevFund.DriverFramework.KMDF Device.DevFund.INF Device.DevFund.Memory Device.DevFund.Reliability.Interrupts Device.DevFund.Reliability Device.DevFund.ReliabilityDisk Device.DevFund.Security Device.DevFund.Server Device.Storage.Hd.Iscsi Device.Storage.Hd.MultipleAccess.PersistentReservation Device.Storage.Hd.PersistentReservation Device.Storage.Hd.ScsiProtocol Device.Storage.Hd" />
               </TestCollectionRecord>
</ArrayOfTestCollectionRecord>

    Where the attributes are defined as:

    • StartTime - Data and Time the test run started

    • Status - set to either pass or fail

    • FiltersAppliedCount - number of filters applied to the result log

    • SourcePath - file path to the package .hlkx file generated for the project run

    • InstanceID - Device instance ID of the Target on the test computer

    • FeatureDetected - features detected for the tested Target

Stopping/restarting test execution

You can stop and restart test runs at any time. Tests that are currently running on client machines will continue to run, but no further tests are scheduled. At most, the number of running tests is equal to the number of available machines, because the scheduling logic will not queue up more tests than available machines. While running tests will continue to execute (and can return test results back to the Windows HLK project), the status xml file that is generated by the Windows HLK Execution Engine tool will not contain the pass/fail value for those tests that were running at the time the process was stopped. Therefore, restarting a project can cause a set of tests to be run twice -- one time after the automation tool exited, and one time when the process restarts. Because early termination of the process generally implies that machine state issues need to be investigated, this re-run behavior of the final batch of previously scheduled tests is by design and is generally desired.

Stopping mechanism

You can stop the test process by typing a Ctrl-C command in the console window. The Windows HLK Execution Engine will stop executing new tests and will begin a short cleanup process, such as writing final status to the summary xml file and to the execution engine log.

Restarting mechanism

A basic high-level overview of the process is as follows:

  1. Using Windows HLK Studio, create an .hlkx package of the project that was running before you stopped the test process.

  2. Edit the Windows HLK Execution Engine project definition xml file to supply a new input and output status file.

  3. Restart HlkExecutionEngine.exe by using the project definition file.

  4. Use Windows HLK Studio to merge the two partial HLK projects into a new, complete .hlkx file.

  5. Runsthe Analyze phase on the compete .hlkx file as outlined in the "Subsequent Analyze options" section in this document.

Detailed steps of this process are as follows:

  1. To create an .hlkx package of the results that were completed prior to test execution being stopped, start Windows HLK Studio.

  2. In Windows HLK Studio, double-click the project name of the project that was stopped. The project name is the same as in the project xml file. (The project xml file can be found under C:\Users\LocalAdminUser\Desktop\PDEF_Files, in a time-stamped folder.)

  3. In Windows HLK Studio, on the Package tab, click Create Package and save the package.

    NOTE

    The following step must be performed only if the initial test pass was run by having the client machines starting in the Default Pool.

  4. Because tests can run only when machines are in a non-Default Pool, and because the Windows HLK Execution Engine does not wait for all currently running tests to complete prior to completing a Ctrl-C operation, all machines will remain in their existing machine pool after Windows HLK Execution Engine stops. If the original project xml file specified machines in the Default Pool, then you must move the client machines back to the Default Pool. You can do this by using the Configuration menu that is located at the top of the Windows HLK Studio UI, or through the Windows HLK Manager application.

  5. After the partial .hlkx package is generated, you must update the Windows HLK Execution Engine project file to prepare for the remaining run. Navigate to C:\Users\LocalAdminUser\Desktop\PDEF_Files, and find the correct time-stamped folder from the test run. In the set of xml files in the folder, the project xml file is the one that is not preceded with "Status_", "FTC_", or "TC_". In Notepad or other text editor, edit this file as follows:

    In the project xml file, two fields must be edited: TestCollectionReadLocation and TestCollectionStatusLocation. For the Windows HLK Execution Engine tool to know where to resume, the previous TestCollectionStatusLocation value (the xml output file of results) must become the input file. Copy the value of TestCollectionStatusLocation to the TestCollectionReadLocation value. Then, set a new TestCollectionStatusLocation value. The TestCollectionStatusLocation value can be any value; for example, "C:\Users\LocalAdminUser\Desktop\PDEF_Files\Rerun.xml".

    Optionally modify the Project node Name value to make the project easier to find in HLK Studio later on. (Because the current Name value has already been used, Windows HLK Execution Engine will create a new project name.)

  6. To restart the tool, open a new command prompt window by using administrator privileges. Navigate to the Windows HLK Studio directory (%wttstdio%). Type the following command:

    HlkExecutionEngine.exe /Project <project xml file location> /RunCollection

    This command starts the Windows HLK Execution Engine, which resumes by using the previous set of tests that were running before the tool stopped. Execution can continue until all tests are completed.

  7. After the second set of tests are finished, you must merge the two projects together. To do this, open Windows HLK Studio. Look at the most recent projects that were created - typically the most recent project is from the second execution run that was performed (unless other users are also creating projects during this time). Or, if you changed the project Name value in the project xml file, you can identify the project by the new Name.

  8. Double-click the new project that was created from the second run. On the Package tab, click Merge Package. In the Package To Merge dialog, click Add and navigate to the first partial .hlkx package that was created from the first run of HLK Execution Engine. Click Save and click Create Package in the main window.

Step 8: Analyze the test results in Excel

You can use a Management Tool PowerShell command to generate the aggregated list of test results for the project. You can then analyze the aggregated results in Excel.

There are two ways to aggregate the list of test results for a project.

  1. Use the XML-based output files. An example of how you can merge XML-based test results from the Windows PowerShell session that is open on your Controller or test server is shown here:

    dir -s "c:\temp\*.xml" | Merge-HwCertTestCollectionFromXml -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_1.xml"  -TestPassIdentifier "TP003"
dir -s "c:\temp\*.xml" | Merge-HwCertTestCollectionFromXml -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_2.xml"  -TestPassIdentifier "TP004"

  2. Use the project .hlkx output files. An example of how you can merge .hlkx output files from the Windows PowerShell session that is open on your Controller or test server is shown here:

    dir -s "c:\temp\*.hlkx" | Merge-HwCertTestCollectionFromPackage -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_1.xml" -TestPassIdentifier "TP003"
dir -s "c:\temp\*.hlkx" | Merge-HwCertTestCollectionFromPackage -ValidationXmlPath "C:\temp\master.xml" | Export-HwCertTestCollectionToXml -Output "C:\Temp\merged_2.xml" -TestPassIdentifier "TP004"

When ValidationXmlPath is specified as a parameter to the Merge-HwCertTestCollectionFromXml or Merge-HwCertTestCollectionFromPackage cmdlet, the aggregation algorithm verifies if all of the tests listed in the master test collection have at least one result specified for the aggregation in any of the test collection files. This condition is checked only for the test collections that have the same TestPassIdentifier value as specified in the TestPassIdentifier cmdlet parameter. If this condition is not true, the aggregation is cancelled and an error occurs.

To determine which tests are not run for the test pass, include the master test collection into the list of test collection files that are specified for aggregation, but do not specify the ValidationXmlPath. In this case, the output aggregated test collection is generated. The collection contains all tests that are listed in the master collection, although some of them may not have results.

The aggregated list of test results (C:\temp\merged.xml) includes information for the full list of tests. If any of the required tests were never run, the aggregated list of tests results shows that a required test was not run. Because all test results are merged, running multiple test runs by using the same TestPassIdentifier attribute name value can create inconsistent results reporting. We recommend that you use a different name for each test pass.

After you have created an aggregated list of test results, you can generate an Excel spreadsheet by using commands in the Windows PowerShell session on the Controller or test server. An example of the commands that will create the Excel spreadsheet report is given here:

New-HwCertTestCollectionExcelReport ("C:\Temp\merged_1.xml", "C:\Temp\merged_2.xml" ) -ExcelPath 'c:\temp\report.xls' -ResultCount 1

Where ResultCount is defined as the maximum number of the most recent results, which is stored in the Excel report for each test.

An example of the output created after running the commands to create an Excel spreadsheet report is shown below.

hlk automation tool example of excel results

The resulting Excel report will contain the following headings:

  • Total Test - The total number of tests in this test pass.

  • Total Pass - The total number of results in this test pass

  • Total Pass With Filter - The total number of passes with an errata filter applied to the test.

  • Total Pass Percentage - Percentage of passing tests (Total Pass / Total Test).

  • Total Fail - The total number of fails in this test pass (Total Test - Total Pass).

  • N-1 Improvement - Between this test pass and the previous test pass (column to the left), how many new passes were achieved.

  • N-1 Regression - Between this test pass and the previous test pass (column to the left), how many new fails were encountered.

  • N-1 Not Changed - Between this test pass and the previous test pass (column to the left), how many tests did not have a change in result outcome.

  • N-1 Not Compared - Between this test pass and the previous test pass (column to the left), how many tests were not compared due to the test was only available in only one of the test passes.

PDEF reference

Auxiliary information that is specified in the PDEF

Some projects require Test-specific information for discovering and executing tests. This information includes:

  • Test parameters that do not have default values in the tests definition. Optional <Parameter> elements can be specified in multiple places (see PDEF schema):

    • Under the <Test> element. In this case, the parameter value is specified for the particular Test.

    • Under the <Family> element. In this case, the parameter value is applied for all Tests for all Targets in the Family, unless it is overwritten by the value of the same parameter that is specified for the Test

    • Under the <Product> element. In this case, the parameter value is applied for all Tests for all Targets in the Product, unless it is overwritten by the value of the same parameter specified for the Family or for the Test.

  • Target features, which cannot be detected automatically. Optional <ManualSelectedFeature> elements can be specified under the <Target> element. If specified, these features, together with automatically detected features, participate in the Tests discovery and Test Collection generation.

Project Definition File Schema

<?xml version="1.0" encoding="UTF-8"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<xsd:attribute name="User" type="xsd:string"/>
<xsd:attribute name="Controller" type="xsd:string"/>
<xsd:attribute name="Timeout" type="xsd:nonNegativeInteger"/>
<xsd:attribute name="Database" type="xsd:string"/>
<xsd:attribute name="Name" type="xsd:string"/>
<xsd:attribute name="Value" type="xsd:string"/>
<xsd:attribute name="TestCollectionReadLocation" type="xsd:string"/>
<xsd:attribute name="TestCollectionStatusLocation" type="xsd:string"/>
<xsd:attribute name="OsPlatform" type="xsd:string"/>
<xsd:attribute name="MachinePool" type="xsd:string"/>
<xsd:attribute name="Path" type="xsd:string"/>
<xsd:attribute name="Role" type="xsd:string"/>
<xsd:attribute name="TargetType">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:pattern value="((S|s)(Y|y)(S|s)(T|t)(E|e)(M|m))|((D|d)(E|e)(V|v)(I|i)(C|c)(E|e))|((T|t)(A|a)(R|r)(G|g)(E|e)(T|t)(C|c)(O|o)(L|l)(L|l)(E|e)(C|c)(T|t)(I|i)(O|o)(N|n))"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:attribute>
<xsd:attribute name="Id" type="xsd:string"/>
<xsd:attribute name="CrashDumpCopyBack">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:pattern value="((D|d)(I|i)(S|s)(A|a)(B|b)(L|l)(E|e)|(M|m)(I|i)(N|n)(I|i))|(K|k)(E|e)(R|r)(N|n)(E|e)(L|l)|((F|f)(U|u)(L|l)(L|l))"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:attribute>
<xsd:element name="ProjectDefinitionData">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Project" minOccurs="1"  maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="User" use="optional"/>
<xsd:attribute ref="Controller" use="required"/>
<xsd:attribute ref="Timeout" use="optional" default="120"/>
<xsd:attribute ref="Database" use="optional" default="HLKJobs"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Project">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="MultiDeviceTestGroup" minOccurs="0" maxOccurs="1"/>
<xsd:element ref="TestStatusToSkip" minOccurs="0" maxOccurs="unbounded"/>
<xsd:element ref="Product" minOccurs="1" maxOccurs="unbounded"/>
<xsd:element ref="Packages" minOccurs="1" maxOccurs="1"/>
</xsd:sequence>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="TestCollectionReadLocation" use="optional"/>
<xsd:attribute ref="TestCollectionStatusLocation" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="MultiDeviceTestGroup" type="xsd:Boolean"/>
<xsd:element name="TestStatusToSkip">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:pattern value="((P|p)(A|a)(S|s)(S|s))|((F|f)(A|a)(I|i)(L|l))|((N|n)(O|o)(D|d)(A|a)(T|t)(A|a))"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:element>
<xsd:element name="Product">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Family" minOccurs="1" maxOccurs="unbounded"/>
<xsd:element ref="Machine" minOccurs="0" maxOccurs="unbounded"/>
<xsd:element ref="Parameter" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="OsPlatform" use="required"/>
<xsd:attribute ref="CrashDumpCopyBack" use="optional"/>
<xsd:attribute ref="MachinePool" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Family">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Target" minOccurs="1" maxOccurs="unbounded"/>
<xsd:element ref="Parameter" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="Name" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="ManualSelectFeature" type="xsd:string"/>
<xsd:element name="Target">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="ManualSelectFeature" minOccurs="0" maxOccurs="unbounded"/>
<xsd:element ref="Test" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="TargetType" use="required"/>
<xsd:attribute ref="Id" use="required"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Test">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Parameter" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="Id" use="required"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Parameter">
<xsd:complexType>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="Value" use="required"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Machine">
<xsd:complexType>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="Role" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Packages">
<xsd:complexType>
<xsd:attribute ref="Path" use="required"/>
</xsd:complexType>
</xsd:element>
</xsd:schema>

Related topics

HLK Tools Technical Reference


HLK Mobile Testing Tools and Utilities

Several command line tools are provided with the HLK for onboarding and device control.

KitsDeviceDetector.exe

KitsDeviceDetector is used during the Mobile Test system onboarding process.

Usage

KitsDeviceDetector.exe /<parameter>:<parameter value> …

Supported parameters

Parameter | Description
/ImagePath:<Path to image.ffu> | Optional. If supplied, the image will be flashed to the device.
/ImageProfile:<Default|Health|Retail> | Optional. Valid types are Default, Health, Retail.
/LowCost:<true/false> | Optional. Informs the HLK that we are testing a low cost device.
/SDMemory:<true/false> | Optional. Informs the HLK tests that the device has an additional SD memory card.
/SDCardImageInstalled | Optional.
/DeviceName:<device name> | Required when onboarding USB connected phone.
/DeviceId:<device ID> | Required when onboarding USB connected phone.
/DeviceMacAddress:<Device MAC address> | Optional. Derived from DeviceId when onboarding USB connected phone.
/? | Prints the help menu.
/logical:<logical connection> | Optional. Specifies the logical connection DLL. Default value is WPConLC.dll.
/physical:<physical connection> | Specifies the physical connection DLL. Optional with Aries connected devices. Required with USB connected devices.
/machinepool:<machine pool> | Required. Name of the machine pool to place the onboarded device.
(/DeviceFilters:<comma-delimited-list>) | Note /DeviceFilters only applies to certain physical connection plugins. The value should be a comma or semi-colon delimited list of devices to limit the scope of discovery.

Examples

KitsDeviceDetector /ImagePath:\\servername\images\image.ffu
            /devicefilters:device1,device2 /ImageProfile:Default
            /LowCost:true /SDMemory:true

[Using USB-attached device]

KitsDeviceDetector /Physical:Fake_PC.dll
            /machinepool:$\User
            /DeviceName:my-device
            /DeviceID:00000011-abc1-abc1-0000-000000000000

AriesUtil.exe

AriesUtil.exe enables initial device discovery and provides a means to carry out operations on the Aries dongle or connected device. The tool exposes the following capabilities:

  • Send a discovery broadcast
  • Enumerate all Aries that have been associated / registered with this host
  • Get the firmware version of the Aries
  • Set the port used to route debug messages from the device to the host
  • Set the port used to route log messages from the Aries itself to the host
  • Power cycle the attached device
  • Power cycle the Aries itself
  • Flash an image to the attached device
  • Flash firmware to the Aries itself

Usage

AriesUtil.exe <action> [action-arguments ...]

Supported actions

Action | Description
Help [<action-name>] | Display general help, or help for a specific command.
Enumerate | List Aries that have been registered with this host.
Discover [/Aries:<aries-names>] [/Adapter:<adapter>] [/TTL:<ttl>] [/TimeoutSec:(<seconds>|infinite) | /TimeoutMin:(<minutes>|infinite)] [/BroadcastAddr:<addr>][/BroadcastPort:<port>] [/ListenPort:<port>]

List the Aries that respond to a discovery broadcast.

The most common use case will specify no arguments.

/Aries

Use to specify a filter list of Aries to look for responses from.

  • Once all specified Aries are found the discovery can end before the timeout expires.
  • If not specified, then discovery will proceed to list any Aries that respond until the timeout expires.
  • The argument value can be a single Aries name, or a comma or semi-colon delimited list of Aries names. It can also be the wildcard asterisk () character, in which case all Aries registered on the current host will be considered.
/Adapter

Use to specify the network adapter to issue the discovery broadcast across.

/TTL

Use to specify time-to-live of the discovery broadcast.

/TimeoutSec

Use to specify the discovery broadcast timeout in seconds.

/TimeoutMin

Use to specify the discovery broadcast timeout in minutes.

/BroadcastAddr

Use to specify the discovery broadcast IP address to send to.

/BroadcastPort

Use to specify the discovery broadcast destination port to send to.

/ListenPort

Use to specify the discovery broadcast response port to listen on.
GetFirmwareVersion /Aries:<aries-name>

Gets the firmware version currently installed on the specified Aries.

The /Aries argument value can be a single Aries name, or a comma or semi-colon delimited list of Aries names. It can also be the wildcard asterisk () character, in which case all Aries registered on the current host will be selected.
MapDebugPort /Aries:<aries-name> /Port:<port-number> | Sets debug output for the device attached to the Aries to be routed to the local host on the specified port.
MapSysLogPort /Aries:<aries-name> /Port:<port-number> [/Frequency:<minutes>] [/Verbosity:<Critical|Error|Warning|Informational>]

Sets SysLog output for the device attached to the Aries to be routed to the local host on the specified port. The Frequency option controls how often the Aries will broadcast its own health heartbeat, which will be 5 minutes by default.

Verbosity controls the maximum log level that will be displayed. Informational is the default.
ResetDevice /Aries:<aries-name> [/AutoSkip:<true|false>] | Resets the device attached to the specified Aries. By default, AutoSkip is turned off.
ResetAries /Aries:<aries-name> [/Wait:<seconds>] [/SkipFail]

Power cycle the Aries aries itself. If the /Wait option is specified, the tool will wait for up to the specified number of seconds for the Aries to come back online before exiting.

The /Aries argument value can be a single Aries name, or a comma or semi-colon delimited list of Aries names. It can also be the wildcard asterisk () character, in which case all Aries registered on the current host will be selected.

If the /SkipFail argument is specified, any failures encountered during the operation will be ignored until the entire Aries list has been processed.
FlashDevice /Aries:<aries-name> /ImagePath:<path-to-image.ffu> | Flashes an FFU image onto the device attached to the specified Aries.
FlashAries /Aries:<aries-name> /App:<path-to-app-file> [/MLO:<path-to-mlo-file>] [/Wait:<seconds>] [/SkipFail]

Flashes a firmware update to the Aries itself.

If the /Wait option is specified, the tool will wait for up to the specified number of seconds for the Aries to come back online before exiting.

If the /MLO option is specified, the loader will be flashed to the Aries prior to the flashing the App.

The /Aries argument value can be a single Aries name, or a comma or semi-colon delimited list of Aries names. It can also be the wildcard asterisk () character, in which case all Aries registered on the current host will be selected.

If the /SkipFail argument is specified, any failures encountered during the operation will be ignored until the entire Aries list has been processed.
StartPowMon /Aries:<aries-name> [/OutFile:<Output>] [/Duration:<seconds>]

Starts a power monitoring session for the specified Aries if one does not yet exist.

Note that power monitoring is a blocking action. To stop an active power monitoring session a StopPowMon action must be invoked.

If the /OutFile option is specified, the name of the output file containing the power sampling data will be the value passed in rather than the default.

If the /Duration option is specified, then the power monitoring session will only last for the specified duration. The duration is in seconds.

The /Aries argument value can be a single Aries name only.
StopPowMon /Aries:<aries-name> | Stops the active power monitoring session for the specified Aries if one exists.
SignalOn /Aries:<aries-name> | Turn on the LED pulsing for both the Aries and the Beagle Bone.
SignalOff /Aries:<aries-name> | Turn off the LED pulsing for both the Aries and the Beagle Bone.

Examples

Aries discovery:

AriesUtil.exe Discover

Flash an Aries-connect mobile device:

AriesUtil.exe ...

Turn on Autoskip:

AriesUtil.exe ResetDevice /Aries:myaries [/Autoskip:true]


Troubleshooting Windows HLK

This section provides troubleshooting support articles for Windows Hardware Lab Kit (Windows HLK).

In this section:

Topic | Description
Troubleshooting the Windows HLK Environment | Provides general troubleshooting information on installing and running HLK environment.
Troubleshooting Windows HLK Test Failures | Provides video demonstrations and troubleshooting information related to all HLK tests.
Windows HLK Support | How to get help from Microsoft.

Additional troubleshooting resources

The following articles provide additional troubleshooting assistance:

Article | Description
Bug Check Code Reference | This article provides a list of bug check error codes for kernel debugging.
Debugging Resources | This site provides tools to debug drivers, applications, and services on Windows systems.
Interpreting a Bug Check Code | This article contains information about bug checks when you use a kernel debugger.
Setting Up Kernel-Mode Debugging in Visual Studio or Setting Up Kernel-Mode Debugging Manually | This article describes how to set up kernel debugging
Troubleshooting the Device Fundamentals tests using WDK | This article contains troubleshooting content for device driver developers.
Using KDbgCtrl | This article describes how to use the kernel debugger.
Windows Debugging | This site contains a collection of debuggers and related tools.
Windows Hardware Lab Kit Filters | This site contains the latest Windows HLK filters and kit updates.


Troubleshooting the Windows HLK Environment

Troubleshooting the Windows Hardware Lab Kit

This topic contains information to help you to troubleshoot Windows Hardware Lab Kit (Windows HLK) issues.

To troubleshoot testing problems, see Troubleshooting Windows HLK Test Failures. For Microsoft® support for Windows HLK testing, see Windows HLK Support.

Related topics

Troubleshooting Windows HLK


Troubleshooting Windows HLK Client

This topic describes how to troubleshoot issues with the Windows Hardware Lab Kit (Windows HLK) Client.

For help with problems that occur during Windows HLK Client setup, see Troubleshooting Windows HLK Setup.

Cannot get a client computer out of Debug state

Problem. The Client does not change from the Debug state to the Ready state, even after changing the state to Reset in Windows HLK Manager.

This problem can be caused by a lack of communication between the Windows HLK Controller computer and the Windows HLK Client computer, or by a trusted key mismatch between the two systems.

Try these solutions in the following order:

  1. Try the solutions in Client computers cannot communicate with the Windows HLK Controller.

  2. Reinstall the Client using the steps in Remove and reinstall the Windows HLK Client.

Cannot select tests after previous test fails

After a test fails, the checkboxes for the list of tests are dimmed and you cannot select additional tests.

If you select a target but cannot select any of the tests, the computer is not in a ready state.

Go to the Configuration menu and put the computer in a ready state.

Client computer goes to sleep during a test

An always on, always connected (AOAC) computer that is not an ARM machine can go to sleep during a test. To prevent this, run the following command from an elevated command prompt on each Windows HLK Client computer:

powercfg /setacvalueindex scheme_current sub_video videoidle 0 & Powercfg /setdcvalueindex scheme_current sub_video videoidle 0 & Powercfg /s scheme_current

Client computer is locked by an LLU account

If a client computer is locked by a LLU account or is unresponsive, you must log on by using the correct credentials for the LLU account. The two main LLU accounts on a client computer are:

  • Local Standard User account

    The client computer uses this account to run tests that require local standard user access on the client computer and any other computers with which it communicates. The local administrator account credentials can also be used for tests of this type, but the additional privileges might not be necessary.

    • LLU Name. LLU_LSU

    • UserName. <client machine name>\WDKLclStdUsr

    • Password. WDKStdTstUsr!

  • Local Administrative User account

    The client computer uses this account to run tests that require local administrator access on the client computer and any other computers with which it communicates.

    • LLU Name. LLU_LAU

    • UserName. <client machine name>\LLUAdminUser

    • Password. Testpassword,1

Client computers cannot communicate with the Windows HLK Controller

If a client computer cannot communicate with the Windows HLK Controller, review the following problems and solutions:

  • Client computers do not appear in the Machine List in the Windows HLK Manager Job Monitor window.

  • Client computers can't connect to the Controller computer.

  • Client computers do not process jobs in the job Scheduler in Windows HLK Manager.

  • Client computers always go to the debug state, even after a reset.

Try these solutions in the following order:

  1. Review the steps in Step 2: Install Client on the test computer(s) and check basic networking connectivity between the two computers.

  2. Run the procedure To change the Windows HLK Client to a Home or Private network.

  3. Make sure the Internet Connection Firewall (ICF) port for Windows HLK is open on both the Windows HLK Client and Windows HLK Controller computers.

    To open an ICF port for Windows HLK in Windows 7

    1. Open Control Panel.

    2. Click System and Security >Windows Firewall > Advanced Settings > Inbound Rules.

    3. Make sure that WLK Client is present and enabled.

    4. If WLK Client isn't there, click New Rule, click Port, and then click Next.

    5. Type 1771 in the Specific local ports box, click Next twice for Allows the Connection.

    6. Leave all Profiles checked and click Next.

    7. For Name, type WLK Client and then click Finish.

    To open an ICF port for Windows HLK

    1. Open Control Panel.

    2. Click Security >Windows Firewall > Change Settings.

    3. Click the Exceptions tab. Make sure that WLK Client is present and selected under Programs and Services.

    4. If WLK Client does not appear, click Add Port and enter this information:

      • In the Name box, type WLK Client.

      • In the Port number box, type 1771.

      • Click the TCP button, and then click OK.

    5. Return to the exceptions tab and make sure that the WLK Client check box is selected, and then click OK.

  4. Disable Internet Protocol security (IPsec)

    For Windows HLK Client and Windows HLK Controller computers to communicate, all computers must either be running IPsec or all computers must have IPsec disabled.

    To disable IPsec

    • At a command prompt, type net stop ipsec, and then press Enter.

    To change IPSec properties

    1. At a command prompt, type services.msc, and then press Enter. The Microsoft Management Console appears.

    2. Double-click IPsec Policy Agent and change its Startup Type (Automatic | Manual | Disabled) and/or Service Status (Start | Stop).

Client information in HLK Studio is inaccurate

The Windows HLK Client information that shows in Windows HLK Studio can be inaccurate if the gatherer data is not current. Inaccurate information can include the following data:

  • Missing or detected features.

  • Missing or extra tests.

  • Drivers that are included with the operating system are reported as not being included.

    Drivers that are not included with the operating system are reported as being included.

To work around this issue, perform the following steps:

  1. Restart the Windows HLK Client computer.

  2. (Optional) Delete the project in Windows HLK Studio.

  3. (Optional) Reset the status of the client computer in Windows HLK Manager Job Monitor.

  4. Close all instances of Windows HLK Studio and Windows HLK Manager.

  5. Restart Windows HLK Studio.

  6. Create a new project and add the Windows HLK Client computer to the machine pool.

Client software is not uninstalled from the test system

This problem occurs when the entry in the database for the Windows HLK Controller is deleted for the test system. After ten minutes or less, the client software sends out a new signal (heartbeat) and the controller generates a new client entry in the database. After the client entry appears, the client is visible in the Configuration screen in Windows HLK Studio; however, when you select the machine pool on the Selection tab, no targets are listed for the system.

To resolve this problem, get a gatherer to return some new data. You can do this by installing a driver or hardware or by restarting the client system.

Error encountered while adding user <domain\username>

When you try to create a user account for a domain user, the following error message appears:

Error encountered while adding user <domain\username>

Cannot grant/remove permission for user on data store controller name: User username does not exist in domain domain. Please ensure that user name is valid or contact your network administrator.

The domain that the error message refers to is the local machine domain. You cannot create a user account for a domain user if you are logged onto the Windows HLK Studio computer as a local Administrator. You must log off and log back on as a domain user who has Administrator rights, and then create the user account for the domain user.

Error: Skipped as Public key is null for the machine

When you try to add a local logical user (LLU) to a client computer, the following error appears:

Skipped as Public key is null for the machine.

This error means that the Windows HLK Client did not install correctly. To fix this problem, uninstall and reinstall the Windows HLK Client. For more info, see Remove and reinstall the Windows HLK Client.

Job is stuck in the Scheduler

When you set up a job, Windows Scheduler searches for a client computer to run the job. The Scheduler considers all client computers in the machine pool that are available and capable of running the job.

When you use Windows HLK Manager Job Monitor to view the status of a job, the Current Pipeline column of the Job Execution Status pane displays the job status. If the Current Pipeline value for your job is Scheduler, and if this value hasn't changed for several minutes, make sure that a Windows HLK Client in the machine pool with a Ready status exists.

  • If no Windows HLK Client computers are ready to run jobs, see Step 3: Create a machine pool.

  • If Windows HLK Client computers are available to run the job, make sure that at least one Windows HLK Client computer is capable of running the job. Check the attributes of the Windows HLK Client computers and compare them with the job requirements.

  • If a job contains machine sets, confirm that there are enough Windows HLK Client computers to meet the requirements of all machine sets. Windows HLK schedules all of the Windows HLK Client computers at the same time.

If a job remains unchanged in the Scheduler, make sure that the SQL Server (MSSQLSERVER), WLKSvc, and DTMSERVICE services are started in services.msc.

Jobs do not run after reinstalling the Windows HLK Client

Previously scheduled jobs do not run if you have installed the Windows HLK Controller and Windows HLK Studio, scheduled some jobs, and then uninstalled and reinstalled the Windows HLK Client.

In this case, you must establish a new connection between the Windows HLK Client computer and the Windows HLK Controller computer by uninstalling and reinstalling the Client. For information on how to do this, see Remove and reinstall the Windows HLK Client.

Multiple client systems are identified as the same system

Client systems are identified through a pair of hashes. These hashes are individually composed of the following data sets:

Hash1:

smbios UUID
smbios serial number
smbios manufacturer
smbios model
smbios SKU number

Hash 2:

mac address 0
driver 0 vendor
driver 0 product
driver 0 serial number

This characteristic allows you to change the hardware while retaining the same machine identifier. However, if the hashes are too similar between two (or more) different systems, the systems are identified as the same system. This causes the last system's heart-beat to be the active client.

To prevent this from happening, the hash data should be unique for each client system. The easiest values to update are smbios UUID and smbios serial number.

You can see these values in the CLIENTMACHINE gatherer data. This log does not determine these values and modifying this log does not prevent or resolve the problem.

This log exists at %SystemDrive%\WLK\JobsWorkingDir\AssetCfg\Log.

Remote Desktop cannot connect to a Windows HLK Client computer

If Remote Desktop cannot connect to a Windows HLK Client computer, make sure that Remote Desktop is a Windows Firewall exception.

To allow a Remote Desktop connection in Windows 7

  1. Open Control Panel.

  2. Click System and Security > Windows Firewall > Allow a program or feature through Windows Firewall.

  3. Click the Remote Desktop check box, and then click OK.

To allow a Remote Desktop connection in Windows Vista

  1. Open Control Panel.

  2. System and Security Security > Windows Firewall > Change Settings.

  3. Click the Exceptions tab.

  4. Click the Remote Desktop check box, and then click OK.

Remove and reinstall the Windows HLK Client

WARNING

Do not remove the Windows HLK Client as the first step in troubleshooting Windows HLK Client problems. If you reinstall the Windows HLK Client, any certification testing in progress is lost and you have to rerun all the tests in a new project.

To remove and reinstall the Windows HLK Client

  1. Uninstall the Windows HLK Client (Control Panel > Uninstall a program > Windows Hardware Certification Kit Client.)

  2. Start the Windows HLK Manager, go to Explorers | Job Monitor, right-click your computer, and then select Change Status -> Unsafe to set the computer to the Unsafe state.

  3. Install the Windows HLK Client by using the steps in the Step 2: Install Client on the test system(s) topic.

  4. Wait for the computer to go into the Manual state in HLK Manager | Job Monitor, below the Status column.

  5. Go to Explorers | Job Monitor, right-click your computer, and then select Change Status -> Reset.

  6. Wait for the computer to automatically return to the Ready state, or click Refresh in Windows HLK Manager.

SQL Server updates cause Windows HLK Client to crash

SQL Server updates can cause the Windows HLK Client to crash. To fix, disable automatic updates while running HLK tests:

  • Windows 10
    1. Open the Settings app
    2. Select Update & security
    3. Select Windows Update
    4. Choose Advanced Options
    5. Choose the defer upgrades option
  • Pre-Windows 10
    1. Open Control Panel
    2. Select Windows Update
    3. Select Change settings
    4. Choose an option that disables automatic updates

Client computer goes to Windows diagnostics mode after installing HLK client

If you are prompted the check the C:\Windows\System32\LogFiles\srt\SrtTrail.txt log file and receive the following Error:

Root cause found:
----------------------------
Boot critical file c:\windows\system32\drivers\msdmfilt.sys is corrupt.

SecureBoot will need to be disabled from within BIOS/UEFI. Unless you are running SecureBoot tests on the device/system, SecurBoot needs to be disabled to run HLK tests.

Unsupported scenarios

The following scenarios are not supported by the Windows HLK Client:

  • Multiple operating systems. Installing multiple operating systems on a computer with the Windows HLK Client installed is not supported. If you have more than one operating system installed on a computer, and multiple instances of Windows HLK Client installed, you might cause errors than cannot be fixed without reinstalling the operating system.

    Only one instance of Windows HLK Client should be installed on the system under test. In this scenario, the system includes all related physical discs and partitions.

  • Testing on multiple client computers. If you are using multiple client computers to complete a test project, you must use the same client computers to complete and also package the test project in Windows HLK Studio. For example, if one computer is testing for Windows 7 x86 and another computer is testing for Windows 7 x64, you must complete and package all testing on each computer before you make any changes to a system or operating system. If you change anything about the client computer, you might invalidate the project and then have to restart the test by using a new project. You might need to restart your test project if you make any of these changes:

    • Change the computer name

    • Reinstall the Client

    • Reinstall the operating system

    • Move the computer from a DOMAIN to a WORKGROUP or from a WORKGROUP to a DOMAIN.

If you have one of the above unsupported scenarios on a Windows HLK Client computer, you might have no heartbeat, jobs stuck in the Scheduler, or jobs that do not run.

To re-establish a working test environment, change the Windows HLK Client system back to its original state to continue and complete the test submission. Optionally, uninstall and reinstall Windows HLK Controller and Windows HLK Client so that all systems are either joined to a domain or part of a workgroup.

Watched system does not have a heartbeat

If you select a machine pool in configuration, and watch the test system from the configuration screen, the heart-beat, that is, the user interface (UI) time stamp, does not update.

This is a Windows HLK Studio UI issue. The system does continue to heart-beat, but the UI just does not update.

To update the heart-beat time stamp, switch machine pools.

Windows 7 Clients do not enter the Ready state

Problem. A test Windows HLK Client appears in the Default Test Pool and has a recent heartbeat, but when you change the state of the Client to Reset, the status does not change to Ready and it eventually changes to Debug.

If the test computer is connected to a public network, the Windows HLK Client does not enter the Ready state because the public network category is restrictive, and network discovery is turned off by default.

Solution. Change the network location of the Windows HLK Client.

To change the Windows HLK Client to a Home or Private network

  1. On the client computer, open Control Panel, click Network and Internet, and then click View network status and tasks.

  2. On Windows 7, if the network under View your active networks is set to Public Network, click Public Network, and then change it to Home network.

    -or-

    On Windows Vista, if the Network category (under Network Details) is set to Public network, click Change, and then click Private.

The Windows HLK Client status changes from Reset to Ready, and this action reinstalls the Windows HLK Client on the computer.

Related topics

Troubleshooting the Windows HLK Environment


Troubleshooting Windows HLK Controller

This topic describes how to troubleshoot issues with the Windows Hardware Lab Kit (Windows HLK) Controller.

For help with problems that occur during Windows HLK Controller setup, see Troubleshooting Windows HLK Setup.

Cannot add test clients after installing the Windows HLK

After installing Windows HLK, the Windows HLK Controller cannot access the HLKJobs database. This prevents the Windows HLK Controller from responding to new clients or sending updates to existing clients.

To fix this problem, stop and restart the MSSQLServer service on the Windows HLK Controller by using Services Management Console (From a command prompt, type services.msc). The MSSQLServer service should be set to Automatic.

Transaction log is too large (standalone SQL Server 2012)

When using the HLK with standalone SQL Server 2012, if you find that your transaction log is growing too large or too fast, you may need to adjust your recovery configuration.

Unsupported scenarios

You must uninstall and reinstall the Windows HLK Controller if you make any of the following changes:

  • Rename the Windows HLK Controller computer.

  • Remove the Windows HLK Controller computer from a domain and add it to a workgroup.

  • Remove the Windows HLK Controller computer from a workgroup and join it to a domain.

Related topics

Troubleshooting the Windows HLK Environment


Troubleshooting Windows HLK Setup

This article contains information to help you to troubleshoot Windows Hardware Lab Kit (Windows HLK) installation and setup issues.

Cannot browse \\<controller-name>\HLKInstall\ on Studio or Client computer

If you cannot browse to the HLKInstall folder from the Windows HLK Studio or Client, review the setup and configuration information in the Step 1: Install Controller and Studio on the test server topic.

Cannot change or repair Windows HLK by using Control Panel

If you try to change or repair the Windows HLK by using Control Panel, you receive an error message that the repair failed. To change or repair your Windows HLK installation, use Control Panel to uninstall Windows Hardware Certification Kit, and then reinstall the Windows HLK See Step 1: Install Controller and Studio on the test server.

Cannot install HLK.AddLoggerEntries: Access is denied

In rare cases, Windows HLK setup might fail just before it completes. If you look at the Windows HLK Controller log, CA AddLoggerEntries appears with an Access is denied error. If this happens, run HLKSetup.exe again to see if the Windows HLK installs successfully. If setup fails again, see Windows HLK Support for instructions about how to contact Support. Include the *HLKControllerx86_en_us.log file from the %temp%\hlk folder. For information about how to review the Windows HLK Controller log file, see To review the Windows HLK Controller log file.

Cannot install the Windows HLK Client

If you cannot install the Windows HLK Client, review the installation info in the Step 2: Install Client on the test system(s) topic and make sure that you follow these instructions.

If you still cannot install the Windows HLK Client, locate these Client log files in the %TEMP% folder. See Windows HLK Support for information about how to contact Support, and share the following client log files with Microsoft Support:

  • WLKInstall.log

  • Windows Hardware Certification Kit Client_Install.log

  • Windows Driver Testing Framework (WDTF) Runtime Libraries_Install.log

  • Application Verifier x64 External Package_Install.log

  • WPTx64_Install.log

Cannot install or remove the Windows HLK Controller

If you encounter issues installing the Windows HLK Controller, confirm the following:

  • The operating system uses the English language (en-us) version of Windows Server 2008 R2 x64 or Windows Server 2012 and is not running as a domain controller.

  • The system language is set to US English. To do this, click Region and Language in Control Panel, click the Administrative tab, click Change system locale, and then select English (United States).

If you cannot install or remove the Windows HLK Controller, review the controller log file that is located in the %temp%\HLK folder.

To review the Windows HLK Controller log file

  1. At a command prompt, type %HomeDrive%, and then press Enter.

  2. Type cd %temp%\HLK, and then press Enter.

  3. Type dir *HLKControllerx86_en_us.log, and then press Enter.

  4. Open the log file in a text editor such as Notepad.

    NOTE

    If more than one file ends in HLKControllerx86_en_us.log, open the newest file. To open the log file in Notepad from the command line, type Notepad, the full file name, and then press Enter.

  5. Search for return value 3 to see which action failed. Error information is located a few lines above the string return value 3.

    MSI (s) (F4:74) [18:58:28:187]: Executing op: ActionStart(Name=CreateStandaloneEnterprise,,)
MSI (s) (F4:74) [18:58:28:187]: Executing op: CustomActionSchedule(Action=CreateStandaloneEnterprise,ActionType=17409,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\Program Files (x86)\Windows Kits\8.0\Hardware Certification Kit\Controller\WTTStandaloneEnterpriseSetup.exe" "TEST-SERVER" "HLKJobs" "C:\StandaloneEnterprise")
MSI (s) (F4:48) [18:58:28:187]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI9E59.tmp, Entrypoint: CAQuietExec
CAQuietExec:  Standalone Enterprise setup started by user TEST-SERVER\Administrator
CAQuietExec:  Error::
************************************************************ERROR REPORT (Exception levels including inner exceptions. Level 0 denotes outermost exception)
CAQuietExec:
CAQuietExec:  ------------START OF ERROR REPORT------------
CAQuietExec:
CAQuietExec:  Level            : 0
CAQuietExec:  Error Message    : Error while creating new data store  'HLKJobs' .
CAQuietExec:  Source           : Void CreateEnterprise(Microsoft.DistributedAutomation.DSLink, Microsoft.DistributedAutomation.ServiceCollection, Boolean)
CAQuietExec:  Inner Exception  : System.Runtime.InteropServices.COMException (0x80041432): Cannot create file 'C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\HLKJobs.mdf' because it already exists. Change the file path or the file name, and retry the operation.
CREATE DATABASE failed. Some file names listed could not be created. Check related errors.
CAQuietExec:     at Interop.SQLDMO.Databases.Add(_Database Object)
CAQuietExec:     at Microsoft.DistributedAutomation.SqlDataStore.SqlDataStoreSetup.CreateDeploymentDataStore(ServiceCollection serviceList, DSLink newDSLink)
CAQuietExec:  Call Stack       :    at Microsoft.DistributedAutomation.SqlDataStore.SqlDataStoreSetup.CreateEnterprise(DSLink identityDSLink, ServiceCollection serviceList, Boolean standaloneInstall)
CAQuietExec:     at Microsoft.DistributedAutomation.EnterpriseSetup.EnterpriseSetupHelper.CreateEnterprise(EnterpriseConfiguration enterpriseConfig, DSLink dsLink, String setupFilePath, Boolean standaloneInstall)
CAQuietExec:     at Microsoft.DistributedAutomation.EnterpriseSetup.Tools.CMain.Main(String args)
CAQuietExec:  Trace            :
CAQuietExec:
CAQuietExec:  Level            : 1
CAQuietExec:  Error Message    : Cannot create file 'C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\HLKJobs.mdf' because it already exists. Change the file path or the file name, and retry the operation.
CREATE DATABASE failed. Some file names listed could not be created. Check related errors.
CAQuietExec:  Source           : Void Add(Interop.SQLDMO._Database)
CAQuietExec:  Inner Exception  :
CAQuietExec:
CAQuietExec:  --------------END OF ERROR REPORT------------************************************************************
CAQuietExec:  Error 0x80070001: Command line returned an error.
CAQuietExec:  Error 0x80070001: CAQuietExec Failed
CustomAction CreateStandaloneEnterprise returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (F4:74) [18:58:30:137]: User policy value 'DisableRollback' is 0
MSI (s) (F4:74) [18:58:30:137]: Machine policy value 'DisableRollback' is 0
Action ended 18:58:30: InstallFinalize. Return value 3

If the *HLKControllerx86_en_us.log file includes Error while creating new data store 'Jobs', complete these steps:

CAQuietExec:  Error Message    : Cannot create file 'C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\HLKJobs.mdf' because it already exists. Change the file path or the file name, and retry the operation.
CREATE DATABASE failed. Some file names listed could not be created. Check related errors.

  1. Delete these files from the C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA folder:

    • HLKJobs.mdf

    • HLKJobs_Log.ldf

  2. Reinstall the Windows HLK Controller. For info on how to do this, see Step 1: Install Controller and Studio on the test server

Client installation fails with error "This app can't run on your PC"

The system returns an error "This app can't run on your PC" if you try to install Windows HLK Client software on a computer that is running Windows 8 RT. This is not a supported platform; however, you can install Windows HLK Client software on a computer that is running Windows RT 8.1.

Error: Failed to connect to database. Failed to connect to OM.

If you get an error message that states Failed to connect to database. Failed to connect to OM when you start Windows HLK Studio, make sure that your user account is added to the Windows HLK Controller. For instructions on how to add your user account to the Windows HLK Controller, see "Configure additional user accounts" in Install a remote HLK Studio.

Error: SQL client components are required for this operation

This error occurs when you attempt to install the full version of HLK (HLK Controller + Studio option), after you first downloaded the HLK product on a separate machine that already has the HLK Studio only option installed.

Workaround: Uninstall the HLK Studio-only version and try downloading and reinstalling the full HLK version again.

HLK setup fails with a database-related error

This error can occur when uninstalling and then reinstalling HLK. When the new instance of HLK is installed, one of the following error messages appears:

  • There is already an object named DSLinkType in the database.
  • The database database_name already exists.
  • Failed to create SQL database.

When uninstalling HLK, database uninstall can fail if the database is locked by another process. The HLK uninstall reports success, but the database is left behind.

To recover, follow these steps:

  1. From an elevated command prompt, run SQLCMD -E

  2. From the SQL Shell command line, enter the following:

    ALTER DATABASE WTTIdentity SET SINGLE_USER WITH ROLLBACK IMMEDIATE
DROP DATABASE WTTIdentity
GO
ALTER DATABASE HLKJobs SET SINGLE_USER WITH ROLLBACK IMMEDIATE
DROP DATABASE HLKJobs
GO

  3. Verify that C:\Program Files\Microsoft SQL Server\MSSQL(sql version).MSSQLSERVER\MSSQL\DATA contains no files starting with WTTIdentity or HLKJobs

  4. Install the HLK

Related topics

Troubleshooting the Windows HLK Environment


Troubleshooting Windows HLK Studio and Windows HLK Manager

This topic describes how to troubleshoot issues with the Windows Hardware Lab Kit (Windows HLK) Studio and Windows HLK Manager.

For help with problems that occur during Windows HLK Studio and Windows HLK Manager setup, see Troubleshooting Windows HLK Setup.

Archive is no longer supported

The archive state, available in HLK Manager, and the Archive pool should not be used under any circumstances.

An error message displays that is not specific to the failure

An error message appears that is not specific to the failure; it is the general error message that displays when the UI encounters an exception it has not specifically handled:

HLK Failure

HLK Studio encountered a critical failure and needs to exit now.\n\nPlease see Event Viewer for more details.

An exception is listed in the event log; however, the listed exception is not specific to the failure.

A workaround for this problem is to create a new project and restart testing again. The old project is corrupted.

You might be able to delete the results that are generated by the logical machine set (LMS) jobs that created this condition, but the names of the jobs are not the same for each instance.

Failed to start the task: Failed to GetUserToken

If the Windows HLK Client computer that is running the test does not have an active user logged in to an available session, this error message might appear:

Failed to Start the Task" : "Failed to GetUserToken for…

If you get this error, make sure that the Windows HLK Client computer is not locked or logged off.

Show all context menu command causes UI to become unresponsive when large (GB+) files are present

The Show all context menu command makes a copy of the log files to which the location points. Kernel and full dump files can be very large and can take a very long time to be copied. When the Show all command is used with very large files, the UI becomes unresponsive as it waits for the copy to complete.

The best way to get to a large kernel, log or dump file, is to go to the actual location where the file exists. To get to a dump file, open the DiagnosticLogManifest* file. (This is one of the logs that is populated by the client to the Diagonistic Logs context menu in the Results tab.) The contents are similar to the following:

<?xml version="1.0" encoding="utf-8"?>
<DiagnosticLogs>
  <DiagnosticLog Type="EventLog" Source="C:\Windows\TEMP\Working_b225172c-b7fc-4d9d-9a3e-393dc674b0b4\EventLog\Application.evt" Destination="\\10-1361B0111\HLKLogs\DiagnosticLogs\2a513b38-27df-4681-b0cf-de44148c4923\6a860085-3a5b-48ee-bab4-9adfd23950d4\Application.evt" />
  <DiagnosticLog Type="EventLog" Source="C:\Windows\TEMP\Working_b225172c-b7fc-4d9d-9a3e-393dc674b0b4\EventLog\System.evt" Destination="\\10-1361B0111\HLKLogs\DiagnosticLogs\2a513b38-27df-4681-b0cf-de44148c4923\6a860085-3a5b-48ee-bab4-9adfd23950d4\System.evt" />
  <DiagnosticLog Type="KernelModeCrashDump" Source="C:\Windows\TEMP\Working_b225172c-b7fc-4d9d-9a3e-393dc674b0b4\KernelModeCrashDump\KM_f4330059-0cd4-435c-8ad5-ee226c842409.dmp" Destination="\\10-1361B0111\HLKLogs\DiagnosticLogs\2a513b38-27df-4681-b0cf-de44148c4923\6a860085-3a5b-48ee-bab4-9adfd23950d4\KM_f4330059-0cd4-435c-8ad5-ee226c842409.dmp" />

In this content, you can find the node: DiagnosticLog Type="KernelModeCrashDump". You can take the value of the Destination attribute to get to the actual location of the dump file on the controller.

System name is wrong in the machine pool

If the name for a system in the machine pool appears to be randomly generated (for example, RHOQNQHEE77U2), try restarting the Windows HLK Client and Windows HLK Studio. If the problem remains, create a new project.

Test does not recover after a critical error

A test system encounters a critical error, or blue screen, during a test. After rebooting, the test system does not start the next test, and both the test system and the test remain in a Running mode. You cannot cancel the test in Windows HLK Studio; Windows HLK Manager fails.

In Windows HLK Manager, select and right-click the test and then select Delete. This action deletes the result and forces the test to run again.

NOTE

Cancelling a running job requires the running test to check with the Windows HLK Controller to see if it has been canceled. Because this job is no longer running on the Windows HLK Client, selecting Cancel has no effect.

Putting the test machine into a reset state, and continuing on to the next test does not resolve the problem because the running test will never send a message that the test has finished.

A test should recover within a few minutes after a test machine is rebooted from a blue screen event, but if a test fails and causes an unstable state, we recommend that you review the client logs.

Test fails without an error

Jobs that cancel because they exceed the set time-out do not return a task log or display an error in Windows HLK Studio. To see if a job failed because it timed out, check the job result error messages in Windows HLK Manager. A time-out message is similar to the following:

Result Errors

# Message Time Source Machine Name Root Cause

1 3/8/2012 1:32:36 PM Execution Agent 10-1361B1222 Failed the Job "timeout"

Job Failed And Rest of the Tasks Canceled because Task "timeout task" Failed with Failure Action FailAndStop

Test list does not update after configuration changes

If you select a test target and then make a change to a test computer's configuration, such as changing the video card, the list of tests for the test target does not update.

To get an updated test list after making a configuration change, deselect the test target, and then select it again. This action creates a new list of tests based on the test target.

Unsupported scenario

Tests fail if you installed Windows HLK Studio on a computer that is joined to a domain and then removed from the domain to join a workgroup.

To continue the test submission in this scenario, change the Windows HLK Studio computer back to its original domain, or uninstall and reinstall Windows HLK Controller and Windows HLK Studio so that all computers are either joined to a domain or are part of a workgroup.

Windows HLK Studio crashes if updates are applied to the Controller

Windows HLK Studio crashes and exits when an attempt is made to rerun jobs from Windows HLK Studio. In this case, the jobs have results before a service build update is applied.

For example:

  1. Install servicing build 8324.3

  2. Run all of the jobs under for a specific feature

  3. Install servicing build 8324.4

  4. Select one of the jobs to run. Windows HLK Studio crashes with an error

If the Windows HLK is installed, and a service build update for that version must be applied, all instances of Windows HLK Studio and Windows HLK Manager must to be shut down on the Windows HLK Controller and restarted only when the update procedure is complete. This includes any remote systems that have installed Windows HLK Studio from the Windows HLK Controller.

This prevents submission and content data that is displayed in Windows HLK studio from getting out of sync with updated data on the Windows HLK Controller and causing it to crash during certain operations that access the missing, updated, or new data. The Windows HLK manager can also, in some cases, lock files in memory that are updated and cause it to fail. (These are generally .pck files.)

To prevent this, all instances of Windows HLK Studio and Windows HLK Manager must be shut down on the Windows HLK Controller, and on any remote systems that have installed Windows HLK Studio from the Windows HLK Controller, before you install a service build update and apply QFEs. Restart Windows HLK Studio and Windows HLK Manager after the update procedure is complete.

Unable to determine the identify of domain error

When signing some (large) packages using Windows PowerShell, you might see an exception such as "Unable to determine the identity of domain". When this exception occurs, please use the managed API (see http://msdn.microsoft.com/en-us/library/windows/hardware/jj123504.aspx#BKMK_CS_SignPackage) as a work-around."

During packaging, the Signability test reports errors when attempting to sign for down level operating systems

When running the Signability test for down level operating systems (Windows Vista, Windows 2000, Windows XP, or Windows Server 2008), if the driver is not targeted for these operating systems, the test will report errors.

This error can appear in the following ways:

  • In HLK Studio, after creating a driver submission package, right-clicking on the added driver folder and choosing Signability Results displays a dialog box similar to the following:

  • If using the object model, you might see this issue when calling PackageWriter.AddDriver. 'errorMessages' might contain errors for non-targeted down level operating systems. Despite this error, the call to PackageWriter.AddDriver will succeed.

These errors should be treated as warnings and can be safely ignored. You can still submit the package to the hardware dashboard.

Related topics

Troubleshooting the Windows HLK Environment


Troubleshooting Windows HLK Test Failures

We recommend that you use this guide as your starting point to troubleshoot Windows Hardware Lab Kit (Windows HLK) test failures. This article describes possible test failures and provides step-by-step instructions on how to troubleshoot them. You must perform the troubleshooting steps in the prescribed order.

Troubleshooting steps:

  1. Install latest updates and filters

  2. Review the Status icons

  3. Make sure that the test was run correctly

  4. Check for configuration changes

  5. Identify the failure category

  6. Contact Windows HLK Support

1. Install latest updates and filters

Verify that you have the latest updates and filters for Windows HLK. The test failure might already be resolved by a published filter or update. You can get the latest Windows HLK content at Windows Hardware Lab Kit Filters.

Watch a video demonstration.

Video link

2. Review the Status icons

In Windows HLK Studio, review the test status icons on the Results tab. The status icons are described below. To follow the test failure categories that are listed in 5. Identify the failure category, you must know what each icon represents.

Status Icon | Meaning | Description
test queued status icon | Queued | The test is queued but not running. If the test is in this mode for a long time, it can indicate a network infrastructure or Windows HLK infrastructure problem. In most cases, this does not indicate an issue with the test itself.
test running status icon | Running | The test is running. On the Tests tab, the Length column indicates the expected test runtime. This information is also available in the test reference topic for the specific test. If a device encounters issues during testing, the tests can run for three to four times the expected runtime.
test passed status icon | Passed | The test passed.
test passed with filters status icon | Passed with Filters | The test passed.
test failed status icon | Failed | The test failed.
test failed with filters status icon | Failed with Filters | The test failed.
test failed due to system crash status icon Failed due to system crash

The system crashed during the test run. You can right-click on this test to view Bugcheck information.

For more information about reviewing system crashes, see Troubleshooting Windows HLK Test Failures (system crashes).
test canceled status icon | Canceled | A user canceled the test, or a task has been canceled because the preceding task failed.
NOTE

If the status icon suggests that you have a Windows HLK infrastructure problem, see Troubleshooting the Windows HLK Environment.

3. Make sure that the test was run correctly

Make sure that the test was run correctly, as described in the following sections:

  • Verify tests that require special configuration

  • Verify manual tests that require user interaction

  • Run multi-device test as a single test

Watch a video demonstration.

Video link

Verify tests that require special configuration

You should check whether the test requires a special configuration and if it does, verify that all special configuration requirements are met.

Some Windows HLK tests require additional files that are not included in the Windows HLK because of size or security reasons. Windows HLK Studio denotes these tests as requiring special configuration. These tests fail if the supplemental data is not installed.

Tests that require special configuration are denoted by a toolbox icon ( special configuration) in the Type column in the Test pane and the Results pane in Windows HLK Studio. Special configuration details are described in the test reference topic for each test. For specific test reference documentation, see HLK Test Reference, or from in Windows HLK Studio, select the specific test on the Test tab or the Result tab, and then press F1.

NOTE

The online version of the help content is generally the most current.

Verify manual tests that require user interaction

You should determine whether the test requires user interaction.

Tests that require user interaction are denoted by a person icon ( requires user interaction) in the Type column in the Test pane and the Results pane in Windows HLK Studio. For instructions on how to run a manual test, see the Running the test section in the test reference topic for the particular test. For specific test reference documentation, see HLK Test Reference, or from in Windows HLK Studio, select the specific test on the Test tab or the Result tab, and then press F1.

Run multi-device test as a single test

If the test was run as a multi-device test, rerun the test as a single test.

Multi-device testing is a Windows HLK feature that is supported by some tests. This feature reduces the time that a test runs by testing multiple devices at the same time (instead of scheduling a separate test run for each device.) Although this is a good way to reduce overall test time, it makes troubleshooting difficult because the results for all devices are logged in the same log files.

If a test fails during a multi-device test run, we recommend that you rerun the test separately against each device and troubleshoot each test run accordingly. To run a test individually in Windows HLK Studio, select the context-menu item Run Tests Individually. This menu item is available in the Results pane for tests that run as multi-device tests.

4. Check for configuration changes

Confirm that the Windows HLK infrastructure or the device configuration did not change after you selected the test target. Windows HLK gets the Windows HLK Client system configuration information when you select the test target. If you change the system or device configuration after you select the test target, you must then re-select the test target.

WARNING

Be aware that re-selecting the test target invalidates and removes all previous test results. We highly recommend that you do not make any device or infrastructure changes after you have started testing.

Watch a video demonstration.

Video link

5. Identify the failure category

The Results tab in Windows HLK Studio lists test tasks in the order in which they were run. Failed tests include error options that you can use to help troubleshoot test failures. For more information about the Results tab, see Manage Test Results using Result Tab.

The following table describes test categories and their indicators; the failure category column links to troubleshooting assistance in this article. To access test errors, execution logs, tasks logs, and additional associated files, right-click the failed test on the Windows HLK Studio Results tab.

Failure category Status icon Identifiers Description

Test failed because of test results

Failed

Task Error, Task Log

Task Log

Task Error

Task &lt;&gt; is Marked as Failed from the Log File

Failed to determine Pass/Fail of the task &lt;&gt; Task will be marked as failed anyway.

Cause : The Execute Task with &lt;&gt; Failed with ExitCode &lt;Error Code&gt;

System crashed

Failed

Windows Event Log, Windows crash dump files

A system event log entry and (if enabled) a crash dump file are created during a system crash. The Task Error probably states: Task Cancelled Because of an Unexpected Reboot.

You can right-click on a test associated with a system crash to view associated Bugcheck information.

Test crashed

Failed

Windows Event Log, user-mode crash dump files

When a user mode component crashes, an Application event log entry is created on the Windows HLK Client; if it is enabled, a user mode dump file is also created.

Test was cancelled because it ran too long

Failed

Task Execution Log

This problem is indicated in the Task Execution Log.

Client system is unresponsive

Running

No indicators

If the Windows HLK Client is not responding, tests can run indefinitely.

Test was ended by the user on the Windows HLK Client.

Failed

Task Error

This kind of error does not usually produce a log file.

For additional information about specific error messages, see Windows HLK Studio task error message reference.

The following sections fully describe the failure categories that are listed in the preceding table:

  • Test failed because of test results

  • Test fails with no failing task and Execution Logs are disabled

  • System crashed

  • Test crashed

  • Test was cancelled because it ran too long

  • Client system is unresponsive

Test failed because of test results

Test result failures are the most common kind of failure. If you receive a test result failure, review the following information:

  • The Task Log file and Additional Files from the Results tab in Windows HLK Studio.

  • The Troubleshooting section in the test reference topic. Select the test in Windows HLK Studio and then press F1.

  • The associated technology-specific troubleshooting guide that contains general troubleshooting guidance for all tests in a particular feature or technology area. For a list of technology-specific troubleshooting guides, see Troubleshooting Windows HLK.

Test fails with no failing task and Execution Logs are disabled

A known HLK client issue can cause a test to fail when there are no failing tasks, but one or more of the tasks is marked as cancelled. The test result should be checked for Execution Logs.

*To check for execution logs*

  1. In Windows HLK Studio, right click a task result from the failing test result.

  2. Use the Infrastructure menu item to view the types of logs.

  3. Check whether the Execution Logs option is disabled (greyed out).

If the Execution Logs are missing this failure is likely caused by the known issue. The work-around is to re-run the test, so that logs are copied back to the controller.

System crashed

When Windows encounters a condition that compromises safe system operation, the system halts. This condition is commonly called a bug check, a system crash, a kernel error, a Stop error, or BSOD. A hardware device, its driver, or related software can cause this error.

Bugcheck summary information

The system crash icon ( system crash icon) indicates that the system crashed during the test run. You can right-click on a test associated with a system crash to view associated Bugcheck information:

bugcheck summary information dialog

Copying crash dump files from the client machine back to the HLK Controller

In the Configuration tab of HLK Studio, the Crash Dump Copy Back Setting specifies whether to copy the kernel dump back to the HLK Controller.

NOTE

Copying is disabled by default. For more information, see Manually Configure HLK Client Kernel Debugger Settings.

When Windows crashes, it writes an event to the Windows System Event Log. To start the Event Viewer and view the event, do the following:

  1. On the Start screen, type Event Logs.

  2. Under Settings, click View Event Log.

  3. In the Event Log Viewer, select Windows Logs.

  4. Select the specific log of interest. To troubleshoot most user-mode failures, including problems with Windows HLK tests, select Application Log. For kernel-mode issues, select System Log.

  5. In the Windows System Event Log file, look for an event that is similar to the following:

    Level = Critical
Source = Kernel-Power
Event ID 41
Description:
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

Analyzing crash dump files

In addition to the Bugcheck summary information dialog, you can debug a system crash by using the crash dump file and the Windows debugger. For information on how to analyze crash dump files see Crash Dump Files and Analyzing a Kernel-Mode Dump File. For Windows debugging tools, see Troubleshooting Windows HLK.

You must determine whether the crash is caused by the driver that you are trying to certify or whether it is a Windows problem. You can identify this by using the Windows debugger !analyze extension. In the kernel debugger, use the !analyze -v command to review data on the failing component.

For more information about how to use the !analyze extension, see Using the !analyze Extension. For advanced troubleshooting assistance, see Debugging Techniques. For more information about bug checks, see Interpreting a Bug Check Code. For a list of bug check error codes, see Bug Check Code Reference.

If the problem is caused by Windows, collect the dump file and debugging data and follow the instructions in Windows HLK Support.

Test crashed

Tests in this category show up as test failures that have no Task Logs files. Start the Windows Event Viewer on the client computer. (To start Windows Event Viewer, on the Start screen, type Event Logs and then select View Event Log under Settings.) In the Windows Event Viewer, in the Windows Application event log, look for an event that is similar to the following:

Level      = ErrorSource     = Application ErrorEvent ID   = 1000Description: Faulting application name: Testname.exe, …

Collect the-user mode crash dumps as described in Collecting User-Mode Dumps, and submit them as instructed in Windows HLK Support.

Test was cancelled because it ran too long

Windows HLK automatically cancels a test run if the test is still running after three times the expected runtime. Windows HLK Studio displays the estimated test run time for each test.

You can identify tests that were cancelled because they ran too long by using the following criteria:

  • Test does not have associated Task Logs.

  • Test does not have a Task Error in Windows HLK Studio.

  • In the WttEa.log file, under Infrastructure\Execution Log, look for the error: Run Test Failed Because the Task With TaskTimeout, as shown in the following example:

    1872 3868 2012:3:3 3:43:7:898 Error: 0x8201adb1, Error 0x8201adb1   CExecutionTask::Cleanup()::(null)::CAUSE:INFORMATION: Task "Run Test" Failed Because the Task With TaskTimeout Flag Was running after the Timeout period 10800000 MilliSeconds    File=d:\branches\fbl\tools\wtt\rel25\dtm\sdktools\wtt\jobs\runtime\wttexecutionagent\coreea\executiontask\src\executiontask.cpp Line=1686

To view the Wttea.log file by using Windows HLK Studio

  1. In Windows HLK Studio, click the Results tab.

  2. Right-click the failed test.

  3. Click Infrastructure, click Execution Logs, and then click WttEa.log.

Verify that the basic functionality of the device still works.

Client system is unresponsive

Use the Job Monitor in Windows HLK Manager to view the Last Heartbeat column in the Machine window. If the last heartbeat has not registered for a long time, a communication problem probably exists between the Windows HLK Controller and the Windows HLK Client. If there is no heartbeat from the Windows HLK Client, it can take a long time for a test to be cancelled. To troubleshoot this problem, consider the following issues:

  • Network problems. See Troubleshooting the Windows HLK Environment.

  • Client system is unresponsive. This state is indicated in the following ways:

    • The mouse pointer moves, but it cannot perform any actions.

    • All video is frozen; the mouse pointer does not move; paging continues.

    • The mouse, keyboard, and disk are all unresponsive.

    If the test appears to be making progress but the progress is slow, review console logging to determine the cause.

    Enable the system for debugging and follow the instructions in Forcing a System Crash and Debugging a Stalled System.

    Driver developers should investigate these issues by using a kernel debugger. If the test is nonresponsive, start the kernel debugger before Windows HLK cancels the test run. In the kernel debugger, look for any unresponsive threads in the test process.

6. Contact Windows HLK Support

See Windows HLK Support for instructions on how to report the following problems to Windows HLK Support:

  • An inaccurate status icon is reported.

  • You cannot determine the cause of the failure.

  • The failure is caused by a system crash that you cannot resolve.

  • The failure is caused by a Windows problem.

How to get the test name

To get the test name in Windows HLK Studio, perform the following steps:

  1. On the Results tab in Windows HLK Studio, right-click the test name.

  2. Type Ctrl-C to copy the test data into the clipboard.

  3. Paste the test data into Notepad or other text editor. The data will be similar to Figure 2. Sample Test Data, where DF - PNP (disable and enable) with IO Before and After (Basic) is the test name, 03m is the anticipated test runtime, USB Input Device is the device under test, and MYSYSTEM is the name of the Windows HLK Client.

    sample test data

Windows HLK Studio task error message reference

This section describes task error messages that Windows HLK Studio returns for some test failures.

Task <> is Marked as Failed from the Log File

This is the most common error message. Review the Task Log file.

Failed to determine Pass/Fail of the task <> Task will be marked as failed anyway.

This error usually means that the test generated a log, but did not log anything other than comments. Some log failures do not result in a Task Error. The Log indicates a failure or the Log is incomplete.

Cause : The Execute Task with <> Failed with ExitCode <Error Code>

Not all Tasks return logs; failure is indicated by exe exit code. This code can be any error typ. Determine whether the error code makes sense for a win32 error or a HRESULT error.

Task cancelled because of an unexpected reboot

This is a general error that can have various causes, including but not limited to the system under test rebooting or crashing.

Troubleshooting graphics tests

Graphics Support CABs

Graphics Feature on Demand (FOD) packages are required to be present on the test client for all graphics testing. The DLLs for the\\BUILD OS are available for download on the MSDN on the HLK Supplemental Content download page. The cabs can be deployed on a running client, or injected into the OS image prior to deploying to the client.

For example, to install on a running client, use the following command:

dism /online /add-package /packagepath:<path to package>\Microsoft-OneCore-Graphics-Tools-Package.cab

Related topics

Troubleshooting Windows HLK

Diagnostics (Windows)

Collecting User-Mode Dumps


Windows HLK Support

Getting support on Windows HLK test issues.

Before you contact Support, make sure you follow the basic troubleshooting steps in Troubleshooting Windows HLK Test Failures. You must provide information for each test issue as a separate support issue. Make sure the information that you collect is accurate; for example, provide the exact test name as it appears in Windows Hardware Lab Kit (Windows HLK) Studio.

You must provide the following information to Support to receive technical support on your issue:

  • The full and exact test name as it displays in Windows HLK Studio.

  • The Windows HLK package file.

  • If the failure category is System crashed, include the system crash dump files that were created during the test run. At a minimum, you must supply a kernel dump; a mini-dump is not sufficient.

  • If the test failure category is Test crashed, include the user mode dump files.

  • All available system or user-mode crash dump files system event log files that were created by running the failed test.

  • Any additional debugging data that you have obtained about the failed test.

After you have run the troubleshooting steps and collected the necessary information, see HLK support to contact Support.

Related topics

Troubleshooting Windows HLK


HLK Testing Concepts

Windows HLK testing is based on feature detection. Windows HLK determines what a part of a device needs to be tested by detecting the functionality of the device or system.

Terminology

Term | Definition
Feature | A feature is a Windows capability exposed by a device. When you connect a device to a Windows HLK environment, the kit searches for features on the device using a mechanism called gatherers. Features are organized using a namespace style, for example, Device.Graphics.WDDM12, System.Client.BluetoothController.Base, and Filter.Driver.Network.LWF. A target device or system can detect many features.
Requirement | A requirement is the official specification that defines what a feature must do to qualify for the Windows hardware compatibility list. Requirements are organized using a namespace style. For example Device.Imaging.Scanner.Base.RawFileFormat is a requirement for the Device.Imaging.Scanner.Basefeature. There can be many requirements associated with a single feature.
Test | Tests validate that features are implemented on a device or system in accordance with requirements. Each test has a pointer to the requirement(s) it validates.
Product type | A product that contains a predefined list of testable features. To be listed on the Windows Hardware Compatibility list, a product must implement all of the features of at least one product type.
Project | A project is a submission that is sent to Microsoft that encompasses all of the architectures and platforms for the certification request. You can combine different projects into a larger project for submission through the process of creating a package.
Product Instance | A product instance is collection of devices on a single platform. Unlike a target family, which is a collection of effectively identical devices, devices in the product instance can be similar or dissimilar. Each platform must be tested individually, though you can use multiple machines to test in parallel with other product instances.
Device Family | A device family is a collection of hardware IDs that are cached in the datastore under a common name. A device family is used to define a family of similar devices that may have different hardware IDs. A device family is one of the criteria used to identify similar targets in a target family.
Target Family | A target family is a collection of targets within a single device family. For the purposes of testing, targets in a target family are treated as identical, allowing jobs to run in parallel across all targets in the target family. Unlike a product instance, which is a collection of dissimilar devices, a target family is a collection of effectively identical devices.
Target | A target is any hardware, software driver, or system that can be individually addressed and tested.

How it works

In the following example, a multi-function printer device contains several features: It's a scanner, an Ethernet network port, a storage reader, and a printer. Windows HLK detects each feature, determines the associated requirements for it, and then runs a corresponding test to verify that the requirements are implemented correctly.

windows hck feature detection process

Best Practices

In addition to understanding the terminology and logic, consider these best practices:

  • Design your hardware using the Windows Hardware Requirements.

  • Review the test reference for your device before testing. Any Windows HLK test may require a specific configuration. The more complex the device, the more complex the test configuration.

  • Manual tests require more time and preparation. You should run manual steps separately from automated tests. When you connect a device to Windows HLK, you can sort detected test by automated and manual. To learn more about any test, select the test from Windows HLK Studio and press F1 for Help.

  • Ensure that your test server contains the latest QFE and filters. We periodically release updated tests. For more info, see Windows Hardware Certification in the Windows Dev Center.

  • Use the test levels to test basic, functional, reliability and certification tests in that order as the different levels provide testing from basics to functionally complete devices.

Testing Strategy

The complexity of a device determines the complexity of a test. It can be as simple as connecting the device and running the test, or it can require additional hardware resources, extensive configuration, and/or active use. Considering your knowledge of the device and previous versions of this kit, you can approach testing two ways:

  • Connect the device to a Windows HLK environment. Let the kit detect features and the corresponding tests to run against the device. Press F1 on each identified test to review any prerequisites for it.

  • Review the Windows HLK Users Guide in advance. Review the Test Reference section for the specific technologies implemented in your device, specifically the "Prerequisite" topic for each area.

  • Take advantage of multi-device and distributed testing features to reduce overall test time. For more information, see Configuration Page - Machine Management.

Test Automation Support

For partners interested in automating their test environment, Windows HLK provides scripting and application programming interface (API) support.

  • HLK Automation Tool - a scripting solution based on Windows PowerShell that enables you to automate a test pass.

  • HLK Developer Guide - a collection of Windows HLK API that enables you to automate any part of the certification test process. The API exposes all functionality of Windows HLK Studio, so you can use both Windows HLK Studio and automation in your certification test workflow.

Test taxonomy

The Windows HLK introduces a new set of test types.

Test type Description

Development tests

Tests that assist in the bring up and development process. These BVT-like functional tests provide basic functionality and compliance checks and rich debug information. Additionally, this type of test may perform code quality testing.

Compatibility tests

These are tests required for the Hardware Compatibility program.

These tests validate compliance with Windows feature implementation and compatibility with Windows. When all of these tests pass for a given device/driver/system, the target under test can be said to be feature complete and Windows compatible.

At this stage, you are ready to submit your drivers/devices/systems to be included on the Windows Compatibility list.

Scenario tests

These tests assess the behavior of a device or system, focusing on validating end-to-end experiences. These experiences can serve very specific purposes - such as lab readiness testing for a specific device stack, or may be broad end-user experiences that touches various hardware components in a system.

Benchmark tests

AThese tests provide power and performance measurement.

Related topics

What's New in Windows Hardware Certification Kit


HLK Glossary

This section provides definitions of commonly used words or terms within the Windows Hardware Lab Kit (Windows HLK)

C

child machine pool

A machine pool that is contained within another ("parent") machine pool. Several child machine pools can be created as part of a parent machine pool in the machine pool hierarchy.

client computer

A computer that the HLK client has been installed on. You use HLK to run tests on client computers.

configuration job

A job that sets the value of a dimension. Configuration jobs can be executed automatically to satisfy the constraints of another job that is executing.

constraint

A triplet that consists of a dimension, an operator, and a value. A constraint is part of the job definition. A job can only execute on client computers that match the job's constraints. For example, a job that had the following constraint could only be executed on client computers that have an x86 processor. See also dimension.

context

A set of constraints that are specified in a job. For example, if a job included the constraints "WTT\OS equals Windows XP" and "WTT\RAM-MB greater than 512", then these two constraints would form the job's context. See also dimension, mix.

controller

A computer that the HLK controller has been installed on. The controller stores data about jobs, client computers, and HLK users, and it manages job scheduling.

Copy File task

A task that copies files from a remote location to the client computer.

Copy Result task

A task that copies files from the client computer to a remote location.

custom dependencies

User-defined relationships between tasks in a job that specify the order in which the tasks execute.

D

Dashboard

The website that you use to submit or manage your packages as part of the Windows Certification Program. This site replaces Winqual.

daemon task

A task that begins running either before all other tasks in a phase, or after all other tasks in a phase. A daemon task can run in parallel with other tasks.

DCT

See Display Compatibility Test.

default pool

The machine pool that computers are initially placed in when the HLK client is installed.

dimension

A key/value pair that identifies a characteristic of a client computer. For example, a dimension with the key "ProcessorCount" might have the value "1" on one client computer and the value "4" on another client computer.

A job can include constraints, which indicate that the job can run only on client computers that have a specific value for a dimension.

Display Compatibility Test

A test that verifies display functionality on computers running Windows.

HLK administrator

An HLK user account that has administrator privileges. An HLK administrator can create machine pools, create HLK user accounts, and grant privileges to the HLK user accounts.

An HLK administrator often has an account with administrative privileges on the computer that is running the HLK controller, but this type of account is not required.

When you install the HLK controller, an HLK user account is automatically created for you, and your account is automatically given administrator privileges.

E

EA

See also execution agent (EA).

execution agent (EA)

A component of the HLK client that executes the tasks of a job.

Execute task

A task that executes a command line.

F

Feature

An attribute of a job that organizes jobs within a hierarchy.

Within Job Explorer, you expand nodes of the feature hierarchy to locate jobs.

G

gatherer

A program that collects information about a client computer.

global parameter

A parameter that can be used by all jobs on the HLK controller. You can define global parameters by using the Management Console.

H

HLK Client

A test computer that the HLK client application has been installed on. You use HLK Studio to run tests on client (test) computers.

HLK Controller

The HLK Controller stores data about jobs, client computers, and HLK users, and it manages job scheduling.

A collection of string values which should provide sufficient information to correlate to see if a driver should be loaded for any specific device.

HLK Manager

This item was previous known as the DTM Studio. Use the HLK Manager to access Windows Logo Kit functionality that is included in the Windows HLK.

HLK Studio

The user interface for Windows HLK. By using HLK Studio, you can run tests, monitor the progress of jobs, and review test logs.

J

job

A collection of tasks that can be run on a client computer. A job describes the order in which to execute the tasks. A job can identify conditions that a client computer must meet to run the job.

L

library job

A job that has been stored and can be used by another job.

LLU

See Local Logical User.

Local Logical User (LLU)

A mapping from a variable to a user account on each client computer.

For example, the Local Logical User (LLU) with the name AdminUser might map to the user account MyDomain\User6 with a password of My^Password%23 on one client computer, and to the user account MyDomain\User32 with a password of My#Password@97 on another client computer.

M

machine

A client computer that is a member of a machine pool. Client computers that are not in the System machine pool are test clients that you can execute jobs on.

machine pool

A virtual collection of computers, devices, or both that is created by a user to help manage the testing process.

Machine Set

A set of computers that play the same role in a job that requires multiple computers. For example, a job that required more than one computer might have a client machine set and a server machine set.

Manual Prompt task

A task that displays a prompt and options to the user and waits for the user to make a selection.

Master client

The test computer that issues commands to another test computer on a test network.

MC

See Master client.

mix

A set of contexts that is specified in a job. The job can be executed on a computer that matches any of the contexts. For example, a job could specify a mix that consisted of two contexts. Context 1 could consist of the constraints "WTT\OS equals Windows XP" and "WTT\RAM-MB greater than 512". Context 2 could consist of the constraints "WTT\OS equals Windows Server 2003" and "WTT\RAM-MB greater than 1000". In this case, the job's mix would specify that the job could run on client computers with Windows XP and more than 512 MB of RAM, or client computers with Windows Server 2003 and more than 1GB of RAM. See also constraint.

P

package

A container that can include jobs and the other data that is required to run the jobs. Packages are used for grouping, storing, and sharing jobs.

Parameter

A variable that provides information to a task. Global parameters are defined by using the Management Console. Local variables are defined within a job. Default values for parameters can be overridden when a job is scheduled.

PD

Push Daemon. A component of the HLK controller that sends a job to the client computer to execute.

R

result

The information that is created when you execute a job. Each instance of a job creates a result that contains the start time, end time, and completion status of the job's tasks; any error messages; a link to the job's log files; and more detailed information.

result collection

A group of results. When you execute a job, a result collection is created to contain the job's results. If more than one instance of a job is created when a job is executed, the results of all of the job instances are stored in one result collection. You can specify your own result collection to hold results, and you can add, modify, delete, or move results within result collections.

Run Job task

A task that runs a library job.

S

SC

See Subordinate client.

schedule

Adds a job to the list of jobs that are ready to run. A job that has been scheduled will run when a client computer that meets the job's constraints is available.

scheduler

A component of the HLK controller that assigns a job to execute on a specific client computer.

System under test

The computer being tested.

Subordinate client

A computer that acts as a client during testing on a network.

SUT

See System under test.

T

task

A unit of work to be done on a client computer. The most common tasks execute a command line, copy files, or prompt the user to perform a manual action.

test harness

A software application that is used to automate testing.

W

Windows Certification Program

A previous program that supported hardware submission for Windows 8.1.

Windows Compatibility Program

The new program that supported hardware submission for Windows 10.

Windows Hardware Certification Kit

The application provided as part of the previous Windows Certification Program that enables you to test your Windows 8.1 device or computer for Windows certification. Also known as the Windows HLK.

Windows Hardware Lab Kit

The kit provided as part of the Windows Hardware Compatibility Program. Also know as the Windows HLK.

Winqual

The previous web service that supported hardware submission for Windows 7. This site is replaced by the Hardware Dashboard in the Windows Dev Center.


Accessibility for People with Disabilities

Microsoft is committed to making its products and services easier for everyone to use. The following topics provide information about the following features, products, and services that make the Windows HLK more accessible for people with disabilities.

  • Accessibility Features in Windows HLK

  • Accessibility Products and Services from Microsoft


Accessibility Features in Windows HLK

Using Keyboard Shortcuts

This topic provides instructions for accessing Windows Hardware Lab Kit (Windows HLK) Studio commands by using keyboard shortcuts. The following table lists Windows HLK Studio menu items and the keyboard shortcuts that perform the same action as the menu item.

Menu Item | Keyboard Shortcut Using Ctrl | Keyboard Shortcut Using Alt
File Menu |  | Alt + F
Open | Ctrl + O | Alt + F + O
Save | Ctrl + S | Alt + F + S
Save As |  | Alt + F + A
Print | Ctrl + P | Alt + F + P
Print Preview |  | Alt + F + V
Recent Files |  | Alt + F + R
Exit |  | Alt + F + X
New Job |  | Alt + F + N + J
New Package |  | Alt + F + P
Export Jobs |  | Alt + F + E
Import Jobs |  | Alt + F + I
Save Job | Ctrl + S | Alt + F + E
Create Schedule | Ctrl + Shift + S | Alt + F + U
Save Result | Ctrl + S | Alt + F + E
Edit Menu |  | Alt + E
Undo | Ctrl + Z | Alt + E + U
Cut | Ctrl + X | Alt + E + T
Copy | Ctrl + C | Alt + E + C
Paste | Ctrl+ V | Alt + E + P
Delete | Del | Alt + E + D
View Menu |  | Alt + V
 | Ctrl + Q | Alt + V + Q
 | Ctrl + H | Alt + V + H
 | F5 | Alt + V + R
 | Ctrl + T | Alt + V + T
 |  | Alt + V +_T
 |  | Alt + V + S
Explorers Menu |  | Alt + X
Job Explorer |  | Alt + X + J
Result Explorer |  | Alt + X + R
Job Monitor |  | Alt + X + M
Result Collection |  | Alt + X + C
Error Log View |  | Alt + X + E
Result Rollup |  | Alt + X + O
Device Explorer |  | Alt + X + D
Tools |  | Alt + T
Management Console |  | Alt + T + C
Plugin Manager |  | Alt + T + P
Device Categories |  | Alt + T + D
Window |  | Alt + W
Cascade |  | Alt + W + S
Tile |  | Alt + W + T
Opened Window |  | Alt + W + [window number]
Close |  | Alt + W + C
Close All |  | Alt + W + A
Help | F1 | Alt + H
Contents |  | Alt + H + C
Show Start Page |  | Alt + H + H
About Windows HLK Studio |  | Alt + H + A
Show items in drop-down list |  | Alt + Down Arrow


Accessibility Products and Services from Microsoft

Microsoft is committed to making its products and services easier for everyone to use. The following topics provide information about the features, products, and services that make Microsoft Windows more accessible for people with disabilities:

  • Accessibility Features of Windows

  • Documentation in Alternative Formats

  • Customer Service for People with Hearing Impairments

  • For More Information

NOTE

The information in this section may apply only to users who license Microsoft products in the United States. If you obtained this product outside of the United States, you can use the subsidiary information card that came with your software package or visit the Microsoft Accessibility Web site for a list of Microsoft support services telephone numbers and addresses. You can contact your subsidiary to find out whether the type of products and services described in this section are available in your area. Information about accessibility is available in other languages, including Japanese and French.


Accessibility Features of Windows

The Windows operating system has many built-in accessibility features that are useful for individuals who have difficulty typing or using a mouse, are blind or have low vision, or who are deaf or hard-of-hearing. The features are installed during the installation of Windows. For more information about these features, see Help in Windows and the Microsoft Accessibility website.

Free Step-by-Step Tutorials

Microsoft offers a series of step-by-step tutorials that provide detailed procedures for adjusting the accessibility options and settings on your computer. This information is presented in a side-by-side format so that you can learn how to use the mouse, the keyboard, or a combination of both.

To find step-by-step tutorials for Microsoft products, see the Microsoft Accessibility website.

Assistive Technology Products for Windows

A wide variety of assistive technology products are available to make computers easier to use for people with disabilities. You can search a catalog of assistive technology products that run on Windows at the Microsoft Accessibility website.

If you use assistive technology, be sure to contact your assistive technology vendor before you upgrade your software or hardware to check for possible compatibility issues.


Documentation in Alternative Formats

If you have difficulty reading or handling printed materials, you can obtain the documentation for many Microsoft products in more accessible formats. You can view an index of accessible product documentation on the Microsoft Accessibility website.

In addition, you can obtain additional Microsoft publications from Recording for the Blind & Dyslexic, Inc (RFB&D). RFB&D distributes these documents to registered, eligible members of their distribution service. For information about the availability of Microsoft product documentation and books from Microsoft Press, contact:

Recording for the Blind & Dyslexic, Inc.

20 Roszel Road

Princeton, NJ 08540

Telephone number from within the United States: (800) 221-4792

Telephone number from outside the United States and Canada: (609) 452-0606

Fax: (609) 987-8116

Recording for the Blind & Dyslexic website

NOTE

Web addresses can change, so you might be unable to connect to the website or sites mentioned here.


Customer Service for People with Hearing Impairments

If you are deaf or hard-of-hearing, complete access to Microsoft product and customer services is available through a text telephone (TTY/TDD) service:

  • For customer service, contact Microsoft Sales Information Center at (800) 892-5234 between 6:30 AM and 5:30 PM Pacific Time, Monday through Friday, excluding holidays.

  • For technical assistance in the United States, contact Microsoft Product Support Services at (800) 892-5234 between 6:00 AM and 6:00 PM Pacific Time, Monday through Friday, excluding holidays. In Canada, dial (905) 568-9641 between 8:00 AM and 8:00 PM Eastern Time, Monday through Friday, excluding holidays.

Microsoft Support Services are subject to the prices, terms, and conditions in place at the time the service is used.


For More Information

For more information about how accessible technology for computers helps to improve the lives of people with disabilities, see the Microsoft Accessibility website.


HLK Test Reference

In this section

  • Device.Audio
  • Device.BusController
  • Device.Cluster
  • Device.Connectivity
  • Device.DevFund
  • Device.Display
  • Device.Graphics
  • Device.Imaging
  • Device.Input
  • Device.Network
  • Device.Portable
  • Device.Storage
  • Device.Streaming
  • Device.TrustedPlatformModule
  • Filter.Driver
  • System.Client
  • System.Fundamentals
  • System.Fundamentals.Security
  • System.Fundamentals.SystemUSB
  • System.Server
  • System.Solutions


Device.Audio

In this section

  • Device.Audio tests
  • Device.Audio additional documentation


Device.Audio tests

  • Audio APO - Verify APO Initializes - TestAPOInitialize
  • Audio APO - Verify APO Streams Data - TestAPODataStreaming
  • Audio APO - Verify All Formats on Device are Valid - TestCustomFormatSupport
  • Audio APO - Verify Frame Count is Valid - TestValidFrameCount
  • Audio APO - Verify Proper APO Activation and Deactivation - TestActivateDeactivate
  • Audio Codec - AC3 Test - Certification
  • Audio Codec - Audio Engine Core Test (UMACoreTest)
  • Audio Codec - Audio Engine Test (UMATest)
  • Audio Codec - Audio Logo Test - Basic
  • Audio Codec - Audio Logo Test - Certification
  • Audio Codec - Audio Logo Test - Certification - Phone
  • Audio Codec - Audio Logo Test - Glitch
  • Audio Codec - Class Driver Audio Logo Test - Certification
  • Audio Codec - Communications Audio Fidelity Test (Manual)
  • Audio Codec - Device Power State Transition Test
  • Audio Codec - DRM Test
  • Audio Codec - General Audio Test - MobileCore
  • Audio Codec - General Audio Test - WinBlue
  • Audio Codec - Hardware Offload of Audio Processing Test - Basic
  • Audio Codec - Hardware Offload of Audio Processing Test - Certification
  • Audio Codec - Hardware Offload of Audio Processing Test - Reliability
  • Audio Codec - KS Position Test
  • Audio Codec - KS Topology Test - Mobilecore
  • Audio Codec - KS Topology Test - WinBlue
  • Audio Codec - Lullaby Test - Certification
  • Audio Codec - Lullaby Test - Functional
  • Audio Codec - Lullaby Test - Reliability
  • Audio Codec - Lullaby Test for Phone
  • Audio Codec - MediaCapture API Test - Test Audio Capture
  • Audio Codec - MFCaptureEngine API Test - Capture AAC Audio samples from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture AMR-NB Audio to a file from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture Audio to an AAC file from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture MP3 Audio samples from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture MP3 Audio to a file from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture PCM Audio samples from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture PCM Audio to a wav file from the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture WMA9 audio samples the default capture pin
  • Audio Codec - MFCaptureEngine API Test - Capture WMA9 Audio to an wma file from the default capture pin
  • Audio Codec - SysFX Test
  • Audio Codec - SysFx Test (Mobile)
  • Audio Codec - UAA Test (Manual)
  • Audio Codec - USB Audio Logo Test (Manual) - Certification
  • Audio Codec - Verify Audio EffectsDiscovery - Mobilecore
  • Audio Codec - Verify Audio EffectsDiscovery (Manual) - Certification
  • Audio Codec - Voice Activation Manager Tests
  • Audio Codec - Wave Test - Basic
  • Audio Codec - Wave Test - Certification
  • Audio Codec - Wave Test - Functional
  • Audio Codec - Wave Test - Threshold - Basic
  • Audio Codec - Wave Test - Threshold - Certification

  • Audio Codec - Wave Test - Threshold - Functional

  • Bluetooth - BluetoothAudioClassesVerify (Bring Up)

  • Bluetooth - BluetoothAudioProfilesVerify (Bring Up)


Audio APO - Verify APO Initializes - TestAPOInitialize

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed37b03b-f091-4c8d-9edd-fe7ec803bc8e

Third Party APO Test: TestAPOInitialize

Test details
Specifications
  • Device.Audio.APO.ThirdParty
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.


Audio APO - Verify APO Streams Data - TestAPODataStreaming

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d327b019-99e4-41bd-bf66-af1a92801dac

Third Party APO Test: TestAPODataStreaming

Test details
Specifications
  • Device.Audio.APO.ThirdParty
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation

Troubleshooting


Audio APO - Verify All Formats on Device are Valid - TestCustomFormatSupport

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/571bd021-64f5-4cd1-9ba4-8abd0857025f

Third Party APO Test: TestCustomFormatSupport

Test details
Specifications
  • Device.Audio.APO.ThirdParty
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation


Audio APO - Verify Frame Count is Valid - TestValidFrameCount

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9e9f61a-2882-4256-aba8-d57a46e54b76

Third Party APO Test: TestValidFrameCount

Test details
Specifications
  • Device.Audio.APO.ThirdParty
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation


Audio APO - Verify Proper APO Activation and Deactivation - TestActivateDeactivate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1c21041-9080-4990-b6a2-5f718649a3f2

Third Party APO Test: TestActivateDeactivate

Test details
Specifications
  • Device.Audio.APO.ThirdParty
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation


Audio Codec - AC3 Test - Certification - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b42bd7fc-32b1-4500-8049-a4e00c70eb33

This automated test verifies that audio devices that support the AC-3 format comply with Windows requirements.

This test makes sure that each enumerated KSCATEGORY_AUDIO and KSCATEGORY_RENDER filter that exposes AC-3 format pins complies with the Microsoft Driver Development Kit documentation that is related to implementing AC-3 format pins. Also, this test makes sure that the filter does not prevent support for AC-3 streaming through the Wave and Microsoft DirectSound APIs.

Test details
Specifications
  • Device.Audio.Base.TwoDMAEnginesAndConnections
  • Device.Audio.Base.StreamingFormats
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

All test cases return PASS or FAIL. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. The test might return SKIP, which you should consider to be PASS for the overall test if no AC-3-compatible devices are present on the system. If the test does not detect AC-3 devices and the hardware does support them, a problem exists with the way that the pin in the filter of the specific device advertises itself.

More information

Command syntax

Command option | Description
Ac3Test | Without any options, the test enumerates devices.
-c [string] | This option starts the application and runs the test cases that are specified in the .profile file.
-h [string] | This option specifies the Plug and Play (PnP) ID of the device to be tested.
wdk_ac3test.pro | This is the .profile file of test cases to be run.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
AC3Test.exe | <testbinroot>\nttest\multimediatest\AVCore\Audio\WDK</p>
Wdk_ac3test.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
Logo_win7_ac3test.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
Logo_vista_ac3test.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Profile for Test Cases


Audio Codec - Audio Engine Core Test (UMACoreTest)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb304880-c6ad-401e-b664-b31c15d5460e

This test validates the audio engine and its interactions with the audio driver. It includes validation of the different APOs, KS Render/Capture, and core engine functionality.

Test details
Specifications
  • Device.Audio.HardwareAudioProcessing.AudioHardwareOffloading
  • Device.Audio.HardwareAudioProcessing.ETWEvent
  • Device.Audio.Base.AudioProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Development
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Command syntax

Command option | Description
te.exe umacoretest_mc.dll /enablewttlogging | Without any options, the test executes all cases against all audio devices.

File list

File | Location
Umacoretest_mc.dll | <testbinroot>\audio-test\bin
te.exe | <testbinroot>\Testing\Runtimes\TAEF\x86

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of the machine's LLU for copying files


Audio Codec - Audio Engine Test (UMATest)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff91440c-9557-489b-85e2-38726d34f826

This test validates the audio engine and its interactions with the audio driver. It includes API level tests against the different interfaces. It also includes streaming tests to validate driver and engine streaming in different formats and modes.

Test details
Specifications
  • Device.Audio.HardwareAudioProcessing.AudioHardwareOffloading
  • Device.Audio.HardwareAudioProcessing.ETWEvent
  • Device.Audio.Base.AudioProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Development
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Command syntax

Command option | Description
te.exe umatest_mc.dll /enablewttlogging | Without any options, the test executes all cases against all audio devices.

File list

File | Location
Audiostreaming.dll | <testbinroot>\audio-test\bin
Umatest_mc.dll | <testbinroot>\audio-test\bin
Sndanlyz.dll | <testbinroot>\audio-test\bin
te.exe | <testbinroot>\Testing\Runtimes\TAEF\x86

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of the machine's LLU for copying files


Audio Codec - Audio Logo Test - Basic - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1c32846-fdd3-4efd-b918-baee82cd1a04

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Audio Logo Test - Certification - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e27f2dd-2fde-4865-945c-7ca26d508148

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.ZeroGlitch
  • Device.Audio.Base.ReportSupportedProperties
  • Device.Audio.Base.WaveRTConformance
  • Device.Audio.Base.HardwareArchitecture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Audio Logo Test - Certification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/91d27525-b5cf-4a7d-a52d-fdcf6a530571

This automated test verifies that WaveRT drivers support pull-mode audio-streaming technology by implementing the IMiniportWaveRTStreamNotification interface.

Parameter:

[WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing

Please refer to WDK documentation for details about this test!

The following table shows the details for this test.

Test details
Specifications
  • Device.Audio.Base.ZeroGlitch
  • Device.Audio.Base.ReportSupportedProperties
  • Device.Audio.Base.WaveRTConformance
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.HardwareArchitecture
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

All test cases return PASS or FAIL. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

The test should return PASS if the following occur:

  1. Render to all audio endpoints simultaneously is successful.

  2. A nearby associated hardware mute control exists on compressed endpoints

  3. All audio render endpoints successfully render streams in exclusive pull mode.

  4. All audio capture endpoints successfully capture streams in exclusive pull mode.

More information

Command syntax

Command option | Description
AudioLogo | Without any options, the test enumerates audio devices.
-c [string] | This option starts the application and runs the test cases that are specified in the .profile file.
-h [string] | This option specifies the Plug and Play (PnP) ID of the device to be tested.
logo_win7_audiologo.pro | This is the .profile file of test cases to be run.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
AudioLogo.exe | <testbinroot>\nttest\multimediatest\AVCore\Audio\WDK</p>
Logo_win7_audiologo.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
S98wtt_u.dll | <testbinroot>\nttest\multimediatest\common</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files


Audio Codec - Audio Logo Test - Glitch - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efe246ce-6847-4d60-a113-066336006409

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Benchmark
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Class Driver Audio Logo Test - Certification - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16654eec-27a6-4277-bbd1-afce969aedbe

This automated test is functionally equivalent to the Audio Logo test. If the device that you are testing includes a non-inbox driver, this test is run. The test includes the same test cases as the Audio Logo test. However, the test runs against the inbox driver.

For more information, see Audio Logo Test - Certification.

Test details
Specifications
  • Device.Audio.UAACompliance.UAA
  • Device.Audio.Base.HardwareArchitecture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Development
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
WDKDeviceID | Device ID string
TestPro | Test Case Profile String


Audio Codec - Communications Audio Fidelity Test (Manual) - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b2c652c-71c3-4f8b-a1d2-dc40cb660168

The Windows Hardware Compatibility Program defines a minimum bar for audio quality of devices that have integrated loudspeakers and microphone(s). The Communications Audio Fidelity test verifies that the system meets the hardware certification requirements for a high fidelity audio playback and capture experience.

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

This test requires the following items:

  • One test computer that has at least one microphone and one loudspeaker (referred to as the Device under Test [DUT]).

  • One Polycom CX-100 USB device for reference and measurement.

The test is required for systems that have at least one microphone and one loudspeaker. The test does not require an anechoic chamber; it can be performed in a quiet office environment.

The in-air audio fidelity test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests play speech signals from the device under test and from a reference device to simulate realistic user scenarios.

You should perform the in-air audio fidelity tests in a typical office environment that has background noise that is less than 35 dBA SPL. Put the device under test (DUT) on a table in a position for typical usage and mount the Polycom CX-100 reference device on a tripod, as shown in REF _Ref345316931 \h Figure 1 Device under Test Setup. Connect the reference device to the DUT by using a USB connection.

Step-by-step instructions for running the test:

Watch the following video demonstration.

Video link

  1. Prepare the client for Windows HLK testing.

  2. Put the device and reference device in a quiet room (background noise less than 35 dBA SPL).

  3. Position the device and reference device according to the diagram in the reference document.

    1. 0.4 m forward of the device

    2. 0.3m above the device

    3. 0.5m overall

    4. Laptop or tablet screen should be at a 20 degree angle from vertical.

    5. Centerline of both devices should be lined up.

    6. The reference device should be vertically oriented as shown in REF _Ref345316931 \h Figure 1 Device under Test Setup, with its speaker facing the DUT.

  4. Connect the reference device to the DUT by using USB.

  5. Schedule and run the Communications Audio Test on the Windows HLK Controller.

audio fidelity test position

Figure 1 Device under Test Setup

The following eight tests are performed and the results are compared to the Windows Hardware Certification Requirements for in-air audio fidelity:

Microphone tests

  • Speech to noise ratio of the raw microphone signal when capturing a speech signal that is played back by the reference device that is located 0.5m from the DUT.

  • Digital signal level of the raw microphone signal when capturing a speech signal that is played back by the reference device that is located 0.5m from the DUT.

  • Clipping (saturation) of the raw microphone signal when capturing a speech signal played that is back by the reference device that is located 0.5m from the DUT.

Loudspeaker test

  • Output level of the loudspeaker(s) at 0.5m when rendering a digital speech signal by the DUT.

Combined microphone and loudspeaker tests

  • Clipping of raw microphone signal during loudspeaker playback of speech signal at nominal volume.

  • Echo attenuation by the Windows acoustic echo canceller during speech playback by the DUT.

  • Latency between microphone and loopback signal that is not reported by the timestamps.

  • Measurement of mouth to ear latency; that is, the time difference between when the signal is given to the loudspeaker renderer and when it is obtained from the microphone capture.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For additional troubleshooting information, see Troubleshooting Audio Testing.

Microphone tests troubleshooting

This section describes common problems that can occur during microphone testing.

Speech to noise ratio

If the speech to noise ratio is lower than the requirement, check the following possible causes:

  • The room in which the test has been performed is too noisy; it does not meet the <35dBA SPL requirement. Use a sound pressure level meter to verify that the background noise is below 35dBA SPL. Repeat the test in a quiet room that meets this requirement.

  • The microphone(s) have a low signal to noise ratio (SNR). Use microphones that have a higher SNR.

  • The microphones are not isolated from the fan noise. Make sure that quiet fans are used and that the microphones are located away from the fans and are mechanically isolated from fan noise.

  • Electrical components can cause a buzzing noise. Ensure electrical components don't emit any audible noise.

Digital signal level

This test plays a speech signal from the reference device and captures it by using the microphone of the DUT. The test automatically adjusts the microphone level in the control panel of the Windows operating system. If the microphone capture signal level is too low, we recommend the following solutions:

  • The analog microphone gain that is exposed to the operating system cannot be amplified high enough. Use an amplifier that has higher analog gain.

  • The sensitivity of the digital microphone is too low. Use a digital microphone that has higher sensitivity.

If the microphone capture level is too high, we recommend the following solutions:

  • The analog microphone gain that is exposed to the operating system has a signal that cannot be reduced low enough. Make sure that the correct gain range is exposed by using the firmware of the preamplifier.

  • The sensitivity of the digital microphone is too high. Use a digital microphone that has lower sensitivity.

Speech played back by reference device is clipped

If the microphone signal is clipped, we recommend the following solutions:

  • The analog microphone gain that is exposed to the operating system cannot be reduced low enough. Make sure that the correct gain range is exposed by using the firmware of the preamplifier.

  • The sensitivity of the digital microphone is too high. Use a digital microphone that has lower sensitivity.

Loudspeaker test troubleshooting

This section describes common problems that can occur during loudspeaker testing.

Output signal level

If the loudspeaker output level is too low, we recommend the following solutions:

  • Check that the loudspeaker assembly is properly sealed to the speaker grill.

  • Check that the grill holes are more than 50% open.

  • Use a loudspeaker that has higher sensitivity.

Combined microphone and loudspeaker tests troubleshooting

This section describes common problems that can occur during combined microphone and loudspeaker testing.

Speech played back by device under test is clipped

This test plays back a speech signal from the DUT and captures the signal on the same DUT. The test checks whether the captured signal is clipped (that is, saturated) after the microphone level found in the control panel of the Windows operating system is automatically adjusted to prevent clipping. The microphone level is only reduced to a point where it still meets the requirement for the microphone output signal level when it plays back a speech signal from the reference device. For example, a device under test might need a microphone level of ≥+10dB to pass the microphone output signal test. In this case, the clipping test for speech played back by the DUT needs to pass at a microphone level setting of ≥+10dB.

If the microphone signal that is recorded during playback of sound by the speaker was clipped (saturated), we recommend the following solutions:

  • Mechanically isolate the loudspeakers from the microphones to reduce the loudspeaker to microphone coupling. In addition, to prevent coupling through the device enclosure, the microphone boot should be sealed to the chassis and the speaker assembly should be sealed to the speaker grill.

  • Ensure that the analog gain of the preamplifier can be reduced enough to avoid microphone clipping.

Echo attenuation

If the acoustic echo canceller cannot remove a sufficient amount of echo in the microphone signal, we recommend the following solutions:

  • Reduce the coupling total harmonic distortion and noise by reducing rattles that are caused to keys, wires, tape, etc.

  • Increase the terminal coupling loss by more fully separating loudspeaker(s) and microphone(s).

  • Use loudspeakers that have better total harmonic distortion.

Unreported latency between microphone and loudspeaker loopback signal

To ensure that the microphone signal is either completely aligned with the loudspeaker signal or is slightly delayed, acoustic echo cancellers align the loudspeaker and microphone signal based on timestamps. If too much delay occurs, the acoustic echo canceller cannot fully cover the echo that is caused by reverberation. Failures must be fixed by improving the implementation of the timestamps. A timestamp is determined by device streaming positions (DevPos), application streaming position (AppPos) and system performance counter (QPC: query performance counter) by using the IAudioCaptureClient::GetBuffer method. Assuming that the audio stream sampling rate is FS, the timestamp is calculated as: TS=QPC+(AppPos-DevPos)/FS.

Mouth to ear latency

If mouth to ear latency is too high, users cannot have a full-duplex conversation and unintentionally talk over each other. We recommend that you reduce latency in the following ways:

  • Improve the audio driver to have a lower delay.

  • Reduce the delay in render-side on-board processing (for example, volume leveler algorithms), or turn off render-side processing.

  • If a raw microphone API is used, make sure that the audio drivers disable capture side processing (as required by the Windows Hardware Certification Requirements).

More information

Parameters

Parameter name | Parameter description
CmdLnOptions | Command line options
LLU_NetAccessOnly | Name of machine's LLU for copying files
WDKDeviceID | Device Id String


Audio Codec - Device Power State Transition Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16ab8841-0aa3-4fe1-8d12-2fc9e27cda91

This automated test verifies that an audio codec can resume from its D3 sleep state to a running state (D0) in the appropriate amount of time to comply with Windows requirements.

Test details
Specifications
  • Device.Audio.Base.PowerManagement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Development
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

All test cases return PASS or FAIL. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

If there are failures in this test, confirm that the hardware is capable of resuming from D3 in the appropriate amount of time in accordance with Windows requirements.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExePath | Partial path of the test executable
WDKDeviceID | Device ID


Audio Codec - DRM Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bc47d11-e275-4309-aa8a-e0ecd0aa76fb

This automated test verifies that audio devices comply with Windows trusted audio paths for digital rights management (DRM). Hardware that complies with Windows DRM supports DRM level 1300. The audio drivers must not call the DrmForwardContentToFileObject function.

NOTE

The DRM requirement does not apply to Bluetooth audio devices.

Test details
Specifications
  • Device.Audio.Base.DRM
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
Expected run time (in minutes) | 8
Category | Development
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

More information

Command syntax

Command option | Description
CScript DevIDparse.vbs /WDKDeviceID: [WDKDeviceID] | Runs the test job.

File list

File | Location
DevIDParse.vbs | <testbinroot>\nttest\MULTIMEDIATEST\avcore\audio\scripts</p>
s98wtt.dll | <testbinroot>\nttest\multimediatest\common

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
WDKDeviceID | Device ID string


Audio Codec - General Audio Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d6b6f82-3777-4962-b0dc-336cbbaa2ac3

Parameter: Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.KSPROPERTYAUDIOVOLUMELEVEL
  • Device.Audio.Base.ReportSupportedProperties
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.KSTopologyCompliance
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
WDKDeviceID | Device ID under test


Audio Codec - General Audio Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aae8c46b-044d-4b42-9208-8994a807f88f

Parameter: Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.KSPROPERTYAUDIOVOLUMELEVEL
  • Device.Audio.Base.ReportSupportedProperties
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.KSTopologyCompliance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestPro | Name of test profile
WDKDeviceID | Device ID under test


Audio Codec - Hardware Offload of Audio Processing Test - Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/20701a6e-e09d-4e4f-b43b-64a3995d33a5

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of the machine's LLU for copying files


Audio Codec - Hardware Offload of Audio Processing Test - Certification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e115648d-b079-462e-b20f-0d0a7b538aef

This automated test verifies hardware-based audio offloading or processing.

Test details
Specifications
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.HardwareAudioProcessing.AudioHardwareOffloading
  • Device.Audio.HardwareAudioProcessing.ETWEvent
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

More information

Command syntax

Command option | Description
Te.exe haptest.dll /enablewttlogging | [This content isn't available yet.]
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Audiostreaming.dll | <testbinroot>\nttest\multimediatest\avcore\audio\bin</p>
Haptest.dll | <testbinroot>\nttest\multimediatest\avcore\audio\bin</p>
Sndanlyz.dll | <testbinroot>\nttest\multimediatest\common</p>
Te.exe | <testbinroot>\Testing\Runtimes\TAEF\x86</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID String
LLU_NetAccessOnly | Name of the machine's LLU for copying files


Audio Codec - Hardware Offload of Audio Processing Test - Reliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c39095c0-c324-4b97-bdc8-455c5d2b5b95

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of the machine's LLU for copying files


Audio Codec - KS Position Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59caf630-c395-4b6c-b9b1-b6a618dc12e4

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing [WDKDataWhqlQualification] - set this parameter to either "Premium" or "Basic" to run premium or basic logo test profile respectively Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.WAVEFORMATEXTENSIBLESupport
  • Device.Audio.Base.WaveRTConformance
  • Device.Audio.UAACompliance.UAA
  • Device.Audio.Base.BasicDataFormats
  • Device.Audio.Base.ChannelMasks
  • Device.Audio.Base.RealtimeDriversSupportStandardLoopedStreaming
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.SamplePositionAccuracy
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files


Audio Codec - KS Topology Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1afb964-7c78-441a-a00b-a834e0868480

Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Endpoints
  • Device.Audio.Base.PowerManagement
  • Device.Audio.Base.VolumeControl
  • Device.Audio.Base.AudioProcessing
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
WDKDeviceID | Device ID under test


Audio Codec - KS Topology Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/907068eb-1f63-45fe-9989-6aff8f8745e9

Parameter: [WDKDeviceID] - set this parameter to device ID + instance ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.KSPROPERTYAUDIOVOLUMELEVEL
  • Device.Audio.Base.JackDetection
  • Device.Audio.Base.JackConnectorStateDescription
  • Device.Audio.Base.VolumeControl
  • Device.Audio.Base.ReportSupportedProperties
  • Device.Audio.Base.NoUncontrollableStreamRouting
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.KSTopologyCompliance
  • Device.Audio.Base.Endpoints
  • Device.Audio.Base.PowerManagement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Lullaby Test - Certification - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae5fab5a-51bb-4d66-a675-bb41feb4dae8

This automated test verifies audio during power-state transitions. The test plays audio before, during, and after transitions into sleep and hibernate power states to verify the integrity of the audio pipeline.

Specifically, the test uses the Microsoft® DirectSound® and Wave APIs to play audio, calls Advanced Configuration and Power Interface (ACPI) functions to put the computer into a low-power state, and awakens the computer by using a wait able timer event. The test then verifies that audio still plays correctly.

Test details
Specifications
  • Device.Audio.Base.PowerManagement
  • Device.Audio.Base.JackDetection
  • Device.Audio.Base.Endpoints
  • Device.Audio.HardwareAudioProcessing.AudioHardwareOffloading
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

The test returns FAIL if it does not detect an audio device, if it cannot set the power state of the computer, or if the audio pipeline is in an inconsistent state. For specific information about failures, review the test results in the generated log file.

Depending on BIOS, the test might require user intervention. If BIOS does not support wake from sleep and wake from hibernate, you must bring the computer out of sleep states for the test to continue.

More information

Command syntax

Command option | Description
Lullaby | Without any options, the test opens the GUI.
-c [string] | This option starts the application and runs the test cases that are specified in the .pro file that [string] specifies.
-h [string] | This option specifies the Plug and Play (PnP) ID of the device for the test cases to use. The default value is all devices.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
DevIDParse.vbs | <testbinroot>\nttest\multimediatest \avcore\audio\scripts</p>
Lullaby.exe | <testbinroot>\nttest\multimediatest\avcore\audio\wdk
Logo_win7_lullaby.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
Logo_vista_lullaby.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
S98wtt.dll | <testbinroot>\nttest\multimediatest\common</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestExePath | Partial path of the test executable
WDKDeviceID | Device ID string
TestPro | Name of test profile


Audio Codec - Lullaby Test - Functional - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05df4da9-a322-4d8d-83fa-49c5fcc3e91e

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestExePath | Partial path of the test executable
WDKDeviceID | Device ID string
TestPro | Name of test profile


Audio Codec - Lullaby Test - Reliability - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/add1554b-5026-42ce-b15e-f812dfbbf351

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestExePath | Partial path of the test executable
WDKDeviceID | Device ID string
TestPro | Name of test profile


Audio Codec - Lullaby Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebc0b1dd-561c-49d7-91c3-acf201086221

Test details
Specifications
  • Device.Audio.HardwareAudioProcessing.AudioHardwareOffloading
  • Device.Audio.HardwareAudioProcessing.ETWEvent
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.PowerManagement
  • Device.Audio.Base.Endpoints
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of the machine's LLU for copying files


Audio Codec - MediaCapture API Test - Test Audio Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73fab36e-9017-47d6-a61c-b3b1278ada9a

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MediaCapture)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 50
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllAudioDevices |


Audio Codec - MFCaptureEngine API Test - Capture AAC Audio samples from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e4443b9-294a-421e-bec0-20a78397beee

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture AMR-NB Audio to a file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e99fce66-b17d-446d-86d5-44b08d7c88f3

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture Audio to an AAC file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5df725e2-6b0e-40e0-b732-94fbae122516

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture MP3 Audio samples from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8cc609d2-954a-441b-9edd-78682273acb6

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture MP3 Audio to a file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c80b96d-0818-4adc-acca-2827ceaae337

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture PCM Audio samples from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd6e15ec-3253-4302-a867-b9c02a12368d

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture PCM Audio to a wav file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93e41886-1b08-4b98-bc41-fa0aa9d06bf6

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture WMA9 audio samples the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d373ec1-357d-4056-942f-c1f9bbcc1f78

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - MFCaptureEngine API Test - Capture WMA9 Audio to an wma file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efe258a7-aab3-455c-9a87-d12e93625588

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • Device.Audio.Base.SupportWindowsAPIs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Audio Codec - SysFX Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76583675-20f6-45e4-8792-8c043a45644a

This automated test verifies users have the ability to enable and disable system effects on an audio endpoint in the event it is malfunctioning or otherwise affecting the user experience.

During this test, you must respond to prompts displayed to complete the test.

Test details
Specifications
  • Device.Audio.APO.MicArrayRawData
  • Device.Audio.APO.WinPEConformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

Before you start this test, install your device and driver and verify that the audio device is working properly. As with most UI automation tests, make sure that the desktop is free of unnecessary windows or other elements. Do not cause any manual input (via keyboard or mouse) that might disturb the test while it is running.

If multiple languages are installed on the test computer, you must select a preferred display language in Control Panel.

To set the preferred language

  1. In Control Panel, click Region and Language.

  2. Click the Keyboards and Languages tab.

  3. Under Display language, under Choose a display language, click English.

  4. Click OK.

  5. To apply settings, log off and then log back on, or restart the computer.

  6. If you need it, use Testpassword,1 as the password for the DTMLLUAdminUser account.

More information

This test is an automated user interface test. The script verifies that each extensible vendor-provided system effects property page set which is in turn to be registered on each visible endpoint (displayed to the user within the MM Control Panel CPL configuration dialogs) implements at least one check box to enable and disable the said audio effect; per the Microsoft Windows Logo Program requirements.

This manual test provides an automated UI test. The script verifies that each extensible vendor-provided system effects property page set which is in turn to be registered on each visible endpoint (displayed to the user in the MM Control Panel CPL configuration dialog boxes) implements at least one check box to enable and disable the audio effect; in compliance with the Windows Hardware Lab Kit (HLK) requirements.

On each audio playback or recording endpoint that the test finds to have registered UI to be displayed in the form of a property-sheet set that is visible to users, a check-box requirement exists.

For these endpoints, a conventional check-box control must be both visible and functional on at least one property sheet in each vendor-provided property page that is set on each registered endpoint. The check box must have the correct control ID set so that this UI automation test can identify it and make sure that it is working appropriately.

NOTE

The check box must set the correct property-key value for enabling (when it is selected) and disabling (when it is cleared) the Audio Processing Object (APO).

Command syntax

Command option | Description
Cscript sysfx.ui.wdk.verifyenabledisablecheckbox.wsf | Without any options, the test runs through its default verification. Note When you are scheduling from Job Explorer for private testing, set the [WDKDeviceID] option to the device ID.
NOTE

For help with this test job, review the Sysfx.ui.wdk.verifyenabledisablecheckbox.wsf file in a text editor.

File list

File | Location
S98wtt.dll | <testbinroot>\nttest\multimediatest\common</p>
Sysfx.ui.wdk.verifyenabledisablecheckbox.wsf | <testbinroot>\nttest\multimediatest\deviceui\UIScripts\sysfx\sysfx.ui.wdk.verifyenabledisablecheckbox.wsf

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - SysFX Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50e979c2-629d-4019-bd16-9b9fb7821e95

Parameter: Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.APO.MicArrayRawData
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
WDKDeviceID | Device ID under test


Audio Codec - UAA Test (Manual) - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cd7d686-b209-4708-8536-fa751f009581

This automated test validates that High Definition (HD) Audio controller and Codec hardware meet the requirements for making sure that the Microsoft HD Audio class driver works correctly. This test also validates that the system BIOS is correctly programming the pin configuration registers in the codec.

Test details
Specifications
  • Device.Audio.AudioController.HDControllerCompliance
  • Device.Audio.UAACompliance.UAA
  • Device.Audio.Base.HardwareArchitecture
  • Device.Audio.HDAudio.HDAudioSpecCompliance
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

For the list of standard prerequisites, seeAudio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestExePath | Partial path of the test exe
TestPro | Name of test profile
WDKDeviceID | Device ID string


Audio Codec - USB Audio Logo Test (Manual) - Certification - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36b1763e-0c6b-4a6e-a1cf-f4723b8d947b

This manual test hosts test cases for USB audio devices.

Parameter:

[WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing

Test details
Specifications
  • Device.Audio.USB.HIDControls
  • Device.Audio.USB.USB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

The test returns PASS if audio-capable, video-capable, and audio/video-capable USB communication devices implement human interface device (HID) controls according to USB HID specifications. The test returns SKIP if no USB device is enumerated on the system.

More information

Command syntax

Command option | Description
Shellrunner | Without any options, the test enumerates devices.
-c [string] | This option starts the application and runs the test cases that are specified in the .profile file.
-h [string] | This option specifies the Plug and Play (PnP) ID of the device to be tested.
logo_win7_usbaudlogo.pro | This is the .profile file of test cases to be run.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
S98wtt_u.dll | <[testbinroot]>\nttest\multimediatest\common</p>
Shellrunner.exe | <[testbinroot]>\nttest\multimediatest\common</p>
USBAudLogo.dll | <[testbinroot]>\nttest\multimediatest\avcore\audio\wdk
Logo_win7_usbaudlogo.pro | <[testbinroot]>\nttest\multimediatest\AVCore\Audio\Profiles</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Verify Audio EffectsDiscovery

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b516982-c200-4e51-8cdc-ade4836ac583

Test details
Specifications
  • Device.Audio.Base.AudioProcessing
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU


Audio Codec - Verify Audio EffectsDiscovery (Manual) - Certification - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9ffe6819-92f8-4cd8-8174-3f74a6468c8a

  • Test1/Test2

    Use WinRT APIs to check for the existence of raw mode support on a capture or render audio device. To support raw mode, the driver must support the new DDI for audio signal processing modes.

  • Test3/Test4

    Check for effects that are turned on by default in capture or render device on raw or default streams. On raw streams, the only expected effects are endpoint mode effects such as speaker compensation or speaker protection. On render stream of the Communication category, no effects are expected other than endpoint effects. The presence of effects in the Other category can also fail the test.

  • Test 5/Test 6

    In this test, all effects are disabled and then raw and default streams are queried to ensure that no effects other than must-have effects are on in the pipeline. Must-have effects include endpoint effects that cannot or should not be turned off.

  • Manual tests:

    This test ensures that when each of the effects on the UI (Microsoft Store App UI, or Enhancements tab in Sound Control panel) is enabled, the effects list shows up correctly.

    The test will iterate through each render/capture device and show the initial list of default effects on raw and default streams. It then prompts you to enable the effects on the UI. You can enable the effects one at a time or all at once. You should pay attention to the list of effects displayed as they choose each option. This should be repeated for each device. After the tests are done, you should press Enter to proceed. You are asked if the list of effects displayed is accurate. You can select Y or N as answer.

Test details
Specifications
  • Device.Audio.Base.AudioProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU


Audio Codec - Voice Activation Manager Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6834a4ac-94e8-4995-be44-009835d0625c

Validate HW support for KSPROPSETID_SoundDetector properties

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation


Audio Codec - Wave Test - Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1a177af-a63d-497b-81a9-560ab49fae8d

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing [WDKDataWhqlQualification] - set this parameter to either "Premium" or "Basic" to run premium or basic logo test profile respectively Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Wave Test - Certification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed35b0cd-7562-446f-92a6-6ed0a42ff1c6

This automated test validates that an audio device and driver meet the basic requirements for capture and playback of pulse code modulation (PCM) data.

The test exercises simple combinations of capture and playback of PCM data by using the kernel-streaming (KS) interfaces.

Test details
Specifications
  • Device.Audio.Base.WAVEFORMATEXTENSIBLESupport
  • Device.Audio.Base.WaveRTConformance
  • Device.Audio.UAACompliance.UAA
  • Device.Audio.Base.BasicDataFormats
  • Device.Audio.Base.ChannelMasks
  • Device.Audio.Base.RealtimeDriversSupportStandardLoopedStreaming
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.StreamingFormats
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

More information

Command syntax

Command option | Description
Wavetest | Without any options, the test opens the user interface.
-c [string] | This option starts the application and runs the test cases that are specified in the .profile file.
-h [string] | This option specifies the Plug and Play (PnP) ID of the device to test. Default is all devices.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Logo_win7_wavetest.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
Logo_vista_wavetest.pro | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
S98wtt.dll | <testbinroot>\nttest\multimediatest\AVCore\Audio\Profiles</p>
Wavetest.exe | <testbinroot>\nttest\multimediatest\avcore\audio\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files


Audio Codec - Wave Test - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/425872ba-55b3-4e8e-82e6-6077a8a769e7

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing [WDKDataWhqlQualification] - set this parameter to either "Premium" or "Basic" to run premium or basic logo test profile respectively Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Wave Test - Threshold - Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5526f9a-48a6-46b9-a4fe-f301650272ab

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing [WDKDataWhqlQualification] - set this parameter to either "Premium" or "Basic" to run premium or basic logo test profile respectively Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Audio Codec - Wave Test - Threshold - Certification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e2409f1e-d6ae-4fef-8991-790016959448

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing [WDKDataWhqlQualification] - set this parameter to either "Premium" or "Basic" to run premium or basic logo test profile respectively Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.WAVEFORMATEXTENSIBLESupport
  • Device.Audio.Base.WaveRTConformance
  • Device.Audio.UAACompliance.UAA
  • Device.Audio.Base.BasicDataFormats
  • Device.Audio.Base.ChannelMasks
  • Device.Audio.Base.RealtimeDriversSupportStandardLoopedStreaming
  • Device.Audio.Base.AudioProcessing
  • Device.Audio.Base.StreamingFormats
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files


Audio Codec - Wave Test - Threshold - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/77eec9d1-2f1a-40c5-9331-f66575cb8670

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing [WDKDataWhqlQualification] - set this parameter to either "Premium" or "Basic" to run premium or basic logo test profile respectively Please refer to WDK documentation for details about this test!

Test details
Specifications
  • Device.Audio.Base.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Audio additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


Bluetooth - BluetoothAudioClassesVerify (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8761de9-51ff-4f77-a5d4-8f74cffd752f

Verifies the current bluetooth audio device supports contains sensible class of device information.

Test details
Specifications
  • Device.Audio.Bluetooth.AtleastOneProfileSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation


Bluetooth - BluetoothAudioProfilesVerify (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1d0feabe-ed11-4e30-88f3-fa9ecd30ed9c

Verifies the current bluetooth audio device supports one of the Bluetooth Audio profiles

Test details
Specifications
  • Device.Audio.Bluetooth.AtleastOneProfileSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Audio additional documentation


Device.Audio additional documentation

In this section

  • Troubleshooting Audio Testing
  • Audio Device Testing Prerequisites


Troubleshooting Audio Testing

This article describes how to troubleshoot problems that can occur during Windows Hardware Lab Kit (Windows HLK) Device.Audio and System.Fundamentals audio tests.

In this article:

  • General audio test issues

  • Jack detection issues

  • Wireless display issues

General audio test issues

To troubleshoot general audio test issues, start with the following steps:

  1. Make sure that all audio endpoints are connected and capable of streaming. This includes but is not limited to headphones, high definition multimedia interface (HDMI), DisplayPort, Sony/Philips digital interface (S/PDIF), and other endpoints.

    1. To verify that all devices are connected, open the sound control panel by typing mmsys.cpl from a command prompt window. All devices on both the playback and recording tabs should show as being connected.

    2. Sometimes devices do not display if they were disconnected or disabled. To make sure that all devices are visible, right-click the background of the control panel and verify that both Show Disabled Devices and Show Disconnected Devices are checked.

    3. To check endpoints on the playback tab for streaming capability, right-click the endpoint and select Test. You should hear audio from the endpoint and see the corresponding meter move.

    4. To check endpoints in the recording tab for streaming capability, speak into the microphone and confirm that the meter moves.

  2. The fidelity test has a complex setup. Confirm that the test environment is set up correctly. Make sure that you have the cables connected properly. Improperly connected or missing cables result in failures, such as very low THD+N.

  3. The audio logo tests include several test cases that validate the zero glitch requirement. If a test fails on a glitch test case, we recommend that you review the hardware and driver for issues that can cause glitches. In particular, look for the following causes:

    • Improper thread priority in drivers together with long DPC / ISRs.

    • Improper hardware power management.

  4. If a test fails, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  5. Verify that you have installed the latest Windows HLK filters and kit updates. For more information, see Windows Hardware Lab Kit Filters.

  6. Review the following Windows HLK topics:

    • Troubleshooting Windows HLK Test Failures

    • Audio Device Testing Prerequisites

Jack detection issues

Some audio-device vendors use a four-ring combo jack, which uses headsets that similar to the headsets that are used for the iPhone. Normal microphone or head phone plugs have the following three contacts (TRS): tip: left, ring: right, and sleeve: ground. The combo headset has the following four contacts (TRRS): tip: left, ring1: right, ring2: ground, and sleeve: microphone. These combo jacks are connected to two ports on the Codec simultaneously. Therefore, they must trigger two jack-detection signals simultaneously.

There is a known issue with the HDAudio.sys driver on Windows 7 and Windows Vista. It does not correctly handle simultaneous, or nearly simultaneous, jack-detection signals. You can work around this issue by plugging the device into the jack more slowly.

Wireless display issues

The audio tests listed below are not suitable for testing devices supporting Wireless Display functionality. It is possible for the tests to fail the devices due to unreachable audio endpoints while a wireless endpoint is connected.

Affected Audio Tests

  • Audio Logo Test
  • Class Driver Audio Logo Test
  • Class Driver KS Topology
  • Class Driver Round Trip Test
  • Round Trip Test

The error message is FAIL: Endpoint (XXXXXX) is unplugged, where XXXXXX is the name of Wireless Audio Endpoint.

Workaround

Prior to running the affected audio tests, disconnect wirelessly-connected endpoints, such as wireless monitors, from the test device. You can reconnect the wireless endpoints after testing.

Related topics

Device.Audio Tests

System.Fundamentals Tests

Troubleshooting Windows HLK


Audio Device Testing Prerequisites

This section describes the tasks that you must complete before you test an audio device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing an audio device. You might need additional hardware if the test device provides bus-specific support. To determine whether additional hardware requirements apply, see the test description for each bus-specific test.

  • Two test computers. These test computers must meet the Windows HLK prerequisites and must be included in the same computer pool. For more information, see Windows HLK Prerequisites. If the device being tested is a Bluetooth audio device, you need one of the test computers to include a Bluetooth radio, or you must have a Bluetooth controller adapter installed or connected to one of the test computers.

  • One audio device to be tested.

  • For in-air tests, a microphone or another active source for audio capture.

    NOTE

    For in-air tests, a microphone or another active capture source (such as an S/PDIF cable that is attached to an audio/video receiver that is actively playing back audio) must be attached to all capture endpoints. In addition, speakers or headphones must be attached to all render endpoints.

  • A sound playback device (speakers or headphones).

  • An Audio Precision System Two analyzer. This is required when the Fidelity Test is run and a host computer (x86 or AMD64 based) is used for communication during that test.

  • An audio loopback cable.

    NOTE

    For loopback tests, loopback cables must be plugged into all jacks under testing. This links the render jacks to the capture jacks.

WARNING

All audio devices must be plugged in during audio testing.

The following diagram shows how to configure your hardware for Device.Audio testing.

diagram of a windows hlk setup for audio device te

This configuration is specifically required to complete the Audio Fidelity test; however, all other audio tests can be completed without changes to this setup.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required for testing an audio device:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Audio Precision System Two software

    NOTE

    The second computer is required to complete the Fidelity Test. However, if that test is run in Import log mode, the audio processor is not required.

Test computer configuration

To complete audio testing, you must configure two computers. The computer that includes the test audio device is referred to as the System under Test (SUT). The computer that receives audio communications from the SUT is referred to as the AP Host.

NOTE

The secondary computer must contain either an x86 or an AMD64 processor.

To configure the SUT for the testing of an audio device follow these steps:

If your SUT supports HDMI video and audio output capability, you SUT must be connected to an HDMI audio capable device such as an HDMI Monitor or an A/V Receiver.

  1. Install the appropriate Windows operating system on the test computer and then configure the computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. For an external audio device, install or attach the hardware to be tested on the test computer.

  3. Install the manufacturer-supplied device driver, if you have to, on the test computer.

  4. Set up the device configuration that is specified in the Fidelity Test.

  5. Check that the capture device functions correctly on the test computer. If you are testing a Bluetooth audio device, verify that it is paired with the test computer.

  6. Install the Windows HLK client application on the test computer.

  7. By using Windows HLK Studio, create a machine pool and move the test computer to that pool.

To configure the AP Host for the testing of an audio device follow these steps:

  1. Install the appropriate Windows operating system on the test computer and then configure the computer for your test network.

  2. Install the Windows HLK client application on the test computer.

  3. Using Windows HLK Studio, move the AP Host computer to the same machine pool that contains the test computer.

If the test computers include a third-party firewall, then the SUT and AP host must be configured as follows:

  • On the SUT there must be a firewall exclusion to allow the Fidelitytestapp.exe (located at <testbinroot>\nttest\multimediatest\avcore\audio\wdk) to receive incoming traffic on port 135.

  • On the AP Host, there must be a firewall exclusion to allow the dllhost.exe (located at <windir>\system32) to receive incoming traffic on port 135.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Device.BusController

In this section

  • Device.BusController tests
  • Device.BusController additional documentation


Device.BusController tests

  • Bluetooth - LE Supported States - Peripheral Role Support (Bring Up)
  • Bluetooth - LE Supported States - Scatternet Support (Bring Up)
  • Bluetooth - Wide Band Speech Capability (Bring Up)
  • Bluetooth - Wide Band Speech Offload Capability (Bring Up)
  • PWM WinRT Concurrent Creation (Reliability)
  • PWM WinRT Concurrent Usage (Reliability)
  • PWM WinRT Functional Tests (Development and Integration)
  • PWM WinRT SetActiveDutyCycle (Reliability)
  • PWM WinRT SetActiveDutyCycle Benchmark (Tuning and Validation)
  • PWM WinRT SetDesiredFrequency Benchmark (Tuning and Validation)
  • [Dual-Role MUTT] Bulk IO Tests (Long)
  • [Dual-Role MUTT] Bulk IO Tests (Short)
  • [Dual-Role MUTT] Enumeration Tests (Long)
  • [Dual-Role MUTT] Enumeration Tests (Short)
  • [Dual-Role MUTT] Interrupt Tests (Long)
  • [Dual-Role MUTT] Interrupt Tests (Short)
  • AtrForDesfire
  • AtrForMifareCL1K
  • AtrForMifareUL
  • AtrForMifareULC
  • AuthKeyBMifareCL1k
  • Bluetooth - 4LeSpecification (Development and Integration)
  • Bluetooth - 4LeSpecification (Reliability)
  • Bluetooth - Hardware Offload Limit (Dev and Int.)
  • Bluetooth - LEStateCombinations1 (Bring Up)
  • Bluetooth - LEWhiteList1 (Bring Up)
  • Bluetooth - MicrosoftBluetoothStackPresent1 (Bring Up)
  • Bluetooth - NoBluetoothLEFilterDriver1 (Bring Up)
  • Bluetooth - NonUsbPerformance (Reliability)
  • Bluetooth - NonUsbScoSupport (Development and Integration)
  • Bluetooth - OnOffStateControllableViaSoftware1 (Bring Up)
  • Bluetooth - OnOffStateControllableViaSoftware2 (Reliability)
  • Bluetooth - Optional - HciExtension1 (Bring Up)
  • Bluetooth - Optional - HciExtensions (Development and Integration)
  • Bluetooth - Scatternet (Development and Integration)
  • Bluetooth - SimultaneousBrEdrAndLeTraffic (Development and Integration)
  • Bluetooth - SimultaneousBrEdrAndLeTraffic1 (Bring Up)
  • Bluetooth - SpecificInformationParameters1 (Bring Up)
  • Bluetooth - SupportsBluetooth21AndEdr (Development and Integration)
  • Bluetooth - UsbScoDataTransportLayer (Development and Integration)
  • CancelIsAbsent
  • CancelIsPresent
  • CardEmulationOnHandleExclusive
  • CardEmulationOnOff
  • CardEmulationOnOff
  • CardEmulationSetTwice
  • CardEmulationSetTwice
  • ChannelId
  • Characteristics
  • ClosePublishHandle
  • CloseSeManageHandleWhileOn
  • CloseSeManageHandleWhileOn
  • Copy MITT binaries.
  • CurrentProtocol
  • CurrentProtocol
  • CustomKeyMifareCL1k
  • DeviceUnit
  • DropPublishMaxReceivingQueue
  • DropSubscribeMaxReceivingQueue
  • EnablePublishWhileTapped
  • EnableSubscribeWhileTapped
  • EnableTagWriteAndReadWhileTapped
  • GetAtrDesfireInvalidOutBuffer
  • GetAttributesInvalidBuffer
  • GetAttributeStress
  • GetAttributeStress
  • GetData
  • GetData
  • GetEventAfterTimeout
  • GetEventAfterTimeout
  • GetEventBeforeTimeout
  • GetEventBeforeTimeout
  • GetMaxBytes
  • GetNextBeforeSubscribe
  • GetNextTransmittedWithBuffers
  • GetNextWithInvalidBuffer
  • GetNextWithInvalidBuffer
  • GetNfccCapabilities
  • GetOutputBufferSize
  • GetOutputBufferSize
  • GetPublishedMessageAfterTimeout
  • GetRoutingTable
  • GetStateInvalidParams
  • GetStateInvalidParams
  • GetSubscribedMessageAfterTimeout
  • GetTransmissionRate
  • GPIO WinRT Functional and Stress Tests
  • I2C WinRT Advanced Functional Tests (mbed LPC1768 Required)
  • I2C WinRT IO Stress Tests (EEPROMs Required)
  • I2C WinRT Nonexistent Slave Address Tests
  • I2C WinRT Read Tests (EEPROM Required)
  • I2C WinRT Write Tests (EEPROM Required)
  • IccPresence
  • IccTypePerAtrForDesfire
  • IncDecMifareCL1k
  • InvalidBuffer
  • InvalidBuffer
  • InvalidBuffer
  • InvalidBuffer
  • InvalidBufferGetNext
  • InvalidBufferSubscribe
  • InvalidHandle
  • InvalidHandle
  • InvalidHandle
  • InvalidHandle
  • InvalidHandle
  • InvalidHandle
  • InvalidHandle
  • InvalidInAndOutBuffer
  • InvalidInBuffer
  • InvalidNdefTests
  • InvalidOutBuffer
  • IsAbsent
  • IsAbsentInvalidParams
  • IsAbsentInvalidParams
  • IsPresent
  • IsPresentInvalidParams
  • IsPresentInvalidParams
  • IsPresentIsAbsent
  • ManySeHceSubscriber
  • ManySESubscriber
  • ManySESubscriber
  • MessageTypeIsCaseSensitive
  • MITTI2C BasicIOKernel
  • MITTI2C BasicIORead
  • MITTI2C BasicIOSequence
  • MITTI2C BasicIOWrite
  • MITTI2C BusRecovery
  • MITTI2C CancelRead
  • MITTI2C CancelSequence
  • MITTI2C CancelWrite
  • MITTI2C ClockStretching
  • MITTI2C DeviceNACK
  • MITTI2C LockUnlock
  • MITTI2C PerfRead
  • MITTI2C PerfSequence
  • MITTI2C PerfWrite
  • MITTI2C Power
  • MITTI2C Stress
  • MITTSPI BasicFullDuplex
  • MITTSPI BasicIOKernel
  • MITTSPI BasicIORead
  • MITTSPI BasicIOSequence
  • MITTSPI BasicIOWrite
  • MITTSPI CancelRead
  • MITTSPI CancelSequence
  • MITTSPI CancelSequence
  • MITTSPI CancelWrite
  • MITTSPI LockUnlock
  • MITTSPI PerfRead
  • MITTSPI PerfSequence
  • MITTSPI PerfSequence
  • MITTSPI PerfWrite
  • MITTSPI Power
  • MITTSPI Stress
  • MITTUart LoopbackCancellation
  • MITTUart LoopbackGuardBuffer
  • MITTUart LoopbackReadWrite
  • MultipleRadioOffRequests
  • MultipleRadioOnRequests
  • NDEFMessageTypes
  • NDEFMultiRecord
  • NDEFRecordChunks
  • NfcMixedStress
  • PowerInvalidParams
  • PowerInvalidParams
  • PresenceEventNoMessage
  • PresenceEventPubSubAtOnce
  • PresenceEventPubSubManyMessage
  • PresenceEventWithReadOnlyTag
  • PresenceEventWithTag
  • PublishAndSubscribeMany
  • PublishAndSubscribeManyMessages
  • PublishAndSubscribeManyMessages2
  • PublishAndSubscribeManyMessagesWhileTapped
  • PublishBothP2PAndTag
  • PublishCancelIo
  • PublishDisableEnable
  • PublishMessageWithInvalidMessageData
  • PublishMessageWithInvalidMessageType
  • PublishMessageWithMaxMessageData
  • PublishMessageWithMaxSizeMessageType
  • PublishMultipleTags
  • PublishPartialDisableEnable
  • PublishTagsTwice
  • PublishTagTooLargeAfterTap
  • PublishTagTooLargeBeforeTap
  • PublishWriteTag
  • PublishWriteTagLaunchApp
  • PublishWriteTagWithPublish
  • PubOnRadioOff_AttemptToGetPubHandleFails
  • PubOnRadioOff_StackEntersD3
  • PubRadioOffOn_StackEntersExitsD3
  • PubSubRadioOff_AttemptToGetPubHandleFails
  • PubSubRadioOff_AttemptToGetSubHandleFails
  • PubSubRadioOff_GetKiloBytesPerSecondFails
  • PubSubRadioOff_GetMaxMessageBytesFails
  • PubSubRadioOff_StackEntersD3
  • PubSubRadioOffOn_GetKiloBytesPerSecondSucceeds
  • PubSubRadioOffOn_GetMaxMessageBytesSucceeds
  • PubSubRadioOffOn_PubSucceeds
  • PubSubRadioOffOn_SubSucceeds
  • RadioOffOnMultipleTimes
  • ReadAllFelica
  • ReadAllJewel
  • ReadAllMifareCL1k
  • ReadAllMifareUL
  • ReadAllMifareULC
  • RemoteDataExchange
  • RepeatCardEmulationOnOff
  • RepeatCardEmulationOnOff
  • RepeatedRemoteDataExchange
  • RepeatPublishAndSubscribeDifferentMessage
  • RepeatPublishAndSubscribeSameMessage
  • RepeatPublishAndSubscribeWithCardEmulation
  • RepeatPublishAndSubscribeWithLongSleep
  • RepeatPublishAndSubscribeWithSleep
  • RepeatPublishWriteTag
  • RepeatTagReading
  • RepeatTagReadingLonghaul
  • RepeatTagReadingWithCardEmulation
  • RepeatTapDesfire
  • RepeatTapDesfire
  • RepeatTapFelicaReadAll
  • RepeatTapMifare
  • RepeatTapMifareReadAll
  • RestoreDefaultKeyToMifareCard
  • ScardSpecific
  • ScardSpecific
  • ScardSpecificWithPower
  • ScardSpecificWithPower
  • SeEnumerationBasic
  • SeEnumInvalidBuffer
  • SeEnumVariousHandle
  • SEEventCancel
  • SEEventCancel
  • SEEventCloseWhilePending
  • SEEventCloseWhilePending
  • SeHceEventCancel
  • SeHceEventCloseWhilePending
  • SetPayLoadTwice
  • SetPayLoadWithOutputBuffer
  • SetProtocolInvalidParams
  • SetProtocolInvalidParams
  • SetRoutingTable
  • SetRoutingTable
  • SetRoutingTableContainingNfcDep
  • SetRoutingTableInvalidAidLengthSmall
  • SetRoutingTableInvalidAidLengthTooBig
  • SetRoutingTableInvalidInputBufferSize
  • SetRoutingTableInvalidOutputBuffer
  • SetRoutingTableInvalidProtocol
  • SetRoutingTableInvalidSecureElementId
  • SetRoutingTableInvalidTech
  • SetRoutingTableTooManyEntries
  • SetTagReadOnly
  • SPI WinRT Clock Frequency Verification Tests (mbed LPC1768 Required)
  • SPI WinRT IO Transfer Tests (mbed LPC1768 Required)
  • SPI WinRT Stride Verification Tests
  • SPI WinRT Transfer Gap Detection Tests (mbed LPC1768 Required)
  • StressGetState
  • StressIsAbsent
  • StressIsPresent
  • StressScardSpecific
  • SubOnRadioOff_AttemptToGetSubHandleFails
  • SubOnRadioOff_StackEntersD3
  • SubRadioOffOn_StackEntersExitsD3
  • SubscribeCancelIo
  • SubscribeDisableEnable
  • SubscribeMessageAgain
  • SubscribeMessageWithInvalidMessageType
  • SubscribeNotEnoughBuffer
  • SubscribePartialDisableEnable
  • SubscribeToDifferentSEEvents
  • SubscribeToDifferentSEEvents
  • SubscribeWhileTapped
  • SubscribeWhileTapped
  • SubscribeWithInvalidBuffer
  • SubscribeWithInvalidBuffer
  • SubscribeWithSeHceGuidAndNullGuid
  • SubscribeWithVariousSEs
  • SubscribeWithVariousSEs
  • TagWriteInvalidMessageType
  • TransmitInvalidDeviceState
  • TransmitInvalidDeviceState
  • TransmitMaxApduLength
  • TransmitMaxApduLength
  • TransmitMinApduLength
  • TransmitMinApduLength
  • TransmitNoCard
  • TransmitNoCard
  • TransmitNullParams
  • TransmitNullParams
  • TransmitStress
  • TransmitStress
  • TransmitSuccess
  • TransmitSuccess
  • TwoPendingIoctls
  • USB Host Controller Hardware Verifier Test
  • USB Install MUTT Tools
  • USB MUTT Firmware Update for Devices
  • USB TCD 1 Simple IO Completions
  • USB TCD 2 Bulk IO Cancellations
  • USB TCD 3 Bulk and Interrupt IO Cancellations
  • USB TCD 4 Isochronous IO Cancellations
  • USB TCD 5 Bulk and Isochronous IO Cancellations
  • USB TCD 6 All Endpoints IO Cancellations
  • USB TCD 7 Random Sized Bulk IO Cancellations
  • USB TCD 8 Isoch Completions Single Thread
  • USB TCD 9 Isoch Completions Multi-Thread
  • USB-IF Certification Validation Test (Controller)
  • USBStress (Mobile)
  • USBSTRESS Test
  • USBTCD MUTT IO Tests (Mobile)
  • VendorIfdType
  • VendorName
  • WindowsMessageTypes
  • WinUSB 1 Simple IO Completions
  • WinUSB 2 Bulk IO Cancellations
  • WinUSB 3 Bulk and Interrupt IO Cancellations
  • WinUSB 4 Isochronous IO Cancellations
  • WinUSB 5 Bulk and Isochronous IO Cancellations
  • WinUSB 6 All Endpoints IO Cancellations
  • WinUSB 7 Random Sized Bulk IO Cancellations
  • WinUSB 8 Isoch Completions Single Thread
  • WinUSB 9 Isoch Completions Multi-Thread
  • WinUSB MUTT IO Tests (Mobile)
  • WriteAllFelica
  • WriteAllIso15693
  • WriteAllJewel
  • WriteAllMifareCL1k
  • WriteAllMifareUL
  • WriteAllMifareULC
  • WriteTagPreventReceivingSubscribePayload
  • xHCI Debug Capability Device Compliance (Logo)


Bluetooth - LE Supported States - Peripheral Role Support (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4609ecd5-8f82-487a-b44b-21d16d13eb40

Validates the Bluetooth controller reports support for LE peripheral role.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.LEStateCombinations
  • System.Client.BluetoothController.Base.LEStateCombinations
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 2
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation

  • Device.BusController additional documentation


Bluetooth - LE Supported States - Scatternet Support (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b11e1107-327b-433e-8b54-b7f65223fe40

Validates the Bluetooth controller reports support for LE scatternet.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.LEStateCombinations
  • System.Client.BluetoothController.Base.LEStateCombinations
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 2
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.BusController additional documentation

  • System.Client additional documentation


Bluetooth - Wide Band Speech Capability (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0bed46c5-94d3-4188-b85c-2090e107d47d

Verifies that the Bluetooth controller can support wideband SCO audio over HCI.

Test details
Specifications
  • Device.BusController.Bluetooth.USB.ScoDataTransportLayer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


Bluetooth - Wide Band Speech Offload Capability (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3fe79e60-9d27-431d-a586-daf7346a98c1

Verifies that Bluetooth controller supports wideband SCO audio over a sideband DDI.

Test details
Specifications
  • Device.BusController.Bluetooth.NonUSB.ScoSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


PWM WinRT Concurrent Creation (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a73ce07-16a4-4e7b-b85d-85dcd3067937

Stress controller and pin concurrent creation.

Test details
Specifications
  • Device.BusController.Pwm.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Scenario
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description
WDKDeviceID | DeviceInstanceId of the device under test.

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation


PWM WinRT Concurrent Usage (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e63cad4e-a9f4-4443-86d4-583b40ba9ec3

Stress usage of controller and different pins concurrently.

Test details
Specifications
  • Device.BusController.Pwm.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Scenario
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description
WDKDeviceID | DeviceInstanceId of the device under test.

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation


PWM WinRT Functional Tests (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed0ba37e-5e64-44a7-94b4-da6ece511a5a

Does functional testing of PWM through the WinRT interfaces. Verifies that the underlying PWM device is compliant with the PWM DDI which includes but not limited to controller and pin defined device interface, state machines, sharing semantics, and supported IOCTLs.

Test details
Specifications
  • Device.BusController.Pwm.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 2
    Category | Development
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description
WDKDeviceID | DeviceInstanceId of the device under test.

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation


PWM WinRT SetActiveDutyCycle (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2280f074-4de1-479b-8686-1bb9ba7d1ce6

Stress setting of pin active duty cycle using different frequencies.

Test details
Specifications
  • Device.BusController.Pwm.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Scenario
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description
WDKDeviceID | DeviceInstanceId of the device under test.

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation


PWM WinRT SetActiveDutyCycle Benchmark (Tuning and Validation)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d19e8260-2310-4926-8d34-38f75bfa6bed

Measure the performance of setting pin active duty cycle using different frequencies.

Test details
Specifications
  • Device.BusController.Pwm.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 3
    Category | Benchmark
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description
WDKDeviceID | DeviceInstanceId of the device under test.

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation


PWM WinRT SetDesiredFrequency Benchmark (Tuning and Validation)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9bf5818-3ef0-4a39-948a-0936aa350643

Measure the performance of setting different controller frequencies using 50% duty cycle.

Test details
Specifications
  • Device.BusController.Pwm.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 3
    Category | Benchmark
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description
WDKDeviceID | DeviceInstanceId of the device under test.

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation


\Dual-Role MUTT\ Bulk IO Tests (Long)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7cb0d88d-583c-4582-8435-9665fd2d48e4

Dual-Role MUTT performs tests on the bulk I/O endpoints

Test details
Specifications
  • Device.BusController.UsbController.DualRoleController.Discretional
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 720
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
BulkIoTimeoutInMs | Duration of time, specified in milliseconds, for which the Dual-Role MUTT should repeat the tests


\Dual-Role MUTT\ Bulk IO Tests (Short)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53729039-3619-4a83-ac08-72b5c605e8b2

Dual-Role MUTT performs tests on the bulk I/O endpoints

Test details
Specifications
  • Device.BusController.UsbController.DualRoleController.Discretional
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


\Dual-Role MUTT\ Enumeration Tests (Long)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1af0d0ea-0b4f-4032-bbfd-a69707b7c56a

Dual-Role MUTT tries to enumerate the device

Test details
Specifications
  • Device.BusController.UsbController.DualRoleController.Discretional
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 720
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
EnumerationTimeoutInMs | Duration of time, specified in milliseconds, for which the Dual-Role MUTT should repeat the tests


\Dual-Role MUTT\ Enumeration Tests (Short)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0223965b-241e-47db-8e25-e9e14f505c8c

Dual-Role MUTT tries to enumerate the device

Test details
Specifications
  • Device.BusController.UsbController.DualRoleController.Discretional
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


\Dual-Role MUTT\ Interrupt Tests (Long)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2a3e349-e089-4638-86ac-02bd345aac40

Dual-Role MUTT performs tests on the interrupt endpoints

Test details
Specifications
  • Device.BusController.UsbController.DualRoleController.Discretional
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 720
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
InterruptTimeoutInMs | Duration of time, specified in milliseconds, for which the Dual-Role MUTT should repeat the tests


\Dual-Role MUTT\ Interrupt Tests (Short)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1132e582-a3ef-4387-b9a0-b3efa97b9ce0

Dual-Role MUTT performs tests on the interrupt endpoints

Test details
Specifications
  • Device.BusController.UsbController.DualRoleController.Discretional
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


AtrForDesfire

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33154a5a-2cb9-41c1-a080-854846d02f4b

Verify getting the ATR attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


AtrForMifareCL1K

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5ac058b-2a4b-43cc-8e94-7ecff6fe36f3

Verify getting the ATR attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


AtrForMifareUL

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/750bac7d-d70b-4603-8c0d-0cd176f53673

Verify getting the ATR attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


AtrForMifareULC

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae22f2fc-f1d7-4205-93b5-5656d440ce5b

Verify getting the ATR attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Auth Key B (MifareClassic1k)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9eec5482-9756-4efe-8bb2-9658c5b02b1b

Verify that we can use key B to auth Mifare Classic 1k card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


Bluetooth - 4LeSpecification (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d331b4f-44f4-41f1-b392-795e5d17d396

This test module verifies that a dual mode Bluetooth radio is capable of enabling/disabling discoverable mode, enabling/disabling connectable mode, sending/receiving data over a basic rate connection, and sending/receiving data over a low energy connection. 4LeSpecification1 This test verifies that the radio under test responds to inquiry when discoverable and non-connectable. 4LeSpecification2 This test verifies that the radio under test does not respond to inquiry when non-discoverable. 4LeSpecification3 This test verifies that the radio under test connects when non-discoverable and connectable. 4LeSpecification4 This test verifies that the radio under test transfers data over a low energy L2CAP fixed channel.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.4LeSpecification
  • System.Client.BluetoothController.Base.4LeSpecification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - 4LeSpecification (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38f8b917-00d4-4394-8300-e49e11d71340

This test module verifies that a Bluetooth radio is capable of handling throughput of L2CAP traffic that simulates common Bluetooth audio profile scenarios. AudioProfileTest Verify that the Radio under test can handle L2CAP traffic that simulates A2DP streaming music and AVRCP commands sent from the controller role. ControlMusicFromHost Verify that the Radio under test can handle L2CAP traffic that simulates A2DP streaming music and AVRCP commands sent from the target role.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.4LeSpecification
  • System.Client.BluetoothController.Base.4LeSpecification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - Hardware Offload Limit (Dev and Int.)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/881738ca-7e36-49c7-b7f4-fb88c7ff2210

Validates the Hardware Offload limit Reach for the Bluetooth controller.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.MicrosoftBluetoothStack
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


Bluetooth - LE Supported States - Legacy Minimum Requirement (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/416bddf4-a01d-4c83-943f-8cfd42e34d50

Validates the minimal Bluetooth LE supported state combinations.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.LEStateCombinations
  • System.Client.BluetoothController.Base.LEStateCombinations
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 2
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - LEWhiteList1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e293dfde-1181-44b7-bf80-c4e48f31c501

Validates the minimal Bluetooth LE whitelist size.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.LEWhitelist
  • System.Client.BluetoothController.Base.LEWhitelist
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - MicrosoftBluetoothStackPresent1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/43f72e80-f4c7-4d27-b3a8-ff64438d7c4e

Validates the presence of the Microsoft Windows Bluetooth stack.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.MicrosoftBluetoothStack
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


Bluetooth - NoBluetoothLEFilterDriver1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7aa39fe4-98d4-45ca-a89b-c514096bf48e

Validates that filter drivers are attached to the Bluetooth LE Enumerator

Test details
Specifications
  • Device.BusController.Bluetooth.Base.NoBluetoothLEFilterDriver
  • System.Client.BluetoothController.Base.NoBluetoothLEFilterDriver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - NonUsbPerformance (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b44ffb4-52a2-4ff8-a2fe-5bc22810e273

This test module verifies that a non USB Bluetooth controller meets the minimum throughput requirements for Bluetooth traffic. NonUsbPerformance1 This test verifies that the radio under test throughput is greater than the minimum throughput of 700kbps.

Test details
Specifications
  • Device.BusController.Bluetooth.NonUSB.Performance
  • System.Client.BluetoothController.NonUSB.ScoSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - NonUsbScoSupport (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5bc4b10-9311-46cd-a7fd-fd4c35ac382c

This test module verifies that a Bluetooth radio is capable of performing SCO operations via Sideband SCO. OpenSidebandScoChannel This test verifies that the radio under test is able to initiate an Sideband SCO connection. AcceptOpenSidebandScoChannel This test verifies that the radio under test is able to accept an incoming Sideband SCO connection. OpenEnhancedScoChannel This test verifies that the radio under test is able to initiate an Enhanced SCO connection.

Test details
Specifications
  • Device.BusController.Bluetooth.NonUSB.ScoSupport
  • System.Client.BluetoothController.NonUSB.ScoSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - OnOffStateControllableViaSoftware1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66574c98-3b2d-41ba-9799-88aaa8dca9aa

Validates the Radio ON and OFF functionality.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.OnOffStateControllableViaSoftware
  • System.Client.BluetoothController.Base.OnOffStateControllableViaSoftware
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - OnOffStateControllableViaSoftware2 (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9358c22d-4de3-4630-963a-5af123f5fcc4

Validates the Radio ON and OFF reliability by toggling the radio states.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.OnOffStateControllableViaSoftware
  • System.Client.BluetoothController.Base.OnOffStateControllableViaSoftware
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - Optional - HciExtension1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ed42f21-e8dd-4f76-883e-9b20a30b3cde

Validates the Bluetooth controller reported support for Microsoft's Hci extensions.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.HciExtensions
  • System.Client.BluetoothController.Base.HciExtensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - Optional - HciExtensions (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37966e33-0e5d-4085-ba71-572e3c56eb34

This test module verifies that all the HCI Extensions commands behave as defined by Microsoft Hci Extensions specification. HciExtensions1 This test verifies that we can obtain absolute RSSI for BR connections from controller HciExtensions2 This test verifies that we can monitor for RSSI values for BR connections and cancel it. HciExtensions3 This test verifies that we can monitor for RSSI values for LE connections and cancel it. HciExtensions4 This test verifies that the radio can filter for Advertisements when the filter command contains 2 patterns, service UUIDs, or Bluetooth Address. HciExtensions5 This test verifies that disabling and enabling advertisement filters behavior conforms to MSFT HCI Extensions Spec. HciExtensions6 This test verifies that a single pattern can match the entire advertisement payload. HciExtensions7 This test verifies that IRK can be offloaded to the hardware and that the hardware properly resolves resolvable addresses.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.HciExtensions
  • System.Client.BluetoothController.Base.HciExtensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - Scatternet (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/053910d5-cb2c-45ea-ae69-57d4ee16435d

This test module verifies that a Bluetooth radio supports at least two concurrent piconets, also known as a scatternet. ScatternetTest_3_Inquiry_1 This test verifies that the radio under test is able to become the subordinate role in one piconet while already being the master role in another piconet; including sustaining these roles while inquiring for other devices.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.Scatternet
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - SimultaneousBrEdrAndLeTraffic (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a418fd87-d6af-4038-a136-4f24ce11238b

This test module verifies that the Bluetooth radio is able to simultaneously communicate with BR and LE devices. DualModeTraffic_1 This test verifies that the radio under test is able to send Simultaneous BR/LE traffic at max MTU

Test details
Specifications
  • Device.BusController.Bluetooth.Base.SimultaneousBrEdrAndLeTraffic
  • System.Client.BluetoothController.Base.SimultaneousBrEdrAndLeTraffic
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - SimultaneousBrEdrAndLeTraffic1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ab4cd6a-31f0-43cc-b729-b38521608266

Validates the Bluetooth controller reported simultaneous BR/EDR and LE Traffic support.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.SimultaneousBrEdrAndLeTraffic
  • System.Client.BluetoothController.Base.SimultaneousBrEdrAndLeTraffic
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation


Bluetooth - SpecificInformationParameters1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10340e73-dd9c-4d30-9904-046e3f322cd7

Validates the minimal specification version and features of the Bluetooth controller.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.SpecificInformationParameters
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


Bluetooth - SupportsBluetooth21AndEdr (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/602d4ba9-c8d8-4168-a5e4-a4b9afcdfd14

This test module verifies that a Bluetooth radio is capable of performing 2.1 + EDR operations. SupportsBluetooth21AndEdr2 This test verifies that the radio under test is able to perform Secure Simple Pairing (SSP) using out-of-band data. SupportsBluetooth21AndEdr3 This test verifies that the radio under test is able to perform Secure Simple Pairing (SSP). SupportsBluetooth21AndEdr4 This test verifies that the radio under test is able to perform discovery and return the Enhanced Inquiry Result (EIR) data.

Test details
Specifications
  • Device.BusController.Bluetooth.Base.4LeSpecification
  • System.Client.BluetoothController.Base.4LeSpecification
  • Device.BusController.Bluetooth.Base.SupportsBluetooth21AndEdr
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


Bluetooth - UsbScoDataTransportLayer (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1a89b7d-e692-4025-9063-95519b03e16b

This test module verifies that a Bluetooth radio is capable of performing SCO operations via Inband USB. OpenInbandScoChannel This test verifies that the radio under test is able to initiate an SCO connection via Inband USB. AcceptOpenInbandScoChannel This test verifies that the radio under test is able to accept an incoming SCO connection via Inband USB. FullDuplexDataTransfer This test verifies that the radio under test is able to perform duplex read and write of clear data via Inband USB.

Test details
Specifications
  • Device.BusController.Bluetooth.USB.ScoDataTransportLayer
  • System.Client.BluetoothController.USB.ScoDataTransportLayer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TCMFILE |
COMPONENT |
MODULE |
MULTI_INSTANCE |


CancelIsAbsent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a7ccf04-6d55-40b7-a3bc-a1049bc1207a

Verify the behavior of IS_ABSENT and GET_STATE IOCTLs when IO is canceled.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CancelIsPresent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0830245-dcbe-4bd6-ab7a-040baa170d9f

Verify the behavior of IS_PRESENT and GET_STATE IOCTLs when IO is canceled.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CardEmulationOnHandleExclusive

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1876a96d-5f50-4f2c-b3e7-ab8a57add0a9

Card Emulation handle is exclusive.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CardEmulationOnOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99be1508-1f05-4deb-8417-eaa318c64e3f

Test turning Card Emulation on and off.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CardEmulationOnOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a9760f7-0c2d-45f8-9533-4eed6a7d7a66

Test turning Card Emulation on and off.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CardEmulationSetTwice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f84a07a0-d972-4d1e-a039-0b0c8ae10050

Test setting the same Card Emulation mode twice.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CardEmulationSetTwice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53a2dff9-c501-4507-9ae7-b085075727a1

Test setting the same Card Emulation mode twice.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ChannelId

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a27ed4ac-64aa-406e-b4ba-31e403397ab6

Verify getting the channel ID attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


Characteristics

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e5388aa9-b376-4a52-8269-405178f02fa5

Verify getting the reader characteristics attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ClosePublishHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/156a2cc5-9725-4bdf-9035-dbea16911cb5

Subscriber didn't receive message after publish handle closed.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.PeerToPeer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CloseSeManageHandleWhileOn

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79c00917-f282-45f6-8f14-e198ebe36ea4

Test Card Emulation after SEManage handle closed.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CloseSeManageHandleWhileOn

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ae5fda5-33b9-48d5-847f-9b4ae47c03a7

Test Card Emulation after SEManage handle closed.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


Copy MITT binaries.

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76dcd8a5-6bd7-42b1-9b07-474a0e91422c

This test copies MITT binaries to the system under test.

Test details
Specifications
  • Device.BusController.I2C.Stress
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
MittDirectory | Directory to copy the MITT test binaries to.


GetAttributes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13ea0597-9468-4ab1-a9d6-a494d1672ed3

Verify getting the current protocol attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


CurrentProtocol

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/102c3ad2-7b6f-459a-947f-a6777c351609

Verify getting the current protocol attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Custom key (MifareClassic1k)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/41fb23e3-3737-42eb-a9e1-175d13fbd2b0

Verify that we can use custom key to auth Mifare Classic 1k card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


DeviceUnit

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/526e9464-8c64-418c-a52d-7c7f04a8cf8a

Verify getting the device unit attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


DropPublishMaxReceivingQueue

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a475c223-0cb3-4735-9ed4-108274ff8ed7

Verify message is ignored after max queue size.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


DropSubscribeMaxReceivingQueue

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd9a3813-33e9-46e8-bfa3-2bdb889b2936

Verify message is ignored after max queue size

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EnablePublishWhileTapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1e78bd9-f450-4be5-91b8-eba7ac721b49

Enable disabled publish handle while tapped.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EnableSubscribeWhileTapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd3aa507-26d2-41e8-a6f2-e973ce289fa8

Enable subscription while tapped

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EnableTagWriteAndReadWhileTapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3d0a2e3-1133-4542-8b28-8867bd472b7f

Enable disabled TagWrite or Read while tapped.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


GetAtrDesfireInvalidOutBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1e150de0-cbe9-4ead-a204-22ae4ad39e01

Verify trying to get ATR string with an invalid output buffer fails with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetAttributesInvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1950a7cb-3a6f-4fa3-871b-c3263fd62db9

Verify trying to get an attribute with an invalid buffer fails with the right error code.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetAttributeStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca0b069f-db8f-4c71-957e-f3bf3f90c6ea

Verify that repeatedly sending GET_ATTRIBUTE IOCTLs succeeds.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetAttributeStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/887f5a06-23a1-4187-8643-30b57b582049

Verify that repeatedly sending GET_ATTRIBUTE IOCTLs succeeds.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Get Data

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9be92a88-98d7-496e-ac6c-0a59432a89d5

Verify that we can read the information of the smart card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseGetData

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5da0db76-a2b8-4202-a10c-062027d37756

Verify that we can read the information of the smart card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetEventAfterTimeout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15388b96-95d8-4d9e-a302-0077851ac595

Test getting event after receiving queue timeout.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetEventAfterTimeout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/18b96ee0-6a93-4245-8b7d-3aacb138e7d1

Test getting event after receiving queue timeout.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetEventBeforeTimeout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e88b6fb-e652-4265-83ce-295f73b098fb

Test getting event before receiving queue timeout.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetEventBeforeTimeout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/851db7cd-dd33-4726-8268-54b0fa5c1a1f

Test getting event before receiving queue timeout.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetMaxBytes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fed2dbb1-b567-40a7-b871-80cdcd3716a8

Test IOCTL_NFP_GET_MAX_MESSAGE_BYTES, and check returned value meets minimum required MAX size.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetNextBeforeSubscribe

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/789532b1-7431-429b-b8e7-42509d8ffb9f

Test waiting for event before subscribe.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetNextTransmittedWithBuffers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c979c303-e8b0-4bfb-a270-7972311b6f17

GetNextTransmitted should be used with no output buffer.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetNextWithInvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c7e61d6-f8fa-48da-ab1e-494457d5d16d

Test invalid input/output buffers for IOCTL_NFCSE_GET_NEXT_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetNextWithInvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a4167d03-7a24-45d2-b3e4-fdbf9f447bf2

Test invalid input/output buffers for IOCTL_NFCSE_GET_NEXT_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetNfccCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/35dd2bfb-1619-4604-91bc-b841d523a34c

Test IOCTL to get NFCC capabilities.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 2
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetOutputBufferSize

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7427dd14-ae44-4b0d-8ccf-95303ad6c6a2

Test small output buffer to get required size.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetOutputBufferSize

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d3aaa17-ae06-4853-860b-6e2ae7032241

Test small output buffer to get required size.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetPublishedMessageAfterTimeout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21ac6734-8fcd-4917-bd74-00a53c898e04

Verify message queue is cleaned up after 20 seconds.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetRoutingTable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/001f6c77-0cd8-460d-9248-f1abe9af4660

Test IOCTL to get routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetStateInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16f98f1e-43df-4099-8bc7-658c64f23ea5

Verify error code when sending GET_STATE IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetStateInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de165bed-3750-4e11-ba34-d08669d944e4

Verify error code when sending GET_STATE IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetSubscribedMessageAfterTimeout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8e9a48d-6d5c-4647-bee6-f36f2b8993bd

Verify message queue is cleaned up after 20 seconds

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GetTransmissionRate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebbc6fea-b5b8-47e5-9fb3-ac6ed6a023ac

Test IOCTL_NFP_GET_KILO_BYTES_PER_SECOND.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


GPIO WinRT Functional and Stress Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1fc0922-1186-48bd-bfcd-c7385a2f6f96

The GPIO tests do functional and stress testing of GPIO drivers through the WinRT APIs. The scope of testing includes:

  • Verification that reading, writing, and interrupts work on all pins by using loopbacks. See description of Board.xml below to specify loopback configuration.
  • Verification that a pin reverts to its default state when its handle is closed.
  • Verification that the expected pins are exposed by comparing the enumerated pins against a configuration file (see description of Board.xml below).
  • Verification that the state of a pin can be tracked reliably using interrupts.
  • Verification that the drivers behave correctly under stress conditions. The stress tests toggle two sets of loopback pins in parallel and verify that the pin value as returned by Read() is correct and that interrupts are fired at the correct times.

Test details
Specifications
  • Device.BusController.Gpio.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10000
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    The GPIO functional and stress tests require a minimum of 4 pins to run. These pin numbers are referred to as A1, A2, B1, and B2. A1 must be connected to A2 through a 1k resistor, and B1 must be connected to B2 through a 1k resistor as shown in the following schematic:

    gpio loopback schematic

    The resistors protect the hardware from damage during output contention and are necessary for the tests to validate drive modes. You will be prompted to supply the pin numbers of A1, A2, B1, and B2 when you schedule the tests for execution. If you're running the tests from the command line, you must specify the pin numbers with the 'Pins' runtime parameter as shown in the Troubleshooting section.

    In the tests' default configuration, only the 4 pins specified above will be run. While this is sufficient to gain coverage of the controller driver, it is also necessary to validate that every exposed pin can be used for IO and interrupts. To run loopback tests on all pins, connect every two pins together through a 1k resistor, then modify %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot\Board.xml as follows:

    • Under the <Table Id="Pins"> element, add a <Row> for each exposed pin, where DefaultDriveMode specifies the drive mode you're expecting the pin to be in when the board is powered on. DefaultDriveMode must be one of the values in the Windows.Devices.Gpio.GpioPinDriveMode enumeration.

                <Table Id="Pins">
            <Row>
              <Parameter Name="PinNumber">0</Parameter>
              <Parameter Name="Enabled">True</Parameter>
              <Parameter Name="DefaultDriveMode">Input</Parameter>
            </Row>
            <Row>
              <Parameter Name="PinNumber">1</Parameter>
              <Parameter Name="Enabled">True</Parameter>
              <Parameter Name="DefaultDriveMode">InputPullUp</Parameter>
            </Row>
            <!-- By setting Enabled to False, you can also assert that a pin should NOT be accessible -->
            <Row>
              <Parameter Name="PinNumber">2</Parameter>
              <Parameter Name="Enabled">False</Parameter>
            </Row>
          </Table>

    • Under the <Table Id="Loopbacks"> element, add a <Row> for each pair of pins that is connected in loopback configuration. For example, the following data specifies that pin 0 is connected to pin 2 and pin 1 is connected to pin 3.

                <Table Id="Loopbacks">
            <Row>
              <Parameter Name="Pin1">0</Parameter>
              <Parameter Name="Pin2">2</Parameter>
            </Row>
            <Row>
              <Parameter Name="Pin1">1</Parameter>
              <Parameter Name="Pin2">3</Parameter>
            </Row>
          </Table>

    Board-rpi.xml and Board-mbm.xml are provided in %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot as examples for the Raspberry Pi and MinnowBoardMax platforms.

    Board.xml must be present in the same directory as Windows.Devices.LowLevel.UnitTests.dll when the tests are run. If you run the tests through HLK manager, it will automatically copy Board.xml from the HLK directory to the correct location on the device. If you run the tests on the command line, you must deploy Board.xml yourself.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy all files in %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run

      minte\te.exe windows.devices.lowlevel.unittests.dll /p:Pins=A1,A2,B1,B2 /name:GpioTests::*

    Command line test usage:

    minte\te.exe windows.devices.lowlevel.unittests.dll [/p:Pins=pin_numbers] [/name:test_name] [/p:Duration=duration]
    • pin_numbers - the pin numbers to use for testing, of the form A1,A2,B1,B2 where A1 is connected to A2 through a 1k resistor and B1 is connected to B2 through a 1k resistor. If not specified, A1 defaults to the lowest available pin number, A2 defaults to the highest available pin number, B1 defaults to the second lowest available pin number, and B2 defaults to the second highest available pin number. Example: /p:Pins=4,27,5,26
    • test_name - the name of the test to run which may include wildcards. Examples: /name:GpioTests::*, /name:GpioTests::VerifySetDriveMode#metadataSet0
    • duration - how long to run stress tests. Examples: /p:Duration=10s (10 seconds), /p:Duration=1m (1 minute), /p:Duration=2h (2 hours), /p:Duration=1d (1 day)

    To run the tests in default configuration,

    minte\te.exe windows.devices.lowlevel.unittests.dll /p:Pins=0,1,2,3 /name:GpioTests::*

    To run a specific test, pass the full test name to the /name parameter:

    minte\te.exe windows.devices.lowlevel.unittests.dll /p:Pins=0,1,2,3 /name:GpioTests::VerifyInterruptStateTracking

    To run the stress tests for the recommended duration of 2 hours each, run:

    minte\te.exe windows.devices.lowlevel.unittests.dll /p:Pins=0,1,2,3 /name:GpioTests::* /p:Duration=2h

    A tool that can help with manual troubleshooting is GpioTestTool, a simple utility for interacting with GPIO from the command line.

    More information

    Parameters

    Parameter name | Parameter description
Pins | Loopback pins of the form <A1>,<A2>,<B1>,<B2> where A1 is connected to A2, and B1 is connected to B2
Duration | Specifies how long to run each of the stress tests. e.g. 30s, 1m, 1h, 1d


I2C WinRT Advanced Functional Tests (mbed LPC1768 Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a60f5a94-12b2-4905-8416-e9774f539f1d

The I2C tests do functional and stress testing of I2C controllers exposed to usermode through the Windows.Devices.I2c WinRT APIs. The tests are split into two parts - basic functional and stress tests, and advanced functional tests. The scope of testing of the basic functional tests includes:

  • Verification that an I2C controller with specified friendly name is accessible from usermode.
  • Verification that data is written correctly over a range of clock speeds and buffer lengths up to 8 bytes (EEPROM page size).
  • Verification that data is read correctly over a range of clock speeds and buffer lengths.
  • Verification that write-restart-read sequences (WriteRead's) are executed correctly over a range of clock speeds and buffer lengths.
  • Verification that when a write, read, or WriteRead is attempted to a slave address that is not acknowledged, the driver returns STATUS_NO_SUCH_DEVICE. This is reported by I2cDevice::Write/Read/WriteRead() as HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND) and is reported by I2cDevice::WritePartial/ReadPartial/WriteReadPartial() as I2cTransferStatus::SlaveAddressNotAcknowledged.
  • Verification that the APIs and drivers function correctly under stress conditions. The stress tests write and read from two EEPROMs concurrently with separate device handles over an extended duration.

The scope of testing of the advanced functional tests includes:

  • Verification that data is written correctly for buffer lengths of up to 16384 bytes.
  • Verification that an I2C restart condition is generated in response to a WriteRead sequence.
  • Verification that when the slave device NAK's while the master is still writing bytes, the driver completes the request with STATUS_SUCCESS and reports the actual number of bytes written through the request information. This is called a partial transfer, and is reported by WritePartial() and WriteReadPartial() as I2cTransferStatus::PartialTransfer.
  • Verification that clock stretching up to 500ms is permitted and does not cause the transfer to fail.
  • Verification that when the slave device holds the clock line low for an extended duration (10+ seconds), the driver completes the transfer within at most 10 seconds with a failure code. The failure code should be STATUS_IO_TIMEOUT, but this is not verified for compatibility reasons.

The basic functional tests and stress tests run against two externally connected EEPROMs. The advanced functional tests run against an mbed LPC1768 running custom firmware. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Updating the mbed's firmware is as simple as dragging and dropping a file. The firmware source code is available on github. Instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.I2C.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Development
    Timeout (in minutes) | 30
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    Running the basic functional and stress tests

    You will need the following hardware to run the tests:

    • Atmel AT24HC serial EEPROMs qt. 2
    • 10k resistor qt. 2
    • Breadboard
    • Wires

    Wire up the EEPROMs as shown in the following diagram and connect SDA and SCL to your device under test.

    i2c eeprom schematic

    You can now schedule the basic functional and stress tests from HLK manager.

    Running the advanced functional tests

    The advanced functional tests verify NACKing behavior, hung bus conditions, clock stretching, and repeated starts. The tests require an mbed LPC1768 running custom firmware to be connected to the device under test. Before running the tests, you must load the HLK firmware onto the mbed LPC1768. Here's how to update firmware:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removeable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the mbed
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your device under test. Plug in the mbed over USB to your device under test. Then, make the I2C connections (mbed pinout),

    1. Connect mbed pin 9 (P0.0/SDA) to the SDA pin on your device under test
    2. Connect mbed pin 10 (P0.1/SCL) to the SCL pin on your device under test
    3. Connect mbed GND to a GND pin on your device under test

    The mbed has internal pull-up resistors enabled on the SDA and SCL lines and does not require external pull-up resistors.

    You can now schedule the advanced functional tests from HLK manager.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:I2c*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/select:select_clause] [/p:I2cFriendlyName=friendly_name] [/p:Duration=duration]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:I2c*, /name:I2cEepromWriteTests#metadataSet0::VerifyWrite#metadataSet0
    • select_clause - a TAEF selection clause. Example: /select:"@name='I2c*' and not(@name='I2cTestsEx*')"
    • friendly_name - the friendly name of the I2C controller under test. If omitted, the first enumerated controller is used. Examples: /p:I2cFriendlyName=I2C0
    • duration - how long to run stress tests. Examples: /p:Duration=10s (10 seconds), /p:Duration=1m (1 minute), /p:Duration=2h (2 hours), /p:Duration=1d (1 day)

    Examples:

    To run the basic functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /select:"@name='I2c*' and not(@name='I2cTestsEx*')"

    To run the advanced functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cTestsEx::*

    To run the tests against a specific I2C controller instance, pass the friendly name to the I2cFriendlyName test parameter,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2c* /p:I2cFriendlyName=I2C0

    To run a specific test, pass the full test name to the /name parameter:

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cNonexistentSlaveAddressTests::TestWriteRead

    To run the stress tests for the recommended duration of 8 hours, run

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cStressTests::StressIoConcurrent /p:Duration=8h

    A tool that can help with manual troubleshooting is I2cTestTool. I2cTestTool is a simple utility for interacting with I2C from the command line.

    More information

    Parameters

    Parameter name | Parameter description
I2cFriendlyName | The friendly name of the I2C controller under test (e.g. I2C0).


I2C WinRT IO Stress Tests (EEPROMs Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ef0ce6f0-a8a7-42d0-b0b5-eb01532d6a6a

The I2C tests do functional and stress testing of I2C controllers exposed to usermode through the Windows.Devices.I2c WinRT APIs. The tests are split into two parts - basic functional and stress tests, and advanced functional tests. The scope of testing of the basic functional tests includes:

  • Verification that an I2C controller with specified friendly name is accessible from usermode.
  • Verification that data is written correctly over a range of clock speeds and buffer lengths up to 8 bytes (EEPROM page size).
  • Verification that data is read correctly over a range of clock speeds and buffer lengths.
  • Verification that write-restart-read sequences (WriteRead's) are executed correctly over a range of clock speeds and buffer lengths.
  • Verification that when a write, read, or WriteRead is attempted to a slave address that is not acknowledged, the driver returns STATUS_NO_SUCH_DEVICE. This is reported by I2cDevice::Write/Read/WriteRead() as HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND) and is reported by I2cDevice::WritePartial/ReadPartial/WriteReadPartial() as I2cTransferStatus::SlaveAddressNotAcknowledged.
  • Verification that the APIs and drivers function correctly under stress conditions. The stress tests write and read from two EEPROMs concurrently with separate device handles over an extended duration.

The scope of testing of the advanced functional tests includes:

  • Verification that data is written correctly for buffer lengths of up to 16384 bytes.
  • Verification that an I2C restart condition is generated in response to a WriteRead sequence.
  • Verification that when the slave device NAK's while the master is still writing bytes, the driver completes the request with STATUS_SUCCESS and reports the actual number of bytes written through the request information. This is called a partial transfer, and is reported by WritePartial() and WriteReadPartial() as I2cTransferStatus::PartialTransfer.
  • Verification that clock stretching up to 500ms is permitted and does not cause the transfer to fail.
  • Verification that when the slave device holds the clock line low for an extended duration (10+ seconds), the driver completes the transfer within at most 10 seconds with a failure code. The failure code should be STATUS_IO_TIMEOUT, but this is not verified for compatibility reasons.

The basic functional tests and stress tests run against two externally connected EEPROMs. The advanced functional tests run against an mbed LPC1768 running custom firmware. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Updating the mbed's firmware is as simple as dragging and dropping a file. The firmware source code is available on github. Instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.I2C.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 240
    Category | Development
    Timeout (in minutes) | 10000
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    Running the basic functional and stress tests

    You will need the following hardware to run the tests:

    • Atmel AT24HC serial EEPROMs qt. 2
    • 10k resistor qt. 2
    • Breadboard
    • Wires

    Wire up the EEPROMs as shown in the following diagram and connect SDA and SCL to your device under test.

    i2c eeprom schematic

    You can now schedule the basic functional and stress tests from HLK manager.

    Running the advanced functional tests

    The advanced functional tests verify NACKing behavior, hung bus conditions, clock stretching, and repeated starts. The tests require an mbed LPC1768 running custom firmware to be connected to the device under test. Before running the tests, you must load the HLK firmware onto the mbed LPC1768. Here's how to update firmware:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removeable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the mbed
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your device under test. Plug in the mbed over USB to your device under test. Then, make the I2C connections (mbed pinout),

    1. Connect mbed pin 9 (P0.0/SDA) to the SDA pin on your device under test
    2. Connect mbed pin 10 (P0.1/SCL) to the SCL pin on your device under test
    3. Connect mbed GND to a GND pin on your device under test

    The mbed has internal pull-up resistors enabled on the SDA and SCL lines and does not require external pull-up resistors.

    You can now schedule the advanced functional tests from HLK manager.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:I2c*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/select:select_clause] [/p:I2cFriendlyName=friendly_name] [/p:Duration=duration]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:I2c*, /name:I2cEepromWriteTests#metadataSet0::VerifyWrite#metadataSet0
    • select_clause - a TAEF selection clause. Example: /select:"@name='I2c*' and not(@name='I2cTestsEx*')"
    • friendly_name - the friendly name of the I2C controller under test. If omitted, the first enumerated controller is used. Examples: /p:I2cFriendlyName=I2C0
    • duration - how long to run stress tests. Examples: /p:Duration=10s (10 seconds), /p:Duration=1m (1 minute), /p:Duration=2h (2 hours), /p:Duration=1d (1 day)

    Examples:

    To run the basic functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /select:"@name='I2c*' and not(@name='I2cTestsEx*')"

    To run the advanced functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cTestsEx::*

    To run the tests against a specific I2C controller instance, pass the friendly name to the I2cFriendlyName test parameter,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2c* /p:I2cFriendlyName=I2C0

    To run a specific test, pass the full test name to the /name parameter:

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cNonexistentSlaveAddressTests::TestWriteRead

    To run the stress tests for the recommended duration of 8 hours, run

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cStressTests::StressIoConcurrent /p:Duration=8h

    A tool that can help with manual troubleshooting is I2cTestTool. I2cTestTool is a simple utility for interacting with I2C from the command line.

    More information

    Parameters

    Parameter name | Parameter description
I2cFriendlyName | The friendly name of the I2C controller under test (e.g. I2C0).
Duration | Specifies how long to run each of the stress tests. e.g. 30s, 1m, 1h, 1d


I2C WinRT Nonexistent Slave Address Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2746ad72-fe5c-4412-8231-f7ed53d95e71

Verifies that when a slave address is not acknowledged, the correct error code is returned.

Test details
Specifications
  • Device.BusController.I2C.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    More information

    Parameters

    Parameter name | Parameter description
I2cFriendlyName | The friendly name of the I2C controller under test (e.g. I2C0).


I2C WinRT Read Tests (EEPROM Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca91c2d2-4615-4a1b-928e-587ab2b69b04

The I2C tests do functional and stress testing of I2C controllers exposed to usermode through the Windows.Devices.I2c WinRT APIs. The tests are split into two parts - basic functional and stress tests, and advanced functional tests. The scope of testing of the basic functional tests includes:

  • Verification that an I2C controller with specified friendly name is accessible from usermode.
  • Verification that data is written correctly over a range of clock speeds and buffer lengths up to 8 bytes (EEPROM page size).
  • Verification that data is read correctly over a range of clock speeds and buffer lengths.
  • Verification that write-restart-read sequences (WriteRead's) are executed correctly over a range of clock speeds and buffer lengths.
  • Verification that when a write, read, or WriteRead is attempted to a slave address that is not acknowledged, the driver returns STATUS_NO_SUCH_DEVICE. This is reported by I2cDevice::Write/Read/WriteRead() as HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND) and is reported by I2cDevice::WritePartial/ReadPartial/WriteReadPartial() as I2cTransferStatus::SlaveAddressNotAcknowledged.
  • Verification that the APIs and drivers function correctly under stress conditions. The stress tests write and read from two EEPROMs concurrently with separate device handles over an extended duration.

The scope of testing of the advanced functional tests includes:

  • Verification that data is written correctly for buffer lengths of up to 16384 bytes.
  • Verification that an I2C restart condition is generated in response to a WriteRead sequence.
  • Verification that when the slave device NAK's while the master is still writing bytes, the driver completes the request with STATUS_SUCCESS and reports the actual number of bytes written through the request information. This is called a partial transfer, and is reported by WritePartial() and WriteReadPartial() as I2cTransferStatus::PartialTransfer.
  • Verification that clock stretching up to 500ms is permitted and does not cause the transfer to fail.
  • Verification that when the slave device holds the clock line low for an extended duration (10+ seconds), the driver completes the transfer within at most 10 seconds with a failure code. The failure code should be STATUS_IO_TIMEOUT, but this is not verified for compatibility reasons.

The basic functional tests and stress tests run against two externally connected EEPROMs. The advanced functional tests run against an mbed LPC1768 running custom firmware. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Updating the mbed's firmware is as simple as dragging and dropping a file. The firmware source code is available on github. Instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.I2C.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    Running the basic functional and stress tests

    You will need the following hardware to run the tests:

    • Atmel AT24HC serial EEPROMs qt. 2
    • 10k resistor qt. 2
    • Breadboard
    • Wires

    Wire up the EEPROMs as shown in the following diagram and connect SDA and SCL to your device under test.

    i2c eeprom schematic

    You can now schedule the basic functional and stress tests from HLK manager.

    Running the advanced functional tests

    The advanced functional tests verify NACKing behavior, hung bus conditions, clock stretching, and repeated starts. The tests require an mbed LPC1768 running custom firmware to be connected to the device under test. Before running the tests, you must load the HLK firmware onto the mbed LPC1768. Here's how to update firmware:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removeable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the mbed
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your device under test. Plug in the mbed over USB to your device under test. Then, make the I2C connections (mbed pinout),

    1. Connect mbed pin 9 (P0.0/SDA) to the SDA pin on your device under test
    2. Connect mbed pin 10 (P0.1/SCL) to the SCL pin on your device under test
    3. Connect mbed GND to a GND pin on your device under test

    The mbed has internal pull-up resistors enabled on the SDA and SCL lines and does not require external pull-up resistors.

    You can now schedule the advanced functional tests from HLK manager.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:I2c*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/select:select_clause] [/p:I2cFriendlyName=friendly_name] [/p:Duration=duration]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:I2c*, /name:I2cEepromWriteTests#metadataSet0::VerifyWrite#metadataSet0
    • select_clause - a TAEF selection clause. Example: /select:"@name='I2c*' and not(@name='I2cTestsEx*')"
    • friendly_name - the friendly name of the I2C controller under test. If omitted, the first enumerated controller is used. Examples: /p:I2cFriendlyName=I2C0
    • duration - how long to run stress tests. Examples: /p:Duration=10s (10 seconds), /p:Duration=1m (1 minute), /p:Duration=2h (2 hours), /p:Duration=1d (1 day)

    Examples:

    To run the basic functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /select:"@name='I2c*' and not(@name='I2cTestsEx*')"

    To run the advanced functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cTestsEx::*

    To run the tests against a specific I2C controller instance, pass the friendly name to the I2cFriendlyName test parameter,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2c* /p:I2cFriendlyName=I2C0

    To run a specific test, pass the full test name to the /name parameter:

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cNonexistentSlaveAddressTests::TestWriteRead

    To run the stress tests for the recommended duration of 8 hours, run

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cStressTests::StressIoConcurrent /p:Duration=8h

    A tool that can help with manual troubleshooting is I2cTestTool. I2cTestTool is a simple utility for interacting with I2C from the command line.

    More information

    Parameters

    Parameter name | Parameter description
I2cFriendlyName | The friendly name of the I2C controller under test (e.g. I2C0).


I2C WinRT Write Tests (EEPROM Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ab0df1b-3369-4aaf-a4d5-d157cb7bf578

The I2C tests do functional and stress testing of I2C controllers exposed to usermode through the Windows.Devices.I2c WinRT APIs. The tests are split into two parts - basic functional and stress tests, and advanced functional tests. The scope of testing of the basic functional tests includes:

  • Verification that an I2C controller with specified friendly name is accessible from usermode.
  • Verification that data is written correctly over a range of clock speeds and buffer lengths up to 8 bytes (EEPROM page size).
  • Verification that data is read correctly over a range of clock speeds and buffer lengths.
  • Verification that write-restart-read sequences (WriteRead's) are executed correctly over a range of clock speeds and buffer lengths.
  • Verification that when a write, read, or WriteRead is attempted to a slave address that is not acknowledged, the driver returns STATUS_NO_SUCH_DEVICE. This is reported by I2cDevice::Write/Read/WriteRead() as HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND) and is reported by I2cDevice::WritePartial/ReadPartial/WriteReadPartial() as I2cTransferStatus::SlaveAddressNotAcknowledged.
  • Verification that the APIs and drivers function correctly under stress conditions. The stress tests write and read from two EEPROMs concurrently with separate device handles over an extended duration.

The scope of testing of the advanced functional tests includes:

  • Verification that data is written correctly for buffer lengths of up to 16384 bytes.
  • Verification that an I2C restart condition is generated in response to a WriteRead sequence.
  • Verification that when the slave device NAK's while the master is still writing bytes, the driver completes the request with STATUS_SUCCESS and reports the actual number of bytes written through the request information. This is called a partial transfer, and is reported by WritePartial() and WriteReadPartial() as I2cTransferStatus::PartialTransfer.
  • Verification that clock stretching up to 500ms is permitted and does not cause the transfer to fail.
  • Verification that when the slave device holds the clock line low for an extended duration (10+ seconds), the driver completes the transfer within at most 10 seconds with a failure code. The failure code should be STATUS_IO_TIMEOUT, but this is not verified for compatibility reasons.

The basic functional tests and stress tests run against two externally connected EEPROMs. The advanced functional tests run against an mbed LPC1768 running custom firmware. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Updating the mbed's firmware is as simple as dragging and dropping a file. The firmware source code is available on github. Instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.I2C.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    Running the basic functional and stress tests

    You will need the following hardware to run the tests:

    • Atmel AT24HC serial EEPROMs qt. 2
    • 10k resistor qt. 2
    • Breadboard
    • Wires

    Wire up the EEPROMs as shown in the following diagram and connect SDA and SCL to your device under test.

    i2c eeprom schematic

    You can now schedule the basic functional and stress tests from HLK manager.

    Running the advanced functional tests

    The advanced functional tests verify NACKing behavior, hung bus conditions, clock stretching, and repeated starts. The tests require an mbed LPC1768 running custom firmware to be connected to the device under test. Before running the tests, you must load the HLK firmware onto the mbed LPC1768. Here's how to update firmware:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removeable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the mbed
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your device under test. Plug in the mbed over USB to your device under test. Then, make the I2C connections (mbed pinout),

    1. Connect mbed pin 9 (P0.0/SDA) to the SDA pin on your device under test
    2. Connect mbed pin 10 (P0.1/SCL) to the SCL pin on your device under test
    3. Connect mbed GND to a GND pin on your device under test

    The mbed has internal pull-up resistors enabled on the SDA and SCL lines and does not require external pull-up resistors.

    You can now schedule the advanced functional tests from HLK manager.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:I2c*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/select:select_clause] [/p:I2cFriendlyName=friendly_name] [/p:Duration=duration]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:I2c*, /name:I2cEepromWriteTests#metadataSet0::VerifyWrite#metadataSet0
    • select_clause - a TAEF selection clause. Example: /select:"@name='I2c*' and not(@name='I2cTestsEx*')"
    • friendly_name - the friendly name of the I2C controller under test. If omitted, the first enumerated controller is used. Examples: /p:I2cFriendlyName=I2C0
    • duration - how long to run stress tests. Examples: /p:Duration=10s (10 seconds), /p:Duration=1m (1 minute), /p:Duration=2h (2 hours), /p:Duration=1d (1 day)

    Examples:

    To run the basic functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /select:"@name='I2c*' and not(@name='I2cTestsEx*')"

    To run the advanced functional tests,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cTestsEx::*

    To run the tests against a specific I2C controller instance, pass the friendly name to the I2cFriendlyName test parameter,

    minte\te windows.devices.lowlevel.unittests.dll /name:I2c* /p:I2cFriendlyName=I2C0

    To run a specific test, pass the full test name to the /name parameter:

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cNonexistentSlaveAddressTests::TestWriteRead

    To run the stress tests for the recommended duration of 8 hours, run

    minte\te windows.devices.lowlevel.unittests.dll /name:I2cStressTests::StressIoConcurrent /p:Duration=8h

    A tool that can help with manual troubleshooting is I2cTestTool. I2cTestTool is a simple utility for interacting with I2C from the command line.

    More information

    Parameters

    Parameter name | Parameter description
I2cFriendlyName | The friendly name of the I2C controller under test (e.g. I2C0).


IccPresence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec65f6bd-5f37-45d4-9228-d9e7bdc5752d

Verify getting the ICC presence attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IccTypePerAtrForDesfire

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99132855-0ac1-4558-b94a-8a1475447a1c

Verify getting the ICC type per ATR attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Inc Dec (MifareClassic1k)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/300e65ef-be01-40e3-8c05-8c3efc7206d2

Verify that we can increment/decrement block of a Mifare Classic 1k card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e10ff2b-40fd-4098-8883-23f738cd0abe

Publish with Invalid buffer

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83cf09e4-683d-49b5-8697-d38935457e17

Subscribe with Invalid buffer

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78d1acb0-7c86-4b41-a190-c1094eadd177

Test calling IOCTL_SE_SET_CARD_EMULATION_MODE with invalid input/output buffers.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce675540-20d8-4d60-8c64-2a7243272d5e

Test calling IOCTL_SE_SET_CARD_EMULATION_MODE with invalid input/output buffers.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidBufferGetNext

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92ff8542-310b-4a88-b86f-36e518ef20c1

Test invliad input/output buffer.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidBufferSubscribe

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0dcf1551-d7a6-439c-a32e-91d74a0c91d0

Test invliad input/output buffer.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/764492ca-5830-4ae7-b95e-6fde7102eb0d

Subscribe with Invalid handle

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8397d01a-e476-4637-80c8-8352ef83f782

Test ioctl on invalid handle.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c57e01d5-2cff-4d12-8b8a-b1ea3238391b

Test ioctl on invalid handle.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/98acf829-875c-4bbf-9dc5-79b7a168d659

Test calling IOCTL_SE_SET_CARD_EMULATION_MODE on invalid handles.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/95fe1055-85bb-4e0a-8112-deef6ffad9dd

Publish with Invalid handle

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01523a61-7a9f-4fab-aa99-40446b077919

Test calling IOCTL_SE_SET_CARD_EMULATION_MODE on invalid handles.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3ce1ff3-8f2a-4e5d-934d-5cd6c8397ac7

Test ioctl on invalid handle.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidInAndOutBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/adc56aa8-0d65-421b-8a97-3d0ef850a45e

Verify trying to get an attribute with an invalid input and output buffer fails with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidInBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71a126aa-140b-4d78-b2b8-87aae57da9c5

Verify trying to get an attribute with an invalid input buffer fails with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidNdefTests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e98e497-1f00-4490-8ba3-ee3cb7732d86

Test invalid NDEF records.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.NDEF
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


InvalidOutBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/017c17c9-da97-4724-bc78-03a7bf759ad1

Verify trying to get any attribute with an invalid output buffer fails with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsAbsent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75a472f9-3648-454e-92b9-25017f6a5043

Verify the behavior of IS_ABSENT and GET_STATE IOCTLs when card is absent.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsAbsentInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2bb23875-44af-4492-ab68-572105ced76e

Verify error code when sending IS_ABSENT IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsAbsentInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/defa7261-6fae-4464-90e0-ddae75e3f9c3

Verify error code when sending IS_ABSENT IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsPresent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a2b2668-84b7-40a5-8e5c-9d942ea4c8e4

Verify the behavior of IS_PRESENT and GET_STATE IOCTLs when card is present.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsPresentInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f09b84a3-3de6-4148-8fef-5bb85fb3dded

Verify error code when sending IS_PRESENT IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsPresentInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13e41e3e-fa87-43f4-a212-978c6c35eb27

Verify error code when sending IS_PRESENT IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


IsPresentIsAbsent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97a23c50-c869-4b08-9245-826d255d1908

Verify the behavior of IS_PRESENT, IS_ABSENT, and GET_STATE IOCTLs.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ManySeHceSubscriber

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed1af673-25fa-4633-829a-b96341850a58

Test having many subscribers.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ManySESubscriber

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/34270937-5834-4259-9bf9-8929356f363b

Test having many subscribers.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ManySESubscriber

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8cd38dfc-d210-44b0-ab21-c9fea08a00d0

Test having many subscribers.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


MessageTypeIsCaseSensitive

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f412af2-4809-4feb-a994-a2002a23f1ec

Test case sensitive of message type.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.PeerToPeer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


MITTI2C BasicIOKernel

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72205ee4-decf-41f8-8646-9dae0d572507

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBRead
  • Device.BusController.I2C.SPBWrite
  • Device.BusController.I2C.SPBSequenceIOCTL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C BasicIORead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/774bf853-aae2-4f1a-99a7-0650e7b82ec1

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBRead
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C BasicIOSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97845f14-9a27-428a-9568-1959f6537114

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBSequenceIOCTL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C BasicIOWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4968d46e-7999-4482-9b07-16999c9275d0

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBWrite
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C BusRecovery

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01705206-a298-47a8-9f3f-691da1c7608c

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.Stress
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C CancelRead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9fee93f3-8f12-47d8-8d7f-b770e9d062f9

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.CancellationOfIO
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C CancelSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0a1a6003-90ee-449c-9e6d-129af7e51f93

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.CancellationOfIO
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C CancelWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6863753-fa6e-4e8f-846f-a9a26d9dde61

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.CancellationOfIO
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C ClockStretching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3e7de57-958a-4f17-a885-a11e82ea14be

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.ClockStretching
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C DeviceNACK

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7adbfc3-e650-4be0-bdcd-8f2bb9446405

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.NACK
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C LockUnlock

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3a2f7055-4c33-47da-8d58-1a38ac3310e6

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.LockUnlockIOCTL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C PerfRead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7412705-99a2-4ca1-ab9c-2a0d03c3544f

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBRead
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C PerfSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31221b1b-15bf-486e-af13-933481a5422a

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBSequenceIOCTL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C PerfWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0ee7dea-aafb-4b97-b6bb-367b46eee49d

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.SPBWrite
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C Power

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27c2360a-f473-457b-b6f8-f89ccd2fba47

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.IdlePowerManagement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTI2C Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0744097-2f8d-44d8-b681-2653fd5305a5

This test verifies the SPB of controller driver and I2C bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.I2C.Stress
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI BasicFullDuplex

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c812eca-069b-43a1-b1b4-d7fae82b4408

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI BasicIOKernel

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/495e0c8c-d2bc-40a7-9e59-c4439ab59e24

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI BasicIORead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f705fdd0-8d99-4030-a3f5-782265d971a1

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI BasicIOSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d610181-6a58-4f88-9947-6a4fed658455

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI BasicIOWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0c8b3a1-d74e-428f-a6c8-c329190a2798

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI CancelRead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1dafad19-35df-450b-b430-71aea505e245

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI CancelSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94301fab-3a16-403a-a557-de3ba4e5c9db

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI CancelSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67ffe1cc-79cd-4023-b45b-315d55d1bca2

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI CancelWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da562f6d-6ad5-4d63-bc3b-da83b40083ac

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI LockUnlock

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a459a690-4350-4510-ae40-14435f81109a

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI PerfRead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16f0cadf-f47e-4091-b9be-bb4b7914dd54

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI PerfSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/759ad7fd-ff00-467b-93dd-ef04bd7b5122

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI PerfSequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e6481502-d32b-4c54-8913-9d783537ac81

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI PerfWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00686ee1-b0cd-4068-8007-cc367725f81c

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI Power

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed58287c-f1d3-46f1-b0ee-8d46002d3d65

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTSPI Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9c4fbae-6385-4dff-a560-331f24fef036

This test verifies the SPB of controller driver and SPI bus.See msdn.microsoft.com

Test details
Specifications
  • Device.BusController.SPI.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTUart LoopbackCancellation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc31487d-ad6a-4e02-cffa-b6a76fd41b43

This test verifies the SPB of controller driver and UART bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.UART.Cancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTUart LoopbackGuardBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c760df95-149c-479b-cf26-60da588f0fa0

This test verifies the SPB of controller driver and UART bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.UART.GuardBuffer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


MITTUart LoopbackReadWrite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d78fc29-718e-43b4-908c-c54425def8b2

This test verifies the SPB of controller driver and UART bus. See https://msdn.microsoft.com/en-us/library/windows/hardware/dn919852(v=vs.85).aspx

Test details
Specifications
  • Device.BusController.UART.ReadWrite
  • Device.BusController.UART.DMA
  • Device.BusController.UART.FlowControl
  • Device.BusController.UART.FlushFIFO
  • Device.BusController.UART.HCKTestability
  • Device.BusController.UART.IdlePowerManagement
  • Device.BusController.UART.Performance
  • Device.BusController.UART.Stress
  • Device.BusController.UART.SupportedBaudRates
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


NFC Power - Multiple radio OFF requests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6c7ca85-0de2-43fc-b475-c764fc996623

Send multiple OFF requests to NFC radio.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Multiple radio ON requests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a619ce8-13cb-4e2e-af28-a5ff8ef5d253

Send multiple ON requests to NFC radio.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NDEFMessageTypes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5bfc85f-8190-44d1-a2d1-c966c1b40794

Publish and subscribe different NDEF & windows types.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.PeerToPeer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NDEFMultiRecord

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/593c0e69-f3fc-4b0c-a80a-27fbc7def5e3

Publish and subscribe multi NDEF records.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.PeerToPeer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NDEFRecordChunks

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc228c87-c53c-49c0-91a1-174630f83f46

Publish and subscribe NDEF record chunks.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.PeerToPeer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NfcMixedStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62b94c69-2604-4bd7-b23a-a8c58bd6f244

Test all the NFC features (peer-to-peer communication, proximity tag reading/writing, smart card transmitting APDUs, HCE) mixed together.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PowerInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f38f15fe-c78b-4b24-b5df-4f5480b7a02b

Verify error code when sending POWER IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PowerInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4744ddc7-a478-495e-8e27-c8d35e21bd73

Verify error code when sending POWER IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PresenceEventNoMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/41ddda1e-52e5-4cd8-b87e-f5d513983c26

Test Presence Events(arrival/departure) without any other message.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PresenceEventPubSubAtOnce

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/246d7ac6-dbf4-457b-9a13-ea8757ab4210

Test Presence Events(arrival/departure) with two-way P2P communication at once.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PresenceEventPubSubManyMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49ac43f0-9d08-4df5-8b73-f3e3c544f5b6

Test Presence Events(arrival/departure) with simple pub/sub 10 messages.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PresenceEventWithReadOnlyTag

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/031cfd92-c05c-410c-b8b6-4ebac8da9f24

Tag arrival and Tag departure event for ReadOnly tag.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PresenceEventWithTag

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f74b3e62-6a65-4d3b-9db2-a857a2ef2fc9

Tag arrival and Tag departure event.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishAndSubscribeMany

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96078f81-112d-447c-83cd-4cade037da1e

publish and subscribe with many subscriber/publisher

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishAndSubscribeManyMessages

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1ed1414-d87f-4f12-8436-ac3c06bddf4f

publish and subscribe 100 messages at once

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishAndSubscribeManyMessages2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/77a6f16a-02b0-4fcc-a489-8d5cbe9be833

publish and subscribe 10000 small messages at once

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishAndSubscribeManyMessagesWhileTapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3fb9250-7cf0-4cd8-8c1d-c73201b2f438

publish and subscribe while tapped

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishBothP2PAndTag

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9d21497-18fb-4c8f-8d9d-be0027216ab7

Publish P2P message while WriteTag message is published.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishCancelIo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6786186f-d5f8-4c07-aba6-51ca8b1cb261

Cancel pending IO.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishDisableEnable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8fa28b59-d4ff-4aea-91ad-952ea52b0e12

Disable/Enable publication twice.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishMessageWithInvalidMessageData

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1b90d51-d5d4-4659-996a-7673c05dd872

Publish message with invalid message data.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishMessageWithInvalidMessageType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bb8deca8-c14e-4975-b7f5-13ed24072ced

Publish with invalid message type.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishMessageWithMaxMessageData

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78560a84-43ab-4425-9e84-904728793e0f

Publish message with max data size.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishMessageWithMaxSizeMessageType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1fa54aa5-030c-419c-96fa-010a746de3d6

Publish message with max message sub type length.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishMultipleTags

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6906cc76-c3f6-4a2a-aadf-f88af273baa2

Perform multiple tag writing.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishPartialDisableEnable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab5bef63-ca34-4478-b5ea-948b68bdcd33

Disable/Enable subset of publication.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


PublishTagsTwice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1788904b-1172-47d1-bc1f-2974e640bc7f

Perform multiple tag writing while in a single tap.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishTagTooLargeAfterTap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10fab779-2050-4da3-8a6c-269d6918cd6d

Bring in tag first, and write message larger than available size.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishTagTooLargeBeforeTap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6204bb6a-fc22-4ba1-9d25-e7e74aae980d

Publish message larger than available size, and bring in tap.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishWriteTag

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0e8836c-583a-4181-b08c-8ea7ee077bee

Write different types of messages to tag.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishWriteTagLaunchApp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d60b9f88-a570-4f88-bf13-eec00829c36d

Tag writing for LaunchApp message.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


PublishWriteTagWithPublish

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0e65302-d315-4547-bdc3-12a6689cdc25

Write tag while other message is published.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


NFC Power - Get publication handle fails (radio off, active publication)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d2d4e52-a70d-450a-b25e-6158edbd3ac0

With active publication, Verify that attempt to get a Publication handle fails after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Low-power state (radio off, active publication)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07bd7cff-72d0-4dd8-acb6-0d04800596e1

With active publication, Verify that stack enters D3 state after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Low-power state (no publications)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6fc95a9e-f963-49ff-8320-a7eada62bfc4

When a publication handle is closed, and no other open handles exist, verify that the stack enters D3 with the radio on

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get publication handle fails (radio off)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a079fe6-cd51-465e-b5ab-d5f6174c1567

With no Publication and Subscription, verify that attempt to get a Publication handle fails after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get subscription handle fails (radio off)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4f26174-ef07-4fc5-a5e9-a5e1d7872f40

With no Publication and Subscription, verify that attempt to get a Subscription handle fails after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get proximity transmission rate fails (radio off)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d2b1422-5c2d-498d-8886-64af737c0cad

With no Publication and Subscription, verify that IOCTL_NFP_GET_KILO_BYTES_PER_SECOND fails after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get maximum message size fails (radio off)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/935c9300-3652-46d1-95ad-bfcbd9feac14

With no Publication and Subscription, verify that IOCTL_NFP_GET_MAX_MESSAGE_BYTES fails after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Low-power state (radio off)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bac9a35a-45f0-4bda-9f12-589df45cb033

With no Publication and Subscription, verify that stack enters D3 state after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get proximity transmission rate (radio on)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c83006e5-641e-48cf-b53b-2333de6fdb81

With no Publication and Subscription, verify that IOCTL_NFP_GET_KILO_BYTES_PER_SECOND succeeds after radio is turned off/on.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get maximum message size

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8702cb21-07f6-46df-ba24-304ed6ab0035

With no Publication and Subscription, verify that IOCTL_NFP_GET_MAX_MESSAGE_BYTES succeeds after radio is turned off/on.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Create publication message

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81ac722e-6e5d-4989-b628-0e164cd4b3b1

With no Publication and Subscription, verify that publication succeeds after radio is turned off/on.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get subscribed message

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b56c612d-6d7d-42bb-a537-7e103fab0403

With no Publication and Subscription, verify that subscription succeeds after radio is turned off/on.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Multiple power state transitions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9f169842-0d42-407e-aa89-a1fa861654a1

Turn radio OFF/ON multiple times.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Read All (Felica)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8bad01ac-85f8-41af-8f46-c825b8ba9907

Verify that we can read every writable block of a Felica card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Read All (Jewel)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd8a5a9d-8fe9-4feb-97ba-4b74b4362bcf

Verify that we can read every block of a Jewel/Topaz card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Read All (MifareClassic1k)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd95c236-b24a-4c6c-a7a9-9da4cbbbb73a

Verify that we can read every block of a Mifare Classic 1k card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Read All (MifareUL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a81d58d3-1e5a-40a9-a14c-49b300466bdb

Verify that we can read every block of a Mifare Ultralight card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Read All (MifareULC)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58c4057f-234b-4a48-9abf-fba7b4d8f9b7

Verify that we can read every block of a Mifare Ultralight C card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RemoteDataExchange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc865c5e-124a-442a-80c8-16c98e43a1e1

Test Card Emulation data exchange.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatCardEmulationOnOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76f537d2-cd55-49a3-bfb6-da9026b536e6

Test Card Emulation mode on/off stress.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatCardEmulationOnOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67f589ab-d825-4c62-af5c-db92eab4ef5e

Test Card Emulation mode on/off stress.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatedRemoteDataExchange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/461da593-7583-4afa-a838-44f21d8bfdcf

Test Card Emulation data exchange stress.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatPublishAndSubscribeDifferentMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7dda105-425d-49f2-b1f9-67d61922436d

Repeat publish and subcribe sequence with different message

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatPublishAndSubscribeSameMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb16a1b7-a921-4af5-8111-4f988ff4a57d

Repeat publish and subcribe sequence with random size of payload.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatPublishAndSubscribeWithCardEmulation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7ce0370-f271-4c52-a48e-5fc54500f7f5

Repeat publish and subcribe with Card Emulation on.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatPublishAndSubscribeWithLongSleep

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f9d8aeb-30bc-4c4c-a37a-6da9537598df

Repeat publish and subcribe with long sleep

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatPublishAndSubscribeWithSleep

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3fea8a1-61d7-42f5-a74a-59df3126a3df

Repeat publish and subcribe sequence with radio on/off

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatPublishWriteTag

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16084044-7baf-48ca-abe8-ae68062bebef

Perform repeated tag writing.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatTagReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7e5b99f-d655-484c-a4ed-6467976d7813

Perform repeated tag reading

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatTagReadingLonghaul

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0cc234e0-9513-48fd-8b5d-1ef9ce168941

Perform repeated tag reading with long sleep

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


RepeatTagReadingWithCardEmulation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a3bd24c-909f-45d1-9a1e-14588ea64a3d

Perform repeated tag writing with Card Emulation on.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Repeat Tap (Desfire)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3d56926-d2e9-4ab8-93e1-32c2de18cd48

Repeat tap Desfire card and send APDU command.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseRepeatTapDesfire

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e85b069f-20c6-4b61-82f4-7844b7c2ed7d

Repeat tap Desfire card and send APDU command.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Repeat Tap and Read All (Felica)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5507a400-f62d-436f-88c6-04cb29dfbf0b

Repeat tap Felica Card and read all content.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Repeat Tap (Mifare)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/136552d4-acfc-4b4f-8cf9-2928677abb49

Repeat tap Mifare Card and read.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Repeat Tap and Read All (Mifare)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7de269da-a668-4dc0-8c93-6a67de2014d1

Repeat tap Mifare Card and read all content.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


Nfc Smartcard - Restore default key (MifareClassic1k)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abe0311a-30ce-4bcb-ac09-f19aea28b386

Restore Default key to Mifare Classic 1k card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ScardSpecific

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e68b3ebb-11a1-4bf9-bc77-6a95cf58f0f2

Verify GET_STATE IOCTL returns SCARD_SPECIFIC when communication protocols have been established.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ScardSpecific

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6763e3db-abcc-4e59-baa6-2b889835232e

Verify GET_STATE IOCTL returns SCARD_SPECIFIC if the card is present and communication protocols have been established.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ScardSpecificWithPower

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0a8b2a8-a81a-4396-93fe-2dc6ab6c02ae

Verify IOCTL_SMARTCARD_POWER returns not supported when powering down SCARD_SPECIFIC card. Also, verify cold/warm reset does not alter card state.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


ScardSpecificWithPower

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b6df22e-fc68-43dc-aa10-7bbbcb4fbbbf

Verify IOCTL_SMARTCARD_POWER returns not supported when powering down SCARD_SPECIFIC card. Also, verify cold/warm reset does not alter card state.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SeEnumerationBasic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9fd525cb-33e0-41f6-8345-acac7e63e60d

Test IOCTL_SE_ENUM_ENDPOINTS can return correct enumerations.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Enumeration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SeEnumInvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4aa31628-8856-42fe-8a83-beba3eb3eb9b

Test IOCTL_SE_ENUM_ENDPOINTS with invalid buffers.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Enumeration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SeEnumVariousHandle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2c928f2-d845-4e63-bdbd-b993342306b0

Test IOCTL_SE_ENUM_ENDPOINTS with various handles.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Enumeration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SEEventCancel

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/443e65e7-39bc-411b-8710-47793328972c

Test canceling IOCTL_SE_GET_NEXT_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SEEventCancel

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df8321a1-d4a6-4805-a6c0-d666ff224800

Test canceling IOCTL_SE_GET_NEXT_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SEEventCloseWhilePending

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8410264-a402-4d1b-a60b-eac98a0ea516

Test closing file while pending.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SEEventCloseWhilePending

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cdf5198-3ec2-4a15-937a-9b4658b72f86

Test closing file while pending.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SeHceEventCancel

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5db7682c-20a7-4445-adcb-d2112de3d08d

Test canceling IOCTL_SE_GET_NEXT_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SeHceEventCloseWhilePending

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2c96497f-c401-4268-8d6b-3d404fea7826

Test closing file while pending.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetPayLoadTwice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e83ddee0-6c32-4d70-b36b-de0f2d829f6a

Set payload more than once

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetPayLoadWithOutputBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54e58f58-bb9b-4278-ac21-13bf2b266890

SetPayload with output buffer. Should fail.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Publish
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetProtocolInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a323262a-3ba8-4b46-97fd-27d1914f4200

Verify error code when sending SET_PROTOCOL IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetProtocolInvalidParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e05997d-00f1-4728-b50e-834d4b840029

Verify error code when sending SET_PROTOCOL IOCTL with an invalid buffer.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed49d94e-6a0b-485d-88b7-cfed58d65952

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Emulation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4ca26b3-eaea-4178-b2b3-e1b12ee6d719

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableContainingNfcDep

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/520b1c1a-5e87-4090-bcd7-480fccfd9951

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidAidLengthSmall

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1490fb80-ee5a-4117-9123-4d0a87a79acb

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidAidLengthTooBig

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/af21fbbe-15b6-42b9-8130-b142c78e702e

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidInputBufferSize

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8450f4a5-c01c-42f7-8d3f-000fb9080228

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidOutputBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d43ee681-b8a7-42af-a618-04398a2f415b

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidProtocol

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87c7ca2d-05ed-49b1-923e-a246d03381b0

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidSecureElementId

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/378d0e00-56d3-497f-b6b2-1bdbf0a99cc7

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableInvalidTech

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d050ad83-aa3b-4670-b8b6-9514eb1fab75

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetRoutingTableTooManyEntries

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f58a5a83-1f2a-429e-9829-2c3d76ec21ce

Test IOCTL to set routing table.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SetTagReadOnly

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e124c7ae-002b-4451-85db-8f7e621f2aae

Set tag to ReadOnly.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


SPI WinRT Clock Frequency Verification Tests (mbed LPC1768 Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50cf9ccc-bbd3-4514-979f-b0499cb18ed8

The SPI tests do functional and stress testing of SPI controllers exposed to usermode through the Windows.Devices.Spi WinRT APIs. The scope of testing includes:

  • Verification that an SPI controller with specified friendly name is accessible from usermode.
  • Verification that data is sent and received correctly over a range of SPI modes, clock frequencies, data bit lengths, and transfer lengths.
  • Verification there are no gaps between bytes within a transfer. Some devices such as LED strips and analog to digital converters require an uninterrupted clock signal.
  • Verification that the actual clock speed used is within 15% of the requested value.

  • Verification that when a transfer is attempted with a buffer length that is not a multiple of the stride, the transfer is failed with STATUS_INVALID_PARAMETER and no activity is generated on the bus. The stride is determined by DataBitLength as follows:
    DataBitLength | Stride
    4 - 8 | 1
    9 - 16 | 2
    17 - 32 | 4

Tests run against an externally connected mbed LPC1768. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Programming the mbed with the test firmware image is as simple as dragging and dropping the firmware image to the mass storage device. The firmware source code is available on github. Detailed instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.SPI.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Development
    Timeout (in minutes) | 30
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    You will need the following hardware to run the tests:

    • mbed LPC1768
    • Breadboard
    • Jumper Wires

    First, you must load the test firmware onto the mbed:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the drive
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your SPI controller under test. To power the mbed, you can plug it in over USB to your device under test or connect the VIN and GND pins directly to power pins on your device under test. Make the following connections between your device under test and the mbed: (mbed pinout),

    1. Connect mbed pin 13 (P0.15/SCK0) to the SCK pin on your device under test
    2. Connect mbed pin 30 (P0.4/CAP2.0) to the SCK pin on your device under test (this pin is used for precise clock measurement)
    3. Connect mbed pin 11 (P0.18/MOSI0) to the MOSI pin on your device under test
    4. Connect mbed pin 12 (P0.17/MISO0) to the MISO pin on your device under test
    5. Connect mbed pin 14 (P0.16/SSEL0) to the Chip Select pin on your device under test
    6. Connect mbed GND to a GND pin on your device under test

    You can now schedule the tests in HLK studio.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. We also recommend hooking up a logic analyzer such as a salae. It can be difficult or impossible to determine the cause of a failure without the ability to inspect bus traffic.

    Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlk*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/p:SpiFriendlyName=friendly_name] [/p:ClockFrequency=clock_frequency] [/p:DataBitLength=data_bit_length] [/p:SpiMode=0|1|2|3] [/p:Length=length] [/p:WriteLength=write_length] [/p:ReadLength=read_length] [/p:ExtraClocks=extra_clocks] [/p:Verbose=true]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:SpiHlk*, /name:SpiHlkTests::VerifyClockFrequency#metadataSet0
    • friendly_name - the friendly name of the SPI controller under test. If omitted, the first enumerated controller is used. Examples: /p:SpiFriendlyName=SPI1
    • clock_frequency - force a test to use the specified clock frequency. By default, the clock frequency comes from the test data, which is designed to give coverage over a range of frequencies. This parameter should be omitted under normal circumstances. Example: /p:ClockFrequency=1500000
    • data_bit_length - force a test to use the specified data bit length. Example: /p:DataBitLength=9
    • SpiMode - force a test to use the specified SPI mode. Example: /p:SpiMode=2
    • length - force a test to use the specified buffer length for the transfer. Example: /p:length=128
    • write_length - force a TransferSequential test to use the specified buffer length for the write portion of the transfer. Example: /p:WriteLength=8
    • read_length - force a TransferSequential test to use the specified buffer length for the read portion of the transfer. Example: /p:ReadLength=16
    • extra_clocks - specify an adjustment to the number of clocks per byte that the tests use when computing expected clock active times for performance measurements, gap detection, and clock frequency validation. For example, the BCM2836 SPI controller waits an extra clock cycle after each byte, so to compensate for this behavior the measurements must be adjusted. Example: /p:ExtraClocks=1.5
    • /p:Verbose=true - turn on verbose output. This will cause entire buffers to be dumped to the console when a failure occurs. By default, only the first mismatched byte is displayed.

    Examples:

    List available tests:

    minte\te windows.devices.lowlevel.unittests.dll /list

    Run the IO validation tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests*

    Run the gap detection tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkGapTests*

    Run the clock frequency validation and stride tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkTests*

    Run a specific test against a specific SPI controller instance:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests#2::VerifyTransferSequential#metadataSet9 /p:SpiFriendlyName=SPI1

    A tool that can help with manual troubleshooting is SpiTestTool. SpiTestTool is a simple utility for interacting with SPI from the command line.

    More information

    Parameters

    Parameter name | Parameter description
SpiFriendlyName | The friendly name of the SPI controller under test (e.g. SPI0).


SPI WinRT IO Transfer Tests (mbed LPC1768 Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00c892e8-c226-4c71-9c2a-68349fed7113

The SPI tests do functional and stress testing of SPI controllers exposed to usermode through the Windows.Devices.Spi WinRT APIs. The scope of testing includes:

  • Verification that an SPI controller with specified friendly name is accessible from usermode.
  • Verification that data is sent and received correctly over a range of SPI modes, clock frequencies, data bit lengths, and transfer lengths.
  • Verification there are no gaps between bytes within a transfer. Some devices such as LED strips and analog to digital converters require an uninterrupted clock signal.
  • Verification that the actual clock speed used is within 15% of the requested value.

  • Verification that when a transfer is attempted with a buffer length that is not a multiple of the stride, the transfer is failed with STATUS_INVALID_PARAMETER and no activity is generated on the bus. The stride is determined by DataBitLength as follows:
    DataBitLength | Stride
    4 - 8 | 1
    9 - 16 | 2
    17 - 32 | 4

Tests run against an externally connected mbed LPC1768. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Programming the mbed with the test firmware image is as simple as dragging and dropping the firmware image to the mass storage device. The firmware source code is available on github. Detailed instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.SPI.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Development
    Timeout (in minutes) | 30
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    You will need the following hardware to run the tests:

    • mbed LPC1768
    • Breadboard
    • Jumper Wires

    First, you must load the test firmware onto the mbed:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the drive
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your SPI controller under test. To power the mbed, you can plug it in over USB to your device under test or connect the VIN and GND pins directly to power pins on your device under test. Make the following connections between your device under test and the mbed: (mbed pinout),

    1. Connect mbed pin 13 (P0.15/SCK0) to the SCK pin on your device under test
    2. Connect mbed pin 30 (P0.4/CAP2.0) to the SCK pin on your device under test (this pin is used for precise clock measurement)
    3. Connect mbed pin 11 (P0.18/MOSI0) to the MOSI pin on your device under test
    4. Connect mbed pin 12 (P0.17/MISO0) to the MISO pin on your device under test
    5. Connect mbed pin 14 (P0.16/SSEL0) to the Chip Select pin on your device under test
    6. Connect mbed GND to a GND pin on your device under test

    You can now schedule the tests in HLK studio.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. We also recommend hooking up a logic analyzer such as a salae. It can be difficult or impossible to determine the cause of a failure without the ability to inspect bus traffic.

    Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlk*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/p:SpiFriendlyName=friendly_name] [/p:ClockFrequency=clock_frequency] [/p:DataBitLength=data_bit_length] [/p:SpiMode=0|1|2|3] [/p:Length=length] [/p:WriteLength=write_length] [/p:ReadLength=read_length] [/p:ExtraClocks=extra_clocks] [/p:Verbose=true]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:SpiHlk*, /name:SpiHlkTests::VerifyClockFrequency#metadataSet0
    • friendly_name - the friendly name of the SPI controller under test. If omitted, the first enumerated controller is used. Examples: /p:SpiFriendlyName=SPI1
    • clock_frequency - force a test to use the specified clock frequency. By default, the clock frequency comes from the test data, which is designed to give coverage over a range of frequencies. This parameter should be omitted under normal circumstances. Example: /p:ClockFrequency=1500000
    • data_bit_length - force a test to use the specified data bit length. Example: /p:DataBitLength=9
    • SpiMode - force a test to use the specified SPI mode. Example: /p:SpiMode=2
    • length - force a test to use the specified buffer length for the transfer. Example: /p:length=128
    • write_length - force a TransferSequential test to use the specified buffer length for the write portion of the transfer. Example: /p:WriteLength=8
    • read_length - force a TransferSequential test to use the specified buffer length for the read portion of the transfer. Example: /p:ReadLength=16
    • extra_clocks - specify an adjustment to the number of clocks per byte that the tests use when computing expected clock active times for performance measurements, gap detection, and clock frequency validation. For example, the BCM2836 SPI controller waits an extra clock cycle after each byte, so to compensate for this behavior the measurements must be adjusted. Example: /p:ExtraClocks=1.5
    • /p:Verbose=true - turn on verbose output. This will cause entire buffers to be dumped to the console when a failure occurs. By default, only the first mismatched byte is displayed.

    Examples:

    List available tests:

    minte\te windows.devices.lowlevel.unittests.dll /list

    Run the IO validation tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests*

    Run the gap detection tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkGapTests*

    Run the clock frequency validation and stride tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkTests*

    Run a specific test against a specific SPI controller instance:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests#2::VerifyTransferSequential#metadataSet9 /p:SpiFriendlyName=SPI1

    A tool that can help with manual troubleshooting is SpiTestTool. SpiTestTool is a simple utility for interacting with SPI from the command line.

    More information

    Parameters

    Parameter name | Parameter description
SpiFriendlyName | The friendly name of the SPI controller under test (e.g. SPI0).


SPI WinRT Stride Verification Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/20c6b079-62f7-4067-953f-e252bd271938

The SPI tests do functional and stress testing of SPI controllers exposed to usermode through the Windows.Devices.Spi WinRT APIs. The scope of testing includes:

  • Verification that an SPI controller with specified friendly name is accessible from usermode.
  • Verification that data is sent and received correctly over a range of SPI modes, clock frequencies, data bit lengths, and transfer lengths.
  • Verification there are no gaps between bytes within a transfer. Some devices such as LED strips and analog to digital converters require an uninterrupted clock signal.
  • Verification that the actual clock speed used is within 15% of the requested value.

  • Verification that when a transfer is attempted with a buffer length that is not a multiple of the stride, the transfer is failed with STATUS_INVALID_PARAMETER and no activity is generated on the bus. The stride is determined by DataBitLength as follows:
    DataBitLength | Stride
    4 - 8 | 1
    9 - 16 | 2
    17 - 32 | 4

Tests run against an externally connected mbed LPC1768. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Programming the mbed with the test firmware image is as simple as dragging and dropping the firmware image to the mass storage device. The firmware source code is available on github. Detailed instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.SPI.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    You will need the following hardware to run the tests:

    • mbed LPC1768
    • Breadboard
    • Jumper Wires

    First, you must load the test firmware onto the mbed:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the drive
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your SPI controller under test. To power the mbed, you can plug it in over USB to your device under test or connect the VIN and GND pins directly to power pins on your device under test. Make the following connections between your device under test and the mbed: (mbed pinout),

    1. Connect mbed pin 13 (P0.15/SCK0) to the SCK pin on your device under test
    2. Connect mbed pin 30 (P0.4/CAP2.0) to the SCK pin on your device under test (this pin is used for precise clock measurement)
    3. Connect mbed pin 11 (P0.18/MOSI0) to the MOSI pin on your device under test
    4. Connect mbed pin 12 (P0.17/MISO0) to the MISO pin on your device under test
    5. Connect mbed pin 14 (P0.16/SSEL0) to the Chip Select pin on your device under test
    6. Connect mbed GND to a GND pin on your device under test

    You can now schedule the tests in HLK studio.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. We also recommend hooking up a logic analyzer such as a salae. It can be difficult or impossible to determine the cause of a failure without the ability to inspect bus traffic.

    Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlk*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/p:SpiFriendlyName=friendly_name] [/p:ClockFrequency=clock_frequency] [/p:DataBitLength=data_bit_length] [/p:SpiMode=0|1|2|3] [/p:Length=length] [/p:WriteLength=write_length] [/p:ReadLength=read_length] [/p:ExtraClocks=extra_clocks] [/p:Verbose=true]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:SpiHlk*, /name:SpiHlkTests::VerifyClockFrequency#metadataSet0
    • friendly_name - the friendly name of the SPI controller under test. If omitted, the first enumerated controller is used. Examples: /p:SpiFriendlyName=SPI1
    • clock_frequency - force a test to use the specified clock frequency. By default, the clock frequency comes from the test data, which is designed to give coverage over a range of frequencies. This parameter should be omitted under normal circumstances. Example: /p:ClockFrequency=1500000
    • data_bit_length - force a test to use the specified data bit length. Example: /p:DataBitLength=9
    • SpiMode - force a test to use the specified SPI mode. Example: /p:SpiMode=2
    • length - force a test to use the specified buffer length for the transfer. Example: /p:length=128
    • write_length - force a TransferSequential test to use the specified buffer length for the write portion of the transfer. Example: /p:WriteLength=8
    • read_length - force a TransferSequential test to use the specified buffer length for the read portion of the transfer. Example: /p:ReadLength=16
    • extra_clocks - specify an adjustment to the number of clocks per byte that the tests use when computing expected clock active times for performance measurements, gap detection, and clock frequency validation. For example, the BCM2836 SPI controller waits an extra clock cycle after each byte, so to compensate for this behavior the measurements must be adjusted. Example: /p:ExtraClocks=1.5
    • /p:Verbose=true - turn on verbose output. This will cause entire buffers to be dumped to the console when a failure occurs. By default, only the first mismatched byte is displayed.

    Examples:

    List available tests:

    minte\te windows.devices.lowlevel.unittests.dll /list

    Run the IO validation tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests*

    Run the gap detection tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkGapTests*

    Run the clock frequency validation and stride tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkTests*

    Run a specific test against a specific SPI controller instance:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests#2::VerifyTransferSequential#metadataSet9 /p:SpiFriendlyName=SPI1

    A tool that can help with manual troubleshooting is SpiTestTool. SpiTestTool is a simple utility for interacting with SPI from the command line.

    More information

    Parameters

    Parameter name | Parameter description
SpiFriendlyName | The friendly name of the SPI controller under test (e.g. SPI0).


SPI WinRT Transfer Gap Detection Tests (mbed LPC1768 Required)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6da79d04-940b-4c49-8f00-333bf0cfbb19

The SPI tests do functional and stress testing of SPI controllers exposed to usermode through the Windows.Devices.Spi WinRT APIs. The scope of testing includes:

  • Verification that an SPI controller with specified friendly name is accessible from usermode.
  • Verification that data is sent and received correctly over a range of SPI modes, clock frequencies, data bit lengths, and transfer lengths.
  • Verification there are no gaps between bytes within a transfer. Some devices such as LED strips and analog to digital converters require an uninterrupted clock signal.
  • Verification that the actual clock speed used is within 15% of the requested value.

  • Verification that when a transfer is attempted with a buffer length that is not a multiple of the stride, the transfer is failed with STATUS_INVALID_PARAMETER and no activity is generated on the bus. The stride is determined by DataBitLength as follows:
    DataBitLength | Stride
    4 - 8 | 1
    9 - 16 | 2
    17 - 32 | 4

Tests run against an externally connected mbed LPC1768. The mbed LPC1768 is a popular microcontroller prototyping platform that can be purchased from a variety of online retailers including Sparkfun, Digikey, and Adafruit. Programming the mbed with the test firmware image is as simple as dragging and dropping the firmware image to the mass storage device. The firmware source code is available on github. Detailed instructions on preparing the mbed and running the tests are provided below.

Test details
Specifications
  • Device.BusController.SPI.WinRT.Discretional
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Development
    Timeout (in minutes) | 30
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.BusController additional documentation

    Running the test

    You will need the following hardware to run the tests:

    • mbed LPC1768
    • Breadboard
    • Jumper Wires

    First, you must load the test firmware onto the mbed:

    1. Plug in the mbed LPC1768 over USB to your PC. It will show up as a removable drive on your PC.
    2. Open the drive in file explorer
    3. Copy c:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\x86\iot\busses-tester-mbed_LPC1768.bin to the drive
    4. Press the button on the mbed to reset the microcontroller

    Next, wire up the mbed to your SPI controller under test. To power the mbed, you can plug it in over USB to your device under test or connect the VIN and GND pins directly to power pins on your device under test. Make the following connections between your device under test and the mbed: (mbed pinout),

    1. Connect mbed pin 13 (P0.15/SCK0) to the SCK pin on your device under test
    2. Connect mbed pin 30 (P0.4/CAP2.0) to the SCK pin on your device under test (this pin is used for precise clock measurement)
    3. Connect mbed pin 11 (P0.18/MOSI0) to the MOSI pin on your device under test
    4. Connect mbed pin 12 (P0.17/MISO0) to the MISO pin on your device under test
    5. Connect mbed pin 14 (P0.16/SSEL0) to the Chip Select pin on your device under test
    6. Connect mbed GND to a GND pin on your device under test

    You can now schedule the tests in HLK studio.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    We recommend running the tests on the command line to gain insight into failures and to quickly iterate on solutions. We also recommend hooking up a logic analyzer such as a salae. It can be difficult or impossible to determine the cause of a failure without the ability to inspect bus traffic.

    Here's how to run the tests on the command line:

    1. Copy %programfiles(x86)%\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\MinTe to c:\data\minte
    2. Copy Windows.Devices.LowLevel.UnitTests.dll from %programfiles(x86)%\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\iot to c:\data on your device.
    3. Telnet or ssh into your device
    4. Change directories to c:\data

    5. Run the tests:

      minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlk*

    Command line test usage:

    minte\te windows.devices.lowlevel.unittests.dll [/name:test_name] [/p:SpiFriendlyName=friendly_name] [/p:ClockFrequency=clock_frequency] [/p:DataBitLength=data_bit_length] [/p:SpiMode=0|1|2|3] [/p:Length=length] [/p:WriteLength=write_length] [/p:ReadLength=read_length] [/p:ExtraClocks=extra_clocks] [/p:Verbose=true]
    • test_name - the name of the test to run which may include wildcards. Examples: /name:SpiHlk*, /name:SpiHlkTests::VerifyClockFrequency#metadataSet0
    • friendly_name - the friendly name of the SPI controller under test. If omitted, the first enumerated controller is used. Examples: /p:SpiFriendlyName=SPI1
    • clock_frequency - force a test to use the specified clock frequency. By default, the clock frequency comes from the test data, which is designed to give coverage over a range of frequencies. This parameter should be omitted under normal circumstances. Example: /p:ClockFrequency=1500000
    • data_bit_length - force a test to use the specified data bit length. Example: /p:DataBitLength=9
    • SpiMode - force a test to use the specified SPI mode. Example: /p:SpiMode=2
    • length - force a test to use the specified buffer length for the transfer. Example: /p:length=128
    • write_length - force a TransferSequential test to use the specified buffer length for the write portion of the transfer. Example: /p:WriteLength=8
    • read_length - force a TransferSequential test to use the specified buffer length for the read portion of the transfer. Example: /p:ReadLength=16
    • extra_clocks - specify an adjustment to the number of clocks per byte that the tests use when computing expected clock active times for performance measurements, gap detection, and clock frequency validation. For example, the BCM2836 SPI controller waits an extra clock cycle after each byte, so to compensate for this behavior the measurements must be adjusted. Example: /p:ExtraClocks=1.5
    • /p:Verbose=true - turn on verbose output. This will cause entire buffers to be dumped to the console when a failure occurs. By default, only the first mismatched byte is displayed.

    Examples:

    List available tests:

    minte\te windows.devices.lowlevel.unittests.dll /list

    Run the IO validation tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests*

    Run the gap detection tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkGapTests*

    Run the clock frequency validation and stride tests:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkTests*

    Run a specific test against a specific SPI controller instance:

    minte\te windows.devices.lowlevel.unittests.dll /name:SpiHlkIoTests#2::VerifyTransferSequential#metadataSet9 /p:SpiFriendlyName=SPI1

    A tool that can help with manual troubleshooting is SpiTestTool. SpiTestTool is a simple utility for interacting with SPI from the command line.

    More information

    Parameters

    Parameter name | Parameter description
SpiFriendlyName | The friendly name of the SPI controller under test (e.g. SPI0).


StressGetState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e864fd2-ae8a-41b8-8243-afecdc30b17d

Verify that we send muliple GET_STATE IOCTLs in a row.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


StressIsAbsent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76424326-1094-424e-a394-7e61c5b1e6af

Verify that we send muliple GET_STATE IOCTLs in a row when card is absent.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


StressIsPresent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9941a490-915d-45b2-ba17-d9d3e038f01b

Verify that we send muliple GET_STATE IOCTLs in a row when card is present.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


StressScardSpecific

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c814ee90-6a87-4607-8e5c-316a6aa7f16e

Verify that we send multiple GET_STATE IOCTLs in a row when card is connected.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Get subscription handle fails (radio off, active subscription)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a30e614b-6df3-49c9-be0e-f332a748a0ae

With active subscription, Verify that attempt to get a Subscription handle fails after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Low-power state (radio off, active subscription)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b508c6d-ebfc-441c-a2f0-17e30ea79825

With active subscription, Verify that stack enters D3 state after radio is turned off.

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Power - Low-power state (no subscriptions)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/310fcd23-f156-4634-80af-c3ae3d1b8cc8

When a subscription handle is closed, and no other open handles exist, verify that the stack enters D3 with the radio on

Test details
Specifications
  • Device.BusController.NFC.RadioManagement.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeCancelIo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45ea3df9-f771-4676-8a54-fc44a0297a79

Cancel pending IO

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeDisableEnable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d9c88633-efa5-4e78-a20b-356997c34eb0

Disable/Enable subscription twice

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeMessageAgain

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1d73dbf-cdf1-4ec2-b0c7-82208de3d544

Subscribe to the same message again

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeMessageWithInvalidMessageType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/577a7dfc-9653-4052-b664-0c5d68f4ef59

Subscribe to invalid meesage type

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeNotEnoughBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/692a737a-702c-4766-990b-92a0b3a8dd63

Provide small buffer and get actual size of buffer

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribePartialDisableEnable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/794660fe-ef13-4c95-bee3-533343659886

Disable/Enable subset of subscription

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.Subscribe
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeToDifferentSEEvents

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4677c51-20aa-4b4c-9a61-d4be2c612c2b

Test subscribing to different events including transaction.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
SeTransactionApdu1 | The first APDU used to trigger the transaction event for the SE. This is optional. Write it as a hexidecimal string. For example: "00A4040005112233445500"
SeTransactionApdu2 | The second APDU used to trigger the transaction event for the SE. This is optional. Write it as a hexidecimal string. For example: "00A4040005112233445500"


SubscribeToDifferentSEEvents

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7501442-3b23-404f-b32f-d41c0f2ab8ec

Test subscribing to different events including transaction.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
SeTransactionApdu1 | The first APDU used to trigger the transaction event for the SE. This is optional. Write it as a hexidecimal string. For example: "00A4040005112233445500"
SeTransactionApdu2 | The second APDU used to trigger the transaction event for the SE. This is optional. Write it as a hexidecimal string. For example: "00A4040005112233445500"


SubscribeWhileTapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0eace938-c4bc-40a0-9d99-d70dc4582891

Test getting event while tapped.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeWhileTapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fcd61395-7ef5-4808-a0f5-1751e40025ca

Test getting event while tapped.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeWithInvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0db97446-345d-4871-81c6-202b3a3344a4

Test invalid input/output buffers for IOCTL_NFCSE_SUBSCRIBE_FOR_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeWithInvalidBuffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ce067e2-bd37-48cf-ae9b-769fe98b1b6a

Test invalid input/output buffers for IOCTL_NFCSE_SUBSCRIBE_FOR_EVENT.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeWithSeHceGuidAndNullGuid

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80e142b9-f79d-4eb3-b419-c882b794c91a

Test subscribing with correct GUID & NULL GUID.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.HCE.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeWithVariousSEs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b75b0a34-853a-4e59-a2f3-4cd0c35ff75a

Test subscribing to events with various SEs.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


SubscribeWithVariousSEs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d32a7613-1e55-4d3d-8562-df55d92677bc

Test subscribing to events with various SEs.

Test details
Specifications
  • Device.BusController.NFC.SecureElement.UICC.Event
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


TagWriteInvalidMessageType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/804f46dc-f5fd-4b4d-b7f5-9952136acadf

Publish WriteTag with invalid message type.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


NFC Smartcard - Transmit invalid buffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0a1b40fa-dc6f-4243-a8da-1679aa424f33

Verify sending IOCTL with invalid in or out buffers results in invalid parameter error.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitInvalidDeviceState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1dbf434e-77e2-4680-be6f-37e6db3ccb7d

Verify sending IOCTL with invalid in or out buffers results in invalid parameter error.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Transmit maximum APDU length

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6fb77bb4-e858-4d39-a31a-16817bf2173e

Verify sending IOCTL with the maximum APDU length, -1, and +1.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitMaxApduLength

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96e5aa8a-004d-456f-8b1b-1340454ea349

Verify sending IOCTL with the maximum APDU length, -1, and +1.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Transmit minimum APDU length

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eae0c4f2-fc36-4317-a34c-6213befae209

Verify sending IOCTL with the minimum APDU length, -1, and +1.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitMinApduLength

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12450892-809e-428a-9631-7f34782ddb4f

Verify sending IOCTL with the minimum APDU length, -1, and +1.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Transmit no card

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa1e9904-6522-476f-88c5-6e3871444c9c

Verify transmitting APDU when there is no card fails with no media error.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitNoCard

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f90c3567-83d5-4086-a0d2-146cfcd7ec10

Verify transmitting APDU when there is no card fails with no media error.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitNullParams

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/afdae634-75c7-475d-96d4-3b41921df546

Verify sending IOCTL with invalid in or out buffers results in invalid parameter error.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Transmit NULL parameters

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b422d8c-af6b-4a2a-8424-dda3968bff28

Verify sending IOCTL with invalid in or out buffers results in invalid parameter error.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Transmit stress (Desfire)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21ed04d0-d40a-4f99-8d91-fd9e2367b31a

Verify sending multiple APDUs while connected to a smart card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8880ea1c-2559-450a-93c1-f8257db60bb6

Verify sending multiple APDUs while connected to a smart card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Transmit success (Desfire)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/18885a07-8efd-4ff1-b897-e0bdcdff36d4

Verify we can send an APDU to a smart card in the field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


EseTransmitSuccess

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1b02e94-0f30-4776-a091-e2e58107d26f

Verify we can send an APDU to a smart card in the field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


TwoPendingIoctls

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a2778a0-7df9-4d24-b4a3-3eedd1f94046

Verify that we can have two pending IOCTLs of different types.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.State
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


USB Host Controller Hardware Verifier Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/163832d7-a0ed-4af4-b151-fd3e38745752

This test runs Host Controller Hardware Verifier.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


USB Install MUTT Tools

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d46285a-8018-4547-9182-86d825375f6a

Copies all MUTT tools to [SystemDrive]usbtest and installs the test drivers.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


USB MUTT Firmware Update for Devices

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7f8441a-08da-43e1-8537-7fe02cf94d32

This test updates all MUTT devices in the system to the latest firmware included in this kit.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation


USB TCD 1 Simple IO Completions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dcfe7828-8a74-4ffb-ad66-5a73df7e4b62

This test performs Bulk, Interrupt, Isoch and Stream transfers, allowing them to complete.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 2 Bulk IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3bf9b24-9429-400e-8d8c-92f96ccdedd5

This test performs large bulk and stream transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 3 Bulk and Interrupt IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19d64825-3992-4c61-89a0-2a1891c50182

This test performs medium sized bulk, interrupt and stream transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 4 Isochronous IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f53b2d2d-cdab-4d25-9a54-afa0095dbd85

This test performs Isoch transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 5 Bulk and Isochronous IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d32e3f24-5b36-469c-a860-7aa0d175ee72

This test performs small bulk and isoch transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 6 All Endpoints IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ccb01128-22e9-4e5f-a70b-e0946c00ee81

This test performs small sized bulk, interrupt, isoch and stream transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 7 Random Sized Bulk IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/806dfc29-fc97-4559-ab67-fd9b60363b21

This test performs random sized bulk transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 8 Isoch Completions Single Thread

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/088f2822-d933-40d6-a7d3-c1c30fbf923e

This test performs Isoch transfers from a single consumer thread.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB TCD 9 Isoch Completions Multi-Thread

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a502029-2f91-43bb-9f01-7ca756566055

This test performs Isoch transfers from multiple consumer threads.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


USB-IF Certification Validation Test (Controller)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a7785ba8-e619-4fa9-a709-8404c9e75dfe

This test checks that the controller has passed USB-IF Certification

Test details
Specifications
  • Device.BusController.UsbController.UsbifCertification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TID | USB-IF Certification Test ID


USBStress (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23bc212f-1715-4a50-baf0-77af16d9dfbf

This test performs Bulk, Interrupt, Isoch and Stream transfers with cancellations.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 40
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
xmlFileName | Name of xml file describing test content.


USBSTRESS Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cee3cab0-6039-4487-a624-ae82f6ac11af

This test runs USBSTRESS testing against the MUTT device.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
USBStressTimeout | Time to run USBSTRESS in minutes


USBTCD MUTT IO Tests (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88ef1b1d-dd59-4ea8-92e2-04653b9db5e9

This test performs Bulk, Interrupt, Isoch and Stream transfers with cancellations.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
xmlFileName | Name of xml file describing test content.


VendorIfdType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92137069-8af7-4826-9338-5e4322a4adf4

Verify getting the vendor IFD type attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


VendorName

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a4aae104-8a2b-4044-b8c4-0ae2ae63dbd2

Verify getting the vendor name attribute with card in and out of field.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.Attribute
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


WindowsMessageTypes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33bbdc8a-c3fd-47d3-bcc4-140c0875f032

publish and subscribe windows types

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.PeerToPeer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


WinUSB 1 Simple IO Completions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1c0c2dd-cd25-4f60-a4bc-c8544d481225

This test performs Bulk, Interrupt, Isoch and Stream transfers, allowing them to complete.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 2 Bulk IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51e5ed02-a40f-4c41-b539-1333b93e39bc

This test performs large bulk and stream transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 3 Bulk and Interrupt IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae30b11c-2e8c-4de4-9dba-708948f53d71

This test performs medium sized bulk, interrupt and stream transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 4 Isochronous IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d77f27a-7947-40bd-b9e6-e4bd2cc7d461

This test performs Isoch transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 5 Bulk and Isochronous IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3f66a3e-48de-4723-aee4-7d70fb18b366

This test performs small bulk and isoch transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 6 All Endpoints IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10c43e50-569f-47fa-ac97-eacb768c246a

This test performs small sized bulk, interrupt, isoch and stream transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 7 Random Sized Bulk IO Cancellations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3443ccc0-1137-4a2b-b224-9cd7e01fb73f

This test performs random sized bulk transfers, cancelling after a short timeout.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 8 Isoch Completions Single Thread

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c672c8db-3c19-4659-a352-a9736496692d

This test performs Isoch transfers from a single consumer thread.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB 9 Isoch Completions Multi-Thread

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aeb834e0-7701-4761-aeb1-e36454be99f7

This test performs Isoch transfers from multiple consumer threads.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
RunTimeInMinutes |


WinUSB MUTT IO Tests (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0e275ec-b919-4aef-88a3-fbedfbae882e

This test performs Bulk, Interrupt, Isoch and Stream transfers with cancellations.

Test details
Specifications
  • Device.BusController.UsbController.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
xmlFileName | Name of xml file describing test content.


NFC Smartcard - Write All (Felica)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3d2674f-e289-46f8-91d7-17d551dde5d4

Verify that we can write every writable block of a Felica card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Write All (Iso15693)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53937e90-f565-49e0-8ead-e340dab2d735

Verify that we can read and write every writable block of a Iso15693 card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Write All (Jewel)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e8969d4-b34d-4f0d-9d0c-d68980a54613

Verify that we can write every writable block of a Jewel/Topaz card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Write All (MifareClassic1k)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1fda38c-cad3-4e76-bcf0-29a5cbe064c8

Verify that we can write to every writable block of a Mifare Classic 1k card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Write All (MifareUL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48dc69df-9845-4f52-8a61-63382bd668f6

Verify that we can write every writable block of a Mifare Ultralight card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


NFC Smartcard - Write All (MifareULC)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/827f3124-8166-4c9e-9a95-98791620a78a

Verify that we can write every writable block of a Mifare Ultralight C card.

Test details
Specifications
  • Device.BusController.NFC.SmartCard.DataExchange
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.


WriteTagPreventReceivingSubscribePayload

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e370d2c0-3455-4cc8-96c5-09225910d3cf

Subscriber should not receive message while TagWrite present.

Test details
Specifications
  • Device.BusController.NFC.NearFieldProximity.TagOperation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

More information

Parameters

Parameter name | Parameter description
TapType | DUT tapping device. Possible values are 'nitt' or 'manual'.
EnableSetTagReadOnly | Enables the SetReadOnly tag tests. The tag used for the tests will no longer be writable after the tests. Possible values are '1' for enable or '0' for disable.


xHCI Debug Capability Device Compliance (Logo)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab0fb7ce-33da-4979-9190-8674fe11112d

This test measures the ability of a test computer to support debug operations using an xHCI controller.

Test details
Specifications
  • Device.BusController.UsbController.XhciSupportDebuggingOnAllExposedPorts
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.BusController additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: USB Bus Controller Testing Prerequisites.

To complete this debug test, you must configure two computers. The computer that you are trying to certify is the System under Test (SUT). The second computer is the Host on which the Windows debugger will run. These computers must meet the Windows HLK prerequisites and must be included in the same computer pool. For more information, see Windows HLK Prerequisites. If the device being tested is an XHCI controller, an XHCI controller must be included in both computers. If the XHCI controller in the SUT has any user-accessible ports, the controller must have debug capability.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Bus Controller Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

In the Parameters window Transport field, enter USB. Provide the following additional parameters.

Transport type Required parameters Comments

USB

UsbTargetName

Default is default. If there's more than one USB host controller on the SUT computer, you must specify a BusParams value. Enter Busparams as b.d.f where b, d, and f are the bus number, device number, and function number of the USB host controller that you are using for debugging. These numbers are displayed in the USB host controller's Properties window in Device Manager.

Important

If you are using an EHCI host controller on the SUT computer, the debug cable must be connected to Port 1. You can use the UsbView tool to identify Port 1. USBView is included in the WDK.

Parameters

Parameter name | Parameter description
AccessiblePorts | Please enter the number of accessible ports
BusParams | For a PCI-enumerated controller, please enter bus params as b.d.f where b, d, and f are the bus number, device number, and function displayed in the relevant device manager properties page. For an ACPI-enumerated controller, please enter a single integer.


Device.BusController additional documentation

In this section

  • Bluetooth Controller Testing Prerequisites
  • Proximity Controller Testing Prerequisites
  • Secure Digital Host Controller Testing Prerequisites
  • USB Bus Controller Testing Prerequisites
  • Troubleshooting Bus Controller Testing
  • WITT I2C Testing Prerequisites
  • Hardware Lab Kit (HLK) for Near Field Communication (NFC)


Bluetooth Controller Testing Prerequisites

This document covers how to properly setup your test environment and test machines for running the Bluetooth Windows HLK tests for a Bluetooth radio.

Bluetooth Bus Controller Requirements (Device.BusController.Bluetooth)

When certifying a Bluetooth radio, it is required that all testing is done with the Microsoft Inbox Bluetooth stack. Filter drivers required for radio operation can still be used as long as the functionality of the Microsoft stack is not replaced.

The radio should be tested while connected over the transport type OEMs and ODMs will be using in their System. For example, if the radio will be connected over UART in a System, please certify the radio with it connected over UART as well.

The radio testing should be done in the default Windows configuration and no changes to Bluetooth settings should be made. For example, USB radios must support Selective Suspend and this will be enabled in Windows by default. Do not change this setting from the OS selected default.

NOTE

It is highly recommended that IHVs who also produce a Profile Add-on pack perform additional Bluetooth System level testing (System.Client.BluetoothController) with their profile pack installed on the system as OEMs and ODMs will be required to certify their systems with these profile packs installed.

Test Environment Setup

The Bluetooth tests require up to 3 test systems, each with a 4.0 Bluetooth radio present on the machine and in the same WHLK machine pool. The machines are broken down into two roles.

  • Primary - Test system which has the Bluetooth radio to be certified (DUT).

  • Secondary - Supporting test systems which have a 4.0 Bluetooth Radio present on the system.

All of the test machines must be able to communicate over TCP/IP and must be able to resolve each other's machine names using DNS. Back channel TCP/IP communication takes places over ports 5005 and 5006 and should be opened automatically by the test software.

Machine Setup Instructions

  1. Install the newest available Windows Operating System on the test machines, and join the machines to your test network. All test machines must be able to communicate with each other over TCP/IP and the WHLK controller.

  2. If the systems do not have an internal Bluetooth radio, perform the following steps.

    1. Install the Bluetooth controller to be certified (DUT) on the primary system.

    2. Install the supporting Bluetooth 4.0 radios on the secondary machines. It is recommended to use a previously certified radio on your secondary test machines, but no 4.0 radios have received a logo at the time that this document was written.

  3. Install software packages.

    1. If certifying the Bluetooth radio, install any required software (filter drivers, etc.) required for the radios operation. Functionality of the Microsoft inbox Bluetooth Stack must not be replaced when certifying a radio.

    2. If certifying a Windows System which has an integrated Bluetooth radio, install any required software required for radio operation, as well as any software the machine will ship with (this includes 3rd party drivers such as profiles packs and filter drivers).

  4. Install Windows HLK client on the test computer.

  5. Use Windows HLK studio to create a machine pool and move the 3 test machines into the newly created pool.

  6. Place all test machines into the "Ready" state.


Proximity Controller Testing Prerequisites

This topic describes the tasks that you must complete before you test a proximity-compliant controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Hardware Requirements

The following hardware is required for testing a proximity-compliant controller. You might need more hardware if the controller includes more capabilities. See the test description for each test that the Windows HLK identifies to determine whether your controller requires more hardware.

  • Two test computers. These test computers must meet the Windows HLK prerequisites and must be included in the same machine pool. For more information, see Windows HLK Prerequisites.

  • Two test proximity controllers.

  • One Near Field Communication (NFC) Forum Type 2 tag.

NOTE

For more information about the NFC Forum Type 2 tag, see Near Field Communication (NFC) Forum.

Software Requirements

The following software is required to run the proximity tests:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test Computer Configuration

For proximity controller tests, you must have two test computers in your machine pool so that you can test communication between the proximity controller and another proximity-compliant device. The primary test computer is Computer A. This test computer runs the proximity tests and generates test results. The second test computer is Computer B. This computer is required to test the sending and receiving of subscription messages.

To configure both test computers, follow these steps:

  1. Install the appropriate Windows operating system on the test computers, and then configure the computers for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Install the manufacturer-supplied device driver for the proximity controller on Computer A.

  3. Attach a proximity device (for example, a proximity-compliant mouse) to Computer B.

  4. Install the manufacturer-supplied device driver for the proximity device on Computer B.

  5. Verify that the proximity controller and the proximity-compliant device are enabled on Computer A and Computer B by reviewing their status in Device Manager.

  6. Install the Windows HLK client application on both test computers.

  7. Use Windows HLK Studio to create a machine pool, and then move the test computers to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set, a dialog box appears for that test. Review the specific test topic for more information about the parameters.

Manual Windows HLK tests require user intervention. When you run tests for a submission, it's best to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting an automated test.

IMPORTANT

On both Computer A and Computer B, switch to the Windows Desktop before you run your proximity tests.


Secure Digital Host Controller Testing Prerequisites

This topic describes the tasks that you must complete before you test your audio device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Secure Digital I/O (SDIO) host controllers must comply with Peripheral Component Interconnect (PCI) 2.3 or later requirements for that interface. For PCI configuration registers and interface information, see the SD Host Controller Specification, Version 1.0, Appendix A, which is available from the SD Association website.

Hardware requirements

The following hardware is required for SDIO host controller testing. You might need additional hardware if the controller includes additional capabilities. See the test description for each test that is listed for the device in Windows HLK Studio to determine whether your hardware requires additional tests.

  • One test computer that meets the Windows HLK prerequisites. See Windows HLK Prerequisites for more information.

  • One test SDIO host controller.

  • Any secure digital memory card that complies with the requirements of the "Designed for Microsoft Windows" Logo Program for Hardware.

    NOTE

    If the SDIO host controller test device supports High Speed mode, the memory card used must also support High Speed mode.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required to run the SDIO host controller tests:

  • The drivers for the test device.

Test computer configuration

Only one test computer is required for SDIO host controller testing. To configure the test computer for SDIO host controller testing:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Install the SDIO host controller, if the controller is not embedded on the motherboard.

  3. Install the manufacturer-supplied device driver, if it is required, on the test computer.

  4. Verify that the SDIO host controller functions correctly by using the secure digital memory card.

    NOTE

    It is a best practice to verify full functionality of the SDIO host controller before you begin testing.

  5. Install the Windows HLK client application on the test computer.

  6. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


USB Bus Controller Testing Prerequisites

This topic describes the tasks that you must complete before you test your USB host controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for USB host controller testing. You might need additional hardware if the USB host controller includes additional capabilities. See the test description for each test that the Windows HLK identifies to determine whether the USB host controller requires additional hardware.

  • One test computer that meets the Windows HLK prerequisites. For more information, see Windows HLK Prerequisites.

  • One test USB host controller.

For USB 3.0 controller certification you will need a device of each speed and one Windows certified USB 3.0 hub* on each exposed port.

*We recommend that you use a USB 3.0 hub that is both USB-IF certified and Windows certified.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)
NOTE

To run USB Bus Controller Tests, a Windows 10 Mobile device currently requires a separate dedicated USB function controller that can provide connectivity to the HLK server. This is in addition to the USB host controller or USB dual-role controller being tested. Typically this will be an engineering device rather than a retail device.

Software requirements

The following software is required to run the USB host controller tests:

  • The drivers for the USB host controller.

  • The latest Windows HLK filters or updates.

  • Other tools and drivers that are installed as part of the Install MUTT Tools Bring-Up job. This job is not included as part of certification, so you'll need to schedule this job manually.

Test computer configuration

Only one test computer is required for USB host controller testing. To configure the test computer for USB host controller testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Install or attach the USB host controller to the test computer, if the controller is not embedded on the motherboard.

  3. Verify that the USB host controller functions correctly by using a USB device.

    NOTE

    It is a best practice to verify full functionality of the USB host controller before you begin testing.

  4. Install the Windows HLK client application on the test computer.

  5. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

NOTE

When running a USB Host Controller or System test that requires a MUTT device, be sure to plug in the device before you begin testing.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Related topics

Device.BusController Tests


Troubleshooting Bus Controller Testing

To troubleshoot bus controller test issues, follow these steps:

  1. Review the following Windows Hardware Lab Kit (Windows HLK) topics:

    • Troubleshooting Windows HLK Test Failures

    • One of the following topics, depending on the type of bus controller that you are testing:

      • Bluetooth Controller Testing Prerequisites

      • Proximity Controller Testing Prerequisites

      • Secure Digital Host Controller Testing Prerequisites

      • USB Bus Controller Testing Prerequisites

      • WITT I2C Testing Prerequisites

  2. Verify that you have installed the latest Windows HLK filters and kit updates. For more information, see Windows Hardware Lab Kit Filters.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  4. If you cannot obtain a successful test result, contact Windows HLK Support.

Bluetooth controller test troubleshooting

The following table describes common issues that can occur during Bluetooth controller testing:

Issue | Resolution
Failures finding Bluetooth devices during an Bluetooth Inquiry command | This failure can happen when you run a test in a noisy environment. Rerunning the test usually fixes this error. You can also try to bring the radios closer together. Make sure that the radios have a clear line of sight. Turn off other radios that may be causing interference.
Failures connecting Bluetooth devices during Bluetooth Inquiry commands | This failure occurs when the test times out before the devices could be reconnected. Rerunning the test usually fixes this error.

WITT I2C controller test troubleshooting

The following table describes common issues that can occur during Windows Inter-Integrated Circuit (I2C) Testing Tool (WITT) controller testing:

Issue | Resolution
All tests failed with error message WITT device test interface is not found. | Review WITT I2C Testing Prerequisites. Make sure that the WITT test peripheral driver is installed, ACPI table modified with sample ASL and four instances of WITT Test Driver are found in Windows HLK Device Manager.
WITT firmware needs to be updated. The WITT firmware binary (i2c9665a.iic) is released as part of. When you install a new Windows HLK package, you should update the WITT firmware. | See WITT I2C Testing Prerequisites for instructions on how to upgrade the WITT firmware.
WITT device is in a bad state. Typically, the green LED on a WITT device should be lit when there is no traffic, and should blink when there is traffic. Otherwise, the WITT or I2C controller might be in a bad state. | Unplug the WITTs USB cable to power-cycle the device. If the controller is still not working, reboot the testing system.

Related topics

Device.BusController Tests

Troubleshooting Windows HLK


WITT I2C Testing Prerequisites

The Windows Inter-Integrated Circuit (I2C) Testing Tool (WITT) controller tests verify Windows Hardware Lab Kit (Windows HLK) Windows Simple Peripheral Bus (SPB) compliance and the reliability of the I2C controller and its associated driver. WITT I2C controller tests consist of hardware (WITT adaptor) and software (test executable, test driver and utilities). For a list of WITT I2C tests, see Device.BusController Tests.

In this article:

  • WITT I<superscript xmlns="http://ddue.schemas.microsoft.com/authoring/2003/5">2</superscript>C controller test hardware setup

  • WITT I<superscript xmlns="http://ddue.schemas.microsoft.com/authoring/2003/5">2</superscript>C controller test software setup

  • I<superscript xmlns="http://ddue.schemas.microsoft.com/authoring/2003/5">2</superscript>C controller verification tests manual instructions

WITT I2C controller test hardware setup

Figure 1. Typical WITT test setup shows the test, test driver setup, and I2C connections that you must make to run WITT tests.

Figure 2. WITT Board with I2C Header shows the LEDs, I2C header, USB connector, test pin, EEPROM jumper, and voltage jumper on a typical WITT board.

network interface card with i2c header

You must connect Serial Clock (SCL), Serial Data (SDA), and ground (GND) pins to the host I2C controller. The General Purpose Input/Output (GPIO) connection is not needed for the WITT I2C controller tests. The SCL, SDA, and GND pins are shown in Figure 3. I2C 10-Pin Header:

USB

Connect a USB cable to a USB connector (type B). You can use the USB connection to update WITT firmware (this requires a Microsoft USB Test Tool (MUTT) driver and the Muttutil.exe utility, which you can get from the MUTT Software Package. Because WITT already has I2C controller test firmware, the USB connection is used for power supply purposes only. If a firmware upgrade is necessary, use following steps:

  1. Set up the WITT I2C targets as described in WITT I<superscript xmlns="http://ddue.schemas.microsoft.com/authoring/2003/5">2</superscript>C controller test software setup.

  2. From a command prompt window that has administrative privileges, run the following command:

    WITTUpgrade.exe I2C9665.iic /f

    Where I2C9665.iic is the firmware file and /f forces the upgrade to occur. (The firmware .iic file is released in the Windows HLK together with other test binaries.)

Test pin

The SCL/SDA/GND connectors on the test pin header can be soldered and used to connect an I2C to the host controller. The voltage of the I2C lines must match those of the host controller; these are typically 1.8v or 3.3v, and can be set by switching the voltage jumper on the WITT board (see Figure 2. WITT Board).

EEPROM jumper

The EEPROM jumper controls whether to boot from EEPROM. You should set the jumper at the position that is shown in Figure 2. WITT Board. (You only need to switch to the other position to recover the WITT firmware through the USB method.)

LED

You can interpret the LEDs as follows:

  • RED LED: POWER ON.

  • YELLOW LED: Constantly lit if there is no I2C BUS traffic (SCL and SDA are high).

  • BLUE LED: Flashing when I2C data traffic is ongoing between the host and WITT board.

I2C voltage jumper

This jumper can be used for level-shifting an I2C signal to WITT. Set jumper position 1-2 for 3.3v or jumper position 2-3 for 1.8v. Connect the power source to pin2 for additional voltage levels other than 1.8v and 3.3v.

WITT I2C controller test software setup

WITT test binaries are shipped together with the Windows HLK and are located on a Windows HLK controller or server in the \\{$HCKServer}\Tests\{$PROCESSOR_ARCHITECTURE}\spb folder, where HCKServer is the name of the Windows HLK server and $PROCESSOR_ARCHITECTURE is the device platform (AMD64, x86, or ARM). The WITT I2C tests require the following binaries:

  • Test peripheral driver: WITTTest.inf, WITTTest.sys, and WITTTest.cat.

  • WITTTest.exe

You must use a kernel debugger during the tests. You can download and install a kernel debugger from Download and Install Debugging Tools for Windows.

Typical setup step (single controller instance)

To setup a typical test configuration that uses a single controller, perform the following steps.

To set up a typical test configuration

  1. Open a command prompt that has administrative privileges.

  2. Run the following command to install the test peripheral driver:

    pnputil -a witttest.inf

    The -a flag adds the driver package to the Windows driver store.

  3. Update the Advanced Configuration and Power Interface (ACPI) table to enumerate the test device nodes. These are usually defined in the SSDT (secondary system descriptor table) or the DSDT (differentiated system description table).

    • In the command prompt window, run the following command to generate the SSDT:

      asl.exe /tab:ssdt

    • Edit the generated SSDT.asl table as follows:

      Device(TP1) {
    Name(_ADR,0)
    Name (_HID, "STK0001")
    Name (_CID, "WITTTest")
    Method(_CRS, 0x0, NotSerialized)
    {
      Name (RBUF, ResourceTemplate ()
      {
        I2CSerialBus ( 0x7F, ControllerInitiated, 100000,AddressingMode7Bit, "\\_SB_.I2C3",,, , )
      })
      Return(RBUF)
    }
}
Device(TP2) {
    Name(_ADR,0)
    Name (_HID, "STK0002")
    Name (_CID, "WITTTest")
    Method(_CRS, 0x0, NotSerialized)
    {
      Name (RBUF, ResourceTemplate ()
      {
        I2CSerialBus ( 0x11, ControllerInitiated, 100000,AddressingMode7Bit, "\\_SB_.I2C3",,, , )
      })
      Return(RBUF)
    }
}
Device(TP3) {
    Name(_ADR,0)
    Name (_HID, "STK0003")
    Name (_CID, "WITTTest")
    Method(_CRS, 0x0, NotSerialized)
    {
      Name (RBUF, ResourceTemplate ()
      {
        I2CSerialBus ( 0x12, ControllerInitiated, 400000,AddressingMode7Bit, "\\_SB_.I2C3",,, , )
      })
      Return(RBUF)
    }
}
Device(TP4) {
    Name(_ADR,0)
    Name (_HID, "STK0004")
    Name (_CID, "WITTTest")
    Method(_CRS, 0x0, NotSerialized)
    {
      Name (RBUF, ResourceTemplate ()
      {
        I2CSerialBus ( 0x13, ControllerInitiated, 1000000,AddressingMode7Bit, "\\_SB_.I2C3",,, , )
      })
      Return(RBUF)
    }
}

      In this test, TP1 is used as test interface (0x7F), TP2 (0x11) is configured as standard I2C target, TP3 (0x12) is configured as fast I2C target and TP4 (0x13) is configured as fast plus I2C target.

      NOTE

      Change the I2C controller address that is listed in the table to that of the actual I2C controller.

  4. In the command prompt window, run the following command to generate an Ssdt.aml file from the modified Ssdt.asl file:

    asl.exe ssdt.asl

  5. In the command prompt window, run the following command to update the revised ACPI table:

    asl.exe /loadtable ssdt.aml

  6. Enable the driver verifier on the I2C Controller and in Spbcx.sys by using the default settings.

  7. Restart the system: four device instances should display under the WITT Test Class node in Device Manager in the Windows HLK.

  8. You can verify that the WITT test environment is set up correctly by running Spbcmd.exe from the command line. Sample command output of the Spbcmd tool follows, where 7F is the signature for the test interface and 01, 02 and 03 are signatures for three testing targets.

    > list
list
Available connection ID:
Target:53, Instance:0x0
Target:54, Instance:0x0
Target:55, Instance:0x0
Target:56, Instance:0x0
> i2c 0x0 0x21    //this step is not necessary if you are not testing multiple instances
i2c 0x0 0x21
Instance requested:0x0
I2C address requested:0x21
Found WITT test interface at \\.\RESOURCE_HUB\0000000000000035
WITT Testing I2C address successfully changed to 0x21 for instance 0x0
> open 53
open 53
Address 53 opened
> read 53 1
read 53 1
1 bytes read
  7f
> open 54
open 54
Address 54 opened
> read 54 1
read 54 1
1 bytes read
  01
> write 54 {01 02 03}
write 54 {01 02 03}
3 bytes written
> writeread 54 {01 02 03} 2
writeread 54 {01 02 03} 2
5 bytes transferred
  01 01 52 00 c0

    Use the Open and Close commands to open and close targets. Read, Write, and WriteRead are manual I/O commands.

    You can also use the List command to list all available I2C testing targets I2C: I2C 0x0 0x21. Switch the WITT testing address to start with 0x21(0x21,0x22,0x23); for example, 0 if you configured non-default I2C address in the ASL.

I2C controller verification tests manual instructions

You can run the I2C controller verification test manually in addition to running it in Windows HLK Studio. This section describes how to manually run the WITT I2C controller tests. For specific information about each test, see the individual test topics.

You must run each test from a command prompt window that has administrative privileges.

Copy wttlog.dll from \\${HCKServer}\TaefBinaries to the same directory where Witttest.exe resides, where HCKServer is the name of the Windows HLK server.

To list all available tests and command line parameters, type wittest.exe /? at a command prompt. For example:

Witttest.exe /?
Supported command line arguments are:
/rs:<Seed>
/sm internal use of acpsim load
/fw:firmwareware iic
/i2c:address
/ins:witt instance number
/dip:device instance path
/duration:stress duration in minutes
/test:<test_id>

Example:
WITTTest.exe /test:BasicIORead

Currently the following test id's are supported:
/test:BasicIORead
/test:BasicIOWrite
/test:BasicIOSeq
/test:BasicIOKernel
/test:ClkStretch
/test:DeviceNack
/test:LockUnlock
/test:CancelRead
/test:CancelWrite
/test:CancelSeq
/test:PerfRead
/test:PerfWrite
/test:PerfSeq
/test:MultipleTargets
/test:BusRecovery
/test:Power
/test:Stress
/test:RunAll

To run an individual test by using the default values, type Witttest.exe /test:<Testname>, where <Testname> is the name of the test; for example, Witttest.exe /test:BasicIORead. To run this test with a different instance than the default instance of 0, type Witttest.exe /test:BasicIORead /ins:0x1. To run this test with a different testing I2C testing address instead of the default testing I2C address 0x11,0x12,0x13, type Witttest.exe /test:BasicIORead /i2c:0x21.

To run all tests, type Witttest.exe /test:RunAll. This command cycles through all tests and a test result is printed at the end of the test sequence; for example:

*****Test run results*****

# Test cases passed:

BasicIORead
BasicIOWrite
BasicIOSeq
BasicIOKernel
ClkStretch
LockUnlock
PerfRead
PerfWrite
PerfSeq
MultipleTargets
Stress

# Test Cases passed with warning:

CancelRead
CancelWrite
CancelSeq

# Test Cases Failed:

DeviceNack

# Total:

Pass:11 Fail:1 Warn:3

Related topics

WITT (Windows I2C Test Tool)

Troubleshooting Bus Controller Testing


Hardware Lab Kit (HLK) for Near Field Communication (NFC)

The HLK for NFC validates that the NFC driver implementation meets Microsoft specifications. Although the tests are able to be run manually, for automated, faster and more reliable testing for the HLK NFC test suite, we recommend that partners acquire the NFC Interoperability Test Tool (NITT).

The NITT simulates Type 1, 2, 3, and 4 NFC forum tags. The NITT has a robot arm that moves an RF shield, simulating tapping/un-tapping operations for Peer-to-Peer and Card Emulation scenarios. The following image illustrates the NITT setup.

The NITT is powered with an external power supply of 7.5v and is connected to the client PC.

To acquire the NITT, use the following contact information:

JJG Technologies LLC
1034 231st Pl NE
Sammamish, WA 98074
Phone: (206) 304-1921 Fax: (208) 298-0623
inquiry@jjgtechnologies.com

After setting up the HLK test framework:

Hardware requirements

  • Device with NFC chip that implements the NFC driver DDIs and is subject to compliance tests (referred to as Device Under Test (DUT))
  • Desktop PC with USB port (PC client)
  • NITT board (if available) connected to the PC client
  • Device with NFC chip that implements the Near Field Proximity DDIs (NFC client)
  • Smart card reader connected to the PC client (either by USB or embedded in the PC client)
NOTE

The PC client requires the installation of the Universal C Runtime. This package is available directly from the Microsoft Download Center.

Test execution

Before you run the test

  • Make sure HLK client is deployed to DUT.
  • Place the DUT on top of the NITT board NFC antenna.
  • Place NFC client or smart card reader, depending on the test being run, below the NFC antenna and the RF shield of the NITT.
  • Make sure the PC client has the Universal C Runtime installed.
  • Make sure DUT, NFC client and PC client have network connections. If the DUT or the NFC client is a phone, you will need the Virtual Ethernet tool to be able to connect to the phone.

The HLK studio/controller deploys and runs test cases on the DUT but some intervention on the tester's part is required. For test cases where manual intervention is required, the helper binaries need to be launched manually. In order to do so, the NFC and PC clients need to have the following setup:

NFC client

  • Create a working folder, and copy TAEF binaries corresponding to the client architecture from the HLK controller to the working directory. For a typical HLK studio setup, the TAEF binaries will be located in the following directory:

    C:\Program Files (x86)\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\*\MinTE\*

    Where <arch> is either x86, x64, arm, arm64.

  • Copy NfcRemotePeerService.dll from the following HLK Studio location to the working directory created above:

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\NFC\NfcRemotePeerService.dll

    Where <arch> is either x86, amd64, arm, arm64.

PC client (*setup if using NITT)

  • Create a working folder, and copy TAEF binaries corresponding to the client architecture from the HLK controller to the working directory. For a typical HLK studio setup, the TAEF binaries will be located in the following directory:

    C:\Program Files (x86)\Windows Kits\10\Testing\Runtimes\TAEF\<arch>\*\MinTE\*

    Where <arch> is either x86, x64, arm, arm64.

  • Copy NfcNittController.exe from the following HLK studio location to the working directory created above:

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\NFC\NfcNittController.exe

    Where <arch> is either x86, amd64, arm, arm64.

  • Copy MuttUtil.dll from the following HLK studio location to the working directory created above:

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\usb\MuttTools\MuttUtil.dll

    Where <arch> is either x86, amd64, arm, arm64.

PC client (*setup if not using NITT)

  • Create a working folder, and copy NfcManualHelper.exe corresponding to the client architecture from the HLK controller to the working directory. For a typical HLK studio setup, NfcManualHelper.exe will be located in the following directory:

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\<arch>\NFC\NfcManualHelper.exe

    Where <arch> is either x86, x64, arm, arm64.

Running the test using HLK

HLK Studio

  • In HLK studio, select the test from the "Tests" tab as per following image:

  • Click Run Selected

  • If you are running the tests manually (without the NITT) then change the Parameters value from nitt to manual, as shown in the following image:

NFC client

  • Open the command prompt, and go to the working folder created above

  • Run the following command:

    TE.exe NfcRemotePeerService.dll /p:server=<ip_of_dut>

    Where <ip_of_dut> is the IP address of the DUT

  • NfcRemotePeerService.dll will connect to the test running on the DUT and will receive commands from the test. These commands will instruct NfcRemotePeerService.dll on when to create Near Field Proximity publications and subscriptions on the NFC client. When the DUT and the NFC client are tapped together, the publications and subscriptions will fire, exercising NFC's Peer-to-Peer scenarios.

PC client (*setup if using NITT)

  • Open the command prompt, and go to the working folder created above

  • Run the following command:

    nfcnittcontroller.exe -server <ip_of_dut> -tagIndex <tag_index> -reader <reader_name>

    Where <ip_of_dut> is the IP address of the DUT, <tag_index> is the NITT board tag index, and <reader_name> is the name of the smart card reader connected to the PC client. Possible values of <tag_index> are 1, 2, 3, and 4 corresponding to NFC Forum compliant T1T, T2T, T3T, and T4T, respectively. To find the name of the smart card reader connected to the PC client, you can use the -listReaders option of NfcManualHelper.exe (see below).

  • NfcNittController.exe will connect to the test running on the DUT and will receive commands from the test. These commands will instruct NfcNittController.exe on when to perform actions with the NITT. These actions are performed automatically and don't need any manual interaction. Example actions: Opening and closing the RF shield, turning on and off a tag on the NITT.

PC client (*setup if not using NITT)

  • Open the command prompt, and go to the working folder created above

  • Run the following command:

    nfcmanualhelper.exe -server <ip_of_dut> -reader <reader_name>

    Where <ip_of_dut> is the IP address of the DUT and <reader_name> is the name of the smart card reader connected to the PC client. To find the name of the smart card reader connected to the PC client, you can run the following command:

    nfcmanualhelper.exe -listReaders

  • NfcManualHelper.exe will connect to the test running on the DUT and will print instructions on what to do while the test is executing. Example instructions: Tap DUT onto NFC client, tap DUT onto smart card reader, tap DUT onto Near Field Proximity tag.


Device.Cluster

In this section

  • Device.Cluster tests


Device.Cluster tests

  • CiB CA Validation Tests


CiB CA Validation Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d69c3a49-48d5-4022-84bc-5ea9cba3d446

These tests are the second part of the Cluster in a Box (CiB) Continuous Available (CA) validation tests which help validate CiB product meet the CA hardware requirements. The tests conduct various end-to-end test scenarios by running I/O workloads, data integrity tests against the cluster during a planned or unplanned failover. The tests also validate that the hardware platform under test meets CA hardware requirements.

Test details
Specifications
  • Device.Cluster.Core.ClusterInABox
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 480
Category | Scenario
Timeout (in minutes) | 28800
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

Prerequisite: Pass the CiB Cluster Evaluation Tests

  1. After passing the CiB Cluster Evaluation Tests, go back to the Selection page and deselect the Test Controller machine under the systems tab

  2. Click on the device manager tab, and search for the cluster name specified for Cluster Evaluation Tests. Select the listed device.

  3. Go to the Tests page, select CiB CA Validation Tests, and click Run Selected

  4. Set the Duration value, which is how long the test scenarios run in minutes. The suggested runtime is 480 minutes (8 hours) or longer. The minimum runtime is 120 minutes. This can also be used as long haul tests for testing product reliability.

    Click OK to schedule the job.

  5. Go to the Results page to check the test status and results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

If failures are found, you can review the logs to get additional details about the failures in HLK Studio under the Results page:

  • CiB CA Validation Tests->Run CiB CA tests->Logs->te.wtl

To view CA Validation Report and additional logs, right-click the test, and select Additional Files

More information

Parameters

Parameter name | Parameter description
CiBTestBin | test binary location
AutomatedOnly | Specify true if this test should not run any manual tests
PATHTOXML |
CONFIGFILENAME | Name of the config XML file
LOGFILE_INPUT |
LOGFILE_OUTPUT |
parse_whck.ps1 |
Duration | The duration of the test run in minutes. Minimum is 120 minutes
Validate-Cluster.ps1 |


Device.Connectivity

In this section

  • Device.Connectivity tests
  • Device.Connectivity additional documentation


Device.Connectivity tests

  • [Windows USB Device] Basic transfer stress
  • [Windows USB Device] Bulk in performance
  • [Windows USB Device] Bulk out performance
  • [Windows USB Device] Endpoint 0 descriptor
  • [Windows USB Device] Endpoint 0 transfers
  • [Windows USB Device] Endpoint 0 transfers with stalls
  • [Windows USB Device] Endpoint 0 transfers with zero-length packets
  • [Windows USB Device] Full packet loopback on all pipes
  • [Windows USB Device] Full packet loopback on bulk pipes
  • [Windows USB Device] Full packet loopback on interrupt pipes
  • [Windows USB Device] Get MSOS compatible IDs
  • [Windows USB Device] Get MSOS extended properties
  • [Windows USB Device] Get MSOS string descriptor
  • [Windows USB Device] Interrupt in performance
  • [Windows USB Device] Interrupt out performance
  • [Windows USB Device] Large transfer stress
  • [Windows USB Device] Maximum packet size loopback on bulk pipes
  • [Windows USB Device] Maximum packet size loopback on interrupt pipes
  • [Windows USB Device] Performance
  • [Windows USB Device] Performance - Bidirectional
  • [Windows USB Device] Short out transfer stress
  • [Windows USB Device] Short packet in transfers on all pipes
  • [Windows USB Device] Short packet in transfers on bulk pipes
  • [Windows USB Device] Short packet in transfers on interrupt pipes
  • [Windows USB Device] Short packet loopback on all pipes
  • [Windows USB Device] Short packet loopback on bulk pipes
  • [Windows USB Device] Short packet loopback on bulk pipes
  • [Windows USB Device] Short packet loopback on interrupt pipes
  • [Windows USB Device] Short packet loopback on interrupt pipes
  • [Windows USB Device] Short packet out transfers on all pipes
  • [Windows USB Device] Short packet out transfers on bulk pipes
  • [Windows USB Device] Short packet out transfers on interrupt pipes
  • [Windows USB Device] Stalled transfer on bulk pipes
  • [Windows USB Device] Stalled transfer on interrupt pipes
  • [Windows USB Device] Support for USB_REQUEST_GET_DESCRIPTOR
  • [Windows USB Device] Support for USB_REQUEST_GET_INTERFACE
  • Bluetooth - BluetoothDeviceIDProfileVer13_1 (Bring Up)
  • Bluetooth - BluetoothHidLimitedDiscoverableMode (Bring Up)
  • Bluetooth - HidInitiateReconnect1 (Bring Up)
  • Bluetooth - KeyboardSupportPasskeyAuthentication1 (Bring Up)
  • Bluetooth - SupportsBluetoothVer21_1 (Bring Up)
  • USB (USBDEX) Verifier Test
  • USB 3.0 Hub Enumeration Bounce
  • USB 3.0 Insertion Test
  • USB Device Connection S3+S4+Connected Standby
  • USB Hardware Verifier Test For Devices (XHCI)
  • USB Hub Exposed Port Test
  • USB Selective Suspend Test (XHCI)
  • USB Serial Number Test
  • USB-IF Certification Validation Test (Device)
  • Web Services for Devices (WSD)


\Windows USB Device\ Basic transfer stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0a0674eb-92d9-4e20-a4f4-2dee3fb5c10f

Performs I/O stress tests on all pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Bulk in performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bde9aad5-69f8-4779-bd00-4d6325e13891

Measures performance of a pair of BULK and INTERRUPT pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Bulk out performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f96c3cf0-aa8e-437c-abec-d439a49365c4

Measures performance of a pair of BULK and INTERRUPT pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Endpoint 0 descriptor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24bf72f8-980a-465f-b0d3-4f4074a479e2

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Endpoint 0 transfers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8361faa7-e9ee-4162-a028-600087705ca2

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Endpoint 0 transfers with stalls

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82d87905-1591-45d5-8521-cb20353c1be5

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Endpoint 0 transfers with zero-length packets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69a003bc-0691-4449-93b0-e1ef738d71cd

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Full packet loopback on all pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3ced15c-9486-4482-b351-30c8c54e7c03

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Full packet loopback on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2944559-85c0-40f7-adc3-6f0895528e2d

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Full packet loopback on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d36a0fda-2af5-4ea6-a105-f6c20ee851aa

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Get MSOS compatible IDs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f25108a4-8889-4e81-b03c-0195da18dbd1

Tests the ability of the device to respond to queries for various MSOS descriptors.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Get MSOS extended properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f085730-141a-41a2-8fb6-679baba5f62a

Tests the ability of the device to respond to queries for various MSOS descriptors.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Get MSOS string descriptor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9c412e2-67ee-4e51-9477-8681c4e93051

Tests the ability of the device to respond to queries for various MSOS descriptors.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Interrupt in performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f27ac42d-5d78-4abb-a97a-94e43dfbdd48

Measures performance of a pair of BULK and INTERRUPT pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Interrupt out performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67acb4e9-2b75-4bb2-80a8-11ac39f67e51

Measures performance of a pair of BULK and INTERRUPT pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Large transfer stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4643001b-ca53-4b18-a011-364f2566ea03

Performs I/O stress tests on all pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Maximum packet size loopback on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1751aa8-8681-461a-a395-62b2bc5bdee6

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Maximum packet size loopback on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/adf6663a-5842-40a4-9514-70ba7364a355

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9cebed32-c87e-474b-81ce-341a9fed1e00

Measures performance of a pair of BULK and INTERRUPT pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Benchmark
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Performance - Bidirectional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9f5e2fd0-9b74-4080-a09d-492d691e288b

Measures performance of a pair of BULK and INTERRUPT pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short out transfer stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8358de6a-5fad-4455-850a-c72fb210c82a

Performs I/O stress tests on all pipes.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet in transfers on all pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9cd8b529-9a8c-4fb8-bb74-8d9ecbee551f

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet in transfers on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2522de20-146e-40c2-803e-d7ca800374a9

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet in transfers on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cff9af15-7982-4248-be31-7a94d24a3488

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet loopback on all pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eab895b4-0fed-433b-b894-922c53419200

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet loopback on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51481a78-9ee6-405c-af47-85b3b41f3fd9

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet loopback on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/904c6bb2-3441-4474-af05-378e87835e46

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet loopback on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01759e9b-9b6a-469e-9197-7623f096ad06

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet loopback on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08ceb293-967a-4f68-8a55-ed460decce26

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet out transfers on all pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bcdf119a-5b49-471c-b1af-03ae0b658705

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet out transfers on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c003b712-e5fe-4f24-83e6-620126816ff1

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Short packet out transfers on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b076c77-af6d-444c-a2b5-90416ca2bea9

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Stalled transfer on bulk pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4be2a62e-b5d2-407f-be45-8f9680f6dda7

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Stalled transfer on interrupt pipes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efe6187c-2a1e-41d1-90a5-82f0c786ac37

Performs I/O tests on all BULK and INTERRUPT pipes as well as the control endpoint.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Support for USB_REQUEST_GET_DESCRIPTOR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cddb8c4b-31ce-472c-9e83-24128a02c4e3

Verifies that the device supports USB_REQUEST_GET_DESCRIPTOR correctly.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


\Windows USB Device\ Support for USB_REQUEST_GET_INTERFACE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a136014a-3946-4c36-a802-38debe1127e6

Verifies that the device supports USB_REQUEST_GET_INTERFACE correctly.

Test details
Specifications
  • Device.Connectivity.UsbDevices.WindowsUsbDevice.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


Bluetooth - BluetoothDeviceIDProfileVer13_1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/865d28e3-a84a-49db-b755-4fd606e4c508

Validates the device support for the Bluetooth Device ID Profile version 1.3

Test details
Specifications
  • Device.Connectivity.BluetoothDevices.BluetoothDeviceIdProfileVer13
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices


Bluetooth - BluetoothHidLimitedDiscoverableMode (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/950da6ae-fffb-42b1-9b5c-56e27a1c10b2

Validates the Bluetooth HID device supports the Limited Discoverable Mode

Test details
Specifications
  • Device.Connectivity.BluetoothDevices.BluetoothHidLimitedDiscoverableMode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices


Bluetooth - HidInitiateReconnect1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/39c3c500-5d68-4a94-b114-bc3232ec609d

Validates the Bluetooth HID device supports for the HID Reconnect Initiate feature.

Test details
Specifications
  • Device.Connectivity.BluetoothDevices.HidInitiatedReconnect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices


Bluetooth - KeyboardSupportPasskeyAuthentication1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79cd2a1f-0651-484f-901e-aaccd831e4fe

Validates the Bluetooth HID keyboard supports passkey authentication.

Test details
Specifications
  • Device.Connectivity.BluetoothDevices.KeyboardsSupportPasskeyAuthentication
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices


Bluetooth - SupportsBluetoothVer21_1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9af9919e-8a0c-4210-aef6-3a6ef2201446

Validates the device support for the Bluetooth Core specification 2.1 or newer

Test details
Specifications
  • Device.Connectivity.BluetoothDevices.SupportBluetooth21
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of the target Bluetooth device, if not set, tests are ran against all paired devices


USB (USBDEX) Verifier Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac8f8d7d-b057-4d62-9602-8551aaf943fc

This test runs USB (USBDEX) Verifier Tests.

Test details
Specifications
  • Device.Connectivity.UsbDevices.TestedUsingMicrosoftUsbStack
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID of the device under test
queryVendorId | VID of the device under test
queryProductId | PID of the device under test
queryIsUsbHubParam | True if device under test is a hub


USB 3.0 Hub Enumeration Bounce

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/202cba32-fa22-4cbb-9359-e881b1f949ae

This test verifies that when a USB 3.0 hub is connected to an xHCI port configured at USB 2.0 speeds, the hub reconnects on the SuperSpeed port when the SuperSpeed port is re-enabled and that the companion port stays connected.

Test details
Specifications
  • Device.Connectivity.UsbHub.SuperSpeedRemainsOnAfterPortReset
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID of the device under test


USB 3.0 Insertion Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a193c3a-d18b-468b-92bd-77166266a2df

This test verifies that a USB 3.0 device always connects on the SuperSpeed port.

Test details
Specifications
  • Device.Connectivity.UsbDevices.SuperSpeedOnConnectViaUsb3Port
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


USB Device Connection S3+S4+Connected Standby

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e35cd21-a1dd-4cfa-be2d-1a9c9d6a1fef

This test verifies that a USB-based device becomes available within 500 milliseconds after the test system exits the S3 or S4 power state or connected standby. The test also confirms that there were not any errant device disconnects during system resume.

Test details
Specifications
  • Device.Connectivity.UsbDevices.DeviceAttachLessThan100ms
  • Device.Connectivity.UsbDevices.MustBeFunctionalAfterResume
  • Device.Connectivity.UsbDevices.MustResumeWithoutForcedReset
  • Device.Connectivity.UsbDevices.MustSignalAttachWithin500ms
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID of the device under test
queryIsUsb3 | QueryIsUsb3 of device under test
DFUDevice | Uses DFU to reflash firmware on connect


USB Hardware Verifier Test For Devices (XHCI)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e23dceb6-a3d4-41ee-abe7-ac2a9a498988

This test performs USB descriptor validation, and also verifies that a SuperSpeed device, when configured as a USB 2.0 device, will re-connect on the SuperSpeed port when the port is reset.

Test details
Specifications
  • Device.Connectivity.UsbDevices.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID of the device under test


USB Hub Exposed Port Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68f6e04f-4b7f-4548-9562-db9d46105554

This test verifies that a USB 3.0 hub adheres to section 10.1 of the USB 3.0 specification.

Test details
Specifications
  • Device.Connectivity.UsbHub.Usb3HubCompliesWithUsb3Spec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of device under test
queryVendorId | queryVendorId of device under test
queryProductId | queryProductId of device under test


USB Selective Suspend Test (XHCI)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac1599fe-ed1f-4f29-9a57-01896c3d7db5

This test evaluates the selective suspend abilities of the USB device.

Test details
Specifications
  • Device.Connectivity.UsbDevices.MustSupportSuspend
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation


USB Serial Number Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0f2d5113-cf70-4cda-8afc-b7005d1e2739

This test verifies that device serial numbers are unique.

Test details
Specifications
  • Device.Connectivity.UsbDevices.SerialNumbers
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
queryVendorId | VendorId of device under test
queryProductId | ProductId of device under test
IsSoloEmbeddedUSBDevice | Set this to True for devices where you can have only one device connected. E.g: Bluetooth controller.


USB-IF Certification Validation Test (Device)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eaccaddf-d3dc-4d05-9d04-bf2549a54cbd

This test checks that the device has passed USB-IF Certification

Test details
Specifications
  • Device.Connectivity.UsbDevices.UsbifCertification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
TID | USB-IF Certification Test ID

For more information about TID, see USB tests in the Windows 10 Hardware Lab Kit (HLK) on the Microsoft Windows USB Core Team Blog.

NOTE

When you use SELF_TEST, you don't need to submit any type of USB-IF test log to MS for review.


Web Services for Devices (WSD)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81242753-2559-474c-9dd2-3b44debd6b38

This runs the WSD/DPWS logo tests This job requires 1 machine as well as the DeviceID for the device that is being tested.

Test details
Specifications
  • Device.Connectivity.WSD.DPWS
  • Device.Connectivity.WSD.DPWSExtensibility
  • Device.Connectivity.WSD.MetadataExchange
  • Device.Connectivity.WSD.MetadataValid
  • Device.Connectivity.WSD.Schema
  • Device.Connectivity.WSD.WSDiscovery
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Connectivity additional documentation

More information

Parameters

Parameter name | Parameter description
DPWS_UUID | UUID of the DPWS Device under test
TestLocation | Location of the test binaries


Device.Connectivity additional documentation

In this section

  • PCI Device.Connectivity Testing Prerequisites
  • Proximity Device.Connectivity Testing Prerequisites
  • USB Device.Connectivity Testing Prerequisites
  • USB Hub.Connectivity Testing Prerequisites
  • Troubleshooting Device.Connectivity Testing


PCI Device.Connectivity Testing Prerequisites

This section describes the tasks that you must complete before you test a PCI-based test device using the Windows Hardware Lab Kit (Windows HLK).

Before beginning testing, complete the following:

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for PCI device testing. You might need additional hardware if the test device includes additional features.

  • One test computer. The test computer must meet Windows HLK prerequisites. See Windows HLK Prerequisites for more information.

  • One test PCI device.

NOTE

Additional test hardware will be required depending on that type of PCI device is being tested. For example, if the PCI test device is a graphic adapter, review the Device.Graphics test prerequisites.

Software requirements

The following software is required to run the Device.Connectivity tests:

  • The latest Windows HLK filters or updates.

  • The drivers for the test device.

Test computer configuration

To configure the test computer for PCI device testing:

  1. Install the appropriate Windows operating system on the test computer and then configure the computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Install the test PCI device in the test computer.

  3. Install any required drivers for the test PCI device.

  4. Check that the test PCI device is detected by the test computer.

  5. Install the Windows HLK client application on the test computer.

  6. Using the Windows HLK Studio, create a machine pool, and move the test computer to that pool.

  7. Review the features detected by the Windows HLK Studio and review any additional prerequisites for the features detected for the test device.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

NOTE

If a device supports multiple connectivity methods, complete a separate submission for each connectivity method.


Proximity Device.Connectivity Testing Prerequisites

This topic describes the tasks that you must complete before you test your device for proximity feature support by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

To run the proximity tests, you need the following hardware:

  • One test device that includes the proximity feature (for example, a proximity-enabled mouse or keyboard).

  • One test computer that meets the Windows HLK Prerequisites and has one near field proximity hardware device attached.

  • One proximity controller.

Software requirements

To run the proximity tests, you need the following software:

  • The drivers for the test device

  • The latest Windows HLK filters and software updates

Test computer configuration

To configure the test computer for proximity testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains Windows HLK Studio and Windows HLK Controller).

  2. If the test computer doesn't include an integrated proximity controller, attach an external proximity controller to the test computer.

  3. Install the manufacturer-supplied device driver, if it's required, on the test computer.

  4. Install the Windows HLK client application on the test computer.

  5. By using Windows HLK Studio, create a computer pool and move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review that test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

IMPORTANT

You must open the desktop on the test computer before you run any proximity tests. To do this, choose the Desktop tile from the Start screen after the test computer starts.

NOTE

If a device supports multiple connectivity methods, complete a separate submission for each connectivity method.


USB Device.Connectivity Testing Prerequisites

This topic describes the tasks that you must complete before you test your USB device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements,

  • Test computer configuration.

Hardware requirements

The following hardware is required for USB device testing. You might need additional hardware if the device includes additional features.

  • A test computer that meets the Windows HLK Prerequisites.

  • An EHCI-compliant controller and an xHCI version 1.0 compliant controller, or an xHCI-compliant controller and a high speed hub. The controllers can be either embedded or included on an adapter that is attached or installed in the test computer.

  • Two identical USB test devices. (Note that if the device does not support serial numbers,a legacy test mode option supports using one device only.)

  • A high speed hub if you are using an xHCI controller only.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

Before you run the USB tests in the Device.Connectivity category, you should install the latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for USB device testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains Windows HLK Studio and Windows HLK Controller).

  2. Attach one of the USB devices to the test computer through an xHCI controller (it can either be attached directly to the root hub port or through a SuperSpeed hub.)

  3. Attach the other USB device to the EHCI port or to a high speed hub that is connected to the XHCI port.

    NOTE

    If the USB device supports a USB serial number, attach an additional USB 3.0-compliant device to the test computer before you run the USB Serial Number test. For more information about this test, see USB Serial Number.

    To test USB 3.0 or 2.0 devices or hubs on a system running Windows 7, make sure that the device or hub is attached to a USB 2.0 port of an EHCI controller. xHCI controllers on systems running Windows 7 load non-Microsoft drivers. HLK tests cannot detect devices and hubs enumerated by third-party drivers.

  4. Optionally, verify that the test device is visible from Device Manager on the test computer.

  5. Install the Windows HLK client application on the test computer.

  6. By using Windows HLK Studio, create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

If a device supports multiple connectivity methods, complete a separate submission for each connectivity method.

Related topics

Device.Connectivity Tests


USB Hub.Connectivity Testing Prerequisites

This topic describes the tasks that you must complete before you test your USB hub by using the Windows Hardware Lab Kit (Windows HLK):

  • USB Device.Connectivity Testing Prerequisites.

  • USB Device.Connectivity Testing Prerequisites.

  • USB Device.Connectivity Testing Prerequisites.

Hardware requirements

The following hardware is required for USB device testing. You might need additional hardware if the device includes additional features.

  • One test computer. The test computer must meet Windows HLK prerequisites and include a USB 2.0-compliant controller and a USB 3.0 or xHCI-compliant controller. The controllers can be either embedded or included on an adapter that is attached or installed in the test computer. For more information, see Windows HLK Prerequisites.

  • One USB device to connect to the test hub. If you are testing a USB 3.0 hub, you need a USB 3.0-compliant device. Otherwise a high or low speed USB device is sufficient.

  • One USB test hub (for USB 2.0 compliant hubs) or two USB 3.0 test hubs. USB 3.0 hubs require another USB 3.0 hub to validate port mapping in the USB Hub Exposed Port Test.

    NOTE

    Two identical USB test hubs are required to verify the USB serial number is unique for classes of USB devices that include a USB serial number.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

Before you run the USB tests in the Device.Connectivity category, you should install the latest Windows HLK filters or updates .

Test computer configuration

To configure the test computer for USB hub testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains Windows HLK Studio and Windows HLK Controller).

  2. Attach the USB hub to the test computer through an xHCI controller port (Windows 8) or an EHCI controller port (Windows 7). USB tests must be run while connected to the xHCI port with the exception of the USB Topology Compatibility test, which requires you to unplug and reattach the hub to other USB ports on the test computer.

    NOTE

    If the USB hub supports a USB serial number, attach an additional USB 3.0-compliant device to the test computer before you run the USB Serial Number test. For more information about this test, see USB Serial Number.

    To test USB 3.0 or 2.0 devices or hubs on a system running Windows 7, make sure that the device or hub is attached to a USB 2.0 port of an EHCI controller. xHCI controllers on systems running Windows 7 load non-Microsoft drivers. HLK tests cannot detect devices and hubs enumerated by third-party drivers.

  3. Optionally, verify that the test device is visible from Device Manager on the test computer.

  4. Install the Windows HLK client application on the test computer.

  5. By using Windows HLK Studio, create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

If a device supports multiple connectivity methods, complete a separate submission for each connectivity method.


Troubleshooting Device.Connectivity Testing

To troubleshoot issues with PCI device, USB devices, or USB hub connectivity tests, follow these steps:

  1. Review:

    • Troubleshooting Windows HLK Test Failures

    • The following topics, depending on the device type:

      • PCI Device.Connectivity Testing Prerequisites

      • Proximity Device.Connectivity Testing Prerequisites

      • USB Device.Connectivity Testing Prerequisites

      • USB Hub.Connectivity Testing Prerequisites

  2. Verify that you have installed the latest Windows HLK filters and kit updates. For more information, see Windows Hardware Lab Kit Filters.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  4. If you cannot obtain a successful test result, contact Windows HLK Support.

Information about USB connectivity tests for Windows 7

The advantages of connecting a device to a USB 2.0 hub are as follows:

  • We recommended this connection for regular USB devices.

  • This connection is required for the USB Selective Suspend test. For more information, see USB Internal Device Idle Test - Compat.

  • This connection forces the Enhanced Host Controller Interface (EHCI) high-speed controller to enumerate low-speed and full-speed devices.

The disadvantages of connecting a device to a USB 2.0 hub are as follows:

  • Devices that have embedded hubs must be directly connected for certification tests.

  • We do not recommend multi-TT (transaction translator) hubs for certification testing.

When you are testing a device that has an embedded high-speed hub, attach the device directly to the system for all tests.

Related topics

Device.Connectivity Tests

Troubleshooting Windows HLK


Device.DevFund

In this section

  • Device.DevFund tests
  • Device.DevFund additional documentation


Device.DevFund tests

  • ApiValidator
  • ApiValidator - (WoW64 for ARM64)
  • BitLocker check after firmware update
  • BitLocker Tpm And Recovery Password tests for AOAC devices with Legacy PCR's
  • BitLocker Tpm And Recovery Password tests for AOAC devices with PCR[7]
  • BitLocker Tpm and Recovery Password tests for non-AOAC devices for Legacy PCRs
  • BitLocker Tpm and Recovery password tests for NONAOAC devices with PCR[7]
  • DF - InfVerif INF Verification
  • DevFund Broker Test
  • DF - Concurrent Hardware And Operating System (CHAOS) Test (Development and Integration)
  • DF - Concurrent Hardware And Operating System (CHAOS) Test (Reliability)
  • DF - Embedded Signature Verification Test (Tuning and Validation)
  • DF - Firmware Package Installation Test
  • DF - Firmware Package Installation Test - (WoW64 for ARM64)
  • DF - Fuzz Misc API test (Reliability)
  • DF - Fuzz misc API with zero length query test (Reliability)
  • DF - Fuzz open and close test (Reliability)
  • DF - Fuzz Query and Set File Information Test (Reliability)
  • DF - Fuzz Query and Set Security Test (Reliability)
  • DF - Fuzz random FSCTL test (Reliability)
  • DF - Fuzz random IOCTL test (Reliability)
  • DF - Fuzz sub-opens test (Reliability)
  • DF - Fuzz sub-opens with streams test (Reliability)
  • DF - Fuzz zero length buffer FSCTL test (Reliability)
  • DF - Fuzz zero length buffer IOCTL test (Reliability)
  • DF - InfVerif INF Verification
  • DF - PCI Root Port Surprise Remove Test (PCI devices only) (Reliability)
  • DF - PNP (disable and enable) with IO Before and After (Bring Up)
  • DF - PNP Cancel Remove Device Test (Development and Integration)
  • DF - PNP Cancel Remove Device Test (Reliability)
  • DF - PNP Cancel Stop Device Test (Development and Integration)
  • DF - PNP Cancel Stop Device Test (Reliability)
  • DF - PNP DIF Remove Device Test (Development and Integration)
  • DF - PNP DIF Remove Device Test (Reliability)
  • DF - PNP Disable And Enable Device Test (Development and Integration)
  • DF - PNP Disable And Enable Device Test (Reliability)
  • DF - PNP Rebalance Fail Restart Device Test (Development and Integration)
  • DF - PNP Rebalance Fail Restart Device Test (Reliability)
  • DF - PNP Rebalance Request New Resources Device Test (Development and Integration)
  • DF - PNP Rebalance Request New Resources Device Test (Reliability)
  • DF - PNP Remove Device Test (Development and Integration)
  • DF - PNP Remove Device Test (Reliability)
  • DF - PNP Stop (Rebalance) Device Test (Development and Integration)
  • DF - PNP Stop (Rebalance) Device Test (Reliability)
  • DF - PNP Surprise Remove Device Test (Development and Integration)
  • DF - PNP Surprise Remove Device Test (Reliability)
  • DF - Reboot restart with IO before and after (Reliability)
  • DF - Reboot Restart with IO During (Development and Integration)
  • DF - Reboot Restart with IO During (Reliability)
  • DF - Reinstall with IO Before and After (Development and Integration)
  • DF - Reinstall with IO Before and After (Reliability)
  • DF - SimpleIO stress test with IO process termination (Reliability)
  • DF - Sleep and PNP (disable and enable) with IO Before and After (Development and Integration)
  • DF - Sleep and PNP (disable and enable) with IO Before and After (Reliability)
  • DF - Sleep with IO Before and After (Bring Up)
  • DF - Sleep with IO During (Development and Integration)
  • DF - Sleep with IO During (Reliability)
  • HyperVisor Code Integrity Readiness Test
  • Operate In Nano Server Test
  • Operate In Server Core Test
  • Reflash Device Connected via Proxy Client
  • Static Tools Logo Test
  • TDI filters and LSPs are not allowed
  • Validate HAL Extension have no Imports
  • Verify HAL Extension serviceable
  • Wdf - Check Kmdf Function Table Test
  • Wdf - Check Umdf Function Table Test


ApiValidator

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df4a9671-c2aa-4c81-b964-7247fb4799df

This test performs the WDK Universal Driver API analysis on driver package(s).

Test details
Specifications
  • Device.DevFund.UniversalDriver.API
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
QueryValidateDriverFolder | Path to driver folder to validate. E.g. "%userprofile%\desktop\MY_DRIVER_PACKAGE"
PackageArchitecture | The platform architecture the package binary supports. Supported values; arm, arm64, amd64, x86

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation


ApiValidator - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c790765-d169-46ae-ba80-2c846e570871

This test performs the WDK Universal Driver API analysis on driver package(s). - This test is a WoW64 for ARM64 version of test guid df4a9671-c2aa-4c81-b964-7247fb4799df

Test details
Specifications
  • Device.DevFund.UniversalDriver.API
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
QueryValidateDriverFolder | Path to driver folder to validate. E.g. "%userprofile%\desktop\MY_DRIVER_PACKAGE"
PackageArchitecture | The platform architecture the package binary supports. Supported values; arm, arm64, amd64, x86

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation


BitLocker check after firmware update

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/954cf796-a640-4134-b742-eaf0ed2663ff

This test determines whether the device has hit recovery during the firmware update process. BitLocker must be enabled before a firmware update, and the test should be run after an update.

Test details
Specifications
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

The test returns Pass or Fail.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

If the test fails, it means that this system has hit BitLocker recovery. Please collect BitLocker events in Event viewer at two locations:

  • Application and Services Logs > Microsoft > Windows > BitLocker-API > Management

  • Filter Windows Logs > System by event sources started with BitLocker

The events should give detailed reasonS why recovery is hit. After the root cause of BitLocker recovery is understood and fixed, run the test on a system that has never hit a BitLocker recovery to get a passing result.

If the system uses Secure Boot for integrity check (PCR[7]), please see the following steps for more diagnosis information.

  1. The recovery might be triggered by the firmware update package.

  2. If the system has TPM2.0, PCR [7] support is required. Otherwise, PCR [7] support is optional. Tree EFI Protocol specification has details about PCR [7] support.

  3. Check to see if this system supports PCR [7] and is used by BitLocker/Device Encryption by issuing the following command from an elevated command prompt:

    Manage-bde -protectors -get %systemdrive%

    If PCR validation profile shows PCR 7, 11 (Uses Secure Boot for integrity validation), the system is configured correctly.

    If PCR validation profile doesn't show that BitLocker uses Secure Boot for integrity validation (for example, PCR validation profile says PCR 0, 2, 4, 11), this indicates that BitLocker cannot use PCR [7] and one of the following events might be logged into the event log, which is found at Application and Services Logs > Microsoft > Windows > BitLocker-API > Management.

    • BitLocker cannot use Secure Boot for integrity because it is disabled.

    • BitLocker cannot use Secure Boot for integrity because the required UEFI variable X is not present.

    • BitLocker cannot use Secure Boot for integrity because the UEFI variable X could not be read. Error Message: X.

    • BitLocker cannot use Secure Boot for integrity because the expected TCG Log entry for variable X is missing or invalid.

    • BitLocker cannot use Secure Boot for integrity because the expected TCG Log entry for the OS Loader Authority is missing or invalid.

    • BitLocker cannot use Secure Boot for integrity because the expected TCG Log entry for the OS Loader Authority has invalid structure. The event is expected to be an EV_EFI_VARIABLE_AUTHORITY event. The event data must be formatted as an EFI_VARIABLE_DATA structure with VariableName set to EFI_IMAGE_SECURITY_DATABASEGUID and UnicodeName set to 'db'.

    • BitLocker cannot use Secure Boot for integrity because the expected TCG Log entry for the OS Loader Authority is invalid. The contents of the EFI_VARIABLE_DATA.VariableData field should be an EFI_SIGNATURE_DATA structure with SignatureOwner set to the GUID {77fa9abd-0359-4d32-bd60-28f4e78f784b} (Microsoft).

    • BitLocker cannot use Secure Boot for integrity because the expected TCG Log entry for the OS Loader Authority is invalid. The EFI_SIGNATURE_DATA structure contained in the OS authority event could not be found in the Secure Boot 'db' signature database.

    • BitLocker cannot use Secure Boot for integrity because the signature of the boot loader could not be validated as a Windows signature chained to a trusted Microsoft root certificate.

    • BitLocker cannot use Secure Boot for integrity because the TCG Log entry for the OS Loader Authority is invalid. The signature contained in the EFI_SIGNATURE_DATA structure from the OS authority event could not be found in the verified certificate chain for the boot loader.

    • BitLocker cannot use Secure Boot for integrity because the expected TCG Log separator entry is missing or invalid.

    • BitLocker cannot use Secure Boot for integrity because the TCG Log for PCR [7] contains invalid entries.

  4. If BitLocker/Device Encryption is using PCR [7] as reported by the manage-bde command in step 3 and the system hit recovery, you will see a BitLocker-Driver event in Windows Logs > System with Event ID 24658, stating that the Secure Boot configuration has changed unexpectedly. To diagnose the issue, find two most recent BitLocker-API events (Event ID 817) in Application and Services Logs > Microsoft > Windows > BitLocker-API > Management. Time stamp of one of the 817 events should be earlier than that of event 24658; time stamp of the other 817 event should be later. Event 817 is logged when BitLocker seals a key to TPM where PCR [7] is used. In the Details tab, you can find PCR [7] value for the boot session where this event is logged. Given the system hit a recovery during a reboot, PCR [7] values across these two boot sessions should be different. PCR [7] values logged in these two 817 events will tell the difference. In event 817, TCG log for that boot session is logged as well. If you have a tool to parse TCG log, that will reveal detailed information about PCR extension. If you don't have such a tool, you can do the following:

    1. Copy TBSLogGenerator.exe from the Windows HLK Controller to your test machine. It is located at %systemdrive%\Program Files (x86)\Windows Kits\8.1\Hardware Certification Kit\Tests\<architecture>\NTTEST\BASETEST\ngscb, where <architecture> is the architecture of your test machine. This can be amd64, x86 or ARM.

      TBSLogGenerator.exe dumps PCR values and TCG log in a human-readable format for the boot session when TBSLogGenerator.exe gets run.

    2. Repeat the steps that triggers BitLocker recovery. For both boot sessions across BitLocker recovery, use TBSLogGenerator.exe to dump PCR values and TCG logs.

    3. Analyze two sets of PCR values and TCG logs to find the difference.


BitLocker Tpm And Recovery Password tests for AOAC devices with Legacy PCR's

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a4641a2-4fc6-4447-9d94-fdf402ca263c

This automated test contains TPM and recovery tests for devices that support InstantGo without Secure Boot

Test details
Specifications
  • System.Fundamentals.TPM.CS.ConnectedStandby
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Secure boot should be enabled.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail.

If this test fails, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

  1. Make sure you can see fveapi.dll in %systemroot%\system32\.

  2. Check test output directly from command prompt when the test runs or open te.wtl in the HLK Manager.

  3. If a test script fails, check the BitLocker status:

    • Manage-bde -status [volume]

  4. Collect BitLocker event logs from event viewer at two locations:

    • Filter \Windows logs\System logs by event sources started with BitLocker

    • Applications and Services Logs\Microsoft\Windows\BitLocker-API\Management

  5. Run **tpm.msc ** to ensure that the TPM Status is ON and that ownership has been taken.

  6. Check TCG logs

    • Collect TCG log (*.txt).

    • Compare multiple copies of the TCG log and see whether PCR [0, 2, 4, 11] are consistent across reboot and hibernate.

NOTE

If the BitLocker WHLK test results in a recovery event, the BitLocker recovery key is 48-zeros (0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000).


BitLocker Tpm And Recovery Password tests for AOAC devices with PCR\7\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5aac52da-a57c-4a12-aaac-de878a62bb08

All platforms that implement a TPM must ensure invariance of PCRs 7, 11 across power cycles in the absence of changes to the platform's static core root of trust for measurements (SRTM). Attaching a (non-bootable) USB to the platform or attaching the platform to a docking station should not cause changes to the SRTM.

NOTE

This test restarts the system multiple times to check whether PCRs are consistent.

Test details
Specifications
  • System.Fundamentals.TPM.CS.ConnectedStandby
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites. Also, check that TPM is on and ready for use by running tpm.msc (the Trusted Platform Module (TPM) Management snap-in). Secure boot should be enabled.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

If this test fails, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

  1. Make sure you can see fveapi.dll in %systemroot%\system32\.

  2. Check test output directly from command prompt when the test runs or open te.wtl in the HLK Manager.

  3. If a test script fails, check the BitLocker status:

    • Manage-bde -status [volume]

  4. Collect BitLocker event logs from event viewer at two locations:

    • Filter \Windows logs\System logs by event sources started with BitLocker

    • Applications and Services Logs\Microsoft\Windows\BitLocker-API\Management

  5. Run **tpm.msc ** to ensure that the TPM Status is ON and that ownership has been taken.

  6. Check TCG logs

    • Collect TCG log (*.txt).

    • Compare multiple copies of the TCG log and see whether PCR [0, 2, 4, 11] are consistent across reboot and hibernate.

NOTE

If the BitLocker WHLK test results in a recovery event, the BitLocker recovery key is 48-zeros (0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000).


BitLocker Tpm and Recovery Password tests for non-AOAC devices for Legacy PCRs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce9e5b64-8903-4025-bccf-a99d65663cf8

This test determines whether PCR [0,2,4,11] are consistent across restarts.

Test details
Specifications
  • System.Fundamentals.TPM.NonCS.NonConnectedStandby
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, remove any bootable CD/DVD media from the system under test and run this test from the Desktop instead of the Start Screen. Complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

This test will restart and hibernate the system to check whether PCRs are consistent.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

If this test fails, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

  1. Make sure you can see fveapi.dll from %systemroot%\system32\.

  2. Check test output directly from command prompt when the test runs or open te.wtl in the HLK Manager.

  3. If a test script fails, check the BitLocker status:

    • Manage-bde -status [volume]

  4. Collect BitLocker event logs from event viewer at two locations:

    • Filter \Windows logs\System logs by event sources started with BitLocker

    • Applications and Services Logs\Microsoft\Windows\BitLocker-API\Management

  5. Make sure TPM is turned on by running tpm.msc to ensure that the TPM Status is ON and that ownership has been taken.

  6. Check TCG logs

    • Collect TCG log (*.txt).

    • Compare multiple copies of the TCG log and see whether PCR [0,2,4,11] are consistent across reboot and hibernate.

NOTE

If the BitLocker WHLK test results in a recovery event, the BitLocker recovery key is 48-zeros (0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000).


BitLocker Tpm and Recovery password tests for NONAOAC devices with PCR\7\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c7a62bb-7f02-4a16-b37d-711cc9026e17

This automated test verifies whether PCR [7] is consistent across reboot and hibernates, and determines whether PCR [7] has the correct measurements.

Test details
Specifications
  • System.Fundamentals.TPM.NonCS.NonConnectedStandby
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Secure boot should be enabled if it is supported by the platform.

This test will reboot and hibernate to determine whether PCRs are consistent.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

If this test fails, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

  1. Make sure you can see fveapi.dll in %systemroot%\system32\.

  2. Check test output directly from command prompt when the test runs or open te.wtl in the HLK Manager.

  3. If a test script fails, check the BitLocker status:

    • Manage-bde -status [volume]

  4. Collect BitLocker event logs from event viewer at two locations:

    • Filter \Windows logs\System logs by event sources started with BitLocker

    • Applications and Services Logs\Microsoft\Windows\BitLocker-API\Management

  5. Run **tpm.msc ** to ensure that the TPM Status is ON and that ownership has been taken.

  6. Check TCG logs

    • Collect TCG log (*.txt).

    • Compare multiple copies of the TCG log and see whether PCR [0, 2, 4, 11] are consistent across reboot and hibernate.

NOTE

If the BitLocker WHLK test results in a recovery event, the BitLocker recovery key is 48-zeros (0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000).


DF - InfVerif INF Verification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bbcc1b46-d0bf-46c8-85b4-2cd62df34a20

This test validates a driver INF file syntactically, by passing it into the core Windows INF parser.

Test details
Specifications
  • Device.DevFund.INF.Syntax
  • Device.DevFund.Reliability.ProperINF
  • Device.Audio.HDAudio.INFHasDeviceID
  • Device.DevFund.DriverFramework.KMDF.WDFProperINF
  • Device.DevFund.DriverFramework.UMDF.WDFProperINF
  • Device.Graphics.AdapterBase.RunFromDriverStore
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device Instance ID of the target device


DevFund Broker Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5fe996a4-38ee-4b20-86e2-362dbefa0ddd

This test verifies all of the device interface paths for a device node against the Device.Fundamentals requirements.

Test details
Specifications
  • Device.DevFund.CDA.Application
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

If you select a device node that has any restricted interfaces, a dialog box is displayed. Press OK to dismiss the dialog box.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

File list

File | Location
brokerlogotest.dll | <testbinroot>\brokerlogotest.dll
brokerlogotest.dll.mui | <testbinroot>\en-us\brokerlogotest.dll.mui

Parameters

Parameter name | Parameter description
WDKDeviceID | The target devnode's device identifier.


DF - Concurrent Hardware And Operating System (CHAOS) Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66f2b4ea-285c-41ac-9699-66a288abd46e

The CHAOS (Concurrent Hardware and Operating System) tests run various PnP driver tests, device driver fuzz tests, and power system tests concurrently.

Additional test info

Test Description
Run CHAOS Test

This test runs PnP tests (disable/enable, rebalance, remove/restart, surprise remove, and DIF remove) and Driver Fuzz tests on the test device in parallel, while cycling the test system in and out of all of its supported sleep states (S1, S2, S3, S4 and Connected Standby) at the same time. The goal of this test is to test PNP, I/O, and Power concurrency scenarios and find any crashes and/or hangs in the process.

Test binary: Devfund_ChaosTest.dll Test method: RunCHAOSTest
Disable Enhanced Device Testing (EDT) Support

This test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category.

The PnP driver test uses EDT filter driver to send IRP_MN_CANCEL_REMOVE_DEVICE to target device stacks.

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 75
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
TestPeriod | Number of minutes to run the test for.
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Concurrent Hardware And Operating System (CHAOS) Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff5f2837-310a-4448-8f79-580c83faa96e

The CHAOS (Concurrent Hardware and Operating System) tests run various PnP driver tests, device driver fuzz tests, and power system tests concurrently.

Additional test info

Test Description
Run CHAOS Test

This test runs PnP tests (disable/enable, rebalance, remove/restart, surprise remove, and DIF remove) and Driver Fuzz tests on the test device in parallel, while cycling the test system in and out of all of its supported sleep states (S1, S2, S3, S4 and Connected Standby) at the same time. The goal of this test is to test PNP, I/O, and Power concurrency scenarios and find any crashes and/or hangs in the process.

Test binary: Devfund_ChaosTest.dll Test method: RunCHAOSTest
Disable Enhanced Device Testing (EDT) Support

This test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category.

The PnP driver test uses EDT filter driver to send IRP_MN_CANCEL_REMOVE_DEVICE to target device stacks.

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Scenario
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
TestPeriod | Number of minutes to run the test for.
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Embedded Signature Verification Test (Tuning and Validation)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1fd837c2-db8b-4e8c-a189-0ee8daff7173

This test validates that the boot start driver under test is embedded and signed.

Test details
Specifications
  • Device.DevFund.Reliability.BootDriverEmbeddedSignature
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

If you see an error similar to "<driver name> is not a signed driver", you can use signtool.exe to get more information about the digital signature to better troubleshoot the issue. For example, you could run the following command to find out more about pci.sys: signtool.exe verify /pa /v c:\Windows\system32\drivers\pci.sys.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

File list

File | Location
EmbeddedSignature.exe | <testbinroot>\EmbeddedSignature.exe
Signtool.exe | <testbinroot>\Signtool.exe

Parameters

Parameter name | Parameter description
QueryDriverName | Driver name


DF - Firmware Package Installation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2967af91-65ee-4bfb-b6ac-2e71637f4102

This test validates a firmware package and installation state on the device meets the specified requirements.

Test details
Specifications
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

File list

File | Location
DevFundFirmwareUpdateTest.dll | <testbinroot>\DevFundFirmwareUpdateTest.dll


DF - Firmware Package Installation Test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bb142846-49b9-4a30-94cc-55bf16953809

This test validates a firmware package and installation state on the system meet specified requirements. - This test is a WoW64 for ARM64 version of test guid 2967af91-65ee-4bfb-b6ac-2e71637f4102.

Test details
Specifications
  • Device.DevFund.Firmware.UpdateDriverPackage
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.


DF - Fuzz Misc API test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb305d04-6e8c-4dfc-9984-9692df82fbd8

This test retrieves the security descriptor and changes the security state of devices.

Fuzz Misc API tests

The Fuzz Misc API tests are tests that determine whether the driver can handle a variety of common calls from kernel mode drivers.

The suite tests the following:

  • Calls to ZwReadFile and ZwWriteFile, specifying valid data buffer pointers, varying lengths (including zero), and varying byte offsets, including zero, -1 and 64-bit bytes offsets.
  • Calls to cancel I/O and flush buffers.
  • A series of directory query calls using common file information classes with valid user data buffer pointers and varying buffer lengths (including zero).
  • Directory query calls similar to those issued by programs running under control of the Virtual DOS Machine (VDM).
  • Calls to retrieve the extended attributes of a file with varying buffer sizes and lengths.
  • Calls to create and close section objects, with varying section page protection and sectional allocation attributes (committed section, image file section).
  • Calls to lock and unlock files.
  • Calls to retrieve quota entries for a volume.

  • File Attributes Test, a series of file attribute queries with valid pointers to an ObjectAttributes structure.

    The File Attributes Test has an optional zero-length test. While retrieving the extended attributes of a file, the Fuzz test passes a blank (zero-length) query and an invalid buffer address to the driver.

Test binary: Devfund_FuzzTest.dll Test method: DoMiscAPITest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz misc API with zero length query test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/576e3dd6-c902-4fca-92f0-ae641057bd2b

This test passes a blank, zero-length query and an invalid buffer address to the driver while trying to retrieve the extended attributes of a file.

For information included in the Windows Driver Kit on this test, see Penetration Tests (Device Fundamentals) (Windows Drivers).

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz open and close test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1617d804-06d2-40fc-a1bb-587fabc9de77

This test performs thousands of create-open-close sequences and employs several different ways of opening and closing instances of the specified device or devices: Basic Open Operations, Direct Device Open Operations, and an Open and Close stress test.

Basic Open Operations

During the Basic Open Operations, the Fuzz test repeatedly opens (creates) instances of the specified devices or the devices exported by the specified driver by using different methods and options.

The Fuzz test always performs the Basic Open Operations. You do not need to select them and you cannot exclude them from a test session.

The Fuzz test performs all open operations in user mode by calling system services (ZwXxx Routines) that are appropriate to the device. If an open call returns a handle to the device, the Fuzz test uses the handle to perform the other device tests selected for the test session.

There are five types of Basic Open Operations:

  • Standard open: the Fuzz test opens the device asynchronously and specifies only the native device name.

  • Open with added backslash: the Fuzz test issues an open call for the device name followed by a backslash (), such as \device\cdrom\, as though the call were to open a root directory within the device.

    This operation determines how the driver or file system manages open requests in its namespace. In particular, if the device does not support open requests in its namespace, the driver must prevent unauthorized access, either by failing the requests, or by setting the FILE_DEVICE_SECURE_OPEN device characteristic when it calls IoCreateDevice or IoCreateDeviceSecure to create the device object.

  • Open as a named pipe: the Fuzz test opens the device and establishes a named pipe to the device. The access parameter (ShareAccess) is initially set to read and write, but is adjusted if the request fails. If the device does not support named pipes, it should fail the request.

  • Open as a mailslot: the Fuzz test opens the device as a mailslot. If the device does not support this type of connection, it should fail the request.
  • Open as a tree connection: the Fuzz test opens the device as a tree connection for use in remote network access. The access parameter (ShareAccess) is initially set to read and write, but is adjusted if the request fails. If the device does not support this type of connection, it should fail the request.

The parameters used in the open calls vary to accommodate the characteristics of the device and make it likely that the calls succeed. For example, if a basic open operation fails because the call did not meet the security requirements of the device, the Fuzz test repeats the open operation with a request for lesser access. For example, if an open operation that requested write access returns a security violation error, the open is repeated with a request for read access.

Direct Device Open Operations

During the Direct Device Open Operations, the Fuzz test opens the device directly, as a device, not as a file in a file system. Direct Device Open Operations are always synchronous. If the call is successful, the Fuzz test uses the handle provided to perform other selected tests.

Open and Close Test

During the Open and Close Test, the Fuzz test creates several threads, each of which performs thousands of create-open-close sequences. This tests the driver's ability to handle an extraordinary volume of otherwise simple and anticipated calls.

The Open and Close Test uses the same options used in Basic Open Operation and Open with Added Backslash tests and are performed just prior to these tests.

Test binary: Devfund_FuzzTest.dll Test method: DoOpenCloseTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz Query and Set File Information Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00b8f3bb-e5cb-4b77-9e5a-63d4b3ed7566

During the Query and Set File Information Test, the Fuzz test issue calls to retrieve and change the object, file, and volume information of devices opened by the Basic Open Operations and other open operations, including the operations performed by the Fuzz Sub-opens test.

The Fuzz test issues each query or set call at least 1024 times with a valid buffer and a variety of buffer lengths and file information classes. One request of each type is also sent with an invalid buffer pointer and a zero buffer length.

If you use the ChangeBufferProtectionFlags parameter, which sets the protection option, the Fuzz test varies the security setting on the buffer in each query and set call.

This test also performs the Fuzz Sub-opens test.

This test uses the ZwQueryInformationFile, ZwSetInformationFile, ZwQueryVolumeInformationFile, and ZwSetVolumeInformationFile functions.

Test binary: Devfund_FuzzTest.dll Test method: DoQueryAndSetFileInformationTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz Query and Set Security Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aaaa799f-06ca-4da2-bc7e-597283f6891f

During the Query and Set Security Test, the Fuzz test issues calls to retrieve the security descriptor and change the security state of devices opened by the Basic Open Operations and other open operations, including the operations performed by the Fuzz Sub-opens test.

The Fuzz test issues each query or set call at least 1024 times with a valid buffer and a variety of buffer lengths and security information types (OWNER_SECURITY_INFORMATION, GROUP_SECURITY_INFORMATION, DACL_SECURITY_INFORMATION, SACL_SECURITY_INFORMATION, and no information type). One request of each type is also sent with an invalid buffer pointer and a zero buffer length.

If you use the ChangeBufferProtectionFlags parameter, which sets the protection option, the Fuzz test varies the security setting on the buffer in each query and set call.

Test binary: Devfund_FuzzTest.dll Test method: DoQueryAndSetSecurityTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz random FSCTL test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e529e34e-076a-4978-926f-7eca333e8f4d

During random tests, the Fuzz test issues a series of calls to the DeviceIoControl function with function codes, device types, data transfer methods, and access requirements that are selected at random from a specified range of values. The calls include input and output buffers with valid and invalid buffer pointers and lengths, and randomly generated content.

The Fuzz test performs the random tests on all devices opened during the Basic Open Test and additional open tests. You can customize this test by using the following parameters:

  • Use MinFunctionCode and MaxFunctionCode to specify the range of IOCTL or FSCTL function codes used in the calls
  • Use MinDeviceType and MaxDeviceType to specify the range of device types used in the calls
  • Use SeedNumber to specify a seed number for the random number generating routine.

The function that the Fuzz test uses to generate random numbers for the test uses a seed number, a starting number for the random-number-generating algorithm. To reproduce the test conditions, use the seed number parameter to specify the seed number that was used in the original test trial.

A Tailored Random Test is included as part of the random test. The tailored random test uses the results of the random test to examine the drivers response to FSCTL requests in more detail. The tailored random test probes areas that the random test missed and those on which the driver did not respond as expected based on the status returned by the random test calls.

Test binary: Devfund_FuzzTest.dll Test methods: DoRandomFSCTLTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
MinDeviceType | Specifies the minimum value of the DeviceType field in the IOCTLs. The minimum possible value is 0. Use -1 for automatic type detection (preferred).
MaxDeviceType | Specifies the maximum value of the DeviceType field in the IOCTLs. The maximum possible value is 65535. Use -1 for automatic type detection (preferred).
MinFunctionCode | Specifies the minimum value of the FunctionCode field in the FSCTLs. The minimum possible value is 0.
MaxFunctionCode | Specifies the maximum value of the FunctionCode field in the FSCTLs. The maximum possible value is 4095.
MinInBuffer | Specifies the minimum size, in bytes, of the input buffers that the test passes to the driver in FSCTLs.
MaxInBuffer | Specifies the maximum size, in bytes, of the input buffers that the test passes to the driver in FSCTLs.
MinOutBuffer | Specifies the minimum size, in bytes, of the output buffers that the test passes to the driver in FSCTLs.
MaxOutBuffer | Specifies the maximum size, in bytes, of the output buffers that the test passes to the driver in FSCTLs.
MaxRandomCalls | Specifies the maximum number of calls that the test issues.
MaxTailoredCalls | Specifies the maximum number of calls that the test issues during the tailored random test.
SeedNumber | Specified the seed number used in generating random FSCTLs.


DF - Fuzz random IOCTL test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/236b8ad5-0ba1-4075-80a6-ae9dafb71c94

During random tests, the Fuzz test issues a series of calls to the DeviceIoControl function with function codes, device types, data transfer methods, and access requirements that are selected at random from a specified range of values. The calls include input and output buffers with valid and invalid buffer pointers and lengths, and randomly generated content.

The Fuzz test performs the random tests on all devices opened during the Basic Open Test and additional open tests. You can customize this test by using the following parameters:

  • Use MinFunctionCode and MaxFunctionCode to specify the range of IOCTL or FSCTL function codes used in the calls
  • Use MinDeviceType and MaxDeviceType to specify the range of device types used in the calls
  • Use SeedNumber to specify a seed number for the random number generating routine.

The function that the Fuzz test uses to generate random numbers for the test uses a seed number, a starting number for the random-number-generating algorithm. To reproduce the test conditions, use the seed number parameter to specify the seed number that was used in the original test trial.

A Tailored Random Test is included as part of the random test. The tailored random test uses the results of the random test to examine the drivers response to FSCTL requests in more detail. The tailored random test probes areas that the random test missed and those on which the driver did not respond as expected based on the status returned by the random test calls.

Test binary: Devfund_FuzzTest.dll Test methods: DoRandomFSCTLTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
MinDeviceType | Specifies the minimum value of the DeviceType field in the IOCTLs. The minimum possible value is 0. Use -1 for automatic type detection (preferred).
MaxDeviceType | Specifies the maximum value of the DeviceType field in the IOCTLs. The maximum possible value is 65535. Use -1 for automatic type detection (preferred).
MinFunctionCode | Specifies the minimum value of the FunctionCode field in the IOCTLs. The minimum possible value is 0.
MaxFunctionCode | Specifies the maximum value of the FunctionCode field in the IOCTLs. The maximum possible value is 4095.
MinInBuffer | Specifies the minimum size, in bytes, of the input buffers that the test passes to the driver in IOCTLs.
MaxInBuffer | Specifies the maximum size, in bytes, of the input buffers that the test passes to the driver in IOCTLs.
MinOutBuffer | Specifies the minimum size, in bytes, of the output buffers that the test passes to the driver in IOCTLs.
MaxOutBuffer | Specifies the maximum size, in bytes, of the output buffers that the test passes to the driver in IOCTLs.
MaxRandomCalls | Specifies the maximum number of calls that the test issues.
MaxTailoredCalls | Specifies the maximum number of calls that the test issues during the tailored random test.
SeedNumber | Specified the seed number used in generating random IOCTLs.


DF - Fuzz sub-opens test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92bf534e-aa48-4aeb-b3cd-e46fb7cc7d80

During a Relative Open Test, (also known as a Sub-open Test) the Fuzz test attempts to open objects in the device's namespace.

During this test, the Fuzz test performs a rapid series of calls to open objects in the namespace of the devices opened by using Basic Open Operations and other open operations. In these calls, the Fuzz test passes a path that begins with the device and includes arbitrary names and nonsense strings of varying length and content.

This test determines how the driver or file system manages open requests in its namespace. In particular, if the driver does not support open requests in its namespace, it must prevent unauthorized access, either by failing the requests, or by setting the FILE_DEVICE_SECURE_OPEN device characteristic when it uses IoCreateDevice or IoCreateDeviceSecure to create the device object.

For more information about the namespace of a device, see Controlling Device Namespace Access.

Test binary: Devfund_FuzzTest.dll Test method: DoSubOpensTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz sub-opens with streams test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7b43caa-9289-40dd-8ed2-bfce9eabe356

During the Streams Test, the Fuzz test tries to open a variety of named data streams on the device. The tests use a series of arbitrary stream names with content and characters that might be valid for other uses on some devices. This test determines whether the driver can properly handle data stream requests, especially if the driver exports a device that does not support or anticipate data streams.

A named data stream is an attribute of a file object. You specify a named data stream by writing the name of the file, a colon, and the name of the data stream, for example, "File01.txt:AccessDate" where AccessDate is a named data stream, that is, an attribute of the File01.txt file.

The Fuzz test records the stream names used in the test.

  • Test binary: Devfund_FuzzTest.dll
  • Test method: DoSubOpensWithStreamsTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Fuzz zero length buffer FSCTL test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f5f6c7e-d5db-4ff1-8cee-da47203ab070

During the Zero-Length Buffer Test, the Fuzz test issues a series of calls to the DeviceIoControl function with input and/or output buffer lengths of 0. The test generates varying I/O control codes by using different function codes, device types, data transfer methods, and access requirements. For information about the contents of I/O control codes, see Defining I/O Control Codes.

To test the driver's handling of invalid buffer pointers, the buffer pointers in these user-mode calls specify addresses high in kernel virtual address space, such as 0xFFFFFC00).

The Fuzz test performs the Zero-Length Buffer test on all devices opened during the basic and additional open tests. You can customize this test by using the MinFunctionCode and MaxFunctionCode command parameters to specify the range of FSCTL function codes used in the calls and MinDeviceType and MaxDeviceType to specify the range of device types used in the calls.

  • Test binary: Devfund_FuzzTest.dll
  • Test methods: DoZeroLengthBufferFSCTLTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
MinDeviceType | Specifies the minimum value of the DeviceType field in the IOCTLs. The minimum possible value is 0. Use -1 for automatic type detection (preferred).
MaxDeviceType | Specifies the maximum value of the DeviceType field in the IOCTLs. The maximum possible value is 65535. Use -1 for automatic type detection (preferred).
MinFunctionCode | Specifies the minimum value of the FunctionCode field in the FSCTLs. The minimum possible value is 0.
MaxFunctionCode | Specifies the maximum value of the FunctionCode field in the FSCTLs. The maximum possible value is 4095.


DF - Fuzz zero length buffer IOCTL test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c78c5917-f2f9-417d-81e4-ec9c650fb440

During the Zero-Length Buffer Test, the Fuzz test issues a series of calls to the DeviceIoControl function with input and/or output buffer lengths of 0. The test generates varying I/O control codes by using different function codes, device types, data transfer methods, and access requirements. For information about the contents of I/O control codes, see Defining I/O Control Codes.

To test the driver's handling of invalid buffer pointers, the buffer pointers in these user-mode calls specify addresses high in kernel virtual address space, such as 0xFFFFFC00).

The Fuzz test performs the Zero-Length Buffer test on all devices opened during the basic and additional open tests. You can customize this test by using the MinFunctionCode and MaxFunctionCode command parameters to specify the range of IOCTL function codes used in the calls and MinDeviceType and MaxDeviceType to specify the range of device types used in the calls.

  • Test binary: Devfund_FuzzTest.dll
  • Test method: DoZeroLengthBufferIOCTLTest

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.BasicSecurity
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ChangeBufferProtectionFlags | True or False. Changes the memory protection flags of buffers passed to the tested device. The memory protection flags alternates between no access, read-only, and read-only with page guard.
Impersonate | True or False. Runs the test as a non administrative user.
FillZeroPageWithNull | True or False. Maps the zero page and fills it with NULL values. This test identifies drivers that do not verify a pointer reference before dereferencing a pointer.
DoPoolCheck | True or False. Monitors the driver's use of the paged and nonpaged system memory pools by using pool tags and lookaside lists. This option also monitors changes in the number of exceptions handled which might indicate errors in exception handling.
DoSync | True or False. Also opens device handles in SYNC mode (FILE_SYNCHRONOUS_IO_ALERT). Random read and write operations are skipped.
TestCycles | Number of test cycles.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of device under test
QueryHardwareID | Hardware id of device under test
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
MinDeviceType | Specifies the minimum value of the DeviceType field in the IOCTLs. The minimum possible value is 0. Use -1 for automatic type detection (preferred).
MaxDeviceType | Specifies the maximum value of the DeviceType field in the IOCTLs. The maximum possible value is 65535. Use -1 for automatic type detection (preferred).
MinFunctionCode | Specifies the minimum value of the FunctionCode field in the IOCTLs. The minimum possible value is 0.
MaxFunctionCode | Specifies the maximum value of the FunctionCode field in the IOCTLs. The maximum possible value is 4095.


DF - PCI Root Port Surprise Remove Test (PCI devices only) (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0b3428a-0f13-48bd-ab3a-130f21a0aeb2

This automated test surprise removes the test device's PCI root port. This test does the following if the test device is a descendant of the PCI bus. Otherwise, it automatically passes.

  1. Determines the PCI root port device for the test device. The PCI root port of the test device is:

    1. The device that is the immediate child of the PCI bus.

    2. The device that is also the ancestor of the test device.

  2. It surprise removes and restarts this PCI root port device 100 times or for one hour in a continuous loop.

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK.

More information

Parameters

Parameter name | Parameter description
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DQ | A WDTF SDEL query that is used to identify the target device(s)
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - PNP (disable and enable) with IO Before and After (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4819558-0d42-40c3-9585-cf6b7b71bac7

This test does the following:

  1. Verifies that there are no devices on the system reporting device problem codes.
  2. Tests I/O on every device on the system using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  3. Disables and enables every device on the system using WDTF PnP action interfaces, see IWDTFPNPAction2::DisableDevice and IWDTFPNPAction2::EnableDevice methods for more information.
  4. Verifies that there are no devices on the system reporting device problem codes.
  5. Tests I/O on every device on the system using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  6. Repeats steps 3-5 several times.
  • Test binary: Devfund_PNP_DisableEnable_With_IO_BeforeAndAfter.dll
  • Test method: PNP_DisableEnable_With_IO_Before_And_After

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
WDKDeviceID | Device id of DUT
QueryHardwareID | Hardware id of device under test


DF - PNP Cancel Remove Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53c9e4a3-147a-4590-be9a-de6104f8d84b

This test attempts to install its upper-filter driver on the target device stack. This attempt results in a query-remove IRP.

If this query-remove IRP fails, the test restarts the computer to get the filter driver onto the device stack. If the remove request is not vetoed, the device stack will be removed and restarted with the filter driver on the device stack.

The test, by using setup APIs, causes a query-remove IRP to be sent to the device stack. The filter driver fails this remove request, so a cancel-remove IRP is sent. The filter driver will assert that the cancel-remove was successful.

Next, the test application calls the appropriate class installer and any registered co-installers to disable or enable and remove or reenumerate the device (this tests the class and co-installers handling of DIF_PROPERTYCHANGE with DICS_DISABLE, DICS_ENABLE, and DICS_PROPCHANGE). When receiving IRP_MN_REMOVE_DEVICE, the filter driver will assert that the lower drivers completed it successfully.

Each of these steps involves a preliminary remove request. If that request is vetoed, the device will not be removed. You can choose to veto a remove request when appropriate, such as while streaming video on a USB camera or if the target device is in the boot or paging path. Remember that simply failing all remove requests is generally not good practice. Failing all remove requests will not guarantee that driver will never receive a remove because a remove IRP will still be issued after a surprise removal, or if anyone in the device stack fails a start IRP.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPCancelRemoveDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Cancel Remove Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b6a633f-6042-44db-888f-8fcc6381fb98

The test attempts to install its upper-filter driver on the target device stack. This attempt results in a query-remove IRP.

If this query-remove IRP fails, the test restarts the computer to get the filter driver onto the device stack. If the remove request is not vetoed, the device stack will be removed and restarted with the filter driver on the device stack.

The test, by using setup APIs, causes a query-remove IRP to be sent to the device stack. The filter driver fails this remove request, so a cancel-remove IRP is sent. The filter driver will assert that the cancel-remove was successful.

Next, the test application calls the appropriate class installer and any registered co-installers to disable or enable and remove or reenumerate the device (this tests the class and co-installers handling of DIF_PROPERTYCHANGE with DICS_DISABLE, DICS_ENABLE, and DICS_PROPCHANGE). When receiving IRP_MN_REMOVE_DEVICE, the filter driver will assert that the lower drivers completed it successfully.

Each of these steps involves a preliminary remove request. If that request is vetoed, the device will not be removed. You can choose to veto a remove request when appropriate, such as while streaming video on a USB camera or if the target device is in the boot or paging path. Remember that simply failing all remove requests is generally not good practice. Failing all remove requests will not guarantee that driver will never receive a remove because a remove IRP will still be issued after a surprise removal, or if anyone in the device stack fails a start IRP.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPCancelRemoveDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Cancel Stop Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a63d28ed-a884-4068-87d7-113914864227

As with the removal test, the test application attempts to add an upper filter to the target device stack and then restart the device stack by using SetupDiCallClassInstaller with DIF_PROPERTYCHANGE. If this attempt is not successful (that is, if someone on the target device stack failed the query-remove IRP), the test restarts the computer to test rebalance.

This test initiates a rebalance procedure, but the filter driver deliberately fails the query stop IRP. The order of IRPs looks like IRP_MN_QUERY_STOP_DEVICE (which is failed by the filter driver while coming up, causing a cancellation of rebalance) and IRP_MN_CANCEL_STOP_DEVICE. The resources of the device do not change.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPCancelStopDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Cancel Stop Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/af6dc68b-da92-41aa-a538-fe2f73c2cb71

As with the removal test, the test application attempts to add an upper filter to the target device stack and then restart the device stack by using SetupDiCallClassInstaller with DIF_PROPERTYCHANGE. If this attempt is not successful (that is, if someone on the target device stack failed the query-remove IRP), the test restarts the computer to test rebalance.

This test initiates a rebalance procedure, but the filter driver deliberately fails the query stop IRP. The order of IRPs looks like IRP_MN_QUERY_STOP_DEVICE (which is failed by the filter driver while coming up, causing a cancellation of rebalance) and IRP_MN_CANCEL_STOP_DEVICE. The resources of the device do not change.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPCancelStopDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP DIF Remove Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/779dee1a-dfe5-4343-ab48-ac6bfb51d45b

This test uses the SetupDi API to send a DIF_REMOVE request for the installers to remove the device.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPDIFRemoveAndRescanParentDevice

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP DIF Remove Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/731f7bde-e2da-4aab-8e35-3715fa405da7

This test uses the SetupDi API to send a DIF_REMOVE request for the installers to remove the device.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPDIFRemoveAndRescanParentDevice

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Disable And Enable Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38725ea8-0ab2-4ae4-9ffc-e5109099723c

This test disables and enables the target devices.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPDisableAndEnableDevice

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Disable And Enable Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9d4e2811-1007-445b-b2bd-a2e0ac8468d2

This test disables and enables the target devices.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPDisableAndEnableDevice

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Rebalance Fail Restart Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/834db660-798b-4ce6-a3a4-2989bb82f76c

As with the removal test, the test application attempts to add an upper filter to the target device stack and then restart the device stack by using SetupDiCallClassInstaller with DIF_PROPERTYCHANGE. If this attempt is not successful (that is, if someone on the target device stack failed the query-remove IRP), the test restarts the computer to test rebalance.

This test initiates a rebalance but when the filter driver gets the start after the rebalance, it deliberately fails it-which causes the surprise removal IRP followed by Removal IRP.

First, it starts the rebalance procedure and makes sure that the driver gets a stop and a start by generating fake resource requirement for a device which does not consume any resources.

  • IRP_MN_QUERY_STOP_DEVICE (assuming this IRP is passed by all the drivers. The test already covered the case where this IRP is failed.)
  • IRP_MN_QUERY_RESOURCE_REQUIREMENTS
  • IRP_MN_FILTER_RESOURCE_REQUIREMENTS (If the actual resource requirement are null, filter assign fake resource requirement, so there is a stop and a start.)
  • IRP_MN_STOP_DEVICE
  • IRP_MN_START_DEVICE (The filter fails this IRP while going up. This action causes the surprise remove IRP.)
  • IRP_MN_SURPRISE_REMOVAL
  • IRP_MN_REMOVE

After the rebalance test is complete, the device will be uninstalled and reenumerated, also removing the filter driver from the stack.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPTryStopDeviceAndFailRestart

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Rebalance Fail Restart Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5b9e51a-b1fc-4336-b12c-17215c20956d

As with the removal test, the test application attempts to add an upper filter to the target device stack and then restart the device stack by using SetupDiCallClassInstaller with DIF_PROPERTYCHANGE. If this attempt is not successful (that is, if someone on the target device stack failed the query-remove IRP), the test restarts the computer to test rebalance.

This test initiates a rebalance but when the filter driver gets the start after the rebalance, it deliberately fails it-which causes the surprise removal IRP followed by Removal IRP.

First, it starts the rebalance procedure and makes sure that the driver gets a stop and a start by generating fake resource requirement for a device which does not consume any resources.

  • IRP_MN_QUERY_STOP_DEVICE (assuming this IRP is passed by all the drivers. The test already covered the case where this IRP is failed.)
  • IRP_MN_QUERY_RESOURCE_REQUIREMENTS
  • IRP_MN_FILTER_RESOURCE_REQUIREMENTS (If the actual resource requirement are null, filter assign fake resource requirement, so there is a stop and a start.)
  • IRP_MN_STOP_DEVICE
  • IRP_MN_START_DEVICE (The filter fails this IRP while going up. This action causes the surprise remove IRP.)
  • IRP_MN_SURPRISE_REMOVAL
  • IRP_MN_REMOVE

After the rebalance test is complete, the device will be uninstalled and reenumerated, also removing the filter driver from the stack.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPTryStopDeviceAndFailRestart

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Rebalance Request New Resources Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ef36f194-1fd7-41f5-ae1b-1db5c47bb51f

As with the removal test, the test application attempts to add an upper filter to the target device stack and then restart the device stack by using SetupDiCallClassInstaller with DIF_PROPERTYCHANGE. If this attempt is not successful (that is, if someone on the target device stack failed the query-remove IRP), the test restarts the computer to test rebalance.

This test initiates a rebalance and also manipulates the resource requirement of the device to maximize the chances that actually new resources are allocated to the device. This option also helps a device with no resources to actually go through the complete rebalance procedure:

  1. First the simple rebalance is started, causing the following IRPs:

    • IRP_MN_QUERY_STOP_DEVICE (assuming this IRP is passed by all the drivers. The test already covered the case where this IRP is failed.)
    • IRP_MN_QUERY_RESOURCE_REQUIREMENTS

    • IRP_MN_FILTER_RESOURCE_REQUIREMENTS. In response to this IRP, while going up, filter driver takes action based on whether the device consumes any resources or not:

      • If the device has no resource requirement, filter assigns a fake resource.
      • If the device has a resource requirement, it tries to restructure the resource requirement list in such a way that maximizes the probability of changing the current assignment. For example, if a device needs 2 bytes of memory anywhere between 00 to FF and currently is assigned 3A-3B, modify such that the new resource requirement (in order of preference) looks like 00-39 or 3C-FF or 3A-3B. Similarly if the device resource requirement list has any alternate requirements, it will change their order so the alternate requirement comes earlier in the list.

  2. Now the device should always complete the rebalance procedure.

    IRP_MN_STOP_DEVICE

    IRP_MN_START_DEVICE (The new allocated resources. If fake requirements were created, mask the new resources from the actual drivers.)

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPTryStopDeviceRequestNewResourcesAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Rebalance Request New Resources Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c71001f9-0751-428a-9c21-eb2a77baf0ff

As with the removal test, the test application attempts to add an upper filter to the target device stack and then restart the device stack by using SetupDiCallClassInstaller with DIF_PROPERTYCHANGE. If this attempt is not successful (that is, if someone on the target device stack failed the query-remove IRP), the test restarts the computer to test rebalance.

This test initiates a rebalance and also manipulates the resource requirement of the device to maximize the chances that actually new resources are allocated to the device. This option also helps a device with no resources to actually go through the complete rebalance procedure:

  1. First the simple rebalance is started, causing the following IRPs:

    • IRP_MN_QUERY_STOP_DEVICE (assuming this IRP is passed by all the drivers. The test already covered the case where this IRP is failed.)
    • IRP_MN_QUERY_RESOURCE_REQUIREMENTS

    • IRP_MN_FILTER_RESOURCE_REQUIREMENTS. In response to this IRP, while going up, filter driver takes action based on whether the device consumes any resources or not:

      • If the device has no resource requirement, filter assigns a fake resource.
      • If the device has a resource requirement, it tries to restructure the resource requirement list in such a way that maximizes the probability of changing the current assignment. For example, if a device needs 2 bytes of memory anywhere between 00 to FF and currently is assigned 3A-3B, modify such that the new resource requirement (in order of preference) looks like 00-39 or 3C-FF or 3A-3B. Similarly if the device resource requirement list has any alternate requirements, it will change their order so the alternate requirement comes earlier in the list.

  2. Now the device should always complete the rebalance procedure.

    IRP_MN_STOP_DEVICE

    IRP_MN_START_DEVICE (The new allocated resources. If fake requirements were created, mask the new resources from the actual drivers.)

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPTryStopDeviceRequestNewResourcesAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Remove Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87587c6e-8862-4d6e-875b-9a9976ecf30a

This test uses the EDT filter driver to send causes IRP_MN_QUERY_REMOVE_DEVICE and IRP_MN_REMOVE_DEVICE to be sent to target device stacks.

The test attempts to install its upper-filter driver on the target device stack. This attempt results in a query-remove IRP.

If this query-remove IRP fails, the test restarts the computer to get the filter driver onto the device stack. If the remove request is not vetoed, the device stack will be removed and restarted with the filter driver on the device stack.

The test, by using setup APIs, causes a query-remove IRP to be sent to the device stack. The filter driver fails this remove request, so a cancel-remove IRP is sent. The filter driver will assert that the cancel-remove was successful.

Next, the test application calls the appropriate class installer and any registered co-installers to disable or enable and remove or reenumerate the device (this tests the class and co-installers handling of DIF_PROPERTYCHANGE with DICS_DISABLE, DICS_ENABLE, and DICS_PROPCHANGE). When receiving IRP_MN_REMOVE_DEVICE, the filter driver will assert that the lower drivers completed it successfully.

Each of these steps involves a preliminary remove request. If that request is vetoed, the device will not be removed. You can choose to veto a remove request when appropriate, such as while streaming video on a USB camera or if the target device is in the boot or paging path. Remember that simply failing all remove requests is generally not good practice. Failing all remove requests will not guarantee that driver will never receive a remove because a remove IRP will still be issued after a surprise removal, or if anyone in the device stack fails a start IRP.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPRemoveAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Remove Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ead2222e-4485-4bfc-84cd-43ac0d2e8181

This test uses the EDT filter driver to send causes IRP_MN_QUERY_REMOVE_DEVICE and IRP_MN_REMOVE_DEVICE to be sent to target device stacks.

The test attempts to install its upper-filter driver on the target device stack. This attempt results in a query-remove IRP.

If this query-remove IRP fails, the test restarts the computer to get the filter driver onto the device stack. If the remove request is not vetoed, the device stack will be removed and restarted with the filter driver on the device stack.

The test, by using setup APIs, causes a query-remove IRP to be sent to the device stack. The filter driver fails this remove request, so a cancel-remove IRP is sent. The filter driver will assert that the cancel-remove was successful.

Next, the test application calls the appropriate class installer and any registered co-installers to disable or enable and remove or reenumerate the device (this tests the class and co-installers handling of DIF_PROPERTYCHANGE with DICS_DISABLE, DICS_ENABLE, and DICS_PROPCHANGE). When receiving IRP_MN_REMOVE_DEVICE, the filter driver will assert that the lower drivers completed it successfully.

Each of these steps involves a preliminary remove request. If that request is vetoed, the device will not be removed. You can choose to veto a remove request when appropriate, such as while streaming video on a USB camera or if the target device is in the boot or paging path. Remember that simply failing all remove requests is generally not good practice. Failing all remove requests will not guarantee that driver will never receive a remove because a remove IRP will still be issued after a surprise removal, or if anyone in the device stack fails a start IRP.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPRemoveAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Stop (Rebalance) Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ade2585d-46b1-45eb-b224-d22245083b01

This test initiates a rebalance procedure which results in the IRP_MN_QUERY_STOP_DEVICE PnP IRP to the device driver.

If any driver in the stack fails this IRP the rebalance procedure is abandoned. Please note that in Windows Vista, there is support for multi-level rebalance. If a rebalance is started on a non-leaf device node, all of the device stacks that are present in the device tree with that device node as the root also go through rebalance. And if any of the child device stacks fails query stop, the whole rebalance procedure is abandoned. So drivers must not fail query stop without a genuine reason to do so. If this failure happens, the PnP manager sends cancel stop (IRP_MN_CANCEL_STOP) to all the device stacks that had been sent query stop.

If all of the device stacks involved pass query stop, the test continues with the rebalance and sends the IRP_MN_QUERY_RESOURCE_REQUIREMENTS and IRP_MN_FILTER_RESOURCE_REQUIREMENTS IRPS to find the resource requirement of the devices.

After this point, two different paths are possible depending on whether the target device consumes any resources or not:

  • If the device does not consume any resources, the PnP manager itself sends a cancel stop (IRP_MN_CANCEL_STOP_DEVICE) as an optimization.

    If the device actually consumes resources, the rebalance procedure is completed with the IRP_MN_STOP_DEVICE and IRP_MN_START_DEVICE IRPs.

With this test, the resources of the device do not change.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPTryStopAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Stop (Rebalance) Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/46726c00-8d98-4c98-8038-b15944e44c41

This test initiates a rebalance procedure which results in the IRP_MN_QUERY_STOP_DEVICE PnP IRP to the device driver.

If any driver in the stack fails this IRP the rebalance procedure is abandoned. Please note that in Windows Vista, there is support for multi-level rebalance. If a rebalance is started on a non-leaf device node, all of the device stacks that are present in the device tree with that device node as the root also go through rebalance. And if any of the child device stacks fails query stop, the whole rebalance procedure is abandoned. So drivers must not fail query stop without a genuine reason to do so. If this failure happens, the PnP manager sends cancel stop (IRP_MN_CANCEL_STOP) to all the device stacks that had been sent query stop.

If all of the device stacks involved pass query stop, the test continues with the rebalance and sends the IRP_MN_QUERY_RESOURCE_REQUIREMENTS and IRP_MN_FILTER_RESOURCE_REQUIREMENTS IRPS to find the resource requirement of the devices.

After this point, two different paths are possible depending on whether the target device consumes any resources or not:

  • If the device does not consume any resources, the PnP manager itself sends a cancel stop (IRP_MN_CANCEL_STOP_DEVICE) as an optimization.

    If the device actually consumes resources, the rebalance procedure is completed with the IRP_MN_STOP_DEVICE and IRP_MN_START_DEVICE IRPs.

With this test, the resources of the device do not change.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPTryStopAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Surprise Remove Device Test (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ee33f51-99b6-4462-888c-a838d6cd3aba

The Surprise Removal test encompasses IRP_MN_SURPRISE_REMOVAL followed by IRP_MN_REMOVE_DEVICE.

As with the previous tests, the test application will attempt to add an upper filter to the target device stack and then restart the stack. If this attempt is not successful, the test restarts the computer.

When triggered by the test application, the filter driver will cause the system to send an IRP_MN_SURPRISE_REMOVAL to the device stack, followed by an IRP_MN_REMOVE_DEVICE. The filter driver will assert that both of these IRPs are completed successfully by lower drivers.

After the surprise removal test is complete, the device will be uninstalled and reenumerated, also removing the filter driver from the stack.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPSurpriseRemoveAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - PNP Surprise Remove Device Test (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/decf00f0-0eae-4768-b06b-85e9c0aaf7da

The Surprise Removal test encompasses IRP_MN_SURPRISE_REMOVAL followed by IRP_MN_REMOVE_DEVICE.

As with the previous tests, the test application will attempt to add an upper filter to the target device stack and then restart the stack. If this attempt is not successful, the test restarts the computer.

When triggered by the test application, the filter driver will cause the system to send an IRP_MN_SURPRISE_REMOVAL to the device stack, followed by an IRP_MN_REMOVE_DEVICE. The filter driver will assert that both of these IRPs are completed successfully by lower drivers.

After the surprise removal test is complete, the device will be uninstalled and reenumerated, also removing the filter driver from the stack.

  • Test binary: Devfund_PnPDTest.dll
  • Test method: PNPSurpriseRemoveAndRestartDevice

The Disable Enhanced Device Testing (EDT) Support test uninstalls the test filter driver (msdmfilt.sys) as an upper filter on devices specified using the DQ parameter. This test filter gets installed as part of running tests in this test category

  • Test binary: Devfund_PnPDTest.dll
  • Test method: DisableEnhancedDeviceTestingSupport

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.PnPIRPs
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Scenario
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or one of its child devices is a wired NIC that doesn't have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the test NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of cycles to run the test for.
DoSimpleIO | True or False. Runs SimpleIO (if found) on test devices before and after performing PNP operations.
IOPeriod | Time period in minutes to run SimpleIO (if found).
DoConcurrentIO | True or False. Uses WDTF concurrent IO interface to send I/O requests to target device stacks while performing PNP operations.


DF - Reboot restart with IO before and after (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99c61fa9-e0eb-43ea-a5fc-db5c3cbd9239

This test runs I/O on devices before and after a system reboot.

  • Test binary: Devfund_RebootRestart_With_IO_BeforeAndAfter.dll
  • Test method: Reboot_Restart_With_IO_Before_And_After

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.Reliability.PnPIDs
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Reboot Restart with IO During (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3a6f308d-f8e2-47fd-9c19-a65b31fd765d

This test starts Simple I/O on devices, initiates a reboot with I/O running, and runs SimpleI/O again after the reboot.

  • Test binary: Devfund_RebootRestart_With_IO_During.dll
  • Test method: Reboot_Restart_With_IO_During

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
TestCycles | Number of test cycles
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Reboot Restart with IO During (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/496343a3-7378-4288-83c5-43a688f4c09d

This test starts Simple I/O on devices, initiates a reboot with I/O running, and runs SimpleI/O again after the reboot.

  • Test binary: Devfund_RebootRestart_With_IO_During.dll
  • Test method: Reboot_Restart_With_IO_During

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.Reliability.PnPIDs
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
TestCycles | Number of test cycles
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Reinstall with IO Before and After (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4b08097-f79a-4e47-be59-ee21a58b29f3

This test uninstalls and reinstalls the drivers for selected devices and runs IO on devices, verifies that no device or driver, except the device under test, has been affected by devices, driver installations, or co-install processes, and verifies that no system resources have been overwritten during a device or driver package installation.

When the test runs the test case that no device or driver, except the device under test, has been affected by devices, driver installations, or co-install processes, it creates two files: preinstallscan.xml and postinstallscan.xml. The preinstallscan.xml file records information about every device before the test starts. After the test completes, it records information about every device in the postinstallscan.xml file. The two files are then examined for differences. You can view the preinstallscan.xml and postinstallscan.xml files by right clicking the Run Test task and then clicking Additional Files on the Results tab in HLK Studio for this test.

This test does the following:

  1. Verifies that the test device and its descendants are not reporting any device problem codes.
  2. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  3. Reinstalls the original driver on the test device using IWDTFDriverSetupAction2::UpdateDriver method.
  4. Verifies that the test device and its descendants are not reporting any device problem codes.
  5. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  6. Reboots the system if step #3 requires a reboot.
  7. Installs NULL driver on the test device using IWDTFDriverSetupAction2::UnInstallDriverPermanently method Reboots the system if a reboot is required.
  8. Reinstalls the original driver on device under test using IWDTFDriverSetupAction2::UpdateDriver method.
  9. Verifies that the test device and its descendants are not reporting any device problem codes.
  10. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  11. Repeats step 1 - 10 several times.
  • Test binary: Devfund_Reinstall_With_IO_BeforeAndAfter.dll
  • Test method: Reinstall_With_IO_Before_And_After

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Devfund.Rollback.Driver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 450
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Reinstall with IO Before and After (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8dd417ab-e523-4bf0-a971-7c27d99ff5b2

This test uninstalls and reinstalls the drivers for selected devices and runs IO on devices, verifies that no device or driver, except the device under test, has been affected by devices, driver installations, or co-install processes, and verifies that no system resources have been overwritten during a device or driver package installation.

When the test runs the test case that no device or driver, except the device under test, has been affected by devices, driver installations, or co-install processes, it creates two files: preinstallscan.xml and postinstallscan.xml. The preinstallscan.xml file records information about every device before the test starts. After the test completes, it records information about every device in the postinstallscan.xml file. The two files are then examined for differences. You can view the preinstallscan.xml and postinstallscan.xml files by right clicking the Run Test task and then clicking Additional Files on the Results tab in HLK Studio for this test.

This test does the following:

  1. Verifies that the test device and its descendants are not reporting any device problem codes.
  2. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  3. Reinstalls the original driver on the test device using IWDTFDriverSetupAction2::UpdateDriver method.
  4. Verifies that the test device and its descendants are not reporting any device problem codes.
  5. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  6. Reboots the system if step #3 requires a reboot.
  7. Installs NULL driver on the test device using IWDTFDriverSetupAction2::UnInstallDriverPermanently method Reboots the system if a reboot is required.
  8. Reinstalls the original driver on device under test using IWDTFDriverSetupAction2::UpdateDriver method.
  9. Verifies that the test device and its descendants are not reporting any device problem codes.
  10. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  11. Repeats step 1 - 10 several times.
  • Test binary: Devfund_Reinstall_With_IO_BeforeAndAfter.dll
  • Test method: Reinstall_With_IO_Before_And_After

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.DriverInstallUninstallReinstall
  • Device.DevFund.Reliability.DriverUninstallInstallOtherDeviceStability
  • Device.DevFund.Reliability.NoReplacingSysComponents
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
  • Devfund.Rollback.Driver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - SimpleIO stress test with IO process termination (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc7e0020-bb7a-483f-b495-7e7fd0a40daa

This test performs simple I/O testing on devices in a separate process and terminates the I/O process after the specified I/O period and test cycles.

  • Test binary: Devfund_SimpleIoStress_TermIoProc.dll
  • Test method: SimpleIOStress_TermIoProc

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Sleep and PNP (disable and enable) with IO Before and After (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82178a94-924b-4ac6-a11b-17bcedc05325

This test does the following:

  1. Verifies that the test device and its descendants are not reporting any device problem codes.
  2. Tests I/O on the test device and its descendants using the WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  3. Sends the test system into its first supported sleep state and resumes the system from sleep after some time.
  4. Verifies that the test device and its descendants are not reporting any device problem codes.
  5. Tests I/O on the test device and its descendants using the WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  6. If the test device is can be disabled, the test disables and enables the test device using WDTF PnP action interfaces, see IWDTFPNPAction2::DisableDevice and IWDTFPNPAction2::EnableDevice methods for more information.
  7. Verifies that the test device and its descendants are not reporting any device problem codes.
  8. Tests I/O on the test device and its descendants using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  9. Repeats step 3-8 for each supported sleep state of the test system.
  10. Repeats step 1-9 several times.
  • Test binary: Devfund_Sleep_PNP_DisableEnable_With_IO_BeforeAndAfter.dll
  • Test method: Sleep_PNP_DisableEnable_With_IO_Before_And_After

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ResumeDelay | Delay time in seconds after each sleep cycle
WDTFREMOTESYSTEM | Required ONLY if there is a wired NIC on the test system AND it does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Sleep and PNP (disable and enable) with IO Before and After (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6bd51c1b-3dad-4a5e-b46d-98c2fe91d1aa

This test cycles the system through various sleep states and performs IO and basic PNP (disable/enable) on devices before and after each sleep state cycle.

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.S3S4SleepStates
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ResumeDelay | Delay time in seconds after each sleep cycle
WDTFREMOTESYSTEM | Required ONLY if there is a wired NIC on the test system AND it does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Sleep with IO Before and After (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93eaf322-1d61-4a65-81a2-7da7129cf3cd

This test does the following:

  1. Verifies that there are no devices on the system reporting device problem codes.
  2. Tests I/O on every device on the system using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  3. Sends the test system into its first supported sleep state and resumes the system from sleep after some time.
  4. Verifies that there are no devices on the system reporting device problem codes.
  5. Tests I/O on every device on the system using WDTF Simple I/O plugins. See Provided WDTF Simple I/O plug-ins for more information.
  6. Repeats steps 3 - 5 for each supported sleep state of the test system.
  7. Repeats steps 1 - 6 several times.
  • Test binary: Devfund_Sleep_With_IO_BeforeAndAfter.dll
  • Test method: Sleep_With_Io_Before_And_After

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
TestCycles | Number of test cycles
IOPeriod | IO period in minutes
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
ResumeDelay | Delay time in seconds after each sleep cycle
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
WDKDeviceID | Hardware id of device under test
QueryHardwareID | Hardware id of device under test


DF - Sleep with IO During (Development and Integration)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3528d72b-fa1c-4ae6-a176-ebd301adaa6f

This test cycles the system through various sleep states and performs I/O on devices.

  • Test binary: Devfund_Sleep_With_IO_During.dll
  • Test method: Sleep_With_IO_During

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
TestCycles | Number of test cycles
ResumeDelay | Delay time in seconds after each sleep cycle
IOPeriod | IO period in minutes
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


DF - Sleep with IO During (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9d87d997-f451-4a3d-852c-90367d4d3864

This test cycles the system through various sleep states and performs I/O on devices.

  • Test binary: Devfund_Sleep_With_IO_During.dll
  • Test method: Sleep_With_IO_During

Test details
Specifications
  • Device.DevFund.Reliability.BasicReliabilityAndPerformance
  • Device.DevFund.Reliability.S3S4SleepStates
  • Device.DevFund.DriverFramework.KMDF.Reliability
  • Device.DevFund.DriverFramework.UMDF.Reliability
  • Device.DevFund.ReliabilityDisk.IOCompletionCancellation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Scenario
Timeout (in minutes) | 150
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information specific to the Device Fundamentals tests in the HLK and WDK, see Device.DevFund additional documentation.

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
TestCycles | Number of test cycles
ResumeDelay | Delay time in seconds after each sleep cycle
IOPeriod | IO period in minutes
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
WDTFREMOTESYSTEM | Required ONLY if DUT or any of its child devices is a wired NIC that does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
DriverVerifierAdditionalDrivers | Additional drivers that should have Driver Verifier enabled
DriverVerifierExcludedFlags | Placeholder for Driver Verifier flags that may be manually excluded for the test run
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings


HyperVisor Code Integrity Readiness Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b972fc52-2468-4462-9799-6a1898808c86

Verifies that drivers are compatible with Windows HyperVisor Code Integrity feature

Test details
Specifications
  • Device.DevFund.DeviceGuard.DriverCompatibility
  • Filter.Driver.DeviceGuard.DriverCompatibility
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • Filter.Driver additional documentation

More information

Parameters

Parameter name | Parameter description
QueryDriverFile1 | Query for the first of the driver files under test
QueryDriverFile2 | Query for the second of the driver files under test
QueryDriverFile3 | Query for the third of the driver files under test
QueryDriverFile4 | Query for the fourth of the driver files under test
QueryDriverFile5 | Query for the fifth of the driver files under test
QueryDriverFile6 | Query for the sixth of the driver files under test
QueryDriverFile7 | Query for the seventh of the driver files under test
QueryDriverFile8 | Query for the eighth of the driver files under test
QueryDriverFile9 | Query for the ninth of the driver files under test
QueryDriverFileOverflow | Query for a tenth driver file (considered to be overflow)
CILogFileName | Name of Driver Verifier log of CI statistics


Operate In Nano Server Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33d6629d-1126-46cc-949b-8f2e6e028cc6

Checks that the machine is running in a Nano Server configuration.

Test details
Specifications
  • Device.DevFund.Server.Nano.OperateInServerNano
  • System.Fundamentals.ServerNano.OperateInServerNano
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.DevFund additional documentation
    • System.Fundamentals additional documentation


Operate In Server Core Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac3eb111-539a-4b7b-93f2-d542bd8a2135

This test validates that the device is running in a Server Core configuration. Server Core is the default installation state of Windows Server which minimizes attack surface, reduces patch frequency, and reduces disk and memory footprint which in turn increases VM density. To pass certification, all device drivers must be supported in Server Core mode, without a dependency on graphical shell binaries. To ensure this requirement is satisfied, the User Interfaces and Infrastructure feature must be "Disabled with Payload Removed."

If you installed the "Full Server" or "Server with a GUI" during Setup, you should reinstall Windows and select the "Server Core Installation" option in Setup to ensure that no traces of Server with a GUI remain on the server running certification. All installation and configuration tests for your driver must be done from within Server Core.

For more information about Server Core configuration, see the following topics:

  • Windows Server Installation Options
  • Configure and Manage Server Core Installations

Test details
Specifications
  • Device.DevFund.Server.OperateInServerCore
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation


Reflash Device Connected via Proxy Client

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf446b11-40b6-46be-a15b-d5c6e7c4811a

This job reflashes devices connected with Proxy Client using Workflow parameters in the scheduler.

Test details
Specifications
  • Device.DevFund.Reliability.Discretional
  • System.Fundamentals.Reliability.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation


Static Tools Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ab6df93-423c-4af6-ad48-8ea1049155ae

This test performs static analysis that is designed to improve reliability of drivers using Static Driver Verifier [SDV] and the Code Analysis tool.

Test details
Specifications
  • Device.DevFund.StaticTools.CAandSDV
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test,, you must create a Driver Verification Log (DVL) by performing the following steps.

  1. Run the Static Driver Verifier and the Code Analysis tool on the driver source code.

  2. Run a utility that generates the DVL file.

  3. Copy the DVL file from the computer that was used to create the DVL file to the test computer that is used when you run the Static Tools Logo Test.

For more information about creating a Driver Verification Log file to include with your submission, see Creating a Driver Verification Log.

NOTE

The Static Tools Logo Test requires only the DVL file to show that Code Analysis and SDV have been run. The test does not require all rules to pass. Additionally, this job must be run on Server with Desktop. If the HLK test fails from using Server Core (with error message: "RoMetadata.dll could not be found"), the workaround is to run on Server with Desktop and then merge the package with the package containing the results from Server Core. Information on how to merge packets can be found here: https://docs.microsoft.com/en-us/windows-hardware/test/hlk/user/merge-packages.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Command syntax

Command option | Description
TE.exe /inproc /enablewttlogging /appendwttlogging Devfund_DvlTest.dll /p:WDKClass=[WDKClass] /p:DeviceClass=[DeviceClass] /p:QueryDriverNames=[QueryDriverNames] | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Devfund_DvlTest.dll | <testbinroot>\OSBinRoot
Microsoft.StaticToolsLogo.ObjectModel.dll | <testbinroot>\OSBinRoot
TE.exe | <testbinroot>\OSBinRoot

Parameters

Parameter name | Parameter description
WDKClass | Device Class
DeviceClass | Device Class parameter
QueryDriverNames | Expected driver names.


TDI filters and LSPs are not allowed

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1597d1fd-055a-43c7-b4c7-5396ab1ad525

This test verifies that no TDI Filters or LSPs are installed by the driver or associated software packages during installation or usage.

Test details
Specifications
  • Device.DevFund.Security.NoTDIFilterAndLSP
  • Filter.Driver.Security.NoTDIFilterAndLSP
  • System.Fundamentals.Security.NoTDIFilterAndLSP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • Filter.Driver additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.


Validate HAL Extension have no Imports

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78b8dab3-8ec9-406d-b395-2a34e922e8e7

This test determines whether the HAL Extension DLL has any Import Table entries. A HAL extension must not be dependent on any other DLL.

Test details
Specifications
  • Device.DevFund.HALExtension.HAL
  • System.Fundamentals.HAL.IfCSRTPresent
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 30
    Category | Development
    Timeout (in minutes) | 60
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.DevFund additional documentation
    • System.Fundamentals additional documentation


Verify HAL Extension serviceable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de119483-e85e-4f19-ba05-202a7219b43f

This test determines whether the HAL Extension DLL is serviceable. For a HAL Extension to be serviceable the PNP ID associated with the HAL Extension must match the PNP ID of a device currently in the system.

Test details
Specifications
  • Device.DevFund.HALExtension.HAL
  • System.Fundamentals.HAL.IfCSRTPresent
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 30
    Category | Development
    Timeout (in minutes) | 60
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.DevFund additional documentation
    • System.Fundamentals additional documentation


Wdf - Check Kmdf Function Table Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/335ba211-38cd-4810-a76b-38fcdafee397

This test verifies if the kernel mode driver framework (KMDF) driver is built with the correct version of the Windows Driver Kit with the public KMDF headers.

Test details
Specifications
  • Device.DevFund.DriverFramework.KMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Device.Fundamentals Reliability Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK.

More information

File list

File | Location
checkwdffunctiontable.dll | <testbinroot>\wdftest\bin\checkwdffunctiontable.dll

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT


Wdf - Check Umdf Function Table Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca903d6c-1674-4234-8c69-22ccd13cfa15

This test verifies if the UMDF driver is built with the correct version of the WDK with public UMDF headers

Test details
Specifications
  • Device.DevFund.DriverFramework.UMDF.Reliability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT


Device.DevFund additional documentation

In this section

  • Device.Fundamentals Reliability Testing Prerequisites
    • Prerequisites for Provided WDTF Simple I/O plug-ins
    • Prerequisites for Wireless LAN (802.11) Testing
  • Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK
    • Collect and View Windows Device Testing Framework (WDTF) Traces
    • Review common Device Fundamentals Reliability test failures
    • Reproduce the test failure by running the test from the command line
    • Review Log Files
    • Troubleshoot WLAN SimpleIO plugin failures that are logged by Device Fundamentals tests
    • Use kernel debugging to debug Device Fundamentals Reliability test failures
  • Using Device Fundamentals Tests to Reproduce Device Manager Problem Codes
  • Driver Compatibility with Device Guard


Driver Compatibility with Device Guard

Windows 10 has a feature called Device Guard that gives organizations the ability to lock down devices in a way that provides advanced malware protection against new and unknown malware variants as well as Advanced Persistent Threats (APTs). Device Guard can use hardware technology and virtualization to isolate the Code Integrity (CI) decision-making function from the rest of the Windows operating system. When using virtualization-based security to isolate Code Integrity, the only way kernel memory can become executable is through a Code Integrity verification. This means that kernel memory pages can never be Writable and Executable (W+X) and executable code cannot be directly modified.

How to build compatible drivers

Since memory pages and sections can never be writable and executable, the first step is to ensure a clear separation of data and code and not to attempt to directly modify code pages.

  • Opt-in to NX by default
  • Use NX APIs/flags for memory allocation - NonPagedPoolNx
  • Don't use sections that are both writable and executable
  • Don't attempt to directly modify executable system memory
  • Don't use dynamic code in kernel
  • Don't load data files as executable
  • Section Alignment must be a multiple of 0x1000 (PAGE_SIZE). E.g. DRIVER_ALIGNMENT=0x1000

Use the latest version of the WDK and Visual Studio 2015 to produce compatible drivers when using default settings. Visual Studio 2013 currently marks the INIT section as RWX. This will be patched, but is still compatible as Windows 10 will automatically strip the write permission (W) from the INIT section.

How to verify driver compatibility

There are four steps to verify driver compatibility:

  1. Use Driver Verifier with the new Code Integrity compatibility checks enabled
  2. Test the driver on a system with virtualization-based isolation of Code Integrity enabled.
  3. Run the HyperVisor Code Integrity Readiness Test in the Windows HLK.
  4. Use the Device Guard Readiness Tool.

Driver Verifier compatibility checks

Driver Verifier has a new Code Integrity option flag (0x02000000) to enable extra checks that validate compliance with this feature. To enable this from the command line, use the following command:

verifier.exe /flags 0x02000000 /driver <driver.sys>

To choose this option if using the verifier GUI, choose Create custom settings (for code developers), choose Next, and then choose Code integrity checks.

Drivers built with older versions of Visual Studio will fail on the INIT section being WRX. However, if this is the only issue you can ignore this issue and hit go past this in the kernel debugger as this will not cause any compatibility issues with this feature. Forthcoming updates to driver verifier will not flag the INIT section.

Enable virtualization-based isolation for Code Integrity

Virtualization-based security is supported on Enterprise and Server editions of Windows. To enable virtualization-based protection of Code Integrity, the simplest method is to use gpedit as described below. This will turn on Hyper-V and Isolated User Mode and enable the feature:

  1. Run gpedit to edit local Group Policy

  2. Under Computer Configuration -> Administrative Templates -> System -> Device Guard, choose Turn On Virtualization Based Security

  3. In the detailed configuration dialog that appears, choose Enabled, and then select Enable Virtualization Based Protection of Code Integrity

  4. Reboot

Virtualization-based protection of Code Integrity is now enabled.

HLK tests and requirements

Client

There is a new HLK test called the Hypervisor Code Integrity Readiness Test that will enable the driver verifier Code Integrity options to catch any driver loading issues. This test will not necessarily catch things that the driver does during normal operation, so it is suggested that other testing be performed while driver verifier is enabled and/or while virtualization-based protection of CI is enabled.

Server

The HLK Hypervisor Code Integrity Readiness Test is required as part of the Assurance AQ and the flags to enable Code Integrity checks are also set while enabling driver verifier during other HLK tests.

Device Guard Readiness Tool

The Device Guard and Credential Guard hardware readiness tool can also be used to check for HVCI compatibility of all installed drivers on the device. The download includes a readme file that contains usage information. Note that while running the Readiness Tool, Device Guard must be disabled, as Device Guard might prevent the driver from loading, and the driver won’t be available for the Readiness Tool to test. For more information about the Readiness Tool, see Use the Device Guard Readiness Tool to evaluate HVCI driver compatibility.

FAQs:

What about existing drivers? Do I need to re-build these drivers to get them to work with Windows 10?

It depends. Many drivers will already be compatible. If using standard settings with the old versions of the WDK and Visual Studio, a known issue is that the INIT section is marked as RWX. In Windows 10, however, the W will automatically be stripped, so if this is the only issue then the driver will be compatible.

How do I verify that Virtualization Based Protection of Code Integrity is enabled?

The simplest mechanism is to run the System Information app (msinfo32). Look for the following line: "Device Guard Security Services Running". It should report: "Hypervisor enforced Code Integrity". There is also a WMI interface for checking using management tools.

Can I verify that Virtualization Based Protection of Code Integrity is enabled programmatically from kernel in order to alter driver behavior?

Yes, you can use NtQuerySystemInformation: https://msdn.microsoft.com/en-us/library/windows/desktop/ms724509(v=vs.85).aspx

The SYSTEM_CODEINTEGRITY_INFORMATION structure has a new 0x400 value exposed, indicating that virtualization based protection of Code Integrity is on.

How do I fix compatibility issues?

In addition to double checking that there are no W+X pages and the driver sections are aligned correctly as mentioned above, the most likely issue will be improper memory allocation. Information about the Code Analysis warnings related to memory allocation issued is available on MSDN on the following page:

Code Analysis for Drivers Warnings

The following MSDN links show some examples of commonly-used APIs that cause executable memory to be allocated, along with some example fixes:

  • C30029
  • C30030
  • C30031
  • C30032
  • C30033
  • C30034
  • C30035

Use the following table to interpret the output to determine what driver code changes are needed to resolve the different types of HVCI incompatibilities.

Warning | Resolution
Execute Pool Type | The caller specified an executable pool type. Calling a memory allocating function that requests executable memory. Be sure that all pool types contain a non executable NX flag.
Execute Page Protection | The caller specified an executable page protection. Specify a "no execute" page protection mask.
Execute Page Mapping | The caller specified an executable memory descriptor list (MDL) mapping. Make sure that the mask that is used contains MdlMappingNoExecute. For more information, see MmGetSystemAddressForMdlSafe
Execute-Write Section | The image contains an executable and writable section.
Section Alignment Failures | The image contains a section that is not page aligned. Section Alignment must be a multiple of 0x1000 (PAGE_SIZE). E.g. DRIVER_ALIGNMENT=0x1000
Unsupported Relocs In Windows 10 version 1507 through version 1607, because of the use of Address Space Layout Randomization (ASLR) an issue can arise with address alignment and memory relocation. The operating system needs to relocate the address from where the linker set its default base address to the actual location that ASLR assigned. This relocation cannot straddle a page boundary. For example, consider a 64-bit address value that starts at offset 0x3FFC in a page. It’s address value overlaps over to the next page at offset 0x0003. This type of overlapping relocs is not supported prior to Windows 10 version 1703. This situation can occur when a global struct type variable initializer has a misaligned pointer to another global, laid out in such a way that the linker cannot move the variable to avoid the straddling relocation. The linker will attempt to move the variable, but there are situations where it may not be able to do so, for example with large misaligned structs or large arrays of misaligned structs. Where appropriate, modules should be assembled using the /Gy (COMDAT) option to allow the linker to align module code as much as possible.
#include <pshpack1.h>

typedef struct _BAD_STRUCT {
      USHORT Value;
      CONST CHAR *String;
} BAD_STRUCT, * PBAD_STRUCT;

#include <poppack.h>

#define BAD_INITIALIZER0 { 0, "BAD_STRING" },
#define BAD_INITIALIZER1 \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0      \
      BAD_INITIALIZER0

#define BAD_INITIALIZER2 \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1      \
      BAD_INITIALIZER1

#define BAD_INITIALIZER3 \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2      \
      BAD_INITIALIZER2

#define BAD_INITIALIZER4 \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3      \
      BAD_INITIALIZER3

BAD_STRUCT MayHaveStraddleRelocations[4096] = { // as a global variable
      BAD_INITIALIZER4
};
There are other situations involving the use of assembler code, where this issue can also occur.
IAT in Executable Section | The import address table (IAT), should not be an executable section of memory. This issue occurs when the IAT, is located in a Read and Execute (RX) only section of memory. This means that the OS will not be able to write to the IAT to set the correct addresses for where the referenced DLL. One way that this can occur is when using the /MERGE (Combine Sections) option in code linking. For example if .rdata (Read-only initialized data) is merged with .text data (Executable code), it is possible that the IAT may end up in an executable section of memory.

Which APIs are potentially affected?

The following list of APIs that are not reserved for system use may be impacted:

API name | Description
ExAllocatePool | https://msdn.microsoft.com/en-us/library/windows/hardware/ff544501(v=vs.85).aspx
ExAllocatePoolWithQuota | https://msdn.microsoft.com/en-us/library/windows/hardware/ff544506(v=vs.85).aspx
ExAllocatePoolWithQuotaTag | https://msdn.microsoft.com/en-us/library/windows/hardware/ff544513(v=vs.85).aspx
ExAllocatePoolWithTag | https://msdn.microsoft.com/en-us/library/windows/hardware/ff544520(v=vs.85).aspx
ExAllocatePoolWithTagPriority | https://msdn.microsoft.com/en-us/library/windows/hardware/ff544523(v=vs.85).aspx
ExInitializeNPagedLookasideList | https://msdn.microsoft.com/en-us/library/windows/hardware/ff545301(v=vs.85).aspx
ExInitializeLookasideListEx | https://msdn.microsoft.com/en-us/library/windows/hardware/ff545298(v=vs.85).aspx
MmAllocateContiguousMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554460(v=vs.85).aspx
MmAllocateContiguousMemorySpecifyCache | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554464(v=vs.85).aspx
MmAllocateContiguousMemorySpecifyCacheNode | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554464(v=vs.85).aspx
MmAllocateContiguousNodeMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/jj602795(v=vs.85).aspx
MmCopyMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/dn342884(v=vs.85).aspx
MmMapIoSpace | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554618(v=vs.85).aspx
MmMapLockedPages | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554622(v=vs.85).aspx
MmMapLockedPagesSpecifyCache | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554629(v=vs.85).aspx
MmProtectMdlSystemAddress | https://msdn.microsoft.com/en-us/library/windows/hardware/ff554670(v=vs.85).aspx
ZwAllocateVirtualMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/ff566416(v=vs.85).aspx
ZwCreateSection | https://msdn.microsoft.com/en-us/library/windows/hardware/ff566428(v=vs.85).aspx
ZwMapViewOfSection | https://msdn.microsoft.com/en-us/library/windows/hardware/ff566481(v=vs.85).aspx
NtCreateSection | https://msdn.microsoft.com/en-us/library/windows/hardware/ff556473(v=vs.85).aspx
NtMapViewOfSection | https://msdn.microsoft.com/en-us/library/windows/hardware/ff556551(v=vs.85).aspx
StorPortGetDataInBufferSystemAddress | https://msdn.microsoft.com/en-us/library/windows/hardware/jj553720(v=vs.85).aspx
StorPortGetSystemAddress | https://msdn.microsoft.com/en-us/library/windows/hardware/ff567100(v=vs.85).aspx
DxgkCbMapMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/ff559533(v=vs.85).aspx
IMiniportDMus::NewStream | https://msdn.microsoft.com/en-us/library/windows/hardware/ff536701(v=vs.85).aspx
FltAllocatePoolAlignedWithTag | https://msdn.microsoft.com/en-us/library/windows/hardware/ff541762(v=vs.85).aspx
FltAllocateContext | https://msdn.microsoft.com/en-us/library/windows/hardware/ff541710(v=vs.85).aspx
ChangerClassAllocatePool | https://msdn.microsoft.com/en-us/library/windows/hardware/ff551402(v=vs.85).aspx
IMiniportMidi::NewStream | https://msdn.microsoft.com/en-us/library/windows/hardware/ff536710(v=vs.85).aspx
IMiniportWaveCyclic::NewStream | https://msdn.microsoft.com/en-us/library/windows/hardware/ff536723(v=vs.85).aspx
IPortWavePci::NewMasterDmaChannel | https://msdn.microsoft.com/en-us/library/windows/hardware/ff536916(v=vs.85).aspx
IMiniportWavePci::NewStream | https://msdn.microsoft.com/en-us/library/windows/hardware/ff536735(v=vs.85).aspx
PcNewDmaChannel | https://msdn.microsoft.com/en-us/library/windows/hardware/ff537712(v=vs.85).aspx
PcNewResourceList | https://msdn.microsoft.com/en-us/library/windows/hardware/ff537717(v=vs.85).aspx
PcNewResourceSublist | https://msdn.microsoft.com/en-us/library/windows/hardware/ff537718(v=vs.85).aspx
VideoPortAllocatePool | https://msdn.microsoft.com/en-us/library/windows/hardware/ff570180(v=vs.85).aspx
ClfsCreateMarshallingArea | https://msdn.microsoft.com/en-us/library/windows/hardware/ff541520(v=vs.85).aspx
WdfLookasideListCreate | https://msdn.microsoft.com/en-us/library/windows/hardware/ff548694(v=vs.85).aspx
WdfMemoryCreate | https://msdn.microsoft.com/en-us/library/windows/hardware/ff548706(v=vs.85).aspx
WdfDeviceAllocAndQueryProperty | https://msdn.microsoft.com/en-us/library/windows/hardware/ff545882(v=vs.85).aspx
WdfDeviceAllocAndQueryPropertyEx | https://msdn.microsoft.com/en-us/library/windows/hardware/dn265599(v=vs.85).aspx
WdfFdoInitAllocAndQueryProperty | https://msdn.microsoft.com/en-us/library/windows/hardware/ff547239(v=vs.85).aspx
WdfFdoInitAllocAndQueryPropertyEx | https://msdn.microsoft.com/en-us/library/windows/hardware/dn265612(v=vs.85).aspx
WdfIoTargetAllocAndQueryTargetProperty | https://msdn.microsoft.com/en-us/library/windows/hardware/ff548585(v=vs.85).aspx
WdfRegistryQueryMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/ff549920(v=vs.85).aspx
NdisAllocateMemory | https://msdn.microsoft.com/en-us/library/windows/hardware/ff550762(v=vs.85).aspx


Device.Fundamentals Reliability Testing Prerequisites

This content applies to a subset of the Windows Hardware Lab Kit (Windows HLK) Device.Device Fundamentals tests that are known as Device Fundamentals Reliability tests. (The applicable test names begin with "DF - ".)

This topic describes configuration requirements for the Windows HLK Device Fundamentals Reliability tests.

In this article:

  • General requirements

  • Bluetooth mice

  • LAN adapters

  • WLAN adapters

  • Storage devices

  • Microsoft USB Test Tool (MUTT)

NOTE

For information regarding prerequisites and configuration details for additional device types, see Provided WDTF Simple I/O plug-ins.

General requirements

Device Fundamentals Reliability tests require devices to be configured properly for the tests to test I/O on devices when they run. Tests log device configuration errors if devices are not configured properly.

These tests use WDTF Simple I/O interfaces to test I/O in devices. Simple I/O plug-ins are extensions to the Windows Driver Test Framework (WDTF) that implement generic device-specific I/O functionality. Before you run any tests, review the specific plug-in requirements for the device. For more information, see Provided WDTF Simple I/O plug-ins.

Bluetooth mice

When you test a Bluetooth mouse, you must keep the mouse moving during the entire course of testing so that the HID mouse devnode stays enumerated the whole time. Otherwise, the Device Fundamentals Reliability tests will log failures. We recommend that you use custom/simple automatic solutions to keep the mouse moving during the tests.

LAN adapters

NOTE

The network test configuration that is required to run Device Fundamentals Reliability tests for network LAN adapters is different from the network test configuration that is required to run Device.Network Tests.

If the device under test (DUT) is a network LAN adapter, make sure that the network LAN adapter has an IPv6 gateway address assigned to it before you run Device Fundamentals Reliability tests.

If the test network environment cannot support a test adapter that has an assigned IPv6 gateway address (for example, if you are testing in a private network configuration or in a network configuration that supports IPv4 gateway assignments only), we recommend that you use the following test configuration:

  1. Select a remote client or server system that is running Windows 7 or later version of Windows.

  2. Use an Ethernet cable to make a direction connection between the test system's adapter to the remote system's LAN adapter.

  3. On the remote system, from the Network and Sharing Center, turn on file and printer sharing. (For more information about how to enable file and printer sharing, see Enable file and printer sharing.)

  4. On the remote system, open a command prompt window that has administrative privileges. Type ipconfig /all and make a note of the IPv6 address that is assigned to the remote system's LAN adapter.

  5. From the command prompt window on the test system, ping the IPv6 address that you noted in the previous step. Use the ping -s option to specify the IPv6 address of the test adapter as the source address.

  6. Provide the noted IPv6 address, without the scope ID (for example, fe80::205:ddff:fe27:3840), as the WDTFREMOTESYSTEM parameter to Device Fundamentals Reliability tests.

WLAN adapters

WLAN adapters are among the more difficult devices to configure for Device Fundamentals and System Fundamentals testing. While many different routers may work for testing, we recommend that you follow the setup instructions described in Wireless LAN (802.11) Testing Prerequisites.

See Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK for additional help with testing WLAN devices.

Storage devices

We strongly recommend that you complete all Device Fundamentals Reliability tests before you start to run storage tests. This means scheduling the tests two times, as follows:

  1. Schedule the tests to run one time, to run all Device Fundamentals Reliability tests.

  2. Schedule the tests to run one time, after Device Fundamentals Reliability tests finish running, to run Storage tests.

Storage tests reconfigure a test device and can leave the device in a state that cannot support Device Fundamentals Reliability tests. If you must run storage tests before you run Device Fundamentals Reliability tests, you must reconfigure the devices according to the preceding general requirements before you run Device Fundamentals Reliability tests.

Media card readers or multi-function devices that have storage capability

If you are testing a media card reader or a multi-function device that has an external storage capability, you must populate all media slots of the storage device with media, according to the Volume I/O plug-in requirements.

Because of Windows HLK and test limitations, you must insert media into all media slots on the test computer also (even if you are not testing media slots on the test computer).

Microsoft USB Test Tool (MUTT)

The Microsoft USB Test Tool (MUTT) device and the software package gives you a powerful set of tools for testing interoperability of your USB hardware with the Microsoft USB driver stack. See Test with Microsoft USB Test Tool (MUTT) for a brief overview of the different types of MUTT devices, the tests you can run by using the device, and suggests topologies for controller, hub, device, and BIOS/UEFI testing.


Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK

This article describes how to troubleshoot problems that can occur during Windows Hardware Lab Kit (Windows HLK) Device Fundamentals Reliability testing. See Troubleshooting Windows HLK Test Failures.

Troubleshooting Device Fundamentals Reliability tests consists of the following primary steps:

  1. Check the device configuration

  2. Identify the type of test failures

  3. Triage test failures

The following sections provide additional detailed and important information that you can use to troubleshoot failed Device Fundamentals Reliability tests:

  • Collect and View Windows Device Testing Framework (WDTF) Traces

  • Review common Device Fundamentals Reliability test failures

  • Review Log Files

  • Reproduce the test failure by running the test from the command line

  • Troubleshoot WLAN SimpleIO plugin failures that are logged by Device Fundamentals tests

  • Use kernel debugging to debug Device Fundamentals Reliability test failures

  • How to get help

  • Additional resources

Check the device configuration

Device Fundamentals Reliability tests require test devices to be properly configured to test I/O. Before you start to test, make sure that the test configuration adheres to the testing prerequisites that are described in Device.Fundamentals Reliability Testing Prerequisites. Failure to meet these prerequisites can result in test failures.

Identify the type of test failures

See Troubleshooting Windows HLK Test Failures in Troubleshooting Windows HLK Test Failures to identify specific types of test failures.

Test logs a failure

The most common way for Device Fundamentals Reliability tests to fail in Windows HLK is for the test to log a failure. If your failed test logged a failure, we recommend that you proceed to the Triage test failures section of this topic.

Test system bug checks

System bug checks are commonly seen during Device Fundamentals Reliability tests because of the nature of the tests (stress, reliability, concurrency, etc.).

When you investigate failures that are caused by system bug checks, we highly recommend that you re-run the tests by having the test system connected to a kernel debugger. Running the tests by using the debugger causes the system to break into the debugger when the system bug-checks.

  • See Setting Up Kernel-Mode Debugging Manually for information on how to setup a kernel debugger.

  • See Use kernel debugging to debug Device Fundamentals Reliability test failures for more information.

  • See Troubleshooting Windows HLK Test Failures in Troubleshooting Windows HLK Test Failures for general guidance on how to troubleshoot system bug checks during Windows HLK test runs.

Test hangs

Test hangs frequently occur during Device Fundamentals Reliability tests. Test hangs are typically seen when I/O request packets (IRPs) (typically, I/O and PNP IRPs) become stuck in drivers and prevent the tests from progressing.

NOTE

Windows HLK will eventually cancel and fail a hung test so that the next scheduled test can proceed.

If a test hangs, we highly recommended that you re-run the tests by having the test system connected to a kernel debugger. This allows you to break into the debugger at the time when the test hangs, and to inspect stack traces of the test process (Device Fundamentals Reliability tests typically run as te.processhost.exe or te.exe).

  • See Setting Up Kernel-Mode Debugging Manually for information on how to setup a kernel debugger.

  • See Use kernel debugging to debug Device Fundamentals Reliability test failures for more information.

  • See Troubleshooting Windows HLK Test Failures in Troubleshooting Windows HLK Test Failures for general guidance on how to troubleshoot test hangs during Windows HLK test runs.

Triage test failures

Review test documentation

Device Fundamentals Reliability tests generally test common user scenarios such as Sleep with I/O, PNP with I/O, Reboot with I/O, etc. We recommend that you completely understand the scenario under test for the failing test(s) by reviewing the appropriate test documentation at Device.DevFund Tests.

Thoroughly review test logs

You should thoroughly review log entries that precede the actual error message, to gain a clear understanding of the current test scenario and the previous test scenarios that ran. Sometimes previous test scenarios that ran (even if they passed) affect the next test scenario. For example, I/O failures can occur after a device is disabled and enabled. For more information about reviewing test logs, see Review Log Files

Review additional log files that are copied back

Device Fundamentals Reliability tests often copy back additional files that are useful for triaging test failures. For example, Reinstall and PNP tests copy back SetupAPI logs from the test system. You should open and review all files under Additional Files on the Results tab in Windows HLK Studio. Right-click the test result and then select Additional Files.

Collect and view WDTF traces

It can be useful to collect and view WDTF traces when you troubleshoot certain test failures. See Collect and View Windows Device Testing Framework (WDTF) Traces for information about how to collect and view WDTF traces.

How to get help

Device Fundamentals Reliability test owners at Microsoft regularly review and respond to questions posted about Device Fundamentals Test failures at the Windows Hardware Testing and Certification Forum. We recommend that you use this forum to get needed support.

See Windows HLK Support for information about how to open a support case for investigating test failures.

Additional resources

The following table lists additional resources that can help you resolve problems you can encounter during device fundamentals testing.

Resource | Description
Troubleshooting the Windows HLK Environment | General triage and troubleshooting assistance for Windows HLK infrastructure failures.
Troubleshooting Windows HLK Test Failures | General triage and troubleshooting guidance to investigate test failures.
Triaging WDTF-based tests | General guidance for troubleshooting failures that are logged by WDTF-based tests.
How to select and configure the Device Fundamentals tests | Device Fundamentals Reliability tests also ship in the Windows Driver Kit (WDK). Driver developers might prefer to use WDK and Microsoft Visual Studio to run the failing tests to investigate test failures. This page describes how to run the tests by using the WDK.
%ProgramFiles%\Windows Kits\8.1\Testing\Tests\Additional Tests\DeviceFundamentals.). | A subset of Device Fundamentals Reliability tests are written by using VBScript. You can open these script files by using Notepad. The scripts are located in the specified folder after you install the WDK.
Troubleshooting the Device Fundamentals tests using the WDK | Provides suggestions for fixing problems that you might encounter when you use the WDK to run the Device Fundamentals Tests.

Related topics

Device.DevFund Tests


Collect and View Windows Device Testing Framework (WDTF) Traces

Most device fundamentals reliability tests in Windows Hardware Lab Kit (Windows HLK) are written by using Windows Device Testing Framework (WDTF). It can be useful to collect and view WDTF traces when you troubleshoot device fundamentals test failures.

How to Collect WDTF Traces

To collect WDTF traces, you must perform the following steps:

  • Start a new trace collection session.

  • Run the test from command line and reproduce the failure. (See Reproduce the test failure by running the test from the command line)

  • Stop the trace collection session.

Start a WDTF trace

You can start a WDTF trace collection from the command line, as shown in the following procedure.

To start a WDTF trace from the command line

  1. Open a command prompt by using administrative privileges.

  2. Type the following commands:

    logman create trace "autosession\WDTF" -p {6210f559-c7f7-4d2f-b674-4bc9315cecc7} 0xffffffff 0xff -o c:\WDTF_Traces\TraceFile.etl
reg add HKLM\SYSTEM\CurrentControlSet\Control\WMI\Autologger\WDTF /v LogFileMode /t REG_DWORD /d 1 /f
reg add HKLM\SYSTEM\CurrentControlSet\Control\WMI\Autologger\WDTF /v FileMax /t REG_DWORD /d 16 /f
reg add HKLM\SYSTEM\CurrentControlSet\Control\WMI\Autologger\WDTF /v MaxFileSize /t REG_DWORD /d 0 /f

  3. Reboot the computer.

NOTE

For more information about trace options, see Configuring and Starting an AutoLogger Session and Logman.

Stop Collecting Traces

You can stop a WDTF trace collection from the command line, as shown in the following procedure.

To stop a WDTF trace from the command line

  1. Open a command prompt by using administrative privileges.

  2. Type the following commands:

    logman -stop -ets WDTF
logman delete "autosession\WDTF"

  3. Reboot the computer.

Delete collected traces

Collected event trace log (.etl) files can be very large. We recommend that you copy them from the test system to another system for later analysis, and that you delete them from the test system.

How to View WDTF Traces

To view WDTF traces, you must first format the collected .etl files into text or comma-separated, variable-length (CSV) versions.

You can run Tracefmt from the command line to create the formatted log files:

To create formatted log files from the command line

  1. Open a command prompt by using administrative privileges.

  2. Type Tracefmt.exe -r http://msdl.microsoft.com/download/symbols <full path to ETL file> -o OutputTxtFile.txt

  3. Type Tracefmt.exe -r http://msdl.microsoft.com/download/symbols <full path to ETL file> -csv -o OutputCsvFile.csv

You can open CSV files in Microsoft Excel; you can use the filtering features of Excel to filter collected traces, and to search for traces from certain time periods, from certain WDTF components, and other specific criteria.

Related topics

Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK


Review common Device Fundamentals Reliability test failures

This topic describes common test failures that you can encounter when you run Windows Hardware Lab Kit (Windows HLK) Device Fundamentals Reliability tests.

The test is marked as failed in HLK Studio, but the te.wtl log shows only pass results

If test is marked as failed in HLK Studio, but the te.wtl log shows only pass results, you can obtain the error that caused the failure by executing the following steps:

  1. Right click on the red Run Test icon
  2. Select Error

A dialog box will appear that contains a description of the error that occurred.

The test failed because an unexpected reboot occurred during testing

If the error text states that an unexpected reboot occurred, this likely means that the device caused the operating system to reboot unexpectedly (BSOD). To diagnose this failure, attach a debugger or configure the test machine to automatically generate full memory dumps, and investigate the bug check. To get started with kernel debugging of test failures, see Use kernel debugging to debug Device Fundamentals Reliability test failures.

Device Status Check task fails during setup

Device Status Check tasks often fail because the device is not properly set up with media or a connection before testing starts. For information regarding how to properly configure a device for testing, see Device.Fundamentals Reliability Testing Prerequisites.

The Device Status Check task is included in the setup phase of every Device Fundamentals Reliability test job. It runs a tool to verify that the device under test (DUT) is in working condition. If it fails, a log is created that indicates the problem with the device.

For example, for Bluetooth devices, you might get the following error:

PerformIO(Example ) Failed : Streaming error capturing audio HRESULT=0x8445001F Count 1

This error message can indicate that, prior to testing, you must connect to the Bluetooth device by using the Audio Control panel.

In the following example, the test device reports problem code A - CM_PROB_FAILED_START status. It should report problem code 0 (no problem).

WDTF_TARGETS          : INFO  : - Query("IsPhantom=False AND (DeviceID='USB\VID_0BDB&PID_1917&CDC_0D&MI_06\6&2A131B9E&1&0006')")
WDTF_TARGETS          : INFO  : Target: F5321 gw Mobile Broadband Network Adapter USB\VID_0BDB&PID_1917&CDC_0D&MI_06\6&2A131B9E&1&0006
WDTF_TEST             : ERROR : Found a device that has a non-zero problem code or is phantom. Logging device info.
WDTF_TEST             : INFO  : DeviceID:     USB\VID_0BDB&PID_1917&CDC_0D&MI_06\6&2A131B9E&1&0006
WDTF_TEST             : INFO  : DisplayName:  F5321 gw Mobile Broadband Network Adapter
WDTF_TEST             : INFO  : Status:       Status Flags=0x1802400 (DN_HAS_PROBLEM DN_DISABLEABLE DN_NT_ENUMERATOR DN_NT_DRIVER) Problem Code=a (CM_PROB_FAILED_START)
WDTF_TEST             : INFO  : IsPhantom:    False

Device Path Exerciser fails with "Test thread exceeded timeout limit. Terminating thread error" error

When the test logs the Test thread exceeded timeout limit. Terminating thread error error during a device path exerciser test, the test also logs the last operation that it performed. Driver developers must determine why the last logged operation would cause the test to hang. For example:

WDTF_FUZZTEST : Test thread exceeded timeout limit. Terminating thread
WDTF_FUZZTEST : Last logged operation: ZwDeviceIoControlFile, CtrlCode=0x2b0020, InBuf=0xfffffc00, 0 OutBuf=0xfffffc00, 0

Surprise Remove test fails with "Failed to receive IRP_MN_REMOVE_DEVICE after receiving IRP_MN_SURPRISE_REMOVAL" error message

The DF - PNP Surprise Remove Device Test might fail with the following error message if the PnP manager does not send the remove IRP to the test device stack after it sends the surprise remove IRP:

"Failed to receive IRP_MN_REMOVE_DEVICE after receiving IRP_MN_SURPRISE_REMOVAL. Ensure that there are no open handles or references to the test device (in user mode or in kernel mode) preventing IRP_MN_REMOVE_DEVICE from being sent. You may need to terminate any processes or services that may have open user mode handles to this device."

The PnP manager does not send the IRP_MN_REMOVE_DEVICE request until all outstanding file handles to the device are closed. That is, the PnP manager does not send the IRP_MN_REMOVE_DEVICE request until reference count of the PDO reaches zero. See Handling an IRP_MN_SURPRISE_REMOVAL Request for information on how to properly handle IRP_MN_SURPRISE_REMOVAL request.

To help debug this test failure, you should determine how the reference count of the physical device object (PDO) changes. Identify the process that is changing the reference count and examine what the call stack looks like when the reference count is changed. The following steps can be used for debugging this failure:

  1. If you have not already done so, connect a kernel debugger to the test computer. See Configuring a Computer for Driver Deployment, Testing, and Debugging.

  2. Set a ba (Break on Access) breakpoint at the location where the reference count of the PDO of the test device is stored. See Processor Breakpoints (ba Breakpoints) for more information about access breakpoints. In the following example, the kernel debugger !devnode command obtains information about the devnode for the USBvideo driver. The address of the PDO for this devnode is 0x849e9648.

    0: kd> !devnode 0 1 usbvideo
Dumping IopRootDeviceNode (= 0x848fadd8)
DevNode 0x849e9448 for PDO 0x849e9648
  InstancePath is "USB\VID_045E&PID_076D&MI_00\7&1243e0b7&0&0000"
  ServiceName is "usbvideo"
  State = DeviceNodeStarted (0x308)
  Previous State = DeviceNodeEnumerateCompletion (0x30d)

  3. Use the !devobj command on the PDO to display information about the reference count (RefCount) of the PDO.

    0: kd> !devobj 0x849e9648
Device object (849e9648) is for:
 0000004e \Driver\usbccgp DriverObject 8727e120
Current Irp 00000000 RefCount 0 Type 00000022 Flags 00003040
Dacl 82910320 DevExt 849e9700 DevObjExt 849e99e0 DevNode 849e9448
ExtensionFlags (0x00000800)  DOE_DEFAULT_SD_PRESENT
Characteristics (0x00000180)  FILE_AUTOGENERATED_DEVICE_NAME, FILE_DEVICE_SECURE_OPEN
AttachedDevice (Upper) 88310588 \Driver\usbvideo
Device queue is not busy

  4. Examine the PDO device object by using the dt (Display Type) kernel debugger command. The ReferenceCount shows the number of open handles for the device that are associated with the device object.

    0: kd> dt nt!_DEVICE_OBJECT 849e9648
…
   +0x002 Size             : 0x398
   +0x004 ReferenceCount   : 0n0
   +0x008 DriverObject     : 0x8727e120 _DRIVER_OBJECT
..
…

  5. If the reference count is greater than 0 before starting the test:

    • Set a breakpoint where the PDO gets created.

    • After the PDO is created, set the break on access (ba) breakpoint at the location where the reference count of the PDO is stored.

      For example, the following command sets a ba (Break on Access) breakpoint on the device object (0x849e9648). The breakpoint is set on write access to the ReferenceCount (+4 offset) with a size of 4 bytes (the size of ReferenceCount).

      0: kd> ba w 4 849e9648+4

    • If the reference count of the PDO is equal to 0 before starting the test, it is likely that running the test is what is causing the reference count of the PDO to be greater than zero at the time the test performs the surprise remove of the device. This usually indicates a handle leak. Run the PNP Surprise Remove Device test from a Command Prompt window or from Visual Studio to reproduce the failure and capture the information that is needed to troubleshoot the problem.

    NOTE

    If you set the DoConcurrentIO parameter to TRUE, the test opens hundreds of file handles to the PDO. We recommend that you set this parameter to FALSE when you reproduce this failure.

  6. When the break on access (ba) breakpoint occurs, you can use the !thread and k (Display Stack Backtrace) kernel debugger commands to debug the failure. Because the reference count can change multiple times during the course of running the test, as an option, you can use the commandString parameter of the ba (Break on Access) debugger command to get the information that you need on each change to the reference count, and still continue to test.

    For example, in the following break on access command, the commandString consists of a !thread command that will identify the process causing the reference count change, and the .reload ; k 100 commands that will identify the call stack, a !devobj command to print the reference count on each change, and g command to continue after the breakpoint.

    0: kd> ba w 4 849e9648+4 "!thread; .thread /p /r; .reload; k 100; !devobj 849e9648; g"

Example:

In the following example, the CreateFile function call from a thread that is running in cscript.exe causes an increment to the reference count. Capturing all the instances where the reference count is changed while running the test and analyzing these call stacks can help identify the handle leaks.

THREAD 87eb3d40  Cid 1094.1490  Teb: 7f5a8000 Win32Thread: 82da2210 RUNNING on processor 3
Not impersonating
DeviceMap                 a71b3228
Owning Process            88199cc0       Image:         cscript.exe
Attached Process          N/A            Image:         N/A
Wait Start TickCount      1232688        Ticks: 0
Context Switch Count      18             IdealProcessor: 2
UserTime                  00:00:00.000
KernelTime                00:00:00.000
Win32 Start Address ntdll!TppWorkerThread (0x7710704d)
Stack Init a6ebfde0 Current a6ebfa6c Base a6ec0000 Limit a6ebd000 Call 0
Priority 9 BasePriority 8 UnusualBoost 0 ForegroundBoost 0 IoPriority 2 PagePriority 5
ChildEBP RetAddr  Args to Child
a6ebfa50 814a73fe f81771f8 814a72e5 8281000e nt!IopCheckDeviceAndDriver+0x61 (FPO: [Non-Fpo]) (CONV: stdcall) [d:\w8rtm\minkernel\ntos\io\iomgr\parse.c @ 182]
a6ebfb70 8149fb76 849e9648 848f9200 87164008 nt!IopParseDevice+0x11d (FPO: [Non-Fpo]) (CONV: stdcall) [d:\w8rtm\minkernel\ntos\io\iomgr\parse.c @ 1634]
…
…
0236f874 7710689d ffffffff 77195ae2 00000000 ntdll!__RtlUserThreadStart+0x4a (FPO: [SEH]) (CONV: stdcall) [d:\w8rtm\minkernel\ntdll\rtlstrt.c @ 1021]
0236f884 00000000 7710704d 0031c540 00000000 ntdll!_RtlUserThreadStart+0x1c (FPO: [Non-Fpo]) (CONV: stdcall) [d:\w8rtm\minkernel\ntdll\rtlstrt.c @ 939]

Implicit thread is now 87eb3d40
Connected to Windows 8 9200 x86 compatible target at (Wed Sep 19 21:04:27.601 2012 (UTC - 7:00)), ptr64 FALSE
Loading Kernel Symbols
...............................................................
................................................................
...............
Loading User Symbols
................................................................
...........................
Loading unloaded module list
.....................
ChildEBP RetAddr
a6ebfa50 814a73fe nt!IopCheckDeviceAndDriver+0x61 [d:\w8rtm\minkernel\ntos\io\iomgr\parse.c @ 182]
a6ebfb70 8149fb76 nt!IopParseDevice+0x11d [d:\w8rtm\minkernel\ntos\io\iomgr\parse.c @ 1634]
…
…
0236f2d4 6970274e KERNELBASE!CreateFileW+0x61 [d:\w8rtm\minkernel\kernelbase\fileopcr.c @ 1194]
0236f31c 6b6ce0e1 deviceaccess!CDeviceBroker::OpenDeviceFromInterfacePath+0x178 [d:\w8rtm\base\devices\broker\dll\broker.cpp @ 177]
0236f34c 6b6cc5c0 MFCORE!CDevProxy::CreateKsFilter+0x46 [d:\w8rtm\avcore\mf\core\transforms\devproxy\devproxy.cpp @ 2263]
…
…
0236f874 7710689d ntdll!__RtlUserThreadStart+0x4a [d:\w8rtm\minkernel\ntdll\rtlstrt.c @ 1021]
0236f884 00000000 ntdll!_RtlUserThreadStart+0x1c [d:\w8rtm\minkernel\ntdll\rtlstrt.c @ 939]

Device object (849e9648) is for:
 0000004e \Driver\usbccgp DriverObject 8727e120
Current Irp 00000000 RefCount 1 Type 00000022 Flags 00003040
Dacl 82910320 DevExt 849e9700 DevObjExt 849e99e0 DevNode 849e9448
ExtensionFlags (0x00000800)  DOE_DEFAULT_SD_PRESENT
Characteristics (0x00000180)  FILE_AUTOGENERATED_DEVICE_NAME, FILE_DEVICE_SECURE_OPEN
AttachedDevice (Upper) 88310588 \Driver\usbvideo
Device queue is not busy.

SimpleIO plugins log failures

Device Fundamentals Reliability tests use Provided WDTF Simple I/O plug-ins to test I/O on devices. SimpleIO plugins are WDTF extensions that test generic device-specific I/O functionality. If a WDTF plug-in exists for the type of device that is being tested, then the test uses IWDTFSimpleIOStressAction2 interface to test I/O on the device.

Errors that are logged by WDTF SimpleIO plugins use the WDTF_SIMPLE_IO tag in the TestTextLog.log file (see WDTF Object Name tags. The error message always identifies the device under test and the specific reason for failure.

Example:

In this example, the Wireless SimpleIO plug-in logged a failure that I/O failures occurred during the test of an 802.11n USB Wireless LAN Card device. Specifically, the SimpleIO plugin pinged the gateway address by using an IcmpSendEcho function, which returned an error 11010. This error translates to Error due to lack of resources.

WDTF_SIMPLE_IO            : ERROR :  - PerformIO(802.11n USB Wireless LAN Card USB\VID_XXXX&PID_XXXX\X&XXXXXXX&X&X ) Failed : WirelessPlugin: TestPingGateway() - IcmpSendEcho() call failed several times. The error reported is for the last failure instance Win32=11010 - Error due to lack of resources.

Testing I/O on a particular device permanently hangs, and eventually causes the test to fail because of a timeout

Device Fundamentals Reliability tests are scenario based tests and combine I/O testing with PNP & power test scenarios. The tests typically will test I/O for two minutes before and after a scenario. For instance, the DF - Sleep with IO Before and After test does the following:

For each sleep state supported on the system (CS, S1, S2, S3, S4)

Test I/O on devices with I/O plugins in parallel (one thread per device) for 2 minutes

Enter sleep state & exit after 2 minutes

Next

The test ends up testing I/O on devices several times (one time for each sleep state) when it runs. See Review Log Files for information about how to see this in the log files.

One of the common failures when testing I/O is that testing I/O on a particular device can permanently hang. This results in the test to eventually fail after a test timeout period (which is typically hours). See Troubleshooting Windows HLK Test Failures for information about how to identify failures caused by timeout.

NOTE

Windows HLK will terminate the hung process after the timeout period. Instead of waiting for the test to eventually fail because of a permanent hang, we recommend that you investigate the hang while the hung process is still running on the system. See the Test Hangs section of the Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK topic for information about how to troubleshoot test hangs.

Depending on how many devices the I/O is being tested on, the hung device can be identified as follows:

  1. If the number of devices the test is testing I/O on is one, you will see no progress in the command window for more than ten minutes. The last log entry in the command window will have a WDTF_SIMPLE_IO or WDTF_SIMPLEIO_STRESS tag, and it will identify the hung device. See Review Log Files for more information about how to read the test log files.

  2. If the number of devices on which the test is testing I/O is greater than one, you will see a constant repetition of PerformIO(<Device Name>) Count … messages for longer than ten minutes in the command window. The test tries to stop testing I/O on one device at a time after two minutes of testing I/O on them. If the stop operation is successful for a particular device, you should see a "Stop" message followed by a "Close" message for the device in the logs. If the "Stop" message is seen, but the corresponding "Close" message is not seen for a device, then it implies that testing I/O to this device is hung.

Example:

In the following case, the mobile broadband device is the problem device because there is a "Stop" message, but there is no corresponding "Close" message. On the other hand, the I2C HID Device has both a "Stop" message and a "Close" message, which implies that the test was able to stop I/O on the device without any problems. The test never had a chance to stop testing I/O on the Microsoft Basic Render Driver and Microsoft ACPI-Compliant System devices; therefore, "PerformIO" messages are continuously seen for these devices.

WDTF_SIMPLEIO_STRESS      : INFO  :  - Stop(I2C HID Device ACPI\STMQ7017\2&DABA3FF&3 )
WDTF_SIMPLE_IO            : INFO  :  - Close(I2C HID Device ACPI\STMQ7017\2&DABA3FF&3 )
WDTF_SIMPLEIO_STRESS      : INFO  :  - Stop(XYZ Mobile Broadband Device USB\VEN_XXX&PID_XXX\X&XXXXXX&X&X)
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft Basic Render Driver ROOT\BASICRENDER\0000 ) Count 119
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft ACPI-Compliant System ACPI_HAL\PNP0C08\0 ) Count 119
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft Basic Render Driver ROOT\BASICRENDER\0000 ) Count 119
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft ACPI-Compliant System ACPI_HAL\PNP0C08\0 ) Count 119
…
…
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft Basic Render Driver ROOT\BASICRENDER\0000 ) Count 119
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft ACPI-Compliant System ACPI_HAL\PNP0C08\0 ) Count 119
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft Basic Render Driver ROOT\BASICRENDER\0000 ) Count 119
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(Microsoft ACPI-Compliant System ACPI_HAL\PNP0C08\0 ) Count 119
…
…

The next step is to inspect the stack traces of the threads in the test process to determine why testing I/O to the mobile broadband device is hung. You will find that one of the threads in the test process is used to specifically test I/O on the mobile broadband device. See Use kernel debugging to debug Device Fundamentals Reliability test failures for additional troubleshooting information.

Tests do not resume from sleep

Device Fundamentals Reliability tests rely on system wake timers to wake up the test system from sleep states during power management testing. Faulty wake timers can prevent the test system from automatically waking up during the test runs. If you the test system is not automatically waking up from sleep, you might need to contact your BIOS vendor to have them release a BIOS fix to address the wake timer issues, or run tests on a different system where the wake timers work as expected.

The system can also permanently hang during power up or power down because of driver bugs. In this case, you should re-run the test by using the test system connected to a kernel debugger, and debug the system hang from the kernel debugger.

See Setting Up Kernel-Mode Debugging Manually for information about how to setup a kernel debugger. See Troubleshooting Windows HLK Test Failures for general guidance on how to troubleshoot system hangs during Windows HLK test runs.

WirelessPlugin: ConnectToTestProfile() - Failed to connect to test profile. Reason string: "The specific network is not available." error message

Device Fundamentals tests will fail with this error message if correct values for Wpa2PskAesSsid and Wpa2PskPassword parameters are not supplied to the test at test schedule time. The tests require you to provide connection information (SSID and password) of a test wireless network if one of the devices under test is a WiFi adapter. See parameters section of the failing test's documentation page for more information about these test parameters.

WDTFSensorsPlugin: Open() - GPS Sensor did not go to ready state

Device Fundamentals Reliability tests require systems with a GPS sensor to be tested in an environment where there is a strong GPS signal (in order for the tests to be able to test I/O on the GPS sensor device). This error indicates that the GPS sensor on the test system cannot get a GPS fix. Please consider running the tests in a location where the test system can get a strong GPS signal.

Test log message: Number of devices found after reboot (1) is not the same as before the reboot (2); please review logs to find the missing device(s)

This message indicates that one of the devices did not come back after reboot. To investigate this failure, generate and analyze the verbose Setupapi logs for Reinstall, Restart, and Reboot tests by executing the following steps:

  1. To generate verbose setupapi logs, set the registry key KEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup!LogLevel to 0x2000ffff
  2. Repro the issue and then review the Setupapi logs at %windir%\inf\setupapi*
  3. To root cause device install issues, see Troubleshooting by Using the Setupapi.log File

If the log contains an error stating that the device was missing or did not start, run !pnptriage from the debugger and review the output. For more information on debugging test failures, see Use kernel debugging to debug Device Fundamentals Reliability test failures.

Related topics

Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK


Reproduce the test failure by running the test from the command line

It is sometimes convenient to reproduce test failures by running the tests from command line. The following documentation assumes that the Hardware Lab Kit (HLK) has already been installed on the controller machine.

Run a Device Fundamentals test from the command line

To run a Device Fundamentals test from the command line:

  1. Create a c:\temp folder on the system under test (SUT).

  2. Copy all files from \\<hckcontroller>\taefbinaries\<arch> folder to c:\temp on the SUT.

    Where <hckcontroller is the name of the Windows Hardware Lab Kit (Windows HLK) controller, and <arch> is the SUT platform.

  3. To install and start the TAEF service, type the following commands from a command prompt:

    1. Go to the 'temp' folder created above:

      On X86 or X64: cd c:\temp

      On ARM or ARM64: cd c:\temp\MinTe

    2. wex.services.exe /install:Te.Service

    3. sc start Te.Service

  4. Copy all files from \\<hckcontroller>\tests\<arch>\DevFund\ directory to c:\temp.

  5. Change directory to c:\temp and run the following command (note that Te.exe lives in c:\temp\MinTe on ARM and ARM64):

    c:\temp\Te.exe Devfund_<testname>.dll /name:"<test case name>" /p:"DQ=DeviceID='<Device Instance Path of device under test from Device Manager>'" /RebootStateFile:state.xml

    Where <test case name> is the name of the test in the test binary.

    The /name switch is optional. Since some test binaries contain multiple tests, the /name switch specifies which tests should be run. If unspecified, all tests contained in the test binary are executed in sequence. The list of tests in a test binary can be obtained by running the following command:

    Te.exe Devfund_<testname>.dll /list

    For example, the Devfund_PnPDTest.dll contains most of the PnP-related tests:

    c:\temp>Te.exe Devfund_PnPDTest.dll /list
Test Authoring and Execution Framework v10.21 for x64

    c:\temp\Devfund_PnPDTest.dll
        PNPDTest
            PNPDTest::PNPDisableAndEnableDevice
            PNPDTest::PNPRemoveAndRestartDevice
            PNPDTest::PNPCancelRemoveDevice
            PNPDTest::PNPCancelStopDevice
            PNPDTest::PNPTryStopAndRestartDevice
            PNPDTest::PNPTryStopDeviceRequestNewResourcesAndRestartDevice
            PNPDTest::PNPTryStopDeviceAndFailRestart
            PNPDTest::PNPSurpriseRemoveAndRestartDevice
            PNPDTest::PNPDIFRemoveAndRescanParentDevice
            PNPDTest::DisableEnhancedDeviceTestingSupport

    The command to run a single test from this test binary might look like this:

    c:\temp\Te.exe Devfund_PnPDTest.dll.dll /name:PNPDTest::PNPSurpriseRemoveAndRestartDevice /p:"DQ=DeviceID='my\device\id'" /RebootStateFile:state.xml

    The name of the test in the test binary will not be exactly the same as the title of the test. For a mapping of test binary names to HLK test names, see Device.DevFund tests.

How to use /BreakOnError to break into the debugger

If the "Run Test" task in a Device Fundamentals test fails and you want to review the system state in the kernel debugger at the same time that the test logs a failure, you can run the test manually from a command prompt together with the kernel debugger and pass the /BreakOnError command line switch to Te.exe.

Running Te.exe with the /BreakOnError switch causes the system to break into the kernel debugger when the test is ready to log an error. For more information on setting up a kernel debugger, see Setting Up Kernel-Mode Debugging Manually.

To run a Device Fundamentals test with the /BreakOnError switch, add the switch as shown below:

Run c:\temp\Te.exe Devfund_<testname>.dll /p:"DQ=DeviceID='<Device Instance Path of device under test from Device Manager>'" /RebootStateFile:state.xml /BreakOnError /name:"*<test case name>*"

Where <test case name> is the name of the test.

Example debug scenario

You can investigate the following failure by re-running the test and having the system break into the debugger when the test logs the failure on re-run.

WDTF_FUZZTEST             : INFO  :    Running IOCTL Fuzzing Test on surface \DosDevices\usb#vid_045e&pid_f0ca&mi_00#7&12099dde&0&0000#{0b9f1048-b94b-dc9a-4ed7-fe4fed3a0deb}\{8de0ff21-6c06-4c27-bfe0-e62612c015ae}. Access Mode=NO SYNC. Open Type=TREE_CONNECT. Opened with access 1201bf

WDTF_FUZZTEST             : ERROR :    Test thread exceeded timeout limit. Terminating thread

WDTF_FUZZTEST             : ERROR :    Last logged operation: ZwDeviceIoControlFile, CtrlCode=0x22e10b, InBuf=0xfffffc00, 0 OutBuf=0xfffffc00, 0

WDTF_FUZZTEST             : INFO  :    Successfully terminated test thread.

You can set a break point in the debugger using the following command:

Te.exe Devfund_FuzzTest_WLK_Certification.dll /p:"DQ=DeviceID='USB\VID_045E&PID_F0CA&MI_00\7&12099DDE&0&0000'" /RebootStateFile:state.xml /BreakOnError /name:"*IOCTLTest*"

Device Fundamentals tests run as Te.ProcessHost.exe (if it exists) or as Te.exe (if Te.ProcessHost.exe doesn't exist). Reviewing threads running in these test processes can help with triaging hangs and/or test failures.

You can get the process id of Te.ProcessHost.exe by running the following command:

!process 0 0 Te.ProcessHost.exe

Switch the process context in the debugger to the test process:

.process /p /r <process id>

Dump process info:

!process <process id>

Related topics

Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK


Review Log Files

When a Device Fundamentals Reliability test fails, you should thoroughly review log entries to help determine the cause of the failure. This topic describes the log files and how to review them.

TestTextLog.log file

TestTextLog.log is a simple text version of the WTT log file (Te.wtl) that is generated by all Device Fundamentals Reliability tests. TestTextLog.logis easier to read than Te.wtl. We recommend that you use TestTextLog.log when you investigate test failures, instead of using the Te.wtl log file. From the Results tab in Windows HLK Studio, right-click the test result, click Additional Files and then click TestTextLog.log

Interpret log entries

Device Fundamentals Reliability tests are written by using the Windows Device Test Framework (WDTF). TestTextLog.log file is a WDTF log file; each WDTF object that performs test actions logs operations to this file. See WDTF Object Logging for more information about how to interpret log entries in TestTextLog.log.

Identify test scenarios

Plug and Play (PNP), power management, and I/O are common scenarios that are tested by Device Fundamentals Reliability tests. You can identify the scenario that is being tested by reviewing the test name and log entries.

Example #1

In this example, Provided WDTF Simple I/O plug-ins test I/O on the WiFi adapter for one minute:

WDTF_SIMPLEIO_STRESS      : INFO  :  - Start(802.11n USB Wireless LAN Card USB\VID_148F&PID_3070\5&35DEE9D9&0&5 )
WDTF_SIMPLE_IO            : INFO  :  - Open(802.11n USB Wireless LAN Card USB\VID_148F&PID_3070\5&35DEE9D9&0&5 ) Try count 1
WDTF_SUPPORT              : INFO  :  - WaitForMinutes : 1
WDTF_SIMPLE_IO            : INFO  :  - PerformIO(802.11n USB Wireless LAN Card USB\VID_148F&PID_3070\5&35DEE9D9&0&5 ) Count 1
WDTF_SIMPLEIO_STRESS      : INFO  :  - Stop(802.11n USB Wireless LAN Card USB\VID_148F&PID_3070\5&35DEE9D9&0&5 )
WDTF_SIMPLE_IO            : INFO  :  - Close(802.11n USB Wireless LAN Card USB\VID_148F&PID_3070\5&35DEE9D9&0&5 )

Example #2

In this example, IWDTFSystemAction2 interface sends the machine state to S1, and then resumes from S1 to test the driver's handling of power IRPs.

WDTF_SYSTEM               : INFO  : Attempt Sleep State: 1 , At (hh:mm:ss): 18:20:58 ,  Wake Time In Seconds: 120
WDTF_SYSTEM               : INFO  : Returning from Sleep. Elapsed time (hh:mm:ss): 0:2:0

Example #3

In this example, IWDTFPNPAction2 interface disables and enables the test device.

WDTF_PNP                  : INFO  :  - DisableDevice()
WDTF_PNP                  : INFO  :          Target: Marvell AVASTAR Wireless-N Network Controller (SDIO) SD\VID_02DF&PID_9128\3&2FF51610&0&0
WDTF_PNP                  : INFO  :  - EnableDevice()   :  ( get status count:  1 )
WDTF_PNP                  : INFO  :          Target: Marvell AVASTAR Wireless-N Network Controller (SDIO) SD\VID_02DF&PID_9128\3&2FF51610&0&0

Related topics

Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK


Troubleshoot WLAN SimpleIO plugin failures that are logged by Device Fundamentals tests

Device Fundamentals tests in Windows Hardware Lab Kit (Windows HLK) and Windows Drivers Kit (WDK) use Windows Device Testing Framework (WDTF) SimpleIO plugins to test device-specific IO when they run. If a WDTF plugin exists for the type of device being tested, then the tests use the IWDTFSimpleIOStressAction2 interface to test I/O on the device.

This article contains information that can help with troubleshooting failures that are logged by the WDTF WLAN SimpleIO plug-in when it is used to test IO on wireless network adapters during device and system testing in WDK and Windows HLK.

Configuration requirements

The WLAN SimpleIO plug-in requires a basic WPA2-PSK wireless network that uses AES that it can connect to when it runs. The SSID and password of the wireless network must be passed in as parameters to the tests that require them. These parameters are named as follows in the tests that require them: Wpa2PskAesSsid and Wpa2PskPassword. The default values of the two parameters are kitstestssid and password, respectively.

Test coverage overview

The WLAN SimpleIO plug-in performs the following tests on the wireless adapter under test:

  1. Finds the Wlan interface that is under test by calling the WlanEnumInterfaces function.

  2. Deletes the test profile that is named WDTFWlanTestProfile (if it exists) by calling the WlanGetProfile() function and the WlanDeleteProfile() function.

  3. Creates a new test profile named WDTFWlanTestProfile by calling the WlanSetProfile() function and by using a profile XML. The profile uses the SSID and password of the wireless network as input parameters to the test.

  4. Connects to the newly created profile by calling the WlanConnect() function. Expect to receive a connect complete notification in 30 seconds.

  5. Checks for connectivity by calling the INetworkListManager::GetConnectivity method of the Network List Manager API, and looks for NLM_CONNECTIVITY enumeration NLM_CONNECTIVITY_IPV4_INTERNET or NLM_CONNECTIVITY_IPV4_LOCALNETWORK flags to be set. The plug-in calls the GetConnectivity() function several times (if required) as it waits for a connection, before it eventually times out and reports an error.

  6. Calls the GetAdaptersInfo() function to determine the gateway address that corresponds to the test adapter.

  7. Opens an ICMP handle by calling IcmpCreateFile() function, and calls an internal function in a loop for several minutes that pings the IPv4 gateway address (by using the IcmpSendEcho() function with one-second timeout) 500 times each time it is called, and logs an error message if at any time it is called, the failure rate is >10%.

  8. Disconnects from the network by calling the WlanDisconnect() function.

  9. Deletes the test profile by calling the WlanGetProfile() function and the WlanDeleteProfile() function.

Troubleshooting guidance

Identify failures that are logged by the WLAN SimpleIO plugin

The error messages logged by the plug-in will contain the text "WirelessPlugin:". The text that immediately follows "WirelessPlugin:" provides more context about the errors. For example:

WDTF_SIMPLE_IO            : ERROR :  - Open(802.11n USB Wireless LAN Card USB\VID_XXXX&PID_XXXX\5&35DEE9D9&0&5 ) Failed : WirelessPlugin: ConnectToTestProfile() - Failed to connect to test profile; Reason string: "The specific network is not available." HRESULT=0x80004005

General troubleshooting guidance

We recommend that you follow troubleshooting steps in the listed order:

  1. Review the test documentation to understand the test scenario.

  2. Review Test coverage overview to understand how the plugin tests a device or driver.

  3. Carefully review log entries that precede the error message, and the error message itself, to understand the test scenario and the reason for the failure.

  4. Troubleshoot the router setup. Make sure that you can manually connect to the router, that you can ping the gateway address after making the connection, and that the router is in range to the test computer. If the router fails any of these tests, reset the router.

  5. Enable tracing in the test driver and review driver traces from the time when the test logged the error(s).

  6. Enable WLAN OS tracing and review traces that are logged from the time when the logged the error(s). For more information about WLAN OS tracing, see Tools for Troubleshooting using Network Tracing in Windows 7.

In some cases, it is helpful to run the failing test manually from a command line (without using Windows HLK or WDK), and then reviewing the plug-in's WPP traces. See How to run tests from the command line and View WLAN plug-in traces.

How to run tests from the command line

We recommend that you use a Windows HLK Client to run tests manually because Windows HLK clients have WDTF installed on them. Follow the steps in How to run the Windows HLK device fundamentals tests on the command line. Enable Driver Verifier on Ndis.sys and the test Wi-Fi driver.

View WLAN plug-in traces

The WLAN plugin uses WPP tracing to trace information and errors that you might find useful when you investigate failures that are logged by the WLAN plug-in. See Collect and View Windows Device Testing Framework (WDTF) Traces for instructions on how to collect and view WDTF traces.

NOTE

WDTF_Action_SimpleIO_Wireless is the name of the provider that you can use for filtering.

Sample trace output

                               -->this(047BB318):?FinalConstruct@CWirelessImpl@@QEAAJXZ(void)
                               <--this(047BB318):?FinalConstruct@CWirelessImpl@@QEAAJXZ(): S_OK
                               o->this(047BB318):?SetTarget@CWirelessImpl@@UEAAJPEAUITarget@@UtagVARIANT@@@Z(pMainTarget = 0476BBAC, MoreTargets = 8)
                                    INFO:Calling WlanOpenHandle() function
                                    INFO:Calling WlanEnumInterfaces() function to find wlan interface under test: N300 USB Network Adapter" ({4138C082-E821-433C-ABB8-6FF864BF80B5})"
                                    INFO:Found 1 wlan interfaces in total
                                    INFO:Processing wlan interface: N300 USB Network Adapter""
                                    INFO:Found the wlan interface under test!
                                    INFO:Interface information: Interface Guid: {4138C082-E821-433C-ABB8-6FF864BF80B5}; Interface State: disconnected""
                               o<-this(047BB318):?SetTarget@CWirelessImpl@@UEAAJPEAUITarget@@UtagVARIANT@@@Z(): S_OK
           o->this(047BB318):?Open@CWirelessImpl@@UEAAJXZ(void)
                INFO:Calling WlanOpenHandle() function
                -->this(047BB318):?FindAndDeleteTestProfile@CWirelessImpl@@AEAAJXZ(void)
                     INFO:Test profile WDTFWlanTestProfile" doesn't exist"
                o<-this(047BB318):?FindAndDeleteTestProfile@CWirelessImpl@@AEAAJXZ(): S_OK
                -->this(047BB318):?CreateTestProfile@CWirelessImpl@@AEAAJXZ(void)
                     INFO:Calling WlanSetProfile() with a profile XML to create a profile with name: WDTFWlanTestProfile"
                o<-this(047BB318):?CreateTestProfile@CWirelessImpl@@AEAAJXZ(): S_OK
                -->this(047BB318):?ConnectToTestProfile@CWirelessImpl@@AEAAJXZ(void)
                     INFO:Calling WlanRegisterNotification() to get notified of connect complete event
                     INFO:Calling WlanConnect() to connect to test profile with name: WDTFWlanTestProfile""
                     INFO:Waiting to receive connect complete notification
                     INFO:Received connect complete notification: 0
                     INFO:Calling WlanRegisterNotification() to unregister from notifications
                o<-this(047BB318):?ConnectToTestProfile@CWirelessImpl@@AEAAJXZ(): S_OK
                INFO:Calling an internal helper function to check for the connectivity state of the network connection
                -->this(047BB318):?CheckForConnectivity@CWirelessImpl@@AEAAJPEA_N@Z(void)
                     INFO:Creating an instance of the NLM COM object
                     INFO:Calling NLM GetNetworkConnections() to get a list of network connections
                     INFO:Iterating through the network connections found looking for the connection corresponding to the test adapter ({4138C082-E821-433C-ABB8-6FF864BF80B5})
                     INFO:Calling NLM GetAdapterId() on a network connection found
                     INFO:Calling NLM GetAdapterId() on a network connection found
                     INFO:Found a network connection using the test adapter!
                     INFO:Calling NLM GetConectivity() on a network connection using the test adapter
                     INFO:NLM GetConectivity() reported the following connectivity state: 66
                     INFO:NLM GetConectivity() reported IPv4 connectivity!
                o<-this(047BB318):?CheckForConnectivity@CWirelessImpl@@AEAAJPEA_N@Z(): S_OK
                -->this(047BB318):?RefreshIPInfo@CWirelessImpl@@AEAAJXZ(void)
                     INFO:Calling GetAdaptersInfo() function to find IP address info for adapter {4138C082-E821-433C-ABB8-6FF864BF80B5}""
                     INFO:Found the adapter we are looking for!
                     INFO:Adapter Info: Index: 4, IPv4 Address: 192.168.1.147, Gateway Address: 192.168.1.1
                o<-this(047BB318):?RefreshIPInfo@CWirelessImpl@@AEAAJXZ(): S_OK
                INFO:Calling IcmpCreateFile() function
                INFO:Pinging gateway (192.168.1.1) 10 times
                -->this(047BB318):?TestPingGateway@CWirelessImpl@@AEAAJHH@Z(numPings: 10)
                     INFO:Calling IcmpSendEcho() to ping gateway (192.168.1.1) 10 times with a random input buffer of size 255 and a timeout value of 1000 milliseconds
                o<-this(047BB318):?TestPingGateway@CWirelessImpl@@AEAAJHH@Z(): S_OK
           o<-this(047BB318):?Open@CWirelessImpl@@UEAAJXZ(): S_OK
           o->this(047BB318):?RunIO@CWirelessImpl@@UEAAJXZ(void)
                -->this(047BB318):?TestPingGateway@CWirelessImpl@@AEAAJHH@Z(numPings: 500)
                     INFO:Calling IcmpSendEcho() to ping gateway (192.168.1.1) 500 times with a random input buffer of size 255 and a timeout value of 1000 milliseconds
                o<-this(047BB318):?TestPingGateway@CWirelessImpl@@AEAAJHH@Z(): S_OK
           o<-this(047BB318):?RunIO@CWirelessImpl@@UEAAJXZ(): S_OK
           o->this(047BB318):?RunIO@CWirelessImpl@@UEAAJXZ(void)
                -->this(047BB318):?TestPingGateway@CWirelessImpl@@AEAAJHH@Z(numPings: 500)
                     INFO:Calling IcmpSendEcho() to ping gateway (192.168.1.1) 500 times with a random input buffer of size 255 and a timeout value of 1000 milliseconds
                o<-this(047BB318):?TestPingGateway@CWirelessImpl@@AEAAJHH@Z(): S_OK
           o<-this(047BB318):?RunIO@CWirelessImpl@@UEAAJXZ(): S_OK
...
...
...
           o->this(047BB318):?Close@CWirelessImpl@@UEAAJXZ(void)
                -->this(047BB318):?DisconnectFromTestProfile@CWirelessImpl@@AEAAJXZ(void)
                     INFO:Calling WlanDisconnect() to disconnect
                o<-this(047BB318):?DisconnectFromTestProfile@CWirelessImpl@@AEAAJXZ(): S_OK
                -->this(047BB318):?FindAndDeleteTestProfile@CWirelessImpl@@AEAAJXZ(void)
                     INFO:Calling WlanDeleteProfile() to delete the previously created test profile with name WDTFWlanTestProfile""
                o<-this(047BB318):?FindAndDeleteTestProfile@CWirelessImpl@@AEAAJXZ(): S_OK
           o<-this(047BB318):?Close@CWirelessImpl@@UEAAJXZ(): S_OK

Related topics

Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK

Troubleshooting Windows HLK

Windows HLK Support


Use kernel debugging to debug Device Fundamentals Reliability test failures

This describes how to use common kernel debugging commands to debug Device Fundamentals Reliability test failures.

Set symbols

You can find Windows Hardware Lab Kit content symbols on the Microsoft Public Symbols Server site. See Use the Microsoft Symbol Server to obtain debug symbol files for more information about the Microsoft Public Symbols Server. You can set symbols in the kernel debugger by running the .sympath (Set Symbol Path) command.

Example:

In this example,the .sympath command sets the public symbols server path in the debugger.

.sympath SRV*c:\localsymbols*http://msdl.microsoft.com/download/symbols

!analyze -v

When you investigate test failures that are caused by system bug checks from the kernel debugger, the first command that should you should issue after you set symbols is !analyze. This command identifies the bug check code, the reason for the bug check, and the stack trace that shows the faulting component. See Using the !analyze Extension for more information about this command.

Inspect stack traces of the test process

Device Fundamentals Reliability tests often run as Te.ProcessHost.exe or Te.exe on the test computer. It is useful to review stack traces from these test processes when you investigate system bug checks or test hangs. In the case of bug checks, stack traces can help identify the test case that was being tested at the time of the crash. In the case of test hangs, stack traces identify any test threads that prevent the test from progressing.

You can use the !process 0 0 extension to list all processes that are running on the test computer, to find the test process EPROCESS block address.

You can then use the !process /p /r extension to get full stack traces from the test processes.

For more information about the !process extension, see !process and .process (Set Process Context).

Note that !process output contains tick counts for each thread that is running in the process. When you investigate test hangs, threads that have a high tick count that contain WDTF components on the stack (that is, module names that start with "WDTF" on the stack) should be reviewed carefully because these threads can cause the tests to permanently hang and eventually fail because of a timeout.

Example:

In this example, !process 0 0, !process /p /r, and !process extensions identify a test thread that has a very high tick count, that prevents the test from progressing:

!process 0 0 Te.ProcessHost.exe
    PROCESS fffffa80093c6340
    SessionId: 1 Cid: 1320 Peb: 7f6595b3000 ParentCid: 12a0
    DirBase: 21eee000 ObjectTable: fffff8a0035b0a00 HandleCount: 327.
    Image: TE. ProcessHost.exe
.process /p /r fffffa80093c6340

!process fffffa80093c6340

        THREAD fffffa800b2be8c0  Cid 0964.0eac  Teb: 000007f601ba6000 Win32Thread: 0000000000000000 WAIT: (UserRequest) UserMode Non-Alertable
            fffffa800b2a11d0  SynchronizationEvent
            fffffa800b300640  SynchronizationEvent
        Not impersonating
        DeviceMap                 fffff8a0014b9c80
        Owning Process            fffffa800b302940       Image:         TE.exe
        Attached Process          N/A            Image:         N/A
        Wait Start TickCount      210995         Ticks: 405945 (0:01:45:32.782)
        Context Switch Count      51             IdealProcessor: 2
        UserTime                  00:00:00.015
        KernelTime                00:00:00.015
        Win32 Start Address WDTFInterfaces!TsSingleWorkerThread (0x000007fe3a567f28)
        Stack Init fffff8800eb5edd0 Current fffff8800eb5dee0
        Base fffff8800eb5f000 Limit fffff8800eb59000 Call 0
        Priority 9 BasePriority 8 UnusualBoost 0 ForegroundBoost 0 IoPriority 2 PagePriority 5
        Kernel stack not resident.
        Child-SP          RetAddr           Call Site
        fffff880`0eb5df20 fffff803`78b27f7c nt!KiSwapContext+0x76
        (Inline Function) --------`-------- nt!KiSwapThread+0xf4 (Inline Function @ fffff803`78b27f7c)
        fffff880`0eb5e060 fffff803`78aaf4ab nt!KiCommitThreadWait+0x23c
        fffff880`0eb5e120 fffff803`78b257a0 nt!KiWaitForAllObjects+0x3bb
        fffff880`0eb5e3c0 fffff803`78ecb3dc nt!KeWaitForMultipleObjects+0x4ae
        fffff880`0eb5e470 fffff803`78ecb853 nt!ObWaitForMultipleObjects+0x29c
        fffff880`0eb5e980 fffff803`78aff053 nt!NtWaitForMultipleObjects+0xe3
        fffff880`0eb5ebd0 000007fe`45d2315b nt!KiSystemServiceCopyEnd+0x13 (TrapFrame @ fffff880`0eb5ec40)
        00000083`7cdef148 000007fe`430912c6 ntdll!ZwWaitForMultipleObjects+0xa
        00000083`7cdef150 000007fe`368641b5 KERNELBASE!WaitForMultipleObjectsEx+0xe5
        00000083`7cdef430 000007fe`3a566793 WDTFAudioSimpleIoAction!CAudioImpl::RunIO+0x3d1
        00000083`7cdef520 000007fe`3a566ea0 WDTFInterfaces!CSimpleIOEx::PerformIO+0x10f
        00000083`7cdef5b0 000007fe`3a56706b WDTFInterfaces!CSimpleIOExWrap::PerformIO+0x28
        00000083`7cdef5e0 000007fe`3a553fe5 WDTFInterfaces!CMTest_Receiver::Run+0x77
        00000083`7cdefe20 000007fe`3a5578ac WDTFInterfaces!CSimpleIO_MTestEx::ActionThread+0x105
        00000083`7cdefeb0 000007fe`3a567f3e WDTFInterfaces!CMTEXThread::ThreadWorker+0xc
        00000083`7cdefee0 000007fe`4319167e WDTFInterfaces!TsSingleWorkerThread+0x16
        00000083`7cdeff20 000007fe`45d3c3f1 KERNEL32!BaseThreadInitThunk+0x1a
        00000083`7cdeff50 00000000`00000000 ntdll!RtlUserThreadStart+0x1d

Switch context to threads and frames to view locals

To view local variables from a stack frame, you must perform the following actions:

  1. Switch context to the thread by using the .thread (Set Register Context) command.

  2. Dump the stack together with frame numbers by using the kn command (see Stack and Dump Logging.

  3. Switch to frame context by using the .frame (Set Local Context) command.

  4. View locals by using the dv (Display Local Variables) command.

NOTE

You must use private symbols to dump local variables.

Example:

This example uses .thread, kn, .frame, and dv commands to dump local variables from a stack frame:

3: kd> .thread fffffa8009da7b00
Implicit thread is now fffffa80`09da7b00

3: kd> kn
  *** Stack trace for last set context - .thread/.cxr resets it
# Child-SP          RetAddr           Call Site
00 fffff880`054a03a0 fffff801`05caaf7c nt!KiSwapContext+0x76
01 fffff880`054a04e0 fffff801`05ca8d9f nt!KiCommitThreadWait+0x23c
02 fffff880`054a05a0 fffff801`05f98841 nt!KeWaitForSingleObject+0x1cf
03 fffff880`054a0630 fffff801`061f253d nt!IopCancelAlertedRequest+0x71
04 fffff880`054a0670 fffff801`0604fc5d nt! ?? ::NNGAKEGL::`string'+0x1caaf
05 fffff880`054a0860 fffff801`060552b8 nt!ObpLookupObjectName+0x7a1
06 fffff880`054a0990 fffff801`06066ebe nt!ObOpenObjectByName+0x258
07 fffff880`054a0a60 fffff801`06067609 nt!IopCreateFile+0x37c
08 fffff880`054a0b00 fffff801`05c82053 nt!NtCreateFile+0x79
09 fffff880`054a0b90 000007fa`1a4930fa nt!KiSystemServiceCopyEnd+0x13
0a 00000038`d21bb478 000007fa`0677feef ntdll!NtCreateFile+0xa
0b 00000038`d21bb480 000007fa`0678e9a2 WDTFFuzzTestAction!DPETryOpenDevice+0x2b3
0c 00000038`d21bcde0 000007fa`0678e892 WDTFFuzzTestAction!CWDTFFuzz_MTestImpl::AttemptToOpenSurface+0x66
0d 00000038`d21bce50 000007fa`0678b84c WDTFFuzzTestAction!CWDTFFuzz_MTestImpl::FindAttackSurfaces+0x16e
0e 00000038`d21bf6c0 000007fa`0678a4d9 WDTFFuzzTestAction!CWDTFFuzz_MTestImpl::ActionThread+0x200
0f 00000038`d21bf760 000007fa`1a17167e WDTFFuzzTestAction!ActionThreadStart+0x9
10 00000038`d21bf790 000007fa`1a4ac3f1 KERNEL32!BaseThreadInitThunk+0x1a
11 00000038`d21bf7c0 00000000`00000000 ntdll!RtlUserThreadStart+0x1d

3: kd> .frame b
0b 00000038`d21bb480 000007fa`0678e9a2 WDTFFuzzTestAction!DPETryOpenDevice+0x2b3

3: kd> dv
szName = 0x00000038`d21bce90
bSync = 0n0
ppdevice = 0x00000038`d21bce10
messageBuffer = wchar_t [2048] "Attempting to open device : \DosDevices\root#multiportserial#0000#{05caff94-7b1e-420c-8c70-d8361bc4ee0a}"
oa = struct _OBJECT_ATTRIBUTES

!pnptriage

When you debug Device Fundamentals Reliability test hangs, you can use the !pnptriage command to list active PNP threads. Note that !pnptriage output contains tick counts for each PNP thread that is running in the system. When you investigate test hangs, threads that have high tick counts should be carefully reviewed because these threads can cause the tests to permanently hang and eventually fail because of a timeout.

Driver debugging extensions

The following kernel debugger extensions can debug driver issues that can occur when you run Device Fundamentals Reliability tests: !drvobj, !devnode, !devobj, !devstack, and !irp. For more information about these extensions, see Kernel-Mode Extensions.

Debugger extensions

Debugging Tools for Windows ships with additional debugger extensions that are useful to troubleshoot failures that can occur when you run tests against the following types of drivers: USB, Storage, NDIS, Graphics, Kernel-Mode Driver Framework (KMDF), and User-Mode Driver Framework (UMDF). For more information about these extensions, see Specialized Extensions. For more information about debugging tools for Windows, see Download and Install Debugging Tools for Windows.

Related topics

Troubleshooting Device Fundamentals Reliability Testing by using the Windows HLK


Windows Server Must-Fix Code Analysis and Static Driver Verifier Errors affecting Network and Storage Adapter Vendors

Overview

If your company manufactures a Network or Storage adapter that is to be Certified for Windows Server 2016, there are Code Analysis (CA) and Static Driver Verifier (SDV) driver source code errors which are considered Must-Fix in order for the driver to be successfully certified for Windows Server 2016.

The SDV user interface highlights these errors specifically for NDIS and Network related interface calls that are incorrect and considered Must-Fix in order to get a driver Certified for Windows Server 2016. The Storage interface calls are planned to be called out as well, but that functionality is not complete at this time.

The CA user interface does not currently highlight the errors it detects in Network and Storage driver sources that are incorrect and considered Must-Fix in order to get a driver Certified for Windows Server 2016. That work is planned for future versions of the CA tool.

Criteria for Rules Selection as Must-Fix

The criteria for the SDV and CA Rules which have been selected for Network and Storage adapter drivers as being Must-Fix in order to get a driver Certified for Windows Server 2016 are as follows:

  • Accuracy - the Rule finds code errors with a low false failure rate
  • Impact - the code error can cause data corruption, hangs or crashes
  • Data Driven - the code error caused a problem in a driver that crashed and was analyzed as part of Microsoft's Online Crash Analysis tool, OCA.
  • Experience - the code error is one included in the internal bar used by Microsoft, with high impact and security issues always being fixed
  • Minimal Annotation - there is low dependency on annotations of the driver's sources in order for the CA and SDV tools to function. Note however that some annotations are required.
NOTE

There are a few CA Rules below for which there are no links in MSDN, which are called out below. The functionality for checking these in Visual Studio Express 2013 does not exist, so other versions of Visual Studio must be used. However, the errors are generally self-explanatory.

For all other Rules, the link can be found by searching on MSDN.

For convenience, there is a short snippet of text from the links, but the links themselves usually contain more text and code examples of both correct and incorrect usage to illustrate the needed change(s).

CA Rules

C6001:USING UNINITIALIZED MEMORY
This warning is reported when an uninitialized local variable is used before it is assigned a value. This could lead to unpredictable results.

C6011:DEREFERENCING A NULL POINTER
This warning indicates that a null pointer is being dereferenced. If the pointer value is invalid, the result is undefined.

C6014:LEAKING MEMORY
This warning indicates that the specified pointer points to allocated memory or some other allocated resource that has not been freed.

C6063:MISSING_STRING_ARGUMENT_TO_FORMAT_FUNCTION
This defect can cause crashes and buffer overflows (if the called function is of the sprintf family), as well as potentially incorrect output.

C6214:CAST_HRESULT_TO_BOOL
Any comparison that uses the Boolean variable to test for HRESULT success or failure could lead to incorrect results.

C6215:CAST_BOOL_TO_HRESULT
Casting a Boolean type to an HRESULT and then using it in a test expression will yield an incorrect result.

C6216:COMPILER_INSERTED_CAST_BOOL_TO_HRESULT
The typical failure value for functions that return a Boolean false is a success status when it is tested as an HRESULT. This is likely to lead to incorrect results.

C6230:USING_HRESULT_IN_BOOLEAN_CONTEXT
This warning indicates that a bare HRESULT is being used in a context, such as if statement, where a Boolean result is expected. This is likely to yield incorrect results.

C6248:CREATINGNULLDACL
This warning identifies a call that sets a SECURITY_DESCRIPTOR's DACL field to null, which grants full access to any user who requests it; normal security checking is not performed with respect to the object. Objects that have null DACLs can have their security descriptors altered by malicious users so that no one has access to the object.

C6259:DEADCODEINBITORLIMITEDSWITCH
This warning indicates unreachable code caused by the result of a bitwise-AND (&) comparison in a switch expression

C6260:USEOFBYTEAREA
This warning indicates that the results of two sizeof operations have been multiplied together.

C6268:MISPARENTHESIZED_CASTS
This warning indicates that a complex cast expression might involve a precedence problem when performing pointer arithmetic. In some cases, this defect causes incorrect behavior or a program crash.

C6276:CHAR_TO_WCHAR_CAST
This warning indicates a potentially incorrect cast from an ANSI string (char_t*) to a UNICODE string (wchar_t *). Using such strings with the wcs* library of functions could cause buffer overruns and access violations.

C6277:CREATEPROCESS_ESCAPE
This warning indicates that the application name parameter is null and there might be spaces in the executable path name. A malicious user might insert a rogue executable with the same name earlier in the path.

C6281:BITWISERELATIONPRECEDENCEERROR
This warning indicates a possible error in the operator precedence. This might produce incorrect results.

C6282:ASSIGNMENTREPLACESTEST
This warning indicates that an assignment of a constant to a variable was detected in a test context.

C6284:OBJECT_AS_STRING_ARGUMENT_TO_FORMAT_FUNCTION
This warning indicates that the format string specifies a string, for example, a %s specification for printf or scanf, but a C++ object has been passed instead.

C6287:REDUNDANTTEST
This warning indicates that a redundant element was detected in an expression.

C6288:MUTUALINCLUSIONOVERANDISFALSE
This warning indicates that in a test expression, a variable is being tested against two different constants and the result depends on both conditions being true.

C6289:MUTUALEXCLUSIONOVERORISTRUE
This warning indicates that in a test expression a variable is being tested against two different constants and the result depends on either condition being true. This always evaluates to true.

C6290:LOGICALNOTBITWISEAND
This warning indicates possible confusion in the use of an operator or an operator precedence.

C6291:LOGICALNOTBITWISEOR
The ! operator yields a Boolean result, and the | (bitwise-or) operator takes two arithmetic arguments. It is difficult to judge the severity of this problem without examining the code

C6293:LOOP_INDEX_GOES_NEGATIVE
This warning indicates that a for-loop might not function as intended.

C6295:INFINITE_LOOP
No link in MSDN

C6296:LOOP_ONLY_EXECUTED_ONCE
This warning indicates that a for-loop might not function as intended

C6299:BITFIELD_TO_BOOL_COMPARISON
This warning indicates an incorrect assumption that Booleans and bit fields are equivalent. The comparison can yield unexpected results.

C6305:SIZEOF_COUNTOF_MISMATCH
This will cause unexpected scaling in pointer arithmetic.

C6306:INCORRECT_VARARG_FUNCTIONCALL
This warning indicates an incorrect function call.

C6308:REALLOCLEAK
This warning indicates a memory leak that is the result of the incorrect use of a reallocation function.

C6312:EXCEPTIONCONTINUEEXECUTION
This warning indicates the use of the constant EXCEPTION_CONTINUE_EXECUTION. This can cause an infinite loop.

C6318:EXCEPTIONCONTINUESEARCH
This warning indicates that if an exception occurs in the protected block of this structured exception handler, the exception will not be handled because the constant EXCECPTION_CONTINUE_SEARCH is used in the exception filter expression. This code is equivalent to the protected block without the exception handler block because the handler block is not executed.

C6328:FORMAT_SIZE_MISMATCH
For C runtime character-based routines in the family name isxxx(), passing an argument of type char can have unpredictable results.

C6384:DIVIDING_SIZEOF_POINTER
This warning indicates that a size calculation might be incorrect.

C26110:FAILING TO HOLD LOCK BEFORE CALLING FUNCTION
No link in MSDN

C28126:OBJ_REFERENCE_MODE
Driver is passing UserMode or KernelMode for the AccessMode parameter, instead of using Irp->RequestorMode.

C28128:FUNCTION_ASSIGNMENT
The driver directly accessed a structure member that should be accessed only by using specialized functions.

C28134:POOL_TAG
No link in MSDN

C28135:KE_WAIT_LOCAL
If the first argument to KeWaitForSingleObject is a local variable, the Mode parameter must be KernelMode

C28145:MODIFYING_MDL
The opaque MDL structure should not be modified by a driver

C28157:IRQL_NOT_USED
There is at least one path in which the driver is executing at a different IRQL when the function completes.

C28158:IRQL_NOT_SET
There is at least one path in which the IRQL value is not saved in that variable.

C28163:MUST_NOT_TRY
This warning is reported when a function is of a type that should never be enclosed in a try/except block is found in a try/except block.

C28164:PVOID
This warning is reported when a pointer to a pointer is used in a call to a function that is expecting a pointer to an object.

C28170:NO_PAGED_CODE
The function has been declared to be in a paged segment, but neither PAGED_CODE nor PAGED_CODE_LOCKED was found

C28171:MULTIPLE_PAGED_CODE
The function has more than one instance of PAGED_CODE or PAGED_CODE_LOCKED

C28719:BANNED_API_USAGE
This warning indicates that a function is being used that has been banned, and has a more robust and secure replacement.

C28726:BANNED_API_USAGEL2
This warning indicates that a function is being used that has been banned, and has a more robust and secure replacement.

C28735:BANNED_CRIMSON_API_USAGE
This warning indicates that a function is being used that has been banned, and has a more robust and secure replacement. ETW is the replacement

C28736:BANNED_API_ARGUMENT_USAGE
This warning indicates that a function is being used that has been banned, and has a more robust and secure replacement. ETW is the replacement

C28750:BANNED_API_USAGE_LSTRLEN
This warning indicates that a function is being used that has been banned, and has better replacements.

C28751:BANNED_API_USAGE_EXALLOCATEPOOL
Banned usage of ExAllocatePool and its variants. This warning indicates that a function is being used that has been banned, and has a more robust and secure replacement.

Rules needed for SDV to work as well as possible

The below CA outputs are not errors per se, but rather indicate where some annotation is required in order for Static Driver Verifier to work as well as possible.

C28168:
This warning supports Static Driver Verifier by checking that each function assigned into the dispatch table is annotated with one or more _Dispatch_type_ annotations

C28169:
This warning supports Static Driver Verifier by checking that each function assigned into the dispatch table is annotated with one or more _Dispatch_type_ annotations

C28101:
The Drivers module has inferred that the current function is a <function-type> function

C28022:
The function class(es) on this function do not match the function class(es) on the typedef used to define it.

C28023:
The function being assigned or passed should have a _Function_class_ annotation for at least one of the class(es)

C28024:
The function pointer being assigned to is annotated with the function class, which is not contained in the function class(es) list.

C28155:
Driver routine was not declared with the correct Role type

C28208:
Function signature doesn't match with the function declarations

SDV Rules

Network

DoubleComplete
The DoubleComplete rule specifies that NDIS drivers must not complete an object identifier (OID) request multiple times.

DoubleCompleteWorkItem
The DoubleCompleteWorkItem rule specifies that NDIS drivers must not complete an OID request multiple times when the completion is deferred in a work item.

Init_DeRegisterInterrupt
The Init_DeRegisterInterrupt rule specifies that if NdisMRegisterInterruptEx is called at least once during MPInitilize, NdisMDeregisterInterruptEx should be called at least once in MPHaltEx.

Init_NdisAllocateIoWorkItem
The Init_NdisAllocateIoWorkItem rule specifies that if NdisAllocateIoWorkItem is called at least once during MiniportInitializeEx, the NdisFreeIoWorkItem function should;

  • be called at least once in MPHaltEx, if MiniportInitializeEx succeeds
  • be called in MiniportInitializeEx, if MiniportInitializeEx fails

Init_RegisterInterrupt
The Init_RegisterInterrupt rule specifies that the registration of interrupts, which usually happens during initialization, must be undone if something goes wrong in the initialization process or during the halting of the miniport driver. If NdisMRegisterInterruptEx is called at least one time during MiniportInitializeEx, the NdisMDeregisterInterruptEx function must be called at least one time in MiniportHaltEx.

Init_RegisterSG
The Init_RegisterSG rule specifies that the registration of the scatter-gather list (SG), which usually happens during initialization, must be undone if something goes wrong in the initialization process or during the halting of the miniport driver. If NdisMRegisterScatterGatherDma is called at least one time during MiniportInitializeEx, the NdisMDeregisterScatterGatherDma function should be called at least one time in MiniportHaltEx.

Irql_CallManager_Function
The Irql_CallManager_Function rule specifies that the NDIS functions for the NDIS CallManager must be called at correct IRQL levels. This rule examines the following NDIS functions;

  • NdisCmActivateVc
  • NdisCmAddPartyComplete
  • NdisCmCloseAddressFamilyComplete
  • NdisCmCloseCallComplete
  • NdisCmDeactivateVc
  • NdisCmDeregisterSapComplete
  • NdisCmDispatchCallConnected
  • NdisCmDispatchIncomingCall
  • NdisCmDispatchIncomingCallQoSChange
  • NdisCmDispatchIncomingCloseCall
  • NdisCmDispatchIncomingDropParty
  • NdisCmDropPartyComplete
  • NdisCmMakeCallComplete
  • NdisCmModifyCallQoSComplete
  • NdisCmNotifyCloseAddressFamily
  • NdisCmOpenAddressFamilyComplete
  • NdisCmRegisterAddressFamilyEx
  • NdisCmRegisterSapComplete

Irql_Connection_Function
The Irql_Connection_Function rule specifies that the NDIS connection functions for protocol drivers must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisCoAssignInstanceName
  • NdisCoCreateVc
  • NdisCoDeleteVc
  • NdisCoGetTapiCallId
  • NdisCoOidRequest
  • NdisCoOidRequestComplete
  • NdisCoSendNetBufferLists

Irql_Filter_Driver_Function
The Irql_Filter_Driver_Function rule specifies that the NDIS functions for filter drivers must be called at correct IRQL levels. The NDIS functions for filter drivers include the following;

  • NdisFRegisterFilterDriver
  • NdisFDeregisterFilterDriver
  • NdisFSetAttributes
  • NdisFRestartFilter
  • NdisFRestartComplete
  • NdisFPauseComplete
  • NdisFSendNetBufferLists
  • NdisFReturnNetBufferLists
  • NdisFSendNetBufferListsComplete
  • NdisFCancelSendNetBufferLists
  • NdisFIndicateReceiveNetBufferLists
  • NdisFNetPnPEvent
  • NdisFDevicePnPEventNotify
  • NdisEnumerateFilterModules

Irql_Gather_DMA_Function
The Irql_Gather_DMA_Function rule specifies that the NDIS scatter/gather DMA functions must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisMAllocateNetBufferSGList
  • NdisMAllocateSharedMemoryAsyncEx
  • NdisMDeregisterScatterGatherDma
  • NdisMFreeNetBufferSGList
  • NdisMRegisterScatterGatherDma

Irql_IM_Function
The Irql_IM_Function rule specifies that the NDIS functions for Intermediate (IM) drivers must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisIMAssociateMiniport
  • NdisIMCancelInitializeDeviceInstance
  • NdisIMDeInitializeDeviceInstance
  • NdisIMGetBindingContext
  • NdisIMInitializeDeviceInstanceEx

Irql_Interfaces_Function
The Irql_Interfaces_Function rule specifies that the NDIS network interface functions must be called at correct IRQL levels. This rule verifies the following NDIS network interface functions; NdisIfAddIfStackEntry,

  • NdisIfAllocateNetLuidIndex
  • NdisIfDeleteIfStackEntry
  • NdisIfDeregisterInterface
  • NdisIfDeregisterProvider
  • NdisIfFreeNetLuidIndex
  • NdisIfGetInterfaceIndexFromNetLuid
  • NdisIfGetNetLuidFromInterfaceIndex
  • NdisIfQueryBindingIfIndex
  • NdisIfRegisterInterface
  • NdisIfRegisterProvider

Irql_Interrupt_Function
The Irql_Interrupt_Function rule specifies that the NDIS functions for interrupts must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisMDeregisterInterruptEx
  • NdisMRegisterInterruptEx

Irql_IrqlSetting_Function
The Irql_IrqlSetting_Function rule specifies that the NDIS interrupt macros must be called at correct IRQL levels. This rule verifies the following NDIS macros;

  • NDIS_LOWER_IRQL
  • NDIS_RAISE_IRQL_TO_DISPATCH"

Irql_MCM_Function
The Irql_MCM_Function rule specifies that the NDIS MCM functions for drivers must be called at correct IRQL levels.

Irql_MCO_Function
The Irql_MCO_Function rule specifies that the NDIS MCO DDIs for miniport drivers must be called at correct IRQL levels.

Irql_Miniport_Driver_Function
The Irql_Miniport_Driver_Function rule specifies that the NDIS functions for miniport drivers must be called at correct IRQL levels. This rule verifies functions for NDIS miniport driver logging, NDIS ports, and NDIS DMA interface;

  • NdisMCreateLog
  • NdisMDeregisterDmaChannel
  • NdisMDeregisterIoPortRange
  • NdisMDeregisterMiniportDriver
  • NdisMFlushLog
  • NdisMFreePort
  • NdisMFreeSharedMemory
  • NdisMGetDeviceProperty
  • NdisMGetDmaAlignment
  • NdisMMapIoSpace
  • NdisMPauseComplete
  • NdisMQueryAdapterInstanceName
  • NdisMReadDmaCounter
  • NdisMRegisterDmaChannel
  • NdisMRegisterIoPortRange
  • NdisMRegisterMiniportDriver
  • NdisMRemoveMiniport
  • NdisMResetComplete
  • NdisMRestartComplete
  • NdisMSetMiniportAttributes
  • NdisMSetupDmaTransfer
  • NdisMSleep
  • NdisMUnmapIoSpace
  • NdisMUpdateSharedMemory
  • NdisMWriteLogData

Irql_Miscellaneous_Function
The Irql_Miscellaneous_Function rule specifies that the NDIS functions must be called at correct IRQL levels. This rule verifies the following functions;

  • KeGetCurrentProcessorNumber
  • NdisAllocateFromNPagedLookasideList
  • NdisAllocateGenericObject
  • NdisAllocateIoWorkItem
  • NdisAllocateMemoryWithTagPriority
  • NdisAnsiStringToUnicodeString
  • NdisCloseConfiguration
  • NdisCloseFile
  • NdisDeleteNPagedLookasideList
  • NdisDeregisterDeviceEx
  • NdisEqualMemory
  • NdisEqualUnicodeString
  • NdisFreeGenericObject
  • NdisFreeIoWorkItem
  • NdisFreeMemory
  • NdisFreeSpinLock
  • NdisFreeString
  • NdisFreeToNPagedLookasideList
  • NdisGeneratePartialCancelId
  • NdisGetCurrentProcessorCounts
  • NdisGetDriverHandle
  • NdisGetRoutineAddress
  • NdisGetSharedDataAlignment
  • NdisGetVersion
  • NdisInitAnsiString
  • NdisInitializeListHead
  • NdisInitializeNPagedLookasideList
  • NdisInitializeSListHead
  • NdisInitializeString
  • NdisInitUnicodeString
  • NdisMapFile
  • NdisOpenConfigurationEx
  • NdisOpenConfigurationKeyByIndex
  • NdisOpenConfigurationKeyByName
  • NdisOpenFile
  • NdisQueryAdapterInstanceName
  • NdisQueryDepthSList
  • NdisQueueIoWorkItem
  • NdisReadConfiguration
  • NdisReadNetworkAddress
  • NdisReEnumerateProtocolBindings
  • NdisSetOptionalHandlers
  • NdisSystemProcessorCount
  • NdisUnicodeStringToAnsiString
  • NdisUnmapFile
  • NdisUpcaseUnicodeString
  • NdisWaitEvent
  • NdisWriteConfiguration
  • NdisWriteErrorLogEntry
  • NdisWriteEventLogEntry

Irql_NetBuffer_Function
The Irql_NetBuffer_Function rule specifies that the NET_BUFFER-related functions must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisAdvanceNetBufferDataStart
  • NdisAdvanceNetBufferListDataStart
  • NdisAllocateCloneNetBufferList
  • NdisAllocateFragmentNetBufferList
  • NdisAllocateMdl
  • NdisAllocateNetBuffer
  • NdisAllocateNetBufferAndNetBufferList
  • NdisAllocateNetBufferList
  • NdisAllocateNetBufferListContext
  • NdisAllocateNetBufferListPool
  • NdisAllocateNetBufferMdlAndData
  • NdisAllocateNetBufferPool
  • NdisAllocateReassembledNetBufferList
  • NdisCopyFromNetBufferToNetBuffer
  • NdisCopyReceiveNetBufferListInfo
  • NdisCopySendNetBufferListInfo
  • NdisFreeCloneNetBufferList
  • NdisFreeFragmentNetBufferList
  • NdisFreeMdl
  • NdisFreeNetBuffer
  • NdisFreeNetBufferList
  • NdisFreeNetBufferListContext
  • NdisFreeNetBufferListPool
  • NdisFreeNetBufferPool
  • NdisFreeReassembledNetBufferList
  • NdisGetDataBuffer
  • NdisGetMdlPhysicalArraySize
  • NdisGetPoolFromNetBuffer
  • NdisGetPoolFromNetBufferList
  • NdisQueryMdl
  • NdisQueryMdlOffset
  • NdisQueryNetBufferPhysicalCount
  • NdisRetreatNetBufferDataStart
  • NdisRetreatNetBufferListDataStart

Irql_OID_Function
The Irql_OID_Function rule specifies that the NDIS OID request DDIs must be called at correct IRQL levels.

Irql_Protocol_Driver_Function
The Irql_Protocol_Driver_Function rule specifies that the NDIS functions for CoNDIS clients must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisClAddParty
  • NdisClCloseAddressFamily
  • NdisClCloseCall
  • NdisClDeregisterSap
  • NdisClDropParty
  • NdisClGetProtocolVcContextFromTapiCallId
  • NdisClIncomingCallComplete
  • NdisClMakeCall
  • NdisClModifyCallQoS
  • NdisClNotifyCloseAddressFamilyComplete
  • NdisClOpenAddressFamilyEx
  • NdisCloseAdapterEx
  • NdisClRegisterSap
  • NdisCompleteBindAdapterEx
  • NdisCompleteNetPnPEvent
  • NdisCompleteUnbindAdapterEx
  • NdisDeregisterProtocolDriver
  • NdisMNetPnPEvent
  • NdisOpenAdapterEx
  • NdisRegisterProtocolDriver
  • NdisUnbindAdapter

Irql_SendRcv_Function
The Irql_SendRcv_Function rule specifies that the send and receive functions for NDIS drivers must be called at correct IRQL levels.

Irql_StatusIndication_Function
The Irql_StatusIndication_Function rule specifies that the NDIS status indication functions for miniport and filter drivers must be called at correct IRQL levels. This rule verifies the following NDIS functions; NdisFIndicateStatus and,NdisMIndicateStatusEx

Irql_Synch_Function
The Irql_Synch_Function rule specifies that the NDIS interrupt and synchronization DDIs must be called at correct IRQL levels.

Irql_Timer_Function
The Irql_Timer_Function rule specifies that the NDIS timer service functions must be called at correct IRQL levels. This rule verifies the following NDIS functions;

  • NdisAllocateTimerObject
  • NdisCancelTimerObject
  • NdisFreeTimerObject
  • NdisSetTimerObject

MiniportPause_Return
The MiniportPause_Return rule specifies that the MiniportPause callback function should return only NDIS_STATUS_SUCCESS if the pause operation is complete, or NDIS_STATUS_PENDING if the miniport driver is in the pausing state. Any other returned status is invalid.

NdisAllocateCloneNetBufferList
This rule checks that NdisAllocateCloneNetBufferList and NdisFreeCloneNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffer are free when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateCloneNetBufferList_InitFail
This rule checks that NdisAllocateCloneNetBufferList and NdisFreeCloneNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateFragmentNetBufferList
This rule checks that NdisAllocateFragmentNetBufferList and NdisFreeFragmentNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateFragmentNetBufferList_InitFail
This rule checks that NdisAllocateFragmentNetBufferList and NdisFreeFragmentNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateFromNPagedLookasideList
This rule checks that NdisAllocateFromNPagedLookasideList and NdisFreeToNPagedLookasideList are called in alternate order. The ultimate goal is to make sure all LookasideList are freed. The rule uses three different states. State changes when a LookasideList is allocated or freed and deleted.

NdisAllocateFromNPagedLookasideList_InitFail
This rule checks that NdisAllocateFromNPagedLookasideList and NdisFreeToNPagedLookasideList are called in alternate order. The ultimate goal is to make sure all LookasideList are freed. The rule uses three different states. State changes when a LookasideList entry is allocated or freed.

NdisAllocateGenericObject
The NdisAllocateGenericObject rule specifies that NdisAllocateGenericObject and NdisFreeGenericObject are called in alternate order. The ultimate goal is to make sure all generic objects are freed when MiniportHaltEx ends. The rule uses three different states. The state changes when an NDIS generic object is allocated or freed. If an NDIS generic object is still allocated when the MiniportHaltEx exits, the rule will fail.

NdisAllocateMdl
The NdisAllocateMdl rule specifies that NdisAllocateMdl and NdisFreeMdl are called in alternate order. The ultimate goal is to make sure all MDLs are freed when MiniportHaltEx ends. The rule uses three different states. The state changes when an MDL is allocated or freed. If an MDL is still allocated when the MiniportHaltEx exits, the rule reports the defect.

NdisAllocateMemoryWithTagPriority
The NdisAllocateMemoryWithTagPriority rule specifies that a driver must not call NdisAllocateMemoryWithTagPriority without providing a Tag. Every memory allocation should use a unique pool tag to ensure that kernel debuggers and Driver Verifier can identify a distinct allocated block of memory.

NdisAllocateMemoryWithTagPriority_Cleanup
This rule checks that NdisAllocateMemoryWithTagPriority and NdisFreeMemoryWithTagPriority or NdisFreeMemory are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateMemoryWithTagPriority_InitFail
This rule checks that NdisAllocateMemoryWithTagPriority and NdisFreeMemoryWithTagPriority or NdisFreeMemory are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateNetBuffer
The NdisAllocateNetBuffer rule specifies that NdisAllocateNetBuffer and NdisFreeNetBuffer are called in alternate order. The ultimate goal is to make sure all instances of NET_BUFFER are freed when MiniportHaltEx ends. The rule uses three different states. The state changes when a NET_BUFFER is allocated or freed. If a NET_BUFFER is still allocated when the MiniportHaltEx exits, the rule reports the defect.

NdisAllocateNetBufferList
This rule checks that NdisAllocateNetBufferList and NdisFreeNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends.

NdisAllocateNetBufferList2
This rule checks that NdisAllocateNetBufferList and NdisFreeNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateNetBufferList2_InitFail
This rule checks that NdisAllocateNetBufferList and NdisFreeNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateNetBufferListPool
This rule checks that NdisAllocateNetBufferListPool and NdisFreeNetBufferListPool are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateNetBufferListPool_InitFail
This rule checks that NdisAllocateNetBufferListPool and NdisFreeNetBufferListPool are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateNetBufferList_InitFail
This rule checks that NdisAllocateNetBufferAndNetBufferList and NdisFreeNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails.

NdisAllocateNetBufferMdlAndData
This rule checks that NdisAllocateNetBufferMdlAndData and NdisFreeNetBuffer are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateNetBufferMdlAndData_InitFail
This rule checks that NdisAllocateNetBufferMdlAndData and NdisFreeNetBuffer are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateNetBufferPool
This rule checks that NdisAllocateNetBufferPool and NdisFreeNetBufferListPool are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateNetBufferPool_InitFail
This rule checks that NdisAllocateNetBufferPool and NdisFreeNetBufferListPool are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisAllocateReassembledNetBufferList
This rule checks that NdisAllocateReassembledNetBufferList and NdisFreeReassembledNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffer are freed when MiniportHaltEx ends. The rule uses three different states. State changes when a NetBuffer is allocated or freed. If a NetBuffer is still allocated when the MiniportHaltEx exits, then the rule will fail.

NdisAllocateReassembledNetBufferList_InitFail
This rule checks that NdisAllocateReassembledNetBufferList and NdisFreeReassembledNetBufferList are called in alternate order. The ultimate goal is to make sure all NetBuffers are freed when the initialization functions fails. The rule uses three different states. State changes when a NetBuffer is allocated or freed If a NetBuffer is still allocated when the Initialization functions fails this rule will report a defect.

NdisFDeregisterFilterDriver
A filter driver must call NdisFDeregisterFilterDriver from its FilterDriverUnload routine.

NdisMDeregisterInterruptEx
After NdisMDeregisterInterruptEx returns control, the miniport driver cannot call the NdisMSynchronizeWithInterruptEx function.

NdisMFreeSharedMemory
NdisMFreeSharedMemory cannot be called from a MiniportShutdownEx function.

NdisMIndicateStatusEx
The driver must not call NdisMIndicateStatusEx after it returns from the MiniportHaltEx function.

NdisMMapIoSpace
The NdisMMapIoSpace function should only be called in the context of MiniportInitializeEx.

NdisMNetPnPEventInOIDRequest
This rule checks that NdisMNetPnPEvent is not called in the context of an OID request.

NdisMRegisterIoPortRange
A miniport driver calls NdisMRegisterIoPortRange from its MiniportInitializeEx or MINIPORT_ADD_DEVICE functions. MiniportInitializeEx or MINIPORT_ADD_DEVICE must call NdisMSetMiniportAttributes before calling NdisMRegisterIoPortRange.

NdisOpenConfigurationEx
This rule checks that NdisOpenConfigurationEx and NdisCloseConfiguration are called in alternate order. The ultimate goal is to make sure that configuration handles are closed when MiniportHaltEx exits. The rule uses three different states. The state changes when a configuration is opened or closed. If a configuration handle is still open when the MiniportHaltEx exits, a defect is reported.

NdisQueryBindInstanceName
NdisQueryBindInstanceName allocates memory for the string that specifies the friendly name. After the caller finishes using this memory, the caller must call the NdisFreeMemory function to release the memory.

NdisReEnumerateProtocolBindings
Protocol drivers cannot call NdisReEnumerateProtocolBindings from within the context of the ProtocolBindAdapterEx, or ProtocolUnbindAdapterEx functions. Also, protocol drivers cannot call NdisReEnumerateProtocolBindings from within the context of the ProtocolNetPnPEvent function if the ProtocolBindingContext parameter of ProtocolNetPnPEvent is not NULL. However, protocol drivers can call NdisReEnumerateProtocolBindings from within the context of ProtocolNetPnPEvent if ProtocolBindingContext is NULL. A NULL ProtocolBindingContext value indicates that the event applies to all bindings.

PeriodicTimer
The PeriodicTimer rule specifies that the caller of NdisCancelTimerObject must be running at IRQL = PASSIVE_LEVEL if a nonzero value was specified in the MillisecondsPeriod parameter of the NdisSetTimerObject function. If the MillisecondsPeriod parameter of the NdisSetTimerObject function was zero, callers of NdisCancelTimerObject can be running at IRQL <= DISPATCH_LEVEL.

Irqlapclte
The IrqlApcLte rule specifies that the driver calls ObGetObjectSecurity and ObReleaseObjectSecurity only when it is executing at IRQL <= APC_LEVEL.

Irqldispatch
The IrqlDispatch rule specifies that the driver calls the following DDIs only when it is executing at IRQL = DISPATCH_LEVEL;

  • FreeAdapterChannel,
  • FreeMapRegisters,
  • GetScatterGatherList,
  • IoAllocateAdapterChannel,
  • IoAllocateController,
  • IoFreeController,
  • IoStartNextPacket,
  • KeAcquireSpinLockAtDpcLevel,
  • KeInsertByKeyDeviceQueue,
  • KeInsertDeviceQueue,
  • KeReleaseSpinLockFromDpcLevel,
  • KeRemoveByKeyDeviceQueue,
  • KeRemoveDeviceQueue,
  • PutScatterGatherList

Irqlexallocatepool
The IrqlExAllocatePool rule specifies that the driver calls ExAllocatePoolWithTag and ExAllocatePoolWithTagPriority only when it is executing at IRQL <= DISPATCH_LEVEL.. A caller executing at DISPATCH_LEVEL must specify a NonPagedXxx value for PoolType. A caller executing at IRQL <= APC_LEVEL can specify any POOL_TYPE value.

Irqlexapclte1
The IrqlExApcLte1 rule specifies that the driver calls ExAcquireFastMutex and ExTryToAcquireFastMutex only at IRQL <= APC_LEVEL.

Irqlexapclte2
The IrqlExApcLte2 rule specifies that the driver calls the following routines only at IRQL <= APC_LEVEL;

  • CmRegisterCallback,
  • CmUnRegisterCallback,
  • ExAllocateFromPagedLookasideList,
  • ExAllocatePoolWithQuota,
  • ExAllocatePoolWithQuotaTag,
  • ExDeletePagedLookasideList,
  • ExFreeToPagedLookasideList,
  • ExInitializePagedLookasideList,
  • ExRegisterCallback,
  • ExSetTimerResolution,
  • ExUnregisterCallback,
  • ProbeForRead,
  • ProbeForWrite

Irqlexapclte3
The IrqlExApcLte3 rule specifies that the driver calls the following executive support routines only at IRQL <= APC_LEVEL;

  • ExAcquireResourceExclusiveLite,
  • ExAcquireResourceSharedLite,
  • ExAcquireSharedStarveExclusive,
  • ExAcquireSharedWaitForExclusive,
  • ExConvertExclusiveToSharedLite,
  • ExDeleteResourceLite

Drivers that have errors related to IRQL can cause serious problems and could cause a computer to crash.

Irqlexapclteinline
The IrqlExApcLteInline rule specifies that DDIs are only called at proper IRQL levels

irqlexpassive
The IrqlExPassive rule specifies that the driver calls the following executive support routines only at IRQL = PASSIVE_LEVEL;

  • ExCreateCallback,
  • ExIsProcessorFeaturePresent,
  • ExRaiseAccessViolation,
  • ExRaiseDatatypeMisalignment,
  • ExRaiseStatus,
  • ExUuidCreate

The IrqlExPassive rule also specifies that the driver calls ExRaiseStatus at IRQL <= APC_LEVEL.

irqlioapclte
The IrqlIoApcLte rule specifies that the driver calls the following I/O manager routines only when it is executing at IRQL <= APC_LEVEL;

  • IoDeleteDevice,
  • IoGetInitialStack,
  • IoRaiseHardError,
  • IoRaiseInformationalHardError

irqliodispatch
The IrqlIoDispatch rule specifies that the driver calls the following I/O Manager routines only when it is executing at IRQL <= DISPATCH_LEVEL;

  • IoGetDeviceToVerify,
  • IoSetDeviceToVerify.

irqliopassive1
The IrqlIoPassive1 rule specifies that the driver calls the following routines only when it is executing at IRQL = PASSIVE_LEVEL;

  • IoAttachDevice,
  • IoCreateDevice,
  • IoSetDeviceInterfaceState

The rule also specifies that the driver calls the following routine only when it is executing at IRQL = PASSIVE_LEVEL or IRQL = APC_LEVEL: IoBuildDeviceIoControlRequest

irqliopassive2
The IrqlIoPassive2 rule specifies that the driver calls the following I/O Manager routines only at IRQL = PASSIVE_LEVEL;

  • IoCheckShareAccess,
  • IoConnectInterrupt,
  • IoCreateController

irqliopassive3
The IrqlIoPassive3 rule specifies that the driver calls the following routines only when it is executing at IRQL = PASSIVE_LEVEL;

  • IoDetachDevice,
  • IoAssignArcName,
  • IoRegisterDeviceInterface

irqliopassive4
The IrqlIoPassive4 rule specifies that the driver calls the following routines only when it is executing at IRQL = PASSIVE_LEVEL;

  • IoCreateFile,
  • IoCreateNotificationEvent,
  • IoCreateSymbolicLink,
  • IoCreateSynchronizationEvent,
  • IoCreateUnprotectedSymbolicLink,
  • IoDeassignArcName,
  • IoDeleteController,
  • IoDeleteSymbolicLink,
  • IoDisconnectInterrupt

irqliopassive5
The IrqlIoPassive5 rule specifies that the driver calls specific I/O Manager routines only when it is executing at IRQL = PASSIVE_LEVEL.

irqlkeapclte1
The IrqlKeApcLte1 rule specifies that the driver calls the following kernel routines only when it is executing at IRQL <= APC_LEVEL;

  • KeAcquireGuardedMutex,
  • KeAcquireGuardedMutexUnsafe,
  • KeDelayExecutionThread,
  • KeQueryActiveProcessors,
  • KeReleaseGuardedMutex,
  • KeReleaseGuardedMutexUnsafe,
  • KeTryToAcquireGuardedMutex

irqlkeapclte2
The IrqlKeApcLte2 rule specifies that the driver calls the following kernel routines only when it is executing at IRQL <= APC_LEVEL;

  • KeAreAllApcsDisabled,
  • KeAreApcsDisabled,
  • KeDeregisterNmiCallback,
  • KeEnterCriticalRegion,
  • KeEnterGuardedRegion,
  • KeLeaveCriticalRegion,
  • KeLeaveGuardedRegion,
  • KeRegisterNmiCallback

irqlkedispatchlte
The IrqlKeDispatchLte rule specifies that the driver calls the following kernel routines only when it is executing at IRQL <= DISPATCH_LEVEL;

  • KeAcquireSpinLock,
  • KeCancelTimer,
  • KeClearEvent,
  • KeFlushIoBuffers,
  • KeInitializeDeviceQueue,
  • KeInitializeTimer,
  • KeInitializeTimerEx,
  • KePulseEvent,
  • KeRaiseIrqlToDpcLevel,
  • KeReadStateEvent,
  • KeReadStateTimer,
  • KeReleaseMutex,
  • KeRemoveEntryDeviceQueue,
  • KeResetEvent,
  • KeSaveFloatingPointState,
  • KeSetTimer,
  • KeSetTimerEx

irqlkeraiselower
The IrqlKeRaiseLower rule specifies that the driver does the following when raising and lowering the IRQL;

When the driver calls KeRaiseIrql, it is executing at an IRQL that is lower than or equal to the value of the NewIrql parameter.

The driver calls KeLowerIrql only after calling KeRaiseIrql or KeRaiseIrqlToDpcLevel.

This rule permits nested calls to KeRaiseIrql, KeRaiseIrqlToDpcLevel, and KeLowerIrql.

irqlkeraiselower2
The IrqlKeRaiseLower2 rule specifies that drivers use KeLowerIrql to restore the original IRQL raised by a preceding call to KeRaiseIrql or KeRaiseIrqlToDpcLevel. This rule permits nested calls to KeRaiseIrql, KeRaiseIrqlToDpcLevel and KeLowerIrql.

irqlkereleasespinlock
The IrqlKeReleaseSpinLock rule specifies that the driver calls KeReleaseSpinLock only when it is executing at IRQL = DISPATCH_LEVEL. This rule also specifies that the value of the NewIrql parameter in the call to KeReleaseSpinLock is equal to the IRQL at which the driver was executing before the call to KeAcquireSpinLock. (This value is also the value of the OldIrql parameter that is supplied by KeAcquireSpinLock.)

irqlkewaitformultipleobjects
The IrqlKeWaitForMultipleObjects rule specifies that callers of the KeWaitForMultipleObjects routine must be running at proper IRQL based upon the Timeout parameter.

Callers of IrqlKeWaitForMultipleObjects routine can be running at IRQL <= DISPATCH_LEVEL, except in the following situations;

If Timeout <> 0, the caller of the KeWaitForMultipleObjects routine must be running at IRQL <= APC_LEVEL.

If Timeout != NULL and *Timeout = 0, the caller of the KeWaitForMultipleObjects routine must be running at IRQL = DISPATCH_LEVEL.

If Timeout = NULL, or *Timeout != 0, the caller of the KeWaitForMultipleObjects routine must running at IRQL <= APC_LEVEL.

irqlkewaitformutexobject
The IrqlKeWaitForMutexObject rule specifies the driver to call the KeWaitForMutexObject routine at the proper IRQL based on the value of the Timeout parameter:

If Timeout points to a zero value, the driver is executing at IRQL = DISPATCH_LEVEL.

If Timeout is NULL, or points to any value other than zero, the driver is executing at IRQL <= APC_LEVEL.

irqlmmapclte
The IrqlMmApcLte rule specifies that the driver calls the following memory manager routines only when it is executing at IRQL <= APC_LEVEL;

  • MmAllocateNonCachedMemory,
  • MmFreeNonCachedMemory,
  • MmAllocatePagesForMdl,
  • MmFreePagesFromMdl,
  • MmLockPagableDataSection,
  • MmLockPagableSectionByHandle,
  • MmPageEntireDriver,
  • MmResetDriverPaging,
  • MmSecureVirtualMemory,
  • MmUnlockPagableImageSection,
  • MmUnsecureVirtualMemory

irqlmmdispatch
The IrqlMmDispatch rule specifies that the driver calls MmFreeContiguousMemory only when it is executing at IRQL <= DISPATCH_LEVEL.

irqlobpassive
The IrqlObPassive rule specifies that the driver calls ObReferenceObjectByHandle only when it is executing at IRQL = PASSIVE_LEVEL.

irqlpspassive
The IrqlPsPassive rule specifies that the driver calls the following Process Structure routines only when it is executing at IRQL = PASSIVE_LEVEL;

  • PsCreateSystemThread,
  • PsGetVersion,
  • PsSetCreateProcessNotifyRoutine,
  • PsSetCreateThreadNotifyRoutine,
  • PsSetLoadImageNotifyRoutine,
  • PsTerminateSystemThread

irqlrtlapc
The IrqlRtlApc rule specifies that the driver calls RtlCreateUnicodeString only when it is executing at IRQL <= APC_LEVEL.

irqlrtlpassive
The IrqlRtlPassive rule specifies that the driver calls RtlDeleteRegistryValue only when it is executing at IRQL = PASSIVE_LEVEL.

irqlrtlpassive2
The IrqlRtlPassive rule specifies that the driver calls Rtl* functions only when it is executing at IRQL = PASSIVE_LEVEL.

irqlzwpassive
The IrqlZwPassive rule specifies that the driver calls ZwClose only when it is executing at IRQL = PASSIVE_LEVEL.

Storage

Note - the Must-Fix Rules are based on examining the information for each Rule from this URL, http://msdn.microsoft.com/en-us/library/windows/hardware/jj126200(v=vs.85).aspx

DDIs

HwStorPortProhibitedDDIs
This rule contains a list of WDM DDIs (excluding interlocked functions) that should not be called in physical StorPort miniport drivers.

StorPortDDIsPortOnly
This rule contains a list of StorPort port-only DDIs (excluding interlocked functions) that should not be called in StorPort miniports.

StorPortDeprecated
This rule verifies that the driver does not call either of these deprecated routines; StorPortValidateRange or StorPortLogError.

IrqL

IrqlDispatch
This rule verifies that the following routines are only called at IRQL = DISPATCH_LEVEL.

IrqlKeReleaseSpinLock
This rule verifies that KeReleaseSpinLock is called at IRQL = DISPATCH_LEVEL only. It must also set the IRQL to the previous IRQL level. Typically this call would be preceded by a call to KeAcquireSpinLock.

SpChangeIrql
This rule verifies that the StorPort callback routines return at the same IRQL level as the level at which they are called.

SpIrql
This rule verifies that the routines TdiRegisterPnPHandlers and TdiDeregisterPnPHandlers are only called at IRQL lower than DISPATCH_LEVEL. However, if ExFreeToNPagedLookasideList is called, the rule passes.

StorPortIrql
The StorPortIrql rule checks that StorPort routines are called at the correct IRQL levels.

Locking

CancelSpinLock
The CancelSpinLock Rule (Storport) rule verifies that each call to IoAcquireCancelSpinLock is promptly followed by a call to IoReleaseCancelSpinLock.

QueuedSpinLock
The QueuedSpinLock rule verifies that in-stack queued spin locks that are acquired using KeAcquireInStackQueuedSpinLock are promptly released using KeReleaseInStackQueuedSpinLock. In addition, at the end of a dispatch or cancel routine, the driver should not hold any locks.

QueuedSpinLockRelease
This rule verifies that the driver does not call KeReleaseInStackQueuedSpinLock without first acquiring the lock via KeAcquireInStackQueuedSpinLock.

SpinLock
This rule verifies that a call to KeAcquireSpinLock is promptly followed by a call to KeReleaseSpinlock. If a driver calls KeAcquireSpinLockRaiseToDpc or KeAcquireSpinLock again prior to releasing the lock, it fails the rule. In addition, before exiting the dispatch or cancel routine, the driver must release the spin lock.

SpinLockDpc
This rule verifies that a call to KeAcquireSpinLockRaiseToDpc is promptly followed by a call to KeReleaseSpinlock. If a driver calls KeAcquireSpinLock or KeAcquireSpinLockRaiseToDpc again prior to releasing the lock, it fails the rule. In addition, before exiting the dispatch or cancel routine, the driver must release the spin lock.

StorPortMSILock
Miniport drivers are required to acquire the MSI spin lock for a message if, and only if, the InterruptSynchronizationMode member of the PORT_CONFIGURATION_INFORMATION (Storport) structure is set to InterruptSynchronizePerMessage. This rule verifies that calls to StorPortAcquireMSISpinLock are only made if the synchronization mode is InterruptSynchronizePerMessage.

StorPortSpinLock
This rule verifies that locks that are acquired via StorPortAcquireSpinLock are promptly released via StorPortReleaseSpinLock. The miniport driver fails the rule if it attempts to acquire a lock that it had already acquired, or if it attempts to release a lock that it had not acquired. In addition, at the end of the dispatch or cancel routine, the driver should not hold any spin locks.

StorPortSpinLock3
The StorPortSpinLock3 rule verifies the lock acquisition hierarchy that is described in the documentation for the StorPortAcquireSpinLock routine.

SRB Processing

SpDuplex
This rule verifies that this miniport is in Full Duplex mode. Any driver built according to the StorPort-miniport model must be in Full Duplex mode. Half Duplex should only be used when porting an existing SCSI driver to StorPort.

SpNoWait
This rule verifies that waits or data allocation are not performed inside StartIo.

SpReturnValue
This rule verifies that the driver's implementations of HwStorFindAdapter and VirtualHwStorFindAdapter return a valid status. A valid status is one of the following; SP_RETURN_FOUND, SP_RETURN_ERROR, SP_RETURN_BAD_CONFIG, or SP_RETURN_NOT_FOUND.

StorPortAllocatePool2
This rule verifies that the miniport makes the correct number of calls to StorPortAllocatePool and StorPortFreePool. If StorPortAllocatePool returns a failure (STOR_STATUS_INSUFFICIENT_RESOURCES), the miniport must not attempt to call StorPortFreePool. In addition, upon exit from a callback, the number of calls to StorPortAllocatePool and StorPortFreePool must be equal.

StorPortBuildIo
This rule verifies that if the StorPort miniport's StorPortBuildIo routine returns FALSE, the SRB in question is not passed to StartIo. (In such cases, the miniport driver must complete the SRB by calling StorPortNotification with a notification type of RequestComplete from StorPortBuildIo or someplace else).

StorPortCompleteRequest
This rule verifies that no calls to StorPortCompleteRequest are made by the miniport. Usage of the StorPortCompleteRequest is not recommended; miniports should instead call StorPortNotification with notificationType = RequestComplete.

StorPortEnablePassive
This rule verifies that StorPortEnablePassiveInitialization is not called from any StorPort miniport driver routine other than HwInitialize.

StorPortNotification2
This rule verifies that calls to StorPortNotification use only allowed (i.e. documented) notification types.

StorPortPassiveFromHwInit
StorPortEnablePassiveInitialization should not be called within the HW Initialization entry point for Storport drivers if the HW Initialization entry point can be called directly from the HW Adapter Control entry point.

StorPortPerfOpts
This rule verifies that the PerfConfigData parameter that is passed to StorPortInitializePerfOpts is not NULL.

StorPortStartIo
Waits or data allocation must never be performed in the miniport's StartIo routine. The driver fails the rule if it calls StorPortStallExecution or another function that involves time-consuming operations. Since StartIo is synchronized, these calls should mostly be done in BuildIo.

Virtual Miniport

DoubleExFreePool
This rule verifies that the driver does not attempt to free the same block of pool memory twice.

StorPortVirtualDevice
This rule verifies that upon exit from the HwStorFindAdapter routine, the VirtualDevice field in the PORT_CONFIGURATION_INFORMATION (Storport) structure has been set to FALSE. The rule applies only to physical StorPort miniports.

StorPortVirtualDevice2
This rule verifies that upon exit from the HwStorFindAdapter routine, the VirtualDevice field in the PORT_CONFIGURATION_INFORMATION (Storport) structure has been set to TRUE. The rule applies only to virtual StorPort miniports.

WithinCriticalRegion
This rule verifies that the driver's calls to certain synchronization functions are made only while normal kernel APC delivery is disabled.

Screenshots of Analysis Tool Interfaces

SDV

Create Driver Verification Log (DVL) file for submission package

DVL File data


Using Device Fundamentals Tests to Reproduce Device Manager Problem Codes

The Device Fundamentals (DevFund) tests use Microsoft-supplied I/O plug-ins to exercise devices by sending device class-specific I/O to the device while disabling and enabling the device, cycling the system through power states and reboots, deallocating and reallocating resources, and other tasks.

Step 1: Determine which tests can potentially reproduce the device error code

The following table matches device problem codes to tests known to exercise a device in such a way as to induce the corresponding problem code. This chart can be used by device and driver testers in an attempt to reproduce device problems seen in the wild, or problems which may be hard to reproduce during regular testing.

Device Error Code | Device Error Message | Device Fundamentals Test
10 | CM_PROB_FAILED_START | DF - PNP Rebalance Fail Restart Device Test (Reliability) DF - PNP Surprise Remove Device Test (Development and Integration) DF - PNP Surprise Remove Device Test (Reliability) DF - PNP DIF Remove Device Test (Reliability) DF - Reboot restart with IO before and after (Reliability) DF - PNP Cancel Remove Device Test (Reliability) DF - PNP Disable And Enable Device Test (Reliability) DF - PNP Rebalance Request New Resources Device Test (Development and Integration) DF - PNP Rebalance Request New Resources Device Test (Reliability) DF - PNP Remove Device Test (Reliability) DF - PNP Stop (Rebalance) Device Test (Development and Integration) DF - PNP Stop (Rebalance) Device Test (Reliability) DF - Sleep with IO During (Reliability) DF - PCI Root Port Surprise Remove Test (PCI devices only) (Reliability)
14 | CM_PROB_NEED_RESTART | DF - PNP Remove Device Test (Reliability) DF - PNP DIF Remove Device Test (Reliability)
28 | CM_PROB_FAILED_INSTALL | DF - PNP DIF Remove Device Test (Reliability)
31 | CM_PROB_FAILED_ADD | DF - PNP DIF Remove Device Test (Reliability) DF - PNP Disable And Enable Device Test (Reliability) DF - PNP Rebalance Fail Restart Device Test (Reliability) DF - PNP Remove Device Test (Reliability)
38 | CM_PROB_DRIVER_FAILED_PRIOR_UNLOAD | DF - PNP DIF Remove Device Test (Reliability)
39 | CM_PROB_DRIVER_FAILED_LOAD | DF - PNP DIF Remove Device Test (Reliability)
43 | CM_PROB_FAILED_POST_START | DF - PNP Cancel Stop Device Test (Reliability) DF - PNP Cancel Remove Device Test (Reliability) DF - PNP Rebalance Fail Restart Device Test (Reliability) DF - PNP Rebalance Request New Resources Device Test (Reliability) DF - PNP Remove Device Test (Reliability) DF - Sleep with IO During (Reliability)
52 | CM_PROB_UNSIGNED_DRIVER | DF - PNP Disable And Enable Device Test (Reliability)

See Device Manager Error Messages for the list of device error codes.

See Device.DevFund tests for the complete list of Device Fundamentals tests.

Step 2: Determine how to configure the test and test machine

After determining which test to run, decide how to configure the test and the test machine to reproduce the error. To see which parameters are supported by each test, click the link for a specific test in the table above. This will describe the test and the options available for that test. For example, some device PnP errors are sporadic. The /testcycles switch can be used with all tests to specify how many times the test should run:

/p:testcycles=10

Running the test with more iterations may increase the likelihood of inducing the device error.

Some tests will cause SetupAPI logs to be generated (e.g. DF - Reinstall with IO Before and After (Reliability). The test machine can be configured to generate verbose SetupAPI logs.

Step 3: Run the test

These tests can easily be run on the command line or the HLK after setting up an HLK Controller.

Running tests on the command line via te.exe allows for more test options than running the tests via the HLK. For example, the /breakonerror command line parameter causes TAEF to break into the debugger when an error occurs in the test. There are many more command line options which can be supplied to te.exe when running tests on the command line.

Step 4: Debug the issue

There is a lot of help available for investigating device and driver problems. See the troubleshooting documentation for information on reviewing test logs and using the kernel debugger to investigate device and driver problems.


Device.Display

In this section

  • Device.Display tests


Device.Display tests

  • Display Monitor Modes - Check EDID support
  • EDID 1.3 and DDC (WoW64)
  • Monitor - Digital link protection test
  • Test for EDID Requirements (Manual)


Display Monitor Modes - Check EDID support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f041eba7-ec0b-4edb-915c-ef5735e98f07

Verify edid contains the required display modes.

Test details
Specifications
  • Device.Display.Monitor.Modes
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic


EDID 1.3 and DDC (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d089993-3e87-4c52-8f57-8bf9db6b818b

This automated test checks for the compliance of the extended-display identification data (EDID) of a monitor.

Specifically, this test retrieves EDID data from monitor software key fields. It then verifies key fields that are associated with the EDID structure that is based on the Video Electronics Standards Association (VESA) Enhanced Extended Display Identification Data (EDID) Standard Version 1.3.

Test details
Specifications
  • Device.Display.Monitor.EDID
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Running the test

Before you run the test, complete the test setup as described in the test requirements: Display Monitor Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
EDIDV2 /debuglevel=3 /auto /monitor=1 | Runs the EDID 1.3 and DDC (WoW64) test job
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Edidv2.exe | <testbinroot>\nttest\windowstest\graphics\wddm\bin</p>
Ntlog.dll | <testbinroot>\nttest\commontest\ntlog</p>
NTLogger.ini | <testbinroot>\nttest\basetest\serverkits\common</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | The name of your machine's LLU
MONITOR | Index of display output to target with test


Monitor - Digital link protection test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/109e4e03-e977-44df-8049-d0d1ea317e45

This automated test verifies High-Bandwidth Digital Content Protection (HDCP) support for a given monitor. The test first queries the connector types available on the graphics chipset. If a digital connector is available and supports HDCP, it will try to turn on HDCP.

Test details
Specifications
  • Device.Display.Monitor.DigitalLinkProtection
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Running the test

Before you run the test, complete the test setup as described in the test requirements: Display Monitor Testing Prerequisites.

In addition, this test requires the following:

  • Graphics adapter or chipset that supports the HDCP feature.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test returns Pass or Fail. For internal monitors, such as laptops, the test returns SKIP if the reported connection type is OPM_CONNECTOR_TYPE_LVDS.To review test details, review the test log from Windows HLK Studio.

More information

Command syntax

Command option | Description
Shellrunner.exe | Without any options, the test enumerates the monitor.
-c [profile] | Starts the application and runs the test cases that are specified in the .profile file. (For this test, that is the WLP_Display_009.pro file).
-l [dll file] | Starts the application and specifies the .dll file to be run. (For this test, that is the s98wtt_u.dll file.)
-x [string] | Starts the test and selects the test level to be run. (For this test, that is the premium level.)
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
s98wtt_u.dll | <testbinroot>\nttest</p>
Shellrunner.exe | <testbinroot>\nttest\multimediatest\common\wdk</p>
WLP_Display_009.pro | <testbinroot>\nttest\multimediatest\wmmftest</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
TDRArgs | TDR arguments.
LIBRARYNAME | Library name.


Test for EDID Requirements (Manual)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b97fb72d-0f43-48e1-82e3-3af4c5bc96ca

This manual test verifies that the display device implements the extended-display identification data (EDID) data structure correctly.

Test details
Specifications
  • Device.Display.Monitor.EDID
  • Device.Graphics.WDDM.Display.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Display Monitor Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The display device test must meet the following specifications:

  1. Must have native timing set in the detailed timing block and for the preferred display mode

  2. Must implement monitor range limits unless display only supports discrete timings

  3. Must implement monitor name, suitable for presentation to the user (though optional for internal displays)

  4. Must contain unique monitor serial number in either the serial number field or in a detailed timing block (both OK) (though optional for internal displays)

  5. Recommended mode must be a progressive mode

  6. Must provide accurate physical dimensions, unless the device is a projector

  7. Display devices that support more than 8 bits per pixel use EDID 1.4 in order to describe the color capabilities.

Command syntax

Command option | Description
CCDEdid.exe | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
CCDEdid.exe | <testbinroot>\nttest\windowstest\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


Device.Graphics

In this section

  • Device.Graphics tests
  • Device.Graphics additional documentation


Device.Graphics tests

  • 10L9Constantbuffers (Mobile)
  • 10L9ShaderMobile (Mobile)
  • Alpha Blending - FALSE-TRUE 16bpp
  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)
  • Alpha Blending - FALSE-TRUE 2-10-10-10
  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)
  • Alpha Blending - FALSE-TRUE 32bpp
  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)
  • Alpha Blending Precision
  • Alpha Blending Precision (WoW64)
  • Alpha Compare
  • Alpha Compare (WoW64)
  • Anisotropic
  • Anisotropic (WoW64)
  • Arbitrary Clipping Planes
  • Arbitrary Clipping Planes (WoW64)
  • Auto Generation of Mip Maps
  • Auto Generation of Mip Maps (WoW64)
  • Basic Rasterization
  • Basic Rasterization (WoW64)
  • Basic Rasterization 2-10-10-10
  • Basic Rasterization 2-10-10-10 (WoW64)
  • Blocklist Parse Conditions Test
  • Brightness2 Test
  • BrightnessTest (Mobile, Manual)
  • Bump Env Map
  • Bump Env Map (WoW64)
  • Capscheck
  • Capscheck (WoW64)
  • Check Driver SetTimings Support
  • Check Resolution (WoW64)
  • Check Resolution for Dualview (WoW64) - multihead
  • Check Resource
  • Check Resource (WoW64)
  • Clear
  • Clear (WoW64)
  • Color Fill
  • Color Fill (WoW64)
  • Color Space Transform
  • Compare Z
  • Compare Z (WoW64)
  • Compressed Texture
  • Compressed Texture (WoW64)
  • CoolingInterface Test
  • COPP - HDCP Test
  • COPP - HDCP Test (WoW64)
  • COPP - Protocol Test
  • COPP - Protocol Test (WoW64)
  • CopyRects Functionality (WoW64)
  • CRASH - Display Stress 4-hour WDDM Profile (32bit)
  • CRASH - Display Stress 4-hour WDDM Profile (64bit)
  • Cube Mapping
  • Cube Mapping (WoW64)
  • D2D - DImage Effect Tests - 2DAffineTransform
  • D2D - DImage Effect Tests - 3DNonTrivial
  • D2D - DImage Effect Tests - 3DPerspectiveTransform
  • D2D - DImage Effect Tests - 3DTransform
  • D2D - DImage Effect Tests - 3DTransformNoVertex
  • D2D - DImage Effect Tests - 3DTransformNoVertexNearPlaneClipping
  • D2D - DImage Effect Tests - 3DTransformNoVertexPartiallyInfinite
  • D2D - DImage Effect Tests - Antialiasing
  • D2D - DImage Effect Tests - Api
  • D2D - DImage Effect Tests - ArithmeticComposite
  • D2D - DImage Effect Tests - BatchFlushing
  • D2D - DImage Effect Tests - Batching
  • D2D - DImage Effect Tests - BitmapImageRectangleDpi
  • D2D - DImage Effect Tests - BitmapNullRectangleDpi
  • D2D - DImage Effect Tests - BitmapSource
  • D2D - DImage Effect Tests - BitmapTiling
  • D2D - DImage Effect Tests - BoundsTests
  • D2D - DImage Effect Tests - ColorManagement
  • D2D - DImage Effect Tests - ColorManagementBuiltInSpaces
  • D2D - DImage Effect Tests - ColorManagementNonTrivial
  • D2D - DImage Effect Tests - ColorMatrix
  • D2D - DImage Effect Tests - CommandBatching
  • D2D - DImage Effect Tests - CommandBrush
  • D2D - DImage Effect Tests - CommandBrushSmall
  • D2D - DImage Effect Tests - CommandListUnitMode
  • D2D - DImage Effect Tests - CommandTiling
  • D2D - DImage Effect Tests - CommandTilingAliased
  • D2D - DImage Effect Tests - CommandTransform
  • D2D - DImage Effect Tests - Composite
  • D2D - DImage Effect Tests - CompositeOffset
  • D2D - DImage Effect Tests - DemandCache
  • D2D - DImage Effect Tests - DirectionalBlur
  • D2D - DImage Effect Tests - DpiCompensation
  • D2D - DImage Effect Tests - EffectInputBatching
  • D2D - DImage Effect Tests - EffectPropertyBatching
  • D2D - DImage Effect Tests - GaussianBlur
  • D2D - DImage Effect Tests - HazardTracking
  • D2D - DImage Effect Tests - HelloWorld
  • D2D - DImage Effect Tests - HighlightsAndShadows
  • D2D - DImage Effect Tests - ImageBrush
  • D2D - DImage Effect Tests - ImageBrushWithBitmap
  • D2D - DImage Effect Tests - ImageSourceFromMapDefaultSurface
  • D2D - DImage Effect Tests - LayersAndClips
  • D2D - DImage Effect Tests - LookupTable3d
  • D2D - DImage Effect Tests - NestedEffects
  • D2D - DImage Effect Tests - RenderInfoHazardTracking
  • D2D - DImage Effect Tests - Rendering_A8Planar
  • D2D - DImage Effect Tests - Rendering_AYUV
  • D2D - DImage Effect Tests - Rendering_ImageSourceFromDxgi_RGB
  • D2D - DImage Effect Tests - Rendering_ImageSourceFromDxgi_WicPlanar
  • D2D - DImage Effect Tests - Rendering_ImageSourceFromDxgi_YUY2
  • D2D - DImage Effect Tests - Rendering_ImageSourceFromWic_RGB
  • D2D - DImage Effect Tests - Rendering_ImageSourceFromWic_WicPlanar
  • D2D - DImage Effect Tests - Rendering_ImageSourceFromWicHardware
  • D2D - DImage Effect Tests - Rendering_NV12
  • D2D - DImage Effect Tests - Rendering_P208
  • D2D - DImage Effect Tests - Rendering_V208
  • D2D - DImage Effect Tests - Rendering_V408
  • D2D - DImage Effect Tests - Scale
  • D2D - DImage Effect Tests - Shadow
  • D2D - DImage Effect Tests - Tile
  • D2D - DImage Effect Tests - Tiling
  • D2D - DImage Effect Tests - Transform
  • D2D - DImage Effect Tests - Turbulence
  • D2D - DImage Effect Tests - UnitMode
  • D2D - DImage Effect Tests - WicBitmap
  • D2D - DImage Effect Tests - WicPixelFormats
  • D2D - DImage Effect Tests - YCbCr
  • D2D - DImage Effect Tests - YCbCrSubregion
  • D2D - DImage Ink Tests - Batching
  • D2D - DImage Ink Tests - Bounds
  • D2D - DImage Ink Tests - ConstantSpacing
  • D2D - DImage Ink Tests - HybridSpacing
  • D2D - DImage Ink Tests - InkApi
  • D2D - DImage Ink Tests - InkCoalescing
  • D2D - DImage Ink Tests - InkStrokeHazards
  • D2D - DImage Ink Tests - PointErase
  • D2D - DImage Ink Tests - PointEraseCycleStampingState
  • D2D - DImage Ink Tests - PointEraseWithStampInvalidation
  • D2D - DImage Ink Tests - ProgressiveDistance
  • D2D - DImage Ink Tests - StrokeEditingInvalidation
  • D2D - DImage Ink Tests - StrokeTransfer
  • D2D - DImage Ink Tests - VariableSpacing
  • D2D - DImage Tests - CWicInteropImageSourceTests-TestRegistration
  • D2D - DImage Tests - CWicInteropSourceTests-TestRegistration
  • D2D - DImage Tests - LeastRecentlyUsedIndexTest
  • D2D - DImage Tests - LookupTableApiTest
  • D2D - DImage Tests - TestAlphaModes
  • D2D - DImage Tests - TestBGRX
  • D2D - DImage Tests - TestBitmapAlphaOnly
  • D2D - DImage Tests - TestBitmapRenderTarget
  • D2D - DImage Tests - TestBitmapShaderResource
  • D2D - DImage Tests - TestDrawFrameOne
  • D2D - DImage Tests - TestDrawFrameZero
  • D2D - DImage Tests - TestDrawInvalidTmpDir
  • D2D - DImage Tests - TestDrawNoImageFilenameSet
  • D2D - DImage Tests - TestGetFileName
  • D2D - DImage Tests - TestGetFileNameInvalidSize1
  • D2D - DImage Tests - TestGetFileNameInvalidSize2
  • D2D - DImage Tests - TestGetFrameCount
  • D2D - DImage Tests - TestGoldenImageRender
  • D2D - DImage Tests - TestGoldenImageSubRect
  • D2D - DImage Tests - TestImage1x1
  • D2D - DImage Tests - TestImageMultiFormatTarget
  • D2D - DImage Tests - TestImageNotWiderThanStripSize
  • D2D - DImage Tests - TestImageWiderThanStripSize
  • D2D - DImage Tests - TestInitialPropertyValues
  • D2D - DImage Tests - TestMipMapLevels
  • D2D - DImage Tests - TestOffset
  • D2D - DImage Tests - TestOffsetDifferentFormat
  • D2D - DImage Tests - TestResourceTexture
  • D2D - DImage Tests - TestSetCurrentFrameInvalidValue
  • D2D - DImage Tests - TestSetFilenameEmtpyString
  • D2D - DImage Tests - TestSetFilenameInvalidValue
  • D2D - DImage Tests - TestTransparentCommandList
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedGradientMeshNonOverlap
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedGradientMeshOverlapped
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedImage
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedInk
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedMesh
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedOverlappingStroke
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedPerspectiveDrawBitmap
  • D2D - PrimitiveBlend - TestPrimitiveBlendAliasedRectangle
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedClip
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedGradientMeshNonOverlap
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedGradientMeshOverlapped
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedImage
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedInkHighQuality
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedInkLowLatency
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedLayer
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedOverlappingStroke
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedPerspectiveDrawBitmap
  • D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedRectangle
  • D2D - PrimitiveBlend - TestWin7AlphaCompatibility
  • D2D - VisualVerification - AATessellationTest
  • D2D - VisualVerification - BackFaceCullingTest
  • D2D - VisualVerification - BitmapRTTest
  • D2D - VisualVerification - BitmapTest
  • D2D - VisualVerification - BrushTest
  • D2D - VisualVerification - ClipBitmapOpacityTest
  • D2D - VisualVerification - CommandListBoundsTest
  • D2D - VisualVerification - CommandListEquivalenceTest
  • D2D - VisualVerification - CommandListRenderingTest
  • D2D - VisualVerification - CompositeModesTest
  • D2D - VisualVerification - CoverageTest
  • D2D - VisualVerification - DrawTextClippingTest
  • D2D - VisualVerification - DrawTextTest
  • D2D - VisualVerification - EffectImageBrushTest
  • D2D - VisualVerification - FillOpacityMaskTest
  • D2D - VisualVerification - GdiInteropTest
  • D2D - VisualVerification - GeometryOperationsTest
  • D2D - VisualVerification - GeometryRealizationTest
  • D2D - VisualVerification - GradientBrushTest
  • D2D - VisualVerification - GradientMeshTest
  • D2D - VisualVerification - HighColorGradientTest
  • D2D - VisualVerification - InkTest
  • D2D - VisualVerification - LargeGeometryTest
  • D2D - VisualVerification - Layer
  • D2D - VisualVerification - MatrixTest
  • D2D - VisualVerification - MetafileRenderingTest
  • D2D - VisualVerification - MiscTextTest
  • D2D - VisualVerification - MSAATest
  • D2D - VisualVerification - OpacityFillGeometryTest
  • D2D - VisualVerification - ParameterizedTest
  • D2D - VisualVerification - PolygonClipTest
  • D2D - VisualVerification - RealizationTest
  • D2D - VisualVerification - StripCacheTest
  • D2D - VisualVerification - TextGridTest
  • D2D - VisualVerification - TextPerfTest
  • D2D - VisualVerification - TextRealizationTest
  • D2D - VisualVerification - TextSplittingTest
  • D2D - VisualVerification - TextTest
  • D2D - VisualVerification - TIROrderingTest
  • D2D - VisualVerification - UnitModeEquivalenceTest
  • D2D - VisualVerification - WidenerTest
  • D2D - VisualVerification - YCbCrImageBrushTest
  • D3D AGP Texture (WoW64)
  • D3D Cross Proc Sharing
  • D3D Cross Proc Sharing (WoW64)
  • D3D Lines
  • D3D Lines (WoW64)
  • D3D11 - Conservative Rasterization
  • D3D11 - Cross Adapter Resource Support
  • D3D11 - Decode Histogram
  • D3D11 - NegotiateCryptoSessionKeyExchangeMT
  • D3D11 - PS-Specified Stencil Reference
  • D3D11 - Rasterizer Ordered Views
  • D3D11 - RenderTargetArrayIndex and ViewportArrayIndex from VS and DS
  • D3D11 - Typed UAV Load
  • D3D11 WGF11TimingData HW FL*
  • D3D12 - 11 on 12 - WGF11 Async
  • D3D12 - 11 on 12 - WGF11 Blend
  • D3D12 - 11 on 12 - WGF11 Blend (subset)
  • D3D12 - 11 on 12 - WGF11 Clipping
  • D3D12 - 11 on 12 - WGF11 Clipping (subset)
  • D3D12 - 11 on 12 - WGF11 Compute Shader
  • D3D12 - 11 on 12 - WGF11 Compute Shader (subset)
  • D3D12 - 11 on 12 - WGF11 Compute Shader - PSO Cache
  • D3D12 - 11 on 12 - WGF11 D3DWDDM
  • D3D12 - 11 on 12 - WGF11 Depth Stencil
  • D3D12 - 11 on 12 - WGF11 Depth Stencil (subset)
  • D3D12 - 11 on 12 - WGF11 Draw
  • D3D12 - 11 on 12 - WGF11 Draw (subset)
  • D3D12 - 11 on 12 - WGF11 Fill Rules
  • D3D12 - 11 on 12 - WGF11 Fill Rules (subset)
  • D3D12 - 11 on 12 - WGF11 Filter
  • D3D12 - 11 on 12 - WGF11 Filter (subset)
  • D3D12 - 11 on 12 - WGF11 Input Assembler
  • D3D12 - 11 on 12 - WGF11 Input Assembler (subset)
  • D3D12 - 11 on 12 - WGF11 Multisample
  • D3D12 - 11 on 12 - WGF11 Multisample (subset)
  • D3D12 - 11 on 12 - WGF11 Pixel Shader
  • D3D12 - 11 on 12 - WGF11 Precision
  • D3D12 - 11 on 12 - WGF11 Rasterizer
  • D3D12 - 11 on 12 - WGF11 Render Targets
  • D3D12 - 11 on 12 - WGF11 Render Targets (subset)
  • D3D12 - 11 on 12 - WGF11 Resource Access
  • D3D12 - 11 on 12 - WGF11 Resource Access (subset)
  • D3D12 - 11 on 12 - WGF11 Resource Formats
  • D3D12 - 11 on 12 - WGF11 Shader 5x
  • D3D12 - 11 on 12 - WGF11 Shader 5x (subset)
  • D3D12 - 11 on 12 - WGF11 Shader 5x - PSO Cache
  • D3D12 - 11 on 12 - WGF11 Streamout
  • D3D12 - 11 on 12 - WGF11 Streamout (subset)
  • D3D12 - 11 on 12 - WGF11 Tessellation
  • D3D12 - 11 on 12 - WGF11 Tessellation (subset)
  • D3D12 - 11 on 12 - WGF11 TiledResources
  • D3D12 - 11 on 12 - WGF11 Vertex Shader
  • D3D12 - 11 on 12 - WGF11 Viewports
  • D3D12 - 11on12Video - DecodeVPBlit
  • D3D12 - 9on12Video - CheckBufferInfo
  • D3D12 - 9on12Video - CreateVideoDecoder
  • D3D12 - 9on12Video - CreateVideoDevice
  • D3D12 - 9on12Video - CreateVideoProcessor
  • D3D12 - 9on12Video - DecodeVPBlit
  • D3D12 - 9on12Video - VideoProcessorBlt
  • D3D12 - Allocation Info
  • D3D12 - Async Timing
  • D3D12 - Basic WriteBufferImmediate Test
  • D3D12 - Binding Initialized Validation
  • D3D12 - Bundle BlendFactor Test
  • D3D12 - Bundle DescriptorTable Test
  • D3D12 - Bundle Dispatch Test
  • D3D12 - Bundle ImmediateConstantBuffer Test
  • D3D12 - Bundle InputLayout Test
  • D3D12 - Bundle Markers Disabled
  • D3D12 - Bundle Markers Enabled
  • D3D12 - Bundle Pso Test
  • D3D12 - Bundle Resubmit Test
  • D3D12 - Bundle Root Constant inheritance Test
  • D3D12 - Bundle RootSignature Switch Test
  • D3D12 - Bundle Rundown
  • D3D12 - Bundle StencilReference Test
  • D3D12 - CPU MMU Isolation
  • D3D12 - Clear Depth Stencil Test
  • D3D12 - CommandAllocator Reset Test
  • D3D12 - CommandList Destruction Test
  • D3D12 - Common State Promotion for Descriptors in Table Validation
  • D3D12 - Common State Promotion for Root Descriptors Validation
  • D3D12 - Compute Timestamps
  • D3D12 - Conservative Rasterization
  • D3D12 - Copy Queue Timestamps
  • D3D12 - Copy across different Command Lists Validation
  • D3D12 - Copy Timestamps
  • D3D12 - Counters And Queries Tests
  • D3D12 - CreateVideoDecoder
  • D3D12 - CreateVideoDevice
  • D3D12 - Cross API Sharing of Protected Resources
  • D3D12 - Cross Adapter Resource DX12
  • D3D12 - DCL Resubmit Test
  • D3D12 - DXIL 16bit Types Test - Acos instruction
  • D3D12 - DXIL 16bit Types Test - And instruction
  • D3D12 - DXIL 16bit Types Test - Asin instruction
  • D3D12 - DXIL 16bit Types Test - Atan instruction
  • D3D12 - DXIL 16bit Types Test - Bfrev instruction
  • D3D12 - DXIL 16bit Types Test - CBuffer Test
  • D3D12 - DXIL 16bit Types Test - Cos instruction
  • D3D12 - DXIL 16bit Types Test - FAbs instruction
  • D3D12 - DXIL 16bit Types Test - FAdd instruction
  • D3D12 - DXIL 16bit Types Test - FDiv instruction
  • D3D12 - DXIL 16bit Types Test - FMad instruction
  • D3D12 - DXIL 16bit Types Test - FMin instruction
  • D3D12 - DXIL 16bit Types Test - FMul instruction
  • D3D12 - DXIL 16bit Types Test - FSub instruction
  • D3D12 - DXIL 16bit Types Test - FirstbitHi instruction
  • D3D12 - DXIL 16bit Types Test - FirstbitLo instruction
  • D3D12 - DXIL 16bit Types Test - FirstbitSHi instruction
  • D3D12 - DXIL 16bit Types Test - Frc instruction
  • D3D12 - DXIL 16bit Types Test - Hcos instruction
  • D3D12 - DXIL 16bit Types Test - Hsin instruction
  • D3D12 - DXIL 16bit Types Test - Htan instruction
  • D3D12 - DXIL 16bit Types Test - IAdd instruction
  • D3D12 - DXIL 16bit Types Test - IMad instruction
  • D3D12 - DXIL 16bit Types Test - IMax instruction
  • D3D12 - DXIL 16bit Types Test - IMin instruction
  • D3D12 - DXIL 16bit Types Test - IMul instruction
  • D3D12 - DXIL 16bit Types Test - ISub instruction
  • D3D12 - DXIL 16bit Types Test - IsFinite instruction
  • D3D12 - DXIL 16bit Types Test - IsInf instruction
  • D3D12 - DXIL 16bit Types Test - IsNaN instruction
  • D3D12 - DXIL 16bit Types Test - LShr instruction
  • D3D12 - DXIL 16bit Types Test - Or instruction
  • D3D12 - DXIL 16bit Types Test - Round_ne instruction
  • D3D12 - DXIL 16bit Types Test - Round_ni instruction
  • D3D12 - DXIL 16bit Types Test - Round_pi instruction
  • D3D12 - DXIL 16bit Types Test - Round_z instruction
  • D3D12 - DXIL 16bit Types Test - Rsqrt instruction
  • D3D12 - DXIL 16bit Types Test - Shl instruction
  • D3D12 - DXIL 16bit Types Test - Sin instruction
  • D3D12 - DXIL 16bit Types Test - Sqrt instruction
  • D3D12 - DXIL 16bit Types Test - Tan instruction
  • D3D12 - DXIL 16bit Types Test - UAdd instruction
  • D3D12 - DXIL 16bit Types Test - UMad instruction
  • D3D12 - DXIL 16bit Types Test - UMax instruction
  • D3D12 - DXIL 16bit Types Test - UMin instruction
  • D3D12 - DXIL 16bit Types Test - UMul instruction
  • D3D12 - DXIL 16bit Types Test - USub instruction
  • D3D12 - DXIL 16bit Types Test - Xor instruction
  • D3D12 - DXIL Core Test - And instruction
  • D3D12 - DXIL Core Test - Basic 64-bit int test
  • D3D12 - DXIL Core Test - Basic OutOfBoundsTest
  • D3D12 - DXIL Core Test - Basic partial derivative test
  • D3D12 - DXIL Core Test - Basic shader model 6.1 test
  • D3D12 - DXIL Core Test - Basic shader model 6.3 test
  • D3D12 - DXIL Core Test - Bfi instruction
  • D3D12 - DXIL Core Test - Bfrev instruction
  • D3D12 - DXIL Core Test - Countbits instruction
  • D3D12 - DXIL Core Test - Dot instruction
  • D3D12 - DXIL Core Test - FAbs instruction
  • D3D12 - DXIL Core Test - FAdd instruction
  • D3D12 - DXIL Core Test - FDiv instruction
  • D3D12 - DXIL Core Test - FMad instruction
  • D3D12 - DXIL Core Test - FMin instruction
  • D3D12 - DXIL Core Test - FMul instruction
  • D3D12 - DXIL Core Test - FSub instruction
  • D3D12 - DXIL Core Test - FirstBitLo instruction
  • D3D12 - DXIL Core Test - FirstbitHi instruction
  • D3D12 - DXIL Core Test - FirstbitSHi instruction
  • D3D12 - DXIL Core Test - Hcos instruction
  • D3D12 - DXIL Core Test - Hsin instruction
  • D3D12 - DXIL Core Test - Htan instruction
  • D3D12 - DXIL Core Test - IAdd instruction
  • D3D12 - DXIL Core Test - IDiv instruction
  • D3D12 - DXIL Core Test - IMad instruction
  • D3D12 - DXIL Core Test - IMax instruction
  • D3D12 - DXIL Core Test - IMin instruction
  • D3D12 - DXIL Core Test - IMul instruction
  • D3D12 - DXIL Core Test - ISub instruction
  • D3D12 - DXIL Core Test - IsFinite instruction
  • D3D12 - DXIL Core Test - IsInf instruction
  • D3D12 - DXIL Core Test - IsNaN instruction
  • D3D12 - DXIL Core Test - LShr instruction
  • D3D12 - DXIL Core Test - Or instruction
  • D3D12 - DXIL Core Test - Saturate instruction test
  • D3D12 - DXIL Core Test - Shl instruction
  • D3D12 - DXIL Core Test - Sign instruction test
  • D3D12 - DXIL Core Test - UAdd instruction
  • D3D12 - DXIL Core Test - UDiv instruction
  • D3D12 - DXIL Core Test - UMad instruction
  • D3D12 - DXIL Core Test - UMax instruction
  • D3D12 - DXIL Core Test - UMin instruction
  • D3D12 - DXIL Core Test - UMul instruction
  • D3D12 - DXIL Core Test - USub instruction
  • D3D12 - DXIL Core Test - Xor instruction
  • D3D12 - DXIL Core Test - acos instruction
  • D3D12 - DXIL Core Test - asin instruction
  • D3D12 - DXIL Core Test - atan instruction
  • D3D12 - DXIL Core Test - cos instruction
  • D3D12 - DXIL Core Test - exp instruction
  • D3D12 - DXIL Core Test - frc instruction
  • D3D12 - DXIL Core Test - log instruction
  • D3D12 - DXIL Core Test - round_ne instruction
  • D3D12 - DXIL Core Test - round_ni instruction
  • D3D12 - DXIL Core Test - round_pi instruction
  • D3D12 - DXIL Core Test - round_z instruction
  • D3D12 - DXIL Core Test - rsqrt instruction
  • D3D12 - DXIL Core Test - sin instruction
  • D3D12 - DXIL Core Test - sqrt instruction
  • D3D12 - DXIL Core Test - tan instruction
  • D3D12 - DXIL Int64 Test - UAddc instruction
  • D3D12 - DXIL SM 6.2 DenormMode Test - FAddDenormAny
  • D3D12 - DXIL SM 6.2 DenormMode Test - FAddDenormFTZ
  • D3D12 - DXIL SM 6.2 DenormMode Test - FAddDenormPreserve
  • D3D12 - DXIL SM 6.2 DenormMode Test - FDivDenormAny
  • D3D12 - DXIL SM 6.2 DenormMode Test - FDivDenormFTZ
  • D3D12 - DXIL SM 6.2 DenormMode Test - FDivDenormPreserve
  • D3D12 - DXIL SM 6.2 DenormMode Test - FMadDenormAny
  • D3D12 - DXIL SM 6.2 DenormMode Test - FMadDenormFTZ
  • D3D12 - DXIL SM 6.2 DenormMode Test - FMadDenormPreserve
  • D3D12 - DXIL SM 6.2 DenormMode Test - FMulDenormAny
  • D3D12 - DXIL SM 6.2 DenormMode Test - FMulDenormFTZ
  • D3D12 - DXIL SM 6.2 DenormMode Test - FMulDenormPreserve
  • D3D12 - DXIL SM 6.2 DenormMode Test - FSubDenormAny
  • D3D12 - DXIL SM 6.2 DenormMode Test - FSubDenormFTZ
  • D3D12 - DXIL SM 6.2 DenormMode Test - FSubDenormPreserve
  • D3D12 - DXIL Wave Op Test - WaveActiveAllEqual instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveAllTrue instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveAnyTrue instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveBitAnd instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveBitOr instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveBitXor instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveCountBits instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveMax instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveMin instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveProduct instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveSum instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveUMax instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveUMin instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveUProduct instruction
  • D3D12 - DXIL Wave Op Test - WaveActiveUSum instruction
  • D3D12 - DXIL Wave Op Test - WaveIntrinsicsInPSTest
  • D3D12 - DXIL Wave Op Test - WavePrefixCountBits instruction
  • D3D12 - DXIL Wave Op Test - WavePrefixProduct instruction
  • D3D12 - DXIL Wave Op Test - WavePrefixSum instruction
  • D3D12 - DXIL Wave Op Test - WavePrefixUProduct instruction
  • D3D12 - DXIL Wave Op Test - WavePrefixUSum instruction
  • D3D12 - Debug Layer GBV - Buffer descriptor out of bounds with static descriptors validation
  • D3D12 - Debug Layer GBV - Copy across different Command Lists Validation for Upload and Readback resources
  • D3D12 - Debug Layer GBV - Initialized Validation for Shader Instructions that do not read or write from resources
  • D3D12 - Debug Layer GBV - Resource State across Multiple threads, Command Queues and Command Lists Validation
  • D3D12 - Debug Layer GBV - Simple Sampler Mode Mismatch Validation
  • D3D12 - Decay Validation
  • D3D12 - Decode Histogram
  • D3D12 - DecodePredicationH264
  • D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs
  • D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs when range is inverted [FLT_MAX, -FLT_MAX]
  • D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs when range is set to [-FLT_MAX, FLT_MAX]
  • D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs when set via a bundle
  • D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target when no depth buffer is bound
  • D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target when no depth buffer is bound and range is set to [0,1]
  • D3D12 - DepthCopy Test
  • D3D12 - Depth-Read Stencil-Write
  • D3D12 - Depth-Write Stencil-Read
  • D3D12 - DirectCommandListReset test
  • D3D12 - Global Realtime Command Queue Priority
  • D3D12 - Heap CPU Access Test
  • D3D12 - Heap Of Unaligned Size Test
  • D3D12 - History Buffer Format Test
  • D3D12 - Index Buffer Format and Strip Cut
  • D3D12 - Indirect Draw - Bundle test
  • D3D12 - Indirect Draw - Draw Indexed test
  • D3D12 - Indirect Draw - Indirect Dispatch test
  • D3D12 - Indirect Draw - Stress test
  • D3D12 - Large Resource Copy Test
  • D3D12 - Late Latch Atomic Copy Barrier
  • D3D12 - Late Latch Atomic Copy Miscellaneous
  • D3D12 - Late Latch Atomic Copy UINT
  • D3D12 - Late Latch Atomic Copy UINT64
  • D3D12 - Latest Versions
  • D3D12 - Linked Adapter Features
  • D3D12 - Long CommandLists Execution test
  • D3D12 - Metacommands - Batch Normalization
  • D3D12 - Metacommands - Convolution
  • D3D12 - Metacommands - Copy Tensor
  • D3D12 - Metacommands - Data modification between executions
  • D3D12 - Metacommands - Gated Recurrent Unit
  • D3D12 - Metacommands - General Matrix Multiplication
  • D3D12 - Metacommands - Long Short Term Memory
  • D3D12 - Metacommands - Mean Variance Normalization
  • D3D12 - Metacommands - Pooling
  • D3D12 - Metacommands - Recurrent Neural Network
  • D3D12 - Metacommands - Reduction
  • D3D12 - Metacommands - Reflection Metadata
  • D3D12 - Metacommands - Region of Interest Pooling
  • D3D12 - Metacommands - Validate Dirty State
  • D3D12 - Miscellaneous Residency Test
  • D3D12 - MultiDecodeSingleCommandListH264
  • D3D12 - MultiEngine
  • D3D12 - MultiResSingleCommandListH264
  • D3D12 - Multiple Heaps Residency interaction Test
  • D3D12 - Multiple Resources Test
  • D3D12 - Multiple Threads Wait For A Single Fence Test
  • D3D12 - Multiple Threads Wait For Multiple Fences Test
  • D3D12 - MultiThreaded Create Record and ExecuteTest
  • D3D12 - MultiThreaded Execution Test
  • D3D12 - MultiThreaded Recording ConstantBuffer Test
  • D3D12 - MultiThreaded Recording Speed Test
  • D3D12 - MultiThreaded Recording Test
  • D3D12 - Null IB VB SO
  • D3D12 - NULL PSO Compute test
  • D3D12 - Null PSO Graphics test
  • D3D12 - Overlapping Resources Test
  • D3D12 - Placed Views Test
  • D3D12 - PSO Deduplication Test
  • D3D12 - PS-Specified Stencil Reference
  • D3D12 - Programmable MSAA Test Decompress -
  • D3D12 - Programmable MSAA Test Hardware Tier 1 -
  • D3D12 - Programmable MSAA Test Hardware Tier 2 -
  • D3D12 - Programmable MSAA Test Resource Copy -
  • D3D12 - Rasterizer Ordered Views
  • D3D12 - Raytracing
  • D3D12 - Raytracing Any Hit Tests
  • D3D12 - Raytracing Barriers
  • D3D12 - Raytracing Barycentric
  • D3D12 - Raytracing Command List State
  • D3D12 - Raytracing HLSL
  • D3D12 - Raytracing Intersection
  • D3D12 - Raytracing Recursion
  • D3D12 - Raytracing Shader Tables
  • D3D12 - Raytracing TraceRay
  • D3D12 - Raytracing Watertightness
  • D3D12 - Red Blue Test
  • D3D12 - RelaxedCasting
  • D3D12 - Render Passes
  • D3D12 - RenderTargetArrayIndex and ViewportArrayIndex from VS and DS
  • D3D12 - Resource Barrier Batch - Texture2D
  • D3D12 - Resource Barrier Transition - Buffers
  • D3D12 - Resource Barrier Transition - Depth Texture2D
  • D3D12 - Resource Barrier Transition - Texture2D
  • D3D12 - Resource Binding - Basic API Index Vertex
  • D3D12 - Resource Binding - Basic Depth Stencil
  • D3D12 - Resource Binding - Basic Stream Output
  • D3D12 - Resource Binding - Clear Compute Root Arguments
  • D3D12 - Resource Binding - Clear Graphics Root Arguments
  • D3D12 - Resource Binding - Compute deferred descriptor editing test.
  • D3D12 - Resource Binding - Compute Root Constant Buffer Views
  • D3D12 - Resource Binding - Compute Root Constants
  • D3D12 - Resource Binding - Compute Root Shader Resource Views
  • D3D12 - Resource Binding - Compute Root Unordered Access Views
  • D3D12 - Resource Binding - Copy Descriptor Simple Non Shader visiable to Shader Visible Test
  • D3D12 - Resource Binding - Copy Descriptors using the copy descriptor API to do the exact same as the CopyDescriptorSimple
  • D3D12 - Resource Binding - Degenerate root signature variation test
  • D3D12 - Resource Binding - Graphics deferred descriptor editing test.
  • D3D12 - Resource Binding - Graphics Root Constant Buffer Views
  • D3D12 - Resource Binding - Graphics Root Constants
  • D3D12 - Resource Binding - Graphics Root Shader Resource Views
  • D3D12 - Resource Binding - Graphics Root Unordered Access Views
  • D3D12 - Resource Binding - Max binding test for tier 1 hardware
  • D3D12 - Resource Binding - Max binding test for tier 2 hardware
  • D3D12 - Resource Binding - Max binding test for tier 3 hardware
  • D3D12 - Resource Binding - Max Descriptor Heap Size
  • D3D12 - Resource Binding - Max Descriptor Heap Size shader model 5.1
  • D3D12 - Resource Binding - Max Sampler Descriptor Heap Size for Shader Model 5_0
  • D3D12 - Resource Binding - Max Sampler Descriptor Heap Size for Shader Model 5_1
  • D3D12 - Resource Binding - Null Descriptor Access
  • D3D12 - Resource Binding - Null Descriptor Access Compute
  • D3D12 - Resource Binding - Out of Order and Aliased Bindings
  • D3D12 - Resource Binding - Root signature variation test
  • D3D12 - Resource Binding - ScatterGather copy descriptors from one heap into another
  • D3D12 - Resource Binding - Shader Resource Visibility
  • D3D12 - Resource Copy Test MultiQueue
  • D3D12 - Resource Copy Test MultiQueue with compute
  • D3D12 - Resource Serialization
  • D3D12 - Resource State across Multiple Command Lists executed together by a Command Queue Validation
  • D3D12 - Resource State across Multiple Command Lists Validation
  • D3D12 - Resource State Validation
  • D3D12 - SetBlendFactorTest test
  • D3D12 - SetScissors test
  • D3D12 - SetStencilReference test
  • D3D12 - SetViewportsTest test
  • D3D12 - Shader Cache Tests
  • D3D12 - Shader Disassembly Tests
  • D3D12 - Signal a Fence directly test
  • D3D12 - Signal a fence from command queue Test
  • D3D12 - Simple Descriptor Table Register Index Out of Bounds Validation
  • D3D12 - Simple Descriptor Type Mismatch Validation
  • D3D12 - Simple ETW Check Test
  • D3D12 - Simple Heap Index Out of Bounds Validation
  • D3D12 - Simple Invalid Resource Validation
  • D3D12 - Simple Resource Barrier Validation
  • D3D12 - Simple Resource Dimension Mismatch Validation
  • D3D12 - Simple Resource State for Non Shader Access resources Validation
  • D3D12 - Simple Resource State Validation
  • D3D12 - Simple Root Descriptor Out of Bounds Validation
  • D3D12 - Simple Split Barrier Validation
  • D3D12 - Simple Uninitialized Descriptor Table Validation
  • D3D12 - SRVSwizzle
  • D3D12 - SingleCommandListTimestampsDecode
  • D3D12 - SingleCommandListTimestampsProcess
  • D3D12 - SingleDecodeH264
  • D3D12 - Standard Swizzle Test
  • D3D12 - State Object Creation
  • D3D12 - Static Samplers Basic
  • D3D12 - Static Samplers Limit Stress
  • D3D12 - StressBind test
  • D3D12 - Subresource State Validation in Shader Instructions
  • D3D12 - System Reserved Root Signature Space
  • D3D12 - Timestamp Range
  • D3D12 - Tracked Workloads
  • D3D12 - Typed UAV Load
  • D3D12 - UMH - Reserved Resource Copy Mapping Test
  • D3D12 - UMH - Reserved Resource Copy Tiles Test
  • D3D12 - UMH - Reserved Resource Update Mapping Test
  • D3D12 - Video - CheckBufferInfo
  • D3D12 - Video - CreateVideoDecodeOutputView
  • D3D12 - Video - CreateVideoDecoder
  • D3D12 - Video - CreateVideoDevice
  • D3D12 - Video - CreateVideoProcessor
  • D3D12 - Video - GetDecodingStatus
  • D3D12 - Video - SingleDecodeH264
  • D3D12 - Video - SingleDecodeHEVC
  • D3D12 - Video - SingleDecodeVC1
  • D3D12 - Video - SingleDecodeVP9
  • D3D12 - Video - VideoProcessorBlt
  • D3D12 - Video - VideoProcessorSetGet
  • D3D12 - VideoProcessAndDecodeMarkers
  • D3D12 - VideoProcessFramesPredication
  • D3D12 - View Instancing test
  • D3D9 - Cross Adapter Resource Support
  • D3D9 Overlay - CheckDeviceOverlayType
  • D3D9 Overlay - CreateAdditionalSwapChain
  • D3D9 Overlay - CreateDeviceEx
  • D3D9 Overlay - PresentEx
  • DF - InfVerif INF Verification
  • Depth Bias
  • Depth Bias (WoW64)
  • Discardable Depth Stencil
  • Discardable Depth Stencil (WoW64)
  • Discardable Depth Stencil 2-10-10-10
  • Discardable Depth Stencil 2-10-10-10 (WoW64)
  • Displacement Mapping
  • Displacement Mapping (WoW64)
  • Display Mode Filter Check
  • DisplaySizeTest (Mobile, Manual)
  • Driver Layering Check
  • Driver Scenario
  • Driver Scenario (WoW64)
  • DX11 3DStereoVideo
  • DX11 Video Rotation
  • DX11 Video Rotation for overlay
  • DX11 VideoProcessing
  • DX11 VideoProcessing for Overlay
  • DXGI Cross Process Resource Sharing
  • DXGI Cross Process Resource Sharing (WoW64)
  • DXGI DirectFlip
  • DXGI Frame Statistics
  • DXGI Frame Statistics (WoW64)
  • DXGI Gamma Ramps
  • DXGI Gamma Ramps (WoW64)
  • DXGI GDI Interop D3D10.1
  • DXGI GDI Interop D3D11
  • DXGI Multi-Present
  • DXGI Multi-Present (WoW64)
  • DXGI Presentation Rate Testing
  • DXGI Presentation Rate Testing (WoW64)
  • DXGI Presentation testing - FSPresentMS
  • DXGI Presentation testing - FSPresentMS (WoW64)
  • DXGI Presentation testing - Other
  • DXGI Presentation testing - Other - multihead
  • DXGI Presentation testing - Other - multihead (WoW64)
  • DXGI Presentation testing - Other (WoW64)
  • DXGI Presentation testing - WinpresentMS
  • DXGI Presentation testing - WinpresentMS (WoW64)
  • DXGI Resource Check
  • DXGI Resource Check (WoW64)
  • DXGI Stereo Present
  • DXGI Stereo Present (WoW64)
  • DXGI Swap Effects
  • DXGI Swap Effects (WoW64)
  • DXGI Trim AutoMemoryBenchmark
  • DXGI Trim Memory
  • DXGI Trim Memory (WoW64)
  • DXVA High Definition Video Processing - CreateDevice
  • DXVA High Definition Video Processing - CreateVideoProcessor
  • DXVA High Definition Video Processing - CreateVideoSurface
  • DXVA High Definition Video Processing - VideoProcessing
  • Dynamic Resources
  • Dynamic Resources (WoW64)
  • Fill Modes
  • Fill Modes (WoW64)
  • Four Character Code Surface Stability Test (WoW64)
  • Functional test for monitor container ID
  • Gamma Correction
  • Gamma Correction (WoW64)
  • GDIHW_Functional test for GDI HW ACC (v1.1)
  • GDIHW_Functional test for GDI HW ACC (v1.1) (WoW64)
  • Geometry Instancing
  • Geometry Instancing (WoW64)
  • Get DC
  • Get DC (WoW64)
  • GetInfo (WoW64)
  • GetRasterStatus
  • GetRasterStatus (WoW64)
  • GetRenderTargetData - Backbuffer and Render Target
  • GetRenderTargetData - Backbuffer and Render Target (WoW64)
  • GetRenderTargetData - Mip Texture and Cube Texture
  • GetRenderTargetData - Mip Texture and Cube Texture (WoW64)
  • Graphics Device Runtime Power Management Component Validation
  • Graphics Driver Installation During OS Setup.
  • H264 multi instance test 400
  • H264 playback test 1
  • H264 playback test 10
  • H264 playback test 11
  • H264 playback test 12
  • H264 playback test 13
  • H264 playback test 14
  • H264 playback test 15
  • H264 playback test 16
  • H264 playback test 17
  • H264 playback test 18
  • H264 playback test 19
  • H264 playback test 2
  • H264 playback test 3
  • H264 playback test 4
  • H264 playback test 5
  • H264 playback test 6
  • H264 playback test 7
  • H264 playback test 8
  • H264 playback test 9
  • H264 quality test 202
  • H264 stress test 300
  • HEVCMultiInstanceTest410
  • HEVCMultiInstanceTest411
  • HEVCMultiInstanceTest412
  • HEVCMultiInstanceTest413
  • HEVCMultiInstanceTest414
  • HEVCMultiInstanceTest415
  • HEVCStressTest310
  • HEVCStressTest311
  • HEVCStressTest312
  • HeterogeneousRRI - Core Test
  • HeterogeneousRRI - IHV Bring-up Test
  • Index Buffer
  • Index Buffer (WoW64)
  • Indirect Display Inactive Path
  • Indirect Display Mode Change
  • Indirect Display Pnp Stop-Start Indirect Display Adapter
  • Indirect Display Pnp Stop-Start Render Adapter
  • Indirect Display Render Adapter TDR
  • IoMmu Support
  • Level9 Instancing
  • Level9 Instancing (WoW64)
  • Lightmap
  • Lightmap - Alpha
  • Lightmap - Alpha (WoW64)
  • Lightmap - Factor
  • Lightmap - Factor (WoW64)
  • Lightmap - Stability Mix (WoW64)
  • Lightmap (WoW64)
  • Link training on hibernation
  • Link training on monitor power transition
  • Link training on physical mode change
  • Link training on system sleep
  • Link training on virtual mode change
  • Lockable Depth Buffer
  • Lockable Depth Buffer (WoW64)
  • Lost Devices - Resource Management DX9 w Lost Texture
  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)
  • Lost Devices - Resource Management DX9 w-o Lost Texture
  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)
  • Lost Devices - Resource Management DX9.L
  • Lost Devices - Resource Management DX9.L (WoW64)
  • Maximum Primitives
  • Maximum Primitives (WoW64)
  • Memory Leak Verifier (WoW64)
  • Memory-Texture Management (WoW64)
  • MipFilter
  • MipFilter (WoW64)
  • Monitor ACPI _PLD (Physical Device Location)
  • MoveTest
  • MPEG2 fuzz test 107
  • MPEG2 fuzz test 108
  • MPEG2 fuzz test 109
  • MPEG2 Multi-Instance test 403
  • MPEG2 playback test 20
  • MPEG2 playback test 21
  • MPEG2 playback test 22
  • MPEG2 playback test 23
  • MPEG2 playback test 24
  • MPEG2 playback test 25
  • MPEG2 playback test 27
  • MPEG2 playback test 28
  • MPEG2 playback test 30
  • MPEG2 playback test 31
  • MPEG2 quality test 206
  • MPEG2 quality test 207
  • MPEG2 quality test 211
  • MPEG2 Stress test 303
  • MultiHead Support
  • MultiHead Support (WoW64)
  • Multimon minimum resolution check - Multihead
  • Multipass Z-Fighting
  • Multipass Z-Fighting (WoW64)
  • Multiple Lights
  • Multiple Lights (WoW64)
  • Multiple Render Targets
  • Multiple Render Targets (WoW64)
  • Multisample Stability (WoW64)
  • Multisampling
  • Multisampling (WoW64)
  • Multistream Rendering
  • Multistream Rendering (WoW64)
  • MultiSwapchain
  • MultiSwapchain (WoW64)
  • Non Power 2 Conditional ConfTest
  • Non Power 2 Conditional ConfTest (WoW64)
  • Non Power 2 Conditional RenderTarget
  • Non Power 2 Conditional RenderTarget (WoW64)
  • Non Power 2 Conditional Test (DX9) (WoW64)
  • Non Power 2 Conditional Test (WoW64)
  • Office 2013 Basic Test Cases (Excel)
  • Office 2013 Basic Test Cases (Lync)
  • Office 2013 Basic Test Cases (PowerPoint)
  • Office 2013 Basic Test Cases (Word)
  • OPM - HDCP CSS DVD Test
  • OPM - HDCP CSS DVD Test (WoW64)
  • OPM - HDCP Test
  • OPM - HDCP Test (WoW64)
  • OPM - Protocol Test
  • OPM - Protocol Test (WoW64)
  • OptStandby - Video Memory Purge and Resume
  • Overdraw-Underdraw
  • Overdraw-Underdraw (WoW64)
  • Palettized Textures
  • Palettized Textures (WoW64)
  • Perspective
  • Perspective (WoW64)
  • Pixel Shaders Precision
  • Pixel Shaders Precision (WoW64)
  • Pixel Shaders Ver 1.1
  • Pixel Shaders Ver 1.1 (WoW64)
  • Pixel Shaders Ver 1.2
  • Pixel Shaders Ver 1.2 (WoW64)
  • Pixel Shaders Ver 1.3
  • Pixel Shaders Ver 1.3 (WoW64)
  • Pixel Shaders Ver 1.4
  • Pixel Shaders Ver 1.4 (WoW64)
  • Pixel Shaders Ver 1.x
  • Pixel Shaders Ver 1.x (WoW64)
  • Pixel Shaders Ver 2.0
  • Pixel Shaders Ver 2.0 (WoW64)
  • Pixel Shaders Ver 2.0 Extended
  • Pixel Shaders Ver 2.0 Extended (WoW64)
  • Pixel Shaders Ver 2.0 Landscape - Starburst
  • Pixel Shaders Ver 2.0 Landscape - Starburst (WoW64)
  • Pixel Shaders Ver 2.x
  • Pixel Shaders Ver 2.x (WoW64)
  • Pixel Shaders Ver 3.0
  • Pixel Shaders Ver 3.0 (WoW64)
  • Point Sprites
  • Point Sprites (WoW64)
  • Preempt - Scheduler WLK Validate non-zero preemption values for WDDM1.2 hardware
  • Present Validation (WoW64)
  • Present Validation 2
  • Present Validation 2 - ColorConverting
  • Present Validation 2 - ColorConverting (WoW64)
  • Present Validation 2 - GammaPresent
  • Present Validation 2 - GammaPresent (WoW64)
  • Present Validation 2 - Present
  • Present Validation 2 - Present (WoW64)
  • Present Validation 2 - Vista
  • Present Validation 2 - Vista (WoW64)
  • Present Validation 2 (FullScreen)
  • Present Validation 2 (FullScreen) (WoW64)
  • Present Validation 2 (WoW64)
  • Primitive Batching
  • Primitive Batching (WoW64)
  • Ratetest (WoW64)
  • RenderOnly SetupAPI Test
  • RenderOnly Swapchain Test
  • Set All Preferred Display Modes
  • Set Display Modes with Scaling
  • Set Display Modes with two paths
  • Set None Preferred Display Modes
  • Set Render Target
  • Set Render Target (WoW64)
  • Set Render Target 2-10-10-10
  • Set Render Target 2-10-10-10 (WoW64)
  • SimulatePreemption TDR
  • SimulateVSync TDR
  • State Blocks
  • State Blocks (WoW64)
  • Stencil
  • Stencil (WoW64)
  • Stretch Rect
  • Stretch Rect (WoW64)
  • Subpixel Texture
  • Subpixel Texture (WoW64)
  • TDR Kernel Mode Display Only Driver Tests
  • TDR2 - Large Payload Penalty Compute Application Test
  • TDR2 - Large Payload Penalty Graphics Application Test
  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive)
  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive, PoliceDdi)
  • TDR2 - Long Running Compute Packet Expect TDR (Interactive)
  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive)
  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)
  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)
  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive)
  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive, PoliceDdi)
  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive)
  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive)
  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)
  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)
  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)
  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)
  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)
  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)
  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)
  • Tessellation
  • Tessellation (WoW64)
  • Test CreateDecodeSwapChain For CompositionSurfaceHandle (Native)
  • Test CreateDecodeSwapChain For CompositionSurfaceHandle (WoW64)
  • Test CreateSwapChain (Native)
  • Test CreateSwapChain (WoW64)
  • Test CreateSwapChain For CompositionSurfaceHandle (Native)
  • Test CreateSwapChain For CompositionSurfaceHandle (WoW64)
  • Test CreateSwapChainForHwnd (Native)
  • Test CreateSwapChainForHwnd (WoW64)
  • Test for Custom Presentation Duration Precision (Native)
  • Test for Custom Presentation Duration Precision (WoW64)
  • Test for Custom Presentation Duration Support (Native)
  • Test for Custom Presentation Duration Support (WoW64)
  • Test for EDID Requirements (Manual)
  • TestDefrag
  • TestEngineReset
  • TestEviction
  • TestFlipModes
  • TestHighPriorityOverLowPriority
  • TestPreemptionGranularity
  • TestTransfer
  • Texture Address
  • Texture Address (WoW64)
  • Texture Blend
  • Texture Blend (WoW64)
  • Texture ColorKey (WoW64)
  • Texture Coordinate Generation
  • Texture Coordinate Generation (WoW64)
  • Texture Filter
  • Texture Filter (WoW64)
  • Texture Formats
  • Texture Formats (WoW64)
  • Texture Formats 2-10-10-10
  • Texture Formats 2-10-10-10 (WoW64)
  • Texture Gradient
  • Texture Gradient (WoW64)
  • Texture Load (WoW64)
  • Texture Mapping
  • Texture Mapping (WoW64)
  • Texture Stage
  • Texture Stage (WoW64)
  • Texture Transforms
  • Texture Transforms (WoW64)
  • TL Vertex Clipping
  • TL Vertex Clipping (WoW64)
  • Update Surface
  • Update Surface (WoW64)
  • Update Texture
  • Update Texture (WoW64)
  • VM D3D12 - Clear Depth Stencil Test
  • VM D3D12 - CommandAllocator Reset Test
  • VM D3D12 - CommandList Destruction Test
  • VM D3D12 - Indirect Draw - Draw Indexed test
  • VM D3D12 - Resource Binding - Basic API Index Vertex
  • VM D3D12 - SetViewportsTest test
  • VM DX11 VideoProcessing
  • VM DXGI Frame Statistics
  • VM DXGI Presentation testing - WinpresentMS
  • VM Run Dxgkrnl Smasher MITM module
  • VM Texture Blend
  • VM Vertex Shaders
  • VM WDDM - OfferReclaim11 - Basic Test
  • VM WDDM2 - Make Resident - Verify Standard Test
  • VM WDDM2 - OfferReclaim12 - Basic Test
  • VM WDDM2 - Page Fault Test - Induce Fault 11 Test
  • VM WDDM2 - Page Fault Test - Induce Fault 12 Test
  • VM WDDM2 - Page Fault Test - Induce Fault 9 Test
  • VM WDDM2.2 Periodic frame notification - Precision at various point of the VSync interval
  • VM WGF Create Device
  • VM WGF Feature Level 9.3 Support
  • VM WGF11 Draw (subset)
  • VM WGF11 Pixel Shader
  • VM WGF11 Rasterizer
  • VM WGF11 Render Targets (subset)
  • VM WGF11 Resource Access (subset)
  • VM WGF11 Shader 5x (subset)
  • VM WGF11 SharedResources (subset)
  • VM WGF11 Viewports
  • Validate 3D content runs on 3D Engine
  • Validate Copy content runs on Copy Engine
  • Validate Decode content runs on Decode Engine
  • Validate Engine Meta Data Basic Support
  • Validate Video Processing Content runs on Video Processing Engine
  • VBIB - Vertex and Index Buffer Validation
  • VBIB - Vertex and Index Buffer Validation (WoW64)
  • Verifies that the kernel blocklist returns correct information
  • Verifies that the runtime blocklist returns correct information
  • Verify run from driver store support and file versioning (Graphics Drivers)
  • Verify VESA and CEA required display modes
  • VerifyDefaults
  • VerifyReservation
  • VerifySurpriseRemoval
  • Vertex Blending
  • Vertex Blending (WoW64)
  • Vertex Buffer Rendering
  • Vertex Buffer Rendering (WoW64)
  • Vertex Buffer Swapping
  • Vertex Buffer Swapping (WoW64)
  • Vertex Formats
  • Vertex Formats (WoW64)
  • Vertex Formats- TnL
  • Vertex Formats- TnL (WoW64)
  • Vertex Shaders
  • Vertex Shaders (WoW64)
  • Vertex Shaders Precision
  • Vertex Shaders Precision (WoW64)
  • Vertex Tweening
  • Vertex Tweening (WoW64)
  • Viewport Clipping
  • Viewport Clipping (WoW64)
  • Volume Texture
  • Volume Texture (WoW64)
  • W Buffer
  • W Buffer (WoW64)
  • W Compare
  • W Compare (WoW64)
  • WDDM - OfferReclaim11 - Decommit Force Decommit Test
  • WDDM - OfferReclaim11 - OfferResources1 ReclaimResources1 API Test
  • WDDM2.2 Periodic frame notification - Cancel on mode change - CPU wait
  • WDDM2.2 Periodic frame notification - Cancel on mode change - GPU wait
  • WDDM2.2 Periodic frame notification - Multiple frames ahead
  • WDDM2.2 Periodic frame notification - Precision at various point of the VSync interval
  • WDDM2.2 Periodic frame notification - Precision of simultaneous notifications at various point of the VSync interval
  • WDDM2.2 Periodic frame notification - Test Invalid Parameters
  • WDDM2.2 Periodic frame notification - Very close to each other
  • WDDM2.2 Periodic frame notification - Very close to the VSync boundary
  • WDDM2.4 Mandatory Caps
  • WDDM2.5 Universal ApiValidator Test
  • WGF11 Async (subset)
  • WGF11 Blend (subset)
  • WGF11 Clipping (subset)
  • WGF11 Compute Shader (subset)
  • WGF11 Depth Stencil (subset)
  • WGF11 Draw (subset)
  • WGF11 Fill Rules (subset)
  • WGF11 Filter (subset)
  • WGF11 Input Assembler (subset)
  • WGF11 Multisample (subset)
  • WGF11 Render Targets (subset)
  • WGF11 Resource Access (subset)
  • WGF11 Shader 5x (subset)
  • WGF11 SharedResources (subset)
  • WGF11 Streamout (subset)
  • WGF11 Tessellation (subset)
  • Wait For VBlank
  • Wait For VBlank (WoW64)
  • WDDM - OfferReclaim11 - Allocation States Test
  • WDDM - OfferReclaim11 - API Test
  • WDDM - OfferReclaim11 - Basic Test
  • WDDM - OfferReclaim11 - Decommit Full Test
  • WDDM - OfferReclaim11 - Decommit Lazy Test
  • WDDM - OfferReclaim11 - Decommit Null Test
  • WDDM - OfferReclaim11 - Decommit Partial Test
  • WDDM - OfferReclaim11 - Decommit Query Test
  • WDDM - OfferReclaim11 - Decommit Repurposed Test
  • WDDM - OfferReclaim11 - Lower Commit Test
  • WDDM - OfferReclaim11 - Offer States Test
  • WDDM - OfferReclaim11 - Reclaim Failure Test
  • WDDM - OfferReclaim11 - Shared Allocation Test
  • WDDM Bit Flip - Invalid Param Fifth Group
  • WDDM Bit Flip - Invalid Param First Group
  • WDDM Bit Flip - Invalid Param Fourth Group
  • WDDM Bit Flip - Invalid Param Second Group
  • WDDM Bit Flip - Invalid Param Third Group
  • WDDM Blt
  • WDDM Blt - Depth
  • WDDM Blt - Depth (WoW64)
  • WDDM Blt - DepthFill
  • WDDM Blt - DepthFill (WoW64)
  • WDDM Blt - Stretch
  • WDDM Blt - Stretch (WoW64)
  • WDDM Blt (WoW64)
  • WDDM BVT2
  • WDDM BVT2 (WoW64)
  • WDDM Coherency
  • WDDM Cross Processor
  • WDDM Cross Processor (WoW64)
  • WDDM Dead Lock
  • WDDM DMA Split (Force Split Points)
  • WDDM DMA Split (Force Split Points) (WoW64)
  • WDDM FlipQueue
  • WDDM Fuzzer Allocation- Invalid Param
  • WDDM Fuzzer Command Buffer- Invalid Param
  • WDDM Fuzzer Misc- Invalid Param
  • WDDM GammaRamp
  • WDDM Handles - Invalid Param First Group
  • WDDM Handles - Invalid Param Second Group
  • WDDM Handles - Invalid Param Third Group
  • WDDM HPD Notification Test (Manual)
  • WDDM LockConfirm
  • WDDM LockConfirm (WoW64)
  • WDDM Locksmith
  • WDDM ManagedPrimary
  • WDDM ManagedPrimary (WoW64)
  • WDDM Max Contexts
  • WDDM ModeChange
  • WDDM ModifyVAD
  • WDDM Overlay
  • WDDM Overlay (WoW64)
  • WDDM Pass Through
  • WDDM Pass Through - Lock
  • WDDM Pass Through - Lock (WoW64)
  • WDDM Pass Through - QueryResidency
  • WDDM Pass Through - QueryResidency (WoW64)
  • WDDM Pass Through (WoW64)
  • WDDM PnPMultiModeSwitch Test
  • WDDM PnPStop Test
  • WDDM PnPStopModeSwitch Test
  • WDDM PresentStats - Present Statistics Test
  • WDDM Primary Surface
  • WDDM Primary Surface (WoW64)
  • WDDM Process Callout
  • WDDM RotateBlt Full Screen ColorFillPresent
  • WDDM RotateBlt Full Screen ColorFillPresent (WoW64)
  • WDDM RotateBlt Window D3D
  • WDDM RotateBlt Window D3D (WoW64)
  • WDDM RotateBlt Window GDI
  • WDDM RotateBlt Window GDI (WoW64)
  • WDDM Sch_Stress
  • WDDM Scheduler Stress (AlwaysRepatch)
  • WDDM Scheduler Stress (No PrePatching)
  • WDDM Sync - VolBlt Test
  • WDDM Sync - VolBlt Test (WoW64)
  • WDDM Sync Test
  • WDDM Sync Test (WoW64)
  • WDDM Toaster - Invalid Param Fifth Group
  • WDDM Toaster - Invalid Param First Group
  • WDDM Toaster - Invalid Param Fourth Group
  • WDDM Toaster - Invalid Param Second Group
  • WDDM Toaster - Invalid Param Sixth Group
  • WDDM Toaster - Invalid Param Third Group
  • WDDM Unmap Segment to DummyPage Check
  • WDDM WSSections
  • WDDM2 - Make Resident - Verify Standard Test
  • WDDM2 - Make Resident - Verify Support Test
  • WDDM2 - Map Default Texture - Basic Test
  • WDDM2 - Map Default Texture - Device-dependent layout test
  • WDDM2 - Map Default Texture - Row Major layout test
  • WDDM2 - Map Default Texture - Standard swizzle layout test
  • WDDM2 - Memory Budget Test - Periodic Trim 11 Test
  • WDDM2 - Memory Budget Test - Periodic Trim 9 Test
  • WDDM2 - Memory Budget Test - Trim To Budget 11 Test
  • WDDM2 - Memory Budget Test - Trim To Budget 9 Test
  • WDDM2 - OfferReclaim11 - Working Set Test
  • WDDM2 - OfferReclaim12 - Basic Test
  • WDDM2 - Page Fault Test - Induce Fault 11 Test
  • WDDM2 - Page Fault Test - Induce Fault 12 Test
  • WDDM2 - Page Fault Test - Induce Fault 9 Test
  • WDDM2.1 - Update Allocation Property
  • WDDM20 - Virtual Mode Test
  • WGF Create Device
  • WGF Create Device (WoW64)
  • WGF Feature Level 9.3 Support
  • WGF Feature Level 9.3 Support (WoW64)
  • WGF11 -- Multi-threading -- one-way stress test
  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)
  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)
  • WGF11 -- Multi-threading -- one-way stress test (WoW64)
  • WGF11 -- Multi-threading -- two-way stress test
  • WGF11 -- Multi-threading -- two-way stress test - do not bind
  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)
  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)
  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)
  • WGF11 -- Multi-threading -- two-way stress test - immediate context
  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)
  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)
  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)
  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)
  • WGF11 -- Multi-threading -- two-way stress test (WoW64)
  • WGF11 Async
  • WGF11 Async - DeferredContext
  • WGF11 Async - DeferredContext (WoW64)
  • WGF11 Async (Mobile)
  • WGF11 Async (WoW64)
  • WGF11 Async Deferred (Mobile)
  • WGF11 Blend
  • WGF11 Blend - LogicOps
  • WGF11 Blend - LogicOps (WoW64)
  • WGF11 Blend (D3D10 HW Only)
  • WGF11 Blend (D3D10 HW Only) (WoW64)
  • WGF11 Blend (Featurelevel 10.0) (Pri-1)
  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)
  • WGF11 Blend (Mobile)
  • WGF11 Blend (WoW64)
  • WGF11 Clipping
  • WGF11 Clipping (Mobile)
  • WGF11 Clipping (WoW64)
  • WGF11 Compute (Mobile)
  • WGF11 Compute Shader
  • WGF11 Compute Shader - Dispatch and GroupSharedMemory
  • WGF11 Compute Shader - Dispatch and GroupSharedMemory (WoW64)
  • WGF11 Compute Shader (D3D10.x HW Only)
  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)
  • WGF11 Compute Shader (FL 10.0) (Pri-1)
  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)
  • WGF11 Compute Shader (WoW64)
  • WGF11 D3DWDDM
  • WGF11 D3DWDDM (Mobile)
  • WGF11 D3DWDDM (WoW64)
  • WGF11 Depth Stencil
  • WGF11 Depth Stencil (Mobile)
  • WGF11 Depth Stencil (WoW64)
  • WGF11 Draw
  • WGF11 Draw (Mobile)
  • WGF11 Draw (WoW64)
  • WGF11 Fill Rules
  • WGF11 Fill Rules (Mobile)
  • WGF11 Fill Rules (WoW64)
  • WGF11 Filter
  • WGF11 Filter (Mobile)
  • WGF11 Filter (WoW64)
  • WGF11 Geometry Shader
  • WGF11 Geometry Shader (Mobile)
  • WGF11 Geometry Shader (WoW64)
  • WGF11 Input Assembler
  • WGF11 Input Assembler (Mobile)
  • WGF11 Input Assembler (WoW64)
  • WGF11 Interfaces
  • WGF11 Interfaces (Mobile)
  • WGF11 Interfaces (WoW64)
  • WGF11 Multisample
  • WGF11 Multisample (Mobile)
  • WGF11 Multisample (WoW64)
  • WGF11 Pixel Shader
  • WGF11 Pixel Shader (Mobile)
  • WGF11 Pixel Shader (WoW64)
  • WGF11 Precision
  • WGF11 Precision (Mobile)
  • WGF11 Precision (WoW64)
  • WGF11 Rasterizer
  • WGF11 Rasterizer (Mobile)
  • WGF11 Rasterizer (WoW64)
  • WGF11 Render Targets
  • WGF11 Render Targets (Mobile)
  • WGF11 Render Targets (WoW64)
  • WGF11 Resource Access
  • WGF11 Resource Access (Mobile)
  • WGF11 Resource Access (WoW64)
  • WGF11 Resource Formats
  • WGF11 Resource Formats - BGRA Support on 10.x
  • WGF11 Resource Formats - BGRA Support on 10.x (WoW64)
  • WGF11 Resource Formats (Mobile)
  • WGF11 Resource Formats (WoW64)
  • WGF11 Shader 5x
  • WGF11 Shader 5x - DoubleArith
  • WGF11 Shader 5x - DoubleArith (WoW64)
  • WGF11 Shader 5x - Extended double precision shader instructions
  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)
  • WGF11 Shader 5x (WoW64)
  • WGF11 Shader5x (Mobile)
  • WGF11 SharedResources
  • WGF11 SharedResources (Mobile)
  • WGF11 SharedResources (WoW64)
  • WGF11 Streamout
  • WGF11 Streamout (Mobile)
  • WGF11 Streamout (WoW64)
  • WGF11 Tessellation
  • WGF11 Tessellation (Mobile)
  • WGF11 Tessellation (WoW64)
  • WGF11 TiledResources
  • WGF11 TiledResources (Mobile)
  • WGF11 TiledResources (WoW64)
  • WGF11 Timing Data (Mobile)
  • WGF11 Vertex Shader
  • WGF11 Vertex Shader (Mobile)
  • WGF11 Vertex Shader (WoW64)
  • WGF11 Viewports
  • WGF11 Viewports (Mobile)
  • WGF11 Viewports (WoW64)
  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0
  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1
  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0
  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0 (WoW64)
  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1
  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1 (WoW64)
  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0
  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1
  • WHQL FPO optimization check for kernel video driver(s) (1.1)
  • WHQL FPO optimization check for kernel video driver(s) (1.2)
  • Windows Client System Check For WDDM 1.1 Or Greater Display Driver Support
  • Wireframe
  • Wireframe - TnL
  • Wireframe - TnL (WoW64)
  • Wireframe (WoW64)
  • Wireless Display Verify 1080p
  • Wireless Display Verify Connector Type
  • Wireless Display Verify Container ID Test
  • Wireless Display Verify Edid
  • Wireless Display Verify Frame Quality
  • Wireless Display Verify Hibernate
  • Wireless Display Verify Message Timeouts
  • Wireless Display Verify Miracast Support
  • Wireless Display Verify Mode Change
  • Wireless Display Verify Monitor Arrival Departure
  • Wireless Display Verify Monitor Disconnect
  • Wireless Display Verify Monitor Off
  • Wireless Display Verify OPM On Real Sink
  • Wireless Display Verify PnpStop
  • Wireless Display Verify Protocol
  • Wireless Display Verify Session Connect Disconnect
  • Wireless Display Verify Sink Disconnect
  • Wireless Display Verify Sink Failed To Set Mode
  • Wireless Display Verify Sleep
  • Wireless Display Verify Stability
  • Wireless Display Verify TDR
  • Wireless Display Verify Topology
  • WLP MultiTexturing
  • WLP MultiTexturing (WoW64)
  • WLP RGB Rasterization
  • WLP RGB Rasterization - Mobile (WoW64)
  • WLP RGB Rasterization (WoW64)
  • WLP Specular
  • WLP Specular (WoW64)
  • WLP Texture Sizes
  • WLP Texture Sizes (WoW64)
  • WMV multiInstance test 405
  • WMV Multi-Instance test 406
  • WMV playback test 32
  • WMV playback test 33
  • WMV playback test 34
  • WMV playback test 35
  • WMV playback test 36
  • WMV playback test 37
  • WMV playback test 38
  • WMV playback test 39
  • WMV playback test 40
  • WMV playback test 41
  • WMV playback test 42
  • WMV playback test 43
  • WMV Stress test 305
  • XVP test 1
  • XVP test 10
  • XVP test 109
  • XVP test 11
  • XVP test 110
  • XVP test 2
  • XVP test 3
  • XVP test 4
  • XVP test 5
  • XVP test 6

  • XVP test 92

  • ZeroStateTransitions

  • iFlip Present Desktop - Multihead (Requires 2+ monitors)
  • iFlip Present UAP (Mobile)
  • iFlip Present UAP - Multihead (Requires 2+ monitors)


10L9Constantbuffers (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44229ea8-ccc9-4148-bb09-6b08edab0e6c

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


10L9ShaderMobile (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a12a3e8e-d899-4c9a-b069-f79f04387d8b

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


Alpha Blending - FALSE-TRUE 16bpp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5212733-193e-43c9-80b8-28344cd1b908

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending - FALSE-TRUE 16bpp (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e6470ec-970a-49bc-9a74-424fb323458e

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending - FALSE-TRUE 2-10-10-10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f343625-5172-44ef-97b4-efad6f2df048

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 35
Category | Compatibility
Timeout (in minutes) | 2100
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92778ac7-2363-406f-86b9-e407d9424712

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 35
Category | Compatibility
Timeout (in minutes) | 2100
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending - FALSE-TRUE 32bpp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9b4ef906-1fe4-4a09-9380-b5a6a77b9e59

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending - FALSE-TRUE 32bpp (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c75f5e4-596a-4de7-bcb9-c0632f0da26f

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending Precision

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/441c2c81-3614-40c4-ad4f-582f14e8b8b1

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending Precision

  • Alpha Blending Precision (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Alphaprecision -M:1 -whql -logclean -dx9 | Runs the Alpha Blending Precision test job.
Alphaprecision -M:1 -whql -logclean | Runs the Alpha Blending Precision (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Alphaprecision.exe | [This content isn't available yet.]
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Blending Precision (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d269682-d5cd-42ef-affc-c1d9830c6d9e

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Blending - FALSE-TRUE 16bpp

  • Alpha Blending - FALSE-TRUE 16bpp (WoW64)

  • Alpha Blending - FALSE-TRUE 2-10-10-10

  • Alpha Blending - FALSE-TRUE 2-10-10-10 (WoW64)

  • Alpha Blending - FALSE-TRUE 32bpp

  • Alpha Blending - FALSE-TRUE 32bpp (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 16bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xR5G6B5 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 16bpp (64-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (32-bit) test case.
Alphabld -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -srcalphainvsrcalpha -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 2-10-10-10 (64-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean -dx9 | Runs the Alpha Blending - FALSE-TRUE 32bpp (32-bit) test case.
Alphabld -DisplayMode:?x?xX8R8G8B8 -M:1 -whql -logclean | Runs the Alpha Blending - FALSE-TRUE 32bpp (64-bit) test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Alphabld.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Compare

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3de66a8e-4579-49a8-9370-788b15027543

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Compare

  • Alpha Compare (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Alphacmp.exe -M:1 -whql -logclean -dx9 | Runs the Alpha Compare test job.
Alphacmp.exe -M:1 -whql -logclean | Runs the Alpha Compare (WoW64) test job.

File List

File | Location
Alphacmp.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Alpha Compare (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f20ccd63-5837-4fc1-859f-9e2f34211030

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Alpha Compare

  • Alpha Compare (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Alphacmp.exe -M:1 -whql -logclean -dx9 | Runs the Alpha Compare test job.
Alphacmp.exe -M:1 -whql -logclean | Runs the Alpha Compare (WoW64) test job.

File List

File | Location
Alphacmp.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Anisotropic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/824871da-c279-4e94-83c7-f11e07733c8e

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Anisotropic

  • Anisotropic (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Anisotropic.exe -M:1 -whql -logclean -dx9 | Runs the Anisotropic test job.
Anisotropic.exe -M:1 -whql -logclean | Runs the Anisotropic (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Anisotropic.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Anisotropic (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/04e12829-aba0-41be-b2d2-1bebcb70744b

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Anisotropic

  • Anisotropic (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Anisotropic.exe -M:1 -whql -logclean -dx9 | Runs the Anisotropic test job.
Anisotropic.exe -M:1 -whql -logclean | Runs the Anisotropic (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Anisotropic.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Arbitrary Clipping Planes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0adc55ef-9e02-4bfc-a96e-574826d0a355

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Arbitrary Clipping Planes

  • Arbitrary Clipping Planes (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
UClip.exe -M:1 -whql -logclean -dx9 | Runs the Arbitrary Clipping Planes test job.
UClip.exe -M:1 -whql -logclean | Runs the Arbitrary Clipping Planes (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
UClip.exe | [This content isn't available yet.]
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Arbitrary Clipping Planes (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f770e48-6d29-4184-844b-6f6290b04deb

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Arbitrary Clipping Planes

  • Arbitrary Clipping Planes (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
UClip.exe -M:1 -whql -logclean -dx9 | Runs the Arbitrary Clipping Planes test job.
UClip.exe -M:1 -whql -logclean | Runs the Arbitrary Clipping Planes (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
UClip.exe | [This content isn't available yet.]
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Auto Generation of Mip Maps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aac6b5ce-ae8d-4b1f-ab49-756e5a6b0a9f

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Auto Generation of Mip Maps

  • Auto Generation of Mip Maps (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Mipgen.exe -M:1 -whql -logclean -dx9 | Runs the Auto Generation of Mip Maps test job.
Mipgen.exe -M:1 -whql -logclean | Runs the Auto Generation of Mip Maps (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mipgen.exe | [This content isn't available yet.]
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Auto Generation of Mip Maps (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d768c868-4d6e-4d0c-97c8-99ead8ec3be4

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Auto Generation of Mip Maps

  • Auto Generation of Mip Maps (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Mipgen.exe -M:1 -whql -logclean -dx9 | Runs the Auto Generation of Mip Maps test job.
Mipgen.exe -M:1 -whql -logclean | Runs the Auto Generation of Mip Maps (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mipgen.exe | [This content isn't available yet.]
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Basic Rasterization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84df33c2-8c01-4344-9138-8588daebdf6a

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Basic Rasterization

  • Basic Rasterization (WoW64)

  • Basic Rasterization 2-10-10-10

  • Basic Rasterization 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Basicrst.exe -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization (32-bit) test case.
Basicrst.exe -M:1 -whql -logclean | Runs the Basic Rasterization (64-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization 2-10-10-10 (32-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Basic Rasterization 2-10-10-10 (64-bit) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Basicrst.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Basic Rasterization (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5489a2db-19c7-4bd0-84f7-2769908f4f88

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Basic Rasterization

  • Basic Rasterization (WoW64)

  • Basic Rasterization 2-10-10-10

  • Basic Rasterization 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Basicrst.exe -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization (32-bit) test case.
Basicrst.exe -M:1 -whql -logclean | Runs the Basic Rasterization (64-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization 2-10-10-10 (32-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Basic Rasterization 2-10-10-10 (64-bit) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Basicrst.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Basic Rasterization 2-10-10-10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aee4bbc8-7d7c-43f0-8d4e-5d9725f0c3fb

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Basic Rasterization

  • Basic Rasterization (WoW64)

  • Basic Rasterization 2-10-10-10

  • Basic Rasterization 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Basicrst.exe -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization (32-bit) test case.
Basicrst.exe -M:1 -whql -logclean | Runs the Basic Rasterization (64-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization 2-10-10-10 (32-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Basic Rasterization 2-10-10-10 (64-bit) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Basicrst.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Basic Rasterization 2-10-10-10 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ecbb8e34-2764-4025-b378-e4d3ddc57840

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Basic Rasterization

  • Basic Rasterization (WoW64)

  • Basic Rasterization 2-10-10-10

  • Basic Rasterization 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Basicrst.exe -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization (32-bit) test case.
Basicrst.exe -M:1 -whql -logclean | Runs the Basic Rasterization (64-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean -dx9 | Runs the Basic Rasterization 2-10-10-10 (32-bit) test case.
Basicrst.exe -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Basic Rasterization 2-10-10-10 (64-bit) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Basicrst.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Blocklist Parse Conditions Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea3c7a23-d894-4b12-93cd-802d9eaa294f

Parses various conditions and verifies that it returns the correct result

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Brightness2 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6949d144-dcb0-42dd-90a0-e56d2d17c4ad

Contains: Code: \windowstest\graphics\base\tests\brightness2 Tests: brightness2.dll Tests run on internal monitor. DevX::BaseVideo::TestSmoothBrightenessControl Test uses private escape to verify: - smooth brighness is supported (Skipped if not). - number of brightness levels supported by the driver is more or equal of 101. - smoth brighness ON doesn't afffect Set/Get Brightness DDI functionality. - there is a trasition period ( 0.1< t < 0.5) when brighness changed from MIN to MAX and from MAX to MIN. DevX::BaseVideo::TestAdaptiveBrightnessControl Test uses private escape to verify (with brightness level set to MAX): - adaptive brighness is supported (Skipped if not). - verifies that user brightness seeting (Usersettings) is not affected by different DxgbacklightOptimization levels - verifies that actual brightness (ActualBrightness) is affected by different DxgbacklightOptimization levels as follows: DxgBacklightOptimizationDynamic: Actual <= Actual for otimization OFF. Gamma >= Gamma for optimization OFF. DxgBacklightOptimizationDimmed: Actual <= 0.5* Actual for otimization OFF. Gamma >= Gamma for optimization OFF.

Test details
Specifications
  • Device.Graphics.WDDM12.Display.Base
  • System.Client.BrightnessControls.BacklightOptimization
  • System.Client.BrightnessControls.SmoothBrightness
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 25
Category | Compatibility
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


BrightnessTest (Mobile, Manual)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/851a91b2-bca3-4930-8233-19c44523ca13

Test details
Specifications
  • Device.Graphics.AdapterRender.MaximumDirect9x
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


Bump Env Map

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b49914ff-24a0-42dc-92fb-858c12a95a73

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Bump Env Map

  • Bump Env Map (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Bump -M:1 -whql -logclean -dx9 | Runs the Bump Env Map test job.
Bump -M:1 -whql -logclean | Runs the Bump Env Map (WoW64) test job.

File List

File | Location
Bump.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics\
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Bump Env Map (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/41995634-3418-46ae-8e76-2e0c191dd64c

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Bump Env Map

  • Bump Env Map (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Bump -M:1 -whql -logclean -dx9 | Runs the Bump Env Map test job.
Bump -M:1 -whql -logclean | Runs the Bump Env Map (WoW64) test job.

File List

File | Location
Bump.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics\
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Capscheck

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b64cd1af-2ba3-4855-8ff9-cb2afda34870

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Capscheck

  • Capscheck (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Capscheck -M:1 -whql -logclean -dx9 [CUSTOMPARAM] | This command runs the Capscheck test job.
Capscheck.exe -M:1 -whql -logclean [CUSTOMPARAM] | This command runs the Capscheck (WoW64) test job.

File list

File | Location
Capscheck.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics\
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Capscheck (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/931a08e6-8aba-41f8-aa2a-dc1b10c0f3a1

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Capscheck

  • Capscheck (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Capscheck -M:1 -whql -logclean -dx9 [CUSTOMPARAM] | This command runs the Capscheck test job.
Capscheck.exe -M:1 -whql -logclean [CUSTOMPARAM] | This command runs the Capscheck (WoW64) test job.

File list

File | Location
Capscheck.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics\
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Check Driver SetTimings Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b2-85b3-4337-9249-e5ab1efaccd0

check driver supports DxgkddiSetTimings or not. It is optinal for WDDM 2.2 and required from WDDM 2.3 and later.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Check Resolution (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7bfb0b2-75af-40b7-87b3-d788473ae928

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Check Resolution (WoW64)

  • Check Resolution for Dualview (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.Display.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 75
Category | Compatibility
Timeout (in minutes) | 4500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Chndsp -video | This command runs the Check Resolution (WoW64) test job.
Chndsp -dualview | This command runs the Check Resolution for Dualview (WoW64) test job.

File list

File | Location
Chndsp.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Ntlog.dll | <[testbinroot]>\nttest\commontest\ntlog</p>
NTLogger.ini | <[testbinroot]>\nttest\commontest\ntlog</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Check Resolution for Dualview (WoW64) - multihead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/084a65d3-dd1c-46d8-a7f6-b60e96f74273

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.WDDM.Display.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run this test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration.

Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Check Resource

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b299341f-8923-45c6-8d31-f822c7e93ba7

This automated test uses the D3D9Ex API to verify the QueryResourceResidency function of the user-mode display driver.

This topic is applicable to the following test jobs:

  • Check Resource

  • Check Resource (WoW64)

Applications use QueryResourceResidency to determine if the operating system will pause at draw time to make the resource CPU-accessible. The test runs against the following resource texture types: Cube Texture, Volume Texture, Surface, vertex buffer (VB), and index buffer (IB). For each resource type the test creates the resource, uses the resource in a rending operation, and then checks its residency. If the resource is not resident (fully or in shared memory), the test fails.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ResChk -M:1 -whql -logclean -dx9 | Runs the Check Resource test job.
ResChk -M:1 -whql -logclean | Runs the Check Resource (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | [testbinroot]\nttest\windowstest\tools
D3d10ref.dll | [testbinroot]\nttest\graphics\d3d\support</p>
D3d11ref.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support
D3dref8.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | [testbinroot]\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | [testbinroot]\nttest\windowstest\graphics\d3d\utility</p>
ResChk.exe | [testbinroot]\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | [testbinroot]\nttest\windowstest\graphics</p>
Vbswap.x | [testbinroot]\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Check Resource (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/edcf104f-3293-438c-b3da-82c8fe21db09

This automated test uses the D3D9Ex API to verify the QueryResourceResidency function of the user-mode display driver.

This topic is applicable to the following test jobs:

  • Check Resource

  • Check Resource (WoW64)

Applications use QueryResourceResidency to determine if the operating system will pause at draw time to make the resource CPU-accessible. The test runs against the following resource texture types: Cube Texture, Volume Texture, Surface, vertex buffer (VB), and index buffer (IB). For each resource type the test creates the resource, uses the resource in a rending operation, and then checks its residency. If the resource is not resident (fully or in shared memory), the test fails.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ResChk -M:1 -whql -logclean -dx9 | Runs the Check Resource test job.
ResChk -M:1 -whql -logclean | Runs the Check Resource (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | [testbinroot]\nttest\windowstest\tools
D3d10ref.dll | [testbinroot]\nttest\graphics\d3d\support</p>
D3d11ref.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support
D3dref8.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | [testbinroot]\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | [testbinroot]\nttest\windowstest\graphics\d3d\utility</p>
ResChk.exe | [testbinroot]\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | [testbinroot]\nttest\windowstest\graphics</p>
Vbswap.x | [testbinroot]\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Clear

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3155741-e7c5-4cf0-9cd4-b8a2196afceb

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Clear

  • Clear (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Clear -M:1 -whql -logclean -dx9 | This command runs the Clear test job.
Clear -M:1 -whql -logclean | This command runs the Clear (WoW64) test job.

File list

File | Location
Clear.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Clear (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66d9864e-6eaf-44f2-aec8-b5d4a68df13c

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Clear

  • Clear (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Clear -M:1 -whql -logclean -dx9 | This command runs the Clear test job.
Clear -M:1 -whql -logclean | This command runs the Clear (WoW64) test job.

File list

File | Location
Clear.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Color Fill

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d43a77b-7f14-43f3-b580-c3067762d395

This automated test verifies proper implementation of the driver functionality that supports the IDirect3DDevice9::ColorFill Microsoft Direct3D9 method.

The test cases are defined according to several sets of attributes:

  • The type of destination surface for the ColorFill operation. Valid types are:

    • Render targets.

    • Offscreen plain surfaces in the D3DPOOL_DEFAULT memory pool.

    • Surfaces that belong to render target textures.

      NOTE

      The destination surface is always in the D3DPOOL_DEFAULT memory pool.

  • The format of the destination surface.

  • The destination rectangle, including rectangles that vary by size, aspect ratio, and location, and includes horizontal and vertical lines.

  • The color.

The test validates each case by verifying that the ColorFill operation succeeded, and by comparing the result with a reference image. The surface verification algorithm is applied to the entire destination surface, rather than only to the destination rectangle.

This topic applies to the following test jobs:

  • Color Fill

  • Color Fill (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Colorfill -M:1 -whql -logclean -dx9 | Runs the Color Fill test job.
Colorfill -M:1 -whql -logclean | Runs the Color Fill (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Colorfill.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Color Fill (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0133ddf-15f9-4687-b450-a8fbbd6e6448

This automated test verifies proper implementation of the driver functionality that supports the IDirect3DDevice9::ColorFill Microsoft Direct3D9 method.

The test cases are defined according to several sets of attributes:

  • The type of destination surface for the ColorFill operation. Valid types are:

    • Render targets.

    • Offscreen plain surfaces in the D3DPOOL_DEFAULT memory pool.

    • Surfaces that belong to render target textures.

      NOTE

      The destination surface is always in the D3DPOOL_DEFAULT memory pool.

  • The format of the destination surface.

  • The destination rectangle, including rectangles that vary by size, aspect ratio, and location, and includes horizontal and vertical lines.

  • The color.

The test validates each case by verifying that the ColorFill operation succeeded, and by comparing the result with a reference image. The surface verification algorithm is applied to the entire destination surface, rather than only to the destination rectangle.

This topic applies to the following test jobs:

  • Color Fill

  • Color Fill (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Colorfill -M:1 -whql -logclean -dx9 | Runs the Color Fill test job.
Colorfill -M:1 -whql -logclean | Runs the Color Fill (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Colorfill.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Color Space Transform

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b8-85b3-4337-9249-e5ab1efaccd0

verify driver color space transform if driver supports it.

Test details
Specifications
  • Device.Graphics.WDDM24.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Compare Z

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da6d5393-7380-49af-945c-8f1696747a8d

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Compare Z

  • Compare Z (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Zcmp -M:1 -dx9 -whql -logclean | This command runs the Compare Z test job.
Zcmp.exe -M:1 -whql -logclean | This command runs the Compare Z (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zcmp.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Compare Z (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55f666bf-f2f8-4d55-b646-289776343aac

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Compare Z

  • Compare Z (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Zcmp -M:1 -dx9 -whql -logclean | This command runs the Compare Z test job.
Zcmp.exe -M:1 -whql -logclean | This command runs the Compare Z (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zcmp.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Compressed Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/513d7105-cede-4273-9769-9c009c331905

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Compressed Texture

  • Compressed Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Compress -M:1 -dx9 -whql -logclean | This command runs the Compressed Texture test job.
Compress -M:1 -whql -logclean | This command runs the Compressed Texture (WoW64) test job.

File list

File | Location
Compress.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Compressed Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/354df96d-e0f3-46b3-b1c3-851b01eac271

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Compressed Texture

  • Compressed Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Compress -M:1 -dx9 -whql -logclean | This command runs the Compressed Texture test job.
Compress -M:1 -whql -logclean | This command runs the Compressed Texture (WoW64) test job.

File list

File | Location
Compress.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


CoolingInterface Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6efc91df-8e9c-4eb4-8da3-2840a2eac30f

Contains: Code: \windowstest\graphics\base\tests\ThermalInterface Tests: thermalinterfacetests.dll Tests run on primary display adapter. DevX::GRFX::BaseVideo::TestThermalInterfacePresence Test uses private escape to verify that: - any interface is present (Skipped if not). - if present, the driver should be WDDM 1.3 or higher DevX::GRFX::BaseVideo::TestThermalInterfaceActiveState Test uses private escape to verifyt: - interface is present (Skipped if not). - intrface can be called to turn on/off a fun DevX::GRFX::BaseVideo::TestThermalInterfacePassiveState Test uses private escape to verifyt: - interface is present (Skipped if not). - intrface can be called to set desired power level.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.CoolingInterface.ThermalHints
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 25
Category | Compatibility
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


COPP - HDCP Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4af28343-37aa-4071-8e05-4923acb7c2a9

This automated test runs Certified Output Protection Protocol (COPP) commands to test display drivers for COPP compatibility.

There are three assertions for this test. The display driver must support:

  • COPP driver interfaces.

  • Content Generation Management System Analog (CGMS-A) and analog protection support (APS)

  • High-Bandwidth Digital Content Protection (HDCP).

The test attempts the COPP initialization protocol. If initialization fails, all of the assertions will fail. The tests will not actually verify each protection schema. They only query the driver for the availability.

This topic applies to the following test jobs:

  • COPP - HDCP Test

  • COPP - HDCP Test (WoW64)

  • COPP - Protocol Test

  • COPP - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

For information about requirements, see Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following hardware and actions:

  • On Windows Vista and Windows 7, if the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • On Windows Vista, if the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA test job.
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA (WoW64) test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP (WoW64) test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | [WTT\TestBinRoot]\nttest\windowstest\tools</em>
COPP_Protocol_Test.pro | [testbinroot]\nttest\multimediatest\streaming</em>
COPPTest.dll | [testbinroot]\nttest\multimediatest\streaming</em>
s98wtt_u.dll | [testbinroot]\nttest\multimediatest\common</em>
shellrunner.exe | [testbinroot]\nttest\multimediatest\common\wdk</em>
Smallboat.avi | [testbinroot]\nttest\multimediatest\streaming</em>
TDRWatch.exe | [WTT\TestBinRoot]\nttest\windowstest\graphics</em>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
TESTDATANAME | Test data name
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


COPP - HDCP Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9368a36a-ef6a-4bc0-bb50-e2b5b3906b69

This automated test runs Certified Output Protection Protocol (COPP) commands to test display drivers for COPP compatibility.

There are three assertions for this test. The display driver must support:

  • COPP driver interfaces.

  • Content Generation Management System Analog (CGMS-A) and analog protection support (APS)

  • High-Bandwidth Digital Content Protection (HDCP).

The test attempts the COPP initialization protocol. If initialization fails, all of the assertions will fail. The tests will not actually verify each protection schema. They only query the driver for the availability.

This topic applies to the following test jobs:

  • COPP - HDCP Test

  • COPP - HDCP Test (WoW64)

  • COPP - Protocol Test

  • COPP - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

For information about requirements, see Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following hardware and actions:

  • On Windows Vista and Windows 7, if the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • On Windows Vista, if the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA test job.
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA (WoW64) test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP (WoW64) test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | [WTT\TestBinRoot]\nttest\windowstest\tools</em>
COPP_Protocol_Test.pro | [testbinroot]\nttest\multimediatest\streaming</em>
COPPTest.dll | [testbinroot]\nttest\multimediatest\streaming</em>
s98wtt_u.dll | [testbinroot]\nttest\multimediatest\common</em>
shellrunner.exe | [testbinroot]\nttest\multimediatest\common\wdk</em>
Smallboat.avi | [testbinroot]\nttest\multimediatest\streaming</em>
TDRWatch.exe | [WTT\TestBinRoot]\nttest\windowstest\graphics</em>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
TESTDATANAME | Test data name
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


COPP - Protocol Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0334ebcb-81b4-4aff-9c74-7bdf1fb928df

This automated test runs Certified Output Protection Protocol (COPP) commands to test display drivers for COPP compatibility.

There are three assertions for this test. The display driver must support:

  • COPP driver interfaces.

  • Content Generation Management System Analog (CGMS-A) and analog protection support (APS)

  • High-Bandwidth Digital Content Protection (HDCP).

The test attempts the COPP initialization protocol. If initialization fails, all of the assertions will fail. The tests will not actually verify each protection schema. They only query the driver for the availability.

This topic applies to the following test jobs:

  • COPP - HDCP Test

  • COPP - HDCP Test (WoW64)

  • COPP - Protocol Test

  • COPP - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

For information about requirements, see Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following hardware and actions:

  • On Windows Vista and Windows 7, if the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • On Windows Vista, if the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA test job.
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA (WoW64) test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP (WoW64) test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | [WTT\TestBinRoot]\nttest\windowstest\tools</em>
COPP_Protocol_Test.pro | [testbinroot]\nttest\multimediatest\streaming</em>
COPPTest.dll | [testbinroot]\nttest\multimediatest\streaming</em>
s98wtt_u.dll | [testbinroot]\nttest\multimediatest\common</em>
shellrunner.exe | [testbinroot]\nttest\multimediatest\common\wdk</em>
Smallboat.avi | [testbinroot]\nttest\multimediatest\streaming</em>
TDRWatch.exe | [WTT\TestBinRoot]\nttest\windowstest\graphics</em>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
TESTDATANAME | Test data name
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


COPP - Protocol Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f74891fb-a040-443a-8394-0901d6d64082

This automated test runs Certified Output Protection Protocol (COPP) commands to test display drivers for COPP compatibility.

There are three assertions for this test. The display driver must support:

  • COPP driver interfaces.

  • Content Generation Management System Analog (CGMS-A) and analog protection support (APS)

  • High-Bandwidth Digital Content Protection (HDCP).

The test attempts the COPP initialization protocol. If initialization fails, all of the assertions will fail. The tests will not actually verify each protection schema. They only query the driver for the availability.

This topic applies to the following test jobs:

  • COPP - HDCP Test

  • COPP - HDCP Test (WoW64)

  • COPP - Protocol Test

  • COPP - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

For information about requirements, see Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following hardware and actions:

  • On Windows Vista and Windows 7, if the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • On Windows Vista, if the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA test job.
ShellRunner.exe -x basic -c COPP_ACPandCGMSA_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - ACP and CGMSA (WoW64) test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP test job.
ShellRunner.exe -x basic -c COPP_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - HDCP (WoW64) test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol test job.
ShellRunner.exe -x basic -c COPP_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | This command runs the COPP - Protocol (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | [WTT\TestBinRoot]\nttest\windowstest\tools</em>
COPP_Protocol_Test.pro | [testbinroot]\nttest\multimediatest\streaming</em>
COPPTest.dll | [testbinroot]\nttest\multimediatest\streaming</em>
s98wtt_u.dll | [testbinroot]\nttest\multimediatest\common</em>
shellrunner.exe | [testbinroot]\nttest\multimediatest\common\wdk</em>
Smallboat.avi | [testbinroot]\nttest\multimediatest\streaming</em>
TDRWatch.exe | [WTT\TestBinRoot]\nttest\windowstest\graphics</em>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
TESTDATANAME | Test data name
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


CopyRects Functionality (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a37f9fce-aab8-47f1-b20f-912f9f1086f3

This automated test verifies the functionality that the IDirect3DDevice8::CopyRects method provides by comparing surfaces that tested operations generate with reference surfaces that the test itself generates.

For each Microsoft Direct3D version 8 format, the test uses IDirect3D8::CheckDeviceFormat to determine the surface types, if any, that the driver supports. The test then generates representative surfaces for each combination of format and surface type and performs a set of CopyRects operations for each pair of source and destination surfaces that share the same format. These operations include full-surface copies, subrect copies with and without translation, and copies of multiple overlapping rectangles. In each case, the result of the operation is evaluated automatically by comparing the content of the destination surface with that of a reference surface that the test generates.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Copyrects -M:1 -whql -logclean | This command runs the CopyRects Functionality (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | [testbinroot]\nttest\windowstest\tools
Copyrects.exe | [testbinroot]\nttest\windowstest\graphics\d3d\conf</p>
D3d10ref.dll | [testbinroot]\nttest\graphics\d3d\support</p>
D3d11ref.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support
D3dref8.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | [testbinroot]\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | [testbinroot]\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | [testbinroot]\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | [testbinroot]\nttest\windowstest\graphics</p>
Vbswap.x | [testbinroot]\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


CRASH - Display Stress 4-hour WDDM Profile (32bit)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f48b13b9-a08c-4b84-9146-9c0ffec1c04e

This automated test verifies system stability over a specified time. If the system does not stop responding or encounter a bug check during this specified time, the test is considered a pass.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.Stability
  • System.Fundamentals.Graphics.DisplayRender.StableAndFunctional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
SLP | Unused
SLPATH | Unused
SLF | Unused
SLFILENAME | Unused
CONT | Unused
TRIAGE | Unused
AUTO | auto run
DISPLAYLOGOLEVEL | Submission logo level: Basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


CRASH - Display Stress 4-hour WDDM Profile (64bit)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47fcb092-20ae-42e9-b961-1fb344462108

This automated test verifies system stability over a specified time. If the system does not stop responding or encounter a bug check during this specified time, the test is considered a pass.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.Stability
  • System.Fundamentals.Graphics.DisplayRender.StableAndFunctional
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
SLP | Unused
SLPATH | Unused
SLF | Unused
SLFILENAME | Unused
CONT | Unused
TRIAGE | Unused
AUTO | auto run
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


Cube Mapping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2e5bc32-4c34-49c0-ad8f-0912fb4eb685

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Cube Mapping

  • Cube Mapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Cubemap -M:1 -dx9 -whql -logclean | This command runs the Cube Mapping test job.
Cubemap -M:1 -whql -logclean | This command runs the Cube Mapping (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Cubemap.exe | <[testbinroot]>\nttest</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Cube Mapping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82ec9493-6ac2-409d-8de4-d140a397a70d

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • Cube Mapping

  • Cube Mapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command Syntax

Command option | Description
Cubemap -M:1 -dx9 -whql -logclean | This command runs the Cube Mapping test job.
Cubemap -M:1 -whql -logclean | This command runs the Cube Mapping (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Cubemap.exe | <[testbinroot]>\nttest</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D2D - DImage Effect Tests - 2DAffineTransform

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a4f62f1-5529-4893-a212-10dd1f8b0b64

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - 3DNonTrivial

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bce30c4c-2820-4f07-9266-8c315208d093

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - 3DPerspectiveTransform

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d92985f9-1ff1-4df0-addb-b748f1607559

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - 3DTransform

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf263cac-25cd-46cb-aea8-4c8895e4df9c

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - 3DTransformNoVertex

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c81304d9-da9c-4c54-86a4-9f8512899e2f

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - 3DTransformNoVertexNearPlaneClipping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ff41f4a-f521-4a1a-b424-1cee6b0176b0

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - 3DTransformNoVertexPartiallyInfinite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a267974-0444-41ec-be6b-7d2bc649f4b6

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Antialiasing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b1a48c2-db62-4e40-b94c-e90c89fb1232

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Api

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a96ef710-6ad3-43be-a908-f3a7581e7017

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ArithmeticComposite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1fc95ea6-551b-4a1e-8ea8-02e9a10825b5

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - BatchFlushing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2ecb28e-5951-4f0e-be6f-e91a5309f064

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Batching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b025aba2-b222-4856-82bd-f3443db3b6c2

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - BitmapImageRectangleDpi

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f9ec004-d092-46fb-82d6-e8ea7a6f4933

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - BitmapNullRectangleDpi

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87a221a2-08e7-4f79-b0a7-7d99153ecae4

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - BitmapSource

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/558e6f7d-be21-4b76-b92d-d3e9053b39a5

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - BitmapTiling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c81850ee-7eea-42e2-b196-c17834df8cac

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - BoundsTests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/211a8af8-9920-4603-87b8-f169e8e492ce

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ColorManagement

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/29a3a397-01a7-41d3-a5de-6bb90893687c

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ColorManagementBuiltInSpaces

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2abf88b3-f167-4149-a0f3-1e762020cef4

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Effect Tests - ColorManagementNonTrivial

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0453af3-6ffd-4a67-8fd4-9128e2065ecf

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ColorMatrix

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/302278ad-69bd-4253-9260-2d2f6b02c704

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandBatching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e4bfa99-8733-4ce0-995d-7d1a5afb1384

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandBrush

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1311beff-d6a0-4095-92d0-4a1e828bfb1d

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandBrushSmall

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2de7a78f-50f7-4bb2-b4d0-3b347fd29a4c

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandListUnitMode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/396f1010-0a74-420c-bce6-6d6812b134fd

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandTiling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f6e123ea-5c7f-4444-8040-14f7766f6693

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandTilingAliased

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26b86936-b593-45c4-b683-9cadce67e532

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CommandTransform

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51e8791b-d237-4df9-8a10-e17ad942f3cf

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Composite

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/275d5bdc-ccd9-46cc-a746-da56a9ea90a3

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - CompositeOffset

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f91535fe-8ea3-4cd5-bb79-889542b3f970

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - DemandCache

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c3abbb7-fb00-4a92-88a0-4701de374679

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - DirectionalBlur

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d1cd869-85fe-4558-ba28-a6054c7ecb43

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - DpiCompensation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/388e9c7d-81b3-45f7-9449-34fd374ff16d

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - EffectInputBatching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e53b02e6-eb64-4a4c-a607-0fbe97d8d465

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - EffectPropertyBatching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/86003afa-1bd2-4b29-91a9-cece63d9ca94

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - GaussianBlur

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe92626c-f344-4412-9612-673532bc719f

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - HazardTracking

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7d86ee2-2e10-4715-b174-24e0c5ad6aec

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - HelloWorld

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/997c525e-95c2-4964-b0ec-e13068f13d70

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - HighlightsAndShadows

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aaec753b-7493-40e6-80d5-efed153933bd

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ImageBrush

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c6e2b4a-361f-4afd-902a-539f48be677c

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ImageBrushWithBitmap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2935df3-e259-4a23-baf2-be4e1d240803

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - ImageSourceFromMapDefaultSurface

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2c2f4f0f-2c94-4147-a300-a368a0ee3ed4

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - LayersAndClips

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abbd6a9c-ae4d-41ba-b685-0ea3d8ab93c9

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - LookupTable3d

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f75bd3d-ef15-4881-928e-9530c87bd08a

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - NestedEffects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c82c367-e4da-4cc1-98ab-ef4f9a2693c5

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - RenderInfoHazardTracking

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3a424337-f8b9-4dbd-a4e7-171431acd8f8

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_A8Planar

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc10c8f0-a230-4cd4-a363-f3e2763b995c

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_AYUV

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/652439c2-3ea4-444b-9867-a44bc900c939

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_ImageSourceFromDxgi_RGB

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/213646b1-d2a7-4fe0-9207-efbde04389fc

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_ImageSourceFromDxgi_WicPlanar

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1cb2b59e-f6c3-4553-a860-1df6c6ff7209

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_ImageSourceFromDxgi_YUY2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae553b18-8dc9-4a6d-aac0-8dc4d9ffb6f4

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_ImageSourceFromWic_RGB

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bccb8391-49de-47dd-9a77-258080c6f43c

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_ImageSourceFromWic_WicPlanar

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd16516c-2e9e-43b3-819c-7708c44f00d5

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_ImageSourceFromWicHardware

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/42aea638-006b-45eb-81a4-6b6fe9ef3220

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_NV12

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66e86e6e-675c-4dd8-a71b-222a65cf153e

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_P208

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6116eecc-2d88-47dc-a0ad-5a0370924e18

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_V208

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1e264d1-d38c-4438-8d90-a73696c64446

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Rendering_V408

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c201b678-2993-4b42-90d2-646aca9736e8

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Scale

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24abcda2-f09d-4b35-9dc0-00193a708336

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Shadow

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6727b5d5-e8f3-4747-b11d-e59c185dae86

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Tile

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/205940b6-752e-4555-8dc2-dc081fc06987

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Tiling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a2a89c2-e1a1-4299-b97f-4563ca6aa235

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Transform

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0feba77-2f34-42aa-9fa5-8da00884345e

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - Turbulence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e06fd17-131e-4ba2-8975-5ea9c4c0b080

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - UnitMode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e19a55dd-9e41-4ec7-ab67-7ab5a572d0d1

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - WicBitmap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7491ba04-b308-4801-8662-6ed347bd2249

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - WicPixelFormats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b718be9-d785-4fd4-bb15-c71589c7c01a

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - YCbCr

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54d31a41-587c-4c03-9ce8-c3da512548ca

DImage Golden Image Effect Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Effect Tests - YCbCrSubregion

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ff5e239-01e3-4de7-89d3-9e6017ff1a9e

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Ink Tests - Batching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1d622810-6b5f-4d8e-a805-daafc22baaf6

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - Bounds

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40d24af0-db03-461c-b61d-659c144b3128

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - ConstantSpacing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/09f8e95f-14e2-4b83-a7ed-fcf53b37741a

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - HybridSpacing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79c71355-44f0-491d-a822-14c6b4b4390c

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - InkApi

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b57c3709-e2b0-43ee-ad83-92c5c4ed5b9c

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - InkCoalescing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/951afea3-74e8-4daf-9bc2-5c77671987ae

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - InkStrokeHazards

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/106abe1b-ae9c-43c6-abf7-0bf5bcdb610c

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - PointErase

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63d5e602-3bb7-4705-ba5c-d8e468a9d875

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - PointEraseCycleStampingState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61b1b739-18b5-48e4-ab43-1a2c3ac69dd9

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - PointEraseWithStampInvalidation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ae93943-c4e0-4057-9272-1791635d7524

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - ProgressiveDistance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/376d56dd-d163-4509-9ee0-501296280993

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - StrokeEditingInvalidation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cc3fea6-b7f6-4f14-8b4f-2414ea800148

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - StrokeTransfer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/001c7b16-ba08-48ef-b7af-8bb9e5e1a11b

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Ink Tests - VariableSpacing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/626dbaa8-e215-496f-be05-269f1caae68e

DImage Ink Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D2D - DImage Tests - CWicInteropImageSourceTests-TestRegistration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8ae7bde-8063-4c3f-967a-dbbeca0174a4

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - CWicInteropSourceTests-TestRegistration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/525a7bce-5c8a-4023-884f-c63f9c27df27

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - LeastRecentlyUsedIndexTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d42b1322-693d-4880-b2dd-a577670bf028

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - LookupTableApiTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efbaf3e4-2692-4d19-9dd4-266b93000d35

DImage ImageSource Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestAlphaModes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b499e589-fab1-4a49-88cf-380832b6f94f

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestBGRX

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/345703b2-13a4-4712-a32f-4162abfdcf1e

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestBitmapAlphaOnly

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d675fc0b-e256-4d56-8925-cc885c6692d8

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestBitmapRenderTarget

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0e375cd-b464-4c33-bd82-8452b041d9ee

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestBitmapShaderResource

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/945dfa23-66a3-435b-838e-a6dec494264d

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestDrawFrameOne

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e4abc746-adef-468b-a139-2fdfc75da822

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestDrawFrameZero

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e0dbc07-703f-464a-8a79-fe6749ec30bb

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestDrawInvalidTmpDir

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/30f58246-6a40-4273-9b15-6aee3001cebc

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestDrawNoImageFilenameSet

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc57ed7e-b610-4d0a-8506-cc81ba381373

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestGetFileName

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/527211fe-bba7-4da3-99bc-816a7539de69

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestGetFileNameInvalidSize1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e22c763e-8436-4d01-bdf5-dbbcd9e905b9

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestGetFileNameInvalidSize2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10d50fc6-cb0c-46bd-986e-1213daabbd71

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestGetFrameCount

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1daf5921-3385-45a4-9522-600845ea07a1

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestGoldenImageRender

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61408bab-466e-46dc-adbb-af0f711212c0

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestGoldenImageSubRect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff85de64-c303-42ac-959a-238437dc09a1

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestImage1x1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd5c5a0a-101e-4455-836c-03d072e17219

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestImageMultiFormatTarget

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f2c6609-de97-4cd3-9446-d4c3b2da1b01

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestImageNotWiderThanStripSize

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d71dc715-d440-48fc-ac3f-acc2699b0dcf

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestImageWiderThanStripSize

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/77a60c74-96b3-48ae-b7fc-0fd00074c851

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestInitialPropertyValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0fc3f06e-ef52-4227-bc97-9160609e7ce2

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestMipMapLevels

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b2f08f4-be64-449f-af6a-92b07758bc47

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestOffset

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27e8b3f1-6fb9-4bcb-8da6-b3e3f7959886

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestOffsetDifferentFormat

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a18a21a-bbbe-4900-9ee9-e24a3bf2131d

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestResourceTexture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3ed6711-ef44-4a50-b973-b34986fa365e

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestSetCurrentFrameInvalidValue

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d20da128-d21a-47cf-9f78-a555239edb60

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestSetFilenameEmtpyString

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/271b4c98-df57-4f23-ac4b-bff5af24d239

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestSetFilenameInvalidValue

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45b48035-97a0-42be-9e19-4b6c5b2d6df1

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - DImage Tests - TestTransparentCommandList

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a74c2791-4f57-4803-a9f9-fbce32689360

DImage-WIC Interop Test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify the test is running on HLK so we run against warp.
Device | Specify the test is running on Hardware so we run against warp.


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedGradientMeshNonOverlap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b961246d-aa5a-4fb2-8922-05493c979e41

D2D primitive blend test for aliased non-overlapped gradient mesh

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedGradientMeshOverlapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/599f38f3-7fbf-4a9b-9e64-b4bac83908a3

D2D primitive blend test for aliased overlapped gradient mesh

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedImage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4ab011d-007c-4787-9fc5-810668eef006

D2D primitive blend test for aliased image

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedInk

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cefad53-6b73-4dbc-8743-16fc1edf76e4

D2D primitive blend test for aliased ink

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedMesh

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/875fdef9-ba34-4b3e-94dc-015a86604fdc

D2D primitive blend test for aliased mesh

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedOverlappingStroke

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a1536da-084c-4d65-af4b-b7cc518f457d

D2D primitive blend test for aliased overlapped stroke

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedPerspectiveDrawBitmap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1fdbeb0a-7105-4f9e-a968-00500765400b

D2D primitive blend test for aliased PerspectiveDrawBitmap

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAliasedRectangle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c861afd-7d6b-46fa-be7e-2970e7b5bca5

D2D primitive blend test for aliased rectangle

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedClip

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b948fcf6-3909-4a6c-989c-df617188c724

D2D primitive blend test for antialiased clip

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedGradientMeshNonOverlap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d70d9d1c-1638-4f15-8e15-e11e7db3a67b

D2D primitive blend test for antialiased non-overlapped gradient mesh

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedGradientMeshOverlapped

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e531f083-0b89-41ae-ac17-1175fee8d5f7

D2D primitive blend test for antialiased overlapped gradient mesh

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedImage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92a220e0-dd52-4ef5-ac57-98c8b71c9a05

D2D primitive blend test for antialiased image

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedInkHighQuality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/569d3bec-8562-486c-85d8-ff55418cea27

D2D primitive blend test for antialiased high quality ink

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedInkLowLatency

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ffc19fba-8e1b-49d2-b8ad-1d070896dde8

D2D primitive blend test for antialiased overlapped low latency ink

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedLayer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b87d0c7d-184d-4f1d-9b8d-1b033717f964

D2D primitive blend test for antialiased layer

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedOverlappingStroke

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c1072a3-a06d-4cde-b9c3-5de4b0384358

D2D primitive blend test for antialiased overlapped stroke

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedPerspectiveDrawBitmap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc41238b-778b-41ce-9681-7fa7dfad5cdf

D2D primitive blend test for antialiased rectangle

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestPrimitiveBlendAntialiasedRectangle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6395ea7e-e56f-430b-8d6f-15923ba96dd1

D2D primitive blend test for antialiased rectangle

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - PrimitiveBlend - TestWin7AlphaCompatibility

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a33d7186-1141-4aeb-a6a1-c3cb6f99f892

D2D primitive blend test for win7 alpha compatibility

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - AATessellationTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7223e888-6de3-4fd2-888f-34b9550304ca

D2D visual verification test for Antialiased tessellation

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - BackFaceCullingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4678b6c9-e9ed-4580-a3a4-6f492aaa6f39

D2D visual verification test for back face culling

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - BitmapRTTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17c896df-ba0c-47b5-84bc-659725d8a836

D2D visual verification test for bitmap RT

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - BitmapTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc7090f0-6c7e-42de-8db8-9f97489f1f43

D2D visual verification test for bitmap

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - BrushTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f05a31f9-dfdd-4335-9098-2f211a05a1bc

D2D visual verification test for brush

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - ClipBitmapOpacityTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12a40274-826c-4a22-ab26-d0c1efb4009e

D2D visual verification test for clip bitmap opacity

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - CommandListBoundsTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea792050-5e3d-4562-b94c-4039ddbba317

D2D visual verification test for commandList bounds

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - CommandListEquivalenceTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7de29dfc-a6f4-4725-98bc-ad7079690347

D2D visual verification test for commandList equivalence

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - CommandListRenderingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/088f70c7-0481-48d0-b918-0d1f863ad570

D2D visual verification test for commandList rendering

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - CompositeModesTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ffd2794a-fc7b-47c6-b005-41ef2e760378

D2D visual verification test for composite modes

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - CoverageTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9b22d4e0-a15d-433e-9bf7-5524a649622d

D2D visual verification test for coverage

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - DrawTextClippingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68f2ee29-b9c8-40a4-a8d4-7168fb4cbc5d

D2D visual verification test for drawing text with clipping

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - DrawTextTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/540f5d30-c06a-46a2-af7b-1c9aadcdc693

D2D visual verification test for drawing text

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - EffectImageBrushTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6c04286-9bb5-4aa3-aef0-cddbbc28266b

D2D visual verification test for effect image brush

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - FillOpacityMaskTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8be05daf-3ac4-4076-a801-7136748eeaea

D2D visual verification test for filling opacity mask

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - GdiInteropTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c060c3a4-aaa9-414b-81e8-f3ae8c895883

D2D visual verification test for GDI interop

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - GeometryOperationsTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83d1e51e-d13a-4a00-aa7a-7f097a4a6c1b

D2D visual verification test for geometry operations

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - GeometryRealizationTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7537d182-60b1-4931-b210-839fcd707627

D2D visual verification test for geometry realization

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - GradientBrushTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5043e5b4-aa3e-4c82-98c9-47a49dbd79dd

D2D visual verification test for gradient brush

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - GradientMeshTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e120dc2c-3fa4-42d7-a526-26215bd1db89

D2D visual verification test for gradient mesh

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - HighColorGradientTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96780b7b-4bc8-439b-bc1e-bdaf554dbdc4

D2D visual verification test for high color gradient

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - InkTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea80a98b-a2b5-4fd9-9fa3-45d875a3dd54

D2D visual verification test for ink

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - LargeGeometryTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/98c61a9d-6811-4360-997b-76a5f7cb40de

D2D visual verification test for large geometry

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - Layer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9847f825-5c55-441a-b755-069cbda65d3b

D2D visual verification test for layer

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - MatrixTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c070b4e-3f4e-45ec-bb19-fdc56f9f32cf

D2D visual verification test for matrix

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - MetafileRenderingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/705ae636-4623-4843-afdc-b0f12ab73479

D2D visual verification test for MetafileRendering

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - MiscTextTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90ff4170-c5d6-4a14-afa0-28125abdda76

D2D visual verification test for miscellaneous text feature

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - MSAATest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3590a64b-9ed6-4b89-ac5b-f7ac05bdd7aa

D2D visual verification test for MSAA

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - OpacityFillGeometryTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b13bc4eb-0d93-4d4d-8cb1-64d00e1f2b32

D2D visual verification test for filling geometry with opacity

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - ParameterizedTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1899e170-3930-4b31-9b4d-ed4a3a3faecb

D2D visual verification test for parameterized test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - PolygonClipTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bf9d99a9-a3e2-47f6-bb67-e8ca7c9772a8

D2D visual verification test for polygon clip

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - RealizationTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2011e8cb-307a-4f91-a88e-254748c9d12c

D2D visual verification test for realization

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - StripCacheTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc3b63ed-a92c-41c7-a5da-33654bdb42c6

D2D visual verification test for strip cache

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - TextGridTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/46a09633-ecf1-4ed4-89ad-ba0bfe9498d6

D2D visual verification test for text grid

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - TextPerfTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a769ad04-0980-478d-89a9-3eaa386de641

D2D visual verification test for text performance

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - TextRealizationTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db767983-d8bb-431e-ab56-2226684be369

D2D visual verification test for text realization

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - TextSplittingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b9a2bc0-39b8-4470-b00b-83fb1488d7c7

D2D visual verification test for text splitting

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - TextTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9341224-c237-498d-be5a-13b1899a8c7e

D2D visual verification test for text

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - TIROrderingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2d7090b-edee-4ac9-807e-48b94f85ae85

D2D visual verification test for TIR ordering

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - UnitModeEquivalenceTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d18f7b8-19c0-4afa-a325-53793d88cfdf

D2D visual verification test for unit mode equivalence

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - WidenerTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da7a5d4a-6a16-4fe6-bc2b-8d5306ebf327

D2D visual verification test for widener

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D2D - VisualVerification - YCbCrImageBrushTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1171b55d-4133-4133-9434-3c40e6ddc195

D2D visual verification test for YCbCrImage brush test

Test details
Specifications
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
IHV | Specify it is running as IHV such that the test is running without debug layer


D3D AGP Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54a9c16d-c43c-4c8c-9ccb-cc471affe98b

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Agp.exe -M:1 -whql -logclean | This command runs the D3D AGP Texture (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Agp.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D Cross Proc Sharing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a49dfc9b-0330-46ca-9539-a94b802d7d9f

This automated test verifies support for the cross-process resource sharing in Microsoft® Direct3D® version 9.

This topic applies to the following test jobs:

  • D3D Cross Proc Sharing

  • D3D Cross Proc Sharing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test includes the following test cases:

  • CONF:Create. Create a shared resource.

  • CONF:Open. Create and open a shared resource in the same process.

  • CONF:ClientOpen. Create a shared resource in Process 1, and open that resource in Process 2.

  • CONF:Verify. Process 2 verifies that the content of the opened resource is correct.

  • CONF:Fill. Process 2 fills the open resource, and Process 1 verifies the content.

  • CONF:Lock. This test case initiates the following actions:

    • Process 1 locks the resource,

    • Process 2 attempts to lock the resource (this attempt should fail)

    • Process 2 attempts to unlock the resource (this attempt should fail)

    • Process 1 unlocks the resource

    • Process 2 attempts to lock the resource (this attempt should fail)

    • Process 2 attempts to unlock the resource (this attempt should fail)

    • Process 1 attempts to unlock the resource again (this attempt should fail)

  • CONF:ReleaseSourceUseOpen. This test case completes the following actions:

    • Process 1 creates a resource

    • Process 2 opens the resource and verifies the content of the resource

    • Process 1 releases the resource

    • Process 2 uses the resource

    • Process 1 opens the resource and then updates the resource content.

You can test multiple resource types, or just one by using the command line. To run with only one resource type, use -ResourceType:<ResourceType>.

You can use the following resource types:

  • OFFSCREENPLAIN

  • DEPTHSTENCIL

  • RENDERTARGET

  • TEXTURE

  • VOLUMETEXTURE

  • VOLUMETEXTURE

  • INDEXBUFFER

Command syntax

Command option | Description
D3DCrossProcShare -CrossProcShare_Conf -M:1 -whql -logclean | This command runs the D3D Cross Proc Sharing test job.
D3DCrossProcShare -CrossProcShare_Conf -M:1 -whql -logclean | This command runs the D3D Cross Proc Sharing (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3DCrossProcShare.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D Cross Proc Sharing (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9d7f23a-875f-4dba-96d0-b17008256885

This automated test verifies support for the cross-process resource sharing in Microsoft® Direct3D® version 9.

This topic applies to the following test jobs:

  • D3D Cross Proc Sharing

  • D3D Cross Proc Sharing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test includes the following test cases:

  • CONF:Create. Create a shared resource.

  • CONF:Open. Create and open a shared resource in the same process.

  • CONF:ClientOpen. Create a shared resource in Process 1, and open that resource in Process 2.

  • CONF:Verify. Process 2 verifies that the content of the opened resource is correct.

  • CONF:Fill. Process 2 fills the open resource, and Process 1 verifies the content.

  • CONF:Lock. This test case initiates the following actions:

    • Process 1 locks the resource,

    • Process 2 attempts to lock the resource (this attempt should fail)

    • Process 2 attempts to unlock the resource (this attempt should fail)

    • Process 1 unlocks the resource

    • Process 2 attempts to lock the resource (this attempt should fail)

    • Process 2 attempts to unlock the resource (this attempt should fail)

    • Process 1 attempts to unlock the resource again (this attempt should fail)

  • CONF:ReleaseSourceUseOpen. This test case completes the following actions:

    • Process 1 creates a resource

    • Process 2 opens the resource and verifies the content of the resource

    • Process 1 releases the resource

    • Process 2 uses the resource

    • Process 1 opens the resource and then updates the resource content.

You can test multiple resource types, or just one by using the command line. To run with only one resource type, use -ResourceType:<ResourceType>.

You can use the following resource types:

  • OFFSCREENPLAIN

  • DEPTHSTENCIL

  • RENDERTARGET

  • TEXTURE

  • VOLUMETEXTURE

  • VOLUMETEXTURE

  • INDEXBUFFER

Command syntax

Command option | Description
D3DCrossProcShare -CrossProcShare_Conf -M:1 -whql -logclean | This command runs the D3D Cross Proc Sharing test job.
D3DCrossProcShare -CrossProcShare_Conf -M:1 -whql -logclean | This command runs the D3D Cross Proc Sharing (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3DCrossProcShare.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D Lines

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/20fd14c7-de9c-441f-a19e-83bcc81af488

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • D3D Lines

  • D3D Lines (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Lines -M:1 -dx9 -whql -logclean | This command runs the D3D Lines test job.
Lines -M:1 -whql -logclean | This command runs the D3D Lines (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lines.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D Lines (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb799dbb-41cd-4208-b73b-0bc63f621c84

This automated test measures the minimum supported Direct X renderer capability of a graphics adapter or chipset.

This topic applies to the following test jobs:

  • D3D Lines

  • D3D Lines (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

For an N-bit-per-component RGB frame buffer format, the lowest N bits must contain the blue component, the next N bits must contain the green component, the next N bits must contain the red component, and the remaining 32-(3 x N) bits may contain alpha. The resulting 32-bit value must be stored in memory in little-endian format.

NOTE

This requirement is "If-Implemented" for Windows Server.

Command syntax

Command option | Description
Lines -M:1 -dx9 -whql -logclean | This command runs the D3D Lines test job.
Lines -M:1 -whql -logclean | This command runs the D3D Lines (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lines.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D11 - Conservative Rasterization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d823d29d-024b-427e-a38b-8bb3fd41a22e

Verifies whether the conservative rasterization feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11ConservativeRasterization.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - Cross Adapter Resource Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2debaf64-db00-4352-b764-0f5d2be8d1f0

Verifies whether support for cross adapter resources is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.WDDM24.Render.CrossAdapterResource
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - Decode Histogram

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6eabf474-cd40-498b-b61a-fedb7e67134e

Verifies that the correct Decode Histogram is produced for NV12 and P010 output when decode histogram is supported.

Test details
Specifications
  • Device.Graphics.WDDM24.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - NegotiateCryptoSessionKeyExchangeMT

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c11b25a-0780-4b61-a756-466533df0ef8

Verifies that NegotiateCryptoSessionKeyExchange behaves as expected when called asynchronously.

Test details
Specifications
  • Device.Graphics.WDDM24.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - PS-Specified Stencil Reference

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ff0259a-67ff-4b31-8cbc-742982e8bbdd

Verifies whether the Pixel Shader specified Stencil Reference feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11StencilReference.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - Rasterizer Ordered Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb4d024a-7aba-4e81-a91c-3fb327b18b38

Verifies whether the Rasterizer Ordered Views feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11RasterizerOrderedViews.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - RenderTargetArrayIndex and ViewportArrayIndex from VS and DS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca0ad6b6-a44f-4869-9bdd-ce55b1b609e1

For VS/DS RTAI/VPAI output for D3D11, verify that it works as expected.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11RTVPFromVSDS.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 - Typed UAV Load

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3557754c-a00b-44f0-b2fb-08fee3a66f8e

Verifies whether the Typed UAV load feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11TypedUAVLoad.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D11 WGF11TimingData HW FL*

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3253028a-c7c6-4582-93e7-426b8ed61e0b

Test details
Specifications
  • Device.Graphics.WDDM13.Render.HighPerformanceTimingData
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Async

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e54c4b73-b55d-439a-b0bd-c600c2f95508

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Blend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80ea58fd-2310-4a6d-92ed-696af5244da8

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Blend (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63919224-2480-4f5c-bb86-1a3a23a45b42

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Clipping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d80c608a-7b21-4c00-9401-524e39d45875

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Clipping (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/964ae757-575f-479c-a993-847107416bd6

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Compute Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e28c4837-66bc-430f-b345-5d0232b00c9c

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Compute Shader (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac2efe80-91ef-4a1f-abd6-25a2193d3270

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Compute Shader - PSO Cache

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad061b31-8b17-4a75-a75f-7e2bf1c8859a

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 D3DWDDM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4b6ba531-0096-4bd4-bdf8-c62c61281ec0

Validates that WDDM drivers expose the necessary DDI's as documented in the WDDM hardware functional spec Enables DXGKrnl WDDM validation which ensures that drivers implemented all mandatory WDDM features

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
WDKDeviceID | Device id of DUT


D3D12 - 11 on 12 - WGF11 Depth Stencil

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5222ea60-485b-4a6d-b5ee-e05bb5084af8

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Depth Stencil (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0cdf33a-e74a-46e4-bab2-280777f976f5

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Draw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/60262502-f2a4-4f17-8bc5-f6f60ba78770

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDArgs | /get or /sets


D3D12 - 11 on 12 - WGF11 Draw (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a16468af-a434-46b5-b9b7-7ecff1981876

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDArgs | /get or /sets

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Fill Rules

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/912433c6-0a94-4ea2-a946-809183683ebf

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Fill Rules (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c956e393-6c14-4674-94c3-afbde720ed34

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Filter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e05ef56-8574-4697-b6c9-98a5c9370f13

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Filter (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb347ee7-7d04-4ae2-a782-453e75f53223

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Input Assembler

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7546c2fa-68d2-4e29-b20f-dbc4c18839cd

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Input Assembler (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6795e97a-f104-4120-b904-3eee5fcab248

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Multisample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df13a8ab-c45a-4b05-ad82-5ed0904e6ed0

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Multisample (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/118b85d2-f2d1-4813-b490-83de48533775

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Pixel Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e82cf1e-5b8f-46d1-82d7-7da788f9d18c

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Precision

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2685dc1d-2b51-4094-a00b-bea1921d9326

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11PartialPrecision.D3D11CoreE
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Rasterizer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/edbdc655-19ee-4d5e-9490-287642629ade

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Render Targets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/541c76a1-c4d1-4778-aae0-b5f9a7975e12

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Render Targets (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40ae8670-a64f-4cdb-b62f-1e00d83adbcd

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Resource Access

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c60f2784-2a1b-4908-a56d-3e9349718b13

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Resource Access (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/acf90eb1-47bc-4e1b-8451-ba16642d77f7

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Resource Formats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e86becaa-f352-4bbc-b85f-66440991bc6c

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Shader 5x

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3de20b5-2612-4729-92da-526af3376444

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Shader 5x (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb400c2d-89b0-44c1-a2d6-b84ba5f6b98b

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Shader 5x - PSO Cache

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba38a5ed-8d80-4634-b207-2ed5008b16a8

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Streamout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0775cf7f-6c18-4c5e-85df-e8a346be85b0

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Streamout (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3974b096-183e-4128-8bd6-6dd685b3ff9b

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 Tessellation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a724181e-55ba-4370-9152-dacfbedec693

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Tessellation (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01019b2f-810e-4e95-90b4-373658e1a8d5

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 11 on 12 - WGF11 TiledResources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/481778f3-d6a5-4f4d-925a-777d4d7718ef

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Vertex Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1720604-60f6-44fb-9920-64cffb73be90

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11 on 12 - WGF11 Viewports

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f4e30cb-16f2-4e59-a111-5fe01a31747f

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


D3D12 - 11on12Video - DecodeVPBlit

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c510c85c-9da1-4028-b396-4b1b5117f5c5

Test decoding/VPBlit of previously recorded data using a variety of profiles

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
  • Device.Graphics.AdapterRender.D3D12VideoProcessing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 9on12Video - CheckBufferInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abe56184-a684-4a41-97b9-3190efaabd31

Test video decoder buffer creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 9on12Video - CreateVideoDecoder

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0b83f5c-bfab-4e8e-bae1-883b8a42d3bc

Test basic creation of video decoder

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 9on12Video - CreateVideoDevice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/268f175b-1c37-46a6-931f-ed2115cb5389

Test basic video device creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 9on12Video - CreateVideoProcessor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66cbb9bc-4a73-481a-8c4e-16e45b6bc17f

Test basic creation of video processor

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoProcessing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 9on12Video - DecodeVPBlit

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a602f3fe-7f00-4a7e-909f-286851c36866

Test decoding/VPBlit of previously recorded data using a variety of profiles

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - 9on12Video - VideoProcessorBlt

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c905ab8b-00d3-4166-8aa9-0c6459261b93

Test basic video processor blit functionality

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoProcessing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Allocation Info

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9cf8f3a7-3c66-4105-8b90-301ac9304f84

Validation for PFND3D12DDI_GET_DEBUG_ALLOCATION_INFO_0012.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Async Timing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846188

Verify that Timestamps capable of executing in parallel overlap.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Basic WriteBufferImmediate Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3cc07b7-d25d-4561-a4af-096e5898854f

Verifies behavior of the optional WriteBufferImmediate feature for each command list type supported by the driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Binding Initialized Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/303e9b7a-f4ee-4ec6-b036-01d8186f6a5a

Debug layer catches shader access to uninitialized bindings.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle BlendFactor Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ab7bc60-0e87-4909-a755-1123408b3dfa

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle DescriptorTable Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0fef46b0-cbd2-4e4c-ac7d-b5cbbe55d180

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Dispatch Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75b9533a-c3be-425b-a8d2-ba3cb165d12d

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle ImmediateConstantBuffer Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44311d5e-51a2-4efa-9db0-76c7732c3d18

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle InputLayout Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0177c175-fdcd-4824-b3be-8483537029d4

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Markers Disabled

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846182

Verifies that markers do not show up within a bundle when logging is disabled for bundles.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Markers Enabled

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846181

Verifies that markers show up within a bundle.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Pso Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/278dc92c-3727-424a-9d88-39710d1a229c

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Resubmit Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c8f518f-8de6-48da-8205-c7bf9ce35586

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Root Constant inheritance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/792695b5-5cd2-49fa-ad83-2bd97b4f6c79

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle RootSignature Switch Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/867f5849-818d-4fc4-b6e3-00eec17726fd

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle Rundown

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd7ad45d-d45a-4788-86e2-63360a29e293

Verify that Bundle markers are not output if they were not recorded in a scenario where profiling is enabled after a Dx12 app was started.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Bundle StencilReference Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc034608-fa4f-4fe8-96f8-2d839e27f20f

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - CPU MMU Isolation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1213cc71-c7a0-4fcd-8c3f-a8eeae902c88

Verify either the GPU is isolated from CPU MMU features or the driver correctly advertises some functionality is honored by GPU.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Clear Depth Stencil Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/985edc85-9069-4fc2-b970-64224125ff9e

Creates a resource with matching-mismatching depth-stencil values and verifies clear results

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - CommandAllocator Reset Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/978b3dcf-7a40-492e-a4af-c40b67fb53dd

CommandAllocator Reset Test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - CommandList Destruction Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db3aded5-3f4b-4c96-b3e8-65f25d6dc0df

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Common State Promotion for Descriptors in Table Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38287ffd-5b95-4d61-84b6-f7000906fdcf

Debug layer performs common state promotion when there is shader access.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Common State Promotion for Root Descriptors Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1552fc6d-1e68-4d16-9b50-a482b83eda8a

Debug layer performs common state promotion when there is shader access.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Compute Timestamps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846186

Verify that Timestamps are emitted from the Compute Engine as well as 3D Engine.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Conservative Rasterization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6dae406e-3599-498f-8d12-e8a56a391586

Verifies whether the conservative rasterization feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12ConservativeRasterization.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Copy Queue Timestamps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/34b0bbfe-8f8d-41c5-9639-5319b9874a95

Verifies that (on drivers that report support) timestamps on copy command queues function correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Copy across different Command Lists Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81925a6e-b066-40b5-bcf8-a0a23ed9566a

Debug layer tracks resource state across multiple command lists of different types.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Copy Timestamps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846185

Verify that Timestamps are emitted from the Copy Engine as well as 3D Engine.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Counters And Queries Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15424120-90e7-4b6e-9a0f-b9272c1793f1

Verifies new features of Counters And Queries.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - CreateVideoDecoder

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0c54bab-70d0-4df7-bed3-61f1883c88f4

Test basic creation of video decoder

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - CreateVideoDevice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7a15165-0e80-4b03-9f3c-296306b4a2a5

Test basic video device creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Cross API Sharing of Protected Resources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ce99593-5f60-4a74-b31e-7bfdcd0d4d18

Validation for cross D3D11/D3D12 API sharing of protected resources.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Cross Adapter Resource DX12

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f33bb6d-c11d-46ca-bc52-e432f0c05ef8

Verifies behavior of cross-adapter resources.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DCL Resubmit Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2410792-b412-4058-b81f-373ff9e99b12

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Acos instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55aebea2-4ec0-4359-93c9-c8b6e0ad9ed4

Verifies the Acos DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - And instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c323a9ee-7a65-4135-a07c-889cdcda84b2

Verifies the And DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Asin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c11decc-84cd-4048-85c2-370c1a2c447d

Verifies the Asin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Atan instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24789c37-f0a0-4949-b1fe-5978ad3a055d

Verifies the Atan DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Bfrev instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1fbf0c41-ba44-455c-94bf-7ee31fbd1f5c

Verifies the Bfrev DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - CBuffer Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/936cd44a-c4b1-4f9b-992f-76fe17d2bf60

Verifies float16 in CBuffer

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Cos instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8d5d6c4-2638-48e4-b842-d679b31a354f

Verifies the Cos DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FAbs instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/224b71e1-05f0-43a0-8306-a97dddfd2b7a

Verifies the FAbs DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FAdd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c338e53-1453-4cdf-a7aa-ce144f6d8b32

Verifies the FAdd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FDiv instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f258969-fa5d-4c65-bd1f-e77219821cff

Verifies the FDiv DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FMad instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22dd4109-5308-4027-a110-2007c83496b6

Verifies the FMad DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4f8ada6-b2a9-453a-b1ab-fc5339a3946d

Verifies the FMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FMul instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b3fea80-6fdd-4721-9cc6-7aab47072333

Verifies the FMul DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FSub instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5319dff-a6aa-4db5-818b-097eb43cf49c

Verifies the FSub DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FirstbitHi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5da7c9d-007f-47c6-9edd-db36a1655ad1

Verifies the FirstbitHi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FirstbitLo instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e103af1c-00c6-41b6-8310-8666eb1500f8

Verifies the FirstbitLo DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - FirstbitSHi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb0d7720-e8d2-4c8d-892b-6ae5fa0ddf9a

Verifies the FirstbitSHi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Frc instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9174eccd-a8dd-4ae1-91cd-0bd698a2f1b1

Verifies the Frc DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Hcos instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73280064-04a1-4205-85aa-40da9e0db8dc

Verifies the Hcos DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Hsin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/605d75ad-a880-420c-bf02-b20699154a50

Verifies the Hsin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Htan instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/194d65a4-ffb8-41a5-a733-18cb4d7323e6

Verifies the Htan DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IAdd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8eeef10e-c9c8-4d13-b276-06382293d41a

Verifies the IAdd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IMad instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fae141e5-7717-4143-8c74-1b7e3faf2faf

Verifies the IMad DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IMax instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b8213a21-fee7-4139-b0af-50b5d54f71ae

Verifies the IMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e841a25e-e705-4e4c-9296-f323157efe9d

Verifies the IMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IMul instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f8bc584-ffd0-4747-87e0-ce799a0969d2

Verifies the IMul DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - ISub instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bda34a86-8eee-4071-be29-0c039b733850

Verifies the ISub DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IsFinite instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a757d483-20c4-47b9-b295-84c86a8c6944

Verifies the IsFinite DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IsInf instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b900a1f-c28e-4452-a29e-f2dafabe0e19

Verifies the IsInf DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - IsNaN instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/538e17c4-f203-4d6b-9b73-c2ff8f878a18

Verifies the IsNaN DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - LShr instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f697154e-5bc2-4908-bcf3-bc03517b4cdb

Verifies the LShr DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Or instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b18f4b0f-2de2-415f-827b-70743e650308

Verifies the Or DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Round_ne instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/411141bf-5228-42d8-8f05-0179b2c5b5bf

Verifies the Round_ne DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Round_ni instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd08a855-0274-476d-8be0-4b306b308ddc

Verifies the Round_ni DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Round_pi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14906d68-cc01-47da-8cb5-80120914f65a

Verifies the Round_pi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Round_z instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4b525e2-a86b-41bf-9451-3373e3a99c2b

Verifies the Round_z DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Rsqrt instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e541497f-60ca-409b-8003-97631b99573e

Verifies the Rsqrt DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Shl instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ef2990e7-0fa9-4552-954a-93e4977e016f

Verifies the Shl DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Sin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/484c6534-4394-4f34-972c-1ec6dd36e78b

Verifies the Sin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Sqrt instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4b73ddc7-ce42-4c7d-bfcf-2a78a1998f0f

Verifies the Sqrt DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Tan instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0fd40b44-9437-496b-9db7-b030cfa96595

Verifies the Tan DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - UAdd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d666ebb0-3078-429f-9bc3-a75b531e8e36

Verifies the UAdd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - UMad instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d66c3633-7838-46b7-9575-6dfa1ad84ed6

Verifies the UMad DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - UMax instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc6f79b8-2d18-4ee8-b1ee-be3f537e9a2c

Verifies the UMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - UMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a32dd09-a03a-4468-aecd-8d94045b3a10

Verifies the UMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - UMul instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b56d8e78-68f7-448a-94b3-0f0523fed496

Verifies the UMul DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - USub instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ba55817-e248-4e78-b8e7-787cbaeadbcd

Verifies the USub DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL 16bit Types Test - Xor instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8507b10a-8ee6-48f4-bc26-6328511fc50e

Verifies the Xor DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.Native16Bits.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - And instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/651ea807-5a7d-4b74-93b8-06ec14df634a

Verifies the And DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Basic 64-bit int test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/969d000a-d972-43fb-abc5-9ed622bfb392

Verifies basic 64-bit int usage.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.Int64.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Basic OutOfBoundsTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d8f4e73-d840-4582-8182-8996f717ebac

Verifies basic OutOfBoundsTest.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Basic partial derivative test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b190893f-ae70-4d34-85b9-a20248e76f40

Verifies partial derivative intrinsics under pixel shader.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Basic shader model 6.1 test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a53f923a-af31-4d2c-b6d9-b667281c52c0

Verifies shader model 6.1 support.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DXILCore.ShaderModel61.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - DXIL Core Test - Basic shader model 6.3 test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8918d1c-382f-491a-a1b2-3c1fcc994202

Verifies shader model 6.3 support.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.DXILCore.ShaderModel63.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - DXIL Core Test - Bfi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca7a8fe3-b671-4b2a-90d3-0efca2abff87

Verifies the Bfi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Bfrev instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc9cd60e-5c51-4342-814c-dc4fa4f55352

Verifies the Bfrev DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Countbits instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2fbc3458-c101-47ea-8fd3-ab06e3d42fd4

Verifies the Countbits DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Dot instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cc8886a-fec9-4cc5-a8fb-f4f61348ca08

Verifies the Dot DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FAbs instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4a46930-9662-4fce-a56c-e74a7442d917

Verifies the FAbs DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FAdd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d9ec5e60-2f6d-4466-87db-31d9e7a9b550

Verifies the FAdd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FDiv instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6820e352-c828-4221-88b8-172b118707eb

Verifies the FDiv DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FMad instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5304af4b-b832-416b-aebf-47998f6b9bdb

Verifies the FMad DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/98a4dcf8-8089-4a4e-a6a5-9281ab9125e9

Verifies the FMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FMul instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1831ea9c-1b26-4998-9b34-ed7a5a653ef9

Verifies the MSad4 DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FSub instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3396b085-6ce1-4163-ab73-09dbb91dcad7

Verifies the FSub DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FirstBitLo instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e4fdbcda-0177-4fd0-9b58-67bece1f5282

Verifies the FirstBitLo DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FirstbitHi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/35d0d21d-dcbb-445e-9961-0dbd7276d478

Verifies the FirstbitHi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - FirstbitSHi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/34fe016a-8bb7-41a5-b6ef-02581244019e

Verifies the FirstbitSHi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Hcos instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4142df16-49c8-4810-9ba9-7e03cc04e2f5

Verifies the Hcos DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Hsin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c83f4d3-6a7e-4e70-855c-e75e9b230735

Verifies the Hsin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Htan instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/785bbc28-b70c-47db-b3e9-6fc67e775334

Verifies the Htan DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IAdd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a646221a-617a-4286-925c-67b28eeac233

Verifies the IAdd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IDiv instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0391d49-228c-46f2-acab-9f8fae2dbad9

Verifies the IDiv DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IMad instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d04df7d7-23b9-4e83-895d-bbd01fb6df15

Verifies the IMad DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IMax instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bee2bcff-a8cd-4a6e-b10e-5ac3f8c7b25e

Verifies the IMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/137f5007-47bb-4cae-ae4e-9559cbaf52b2

Verifies the IMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IMul instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d99c4b20-18c6-496d-96b6-0afeef519d2c

Verifies the IMul DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - ISub instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b7f1ff3-cff9-4381-84bd-70f4eede4fbc

Verifies the MinMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IsFinite instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc27eedf-9414-42d7-8dad-44273696e3fc

Verifies the IsFinite DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IsInf instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba0407d9-9cae-4722-afd9-319eec03e5e4

Verifies the IsInf DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - IsNaN instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83aabda7-b419-4b96-8847-6cd4dbb45938

Verifies the IsNaN DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - LShr instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9583699c-22d4-495e-8ece-5d6ddd4a9d57

Verifies the LShr DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Or instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c460f32d-58aa-4eb6-9f96-8d080773c61d

Verifies the Or DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Saturate instruction test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1d6cd38-d89c-47d2-bfb4-2e17b94b4d0f

Verifies the saturate instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Shl instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab668b1c-3b4a-4353-a00f-ff7758066c93

Verifies the Shl DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Sign instruction test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4827868d-b4c5-408a-841a-6f8336bb1605

Verifies basic sign.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - UAdd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d566a6cb-cd79-4652-a65d-1350f5547f14

Verifies the UAdd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - UDiv instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f3bcf64-0ebe-4cc3-8804-87fe3f2b25dd

Verifies the UDiv DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - UMad instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9fd4b17d-a8be-416b-bc4a-6aa91f47ef39

Verifies the UMad DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - UMax instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d536a119-b5a3-4f86-b8cb-109f91deb5f7

Verifies the UMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - UMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9b0e370f-0d4f-4cad-adb2-74dc33d62d28

Verifies the UMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - UMul instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc41345a-3159-4eaf-8d89-c8b0ba8866e3

Verifies the UMul DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - USub instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed8edd45-6e95-4744-b534-1dc05d65dfd5

Verifies the USub DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - Xor instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce0dfea7-f465-4e07-ba11-5173973b45ad

Verifies the Xor DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - acos instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ab74717-e19e-48bf-b56e-a26fc4ed6bb3

Verifies the acos DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - asin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99d2e6c9-ee24-4c7d-abda-ca73c1178f0f

Verifies the asin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - atan instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b066f1d-980f-45fe-bcdf-bffb1da4b82d

Verifies the atan DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - cos instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31d81fd1-8ca3-4150-a6c2-595760539e58

Verifies the cos DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - exp instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3b52562-22a7-42b1-9127-fae4c4f4c133

Verifies the exp DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - frc instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5471d3b4-040b-4786-990e-72bdb048bf43

Verifies the frc DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - log instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a58d9628-92ea-451f-a81d-ad20618a26b3

Verifies the log DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - round_ne instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a106698-a40c-410a-a4d4-d17851b6498f

Verifies the round_ne DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - round_ni instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/832fa6a7-4a8c-4c5a-9657-61ba75066d7a

Verifies the round_ni DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - round_pi instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/adb1816a-6330-45eb-b7ca-2b8ebcd38c6c

Verifies the round_pi DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - round_z instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72a0379d-550b-4663-930b-547b5a7d42f7

Verifies the round_z DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - rsqrt instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8931e24-97cd-482b-b027-0c90e16bceb9

Verifies the rsqrt DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - sin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f300f654-d7d0-4292-b6bb-6259f3d4a07a

Verifies the sin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - sqrt instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da2aa9e6-22a1-4c04-9f12-406e591b2dd9

Verifies the sqrt DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Core Test - tan instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e8bf68c-88c5-4077-930c-7b1355bd4735

Verifies the tan DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXILCore.ShaderModel60.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Int64 Test - UAddc instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2e34088-f5ce-4d46-afad-86f57e302aee

Verifies the UAddc DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.Int64.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FAddDenormAny

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f84c8f4-1887-4c2f-8c09-120f57902754

Verifies the FAddDenormAny DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FAddDenormFTZ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21d9647a-97e9-4c13-b338-b98fd9e5a9d0

Verifies the FAddDenormFTZ DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FAddDenormPreserve

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2557db62-2fe8-4864-bdfc-8b66abebcce0

Verifies the FAddDenormPreserve DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FDivDenormAny

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/86db7145-d715-4c65-b601-cd54f333bd38

Verifies the FDivDenormAny DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FDivDenormFTZ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600f25bf-4a61-4588-9ac4-eb8174b4d00a

Verifies the FDivDenormFTZ DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FDivDenormPreserve

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11a07234-d18d-4b84-8ac0-f58bb2257c44

Verifies the FDivDenormPreserve DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FMadDenormAny

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9282e9f-124d-42b6-af33-c789d760010b

Verifies the FMadDenormAny DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FMadDenormFTZ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38505da3-4721-46c2-b14d-f599babd9d88

Verifies the FMadDenormFTZ DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FMadDenormPreserve

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce818de1-e721-4a4e-a032-be56651ce8c3

Verifies the FMadDenormPreserve DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FMulDenormAny

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24fc24e4-7fd6-492f-9429-7219d1048c2f

Verifies the FMulDenormAny DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FMulDenormFTZ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c27aad8-bff0-4234-ada8-35af86975ddc

Verifies the FMulDenormFTZ DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FMulDenormPreserve

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1e95159-76a0-4564-859f-ca822aae520c

Verifies the FMulDenormPreserve DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FSubDenormAny

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66d8739b-4d09-4c8b-8096-16e256ec1c21

Verifies the FSubDenormAny DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FSubDenormFTZ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84047942-701d-4462-8d14-295629fee7c9

Verifies the FSubDenormFTZ DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL SM 6.2 DenormMode Test - FSubDenormPreserve

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f477b37-a76d-4826-92ba-fa13644c62e7

Verifies the FSubDenormPreserve DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.D3D12.DXILCore.ShaderModel62.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveAllEqual instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dfb840d8-edfe-4334-a3a5-d421c564784b

Verifies the WaveActiveAllEqual DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveAllTrue instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/300aeb6e-0b2a-4037-bfc2-704529ae73da

Verifies the WaveActiveAllTrue DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveAnyTrue instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/797f13e2-be79-408d-b06d-f759a336e9fe

Verifies the WaveActiveAnyTrue DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveBitAnd instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2305e19-5259-4a30-aeda-e4cc2445d8cd

Verifies the WaveActiveBitAnd DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveBitOr instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe5caf2a-6b79-4276-a61b-020c80835270

Verifies the WaveActiveBitOr DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveBitXor instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f443cf35-4f7d-4091-a0c2-b628c8232f81

Verifies the WaveActiveBitXor DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveCountBits instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eee5f3e5-e1a2-43dd-a494-71cf3a957d3d

Verifies the WaveActiveCountBits DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveMax instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc66cabc-950d-4adb-bf45-3d74b7afac20

Verifies the WaveActiveMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1fd0e83f-8356-4ec1-a99d-ec48a02bdee2

Verifies the WaveActiveMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveProduct instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f022140b-e259-4aa0-94ac-61f920830fe2

Verifies the WaveActiveProduct DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveSum instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15e666a4-c88b-4bac-b855-b5ac811814d4

Verifies the WaveActiveSum DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveUMax instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5e1e671-ca94-4fb6-b94e-8ad14fa14f1c

Verifies the WaveActiveUMax DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveUMin instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88832bf8-522b-4465-ad8f-46a3e2a32aad

Verifies the WaveActiveUMin DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveUProduct instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3366af79-6af7-4196-89c8-e882331ff01d

Verifies the WaveActiveUProduct DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveActiveUSum instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9bb639e-febd-40d4-b79d-233cadc06513

Verifies the WaveActiveUSum DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WaveIntrinsicsInPSTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4b93ce1-0f21-41bd-9a00-0ad2772aac56

Verifies basic wave intrinsics under pixel shader.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WavePrefixCountBits instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a93b2e41-c818-4f30-b17d-7d38af72fb74

Verifies the WavePrefixCountBits DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WavePrefixProduct instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3fce5184-528e-41a0-9c25-0ff28e574ce2

Verifies the WavePrefixProduct DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WavePrefixSum instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d60f69e-ddcb-425e-9254-b3fd16745333

Verifies the WavePrefixSum DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WavePrefixUProduct instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a85ac2e3-0e4e-450e-b9a0-f5cb6d473698

Verifies the WavePrefixUProduct DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DXIL Wave Op Test - WavePrefixUSum instruction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7ab0c2f-6f1f-43d5-b638-04704fbc1704

Verifies the WavePrefixUSum DXIL instruction.

Test details
Specifications
  • Device.Graphics.WDDM22.AdapterRender.D3D12.DXIL.WaveOps.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Buffer descriptor out of bounds with static descriptors validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/02ffc5c4-a0e5-4598-a0b8-035591ef89d3

Debug layer catches reading CBV/UAB/SRV buffers out of bounds via descriptors when descriptors declared as static via root sig 1.1.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Copy across different Command Lists Validation for Upload and Readback resources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da75a555-5c27-48ff-b1cc-53c28d414e93

Debug layer tracks resource state across multiple command lists for Upload and Readback resources.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Initialized Validation for Shader Instructions that do not read or write from resources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55971bd9-bada-4440-8232-2c1ba0ad3ba5

Debug layer only validates for valid resource in shader non-access instructions.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Resource State across Multiple threads, Command Queues and Command Lists Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54aeb1cd-2a64-4aa2-917a-669a083409b8

Debug layer tracks resource state across multiple threads, command queues and command lists accurately.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Sampler Mode Mismatch Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da9feda1-9b07-4ea9-b5cb-503999e15eb6

Simple Test - Debug layer catches shader use of a sampler in the wrong mode.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Decay Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1580553a-77e9-4c9e-988c-4d795d76c0bc

Debug layer performs resource state decay to COMMON for simultaneous access resources.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Decode Histogram

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a3a04cc-907c-4f3d-aec9-20de0bc9a9dd

Verifies that the correct Decode Histogram is produced for NV12 and P010 output when decode histogram is supported.

Test details
Specifications
  • Device.Graphics.WDDM24.Render.D3D12VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DecodePredicationH264

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac2e16a6-1423-4524-aaa8-2b93ed0629d9

Test out of order recording with predication for d3d12 video decode command queue type.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2274bc5e-eb99-4e06-8fe0-7312bb9ecb94

Test Depth bounds test.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DepthBoundsTest.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs when range is inverted \FLT_MAX, -FLT_MAX\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9466cae-a090-4d4a-810c-62c251f14154

Test Depth bounds test.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DepthBoundsTest.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs when range is set to \-FLT_MAX, FLT_MAX\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab1c14ba-cf18-4f8e-8154-01be31478aa0

Test Depth bounds test.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DepthBoundsTest.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target as well as UAVs when set via a bundle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c7fceb6-a622-4041-8e96-c9dbbd187aff

Test Depth bounds test.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DepthBoundsTest.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target when no depth buffer is bound

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f5c5814-12e6-4e14-9c42-9074130db95d

Test Depth bounds test.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DepthBoundsTest.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth Bounds Test - Verify Depth Bounds Test correctly limits writes to the Render Target when no depth buffer is bound and range is set to \0,1\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f555750f-099a-44c8-a480-e651af66e423

Test Depth bounds test.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.DepthBoundsTest.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DepthCopy Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e5b1908-55a1-4eea-a267-63ec323d285d

Verifies that the driver correctly implements depth copies.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth-Read Stencil-Write

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4e21a3b-a7cb-47a9-9cc9-a5d9a31a8978

Tests the ability to use a barrier to mark a depth plane as read, and stencil plane as write

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Depth-Write Stencil-Read

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe7d0d72-3317-4805-ac57-7484a0e526af

Tests the ability to use a barrier to mark a depth plane as write, and stencil plane as read

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - DirectCommandListReset test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f496394-a119-42e5-aaa1-acb3b1192d80

DirectCommandListReset test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Global Realtime Command Queue Priority

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f00f5cec-0845-479f-a9b1-7791d8f7c99a

Verifies that command queues created with GLOBAL_RELATIME priority are able to preempt lower-priority workloads on the system.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Heap CPU Access Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23174b8b-8b36-49c5-94d5-69a7fe7cfdc6

Creates a heap and test if it is mapped for CPU access properly

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Heap Of Unaligned Size Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24b776e5-3bb3-4025-b0c4-58e04c2b38ea

Check if heap of unaligned size can be created

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - History Buffer Format Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846184

Validates that drivers insert begin/end timestamps per command list and not per dma buffer.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Index Buffer Format and Strip Cut

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f48f63fe-f44b-4bbc-87ae-437f6e177d5a

Switch through combinations of index buffer format and strip cut value.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Indirect Draw - Bundle test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e9b7c77-4725-4f31-87e8-ce0858e79186

Test conformance of calling indirect draw from a bundle.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Indirect Draw - Draw Indexed test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee0234b7-14d5-4d32-9b4a-33bd7636b8b1

Test indirect draw conformance.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Indirect Draw - Indirect Dispatch test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8537e7cf-145d-4720-bde2-bf94ae62d2fa

Test indirect dispatch conformance.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Indirect Draw - Stress test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6097b430-9e50-4d55-b76c-f044e6e1aab3

Stress test ExecuteIndirect implementations by creating an Command Signature that draws 100,000 triangles each with a unique vertex buffer and a color data root CBV. Executes this directly and indirectly to ensure that the same result is output

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Large Resource Copy Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c59a7c1-a9fc-4a4d-bfc5-4f138133550e

Verifies that the driver can correctly copy large resources, which exceed the size limits of DX11.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Late Latch Atomic Copy Barrier

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/857ad4d9-50b1-485c-ae1f-c2868471fc3c

Verifies global memory ordering barriers work with atomic copy.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Late Latch Atomic Copy Miscellaneous

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d652cc9a-3a6d-4b8b-9de5-94e054b9a355

Verifies atomic copy operations behave like other buffer copying operations.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Late Latch Atomic Copy UINT

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9677319-667a-45f5-a591-012261200df2

Verifies 4 bytes can be atomically copied when naturally aligned.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Late Latch Atomic Copy UINT64

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99628943-14fd-463b-9529-89ede0fc074d

Verifies 8 bytes can be atomically copied when naturally aligned.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Latest Versions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d82297bd-09ae-47d2-a40e-02977e6fd773

Validation for Usermode DDI versioning is at latest for a given release.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Linked Adapter Features

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/811985e3-9944-4a77-b9f9-0a554f685f53

Verifies behavior of linked adapter features.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12MultiAdapter.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Long CommandLists Execution test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59c9dda3-2d37-454b-a437-6f3b43c65d7e

ExtremelyLongCommandLists test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Metacommands - Batch Normalization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1474f59-dcf0-4147-ab3d-f07c54a908a9

Tests batch normalization operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Convolution

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/800e49e0-91fc-4930-97d2-55b257f6e8e4

Tests convolution operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Copy Tensor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a99d43c0-c233-4a24-8392-7e700a4d0a08

Tests the copy tensor operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Data modification between executions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/60f8a5ea-de7e-4539-a2b0-d687ca257443

Tests an IDMLOperation works correctly when executed twice with different data.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Gated Recurrent Unit

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24dbc5c8-da61-45d3-93a1-9f45489d859e

Tests gated recurrent unit operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - General Matrix Multiplication

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f9371a9-d7c4-47db-b60a-74d412cd12a3

Tests general matrix multiplication operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Long Short Term Memory

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31c434ab-ef76-463d-b9a6-ce96b95c3ec8

Tests long short term memory operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Mean Variance Normalization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/893233d1-9bda-4740-ab0d-f6bb6ebd1951

Tests mean variance normalization operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Pooling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/95fa4814-5ae5-42d7-a2bd-b9ad5e0dbdb3

Tests pooling operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Recurrent Neural Network

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8955bf0a-fb22-43d7-b07d-c2d27b3af902

Tests recurrent neural network operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Reduction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be64ac98-3fbd-486e-900e-066401935a39

Tests reduction operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Reflection Metadata

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d50f701-9ecb-40a3-8a3a-cf9885e74008

Tests reflection metadata offsets is accurate for PIX capture.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Region of Interest Pooling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0aad0491-a239-499a-9c8a-5e91564fa21e

Tests pooling operator.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Metacommands - Validate Dirty State

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bc7241a-1ce7-4265-bb88-0b6b14b4c367

Tests that metacommand execution does not change unintended state.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Metacommands.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Miscellaneous Residency Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9fde9f03-6184-45f9-b80e-d2b60ea63f5d

Exercise Residency management on D3D12 objects other Resource and Resource Heap.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiDecodeSingleCommandListH264

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61d617b0-9513-43e8-acc2-067eb3b9871a

Test decoding of two different streams using a single H264 decoder

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiEngine

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c4dde51-2ddd-497a-b107-203b378b91c4

Verifies the MultiEngine feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiResSingleCommandListH264

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c269d6a-5847-49eb-9d88-8eedfe3ef389

Test decoding of two different streams at different resolutions using a single H264 decoder

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Multiple Heaps Residency interaction Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb84a9f3-e978-4501-8094-bfacfae49a72

Check multiple heaps residency interaction under budget constain.Make one heap resident and draw a matrix of 64 quads from resources in it to compare with golden image.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Multiple Resources Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d91922a-05ba-4645-99d4-7b7575f38a38

Exercise multiple placed resources in heap by drawing a matrix of 64 quads setting a Constant Buffer and Texture for each.Compare against test generated golden image for correctness.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Multiple Threads Wait For A Single Fence Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4da9938f-7e0b-4984-bb5f-bf960a381a10

Multiple Threads Wait For A Single Fence, the main thread will signal all the other threads.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Multiple Threads Wait For Multiple Fences Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/236aa252-d1bd-439e-902d-476e99571b97

Multiple Threads Wait For different fences, the main thread will signal all the other threads.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiThreaded Create Record and ExecuteTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3e989da-3884-4d85-97c7-b49ed8f3797e

Creating, Recording, and Excuting multiple command lists concurrently, each thread works on a different command list

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiThreaded Execution Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/147e5b76-c2de-4ea3-b817-46d0871ea17a

Excuting multiple command lists concurrently, each thread excutes a different command list

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiThreaded Recording ConstantBuffer Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b746b68c-54e0-41df-8513-62b8d4e6cd94

Recording multiple command lists concurrently, each thread writes to a different command list, all the threads create its own constant buffer in the same upload heap

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiThreaded Recording Speed Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c4ae1bc-eded-4e66-9c91-6f437cf5610c

Comparing the speed of recording multiple command lists with multiple threads vs single thread

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - MultiThreaded Recording Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee76afc8-0181-4960-bf06-b650442a8e32

Recording multiple command lists concurrently, each thread write to a different command list

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Null IB VB SO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3da4fec-914e-4442-bb10-851cbb910751

Verify options for Null bindings for IB/VB/SO.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - NULL PSO Compute test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f898ac8-6561-4a7c-a2a6-b5cc1841e3c6

Verifies that dispatch with a Graphics PSO set, actually is vetoed by the driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Null PSO Graphics test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cecaa06b-d636-4908-83e4-82f37d597265

Verifies that drawing with a Compute PSO set, actually is vetoed by the driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Overlapping Resources Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/677fed4b-dc62-420e-b66a-0ba0f70b390b

Exercise overlapping resources in heap by drawing a matrix of 64 quads setting a Constant Buffer and Texture for each.Compare against test generated golden image for correctness.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Placed Views Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03af47be-4f8b-4c39-b06c-32283422f3c7

Creates an SRV/DSV/RTV as placed resources. Copies from the SRV to the RTV in a PS and then verifies content. Based on parameters, also tests shared resources by doing the rendering work on one device and then the RTV/DSV verification on a separate device

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - PSO Deduplication Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/74e9a354-4a37-498b-b92b-956cbbbcd073

Verifies whether drivers implement PSO deduplication correctly.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - PS-Specified Stencil Reference

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1c841b6-0b43-4982-a834-fbed33333aa6

Verifies whether the Pixel Shader specified Stencil Reference feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12StencilReference.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Programmable MSAA Test Decompress -

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/91b42e6b-cf60-4c3a-9a69-804da4cacc7c

Test programmable MSAA.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.ProgrammableMSAA.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Programmable MSAA Test Hardware Tier 1 -

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/782640ea-a8d0-4342-b35f-02b2485f76ed

Test programmable MSAA.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.ProgrammableMSAA.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Programmable MSAA Test Hardware Tier 2 -

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e766b0d-2cf1-4bf7-87a5-2d5b79d4713c

Test programmable MSAA.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.ProgrammableMSAA.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Programmable MSAA Test Resource Copy -

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e478379a-0bf0-4ab6-afe9-75bae9e557fc

Test programmable MSAA.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.ProgrammableMSAA.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Rasterizer Ordered Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c15ca796-31c0-4e2f-b6dc-4c51d1020377

Verifies whether the Rasterizer Ordered Views feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12RasterizerOrderedViews.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Raytracing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06e9b55c-773e-4900-afdc-e43740ee50e8

Validates rendering correctness when D3D12 Raytracing APIs are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Any Hit Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50051d1f-6f3f-467d-9d39-5dec2c620774

Validates correctness when D3D12 Raytracing any-hit shaders and associated intrinsics are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Barriers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31b5ae06-0000-42d9-8b0b-5f51c92df888

Validates correctness when D3D12 Raytracing Barriers are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Barycentric

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db5b4ea6-df87-4058-9a8b-79b00b03e536

Validates correct barycentrics when using DirectX Raytracing.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Command List State

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4507136d-3928-45c8-92fd-5ad6ade34be7

Validates correctness when D3D12 Raytracing Command Lists are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing HLSL

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4768d409-bd8c-44ad-acdd-6ecda19cc1e4

Validates correctness when D3D12 Raytracing shader intrinsics, payloads, and parameters are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Intersection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8271ba7f-8c7e-46b3-8f0b-45e09a9cace3

Validates correctness when D3D12 Raytracing intersection shaders are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Recursion

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/29d442b0-f784-4736-a71e-183299338b8f

Validates correctness when D3D12 Raytracing recursion is used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Shader Tables

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a38b1886-173b-4e96-ac28-ac69d58e0521

Validates correctness when D3D12 Raytracing Shader Tables are used.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing TraceRay

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81a77753-8359-4f1e-9e8b-fd3a64988884

Validates correct behavior when a TraceRay call is invoked.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Raytracing Watertightness

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c2cd14e-969b-4a41-8eac-b3e74ec0d8ec

Validates correct watertightness when using DirectX Raytracing.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Red Blue Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc232084617c

Reconstructs pixel drawing based on the order of Gpu Timestamps.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - RelaxedCasting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e043f48a-d49a-4364-8989-2da8e8c2693c

RS3+ drivers must support views casting format of fully typed resources.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Render Passes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e51c738-50d3-4dc8-be04-ff0af2e94769

Validates rendering correctness when D3D12 Render Passes are used at the API.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - RenderTargetArrayIndex and ViewportArrayIndex from VS and DS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07d08430-8a97-4117-8e14-c0d3d55630fe

For VS/DS RTAI/VPAI output for D3D12, verify that it works as expected.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Barrier Batch - Texture2D

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1882a461-0654-4e35-8a03-d563149e5642

Tests the ability to put multiple resource barriers in a single call

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Barrier Transition - Buffers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c8d9e83-4c5d-4036-9ca3-0f0a50279d12

Tests all meaningful permutations of resource barriers that can be done with a buffer. For each permutation, DX operations are done before and after the barrier to test GPU read/write hazards.Tests usage for UAV/Copy Source/Copy Dest/RTV

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Barrier Transition - Depth Texture2D

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a996a540-47b4-4bc2-b991-cb6ed14e5f34

Tests all meaningful permutations of resource barriers that can be done with a DSV compatible texture. For each permutation, DX operations are done before and after the barrier to test GPU read/write hazards. Tests usage for DSV/SRV/Non-PS SRV/Copy Dest/Copy Source/Resolve Dest

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Barrier Transition - Texture2D

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/986387dc-8f32-4491-8255-13878ab08aeb

Tests all meaningful permutations of resource barriers that can be done with a texture. For each permutation, DX operations are done before and after the barrier to test GPU read/write hazards. Tests usage for SRV/RTV/Non-PS SRV/Copy Dest/Copy Source/UAV/Resolve Dest

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Basic API Index Vertex

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85722943-237b-48c9-a89b-9a5dc008d5a0

Test basic binding API functionality and conformance by drawing a quad that uses an index buffer and a vertex buffer.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Basic Depth Stencil

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8a17f5e-77c1-4b39-82a3-951a39a7474e

Test basic depth stencil functionality by binding a depth stencil view and comparing the output to a known value.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Basic Stream Output

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b23bf07-0802-48e9-9645-05555d3263b2

Test basic stream output functionality by binding a stream output view and examining the values after drawing a rectangle.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Clear Compute Root Arguments

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f4b926c-129a-4a18-a1a9-58b532643190

Tests whether root arguments are cleared at appropriate times.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Clear Graphics Root Arguments

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94978011-a17c-41c8-818f-ac02e7969c8b

Tests whether root arguments are cleared at appropriate times.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Compute deferred descriptor editing test.

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f307fb58-db3e-443c-b9ef-d1624c8efdcf

Validates driver conformance when changing descriptors after a command list has been completed and closed for the compute pipeline.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Compute Root Constant Buffer Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee350bb4-5530-423e-bbcc-a18127b8a7f8

Test Compute Root Constant Buffer Views by binding 4 views and using a Compute Shader to gather the values they contain into an output UAV for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Compute Root Constants

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/635f8a3a-56a2-4d0e-8b2b-b2808586b5d9

Test Compute Root Constants by binding 4 different root constant values and using a compute shader to gather the values they contain into an output UAV for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Compute Root Shader Resource Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ced39aaa-bb6b-48c8-bd41-3a06dabf5c36

Test Compute Root Shader Resource Views by binding 4 views and using a Compute Shader to gather the values they contain into an output UAV for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Compute Root Unordered Access Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3acc53d6-49e5-4f4c-86b2-9ef5eb01da80

Test Compute Root Unordered Access Views by binding 3 views and using a Compute Shader to gather the values they contain into an output UAV for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Copy Descriptor Simple Non Shader visiable to Shader Visible Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31308e3d-5cc0-4069-b330-a8cf42d5ed49

Validates whether descriptor copies work correctly, by creating an arbitrary heap with descriptor entries copying that into a new heap and rendering a rectangle which uses all heap entries to produce a color.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Copy Descriptors using the copy descriptor API to do the exact same as the CopyDescriptorSimple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f31baae5-9e83-4ed2-ade0-ff4eb8bfea5b

Validates whether descriptor copies work correctly, by creating an arbitrary heap with descriptor entries copying that into a new heap and rendering a rectangle which uses all heap entries to produce a color.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Degenerate root signature variation test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e06be179-3242-477e-be0a-47de56d17a3d

Tests whether the pipeline can draw with a root signature that does not have any entries and shaders that solely rely on vertices.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Graphics deferred descriptor editing test.

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/308aadee-b853-4f0b-aafd-d0dee1a1af2d

Validates driver conformance when changing descriptors after a command list has been completed and closed for the graphics pipeline.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Graphics Root Constant Buffer Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90dbe89f-d76e-426c-a377-d54d6f077e9a

Test 3D Root Constant Buffer Views by binding 4 views and adding up the contents in a pixel shader and outputting to Render Target for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Graphics Root Constants

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b194c12-0213-4ec5-b050-1e3ddaaaff05

Test 3D Root Constants by binding 14 different root constant values and adding them up in a pixel shader and outputting result to Render Target for verification

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Graphics Root Shader Resource Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fcb0d79e-d2c8-4f93-8635-233ba0821ba5

Test 3D Root Shader Resource Views by binding 4 views and adding up the contents in a pixel shader and outputting to Render Target for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Graphics Root Unordered Access Views

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca6a932d-67ca-4ece-8462-68acf5bb30b5

Test 3D Root Unordered Access Views by binding 3 views and adding up the contents in a pixel shader and outputting to Render Target for verification.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max binding test for tier 1 hardware

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49a534f9-ee34-4158-8379-0df6fea88ef4

Generates resources which formulate a hash and verifies that all resources are part of the final render.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max binding test for tier 2 hardware

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c746a5ad-e1e7-45bf-b9a6-8d012a37d58f

Generates resources which formulate a hash and verifies that all resources are part of the final render.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max binding test for tier 3 hardware

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce359551-d761-4d6f-bad8-dfc7ead502ac

Generates resources which formulate a hash and verifies that all resources are part of the final render.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max Descriptor Heap Size

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efad06e8-51d1-40ce-ad5c-573a134b4bb6

Test that all regions of a descriptor heap are accessible. Creates a heap of 1,000,000 SRVs (1.1m for tier 3) and does some rendering to test that all of the descriptors return the correct value when accessed through a shader.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max Descriptor Heap Size shader model 5.1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9567f460-03ef-4281-8531-eb2c9fefee80

Uses the 5.1 shader model to dynamically index and us all resources, to verify that all descriptor heap entries are valid.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max Sampler Descriptor Heap Size for Shader Model 5_0

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94fce664-f2b2-42a9-bd12-53593b909831

Test that all regions of a sampler descriptor heap are accessible. Creates a heap of 2048 Samplers (the max for any tier) and does some rendering to test that all of the descriptors return the correct value when accessed through a shader. This is done in 16 Sampler chunks to satisfy the Tier 1 max Sampler binding limit of 16.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Max Sampler Descriptor Heap Size for Shader Model 5_1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97c9c6c9-d9fb-4173-bdce-a8cda7c416d5

Test that all regions of a sampler descriptor heap are accessible. Creates a heap of 2048 Samplers (the max for any tier) and does some rendering to test that all of the descriptors return the correct value when accessed through a shader. This is done in one draw with all Samplers bound in an unbounded fashion.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Null Descriptor Access

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a60b130-a15a-4428-b9be-4ef2fec82687

Test shader access of NULL descriptors matches the expected behaviour. Bind NULL SRV, UAV and CBV's and read them back into a UAV to verify results.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Null Descriptor Access Compute

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88294ab2-6540-4d21-8bc2-2a03d53b7b13

Test shader access of NULL descriptors matches the expected behaviour. Bind NULL SRV, UAV and CBV's and read them back into a UAV to verify results.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Out of Order and Aliased Bindings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08a950b1-f07b-4959-b7d7-6c8beb7f184a

Test that out of order and overlapping-aliased bindings are handled correctly. Defines a Root Signature that will cause 2 bindings to come from the same location and 1 binding that is out of order from the first two binding entries (further towards the start of the heap)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Root signature variation test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/326c8a46-e816-452b-9aa3-c01587bb35cb

Tests whether different Root signatures can be created and used to bind resources for the graphics pipeline.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - ScatterGather copy descriptors from one heap into another

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/822e5538-dabd-478f-a121-2601d8981157

Validates whether descriptor copies work correctly, by creating an arbitrary descriptor heap with descriptor entries reversing this heap into an intermediate heap and reconstructing the original heap and rendering a rectangle which uses all heap entries to produce a color.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Binding - Shader Resource Visibility

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7afeb58f-ab42-4015-b7ce-db5c4ddbce8f

Test that different shader stages can use the same register binding but reference different descriptors through the root signature parameter Shader Visibility functionality. Test uses all 5 3D shader stages, each reading from SRV0 and writting to UAV1. The UAVs are then verified to hold unique data from each stage

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Copy Test MultiQueue

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c59a7c1-a9fc-4a4d-bfc5-4f1381335511

Saturates memory bus bandwith with multiple copies on different GPU queues.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Copy Test MultiQueue with compute

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c59a7c1-a9fc-4a4d-bfc5-4f138133550f

Excersizes multi queue parallelism, while copying buffers and running compute work.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Resource Serialization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a5f233e-8694-413c-91be-34c0e77fe222

Tests implicit promotion and decay behavior for resource state barriers, to ensure multi-reader and resource serialization requirements are met.

Test details
Specifications
  • Device.Graphics.WDDM24.Render.D3D12ResourceSerialization
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Resource State across Multiple Command Lists executed together by a Command Queue Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/354b7c05-4ca7-4f8e-b8e3-f971e8477767

Debug layer tracks resource state across multiple command lists executed together by a command queue.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Resource State across Multiple Command Lists Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a6f1ac1-4a47-48ee-a5b4-7c1a78b08020

Debug layer tracks resource state across multiple command lists.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Resource State Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97f96d9f-a769-4d32-87a6-dc336573460f

Debug layer catches improper resource state.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SetBlendFactorTest test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dfec21d1-9acc-4534-a47d-641b4e13735c

SetBlendFactorTest test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SetScissors test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58575159-2647-45e4-9beb-6a7fe796322c

SetScissors test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SetStencilReference test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7486ce28-ebcd-41e3-a696-036b217ca5ba

SetStencilReference test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SetViewportsTest test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1d2df61d-d12f-49dd-ab77-3b58620d6ee9

SetViewportsTest test

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Shader Cache Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea814d23-99ae-4ccc-8f71-b7592d22ad2b

Tests to prevent incorrect usage of shader caching callbacks.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Shader Disassembly Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6fd0912-4c04-4709-90c2-06e7165cdfd9

Tests for correct implementation of RetrieveShaderComment DDI and well-formed resulting XML.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Signal a Fence directly test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/30c59d62-1989-4dc3-8a7b-a6558461a111

Signal a fence from ID3D12Fence

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Signal a fence from command queue Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c18b798-c339-473e-99d2-1886f611f691

Signal a fence from a command queue

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Descriptor Table Register Index Out of Bounds Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cbba3ebd-1abb-47f3-8374-f764c0bd8690

Simple Test - Debug layer catches shader access to an out of bounds shader register index.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Descriptor Type Mismatch Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff037b13-29c0-43d1-9f79-cfa011faba91

Simple Test - Debug layer catches shader access to descriptor of wrong type.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Simple ETW Check Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc232084617b

This test verifies D3D12 functionality conformance across for high performance ETW data.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Heap Index Out of Bounds Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f439b8a4-ea43-4c46-b33c-e955b226cb78

Simple Test - Debug layer catches shader access to an out of bounds heap index.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Invalid Resource Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11db400c-ff2c-4332-b68d-77633296c216

Simple Test - Debug layer catches shader access to a released resource.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Resource Barrier Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a036ba6-05ea-4b6d-b1f3-17e7ff1b035d

Simple Test - Debug layer catches resource barrier transition errors.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Resource Dimension Mismatch Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a4663f21-fd2e-49e5-8b52-9d3b31c0f3ed

Simple Test - Debug layer catches shader access to resource of the wrong dimension.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Resource State for Non Shader Access resources Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88b8e125-2ef6-4cb2-8783-30caceae6d9e

Simple Test - Debug layer catches resources in the wrong state.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Resource State Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c9b092d-931a-49d1-91a5-5789a3130c61

Simple Test - Debug layer catches shader access to resource in the wrong state.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Root Descriptor Out of Bounds Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd90303a-a820-4421-8581-65e28a99e571

Simple Test - Debug layer catches shader access to root descriptor out of bounds.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Split Barrier Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8daf7d61-bc5a-4a7c-b8e5-bd7df91eabb8

Simple Test - Debug layer catches resource split barrier transition errors.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Simple Uninitialized Descriptor Table Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e215c351-840c-48b6-bb8d-8cbb86dde1c2

Simple Test - Debug layer catches shader access to uninitialized bindings.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SRVSwizzle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50bec227-039a-408c-ad0c-fa5a33398460

Component selection in SRVs.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SingleCommandListTimestampsDecode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e325ab37-f285-472f-98c1-aa48cca4d121

Test time stamps on the video decode command queue.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SingleCommandListTimestampsProcess

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d3e293c-c74a-4888-aa75-e73378f32fc4

Test time stamps on the video Process command queue.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - SingleDecodeH264

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d8581d9-f453-45c5-8c06-c200389017cc

Test decoding of a single frame using H264 codec

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Standard Swizzle Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e229f8b-1e3d-48d6-80c2-20d34192b3f3

Check Standard Swizzle of resource in CPU-invisible Heap.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - State Object Creation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15dfd5f4-2e69-4908-a51f-824ff8287be2

Validates state object creation for a complex state object.

Test details
Specifications
  • Device.Graphics.WDDM25.AdapterRender.D3D12.Raytracing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Static Samplers Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e83378bb-0cff-483d-9461-023656d5ba09

Basic usage of static samplers. Verify static samplers and dynamic samplers behave identically.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Static Samplers Limit Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c91de7b-b33c-4079-bf97-cd6cbe224692

Stress 2032 static sampler limit, since some drivers need to emulate these via hidden space in sampler descriptor heap(s).

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - StressBind test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/98a97e2f-85ab-42fc-b724-5174fad1bf18

Excersizes binding to stress test the drivers binding implementation.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Debug Layer GBV - Subresource State Validation in Shader Instructions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b56d789-8425-4291-a2e5-1f79a6298e63

Debug layer catches improper subresource state in shader access instructions.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - System Reserved Root Signature Space

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e53132e-df8c-4c47-a5c2-a4b11e372365

Use system reserved 64 slots of root signature space, in addition to full API visible 64 slots.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Timestamp Range

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12fecd65-3ecf-4b56-8485-cc2320846183

Ensures that GPU Timestamps fall between the range defined by the begin and end Timestamps of a DMA Buffer.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Tracked Workloads

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/34c2744d-4b7e-4014-838e-5e1989e8b602

Test tracked workload duration

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


D3D12 - Typed UAV Load

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5ff0a2a6-f43b-4eda-a3a1-d01c46940c3b

Verifies whether the Typed UAV load feature is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12TypedUAVLoad.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - UMH - Reserved Resource Copy Mapping Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9588d945-4227-4ae1-86b0-3b73ef2d2d16

Conformance test for Reserved resource creation.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - UMH - Reserved Resource Copy Tiles Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4940664-43b1-47f9-bcdc-a73cce67dae8

Conformance test for Reserved resource creation.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - UMH - Reserved Resource Update Mapping Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/865d45dd-14d2-47c0-8678-55afb280077a

Conformance test for Reserved resource creation.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12Core.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - CheckBufferInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/281188b8-ad13-446b-8969-d27c853be821

Test video decoder buffer

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - CreateVideoDecodeOutputView

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23097e31-7c79-457f-94f6-acf41689d9cc

Test basic video decode output view creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - CreateVideoDecoder

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4ef8f14-621f-4e08-8dfd-b62f1c59bed7

Test basic video decoder creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - CreateVideoDevice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fbda8c74-cdb1-4f66-8139-d5b065b70d02

Test basic video device creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - CreateVideoProcessor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e016167-45a2-45c5-9a54-5b75bcab9a24

Test basic video processor creation

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoProcessing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - GetDecodingStatus

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abdbd718-85d2-457d-9b08-601e6e42ef1c

Test decoding status feature

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - SingleDecodeH264

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55706591-80af-4626-85ad-79ca55a4f65a

Test decoding of a single frame using H264 codec

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - SingleDecodeHEVC

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/379076a2-fcb7-43eb-b6a1-9bdcb09c8a35

Test decoding of a single frame using HEVC codec

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - SingleDecodeVC1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d9cc0e7-3152-4b15-9ecd-ddd6ba2cdf39

Test decoding of a single frame using VC1 codec

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - SingleDecodeVP9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71073dcb-2217-4ecd-b05c-b02873a5063d

Test decoding of a single frame using VP9 codec

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - VideoProcessorBlt

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50dacf76-6d87-4a10-ac83-dfd45ca59051

Test basic video processor blit operations

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoProcessing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - Video - VideoProcessorSetGet

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5fc74e5a-f910-49fd-8f72-33bf0f0b8c0c

Test basic video processor setters and getters

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoProcessing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - VideoProcessAndDecodeMarkers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10885fc6-5931-4c77-b67b-a25f0bc33811

Test ETW markers on Video Process and Decode command lists.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - VideoProcessFramesPredication

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c13fb6c7-c9b4-4f60-9db2-4ae7c07a2c6f

Test predication functionality for video process functionality.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D12VideoDecoding.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D12 - View Instancing test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d856efa-a708-46cb-b74a-5adcf134a7f2

Test view instancing functionality.

Test details
Specifications
  • Device.Graphics.WDDM23.AdapterRender.D3D12.ViewInstancing.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D9 - Cross Adapter Resource Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/29167635-a8b1-46ae-9b00-7cffb419abfc

Verifies whether support for cross adapter resources is correctly implemented for a specific driver.

Test details
Specifications
  • Device.Graphics.WDDM24.Render.CrossAdapterResource
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


D3D9 Overlay - CheckDeviceOverlayType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94ff5cd9-391b-4cda-b099-2495cef69ed7

This manual test executes multiple test cases targeting IDirect3D9ExOverlayExtension::CheckDeviceOverlayType. It uses different sizes of both valid and invalid display modes, including rotated modes.

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.D3D9Overlay.D3D9Overlay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following:

  • A device driver with D3D9 support that exposes D3DCAPS_OVERLAY

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test calls into CheckDeviceOverlayType with valid and invalid parameters. It attempts to check the largest overlay size, as well as the smallest reported as supported by the driver.

The test might return SKIP if the driver does not expose D3DCAPS_OVERLAY. Some cases might skip if the back buffer format or mode is not supported during D3D device creation.

More information

The test runs the following test jobs:

CheckDeviceOverlayType:

  • Verify failure if Adapter index is out range.

  • Verify a NULL if pDisplayMode returns the same results as a pDisplayMode filled in with the current display mode.

  • Verify D3DERR_UNSUPPORTEDOVERLAYFORMAT by finding a successful overlay type, and cycling on OverlayFormats.

  • Verify D3DERR_UNSUPPORTEDOVERLAY is returned for an invalid width and height. The job finds a successful overlay type, and cycling on non-standard overlays sizes.

CheckDeviceOverlayType with CreateDeviceEx interaction:

  • Verify that a successful call to CheckDeviceOverlayType can result in a successful call to CreateDeviceEx.

    WARNING

    This will always be the case until driver support is added.

  • Verify that a failed call to CheckDeviceOverlayType results in a failed call to CreateDeviceEx.

    WARNING

    This test case will fail until driver support is added.

Command syntax

Command option | Description
D3D9OverlayTest CheckDeviceOverlayType -whql -logclean | This command runs the D3D9 Overlay - CheckDeviceOverlayType test job.
TestCasePriority:[0, 1, 2] | Specifies the priority of the test cases to run. 0 runs build verification level (BVT) level test cases; 1 and 2 run more aggressive test cases.
LogLevel[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default, level 0 is set; level 1 gathers increased logging information per test cases, including many stream states/blt states set; and level 2 gathers all adjusted stream states and blt states, as well as any configuration information.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3D9OverlayTest.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\func</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


D3D9 Overlay - CreateAdditionalSwapChain

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79e3ea66-6137-4c7e-82dd-857d30d3da2f

This manual test calls into CreateAdditionalSwapChain with valid and invalid parameters. It attempts to check the largest overlay size, as well as the smallest reported as supported by the driver.

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.D3D9Overlay.D3D9Overlay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following:

  • A device driver with D3D9 support that exposes D3DCAPS_OVERLAY.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test calls into CheckDeviceOverlayType with valid and invalid parameters. It attempts to check the largest overlay size, as well as the smallest reported as supported by the driver.

The test might return SKIP if the driver does not expose D3DCAPS_OVERLAY. Some cases might skip if the back buffer format or mode is not supported during D3D device creation.

More information

This test executes multiple test cases targeting IDirect3D9Ex::CreateDevice with IDirect3D9ExDevice::CreateSwapChain. It uses different sizes of both valid and invalid display modes, flags, and overlay sizes. It also tests different types of swap chain creations.

The test runs the following test jobs:

CreateDeviceEx:

  • Verify successful creation of non-RGB backbuffer if non-RGB overlay is supported.

  • Verify swapeffect fails full screen and is successfully windowed.

  • Verify swapeffect fails when using an interface other than D3D9OverlayExtended.

  • Verify that Multisampling fails.

  • Test case in which a D3D9Ex overlay device has been created by one process, and then another process attempts to create another D3D9Ex swap chain.

  • Verify CreateDeviceEx with D3DPRESENTFLAG_OVERLAY_LIMITEDRGB successfully limits color range during present time of 16 to 235 if supported by the driver. For more information, see the PresentEx test cases below.

  • Verify CreateDeviceEx with D3DPRESENTFLAG_OVERLAY_YCbCr_BT709 successfully increases luma and chroma sampling, as well as limiting the RGB values to between 16 and 235 during present time if supported by the driver. For more information, see the PresentEx test cases below.

  • Verify CreateDeviceEx with D3DPRESENTFLAG_OVERLAY_YCbCr_xvYCC successfully increases RGB color range between 1 and 255 during present time if supported by the driver. For more information, see the PresentEx test cases below.

  • Verify CreateDeviceEx with unsupported D3DPRESENTFLAG (fails or succeeds).

CreateAdditionalSwapChain:

  • Verify creation of additional swap chains fails both through CreateAdditionalSwapChain and through reset of an existing swap chain.

Command syntax

Command option | Description
D3D9OverlayTest CreateAdditionalSwapChain -whql -logclean | This command runs the D3D9 Overlay - CreateAdditionalSwapChain test job. Without any options, the test enumerates all but some extreme cases.
TestCasePriority:[0, 1, 2] | Specifies the priority of the test cases to run. 0 will run build verification test (BVT)level test cases 1,2 more aggressive test cases.
LogLevel[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default, level 0 is set; however, level one will gather increased logging info per test cases including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states, as well as any configuration information.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3D9OverlayTest.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\func</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


D3D9 Overlay - CreateDeviceEx

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc22fbbf-60ca-472f-9b76-ffcf143a988f

This automated test executes multiple test cases targeting IDirect3D9Ex::CreateDeviceEx. It uses different sizes of back buffer and formats, both with and without invalid flags and multisampling. It also uses both valid and invalid display modes, including rotated modes.

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.D3D9Overlay.D3D9Overlay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following:

  • A device driver that supports D3DCaps9.Caps D3DCAPS_OVERLAY.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test calls into CreateDeviceEx with valid and invalid parameters. It attempts to check the largest overlay size, as well as the smallest reported as supported by the driver. The test does not present any frames to the screen; it simply iterates over test cases and produces a result of PASS or FAIL.

The test might return SKIP if the driver does not expose D3DCAPS_OVERLAY or if the back buffer format or mode is not supported during D3D device creation.

More information

The test runs the following test jobs

CreateDeviceEx:

  • Verify successful creation of non-RGB backbuffer if non-RGB overlay is supported.

  • Verify swapeffect fails full screen and is successfully windowed.

  • Verify swapeffect fails when using interface other than D3D9OverlayExtended.

  • Verify that Multisampling fails.

  • Test case where a D3D9Ex overlay device has been created by one process, and then another process attempts to create another D3D9Ex swapchain.

  • Verify CreateDeviceEx with D3DPRESENTFLAG_OVERLAY_LIMITEDRGB successfully limits color range during present time to 16...235 if supported by the driver. See PresentEx tests below.

  • Verify CreateDeviceEx with D3DPRESENTFLAG_OVERLAY_YCbCr_BT709 successfully increases luma and chroma sampling, as well as limiting the RGB values to 16...235 during present time if supported by the driver. See PresentEx tests below.

  • Verify CreateDeviceEx with D3DPRESENTFLAG_OVERLAY_YCbCr_xvYCC successfully increases RGB color range to 1...255 during present time if supported by the driver. See PresentEx tests below.

  • Verify CreateDeviceEx with unsupported D3DPRESENTFLAG (fails or succeeds).

CreateDeviceEx with ResetEx:

  • Verify CreateDeviceEx with specified D3DPRESENTFLAG is successfully overridden when a different D3DPRESENTFLAG is specified during ResetEx of the device.

    WARNING

    Verify ResetEx with unsupported D3DPRESENTFLAG (fails or succeeds).

Command syntax

Command option | Description
D3D9OverlayTest CreateDeviceEx -whql -logclean | This command runs the D3D9 Overlay - CreateDeviceEx test job. Without any options, the test enumerates all but some extreme invalid argument test cases.
TestCasePriority:[0, 1, 2] | Specifies the priority of the test cases to run. 0 will run build verification test (BVT) level test cases 1,2 more aggressive test cases.
LogLevel[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default, level 0 is set; however, level one will gather increased logging info per test cases including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states, as well as any configuration information.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3D9OverlayTest.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\func</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


D3D9 Overlay - PresentEx

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c3070fe-7827-4056-842c-c6cbed97a8e1

This automated test executes multiple test cases targeting IDirect3D9DeviceEx::PresentEx. There are specific test cases around dest rect movement resize, colorkey all, with and without DWM enabled. There are cases around hiding the overlay and changing modes during presentation. Presenting overlays on top of existing flip content. If supported, both RGB and non-RGB overlays are tested in common context modes (480p/i, 720p, 1080i, etc.)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.D3D9Overlay.D3D9Overlay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following:

  • A device driver with D3D9 support that exposes D3DCAPS_OVERLAY

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test presents color bars in different sizes and modes. The test presents only 1-10 frames, and in many cases these are not visible without stepping through the test. Internal testing requires frame capture devices, and capturing screen contents can be quite slow. Validating more than 1-10 frames is taxing.

The test might return SKIP if the driver does not expose D3DCAPS_OVERLAY or if the back buffer format or mode is not supported during D3D device creation.

More information

These cases must be tested in combination. Automated verification is achieved using VGA and DVI image capture and compared against a compatible reference image.

The test runs the following test jobs:

  • PresentEx:

    • Verify that moving, resizing, un-occluding, and changing dest rects for a window updates color key data appropriately. The test runs the test cases with the Desktop Window Manager (DWM) both on and then off.

    • Verify that moving a window after calling PresentEx with D3DPRESENT_UPDATEOVERLAYONLY does not cause an actual flip, and that the position and colorkey data update. Cycle with DWM on and off.

    • Verify that if the device or swap chain is destroyed without first using D3DPRESENT_HIDEOVERLAY to turn off the overlay, the overlay is somehow cleaned up. The Microsoft® DirectX® graphics kernel subsystem (DxgKrnl) is expected to clean up, but D3D9 will handle cleanup in most cases.

    • Verify that D3DPRESENT_HIDEOVERLAY turns off the overlay.

    • Addition of a device parameter to allow test cases to be run on either device or monitor, as well as different configurations.

    • Verify the successful presentation of a non-overlay frame in current mode, while an overlay frame is already presented. Then, upon release, the subsequent call to present an overlay results in a successfully presented image.

    • Verify the successful presentation of a non-overlay frame in a mode other than current desktop mode, while an overlay frame is already presented. Then, upon release, the subsequent call to present an overlay results in a successfully presented image.

    • Verify the successful presentation of a non-overlay frame windowed, while an overlay frame is already presented. Then, upon release, the overlay is still the correctly presented image.

  • PresentStatistics:

    • Validate that present statistics are not available or supported.

  • Power Management:

    • Verify all sleep states.

  • Frame capture and comparison implementation:

    • Implementing comparison of a software reference frame and the hardware rendered overlay constitutes a testable unit. This implementation uses peak signal-to-noise ratio (PSNR) with a specified level of tolerance. This tolerance must be high because of the hardware frame capture device. On analog connections, this device can cause color ranges to be compressed or stomped, which produces an increased difference between the rendered frame and the actual displayed frame.

    • This comparison can be implemented on each parameterized test case, including the different D3DFORMATs. It then validates each frame when rendered.

Command syntax

Command option | Description
D3D9OverlayTest PresentEx -whql -logclean | This command runs the D3D9 Overlay - PresentEx test job. Without any options, the test enumerates all but some extreme invalid argument test cases.
TestCasePriority:[0, 1, 2] | Specifies the priority of the test cases to run. 0 will run build verification test (BVT) level test cases 1,2 more aggressive test cases.
LogLevel[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default, level 0 is set; however, level one will gather increased logging info per test cases including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states, as well as any configuration information.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3D9OverlayTest.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\func</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


Depth Bias

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/686430f8-cc23-4e6f-a40c-c2a7da217b53

This automated test verifies that a graphics adapter or chipset has implemented the minimum hardware acceleration capabilities.

This topic applies to the following test jobs:

  • Depth Bias

  • Depth Bias (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Zbias -M:1 -dx9 -whql -logclean | This command runs the Depth Bias test job.
Zbias -M:1 -whql -logclean | This command runs the Depth Bias (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zbias.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Depth Bias (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06e66da4-f103-4ac5-8395-efd1b7d6b5a1

This automated test verifies that a graphics adapter or chipset has implemented the minimum hardware acceleration capabilities.

This topic applies to the following test jobs:

  • Depth Bias

  • Depth Bias (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Zbias -M:1 -dx9 -whql -logclean | This command runs the Depth Bias test job.
Zbias -M:1 -whql -logclean | This command runs the Depth Bias (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zbias.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Discardable Depth Stencil

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/421907f9-f25c-4411-b49c-72f7c3038d2f

This automated test verifies that a graphics adapter implements the minimum hardware acceleration capabilities.

This topic applies to the following test jobs:

  • Discardable Depth Stencil

  • Discardable Depth Stencil (WoW64)

  • Discardable Depth Stencil 2-10-10-10

  • Discardable Depth Stencil 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Zbuffer -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil test job.
Zbuffer -M:1 -whql -logclean | Runs the Discardable Depth Stencil (WoW64) test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zbuffer.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Discardable Depth Stencil (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/173aec82-765e-43a1-bdb1-810e3a00b21f

This automated test verifies that a graphics adapter implements the minimum hardware acceleration capabilities.

This topic applies to the following test jobs:

  • Discardable Depth Stencil

  • Discardable Depth Stencil (WoW64)

  • Discardable Depth Stencil 2-10-10-10

  • Discardable Depth Stencil 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Zbuffer -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil test job.
Zbuffer -M:1 -whql -logclean | Runs the Discardable Depth Stencil (WoW64) test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zbuffer.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Discardable Depth Stencil 2-10-10-10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ed91517-9d6d-41be-9e7a-e53c9d777a19

This automated test verifies that a graphics adapter implements the minimum hardware acceleration capabilities.

This topic applies to the following test jobs:

  • Discardable Depth Stencil

  • Discardable Depth Stencil (WoW64)

  • Discardable Depth Stencil 2-10-10-10

  • Discardable Depth Stencil 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Zbuffer -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil test job.
Zbuffer -M:1 -whql -logclean | Runs the Discardable Depth Stencil (WoW64) test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zbuffer.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Discardable Depth Stencil 2-10-10-10 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/60031032-bdc5-4324-bcef-5c982479ce5c

This automated test verifies that a graphics adapter implements the minimum hardware acceleration capabilities.

This topic applies to the following test jobs:

  • Discardable Depth Stencil

  • Discardable Depth Stencil (WoW64)

  • Discardable Depth Stencil 2-10-10-10

  • Discardable Depth Stencil 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Zbuffer -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil test job.
Zbuffer -M:1 -whql -logclean | Runs the Discardable Depth Stencil (WoW64) test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 test job.
Zbuffer -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Discardable Depth Stencil 2-10-10-10 (WoW64) test job.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Zbuffer.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Displacement Mapping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8840b740-1408-40a6-9112-7861408a3c09

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Displacement Mapping

  • Displacement Mapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Displacementmapping -M:1 -dx9 -whql -logclean | Runs the Displacement Mapping test job.
Displacementmapping -M:1 -whql -logclean | Runs the Displacement Mapping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Displacementmapping.exe | <[testbinroot]>\nttest</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Displacement Mapping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/744070b2-9c15-472a-a5b1-17a9ba5f7623

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Displacement Mapping

  • Displacement Mapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Displacementmapping -M:1 -dx9 -whql -logclean | Runs the Displacement Mapping test job.
Displacementmapping -M:1 -whql -logclean | Runs the Displacement Mapping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Displacementmapping.exe | <[testbinroot]>\nttest</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Display Mode Filter Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2eef3c0-2f71-4872-906f-a8ee6f707a36

This automated test will check the display modes reported to the BIOS. The test will make sure that Windows 8 drivers expose the correct color depth.

Test details
Specifications
  • System.Fundamentals.Graphics.Display.MinimumResolutionandColorDepth
  • Device.Graphics.WDDM12.DisplayOnly.Base
  • Device.Graphics.WDDM12.Display.ModeEnumeration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.


DisplaySizeTest (Mobile, Manual)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ed03df7-971f-45a3-ab57-9f3c3cfa7bcd

Test details
Specifications
  • Device.Graphics.AdapterRender.MaximumDirect9x
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


Driver Layering Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a424d41c-e66a-4dd9-b228-8fb33a83f571

Test details
Specifications
  • Device.Graphics.WDDM13.Render.CheckDDIBoundaries
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


Driver Scenario

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/742df14b-d94d-4668-a2d1-e29104626d38

This automated test verifies that the display adapter can meet the minimum Microsoft® Direct3D® requirements. For the full list of minimum requirements, refer to the latest Windows Logo Program (WLP) documentation.

The test composes a Direct3D scene that includes all of the relevant elements from the WLP minimum requirements, such as Gouraud shading, basic alpha blending, bi-linear filtering, specific texture formats, and so on. The test then renders the scene with the display adapter and with the reference rasterizer.

The test does a pixel comparison of the rendered images and determines if the test passed or failed based on that comparison (allowing the standard 15 percent difference).

This topic applies to the following test jobs:

  • Driver Scenario

  • Driver Scenario (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software and hardware:

  • Microsoft DirectX® version 7.0 or later

  • Display adapter with Direct3D capabilities

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Scenario -M:1 -dx9 -whql -logclean | Runs the Driver Scenario test job.
Scenario -M:1 -whql -logclean | Runs the Driver Scenario (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Scenario.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Driver Scenario (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54e49bfc-f097-4160-8885-159b5b6c5970

This automated test verifies that the display adapter can meet the minimum Microsoft® Direct3D® requirements. For the full list of minimum requirements, refer to the latest Windows Logo Program (WLP) documentation.

The test composes a Direct3D scene that includes all of the relevant elements from the WLP minimum requirements, such as Gouraud shading, basic alpha blending, bi-linear filtering, specific texture formats, and so on. The test then renders the scene with the display adapter and with the reference rasterizer.

The test does a pixel comparison of the rendered images and determines if the test passed or failed based on that comparison (allowing the standard 15 percent difference).

This topic applies to the following test jobs:

  • Driver Scenario

  • Driver Scenario (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software and hardware:

  • Microsoft DirectX® version 7.0 or later

  • Display adapter with Direct3D capabilities

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Scenario -M:1 -dx9 -whql -logclean | Runs the Driver Scenario test job.
Scenario -M:1 -whql -logclean | Runs the Driver Scenario (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Scenario.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DX11 3DStereoVideo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/60a7bd22-8b00-4446-b895-d9a1c71b1242

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM12.DisplayRender.ProcessingStereoscopicVideoContent.ProcessingStereoscopicVideoContent
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DXVAHDVideoProcessing -Stereo -DXVA11 [CMDLINE] | Runs the test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
DXVAHDVideoProcessing.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\d3d\func</p>
dxvahdsw.dll | <[testbinroot]>\nttest\WINDOWSTEST\graphics\DXVA\dxvahdsw.dll

Parameters

Parameter name | Parameter description
CMDLINE | Command line alteration for specific logging or test case specification.


DX11 Video Rotation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4b651941-b858-430e-8ddc-0e23ba1307a4

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DX11VideoTest.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
DX11VideoTest.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\d3d\func</p>
Dxvahdsw.dll | <[testbinroot]>\nttest\WINDOWSTEST\graphics\DXVA</p>

Parameters

Parameter name | Parameter description
CMDLINE | Command line alteration for specific logging or test case specification.


DX11 Video Rotation for overlay

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6411987-d838-407d-a1b2-3e9f49a90c6a

This test runs test cases for the D3D11 VideoProcessing with all supported D3D11_VIDEO_PROCESSOR_STERO_FORMAT's supported and Overlays enabled where supported:

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_MONO

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_HORIZONTAL

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_VERTICAL

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_SEPARATE

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_MONO_OFFSET

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_ROW_INTERLEAVED

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_COLUMN_INTERLEAVED

  • D3D11_VIDEO_PROCESSOR_STEREO_FORMAT_CHECKERBOARD

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiplaneOverlaySupport
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlayVideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Parameter | Description
-LogClean | Clear the test log at the start of each run. Default value: True
-Step | Run the first test case and then wait for user input before running the next. Useful for debugging failures. Default value: False
NOTE

For command line help for this test binary, type /h.

Parameters

Parameter name | Parameter description
CMDLINE | Command line alteration for specific logging or test case specification.


DX11 VideoProcessing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a54f0c88-300c-476f-8313-c615ae0a81e7

This automated test validates that a graphics adapter or chipset converts all of the specified YUV formats to RGB data for display of video.

Test details
Specifications
  • Device.Graphics.WDDM12.DisplayRender.ProcessingStereoscopicVideoContent.ProcessingStereoscopicVideoContent
  • Device.Graphics.WDDM12.Render.D3D11VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DXVAHDVideoProcessing.exe -Stereo -DXVA11 [CMDLINE] | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
DXVAHDVideoProcessing.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\d3d\func</p>
Dxvahdsw.dll | <[osbinroot]>\nttest\WINDOWSTEST\graphics\DXVA</p>

Parameters

Parameter name | Parameter description
CMDLINE | Command line alteration for specific logging or test case specification.


DX11 VideoProcessing for Overlay

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bff94b26-0a7a-434d-8a93-333f383f2e3d

This test runs test cases across the following DX11 VideoProcessing steps with Overlays enabled where supported:

  • SetVideoProcessBltState

  • GetVideoProcessBltState

  • SetVideoProcessStreamState

  • GetVideoProcessStreamState

  • VideoProcessBlt

The test will show a ticker-like window incrementing pass fail counts and showing which test case variables are being iterated on.

Test details
Specifications
  • Device.Graphics.WDDM12.DisplayRender.ProcessingStereoscopicVideoContent.ProcessingStereoscopicVideoContent
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlayVideoProcessing
  • Device.Graphics.WDDM13.DisplayRender.MultiplaneOverlaySupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Parameter | Description
-LogClean | Clear the test log at the start of each run. Default value: True
-Step | Run the first test case and then wait for user input before running the next. Useful for debugging failures. Default value: False
NOTE

For command line help for this test binary, type /h.

Parameters

Parameter name | Parameter description
CMDLINE | Command line alteration for specific logging or test case specification.


DXGI Cross Process Resource Sharing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31641dc8-36a4-4a91-b99b-4b9eda680eaf

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Cross Process Resource Sharing

  • DXGI Cross Process Resource Sharing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
DXGICrossProcSharing -whql -logclean | Runs the DXGI Cross Process Resource Sharing test job and the DXGI Cross Process Resource Sharing (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGICrossProcSharing.exe | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\api</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Cross Process Resource Sharing (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b38a2847-7cc5-4298-8aee-eb7360708a5b

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Cross Process Resource Sharing

  • DXGI Cross Process Resource Sharing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
DXGICrossProcSharing -whql -logclean | Runs the DXGI Cross Process Resource Sharing test job and the DXGI Cross Process Resource Sharing (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGICrossProcSharing.exe | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\api</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI DirectFlip

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d80da43-4da5-45e9-a629-b3defd3f52ee

This automated test verifies that a graphics adapter or chipset driver publishes the SupportDirectFlip field as TRUE in the DXGK_DRIVERCAPS structure.

NOTE

This field is required for support of DirectFlip. DirectFlip enables a minimum amount of memory bandwidth for displaying full-screen content while ensuring smooth transitions between full-screen applications, other applications, and the desktop environment.

Test details
Specifications
  • Device.Graphics.WDDM12.Render.DirectFlip
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DX11VideoTest.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
DX11VideoTest.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\func</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


DXGI Frame Statistics

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7eaebf39-e735-4556-bafb-0e7fffbf5fc9

This automated test verifies support for the frame statistics feature of DirectX Graphics Infrastructure (DXGI).

This test verifies the DXGI_FRAME_STATISTICS buffer for calls to the DXGISwapChain::GetFrameStatistics and DXGIOutput::GetFrameStatistics functions. PresentCounts should be updated according to the DXGISwapChain::Present function.

This topic applies to the following test jobs:

  • DXGI Frame Statistics

  • DXGI Frame Statistics (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

.

Command syntax

Command option | Description
DXGIFrameStats -whql -logclean | Rusn both the DXGI Frame Statistics test job and the DXGI Frame Statistics (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGIFrameStats.exe | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\api</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Frame Statistics (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d090639-9ada-45a6-8a02-5301efdf86d0

This automated test verifies support for the frame statistics feature of DirectX Graphics Infrastructure (DXGI).

This test verifies the DXGI_FRAME_STATISTICS buffer for calls to the DXGISwapChain::GetFrameStatistics and DXGIOutput::GetFrameStatistics functions. PresentCounts should be updated according to the DXGISwapChain::Present function.

This topic applies to the following test jobs:

  • DXGI Frame Statistics

  • DXGI Frame Statistics (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

.

Command syntax

Command option | Description
DXGIFrameStats -whql -logclean | Rusn both the DXGI Frame Statistics test job and the DXGI Frame Statistics (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGIFrameStats.exe | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\api</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Gamma Ramps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd496d5d-96fa-40be-99c9-e2cf462065c9

This automated test verifies cycle setting, and reads a variety of gamma options using the SetGammaControl function of the DirectX Graphics Infrastructure (DXGI) output.

This topic applies to the following test jobs:

  • DXGI Gamma Ramps

  • DXGI Gamma Ramps (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.Display.GammaCorrection
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test returns Pass or Fail. The test might return SKIP if the DXGI GammaCapabilities cap ScaleAndOffsetSupportd is not set. To review test details, review the test log from Windows HLK Studio.

More information

The DXGI Gamma Ramps test has three tests cases: Curve, Offset, and Scaling. Each group modifies the individual component of the DXGI_GAMMA_CONTROL structure, and then sets it using SetGammaControl.

typedef struct DXGI_GAMMA_CONTROL {DXGI_RGB Scale;DXGI_RGB Offset;DXGI_RGB GammaCurve[ 1025 ];} DXGI_GAMMA_CONTROL;

Command syntax

Command option Description

DXGIGammaVM -whql -logclean

This command runs the following test jobs:

  • DXGI Gamma Ramps

  • DXGI Gamma Ramps (WoW64)
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\graphics\d3d\support</p>
DXGIGammaVM.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Gamma Ramps (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff4a8904-03ca-42f5-b10d-0841a1306a84

This automated test verifies cycle setting, and reads a variety of gamma options using the SetGammaControl function of the DirectX Graphics Infrastructure (DXGI) output.

This topic applies to the following test jobs:

  • DXGI Gamma Ramps

  • DXGI Gamma Ramps (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.Display.GammaCorrection
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test returns Pass or Fail. The test might return SKIP if the DXGI GammaCapabilities cap ScaleAndOffsetSupportd is not set. To review test details, review the test log from Windows HLK Studio.

More information

The DXGI Gamma Ramps test has three tests cases: Curve, Offset, and Scaling. Each group modifies the individual component of the DXGI_GAMMA_CONTROL structure, and then sets it using SetGammaControl.

typedef struct DXGI_GAMMA_CONTROL {DXGI_RGB Scale;DXGI_RGB Offset;DXGI_RGB GammaCurve[ 1025 ];} DXGI_GAMMA_CONTROL;

Command syntax

Command option Description

DXGIGammaVM -whql -logclean

This command runs the following test jobs:

  • DXGI Gamma Ramps

  • DXGI Gamma Ramps (WoW64)
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\graphics\d3d\support</p>
DXGIGammaVM.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI GDI Interop D3D10.1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3020fb9-4b56-4ab7-8159-6707af8d9bcd

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI GDI Interop D3D11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf351b6c-da4e-4aed-8a14-2278d7ceb4e1

This automated test verifies that video adapters/drivers can support DXGI/GDI interop well. This feature is served as infrastructure of D2D.

DXGI/GDI interop is supported by D3D10.1 or later on Windows 7 IP and Windows 7. This test should be run on video adapters/drivers for D3D10.1 and later, as well as associated feature levels.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Multi-Present

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc0e73a2-802d-435f-96fd-908b05879fc6

Test details
Specifications
  • Device.Graphics.WDDM13.Render.PresentOverheadOptimization
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Multi-Present (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f056713-a7c5-4688-a87f-afaaa750d65a

Test details
Specifications
  • Device.Graphics.WDDM13.Render.PresentOverheadOptimization
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation Rate Testing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/863f74f1-df8e-4de2-9899-da7b6fc6d9b6

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Presentation Rate Testing

  • DXGI Presentation Rate Testing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test runs the following test jobs:

  • DXGI Presentation Rate Testing

  • DXGI Presentation Rate Testing (WoW64)

Command syntax

Command option | Description
DXGIPresentRate FSSequential FSDiscard -whql -logclean | Runs both the DXGI Presentation Rate Testing test job and the DXGI Presentation Rate Testing (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGIPresentRate.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation Rate Testing (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/862e2857-9309-49af-8c09-8eb305da9374

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Presentation Rate Testing

  • DXGI Presentation Rate Testing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test runs the following test jobs:

  • DXGI Presentation Rate Testing

  • DXGI Presentation Rate Testing (WoW64)

Command syntax

Command option | Description
DXGIPresentRate FSSequential FSDiscard -whql -logclean | Runs both the DXGI Presentation Rate Testing test job and the DXGI Presentation Rate Testing (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGIPresentRate.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - FSPresentMS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45c2c5be-26d0-4fc0-a0f3-7149f214f29c

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - FSPresentMS (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27a9cd41-ea37-476d-bf53-6e5d4558af6d

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - Other

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/827e9708-5145-4d2e-99df-f924d0e77ea2

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - Other - multihead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0a7a8fd-d97f-4beb-86aa-b9b26c15fef8

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - Other - multihead (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4bd17e7a-958d-426b-95ff-69a4c6d86f9f

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - Other (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e68651ac-b22c-4f97-ae91-b990e16ff982

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - WinpresentMS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df24aca5-c425-4391-8c10-be29b8b478bf

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Presentation testing - WinpresentMS (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58ef0b51-8dcd-42dc-931f-816c1519665f

This automated test verifies several aspects of the implementation of IDXGISwapChain::Present method.

This topic applies to the following test jobs:

  • DXGI Presentation testing - FSPresentMS

  • DXGI Presentation testing - FSPresentMS (WoW64)

  • DXGI Presentation testing - Other

  • DXGI Presentation testing - Other - multihead

  • DXGI Presentation testing - Other - multihead (WoW64)

  • DXGI Presentation testing - Other (WoW64)

  • DXGI Presentation testing - WinpresentMS

  • DXGI Presentation testing - WinpresentMS (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run the DXGI Presentation testing - Other - multihead or DXGI Presentation testing - Other - multihead (WoW64) test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test creates swap chains, both full-screen and within windows. It also creates back buffers in all supported back buffer formats, by using dimensions that match or differ from those of the output window. Because of this variety, the test comprehensively tests stretching and color-converting Present operations. Full-screen test cases make use of both flip-based and copy-based Present operations.

The test also verifies that the different DirectX Graphics Infrastructure (DXGI) swap effects are implemented correctly. It uses timing-based test cases to verify the correct implementation of presentation intervals.

The test automatically verifies presented images by using the IDXGIOutput::GetDisplaySurfaceData method to retrieve the images. It compares these images with the surfaces that were used to initialize the back buffers.

Command syntax

Command option | Description
DXGIPresent.exe FSPresentMS -whql -logclean | This command runs both the DXGI Presentation testing - FSPresentMS test job and the DXGI Presentation testing - FSPresentMS (WoW64) test job.
DXGIPresent.exe WinPresent WinpresentSmallWindow FSPresent FSpresentRotation FSPresentMulti -whql -logclean | This command runs both the DXGI Presentation testing - Other test job and the DXGI Presentation testing - Other (WoW64) test job.
DXGIPresent.exe WinpresentMS -whql -logclean | This command runs both the DXGI Presentation testing - WinpresentMS test job and the DXGI Presentation testing - WinpresentMS (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIPresent.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Resource Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/655e8cdf-72ba-4937-9ec1-bd70e2a0bed2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Resource Check

  • DXGI Resource Check (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DXGIResChk -whql -logclean | Runs the DXGI Resource Check test job and the DXGI Resource Check (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIResChk.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Resource Check (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92fdbeec-1497-40df-91be-6813960beec7

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Resource Check

  • DXGI Resource Check (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DXGIResChk -whql -logclean | Runs the DXGI Resource Check test job and the DXGI Resource Check (WoW64) test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\ windowstest\graphics\d3d\support</p>
DXGIResChk.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Stereo Present

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f68c6ce8-8518-4def-978d-9d37d2ee14ac

This automated test measures conformance of DXGI Stereo Swapchains, specifically presentation swapchains.

This topic applies to the following test jobs:

  • DXGI Stereo Present

  • DXGI Stereo Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10WDDM12.Stereoscopic3DArraySupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

This test can only be run on configurations that support the Stereo feature. Specifically, this test requires the following software and hardware:

  • A WDDM 1.2 driver

  • A monitor supporting Stereo output through HDMI 1.4

  • Hardware capable of driving a stereo monitor connected through HDMI 1.4

  • A display driver capable of creating and presenting stereo swapchains.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test will always return Pass if stereo presentation is handled correctly. The test will fail if not run on a valid stereo configuration. It is also possible that the Windowed and DComp tests will fail if DWM is not in a stereo mode, even if the machine is capable of displaying stereo content. To review test details, review the test log from the HLK Studio.

More information

This test include test cases that verify specific instances of swapchains:

  • Windowed Swapchains

  • Fullscreen Swapchains

  • DComp Swapchains

Windowed swapchains

These test cases determine conformance of windowed stereo swapchains. It will determine if the expected unique results are presented to each eye from the arrayed swapchain. Temporary mono is tested if the driver claims to support it. Conformance is determined by ensuring that the content for the right eye is not presented. Also for windowed mode, dirty and scroll rects are tested with stereo. The driver should apply the various rects correctly for both the left and right buffers. The test will also cycle on supported display formats.

Fullscreen swapchains

These test cases determine conformance of fullscreen stereo swapchains. The test will cycle on a varied subset of the supported stereo modes. It will determine if the expected unique results are presented to each eye from the arrayed swapchain. Temporary mono is tested if the driver claims to support it. Conformance is determined by ensuring that the content for the right eye is not presented.

DComp swapchains

These test cases determine conformance of windowless presentation of stereo content. It will determine if the expected unique results are presented to each eye from the arrayed swapchain. Temporary mono is tested if the driver claims to support it. Conformance is determined by ensuring that the content for the right eye is not presented. Dirty and scroll rects are tested with stereo. The driver should apply the various rects correctly for both the left and right buffers. The test will also cycle on supported display formats.

Command syntax

Standard command line syntax for WGF11 tests. Nothing unique to this test.

Command option | Description
DXGIStereoPresent | Runs the test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGIStereoPresent.exe | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\api</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Stereo Present (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/545729f0-786a-428f-8d58-48721b4e85b3

This automated test measures conformance of DXGI Stereo Swapchains, specifically presentation swapchains.

This topic applies to the following test jobs:

  • DXGI Stereo Present

  • DXGI Stereo Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10WDDM12.Stereoscopic3DArraySupport
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

This test can only be run on configurations that support the Stereo feature. Specifically, this test requires the following software and hardware:

  • A WDDM 1.2 driver

  • A monitor supporting Stereo output through HDMI 1.4

  • Hardware capable of driving a stereo monitor connected through HDMI 1.4

  • A display driver capable of creating and presenting stereo swapchains.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test will always return Pass if stereo presentation is handled correctly. The test will fail if not run on a valid stereo configuration. It is also possible that the Windowed and DComp tests will fail if DWM is not in a stereo mode, even if the machine is capable of displaying stereo content. To review test details, review the test log from the HLK Studio.

More information

This test include test cases that verify specific instances of swapchains:

  • Windowed Swapchains

  • Fullscreen Swapchains

  • DComp Swapchains

Windowed swapchains

These test cases determine conformance of windowed stereo swapchains. It will determine if the expected unique results are presented to each eye from the arrayed swapchain. Temporary mono is tested if the driver claims to support it. Conformance is determined by ensuring that the content for the right eye is not presented. Also for windowed mode, dirty and scroll rects are tested with stereo. The driver should apply the various rects correctly for both the left and right buffers. The test will also cycle on supported display formats.

Fullscreen swapchains

These test cases determine conformance of fullscreen stereo swapchains. The test will cycle on a varied subset of the supported stereo modes. It will determine if the expected unique results are presented to each eye from the arrayed swapchain. Temporary mono is tested if the driver claims to support it. Conformance is determined by ensuring that the content for the right eye is not presented.

DComp swapchains

These test cases determine conformance of windowless presentation of stereo content. It will determine if the expected unique results are presented to each eye from the arrayed swapchain. Temporary mono is tested if the driver claims to support it. Conformance is determined by ensuring that the content for the right eye is not presented. Dirty and scroll rects are tested with stereo. The driver should apply the various rects correctly for both the left and right buffers. The test will also cycle on supported display formats.

Command syntax

Standard command line syntax for WGF11 tests. Nothing unique to this test.

Command option | Description
DXGIStereoPresent | Runs the test job.
NOTE

For command-line help for this test binary, type /?

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGIStereoPresent.exe | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\api</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Swap Effects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/626c6a16-6b95-4cd6-b360-074d7c48b32c

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Swap Effects

  • DXGI Swap Effects (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DXGISwap.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGISwap.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Swap Effects (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d33a8bb3-05b9-407b-85af-cefcfc40e76e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • DXGI Swap Effects

  • DXGI Swap Effects (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
DXGISwap.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d10sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
DXGISwap.exe | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Trim AutoMemoryBenchmark

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b0fceba-0e8c-4928-b15f-0747b36baaa6

Test details
Specifications
  • Device.Graphics.WDDM13.Render.TrimSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


DXGI Trim Memory

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0729d6a1-ede7-4835-bd96-34427d1a12a8

Test details
Specifications
  • Device.Graphics.WDDM13.Render.TrimSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI Trim Memory (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/412a5ff0-03f3-4a08-92b1-3663503e9ea2

Test details
Specifications
  • Device.Graphics.WDDM13.Render.TrimSupport
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXVA High Definition Video Processing - CreateDevice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5abb0f5-c98c-45ec-853d-9f6293e1878d

This manual test performs multiple test cases targeting IDXVAHD_CreateDevice. It uses several different IDirect3D9DeviceEx interface devices.

The permutations consist of multiple different content descriptions, including (but not limited to) different sizes of content, different frame rates, and different frame formats.

Test performs a few mode changes, but generally just shows incrementing pass or fail counts. It also displays which test case variables are being iterated upon.

The test might return SKIP if the driver does not expose D3DCAPS3_DXVAHD. In some cases it might fail if back buffer format or mode is not supported during D3D device creation.

Test details
Specifications
  • Device.Graphics.WDDM11.Render.DXVAHD.DXVAHD
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software:

  • A display driver that supports D3D9Caps.Caps3 D3DCAPS3_DXVAHD, specifically:

    • D3D9 support exposing D3DCAPS3_DXVAHD

    • Required Output Formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8

    • Required Input Formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8, D3DFMT_YUY2, D3DFMT_AYUV and Any Decode Render targets supported.

  • dxvahdsw.dll.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

DXVAHD_CONTENT_DESC Tested output rates and input rate permutations additional output rates may be added depending on the output device attached.

Tested output rates | Input rates
120Hz | 60p 60i 30p 24p
75Hz | 60p 60i 30p 24p
60Hz | 60p 60i 30p 24p
59Hz | 60p 60i 30p 24p
50Hz | 60p 60i 30p 24p
30Hz | 60p 60i 30p 24p
29Hz | 60p 60i 30p 24p
25Hz | 60p 60i 30p 24p

Verify all permutations of output and input rates. Keep a table of capabilities exposed per rate configuration. Only execute across other test cases on rates that caused the device to expose different capabilities.

Verify correct scaling between input and output frame descriptions. Invalid frame rate rational should default to 0/1, and 0/* should result in 0 rate.

  • InputFrameRate with valid numerator/denominator values

  • InputFrameRate with invalid numerator/denominator values

  • Valid InputFrameRate with matching OutputFrameRate

  • Valid InputFrameRate with different valid OutputFrameRate

  • Valid InputFrameRate with different invalid OutputFrameRate

  • Zeroed out FrameRate values both Input and Output

  • Use a FrameFormat of Interlaced value, and then use progressive content

  • Use a FrameFormat of Progressive value, and then use interlaced content

typedef enum _DXVAHD_DEVICE_USAGE{DXVAHD_DEVICE_USAGE_PLAYBACK_NORMAL = 0,DXVAHD_DEVICE_USAGE_OPTIMAL_SPEED = 1,DXVAHD_DEVICE_USAGE_OPTIMAL_QUALITY = 2} DXVAHD_DEVICE_USAGE;DXVAHD_DEVICE_USAGE

  • Verify output is of higher quality frame DXVAHD_DEVICE_USAGE_OPTIMAL_QUALITY than that of the normal playback usage.

  • Verify optimal performance processes frames more quickly DXVAHD_DEVICE_USAGE_OPTIMAL_SPEED than that of the normal playback usage.

  • Top two cases should prove NORMAL playback is more typical than that of the other two instances.

Verify successful handle to SW Plugin when valid pPlugin is passed and SW VP is available.

Validate on failure that ppDevice is NULL.

Attempt to create multiple devices from separate threads, both with the D3DCREATE_MULTITHREADED D3D9Ex Device and without.

Command syntax

Command option | Description
DXVAHDVideoProcessing CreateDevice | Without any options, the test enumerates all but some extreme invalid argument test cases.
TestPriority:[0, 1, 2] | By default, tests at a priority 1 level; however, priority 2 will test every permutation, including extreme invalid arg test cases. 0 is for BVT level.
SoftwareOnly | Tests only the software implementation of the video processor. This was mainly used for initial testing before drivers supported the test cases.
SaveAllFrames | The test has a hard-coded save count of invalid frames set to 100. If you want all of them saved, then use this flag. Good for high frame count test case failures.
LogLevel:[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default level 0 is set, however; level one will gather increased logging info per test cases including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states as well as any configuration information.

File list

File | Location
DXVAHDVideoProcessing.exe | [testbinroot]\nttest\windowstest\graphics\d3d\func</p>
Dxvahdsw.dll | [osbinroot]\nttest\windowstest\graphics\dxva</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
MODIFIEDCMDLINE | Additional command line arguments for test executable


DXVA High Definition Video Processing - CreateVideoProcessor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5ef33d87-7094-410b-8d76-dabbb6dbfd9f

This manual test runs test cases across the following: IDXVAHD_Device::GetVideoProcessorCaps, IDXVAHD_Device::GetVideoProcessorCustomRates, IDXVAHD_Device::GetVideoProcessorFilterRange, IDXVAHD_Device::CreateVideoProcessor.

This test will, for the most part, show a ticker-like window incrementing pass fail counts and showing which test case variables are being iterated upon. The test might return SKIP if the driver does not expose D3DCAPS3_DXVAHD. In some cases, it might skip if another device is not available to query other VP GUIDs from.

For both valid and invalid calls to the API entry points, verify that the proper return values match up to those exposed by the capabilities. Also confirm the ability to create a video processor successfully. If the VP GUID is invalid, the test should return a FAIL.

Test details
Specifications
  • Device.Graphics.WDDM11.Render.DXVAHD.DXVAHD
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software:

  • A display driver that supports D3D9Caps.Caps3 D3DCAPS3_DXVAHD. Specifically:

    • D3D9 support exposing D3DCAPS3_DXVAHD.

    • Required output formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8.

    • Required input formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8, D3DFMT_YUY2, D3DFMT_AYUV and any decode render targets supported.

  • dxvahdsw.dll.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test verifies the following requirements:

  • IDXVAHD_Device::GetVideoProcessorCaps

    • Use a valid number of video processors from DXVAHD_VPDEVCAPS.VideoProcessorCount.

    • Use both a number less than the video processors count and a number greater than video processors Count verify result is E_INVALIDARG.

    • Validate pCaps is empty on failure.

    • Verify VPGUID for given device works successfully with GetVideoProcessorCustomRates.

    • Verify CustomRateCount corresponds and works properly with GetVideoProcessorCustomRates.

    • Verify that PastFrames and FutureFrames (Counts) work accordingly with DXVAHD_STREAM_DATA expected counts.

  • IDXVAHD_Device::GetVideoProcessorCustomRates

    • With the valid video processor GUID for this device, then a valid GUID from another DXVAHD Device if another device can be found with a different GUID.

    • With an invalid zeroed out GUID.

    • Verify pRates is successfully filled when valid pVPGUID and Count are used.

    • Use both a number less than the DXVAHD_VPCAPS.CustomRateCount and a number greater than DXVAHD_VPCAPS.CustomRateCount. Both should result in E_INVALIDARG.

    • Validate pRates is empty on failure.

  • IDXVAHD_Device::GetVideoProcessorFilterRange

    • Iterate over all filters, validating for any failures that pRange is NULL.

    • Out of range filter value and validate E_INVALIDARG.

    • Verify Empty pRange on failure.

    • Verify maximum value is greater than minimum.

    • Verify the default value is within minimum and maximum values.

  • IDXVAHD_Device::CreateVideoProcessor

    • With the valid video processor GUID for this device, then a valid GUID from another DXVAHD Device if another device can be found with a different GUID.

    • With an invalid zeroed out GUID.

    • Verify ppVideoProcessor is NULL upon any failures.

Command syntax

Command option | Description
DXVAHDVideoProcessing CreateVideoProcessor | Without any options, the test enumerates all but some extreme invalid argument test cases.
TestPriority:[0, 1, 2] | By default, tests at a priority 1 level; however, priority 2 will test every permutation, including extreme invalid arg test cases. 0 is for BVT level.
SoftwareOnly | Tests only the software implementation of the video processor. This was mainly used for initial testing before drivers supported the test cases.
SaveAllFrames | The test has hard coded save count of invalid frames set to 100. I you want all of them saved, then use this flag. Good for high frame count test case failures.
LogLevel:[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default level 0 is set, however; level one will gather increased logging info per test cases, including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states, as well as any configuration information.

File list

File | Location
DXVAHDVideoProcessing.exe | [testbinroot]\nttest\windowstest\graphics\d3d\func</p>
Dxvahdsw.dll | [osbinroot]\nttest\windowstest\graphics\dxva</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
MODIFIEDCMDLINE | Additional command line arguments for test executable


DXVA High Definition Video Processing - CreateVideoSurface

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f95fdd52-0d5f-4cec-bb69-14be44a6412c

This automated test calls the GetVideoProcessorDeviceCaps. Then, using those caps, it generates multiple test cases based on a default memory pool width size of the content from the generated dxvahd device.

The test case also checks the supported input and output formats of each device. It verifies that a surface can be created for each input and output surface, and confirms that unknown formats fail. The test case also verifies creation of multiple surfaces for each format as well.

Test will for the most part just show a ticker like window incrementing pass fail counts and showing which test case variables are being iterated upon.

The test might return SKIP if the driver does not expose D3DCAPS3_DXVAHD. In some cases, it might skip if certain surface formats are not-supported.

Test details
Specifications
  • Device.Graphics.WDDM11.Render.DXVAHD.DXVAHD
  • Device.Graphics.AdapterRender.YUVSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software:

  • A display driver that supports D3D9Caps.Caps3 D3DCAPS3_DXVAHD, specifically:

    • D3D9 support exposing D3DCAPS3_DXVAHD.

    • Required Output Formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8.

    • Required Input Formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8, D3DFMT_YUY2, D3DFMT_AYUV and Any Decode Render targets supported.

  • dxvahdsw.dll.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test verifies the following requirements:

  • Verify Success with valid pointer to DXVAHD_VPDEVCAPS.

    • Verify OutputFormat and InputFormat Counts are correct and function properly with associated get routines.

    • Verify VideoProcessorCount correctly maps to number of video processors.

    • Verify MaxInputStreams greater than zero.

    • Verify MaxStreamStates greater than zero.

  • Verify success when DXVAHD_VPDEVCAPS.InputFormatCount is used.

  • Verify failure when less than and greater than InputFormatCount is used.

  • Verify that D3DFMT_X8R8G8B8 is supported.

  • Verify success when DXVAHD_VPDEVCAPS.InputFormatCount is used.

  • Verify failure when less than and greater than InputFormatCount is used.

  • Verify that D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8, D3DFMT_YUY2, and AYUV (FourCC) are reported as supported.

  • Verify that all decode render target formats report as supported as well.

  • Create Surface with Width Height that of the content description input width height.

  • Create Surface with Width Height different both larger and smaller of the content description input width height.

  • Create Surface with D3DPOOL type from DXVAHD_VPDEVCAPS.InputPool. Then with a different InputPool, verify during Processing VPBltHD returns E_INVALIDCALL.

  • Verify any usage value other than 0 results in return value (E_INVALIDARG).

  • Create a surface of DXVAHD_SURFACE_TYPE_VIDEO_INPUT, and attempt to manipulate it some way with D3D9 API. Validate success. (Off-screen plain.)

    • Iterate over all supported input D3D formats obtained by IDXVAHD_Device::GetVideoProcessorInputFormats. Then check an unsupported D3D format.

  • Create a surface of DXVAHD_SURFACE_TYPE_VIDEO_INPUT_PRIVATE. Confirm that manipulation of it through the D3D 9 API fails. (Off-screen plain.)

    • Iterate over all supported input D3D formats obtained by IDXVAHD_Device::GetVideoProcessorInputFormats. Then check an unsupported D3D format.

  • Create a surface of DXVAHD_SURFACE_TYPE_VIDEO_OUTPUT, and validate as a render target.

    • Iterate over all supported input D3D formats obtained by IDXVAHD_Device::GetVideoProcessorOutputFormats. Then check an unsupported D3D format.

  • Attempt to create a single surface, and then verify ppSurfaces only contains one surface.

  • Create multiple surfaces, and verify the number of surfaces equals the number of surfaces represented by NumSurfaces passed.

  • Confirm that ppSurfaces that fail are NULL.

Command syntax

Command option | Description
DXVAHDVideoProcessing CreateVideoSurface | Without any options, the test enumerates all but some extreme invalid argument test cases.
TestPriority:[0, 1, 2] | By default, tests at a priority 1 level; however, priority 2 will test every permutation, including extreme invalid argument test cases. 0 is for BVT level.
SoftwareOnly | Tests only the software implementation of the video processor. This was mainly used for initial testing before drivers supported the test cases.
SaveAllFrames | The test has hard coded save count of invalid frames set to 100. I you want all of them saved, then use this flag. Good for high frame count test case failures.
LogLevel:[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default level 0 is set, however; level one will gather increased logging info per test cases, including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states, as well as any configuration information.

File list

File | Location
DXVAHDVideoProcessing.exe | [testbinroot]\nttest\windowstest\graphics\d3d\func</p>
Dxvahdsw.dll | [osbinroot]\nttest\windowstest\graphics\dxva</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
MODIFIEDCMDLINE | Additional command line arguments for test executable


DXVA High Definition Video Processing - VideoProcessing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c6a3818b-a9ea-4d9b-8682-f66cb57b3aee

This manual test runs test cases across the following: IDXVAHD_VideoProcessor::SetVideoProcessBltState, IDXVAHD_VideoProcessor::GetVideoProcessBltState, IDXVAHD_VideoProcessor::SetVideoProcessStreamState, IDXVAHD_VideoProcessor::GetVideoProcessStreamState, and IDXVAHD_VideoProcessor::VideoProcessBltHD.

For details about all of the test cases, see the "Supporting information" section below. Most test cases present to the screen while a utility post-processes the frames for comparison. Most test cases enforce a > 20.0f PSNR between software and hardware processed frames. For some test cases, the threshold is lowered due to lack of support of some filters and features in the software implementation.

The test will for the most part just show a ticker-like window incrementing pass fail counts and showing which test case variables are being iterated upon.

Test details
Specifications
  • Device.Graphics.WDDM11.Render.DXVAHD.DXVAHD
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software:

  • A display driver that supports D3D9Caps.Caps3 D3DCAPS3_DXVAHD. Specifically:

    • D3D9 support exposing D3DCAPS3_DXVAHD.

    • Required output formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8.

    • Required input formats: D3DFMT_X8R8G8B8, D3DFMT_A8R8G8B8, D3DFMT_YUY2, D3DFMT_AYUV and any decode render targets supported.

  • dxvahdsw.dll.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test will for the most part just show a ticker-like window incrementing pass fail counts and showing which test case variables are being iterated upon.

The test will return Pass or Fail. The test might return SKIP if the driver does not expose D3DCAPS3_DXVAHD. Other test cases can skip based on stream state support, inverse telecine caps, filter caps, feature caps, and formats supported. To review test details, review the test log from the DTM Studio.

More information

After each SetVideoProcessBltState, call the corresponding GetVideoProcessBltState. The call ensures proper reporting, then processes and presents frames compared to the reference frames for accuracy. Most BltStates are cycled across for each full cycle of a given BltState, then again for each valid StreamState. However, some permutations are not necessary.

  • Verify invalid data types passed to SetVideoProcessBltState and GetVideoProcessBltState return E_INVALIDARG.

  • DXVAHD_BLT_STATE_TARGET_RECT_DATA

    • Verify Limiting Data to rect smaller than output surface results in correct scaling.

    • Verify a rect larger than the output surface results in an expanded frame.

    • Verify when target rect data is set and Enable flagged as false, that the entire surface is used.

    • Process one frame with target rect data and Enable set to false. Then process another frame with target rect data shrunken, expanded, or moved, and Enable is true. Verify the surface scales or moves accordingly.

    • Verify Default no data set results in entire surface being used.

  • DXVAHD_BLT_STATE_BACKGROUND_COLOR_DATA

    • Verify Default is RGB Black.

    • If YCbCr is set to true, verify correct color range for background is actually presented.

    • Verify RGB Orange (255,165, 0) along with default black value with alpha values for both RGB and YcbCr

    • with DXVAHD_BLT_STATE_OUTPUT_COLOR_SPACE_DATA

      • Verify that if Background Color of YCbCr is used and ColorSpaceData is of Full RGB_Range, that Full range RGB is ignored and the correct limited range is used per the specified Matrix and xvYCC setting.

    • with DXVAHD_BLT_STATE_ALPHA_FILL

      • Verify the alpha value of given background color when DXVAHD_ALPHA_FILL_MODE_BACKGROUND is used across different background colors.

  • DXVAHD_BLT_STATE_OUTPUT_COLOR_SPACE_DATA

    • Verify Default Usage, RGB_Range, YCbCr_Matrix, and YCbCr_xvYCC are all set to 0.

    • Verify Limiting RGB_Range successfully limits color range to 16..235.

    • Verify BT.709 correctly increases luma and chroma accordingly.

    • xvYCC successfully extends color range. This validation is a special case, because the reference video processor does not support any output surface other than XRGB. Validation of this is difficult, and the process will be documented at a later time.

    • Verify if DXVAHD_VPDEVCAPS.DeviceCaps does not have DXVAHD_DEVICE_CAPS_xvYCC. Validate YCbCr_xvYCC does not adjust any settings, and is truly ignored.

    • Tolerance is flexible initially, but the starting percentage of pixel precision is 90 percent accuracy.

  • DXVAHD_BLT_STATE_ALPHA_FILL_DATA

    • Verify that output surfaces not of Alpha format are unchanged.

    • Verify that output surfaces of Alpha format successfully apply alpha values to the color.

    • Verify default Mode adjusts Background Alpha values correctly.

      Test Input Surface of NonAlpha Format with an output surface of Alpha Format. Validate alpha correctness with again flexible precision, initially at 90 percent accuracy.

  • DXVAHD_BLT_STATE_CONSTRICTION_DATA

    • Due to lack of support in the Reference driver for the course of M2 constriction, test cases must be validated outside of direct 1:1 comparison for valid down-sampled sizes.

    • Verify correct down-sampling to the output surface.

    • If the size is greater than the target, verify that constriction is limited to the size of the target rect.

    • Attempt to set sizes to 0,* and *, 0 validate return value E_INVALIDARG.

    • If DXVAHD_VPDEVCAPS.FeatureCaps does not expose DXVAHD_FEATURE_CAPS_CONSTRICTION, then verify that error E_INVALIDARG is returned when Constriction is attempted to be set.

    • Verify that Default Value represents disabled. If disabled is flagged and a size is specified, the size value is ignored.

  • DXVAHD_BLT_STATE_PRIVATE_DATA

    • Pass invalid Guid, DataSize, and pData. Validate that driver handles accordingly.

    • Null pData retrieves correct size of the private blt state.

  • Verify invalid data types passed to SetVideoProcessStreamState and GetVideoProcessStreamState return E_INVALIDARG.

  • DXVAHD_STREAM_STATE_D3DFORMAT_DATA

    • Validate all supported formats reported by GetVideoProcessorInputFormats.

    • Validate an unsupported format in GetVideoProcessorInputFormats.

    • Validate default D3DFORMAT is D3DFMT_UNKNOWN.

  • DXVAHD_STREAM_STATE_FRAME_FORMAT_DATA

    • Verify Default value is Progressive.

    • Verify Progressive and Interlaced formats are presented accordingly.

    • If DXVAHD_INPUT_FORMAT_CAPS_RGB_INTERLACED is not reported as supported by DXVAHD_VPDEVCAPS.InputFormatCaps, verify that using DXVAHD_FRAME_FORMAT_INTERLACED_* defaults to using Progressive.

  • DXVAHD_STREAM_STATE_INPUT_COLOR_SPACE_DATA

    • Verify default values.

    • Verify Limiting RGB_Range successfully limits color range to 16..235.

    • If DXVAHD_VPDEVCAPS.InputFormatCaps does not report support for DXVAHD_INPUT_FORMAT_CAPS_RGB_LIMITED_RANGE, verify that when RGB_Range is 1, it is ignored and FullRange is used.

      • Limited range validation is not possible with a 1:1 comparison with the reference. Some loose validation of whites and blacks may be possible to validate the color range has been limited accordingly.

    • Verify BT.709 correctly increases luma and chroma sampling.

    • xvYCC successfully extends color range.

    • Verify that if DXVAHD_VPDEVCAPS.DeviceCaps does not report support for xvYCC.

    • If possible, and if processing is specified, validate increased color conversion performance.

    • Verify if DXVAHD_VPDEVCAPS.DeviceCaps does not have DXVAHD_DEVICE_CAPS_xvYCC. Validate YCbCr_xvYCC does not adjust any settings, and is truly ignored.

  • DXVAHD_STREAM_STATE_OUTPUT_RATE_DATA

    • Test and validate default values (specifically interpolation occurs).

    • Test both NormalRate and HalfRate, verifying that NormalRate is 2:1 interlaced to progressive, and HalfRate is 1:1 interlaced to progressive.

    • Verify all CustomRates if GetVideoProcessorCustomRates exposes any.

      • Specify Inverse Telecine Rates

        • ITELECINE support will not be available in the reference video processor, so direct comparison is impossible. For validation, a telecine frame is generated and passed to the reference. Then the non-telecine frame is processed and compared to that of the frames provided by the telecine frame.

    • Test unsupported CustomRate, both interpolated and repeated.

    • Test unsupported CustomRate at both NormalRate and HalfRate. Verify that error E_INVALIDARG is returned.

    • Validate that supported CustomRates are not successfully set unless DXVAHD_OUTPUT_RATE_CUSTOM is specified.

  • DXVAHD_STREAM_STATE_SOURCE_RECT_DATA

    • Verify Limiting Data to rect smaller than input surface results in correct scaling.

    • Verify a rect larger than the input surface results in the clipped areas being transparent.

    • Verify when source rect data is set and Enable flagged as false, the entire surface is used.

    • Once one frame is processed with source rect data and Enable is false, then a second frame is processed with source rect data and Enable is true, verify that the surface is visible and scales according to the rect size to the input surface.

    • Verify Default no data set results in entire surface being used.

  • DXVAHD_STREAM_STATE_DESTINATION_RECT_DATA

    • Verify Limiting Data to rect smaller than output surface results in correct scaling.

    • Verify a rect larger than the output surface results in the clipped areas being clipped.

    • Verify when destination rect data is set and Enable flagged as false, the entire surface is used.

    • Once one frame is processed with destination rect data and Enable is false, then a second frame is processed with destination rect data and Enable is true, verify that the output surface is visible and scales according to the rect size to the output surface.

    • Verify Default no data set results in entire surface being used.

  • DXVAHD_STREAM_STATE_ALPHA_DATA

    • All Alpha test cases require more than one video stream, therefore multiplying these test cases by two.

    • Verify default values alpha is disabled.

    • Verify Low, Mid, and High range alpha blending, and verify transparency.

    • Verify out of range float alpha value fails during processing.

    • Tolerance level for pixel precision is 10 percent. Precision should be greater than or equal to 90 percent accuracy.

  • DXVAHD_STREAM_STATE_PALETTE_DATA

    • With no palette entries set, validate that Null value returns zero.

    • With a specific number of palette entries set, validate that Null value returns the expected number of palette entries.

    • Test both 4-bit and 8-bit palletized fourCC formats.

    • Set both ARGB and AYUV mixed array of palette entries validate success.

    • Verify correct blending occurs when used with alpha blending.

    • Tolerance level for pixel precision is 10 percent. Precision should be greater than or equal to 90 percent accuracy.

  • DXVAHD_STREAM_STATE_CLEAR_RECT_DATA

    • If DXVAHD_VPDEVCAPS. FeatureCaps does not expose DXVAHD_FEATURE_CAPS_CLEAR_RECT, verify error E_INVALIDARG is returned when an attempt to use ClearRects occurs.

    • Verify Default CLEAR RECT State is disabled and not visible.

    • Verify CLEAR_RECT Outside the destrect is not visible.

    • Verify CLEAR_RECT Outside the destrect is successfully clipped.

  • DXVAHD_STREAM_STATE_LUMA_KEY_DATA

    • If DXVAHD_VPDEVCAPS. FeatureCaps does not expose DXVAHD_FEATURE_CAPS_LUMA_KEY, verify error E_INVALIDARG is returned.

    • When RGB input stream is used, and DXVAHD_VPDEVCAPS. FeatureCaps does not expose DXVAHD_FEATURE_CAPS_RGB_LUMA_KEY, verify that no luma is ignored.

    • Verify if Enable is set to false, luma is ignored.

    • Verify out-of-range values for lower and upper results in failure during Set state (E_INVALIDARG).

    • Verify default is Luma disabled, and values for Lower/Upper are 0.

    • Tolerance level for pixel precision is 10 percent. Precision should be greater than or equal to 90 percent accuracy.

  • DXVAHD_STREAM_STATE_FILTER_DATA

    • Verify default values (Disabled and DXVAHD_FILTER_RANGE_DATA.Default).

    • Verify when Enabled and Level is Default that presented stream is the same as when the filter is enabled.

    • Verify Level less than and greater than GetVideoProcessorFilterRange reported. Greater than should fail with E_INVALIDARG.

    • Tolerance level for pixel precision is 10 percent. Precision should be greater than or equal to 90 percent accuracy.

  • DXVAHD_STREAM_STATE_PRIVATE_DATA

    • Pass invalid Guid, DataSize, and pData. Validate that driver handles accordingly.

    • Null pData retrieves correct size of the private blt state.

Verify VideoProcessBltHD to pOutputSurface of surface types below are successful.

  • Default Surface used will be a swap chain.

  • DXVAHD_SURFACE_TYPE_VIDEO_OUTPUT

  • RENDERTARGET

  • An Overlay swap chain.

  • Swap chains of all other types.

  • Standard supported output and input surface pixel formats, as well as output and input surface formats reported as supported for the given device.

Verify an OutputFrame value of 1 or higher, before frame 0 has been processed, results in E_INVALIDARG.

Validate Processing of OutputFrame 0 twice in a row, without any stream data changes, results in a paused frame.

Validate Processing of OutputFrame 0 twice, with stream data changes, still results in the cached data being presented (paused frame).

Verify Processing of Max, Mid, and Min Number of streams is successful.

Verify StreamCount Greater than or Less than the number of pStreams results in E_INVALIDARG.

Verify StreamCount of zero results in E_INVALIDARG.

DXVAHD_STREAM_DATA: Progressive normal/half rate, Progressive at 2/1, Interlaced at normal rate, Interlaced at half rate, Interlaced at 4/5

  • Enable one stream verify presented contents.

  • Two streams, main stream enabled with sub-stream disabled. Verify presented contents.

  • Two streams, main stream and sub-stream enabled. Verify presented contents.

  • Three streams, two streams used to compose main stream both enabled, and the third stream as the sub-stream disabled. Verify presented content.

  • Three streams, two streams used to compose main stream one enabled one disabled, and the third stream as the sub-stream disabled. Verify presented content.

  • Three streams, two streams used to compose main stream both enabled, and the third stream as the sub-stream enabled as well. Verify presented content.

  • Three streams, two streams used to compose main stream one enabled one disabled, and a third stream as the sub-stream enabled. Verify presented content.

  • Out-of-range PastFrames and FutureFrames.

  • Invalid PastFrames and FutureFrames, according to given PastSurfaces and FutureSurfaces.

  • Null PastSurfaces and FutureSurfaces, with non-zero PastFrames with FutureFrames.

  • All permutations of DXVAHD_SURFACE_TYPE_VIDEO_INPUT, DXVAHD_SURFACE_TYPE_VIDEO_INPUT_PRIVATE, Decode RenderTarget, and an off-screen plain surface across ppPastSurfaces, pInputSurfaces, ppFutureSurfaces.

  • Validate that ppPastSurfaces, pInputSurfaces, ppFutureSurfaces of an unsupported SurfaceType returns E_INVALIDARG.

  • Validate Surfaces allocated to memory pool of type other than DXVAHD_VPDEVCAPS.InputPool results in E_INVALIDARG.

Command syntax

Command option | Description
DXVAHDVideoProcessing VideoProcessing | Without any options, the test enumerates all but some extreme invalid argument test cases.
TestPriority:[0, 1, 2] | By default tests at a priority 1 level however priority 2 will test every permutation including extreme invalid argument test cases. 0 is for BVT level.
SoftwareOnly | Tests only the software implementation of the video processor. This was mainly used for initial testing before drivers supported the test cases.
SaveAllFrames | The test has hard coded save count of invalid frames set to 100 if you want all of them saved then use this flag. Good for high frame count test case failures.
LogLevel:[0, 1, 2] | The test has the ability to be very verbose in its logging methods. By default level 0 is set however level one will gather increased logging info per test cases including many stream states/blt states set. Level 2 will gather all adjusted stream states and blt states as well as any configuration information.

File list

File | Location
DXVAHDVideoProcessing.exe | [testbinroot]\nttest\windowstest\graphics\d3d\func</p>
Dxvahdsw.dll | [osbinroot]\nttest\windowstest\graphics\dxva</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
MODIFIEDCMDLINE | Additional command line arguments for test executable


Dynamic Resources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3485ad7-1aac-4cae-867b-29ef6959bf51

This automated test creates dynamic resources (vertex buffers, index buffers, and textures), and uses them with various lock flags.

This test renders an image, and compares pixels in the source image to an image that the Microsoft® Direct3D® reference (software rasterizer) creates. The test uses the comparison to verify that none of the buffers were dropped while locked.

This topic applies to the following test jobs:

  • Dynamic Resources

  • Dynamic Resources (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Dynamicresources -M:1 -dx9 -whql -logclean | This command runs the Dynamic Resources test job.
Dynamicresources -M:1 -whql -logclean | This command runs the Dynamic Resources (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Dynamicresources.exe | <[testbinroot]>\nttest
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Dynamic Resources (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9cf03c3e-4e70-4bc3-9e05-a3daf5b354b0

This automated test creates dynamic resources (vertex buffers, index buffers, and textures), and uses them with various lock flags.

This test renders an image, and compares pixels in the source image to an image that the Microsoft® Direct3D® reference (software rasterizer) creates. The test uses the comparison to verify that none of the buffers were dropped while locked.

This topic applies to the following test jobs:

  • Dynamic Resources

  • Dynamic Resources (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Dynamicresources -M:1 -dx9 -whql -logclean | This command runs the Dynamic Resources test job.
Dynamicresources -M:1 -whql -logclean | This command runs the Dynamic Resources (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Dynamicresources.exe | <[testbinroot]>\nttest
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Fill Modes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62bed444-5ccc-4737-b778-7e744cde304f

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Fill Modes

  • Fill Modes (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Fillmode -M:1 -dx9 -whql -logclean | Runs the Fill Modes Test test job.
Fillmode -M:1 -whql -logclean | Runs the Fill Modes Test (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fillmode.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Fill Modes (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a7912f2-ae75-49a0-8985-ac7856fad7be

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Fill Modes

  • Fill Modes (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Fillmode -M:1 -dx9 -whql -logclean | Runs the Fill Modes Test test job.
Fillmode -M:1 -whql -logclean | Runs the Fill Modes Test (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fillmode.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Four Character Code Surface Stability Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e108dad-b2ef-4fa5-8ffc-c0e98bbebfc4

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
  • Device.Graphics.XDDM.Stability
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
FourCC.exe -!fpucheck -M:[Monitor] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
FourCC.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\stress</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Functional test for monitor container ID

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f657caa-368c-4531-8cec-8faf475125f4

This automated test applies SetupAPI functions to retrieve the monitor containerId and check the consistency of those after reboot. The ones achieved from monitor EDID and ELD info from audio devices are also used for verification.

Test details
Specifications
  • Device.Graphics.WDDM12.Display.ContainerIDSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


Gamma Correction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ecb0b09-40de-4ba9-ab76-1a3941eb21d9

This automated test verifies D3D9 SRGB Texture Read/Write features (specifically the Sampler state: D3DSAMP_SRGBTEXTUREand the Render State: D3DRS_SRGBWRITEENABLE).

This topic applies to the following test jobs:

  • Gamma Correction

  • Gamma Correction (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.Display.GammaCorrection
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gammacorrect -M:[Monitor] | Runs the test job.
NOTE

For command line help for this test binary, type /?h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Gammacorrect.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Gamma Correction (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3b0e551-a429-4f04-a457-8386ed5b5269

This automated test verifies D3D9 SRGB Texture Read/Write features (specifically the Sampler state: D3DSAMP_SRGBTEXTUREand the Render State: D3DRS_SRGBWRITEENABLE).

This topic applies to the following test jobs:

  • Gamma Correction

  • Gamma Correction (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.Display.GammaCorrection
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gammacorrect -M:[Monitor] | Runs the test job.
NOTE

For command line help for this test binary, type /?h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Gammacorrect.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GDIHW_Functional test for GDI HW ACC (v1.1)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47737217-dcac-431e-9a09-6f7bb398950c

This automated test checks that if graphic adapter or chipset is using a WDDM 1.1 driver, that if device bitmaps are enabled and GDI HW ACC is appled; then test cases for verifying the new code paths for GDI HW ACC are executed.

This topic applies to the following test jobs:

  • GDIHW_Functional test for GDI HW ACC (v1.1)

  • GDIHW_Functional test for GDI HW ACC (v1.1) (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gditest_hw.exe -tolerance -clipping -all | This command runs both the GDIHW_Functional test for GDI HW ACC (v1.1) and the GDIHW_Functional test for GDI HW ACC (v1.1) (WoW64) test jobs.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Gditest_hw.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Domain User who is local admin
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GDIHW_Functional test for GDI HW ACC (v1.1) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/609268ec-baa9-4694-97d6-a24d90659400

This automated test checks that if graphic adapter or chipset is using a WDDM 1.1 driver, that if device bitmaps are enabled and GDI HW ACC is appled; then test cases for verifying the new code paths for GDI HW ACC are executed.

This topic applies to the following test jobs:

  • GDIHW_Functional test for GDI HW ACC (v1.1)

  • GDIHW_Functional test for GDI HW ACC (v1.1) (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gditest_hw.exe -tolerance -clipping -all | This command runs both the GDIHW_Functional test for GDI HW ACC (v1.1) and the GDIHW_Functional test for GDI HW ACC (v1.1) (WoW64) test jobs.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Gditest_hw.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Geometry Instancing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d9426834-a451-442b-b07c-0566de595373

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Geometry Instancing

  • Geometry Instancing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Instancing -M:1 -dx9 -whql -logclean | This command runs the Geometry Instancing test job.
Instancing -M:1 -whql -logclean | This command runs the Geometry Instancing (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Instancing.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Geometry Instancing (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a93f13e3-1ed6-4128-b55b-33c110da93e6

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Geometry Instancing

  • Geometry Instancing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Instancing -M:1 -dx9 -whql -logclean | This command runs the Geometry Instancing test job.
Instancing -M:1 -whql -logclean | This command runs the Geometry Instancing (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Instancing.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Get DC

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c667be94-806f-4d45-91a5-b36296dd9300

This automated test verifies that a graphics adapter of chipset implements the minimum hardware acceleration capabilities as described in the requirements document.

This topic applies to the following test jobs:

  • Get DC

  • Get DC (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Getdc.exe -M:1 -dx9 -whql -logclean | This command runs the Get DC test job.
Getdc.exe -M:1 -whql -logclean | This command runs the Get DC (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Getdc.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Get DC (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bf384798-0cd3-4f3e-b511-2663d7e19b5f

This automated test verifies that a graphics adapter of chipset implements the minimum hardware acceleration capabilities as described in the requirements document.

This topic applies to the following test jobs:

  • Get DC

  • Get DC (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Getdc.exe -M:1 -dx9 -whql -logclean | This command runs the Get DC test job.
Getdc.exe -M:1 -whql -logclean | This command runs the Get DC (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Getdc.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetInfo (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85e6c55c-0498-4c2d-a4a3-a3d851e0456f

This automated test verifies that the graphics adapter or chipset implements the minimum hardware acceleration capabilities as specified.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Trek -model:cube -!antialias -invalid -winmode:win -!ref -!sw -M:1 -whql -logclean | Runs the GetInfo (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Trek.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetRasterStatus

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/04a487ca-028c-4fdd-942d-1f7ed99ced73

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • GetRasterStatus

  • GetRasterStatus (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
GetRStat -M:1 -dx9 -whql -logclean | Runs the GetRasterStatus test job.
GetRStat -M:1 -whql -logclean | Runs the GetRasterStatus (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
GetRStat.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetRasterStatus (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2d0d120-b2fb-4d75-8607-3180e34ead7c

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • GetRasterStatus

  • GetRasterStatus (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
GetRStat -M:1 -dx9 -whql -logclean | Runs the GetRasterStatus test job.
GetRStat -M:1 -whql -logclean | Runs the GetRasterStatus (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
GetRStat.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetRenderTargetData - Backbuffer and Render Target

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a775ab96-e85f-4d25-a82b-f74cea95f953

This automated test verifies that the IDirect3DDevice9::GetRenderTargetData method in Microsoft® Direct3D® 9 can be used to extract the contents of back buffers and basic render targets.

The test first creates the source and destination surfaces. The test then cycles through various surface formats and usage specifications. If either surface cannot be created, that configuration is skipped. After the surfaces are created, the render-target surface is filled with a textured quad. Next, the source is copied to the destination with the GetRenderTargetData method, and a surface comparison is performed to verify that the two surface contents are the same.

This topic applies to the following test jobs:

  • GetRenderTargetData - Backbuffer and Render Target

  • GetRenderTargetData - Backbuffer and Render Target (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software and hardware.

  • Microsoft DirectX® 9.0 or later

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

This test validates the functional and operational specifications for the IDirect3DDevice9::GetRenderTargetData method. The GetRenderTargetData method provides a way to copy the contents of a render-target surface to a system-memory surface. There are several restrictions on the source and destination surfaces that you must meet for this copy to succeed:

  • The source surface must be a regular render-target surface, or a specific level of a render-target texture (MIP map or cube texture).

  • The source must be POOL_DEFAULT and D3DMULTISAMPLE_NONE.

  • The destination surface must be either an off-screen plain surface, or a texture (MIP map or cube) that is created with POOL_SYSTEMMEM.

  • The source and destination surfaces must be the same dimension and format.

The following table shows the matrix of surface combinations that this test covers, and the command options that the test uses to select the type of surface.

Surface | Offscreen plain | MIP-map texture | Cube texture
Back buffer | -grtdbb | -grtdbbt | -grtdbbct
Render target | -grtdrt | -grtdrtt | -grtdrtct
MIP-map texture | -grtdts | -grtdtt | -grtdtct
Cube texture | -grtdcts | -grtdctt | -grtdctct

Command syntax

Command option | Description
Getrendertargetdata.exe -grtdbb -grtdbbt -grtdbbct -grtdrt -grtdrt -grtdrtt -grtdrtct -M:1 -dx9 -whql -logclean | Runs the test job, including options for specific surfaces. For more information about which option to use, see the table earlier in this topic.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Getrendertargetdata.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetRenderTargetData - Backbuffer and Render Target (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1bacae00-110d-47d6-afa9-00c3b8c501dd

This automated test verifies that the IDirect3DDevice9::GetRenderTargetData method in Microsoft® Direct3D® 9 can be used to extract the contents of back buffers and basic render targets.

The test first creates the source and destination surfaces. The test then cycles through various surface formats and usage specifications. If either surface cannot be created, that configuration is skipped. After the surfaces are created, the render-target surface is filled with a textured quad. Next, the source is copied to the destination with the GetRenderTargetData method, and a surface comparison is performed to verify that the two surface contents are the same.

This topic applies to the following test jobs:

  • GetRenderTargetData - Backbuffer and Render Target

  • GetRenderTargetData - Backbuffer and Render Target (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software and hardware.

  • Microsoft DirectX® 9.0 or later

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

This test validates the functional and operational specifications for the IDirect3DDevice9::GetRenderTargetData method. The GetRenderTargetData method provides a way to copy the contents of a render-target surface to a system-memory surface. There are several restrictions on the source and destination surfaces that you must meet for this copy to succeed:

  • The source surface must be a regular render-target surface, or a specific level of a render-target texture (MIP map or cube texture).

  • The source must be POOL_DEFAULT and D3DMULTISAMPLE_NONE.

  • The destination surface must be either an off-screen plain surface, or a texture (MIP map or cube) that is created with POOL_SYSTEMMEM.

  • The source and destination surfaces must be the same dimension and format.

The following table shows the matrix of surface combinations that this test covers, and the command options that the test uses to select the type of surface.

Surface | Offscreen plain | MIP-map texture | Cube texture
Back buffer | -grtdbb | -grtdbbt | -grtdbbct
Render target | -grtdrt | -grtdrtt | -grtdrtct
MIP-map texture | -grtdts | -grtdtt | -grtdtct
Cube texture | -grtdcts | -grtdctt | -grtdctct

Command syntax

Command option | Description
Getrendertargetdata.exe -grtdbb -grtdbbt -grtdbbct -grtdrt -grtdrt -grtdrtt -grtdrtct -M:1 -dx9 -whql -logclean | Runs the test job, including options for specific surfaces. For more information about which option to use, see the table earlier in this topic.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Getrendertargetdata.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetRenderTargetData - Mip Texture and Cube Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e146187-6356-4030-96b5-b555c93fa1fd

This automated test verifies that you can use the IDirect3DDevice9::GetRenderTargetData method (Microsoft Direct3D 9) to extract the contents of Render Target Mipmaps and Cubemaps.

The test first creates the source and destination surfaces. The test cycles through various surface formats and usage specifications. If either surface cannot be created, that configuration is skipped. After the surfaces are created, the render-target surface is filled with a textured quad. Next, the source is copied to the destination with the GetRenderTargetData method and a surface comparison is performed to verify that the two surface contents are the same.

This topic applies to the following test jobs:

  • GetRenderTargetData - Mip Texture and Cube Texture

  • GetRenderTargetData - Mip Texture and Cube Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software and hardware.

  • Microsoft DirectX® 9.0 or later

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test validates the functional and operational specifications for the IDirect3DDevice9::GetRenderTargetData method. The GetRenderTargetData method provides a way to copy the contents of a render-target surface to a system-memory surface. There are several restrictions on the source and destination surfaces that you must meet for this copy to succeed.

  • The source surface must be a regular render-target surface or a specific level of a render-target texture (MIP map or cube texture).

  • The source must be POOL_DEFAULT and D3DMULTISAMPLE_NONE.

  • The destination surface must be either an off-screen plain surface or a texture (MIP map or cube) created with POOL_SYSTEMMEM.

  • The source and destination surfaces must be the same dimension and format.

The following table shows the matrix of surface combinations that this test and the command options that are used to select the type of surface.

Surface | Offscreen plain | MIP-map texture | Cube texture
Back buffer | -grtdbb | -grtdbbt | -grtdbbct
Render target | -grtdrt | -grtdrtt | -grtdrtct
MIP-map texture | -grtdts | -grtdtt | -grtdtct
Cube texture | -grtdcts | -grtdctt | -grtdctct

Command syntax

Command option | Description
Getrendertargetdata.exe -grtdts -grtdtt -grtdtct -grtdcts -grtdctt -grtdctct -M:1 -dx9 -whql -logclean | Runs the test job, including options for specific surfaces. For more information about which option to use, see the table earlier in this topic.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Getrendertargetdata.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


GetRenderTargetData - Mip Texture and Cube Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66d30e83-bbe3-4293-8e1f-de538617fc47

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 40
Category | Compatibility
Timeout (in minutes) | 2400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Graphics Device Runtime Power Management Component Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8fd9f76-7273-4133-a185-ca979886bb45

This automated test will verify the reported power components for device runtime power management (containing correct data or information) as it is relates to each component state reported.

Test details
Specifications
  • Device.Graphics.WDDM12.DisplayRender.RuntimePowerMgmt.RuntimePowerMgmt
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gdpm_ComponentParams | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Gdpm_ComponentParams.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>


Graphics Driver Installation During OS Setup.

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a899432-c2bd-42a7-8afe-1cbebee7aec2

This test verifies that a driver can be injected into an OS image, that it installs during the setup phase of the OS, and is working when the user first boots into the OS during personalization stage. In order to accomplish this the following steps need to be done: 1. Copy an existing build folder to a Windows 8.1 machine. 2. Inject the driver being tested into the image using DISM.exe 3. Enable Test signing in the image file if using test signed drivers. 4. Use the image created to install a test machine. 5. Verify the driver was installed successfully and is working. A dialog prompt requiring user intervention to indicate Pass or Fail will be presented on the HCK client. The script that can be used for creating the OS setup image is located at \\[HCKControllerName]\Tests\amd64\NTTEST\windowstest\tools\InjectDriversToWim.cmd The script takes the following paramerters: First parameter is the path to the location of the build folder. Second parameter is the location of the folder that contains the drivers to be injected. Example: InjectDriversToWim.cmd "c:\Build_9405\Client" "C:\MyDrivers\AMD64" After verifying the script completed successfully installation of the OS can be ran. In the example passed setup.exe contained in the "c:\Build_9405\Client" can be run to install the OS.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.DriverSetupCompatible
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | The name of your machine's LLU
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


H264 multi instance test 400

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2ef5380-4fc1-9ba5-69aa-02902578c13c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Multi Instance DXVA Test: InputType H264 - Multi Instance DXVA Test H264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5a01625-412e-5491-c53f-caad773d59c2

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15ab952a-4f2a-8ef5-0848-89a15f9fb326

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/772f6f99-91a5-47bd-aa21-33f356de7eca

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 12

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45e1cfcf-9c43-453d-9e76-a7622e6fbd43

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 13

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1de081b4-b7a4-45d7-a2df-4f381de99219

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 14

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7973cf0c-4a46-4af4-8dc7-570f629ecb2b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 15

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2f7bf38-616b-449c-8c75-1e4580068f0a

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 16

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab0baa82-6ec0-4b82-b545-f422cddba87e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 17

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2565bee-44f0-4724-b908-5d6b1b9e3a95

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 18

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c96add7b-733e-4324-9ea6-9e808f9db1b0

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 19

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/29aab814-8bfd-4f37-9952-8816441fc98e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9515a60-ca57-4178-92ba-21f47864264d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc8389c1-1644-4696-ad7a-9388407f43d4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/746cdba3-d0a4-4058-b99e-b014af320331

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5614065d-d34f-45a5-989e-37f3c7f6080b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/237c0151-3341-4e0e-ae86-041be6d6fb88

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9201fd89-5532-45d2-9854-761d032b069d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/616d8773-eb79-491e-8edb-a056efab8fb6

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 Playback Test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89fe28e2-5e6d-4ebb-a8ca-b90d92818945

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Decoder H.264 Compliance: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 Direct3D_9 quality test 202

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c82c4794-4afb-7062-89e0-fcb19b189593

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Quality DXVA Test: InputType H264 - H264 Quality

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


H264 stress test 300

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10997168-451f-ccde-a4f6-7c9cc869351d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Stress DXVA Test: InputType H264 - H.264 Stress 15min DXVA Decode of H.264

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCMultiInstanceTest410

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec655496-b230-4e6d-9bc4-8f3983a8d72f

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC multiinstance test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCMultiInstanceTest411

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73d8a2ee-1d0c-42fd-8874-165435eef6dc

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC multiinstance test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCMultiInstanceTest412

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1022ff97-3af1-483c-b068-d24c195a0421

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC multiinstance test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCMultiInstanceTest413

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/626713cc-0a5c-4cd6-9582-e7dd58946731

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC multiinstance test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCMultiInstanceTest414

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e071706-0b78-4ae9-a2ee-ad959078eb03

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC multiinstance test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCMultiInstanceTest415

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cbe14ec3-e33d-4dac-bf30-ce8708f7ba9f

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC multiinstance test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCStressTest310

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/875de39c-fb5d-4950-916d-fe891b287edb

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC Stress test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCStressTest311

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f859c89-553f-42a7-a083-130f1c85f86b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC Stress test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HEVCStressTest312

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f6642b5-c57c-4940-87ab-ea936e1e9f75

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HEVC Stress test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


HeterogeneousRRI - Core Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b987ab8a-90e3-461f-a3fa-3be6d5679796

Testing core heterogeneous RRI capability via multiple input data methods (i.e. clear, draw, dispatch) and faciliating resource rotation.Establish baseline prior to rotation and compare against baseline after rotation.Track and validate resource creation and destruction semantics consistency after rotation.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11WDDM24.eFSE
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


HeterogeneousRRI - IHV Bring-up Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/575df6ee-7223-4fd3-918c-fba4f2f8615f

Testing basic heterogeneous RRI capability by staged resource copy and faciliating resource rotation.Establish baseline prior to rotation and compare against baseline after rotation.Track and validate resource creation and destruction semantics consistency after rotation.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11WDDM24.eFSE
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Index Buffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ad906b5-3900-4338-a936-5893510ffd34

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Index Buffer

  • Index Buffer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Ibuffer -M:1 -dx9 -whql -logclean | This command runs the Index Buffer test job.
Ibuffer -M:1 -whql -logclean | This command runs the Index Buffer (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Ibuffer.exe | <[testbinroot]>\nttest\ </p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Index Buffer (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ed22e21-1201-4dfb-a8c6-9d163744f213

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Index Buffer

  • Index Buffer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Ibuffer -M:1 -dx9 -whql -logclean | This command runs the Index Buffer test job.
Ibuffer -M:1 -whql -logclean | This command runs the Index Buffer (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Ibuffer.exe | <[testbinroot]>\nttest\ </p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Indirect Display inactive path

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b19431b9-32aa-4600-a178-45fdc4931708

Test configurations where Indirect DIsplay paths are inactive

Test details
Specifications
  • Device.Graphics.IndirectDisplay.Wired.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Indirect Display Mode Change

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c2be2fe-06c8-4dcd-ad1e-35a42018d63b

Tests mode changes on the indirect display

Test details
Specifications
  • Device.Graphics.IndirectDisplay.Wired.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Indirect Display Pnp Stop-Start Indirect Display Adapter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9ab8f8b7-7d5f-4cca-bfd6-a768b74cb41b

Test Pnp stop on Indirect Display adapter

Test details
Specifications
  • Device.Graphics.IndirectDisplay.Wired.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Indirect Display Pnp Stop-Start Render Adapter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d499521f-601b-4f93-af60-46cf383302ca

Test Pnp stop on render adapter

Test details
Specifications
  • Device.Graphics.IndirectDisplay.Wired.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Indirect Display render adapter TDR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37cb9a22-5fa4-4f9a-bdb2-e03e4e28b784

Trigger TDR on render adapter and check indirect display adapter correctly recovers

Test details
Specifications
  • Device.Graphics.IndirectDisplay.Wired.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


IoMmu Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd207951-9e31-4eb7-8c44-1166e0926c59

Verifies that WDDM 2.4 drivers support IoMmu isolation

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.IoMmuSupport.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Level9 Instancing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/768062eb-54e2-46ac-a2fe-690902553e55

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Level9WDDM13.Level9Instancing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Level9 Instancing (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e2da4a8-b979-4e15-8d39-9cdb3607ef7d

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Level9WDDM13.Level9Instancing
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05dc750d-07c6-409f-900f-f9f049c7b8e9

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap - Alpha

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cc7e491-9c2b-4485-98a3-fbebccf6290e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap - Alpha (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c71be85-35ba-44da-bf5f-b30d9ce50c22

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap - Factor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16a150f4-13cd-4a71-9e28-7f9712cd72af

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap - Factor (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/013c3c0c-95b8-47b2-9293-4b9a8a517bfd

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap - Stability Mix (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9f3e92b4-cda7-44b0-9d62-7a5bccb090d2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
  • Device.Graphics.XDDM.Stability
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lightmap (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f57ff5d5-6b72-4cd8-bd62-e4487477e3c5

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lightmap

  • Lightmap - Alpha

  • Lightmap - Alpha (WoW64)

  • Lightmap - Factor

  • Lightmap - Factor (WoW64)

  • Lightmap - Stability Mix (WoW64)

  • Lightmap (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lightmap -M:1 -dx9 -whql -logclean | Runs the Lightmap test job.
Lightmap -M:1 -whql -logclean | Runs the Lightmap (WoW64) test job.
Lightmap-intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Alpha test job.
Lightmap -intervals:0 -alpha -M:1 -whql -logclean | Runs the Lightmap - Alpha (WoW64) test job.
Lightmap -intervals:0 -factor -M:1 -dx9 -whql -logclean | Runs the Lightmap - Factor test job.
Lightmap.exe -intervals:0 -factor -M:1 -whql -logclean | Runs the Lightmap - Factor (WoW64) test job.
Lightmap.exe -intervals:0 -mix -M:1 -whql -logclean | Runs the Lightmap - Stability Mix (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lightmap.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Link training on hibernation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b7-85b3-4337-9249-e5ab1efaccd0

check driver reports any HPD due to possible link training during system hibernation and resume.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Link training on monitor power transition

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b5-85b3-4337-9249-e5ab1efaccd0

check driver reports any HPD due to possible link training during monitor power transition.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Link training on physical mode change

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b4-85b3-4337-9249-e5ab1efaccd0

check driver reports any HPD due to possible link training during physical mode change.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Link training on system sleep

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b6-85b3-4337-9249-e5ab1efaccd0

check driver reports any HPD due to possible link training during system sleep and resume.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Link training on virtual mode change

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b3-85b3-4337-9249-e5ab1efaccd0

check driver reports any HPD due to possible link training during virtual mode change.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Lockable Depth Buffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5357fdc4-cd8a-4890-a8be-d49937957dde

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lockable Depth Buffer

  • Lockable Depth Buffer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
LockDpth -M:1 -dx9 -whql -logclean | This test runs the Lockable Depth Buffer test job.
LockDpth -M:1 -whql -logclean | This test runs the Lockable Depth Buffer (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
LockDpth.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lockable Depth Buffer (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cda22c2-4cc2-467e-84f0-282df443c416

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lockable Depth Buffer

  • Lockable Depth Buffer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
LockDpth -M:1 -dx9 -whql -logclean | This test runs the Lockable Depth Buffer test job.
LockDpth -M:1 -whql -logclean | This test runs the Lockable Depth Buffer (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
LockDpth.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lost Devices - Resource Management DX9 w Lost Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c5925cb-8475-4ca2-a591-0fa1cc603eb2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lost Devices - Resource Management DX8 and lower (WoW64)

  • Lost Devices - Resource Management DX9 w Lost Texture

  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9 w-o Lost Texture

  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9.L

  • Lost Devices - Resource Management DX9.L (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Compatibility
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Lostdev -!dx9 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX8 and lower (WoW64) test job.
Lostdev -dx9 -losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture test job.
Lostdev -dx9 -losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture (WoW64) test job.
Lostdev -dx9 -!losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture test job.
Lostdev -dx9 -!losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64) test job.
Lostdev -dx9.1 -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L test job.
Lostdev -dx9.1 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lostdev.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b5defdc-b178-4b8b-a704-0564484d0b0c

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lost Devices - Resource Management DX8 and lower (WoW64)

  • Lost Devices - Resource Management DX9 w Lost Texture

  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9 w-o Lost Texture

  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9.L

  • Lost Devices - Resource Management DX9.L (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Compatibility
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Lostdev -!dx9 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX8 and lower (WoW64) test job.
Lostdev -dx9 -losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture test job.
Lostdev -dx9 -losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture (WoW64) test job.
Lostdev -dx9 -!losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture test job.
Lostdev -dx9 -!losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64) test job.
Lostdev -dx9.1 -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L test job.
Lostdev -dx9.1 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lostdev.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lost Devices - Resource Management DX9 w-o Lost Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6364a1a-01c0-418e-8937-8c7dfe25661d

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lost Devices - Resource Management DX8 and lower (WoW64)

  • Lost Devices - Resource Management DX9 w Lost Texture

  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9 w-o Lost Texture

  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9.L

  • Lost Devices - Resource Management DX9.L (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Lostdev -!dx9 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX8 and lower (WoW64) test job.
Lostdev -dx9 -losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture test job.
Lostdev -dx9 -losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture (WoW64) test job.
Lostdev -dx9 -!losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture test job.
Lostdev -dx9 -!losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64) test job.
Lostdev -dx9.1 -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L test job.
Lostdev -dx9.1 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lostdev.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/65a70ffa-a02c-4975-afb1-c81828b4055b

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lost Devices - Resource Management DX8 and lower (WoW64)

  • Lost Devices - Resource Management DX9 w Lost Texture

  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9 w-o Lost Texture

  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9.L

  • Lost Devices - Resource Management DX9.L (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Lostdev -!dx9 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX8 and lower (WoW64) test job.
Lostdev -dx9 -losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture test job.
Lostdev -dx9 -losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture (WoW64) test job.
Lostdev -dx9 -!losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture test job.
Lostdev -dx9 -!losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64) test job.
Lostdev -dx9.1 -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L test job.
Lostdev -dx9.1 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lostdev.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lost Devices - Resource Management DX9.L

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/750ea5cb-aa9d-4cf2-a42e-b8bebd95762e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lost Devices - Resource Management DX8 and lower (WoW64)

  • Lost Devices - Resource Management DX9 w Lost Texture

  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9 w-o Lost Texture

  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9.L

  • Lost Devices - Resource Management DX9.L (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 13
Category | Compatibility
Timeout (in minutes) | 780
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Lostdev -!dx9 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX8 and lower (WoW64) test job.
Lostdev -dx9 -losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture test job.
Lostdev -dx9 -losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture (WoW64) test job.
Lostdev -dx9 -!losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture test job.
Lostdev -dx9 -!losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64) test job.
Lostdev -dx9.1 -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L test job.
Lostdev -dx9.1 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lostdev.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Lost Devices - Resource Management DX9.L (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9012815-8b5b-4907-8bab-124ae798472c

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Lost Devices - Resource Management DX8 and lower (WoW64)

  • Lost Devices - Resource Management DX9 w Lost Texture

  • Lost Devices - Resource Management DX9 w Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9 w-o Lost Texture

  • Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64)

  • Lost Devices - Resource Management DX9.L

  • Lost Devices - Resource Management DX9.L (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 13
Category | Compatibility
Timeout (in minutes) | 780
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Lostdev -!dx9 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX8 and lower (WoW64) test job.
Lostdev -dx9 -losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture test job.
Lostdev -dx9 -losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w Lost Texture (WoW64) test job.
Lostdev -dx9 -!losttexture -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture test job.
Lostdev -dx9 -!losttexture -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9 w-o Lost Texture (WoW64) test job.
Lostdev -dx9.1 -M:1 -dx9 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L test job.
Lostdev -dx9.1 -M:1 -whql -logclean | This command runs the Lost Devices - Resource Management DX9.L (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Lostdev.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Maximum Primitives

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e272e8f8-aeb0-4f63-a781-6d7f04358cfc

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Maximum Primitives

  • Maximum Primitives (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mvertex -M:1 -dx9 -whql -logclean | This command runs the Maximum Primitives (WoW64) test job.
Mvertex -M:1 -whql -logclean | This command runs the Maximum Primitives (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mvertex.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Maximum Primitives (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/382ad898-1b0e-409a-8e6b-4ab2c7ae86a3

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Maximum Primitives

  • Maximum Primitives (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mvertex -M:1 -dx9 -whql -logclean | This command runs the Maximum Primitives (WoW64) test job.
Mvertex -M:1 -whql -logclean | This command runs the Maximum Primitives (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mvertex.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Memory Leak Verifier (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5589db5f-e28c-476b-9d9a-9f559ecc08a0

This automated test creates and releases numerous resources and checks for memory leaks that are greater than 1 megabyte (MB).

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
  • Device.Graphics.XDDM.Stability
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
MemChecker.exe -M:1 -whql -logclean | Runs the test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
MemChecker.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Memory-Texture Management (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71939f01-c300-4719-bd1c-3ba7a4da722a

This automated test is one of the Microsoft® Direct3D® Video Memory Management Tests.

This test contains test jobs for the following features of Direct3D version 8 and Direct3D version 9:

  • DiscardBytes. The test verifies that the resource manager can free managed video memory through the Direct3D version 8 DiscardBytes function. Tests depend heavily on GetAvailableTextureMemory for verification.

  • Preload. The test verifies that preloading works, by measuring the time it takes to render a scene with preloaded and non-preloaded resources. The preloaded resources should result in a scene that renders more quickly.

  • TexMan. The test verifies that a managed texture can be recycled multiple times per frame. The test reuses a managed texture 9 times within a frame, verifying the image contents between uses. The test validates the final rendered scene.

  • Memman. The test contains a small set of tests for verifying some basic aspects of video memory management. The tests try to consume all available video memory with textures and vertex buffers, verifying that memory is used efficiently and that reported memory is reasonably accurate. Under Direct3D version 8 interfaces, the tests verify that resources are not allocated on top of one another. They write a byte pattern to surfaces that can be monitored to ensure surface integrity.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Memman.exe -M:1 -whql -logclean | Runs the test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Memman.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


MipFilter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce5538ea-540b-4797-b7c4-75fd61151a3a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • MipFilter

  • MipFilter (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mipfilter -M:1 -dx9 -whql -logclean | This command runs the MipFilter test job.
Mipfilter -M:1 -whql -logclean | This command runs the MipFilter (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mipfilter.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


MipFilter (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/acbdb9fe-b3c4-4cde-8207-e0a188e62287

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • MipFilter

  • MipFilter (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mipfilter -M:1 -dx9 -whql -logclean | This command runs the MipFilter test job.
Mipfilter -M:1 -whql -logclean | This command runs the MipFilter (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mipfilter.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Monitor ACPI _PLD (Physical Device Location)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600982b9-85b3-4337-9249-e5ab1efaccd0

verify ACPI namespace object _PLD for monitors are correct.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | manual

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


MoveTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d0c5336-5b63-4518-8828-5ab96f6f7d3e

Moves a variety of allocations around the segment and validates their content is preserved

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


MPEG2 fuzz test 107

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/051c9f56-4742-fe53-7a6d-e88d0f37a953

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Fuzz DXVA Test: InputType MPEG2 - MPEG2 Fuzzing Test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 fuzz test 108

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aa96b905-4f0f-05e5-0097-ffaa3669ac75

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Fuzz DXVA Test: InputType M2V - MPEG2 Fuzzing Test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 fuzz test 109

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5aa2a021-488a-15ca-553e-bd8bbf9cba27

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Fuzz DXVA Test: InputType M2V - MPEG2 Fuzzing Test

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Multi-Instance test 403

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9b0959e-6139-4c6f-9ace-50af1f0da4b7

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Multi-Instance DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 20

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f466b676-491e-ca33-bf31-0aa6dc3fea19

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 21

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7bd7408-db68-43e0-80c1-2c0f4d3d6959

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 22

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e07f9dba-aaa1-4941-a7e9-5f79e7f6b954

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 23

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ccd7f578-d81b-42f4-b161-b0ee0e548aa6

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 24

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cbf37842-09f3-4453-85a8-04c8e82172fa

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 25

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0092117b-d10a-47d2-97b9-22b6f598f6be

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 27

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81fcdc9b-db3b-4800-9920-8da776e2f73d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 28

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aec8fe22-68d4-40c2-add1-e5498c713332

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 30

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7859136f-6b0a-455c-a550-64877feaae76

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 Playback Test 31

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d003b9a6-519d-452d-a46e-2735fe677003

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Playback DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 quality test 206

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b046572a-4e2a-896b-0028-54930c657883

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Quality DXVA Test: InputType MPEG2 - MPEG2 Quality

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Direct3D_9 quality test 207

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bff3fa40-4228-dc23-dfeb-0a980e85f0da

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Quality DXVA Test: InputType MPEG2 - MPEG2 Quality

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 quality test 211

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1ae4af1-4e4c-71c5-23dd-e8ac90635d0c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Quality DXVA Test: InputType MPEG2 - MPEG2 Quality

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MPEG2 Stress test 303

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da4d8eca-1e52-4ae4-b0a4-06bffdcbb526

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG2 Stress DXVA Test: InputType MPEG2 - Verify DXVA Decoding for MPEG2

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


MultiHead Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dce302a5-0cb7-45a3-ad6b-7f04670eb44a

This automated test validates the functional and operational specifications for the multihead support that is added in Microsoft® DirectX® 9.0.

Multihead support allows a single Direct3D device to drive multiple heads. This functionality uses resources such as surfaces and textures more efficiently than a multi-monitor configuration.

This topic applies to the following test jobs:

  • MultiHead Support

  • MultiHead Support (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software:

  • Microsoft DirectX 9.0 or later
NOTE

If you run this test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test writes the test results to a log file called Multihead.xml, and displays on-screen pass or fail compliance. The test log is written to the %windir%\dxlogs directory.

More information

When creating and resetting a multihead device, observe the following restrictions:

  • Each head must have the windowed mode set to FALSE.

  • Each head must have the same value set for the EnableAutoDepthStencil property.

  • If EnableAutoDepthStencil is TRUE, each head must have the same value for AutoDepthStencilFormat, back buffer dimension, and format.

  • You cannot create additional swap chains on a multihead device.

The test covers the core usage scenarios and a set of Direct3D interfaces (IDirect3D9 and IDirect3DDevice9). The interface methods include: GetDeviceCaps, CreateDevice, Reset, CreateAdditionalSwapChain, GetSwapChain, and GetNumberOfSwapchains.

Core usage scenarios include rendering to each head, and cursor manipulation.

For each of the covered interface methods, a set of test cases are run to verify the basic functional properties. Most of these tests simply involve verifying state changes or verifying that the actual results match the expected results. There are several tests that vary the surface properties of each head, render a scene on the heads, and compare the images against the rendering of the reference device.

Command syntax

Command option | Description
Multihead.exe -dx9 -whql -logclean | Runs the MultiHead Support test job.
Multihead.exe -whql -logclean | Runs the MultiHead Support (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Multihead.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


MultiHead Support (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dba40a83-c886-4dc8-affa-542d50e464c1

This automated test validates the functional and operational specifications for the multihead support that is added in Microsoft® DirectX® 9.0.

Multihead support allows a single Direct3D device to drive multiple heads. This functionality uses resources such as surfaces and textures more efficiently than a multi-monitor configuration.

This topic applies to the following test jobs:

  • MultiHead Support

  • MultiHead Support (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition, this test requires the following software:

  • Microsoft DirectX 9.0 or later
NOTE

If you run this test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test writes the test results to a log file called Multihead.xml, and displays on-screen pass or fail compliance. The test log is written to the %windir%\dxlogs directory.

More information

When creating and resetting a multihead device, observe the following restrictions:

  • Each head must have the windowed mode set to FALSE.

  • Each head must have the same value set for the EnableAutoDepthStencil property.

  • If EnableAutoDepthStencil is TRUE, each head must have the same value for AutoDepthStencilFormat, back buffer dimension, and format.

  • You cannot create additional swap chains on a multihead device.

The test covers the core usage scenarios and a set of Direct3D interfaces (IDirect3D9 and IDirect3DDevice9). The interface methods include: GetDeviceCaps, CreateDevice, Reset, CreateAdditionalSwapChain, GetSwapChain, and GetNumberOfSwapchains.

Core usage scenarios include rendering to each head, and cursor manipulation.

For each of the covered interface methods, a set of test cases are run to verify the basic functional properties. Most of these tests simply involve verifying state changes or verifying that the actual results match the expected results. There are several tests that vary the surface properties of each head, render a scene on the heads, and compare the images against the rendering of the reference device.

Command syntax

Command option | Description
Multihead.exe -dx9 -whql -logclean | Runs the MultiHead Support test job.
Multihead.exe -whql -logclean | Runs the MultiHead Support (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Multihead.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multimon minimum resolution check - Multihead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3338858-851b-432d-8728-5451b95a1795

This is an automated test to verify that the system can support a 1024x768 internal display and a 1920x1080 external display simultaneously. Both displays should be running at a minimum of 60Hz and 32bpp.

Test details
Specifications
  • Device.Graphics.WDDM12.Display.ModeEnumeration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

NOTE

If you run this test on a system without multiple monitors, you will be prompted to add a second monitor. If your device family does not support multimon, select "Continue" to force the test to run in single monitor configuration. Some tests can only be run on systems with multiple monitors, in which case the test will be skipped.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.


Multipass Z-Fighting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63884a99-e857-4fa1-8106-b3636a32ac2a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multipass Z-Fighting

  • Multipass Z-Fighting (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Zfight -M:1 -dx9 -whql -logclean | This command runs the Multipass Z-Fighting test job.
Zfight -M:1 -whql -logclean | This command runs the Multipass Z-Fighting (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Zfight.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multipass Z-Fighting (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e01b2fa-31e4-46e1-955c-e27c1852b9c1

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multipass Z-Fighting

  • Multipass Z-Fighting (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Zfight -M:1 -dx9 -whql -logclean | This command runs the Multipass Z-Fighting test job.
Zfight -M:1 -whql -logclean | This command runs the Multipass Z-Fighting (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Zfight.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multiple Lights

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/516da266-86ce-4870-a67d-da664a668891

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multiple Lights

  • Multiple Lights (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
MultiLight -M:1 -dx9 -whql -logclean | This command runs the Multiple Lights test job.
MultiLight -M:1 -whql -logclean | This command runs the Multiple Lights (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
MultiLight.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multiple Lights (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9278c497-f0b0-430c-9057-7059518dfc6a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multiple Lights

  • Multiple Lights (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
MultiLight -M:1 -dx9 -whql -logclean | This command runs the Multiple Lights test job.
MultiLight -M:1 -whql -logclean | This command runs the Multiple Lights (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
MultiLight.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multiple Render Targets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/336e1045-8ada-428f-b0c8-f89cc2cb26bc

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multiple Render Targets

  • Multiple Render Targets (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mrt -M:1 -dx9 -whql -logclean | This command runs the Multiple Render Targets test job.
Mrt -M:1 -whql -logclean | This command runs the Multiple Render Targets (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mrt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multiple Render Targets (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25144f2a-9b3b-496f-8756-97e09bc7035d

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multiple Render Targets

  • Multiple Render Targets (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mrt -M:1 -dx9 -whql -logclean | This command runs the Multiple Render Targets test job.
Mrt -M:1 -whql -logclean | This command runs the Multiple Render Targets (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mrt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multisample Stability (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8dcac1e6-10b3-4fd7-8b40-72aa22217fb2

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
  • Device.Graphics.XDDM.Stability
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
MSStress -M:[Monitor] | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
MSStress.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\stress
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multisampling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/deb18957-c491-4733-b86d-9f7146d8e614

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multisampling

  • Multisampling (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Multisample -M:1 -dx9 -whql -logclean | This command runs the Multisampling test job.
Multisample -M:1 -whql -logclean | This command runs the Multisampling (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Multisample.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multisampling (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b14eb13-b228-490d-88b3-e25e29233d1d

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multisampling

  • Multisampling (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Multisample -M:1 -dx9 -whql -logclean | This command runs the Multisampling test job.
Multisample -M:1 -whql -logclean | This command runs the Multisampling (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Multisample.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multistream Rendering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5366b14d-f3fb-4613-a5c2-cbbb24cd2189

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multistream Rendering

  • Multistream Rendering (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Zerostride.exe -M:1 -dx9 -whql -logclean | Runs the Multistream Rendering test job.
Zerostride -M:1 -whql -logclean | Runs the Multistream Rendering (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Zerostride.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Multistream Rendering (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44d7d1cb-2eb4-4fb6-8fc8-3c7fcc953aff

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Multistream Rendering

  • Multistream Rendering (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Zerostride.exe -M:1 -dx9 -whql -logclean | Runs the Multistream Rendering test job.
Zerostride -M:1 -whql -logclean | Runs the Multistream Rendering (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Zerostride.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


MultiSwapchain

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19d4e79b-5c1b-4a26-a7c5-4a2585600c12

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • MultiSwapchain

  • MultiSwapchain (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Multi_swapchain -M:1 -dx9 -whql -logclean | Runs the MultiSwapchain test job.
Multi_swapchain -M:1 -whql -logclean | Runs the MultiSwapchain (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Multi_swapchain.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


MultiSwapchain (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cdd9504f-dc19-4857-bc49-1e49ff62b86f

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • MultiSwapchain

  • MultiSwapchain (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Multi_swapchain -M:1 -dx9 -whql -logclean | Runs the MultiSwapchain test job.
Multi_swapchain -M:1 -whql -logclean | Runs the MultiSwapchain (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Multi_swapchain.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Non Power 2 Conditional ConfTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/370a1f0f-a8e2-4b69-9089-ea6940d4bdfe

This automated test verifies the requirements listed in the test details table.

This topic is applicable to the following test jobs:

  • Non Power 2 Conditional ConfTest

  • Non Power 2 Conditional ConfTest (WOW64)

  • Non Power 2 Conditional RenderTarget

  • Non Power 2 Conditional RenderTarget (WOW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 11
Category | Compatibility
Timeout (in minutes) | 660
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
NonPowTwo.exe -ConfTest -M:1 -whql -logclean | This command runs both the 32-bit and 64-bit Non Power 2 Conditional ConfTest test case.
NonPowTwo.exe -RenderTarget -M:1 -whql -logclean | This command runs both the 32-bit and 64-bit Non Power 2 Conditional RenderTarget test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[osbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[osbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[osbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dref8.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest \graphics\d3d\utility</p>
NonPowTwo.exe | <[testbinroot]>\nttest windowstest\graphics\d3d\conf
TDRWatch.exe | <[testbinroot]>\nttest windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Non Power 2 Conditional ConfTest (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2bf4b972-52c8-474a-82ca-c740dfa61b5e

This automated test verifies the requirements listed in the test details table.

This topic is applicable to the following test jobs:

  • Non Power 2 Conditional ConfTest

  • Non Power 2 Conditional ConfTest (WOW64)

  • Non Power 2 Conditional RenderTarget

  • Non Power 2 Conditional RenderTarget (WOW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
NonPowTwo.exe -ConfTest -M:1 -whql -logclean | This command runs both the 32-bit and 64-bit Non Power 2 Conditional ConfTest test case.
NonPowTwo.exe -RenderTarget -M:1 -whql -logclean | This command runs both the 32-bit and 64-bit Non Power 2 Conditional RenderTarget test case.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[osbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[osbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[osbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dref8.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest \graphics\d3d\utility</p>
NonPowTwo.exe | <[testbinroot]>\nttest windowstest\graphics\d3d\conf
TDRWatch.exe | <[testbinroot]>\nttest windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Non Power 2 Conditional RenderTarget

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e197fdf-7d8e-4001-ad9a-59202cd18e9c

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Non Power 2 Conditional RenderTarget (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2671f153-7f4f-4c85-af7f-a6d7d4875fc2

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Non Power 2 Conditional Test (DX9) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1dea58b-c633-4871-9591-368bf382abc3

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
NonPower2ConditionalTest9.exe -d 1 -whql | This command runs the Non Power 2 Conditional Test (WoW64) test job
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
NonPower2ConditionalTest9.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Index of display output to target with test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Non Power 2 Conditional Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f81f0450-287a-4b0a-950c-dc723b06d40f

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
NonPower2ConditionalTest.exe -d 1 -whql | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
NonPower2ConditionalTest.exe | <[testbinroot]>\nttest\multimediatest\streaming

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Index of display output to target with test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Office 2013 Basic Test Cases (Excel)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/254ceb77-0367-4a6a-870d-7128916f5e73

Basic test cases to verify that Office 2013 works with a display driver or system. Excel 1. Copy Test_Excel_Workbook.xlsx to the machine where Office is installed and you are doing the testing 2. Once you've copied it, double click Test Excel Workbook.xlsx on that machine 3. Verify Excel boots, the file is opened and there are no rendering issues 4. Highlight Cells A:1 and B:1 5. Hit CTRL-C 6. Verify both cells have a green animated dotted line around the select that is smoothly animated and without any rendering issues 7. In the upper right side of the window, click on the button to the left of the minimize button which has a tooltip that reads "Ribbon Options" 8. A menu will pop up. Click on Show Tabs. 9. Verify that the ribbon toolbar smoothly animates up, there are no rendering issues, and is no longer visible 10. Click on the Ribbon Options button again and select Show Tabs and Commands 11. Verify that the ribbon toolbar smoothly animates down, there are no rendering issues, and the ribbon is showing In addition to specific verifications listed in the steps above, the general types of issues that may be encountered include: Application crashes Broken or missing functionality Rendering issues (ie. flickering UI, frame rate drops, piecemeal drawing, failure to repaint, choppy or slow animations) App Responsiveness problems (typing, selection, UI, "Not Responding", hangs, Inability to cancel)

Test details
Specifications
  • Device.Graphics.WDDM.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU name of net user


Office 2013 Basic Test Cases (Lync)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55a196e7-c2d3-4e9b-b289-973c96196a25

Basic test cases to verify that Office 2013 works with a display driver or system. Lync Setup Required: 2 Lync user accounts and 2 machines with webcams and capable video 1. On 2 different machines with different user accounts, boot Lync 2. From User1's Lync instance, double click User2's name to start an IM conversation with user User2 3. In User1's Lync IM window, hover over the video icon in the bottom of the IM window. A pop up menu should appear with video coming from User1's webcam 4. Verify that the video is smooth and there are no rendering issues In addition to specific verifications listed in the steps above, the general types of issues that may be encountered include: Application crashes Broken or missing functionality Rendering issues (ie. flickering UI, frame rate drops, piecemeal drawing, failure to repaint, choppy or slow animations) App Responsiveness problems (typing, selection, UI, "Not Responding", hangs, Inability to cancel)

Test details
Specifications
  • Device.Graphics.WDDM.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU name of net user


Office 2013 Basic Test Cases (PowerPoint)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c089b830-ca4c-409b-9d2b-a88d57e09c00

Basic test cases to verify that Office 2013 works with a display driver or system. PowerPoint 1. Copy Test_Presentation.pptx to the machine where Office is installed and you are doing the testing 2. Once you've copied it, double click Test Presentation.pptx on that machine 3. Verify PowerPoint boots, the file is opened, and there are no rendering issues 4. If the window is maximized, click on the restore down button in the upper right corner of the window to allow the window to be resized 5. Click, hold and drag the bottom right corner of the window to slowly resize the window to be smaller and bigger 6. Verify there are no rendering issues 7. Select slide 2 in the presentation 8. Select the box that says "Select Me" 9. Click on the Design in the ribbon 10. In the Layouts section of Design, hover over the various Layout options shown in the drop down box 11. Verify that as you hover from one to the other that the SmartArt on slide 2 animates smoothly to the currently moused-over SmartArt and there are no rendering issues 12. Connect to an external projector or additional monitor and extend Windows to the 2nd display device 13. Verify there are no rendering issues when 2nd display is connected 14. Hit F5 15. Verify PowerPoint enters presentation mode with 1 screen as the normal presentation and 1 screen showing the presentation view and there are no rendering issues 16. Hit the Up and Down area a few times 17. Verify slides move to the next/previous slide and there are no rendering issues In addition to specific verifications listed in the steps above, the general types of issues that may be encountered include: Application crashes Broken or missing functionality Rendering issues (ie. flickering UI, frame rate drops, piecemeal drawing, failure to repaint, choppy or slow animations) App Responsiveness problems (typing, selection, UI, "Not Responding", hangs, Inability to cancel)

Test details
Specifications
  • Device.Graphics.WDDM.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU name of net user


Office 2013 Basic Test Cases (Word)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bcc2b44b-8330-47c2-812e-9eb11a81f928

Basic test cases to verify that Office 2013 works with a display driver or system. Word 1. Copy Test_Word_Doc.docx to the machine where Office is installed and you are doing the testing 2. Once you've copied it, double click Test Word Doc.docx on that machine 3. Verify Word boots, the file is opened and there are no rendering issues 4. Hit Page Up and Page Down multiple times 5. Verify the pages smoothly scrolls up/down and there are no rendering issues 6. At the bottom right part of the Word window, grab, hold and move the slider bar to zoom in/out on the page 7. Verify the zooming animation is smooth and there are no rendering issues (note that as you zoom in/out the text fidelity will be low until you stop zooming where the text content will render in full fidelity) 8. Click on View in the ribbon 9. Under the Show section, check on the option for Navigation Pane 10. Verify the navigation pane smoothly animates in and there are no rendering issues In addition to specific verifications listed in the steps above, the general types of issues that may be encountered include: Application crashes Broken or missing functionality Rendering issues (ie. flickering UI, frame rate drops, piecemeal drawing, failure to repaint, choppy or slow animations) App Responsiveness problems (typing, selection, UI, "Not Responding", hangs, Inability to cancel)

Test details
Specifications
  • Device.Graphics.WDDM.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU name of net user


OPM - HDCP CSS DVD Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1475478c-9219-44e0-80da-cb075c31c4b6

These automated tests run PVP-OPM (Protected Video Path - Output Protection Management) commands. They test display drivers for PVP-OPM compatibility, and check for the availability of digital protection (HDCP) and analog protections (ACP and CGMSA).

There are three assertions for this test:

  • The display driver must support PVP-OPM driver interfaces.

  • The display driver must support CGMSA and APS.

  • The display driver must support HDCP.

For all of the assertions, the test goes through the PVP-OPM initialization protocol. If initialization fails, all of the assertions fail for premium SKUs (and skip for basic SKUs). Tests do not actually verify each protection schema, but do query the driver for the availability.

This topic applies to the following test jobs:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP CSS DVD Test (WoW64)

  • OPM - HDCP Test

  • OPM - HDCP Test (WoW64)

  • OPM - Protocol Test

  • OPM - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition:

  • If the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • If the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the analog connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The following jobs validate the test assertions below:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP Test

  • OPM - Protocol Test

Command syntax

Command option | Description
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD test job.
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol Test (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
OPM_ACPandCGMSA_Test.pro | <[testbinroot]>\nttest</p>
OpmCompTest.dll | <[testbinroot]>\nttest</p>
S98wtt_u.dll | <[testbinroot]>\nttest</p>
Shellrunner.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


OPM - HDCP CSS DVD Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8dba00a-4223-442d-9c93-e69cc41ccea4

These automated tests run PVP-OPM (Protected Video Path - Output Protection Management) commands. They test display drivers for PVP-OPM compatibility, and check for the availability of digital protection (HDCP) and analog protections (ACP and CGMSA).

There are three assertions for this test:

  • The display driver must support PVP-OPM driver interfaces.

  • The display driver must support CGMSA and APS.

  • The display driver must support HDCP.

For all of the assertions, the test goes through the PVP-OPM initialization protocol. If initialization fails, all of the assertions fail for premium SKUs (and skip for basic SKUs). Tests do not actually verify each protection schema, but do query the driver for the availability.

This topic applies to the following test jobs:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP CSS DVD Test (WoW64)

  • OPM - HDCP Test

  • OPM - HDCP Test (WoW64)

  • OPM - Protocol Test

  • OPM - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition:

  • If the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • If the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the analog connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The following jobs validate the test assertions below:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP Test

  • OPM - Protocol Test

Command syntax

Command option | Description
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD test job.
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol Test (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
OPM_ACPandCGMSA_Test.pro | <[testbinroot]>\nttest</p>
OpmCompTest.dll | <[testbinroot]>\nttest</p>
S98wtt_u.dll | <[testbinroot]>\nttest</p>
Shellrunner.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


OPM - HDCP Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4af26016-316b-42aa-b6e3-fe587be066df

These automated tests run PVP-OPM (Protected Video Path - Output Protection Management) commands. They test display drivers for PVP-OPM compatibility, and check for the availability of digital protection (HDCP) and analog protections (ACP and CGMSA).

There are three assertions for this test:

  • The display driver must support PVP-OPM driver interfaces.

  • The display driver must support CGMSA and APS.

  • The display driver must support HDCP.

For all of the assertions, the test goes through the PVP-OPM initialization protocol. If initialization fails, all of the assertions fail for premium SKUs (and skip for basic SKUs). Tests do not actually verify each protection schema, but do query the driver for the availability.

This topic applies to the following test jobs:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP CSS DVD Test (WoW64)

  • OPM - HDCP Test

  • OPM - HDCP Test (WoW64)

  • OPM - Protocol Test

  • OPM - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition:

  • If the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • If the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the analog connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The following jobs validate the test assertions below:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP Test

  • OPM - Protocol Test

Command syntax

Command option | Description
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD test job.
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol Test (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
OPM_ACPandCGMSA_Test.pro | <[testbinroot]>\nttest</p>
OpmCompTest.dll | <[testbinroot]>\nttest</p>
S98wtt_u.dll | <[testbinroot]>\nttest</p>
Shellrunner.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


OPM - HDCP Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1fdbf80-4ef0-4828-ac90-73ff66392835

These automated tests run PVP-OPM (Protected Video Path - Output Protection Management) commands. They test display drivers for PVP-OPM compatibility, and check for the availability of digital protection (HDCP) and analog protections (ACP and CGMSA).

There are three assertions for this test:

  • The display driver must support PVP-OPM driver interfaces.

  • The display driver must support CGMSA and APS.

  • The display driver must support HDCP.

For all of the assertions, the test goes through the PVP-OPM initialization protocol. If initialization fails, all of the assertions fail for premium SKUs (and skip for basic SKUs). Tests do not actually verify each protection schema, but do query the driver for the availability.

This topic applies to the following test jobs:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP CSS DVD Test (WoW64)

  • OPM - HDCP Test

  • OPM - HDCP Test (WoW64)

  • OPM - Protocol Test

  • OPM - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition:

  • If the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • If the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the analog connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The following jobs validate the test assertions below:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP Test

  • OPM - Protocol Test

Command syntax

Command option | Description
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD test job.
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol Test (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
OPM_ACPandCGMSA_Test.pro | <[testbinroot]>\nttest</p>
OpmCompTest.dll | <[testbinroot]>\nttest</p>
S98wtt_u.dll | <[testbinroot]>\nttest</p>
Shellrunner.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


OPM - Protocol Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1cd56bda-d320-476e-badd-46fe9acb34cc

These automated tests run PVP-OPM (Protected Video Path - Output Protection Management) commands. They test display drivers for PVP-OPM compatibility, and check for the availability of digital protection (HDCP) and analog protections (ACP and CGMSA).

There are three assertions for this test:

  • The display driver must support PVP-OPM driver interfaces.

  • The display driver must support CGMSA and APS.

  • The display driver must support HDCP.

For all of the assertions, the test goes through the PVP-OPM initialization protocol. If initialization fails, all of the assertions fail for premium SKUs (and skip for basic SKUs). Tests do not actually verify each protection schema, but do query the driver for the availability.

This topic applies to the following test jobs:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP CSS DVD Test (WoW64)

  • OPM - HDCP Test

  • OPM - HDCP Test (WoW64)

  • OPM - Protocol Test

  • OPM - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition:

  • If the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • If the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the analog connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The following jobs validate the test assertions below:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP Test

  • OPM - Protocol Test

Command syntax

Command option | Description
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD test job.
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol Test (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
OPM_ACPandCGMSA_Test.pro | <[testbinroot]>\nttest</p>
OpmCompTest.dll | <[testbinroot]>\nttest</p>
S98wtt_u.dll | <[testbinroot]>\nttest</p>
Shellrunner.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


OPM - Protocol Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8dfa3cc-a19f-4e97-b4da-aa6f7d32697d

These automated tests run PVP-OPM (Protected Video Path - Output Protection Management) commands. They test display drivers for PVP-OPM compatibility, and check for the availability of digital protection (HDCP) and analog protections (ACP and CGMSA).

There are three assertions for this test:

  • The display driver must support PVP-OPM driver interfaces.

  • The display driver must support CGMSA and APS.

  • The display driver must support HDCP.

For all of the assertions, the test goes through the PVP-OPM initialization protocol. If initialization fails, all of the assertions fail for premium SKUs (and skip for basic SKUs). Tests do not actually verify each protection schema, but do query the driver for the availability.

This topic applies to the following test jobs:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP CSS DVD Test (WoW64)

  • OPM - HDCP Test

  • OPM - HDCP Test (WoW64)

  • OPM - Protocol Test

  • OPM - Protocol Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.OutputProtection
  • Device.Graphics.WDDM.DisplayRender.OutputProtection.Windows7
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

In addition:

  • If the graphics card supports a digital connector (DVI or HDMI), you must connect and enable an HDCP-enabled monitor.

  • If the graphics card supports an analog connector (component, composite, or S-Video), you must connect and enable the analog connector.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The following jobs validate the test assertions below:

  • OPM - HDCP CSS DVD Test

  • OPM - HDCP Test

  • OPM - Protocol Test

Command syntax

Command option | Description
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD test job.
ShellRunner.exe -x premium -c OPM_CSSDVD_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP CSS DVD Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP test job.
ShellRunner.exe -x basic -c OPM_HDCP_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - HDCP Test (WoW64) test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol test job.
ShellRunner.exe -x basic -c OPM_Protocol_Test.pro -l "[WTTRunWorkingDir]\s98wtt_u.dll" | Runs the OPM - Protocol Test (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
OPM_ACPandCGMSA_Test.pro | <[testbinroot]>\nttest</p>
OpmCompTest.dll | <[testbinroot]>\nttest</p>
S98wtt_u.dll | <[testbinroot]>\nttest</p>
Shellrunner.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU local name, local with net access
LIBRARYNAME | Library for the test to run
PROFILENAME | Profile for the test to run
DISPLAYLOGOLEVEL | Qualification level for submission: basic
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


OptStandby - Video Memory Purge and Resume

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4a7d704-f630-4149-bacb-49e40f3ec2a0

This automated test enables developers, testers and system integrators to exercise and record power management information from the system.

This test can be used to automate sleep and resume transitions as well as record processor power management and battery information from the system over a period of time.

The test features robust logging (capable of logging information to both a Windows Test Technologies (WTL) and XML file format) and a command-line interface.

Test details
Specifications
  • Device.Graphics.WDDM12.StandbyHibernateFlags.StandbyHibernateFlags
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

PwrTest functionality is separated into scenarios. Currently, PwrTest supports the following scenarios:

  • Sleep - Exercises sleep and resume transition functionality. Sleep/resume transitions can be automated and target sleep states can be specified.

  • PPM - Displays and records processor power management (PPM) information and metrics. Performance (ACPI P states) and processor idle (ACPI C states) state information can be logged for a period of time at a specified interval.

  • Battery - Displays and records battery information and metrics. Battery capacity, voltage, rate of drain and estimated life time remaining can be logged for a period of time at a specified interval.

  • Info - Displays system power management information, such as available sleep states and processor power management capabilities.

  • Execution state - Displays and records thread execution state changes. Thread execution states allow applications and services to temporarily override power management settings such as the monitor and sleep idle timeouts

Running the test

The following sections describe how to run this test from a command line and how to interpret the log files that are created by the test binary.

Command-Line Arguments

PwrTest functionality and scenarios can be accessed through the command-line. The basic usage for PwrTest is:

usage: PwrTest /scenario [-l:path] scenario indicates the test scenario  sleep  for sleep/resume transition testing  ppm    for processor power management testing  battery   for battery information testing  info  for system capabilities information  es  for thread execution state changespath indicates the logfile path  For example, c:\logfile.xml  Default is .\PwrTest.xml

The logfile path can be specified as the name of the target file in the current directory, or as the path and target file in another directory. PwrTest will automatically generate an XML and WTL version of the log with the same file name and ".XML" or ".WTL" appended at the end of the file name.

To learn more about each of the PwrTest scenarios, type:

PwrTest /<scenario> /?

Log file details

PwrTest supports both XML and WTL log file formats. By default, PwrTest will generate both the XML and WTL logs named "PwrTestlog.xml" and "PwrTestlog.wtl", respectively. These files will be generated in the current directory.

You can use the -l:path argument to specify a different path and file name for the PwrTest log files. For example, -l:\\server\share\PwrTest_today\run will generate the files run.xml and run.wtl in the folder \\server\share\PwrTest_today\.

The WTL log file format is common to all Microsoft Windows Driver Kit (WDK) tools that use the WTTlog interface.

The PwrTest XML log file format is described in detail with the scenario information below. However, all PwrTest XML log files have the following root element:

  <PwrTestLog   date="today's date"   time="beginning time"   filename = "logfile path">  ... scenario information ...   </PwrTestLog>

Sleep scenario information

The PwrTest Sleep scenario is designed to facilitate automated testing of sleep and resume transitions. PwrTest is capable of directing the platform into one or more sleep states in an automated fashion and logging sleep state performance information such as the BIOS initialization and total resume times.

To learn more about the Sleep Scenario, type:

PwrTest /sleep /?

The PwrTest Sleep scenario supports the command-line arguments in the following table.

Argument Description Default value

/c:n

n indicates the number of sleep cycles

/c:1

/d:n

n indicates the delay time between consecutive sleep cycles, in seconds.

/d:90

/p:n

n indicates the time the system will sleep before automatically waking for the next sleep cycle, in seconds.

/p:60

/h:y

Indicates hybrid sleep transitions should be enabled.

Current user power policy

/h:n

Indicates hybrid sleep transitions should be disabled.

Current user power policy

/t:y

Indicates sleep transitions should be marked critical. Applications and services are not able to prevent the sleep transition.

Current user power policy

/t:n

Indicates sleep transitions should not be marked critical. Applications and services are able to prevent the sleep transition.

Current user power policy

/s:n

n indicates the target sleep state(s) for the sleep transitions. Possible values are:

  • "all", All ACPI sleep states should be used in sequential order (S1, S3, S4, S1, S3, S4...)

  • "rnd", All ACPI sleep states should be used in random order (S1, S4, S3, S1, S4, S1...)

  • "1", Only S1 state should be used.

  • "3", Only S3 state ("Standby") should be used.

  • "4", Only S4 state ("Hibernate") should be used.

/s:3

/unattend

Indicates the system should wake unattended. PwrTest will not request the display to be enabled between each sleep cycle.

This feature is disabled by default.

Examples

PwrTest /sleep /c:7 /s:3

PwrTest will cycle the system through 7 standby transitions and save the output file information to .\PwrTestlog.xml and .\PwrTestlog.wtl.

PwrTest /sleep /c:1 /s:1

PwrTest will cycle the system through a single S1 transition and save the output file information to .\PwrTestlog.xml and .\PwrTestlog.wtl.

PwrTest /sleep /c:10 /s:rnd /d:180 /p:600 /l:random

PwrTest will cycle the system through 10 sleep/resume cycles with a random target sleep state from the available sleep states on the system. The system will sleep for 10 minutes on each sleep cycle and the delay between sleep cycles will be 3 minutes. The output will be saved to .\random.xml and .\random.wtl.

XML Logfile Output

The Sleep scenario generates the following XML elements:

  <SleepScenario>   <SleepTransitions   critical=""   hybrid=""   delay=""   sleeptime="">    <SleepTransition   number=""   status="">    <StartT></StartT>    <EndT></EndT>    <Duration></Duration>    <TargetState></TargetState>    <EffectiveState></EffectiveState>    <BIOSInit></BIOSInit>    <DriverInit></DriverInit>    <Suspend></Suspend>    <Resume></Resume>    <HiberRead></HiberRead>    <HiberWrite></HiberWrite>    </SleepTransition>   <SleepTransition   number=""   status="">    <StartT></StartT>    <EndT></EndT>    <Duration></Duration>    <TargetState></TargetState>    <EffectiveState></EffectiveState>    <BIOSInit></BIOSInit>    <DriverInit></DriverInit>    <Suspend></Suspend>    <Resume></Resume>    <HiberRead></HiberRead>    <HiberWrite></HiberWrite>    </SleepTransition>   </SleepTransitions>   </SleepScenario>

This table describes the Sleep scenario XML elements in detail.

Element | Description
<SleepScenario> | Contains information related to the sleep scenario. Only one <SleepScenario> element per PwrTest log file.
<SleepTransitions> | Provides overall data about the sleep transition cycles such as the state of critical and hybrid sleep features.
<SleepTransition> | Provides per-sleep cycle information such as the start and end times, as well as details about the resume time such as the BIOS initialization time. A <SleepTransition> element is generated for each sleep transition cycle.
<StartT> | Indicates the start time of the sleep cycle. (hh:mm:ss)
<EndT> | Indicates the end time of the sleep cycle. (hh:mm:ss)
<Duration> | Indicates the duration of the sleep cycle. (hh:mm:ss)
<TargetState> | Indicates the target sleep state.
<EffectiveState> | Indicates the effective sleep state.
<BIOSInit> | Indicates the amount of time required to initialize the BIOS (TargetState must be 3) on resume in milliseconds.
<DriverInit> | Indicates the amount of time required to initialize drivers on resume in milliseconds.
<Suspend> | Indicates the amount of time required to suspend the system in milliseconds.
<Resume> | Indicates the total amount of time required to resume the system in milliseconds.
<HiberRead> | Indicates the time required to read the hibernation file in milliseconds. (TargetState must be 4).
<HiberWrite> | Indicates the time required to write the hibernation file in milliseconds. (EffectiveState must be 4).

PPM scenario information

The PwrTest PPM scenario is designed to facilitate automated inspection of processor power management capabilities and run-time information. PwrTest is capable of recording system usage of processor performance and processor idle states over a duration of time.

These metrics can be analyzed post-run from the PwrTest logfile and compared to past or future runs of PwrTest.

To learn more about the PPM Scenario, type:

PwrTest /ppm /?

The PwrTest PPM scenario supports the command-line arguments in the following table.

Argument | Description | Default value
/n:n | n indicates the number of cycles of processor information to log. | /c:100
/i:n | n indicates the polling interval (in milliseconds) to update processor information. PwrTest will record processor information for the number of cycles specified by /n:n multiplied by the polling interval specified by /i:n. | /i:5000
/c:y | Indicates that processor idle (ACPI C-state) information should be logged. | (default)
/c:n | Indicates that processor idle (ACPI C-state) information should not be logged. | [This content isn't available yet.]
/p:y | Indicates that processor performance / throttle state information should be logged. | (default)
/p:n | Indicates that processor performance / throttle state information should not be logged. | [This content isn't available yet.]
/u:y | Indicates that CPU utilization information should be logged. | (default)
/u:n | Indicates that CPU utilization information should not be logged. | [This content isn't available yet.]

Examples

PwrTest /ppm /n:10 /i:6000

PwrTest will record all processor power management information for one minute at 6 second intervals.

PwrTest /ppm /n:3600 /i:1000 /p:n

PwrTest will record processor performance state information every second for an hour

PwrTest /ppm /n:3600 /i:1000 /u:y /p:n /c:n

PwrTest will record processor utilization only for one-second intervals for an hour.

XML Logfile Output

The PPM scenario generates the following XML elements:

<PPMScenario>  <ProcessorInformation>  <PerformanceStates>  <PerformanceState    number="0"   frequency=""   percentofmaxfrequency=""   type="" />  </PerformanceStates>  <ProcessorName> </ProcessorName>  <InterfaceType> </InterfaceType>   <TransitionLatency units=""></TransitionLatency>  </ProcessorInformation>  <ProcessorTraces interval="">  <Trace>  <CpuId></CpuId>  <ElapsedT></ElapsedT>  <CPUIdle></CPUIdle>  <PState></PState>  <Frequency></Frequency>  <PercentOfMax></PercentOfMax>  <PStateType></PStateType>  <COne></COne>  <CTwo></COne>  <CThree></CThree>  </Trace>   </ProcessorTraces>   </PPMScenario>

This table describes the PPM scenario XML elements in detail.

Element | Description
<PPMScenario> | Contains information related to the PPM scenario. Only one <SleepScenario> element per PwrTest log file.
<ProcessorInformation> | Contains information related to the static attributes of the processor, such as performance and throttle state capabilities.
<PerformanceStates> | Contains a list of <PerformanceState> elements.
<PerformanceState> | Indicates an available performance or throttle state. Includes state number, frequency, percentage of maximum frequency and type attributes.
<ProcessorName> | Indicates the friendly name of the processor.
<InterfaceType> | Indicates the mechanism used to interface between Windows and platform processor power management features.
<TransitionLatency> | Indicates the latency when switching performance states. Includes an units attribute, typically "us".
<ProcessorTraces> | Contains a list of <Trace> elements. Includes an interval attribute indicating the interval of each <Trace> element.
<Trace> | Contains trace information, which will vary depending on the command-line arguments presented to PwrTest.
<CpuId> | Identifies the processor.
<ElapsedT> | Indicates the elapsed time since the start of PwrTest in milliseconds.
<CPUIdle> | Indicates the percentage of processor idle time.
<PState> | Indicates the current processor performance state.
<Frequency> | Indicates the actual frequency of the current processor performance state in Megahertz.
<PercentOfMax> | Indicates the percentage of maximum frequency for the current performance state.
<PStateType> | Indicates if the performance state is a performance state (1) or a throttle state (0).
<COne> | Indicates the percentage of CPU idle time spent in the C1 CPU idle state.
<CTwo> | Indicates the percentage of CPU idle time spent in the C2 CPU idle state.
<CThree> | Indicates the percentage of CPU idle time spent in the C3 CPU idle state.

Battery scenario information

The PwrTest Battery scenario is designed to facilitate automated inspection of battery and power source information. PwrTest is capable of logging battery capacity, voltage, rate of drain and general state for up to two batteries on the system. Battery data is logged at a specified interval for a specified number of cycles.

To learn more about the Battery Scenario, type:

PwrTest /battery /?

The PwrTest Battery scenario supports the command-line arguments in the following table.

Argument | Description | Default value
/n:n | n indicates the number of cycles of battery information to log. | /c:100
/i:n | n indicates the polling interval (in milliseconds) to update battery information. | /i:5000
/b:n | n indicates the which battery to log information from (0 or 1). | /b:all
/b:all | Indicates battery information should be logged from all batteries. | /b:all

Examples

PwrTest /battery /n:10 /i:6000

PwrTest will record all battery information for one minute at 6 second intervals

PwrTest /battery /n:10 /i:6000 /b:0

PwrTest will record battery information only from battery 0 for one minute at 6 second intervals.

XML Logfile Output

The Battery scenario generates the following XML elements:

<BatteryScenario>  <Batteries>  <Battery  id="" shortterm="" rechargable="" >  <Name></Name>  <UniqueID></UniqueID>  <Chemistry></Chemistry>  <Manufacturer></Manufacturer>  <DesignedCapacity></DesignedCapacity>  <FullChargeCapacity></FullChargeCapacity>  <CriticalBias></CriticalBias>  <CycleCount></CycleCount>  <ManufactureDate></ManufactureDate>  <FullLifeTime Units=""></FullLifeTime>  </Battery>   </Batteries>  <BatteryTraces interval="">  <Trace>  <ElapsedT></ElapsedT>  <ACStatus></ACStatus>  <Capacity id=""></Capacity>  <TimeRemaining></TimeRemaining>  <Capacity id=""></Capacity>  <RateOfDrain id=""></RateOfDrain>  <Voltage id=""></Voltage>  <Capacity id=""></Capacity>  <RateOfDrain id=""></RateOfDrain>  <Voltage id=""> </Voltage>  </Trace>  </BatteryTraces>   </BatteryScenario>

This table describes the PPM scenario XML elements in detail.

Element | Description
<BatteryScenario> | Contains information related to the battery scenario. Only one <BatteryScenario> element per PwrTest log file.
<Batteries> | Contains information related to the static attributes of the system batteries, such as manufacturer and cycle count information. Note, all information may not be available for each battery.
<Battery> | Contains static information about a system battery. An id attribute is present to uniquely identify the battery.
<Name> | Indicates the name of the battery.
<UniqueID> | Indicates the unique ID of the battery.
<Chemistry> | Indicates battery chemistry.
<Manufacturer> | Indicates the battery manufacturer.
<DesignedCapacity> | Indicates the designed capacity of the battery in mWh.
<FullChargeCapacity> | Indicates the fully charged capacity of the battery in mWh
<CriticalBias> | Indicates a bias from zero, in mWh, which is applied to the battery reporting.
<CycleCount> | Indicates the number of charge/discharge cycles the battery has experienced.
<ManufactureDate> | Indicates the manufacture date of the battery.
<FullLifeTime> | Indicates the battery full life time in seconds.
<BatteryTraces> | Contains a list of <Trace> elements. Has an attribute indicating the battery information polling interval.
<Trace> | Contains information about battery status such as voltage, capacity and rate of drain for a given interval.
<ElapsedT> | Indicates the elapsed time since PwrTest was started.
<ACStatus> | Indicates if the system is running on AC (1) or battery (0) power.
<TimeRemaining> | Indicates the battery life time remaining from all system batteries, in seconds.
<Capacity> | Indicates the capacity of the battery in mWh. Has an id attribute to indicate which battery the capacity is being reported for.
<RateOfDrain> | Indicates the rate of drain of the battery in mW. Has an id attribute to indicate which battery the rate of drain is being reported for.
<Voltage> | Indicates the battery voltage in mV. Has an id attribute to indicate which battery the voltage is being reported for.

Info scenario information

The PwrTest Info scenario is designed to log and display system power management capabilities and information, such as the availability of system power states.

To learn more about the Info Scenario, type:

PwrTest /info /?

The PwrTest Info scenario supports the command-line arguments in the following table.

Argument | Description | Default value
/info:powercap | Display SYSTEM_POWER_CAPABILITIES, which includes information about the availability of system sleep states. | (none)
/info:powerinfo | Display SYSTEM_POWER_INFORMATION which displays dynamic data about current idle thresholds and timers. | (none)
/info:battery | Display SYSTEM_BATTERY_STATE which contains information about the current state of the system battery. | (none)
/info:ppm | Display PROCESSOR_POWER_INFORMATION which contains information about the system processor. | (none)
/info:all | Display all supported information data. | (none)

Examples

PwrTest /info:powercap

PwrTest will display and log system power capabilities information from the SYSTEM_POWER_CAPABILITIES structure.

PwrTest /info:all

PwrTest will display and log all supported information data.

XML Logfile Output

The Info scenario generates the following XML elements:

<InfoScenario>  <SYSTEM_POWER_CAPABILITIES>   <SystemS1StateSupported></SystemS1StateSupported>  <SystemS2StateSupported></SystemS2StateSupported>  <SystemS3StateSupported></SystemS3StateSupported>   <SystemS4StateSupported></SystemS4StateSupported>  <SystemS5StateSupported></SystemS5StateSupported>  <RtcWakeSupported></RtcWakeSupported>  <FastSystemS4></FastSystemS4>  </SYSTEM_POWER_CAPABILITIES>   <SYSTEM_POWER_INFORMATION>    <MaxIdlenessAllowed></MaxIdlenessAllowed>  <Idleness></Idleness>  <TimeRemaining></TimeRemaining>  <CoolingMode></CoolingMode>  </SYSTEM_POWER_INFORMATION>   <SYSTEM_BATTERY_STATE>   <AcOnLine></AcOnLine>  <BatteryPresent></BatteryPresent>  <Charging></Charging>  <Discharging></Discharging>  <MaxCapacity></MaxCapacity>  <RemainingCapacity></RemainingCapacity>  <RateOfDrain></RateOfDrain>  <EstimatedTime></EstimatedTime>  <DefaultAlert1></DefaultAlert1>  <DefaultAlert2></DefaultAlert2>  </SYSTEM_BATTERY_STATE>   <PROCESSOR_POWER_INFORMATION>   <CPUNumber></CPUNumber>  <MaxMhz></MaxMhz>  <CurrentMhz></CurrentMhz>  <MhzLimit></MhzLimit>  <MaxIdleState></MaxIdleState>  <CurrentIdleState></CurrentIdleState>  </PROCESSOR_POWER_INFORMATION>   </InfoScenario>

This table describes the PPM scenario XML elements in detail.28

Element | Description
<InfoScenario> | Contains information related to the info scenario. Only one <InfoScenario> element per PwrTest log file.
<SYSTEM_POWER_CAPABILITIES> | Contains information related to system power capabilities. This information is retrieved from the SYSTEM_POWER_CAPABILITIES structure.
<SystemSxStateSupported> | Indicates if a given system ACPI sleep state is supported on the system.
<RtcWakeSupported> | Indicates the lowest sleep state where RTC wake (wake on timer) is supported. The value is of the SYSTEM_POWER_STATE enumeration.
<FastSystemS4> | Indicates if hybrid sleep is available on the system.
<SYSTEM_POWER_INFORMATION> | Contains information related to the idleness of the system.
<MaxIdlenessAllowed> | Indicates the idleness (in percentage) when the system is considered idle and the idle timeout begins counting.
<Idleness> | Current idle level, expressed in percentage.
<TimeRemaining> | Indicates the time remaining in the system standby idle timer, in seconds
<CoolingMode> | Indicates the current system cooling mode: (0) Active, (1), Passive, (2) Invalid.
<SYSTEM_BATTERY_STATE> | Contains information related to the current state of the system battery.
<AcOnLine> | Indicates if the system is currently operating on AC power.
<BatteryPresent> | Indicates if at least one battery is present in the system.
<Charging> | Indicates if at least one battery is currently charging.
<Discharging> | Indicates if at least one battery is currently discharging.
<MaxCapacity> | Maximum capacity of the battery when new, in mWh.
<RemainingCapacity> | Estimated remaining capacity of the battery, in mWh.
<RateOfDrain> | Indicates the current rate of discharge of the battery in mW.
<EstimatedTime> | Estimated time remaining on the battery, in seconds.
<DefaultAlert1> | Indicates the battery manufacturers suggested capacity when a low battery alert should occur.
<DefaultAlert2> | Indicates the battery manufacturers suggested capacity when a warning battery alert should occur.
<PROCESSOR_POWER_INFORMATION> | Contains information related to the system processors and their power management capabilities.
<CPUNumber> | Indicates which processor the current <PROCESSOR_POWER_INFORMATION> element is describing.
<MaxMhz> | Indicates the maximum frequency of the processor.
<CurrentMhz> | Indicates the current frequency of the processor.
<MhzLimit> | Indicates the current limit on the processor clock frequency.
<MaxIdleState> | Indicates the maximum idle state of the processor.
<CurrentIdleState> | Indicates the current idle state of the processor.

Execution state scenario information

The PwrTest Execution State scenario is designed to log and display thread execution state change events.

Applications and services may temporarily override power management settings such as the monitor and sleep idle time outs by changing their thread execution state. Execution state for a given thread can be changed through the Microsoft Win32 SetThreadExecutionState() API.

The Execution State scenario will display and log in real-time applications and services that are changing their thread execution state. This can be useful to diagnose applications and services that are preventing the monitor or system from going idle.

For more information about the SetThreadExecutionState() API, see SetThreadExecutionState on the MSDN Web site.

To learn more about the Execution State scenario, type:

PwrTest /es /?

The PwrTest /es scenario can be exited by pressing the 'q' key.

NOTE

PwrTest is not capable of determining changes to thread execution state before the Execution State scenario is started.

Argument | Description | Default value
(no arguments) | Not applicable | Not applicable

Examples

PwrTest /es

PwrTest will display and log changes to thread execution state.

XML Logfile Output

The Execution State scenario generates the following XML elements:

<ExecutionState>   <EsChange>   <Time>09:13:47</Time>  <Process>\Device\HarddiskVolume1\Program Files\Windows Media Player\wmplayer.exe</Process>  <RawState>0x80000001</RawState>  <Continuous>TRUE</Continuous>  <System>TRUE</System>  <Display>FALSE</Display>  <AwayMode>FALSE</AwayMode>  </EsChange>   <EsChange>   <Time>09:13:47</Time>  <Process>\Device\HarddiskVolume1\Program Files\Windows Media Player\wmplayer.exe</Process>  <RawState>0x80000003</RawState>  <Continuous>TRUE</Continuous>  <System>TRUE</System>  <Display>TRUE</Display>  <AwayMode>FALSE</AwayMode>  </EsChange>   </ExecutionState>

The following table describes the Execution State scenario XML elements in detail.

Element | Description
<ExecutionState> | Contains information related to the execution state scenario. Only one <ExecutionState> element per PwrTest log file.
<EsChange> | Contains information related a single thread execution state change event. There will be one <EsChange> element for each thread execution state change event recorded in the PwrTest log file.
<Time> | Indicates the time when the execution state change event occurred.
<Process> | Indicates the path to the image file for the process that requested the execution state change.
<RawState> | Indicates the request execution state. This state is a 32-bit value of type EXECUTION_STATE (see Windows.h).
<Continuous> | Indicates if the process requested the execution state change to be continuous (ES_CONTINUOUS).
<System> | Indicates if the process requested the system to be available (ES_SYSTEM_REQUIRED).
<Display> | Indicates if the process requested the display to be available (ES_DISPLAY_REQUIRED).
<AwayMode> | Indicates if the process requested away mode to be enabled (ES_AWAYMODE_REQUIRED).

Command syntax

Command option | Description
Pwrtest.exe /sleep /c:1 /d:90 /p:60 /s:standby /unattend /ln:VMPWR | Runs the OptStandby - Video Memory Purge and Resume test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Pwrtest.exe | <[testbinroot]>\nttest\tools\acpi\pwrtest</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


Overdraw-Underdraw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/193e004f-2d4a-419d-bccb-f9564f1a4364

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Overdraw-Underdraw

  • Overdraw-Underdraw (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Overdraw -M:1 -dx9 -whql -logclean | This command runs the Overdraw-Underdraw test job.
Overdraw -M:1 -whql -logclean | This command runs the Overdraw-Underdraw (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Overdraw.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Overdraw-Underdraw (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01bdd47e-2e48-4788-b69d-6480277b074b

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Overdraw-Underdraw

  • Overdraw-Underdraw (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Overdraw -M:1 -dx9 -whql -logclean | This command runs the Overdraw-Underdraw test job.
Overdraw -M:1 -whql -logclean | This command runs the Overdraw-Underdraw (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Overdraw.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Palettized Textures

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/367a4d35-5ea3-4b00-8396-3e672386abf6

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Palettized Textures (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0933127c-28d7-4bc9-a8a3-8fa636044252

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Palettized Textures

  • Palettized Textures (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Palalpha -M:1 -dx9 -whql -logclean | Runs the Palettized Textures test job.
Palalpha -M:1 -whql -logclean | Runs the Palettized Textures (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Palalpha.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Perspective

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/caf62d02-f7da-4f7b-b742-786ef2f167a9

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Perspective

  • Perspective (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Perspective -M:1 -dx9 -whql -logclean | Runs the Perspective test job.
Perspective.exe -M:1 -whql -logclean | Runs the Perspective (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Perspective.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Perspective (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3bf9440-2dbe-4201-8a0c-303196144b1e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Perspective

  • Perspective (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Perspective -M:1 -dx9 -whql -logclean | Runs the Perspective test job.
Perspective.exe -M:1 -whql -logclean | Runs the Perspective (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Perspective.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Precision

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7e7d722-7a72-4e18-af18-647dbf2ab989

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Pixel Shaders Precision

  • Pixel Shaders Precision (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PSPrecision -M:1 -dx9 -whql -logclean | Runs the Pixel Shaders Precision test job.
PSPrecision -M:1 -whql -logclean | Runs the Pixel Shaders Precision (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
PSPrecision.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Precision (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3a03780-c07b-4247-9755-3c646c203ce6

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Pixel Shaders Precision

  • Pixel Shaders Precision (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PSPrecision -M:1 -dx9 -whql -logclean | Runs the Pixel Shaders Precision test job.
PSPrecision -M:1 -whql -logclean | Runs the Pixel Shaders Precision (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
PSPrecision.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5b420ef-8cf4-48a5-a540-ffcdc74dfd08

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.1 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67175b08-042f-455c-998c-d24bc821610a

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1858565f-9462-489e-8184-eb07046608ba

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.2 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/beafc6d8-040b-49e4-8df6-0237b27f4b0d

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/798146c3-4555-43b0-8672-010ef96095df

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.3 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1842e96e-7e55-469d-9e5f-42c44bb7ec35

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1102980-ed82-4f81-921b-88b6056df6cf

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.4 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2841b98-3894-4755-b59a-9ad8e3007d3d

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.x

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/18c9dd12-0dde-4cdf-8626-4cfe82670c3f

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 1.x (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/566bc1c9-9699-40e1-9bb8-f95e0e7aa3db

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.0

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a95953a-7754-428c-81e7-be3077e12ed0

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.0 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1414007d-3b77-444c-9ccc-55e934439cd1

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.0 Extended

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d302c51d-f705-45f5-a45d-5869e22cdd01

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.0 Extended (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/154655a2-1be2-408f-9e72-01e258358f7e

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.0 Landscape - Starburst

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3dcc4ab3-e19b-4570-8c4f-8462ea4b7383

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.0 Landscape - Starburst (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fbcd81c7-5f9d-4bad-b5b3-5dfbb8eb78f5

This automated test verifies the requirements listed in the test details table.

This test document applies to the following test jobs:

  • Pixel Shaders Ver 1.1

  • Pixel Shaders Ver 1.1 (WoW64)

  • Pixel Shaders Ver 1.2

  • Pixel Shaders Ver 1.2 (WoW64)

  • Pixel Shaders Ver 1.3

  • Pixel Shaders Ver 1.3 (WoW64)

  • Pixel Shaders Ver 1.4

  • Pixel Shaders Ver 1.4 (WoW64)

  • Pixel Shaders Ver 2.0

  • Pixel Shaders Ver 2.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader.exe -Ver:1.1 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.1 test job and the Pixel Shaders Ver 1.1 (WoW64) test job.
Pshader.exe -Ver:1.2 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.2 test job and the Pixel Shaders Ver 1.2 (WoW64) test job.
Pshader.exe -Ver:1.3 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.3 test job and the Pixel Shaders Ver 1.3 (WoW64) test job.
Pshader.exe -Ver:1.4 -M:[Monitor] | This command runs the Pixel Shaders Ver 1.4 test job and the Pixel Shaders Ver 1.4 (WoW64) test job.
Pshader.exe -Ver:2.0 -M:[Monitor] | This command runs the Pixel Shaders Ver 2.0 test job and the Pixel Shaders Ver 2.0 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.x

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/860b00f6-8d3f-4182-83c6-22c2e1fbf965

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 80
Category | Compatibility
Timeout (in minutes) | 4800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 2.x (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5ccd5d74-3e3d-4d6c-9a2e-3412dd024e40

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 80
Category | Compatibility
Timeout (in minutes) | 4800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 3.0

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d90a0516-5fc9-4203-bbea-a8ffd23698b6

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Pixel Shaders Ver 3.0

  • Pixel Shaders Ver 3.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader3.exe -ps30 -ps30_tex -ps30_cube -ps30_vol -M:[Monitor] Pshader3.exe -ps1x -ps1x_tex -ps1x_cube -ps1x_vol -M:[Monitor] [MODIFIEDCMDLINE] | Runs the Pixel Shaders Ver 3.0 (WoW64) test job.
Pshader3.exe -ps30 -ps30_tex -ps30_cube -ps30_vol -M:[Monitor] [MODIFIEDCMDLINE] | Runs the Pixel Shaders Ver 3.0 test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader3.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Pixel Shaders Ver 3.0 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1642b89a-73ac-4718-a4a7-7f3b77b7d474

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Pixel Shaders Ver 3.0

  • Pixel Shaders Ver 3.0 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Pshader3.exe -ps30 -ps30_tex -ps30_cube -ps30_vol -M:[Monitor] Pshader3.exe -ps1x -ps1x_tex -ps1x_cube -ps1x_vol -M:[Monitor] [MODIFIEDCMDLINE] | Runs the Pixel Shaders Ver 3.0 (WoW64) test job.
Pshader3.exe -ps30 -ps30_tex -ps30_cube -ps30_vol -M:[Monitor] [MODIFIEDCMDLINE] | Runs the Pixel Shaders Ver 3.0 test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Pshader3.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Point Sprites

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d35e0fd7-2d8a-42a9-badd-1dc951d5fada

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Point Sprites

  • Point Sprites (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PointSprite -M:1 -dx9 -whql -logclean | This command runs the Point Sprites test job.
PointSprite -M:1 -whql -logclean | This command runs the Point Sprites (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
PointSprite.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Point Sprites (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9ae855d2-9b6d-4ee7-9a84-4ceeeec63b86

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Point Sprites

  • Point Sprites (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PointSprite -M:1 -dx9 -whql -logclean | This command runs the Point Sprites test job.
PointSprite -M:1 -whql -logclean | This command runs the Point Sprites (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
PointSprite.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Preempt - Scheduler WLK Validate non-zero preemption values for WDDM1.2 hardware

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1dd9de6-d5cc-48e5-b889-dd0ce35fd918

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM12.Render.PreemptionGranularity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
SchBillboard.exe Time:5 SyncWith:ABC123HiGirls ProcCount:2 Quadrant:2 | Runs the test job.
SchManager.exe ListenForPreemptionTime EnforcePreemptionSupport:true Time:5 SyncWith:ABC123HiGirls ProcCount:2 Loop:1 windowed:true Quadrant:4 | Runs the support application.

File list

File | Location
Sched_basic.exe | <testbinroot>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <testbinroot>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>


Present Validation (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a78b261-a6d2-4ff6-929c-f5a0f3aa152b

This automated test makes sure that the video card can perform Idirect3Ddevice8::Present() calls correctly in all situations, including stretching, shrinking, and destination window overrides. The test uses a reference image that Microsoft® Direct3DX uses for comparison.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section provides information that is not required for running the test but may be helpful.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64)test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Present2.exe | <[testbinroot]>\nttest</p>
Present.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0a29b8a-8509-47ba-be62-b8ae85e5a7ce

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - ColorConverting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a8d7d4d1-f176-42b2-927f-f5f2a009d433

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - ColorConverting (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbc4b7d8-bf96-47e9-a432-4371dd34137c

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - GammaPresent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0deb0b6-c8e7-4328-ad3b-e56daa2aaf9b

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 11
Category | Compatibility
Timeout (in minutes) | 660
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - GammaPresent (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7055e4c9-f48c-499d-84aa-d385d5ff45ea

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 11
Category | Compatibility
Timeout (in minutes) | 660
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - Present

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b687537f-bbd2-40d7-bc43-ddd9bde29dcf

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 23
Category | Compatibility
Timeout (in minutes) | 1380
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - Present (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/260540b9-a275-4809-ba38-2c77d17b9bc3

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 23
Category | Compatibility
Timeout (in minutes) | 1380
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - Vista

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49aff0d3-b6b9-4579-93d2-85b5a3509c9d

This automated test verifies the new D3DPRESENT_DONOTFLIP option. The driver should skip the Present() method if this option is set.

The test verifies that no presentation occurs when D3DPRESENT_DONOTFLIP is specified. The test first renders with regular Present() and then verifies that the front buffer is not modified when the option is used.

This topic applies to the following test jobs:

  • Present Validation 2 - Vista

  • Present Validation 2 - Vista (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Present2_lh.exe -M:1 -whql -logclean | Runs the Present Validation 2 - Vista test job and the Present Validation 2 - Vista (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Present2_lh.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 - Vista (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68564178-dca2-45d3-aa7e-00c4011d80b8

This automated test verifies the new D3DPRESENT_DONOTFLIP option. The driver should skip the Present() method if this option is set.

The test verifies that no presentation occurs when D3DPRESENT_DONOTFLIP is specified. The test first renders with regular Present() and then verifies that the front buffer is not modified when the option is used.

This topic applies to the following test jobs:

  • Present Validation 2 - Vista

  • Present Validation 2 - Vista (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Present2_lh.exe -M:1 -whql -logclean | Runs the Present Validation 2 - Vista test job and the Present Validation 2 - Vista (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Present2_lh.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 (FullScreen)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d1e82f6-742d-4a49-b11c-0d96c9302127

This automated test verifies that all modes that the EnumAdapterModes method reports for the device are available to applications.

The test uses the following parameters: back buffer format, screen resolution, present intervals, swap effects, and multisample types.

The DoNotWait test calls the swap chain's Present method in a loop, passes the D3DPRESENT_DONOTWAIT option (in full-screen mode), and uses the D3DPRESENT_INTERVAL_ONE value. As a result, the driver's queue of frames will exceed the allowed maximum of three. The DoNotWait test expects the driver to return control to the application by using the D3DERR_WASSTILLDRAWING error code. If the error code is not returned, the test fails.

The LockDoNotWait test is similar to the DoNotWait test but occurs on a surface (the back buffer). The same behavior is expected of the driver. If the error code is not returned, the test fails.

This topic applies to the following test jobs:

  • Present Validation 2 (FullScreen)

  • Present Validation 2 (FullScreen) (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 9
Category | Compatibility
Timeout (in minutes) | 540
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test displays on-screen pass-or-fail compliance and writes the results to a log file that is named Present2.xml. Present2.xml is written to the %windir%\dxlogs directory.

If the call to the Reset method fails, you can check the values that the test used for the back buffer format and size in the log file. If the image comparison fails, the test prints the image-comparison statistics, just like the other Present Validation tests in the group.

The following table lists the image surfaces that the test uses. If you specify the -Save command option, the test saves these files.

File | Location
Texture.dds | The texture that is used to fill the quad that is used in Present operations.
SourceSurface.bmp | The source surface in the back buffer. For full-screen Present operations, this surface is the whole buffer.
DestSurface.bmp | The destination surface in the front buffer. For full-screen Present operations, this surface is the whole buffer.
RefSurface.bmp | The reference surface, as computed by the Microsoft Direct3D API.
DiffSurface.bmp | The difference between the front buffer and the reference image.
FrontBuffer.bmp | The contents of the front buffer.

Command syntax

Command option | Description
Present2_fullscreen.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 (FullScreen) test job.
Present2_fullscreen.exe -M:1 -whql -logclean | Runs the Present Validation 2 (FullScreen) (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Present2_fullscreen.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 (FullScreen) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2e0db44-2ac8-49fb-bf5a-fe321bbfc1a2

This automated test verifies that all modes that the EnumAdapterModes method reports for the device are available to applications.

The test uses the following parameters: back buffer format, screen resolution, present intervals, swap effects, and multisample types.

The DoNotWait test calls the swap chain's Present method in a loop, passes the D3DPRESENT_DONOTWAIT option (in full-screen mode), and uses the D3DPRESENT_INTERVAL_ONE value. As a result, the driver's queue of frames will exceed the allowed maximum of three. The DoNotWait test expects the driver to return control to the application by using the D3DERR_WASSTILLDRAWING error code. If the error code is not returned, the test fails.

The LockDoNotWait test is similar to the DoNotWait test but occurs on a surface (the back buffer). The same behavior is expected of the driver. If the error code is not returned, the test fails.

This topic applies to the following test jobs:

  • Present Validation 2 (FullScreen)

  • Present Validation 2 (FullScreen) (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 9
Category | Compatibility
Timeout (in minutes) | 540
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test displays on-screen pass-or-fail compliance and writes the results to a log file that is named Present2.xml. Present2.xml is written to the %windir%\dxlogs directory.

If the call to the Reset method fails, you can check the values that the test used for the back buffer format and size in the log file. If the image comparison fails, the test prints the image-comparison statistics, just like the other Present Validation tests in the group.

The following table lists the image surfaces that the test uses. If you specify the -Save command option, the test saves these files.

File | Location
Texture.dds | The texture that is used to fill the quad that is used in Present operations.
SourceSurface.bmp | The source surface in the back buffer. For full-screen Present operations, this surface is the whole buffer.
DestSurface.bmp | The destination surface in the front buffer. For full-screen Present operations, this surface is the whole buffer.
RefSurface.bmp | The reference surface, as computed by the Microsoft Direct3D API.
DiffSurface.bmp | The difference between the front buffer and the reference image.
FrontBuffer.bmp | The contents of the front buffer.

Command syntax

Command option | Description
Present2_fullscreen.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 (FullScreen) test job.
Present2_fullscreen.exe -M:1 -whql -logclean | Runs the Present Validation 2 (FullScreen) (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Present2_fullscreen.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Present Validation 2 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d55f876-ff02-4bdd-9e40-74b1d0c9a857

This automated test validates the Present() method.

Specifically, this test performs the following tasks:

  • Shrinks or stretches the height

  • Shrinks or stretches the width

  • Clips to the source area

  • Clips to the destination area

  • Overrides the destination window

The test performs these tasks individually and in combination. It then verifies the resulting output for correctness.

This topic applies to the following test jobs:

  • Present Validation 2

  • Present Validation 2 (WoW64)

  • Present Validation 2 - ColorConverting

  • Present Validation 2 - ColorConverting (WoW64)

  • Present Validation 2 - GammaPresent

  • Present Validation 2 - GammaPresent (WoW64)

  • Present Validation 2 - Present

  • Present Validation 2 - Present (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test is similar to the standard Present Validation test. The difference is that Present Validation 2 resets the device into a state where the back buffer and the front buffer have different formats (if the call to the CheckDeviceFormatConversion method was successful). The test performs a comparison with a reference image that the Microsoft Direct3D API generates. The driver must perform the color conversion between those two formats. (Direct3D does not perform any software emulation.)

This test uses the IDirect3DSwapChain9::Present method with the D3DPRESENT_LINEAR_CONTENT option.

If the driver supports gamma presentation (that is, the driver exposes the D3DCAPS3 capabilities option D3DCAPS3_LINEAR_TO_SRGB_PRESENTATION), a gamma-corrected presentation should occur. This test verifies the correct output by post-processing the reference image via gamma 2.2 correction. If the driver claims that gamma presentation is not supported, the test verifies that no gamma correction occurs.

The test performs the following tasks:

  • Scales the color channels to [0..1)

  • Calculates Channel = pow( Channel, 1 / Gamma )

  • Scales the result back to int [0..256)

WARNING

Gamma presentation is supported only on a desktop that has a 32-bit color depth.

Command syntax

Command option | Description
Present2.exe -M:1 -dx9 -whql -logclean | Runs the Present Validation 2 test job.
Present2.exe -M:1 -whql -logclean | Runs the Present Validation 2 (WoW64) test job.
Present2.exe -ColorConverting -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - ColorConverting test job and the Present Validation 2 - ColorConverting (WoW64) test job.
Present2.exe -GammaPresent -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - GammaPresent test job and the Present Validation 2 - GammaPresent (WoW64) test job.
Present2.exe -Present -src:ref -M:1 -whql -logclean | Runs both the Present Validation 2 - Present test job and the Present Validation 2 - Present (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
MONITOR | Display device to test
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Primitive Batching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/43af6c6d-5ac7-40f6-9990-a4ad866a6359

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Primitive Batching

  • Primitive Batching (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Batch -M:1 -dx9 -whql -logclean | Runs the Primitive Batching test job.
Batch -M:1 -whql -logclean | Runs the Primitive Batching (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Batch.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Primitive Batching (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3238e0e-747b-412d-95f4-14fa45beda0c

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Primitive Batching

  • Primitive Batching (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Batch -M:1 -dx9 -whql -logclean | Runs the Primitive Batching test job.
Batch -M:1 -whql -logclean | Runs the Primitive Batching (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Batch.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Ratetest (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17ee2eaf-9b21-4e07-bb5e-9f32f4fe33ac

This automated test verifies that the video card hardware supports a resolution of 800 × 600 pixels, a color depth of 16 bits per pixel (bpp), a 16-bit Z buffer, double frame buffering, and a 75-Hertz (Hz) refresh rate in full-screen 3-D graphics mode.

The test switches to all enumerated Graphics Device Interface (GDI) display modes, all available low-resolution GDI modes (less than 640 × 480 pixels), and enumerated Microsoft® DirectDraw full-screen modes. The test then intersects these two sets of modes and validates that the set of Microsoft DirectX® enumerated modes exists in the set of GDI enumerated modes.

The test switches to these modes and validates that the refresh rate actually produced by the card matches the refresh rate that the driver indicates. The test validates the refresh rate by using IDirectDraw::GetVerticalBlankStatus. After each mode is set, the test displays an MS-DOS window to make sure that virtualization of VGA hardware works correctly for each mode.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

WARNING

The Super VGA (SVGA)-compatible monitor that is attached to the system that you are testing must support the minimum display resolution and refresh rate that were specified earlier.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The test first verifies the requirements in software by querying the DirectDraw capabilities. Then, it verifies the requirements in hardware by selecting the specified settings and displaying a predefined scene. The following steps describe the process in detail:

  1. The test creates a DirectDraw object with the DirectDrawCreate function by using the DDCREATE_HARDWAREONLY option. This action forces a HAL device to be used, instead of a HEL device.

  2. By using the DirectDraw IDirectDraw4:EnumDisplayModes function, the test verifies the following values in the DDSURFACEDESC2 structure as valid choices:

    • dwWidth = 800 (dwWidth = 640 for mobile systems)

    • dwHeight = 600 (dwHeight = 480 for mobile systems)

    • dwRefreshRate = 75 (or 0 for drivers that do not report this value)

  3. The DDPIXELFORMAT structure verifies that the following are valid choices:

    • dwRGBBitCount = 16

    • dwZBufferBitDepth = 16

  4. The SetCooperativeLevel function selects the DDSCL_EXCLUSIVE and DDSCL_FULLSCREEN options.

  5. The test calls SetDisplayMode to set the display to 800 × 600 × 16 and the refresh rate to 75 Hz. If the 75-Hz value fails, the test uses a refresh-rate value of 0 (default).

  6. The test calls CreateSurface for the primary surface, the back buffer, and the Z buffer.

  7. The test calls the Direct3D CreateDevice function by using the IID_IDirect3DHALDevice class identifier to allow access to the 3-D graphics hardware device.

  8. All other 3-D graphics tests that are specified use a double-buffered surface to verify compliance with the requirement for double frame buffering.

The test application displays and logs a pass-or-fail indication of compliance with this requirement. Any of the device setup steps in the preceding list can generate failures. Any detected failure generates additional information that clearly identifies the noncompliant issue.

Command Syntax

Command option | Description
Ratetest | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Dxgfilterua.dll | <[testbinroot]>\nttest\windowstest\graphics\tests\gdi</p>
Ntlog.dll | <[testbinroot]>\nttest\Commontest\ntlog
Ratetest.exe | <[testbinroot]>\nttest\windowstest\graphics\tests\gdi
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | The name of your machine's LLU
MONITOR | Display Number to run test against.
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


RenderOnly SetupAPI Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25860314-0969-42d5-92ae-34665277069f

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.WDDM12.RenderOnly.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


RenderOnly Swapchain Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd05d2c6-d00c-4c92-85e4-d94a813dba5b

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.WDDM12.RenderOnly.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


Set All Preferred Display Modes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/081cc631-dc97-4931-9f04-cf4374080ac2

Confirm preferred display modes can be set successfully

Test details
Specifications
  • Device.Graphics.WDDM23.CoreRequirement
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Set Display Modes with Scaling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4afbd75a-0142-4e24-bcf1-9a87be2c1805

Confirm display modes can be set successfully with scaling

Test details
Specifications
  • Device.Graphics.WDDM23.CoreRequirement
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Set Display Modes with two paths

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/577a5d27-e4c5-461a-8a2f-1596ec3081a4

Confirm display modes can be set successfully on two paths

Test details
Specifications
  • Device.Graphics.WDDM23.CoreRequirement
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Set None Preferred Display Modes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea39c47e-2ef7-4ab9-9918-e78cee2babad

Confirm non-preferred display modes can be set successfully

Test details
Specifications
  • Device.Graphics.WDDM23.CoreRequirement
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 0
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    More Information

    Parameters

    Parameter Name | Parameter Description

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Set Render Target

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abf14d99-8e42-4586-b52f-583a199e6203

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Set Render Target

  • Set Render Target (WoW64)

  • Set Render Target 2-10-10-10

  • Set Render Target 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Srt -M:1 -dx9 -whql -logclean | Runs the Set Render Target test job.
Srt -M:1 -whql -logclean | Runs the Set Render Target (WoW64) test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Set Render Target 2-10-10-10 test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Set Render Target 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Srt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Set Render Target (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e2dbfadf-6187-4f22-bd54-a0389c3f18b2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Set Render Target

  • Set Render Target (WoW64)

  • Set Render Target 2-10-10-10

  • Set Render Target 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Srt -M:1 -dx9 -whql -logclean | Runs the Set Render Target test job.
Srt -M:1 -whql -logclean | Runs the Set Render Target (WoW64) test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Set Render Target 2-10-10-10 test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Set Render Target 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Srt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Set Render Target 2-10-10-10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/39d13b39-d30b-4384-9ba6-08d9ff856ac8

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Set Render Target

  • Set Render Target (WoW64)

  • Set Render Target 2-10-10-10

  • Set Render Target 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Srt -M:1 -dx9 -whql -logclean | Runs the Set Render Target test job.
Srt -M:1 -whql -logclean | Runs the Set Render Target (WoW64) test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Set Render Target 2-10-10-10 test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Set Render Target 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Srt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Set Render Target 2-10-10-10 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7ae3d34-0add-4501-a6ea-f2fb975e2752

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Set Render Target

  • Set Render Target (WoW64)

  • Set Render Target 2-10-10-10

  • Set Render Target 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Srt -M:1 -dx9 -whql -logclean | Runs the Set Render Target test job.
Srt -M:1 -whql -logclean | Runs the Set Render Target (WoW64) test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | Runs the Set Render Target 2-10-10-10 test job.
Srt -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | Runs the Set Render Target 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Srt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


SimulatePreemption TDR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/86be5032-cfcd-4ee5-a515-0e3ebc0cb6f4

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterBase.SubsystemResettable
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.


SimulateVSync TDR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ccb45a50-ea07-42f0-9f0b-2105e453f8ae

[This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterBase.SubsystemResettable
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.


State Blocks

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14c48a85-5543-4bae-a2af-267d47db6c64

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • State Blocks

  • State Blocks (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Stateblocks -M:1 -dx9 -whql -logclean | Runs the State Blocks test job.
Stateblocks -M:1 -whql -logclean | Runs the State Blocks (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Stateblocks.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


State Blocks (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fae09503-36dd-48f6-be4a-11da345fab9f

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • State Blocks

  • State Blocks (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Stateblocks -M:1 -dx9 -whql -logclean | Runs the State Blocks test job.
Stateblocks -M:1 -whql -logclean | Runs the State Blocks (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Stateblocks.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Stencil

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/91b17e1f-81b1-4bd0-869d-8daafd88e999

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Stencil

  • Stencil (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Stencil (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/afeb4aa3-eef6-478b-a964-fdc31521bd3a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Stencil

  • Stencil (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Stretch Rect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a41ed4db-937f-4fe6-a9bd-0bcef993e8c3

This automated test verifies correct implementation of the driver functionality that underlies the IDirect3DDevice9::StretchRect method.

The Stretch Rect test uses the IDirect3D9::CheckDeviceFormat method to determine the combinations of formats and surface types that the driver supports. It also uses the IDirect3D9::CheckDeviceFormatConversion method to determine the color-conversion operations that the driver supports.

For all valid surface-type combinations, the test performs a comprehensive set of StretchRect operations. These operations include those that involve stretching, color conversion, and copies to or from a subset rectangle (subrect). In these test cases, the source surface may be a texture surface (RT or non-RT), an off-screen render target, or an off-screen plain surface. The destination must be a render target or an RT texture surface.

Under D3D9L, the test also considers a more comprehensive set of source and destination surface-type combinations: Each surface may be a non-RT texture surface, an RT texture surface, an off-screen RT, or an off-screen plain surface. All sixteen combinations are tested. However, in compliance with D3D9L specifications, the StretchRect operations are limited to those that involve only full-surface copies without stretching or color conversion.

The test accomplishes automatic verification by rendering both the destination surface and a reference surface and comparing the rendered images. The test uses the LoadSurfaceFromSurface function in D3DX9 to prepare reference images.

This topic applies to the following test jobs:

  • Stretch Rect

  • Stretch Rect (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Stretchrect.exe -M:1 -dx9 -whql -logclean | Runs the Stretch Rect test job.
stretchrect.exe -M:1 -whql -logclean | Runs the Stretch Rect (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Stretchrect.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Stretch Rect (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79ab98d5-862a-4cc6-9c85-346cac8ed7fe

This automated test verifies correct implementation of the driver functionality that underlies the IDirect3DDevice9::StretchRect method.

The Stretch Rect test uses the IDirect3D9::CheckDeviceFormat method to determine the combinations of formats and surface types that the driver supports. It also uses the IDirect3D9::CheckDeviceFormatConversion method to determine the color-conversion operations that the driver supports.

For all valid surface-type combinations, the test performs a comprehensive set of StretchRect operations. These operations include those that involve stretching, color conversion, and copies to or from a subset rectangle (subrect). In these test cases, the source surface may be a texture surface (RT or non-RT), an off-screen render target, or an off-screen plain surface. The destination must be a render target or an RT texture surface.

Under D3D9L, the test also considers a more comprehensive set of source and destination surface-type combinations: Each surface may be a non-RT texture surface, an RT texture surface, an off-screen RT, or an off-screen plain surface. All sixteen combinations are tested. However, in compliance with D3D9L specifications, the StretchRect operations are limited to those that involve only full-surface copies without stretching or color conversion.

The test accomplishes automatic verification by rendering both the destination surface and a reference surface and comparing the rendered images. The test uses the LoadSurfaceFromSurface function in D3DX9 to prepare reference images.

This topic applies to the following test jobs:

  • Stretch Rect

  • Stretch Rect (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Stretchrect.exe -M:1 -dx9 -whql -logclean | Runs the Stretch Rect test job.
stretchrect.exe -M:1 -whql -logclean | Runs the Stretch Rect (WoW64) test job.
NOTE

For command-line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Stretchrect.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Subpixel Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ed1c94e-d32c-432c-a2c3-6ab0afed1d1a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Subpixel Texture

  • Subpixel Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Subpixel -M:1 -dx9 -whql -logclean | Runs the Subpixel Texture test job.
Subpixel -M:1 -whql -logclean | Runs the Subpixel Texture (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Subpixel.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Subpixel Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4670d50-79d8-47d3-a5c5-2ebdfaef0469

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Subpixel Texture

  • Subpixel Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Subpixel -M:1 -dx9 -whql -logclean | Runs the Subpixel Texture test job.
Subpixel -M:1 -whql -logclean | Runs the Subpixel Texture (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Subpixel.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a1f4090-38e2-4b2b-a82f-c2d8d610b6ea

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM12.Display.Base
  • Device.Graphics.WDDM12.DisplayOnly.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


TDR2 - Large Payload Penalty Compute Application Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4dea15f0-ac8a-4535-bb8f-2316d75f773e

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Large Payload Penalty Graphics Application Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0dc780e-5a71-45c1-8dce-93ba311cf16c

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Compute Packet Expect NO TDR (Interactive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7fb1fa3e-d6ce-42bc-b9c6-c24ba1255616

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Compute Packet Expect NO TDR (Interactive, PoliceDdi)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5442f83-eb40-421d-a4a2-682d3cf0a495

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Compute Packet Expect TDR (Interactive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/366d25c0-9e10-4644-b57c-643f0d5f273c

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Compute Packet Expect TDR (NonInteractive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a62a186-4a45-4d8d-ae57-86b63d9cb036

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f5f0483-62a9-42d6-ae37-ebda3ffd3413

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c53f986-ee9f-4717-850c-dfe1a3e5a65c

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d41d1929-ca3f-4967-87c9-e388988b2650

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive, PoliceDdi)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd226bb7-2f8f-4cf5-87bf-9d9bd1f3c4f3

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Graphics Packet Expect TDR (Interactive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0f06bc3-82d6-4000-8057-9fa2549c473a

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5b547fa-a7df-4492-b1d7-207c4930fbf6

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f11a1533-35bb-42fe-b67c-31a825679574

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3872a37e-f42b-4482-88a7-d0ef941c8326

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19b0c579-036f-411b-8c15-882388657f28

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba2fa618-d344-4c90-bd27-f52459c236f6

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50353b03-236f-4cd0-ae30-34523342d769

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83406522-6127-4bd1-8ae5-809556767703

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/575d868d-b89a-48f7-b356-1c9f8c371a6f

This automated test measures the Timeout Detection and Recovery (TDR) capabilities of the graphics processing unit (GPU) of a video card or chipset.

This topic applies to these test jobs:

  • TDR2 - Large Payload Penalty Compute Application Test

  • TDR2 - Large Payload Penalty Graphics Application Test

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7)

  • TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi)

  • TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter)

  • TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter)

  • TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets

  • TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.TDRResiliency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

The TDR2 test validates that the video driver functions correctly when GPU workloads, as direct memory access (DMA) packets, are processed for longer periods than expected or wanted.

Terms that you'll find in the titles of the jobs for this test include:

  • Interactive (standard behavior). The application doesn't schedule larger workloads. TDRs (at 2 seconds) are expected if the workload is too big.

  • NonInteractive (new functionality). The application may schedule workloads that take longer than 2 seconds to finish. A typical scenario here is a Compute application that will run a large calculation in the background. With NonInteractive workloads, the scheduler will not interrupt its processing if no other GPU work must be performed at the same time.

  • PoliceDdi. When resets occur, the test jobs track all device driver interface (DDI) calls to measure a reasonable responsiveness from the driver and hardware. Generally, DDI calls that take over a quarter second are flagged as excessive.

These test jobs also exercise engine-reset functionality where appropriate. The older TDR functionality performed an adapter-wide reset, whereas the new TDR functionality attempts an engine reset before an adapter-wide reset.

The testing process requires running multiple binaries at the same time. One or more applications generate workloads while another application monitors the effect that these workloads have on the system. The command lines that the test jobs use to start the applications allow for cross-process communication, so running the test jobs in scripts is the preferred technique.

NOTE

You must run all test jobs by using administrator credentials. All the test binaries generate log files that shouldn't contain test failures.

Command syntax

TDR2 test jobs are divided into these areas:

  • Long Running Graphics Packet test jobs

  • Long Running Compute Packets test jobs

  • Multiple TDR Lockout and Recovery test jobs

  • Uninterrupted Application test job

  • Large Payload Penalty test jobs

  • Miscellaneous test job

Scripts control actions that occur during individual test jobs. The following tables list these scripts. If you're manually reproducing the test jobs, you must run these scripts.

NOTE

For test combination command lines, see individual script files.

The following Long Running Graphics Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also make sure that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7) | TDR_Long_Graphics_5.cmd
TDR2 - Long Running Graphics Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Graphics_6.cmd
TDR2 - Long Running Graphics Packet Expect TDR (Interactive - win7) | TDR_Long_Graphics_1.cmd
TDR2 - Long Running Graphics Packet Expect TDR (NonInteractive - win8) | TDR_Long_Graphics_2.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi) | TDR_Long_Graphics_3.cmd
TDR2 - Long Running Graphics Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Graphics_4.cmd

The following Long Running Compute Packet test jobs run test situations that should and shouldn't cause a TDR, based on whether the test acts like an interactive application. These test jobs also validate that DDI calls respond in a reasonable amount of time.

Test job | Command script
TDR2 - Long Running Compute Packet Expect TDR (Interactive - win7) | TDR_Long_Compute_1.cmd
TDR2 - Long Running Compute Packet Expect TDR (NonInteractive - win8) | TDR_Long_Compute_2.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi) | TDR_Long_Compute_3.cmd
TDR2 - Long Running Compute Packet Expect TDR (PoliceDdi, NonInteractive) | TDR_Long_Compute_4.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7, PoliceDdi) | TDR_Long_Compute_5.cmd
TDR2 - Long Running Compute Packet Expect NO TDR (Interactive - win7) | TDR_Long_Compute_6.cmd

In the following Multiple TDR Lockout and Recovery test jobs, the application runs workloads that cause a TDR. The test jobs then validate that after 6 TDRs in a particular period, the application can no longer open the hardware device.

Test job | Command script
TDR2 - Multiple TDR Compute Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_4.cmd
TDR2 - Multiple TDR Compute Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_3.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (Enumerated Adapter) | TDR_Multiple_2.cmd
TDR2 - Multiple TDR Graphics Lockout and Recovery Test (NULL Adapter) | TDR_Multiple_1.cmd

The following Uninterrupted Application test job makes sure that when an engine reset occurs, an application that currently has the device open continues to function without a device lost.

Test job | Command script
TDR2 - Standard Two Device Test Graphics (Uninterrupted when another app TDRs) | TDR_Standard_1.cmd

The following Large Payload Penalty test jobs run workloads that are just under the TDR threshold. The test jobs validate that the scheduler correctly delays the application.

Test job | Command script
TDR2 - Large Payload Penalty Compute Application Test | TDR_Large_Payload_Compute.cmd
TDR2 - Large Payload Penalty Graphics Application Test | TDR_Large_Payload_Graphics.cmd

The following Miscellaneous test job validates that the driver sets appropriate flags.

Test job | Command script
TDR2 - Scheduler WLK Validate WDDM1.2 drivers say they support per engine resets | TDR_Validate_WDDM12.cmd

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DxgFault.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchBillboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
SchManager.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
Surfboard.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>
TdrKMDODTests.dll | <[testbinroot]>\nttest</p>
WGFPayloadTDR.exe | <[testbinroot]>\nttest\WINDOWSTEST\Graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
PREEMPTION_LEVEL | requested preemption level. Either: none, dma_buffer, primitive, triangle, pixel, shader
SCRIPT_NAME |


Tessellation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/292b2f57-fbc8-4cac-8211-7135760b09c2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Tessellation

  • Tessellation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Tessellation -M:1 -dx9 -whql -logclean | Runs the Tessellation test job.
Tessellation -M:1 -whql -logclean | Runs the Tessellation (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Tessellation.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Tessellation (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e6920e8-b4ba-49fa-8c8b-8711d8fe4199

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Tessellation

  • Tessellation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Tessellation -M:1 -dx9 -whql -logclean | Runs the Tessellation test job.
Tessellation -M:1 -whql -logclean | Runs the Tessellation (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Tessellation.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Test CreateDecodeSwapChain For CompositionSurfaceHandle (Native)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df4356cf-8556-46ac-965c-d6a63f1d9665

This test case verifies that content rendered by a swap chain created with CreateDecodeSwapChainForCompositionSurfaceHandle is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateDecodeSwapChain For CompositionSurfaceHandle (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bcc341aa-f043-4cfd-b417-8ffaae7168f3

This test case verifies that content rendered by a swap chain created with CreateDecodeSwapChainForCompositionSurfaceHandle is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateSwapChain (Native)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85978b6f-70ce-4ff1-8c53-825f1fe54608

This test case verifies that content rendered by a swap chain created with CreateSwapChain is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateSwapChain (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89c9f115-3218-4009-8c91-aa8881825c78

This test case verifies that content rendered by a swap chain created with CreateSwapChain is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateSwapChain For CompositionSurfaceHandle (Native)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48efe820-9334-4676-9504-b02ca99d8427

This test case verifies that content rendered by a swap chain created with CreateSwapChainForCompositionSurfaceHandle is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateSwapChain For CompositionSurfaceHandle (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79419659-4ab2-4f95-97c2-585ff47bbab5

This test case verifies that content rendered by a swap chain created with CreateSwapChainForCompositionSurfaceHandle is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateSwapChainForHwnd (Native)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84d3569c-71d5-4598-a29d-9d98308373d1

This test case verifies that content rendered by a swap chain created with CreateSwapChainForHwnd is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test CreateSwapChainForHwnd (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9ebb8466-c491-44cf-8dbc-7c5b8bebbef3

This test case verifies that content rendered by a swap chain created with CreateSwapChainForHwnd is correct.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.MultiPlaneOverlaySupport
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test for Custom Presentation Duration Precision (Native)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a433077-8026-4feb-9287-9fc02cdff78a

This test verifies that a system which supports custom presentation durations precisely honors a specified duration.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.48HzVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test for Custom Presentation Duration Precision (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fcf3e81e-8fdc-4d46-80e0-2195ac218938

This test verifies that a system which supports custom presentation durations precisely honors a specified duration.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.48HzVideoPlayback
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test for Custom Presentation Duration Support (Native)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d14cbdb9-bb12-42f6-80bd-1a98a7793742

This test verifies whether the system reports support for custom presentation durations.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.48HzVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Test for Custom Presentation Duration Support (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62cbf58c-c18f-499c-af47-8261aab8f4e1

This test verifies whether the system reports support for custom presentation durations.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.48HzVideoPlayback
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestDefrag

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd3884bb-7936-4c96-af9e-7881344161f6

Small, Mid and Large sized Allocations - Defragment Mode

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestEngineReset

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b30d551-660c-4ff6-bf89-d71f6cba6537

Verifies that GPU correctly resets 3D engine when receiving workloads longer than 2 seconds.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
  • Device.Graphics.WDDM12.Render.EngineReset
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestEviction

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1aab3335-869d-47a0-9966-e3303334b01c

Small, Mid and Large sized Allocations

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestFlipModes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3612c39c-5ce5-4533-9f52-19d5e9f7ae49

Verifies that the GPU scheduler presents using expected flip modes (DFlip, IFlip, etc.)

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestHighPriorityOverLowPriority

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/43e4f30b-0d9b-4083-947e-7ee36592acd5

Verifies that the GPU scheduler finishes higher priority workload before lower priority workload

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestPreemptionGranularity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7772c094-51e5-4d6b-8064-3c15e246e9e4

Determines GPU preemption granularity.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
  • Device.Graphics.WDDM12.Render.PreemptionGranularity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


TestTransfer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec15b0f4-7185-4160-abe1-21cb4ce2f2cb

Small, Mid and Large sized Allocations - Transfer Mode

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Texture Address

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4acfb806-3448-4d13-a2e1-577c8ecba243

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Address

  • Texture Address (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Address -M:1 -dx9 -whql -logclean | This command runs the Texture Address test job.
Address -M:1 -whql -logclean | This command runs the Texture Address (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Address.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Address (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c2f9376-d81c-4b68-9e2c-9a7c043a8099

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Address

  • Texture Address (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Address -M:1 -dx9 -whql -logclean | This command runs the Texture Address test job.
Address -M:1 -whql -logclean | This command runs the Texture Address (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Address.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Blend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50c5be44-4682-4405-a715-8a6593beb8d4

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Blend

  • Texture Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blend -M:1 -dx9 -whql -logclean | Runs the Texture Blend test job.
Blend -M:1 -whql -logclean | Runs the Texture Blend (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Blend.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Blend (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca9c25c7-3e6f-4dd7-9ce0-611bac65e2d0

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Blend

  • Texture Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blend -M:1 -dx9 -whql -logclean | Runs the Texture Blend test job.
Blend -M:1 -whql -logclean | Runs the Texture Blend (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Blend.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture ColorKey (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5617a4b9-4042-47f9-a303-343766a39fb4

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Colorkey -M:1 -whql -logclean | This command runs the Texture ColorKey (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Colorkey.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Coordinate Generation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12a23b32-cea4-49e5-8b9c-2c811471e3e9

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Coordinate Generation

  • Texture Coordinate Generation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
TexGen -M:1 -dx9 -whql -logclean | Runs the Texture Coordinate Generation test job.
TexGen -M:1 -whql -logclean | Runs the Texture Coordinate Generation (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TexGen.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Coordinate Generation (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c87798fb-55d8-4f94-be96-4b6821880d76

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Coordinate Generation

  • Texture Coordinate Generation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
TexGen -M:1 -dx9 -whql -logclean | Runs the Texture Coordinate Generation test job.
TexGen -M:1 -whql -logclean | Runs the Texture Coordinate Generation (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TexGen.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Filter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd9ef49b-6cb8-4cdc-b15b-ee61591b276a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Filter

  • Texture Filter (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Filter -M:1 -dx9 -whql -logclean | Runs the Texture Filter test job.
Filter -M:1 -whql -logclean | Runs the Texture Filter (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Filter.exe | <[testbinroot]>\nttest
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Filter (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2931d148-9605-4f12-be66-f7e0321eeb8f

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Filter

  • Texture Filter (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Filter -M:1 -dx9 -whql -logclean | Runs the Texture Filter test job.
Filter -M:1 -whql -logclean | Runs the Texture Filter (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Filter.exe | <[testbinroot]>\nttest
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Formats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ddc97f27-3fa8-4472-8f85-fd24cf5db314

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Formats

  • Texture Formats (WoW64)

  • Texture Formats 2-10-10-10

  • Texture Formats 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Texformats -M:1 -dx9 -whql -logclean | This command runs the Texture Formats test job.
Texformats -M:1 -whql -logclean | This command runs the Texture Formats (WoW64) test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | This command runs the Texture Formats 2-10-10-10 test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | This command runs the Texture Formats 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Texformats.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Formats (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/737f5d8d-9cf6-42bb-abbf-06ef06887b9d

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Formats

  • Texture Formats (WoW64)

  • Texture Formats 2-10-10-10

  • Texture Formats 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Texformats -M:1 -dx9 -whql -logclean | This command runs the Texture Formats test job.
Texformats -M:1 -whql -logclean | This command runs the Texture Formats (WoW64) test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | This command runs the Texture Formats 2-10-10-10 test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | This command runs the Texture Formats 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Texformats.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Formats 2-10-10-10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea6c2a37-502f-4522-a429-957f7d4daad3

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Formats

  • Texture Formats (WoW64)

  • Texture Formats 2-10-10-10

  • Texture Formats 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Texformats -M:1 -dx9 -whql -logclean | This command runs the Texture Formats test job.
Texformats -M:1 -whql -logclean | This command runs the Texture Formats (WoW64) test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | This command runs the Texture Formats 2-10-10-10 test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | This command runs the Texture Formats 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Texformats.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Formats 2-10-10-10 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbea3fce-5776-4660-9b89-ccfebbdf88e2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Formats

  • Texture Formats (WoW64)

  • Texture Formats 2-10-10-10

  • Texture Formats 2-10-10-10 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Texformats -M:1 -dx9 -whql -logclean | This command runs the Texture Formats test job.
Texformats -M:1 -whql -logclean | This command runs the Texture Formats (WoW64) test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -dx9 -whql -logclean | This command runs the Texture Formats 2-10-10-10 test job.
Texformats -dx9 -winmode:full -displaymode:800x600xA2R10G10B10 -M:1 -whql -logclean | This command runs the Texture Formats 2-10-10-10 (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Texformats.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Gradient

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47d29d9f-4cba-4b77-a185-5c9cf3f9d1ab

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Gradient

  • Texture Gradient (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gradient -M:1 -dx9 -whql -logclean | This command runs the Texture Gradient test job.
Gradient -M:1 -whql -logclean | This command runs the Texture Gradient (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Gradient.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Gradient (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96894e70-5fb6-48c7-9183-3a5f048a4c9d

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Gradient

  • Texture Gradient (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Gradient -M:1 -dx9 -whql -logclean | This command runs the Texture Gradient test job.
Gradient -M:1 -whql -logclean | This command runs the Texture Gradient (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Gradient.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Load (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db33ec2f-bcc3-46c5-bb7c-7433c3f24562

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
TexLoad.exe -M:1 -whql -logclean | Runs the test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
TexLoad.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Mapping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d920056-e1ee-4db6-a633-b4a70070d91e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Mapping

  • Texture Mapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mapping -M:1 -dx9 -whql -logclean | This command runs the Texture Mapping test job.
Mapping -M:1 -whql -logclean | This command runs the Texture Mapping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mapping.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Mapping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d675422c-c6f8-4136-8171-17bbe5d06802

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Mapping

  • Texture Mapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Mapping -M:1 -dx9 -whql -logclean | This command runs the Texture Mapping test job.
Mapping -M:1 -whql -logclean | This command runs the Texture Mapping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Mapping.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Stage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c214d595-79c9-4915-8cd7-e18df580087a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Stage

  • Texture Stage (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 40
Category | Compatibility
Timeout (in minutes) | 2400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Texturestage3 -M:1 -dx9 -whql -logclean | Runs the Texture Stage test job.
Texturestage3 -M:1 -whql -logclean | Runs the Texture Stage (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Texturestage3.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Stage (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8651271b-b3b1-4987-8528-896e77f0fac2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Stage

  • Texture Stage (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 40
Category | Compatibility
Timeout (in minutes) | 2400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Texturestage3 -M:1 -dx9 -whql -logclean | Runs the Texture Stage test job.
Texturestage3 -M:1 -whql -logclean | Runs the Texture Stage (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Texturestage3.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Transforms

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/254bf22f-e81b-4ad2-95a7-0d1d0a37df0b

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Transforms

  • Texture Transforms (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
LightBall -M:1 -dx9 -whql -logclean | Runs the Texture Transforms test job.
LightBall -M:1 -whql -logclean | Runs the Texture Transforms (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
LightBall.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Texture Transforms (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a15c9b6-f9e4-41d9-93eb-b06a55974d43

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Texture Transforms

  • Texture Transforms (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
LightBall -M:1 -dx9 -whql -logclean | Runs the Texture Transforms test job.
LightBall -M:1 -whql -logclean | Runs the Texture Transforms (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
LightBall.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


TL Vertex Clipping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e27e0c0c-3eb4-4f1d-a5ea-3c4ba9406499

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • TL Vertex Clipping

  • TL Vertex Clipping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Tlvertexclip -M:1 -dx9 -whql -logclean | Runs the TL Vertex Clipping test job.
Tlvertexclip -M:1 -whql -logclean | Runs the TL Vertex Clipping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Tlvertexclip.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


TL Vertex Clipping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4e7ab39-4442-4f70-9a04-6ccbe660e9cb

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • TL Vertex Clipping

  • TL Vertex Clipping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Tlvertexclip -M:1 -dx9 -whql -logclean | Runs the TL Vertex Clipping test job.
Tlvertexclip -M:1 -whql -logclean | Runs the TL Vertex Clipping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Tlvertexclip.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Update Surface

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3032590-9d6b-47a3-ad4e-5b0186aee89d

This automated test verifies correct implementation of the driver functionality that underlies the IDirect3DDevice9::UpdateSurface method.

The test uses the IDirect3D9::CheckDeviceFormat method to determine the combinations of formats and surface types that the driver supports.

For all valid surface-type combinations, the test performs a comprehensive set of UpdateSurface operations. These operations include full surface and subrect copies, with and without translation.

The test accomplishes automatic verification by rendering both the destination surface and a reference surface and comparing the rendered images. The test uses the LoadSurfaceFromSurface function in Microsoft® Direct3D® 9 to prepare reference images.

This topic applies to the following test jobs:

  • Update Surface

  • Update Surface (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Updatesurface.exe -M:1 -dx9 -whql -logclean | Runs the Update Surface test job.
Updatesurface.exe -M:1 -whql -logclean | Runs the Update Surface (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Updatesurface.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Update Surface (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f21e7ba-d946-47eb-9c33-60fe1fb05bc5

This automated test verifies correct implementation of the driver functionality that underlies the IDirect3DDevice9::UpdateSurface method.

The test uses the IDirect3D9::CheckDeviceFormat method to determine the combinations of formats and surface types that the driver supports.

For all valid surface-type combinations, the test performs a comprehensive set of UpdateSurface operations. These operations include full surface and subrect copies, with and without translation.

The test accomplishes automatic verification by rendering both the destination surface and a reference surface and comparing the rendered images. The test uses the LoadSurfaceFromSurface function in Microsoft® Direct3D® 9 to prepare reference images.

This topic applies to the following test jobs:

  • Update Surface

  • Update Surface (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Updatesurface.exe -M:1 -dx9 -whql -logclean | Runs the Update Surface test job.
Updatesurface.exe -M:1 -whql -logclean | Runs the Update Surface (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Updatesurface.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Update Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bac38823-8d93-410d-a637-a31be5c1038d

This automated test verifies device capabilities to load textures (such as mipmap or cubemap) from system memory to video memory by using the UpdateTexture function.

The test includes the following scenarios:

  • The entire texture is loaded.

  • A portion of the texture is loaded.

  • The source and destination textures are square or non-square.

  • The source and destination textures have different levels.

The test first creates a source texture in the system memory and a destination texture in the video memory, and it populates these surfaces with data. Second, the test prepares the source texture; that is, it makes the entire texture dirty, and it makes a portion of the texture dirty. Finally, the test calls UpdateTexture to load the texture and checks the destination texture to make sure that it is loaded correctly.

This topic applies to the following test jobs:

  • Update Texture

  • Update Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Updatetexture.exe -M:1 -dx9 -whql -logclean | Runs the Update Texture test job.
Updatetexture.exe -M:1 -whql -logclean | Runs the Update Texture (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Updatetexture.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Update Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5717e1a-cfa5-4e80-95f9-a36bbf3e33d7

This automated test verifies device capabilities to load textures (such as mipmap or cubemap) from system memory to video memory by using the UpdateTexture function.

The test includes the following scenarios:

  • The entire texture is loaded.

  • A portion of the texture is loaded.

  • The source and destination textures are square or non-square.

  • The source and destination textures have different levels.

The test first creates a source texture in the system memory and a destination texture in the video memory, and it populates these surfaces with data. Second, the test prepares the source texture; that is, it makes the entire texture dirty, and it makes a portion of the texture dirty. Finally, the test calls UpdateTexture to load the texture and checks the destination texture to make sure that it is loaded correctly.

This topic applies to the following test jobs:

  • Update Texture

  • Update Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Updatetexture.exe -M:1 -dx9 -whql -logclean | Runs the Update Texture test job.
Updatetexture.exe -M:1 -whql -logclean | Runs the Update Texture (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Updatetexture.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


VM D3D12 - Clear Depth Stencil Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84497cea-67e4-445a-bef1-88e57800df36

Creates a resource with matching-mismatching depth-stencil values and verifies clear results

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM D3D12 - CommandAllocator Reset Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26fa615b-4392-4076-a412-574d92c66cf3

CommandAllocator Reset Test

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM D3D12 - CommandList Destruction Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63f82ecb-c93f-4bdb-b212-f8714bdf3258

Bundle conformance test. Verifies whether the device-driver support bundles correctly.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM D3D12 - Indirect Draw - Draw Indexed test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03e35556-27c7-4afc-a51a-edb842ef49e8

Test indirect draw conformance.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM D3D12 - Resource Binding - Basic API Index Vertex

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53066e22-9c65-4a3d-b6d5-b084ed01242e

Test basic binding API functionality and conformance by drawing a quad that uses an index buffer and a vertex buffer.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM D3D12 - SetViewportsTest test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1521ac1-7df8-4592-8a2d-6154f2e95d1d

SetViewportsTest test VM

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM DX11 VideoProcessing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e8e652f-a837-4659-b454-28c3590bc85e

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Compatibility
Timeout (in minutes) | 420
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
CMDLINE | Command line alteration for specific logging or test case specification.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM DXGI Frame Statistics

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/296527d0-9019-454b-b2b4-f07c6aa0e06c

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM DXGI Presentation testing - WinpresentMS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93406026-0400-4271-847d-21ec80948035

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM Run Dxgkrnl Smasher MITM module

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e730e88c-527f-474e-b722-4e02ee73a5a8

This job runs the interception fuzzer.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 130
Category | Development
Timeout (in minutes) | 7800
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
LLU_NetAccessOnly | TEX OFFICIAL Windows LLU: Net Access Only on machine - contact texeng with questions
OSBinRoot | Base of the bins.
OSTestAutomation | Base of the scripts.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM Texture Blend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b47aeb96-8d0d-44d6-bc64-22e50daedffb

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM Vertex Shaders

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f62cd44-f3a8-4717-96ca-9887333e9e60

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 16
Category | Compatibility
Timeout (in minutes) | 960
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM - OfferReclaim11 - Basic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5b73868-dab1-4094-8557-f7fd8dc71340

Verifies basic offer and reclaim usage on the D3D11 runtime.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM2 - Make Resident - Verify Standard Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9050b320-285c-48c0-bb8f-58796639083b

Verifies that MakeResident and Evict are properly implemented by the driver, and that the corresponding usage request changes are detected by kernel.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM2 - OfferReclaim12 - Basic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38f18467-ded5-48c1-bb9b-356a56136ac1

This test verifies WDDM 2.0 offer reclaim functionality in Direct3D 12 in a paravirtualized vm.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM2 - Page Fault Test - Induce Fault 11 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3c405d6-7715-4cb5-8531-1fb58001297e

Verifies that the hardware and DX11 driver support and can recover from page faults caused by accessing invalid GPU virtual addresses.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM2 - Page Fault Test - Induce Fault 12 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1e0f25d-fd63-486e-a6c4-f03c28dfe116

Verifies that the hardware and DX12 driver support and can recover from page faults caused by accessing invalid GPU virtual addresses.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM2 - Page Fault Test - Induce Fault 9 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b8d802ea-efc9-47eb-837a-7d064b330abd

Verifies that the hardware and DX9 driver support and can recover from page faults caused by accessing invalid GPU virtual addresses.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WDDM2.2 Periodic frame notification - Precision at various point of the VSync interval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/270fecac-b6f0-40c8-9b1e-cfa053c4f8f4

Schedules notifications that are at various points of the VSync interval to make sure precision is consistent.

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF Create Device

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f53eac5-cdec-4873-a25b-2899bba0a121

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF Feature Level 9.3 Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62fee9a0-e8da-4112-b464-9524aebb6865

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
ExecutableLocation |
ExecutableBinary |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Draw (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82c9c1d6-5209-4aef-929a-a42b585193a6

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDArgs | /get or /sets

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Pixel Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d99d57ad-ad79-47c4-a0d8-5c280c2440b7

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Rasterizer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8d3ec5d-dcb9-49d9-97ee-6b2ac1693646

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Render Targets (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f415371d-f400-4900-9206-94f13a129817

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Resource Access (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1ecdaf3-1d0a-4130-a5bf-6720e4f7e496

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Shader 5x (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cf8abf3-f885-487f-9307-129282e2f0c6

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 SharedResources (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e423608-7615-4f65-910d-6d39cd4bbb5e

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


VM WGF11 Viewports

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7de916ec-4f29-4861-9c35-671818c698c0

Test details
Specifications
  • Device.Graphics.WDDM24.AdapterRender.Paravirtualized.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Validate 3D content runs on 3D Engine

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff468052-1946-47c4-959a-74a191ae4f09

Test will check dma packet usage is in line with engine meta data description using ETW events

Test details
Specifications
  • Device.Graphics.WDDM13.Render.GPUNode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Validate Copy content runs on Copy Engine

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff498052-1946-47c4-959a-74a1c1ae4f09

Test will check dma packet usage is in line with engine meta data description using ETW events

Test details
Specifications
  • Device.Graphics.WDDM13.Render.GPUNode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Validate Decode content runs on Decode Engine

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff478052-1946-47c4-959a-74a1a1ae4f09

Test will check dma packet usage is in line with engine meta data description using ETW events

Test details
Specifications
  • Device.Graphics.WDDM13.Render.GPUNode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Validate Engine Meta Data Basic Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff458052-1946-47c4-959a-74a181ae4f09

Test will check for adpater engine meta data using ETW events

Test details
Specifications
  • Device.Graphics.WDDM13.Render.GPUNode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Validate Video Processing Content runs on Video Processing Engine

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff488052-1946-47c4-959a-74a1b1ae4f09

Test will check dma packet usage is in line with engine meta data description using ETW events

Test details
Specifications
  • Device.Graphics.WDDM13.Render.GPUNode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 4
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


VBIB - Vertex and Index Buffer Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78ce31bc-f6b5-46b4-8a4c-2f0b6ed8a6af

This automated test validates the use of a variety of vertex and index buffers.

This test contains following test groups, which test vertex and index buffers in different ways:

  • Buffer makes sure that simple objects can be rendered correctly.

  • LockActive makes sure that a selected vertex or index buffer can be rendered from, and locked across, multiple scenes and in one scene.

  • Priority makes sure that a selected vertex or index buffer can have its priority manipulated while it renders a scene.

  • SwitchRenderState ensures correct operation when switching between hardware and software vertex processing during a scene.

  • LostOnReset makes sure that all buffers must be released before a Reset()function will succeed.

  • HugeBuffer makes sure that a large object can be rendered correctly.

  • RelockDynamic makes sure that dynamic vertex and index buffers can be reused correctly in a single scene.

  • LockPointerAlias makes sure that, when a device is lost, pointers to vertex and index buffers that are obtained through the Lock() function do not cause exceptions.

  • InternalPointerAlias makes sure that, when a device is lost, internal buffer pointers do not cause exceptions (such as during calls to the DrawPrimitive() or DrawIndexedPrimitive() function).

This topic applies to the following test jobs:

  • VBIB - Vertex and Index Buffer Validation

  • VBIB - Vertex and Index Buffer Validation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Compatibility
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
VBIB.exe -M:1 -dx9 -whql -logclean | Runs the VBIB - Vertex and Index Buffer Validation test job.
VBIB.exe- Vertex and Index Buffer Validation (WoW64) | Runs the VBIB - Vertex and Index Buffer Validation (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
VBIB.exe | <[testbinroot]>\nttest
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


VBIB - Vertex and Index Buffer Validation (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2747ed28-ba6b-4e8e-82bd-7cf61abb9109

This automated test validates the use of a variety of vertex and index buffers.

This test contains following test groups, which test vertex and index buffers in different ways:

  • Buffer makes sure that simple objects can be rendered correctly.

  • LockActive makes sure that a selected vertex or index buffer can be rendered from, and locked across, multiple scenes and in one scene.

  • Priority makes sure that a selected vertex or index buffer can have its priority manipulated while it renders a scene.

  • SwitchRenderState ensures correct operation when switching between hardware and software vertex processing during a scene.

  • LostOnReset makes sure that all buffers must be released before a Reset()function will succeed.

  • HugeBuffer makes sure that a large object can be rendered correctly.

  • RelockDynamic makes sure that dynamic vertex and index buffers can be reused correctly in a single scene.

  • LockPointerAlias makes sure that, when a device is lost, pointers to vertex and index buffers that are obtained through the Lock() function do not cause exceptions.

  • InternalPointerAlias makes sure that, when a device is lost, internal buffer pointers do not cause exceptions (such as during calls to the DrawPrimitive() or DrawIndexedPrimitive() function).

This topic applies to the following test jobs:

  • VBIB - Vertex and Index Buffer Validation

  • VBIB - Vertex and Index Buffer Validation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Compatibility
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
VBIB.exe -M:1 -dx9 -whql -logclean | Runs the VBIB - Vertex and Index Buffer Validation test job.
VBIB.exe- Vertex and Index Buffer Validation (WoW64) | Runs the VBIB - Vertex and Index Buffer Validation (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
VBIB.exe | <[testbinroot]>\nttest
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Verifies that the kernel blocklist returns correct information

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ffaca64-cddd-448d-89e3-e02fbb0f4692

Verifies that the kernel blocklist returns correct information

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Verifies that the runtime blocklist returns correct information

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de55283e-0119-49f5-a230-e552f3cd4ef4

Verifies that the runtime blocklist returns correct information

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Verify run from driver store support and file versioning (Graphics Drivers)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67db7078-b8b7-4b13-8e60-408dd807fe42

This test verifies that driver versioning is consisent between driver files and the INF, and confirms that driver files are in the expected location in the driver store. Make sure the driver to test is installed, and execute this test via TAEF.

Test details
Specifications
  • Device.Graphics.AdapterBase.DriverVersion
  • Device.Graphics.AdapterBase.RunFromDriverStore
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Verify VESA and CEA required display modes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f62f2b44-53c1-4110-a35e-55b61e52fa22

This automated test checks the monitor and ensures that the adapter exposes all of the appropriate display modes.

Test details
Specifications
  • System.Fundamentals.Graphics.Display.MinimumResolutionandColorDepth
  • Device.Graphics.WDDM12.Display.ModeEnumeration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.


VerifyDefaults

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee52fd89-3fa1-4fc4-b93a-1944f9190d26

Validates default values of QueryVideoMemoryInfo API

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


VerifyReservation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/42263e16-5bd6-4f6a-b549-883e43832fef

Validates getting/setting reservation functionality of QueryVideoMemoryInfo API

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


VerifySurpriseRemoval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db1c302e-7290-452b-a097-d8df4f7ce6ea

Tests whether driver supports surprise removal for detachable GPUs.

Test details
Specifications
  • Device.Graphics.WDDM25.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


Vertex Blending

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/868d4f07-07bc-4417-9306-127029bc422e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Blending

  • Vertex Blending (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Ball -M:1 -dx9 -whql -logclean | Runs the Vertex Blending test job.
Ball -M:1 -whql -logclean | Runs the Vertex Blending (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Ball.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Blending (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0dbdf07-6d77-4dd9-b719-588125388f19

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Blending

  • Vertex Blending (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Ball -M:1 -dx9 -whql -logclean | Runs the Vertex Blending test job.
Ball -M:1 -whql -logclean | Runs the Vertex Blending (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Ball.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Buffer Rendering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c1de8f7-767f-4ff1-8a01-3c2c05414438

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Buffer Rendering

  • Vertex Buffer Rendering (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Vbbatch -M:1 -dx9 -whql -logclean | Runs the Vertex Buffer Rendering test job.
Vbbatch -M:1 -whql -logclean | Runs the Vertex Buffer Rendering (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbbatch.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Buffer Rendering (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1ef95dc-9673-4be5-9677-63d51ae61b97

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Buffer Rendering

  • Vertex Buffer Rendering (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Vbbatch -M:1 -dx9 -whql -logclean | Runs the Vertex Buffer Rendering test job.
Vbbatch -M:1 -whql -logclean | Runs the Vertex Buffer Rendering (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbbatch.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Buffer Swapping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4909c405-a67a-40b2-854f-029abe3fee83

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Buffer Swapping

  • Vertex Buffer Swapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Vbswap -M:1 -dx9 -whql -logclean | Runs the Vertex Buffer Swapping test job.
Vbswap -M:1 -whql -logclean | Runs the Vertex Buffer Swapping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Buffer Swapping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab1d6a1d-6f04-4caa-a52f-5e32a4a58175

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Buffer Swapping

  • Vertex Buffer Swapping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Vbswap -M:1 -dx9 -whql -logclean | Runs the Vertex Buffer Swapping test job.
Vbswap -M:1 -whql -logclean | Runs the Vertex Buffer Swapping (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.exe | <[testbinroot]>\nttest</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Formats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8488814-4ef6-4fe1-8d47-09130e9609a9

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Formats

  • Vertex Formats (WoW64)

  • Vertex Formats- TnL

  • Vertex Formats- TnL (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Fvf -rast -M:1 -dx9 -whql -logclean | Runs the Vertex Formats test job.
Fvf -rast -M:1 -whql -logclean | Runs the Vertex Formats (WoW64) test job.
Fvf -M:1 -dx9 -whql -logclean | Runs the Vertex Formats- TnL test job.
Fvf -M:1 -whql -logclean | Runs the Vertex Formats- TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Fvf.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Formats (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ced3b48d-b5f2-4984-bf58-0f44df1bb164

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Formats

  • Vertex Formats (WoW64)

  • Vertex Formats- TnL

  • Vertex Formats- TnL (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Fvf -rast -M:1 -dx9 -whql -logclean | Runs the Vertex Formats test job.
Fvf -rast -M:1 -whql -logclean | Runs the Vertex Formats (WoW64) test job.
Fvf -M:1 -dx9 -whql -logclean | Runs the Vertex Formats- TnL test job.
Fvf -M:1 -whql -logclean | Runs the Vertex Formats- TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Fvf.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Formats- TnL

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2eaa57e-4577-426c-8dce-006b8c7c82d2

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Formats

  • Vertex Formats (WoW64)

  • Vertex Formats- TnL

  • Vertex Formats- TnL (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Fvf -rast -M:1 -dx9 -whql -logclean | Runs the Vertex Formats test job.
Fvf -rast -M:1 -whql -logclean | Runs the Vertex Formats (WoW64) test job.
Fvf -M:1 -dx9 -whql -logclean | Runs the Vertex Formats- TnL test job.
Fvf -M:1 -whql -logclean | Runs the Vertex Formats- TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Fvf.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Formats- TnL (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3af20855-2618-4f22-80c7-7b6f511fe00e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Formats

  • Vertex Formats (WoW64)

  • Vertex Formats- TnL

  • Vertex Formats- TnL (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Fvf -rast -M:1 -dx9 -whql -logclean | Runs the Vertex Formats test job.
Fvf -rast -M:1 -whql -logclean | Runs the Vertex Formats (WoW64) test job.
Fvf -M:1 -dx9 -whql -logclean | Runs the Vertex Formats- TnL test job.
Fvf -M:1 -whql -logclean | Runs the Vertex Formats- TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Fvf.exe | <[testbinroot]>\nttest</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Shaders

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d80c5633-8738-4aa0-bd3f-1f09c8aa4850

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Shaders

  • Vertex Shaders (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 16
Category | Compatibility
Timeout (in minutes) | 960
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
VShader -M:1 -dx9 -whql -logclean | Runs the Vertex Shaders test job
VShader -M:1 -whql -logclean | Runs the Vertex Shaders (WoW64) test job
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
VShader.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Shaders (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5615845e-b402-4052-8183-945d098a6be1

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Shaders

  • Vertex Shaders (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 16
Category | Compatibility
Timeout (in minutes) | 960
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
VShader -M:1 -dx9 -whql -logclean | Runs the Vertex Shaders test job
VShader -M:1 -whql -logclean | Runs the Vertex Shaders (WoW64) test job
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
VShader.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Shaders Precision

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/643bdc78-b946-4ef2-a8a2-462bd337dd7f

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Shaders Precision

  • Vertex Shaders Precision (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
VSPrecision -M:1 -dx9 -whql -logclean | Runs the Vertex Shaders Precision test job.
VSPrecision -M:1 -whql -logclean | Runs the Vertex Shaders Precision (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
VSPrecision.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Shaders Precision (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/91be2068-7ae3-4612-8f4d-aea2a3a405cc

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Shaders Precision

  • Vertex Shaders Precision (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
VSPrecision -M:1 -dx9 -whql -logclean | Runs the Vertex Shaders Precision test job.
VSPrecision -M:1 -whql -logclean | Runs the Vertex Shaders Precision (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
VSPrecision.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Tweening

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79b681e1-5203-466e-bd84-000df76a6590

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Tweening

  • Vertex Tweening (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Vertextween -M:1 -dx9 -whql -logclean | Runs the Vertex Tweening test job.
Vertextween -M:1 -whql -logclean | Runs the Vertex Tweening (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Vertextween.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Vertex Tweening (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f20e03e1-bf70-4b32-8fdd-beb24a99ca85

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Vertex Tweening

  • Vertex Tweening (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Vertextween -M:1 -dx9 -whql -logclean | Runs the Vertex Tweening test job.
Vertextween -M:1 -whql -logclean | Runs the Vertex Tweening (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Vertextween.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Viewport Clipping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/29817085-3e0d-4eb6-ba44-32c9b05385f7

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Viewport Clipping

  • Viewport Clipping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Clipping -M:1 -dx9 -whql -logclean | Runs the Viewport Clipping test case.
Clipping -M:1 -whql -logclean | Runs the Viewport Clipping (WoW64) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Clipping.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Viewport Clipping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad6b6627-4531-40c6-a2b8-2c8f6b87df36

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Viewport Clipping

  • Viewport Clipping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Clipping -M:1 -dx9 -whql -logclean | Runs the Viewport Clipping test case.
Clipping -M:1 -whql -logclean | Runs the Viewport Clipping (WoW64) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Clipping.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Volume Texture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9d64411-8a32-4b50-8a6a-fb38505265c0

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Volume Texture

  • Volume Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Volume -M:1 -dx9 -whql -logclean | Runs the Volume Texture test case.
Volume -M:1 -whql -logclean | Runs the Volume Texture (WoW64) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Volume.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Volume Texture (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0e6cf9a-0271-4968-a1c8-b9f7b10f2019

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Volume Texture

  • Volume Texture (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Volume -M:1 -dx9 -whql -logclean | Runs the Volume Texture test case.
Volume -M:1 -whql -logclean | Runs the Volume Texture (WoW64) test case.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Volume.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


W Buffer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/212cb5f3-c7ec-4039-9033-70c8aeac22ce

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • W Buffer

  • W Buffer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wbuffer -M:1 -dx9 -whql -logclean | Runs the W Buffer test case.
Wbuffer -M:1 -whql -logclean | Runs the W Buffer (WoW64) test case.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wbuffer.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


W Buffer (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5a0fbf9-2880-4660-aeb2-21672e7f66b5

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • W Buffer

  • W Buffer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wbuffer -M:1 -dx9 -whql -logclean | Runs the W Buffer test case.
Wbuffer -M:1 -whql -logclean | Runs the W Buffer (WoW64) test case.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wbuffer.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


W Compare

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5043c2ab-f237-464a-93f7-647fcbf65fc7

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • W Compare

  • W Compare (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wcmp -M:1 -dx9 -whql -logclean | Runs the W Compare test job.
Wcmp -M:1 -whql -logclean | Runs the W Compare (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wcmp.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


W Compare (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad1035ad-22c0-4ebc-ba00-75f26101231a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • W Compare

  • W Compare (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wcmp -M:1 -dx9 -whql -logclean | Runs the W Compare test job.
Wcmp -M:1 -whql -logclean | Runs the W Compare (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wcmp.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM - OfferReclaim11 - Decommit Force Decommit Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a2eca9d-bb73-4df0-9da4-7bafc02a2558

Validates the use of the verifier flag used to force allocations to be decommitted on reclaim.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - OfferResources1 ReclaimResources1 API Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be2ace5c-8ea2-4f53-a8ae-07b3156b2105

Validates the semantics of the new Offer and Reclaim APIs exposed via IDXGIDevice5.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Cancel on mode change - CPU wait

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a292326-507f-4cc6-952a-ab243ee86d26

Schedules periodic frame notification, changes mode, expects notification to be canceled/destroyed.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Cancel on mode change - GPU wait

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90b5803c-9d32-4990-8484-154d06191ba9

Schedules periodic frame notification, changes mode, expects notification to be canceled/destroyed.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Multiple frames ahead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d697c545-5d71-4a7d-b297-396ffb0bbc19

Schedules periodic frame notification multiple frames ahead and ensures it gets fired with the right fence value.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Precision at various point of the VSync interval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd947917-4c21-4d14-a4fe-855d9ae4072d

Schedules notifications that are at various points of the VSync interval to make sure precision is consistent.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Precision of simultaneous notifications at various point of the VSync interval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb051089-ae45-4140-952d-7aff7ed8aa32

Schedules multiple simultaneous notifications that are at various points of the VSync interval to make sure precision is consistent.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Test Invalid Parameters

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48e5c819-281a-4943-b42f-086bb99cb645

Tests for invalid parameters.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Very close to each other

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/745897bf-f3de-471e-b3fa-ef964d6f19c9

Schedules notifications that are only one scan line apart from each other and makes sure both are signaled correctly.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.2 Periodic frame notification - Very close to the VSync boundary

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ec77129-3d2e-4aa5-92e4-28147025fdc7

Schedules notifications that are scheduled to be very close to the VSync boundary.

Test details
Specifications
  • Device.Graphics.WDDM22.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.4 Mandatory Caps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05a86c55-9c50-4050-8932-30f951d72709

Tests whether mandatory WDDM2.4+ caps are set.

Test details
Specifications
  • Device.Graphics.WDDM24.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.5 Universal ApiValidator Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3ecc3b9-ff6b-4741-a535-172576c34dbc

Tests if WDDM2.5 drivers are compliant with the universal api

Test details
Specifications
  • Device.Graphics.WDDM25.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Graphics additional documentation


WGF11 Async (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cfa25576-4f48-48f8-939d-52b2b36a7fc4

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Blend (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aff7ae8a-d197-458d-83a6-6417b85fd02d

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Clipping (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a0c11a4-35bc-4595-90c3-1b25e3c627b5

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Compute Shader (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/729ffb57-4275-49b4-a724-feb4a9b9f368

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Depth Stencil (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48d08dc1-6f5d-4c18-bd9c-c23c6f1748c9

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Draw (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6948dc6e-8c2b-4524-b367-009c82c5a37a

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDArgs | /get or /sets

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Fill Rules (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48ebe70d-178a-49cb-b231-ff8109993852

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Filter (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/af38a996-be30-42d5-8047-58e56e713735

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Input Assembler (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abf8ccb0-9d0b-44a8-a38d-2a221d9dc20d

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Multisample (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b41ba94-e4a6-4605-be45-33a540381e58

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D10Multisampling4X.D3D10CoreA
  • Device.Graphics.AdapterRender.D3D10Multisampling8X.D3D10CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Render Targets (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df67dfa2-ec7f-4197-8b1d-52d61c166ed4

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Resource Access (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba049d62-525a-4934-b2eb-804418ca0614

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Shader 5x (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5ba5ee56-d0b0-4634-9f44-74a3ee7d3907

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 SharedResources (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e52db5d-17bd-4b0f-9958-2b4cc36cb76d

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Streamout (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f22bf91-8914-428d-856b-5fab5b750b9d

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF11 Tessellation (subset)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63b99777-39b4-48b6-80b1-56aa0e7eafef

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Wait For VBlank

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a8c0ab2f-b093-4b42-9808-3a0a7525e389

This automated test verifies correct driver implementation of the vertical blank synchronization functionality that underlies the implementation of the IDirect3DDevice9Ex::WaitForVBlank method.

The test automatically runs against several display modes. For each mode, the test determines the expected interval between consecutive vertical retrace periods, based on the mode's refresh rate. It then performs 101 calls to the WaitForVBlank function and measures the 100 intervals between the return times. Each interval is expected to be comparable to the interval that the test predicted via the refresh rate. The test reports a failure if more than 10 percent of the intervals differ from the expected interval by more than 2 milliseconds.

This topic applies to the following test jobs:

  • Wait For VBlank

  • Wait For VBlank (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Waitvbl.exe -M:1 -dx9 -whql -logclean | Runs the Wait For VBlank test job.
Waitvbl.exe -M:1 -whql -logclean | Runs the Wait For VBlank (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Waitvbl.exe | <[testbinroot]>\nttest

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Wait For VBlank (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/743e78bc-2f86-43a4-b8b5-d8e46cc758b7

This automated test verifies correct driver implementation of the vertical blank synchronization functionality that underlies the implementation of the IDirect3DDevice9Ex::WaitForVBlank method.

The test automatically runs against several display modes. For each mode, the test determines the expected interval between consecutive vertical retrace periods, based on the mode's refresh rate. It then performs 101 calls to the WaitForVBlank function and measures the 100 intervals between the return times. Each interval is expected to be comparable to the interval that the test predicted via the refresh rate. The test reports a failure if more than 10 percent of the intervals differ from the expected interval by more than 2 milliseconds.

This topic applies to the following test jobs:

  • Wait For VBlank

  • Wait For VBlank (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Waitvbl.exe -M:1 -dx9 -whql -logclean | Runs the Wait For VBlank test job.
Waitvbl.exe -M:1 -whql -logclean | Runs the Wait For VBlank (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Waitvbl.exe | <[testbinroot]>\nttest

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM - OfferReclaim11 - Allocation States Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d5b4d74-e980-49d3-b028-a1b385bce3cc

Verifies offer and reclaim functionality when the allocation is in various residency states.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - API Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a853968-6829-4c8f-abf6-f52ebd27e294

Validates the semantics of the Offer and Reclaim APIs.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Basic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aa6034f0-dd6e-4f3e-9cc9-bdb120858226

Verifies basic offer and reclaim usage on the D3D11 runtime.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Decommit Full Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b8ae4ae0-0d42-467e-a162-7cc3b4a9f3a7

Performs a non-lazy full trim pass to decommit all trimmable memory in the process.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Decommit Lazy Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0cd81293-7b1a-4ee0-aa2d-8ac426e7e7fc

Performs a lazy full trim pass to decommit all trimmable memory in the process, ensuring that all memory is decommitted over multiple passes.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Decommit Null Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/286c5b7e-0bc2-4840-9e20-00797f88961a

Offers allocations without the ALLOW_DECOMMIT flag and performs a trim pass to ensure that the allocation is not decommitted.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Decommit Partial Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c26b6333-1d8f-4cad-bc0e-3b78a32fbae7

Performs a non-lazy partial trim pass to decommit a subset of trimmable memory in the process.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Decommit Query Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/86f44b59-33bd-4dae-9eae-3152282f5c9a

Validates that the new private decommit query function returns expected results based on the amount of offered contents

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Decommit Repurposed Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2563ce56-2d8f-4410-ae9a-524c111522d0

Performs a non-lazy full trim pass to decommit all trimmable memory in the process which has already been repurposed by the NT memory manager.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Lower Commit Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/657eabbd-93de-4743-8416-55d2f18e51d3

Offers and decommits allocations with a trimming pass and verifies the total system commit is lower.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Offer States Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/900d862e-17aa-4cc4-8db0-7af105aedaec

Verifies offer and reclaim functionality when the allocation is in various offered states, and then uses the allocation in various ways to ensure that proper behavior is observed.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Reclaim Failure Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0948246a-c00f-4f9c-81c9-1f3305a77d9d

Trims decommittable memory from a process and then verifies that the proper information is reported from the API for memory which could not be recommitted.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM - OfferReclaim11 - Shared Allocation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66eed799-d2a0-465d-9089-ca176bbc2bcb

Verifies offer and reclaim usage with shared allocations.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM Bit Flip - Invalid Param Fifth Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0733e4af-8b45-496f-bf9e-d427e1cb551d

This automated test checks the stability of invalid parameters. It verifies that kernel-mode video drivers correctly validate command buffers and private driver data that is passed from user mode.

The test runs in the layer between the user-mode video driver and the kernel-mode video driver. The test intercepts calls from user mode to kernel mode. It then modifies the data that is associated with these calls. Kernel-mode video drivers must be robust enough to handle invalid parameters that come from any user-mode module without crashing or hanging.

This topic applies to the following test jobs:

  • WDDM Bit Flip - Invalid Param First Group

  • WDDM Bit Flip - Invalid Param Second Group

  • WDDM Bit Flip - Invalid Param Third Group

  • WDDM Bit Flip - Invalid Param Fourth Group

  • WDDM Bit Flip - Invalid Param Fifth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BitFlip.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BitFlip.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Bit Flip - Invalid Param First Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8c8edb5-1b7a-4db2-bea8-961aa3eb547d

This automated test checks the stability of invalid parameters. It verifies that kernel-mode video drivers correctly validate command buffers and private driver data that is passed from user mode.

The test runs in the layer between the user-mode video driver and the kernel-mode video driver. The test intercepts calls from user mode to kernel mode. It then modifies the data that is associated with these calls. Kernel-mode video drivers must be robust enough to handle invalid parameters that come from any user-mode module without crashing or hanging.

This topic applies to the following test jobs:

  • WDDM Bit Flip - Invalid Param First Group

  • WDDM Bit Flip - Invalid Param Second Group

  • WDDM Bit Flip - Invalid Param Third Group

  • WDDM Bit Flip - Invalid Param Fourth Group

  • WDDM Bit Flip - Invalid Param Fifth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 50
Category | Compatibility
Timeout (in minutes) | 3000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BitFlip.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BitFlip.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Bit Flip - Invalid Param Fourth Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89b84b1d-56ad-47e2-ac6c-528a35588ef3

This automated test checks the stability of invalid parameters. It verifies that kernel-mode video drivers correctly validate command buffers and private driver data that is passed from user mode.

The test runs in the layer between the user-mode video driver and the kernel-mode video driver. The test intercepts calls from user mode to kernel mode. It then modifies the data that is associated with these calls. Kernel-mode video drivers must be robust enough to handle invalid parameters that come from any user-mode module without crashing or hanging.

This topic applies to the following test jobs:

  • WDDM Bit Flip - Invalid Param First Group

  • WDDM Bit Flip - Invalid Param Second Group

  • WDDM Bit Flip - Invalid Param Third Group

  • WDDM Bit Flip - Invalid Param Fourth Group

  • WDDM Bit Flip - Invalid Param Fifth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BitFlip.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BitFlip.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Bit Flip - Invalid Param Second Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fdf29686-93e7-46dd-83c3-84848098c17a

This automated test checks the stability of invalid parameters. It verifies that kernel-mode video drivers correctly validate command buffers and private driver data that is passed from user mode.

The test runs in the layer between the user-mode video driver and the kernel-mode video driver. The test intercepts calls from user mode to kernel mode. It then modifies the data that is associated with these calls. Kernel-mode video drivers must be robust enough to handle invalid parameters that come from any user-mode module without crashing or hanging.

This topic applies to the following test jobs:

  • WDDM Bit Flip - Invalid Param First Group

  • WDDM Bit Flip - Invalid Param Second Group

  • WDDM Bit Flip - Invalid Param Third Group

  • WDDM Bit Flip - Invalid Param Fourth Group

  • WDDM Bit Flip - Invalid Param Fifth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BitFlip.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BitFlip.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Bit Flip - Invalid Param Third Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d39721a-fafd-4fb9-869d-c2b8e69c1fce

This automated test checks the stability of invalid parameters. It verifies that kernel-mode video drivers correctly validate command buffers and private driver data that is passed from user mode.

The test runs in the layer between the user-mode video driver and the kernel-mode video driver. The test intercepts calls from user mode to kernel mode. It then modifies the data that is associated with these calls. Kernel-mode video drivers must be robust enough to handle invalid parameters that come from any user-mode module without crashing or hanging.

This topic applies to the following test jobs:

  • WDDM Bit Flip - Invalid Param First Group

  • WDDM Bit Flip - Invalid Param Second Group

  • WDDM Bit Flip - Invalid Param Third Group

  • WDDM Bit Flip - Invalid Param Fourth Group

  • WDDM Bit Flip - Invalid Param Fifth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BitFlip.exe | Runs the test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BitFlip.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Blt

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3a9aab0-484b-44b9-8e0e-c8873f2b4797

This automated test is a stability test for the user-mode Device Driver Interface (DDI) for bit-block transfer (bitblt).

This test verifies system stability when the system is performing valid surface bitblt operations for video and system memory. The test performs surface bitblts between a variety of surface types and memory pools. Longhorn Display Driver Model (LDDM) drivers must not crash in user mode or kernel mode during the test.

This topic applies to the following test jobs:

  • WDDM Blt

  • WDDM Blt (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe monitor:1 | Runs the WDDM Blt test job and the WDDM Blt (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt - Depth

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81e6d771-cd68-452a-a065-1ebd60f2f526

This automated test verifies that drivers are stable when they perform bit-block transfers (bitblts) to and from system memory surfaces that have depth/stencil formats.

In particular, this test creates a video memory depth buffer of a supported format. It then creates a system memory lockable depth buffer and instructs the driver to perform a bitblt between them. The driver must not crash or hang during the test.

This topic applies to the following test jobs:

  • WDDM Blt - Depth

  • WDDM Blt - Depth (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe DepthBlt | Runs the WDDM Blt - Depth test job and the WDDM Blt - Depth (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt - Depth (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55627af7-086a-48c4-8c19-dc98d327a69a

This automated test verifies that drivers are stable when they perform bit-block transfers (bitblts) to and from system memory surfaces that have depth/stencil formats.

In particular, this test creates a video memory depth buffer of a supported format. It then creates a system memory lockable depth buffer and instructs the driver to perform a bitblt between them. The driver must not crash or hang during the test.

This topic applies to the following test jobs:

  • WDDM Blt - Depth

  • WDDM Blt - Depth (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe DepthBlt | Runs the WDDM Blt - Depth test job and the WDDM Blt - Depth (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt - DepthFill

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9fb4aa59-8486-467b-9431-05a5640d460d

This automated test validates that drivers correctly implement the DepthFill Device Driver Interface (DDI).

In particular, the test creates depth-stencil surfaces for video memory and instructs the user-mode driver to fill them with a value. The driver must not crash or hang during the test. Additionally, the driver must not fail the DepthFill DDI call.

This topic applies to the following test jobs:

  • WDDM Blt - DepthFill

  • WDDM Blt - DepthFill (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe DepthFill | Runs the WDDM Blt - DepthFill test job and the WDDM Blt - DepthFill (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt - DepthFill (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad8cb91c-16c1-4ef0-a29b-97a4e371ecc5

This automated test validates that drivers correctly implement the DepthFill Device Driver Interface (DDI).

In particular, the test creates depth-stencil surfaces for video memory and instructs the user-mode driver to fill them with a value. The driver must not crash or hang during the test. Additionally, the driver must not fail the DepthFill DDI call.

This topic applies to the following test jobs:

  • WDDM Blt - DepthFill

  • WDDM Blt - DepthFill (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe DepthFill | Runs the WDDM Blt - DepthFill test job and the WDDM Blt - DepthFill (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt - Stretch

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08480dda-2719-47be-903f-da19e6ca479d

This automated test verifies that user-mode video drivers correctly implement stretching bit-block transfer (bitblt) operations.

The test creates two surfaces and uses the user-mode Blt Device Driver Interface (DDI) to transfer data between them. The test instructs drivers to perform stretching blts between the two surfaces. The source surface can exist in system memory while the destination exists in video memory. User-mode drivers must not crash or cause the Blt DDI call to fail during the test.

This topic applies to the following test jobs:

  • WDDM Blt - Stretch

  • WDDM Blt - Stretch (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe Stretch | Runs the WDDM Blt - Stretch test job and the WDDM Blt - Stretch (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt - Stretch (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90e50d12-d324-4e27-af4e-131285514e8e

This automated test verifies that user-mode video drivers correctly implement stretching bit-block transfer (bitblt) operations.

The test creates two surfaces and uses the user-mode Blt Device Driver Interface (DDI) to transfer data between them. The test instructs drivers to perform stretching blts between the two surfaces. The source surface can exist in system memory while the destination exists in video memory. User-mode drivers must not crash or cause the Blt DDI call to fail during the test.

This topic applies to the following test jobs:

  • WDDM Blt - Stretch

  • WDDM Blt - Stretch (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe Stretch | Runs the WDDM Blt - Stretch test job and the WDDM Blt - Stretch (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Blt (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9ee1e95-a086-41a5-b075-3e32a6c98586

This automated test is a stability test for the user-mode Device Driver Interface (DDI) for bit-block transfer (bitblt).

This test verifies system stability when the system is performing valid surface bitblt operations for video and system memory. The test performs surface bitblts between a variety of surface types and memory pools. Longhorn Display Driver Model (LDDM) drivers must not crash in user mode or kernel mode during the test.

This topic applies to the following test jobs:

  • WDDM Blt

  • WDDM Blt (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Blt.exe monitor:1 | Runs the WDDM Blt test job and the WDDM Blt (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Blt.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM BVT2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8507670-c532-4d36-ac3b-a5bdc14e30cd

Thisautomated test verifies system stability under the Windows Display Driver Model (WDDM) and verifies the functionality of Windows Vista video drivers.

The test consists of a set of test groups. Each test group exercises one subset of the Windows Vista user-mode Device Driver Interface (DDI). The test does not use the Microsoft® Direct3D® runtime. Instead, it calls directly into the user-mode driver and the kernel-mode entry points in the operating system. Drivers must not crash or leak memory during the test.

This topic applies to the following test jobs:

  • WDDM BVT2

  • WDDM BVT2 (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BVT2.exe monitor:1 | Runs the WDDM BVT2 test job and the WDDM BVT2 (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BVT2.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM BVT2 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ce023a5-83b2-4357-8ab8-e3692d81c4df

Thisautomated test verifies system stability under the Windows Display Driver Model (WDDM) and verifies the functionality of Windows Vista video drivers.

The test consists of a set of test groups. Each test group exercises one subset of the Windows Vista user-mode Device Driver Interface (DDI). The test does not use the Microsoft® Direct3D® runtime. Instead, it calls directly into the user-mode driver and the kernel-mode entry points in the operating system. Drivers must not crash or leak memory during the test.

This topic applies to the following test jobs:

  • WDDM BVT2

  • WDDM BVT2 (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
BVT2.exe monitor:1 | Runs the WDDM BVT2 test job and the WDDM BVT2 (WoW64) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BVT2.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Coherency

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/506b5487-232f-410a-961d-509d90a98561

This automated test validates that GPU and CPU accesses to aperture segments are flushed correctly. The test ensures coherency of the data accesses between both processors.

The Windows Display Driver Model (WDDM) coherency test invokes a test that is embedded in the Windows Vista kernel. The test validates that accesses to Accelerated Graphics Port (AGP) and Peripheral Component Interconnect (PCI) Express aperture segments are coherent and correctly cause cache flushes. To pass this test, AGP chipset drivers and video drivers must correctly flush caches when the operating system instructs them to do so.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
Coherency | Runs the test job.

File List

File | Location
Coherency.exe | <[testbinroot]>\nttest</p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Cross Processor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2fdcf57-2596-47f1-9cbd-900ddd991074

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WDDM Cross Processor

  • WDDM Cross Processor (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
CrossProc | Runs both the WDDM Cross Processor (WoW64) test job and the WDDM Cross Processor (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
CrossProc.exe | <[testbinroot]>\nttest</p>
Crossproc.ini | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Cross Processor (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9820c83e-f640-4ebe-a0fe-67a774ee3b95

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WDDM Cross Processor

  • WDDM Cross Processor (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
CrossProc | Runs both the WDDM Cross Processor (WoW64) test job and the WDDM Cross Processor (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
CrossProc.exe | <[testbinroot]>\nttest</p>
Crossproc.ini | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Dead Lock

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/327aef01-95b1-4a24-afb4-ae93ec9a10ba

This automated test verifies that user-mode and kernel-mode drivers correctly synchronize calls from multiple processes and threads.

This test calls into the user-mode and kernel-mode video drivers concurrently from multiple processes and threads. Video drivers must correctly synchronize access to shared data structures to make sure that the system is stable in this scenario. Drivers pass this test if they do not cause the system to crash or hang while the test is running.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Deadlock Time:15 | Runs the WDDM Deadlock test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Deadlock.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM DMA Split (Force Split Points)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22f03980-e458-4c9e-957b-24e17042b159

This automated test verifies that whenever a Direct Memory Access (DMA) buffer references multiple resources, the video driver will insert enough split points for this buffer to be run in parts. The test puts the operating system into a mode that causes it to always use all split points that the driver specifies. Video drivers must not cause the system to crash or hang during this test.

This topic applies to the following test jobs:

  • WDDM DMA Split (Force Split Points)

  • WDDM DMA Split (Force Split Points) (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
DMAsplit.exe | Runs both the WDDM DMA Split (Force Split Points) test job and the WDDM DMA Split (Force Split Points) (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DMAsplit.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
Monitor | Display device to test against
ConfigDisplayCommandLine | Customer Command Line for ConfigDisplay. Defalut: logo
TDRArgs | /get or /set


WDDM DMA Split (Force Split Points) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e192526-533f-4004-b3c7-9707281ba3f0

This automated test verifies that whenever a Direct Memory Access (DMA) buffer references multiple resources, the video driver will insert enough split points for this buffer to be run in parts. The test puts the operating system into a mode that causes it to always use all split points that the driver specifies. Video drivers must not cause the system to crash or hang during this test.

This topic applies to the following test jobs:

  • WDDM DMA Split (Force Split Points)

  • WDDM DMA Split (Force Split Points) (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command Syntax

Command option | Description
DMAsplit.exe | Runs both the WDDM DMA Split (Force Split Points) test job and the WDDM DMA Split (Force Split Points) (WoW64) test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
DMAsplit.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
Monitor | Display device to test against
ConfigDisplayCommandLine | Customer Command Line for ConfigDisplay. Defalut: logo
TDRArgs | /get or /set


WDDM FlipQueue

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2caf4f2-73f2-48ec-a03b-b6870ba8d518

This automated test verifies that kernel-mode video drivers correctly implement flip queuing for hardware or software.

This test uses the GPU to render on many GPU device contexts simultaneously. One of the contexts does flipping operations. If the driver correctly implements flip queuing for hardware or software, the flipping operations that one context submits does not cause the GPU to stall and starve the other contexts. Drivers pass this test if the non-flipping contexts are not starved.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Flipqueue.exe | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Flipqueue.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Fuzzer Allocation- Invalid Param

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a58349b-1999-4414-95e1-c1df82483247

This automated test verifies that kernel-mode drivers are stable when requested to process command buffers that contain invalid data.

The WDDM fuzzer test intercepts command buffers and other private driver data sent from the user-mode driver to the kernel-mode driver. The test randomly modifies the contents of the buffers and private driver data before the data is sent to the kernel. Drivers must not cause the system to crash or stop responding while running this test.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
FuzzerAlloc | Runs the WDDM Fuzzer Allocation- Invalid Param test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
FuzzerAlloc.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Fuzzer Command Buffer- Invalid Param

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b66817a2-bed9-4672-9d58-02d128afbee4

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
FuzzerCb | This command runs the WDDM Fuzzer Command Buffer- Invalid Param test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
FuzzerCb.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Fuzzer Misc- Invalid Param

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21d1ef5b-228d-4fac-9008-c605ccb120bc

This automated test verifies the requirements listed in the test details table.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
FuzzerMisc | Runs the WDDM Fuzzer Misc- Invalid Param test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
FuzzerMisc.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM GammaRamp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58614a1c-0938-4d0a-80fb-a0332f135762

This automated test verifies that kernel-mode video drivers succeed in attempts to set gamma ramps.

This test is a basic test of Longhorn Display Driver Model (LDDM) gamma-ramp functionality. It sets gamma ramps by using Graphics Device Interface (GDI) and kernel-mode entry points for the operating system. Drivers must not fail during this process.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
LDDMGammaRamp.exe monitor:1 | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
LDDMGammaRamp.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Handles - Invalid Param First Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3311715f-9500-4cf4-a3ca-81497e222533

This automated test verifies that kernel-mode drivers are stable when they process handles that are invalid or of the incorrect type.

The test intercepts handles that the operating system kernel returns to the user-mode driver. It then modifies the handles. User-mode drivers can then generate invalid commands and handle lists that are passed to the kernel-mode driver. Kernel-mode drivers must not fail or hang during this test.

This topic applies to the following test jobs:

  • WDDM Handles - Invalid Param First Group

  • WDDM Handles - Invalid Param Second Group

  • WDDM Handles - Invalid Param Third Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Handles.exe | Runs the test job..

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Handles.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Handles - Invalid Param Second Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22a42a7b-0ff4-4777-a330-7b5ab564a89a

This automated test verifies that kernel-mode drivers are stable when they process handles that are invalid or of the incorrect type.

The test intercepts handles that the operating system kernel returns to the user-mode driver. It then modifies the handles. User-mode drivers can then generate invalid commands and handle lists that are passed to the kernel-mode driver. Kernel-mode drivers must not fail or hang during this test.

This topic applies to the following test jobs:

  • WDDM Handles - Invalid Param First Group

  • WDDM Handles - Invalid Param Second Group

  • WDDM Handles - Invalid Param Third Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Handles.exe | Runs the test job..

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Handles.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay: Default logo


WDDM Handles - Invalid Param Third Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ee7f0fd-03b0-4bc1-84d7-394da594e69d

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay: Default logo


WDDM HPD Notification Test (Manual)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e903a10b-8c9f-4a67-8f54-0e0ee7251cf2

This manual test verifies support for notification events about Hot Plug Detect (HPD) removal and arrival.

This test is a user-mode test. You first generate an HPD removal event by unplugging a computer monitor. Then, plug in the monitor. The test reports success if it detects the arrival event after it detects the removal event.

Test details
Specifications
  • Device.Graphics.WDDM.Display.HotPlugDetection
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

WARNING

Make sure that the computer can run all manual tests that are required for certification. Depending on the type of submission, prerequisites may include the following:

  • TV Out support

  • Multimonitor support

  • Hot plug detection support

When you are running this test, select one computer in your pool, set the necessary dimension, and then schedule all jobs that have "(Manual)" in the title at the same time. You can do this before or after the rest of the automated jobs so that they are sent to the system in bulk.

You can set the dimension for this test by using either of the following methods:

  • Type this command at a command prompt: WTTCmd.exe /ConfigReg /Add /Value:Display\PrimaryMachine /Data:""

  • Use this procedure:

    1. Pick a relevant computer in the pool via job monitor.

    2. Right-click the computer name in the pool, and then click Edit.

    3. Add the dimension to the list.

    4. Click Save.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
HPDNotification | Runs the WDDM HPD Notification Test (Manual) test job.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
HPDNotification.exe | <[testbinroot]>\nttestnttest\windowstest\graphics\wddm\bin</p>
TDRWatch.exe | <[testbinroot]>\nttest nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM LockConfirm

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23ddaa2b-110a-4b61-90da-62b97818281d

This automated test executes different locking scenarios and verifies that surface pattern remains the same after the lock.

This topic applies to the following test jobs:

  • WDDM LockConfirm

  • WDDM LockConfirm (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lockconfirm.exe | Runs both the WDDM LockConfirm test job and the WDDM LockConfirm (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Lockconfirm.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM LockConfirm (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c0c3365-64ec-445a-b92b-43722c6c842d

This automated test executes different locking scenarios and verifies that surface pattern remains the same after the lock.

This topic applies to the following test jobs:

  • WDDM LockConfirm

  • WDDM LockConfirm (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Lockconfirm.exe | Runs both the WDDM LockConfirm test job and the WDDM LockConfirm (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Lockconfirm.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Locksmith

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19500b44-f67a-478c-a856-534b8389ebdf

This automated test is a basic test of user-mode display driver locking functionality.

This test verifies that user-mode display drivers correctly implement the Lock DDI. In particular, this test simultaneously locks multiple surfaces with a resource and locks surfaces with discard semantics. Display drivers must not stop responding or fail calls to the Lock DDI during this test.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Locksmith.exe monitor:1 | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Locksmith.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM ManagedPrimary

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/985a614d-a5bf-4a0e-86ef-683ac52d7f10

This automated test verifies that display drivers correctly implement managed primary functionality.

In particular, this test:

  1. Creates primary surfaces.

  2. Calls the user-mode SetDisplayMode DDI.

  3. Renders some frames into the surfaces and switches between them.

  4. Changes the display mode (which causes the managed primaries to become unpinned from video memory).

  5. Calls the SetDisplayMode DDI again to cause the managed primaries to become pinned into video memory again.

Drivers must not fail calls to the SetDisplayMode DDI during this test.

This topic applies to the following test jobs:

  • WDDM ManagedPrimary

  • WDDM ManagedPrimary (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Managedprimary.exe | Runs both the WDDM ManagedPrimary test job and the WDDM ManagedPrimary (WoW64) test job..

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Managedprimary.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM ManagedPrimary (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ce96c39-f168-48d5-9749-c9f8239cca2f

This automated test verifies that display drivers correctly implement managed primary functionality.

In particular, this test:

  1. Creates primary surfaces.

  2. Calls the user-mode SetDisplayMode DDI.

  3. Renders some frames into the surfaces and switches between them.

  4. Changes the display mode (which causes the managed primaries to become unpinned from video memory).

  5. Calls the SetDisplayMode DDI again to cause the managed primaries to become pinned into video memory again.

Drivers must not fail calls to the SetDisplayMode DDI during this test.

This topic applies to the following test jobs:

  • WDDM ManagedPrimary

  • WDDM ManagedPrimary (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Managedprimary.exe | Runs both the WDDM ManagedPrimary test job and the WDDM ManagedPrimary (WoW64) test job..

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Managedprimary.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Max Contexts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7fd193d-bc2c-4927-8ec0-ec7b0f10c0b2

This automated test verifies that drivers do not have any hardware limits on the number of rendering contexts that can exist at any given time.

The WDDM Max Contexts test creates 100 user-mode device contexts at the same time. Drivers fail the test if they fail any of the device creation attempts. The number of outstanding device contexts that exist must be limited by available system memory only.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Maxcontexts.exe monitor:1 | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Maxcontexts.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM ModeChange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c519159b-d59d-42c3-a6af-65d260095098

This automated test verifies system stability during display mode changes.

This test changes the display mode of all display outputs on the system and concurrently locks primary surfaces for use by the CPU. The test might put the system into rotated modes. Display drivers must not crash or stop responding (hang) while this test is running.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
LDDMModeChange.exe | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
LDDMModeChange.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
TopologyConfigSaveFile |


WDDM ModifyVAD

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e798529c-2481-4fae-ae47-09ee89af4aca

This automated test verifies system stability during display mode changes.

This test changes the display mode of all display outputs on the system and concurrently locks primary surfaces for use by the CPU. The test might put the system into rotated modes. Display drivers must not crash or stop responding (hang) while this test is running.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
ModifyVAD.exe monitor:1 | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
ModifyVAD.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
MONITOR | Display device to test against
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Overlay

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7cbc46ba-9b13-4970-aba4-7ca1f585668f

This automated test verifies that user-mode and kernel-mode display drivers correctly handle overlays.

The test creates overlays (if supported) and performs rendering operations on surfaces display via overlays. Neither the user-mode nor kernel-mode driver can crash or hang during this test

This topic applies to the following test jobs:

  • WDDM Overlay

  • WDDM Overlay (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing..

More information

Command syntax

Command option | Description
lddmoverlay | Runs both the WDDM Overlay test job and the WDDM Overlay (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Iddmoverlay.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Overlay (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49f5abb5-4de7-4272-a338-a14871e67fad

This automated test verifies that user-mode and kernel-mode display drivers correctly handle overlays.

The test creates overlays (if supported) and performs rendering operations on surfaces display via overlays. Neither the user-mode nor kernel-mode driver can crash or hang during this test

This topic applies to the following test jobs:

  • WDDM Overlay

  • WDDM Overlay (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing..

More information

Command syntax

Command option | Description
lddmoverlay | Runs both the WDDM Overlay test job and the WDDM Overlay (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Iddmoverlay.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Pass Through

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0e29b06-6b0b-4dae-97d4-1ff1e1d56a63

This automated test verifies that user-mode display drivers correctly handle failures originating from runtime callbacks

This test intercepts calls from the user-mode display driver into the operating system. The test injects failures into these calls and verifies that drivers fail the corresponding DDI call. Drivers must not crash when they see a failure from the operating system, and they must also fail the corresponding DDI call when an operating system callback fails. This test variation injects failures into the following callbacks:

  • CreateDeviceCB

  • DestroyDeviceCB

  • CreateContextCB

  • DestroyContextCB

  • AllocateCB

  • DeallocateCB

  • UpdateOverlayCB

  • FlipOverlayCB

  • CreateOverlayCB

  • DestroyOverlayCB

  • SetDisplayModeCB

This topic applies to the following test jobs:

  • WDDM Pass Through

  • WDDM Pass Through (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PassThrough.exe monitor:1 | Runs both the WDDM Pass Through test job and the WDDM Pass Through (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PassThrough.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Pass Through - Lock

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db5ce247-dbae-4e1e-b738-0ef0139d0dbc

This automated test verifies that user-mode display drivers correctly handle failures originating from runtime callback functions

This test intercepts calls from the user-mode display driver into the operating system. The test injects failures into these calls and verifies that drivers fail the corresponding DDI call. Drivers must not crash when they see a failure from the operating system, and they must also fail the corresponding DDI call when an operating system callback function fails. This test variation injects failures into the following callback functions:

  1. LockCB

  2. UnlockCB

This topic applies to the following test jobs:

  • WDDM Pass Through - Lock

  • WDDM Pass Through - Lock (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PassThrough.exe monitor:1 Lock | Runs both the WDDM Pass Through - Lock test job and the WDDM Pass Through - Lock (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PassThrough.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Pass Through - Lock (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/52b1506d-3a66-4d7e-86b2-61b79cab5288

Passthrough with Locking cases enabled

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Pass Through - QueryResidency

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1084117-97fb-4761-99bb-8fa61d82abf2

This automated test verifies that drivers correctly implement the QueryResourceResidency DDI.

This test calls the user-mode QueryResourceResidency DDI. It then injects specific return codes into the QueryResidencyCB callback and verifies that drivers correctly map these return codes into the return code from the QueryResourceResdiencyDDI. The correct mapping is defined the WDK documentation.

This topic applies to the following test jobs:

  • WDDM Pass Through - QueryResidency

  • WDDM Pass Through - QueryResidency (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Passthrough.exe QueryResidency | Runs both the WDDM Pass Through - QueryResidency test job and the WDDM Pass Through - QueryResidency (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PassThrough.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Pass Through - QueryResidency (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b785baa-eca5-45df-847e-4657e11955ba

WDDM QueryResourceResidency driver test

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Pass Through (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d05441b-5a47-4ff9-9483-ec03e9f6926c

This automated test verifies that user-mode display drivers correctly handle failures originating from runtime callbacks

This test intercepts calls from the user-mode display driver into the operating system. The test injects failures into these calls and verifies that drivers fail the corresponding DDI call. Drivers must not crash when they see a failure from the operating system, and they must also fail the corresponding DDI call when an operating system callback fails. This test variation injects failures into the following callbacks:

  • CreateDeviceCB

  • DestroyDeviceCB

  • CreateContextCB

  • DestroyContextCB

  • AllocateCB

  • DeallocateCB

  • UpdateOverlayCB

  • FlipOverlayCB

  • CreateOverlayCB

  • DestroyOverlayCB

  • SetDisplayModeCB

This topic applies to the following test jobs:

  • WDDM Pass Through

  • WDDM Pass Through (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PassThrough.exe monitor:1 | Runs both the WDDM Pass Through test job and the WDDM Pass Through (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PassThrough.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM PnPMultiModeSwitch Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be28b2a8-2d73-4f1e-aa5f-5916be069380

This automated test verifies the behavior of applications when a PnP Stop event is generated and when transitioning from windowed mode to full-screen mode and vice-versa.

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM12.Display.PnpStopStartSupport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PnPMultiModeSwitchTest Repetitions:100 | Runs the test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PnPMultiModeSwitchTest.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


WDDM PnPStop Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85bc85b5-cf3e-4773-a9fa-de73c1475cf7

This automated test disables and enables the display adapter.

This test disables the display adapter and then enables it again. Setupapi is used for disabling and enabling the display device. This is an alternate method of enabling and disabling the display adapter to using Device Manager.

Test details
Specifications
  • Device.Graphics.WDDM.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PnPStop.exe RestartDevice | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PnPStop.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM PnPStopModeSwitch Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b36f16ef-b4c7-4d78-b05b-b085a3157483

This automated test invokes a mode switch and then tries to restore the original mode after a PnP Stop event is created on the same device.

Test details
Specifications
  • Device.Graphics.WDDM11.DisplayRender.Base
  • Device.Graphics.WDDM12.Display.PnpStopStartSupport
  • System.Fundamentals.Graphics.MicrosoftBasicDisplayDriver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PnPModeSwitch | Runs the test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PnPModeSwitch.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


WDDM PresentStats - Present Statistics Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11db634c-6fa6-4733-ad91-82eedc544add

This automated test verifies that drivers work correctly with the operating system to provide reliable presentation statistics to applications.

Specifically, this test verifies that the following scenarios work:

  • For multihead devices, presentations on 1 swap chain do not affect the present IDs for other swap chains.

  • The QPC times reported for v-blanks increase at a rate approximately equal to the refresh rate of the monitor that is connected to the corresponding output head.

  • GPU-bound applications that spin calling the present API (for flipping) should never miss a frame.

  • The latency reported by the presentation statistics increase linearly with the maximum number of queued presents (for GPU-bound applications).

  • v-blank IDs reported through the present statistics API agree with the WaitForVerticalBlank API.

  • Present statistics work for immediate flips, and flips occur during a vertical blank.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Presentstats.exe | Runs the test job..

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Presentstats.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Primary Surface

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb8ff2b2-6604-4388-8cff-4e77fd80d8f3

This automated test verifies that drivers correctly implement presentation operations.

This test exercises the kernel-mode presentation DDI in a variety of ways. Drivers must succeed present calls and not crash or fail to respond (hang) during this test. Specifically, the following scenarios:

  • Present-blts to 8bpp, 16bpp, and 32bpp surfaces

  • Color-fill presents to 8bpp, 16bpp, and 32bpp surfaces

  • Presents to staging buffers

  • Primary to primary present-blts

  • Primary to primary present-blts

This topic applies to the following test jobs:

  • WDDM Primary Surface

  • WDDM Primary Surface (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PrimarySurf.exe | Runs both the WDDM Primary Surface test job and the WDDM Primary Surface (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PrimarySurf.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Primary Surface (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e72b0b6-55d4-4247-8be9-30e8b5d131ea

This automated test verifies that drivers correctly implement presentation operations.

This test exercises the kernel-mode presentation DDI in a variety of ways. Drivers must succeed present calls and not crash or fail to respond (hang) during this test. Specifically, the following scenarios:

  • Present-blts to 8bpp, 16bpp, and 32bpp surfaces

  • Color-fill presents to 8bpp, 16bpp, and 32bpp surfaces

  • Presents to staging buffers

  • Primary to primary present-blts

  • Primary to primary present-blts

This topic applies to the following test jobs:

  • WDDM Primary Surface

  • WDDM Primary Surface (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
PrimarySurf.exe | Runs both the WDDM Primary Surface test job and the WDDM Primary Surface (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
PrimarySurf.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Process Callout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/308a3e9c-7156-4a27-a31e-58792e250b7f

This automated test is a stress test that verifies system stability during process destruction.

This test creates many processes that do windowed and full-screen d3d9 rendering. The test then asynchronously terminates these processes. Drivers must not cause the system to stop responding (hang) or crash while running this test.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Processcallout.exe | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Processcallout.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM RotateBlt Full Screen ColorFillPresent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c8d9c13-56b6-4252-9b7f-fefcae7a7521

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WDDM RotateBlt Full Screen ColorFillPresent

  • WDDM RotateBlt Full Screen ColorFillPresent (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

RotateBlt.exe is an automated test application that verifies the following:

  • Present-blt and colorfill-presents are correctly rotated when the blt intersects with a GDI sprite (DWM off)

  • Present-blts are correctly stretched in rotated modes (DWM off)

  • Present-blts are correctly clipped in rotated modes (DWM off)

  • Blts from a CDD shadow surface to a shared primary are correctly rotated

  • Blts from a shared primary to a CDD shadow surface are correctly rotated

  • Windowed modes present-blts are correctly color converted in a rotated mode, including sRGB conversions (DWM off)

  • Full-screen presentation operations from rotation aware apps are not rotated by the driver

  • GetFrontBufferData performs rotating copy from a primary surface to the application-provided system memory destination for non-rotation aware applications

The program performs the following tests for each specified mode of each specified monitor. Each test is performed with the DWM disabled:

  1. Shadow buffer to CDD primary blt test

  2. CDD primary to shadow buffer blt test

  3. D3D render target to CDD primary blt test

  4. D3D render target to staging buffer blt test

  5. D3D color-fill operation to the primary surface in full screen mode

  6. IDirectD3D9 render target to primary blt test in full screen mode

The test performs the following test cases:

Test case | Details
Shadow buffer to CDD primary blt | This test case renders to the screen via GDI methods. It then gets the contents of the primary surface via WDDM kernel entry points, and compares the contents of the primary surface with the contents rendered via GDI. If the contents differ too much, the test case fails.
CDD primary to shadow buffer blt | This test case uses WDDM kernel entry points to set the contents of the CDD primary. It then uses GDI APIs to blt from the screen to an off-screen surface. The test case then compares the contents of the off-screen surface to the contents set in the shared primary. If the contents differ too much, the test case fails.
D3D render target to CDD primary blt | This test case uses D3D9 APIs to render a scene into a render target. It then calls the Present API to copy the contents of the render target to the shared primary. The test case then compares the contents of the render target to the contents of the shared primary. If the contents differ too much, the test case fails.
D3D render target to staging buffer blt | This test case performs the same actions as the D3D render target to CDD primary blt test case. During each present call, a GDI sprite intersects with the rendering window. The test case verifies that the correct results appear in the shared primary surface.
D3D color-fill operation to the primary surface in full screen mode | This test case uses D3D API ColorFill to render a scene into a render target. It then calls the Present API with no D3DKMT_PRESENT rotate bit set to copy the contents of the render target to the shared primary. The test case then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test case fails.
 | This test case uses IDirectD3D9 API to render a scene into a render target. It then calls GetFrontBufferData performs rotating copy of primary surface contents. The test case then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test case fails.

Command syntax

The test is run using RotateBlt.exe with the following command line syntax:

RotateBlt.exe [save] [[Window] [WinGdi][WinCdd][WinD3d][fullscreen] [D3D]] [width:XXX] [height:XXX] [BPP:XXX] [Rotation:XXX] [Monitor:X]

Command option | Description
RotateBlt.exe | Runs the test jobs.
Save | Saves the images to disk whenever a test case fails.
Screen | Saves the Desktop images for all test cases, not just test failures.
Window | Runs all window device test cases.
WinGdi | Runs all of the Windows GDI test cases.
WinCdd | Runs all of the Windows CDD test cases.
WinD3D | Runs all of the Windows D3D test cases.
FullScreen | Runs all of the full screen device test cases that use Device Driver Interfaces.
D3D | Runs all of the full screen device test cases that use Direct3D Interfaces.
Width | Specifies the width of the primary surface. If this is not specified, then the width is cycled through the set (800, 1024, 1280, and 1600).
Height | Specifies the height of the primary surface. If this is not specified, then the height is cycled through the set (600, 768, 900, 1024, and 1280).
BPP | Specifies the number of bits per pixel in the primary. If this is not specified, then the bits per pixel is cycled through the set (32, 16).
Rotation | Specifies the rotation of the display. If this is not specified, the rotation is cycled through the set (0, 90, 180, and 270).
Monitor | Sets the monitor to test using a 1-based index. If this is not specified, then the primary monitor is tested.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
RotateBlt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM RotateBlt Full Screen ColorFillPresent (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c6a6d47-458b-4ea9-99fe-788227202950

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WDDM RotateBlt Full Screen ColorFillPresent

  • WDDM RotateBlt Full Screen ColorFillPresent (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

RotateBlt.exe is an automated test application that verifies the following:

  • Present-blt and colorfill-presents are correctly rotated when the blt intersects with a GDI sprite (DWM off)

  • Present-blts are correctly stretched in rotated modes (DWM off)

  • Present-blts are correctly clipped in rotated modes (DWM off)

  • Blts from a CDD shadow surface to a shared primary are correctly rotated

  • Blts from a shared primary to a CDD shadow surface are correctly rotated

  • Windowed modes present-blts are correctly color converted in a rotated mode, including sRGB conversions (DWM off)

  • Full-screen presentation operations from rotation aware apps are not rotated by the driver

  • GetFrontBufferData performs rotating copy from a primary surface to the application-provided system memory destination for non-rotation aware applications

The program performs the following tests for each specified mode of each specified monitor. Each test is performed with the DWM disabled:

  1. Shadow buffer to CDD primary blt test

  2. CDD primary to shadow buffer blt test

  3. D3D render target to CDD primary blt test

  4. D3D render target to staging buffer blt test

  5. D3D color-fill operation to the primary surface in full screen mode

  6. IDirectD3D9 render target to primary blt test in full screen mode

The test performs the following test cases:

Test case | Details
Shadow buffer to CDD primary blt | This test case renders to the screen via GDI methods. It then gets the contents of the primary surface via WDDM kernel entry points, and compares the contents of the primary surface with the contents rendered via GDI. If the contents differ too much, the test case fails.
CDD primary to shadow buffer blt | This test case uses WDDM kernel entry points to set the contents of the CDD primary. It then uses GDI APIs to blt from the screen to an off-screen surface. The test case then compares the contents of the off-screen surface to the contents set in the shared primary. If the contents differ too much, the test case fails.
D3D render target to CDD primary blt | This test case uses D3D9 APIs to render a scene into a render target. It then calls the Present API to copy the contents of the render target to the shared primary. The test case then compares the contents of the render target to the contents of the shared primary. If the contents differ too much, the test case fails.
D3D render target to staging buffer blt | This test case performs the same actions as the D3D render target to CDD primary blt test case. During each present call, a GDI sprite intersects with the rendering window. The test case verifies that the correct results appear in the shared primary surface.
D3D color-fill operation to the primary surface in full screen mode | This test case uses D3D API ColorFill to render a scene into a render target. It then calls the Present API with no D3DKMT_PRESENT rotate bit set to copy the contents of the render target to the shared primary. The test case then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test case fails.
 | This test case uses IDirectD3D9 API to render a scene into a render target. It then calls GetFrontBufferData performs rotating copy of primary surface contents. The test case then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test case fails.

Command syntax

The test is run using RotateBlt.exe with the following command line syntax:

RotateBlt.exe [save] [[Window] [WinGdi][WinCdd][WinD3d][fullscreen] [D3D]] [width:XXX] [height:XXX] [BPP:XXX] [Rotation:XXX] [Monitor:X]

Command option | Description
RotateBlt.exe | Runs the test jobs.
Save | Saves the images to disk whenever a test case fails.
Screen | Saves the Desktop images for all test cases, not just test failures.
Window | Runs all window device test cases.
WinGdi | Runs all of the Windows GDI test cases.
WinCdd | Runs all of the Windows CDD test cases.
WinD3D | Runs all of the Windows D3D test cases.
FullScreen | Runs all of the full screen device test cases that use Device Driver Interfaces.
D3D | Runs all of the full screen device test cases that use Direct3D Interfaces.
Width | Specifies the width of the primary surface. If this is not specified, then the width is cycled through the set (800, 1024, 1280, and 1600).
Height | Specifies the height of the primary surface. If this is not specified, then the height is cycled through the set (600, 768, 900, 1024, and 1280).
BPP | Specifies the number of bits per pixel in the primary. If this is not specified, then the bits per pixel is cycled through the set (32, 16).
Rotation | Specifies the rotation of the display. If this is not specified, the rotation is cycled through the set (0, 90, 180, and 270).
Monitor | Sets the monitor to test using a 1-based index. If this is not specified, then the primary monitor is tested.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
RotateBlt.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM RotateBlt Window D3D

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01d2bed1-2596-4df1-85a6-3f2eb7c840ff

RotateBlt.exe is an automated test application that verifies the following assertions: Present-blt and colorfill-presents are correctly rotated when the blt intersects with a GDI sprite (DWM off) Present-blts are correctly stretched in rotated modes (DWM off) Present-blts are correctly clipped in rotated modes (DWM off) Blts from a CDD shadow surface to a shared primary are correctly rotated Blts from a shared primary to a CDD shadow surface are correctly rotated Windowed modes present-blts are correctly color converted in a rotated mode, including sRGB conversions (DWM off) Full-screen presentation operations from rotation aware apps are not rotated by the driver GetFrontBufferData performs rotating copy from a primary surface to the application-provided system memory destination for non-rotation aware applications RotateBlt.exe is invoked with the following command line syntax: RotateBlt.exe [save] [[Window] [WinGdi][WinCdd][WinD3d][fullscreen] [D3D]] [width:XXX] [height:XXX] [BPP:XXX] [Rotation:XXX] [Monitor:X] Save - If this argument is present, then images will be saved to disk whenever a test case fails Screen - Save the Desktop images anyway. Window - Run all window device test cases. WinGdi - Run the Windows GDI test cases. WinCdd - Run the Windows CDD test cases. WinD3D- Run the Windows D3D test cases. FullScreen - Run full screen device test cases that use Device Driver Interfaces. D3D - Run full screen device test cases that use Direct3D Interfaces. Width - Specifies the width of the primary surface. If this is not specified, then the width is cycled through the set (800, 1024, 1280, 1600) Height - Specifies the height of the primary surface. If this is not specified, then the height is cycled through the set (600, 768, 900, 1024, 1280) BPP - Specifies the number of bits per pixel in the primary. If this is not specified, then the bits per pixel is cycled through the set (32, 16) Rotation - Specifies the rotation of the display. If this is not specified, the rotation is cycled through the set (0, 90, 180, 270) Monitor - The 1-based index of the monitor to test. If this is not specified, then the primary monitor is tested The program performs the following tests for each specified mode of each specified monitor. Each test is performed with the DWM disabled 1. Shadow buffer to CDD primary blt test 2. CDD primary to shadow buffer blt test 3. D3D render target to CDD primary blt test 4. D3D render target to staging buffer blt test 5. D3D color-fill operation to the primary surface in full screen mode 6. IDirectD3D9 render target to primary blt test in full screen mode The tests perform the following actions 1. Shadow buffer to CDD primary blt test This test renders to the screen via GDI methods. It then gets the contents of the primary surface via wddm kernel entry points, and compares the contents of the primary surface with the contents rendered via GDI. If the contents differ too much, the test fails. 2. CDD primary to shadow buffer blt test This test uses wddm kernel entry points to set the conents of the CDD primary. It then uses GDI APIs to blt from the screen to an offscreen surface. The test then compares the contents of the offscreen surface to the contents set in the shared primary. If the contents differ too much, the test fails. 3. D3D render target to CDD primary blt test This test uses D3D9 APIs to render a scene into a render target. It then calls the Present API to copy the contents of the render target to the shared primary. The test then compares the contents of the render target to the contents of the shared primary. If the contents differ too much, the test fails. 4. D3D render target to staging buffer blt test This test performs the same actions as #3. During each present call, a GDI sprite intersects with the rendering window. The test verifies that the correct results appear in the shared primary surface. 5. D3D color-fill operation to the primary surface in full screen mode. This test uses D3D API ColorFill to render a scene into a render target. It then calls the Present API with no D3DKMT_PRESENT rotate bit set to copy the contents of the render target to the shared primary. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. 6. IDirectD3D9 render target to primary blt test in full screen mode. This test uses IDirectD3D9 API to render a scene into a render target. It then calls GetFrontBufferData performs rotating copy of primary surface contents. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. ExpectedRunTime: 10 min, if > 10 min then investigate TestOwner: maithida TestType: Stability Does the test render?: Yes Does the test go fullscreen?: Yes Do the number of test cases depend on machine config?: Yes (driver caps) Does the test change desktop resolution?: Yes Does the test pass invalid parameters?: No How many monitors does the test run on?: 2 Uses DirectX runtime?: Yes

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM RotateBlt Window D3D (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f3f5c09-2615-427b-b717-fd64c579a28b

RotateBlt.exe is an automated test application that verifies the following assertions: Present-blt and colorfill-presents are correctly rotated when the blt intersects with a GDI sprite (DWM off) Present-blts are correctly stretched in rotated modes (DWM off) Present-blts are correctly clipped in rotated modes (DWM off) Blts from a CDD shadow surface to a shared primary are correctly rotated Blts from a shared primary to a CDD shadow surface are correctly rotated Windowed modes present-blts are correctly color converted in a rotated mode, including sRGB conversions (DWM off) Full-screen presentation operations from rotation aware apps are not rotated by the driver GetFrontBufferData performs rotating copy from a primary surface to the application-provided system memory destination for non-rotation aware applications RotateBlt.exe is invoked with the following command line syntax: RotateBlt.exe [save] [[Window] [WinGdi][WinCdd][WinD3d][fullscreen] [D3D]] [width:XXX] [height:XXX] [BPP:XXX] [Rotation:XXX] [Monitor:X] Save - If this argument is present, then images will be saved to disk whenever a test case fails Screen - Save the Desktop images anyway. Window - Run all window device test cases. WinGdi - Run the Windows GDI test cases. WinCdd - Run the Windows CDD test cases. WinD3D- Run the Windows D3D test cases. FullScreen - Run full screen device test cases that use Device Driver Interfaces. D3D - Run full screen device test cases that use Direct3D Interfaces. Width - Specifies the width of the primary surface. If this is not specified, then the width is cycled through the set (800, 1024, 1280, 1600) Height - Specifies the height of the primary surface. If this is not specified, then the height is cycled through the set (600, 768, 900, 1024, 1280) BPP - Specifies the number of bits per pixel in the primary. If this is not specified, then the bits per pixel is cycled through the set (32, 16) Rotation - Specifies the rotation of the display. If this is not specified, the rotation is cycled through the set (0, 90, 180, 270) Monitor - The 1-based index of the monitor to test. If this is not specified, then the primary monitor is tested The program performs the following tests for each specified mode of each specified monitor. Each test is performed with the DWM disabled 1. Shadow buffer to CDD primary blt test 2. CDD primary to shadow buffer blt test 3. D3D render target to CDD primary blt test 4. D3D render target to staging buffer blt test 5. D3D color-fill operation to the primary surface in full screen mode 6. IDirectD3D9 render target to primary blt test in full screen mode The tests perform the following actions 1. Shadow buffer to CDD primary blt test This test renders to the screen via GDI methods. It then gets the contents of the primary surface via wddm kernel entry points, and compares the contents of the primary surface with the contents rendered via GDI. If the contents differ too much, the test fails. 2. CDD primary to shadow buffer blt test This test uses wddm kernel entry points to set the conents of the CDD primary. It then uses GDI APIs to blt from the screen to an offscreen surface. The test then compares the contents of the offscreen surface to the contents set in the shared primary. If the contents differ too much, the test fails. 3. D3D render target to CDD primary blt test This test uses D3D9 APIs to render a scene into a render target. It then calls the Present API to copy the contents of the render target to the shared primary. The test then compares the contents of the render target to the contents of the shared primary. If the contents differ too much, the test fails. 4. D3D render target to staging buffer blt test This test performs the same actions as #3. During each present call, a GDI sprite intersects with the rendering window. The test verifies that the correct results appear in the shared primary surface. 5. D3D color-fill operation to the primary surface in full screen mode. This test uses D3D API ColorFill to render a scene into a render target. It then calls the Present API with no D3DKMT_PRESENT rotate bit set to copy the contents of the render target to the shared primary. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. 6. IDirectD3D9 render target to primary blt test in full screen mode. This test uses IDirectD3D9 API to render a scene into a render target. It then calls GetFrontBufferData performs rotating copy of primary surface contents. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. ExpectedRunTime: 10 min, if > 10 min then investigate TestOwner: maithida TestType: Stability Does the test render?: Yes Does the test go fullscreen?: Yes Do the number of test cases depend on machine config?: Yes (driver caps) Does the test change desktop resolution?: Yes Does the test pass invalid parameters?: No How many monitors does the test run on?: 2 Uses DirectX runtime?: Yes

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM RotateBlt Window GDI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c93c5e20-875e-4891-beb9-2717efc4b8ec

RotateBlt.exe is an automated test application that verifies the following assertions: Present-blt and colorfill-presents are correctly rotated when the blt intersects with a GDI sprite (DWM off) Present-blts are correctly stretched in rotated modes (DWM off) Present-blts are correctly clipped in rotated modes (DWM off) Blts from a CDD shadow surface to a shared primary are correctly rotated Blts from a shared primary to a CDD shadow surface are correctly rotated Windowed modes present-blts are correctly color converted in a rotated mode, including sRGB conversions (DWM off) Full-screen presentation operations from rotation aware apps are not rotated by the driver GetFrontBufferData performs rotating copy from a primary surface to the application-provided system memory destination for non-rotation aware applications RotateBlt.exe is invoked with the following command line syntax: RotateBlt.exe [save] [[Window] [WinGdi][WinCdd][WinD3d][fullscreen] [D3D]] [width:XXX] [height:XXX] [BPP:XXX] [Rotation:XXX] [Monitor:X] Save - If this argument is present, then images will be saved to disk whenever a test case fails Screen - Save the Desktop images anyway. Window - Run all window device test cases. WinGdi - Run the Windows GDI test cases. WinCdd - Run the Windows CDD test cases. WinD3D- Run the Windows D3D test cases. FullScreen - Run full screen device test cases that use Device Driver Interfaces. D3D - Run full screen device test cases that use Direct3D Interfaces. Width - Specifies the width of the primary surface. If this is not specified, then the width is cycled through the set (800, 1024, 1280, 1600) Height - Specifies the height of the primary surface. If this is not specified, then the height is cycled through the set (600, 768, 900, 1024, 1280) BPP - Specifies the number of bits per pixel in the primary. If this is not specified, then the bits per pixel is cycled through the set (32, 16) Rotation - Specifies the rotation of the display. If this is not specified, the rotation is cycled through the set (0, 90, 180, 270) Monitor - The 1-based index of the monitor to test. If this is not specified, then the primary monitor is tested The program performs the following tests for each specified mode of each specified monitor. Each test is performed with the DWM disabled 1. Shadow buffer to CDD primary blt test 2. CDD primary to shadow buffer blt test 3. D3D render target to CDD primary blt test 4. D3D render target to staging buffer blt test 5. D3D color-fill operation to the primary surface in full screen mode 6. IDirectD3D9 render target to primary blt test in full screen mode The tests perform the following actions 1. Shadow buffer to CDD primary blt test This test renders to the screen via GDI methods. It then gets the contents of the primary surface via wddm kernel entry points, and compares the contents of the primary surface with the contents rendered via GDI. If the contents differ too much, the test fails. 2. CDD primary to shadow buffer blt test This test uses wddm kernel entry points to set the conents of the CDD primary. It then uses GDI APIs to blt from the screen to an offscreen surface. The test then compares the contents of the offscreen surface to the contents set in the shared primary. If the contents differ too much, the test fails. 3. D3D render target to CDD primary blt test This test uses D3D9 APIs to render a scene into a render target. It then calls the Present API to copy the contents of the render target to the shared primary. The test then compares the contents of the render target to the contents of the shared primary. If the contents differ too much, the test fails. 4. D3D render target to staging buffer blt test This test performs the same actions as #3. During each present call, a GDI sprite intersects with the rendering window. The test verifies that the correct results appear in the shared primary surface. 5. D3D color-fill operation to the primary surface in full screen mode. This test uses D3D API ColorFill to render a scene into a render target. It then calls the Present API with no D3DKMT_PRESENT rotate bit set to copy the contents of the render target to the shared primary. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. 6. IDirectD3D9 render target to primary blt test in full screen mode. This test uses IDirectD3D9 API to render a scene into a render target. It then calls GetFrontBufferData performs rotating copy of primary surface contents. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. ExpectedRunTime: 10 min, if > 10 min then investigate TestOwner: maithida TestType: Stability Does the test render?: Yes Does the test go fullscreen?: Yes Do the number of test cases depend on machine config?: Yes (driver caps) Does the test change desktop resolution?: Yes Does the test pass invalid parameters?: No How many monitors does the test run on?: 2 Uses DirectX runtime?: Yes

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.Display.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM RotateBlt Window GDI (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee64b2e6-55e0-468e-bf19-274281e0fa0f

RotateBlt.exe is an automated test application that verifies the following assertions: Present-blt and colorfill-presents are correctly rotated when the blt intersects with a GDI sprite (DWM off) Present-blts are correctly stretched in rotated modes (DWM off) Present-blts are correctly clipped in rotated modes (DWM off) Blts from a CDD shadow surface to a shared primary are correctly rotated Blts from a shared primary to a CDD shadow surface are correctly rotated Windowed modes present-blts are correctly color converted in a rotated mode, including sRGB conversions (DWM off) Full-screen presentation operations from rotation aware apps are not rotated by the driver GetFrontBufferData performs rotating copy from a primary surface to the application-provided system memory destination for non-rotation aware applications RotateBlt.exe is invoked with the following command line syntax: RotateBlt.exe [save] [[Window] [WinGdi][WinCdd][WinD3d][fullscreen] [D3D]] [width:XXX] [height:XXX] [BPP:XXX] [Rotation:XXX] [Monitor:X] Save - If this argument is present, then images will be saved to disk whenever a test case fails Screen - Save the Desktop images anyway. Window - Run all window device test cases. WinGdi - Run the Windows GDI test cases. WinCdd - Run the Windows CDD test cases. WinD3D- Run the Windows D3D test cases. FullScreen - Run full screen device test cases that use Device Driver Interfaces. D3D - Run full screen device test cases that use Direct3D Interfaces. Width - Specifies the width of the primary surface. If this is not specified, then the width is cycled through the set (800, 1024, 1280, 1600) Height - Specifies the height of the primary surface. If this is not specified, then the height is cycled through the set (600, 768, 900, 1024, 1280) BPP - Specifies the number of bits per pixel in the primary. If this is not specified, then the bits per pixel is cycled through the set (32, 16) Rotation - Specifies the rotation of the display. If this is not specified, the rotation is cycled through the set (0, 90, 180, 270) Monitor - The 1-based index of the monitor to test. If this is not specified, then the primary monitor is tested The program performs the following tests for each specified mode of each specified monitor. Each test is performed with the DWM disabled 1. Shadow buffer to CDD primary blt test 2. CDD primary to shadow buffer blt test 3. D3D render target to CDD primary blt test 4. D3D render target to staging buffer blt test 5. D3D color-fill operation to the primary surface in full screen mode 6. IDirectD3D9 render target to primary blt test in full screen mode The tests perform the following actions 1. Shadow buffer to CDD primary blt test This test renders to the screen via GDI methods. It then gets the contents of the primary surface via wddm kernel entry points, and compares the contents of the primary surface with the contents rendered via GDI. If the contents differ too much, the test fails. 2. CDD primary to shadow buffer blt test This test uses wddm kernel entry points to set the conents of the CDD primary. It then uses GDI APIs to blt from the screen to an offscreen surface. The test then compares the contents of the offscreen surface to the contents set in the shared primary. If the contents differ too much, the test fails. 3. D3D render target to CDD primary blt test This test uses D3D9 APIs to render a scene into a render target. It then calls the Present API to copy the contents of the render target to the shared primary. The test then compares the contents of the render target to the contents of the shared primary. If the contents differ too much, the test fails. 4. D3D render target to staging buffer blt test This test performs the same actions as #3. During each present call, a GDI sprite intersects with the rendering window. The test verifies that the correct results appear in the shared primary surface. 5. D3D color-fill operation to the primary surface in full screen mode. This test uses D3D API ColorFill to render a scene into a render target. It then calls the Present API with no D3DKMT_PRESENT rotate bit set to copy the contents of the render target to the shared primary. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. 6. IDirectD3D9 render target to primary blt test in full screen mode. This test uses IDirectD3D9 API to render a scene into a render target. It then calls GetFrontBufferData performs rotating copy of primary surface contents. The test then compares the contents of the render data to the contents of the shared primary. If the contents differ too much, the test fails. ExpectedRunTime: 10 min, if > 10 min then investigate TestOwner: maithida TestType: Stability Does the test render?: Yes Does the test go fullscreen?: Yes Do the number of test cases depend on machine config?: Yes (driver caps) Does the test change desktop resolution?: Yes Does the test pass invalid parameters?: No How many monitors does the test run on?: 2 Uses DirectX runtime?: Yes

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.WDDM.Display.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Sch_Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72a45438-046a-429a-8590-4fe8a88f12c7

This automated test verifies system stability while running many GPU-bound memory intensive applications.

This test creates many processes that do D3D9 rendering with a large video memory working set. This causes preemption and paging to occur on the GPU. Display drivers must not cause the system to crash or stop responding (hang) while running this test.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sch_Stress.exe | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sch_Stress.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Domain User who is local admin
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Scheduler Stress (AlwaysRepatch)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/18c9ab8b-ee67-47c4-950c-20eafd9ffbdc

This automated test verifies system stability while running many GPU-bound memory intensive applications when all patch locations are always repatched via the Patch DDI.

This test creates many processes that do D3D9 rendering with a large video memory working set. This causes preemption and paging to occur on the GPU. The test puts the operating system into a mode that causes it to repatch all patch locations via the Patch DDI. Display drivers must not cause the system to crash or stop responding (hang) while running this test.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sch_Stress.exe | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sch_Stress.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Domain User who is local admin
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Scheduler Stress (No PrePatching)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b47f388d-afa0-482f-9ad3-c6a87f08ae46

This automated test verifies system stability while running many GPU-bound, memory intensive applications when pre-patching of DMA buffers is disabled.

This test creates many processes that do D3D9 rendering with a large video memory working set. This causes preemption and paging to occur on the GPU. The test puts the operating system into a mode that causes it to never prepatch DMA buffers. Display drivers must not cause the system to crash or stop responding (hang) while running this test.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sch_Stress.exe | Runs the test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sch_Stress.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Domain User who is local admin
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Sync - VolBlt Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac56dc42-b8d4-4eac-97c1-0b3b053730df

This automated test verifies that user-mode drivers properly synchronize the CPU and GPU when resources are used by the CPU and GPU

This test creates a video memory volume texture. It then uses the VolBlt DDI to ask the user-mode driver to program the GPU to write into the volume texture. The test then locks the texture with the CPU and verifies that the texture contents read by the CPU match the contents that should have been written into the texture via the VolBlt DDI.

This topic applies to the following test jobs:

  • WDDM Sync - VolBlt Test

  • WDDM Sync - VolBlt Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites..

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sync.exe monitor:1 VolBlt | Runs both the WDDM Sync - VolBlt Test test job and the WDDM Sync - VolBlt Test (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sync.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Sync - VolBlt Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eed8b4b3-3b36-4d83-884e-155587255432

This automated test verifies that user-mode drivers properly synchronize the CPU and GPU when resources are used by the CPU and GPU

This test creates a video memory volume texture. It then uses the VolBlt DDI to ask the user-mode driver to program the GPU to write into the volume texture. The test then locks the texture with the CPU and verifies that the texture contents read by the CPU match the contents that should have been written into the texture via the VolBlt DDI.

This topic applies to the following test jobs:

  • WDDM Sync - VolBlt Test

  • WDDM Sync - VolBlt Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites..

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sync.exe monitor:1 VolBlt | Runs both the WDDM Sync - VolBlt Test test job and the WDDM Sync - VolBlt Test (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sync.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Sync Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12b4814c-7d34-47f8-9b91-5b86ce73f610

This automated test verifies that user-mode drivers properly synchronize the CPU and GPU when resources are used by the CPU and GPU.

This test verifies that user-mode display drivers expose correct locking semantics. In particular, there are two situations in which user-mode drivers must flush command buffers to kernel mode before returning from a Lock() call:

  • When a resource that is the target of a pending GPU write operation is locked

  • When a resource that is the source of a pending GPU read operation is locked

The test creates video memory resources and instructs the user-mode driver to program the GPU to read from or write to these resources. The test then locks the resources and reads their contents with the CPU. The test verifies that the data read by the CPU indicates that the Lock DDI is blocked until the GPU finishes processing all commands that reference the resources.

This topic applies to the following test jobs:

  • WDDM Sync Test

  • WDDM Sync Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sync.exe monitor:1 | Runs both the WDDM Sync Test test job and the WDDM Sync Test (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sync.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Sync Test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cf4642d-c550-485c-98ae-e08d9621bc74

This automated test verifies that user-mode drivers properly synchronize the CPU and GPU when resources are used by the CPU and GPU.

This test verifies that user-mode display drivers expose correct locking semantics. In particular, there are two situations in which user-mode drivers must flush command buffers to kernel mode before returning from a Lock() call:

  • When a resource that is the target of a pending GPU write operation is locked

  • When a resource that is the source of a pending GPU read operation is locked

The test creates video memory resources and instructs the user-mode driver to program the GPU to read from or write to these resources. The test then locks the resources and reads their contents with the CPU. The test verifies that the data read by the CPU indicates that the Lock DDI is blocked until the GPU finishes processing all commands that reference the resources.

This topic applies to the following test jobs:

  • WDDM Sync Test

  • WDDM Sync Test (WoW64)

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Sync.exe monitor:1 | Runs both the WDDM Sync Test test job and the WDDM Sync Test (WoW64) test job.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Sync.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WDDM Toaster - Invalid Param Fifth Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f315adb8-6f9f-487b-aaa4-fb027c758c72

This automated test verifies that the operating system is stable and secure despite invalid parameters passed to a user-mode display driver.

This test verifies system stability when invalid parameters are passed to the user-mode driver. Kernel-mode drivers must be robust enough to not cause the system to crash or stop responding "hang" when a user-mode driver is given invalid parameters.

This topic applies to the following test jobs:

  • WDDM Toaster - Invalid Param First Group

  • WDDM Toaster - Invalid Param Second Group

  • WDDM Toaster - Invalid Param Third Group

  • WDDM Toaster - Invalid Param Fourth Group

  • WDDM Toaster - Invalid Param Fifth Group

  • WDDM Toaster - Invalid Param Sixth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Toaster.exe | Runs the test jobs.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Toaster.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Toaster - Invalid Param First Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/acab9b2b-907a-413e-95cf-5e85c2630d98

This automated test verifies that the operating system is stable and secure despite invalid parameters passed to a user-mode display driver.

This test verifies system stability when invalid parameters are passed to the user-mode driver. Kernel-mode drivers must be robust enough to not cause the system to crash or stop responding "hang" when a user-mode driver is given invalid parameters.

This topic applies to the following test jobs:

  • WDDM Toaster - Invalid Param First Group

  • WDDM Toaster - Invalid Param Second Group

  • WDDM Toaster - Invalid Param Third Group

  • WDDM Toaster - Invalid Param Fourth Group

  • WDDM Toaster - Invalid Param Fifth Group

  • WDDM Toaster - Invalid Param Sixth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Toaster.exe | Runs the test jobs.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Toaster.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Toaster - Invalid Param Fourth Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/52b00b65-1f5a-4904-af00-3b94a8c7ab9c

This automated test verifies that the operating system is stable and secure despite invalid parameters passed to a user-mode display driver.

This test verifies system stability when invalid parameters are passed to the user-mode driver. Kernel-mode drivers must be robust enough to not cause the system to crash or stop responding "hang" when a user-mode driver is given invalid parameters.

This topic applies to the following test jobs:

  • WDDM Toaster - Invalid Param First Group

  • WDDM Toaster - Invalid Param Second Group

  • WDDM Toaster - Invalid Param Third Group

  • WDDM Toaster - Invalid Param Fourth Group

  • WDDM Toaster - Invalid Param Fifth Group

  • WDDM Toaster - Invalid Param Sixth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Toaster.exe | Runs the test jobs.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Toaster.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Toaster - Invalid Param Second Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/478246d4-de6d-4900-80af-afb14e41dfc6

This automated test verifies that the operating system is stable and secure despite invalid parameters passed to a user-mode display driver.

This test verifies system stability when invalid parameters are passed to the user-mode driver. Kernel-mode drivers must be robust enough to not cause the system to crash or stop responding "hang" when a user-mode driver is given invalid parameters.

This topic applies to the following test jobs:

  • WDDM Toaster - Invalid Param First Group

  • WDDM Toaster - Invalid Param Second Group

  • WDDM Toaster - Invalid Param Third Group

  • WDDM Toaster - Invalid Param Fourth Group

  • WDDM Toaster - Invalid Param Fifth Group

  • WDDM Toaster - Invalid Param Sixth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Toaster.exe | Runs the test jobs.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Toaster.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Toaster - Invalid Param Sixth Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff0071d0-05b7-4807-9de3-deef8b24a858

This automated test verifies that the operating system is stable and secure despite invalid parameters passed to a user-mode display driver.

This test verifies system stability when invalid parameters are passed to the user-mode driver. Kernel-mode drivers must be robust enough to not cause the system to crash or stop responding "hang" when a user-mode driver is given invalid parameters.

This topic applies to the following test jobs:

  • WDDM Toaster - Invalid Param First Group

  • WDDM Toaster - Invalid Param Second Group

  • WDDM Toaster - Invalid Param Third Group

  • WDDM Toaster - Invalid Param Fourth Group

  • WDDM Toaster - Invalid Param Fifth Group

  • WDDM Toaster - Invalid Param Sixth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Compatibility
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Toaster.exe | Runs the test jobs.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Toaster.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Toaster - Invalid Param Third Group

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36dcfd55-96b1-487b-bbb9-3ef0db647fea

This automated test verifies that the operating system is stable and secure despite invalid parameters passed to a user-mode display driver.

This test verifies system stability when invalid parameters are passed to the user-mode driver. Kernel-mode drivers must be robust enough to not cause the system to crash or stop responding "hang" when a user-mode driver is given invalid parameters.

This topic applies to the following test jobs:

  • WDDM Toaster - Invalid Param First Group

  • WDDM Toaster - Invalid Param Second Group

  • WDDM Toaster - Invalid Param Third Group

  • WDDM Toaster - Invalid Param Fourth Group

  • WDDM Toaster - Invalid Param Fifth Group

  • WDDM Toaster - Invalid Param Sixth Group

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Stability
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Toaster.exe | Runs the test jobs.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
Toaster.exe | <[testbinroot]>\nttest</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU_NetAccessOnly
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo


WDDM Unmap Segment to DummyPage Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/107dded8-f711-47ec-8b8e-fc1d3eee4699

This automated test verifies that the AGP driver implements the guard page mappings for all AGP aperture segments properly.

The AGP driver implements the guard page mappings for all AGP aperture segments but IHV drivers have to implement the build paging buffer unmap segment to dummy page (DXGKARG_BUILDPAGINGBUFFER.UnmapApertureSegment.DummyPage) so that any corruption can be detected by dxgkrnl. Because on non-AGP systems we need IHV support the test has two modes, check the unmap segement to dummy page is supported and check for corruption.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Unmappedaperture unmap | Runs the WDDM Unmap Segment to DummyPage Check test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Unmappedaperture.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
TDRArgs | /get or /set


WDDM WSSections

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c3c1106-192a-4285-b7fa-ed57c3764096

This automated test verifies that graphic drivers are not wide opened to all processes.

Some video vendors might release drivers with shared portable executable (PE) sections that are wide opened to all processes. This test finds all installed display driver files and scans for write-shared sections. The test will fail if it finds a write-shared memory section.

Test details
Specifications
  • Device.Graphics.WDDM.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wssections.exe | Runs the test job.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wssections.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
TDRArgs | /get or /set


WDDM2 - Make Resident - Verify Standard Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aeb6d8f0-9c34-45ac-a9c4-8f91ba83025c

Verifies that MakeResident and Evict are properly implemented by the driver, and that the corresponding usage request changes are detected by kernel.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Make Resident - Verify Support Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df30c079-ae11-45a3-9e69-5f48955e5a5e

Verifies that MakeResident and Evict are supported by the driver.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Map Default Texture - Basic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05347c6b-34bb-4ac2-8aec-1543e63a9c1c

This test exercises basic usage of Map on default textures.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Map Default Texture - Device-dependent layout test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/caa1894d-f474-4d31-819b-755bcb39bbed

This test checks that resource access methods and swizzle patterns for CPU-mappable default textures are correct.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Map Default Texture - Row Major layout test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9edf01d-972c-4261-9201-acc7e8384191

This test checks that resource access methods and swizzle patterns for CPU-mappable default textures are correct.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Map Default Texture - Standard swizzle layout test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83058f41-cbb6-4d69-8839-e2ce9224548c

This test checks that resource access methods and swizzle patterns for CPU-mappable default textures are correct.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Memory Budget Test - Periodic Trim 11 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c1bf14b-7926-4392-8f70-49027e3a184c

Verifies that DX11 driver is able to respond to trimming requests, and evict video memory surfaces whcih have not been recently used.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Memory Budget Test - Periodic Trim 9 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/120c3b0a-552b-4e53-9832-c97254838448

Verifies that DX9 driver is able to respond to trimming requests, and evict video memory surfaces whcih have not been recently used.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Memory Budget Test - Trim To Budget 11 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d035ea1-571a-4dda-9543-abbc1798e5a5

Verifies that DX11 driver is able to respond to budget trimming requests, and is capable of trimming their working set to the requested size.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Memory Budget Test - Trim To Budget 9 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bebf5a21-2e65-4e1b-8e78-badcbb36ba46

Verifies that DX9 driver is able to respond to budget trimming requests, and is capable of trimming their working set to the requested size.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - OfferReclaim11 - Working Set Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a84685aa-edd1-4a4b-aa48-c51e97cd46ff

Verifies that the working set of the process is properly adjusted by offering and reclaiming allocations.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - OfferReclaim12 - Basic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd3f4461-2885-4558-ae31-71f02b1dfa5c

This test verifies WDDM 2.0 offer reclaim functionality in Direct3D 12.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Page Fault Test - Induce Fault 11 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a99b31db-1b2d-40b4-9e59-7bd546049083

Verifies that the hardware and DX11 driver support and can recover from page faults caused by accessing invalid GPU virtual addresses.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Page Fault Test - Induce Fault 12 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/566c0d1d-5445-4dc8-908f-732992b07ffc

Verifies that the hardware and DX12 driver support and can recover from page faults caused by accessing invalid GPU virtual addresses.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2 - Page Fault Test - Induce Fault 9 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9ca50ec5-9906-4ef3-a3d9-ef04c2d32b2b

Verifies that the hardware and DX9 driver support and can recover from page faults caused by accessing invalid GPU virtual addresses.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM2.1 - Update Allocation Property

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51f5ec4f-bfcb-41c2-bb01-fef1403c93e4

Verifies that UpdateAllocationProperty works.

Test details
Specifications
  • Device.Graphics.WDDM21.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 3
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WDDM20 - Virtual Mode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01e4dd8e-e915-443d-8852-c5a442abbfcc

Misc. virtual related mode tests.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


WGF Create Device

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f510cbf6-94f4-4627-8621-d4cf34d38674

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WGF Create Device

  • WGF Create Device (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
D3D10MiscDevice -TestHAL createdevice createdevice11 -whql -logclean | Runs both the WGF Create Device test job and the WGF Create Device (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3D10MiscDevice.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\api</p>
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3d11SDKLayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF Create Device (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/449b2b02-9c36-4651-b909-6af598b56eef

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WGF Create Device

  • WGF Create Device (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
D3D10MiscDevice -TestHAL createdevice createdevice11 -whql -logclean | Runs both the WGF Create Device test job and the WGF Create Device (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3D10MiscDevice.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\api</p>
D3d10ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d10SDKLayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3d11SDKLayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF Feature Level 9.3 Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ae28052-1946-47c4-959a-74a171ae4f09

This automated test verifies the requirements listed in the test details table.

This topic is applicable to the following test jobs:

  • WGF Feature Level 9.3 Support

  • WGF Feature Level 9.3 Support (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
  • System.Fundamentals.Graphics.RenderOnly.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
10L9CreateDevice.exe -MinimumFeatureLevel:9_3 -logclean -logall | Runs both the WGF Feature Level 9.3 Support test job and the WGF Feature Level 9.3 Support (WoW64) test job.

File list

File | Location
10L9CreateDevice.exe | <[testbinroot]></p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3D11_1SDKLayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
DXGIDebug.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
HCKShowClassicDesktop.exe | <[testbinroot]></p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
ExecutableLocation |
ExecutableBinary |


WGF Feature Level 9.3 Support (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5ca8a48a-76ff-4a44-844c-1fc99af2def6

This automated test verifies the requirements listed in the test details table.

This topic is applicable to the following test jobs:

  • WGF Feature Level 9.3 Support

  • WGF Feature Level 9.3 Support (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
  • System.Fundamentals.Graphics.RenderOnly.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
10L9CreateDevice.exe -MinimumFeatureLevel:9_3 -logclean -logall | Runs both the WGF Feature Level 9.3 Support test job and the WGF Feature Level 9.3 Support (WoW64) test job.

File list

File | Location
10L9CreateDevice.exe | <[testbinroot]></p>
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3D11_1SDKLayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
DXGIDebug.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
HCKShowClassicDesktop.exe | <[testbinroot]></p>
Modechange.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
ExecutableLocation |
ExecutableBinary |


WGF11 -- Multi-threading -- one-way stress test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ae06fbc-087f-4c6b-854d-882191f60e04

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82798795-7266-44e5-ad75-e878e0cebb3b

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79203029-e7f9-4331-8254-93e8bbd971cb

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- one-way stress test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd720153-828d-45ab-ae10-80d8b740b443

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45001e2c-b57c-4ce6-9b35-1ac5ecb9e6a1

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - do not bind

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2f0dc88-3248-45bd-825b-054d6ba3043a

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55278633-90a2-477c-9732-d1ef71d7a399

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f44dd38-37db-45af-abfe-30dc1d144140

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6bc8fa8a-9d03-40ea-903c-83c7e5dcba82

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - immediate context

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4fb4ba5f-3836-446d-a225-fd20e2721e05

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e9fd12a-6716-4140-80eb-fed998751556

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e59ead57-78ab-455c-876c-e0b7a0b6887e

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aed4ff5a-77c3-4bf6-aed8-3d3aee692fcb

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f17a06d3-5b79-4397-bc3c-9a8a2644e402

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 -- Multi-threading -- two-way stress test (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3626e51-d248-4f3e-9efa-444ff5e594d7

This automated test verifies the requirements listed in the test details table.

The content in this topic applies to the following test jobs:

  • WGF11 -- Multi-threading -- one-way stress test

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- one-way stress test (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test

  • WGF11 -- Multi-threading -- two-way stress test - do not bind

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - do not bind (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test - immediate context (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0)

  • WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64)

  • WGF11 -- Multi-threading -- two-way stress test (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D11DriverConcurrentObjectCreation.D3D11CoreA
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 10.0) test job and the Multi-threading -- one-way stress test (FeatureLevel 10.0) (WoW64) case.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::OneWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- one-way stress test (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='2'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - do not bind (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:ScenarioId='3' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0'" | Runs both the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test - immediate context (FeatureLevel 11.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_10_0' and @Data:ScenarioId='1'" | Runs both the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 10.0) (WoW64) test job.
te.exe D3D11Chess.dll /select:&quot;@Name='D3D11Stress::TwoWayStress#' and @Data:DriverType='D3D_DRIVER_TYPE_HARDWARE' and @Data:FeatureLevel='D3D_FEATURE_LEVEL_11_0' and @Data:ScenarioId='1'" | Runs both WGF11 -- Multi-threading -- one-way stress test the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) test job and the WGF11 -- Multi-threading -- two-way stress test (FeatureLevel 11.0) (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\TestBinRoot]\nttest\windowstest\tools</p>
D3D10ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11_1SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Chess.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11ProxyDriver.dll | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3d11SDKLayers.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3D11Stress.Configuration.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.OneWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.ThreeWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3D11Stress.TwoWay.pict | <[testbinroot]>\TestBinRoot]\nttest\windowstest\graphics\d3d\chess</p>
D3dcompiler_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\OSBinRoot]\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Async

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df64f42e-5166-4941-a9af-a9a7ed0329cc

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Separate group for each query type

  • Queries tested for asynchronous (non-blocking) execution and correct values

  • Occlusion tested by rendering quads repeatedly with different depth functions

  • Predicates tested with all known predication functions (to ensure that they are predicated)

  • Counters tested with random amounts of geometry being rendered

  • Possibly considers issues with clipping in regards to pipeline statistics

This topic applies to the following test jobs:

  • WGF11 Async

  • WGF11 Async - DeferredContext

  • WGF11 Async - DeferredContext (WoW64)

  • WGF11 Async (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
WGF11Async | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Async - DeferredContext

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07f1e91a-2364-4b17-a63f-adf8e5e5c3e2

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Separate group for each query type

  • Queries tested for asynchronous (non-blocking) execution and correct values

  • Occlusion tested by rendering quads repeatedly with different depth functions

  • Predicates tested with all known predication functions (to ensure that they are predicated)

  • Counters tested with random amounts of geometry being rendered

  • Possibly considers issues with clipping in regards to pipeline statistics

This topic applies to the following test jobs:

  • WGF11 Async

  • WGF11 Async - DeferredContext

  • WGF11 Async - DeferredContext (WoW64)

  • WGF11 Async (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
WGF11Async | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Async - DeferredContext (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de940fe5-5f8a-41d0-b046-dbf38ef80f7d

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Separate group for each query type

  • Queries tested for asynchronous (non-blocking) execution and correct values

  • Occlusion tested by rendering quads repeatedly with different depth functions

  • Predicates tested with all known predication functions (to ensure that they are predicated)

  • Counters tested with random amounts of geometry being rendered

  • Possibly considers issues with clipping in regards to pipeline statistics

This topic applies to the following test jobs:

  • WGF11 Async

  • WGF11 Async - DeferredContext

  • WGF11 Async - DeferredContext (WoW64)

  • WGF11 Async (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11DriverCommandLists.D3D11CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
WGF11Async | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Async (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13e51eaf-cd03-4249-a490-8a93698691cc

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Async (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/30033a87-d821-4bda-977f-4b786dae0533

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Separate group for each query type

  • Queries tested for asynchronous (non-blocking) execution and correct values

  • Occlusion tested by rendering quads repeatedly with different depth functions

  • Predicates tested with all known predication functions (to ensure that they are predicated)

  • Counters tested with random amounts of geometry being rendered

  • Possibly considers issues with clipping in regards to pipeline statistics

This topic applies to the following test jobs:

  • WGF11 Async

  • WGF11 Async - DeferredContext

  • WGF11 Async - DeferredContext (WoW64)

  • WGF11 Async (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
WGF11Async | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Async.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Async Deferred (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e2f7dd3-25c3-41f0-84b2-81615396fc92

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Blend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ea1c8f4-c461-438e-a2a8-85b01ee00f11

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend - LogicOps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d360ffdc-8222-49d9-b3c3-fbe5007cd6f1

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10D3D11LogicOps.D3D10CoreD
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend - LogicOps (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/844a3ca0-2f6e-462e-bedc-1b0741b77aa6

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10D3D11LogicOps.D3D10CoreD
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend (D3D10 HW Only)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72f12315-11f3-4d38-aefd-ff98aca57381

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend (D3D10 HW Only) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d79773be-5fd8-4b3b-aeec-5577c559cbda

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend (Featurelevel 10.0) (Pri-1)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b6b3e00-d1a8-4d3e-971f-138309ab8e6f

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9faee922-f2cf-4dfe-8a0b-c464a216f535

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Blend (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2d063e9-93de-44ec-abc5-5e96b777521c

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Blend (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d5e9bf4-1258-430c-8ea5-47daa1878691

This automated test verifies D3D graphics driver/hardware conformance for query and other asynchronous features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Different gradients rendered to RT for each blend element (destination, source, second source)

  • Blend modes cycled independently and in tandem for color and alpha

  • RT formats cycled, to find issues with clamping and precision

  • Cycle number of RTs used and with blending enabled

  • Different RT formats used in RT indices, to test independent clamping and precision

This topic applies to the following test jobs:

  • WGF11 Blend

  • WGF11 Blend - LogicOps

  • WGF11 Blend - LogicOps (WoW64)

  • WGF11 Blend (D3D10 HW Only)

  • WGF11 Blend (D3D10 HW Only) (WoW64)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1)

  • WGF11 Blend (Featurelevel 10.0) (Pri-1) (WoW64)

  • WGF11 Blend (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11blend | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11blend.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Clipping

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/686000fe-2a92-41f3-8a74-92e53d4597d8

This automated test verifies D3D graphics driver/hardware conformance for geometry clipping features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Clipdist, Culldist values cycled independently for each vertex, to test shaded clipping

  • W values manipulated independently for each vertex, to test fixed clipping

  • Tests multisample with fixed sample pattern and potential deviation

  • Might need some uncertainty epsilon for floating-point precision issues

  • Consider non perspective correct attribute interpolation (though this may be better tested in rasterization tests)

  • Be particularly aware of guardband and z-clip

  • Guardband may hide some clipping problems

  • Z-clipping has no guardband protection

This topic applies to the following test jobs:

  • WGF11 Clipping

  • WGF11 Clipping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Some test cases my skip if run using feature level 10.0 or feature level 10.1.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11clipping | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11clipping.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Clipping (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71d00d60-f41e-46bf-9ac4-fc2abe885e0c

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Clipping (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d18b6661-a2ba-48de-b048-5a3baeb30f44

This automated test verifies D3D graphics driver/hardware conformance for geometry clipping features that are not specifically tested elsewhere.

Specifically, this test features the following characteristics:

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Clipdist, Culldist values cycled independently for each vertex, to test shaded clipping

  • W values manipulated independently for each vertex, to test fixed clipping

  • Tests multisample with fixed sample pattern and potential deviation

  • Might need some uncertainty epsilon for floating-point precision issues

  • Consider non perspective correct attribute interpolation (though this may be better tested in rasterization tests)

  • Be particularly aware of guardband and z-clip

  • Guardband may hide some clipping problems

  • Z-clipping has no guardband protection

This topic applies to the following test jobs:

  • WGF11 Clipping

  • WGF11 Clipping (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Some test cases my skip if run using feature level 10.0 or feature level 10.1.

More information

This section will include test-related content that may not aid the tester in running or troubleshooting the test, but is information that is good to know, but not necessary for running the test.

Command syntax

Command option | Description
Wgf11clipping | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11clipping.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67bb1d1f-fce3-48f2-9eb7-19ed4fc3a7c1

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Compute Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dba2b248-368c-4193-b458-8570632ca287

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader - Dispatch and GroupSharedMemory

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/09acdba9-c7a2-41b9-b42e-d6335f68225a

This is an automated test. [This content isn't available yet.]

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader - Dispatch and GroupSharedMemory (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cb23caa-a717-432e-84b8-58b36478d39e

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader (D3D10.x HW Only)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c85a3a0-90ec-49a2-9b6f-c684a3adaf26

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D10ComputeShader.D3D10CoreC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1a96796-d592-493c-b7c5-4b3f5ee55cc7

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D10ComputeShader.D3D10CoreC
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader (FL 10.0) (Pri-1)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba2a5b4e-a47e-4d70-9c7f-eb4b740d5f25

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D10ComputeShader.D3D10CoreC
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b437a29-b1ee-4608-8e24-6d2b71288e0b

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Compute Shader (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e74312d-e07c-4d41-92ac-152ac39bae97

This automated test includes multiple test groups, which exercise different features that are specific to Compute Shader stage.

NOTE

A subset of these features is also extended to Pixel Shader stage. Please make sure that the implementations for critical features from different hardware vendors conform to the DX11 spec.

The features covered by this test include the following:

  • Dispatch calls

  • System values for Compute Shader Stage

  • Memory barrier

  • Atomicity of atomic operations

  • Group shared memory

  • Unordered Access Views (UAV) of different resource types

  • Append UAVs

  • Counter UAVs and interactions between Compute Shader stage and Pixel Shader stage

This topic applies to the following test jobs:

  • WGF11 Compute Shader

  • WGF11 Compute Shader (D3D10.x HW Only)

  • WGF11 Compute Shader (D3D10.x HW Only) (WoW64)

  • WGF11 Compute Shader (FL 10.0) (Pri-1)

  • WGF11 Compute Shader (FL 10.0) (Pri-1) (WoW64)

  • WGF11 Compute Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11compute | Rusn the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11compute.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 D3DWDDM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88f5272c-253e-47ee-a30a-c0e4377f103a

This automated test verifies that WDDM drivers expose the necessary DDIs as documented in the WDDM hardware functional spec. For example, the new D3D9 and/or D3D11.1 DDIs are supported on WDDM 1.2 drivers, but not on WDDM 1.0 or 1.1 drivers.

This test runs on all graphics devices with WDDM drivers.

Test details
Specifications
  • Device.Graphics.WDDM12.Render.Base
  • Device.Graphics.WDDM11.Render.Base
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Also, be sure to review the command line parameters; it is suggested that you always use -whql or -featurelevel:[X.Y] to avoid create device issues. The test always uses -whql when run from Windows Hardware Lab Kit (Windows HLK) Studio.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. To review test details, review the test log from Windows Hardware Certification Kit (Windows HLK) Studio. The test might return SKIP, which you should consider to be PASS for the overall test if no WDDM render devices are present on the system. If the test does not detect WDDM render devices and the hardware does support them, a problem exists with the way that the specific device advertises itself.

More information

.

Command syntax

Command option | Description
WGF11D3DWDDM | Without any options, the test's framework will attempt to create a D3D device at the highest possible feature level (currently feature level 11.1). If your device doesn't support this feature level the test will fail. Use either -featurelevel:[X.Y] or -whql to run the test. See -? for more details on command line usage.
-whql | This option specifies a WHLK (WHQL) mode where feature levels are enumerated. You should always use this option when running the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
WGF11D3DWDDM.exe | <[testbinroot]>\nttest\windowstest\Graphics\D3D\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
WDKDeviceID | Device id of DUT


WGF11 D3DWDDM (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/891232c5-f36b-43c8-9b16-b38aab07c8eb

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 D3DWDDM (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f48902ec-375d-4a15-8bed-f482b24a585c

This automated test verifies that WDDM drivers expose the necessary DDIs as documented in the WDDM hardware functional spec. For example, the new D3D9 and/or D3D11.1 DDIs are supported on WDDM 1.2 drivers, but not on WDDM 1.0 or 1.1 drivers.

This test runs on all graphics devices with WDDM drivers.

Test details
Specifications
  • Device.Graphics.WDDM12.Render.Base
  • Device.Graphics.WDDM11.Render.Base
  • Device.Graphics.WDDM.Render.Base
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Also, be sure to review the command line parameters; it is suggested that you always use -whql or -featurelevel:[X.Y] to avoid create device issues. The test always uses -whql when run from Windows Hardware Lab Kit (Windows HLK) Studio.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. To review test details, review the test log from Windows Hardware Certification Kit (Windows HLK) Studio. The test might return SKIP, which you should consider to be PASS for the overall test if no WDDM render devices are present on the system. If the test does not detect WDDM render devices and the hardware does support them, a problem exists with the way that the specific device advertises itself.

More information

.

Command syntax

Command option | Description
WGF11D3DWDDM | Without any options, the test's framework will attempt to create a D3D device at the highest possible feature level (currently feature level 11.1). If your device doesn't support this feature level the test will fail. Use either -featurelevel:[X.Y] or -whql to run the test. See -? for more details on command line usage.
-whql | This option specifies a WHLK (WHQL) mode where feature levels are enumerated. You should always use this option when running the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
WGF11D3DWDDM.exe | <[testbinroot]>\nttest\windowstest\Graphics\D3D\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
WDKDeviceID | Device id of DUT


WGF11 Depth Stencil

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad43f639-5b33-4f7a-81f3-868c7652c655

This automated test verifies D3D graphics driver/hardware conformance for depth stencil functionality and DepthStencilViews.

The features covered by this test include the following:

  • DepthStencil (tests mainly DepthStencilViews) via D3D11 API's

  • Falls back to FL 10.x on D3D10.x parts

  • A Depth/stencil resource stores depth information for primitives rendered on it, with various operations that can be performed on the depth values stored on them against new values being read in. This type of resource is typically used in shadowing applications.

  • Basic functionality for DepthStencil views

  • Cycles through all formats capable of being used for depth-stencil operations

  • Test rendering to Texture 1-D

  • Test rendering to Texture 2-D

  • Varied resource dimensions

  • Array slices

  • Mip levels

  • Basic functionality for ClearDepthStencilView

  • Special floats used to clear view

  • Read-only Depth (D3D11 only)

This topic applies to the following test jobs:

  • WGF11 Depth Stencil

  • WGF11 Depth Stencil (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Some test cases my skip if run using feature level 10.0 or feature level 10.1

More information

.

Command Syntax

Command option | Description
wgf11depthstencil | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11depthstencil.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Depth Stencil (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8fb08bd7-c524-47e4-a2d3-26aa09061187

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Depth Stencil (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa6bef94-f4ce-4e96-9721-ff48cc9afa07

This automated test verifies D3D graphics driver/hardware conformance for depth stencil functionality and DepthStencilViews.

The features covered by this test include the following:

  • DepthStencil (tests mainly DepthStencilViews) via D3D11 API's

  • Falls back to FL 10.x on D3D10.x parts

  • A Depth/stencil resource stores depth information for primitives rendered on it, with various operations that can be performed on the depth values stored on them against new values being read in. This type of resource is typically used in shadowing applications.

  • Basic functionality for DepthStencil views

  • Cycles through all formats capable of being used for depth-stencil operations

  • Test rendering to Texture 1-D

  • Test rendering to Texture 2-D

  • Varied resource dimensions

  • Array slices

  • Mip levels

  • Basic functionality for ClearDepthStencilView

  • Special floats used to clear view

  • Read-only Depth (D3D11 only)

This topic applies to the following test jobs:

  • WGF11 Depth Stencil

  • WGF11 Depth Stencil (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Some test cases my skip if run using feature level 10.0 or feature level 10.1

More information

.

Command Syntax

Command option | Description
wgf11depthstencil | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11depthstencil.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Draw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd0046f6-9516-46e7-8e43-1de84a6de9d7

This automated test verifies that the behavior of draw calls of the graphics drivers/hardware meets the DX11 specification.

NOTE

The test covers draw calls and indirect draw calls.

This topic applies to the following test jobs:

  • WGF11 Draw

  • WGF11 Draw (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

In the Draw test group:

  • Draw functions are cycled, including Draw(), DrawIndexed(), DrawInstanced() and DrawIndexedInstanced().

  • The vertex buffer size, vertex buffer offset, index buffer size, and index buffer offset cycle through different values.

  • The number of elements in the vertex buffer and the input classification cycle through different values.

  • The number of vertices to draw and the start vertex location cycle through different values.

  • Other parameters that are specific to different draw functions, including index count, start index location, instance count, start instance location, and base vertex location, also cycle through different values.

  • Test results are read back from the stream output buffer and verified against expected values.

  • Pipeline statistics, including VSInvocations, IAPrimitives, and IAVertices are verified.

In the DrawIndirect test group:

  • Draw indirect functions are cycled, including DrawInstancedIndirect() and DrawIndexedInstancedIndirect().

  • The methods to fill in the argument buffer include UpdateSubresource, StreamOutput buffer, RenderTarget buffer, and CopyStructureCount.

  • The aligned byte offset for the argument buffer cycles through different values.

  • Test results are read back from the stream output buffer and verified against expected values.

  • Pipeline statistics, including VSInvocations, IAPrimitives, and IAVertices are verified.

Command syntax

Command option | Description
Wgf11draw | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11draw.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDArgs | /get or /sets


WGF11 Draw (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea4951a0-61f1-422a-ad31-457175f62495

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Draw (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d7fd917-d992-4213-988a-d859b26f466b

This automated test verifies that the behavior of draw calls of the graphics drivers/hardware meets the DX11 specification.

NOTE

The test covers draw calls and indirect draw calls.

This topic applies to the following test jobs:

  • WGF11 Draw

  • WGF11 Draw (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

In the Draw test group:

  • Draw functions are cycled, including Draw(), DrawIndexed(), DrawInstanced() and DrawIndexedInstanced().

  • The vertex buffer size, vertex buffer offset, index buffer size, and index buffer offset cycle through different values.

  • The number of elements in the vertex buffer and the input classification cycle through different values.

  • The number of vertices to draw and the start vertex location cycle through different values.

  • Other parameters that are specific to different draw functions, including index count, start index location, instance count, start instance location, and base vertex location, also cycle through different values.

  • Test results are read back from the stream output buffer and verified against expected values.

  • Pipeline statistics, including VSInvocations, IAPrimitives, and IAVertices are verified.

In the DrawIndirect test group:

  • Draw indirect functions are cycled, including DrawInstancedIndirect() and DrawIndexedInstancedIndirect().

  • The methods to fill in the argument buffer include UpdateSubresource, StreamOutput buffer, RenderTarget buffer, and CopyStructureCount.

  • The aligned byte offset for the argument buffer cycles through different values.

  • Test results are read back from the stream output buffer and verified against expected values.

  • Pipeline statistics, including VSInvocations, IAPrimitives, and IAVertices are verified.

Command syntax

Command option | Description
Wgf11draw | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11draw.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Fill Rules

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31378dc1-1124-4488-b703-839bcafff616

This automated test verifies whether the device is consistent with the triangle fill rules and point fill rules as detailed in the DX11 specification.

The test draws geometry in various orientations relative to sample locations, and verifies that fill rules are observed. Test cases cycle on different formats, pixel positions, sample counts, quality levels, and sample indices. The geometry drawn can be a triangle or a point.

This topic applies to the following test jobs:

  • WGF11 Fill Rules

  • WGF11 Fill Rules (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites..

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11fillrules | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11fillrules.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Fill Rules (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e65c7d74-6133-4b63-92e5-f59ab4cdc9db

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Fill Rules (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10cdedbe-ac88-497b-98c6-cf4a74854ef5

This automated test verifies whether the device is consistent with the triangle fill rules and point fill rules as detailed in the DX11 specification.

The test draws geometry in various orientations relative to sample locations, and verifies that fill rules are observed. Test cases cycle on different formats, pixel positions, sample counts, quality levels, and sample indices. The geometry drawn can be a triangle or a point.

This topic applies to the following test jobs:

  • WGF11 Fill Rules

  • WGF11 Fill Rules (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites..

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command syntax

Command option | Description
Wgf11fillrules | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11fillrules.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Filter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a641b9d-a323-4753-a381-6a7102dbc512

This automated test verifies D3D graphics driver/hardware conformance for texture filtering features that are not specifically tested elsewhere.

The following outlines the content of the test

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Texture created with non-symmetric colored pattern

  • All texture types tested independently (1-D, 2-D, 3-D, cube)

  • Texture coordinates cycled for all vertices in tandem, to achieve specific LOD values

  • Texture filter type cycled through all valid types (point, linear, mixed point and linear, with and without mipmap LOD)

  • Texture formats cycled, to find issues with, for example, precision and clamping

  • Texture addressing cycled, independently per dimension and then in tandem

  • One texture unit active, with texture arrays occupying a single unit

  • Texture views cycled for mip-level and array constraints

  • Different sample instructions cycled (biased, fixed LOD, fixed deriv, comparison sample), with corresponding attributes

  • Selected filter types tested for Geometry shader stage and Vertex shader stage

  • Selected filter types tested on textures generated by GenerateMips() function

  • Verify that sample_d works in normalized space

  • Covers resources with per-resource minLOD (only for featurel level 11.0 and above)

This topic applies to the following test jobs:

  • WGF11 Filter

  • WGF11 Filter (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command Syntax

Command option | Description
Wgf11multisample | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11multisample.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Filter (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e9fb683-b06e-4254-92e3-633fe4a31132

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Filter (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e94cba4-f753-45ab-a76e-7451a7469378

This automated test verifies D3D graphics driver/hardware conformance for texture filtering features that are not specifically tested elsewhere.

The following outlines the content of the test

  • Quad rendered to render target

  • Each RT pixel tested programmatically against expected value

  • Texture created with non-symmetric colored pattern

  • All texture types tested independently (1-D, 2-D, 3-D, cube)

  • Texture coordinates cycled for all vertices in tandem, to achieve specific LOD values

  • Texture filter type cycled through all valid types (point, linear, mixed point and linear, with and without mipmap LOD)

  • Texture formats cycled, to find issues with, for example, precision and clamping

  • Texture addressing cycled, independently per dimension and then in tandem

  • One texture unit active, with texture arrays occupying a single unit

  • Texture views cycled for mip-level and array constraints

  • Different sample instructions cycled (biased, fixed LOD, fixed deriv, comparison sample), with corresponding attributes

  • Selected filter types tested for Geometry shader stage and Vertex shader stage

  • Selected filter types tested on textures generated by GenerateMips() function

  • Verify that sample_d works in normalized space

  • Covers resources with per-resource minLOD (only for featurel level 11.0 and above)

This topic applies to the following test jobs:

  • WGF11 Filter

  • WGF11 Filter (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

.

Command Syntax

Command option | Description
Wgf11multisample | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11multisample.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Geometry Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eebf8171-f86b-4a66-b5cb-d5d7cabc9b2c

This automated test verifies verifies D3D graphics driver/hardware conformance for geometry shader features that are not specifically tested elsewhere.

This topic applies to the following test jobs:

  • WGF11 Geometry Shader

  • WGF11 Geometry Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

The following items outline the Geometry Shader Conformance Test Plan:

Geometry Shader Input

  • Verifies support for all input primitive types:

    • Line

    • Point

    • Triangle

    • LineAdj

    • TriangleAdj

  • PrimitiveID

    • Verifies that primitive ordering is respected.

    • PS test should test this for cases where there is no GS in the pipeline.

    • Cycle on Draw() and DrawInstanced().

      NOTE

      Make sure that the id resets to zero for each instance drawn.

  • InstanceID

Geometry Shader Output

  • RenderTargetArrayIndex

  • Position

  • Limits

    NOTE

    Maximum GS invocation output data size (components * vertices) go up to 1024.

  • Ordering (Verifies that primitive ordering is respected.)

Command syntax

Command option | Description
Wgf11geometryshader | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11geometryshader.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Geometry Shader (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/843040b8-0f43-460b-91ab-775c0cd8830e

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Geometry Shader (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aab4f278-c6d0-4b2c-8062-7103b2c7916a

This automated test verifies verifies D3D graphics driver/hardware conformance for geometry shader features that are not specifically tested elsewhere.

This topic applies to the following test jobs:

  • WGF11 Geometry Shader

  • WGF11 Geometry Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 75
Category | Compatibility
Timeout (in minutes) | 4500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

The following items outline the Geometry Shader Conformance Test Plan:

Geometry Shader Input

  • Verifies support for all input primitive types:

    • Line

    • Point

    • Triangle

    • LineAdj

    • TriangleAdj

  • PrimitiveID

    • Verifies that primitive ordering is respected.

    • PS test should test this for cases where there is no GS in the pipeline.

    • Cycle on Draw() and DrawInstanced().

      NOTE

      Make sure that the id resets to zero for each instance drawn.

  • InstanceID

Geometry Shader Output

  • RenderTargetArrayIndex

  • Position

  • Limits

    NOTE

    Maximum GS invocation output data size (components * vertices) go up to 1024.

  • Ordering (Verifies that primitive ordering is respected.)

Command syntax

Command option | Description
Wgf11geometryshader | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11geometryshader.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Input Assembler

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae682378-cab9-4c4d-9c68-f358eebb1998

This automated test examines the Input Assembler stage of the graphics pipeline.

This topic applies to the following test jobs:

  • WGF11 Input Assembler

  • WGF11 Input Assembler (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test verifies the following:

  • Whether the Input Assembler stage of the graphics pipeline operates correctly given the different permutations of input layouts and their slot assignments.

  • Whether the combinations of different buffers as inputs work correctly.

The first test group, "InputLayouts," defined through ID3D11InputLayoutsTest, generates its test cases by permuting on the following factors:

  • Input Slot Classes - different sequences of per-instance and per-vertex data

  • Input Slot assignments - out-of-order slot usage, skipping slots, not using slot 0

  • Instance Data Step Rate

  • Alignments

  • Number of Elements per Input Layout - smaller / bigger than number of elements in shader, maximum allowable number of elements as per the spec

The second test group, "Buffers", defined through CBuffersTest, does the following:

  • Makes sure that indices are respected for IB.

  • Makes sure that buffer bound as a view works.

  • Makes sure that VB works.

  • Cycled through all valid buffer usages and some sizes.

  • Tries huge buffers.

  • Bind max number of buffers, with each buffer of a different usage/pool/CPU access.

  • Draws maximum vertices, index, and instance count.

Command syntax

Command option | Description
Wgf11inputassembler | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11inputassembler.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Input Assembler (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3925251d-18aa-4e45-8c06-38b0a2d4f2d8

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Input Assembler (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b7316ca2-2310-4f8d-8e55-fb35d6128466

This automated test examines the Input Assembler stage of the graphics pipeline.

This topic applies to the following test jobs:

  • WGF11 Input Assembler

  • WGF11 Input Assembler (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

This test verifies the following:

  • Whether the Input Assembler stage of the graphics pipeline operates correctly given the different permutations of input layouts and their slot assignments.

  • Whether the combinations of different buffers as inputs work correctly.

The first test group, "InputLayouts," defined through ID3D11InputLayoutsTest, generates its test cases by permuting on the following factors:

  • Input Slot Classes - different sequences of per-instance and per-vertex data

  • Input Slot assignments - out-of-order slot usage, skipping slots, not using slot 0

  • Instance Data Step Rate

  • Alignments

  • Number of Elements per Input Layout - smaller / bigger than number of elements in shader, maximum allowable number of elements as per the spec

The second test group, "Buffers", defined through CBuffersTest, does the following:

  • Makes sure that indices are respected for IB.

  • Makes sure that buffer bound as a view works.

  • Makes sure that VB works.

  • Cycled through all valid buffer usages and some sizes.

  • Tries huge buffers.

  • Bind max number of buffers, with each buffer of a different usage/pool/CPU access.

  • Draws maximum vertices, index, and instance count.

Command syntax

Command option | Description
Wgf11inputassembler | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11inputassembler.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Interfaces

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e750e13-78da-48b8-b53f-41445b80c5c0

This automated test verifies different parts of the hardware and the driver for valid shader execution when interfaces are used.

The test focuses on covering hidden buffer information that is provided to the driver through the DDI, which includes interface types and resource locations. Some information that is used in interfaces is embedded in the shader itself, such as the function tables and class type tables. The hardware is only required to correctly call and index these tables, because the runtime does all the management required to keep the information organized and mapped correctly.

The test only executes valid scenarios and verifies results are successful. No failures are expected to occur on certifiable D3D11 hardware.

The test logs to WTT as previous conformance tests have, and contain useful information about the failure to help IHVs to debug their failures.

This topic applies to the following test jobs:

  • WGF11 Interfaces

  • WGF11 Interfaces (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test returns SKIP when run on feature level < 11. The test returns SKIP when run on feature level < 11.

More information

WGF11Interfaces - Interface Shader Execution

The WGF11Interfaces cover all aspects of data transfer to the driver, along with correct execution of shader IL.

A description of each test group and the necessary command-line parameter is listed later in this section. Whole shaders are not provided in this documentation. However, a description of the shader's intended goal and the types of inputs are described to provide information about how to test in Windows Hardware Quality Labs (WHQL). In addition, each test is run on all shader stages to verify consistent behavior for a feature that adheres to the unified architecture goals.

The tests use ints and uints as inputs and during calculation wherever possible, because precision and verification of floating point math is covered in a different conformance test.

Tests that use samplers perform point sampling and use border color to verify whether the correct sampler is used. Filtering and other aspects of sampler coverage are covered in a different conformance test. Interface testing is only concerned with the correct indexing of samplers that are used by class instances during execution.

Tests that use resources focus on formats with 8-bit channels and no MIP levels. Other tests verify resource correctness. Interface testing is only concerned with the correct indexing of textures that are used by class instances during execution. Only resource loads are used. Because they cannot be indexed, UAVs are not important for interfaces.

Tests are run against every shader stage, because the feature is supposed to fit within the unified architecture of Shader Model 5.0.

Each test has a Pri-1 task and a Pri-2 task, which, when combined, complete coverage of the feature. Pri-1 tasks require that a test to run only on a specific shader stage. Pri-2 tasks test the remaining shader stages.

All instances are created by the runtime using the following API calls:

HRESULT CreateClassInstance(LPCWSTR pszClassTypeName,UINT ConstantBufferOffset,UINT ConstantVectorOffset,UINT TextureOffset,UINT SamplerOffset,ID3D11ClassInstance **ppInstance);

Instances are set when the shader is set by using XXSetShader() calls.

WGF11Interfaces.exe Interfaces\FunctionTables and fcall\[ PS]

Pri-1 16 hours

The large function table test verifies whether hardware is able to manage the shader programs output by the compiler. This verification is specific to shaders that have many cascading interface calls that resulted in large generations of code that have many function bodies. This test does not test the performance of such shaders, but tests whether the execution is correct when compared against the reference rasterizer.

Several shaders are written that will sequentially double the number of function bodies that are created by the compiler. These shaders are then run with several variations on the instances that fill the slots, in order to verify correct execution through a subset of code paths. At any time, the test may attempt to validate all code paths, and it is expected that hardware will not fail on any of them. If the hardware returns out-of-memory during shader creation time, the test returns RESULT_SKIP, when reasonable. The resource requirements of these shaders should not push the limits of hardware. As such, the shader should bind and execute just fine. If hardware fails on even small function tables, a warning occurs. The hardware should support a minimum of 4 KB function bodies.

The cascading functions are designed by using several interface types, each which relies on an object of another instance for its parameter. These calls are designed to be several layers deep and may easily result in more than 1k function bodies to be created.

The test also provides coverage of the fcall instruction by extensively calling other functions to get appropriate coverage of the 4 KB function bodies in the shader. This can be done by varying the bound instances by using XXSetShader by the runtime. The framework provides a simple way to get adequate coverage through permutations of bound types.

To ensure that the test does not need maintenance due to changes in the compiler, each function body must be unique from all other function bodies. This is because the compiler may at some point collapse function bodies with identical code to reduce code size and provide a more optimized function table. By ensuring that all function bodies are different, you prevent the test from being changed or becoming obsolete when this optimization is added to the compiler. It is important to review the IL to make sure that the expected code is produced.

Example:

interface Type0{ float2 func( float x );};interface Type1{ float4 func( const Type0 param, inout float2 y );};interface Type2{ float func( Type0 param0, Type1 param1 );};interface Type3{ uint func( out float z, Type0 param0, Type1 param1, Type2 param2 );};class AT0 : Type0;class BT0 : Type0;class CT0 : Type0;class DT0 : Type0;class ET0 : Type0;class FT0 : Type0;class AT1 : Type1;class BT1 : Type1;class CT1 : Type1;class DT1 : Type1;class AT2 : Type2;class BT2 : Type2;class CT2 : Type2;class DT2 : Type2;class ET2 : Type2;class AT3 : Type3;class BT3 : Type3;class CT3 : Type3;class DT3 : Type3;class ET3 : Type3;class FT3 : Type3;

If the interface for Type3 is called, and each implementation calls the interface method of an input parameter, 720 function bodies are created by all possible code paths, each one optimized for its particular code path. Because there is no limitation to code size other than memory, even very large shaders should execute without error.

Shader code is optimized across fcall sites, so it is possible for each call to be unique based on information from the caller and the callee. Simple multiplying by a constant is not enough; instead, each function body must be unique by doing different operations and using member variables. The resulting output must be verified, so multiplication by prime numbers or something similar would work. To verify that the shader was executed correctly, the same math must be done on the CPU based on the bound class instances.

This test also covers call tree depth (32). It is important to test that more than 32 fcalls result in no-ops (you can only test 33 at a given time). The compiler does not allow code to be written to simply test this case, so you need a more sophisticated approach that can dynamically change the call depth and verify that each call was made (or not made).

A fibinachi sequence or similar could be useful for this. Recursive calls are not allowed, so there must be 33 interfaces that can be called one after another. Locally, the instances must decide whether or not to continue the fcall depth. The runtime binds the data to drive these tests.

This test is written for the pixel shader as Pri-1.

Completion of this test proves the following:

  • The fcall works.

  • The function tables are correct and are being used correctly.

  • The 4 KB function table limit is supported.

  • The call depth is 32.

Results for the test are captured in the following render target:

WGF11Interfaces.exe Interfaces\FunctionTables and fcall \[VS,GS, HS,DS,CS]

Pri-2

The test covers all shader stages.

Verification of this feature supports a wide range of valid design patterns and OO programming techniques that Shader Model 5.0 was designed to support.

Results for these tests are captured in a stream out buffer for VS,HS,DS, and GS. Results for PS and CS are captured by render targets and writeable buffers.

WGF11Interfaces.exe Interfaces\GroupExecutionPathDifferences\[ CS]

Pri-1 40 hours

Exploiting parallelism is very important when designing hardware. However, capitalizing on such opportunities should not disrupt the correct execution of a shader when code paths diverge. This test runs on each shader stage and provides coverage that executes different code paths despite the fact that pixels, vertices, and other pipeline stage primitives might be getting executed as lock step groups. This test does not test performance in such cases. Instead, it is only verifies a valid result after execution.

Providing data to each pipeline stage is important and must be done in sizeable chunks to verify coverage of varied execution across groups. The following method provides the data to the tests for each shader stage:

  • Compute Shader:

    Data that is used to select instances that are based on array slots is provided by using resources to the compute shader. The SV_GroupID and SV_GroupThreadID are used to select the correct data from the resource to choose which class instances to use during the invocation of a shader. The results of execution are written to a writable buffer to be verified that it is correct. A large dimension count of threads in each dimension is used. This includes large prime numbers of threads and multiple groups that will be dispatched to get adequate coverage for this test.

Each hardware thread should execute a method call in a different type provided by the runtime. The runtime is able to calculate the result for verification based on the type used, the data provided, and the algorithm of the type. The code for each method should vary in length and complexity to prove the hardware can handle shaders like this. 12-18 different class implementations should be used, and each SV_[Index] value can be pseudo modded to pick which array index and which class instance to execute.

WGF11Interfaces.exe Interfaces\GroupExecutionPathDifferences\[VS,GS,PS,HS,DS]

Pri-2 40 hours

The test is extended to the other shader stages.

  • Vertex Shader:

    A set of interface slot array indexes are added to the vertex data and used during vertex shader execution to determine which interface instance to invoke. The data also covers which instances are used as parameters when methods are invoked. A block of at least 512 points are drawn to verify hardware behavior. The results are caught by a stream out buffer.

  • Hull Shader:

    The interface slot array indexes are added to the control point input structure, allowing each point to determine which class instances are invoked over the course of the shader. That data also covers which instances are used as parameters when methods are invoked. A full 32 point patch is drawn several times to verify hardware behavior. The results will be caught by a stream out buffer.

    This test also forwards the data to the Patch Constant function, which also verifies correct behavior.

    In addition, the SV_OutputControlPointID and specific forking code are turned on in the compiler. The forking code causes divergent code execution paths by using interfaces in this stage as well. Forking can be accessed by using a loop and calling an interface method from within the loop.

  • Domain Shader:

    Data is passed through the Hull shader on each control point and then recovered by using the SV_PrimitiveID available in the Domain Shader. The tessellator output positions are combined with the SV_PrimitiveID to create the indexes into the available class instance slots during execution. The full 32 point patch is drawn several times to verify hardware behavior. The results are caught by a stream out buffer. The focus is not to cover all domain types.

  • Geometry Shader:

    Interface slot indexes are attached to point primitives that are provided to the geometry shader. The indexes are used to choose class instances to invoke methods on and use as parameters during shader execution. A block of at least 512 points are drawn to verify hardware behavior. The results are captured in a stream out buffer for verification.

  • Pixel Shader:

    For pixel shaders, a texture is used to provide the class instance indexes for each pixel. The texture exactly matches the size of the render target by drawing a large quad. An area of at least 512x512 pixels is drawn, with the supporting resources, to verify hardware behavior. The results are captured in a render target for validation. SV_Position and SV_SampleIndex can also be used to determine how a pixel indexes into the interface slots. Drawing a triangle is more interesting than drawing a quad.

WGF11Interfaces.exe Interfaces\IndexingResources and this[]\[VS]

Pri-1 26 hours

All resources that are used by an interface were made indexable by the IL in order to support dynamic runtime binding. The data is provided through the DDI and includes the following information:

  • Class type ID

  • Cbuffer

  • Cbuffer offset

  • Texture slot

  • Sampler slot

This test ensures that all this information is used correctly by the driver and shader execution. Access to this information can only be done through the "this" keyword, which uses a hidden reserved buffer. Class instances that are 256 bytescan be bound to a shader, so this test provides coverage for using all 256 instance slots. Doing so implies that this needs to be used in combination with each of the other areas in this test. However, the other areas do not need to be verified through permutation with each other.

The test cycles location for all the different slots and offsets in the resources and uses those resources when producing results.

In order to get full coverage, each class instances should execute a method that makes use of the resource data to produce a result. By doing this, it ensures that the instance type ID is being used correctly with respect to the function tables.

Each cbuffer must be tested for class data. The data needs to be placed throughout the buffer using the offset parameter. This can be done by binding 256 instances each with a different location set by the runtime. The shader can execute 256 vertices and use the SV_PrimitiveID to determine the instance slot to use.

Each tbuffer slot in the 128 available must be used in the same way as mentioned previously. Only a simple buffer or texture2d need be used, and only the load instruction is tested. The test is only interested in correct indexing of the texture registers.

Each sampler slot in the 16 available to a shader stage must be used in the same way as mentioned previously. Samplers will be sampled outside of texture boundary so that a border color is returned. Each of the 16 samplers should have a unique border color in order for the test to verify that the correct sampler was used.

These can be tested separately--combined coverage is unnecessary.

F11Intefaces.exe Interfaces\IndexingResources and this[]\[GS,PS,HS,DS,CS]

Pri-2 26 hours

The previous test is extended to cover all shader stages.

(Pri 1 18 hours) The deferred context should also be used in these tests.

The test cases outlined will also be run on a deferred context by using command lists to set classes and instances.

Command lists do not inherit state from the immediate context. Therefore, instances set on the immediate context should not be accessible when executing a command list.

State clearing on the deferred context (through the bool parameter in ExecuteCommandList and FinishCommandList) should be tested with interfaces and classes.

Command syntax

Command option | Description
Wgf11interfaces | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature lewlve, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11interfaces.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Interfaces (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e59758f-732a-477a-a382-ffde0fcc9ee0

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Interfaces (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00f1fc0c-237b-49b9-a4c3-1a5935d6460b

This automated test verifies different parts of the hardware and the driver for valid shader execution when interfaces are used.

The test focuses on covering hidden buffer information that is provided to the driver through the DDI, which includes interface types and resource locations. Some information that is used in interfaces is embedded in the shader itself, such as the function tables and class type tables. The hardware is only required to correctly call and index these tables, because the runtime does all the management required to keep the information organized and mapped correctly.

The test only executes valid scenarios and verifies results are successful. No failures are expected to occur on certifiable D3D11 hardware.

The test logs to WTT as previous conformance tests have, and contain useful information about the failure to help IHVs to debug their failures.

This topic applies to the following test jobs:

  • WGF11 Interfaces

  • WGF11 Interfaces (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test returns SKIP when run on feature level < 11. The test returns SKIP when run on feature level < 11.

More information

WGF11Interfaces - Interface Shader Execution

The WGF11Interfaces cover all aspects of data transfer to the driver, along with correct execution of shader IL.

A description of each test group and the necessary command-line parameter is listed later in this section. Whole shaders are not provided in this documentation. However, a description of the shader's intended goal and the types of inputs are described to provide information about how to test in Windows Hardware Quality Labs (WHQL). In addition, each test is run on all shader stages to verify consistent behavior for a feature that adheres to the unified architecture goals.

The tests use ints and uints as inputs and during calculation wherever possible, because precision and verification of floating point math is covered in a different conformance test.

Tests that use samplers perform point sampling and use border color to verify whether the correct sampler is used. Filtering and other aspects of sampler coverage are covered in a different conformance test. Interface testing is only concerned with the correct indexing of samplers that are used by class instances during execution.

Tests that use resources focus on formats with 8-bit channels and no MIP levels. Other tests verify resource correctness. Interface testing is only concerned with the correct indexing of textures that are used by class instances during execution. Only resource loads are used. Because they cannot be indexed, UAVs are not important for interfaces.

Tests are run against every shader stage, because the feature is supposed to fit within the unified architecture of Shader Model 5.0.

Each test has a Pri-1 task and a Pri-2 task, which, when combined, complete coverage of the feature. Pri-1 tasks require that a test to run only on a specific shader stage. Pri-2 tasks test the remaining shader stages.

All instances are created by the runtime using the following API calls:

HRESULT CreateClassInstance(LPCWSTR pszClassTypeName,UINT ConstantBufferOffset,UINT ConstantVectorOffset,UINT TextureOffset,UINT SamplerOffset,ID3D11ClassInstance **ppInstance);

Instances are set when the shader is set by using XXSetShader() calls.

WGF11Interfaces.exe Interfaces\FunctionTables and fcall\[ PS]

Pri-1 16 hours

The large function table test verifies whether hardware is able to manage the shader programs output by the compiler. This verification is specific to shaders that have many cascading interface calls that resulted in large generations of code that have many function bodies. This test does not test the performance of such shaders, but tests whether the execution is correct when compared against the reference rasterizer.

Several shaders are written that will sequentially double the number of function bodies that are created by the compiler. These shaders are then run with several variations on the instances that fill the slots, in order to verify correct execution through a subset of code paths. At any time, the test may attempt to validate all code paths, and it is expected that hardware will not fail on any of them. If the hardware returns out-of-memory during shader creation time, the test returns RESULT_SKIP, when reasonable. The resource requirements of these shaders should not push the limits of hardware. As such, the shader should bind and execute just fine. If hardware fails on even small function tables, a warning occurs. The hardware should support a minimum of 4 KB function bodies.

The cascading functions are designed by using several interface types, each which relies on an object of another instance for its parameter. These calls are designed to be several layers deep and may easily result in more than 1k function bodies to be created.

The test also provides coverage of the fcall instruction by extensively calling other functions to get appropriate coverage of the 4 KB function bodies in the shader. This can be done by varying the bound instances by using XXSetShader by the runtime. The framework provides a simple way to get adequate coverage through permutations of bound types.

To ensure that the test does not need maintenance due to changes in the compiler, each function body must be unique from all other function bodies. This is because the compiler may at some point collapse function bodies with identical code to reduce code size and provide a more optimized function table. By ensuring that all function bodies are different, you prevent the test from being changed or becoming obsolete when this optimization is added to the compiler. It is important to review the IL to make sure that the expected code is produced.

Example:

interface Type0{ float2 func( float x );};interface Type1{ float4 func( const Type0 param, inout float2 y );};interface Type2{ float func( Type0 param0, Type1 param1 );};interface Type3{ uint func( out float z, Type0 param0, Type1 param1, Type2 param2 );};class AT0 : Type0;class BT0 : Type0;class CT0 : Type0;class DT0 : Type0;class ET0 : Type0;class FT0 : Type0;class AT1 : Type1;class BT1 : Type1;class CT1 : Type1;class DT1 : Type1;class AT2 : Type2;class BT2 : Type2;class CT2 : Type2;class DT2 : Type2;class ET2 : Type2;class AT3 : Type3;class BT3 : Type3;class CT3 : Type3;class DT3 : Type3;class ET3 : Type3;class FT3 : Type3;

If the interface for Type3 is called, and each implementation calls the interface method of an input parameter, 720 function bodies are created by all possible code paths, each one optimized for its particular code path. Because there is no limitation to code size other than memory, even very large shaders should execute without error.

Shader code is optimized across fcall sites, so it is possible for each call to be unique based on information from the caller and the callee. Simple multiplying by a constant is not enough; instead, each function body must be unique by doing different operations and using member variables. The resulting output must be verified, so multiplication by prime numbers or something similar would work. To verify that the shader was executed correctly, the same math must be done on the CPU based on the bound class instances.

This test also covers call tree depth (32). It is important to test that more than 32 fcalls result in no-ops (you can only test 33 at a given time). The compiler does not allow code to be written to simply test this case, so you need a more sophisticated approach that can dynamically change the call depth and verify that each call was made (or not made).

A fibinachi sequence or similar could be useful for this. Recursive calls are not allowed, so there must be 33 interfaces that can be called one after another. Locally, the instances must decide whether or not to continue the fcall depth. The runtime binds the data to drive these tests.

This test is written for the pixel shader as Pri-1.

Completion of this test proves the following:

  • The fcall works.

  • The function tables are correct and are being used correctly.

  • The 4 KB function table limit is supported.

  • The call depth is 32.

Results for the test are captured in the following render target:

WGF11Interfaces.exe Interfaces\FunctionTables and fcall \[VS,GS, HS,DS,CS]

Pri-2

The test covers all shader stages.

Verification of this feature supports a wide range of valid design patterns and OO programming techniques that Shader Model 5.0 was designed to support.

Results for these tests are captured in a stream out buffer for VS,HS,DS, and GS. Results for PS and CS are captured by render targets and writeable buffers.

WGF11Interfaces.exe Interfaces\GroupExecutionPathDifferences\[ CS]

Pri-1 40 hours

Exploiting parallelism is very important when designing hardware. However, capitalizing on such opportunities should not disrupt the correct execution of a shader when code paths diverge. This test runs on each shader stage and provides coverage that executes different code paths despite the fact that pixels, vertices, and other pipeline stage primitives might be getting executed as lock step groups. This test does not test performance in such cases. Instead, it is only verifies a valid result after execution.

Providing data to each pipeline stage is important and must be done in sizeable chunks to verify coverage of varied execution across groups. The following method provides the data to the tests for each shader stage:

  • Compute Shader:

    Data that is used to select instances that are based on array slots is provided by using resources to the compute shader. The SV_GroupID and SV_GroupThreadID are used to select the correct data from the resource to choose which class instances to use during the invocation of a shader. The results of execution are written to a writable buffer to be verified that it is correct. A large dimension count of threads in each dimension is used. This includes large prime numbers of threads and multiple groups that will be dispatched to get adequate coverage for this test.

Each hardware thread should execute a method call in a different type provided by the runtime. The runtime is able to calculate the result for verification based on the type used, the data provided, and the algorithm of the type. The code for each method should vary in length and complexity to prove the hardware can handle shaders like this. 12-18 different class implementations should be used, and each SV_[Index] value can be pseudo modded to pick which array index and which class instance to execute.

WGF11Interfaces.exe Interfaces\GroupExecutionPathDifferences\[VS,GS,PS,HS,DS]

Pri-2 40 hours

The test is extended to the other shader stages.

  • Vertex Shader:

    A set of interface slot array indexes are added to the vertex data and used during vertex shader execution to determine which interface instance to invoke. The data also covers which instances are used as parameters when methods are invoked. A block of at least 512 points are drawn to verify hardware behavior. The results are caught by a stream out buffer.

  • Hull Shader:

    The interface slot array indexes are added to the control point input structure, allowing each point to determine which class instances are invoked over the course of the shader. That data also covers which instances are used as parameters when methods are invoked. A full 32 point patch is drawn several times to verify hardware behavior. The results will be caught by a stream out buffer.

    This test also forwards the data to the Patch Constant function, which also verifies correct behavior.

    In addition, the SV_OutputControlPointID and specific forking code are turned on in the compiler. The forking code causes divergent code execution paths by using interfaces in this stage as well. Forking can be accessed by using a loop and calling an interface method from within the loop.

  • Domain Shader:

    Data is passed through the Hull shader on each control point and then recovered by using the SV_PrimitiveID available in the Domain Shader. The tessellator output positions are combined with the SV_PrimitiveID to create the indexes into the available class instance slots during execution. The full 32 point patch is drawn several times to verify hardware behavior. The results are caught by a stream out buffer. The focus is not to cover all domain types.

  • Geometry Shader:

    Interface slot indexes are attached to point primitives that are provided to the geometry shader. The indexes are used to choose class instances to invoke methods on and use as parameters during shader execution. A block of at least 512 points are drawn to verify hardware behavior. The results are captured in a stream out buffer for verification.

  • Pixel Shader:

    For pixel shaders, a texture is used to provide the class instance indexes for each pixel. The texture exactly matches the size of the render target by drawing a large quad. An area of at least 512x512 pixels is drawn, with the supporting resources, to verify hardware behavior. The results are captured in a render target for validation. SV_Position and SV_SampleIndex can also be used to determine how a pixel indexes into the interface slots. Drawing a triangle is more interesting than drawing a quad.

WGF11Interfaces.exe Interfaces\IndexingResources and this[]\[VS]

Pri-1 26 hours

All resources that are used by an interface were made indexable by the IL in order to support dynamic runtime binding. The data is provided through the DDI and includes the following information:

  • Class type ID

  • Cbuffer

  • Cbuffer offset

  • Texture slot

  • Sampler slot

This test ensures that all this information is used correctly by the driver and shader execution. Access to this information can only be done through the "this" keyword, which uses a hidden reserved buffer. Class instances that are 256 bytescan be bound to a shader, so this test provides coverage for using all 256 instance slots. Doing so implies that this needs to be used in combination with each of the other areas in this test. However, the other areas do not need to be verified through permutation with each other.

The test cycles location for all the different slots and offsets in the resources and uses those resources when producing results.

In order to get full coverage, each class instances should execute a method that makes use of the resource data to produce a result. By doing this, it ensures that the instance type ID is being used correctly with respect to the function tables.

Each cbuffer must be tested for class data. The data needs to be placed throughout the buffer using the offset parameter. This can be done by binding 256 instances each with a different location set by the runtime. The shader can execute 256 vertices and use the SV_PrimitiveID to determine the instance slot to use.

Each tbuffer slot in the 128 available must be used in the same way as mentioned previously. Only a simple buffer or texture2d need be used, and only the load instruction is tested. The test is only interested in correct indexing of the texture registers.

Each sampler slot in the 16 available to a shader stage must be used in the same way as mentioned previously. Samplers will be sampled outside of texture boundary so that a border color is returned. Each of the 16 samplers should have a unique border color in order for the test to verify that the correct sampler was used.

These can be tested separately--combined coverage is unnecessary.

F11Intefaces.exe Interfaces\IndexingResources and this[]\[GS,PS,HS,DS,CS]

Pri-2 26 hours

The previous test is extended to cover all shader stages.

(Pri 1 18 hours) The deferred context should also be used in these tests.

The test cases outlined will also be run on a deferred context by using command lists to set classes and instances.

Command lists do not inherit state from the immediate context. Therefore, instances set on the immediate context should not be accessible when executing a command list.

State clearing on the deferred context (through the bool parameter in ExecuteCommandList and FinishCommandList) should be tested with interfaces and classes.

Command syntax

Command option | Description
Wgf11interfaces | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature lewlve, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11interfaces.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /sets


WGF11 Multisample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7d608c2-527d-45c2-a16a-ac316c2322a6

This automated test verifies that the multisampling behavior of the device is consistent with the DX11 specification.

This topic applies to the following test jobs:

  • WGF11 Multisample

  • WGF11 Multisample (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D10Multisampling4X.D3D10CoreA
  • Device.Graphics.AdapterRender.D3D10Multisampling8X.D3D10CoreB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case returns Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case returns Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

This test examines the following:

  • Sample Count

  • Sample Positions for standard pattern

  • Area-to-Coverage

  • Sample Mask

  • Occlusion Query and Predicate for multisampled render target

  • Multisample Resolve

  • Centroid Attributes

  • Centroid Definition (only Feature Level 11.0 and above)

  • Sample Frequency Attributes, SV_COVERAGE (only Feature Level 11.0 and above)

  • Depth test for multisampled render target

NOTE

Test cases are arranged into sub-groups with different sample counts, quality levels and render targets formats.

Command syntax

Command option | Description
Wgf11multisample.exe | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11multisample.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Multisample (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bf903df7-cca3-442f-bb65-7800b17e2b10

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Multisample (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/adaf8993-b557-447a-bebe-5262143ff9d6

This automated test verifies that the multisampling behavior of the device is consistent with the DX11 specification.

This topic applies to the following test jobs:

  • WGF11 Multisample

  • WGF11 Multisample (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D10Multisampling4X.D3D10CoreA
  • Device.Graphics.AdapterRender.D3D10Multisampling8X.D3D10CoreB
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results:

  • Pass

  • Fail

  • Blocked

  • Skipped

The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case returns Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case returns Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

This test examines the following:

  • Sample Count

  • Sample Positions for standard pattern

  • Area-to-Coverage

  • Sample Mask

  • Occlusion Query and Predicate for multisampled render target

  • Multisample Resolve

  • Centroid Attributes

  • Centroid Definition (only Feature Level 11.0 and above)

  • Sample Frequency Attributes, SV_COVERAGE (only Feature Level 11.0 and above)

  • Depth test for multisampled render target

NOTE

Test cases are arranged into sub-groups with different sample counts, quality levels and render targets formats.

Command syntax

Command option | Description
Wgf11multisample.exe | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11multisample.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Pixel Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62ac2876-3a48-4ec6-bb38-dab847a3c232

This automated test verifies that the pixel shader behavior of the graphics hardware/drivers meets the Microsoft DirectX 11 specification.

This topic applies to the following test jobs:

  • WGF11 Pixel Shader

  • WGF11 Pixel Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return Pass, Fail, Blocked, or Skipped. To review test details, review the test log from the DTM Studio. The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case returns Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case returns Blocked if the failure is caused by reasons other than the tested feature.

More information

.

Command syntax

Command option | Description
Wgf11pixelshader | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11pixelshader.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Pixel Shader (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a247eb9-9af0-4915-b57f-2325a50096b0

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Pixel Shader (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/239b17a1-75cb-4017-a71a-726d83cda774

This automated test verifies that the pixel shader behavior of the graphics hardware/drivers meets the Microsoft DirectX 11 specification.

This topic applies to the following test jobs:

  • WGF11 Pixel Shader

  • WGF11 Pixel Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return Pass, Fail, Blocked, or Skipped. To review test details, review the test log from the DTM Studio. The log file contains specific details about the test cases that are failed, blocked, or skipped. A test case returns Skipped if it is invalid according to the current hardware configuration (some features are optional and may not be supported by some hardware) and the command line options (some test cases are only valid for certain feature levels). A test case returns Blocked if the failure is caused by reasons other than the tested feature.

More information

.

Command syntax

Command option | Description
Wgf11pixelshader | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11pixelshader.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Precision

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1dd39dce-ab9c-4d3e-aae7-f824cf2fd64f

This automated test ensures that when shaders specify the minimum partial precision flag (8, 10, or 16-bit) that IHVs do not use a lower precision for calculations. For example, the shader specifies 16-bit but the IHV uses 10-bit.

This topic is applicable to the following test cases:

  • WGF11 Precision

  • WGF11 Precision (WoW64)

  • WGF11 Precision FL9.3

  • WGF11 Precision FL9.3 (WoW64)

NOTE

Using higher precision than the minimum specified value is valid.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11PartialPrecision.D3D11CoreE
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test will always return Pass if precision is handled correctly, or return Fail if not. To review test details, review the test log from the Windows HLK Manager.

If the partial precision test fails, try setting your driver to ignore the partial precision flags. If that passes, then it means that when you are attempting to follow the partial precision flags, you are using a lower precision than what the shader specified. E.g. The shader asked for 16-bit minimum, but you are using 8-bit or 10-bit. If you ignore the partial precision flags, and it still fails, ensure other conformance tests pass because the test relies on things like "sample" working correctly.

More information

The partial precision group in WGF11Precision.exe ensures that when shaders specify the minimum partial precision flag (8, 10, or 16-bit) that IHVs do not use a lower precision for calculations. For example, the shader specifies 16-bit but the IHV uses 10-bit. Using higher precision than the minimum specified value is valid.

Command syntax

Command option | Description
WGF11Precision.exe | Runs the test jobs.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Precision.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Precision (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e4938753-7d65-4b76-b93d-5caf24d040eb

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Precision (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fdf821ce-cfc7-4ce0-8546-70d1584df0c6

This automated test ensures that when shaders specify the minimum partial precision flag (8, 10, or 16-bit) that IHVs do not use a lower precision for calculations. For example, the shader specifies 16-bit but the IHV uses 10-bit.

This topic is applicable to the following test cases:

  • WGF11 Precision

  • WGF11 Precision (WoW64)

  • WGF11 Precision FL9.3

  • WGF11 Precision FL9.3 (WoW64)

NOTE

Using higher precision than the minimum specified value is valid.

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11PartialPrecision.D3D11CoreE
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

This test will always return Pass if precision is handled correctly, or return Fail if not. To review test details, review the test log from the Windows HLK Manager.

If the partial precision test fails, try setting your driver to ignore the partial precision flags. If that passes, then it means that when you are attempting to follow the partial precision flags, you are using a lower precision than what the shader specified. E.g. The shader asked for 16-bit minimum, but you are using 8-bit or 10-bit. If you ignore the partial precision flags, and it still fails, ensure other conformance tests pass because the test relies on things like "sample" working correctly.

More information

The partial precision group in WGF11Precision.exe ensures that when shaders specify the minimum partial precision flag (8, 10, or 16-bit) that IHVs do not use a lower precision for calculations. For example, the shader specifies 16-bit but the IHV uses 10-bit. Using higher precision than the minimum specified value is valid.

Command syntax

Command option | Description
WGF11Precision.exe | Runs the test jobs.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
WGF11Precision.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Rasterizer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/505e9736-ad3e-4503-99c9-1298ce0b3a50

This automated test verifies various aspects of the D3D primitive rasterizer and rasterizer state as implemented by hardware.

This topic applies to the following test jobs:

  • WGF11 Rasterizer

  • WGF11 Rasterizer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

For D3D10 and above, this test verifies the following:

  • Primitive culling, fill mode, and winding order based on the rasterizer state.

  • Interpolation modes in the pixel shader

    • Constant mode is simple, because there is no change from the values sent from the vertex shader.

    • Because it is not tightly spec'd, linear modes are verified by ensuring that adjacent pixels are not equal and follow the gradient of an edge.

  • Sample frequency pixel shader invocation (D3D10.1 and above).

For D3D11, this test verifies pull model attribute evaluation.

The following intrinsic functions will be introduced into D3D11 (HLSL 5.0) for the feature of pull-model attribute evaluation:

  • EvaluateAttributeSnapped( attrib numeric value, int2 pixeloffset )

  • EvaluateAttributeAtSample( attrib numeric value, uint sampleindex )

  • EvaluateAttributeAtCentroid( attrib numeric value )

For each intrinsic function, a set of pixel shaders will be generated, targeting the cases on different combinations of the parameter values of the intrinsic function and the declared interpolation modes of the input attributes.

The following are test factors for all three intrinsics:

  • Input attributes passed from the Vertex shader.

    NOTE

    Only float type attribute can be interpolated; int/uint type will always be constant interpolation mode

    • float4 texCoord : TEXCOORD

    • float4 color : COLOR

    • float clipDis : SV_ClipDistance

  • Declarations of interpolation modes.

    NOTE

    Nointerpolation mode is not allowed by the HLSL compiler when the corresponding attribute is evaluated with pull-model in the shader.

    • linear

    • linear noPerspective

    • linear centroid

    • linear sample

    • linear noPerspective centroid

    • linear noPerspective sample

  • Primitives to draw:

    • When the interpolation mode is linear, a triangle C1-C2-C3 as follows will be drawn. This covers one whole pixel and two half pixels. The coordinates of the vertices in projection space are as the following:

      <need image here

      C1: (-1, 1, 0), C2(-1, -1, 0), C3(1, 1, 0).

      Right triangle within a square, with vertices C1, C2, and C3; C1 forms the 90-degree angle and is at the upper-left corner of the square

  • When the interpolation mode is noperspective, a triangle A-B-C with the following vertex coordinates in the projection space will be drawn:

    A:(-1, 1, 1);

    B:(-1, -1, 0);

    C:(1, 1, 1)

    The screen space triangle should cover the same pixels and pixel areas as triangle C1-C2-C3 shown above.

  • Render target

    • Format: All formats supporting render target.

    • Sample count: 1, 2, ... the maximum supported sample count.

Different values of pixeloffset for EvaluateAttributeSnapped( )

Ideally, all possible 256 offset positions. If the test runs too long, this group of test cases will be reduced to 4 corner positions, 8 border positions, 4 positions from 4x4 grid, 4 positions from 8x8 grid, and 4 positions from 16x16 grid.

Different values of sampleindex for EvaluateAttributeAtSample( )

All sample indices supported by the render target

The verification method begins when the pixel shader writes the interpolated attribute value to the render target. The render target data is then mapped and read out. In cases of multisampled render targets, multisample resolve is required before mapping. The result data will be compared with pre-calculated interpolated data or data got from direct accessing the attribute.

  1. When interpolation mode is linear noperspective:

    1. Calculate and store the interpolated (and extrapolated for uncovered area of p2 and p3) values for 256 offset positions of each pixels of p1, p2, p3.

    2. For EvaluateAttributeSnapped :

      • Pixel p1 should have "pulled " attribute value in between of the expected values for left and right (as well as upper and lower) neighboring offsets of the "pulled" offset.

      • Pixels p2 and p3:

        In single-sampled cases, they should not be rendered.

        In multi-sampled cases, they should have "pulled" attribute value in between of the expected values for left and right (as well as upper and lower) neighboring offsets of the "pulled" offset.

    3. For EvaluateAttributeAtSample with SampleFinder, find the position of the sample index on the sample coordinate system with range [-8, 7]. Use this position to do the verification the same way as in EvaluateAttributeSnapped above.

    4. For EvaluateAttributeAtCentroid, draw triangle C1-C2-C3 with SV_COVERAGE to find out the first covered sample, which is the centroid position defined by the Shader Model 5.0. Use the sample index for centoid to do the verification the same way as in EvaluateAttributeAtSample above.

  2. When interpolation mode is linear:

    1. Calculate and store the interpolated (and extrapolated for uncovered area of p2 and p3) values for 256 offset positions of each pixels, using perspective correct interpolation. Interpolate the attribute values that have been divided by the respective depth value, then divide the interpolated attribute value by the interpolated reciprocal of the depth.

    2. For EvaluateAttributeSnapped(), use the same verification as 2.a.

    3. For EvaluateAttributeAtCentroid(), use the same verification as 2.c.

    4. For EvaluateAttributeAtSample(), use the same verification as 2.b.

  3. Use PSInvocation to verify the number of PS invocations for all test cases.

    1. If any attribute has sample interpolation mode or SV_SAMPLEINDEX is declared, and the sample count is larger than 1, PSInvocation should be 3*(sample count).

    2. When the sample count is 1, PSInvocation should be 1.

Command syntax

Command option | Description
Wgf11rasterizer | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feauture level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11rasterizer.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Rasterizer (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/179ed40c-de29-4fc8-93bc-18f1f83d2c08

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Rasterizer (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1700220-5f56-4d62-adc8-b24ef22a8971

This automated test verifies various aspects of the D3D primitive rasterizer and rasterizer state as implemented by hardware.

This topic applies to the following test jobs:

  • WGF11 Rasterizer

  • WGF11 Rasterizer (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

For D3D10 and above, this test verifies the following:

  • Primitive culling, fill mode, and winding order based on the rasterizer state.

  • Interpolation modes in the pixel shader

    • Constant mode is simple, because there is no change from the values sent from the vertex shader.

    • Because it is not tightly spec'd, linear modes are verified by ensuring that adjacent pixels are not equal and follow the gradient of an edge.

  • Sample frequency pixel shader invocation (D3D10.1 and above).

For D3D11, this test verifies pull model attribute evaluation.

The following intrinsic functions will be introduced into D3D11 (HLSL 5.0) for the feature of pull-model attribute evaluation:

  • EvaluateAttributeSnapped( attrib numeric value, int2 pixeloffset )

  • EvaluateAttributeAtSample( attrib numeric value, uint sampleindex )

  • EvaluateAttributeAtCentroid( attrib numeric value )

For each intrinsic function, a set of pixel shaders will be generated, targeting the cases on different combinations of the parameter values of the intrinsic function and the declared interpolation modes of the input attributes.

The following are test factors for all three intrinsics:

  • Input attributes passed from the Vertex shader.

    NOTE

    Only float type attribute can be interpolated; int/uint type will always be constant interpolation mode

    • float4 texCoord : TEXCOORD

    • float4 color : COLOR

    • float clipDis : SV_ClipDistance

  • Declarations of interpolation modes.

    NOTE

    Nointerpolation mode is not allowed by the HLSL compiler when the corresponding attribute is evaluated with pull-model in the shader.

    • linear

    • linear noPerspective

    • linear centroid

    • linear sample

    • linear noPerspective centroid

    • linear noPerspective sample

  • Primitives to draw:

    • When the interpolation mode is linear, a triangle C1-C2-C3 as follows will be drawn. This covers one whole pixel and two half pixels. The coordinates of the vertices in projection space are as the following:

      <need image here

      C1: (-1, 1, 0), C2(-1, -1, 0), C3(1, 1, 0).

      Right triangle within a square, with vertices C1, C2, and C3; C1 forms the 90-degree angle and is at the upper-left corner of the square

  • When the interpolation mode is noperspective, a triangle A-B-C with the following vertex coordinates in the projection space will be drawn:

    A:(-1, 1, 1);

    B:(-1, -1, 0);

    C:(1, 1, 1)

    The screen space triangle should cover the same pixels and pixel areas as triangle C1-C2-C3 shown above.

  • Render target

    • Format: All formats supporting render target.

    • Sample count: 1, 2, ... the maximum supported sample count.

Different values of pixeloffset for EvaluateAttributeSnapped( )

Ideally, all possible 256 offset positions. If the test runs too long, this group of test cases will be reduced to 4 corner positions, 8 border positions, 4 positions from 4x4 grid, 4 positions from 8x8 grid, and 4 positions from 16x16 grid.

Different values of sampleindex for EvaluateAttributeAtSample( )

All sample indices supported by the render target

The verification method begins when the pixel shader writes the interpolated attribute value to the render target. The render target data is then mapped and read out. In cases of multisampled render targets, multisample resolve is required before mapping. The result data will be compared with pre-calculated interpolated data or data got from direct accessing the attribute.

  1. When interpolation mode is linear noperspective:

    1. Calculate and store the interpolated (and extrapolated for uncovered area of p2 and p3) values for 256 offset positions of each pixels of p1, p2, p3.

    2. For EvaluateAttributeSnapped :

      • Pixel p1 should have "pulled " attribute value in between of the expected values for left and right (as well as upper and lower) neighboring offsets of the "pulled" offset.

      • Pixels p2 and p3:

        In single-sampled cases, they should not be rendered.

        In multi-sampled cases, they should have "pulled" attribute value in between of the expected values for left and right (as well as upper and lower) neighboring offsets of the "pulled" offset.

    3. For EvaluateAttributeAtSample with SampleFinder, find the position of the sample index on the sample coordinate system with range [-8, 7]. Use this position to do the verification the same way as in EvaluateAttributeSnapped above.

    4. For EvaluateAttributeAtCentroid, draw triangle C1-C2-C3 with SV_COVERAGE to find out the first covered sample, which is the centroid position defined by the Shader Model 5.0. Use the sample index for centoid to do the verification the same way as in EvaluateAttributeAtSample above.

  2. When interpolation mode is linear:

    1. Calculate and store the interpolated (and extrapolated for uncovered area of p2 and p3) values for 256 offset positions of each pixels, using perspective correct interpolation. Interpolate the attribute values that have been divided by the respective depth value, then divide the interpolated attribute value by the interpolated reciprocal of the depth.

    2. For EvaluateAttributeSnapped(), use the same verification as 2.a.

    3. For EvaluateAttributeAtCentroid(), use the same verification as 2.c.

    4. For EvaluateAttributeAtSample(), use the same verification as 2.b.

  3. Use PSInvocation to verify the number of PS invocations for all test cases.

    1. If any attribute has sample interpolation mode or SV_SAMPLEINDEX is declared, and the sample count is larger than 1, PSInvocation should be 3*(sample count).

    2. When the sample count is 1, PSInvocation should be 1.

Command syntax

Command option | Description
Wgf11rasterizer | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feauture level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11rasterizer.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Render Targets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f797e77a-6458-41fd-b00e-c68a7529dd16

This automated test verifies D3D graphics driver/hardware conformance for render target features and RenderTargetViews. It also verifies driver support for render target clearing and swap chains.

This topic applies to the following test jobs:

  • WGF11 Render Targets

  • WGF11 Render Targets (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. To review test details, review the test log from the DTM Studio for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the device does not support backbuffer casting for a particular format (in the SwapChain test group). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

RenderTargets (tests mainly RenderTargetViews)

Rather than rendering to the backbuffer that is presented on the screen, you can draw to a render target resource. This is typically used in environment mapping techniques or in techniques where multiple passes are involved where the render target texture is used as input in another pass.

  • Tests cycles through all formats capable of being used as a render target. No conversion takes place, but results must be within 1-ULP (Unit Least Precision) of expected result (per component).

  • Three types of source data are used: tiles, gradients, and stripes. Each data type is parameterized, such as gradient colors, tile and stripe size, and so on.

  • Depending on the resource type (all five types are tested), the test cycles through different values for height, width, and depth. This includes non-square and non-pow-2 values.

  • MRT (Multiple Render Targets) are tested, and multiple mip-levels and array slices are targeted.

  • Hits all render target slots throughout the test run.

  • Renders to VB, IB, and shader resource (verify in subsequent Draw() call).

  • Renders to texture cube (and sub mips) by creating a Texture2DArray render target view.

Clear

Tests clearing of the bound render target view through the ClearRenderTargetView D3D API. This includes testing of the various resource types (1D, 2D, and so on), and using special floating point values as the clear value (INF, NaN, and so on).

SwapChain

Tests rendering to the backbuffer and presenting using various swap chain creation parameters, including format. Also tests back buffer casting, which is new to D3D11. This allows creating a render target view of a format that is not in the same typeless family as the resource's format.

Command syntax

Command option | Description
Wgf11rendertargets | Rusn the terst jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
wgf11rendertargets.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Render Targets (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5e3adf2-72b4-4468-ae41-a5fde2318a87

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Compatibility
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Render Targets (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad624bae-5f84-43ca-95dd-2d7bac47487b

This automated test verifies D3D graphics driver/hardware conformance for render target features and RenderTargetViews. It also verifies driver support for render target clearing and swap chains.

This topic applies to the following test jobs:

  • WGF11 Render Targets

  • WGF11 Render Targets (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. To review test details, review the test log from the DTM Studio for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the device does not support backbuffer casting for a particular format (in the SwapChain test group). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

RenderTargets (tests mainly RenderTargetViews)

Rather than rendering to the backbuffer that is presented on the screen, you can draw to a render target resource. This is typically used in environment mapping techniques or in techniques where multiple passes are involved where the render target texture is used as input in another pass.

  • Tests cycles through all formats capable of being used as a render target. No conversion takes place, but results must be within 1-ULP (Unit Least Precision) of expected result (per component).

  • Three types of source data are used: tiles, gradients, and stripes. Each data type is parameterized, such as gradient colors, tile and stripe size, and so on.

  • Depending on the resource type (all five types are tested), the test cycles through different values for height, width, and depth. This includes non-square and non-pow-2 values.

  • MRT (Multiple Render Targets) are tested, and multiple mip-levels and array slices are targeted.

  • Hits all render target slots throughout the test run.

  • Renders to VB, IB, and shader resource (verify in subsequent Draw() call).

  • Renders to texture cube (and sub mips) by creating a Texture2DArray render target view.

Clear

Tests clearing of the bound render target view through the ClearRenderTargetView D3D API. This includes testing of the various resource types (1D, 2D, and so on), and using special floating point values as the clear value (INF, NaN, and so on).

SwapChain

Tests rendering to the backbuffer and presenting using various swap chain creation parameters, including format. Also tests back buffer casting, which is new to D3D11. This allows creating a render target view of a format that is not in the same typeless family as the resource's format.

Command syntax

Command option | Description
Wgf11rendertargets | Rusn the terst jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
wgf11rendertargets.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Resource Access

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec3e13a2-6847-44b7-bfdd-97d9dc04dec5

This automated test verifies D3D graphics driver/hardware conformance for resource copying functions and the integrity of the data manipulated. There are also groups for D3D10.1 features that allow copying of compressed textures to structured formats and copying of multisample resources.

This topic applies to the following test jobs:

  • WGF11 Resource Access

  • WGF11 Resource Access (WoW64)

  • WGF11 Resource Access FL9.3

  • WGF11 Resource Access FL9.3 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the feature level is lower than the one required to test a particular feature (10.1 for CopyMultisample/CopyCompressed). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

You can access and modify the contents of resources through four functions: CopyResource(), CopySubresourceRegion(), UpdateSubresource(), and Map().

  • Test behavior when specifying regions that are 1 pixel in size and other special cases.

  • Ensure consistent data when copying from mip (progressively smaller and less detailed versions of the texture) and array slices.

  • Make sure that only specified data is changed and other subresources or regions remain untouched.

  • Test behavior with special and compressed formats.

  • Watch for CopyResource() and related functions that affect pipeline statistics. You can choose to use the rendering pipeline to "emulate" copy functionality, but the specification states that copy functions cannot affect pipeline statistics.

CopyMultisample

Tests support for the D3D10.1 feature of copy multisample resources.

  • Varies the number of samples used.

  • Ensures a unique value in each sample location.

  • Verifies that this is preserved on copy on the destination resource.

CopyCompressed

Verifies support for copying of compressed textures to structured formats which was added in D3D10.1. The compatible structured format (i.e. traditional 3-4 color channels) for each compressed texture is tested to make sure the data in the original texture is preserved on copy. No conversion should take place. This is a bit-for-bit copy. Roundtrip copy (structured->compressed) is also tested and should also be bit-for-bit accurate.

Command syntax

Command option | Description
Wgf11resourceaccess | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11resourceaccess.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Resource Access (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ef446487-8f65-408b-be34-1a56a3f4459d

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Resource Access (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6715cb3-b168-4ca3-a5db-5ca0a0ca627d

This automated test verifies D3D graphics driver/hardware conformance for resource copying functions and the integrity of the data manipulated. There are also groups for D3D10.1 features that allow copying of compressed textures to structured formats and copying of multisample resources.

This topic applies to the following test jobs:

  • WGF11 Resource Access

  • WGF11 Resource Access (WoW64)

  • WGF11 Resource Access FL9.3

  • WGF11 Resource Access FL9.3 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the feature level is lower than the one required to test a particular feature (10.1 for CopyMultisample/CopyCompressed). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

You can access and modify the contents of resources through four functions: CopyResource(), CopySubresourceRegion(), UpdateSubresource(), and Map().

  • Test behavior when specifying regions that are 1 pixel in size and other special cases.

  • Ensure consistent data when copying from mip (progressively smaller and less detailed versions of the texture) and array slices.

  • Make sure that only specified data is changed and other subresources or regions remain untouched.

  • Test behavior with special and compressed formats.

  • Watch for CopyResource() and related functions that affect pipeline statistics. You can choose to use the rendering pipeline to "emulate" copy functionality, but the specification states that copy functions cannot affect pipeline statistics.

CopyMultisample

Tests support for the D3D10.1 feature of copy multisample resources.

  • Varies the number of samples used.

  • Ensures a unique value in each sample location.

  • Verifies that this is preserved on copy on the destination resource.

CopyCompressed

Verifies support for copying of compressed textures to structured formats which was added in D3D10.1. The compatible structured format (i.e. traditional 3-4 color channels) for each compressed texture is tested to make sure the data in the original texture is preserved on copy. No conversion should take place. This is a bit-for-bit copy. Roundtrip copy (structured->compressed) is also tested and should also be bit-for-bit accurate.

Command syntax

Command option | Description
Wgf11resourceaccess | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11resourceaccess.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Resource Formats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c61b186-bf1c-48ca-bd84-b1be5649860f

This automated test verifies D3D graphics driver/hardware conformance for shader resource views and the texture formats that are outlined in the D3D11 functional specification.

This topic applies to the following test jobs:

  • WGF11 Resource Formats

  • WGF11 Resource Formats - BGRA Support on 10.x

  • WGF11 Resource Formats - BGRA Support on 10.x (WoW64)

  • WGF11 Resource Formats (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file from the DTM Studio for specific details about failures. The test might return SKIP if a format is not supported by the device. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

ResourceFormats (tests mainly ShaderResourceViews)

There are various formats available for resources. They vary mainly in number of components, type, precision, and whether or not they are compressed.

  • Render target is a four-component, 32-bit float format. The formats tested are converted to this format. Results must be within 1-ULP(Unit Least Precision) per component of expected result.

  • Compressed and other special formats are decoded as specified in the test and compared against the hardware's (or REF's) results (again, 1-ULP tolerance).

  • Three types of source data are used: tiles, gradients, and stripes. Each data type is parameterized, such as gradient colors, tile and stripe size, and so on.

  • Depending on the resource type (all five types are tested) the test cycles through different values for height, width, and depth. This includes non-square and non-pow-2 values.

  • Hit all shader resource slots throughout the test run.

  • Verify multiple use input resources.

  • Example: Use a texture as vertex input and shader resource input in the same Draw() call.

  • Test input/output resources (for example: D3D10_BIND_SHADER_RESOURCE | D3D10_BIND_RENDERTARGET)

  • Try using first pass to initialize resource data.

DepthReadback Verifies driver behavior when using a depth buffer from one pass as a shader resource in a subsequent pass.

CheckFormatSupport Verifies that the driver supports the required formats and their capabilities based on the format table in the spec.

Command syntax

Command option | Description
Wgf11resourceformats | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level tested, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11resourceformats.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Resource Formats - BGRA Support on 10.x

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bb8a1e51-8425-46f8-887d-96a62e2f7603

This automated test verifies D3D graphics driver/hardware conformance for resource copying functions and the integrity of the data manipulated. There are also groups for D3D10.1 features that allow copying of compressed textures to structured formats and copying of multisample resources.

This topic applies to the following test jobs:

  • WGF11 Resource Access

  • WGF11 Resource Access (WoW64)

  • WGF11 Resource Access FL9.3

  • WGF11 Resource Access FL9.3 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D10WDDM11.D3D10v11Primary
  • Device.Graphics.AdapterRender.D3D101WDDM11.D3D101v11Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the feature level is lower than the one required to test a particular feature (10.1 for CopyMultisample/CopyCompressed). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

You can access and modify the contents of resources through four functions: CopyResource(), CopySubresourceRegion(), UpdateSubresource(), and Map().

  • Test behavior when specifying regions that are 1 pixel in size and other special cases.

  • Ensure consistent data when copying from mip (progressively smaller and less detailed versions of the texture) and array slices.

  • Make sure that only specified data is changed and other subresources or regions remain untouched.

  • Test behavior with special and compressed formats.

  • Watch for CopyResource() and related functions that affect pipeline statistics. You can choose to use the rendering pipeline to "emulate" copy functionality, but the specification states that copy functions cannot affect pipeline statistics.

CopyMultisample

Tests support for the D3D10.1 feature of copy multisample resources.

  • Varies the number of samples used.

  • Ensures a unique value in each sample location.

  • Verifies that this is preserved on copy on the destination resource.

CopyCompressed

Verifies support for copying of compressed textures to structured formats which was added in D3D10.1. The compatible structured format (i.e. traditional 3-4 color channels) for each compressed texture is tested to make sure the data in the original texture is preserved on copy. No conversion should take place. This is a bit-for-bit copy. Roundtrip copy (structured->compressed) is also tested and should also be bit-for-bit accurate.

Command syntax

Command option | Description
Wgf11resourceaccess | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11resourceaccess.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Resource Formats - BGRA Support on 10.x (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c894fe44-a7e3-4e09-ac66-638466c437c3

This automated test verifies D3D graphics driver/hardware conformance for resource copying functions and the integrity of the data manipulated. There are also groups for D3D10.1 features that allow copying of compressed textures to structured formats and copying of multisample resources.

This topic applies to the following test jobs:

  • WGF11 Resource Access

  • WGF11 Resource Access (WoW64)

  • WGF11 Resource Access FL9.3

  • WGF11 Resource Access FL9.3 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D101WDDM11.D3D101v11Primary
  • Device.Graphics.AdapterRender.D3D10WDDM11.D3D10v11Primary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the feature level is lower than the one required to test a particular feature (10.1 for CopyMultisample/CopyCompressed). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

You can access and modify the contents of resources through four functions: CopyResource(), CopySubresourceRegion(), UpdateSubresource(), and Map().

  • Test behavior when specifying regions that are 1 pixel in size and other special cases.

  • Ensure consistent data when copying from mip (progressively smaller and less detailed versions of the texture) and array slices.

  • Make sure that only specified data is changed and other subresources or regions remain untouched.

  • Test behavior with special and compressed formats.

  • Watch for CopyResource() and related functions that affect pipeline statistics. You can choose to use the rendering pipeline to "emulate" copy functionality, but the specification states that copy functions cannot affect pipeline statistics.

CopyMultisample

Tests support for the D3D10.1 feature of copy multisample resources.

  • Varies the number of samples used.

  • Ensures a unique value in each sample location.

  • Verifies that this is preserved on copy on the destination resource.

CopyCompressed

Verifies support for copying of compressed textures to structured formats which was added in D3D10.1. The compatible structured format (i.e. traditional 3-4 color channels) for each compressed texture is tested to make sure the data in the original texture is preserved on copy. No conversion should take place. This is a bit-for-bit copy. Roundtrip copy (structured->compressed) is also tested and should also be bit-for-bit accurate.

Command syntax

Command option | Description
Wgf11resourceaccess | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11resourceaccess.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Resource Formats (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1773a57-445f-41a7-ae2c-52f28b432727

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Resource Formats (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d75a6a7-0d5e-43d6-a0b4-1c220f1035d9

This automated test verifies D3D graphics driver/hardware conformance for resource copying functions and the integrity of the data manipulated. There are also groups for D3D10.1 features that allow copying of compressed textures to structured formats and copying of multisample resources.

This topic applies to the following test jobs:

  • WGF11 Resource Access

  • WGF11 Resource Access (WoW64)

  • WGF11 Resource Access FL9.3

  • WGF11 Resource Access FL9.3 (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if a format is not supported by the device, or if the feature level is lower than the one required to test a particular feature (10.1 for CopyMultisample/CopyCompressed). The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the DTM Studio.

More information

You can access and modify the contents of resources through four functions: CopyResource(), CopySubresourceRegion(), UpdateSubresource(), and Map().

  • Test behavior when specifying regions that are 1 pixel in size and other special cases.

  • Ensure consistent data when copying from mip (progressively smaller and less detailed versions of the texture) and array slices.

  • Make sure that only specified data is changed and other subresources or regions remain untouched.

  • Test behavior with special and compressed formats.

  • Watch for CopyResource() and related functions that affect pipeline statistics. You can choose to use the rendering pipeline to "emulate" copy functionality, but the specification states that copy functions cannot affect pipeline statistics.

CopyMultisample

Tests support for the D3D10.1 feature of copy multisample resources.

  • Varies the number of samples used.

  • Ensures a unique value in each sample location.

  • Verifies that this is preserved on copy on the destination resource.

CopyCompressed

Verifies support for copying of compressed textures to structured formats which was added in D3D10.1. The compatible structured format (i.e. traditional 3-4 color channels) for each compressed texture is tested to make sure the data in the original texture is preserved on copy. No conversion should take place. This is a bit-for-bit copy. Roundtrip copy (structured->compressed) is also tested and should also be bit-for-bit accurate.

Command syntax

Command option | Description
Wgf11resourceaccess | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11resourceaccess.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader 5x

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40659235-009c-419d-a177-11623e8c995d

This automated test utilizes the D3D11 APIs and Shader 4.0, 4.1, or 5.0 instruction set, depending on the feature level specified on the command line. The test doesn't rely on the compiler; instead it assembles shaders to ensure specific instructions are fully tested and not altered by the compiler. During execution, the test cycles between different instructions (each instruction is a separate group), shader stages, register values, and mask/swizzle combinations. Each test case uses different data depending on the current instruction and its behavior as described by the spec.

WGF11Shader5x adds support for new 4.x instructions (including doubles) and stages (like the Compute Shader), if the driver supports it.

This topic applies to the following test jobs:

  • WGF11 Shader 5x

  • WGF11 Shader 5x - DoubleArith

  • WGF11 Shader 5x - DoubleArith (WoW64)

  • WGF11 Shader 5x - Extended double precision shader instructions

  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

  • WGF11 Shader 5x (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

The test might return SKIP if the shader stages are not supported. For example, if running the test with feature level 10.0, HULL and DOMAIN shaders are not supported, so those tests will skip. The test will also skip if specific formats, quality levels, doubles, and so on are not supported. The test asks the driver for support before executing a given test. To run the test with a different feature level, use one of the following command line options (also see below):

  • featurelevel:10.0

  • featurelevel:10.1

  • featurelevel:11.0

If your driver sample is in one location, but it reports that the location is in another location during the test, or if the sample locations change between draw calls, you may fail the test with the following error: "samplepos returned incorrect sample location".

One possible cause for this error is that the test specifies the sample index 0 at (32, 32) in the 256x256 sub-pixel grid, because the driver lit the pixel when a sub-pixel quad was rendered there. However, your driver is returning (192, 192) for sample index 0 through the samplepos instruction.

Test command line: WGF11Shader5x.exe: -src:hw -logclean multisample\samplepos\2\9:9 -featurelevel:11.0

Error message in the log:

Test Case 9: Multisample\samplepos\2\9 Fail + Test Case 9: Multisample\samplepos\2\9 Fail Parameter: Format=R32G32B32A32_FLOAT Parameter: Dimension=TEXTURE2DMS Parameter: SampleCount=2 Parameter: SampleQuality=1 Parameter: Height=3 Parameter: Width=7 Parameter: rasterizer=true Parameter: SRV_Bound=false Parameter: SampleIndex=0 Pixel [0,0], Sample[0] samplepos returned (8, 8) actual sample position = (-12, -12) [CSampleInfoTest::ExecuteTestCase()] samplepos returned incorrect sample location.

More information

.

Command syntax

Command option | Description
Wgf11shader5x | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11shader5x.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader 5x - DoubleArith

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75192744-4014-4f5f-9604-c851c1f28de6

This automated test utilizes the D3D11 APIs and Shader 4.0, 4.1, or 5.0 instruction set, depending on the feature level specified on the command line. The test doesn't rely on the compiler; instead it assembles shaders to ensure specific instructions are fully tested and not altered by the compiler. During execution, the test cycles between different instructions (each instruction is a separate group), shader stages, register values, and mask/swizzle combinations. Each test case uses different data depending on the current instruction and its behavior as described by the spec.

WGF11Shader5x adds support for new 4.x instructions (including doubles) and stages (like the Compute Shader), if the driver supports it.

This topic applies to the following test jobs:

  • WGF11 Shader 5x

  • WGF11 Shader 5x - DoubleArith

  • WGF11 Shader 5x - DoubleArith (WoW64)

  • WGF11 Shader 5x - Extended double precision shader instructions

  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

  • WGF11 Shader 5x (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11DoublePrecisionShader.D3D11CoreC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

The test might return SKIP if the shader stages are not supported. For example, if running the test with feature level 10.0, HULL and DOMAIN shaders are not supported, so those tests will skip. The test will also skip if specific formats, quality levels, doubles, and so on are not supported. The test asks the driver for support before executing a given test. To run the test with a different feature level, use one of the following command line options (also see below):

  • featurelevel:10.0

  • featurelevel:10.1

  • featurelevel:11.0

If your driver sample is in one location, but it reports that the location is in another location during the test, or if the sample locations change between draw calls, you may fail the test with the following error: "samplepos returned incorrect sample location".

One possible cause for this error is that the test specifies the sample index 0 at (32, 32) in the 256x256 sub-pixel grid, because the driver lit the pixel when a sub-pixel quad was rendered there. However, your driver is returning (192, 192) for sample index 0 through the samplepos instruction.

Test command line: WGF11Shader5x.exe: -src:hw -logclean multisample\samplepos\2\9:9 -featurelevel:11.0

Error message in the log:

Test Case 9: Multisample\samplepos\2\9 Fail + Test Case 9: Multisample\samplepos\2\9 Fail Parameter: Format=R32G32B32A32_FLOAT Parameter: Dimension=TEXTURE2DMS Parameter: SampleCount=2 Parameter: SampleQuality=1 Parameter: Height=3 Parameter: Width=7 Parameter: rasterizer=true Parameter: SRV_Bound=false Parameter: SampleIndex=0 Pixel [0,0], Sample[0] samplepos returned (8, 8) actual sample position = (-12, -12) [CSampleInfoTest::ExecuteTestCase()] samplepos returned incorrect sample location.

More information

.

Command syntax

Command option | Description
Wgf11shader5x | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11shader5x.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader 5x - DoubleArith (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b0abab4-8aef-47a7-81d4-fca731d26ff2

This automated test utilizes the D3D11 APIs and Shader 4.0, 4.1, or 5.0 instruction set, depending on the feature level specified on the command line. The test doesn't rely on the compiler; instead it assembles shaders to ensure specific instructions are fully tested and not altered by the compiler. During execution, the test cycles between different instructions (each instruction is a separate group), shader stages, register values, and mask/swizzle combinations. Each test case uses different data depending on the current instruction and its behavior as described by the spec.

WGF11Shader5x adds support for new 4.x instructions (including doubles) and stages (like the Compute Shader), if the driver supports it.

This topic applies to the following test jobs:

  • WGF11 Shader 5x

  • WGF11 Shader 5x - DoubleArith

  • WGF11 Shader 5x - DoubleArith (WoW64)

  • WGF11 Shader 5x - Extended double precision shader instructions

  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

  • WGF11 Shader 5x (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11DoublePrecisionShader.D3D11CoreC
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

The test might return SKIP if the shader stages are not supported. For example, if running the test with feature level 10.0, HULL and DOMAIN shaders are not supported, so those tests will skip. The test will also skip if specific formats, quality levels, doubles, and so on are not supported. The test asks the driver for support before executing a given test. To run the test with a different feature level, use one of the following command line options (also see below):

  • featurelevel:10.0

  • featurelevel:10.1

  • featurelevel:11.0

If your driver sample is in one location, but it reports that the location is in another location during the test, or if the sample locations change between draw calls, you may fail the test with the following error: "samplepos returned incorrect sample location".

One possible cause for this error is that the test specifies the sample index 0 at (32, 32) in the 256x256 sub-pixel grid, because the driver lit the pixel when a sub-pixel quad was rendered there. However, your driver is returning (192, 192) for sample index 0 through the samplepos instruction.

Test command line: WGF11Shader5x.exe: -src:hw -logclean multisample\samplepos\2\9:9 -featurelevel:11.0

Error message in the log:

Test Case 9: Multisample\samplepos\2\9 Fail + Test Case 9: Multisample\samplepos\2\9 Fail Parameter: Format=R32G32B32A32_FLOAT Parameter: Dimension=TEXTURE2DMS Parameter: SampleCount=2 Parameter: SampleQuality=1 Parameter: Height=3 Parameter: Width=7 Parameter: rasterizer=true Parameter: SRV_Bound=false Parameter: SampleIndex=0 Pixel [0,0], Sample[0] samplepos returned (8, 8) actual sample position = (-12, -12) [CSampleInfoTest::ExecuteTestCase()] samplepos returned incorrect sample location.

More information

.

Command syntax

Command option | Description
Wgf11shader5x | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11shader5x.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader 5x - Extended double precision shader instructions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a68b462-0e28-4a90-8b3e-5c871ee25764

This automated test utilizes the D3D11 APIs and Shader 4.0, 4.1, or 5.0 instruction set, depending on the feature level specified on the command line. The test doesn't rely on the compiler; instead it assembles shaders to ensure specific instructions are fully tested and not altered by the compiler. During execution, the test cycles between different instructions (each instruction is a separate group), shader stages, register values, and mask/swizzle combinations. Each test case uses different data depending on the current instruction and its behavior as described by the spec.

WGF11Shader5x adds support for new 4.x instructions (including doubles) and stages (like the Compute Shader), if the driver supports it.

This topic applies to the following test jobs:

  • WGF11 Shader 5x

  • WGF11 Shader 5x - DoubleArith

  • WGF11 Shader 5x - DoubleArith (WoW64)

  • WGF11 Shader 5x - Extended double precision shader instructions

  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

  • WGF11 Shader 5x (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11WDDM12DoublePrecisionShader.D3D11v12C
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

The test might return SKIP if the shader stages are not supported. For example, if running the test with feature level 10.0, HULL and DOMAIN shaders are not supported, so those tests will skip. The test will also skip if specific formats, quality levels, doubles, and so on are not supported. The test asks the driver for support before executing a given test. To run the test with a different feature level, use one of the following command line options (also see below):

  • featurelevel:10.0

  • featurelevel:10.1

  • featurelevel:11.0

If your driver sample is in one location, but it reports that the location is in another location during the test, or if the sample locations change between draw calls, you may fail the test with the following error: "samplepos returned incorrect sample location".

One possible cause for this error is that the test specifies the sample index 0 at (32, 32) in the 256x256 sub-pixel grid, because the driver lit the pixel when a sub-pixel quad was rendered there. However, your driver is returning (192, 192) for sample index 0 through the samplepos instruction.

Test command line: WGF11Shader5x.exe: -src:hw -logclean multisample\samplepos\2\9:9 -featurelevel:11.0

Error message in the log:

Test Case 9: Multisample\samplepos\2\9 Fail + Test Case 9: Multisample\samplepos\2\9 Fail Parameter: Format=R32G32B32A32_FLOAT Parameter: Dimension=TEXTURE2DMS Parameter: SampleCount=2 Parameter: SampleQuality=1 Parameter: Height=3 Parameter: Width=7 Parameter: rasterizer=true Parameter: SRV_Bound=false Parameter: SampleIndex=0 Pixel [0,0], Sample[0] samplepos returned (8, 8) actual sample position = (-12, -12) [CSampleInfoTest::ExecuteTestCase()] samplepos returned incorrect sample location.

More information

.

Command syntax

Command option | Description
Wgf11shader5x | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11shader5x.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd19ac2b-0709-49f2-bf7b-49b981a6aa1b

This automated test utilizes the D3D11 APIs and Shader 4.0, 4.1, or 5.0 instruction set, depending on the feature level specified on the command line. The test doesn't rely on the compiler; instead it assembles shaders to ensure specific instructions are fully tested and not altered by the compiler. During execution, the test cycles between different instructions (each instruction is a separate group), shader stages, register values, and mask/swizzle combinations. Each test case uses different data depending on the current instruction and its behavior as described by the spec.

WGF11Shader5x adds support for new 4.x instructions (including doubles) and stages (like the Compute Shader), if the driver supports it.

This topic applies to the following test jobs:

  • WGF11 Shader 5x

  • WGF11 Shader 5x - DoubleArith

  • WGF11 Shader 5x - DoubleArith (WoW64)

  • WGF11 Shader 5x - Extended double precision shader instructions

  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

  • WGF11 Shader 5x (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11WDDM12DoublePrecisionShader.D3D11v12C
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

The test might return SKIP if the shader stages are not supported. For example, if running the test with feature level 10.0, HULL and DOMAIN shaders are not supported, so those tests will skip. The test will also skip if specific formats, quality levels, doubles, and so on are not supported. The test asks the driver for support before executing a given test. To run the test with a different feature level, use one of the following command line options (also see below):

  • featurelevel:10.0

  • featurelevel:10.1

  • featurelevel:11.0

If your driver sample is in one location, but it reports that the location is in another location during the test, or if the sample locations change between draw calls, you may fail the test with the following error: "samplepos returned incorrect sample location".

One possible cause for this error is that the test specifies the sample index 0 at (32, 32) in the 256x256 sub-pixel grid, because the driver lit the pixel when a sub-pixel quad was rendered there. However, your driver is returning (192, 192) for sample index 0 through the samplepos instruction.

Test command line: WGF11Shader5x.exe: -src:hw -logclean multisample\samplepos\2\9:9 -featurelevel:11.0

Error message in the log:

Test Case 9: Multisample\samplepos\2\9 Fail + Test Case 9: Multisample\samplepos\2\9 Fail Parameter: Format=R32G32B32A32_FLOAT Parameter: Dimension=TEXTURE2DMS Parameter: SampleCount=2 Parameter: SampleQuality=1 Parameter: Height=3 Parameter: Width=7 Parameter: rasterizer=true Parameter: SRV_Bound=false Parameter: SampleIndex=0 Pixel [0,0], Sample[0] samplepos returned (8, 8) actual sample position = (-12, -12) [CSampleInfoTest::ExecuteTestCase()] samplepos returned incorrect sample location.

More information

.

Command syntax

Command option | Description
Wgf11shader5x | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11shader5x.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader 5x (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c268721-dffb-480a-916c-e64373b915a1

This automated test utilizes the D3D11 APIs and Shader 4.0, 4.1, or 5.0 instruction set, depending on the feature level specified on the command line. The test doesn't rely on the compiler; instead it assembles shaders to ensure specific instructions are fully tested and not altered by the compiler. During execution, the test cycles between different instructions (each instruction is a separate group), shader stages, register values, and mask/swizzle combinations. Each test case uses different data depending on the current instruction and its behavior as described by the spec.

WGF11Shader5x adds support for new 4.x instructions (including doubles) and stages (like the Compute Shader), if the driver supports it.

This topic applies to the following test jobs:

  • WGF11 Shader 5x

  • WGF11 Shader 5x - DoubleArith

  • WGF11 Shader 5x - DoubleArith (WoW64)

  • WGF11 Shader 5x - Extended double precision shader instructions

  • WGF11 Shader 5x - Extended double precision shader instructions (WoW64)

  • WGF11 Shader 5x (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

The test might return SKIP if the shader stages are not supported. For example, if running the test with feature level 10.0, HULL and DOMAIN shaders are not supported, so those tests will skip. The test will also skip if specific formats, quality levels, doubles, and so on are not supported. The test asks the driver for support before executing a given test. To run the test with a different feature level, use one of the following command line options (also see below):

  • featurelevel:10.0

  • featurelevel:10.1

  • featurelevel:11.0

If your driver sample is in one location, but it reports that the location is in another location during the test, or if the sample locations change between draw calls, you may fail the test with the following error: "samplepos returned incorrect sample location".

One possible cause for this error is that the test specifies the sample index 0 at (32, 32) in the 256x256 sub-pixel grid, because the driver lit the pixel when a sub-pixel quad was rendered there. However, your driver is returning (192, 192) for sample index 0 through the samplepos instruction.

Test command line: WGF11Shader5x.exe: -src:hw -logclean multisample\samplepos\2\9:9 -featurelevel:11.0

Error message in the log:

Test Case 9: Multisample\samplepos\2\9 Fail + Test Case 9: Multisample\samplepos\2\9 Fail Parameter: Format=R32G32B32A32_FLOAT Parameter: Dimension=TEXTURE2DMS Parameter: SampleCount=2 Parameter: SampleQuality=1 Parameter: Height=3 Parameter: Width=7 Parameter: rasterizer=true Parameter: SRV_Bound=false Parameter: SampleIndex=0 Pixel [0,0], Sample[0] samplepos returned (8, 8) actual sample position = (-12, -12) [CSampleInfoTest::ExecuteTestCase()] samplepos returned incorrect sample location.

More information

.

Command syntax

Command option | Description
Wgf11shader5x | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11shader5x.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Shader5x (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82008573-484a-42a6-813e-d2dd6688ffa3

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 SharedResources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6aafb273-bd39-4f9b-8783-a2245990b106

This automated test verifies that hardware supports resource-sharing between processes and across APIs.

This test verifies that D3D resources created by one process can be used in a device context in a separate process. The test uses 2D textures, because this is expected to be the most interesting case. Because resources are also intended to be shared between different APIs (D3D9, D3D10.x, and D3D11), the test creates resources in each of these APIs and validates that they can be shared with devices in all other available API contexts.

This topic applies to the following test jobs:

  • WGF11 SharedResources (WoW64)

  • WGF11 SharedResources (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. To review test details, review the test log from the Windows HLK Manager. Some test cases my skip if run using feature level 10.0 or feature level 10.1.

More information

.

Command syntax

Command option | Description
Wgf11SharedResources | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the featurter lebel tested, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRwatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
wgf11SharedResources.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 SharedResources (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90383a03-abb8-4d9b-9b18-03de12bf68ad

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 SharedResources (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d67b9f82-e74f-40e3-8cc2-ba605bfbcb55

This automated test verifies that hardware supports resource-sharing between processes and across APIs.

This test verifies that D3D resources created by one process can be used in a device context in a separate process. The test uses 2D textures, because this is expected to be the most interesting case. Because resources are also intended to be shared between different APIs (D3D9, D3D10.x, and D3D11), the test creates resources in each of these APIs and validates that they can be shared with devices in all other available API contexts.

This topic applies to the following test jobs:

  • WGF11 SharedResources (WoW64)

  • WGF11 SharedResources (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
  • Device.Graphics.AdapterRender.D3D101WDDM12.D3D101v12Primary
  • Device.Graphics.AdapterRender.D3D10WDDM12.D3D10v12Primary
  • Device.Graphics.AdapterRender.D3D11WDDM12.D3D11v12Primary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. To review test details, review the test log from the Windows HLK Manager. Some test cases my skip if run using feature level 10.0 or feature level 10.1.

More information

.

Command syntax

Command option | Description
Wgf11SharedResources | Runs the test jobs. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the featurter lebel tested, where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRwatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
wgf11SharedResources.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Streamout

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62bd1e3e-3b70-4182-8632-4fb7265da2be

This automated test verifies that graphics drivers/hardware D3D stream-out behavior meets Microsoft Direct3D specifications.

This topic applies to the following test jobs:

  • WGF11 Streamout

  • WGF11 Streamout (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

The following outlines the StreamOut Conformance Test Plan:

  • General Stream Out Test Cases

    • Pass input data into the pipeline by using VB and stream out transformed data from VS or GS.

      NOTE

      In the GS case, consider amplification issues by emitting more than one output primitive per input primitive.

    • Cycle on different primitive types, buffer sizes, emit counts, vand buffer offsets.

    • Test appending SO data by making multiple Draw() calls.

    • For GS, cycle on shaders with different "maxvertexcount" properties.

      Occasionally overflow this value, making sure that only complete primitives are kept.

    • Possibly cycle on different input primitive types and output topologies.

    • Verify expected query results

      • STREAMOUTPUTSTATS

      • STREAMOVERFLOWPREDICATE

    • Test incomplete primitive writes.

    • Test winding order and leading-vertex handling.

    • Up to 227 SO vertices per SO buffer are allowed.

      NOTE

      Because this is such a large resource, this works for probably one or two test cases.

  • Simple Single-Buffer Tests

    • Cycle on several declaration scenarios:

      • Simple.

      • Leave gaps.

      • Split output registers across multiple SO elements.

      • Merge output register into a single SO element.

    • Cycle on different SO vertex sizes.

      Verify limit of 64-component SO vertices.

  • Simple Multi-Buffer Tests

    • Mix up buffer sizes/offsets so that buffers overflow at different times.

    • Cycle on several declaration scenarios:

      • Simple.

      • Skip output slot.

      • Split output registers across multiple SO elements.

      • Stream out partial register components.

      • Stream out to single buffer in non-zero slot.

  • Ping Ponging of Stream Output Buffers

    • Similar to simple single-buffer and simple multi-buffer tests with a twist:

      • Initially bind buffers A and B with a positive offset.

      • Bind buffer A using -1 offset value.

      • Draw()

      • Bind buffer B using -1 offset value.

      • Draw()

      • Repeat as needed.

    • In multiple buffer scenarios, consider optionally ping-ponging only some of the SO buffers between Draw() calls.

  • Changing SO Vertex Size Using Same Target Buffer

    • Custom test case that focuses on setting "fat" vertex strides to a single buffer, then Draw(), then sets "skinny" SO vertex stride, then Draw() again.

    • Examine STREAMOUTPUTSTATS.

    • Watch for overflow during "fat" vertex streaming and make sure that skinny vertices cannot be appended to target.

      NOTE

      Consider ping-ponging during this step to make sure that the overflowed state is "sticky" on the buffer.

  • Addressable Stream Output (D3D11)

    Test RasterizedStream and multiple vectors of data:

    • When sending a stream to the rasterizer, make sure that the final result uses the vertex data from that stream.

    • Make sure that more than one vector of data can be output from a stream under feature level 11, even when using a gs_4_x shader.

    • Test strides that aren't tightly aligned to the size of an element in a stream output buffer.

    • Verify that stream output works when the runtime determines strides based on the size calculated using the stream output declaration. The runtime does this when the stride parameters in the create call are both NULL.

  • Test feature level and query behavior:

    • When using feature levels 10 and 10.1, make sure only stream 0 can be used for stream output.

    • When using feature levels 10 and 10.1, make sure that only gs_4_x shaders can be used. If multiple buffers are used, make sure that only one vector of data can be output from stream 0 i.

    • D3D11_QUERY_SO_STATISTICS and D3D11_QUERY_SO_OVERFLOW_PREDICATE queries should return the correct data for the sum of all streams. D3D11_QUERY_SO_STATISTICS_STREAMn and D3D11_QUERY_SO_OVERFLOW_PREDICATE_STREAMn queries return the correct data for each stream. There are currently test cases for the single stream case. The following will be verified:

      • Expected number of primitives written to stream output buffers.

      • Expected size of the primitives (if they are all to be output to buffers).

      • Overflow predicate is triggered when one buffer overflows when writing to it.

      • If one buffer in a stream is filled, writes to all buffers in that stream are prevented.

      • Results of queries for undefined streams should not be affected.

Command Syntax

Command option | Description
Wgf11streamout | Rusn the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level tested where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11streamout.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Streamout (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8369deae-d7e3-414c-a9c3-bbb21553080f

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Streamout (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bbe0847e-332c-4d6a-b914-a366c0820ea0

This automated test verifies that graphics drivers/hardware D3D stream-out behavior meets Microsoft Direct3D specifications.

This topic applies to the following test jobs:

  • WGF11 Streamout

  • WGF11 Streamout (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures. The test might return SKIP if it is run with a feature level that doesn't support the feature being tested. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it). To review test details, review the test log from the Windows HLK Manager.

More information

The following outlines the StreamOut Conformance Test Plan:

  • General Stream Out Test Cases

    • Pass input data into the pipeline by using VB and stream out transformed data from VS or GS.

      NOTE

      In the GS case, consider amplification issues by emitting more than one output primitive per input primitive.

    • Cycle on different primitive types, buffer sizes, emit counts, vand buffer offsets.

    • Test appending SO data by making multiple Draw() calls.

    • For GS, cycle on shaders with different "maxvertexcount" properties.

      Occasionally overflow this value, making sure that only complete primitives are kept.

    • Possibly cycle on different input primitive types and output topologies.

    • Verify expected query results

      • STREAMOUTPUTSTATS

      • STREAMOVERFLOWPREDICATE

    • Test incomplete primitive writes.

    • Test winding order and leading-vertex handling.

    • Up to 227 SO vertices per SO buffer are allowed.

      NOTE

      Because this is such a large resource, this works for probably one or two test cases.

  • Simple Single-Buffer Tests

    • Cycle on several declaration scenarios:

      • Simple.

      • Leave gaps.

      • Split output registers across multiple SO elements.

      • Merge output register into a single SO element.

    • Cycle on different SO vertex sizes.

      Verify limit of 64-component SO vertices.

  • Simple Multi-Buffer Tests

    • Mix up buffer sizes/offsets so that buffers overflow at different times.

    • Cycle on several declaration scenarios:

      • Simple.

      • Skip output slot.

      • Split output registers across multiple SO elements.

      • Stream out partial register components.

      • Stream out to single buffer in non-zero slot.

  • Ping Ponging of Stream Output Buffers

    • Similar to simple single-buffer and simple multi-buffer tests with a twist:

      • Initially bind buffers A and B with a positive offset.

      • Bind buffer A using -1 offset value.

      • Draw()

      • Bind buffer B using -1 offset value.

      • Draw()

      • Repeat as needed.

    • In multiple buffer scenarios, consider optionally ping-ponging only some of the SO buffers between Draw() calls.

  • Changing SO Vertex Size Using Same Target Buffer

    • Custom test case that focuses on setting "fat" vertex strides to a single buffer, then Draw(), then sets "skinny" SO vertex stride, then Draw() again.

    • Examine STREAMOUTPUTSTATS.

    • Watch for overflow during "fat" vertex streaming and make sure that skinny vertices cannot be appended to target.

      NOTE

      Consider ping-ponging during this step to make sure that the overflowed state is "sticky" on the buffer.

  • Addressable Stream Output (D3D11)

    Test RasterizedStream and multiple vectors of data:

    • When sending a stream to the rasterizer, make sure that the final result uses the vertex data from that stream.

    • Make sure that more than one vector of data can be output from a stream under feature level 11, even when using a gs_4_x shader.

    • Test strides that aren't tightly aligned to the size of an element in a stream output buffer.

    • Verify that stream output works when the runtime determines strides based on the size calculated using the stream output declaration. The runtime does this when the stride parameters in the create call are both NULL.

  • Test feature level and query behavior:

    • When using feature levels 10 and 10.1, make sure only stream 0 can be used for stream output.

    • When using feature levels 10 and 10.1, make sure that only gs_4_x shaders can be used. If multiple buffers are used, make sure that only one vector of data can be output from stream 0 i.

    • D3D11_QUERY_SO_STATISTICS and D3D11_QUERY_SO_OVERFLOW_PREDICATE queries should return the correct data for the sum of all streams. D3D11_QUERY_SO_STATISTICS_STREAMn and D3D11_QUERY_SO_OVERFLOW_PREDICATE_STREAMn queries return the correct data for each stream. There are currently test cases for the single stream case. The following will be verified:

      • Expected number of primitives written to stream output buffers.

      • Expected size of the primitives (if they are all to be output to buffers).

      • Overflow predicate is triggered when one buffer overflows when writing to it.

      • If one buffer in a stream is filled, writes to all buffers in that stream are prevented.

      • Results of queries for undefined streams should not be affected.

Command Syntax

Command option | Description
Wgf11streamout | Rusn the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level tested where XX.X is the Feature Level the test will run at: 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File List

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11streamout.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Tessellation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa64111c-9416-4d7c-8c47-8ee5988040a2

This automated test verifies driver behavior with regards to the D3D11 Tessellation feature. Various aspects of this feature are tested, including the hull and domain shader stages, hull shader phases, and the fixed function tessellator.

This topic applies to the following test jobs:

  • WGF11 Tessellation

  • WGF11 Tessellation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file from the Windows HLK Manager for specific details about failures. The test might return SKIP if it is run with a feature level lower than 11.0. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

This test covers the following four test groups:

Tessellator

This test group verifies that the fixed function tessellator is implemented according to the spec. It cycles on the following items and compares the result to the reference rasterizer:

  • Domain (quad, tri, isolines)

  • Partition (integer, pow2, and so on)

  • Topology (point, line, tri, and so on)

  • TessValues

Hull

This group tests the hull shader portion of the tessellation stage. Shaders generate control points that are sorted by the test and compared to expected values. The contents of the control points depend on what the values the test is cycling on, which is similar to the Tessellator test group above. It verifies the following:

  • The input CPs are correctly read by the control point phase.

  • HS is executed once per output control point (not easily verifiable, only a number of output CPs are visible).

  • Output data is correct for inputs (via pass-through DS and stream-out).

  • Primitive ID is identical across a patch. Other system-generated values are also accurate.

  • Pipeline statistics updated appropriately.

Domain

This group tests the domain shader portion of the tessellation stage. Shaders generate vertices that are compared to expected values. The contents of the vertices depend on what the values the test is cycling on, which is similar to the Tessellator test group above. It verifies the following:

  • Primitive ID identical across a patch. Other system-generated values also accurate.

  • All data is available and accurate.

HullPhases

This group tests the phases of the hull shade, including fork and join. Because these phases are not exposed in HLSL the test uses assembly shaders to verify fork and join. It verifies the following:

  • Input and output CPs correctly read by fork and join phases.

  • Fork phase output correctly read by join phase.

  • Output patch constants are correct and fully written (no overwrites or instances getting dropped).

  • Pipeline statistics updated appropriately.

Command syntax

Command option | Description
Wgf11tessellation | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level. Here XX.X is the Feature Level the test will run at, 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
wgf11tessellation.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Tessellation (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc77fe6e-464c-4938-ba2c-65b00dab7a60

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Tessellation (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c09f61c8-2f62-4ac7-a743-2476909fef66

This automated test verifies driver behavior with regards to the D3D11 Tessellation feature. Various aspects of this feature are tested, including the hull and domain shader stages, hull shader phases, and the fixed function tessellator.

This topic applies to the following test jobs:

  • WGF11 Tessellation

  • WGF11 Tessellation (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

All test cases return PASS or FAIL. Review the test results in the log file from the Windows HLK Manager for specific details about failures. The test might return SKIP if it is run with a feature level lower than 11.0. The test might return BLOCKED if there is an uncaught exception (framework catches it at the end and logs it).

More information

This test covers the following four test groups:

Tessellator

This test group verifies that the fixed function tessellator is implemented according to the spec. It cycles on the following items and compares the result to the reference rasterizer:

  • Domain (quad, tri, isolines)

  • Partition (integer, pow2, and so on)

  • Topology (point, line, tri, and so on)

  • TessValues

Hull

This group tests the hull shader portion of the tessellation stage. Shaders generate control points that are sorted by the test and compared to expected values. The contents of the control points depend on what the values the test is cycling on, which is similar to the Tessellator test group above. It verifies the following:

  • The input CPs are correctly read by the control point phase.

  • HS is executed once per output control point (not easily verifiable, only a number of output CPs are visible).

  • Output data is correct for inputs (via pass-through DS and stream-out).

  • Primitive ID is identical across a patch. Other system-generated values are also accurate.

  • Pipeline statistics updated appropriately.

Domain

This group tests the domain shader portion of the tessellation stage. Shaders generate vertices that are compared to expected values. The contents of the vertices depend on what the values the test is cycling on, which is similar to the Tessellator test group above. It verifies the following:

  • Primitive ID identical across a patch. Other system-generated values also accurate.

  • All data is available and accurate.

HullPhases

This group tests the phases of the hull shade, including fork and join. Because these phases are not exposed in HLSL the test uses assembly shaders to verify fork and join. It verifies the following:

  • Input and output CPs correctly read by fork and join phases.

  • Fork phase output correctly read by join phase.

  • Output patch constants are correct and fully written (no overwrites or instances getting dropped).

  • Pipeline statistics updated appropriately.

Command syntax

Command option | Description
Wgf11tessellation | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level. Here XX.X is the Feature Level the test will run at, 10.0, 10.1, or 11.0.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
wgf11tessellation.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 TiledResources

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d965921-5b57-4385-b524-4ff263910115

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111TiledResource.D3D111CoreA
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 TiledResources (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce3306dc-2308-45a9-a4f4-20fa0e22d650

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111TiledResource.D3D111CoreA
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 TiledResources (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff1340a0-a190-4194-a4d1-07f95f4c3cbf

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111TiledResource.D3D111CoreA
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Timing Data (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2a9b297-9753-426f-ad07-da689ba4489f

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Vertex Shader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/266eec80-6c6e-43a8-8cbe-115caf96cde1

This automated test verifies that vertex shader behavior of the graphics hardware/drivers meets the DX 11 specification.

This topic applies to the following test jobs:

  • WGF11 Vertex Shader

  • WGF11 Vertex Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results: Pass, Fail, Blocked and Skipped. The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration ( e.g. some features are optional and may not be supported by some hardware) and the command line options (e.g. some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

There are three test cases for this test:

Read From Unbound Buffer Slot

  • Read from a buffer when not set (VB, IB, SRV, Constant) should return default value.

Generated Values

  • Generated values should reset for each draw.

  • Make sure that all VS Generated values are generated correctly:

    • No buffer bound. IDs should be generated correctly.

    • When only IB is used, VertexID should be the IB Values

    • Try IB smaller than the number of vertices to draw.

Limits

  • Test cases with very large vertex buffers, index buffer and shader resource buffers to test the device's ability to handle large sized resources. The specification requires the device to handle 128MB buffers.

Command syntax

Command option | Description
Wgf11vertexshader | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at, 10.0, 10.1, or 11.0
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11vertexshader.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Vertex Shader (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2047702c-569b-46c9-8ded-7154e1e86e5c

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Vertex Shader (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e32f2c53-541f-46ca-af00-c47262629e4b

This automated test verifies that vertex shader behavior of the graphics hardware/drivers meets the DX 11 specification.

This topic applies to the following test jobs:

  • WGF11 Vertex Shader

  • WGF11 Vertex Shader (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results: Pass, Fail, Blocked and Skipped. The log file will contain specific details about the test cases that are failed, blocked, or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration ( e.g. some features are optional and may not be supported by some hardware) and the command line options (e.g. some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

There are three test cases for this test:

Read From Unbound Buffer Slot

  • Read from a buffer when not set (VB, IB, SRV, Constant) should return default value.

Generated Values

  • Generated values should reset for each draw.

  • Make sure that all VS Generated values are generated correctly:

    • No buffer bound. IDs should be generated correctly.

    • When only IB is used, VertexID should be the IB Values

    • Try IB smaller than the number of vertices to draw.

Limits

  • Test cases with very large vertex buffers, index buffer and shader resource buffers to test the device's ability to handle large sized resources. The specification requires the device to handle 128MB buffers.

Command syntax

Command option | Description
Wgf11vertexshader | Runs the test. Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Sets the feature level of the test, where XX.X is the Feature Level the test will run at, 10.0, 10.1, or 11.0
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11vertexshader.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Viewports

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1662596-10a1-4a09-b492-0853853f4498

This automated test verifies that the behavior of viewports and scissors of the device is consistent with the DX11 specification.

This topic applies to the following test jobs:

  • WGF11 Viewports

  • WGF11 Viewports (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results: Pass, Fail, Blocked, and Skipped. The log file will contain specific details about the test cases that are failed, blocked,or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration ( e.g. some features are optional and may not be supported by some hardware) and the command line options (e.g. some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

The test covers the following areas:

  • Multiple (up to 16) viewports set/in use.

  • Verify use of arbitrary viewport.

  • Verify overlapping viewports.

  • Verify "ViewportArrayIndex" higher than viewports set is treated as 0, and no index is treated as zero.

  • The value of SV_ViewportArrayIndex passed to pixel shader is unclamped/unconverted.

  • Verify viewport scale is done in float32 arith.

  • Verify the use of scissor with default viewport (viewport with the same size of the render target).

  • More cases of scissors: larger-than-target, off-target, and arbitrary offsets within the viewports.

  • Verify the usage of SV_ViewportArrayIndex by Geometry shader to split the geometry to two different viewports.

  • If the test runs on feature level 11.0 and above, all viewports defined by fractional values.

Command syntax

Command option | Description
Wgf11viewports | Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Where XX.X is the Feature Level the test will run at, 10.0, 10.1, or 11.0
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11viewports.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGF11 Viewports (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0fc9a2e5-5471-4cff-8611-04ad30d45688

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user


WGF11 Viewports (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48242e29-4a78-4fa6-b708-aaf5fcd56229

This automated test verifies that the behavior of viewports and scissors of the device is consistent with the DX11 specification.

This topic applies to the following test jobs:

  • WGF11 Viewports

  • WGF11 Viewports (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.D3D111Core.D3D111CorePrimary
  • Device.Graphics.AdapterRender.D3D11Core.D3D11CorePrimary
  • Device.Graphics.AdapterRender.D3D101Core.D3D101CorePrimary
  • Device.Graphics.AdapterRender.D3D10Core.D3D10CorePrimary
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

Test cases return one of the following results: Pass, Fail, Blocked, and Skipped. The log file will contain specific details about the test cases that are failed, blocked,or skipped. A test case will return Skipped if it is invalid according to the current hardware configuration ( e.g. some features are optional and may not be supported by some hardware) and the command line options (e.g. some test cases are only valid for certain feature levels). A test case will return Blocked if the failure is caused by reasons other than the tested feature. To review test details, review the test log from the Windows HLK Manager.

More information

The test covers the following areas:

  • Multiple (up to 16) viewports set/in use.

  • Verify use of arbitrary viewport.

  • Verify overlapping viewports.

  • Verify "ViewportArrayIndex" higher than viewports set is treated as 0, and no index is treated as zero.

  • The value of SV_ViewportArrayIndex passed to pixel shader is unclamped/unconverted.

  • Verify viewport scale is done in float32 arith.

  • Verify the use of scissor with default viewport (viewport with the same size of the render target).

  • More cases of scissors: larger-than-target, off-target, and arbitrary offsets within the viewports.

  • Verify the usage of SV_ViewportArrayIndex by Geometry shader to split the geometry to two different viewports.

  • If the test runs on feature level 11.0 and above, all viewports defined by fractional values.

Command syntax

Command option | Description
Wgf11viewports | Without any options, the test enumerates devices.
-FeatureLevel:XX.X | Where XX.X is the Feature Level the test will run at, 10.0, 10.1, or 11.0
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d11_1sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3d11sdklayers.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
d3dx11_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Wgf11viewports.exe | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a68b3175-8445-4004-9cfc-ce01876ca36e

WLK test aimed at testing Display driver UMD (CacheCoherency)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15ba3e63-0855-4af7-9c3a-d08a867af3bd

This automated test verifies the display driver UMD (CacheCoherency).

This topic is applicable to the following test jobs:

  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1

  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0

Test details
Specifications
  • Device.Graphics.WDDM12.Render.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WgfVidMMWDDM1_2 | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
etwLibEvents.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
UMDEtw.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
WGFVidMMWDDM1_2.exe | <[testbinroot]>\nttest\WINDOWSTEST\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e5e1ba2a-49cc-488f-856b-b4fa2910c2ac

This automated test verifies the display driver UMD (CacheCoherency).

This topic is applicable to the following test jobs:

  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1

  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0

Test details
Specifications
  • Device.Graphics.WDDM12.Render.OfferReclaim
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WgfVidMMWDDM1_2 | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
etwLibEvents.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
UMDEtw.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
WGFVidMMWDDM1_2.exe | <[testbinroot]>\nttest\WINDOWSTEST\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - OfferReclaim - FL10.0 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e38b6dcd-8581-400c-8c53-a5f05a07b8c3

WLK test aimed at testing Display driver UMD (Video Memory Offer)

Test details
Specifications
  • Device.Graphics.WDDM12.Render.OfferReclaim
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd833c4a-00c2-44a7-97e2-ee720b60d251

This automated test verifies the display driver UMD (CacheCoherency).

This topic is applicable to the following test jobs:

  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1

  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0

Test details
Specifications
  • Device.Graphics.WDDM12.Render.OfferReclaim
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WgfVidMMWDDM1_2 | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
etwLibEvents.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
UMDEtw.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
WGFVidMMWDDM1_2.exe | <[testbinroot]>\nttest\WINDOWSTEST\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - OfferReclaim - FL9.1 (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/255655fa-4d78-486e-8f8f-f1fdb01911f7

This automated test verifies the display driver UMD (CacheCoherency).

This topic is applicable to the following test jobs:

  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1

  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0

Test details
Specifications
  • Device.Graphics.WDDM12.Render.OfferReclaim
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WgfVidMMWDDM1_2 | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
etwLibEvents.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
UMDEtw.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
WGFVidMMWDDM1_2.exe | <[testbinroot]>\nttest\WINDOWSTEST\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - UMDLogging - FL10.0

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed79fcb1-1596-4718-be99-8697085b1287

This automated test verifies the display driver UMD (CacheCoherency).

This topic is applicable to the following test jobs:

  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1

  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0

Test details
Specifications
  • Device.Graphics.WDDM12.Render.UMDLogging
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WgfVidMMWDDM1_2 | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
etwLibEvents.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
UMDEtw.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
WGFVidMMWDDM1_2.exe | <[testbinroot]>\nttest\WINDOWSTEST\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WGFVidMMWDDM1_2 - UMDLogging - FL9.1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d33f52c7-98d1-4d68-92fb-00e7b69e14df

This automated test verifies the display driver UMD (CacheCoherency).

This topic is applicable to the following test jobs:

  • WGFVidMMWDDM1_2 - CacheCoherency - FL9.1

  • WGFVidMMWDDM1_2 - CacheCoherency - FL10.0

  • WGFVidMMWDDM1_2 - OfferReclaim - FL9.1

  • WGFVidMMWDDM1_2 - OfferReclaim - FL10.0

  • WGFVidMMWDDM1_2 - UMDLogging - FL9.1

  • WGFVidMMWDDM1_2 - UMDLogging - FL10.0

Test details
Specifications
  • Device.Graphics.WDDM12.Render.UMDLogging
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WgfVidMMWDDM1_2 | Runs the test.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
etwLibEvents.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
UMDEtw.man | <[testbinroot]>\nttest\WINDOWSTEST\common\etw</p>
WGFVidMMWDDM1_2.exe | <[testbinroot]>\nttest\WINDOWSTEST\graphics\wddm\bin</p>

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable


WHQL FPO optimization check for kernel video driver(s) (1.1)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ad364ea-73db-47b6-a627-dea13e7c17d2

This automated test validates that the stack records generated in event traces can be traversed through the video driver code. In video code, frame point optimization is turned off for debugging purposes.

This document is applicable to the following test jobs:

  • WHQL FPO optimization check for kernel video driver(s) (1.1)

  • WHQL FPO optimization check for kernel video driver(s) (1.2)

Test details
Specifications
  • Device.Graphics.WDDM11.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

When the test is run, the screen flashes a few times and it outputs an fpo_check.xml file. In the bottom of that file, it logs a pass or fail. When running, the test sets up a listener for ETW events, and then performs video work. During this time, it processes the profile event logged by the kernel, with stackwalk events enabled. For each event, it checks if the video kernel is on the stack. If so, it walks the stack looking for the operating system routine that called the video driver. If it is able to successfully find the module that called the video driver (in every case) the test passes. Otherwise, it fails.

Command syntax

Command option | Description
Fpo_check | Without any options, the test enumerates display devices.
Fpo_check 1.1 | This command runs the WHQL FPO optimization check for kernel video driver(s) (1.1) test job.
Fpo_check 1.2 | WHQL FPO optimization check for kernel video driver(s) (1.2)
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Fpo_check | <[testbinroot]>\nttest\multimediatest\AVCore\Audio\WDK</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


WHQL FPO optimization check for kernel video driver(s) (1.2)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8fa8a507-3867-4319-b7a3-c0460e47a819

This automated test validates that the stack records generated in event traces can be traversed through the video driver code. In video code, frame point optimization is turned off for debugging purposes.

This document is applicable to the following test jobs:

  • WHQL FPO optimization check for kernel video driver(s) (1.1)

  • WHQL FPO optimization check for kernel video driver(s) (1.2)

Test details
Specifications
  • Device.Graphics.WDDM12.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

When the test is run, the screen flashes a few times and it outputs an fpo_check.xml file. In the bottom of that file, it logs a pass or fail. When running, the test sets up a listener for ETW events, and then performs video work. During this time, it processes the profile event logged by the kernel, with stackwalk events enabled. For each event, it checks if the video kernel is on the stack. If so, it walks the stack looking for the operating system routine that called the video driver. If it is able to successfully find the module that called the video driver (in every case) the test passes. Otherwise, it fails.

Command syntax

Command option | Description
Fpo_check | Without any options, the test enumerates display devices.
Fpo_check 1.1 | This command runs the WHQL FPO optimization check for kernel video driver(s) (1.1) test job.
Fpo_check 1.2 | WHQL FPO optimization check for kernel video driver(s) (1.2)
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Fpo_check | <[testbinroot]>\nttest\multimediatest\AVCore\Audio\WDK</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


Windows Client System Check For WDDM 1.1 Or Greater Display Driver Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d52aeb9-54fb-46fb-a7bb-3a82a097e4d4

This automated test verifies that all display adapters/chipsets in the system are using display drivers that are WDDM 1.1 version or greater. This job will be required to pass when all of Graphics-0020 requirement goes into effect on December 1, 2009.

Test details
Specifications
  • System.Client.Graphics.WDDM
  • Device.Graphics.WDDM11.DisplayRender.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Wireframe

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07472b4d-02e7-4e7c-ab14-aa61615e6aca

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Wireframe

  • Wireframe - TnL

  • Wireframe - TnL (WoW64)

  • Wireframe (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wireframe -rast -M:1 -dx9 -whql -logclean | This command runs the Wireframe test job.
Wireframe -rast -M:1 -whql -logclean | This command runs the Wireframe (WoW64) test job.
Wireframe -M:1 -dx9 -whql -logclean | This command runs the Wireframe - TnL test job.
Wireframe -M:1 -whql -logclean | This command runs the Wireframe - TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wireframe.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Wireframe - TnL

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53fd9088-a7a0-460b-8aa1-b24be25535b0

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Wireframe

  • Wireframe - TnL

  • Wireframe - TnL (WoW64)

  • Wireframe (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wireframe -rast -M:1 -dx9 -whql -logclean | This command runs the Wireframe test job.
Wireframe -rast -M:1 -whql -logclean | This command runs the Wireframe (WoW64) test job.
Wireframe -M:1 -dx9 -whql -logclean | This command runs the Wireframe - TnL test job.
Wireframe -M:1 -whql -logclean | This command runs the Wireframe - TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wireframe.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Wireframe - TnL (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4f1e927-5725-438b-8761-ef736736fb26

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Wireframe

  • Wireframe - TnL

  • Wireframe - TnL (WoW64)

  • Wireframe (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wireframe -rast -M:1 -dx9 -whql -logclean | This command runs the Wireframe test job.
Wireframe -rast -M:1 -whql -logclean | This command runs the Wireframe (WoW64) test job.
Wireframe -M:1 -dx9 -whql -logclean | This command runs the Wireframe - TnL test job.
Wireframe -M:1 -whql -logclean | This command runs the Wireframe - TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wireframe.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Wireframe (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a476b22c-32bc-461c-8470-73f7f5917c5a

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • Wireframe

  • Wireframe - TnL

  • Wireframe - TnL (WoW64)

  • Wireframe (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Wireframe -rast -M:1 -dx9 -whql -logclean | This command runs the Wireframe test job.
Wireframe -rast -M:1 -whql -logclean | This command runs the Wireframe (WoW64) test job.
Wireframe -M:1 -dx9 -whql -logclean | This command runs the Wireframe - TnL test job.
Wireframe -M:1 -whql -logclean | This command runs the Wireframe - TnL (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
Wireframe.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Wireless Display Verify 1080p

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71ceab9b-7bec-4607-9534-b6e1866803ea

This automated test verifies that the graphics driver can drive 1080p resolution. The test installs a software device to emulate Mircacast sink, starts a session, and then verifies that the driver can correctly set 1080p display mode.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to locate the connected Miracast display.. | Driver failed to connect the Miracast display.
Expected source resolution of 1920x1080 found. | Driver failed to set desired source resolution..
Expected target resolution of 1920x1080 found. | Driver failed to set desired target resolution.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Connector Type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/32d7583a-7753-43fb-ab3f-edc9c0659548

This automated test verifies that the graphics driver correctly reports the connector type that is being used by Miracast display. The test installs a software device to emulate Miracast sink.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to detect monitor arrival. | Driver failed to connect a Miracast monitor.
Failed: Driver failed to provide connector type … | Driver failed to provide connector type.
Failed: Driver provides invalid connector type… | Driver provides invalid connector type.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Container ID Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/292441fb-9cb0-404a-ba1e-54daf761e7eb

This automated test verifies that the graphics driver uses the same container ID for both the Miracast monitor and the Miracast audio endpoint. The test installs a software device to emulate Mircacast sink, starts a session, and then verifies that there is an audio end point with the same container ID as the Miracast monitor.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Container Id for the monitor can't be internal one. | Driver assigned incorrect container ID to a Miracast monitor.
Audio end point for the monitor is missing. Expected: … | Driver failed to correctly initialize the audio end point for the Miracast monitor.
ContainerId can't be extracted for the monitor. | Driver failed to connect the Miracast monitor.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Edid

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3862d07-381b-4821-9c53-f1d60173a6c3

This automated test verifies that the graphics driver correctly reports the same EDID that is reported by the sink device for the Miracast display. The test installs a software device to emulate Miracast sink and repeatedly connects/disconnects different displays to the sink.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Unable to retrieve Miracast monitor properties. | Driver failed to connect a Miracast monitor.
Failed: Driver provides incorrect EDID data. | Driver modified EDID for Miracast monitor.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Frame Quality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da3935d3-6c3a-4e68-9fee-692e72effe33

This automated test verifies the conformance by checking the quality of the data that is streamed to the sink. The test installs a software device to emulate Miracast sink, starts video playback in the Miracast session, and captures the frames to be verified.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to locate the connected Miracast display. | Driver failed to connect the Miracast display.
Video frame capture and desktop capture images do not match at the start of video file. | Driver failed to correctly encode video data.
Video frame capture and desktop capture images do not match at the end of video file. | Driver failed to correctly encode video data.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Hibernate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe9899b4-ba54-407c-bc2f-b42de497874b

This automated test verifies that the graphics driver provides stability and reliability when an active Miracast session is stopped by hibernation and then started again after system resume. The test installs a software device to emulate Miracast sink, starts a session, and then forces transition into a hibernate state if the system supports it.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to connect a Miracast monitor. | Driver failed to connect a Miracast monitor.
Expected resolution of … found … | Driver failed to set desired resolution.
Failed while waiting for protocol event from driver. Allowed timeout: 3000ms. | Driver failed to respond on protocol event in timely manner.
Failed to connect a Miracast monitor after power transition. | Driver failed to reconnect a Miracast monitor after a power transition.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Message Timeouts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c815f97-c642-4bd7-80d4-e27e76068002

This automated test verifies that the graphics driver can handle Miracast protocol delays. The test installs a software device to emulate Miracast sink, starts a session, and then verifies that the driver can correctly handle delays in protocol messages that are induced by the test.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to trigger virtual sink … event. | The test failed to generate the desired event. Rerun the test.
Expected the session state to be started or start pending but found … | Driver failed to correctly handle a delay in Miracast protocol messages.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Miracast Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93106b25-ec65-4851-a658-1f1eaa755824

This automated test verifies that basic support for wireless display is present and that the UMDF driver for Miracast is implemented in its own DLL.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Miracast UMD name is not unique. | Miracast UMDF driver should be implemented in its own DLL.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Mode Change

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92bee126-d3ba-4965-86c9-99691f4c2c56

This automated test verifies that the graphics driver can reach all reported resolutions and correctly report refresh rate and protocol events. The test installs a software device to emulate Miracast sink, starts a session, and then verifies that the driver can correctly set display modes.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to get a mode list for the miracast display. | Driver failed to supply a mode list for the Miracast display.
Expected resolution of … found … | Driver failed to set desired resolution.
Failed while waiting for protocol event from driver. Allowed timeout: 3000ms. | Driver failed to respond on protocol event in timely manner.
Unexpected mode enumerated by the display driver. Expected only modes with …hz refresh rate. Found: .. | Driver reported incorrect refresh rate.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Monitor Arrival Departure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a99f7a8-f7e5-4bb9-9028-c4223491df91

This automated test verifies the ability of a graphics driver to repeatedly connect and disconnect a Miracast monitor. The test installs a software device to emulate Miracast sink.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed: Monitor wasn't connected properly. | Driver failed to connect a Miracast monitor.
Failed: Miracast monitor isn't present on desktop. | Driver failed to attach a Miracast monitor to the desktop.
Failed: Monitor wasn't disconnected properly. | Driver failed to disconnect Miracast monitor.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Monitor Disconnect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8ee975f3-5e3d-48f1-afe5-4522e68bf297

This automated test verifies that the graphics driver correctly reports the monitor departure when the sink display connector is unplugged and that the Miracast session stops. The test installs a software device to emulate Miracast sink, starts a session, and then disconnects the monitor from the sink.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to connect a Miracast monitor. | Driver failed to connect a Miracast monitor.
Virtual sink thread failed to exit. | Driver failed to inform a sink that the session had stopped because of a monitor departure.
Failed: Miracast device should be stopped when monitor was disconnected. | Driver failed to properly report monitor disconnect event, thereby leaving a device in incorrect state.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Monitor Off

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e67473d6-63c9-4eac-bc32-a229f0a46149

This automated test verifies that the graphics driver correctly handles the Miracast display going idle. The test installs a software device to emulate Miracast sink, starts a session, and then forces the monitor into the idle state.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to connect a Miracast monitor. | Driver failed to connect a Miracast monitor.
Failed to turn monitor off. | The test failed to turn off a monitor.
Failed: Miracast sink should be informed that the source is in standby mode. | Driver failed to inform the sink that a monitor went idle.
Failed: Miracast device should continue run when monitor turned off. | Driver forced the Miracast session into an incorrect state when a monitor went idle.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify OPM On Real Sink

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4a1f98d-6531-49b9-8289-37542f626d20

This manual test verifies that the graphics driver lists support for H264 protection and that it can be enabled on the Miracast display. The test requires a Miracast connection that is established on real hardware that has H264 support. For example, connect a sink to a monitor over a HDMI cable.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed: Wireless monitor is not connected. | The hardware was not properly set up.
Failed: HDCP can't be set, but reported as supported. | Driver failed to establish the high-bandwidth digital content protection (HDCP) connection.
Pass: HDCP is not supported on wireless output. HDCP support is optional. | Driver or connection doesn't support HDCP. If the driver is supposed to support HDCP, rerun the test by attaching an appropriate wireless display.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify PnpStop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06f67578-400a-449f-a7c3-14e859fbcb61

This automated test verifies that the graphics driver provides stability and reliability when a PnP event occurs during different Miracast active session scenarios. The test installs a software device to emulate Miracast sink, starts a session, and then disables the graphics adapter, thereby forcing the operating system to unload the driver.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed: Miracast device should be stopped if an adapter had been disabled. | Driver failed to stop Miracast session.
Virtual sink thread failed to exit. | Driver failed to inform a sink that the session had been stopped.
QueryMiracastDisplayDeviceStatus failed with status … | Driver placed Miracast device in an incorrect state.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Protocol

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b155c14-57f7-4435-a0af-840658db08c0

This automated test verifies that the graphics driver can handle Miracast protocol errors. The test installs a software device to emulate Mircacast sink, starts session and then verifies that the driver can correctly handle protocol errors induced by the test.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Compatibility
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to trigger virtual sink … event. | The test failed to generate the desired event.
Expected the driver to time-out and disconnect the session due to message corruption and incomplete message sequence. | Driver failed to disconnect the session due to a fatal error that was caused by the test.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Session Connect Disconnect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee472a49-d016-4475-b14b-26288a447217

This automated test verifies graphics driver stability to repeatedly start and stop a Miracast session without issue. The test installs two software devices to emulate Miracast sinks.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Start session failed with result … | Miracast session failed to start.
Expected session started result of … | Miracast session started in unexpected state.
Device reported success but session failed to reach the stopped state. | Miracast session failed to stop.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Sink Disconnect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8387a7fb-086a-4422-a6d0-9da8874dc145

This automated test verifies that the graphics driver correctly reports failure when the sink device drops connection, indicates session stop, and other failures. The test installs a software device to emulate Miracast sink, starts a session, and then forces the sink to drop the connection, etc.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Keepalive timeout shouldn't be less than 10 sec, source specified: … | Driver specified incorrect value for keepalive timeout.
Keepalive timeout shouldn't be more than 120 sec, source specified: … | Driver specified incorrect value for keepalive timeout.
Failed while waiting for disconnect ETW event for … | Driver failed to properly disconnect a session.
Expected … but received … | Driver reported incorrect reason for disconnect event.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Sink Failed To Set Mode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10bf8607-2a49-44c7-96c7-82fce1c3177a

This automated test verifies that the graphics driver correctly reports failure when the sink device fails to set a display mode. The test installs a software device to emulate Miracast sink, starts a session, and then forces the sink fail to set mode.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to detect M4 message override. Expected to set mode within 15000 ms. | Driver failed to issue a set mode request in 15 seconds.
Monitor shouldn't be connected after the set mode failed. | Driver must disconnect the Miracast monitor when the sink failed to set mode.
Expected UMD_SINK_FAILED_STANDARD_MODE_CHANGE but received… | Driver reported incorrect error code on failed to set mode event.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Sleep

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc416f10-3679-4356-b736-6a7fd50257f2

This automated test verifies that the graphics driver provides stability and reliability when an active Miracast session is stopped by sleep and then started again after system resume. The test installs a software device to emulate Mircacast sink, starts a session, and then forces transition into sleep or connected standby state.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to connect a miracast monitor. | Driver failed to connect a Miracast monitor.
Failed to force sleep state. | The test failed to force sleep state.
Failed to force connected standby state. | The test failed to force connected standby state.
Failed: Miracast device should be stopped on power transition.Unexpected mode enumerated by the display driver. Expected only modes with …hz refresh rate. Found: .. | Driver failed to stop Miracast device properly.
Failed to connect a Miracast monitor after a power transition. | Driver failed to reconnect a Miracast monitor after a power transition.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Stability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b445d260-89b2-43f0-9171-93a47d39488e

This automated test verifies the long term stability of a Miracast connection while playing video. The test installs a software device to emulate Miracast sink and starts video playback in the Miracast session.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed while waiting for device to stop. | Driver failed to support the Miracast session for 120 min. The session was stopped prematurely.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify TDR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ee0a256-4062-46af-a7f8-d25260871354

This automated test verifies that the graphics driver allows an active Miracast session to survive TDR events. The test installs a software device to emulate Miracast sink, starts a session, and forces GPU to stop responding to rendering and presenting commands.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to connect a Miracast monitor. | Driver failed to connect a Miracast monitor.
Failed to trigger … event. | The test failed to trigger TDR event on GPU.
Failed: Miracast device should continue run after TDR. | Driver exited Miracast session due to TDR event on GPU.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


Wireless Display Verify Topology

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4fdb9216-5479-49c3-9500-5e4a834b94fd

This automated test verifies that the graphics driver can reach all valid topologies. The test installs a software device to emulate Miracast sink, starts a session, and then verifies that all valid topologies can be set.

Test details
Specifications
  • Device.Graphics.WDDM13.DisplayRender.WirelessDisplay.BasicWirelessDisplay
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

The test generates an RTSP message log file: virtualsinklog.{…}.txt. The actual name of this file can be found in the test log file. For example:

Message 6/13/2013 7:39:22.724 PM RTSP log file: virtualsinklog.{3D55759A-4BB2-43C6-9AD6-9D98D6726908}.txt

The test job captures WirelessDisplay.etl and WPP.etl files. You can find these files by selecting Child Job Results in Windows Hardware Lab Kit (Windows HLK) Manager and then browsing job logs for Wireless Display Cleanup Trace.

WirelessDisplay.etl contains information about the Miracast session from start to stop. Most events are aligned with DDI calls for both the user mode driver (UMD) and kernel mode driver (KMD). IHV investigating issues might find it useful to look for errors in these DDI events. The event names should be familiar to the developer because they closely match the DDI names that are used for the wireless feature. This file can be analyzed by using Windows Performance Analyzer (WPA).

WPP.etl contains WPP traces that are captured for the display kernel events related to Miracast. These traces are highly detailed, and should provide adequate information about session failures that is sufficient to debug most issues. These files require access to symbols to decode them. Symbols for the OS should be available to IHVs. The following command line should be used to decode WPP.etl in wpp.txt is: netsh trace convert overwrite=yes tmf=..\symbols.pri\TraceFormat WPP.etl.

All test cases return PASS or FAIL. The test details are available in the test log (Te.wtl), which you can view in Windows HLK Studio.

Error | Description/Workaround
Failed to reach the starting state topology. | Driver failed to set basic topology.
Miracast display is no longer present after topology change. | Driver failed to connect Miracast display.
Failed to reach the target topology. | Driver failed to set desired topology.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
WDKDeviceID | Device id of DUT


WLP MultiTexturing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6f847973-528d-4c85-8666-e21e8131ef1c

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WLP MultiTexturing

  • WLP MultiTexturing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WLPMultiTexturing -M:1 -dx9 -whql -logclean | Runs the WLP MultiTexturing test job.
WLPMultiTexturing.exe -M:1 -whql -logclean | Runs the WLP MultiTexturing (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
WLPMultiTexturing.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP MultiTexturing (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe3f0532-17ba-47ed-bf05-f9e69c2dcb10

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WLP MultiTexturing

  • WLP MultiTexturing (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WLPMultiTexturing -M:1 -dx9 -whql -logclean | Runs the WLP MultiTexturing test job.
WLPMultiTexturing.exe -M:1 -whql -logclean | Runs the WLP MultiTexturing (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <[testbinroot]>\nttest\windowstest\tools</p>
D3d10ref.dll | <[testbinroot]>\nttest\graphics\d3d\support</p>
D3d11ref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support
D3dref8.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
WLPMultiTexturing.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP RGB Rasterization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9b4da2c6-b236-4b53-aa6d-0df72d410082

This automated test verifies that the display adapter can meet the minimum Microsoft Direct3D requirements.

The test composes a Direct3D scene that includes all of the relevant elements from the WLP minimum requirements, such as Gouraud shading, basic alpha blending, Bi-Linear filtering, specific texture formats, and so on. The test then validates that the display adapter claims support for each of these (and will fail the test if it does not) and renders the scene with the display adapter and with the reference rasterizer.

The test does a pixel comparison of the rendered images and determines if the test passed or failed based on that comparison (allowing the standard 15% difference). The test is run twice: the first time in windowed mode and the second time in full-screen mode.

This topic is applicable to the following test jobs:

  • WLP RGB Rasterization

  • WLP RGB Rasterization (WoW64)

  • WLP RGB Rasterization - Mobile

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Scenario -wlp -M:1 -dx9 -whql -logclean | Runs the WLP RGB Rasterization test job.
Scenario -wlp -M:1 -whql -logclean | Runs the WLP RGB Rasterization (WoW64) test job.
Scenario -wlp -Mobile -M:1 -whql -logclean | Runs the 32-bit WLP RGB Rasterization - Mobile test case.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
Scenario.exe | <testbinroot>\nttest</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>
Vbswap.x | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP RGB Rasterization - Mobile (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a97e6b11-188d-4537-8caf-8978f3edb7ef

This automated test enforces that the display adapter can meet the minimum Microsoft Direct3D requirements. For the full list of minimum requirements, refer to the latest Windows Certification Program documentation.

The test composes a Direct3D scene that includes all of the relevant elements from the WLP minimum requirements, such as Gouraud shading, basic alpha blending, Bi-Linear filtering, specific texture formats, etc. The test then validates that the display adapter claims support for each of these (and fails the test if it does not) and renders the scene with the display adapter and with the reference rasterizer.

The test does a pixel comparison of the rendered images and determines if the test passed or failed based on that comparison (allowing the standard 15% difference). The test is run twice: the first time in windowed mode and the second time in full-screen mode.

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP RGB Rasterization (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/193cca73-ef03-4925-9bdb-48ac3f2b4bd4

This automated test verifies that the display adapter can meet the minimum Microsoft Direct3D requirements.

The test composes a Direct3D scene that includes all of the relevant elements from the WLP minimum requirements, such as Gouraud shading, basic alpha blending, Bi-Linear filtering, specific texture formats, and so on. The test then validates that the display adapter claims support for each of these (and will fail the test if it does not) and renders the scene with the display adapter and with the reference rasterizer.

The test does a pixel comparison of the rendered images and determines if the test passed or failed based on that comparison (allowing the standard 15% difference). The test is run twice: the first time in windowed mode and the second time in full-screen mode.

This topic is applicable to the following test jobs:

  • WLP RGB Rasterization

  • WLP RGB Rasterization (WoW64)

  • WLP RGB Rasterization - Mobile

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
Scenario -wlp -M:1 -dx9 -whql -logclean | Runs the WLP RGB Rasterization test job.
Scenario -wlp -M:1 -whql -logclean | Runs the WLP RGB Rasterization (WoW64) test job.
Scenario -wlp -Mobile -M:1 -whql -logclean | Runs the 32-bit WLP RGB Rasterization - Mobile test case.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
Scenario.exe | <testbinroot>\nttest</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>
Vbswap.x | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP Specular

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc1d3494-0464-44f6-bc61-ca4a220294ee

This automated test verifies the requirements listed in the test details table.

This topic is applicable to the following test jobs:

  • WLP Specular

  • WLP Specular (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WLPSpecular -M:1 -dx9 -whql -logclean | This command runs the WLP Specular test job.
WLPSpecular -M:1 -whql -logclean | This command runs the WLP Specular (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>
Vbswap.x | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
WLPSpecular.exe | <testbinroot>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP Specular (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb8285be-8f00-4545-a3a3-2d6b148081c5

This automated test verifies the requirements listed in the test details table.

This topic is applicable to the following test jobs:

  • WLP Specular

  • WLP Specular (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WLPSpecular -M:1 -dx9 -whql -logclean | This command runs the WLP Specular test job.
WLPSpecular -M:1 -whql -logclean | This command runs the WLP Specular (WoW64) test job.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <testbinroot>\nttest\windowstest\graphics</p>
Vbswap.x | <testbinroot>\nttest\windowstest\graphics\d3d\conf</p>
WLPSpecular.exe | <testbinroot>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP Texture Sizes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8942016-6556-482d-80f9-1df0627d798e

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WLP Texture Sizes

  • WLP Texture Sizes (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WLPTextureSizes -M:1 -dx9 -whql -logclean | This command runs the WLP Texture Sizes test job.
WLPTextureSizes -M:1 -whql -logclean | This command runs the WLP Texture Sizes (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
WLPTextureSizes.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WLP Texture Sizes (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99dab440-699b-4add-9a47-5132aaa54581

This automated test verifies the requirements listed in the test details table.

This topic applies to the following test jobs:

  • WLP Texture Sizes

  • WLP Texture Sizes (WoW64)

Test details
Specifications
  • Device.Graphics.AdapterRender.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Graphic Adapter or Chipset Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Graphics Testing.

More information

Command syntax

Command option | Description
WLPTextureSizes -M:1 -dx9 -whql -logclean | This command runs the WLP Texture Sizes test job.
WLPTextureSizes -M:1 -whql -logclean | This command runs the WLP Texture Sizes (WoW64) test job.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Configdisplay.exe | <testbinroot>\nttest\windowstest\tools</p>
D3d10ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3d11ref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dcompiler_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref8.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dref9.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx10_test.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx11_TEST.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx8d.dll | <testbinroot>\nttest\windowstest\graphics\d3d\support</p>
D3dx9_TEST.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\support</p>
Fpstate.dll | <[testbinroot]>\nttest\windowstest\graphics\d3d\utility</p>
Modechange.exe | <testbinroot>\nttest\windowstest\graphics\d3d\utility</p>
TDRWatch.exe | <[testbinroot]>\nttest\windowstest\graphics</p>
Vbswap.x | <[testbinroot]>\nttest\windowstest\graphics\d3d\conf</p>
WLPTextureSizes.exe | <[testbinroot]>\nttest</p>

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


WMV multiInstance test 405

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c1d16a3-4046-5d3f-5df7-df9d85d10759

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Multi Instance DXVA Test: InputType WMV - Multi Instance DXVA Test WMV

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Multi-Instance test 406

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/226c688f-5958-4aea-a1df-3e6c487005cc

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 32

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f3dede6-40cd-254d-1e3f-33ae5c4d5d51

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 33

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d63b71e-fead-4cd2-a519-ddac1673cbd7

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 34

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6f903f12-3d93-4130-921b-159b62a5122a

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 35

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d88c421d-427b-4b7d-b063-6ac0c8732a23

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 36

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61a93211-75fa-4d54-aca6-c06608b965bb

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 37

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17ab700f-f761-48d8-82ff-c63ac4915229

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 38

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/399f7753-8215-47f0-968f-2b09ac6f5be4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 39

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/003c7519-81d3-443e-b320-a4fb3c9efbdf

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 40

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b3e23f3-93a6-4f20-98aa-3842a6c6d8ff

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 41

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd9d1d48-f243-431c-9a97-af7bc7ae739a

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 42

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5fcbc03-d725-4114-aae5-ad28a9b62992

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Direct3D_9 Playback Test 43

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/934d5e6c-92b0-48aa-9d2d-688fa729e1d4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


WMV Stress test 305

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b0b1d3b-2906-40dc-b231-7afaf40cfce4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Graphics.WDDM12.Render.D3D11VideoDecoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the DXVA Decoder to test - {DETECT} should be used for certification, this can be overridden to test a specific decoder


XVP test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8594c77d-4374-0108-906e-f6b146e0bc58

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbd78f7d-9f2e-4497-9571-7db0b94a4625

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 109

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8890d733-57a5-43ba-98af-87a085e8da8c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e2aeacb-8824-4af8-aee0-bf1df3dd49b9

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 110

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c73824c6-5631-4dfe-a6ac-247c645ee0e9

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/752ba963-cc9e-4dce-9be4-9a061c5743f9

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b8cf1ef4-4468-0d0f-a0bd-88957c2103de

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD Test: InputType H264 - Video Processor Quality XVP Color Conversion VV YUY2ex to ARGB32

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/785b177e-2f01-4255-b11d-53fb7aef8fa3

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd87fb6b-1540-4654-8de5-fc0b9818eeb5

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47454f8e-4e0f-6fa1-8e3a-33bc50462418

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


XVP test 92

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2dac36cb-0c64-4896-b6c4-477c729476e7

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

DXVAHD XVP Test - Video Processor Quality XVP

Test details
Specifications
  • Device.Graphics.WDDM.Render.VideoProcessing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


ZeroStateTransitions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ade2d220-2d6b-4662-91ca-415bf70474e6

This test walks an allocation's zeroing state graph and detects when process zeroing stats increase, validating expectations.

Test details
Specifications
  • Device.Graphics.WDDM20.CoreRequirement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


iFlip Present Desktop - Multihead (Requires 2+ monitors)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1d24afbc-dfac-4994-880c-dd5af8581471

Validates that iFlip is maintained across different scenarios.

Test details
Specifications
  • Device.Graphics.WDDM22.DisplayRender.MultiPlaneOverlay3
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
TestRequiresMultipleOutputs | Test requires multiple outputs by default when run in the HLK.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


iFlip Present UAP (Mobile)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3fdc5c05-7479-46be-aa85-f65aaad77688

Validates that iFlip is maintained across different scenarios.

Test details
Specifications
  • Device.Graphics.WDDM22.DisplayRender.MultiPlaneOverlay3
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
UAPHLKmode |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


iFlip Present UAP - Multihead (Requires 2+ monitors)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48a61c2d-36e6-423d-b785-ff16423e9b67

Validates that iFlip is maintained across different scenarios.

Test details
Specifications
  • Device.Graphics.WDDM22.DisplayRender.MultiPlaneOverlay3
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
TestRequiresMultipleOutputs | Test requires multiple outputs by default when run in the HLK.
UAPHLKmode |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation


Device.Graphics additional documentation

In this section

  • Display Monitor Testing Prerequisites
  • Graphic Adapter or Chipset Testing Prerequisites
  • Troubleshooting Device.Graphics Testing


Display Monitor Testing Prerequisites

This section describes the tasks that you must complete before you test a display monitor or projector by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing a CRT or flat panel display monitor or a projector.

  • Two test computers. These test computers must meet the Windows HLK prerequisites and must be included in the same computer pool. For more information, see Windows HLK Prerequisites.

  • Two test display devices.

NOTE

We recommend that you test two different display adapters that use different IHV drivers when you test the display device. You might need additional hardware if the test device offers other features, such as a USB port or built-in audio capabilities. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required for testing a display device:

  • Any drivers that are not included with the operating system.

  • A setup information file (INF) for the device that you are testing.

  • An Image Color Management (ICM) file, if applicable.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the two test computers for display monitor testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computers, and then add these computers to your test network.

  2. Connect the display monitor or projector to each test computer.

  3. Install the manufacturer-supplied INF or ICM files, if either of these files is required for the display device, on the test computers.

  4. Make sure that the display monitor or projector functions correctly on both test computers.

  5. Install the Windows HLK client application on the test computers.

  6. Use Windows HLK Studio to create a machine pool and move the test computers to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Graphic Adapter or Chipset Testing Prerequisites

This section describes the tasks that you must complete before you test a graphic adapter or chipset by using the Windows Hardware Lab Kit (Windows HLK).

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing a graphics adapter or chipset. This specific hardware fulfills the diversity requirements that demonstrate the stability of display drivers and chipsets. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

  • At least two test computers for every discrete device family in the INF file that is being certified. These test computers must meet the Windows HLK prerequisites and must be included in the same machine pool. For more information, see Windows HLK Prerequisites. These systems must contain the following:

    • If your device family supports a stand-alone feature, you must include at least one adapter with that capability per device family in the machine pool. For example, if your adapter supports Stereo 3D, you must include at least one of these adapters (per device family) in the machine pool along with a stereo capable monitor as the primary display set to a stereo-capable mode.

    • If you support LDA configuration, you will need to include relevant display adapters in the machine pool.

  • A minimum of two adapters for every device family that the INF file supports. One of the adapters must support multi-display capabilities and have a monitor attached and enabled.

  • One multi-sync display data channel standard, level 2B (DDC2B)-capable monitor that has extended display identification data (EDID) 1.3 support on the test computer.

Depending on the type of submission, you might need the following features or configurations:

  • TV-out support

  • Multi-monitor support

  • Hot-plug detection support

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required for testing a graphics adapter or chipset:

  • The drivers for the test device.

    NOTE

    OPM/COPP requirements are implemented based on feature detection; Full WDDM drivers must support OPM/COPP if they have a capable connector/monitor.

  • Supplemental Content for Windows HLK Tests for DXVA and HMFT Multimedia Tests is required to pass the DXVA (DirectX Video Acceleration) tests. Download and install this supplemental test content from the MSDN® website at: http://msdn.microsoft.com/en-us/windows/hardware/hh852358.

    IMPORTANT

    Before running the DXVA tests on x86 or amd64 systems, you must install the Windows 8 Professional SKU and then install the Windows Anytime Upgrade for Media Center; otherwise, the MPEG2 tests will fail.

    The Media Foundation Feature must be installed on Server 2012 for DXVA testing.

  • The latest Windows HLK filters or updates.

  • All operating system updates, service packs and compatibility packs

NOTE

The Displaygroups.xml (required in previous version of the kit) is not present in the Windows HLK. The declaration of ASIC families has been replaced by device families which must be declared using scripts in the Windows Hardware Lab Kit Object Model. Refer to WHLK OM documentation for more details.

Many Windows HLK graphics tests use a HLKShowClassicDesktop.exe tool to forcibly switch from the tailored app start menu to the classic desktop. Be aware that HLKShowClassicDesktop does not work if User Account Control (UAC) is disabled.

Many people disable UAC so that its prompts do not interfere with test automation. However, HLKShowClassicDesktop requires a higher privilege level than most Windows HLK tests. If you disable UAC, all applications run at the same default level.

We recommend you use the Never Notify option to silence prompts instead of disabling UAC. To do this, configure the following registry keys settings: .

Set HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA = 1 to turn UAC on
Set HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\ConsentPromptBehaviorAdmin = 0 to turn on Never Notify mode

Test computer configuration

Display adapter or chipset testing requires at least one test computer for every device family in the INF file that is being certified.

To configure the test computer for the display adapter testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computers and then join the computers to your test network.

    For each graphics device family:

    • Configure at least one computer with multiple display adapters (two monitors at a minimum)

    • If supported configure at least one system with:

      1. Stereo-capable display as the primary display set to a stereo-capable mode

      2. Composite display or S-Video display

      3. HDCP capable display

  2. Attach one multi-sync display data channel standard, level 2B (DDC2B)-capable monitor that has EDID 1.3 support to each test computer.

    NOTE

    The secondary head of a multiple-headed display adapter and chipset must be connected to a monitor and enabled before you start testing. Not all devices that support multiple heads must be enabled, but at least one device for each device family that is listed in the INF file must be enabled. To test outside of the submission process, make sure that all secondary heads are connected to a monitor and enabled. Otherwise, when a test is selected for the unattached secondary head, the test runs on the primary head.

  3. If you have to install the manufacturer-supplied device driver on the test computer or computers, do this now.

  4. Make sure that the display monitor or projector functions correctly on both the test computers.

  5. Disable power management and password protection before you start the testing.

  6. Install the Windows HLK client application on the test computers.

  7. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

  8. (Optional) Define device families to test (requires the Windows HLK object model

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Before you start a display test, close any active applications, including File Explorer and Internet Explorer, on the test computer. Disable any active applications that, by default, are the top window. Examples of such applications are pop-up balloons or on-screen keyboards for Tablet PCs.

To run the Fast User Switching (FUS) tests, make sure that the test system is not part of a domain. To do this, right-click My Computer, and then click Properties. On the Computer Name tab, see if the computer is a part of a domain. If the computer is part of a domain, click Change, and then add the computer to a workgroup.


Troubleshooting Device.Graphics Testing

To troubleshoot issues that occur with Device.Graphic tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review one of the following topics, depending on the type of graphic device that you want to test:

    • Display Monitor Testing Prerequisites

    • Graphic Adapter or Chipset Testing Prerequisites

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Specific information about DXVA testing

The DXVA tests require the following:

  • Supplemental Content for Windows HLK Tests for DXVA and HMFT Multimedia Tests: Download and install the Supplemental Content for Windows HLK Tests for DXVA and HMFT Multimedia Tests from the MSDN® website at http://msdn.microsoft.com/en-us/windows/hardware/hh852358.

    IMPORTANT

    Before running the DXVA tests on x86 or amd64 systems, you must install the Windows 8 Professional SKU and then install Windows Anytime Upgrade for Media Center, otherwise the MPEG2 tests will fail.

Common errors

Error | Description | Solution
ERROR>> Failed to find input source file. | Content not available to client machine. | Ensure that the ContentSource parameter points to the correct location of the source content at run time.

Related topics

Device.Graphics Tests

Troubleshooting Windows HLK


Device.Imaging

In this section

  • Device.Imaging tests
  • Device.Imaging additional documentation


Device.Imaging tests

  • DocumentProperties Test (Unicode)
  • GDL Correctness Test
  • INF Syntax Test
  • Mobile Print - Print Device Capabilities conformance
  • Mobile Print - Print Device Capabilities resource validation
  • Mobile Print - Rendering Tests (Basic)
  • Mobile Print - Rendering Tests (Device Processed)
  • Mobile Print - WSD Print V2.0 Verify
  • OXPS Content Library - Discard Control Processing(MANUAL)
  • OXPS Content Library - Files that violate OPC, XPS, Markup Compatibility rules(MANUAL)
  • OXPS Content Library - MinBar Files(MANUAL)
  • OXPS Content Library - Thumbnail Processing(MANUAL)
  • OXPS Rendering
  • OXPS Security
  • PGremlin Rendering Test
  • PGremlin2 Rendering Test
  • Photo Print Test
  • Print Bidi Test
  • Print Device Capabilities conformance (Driver)
  • Print Driver Device Capabilities Test (PrDeviceCapabilities)
  • Print Driver DevMode Corruptor Test
  • Print Driver Stress Test
  • Print Processor API Test
  • Printable Area Test
  • Printer CompatibleID Test - USB
  • Printer CompatibleID Test - WSD
  • Printer Port Monitor MIB Verification Test
  • PrintTicket Conformance Test
  • PrintTicket Test
  • WIA Properties Test
  • WIA Transfer Test
  • WSD Print Verify
  • WSD Scan Discover
  • WSD Scan Verify
  • XPS Content Library - Discard Control Processing(MANUAL)
  • XPS Content Library - Files that violate OPC, XPS, Markup Compatibility rules(MANUAL)
  • XPS Content Library - MinBar Files(MANUAL)
  • XPS Content Library - Thumbnail Processing(MANUAL)
  • XPS Rendering
  • XPS Security


DocumentProperties Test (Unicode)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e90612e1-8a9f-4c0d-b0c5-88b06b38b912

The Document Property Test exercises the printer driver's implementation of the DocumentProperty API. The test calls the API with various data and then validates the returned values.

Test details
Specifications
  • Device.Imaging.Printer.Base.DocumentProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LAU | Logical Local User.
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test Exectuable name.
WDKPrinterName | Printer name.


GDL Correctness Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/841086ff-6142-4f1c-af69-eda544898a5b

This automated test is run by the GDLCheck tool. The tool performs a generic description language (GDL) syntax check that parses and loads GDL files, specifies configurations, obtains XML snapshots, and looks for syntax errors.

Test details
Specifications
  • Device.Imaging.Printer.Base.GDLFile
  • Device.Imaging.3DPrinter.Base.GDLFile
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

More information

This test sends all parsing errors and debug output to Gdlcheck.xml. The test processes command-line arguments from left to right. Each argument is separated from the next with a space character. You must specify all options before you specify the GDL root file name.

You can run this test tool from the Microsoft® Windows Driver Kit (WDK) or by itself from the command prompt. This tool logs results to a Windows Test Technologies (WTT) log file. You can configure the tool to log information at different verbosity levels. The tool requires the root generic printer description (GPD) or GDL file that you want to validate and any other GPD or GDL files that the root file references.

GDLCheck writes all debug output to the GDLCheck.xml file.

The syntax for this tool is as follows:

GDLCheck.exe [-Verbosity=n], where n is a number from 0 to 4 specifying the verbosity level of parser messages. Verbosity 4 is the most verbose and Verbosity 0 is the least verbose. [-Personality[=persona]] Generate Personality Aware snapshot. (To enable all personalities, use -Personality alone.) [-DisplaySynthesizedFeatures] [-GenerateSchema] (GDLschema.xsd) for XML snapshot. [-DoNotGenerateXMLSnapshot] [-DisplayOnlyStickyFeatures] [-DisplayValidatedConfiguration] [-ParserContext=n] where n is a number from 0 to 9. Initial context is 0. [-PrefaceFile=<full path to file that holds Preface>] [-DeviceConfiguration[=Feature1.Option1[:Feature2.Option2[:Feature3.Option3...]]] [-DocumentConfiguration[=Feature1.Option1[:Feature2.Option2[:Feature3.Option3...]]] (Always generates XML Snapshot.) <-PrinterName=<name of an installed printer> | GDL root file path1 [GDL root file path2...]> [-?] Display this message.

The following list describes some example GDLCheck commands:

  • GDLCheck.exe -DisplayValidatedConfiguration -DeviceConfiguration -DocumentConfiguration basic.gdl

    This command produces an XML snapshot in the GDLsnapshot.xml file by using the default device and document configurations. The basic.gdl file implements the basic features that you need to satisfy the root construct productions that the stdschem.gdl file defines. The following debug output shows an example of what occurs if you specify the -DisplayValidatedConfiguration option.

    ==== Validated Configuration ====PaperSize:LETTERResolution:Option1RESDLL:UniresDLLInputBin:UPPERIf you execute the same command with hplj5si.gdl (instead of basic.gdl), you will see the following debug output.==== Validated Configuration ====Memory:4096KBPrinterHardDisk:FALSEDuplexUnit:InstalledPageProtect:OFF==== Validated Configuration ====Memory:4096KBPrinterHardDisk:FALSEDuplexUnit:InstalledPageProtect:OFFPaperSize:LETTEROrientation:PORTRAITDuplex:NONEResolution:Option1Halftone:HT_PATSIZE_AUTORESDLL:UniresDLLOutputBin:Option1Collate:OFFStapling:Option1InputBin:Option1

  • GDLCheck.exe -GenerateSchema -DoNotGenerateXmlSnapshot basic.gdl

    This command produces the schema for the XML snapshot but not the snapshot itself. You can find the schema in the GDLschema.xsd file. This command shows the -GenerateSchema option and the -DoNotGenerateXmlSnapshot option. This option turns off snapshot creation. By default, Gdlcheck produces the XML snapshot unless you specify the -DoNotGenerateXmlSnapshot option.

  • GDLCheck.exe -PrefaceFile=preface.gdl -DisplayValidatedConfiguration -DeviceConfiguration -DocumentConfiguration basic.gdl

    This command shows how to use the -PrefaceFile option in Gdlcheck to specify a preface file. To perform this test, comment out or remove the "*Include: "stdschmx.gdl" line from the basic.gdl file because the preface.gdl file already includes this line. The result of running this command is the same as the result for the first example command.

  • GDLCheck.exe -DisplaySynthesizedFeatures -DoNotGenerateXmlSnapshot synfea.gdl

    This command shows how to use the -DisplaySynthesizedFeatures option to verify the creation of synthesized features. The following debug output shows an example of what occurs if you run this command. Note that because this command does not use the -DoNotGenerateXmlSnapshot option, the test does not create the XML snapshot.

    === Begin Contents of Synthesized Features Buffer ===*Feature: SynFea_InputBinENVFEED{*FeatureType: SYNTHESIZED_PROPERTY*Name: "Optional Envelope Feeder"*Option: NotInstalled{*Name: "Not installed"*Constraints: InputBin.ENVFEED}*Option: Installed{*Name: "Installed"}}=== End Contents of Synthesized Features Buffer ===

    Note that you do not have to use the -DoNotGenerateXmlSnapshot option if you want to use the -DisplaySynthesizedFeatures option. You can also use the following command:

    GDLCheck.exe -DisplaySynthesizedFeatures -DisplayValidatedConfiguration -DeviceConfiguration -DocumentConfiguration synfea.gdl

    This command produces the following debug output:

    === Begin Contents of Synthesized Features Buffer ===*Feature: SynFea_InputBinENVFEED{*FeatureType: SYNTHESIZED_PROPERTY*Name: "Optional Envelope Feeder"*Option: NotInstalled{*Name: "Not installed"*Constraints: InputBin.ENVFEED}*Option: Installed{*Name: "Installed"}}=== End Contents of Synthesized Features Buffer ======= Validated Configuration ====SynFea_InputBinENVFEED:NotInstalled==== Validated Configuration ====SynFea_InputBinENVFEED:NotInstalledPaperSize:LETTERResolution:Option1RESDLL:UniresDLLInputBin:UPPER

  • GDLCheck.exe -DisplayValidatedConfiguration -DeviceConfigurationMemory.8192KB:PrinterHardDisk.TRUE -cOrientation.LANDSCAPE_CC90:Resolution.Option2:PaperSize.LEGAL hplj5si.gdl

    This command shows how to use the -DeviceConfiguration and -DocumentConfiguration options to define your own device and document configurations. The following debug output shows an example of what you might see when you run this command.

    ==== Validated Configuration ====Memory:8192KBPrinterHardDisk:TRUEDuplexUnit:InstalledPageProtect:OFF==== Validated Configuration ====Memory:8192KBPrinterHardDisk:TRUEDuplexUnit:InstalledPageProtect:OFFPaperSize:LEGALOrientation:LANDSCAPE_CC90Duplex:NONEResolution:Option2Halftone:HT_PATSIZE_AUTORESDLL:UniresDLLOutputBin:Option1Collate:OFFStapling:Option1InputBin:Option1

  • You can use the -ParserContext argument in GDLCheck to validate more than one root GDL file within a single execution of GDLCheck. The following is the syntax for this command:

    GDLCheck.exe -Preface=c:\test\preface.gdl -DisplayValidatedConfiguration -DeviceConfiguration -DocumentConfiguration c:\test\basic.gdl -ParserContext=1 -Preface=c:\test\preface.gdl -DisplayValidatedConfiguration -Verbosity=1 -Personality=Persona1 -GenerateSchema -DeviceConfiguration -DocumentConfiguration c:\test\personatest.gdl

    This example also shows how to use the -Personality option to specify a personality for the generation of the personality-aware XML snapshot.

Parameters

Parameter name | Parameter description
CommandStringOptions | Command arguments.
LLU_LAU | Logical Local User.
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test Executable name.
WDKPrinterName | Printer name.


INF Syntax Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f8c935b-a57a-4e9f-a49a-d58165e7eb83

This automated test checks the syntax in INF files for printer and scanner device drivers. The INFGate tool runs this test.

Test details
Specifications
  • Device.Imaging.Printer.Base.infFile
  • Device.Imaging.Printer.Base.configurationFiles
  • Device.Imaging.Printer.Base.DriverCategory
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

In addition, if the device is using an in-box driver, you'll need to specify "/MS" for the "Inbox" parameter.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

More information

INFGate is the tool that checks syntax, format, and validity for both printing and imaging INF files. You can run the tool on an installed printer or on a stand-alone INF file. If you select an installed printer, the tool looks for an INF file for the specified printer, and then runs.

Creating valid INFs for virtual printers

Virtual printers must specify a null hardware ID. To specify a null hardware ID, in the models-section-name of the device's INF file, add a second comma between the install-section-name and the compatible-id.

[models-section-name]

device-description=install-section-name,,[compatible-id]

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test executable name.
WDKPrinterName | Printer name.
WDKDataWhqlQualification | Data WHQL Qualification.
Inbox | Put "/MS" if the printer uses an inbox driver


Mobile Print - Print Device Capabilities conformance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7eaff93-910d-4518-af57-d71c59348d39

This test attempts to verify that a WS-Print v2.0-capable printer publishes a valid PrintDeviceCapabilities.

Test details
Specifications
  • Device.Imaging.Printer.Mobile.WSD20.PDC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKWSDServiceURL | WSD Printer Service URL
WDKWSDServiceID | WSD Printer Service Id
WDKWSDDeviceID | WSD Printer Device Id


Mobile Print - Print Device Capabilities resource validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/753aeff4-56c5-4bd3-a5d5-73b92706857b

This test attempts to validate localized strings are present on the resource file requested from the device.

Test details
Specifications
  • Device.Imaging.Printer.Mobile.WSD20.PDC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKWSDServiceURL | WSD Printer Service URL
WDKWSDServiceID | WSD Printer Service Id
WDKWSDDeviceID | WSD Printer Device Id


Mobile Print - Rendering Tests (Basic)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bd94708-00e8-4361-ab49-8387e89eb9af

The Mobile Print Rendering Tests test printing to PWG-Raster, PCLm, XPS, and OXPS compatible printers. The tests produce numerous pages of output at different DPI sizes, page sizes, page orientations, page orderings, and color formats suported by the printer (as defined by the PrintDeviceCapabilities).

Test details
Specifications
  • Device.Imaging.Printer.Mobile.PDL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKWSDServiceURL | WSD Printer Service URL
WDKWSDServiceID | WSD Printer Service Id
WDKWSDDeviceID | WSD Printer Device Id


Mobile Print - Rendering Tests (Device Processed)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd90a4d6-b7e5-4ee1-aea4-84b9ff58ebba

The Mobile Print Rendering Tests test printing to PWG-Raster, PCLm, XPS, and OXPS compatible printers. The tests produce numerous pages of output at different DPI sizes, page sizes, page orientations, page orderings, and color formats suported by the printer (as defined by the PrintDeviceCapabilities).

Test details
Specifications
  • Device.Imaging.Printer.Mobile.PDL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKWSDServiceURL | WSD Printer Service URL
WDKWSDServiceID | WSD Printer Service Id
WDKWSDDeviceID | WSD Printer Device Id


Mobile Print - WSD Print V2.0 Verify

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c6bd78ec-5315-4ae5-a315-85ddd1eb8837

This test attempts to verify that a WSD V2.0 printer complies with the Print Service Definition V2.0 WDP specification.

Test details
Specifications
  • Device.Imaging.Printer.Mobile.WSD20.WSD20Support
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKWSDDeviceID | WSD V2.0 Printer Device Id
WDKWSDServiceID | WSD V2.0 Printer Service Id
WDKWSDServiceURL | WSD V2.0 Printer Service URL


OXPS Content Library - Discard Control Processing(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/70c1c9b1-2a1f-44d0-875c-29d2a4a1f0e4

Prints XPS files that use valid and invalid discard control

Test details
Specifications
  • Device.Imaging.Printer.OXPS.OXPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


OXPS Content Library - Files that violate OPC, XPS, Markup Compatibility rules(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9038c37b-71f3-4408-bcd5-8ab94f76523f

Prints OXPS files that violate OPC, XPS, Markup Compatibility rules

Test details
Specifications
  • Device.Imaging.Printer.OXPS.OXPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


OXPS Content Library - MinBar Files(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d215eabc-9e94-4ca9-a8b2-007f2402fec2

Prints valid XPS files

Test details
Specifications
  • Device.Imaging.Printer.OXPS.OXPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


OXPS Content Library - Thumbnail Processing(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22255fc9-7d32-4b71-bb24-89ec0cac004c

Prints XPS files that use valid and invalid thumbnails

Test details
Specifications
  • Device.Imaging.Printer.OXPS.OXPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


OXPS Rendering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4fd0e404-6b8f-435b-8858-2de9da518bcf

Prints various OXPS files

Test details
Specifications
  • Device.Imaging.Printer.OXPS.OXPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


OXPS Security

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17c68285-2f60-4bf1-97e2-624c8abd07c9

Prints a number of fuzzed OXPS files

Test details
Specifications
  • Device.Imaging.Printer.OXPS.OXPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


PGremlin Rendering Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc7c0cbd-6369-4073-9f40-2af64008698c

Pgremlin tests DDI calls that a driver can make. This test produces numerous pages of output with shapes and gradient fills / alpha blends. It also prints and tests some complex fonts.

Test details
Specifications
  • Device.Imaging.Printer.Base.Rendering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


PGremlin2 Rendering Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b486373-061c-449d-897d-f476b50dc782

PGremlin2 tests the basic rendering primitives of a printer driver by calling various GDI APIs to render content

Test details
Specifications
  • Device.Imaging.Printer.Base.Rendering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


Photo Print Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/64fb7691-45aa-4016-bf2a-aff784797afe

Prints a series of photos

Test details
Specifications
  • Device.Imaging.Printer.Base.Rendering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


Print Bidi Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85da7f96-de75-4b84-b950-9e44277b8fa6

Verifies that Javascript bidi extenders are implemented correctly

Test details
Specifications
  • Device.Imaging.Printer.USB.JSBidiExtender
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


Print Device Capabilities conformance (Driver)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ded78f66-a9ea-45d2-9f21-89d8ff2c87fd

This test verifies that a v4 print driver publishes a valid PrintDeviceCapabilities. It also enforces that drivers including the PWG Raster Filter provide a valid PrintDeviceCapabilities.

Test details
Specifications
  • Device.Imaging.Printer.Base.DriverPDC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Printer name


Print Driver Device Capabilities Test (PrDeviceCapabilities)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0299ff0c-69e9-4ba5-bd2c-8bf47f805c3f

This automated test queries the driver to ensure that the driver returns the correct information for the GetDeviceCapabilities API call.

The output is a XML file that is named prdevcaptest.xml. This file contains the pass or fail information. This test does not produce any output to the physical printer.

Test details
Specifications
  • Device.Imaging.Printer.Base.deviceCapabilities
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

The expected exit code is 0. The pass/fail of the job is determined by the log.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

Failure of this test can be identified if the debugger breaks in, or the log file indicate a failure.

The following are the log files for this test:

  • prdevcaps.xml

  • prdevcaps_DeviceLogger.xml

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Logical Local User: Network Access only.
WDKPrinterName | Printer name.
TestExecutable Name | Test Executable name.


Print Driver DevMode Corruptor Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/448e0c78-58ae-452a-b69d-b1f6ffc74a8c

This automated test uses good and bad DEVMODE structures to make sure that the driver gracefully handles bad data. This test is not meant to have output evaluated.

Test details
Specifications
  • Device.Imaging.Printer.Base.applicationVerifier
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Scenario
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

NOTE

This test must be run from an AppVerifier environment that has NTSD debugging enabled. The test uses the following Windows HLK library test jobs to run this test with a null port and then automatically restore the printer port:

  • Add NullPortMonitor and switch port

  • Restore port and delete NullPortMonitor

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

Failure of this test can be identified if the debugger breaks in, UI is displayed in the spooler process, the test halts for any reason or the log file indicates a failure.

The following are the log files for this test:

  • DevmodeCorrupt.xml

  • DevModeCorruptor_DeviceLogger.xml

More information

The primary way for applications and users to specify print job settings to the print subsystem is by using the DEVMODE structure. The print subsystem treats the DEVMODE structure as untrusted because the DEVMODE structure originates from outside the print subsystem. The printer drivers often access this data structure as well.

This test does not require a printer to be physically attached to the test computer. The test may be run with a null port.

The Print Driver Devmode Corruptor test tool exercises fault injection in the driver-related code paths in the print subsystem to make sure that the driver is robust enough to handle corrupted DEVMODE structures.

This test can generate large quantities of output. You can ignore and discard this output. You can also make sure that this test prints to a NULL port printer to avoid the physical output.

You can run this test manually by typing the following command at a command prompt:

DevModeCorruptW.exe /printer="&lt;printername>" /stress /Logfile=DevmodeCorrupt.xml /timetorun=4

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutable Name | Test Executable name.
WDKPrinterName | Printer name.


Print Driver Stress Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84f54ad9-f24e-486d-9300-ce8859e0d151

This automated test stresses the driver in several ways. You do not have to examine the output from this test.

NOTE

You must run this test separately from the other printer tests.

Test details
Specifications
  • Device.Imaging.Printer.Base.applicationVerifier
  • Device.Imaging.3DPrinter.Base.DriverStability
  • Device.Imaging.3DPrinter.Base.ApplicationVerifier
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Scenario
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

NOTE

This test does not require a printer to be physically attached to the test computer. You can run this test by using a null port. However, you must run this test in the Appverifier environment. You must enable the NT system debugger (NTSD).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

This test fails if any of the following problems occur:

  • The test does not produce output.

  • The debugger breaks in.

  • The test produces incorrect output.

  • The log file indicates a failure.

The following are the log files for this test:

  • Printdrvstress.xml

  • PrintDrvStress_DeviceLogger.xml

More information

This test can generate lots of output. You can ignore and discard this output.

This test exercises several driver code paths on multiple threads. This test exercises both the rendering and configuration portion of the driver. This exercise creates a stress environment for the printer drivers. The tool often reveals bugs.

Typically, this test prints to a NULL port printer to avoid large quantities of physical output.

To run this test manually, run the following command at a command prompt:

PrintDrvStress.exe /printer="&lt;printername>" /timetorun=120

This test uses the "Add NullPortMonitor and switch port" and "Restore port and delete NullPortMonitor" test jobs in the Windows HLK library to automatically run PrintDrvStress by using a null port and then to restore the printer port.

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Logical Local User: Network Access only.
LLU_LAU | Logical Local User.
TestExecutable Name | Test Executable name.
WDKPrinterName | Printer name.
3MFFile_Path | Path to 3MF file.


Print Processor API Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2eba0c55-5ab8-4aea-8c8d-642fe7f251bb

This automated test loads the print processor into its own memory space and verifies that all required interfaces are present. Furthermore, the test tries to call these interfaces to make sure that the print processor is robust.

Test details
Specifications
  • Device.Imaging.Printer.Base.printProcessor
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

WARNING

You must install all print processors on the system before you can test these processors. If you specify the print processor, the test evaluates the print processor and the default printer. If you do not install a printer, the test only evaluates whether the print processor supports the required interfaces.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

More information

The Print Processor API test calls LoadLibrary function on the specified print processor to load it into its own process. It then calls GetProcAddress on the following six required endpoints:

  • OpenPrintProcessor

  • ClosePrintProcessor

  • ControlPrintProcessor

  • EnumPrintProcessorDatatypesW

  • PrintDocumentOnPrintProcessor

  • GetPrintProcessorCapabilities

If the test cannot find one of these required endpoints, the test logs a failure.

Because print processors are capable of running many functions, it is impossible to write an automated test that can test any particular print processor. It We recommend that you test the print processor's functionality manually.

Success: The Print Processor API test passes if the rollup at the end of the log file contains no failures.

Failure: The Print Processor API test fails if the rollup at the end of the log file contains one or more failures.

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test Executable name.
WDKPrinterName | Printer name.
LLU_LAU | Logical Local User.
LLU_LSU | Logical Local User.


Printable Area Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c7a05fa-2885-40d5-8056-a8817ad7811b

This automated test verifies that a print driver can output lines to the outer edge of the printable area.

Test details
Specifications
  • Device.Imaging.Printer.Base.printRegions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

This test fails if any of the following problems occur:

  • The test does not produce output.

  • The debugger breaks in.

  • The test produces incorrect output.

  • The paper size measurements are incorrect

  • The log file indicates a failure.

NOTE

Paper and print location measurements can vary by one-sixteenth (1/16) of an inch.

More information

The Printable Area test generates two single sheets, a portrait sheet and a landscape sheet). You should run this test on different paper sizes, such as A4, Letter, Envelope 10, and A5.

Check the following points in the print area test:

  • Four separate lines are drawn. Each one runs beyond the clipped region. (Each one must be 2 inches larger than the HORZRES and VERTRES properties produce).

  • Diagonals are drawn in this rectangle to identify the page center and to facilitate debugging if the reported printable region is incorrect.

  • A second rectangle is drawn to be 1 inch from the physical edge of the page.

  • A 2-inch square is centered horizontally on the page, 1 inch from the top printable region.

  • A line of text is added to indicate the paper size and page orientation and should be centered on the page's printable area.

Parameters

Parameter name | Parameter description
LLU_LAU | Logical Local User.
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test Executable name.
WDKPrinterName | Printer name.


Printer CompatibleID Test - USB

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f96d946b-f0b9-4886-aa13-aab6de13a899

Verifies that the device has a IEEE1284 CompatibileID

Test details
Specifications
  • Device.Imaging.Printer.USB.CompatID
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
EnumAll | For debugging failures only. This will enumerate all devnodes using the enumerator for the test(SWD for WSD or USBPRINT)
WDKPrinterName | Name of Printer


Printer CompatibleID Test - WSD

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d48e54b-bddf-444d-9bef-ea36d888bf40

Verifies that the device has a IEEE1284 CompatibileID

Test details
Specifications
  • Device.Imaging.Printer.WSD.CompatID
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
EnumAll | For debugging failures only. This will enumerate all devnodes using the enumerator for the test(SWD for WSD or USBPRINT)
WDKPrinterName | Name of Printer


Printer Port Monitor MIB Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d992ff6e-f739-4523-ae89-ea761c266111

This automated test verifies that a TCP/IP printer supports the Printer Port Monitor Management Information Base (MIB) 1.0. This test tool also verifies that the printer supports the minimum components of the Host Resources MIB and Printer MIB that the Standard TCP/IP Port Monitor requires.

Test details
Specifications
  • Device.Imaging.Printer.Base.TCPMon
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

More information

This test performs Simple Network Management Protocol (SNMP) queries on the device that you want to test. This test verifies that the device supports the minimum components of the Host Resources MIB and the Printer MIB that the Standard TCP/IP Port Monitor uses to query device status. This test also verifies that the device supports the Printer Port Monitor MIB that is required for port installation and configuration by the Standard TCP/IP Port Monitor.

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Logical Local User: Network Access only.
LLU_LAU | Logical Local User.
TestExecutableName | Test Executable name.
WDKPrinterName | Printer name.


PrintTicket Conformance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0f44f97-6884-4d9a-a875-dd522de1df01

This automated test uses a conformance tool (PTConform.exe) that verifies the validity of PrintTicket and PrintCapabilities documents. PTConform verifies that a particular PrintTicket and PrintCapabilities API syntactically and structurally conforms to the public PrintSchema specification.

The PrintSchema specification describes an XML-based format for expressing and organizing a large set of properties that describe either a job format or capabilities of a print queue in a hierarchically structured manner. The PrintSchema specification has well-defined public framework elements and public keywords.

The PTConform test tool treads through an XML document and tests each node to make sure that the node is a valid public framework element. After the test verifies the framework element, the test determines whether the framework element defines any public keyword element. If so, the test determines whether the keyword conforms to the PrintSchema specification.

NOTE

If a framework node contains a printer driver's private namespace keyword instead of a public keyword, the test skips keyword validation for that node.

Test details
Specifications
  • Device.Imaging.Printer.Base.printTicket
  • Device.Imaging.3DPrinter.Base.PrintTicket
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

NOTE

The results of the test are logged in the PTConform.log or PTConform.xml log file depending on the log type that the command-line parameters specify.

More information

Parameters

Parameter name | Parameter description
LLU_LAU | Logical Local User.
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test Executable name.
WDKPrinterName | Printer name.


PrintTicket Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59c36ef2-9ec8-494e-bbaa-8fed2dacd376

This automated test exercises the unmanaged PrintTicket and PrintCapabilties APIs that are part of Windows Vista and newer version of Windows.

If you have the Windows Driver Kit (WDK) test suite at the command line, the test tool sequentially runs the test cases that the TestSuite.xml file mentions. For the WDK test suite, the test cases call all of the native PrintTicket and PrintCapabilities APIs sequentially by using valid input parameters and expect valid output.

You can use this test to evaluate:

  • A driver's implementation of the PrintTicket and PrintCapabilities COM callable interface: IPrintTicketProvider.

  • A driver plugin's implementation of the PrintTicket and PrintCapabilities COM callable interface: IPrintOEMPrintTicketProvider.

  • A legacy driver's PrintTicket and PrintCapabilities shim layer. You can test the PrintTicket and PrintCapabilities API calls for legacy printers that do not support the IPrintTicketProvider interface.

Test details
Specifications
  • Device.Imaging.Printer.Base.printTicket
  • Device.Imaging.3DPrinter.Base.PrintTicket
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Printer Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing.

WARNING

Any attempt to change the system default printer while the test is running might lead to inconsistent results.

More information

Parameters

Parameter name | Parameter description
LLU_LAU | Logical Local User.
LLU_NetAccessOnly | Logical Local User: Network Access only.
TestExecutableName | Test Executable name.
WDKPrinterName | Printer name.


WIA Properties Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16ebf42b-f403-4cc7-bdb2-9ed1b2341841

This automated test uses the Windows Image Acquisition (WIA) test tool to verify that all WIA properties for pre-Vista style drivers are implemented according to the Windows Driver Kit (WDK) and Windows Vista Logo requirements. It also verifies that the structure of the WIA item tree that is built by a pre-Vista scanner driver is correct.

This test will help driver developers to detect property errors and item tree implementation errors.

NOTE

WIA 2.0 is a requirement for the test to pass in Windows 8, Windows 7, Windows Server 2008 R2 and Windows Server 2012. WIA 2.0 is not a requirement for Windows Vista.

Test details
Specifications
  • Device.Imaging.Scanner.Base.wia20
  • Device.Imaging.Scanner.Base.dataTransfer
  • Device.Imaging.Scanner.Base.WIAProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Scanner Testing Prerequisites.

If your device supports automatic document feeding, this test requires the following:

  • Enough paper in the feeder (usually about 50 pages).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing

If failure is reported somewhere in the middle of a large log file, try to determine which test script caused it. Then run this script by itself, without combining it with other tests. For example:

WiaTreeProperties.exe -r scripts\DPA\DPA_DEVICE_TIME.wia -debug -w

If the test crashes, try running WiaTreeProperties.exe from a command prompt under a debugger to determine the reason for the crash.

The UseDebugLogs parameter should only be used if the test is failing and Microsoft Support Services asks you to use this parameter.

More information

This tool uses information stored in an XML file and test scripts to verify the correct implementation of WIA Properties. Each WIA property defined in Windows SDK and WDK documentation has the following attributes:

  • Data type

  • Access type

  • Required items

  • Optional items

  • Legal values (list or range)

  • Dependencies on other properties

The tool consists of a test application, an XML file listing all properties, and one test script per property. The test application allows a tested property or set of properties to be specified through command line parameters, reads property test scripts and XML data, and compares the results to the property implementation in a WIA Driver. The test fails if the expected property attributes and implemented property attributes do not match. The test succeeds if all tested properties are implemented according to WDK requirements.

This tool includes:

  • Console test application WiaTreeProperties.exe - supports multiple command line parameters. The console test application also exports test information to a WTT log file, console, and custom log window (optional).

  • GUI application WiaTreePropertiesGUI.exe - collects test parameters through UI and runs WiaTreeProperties.exe to perform testing.

  • WiaTestLog.exe - custom log window, which may be used for displaying test output. See the -w command switch.

  • WiaPropDB.dll - managed assembly for reading WIA Properties. The XML database is stored in WiaTreeProp.xml file

  • *.wis files - test suites (groups of test scripts)

  • *.wia files - test scripts, used by WiaTreeProperties.exe application

Running WIA Tree Properties test

WIA tests may fail if you do not use the WIA Friendly name. To resolve this, follow these steps:

  1. Restart the DTM Client and wait for it to log in.

  2. Close the Device Console.

  3. Re-open the submission.

This will ensure that the gatherer data is in-sync and that the friendly name is populated.

If the steps above do not work, please work with your driver developer to make sure that the INF is referencing the driver correctly.

Parameters

Parameter name | Parameter description
LLU_LclAdmin.DomUsr | LLU_LclAdmin.DomUsr
LLU_NetAccessOnly | LLU_NetAccessOnly


WIA Transfer Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/46e93150-b456-4aaa-a02a-09a93f32fe93

This manual test is initiated by the Windows Image Acquisition (WIA) Data Transfer tool, which is an automated Windows Driver Kit tool for testing the behavior of WIA minidrivers that are related to data transfer.

The test tool verifies that a driver does not cause applications or the WIA service to crash or hang during data transfer. It also verifies that the correct behavior is implemented by the driver for different configurations, sequences of actions, and errors that may occur during transfer. This tool ensures that there is no ambiguity in the driver's behavior in these scenarios. This improves compatibility between all WIA drivers and WIA applications.

Test details
Specifications
  • Device.Imaging.Scanner.Base.dataTransfer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Scanner Testing Prerequisites.

Before running this test the Wdk\ConfigureScanner dimension must be added to the computer pool. To do add the dimension to the computer pool, complete the following steps:

  1. From the Windows Certification Test Kit Studio, open the Job Monitor.

  2. Select the computer pool containing the test computer that the test scanner is attached to.

  3. Right-click the computer pool to open the properties page, and then select the MCU Policy tab.

  4. From the available dimension list select Wdk\ConfigureScanner, add it to the machine pool and then click Ok.

In addition, if your device supports automatic document feeding, this test requires the following:

  • Enough paper in the feeder (usually about 50 pages).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing

For test failures, search for the term "+sev" in the log.

The test executable supports verbose logging. Use the /verboselog:1 command-line option when running the test to enable verbose logging. Detailed logging is recorded in a WTT log file.

More information

The WIA Data Transfer tool runs either from the WDK or from the command line. It logs results to the console and to a WTT log file, and can be configured to log at two different levels of verbosity. By default, it runs all test cases but individual test cases can be specified as well.

WIA 2.0 is a requirement for the test to pass in Windows 7 and Windows 2008 R2. WIA 2.0 is not a requirement for Windows Vista

To set up this tool manually, follow these steps:

  1. Install the WIA device to be tested.

  2. Register WiaTestLog.dll using RegSvr32

  3. Run the WiaTransfer Tool from a command prompt.

NOTE

WIA tests may fail if you do not use the WIA Friendly name. To resolve this, follow these steps:

  1. Restart the Windows HLK Client and wait for it to log in.

  2. Close the Device Console.

  3. Re-open the submission.

This will ensure that the gatherer data is in-sync and that the friendly name is populated.

If the steps above do not work, please work with your driver developer to make sure that the INF is referencing the driver correctly.

Parameters

Parameter name | Parameter description
LLU_LclAdmin.DomUsr | LLU_LclAdmin.DomUsr
LLU_NetAccessOnly | LLU_NetAccessOnly


WSD Print Verify

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87d00dc6-7c9c-4de2-9203-4a1304d00498

This test attempts to verify that a WSD printer complies with the WDP specification.

Test details
Specifications
  • Device.Imaging.Printer.WSD.WSPrint
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer
Timeout | WS-Event Timeout Value in Minutes


WSD Scan Discover

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0cbb5c67-6f41-460d-846e-210bf2163921

This automated test verifies that a Web Services on Devices (WSD) scan device responds to "Probe" and "Resolve" multi-cast Web Services for Scanner (WS-Scan)-Discovery messages according to the Device Profile for Web Services protocol document. The "Probe" filters on the ScanDeviceType and the "Resolve" message filters on the Device UUID.

NOTE

For WS-Discovery details, visit WS-Discovery Specification Compliance. For WS-Scan details, visit Scan Service (WS-Scan) Schema.

The test first performs the "Probe" WS-Discovery operation filtered by ScanDeviceType. The second and final test is the "Resolve" WS-Discovery operation based on the device WSD ID. Both test cases will timeout if the device does not respond within 60 seconds.

Test details
Specifications
  • Device.Imaging.Scanner.WSD.WSScan
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Scanner Testing Prerequisites.

In addition, this test requires the following:

  • For versions of Windows Server, the "Desktop Experience" Feature must be installed.

  • The "Network Discovery" firewall exception must be enabled on the test host.

WARNING

The device must be on the same subnet as the test host. It does not have to be installed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing

Multicast network traces will be needed to determine the root cause of any failures.

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LUA Local Admin User
LLU_NetAccessOnly | LUA Network Access Only User
WDKData_WSDID | Device UUID (i.e. urn:uuid:11111111-2222-3333-4444-555555555555)


WSD Scan Verify

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac904c9d-4117-4d89-ae72-476aa618255c

This manual test verifies that a Web Services on Devices (WSD) scan device complies with the Web Services for Scanner (WS-Scan) Protocol. Specifically it verifies that the device being tested supports WS-Scan events and operations.

NOTE

For WS-Discovery details, visit WS-Discovery Specification Compliance. For WS-Scan details, visit Scan Service (WS-Scan) Schema.

The test directly communicates with the device over the WS-Scan protocol. It will create the web service connection and then subscribe for WS-Scan Events and attempt WS-Scan Operations. It will also pull scan jobs from the device whether or not they have an active event subscription.

Test details
Specifications
  • Device.Imaging.Scanner.WSD.WSScan
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Scanner Testing Prerequisites.

In addition, this test requires the following:

  • For versions of Windows Server, the "Desktop Experience" Feature must be installed.

  • The "Network Discovery" firewall exception must be enabled on the test host.

WARNING

The device must be on the same subnet as the test host. It does not have to be installed. If the device only has a document feeder, make sure it is loaded with a document that can be scanned.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Imaging Testing

The test can trace the HTTP SOAP messages sent between the device and the test. To generate a trace file, edit the file named "WsdScanVerify.exe.config" in a text editor.

Modify this line in the file:

<MessageTrace TraceDestination="None"/>

The config file contains details on how to set the "TraceDestination" value.

If the test is not logging HTTP SOAP messages, the next step is to perform a network trace between the test host and the device to debug the HTTP connection.

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LUA Local Admin User
LLU_NetAccessOnly | LUA Network Access Only User
WDKData_HostName | Device Hostname or Discovery URL


XPS Content Library - Discard Control Processing(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54dad7f5-bf21-406f-a262-0a04833c363d

Prints XPS files that use valid and invalid discard control

Test details
Specifications
  • Device.Imaging.Printer.XPS.XPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


XPS Content Library - Files that violate OPC, XPS, Markup Compatibility rules(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9e7cb5f-6a6f-4c3f-86c1-f26b147919de

Prints XPS files that violate OPC, XPS, Markup Compatibility rules

Test details
Specifications
  • Device.Imaging.Printer.XPS.XPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


XPS Content Library - MinBar Files(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3855eedb-fa63-4d0b-a0a1-c0c49f01807b

Prints valid XPS files

Test details
Specifications
  • Device.Imaging.Printer.XPS.XPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


XPS Content Library - Thumbnail Processing(MANUAL)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8ed81b6-23f4-4e3d-b52e-6d22b31ac43b

Prints XPS files that use valid and invalid thumbnails

Test details
Specifications
  • Device.Imaging.Printer.XPS.XPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


XPS Rendering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1bd7990-beec-48a4-88de-520c35bbc085

Prints various XPS files

Test details
Specifications
  • Device.Imaging.Printer.XPS.XPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


XPS Security

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/60533596-64d7-4654-b9e1-56cd7dbe5752

Prints a number of fuzzed XPS files

Test details
Specifications
  • Device.Imaging.Printer.XPS.XPS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Imaging additional documentation

More information

Parameters

Parameter name | Parameter description
WDKPrinterName | Name of Printer


Device.Imaging additional documentation

In this section

  • Printer Testing Prerequisites
  • Scanner Testing Prerequisites
  • Web Services on Devices Testing Prerequisites
  • Troubleshooting Device.Imaging Testing


Printer Testing Prerequisites

This section describes the tasks that you must complete before you test a printer by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for printer testing. Additional hardware may be required if the test device provides bus-specific support. See the test description for each bus-specific test to determine whether there are additional hardware requirements.

  • Basic Windows HLK test setup (Controller and Studio). See Windows HLK Getting Started.

  • One test computer.

    NOTE

    All computers must meet the Windows HLK requirements. If two test computers are required, both computers must be in the same computer pool. For more information, see Windows HLK Prerequisites.

    For testing networking capabilities, the test computer that the scanner is physically attached to is referred to as the System Under Test (SUT) and the other computer is referred to as the support computer.

  • One test printer.

  • One wireless network card that supports SoftAP (for example, a D-Link WDA-1320 Desktop Adapter) and a Wireless router if the test printer includes wireless networking capabilities.

  • One stand-alone network adapter (if the test computer does not include an integrated network adapter) and an Ethernet hub or switch if the test scanner includes network printing capabilities.

  • One USB cable and one USB 3.0 hub for testing printers that support USB 3.0; or a USB 2.0 hub for testing a printer that supports USB 2.0

  • Printer paper.

Other hardware may be required to enable certain scenarios.

  • Kernel Debugger system attached to the Windows HLK client.

  • Print server to test print server configurations.

NOTE

Testing a device for Server Device certification requires that the system that is being used to test the device supports four processors and a minimum of 1 GB of RAM. These system capabilities are required for testing the device and driver for their Rebalance, D3 State and Multiple Processor Group functionality. You do not need a computer that has more than 64 processors to test your device.

If a pool of test computers is used to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and driver that is being tested. As long as the driver is the same on all computers in the pool, the test will be created to run against all computers.

For those tests that do not include a driver to test, such as testing a hard drive, the Windows HLK scheduler will require the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default computer. This computer should also be manually configured to have multiple processor groups. The default computer is the first computer listed. Test personnel, in this case, should ensure that this first computer meets these minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), physical devices and their associated drivers being tested for a server certification or signature may not be tested in virtual machines using any form of virtualization. This is because not all virtualization products support the underlying functionality needed to pass the tests relating to Multiple Processor Groups, Device Power Management, Device PCI functionality, and so on.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

Install the operating system on the client systems before the final test passes to ensure that the system is in a known good state.

The following software is required to run the printer tests:

  • The driver package that is being tested on the client system.

  • The AppVerifier application.

  • The Windows .NET Framework 4.0 for computers with Windows Server 2008 R2 installed. This ensures that the tests run correctly.

    NOTE

    Both AppVerifier and the .NET Framework are installed during the Windows HLK client application installation.

Device configuration

To configure the test device for HLK testing, follow these steps:

  1. Stage the driver you want like to use for testing to the driver store.

  2. Use Plug and Play to install the device on the test machine.

  3. Confirm that the driver you want to test was installed automatically.

If the driver you want to use for testing was not installed, follow these steps:

  1. Select the printer in Device and Printers.

  2. Right-click the printer and select Printer Properties.

  3. Select the Advanced tab.

  4. Under Driver, select the driver you want to test.

For the print tests to run properly, the queue must have plug and play data populated. Do not manually create a new queue using the same port and the driver.

Test computer configuration

To configure the test computer for printer testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computer.

  2. Configure the test computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  3. Connect the SUT and the support computer to an Ethernet switch or hub to test wired networking capabilities of your printer. Connect a wireless router to the support computer to test wireless capabilities.

  4. Install the manufacturer-supplied device driver on the test computer, if the device requires one that is not included with Windows.

  5. Attach the test printer to the test computer using a USB cable.

  6. Check that the printer functions properly on the test computer.

  7. Install the Windows HLK client application on the test computer.

  8. Create a computer pool and move the test computers to that pool by using Windows HLK Studio.

Make sure that the test computers are in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

If a device supports multiple connectivity methods, you can either test each individual connectivity, or run them all at one time. Each connectivity will run all of the print features, and are separate from each other.


Scanner Testing Prerequisites

This section describes the tasks that you must complete before you test a scanner by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test system configuration.

Hardware requirements

The following hardware is required for scanner testing. Additional hardware may be required if the test device provides bus-specific support. See the test description for each bus-specific test to determine whether there are additional hardware requirements.

  • Basic Windows HLK test setup (Controller and Studio). See Windows HLK Getting Started

  • One test computer.

    NOTE

    All computers must meet the Windows HLK requirements. If two test computers are required, both computers must be in the same computer pool. For more information, see Windows HLK Prerequisites.

    For testing networking capabilities, the test computer that the scanner is physically attached to is referred to as the System Under Test (SUT) and the other computer is referred to as the support computer.

  • The test scanner

  • One standalone wireless network adapter that supports SoftAP (for example, a D-Link WDA-1320 Desktop Adapter), and a Wireless router if the test scanner includes wireless networking capabilities.

  • One stand-alone network adapter (if the test computer does not include an integrated network adapter) and an Ethernet hub or switch if the test scanner includes network scanning capabilities.

  • One USB cable and one USB 3.0 hub for testing scanners that support USB 3.0; or a USB 2.0 hub for testing a scanner that supports USB 2.0

NOTE

Testing a device to obtain Server Device certification requires that the system being used to test the device supports four processors and a minimum of 1 GB of RAM. These system capabilities are required for testing the device and driver for their Rebalance, D3 State and Multiple Processor Group functionality. You do not need a computer that actually has more than 64 processors to test your device.

If a pool of test computers is used to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and driver being tested. As long as the driver is the same on all computers in the pool, the schedule will be created to run against all computers.

For those tests that do not include a driver to test, such as testing a hard drive, the Windows HLK scheduler will constrain the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default computer. This computer should also be manually configured to have multiple processor groups. The default computer is the first one listed. Test personnel, in this case, should ensure that this first computer meets these minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), physical devices and their associated drivers being tested for a server logo or signature may not be tested in virtual machines using any form of virtualization. This is because not all virtualization products support the underlying functionality needed to pass the tests relating to Multiple Processor Groups, Device Power Management, Device PCI functionality, and so on.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

It is good practice to clean-install the operating system on client systems before final test passes to ensure that the system is in a known clean state.

The following software is required to run the scanner tests:

  • The AppVerifier application.

    NOTE

    AppVerifier is installed during the Windows HLK client application installation.

  • The driver package being tested installed on a client system

  • Desktop Experience, for computers with Windows Server 2008 R2 installed. Desktop Experience ensures that the scanner tests run correctly. Run the following command from the command prompt to install Desktop experience: ocsetup.exe DesktopExperience /quiet /norestart

Test system configuration

To configure the test computer for scanner testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computer.

  2. Configure the test computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  3. Connect the SUT and the support computer to an Ethernet switch or hub to test wired networking capabilities of your scanner. Connect a wireless router to the support computer to test wireless capabilities.

  4. Install the manufacturer-supplied device driver on the test computer, if the device requires one that is not included with Windows.

  5. Attach the test scanner to the test computer using a USB cable.

  6. Check that the scanner functions properly on the test computer.

  7. Install the Windows HLK client application on the test computer.

  8. Create a computer pool and move the test computers to that pool by using Windows HLK Studio.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Web Services on Devices Testing Prerequisites

This section describes the tasks that you must complete before you test a Web Services on Devices (WSD)-compliant device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing WSD compliance. Additional hardware may be required if the test device provides bus-specific support. See the test description for each bus-specific test to determine whether there are additional hardware requirements.

  • Basic Windows HLK test setup (Controller and Studio). See Windows HLK Getting Started.

  • Two test computers. For testing networking capabilities, the computer that the WDS-compliant device test device is physically attached to is referred to as the System Under Test (SUT) computer and the other computer is referred to as the support computer.

    NOTE

    All computers must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • One WDS-compliant device to be tested.

  • One wireless network card that supports SoftAP (for example, a D-Link WDA-1320 Desktop Adapter) and a Wireless router if the test printer includes wireless networking capabilities.

  • One stand-alone network adapter (if the test computer does not include an integrated network adapter) and an Ethernet hub or switch if the test scanner includes network printing capabilities.

  • One USB cable and one USB 3.0 hub for testing a device that includes support for USB 3.0 or a USB 2.0 hub for testing a device that supports USB 2.0.

NOTE

Testing a device for Server Device certification requires that the system that is being used to test the device supports four processors and a minimum of 1 GB of RAM. These system capabilities are required for testing the device and driver for their Rebalance, D3 State and Multiple Processor Group functionality. You do not need a computer that has more than 64 processors to test your device.

If a pool of test computers is used to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and driver that is being tested. As long as the driver is the same on all computers in the pool, the test will be created to run against all computers.

For those tests that do not include a driver to test, such as testing a hard disk drive, the Windows HLK scheduler will require the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default computer. This computer should also be manually configured to have multiple processor groups. The default computer is the first computer listed. Test personnel, in this case, should ensure that this first computer meets these minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), physical devices and their associated drivers being tested for a server certification or signature may not be tested in virtual machines using any form of virtualization. This is because not all virtualization products support the underlying functionality that is required to pass the tests that relate to Multiple Processor Groups, Device Power Management, Device PCI functionality, and so on.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required to run the WSD tests:

  • The driver for the test device if the device does not include an inbox driver.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for WSD testing, follow these steps:

  1. Install the appropriate Windows operating system on the test computers.

  2. Configure the computers for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  3. Connect both the SUT and the support computer to an Ethernet switch or hub to test wired networking capabilities of your WSD-compliant test device. Connect a wireless router to the support computer to test wireless capabilities.

  4. Attach the WSD-compliant test device to the SUT using a USB cable.

  5. Install the manufacturer-supplied device driver, if you have to, on the test computer.

  6. Check that the WSD-compliant test device is visible from Device Manager on the SUT.

  7. Install the Windows HLK client application on the SUT.

  8. Create a machine pool by using Windows HLK Studio and move both the SUT and the support computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the appropriate test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WSD testing on WSD print and scan devices

PnPX and Vertical Pairing features are required for WSD devices. If you are testing your device over Ethernet, you need to manually add the Device.Connectivity.PnPX feature. If you are testing your device over WiFi, you need to manually add the Device.Connectivity.VerticalPairing feature.

To manually add a feature, follow these steps:

  1. In the HLK Client, choose the Selection tab.

  2. Select Show Selected in the left-hand menu.

  3. Right-click a selected devnode, and then select Show Features.

  4. Select the Device.Connectivity.PnPX or Device.Connectivity.VerticalPairing feature.


Troubleshooting Device.Imaging Testing

To troubleshoot issues that occur with Device.imaging tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review one of the following topics, depending on whether you are testing a printer or a scanner

    • Printer Testing Prerequisites

    • Scanner Testing Prerequisites

    • Web Services on Devices Testing Prerequisites

  3. Review the Windows HLK release notes for current test issues.

  4. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Specific printer test information

When testing your printer over TCP/IP, if the Device.Imaging.Printer.Base feature is not being detected, you may need to go to the Device Manager view under Selection and manually select all of the devnodes that correspond to the print device.

Related topics

Device.Imaging Tests

Troubleshooting Windows HLK


Device.Input

In this section

  • Device.Input tests
  • Device.Input additional documentation


Device.Input tests

  • Acceleroemter Thresholds Verification Test
  • Accelerometer Data Field Properties Verification Test
  • Accelerometer DriverFramework Validation
  • Accelerometer Sensor Data Fields Verification Test
  • Accelerometer minimum report interval verification tests
  • Activity Sensor Data Fields Verification Test
  • Activity Sensor Thresholds Verification Test
  • Activity sensor minimum report interval verification tests
  • ActivitySensor DriverFramework Validation
  • Ambient Light Sensor Thresholds Verification Test
  • Ambient light sensor minimum report interval verification tests
  • Barometer DriverFramework Validation
  • Barometer Sensor Data Field Properties Verification Test
  • Barometer Sensor Data Fields Verification Test
  • Barometer Thresholds Verification Test
  • Check smart card services (SC Reader LOGO)
  • Common data field verification tests
  • Custom Properties Verification Test for All Sensors
  • Custom Sensor DriverFramework Validation
  • DDSI Validation Test
  • Fingerprint Reader Logo Tests
  • Geomagnetic Orientation Sensor Data Fields Verification Test
  • Geomagnetic Orientation Sensor Thresholds Verification Test
  • Geomagnetic orientation sensor minimum report interval verification tests
  • GeomagneticOrientationSensor DriverFramework Validation
  • Gravity Vector Sensor Thresholds Verification Test
  • GravityVector Orientation Sensor Data Fields Verification Test
  • Gyrometer Data Field Properties Verification Test
  • Gyrometer DriverFramework Validation
  • Gyrometer Sensor Data Fields Verification Test
  • Gyrometer Thresholds Verification Test
  • Gyrometer minimum report interval verification tests
  • Ifdtest2 Part D (SC Reader LOGO) - (Manual Test)
  • Ifdtest2 Part E (SC Reader LOGO) - (Manual Test)
  • Ifdtest2 Part F (SC Reader LOGO) - (Manual Test)
  • Ifdtest2 Parts A B & C (SC Reader LOGO) - (Manual Test)
  • Inclinometer DriverFramework Validation
  • Light Sensor Data Field Properties Verification Test
  • Light Sensor Data Fields Verification Test
  • LightSensor DriverFramework Validation
  • Linear Accelerometer Sensor Data Fields Verification Test
  • Linear Accelerometer Thresholds Verification Test
  • Magnetometer Data Field Properties Verification Test
  • Magnetometer DriverFramework Validation
  • Magnetometer Sensor Data Fields Verification Test
  • Magnetometer Thresholds Verification Test
  • Magnetometer minimum report interval verification tests
  • Orientation Sensor Data Fields Verification Test
  • Orientation Sensor Thresholds Verification Test
  • Orientation sensor minimum report interval verification tests
  • Pedometer DriverFramework Validation
  • Pedometer Sensor Data Field Properties Verification Test
  • Pedometer Sensor Data Fields Verification Test
  • Pedometer Thresholds Verification Test
  • Pedometer minimum report interval verification tests
  • PenBufferingTest
  • PenContactAccuracyTest
  • PenCustomGesturesTest
  • PenDownLatencyTest
  • PenEdgeGutterTest
  • PenEraserTest
  • PenGhostReportingTest
  • PenHoverAccuracyTest
  • PenHoverRangeTest
  • PenHoverStationaryJitterTest
  • PenMoveLatencyTest
  • PenMovingJitterTest
  • PenPhysicalDimensionsTest
  • PenPressureLevelsTest
  • PenPressureMotionTest
  • PenResolutionTest
  • PenStationaryJitterTest
  • PenThirdPartyDriverTest
  • Proximity Sensor Data Field Properties Verification Test
  • Proximity Sensor Data Fields Verification Test
  • ProximitySensor DriverFramework Validation
  • Relative Orientation Sensor Data Fields Verification Test
  • Relative Orientation Sensor Thresholds Verification Test
  • Relative orientation sensor minimum report interval verification tests
  • Sensor HID Firmware Test
  • Sensor Location Data Report
  • Sensor Minimum Supported Data Fields
  • Sensor Required Location Data Fields
  • Sensor Required Properties
  • Sensor Required Static Properties
  • Sensor State Transition verification test
  • SimpleDeviceOrientation Sensor Data Fields Verification Test
  • Smart Card Minidriver Certification Test
  • Test.Aliasing
  • Test.AllAreas
  • Test.AudioTouch
  • Test.Buffering
  • Test.Confidence
  • Test.ConvergeDivergeDiagonal
  • Test.DeviceButton
  • Test.DeviceClickPressure
  • Test.DeviceHeight
  • Test.DeviceType
  • Test.DeviceWidth
  • Test.ExternalButtons
  • Test.GhostReporting
  • Test.InputResolution
  • Test.LinearityDiagonal
  • Test.LinearityDiagonalMultiple
  • Test.MinMaxContacts
  • Test.PositionalAccuracy
  • Test.PositionalAccuracyManual
  • Test.PowerStateReliability
  • Test.Pressure
  • Test.PTPHQA
  • Test.ReportRate
  • Test.ReportRateMultiple
  • Test.RightClickReliability
  • Test.SelectiveReporting
  • Test.StaticValidation
  • Test.StationaryJitter
  • Test.StationaryJitterMultiple
  • Test.StepMotor
  • Test.ZHeight
  • TestAgnssInjection
  • TestAgnssInjection_InjectEphemeris
  • TestAgnssInjection_InjectFakeEphemeris
  • TestAgnssInjection_InjectFakePosition
  • TestAgnssInjection_InjectFakeTime
  • TestAgnssInjection_InjectPosition
  • TestAgnssInjection_InjectTime
  • TestCapabilityAndPlatformTest
  • TestDriverCommandBasic
  • TestErraticIrpTest
  • TestGeofenceBasicTest
  • TestGeofenceBasicTest_CheckMaxGeofencesSupported
  • TestGeofenceBasicTest_Iterations
  • TestGeofenceBasicTest_ZeroRadius
  • TestGeofenceTrackTest
  • TestGeofenceTrackTest_AddMultipleGeofences
  • TestGeofenceTrackTest_AddMultipleGeofencesIterations
  • TestGeofenceTrackTest_ExitEvent
  • TestGeofenceTrackTest_ExitEventIterations
  • TestGeofenceTrackTest_Iterations
  • TestGeofenceTrackTest_MultipleExitEvents
  • TestGeofenceTrackTest_MultipleExitEventsIterations
  • TestGeofenceTrackTest_PurgeMultipleGeofences
  • TestGeofenceTrackTest_PurgeMultipleGeofencesIterations
  • TestGNSSBasicStartFix
  • TestGNSSBasicStartFix_ColdStateAndDisallowAgnss
  • TestGNSSBasicStartFix_SetEngineCold
  • TestGNSSBasicStartFix_WithAgnssInjection
  • TestGnssMultiSession
  • TestModifyFixSession
  • TestSuplConfTest_v1
  • TestSuplConfTest_v2
  • TestV2UplFqdnConfTest
  • TestV2UplIpConfTest
  • WinBio API Presence Tests
  • WinRT Accelerometer Batching GetCurrentReading
  • WinRT Accelerometer Batching ReadingChanged
  • WinRT Accelerometer Batching TwoClients
  • WinRT Accelerometer InitialSample
  • WinRT Accelerometer MultiThread Batching
  • WinRT Activity InitialSample
  • WinRT Barometer InitialSample
  • WinRT Custom InitialSample
  • WinRT GeomagneticOrientationSensor GetCurrentReading
  • WinRT GeomagneticOrientationSensor ReadingChanged
  • WinRT GravityVector GetCurrentReading
  • WinRT GravityVector ReadingChanged
  • WinRT Gyrometer InitialSample
  • WinRT LightSensor InitialSample
  • WinRT LinearAccelerometer GetCurrentReading
  • WinRT LinearAccelerometer ReadingChanged
  • WinRT Magnetometer InitialSample
  • WinRT OrientationSensor InitialSample
  • WinRT Pedometer InitialSample
  • WinRT Proximity InitialSample
  • Windows Hid Validation Test
  • Windows Touch Buffering Test
  • Windows Touch Digitizer Jitter Test - Five Contacts
  • Windows Touch Digitizer Jitter Test - One Contact
  • Windows Touch Five Point Minimum Test
  • Windows Touch Input Separation Test
  • Windows Touch Noise Suppression Test
  • Windows Touch Physical Input Position Test
  • Windows Touch Reporting Rate Test - Five Contacts
  • Windows Touch Reporting Rate Test - Maximum Contacts
  • Windows Touch Reporting Rate Test - One Contact
  • Windows Touch Resolution Test
  • Windows Touch Response Latency (Down) Test
  • Windows Touch Response Latency (Panning) Test
  • Windows Touch Test
  • Windows Touch Ux Test
  • WinRT Accelerometer GetCurrentReading
  • WinRT Accelerometer ReadingChanged
  • WinRT Activity ActivitySensorTriggerActivation
  • WinRT Activity FromIdAsync
  • WinRT Activity GetCurrentReadingAsync
  • WinRT Activity GetSystemHistoryAsync
  • WinRT Activity GetSystemHistoryWithDurationAsync
  • WinRT Activity ReadingChanged
  • WinRT Barometer GetCurrentReading
  • WinRT Barometer ReadingChanged
  • WinRT Compass GetCurrentReading
  • WinRT Compass ReadingChanged
  • WinRT Custom GetCurrentReading
  • WinRT Custom ReadingChanged
  • WinRT Gyrometer GetCurrentReading
  • WinRT Gyrometer ReadingChanged
  • WinRT Inclinometer GetCurrentReading
  • WinRT Inclinometer ReadingChanged
  • WinRT LightSensor GetCurrentReading
  • WinRT LightSensor ReadingChanged
  • WinRT Magnetometer GetCurrentReading
  • WinRT Magnetometer ReadingChanged
  • WinRT OrientationSensor GetCurrentReading
  • WinRT OrientationSensor ReadingChanged
  • WinRT Pedometer FromIdAsync
  • WinRT Pedometer GetCurrentReadings
  • WinRT Pedometer GetCurrentReadings
  • WinRT Pedometer GetDefaultAsync
  • WinRT Pedometer GetSystemHistoryAsync
  • WinRT Pedometer GetSystemHistoryWithDurationAsync
  • WinRT Pedometer ReadingChanged
  • WinRT Proximity GetCurrentReading
  • WinRT Proximity Range
  • WinRT Proximity ReadingChanged
  • WinRT Relative Inclinometer GetCurrentReading
  • WinRT Relative Inclinometer ReadingChanged
  • WinRT Relative OrientationSensor GetCurrentReading
  • WinRT Relative OrientationSensor ReadingChanged
  • WinRT SimpleOrientationSensor GetCurrentOrientation
  • WinRT SimpleOrientationSensor OrientationChanged
  • x64 only Smart Card Minidriver Certification Test


Acceleroemter Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b41db84f-f25e-45d4-a39b-b86e887f8bfe

Verifies that the required thresholds fields are present in Accelerometer

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Accelerometer Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88d919d5-0d40-43e1-8b01-f828be722cda

Verifies that the required data field properties are present for the applicable Accelerometer data fields

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Accelerometer DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9fe3485-b2ee-415b-b27c-f4df2823c616

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Accelerometer Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b0bb008-c812-4315-bc7e-3d2f64ad66d6

Verifies that the required data fields are present for the Accelerometer sensor

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Accelerometer minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e751adbe-031c-405b-9654-cbeb88e79075

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Activity Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80529cb3-2e8e-41cd-9a50-e8c09158447e

Verifies that the required data field are present for the Activity sensor

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Activity Sensor Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc77fe44-2709-459a-a679-d1b4b751af23

Verifies that the required thresholds fields are present in Activity Sensor

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Activity sensor minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79cf80f6-1352-4d66-9eaa-73a88d72069f

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


ActivitySensor DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6aeafb8b-ad0f-465b-a15e-7a8921be6af6

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Ambient Light Sensor Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/451940e4-0168-4ecf-bd96-23b3b1140ebc

Verifies that the required thresholds fields are present in Ambient Light Sensor

Test details
Specifications
  • Device.Input.Sensor.AmbientLightSensor.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Ambient light sensor minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79ed5c8e-4802-4d3f-80f4-46cfe5913218

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.AmbientLightSensor.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Barometer DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3818d657-4219-413f-8e09-679c0b65c0e7

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Barometer.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Barometer Sensor Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/003ff501-f18e-4f60-8432-f2748123afb1

Verifies that the required data field properties are present for the applicable Barometer sensor data fields

Test details
Specifications
  • Device.Input.Sensor.Barometer.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Barometer Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2c1186c-ea6a-427e-abd8-6fdaccc6b838

Verifies that the required data fields for the Barometer sensor

Test details
Specifications
  • Device.Input.Sensor.Barometer.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Barometer Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/91bdc66f-2b7a-4763-9b34-73af4d9a1c70

Verifies that the required thresholds fields are present in Barometer

Test details
Specifications
  • Device.Input.Sensor.Barometer.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Check smart card services (SC Reader LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0fdc517a-281d-460e-ab79-41cbd76bf3a4

This test verifies that the Certificate Propagation service and the smart card service are started when the smart card reader driver is loaded.

This test checks whether the smart card reader driver INF file configures the following services to Automatic and Running after system startup:

  • Certificate propagation

  • Smart card

Test details
Specifications
  • Device.Input.SmartCardReader.SmartCardService
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Smart Card Reader Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
scdiag.exe /s /i "[QueryWDKDriverFilePath]" | Runs this test.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
ScDiag.exe | [testbinroot]\nttest\Driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare
LLU_LclAdminUser | User account for running the test
QueryWDKDriverFilePath |


Common data field verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50846c4d-d4d6-4556-a4fb-685c05b05e85

Verifies that the sensor exposes all required common data fields

Test details
Specifications
  • Device.Input.Sensor.General.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Custom Properties Verification Test for All Sensors

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22779fd3-6393-4fe8-b89f-ebc82e8d84fc

Verifies that the custom data fields for all sensors are of expected type

Test details
Specifications
  • Device.Input.Sensor.General.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Custom Sensor DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d4f8a20-6c84-4267-bd84-73c3e39d8fc1

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Custom.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


DDSI Validation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df6485c0-51c7-4db0-8eb3-61627e52bf27

Verifies that all necessary DDSI interface between sensor CX and client driver are implemented

Test details
Specifications
  • Device.Input.Sensor.Base.V2.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Fingerprint Reader Logo Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/969975f1-fe6c-4333-8b7a-a1f0a6c72de1

This test verifies the fingerprint reader for certification.

Test details
Specifications
  • Device.Input.FingerPrintReader.Base
  • Device.Input.FingerPrintReader.ManagementApps
  • Device.Input.FingerPrintReader.SensorEngineDB
  • Device.Input.FingerPrintReader.WBDI
  • Device.Input.FingerPrintReader.BaseLegacy
  • Device.Input.FingerPrintReader.SensorEngineDBLegacy
  • Device.Input.FingerPrintReader.ManagementAppsLegacy
  • Device.Input.FingerPrintReader.WBDILegacy
  • Device.Input.FingerPrintReader.Extensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Fingerprint Reader Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

This test includes the following:

  • Sensor engine adapter test cases

  • Sensor adapter test cases

  • Storage adapter test cases

  • Sequence test cases

  • WBDI driver test cases

Command syntax

Command | Description
Biotest.exe -config EngineTestConfig.xml -log EngineAdapterLog.xml | Runs the engine adapter tests.
Biotest.exe -config SensorTestConfig.xml -log SensorAdapterLog.xml | Runs the sensor adapter tests.
Biotest.exe -config StorageTestConfig.xml -log StorageAdapterLog.xml | Runs the storage adapter tests.
te.exe WinBioSequenceTests.dll | Runs the sequence tests.
WBDIDriverTest.exe | Runs the WBDI driver tests.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
BioTest.exe | <[testbinroot]>\WLK\AdapterTestSuite</p>
EngineTest.dll | <[testbinroot]>\WLK\AdapterTestSuite</p>
EngineTestConfig.xml | <[WorkingDir]>\WLK\AdapterTestSuite</p>
SensorTest.dll | <[testbinroot]>\WLK\AdapterTestSuite</p>
SensorTestConfig.xml | <[WorkingDir]>\WLK\AdapterTestSuite</p>
StorageTest.dll | <[testbinroot]>\WLK\AdapterTestSuite</p>
StorageTestConfig.xml | <[WorkingDir]>\WLK\AdapterTestSuite</p>
TE.Common.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86
TE.DataDrivenTestSource.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86
TE.exe | <[testbinroot]>\Testing\Runtimes\TAEF\x86
TE.Loaders.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>
TE.ProcessHost.exe | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>
Te.TestModes.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>
Wex.Common.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>
Wex.Communication.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>
Wex.Logger.dll | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>
WBDIDriverTest.exe | <[testbinroot]>\WLK\WBDI</p>
WinBioSequenceTests.dll | <[testbinroot]>\WLK\sequencetests</p>

Parameters

Parameter name | Parameter description
WorkingDir | Working directory
TestBinDir | Location of test binaries
LLU_NetAccessOnly | LLU for NAO
TaefBinDir | Directory of TAEF binaries


Geomagnetic Orientation Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2bf065dc-44a1-454b-8e55-02efc60b653c

Verifies that the required data fields are present for the Geomagnetic Orientation sensor

Test details
Specifications
  • Device.Input.Sensor.GeomagneticOrientationSensor.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Geomagnetic Orientation Sensor Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d572dc32-dd90-4ea3-9e37-6af538e3a1a7

Verifies that the required thresholds fields are present in Geomagnetic Orientation Sensor

Test details
Specifications
  • Device.Input.Sensor.GeomagneticOrientationSensor.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Geomagnetic orientation sensor minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97d58beb-d41c-450b-8899-2105a55a9e5a

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.GeomagneticOrientationSensor.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


GeomagneticOrientationSensor DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0729ff91-9689-4544-898d-730e759e7e28

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.GeomagneticOrientationSensor.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Gravity Vector Sensor Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b44302c8-441c-482d-85db-ea11ef3fa916

Verifies that the required thresholds fields are present in Gravity Vector Sensor

Test details
Specifications
  • Device.Input.Sensor.GravityVectorSensor.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


GravityVector Orientation Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efbd3519-b3ad-4736-a669-ef7f35232d1b

Verifies that the required data fields are present for the Gravity vector sensor

Test details
Specifications
  • Device.Input.Sensor.GravityVectorSensor.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Gyrometer Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e9bd62a-443b-4899-8ba0-ab7d45b2a5e7

Verifies that the required data field properties are present for the applicable Gyrometer data fields

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Gyrometer DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9f3b815-42fc-403e-9f54-6b42b8884a4a

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Gyrometer Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/113db23d-275f-47d0-b92c-428432fc4d38

Verifies that the required data fields are present for the Gyrometer sensor

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Gyrometer Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/689367f5-1cce-4706-a83e-e307075cb171

Verifies that the required thresholds fields are present in Gyrometer

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Gyrometer minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1718ea7e-5ec6-4a3d-800c-234048077dfa

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Ifdtest2 Part D (SC Reader LOGO) - (Manual Test)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62a0161d-6133-4ebf-bd3a-56a0c3a9e594

This test verifies the functionality of the smart card reader by validating the PC/SC workgroup test cards. Part D requires the PC/SC test cards.

Test details
Specifications
  • Device.Input.SmartCardReader.Supports258And259BytePackets
  • Device.Input.SmartCardReader.SupportsDirectAndInverseConvention
  • Device.Input.SmartCardReader.PinDataEntryKeyboardCompliesWithIso
  • Device.Input.SmartCardReader.SupportsNegotiableAndSpecificModes
  • Device.Input.SmartCardReader.SupportsResetCommand
  • Device.Input.SmartCardReader.UsbCcidIssuesNak
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Smart Card Reader Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

This test verifies the functionality of the smart card reader by validating the revision two of the PC/SC workgroup test cards.

The test and its hardware must be able to execute specific IFD tests and produce a test report. Specific requirements deal with nominal operation and exceptional operation (error conditions). In addition, these must be applied to all protocols supported by the reader subsystem.

A configuration file needs to be provided for the following types of smart card readers:

  • Contactless
  • Virtual
  • Requires network

The configuration file must be named ifdtest_config.xml and must be placed in C:\SmartCardReaderTest. The following snippet shows a sample configuration file:

<SmartCardReader>
   <Version>1</Version>
   <Contactless>False</Contactless>
   <Virtual>False</Virtual>
   <Network>False</Network>
</SmartCardReader>

IFDTEST2 performs test cases in three separate test jobs: Reader Interface tests are performed without anything inserted in the reader. Resource Manager Status test cases are performed as a sample card is inserted into and removed from the reader, and do handling of card insertion detection under various conditions (any card can be used for this test).

Card Protocol tests involve operation both with inserted representative ordinarily available smart cards and with special cards that exhibit certain specially programmed behavior. The test cases using ordinarily available cards will perform routine operations on cards selected to represent a variety of communication speed and protocol combinations. These tests have changed with the card-set 2.

Resource manager status test cases

Part A

The card monitor test cases check for correct detection of smart card insertion state and correct handling of operations interrupted by the unexpected removal of the card.

  1. Test detection of empty readers using IOCTL_SMARTCARD_IS_PRESENT

  2. Test detection of inserted card using IOCTL_SMARTCARD_IS_PRESENT

  3. Test removal of inserted card using IOCTL_SMARTCARD_IS_ABSENT

  4. Test correct handling of randomly timed card insert and remove actions for 15 seconds

    • Verify that IOCTL_SMARTCARD_IS_PRESENT and IOCTL_SMARTCARD_IS_ABSENT produce valid results

Part C

The resource manager test cases verify successful completion of state change operations normally expected to be commanded by the smart card resource manager.

  1. Verify IOCTL_SMARTCARD_GET_STATE succeeds without card

  2. Verify returned state is valid

  3. Verify correct return from IOCTL_SMARTCARD_IS_PRESENT

  4. Verify correct return from IOCTL_SMARTCARD_IS_ABSENT

  5. Operator inserts a card

  6. Verify IOCTL_SMARTCARD_GET_STATE succeeds with card inserted

  7. Verify returned state is valid

  8. Verify correct return from IOCTL_SMARTCARD_IS_ABSENT

  9. Cold reset the card

  10. Verify card state is SCARD_NEGOTIABLE

  11. Set Card Protocol to T0 or T1

  12. Verify success of IOCTL_SMARTCARD_POWER to turn off the card

  13. Operator removes the card

  14. Verify IOCTL_SMARTCARD_GET_STATE succeeds without a card

Part E

The power management test cases verify that the driver returns the correct state information for the reader across hibernation sequences, even when the state of the reader is changed during hibernation by insertion or removal of a card.

  1. Operator removes all cards

  2. Operator hibernates computer

  3. Operator starts computer

  4. Verify reader state SCARD_ABSENT on return from hibernate

  5. Operator Inserts card

  6. Operator hibernates computer

  7. Operator starts computer

  8. Verify reader state SCARD_PRESENT on return from hibernate

  9. Operator removes card

  10. Operator hibernates computer

  11. Operator removes card during hibernate

  12. Operator starts computer

  13. Verify reader state SCARD_ABSENT on return from hibernate

  14. Operator hibernates computer

  15. Operator inserts card during hibernate

  16. Operator starts computer

  17. Verify reader state SCARD_PRESENT on return from hibernate

Reader interface test cases

Part B

Reader interface test cases check for the correct implementation property and state information at the reader driver.

  1. Check attributes reported by the reader with a sample card inserted

  2. Test that device name reported by the driver is WDM PnP compliant

  3. Test that driver correctly handles attribute read requests with NULL return buffer

  4. Test that driver correctly stops pending i/o requests if the driver is closed and reopened with an i/o operation pending

  5. Test read attributes with no card inserted

    • SCARD_ATTR_VENDOR_NAME : non-zero-length string

    • SCARD_ATTR_VENDOR_IFD_TYPE : non-zero-length string

    • SCARD_ATTR_DEVICE_UNIT : a 4 byte or larger length value

    • SCARD_ATTR_ATR_STRING : read attempt fails

    • SCARD_ATTR_DEFAULT_CLK : 1000 <= value <= 20000

    • SCARD_ATTR_MAX_CLK : 1000 <= value <= 20000

    • SCARD_ATTR_DEFAULT_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_IFSD : 1 <= value <= 254

    • SCARD_ATTR_CURRENT_PROTOCOL_TYPE : read attempt fails

  6. Test read attributes with a card inserted

    • SCARD_ATTR_VENDOR_NAME : non-zero-length string

    • SCARD_ATTR_VENDOR_IFD_TYPE : non-zero-length string

    • SCARD_ATTR_DEVICE_UNIT : a 4 byte or larger length value

    • SCARD_ATTR_ATR_STRING : read attempt succeeds

    • SCARD_ATTR_DEFAULT_CLK : value 1000 <= value <= 20000

    • SCARD_ATTR_MAX_CLK : value 1000 <= value <= 20000

    • SCARD_ATTR_DEFAULT_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_IFSD : 1 <= value <= 254

    • SCARD_ATTR_CURRENT_PROTOCOL_TYPE : value = 0

  7. Read card state with card removed using IOCTL_SMARTCARD_GET_STATE : state <= SCARD_SWALLOWED

  8. Reset card : verify result is ERROR_UNRECOGNIZED_MEDIA

Card protocol test cases

Part D

Infineon Technologies PC/SC Compliance Test Card (Card 0 / Unlabeled)

ATR: 3B EF 00 00 81 31 20 49

00 5C 50 43 54 10 27 F8

D2 76 00 00 38 33 00 4D

  1. Attempt read with buffer too small

  2. Waiting time extension request - route request figure to file 0001, read back and verify

  3. Block chaining resync test on file 0002: card accepts first block. Then repeatedly requests retransmission of block 2; host resyncs - expect ERROR_IO_DEVICE

  4. Block chaining resync test on file 0002: card repeatedly declares EDC error on block 2; host resyncs - expect ERROR_IO_DEVICE

  5. Wrong block sequence by read to file 0003 - expect ERROR_IO_DEVICE

  6. Ifsc request file id 0004

  7. Force time-out by read to file 0005 - expect ERROR_IO_DEVICE

  8. Read and process result file (A000), parse and report errors

Athena T0 Test Card (Card 1)

ATR: 3B D6 18 00 80 B1 80 6D

1F 03 80 51 00 61 10 30

9E

  1. Reset with long (approx 900 mSec) ATR transmission time

  2. Set Protocol to T0, expect success

  3. Erase all card files by proprietary command, expect success

  4. Create test file 0002, expect success

  5. Select test file 0002, expect success

  6. Write 256 bytes as 4 blocks of 64 bytes, expect success

  7. Read and verify 256 bytes as 4 blocks of 64 bytes, expect success

  8. Write 255 bytes as a single block, expect success. The card will receive the bytes in single-byte mode until 8 bytes remain, at which point the rest of the data will be requested from the host as a single block, expect success

  9. Set receive buffer to 9 bytes and attempt to receive 10 bytes response from card, expect ERROR_INSUFFICIENT BUFFER

  10. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect ERROR_INVALID_PARAMETER

  11. Select nonexistent file, expect 6A 82

  12. Send command to silence the card (80 00 01 00 01 11), expect ERROR_SEM_TIMEOUT

  13. Reset the card

  14. Send echo command to card to test request wait time extension for extension counts of 1, 2, 5, and 30 extensions, expect success

Athena\Inverse Convention Test Card (Card 2)

ATR: 3F 96 18 80 01 80 51 00

61 10 30 9F

  1. Reset with long (approx 900 mSec) ATR transmission time

  2. Set Protocol to T0, expect success

  3. Erase all card files by proprietary command, expect success

  4. Create test file 0002, expect success

  5. Select test file 0002, expect success

  6. Write 256 bytes as 4 blocks of 64 bytes, expect success

  7. Read and verify 256 bytes as 4 blocks of 64 bytes, expect success

  8. Write 255 bytes as a single block, expect success. The card will receive the bytes in single-byte mode until 128 bytes remain, at which point the rest of the data will be requested from the host as a single block, expect success

  9. Set receive buffer to 9 bytes and attempt to receive 10 bytes response from card, expect ERROR_INSUFFICIENT BUFFER

  10. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect ERROR_INVALID_PARAMETER

  11. Select nonexistent file, expect 6A 82

  12. Send command to silence the card (80 00 01 00 01 11), expect ERROR_SEM_TIMEOUT

  13. Reset the card

  14. Send echo command to card to test request wait time extension for extension counts of 1, 2, 5, and 30 extensions, expect success

Axalto 32K eGate Test Card (Card 3)

ATR: 3B 95 18 40 FF 62 01 02

01 04

  1. Attempt set protocol T=1, expect ERROR_NOT_SUPPORTED

  2. Set protocol T=0

  3. Authenticate using card transport key, expect success

  4. Clean card state by deleting files from previous runs (Remove RSA public and private key files, the user PIN file, and the test file), expect success

  5. Create new test file 0055, expect success

  6. Test write blocks 1, 25, 75, 128 bytes to test file, expect success

  7. Test read 128 bytes from test file, compare data, expect success

  8. Delete test file 0055, expect success

  9. Create PIN file, expect success

  10. Set user PIN to 00000000, expect success

  11. Create private key file, expect success

  12. Create public key file, expect success

  13. Select private key file, expect success

  14. Authenticate user who has PIN, expect success

  15. Generate key pair, expect success

  16. Hash 16 bytes data, expect success

  17. Get response data to hash operation, 20 bytes + 2 bytes response, expect success

Infineon SiCrypt Card Module Test Card (Card 4)

ATR: 3B DF 18 00 81 31 FE 67

00 5C 49 43 4D D4 91 47

D2 76 00 00 38 33 00 58

  1. Attempt to set protocol T=0, expect ERROR_NOT_SUPPORTED

  2. Set protocol T=1, expect success

  3. Authenticate using PIN 12345678, expect success

  4. Remove files from previous runs if existing

  5. Create new test file 0007, expect success

  6. Select file 0007, expect success

  7. Record system time

  8. Write test blocks of 1, 25, 50, 75, 100, 125, 128 bytes to the card - Read and verify the data after each block write, expect success

  9. Get system time and show elapsed time in seconds for test completion

  10. Select file 0007, expect success

  11. Write 128 byte block of byte value 55, Read back and verify, expect success

  12. Write 128 byte block of byte value AA, Read back and verify, expect success

  13. Write 128 byte block of byte value 00, Read back and verify, expect success

  14. Write 128 byte block of byte value FF, Read back and verify, expect success

  15. Select nonexistent file 7777, expect 9404

  16. Select MF by 00 a4 00 00, expect 90 00 (success)

  17. Select invalid file 77, expect 94 04

  18. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect 94 04

  19. Send malformed (too short) select command by 00 a4 00, expect 67 00

  20. Create DF 5555 from the MF, expect success

  21. Select into 5555, expect success

  22. Create DF 5656 from 5555, expect success

  23. Select into 5656, expect success

  24. Create File 5757 in DF 5656, expect success

  25. Select that file from MF by full path, expect success

  26. Write 8 bytes to file, Read back and verify, expect success

  27. Delete the selected file, expect success

  28. Attempt to select that file by full path, expect 94 04

  29. Select and delete DF 5656, expect success

  30. Select and delete DF 5555, expect success

  31. Select and delete file 0007, expect success

Running the card reader test

WARNING

For the power management test cases in Part D, the computer will hibernate and you may have to remove or reinsert a smart card in the test smart card reader.

Parts A, B, C, and E

Follow the instructions on the screen for Parts A, B, C, and E by using the cards from the PC/SC workgroup test card-set 2. When you are prompted, insert and then remove each smart card from the test smart card reader.

Part D

Follow the instructions on the screen for Part D to complete the four power management test cases. When you are prompted, insert or remove the smart card from the test smart card reader and hibernate or restart the test computer.

To run the Test 1 Card Out/Card Out test case:

  1. Remove the smart card from the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Press the computer power button to bring the computer out of hibernation and continue the test.

  5. When you are prompted, reinsert the smart card in the test smart card reader.

To run the Test 2 Card In/Card Out test case:

  1. Verify that the smart card is in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Remove the smart card from the test smart card reader.

  5. Press the computer power button to bring the computer out of hibernation.

  6. When you are prompted, reinsert the smart card in the test smart card reader before you start the next test case.

To run the Test 3 Card In/Card In test case:

  1. Verify that the smart card is in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Press the computer power button to bring the computer out of hibernation.

  5. When you are prompted, remove the smart card from the test smart card reader before you start the next test case.

To run the Test 4 Card Out/Card in test case:

  1. Verify that there is no smart card in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Reinsert the smart card in the test smart card reader.

  5. Press the computer power button to bring the computer out of hibernation. The smart card reader test is completed.

  6. View the test log files.

  7. Run all of the other required tests.

  8. After you successfully complete all of the tests that are required for this test submission, return the test results.

Command syntax

To run this command outside of HLK Studio, you must stop the Smart Card service, run the command, and then the start the Smart Card service.

Command | Description
ifdtest2.exe -sa -sb -sc -se -sf | Runs the test.

File list

File | Location
ifdtest2.exe | <testbinroot>\nttest\Driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


Ifdtest2 Part E (SC Reader LOGO) - (Manual Test)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a97fe75d-834b-4a8c-9173-08789374cfe6

This manual card reader test verifies the functionality of the smart card reader by validating the PC/SC workgroup test cards. You can run Part E with any smartcard.

Test details
Specifications
  • Device.Input.SmartCardReader.SupportsInsertionAndRemovalMonitor
  • Device.Input.SmartCardReader.UsbCcidCompliesWithUsbDeviceClassSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Smart Card Reader Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

This test verifies the functionality of the smart card reader by validating the revision two of the PC/SC workgroup test cards.

The test and its hardware must be able to execute specific IFD tests and produce a test report. Specific requirements deal with nominal operation and exceptional operation (error conditions). In addition, these must be applied to all protocols supported by the reader subsystem.

A configuration file needs to be provided for the following types of smart card readers:

  • Contactless
  • Virtual
  • Requires network

The configuration file must be named ifdtest_config.xml and must be placed in C:\SmartCardReaderTest. The following snippet shows a sample configuration file:

<SmartCardReader>
   <Version>1</Version>
   <Contactless>False</Contactless>
   <Virtual>False</Virtual>
   <Network>False</Network>
</SmartCardReader>

IFDTEST2 performs test cases in three separate test jobs: Reader Interface tests are performed without anything inserted in the reader. Resource Manager Status test cases are performed as a sample card is inserted into and removed from the reader, and do handling of card insertion detection under various conditions (any card can be used for this test).

Card Protocol tests involve operation both with inserted representative ordinarily available smart cards and with special cards that exhibit certain specially programmed behavior. The test cases using ordinarily available cards will perform routine operations on cards selected to represent a variety of communication speed and protocol combinations. These tests have changed with the card-set 2.

Resource manager status test cases

Part A

The card monitor test cases check for correct detection of smart card insertion state and correct handling of operations interrupted by the unexpected removal of the card.

  1. Test detection of empty readers using IOCTL_SMARTCARD_IS_PRESENT

  2. Test detection of inserted card using IOCTL_SMARTCARD_IS_PRESENT

  3. Test removal of inserted card using IOCTL_SMARTCARD_IS_ABSENT

  4. Test correct handling of randomly timed card insert and remove actions for 15 seconds

    • Verify that IOCTL_SMARTCARD_IS_PRESENT and IOCTL_SMARTCARD_IS_ABSENT produce valid results

Part C

The resource manager test cases verify successful completion of state change operations normally expected to be commanded by the smart card resource manager.

  1. Verify IOCTL_SMARTCARD_GET_STATE succeeds without card

  2. Verify returned state is valid

  3. Verify correct return from IOCTL_SMARTCARD_IS_PRESENT

  4. Verify correct return from IOCTL_SMARTCARD_IS_ABSENT

  5. Operator inserts a card

  6. Verify IOCTL_SMARTCARD_GET_STATE succeeds with card inserted

  7. Verify returned state is valid

  8. Verify correct return from IOCTL_SMARTCARD_IS_ABSENT

  9. Cold reset the card

  10. Verify card state is SCARD_NEGOTIABLE

  11. Set Card Protocol to T0 or T1

  12. Verify success of IOCTL_SMARTCARD_POWER to turn off the card

  13. Operator removes the card

  14. Verify IOCTL_SMARTCARD_GET_STATE succeeds without a card

Part E

The power management test cases verify that the driver returns the correct state information for the reader across hibernation sequences, even when the state of the reader is changed during hibernation by insertion or removal of a card.

  1. Operator removes all cards

  2. Operator hibernates computer

  3. Operator starts computer

  4. Verify reader state SCARD_ABSENT on return from hibernate

  5. Operator Inserts card

  6. Operator hibernates computer

  7. Operator starts computer

  8. Verify reader state SCARD_PRESENT on return from hibernate

  9. Operator removes card

  10. Operator hibernates computer

  11. Operator removes card during hibernate

  12. Operator starts computer

  13. Verify reader state SCARD_ABSENT on return from hibernate

  14. Operator hibernates computer

  15. Operator inserts card during hibernate

  16. Operator starts computer

  17. Verify reader state SCARD_PRESENT on return from hibernate

Reader interface test cases

Part B

Reader interface test cases check for the correct implementation property and state information at the reader driver.

  1. Check attributes reported by the reader with a sample card inserted

  2. Test that device name reported by the driver is WDM PnP compliant

  3. Test that driver correctly handles attribute read requests with NULL return buffer

  4. Test that driver correctly stops pending i/o requests if the driver is closed and reopened with an i/o operation pending

  5. Test read attributes with no card inserted

    • SCARD_ATTR_VENDOR_NAME : non-zero-length string

    • SCARD_ATTR_VENDOR_IFD_TYPE : non-zero-length string

    • SCARD_ATTR_DEVICE_UNIT : a 4 byte or larger length value

    • SCARD_ATTR_ATR_STRING : read attempt fails

    • SCARD_ATTR_DEFAULT_CLK : 1000 <= value <= 20000

    • SCARD_ATTR_MAX_CLK : 1000 <= value <= 20000

    • SCARD_ATTR_DEFAULT_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_IFSD : 1 <= value <= 254

    • SCARD_ATTR_CURRENT_PROTOCOL_TYPE : read attempt fails

  6. Test read attributes with a card inserted

    • SCARD_ATTR_VENDOR_NAME : non-zero-length string

    • SCARD_ATTR_VENDOR_IFD_TYPE : non-zero-length string

    • SCARD_ATTR_DEVICE_UNIT : a 4 byte or larger length value

    • SCARD_ATTR_ATR_STRING : read attempt succeeds

    • SCARD_ATTR_DEFAULT_CLK : value 1000 <= value <= 20000

    • SCARD_ATTR_MAX_CLK : value 1000 <= value <= 20000

    • SCARD_ATTR_DEFAULT_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_IFSD : 1 <= value <= 254

    • SCARD_ATTR_CURRENT_PROTOCOL_TYPE : value = 0

  7. Read card state with card removed using IOCTL_SMARTCARD_GET_STATE : state <= SCARD_SWALLOWED

  8. Reset card : verify result is ERROR_UNRECOGNIZED_MEDIA

Card protocol test cases

Part D

Infineon Technologies PC/SC Compliance Test Card (Card 0 / Unlabeled)

ATR: 3B EF 00 00 81 31 20 49

00 5C 50 43 54 10 27 F8

D2 76 00 00 38 33 00 4D

  1. Attempt read with buffer too small

  2. Waiting time extension request - route request figure to file 0001, read back and verify

  3. Block chaining resync test on file 0002: card accepts first block. Then repeatedly requests retransmission of block 2; host resyncs - expect ERROR_IO_DEVICE

  4. Block chaining resync test on file 0002: card repeatedly declares EDC error on block 2; host resyncs - expect ERROR_IO_DEVICE

  5. Wrong block sequence by read to file 0003 - expect ERROR_IO_DEVICE

  6. Ifsc request file id 0004

  7. Force time-out by read to file 0005 - expect ERROR_IO_DEVICE

  8. Read and process result file (A000), parse and report errors

Athena T0 Test Card (Card 1)

ATR: 3B D6 18 00 80 B1 80 6D

1F 03 80 51 00 61 10 30

9E

  1. Reset with long (approx 900 mSec) ATR transmission time

  2. Set Protocol to T0, expect success

  3. Erase all card files by proprietary command, expect success

  4. Create test file 0002, expect success

  5. Select test file 0002, expect success

  6. Write 256 bytes as 4 blocks of 64 bytes, expect success

  7. Read and verify 256 bytes as 4 blocks of 64 bytes, expect success

  8. Write 255 bytes as a single block, expect success. The card will receive the bytes in single-byte mode until 8 bytes remain, at which point the rest of the data will be requested from the host as a single block, expect success

  9. Set receive buffer to 9 bytes and attempt to receive 10 bytes response from card, expect ERROR_INSUFFICIENT BUFFER

  10. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect ERROR_INVALID_PARAMETER

  11. Select nonexistent file, expect 6A 82

  12. Send command to silence the card (80 00 01 00 01 11), expect ERROR_SEM_TIMEOUT

  13. Reset the card

  14. Send echo command to card to test request wait time extension for extension counts of 1, 2, 5, and 30 extensions, expect success

Athena\Inverse Convention Test Card (Card 2)

ATR: 3F 96 18 80 01 80 51 00

61 10 30 9F

  1. Reset with long (approx 900 mSec) ATR transmission time

  2. Set Protocol to T0, expect success

  3. Erase all card files by proprietary command, expect success

  4. Create test file 0002, expect success

  5. Select test file 0002, expect success

  6. Write 256 bytes as 4 blocks of 64 bytes, expect success

  7. Read and verify 256 bytes as 4 blocks of 64 bytes, expect success

  8. Write 255 bytes as a single block, expect success. The card will receive the bytes in single-byte mode until 128 bytes remain, at which point the rest of the data will be requested from the host as a single block, expect success

  9. Set receive buffer to 9 bytes and attempt to receive 10 bytes response from card, expect ERROR_INSUFFICIENT BUFFER

  10. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect ERROR_INVALID_PARAMETER

  11. Select nonexistent file, expect 6A 82

  12. Send command to silence the card (80 00 01 00 01 11), expect ERROR_SEM_TIMEOUT

  13. Reset the card

  14. Send echo command to card to test request wait time extension for extension counts of 1, 2, 5, and 30 extensions, expect success

Axalto 32K eGate Test Card (Card 3)

ATR: 3B 95 18 40 FF 62 01 02

01 04

  1. Attempt set protocol T=1, expect ERROR_NOT_SUPPORTED

  2. Set protocol T=0

  3. Authenticate using card transport key, expect success

  4. Clean card state by deleting files from previous runs (Remove RSA public and private key files, the user PIN file, and the test file), expect success

  5. Create new test file 0055, expect success

  6. Test write blocks 1, 25, 75, 128 bytes to test file, expect success

  7. Test read 128 bytes from test file, compare data, expect success

  8. Delete test file 0055, expect success

  9. Create PIN file, expect success

  10. Set user PIN to 00000000, expect success

  11. Create private key file, expect success

  12. Create public key file, expect success

  13. Select private key file, expect success

  14. Authenticate user who has PIN, expect success

  15. Generate key pair, expect success

  16. Hash 16 bytes data, expect success

  17. Get response data to hash operation, 20 bytes + 2 bytes response, expect success

Infineon SiCrypt Card Module Test Card (Card 4)

ATR: 3B DF 18 00 81 31 FE 67

00 5C 49 43 4D D4 91 47

D2 76 00 00 38 33 00 58

  1. Attempt to set protocol T=0, expect ERROR_NOT_SUPPORTED

  2. Set protocol T=1, expect success

  3. Authenticate using PIN 12345678, expect success

  4. Remove files from previous runs if existing

  5. Create new test file 0007, expect success

  6. Select file 0007, expect success

  7. Record system time

  8. Write test blocks of 1, 25, 50, 75, 100, 125, 128 bytes to the card - Read and verify the data after each block write, expect success

  9. Get system time and show elapsed time in seconds for test completion

  10. Select file 0007, expect success

  11. Write 128 byte block of byte value 55, Read back and verify, expect success

  12. Write 128 byte block of byte value AA, Read back and verify, expect success

  13. Write 128 byte block of byte value 00, Read back and verify, expect success

  14. Write 128 byte block of byte value FF, Read back and verify, expect success

  15. Select nonexistent file 7777, expect 9404

  16. Select MF by 00 a4 00 00, expect 90 00 (success)

  17. Select invalid file 77, expect 94 04

  18. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect 94 04

  19. Send malformed (too short) select command by 00 a4 00, expect 67 00

  20. Create DF 5555 from the MF, expect success

  21. Select into 5555, expect success

  22. Create DF 5656 from 5555, expect success

  23. Select into 5656, expect success

  24. Create File 5757 in DF 5656, expect success

  25. Select that file from MF by full path, expect success

  26. Write 8 bytes to file, Read back and verify, expect success

  27. Delete the selected file, expect success

  28. Attempt to select that file by full path, expect 94 04

  29. Select and delete DF 5656, expect success

  30. Select and delete DF 5555, expect success

  31. Select and delete file 0007, expect success

Running the card reader test

WARNING

For the power management test cases in Part D, the computer will hibernate and you may have to remove or reinsert a smart card in the test smart card reader.

Parts A, B, C, and E

Follow the instructions on the screen for Parts A, B, C, and E by using the cards from the PC/SC workgroup test card-set 2. When you are prompted, insert and then remove each smart card from the test smart card reader.

Part D

Follow the instructions on the screen for Part D to complete the four power management test cases. When you are prompted, insert or remove the smart card from the test smart card reader and hibernate or restart the test computer.

To run the Test 1 Card Out/Card Out test case:

  1. Remove the smart card from the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Press the computer power button to bring the computer out of hibernation and continue the test.

  5. When you are prompted, reinsert the smart card in the test smart card reader.

To run the Test 2 Card In/Card Out test case:

  1. Verify that the smart card is in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Remove the smart card from the test smart card reader.

  5. Press the computer power button to bring the computer out of hibernation.

  6. When you are prompted, reinsert the smart card in the test smart card reader before you start the next test case.

To run the Test 3 Card In/Card In test case:

  1. Verify that the smart card is in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Press the computer power button to bring the computer out of hibernation.

  5. When you are prompted, remove the smart card from the test smart card reader before you start the next test case.

To run the Test 4 Card Out/Card in test case:

  1. Verify that there is no smart card in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Reinsert the smart card in the test smart card reader.

  5. Press the computer power button to bring the computer out of hibernation. The smart card reader test is completed.

  6. View the test log files.

  7. Run all of the other required tests.

  8. After you successfully complete all of the tests that are required for this test submission, return the test results.

Command syntax

To run this command outside of HLK Studio, you must stop the Smart Card service, run the command, and then the start the Smart Card service.

Command | Description
ifdtest2.exe -sa -sb -sc -sd -sf | Runs the test.

File list

File | Location
ifdtest2.exe | <testbinroot>\nttest\Driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


Ifdtest2 Part F (SC Reader LOGO) - (Manual Test)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7deb14eb-ca37-4799-9536-2cc847d909fb

This test verifies the functionality of the smart card reader by validating the PC/SC workgroup test cards.

Test details
Specifications
  • Device.Input.SmartCardReader.SupportsInsertionAndRemovalMonitor
  • Device.Input.SmartCardReader.UsbCcidCompliesWithUsbDeviceClassSpec
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Smart Card Reader Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

To run this command outside of HLK Studio, you must stop the Smart Card service, run the command, and then the start the Smart Card service.

Command | Description
ifdtest2.exe -sa -sb -sc -se -sf | Runs the test.

File list

File | Location
ifdtest2.exe | <testbinroot>\nttest\Driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


Ifdtest2 Parts A B & C (SC Reader LOGO) - (Manual Test)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e731655-618f-4330-a097-658cce35b906

This test verifies the functionality of the smart card reader by validating the PC/SC workgroup test cards. You can run parts A, B, and C with any smartcard.

Test details
Specifications
  • Device.Input.SmartCardReader.SupportsInsertionAndRemovalMonitor
  • Device.Input.SmartCardReader.SupportsMinClockFrequency
  • Device.Input.SmartCardReader.SupportsMinDataRateOf9600bps
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Smart Card Reader Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

This test verifies the functionality of the smart card reader by validating the revision two of the PC/SC workgroup test cards.

The test and its hardware must be able to execute specific IFD tests and produce a test report. Specific requirements deal with nominal operation and exceptional operation (error conditions). In addition, these must be applied to all protocols supported by the reader subsystem.

A configuration file needs to be provided for the following types of smart card readers:

  • Contactless
  • Virtual
  • Requires network

The configuration file must be named ifdtest_config.xml and must be placed in C:\SmartCardReaderTest. The following snippet shows a sample configuration file:

<SmartCardReader>
   <Version>1</Version>
   <Contactless>False</Contactless>
   <Virtual>False</Virtual>
   <Network>False</Network>
</SmartCardReader>

IFDTEST2 performs test cases in three separate test jobs: Reader Interface tests are performed without anything inserted in the reader. Resource Manager Status test cases are performed as a sample card is inserted into and removed from the reader, and do handling of card insertion detection under various conditions (any card can be used for this test).

Card Protocol tests involve operation both with inserted representative ordinarily available smart cards and with special cards that exhibit certain specially programmed behavior. The test cases using ordinarily available cards will perform routine operations on cards selected to represent a variety of communication speed and protocol combinations. These tests have changed with the card-set 2.

Resource manager status test cases

Part A

The card monitor test cases check for correct detection of smart card insertion state and correct handling of operations interrupted by the unexpected removal of the card.

  1. Test detection of empty readers using IOCTL_SMARTCARD_IS_PRESENT

  2. Test detection of inserted card using IOCTL_SMARTCARD_IS_PRESENT

  3. Test removal of inserted card using IOCTL_SMARTCARD_IS_ABSENT

  4. Test correct handling of randomly timed card insert and remove actions for 15 seconds

    • Verify that IOCTL_SMARTCARD_IS_PRESENT and IOCTL_SMARTCARD_IS_ABSENT produce valid results

Part C

The resource manager test cases verify successful completion of state change operations normally expected to be commanded by the smart card resource manager.

  1. Verify IOCTL_SMARTCARD_GET_STATE succeeds without card

  2. Verify returned state is valid

  3. Verify correct return from IOCTL_SMARTCARD_IS_PRESENT

  4. Verify correct return from IOCTL_SMARTCARD_IS_ABSENT

  5. Operator inserts a card

  6. Verify IOCTL_SMARTCARD_GET_STATE succeeds with card inserted

  7. Verify returned state is valid

  8. Verify correct return from IOCTL_SMARTCARD_IS_ABSENT

  9. Cold reset the card

  10. Verify card state is SCARD_NEGOTIABLE

  11. Set Card Protocol to T0 or T1

  12. Verify success of IOCTL_SMARTCARD_POWER to turn off the card

  13. Operator removes the card

  14. Verify IOCTL_SMARTCARD_GET_STATE succeeds without a card

Part E

The power management test cases verify that the driver returns the correct state information for the reader across hibernation sequences, even when the state of the reader is changed during hibernation by insertion or removal of a card.

  1. Operator removes all cards

  2. Operator hibernates computer

  3. Operator starts computer

  4. Verify reader state SCARD_ABSENT on return from hibernate

  5. Operator Inserts card

  6. Operator hibernates computer

  7. Operator starts computer

  8. Verify reader state SCARD_PRESENT on return from hibernate

  9. Operator removes card

  10. Operator hibernates computer

  11. Operator removes card during hibernate

  12. Operator starts computer

  13. Verify reader state SCARD_ABSENT on return from hibernate

  14. Operator hibernates computer

  15. Operator inserts card during hibernate

  16. Operator starts computer

  17. Verify reader state SCARD_PRESENT on return from hibernate

Reader interface test cases

Part B

Reader interface test cases check for the correct implementation property and state information at the reader driver.

  1. Check attributes reported by the reader with a sample card inserted

  2. Test that device name reported by the driver is WDM PnP compliant

  3. Test that driver correctly handles attribute read requests with NULL return buffer

  4. Test that driver correctly stops pending i/o requests if the driver is closed and reopened with an i/o operation pending

  5. Test read attributes with no card inserted

    • SCARD_ATTR_VENDOR_NAME : non-zero-length string

    • SCARD_ATTR_VENDOR_IFD_TYPE : non-zero-length string

    • SCARD_ATTR_DEVICE_UNIT : a 4 byte or larger length value

    • SCARD_ATTR_ATR_STRING : read attempt fails

    • SCARD_ATTR_DEFAULT_CLK : 1000 <= value <= 20000

    • SCARD_ATTR_MAX_CLK : 1000 <= value <= 20000

    • SCARD_ATTR_DEFAULT_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_IFSD : 1 <= value <= 254

    • SCARD_ATTR_CURRENT_PROTOCOL_TYPE : read attempt fails

  6. Test read attributes with a card inserted

    • SCARD_ATTR_VENDOR_NAME : non-zero-length string

    • SCARD_ATTR_VENDOR_IFD_TYPE : non-zero-length string

    • SCARD_ATTR_DEVICE_UNIT : a 4 byte or larger length value

    • SCARD_ATTR_ATR_STRING : read attempt succeeds

    • SCARD_ATTR_DEFAULT_CLK : value 1000 <= value <= 20000

    • SCARD_ATTR_MAX_CLK : value 1000 <= value <= 20000

    • SCARD_ATTR_DEFAULT_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_DATA_RATE : read attempt succeeds

    • SCARD_ATTR_MAX_IFSD : 1 <= value <= 254

    • SCARD_ATTR_CURRENT_PROTOCOL_TYPE : value = 0

  7. Read card state with card removed using IOCTL_SMARTCARD_GET_STATE : state <= SCARD_SWALLOWED

  8. Reset card : verify result is ERROR_UNRECOGNIZED_MEDIA

Card protocol test cases

Part D

Infineon Technologies PC/SC Compliance Test Card (Card 0 / Unlabeled)

ATR: 3B EF 00 00 81 31 20 49

00 5C 50 43 54 10 27 F8

D2 76 00 00 38 33 00 4D

  1. Attempt read with buffer too small

  2. Waiting time extension request - route request figure to file 0001, read back and verify

  3. Block chaining resync test on file 0002: card accepts first block. Then repeatedly requests retransmission of block 2; host resyncs - expect ERROR_IO_DEVICE

  4. Block chaining resync test on file 0002: card repeatedly declares EDC error on block 2; host resyncs - expect ERROR_IO_DEVICE

  5. Wrong block sequence by read to file 0003 - expect ERROR_IO_DEVICE

  6. Ifsc request file id 0004

  7. Force time-out by read to file 0005 - expect ERROR_IO_DEVICE

  8. Read and process result file (A000), parse and report errors

Athena T0 Test Card (Card 1)

ATR: 3B D6 18 00 80 B1 80 6D

1F 03 80 51 00 61 10 30

9E

  1. Reset with long (approx 900 mSec) ATR transmission time

  2. Set Protocol to T0, expect success

  3. Erase all card files by proprietary command, expect success

  4. Create test file 0002, expect success

  5. Select test file 0002, expect success

  6. Write 256 bytes as 4 blocks of 64 bytes, expect success

  7. Read and verify 256 bytes as 4 blocks of 64 bytes, expect success

  8. Write 255 bytes as a single block, expect success. The card will receive the bytes in single-byte mode until 8 bytes remain, at which point the rest of the data will be requested from the host as a single block, expect success

  9. Set receive buffer to 9 bytes and attempt to receive 10 bytes response from card, expect ERROR_INSUFFICIENT BUFFER

  10. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect ERROR_INVALID_PARAMETER

  11. Select nonexistent file, expect 6A 82

  12. Send command to silence the card (80 00 01 00 01 11), expect ERROR_SEM_TIMEOUT

  13. Reset the card

  14. Send echo command to card to test request wait time extension for extension counts of 1, 2, 5, and 30 extensions, expect success

Athena\Inverse Convention Test Card (Card 2)

ATR: 3F 96 18 80 01 80 51 00

61 10 30 9F

  1. Reset with long (approx 900 mSec) ATR transmission time

  2. Set Protocol to T0, expect success

  3. Erase all card files by proprietary command, expect success

  4. Create test file 0002, expect success

  5. Select test file 0002, expect success

  6. Write 256 bytes as 4 blocks of 64 bytes, expect success

  7. Read and verify 256 bytes as 4 blocks of 64 bytes, expect success

  8. Write 255 bytes as a single block, expect success. The card will receive the bytes in single-byte mode until 128 bytes remain, at which point the rest of the data will be requested from the host as a single block, expect success

  9. Set receive buffer to 9 bytes and attempt to receive 10 bytes response from card, expect ERROR_INSUFFICIENT BUFFER

  10. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect ERROR_INVALID_PARAMETER

  11. Select nonexistent file, expect 6A 82

  12. Send command to silence the card (80 00 01 00 01 11), expect ERROR_SEM_TIMEOUT

  13. Reset the card

  14. Send echo command to card to test request wait time extension for extension counts of 1, 2, 5, and 30 extensions, expect success

Axalto 32K eGate Test Card (Card 3)

ATR: 3B 95 18 40 FF 62 01 02

01 04

  1. Attempt set protocol T=1, expect ERROR_NOT_SUPPORTED

  2. Set protocol T=0

  3. Authenticate using card transport key, expect success

  4. Clean card state by deleting files from previous runs (Remove RSA public and private key files, the user PIN file, and the test file), expect success

  5. Create new test file 0055, expect success

  6. Test write blocks 1, 25, 75, 128 bytes to test file, expect success

  7. Test read 128 bytes from test file, compare data, expect success

  8. Delete test file 0055, expect success

  9. Create PIN file, expect success

  10. Set user PIN to 00000000, expect success

  11. Create private key file, expect success

  12. Create public key file, expect success

  13. Select private key file, expect success

  14. Authenticate user who has PIN, expect success

  15. Generate key pair, expect success

  16. Hash 16 bytes data, expect success

  17. Get response data to hash operation, 20 bytes + 2 bytes response, expect success

Infineon SiCrypt Card Module Test Card (Card 4)

ATR: 3B DF 18 00 81 31 FE 67

00 5C 49 43 4D D4 91 47

D2 76 00 00 38 33 00 58

  1. Attempt to set protocol T=0, expect ERROR_NOT_SUPPORTED

  2. Set protocol T=1, expect success

  3. Authenticate using PIN 12345678, expect success

  4. Remove files from previous runs if existing

  5. Create new test file 0007, expect success

  6. Select file 0007, expect success

  7. Record system time

  8. Write test blocks of 1, 25, 50, 75, 100, 125, 128 bytes to the card - Read and verify the data after each block write, expect success

  9. Get system time and show elapsed time in seconds for test completion

  10. Select file 0007, expect success

  11. Write 128 byte block of byte value 55, Read back and verify, expect success

  12. Write 128 byte block of byte value AA, Read back and verify, expect success

  13. Write 128 byte block of byte value 00, Read back and verify, expect success

  14. Write 128 byte block of byte value FF, Read back and verify, expect success

  15. Select nonexistent file 7777, expect 9404

  16. Select MF by 00 a4 00 00, expect 90 00 (success)

  17. Select invalid file 77, expect 94 04

  18. Send malformed (Lc inconsistent with data length) select command 00 a4 00 00 08 00, expect 94 04

  19. Send malformed (too short) select command by 00 a4 00, expect 67 00

  20. Create DF 5555 from the MF, expect success

  21. Select into 5555, expect success

  22. Create DF 5656 from 5555, expect success

  23. Select into 5656, expect success

  24. Create File 5757 in DF 5656, expect success

  25. Select that file from MF by full path, expect success

  26. Write 8 bytes to file, Read back and verify, expect success

  27. Delete the selected file, expect success

  28. Attempt to select that file by full path, expect 94 04

  29. Select and delete DF 5656, expect success

  30. Select and delete DF 5555, expect success

  31. Select and delete file 0007, expect success

Running the card reader test

WARNING

For the power management test cases in Part D, the computer will hibernate and you may have to remove or reinsert a smart card in the test smart card reader.

Parts A, B, C, and E

Follow the instructions on the screen for Parts A, B, C, and E by using the cards from the PC/SC workgroup test card-set 2. When you are prompted, insert and then remove each smart card from the test smart card reader.

Part D

Follow the instructions on the screen for Part D to complete the four power management test cases. When you are prompted, insert or remove the smart card from the test smart card reader and hibernate or restart the test computer.

To run the Test 1 Card Out/Card Out test case:

  1. Remove the smart card from the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Press the computer power button to bring the computer out of hibernation and continue the test.

  5. When you are prompted, reinsert the smart card in the test smart card reader.

To run the Test 2 Card In/Card Out test case:

  1. Verify that the smart card is in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Remove the smart card from the test smart card reader.

  5. Press the computer power button to bring the computer out of hibernation.

  6. When you are prompted, reinsert the smart card in the test smart card reader before you start the next test case.

To run the Test 3 Card In/Card In test case:

  1. Verify that the smart card is in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Press the computer power button to bring the computer out of hibernation.

  5. When you are prompted, remove the smart card from the test smart card reader before you start the next test case.

To run the Test 4 Card Out/Card in test case:

  1. Verify that there is no smart card in the test smart card reader.

  2. The computer will automatically hibernate after 15 seconds.

  3. Allow the computer to hibernate for 30 to 60 seconds.

  4. Reinsert the smart card in the test smart card reader.

  5. Press the computer power button to bring the computer out of hibernation. The smart card reader test is completed.

  6. View the test log files.

  7. Run all of the other required tests.

  8. After you successfully complete all of the tests that are required for this test submission, return the test results.

Command syntax

To run this command outside of HLK Studio, you must stop the Smart Card service, run the command, and then the start the Smart Card service.

Command | Description
ifdtest2.exe -sd -se -sf | Runs the test.

File list

File | Location
ifdtest2.exe | <testbinroot>\nttest\Driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


Inclinometer DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d12a1cf5-fa81-4dd5-8f13-06767fad0e25

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Light Sensor Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c847503b-e05d-4c4a-8a00-c7854be3cf0f

Verifies that the required data field properties are present for the applicable Light sensor data fields

Test details
Specifications
  • Device.Input.Sensor.Light.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Light Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5798062-993c-423f-b619-6784d10ea890

Verifies that the required data fields are present for the Light sensor

Test details
Specifications
  • Device.Input.Sensor.AmbientLightSensor.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


LightSensor DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/307ddf39-77ab-457b-8bbe-b426dcfa00bc

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Light.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Linear Accelerometer Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92a7ae25-b3a7-4dfc-8457-dea53dbf820a

Verifies that the required data fields are present for the Linear Accelerometer sensor

Test details
Specifications
  • Device.Input.Sensor.LinearAccelerometer.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Linear Accelerometer Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8b8e99e-c6ed-40b4-8240-f025283d2ab0

Verifies that the required thresholds fields are present in Linear Accelerometer

Test details
Specifications
  • Device.Input.Sensor.LinearAccelerometer.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Magnetometer Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ead3579-52b3-4ab7-9449-b58fb11aeded

Verifies that the required data field properties are present for the applicable Magnetometer data fields

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Magnetometer DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d51c5b18-230e-415a-9452-20428b425dd3

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Magnetometer Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51b55fd5-f1fe-4ae3-a69c-b60d97a60021

Verifies that the required data fields are present for Magnetometer sensor

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Magnetometer Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8f549fa-33b9-4994-84c2-a9bbfef8c39a

Verifies that the required thresholds fields are present in Magnetometer

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Magnetometer minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e220b4d-ea40-48d3-a4b2-5c44f2679758

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Orientation Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1511f93b-e999-4556-aafd-adb0253fd057

Verifies that the required data fields are present for the Orientation sensor

Test details
Specifications
  • Device.Input.Sensor.Orientation.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Orientation Sensor Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37a5a72b-0372-46de-b769-394a22ad9fc2

Verifies that the required thresholds fields are present in Orientation Sensor

Test details
Specifications
  • Device.Input.Sensor.Orientation.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Orientation sensor minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4442a2fe-fcc6-4ede-bb6f-1a30aafb5dc2

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.Orientation.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Pedometer DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17eadbbf-ac26-47a3-8a81-1bb795b2260e

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Pedometer Sensor Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5cc30791-0d6e-48a0-81d3-ee7dc595aeac

Verifies that the required data field properties are present for the applicable Pedometer sensor data fields

Test details
Specifications
  • Device.Input.Sensor.Pedometer.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Pedometer Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/582b2bd4-6ae9-43de-bc44-da2917d2ee89

Verifies that the required data fields are present for the Pedometer sensor

Test details
Specifications
  • Device.Input.Sensor.Pedometer.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Pedometer Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa17cab9-d700-4a35-8129-9f0005c7cde3

Verifies that the required thresholds fields are present in Pedometer

Test details
Specifications
  • Device.Input.Sensor.Pedometer.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Pedometer minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/278e968b-6f46-4c17-b106-e1620cebde82

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.Pedometer.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


PenBufferingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab426e01-7814-4253-9edd-7a0fa35f3fcc

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer buffering

Test details
Specifications
  • Device.Input.Digitizer.Pen.Buffering
  • System.Client.Digitizer.Pen.Buffering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenContactAccuracyTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b155134-f7df-408c-968f-f4ecdc388397

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer contact accuracy

Test details
Specifications
  • Device.Input.Digitizer.Pen.Accuracy
  • System.Client.Digitizer.Pen.Accuracy
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenCustomGesturesTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db84bf1c-fbf4-4235-a224-984deed3e0bf

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer custom gestures

Test details
Specifications
  • Device.Input.Digitizer.Pen.CustomGestures
  • System.Client.Digitizer.Pen.CustomGestures
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenDownLatencyTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/57923f90-2e65-48a2-876c-898d51d36d06

Validate pen digitizer active down latency

Test details
Specifications
  • Device.Input.Digitizer.Pen.Latency
  • System.Client.Digitizer.Pen.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenEdgeGutterTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12ba57a5-5a89-45e0-98c2-13bb8912a313

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer edge gutter

Test details
Specifications
  • Device.Input.Digitizer.Pen.Accuracy
  • System.Client.Digitizer.Pen.Accuracy
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenEraserTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cff19a1d-0883-46e7-90cf-93e55965beac

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer eraser affordance

Test details
Specifications
  • Device.Input.Digitizer.Pen.Eraser
  • System.Client.Digitizer.Pen.Eraser
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenGhostReportingTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e04c2870-3ccb-4d65-b224-94786baced8f

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer ghost reporting

Test details
Specifications
  • Device.Input.Digitizer.Pen.ContactReports
  • System.Client.Digitizer.Pen.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenHoverAccuracyTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f91867b3-1c9d-4bfa-9b5f-90028b0f2755

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer hover accuracy

Test details
Specifications
  • Device.Input.Digitizer.Pen.Accuracy
  • System.Client.Digitizer.Pen.Accuracy
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenHoverRangeTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4f3e9d8-dc05-4b6e-8f73-2afb4a839c73

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer hover range

Test details
Specifications
  • Device.Input.Digitizer.Pen.HoverRange
  • System.Client.Digitizer.Pen.HoverRange
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenHoverStationaryJitterTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03645be5-db99-421b-8334-d64555d08a69

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer hover stationary jitter

Test details
Specifications
  • Device.Input.Digitizer.Pen.Jitter
  • System.Client.Digitizer.Pen.Jitter
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenMoveLatencyTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ab9b187-78a8-451e-b749-58f10ee01bc9

Validate pen digitizer move latency

Test details
Specifications
  • Device.Input.Digitizer.Pen.Latency
  • System.Client.Digitizer.Pen.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenMovingJitterTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed6cf07a-0dae-4f59-be44-a9f339a1a64d

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer jitter, linearity, and report rate while in motion

Test details
Specifications
  • Device.Input.Digitizer.Pen.Jitter
  • System.Client.Digitizer.Pen.Jitter
  • Device.Input.Digitizer.Pen.ReportRate
  • System.Client.Digitizer.Pen.ReportRate
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenPhysicalDimensionsTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9cb9a3b1-253e-4217-9f9b-522b87433dc9

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer physical dimensions

Test details
Specifications
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenPressureLevelsTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3688889-01ad-4701-9447-346130d3c863

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer pressure levels

Test details
Specifications
  • Device.Input.Digitizer.Pen.Pressure
  • System.Client.Digitizer.Pen.Pressure
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenPressureMotionTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5fec5e9b-182f-4ecd-b7ef-ce97d313803c

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer pressure levels while in motion

Test details
Specifications
  • Device.Input.Digitizer.Pen.Pressure
  • System.Client.Digitizer.Pen.Pressure
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenResolutionTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a061c039-1704-410f-8bfe-5ed3b33c5644

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer input resolution

Test details
Specifications
  • Device.Input.Digitizer.Pen.Resolution
  • System.Client.Digitizer.Pen.Resolution
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenStationaryJitterTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80792d2c-649d-40dc-9a4e-b397fc5127d4

IMPORTANT

For most of the pen tests, we require Developer Mode to be enabled. Developer Mode is typically enabled through Settings > Update & security > For developers, but a known bug causes the Settings app to crash when this page is opened. To enable Developer Mode manually, follow these steps:

  • Run Gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
  • Edit the policies to enable Allow all trusted apps to install and Allows development of Microsoft Store apps and installing them from an integrated development environment (IDE)

Test pen digitizer jitter while stationary

Test details
Specifications
  • Device.Input.Digitizer.Pen.Jitter
  • System.Client.Digitizer.Pen.Jitter
  • Device.Input.Digitizer.Pen.HIDCompliant
  • System.Client.Digitizer.Pen.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation


PenThirdPartyDriverTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3cdf3c2-1b53-4101-abd0-13acd2694b78

Validate whether the pen digitizer uses only inbox drivers

Test details
Specifications
  • Device.Input.Digitizer.Pen.ThirdPartyDrivers
  • System.Client.Digitizer.Pen.ThirdPartyDrivers
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DQ | Device query string (unused in the test)


Proximity Sensor Data Field Properties Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49d2d6f6-ec16-4652-99ed-3719609f8b92

Verifies that the required data field properties are present for the applicable Proximity sensor data fields

Test details
Specifications
  • Device.Input.Sensor.Proximity.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Proximity Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba246900-6dd0-41a5-a7f2-fb6fd8919672

Verifies that the required data fields are present for the Proximity sensor

Test details
Specifications
  • Device.Input.Sensor.Proximity.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


ProximitySensor DriverFramework Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b579dd1c-e1e0-4774-b89a-0d506fc8a7a5

Verifies that the stack version of the sensor driver is V2

Test details
Specifications
  • Device.Input.Sensor.Proximity.WinRT.Discretional
  • Device.Input.Sensor.General.DriverFramework
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Relative Orientation Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e55b9db-3b15-48a6-906f-776973d99b14

Verifies that the required data fields are present for the Relative orientation sensor

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Relative Orientation Sensor Thresholds Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1675126-e872-4982-98e7-e06864a38b91

Verifies that the required thresholds fields are present in Relative Orientation Sensor

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.Thresholds
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Relative orientation sensor minimum report interval verification tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aac1d2ba-11ad-4941-94db-9fb8c6f7d999

Verifies if the sensor meets the minimum required report interval value

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.MinimumReportInterval
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Sensor HID Firmware Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/547bf976-15af-4632-a566-70ce639e3156

Test details
Specifications
  • Device.Input.Sensor.Base.HID.ReportDescriptor
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Benchmark
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID of the device under test. Ignore if all the sensor devices are to be tested


Sensor Location Data Report

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1ca0c4c-7ccb-4f04-a4cf-31d8585b4368

Test details
Specifications
  • Device.Input.LocationSensor.SupportRequiredDataFieldsForReport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LLU_LclAdminUsr
LLU_NetAccessOnly | LLU_NetAccessOnly
system_Template | system_Template
system_Build | system_Build


Sensor Minimum Supported Data Fields

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d05d14c1-52f3-4d7f-81c8-85fd5e1d936b

Test details
Specifications
  • Device.Input.LocationSensor.SupportDataTypesAndProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LLU_LclAdminUsr
LLU_NetAccessOnly | LLU_NetAccessOnly
system_Template | system_Template
system_Build | system_Build


Sensor Required Location Data Fields

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/956309eb-1a8e-4121-a250-3f2f382ed3e9

Test details
Specifications
  • Device.Input.LocationSensor.SupportRequiredDataFieldsForReport
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LLU_LclAdminUsr
LLU_NetAccessOnly | LLU_NetAccessOnly
system_Template | system_Template
system_Build | system_Build


Sensor Required Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbfa1c6e-582e-4baa-96d7-f53b872dc651

Test details
Specifications
  • Device.Input.LocationSensor.SupportDataTypesAndProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LLU_LclAdminUsr
LLU_NetAccessOnly | LLU_NetAccessOnly
system_Template | system_Template
system_Build | system_Build


Sensor Required Static Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96fb9563-f7ed-4fb4-8d30-288848800690

Test details
Specifications
  • Device.Input.LocationSensor.SupportDataTypesAndProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | LLU_LclAdminUsr
LLU_NetAccessOnly | LLU_NetAccessOnly
system_Template | system_Template
system_Build | system_Build


Sensor State Transition verification test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1556fb1f-ffea-4074-9aef-3b9079286733

Verifies that state of the sensors on the system (as defined in SENSOR_STATE) transitions as expected

Test details
Specifications
  • Device.Input.Sensor.Base.V2.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


SimpleDeviceOrientation Sensor Data Fields Verification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48982962-8b0f-45e8-9e3e-a1e0a066086c

Verifies that the required data fields are present for the SimpleDeviceOrientation sensor

Test details
Specifications
  • Device.Input.Sensor.SimpleDeviceOrientation.DataTypes
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Smart Card Minidriver Certification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14d1de87-ed46-4ee3-8fe7-2785f0c95106

This automated test verifies the operation of smart card minidrivers and associated smart cards.

Smart card minidrivers are software DLLs that are loaded by the Microsoft Base Cryptographic Service Provider (Base CSP) and the Microsoft Smart Card Key Storage Provider (SCKSP) to enable access to the functionality of the associated smart card. For smart card vendors, these minidrivers provide a simpler way to implement smart card functionality on Microsoft Windows operating systems than by developing a traditional Cryptographic Service Provider (CSP). (Historically smart card minidrivers were also referred to as smart card modules or smartcard card modules.)

This test performs functional, stress, performance, and reliability testing on a smart card minidriver. It calls the Microsoft BaseCSP and the Microsoft Smart Card Key Storage Provider and accesses the card minidriver methods directly, to test the correctness of operation of the card minidriver and the associated card. It also uses the Smart Card Resource Manager to access the card directly.

Test details
Specifications
  • Device.Input.SmartCardMiniDriver.SupportMultipleInstancesOnASystem
  • Device.Input.SmartCardMiniDriver.DoNotStopWhenResourcesAreUnavailable
  • Device.Input.SmartCardMiniDriver.SpecsAndCertifications
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Compatibility
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Smart Card Reader Testing Prerequisites.

In addition, this test requires the following hardware.

  • WHQL-certified smart card readers

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

In addition, for smart card-specific troubleshooting information, see the following websites:

  • Smart Card Minidriver Specification

  • Smart Card Minidriver Certification Requirements

More information

This test is located in Windows HLK Studio as a single job, although you can run the tool from outside the Windows HLK Studio environment also. Copy the binaries from the location that is specified below to a directory of your choice and you can run the test tool from there. You might also have to copy the Wttlog.dll shared library to your run directory. This DLL is installed with the Windows HLK client application.

Running the test tool outside the Windows HLK enables greater flexibility than running through the DTM because you can select tests individually. For more information, see the command line description later in this document.

If you are running the test from the Windows HLK, you need only one client computer. The Windows HLK documentation explains how to set up the Windows HLK controller, Windows HLK Studio, and Windows HLK client application on the test computer.

The following information applies to the computer that the test is being run on, regardless of whether you are running the tests inside or outside the Windows HLK environment.

To run the test, you must have your smart card minidriver installed on the computer and registered in the registry. (Also, for more information about certifying on a 64-bit version of the operating system, see the next section, "Certifying on a 64-bit version of the operating system"). And if your smart card device has the ISO 7816 ID-1 form factor, you must use a PC/SC compliant, WHQL-certified smart card reader for certification.

To run the tests, you must have two identical smart cards on the computer, and both must be in the prepared state, where prepared is defined by the Smart Card Minidriver Specification for Windows Base Cryptographic Service Provider (Base CSP) and Smart Card Key Storage Provider (KSP).

The tests that are run depend on the capabilities of the smart card minidriver. The capability of the smart card minidriver can be defined for the test tool in a specific configuration file that is named cmck_config.xml, which you must put in the C:\SmartCardMinidriverTest directory. The description of this file and a sample follow.

In a typical test run, if no configuration file is found, the test will ask you for confirmation to continue by using default values. For a logo submission however, you must supply a configuration file that matches the capability of your minidriver and card combination.

The default key values are as follows:

  • The default user pin is 0000.

  • The default administration key for challenge/response is all zeros.

Certifying on a 64-bit version of the operating system

When you certify on a 64-bit version of the operating system, you must also have the 32-bit version of your minidriver DLL installed on the system. You can put the DLL in the %systemroot%\syswow64 subdirectory. You must put registry entries for the 32-bit version of the DLL under HKEY_LOCAL_MACHINE\SOFTWARE\wow6432Node\Microsoft\Cryptography\Calais\SmartCards.

When a 32-bit application that uses the minidriver is executed, it loads the 32-bit version of the minidriver.

INF file for a smart card minidriver

When you make a certification submission, you must supply an .inf file. Here is the sample .inf file for x86 architecture:

[Version]
Signature="$Windows NT$"
Class=SmartCard
ClassGuid={990A2BD7-E738-46c7-B26F-1CF8FB9F1391}
Provider=%ProviderName%
CatalogFile=delta.cat
DriverVer=06/21/2006,6.1.6473.1

[DefaultInstall]
CopyFiles=System32_CopyFiles
AddReg=MiniDriver_AddReg

[Manufacturer]
%ProviderName%=CompanyName,NTx86,NTx86.6.1

[CompanyName.NTx86]
%ScSuperCardDeviceName%=ScSuperCard_Install,SCFILTER\CID_51FF0800

[CompanyName.NTx86.6.1]
%ScSuperCardDeviceName%=ScSuperCard61_Install,SCFILTER\CID_51FF0800

[SourceDisksFiles]
supercm.dll=1

[SourceDisksNames]
1 = %MediaDescription%

[ScSuperCard_Install.NT]
CopyFiles=System32_CopyFiles
AddReg=MiniDriver_AddReg

[ScSuperCard61_Install.NT]
CopyFiles=System32_CopyFiles
AddReg=MiniDriver_AddReg

[SCSuperCard61_Install.NT.Services]
Include=umpass.infNeeds=UmPass.Services

[UMPassService_Install]
DisplayName=%umpass.SVCDESC%

; Friendly Name of the Service
ServiceType    = 1                    ;SERVICE_KERNEL_DRIVER
StartType      = 3                    ;SERVICE_DEMAND_START
ErrorControl   = 1                    ;SERVICE_ERROR_NORMAL
ServiceBinary  = %12%\umpass.sys
LoadOrderGroup = Extended Base

[System32_CopyFiles]
supercm.dll

[MiniDriver_AddReg]
HKLM,%SmartCardName%,"ATR",0x00000001,3b,04,51,ff,08,00
HKLM,%SmartCardName%,"ATRMask",0x00000001,ff,ff,ff,ff,ff,ff
HKLM,%SmartCardName%,"Crypto Provider",0x00000000,"Microsoft Base Smart Card Crypto Provider"
HKLM,%SmartCardName%,"Smart Card Key Storage Provider",0x00000000,"Microsoft Smart Card Key Storage Provider"
HKLM,%SmartCardName%,"80000001",0x00000000,%SmartCardCardModule%

[DestinationDirs]
System32_CopyFiles=10,system32

[FriendlyName]
ScFriendlyName="Super Card"
; =================== Generic ==================================

[Strings]
ProviderName="ACME"
MediaDescription="Super Card Mini Driver Installation Disk"
SCSuperCardDeviceName="Super Card Mini-driver"
SmartCardName="SOFTWARE\Microsoft\Cryptography\Calais\SmartCards\Super Card"
SmartCardCardModule="supercm.dll"
umpass.SVCDESC = "Microsoft UMPass Driver" Inf file sample for x64 architecture: [Version]
Signature="$Windows NT$"
Class=SmartCard
ClassGuid={990A2BD7-E738-46c7-B26F-1CF8FB9F1391}
Provider=%ProviderName%
CatalogFile=delta.cat
DriverVer=06/21/2006,6.1.6473.1

[DefaultInstall]
CopyFiles=System32_CopyFiles
CopyFiles=Syswow64_CopyFiles
AddReg=MiniDriver_AddReg

[Manufacturer]
%ProviderName%=CompanyName,NTamd64,NTamd64.6.1

[CompanyName.NTamd64]
%ScSuperCardDeviceName%=ScSuperCard_Install,SCFILTER\CID_51FF0800

[CompanyName.NTamd64.6.1]
%ScSuperCardDeviceName%=ScSuperCard61_Install,SCFILTER\CID_51FF0800

[SourceDisksFiles]
supercm64.dll=1
supercm.dll=1

[SourceDisksNames]
1 = %MediaDescription%

[ScSuperCard_Install.NT]
CopyFiles=System32_CopyFiles
CopyFiles=Syswow64_CopyFiles
AddReg=MiniDriver_AddReg

[ScSuperCard61_Install.NT]
CopyFiles=System32_CopyFiles
CopyFiles=Syswow64_CopyFiles
AddReg=MiniDriver_AddReg

[SCSuperCard61_Install.NT.Services]
Include=umpass.inf
Needs=UmPass.Services

[UMPassService_Install]
DisplayName    = %umpass.SVCDESC%

; Friendly Name of the Service
ServiceType    = 1                    ;SERVICE_KERNEL_DRIVER
StartType      = 3                    ;SERVICE_DEMAND_START
ErrorControl   = 1                    ;SERVICE_ERROR_NORMAL
ServiceBinary  = %12%\umpass.sys
LoadOrderGroup = Extended Base

[System32_CopyFiles]
supercm.dll,supercm64.dll

[Syswow64_CopyFiles]
supercm.dll

[MiniDriver_AddReg]
HKLM,%SmartCardName%,"ATR",0x00000001,3b,04,51,ff,08,00
HKLM,%SmartCardName%,"ATRMask",0x00000001,ff,ff,ff,ff,ff,ff
HKLM,%SmartCardName%,"Crypto Provider",0x00000000,"Microsoft Base Smart Card Crypto Provider"
HKLM, %SmartCardName%,"Smart Card Key Storage Provider",0x00000000,"Microsoft Smart Card Key Storage Provider"
HKLM,%SmartCardName%,"80000001",0x00000000,%SmartCardCardModule%
HKLM,%SmartCardNameWOW64%,"ATR",0x00000001,3b,04,51,ff,08,00
HKLM,%SmartCardNameWOW64%,"ATRMask",0x00000001,ff,ff,ff,ff,ff,ff
HKLM,%SmartCardNameWOW64%,"Crypto Provider",0x00000000,"Microsoft Base Smart Card Crypto Provider"
HKLM,%SmartCardNameWOW64%,"Smart Card Key Storage Provider",0x00000000,"Microsoft Smart Card Key Storage Provider"
HKLM,%SmartCardNameWOW64%,"80000001",0x00000000,%SmartCardCardModule%

[DestinationDirs]
System32_CopyFiles=10,system32
Syswow64_CopyFiles=10,syswow64

[FriendlyName]
ScFriendlyName="Super Card"
; =================== Generic ==================================

[Strings]
ProviderName="ACME"
MediaDescription="Super Card Mini Driver Installation Disk"
SCSuperCardDeviceName="Super Card Mini-driver"
SmartCardName="SOFTWARE\Microsoft\Cryptography\Calais\SmartCards\Super Card"
SmartCardNameWOW64="SOFTWARE\Wow6432Node\Microsoft\Cryptography\Calais\SmartCards\Microsoft Virtual Card"
SmartCardCardModule="supercm.dll"
SmartCardCardModule64="supercm64.dll"
umpass.SVCDESC = "Microsoft UMPass Driver"

Smart Card Minidriver Configuration File Description (cmck_config.xml)

CMCK_config.xml consists of below sections for V5, V6, and V7, depending on the versions V5/V6/V7 your minidriver supported. Please note: V5/V6/V7 keywords are uppercased.

<CMCKConfig>
  <V5>...</V5>
  <V6>...</V6>
  <V7>...</V7>
</CMCKConfig>

Each section is filled up with the XML tags described below. Please also note each section may have different settings which depends on what the minidriver supports for that versions.

You can set the following values in each section of the configuration file (in the structure as shown):

  • <Version> is a mandatory field that defines the configuration file's version number. Currently, the expected version is "2" of the CMCK XML configuration file for V6 and V7 sections, and "1" for V5 section.

  • <CardDefaults> contains parameters that are used both for the certification run and for regular test runs.

    • <DefaultPins> - pin values that must be used for authentication-related functions

      <PinEntry><RoleID> - allowed value: 1 - 7

      <PinEntry><Type> - allowed value: "AlphanumericPinType", "ChallengeResponsePinType", "EmptyPinType", "ExternalPinType"

      <PinEntry><Value> - list of space-separated hexadecimal bytes of the pin. Default value: "0x30 0x30 0x30 0x30" (that is "0000")

      <PinEntry><Blocking> [BOOLEAN] - states if the card supports blocking the card for this kind of user when the wrong pin is presented too many times. Default "True".

      <PinEntry><Linking> [BOOLEAN] - states if this pin is linked to another pin, i.e changing one pin will make the other one changed. Default "False".

      <PinEntry><AllowZeroLength> [BOOLEAN] - states if the card allows the pin to be empty. Default "False".

  • <CardSupports> -defines optional features that are supported by the card or card minidriver, such as algorithms, key types, and so on. The test will cover the supported features.

    1. <MinimumVersion> [DWORD] contains the minimum version of the context CARD_DATA structure that the card minidriver supports. For more information, see the Smart Card Minidriver specification. The allowed value is "4," "5," "6," "7".

    2. <CurrentVersion> [DWORD] contains the version of the context CARD_DATA structure for which the card minidriver was designed. For more information, see the Smart Card Minidriver specification. The allowed value is "5," "6," "7".

    3. <LoadingUnderCAPI> [BOOLEAN] is "True" if the card minidriver supports being loaded under CAPI and is "False" otherwise.

    4. <LoadingUnderCNG> [BOOLEAN] is "True" if the card minidriver supports being loaded under CNG and is "False" otherwise. Note that at least one of the two attributes must be "True" (CAPI or CNG).

    5. <KeyImport> [BOOLEAN] is "True" if the card minidriver supports key import and is "False" otherwise.

    6. <KeyTypes> contains space-separated list of key types that the card minidriver supports. The allowed values are "AT_ECDH_P256", "AT_ECDH_P384", "AT_ECDH_P521", "AT_ECDSA_P256", "AT_ECDSA_P384", or "AT_ECDSA_P521" for ECC keys and "AT_SIGNATURE" or "AT_KEYEXCHANGE" for RSA keys. <OnCardPadding> [BOOLEAN] is "True" if on-card padding is supported and is "False" otherwise.

    7. <PaddingAlgorithms> contains a space-separated list of supported on-card padding algorithms (only valid when <OnCardPadding> is "True"). The allowed values are "CARD_PADDING_NONE", "CARD_PADDING_PKCS1", and "CARD_PADDING_PSS".

    8. <SignHashAlgorithms> contains a space-separated list of hash algorithms that the card minidriver supports for signing (aiHashAlg in the CARD_SIGNING_INFO structure). Allowed values are "CALG_MD2", "CALG_MD4", "CALG_MD5", "CALG_SHA", "CALG_SHA1", "CALG_SHA_256", CALG_SHA_384" and CALG_SHA_512". For more details, see the Smart Card Minidriver specification.

    9. <SignHashFlags> contains a space-separated list of CryptSignHash flags that the card minidriver supports. The allowed values are "CRYPT_NOHASHOID" and "CRYPT_X931_FORMAT".

    10. <SignReturnBufferSize> [BOOLEAN] is "True" when the card minidriver supports the CARD_BUFFER_SIZE_ONLY value for dwSigningFlags in the CARD_SIGNING_INFO structure. For more information, see the Smart Card Minidriver specification.

    11. <KDFTypes> contains a space-separated list of key derive functions that the card minidriver supports. The allowed values are "HASH", "HMAC", "TLS_PRF", and "SP800_56A_CONCAT". For more information, see the Smart Card Minidriver specification.

    12. <KDFHashAlgorithms> contains a space-separated list of hash algorithms that the card minidriver supports for the key derivation functions (KDF). The Smart Card Minidriver specification contains more details. The allowed values are defined in the bcrypt.h header file and are the values for BCRYPT_XXXX_ALGORITHM defines (for example, "SHA256" (BCRYPT_SHA256_ALGORITHM) or "MD5" (BCRYPT_MD5_ALGORITHM)).

    13. <Uses2Key3DES> [BOOLEAN] is "True" if the card minidriver ONLY supports 2 key 3DES. When this value is "False", it indicates the card minidriver use default 3 key 3DES. Default value is "False".

    14. <KDFHMACFlag> [BOOLEAN] is "True" if the card minidriver supports the BCRYPT_KDF_HMAC key derive function that has the KDF_USE_SECRET_AS_HMAC_KEY_FLAG flag (see the Crypto Next Generation (CNG) documentation available on MSDN CNG for more information). When this value is "False", the test will provide an explicit HMAC key and will not set the KDF_USE_SECRET_AS_HMAC_KEY_FLAG flag for affected tests.

    15. <ChallengePadding>[BOOLEAN] is "True" if the return of card challenge data contains a padding bit. Default value is "False".

    16. <SupportsCardGetChallenge> [BOOLEAN] - "True" if CM supports CardGetChallenge API (this is used for read only cards).

    17. <SupportsCardAuthenticateChallenge> [BOOLEAN] - "True" if CM supports CardAuthenticateChallenge API (this is used for read only cards).

    18. <SupportsCardGetChallengeEx> [BOOLEAN] - "True" if CM supports CardGetChallengeEx API (this is used for read only cards).

    19. <SupportsCardUnblockPin> [BOOLEAN] - "True" if CM supports CardUnblockPin API (this is used for read only cards).

    20. <SupportsCardChangeAuthenticator> [BOOLEAN] - "True" if CM supports CardChangeAuthenticator API (this is used for read only cards).

    21. <SupportsCardChangeAuthenticatorEx> [BOOLEAN] - "True" if CM supports CardChangeAuthenticatorEx API (this is used for read only cards).

  • <TestSuiteDefaults> contains parameters that influence the test runs only. (The certification run uses its own default values.)

    1. <INF> contains information about INF file that is used in smartcard PnP.

      • <INFFile> contains the location and file name for the smartcard PnP INF file, which matches the smartcard/minidriver to be tested. This is mandatory for all minidrivers other than in-box PIV/GICS class minidriver.

    2. <Logging> contains logging options that apply to the test runs

      1. <LogFile> contains the location and file name for the XML log file. The default is "CMCK_log.xml" (which means that the file will be created in the current directory). Note that the log file will be overwritten.

      2. <LogToConsole> [BOOLEAN] is "True" when the logs will be displayed on the console along with writing to the log file. The default value is "True".

      3. <CertifyLogLevel> specifies the log level (0, 1, or 2). 0 means minimal logging, 1 logs function entry and exit, and 2 means full logging. Full logging is always used when you run tests individually and is mainly to help with development. When you are making a logo submission, we recommend setting the log level to 0.

Configuration File Structure

The following code example shows a sample configure file.

<CMCKConfig>
  <V6>
    <Version>2</Version>
    <CardDefaults>
      <DefaultPins>
        <PinEntry>
          <RoleID>1</RoleID>
          <Type>AlphaNumericPinType</Type>
          <Value>0x30 0x30 0x30 0x30</Value>
          <Blocking>True</Blocking>
          <AllowZeroLength>False</AllowZeroLength>
        </PinEntry>
        <PinEntry>
          <RoleID>2</RoleID>
          <Type>ChallengeResponsePinType</Type>
          <Value>0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00</Value>
          <Blocking>True</Blocking>
          <AllowZeroLength>False</AllowZeroLength>
        </PinEntry>
        <PinEntry>
          <RoleID>3</RoleID>
          <Type>AlphaNumericPinType</Type>
          <Value>0x30 0x30 0x30 0x30</Value>
          <Blocking>True</Blocking>
          <AllowZeroLength>False</AllowZeroLength>
        </PinEntry>
        <PinEntry>
         <RoleID>4</RoleID>
         <Type>AlphaNumericPinType</Type>
         <Value>0x30 0x30 0x30 0x30</Value>
         <Blocking>True</Blocking>
         <AllowZeroLength>False</AllowZeroLength>
       </PinEntry>
       <PinEntry>
          <RoleID>5</RoleID>
          <Type>AlphaNumericPinType</Type>
          <Value>0x30 0x30 0x30 0x30</Value>
          <Blocking>True</Blocking>
          <AllowZeroLength>False</AllowZeroLength>
       </PinEntry>
       <PinEntry>
         <RoleID>6</RoleID>
         <Type>AlphaNumericPinType</Type>
         <Value>0x30 0x30 0x30 0x30</Value>
         <Blocking>True</Blocking>
         <AllowZeroLength>False</AllowZeroLength>
        </PinEntry>
        <PinEntry>
          <RoleID>7</RoleID>
          <Type>AlphaNumericPinType</Type>
          <Value>0x30 0x30 0x30 0x30</Value>
          <Blocking>True</Blocking>
          <AllowZeroLength>False</AllowZeroLength>
        </PinEntry>
      </DefaultPins>
      <CardSupports>
        <MinimumVersion>4</MinimumVersion>
        <CurrentVersion>6</CurrentVersion>
        <LoadingUnderCAPI>True</LoadingUnderCAPI>
        <LoadingUnderCNG>True</LoadingUnderCNG>
        <KeyImport>True</KeyImport>
        <KeyTypes>AT_SIGNATURE AT_KEYEXCHANGE</KeyTypes>
        <OnCardPadding>False</OnCardPadding>
        <PaddingAlgorithms>CARD_PADDING_PKCS1</PaddingAlgorithms>
        <SignHashAlgorithms>CALG_MD5 CALG_SHA CALG_SHA1 CALG_SHA_256 CALG_SHA_384 CALG_SHA_512</SignHashAlgorithms>
        <SignHashFlags />
        <SignReturnBufferSize>True</SignReturnBufferSize>
        <KDFTypes>HASH</KDFTypes>
        <KDFHashAlgorithms>SHA1 SHA256 SHA384 SHA512</KDFHashAlgorithms>
        <KDFHMACflag>False</KDFHMACflag>
        <SupportsCardGetChallenge>True</SupportsCardGetChallenge>
        <SupportsCardAuthenticateChallenge>True</SupportsCardAuthenticateChallenge>
        <SupportsCardGetChallengeEx>True</SupportsCardGetChallengeEx>
        <SupportsCardUnblockPin>True</SupportsCardUnblockPin>
        <SupportsCardChangeAuthenticator>True</SupportsCardChangeAuthenticator>
        <SupportsCardChangeAuthenticatorEx>True</SupportsCardChangeAuthenticatorEx>
      </CardSupports>
    </CardDefaults>
    <TestSuiteDefaults>
      <INF>
        <INFFile>C:\SmartcardMinidriverTest\minidriver.inf</INFFile>
      </INF>
      <Logging>
        <LogFile>CMCK_log.xml</LogFile>
        <LogToConsole>True</LogToConsole>
      </Logging>
      <TestParams>
        <TestParam>
          <Test>MultiThreaded</Test>
          <Name>t</Name>
          <Value>5</Value>
        </TestParam>
        <TestParam>
          <Test>MultiThreaded</Test>
          <Name>n</Name>
          <Value>5</Value>
        </TestParam>
        <TestParam>
          <Test>NonRepeatingChallenge</Test>
          <Name>n</Name>
          <Value>300</Value>
        </TestParam>
      </TestParams>
    </TestSuiteDefaults>
  </V6>
  <V5>
    <Version>1</Version>
      <CardDefaults>
        <DefaultPins>
          <PinEntry>
            <Type>User</Type>
            <Value>0x30 0x30 0x30 0x30</Value>
            <Blocking>True</Blocking>
            <AllowZeroLength>False</AllowZeroLength>
          </PinEntry>
        </DefaultPins>
        <DefaultKeys>
          <KeyEntry>
            <Type>Admin</Type>
            <Algorithm>3DES</Algorithm>
            <Mode>ECB</Mode>
            <Blocking>True</Blocking>
            <Value>0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00</Value>        </KeyEntry>
        </DefaultKeys>
        <CardSupports>
          <MinimumVersion>4</MinimumVersion>
          <CurrentVersion>6</CurrentVersion>
          <LoadingUnderCAPI>True</LoadingUnderCAPI>
          <LoadingUnderCNG>True</LoadingUnderCNG>
          <KeyImport>True</KeyImport>
          <KeyTypes>AT_SIGNATURE AT_KEYEXCHANGE</KeyTypes>
          <OnCardPadding>False</OnCardPadding>
          <PaddingAlgorithms>CARD_PADDING_NONE</PaddingAlgorithms>
          <SignHashAlgorithms>CALG_MD5 CALG_SHA CALG_SHA1</SignHashAlgorithms>
          <SignHashFlags>CRYPT_NOHASHOID</SignHashFlags>
          <SignReturnBufferSize>False</SignReturnBufferSize>
          <KDFTypes>HASH</KDFTypes>
          <KDFHashAlgorithms>SHA1 SHA256 SHA384 SHA512</KDFHashAlgorithms>
          <KDFHMACflag>False</KDFHMACflag>
      </CardSupports>
    </CardDefaults>
    <TestSuiteDefaults>
      <INF>
        <INFFile>C:\SmartcardMinidriverTest\minidriver.inf</INFFile>
      </INF>
      <Logging>
        <LogFile>CMCK_log.xml</LogFile>
        <LogToConsole>True</LogToConsole>
      </Logging>
      <TestParams>
        <TestParam>
          <Test>MultiThreaded</Test>
          <Name>t</Name>
          <Value>5</Value>
        </TestParam>
        <TestParam>
          <Test>MultiThreaded</Test>
            <Name>n</Name>
            <Value>5</Value>
        </TestParam>
        <TestParam>
          <Test>NonRepeatingChallenge</Test>
            <Name>n</Name>
            <Value>300</Value>
        </TestParam>
      </TestParams>
    </TestSuiteDefaults>
  </V5>
</CMCKConfig>

Command syntax

Command option | Description
cmck <command> [options] | Runs the test.
NOTE

For command-line help for this test binary, type cmck help [command]

File list

File | Location
cmck.exe | <[testbinroot]>\nttest\dstest\security\core\bin\credentials\smartcard
cmck_simuse.exe | <[testbinroot]>\nttest\dstest\security\core\bin\credentials\smartcard
intrcptr.dll | <[testbinroot]>\nttest\dstest\security\core\bin\credentials\smartcard

Parameters

Parameter name | Parameter description
WDKDeviceID |
LLU_NetAccessOnly |


Test.Aliasing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bfd64bac-b26c-44af-96fd-b78c09b860c3

The test verifies that the device can track and report unique continually arriving and departing contacts without aliasing at fixed separation distances.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.FingerSeparation
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Alternate between 2 fingers ~15mm apart, and tap the touchpad at 240 taps/minute.

    When you tap, hold down a contact until it is time to make another tap with that contact, rather than making light taps (to interleave the down times of the two contacts).

  2. Verify that after tapping for ten seconds, no line is drawn between these contacts (see Common Errors in this topic for an example of a failure).

  3. Repeat steps 1 and 2 by having fingers aligned on the vertical axis.

  4. Repeat steps 1 and 2 by having fingers aligned on the diagonal axis.

  5. Manually pass the iteration if validations in all axes were successful.

  6. Repeat steps 1 through 5 by having fingers ~40mm apart.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error | Description/Workaround
[20] Positional delta too large ### | Aliasing caused device contact swap, thereby causing the device to report a quick swipe. The value represents the displacement distance. Any displacement > 270 (2.7mm) causes this error.

More information

Command syntax

Command | Description
ptlogo.exe Test.Aliasing.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.Aliasing.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.AllAreas

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45b3fbcc-9f39-4c61-993b-10a62324b81b

This manual test verifies that a Windows Precision Touchpad device reports contacts when any physical area of the touchpad is touched.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Accuracy
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

The test presents five iterations during which you are prompted to touch a contact to the touchpad in a specified region. At the prompt, you should tap a total of five times per region at random unique points inside that region.

In each case, the test validates that a tap occurs in the specified region. If a tap is detected, the test automaticallyes pass the iteration. If no tap is detected after any physical tap in the specified region, you should manually fail the iteration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

To run the test outside of Windows Hardware Lab Kit (Windows HLK) Studio, type the following command in a command prompt window that has administrative privileges:

PTLogo.exe Test.AllAreas.json


Test.AudioTouch

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ef0e4cd-9e02-4131-90cf-c46a0132dc33

This test verifies that device meets the touch down latency requirements (average latency <25ms).

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

To finish this test, see How to Measure Touch Down Latency by using an Acoustic Measurement Tool.

Use pttouch.exe instead of the touch file.

Only 50 taps during the collection phase are required for PTP.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
Ptaudiotouch.exe | Runs the test.

File list

File | Location
ptaudiotouch.exe | <testbinroot>\input\PrecisionTouchpad</p>


Test.Buffering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c544d252-7dfc-440e-8f59-cc94054dd026

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Buffering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Test.Confidence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ccfa629-7039-4234-94e0-74ad9199d382

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Test.ConvergeDivergeDiagonal

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67e82275-e184-466c-8539-8cdf5103df2a

This test verifies that two contacts are reported properly when converged and diverged within 14 millimeters of each other.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.FingerSeparation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

This test requires contacts that move very precisely in very specific distances. It is recommended that a precision rig or robotic solution is used to perform these tests.

  1. Place two 7 millimeter precision contacts on touchpad device next to each other vertically separated by distance as instructed on the screen.

  2. As instructed, move contacts diagonally (at a 45 degree angle) either towards each other or apart. Five iterations per direction for both converge and diverge. If the two contacts remain distinct and no errors are detected, the test will automatically pass each iteration and advance to the next.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

If you get an error of "[17] not enough separate of points" or "[18] too much separation of points: ####", ensure that the widest distance between two contacts is always > 30mm and the smallest distance is always < 11mm.

More information

Command syntax

Command | Description
ptlogo.exe Test.ConvergeDivergeDiagonal.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.ConvergeDivergeDiagonal.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.DeviceButton

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/784c4fd2-25d9-4729-a413-a9a9f8997697

This manual test verifies that a Windows Precision Touchpad button can be depressed.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Buttons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

There are two iterations of this test, as follows.

  1. Iteration 1: Button presses with capacitive contacts

    1. Following the instructions on the screen, put one finger on the center of the touchpad surface, and depress the physical button. Verify that the button state is down (the grey bar in the test should turn green), and that the button state returns to off when the pressure is removed.

    2. Repeat the last step with 2, 3… N contacts, where N is the maximum number of contacts that are supported by the device.

      If the touchpad's physical button is reported anytime it is depressed, and stops being reported as soon as it is released, manually pass the iteration.

  2. Iteration 2: Button presses with non-capacitive contacts

    1. Place a non-capacitive contact on the center of the touchpad surface, and apply pressure to depress the physical button. Verify that the button state is down (the grey bar in PTLogo should turn green), and that the button state returns to off when the pressure is removed.

    2. If the touchpad's physical button is reported anytime it is depressed, and stops being reported as soon as it is released, manually pass the iteration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

To run the test outside of Windows Hardware Lab Kit (Windows HLK) Studio, type the following command in a command prompt window that has administrative privileges:

PTLogo.exe Test.DeviceButton.json


Test.DeviceClickPressure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94cdf7ba-da0d-4d5f-9774-50951fe50606

This test verifies that the device properly registers a click based on the amount of pressure applied to the surface of the touchpad.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Buttons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

NOTE

You just have a 140g and 190g 7 millimeter metal slug.

For this test, you will be verifying the pressure needed to register a click on the touchpad in 5 locations. These locations are slightly different, depending on whether your device is a clickpad or a pressurepad. On a pressurepad, the points map directly to the center of the touchpad and the 4 corners. On a clickpad, we bisect the touchpad in half and test the four corners and center of the bottom half of the clickpad.

Iteration 1

  1. Place the 140g slug next to the bottom left corner of the device, but not touching the device (resting on the surrounding casing of the touchpad).

  2. Carefully slide the slug onto the touchpad, to the bottom left corner.

  3. Verify that no button click is reported (the bar at the bottom of the screen should stay grey and not turn green). If no button click is reported, press P to pass the iteration. Otherwise, press F to fail.

Iteration 2

  • Repeat the steps in Iteration 1 in the bottom right corner of the device.

Iteration 3

  1. Carefully place the 140g slug on the bottom left corner of the touchpad surface.

  2. Slide the slug upwards to the top left corner of the touchpad.

  3. Verify that no button click is reported (the bar at the bottom of the screen should stay grey and not turn green). If no button click is reported, press P to pass the iteration. Otherwise, press F to fail.

Iteration 4

  • Repeat the steps in Iteration 3, but slide the slug from the bottom right corner to the top right corner.

Iteration 5

  • Repeat the steps in Iteration 3, but slide the slug from the bottom left corner to the center of the touchpad.

Iteration 6

  1. Repeat actions of iteration 1 using a 190g slug instead of the 140g slug.

  2. If grey bar in PTLogo turns green when the slug is down and back to grey when the slug is removed, then press P to manually pass the iteration. Otherwise, press F to manually fail the iteration.

Iteration 7

  1. Repeat actions of iteration 2 using a 190g slug instead of the 140g slug.

  2. If grey bar in PTLogo turns green when the slug is down and back to grey when the slug is removed, then press P to manually pass the iteration. Otherwise, press F to manually fail the iteration.

Iteration 8

  1. Repeat actions of iteration 3 using a 190g slug instead of the 140g slug.

  2. If grey bar in PTLogo turns green when the slug is down and back to grey when the slug is removed, then press P to manually pass the iteration. Otherwise, press F to manually fail the iteration.

Iteration 9

  1. Repeat actions of iteration 4 using a 190g slug instead of the 140g slug.

  2. If grey bar in PTLogo turns green when the slug is down and back to grey when the slug is removed, then press P to manually pass the iteration. Otherwise, press F to manually fail the iteration.

Iteration 10

  1. Repeat actions of iteration 5 using a 190g slug instead of the 140g slug.

  2. If grey bar in PTLogo turns green when the slug is down and back to grey when the slug is removed, then press P to manually pass the iteration. Otherwise, press F to manually fail the iteration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.DeviceClickPressure.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.DeviceClickPressure.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.DeviceHeight

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a8032d1-6a44-4445-bf8e-e9789f564af5

This manual test verifies that a Windows Precision Touchpad height is reported correctly by the device.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Dimensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

The test asks you to validate that the physical height of the touchpad is the same as that reported by the device. You should measure the height of the touchpad by using a ruler, and compare that value to the value that is displayed by the test. If the values match*, you should manually pass the test. If they do not match, you should fail the test.

NOTE

*Because the digitizer might be slightly smaller than the physical device, the measured height can be as much as 4mm greater than that which is reported by the device.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

To run the test outside of Windows Hardware Lab Kit (Windows HLK) Studio, type the following command in a command prompt window that has administrative privileges:

PTLogo.exe Test.DeviceHeight.json


Test.DeviceType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53bd9b9f-665f-4516-a9c5-365d9dcd2d81

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.DeviceTypeReporting
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Test.DeviceWidth

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5e29276-542d-45a1-bee0-07b9891d5af6

This manual test verifies that a Windows Precision Touchpad width is reported correctly by the device.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Dimensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

The test asks you to validate that the physical width of the touchpad is the same as that reported by the device. You should measure the width of the touchpad by using a ruler, and compare that value to the value that is displayed by the test. If the values match*, you should manually pass the test. If they do not match, you should fail the test.

NOTE

Because the digitizer might be slightly smaller than the physical device, the measured width can be as much as 4mm greater than that which is reported by the device and still pass the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

To run the test outside of Windows Hardware Lab Kit (Windows HLK) Studio, type the following command in a command prompt window that has administrative privileges:

PTLogo.exe Test.DeviceWidth.json


Test.ExternalButtons

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e35f8df-ae0b-4b79-8a0a-f72a2b21beaf

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Buttons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Test.GhostReporting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5a349a3-4487-4dbe-9aa0-69e54ed8bbad

This manual test verifies that a Windows Precision Touchpad device does not report data for locations where input does not occur.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

The test presents two iterations, during which you are prompted to refrain from touching the touchpad for 60 seconds. If the system has an external power source, it should be unplugged for the second iteration.

In each case, the test validates that no contacts are registered on the touchpad as expected.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

To run the test outside of Windows Hardware Lab Kit (Windows HLK) Studio, type the following command in a command prompt window that has administrative privileges:

PTLogo.exe Test.GhostReporting.json


Test.InputResolution

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2bc34740-73c5-4a63-a9fd-a7bab6051a55

This test verifies the device resolution by ensuring that it can support what it reports. Between two slow swipes, every logical unit of X should be hit, and every value of Y when moving down and up vertically.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.InputResolution
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Drag one precision contact across the touchpad at 1-2mm/second from left to right, and again from right to left. (This can be done anywhere in the middle 80% of the touchpad surface.)

    All Y-axis movement or jitter is ignored in this test when measuring X values (and vice-versa), so if the PT3 cannot move smoothly at a slow pace, a precision contact can be moved by hand across the touchpad to avoid extra friction.

  2. Repeat vertically, dragging first from top to bottom, then from bottom to top.

NOTE

If all logical x/y coordinates are hit after one swipe on that axis, the test automatically passes without a swipe in the other direction. This is expected.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error | Description/Workaround
[20] positional delta too large | There was a jump in X coordinates between 2 packets. To investigate, open the Hid log in Excel, add a column for DeltaX, and populate it with the differences between the X's. You can then filter out 0s (packets in which the contact has not yet moved horizontally), and expected 1s.
[35] logical coordinate not found | Either the minimum or maximum value was never hit in the two passes. The number given is the X or Y value which was not hit (depending on whether the iteration is for horizontal or vertical drags, respectively).
[31] Too low percent of logical coordinates found | Less than 80% of the logical coordinates were reported during the duration of the test.

More information

Command syntax

Command | Description
ptlogo.exe Test.InputResolution.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.InputResolution.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.LinearityDiagonal

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5eba881d-82b3-40ec-8a75-ad1a320fcb56

This test verifies that the touchpad reports a straight line (that corresponds to contact movement) when a single contact is moved diagonally across the surface of a touchpad (within a tolerance of .5mm).

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

This test requires very precise movement in a straight line. We recommend that you perform this test by using a precision rig or other precision device that is capable of straight line movement without any jitter.

  1. Place two precision contacts slightly outside the top left corner of the touchpad.

  2. Drag that contact in a straight line from the top left to the bottom right corner of the touchpad.

  3. Drag the contact from the bottom right up to the top left.

  4. Repeat this pattern for a total of five iterations.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error Description/Workaround

[15] contact didn't move in straight line

Reported path strayed varied from a straight line by more than the allowed tolerance.

[14] packet too far from edge: ###

  • Swipe must start at or before the edge.

  • Swipe must go all the way to the opposite edge. Performing swipe too quickly might not allow the device to fully report.

More information

Command syntax

Command | Description
ptlogo.exe Test.LinearityDiagonal.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.LinearityDiagonal.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.LinearityDiagonalMultiple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7011cee4-ad29-40d0-ac32-904e2642b150

This test verifies that the touchpad reports a straight line (that corresponds to contact movement) when two contacts that are 14mm apart are moved diagonally across the surface of a touchpad (within a tolerance of .5mm).

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.FingerSeparation
  • Device.Input.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

This test requires very precise movement in a straight line. We recommend that you perform this test by using a precision rig or other precision device that is capable of straight line movement without any jitter.

  1. Place two precision contacts 14mm apart slightly outside the top left corner of the touchpad.

  2. Drag the contacts in a straight line from the top left to the bottom right corner of the touchpad.

  3. Drag the contacts back from the bottom right up to the top left.

  4. Repeat this pattern for a total of five iterations.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error Description/Workaround

[15] contact didn't move in straight line

Reported path strayed varied from a straight line by more than the allowed tolerance.

[14] packet too far from edge: ###

  • Swipe must start at or before the edge.

  • Swipe must go all the way to the opposite edge. Performing swipe too quickly might not allow the device to fully report.

More information

Command syntax

Command | Description
ptlogo.exe Test.LinearityDiagonalMultiple.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.LinearityDiagonalMultiple.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.MinMaxContacts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/634ec9ff-268c-4b74-9cdf-a9147c71848a

This test verifies that the device supports the minimum amount of contacts required (3) and does not support more than the maximum number of contacts (5).

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.MinMaxContacts
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

The tool automatically passes/fails the requirement based on how many contacts the device reports that it supports.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error | Description/Workaround
[23] device doesn't support minimum number of contacts:# | Device supports less than 3 contacts.
[[24] device supports too many contacts:# | Device supports more than 5 contacts.

More information

Command syntax

Command | Description
ptlogo.exe Test.MinMaxContacts.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.MinMaxContacts.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.PositionalAccuracy

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/352586f7-adf8-439e-8b34-d5bdca83a86e

This test verifies that the position reported from the device accurately represents the position a contact was placed on the touchpad.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Accuracy
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

By following the directions on the screen, you will perform three taps in an indicated area on the touchpad. After each set of three taps, the instructions will tell you move to a different area, for a total of 15 taps. If the instructions say to tap in a corner, tap as close to that corner as possible. For each iteration, do the following:

  1. Tap the location that is specified on the screen.

    NOTE

    The location is calculated as a 13mm square area. For example, if the instructions say Top Left Corner, you should tap somewhere in the top-left most 13mm of the touchpad.

  2. If a tap is registered by the device, the iteration will automatically pass and move on to the next iteration.

  3. If no tap is registered by the device, you must manually fail the iteration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.PositionalAccuracy.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.PositionalAccuracy.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.PositionalAccuracyManual

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f3bbf6c-cbf1-447d-8939-3f1279030a04

The test verifies that the device can accurately report absolute position.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Accuracy
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Start the test.

  2. Iteration 1:

    1. Horizontally drag three fingers straight across 1/3 of the touchpad.

    2. Without lifting, continue to move across the touchpad in a zig-zag pattern.

    3. Without lifting, continue to move in a straight line across the last 1/3 of the touchpad.

    4. Verify that the visualization matches physical finger movements and manually pass (press P) or fail (press F) the test accordingly.

      positional accuracy iteration 1

  3. Repeat steps 1-4 vertically for the second iteration, and diagonally for the third iteration.

  4. Iteration 4:

    1. Randomly tap 20 times on the touchpad.

    2. Verify that the visualization matches your taps and that there is no jitter, as shown in Figure 2 Positional Accuracy, Iteration 4. Manually pass or fail the test accordingly.

      positional accuracy iteration 4

      In Figure 2 Positional Accuracy, Iteration 4, most of the taps are fine. The top circled contact is borderline - there was travel over the contact lifetime, but not a lot. Generally, up to 1mm (half a gridline) should be considered passing, as long as most are like the middle circled contact. The bottom circled contact shows travel greater than half a grid, which should be considered a failure.

  5. Iteration 5:

    1. Draw a curved line by using your finger.

    2. Without slowing or changing direction, lift your finger.

    3. Verify that the visualization matches your curves and does not jitter on lift, as shown in Figure 3 Positional Accuracy, Iteration 5. Manually pass or fail the test accordingly.

      positional accuracy iteration 5

      The key criteria to look for in this iteration are hooks, when you lift your finger. In the circled example, the contact jittered a significant amount to the left on contact lift. Consider any hook larger than a quarter of a grid as a failure.

  6. Iteration 6:

    1. Draw a curved line by using your finger.

    2. Without lifting, pause for one second.

    3. Click the physical button, and lift.

    4. Verify the visualization matches your curves and does not jitter on lift, as shown in Figure 4. Positional Accuracy, Iteration 6. Manually pass or fail the test accordingly.

      positional accuracy iteration 6

      In this test, there is extra data when the physical button is clicked, so it's harder to judge by looking at the data itself. Instead, watch the mouse cursor as you click and lift. If it moves more than a couple of pixels as you click, consider it a failure. In the circled example, the cursor moved significantly on click and should be considered a failure.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.PositionalAccuracyManual.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.PositionalAccuracyManual.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.PowerStateReliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93692a6e-13a8-484d-ad1b-0e6ef0b550c7

The test verifies that the device can wake the system from CS/S3 with both contact and button press, and handles power state transitions gracefully.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Latency
  • Device.Input.Digitizer.PrecisionTouchpad.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Verify that the touchpad calibrates from a small contact on boot:

    1. Shut down the system.

    2. Put one small capacitive contact (either a finger or by using the PT3) on the digitizer surface.

    3. Power on the system and leave the contact there until login is complete.

    4. Lift contact and then interact with the PTP (move cursor, one-finger tap, two-finger tap, and two-finger panning).

    5. Verify that the touchpad behaves as expected.

  2. Verify that the touchpad calibrates from a large contact on boot:

    1. Shut down the system.

    2. Put an entire palm on the digitizer surface.

    3. Power on the system and leave the contact there until login is complete.

    4. Lift contact and then interact with the PTP (move cursor, one-finger tap, two-finger tap, and two-finger panning).

    5. Verify that the touchpad behaves as expected.

  3. Verify that the touchpad calibrates from a small contact after sleep:

    1. Put the system to sleep.

    2. Put one small capacitive contact (either a finger or by using the PT3) on the digitizer surface.

    3. Wake up the system and leave the contact there until login is complete.

    4. Lift contact and then interact with the PTP (move cursor, one-finger tap, two-finger tap, and two-finger panning).

    5. Verify that the touchpad behaves as expected.

  4. Verify that the touchpad powers up quickly:

    1. Shut down and cold-boot the system.

    2. As soon as the logon screen comes up, start performing quick swipes on the touchpad.

    3. Verify that the cursor moves.

  5. Verify that the system wakes with a capacitive contact:

    1. Put the system to sleep.

    2. Wait ten seconds.

    3. Put a contact on the digitizer surface, without exceeding the button activation force.

    4. Verify that the system wakes up within three seconds.

  6. Verify that the system wakes by depressing the physical button:

    1. Put the system to sleep.

    2. Wait ten seconds.

    3. Place a non-capacitive contact on the digitizer surface, and press down the physical button.

    4. Verify that the system wakes up within one second.

  7. Launch Test.PowerStateReliability.

  8. If each of the preceding scenarios (1-6) behaves as expected, manually pass the test (Press P). If not, fail the test (Press F).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.PowerStateReliability.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.PowerStateReliability.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.Pressure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a4fe1b2-991e-4655-9c5d-3be0970b7c2b

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Test.PTPHQA

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45197fa9-287f-4e0a-8daa-c3907558c67c

The test verifies that the device can report a PTPHQA certification binary large object (BLOB).

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Start the test.

  2. The test will automatically pass/fail the device if it meets the requirement of correctly reporting the PTPHQA sample BLOB.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.PTPHQA.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.PTPHQA.json | <testbinroot>\input\PrecisionTouchpad</p>
GetTHQABlob.exe | <testbinroot>\digitizer\Win8Touch</p>


Test.ReportRate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/968c432e-228d-4d1b-a44e-d7213233a391

This test verifies that the device reports at the required rate during single finger interactions.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
  • Device.Input.Digitizer.PrecisionTouchpad.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Following the instructions on the screen, move one contact around on the touchpad for 1, 5, or 20 seconds. (a clock in the upper right corner shows how many seconds have passed since all contacts have been down).

  2. Repeat 11 times. Note that the length of time will change for some iterations, so please read and follow the on-screen instructions for each iteration

    PTLogo will fail an iteration and display an error if there is a problem with the report rate. Otherwise, the iteration will pass upon lift, and PTLogo will advance to the next iteration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.ReportRate.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.ReportRate.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.ReportRateMultiple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59cd2da8-6ef5-45d7-965e-76d61cff1f85

This test verifies that the device reports at the required rate during multi finger interactions.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.ReportRate
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Following the instructions on the screen, move three contacts around on the touchpad for 1, 5, or 20 seconds. (a clock in the upper right corner shows how many seconds have passed since all contacts have been placed).

  2. Repeat 11 times. Note that the time will change for some iterations, so please read and follow the on-screen instructions for each iteration.

    PTLogo will fail an iteration and display an error if there is a problem with the report rate. Otherwise, the iteration will pass upon lift, and PTLogo will advance to the next iteration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.ReportRateMultiple.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.ReportRateMultiple.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.RightClickReliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13d99bb2-14c0-44db-88e9-861a51a9e25f

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Test.SelectiveReporting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2464d46f-bef5-450f-8c55-4d55d9e5c441

This test verifies that device reports properly when put into selective reporting.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.SelectiveReporting
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Move contact on the touchpad and try to press the button.

  2. If touchpad does not respond (mouse cursor does not move, no contact or button click visualization is shown), press P to manually pass the test. Otherwise, press F to fail the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.SelectiveReporting.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.SelectiveReporting.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.StaticValidation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0fcc869-637c-4da4-b7ca-446d6d9158b6

The test verifies that the device meets the fundamental bus interface requirements with the host.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.HIDCompliant
  • Device.Input.Digitizer.PrecisionTouchpad.ThirdPartyDrivers
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

  1. Launch the test.

  2. The test will automatically pass or fail the device depending on whether it meets the requirements.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.StaticValidation.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.StaticValidation.json | <testbinroot>\input\PrecisionTouchpad</p>
Pstatic.vbs | <testbinroot>\input\PrecisionTouchpad</p>
Pstatic.exe | <testbinroot>\input\PrecisionTouchpad</p>


Test.StationaryJitter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b38725c-f0f6-481e-8473-efceec374978

This test verifies that there is no jitter (within .5mm) reported by the device when a single stationary contact is placed on the device.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

A precision contact is necessary for this test. For the test to pass, the contact must be able to rest on the device with no jitter. We strongly recommend that a robot or precision rig be used to execute this test.

  1. Carefully lower one contact straight down anywhere on the touchpad.

  2. Wait ten seconds (use the timer in the upper-right corner of the Logo tool).

  3. Carefully raise the contact.

    If no jitter is detected, the tool will pass the iteration and move on to the next iteration. Otherwise it will fail the test and give an error.

  4. Repeat for five iterations.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error | Description/Workaround
[12] interaction too short: ##### | The contact was down for less than the required ten seconds. The number given is the duration of the contact, measured in tenths of milliseconds. Make sure you leave the contact down for at least ten seconds.
[11] contact displacement too large: ### | Contact moved or jitter farther than the allowed tolerance. The number given is the himetric distance moved, measured in hundredths of millimeters. Make sure the contact is completely stationary on the device.

More information

Command syntax

Command | Description
ptlogo.exe Test.StationaryJitter.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.StationaryJitter.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.StationaryJitterMultiple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9c3137b-3806-4fc0-add7-9b41093006dd

This test verifies that there is no jitter (within .5mm) reported by the device when three stationary contacts are placed on the device.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

Three precision contacts are necessary for this test. For the test to pass, the contact must be able to rest on the device with no jitter. We strongly recommend that a robot or precision rig be used to execute this test.

  1. Carefully lower three contacts 11mm apart straight down anywhere on the touchpad.

  2. Wait ten seconds (use the timer in the upper-right corner of the Logo tool).

  3. Carefully raise the contacts.

    If no jitter is detected, the tool will pass the iteration and move on to the next iteration. Otherwise it will fail the test and give an error.

  4. Repeat for five iterations.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

Error | Description/Workaround
[12] interaction too short: ##### | The contacts were down for less than the required ten seconds. The number given is the duration of the contacts, measured in tenths of milliseconds. Make sure you leave the contacts down for at least ten seconds.
[11] contact displacement too large: ### | Contacts moved or jitter farther than the allowed tolerance. The number given is the himetric distance moved, measured in hundredths of millimeters. Make sure the contacts are completely stationary on the device.

More information

Command syntax

Command | Description
ptlogo.exe Test.StationaryJitterMultiple.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test. Test.StationaryJitterMultiple.json | <testbinroot>\input\PrecisionTouchpad</p>


Test.StepMotor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8001bfd-fca0-489a-81cf-c66662512612

This test verifies that device meets the panning latency requirements (average latency <15ms).

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

The RA tool is required for this test. For more information, see How to Measure Touch Panning Latency.

You will need to fit your RA tool with a smaller, adjustable PTP bracket.

Adjust the radius of the circle to 15mm and position the touchpad such that the contact will stay on the touchpad for the full circle.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
pstepmotor.exe | Runs the test.

File list

File | Location
pstepmotor.exe | <testbinroot>\input\PrecisionTouchpad</p>


Test.ZHeight

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d7f9f78-8066-4086-ab74-7270e0e0647a

This test verifies that device does not detect contacts that are not directly on the surface of the touchpad.

Test details
Specifications
  • Device.Input.Digitizer.PrecisionTouchpad.ContactTipSwitchHeight
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Mouse or other Pointing Device Testing Prerequisites.

To run this test, you will need precision capacitive contacts that can be placed 1mm above the surface of the touchpad and remain steady for a period of time. It is recommended that this test be performed by a robot or other precision mechanism.

  1. Place 1mm thick material on top of touchpad.

  2. Lower a precision contact until it just touches the non-conductive material.

  3. Remove the material.

  4. Leave contact in place above touchpad for 1 minute.

  5. Verify that no contact is reported and press P to manually pass the test. If contact is reported, press F to fail the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing.

More information

Command syntax

Command | Description
ptlogo.exe Test.ZHeight.json | Runs the test.

File list

File | Location
ptlogo.exe | <testbinroot>\input\PrecisionTouchpad</p>
config.json | <testbinroot>\input\PrecisionTouchpad</p>
Test.ZHeight.json | <testbinroot>\input\PrecisionTouchpad</p>


TestAgnssInjection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f18a628-abd1-487e-a42c-906f34a4315d

Test AGNSS exchange for time, injecting the device's system time (this can work if the device doesn't have network connectivity, but the time is more likely to be incorrect).

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestAgnssInjection_InjectEphemeris

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3eb68d03-4f5f-4b7b-86cd-e5ac17c93a33

Test AGNSS exchange for ephemeris, injecting a real-time, presumable correct ephemeris.

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestAgnssInjection_InjectFakeEphemeris

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9312d6f3-ece3-4f0b-a5f3-ac61076ca767

Test AGNSS exchange for ephemeris, injecting a bogus ephemeris.

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestAgnssInjection_InjectFakePosition

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9688e9be-8b85-4ccf-8956-8960ed616d16

Test AGNSS exchange for coarse position, injecting a bogus position.

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestAgnssInjection_InjectFakeTime

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4ee0291-308f-4f0b-8f9d-a42f1b524a93

Test AGNSS exchange for time, injecting an invalid time value. While it was expected this will impact the performance of the driver, it must not crash.

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestAgnssInjection_InjectPosition

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/596fd813-e4bc-4dbf-a5db-f49a0e55710a

Test AGNSS exchange for coarse position, injecting a configurable position.

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestAgnssInjection_InjectTime

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94b4f22c-40af-4b1a-8f58-3ef87d4a2b6f

Test AGNSS exchange for time, injecting a presumed good time which was effectively reported by NTP.

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestCapabilityAndPlatformTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b30afa60-1b79-421e-aa8d-fec25b6ed59c

Test for the exchange between the platform (GNSS_SEND_PLATFORM_CAPABILITY) and the driver (GNSS_GET_DEVICE_CAPABILITY) regarding their respective capabilities

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestDriverCommandBasic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebc4cbf2-e790-4d55-804b-1072e0f347ba

Test the basic driver commands that are required for both product and test enablement.

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestErraticIrpTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fdd63b2c-3a23-4189-9253-82cde9ac34ba

Tests that the driver will still respond to a fix request if the GetFixData IRP was not lodged before the driver was ready to report the final fix. Fails if a fix does not get reported.

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceBasicTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3dafce9a-679a-4496-b886-c6d16b27c27e

Verify Geofence can be successfully Added and Deleted

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceBasicTest_CheckMaxGeofencesSupported

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/43440639-a451-42dd-8e56-a5144122e93c

Ensures that the driver can support at least 50 MaxGeofences

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceBasicTest_Iterations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3dcac066-03c2-4a22-a1f0-9dd370b75d16

Verify Geofence can be successfully Added and Deleted, Multiple iterations

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceBasicTest_ZeroRadius

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a7ac0f6-7eae-400a-a05c-41b59b9544b9

Try to add Geofence with bad (zero radius) parameters

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a54e2184-0099-4226-a461-489459c5463e

Add a Geofence around your current position with UNKNOWN state and verify ENTRY event

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_AddMultipleGeofences

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/760546a1-2582-41da-b5fa-739e7d77a183

Add Max Supported no of Geofences around your current position with UNKNOWN state and verify all ENTRY events

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_AddMultipleGeofencesIterations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3e7e7ee-f458-438b-bbc2-121e64ea013e

Add Max Supported no of Geofences around your current position with UNKNOWN state and verify all ENTRY events,Multiple Iterations

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_ExitEvent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b7d9a346-efd6-4fd4-84fa-f68726a5ebff

Add a Geofence(with Entered state) such that your current position is just outside the Geofence. Verify Exit event

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_ExitEventIterations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea9e9608-1e3b-4234-981a-385e04824d7a

Add a Geofence(with Entered state) such that your current position is just outside the Geofence. Verify Exit event, Multiple Iterations

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_Iterations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/65112649-0c43-475b-ba94-9c887c779cc2

Add a Geofence around your current position with UNKNOWN state and verify ENTRY event, Multiple iterations

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_MultipleExitEvents

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62843401-2b96-4e26-809c-5c6ad0fe34f4

Add Max Supported no of Geofences(with Entered state) such that your current position is just outside the Geofence. Verify all Exit events

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_MultipleExitEventsIterations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8daa309-7898-440c-b3bd-24ca90715f63

Add Max Supported no of Geofences(with Entered state) such that your current position is just outside the Geofence. Verify all Exit events,Multiple Iterations

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_PurgeMultipleGeofences

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d18dd236-95af-49e2-a635-386dfb706dec

Add multiple Geofences and then purge them all at once

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGeofenceTrackTest_PurgeMultipleGeofencesIterations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47eb0339-f77a-42ac-a59a-bf1b7053939c

Add multiple Geofences and then purge them all at once, Multiple iterations

Test details
Specifications
  • Device.Input.Location.Geofencing
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGNSSBasicStartFix

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c203db59-f9eb-4862-aaa4-1078c4a09dd6

Basic test that begins a single shot session and runs until a final fix is received. Will only succeed if a final fix is delivered within 2 minutes.

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGNSSBasicStartFix_ColdStateAndDisallowAgnss

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d312e9a8-e317-46ab-b81e-3ef44b03dec5

Ensures that the driver is placed into the state it would be in if the phone was cold booted, and then runs a single shot fix without any AGNSS assistance until it reports a final fix

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGNSSBasicStartFix_SetEngineCold

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d10943b4-0164-4710-9314-8f95c4e6528e

Ensure that the driver requests time and position when engine is set cold

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGNSSBasicStartFix_WithAgnssInjection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cb0e6bd-4ece-44af-82c6-70ffd97896a2

Issue a single-shot request, which has access to AGNSS injection. Will fail if it doesn't get a fix within 45 seconds

Test details
Specifications
  • Device.Input.Location.AssistedGNSS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestGnssMultiSession

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf0ad06f-2f9d-4651-a3f9-0e6af06e020c

Run multiple iterations of entire single shot sessions, reinitializing the engine after each fix, gathering performance metrics

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestModifyFixSession

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/530f451b-d087-4ef3-a471-88b98978da27

Runs several modify fix requests to an existing session. In this case, it is done for a single shot request with an increasing fix response time

Test details
Specifications
  • Device.Input.Location.Base
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestSuplConfTest_v1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f0dbf4a-1d81-49fc-b373-c64cd9b831d6

User plane location basic supl ceritificate tests

Test details
Specifications
  • Device.Input.Location.SUPL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestSuplConfTest_v2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d07d42e-0fa6-479d-b0b1-3b103122c8ea

User plane location basic supl ceritificate tests

Test details
Specifications
  • Device.Input.Location.SUPL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestV2UplFqdnConfTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14eec914-3c29-46ec-a19c-2908aa0535a5

User plane location basic v2 upl config via FQDN

Test details
Specifications
  • Device.Input.Location.V2UPL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


TestV2UplIpConfTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cf743ff-0687-49e7-b5ce-75b38d07e4ea

User plane location basic v2 upl config via IP address

Test details
Specifications
  • Device.Input.Location.V2UPL
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 35
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinBio API Presence Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/486ec4e0-710b-4a0d-935a-657209438aa7

API presence tests for WinBio on OneCore

Test details
Specifications
  • Device.Input.FingerPrintReader.Extensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 2
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Accelerometer Batching GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7591a4d1-ef8e-4966-98d7-9529d7b6e458

Windows::Devices::Sensors::Accelerometer Batching C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Accelerometer Batching ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/abb9ce71-4a7a-48b5-a0c1-8b9d2be7a5b2

Windows::Devices::Sensors::Accelerometer Batching C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Accelerometer Batching TwoClients

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb0a7062-93d9-4d78-831d-29c120846378

Windows::Devices::Sensors::Accelerometer Batching C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Accelerometer InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2184b011-beae-49d4-bc5c-e02803fc872a

Windows::Devices::Sensors::Accelerometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Accelerometer MultiThread Batching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f5f5728-3dd5-49fe-9fb0-3d54c8fa264f

Windows::Devices::Sensors::Accelerometer Batching C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Activity InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7be020c9-a222-40ba-8dfc-04af4944ab60

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Barometer InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1b8e68d-89ba-46e9-b9e4-b6b208a98bb9

Windows::Devices::Sensors::Barometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Barometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Custom InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad2deb2a-e727-4358-b8a7-45bd9d70bc7a

Windows::Devices::Sensors::Custom::CustomSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Custom.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT GeomagneticOrientationSensor GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ca8f160-5325-4e91-9679-0f7b4c0c3cf5

Windows::Devices::Sensors::GeomagneticOrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.GeomagneticOrientationSensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT GeomagneticOrientationSensor ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3163fae-ddd9-457a-b30a-db4208f34c2c

Windows::Devices::Sensors::GeomagneticOrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.GeomagneticOrientationSensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT GravityVector GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2c5ecb5e-aa1d-42fd-ad80-a15ae7e85ba1

Windows::Devices::Sensors::GravityVector C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.GravityVectorSensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT GravityVector ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7fe93bd-ffd4-4334-9906-d82e5871c6cf

Windows::Devices::Sensors::GravityVector C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.GravityVectorSensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Gyrometer InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/485480c1-6861-4d7e-ac2b-17db53cb4c9d

Windows::Devices::Sensors::Gyrometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT LightSensor InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fdf25704-3aac-4c51-a4d0-f3926ea24a29

Windows::Devices::Sensors::LightSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Light.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT LinearAccelerometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0d0d3fa-e8fa-4e07-b33f-ecd7766b394c

Windows::Devices::Sensors::LinearAccelerometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.LinearAccelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT LinearAccelerometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed39ebb7-aef2-408c-9ce9-18a2b082094b

Windows::Devices::Sensors::LinearAccelerometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.LinearAccelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Magnetometer InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26bcac22-8e65-4ad8-9266-9e063d46de7b

Windows::Devices::Sensors::Magnetometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT OrientationSensor InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/909b8220-677a-4a79-b84b-aa576c151bb6

Windows::Devices::Sensors::OrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Pedometer InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6696231-b801-42b9-a0e5-ef873e4d7ccb

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


WinRT Proximity InitialSample

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e619481a-6b86-46d8-bf78-2431a6923652

Windows::Devices::Sensors::ProximitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Proximity.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Input additional documentation


Windows Hid Validation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f976f0ec-d3a3-42bb-b433-96b87097d806

This test verifies that Windows Touch device firmware is human interface device (HID)-compliant and doesn't require additional driver installation.

Test details
Specifications
  • Device.Input.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Digitizer Testing.

More information

HIDvalidator.exe checks your HID descriptor to ensure compliance with the HID specification. It ensures that all necessary usages are present, and catches invalid values. Thirty-four rules are validated. This tool produces an easy-to-read report.

Rules

  • Rule 1: Touch-screen devices must support multiple touches.

  • Rule 2: Device must support at least 5 contacts.

  • Rule 3: Device must use parallel or hybrid packet reporting mode or single-finger hybrid reporting mode. When the device is connected through I2C, "single-finger hybrid" is required.

  • Rule 4: A usage item tag must be associated with any collection (such as a pen, touch screen, or finger).

  • Rule 5: The report descriptors for the touch device should use the finger (0x22) CL (Collection Logical) to group the data and control usages in the top-level collections.

  • Rule 6: Device must report generic X and generic Y.

  • Rule 7: The logical minimum and the logical maximum of the generic X must be specified correctly.

  • Rule 8: The logical minimum and the logical maximum of the generic Y location must be specified correctly.

  • Rule 9: The physical minimum and the physical maximum of the generic X location must be specified correctly.

  • Rule 10: The physical minimum and the physical maximum of the generic Y location must be specified correctly.

  • Rule 11: The minimum physical size of a digitizer must be at least 1 square inch (1 inch for generic X).

  • Rule 12: The minimum physical size of a digitizer must be at least 1 square inch (1 inch for generic Y).

  • Rule 13: The unit for the physical size of generic X must be inch or centimeter.

  • Rule 14: The unit for the physical size of generic Y must be inch or centimeter.

  • Rule 15: If the device supports z-axis detection, in-range must be supported as well.

  • Rule 16: Device that support the center value must also support the width and height usages. Devices should have a usage array of two X values and two Y values to report T and C.

  • Rule 17: Device must report "tip" switch.

  • Rule 18: Device must report scan time in the top-level collection, must have a minimum report length of 16 bits, must be less than or equal to 0x7fffffff, and must be at least 65,535.

  • Rule 19: Device must report actual count usage correctly in the top-level collection.

  • Rule 20: Device must support the contact identifier usage to specify the identifier of the current contact.

  • Rule 21: Device must implement the maximum count usage correctly in the top-level collection as a feature report, and not in any child collection.

  • Rule 22: The contact count maximum for a device must not exceed 250.

  • Rule 23: Device must implement the firmware key usage correctly with a length of 256 bytes on the user-defined usage page and in the top-level collection as a feature report.

  • Rule 24: The device configuration feature report must be in its own top-level collection and must include the multiple input configuration usages.

  • Rule 25: A logical range must be provided for all usages.

  • Rule 26: Supporting usages that belong to the usage page digitizer should be assigned to the digitizer (0x0D).

  • Rule 27: Supporting usages that belong to the usage page generic desktop should be assigned to the generic desktop (0x01).

  • Rule 28: All usages that are associated with the generic desktop usage page should be recognized.

  • Rule 29: All usages that are associated with the digitizer usage page should be recognized.

  • Rule 30: Usage should not be defined as 0 for any usage pages.

  • Rule 31: The physical range of the azimuth must be 0 to 360 degrees. The logical range must be large enough to deliver data that's accurate to at least 2 decimal places.

  • Rule 32: The units exponent of the azimuth usage must be accurate to at least 2 decimal places in degree, or it must be accurate to at least 4 decimal places in radians.

  • Rule 33: The units of the azimuth usage must be in degrees or radians.

  • Rule 34: The number of collections and end collections must match in the descriptor file. (Not available for real time.)


Windows Touch Buffering Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63a478ab-a41e-470a-abe5-d48ab9404fa5

Test details
Specifications
  • Device.Input.Digitizer.Touch.Buffering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


Windows Touch Digitizer Jitter Test - Five Contacts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03398297-8036-4d46-ac58-517e159cd1d4

This test verifies that a Windows Touch device does not exceed the allowable amount of jitter (a maximum of 1 millimeter over 10 millimeters of travel).

Test details
Specifications
  • Device.Input.Digitizer.Touch.Jitter
  • Device.Input.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Clean input is important throughout the system and across applications. Whether a user is performing a hold gesture to learn more about a user interface (UI) element, playing a game, or holding a key on the software keyboard, this fidelity allows software to correctly interpret a user's intention and provide an optimal touch experience.

This test presents twelve distinct scenarios that examine jitter during static contact, linear motion, and radial motion. Most of these interactions require the use of assistive technology.

In addition to validating that the jitter specification is respected, this test verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config DigitizerJitter.json | Runs the test.

File list

File | Location
DigitizerJitter.json | <testbinroot>\digitizer\Win8Touch
Logo3.exe | <testbinroot>\digitizer\Win8Touch


Windows Touch Digitizer Jitter Test - One Contact

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/144c6ac6-fb78-4f95-a581-eed55ea43c4d

This test verifies that a Windows Touch device does not exceed the allowable amount of jitter (a maximum of 1 millimeter over 10 millimeters of travel).

Test details
Specifications
  • Device.Input.Digitizer.Touch.Jitter
  • Device.Input.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Clean input is important throughout the system and across applications. Whether a user is performing a hold gesture to learn more about a user interface (UI) element, playing a game, or holding a key on the software keyboard, this fidelity allows software to correctly interpret a user's intention and provide an optimal touch experience.

This test presents twelve distinct scenarios that examine jitter during static contact, linear motion, and radial motion. Most of these interactions require the use of assistive technology.

In addition to validating that the jitter specification is respected, this test verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config DigitizerJitter.json | Runs the test.

File list

File | Location
DigitizerJitter.json | <testbinroot>\digitizer\Win8Touch
Logo3.exe | <testbinroot>\digitizer\Win8Touch


Windows Touch Five Point Minimum Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/20f7fc85-e206-432d-be66-668b0d37be26

This test verifies that a Windows Touch device supports a minimum of five simultaneous touch inputs.

Test details
Specifications
  • Device.Input.Digitizer.Touch.MinContactCount
  • Device.Input.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Because touch capabilities must be consistent across all computers, a minimum number of supported touch points are required. Five-finger support allows for whole-hand interactions in addition to quick and efficient touch-screen typing.

This test presents a single scenario that asks you to briefly place five or more contacts on the screen. All contacts that are placed at the beginning of the test must continue to report for the full duration of the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config 5TouchPointMinimum.json | Runs the test.

File list

File | Location
5TouchPointMinimum.json | <testbinroot>\digitizer\Win8Touch
Logo3.exe | <testbinroot>\digitizer\Win8Touch


Windows Touch Input Separation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2dd85bf-0af3-4efa-8429-4cf71ed85099

This test verifies that a Windows Touch device meets requirements for zoom, tap, or swipe motions.

Test details
Specifications
  • Device.Input.Digitizer.Touch.FingerSeparation
  • Device.Input.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites. You must use assistive test tools to complete this test.

Users often place their fingers close together in fast-paced games, drawing applications, musical instrument applications, and other common applications. In addition, Windows supports a system of touch gestures that let users who have low vision fully explore the user interface (UI) and accomplish common tasks. Much of this gesture language relies on multiple fingers in close proximity.

This test consists of five scenarios that enforce the requirement that contacts in close proximity must be recognized separately. Broadly, this test verifies that a device meets requirements during horizontal, vertical, and diagonal motion, and during a pinch gesture.

This test also verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config InputSeparation.json | Runs the test.

File list

File | Location
InputSeparation.json | <testbinroot>\digitizer\Win8Touch
Logo3.exe | <testbinroot>\digitizer\Win8Touch


Windows Touch Noise Suppression Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bd29092-1f72-46a7-bb6b-7ef0ee9f6e20

This test verifies that a Windows Touch device does not report data for locations where touch input does not occur.

Test details
Specifications
  • Device.Input.Digitizer.Touch.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

This test can help to ensure that touch systems can effectively tolerate common environmental conditions.

This test presents two scenarios: the only distinction between the two scenarios is the power source. For the Battery portion of the test, you should remove the external power source from a mobile system.

In each case, the test validates that a contact that is held at the minimum required distance from the screen does not register any touch contacts. For precise values, see Windows Hardware Certification Requirements: Devices.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config NoiseSuppression.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
NoiseSuppression.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Physical Input Position Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3512b24e-8857-4e7d-8839-79f26778b1e3

This test verifies that a Windows Touch device reports all inputs within plus or minus 1 millimeter of the center of the physical input for all touchable areas.

Test details
Specifications
  • Device.Input.Digitizer.Touch.Accuracy
  • Device.Input.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Minimal offset between the actual and reported point of contact is a primary factor in real and perceived system accuracy. The screen edge hosts some of the most commonly used gestures on the interface, such as displaying the charms, switching applications, dismissing applications, and displaying the Application Bar.

The Physical Input Position Test suite includes tests for linear accuracy (offset) and edge performance, totaling seven scenarios. For the Edge (Inward) scenario, speed is measured and enforced. The tool warns you when motion is too slow, and then asks you to repeat the interaction. Moving too slowly does not generate a failure.

Each test must be passed at a rate of 95%.

This test also verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config PhysicalInputPosition.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
PhysicalInputPosition.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Reporting Rate Test - Five Contacts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0688fe7b-f8b9-48dc-a22f-99dd13a2e98d

This test verifies that a Windows Touch device correctly reports physical contact with the device and the contact position.

Test details
Specifications
  • Device.Input.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

A high packet rate helps ensure smooth, fluid motion, and it supports the feeling that the user interface (UI) is connected to the user's finger. The input rate data and increased data throughput improves gesture recognition.

This test includes four separate reporting rate scenarios that are distinguished by single and multiple contacts and stationary contact versus motion. In each scenario, the test validates that the minimum reporting rate is maintained for each contact (and specifically not just the average reporting rate).

This test also verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config ReportingRate.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
ReportingRate.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Reporting Rate Test - Maximum Contacts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bf6e5d1f-5964-400b-be48-6d98e46d139c

This test verifies that a Windows Touch device correctly reports physical contact with the device and the contact position.

Test details
Specifications
  • Device.Input.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

A high packet rate helps ensure smooth, fluid motion, and it supports the feeling that the user interface (UI) is connected to the user's finger. The input rate data and increased data throughput improves gesture recognition.

This test includes four separate reporting rate scenarios that are distinguished by single and multiple contacts and stationary contact versus motion. In each scenario, the test validates that the minimum reporting rate is maintained for each contact (and specifically not just the average reporting rate).

This test also verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config ReportingRate.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
ReportingRate.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Reporting Rate Test - One Contact

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2db03c0-0eaa-44d2-92f7-34a49ba4b693

This test verifies that a Windows Touch device correctly reports physical contact with the device and the contact position.

Test details
Specifications
  • Device.Input.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

A high packet rate helps ensure smooth, fluid motion, and it supports the feeling that the user interface (UI) is connected to the user's finger. The input rate data and increased data throughput improves gesture recognition.

This test includes four separate reporting rate scenarios that are distinguished by single and multiple contacts and stationary contact versus motion. In each scenario, the test validates that the minimum reporting rate is maintained for each contact (and specifically not just the average reporting rate).

This test also verifies that HID reports conform to the HID protocol that is described in Windows Pointer Device Data Delivery Protocol and defined in the HID I2C v1.0 Protocol Specification.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config ReportingRate.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
ReportingRate.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Resolution Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23833432-e861-4495-8580-0875c303340d

This test verifies that a Windows Touch device has a 100-Hertz minimum reporting rate for all touch inputs.

Test details
Specifications
  • Device.Input.Digitizer.Touch.Resolution
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

To support the assertion that every pixel is touchable, the resolution of the touch screen must be at least as high as the resolution of the display. This test verifies that capability. To complete this test, simply touch the screen. The program validates that the digitizer that reports the contact has a resolution that is at least as high as the connected display.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Digitizer Testing.

More information

Command syntax

Command option | Description
Logo3.exe -config TouchResolution.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
TouchResolution.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Response Latency (Down) Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ab4ddd6-e2e8-4e28-8bcc-2fe4eda21e31

This test verifies that a Windows Touch device meets the response latency requirements for both idle and active states.

Test details
Specifications
  • Device.Input.Digitizer.Touch.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Similar to response rate, low response latency plays a large role in ensuring fast and fluid motion. Conversely, a high degree of response latency breaks the illusion that the user is manipulating a physical object.

This test uses specialized hardware to measure the latency in touch packet delivery under two conditions: touch-down (stationary) and panning (continuous reporting, in motion).

To learn about the hardware and about associated procedures, see How to Measure Touch Panning Latency and How to Measure Touch Down Latency.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Digitizer Testing.

More information

Command syntax

Command option | Description
audiotouch.exe | Runs the test.

File list

File | Location
audiotouch.exe | <testbinroot>\digitizer\Win8Touch


Windows Touch Response Latency (Panning) Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea01d7a6-c58f-4269-b325-4c7805a9be8b

This test verifies that a Windows Touch device meets the response latency requirements for both idle and active states.

Test details
Specifications
  • Device.Input.Digitizer.Touch.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Digitizer Testing.

More information

File list

File | Location
stepmotor.exe | <testbinroot>\digitizer\Win8Touch


Windows Touch Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9b1ece24-41b5-4acf-be7d-ca88a3dc3c61

This test verifies that a Windows Touch device meets requirements.

Test details
Specifications
  • Device.Input.Digitizer.Touch.CustomGestures
  • Device.Input.Digitizer.Touch.HIDCompliant
  • Device.Input.Digitizer.Touch.ThirdPartyDrivers
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

The Windows Touch Test combines a set of simple manual tests. Measured requirements include: having a bezel that is flush with the display, specifying physical dimensions that match the device's true physical dimensions, and passing the HID Validator tool's static test. (The HID Validator tool installed together with the Windows HLK).

Flush Bezel

The bezel requirement (System.Client.Digitizer.Touch.Bezel) helps ensure easy access to the edge of the screen, which is used to display the Charms Bar and to switch applications. It also provides an optimal set of conditions to use the thumb keyboard. USB and I2C buses are required because they support the HID standard upon which the Windows touch infrastructure is based. FFU is required.

For a Tablet device, ensure that the bezel is flush with the display (the bezel must not be taller than the display).

Physical Dimensions

The physical dimensions of the device must support system gestures and general touch interactions (Device.Digitizer.Touch.PhysicalDimension). For example, the momentum of a touch gesture depends on the physical distance moved and the length of that movement.

This test verifies that the physical dimensions that are reported by the HID descriptor match the true physical dimensions of the visible screen area. Discrepancies affect system gestures and UI elements, which rely on physical size information. We strongly recommend that you use the dimensions that are specified by the display manufacturer. The test itself relies on this information to size elements appropriately. The test will be affected by errors; for example, targets that are intended to be 20mm apart might resolve to being 22mm apart. The WTTL does not make allowances for devices that report physical size values that differ from the true measurement by more than 2mm.

High Quality Touch Digitizer Input

To run this test, the HID descriptor must be stored in the device firmware. The Windows Hardware Lab Kit (Windows HLK) includes the HID Validator tool. Before you run this test, we recommend that you review Windows Hardware Certification Requirements and the HID Validator documentation that is installed together with the HID Validator tool.

To run the test, double-click HidValidator.exe on the touch device. The tool ensures that the descriptor conforms to the HID specification.

Power States

For a discussion of power-state requirements (Device.Digitizer.Touch.PowerStates), see Power Handling for Windows 8 Touch Controllers.

You can use the WTTL to check the ability of a device to traverse power states by using the following procedure:

To run the power states test

  1. If applicable, put the device into the Connected Standby state. Otherwise, power the device off.

  2. Place any type of contact on any number on the screen and hold for 10 to 15 seconds.

  3. If the device is in the Connected Standby state, wake the device while maintaining contact. If the device is powered off, power on the device while maintaining contact.

  4. After the machine has booted, ensure that no ghost touches exist. Attempt to use touch input.

  5. If applicable to the device, repeat these steps for Sleep (S3) state.

If no ghost touches exist, and if touch input can be used as expected to control the machine, then the device passes this test. Otherwise, it fails the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config Other.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
Other.json | <testbinroot>\digitizer\Win8Touch


Windows Touch Ux Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8216ab22-011d-4988-a2dd-341126361f91

This test validates the Windows Touch user experience that is associated with the hardware requirements. Tests are designed to run freehand.

Test details
Specifications
  • Device.Input.Digitizer.Touch.Accuracy
  • Device.Input.Digitizer.Touch.FingerSeparation
  • Device.Input.Digitizer.Touch.ContactReports
  • Device.Input.Digitizer.Touch.Jitter
  • Device.Input.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Windows Touch Testing Prerequisites.

The Windows Touch UX Test suite combines disparate touch requirements into everyday tasks. The principle benefit of this test suite is to test the requirements together and to verify that a user can reliably complete the core Windows touch interactions.

Tile Tap

Tile Tap is a simple accuracy test in the context of tapping tiles on the Search screen. It appears four times: one time in each screen quadrant. To complete the test, tap each blue box as it appears.

In the Windows Touch Device Certification Processes and Windows Touch Test Lab (WTTL) Service, a natural tapping motion is used; we recommend that you also use a natural tapping motion during your internal testing. Figure 1. Precise Tapping Position, shows an unnatural tapping position. Figure 2. Natural Tapping Position, shows a more natural tapping position.

too precise tapping

natural tapping position

Semantic Zoom

Semantic zoom is an active feature in many of the default controls in the Windows 8 SDK. For example, you can see Semantic Zoom on the Start screen, where the user can pinch and zoom to reveal different views of the application tiles.

In each iteration of the test, you are asked to zoom in or zoom out. You can accomplish these, respectively, by pulling your fingers apart or by pulling them together. There are two versions of this test: one that uses two fingers and one that uses five fingers.

Quick Toss

Quick toss is a punctuated panning motion that scrolls quickly through pages of content.

The Quick Toss test goes through a series of iterations. In each iteration, you quickly swipe up or down the screen by using one or two fingers. (Note that speed is enforced in this test.) A quick toss that is performed too slowly will not cause a failure, but it will require you to repeat that iteration.

NOTE

When inertia is applied and the tester cannot pan the color screen accordingly (that is, a faster swipe does not make color screen scrolls faster), this test should be treated as a valid fail because the user cannot pan smoothly by using the desired velocity.

Keyboard

The Keyboard test simulates quick typing on the touch keyboard. It presents four keys that must all be tapped once within one second. (This represents a typing speed of four keys per second, or roughly 48 words per minute.)

The test times out one second after the first target is pressed. If a target is missed because of a dropped touch or a sequence of taps that are interpreted as a move, the test can appear to be lagging.

Figure 3 Recommended Finger Position, shows you how to place your fingers on the touch screen for this test.

recommended finger position for keyboard test

Hyperlink

The Hyperlink test asks you to tap a series of hyperlinks that are rendered at their typical size. The test is complete after all of the hyperlinks have been tapped or missed.

Press and Hold

Press and hold is a gesture that users can employ to discover more information about a UI element. For example, if you hold a finger down on the desktop, the context menu opens.

The Press and Hold test presents four squares: three gray and one blue. You must press the blue square until it turns green. Repeat until the test is complete.

Mobar

The modern taskbar (mobar) is the dividing line between two active displayed Microsoft Store applications. The user can drag this line to change the area that is allocated to either application, or to remove one application from the screen.

The Mobar test draws a blue line and asks you to drag from any location on this line to a green box. The locations of the blue line and the green box change during the test, but the goal is always the same.

Backstack

The Backstack test models the back and forward navigation functionality that is built into the tailored app version of Internet Explorer® 10, whereby the user can pan left or right to reveal recently visited pages.

In each iteration of the test, you must swipe left or right. You must complete each iteration to end the test.

Edgy

The Edgy test models the edge gestures that perform such actions as to display the Charms Bar or to cycle through and dismiss applications.

To complete the test, swipe from the border area (or bezel) onto the visible screen area through the side of the screen that is colored blue.

NOTE

each swipe requires a minimum speed of 20mms. This is the same speed threshold that is used in the operating system. If the tester does not achieve this speed, an "Unknown Reason" error will display.

Select

Select is a short swipe gesture that brings focus to an item in the tailored app list views. On the Start screen, users can select their application tiles to reveal options such as Pin to Start or Run as Administrator. The File Picker uses this gesture to let the user select multiple files.

The Select test presents a number of tiles, one of which is colored blue. The goal is to pull up or down on the blue tile toward the gray line without passing it. The test monitors for motion that is perpendicular to the direction of the select gesture; the user sees this motion as panning.

Rearrange

Rearrange is a gesture that is used to move application tiles on the screen. You accomplish this by pulling on an application tile until it breaks free.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Input Testing and the Hardware Component Guidelines for Windows Digitizer Class Input Devices.

More information

Command syntax

Command option | Description
Logo3.exe -config UXTests.json | Runs the test.

File list

File | Location
Logo3.exe | <testbinroot>\digitizer\Win8Touch
UXTests.json | <testbinroot>\digitizer\Win8Touch


WinRT Accelerometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a49b0b46-3c33-45ca-b8d1-ca92db4a57ea

Windows::Devices::Sensors::Accelerometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Accelerometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6af55d72-c8a7-4563-81af-0bce44bb45c3

Windows::Devices::Sensors::Accelerometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Accelerometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Activity ActivitySensorTriggerActivation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e830d18f-0633-4c1c-b544-b914e14084c8

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Activity FromIdAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/417fd0ad-8194-4481-80b5-1a1e4fe62cad

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Activity GetCurrentReadingAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bbe5a8d5-9ff7-4846-9861-eb3580adf343

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Activity GetSystemHistoryAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e6763d4-5ae5-42ed-aa5f-3616584ae038

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Activity GetSystemHistoryWithDurationAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00bb22e5-3a52-4046-b5ae-e9d79c112424

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Activity ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5f77919-95e9-4937-9609-21cf0cdd3c07

Windows::Devices::Sensors::ActivitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.ActivitySensor.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Barometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/57f24c71-36ac-44d4-8a3a-3678316e6059

Windows::Devices::Sensors::Barometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Barometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Barometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1efc963-8784-40ef-9393-95e2ef7f65aa

Windows::Devices::Sensors::Barometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Barometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Compass GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a33d538-d98d-4240-ae89-30d5f36903cb

Windows::Devices::Sensors::Compass C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Compass ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14271cc2-04ac-4e12-861f-343c37c0f420

Windows::Devices::Sensors::Compass C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Custom GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd9d02f7-794e-4532-8d5f-f6d876153593

Windows::Devices::Sensors::Custom::CustomSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Custom.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Custom ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca8ce8cc-3a4e-45a7-b958-a220c5607b15

Windows::Devices::Sensors::Custom::CustomSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Custom.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Gyrometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff607924-2fb5-4e05-8b50-91d580bf35f4

Windows::Devices::Sensors::Gyrometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Gyrometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d72a9f1a-622a-4f32-9f97-84164bde971d

Windows::Devices::Sensors::Gyrometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Gyrometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Inclinometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1e675e7c-c773-4d1d-97b8-d1f042e0da31

Windows::Devices::Sensors::Inclinometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Inclinometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db5e6d5a-2053-414d-9627-f7e509e594fe

Windows::Devices::Sensors::Inclinometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT LightSensor GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3904c863-e111-4ea5-b612-2e24ca5fdbe8

Windows::Devices::Sensors::LightSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Light.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT LightSensor ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e2d5dc2-9a22-4789-9656-fdc041498071

Windows::Devices::Sensors::LightSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Light.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Magnetometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/28eca931-6612-45ae-96f5-1fe976511910

Windows::Devices::Sensors::Magnetometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Magnetometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0aaa9417-15fb-40e3-9bc4-20fd8f0efe11

Windows::Devices::Sensors::Magnetometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Magnetometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT OrientationSensor GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12ba3746-955e-4fb4-b6bf-27e0bb799806

Windows::Devices::Sensors::OrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT OrientationSensor ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d642fbb6-0e0d-43cd-a390-d8fb2738a903

Windows::Devices::Sensors::OrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Orientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Pedometer FromIdAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/56d19b11-06c7-4784-8e6b-948f9434c7a6

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Pedometer GetCurrentReadings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c70dbfc0-e8c4-482e-ada0-d2aab674688d

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Pedometer GetCurrentReadings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f51446f0-0639-4fae-a5dd-b637a022293b

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Pedometer GetDefaultAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b300824b-72a3-4f8f-9290-d389e4b1cae4

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Pedometer GetSystemHistoryAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15cac994-2871-4834-92a6-ef1115a00ebd

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Pedometer GetSystemHistoryWithDurationAsync

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/67ad0e5d-bf34-4468-97cb-b56d3c2772ff

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Pedometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01f3b348-9c72-4481-bf32-a35646093f26

Windows::Devices::Sensors::Pedometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Pedometer.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Proximity GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/016e7893-1e2d-4562-94f1-c1baf937093d

Windows::Devices::Sensors::ProximitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Proximity.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Proximity Range

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ddd3be98-b9eb-492b-8f35-f9d3973a0485

Windows::Devices::Sensors::ProximitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Proximity.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Proximity ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/365877fd-042e-4164-8411-537bc5c50d33

Windows::Devices::Sensors::ProximitySensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.Proximity.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT Relative Inclinometer GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c46aedc3-7e6a-4824-bd18-91acabcec170

Windows::Devices::Sensors::Relative Inclinometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Relative Inclinometer ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/589d342c-05d7-4a25-b5c6-f2c26a8da861

Windows::Devices::Sensors::Relative Inclinometer C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Relative OrientationSensor GetCurrentReading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e110b31e-d5bd-4813-88a3-2395efe50568

Windows::Devices::Sensors::Relative OrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT Relative OrientationSensor ReadingChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b0e81ed-d8ed-4319-ac9c-622c393fb1a8

Windows::Devices::Sensors::Relative OrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.RelativeOrientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


WinRT SimpleOrientationSensor GetCurrentOrientation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/916f1d30-5692-4736-a92d-6adfac2a7cdb

Windows::Devices::Sensors::SimpleOrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.SimpleDeviceOrientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


WinRT SimpleOrientationSensor OrientationChanged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e4f4338e-c134-4813-be80-e6ca1521bf78

Windows::Devices::Sensors::SimpleOrientationSensor C++/Cx Functional Tests

Test details
Specifications
  • Device.Input.Sensor.SimpleDeviceOrientation.WinRT.Discretional
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation


x64 only Smart Card Minidriver Certification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db097b28-a6cb-42f5-964e-c4af1babb6c9

This is a version of an existing test. This automated test validates 32-bit versions of the smartcard minidriver DLL on 64 bit computers.

For information about this test, see Smart Card Minidriver Certification Test.

Test details
Specifications
  • Device.Input.SmartCardMiniDriver.SupportMultipleInstancesOnASystem
  • Device.Input.SmartCardMiniDriver.DoNotStopWhenResourcesAreUnavailable
  • Device.Input.SmartCardMiniDriver.SpecsAndCertifications
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Input additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID |
LLU_NetAccessOnly |


Device.Input additional documentation

In this section

  • How to measure Touch Down Latency by using an Acoustic Measurement Tool
  • How to measure Touch Panning Latency
  • How to run HLK Motion Sensor Tests
  • How to use the Precision Touch Testing Tool
  • Overview of measuring Touch Down Hardware Latency
  • Fingerprint Reader Testing Prerequisites
  • Game Controller Testing Prerequisites
  • Keyboard Testing Prerequisites
  • Mouse or other Pointing Device Testing Prerequisites
  • Sensor Device Testing Prerequisites
  • Smart Card Reader Testing Prerequisites
  • Troubleshooting Device.Input Testing
  • Device Orientation Quaternion Vector Algorithm
  • Global Navigation Satellite System (GNSS) Test Guidance


How to measure Touch Down Latency by using an Acoustic Measurement Tool

This article describes the detailed setup and procedures to measure touch down latency of touch hardware by using an acoustic measurement tool. The intended audience is testers who measure touch down latency of a touch device as required by the Windows Hardware Lab Kit (Windows HLK).

This article assumes that the reader is familiar with touch screens, understands the concept of touch screen latency, and has a basic understanding of electrical and software engineering.

This information applies to the Windows 8 operating system.

Windows Hardware Lab Kit requirements

You must install at least a minimal configuration of the Windows Hardware Lab Kit (Windows HLK). Windows HLK provides you the tools, processes, and tests to create and upload submission packages to certify devices and systems. The Windows HLKeliminates the need for external tools such as the WLK Log Viewer. This document assumes that you are familiar with the Windows HLK.

For instructions about how to install the Windows HLK, see Windows HLK Getting Started.

Windows HLK Studio

You can run the Windows HLK test management console Windows HLK Studio on the Windows HLK test controller. Touch tests display in the Windows HLK Studio when touch hardware is discovered. The Windows HLK Studio allows you to organize tests into projects, view features and tests that are associated with your device, run selected tests, and create a submission package.

Stand-alone tests

You can bypass using the Windows HLK Studio and run the tests directly on the test computer. However, you must have access to a Windows HLK controller to do this.

To manually run the tests in standalone mode, you must copy the following files from the Windows HLK controller to a local folder:

  • audiotouch.exe

  • wlklogannotation.dll

  • WTTLog.dll

Test hardware requirements

To run the tests that are described in this article, you must have the hardware that is described in this section in addition to a Windows HLK controller and test computer.

Touch acoustic measurement tool

The touch acoustic measurement tool consists of an acoustic sensor (microphone), a metal plate, a metal rod (pin), and a control box, as shown in Figure 1 Touch Acoustic Measurement Tool.

acoustic measurement tool

Figure 1 Touch Acoustic Measurement Tool

The control box has the following three controlling switches and a power switch.

  • Motor: The motor is not used for touch down latency measurement. Switch it to OFF.

  • Calibrate: The calibrate switch turns on and off the metal plate signal. Turn Calibrate ON when you perform calibrations.

  • Mode: You can switch between Tachometer (Tach) mode, which refers to the photointerrupter that is used for panning latency measurement, and Microphone (Mic) mode, which is used for touch down latency measurement.

Figure 2 Triex RA Tool Interface

ra tool interface

Figure 3 ITRI RA Tool Interface

For touch down latency measurements, you should initially set the switches as shown in the following table:

Switch | State
Power | OFF
Motor | OFF
Calibrate | ON
Mode | Microphone

Caution
You must power on the control box after you plug the USB into the test computer. If you plug the USB into the test computer after you power on the control box, you can unintentionally set the microcontroller to an unpredictable state.

External keyboard

If you run the tests by using a tablet device, you must use an external keyboard to perform the test procedures.

Calibration

The calibration test stage uses the calculated frequency of the microcontroller. During this stage, the higher resolution timestamps of the microcontroller calculate the latency of the sound wave.

The time frequency of the microcontroller is calculated for the first tap by comparing the two intervals of the host test computer and the microcontroller. The up-and-down pulse of the audio signal has a hard-coded signal duration of one millisecond and a lockout period of 1000 milliseconds, during which time no other audio signal is sent to the testing program. This lockout prevents vibrated sound waves from distorting test results. It is important that you do not double-tap or tap too quickly: wait at least two to three seconds between taps.

The sound wave latency is the time between the test rod touching the metal plate (this touch produces almost no latency), and the sensor detecting the touch through sound waves. On average, the latency should not exceed one millisecond. If you see more than two milliseconds of calibration latency, you must fail the test and investigate the cause of the failure.

Calibration setup

Perform the following steps to set up the test components for calibration.

To set up test components for calibration

  1. Connect the microcontroller to the computer.

  2. Turn the Power switch of the control box to ON. The settings of the control box should be as follows:

    Switch State

    Power

    ON

    Motor

    OFF

    Calibrate

    ON

    Mode

    Microphone

At this point, you can touch the screen and move the machine. You can also use the side nut to move the microphone.

  1. Run the touch down latency test from Windows HLK Studio on the Windows HLK controller, or run the standalone test audiotouch.exe on the test computer.

    IMPORTANT

    This test requires an extremely quiet environment to obtain accurate results.

The instruction **Press the space bar to start the calibration process.** displays.

  1. Put the microphone on one end of the screen (for example, at the upper-left corner). Use the black knob to lower the microphone so that it actually touches the screen.

  2. Put the metal plate at the farthest point on the screen away from the microphone (for example, at the bottom-right corner). If the metal plate does not stay in place, you can hold one end of the plate by using one hand while you tap with your other hand.

  3. Press the space bar. The word CALIBRATION displays.

Calibration steps

Use the test pin to lightly tap and hold on the metal plate approximately ten times. Be aware that tapping too hard on the metal plate might cause vibrations between the metal plate and the rod; we recommend that you lightly tap and hold for a few seconds. Do not slide the rod across the metal plate or double tap: these actions generate noise that distorts the test results.

Figure 4 Test Pin and Metal Plate shows you how to hold the metal pin onto the metal plate.

test pin and metal plate

Figure 4 Test Pin and Metal Plate

Calibration test expected results

The microcontroller frequency should display at the first tap; for example, "Clock synced. Frequency of microcontroller = < returned value>" where <returned value> is the calibration result. For subsequent taps, messages about sound wave latency display; for example, [12] calibration latency: 1.2 [ms].

Collection

After calibration completes, press the space key again to collect the tap latency data.

The test program calculates hardware touch latency by calculating the difference between the sound wave that is created by the touch that is reported through the microcontroller, and the touch event that is detected by the Windows WM_POINTER message. Some latency occurs for the time required for the sound wave to reach the microphone in addition to latency that is transformed through the microcontrollers before it reaches the computer under test. However, the calibration step is designed to measure worst case latency; if it shows less than two milliseconds of latency on average, this latency does not impact the overall touch down latency requirements of 25ms.

Collection setup

Perform the following steps to set up the test components for collection.

To set up test components for collection

  1. Change the mode to the Tach setting.

  2. Turn the Calibrate switch to OFF. The settings should be as follows:

    Switch State

    Power

    ON

    Motor

    OFF

    Calibrate

    OFF

    Mode

    Tachometer

  3. Remove the metal plate from the screen.

  4. Virtually divide the screen into six random regions to prepare to uniformly cover all six areas. The difference of sample counts in any two regions cannot be more than 10%; that is, if you tap 500 times for all regions, you cannot tap more than 90 times for any single region. This ensures that the latency of each region is equally represented in the final average latency.

    • If you plan to move the microphone as you cover each region, place the microphone in the first area that you plan to tap.

    • Alternatively, you can place the microphone near the center area (for example between (2,1) and (2,2) in Figure 5 Regions). In this case, you must move the microphone at least one time to also cover the original placement of the microphone.

      Figure 5 Regions

Collection steps

Use the following steps to perform collection.

To perform collection steps

  1. Turn the Microphone or Acoustic switch ON.

  2. Use your finger to tap quickly and firmly on the screen near the microphone. Do not tap and hold: tap and release quickly to make a distinct sound.

  3. Wait at least two to three seconds after the tap. The latency result should display; for example, [10] latency: 11.2 [ms].

    Randomly tap the screen around the microphone. Always pause least two to three seconds between taps.

  4. Repeat steps 1-3 to cover all areas of the screen.

    NOTE

    The preceding index (for example, [10] in the case [10] latency: 11.2 [ms]), is not the actual count of the measurement: it is the index for acoustic signals that are received from the microphone through the microcontroller. The index does not always change in increments of one; it can change in increments of two or more if noise was perceived between taps. The best way to ensure that you tapped exactly 500 times is to tap 10-20% more times than required; that is, tap 550 times or 600 times.

Collection expectations

The screen displays hardware touch latency. For example, [10] latency: 12.2 [ms].

Analysis and Report

Calibration and clock synchronization errors are reported by the test program in such a way that if errors occur, you can rerun the test or find the cause of the failure.

Average latency is reported through Windows HLK Studio. If you run standalone tests, you can view the latency reports in the TabletDigitizerOPK.wtl file by opening the file in Windows HLK Studio, in Notepad, or in another text viewer application.

Special Handling

The test procedure works well with capacitive and resistive devices; however, two types of devices need special handling. These are optical devices and fragile devices.

Optical Devices

You might not be able to place the microphone directly on an optical device screen because the device detects the placement itself as a touch or tap. To test optical devices, we recommend that you use one of the following methods:

  • Place the microphone on the bezel or frame: If the frame or the bezel is firmly attached to the screen (which is the case for most devices), you can place the microphone on the frame as you tap on the screen. Although the screen and the frame are made of different materials and might therefore have slightly different latencies, the difference is negligible.

  • Place the microphone just above the scan line: You can place the microphone just above the laser scan line (~2-3 mm from the screen) and then follow the test procedure described for fragile devices.

    NOTE

    You might have to experiment to find the scan line.

Fragile Devices

For some devices, especially devices in the prototype stage, placing the microphone firmly on the screen might produce ghost touches or other undesired behavior. In this case, place the microphone just above the screen and leave an approximate one mm gap between the microphone and the screen. Firmly tap the screen so that the sound wave reaches the microphone. For this test, you should tap more firmly than when you run a test in which the microphone is attached to the screen.

NOTE

Partially touching the screen is not recommended because it generates vibration.

Troubleshooting

Calibration errors

You might sometimes see very large latency numbers during calibration. The most likely cause for large latency numbers is that you did not tap and hold correctly throughout the entire test. Metal plate vibration and other acoustic events can generate more than one touch event.

Collection errors

You can encounter several kinds of errors during testing. The most common error is that the device fails to meet the minimum touch down latency goal of 25 milliseconds. A second common error is that you did not tap the minimum number of taps (500).

A third type of error is when the microcontroller's clock drifts during testing. In this case, the displayed error message is: ERROR: microcontroller's frequency changed more than 2%.

To detect whether the clock has drifted, the test program compares two clock frequencies:

  1. Initial clock frequency is obtained during the calibration phase when the tester taps on the metal plate.

  2. Current clock frequency is obtained from the collection timestamps by using the difference between the last and first time stamps.

If more than 2% difference exists between the initial and the current frequency, the test failed. In this case, you must rerun the test.

Support

Contact one of these certified jig vendors if additional support is required:

Triex Technologies, Inc.

+1 (206) 940-0943

http://www.triextech.com/ContactUs.php

Industrial Technology Research Institute

+886 (03) 5743887

http://www.itri.org.tw/eng/econtent/contact/contact01.aspx


How to measure Touch Panning Latency

This topic provides detailed setup instructions and procedures to measure touch panning latency in accordance with Hardware Certification for Windows 8.1. It assumes that the reader is familiar with touch screens, understands the concept of touch screen latency, and has basic understanding of electrical and software engineering.

Overview

Latency is a measure of time delay that is experienced in the touch digitizer system. Touch down latency is the time between the finger or stylus (actuator) touching the screen and the host operating system receiving the contact (usually through a HID report). Panning latency is slightly more complicated because the contact is moving along a continuous path but the reports arrive in discrete time intervals. Therefore, panning latency is defined only in terms of discrete time intervals for which reported touch data are available. Measuring panning latency is then reduced to knowing the time delay between when the touch actually occurs and when the operating system receives the touch event.

Methodology

This topic describes the setup and procedures to measure the panning latency of a touch hardware device by using a step motor and a photo-interrupter. The step motor drives a mechanical arm to drive an actuator that simulates a human finger. The actuator draws a circle on the tested device and the photo-interrupter circuit detects when the actuator is at a certain control point. This information is sent to the host computer by using a microcontroller and the testing application calculates latency based on when the device reports a touch event and when the actuator actually makes contact. The following diagram shows the overall concept.

measuring panning latency

Hardware requirements

This section describes the hardware components that are required to measure panning latency.

Step motor and photo-interrupter

The measuring tool consists of a step motor, a photo-interrupter, a rotating arm and an actuator, and a control box, which is visible in the background of the following figure.

The control box has three controlling switches and a power switch.

  • Motor: To turn on and off the step motor arm.

  • Calibrate: Not used for panning latency - turn it off. (Used for touch down latency only.)

  • Mode: Switch between Tach (refers to the photo-interrupter that is used for panning latency measurement) and Mic (microphone that is used for touch down latency measurement).

For panning latency measurement, the initial settings should be as follows:

Switch name | State
Power | Off
Motor | Off
Calibrate | Off
Mode | Tach

Power-on the control box after you plug the USB in to the computer. Plugging in USB after powering on the control box can result in an unpredictable state of the microcontroller.

Stepper motor settings

The stepper motor can be programmed to run in a variety of ways. By default, the stepper motor is programmed to run in an automated calibration mode. (This mode is explained in more detail in the "Automated calibration mode" section later in the document.) The automated calibration mode is designed to minimize calibration errors and latency variations by manual calibration.

During acquisition and collection stages, the motor runs at a constant speed of 0.75 revolutions per second. The stepper motor settings used for acquisition and collection stages are as follows:

  • AC (acceleration) = 0.167

  • DE (deceleration) = 0.167

  • VE (velocity) = 0.75

By using these settings, the step motor circles one time every 1.33 seconds.

Arm length

The angular velocity differs, depending on the radius of the arm. For example, if the radius of the circle is about 5 cm, the velocity is ~25 cm per second. To standardize the test procedure, the arm length should have a radius of 5 cm to reach the velocity of 25 cm per second. A tolerance of ±1 is allowed: that is, from 24 to 26 cm per second.

In the case of smaller tablet which is up to 10'' diagonal display size, the recommended radius is 3 cm instead of 5 cm.

Arm positioning

Ideally, you should cover as many areas of the screen as possible by running the test multiple times in different parts of the screen. The latency in any part of the digitizer is expected to be equal or below the target latency (15 ms).

  1. Test device with a keyboard: If you are using a tablet device, you will need an external keyboard to complete the testing procedures.

  2. Place the test device on a non-slipping surface: Place the test device in such a way that it does not move during testing. For a small device, a simple solution is to place it on top of a non-slip pad as shown in the figure below. Another way is to have a brace to hold the device firmly in place.

  3. Level the test device: the actuator is designed to minimize the effect of leveling so the leveling does not have to be perfect. However, you should ensure that the actuator surface (~9 mm in diameter) is touching the device uniformly and not standing on one edge.

  4. Close any unnecessary processes from the test device: Because you are measuring system performance, close any unnecessary processes from the test device.

Software requirements

The required software should be installed and configured by the logo controller and the client. If it is running as a standalone, copy stepmotor.exe, wlklogannotation.dll, and WTTLog.dll to a local folder.

Test procedure for Triex RA tool

The test procedure consists of three steps: calibration, acquisition, and collection. Before you start the test however, you have to level the device. The point of leveling is to align it with the level of the motor rotating in circles. If it is not leveled properly, the actuator will not make good contacts with the digitizer and the circles drawn by the step motor will become irregular and will greatly affect the latency numbers at the end. Verification methods are included to fail the test if the device is not properly leveled or aligned.

Calibration

When you start stepmotor.exe, you will see a blank screen. Press the space key to start calibration. The purpose of calibration is to locate the reported position of a touch within a tolerable error estimate when the photo-interrupter is signaled. Because calibration results can greatly affect the latency numbers, it is important that you calibrate carefully.

Setup

  1. Connect the microcontroller to the computer.

  2. Turn on the Power switch of the control box.

    Switch name State

    Power

    On

    Motor

    Off

    Calibrate

    Off

    Mode

    Tach

  3. Make sure that Motor switch is turned off.

  4. Make sure that the photo-interrupter is not signaling (the photo-interrupter's light is off). The slot of the disk should be positioned about 2-3 mm past the photo-interrupter signal beam.

    There are two reasons for the positioning. First, when you turn on the motor, the motor arm will jitter slightly. When it does, you do not want it to cross the beam and therefore make the photo-interrupter signal. Second, when you are running an automated calibration script, this is the position where the loop starts and you want to make sure that the end of the loop (when the calibration begins) aligns properly to be under the photo-interrupter. If you are manually calibrating, this is still a good position to start at so, you do not have to change anything.

  5. Do not move or lower the arm until you enter the calibration phase.

  6. Run stepmotor.exe. If you are running the program through the Windows HLK Controller, select the machine and panning latency test to start the test.

  7. The following text message appears:

    Press the space bar to start the calibration process.

  8. Press the space bar. The word CALIBRATION appears on the screen.

  9. Lower the actuator onto the surface of the screen.

Test steps (automated)

  1. Turn on the motor. The stepper motor will run in a calibration mode nine times.

  2. At the end of the calibration mode, it will stop for five seconds. Follow the instructions in the Acquisition section of this topic.

Test steps (manual)

  1. Slowly turn the arm in the same direction as that in which the motor will be moving when it is turned on.

  2. Decrease the speed almost to the point of a complete stop when the needle (or the hole) passes through the photo-interrupter. (Note that the maximum velocity should not exceed 1% of the acquisition/collection speed; that is., if the acquisition/collection velocity is 25 cm/s, then the calibration velocity when the slot passes through the photo-interrupter should be less than 0.25 cm/s.)

  3. Carefully turn the arm to pass through the photo interrupter.

  4. Repeat steps 1 to 2 at least six times.

    When the signal is interrupted, you should see the photo-interrupter blinking and the test window will report the exact location of the screen where the actuator is making a contact. The following is a sample result:

    Touch Pointer Update count=0, x=508,y=110
Touch Pointer Update count=1, x=512,y=113

Expected results

If calibration is performed successfully, you will not see any error messages.

Acquisition

During the acquisition step, the velocity of the step motor and the shape of the circle are calculated.

Setup

Make sure that the slot is placed as far away from the photo-interrupter as possible.

Test steps

  1. Press the space bar and turn on the Motor switch at the same time. The text on the screen should change to ACQUISITION.

  2. Let the device run for approximately ten loops.

  3. Press the space bar again to go into COLLECTION mode.

Expected results

The screen will display that COLLECTION mode is active and show the acquisition data. It shows a list of time and velocity calculated for each loop. The first few loops might be skipped if the step motor jittered and showed poor results. A sample text is as follows:

[4]: t: 1.333 [s] v: 25.456 [cm/s]

This tells you:

[loop number]: t:<loop time in seconds> [s] v:<velocity> [cm/s]

Collection

Data collection represents the final step for the test.

Setup

Make sure that the word COLLECTION appears at the top of the screen. If the word CALIBRATION remains after you press the space bar, an error occurred. You will need to run the test again.

Test steps

  1. Let the motor run about ten loops.

  2. Press the space bar to finish the test.

  3. Turn off the Motor switch.

Expected results

You will see pass or fail results.

Test procedure for ITRI RA tool

The procedure for running the Touch Panning Latency tool on the ITRI RA tool is slightly different from running the test with the Triex RA tool. The test itself remains the same and contains the same set of Calibration, Acquisition, and Collection steps. The steps for running the test with ITRI are as follows:

  1. RA chassis

    itri ra tool

    Note that in the case of the ITRI RA tool, the calibrate switch has three positions: on, off, and home, which is the center position.

  2. To begin, the switches should be as follows:

    Switch name State

    Power

    On

    Motor

    Off

    Calibrate

    Off (down)

    Mode

    Panning

  3. Zero the system by changing the switches to the following and letting the motor rotate the arm 45 degrees. When completed, turn the motor to OFF.

    Switch name State

    Power

    On

    Motor

    Off

    Calibrate

    Home (center)

    Mode

    Panning (upper)

  4. Place the test finger down on the device and press the space bar to enter the Calibration phase. Switches are now as follows:

    Switch name State

    Power

    On

    Motor

    On

    Calibrate

    On (upper)

    Mode

    Panning (upper)

  5. Allow the test to run past the count of 17, then turn off Motor and turn the Calibrate switch to off (lowest position):

    Switch name State

    Power

    On

    Motor

    Off

    Calibrate

    Off (lower)

    Mode

    Panning (upper)

  6. Press the space bar, and turn the motor back ON for the Acquisition phase.

  7. After the screen shows a count value over 1999, press the space bar. The test display will show the motor circle time and the speed. Wait for the contact information to be collected in the Collection phase for approximately ten loops, and then press the space bar. At this point, the system is finished. Press the space bar again and turn off the motor.

Analysis and report

Analysis

If there are any failures in calibration or acquisition, the test will fail and you can view details for the failure in the report. You will see an error such as the following:

Warning multiple touch devices present.
Calibration failed: x11err=3.71 y11err=1.14 x22err=9.14 y22err=1.71
Acquisition failed: Circles are showing variations in pixel= 9.70
[135] 581 451 739 602 [199556137598] > 18 48

Report

Pass or fail is reported through the Windows HLK. If you are running the test manually, you can open the TabletDigitizerOPK.wtl file in WTT or in Notepad. The average panning latency is logged toward the end. The target latency is equal or less than 15 milliseconds.

Automated calibration mode

Automated calibration mode is the default mode for the RA tool. When you run the script, first make sure that the step motor is set to 20000 steps per revolution in the Q programmer settings. This configuration can be set using the ST Configurator tool. Go to Motion & I/O and then Pulse & Direction Control.

st configurator (1)

st configurator (2)

Make sure that the Steps/Rev setting shows 20000.

st configurator (3)

The settings on the right side should also show Steps/Rev currently set for the step motor.

st configurator (4)

If the settings are correct, then the automation script will run in three modes in sequential order:

  1. Calibration mode: When you first turn on the motor, this is the first mode that it will run. During calibration mode, the step motor runs at a velocity of 0.75 revolutions per second (about 1.33 seconds per loop) for 339 degrees from the starting position. Then it stops for 0.5 second before it runs at a velocity of 0.0042 revolutions per second (lowest possible velocity for stepper motor) for 21 degrees. While the stepper motor is running at a very low speed, the testing program (stepmotor.exe) correlates the positions and timestamps from the reported touch contacts when the photo-interrupter beam is interrupted.

    The following example is a screen shot of how the circle will look. The arc portion where the arrow is pointing at is where the stepper motor runs in a slow speed and where the photo interrupter should be signaling. It is important that the operator aligns the starting position of the disc properly: that is, the slot on the disc should be about 2-3 mm past the photo-interrupter.

    calibration mode circle

    As a reference, the following describes how this calibration arc is designed:

    VE parameter in Q-Programmer 0.0042

    Average calibration signal arc length

    1.85 cm (based on 31.26 cm circumference)

    Average calibration signal angle

    0.37 radian (21.20 degrees

    Average calibration signal time

    12.50 seconds (including 0.5 seconds of wait time when changing velocity)

    Average calibration signal velocity

  2. Five seconds of waiting: After nine loops of calibration, the motor will stop for five seconds. During this time, the operator must press the space bar to enter into Acquisition mode.

  3. Acquisition/Collection mode: After five seconds of waiting, the motor will run at a velocity of 0.75 revolutions per second (1.33 seconds per loop) infinitely.

Troubleshooting

Calibration

During calibration, the test program cannot calculate the exact location of a touch event when the photo-interrupter is signaled. It is therefore important that you do not introduce latency by spinning the arm too fast. If there is an error, you will see an error message on screen. For example:

Calibration failed: x11err=3.71 y11err=1.14 x22err=9.14 y22err=1.71.

Stop and investigate the cause before you restart the test. There are a few common reasons for failure. They occur because the test program cannot make good calculations of the touch point. Reasons for this include:

  • You moved the finger (actuator) too fast when the photo interrupter signaled.

  • The device was moved.

Resolve these issues and try again until you get a good calibration. Additional things to keep in mind are:

  • Never turn the arm the other way around.

  • Move the arm very carefully when passing through the photo-interrupter, to minimize the error and latency that you might be introducing.

  • There should be always two signals when the photo-interrupter is interrupted. The first signal occurs when the light passes through the slot at the end of an edge. The second signal occurs when the light is blocked after it passed through the open slot. The index count is zero-based. After two events have occurred, the count should be an odd number. If you see the following message when you have just started calibration and did not even turn the arm, you have probably turned the arm (therefore the disk) around the photo-interrupter at least one time, causing it to signal. This will automatically cause the calibration to fail. Stop the test immediately and restart.

    Touch Pointer Update count=0, x=0, y=0

Acquisition

If acquisition fails, you will see an error message that is similar to one of the following:

ERROR: Acquisition failed: Loop times not consistent > 6.3
ERROR: Acquisition failed: Circles are showing too many variations in pixels Rcm_error=0.5 xPixelErr=20 yPixelErr=20

The first type of error is generated when the average difference among loop times is more than five milliseconds. The second type of error occurs when the circles are not drawn as perfect circles and therefore result in pixel variations that are greater than five pixels. Common causes for this behavior include the following:

  • An improperly leveled or incorrectly calibrated device.

  • The device was moved.

  • Step motor speed is not consistent. (This is not a probable explanation because it is a well-established, widely used device; nevertheless it is possible that the motor is defective on your particular device.)

Collection

There should be few problems during collection if the calibration and acquisition steps are passed. Most errors are due to external factors such as, the device being moved, some other processes interrupting the test program, or the device itself failing. Operators might encounter the following three common issues:

Problem 1: Electromagnetic field interference

An error can result from the effect of electromagnetic force that is generated by the stepper motor. Depending on the device, this can be manifested in various ways: for example, ghost touch points being generated. The solution to the problem is to provide a good ground.

Problem 2: Other processes interrupt the test program

When another process interrupts the test process, it will usually corrupt the test result by negatively impacting the latency numbers.

You can diagnose this problem by comparing photo interrupter signal intervals. Review the csignal.txt file, which contains the time stamps from the photo-interrupter. The second column shows the system time stamps and the third column shows the microcontroller's time stamps. For example:

[ 0:       0] 431506434557 538485264317
[ 1:      10] 431506447610 538485343495
[ 2:    1333] 431508166028 538495929302
[ 3:    1343] 431508178968 538496008565
[ 4:    1797] 431508769804 538499651185
[ 5:    1803] 431508776386 538499652266
[ 6:    2665] 431509897168 538506594116
[ 7:    2675] 431509910127 538506673294
[ 8:    3998] 431511628522 538517258922
[ 9:    4008] 431511641481 538517338232
[10:    5331] 431513359910 538527923775
[11:    5342] 431513372973 538528003038
sfirst =  0

The last entry in the file shows the index of the first valid signal sequence. A 'valid signal sequence' refers to the beginning of signal sequences when the system became stable. Between acquisition and collection, the test program writes the acquisition results to log files and, depending on the system performance, it might take some time for it to become stable. In the above example, the very first signal was valid so you can start comparing the time stamp intervals.

You can take time stamp intervals by noting the difference between the two even numbered time stamps; or example, 0, 2, 4, 6, etc. As shown in the following table, the signals 4 and 6 are quite different from other signal intervals. Therefore, we know that another process has interrupted the test during that time. In normal cases, you should see less than 1% of difference.

Index | Time stamp | Interval
0 | 431506434557 |
2 | 431492585219 | 1731471
4 | 431494316516 | 603776
6 | 431496047748 | 1127364
8 | 431497779297 | 1731354
10 | 431499509508 | 1731388
12 | 431501240620 | 1731288

Problem 3: Sampling rate changes

If a device changes its sampling rate, a significant variance in latency results will occur. You can diagnose this problem by comparing acquisition and collection sampling rates.

You can use external tools to measure the sampling rate of a device before and after the motor was turned on. Another method is to analyze the logs that are generated by stepmotor.exe.

  1. Open Acquisition.txt.

  2. Take the first and last row's timestamps (last column):

    581   660   709   602   199501901480
581   805   512   602   199554132317

  3. Calculate the acquisition's sampling rate as follows:

    (Last timestamp - first timestamp) /number of samples (rows)

  4. Open Collection.txt.

  5. Take the first and last row's timestamps (last column):

    581   822   423   602 [199554407006]
581   288   164   602 [199594255626]

  6. Calculate the collection sampling rate as follows:

    (Last timestamp - first timestamp) /number of samples (rows)

If you see more than 2% of difference between the two, the collection data is not reliable and you should investigate the cause.

Additional support

If additional support is required, contact one of the following certified jig vendors:

  • Triex Technologies, Inc.

    +1 (206) 940-0943

  • Industrial Technology Research Institute

    +886 (03) 5743887


How to run HLK Motion Sensor Tests

Introduction

This document is a guide or a supplement to the existing HLK 2.0 documentation and tools for sensors OEMs, ODMs and IHVs. It provides some tips and tricks that a partner can leverage to run the tests. Partners are free to use other implementations to test their device-- this is just a singular reference. Items identified in this document are optional (you can run the tests without these pieces of hardware). They have simply been used to help demonstrate the orientations for the purposes of this document.

This document assumes that the HLK 2.0 or greater is being used to test a tablet form factor system (requiring motion and light sensors). Other form factors (e.g. laptops) are beyond the scope of this document. Although the tests do validate other form factor systems, the details below are primarily designed to optimize testing on tablet form factor systems.

This document describes the following tests:

  • Verify Sensor Orientation - 3D Accelerometer

  • Gyroscope Sensor Test

  • Verify Sensor Orientation - 3D Compass

  • Verify Sensor Orientation - Inclinometer

  • Verify Advanced Orientation Sensors

The motion sensor tests are required for the following:

  • Sensor device certification

  • System certification

The motivation to have identical tests in both of these areas is to ensure that IHVs provide passing hardware, firmware, and drivers to PC manufacturers and that PC manufacturers integrate the parts correctly onto their systems to provide accurate and reliable sensor readings.

Test Purpose

The primary purpose of the motion sensor tests is to assist hardware partners in validating that their sensors are correctly orientated in the system and that they meet the WHLK required accuracy requirements. These tests are not designed to provide full test coverage or to take advantage of specialized equipment that can more accurately determine the inaccuracies of individual sensors. It is recommended that PC manufacturers to test their systems with additional applications and quality assurance tests after passing WHLK (e.g. test with production-quality Windows 8 apps).

Recommended Testing Sequence

Microsoft recommends that you run the tests in the order that is listed in the following table. By testing the accelerometer and gyroscope first, you can ensure that these basic sensors are working correctly. The next set of tests validates the data from Compass, Inclinometer, and Orientation sensors that are derived by combining data of multiple sensors. It is also recommended not to attempt to execute subsequent tests until all previous tests are passing.

Sensor | Test Name | Dependencies
Accelerometer | Verify Sensor Orientation - 3D Accelerometer | n/a
Gyroscope | Gyroscope Sensor Test | n/a
Compass | Verify Sensor Orientation - 3D Compass | Accelerometer, Gyro, Compass
Inclinometer | Verify Sensor Orientation - Inclinometer | Accelerometer, Gyro, Compass
Fusion/Orientation Sensors (Rotation Matrix / Quaternion) | Verify Advanced Orientation Sensors | Accelerometer, Gyro, Compass

Suggested Test Equipment

For the purposes of this document, the following hardware items were utilized to help run the WHLK tests. While these devices are not required for WHLK, they may assist the validation engineer get through the tests more easily if used.

suggested test equipment

Figure 1 Suggested Test Equipment

  • Bluetooth keyboard

  • Bluetooth mouse

  • Compass / GPS

  • Clamp and tape to hold system

  • Revolving turn-table (for example, a Lazy Susan)

  • Sensor Diagnostic Tool

These additional devices help test a tablet form factor system (where accelerometer, gyro, compass, inclinometer and orientation sensors are required). For other configurations, these tools may not apply. The remainder of this document will only focus on tablet and not other form factors.

The sensor diagnostic tool (sensordiagnostictool.exe available in the WDK) is useful for debugging test failures. This tool will show the data being returned in real-time from the various motion sensors which can be compared to the expected results.

Verify Sensor Orientation - 3D Accelerometer

Test Scope: This test verifies the accelerometer is correctly orientated in the system. The tests have an error tolerance of +/- 0.1 G.

Prerequisites before running this test:

  1. Manually verify that screen autorotation works as expected.

  2. Use SDT and validate that the sensors do not show new data events when sitting stationary.

Once these simple prerequisites pass, proceed to run the WHLK test. Should you run into errors with the tests, ensure that the device is in the correct orientation as per this document. PC manufacturers with questions should first contact their sensor manufacturer (IHV) to identify how they passed the WHLK tests before contacting Microsoft for assistance with WHLK tests.

Accelerometer Test 1

Hold the device perpendicular to a flat and level surface with the Windows button on the bottom.

Expected values:

SENSOR_DATA_TYPE_ACCELERATION_X_G | 0
SENSOR_DATA_TYPE_ACCELERATION_Y_G | -1
SENSOR_DATA_TYPE_ACCELERATION_Z_G | 0

accelerometer test 1

Figure 2 Accelerometer Test 1

Accelerometer Test 2

Rotate device 90 degrees clockwise, keeping the device perpendicular to the flat and level surface. The Windows button should be on the left.

Expected values:

SENSOR_DATA_TYPE_ACCELERATION_X_G | 1
SENSOR_DATA_TYPE_ACCELERATION_Y_G | 0
SENSOR_DATA_TYPE_ACCELERATION_Z_G | 0

accelerometer test 2

Figure 3 Accelerometer Test 2

Accelerometer Test 3

Now lay the device flat, with the windows button away from you.

Expected values:

SENSOR_DATA_TYPE_ACCELERATION_X_G | 0
SENSOR_DATA_TYPE_ACCELERATION_Y_G | 0
SENSOR_DATA_TYPE_ACCELERATION_Z_G | -1

accelerometer test 3

Figure 4 Accelerometer Test 3

Accelerometer Test 4

Now flip the device over, so the screen is face down.

Expected values:

SENSOR_DATA_TYPE_ACCELERATION_X_G | 0
SENSOR_DATA_TYPE_ACCELERATION_Y_G | 0
SENSOR_DATA_TYPE_ACCELERATION_Z_G | 1

accelerometer test 4

Figure 5 Accelerometer Test 4

Gyroscope Sensor Test

Test Scope:

Gyroscopes generally emit noise on the magnitude of +/- 2 degrees per second. Prior to running the Gyroscope verification tests, testers should use the sensor diagnostic tool to validate the gyroscope sensor is not generating values greater than 2 degrees per second when the system is stationary.

Prerequisites before running this test:

  1. Accelerometer tests pass.

  2. Use SDT, and validate that the sensors do not return data when sitting stationary on a flat surface.

If the gyroscope sensor is generating excessive noise, testers should work with the sensor manufacturer to understand and fix the source of the noise.

Gyro tests expect to receive an angular velocity of greater than 40 degrees per second on the axis being rotated and less than 15 degrees per second on the stationary axes. To achieve passing results, testers will likely find that the system can be rotated on a turntable to keep the other two axes stationary. Note the system should also be centered on the turntable to prevent movement on other axes from detecting rotation.

Gyro Test 1

Lay the device flat with the screen up. Rotate the device clockwise.

Expected values during rotation:

SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_X_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Y_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Z_DEGREES_PER_SECOND_SQUARED | < -40

gyro test 1

Figure 6 Gyro Test 1

Gyro Test 2

Lay the device flat with the screen up. Rotate the device counterclockwise.

Expected Values during rotation:

SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_X_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Y_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Z_DEGREES_PER_SECOND_SQUARED | > 40

gyro test 2

Figure 7 Gyro Test 2

Gyro Test 3

Hold the device vertical with the windows button on the bottom. Looking down on the device, rotate the device clockwise along the axis between the top of the screen and the windows button.

Expected values during rotation:

SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_X_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Y_DEGREES_PER_SECOND_SQUARED | < -40
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Z_DEGREES_PER_SECOND_SQUARED | < 15

gyro test 3

Figure 8 Gyro Test 3

Gyro Test 4

Hold the device vertical with the windows button on the bottom. Looking down on the device, rotate the device counterclockwise along the axis between the top of the screen and the windows button.

Expected values during rotation:

SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_X_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Y_DEGREES_PER_SECOND_SQUARED | > 40
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Z_DEGREES_PER_SECOND_SQUARED | < 15

gyro test 4

Figure 9 Gyro Test 4

Gyro Test 5

Hold the device vertical with the windows button on the left. Looking down on the device, rotate the device clockwise keeping the device vertical and in the portrait orientation.

Expected values during rotation:

SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_X_DEGREES_PER_SECOND_SQUARED | > 40
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Y_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Z_DEGREES_PER_SECOND_SQUARED | < 15

gyro test 5

Figure 10 Gyro Test 5

Gyro Test 6

Hold the device vertical with the windows button on the left. Looking down on the device, rotate the device counterclockwise keeping the device vertical and in the portrait orientation.

Expected values during rotation:

SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_X_DEGREES_PER_SECOND_SQUARED | <-40
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Y_DEGREES_PER_SECOND_SQUARED | < 15
SENSOR_DATA_TYPE_ANGULAR_ACCELERATION_Z_DEGREES_PER_SECOND_SQUARED | < 15

gyro test 6

Figure 11 Gyro Test 6

Verify Sensor Orientation - 3D Compass

Most compass implementations use data from both the 3D magnetometer and the gyro to calculate the current direction the user is facing relative to the magnetic north pole. Some implementations also use data from the accelerometer. Therefore, if the gyroscope or accelerometer sensor is not functioning properly, testers should expect to see the compass return incorrect headings.

Since the earth's magnetic force is relatively weak, the magnetometer sensors will often be subject to interference from other components inside the system. If the magnetometers are not adequately isolated from sources of electromagnetic interference such as antennas, power lines, or other components that are composed of materials such as iron that interfere with magnetic reception, testers will find that the compass will return incorrect headings. Please refer to the Integrating Motion and Orientation Sensors whitepaper for guidance on correct magnetometer placement and best practices.

The user is strongly encouraged to stand holding the system at various angles and rotate themselves so they end up facing different directions. Regardless of the angle the system is being held, or landscape / portrait orientation, the compass should always return the heading that is relative to the direction that the user is facing. Note that sensor diagnostic tool can be used to display the heading value from the compass sensor. If testers find out that the compass is returning incorrect or inconsistent results, please work with the magnetometer sensor vendor to determine if the error is a result of interference or potentially an incorrect sensor fusion algorithm.

The compass tests in the WHLK validate that the compass returns expected values when the system is held at different directions and orientations. The compass tests allow for an error tolerance of +/- 10 degrees. Testers should use a reference compass to determine the direction of magnetic north prior to starting the compass test.

Compass Test 1

Lay the device on a flat surface with the Windows button pointing due south.

The compass should return a heading near 0 degrees.

NOTE

Ignore the logging exception text. This will not cause a failure to be logged.

compass test 1

Figure 12 Compass Test 1

Compass Test 2

Now hold the device vertical with the Windows button on the bottom, with the screen towards you. Aim the Windows button due north.

The compass should return a heading near 0 degrees

compass test 2

Figure 13 Compass Test 2

Compass Test 3

Now lay the device flat, screen down with the windows button pointing due south.

The compass should return a heading near 0 degrees.

compass test 3

Figure 14 Compass Test 3

Compass Test 4

Now rotate the screen 90 degrees clockwise so the Windows button is pointing due West.

The compass should return a heading near 90 degrees.

compass test 4

Figure 15 Compass Test 4

Compass Test 5

Rotate the screen another 90 degrees clockwise so the Windows button is pointing due North.

The compass should return a heading near 180 degrees.

compass test 5

Figure 16 Compass Test 5

Compass Test 6

Rotate the screen another 90 degrees clockwise so the Windows button is pointing due East.

The compass should return a value near 270 degrees.

compass test 6

Figure 17 Compass Test 6

Verify Sensor Orientation - Inclinometer

Based on the guidance in the Integrating Motion and Orientation Sensors whitepaper, the inclinometer implementation could use data from the accelerometer, gyroscope and compass to determine the Euler angle values.

The tests will allow for angle errors of +/- 10 degrees.

IMPORTANT

Please refer to the Validation of Euler Angles section of the Integrating Motion and Orientation Sensors whitepaper for the expected angles for each of the inclinometer tests.

Inclinometer Test 1

Place the device on a flat and level surface with the windows button pointing due SOUTH.

inclinometer test 1

Figure 18 Inclinometer Test 1

Inclinometer Test 2

Place the device on a flat and level surface with the windows button pointing due EAST.

inclinometer test 2

Figure 19 Inclinometer Test 2

Inclinometer Test 3

Place the device on a flat and level surface with the windows button pointing due NORTH.

inclinometer test 3

Figure 20 Inclinometer Test 3

Inclinometer Test 4

Place the device on a flat and level surface with the windows button pointing due WEST.

inclinometer test 4

Figure 21 Inclinometer Test 4

Inclinometer Test 5

Place the device on a flat and level surface face up with the windows button pointing due SOUTH.

inclinometer test 5

Figure 22 Inclinometer Test 5

Inclinometer Test 6

Hold the device vertically against a flat and level surface so the windows button is on the bottom, the +Y axis points straight up and the screen is facing due SOUTH.

inclinometer test 6

Figure 23 Inclinometer Test 6

Inclinometer Test 7

Place the device on a flat and level surface face down so the windows button is pointing due NORTH.

inclinometer test 7

Figure 24 Inclinometer Test 7

Inclinometer Test 8

Hold the device vertically against a flat and level surface so the windows button is on the top, the +Y axis points straight down and the screen is facing due NORTH.

inclinometer test 8

Figure 25 Inclinometer Test 8

Inclinometer Test 9

Place the device on a flat and level surface face up with the windows button pointing due SOUTH.

inclinometer test 9

Figure 26 Inclinometer Test 9

Inclinometer Test 10

Hold the device vertically against a flat and level surface on its right side so the screen is pointing due EAST.

inclinometer test 10

Figure 27 Inclinometer Test 10

Inclinometer Test 11

Place the device on a flat and level surface face down with the windows button pointing due SOUTH.

inclinometer test 11

Figure 28 Inclinometer Test 11

Inclinometer Test 12

Hold the device vertically against a flat and level surface on its left side so the screen is pointing due WEST.

inclinometer test 12

Figure 29 Inclinometer Test 12

Verify Advanced Orientation Sensors

Most rotation matrix and quaternion implementations will use data derived from both the accelerometer and compass to determine rotation matrix and quaternion values. Testers are recommended to first validate accelerometer and compass values before attempting to run the advanced orientation tests.

The tests use dot products to compute the delta between the expected vector and the vector retrieved from the advanced orientation sensors. The tests allow for a delta of up to 15 degrees. If testers find that the sensor is returning different values than what the test expects then the orientation fusion algorithm should be reviewed to see that it produces consistent results with the values given in the Integrating Motion and Orientation Sensors whitepaper.

IMPORTANT

Please refer to the Validation of Euler Angles section of the Integrating Motion and Orientation Sensors whitepaper for the expected quaternion and rotation matrix values.

Advanced Orientation Sensor Test 1

Place device on a flat level surface, screen up with the windows button pointing due SOUTH.

advanced orientation sensor test 1

Figure 30 Advanced Orientation Sensor Test 1

Advanced Orientation Sensor Test 2

Place device on a flat level surface, screen up with the windows button pointing due EAST.

advanced orientation sensor test 2

Figure 31 Advanced Orientation Sensor Test 2

Advanced Orientation Sensor Test 3

Place device on a flat level surface, screen up with the windows button pointing due NORTH.

advanced orientation sensor test 3

Figure 32 Advanced Orientation Sensor Test 3

Advanced Orientation Sensor Test 4

Place device on a flat level surface, screen up with the windows button pointing due WEST.

advanced orientation sensor test 4

Figure 33 Advanced Orientation Sensor Test 4

Advanced Orientation Sensor Test 5

Place device on a flat level surface, screen up with the windows button pointing due SOUTH.

advanced orientation sensor test 5

Figure 34 Advanced Orientation Sensor Test 5

Advanced Orientation Sensor Test 6

Hold the device vertically with the windows button on the bottom and the windows button pointing due SOUTH.

advanced orientation sensor test 6

Figure 35 Advanced Orientation Sensor Test 6

Advanced Orientation Sensor Test 7

Place the device on a flat level surface with screen down and the windows button pointing due NORTH.

advanced orientation sensor test 7

Figure 36 Advanced Orientation Sensor Test 7

Advanced Orientation Sensor Test 8

Place the device on a flat level surface with screen down and the windows button pointing due NORTH.

advanced orientation sensor test 8

Figure 37 Advanced Orientation Sensor Test 8

Advanced Orientation Sensor Test 9

Place device on a flat level surface, screen up with the windows button pointing due SOUTH.

advanced orientation sensor test 9

Figure 38 Advanced Orientation Sensor Test 9

Advanced Orientation Sensor Test 10

Hold the device vertically with the windows button on the side, left side on top, and the windows button pointing due EAST.

advanced orientation sensor test 10

Figure 39 Advanced Orientation Sensor Test 10

Advanced Orientation Sensor Test 11

Place the device on a flat level surface with screen down and the windows button pointing due SOUTH.

advanced orientation sensor test 11

Figure 40 Advanced Orientation Sensor Test 11

Advanced Orientation Sensor Test 12

Hold the device vertically with the windows button on the side, left side on bottom, and the windows button pointing due WEST.

advanced orientation sensor test 12

Figure 41 Advanced Orientation Sensor Test 12


How to use the Precision Touch Testing Tool

The Precision Touch Testing Tool, or PT3, is a multi-function tool that tests high-performance touch digitizers against the Windows Hardware Lab Kit touch tests for Windows 8. It can operate at performance levels where human operator precision is not sufficient. It can tap precisely at a defined point, realign quickly, perfectly trace up to five straight lines simultaneously, draw fixed-radius curves, and support adjustable distances between adjacent contacts.

The PT3 does all of these tasks well, but its capable performance does not make these tasks trivial. You must practice and prepare to become comfortable using the PT3.

Terminology and Visual Orientation

The following images show the terminology and visual orientation of the PT3 that is referenced in this topic.

precision touch testing x-axis

Figure 1: X-axis

precision touch testing y axis

Figure 2: Y-axis

precision touch testing z axis

Figure 3: Z-axis

precision touch testing r1 axis

Figure 4: R1-axis

precision touch testing r2 axis

Figure 5: R2-axis

precision touch testing actuators

Figure 6: Actuators in the carriage

In addition:

  • The R2 Axis is also referred to as the base plate.

  • The R1 Axis is also referred to as the rotational stage.

  • DUT stands for Device Under Test.

  • An Actuator is a finger-like module used to deliver a touch to the screen. Five actuators are shown in Figure 6.

  • The Carriage is the metal piece that holds the actuators. Shown in Figure 6.

Basic Usage

Place the DUT into the housing

The PT3 has four locks to fix the DUT into the housing. We recommend that you position the device so that the center of its screen is concentric with the base plate; this will make alignment easier in many cases. A scale is drawn on the plate to facilitate this. The gap in the center of the base plate is 3 cm in diameter.

We recommend that you position the device so that the device faces the tester in the 0° position.

Position an actuator and make contact

The actuator housing moves freely along four axes: horizontally and vertically in the plane of the base plate, up and down perpendicular to the base plate (Z-axis), and rotationally in the plane of the base plate.

You can restrict motion along the X-axis and Y-axis by using the locks that are found on the rails, as shown in figures 1 and 2. You can restrict rotational motion by turning the knob that is located on the side of the actuator housing (shown in figure 5).

The actuator (or actuators) is brought into contact with the screen by using the red lever on top of the actuator housing, which moves the actuators along the Z-axis. When five actuators are placed in the carriage, the spring will balance the actuators so that they can remain floating in position.

The user interface (UI) of the Windows Hardware Lab Kit (Windows HLK) tests provides affordances for performing precise targeting. Each target is rendered as a set of crosshairs inside a pair of concentric circles. The inner circle, which is colored green or yellow, has a diameter of 9 mm, while the outer circle has a diameter of 10 mm. Position the actuator so that it is contained in the inner circle as best as you can. Use the crosshairs to better position the center of the actuator at the center of the target.

Trace a line

Linear motion is generally performed along the Y-axis, with the X-axis and rotational stage locked. This provides maximum ease of use. Alignment is generally done as follows:

  1. Lock the rotational stage at 0°.

  2. Move the actuator housing along the X-axis and position it over the starting target, which will be green.

  3. Roughly align the on-screen line to the Y-axis by rotating the base plate.

  4. Without bringing the actuator into contact with the screen, trace the on-screen line to its terminus at the yellow target. Use the fine-adjustment knob to correct the alignment.

  5. Repeat steps 2 through 4 until a line can be traced from the center of the green target to the center of the yellow target.

Shortcuts

When the following conditions are met, you can save a significant amount of time in aligning the actuator(s):

  1. The screen is rectangular.

  2. Adjacent edges on the device are at 90° to each other.

In this case, you can use the R1 axis to perform all of the alignment in horizontal and vertical cases simply by locking the rotational (R2) stage at 0° and positioning the R1-axis at 0°, 90°, 180° or 270°, as the situation dictates.If the screen is centered on the device, and the device itself is centered in the PT3, you can use the 45° angles on the rotational stage to perform diagonal alignment.

Trace a curve

Curves are traced by using the motion of the R2-axis, or rotational stage. The center of the carriage is clearly marked, so that circles of varying radii can quickly be configured. The test uses three radii: 1.2 cm, 3 cm, and 3.2 cm.

To trace the curve, first align over the starting point, or points, of the motion. Then, lock the motion of the x and y axes by using the lock switches. Finally, use the handle that is attached to the actuator housing to rotate around the center of the carriage.

Adjust the Actuators

Actuators are affixed to the carriage by magnets. To add an actuator, simply place it into the concave underside of the carriage until it snaps into place. To remove an actuator, tilt it until it becomes free and pull it down and out of the carriage.

You can set the position of the actuator in one-millimeter increments by using the scale on the carriage. For example, this lets you set five contacts at mutual center-to-center distances of 13 mm to execute the horizontal and vertical Input Separation tests.

Running the Tests

Three test jobs require the use of precision tools to be successful (although it is not necessarily true that each case within a test job requires precision tools). This section describes how to use the PT3 to pass these test jobs.

Digitizer Jitter

Single Stationary

Configuration:

  • One actuator

  • Rotational stage locked

To execute these test cases, position the actuator over the green area and lock both the X and Y axes. Once this is done, pull the lever to make contact with the screen, and hold contact for at least one second. Repeat for each target until the test is complete.

Multi Stationary

Configuration:

  • Five actuators

  • At least 20 mm between adjacent actuators

  • Rotational stage locked

To execute this test, position all actuators over the green area and lock both the X and Y axes. Then, pull the lever to make contact with the screen, and hold contact for at least 15 seconds. Repeat for each target until the test is complete. Note that bringing the actuators into contact too quickly can cause them to bounce on the screen, resulting in a failure. We recommend that the actuators be brought down slowly and be allowed to remain in contact for more than 15 seconds.

Single Moving

Configuration:

  • One actuator

  • Rotational stage locked

There are four different cases: horizontal, vertical, diagonal (left to right) and diagonal (right to left). Each case is run the same way.

First, align the motion to the line rendered on the screen by following the instructions in the Basic Usage section of this topic. Position the actuator over the green target, so that the contact area of the actuator is inside the green area. Use the concentric circles and crosshairs as a guide. Bring the actuator into contact with the screen at the center of the green target and drag to the center of the yellow target. There is no minimum or maximum speed.

Multiple Moving

Configuration:

  • Five actuators

  • At least 20 mm between adjacent actuators

  • Rotational stage locked

There are four different cases: horizontal, vertical, diagonal (left to right) and diagonal (right to left). Each case is run the same way.

First, align the motion to the lines rendered on the screen by following the instructions in the Basic Usage section of this document. Position the actuators over the green targets, so that the contact area of each actuator is inside the green area of its corresponding target. Use the concentric circles and crosshairs as a guide. Bring the actuators into contact with the screen at the centers of the green targets and drag to the centers of the yellow targets. There is no minimum or maximum speed.

NOTE

It is important that the R2-axis be locked to the 0° position, or it will be more difficult to align the actuators to the targets.

Radial

Configuration:

  • Two actuators

  • Each actuator is placed 3 cm from the center of the carriage

  • Rotational stage unlocked

This test has been divided into two areas: one to cover the left side of the screen, and one to cover the right side of the screen.

First, fix two actuators to the carriage at a distance of 5 cm from the center. Position each actuator above a green target and make sure that it is centered. Then, rotate in the direction that is indicated by the lines that are rendered on the screen until the end-points are reached.

NOTE

It is easiest to align the actuators and perform the motion if the base plate is rotated so that the short side of the device faces the tester (typically, with the base plate in the 90° or 270° position).

Radial Insert

Configuration:

  • Two actuators

  • One actuator 1.2 cm from the center, the other actuator 3.2 cm from the center

  • Rotational stage unlocked

This test has been divided into two areas: one to cover the left side of the screen, and one to cover the right side of the screen.

To perform this test, attach two actuators to the carriage, each to one side of the center. The interior semi-circle has a radius of 1.2 cm, while the exterior semi-circle has a radius of 3.2 cm. Similar to the Radial test, note the direction that the software indicates before you start the motion.

Move and Hold

Configuration:

  • One actuator

  • Rotational stage locked

To perform the test, simply trace a straight line from the green target to the yellow target, then hold steady on the yellow target for at least five seconds.

Input Separation

Vertical/Horizontal

Configuration:

  • Five actuators

  • Four actuators at a mutual distance of 13 mm

  • Fifth actuator 24 mm from its neighboring actuator

  • Rotational stage locked

Adjust the actuators so that the first four are mutually separated by a distance of 13 mm. Fix the final and rightmost actuator 24 mm from its neighboring actuator. From this point, follow the instructions in the Multi-Moving test.

Diagonal

Configuration:

  • Five actuators

  • Each actuator is 15 mm from either of its neighbors

  • Rotational stage locked

Follow the instructions in the Multi-Moving test.

Converge

Configuration:

  • Converge attachment fixed in carriage

  • Rotational stage locked

In this test, you are presented with four cases, all identical except for placement.

To execute this test, set the two actuators in the housing so that they are centered on the two starting points. A lock is provided to ensure that the contacts do not slide to a wider position. Next, lower the actuators until they make solid contact with the screen and immediately bring them together into their central position. Immediately lift the actuators. The attachment is designed to bring the actuators to a distance of 12 mm from center to center.

NOTE

You must complete the gesture within five seconds of when the first actuator touches the screen.

Input Separation

Vertical/Horizontal

Configuration:

  • Five actuators

  • Four actuators at a mutual distance of 13 mm

  • Fifth actuator 24 mm from its neighboring actuator

  • Rotational stage locked

Adjust the actuators so that the first four actuators are mutually separated by a distance of 13 mm. Fix the final and rightmost actuator 24 mm from its neighboring actuator. From this point, follow the instructions in the Multi-Moving test.

Diagonal

Configuration:

  • Five actuators

  • Each actuator is 15 mm from either of its neighbors

  • Rotational stage locked

Follow the instructions in the Multi-Moving test.

Converge

Configuration:

  • Converge attachment fixed in carriage

  • Rotational stage locked

In this test, you are presented with four cases, all identical except for placement.

To execute this test, set the two actuators in the housing so that they are centered on the two starting points. A lock is provided to ensure that the contacts do not slide to a wider position. Next, lower the actuators until they make solid contact with the screen and immediately bring them together into their central position. Immediately lift the actuators. The attachment is designed to bring the actuators to a distance of 12 mm from center to center.

NOTE

You must complete the gesture within five seconds of when the first actuator touches the screen.

Physical input position

Accuracy

Configuration:

  • One actuator

  • Rotational stage locked

This test can be completed only with the information contained in the section "Positioning an actuator and making contact", but the following discussion will be helpful.

The test has been partitioned to take advantage of the locking mechanism of the tool. It is intended that the Y-axis be locked during each edge test, so that the actuator housing can slide along X-axis to be positioned over each target.

The suggested method for performing a tap is to follow the instructions in "Positioning an actuator and making contact", except to use the lever only to float a short distance (about 1 cm) above the screen and tap on the top of the actuator to deliver the motion along the Z-axis. The actuators permit this motion, and the springs will return them to a position above the screen for a moderate-strength tap. Some practice is required to find the proper balance, but this method is faster than using the lever to deliver contact in this test.

Z-Axis Allowance

Configuration:

  • Five actuators

To complete this test, lower the actuators to the screen until there is 1 mm of space between the screen and the closest actuator. Allow the actuators to float at this distance for the duration of the test.

The suggested method for performing a tap is to follow the instructions in "Positioning an actuator and making contact", except to use the lever only to float a short distance (about 1 cm) above the screen and tap on the top of the actuator to deliver the motion along the Z-axis. The actuators permit this motion, and the springs will return them to a position above the screen for a moderate-strength tap. Some practice is required to find the proper balance, but this method is faster than using the lever to deliver contact in this test.

Additional Instructions for the ITRI PT3 Device

Equipment:

  • ITRI PT3 with X/Y/Z moving mechanism

  • X,Y,Z cable and USB-RS232C cable

  • CCD camera and USB Cable

  • Power cord

  • TouchWhere Installation CD and Software

  • 3-axis display

You will also need a computer to run and display the camera software.

precision touch testing large pt3 system

Figure 7: The large PT3 manufactured by ITRI

Installation

  1. Connect X,Y,Z cable from PT3 to the 3-axis display

  2. Connect the USB RS232C cable from 3-axis display to CCD camera cable

  3. Connect USB adapter to computer and install the USB driver

  4. Install the TouchWhere software

  5. Install CCD driver on computer

Calibration

  1. Run the TouchWhere software and touch_all.exe. Verify that in the bottom left corner of the screen, a green dot indicates that the computer is connected to the CCD camera. A red dot indicates that the camera is not communicating with the computer.

  2. On the Configuration tab, enter in the X and Y values from the 3-axis display and the COM port to which the camera is connected.

  3. On the Calibration tab, align the test finger on the PT3 to the green circle shown on the page and click Start point. Do the same for the yellow circle and click End point. Then click Run calibration. When you align the test finger for all tests, move the finger so that the X and Y offsets are as close to 0 as possible.

precision touch testing touchwhere software screen

Figure 8: TouchWhere software showing how to calibrate the camera with the DUT

IMPORTANT

Make sure that the device under test is level when you put it on the base plate of the PT3.


Overview of measuring Touch Down Hardware Latency

Latency is a measure of time delay experienced in the touch digitizer system. Inherent latency of a system is one of the most important parameters of the touch device and always represents a tradeoff between several important features: noise levels (SNR), sensitivity, power consumption, jitter, and so on.

The starting point for latency measurement is a well-defined standard; it is the moment at which the finger or stylus (actuator) touches the screen for the first time in a given contact. The end point for touch down hardware latency is the moment when the host operating system (for example, Windows 8) becomes aware of the message from the target touch digitizer (for USB devices this is the moment when the bulk interrupt request is detected on a dedicated USB controller for touch digitizers; usually this request indicates an incoming HID report with initial contact information.) For all practical purposes this end point is identical to that of the WndProc end point, which is the moment when the host application first becomes aware of contact (for example through WM_INPUT and WM_POINTER messages for native applications, or via a Windows::UI::Input::PointerPoint message for Microsoft Store applications).

Methodology

This procedure relies on the acoustic/mechanical wave produced by the finger touching the digitizer in order to measure this latency. It is worth noting that even the slightest touch contact will produce a substantial acoustic/mechanical wave on the digitizer's surface, which can clearly and unambiguously (that is, with extremely high SNR, virtually zero false positives, and almost no false negatives) be detected using even the simplest off-the-shelf microphones.

Methodology relies on the test subject manually touching the touch screen a number of times. This is because latency is probabilistic in nature - due to uncertainty inherent in the scanning function). This allows us to build an empirical cumulative distribution function. Predictable expectations for this function exist, enabling estimating the quality of the overall measurement. Using this data, you can extract basic parameters for the distribution.

Each measurement is executed fairly simply: a test subject touches the digitizer with a finger, creating the acoustic/mechanical wave. A small-but-measurable delay between the actual contact and the moment the wave reaches the microphone on the digitizer is recorded. The wave is then detected by the microphone, amplified and thresholded appropriately, hence it is being converted to logical 0 or 1 level). This logical value is fed into the microcontroller board (for example, an AT90USBKEY2), which accepts this change with low latency (~µs) and transmits it to the device under test with at most 1ms latency, via a USB HID report (1ms is the minimum polling period for full-speed USB devices such as the AT90USBKEY2).

On the host (that is, the device under test) side, two events are being anticipated. The first is the reception of an HID report from the microcontroller board, indicating that physical contact took place. The second is the HID report from the touch digitizer. The difference in time between the two reports represents the touch down latency.

There are two uncertainties in this measurement; a method was devised to reduce both. The first uncertainty is that there is a time delay between the actual contact and the time the wave reaches the microphone (or to be more specific, between the actual contact and the time logical 1 is received on the microcontroller). This is compensated for by adding an additional step to the methodology - a calibration. Before beginning latency measurements, the time it takes for the wave to propagate from the farthest position on the digitizer to the microphone (microcontroller) is measured. This information is used to provide an absolute error estimate for each individual measurement later. In most cases this is below 2ms (depending on the size of the screen and materials used for the digitizer's surface).

The second uncertainty is the latency introduced by the USB channel between the microcontroller and the host computer (the device under test). This is dealt with by introducing a 48-bit timestamp to each HID report from the microcontroller. This timestamp is set when logical 1 has been detected on the input port of the microcontroller (with ~µs latency between this event and the generation of the timestamp value). Then the clocks on the host (the computer being tested) and the target (microcontroller) side can be synchronized to yield the most precise results.

This methodology can be fully automated and is fully repeatable; a robot could be used to induce touch instead of a human participant. Instead, the simpler solution, relying on a human participant and natural measurement, with simpler and more convenient setup is recommended. Observed results indicate consistent precision, which indicates that a balance has been achieved between the complexity of the setup and the precision of the measurement.

Hardware Requirements

This section details the required hardware components. The purpose for of piece of equipment is described but actual part numbers are not provided here (these will be provided later in this paper.

  • A microphone - to detect acoustical waves on the touch digitizer. A small and flat piezoelectric microphone that can easily be taped to the touch screen is recommended.

  • An acoustic amplifier - to amplify the signal from the microphone.

  • A thresholding circuit - to distinguish touch sound from environmental noise.

  • A microcontroller board with USB HID capability and polling ability on at least two input ports with ~µs latency.

  • Calibration circuit - to measure acoustic wave propagation, that is, the time between the touch occurring and logical 1 being received on the microcontroller.

The next section discusses an implementation of touch down latency measurement setup.

Detailed Instructions

The hardware device to perform measurements is presented in the following image. The box has three holes: microphone input, calibration metal plate input, and microcontroller micro USB output.

circuit board for touch down hardware latency

The next image shows the circuit for the microphone, acoustic amplifier and thresholder. The microcontroller comparator can be used to apply threshold.

circuit diagram for touch down hardware latency

The microphone connection is shown in the following image. Note that a very simple off-the-shelf microphone is being used in this setup, sufficient to reliably and accurately discriminate between taps and environmental noise.

circuit board with microphone attachment

Calibration plate input goes in the other hole, as shown in the following image.

calibration plate connected to circuit board

The microcontroller board used is AT90USBKEY2.

As described in methodology, this microcontroller board is used to detect changes on the output of the thresholding circuit, namely logical 0 and 1 (the same for calibration and metal plate). When an audio signal is detected with a magnitude exceeding the threshold, that change is detected and a HID report is sent to the host for each such event. As the sound wave oscillates, the threshold will be exceeded multiple times; in order to avoid sending a change event each time the threshold exceeded, the controller logic must ignore the audio signal for some period of time after each change event. That time interval should be long enough so that final result is only one change event per finger tapping. Durations longer than 500ms usually work. Alternatively a mono-stable multivibrator can be used or an additional logical circuit can be used, placed after the audio amplifier and MCU input. In order to reuse the recommended setup (firmware + software) you must feed the output of the audio thresholding circuit into the input pin C0 and the output of the metal plate circuit to the input C1. The microcontroller board and the thresholding circuit should have a shared ground (the grounds should be connected). The placement of pins C0 and C1 as well as the ground is shown in the following two images.

port c of circuit board

The red rectangle delineated area (port C of the AT90USBKEY board) of the preceding image is shown zoomed-in in the following image, with pins C0, C1 and ground marked appropriately.

pins c0, c1, and ground highlighted

For more information about this board please visit manufacturer's web site and hardware user guide for the board.


Fingerprint Reader Testing Prerequisites

This section describes the tasks that you must complete before you test a fingerprint reader by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing a fingerprint reader. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

  • One test computer. The test computer must meet the Windows HLK prerequisites. For more information, see Windows HLK Prerequisites.

  • The fingerprint reader to be tested.

  • One certified USB 2.0 hub if the fingerprint reader is a USB-based device.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required for testing a fingerprint reader:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. If the test device is connected through the USB port, connect the USB 2.0 controller to the high-speed USB 2.0 hub, and then connect the test device to the downstream port of the high-speed USB 2.0 hub.

    NOTE

    Do not connect the USB test device directly to the root hub of the USB 2.0 controller.

  3. Attach the fingerprint reader to the test computer.

  4. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  5. Check that the fingerprint reader functions correctly on the test computer.

  6. Install the Windows HLK client application on the test computer.

  7. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

  8. Create test directory [SYSTEMDRIVE]\FingerprintReaderTest.

  9. Copy the adapter DLLs from [SYSTEMDRIVE]\Windows\System32\WinBioPlugins for the sensor, storage, and engine adapters.

  10. Create configuration files for the sensor, storage, and engine adapters using the following templates.

  11. Edit the sensorAdapterLib, engineAdapterLib, and storageAdapterLib configuration tags to point to correct adapter DLLs as copied previously.

  12. Edit the supportedModes and supportedPurposes configuration tags to match the device capabilities.

  13. The runOptional attribute is false by default. Change it to true to run extra tests.

  14. For storage tests, change the deviceRequired attribute to true if the device has onboard storage.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Before running any fingerprint reader driver or adapter tests, stop and disable the Windows Biometric Service. If the biometric service is running while the fingerprint reader HLK tests execute, there may be a conflict between the two, and test results will not be accurate.

Writing test configuration files

Before running any fingerprint reader adapter tests, you need to create XML configuration files for the sensor, storage, and engine adapters. The names of these files must be SensorTestConfig.XML, EngineTestConfig.XML, and StorageTestConfig.XML. Use the templates below as a starting point and modify them for your specific device.

Sensor Adapter configuration file

<?xml version="1.0" encoding="utf-8"?>
<bioTestConfiguration version="0" runOptional="false" runInteractive="true" abortOnFailure="false" manualStep="false" logType="WTT">
  <testSuites>
    <testSuite deviceRequired="true" id="SensorAdapterTestSuite">
      <library>sensortest.dll</library>
      <description>Sensor Adapter Test Suite</description>
    </testSuite>
  </testSuites>
  <deviceInfo>
    <sensorAdapterLib>winbiosensoradapter.dll</sensorAdapterLib>
    <engineAdapterLib>engineadapter.dll</engineAdapterLib>
    <storageAdapterLib>winbiostorageadapter.dll</storageAdapterLib>
    <indicatorSupported>0</indicatorSupported>
    <supportedModes>
      <supportedMode>0x01</supportedMode>
      <supportedMode>0x02</supportedMode>
    </supportedModes>
    <supportedPurposes>
      <supportedPurpose>0x01</supportedPurpose>
      <supportedPurpose>0x02</supportedPurpose>
      <supportedPurpose>0x04</supportedPurpose>
      <supportedPurpose>0x08</supportedPurpose>
      <supportedPurpose>0x10</supportedPurpose>
      <supportedPurpose>0x80</supportedPurpose>
    </supportedPurposes>
  </deviceInfo>
</bioTestConfiguration>

Engine Adapter configuration file

<?xml version="1.0" encoding="utf-8"?>
<bioTestConfiguration version="0" runOptional="false" runInteractive="true" abortOnFailure="false" manualStep="false" logType="WTT">
  <testSuites>
    <testSuite deviceRequired="true" id="EngineAdapterTestSuite">
      <library>enginetest.dll</library>
      <description>Engine Adapter Test Suite</description>
    </testSuite>
  </testSuites>
  <deviceInfo>
    <sensorAdapterLib>winbiosensoradapter.dll</sensorAdapterLib>
    <engineAdapterLib>engineadapter.dll</engineAdapterLib>
    <storageAdapterLib>winbiostorageadapter.dll</storageAdapterLib>
    <indicatorSupported>0</indicatorSupported>
    <engineOnDevice>FALSE</engineOnDevice>
    <supportedModes>
      <supportedMode>0x01</supportedMode>
      <supportedMode>0x02</supportedMode>
    </supportedModes>
    <supportedPurposes>
      <supportedPurpose>0x01</supportedPurpose>
      <supportedPurpose>0x02</supportedPurpose>
      <supportedPurpose>0x04</supportedPurpose>
      <supportedPurpose>0x08</supportedPurpose>
      <supportedPurpose>0x10</supportedPurpose>
      <supportedPurpose>0x80</supportedPurpose>
    </supportedPurposes>
  </deviceInfo>
</bioTestConfiguration>

Storage Adapter configuration file

<?xml version="1.0" encoding="utf-8"?>
<bioTestConfiguration version="0" runOptional="false" runInteractive="true" abortOnFailure="false" manualStep="false" logType="WTT">
  <testSuites>
    <testSuite deviceRequired="false" id="StorageAdapter">
      <library>storagetest.dll</library>
      <description>Storage Adapter Test Suite</description>
    </testSuite>
  </testSuites>
  <deviceInfo>
    <sensorAdapterLib>winbiosensoradapter.dll</sensorAdapterLib>
    <engineAdapterLib>engineadapter.dll</engineAdapterLib>
    <storageAdapterLib>winbiostorageadapter.dll</storageAdapterLib>
    <indicatorSupported>0</indicatorSupported>
    <storageOnDevice>FALSE</storageOnDevice>
    <supportedModes>
      <supportedMode>0x01</supportedMode>
      <supportedMode>0x02</supportedMode>
    </supportedModes>
    <supportedPurposes>
      <supportedPurpose>0x01</supportedPurpose>
      <supportedPurpose>0x02</supportedPurpose>
      <supportedPurpose>0x04</supportedPurpose>
      <supportedPurpose>0x08</supportedPurpose>
      <supportedPurpose>0x10</supportedPurpose>
      <supportedPurpose>0x80</supportedPurpose>
    </supportedPurposes>
  </deviceInfo>
</bioTestConfiguration>

Additional configuration tags

In the configuration file, under the "device information" section, there are three additional tags:

<deviceInfo>

    <badSwipeDetectionPoint> VALUE </badSwipeDetectionPoint>
    <privateConnectionSensorToEngine>BOOLEAN</privateConnectionSensorToEngine>
    <privateConnectionEngineToStorage>BOOLEAN</privateConnectionEngineToStorage>

</deviceInfo>

badSwipeDetectionPoint

  • SensorFinishCapture

  • EngineAcceptData

  • EngineProcessData

NOTE

A maximum of one badSwipeDetectionPoint tag can appear in a single test configuration file.

privateConnectionSensorToEngine

  • If TRUE, this indicates that there is an internal connection between the sensor and the engine components that is not managed by the WinBio Framework.

  • If FALSE, the connection between the sensor and engine uses the standard WinBio adapter interfaces.

privateConnectionEngineToStorage

  • If TRUE, this indicates that there is internal connection between the engine and storage components that is not managed by the WinBio Framework.

  • If FALSE, the connection between the engine and storage uses the standard WinBio adapter interfaces.

NOTE

For a compound device, it's possible to set both the privateConnectionSensorToEngine and privateConnectionEngineToStorage.

engineOnDevice

  • If TRUE, this indicates that the fingerprint sensor supports the engine functionality in hardware. This typically implies that the sensor is an advanced sensor.

  • If FALSE, this indicates that the fingerprint sensor supports the engine functionality in software. This typically implies that the sensor is a basic sensor.

storageOnDevice

  • If TRUE, this indicates that the fingerprint sensor supports template storage in hardware. This typically implies that the sensor is an advanced sensor.

  • If FALSE, this indicates that the fingerprint sensor does not support template storage in hardware. Templates are stored on disk. This typically implies that the sensor is a basic sensor.


Game Controller Testing Prerequisites

This section describes the tasks that you must complete before you test a game controller by using the Windows Hardware Lab Kit (Windows HLK).

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing a game controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

  • One test computer. The test computer must meet the Windows HLK prerequisites. For more information, see Windows HLK Prerequisites.

  • The game controller to be tested.

  • One USB 2.0 hub that has a Windows logo if the game controller is a USB-based device.

Software requirements

The following software is required for testing a game controller:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer and then configure the computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Attach a USB 2.0 hub to your test computer.

  3. If the game controller uses USB as the primary connection, connect the game controller USB 2.0 hub. If the game controller includes a headset, the headset must be attached to the test game controller.

    NOTE

    Do not connect the USB test device directly to the root hub of the USB 2.0 controller.

  4. Open Joy.cpl and ensure that the game controller shows up in Joy.cpl.

  5. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  6. Verify that the game controller functions correctly on the test computer.

  7. Install the Windows HLK client application on the test computer.

  8. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Keyboard Testing Prerequisites

This section describes the tasks that you must complete before you test a keyboard by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing a keyboard. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

  • One test computer. The test computer must meet the Windows HLK prerequisites. For more information, see Windows HLK Prerequisites.

  • One test keyboard (the keyboard must be compliant with Microsoft®-specified scan codes [PS2 or HID]).

  • If the keyboard is connected through a USB device, one external USB 2.0 high-speed hub that has a logo (unless the keyboard contains an embedded hub).

Software requirements

The following software is required for testing a keyboard:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Attach a USB 2.0 hub to the test computer.

  3. If the keyboard supports USB, attach the keyboard to the test computer. Verify that the keyboard is plugged into the external USB 2.0 high-speed hub that is connected to the test computer. To test a keyboard that supports Bluetooth or wireless connections, connect the associated base station to the USB 2.0 hub.

    NOTE

    Do not connect the keyboard or wireless base station directly to the root hub of a USB 2.0 controller.

  4. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  5. Make sure that the keyboard functions correctly on the test computer.

  6. Install the Windows HLK client application on the test computer.

  7. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Mouse or other Pointing Device Testing Prerequisites

This section describes the tasks that you must complete before you test a mouse or similar pointing device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing a mouse or pointing device. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test displayed for the device in Windows HLK Studio.

  • One test computer. The test computer must meet the Windows HLK prerequisites. For more information, see Windows HLK Prerequisites.

  • One test mouse or similar pointing device.

  • One USB 2.0 hub that has a logo.

Software requirements

The following software is required for testing a mouse or similar pointing device:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Attach a USB 2.0 hub to the test computer.

  3. If the mouse or pointing device supports USB, attach the device to the test computer. Verify that the device is plugged into the external USB 2.0 high-speed hub that is connected to the test computer. To test a mouse that supports Bluetooth or wireless connections, connect the associated base station to the USB 2.0 hub

    NOTE

    Do not connect the keyboard or wireless base station directly to the root hub of a USB 2.0 controller.

  4. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  5. Make sure that the mouse or pointing device functions correctly on the test computer.

  6. Install the Windows HLK client application on the test computer.

  7. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Sensor Device Testing Prerequisites

This section describes the tasks that you must complete before you test a sensor device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Sensor devices as defined here are devices that work with the Windows Sensor and Location platform. Currently this platform is only available on Windows 8 and Windows 7.

Hardware requirements

The following hardware is required for testing a sensor device. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test displayed for the device in Windows HLK Studio.

  • One test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • The sensor device to be tested.

  • USB hubs are required for sensors that are connected via USB. (Sensors that are connected via I2C or other bus do not need a hub).

Software requirements

The following software is required for testing a sensor device:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for your test sensor device, follow these steps:

NOTE

If you are testing a GPS device, be sure to enable the Allow Apps To Use my location privacy setting before running any tests. Otherwise, the GPS tests will fail.

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

    NOTE

    To test your sensor device, the test computer must be running Windows 8 or Windows 7.

  2. If the sensor uses USB as the connection type, connect the USB 2.0 controller to the high-speed USB 2.0 hub, and then connect the sensor to the downstream port of the high-speed USB 2.0 hub.

    NOTE

    Do not connect the USB test device directly to the root hub of the USB 2.0 controller.

  3. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  4. Verify that the sensor device functions correctly on the test computer.

  5. Install the Windows HLK client application on the test computer.

  6. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Smart Card Reader Testing Prerequisites

This section describes the tasks that you must complete before you test a smart card reader by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements

  • Software requirements

  • Test computer configuration

Hardware requirements

The following hardware is required for testing a smart card reader. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

  • One test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • The smart card reader that you want to test.

    NOTE

    If the device supports universal serial bus (USB), you must have two test devices to run the USB Serial Number test. For more information, see USB Serial Number.

  • One Personal Computer / Smart Card (PC/SC) workgroup test card (from card set 2).

    This card set can be purchased from the PC/SC website. Test the product by using the smart cards that the PC/SC workgroup test card set includes. Do not include these smart cards with your test submission.

  • One of the following, depending on the type of connection that the smart card reader implements:

    • A USB 2.0 hub (if the card reader connects through a USB connection).

    • An IEEE 1394 controller (if the card reader connects through a 1394 connection).

      NOTE

      Support for IEEE 1394 has been deprecated.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required for testing a smart card reader:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

Test computer configuration

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. If the reader is an internal device, install the smart card reader in the computer. If the reader is an external device, attach a controller to the test computer, and then attach the reader to the external controller.

    If the test device is connected through the USB port, connect the USB 2.0 controller to the high-speed USB 2.0 hub, and then connect the test device to the downstream port of the high-speed USB 2.0 hub.

    NOTE

    Do not connect the USB test device directly to the root hub of the USB 2.0 controller.

  3. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  4. Verify that the smart card reader functions correctly on the test computer.

  5. Install the Windows HLK client application on the test computer.

  6. Use Windows HLK Studio to create a machine pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Troubleshooting Device.Input Testing

To troubleshoot issues that occur with Device.input tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review one of the following topics, depending on the type of input device that you are testing:

    • Fingerprint Reader Testing Prerequisites

    • Game Controller Testing Prerequisites

    • Keyboard Testing Prerequisites

    • Mouse or other Pointing Device Testing Prerequisites

    • Sensor Device Testing Prerequisites

    • Smart Card Reader Testing Prerequisites

  3. Review the Windows HLK release notes for current test issues.

  4. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Specific information about keyboard tests

The Device.Input test category does not include specific keyboard tests. However, there are tests in the Device.Fundamentals category that apply to keyboards. For more information, see Device.DevFund Tests.

Specific information about mouse or other pointing device tests

The Device.Input test category does not include specific mouse tests. However, the Device.Fundamentals category includes tests that apply to mice.

Specific information about sensor device tests

Currently, known sensor test issues are grouped into the following categories:

  • Test initialization failures

  • Operating system issues

  • Permissions issues

Test initialization failures

When the sensor tests start on a test computer, they perform several tests to verify that the environment can be used for testing. If you receive errors that have a TUID of A012D6BB-36BB-4088-AF3F-1BE3C5607928, verify the following:

  • The test computer must be running Windows 8 or Windows 7.

  • The test computer must currently have your test sensor device installed and the device must be operational.

  • The test sensor device must appear as a sensor device in the Location and Other Sensors Control Panel.

Operating system issues

The sensor tests are only valid on Windows 8 and Windows 7. The tests are not supported on any other version of Windows.

Permissions issues

The user who is logged into the client computer must have permissions to access the sensor device for some of the sensor logo tests. To check permissions, follow these steps:

  1. Open the Location and Other Sensors Control Panel.

  2. Grant all users access to the sensor device that is being tested. To do this, follow these steps:

    1. In the Location and Other Sensors Control Panel, select the check box next to the sensor device that is being tested.

    2. Click Apply.

NOTE

You must have administrator permissions on the test system to change the permissions for the sensor test device.

Related topics

Device.Input Tests

Troubleshooting Windows HLK


Device Orientation Quaternion Vector Algorithm

This article describes the algorithm that is used by the Windows Hardware Lab Kit (Windows HLK) to determine the delta between the received and expected vector for 9-Axis data accuracy in the advanced orientation sensor tests. The tests validate that sensor fusion is properly integrated and that all sensors that are required for sensor fusion are properly integrated and installed.

NOTE

In some cases, you can use the Sensor Diagnostic Tool to examine the 3D inclinometer and aggregated device orientation sensor that is under test.

Quaternion vector algorithm

The algorithm uses the arc cos of the 4 dimensional dot product of the two vectors, divided by the product of the magnitude of the two vectors and divided by 2. This algorithm is shown in Figure 1 Quaternion Vector Algorithm Formula:

quaternion vector algorithm formula

Rotation matrix values are converted to quaternion values for accuracy validation. The calculated quaternion vector should deviate no more than +/- 5 degrees from expected quaternion vector (tolerance compared against angle formed between quaternion vectors) (**+/- 10 degrees accuracy allowed on heading axis direction). The Windows HLK test allows for the Øₜ delta to be up to 15 degrees.

How to compute the delta angle between the received and expected Quaternion vectors

This section describes the calculation that computes the delta angle between the received and expected Quaternion vectors in Advanced Orientation Tests in the Windows HLK.

The following two data values are of interest in the data report of Aggregated Device Orientation Sensor:

  • Quaternion vector

  • Rotation matrix

The test consists of the following two verifications:

  1. Verification of received Quaternion vector in the sensor data report. A Quaternion vector is of the form (xi + yj + zk + w).

    1. The value of w is always expected to be positive.

    2. The Quaternion vector is expected to be normalized and non-zero. For example, the magnitude of the vector must be close to 1.0. One percent (1%) leeway is provided to round off errors in the calculation of the magnitude.

    3. The delta angle is calculated by using delta = 2 * Acos( ( Exp . Rec ) / ( | Exp | * | Rec | ) ), where:

      \* indicates scalar multiplication

      . indicates dot product

      Exp is the expected Quternion vector

      Rec is the received Quaternion vector

      | Q |indicates the magnitude of the quternion vector

      delta is the angle in degrees

    4. If delta is greater than 360 degrees, delta is re-calculated as delta = delta - 360.

    5. At this point, delta should be less than or equal to the error tolerance; for example, 10 degrees.

  2. Verification of the received rotation matrix. The rotation matrix is expected to be a 3x3 matrix.

    1. Each column and row vector of the rotation matrix must be normalized and non-zero. A one percent (1) leeway of is provided to round off errors in the calculation of the magnitude.

    2. The received rotation matrix is transformed into a Quaternion vector.

    3. All the steps from <a> to <e> of Verification (1) are re-used.

Related topics

Testing sensor functionality with the Sensor Diagnostic Tool

Integrating Motion and Orientation Sensors


Global Navigation Satellite System (GNSS) Test Guidance

This article provides global positioning system (GPS) implementation guidelines to ensure a high-quality, competitive GPS experience in computers that run Windows 8 and Windows 8.1. The guidelines in this article apply to original equipment manufacturers (OEMs), independent hardware vendors (IHVs), and other Microsoft partners (such as software vendors). This article focuses on testing the integration of global navigation satellite system (GNSS) devices into a Windows 8 system.

Testing of areas other than GPS is out of the scope of this document. Fully exercising the operating system components or the GNSS device is out of the scope of this document. It is assumed that the IHVs and OEMs thoroughly test their GNSS device both independently and integrated into the system. Interoperability testing is limited to the components that interact with the location platform and devices. This testing should include successful completion of the Windows Hardware Lab Kit (Windows HLK) tests, this test plan, pre-operator trial tests, and internal tests that are developed specifically for the GNSS driver and GNSS receiver.

NOTE

In this article, the term GPS is used interchangeably with GNSS. Unless it is otherwise stated, GPS refers to satellite positioning as a location provider solution, instead of as the GPS satellite system that is deployed by the United States government.

Clear sky conditions are defined as GPS/GNSS satellites that receive signals without obstruction from above or from the surrounding environment down to an elevation mask of 5 degrees above the horizon. All signal levels must be consistent with unobstructed signal levels at the ground and not lower than -131 dBm.

This information applies to the following operating systems:

  • Windows 8

  • Windows 8.1

In this article:

  • Requirements from Partners

  • Reporting and results communication

  • Test equipment

  • Functionality tests

  • Assisted GPS tests

  • Power consumption tests

  • Power management tests

  • Antenna performance tests

  • Interoperability tests

  • Drive tests

  • Simulator tests

  • GPS acceptance test matrix

Requirements from Partners

To receive certification, Microsoft partners must meet the following requirements:

  • To enable Assisted GPS (A-GPS) testing and the ability to cold-start a device, GNSS Drivers must support the SENSOR_PROPERTY_CLEAR_ASSISTANCE_DATA property. To enable turning on and turning off National Marine Electronics Association (NMEA) sentences in data reports, the GNSS Driver must support SENSOR_PROPERTY_TURN_ON_OFF_NMEA. By default, NMEA lines are not included in data reports. This requirement is explicitly described here:

    //{e1e962f4-6e65-45f7-9c36-d487b7b1bd34}DEFINE_GUID(SENSOR_PROPERTY_TEST_GUID, 0XE1E962F4, 0X6E65, 0X45F7, 0X9C, 0X36, 0XD4, 0X87, 0XB7, 0XB1, 0XBD, 0X34);DEFINE_PROPERTYKEY(SENSOR_PROPERTY_CLEAR_ASSISTANCE_DATA, 0XE1E962F4, 0X6E65, 0X45F7, 0X9C, 0X36, 0XD4, 0X87, 0XB7, 0XB1, 0XBD, 0X34, 2); //[VT_UI4]

    DEFINE_PROPERTYKEY(SENSOR_PROPERTY_TURN_ON_OFF_NMEA, 0XE1E962F4, 0X6E65, 0X45F7, 0X9C, 0X36, 0XD4, 0X87, 0XB7, 0XB1, 0XBD, 0X34, 3); //[VT_UI4]

    #define GNSS_CLEAR_ALL_ASSISTANCE_DATA 0x00000001

    SENSOR_PROPERTY_ CLEAR_ASSISTANCE_DATA (PID = 2)

    VT_UI4. Write. Clear the assistance data. Setting a value of GNSS_CLEAR_ALL_ASSISTANCE_DATA signals the driver to clear all assistance data, including time, almanac, ephemeris and last position.Windows HLK tests can set this value to clear the assistance data before a cold start test, before A-GPS tests, or independently before running simulator tests where time and location is simulated. If A-GPS capabilities (for example, SUPL, LTO) are supported, the driver can try to utilize the capabilities after this operation by using the network connection. However, the device should be in a state where no assistance data is saved in the device or on the system. Any assistance data elements are downloaded again.

    SENSOR_PROPERTY_TURN_ON_OFF_NMEA (PID = 3)

    VT_UI4. Read/Write. If set to TRUE, NMEA sentence is included in data reports. If set to False, NMEA sentence is not included in data reports. Windows HLK tests can use this property to instruct the device to start or stop including NMEA data in data reports.

  • In addition to required Windows Hardware Lab Kit (Windows HLK) tests, optional Windows HLK Device.Input Tests must run and pass for non-ARM System on Chip (SoC) systems. (These tests are already mandatory for ARM systems).

  • OEMs and IHVs must run and document the tests that are specified in the GPS acceptance test matrix before they can submit a system, device, or driver to Microsoft.

  • IHVs should review reported failures from their Hardware Dashboard under the Analyze section for issues caused by their GPS drivers, and fix all high-impact failures.

  • Antenna requirements from OEMs must include the items that are listed in Antenna performance tests.

  • The SENSOR_DATA_TYPE_NMEA_SENTENCE property must be supported on systems to verify dynamic navigation accuracy and antenna quality.

  • No dependency on third-party services or Win32 applications can accompany the GPS solution. Third-party Win32 applications are subject to signing requirements on SoC systems and are therefore not allowed.

  • USB connected GPS devices must support selective suspend.

  • GPS on mobile broadband modules must update by using Unified Extensible Firmware Interface (UEFI), and a standalone GPS must update by using a driver.

  • When GPS and mobile broadband exist on the same physical chip, the GPS device should be exposed as part of a USB composite device and it should have its own USB interface.

Reporting and results communication

Microsoft will communicate all issues to partners using bugs. The bugs will contain Windows HLK logs, traces, driver logs, crash dumps, and any relevant performance results and baseline performance comparison data.

Test equipment

The following test equipment is used to perform the tests that are described in this article:

  • Spirent GSS6700 GNSS Simulator

  • Faraday cage

  • RF shielding box

  • Mobile Broadband SIM

  • Reference Devices: Garmin Montana; Windows Tablets that have GPs devices that are certified by using Microsoft Signature.

  • External antennas

Functionality tests

Windows HLK tests that apply to GNSS devices are the first set of tests to verify the basic functionality of GPS devices. Windows HLK contains tests for GPS Sensors, Radio Manager, Device Fundamentals, System Fundamentals Power Management, and USB Hardware Certification tests (for USB connected devices) that apply to GNSS devices.

Sensor category, type, properties and data fields

Description: The device should report correct sensor category and type, support mandatory properties and data fields, and report accurate data. In addition to the mandatory sensor properties that are verified in the Windows HLK, managed program systems must support the SENSOR_DATA_TYPE_NMEA_SENTENCE property.

Run Steps: Query sensor category, type, properties, and data fields the Device Under Test (DUT) reports. Confirm the accuracy of the reported data. You can use the Sensor Diagnostics Tool (SDT) in the Windows Driver Kit (WDK) to test these items.

Expected Result: Mandatory fields must be supported and report accurate data.

State transitions

Description: The device should report changes in sensor state, as documented in Writing a location sensor driver.

  • Data reports must be reported only after a device reaches SENSOR_STATE_READY or SENSOR_STATE_INITIALIZING.

  • A device should not report data if it does not have latitude and longitude information.

  • A GPS sensor must start in the SENSOR_STATE_INITIALIZING state before it obtains a location fix.

  • A GPS sensor should continue to acquire a location fix and must stay in the SENSOR_STATE_INITIALIZING state until the request is cancelled by the operating system.

  • A GPS sensor must go into the SENSOR_STATE_INITIALIZING state when it loses the signal and no longer has data. It should go back to into the SENSOR_STATE_READY state when it reacquires a location fix.

Run Steps: You must monitor state transitions and data events while you disable and re-enable the device. Move into an area that has no GPS signal (for example, a Faraday cage), wait for at least one minute, and return the device to an area that has coverage.

Expected Result: The device should report sensor state transitions (for example, from SENSOR_STATE_INITIALIZING to SENSOR_STATE_READY), and data reports should be reported only after reaching these states. Data is only reported if latitude and longitude information is available. The device should start in the SENSOR_STATE_INITIALIZING state and should not move into the SENSOR_STATE_READY state until after it gets a location fix and has a valid error radius. When the device is moved out of a GPS signal coverage area, the device should go into the SENSOR_STATE_INITIALIZING state, and it should revert to SENSOR_STATE_READY when it is returned to a coverage area.

Latitude and longitude accuracy

Description: The device should provide accurate latitude and longitude values in the specified error radius.

Run Steps: During static testing and in-vehicle testing, device data is compared to latitude and longitude data that reference GPS, survey markers, and a simulator report.

Expected Result: The difference between the latitude and longitude values that the device reports and the reference GPS reports must be inside the error radius.

Speed data

Description: The device should report speed data in knots when the device is moving.

Run Steps: Monitor the speed data that the device reports during simulated in-vehicle or drive tests.

Expected Result: The device should report speed data that is accurate within ±15% of the speed data that a reference GPS or simulator reports.

Heading data

Description: The device should report headings in degrees that are relative to true north when the device is moving.

Run Steps: Monitor the heading data that is reported by the device during simulated in-vehicle tests, manual walking tests, and drive tests.

Expected Result: The device should report heading data, which should be within ±15% of the heading data that a reference GPS or simulator reports.

Other sensor properties

Description: If other sensor properties are supported by the device, the properties should report valid data and accurate values.

Run Steps: Monitor properties that the device supports and verify that they provide valid data within acceptable accuracy ranges.

Expected Result: If a device supports a particular sensor property, the device should report accurate values within ±20% of the values that a reference GPS or simulator reports.

Assisted GPS tests

Within a few seconds of initial power-up, a GPS device should use A-GPS to return an approximated location. When the GPS uses A-GPS, the sensor should provide location data, which can be from several hundred meters to six figure numbers. When the GPS radio can obtain multiple satellite locks, the error radius should decrease to a value of 3 to 30 meters.

A-GPS

Description: A-GPS should help to obtain a faster Time to First Fix (TTFF) that has higher accuracy.

Run Steps: Cold-start the GPS device. Monitor latitude, longitude and error radius data fields by using the SDT.

You should run the tests under the following conditions:

  • Clear-sky conditions (simulated or actual)

  • Subscribed for data events

  • Report interval of one second

  • Wi-Fi or cellular baseband is present and enabled

Expected Result: The device should return a position from A-GPS as soon as possible, and should report an associated error radius. The higher error radius (for example, 300 meters if Wi-Fi is available) should decrease to 3 to 30 meters as the device acquires multiple satellite locks. GPS should report a position within 15 seconds that is based on assistance data.

Position injection

A GPS driver can use data from its triangulation sensors to speed up TTFF by using the Sensor API (ISensorManager). If a driver is used, the following tests apply:

  • Connection time

    Description: A GPS driver should close the connection to other sensors immediately after it gets a position. It should timeout after 15 seconds and it should close the connection to the Sensor API if it does not get a position.

    Run Steps: Monitor the traces from the Sensor API for the active client counts for all sensors in the system. Cold-start the GPS device and monitor the changes on the active client counts for other sensors in the system.

    Expected Result: If active client counts for other sensors are incremented, they should return to their previously recorded values after 15 seconds.

  • Connection type

    Description: GPS drivers should not instantiate ILocation to get data from other location sensors. They can use the Sensor API to open a connection for instance triangulation sensors (SENSOR_TYPE_LOCATION_TRIANGULATION). A GPS driver should not get data from location sensors of the same type. For example, a GPS sensor should not use data from other sensors with type GPS to get a faster location fix.

    Run Steps: Discover the sensor type that the device is reporting; for example, SENSOR_TYPE_LOCATION_GPS. Disable all sensors except for sensors of the same type as the device. Monitor the traces from the Sensor API for the active client counts for enabled sensors in the system. Cold-start the GPS device. Monitor the changes on the active client counts for sensors in the system.

    Expected Result: The device should not increment active client counts for sensors of the same type.

Robustness

Driver Verifier, WDF Verifier, and Application Verifier are enabled for the location platform and the GPS device stack to test the reliability of GPS support in the system.

Driver Verifier is part of the Windows operating system. It can be started from a command prompt that has administrative privileges by using the following settings:

Verifier /standard /driver wudfpf.sys Wdf01000.sys Wdfldr.sys wudfrd.sys <any kernel mode driver >, <dependent kernel mode drivers >

Where <any kernel mode driver> is the driver to be verified, and <dependent kernel mode drivers> are the kernel mode drivers on which the GPS driver depends; for example, wmbclass.sys.

For more information about Driver Verifier, see About Driver Verifier.

WDF Verifier is enabled by default for all WDF drivers. The WdfVerifier.exe tool in the WDK can be used to control the verbosity of logging, debugger settings, and more. For more information about WDF Verifier, see WDF Verifier Control Application.

Application Verifier (appverif.exe) is available in Windows HLK and the Windows 8.1 SDK. A minimum of basic settings is required.

Driver Verifier, WDF Verifier and Application Verifier

Description: Enable Application Verifier and Driver Verifier at the beginning of testing.

Run Steps: Enable Driver Verifier on all kernel mode drivers in the driver package (if any) and enable any kernel mode drivers on which the GPS driver depends. Enable Application Verifier for %windir%\system32\WUDFHost.exe and other user-mode binaries on which the GPS driver depends (for example, wwanapi.dll).

Expected Result: No verifier failures.

Telemetry data

Description: Monitor telemetry data from your Hardware Dashboard under the Analyze section for the GPS driver.

Run Steps: Monitor telemetry data from your Hardware Dashboard under the Analyze section for the GPS driver. Identify, investigate, and fix the driver failures.

Expected Result: The device must report all telemetry failures; you should triage, investigate, and fix the primary problems.

GPS stress tests

A combination of the following operations is simultaneously performed on the GPS device during simulator testing, walk testing, and drive testing:

  • Enable Driver Verifier

  • Enable Application Verifier

  • Repeated Windows HLK test runs (GPS Sensor, Radio Manager, System Power Management)

  • Radio management operations

  • Connected Standby

  • GPS device disable/re-enable

  • Windows Location Provider disable/re-enable

  • Mobile Broadband device disable/re-enable

  • Wi-Fi device disable/re-enable

  • Turn off Mobile Broadband radio

  • Turn off Wi-Fi Radio

  • Large download over Mobile Broadband connection

  • Large download over Wi-Fi connection

  • Bluetooth activity

Perform a basic verification test before the stress testing. It is expected that the same verification test passes both before and after the stress tests, and that no failures are observed.

Performance

GPS device performance is tested for cold-start TTFF, hot-start TTFF, acquisition sensitivity, tracking sensitivity, re-acquisition time, static navigation accuracy, and dynamic navigation accuracy.

A GNNS simulator that has an OTA connection can be used for performance testing.

Cold-start TTFF

Description: Cold-start TTFF should be achieved in less than 45 seconds for 90% of the time. Cold-start is described as the following condition:

  • Time is unknown

  • Current ephemeris is unknown

  • Position is unknown

Run Steps: You can use the SDT to clear the GPS assistance data before you start the cold-start test. Ensure that the cold-start conditions described above are met. Monitor the TTFF under clear sky conditions (actual or simulated).

Expected Result: The device should use the GNSS device to get a location fix within 45 seconds for 90% of the time.

Acquisition sensitivity

Description: The device should obtain a location fix at -150 dBm or lower power levels.

Run Steps: Under simulated lab conditions, by using a direct radio frequency (RF) connection when antenna connector is accessible, expose device to low power levels up to -150 dBm.

Expected Result: The device should acquire a fix at -150 dBm.

Tracking sensitivity

Description: The device should maintain a location fix at -155 dBm or lower power levels.

Run Steps: Under simulated lab conditions, by using a direct RF connection when an antenna connector is accessible, reduce the power level to -155 dBm after the device obtains a location fix.

Expected Result: The device should maintain a location fix -155 dBm.

Reacquisition time

Description: The device should be able to reacquire a location fix in 2 seconds. Clear sky conditions are assumed when a signal is available.

Run Steps: Under simulated lab conditions, after the device obtains a location fix, reduce the power level enough to force the device to lose the fix. Then increase power levels and monitor the reacquisition time. Alternatively, you can drive through a tunnel during drive testing.

Expected Result: The device should reacquire a location fix in 2 seconds.

Static navigation accuracy

Description: The device should report accurate latitude, longitude, and altitude (if supported).

Run Steps: Compare the accuracy of longitude, latitude and altitude (if available), to the location from a trusted data source. Trusted data sources can be survey markers, GNSS simulators, or a Microsoft Signature-certified Windows tablet that has GPS.

Expected Result: The DUT should report horizontal accuracy of 15 meters and vertical accuracy of 30 meters for 95% of the time.

Dynamic navigation accuracy

Description: When the DUT is mobile, the DUT should accurately report latitude, longitude and altitude if supported.

Run Steps: During simulated or actual device/walk testing, compare the accuracy of longitude, latitude and altitude (if available), to the location from trusted data source. Trusted data sources can be survey markers, GNSS simulators, or a Microsoft Signature-certified Windows tablet that has GPS.

Expected Result: Device should report horizontal accuracy of 15 meters and vertical accuracy of 100 meters.

Power consumption tests

The following diagram illustrates how a driver can use WDF idle detection StopIdle/ResumeIdle methods to move between D-States. The test cases in this section confirm that the driver is going to the correct state at the appropriate time.

<Art placeholder for Fig1_ Fig1_stopidle_resumeidle>

Figure 1. StopIdle/ResumeIdle

USB selective suspend

This test applies to USB connected devices only. A GPS device for which no clients subscribe for a report interval of 8 seconds or less should participate on selective suspend when all devices on the bus are ready to go into a Suspend state.

Device Manager and Event Tracing for Windows (ETW) events are used to monitor the USB bus state transitions.

Average sleep power consumption

GPS device should have a sleep average power consumption of less than 1mW, including any bus connection interfaces. If this is not the case, the device must support removing power completely from the GPS device when in D3 (D3-Cold).

D3-Cold

Devices that support D3cold should not degrade the TTFF performance for more than 6 seconds. For example, if a device can get a location fix in 2 seconds under hot-start conditions, it should be able to get a fix in 8 seconds or less when it resumes from D3cold. If device cannot meet this requirement, the driver should limit D3cold state transitions to when GPS Radio is disabled.

For more information about D3cold, see Supporting D3cold in a Driver.

Power management tests

Connected Standby

Connected Standby testing includes Windows HLK PowerState tests and Device Fundamentals tests with IO cover test scenarios.

Resume in no coverage area

Description: Put the system into the Connected Standby state when there are active clients. Resume in a no-coverage area. The device should try to acquire a location fix and enter the SENSOR_STATE_INITIALIZING state.

Run Steps: When active clients are connected, put the device into Connected Standby. Wake from Connected Standby in an area that does not have a GPS signal.

Expected Result: The device should acquire a location fix and go into the SENSOR_STATE_INITIALIZING state.

Antenna performance tests

Performance tests that use an OTA connection

It is common to performance-test GNSS receivers in a lab environment over a cabled RF connection, thereby bypassing the GPS antenna and its associated circuitry. Device performance and issues in GPS antenna and its circuitry can cause poor user experience in location-based service applications. To discover these issues, you should test managed system devices for GPS performance by using an OTA test methodology.

Antenna testing includes the following requirements for certification:

  • Systems that have GPS support must pass testing according to the Cellular Telecommunications & Internet Association (CTIA) Test Plan for Mobile Station Over-the-Air Performance, Method of Measurement for Radiated Radio Frequency (RF) Power and Receiver Performance v3.0+ for A-GPS. For more information about CTIA tests, see CTIA Certification Tests. In addition, Total Isotropic Sensitivity (TIS), Upper Hemisphere Isotropic Sensitivity (UHIS) and Partial Isotropic GPS Sensitivity (PIGS), must be measured; OEMs must post measurement results to Microsoft for review. These requirements apply to systems that have Mobile Broadband support.

  • The system must have TIS and UHIS free space of -140 dBm or better for GPS. For systems that have Mobile Broadband support, the measurements must follow the test methodology and test parameters that are defined in the Antenna Performance for execution guidelines for Wi-Fi-only systems section of the CTIA 3.x test plan.

  • The average gain of the GPS antenna must be better than -6dBi.

  • Performance must not drop below the minimal acceptable standard when the device is held in a common handheld position. The device must maintain over-the-air (OTA) acquisition sensitivity at -140 dBm and OTA tracking sensitivity of -145 dBm when the system is held in common positions.

  • The device must maintain OTA acquisition sensitivity at -140 dBm and OTA tracking sensitivity of -145 dBm when the keyboard or docking station is closed.

  • You must perform antenna and radiated sensitivity testing when the GPS antenna is in the expected positions in the device.

  • The intended GPS production antenna must be in its intended location for Engineering Verification (EV) systems. The antenna location must be finalized for Design Verification (DV) systems.

  • OEMs should run antenna performance and radiated sensitivity tests and understand the failures on EV units. The tests must pass prior to DV units.

RF Sensitivity Testing for Wi-Fi-only systems

A GPS IHV can provide NMEA logging and plotting tools and documentation.

Compare Signal-to-Noise Ratio (SNR) on the test device and on a reference device that has good GPS RF sensitivity at the same location under the same conditions. Enable IHV NMEA logs and take the devices for walk/drive testing for 15+ minutes under a clear sky. Analyze the logs by using the NMEA Plotting tool that the IHV provides. Compare average signal strength of the devices.

NOTE

If you do not have the NMEA Plotting tool from an IHV, you can use Microsoft Bing

Human interference tests

Antenna positioning should take human interference into account. When the system is held in common states, GPS should not lose a location fix, should not increase the error radius more than 30%, and should maintain OTA acquisition sensitivity at -140 dBm and OTA tracking sensitivity of -145 dBm.

Commonly used states for slates:

  • Hands on the sides, landscape orientation

  • Hand on bottom, landscape orientation

  • Hands on the sides, portrait orientation (start on left)

  • Hands on the bottom, portrait orientation (start on left)

  • Hands on the sides, portrait orientation (start on right)

  • Hands on the bottom, portrait orientation (start on right)

Human interference impact on acquisition and tracking sensitivity

Description: The device acquisition and tracking sensitivity should not cause performance to drop below the minimal acceptable standard when the device is held at specified handgrips.

Run Steps: Hold the device in common handheld positions. Check acquisition sensitivity and tracking sensitivity.

Expected Result: Tracking and acquisition sensitivity should not be impacted when the device is held in certain positions. The device should maintain OTA acquisition sensitivity at -140 dBm and OTA tracking sensitivity of -145 dBm.

Interoperability tests

Mobile Broadband, Wi-Fi, and GPS interoperability

Description: Disabling mobile broadband or Wi-Fi device should not prevent GPS from functioning. Turning MB or Wi-Fi radio off should not prevent GPS from getting a location fix.

Run Steps:

  • Disable Mobile Broadband and confirm that GPS can still get a location fix. Re-enable Mobile Broadband.

    NOTE

    GPS devices that use device services is an exception; these devices should first go into SENSOR_STATE_INITIALIZING state and, after 30 seconds, should go into the SENSOR_STATE_NOT_AVAILABLE state when Mobile Broadband is disabled

  • Disable Wi-Fi and confirm that GPS can still get a location fix.

  • Turn off Mobile Broadband Radio and confirm that GPS can still get a location fix.

  • Turn off Wi-Fi Radio and confirm that GPS can still get a location fix.

  • Remove the Mobile Broadband SIM and confirm that GPS can get a location fix.

Expected Result: For Mobile Broadband or Wi-Fi devices, radio and SIM state should not prevent GPS from functioning.

Mobile Broadband, Wi-Fi, Bluetooth, Near Field Communication (NFC), and camera interference

Radios and other devices such as system cameras can interfere with the GPS. GPS devices commonly share the same module with Mobile Broadband, Wi-Fi and Bluetooth. GPS functionality should not be impacted by these devices.

Description: Simultaneous usage of Mobile Broadband, Wi-Fi, Bluetooth, and camera should not degrade the performance and functionality of the GPS device, or vice versa.

Execution Steps: Run basic functionality tests with Mobile Broadband, Wi-Fi, Bluetooth, and camera on and actively in use.

  • Perform a large download over a Mobile Broadband connection while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Perform a large download over a Wi-Fi connection while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Perform a Bluetooth file transfer while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Perform a Wi-Fi scan while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Perform a Mobile Broadband scan while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Perform a Bluetooth scan while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Record video while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Watch a movie over the Internet while using GPS. Monitor sensor state, error radius and signal strength and the event logs from SDT.

  • Perform an NFC data transfer (for example, transfer photos) for 5 minutes. Monitor sensor state, error radius and signal strength and the event logs from SDT.

Expected Result: GPS should function normally during the time that these devices are being used. Usage of these devices should not impact sensor state, error radius and signal strength negatively.

Drive tests

Manual drive testing occurs when the system is taken on a drive by using a predefined route that includes tunnels and areas with different multipath impact. During the drive, the system GPS data is captured by a test application and is compared to a reference GPS. At no time should the location that the system reports be +/- the error radius outside the location reported by the reference GPS. The average error radius should be <= 30 meters.

Drive testing exercises real life conditions such as dynamic navigation accuracy, reacquisition after going through a tunnel, impact of multi-path signals, and atmospheric conditions.

The following functionality tests are run during drive testing:

  • State transitions are monitored and compared to reference GPS.

  • Latitude, longitude and altitude (if available) are monitored and compared to reference GPS. A visual map representation is used for easy comparison.

  • Speed and heading data are monitored and compared to reference GPS.

  • Acquisition time and reacquisition time after driving through tunnels are measured and compared to reference GPS.

  • Tracking sensitivity is monitored in multipath impact areas. Data report frequency and any interruptions on the data reports are monitored.

  • Dynamic navigation accuracy is monitored and compared to reference GPS by using visual map representations.

  • Device Plug and Play (PnP) and radio manager state transitions are performed during dynamic navigation.

  • Report intervals are monitored and compared to reference GPS.

Simulator tests

A GNSS simulator (Spirent GSS6700) is used to achieve controlled lab conditions. It replays same test scenarios for repetition, simulates satellite states, various locations, and time such as south of equator and 2 years later, simulates in vehicle navigation, atmospheric conditions, multi-path signals, and error conditions. The standard Spirent GSS6700 simulator test scenarios are run.

An OTA RF connection tests the system together with original antenna and shielding. Direct connection can also be used when an antenna connector is accessible for receiver testing. Simulator testing focuses on common simulator scenarios, including GNSS receiver performance characteristics and the following scenarios:

  • Cold-start TTFF

  • Hot-start TTFF

  • Acquisition sensitivity

  • Re-acquisition sensitivity

  • Tracking sensitivity

  • Static position accuracy

  • Dynamic position accuracy

  • Multipath

  • GPS and Globalnaya navigatsionnaya sputnikovaya sistema (GLONASS)

GPS acceptance test matrix

  • OS build tests run on:

  • Windows HLK version:

  • Platform firmware version:

  • Platform tests run on:

Test level | Test description | Verification results | Comments
Basic (Level 1) | Driver must be signed with the IHV certificate |  |
Basic (Level 1) | Driver must be installed by using device manager/ Deployment Image Servicing and Management (DISM) |  |
Basic (Level 1) | GPS.Test Descriptions.Robustness.Driver Verifier, WDF Verifier and Application Verifier |  |
Basic (Level 1) | Location Sensor WHLK tests: Device.Input.Sensor.System tests for Location Sensors: System.Client.Sensor. |  |
Basic (Level 1) | Radio Management WHLK tests: System.Client.RadioManagement. |  |
Basic (Level 1) | In addition to required WHLK tests, Optional WHLK tests under Location Sensor WHLK tests: Device.Input.Sensor. and System.Client.Sensor.* must run and pass for non-ARM SoC systems |  |
Basic (Level 1) | Device Fundamentals WHLK tests: Device.DevFund. |  |
Basic (Level 1) | USB WHLK tests (USB connected devices only): Device.Connectivity.UsbDevices. |  |
Basic (Level 1) | GPS.Test Descriptions.Functionality.Sensor category, type, properties and data fields |  |
Basic (Level 1) | GPS.Test Descriptions.Functionality.State Transitions |  |
Basic (Level 1) | GPS.Test Descriptions.Functionality.Accuracy of Latitude and Longitude |  |
Basic (Level 1) | GPS.Test Descriptions.Functionality.Speed Data |  |
Basic (Level 1) | GPS.Test Descriptions.Functionality.Heading Data |  |
Basic (Level 1) | GPS.Test Descriptions.Assisted GPS.A-GPS |  |
Basic (Level 1) | GPS.Test Descriptions.Assisted GPS.Position Injection. Connection Type |  |
Basic (Level 1) | GPS.Test Descriptions.Antenna Performance.OTA Connection. The device should get a location fix in clear sky outdoors as is without using external antennas or other modifications. |  |
Basic (Level 1) | GPS.Test Descriptions.Interoperability.* (GPS can get a location fix when Mobile Broadband, Bluetooth, Wi-Fi, or camera is in active use) |  |
Basic (Level 1) | GPS.Test Descriptions.Functionality.Other Sensor Properties |  |
Basic (Level 1) | GPS.Test Descriptions.Assisted GPS.Position Injection. Connection Time |  |
Basic (Level 1) | GPS.Test Descriptions.Antenna Performance.HumanInterference Tests. Device should get a location fix in clear sky outdoors as is without any external antennas or other modifications, while it is held in common handheld positions. |  |
Stress (Level 2) | GPS.Test Descriptions.Robustness. |  |
Performance (Level 2) | GPS.Test Descriptions.Performance. |  |
Power (Level 1) | GPS.Test Descriptions.Power Consumption. |  |
Power (Level 1) | GPS.Test Descriptions.Power Management. |  |
Antenna Performance (Level 1 for OEM) | GPS.Test Descriptions.Antenna Performance. |  |
Drive Tests (Level 3) | GPS.Test Descriptions.Drive Tests. |  |
Simulator Tests (Level 4) | GPS.Test Descriptions.Simulator Tests.* |  |

Related topics

Windows Sensor and Location Platform

Location driver guidelines for power and performance

Writing a location sensor driver

Filtering data

Sensor Device Testing Prerequisites


Device.Network

In this section

  • Device.Network tests
  • Device.Network additional documentation


Device.Network tests

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Affected Tests: |
Wlan Test - Attempt a connection to a non-existent network Wlan Test - Connect to a WPA2 PSK AES AP Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle Wlan Test - Enable and Disable WFD Autonomous GO Wlan Test - Query All Reported Oids Wlan Test - Query Interface Properties Wlan Test - Scan for Networks Wlan Test - Toggle airplane mode Wlan Test - Wlan Device Capabilities Check | Wlan Test - Wlan Device enumeration Wlan Test - Wlan Device Reset Check Wi-Fi Direct Basic Discovery Tests - Functional Wi-Fi Direct Basic Pairing Tests - Functional Wi-Fi Direct Basic Reconnect Tests - Functional Wi-Fi Direct Legacy Pairing Tests - Functional Wi-Fi Direct Service Discovery Tests - Functional Wi-Fi Direct Service Pairing and Reconnect Tests - Functional Wlan Test - Wlan Device Capabilities Check
  • CopyFile Client to Server LOGO test
  • CopyFile Server to Client LOGO test
  • IPSec TOv2 Logo Test
  • LAN CS Test - IPv4 Basic
  • LAN CS Test - IPv4 Longhaul
  • LAN CS Test - IPv6 basic
  • LAN CS Test - IPv6 Longhaul
  • NDISTest 6.0 - [1 Machine] - 1c_64BitOIDs
  • NDISTest 6.0 - [1 Machine] - 1c_ChimneyOIDCoverage
  • NDISTest 6.0 - [1 Machine] - 1c_ChimneyReqCov
  • NDISTest 6.0 - [1 Machine] - 1c_FaultHandling
  • NDISTest 6.0 - [1 Machine] - 1c_IOCTLCoverage
  • NDISTest 6.0 - [1 Machine] - 1c_KernelCalls
  • NDISTest 6.0 - [1 Machine] - 1c_Mini6PerfSend
  • NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids
  • NDISTest 6.0 - [1 Machine] - 1c_Mini6Send
  • NDISTest 6.0 - [1 Machine] - 1c_NdisRequestCov
  • NDISTest 6.0 - [1 Machine] - 1c_OidsDeviceIoControl
  • NDISTest 6.0 - [1 Machine] - 1c_OidsWMI
  • NDISTest 6.0 - [1 Machine] - 1c_Registry
  • NDISTest 6.0 - [1 Machine] - 1c_WMICoverage
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6CheckConnections
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6Performance
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6SendRecv
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6SendRecvReply
  • NDISTest 6.0 - [2 Machine] - 2c_Mini6Stress
  • NDISTest 6.0 - [2 Machine] - 2c_OidsNdisRequest
  • NDISTest 6.0 - [2 Machine] - 2c_Priority
  • NDISTest 6.5 - [1 Machine] - OffloadRSSv2
  • NDISTest 6.5 - [1 Machine] - GenericMiniportRequirements
  • NDISTest 6.5 - [1 Machine] - IPSecOids
  • NDISTest 6.5 - [1 Machine] - IPSecStdKey
  • NDISTest 6.5 - [1 Machine] - OffloadParity
  • NDISTest 6.5 - [1 Machine] - OffloadRsc
  • NDISTest 6.5 - [1 Machine] - OffloadVMMQ
  • NDISTest 6.5 - [1 Machine] - PM_Requirements
  • NDISTest 6.5 - [1 Machine] - QosCapabilities
  • NDISTest 6.5 - [1 Machine] - QosOids
  • NDISTest 6.5 - [1 Machine] - SRIOVBasicVerification
  • NDISTest 6.5 - [1 Machine] - SRIOVTestingVF
  • NDISTest 6.5 - [1 Machine] - SRIOVVMSwitchStress
  • NDISTest 6.5 - [1 Machine] - StandardizedKeywords
  • NDISTest 6.5 - [1 Machine] - VMQTestingOIDs
  • NDISTest 6.5 - [2 Machine] - AddressChange
  • NDISTest 6.5 - [2 Machine] - CheckConnectivity
  • NDISTest 6.5 - [2 Machine] - CheckConnectivity with AutoFail
  • NDISTest 6.5 - [2 Machine] - ConfigCheck
  • NDISTest 6.5 - [2 Machine] - DynamicVMQBasicVerification
  • NDISTest 6.5 - [2 Machine] - E2EPerf
  • NDISTest 6.5 - [2 Machine] - GlitchFreeDevice
  • NDISTest 6.5 - [2 Machine] - InterruptModeration
  • NDISTest 6.5 - [2 Machine] - InvalidPackets
  • NDISTest 6.5 - [2 Machine] - IOVVMQBasicVerification
  • NDISTest 6.5 - [2 Machine] - IPSecAH
  • NDISTest 6.5 - [2 Machine] - IPSecAhEsp
  • NDISTest 6.5 - [2 Machine] - IPSecESP
  • NDISTest 6.5 - [2 Machine] - KeepAlive
  • NDISTest 6.5 - [2 Machine] - LinkCheck
  • NDISTest 6.5 - [2 Machine] - MPE_Ethernet.xml
  • NDISTest 6.5 - [2 Machine] - MultiCast Address
  • NDISTest 6.5 - [2 Machine] - OffloadChecksum
  • NDISTest 6.5 - [2 Machine] - OffloadLSO
  • NDISTest 6.5 - [2 Machine] - OffloadMisc
  • NDISTest 6.5 - [2 Machine] - PacketFilters
  • NDISTest 6.5 - [2 Machine] - PM_PowerStateTransition
  • NDISTest 6.5 - [2 Machine] - PM_WakeOnLinkChange
  • NDISTest 6.5 - [2 Machine] - PM_WolMagicPacket
  • NDISTest 6.5 - [2 Machine] - PM_WolPattern
  • NDISTest 6.5 - [2 Machine] - QosEts
  • NDISTest 6.5 - [2 Machine] - QosPnpPower
  • NDISTest 6.5 - [2 Machine] - QosPriorityFlowControl
  • NDISTest 6.5 - [2 Machine] - QosRemoteSettings
  • NDISTest 6.5 - [2 Machine] - QosSpeedCheck
  • NDISTest 6.5 - [2 Machine] - QosStorageInterop
  • NDISTest 6.5 - [2 Machine] - Reset
  • NDISTest 6.5 - [2 Machine] - SelectiveSuspend
  • NDISTest 6.5 - [2 Machine] - ShortPackets
  • NDISTest 6.5 - [2 Machine] - SingleEtherType
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingDevice
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingFailover
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingOIDs
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingPFRemoval
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingRegistry
  • NDISTest 6.5 - [2 Machine] - Stats
  • NDISTest 6.5 - [2 Machine] - TxFlowControl
  • NDISTest 6.5 - [2 Machine] - VlanSendRecv
  • NDISTest 6.5 - [2 Machine] - VMQBasicVerification
  • NDISTest 6.5 - [2 Machine] - VMQCheckConnectivity
  • NDISTest 6.5 - [2 Machine] - VMQPnpTest
  • NDISTest 6.5 - [2 Machine] - VMQPowerManagement
  • NDISTest 6.5 - [2 Machine] - VMQReceiveQueueStateChecking
  • NDISTest 6.5 - [2 Machine] - VMQScalability
  • NDISTest 6.5 - [2 Machine] - VMQStressTest
  • NDK Logo Tests
  • PrivateCloudSimulator - Device.Network.LAN.10GbOrGreater
  • PrivateCloudSimulator - Device.Network.LAN.AzureStack
  • Run Network Switch Profile Tests
  • Run Network Switch Profile View Tests
  • Run RSC Tests
  • SMB FileIObvt LOGO test
  • SMB SmbConnect LOGO test
  • SMB SmbConnectStress BVT LOGO test
  • SMB SmbConnectStress Longhaul LOGO test
  • SysCache LOGO test
  • Wi-Fi Direct Basic Discovery Tests - Functional
  • Wi-Fi Direct Basic Pairing Tests - Functional
  • Wi-Fi Direct Basic Reconnect Tests - Functional
  • Wi-Fi Direct Legacy Pairing Tests - Functional
  • Wi-Fi Direct Service Discovery Tests - Functional
  • Wi-Fi Direct Service Pairing and Reconnect Tests - Functional
  • Win6_4.MB.CDMA.Data.MBBDriverStress
  • Win6_4.MB.CDMA.Data.TestClassDriver
  • Win6_4.MB.CDMA.Data.TestConnect
  • Win6_4.MB.CDMA.Data.TestDeviceServices
  • Win6_4.MB.CDMA.Data.TestDisableEnable
  • Win6_4.MB.CDMA.Data.TestHomeProvider
  • Win6_4.MB.CDMA.Data.TestLoopBack
  • Win6_4.MB.CDMA.Data.TestMultiCarrier
  • Win6_4.MB.CDMA.Data.TestPacketService
  • Win6_4.MB.CDMA.Data.TestPin
  • Win6_4.MB.CDMA.Data.TestPowerStates
  • Win6_4.MB.CDMA.Data.TestPreferredProvider
  • Win6_4.MB.CDMA.Data.TestRadioStateHw
  • Win6_4.MB.CDMA.Data.TestRadioStateSw
  • Win6_4.MB.CDMA.Data.TestReadyInfo
  • Win6_4.MB.CDMA.Data.TestRegisterState
  • Win6_4.MB.CDMA.Data.TestRemoval
  • Win6_4.MB.CDMA.Data.TestSelectiveSuspend
  • Win6_4.MB.CDMA.Data.TestSetup
  • Win6_4.MB.CDMA.Data.TestSignalLoss
  • Win6_4.MB.CDMA.Data.TestSignalLoss2
  • Win6_4.MB.CDMA.Data.TestSignalState
  • Win6_4.MB.CDMA.Data.TestSms
  • Win6_4.MB.CDMA.Data.TestSmsStoreFull
  • Win6_4.MB.CDMA.Data.TestUSBDescriptor
  • Win6_4.MB.CDMA.Data.TestVisibleProvider
  • Win6_4.MB.CDMA.Data.TestWake.IncomingDataPacket
  • Win6_4.MB.CDMA.Data.TestWake.RegisterStateChange
  • Win6_4.MB.CDMA.Data.TestWake.SmsMessage
  • Win6_4.MB.CellcoreDataAOACTest
  • Win6_4.MB.CellcoreDataAPI
  • Win6_4.MB.CellcoreDataDualSIMScenario
  • Win6_4.MB.CellcoreDataIPTypeTest
  • Win6_4.MB.CellcoreDataScenario
  • Win6_4.MB.GSM.Data.MBBDriverStress
  • Win6_4.MB.GSM.Data.TestAuthChallenge
  • Win6_4.MB.GSM.Data.TestClassDriver
  • Win6_4.MB.GSM.Data.TestConnect
  • Win6_4.MB.GSM.Data.TestDeviceServices
  • Win6_4.MB.GSM.Data.TestDisableEnable
  • Win6_4.MB.GSM.Data.TestHomeProvider
  • Win6_4.MB.GSM.Data.TestLoopBack
  • Win6_4.MB.GSM.Data.TestMPDP
  • Win6_4.MB.GSM.Data.TestMultiCarrier
  • Win6_4.MB.GSM.Data.TestPacketService
  • Win6_4.MB.GSM.Data.TestPin
  • Win6_4.MB.GSM.Data.TestPowerStates
  • Win6_4.MB.GSM.Data.TestPreferredProvider
  • Win6_4.MB.GSM.Data.TestRadioStateHw
  • Win6_4.MB.GSM.Data.TestRadioStateSw
  • Win6_4.MB.GSM.Data.TestReadyInfo
  • Win6_4.MB.GSM.Data.TestRegisterState
  • Win6_4.MB.GSM.Data.TestRemoval
  • Win6_4.MB.GSM.Data.TestSelectiveSuspend
  • Win6_4.MB.GSM.Data.TestSetup
  • Win6_4.MB.GSM.Data.TestSignalLoss
  • Win6_4.MB.GSM.Data.TestSignalLoss2
  • Win6_4.MB.GSM.Data.TestSignalState
  • Win6_4.MB.GSM.Data.TestSimBad
  • Win6_4.MB.GSM.Data.TestSimNotInserted
  • Win6_4.MB.GSM.Data.TestSimRoaming
  • Win6_4.MB.GSM.Data.TestSms
  • Win6_4.MB.GSM.Data.TestSmsStoreFull
  • Win6_4.MB.GSM.Data.TestUSBDescriptor
  • Win6_4.MB.GSM.Data.TestUssd
  • Win6_4.MB.GSM.Data.TestVisibleProvider
  • Win6_4.MB.GSM.Data.TestWake.IncomingDataPacket
  • Win6_4.MB.GSM.Data.TestWake.RegisterStateChange
  • Win6_4.MB.GSM.Data.TestWake.SmsMessage
  • Win6_4.MB.NDIS.DeviceCaps
  • Win6_4.MB.Registration
  • Win6_4.MB.Registration.DualSim
  • Win6_4.MB.Registration.Location
  • Win6_4.MB.Registration.ModemReset
  • Win6_4.MB.Registration.NetworkSelection
  • Win6_4.MB.Registration.OperatorList
  • Win6_4.MB.Registration.PowerState
  • Win6_4.MB.Registration.RebootTests
  • Win6_4.MB.Registration.VOLTE
  • Win6_4.MB.SMS.Encoding
  • Win6_4.MB.SMS.MultiSegmentMessage
  • Win6_4.MB.SMS.SendMsgInternationNumber
  • Win6_4.MB.SMS.SendMsgNegtiveTest
  • Win6_4.MB.SMS.SendRecvSMS
  • Win6_4.MB.SMS.SendRecvSMSAfterPINUnlocked
  • Win6_4.MB.SMS.SendRecvSMSAfterPinUnlockStress
  • Win6_4.MB.SMS.SendRecvSMSAfterPUKUnlockStress
  • Win6_4.MB.SMS.SendRecvSMSAfterSoftSwap
  • Win6_4.MB.SMS.SendRecvSMSModemOFF
  • Win6_4.MB.SMS.SendRecvSMSNonProvision
  • Win6_4.MB.SMS.SendRecvSMSOutgoingCallOnSameSubphoneStress
  • Win6_4.MB.SMS.SendRecvSMSOutgoingCallOnSameSubphoneStress
  • Win6_4.MB.SMS.SendRecvSMSPINLocked
  • Win6_4.MB.SMS.SendRecvSMSPUKLocked
  • Win6_4.MB.SMS.SendRecvSMSStress
  • Win6_4.MB.SMS.SendRecvSMSStressWithLongCallOnSameSubpone
  • Win6_4.MB.SMS.SendRecvSMSSubphoneOFF
  • Win6_4.MB.SMS.SendRecvSMSTransferDataOnDiffSubPhoneStress
  • Win6_4.MB.SMS.SendRecvSMSTransferDataOnSameSubphoneStress
  • Win6_4.MB.SMS.SendRecvSMSUnregistered
  • Win6_4.MB.SMS.SendRecvSMSWithDatOnDiffSubphone
  • Win6_4.MB.SMS.SendRecvSMSWithDatOnDiffSubphone
  • Win6_4.MB.SMS.SendRecvSMSWithDatOnSameSubphone
  • Win6_4.MB.SMS.SendRecvSMSWithDatOnSameSubphone
  • Win6_4.MB.SMS.SendRecvSMSWithVoiceOnDiffSubpone
  • Win6_4.MB.SMS.SendRecvSMSWithVoiceOnSameSubpone
  • Win6_4.MB.SMS.SMSChangeConfiguration
  • Win6_4.MB.SMS.SMSOnUICC
  • Win6_4.MB.System.Data.TestClassDriver
  • Win6_4.MB.System.Data.TestConnect
  • Win6_4.MB.UICC.ATR
  • Win6_4.MB.UICC.EnumerateSlots
  • Win6_4.MB.UICC.GetCardInfo
  • Win6_4.MB.UICC.GetIMSI
  • Win6_4.MB.UICC.GetSubscriberNumber
  • Win6_4.MB.UICC.GetUiccPRLID
  • Win6_4.MB.UICC.GetUiccRecordStatus
  • Win6_4.MB.UICC.GetUiccServiceState
  • Win6_4.MB.UICC.PB.DeleteAdditionalNumberStrings
  • Win6_4.MB.UICC.PB.FDNWritePhonebookEntry
  • Win6_4.MB.UICC.PB.GetAllAdditionalNumberStrings
  • Win6_4.MB.UICC.PB.GetAllEmergencyNumbers
  • Win6_4.MB.UICC.PB.GetPBCapsType
  • Win6_4.MB.UICC.PB.GetPBMaxRead
  • Win6_4.MB.UICC.PB.GetPhoneBookOptions
  • Win6_4.MB.UICC.PB.ReadFDNPhonebookEntries
  • Win6_4.MB.UICC.PB.ReadPhonebookEntries
  • Win6_4.MB.UICC.PB.WriteAdditionalNumberStrings
  • Win6_4.MB.UICC.PB.WritePhonebookEntry
  • Win6_4.MB.UICC.Security.ChangeUiccLockPassword
  • Win6_4.MB.UICC.Security.GetPersoDeactivationState
  • Win6_4.MB.UICC.Security.GetUiccLockState
  • Win6_4.MB.UICC.Security.GetUiccLockState
  • Win6_4.MB.UICC.Security.GetUiccServiceLock
  • Win6_4.MB.UICC.Security.SetUiccLockEnabled
  • Win6_4.MB.UICC.Security.VerifyAppPersoState
  • Win6_4.MB.UICC.Security.VerifyUiccLock
  • Win6_4.MB.UICC.Security.VerifyUiccLock
  • Win6_4.MB.UICC.SendRestrictedUiccCMD
  • Win6_4.MB.UICC.SetUiccServiceState
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_HoldActive_AcceptHeld
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_RelBoth
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_RelIn_HoldActive_AcceptHeld
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_RemotehangupIn_RelOut
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_3rdOut_RelAll
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_HoldAllBut1st
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_RelBoth
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_RelHeldConf
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_ReleaseActive_AcceptHeld
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_RelOffering
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_RelOut_AcceptIn
  • Win6_4.MB.Voice.3GPP.1stOut_2ndIn_RemoteHangupOut_AcceptIn
  • Win6_4.MB.Voice.3GPP.2OutgoingCalls_BothInConf_RelBoth
  • Win6_4.MB.Voice.3GPP.3Out_AllInConf_Make2ndPrivate_SwapCalls_RelPrivate_RelAll
  • Win6_4.MB.Voice.3GPP.SingleCallTests
  • Win6_4.MB.Voice.3GPP.SingleCallTests
  • WLAN Association Tests - Custom Configuration
  • WLAN Association Tests - OPEN_WEP - WPA_TKIP
  • WLAN Association Tests - OPEN_WPA2_AES
  • WLAN Association Tests - WPA2_PSK_PEAP_AES
  • WLAN D2 Sleep - Functional
  • WLAN Data Path Tests - Functional
  • WLAN Dot11W Tests - Functional
  • WLAN FIPS Association Tests - WPA2_PSK_PEAP_AES
  • WLAN Roaming Tests - Custom Configuration
  • WLAN Roaming Tests - OPEN NONE
  • WLAN Roaming Tests - WPA2_ENTERPRISE_PEAP_TKIP_AES
  • WLAN Roaming Tests - WPA2_ENTERPRISE_TTLS_TKIP_AES
  • WLAN Roaming Tests - WPA2_PSK_AES
  • WLAN Scan Tests - Custom Configuration
  • WLAN Scan Tests - Multiple BSSIDs
  • WLAN Scan Tests - Various Auth Cipher Types And Hidden
  • WLAN Stress Test - Functional
  • Win6_4.MB.CDMA.Data.TestBaseStationsInfo
  • Win6_4.MB.CDMA.Data.TestDeviceCapsEx
  • Win6_4.MB.CDMA.Data.TestLowLevelUiccAccess
  • Win6_4.MB.CDMA.Data.TestLteAttach
  • Win6_4.MB.CDMA.Data.TestModemBulkConfig
  • Win6_4.MB.CDMA.Data.TestPco
  • Win6_4.MB.CDMA.Data.TestProvisionedContext
  • Win6_4.MB.CDMA.Data.TestResetPassthrough
  • Win6_4.MB.CDMA.Data.TestSAR
  • Win6_4.MB.CDMA.Data.TestSlot
  • Win6_4.MB.GSM.Data.TestBaseStationsInfo
  • Win6_4.MB.GSM.Data.TestDeviceCapsEx
  • Win6_4.MB.GSM.Data.TestLowLevelUiccAccess
  • Win6_4.MB.GSM.Data.TestLteAttach
  • Win6_4.MB.GSM.Data.TestModemBulkConfig
  • Win6_4.MB.GSM.Data.TestPco
  • Win6_4.MB.GSM.Data.TestProvisionedContext
  • Win6_4.MB.GSM.Data.TestResetPassthrough
  • Win6_4.MB.GSM.Data.TestSAR
  • Win6_4.MB.GSM.Data.TestSlot
  • Wlan Power Transitions Reliability Test
  • Wlan Power Transitions Reliability Test - (WoW64 for ARM64)
  • Wlan Test - Attempt a connection to a non-existent network
  • Wlan Test - Attempt a connection to a non-existent network - (WoW64 for ARM64)
  • Wlan Test - Check Hosted Network Capable
  • Wlan Test - Check Hosted Network Capable - (WoW64 for ARM64)
  • Wlan Test - Connect to a WPA2 PSK AES AP
  • Wlan Test - Connect to a WPA2 PSK AES AP - (WoW64 for ARM64)
  • Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle
  • Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle - (WoW64 for ARM64)
  • Wlan Test - Enable and Disable WFD Autonomous GO
  • Wlan Test - Enable and Disable WFD Autonomous GO - (WoW64 for ARM64)
  • Wlan Test - Hotspot2 ANQP and GAS
  • Wlan Test - Hotspot2 ANQP and GAS - (WoW64 for ARM64)
  • Wlan Test - MAC Randomization test
  • Wlan Test - MAC Randomization test - (WoW64 for ARM64)
  • Wlan Test - Query All Reported Oids
  • Wlan Test - Query All Reported Oids - (WoW64 for ARM64)
  • Wlan Test - Query Interface Properties
  • Wlan Test - Query Interface Properties - (WoW64 for ARM64)
  • Wlan Test - Scan for Networks
  • Wlan Test - Scan for Networks - (WoW64 for ARM64)
  • Wlan Test - Toggle airplane mode
  • Wlan Test - Toggle airplane mode - (WoW64 for ARM64)
  • Wlan Test - Wlan Device Capabilities Check
  • Wlan Test - Wlan Device Capabilities Check - (WoW64 for ARM64)
  • Wlan Test - Wlan Device enumeration
  • Wlan Test - Wlan Device enumeration - (WoW64 for ARM64)
  • Wlan Test - Wlan Device Reset Check
  • Wlan Test - Wlan Device Reset Check - (WoW64 for ARM64)
  • WLAN Wake - Association Lost - Functional
  • WLAN Wake - GTK Refresh - Functional
  • WLAN Wake - NLO Discovery - Functional
  • WLAN Wake - Packet Tests - Functional


CopyFile Client to Server LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3f5859d-e47a-41da-9355-b4e11bbfc894

SMB CopyFile test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Development
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |


CopyFile Server to Client LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ea2f846-dc37-4d4c-90c8-d23e620cb02c

SMB CopyFile test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Development
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |


IPSec TOv2 Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d23b4ecf-0de9-4bc3-a9f9-69eddc22e35f

This test runs the Task Offload Logo test.

Test details
Specifications
  • Device.Network.LAN.IPsec.IPsec
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Network Testing.

More information

Command syntax

Command | Description
CPerseus.exe /module:[TestDirectory]\Suites\TOv2Logo.xml /type:"IPSec Scenario Testing Add-in" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
CPerseus.exe | <[testbinroot]>\nttest</p>
TOv2Logo.xml | <SystemDrive>\IkeTest\Suites

Parameters

Parameter name | Parameter description
queryTestNicMacAddress | Mac address of test network adapter
ReplacePatternsInFile.ps1 |
Win7_ReplaceNicNameInTest.ps1 |
IsWin7.ps1 |
queryTestNicClass | Device class of test network adapter
Win7_updateNicOffloadStateById.vbs |
Win7_updateNicOffloadStateByName.vbs |
TestDirectory |
Win7_updateNicOffloadStateByAddr.vbs |
SupportNetConnectionID | will hold the returned value from the detect job
TestNetConnectionID | will hold the returned value from the detect job
EnableTOv2Support.ps1 |
EnableTOv2Client.ps1 |
queryTestNicDeviceID |
MsgNICIPSupport | IP of Message NIC on Support machine, to be populated by detect.wsf before installer runs
MsgNICIPClient | IP of Message NIC on Client machine, to be populated by detect.wsf before installer runs


LAN CS Test - IPv4 Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5aaba9b-cdfc-4d7d-8a7d-94ed3f5868c3

This test verifies that the LAN device on systems that support InstantGo delivers reliable connectivity in Connected Standby.

The device seamlessly transitions between D0 and D2 states while in Connected Standby. The device maintains L2 connectivity while in Connected Standby. The device wakes up on matching wake patterns only. There are no spurious wakes while in Connected Standby. The wake packets are delivered without delay or buffering. The Real Time Communication app stays connected while in Connected Standby for 30 minutes.

Test details
Specifications
  • Device.Network.LAN.CS.ReliableCSConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

If you are still having problems completing this test, try the following:

  • If the device exits Connected Standby earlier than expected, make sure the device under test remains idle while the test runs.

  • If you get a system error for a control channel trigger, ensure that the network adapter is compatible with Connected Standby and it complies with NDIS 6.30 requirements.

  • If the OID request for a network adapter fails, ensure that the network adapter complies with NDIS 6.30 requirements.

  • If the network device removes unexpectedly, ensure that the driver is not crashing.

  • If the control channel trigger is detached, ensure that there is good reception and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the network adapter disconnects, ensure that there is good reception.

  • If the push notification is triggered too early, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification is triggered too late, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification did not trigger on time, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If you cannot install the package, ensure that the device under test is configured with the correct date and time. For more information, check the error description.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestInterfaceIndex |
TestDeviceStaticIP |
SupportInterfaceIndex |
SupportDeviceStaticIP |
CsDuration |


LAN CS Test - IPv4 Longhaul

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/550ef914-db21-48c4-905e-76c9f27eac5e

This test verifies that the LAN device on systems that support Connected Standby delivers reliable connectivity in Connected Standby.

The device seamlessly transitions between D0 and D2 states while in Connected Standby. The device maintains L2 connectivity while in Connected Standby. The device wakes up on matching wake patterns only. There are no spurious wakes while in Connected Standby. The wake packets are delivered without delay or buffering. The Real Time Communication app stays connected while in Connected Standby for 12 hours.

Test details
Specifications
  • Device.Network.LAN.CS.ReliableCSConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 720
Category | Development
Timeout (in minutes) | 43200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

If you are still having problems completing this test, try the following:

  • If the device exits Connected Standby earlier than expected, make sure the device under test remains idle while the test runs.

  • If you get a system error for a control channel trigger, ensure that the network adapter is compatible with Connected Standby and it complies with NDIS 6.30 requirements.

  • If the OID request for a network adapter fails, ensure that the network adapter complies with NDIS 6.30 requirements.

  • If the network device removes unexpectedly, ensure that the driver is not crashing.

  • If the control channel trigger is detached, ensure that there is good reception and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the network adapter disconnects, ensure that there is good reception.

  • If the push notification is triggered too early, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification is triggered too late, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification did not trigger on time, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If you cannot install the package, ensure that the device under test is configured with the correct date and time. For more information, check the error description.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestInterfaceIndex |
TestDeviceStaticIP |
SupportInterfaceIndex |
SupportDeviceStaticIP |
CsDuration |


LAN CS Test - IPv6 basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08ce2062-e46e-415b-9896-04f7080668af

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test verifies that the LAN device on systems that support Connected Standby delivers reliable connectivity in Connected Standby.

The device seamlessly transitions between D0 and D2 states while in Connected Standby. The device maintains L2 connectivity while in Connected Standby. The device wakes up on matching wake patterns only. There are no spurious wakes while in Connected Standby. The wake packets are delivered without delay or buffering. The Real Time Communication app stays connected over IPv6 while in Connected Standby for 30 minutes.

Test details
Specifications
  • Device.Network.LAN.CS.ReliableCSConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

If you are still having problems completing this test, try the following:

  • If the device exits Connected Standby earlier than expected, make sure the device under test remains idle while the test runs.

  • If you get a system error for a control channel trigger, ensure that the network adapter is compatible with Connected Standby and it complies with NDIS 6.30 requirements.

  • If the OID request for a network adapter fails, ensure that the network adapter complies with NDIS 6.30 requirements.

  • If the network device removes unexpectedly, ensure that the driver is not crashing.

  • If the control channel trigger is detached, ensure that there is good reception and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the network adapter disconnects, ensure that there is good reception.

  • If the push notification is triggered too early, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification is triggered too late, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification did not trigger on time, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If you cannot install the package, ensure that the device under test is configured with the correct date and time. For more information, check the error description.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestInterfaceIndex |
TestDeviceStaticIPV6 |
SupportInterfaceIndex |
SupportDeviceStaticIPV6 |
CsDuration |


LAN CS Test - IPv6 Longhaul

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/709a4427-6c66-4c78-acf7-b21446a32a56

This test verifies that the LAN device on systems that support InstantGo delivers reliable connectivity in Connected Standby.

The device seamlessly transitions between D0 and D2 states while in Connected Standby. The device maintains L2 connectivity while in Connected Standby. The device wakes up on matching wake patterns only. There are no spurious wakes while in Connected Standby. The wake packets are delivered without delay or buffering. The Real Time Communication app stays connected over IPv6 while in Connected Standby for 12 hours.

Test details
Specifications
  • Device.Network.LAN.CS.ReliableCSConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 720
Category | Development
Timeout (in minutes) | 43200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

If you are still having problems completing this test, try the following:

  • If the device exits Connected Standby earlier than expected, make sure the device under test remains idle while the test runs.

  • If you get a system error for a control channel trigger, ensure that the network adapter is compatible with Connected Standby and it complies with NDIS 6.30 requirements.

  • If the OID request for a network adapter fails, ensure that the network adapter complies with NDIS 6.30 requirements.

  • If the network device removes unexpectedly, ensure that the driver is not crashing.

  • If the control channel trigger is detached, ensure that there is good reception and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the network adapter disconnects, ensure that there is good reception.

  • If the push notification is triggered too early, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification is triggered too late, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If the push notification did not trigger on time, ensure that the network adapter complies with NDIS 6.30 requirements and that the network adapter maintains L2 connectivity in Connected Standby.

  • If you cannot install the package, ensure that the device under test is configured with the correct date and time. For more information, check the error description.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestInterfaceIndex |
TestDeviceStaticIPV6 |
SupportInterfaceIndex |
SupportDeviceStaticIPV6 |
CsDuration |


NDISTest 6.0 - \1 Machine\ - 1c_64BitOIDs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db5498e3-bd6b-43ac-9022-fb607be6ecfd

This test checks OID_GEN_XMIT_OK and OID_GEN_RCV_OK. It does not attempt to verify the values themselves. It only checks that the queries are properly handled. If the driver does not support 64 bit queries, it is warned unless it a Gigabit network adapter. Gigabit network adapters are required to support 64 bit queries.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

The OIDs are queried three times using:

  • Information Buffer Length = 0 bytes

    Expected Response:

    BytesNeeded = 8

    BytesWritten = 0 (Write No data in buffer)

    NdisStatus = INVALID_LENGTH Or BUFFER_TOO_SHORT

  • Information Buffer Length = 4 bytes

    Expected Response:

    Lower 32 bits of statistics

    BytesWritten = 4

    BytesNeeded = 8

    NdisStatus = SUCCESS

  • Information Buffer Length = 8 bytes

    Expected Response:

    64 bit statistics value

    BytesWritten = 8

    NdisStatus = SUCCESS

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_64BitOIDs.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_ChimneyOIDCoverage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22a62574-f39b-4b03-990a-bed2c5590710

This test exercises OID_TCP_TASK_OFFLOAD with various buffer sizes and input values. You should check the log file carefully for problems.

Test details
Specifications
  • Device.Network.LAN.TCPChimney.ComplyWithNDIS
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_ChimneyOIDCoverage.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_ChimneyReqCov

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/41197f01-76ed-4be1-afc5-04f7136430c5

This test exercises OID_TCP_TASK_OFFLOAD with various buffer sizes and input values. The user should check this log carefully for problems.

Test details
Specifications
  • Device.Network.LAN.TCPChimney.ComplyWithNDIS
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_ChimneyReqCov.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_FaultHandling

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/821954e1-dfdf-405f-8ee2-aae655551aa9

This automated test uses a fault injection feature of NDIS. Each loop will set bits in the registry for the driver under test. These bits will cause NDIS to fail specific NDIS calls. The registry value name is NdisDriverVerifyFlags. The loop, value, and NDIS call are listed below:

Loop | Value | NDIS Call
0 | 0x001 | NdisMAllocateMapRegisters
1 | 0x002 | NdisMRegisterInterrupt
2 | 0x004 | NdisMAllocateSharedMemory
3 | 0x010 | NdisMMapIoSpace
4 | 0x020 | NdisMRegisterIoPortRange
5 | 0x040 | Read NdisGetSetBusConfigSpace
6 | 0x080 | Write NdisGetSetBusConfigSpace
7 | 0x100 | NdisMInitializeScatterGatherDma

The driver should not load unless it does not call the particular function. This test is successful as long the driver does not crash the system. During each test loop, after the driver fails to load the registry is cleared and the driver is loaded normally to be sure it still works.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_FaultHandling.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_IOCTLCoverage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/228af305-7f99-4624-93c6-79b0d81fbd4d

This test gets the list of OIDs supported for QueryGlobalStatistics and queries them. It then proceeds to do a QueryAllGlobalStatistics. The NDIS Tester is not able to verify the values returned by most of these OIDs. You should check the log file carefully for problems.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_IOCTLCoverage.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_KernelCalls

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/818bdd92-529a-439e-a7f1-f4a74cd2b84c

This test discovers which kernel calls a driver is making and then checks to see if they are legal. In some of the cases of illegal calls, the log file will also contain information on which legal functions can be substituted for illegal function call.

Test details
Specifications
  • Device.Network.LAN.Base.NDISCalls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_KernelCalls.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_Mini6PerfSend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8477095-4363-4404-bba8-5dce759955b4

This test tries to keep the send path continuously busy. It starts by creating as many threads as processors on the test machine and from each of these threads sends pre-allocated packets to the network adapter. The rate of sends from each thread is controlled by the send complete rate of the miniport. It also measures the performance that the driver is able to achieve on the send path. The test goes through various combinations of send parameters (number of net buffers, number of net buffers per net buffer list, net buffer lists size, and so on), each running for 30 seconds.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 35
Category | Development
Timeout (in minutes) | 2100
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_Mini6PerfSend.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_Mini6RSSOids

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aff4ae7e-feed-452a-afd7-dc37ed071f48

This test exercises the various receive side scaling OIDs. The miniport driver should:

  • Return a valid CAPABILITIES structure which includes support for NdisHashFunctionToeplitz.

  • Accept all the PARAMETER sets if the hash information is valid and supported.

  • Reject the PARAMETER sets if the hash information is not supported or invalid or if the hash table or the structure itself is not of the correct size.

  • In case the miniport rejects a PARAMETER set, it should retain the previously set PARAMETERs structure.

  • Miniport should handle 64 bit misaligned requests correctly.

Test details
Specifications
  • Device.Network.LAN.RSS.RSS
  • Device.Network.LAN.RSS.SetHashFunctionTypeAndValue
  • Device.Network.LAN.RSS.SupportIndirectionTablesSizes
  • Device.Network.LAN.RSS.SupportToeplitzHashFunction
  • Device.Network.LAN.RSS.SupportUpdatesToRSSInfo
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_Mini6RSSOids.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_Mini6Send

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16bb6dfe-11b0-4bf9-8e2c-921147278a52

This NDIS 6.0-based miniport driver test calls the miniport a number of times, sending a bunch of Net Buffers and Net Buffer Lists each time from the test card to a random address. It goes through a combination of send configuration parameters, varying the number of net buffer lists in each call to send, the number of net buffers in each net buffer lists, the number and size of data buffers in each net buffer. It is not a stress test, and in each variation, the configuration parameters remain the same.

Each send variation runs for 20 seconds and the complete test would run for about 2 hours.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 25
Category | Development
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_ChimneyReqCov.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_NdisRequestCov

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0aaac5c-7c4c-488c-8352-14c49bc2ac67

This test checks that the driver is able to handle private OIDs correctly. Its purpose is to check that driver tries to validate the data in set OIDs and private OIDs. A driver should not cause a stop error regardless of what data is passed to it.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_NdisRequestCov.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_OidsDeviceIoControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ea73165-5685-4337-853b-27e103a833eb

This test gets the list of OIDs supported for QueryGlobalStatistics and queries them. It then proceeds to do a QueryAllGlobalStatistics. The NDIS Tester is not able to verify the values returned by most of these OIDs. You should check this log carefully for problems.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_OidsDeviceIoControl.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_OidsWMI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9d6ccb3-8ee9-4fb7-82c3-1abfbe48d221

This test queries for driver information using WMI. This test only has meaning for Windows 98 and Windows NT 5.0. In general, this script is testing ndis.sys and WMI, rather than your driver. If your driver exports any private GUIDs to WMI, then you need to look at the last few variations to make sure your driver is handling these correctly. The test uses a QueryGlobalStatistics call with OID_GEN_SUPPORTED_GUIDS to get the list of private GUIDs exported by your driver. It then attempts to query these GUIDs using WMI.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_OidsWMI.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_Registry

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/30708719-0550-43d3-8a1e-797f758c61f3

This test checks the robustness of the driver to handle data in the registry. The test finds the values in the driver subkey that the driver uses to initialize and tests them by putting random data, changing the type of the value and even deleting the value. Drivers must use appropriate defaults to make sure their functionality is not affected.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_Registry.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \1 Machine\ - 1c_WMICoverage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d6ac688-70fd-4163-8313-ffa2922b2afd

This test queries driver information using WMI. First, this test obtains the list of GUIDs supported by the driver (and by NDIS on behalf of the driver) and then attempts to query these GUIDs by using WMI. It tries to query and set the various exposed GUIDs both as an administrator and a normal user.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /script:{1c_WMICoverage.wsf} | Runs the test.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.0 - \2 Machine\ - 2c_Mini6CheckConnections

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26425705-1a45-4456-bf36-65d38ccf7c4e

This is an NDIS 6.0-based miniport driver test that verifies that the test and support cards are connected. It does this by sending 100 Net Buffer Lists, each containing 1 Net Buffer from the test card, directed to the support card. If the support card does not receive any packets, a dialog box is displays asking to check if the connection is established. As a 6.0 miniport test, it also ensures that all the 100 send attempts were completed successfully and the 100 packets did make it through to the remote side.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6CheckConnections.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Mini6Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d84f1476-2e4f-4079-8618-9551de569545

This test validates NDIS 6.0-based miniport driver performance.

Send: It sends from the test adapter to the various support adapters. It tries to keep the send path continuously busy. It starts by creating as many threads as processors on the test machine and from each of these threads sends (pre-allocated) packets to the support adapters. The rate of sends from each thread is controlled by the send complete rate of the miniport. It also measures the performance that the driver is able to achieve on the send path.

Receive: Receive side performance is restricted by the fact that (normally) only one receive DPC runs for each NIC. We try to improve this by using as many support adapters as possible, creating one open on each of them which is receiving.

Duration: The test goes through various combinations of send parameters (number of net buffers, number of net buffers per net buffer list, net buffer lists size, etc), each running for 30 seconds.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 35
Category | Development
Timeout (in minutes) | 2100
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6Performance.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Mini6RSSSendRecv

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/02453041-ce71-4e61-9e76-12a2a9362780

[This content isn't available yet.]

Test details
Specifications
  • Device.Network.LAN.RSS.RSS
  • Device.Network.LAN.RSS.SetHashFunctionTypeAndValue
  • Device.Network.LAN.RSS.SupportIndirectionTablesSizes
  • Device.Network.LAN.RSS.SupportToeplitzHashFunction
  • Device.Network.LAN.RSS.SupportUpdatesToRSSInfo
Platforms
  • Windows 10, client editions (x86)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6RSSSendRecv.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Mini6RSSSendRecv (Multi-Group Win8+)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ce7b1b3-c5f2-4fe0-99f4-dbf55971411b

This test validates the miniport driver's receive side scaling (RSS) implementation. It tests that when RSS is enabled, the miniport does not drop packets, indicates them in order, and (when appropriate) puts them on the correct processor. It also tests disabling RSS.

This test uses an indirection table which contains a number of processors equal to the greater of either the number of hardware queues the miniport supports or the number of processors on the system.

There are two main iterations in this test:

  • A single support adapter instance sending packets to the RSS miniport driver.

  • Multiple senders sending packets to the RSS miniport driver.

Both OID_GEN_RECEIVE_SCALE_PARAMETERS (RSS) and OID_GEN_RECEIVE_HASH (Hash only) are tested. RSS is tried first. If RSS is not supported, the test falls back to doing hash only. If RSS is supported, the test also attempts hash only. A failure will occur if the miniport driver does not support either hash or RSS and it reported capabilities.

Disabling and enabling RSS and hashing are tested three ways:

  • Setting the NDIS_RSS_PARAM_FLAG_DISABLE_RSS flag

  • Setting the standardized RSS registry key to disabled (0)

  • Setting the HashFunction to 0

When disabled by using a registry key, we expect no capabilities to be reported, sets to fail, and no RSS or hashing to be done.

The test sends different packet types:

  • IPv4 + TCP packets with no options

  • IPv4 packets with no options and no TCP header

  • IPv4 + TCP packets with fixed length IP options

  • IPv4 packets with fixed length IP options and no TCP header

  • Pv4 + TCP packets with variable length IP options

  • IPv4 packets with variable length IP options and no TCP header

  • First fragment of IPv4 + TCP packets with no options

  • Middle fragment of IPv4 + TCP packets with no options

  • Last fragment of IPv4 + TCP packets with no options

  • IPv4 + TCP packets changing ports and addresses

  • Raw NDISTest packets (no IP or TCP)

  • IPv6 + TCP packets with no options

  • IPv6 packets with no options & no TCP header

  • IPv6 + TCP packets with fixed length IP padding

  • IPv6 packets with fixed length IP padding and no TCP header

  • First fragment of IPv6 + TCP packets with no additional options

  • Middle fragment of IPv6 + TCP packets with no additional options

  • Last fragment of IPv6 + TCP packets with no additional options

  • IPv6 packets with route type 0 header and TCP header

  • IPv6 packets with a route type 2 header and TCP header

  • IPv6 packets with a route type 2 header and no TCP header

  • IPv6 packets with home address header and TCP header

  • IPv6 packets with home address header and no TCP header

  • IPv6 packets with home address and route type 2 header and TCP header

  • IPv6 packets with home address and a route type 2 header and no TCP header

Test details
Specifications
  • Device.Network.LAN.RSS.RSS
  • Device.Network.LAN.RSS.SetHashFunctionTypeAndValue
  • Device.Network.LAN.RSS.SupportIndirectionTablesSizes
  • Device.Network.LAN.RSS.SupportToeplitzHashFunction
  • Device.Network.LAN.RSS.SupportUpdatesToRSSInfo
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6RSSSendRecv.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Mini6SendRecv

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/42b91e42-4016-49b5-8f88-a387923a4571

This test is an NDIS 6.0-based miniport driver test that calls the miniport driver a number of times, sending a bunch of Net Buffers and Net Buffer Lists each time from the support card to the test card. It goes through a combination of send configuration parameters, varying the number of net buffer lists in each call to send, the number of net buffers in each net buffer lists, the number and size of data buffers in each net buffer. All the packets are expected to be received by the test adapter.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 35
Category | Development
Timeout (in minutes) | 2100
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6SendRecv.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Mini6SendRecvReply

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/18709c7a-dab6-46e1-8755-59c7dba923e4

This is bidirectional send receive test for NDIS 6.0 miniports sends packets from the test adapter to the support adapter, which the support adapter is expected to reply to. At the same time, it sends packets from the support adapter to the test adapter, which the test adapter is expected to reply to. This should result in continuous bidirectional traffic between the two adapters.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6SendRecvReply.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Mini6Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/20b75dc3-5eb2-4dea-b37f-3d8a25837981

This test validates the stress send and receive code paths of the NDIS 6.0 miniport drivers.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
  • Device.Network.LAN.Base.AnyBoundary
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Development
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Mini6Stress.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_OidsNdisRequest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1bc75de-65f3-4523-990a-4b015d6e279e

This test performs a series of NdisRequest calls to the driver to verify that it supports the querying of all required information OIDS. It will query OID_GEN_SUPPORTED_OIDS, verify that all required OIDs are present, and then query them.

The NDIS Test is not able to verify the values returned by most of these OIDs.

It also checks that the requests modify the fields of the NDIS_REQUEST structure correctly for both queries and sets: It verifies the byteswritten/bytesread field equal the bytes required by the OID, and checks that the buffer is not inappropriately modified.

You should check the log carefully for problems.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_OidsNdisRequest.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.0 - \2 Machine\ - 2c_Priority

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f53cf62-a767-4469-92e6-1bca087193fd

This test checks the miniport driver's ability to send 802.1p priority packets with the following variations:

  • Send mechanism with DIRECTED packets

  • SendPacket mechanism with DIRECTED packets

  • SendPacket mechanism with BROADCAST packets

  • SendPacket mechanism with MULTICAST packets (802.3)

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
  • Device.Network.LAN.Base.PriorityVLAN
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /logo /auto /server /support:[SupportDeviceGuid0] /msg:[ServerMessageDeviceGuid] | Runs the NDIS test server.
[WTTRunWorkingDir]\ndistest\bin\ndtest.exe /auto /client /dvi /u /target:Miniport /tc:[queryTestDeviceID] /support:[SupportDeviceGuid0] /msg:[ClientMessageDeviceGuid] /script:{2c_Priority.wsf} | Runs the NDIS test client.

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
sleep.vbs |


NDISTest 6.5 - \1 Machine\ - GenericMiniportRequirements

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d40e160-4e58-4256-97c5-523476e03ea4

This single machine test is designed to run on any generic miniport driver and validates the following requirements:

  • Miniport ifDesc does not contain invalid characters.

  • Minimum miniport NDIS version.

Test details
Specifications
  • Device.Network.DevFund.NdisVersion
  • Device.Network.DevFund.NdisVersionLegacy
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - IPSecOids

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e38588ad-0043-4f7d-9685-bdcb011ea138

This test verifies the OID handling of IPSec V2 offload miniport drivers.

Test details
Specifications
  • Device.Network.LAN.IPsec.IPsec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - IPSecStdKey

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7c4c8234-5ec0-4176-a36a-3e2d6fc9112c

This test validates that OID_TCP_TASK_OFFLOAD_PARAMETERS requests changing the IPsec configuration are handled correctly by the miniport driver and NDIS_STATUS_TASK_OFFLOAD_CURRENT_CONFIG indications are generated as expected.

Test details
Specifications
  • Device.Network.LAN.IPsec.IPsec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - OffloadParity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dea0e10a-260e-4e7b-8885-c9a0e2f41338

This test is automated.

Test details
Specifications
  • Device.Network.LAN.Base.IPv4AndIPv6OffloadParity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - OffloadRSSv2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/992ba8e2-18d5-4a72-a4e1-8e506b3fcc09

RSSv2 related Oids

Test details
Specifications
  • Device.Network.LAN.VMMQ.RSSv2
  • Device.Network.LAN.VMMQ.RSSv2.RSSv2
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
queryTestDeviceID |
TestScript |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Network additional documentation


NDISTest 6.5 - \1 Machine\ - OffloadRsc

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e44273b-58c1-42c6-a1c7-9cd4871620bf

This test issues RSC OIDs on test adapters.

Test details
Specifications
  • Device.Network.LAN.RSC.RSC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - OffloadVMMQ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0485cf9a-9a4a-428e-be26-1572e2e6aa80

VMMQ related Oids

Test details
Specifications
  • Device.Network.LAN.VMMQ.VirtualMachineMultiQueues
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript |


NDISTest 6.5 - \1 Machine\ - PM_Requirements

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/56ad0e7f-5e0b-4bd6-95bf-d74f0f95017e

This test determines if the test device meets the power management certification criteria and will validate what is indicated in NDIS_PM_CAPABILITIES.

Test details
Specifications
  • Device.Network.LAN.PM.PowMgmtNDIS
  • Device.Network.DevFund.SelectiveSuspend
  • Device.Network.DevFund.NPOS
  • Device.Network.LAN.CS.NetworkWake
  • Device.Network.LAN.CS.PresenceOffload
  • Device.Network.LAN.CS.WakeEvents
  • Device.Network.LAN.CS.WakeReasonDetection
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - QosCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c6f5d18e-57e5-4776-baa5-4fb67aed3ee3

This test is automated.

NOTE

Adapter Configuration: DUT - QoS capable adapter

Test Cases:

  • Capability Test

    • Ensure that QoS keyword is advertised and OID_QOS_HARDWARE_CAPABILITIES returns valid values.

  • Keyword (Disable-Enable) Test

    • QoS is enabled when the QoS keyword is enabled.

    • QoS is disabled when the QoS keyword is disabled.

    • QoS is disabled when the QoS keyword is set to an invalid enum value.

    • QoS is disabled when the QoS keyword is missing.

  • Checks enforced (in each of the following cases, assume QoS capable adapter):

    • NUM_TRAFFIC_CLASSES_MIN_VALUE = 3 through 8

      • No error is flagged if this value is greater than 8

    • NUM_ETS_CAPABLE_TRAFFIC_CLASSES = 2 or more, no higher bound check

    • NUM_PFC_ENABLED_TRAFFIC_CLASSES = 1 or more, no higher bound check

    • If *QOS keyword is absent, QoS is assumed as disabled.

    • If *QOS keyword has invalid setting value, QoS is assumed as disabled.

    • When QoS is disabled, miniport driver must -

      • Return NDIS_STATUS_SUCCESS for OID_QOS_HARDWARE_CAPABILITIES and valid capability data in NDIS_QOS_CAPABILITIES structure

      • Return NDIS_STATUS_SUCCESS for OID_QOS_CURRENT_CAPABILITIES and ZEROED data in NDIS_QOS_CAPABILITIES structure

    • NDIS_QOS_CAPABILITIES_STRICT_TSA_SUPPORTED is advertised

    • Only known capability flags are advertised

      • NDIS_QOS_CAPABILITIES_STRICT_TSA_SUPPORTED

      • NDIS_QOS_CAPABILITIES_MACSEC_BYPASS_SUPPORTED

      • NDIS_QOS_CAPABILITIES_CEE_DCBX_SUPPORTED

      • NDIS_QOS_CAPABILITIES_IEEE_DCBX_SUPPORTED

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - QosOids

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1f6cc3e-2000-45e8-8bda-44c533adc644

This test validates that OID_QOS_PARAMETERS is handled properly. If the device does not support QoS, the tests cases are skipped.

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - SRIOVBasicVerification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/616e3e15-2635-4810-b4bf-ec90eeb00a4f

This test does the basic verification of the SRI-OV functionality on the miniport adapter in the presence of vSwitch. This is a single machine job and it needs additional configuration for execution.

  • The machine used for testing should have the Hyper-V server role installed. Also, make sure that you select and install the Hyper-V Module PowerShell management tools during installation.

  • Make sure you that copy a Windows 8 VHD (that you want to use for creating the VM) to the local folder (for example: C:\VHDs) on the machine under test.

Now, you're ready to run the SRIOVBasicVerification test.

When you select the job and click 'Run Selected', you will get a pop-up like the image shown below for entering additional parameters:

The values that the job expects are as follows:

  • VMName - You can give any name for the virtual machine. Please make sure that a virtual machine with the same name does not exist on the test machine already.

  • VHDName - Enter the name of the VHD that you copied to the test machine earlier. For example: Mastervhd.vhd. This vhd will not be deleted from the test machine.

  • VHDPath - Enter the path to the VHD location on the test machine (not on the controller). For example: C:\VHDs.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 2
    Category | Development
    Timeout (in minutes) | 120
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation
    • System.Server additional documentation

    Running the test

    Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    For troubleshooting information, see Troubleshooting LAN Testing.

    More information

    Parameters

    Parameter name | Parameter description
FindSupportAdapter.vbs |
VMQServerConfig.xml |
VMQClientConfig.xml |
LaunchNDISTestInGuest.cmd |
VMP_HWID |
VMP_INF |
LOG_FILE |
VMP_PATH |
INSTALL_VMP.VBS |
queryTestDeviceID |
VMName | The name of the test VM. Please make sure that a VM with the same name doesn't already exist on the test machine.
VHDName | The name of the VHD that was copied onto the test machine earlier. For Example: Mastervhd.vhd. This vhd will not be deleted after the test has finished.
VHDPath | The path to the VHD location on the test machine (not on the controller). For example: C:\VHDs.
VmMemAlloc |
VmProcCount |
SRIOVBasicJob |
Test_Card_Identifier_Type |
Card_Select_Match_Test.ps1 |
PSWttLogger.ps1 |
SRIOVBasicClientConfig.xml |


NDISTest 6.5 - \1 Machine\ - SRIOVTestingVF

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a02123b6-aeda-4695-86c4-9b37674f37fa

This is an automated test.

Test details
Specifications
  • Device.Network.LAN.SRIOV.VF.VF
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - SRIOVVMSwitchStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4de5a018-4367-46f0-9a60-42d242640592

This test stresses the SRIOV capable miniport adapter in the presence of a vSwitch with VFs assigned. This is a single machine job and it needs additional configuration for execution. Please follow the same instructions as specified for the NDISTest 6.5 - 1 Machine - SRIOVBasicVerification test.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 2
    Category | Development
    Timeout (in minutes) | 120
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Server additional documentation
    • Device.Network additional documentation

    Running the test

    Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    For troubleshooting information, see Troubleshooting LAN Testing.

    More information

    Parameters

    Parameter name | Parameter description
FindSupportAdapter.vbs |
VMQServerConfig.xml |
VMQClientConfig.xml |
LaunchNDISTestInGuest.cmd |
VMP_HWID |
VMP_INF |
LOG_FILE |
VMP_PATH |
INSTALL_VMP.VBS |
queryTestDeviceID |
VMName | The name of the test VM. Please make sure that a VM with the same name doesn't already exist on the test machine.
VHDName | The name of the VHD that was copied onto the test machine earlier. For Example: Mastervhd.vhd. This vhd will not be deleted after the test has finished.
VHDPath | The path to the VHD location on the test machine (not on the controller). For example: C:\VHDs.
VmMemAlloc |
VmProcCount |
JobsToRun |
Test_Card_Identifier_Type |
Card_Select_Match_Test.ps1 |
PSWttLogger.ps1 |


NDISTest 6.5 - \1 Machine\ - StandardizedKeywords

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27452a2a-54f9-4e4a-95d8-735b745e843a

This test goes through each standardized keyword supported by NDIS and verifies that capabilities reported by NDIS via OID or other interfaces are consistent with the current value of the keyword. If the miniport does not support a given keyword, the test will verify that adding the keyword does not adversely affect miniport behavior. If the miniport does support a keyword, NDIS will iterate through possible values of the keyword. If any unsupported keywords are found, a failure will be logged.

Test details
Specifications
  • Device.Network.LAN.Base.AdvProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \1 Machine\ - VMQTestingOIDs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40a142cc-b013-4cf5-99b6-6b72b97e13a3

This test validates the VMQ functionality of the miniport adapter. VMQ functionality is optional so the test will successfully exit if the miniport adapter does not support VMQ.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - AddressChange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d423a0dd-926e-491c-a437-0d7bc8ead98c

This test verifies the ability of NDIS and the driver to override the adapter's current MAC address by writing a new address (both valid and invalid addresses into the driver's registry with registry value NetworkAddress. The driver should receive the new address when it calls NdisReadNetworkAddress during initialization. The following is the sequence of events:

  1. Read current NetworkAddress parameter in registry so it can be restored at the end.

  2. Query the card to find its current and permanent Ethernet address.

  3. Stop the driver.

  4. Write the new Ethernet address into registry.

  5. Start the driver.

  6. Query the card to find its current registry setting and compare to expected setting.

  7. Query the card to find its permanent address and make sure it hasn't changed.

  8. Have the server send 250 packets to the new current address.

  9. Have the server send 250 packets to the original current address (expecting 0 packets received).

  10. Repeat steps 3-9 for each new address to be tested (valid and invalid ones).

  11. Stop the driver.

  12. Put the original NetworkAddress into the registry.

  13. Start the driver.

  14. Query the card to find its current and permanent Ethernet address and make sure they are the same as at the start.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - CheckConnectivity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/74c8d652-9dd3-4fdc-88dc-fc41a6016d72

This test performs a send and receive stress test between test and support adapters. It randomly determines the send IRQL, the number of packets in each packet list, packet size, and so on. It then flips the sending and receiving adapters so the test becomes bi-directional.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - CheckConnectivity with AutoFail

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/02664553-8a1f-4fc4-9a62-ad0510f4e23b

This test performs a send and receive stress test between test and support adapters. It randomly determines the send IRQL, the number of packets in each packet list, packet size, and so on. It then flips the sending and receiving adapters so the test becomes bi-directional.

The test enables fault injection feature called AutoFail through a Driver Verifier setting on the miniport driver, while sending the packets on the test adapter.

AutoFail is feature that deterministically injects faults by failing dependent APIs without violating the contract and without modifying the product component or test collateral.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
DriverVerifierAdditionalFlags |


NDISTest 6.5 - \2 Machine\ - ConfigCheck

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6118ee6c-a9c6-420a-a941-50c0255ba009

This test validates the system configuration according to the following criteria:

  • The system cannot be certified on product type server or product suite personal.

  • Desktop computer must have multiple processors.

  • The NDIS.sys file should be from a retail (fre) build.

  • Test, local, and remote adapters should be selected and they should be of the same type.

  • For Datacenter and Enterprise editions:

    • The computer should have at least 6 GB of RAM.

    • The computer should have at least 4 processors.

    • The adapter should use scatter gather for DMA.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
  • Device.Network.LAN.Base.100MbOrGreater
  • Device.Network.LAN.Base.SupportIEEEE8023
  • Device.Network.LAN.Base.PreserveOSServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - DynamicVMQBasicVerification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68515204-1432-4013-bc7c-c5b9bbe7277a

This test is a variation of the VMQBasicVerification test. It validates that the miniport driver reports Dynamic VMQ Capabilities and behaves as expected.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - E2EPerf

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d177b1d0-9ac2-4315-b493-74b14f318326

This test measures the performance of the test adapter by sending and receiving networking traffic using Windows sockets. The following statistics are measured:

  • Link Utilization Percentage

  • Interrupts per second

  • Packets per interrupt

  • Total Receives Coalesced (if RSC is supported)

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - GlitchFreeDevice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f31ff1a-7d98-472b-aef8-e99b4cb4d706

This test enables Glitch Free mode with various indices. Performs a send and receive pass for each index, and then analyzes the ETW logs to ensure that the number of packets indicated during a DPC is under the maximum limit specified by the index.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - InterruptModeration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73ae6a8b-952a-48de-95e3-8282396ba25e

This test checks whether OID_GEN_INTERRUPT_MODERATION is supported.

Interrupt Moderation reduces the number of interrupts generated by miniport drivers using the OID OID_GEN_INTERRUPT_MODERATION. This feature is also useful for Quality of Service. When this OID is enabled, interrupts are generated only after packets greater than a threshold level has arrived or a time interval has passed and when turned off interrupts are generated for each packet received. The threshold and the time interval are specific to the manufacturer. You can also verify that the interrupts generated by the miniport driver have decreased when the OID_GEN_INTERRUPT_MODERATION feature is enabled.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - InvalidPackets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab5325f7-22dd-4fc2-92b7-dfe37ccb38e1

This test generates invalid packets of various types.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 25
Category | Development
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - IOVVMQBasicVerification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8541d497-210d-415f-9b56-cdf201e304d3

This test does the basic verification of VmqBasicVerification using the SR-IOV interfaces. This is a two machine test and is like any normal LAN certification test which requires Support and Message adapter renaming. It does not require any other additional configuration.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation
  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - IPSecAH

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb9405ec-de95-44b9-a609-e99c26d619ca

This test verifies the operation of miniports that do IPsec v2 task offload. This test suite contains tests that target the offloaded operation of IPsec Authentication Header. It verifies that network adapter correctly perform offloaded authentication tasks on IPv4/IPv6 AH frames. It currently tests AUTH-SHA-1-96 and AUTH-AES-GMAC (128/192/256) with "simple sends".

Test details
Specifications
  • Device.Network.LAN.IPsec.IPsec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - IPSecAhEsp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5d8834d-a691-43ea-a2af-0dcb54fe1a6a

This test verifies the operation of miniport drivers that support IPsec v2 task offload. This test offloads a variety of AH and ESP SAs and verifies that the network adapter is able to process traffic on all those offloaded SAs. It also validates that processing of packets on offloaded SAs works across PnP events, such as MiniportReset and Standby.

Test details
Specifications
  • Device.Network.LAN.IPsec.IPsec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - IPSecESP

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a535f88-ecbd-4035-ba1b-a4a28675b744

This test verifies the operation of miniport drivers that support IPSec v2 task offload. This test script contains tests that target the offloaded operation of IPSec ESP. It verifies that network adapters correctly perform offloaded confidentiality and authentication tasks on IPv4/IPv6 ESP frames. It currently tests AES-GCM-ESP (128/192/256), ESP-NULL-AUTH-SHA-1-96 and, ESP-NULL-AUTH-AES-GMAC (128/192/256) with "simple sends".

Test details
Specifications
  • Device.Network.LAN.IPsec.IPsec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - KeepAlive

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25dbe3e2-0927-46f7-a34f-f37b3583e4c6

This test validates the network adapter's ability to offload various protocols when the machine is put in the low power state.

Low Power Protocol Offloads:

  • ARP (IPv4)

  • NS (IPv6)

Test Cases:

  • Protocol Offload Test - Enable Protocol offload for protocols specified by m_TestProtocols and test for a successful offload.

  • Interception Test - Test offload protocols are bypassed by the Test device firmware after the machine resumes following a successful protocol offload.

  • Invalid Packet Test - Verify that no response on invalid packets is received from the test adapter with offload enabled.

  • Traffic Test -Verify no response for packets sent to other hosts on same subnet is sent by Test adapter with offload enabled.

  • Enable Disable Test -Verify no response for packets sent for following configurations -

    • Enable Protocol offload with OID_PM_PARAMETERS but do not program any protocol for offload and test for a failed offload.

    • Disable Protocol offload but program protocol offloads with OID_PM_ADD_PROTOCOL_OFFLOAD and test for a failed offload.

    • Disable Protocol offload and do not program protocols for offload.

Cases Not Tested:

  • Ability of Test device to respond to requests after network connectivity is lost and resumed when machine is in sleep state.

These protocols are not tested and not required to be supported by the Test device:

  • ARP (IPv6)

  • NS (IPv4)

Test details
Specifications
  • Device.Network.LAN.PM.PowMgmtNDIS
  • Device.Network.LAN.CS.PresenceOffload
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 35
Category | Development
Timeout (in minutes) | 2100
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - LinkCheck

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c0ca2bd-aeac-40b7-ba40-c3170ef7c416

This test verifies whether the connect/disconnect events are received from WMI as well as from the protocol driver. It verifies that the initialization time for a network card is not too long. For initialization time, it will stop and start the driver with the link disconnected and then with the link connected. It verifies the connect is detected properly with long (>30 seconds) disconnects and that communication with the server is restored. In all, there are three tests. Pass 0 : short disconnect event Pass 1 : long disconnect event (>30 seconds) Pass 2 : disconnect-unload-load-connect This script can be run with or without a switch. If the test and support devices connect to a switch then the user has to select the switch before running this script. Switch can be selected from the Tools->Option->ManagedSwitch tab. If no switches are selected then the user is prompted to manually connect and disconnect the link for the test device.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - MPE_Ethernet.xml

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a264ad8-2163-4d7c-be31-3913dcdee747

This test stress tests simultaneous handling of OIDs, Send/Receive, PNP and Power Management events.

After running the stress test, this test will check whether the device is in normal state after running the stress.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Development
Timeout (in minutes) | 18000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - MultiCast Address

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f958d686-90ac-47f8-8cac-032f7de53311

This is an automated test.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
  • Device.Network.LAN.Base.32MulticastAddresses
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - OffloadChecksum

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c4cd566-85ea-4f70-986b-eabe0258cda0

This test is an automated test.

Test details
Specifications
  • Device.Network.LAN.GRE.GREPacketTaskOffloads
  • Device.Network.LAN.ChecksumOffload.ChecksumOffload
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

IMPORTANT

For devices running Windows 7, the values of IPChecksumOffloadIPv4 will change.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - OffloadLSO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50a7603a-a84f-45eb-b00d-7c4bb3845647

This test validates LSOv1 and LSOv2 capabilities of the miniport driver. The test cases include LSOv2 over ipv4, LSOv2 over ipv6, LSOv1 over Ipv4, LSOv2 mixed with Ipv4 checksum offload, and LSOv1 mixed with Ipv4 checksum. For each test case variation, the combination of TCP option, IP option, MSS, and segment number is enumerated. TCP flags and urgent pointer are generated randomly during the test. User is allowed to use Hot parameters to select interesting test cases.

Test details
Specifications
  • Device.Network.LAN.GRE.GREPacketTaskOffloads
  • Device.Network.LAN.LargeSendOffload.LargeSendOffload
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

IMPORTANT

For devices running Windows 7, the values of IPChecksumOffloadIPv4 will change.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - OffloadMisc

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1f29b7b-7b6c-48b4-ace2-1e0ebfbcd040

TODO: description

Test details
Specifications
  • Device.Network.LAN.GRE.GREPacketTaskOffloads
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - PacketFilters

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5cbe48a-6484-41ce-b8bf-e9e441968c30

This test validates the filters on the test device. All the possible combinations of filters are tested for different addressing schemes. Only one protocol (NDISTest) is bound on the adapter to ensure NDIS does not perform any filtering. The script identifies the different filters supported by the adapter dynamically.

Test details
Specifications
  • Device.Network.LAN.Base.PacketFiltering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - PM_PowerStateTransition

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9cc702b1-5b51-47ea-a991-53766d8d75b0

This test verifies that the miniport driver behaves properly when the PC comes out of a power management scheme. All the possible combinations of the power management schemes are tested. If AutoWake is not supported by the operating system, all the combinations are not tested. In that case only one power management scheme (Deepest Standby) is tested. Hardware vendors should verify that their adapters on machines support autowake and at least S1, S3, and S4 sleep states. If your machine takes a significantly long time to standby or hibernate, increase the timer (hot parameter Amount of Time to Sleep) appropriately.

Test details
Specifications
  • Device.Network.LAN.PM.PowMgmtNDIS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - PM_WakeOnLinkChange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3101ee19-94f5-4e80-8838-02a1beef1484

This test verifies that a device that advertises support for D3 on Disconnect (also known as Wake On Link Change) can assert #PME line on PCI bus and respond to requests from the operating system to go to a low power state.

Test details
Specifications
  • Device.Network.LAN.PM.PowMgmtNDIS
  • Device.Network.LAN.CS.WakeEvents
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 25
Category | Development
Timeout (in minutes) | 1500
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - PM_WolMagicPacket

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/570d879a-87ce-496f-a98a-9e2c5f60d9f4

This test targets Wake on Magic Packet capabilities of NDIS 6.20 and later adapters. It uses the WoL_TestHelper framework for easily testing each packet variation. The Magic Packet variations tested are enumerated in MagicPacketType.

Test details
Specifications
  • Device.Network.LAN.PM.WakePacket
  • Device.Network.LAN.CS.NetworkWake
  • Device.Network.LAN.CS.WakeReasonDetection
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - PM_WolPattern

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/191a99d8-be82-403c-a45b-00cf16c0d9a4

This test targets Wake on Pattern capabilities of NDIS 6.20 and later adapters. It uses the WoL_TestBase framework for easily testing each packet variation. The pattern variations tested are enumerated in WakePatternType. Additionally, this test will run a capacity test to add max capacity patterns to the miniport and test the first and last.

Test details
Specifications
  • Device.Network.LAN.PM.WakeOnLANPatterns
  • Device.Network.LAN.CS.NetworkWake
  • Device.Network.LAN.CS.WakeReasonDetection
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - QosEts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c3ecb5b-35fa-4379-97a7-788aa6fcea1b

This automated test validates that the network adapter's implementation of ETS and Strict Priority Traffic Classes is in accordance with IEEE 802.1Qaz as of August 4, 2010. The test is divided into groups shown below. Each group is tested with and without strict priority traffic present. Traffic is generated via TCP socket connections and results are captured on the receive path of the support adapter. The captured results are then processed and analyzed to determine total link utilization and the utilization of each traffic classes. Test Groups Single ETS Traffic class Minimum Required ETS traffic classes Maximum supported ETS traffic classes. ETS underutilization. Verifies that when an ETS traffic classes use less than its allocated bandwidth other traffic classes can use more than their allocation.

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - QosPnpPower

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae51d5a5-4c63-4374-b4fa-95c79726d748

This test validates a network adapter's ability to persist QoS settings across a power state transition or NDIS reset. A QoS configuration is set on the network adapter and then a power state transition or NDIS reset is performed. Traffic is then sent to verify that the QoS configuration is still being applied.

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - QosPriorityFlowControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad118a4d-3d03-4f08-a6d0-d6a11d89dae1

This test validates PFC in accordance with IEEE specification and the disparity between CEE and IEEE PFC configuration specification may result in test failures if this requirement is not met.

Adapter Configuration: DUT - QOS capable adapter SUT - Network adapter capable of working at DUT's line rate.

Test Cases:

  • CheckConnectivity: Ensures that the m_Dut and m_Sut can send and receive traffic respectively and the bandwidth monitor is able to see the traffic received at m_Sut PFC Control Frame is sent with.

  • PriorityEnableVector: Set to zero

  • Time[all elements] -: Set to zero

  • TestPfc: Ensures that m_Dut Responds to PFC Frames by Pausing Traffic Fabricate PFC MAC Control Frame with - - Correct Bit Set on Priority Enable Vector - Max quanta value in Time Vector

  • TestPfcDisabled: Ensures that m_Dut does Not Respond to PFC Frames when PFC is Disabled Fabricate PFC MAC Control Frame with - - Correct Bit Set on Priority Enable Vector - Max quanta value in Time Vector

  • TestPfcPriorityEnableVectorBitsReset: Ensures that m_Dut does Not Pause Traffic for PFC Frames with All Priority Enable Vector Bits Reset Fabricate PFC MAC Control Frame with - - All Priority Enable Vector Bits Reset - Max quanta value in Time Vector for Correct Priorities

  • TestPfcTimeVectorZeroQuanta: Ensures that m_Dut does Not Respond to PFC Frames All Time vector entries Set to Zero Quanta Fabricate PFC MAC Control Frame with - - Correct Priority Enable Vector Bits Set - All Zero quanta values in all Time Vector entries

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

If the device under test follows CEE specific DCBX PFC configuration, ensure that DCBX is turned off on the system under test before running this test or replace the system under test with a non-DCB capable adapter.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - QosRemoteSettings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9db124a9-0375-4c07-94d8-3b38239ec85c

This test ensures that m_Dut can parse IEEE DCBX packets sent by m_Sut and correctly indicate these new settings via NDIS_STATUS_QOS_REMOTE_PARAMETERS_CHANGE. TestConflict: Ensures that m_Dut resolves the conflict when both local and remote flow control and classification settings are available. TestNoRemoteSettings: Ensures that m_Dut only takes into account the local settings when there are no remote settings available.

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

This test must only be run on a Windows Server edition adapter configuration. The DUT mused have a QoS-capable network adapter. The network adapter in the SUT must allow IEEE 802.1AB LLDP packets sent from the operating system to pass through.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - QosSpeedCheck

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4933114e-2ddf-41aa-a9ce-fa937f4948b3

This test utilizes the traffic generator and bandwidth monitoring modules, performs a TCP layer connectivity test, and then verifies that the test and support machines can saturate the link.

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - QosStorageInterop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad37b1d9-db2f-42c3-8516-99e67be7a1a0

The DUT must have a QoS-capable CNA adapter and the willing-bit should be turned off. The SUT must have a network adapter capable of working at DUT's line rate. A ISCSI drive should be configured to work over the CNA over either ISCSI connection offered by the CAN or an SMB share should be configured and mounted on drive for testing a NetworkDirect-capable network adapter. No more than one SMB share should be configured on the test machine to ensure no false failures. Test cases are as follows:

  • Network Traffic ETS Enforcement ensures that CNA does not throttle any network traffic flow when the network traffic class is configured at the traffic rate observed when ETS is disabled.

  • Storage Traffic ETS Enforcement ensures that CNA does not throttle any storage traffic flow when the storage traffic class is configured at the traffic rate observed when ETS is disabled.

  • 1:1 Network:Storage -- Traffic Distribution of oversubscribed bandwidth ensures that CNA is able to evenly distribute network and storage traffic overload.

  • 2:1 Network:Storage -- Traffic Distribution of oversubscribed bandwidth ensures that CNA is able to prioritize network traffic over storage traffic at a ratio of 2:1.

Test details
Specifications
  • Device.Network.LAN.DCB.DCB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run
ParamStorageDrive | Single Character Drive-letter [mandatory parameter]
ParamStorageConnectionMode | Storage-connection mode, supported modes are 'ISCSI' and 'ND' [mandatory parameter]
ParamNetworkTrafficGeneratorThreads | Number of traffic-streams (threads) created by Network traffic generator [optional parameter]


NDISTest 6.5 - \2 Machine\ - Reset

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0c4e1da-1d59-4a92-8d37-9ad9f33de1ac

This test attempts to reset the card multiple times, while at the same time sending and receiving lots of packets over that card. It tests to make sure that that card can reset itself and that it deals properly with packets that have been given to it to send when interrupted by a reset. Device is reset multiple times with a configurable time delay between resets.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SelectiveSuspend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07a415cb-bd13-4340-88cf-66bee946ded9

This automated test verifies that keywords and support are indicated correctly. Verifies that the miniport driver will enter suspend correctly and does a check connectivity test.

Test details
Specifications
  • Device.Network.LAN.PM.PowMgmtNDIS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - ShortPackets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e2415f1-f5b3-4be7-98d0-0f942a04d000

This is an automated test.

Test details
Specifications
  • Device.Network.LAN.Base.ShortPacketPadding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SingleEtherType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2f1e29c-c193-4780-92a9-eb58fadd06d3

This test checks for proper usage of NDIS_RECEIVE_FLAGS_SINGLE_ETHER_TYPE by verifying all NBLs in an NBL list indicated to our protocol have the same EtherType.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SRIOVTestingDevice

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc810836-6836-478d-999c-c7771682911f

This test toggles the VMQ & SRIOV registry key entries on the miniport adapter and validates whether the miniport adapter's data path behaves as expected. This is a 2-machine test and is like any normal LAN certification test which requires Support and Message adapter renaming. It does not require any other additional configuration.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation
  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SRIOVTestingFailover

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db3ee80d-faa4-4966-a054-c75e6f8e3067

This test validates the failover capabilities of the miniport adapter while simultaneously sending data. This is a 2-machine test and is like any normal LAN certification test which requires Support and Message adapter renaming. It does not require any additional configuration.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation
  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SRIOVTestingOIDs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da9ba88d-8b20-4eca-bf44-f37ed7078702

This test validates the all the SRIOV related OIDs on the miniport adapter. This is a 2-machine test and is like any normal LAN certification test which requires Support and Message adapter renaming. It does not require any other additional configuration.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation
  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SRIOVTestingPFRemoval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e96f98b-efeb-480f-9a4e-33dfd1dad187

This test validates the Validate the PF removal of the miniport adapter. This is a 2-machine test and is like any normal LAN Logo test which requires Support and Message adapter renaming. It does not require any other additional configuration.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 600
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Server additional documentation
    • Device.Network additional documentation

    Running the test

    Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    For troubleshooting information, see Troubleshooting LAN Testing.

    More information

    Parameters

    Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - SRIOVTestingRegistry

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/02f34b1c-bbc4-4aac-b929-6adab9f753f8

This test validates the SRIOV registry settings of the miniport adapter. This is a 2-machine test and is like any normal LAN certification test which requires Support and Message adapter renaming. It does not require any other additional configuration.

Test details
Specifications
  • Device.Network.LAN.SRIOV.SRIOV
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation
  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - Stats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9fd80de7-eaf5-4ca6-bc4e-877eb0ea3e08

For NDIS 6.0 miniports, this test verifies that miniport maintains and report statistics from OID_GEN_STATISTICS correctly. The test also verifies that the miniport correctly supports statistics OIDs OID_GEN_RCV_OK OID_GEN_RCV_NO_BUFFER OID_GEN_RCV_ERROR. It sends a bunch of packets to the test adapter and checks that the statistics get incremented. It expects the OID_GEN_RCV_NO_BUFFER to incremented exactly by the number of packets that were dropped.

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - TxFlowControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/537d2ef3-7690-48dd-8d31-60942e60495f

This test performs a simple send and receive from the test to the support adapter and checks the following:

  • The test adapter will not receive any PAUSE frame.

  • The test adapter will receive a PAUSE frame with maximum quanta (0xFFFF). We expect the sending be paused by the period expected (for example, 1G 33.5ms)

  • The test adapter will receive a PAUSE frame with maximum quanta (0xFFFF) followed by another PAUSE frame with minimum quanta (0x0000). We expect the sending will not be paused. It is because the second PAUSE frame should resume the paused test adapter. From the first to third, we use the unicast MAC address as the destination address in the PAUSE frame.

  • We will use multicast MAC address (01-80-C2-00-00-01) as the destination address in the PAUSE frame. Then send this PAUSE frame to the test machine. We expect the sending be paused by the period expected (for example, 1G 33.5ms).

Test details
Specifications
  • Device.Network.LAN.Base.NDISRequirements
  • Device.Network.LAN.Base.SupportIEEEE8023
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VlanSendRecv

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7bcd765-0aca-479a-9182-3c29fa0753a9

This test ensures that virtual LAN communication works properly with and without allocated virtual machine queues.

Test details
Specifications
  • Device.Network.LAN.Base.PriorityVLAN
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQBasicVerification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a92c5df-1062-4523-880e-ace372c8583b

This test performs a single network adapter basic verification.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQCheckConnectivity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd02f917-a8fe-4319-992a-89a16e11ed24

This test performs a simple send and receive between test and support adapters. If the miniport adapter does not support VMQ, the test will fail, and the rest of the VMQ test cases will not be performed.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQPnpTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee48c38d-06a5-4ecc-9801-0dd106932ade

This test performs a simple send and receive between test and support adapters and resets the device while running the test.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQPowerManagement

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de62a779-427b-4bb8-b2a5-deb2d3fe8c03

This test uses the PowerManager class to query the supported sleep states that the machine supports. The test then creates a queue on the VMQ-capable adapter, sets a filter on the queue, brings the machine to standby/ hibernation state, wakes up the machine (either automatic or manual), and then runs a send/receive test to check if the queue /filter setting is properly preserved during the sleep-wake up cycle.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQReceiveQueueStateChecking

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1e56ddca-3858-4032-ad6d-ca5ad58cf240

This test validates that the shared memory will not be changed after a DmaStopped indication while a queue is removed from the miniport adapter.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQScalability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/591d89df-6091-424c-849e-f713aed0c763

This test receives queue state and ensures that the shared memory will not be changed after a DmaStopped indication while the queue is removed.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDISTest 6.5 - \2 Machine\ - VMQStressTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d10f80e9-3db7-45ca-b3cf-3bf45827188d

This test stresses VMQ functionality of the miniport adapter. VMQ functionality is optional so the test will successfully exit if the miniport adapter does not support VMQ. A VMQ-capable miniport should be chosen as the test adapter and the support adapter needs to have connectivity to the test adapter.

Test details
Specifications
  • Device.Network.LAN.VMQ.VirtualMachineQueues
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Parameters

Parameter name | Parameter description
queryTestDeviceID |
SupportDeviceGuid0 |
ClientMessageDeviceGuid |
ServerMessageDeviceGuid |
TestScript | comma separated list of test jobs to run


NDK Logo Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13b5a849-b087-492a-9a2a-c9d7cbadbbde

This test verifies NDK (KRDMA) functionality on Ethernet devices.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
  • Device.Network.LAN.SRIOV.VF.NDKMode3.NDKMode3
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Development
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Network Testing.

More information

Parameter | Description
TestDirectory | The location of the test directory. Example: [SystemDrive]\iketest

Command syntax

Command | Description
NdkLogoTests.exe -localIpv4Address [LocalTestIpv4Address] -remoteIpv4Address [RemoteSupportIpv4Address] -localIpv6Address [LocalTestIpv6Address] -remoteIpv6Address [RemoteSupportIpv6Address] -localSupportIpAddress [LocalMessageIpAddress] -remoteSupportIpAddress [RemoteMessageIpAddress] -loggingLevel [LoggingLevel] -wttlog -test \ -priority 1 -run | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
ndkLogoTests.exe | <[testbinroot]>\nttest\nettest\transports\netiotest</p>
ndktestclient.sys | <[testbinroot]>\nttest\nettest\transports\netiotest</p>
ntlog.dll | <[testbinroot]>\nttest\commontest</p>
ndktestclient.sys | <[testbinroot]>\nttest\nettest\transports\netiotest</p>
ndkLogoRemoteServer.exe | <[testbinroot]>\nttest\nettest\transports\rdma</p>

Parameters

Parameter name | Parameter description
queryTestDeviceID |
RemoteSupportIpv4Address |
RemoteSupportIpv6Address |
LocalMessagetIpAddress |
RemoteMessageIpAddress |
LogFileName |
LocalTestIpv4Address |
LocalTestIpv6Address |
RemoteMessageIpv6Address |
LoggingLevel |
queryTestInstanceID |
TestvSwitchName |
TestvNicName |
IsHostvNic |
VerifyHypervInstalled.ps1 |


PrivateCloudSimulator - Device.Network.LAN.10GbOrGreater

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bcada95-9836-4c64-bcb7-298ab27382cb

This job executes Device.Network.LAN.10GbOrGreater profile which has compute actions on hyperconverged solutions Number of VMs Created = 10 per compute node Size: 80% ~2GB and 20% ~4GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction ComputeNodeRestartAction --------------------------------------------- Parameters -------------------------------------------- StorageCluster If you are running in disaggregated configuration, then you must pass in StorageCluster value StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • Device.Network.LAN.10GbOrGreater.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
IsCreateCluster | Enter $True to create a new cluster before running PCS
IsRemoveCluster | Enter $True to remove cluster after running PCS
IsConfigureHyperV | Enter $True to validate Hyper-V feature is installed, and create a virtual switch on all 10Gbps or faster NICs. This parameter is ignored when IsCreateCluster is $false


PrivateCloudSimulator - Device.Network.LAN.AzureStack

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc85c86e-2a90-42cb-a8a8-c272ce96950e

This job executes Device.Network.Lan.AzureStack profile which has network actions on hyperconverged solutions Number of VMs Created = 10 per compute node Size: 80% ~2GB and 20% ~4GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction ComputeNodeRestartAction --------------------------------------------- Parameters -------------------------------------------- StorageCluster If you are running in disaggregated configuration, then you must pass in StorageCluster value StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • Device.Network.LAN.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
StorageTestBinRoot |
InstallStorageShim |
IsNonWindowsSofsShare | Enter $true if the storage is a non-Windows SOFS share
IncludeSdnActions | Include SDN actionis
AdapterNames | Comma seperated adapter names used for SDN
VLan | The VLan ID that needs to be set on VMSwitch
AddressPrefixes | The addresses used by VMs and Hosts (Management IP addresses)
ClientAddressPrefix | The IP addresses for client VMs
NetworkControllerNodeCount | The number of Network Controllers
NetworkControllerMemoryInMB | Memory size for Network Controller VMs
MuxCount | The number of SLB VMs
RDIDCount | Number of routing domains (Tenant application count)
VSIDPerRDIDCount | Number of virtual subnet IDs per routing domains (Tenant application tier count)
VipsPerVSIDCount | Number of virtual IPs per virtual subnet
DipsPerVipCount | Number of VMs with datacenter IPs per virtual IP
NicsPerDip | Number of NICs per Dip
RDMAEnabled | Enter $true if NIC supports RDMA
SetEnabled | Enter $true if NIC supports Switch Embedded Teaming
HnvEnabled | Enter $true if NIC supports Hyper-V Network Virtualization
RSSEnabled | Enter $true if NIC supports Receive Size Scaling. This is $false in the CTLSlbBvt.ps1 script
TaskOffloadEnabled | Enter $true if NIC supports Encapsulate Task Offload
TopologyConfigXML |
ControlPathOnlyTesting |
UseResourceManager |
TestControllerNetAdapterName | The network adapter name on the Test Controller machine that can be used to access SDN management network
IsCreateCluster | Enter $True to create a new cluster before running PCS
IsRemoveCluster | Enter $True to remove cluster after running PCS
IsConfigureHyperV | Enter $True to validate Hyper-V feature is installed, and create a virtual switch on all 10Gbps or faster NICs. This parameter is ignored when IsCreateCluster is $false


Run Network Switch Profile Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c18982b8-84f9-451d-898f-86019f50053d

Test details
Specifications
  • Device.Network.Switch.Manageability.NetworkSwitchProfile
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy
ManagementIPAddress | The Management IP Address of the Switch against which the test needs to be Scheduled
UserName | The User Name for the switch
Password | The Password for the switch
OMIPortNumber | Port Number for the Switch


Run Network Switch Profile View Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d57b3b69-ea2b-4e98-ab5b-98f9d56087bc

Test details
Specifications
  • Device.Network.Switch.Manageability.NetworkSwitchProfileView
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy
SwitchManagementIPAddresses | A Comma Seperated List of Management IP Addresses of Network Switches in the Topology
HostNames | A Comma Seperated List of Host Names that are participating in the Topology
HostUserName | The UserName to Access the Host Machines
HostPassword | The Password to connect to the Host Machines
SwitchUserName | The UserName to Access the Network Switches
SwitchPassword | The Password to connect to the Network Switches


Run RSC Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ad4325c-64e9-49bb-9e8d-6c734ac38275

This test validates receive-segment coalescing (RSC).

Test details
Specifications
  • Device.Network.LAN.RSC.RSC
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

IMPORTANT

The Windows HLK User's Guide - LAN Testing Prerequisites page recommends the HLK configuration of back-to-back test connection and a separate backchannel connection to the same network together with the HLK controller. It is important that in this configuration, the DUT (device-under-test) and the support network interface, be configured for DHCP so that when they are connected back-to-back, they are auto-configured with a '169.x.x.x' IP address. If this configuration is not available, then the RSC test might not be able to determine the correct client and corresponding support IP interfaces for the DUT (device-under-test). An alternate configuration is to configure the HLK Controller to be directly reachable from the DUT network - this typically requires that the test, support and controller machines be connected to the same switch. In this configuration, all network devices, except for the controller NIC, the test NIC and the support NIC, should be disabled. Other configurations are less likely to succeed."

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
cscript [SystemDrive]\Sparta_Test\TCP\RSC.wsf -v4 2>>scripterr.txt | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
spartadrv. | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
netcapdrv6. | <[testbinroot]>\nttest\nettest\Transports\Spartamini</p>
drvinstall.exe | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
autosrvc.dll | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
ntlog.dll | <[testbinroot]>\nttest\commontest\ntlog</p>
netcapture.dll | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
spartacm.dll | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
testcore.dll | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
config_vista.exe | <[testbinroot]>\nttest\nettest\Transports\Sparta</p>
. | <[testbinroot]>\nttest\nettest\Transports\Sparta\scripts\common</p>
tcp.vbs | <[testbinroot]>\nttest\nettest\Transports\Sparta\scripts\tcp</p>
rsc.wsf | <[testbinroot]>\nttest\nettest\Transports\Sparta\scripts\tcp</p>

Parameters

Parameter name | Parameter description
InstallDir |


SMB FileIObvt LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cec62d4e-5c0f-4b3a-b09f-b33abc5e1acb

SMB FileIO test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Development
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
Test Drive 1 |
LOG_FILE |
TestCase |
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |
FileIO Test Parameters |
Test Drive 2 |


SMB SmbConnect LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f83de88-a6f4-4403-b60d-eacf7ea7b677

SmbConnect test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 390
Category | Development
Timeout (in minutes) | 23400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |


SMB SmbConnectStress BVT LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca68cf3c-05b8-45ef-b5c4-a24c06d8b27a

SmbConnectStress BVT test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Development
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |


SMB SmbConnectStress Longhaul LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4145ff46-a62a-42e9-941e-293af7c6d93c

SmbConnectStress Longhaul test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1800
Category | Development
Timeout (in minutes) | 108000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |


SysCache LOGO test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/57d37547-a33a-4438-a324-7c5cdea34b5e

SMB FileIO test.

Test details
Specifications
  • Device.Network.LAN.KRDMA.KRDMA
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Development
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
REMOTE_DRIVE |
LOG_FILE |
LENGTH |
RemoteSupportIpv4Address |
CONNECTIONS_PER_INTERFACE |
RemoteMessageIpAddress |


Wi-Fi Direct Basic Discovery Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/430878d3-71d3-4458-bd54-6a487f18219b

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirect.WiFiDirect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LocalDir | Internal Parameter
EnableTracing | Yes or No to enable tracing
SUTIPAddress | Internal Parameter
Test_EnableConcurrency | No/Both/DUT/SUT to enable testing while connected to AP
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID |


Wi-Fi Direct Basic Pairing Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/994ab513-08bd-4c1e-ab48-e5ea2dc06610

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirect.WiFiDirect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LocalDir | Internal Parameter
EnableTracing | Yes or No to enable tracing
SUTIPAddress | Internal Parameter
Test_EnableConcurrency | No/Both/DUT/SUT to enable testing while connected to AP
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID |


Wi-Fi Direct Basic Reconnect Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/04b9a237-7d06-4bea-ae5b-7d425117e132

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirect.WiFiDirect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LocalDir | Internal Parameter
EnableTracing | Yes or No to enable tracing
SUTIPAddress | Internal Parameter
Test_EnableConcurrency | No/Both/DUT/SUT to enable testing while connected to AP
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID |


Wi-Fi Direct Legacy Pairing Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/312172a5-69f5-4db3-8802-b29866cdb355

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirect.WiFiDirect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LocalDir | Internal Parameter
EnableTracing | Yes or No to enable tracing
SUTIPAddress | Internal Parameter
Test_EnableConcurrency | No/Both/DUT/SUT to enable testing while connected to AP
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID |


Wi-Fi Direct Service Discovery Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ef01b28-b321-4683-b000-9135a1e0c8cf

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirectServices.WiFiDirectServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LocalDir | Internal Parameter
EnableTracing | Yes or No to enable tracing
SUTIPAddress | Internal Parameter
queryTestDeviceID |


Wi-Fi Direct Service Pairing and Reconnect Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d679f2e5-8338-4047-aaf0-aca975d06bb7

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirectServices.WiFiDirectServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
LocalDir | Internal Parameter
EnableTracing | Yes or No to enable tracing
SUTIPAddress | Internal Parameter
queryTestDeviceID |


Win6_4.MB.CDMA.Data.MBBDriverStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/161e2fc4-09e9-4145-890d-526f99e7bfcf

The test performs MBB stress.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Benchmark
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc8K | Specifies a 8K Web Doc to download
DevPhoneNumber | Specifies the device's phone number
DevPhoneNumberType | NATIONAL,INTERNATIONAL, or UNKNOWN


Win6_4.MB.CDMA.Data.TestBaseStationsInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7722186d-ad8f-4d48-82c3-cb952571e220

The test qureies base stations data and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.BaseStationInfo.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MaxGSMCount | The maximum number of GSM base stations returned. The default value is 15.
MaxUMTSCount | The maximum number of LTE base stations returned. The default value is 15.
MaxTDSCDMACount | The maximum number of TDSCDMA base stations returned. The default value is 15.
MaxLTECount | The maximum number of LTE base stations returned. The default value is 15.
MaxCDMACount | The maximum number of CDMA base stations returned. The default value is 15.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestClassDriver

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d56503c-8c25-41af-8c10-bbfe711b0e2a

The test verifies a USB device uses class driver.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.FWComplyWithMBSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestConnect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5a998f3-bd1c-47aa-bcf3-6c9092935e1c

The test verifies the test can sucessfully connect and disconnect.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc1024K | Specifies a 1024K Web Doc to download


Win6_4.MB.CDMA.Data.TestDeviceCapsEx

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e4ec5199-0841-4864-ac17-b6b71f81cdf3

The test qureies 1) modem system capability and 2) extended device capability and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestDeviceServices

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c100487-5e8c-402a-8d1c-746c05e21d08

The test qureies device services and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.FWComplyWithMBSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestDisableEnable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5a65f58-ed2c-4527-9bd4-d230b1cf8f34

The test connects, disables, enables, and connects the device.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestHomeProvider

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f62e920-3a49-468e-a67a-96e96205b71d

The test qureies home provider and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestLoopBack

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f258a239-4741-4419-ad17-24a20b0de7cf

The test connects to loopback and send receives traffic.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.Loopback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestLowLevelUiccAccess

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f27c8d81-7e2b-49d1-be4c-614bf62f003c

The test verifies that low level UICC access commands are successful.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestLteAttach

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae5a77cb-8362-4486-bfc7-5afb5902e544

The test verifies the test can sucessfully set/query Lte Attach Config and query Lte Attach status.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.LteAttach.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
LteSetOp | Specifies the type of operation is used for. Default overwrites existing LTE attach contexts; Reset restores factory pre-configured contexts. [Default
LteIpType0 | IP address type of the first LTE Attach context [default
LteIpType1 | IP address type of the second LTE Attach context [default
LteIpType2 | IP address type of the third LTE Attach context [default
LteRoam0 | Roaming policy of the first LTE Attach context. (All three policies need to be used despite order) [home
LteRoam1 | Roaming policy of the second LTE Attach context (All three policies need to be used despite order) [home
LteRoam2 | Roaming policy of the third LTE Attach context (All three policies need to be used despite order) [home
LteSource0 | Specified the creation source of the first context [admin
LteSource1 | Specified the creation source of the second context [admin
LteSource2 | Specified the creation source of the third context [admin
LteApn0 | APN of the first LTE Attach context
LteApn1 | APN of the second LTE Attach context
LteApn2 | APN of the third LTE Attach context

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestModemBulkConfig

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/543d3954-e442-4e81-8a55-a817628dad95

The test verifies that it can sucessfully query OID_MODEM_CONFIG_INFO.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.ModemConfig.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestMultiCarrier

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae30374d-f64a-4501-9516-00ce55e096a3

The test sets the home provider.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.MultiCarrierFunctionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
MultiCarrierProviderId | Specifies Provider Id
MultiCarrierProviderName | Specifies Provider Name
MultiCarrierCellClass | Specifies Cellular Class [GSM


Win6_4.MB.CDMA.Data.TestPacketService

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e65ce7bc-24d4-4571-8b2a-e1590ac4e21e

The test attaches and detaches the packet service.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestPco

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd56036c-8fb5-40d0-80dc-8ba6bd51b9d5

The test qureies PCO data and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.PCO.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestPin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9412b270-77e8-4f88-ba15-15a97ca58c9a

The test attempts to query pin when radio on/off, enable/disable PIN1 with correct and incorrect pins.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
PIN1 | Specifies the PIN1 to use on the device
PUK1 | Specifies the PUK1 to use on the device


Win6_4.MB.CDMA.Data.TestPowerStates

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/513742d7-72eb-41fa-bf50-2f399b90b61e

The test connects, puts the machine into sleep mode/hibernate, wakes the machine, and connects.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc8K | Specifies a 8K Web Doc to download


Win6_4.MB.CDMA.Data.TestPreferredProvider

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5fe090d-8f8b-40d6-bfc0-069dd7f098f0

The test qureies preferred providers and verifies data members, add/remove a provider.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestProvisionedContext

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e61801bd-251d-4195-9a69-a6814fd729ff

The test verifies that it can sucessfully query/set MS_PROVISIONED_CONTEXT_V2.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestRadioStateHw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/854e40d3-3299-4a65-becb-de9d0dd97533

The test turns the hardware radio off and on in the scenarios: registered, Packet service attached and connected.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestRadioStateSw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/117e5a9f-596f-4c96-a9a5-11b252b434d1

The test turns the software radio off and on in the scenarios: registered, Packet service attached and connected.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestReadyInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9134a9e8-a93f-4c85-800b-d84957409ddf

The test qureies ready info and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestRegisterState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8da7d65e-6cfc-4cc3-91ee-448d29b2787e

The test qureies register state and verifies data members in automatic and manual connect mode.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestRemoval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e3da152-b75a-41ad-8fc1-128f6bf23046

The test prompts the user to remove the device after scenarios: registered, Packet service attached and after connect

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc8K | Specifies a 8K Web Doc to download


Win6_4.MB.CDMA.Data.TestResetPassthrough

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5ee8a1df-3695-444d-a242-1a77b0caacc6

The test verifies that the modem and UICC reset works, and that the UICC passthrough mode can be set and queried.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IsPassthroughEnabled | Should passthrough mode be enabled [TRUE

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestSAR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae5a77cb-8362-4486-bfc7-5afb5902e543

The test verifies the test can sucessfully query/set SAR.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.SAR.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
SarMode | Specifies SAR control mode [Device
SarBackoffStatus | Enable or disable SAR backoff [Enable
SarConfigurations | Specifies SAR backoff index per antenna. Format: AntennaIndex:BackoffIndex[,AntennaIndex:BackoffIndex,...] Example: 0:2,3:1
TransmissionStatusNotification | Enable or disable channel transmission status notification [Enable
HysteresisTimer | Specifies hysteresis timer. Range: 1 - 5

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestSelectiveSuspend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a9ccb4c-cda8-4e2a-971b-1340e7399bb5

The test block outbound IP traffic to verify the device enters selective suspend state. The test will then unblock outbound traffic and verify the device comes out of selective suspend state.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.SupportUSBSelectiveSuspend
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestSetup

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7713188d-75d6-4982-861a-2b5fe48c9e54

The test verifies the NDIS CoInstaller values, driver caps.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestSignalLoss

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bf3af969-75a1-481d-9648-06908ebc33a7

The test verifies the device provides status indications in the right sequence when signal strength loss occurs when packet service was attached.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestSignalLoss2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37327e01-a567-40b3-b669-eb28ec12c1da

The test verifies the device provides status indications in the right sequence when signal strength loss occurs when context was activated.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestSignalState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f841e64-db7c-4d39-b4d5-a6d56a9e8e2e

The test queries signal state and verifies values.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestSlot

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/049a0532-3d58-49aa-ac3d-2a9b8aab24a7

The test includes two parts: 1. Query modem slot information. 2. Query/set the mapping between modem slots and executors.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.DSSA.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
SlotMappingIndexList | Executor to slot mapping: The slot with i-th index will be mapped to Executor i. Format: [index,index,...] Example: 1,0 which means Slot 1 will be mapped to Executor 0, Slot 0 will be mapped to Executor 1.
SlotIndex | Specifies the 0-based slot index whose information is requested

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestSms

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d089c8f6-8973-4cd0-8931-cdc851dd1ee3

The test qureies sms config and status and verifies data members, it sends sms to self/deletes and verifies the operations.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ImplementSMS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
DevPhoneNumber | Specifies the device's phone number
DevPhoneNumberType | NATIONAL,INTERNATIONAL, or UNKNOWN


Win6_4.MB.CDMA.Data.TestSmsStoreFull

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe377fdd-5fd6-40c4-a032-37f5d14a4c37

The test verfies proper behavior when the SIM is full.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ImplementSMS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
DevPhoneNumber | Specifies the device's phone number
DevPhoneNumberType | NATIONAL,INTERNATIONAL, or UNKNOWN


Win6_4.MB.CDMA.Data.TestUSBDescriptor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54b27d39-18fa-4744-a1a9-c40167b195b6

The test verfies USB Descriptor.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.FWComplyWithMBSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestVisibleProvider

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a85988e-8c28-484f-8e00-0e7fee32db2d

The test queries visible providers while: radio is off, while registed and while connected.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.CDMA.Data.TestWake.IncomingDataPacket

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eab2386a-1936-48d9-bdc2-3c89d5372fc5

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for Incoming data packet to wakeup modem.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.SupportWakeOnMB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestWake.RegisterStateChange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d10ef539-a40f-4496-8183-c4d57c7eaf40

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for register state change.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.SupportWakeOnMB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CDMA.Data.TestWake.SmsMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f13f60e-6499-4ad8-a499-179ac5718e94

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for SMS message.

Test details
Specifications
  • Device.Network.MobileBroadband.CDMA.Discretional
  • Device.Network.MobileBroadband.CDMA.SupportWakeOnMB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.CellcoreDataAOACTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e433c35-4c7b-43fb-a0f6-ed7b2afc3d61

Verfies WWAN AOAC feature for different power states

Test details
Specifications
  • Device.Network.MobileBroadband.Data.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 20
    Category | Development
    Timeout (in minutes) | 20
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.CellcoreDataAPI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2747990-8d6f-4697-9069-65b1327efbfd

Verfies WWAN data API

Test details
Specifications
  • Device.Network.MobileBroadband.Data.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 20
    Category | Development
    Timeout (in minutes) | 20
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.CellcoreDataDualSIMScenario

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f11eb09a-e686-495f-b74a-22329647187d

Verfies WWAN data on Dual Sim configuration for downlink uplink and ping

Test details
Specifications
  • Device.Network.MobileBroadband.Data.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 20
    Category | Development
    Timeout (in minutes) | 20
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.CellcoreDataIPTypeTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1c55ae4-6baa-466d-9497-a3827f3e314d

Verfies WWAN data ping, downlink and uplink features on ipv4 ipv6 and ipv4v6 configuration

Test details
Specifications
  • Device.Network.MobileBroadband.Data.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 20
    Category | Compatibility
    Timeout (in minutes) | 20
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.CellcoreDataScenario

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1d97590-3b8c-433a-95c6-3d6b86f964bf

Verfies WWAN data download, upload and ping, also verifies bidirectional, multiple pdp contexts

Test details
Specifications
  • Device.Network.MobileBroadband.Data.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 20
    Category | Development
    Timeout (in minutes) | 20
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.GSM.Data.MBBDriverStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ecf1723-9a15-40e8-9428-56d0f35b0a47

The test performs MBB stress.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Benchmark
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc8K | Specifies a 8K Web Doc to download
DevPhoneNumber | Specifies the device's phone number
DevPhoneNumberType | NATIONAL,INTERNATIONAL, or UNKNOWN


Win6_4.MB.GSM.Data.TestAuthChallenge

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2baa0cac-0f9d-4b71-8904-123ce840efe4

Test will perform a set auth chanllenge and verify an auth response is received

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.EAPSIM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AuthChallengeRand1 | Specifies Auth Rand1 in Hex
AuthChallengeRand2 | Specifies Auth Rand2 in Hex
AuthChallengeRand3 | Specifies Auth Rand3 in Hex
AuthChallengeAutn | Specifies Auth Autn in Hex
AuthChallengeNetworkName | Specifies Auth Network Name


Win6_4.MB.GSM.Data.TestBaseStationsInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/307034db-b2f6-44d5-ae92-053abcf930f6

The test qureies base stations data and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.BaseStationInfo.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MaxGSMCount | The maximum number of GSM base stations returned. The default value is 15.
MaxUMTSCount | The maximum number of LTE base stations returned. The default value is 15.
MaxTDSCDMACount | The maximum number of TDSCDMA base stations returned. The default value is 15.
MaxLTECount | The maximum number of LTE base stations returned. The default value is 15.
MaxCDMACount | The maximum number of CDMA base stations returned. The default value is 15.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestClassDriver

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/95682627-5e12-438a-8a93-44de01fae2c6

The test verifies a USB device uses class driver.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.FWComplyWithMBSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestConnect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb26aed0-f9c7-4f11-90a2-04c74c5fb9d5

The test verifies the test can sucessfully connect and disconnect.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc1024K | Specifies a 1024K Web Doc to download


Win6_4.MB.GSM.Data.TestDeviceCapsEx

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75c812d5-8c7d-4589-8336-7d72f2feb987

The test qureies 1) modem system capability and 2) extended device capability and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestDeviceServices

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/836ff244-1f43-46f1-9b75-31fba977f2ef

The test qureies device services and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.FWComplyWithMBSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestDisableEnable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/631d3b50-4011-4c0d-b099-14bb0e24d6f4

The test connects, disables, enables, and connects the device.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestHomeProvider

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/04ce07b4-31f8-4c03-82b4-c37290321d43

The test qureies home provider and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestLoopBack

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bfcbf72b-bb13-4239-a53c-5873df3a1a6e

The test connects to loopback and send receives traffic.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.Loopback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestLowLevelUiccAccess

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/104db926-5cc4-47ad-a7d0-ff476b0f57a1

The test verifies that low level UICC access commands are successful.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestLteAttach

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aaa1f042-8535-4d09-b19e-082bef24f518

The test verifies the test can sucessfully set/query Lte Attach Config and query Lte Attach status.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.LteAttach.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
LteSetOp | Specifies the type of operation is used for. Default overwrites existing LTE attach contexts; Reset restores factory pre-configured contexts. [Default
LteIpType0 | IP address type of the first LTE Attach context [default
LteIpType1 | IP address type of the second LTE Attach context [default
LteIpType2 | IP address type of the third LTE Attach context [default
LteRoam0 | Roaming policy of the first LTE Attach context. (All three policies need to be used despite order) [home
LteRoam1 | Roaming policy of the second LTE Attach context (All three policies need to be used despite order) [home
LteRoam2 | Roaming policy of the third LTE Attach context (All three policies need to be used despite order) [home
LteSource0 | Specified the creation source of the first context [admin
LteSource1 | Specified the creation source of the second context [admin
LteSource2 | Specified the creation source of the third context [admin
LteApn0 | APN of the first LTE Attach context
LteApn1 | APN of the second LTE Attach context
LteApn2 | APN of the third LTE Attach context

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestMPDP

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08497822-4355-478b-9cba-0c0c7b663953

The test connects to the home network via additional PDP context and default PDP context and downloads a file from the internet simultaneously.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.MultiplePDPContext
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc1024K | Specifies a 1024K Web Doc to download
MpdpAccessString | Specifies the access string to use when making a MPDP connection
MpdpUserName | Specifies the user name to use when making a MPDP connection
MpdpPassword | Specifies the password to use when making a MPDP connection
MpdpWebDoc1024K | Specifies a 1024K MPDP Web Doc to download


Win6_4.MB.GSM.Data.TestModemBulkConfig

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da1177dd-3e1b-45f9-a839-181313751898

The test verifies that it can sucessfully query OID_MODEM_CONFIG_INFO.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.ModemConfig.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestMultiCarrier

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b01ab39d-d945-410c-a804-56e399279cf8

The test sets the home provider.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.MultiCarrierFunctionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
MultiCarrierProviderId | Specifies Provider Id
MultiCarrierProviderName | Specifies Provider Name
MultiCarrierCellClass | Specifies Cellular Class [GSM


Win6_4.MB.GSM.Data.TestPacketService

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c83f8fff-979a-47f5-b4b0-9934f6ac6eba

The test attaches and detaches the packet service.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestPco

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7f8c2c2-ba87-4f51-8666-3fa06dc01451

The test qureies PCO data and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.PCO.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestPin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9d1c9fe-d8f2-4d1b-9d3b-8ea8b1ef68c4

The test attempts to query pin when radio on/off, enable/disable PIN1 with correct and incorrect pins.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
PIN1 | Specifies the PIN1 to use on the device
PUK1 | Specifies the PUK1 to use on the device


Win6_4.MB.GSM.Data.TestPowerStates

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0af8e06-4d04-4027-8b84-777a6de4ce49

The test connects, puts the machine into sleep mode/hibernate, wakes the machine, and connects.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc8K | Specifies a 8K Web Doc to download


Win6_4.MB.GSM.Data.TestPreferredProvider

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22933112-e0e8-4cc0-a8ac-515b866a8694

The test qureies preferred providers and verifies data members, add/remove a provider.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestProvisionedContext

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/977b0b55-1507-4542-bd51-0a23aa2346e9

The test verifies that it can sucessfully query/set MS_PROVISIONED_CONTEXT_V2.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestRadioStateHw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa0bd189-b332-4651-8eda-e89866d2e2f1

The test turns the hardware radio off and on in the scenarios: registered, Packet service attached and connected.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestRadioStateSw

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0aa9981a-e556-4338-a568-b17289dd9742

The test turns the software radio off and on in the scenarios: registered, Packet service attached and connected.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestReadyInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c03b0771-5436-4ad5-a5b7-e08adb758a28

The test qureies ready info and verifies data members.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestRegisterState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc3d6758-86be-445a-aae3-0fb1b2a4b5c7

The test qureies register state and verifies data members in automatic and manual connect mode.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestRemoval

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4854fed2-53dd-4122-9fde-0f669595f6b1

The test prompts the user to remove the device after scenarios: registered, Packet service attached and after connect

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc8K | Specifies a 8K Web Doc to download


Win6_4.MB.GSM.Data.TestResetPassthrough

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b19d12ef-1beb-4ae5-bab5-cfa523c0c3dd

The test verifies that the modem and UICC reset works, and that the UICC passthrough mode can be set and queried.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
IsPassthroughEnabled | Should passthrough mode be enabled [TRUE

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSAR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aaa1f042-8535-4d09-b19e-082bef24f517

The test verifies the test can sucessfully query/set SAR.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.SAR.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
SarMode | Specifies SAR control mode [Device
SarBackoffStatus | Enable or disable SAR backoff [Enable
SarConfigurations | Specifies SAR backoff index per antenna. Format: AntennaIndex:BackoffIndex[,AntennaIndex:BackoffIndex,...] Example: 0:2,3:1
TransmissionStatusNotification | Enable or disable channel transmission status notification [Enable
HysteresisTimer | Specifies hysteresis timer. Range: 1 - 5

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSelectiveSuspend

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d48358ba-8df7-4476-8dfe-2f10ee125c07

The test block outbound IP traffic to verify the device enters selective suspend state. The test will then unblock outbound traffic and verify the device comes out of selective suspend state.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.SupportUSBSelectiveSuspend
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestSetup

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b3cacbe-6fcd-4ca5-a1cc-2b784c523366

The test verifies the NDIS CoInstaller values, driver caps.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSignalLoss

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/18c1859a-ae25-4824-82a0-b89dde60a0c4

The test verifies the device provides status indications in the right sequence when signal strength loss occurs when packet service was attached.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestSignalLoss2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94919dd8-5301-4a0f-ad0f-eddfa5cff449

The test verifies the device provides status indications in the right sequence when signal strength loss occurs when context was activated.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestSignalState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7cb1f36-edfa-4322-8f25-e000ae55d384

The test queries signal state and verifies values.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSimBad

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2be175c8-69a0-45a8-ad8a-01efa2cb393c

The test verfies proper behavior when a bad SIM is inserted.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSimNotInserted

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92b164f7-c0e6-4231-99e7-e51070c4bdf6

The test verfies proper behavior when no SIM is inserted.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSimRoaming

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/546134aa-c5e8-427f-bf33-204d170d7c43

The test verfies proper behavior when a roaming SIM is inserted.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestSlot

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/defddebe-cc40-4d6f-9b0c-ca5ca9a1cb4d

The test includes two parts: 1. Query modem slot information. 2. Query/set the mapping between modem slots and executors.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.DSSA.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
SlotMappingIndexList | Executor to slot mapping: The slot with i-th index will be mapped to Executor i. Format: [index,index,...] Example: 1,0 which means Slot 1 will be mapped to Executor 0, Slot 0 will be mapped to Executor 1.
SlotIndex | Specifies the 0-based slot index whose information is requested

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestSms

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0045e280-e26a-44fe-88ec-98c6975a713b

The test qureies sms config and status and verifies data members, it sends sms to self/deletes and verifies the operations.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ImplementSMS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
DevPhoneNumber | Specifies the device's phone number
DevPhoneNumberType | NATIONAL,INTERNATIONAL, or UNKNOWN


Win6_4.MB.GSM.Data.TestSmsStoreFull

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/836c93b2-d6f4-4b23-b4af-d14d01547f08

The test verfies proper behavior when the SIM is full.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ImplementSMS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
DevPhoneNumber | Specifies the device's phone number
DevPhoneNumberType | NATIONAL,INTERNATIONAL, or UNKNOWN


Win6_4.MB.GSM.Data.TestUSBDescriptor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd3b2809-a9af-4818-8f99-8a426491db4b

The test verfies USB Descriptor.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.FWComplyWithMBSpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestUssd

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17ae6fea-6244-442d-b977-6367d1ae441e

The test will attempt a USSD set operation and verify the USSD status indication.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.USSD
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
UssdStringCodingScheme | Specifies USSD data coding scheme (HexValue)
UssdStringChar | Specifies the USSD string to encode
UssdStringByte | Specifies the USSD byte string to send


Win6_4.MB.GSM.Data.TestVisibleProvider

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13ab135b-1fb2-490f-bc43-5995c5b07217

The test queries visible providers while: radio is off, while registed and while connected.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.ComplyWithBaseReq
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection


Win6_4.MB.GSM.Data.TestWake.IncomingDataPacket

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dab51ae1-91fc-4ce8-87e7-954a9128fce7

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for Incoming data packet to wakeup modem.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.SupportWakeOnMB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestWake.RegisterStateChange

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0f3f0b8f-356c-4434-ab35-3208e6e1631f

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for register state change.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.SupportWakeOnMB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.GSM.Data.TestWake.SmsMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/425719ab-35c7-4ab1-9c8a-fd7b2c9baf69

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for SMS message.

Test details
Specifications
  • Device.Network.MobileBroadband.GSM.Discretional
  • Device.Network.MobileBroadband.GSM.SupportWakeOnMB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Win6_4.MB.NDIS.DeviceCaps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68920684-64a3-4a4c-b675-e450990ec3c1

Test queries device capabilities and verifies data.

Test details
Specifications
  • Device.Network.MobileBroadband.NDIS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/269a8071-1769-498b-93a5-de7adbeb0518

Verifies network registration, signal strenght and various network related APIs

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.DualSim

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/65abb0d2-80f5-4a37-b0e9-2702b8b65a75

Verifies dual sim specific features like changing executor slot mapping and verifying preferences are persistent

Test details
Specifications
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.Location

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/638ee059-2a99-4399-980b-8b963b4a00de

Verifies network time(nitz) and get postion info

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.ModemReset

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe02f090-ec60-4e47-ac26-238a1683998d

Verifies modem reset apis

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.NetworkSelection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/32c21d48-0988-4b29-93c6-5a9c5c6d907e

Verifies network selection with different radio technologies and manual selection

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.OperatorList

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f74bc3d6-12eb-4912-ae09-4b79d1ab3b33

Verifies network operator list, get and set preffered operators

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.PowerState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7380ee0-4e64-44e1-88e0-8350ca59eeb4

Verifies modem and executor power states

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.RebootTests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4d9ccb8-2ebd-483e-9d8c-29dfd4a4f9f7

Verifies modem and executor power states are consistent after reboot

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Scenario
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Registration.VOLTE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f81e0b4e-9746-4b53-9c1c-263239a843df

Verifies networks IMS registration, Get and set Device management profile values

Test details
Specifications
  • Device.Network.MobileBroadband.Registration.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.Encoding

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eebce46c-1e5d-4f70-b2d0-d3fbf59481ab

Send loopback short text message using various supported encoding methods.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.MultiSegmentMessage

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06e9289f-2e3f-4e35-a07e-b45ada7216bb

Send loopback short text message including UDH.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendMsgInternationNumber

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9966a65c-71fa-4386-8c22-faebed95c354

Send loopback short text message using international phone number.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendMsgNegtiveTest

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1bde7a2-878e-4c4e-b899-c67a5d0a7623

Send loopback short text message including invalid/unsupported parameter.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/739fdfd8-7932-490a-b97d-3636caac11f7

Send loopback short text message using 7bit GSM encoding method.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSAfterPINUnlocked

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89781bf2-9660-4963-a92e-a3e095d21608

Send a SMS on the subphone that is just PIN unlocked.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSAfterPinUnlockStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3c38cda-807a-406a-a626-fb23ff2dc1b6

Stress send and receive SMS after PIN is unlocked.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSAfterPUKUnlockStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45035425-ca8c-40a9-925c-f9963153a7d2

Stress send and receive SMS after PUK is unlocked.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSAfterSoftSwap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba4aa8ea-009d-4689-b7a1-3fa804a6a0da

Send a SMS on the subphone after doing a soft swap.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSModemOFF

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b6f04c6-f3a0-4b38-b015-8df03d7e45d5

Send a SMS with the modem power state is off

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSNonProvision

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d293948c-bb36-4509-9f29-394ce4273269

Send a SMS on the subphone that is not provisioned.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSOutgoingCallOnSameSubphoneStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7c52630-cc6c-4879-afde-c6418af2171a

Stress send and receive SMS while there is a voice call going on another subphone.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.Voice.Discretional
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSOutgoingCallOnSameSubphoneStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4190694-7309-4725-ba3d-c3ec2970b659

Stress send and receive SMS while there is a voice call going on the same subphone.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.Voice.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSPINLocked

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1590489-9ae6-4fd2-b539-851e279dcd52

Send a SMS on the subphone that is PIN locked.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSPUKLocked

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21c2f5e5-2c45-48a1-920b-ea0a7bd17af6

Send a SMS on the subphone that is PUK locked.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a43e259-fd3d-44fa-bcad-7629102d9f68

Stress send and receive SMS.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSStressWithLongCallOnSameSubpone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44433ca7-e61a-46d9-ac27-87ec8aa2066a

Send a SMS on the subphone with multiple interations on which there is a long voice call going on.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.Voice.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSSubphoneOFF

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/caf327d8-987f-4cb2-959e-47057cd5b4bf

Send a SMS on the subphone that is RF state OFF, while another subphone RF state is ON.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSTransferDataOnDiffSubPhoneStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6beead71-d52f-4afd-b13d-45de25ff8ee3

Stress send and receive SMS while there is downloading data on another subphone.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSTransferDataOnSameSubphoneStress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10cd2d4c-316e-4bce-b8b8-2488930579d7

Stress send and receive SMS while there is downloading data on the same subphone.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSUnregistered

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/252e18b6-1c41-4be8-8ea2-992a8d422a22

Send a SMS on the subphone that is not camp on the network

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSWithDatOnDiffSubphone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/46c17688-1365-428e-91d4-6f7fa7007e6f

Send a SMS on the subphone wint multiple iterations while there is long data transferring on another subphone.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSWithDatOnDiffSubphone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80ff4446-d7a1-41eb-a44d-18820988cfb7

Send a SMS on the subphone while there is data transferring on another subphone.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSWithDatOnSameSubphone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a037e04f-0e57-44bd-a334-1e744bae7ed5

Send a SMS on the subphone that is data transferring.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSWithDatOnSameSubphone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f424be89-11dd-4169-8329-8ce5c86b3056

Send a SMS wint multiple iterations on the subphone that is long data transferring.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSWithVoiceOnDiffSubpone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/778c979c-ce00-4b03-bdee-2f555e1c2005

Send a SMS on the subphone with multiple interations and on the another subphone there is a long call going on.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.Voice.Discretional
  • Device.Network.MobileBroadband.MultiSim.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 120
    Category | Scenario
    Timeout (in minutes) | 300
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SendRecvSMSWithVoiceOnSameSubpone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3917449a-a84e-46f2-8831-60e1e774e7a2

Send a SMS on the subphone on which there is a voice call going on.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
  • Device.Network.MobileBroadband.Voice.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Scenario
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SMSChangeConfiguration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ece5586-f7bb-476e-bfb5-214f779581e7

Change SMS configuration.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.SMS.SMSOnUICC

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6f45a6a4-994c-4c0f-bd89-45b5717f19ed

Write message on UICC.

Test details
Specifications
  • Device.Network.MobileBroadband.SMS.Discretional
Platforms
    Supported Releases
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 5
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.System.Data.TestClassDriver

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2b34497-2551-40c3-a42d-a3b26955551c

The test verifies a USB device uses class driver.

Test details
Specifications
  • Device.Network.MobileBroadband.Discretional
  • System.Client.MobileBroadBand.ClassDriver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation
  • System.Client additional documentation


Win6_4.MB.System.Data.TestConnect

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c031111f-4bf4-404e-b751-740bce133dbf

The test verifies the test can sucessfully connect and disconnect.

Test details
Specifications
  • Device.Network.MobileBroadband.Discretional
  • System.Client.MobileBroadBand.MobileBroadBand
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
AccessString | Specifies the access string to use when making a connection
UserName | Specifies the user name to use when making a connection
Password | Specifies the password to use when making a connection
WebDoc1024K | Specifies a 1024K Web Doc to download


Win6_4.MB.UICC.ATR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b98ced5b-e4c4-4b27-9df4-92adc3e12ce4

Verify GetUiccATR API

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.EnumerateSlots

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7c94134b-0316-4280-83f4-5436c9dcc766

Verify EnumerateSlots

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.GetCardInfo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d86e1ad3-65dd-43e1-a856-5e5ba1060ede

Verify GetCardInfo

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.GetIMSI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00dabb86-a489-4d9b-97c7-4ad3c4bb6038

Verify GetIMSI

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.GetSubscriberNumber

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81343250-f3c8-42a1-be6d-b80a219c3603

Verify GetSubscriberNumbers

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.GetUiccPRLID

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b7c12ae-6652-4249-8690-83d0064b310a

Verify GetUiccPRLID

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.GetUiccRecordStatus

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e48b9966-11d3-4634-9a06-bcda4d9e71bd

Verify GetUiccRecordStatus API

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.GetUiccServiceState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b7cc7965-01bd-4e6b-8b23-ec460e8813e4

Verify GetUiccServiceState

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.DeleteAdditionalNumberStrings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/269b9b3b-66f2-4c56-8a92-e38d988a54ac

Verify DeleteAdditionalNumberStrings

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.FDNWritePhonebookEntry

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebc70d2e-fd19-4372-9a65-3dc660f19cc2

Verify FDNWritePhonebookEntry

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.GetAllAdditionalNumberStrings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f762805-16cc-49ba-a373-69b30e526ab8

Verify GetAllAdditionalNumberStrings

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.GetAllEmergencyNumbers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/960bc58a-f48b-4cef-b215-6440d1b9ddad

Verify GetAllEmergencyNumbers

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.GetPBCapsType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e586cf35-8967-47fa-bf4b-2e2e2349d858

Verify UICC phone book storage locations that the driver supports

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.GetPBMaxRead

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de10ae1e-67d0-4d70-ae0c-7884577ba5d7

Verify Maximum number of phonebook entries that can be read per call

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.GetPhoneBookOptions

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5003699b-dc1d-4339-afec-e8e95ec07b12

Verify GetPhoneBookOptions

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.ReadFDNPhonebookEntries

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fee12f56-07ff-4970-814c-358c8efa9947

Verify ReadFDNPhonebookEntries

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.ReadPhonebookEntries

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3765d2bb-1a5c-4f80-9b35-2885bee86b83

Verify ReadPhonebookEntries

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.WriteAdditionalNumberStrings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fcc166e9-60eb-40f9-bb31-f5046ad56e7b

Verify WriteAdditionalNumberStrings

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.PB.WritePhonebookEntry

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0043bbcf-65f1-43b8-b434-38d1675ac3f8

Verify WritePhonebookEntry

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.PhoneBook.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.ChangeUiccLockPassword

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54f12776-5006-4564-abcb-81b8bedd2aa0

Verify ChangeUiccLockPassword

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.GetPersoDeactivationState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3624167-5df3-4221-a3a5-94aea28123e6

Verify GetPersoDeactivationState

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.GetUiccLockState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c944c10-a5f1-42a2-88a3-ecf011243c99

Verify Pin1LockState

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.GetUiccLockState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7e09f1a-a922-4091-be1c-75a10b87f40b

Verify Pin2LockState

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.GetUiccServiceLock

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d7bb248-0ffe-494f-8c5c-a80d91d2aa15

Verify GetUiccServiceLock

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.SetUiccLockEnabled

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13c8f21c-3ea4-467b-b1d8-7a59a20839ab

Verify SetUiccLockEnabled

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.VerifyAppPersoState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bac5d6e5-6fed-421e-b27f-2b7bc9c5ecd1

Verify GetUiccAppPersoCheckState

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.VerifyUiccLockPin1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d893996-5463-4a06-a175-23ec4a8950e1

Verify Pin1UiccLock

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.Security.VerifyUiccLockPin2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2d72535-200b-4a38-b75a-fd3edb55479d

Verify Pin2UiccLock

Test details
Specifications
  • Device.Network.MobileBroadband.Uicc.Security.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.SendRestrictedUiccCMD

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/385ac019-45b2-4683-9e34-4c753d830b69

Verify SendRestrictedUiccCmd API.

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.UICC.SetUiccServiceState

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11192e42-64a9-4ac0-90a9-127cb3cebe9d

Verify SetUiccServiceState

Test details
Specifications
  • Device.Network.MobileBroadband.UICC.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_HoldActive_AcceptHeld

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/185e2bcc-472e-4723-a4c8-dd8d50020cf7

MultiCall test: First make outgoing call and then receive incoming call and accept the 2nd call and hold

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_RelBoth

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3b97f98-9847-4d00-bc7e-bc656df3ba95

MultiCall test: First make outgoing call and then receive incoming call and release both calls

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_RelIn_HoldActive_AcceptHeld

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0fc2c33b-2400-4a7b-a597-30651f13704e

MultiCall test: First make outgoing call and then receive incoming call and release the 2nd call and accept 1st

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_AcceptIn_RemotehangupIn_RelOut

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/264e8b2b-7504-4319-b40f-3705b381cdb6

MultiCall test: First make outgoing call and then receive incoming call and accept the 2nd call and remote hangup 2nd

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_3rdOut_RelAll

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75ca6dda-262d-4419-9065-dd13381766e5

MultiCall test: First make outgoing call then receive a call, conf both and make 3rd out call

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_HoldAllBut1st

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd4f29ce-c995-4e37-a264-310d3a1f22b8

MultiCall test: First make outgoing call then receive a call, conf both and make one private

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_RelBoth

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ff6547c-2131-4537-b2ed-301e390a2153

MultiCall test: First make outgoing call then receive a call, conf both and release both

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_BothInConf_RelHeldConf

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/133b0909-42d0-45e3-8b5a-5b552ef15f08

MultiCall test: First make outgoing call and then receive incoming call and accept the 2nd call, then conference both

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_ReleaseActive_AcceptHeld

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2aec147a-58ea-4a94-b7cd-9a4cada7c255

MultiCall test: First make outgoing call and then receive incoming call and release the st call and accept 2nd

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_RelOffering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96a648c2-d365-4cee-8206-1eec68c2c715

MultiCall test: First make outgoing call and then receive incoming call and release the 2nd call

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_RelOut_AcceptIn

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e4e470d4-abca-48a7-8b61-2216e3dfc507

MultiCall test: First make outgoing call and then receive incoming call and accept the 2nd call

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.1stOut_2ndIn_RemoteHangupOut_AcceptIn

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a0f2381-809a-4d80-b596-d15f320f7d08

MultiCall test: First make outgoing call and then receive incoming call and release the 2nd call remotely

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.2OutgoingCalls_BothInConf_RelBoth

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1c3d8c4-3783-4e5f-b666-9ee2160b7d53

MultiCall test: make 2 outgoing calls, conference both and release both

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.3Out_AllInConf_Make2ndPrivate_SwapCalls_RelPrivate_RelAll

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/215d10a4-2fc0-4738-91d5-b10ce3de077b

MultiCall test: Make 3 outgoing calls and conference them, make 2nd call private and swap calls

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.SingleCallTests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff12f8c2-e9d5-4e30-818f-60915bdd46cd

Single Call Tests

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Compatibility
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


Win6_4.MB.Voice.3GPP.SingleCallTests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61fb2e67-56fd-4d99-b6e1-9b71649dd32a

Single Call Bringup Tests

Test details
Specifications
  • Device.Network.MobileBroadband.Voice.3GPP.Discretional
Platforms
    Supported Releases
    • Next update to Windows 10
    Expected run time (in minutes) | 5
    Category | Development
    Timeout (in minutes) | 10
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • Device.Network additional documentation

    More information

    Parameters

    Parameter name | Parameter description
DialupServerNumber | Specifies the Dialup Server Number to use on the device


WLAN Association Tests - Custom Configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/41e3400d-08da-424b-becd-fe3e8952bbca

This test suite validates the WLAN associations.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test allows the test scheduler (user) to run the WLAN Scan Tests with specific parameters. For each of the APs the user can specify the following via one of the CustomAP[1|2]Config[24|5]GHz:

  • SSID Broadcast Setting: Hidden or Visible
  • EAP Phase 1 Type: NONE or EAP_PEAP or EAP_TTLS
  • EAP Phase 2 Type: NONE or MSCHAPV2
  • Authentication Algorithm: OPEN or WEP or WPAPSK or WPA or WPA2PSK or WPA2
  • Cipher Algorithm: NONE or WEP or TKIP or AES
  • Channel: Integer Channel Number
  • Phy Type: A or B or G or N or AC

Below are the examples of AP Configs used by some of the tests:

  • Hidden.NONE.NONE.open.none.11.g
  • Visible.NONE.NONE.WPA2PSK.AES.44.n

This test performs the following actions:

  • If CustomAPConfig parameters are specified, configure two routers, that are named Router 0 and Router 1, as below. If parameters are not specified, the test does nothing.
    • Router 0 - 2.4Ghz : Configured by user parameter Test_CustomAP1Config24GHz
    • Router 0 - 5Ghz : Configured by user parameter Test_CustomAP1Config5GHz (Never used by test)
    • Router 1 - 2.4Ghz : Configured by user parameter Test_CustomAP2Config24GHz
    • Router 1 - 5Ghz : Configured by user parameters Test_CustomAP2Config5GHz
  • Execute the BasicAssociation() test steps below.
  • If Standby testing is enabled (bit 0x1 set in Test_CustomAssociationTestOptions), execute the AssociationPowerManagementSleep() test steps below for Standby or AOAC Sleep
  • If Hibernate testing is enabled (bit 0x2 set in Test_CustomAssociationTestOptions), execute the AssociationPowerManagementHibernate() test steps below for Hibernate

The BasicAssociation() test performs the following actions:

  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual. If executing a FIPS mode test, the profile is configured for FIPS mode.
  • Initiate a WlanConnect using the profile.
  • Wait for up to 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 0 at 2.4 GHz.
  • Exchange TCP packets with the TCP Server on the AP controller server
  • Turn off Router 0 - 2.4 GHz
  • Delete the profile for the Router 0 - 2.4 GHz
  • Turn on Router 1 - 5 GHz (if adapter support 5 GHz) or Router 1 - 2.4 GHz (if adapter does not support 5 GHz)
  • Create a profile for appropriate Router 1 band having ConnectionMode configured as manual. If executing a FIPS mode test, the profile is configured for FIPS mode.
  • Initiate a WlanConnect using the profile.
  • Wait for up to 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to appropriate router and band
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Delete the profile for the Router 1

The AssociationPowerManagementSleep() test first verifies that the adapter can start connected to an AP when it goes through a Standby/Connected Standby transition. Next it verifies that the adapter can switch from one AP to another after it goes through a Standby/Connected Standby transition. It performs the following actions:

  • For Sleep testing, check if system is Standby or AOAC capable. If not capable, the test fails.
  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn off all routers except Router 0 - 2.4 GHz
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual.
  • Initiate a WlanConnect using the profile.
  • Wait for upto 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 0 at 2.4 GHz.
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Depending on system either Standby or go to Connected Standby for 120 seconds
  • After wake up validate that adapter is still connected
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 0 at 2.4 GHz.
  • Exchange TCP packets with the TCP Server on the AP controller server
  • Delete all WLAN profiles (this will disconnect the adapter)
  • The above steps have validated that the adapter can start connected to an AP when going through a Standby or Connected Standby transition. Next the test will verify transition from one AP to another.
  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn off all routers except Router 0 - 2.4 GHz
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual.
  • Initiate a WlanConnect using the profile.
  • Wait for upto 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 0 at 2.4 GHz.
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Configure the AP controller server machine to turn off the Router 0 at 2.4 GHz after 30 seconds and turn on Router 1 5GHz (if adapter supports 5GHz) or Router 1 2.4 GHz (if adapter does not support 5 GHz)
  • Depending on system either Standby or go to Connected Standby for 120 seconds
  • After wake up sleep for 30 seconds
  • Issue a Scan and Validate that the Router 1 is visible in the Scan List
  • Create a profile for Router 1 having ConnectionMode configured as manual.
  • Initiate a WlanConnect using the profile.
  • Wait for upto 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 1 and appropriate band
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Delete all WLAN profiles (this will disconnect the adapter)
  • The above steps have validated that the adapter can switch from one AP to another after it goes through a Standby or Connected Standby transition.

The AssociationPowerManagementHibernate() test first verifies that the adapter can start connected to an AP when it goes through a Hibernate transition. Next it verifies that the adapter can switch from one AP to another after it goes through a Hibernate transition. It performs the following actions:

  • For Hibernate testing, check if system is Hibernate capable. If not capable, the test completes successfully.
  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn off all routers except Router 1 - 5 GHz (if adapter supports 5 GHz) or Router 1 - 2.4 GHz (if adapter does not support 5 GHz)
  • Create a profile for Router 1 appropriate band having ConnectionMode configured as manual.
  • Initiate a WlanConnect using the profile.
  • Wait for upto 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 1 and appropriate band
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Hibernate for 120 seconds
  • After wake up validate that adapter is still connected
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 1 and appropriate band
  • Exchange TCP packets with the TCP Server on the AP controller server
  • Delete all WLAN profiles (this will disconnect the adapter)
  • The above steps have validated that the adapter can start connected to an AP when going through a Hibernate transition. Next the test will verify transition from one AP to another.
  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn off all routers except Router 1 - 5 GHz (if adapter supports 5 GHz) or Router 1 - 2.4 GHz (if adapter does not support 5 GHz)
  • Create a profile for Router 1 appropriate band having ConnectionMode configured as manual.
  • Initiate a WlanConnect using the profile.
  • Wait for upto 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 1 and appropriate band
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Configure the AP controller server machine to turn off the Router 1 after 30 seconds and turn on Router 0 2.4 GHz
  • Hibernate for 120 seconds
  • After wake up sleep for 30 seconds
  • Issue a Scan and Validate that the Router 0 - 2.4 GHz is visible in the Scan List
  • Create a profile for Router 0 - 2.4GHz having ConnectionMode configured as manual.
  • Initiate a WlanConnect using the profile.
  • Wait for upto 30 seconds for the connect to complete by using WLAN notifications.
  • Wait for IP address on the adapter
  • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • Use the WLAN API GetConnectionAttributes to confirm that the association is correct and the connection is to Router 0 - 2.4 GHz
  • Exchange TCP packets with the TCP Server on the AP controller server.
  • Delete all WLAN profiles (this will disconnect the adapter)
  • The above steps have validated that the adapter can switch from one AP to another after it goes through a Hibernate transition.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing
Test_CustomAP1Config24GHz | Custom config for 2.4GHz radio of first AP (Skip test by default)
Test_CustomAP1Config5GHz | Custom config for 5GHz radio of first AP (Skip test by default)
Test_CustomAP2Config24GHz | Custom config for 2.4GHz radio of second AP (Skip test by default)
Test_CustomAP2Config5GHz | Custom config for 5GHz radio of second AP (Skip test by default)
Test_CustomAssociationTestOptions | Bitmask of options for Custom Association Test (0 = default)


WLAN Association Tests - OPEN_WEP - WPA_TKIP

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0eff39a-0d3f-4602-b0bb-0df094564f45

This test suite validates WLAN associations.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test suite performs the following actions:

  • Configure two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : OPEN/WEP40 [Preferred PHY B/Channel 1]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY A/Channel 36]
    • Router 1 - 2.4Ghz : WPAPSK/TKIP [Preferred PHY G/Channel 11]
    • Router 1 - 5Ghz : WPAPSK/TKIP [Preferred PHY A/Channel 36]
  • Execute the BasicAssociation() test steps as described in WLAN Association Tests - Custom Configuration
  • This test does not perform any power transition tests.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Association Tests - OPEN_WPA2_AES

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6da2adf-19f4-4df0-8dc2-cb6acd31deda

This test suite validates WLAN associations.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test suite performs the following actions:

  • Configure two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : OPEN/NONE [Preferred PHY G/Channel 1]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY A/Channel 36]
    • Router 1 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 11]
    • Router 1 - 5Ghz : WPA2PSK/AES [Preferred N/Channel 36]
  • Execute the BasicAssociation() test steps as described in WLAN Association Tests - Custom Configuration
  • Execute the AssociationPowerManagementSleep() test steps as described in WLAN Association Tests - Custom Configuration
  • Execute the AssociationPowerManagementHibernate() test steps as described in WLAN Association Tests - Custom Configuration

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Association Tests - WPA2_PSK_PEAP_AES

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/602d00a4-d2a0-4c10-8f9c-ac0f3590d03c

This test suite validates WLAN associations.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test suite performs the following actions:

  • Configure two routers, that are named Router 0 and Router 1, as follows:

    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY N/Channel 6]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY A/Channel 36]
    • Router 1 - 2.4Ghz : WPA2Enterprise (PEAP-EAPMSCHAPV2)/AES [Preferred PHY N/Channel 11]
    • Router 1 - 5Ghz : WPA2Enterprise (PEAP-EAPMSCHAPV2)/AES [Prefered PHY A/Channel 157]

  • Execute the BasicAssociation() test steps as described in WLAN Association Tests - Custom Configuration

  • This test does not perform any power transition tests.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN D2 Sleep - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14c078a5-bc22-41c1-95ac-edd174f6fa8b

This test validates the D2 sleep functionality. Device should enter the D2 state after pressing the power button and then return to D0.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure one router (Router 0), as follows:

    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 6]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY N/Channel 40]

  • Perform a Scan and validate that the router is found

  • Validate that the adapter is reporting itself as AOAC capable
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual.
  • Perform a WlanConnect using the profile
  • Disable other Network Adapters on the Client machine
  • Start monitoring WLAN state and adapter power state events
  • Enter Connected Standby for 5 minutes
  • Enable other Network Adapters on the Client machine
  • Check the WLAN state and adapter power state events to validate that the adapter went to low power and woke up

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Data Path Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89be74cd-c2b7-41b2-adbe-344e09ce12e2

This test suite validates that the WLAN adapter is able to send and receive IPv4/IPv6 and UDP/TCP unicast, broadcast, and multicast packets.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure one router (Router 0), as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES [Prefered PHY N]
    • Router 0 - 5Ghz : WPA2PSK/AES [Prefered PHY N]
  • Execute the DataExchange() test steps below for Router 0 - 2.4 GHz
  • If adapter supports 5GHz, execute the DataExchange() test steps below for Router 0 - 5 GHz

The DataExchange() test performs the following actions:

  • Create a profile for the appropriate band having ConnectionMode configured as manual.
  • On Client machine perform a WlanConnect using the profile
  • Wait for the adapter to obtain an IP address
  • On Support machine perform a WlanConnect using the profile
  • Wait for the adapter to obtain an IP address

  • Launch parallel threads that perform the data send and receive between the Client and Support machine (through the AP). The test log prints the IP address and port number used for each exchange. Between each send call there is a 1 to 3 second sleep. The packet sizes are randomly determined. The following packet exchanges are performed:

    • UDP Send (IPv4) from Client to Support
    • UDP Receive (IPv4) from Support to Client
    • UDP Send (IPv6) from Client to Support
    • UDP Receive (IPv6) from Support to Client
    • TCP Send (IPv4) from Client to Support
    • TCP Receive (IPv4) from Support to Client
    • TCP Send (IPv6) from Client to Support
    • TCP Receive (IPv6) from Support to Client
    • Multicast Send (IPv4) from Client to Support
    • Multicast Receive (IPv4) from Support to Client
    • Multicast Send (IPv6) from Client to Support
    • Multicast Receive (IPv6) from Support to Client
    • Broadcast Send (IPv4) from Client to Support
    • Broadcast Receive (IPv4) from Support to Client

  • Stop the data traffic after 2 minutes

  • Validate that the percentage of packets received to the packet sent is within an acceptable percentage.
    • For TCP traffic 95% of the packets sent should be received
    • For all other traffic, 80% of the packets sent should be received

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
SUTIPAddress | Internal Parameter
EnableTracing | Yes or No to enable tracing
TestName24Ghz | Internal Parameter
TestName5Ghz | Internal Parameter


WLAN Dot11W Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a00ecf7-fb83-422c-8950-8131c6ec0d67

This test suite validates that the WLAN adapter supports 802.11w.

Test details
Specifications
  • Device.Network.WLAN.SupportDot11W.Dot11W
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Initiate a Scan and validate that the 802.11w AP is visible
  • Create a profile for the 802.11w having ConnectionMode configured as manual.
  • Perform a WlanConnect using the profile
  • Validate that 802.11w was negotiated for the connection
  • Disconnect from the network and delete the profile

This test does not use the AP's connected to the AP machine.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing
Dot11WSSID | SSID of the 11w test network
Dot11WPassword | Passphrase of the 11w test network


WLAN FIPS Association Tests - WPA2_PSK_PEAP_AES

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78ba9a69-e857-4e1e-bede-c18b26da74d5

This test suite validates that the WLAN adapter supports FIPS encryption mode.

Test details
Specifications
  • Device.Network.WLAN.SupportFIPS.FIPS
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test suite performs the following actions:

  • Enables FIPS on the Client machine.
  • Configures two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4 GHz : WPA2PSK/AES [Preferred PHY N/Channel 6]
    • Router 0 - 5 GHz : WPA2PSK/AES [Preferred PHY A/Channel 36]
    • Router 1 - 2.4 GHz : WPA2Enterprise (PEAP-MSCHAPv2)/AES [Preferred PHY N/Channel 11]
    • Router 1 - 5 GHz : WPA2Enterprise (PEAP-MSCHAPv2)/AES [Preferred PHY A/Channel 157]
  • Execute the BasicAssociation() test steps as described in WLAN Association Tests - Custom Configuration with FIPS mode enabled
  • This test does not perform any power transition tests.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing
TestNFIPS | Internal Parameter


WLAN Roaming Tests - Custom Configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0933024-4837-4a7e-bf75-26a12eef3b2b

This test suite validates that the WLAN adapter roams correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test allows the test scheduler (user) to run the WLAN Scan Tests with specific parameters. For each of the APs the user can specify the following via one of the CustomAP[1|2]Config[24|5]GHz:

  • SSID Broadcast Setting: Hidden or Visible
  • EAP Phase 1 Type: NONE or EAP_PEAP or EAP_TTLS
  • EAP Phase 2 Type: NONE or MSCHAPV2
  • Authentication Algorithm: OPEN or WEP or WPAPSK or WPA or WPA2PSK or WPA2
  • Cipher Algorithm: NONE or WEP or TKIP or AES
  • Channel: Integer Channel Number
  • Phy Type: A or B or G or N or AC

Below are the examples of AP Configs used by some of the tests:

  • Hidden.NONE.NONE.open.none.11.g
  • Visible.NONE.NONE.WPA2PSK.AES.44.n

This test performs the following actions:

  • If CustomAPConfig parameters are specified, configure two routers, that are named Router 0 and Router 1, as below. If parameters are not specified, the test does nothing
    • Router 0 - 2.4Ghz : Configured by user parameter Test_CustomAP1Config24GHz
    • Router 0 - 5Ghz : Configured by user parameter Test_CustomAP1Config5GHz
    • Router 1 - 2.4Ghz : Configured by user parameter Test_CustomAP2Config24GHz. Except for the Channel and PhyType, other parameters must match Test_CustomAP1Config24GHz
    • Router 1 - 5Ghz : Configured by user parameters Test_CustomAP2Config5GHz. Except for the Channel and PhyType, other parameters must match Test_CustomAP1Config5GHz
    • Router 0 and Router 1 share the same SSID for their 2.4Ghz radios.
    • Router 0 and Router 1 share the same SSID for their 5Ghz radios.
    • For roaming purposes, network address translation (NAT) is enabled on both routers.
  • If Sudden Drop Of Signal testing is enabled (bit 0x1 set in Test_CustomRoamingTestOptions), execute the SuddenDropOfSignal() test steps below
  • If Sudden Loss Of Signal testing is enabled (bit 0x2 set in Test_CustomRoamingTestOptions), execute the SuddenLossOfSignal () test steps below
  • If Gradual Drop Of Signal testing is enabled (bit 0x4 set in Test_CustomRoamingTestOptions), execute the GradualDropOfSignal () test steps below
  • If Gradual Loss Of Signal testing is enabled (bit 0x8 set in Test_CustomRoamingTestOptions), execute the GradualLossOfSignal () test steps below

The SuddenDropOfSignal() test performs the following actions. This test is performed first on 5 GHz (if adapter supports 5GHz) and then 2.4 GHz

  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn on the radio on both routers.
  • Turn off the radio on Router 1.
  • Set the txpower1 on both routers to 84.
  • Connect to the profile by using WLANConnect and wait for WLANConnect to complete by using WLAN notifications.
  • After IP address is available on the test adapter, poll the TCP server on the AP controller to confirm that full network connectivity is available.
  • Create a connection to TCP server that is called Connection C. Send and receive packets.
  • Turn off the radio on Router 1.
  • Using Connection C, send and receive a packet. This ensures that the networksession is not dropped.
  • Use the GetConnectionAttributes WLAN API to verify that the association is correct and the connection is on Router 0 .
  • Turn on the radio on Router 1 on, and turn off the radio on Router 0.
  • Using Connection C, Send and receive a packet. This ensures that the network session is not dropped. The connection takes some time to roam.
  • Use the GetConnectionAttributes WLAN API to verify that the association is correct and the connection is on Router 1.
  • Turn on the radios on both routers.
  • Using Connection C, send and receive a packet. This ensures that the network session is not dropped.
  • Set the txpwr1 on Router 0 to 84.
  • Set the txpwr1 on Router 1 to 4.
  • Using Connection C, send and receive a packet. This ensures that the network session is not dropped.

The SuddenLossOfSignal() test performs the following actions. This test is repeated for both 5 GHz and 2.4 GHz.

  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn on the radio on both routers.
  • Turn off the radio on Router 1.
  • Set the txpower1 on both routers to 84.
  • Connect to the profile by using WLANConnect and wait for WLANConnect to complete by using WLAN notifications.
  • After IP address is available on the test adapter, poll the TCP server on the AP controller to confirm that full network connectivity is available.
  • Create a connection to TCP server that is called Connection C. Send and receive packets.
  • Turn on the radio on Router 1 ,and turn off the radio on Router 0.
  • Using connection C, Send and receive a packet. This ensures that the networksession is not dropped.
  • Uses the GetConnectionAttributes WLAN API to verify that the association is correct and the connection is on Router 1 by.
  • Turn on the radio on Router 0, and turn off the radio on Router 1.
  • Using connection C, send and receive a packet. This ensures that the network session is not dropped. The connection takes some time to roam.
  • Use the GetConnectionAttributes WLAN API to verify that the association is correct and the connection is on Router 0.
  • Turn the radio on Router 1 on and the radio in Router 0 off.
  • Using connection C, Send and receive a packet. This ensures that the networksession is not dropped.
  • Use the GetConnectionAttributes WLAN API to verify that the association is correct and the connection is on Router 1.
  • Turn on the radio on Router 0, and turn off the radio on Router 1.
  • Using connection C, send and receive a packet. This ensures that the network session is not dropped.
  • Use the GetConnectionAttributes WLAN API to verify that the association is correct and the connection is on Router 0.

The GradualDropOfSignal() test performs the following actions. This test is repeated for both 5 GHz and 2.4 GHz.

  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn on the radio on both routers.
  • Connect to the profile by using WLANConnect and waits for WLANConnect to complete by using WLAN notifications.
  • After IP address is available on the test adapter, poll the TCP server on the AP controller to confirm that full network connectivity is available.
  • Create a connection to TCP server that is called Connection C. Send and receive packets.
  • Set the txpower1 on Router 0 to 4 and Router 1 to 84.
  • Reduce the txpwr1 of Router 0 by 10 and increase the txpwr1 of Router 1 by 10.
  • Using connection C, sends and receives a packet. This ensures that the network session is not dropped.
  • Repeat the last two steps until the txpwer1 of Router 0 is 84 and the txpwr1 of Router 1 is 4.

The GradualLossOfSignal() test does the following. This test is repeated for both 5 GHz and 2.4 GHz.

  • Create a TCP server on the access point (AP) controller server (listen port 7777)
  • Turn on the radio on both routers.
  • Connect to the profile by using WLANConnect and wait for WLANConnect to complete by using WLAN notifications.
  • After IP addres is available on the test adapter, poll the TCP server on the AP controller to confirm that full network connectivity is available.
  • Create a connection to TCP server that is called Connection C. Send and receive packets.
  • Set the txpower1 on Router 0 to 4 and Router 1 to 84.
  • Reduce the txpwr1 of Router 0 by 10 and increase the txpwr1 of Router 1 by 10.
  • When the txpr1 of Router 1 reaches 4, turn off the router.
  • Using connection C, send and receive a packet. This ensures that the network session is not dropped.
  • Repeat the last three steps until the txpwer1 of Router 0 is 84 and the txpwr1 of Router 1 is 4.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing
Test_CustomAP1Config24GHz | Custom config for 2.4GHz radio of first AP (Skip test by default)
Test_CustomAP1Config5GHz | Custom config for 5GHz radio of first AP (Skip test by default)
Test_CustomAP2Config24GHz | Custom config for 2.4GHz radio of second AP (Skip test by default)
Test_CustomAP2Config5GHz | Custom config for 5GHz radio of second AP (Skip test by default)
Test_CustomRoamingTestOptions | Bitmask of options for Custom RoamingTest (0 = default)


WLAN Roaming Tests - OPEN NONE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/050fd9c2-6dfd-411f-a6ea-888e0402adf4

This test suite validates that the WLAN adapter roams correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configures two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : OPEN/NONE [Preferred PHY G/Channel 5]
    • Router 0 - 5Ghz : OPEN/NONE [Preferred PHY A/Channel 36]
    • Router 1 - 2.4Ghz : OPEN/NONE [Preferred PHY G/Channel 11]
    • Router 1 - 5Ghz : OPEN/NONE [Preferred PHY N/Channel 44]
    • Router 0 and Router 1 share the same SSID for their 2.4Ghz radios.
    • Router 0 and Router 1 share the same SSID for their 5Ghz radios.
    • For roaming purposes, network address translation (NAT) is enabled on both routers.
  • Execute the SuddenLossOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration
  • Execute the SuddenDropOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Roaming Tests - WPA2_ENTERPRISE_PEAP_TKIP_AES

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c56738bf-c719-4363-9211-1ba571a780e4

This test suite validates that the WLAN adapter roams correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configures two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : WPA2Enterprise(PEAP-MSCHAPv2)/TKIP [Preferred PHY G/Channel 1]
    • Router 0 - 5Ghz : WPA2Enterprise(PEAP-MSCHAPv2)/AES [Preferred PHY A/Channel 44]
    • Router 1 - 2.4Ghz : WPA2Enterprise(PEAP-MSCHAPv2)/TKIP [Preferred PHY G/Channel 6]
    • Router 1 - 5Ghz : WPA2Enterprise(PEAP-MSCHAPv2)/AES [Preferred PHY N/Channel 36]
    • Router 0 and Router 1 share the same SSID for their 2.4Ghz radios.
    • Router 0 and Router 1 share the same SSID for their 5Ghz radios.
    • For roaming purposes, network address translation (NAT) is enabled on both routers.
  • Execute the SuddenLossOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration
  • Execute the GradualLossOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Roaming Tests - WPA2_ENTERPRISE_TTLS_TKIP_AES

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d164cd67-e025-4e86-b023-fde7f557c47e

This test suite validates that the WLAN adapter roams correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configures two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : WPA2Enterprise(TTLS-MSCHAPv2)/TKIP [Preferred PHY G/Channel 11]
    • Router 0 - 5Ghz : WPA2Enterprise(TTLS -MSCHAPv2)/AES [Preferred PHY A/Channel 40]
    • Router 1 - 2.4Ghz : WPA2Enterprise(TTLS-MSCHAPv2)/TKIP [Preferred PHY G/Channel 1]
    • Router 1 - 5Ghz : WPA2Enterprise(TTLS -MSCHAPv2)/AES [Preferred PHY N/Channel 36]
    • Router 0 and Router 1 share the same SSID for their 2.4Ghz radios.
    • Router 0 and Router 1 share the same SSID for their 5Ghz radios.
    • For roaming purposes, network address translation (NAT) is enabled on both routers.
  • Execute the SuddenLossOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration
  • Execute the GradualDropOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Roaming Tests - WPA2_PSK_AES

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd7a55cd-4f03-42d9-b471-39bd14fe5edc

This test suite validates that the WLAN adapter roams correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configures two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 1]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY A/Channel 44]
    • Router 1 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 9]
    • Router 1 - 5Ghz : WPA2PSK/AES [Preferred PHY N/Channel 36]
    • Router 0 and Router 1 share the same SSID for their 2.4Ghz radios.
    • Router 0 and Router 1 share the same SSID for their 5Ghz radios.
    • For roaming purposes, network address translation (NAT) is enabled on both routers.
  • Execute the SuddenLossOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration
  • Execute the GradualLossOfSignal() test steps as described in WLAN Roaming Tests - Custom Configuration

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Scan Tests - Custom Configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/335b3de2-771f-44a3-90f5-6cc5e7c0d123

This test suite validates that the WLAN adapter scans correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Development
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test allows the test scheduler (user) to run the WLAN Scan Tests with specific parameters. For each of the APs the user can specify the following via one of the CustomAP[1|2]Config[24|5]GHz:

  • SSID Broadcast Setting: Hidden or Visible
  • EAP Phase 1 Type: NONE or EAP_PEAP or EAP_TTLS
  • EAP Phase 2 Type: NONE or MSCHAPV2
  • Authentication Algorithm: OPEN or WEP or WPAPSK or WPA or WPA2PSK or WPA2
  • Cipher Algorithm: NONE or WEP or TKIP or AES
  • Channel: Integer Channel Number
  • Phy Type: A or B or G or N or AC

Below are the examples of AP Configs used by some of the tests:

  • Hidden.NONE.NONE.open.none.11.g
  • Visible.NONE.NONE.WPA2PSK.AES.44.n

This test performs the following actions:

  • If CustomAPConfig parameters are specified, configure two routers, that are named Router 0 and Router 1, as below. If parameters are not specified, the test does nothing.
    • Router 0 - 2.4Ghz : Configured by user parameter Test_CustomAP1Config24GHz
    • Router 0 - 5Ghz : Configured by user parameter Test_CustomAP1Config5GHz
    • Router 1 - 2.4Ghz : Configured by user parameter Test_CustomAP2Config24GHz
    • Router 1 - 5Ghz : Configured by user parameters Test_CustomAP2Config5GHz
  • Turn OFF all radios in adapter
  • Turn ON all radio in adapter
  • Initiate a Scan with Broadcast/NULL SSID (Flush BSS list from adapter before scan).
  • Wait upto 10 seconds for scan to finish
  • For any routers configured for Hidden SSID, Initiate a Scan for that SSID
  • Wait upto 10 seconds for scan to finish
  • Validate all configured routers are available in the scan list. For each router, match SSID, BSSID, Auth, Ciper and Channel.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
IssueMulitpleScans | Internal Parameter
EnableTracing | Yes or No to enable tracing
Test_CustomAP1Config24GHz | Custom config for 2.4GHz radio of first AP (Skip test by default)
Test_CustomAP1Config5GHz | Custom config for 5GHz radio of first AP (Skip test by default)
Test_CustomAP2Config24GHz | Custom config for 2.4GHz radio of second AP (Skip test by default)
Test_CustomAP2Config5GHz | Custom config for 5GHz radio of second AP (Skip test by default)
Test_CustomScanningTestOptions | Bitmask of options for Custom Scanning Test (0 = default)


WLAN Scan Tests - Multiple BSSIDs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78cab329-0dfe-4ed9-9281-79f3b5c7e18d

This test suite validates that the WLAN adapter scans correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Scenario
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : OPEN/NONE/G/Channel 1 - SSID 1
    • Router 0 - 5Ghz : WPA2ENTERPRISE/AES/A/Channel 44 - SSID 2
    • Router 1 - 2.4Ghz : OPEN/NONE/G/Channel 6 - SSID 1
    • Router 1 - 5Ghz : WPA2ENTERPRISE/AES/N/Channel 36 - SSID 2
  • Turn OFF all radios in adapter
  • Turn ON all radio in adapter
  • Initiate a Scan with Broadcast/NULL SSID (Flush BSS list from adapter before scan).
  • Wait upto 10 seconds for scan to finish
  • For any routers configured for Hidden SSID, Initiate a Scan for that SSID
  • Wait upto 10 seconds for scan to finish
  • Validate all configured routers are available in the scan list. For each router, match SSID, BSSID, Auth, Ciper and Channel.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
IssueMulitpleScans | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Scan Tests - Various Auth Cipher Types And Hidden

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba5f3eae-b565-4d9f-9792-63e3152132d4

This test suite validates that the WLAN adapter scans correctly.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Scenario
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : WPAPSK/TKIP/B/Channel 5
    • Router 0 - 5Ghz : WPAENTERPRISE/AES/A/Channel 36
    • Router 1 - 2.4Ghz : OPEN/NONE/G/Channel 11 - Non Broadcast (Hidden) SSID
    • Router 1 - 5Ghz : WPA2PSK/AES/N/Channel 44
  • Turn OFF all radios in adapter
  • Turn ON all radio in adapter
  • Initiate a Scan with Broadcast/NULL SSID (Flush BSS list from adapter before scan).
  • Wait upto 10 seconds for scan to finish
  • For any routers configured for Hidden SSID, Initiate a Scan for that SSID
  • Wait upto 10 seconds for scan to finish
  • Validate all configured routers are available in the scan list. For each router, match SSID, BSSID, Auth, Ciper and Channel.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
Priority | Internal Parameter
TestName | Internal Parameter
IssueMulitpleScans | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Stress Test - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/879993b8-2581-452f-b237-47727101c4f9

This test suite validates that the WLAN adapter driver remains reliable after common WLAN usage scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToWiFiAP.ConnectionToWiFiAP
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure two routers, that are named Router 0 and Router 1, as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES/N
    • Router 0 - 5Ghz : WPA2PSK/AES/N
    • Router 1 - 2.4Ghz : WPA2PSK/AES/N
    • Router 1 - 5Ghz : WPA2PSK/AES/N
  • The following scenarios will be performed for up to 50 minutes
    • Connect and Disconnect - This runs cycles through attempting connection to Router 0 - 2.4GHz and then Router 1 - 2.4GHz
    • Scan - This runs initiates multiple Scans
    • Airplane Mode ON and OFF - This runs cycles through turning OFF and turning ON the radio
  • Before and after the test and periodically between the test scenarios the test will perform a data integrity test which includes:
    • Create a TCP server on the access point (AP) controller server (listen port 80)
    • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual
    • Initiate a WlanConnect using the profile.
    • Wait for IP address on the adapter
    • Connect to the TCP server on the AP controller server to confirm that full network connectivity is available.
  • At the end the test will display the number of times each scenario ran

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
DurationInMinutes | Duration the Test Runs (minimum = 50)
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


Wlan Power Transitions Reliability Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7058483-c986-4577-8790-df81643f8ed8

Validate the Reliability of the WLAN device while doing a number of power transitions

Test details
Specifications
  • Device.Network.WLAN.SupportWakeFromLowPower.WakeFromLowPower
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test
queryTestNetAdapterGUID | Network Adapter GUID of device under test
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
PowerTransitionIterations | The number of sleep/wake cycles to do

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Wlan Power Transitions Reliability Test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cca3427-2cd3-41f5-8dd4-11cd8b458118

Validate the Reliability of the WLAN device while doing a number of power transitions - This test is a WoW64 for ARM64 version of test guid c7058483-c986-4577-8790-df81643f8ed8

Test details
Specifications
  • Device.Network.WLAN.SupportWakeFromLowPower.WakeFromLowPower
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test
queryTestNetAdapterGUID | Network Adapter GUID of device under test
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
PowerTransitionIterations | The number of sleep/wake cycles to do

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation


Wlan Test - Attempt a connection to a non-existent network

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2c57ac94-f46e-4e40-9e23-ae6b0a397542

This automated test creates a wireless profile for a network that does not exist and tries to connect to the non-existent network.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test will do the following:

  • Create a wireless profile for a network that does not exist.

  • Instruct the wireless service to connect to the created profile The device/driver is expected to quickly fail since the network is not visible.

  • If the connection start event is not seen within ten seconds, the test will fail.

  • If the associating message is not seen within eight seconds of connection start, the test will fail.

  • If the connection failure message is not seen within eight seconds of associating, the test will fail.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Attempt a connection to a non-existent network - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1bdd0f33-1d2c-437c-8161-e0d1dc75fafa

This automated test creates a wireless profile for a network that does not exist and tries to connect to the non-existent network.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test will do the following:

  1. Create a wireless profile for a network that does not exist.
  2. Instruct the wireless service to connect to the created profile The device/driver is expected to quickly fail since the network is not visible.
NOTE

Possible Failure Points:

  • If the connection start event is not seen within ten seconds, the test will fail.
  • If the associating message is not seen within eight seconds of connection start, the test will fail.
  • If the connection failure message is not seen within eight seconds of associating, the test will fail.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Check Hosted Network Capable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0dd672ba-55d9-4138-9b9a-129db683506f

This automated test queries whether the device is "Hosted Network" capable.

Test details
Specifications
  • Device.Network.WLAN.SupportHostedNetwork.HostedNetwork
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

The test will check whether the device and driver is hosted network capable. The test will fail if the device or driver reports as not hosted network capable.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Check Hosted Network Capable - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d24e1e1a-a659-4b60-8627-7ddbae382e3e

This automated test queries whether the device is "Hosted Network" capable. If it is it will attempt to start and stop the Hosted Network.

Test details
Specifications
  • Device.Network.WLAN.SupportHostedNetwork.HostedNetwork
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  1. Check to see if Hosted Network is supported on the WLAN adapter
  2. Attempt to start the Hosted Network functionality
  3. Verify the Hosted Network successfully started
  4. Attempt to stop the Hosted Network

If any of the above items fail the test will fail.

NOTE

Hosted Network is an optional feature.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Connect to a WPA2 PSK AES AP

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93197ac8-e6b8-4c2e-8252-b8afead392a8

This automated test creates a wireless profile using the values provided in the two parameters.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

The test does the following:

  • Connect to the wireless network specified using the created profile.

  • If connection success message is not seen from the driver within six seconds, the test will fail.

  • If there is a connection failure, the test will fail.

  • Wait for 60 seconds for the Windows NLM to return network connected status (this waits for DHCP assignment).

  • Choose a target IPv4 address from either the DHCP server on the network or the default gateway (DHCP server has priority).

  • Send ICMP message to the target IPv4 address and expect success.

  • Connect to port 80 of the target address and expect either a HTTP 401 challenge or HTTP 200 success.

Failure to ping the target address or to connect to port 80 of the target address will result in a test failure.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

Make sure that the following are true:

  • The specified SSID is within range of the device

  • The specified password is correct.

  • The target IP address can be pinged.

  • The target IP address is running a web server.

Most home routers (including routers that are specified in the Windows Hardware Lab Kit (Windows HLK)WLAN setup) will satisfy these requirements.

More information

Command syntax

Parameter | Description
WPA2_PSK_AES_SSID | The SSID of a WPA2_PSK_AES network to connect to.
WPA2_PSK_Password | The password for the WPA2_PSK network.

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID | Device id of device under test


Wlan Test - Connect to a WPA2 PSK AES AP - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73436424-e997-46a8-9a9c-efb53a5c570e

Connect to a specified WPA2PSK AES network (Defaults: SSID=kitstestssid Passphrase=password) - This test is a WoW64 for ARM64 version of test guid 93197ac8-e6b8-4c2e-8252-b8afead392a8

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID | Device id of device under test


Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ae2cb26-ea04-4def-8e07-ae7b92e61e1b

Connect to a specified WPA2PSK AES network with sleep resume (Defaults: SSID=kitstestssid Passphrase=password SleepDurationInSec=20, SleepCycleIterations=2)

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
SleepDurationInSec | The amount of time in seconds the device will asleep
SleepCycleIterations | The number of sleep/wake cycles to do
queryTestDeviceID | Device id of device under test


Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0a737ffb-cbd2-41cd-a596-b939fbddc9ec

Connect to a specified WPA2PSK AES network with sleep resume (Defaults: SSID=kitstestssid Passphrase=password SleepDurationInSec=20, SleepCycleIterations=2) - This test is a WoW64 for ARM64 version of test guid 2ae2cb26-ea04-4def-8e07-ae7b92e61e1b

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
SleepDurationInSec | The amount of time in seconds the device will asleep
SleepCycleIterations | The number of sleep/wake cycles to do
queryTestDeviceID | Device id of device under test


Wlan Test - Enable and Disable WFD Autonomous GO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24f9bc8e-591d-4fa0-8dfd-735369428379

This automated test creates a wireless profile that uses the values that are provided in the two parameters and connects to that network.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirect.WiFiDirect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites. Make sure that device has been enabled, drivers are properly installed, and the device is properly inserted.

The test does the following:

  • Connect to the specified wireless network by using the created profile.

  • If the driver does not return a connection success message in four seconds, the test fails.

  • If there is a connection failure, the test fails.

  • Wait for up to 45 seconds for the Windows NLM to return network connected status (this waits for DHCP assignment).

  • Choose a target IPv4 address from either the DHCP server on the network or the default gateway (the DHCP server has priority).

  • Send an ICMP message to the target IPv4 address and expect success.

  • Connect to port 80 of the target address and expect either a HTTP 401 challenge or HTTP 200 success.

  • Failure to ping target address or connect to port 80 of target address results in a test failure.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

Make sure that the following are true:

  • The specified SSID is within range of the device

  • The specified password is correct.

  • The target IP address can be pinged.

  • The target IP address is running a web server.

Most home routers (including routers that are specified in the Windows Hardware Lab Kit (Windows HLK) WLAN setup) will satisfy these requirements.

More information

Command syntax

Parameter | Description
WPA2_PSK_AES_SSID | The SSID of a WPA2_PSK_AES network to connect to.
WPA2_PSK_Password | The password for the WPA2_PSK network.

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Enable and Disable WFD Autonomous GO - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d2f68b9-f4ce-43d1-87ec-898b008c4f12

This automated test enables WifiDirect Autonomous GO, checks for the SSID being broadcast, and then disables Autonomous GO.

Test details
Specifications
  • Device.Network.WLAN.SupportWiFiDirect.WiFiDirect
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Test will tell driver to enable Autonomous GO.
NOTE

Possible Failures:

NOTE

Test will fail if driver cannot return the WifiDirect capabilities.

NOTE

Test will fail if driver returns ConcurrentOperationSupported as false.

NOTE

Test will fail if it cannot retrieve a non-empty SSID.

NOTE

Test will fail if either start or stop of Autonomous GO fails.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Hotspot2 ANQP and GAS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b967267f-8e0a-43c1-9ab2-cc54d388e9c7

Send and receive ANQP messages

Test details
Specifications
  • Device.Network.WLAN.SupportHotspot2Dot0.Hotspot2Dot0
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Hotspot2 ANQP and GAS - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a2117d6-c80b-40b7-9532-fc8e1e8cd8a1

Send and receive ANQP messages - This test is a WoW64 for ARM64 version of test guid b967267f-8e0a-43c1-9ab2-cc54d388e9c7

Test details
Specifications
  • Device.Network.WLAN.SupportHotspot2Dot0.Hotspot2Dot0
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - MAC Randomization test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f27109b8-54ce-4279-8276-f5d2b8cb71f3

This automated test checks to make sure the wlan device has properly implemented the MAC address randomization feature.

Test details
Specifications
  • Device.Network.WLAN.SupportMACAddressRandomization.MACAddressRandomization
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented WLAN MAC Address Randomization. This test does the following:

  1. enables the mac randomization option
  2. connectes to a wpa2psk network
  3. disables the mac randomization option
  4. connectes to a wpa2psk network
NOTE

Possible Failure Points:

  • Adapter failed to set MAC Address randomization feature
  • Adapter failed to connect to wpa2psk network
  • Adapter failed to clear MAC Address randomization feature

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID | Device id of device under test


Wlan Test - MAC Randomization test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b08f847c-5bc1-45ea-b2da-3fa007429964

This automated test checks to make sure the wlan device has properly implemented the MAC address randomization feature.

Test details
Specifications
  • Device.Network.WLAN.SupportMACAddressRandomization.MACAddressRandomization
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented WLAN MAC Address Randomization. This test does the following:

  1. enables the mac randomization option
  2. connectes to a wpa2psk network
  3. disables the mac randomization option
  4. connectes to a wpa2psk network
NOTE

Possible Failure Points:

  • Adapter failed to set MAC Address randomization feature
  • Adapter failed to connect to wpa2psk network
  • Adapter failed to clear MAC Address randomization feature

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
queryTestDeviceID | Device id of device under test


Wlan Test - Query All Reported Oids

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26568a8c-39cb-46ef-b8b8-e1bc835b05c1

This automated test verifies the driver reports mandatory OIDs as supported

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

The test completes the following:

  • Queries NDIS for all implemented OIDs that the driver returned during miniport initialization.

  • Compares the resulting list against all required OIDS listed here: http://msdn.microsoft.com/en-us/library/windows/hardware/ff571095(v=vs.85).aspx.

The test will fail if any of the required OIDs listed on MSDN are not reported by the driver during miniport initialization.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Query All Reported Oids - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0a2e1d4-394d-4076-ac20-0a7d655f69b5

This automated test queries all reported oids.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. The test completes the following:

  1. Queries NDIS for all implemented OIDs that the driver returned during miniport initialization.
  2. Checks each for a valid return code
NOTE

Possible Failure Point:

  • The test will fail if any of the reported OIDs return invalid data or crashes the machine.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Query Interface Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38099fc3-b893-4165-9727-5d4ce70d479e

This automated test queries the interface for a variety of common properties.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test queries the device for the following properties:

  • IsMediaStreamingEnabled

  • IsBackgroundScanEnabled

  • IsSafeModeSupported

  • sSafeModeCertified

  • GetCurrentOperationMode

  • GetInterfaceState

  • sManagementFrameProtectionSupported

  • IsHostedNetworkCapable

  • enumerate all radios and radio states

  • IsAutoConfigEnabled

  • enumerate all support infrastructure cipher pairs

  • devices without Connected Standby must enumerate supported adhoc cipher pairs

  • GetBSSMode

  • GetCountryList

  • GetConnectionAttributes

  • GetRSSi

  • GetChannel

Any returned failure in the WLAN service API from the device these capabilities are queried will result in a failure in the test

The test will fail if the following is true:

  • There are less than three infrastructure cipher pairs.

  • If DOT11_AUTH_ALGO_RSNA_PSK is not implemented.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Query Interface Properties - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/365d7beb-e1c6-4477-ad91-f736cbabcb6d

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test queries the device for the following properties:

  • IsMediaStreamingEnabled
  • IsBackgroundScanEnabled
  • IsSafeModeSupported
  • sSafeModeCertified
  • GetCurrentOperationMode
  • GetInterfaceState
  • sManagementFrameProtectionSupported
  • IsHostedNetworkCapable
  • enumerate all radios and radio states
  • IsAutoConfigEnabled
  • enumerate all support infrastructure cipher pairs
  • devices without Connected Standby must enumerate supported adhoc cipher pairs
  • GetBSSMode
  • GetCountryList
  • GetConnectionAttributes
  • GetRSSi
  • GetChannel

Any returned failure in the WLAN service API from the device these capabilities are queried will result in a failure in the test

NOTE

Possible Failure Points:

  • There are less than three infrastructure cipher pairs.
  • If DOT11_AUTH_ALGO_RSNA_PSK is not implemented.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Scan for Networks

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/65eac5b5-219f-459a-a8be-b53b96d96a28

This automated test issues a scan request and enumerates networks after the scan.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test will do the following:

  • Test will disable the device.

  • Test will enable the device.

  • Test will start a scan with the option to flush set to true.

  • Test will fail if scan complete event is not returned in less than six seconds.

  • Test will fail if a scan failure event is returned.

  • Test will enumerate available networks after a completed scan.

  • Test will fail if there are no networks in the enumerated list.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Scan for Networks - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1205c9a8-ac68-4ac7-8656-64efe85a663e

This automated test issues a scan request and enumerates networks after the scan.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test will do the following:

  1. Test will disable the device.
  2. Test will enable the device.
  3. Test will start a scan with the option to flush set to true.
  4. Test will enumerate available networks after a completed scan.
NOTE

Possible Failure Points:

  • Test will fail if there are no networks in the enumerated list.
  • Test will fail if scan complete event is not returned in less than six seconds.
  • Test will fail if a scan failure event is returned.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Toggle airplane mode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1559752d-39a8-4b28-a79f-13eff48dc06d

This automated test toggles the radio states in the same way as the user interface airplane mode option.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

The test completes the following:

  • Disables each radio that is reported to the operating system..

  • Each radio must change state and report its updated state in less than ten seconds.

  • Enables each radio that is reported to the operating system.

  • Each radio must change state and report its update state in under ten seconds

The test allows for and can accommodate devices that change the state of all radios when only one radio is requested.

The test will only fail if an exception is thrown when attempting any of the above tasks, or if radios do not change state within the time required.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Toggle airplane mode - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f5c9607-eb30-43aa-9eb4-c5e994e33f29

This automated test toggles the radio states in the same way as the user interface airplane mode option.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. The test completes the following:

  1. Disables each radio that is reported to the operating system.
  2. Each radio must change state and report its updated state in less than ten seconds.
  3. Enables each radio that is reported to the operating system.
  4. Each radio must change state and report its update state in under ten seconds

The test allows for and can accommodate devices that change the state of all radios when only one radio is requested. The test will only fail if an exception is thrown when attempting any of the above tasks, or if radios do not change state within the time required

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Wlan Device Capabilities Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1949bd77-a684-463f-9512-6812657b8706

This automated test checks to make sure the WLAN device is properly reporting its capabilities to Windows.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Queries the system for the adapter capabilities

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Wlan Device Capabilities Check - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/efdacab3-52bc-42a0-81ae-0cad900db51f

This automated test checks to make sure the WLAN device is properly reporting its capabilities to windows

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Queries the system for the adapter capabilities

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Wlan Device enumeration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78796efa-d844-4ccb-ab95-5bc54f002410

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites. Make sure that device has been enabled, drivers are properly installed, and the device is properly inserted.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Wlan Device enumeration - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5918a9ce-1281-4c24-b70f-584c7347c3df

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Wlan Device Reset Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab3df3e5-1f37-46e4-9da9-a9663c803fb5

This automated test runs the following test five times: Wlan L2 Test 02 - Connect to a WPA2 PSK AES AP (strict).

NOTE

Microsoft will be accepting 802.11ad WDI drivers for HLK certification for the Windows 10 Fall Creators Update (1709) to facilitate broad distribution and testing among Windows Insiders and ecosystem partners. However, due to the lack of broad testing of 802.11ad WDI functionality, this feature is enabled as a developer preview for the Windows 10, version 1709 release.

If a problem is encountered with 802.11ad functionality, please contact your 802.11ad IHV partner for support assistance. Microsoft is committed to supporting 802.11ad Wi-Fi connectivity in a future version of Windows 10 in order to enable wireless docking and other scenarios.

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites. Make sure that device has been enabled, drivers are properly installed, and the device is properly inserted.

The test runs the following test 5 times: Wlan L2 Test 02 - Connect to a WPA2 PSK AES AP (strict). Any error encountered in any of the five attempts will fail the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Command syntax

Parameter | Description
WPA2_PSK_AES_SSID | The SSID of a WPA2_PSK_AES network to connect to.
WPA2_PSK_Password | The password for the WPA2_PSK network.

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


Wlan Test - Wlan Device Reset Check - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/782846ed-7b82-4cd4-9bfb-4058ca4dc10f

This automated test checks to make sure the wlan device has properly implemented the reset recovery functionality

Test details
Specifications
  • Device.Network.WLAN.SupportConnectionToAP.ConnectionToAP
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented Wlan Hang Detection and Recovery. This test does the following:

  1. Initiate a hang in the adapter
  2. Verify the adatper was removed
  3. Verify the adapter was re-enumerated
NOTE

Possible Failure Points:

  • Adapter was not removed from the system
  • Adapter was not re-enumerated by the system

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
queryTestDeviceID | Device id of device under test


WLAN Wake - Association Lost - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/798d6fe1-39ea-4800-b782-add4e7aa6b04

This automated test validates the Wake by Association Lost functionality. The device should enter the D2 state after pressing power button. The device should wake by association lost during the D2 state.

This test is not applicable to devices that support InstantGo.

Test details
Specifications
  • Device.Network.WLAN.SupportWakeFromLowPower.WakeFromLowPower
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure one router, as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 6]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY N/Channel 40]
  • Perform a Scan and validate that the router is found
  • Validate that the adapter is reporting itself as AOAC capable and reports the NDIS_WLAN_WAKE_ON_AP_ASSOCIATION_LOST_SUPPORTED capability
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual.
  • Perform a WlanConnect using the profile
  • Configure the AP controller server machine to turn off the Router 0 - 2.4 GHz after 2 minutes 30 seconds
  • Disable other Network Adapters on the Client machine
  • Start monitoring WLAN state and adapter power state events
  • Enter Connected Standby for 5 minutes
  • Enable other Network Adapters on the Client machine
  • Check the WLAN state and adapter power state events to validate that the adapter went to low power and woke up due to AP Association loss as expected

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Wake - GTK Refresh - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1c42c33-84c4-4a86-99f0-327f12c1df44

This automated test validates the NOT wake by GTK refresh functionality. The device should enter the D2 state after pressing power button. The device should not wake by GTK refresh during the D2 state.

Test details
Specifications
  • Device.Network.WLAN.SupportWakeFromLowPower.WakeFromLowPower
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 14
Category | Scenario
Timeout (in minutes) | 840
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure one router, as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 6]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY N/Channel 40]
  • Perform a Scan and validate that the router is found
  • Validate that the adapter is reporting itself as AOAC capable and reports the NDIS_WLAN_WAKE_ON_GTK_HANDSHAKE_ERROR_SUPPORTED capability
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual.
  • Perform a WlanConnect using the profile
  • Configure the AP controller server machine to perform WLAN connect to and WLAN disconnect from and WLAN reconnect to router 0 - 2.4 GHz after 2 minutes 30 seconds
  • Disable other Network Adapters on the Client machine
  • Start monitoring WLAN state and adapter power state events
  • Enter Connected Standby for 5 minutes
  • Enable other Network Adapters on the Client machine
  • Check the WLAN state and adapter power state events to validate that the adapter went to low power and did not wake up due to GTK Refreshes while it was in low power state

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Wake - NLO Discovery - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49b4cb63-642f-4e20-9508-359f747fcbbd

This automated validates the wake by NLO discovery functionality. The device should enter the D2 state after pressing the power button. The device should wake by NLO discovery during the D2 state.

Test details
Specifications
  • Device.Network.WLAN.SupportWakeFromLowPower.WakeFromLowPower
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Scenario
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Configure one router, as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 6]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY N/Channel 40]
  • Perform a Scan and validate that the router is found
  • Validate that the adapter is reporting itself as AOAC capable and reports the NDIS_WLAN_WAKE_ON_NLO_DISCOVERY_SUPPORTED capability
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as automatic.
  • Perform a WlanConnect using the profile
  • Configure the AP controller server machine to turn off the Router 0 - 2.4 GHz immediately and turn it on after 2 minutes 30 seconds
  • Disable other Network Adapters on the Client machine
  • Start monitoring WLAN state and adapter power state events
  • Enter Connected Standby for 5 minutes
  • Enable other Network Adapters on the Client machine
  • Check the WLAN state and adapter power state events to validate that the adapter went to low power and woke up due to NLO indication as expected

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


WLAN Wake - Packet Tests - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/437516a6-ab8c-424b-a34b-3b5c7df32b9e

This automated test validates the wake by packet functionality. The device should enter the D2 state after pressing power button. The device should wake by packet during the D2 state.

This test is not applicable to devices that support InstantGo.

Test details
Specifications
  • Device.Network.WLAN.SupportWakeFromLowPower.WakeFromLowPower
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 14
Category | Scenario
Timeout (in minutes) | 840
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Network additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

This test performs the following actions:

  • Install custom protocol driver on Client machine to allow adding specific wake pattern and on AP machine to allow sending raw packets matching that pattern
  • Configure one router, as follows:
    • Router 0 - 2.4Ghz : WPA2PSK/AES [Preferred PHY G/Channel 6]
    • Router 0 - 5Ghz : WPA2PSK/AES [Preferred PHY N/Channel 40]
  • Perform a Scan and validate that the router is found
  • Validate that the adapter is reporting itself as AOAC capable and reports the NDIS_PM_WOL_BITMAP_PATTERN_SUPPORTED capability
  • Create a profile for Router 0 - 2.4 GHz having ConnectionMode configured as manual.
  • Perform a WlanConnect using the profile
  • Check the wake up capabilities of the adapter and depending on support capabilities (in no specific order) execute WakePacket() test steps below for the following test wake patterns:
    • A randomly created bitmap pattern
    • An IPv4 TCP SYN pattern
    • An IPv6 TCP SYN pattern
    • An IPv4 wildcard destination address pattern
    • An IPv6 wildcard destination address pattern

The WakePacket() Test case performs the following actions for a pattern specific test case

  • Configure the AP controller server machine to send the specified pattern packet after 2 minutes 30 seconds
  • Add the pattern to the WLAN adapter
  • Disable other Network Adapters on the Client machine
  • Start monitoring WLAN state and adapter power state events
  • Enter Connected Standby for 5 minutes
  • Enable other Network Adapters on the Client machine
  • Check the WLAN state and adapter power state events to validate that the adapter went to low power and woke up due to receipt of the pattern

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Wireless LAN (802.11) Tests.

More information

Parameters

Parameter name | Parameter description
TestDeviceSupports5ghz | This should be set to TRUE if the device supports 5ghz networks and FALSE if it does not
APControllerIPAddress | Internal Parameter
LocalDir | Internal Parameter
AP1IPAddress | IP Address of the first AP connected to the system
AP1Password | Root password for the first AP connected to the system
AP2IPAddress | IP Address of the second AP connected to the system
AP2Password | Root password for the second AP connected to the system
ServiceAPChannelAddress | Internal Parameter
TestDll | Internal Parameter
TestName | Internal Parameter
EnableTracing | Yes or No to enable tracing


Device.Network additional documentation

In this section

  • IPsec Task Offload v2 Testing Prerequisites
  • IPsec Task Offload v2 Test
  • IPsec Task Offload v2 Manual Test
  • LAN Testing Prerequisites
  • Troubleshooting LAN Testing
  • Mobile Broadband Testing Prerequisites
  • Router Testing (Non-wireless) Prerequisites
  • Wireless LAN (802.11) Testing Prerequisites
  • Troubleshooting Wireless LAN (802.11) Tests
  • Wireless Router Testing Prerequisites
  • Troubleshooting Wireless Router Testing
  • Troubleshooting Device.Network Testing
  • Device.Network.Switch.DAL-TOR Test
  • MBN WHLK Content for a CDMA Device
  • MBN WHLK Content for a GSM Device
  • Supported Network Hardware
  • WI-FI Direct Performance Scenario Tests
  • Running Network Switch Certification Tests
  • QosRemoteSettings Troubleshooting


IPsec Task Offload v2 Testing Prerequisites

This section describes the IPsec Task Offload v2 testing prerequisites that you should complete before testing your network adapter using the Windows Hardware Lab Kit (Windows HLK). The Network Driver Interface Specification (NDIS) test suite includes test jobs that verify Internet Protocol Security (IPsec) functionality. If your network adapter supports IPsec, you must complete the IPsec-specific NDIS test jobs to certify your device.

NOTE

This content applies to both standalone network and integrated network devices.

Hardware requirements

This hardware is required for testing:

  • IPsec offload-capable network adapters.

  • Two test computers that meet the Windows HLK prerequisites. For more info, see Windows HLK Prerequisites.

    NOTE

    The test computers must be in the same machine pool.

  • Three identical LAN test devices.

  • Two 100 MB switches. Gigabit Ethernet switches are also supported.

  • An Ethernet crossover cable.

To be included in the Windows HLK, the device must pass the certification tests for both x86 and AMD64 platforms.

A Windows HLK setup for LAN (Ethernet) device testing consists of a test server (controller) and test computers (clients).

Software requirements

To run Device.Networking tests, you need any drivers that aren't shipped with the operating system.

Test computer configuration

IPsec functionality testing requires two computers. One hosts the device being tested, while the other receives and sends data to the test device. The computers also need a separate line of communication to exchange information about ongoing tests. For example, it's beneficial for the receiver of a Send test to know how much data is coming.

The suggested setup for LAN device testing consists of a test server that has the Windows HLK Studio software installed, and three test computers that have the Windows HLK Client software installed.

The following diagram shows the relationship between these computers.

Here's a summary of each computer shown, devices installed on them, and their role during testing.

  • Windows HLK Studio computer. Used to manage all of the client computers during testing.

  • Windows HLK Controller computer. Used to control client computers and gather all test information from them.

    NOTE

    Windows HLK Studio and Windows HLK Controller can run on the same test server, which can help reduce setup complexity.

  • Windows HLK Client 1 computer. During the LAN device testing, this computer, is referred to as the remote test machine, or Network Driver Interface Specification Test (NDISTest) server. It contains these network devices:

    • Remote support device. Communicates with the Windows HLK controller. It also communicates test status information to the local support device in the local test computer via the support network.

    • Remote message device. Communicates with the local test device in the local test computer via the test network.

  • Windows HLK Client 2 computer. During device testing, this computer is referred to as the local test machine, or NDISTest client. It contains these network devices:

    • Local test device. The device under test. During testing, it communicates to the remote message device in the remote test machine via the test network.

    • Local message device. Communicates with the controller. It also communicates test status information to the remote support device in the remote test machine via the support network.

    • Other local devices. The NDISTest 6.5 (PM and WoL) job requires that any local device other than local test and local support devices be disconnected from the network.

We recommended that the backchannel switch be on the same network that the clients use to communicate with the controller, and that the network be DHCP-enabled.

The following diagram shows

lan machine topology

The following table matches device roles with interface aliases.

Device role | Interface alias
Test machine, test target (DUT) | No name necessary; jobs automatically choose it.
Test machine, message device | MessageDevice
Support machine, support device | SupportDevice0
Support machine, message device | MessageDevice

You can use Windows HLK Studio to schedule the LAN device test jobs on the clients that are registered on the controller. The following steps summarize the scheduling procedure.

To schedule LAN device test jobs

  1. In Windows HLK Studio, enter all of the information that the LAN device test job needs, and then schedule the job.

    NOTE

    Test computers must be in the ready state before testing begins. If a test requires parameters to be set before it's run, a dialog box is displayed for that test. Review the specific test topic for more information.

The LAN device test job requires two Windows HLK test computers. For your submission, you will also need three identical network cards. These requirements are enforced when you configure the Windows HLK job.

  1. Windows HLK Studio sends job configuration information to the controller, which reserves the clients and dispatches the job to them.

  2. The clients run the job. They first copy the NDISTest and all related files, which is the actual LAN device test tool, to the clients and run the NDISTest on the computer using the credentials of the user that's currently signed in.

  3. When the test finishes, the log files are gathered and copied on the controller.

Some Windows HLK tests require user intervention. When running tests for a submission, it's best to run manual and automated tests separately. This prevents a manual test from interrupting completion of an automated test.

Overview of changes in network device selection

For LAN device testing, message and support adapters are no longer selected in the UI--they must be renamed on the test and support machines before running tests. Renaming refers to the device's ifAlias, which is visible from the Network Connections window, among other places.

The following image shows

network connections dialog box

The support device on the support machine needs to be renamed to " SupportDevice0". The message devices on both the test and support machines need to be renamed to " MessageDevice".

We have provided a job that tries to automatically detect the network configuration and rename the devices accordingly. You have the option of using this job (recommended), renaming the devices manually, or writing your own renaming script or tool.

Device selection criteria

The test and support machines must be set up in the same configuration shown in the following figure.

Any Ethernet devices/ports not involved in testing must be disconnected or disabled. The reconfigure job uses these criteria to find the message device:

  1. Ethernet device

  2. Link connected

  3. Enabled

  4. TCP bound

  5. IP address assigned using DHCP

The message adapter is typically connected to the controller and standard corporate network. When the message device is found, the job searches the remaining adapters for a support device that's an Ethernet device, link connected, enabled, and doesn't have a DHCP-assigned IP address.

Running the renaming job

The renaming job automatically displays when an Ethernet device is selected as a target. It's named Configure network devices for LAN testing and it must run before any test job. The Windows HLK doesn't guarantee a run order when multiple jobs are scheduled, so the configuration job must be run alone.

To run an automatic renaming job

  1. Create a new project and select only the target device. Don't select message or support adapters.

  2. Select the Configure network devices for LAN testing job and clear all other jobs as shown in the following image.

  3. Click Run Selected. The Parameters/Machine Set dialog appears. Change the value of the Reconfigure parameter to YES as shown in the following image.

  4. Select Support from the Role list box as shown in the following image.

  5. Assign your support machine to the Support role by checking its box. Click OK to schedule the renamed job, and then wait for it to complete.

  6. Go to the Results tab to view the logs. Open the autoconfigure.wtl log from both machines.

  7. Review the logs to ensure that the script automatically detected the correct devices.

Preparing for IPsec Task Offload v2 testing

Before running tests, you must first configure the system and install the operating system.

Many of the tests in the Windows HLK require a test system to restart (often more than once) to complete a test run. The test description and the running instructions specify whether a test requires a system restart. Although these tests programmatically restart the test system, you must manually sign in to the test system after each system restart so that the test run can resume. You can avoid this requirement by enabling autologon functionality on the test system. For more info about autologon, see Running with autologon enabled.

After you install the Windows HLK Controller, Studio, and Client software, you can monitor the status of the clients through Windows HLK Studio. The clients are grouped into logical machine pools that the controller monitors. New clients are automatically placed in the default pool.

Before LAN testing can begin, you must first create your own machine pool to hold the DTM clients. To do this, drag the DTM client from the default pool into your machine pool and wait for its status to change to Ready.

Related topics

Device.Network Testing


IPsec Task Offload v2 Test

The procedures presented in this section outline the process for testing your IPsec Task Offload v2 for proper functionality with the Microsoft Windows operating system. These procedures use the Microsoft Windows Logo Kit (WLK) and Windows Hardware Lab Kit (Windows HLK). To ensure full functionality, you must run all of the tests that the Windows HLK identifies as required for the device.

IPsec Tov2 logo tests use SupportDevice0 on support machine and test target on the test machine. Thus both these network adapters need IPsec Tov2 capability. Building on top of 'Running the LAN tests in the HCK' as described in section 8 of this document, the following steps demonstrate how to run IPsec Tov2 logo tests:

  1. In the HLK studio, create a new project under the Project tab.

  2. In the Selection tab of the HLK studio, select the machine pool in which the test machine is located.

  3. Select Device Manager, and select the network adapter on which the tests are to be run.

  4. In the Tests tab the IPsec Tov2 Logo Test will appear. Select the test and choose Run Selected (found near the top).

  5. The Machine Set dialog box will show up. Select Client and Support machines using the drop down box. Client will be selected by default, but the checkbox needs to be selected for the support machine. The tests will start after clicking ok on the dialog box.

  6. The Results tab shows the step-by-step progress of the tests. The logs are also available once the tests complete.

After you complete the preceding steps, the job is ready for scheduling. After you click Schedule Jobs, DTM Studio will send the job to the DTM controller and dispatch the job on the designated DTM client machines.

You can also put multiple configured jobs into the configured job list first, and then schedule them in one batch. After the test is finished, the log files are gathered and copied on the DTM controller.

The "IPsec Offloadv2 logo verification (Win7)" job tests to verify the support for IPsec Offloadv2. These end-to-end tests require a minimum of two machines. These tests plumb different types of IPsec policies and trigger traffic between these machines and measure characteristics of traffic, IPsec negotiations, and offloaded SA counts. In particular the test suite contains tests for:

  1. Algorithm Testing for IPv4: This test suite ensures that IPsec Task Offload v2 behaves correctly on different variations of algorithms of Authentication and Encryption for IPv4 traffic. Following combinations of algorithms are tested:

    • AH[AESGMAC128]TCP

    • AH[AESGMAC128]TCP_authIP

    • AH[AESGMAC192]TCP

    • AH[AESGMAC256]TCP

    • ESP[None,GCM128]TCP

    • ESP[None,GCM192]TCP

    • ESP[None,GCM256]TCP

    • ESP[GCM128,GCM128]TCP

    • ESP[GCM192,GCM192]TCP

    • ESP[GCM256,GCM256]TCP

    • AH+ESP[GCM128,GCM128]TCP

    • AH+ESP[GCM192,GCM192]TCP

    • AH+ESP[GCM256,GCM256]TDP

    • AH[AESGMAC128]UDP

    • AH[AESGMAC192]UDP

    • AH[AESGMAC256]UDP

    • ESP[None,GCM128]UDP

    • ESP[None,GCM192]UDP

    • ESP[None,GCM256]UDP

    • ESP[GCM128,GCM128]UDP

    • ESP[GCM192,GCM192]UDP

    • ESP[GCM256,GCM256]UDP

    • AH+ESP[GCM128,GCM128]UDP

    • AH+ESP[GCM192,GCM192]UDP

    • AH+ESP[GCM256,GCM256]UDP

    • AH[AESGMAC128]UDP_authIP

  2. Algorithm Testing for IPv6: This test suite does the above testing for IPv6 traffic.

  3. Data Testing for IPv4: This test suite ensures that IPsec Task Offload v2 behaves correctly on these scenarios:

    • Protocols: TCP, UDP and ICMP traffic

    • Different data sizes (Large size packet to exercise LSO offload)

    • Different rekey intervals to test removals and additions of Offload SAs

    • Tunnel mode

    • Multiple security associations

  4. Data Testing for IPv6: This test suite does the above testing for IPv6 traffic.

As part of the logo test a service called ScenarioService gets installed on the clients. Details about this can be found in IPsec Task Offload v2 Manual Test.

Anatomy of a Test Case

The test script (Tov2Logo.xml in %SystemDrive%\iketest\suites) contains the details of all test cases. ScenarioService uses this XML file for running all tests. A test XML file is broadly divided into the following XML tags:

  • Config: Sets up the machine for the tests within the script. This mostly includes setting up private IP addresses for the test network, adding routes if necessary, and so on. This section also includes the cleanup once testing is complete.

  • Group: This is a logical construct for grouping tests within a specific area of testing.

  • Test: Title and description of each test variation.

  • Action: This tag corresponds to actions needed to be performed by a Client. The controller sends signals to each Client in the sequence defined by the action number. For the same action number, all Clients perform the encompassed actions asynchronously and return control to the Controller. Only when all Clients complete their action does the Controller send the signal for starting the next action.

Understanding the logs

The following screen captures illustrate a sample test log for one test variation with comments explaining the entries:


IPsec Task Offload v2 Manual Test

This topic describes how to manually test IPsec Task Offload.

Before starting, be sure that ScenarioHarness.msi is in the [SystemDrive]\iketest\ folder, and add it to your PATH environment variables.

Test Software Preparation Steps

Test installation steps are nearly the same for both the machines with some unique steps for each machine. The machine which controls the logo test process is called the IPsec_Controller and the other machine is called the IPsec_Client. In the following context, IPsec_Controller-machine-name is the Windows machine name of the IPsec_Controller role and IPsec_Client-machine-name is the Windows machine name of the IPsec_Client role. Both of these names are unique to the corporate or local network naming convention or configuration requirements. Notice that the tests running on the IPsec_Controller machine would need to know the IP addresses of the IPsec_Client in order to control the traffic flow and program behavior.

  1. Perform the logo test kit setup as machine local administrator with UAC enabled.

  2. Create a test directory [SystemDrive]\iketest on your Windows 8 system (for example, C:\iketest).

  3. Copy the file with name ScenarioHarness.msi provided by Microsoft DNT Test team to the [SystemDrive]\iketest directory.

  4. Issue cd [SystemDrive]\iketest.

  5. On the IPsec_controller machine, perform the setup step by running the command as follows:

    msiexec /lvx install.log /passive /i ScenarioHarness.msi AgentConfiguration="[AgentConfiguration]" PeersConfig="[PeersConfig]" [AdditionalOptions]

    Name Type Value

    AdditionalOptions

    String

    AgentConfiguration

    String

    tcp=port:8081 rename=yes useasdefault=Microsoft.CoreNetworking.IPSec.NetshPolicy

    InstallDirectory

    String

    [SystemDrive]\iketest

    PeersConfig

    String

    peers=""Client1:tcp://IPsec_Controller-machine-name:8081/ Client2:tcp://IPsec_Client-machine-name:8081/""

For example:

c:\\iketest&gt;msiexec /lvx install.log /passive /i ScenarioHarness.msi AgentConfigu ration="tcp=port:8081 rename=yes useasdefault=Microsoft.CoreNetworking.IPSec.NetshPolicy" PeersConfig="peers=""Client1:tcp://27-3145E737:8081/ Client2:tcp://27-3145E751:8081/"""

Where:

IPsec\_Controller-machine-name = 27-3145E737IPsec\_Client-machine-name = 27-3145E751

  1. On the IPsec_client machine, perform the setup step by running the command as follows:

    msiexec /lvx install.log /passive /i ScenarioHarness.msi AgentConfiguration="[AgentConfiguration]" PeersConfig="[PeersConfig]" [AdditionalOptions]

    Name Type Value

    AdditionalOptions

    String

    AgentConfiguration

    String

    tcp=port:8081 rename=yes useasdefault=Microsoft.CoreNetworking.IPSec.NetshPolicy

    InstallDirectory

    String

    [SystemDrive]\iketest

    PeersConfig

    String

For example:

c:\\iketest&gt;msiexec /lvx install.log /passive /i ScenarioHarness.msi AgentConfiguration="tcp=port:8081 rename=yes useasdefault=Microsoft.CoreNetworking.IPSec.NetshPolicy" PeersConfig=""

  1. After the Test software installation, the next step is to examine the configuration file and to make some adjustments to accommodate local environment specific setting.

  2. First examine the IPsec_Controller's configuration files found in [SystemDrive]\iketest folder. There are two configuration files on the IPsec_Controller machine. Assuming 10.199.48.214 and 2001:4898:1b:1040:2046:c2fb:5a16:d1c1 are the (CorpNIC's) IPv4 and IPv6 addresses of IPsec_Controller's machine respectively, you should expect something like this in one of the configuration files called Microsoft.CoreNetworking.ScenarioServer.config.

  3. Next, examine the IPsec_Controller's controller configuration by opening the following file:

  4. There is one configuration file on the IPsec_Client machine. Examine the IPsec_Client's scenarioServer configuration Microsoft.CoreNetworking.ScenarioServer.config. It should have the IPsec_Client's IPv4 and/or IPv6 addresses registered as well.

    This configuration file defines how the IPsec_Controller machine test kit program would communicate with the local and the remote IPsec_Client test programs to perform the logo certification process. The IPsec_Controller and IPsec_Client IPv4 and IPv6 addresses should all be registered in this configuration file.

  5. The scenarioHarness.msi setup step attempted earlier would install the test software as well as enable a test service called ScenarioService. Issue the following command on both IPsec_Controller and IPsec_Client machines to make sure the service is ready for the test.

    If the scenario is in RUNNING state, this verifies that the ScenarioService is ready to perform the logo test.

    If you have made changes to any of the test configuration files, you must stop the Windows NT Service 'scenarioService' and restart it (for example, net stop scenarioservice && net start scenarioservice).

    Also if your test machines corpnet interface is assigned with DHCP addresses, these addresses assigned to your corpnet NIC might have a defined address lifetime based on the DHCP lease limit. In typical circumstances, we expect the tests to be performed immediately after installation. In the case when these IP addresses changed as result of address renewal or you try to perform the test after a prolonged period, you must update these configuration files manually again and recycle the 'scenarioService' service.

  6. If the NIC Adapter is not enabled for IPsec Offload, you will have to enable that. Windows 8 will have a Windows PowerShell script to enable the IPsec Offload adapter IPsec TaskOffload later. For the time, use the IHV specific operation to enable the IPsec Task Offload capability.

  7. To make sure the testNIC would not conflict with your corpnet IP address ranges, please examine the file tov2logo.xml in the [SystemDrive]\iketest\Suites folder for the hardcoded IP addresses for testNIC. Proceed to run the tests if there is no address conflict.

  8. On the IPsec_Controller machine, perform the following command to start the test (as Administrator and UAC enabled):

    C:\iketest>CPerseus.Exe /module:c:\iketest\Suites\tov2logo.xml /type:"IPSec Scenario Testing Add-in"

    The following is a screen image of how the IPsec Task Offload v2 WLK test in progress looks like:

    test in progress

  9. The test should begin if the configuration is setup properly. The test program will automatically configure the testNIC to run the tests for both IPv4 and IPv6 modes.

  10. To run the individual test cases:

    1. Run the Perseus Studio ([SystemDrive]\iketest\PerseusStudio.exe) from IPsec_Controller machine. This is the UI version of the above explained cmdline execution.

    2. Select "Profile" INVALID USE OF SYMBOLS "Add-module". Select module type: "IPSec Scenario Testing Add-in" and click "ok". Browse to "[Systemdrive]\iketest\Suites\TOv2Logo.xml" and click open.

    3. The module will be loaded in the Perseus Studio, visible on the left hand side pane. Select the appropriate checkboxes in front of the tests you desire to run.

    4. Choose "Start Profile Execution in Process" or press F5 to start the test execution.

    5. The progress of the execution and corresponding logs will be visible on the right hand side pane. All the logs will also be placed in the appropriate locations as in the case with the cmdline execution of these tests explained above.

  11. Generated log files:

    • The main log file "TOv2Logo.xml.wtl" will be placed in [Systemdrive]\iketest directory. This can be opened using the HLK manager.

    • The individual test case failure logs are placed in [Systemdrive]\iketest\Logs directory.

    • The detailed traces including wfp, ndispcap and netmon logs are available in the [Systemdrive]\iketest\traces directory.


LAN Testing Prerequisites

The content in this section describes the LAN (Ethernet) testing prerequisites that you should complete before testing your network adapter using the Windows Hardware Lab Kit (Windows HLK).

NOTE

This content applies to both stand-alone network adapters and integrated network devices.

Document Terms

Device Role | Interface Alias
Test machine, test target (DUT) | No name necessary, HLK jobs will automatically choose it
Test machine, message device | MessageDevice
Support machine, support device | SupportDevice0
Support machine, message device | MessageDevice
LWF driver | NDIS Light Weight Filter driver

Machine topology

The following diagram shows the recommended machine topology. Topologies that differ from this are highly discouraged as they may require extra effort in order to get the tests running correctly.

lan machine topology

This is the topology that applies to all LAN devices (including devices which support QoS and Chimney).

Test connections

The back-to-back connection is preferred in general as it takes away the possibility of the switch from interfering with the test (VLAN misconfigurations, flow control packets, and so on)

A back-to-back connection is required for tests which a network switch may interfere with the result. Such tests include:

  • QoS (aka. DCB) (priority flow control, LLDP/DCBX interop, ETS (as some switches may strip 802.1p tags)

  • Tx Flow Control

  • Tests which send 802.1q-tagged (VlanSendRecv, VMQ, 1c_priority, maybe others)

Backchannel/corporate network

It is recommended that the backchannel switch be the same network which the test machines will use to communicate with the HLK controller. It is recommended that this network be DHCP enabled.

Machine requirements

The machine requirements are often dictated by the features which the test target supports. Certification on client SKUs will require 2 processing cores while certification on server SKUs will require 4 processing cores.

NOTE

The term cores refers to physical processing cores (not virtual or hyper-threaded cores). If your device supports advanced features such as the ones below, then the minimum system requirements may be increased.

  • Wake-on-LAN: system must support power management (S3)

  • RSS: maximum of either 4 physical cores or the default number of RSS queues supported by the device

    • Example: if a 1G NIC supports 2 queues, the number of required cores would be 4

    • Example: if a 10G NIC supports 8 queues, the number of required cores would be 8

  • Server/QoS: Systems must be capable of saturating 90% of max link rate

  • QoS: storage target writes at 20% of max link rate

NOTE

If send/receive packet loss problems happen frequently and throughout the test, it's not likely a selective suspend problem.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Machine configuration

Some tests require unique configuration that is not or cannot be automatically taken care of by test jobs. The below list outlines which tests require unique configurations.

QosStorageInterop

The test target on the DUT machine must have connectivity to network-based storage using either iSCSI or SMB. The test machine topology is such that the test network is back-to-back which means the support machine must also serve as a storage target. This means a software iSCSI target must be configured on the SUT or an SMB share must be shared out. The DUT machine must map the storage target to a drive letter and the user must ensure that this connection flows over the test network and not the backchannel network. Once configured, you must input two additional parameters to this job at schedule time:

  • Drive letter

  • Storage mode (iSCSI or ND (Network Direct))

Selective suspend

The NDIS Selective Suspend feature may have a negative impact on test results. Many of the network certification tests assume a device is in a powered-on and ready-to-use state. Thus, many of the tests may quickly send or receive traffic and expect all packets to be sent or received appropriately. If a device is in low power (Selective Suspend), it may take a short while for the device to resume which may result in packet loss during the resume period.

Microsoft recommends configuring *SelectiveSuspend to disabled if the following are true (note: do not change the default value, just the operational value while running the certification tests):

  • A customer has a selective suspend capable device

  • Send/receive tests are experiencing packet loss problems

  • Send/receive test packet loss problems are only in the FIRST variation of a given test

Overview of changes in network device selection

For LAN device testing, message and support adapters are no longer selected using a UI--they are automatically detected based on the network topology. If the automatic detection fails because the network topology is different than recommended topology, the devices need to be renamed on the test and support machines before running tests. Renaming refers to the device's "ifAlias" which is visible from the Network Connections window among other places.

If renaming is required, the support device on the support machine needs to be renamed to "SupportDevice0". The message devices on both the test and support machines need to be renamed to "MessageDevice".

network connections dialog box

Automatic device selection criteria

The test and support machines must be set up in the same configuration as Figure 4 and all other Ethernet devices/ports not involved in testing need to be disconnected or disabled. The test jobs use the following criteria to find the message device: Ethernet device, link connected, enabled, TCP bound, IP address assigned using DHCP. Detection will include adapters with static IP addresses if no adapters are with DHCP assigned addresses are found. The message adapter is typically connected to the HLK controller and normal corporate network. Once the message device is found the job searches the remaining adapters for a support device that is an Ethernet device, link connected, and enabled.

Running the LAN tests in the HLK

Please refer the HLK help for information on setting up the controller and the client machines.This document only deals with the execution of LAN content in the HLK.

Once the Controller and Client machines are setup, follow these steps for running the LAN tests:

  1. Create a project in HLK studio.

  2. Create a new machine pool, and add the client machines that were setup to the newly created pool, and mark the machine status as ready.

  3. Make sure the test machine and support machine are connected as described in the Device Selection Criteria section above.

  4. Select only the device/driver to be tested (such as device manager or software device), in the Selection tab of HLK studio.

  5. Select the jobs that appear in the list on the Tests tab of the HLK studio.

  6. Click Run Selected, and choose the Support machine for the test run, and click OK.

Running filter logo tests

Use the following steps to run lightweight filter (LWF) logo tests:

  1. Setup/Configure the DTM Server and the DTM Client machines. Filter Logo tests need just the one client machine.

  2. Install the LWF driver on the client machine.

  3. Restart the client machine.

  4. From DTM server, add the client on which the LWF is installed to a new machine pool, and change the machine status to 'Ready'.

  5. From HLK studio, create a new project under the 'Project' tab in HLK Studio.

  6. In the 'Selection' tab of the HLK studio, Select the machine pool that was created in the previous steps from the dropdown.

  7. Click software device, and select the installed LWF driver you want to test.

    lwf logo test

  8. Run the all tests (the 'NDISTest 6.5 - LWF Logo Test' checks for all the LWF requirements) listed in the Tests tab against the LWF driver.

NDISTest 6.5 - LWF logo test

This test targets LWF by ensuring that the filter is able to process packets that are larger than miniport's MTU size.

This also runs a filter stress test to stress the datapath and PNP paths of NDIS filter drivers. The test will limit the test virtual miniports receive descriptors such that a significant number of receive indications will happen with the receive resources flag. The test will then conduct the following actions in a multi-threaded manner:

  • Stress traffic from the support miniport directed to the test miniport.

  • Stress traffic from the test miniport directed to the support miniport

  • Stop/start the test miniport (which will trigger a pause and subsequent restart operations).

  • Test adapter indicating media disconnected/connected.

  • Test adapter resetting.

    Finally, basic send and receive connectivity will be tested between the test/support adapters.

Related topics

Device.Network Testing


Troubleshooting LAN Testing

To troubleshoot issues that occur with Device.Network tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

If the two machines LAN test jobs fail it is probable that the tests are not able to detect the message and/or support devices on either of the two machines.

To quickly diagnose this type of problem, run the "NDISTest 6.5 - [2 Machine] - CheckConnectivity" job. This job only takes a couple minutes to run but will tell you if the machines can communicate and are ready to run the rest of the two machine jobs.

If there is a connectivity issue, the job will fail in the "Run NDISTest Client" task. The job's log files will list failures when the test and support NICs cannot communicate bidirectionally. Review the results in the job's log files, check the machines' connections, and try running the job again.

You should also check that you are selecting the correct machine as the support machine. With multiport NICs and multiple machine setups, it is very easy to select the wrong NIC or wrong machine. We suggest keeping the two machines running LAN tests in their own machine pool to avoid accidentally selecting the wrong machine.

The NDISTest 6.5 - [2 Machine] - CheckConnectivity job

The NDISTest 6.5 - [2 Machine] - CheckConnectivity job ensures that the test and support devices can communicate correctly by doing a basic send and receive.

If the "Run script to detect devices and populate parameters" task is marked as failed, the device autodetection failed. Double click detect.wtl to open the autodetection log to determine which device was not detected.

Autodetection of the devices will only work if machines are set up in the recommended topology. The test machine needs to contain the target NIC and the message NIC. The support machine needs to contain a support NIC and a message NIC. Any additional connected Ethernet devices will make autodetection impossible and will require the devices to be renamed to denote their roles.

The support NIC needs to be connected to the test NIC using a direct connection (no switch or hub) in order to avoid interference. The message NICs are the same NIC used for connectivity to the controller machine and the rest of the lab or corporate network.

The CheckConnectivity script logic

The autodetection script logic is as follows:

  1. Find the message NIC.

    1. Search for devices named "MessageDevice".

    2. If not found, search for the Ethernet NIC with a DHCP assigned IP address.

    3. If still not found, search for the Ethernet NIC with a statically assigned IP address.

    4. If nothing is found, fail and exit.

  2. If running on the support machine, find the support NIC.

    1. Search for devices named "SupportDevice0".

    2. If not found, search for a physical, enabled Ethernet NIC that is not the message NIC.

    3. If nothing is found, fail and exit.

Full details of the autodetection script logic can be found by examining the script which is located at: \\[CONTROLLER]\Tests\[ARCH]\NDIS\Scripts\detect.wsf

Where:

[CONTROLLER]. The name of the controller computer.

[ARCH]. Either x86 (for x86-based processors) or amd64 (for x64-based processors).

Reading the NDISTest Logs

One way to read NDISTest logs is to double click "ndistest.wtl" or right click the task result and go to "Additional files" for the job result you want to view. This will open the DTM Manager log viewer.

NDISTest also produces HTML logs which are often much more readable. To view the HTML log for a result, right click the task result and go to "Additional files". There will be several files listed; open the checkconnectivity.htm file under the "Client" folder.

Additionally open "ndistest.htm" from the "Client" folder to view failures from the preconfig and postconfig tasks that run before and after each NDISTest 6.5 test.

Related topics

Device.Network Testing

Troubleshooting Windows HLK


Mobile Broadband Testing Prerequisites

This section describes the tasks that you must complete before you test an audio device by using the Windows Hardware Lab Kit (Windows HLK).

NOTE

The wireless testing of mobile phones verifies support for 802.11 capabilities. However, the Windows HLK validates basic mobile phone capabilities only for devices based on modems that implement the MSFT IHV RIL interface. For data-only devices that are based on MBIM modems, the Windows HLK does not validate basic mobile phone capabilities.

Before beginning testing, complete the following:

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

NOTE

Software-based Access Points using the Realtek 8185 chipset were deprecated with the release of WLK version 1.3. HLK testing with Software-based Access Points are exclusively supported with Atheros WLAN NICs. Customers that are testing WLAN drivers must use Atheros hardware to complete their submissions. If you have further questions on this, please let us know at wlanndt@microsoft.com.

Hardware requirements

The following hardware is required for LAN device testing. You might need additional hardware if the test device provides bus-specific support. See the test description for each bus-specific test to determine if there are additional hardware requirements.

  • Basic Windows HLK test setup (Controller, Studio, and client systems). See Windows HLK Getting Started

  • One test computer. This test computer must meet the Windows HLK prerequisites. See Windows HLK Prerequisites for more information.

  • One test mobile broadband device.

  • The following SIM cards:

    • 'Home' SIM with data provisioned

    • 'Roaming' SIM with data provisioned

    • 'Home' SIM with no data provisioned

    • 'Roaming' SIM with no data provisioned

    • 'Bad' SIM

    • 'Inactive' SIM

NOTE

The operating systems installed on the test clients must be matching processor architecture versions. If you are Logo testing a 32-bit driver, the DUT, SUT, and Test SoftAP must all have 32-bit versions of Windows installed upon them. For example, you may not use a 64-bit DUT with a 32-bit Test SoftAP.The Ethernet cross over cable can be used in place of the test network when running the NDISTest 6.0 "2c_priority" test job. The cross over cable enables vendors to resolve an switch-related issue. In some cases, a switch will strip the priority header causing this test job to fail.

Software requirements

The following software is required to run the Device.Networking tests:

  • The latest Windows HLK filters and software updates.

Test computer configuration

The following figure provides an overview of the Mobile broadband LAN test setup.

mobile broadband test configuration

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Once your test computers are configured, you are ready to begin testing. Refer to Step 4: Create a project.

Implementing Loopback Test Functionality in MB Devices

This section is intended to provide guidance to mobile broadband (MB) device manufacturers for implementing loopback test functionality in their MB device firmware. Loopback functionality is needed only for passing the Windows Hardware Lab Kit test and is not applicable during normal usage of device.

Loopback testing ensures that the link between host and device is tested for performance with no dependency on the mobile broadband network. A successful pass of this test, by the device, assures that neither the OS stack nor the device firmware is going to be the bottleneck for throughput when the network conditions are right.

NOTE

Loopback functionality is tested only for the IP data traffic because it is in the performance critical path. The scope of this test does not include any other network traffic, such as SMS or USSD. Also, because this is a loopback test that terminates at the device firmware, there is no dependency to the network, SIM, or air interfaces.

Guidance

  • MB device firmware should implement "loopback" APN functionality as explained here. Note that the loopback mode is independent of SIM and PIN lock states.

  • On getting MBIM_CID_CONNECT set request with an ActivationCommand of MBIMActivationCommandActivate and an access string loopback, the firmware should do the following:

    • If the device is already connected, it should respond with a MBIM_STATUS_MAX_ACTIVATED_CONTEXTS.

    • The device should be able to enter loopback mode without registering with a provider.

    • The device should be able to enter loopback mode when its packet service state is detached.

    • The device should respond with a MBIM_CID_CONNECT response using the SessionId, IPType, and ContextType specified in the MBIM_CID_CONNECT request. ActivationState should be MBIMActivationStateActivated, and VoiceCallState should be MBIMVoiceCallStateNone.

    • Enter into loopback mode.

    • The device should respond to additional MBIM_CID_CONNECT set requests with MBIM_STATUS_MAX_ACTIVATE_CONTEXTS until loopback mode is deactivated.

  • While in loopback mode:

    • On getting a MBIM_CID_CONNECT query, the device should respond with a MBIM_CID_CONNECT response using the SessionId, IPType, and ContextType specified in the MBIM_CID_CONNECT request. ActivationState should be MBIMActivationStateActivated, and VoiceCallState should be MBIMVoiceCallStateNone.

    • On getting a MBIM_CID_IP_CONFIGURATION query, the device should respond with a MBIM_STATUS_SUCCESS but not specify any IP addresses.

    • The device will manually be assigned a static IP address by the Windows 8 operating system. The device should not supply an IP address itself, but should respond to MBIM_CID_IP_CONFIGURATION queries as specified above, indicating that it does not have an IP address.

    • Listen for NTBs (NCM Transfer Block) on the BULK OUT pipe from the host.

      • The device should unpack the datagrams from the NTB and send them back to the host on the MBIM Bulk-IN pipe.

      • The device should swap the Source and Destination addresses of IPv4 and IPv6 datagrams. The device should not need to modify the IPv4 checksum and vendor datagrams.

      • NTBs sent on the MBIM Bulk-IN pipe should conform to the NTB parameters specified by the device in the NCM GetNtbParameters function. Datagrams can be sent on the Bulk-IN pipe in one or more NTBs as required by the NTB parameters for the Bulk-IN pipe.

    • On getting a MBIM_CID_CONNECT request with an ActivationCommand of MBIMActivationCommandDeactivate.

      • Ensure that the SessionId matches the SessionId used to start loopback mode. If the SessionId's don't match, the device should respond with MBIM_STATUS_CONTEXT_NOT_ACTIVATED.

      • The device should respond with a MBIM_CID_CONNECT response using the SessionId, IPType and ContextType specified in the MBIM_CID_CONNECT request. ActivationState should be MBIMActivationStateDeactivated and VoiceCallState should be MBIMVoiceCallStateNone.

Resources

MBIM Specification

MB Miniport Driver Performance Requirements

Windows 8 Hardware Certification Requirements

Related topics

Device.Network Testing


Router Testing (Non-wireless) Prerequisites

This section describes the tasks that you must complete before you test an Ethernet router by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for router testing. You might need additional hardware if the test device provides bus-specific support. See the test description for each bus-specific test to determine if there are additional hardware requirements.

  • Basic Windows HLK test setup (Controller, Studio). See Windows HLK Getting Started

  • Four test computers. Each test computer must meet the Windows HLK prerequisites. See Windows HLK Prerequisites for more information.

  • Eleven (11) 10/100 MB Ethernet adapters. Two of these adapters must support QoS 802.1p

  • A minimum of 2 100 megabit switches. More may be needed depending on the number of available Ethernet ports on the device under test.

  • One test router.

NOTE

To certify a router for use with servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM.

Since routers do not include a driver to test, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required to run the Device.Networking tests:

  • The latest Windows HLK filters and software updates.

Test computer configuration

Among the 4 test computers, there are 3 individual configurations. The test computers are designated as LAN1, LAN2, WAN, and SERVER. The test computers labled LAN1 and LAN2 are configured identically. All system requirements are in addition to minimum system requirements for Windows Vista, Windows 7 and Windows 8. The following network schematic illustrates how each is connected in the network:

diagram of machine requirements and configuration

NOTE

Although not illustrated above, the Windows HLK Studio and the Windows HLK controller can be running on one computer to reduce the cost of the setup.

Before you begin testing your router, configure each of the four test computers and the machine pool according to the procedures described in the next sections.

In addition, your router must be configured as follows before you begin your testing:

  • Make sure the DHCP server for the router is enabled.

  • You must set the WAN port to this static IP address: 17.1.1.1.

  • Make sure that the UPnP setting is enabled, if it's not enabled by default.

Configuring LAN1 and LAN2

The test computers identified as LAN1 and LAN2 have an identical setup procedure described below:

  1. Install the appropriate Windows operating system on LAN1.

  2. Install three network adapters in LAN1 (including one of the two that supports QoS 802.1p).

  3. Connect two of the Ethernet cards to the LAN side of the router via Ethernet cable. One of these two must be the QoS 802.1p-capable network adapter.

  4. Connect the third Ethernet adapter to your test network.

  5. Open the Network Connections folder (this can be done by clicking Manage Network Connections in Network Center).

  6. Rename the network connections such that:

    1. The connection to the DTM network is named DTM.

    2. The connection to the LAN side of the router with the QoS -capable interface is named LAN_P.

    3. The remaining interface that is connected to the LAN side is named LAN.

  7. Enable QoS 802.1p on the LAN_P connection (consult individual interface card manual if you are unsure how to do this)

  8. Make sure all of the connections are marked Private in the Network Sharing Center.

  9. Install the Windows HLK client application on both LAN 1 and LAN2. See Step 2: Install Client on the test system(s) for more information.

  10. Run the configuration jobs: Setup Machine LAN1 and Setup Machine LAN2 for Machine Lan1 and Machine2, respectively. These jobs will set Static IP addresses and setup machine dimensions for each machine as follows:

    Interface LAN1 LAN2

    LAN

    192.168.0.10

    192.168.0.20

    LAN_P

    192.168.0.11

    192.168.0.21

    Test

    IP Address assigned by DHCP

    IP Address assigned by DHCP

  11. For each machine, run ipconfig at a command prompt to verify that each interface has correctly assigned IP address.

  12. To ensure IP connectivity on all interfaces try to ping other addresses. If firewall is enabled, then open the ping exception by typing the following command at a command prompt: netsh firewall set icmpsettings 8.

  13. Make sure that all network connections are set to Private in the Network Center in the Control Panel.

    NOTE

    In order to ensure that your test network remains set to Private, you can set a policy to do this automatically by running gpedit.msc from a command prompt (as an Administrator) and modifying the settings for "Unidentified Networks".

Configuring WAN1

The test computer identifies as WAN1 should be configured using the following steps:

  1. Install the appropriate Windows operating system on the test computer.

  2. Install two network adapters in WAN1.

  3. Connect one network adapter to the WAN side of the router. Because most routers only have one port for the WAN interface, a hub can be used (as shown in the diagram).

  4. Connect the other network adapter to the test network.

  5. Open the network connections folder (this can be done by clicking Manage Network Connections in the Network Center in the Control Panel.

  6. Rename the network connections as follows:

    1. The connection to the Test network is named Test.

    2. The connection to the WAN side of the router is named WAN.

  7. The wireless connection needs be associated with the router's wireless network.

  8. Install the Windows HLK client application. See Step 2: Install Client on the test system(s) for more information.

  9. Run the Setup Machine WAN1configuration job. These jobs will set static IP addresses and set up machine dimensions as follows:

    Interface WAN1

    WAN

    17.1.1.10

    Test

    IP Address assigned by DHCP

  10. From a command prompt, run ipconfig to verify that each interface has a correctly assigned IP address.

  11. Make sure that all interfaces have an IP connection. If a firewall is enabled, open the ping exception by running the following command from a command prompt: netsh firewall set icmpsettigns 8.

  12. Make sure that all network connections are set to Private in the Network Center in the Control Panel.

Configuring WAN2

The test computer identified as WAN2 should be setup using the following steps:

  1. Install the appropriate Windows operating system on the WAN2.

  2. Install three network adapters in WAN2.

  3. Connect two of the network adapters to the WAN side of the router. A switch may be needed to accomplish this.

  4. Connect the remaining network adapter to the Test network.

  5. Open the network connections folder. This can be done by clicking Manage Network Connections in the Network Center in the Control Panel.

  6. Rename the network connections as follows:

    1. The connection to the Test network is named Test.

    2. The connections to the WAN side of the router are named WAN1 and WAN2 respectively.

  7. Install the Windows HLK client application. See Step 2: Install Client on the test system(s) for more information.

  8. Run the Setup Machine WAN2 configuration job. These jobs will set static IP addresses and set up machine dimensions as follows:

    Interface WAN2

    WAN1

    17.1.1.20

    WAN2

    17.1.1.21

    Test

    IP Address assigned by DHCP

  9. From a command prompt. run ipconfig to verify that each interface has correctly assigned IP address.

  10. Make sure that there is IP connectivity on all interfaces. If a firewall is enabled, then open the ping exception by typing the following command from a command prompt: netsh firewall set icmpsettings 8.

  11. Make sure that all network connections are set to Private in the Network Center in the Control Panel.

Machine pool configuration

Proper setup of the machine pool is vital. When the machine pool is not properly configured, scheduled jobs will stay in the status "Scheduler". Configuration of the machine pool allows the Windows HLK controller to assign each individual task to the correct machine. For each of the four machines in the pool, a configuration job will have to be run. This job will set "Dimensions" on that machine which will describe its role in the network.

To run the configurations job, complete the following steps:

  1. Using the Windows HLK Studio, create a machine pool that contains all four test computers.

  2. From the Windows HLK Studio, schedule the tests against the wireless router you are testing.

  3. Select Browse, and then select the job Setup Machine<XYZ> found under WDK Tests\Networking\Routers\Configuration. (Where XYZ correspond to LAN1, LAN2, WAN1 and WAN2)

  4. For LAN1 and LAN2: Enter the MAC address of the LAN side interface of the Wireless Router in the Value field for the IGD_Mac parameter

You may now schedule the router tests to be run.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Wireless LAN (802.11) Testing Prerequisites

This topic describes the process to test a Wireless LAN (WLAN) device to make sure that it functions correctly with Windows. These procedures use the Microsoft Windows Driver Kit (WDK) and Windows Hardware Lab Kit (Windows HLK). To comply with the WLAN Windows Hardware Certification Program, you must run all of the tests that Windows HLK identifies as being required for the device. We also recommend that you work through the tests in order by the following levels: "Basic", "Functional", "Reliability", and "Certification."

NOTE

For a driver to pass testing and obtain Windows Hardware Certification, you must use the latest version of the WDK to compile the driver.

NOTE

WLAN Windows HLK tests that use software-based access points are exclusively supported by using specific Atheros WLAN NICs. Windows HLK customers who test WLAN drivers must use two Atheros WLAN adapters that are installed in the SoftAP Machine to complete their submissions. Only two devices have been specifically tested at the time of Windows 8.1 release: Dlink DWA-552 and Dlink DWA-556. Additional models might have worked in the past and might continue to work, but cannot be guaranteed. If you have questions about this, please contact us at wlanndt@microsoft.com.

The tests to run depend on the capabilities of the device or system that you are testing. For devices that are running on Windows 7, the tests take 13 to 15 hours to run. For devices that are running on Windows 8, the tests take 30-32 hours to run. For devices that are running on Windows 8.1, tests take approximately 36-40 hours to run. These times represent fully passing results. Failures in any test or reboots due to crashes add additional time to the tests. These times can vary slightly by platform and performance of individual machines that are used in the tests.

Windows HLK Setup for WLAN Device Testing

A Windows HLK setup for WLAN device testing consists of the following nine components:

  • A computer that is running Windows HLK Studio. Through this application, you can control and configure the Windows HLK Controller to send jobs to the Windows HLK clients in the Windows HLK system pool. All requirements for a WLAN Windows HLK submission are enforced when the Windows HLK test execution job is configured.

  • A Windows HLK Controller computer. This computer must run Windows Server 2008 R2. (In many cases, this computer can be the same computer that runs Windows HLK Studio.) This component reserves Windows HLK clients in the system pool for a test job. In Figure 1 WLAN Setup, the Windows HLK Controller and Windows HLK Studio machine are represented as one machine.

  • A Device Under Test (DUT), which is a computer that is running the desired operating system and architecture for which you are seeking certification, and on which the device for certification is installed. You must install the Windows HLK Client on this machine.

  • A Support Device Under Test (SUT), which is a computer that is running the same version and processor architecture of Windows as the DUT. The SUT must have a WLAN device installed that is capable of passing all certification tests and has drivers properly loaded. We recommend that you use the same device in both the DUT and SUT.

  • A SoftAP Machine (also known as AP Controller), which is a machine that is running the same processor architecture of Windows as the DUT and SUT. If the DUT is running Windows RT, the SoftAP machine must be running a 32bit version of Windows. The SoftAP Machine should be running Windows 8.1 in all cases. This machine must have two compatible Atheros WLAN adapters installed (Dlink DWA-552 is recommended) and two Ethernet adapters installed, one of which must be capable of reaching 1Gbps. You must install the Windows HLK Client on this machine.

  • Two ASUS RT-N66U routers. See Figure 1 WLAN Setup for configuration details and physical arrangement of the routers.

  • An 802.11AC capable router/access point. See Figure 1 WLAN Setup for configuration details and physical arrangements. The 802.11AC router must support at least the same number of antennas, spatial streams, and max throughput as the DUT. We recommend that you use an ASUS RT-AC66U for testing. Using an 802.11AC router that does not support enough throughput will fail the 802.11 performance tests. You can use the 2.4Ghz side of the 802.11AC router as the AP for Wlan L1 and Device Fundamental tests. You should configure this with WPA2 Personal and an AES cipher. The defaults for these tests use an ssid of kitstestssid and a password of password.

  • An 802.11w-capable access point. This item is unchanged from previous WLAN Windows HLK releases and the previously used access point can be used.

NOTE

Windows Vista and earlier versions of Windows are deprecated and are not supported for any role in the test configuration.

The following table summarizes the configurations:

Test Client | Windows 8.1 Logo | Windows RT Logo | Windows 8 Logo | Windows 7 Logo
DUT | Windows 8.1 | Windows RT | Windows 8 | Windows 7
SUT | Windows 8.1 | Windows RT | Windows 8 | Windows 7
SoftAP | Windows 8.1 | Windows 8.1 32-bit | Windows 8 | Windows 7

Figure 1 WLAN Setup shows the WLAN setup:

Prepare for Wireless LAN (802.11) Testing

RT-N66U (AP1 & AP2) Preparation:

  • The only current supported device for AP1 and AP2 is the ASUS RT-N66U.

  • Make sure that you are using 3.0.0.4.354 or later version firmware. New units might have a compatible firmware version directly out of the box. (We recommend that you keep a copy of working firmware available.)

  • You must pre-configure AP1 and AP2 before you connect them. You can use any of the machines or a separate machine to perform the configuration. During this process, make sure that the computer is connected to the RT-N66U LAN ports by using the Ethernet network only.

  • When you set up a new AP for the first time, we recommend that you skip the Configuration wizard on the aps by navigating directly to: http://192.168.1.1/index.asp .

  • The WAN/Internet ports on both AP1 and AP2 must be configured under the WAN section of Advanced Settings by using a connection type of Static IP. The static IPs that are used must be in the subnet that is being used for gigabit switch 2. (For example: 192.168.100.0/255.255.255.0) Do not use a static IP address that falls within an IP subnet to which the DUT and SUT connect. Switch 1 and switch 2 must use separate and non-overlapping IP subnets.

  • The WAN settings page requires that the Default Gateway, DNS Server1, and DNS Server2 fields are filled out. For ease of configuration, we recommend that you enter the static IP address of Nic 2 on the AP controller (which must be in the same subnet range as the WAN IP Setting).

  • You must disable the firewall in the Firewall section in Advanced Settings.

  • You must enable Telnet on the System tab in the Administration section of Advanced Settings on both AP1 and AP2.

  • For debugging purposes from the AP Controller, we highly recommend that you enable web access from WAN on the System tab in the Administration section of Advanced Settings on both AP1 and AP2.

    IMPORTANT

    When the tests run for the first time, the tests disable all LAN ports on both RT-N66U routers. This is expected. If you want to connect to the APs to verify settings during the testing, use the AP controller and connect over the WAN port by using the provisioned port. The tests enable the LAN ports of each AP as needed during testing. If you need to connect to a LAN port for testing, stop the tests from running and manually power off and on the AP. This action re-enables the LAN ports until the next test starts.

  • You can troubleshoot the tests' ability to connect to the APs by using Telnet.exe to connect to both routers on the WAN IP address from the AP-Controller. If you cannot connect to either AP from the AP-Controller by using the WAN IP address, the username of admin, and password that you configured (default password is admin), the tests cannot connect and will fail.

  • These preparation steps do not apply to the 802.11 AC router in the setup. For the 802.11AC router, configure it to match the maximum bandwidth and spatial streams that your device supports.

Topology Configuration and Preparation:

  • Each line in Figure 1. WLAN Setup represents a connected physical Ethernet cable.

  • AP1 and AP2 must be connected to Gigabit Switch 2 by using the WAN/Internet port.

  • The Ethernet cable between the LAN ports on AP1 and AP2 is required. The connection can be between any LAN port on AP1 to any LAN port on AP2.

  • The AP Controller requires two LAN adapters. One LAN adapter (Nic 1) connects to Gigabit Switch 1 (or equivalent), and the second lan adapter (Nic 2) connects to Gigabit Switch 2. Nic 2 MUST be a gigabit adapter and cannot be a USB Ethernet adapter. This adapter is used to measure 802.11AC performance. The IP address on Nic 1 must be assigned by using DHCP. The IP address on Nic 2 must be statically assigned. This assignment method enables the tests to identify the adapters.

  • Do not use the same IP address space for Gigabit switch 1 and Gigabit Switch 2. They must contain IP/subnet masks that do not overlap. Further, you must use DHCP for address assignment on Gigabit Switch 1 (this can be the same network you typically use for other HLK testing) and the IP range for Gigabit Switch 1 must NOT be in the range 192.168.x.x. We suggest that you use 192.168.100.* for the addressing on gigabit switch 2.

  • The DUT, SUT, AP Controller, and HLK Controller need a hard-wired LAN connection to gigabit switch 1. This cannot be the same switch as gigabit switch 2. A DHCP service must provide IP addresses on gigabit switch 1. If Nic 1 on the AP controller is not assigned an IP address by using DHCP, tests will fail.

  • Each static IP connected to gigabit switch 2 must be unique.

  • Figure 1. WLAN Setup includes some notes to keep regarding IP addresses, SSIDs, passwords, etc. You are prompted for these values during the test runs.

  • Both wireless adapters that are installed in the DUT and SUT must fully support Wifi-Direct. We recommend that you use the same device in both DUT and SUT, or use at least a Windows 8-certified device and driver in the SUT if the DUT is running Windows RT.

  • For devices that support 802.11AC, both the DUT and SUT must contain the same wireless adapter. If the DUT is Windows RT, both must support 802.11AC.

  • Install Network Monitor (Netmon) version 3.4 or greater on the AP controller and reboot if you are testing Windows WLAN feature NDIS Packet Coalescing. This requirement is moved from SUT to AP controller with HCKQFE #4. Netmon is specifically required for the D0 Coalescing Feature Test.

AP Controller Configuration:

  • The AP Controller/SoftAP machine requires two Atheros-based WLAN adapters. We recommend a Dlink DWA-552 device. If you require PCI-Express, Dlink DWA-556 devices also work. The driver that is used for software-based AP testing is the same as for Windows 8 testing; however, these adapters are also used in Wifi-Direct testing in Windows 8.1. If your existing SoftAP machine WLAN cards from Windows 8 properly support Wifi-Direct, you can continue to use them.

  • You do not need to manually install the software-based AP driver on the Atheros adapters during setup. The driver will be automatically installed and uninstalled during the testing process.

  • The AP Controller requires 2 Ethernet adapters. One of these must support gigabit speeds.

  • The Ethernet adapter that is connected to gigabit switch 2 must be a gigabit Ethernet adapter. This requirement ensures unrestricted performance testing.

  • The architecture of the AP controller operating system must match the architecture of the DUT operating system (32bit for x86, 64bit for AMD64). For Windows RT DUT devices, use a 32bit operating system on the AP controller.

  • The AP Controller does not require a single-processor architecture. This detail is adjusted by the test automation.

HLK Pool Configuration:

After you configure the test topology, prepare the test systems for WLAN device testing by performing the following steps:

  1. Set up the following machine configurations by using the previous configuration instructions:

    • One test device on the DUT.

    • One test device on the SUT.

    • Two Atheros chipset devices on the AP Controller.

    • Two Ethernet adapters on the AP Controller

    • Windows HLK Studio and Windows HLK Controller.

  2. Based on the operating system for which you are testing the device, install operating system builds on the Windows HLK clients (three test computers namely DUT, SUT and SoftAP machine) as described in the previous section.

  3. Install HLK controller and HLK studio machine on Windows Server 2008 R2 machine. For more information see Step 2: Install Client on the test system(s).

  4. Install HLK clients on three test computers namely DUT, SUT and SoftAP machine. For more information see the Windows Hardware Certification Step-by-Step Guide. Note that when the DUT is a Windows RT machine, the AP machines must be running a 32bit operating system. When the DUT is a Windows RT machine, the HLK client should be installed from (\\<HCKcontroller>\HCKInstall\WoAClient\setup.exe), where <HCKcontroller> is the name of the Windows HLK Controller.

  5. On the Windows HLK Controller click Start, click All Programs, click Windows Kits, click Hardware Certification Kit, and click Windows HLK Studio.

  6. Click Configuration and then click Machine Management.

  7. Click Create Machine Pool.

  8. Type the machine pool name in the New Pool field and then press Enter. The new machine pool should appear as a node under $ (Root).

  9. Select the Default pool. The Windows HLK Client machines should be listed in the Machines list.

  10. Press and hold the CTRL key and click each of the three defined machines to select all three machines.

  11. Drag the three selected machines to the newly created machine pool.

  12. In the new machine pool, right-click the three machines. Click Change Machine Status and then click Reset. The machines will change from a Not Ready state to an Initializing state and then to a Ready state. During the initialization process, devices on the machine are enumerated and cataloged. It is important for all devices to have been installed by this point.

  13. You can configure additional pools on one Windows HLK Controller by replicating the entire topology and restarting with step 4

  14. If you are using a debugger machine with each topology (in the case of multiple topologies), you can install separate copies of the Windows HLK Studio on additional machines so that more than one tester can share the same controller. Use separate projects for each topology/pool and only use one topology per pool.

Run Wireless LAN (802.11) tests for Certification

The following procedure demonstrates how to run the WLAN device tests:

  1. Open the Windows HLK Studio.

  2. On the Project tab, click Create Project and name the project.

  3. Click the Selection tab.

  4. Select your new machine pool in the dropdown in the upper left and click Device Manager. The list should populate with the names of all the devices that are installed on the machines in that pool.

  5. In the list, locate the WLAN driver under test and check the box next to it.

    NOTE

    There might be more than one WLAN driver listed. Make sure you check the one that is on the DUT. The machine name is listed in the right column.

  6. Click the Tests tab - by default, all the available certification tests that are applicable to selected device will display.

  7. You can filter the displayed list by clicking View by and then selecting additional options, such as Basic, Functional, or Reliability.

    Only Certification tests are required for the certification process; however, running Basic and Functional tests provides a specific set of functionally important tests.

  8. Select the test to run by checking the box on the left next to it. Click Run Selected. You are prompted to add any additional parameters. (You can also check the box next to multiple tests.)

  9. Not all parameters are used for all tests. Only the parameters that are necessary for the selected tests are shown. You can view detailed parameter descriptions by hovering the mouse pointer over the parameter name. Many of the parameters will be derived from the topology notes mentioned above. If you press the F1 key while a test is selected, detailed information on that test and its parameters is shown.

  10. Machine Set section is always present for Functional and Reliability tests. This section represents the machine resources that are necessary to run the tests. You must address all "!" symbols before you click OK.

    1. Select the first test name from the list (if there is more than one).

    2. From the Role menu, select Client - the DUT machine should already be selected and grayed out.

    3. From the Role menu, select Support and check the box next to the SUT Machine.

    4. From the Role menu, select AP and check the box next to the AP Machine.

  11. Click OK to schedule. You can monitor the detailed progress of the tests in Windows HLK Manager, or simply watch as each test result displays in the Status column.

View Results and Log Files

Results and logs can be viewed through Windows HLK Manager or Windows HLK Studio.

In Windows HLK Manager, click Explorers and then click Job Monitor.

When the client machines complete test jobs, you can gather information from the Job Execution Status frame by right-clicking a job and viewing errors, job reports, or result reports. You can also click Browse Job Logs to access NDISTest results.

In HLK Studio, click the Results tab. View the Status column to monitor the results of each test. You can choose each column to sort the results. If a test passes, you will see a green checkmark; if it fails, you will see a red X. For more detailed information on viewing logs, see Step 7: View test results and log files.

Create a Package

After passing all of the necessary tests, you are ready to create an .hlkx submission package for certification.

Windows HLK Studio supports package creation, so you don't have to use a separate submission tool. The package creation feature lets you add necessary resource files to complete the certification. For detailed instructions on how to create a package, see Step 8: Create a submission package.

Notes and Troubleshooting for RT-N66U firmware

The tests are designed to work against RT-N66U vB1 APs that have at least firmware version 3.0.0.4.354. Purchases of new RT-N66U devices might meet this requirement with no firmware upgrades required. If your purchased devices meet this requirement, you can start testing as soon as you complete the configuration instructions described in this topic. Devices that come with a later version of firmware are expected to be compatible. Downgrade to the version 3.0.0.4.354 only in the case of confirmed problems or communication from Microsoft.

We highly recommend that you save a backup of the required software to recover the Aps, as well as a few versions of firmware. Make sure you have backup copies of the following:

  • ASUS Firmware Restoration Utility

  • ASUS RT-N66U B1 Firmware Version 3.0.0.4.354 (if available)

  • Current and/or latest version of ASUS RT-N66U B1 Firmware

You can download these items as follows:

  1. Go to http://support.asus.com and click Download.

  2. Type RT-N66U and then click Search.

  3. Click RT-N66U (Ver.B1) (or applicable version that matches your version).

  4. Next to OS:, select Windows 8 from the OS dropdown menu. Match the architecture to that of the computer you are using for any updates to the APs.

  5. Click + next to Utilities, and download the latest available Firmware Restoration utility.

  6. Click + next to Firmware, and download ASUS RT-N66U B1 Firmware Version 3.0.0.4.354.

    You can also download the latest available firmware for future use.

AP Firmware Troubleshooting

WARNING

Applying new firmware to consumer devices can sometimes, although rarely, cause permanent damage. You must read the device manual that came with your router and be careful when you flash new firmware on a device. Detailed steps, especially around the 30-30-30 reset, are required before flashing.

The most reliable way to install firmware on an RT-N66U device is by using the Firmware Restoration Utility. You might also be able to upgrade firmware by using the web interface. Consult the device manual for instructions. To upgrade firmware by using the restoration tool, the following steps are required. (These steps can also be found in your manual under Firmware Restoration.

  1. Remove power from the device.

  2. Press and hold the reset button on the device.

  3. Turn on/plug in the device keeping the reset button held for 8 seconds.

  4. Release the reset button when the power LED has started to slowly flash on and off.

  5. Connect one computer to one of the LAN ports on the device (do not connect any other ports during this process).

  6. Change the IP address on the computer to 192.168.1.4 with a subnet mask of 255.255.255.0 and no gateway address.

  7. Start the Asus firmware restoration utility.

  8. In the firmware restoration utility, browse for the firmware image you downloaded (version 3.0.0.4.354 or later).

  9. Click the Upload button.

  10. If the upload is successful, multiple progress bars appear. The first progress bar shows the upload of the image to the device; additional progress bars show the overall upgrade process.

  11. Do not use the device, press any buttons, or remove power while the device is being upgraded. We recommend that you leave it alone for 15 minutes.

  12. After the upgrade is successful, you can remove the static IP address from the computer and access the devices web-server at http://192.168.1.1/index.asp to confirm a successful upgrade.

    IMPORTANT

    Every time that you upgrade firmware, after the device has finished the upgrade and has restarted, you should reset the NVRAM settings by performing a 30-30-30 reset. The steps for this are as follows:

    1. When the device is ON and functioning, hold down the WPS button for 30 seconds.

    2. While continuing to hold the WPS button, unplug the device and leave it unplugged for 30 seconds.

    3. While continuing to hold the WPS button, plug the device back in and wait for an additional 30 seconds (90 seconds total).

    4. Release the WPS button. This will cause all LEDs to flash on and off again. The device reboots and goes through a prolonged internal setup process again it becomes functional again.

  13. After the router has restarted to respond to web requests, you can continue the preparation steps documented above starting here: http://192.168.1.1/index.asp .

If a device is no longer functional for any reason, or specifically because of a previous attempt to install firmware that was not compatible, try the following instructions first before you replace the device:

  1. With the device ON, perform the 30-30-30 reset instructions listed above with one modification:

  2. After the 90 seconds of holding the WPS button and removing/reapplying power, as soon as all leds on the device turn on and then off, immediately remove power as quickly as possible.

  3. Before plugging the device back in, hold in the reset button (not wps), then continue to plug in the device. Keep the reset button held for at least 8 seconds, but no more than 10.

    The power LED should be slowly flashing. If it is not, repeat the instructions above.

  4. Perform the Firmware Restoration instructions that are listed above to restore either the default firmware or newly downloaded firmware.

Related topics

Device.Network Testing


Troubleshooting Wireless LAN (802.11) Tests

This topic describes some common troubleshooting tips for WLAN testing. To begin:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Changes that you made to devices on HLK clients machines are not reflected in HLK Studio. For example, the machine is expected to be in the Ready state but it is not.

  1. Open a Command Prompt window on the client machine, and then run net stop wttsvc.

  2. Run net start wttsvc. This command will update the C:\wtt\JobsWorkingDir\AssetCfg\Log\ directory.

  3. Restart the HLK Studio. You might have to wait several minutes for the HLK controller to poll the client machine for changes in its device list.

Machines have not been discovered for the machine pool.

  1. Open the Job Monitor window in HLK Manager.

  2. Select the Show Query Builder button at the top of the screen.

  3. Click the Machine Query tab.

  4. Define search parameters for the machines that you are looking for. Typically, you can set a single rule such as "DataStore equals 'Controller Name'".

  5. Right-click the rule that you just defined, and then click Execute. An extensive list of machines should populate the Machines list below the query fields that you defined.

  6. Drag any machines in the Machines list into new machine pools that you created.

Machines do not seem to run jobs that are scheduled for them.

  1. Check the names of the NICs on the DUT, SUT and AP machines. They must be MessageDevice for the Ethernet and SupportDevice0 and SupportDevice1 for the WLAN NICs. If not rename them manually.

  2. Make sure that for each machine in the pool, status is Ready.

    1. Open the Job Monitor window in HLK Manager.

    2. In the Machine Pool tab, select the machine pool that you expect to be running jobs.

    3. If a machine's status is not Ready, right-click the machine, point to Change Status, and then click Reset.

    4. After a few minutes, refresh the screen and the status will change to Ready.

  3. Schedule and start the jobs again.

Problems with installing the Test SoftAP driver on the topology: Device Manager reports code 52

Do not install the x64 Test SoftAP driver before installing the HLK client. When the HLK client is installed, the Root Certificate is installed. Because the Test SoftAP driver signing depends on installation of the Root Certificate, the device manager reports device code 52.

Configuring NDISTest for stand-alone execution

Installing NDISTest separate from HLK Studio enables you to execute individual tests. A DUT, SUT, and Test SoftAP need to be configured to enable stand-alone execution.

NOTE

All test machines must use the same processor architecture.

NOTE

To troubleshoot the NDISTest, try attaching a debugger to the test machine.

Configuring a Support Device Under Test (SUT)

  1. Copy all NDISTest binaries and sub directories from the following HLK controller:

    \\<ControllerName>\tests\<architecture>\nttest\nettest\ndis\ndistest.net\

    <ControllerName> is the name of the HLK controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors).

  2. Launch NDISTest.exe from the install directory. When the main form opens, select Server from the File menu to launch the server form.

  3. Select the message device from the Message Device list. This device must be IP-enabled and on the same subnet as the client message device that will be set up later.

  4. Select SUT device(s) from Support Devices. The support device selected on this server from will be visible to the client after the server is started.

  5. Select the "server" job from Jobs. This is the server side test that will be launched after you click the start button.

After all the options have been selected, click Start to start the server.

Configuring a Test Software Access Point (Test SoftAP)

  1. Copy all NDISTest binaries and sub directories from the following HLK controller:

    \\<ControllerName>\tests\<architecture>\nttest\nettest\ndis\ndistest.net\

    <ControllerName> is the name of the HLK controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors).

  2. Install SoftAP driver for both of the Atheros WLAN devices on the Test SoftAP. You can install this driver from Device Manager, which you can open by running devmgmt.msc from a command prompt. Complete the following step:

    • In Device Manager, install the driver for SoftAP stations from \\<ControllerName>\Tests\<architecture>\nttest\nettest\ndis\NDISTest.net\SoftAPMiniport\

      <ControllerName> is the name of the HLK controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors), depending on the processor architecture of the HLK client machine that have the SoftAP devices.

  3. Launch NDISTest.exe from the install directory. When the main form opens, select Server from the File menu to launch the server form.

  4. Select the message device from the Message Device list. This device must be IP-enabled device and on the same subnet as the client message device that will be set up later.

  5. Select the AP device(s) from AP Devices. AP devices selected on this server will be visible to the client after the server is started.

  6. Select the "server" job from Jobs. This is the server side test that will be launched after you click the start button.

After all the options have been selected, click Start to start the server.

Configuring the Device Under Test (DUT)

  1. Copy all NDISTest binaries and sub directories from the following HLK controller:

    \\<ControllerName>\tests\<architecture>\nttest\nettest\ndis\ndistest.net\

    <ControllerName> is the name of the HLK controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors).

  2. Launch NDISTest.exe from the install directory. When the main form opens, select Client from the File menu to launch the client form.

  3. Select the test target from the Test Target list. For network device, this test target should be Miniport.

  4. Select the test device from the Test Device list. This must be a vendor-specific test device.

  5. Select a message device from the Message Device list. This should be an IP-enabled device that is on the same subnet as the server message device. After the message device has been selected, the AP device section should be displayed and the server AP device should be available in the list.

  6. Select a support device from Support Devices. This must be a vendor-specific support device.

  7. Select an AP device from AP Devices. This must be the AP device that was select on the server side.

  8. Select the tests from the Jobs section that will be run after the client is launched.

After all the options have been selected, click Start to start the client. Any jobs that were selected will begin execution. Test results will be stored on the client in the following logging sub-folder:

<NDISTestRootFolder>/logs/<AdapterName>/

Configuring Client Packet Capture

  1. Configure a test topology for stand-alone execution. For more information, go to "Configuring NDISTest for stand-alone execution."

  2. Setup a second SUT. For more information, go to "Configuring a Support Device Under Test (SUT)."

  3. Launch NDISTest.exe from the install directory. When the main form opens, select Debug from the View menu to launch the Packet Capture section on the client.

  4. Select a Capture device from Packet Capture. This must be a Support device that was selected on the server side.

  5. From Jobs, select the tests that will be run after the client is launched.

  6. After all of the options have been selected, click Start to start the client.

  7. Packet captures corresponding to the Tests will be generated on the Server with the capture device. The logs will be in the following logging sub-folder:

    <NDISTestRootFolder>/logs/<AdapterName>/

Troubleshooting when the Packet Capture section does not show up on client

Verify that the message center user interface is closed. If the NDISTest user interface is not maximized, the Packet Capture section may be hidden behind the message center user interface.

I want to open a bug. What should I include in the bug:

  • Create a .hlkx package containing the failed tests - see the "Creating a Package" section and attach it to the bug.

  • Failing Logs -Please gather the ndistest logs from the test run and include them with the package in the bug. The logs can be found by doing the following:

  1. Open the HLK Manager

  2. Choose Explorers> Job Monitor

  3. Choose the Machine Pool that you scheduled the tests on.

  4. In the right pane choose the DUT machine.

  5. Under Job Execution Status right click the Job name of the test you ran and select Browse Job logs.

  6. This will open up an explorer window with an AP, Server, and Test directories. Zip these directories and attach them to the bug.

How do I reset my machines after a failed run?

Below is a chart with common problems and solutions.

Symptom | Solution
The VAN UI doesn't show any networks | 1
When I connect my WLAN device to a DHCP enabled network I don't get an IP. | 2
I get strange "Back Channel" failures | 2
The (SUT, DUT, or AP) machine crashed and now all tests are failing | 1,2,3
NDISTest isn't auto finding my test adapter when running through the HLK | 3
The HLK test is failing to populate either a MessageDevice or SupportDevice | 3
I updated my HLK Controller and not my clients and now I am seeing strange crashes and failures that I have never seen before | When moving to a new controller you should also rebuild your clients. In the event that is not feasible you will need to remove ndprot630.sys from all three machines and athr.sys and softap.sys from the AP machine. All these files are in the c:\windows\system32\drivers directory. Ndprot630.sys will be automatically re-loaded when NDISTest is run, but not overwritten. ather.sys and Sofap.sys will need to be copied over from the new controller.
My physical AP's don't seem to be working like before | You may have to reset/reboot your physical ap. If you factory reset it make sure you set the channel and radio per the setup instructions.
I have tried all the steps above but nothing worked | If you have tried the above steps and are still seeing issues you can uninstall then reinstall the WLAN adapter. Make sure when you are done to rename the adapter SupportDevice0.

Related topics

Device.Network Testing

Troubleshooting Windows HLK


Wireless Router Testing Prerequisites

This section describes the tasks that you must complete before you test a wireless router by using the Windows Hardware Lab Kit (Windows HLK).

Hardware requirements

The following hardware is required for wireless router testing.

  • Basic Windows HLK test setup (Controller, Studio, and client systems). See Windows HLK Getting Started

  • Four test computers. Each test computer must meet the Windows HLK prerequisites. See Windows HLK Prerequisites for more information.

  • At least two 100-megabit switches (more may be required depending on the number of available Ethernet ports on the DUT).

Software requirements

The following software is required to run the Device.Networking tests:

  • The latest Windows HLK filters and software updates.

  • Windows 7 client x86 for Windows 7 certification or Windows 8 x86 client for Windows 8 certification.

Test computer configuration

Among the four test computers, there are three individual configurations. The test computers are designated as LAN1, LAN2, WAN, and SERVER. All system requirements are in addition to minimum system requirements for Windows Vista, Windows 7 or and Windows 8. The following network schematic illustrates how each is connected in the network:

wireless router test configuration

NOTE

In the above illustration, Y indicates a computer that is wirelessly connected to the router.

Before you being to test your wireless router, configure each test computer and the machine poll according to the procedures described in the next sections.

Wireless router

The wireless router should have its DHCP server enabled. You will need to set the WAN port to this static IP address: 17.1.1.1. The wireless router should be in a controlled environment with its wireless network open (no security enabled). UPnP™ should be enabled, even if not by default. The 5 GHz radio (if equipped) should be turned off.

Configuring LAN1 and LAN2

The test configuration requires:

  1. Three 10/100 Ethernet adapters (one of which must support QoS 802.1p).

  2. One 802.11a/b/g wireless adapter (the wireless adapter must use an NDIS 6.0-compliant native Wi-Fi driver with WMM support).

  3. Support for QueryPerformanceFrequency and QueryPerformanceCounter APIs (for the Wi-Fi performance test). This requirement is typically supported in modern systems.

The test computers identified as LAN1 and LAN2 have an identical setup procedure. Please replicate the following steps for each machine:

  1. Connect two of the Ethernet cards to the LAN side of the wireless router via Ethernet cable. One of these two must be QoS 802.1p capable.

  2. Connect the third Ethernet card to the HLK network.

  3. Open the network connections folder. This can be done by clicking Manage Network Connections in the Network Center in the Control Panel.

  4. Rename the network connections such that:

    • The connection to the HLK network is named DTM.

    • The connection to the LAN side of the router with the QoS capable interface is named LAN_P.

    • The non QoS capable interface connected to the LAN side is named LAN.

    • The wireless connection is named Wireless.

  5. Ensure all of the connections are marked Private in the Network Sharing Center.

  6. Make sure Network Discovery is enabled in the firewall for all connection types.

  7. Enable QoS 802.1p on the LAN_P connection (for more information, see the card manual).

  8. The wireless connection needs be associated with the router's wireless network.

  9. Run configuration Jobs: "Setup Machine LAN1" and "Setup Machine LAN2" for Machine Lan1 and Machine2 respectively. These jobs will set Static IP addresses and setup machine dimensions for each machine as follows:

    Interface LAN1 LAN2

    LAN

    192.168.0.10

    192.168.0.20

    LAN_P

    192.168.0.11

    192.168.0.21

    Wireless

    192.168.0.12

    192.168.0.22

    DTM

    IP Address assigned by DHCP

    IP Address assigned by DHCP

  10. For each machine, run ipconfig at a command prompt to verify that each interface has correctly assigned IP address.

  11. To ensure IP connectivity on all interfaces try to ping other addresses. If firewall is enabled, then open the ping exception via: netsh firewall set icmpsettings 8.

  12. Make sure that all network connections are set to Private in the Network Center in the Control Panel.

    In order to ensure that your test network remains set to Private, you can set a policy to do this automatically by running gpedit.msc (as an Administrator) and modifying the settings for "Unidentified Networks":

    local group policy editor window

    unidentified networks properties dialog box

Configuring WAN1

The system requirements for WAN1 are as follows:

  • Windows 7 client x86 for Windows 7 certification or Windows 8 x86 client for Windows 8 certification.

  • Two 10/100 Ethernet adapters.

  • One 802.11b/g wireless adapter (the adapter must use NDIS 6.0 compliant native Wi-Fi driver with WMM support.

The test computer identifies as WAN should be setup using the following steps:

  1. Connect one Ethernet card to the WAN side of the wireless router. Because most routers only have one port for the WAN interface, a switch may be used (as shown in the diagram).

  2. Connect the other Ethernet card to the HLK network.

  3. Open the network connections folder (this can be done by clicking Manage Network Connections in the Network Center in the Control Panel.

  4. Rename network connections such that:

    1. The connection to the DTM network is named Test.

    2. The connection to the WAN side of the router is named WAN.

    3. The wireless connection is named Wireless.

  5. The wireless connection needs be associated with the router's wireless network.

  6. Run configuration Job: Setup Machine WAN1. These jobs will set static IP addresses and setup machine dimensions as follows:

    Interface WAN1

    Wireless

    192.168.0.30

    WAN

    17.1.1.10

    DTM

    IP Address assigned by DHCP

  7. Run ipconfig at a command prompt to verify that each interface has a correctly assigned IP address.

  8. Ensure IP connectivity on all interfaces. If firewall is enabled, then open the ping exception via: netsh firewall set icmpsettings 8.

  9. Ensure that all network connections are set to Private in the Network Center in the Control Panel.

Configuring WAN2

The test computer identified as WAN2 should be setup using the following steps:

This computer should have Windows 7 client x86 or Windows 8 client x86 and three 10/100 Ethernet adapters.

  1. Connect two of the Ethernet adapters to the WAN side of the router. A switch may be needed to accomplish this.

  2. Connect the remaining Ethernet adapter to the HLK network.

  3. Open the network connections folder. This can be done by clicking Manage Network Connections in the Network Center in the Control Panel.

  4. Rename network connections such that:

    1. The connection to the HLK network is named HLK.

    2. The connections to the WAN side of the router are named WAN1 and WAN2 respectively.

  5. Run configuration Job: Setup Machine WAN2. These jobs will set static IP addresses and setup machine dimensions as follows:

    Interface WAN2

    WAN1

    17.1.1.20

    WAN2

    17.1.1.21

    HLK

    IP address assigned by DHCP

  6. Run ipconfig at a command prompt to verify that each interface has correctly assigned IP address.

  7. Ensure IP connectivity on all interfaces. If firewall is enabled, then open the ping exception via: netsh firewall set icmpsettings 8.

  8. Ensure that all network connections are set to Private in the Network Center in the Control Panel.

Machine pool configuration

Proper setup of the machine pool is vital. When the machine pool is not properly configured, scheduled jobs will stay in the status "Scheduler". Configuration of the machine pool allows the Windows HLK controller to assign each individual task to the correct machine. For each of the four machines in the pool, a configuration job will have to be run. This job will set "dimensions" on that machine that will describe its role in the network.

To run the configurations job, complete the following steps:

  1. Open up HLK Manager.

  2. Choose Explorers and then choose Job Monitor.

  3. On the left side, select the proper machine pool.

  4. Right click the machine and select Schedule.

  5. Select Browse, and then select the job Setup Machine XYZ found under WDK Tests\Networking\Routers\Configuration. (Where XYZ correspond to LAN1, LAN2, WAN1, and WAN2).

  6. Click Start.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Running the tests

In order to receive certification for a wireless router, you must create a submission which contains all of the run tests. There are three steps to doing this: creating a new Project, running the tests, and creating a submission package to send to Microsoft.

  1. Open HLK Studio.

  2. In the Project tab click Create project - name your project something descriptive.

  3. In the Selection tab select your machine pool from the dropdown. The section below that should populate with all the available devices.

  4. Choose Device Manager in the left column.

  5. Scroll through the list and locate the router you are testing.

  6. There may be more than one listed. Select the one that is listed for the LAN1 machine AND the one that states it's a WDKVirtualDevice_<number> for the Device Instance ID.

  7. On the Tests tab you should see all the tests for the router if you only see a few go back to the Selection tab and make sure you have the correct device selected.

  8. Check the tests you wish to run and click Run Selected.

  9. A secondary window will pop up asking for additional parameters. The parameters break down as follows:

    • Data_BSSID = the BSSID of the router

    • Data_DevicePIN = the WPS PIN of the router

    • ProfileFile = the profile used to connect to the router (see the sustained throughput tests)

    • UUID = the UUID of the router (used for the pnpx test)

  10. Once the parameters are filled in you must ensure you have the correct machines selected in the Machine Set section.

    • To do this simply click the offending Test name and select from the drop down each Role and then check the box next to the machine that corresponds to that role.

  11. Once the Parameters and Machine Set are set click OK.

  12. Test will schedule to run.

  13. Once the tests complete and pass, choose the Package tab and click the Create Package button in the lower right to create the .HLKX package for submission.

Some of the tests have special requirements that must be fulfilled before you can run them. Below is a list of those requirements for each specific test or test category. Please pay close attention as failure to do so may result in unexpected failures.

WCN tests

All WCN tests start with prefix "WCN". The automated tests can be run in any order; the only requirement is that they should be scheduled one at a time.

Before running the tests, make sure the device is plugged in and it is in a configurable state. All of the tests try to configure the device. If the device does not support being configured when it is already configured then the router will need to be reset to a configurable state before running a test.

The WCN Tests uses the UPnP protocol as the underlying transport to configure the device, so ensure the firewall doesn't block UPnP traffic (firewall can be disabled from Control Panel) and SSDP service is not disabled or stopped.

All the jobs require the routers BSSID and WPS PIN. The wireless network BSSID is usually the MAC address of the wireless interface. Available wireless network BSSIDs can be viewed by executing the command netsh wlan show networks mode=bssid on the LAN1 machine. Static WPS pins should be 8 digits and dynamic WPS pins should be 8 or 4 digits.

There should be no wireless profiles on the LAN machines and the machines should not be associated with any wireless networks, before starting the WCN wireless tests. You may see a pop-up on the machine saying the computer could not connect to a particular network. This is expected, please ignore the pop-up.

WCN display WPS pin test

The following test verifies that a Wireless AP properly displays the WPS PIN. When the test is executed you will see the following dialog box on one of the LAN computers. Select Pass or Fail accordingly.

wtt: manual task dialog box

Feature Path: $\WDK Tests\Networking\Routers\WCN

  • WCN Wireless Verify the router has a WPS Pushbutton

Proxy test

The following test verifies that a wireless AP is capable of proxying wireless EAP WPS messages to Ethernet UPnP and vice versa. A router with this functionality allows a Microsoft WCN-capable computer connected to the wireless AP via Ethernet to act as a WPS registrar. The test will act as a WPS registrar on the Ethernet side of the router and a WPS enrollee on the Wireless EAP side of the router. The test will send a WPS M1 message to the AP under test over wireless EAP. The test expects to receive the same WPS M1 message via Ethernet UPnP through the AP under test. The test will then send a WPS M2D message over Ethernet UPnP to the AP under test. The test expects to receive the same WPS M2D message via Wireless EAP through the AP under test

Feature Path: $\WDK Tests\Networking\Routers\WCN Wireless

WCN Wireless M1-M2D Proxy Functionality - Windows 7 only

WCN Wireless Test Proxy Functionality WPS10h Only V2 - Windows 8 only

WCN Wireless Test Proxy Functionality WPS20 Only V2 - Windows 8 Only

Push button auth tests

The following logo tests verify that a Wireless AP is capable of using push button authentication in a Wireless EAP WPS session. The test acting as the registrar will initiate a Wireless EAP WPS configuration session with the AP under test using PIN for authentication. The test will comply with the WPS Protocol and confirm the AP is also using all required attributes in its messages. During the configuration session the test will configure the AP under test to use WPA2PSK AES for its wireless security settings. After completing the Wireless EAP in-band WPS configuration session, the test will wait up to 60 seconds for the AP under test to reboot and apply settings. To confirm the AP under test is properly implementing the wireless settings, the test will use a wireless profile to connect to the AP under test, verify connectivity, and disconnect from the AP under test. The logo test will then act as an enrollee and prompt the user to push the 'WPS Button'. After the user unblocks the logo test by pushing any key, the logo test will establish a Wireless EAP WPS session with the Wireless AP under test using Push Button Authentication (AKA PBC).

Feature Path: $\WDK Tests\Networking\Routers\WCN Wireless

  • WCN Wireless Push Button Auth (Push Button Test) - Windows 7 only

  • WCN Wireless Push Button Auth (Push Button Test) v2 - Windows 8 Only

Registrar discovery test

The Registrar Discovery Test verifies that a Wireless AP is capable of being discovered through an EAP WPS M1-M2D message exchange. The test will act as a registrar and respond to the Wireless AP's M1 request message with a M2D response message. The test expects the Wireless AP to respond to the M2D response message with a NACK request message. The test will then respond with a NACK response. The Wireless AP should end the EAP session with an EAP-Fail message.

****Feature Path: $\WDK Tests\Networking\Routers\WCN Wireless

  • WCN Wireless Registrar Discovery

Compare probe response and M1 message test

The compare probe response and M1 message test will verify that the probe response and M1 message are identical.

Feature Path: $\WDK Tests\Networking\Routers\WCN Wireless

  • WCN Wireless Compare Probe Response and M1 messages

IGD data tests

The IGD Data tests verify the routers ability to route UDP and TCP traffic across the WLAN and LAN networks.

IGD data connection test (verify UPnP is enabled)

Test adds port mappings to router using UPnP interface and then verifies port mapping by sending traffic from WAN machine to LAN machine. Test fails if router doesn't not properly implement UPnP port mapping interface.

IGD data connection test (verifies IGD type is cone or restricted)

Test determines router's NAT type. Test passes if NAT type is cone or restricted. Test fails if NAT type is symmetric

IGD data connection test (verifies ECN does not trigger router reboot)

Test establishes TCP connection through router with Explicit Congestion Notification (ECN) enabled. Test fails if connection is not established.

IGD data transmission UDP test

Test streams UDP data through the router for 8 minutes. Test fails if more than 4 packets are dropped.

IGD data transmission test for Windows scaling

Test performs TCP Windows Scaling checks between a LAN machine and a WAN machine. The test sets the LAn machines scaling factor to 8, sets the WAN machines scaling factor to 3, and restricts auto-tuning. The test fails if TCP connections and data transfers are not properly executed between two machines.

IGD data transmission test for ECN streaming

Test sends and receives data over TCP through router with Explicit Congestion Notification (ECN) enabled. Test fails if data is not properly transmitted and received.

IGD byte counters tests

These tests can be identified by the presence of "TotalBytesSent" or "TotalBytesReceived" in their names. The tests should be run one at a time. Although the sequence is not important it is recommended that the Basic logo tests are ran first.

IMPORTANT

Before running the tests, please perform the following on each LAN-side machine. This is required to make sure that the LAN-side machines can resolve the correct IP address of the WAN machine.

  • The user logged on to the console of the machines has administrator privileges.

  • UPnP is enabled on the IGD.

Wi-Fi performance test

Before running a particular WiFi performance job with a specific wireless configuration (SSID, PHY setting, security settings) one has to setup the tested device properly before the test is started. Because the tests cover different wireless settings it's not possible to schedule all WiFi performance jobs at once. It is possible though to group these jobs based on the given wireless configuration.

It's generally good idea to validate connectivity for a given wireless configuration before the test is started. It means applying a given wireless profile at a machine (L1 or L2) and try if you're able to connect using this profile. The used wireless profiles are stored in \\<your HLK controller>\Tests\x86fre\nttest\NetTest\wireless\apcert\profiles.

For the Windows 7 and Windows 8 certification, there are only two available wireless performance tests. Both use the SSID WINDOWS_LOGO and the pass phrase "Nativewifi". It should also be noted that the Windows 7 wireless performance tests MUST be conducted over open air and not in a shielded room. Details are in the following table.

Test Case | SSID | PHY | Wireless Security | Security Key
Sustained Throughput-802.11G_WPA2-PSK | WINDOWS_LOGO | 802.11g | WPA2-PSK | Nativewifi
Sustained Throughput-802.11N_WPA2-PSK | WINDOWS_LOGO | 802.11n | WPA2-PSK | Nativewifi

Test Case and Wireless Profile Mapping Table:

Test Case | SSID
Sustained Throughput-802.11G_WPA2-PSK | 802_11n_wpa2-psk.xml
802_11n_wpa2-psk.xml | 802_11n_wpa2-psk.xml

XBOX Live router certification tool (2NIC) and 24-Hour UDP traffic test

This test sets up and executes the 2 NIC router certification test. It will start a server machine and a client machine and performs a series of network tests over Ethernet to ensure correctness in the router.

Trademarks

UPnP™ is a certification mark of the UPnP™ Implementers Corporation.


Troubleshooting Wireless Router Testing

To troubleshoot issues that occur with Device.Network tests, follow these steps:

  • Review the Troubleshooting Windows HLK topic.

  • Review the Windows HLK release notes for current test issues.

  • For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Use the following steps to test the ability of a computer to send higher bit rates over an Ethernet connection:

  1. Setup the hardware as shown below with only Ethernet connection.

  2. Assign the IP address to Machine S (for example: 10.0.0.2).

  3. Assign the IP address to Machine C (for example: 10.0.0.3).

  4. Open a command prompt and run Stats tool on Machine C with following parameters:

    stats.exe -z DISCARD -i 20 -x 50 -y 30 -r 20000000 -c 3600 -l -h -u

  5. Open the MS command prompt and run Stats tool at the Machine S with following parameters:

    stats.exe -d 10.0.0.3 -r 20000000 -c 4200 -l -h -u

  6. Observe the output of steps 4 and Step 5.

If the output of either step 4 or step 5 shows any failures then your machines cannot make bit rates using wireless adapters.

To manually add a wireless profile, use the following command:

netsh wlan add profile filename=<xmlfilename> i=\*

For example, to add the 802_11n_wpa-psk.xml wireless profile:

  1. Click Start, click Run, and enter cmd.exe.

  2. Type netsh wlan add profile filename=802_11n_wpa-psk.xml i=\*.

  3. Click OK.

NOTE

Make sure that Wireless Profile XML file exists in the current directory or specify the full path.

Related topics

Device.Network Testing


Troubleshooting Device.Network Testing

Troubleshooting Device.Network Testing

To troubleshoot issues that occur with Device.Network tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

    Review one of the following topics, depending on the type of networking product or feature that you are testing:

    • IPsec Task Offload v2 Testing Prerequisites

    • LAN Testing Prerequisites

    • Mobile Broadband Testing Prerequisites

    • Router Testing (Non-wireless) Prerequisites

    • Wireless LAN (802.11) Testing Prerequisites

    • Wireless Router Testing Prerequisites

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Known IPsec test issues

If the Windows HLK Controller cannot connect to clients, follow these steps:

  1. The very first test case is designed to ensure that the setup is correct. It does nothing but check the public and private network for connectivity. If this test fails, then there is a test setup issue.

  2. Check to ensure that the file config.dat is placed in the %SystemDrive%\IPsecTestKit\IPsecScenario\ directory and has the right IP addresses for the controller and the clients. This file is auto generated, but in certain cases such as DNS resolution failures, the config.dat file may contain incorrect data or be missing altogether. Please use the format described in the Test Setup section to verify the config.dat file.

  3. Check to ensure that you have firewall exemptions for IPsecControl.exe and IPsecScenario.exe.

  4. Check to ensure that after running the setup scripts, the IPsec Offload V2 interfaces are successfully renamed to "Test1".

Genconfig_phase2.vbs may not generate the necessary CMD files if there is only 1 default gateway for the message adapter. If your DHCP server does not support IP V6, you may only get 1 IP V6 default gateway address.

Running Individual Test Variations

In certain cases when tests fail, run a single test variation instead of re-running the whole suite. To do this, follow these steps:

  1. Make sure that the IPsecScenario.exe sessions are running on all clients.

  2. Copy individual variations to run from within OffloadV2_logoTests.cmd and run them from a new command window (%SYSTEMDRIVE%\IPsecTestKit\IPSecscenario\Controller

Troubleshooting LAN (Ethernet) Testing

The IPSec test job may fail due to issues with related LAN test jobs. See the following section for details.

Known LAN (Ethernet) test issues

Issue Details

The "IPsec Offloadv2 logo verification (Win7)" test jobs stay in the "Scheduler" status and never run.

This problem is usually caused by various communication issues between the DTM client and the controller. You can check whether the "Last Heartbeat time" is close to the current time. To force the DTM client that is reporting a heartbeat, you can manually change the status of the machine to Reset or Unsafe in the DTM Studio, and then wait until the status of the machine changes back to "Normal". After the status of all machines that are required to run the job is changed to Normal, the job will be scheduled on the DTM clients. If the machine status changes to Debug, verify whether the DTM client machine is still responsive. Sometimes, the machine status is Normal and the heartbeat is correct, but the job still won't run. This is most likely caused by the firewall or IPsec blocking the communication between the DTM client and the controller. Make sure that the DTM client and controller have the same IPsec configuration. If the client has IPsec turned on but the controller turned off, or vice versa, the job will not get scheduled. The DTM client is designed to work with a firewall, but sometimes the firewall blocks normal traffic between the client and the controller.

The following error message is observer in the test log: "The Job xxx requires a device to be selected, not a driver" when clicking "Add Information".

The error happens because you have selected a driver, not a test device, in the Device Console to run the test job. If you cannot find a device under the driver in the Device Console, the INF file and driver files that you provided during the logo submission do not match the actual INF file and driver files on the DTM client. Update your INF file and driver files by using the actual INF file and driver files installed on the DTM client.

No "IPsec Offloadv2 logo verification (Win7)" job shows up in the "Device Console".

Make sure your device is an Ethernet (LAN) device and report media type to NDIS as NdisMedium802_3. This error sometimes happens when the hardware information reported by the DTM client is incomplete. To solve this problem, try to can reboot the DTM client machine and refresh the view of Device Console. If this doesn't work, try to stop and restart the "wttsvc" service on the DTM client, and then refresh the view of Device Console.

The Ethernet - NDISTest 6.0 (priority) test may properly fail the 2c_priority and Directed Packets - NdisSendPackets assertion with a Unable to get test results on the test network adapter message.

This issue may occur when the network switch incorrectly strips priority bits. To confirm that this issue occurs because of the network switch, test the adapter by removing the switch and connecting the cables directly.

You can do this by using an alternate test configuration. This test configuration can only be used by devices that do not support Chimney, (TCP Offload) as the local support device is required for those devices. Please remove the Local Support Device and Test Network Switch altogether, and connect the Local Test Device directly back-to-back with the Remote Support Device. If this is the passes, this is acceptable for certification but please work with the switch manufacturer to correct the switch configuration.

The Ethernet - NDISTest 6.5 (WoL and PM) may correctly fail devices within the Send a FAKE LLMNRv4 network packet assertion with an error indicating the machine is working incorrectly.

To help determine if your device is properly failing, unbound the protocols on the remote device only.

If this does not resolve the issue, open a support incident
NOTE

To troubleshoot the NDISTest (6.0 or 6.5), attach a debugger to the test computer.

Known mobile broadband test issues

The following list describes some common troubleshooting tips for Mobile Broadband testing:

Changes that were made to devices on DTM client computers are not reflected in DTM Studio. For example, the machine is expected to be in the Ready state but it is not.

  1. Open a command prompt window on the client computer, and then run net stop wttsvc.

  2. Run net start wttsvc. This command updates the C:\wtt\JobsWorkingDir\AssetCfg\Log\ directory.

  3. Refresh the Device Console window in DTM Studio. It may take several minutes for the DTM Controller to poll the client computer for changes in its device list.

Computers have not been discovered for the machine pool.

  1. Open the Job Monitor window in DTM Studio.

  2. Click the Show Query Builder button at the top of the screen.

  3. Click the Machine Query tab.

  4. Define search parameters for the targeted computers. Typically, set a single rule such as "DataStore equals 'Controller Name'".

  5. Right-click the rule that was just defined, and then click Execute. An extensive list of computers populates the Machines list below the query fields.

  6. Drag any machines in the Machines list into new machine pool that was created.

Computers do not seem to run jobs that are scheduled for them.

  1. Open the Job Monitor window in DTM Studio.

  2. In the Machine Pool tab, select the machine pool that is expected to be running jobs.

  3. For each computer in that pool, verify that its status is Ready.

  4. If a computer's status is not Ready, right-click the computer, point to Change Status, and then click Reset.

  5. After a few minutes, refresh the screen and the status changes to Ready.

  6. Schedule and start the jobs again.

Known network security software testing prerequisites

The network security software tests (TransitionTechnologies_Tests and WindowsFilteringPlatform_Tests) require that the Sparta miniport drivers are installed and configured correctly. The Sparta miniport drivers are installed when each test runs, However, if you choose to, you can verify that they are present by opening a command prompt and typing IPConfig.exe /all. You should see four new Sparta interfaces named Sparta Miniport Primary, Sparta Miniport Secondary, Sparta Miniport Tertiary, and Sparta Miniport Quaternary.

Known router test issues

Currently there are no known router test issues.

Known wireless LAN (802.11) test issues

The following list describes some common troubleshooting tips for WLAN testing:

Changes that you made to devices on DTM clients machines are not reflected in DTM Studio. For example, the machine is expected to be in the Ready state but it is not.

  1. Open a Command Prompt window on the client machine, and then run net stop wttsvc.

  2. Run net start wttsvc. This command will update the C:\wtt\JobsWorkingDir\AssetCfg\Log\ directory.

  3. Refresh the Device Console window in DTM Studio. You might have to wait several minutes for the DTM controller to poll the client machine for changes in its device list.

Machines have not been discovered for the machine pool.

  1. Open the Job Monitor window in DTM Studio.

  2. Select the Show Query Builder button at the top of the screen.

  3. Click the Machine Query tab.

  4. Define search parameters for the machines that you are looking for. Typically, you can set a single rule such as "DataStore equals 'Controller Name'".

  5. Right-click the rule that you just defined, and then click Execute. An extensive list of machines should populate the Machines list below the query fields that you defined.

  6. Drag any machines in the Machines list into new machine pools that you created.

Machines do not seem to run jobs that are scheduled for them.

  1. Open the Job Monitor window in DTM Studio.

  2. In the Machine Pool tab, select the machine pool that you expect to be running jobs.

  3. For each machine in that pool, verify that its status is Ready.

  4. If a machine's status is not Ready, right-click the machine, point to Change Status, and then click Reset.

  5. After a few minutes, refresh the screen and the status will change to Ready.

  6. Schedule and start the jobs again.

Problems with installing the Test SoftAP driver on the topology: Device Manager reports code 52

Do not install the x64 Test SoftAP driver before installing the DTM client. When the DTM client is installed, the Root Certificate is installed. Because the Test SoftAP driver signing depends on installation of the Root Certificate, the device manager reports device code 52.

Configuring NDISTest for stand-alone execution

Installing NDISTest separate from DTM Studio enables you to execute individual tests. A DUT, SUT, and Test SoftAP needs to be configured to enable stand-alone execution.

NOTE

All test machines must use the same processor architecture.

NOTE

To troubleshoot the NDISTest, try attaching a debugger to the test machine.

Configuring a Support Device Under Test (SUT)

  1. Copy all NDISTest binaries and sub directories from the following DTM controller:

    \\<ControllerMachine]>\tests\<architecture>\nttest\nettest\ndis\ndistest.net\

    <ControllerMachine> is the name of the DTM controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors).

  2. Launch NDISTest.exe from the install directory. When the main form opens, select Server from the File menu to launch the server form.

  3. Select the message device from the Message Device list. This device must be IP-enabled and on the same subnet as the client message device that will be set up later.

  4. Select SUT device(s) from Support Devices. The support device selected on this server from will be visible to the client after the server is started.

  5. Select the "server" job from Jobs. This is the server side test that will be launched after you click the start button.

After all the options have been selected, click Start to start the server.

Configuring a Test Software Access Point (Test SoftAP)

  1. Copy all NDISTest binaries and sub directories from the following DTM controller:

    \\<ControllerMachine]>\tests\<architecture>\nttest\nettest\ndis\ndistest.net\

    <ControllerMachine> is the name of the DTM controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors).

  2. Install SoftAP driver for both of the Atheros WLAN devices on the Test SoftAP. You can install this driver from Device Manager, which you can open by running devmgmt.msc from a command prompt. Complete the following step:

    In Device Manager, install the driver for SoftAP stations from:

    \\<ControllerMachine]>\Tests\<architecture>\nttest\nettest\ndis\NDISTest.net\SoftAPMiniport\

    <ControllerMachine> is the name of the DTM controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors), depending on the processor architecture of the DTM client machine that have the SoftAP devices.

  3. Launch NDISTest.exe from the install directory. When the main form opens, select Server from the File menu to launch the server form.

  4. Select the message device from the Message Device list. This device must be IP-enabled device and on the same subnet as the client message device that will be set up later.

  5. Select the AP device(s) from AP Devices. AP devices selected on this server will be visible to the client after the server is started.

  6. Select the "server" job from Jobs. This is the server side test that will be launched after you click the start button.

After all the options have been selected, click Start to start the server.

Configuring the Device Under Test (DUT)

  1. Copy all NDISTest binaries and sub directories from the following DTM controller:

    \\<ControllerMachine>\tests\<architecture>\nttest\nettest\ndis\ndistest.net\

    <ControllerMachine> is the name of the DTM controller computer and <architecture> is either x86 (for x86-based processors) or amd64 (for x64-based processors).

  2. Launch NDISTest.exe from the install directory. When the main form opens, select Client from the File menu to launch the client form.

  3. Select the test target from the Test Target list. For network device, this test target should be Miniport.

  4. Select the test device from the Test Device list. This must be a vendor-specific test device.

  5. Select a message device from the Message Device list. This should be an IP-enabled device that is on the same subnet as the server message device. After the message device has been selected, the AP device section should be displayed and the server AP device should be available in the list.

  6. Select a support device from Support Devices. This must be a vendor-specific support device.

  7. Select an AP device from AP Devices. This must be the AP device that was select on the server side.

  8. Select the tests from the Jobs section that will be run after the client is launched.

After all the options have been selected, click Start to start the client. Any jobs that were selected will begin execution. Test results will be stored on the client in the following logging sub-folder:

<NDISTestRootFolder>/logs/<AdapterName>/

Configuring Client Packet Capture

  1. Configure a test topology for stand-alone execution. For more information, go to "Configuring NDISTest for stand-alone execution."

  2. Setup a second SUT. For more information, go to "Configuring a Support Device Under Test (SUT)."

  3. Launch NDISTest.exe from the install directory. When the main form opens, select Debug from the View menu to launch the Packet Capture section on the client.

  4. Select a Capture device from Packet Capture. This must be a Support device that was selected on the server side.

  5. From Jobs, select the tests that will be run after the client is launched.

  6. After all of the options have been selected, click Start to start the client.

  7. Packet captures corresponding to the Tests will be generated on the Server with the capture device. The logs will be in the following logging sub-folder:

    <NDISTestRootFolder>/logs/<AdapterName>/

Troubleshooting when the Packet Capture section does not show up on client

Verify that the message center user interface is closed. If the NDISTest user interface is not maximized, the Packet Capture section may be hidden behind the message center user interface.

Known wireless router test issues

This tip will help you in testing the ability of machine sending higher bit rates using Ethernet connection (i.e. validates the machine).

For this test procedure, setup two computers as shown in the following diagram:

diagram of computers s and c connected to a hub

  1. Setup the hardware as shown below with only Ethernet connection

  2. Assign a static IP address to Machine S.

    For Example: 10.0.0.2

  3. Assign a static IP address to Machine C.

    For Example: 10.0.0.3

  4. On Machine C, open a command prompt and run the following command:

    stats.exe -z DISCARD -i 20 -x 50 -y 30 -r 20000000 -c 3600 -l -h -u

  5. On Machine S, open a command prompt and run the following command:

    stats.exe -d 10.0.0.3 -r 20000000 -c 4200 -l -h -u

  6. Review the output of Step 4 and Step 5.

If the output of either Step 4 or Step 5 shows any failures then your machines cannot make bit rates using wireless adapters.

If you need to add a wireless profile manually, you can do so by using the netsh command.

For Example: To add the 802_11a_wpa-psk.xml wireless profile:

  1. Click Start, click Run, and enter cmd.exe.

  2. Type netsh wlan add profile filename=802_11a_wpa-psk.xml i=\*

  3. Click OK.

NOTE

Make sure that Wireless Profile XML file exists in the current directory or specify the full path.

Related topics

Device.Network Testing

Troubleshooting Windows HLK


Device.Network.Switch.DAL-TOR Test

This topic describes how to test network switches for OMI compatibility as part of the Windows Certification Program. To begin the testing part of the certification process, you must install and run the Windows Hardware Lab Kit (Windows HLK) and set up the test environment. For information about how to install and configure Windows HLK, see Step 1: Install Controller and Studio on the test server.

The types of products in the Device.Network.Switch.DAL-TOR category include Top of the Rack Switches.

Switch Testing Prerequisites

This section describes the following tasks that you must complete before you test a switch by using the Windows HLK:

  • Hardware requirements

  • Software requirements

  • Device configuration

  • Test computer configuration

Hardware requirements

The following hardware is required for switch testing. Additional hardware can be required if the test device provides bus-specific support. See the test description for each bus-specific test to determine whether there are additional hardware requirements.

  • Basic Windows HLK test setup (Controller and Studio). See Windows HLK Getting Started.

  • Two test computers.

    NOTE

    All computers must meet the Windows HLK requirements. If two test computers are required, both computers must be in the same computer pool. For more information, see Windows HLK Prerequisites.

    For testing networking capabilities, the test computer to which the switch is physically attached to is referred to as the System Under Test (SUT).

  • One test top of the rack switch.

  • One network card for each of the test machines.

The hardware configuration is illustrated in Figure 1 Hardware Configuration:

Software requirements

Install the operating system on the client systems before the final test passes, to ensure that the system is in a known good state.

  • Client-side software requirements:

    • Windows PowerShell 3.0

    • Dot Net 3.5 or higher

  • Switch-side software requirements

    • OMI server integrated on the switch

Device configuration

To configure the test device for HLK testing, follow these steps:

  1. Connect the switch to the serial port of the test computer by using a console cable.

  2. Establish a console connection to the switch to communicate over the serial port.

  3. Create a default password for the admin user on the switch if one is not already set. (Note: The password is shared when the result is submitted, so be sure to use a default password for the admin user for testing purpose only.)

  4. Assign a Host name to the switch by using the switch cli.

  5. Assign an IP address on the management port on the switch and make sure that the IP is on the same subnet as the test computer so that the test computer can communicate to the switch over the management port.

  6. Make sure that the OMI server is running on the switch. How the OMI server is enabled is determined by the switch vendor.

  7. Make sure that the required access control lists (ACLs) are set on the switch to allow https traffic on the OMI port that is selected by the switch vendor on which the OMI Server is listening.

  8. Make sure that the valid certificate is installed for the OMI service that is running on the system. This certificate is used for a SSL connection to the OMI service from the client.

Test computer configuration

To configure the test computer for switch testing, follow these steps:

  1. Install the appropriate operating system on the test computer.

  2. Configure the test computer for the test network that contains the Windows HLK Studio and Windows HLK Controller.

  3. Connect the SUT to the Top of the rack switch on the management port and connect a test machine to one of the downlink ports of the Top of the rack switch.

  4. Ping the switch from the test machine that is connected to its downlink port.

  5. Check that the switch functions properly on the test computer.

  6. Install the Windows HLK client application on the test computer.

  7. Install the valid certificate on the test computer, which corresponds to the one on the switch, and add it to the local machine certificate store.

  8. Copy \\<HLKControllerMachineName>\tests\AMD64\nttest\admintest\wmi\TORSwitch\Logo\ GenerateVirtualNode.ps1 to the Windows HLK client installation directory that was selected in Step 6, on the test machine. This is typically C:\WLK\JobsWorkingDir.

  9. Run the GenerateVirtualNode script on the client machine by using an elevated PowerShell window. This test setup script detects the switch that is connected to this host, and creates a node so that tests can be targeted against the device.

    GenerateVirtualNode generates a virtual target for the switch in the Windows HLK controller for targeting Top of the Rack switch tests. The script makes a connection to the switch over OMI, and tries to retrieve critical information that is used for test submission on the switch.

    NOTE

    At the end of a successful script execution, the machine is restarted.

**Script parameters**

-   **ipAddress**: The management IP address of the TOR switch that is connected to the host.

-   **username**: The user name of the TOR switch device admin.

-   **password**: The default password of the TOR switch admin user account.

-   **portNumber**: The OMI port number for SSL communication to the switch.

**Script example:**

The following example shows how to run the script by passing the information of all the script arguments.

``` syntax
.\GenerateVirtualNode.ps1 -ipAddress 10.0.0.1 -userName 'admin'-password 'defaultpassword' -portNumber '5986'
```

Before you start to test, make sure that the test computers are in the ready state. If a test requires parameters to be set before it is run, a dialog box displays for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a separate block from manual tests. This prevents a manual test from interrupting an automated test run.

Troubleshooting Device.Network.Switch.DAL-TOR tests

To troubleshoot issues that occur with Device.Network.Switch.DAL-TOR tests, follow these steps:

  1. Review the Troubleshooting Windows HLK topic.

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  4. Review this topic for information about the known test issues for the specific type of device that you are testing. Take any appropriate action that is based on the information that you find, and then rerun the affected test or tests. If you cannot complete testing for your submission, open a support case as described in Troubleshooting Windows HLK.

Specific switch test information

If the Device.Network.Switch.DAL-TOR feature is not detected during testing, we recommend that you run the GenerateVirtualNode script to make sure that the DAL-TOR device is detected in Windows HLK Studio.

Switch Tests

The Switch category includes the following tests:

  • TOR Test

  • Driver Memory Test

NOTE

TDI filters and LSPs are not allowed.

TOR Test

  • D3M.TOR.BVT.SwitchFeatures.Enumerate: The test verifies that the Switch Enumerate Features gets the correct set of features from the switch.

    Steps:

    1. Get Instance on the list of features.

    2. Verify that the feature count is greater than zero (0).

    3. Filter the features to the SSH feature.

    4. Verify that the SSH feature is found.

  • D3M.TOR.BVT.SwitchFeatures.Enable: The test verifies that you can enable and disable the switch features.

    Steps:

    1. Get Instance on the list of features.

    2. Filter the features to the SSH feature.

    3. Disable the SSH feature.

    4. Verify that the SSH feature is disabled.

    5. Enable the SSH feature.

    6. Verify that the SSH feature is enabled.

  • D3M.TOR.BVT.EthernetPort.GetPortList: The test verifies that the port list can be retrieved.

    Steps:

    1. Get Instance on the list of Ethernet ports.

    2. Verify that the list of ports returned is greater than zero (0).

    3. Verify the required properties of the port.

  • D3M.TOR.BVT.EthernetPort.EnablePort: The test verifies that you can enable and disable the Ethernet port.

    Steps:

    1. Get Instance on the list of Ethernet ports.

    2. Get the first port from the list.

    3. Set the Enabled state of the port to two (2).

    4. Get the port that corresponds to the same port name.

    5. Verify that the state is enabled.

    6. Disable the port.

    7. Verify that the state is disabled.

  • D3M.TOR.BVT.EthernetPort.PortProperties: The test verifies that you can set the Ethernet port properties.

    Steps:

    1. Get Instance on the list of Ethernet ports.

    2. Get the first port from the list.

    3. Set the port speed and the port description.

    4. Verify that the properties are correctly set.

  • D3M.TOR.BVT.EthernetPort.PortAssociation: The test verifies that the Ethernet associations in the Ethernet port are working as expected.

    Steps:

    1. Get Instance on the list of Ethernet ports.

    2. Get the first port from the list.

    3. Get the associated Ethernet port setting data for that port.

  • D3M.TOR.BVT.EthernetPort.PortModeToAccess: The test verifies that you can set the Ethernet port mode to Access.

    Steps:

    1. Get Instance on the list of Ethernet Port Setting Data.

    2. Get the first port from the list.

    3. Change the port mode to Access.

    4. Verify that the port mode is successfully set to Access by calling a Get Instance.

  • D3M.TOR.BVT.EthernetPort.PortModeToTrunk: The test verifies that the Ethernet port can be set to Trunk Port.

    Steps:

    1. Get Instance on the list of Ethernet Port Setting Data.

    2. Get the first port from the list.

    3. Change the port mode to Trunk.

    4. Verify that the port mode is successfully set to Trunk by calling a Get Instance.

  • D3M.TOR.BVT.VLAN.CreateVLAN: The test verifies that you can successfully create a VLAN.

    Steps:

    1. Create two VLANs on the machine.

    2. Verify that the two VLAN are created.

    3. Delete the two VLANs.

    4. Verify that the two VLAN are deleted.

  • D3M.TOR.BVT.VLAN.EnableVLAN: The test verifies that you can enable the VLAN on the switch.

    Steps:

    1. Create one VLAN on the machine.

    2. Enable the VLAN.

    3. Verify the Enabled state.

    4. Disable the VLAN.

    5. Verify the Disabled state.

    6. Delete the VLAN.

  • D3M.TOR.BVT.VLAN.AssociateAccessPortWithVLAN: The test verifies that the VLAN can be associated with an Ethernet port.

    Steps:

    1. Create one VLAN on the machine.

    2. Associate the VLAN with an Ethernet Port.

    3. Verify that the VLAN Endpoint is associated with the port.

    4. Delete the VLAN.

  • D3M.TOR.BVT.VLAN.AssociateTrunkPortWithVLAN: The test verifies that the VLAN can be associated with an Ethernet Port.

    Steps:

    1. Create two VLANs on the machine.

    2. Change the Ethernet port to Trunk Port.

    3. Associate the two VLANs with the Ethernet port.

    4. Verify that the VLAN endpoints are associated with the port.

    5. Delete the VLAN.

  • D3M.TOR.BVT.VLAN.VLANProperties: The test verifies that the VLAN can be enabled on the switch.

    Steps:

    1. Create one VLAN on the machine.

    2. Set the name of the VLAN.

    3. Verify the name of the VLAN.

    4. Delete the VLAN.

  • D3M.TOR.BVT.Configuration.CopyConfig: The test verifies that the config can be copied from the startup to the current config and back again.

    Steps:

    1. Create one VLAN on the machine.

    2. Copy the Running to the Startup.

    3. Validate the return value of the method.

    4. Delete the VLAN.

    5. Verify that there is no VLAN in the current config.

    6. Copy the Startup to the Running.

    7. Verify that the VLAN is up.

    8. Delete the VLAN.

    9. Copy the Running to the Startup.

  • D3M.TOR.BVT.Configuration.SetHostName: The test verifies that you can successfully change the Host name on the Switch.

    Steps:

    1. Get Instance of the switch from the computer system.

    2. Set the Host name of the switch.

    3. Get Instance of the switch.

    4. Verify that the Host name of the switch is set as expected.

  • D3M.TOR.BVT.Configuration.SetBanner: The test verifies that the banner data can be set successfully for the switch.

    Steps:

    1. Get Instance of the switch from the computer system.

    2. Get the Instance of the associated data for the switch.

    3. Set the banner text to a specific value.

    4. Get the Instance of MSFT_Banner data again.

    5. Verify that the banner data is successfully retrieved.

  • D3M.TOR.BVT.Configuration.SetIPAddressOnEthernetPort: The test verifies that the IP address can be successfully set on the switch Ethernet port.

    Steps:

    1. Get Instance of the Ethernet port from the computer system.

    2. Create a client-only instance of Cim_IPProtocolEndpoint.

    3. Invoke the AddProtocolEndpoint on the Switch Service Class.

    4. Issue a Get command and obtain the associated instance of the IP Protocol Endpoint.

    5. Verify that the IP address is successfully set on the Ethernet port.

    6. Call Remove Protocol on the IP interface.

    7. Verify that the IP address is successfully reset on the switch.

  • D3M.TOR.BVT.Configuration.SetIPAddressOnVLAN: The test verifies that you can successfully set the IP address on the VLAN interface of the switch.

    Steps:

    1. Create a new VLAN on the switch.

    2. Create a client-only instance of Cim_SwitchedVirtualInterface.

    3. Invoke the AddProtocolEndpoint on the Switch Service Class on the VLAN.

    4. Issue a Get command and obtain the associated instance of the IP Protocol Endpoint for the VLAN.

    5. Verify that the IP address is successfully set on the VLAN.

    6. Call Remove Protocol on the VLAN interface.

    7. Verify that the IP address is successfully reset on the VLAN.

  • D3M.TOR.BVT.Configuration.MACAddressTable: verifies that MACTable can be enumerated in the switch, and the MAC address table entries are valid.

    Steps:

    1. Enumerate the MAC address table.

    2. Get the associated MAC table entries from the table.

    3. Verify the required properties of the MAC table.

    4. Filter by dynamic MAC address table.

    5. Verify that the dynamic entries are found in the MAC address table.


MBN WHLK Content for a CDMA Device

The purpose of this document is to provide a comprehensive view of the MBN WHLK requirements, operations and expectations, by showing the summary log results of a successful test run.

How to read MBN Logs

The MBN operations are listed in chronological order. The beginning of an operation will be shown in black and the successful completion of an operation will be shown with a leading "PASS:". If an operation has sub operations, the entries will be indented and be between the beginning and end operation. If the operation fails in test, it will be shown with a leading "FAIL:".

Example

Attempt to read NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded

How to get a tracing from MBN Tests

The MBN Tests utilize Windows Software trace preprocessor (WPP). A trace can be obtained by using the following commands:

  1. tracelog.exe -b 64 -cir 10 -start MBNWHLK -ft 0 -guid #{d58c1268-b309-11d1-969e-0000f875a532} -flag 0x7fffffff -level 5 -f MBNWHLK.bin

  2. Execute Test

  3. tracelog.exe -stop MBNWHLK

  4. MBNWHLK.bin will then be available in the current directory

Using MBN Tests outside of WHLK

MBN Tests are built on Windows Test Authoring and Execution Framework (TAEF). The tests can be easily executed from the command line.

To view available MBN tests

te.exe <Test Dll> /list

To execute MBN tests

te.exe <Test Dll> /name:<Test Name> <Test Parameters>

Test Parameters

  • INTF - Specifies which device to target testing. The value can be either interface MAC or GUID. This parameter is optional, if not specified the tests will use any WWAN Interface on the machine.

  • PIN1 - Specifies the PIN1 associated with the device. This value is only required for the PIN tests and only if the device supports PIN1. If not specified the test will execute and fail if appropriate.

  • PUK1 - Specifies the PUK1 associated with the device. This value is only required for the PIN tests and only if the device supports PUK1. If not specified the test will execute and fail if appropriate. Be very careful about providing the PUK1 on a real device. If an incorrect PUK1 is provided or the device does not support PUK1 the device could be irreversibly locked.

  • WEBDOC8K - Specifies a web doc over 8K in size. This parameter is optional, if provided the test will use this URL rather than the default URL. The default URL is https://go.microsoft.com/fwlink/?linkid=867396

  • WEBDOC1024K - Specifies a web doc over 1024K in size. This parameter is optional, if provided the test will use this URL rather than the default URL. The default URL is https://go.microsoft.com/fwlink/?linkid=867397

  • DevPhoneNumber - Specifies the phone number of the device. This parameter is optional and used only by the SMS Tests. If the parameter is not specified the test will attempt to retrieve the phone number from the device.

Command Line Examples

te.exe Win8.MBN.CDMA.TestConnect.dll /name:Win8::MBN::TestConnect::ConnectDisconnectte.exe Win8.MBN.CDMA.TestConnect.dll /name:Win8::MBN::TestConnect* /p:INTF=00-A0-D5-FF-FF-A9te.exe Win8.MBN.CDMA.TestConnect.dll /name:Win8::MBN::TestConnect* /p:INTF=00A0D5FFFFA9 te.exe Win8.MBN.CDMA.TestPin.dll /name:Win8::MBN::TestPin* /p:INTF=00:A0:D5:FF:FF:A9 /p:PIN1=1234 /p:PUK1=12345678te.exe Win8.MBN.CDMA.TestSms.dll /name:Win8::MBN::TestSms* /p:DevPhoneNumber=4254437000te.exe Win8.MBN.CDMA.TestConnect.dll /p:WEBDOC8K=https://go.microsoft.com/fwlink/?linkid=867396

Mobile Broadband CDMA Test List

Test Summary: Win8MBN::TestClassDriver::VerifyClassDriver

Test Summary: Win8MBN::TestConnect::ConnectDisconnect

Test Summary: Win8MBN::TestConnect::ConnectAndTraffic

Test Summary: Win8MBN::TestConnect::ConnectWhenPacketServiceIsDetached

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

Test Summary: Win8MBN::TestDriverCaps::Query

Test Summary: Win8MBN::TestDeviceCaps::Query

Test Summary: Win8MBN::TestDeviceServices::Query

Test Summary: Win8MBN::TestDisableEnable::DisableEnableWhileIdle

Test Summary: Win8MBN::TestDisableEnable::ConnectDisableEnableConnect

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

Test Summary: Win8MBN::TestDriverCaps::Query

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

Test Summary: Win8MBN::TestHomeProvider::Query

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficFixed

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficIncrement

Test Summary: Win8MBN::TestMultiCarrier::SetHomeProvider

Test Summary: Win8MBN::TestPacketService::AttachDetach

Test Summary: Win8MBN::TestPin::PinListQueryRadioOn

Test Summary: Win8MBN::TestPin::PinListQueryRadioOff

Test Summary: Win8MBN::TestPin::NoPinSupport

Test Summary: Win8MBN::TestPin::PinExSetEnableDisableWithValidPin

Test Summary: Win8MBN::TestPin::PinExSetDisableIncorrectPinWithValidLength

Test Summary: Win8MBN::TestPin::PukEnableDisableThroughIncorrectPinExDisable

Test Summary: Win8MBN::TestPowerStates::SleepAndWake

Test Summary: Win8MBN::TestPowerStates::HibernateAndWake

Test Summary: Win8MBN::TestPreferredProvider::Query

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredProvider

Test Summary: Win8MBN::TestPreferredProvider::AddRemoveForbiddenProvider

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredForbiddenProvider

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenRegistered

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenPacketServiceAttached

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenConnected

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenRegistered

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenPacketServiceAttached

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenConnected

Test Summary: Win8MBN::TestReadyInfo::Query

Test Summary: Win8MBN::TestRegisterState::Query

Test Summary: Win8MBN::TestRegisterState::RegisterAutomatic

Test Summary: Win8MBN::TestRegisterState::RegisterManualToHomeProvider

Test Summary: Win8MBN::TestRemoval::RemovalWhenRegistered

Test Summary: Win8MBN::TestRemoval::RemovalWhenPacketSvcAttached

Test Summary: Win8MBN::TestRemoval::RemovalWhenConnected

Test Summary: Win8MBN::TestSelectiveSuspend::SelectiveSuspendConnected

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestSignalState::Query

Test Summary: Win8MBN::TestSms::SmsConfigQuery

Test Summary: Win8MBN::TestSms::SmsStatusQuery

Test Summary: Win8MBN::TestSms::SmsSendMessageToSelf

Test Summary: Win8MBN::TestSms::SmsDeleteAllMessages

Test Summary: Win8MBN::TestSms::SmsReadAllMessages

Test Summary: Win8MBN::TestSms::SmsReadNewMessages

Test Summary: Win8MBN::TestVisibleProvider::RadioOff

Test Summary: Win8MBN::TestVisibleProvider::Registered

Test Summary: Win8MBN::TestVisibleProvider::Connected

Test Summary: Win8MBN::TestWake::WakeMachineFromConnectedStandbyWithSmsMessage

Test Summary: Win8MBN::TestClassDriver::VerifyClassDriver

The test verifies a USB device uses class driver.

If device is usb, verify classdriver is implemented
   Attempt to query interface device info data
   PASS: Attempt to query interface device info data, succeeded
   Determine if device is using MB Class Driver
   PASS: Device is not using class driver
   Recursively check for usb
      Verify device is not using usb [{F02F01C1-CE76-49B2-8035-898DB8328951}\CDMAVMP\1&79F5D87&0&03]
      PASS: Device is not using usb
      Recursively check for usb
         Verify device is not using usb [ROOT\SYSTEM\0001]
         PASS: Device is not using usb
         Recursively check for usb
         PASS: Recursively check for usb, succeeded
      PASS: Recursively check for usb, succeeded
   PASS: Recursively check for usb, succeeded
PASS: Driver verified

Test Summary: Win8MBN::TestConnect::ConnectDisconnect

The test verifies the test can sucessfully connect and disconnect.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n639 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x4e
      PASS: Connection id of returned context state is 0x4e
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n78 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x4e
PASS: Connection id of returned context state is 0x4e
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestConnect::ConnectAndTraffic

The test connects to the home network and downloads a file from the Internet.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n94 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x59
      PASS: Connection id of returned context state is 0x59
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Verify TCP/IP shows interface as connected in 0x3a98 ms
PASS: TCP/IP shows interface as connected in 0x196 ms
Attempt to remove non wwan default routes
PASS: Attempt to remove non wwan default routes, succeeded
Attempt to download web doc
PASS: Attempt to download web doc, succeeded
Attempt to restore non wwan default routes
PASS: Attempt to restore non wwan default routes, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n31 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x59
PASS: Connection id of returned context state is 0x59
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestConnect::ConnectWhenPacketServiceIsDetached

The test verifies connection fails with WWAN_STATUS_PACKET_SVC_DETACHED when packet serivce is detached.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Verify device does not support auto packet service attach
      PASS: Device does not support auto packet service attach
      Attempt to set packet service (WwanPacketServiceActionDetach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionDetach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_PACKET_SVC_DETACHED[0xc004000d]
         PASS: Status is WWAN_STATUS_PACKET_SVC_DETACHED[0xc004000d]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

The test queries physical medium and verifies the value.

Attempt OID_GEN_PHYSICAL_MEDIUM query
PASS: OID_GEN_PHYSICAL_MEDIUM succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_PHYSICAL_MEDIUM returned NdisPhysicalMediumWirelessWan
PASS: Ndis physical medium (NdisPhysicalMediumWirelessWan[0x8]) is valid

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

The test queries media supported and verifies the value.

Attempt OID_GEN_MEDIA_SUPPORTED query
PASS: OID_GEN_MEDIA_SUPPORTED succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_MEDIA_SUPPORTED returned NdisMediumWirelessWan
PASS: Ndis medium (NdisMediumWirelessWan[0x9]) is valid

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

The test queries supported oid and verifies the value.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify OID_GEN_PHYSICAL_MEDIUM is supported
PASS: OID_GEN_PHYSICAL_MEDIUM is supported
Verify OID_GEN_MEDIA_SUPPORTED is supported
PASS: OID_GEN_MEDIA_SUPPORTED is supported
Verify OID_GEN_SUPPORTED_LIST is supported
PASS: OID_GEN_SUPPORTED_LIST is supported
Verify OID_WWAN_DEVICE_CAPS is supported
PASS: OID_WWAN_DEVICE_CAPS is supported
Verify OID_WWAN_READY_INFO is supported
PASS: OID_WWAN_READY_INFO is supported
Verify OID_WWAN_REGISTER_STATE is supported
PASS: OID_WWAN_REGISTER_STATE is supported
Verify OID_WWAN_RADIO_STATE is supported
PASS: OID_WWAN_RADIO_STATE is supported
Verify OID_WWAN_PIN_LIST is supported
PASS: OID_WWAN_PIN_LIST is supported
Verify OID_WWAN_HOME_PROVIDER is supported
PASS: OID_WWAN_HOME_PROVIDER is supported
Verify OID_WWAN_PACKET_SERVICE is supported
PASS: OID_WWAN_PACKET_SERVICE is supported
Verify OID_WWAN_SIGNAL_STATE is supported
PASS: OID_WWAN_SIGNAL_STATE is supported
Verify OID_WWAN_CONNECT is supported
PASS: OID_WWAN_CONNECT is supported
Verify OID_WWAN_PROVISIONED_CONTEXTS is supported
PASS: OID_WWAN_PROVISIONED_CONTEXTS is supported
Verify OID_WWAN_SMS_CONFIGURATION is supported
PASS: OID_WWAN_SMS_CONFIGURATION is supported
Verify OID_WWAN_SMS_READ is supported
PASS: OID_WWAN_SMS_READ is supported
Verify OID_WWAN_SMS_SEND is supported
PASS: OID_WWAN_SMS_SEND is supported
Verify OID_WWAN_SMS_DELETE is supported
PASS: OID_WWAN_SMS_DELETE is supported
Verify OID_WWAN_PIN_EX is supported
PASS: OID_WWAN_PIN_EX is supported

Test Summary: Win8MBN::TestDriverCaps::Query

The test queries driver caps and verifies data members.

Attempt to query driver capabilities
   Attempt OID_WWAN_DRIVER_CAPS query
   PASS: OID_WWAN_DRIVER_CAPS succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query driver capabilities succeeded
Verify indication length is equal to or greater than 0x10
PASS: Indication length is valid
Verify ulMajorVersion is valid
PASS: ulMajorVersion (0x2) is valid
Verify ulMinorVersion is valid
PASS: ulMinorVersion (0x0) is valid
Verify ulDriverCaps is valid
PASS: ulDriverCaps (0x0) is valid

Test Summary: Win8MBN::TestDeviceCaps::Query

The test queries device caps and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify indication length is equal to or greater than 0x160
PASS: Indication length (0x160) is valid
Header.Revision is NDIS_WWAN_DEVICE_CAPS_REVISION_2
PASS: Header.Revision is NDIS_WWAN_DEVICE_CAPS_REVISION_2
Verify uStatus is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify CellularClassListHeader.ElementType is WwanStructCellularClass
PASS: CellularClassListHeader.ElementType is WwanStructCellularClass
Verify CellularClassListHeader.ElementCount is less than WwanCellularClassMax
PASS: CellularClassListHeader.ElementCount (0x0) is less than WwanCellularClassMax
Verify WwanDeviceType is valid
PASS: WwanDeviceType is valid
Verify WwanCellularClass is valid
PASS: WwanCellularClass is valid
Verify WwanVoiceClass is valid
PASS: WwanVoiceClass is valid
Verify WwanSimClass is valid
PASS: WwanSimClass is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify CustomDataClass is NULL terminated
PASS: CustomDataClass is NULL terminated
Verify WwanCdmaBandClass are valid
PASS: WwanCdmaBandClass are valid for this device
Verify WwanGsmBandClass are valid
PASS: WwanBandClass are valid for this device
Verify CustomBandClass is NULL terminated
PASS: CustomBandClass is NULL terminated
Verify WwanSmsCaps are valid
PASS: WwanSmsCaps are valid for this device
Verify WwanControlCaps are valid
PASS: WwanControlCaps are valid for this device
Verify DeviceId is NULL terminated
PASS: DeviceId is NULL terminated
Verify Manufacturer is NULL Terminated
PASS: Manufacturer is NULL terminated
Verify Model is NULL terminated
PASS: Model is NULL terminated
Verify FirmwareInfo is NULL terminated
PASS: FirmwareInfo is NULL terminated
Verify MaxActivatedContexts > 0
PASS: MaxActivatedContexts is > 0

Test Summary: Win8MBN::TestDeviceServices::Query

The test queries device services and verifies data members.

Attempt to query enumerate device services
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICES query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICES succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query enumerate device services succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded

Test Summary: Win8MBN::TestDisableEnable::DisableEnableWhileIdle

The test disables and enables the device while idle.

Attempt to disable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A})
PASS: Attempt to disable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A}), succeeded
Attempt to enable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A})
PASS: Attempt to enable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A}), succeeded
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n452 ms
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded

Test Summary: Win8MBN::TestDisableEnable::ConnectDisableEnableConnect

The test connects, disables, enables, and connects the device.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n94 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x26
      PASS: Connection id of returned context state is 0x26
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to disable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A})
PASS: Attempt to disable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A}), succeeded
Attempt to enable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A})
PASS: Attempt to enable interface ({F7C10FC7-4FBD-4BD1-A38A-64B5659A8C6A}), succeeded
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n780 ms
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n94 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xc0
      PASS: Connection id of returned context state is 0xc0
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n47 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xc0
PASS: Connection id of returned context state is 0xc0
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

The test queries physical medium and verifies the value.

Attempt OID_GEN_PHYSICAL_MEDIUM query
PASS: OID_GEN_PHYSICAL_MEDIUM succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_PHYSICAL_MEDIUM returned NdisPhysicalMediumWirelessWan
PASS: Ndis physical medium (NdisPhysicalMediumWirelessWan[0x8]) is valid

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

The test queries media supported and verifies the value.

Attempt OID_GEN_MEDIA_SUPPORTED query
PASS: OID_GEN_MEDIA_SUPPORTED succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_MEDIA_SUPPORTED returned NdisMediumWirelessWan
PASS: Ndis medium (NdisMediumWirelessWan[0x9]) is valid

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

The test queries supported oid and verifies the value.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify OID_GEN_PHYSICAL_MEDIUM is supported
PASS: OID_GEN_PHYSICAL_MEDIUM is supported
Verify OID_GEN_MEDIA_SUPPORTED is supported
PASS: OID_GEN_MEDIA_SUPPORTED is supported
Verify OID_GEN_SUPPORTED_LIST is supported
PASS: OID_GEN_SUPPORTED_LIST is supported
Verify OID_WWAN_DEVICE_CAPS is supported
PASS: OID_WWAN_DEVICE_CAPS is supported
Verify OID_WWAN_READY_INFO is supported
PASS: OID_WWAN_READY_INFO is supported
Verify OID_WWAN_REGISTER_STATE is supported
PASS: OID_WWAN_REGISTER_STATE is supported
Verify OID_WWAN_RADIO_STATE is supported
PASS: OID_WWAN_RADIO_STATE is supported
Verify OID_WWAN_PIN_LIST is supported
PASS: OID_WWAN_PIN_LIST is supported
Verify OID_WWAN_HOME_PROVIDER is supported
PASS: OID_WWAN_HOME_PROVIDER is supported
Verify OID_WWAN_PACKET_SERVICE is supported
PASS: OID_WWAN_PACKET_SERVICE is supported
Verify OID_WWAN_SIGNAL_STATE is supported
PASS: OID_WWAN_SIGNAL_STATE is supported
Verify OID_WWAN_CONNECT is supported
PASS: OID_WWAN_CONNECT is supported
Verify OID_WWAN_PROVISIONED_CONTEXTS is supported
PASS: OID_WWAN_PROVISIONED_CONTEXTS is supported
Verify OID_WWAN_SMS_CONFIGURATION is supported
PASS: OID_WWAN_SMS_CONFIGURATION is supported
Verify OID_WWAN_SMS_READ is supported
PASS: OID_WWAN_SMS_READ is supported
Verify OID_WWAN_SMS_SEND is supported
PASS: OID_WWAN_SMS_SEND is supported
Verify OID_WWAN_SMS_DELETE is supported
PASS: OID_WWAN_SMS_DELETE is supported
Verify OID_WWAN_PIN_EX is supported
PASS: OID_WWAN_PIN_EX is supported

Test Summary: Win8MBN::TestDriverCaps::Query

The test queries driver caps and verifies data members.

Attempt to query driver capabilities
   Attempt OID_WWAN_DRIVER_CAPS query
   PASS: OID_WWAN_DRIVER_CAPS succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query driver capabilities succeeded
Verify indication length is equal to or greater than 0x10
PASS: Indication length is valid
Verify ulMajorVersion is valid
PASS: ulMajorVersion (0x2) is valid
Verify ulMinorVersion is valid
PASS: ulMinorVersion (0x0) is valid
Verify ulDriverCaps is valid
PASS: ulDriverCaps (0x0) is valid

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

The test queries physical medium and verifies the value.

Attempt OID_GEN_PHYSICAL_MEDIUM query
PASS: OID_GEN_PHYSICAL_MEDIUM succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_PHYSICAL_MEDIUM returned NdisPhysicalMediumWirelessWan
PASS: Ndis physical medium (NdisPhysicalMediumWirelessWan[0x8]) is valid

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

The test queries media supported and verifies the value.

Attempt OID_GEN_MEDIA_SUPPORTED query
PASS: OID_GEN_MEDIA_SUPPORTED succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_MEDIA_SUPPORTED returned NdisMediumWirelessWan
PASS: Ndis medium (NdisMediumWirelessWan[0x9]) is valid

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

The test queries supported oid and verifies the value.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify OID_GEN_PHYSICAL_MEDIUM is supported
PASS: OID_GEN_PHYSICAL_MEDIUM is supported
Verify OID_GEN_MEDIA_SUPPORTED is supported
PASS: OID_GEN_MEDIA_SUPPORTED is supported
Verify OID_GEN_SUPPORTED_LIST is supported
PASS: OID_GEN_SUPPORTED_LIST is supported
Verify OID_WWAN_DEVICE_CAPS is supported
PASS: OID_WWAN_DEVICE_CAPS is supported
Verify OID_WWAN_READY_INFO is supported
PASS: OID_WWAN_READY_INFO is supported
Verify OID_WWAN_REGISTER_STATE is supported
PASS: OID_WWAN_REGISTER_STATE is supported
Verify OID_WWAN_RADIO_STATE is supported
PASS: OID_WWAN_RADIO_STATE is supported
Verify OID_WWAN_PIN_LIST is supported
PASS: OID_WWAN_PIN_LIST is supported
Verify OID_WWAN_HOME_PROVIDER is supported
PASS: OID_WWAN_HOME_PROVIDER is supported
Verify OID_WWAN_PACKET_SERVICE is supported
PASS: OID_WWAN_PACKET_SERVICE is supported
Verify OID_WWAN_SIGNAL_STATE is supported
PASS: OID_WWAN_SIGNAL_STATE is supported
Verify OID_WWAN_CONNECT is supported
PASS: OID_WWAN_CONNECT is supported
Verify OID_WWAN_PROVISIONED_CONTEXTS is supported
PASS: OID_WWAN_PROVISIONED_CONTEXTS is supported
Verify OID_WWAN_SMS_CONFIGURATION is supported
PASS: OID_WWAN_SMS_CONFIGURATION is supported
Verify OID_WWAN_SMS_READ is supported
PASS: OID_WWAN_SMS_READ is supported
Verify OID_WWAN_SMS_SEND is supported
PASS: OID_WWAN_SMS_SEND is supported
Verify OID_WWAN_SMS_DELETE is supported
PASS: OID_WWAN_SMS_DELETE is supported
Verify OID_WWAN_PIN_EX is supported
PASS: OID_WWAN_PIN_EX is supported

Test Summary: Win8MBN::TestHomeProvider::Query

The test queries home provider and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query home provider succeeded
Verify indication length is equal to or greater than 0x4c
PASS: Indication length (0x4c) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12301) contains only digits
Verify ProviderId is 5 digits in length for CDMA devices
PASS: ProviderId length (0x5) is valid
Verify ProviderState only uses WWAN_PROVIDER_STATE_HOME,WWAN_PROVIDER_STATE_FORBIDDEN,WWAN_PROVIDER_STATE_PREFERRED,WWAN_PROVIDER_STATE_VISIBLE, and\or WWAN_PROVIDER_STATE_REGISTERED
PASS: ProviderState (0x1) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (MS MBN) is populated
Verify ProviderState has WWAN_PROVIDER_STATE_HOME set
PASS: ProviderState (0x1) has WWAN_PROVIDER_STATE_HOME set

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficFixed

The test connects to loopback and send receives traffic.

Attempt to query interface device info data
PASS: Attempt to query interface device info data, succeeded
Determine if device is using MB Class Driver
PASS: Device is using class driver
Attempt to set connect context WwanActivationCommandActivate loopback (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandActivate loopback (null) (null), succeeded
Verify activation state of returned context state is WwanActivationStateActivated
PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
Attempt to add IPv4 Address
PASS: Attempt to add Loopback IPv4 Address, succeeded
Attempt to add Loopback IPv4 Route
   Attempt to get address from interface
   PASS: Attempt to get address (10.10.10.1) from interface, succeeded
PASS: Attempt to add Loopback IPv4 Route, succeeded
Start sending data
PASS: Start sending data, success
Wait 0n60000 ms for data to be sent
PASS: Wait for data to be sent, success
Verify data loss is less than 5%
PASS: Data loss (0.000000%) is less than 5%
Verify bandwidth is greater than 100 Mbps
PASS: Bandwidth (290.122667) is more than 100 Mbps
Attempt to delete IPv4 Address
PASS: Attempt to delete Loopback IPv4 Address, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xe0
PASS: Connection id of returned context state is 0xe0
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficIncrement

The test connects to loopback and send receives traffic.

Attempt to query interface device info data
PASS: Attempt to query interface device info data, succeeded
Determine if device is using MB Class Driver
PASS: Device is using class driver
Attempt to set connect context WwanActivationCommandActivate loopback (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandActivate loopback (null) (null), succeeded
Verify activation state of returned context state is WwanActivationStateActivated
PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
Attempt to add IPv4 Address
PASS: Attempt to add Loopback IPv4 Address, succeeded
Attempt to add Loopback IPv4 Route
   Attempt to get address from interface
   PASS: Attempt to get address (10.10.10.1) from interface, succeeded
PASS: Attempt to add Loopback IPv4 Route, succeeded
Start sending data
PASS: Start sending data, success
Wait for data to be sent
PASS: Wait for data to be sent, success
Verify data loss is less than 5%
PASS: Data loss (0.612382%) is less than 5%
Attempt to delete IPv4 Address
PASS: Attempt to delete Loopback IPv4 Address, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xd0
PASS: Connection id of returned context state is 0xd0
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestMultiCarrier::SetHomeProvider

The test sets the home provider.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify WWAN_CTRL_CAPS_MODEL_MULTI_CARRIER is supported
NA: Device does not support WWAN_CTRL_CAPS_MODEL_MULTI_CARRIER

Test Summary: Win8MBN::TestPacketService::AttachDetach

The test attaches and detaches the packet service.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify PacketServiceState is valid
PASS: PacketServiceState (WwanPacketServiceStateAttached[0x2]) is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Attempt to query packet service
   Attempt OID_WWAN_PACKET_SERVICE query
   PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query packet service succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify PacketServiceState is valid
PASS: PacketServiceState (WwanPacketServiceStateAttached[0x2]) is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Attempt to set packet service (WwanPacketServiceActionDetach)
   Attempt OID_WWAN_PACKET_SERVICE set
   PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set packet service (WwanPacketServiceActionDetach) succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify PacketServiceState is valid
PASS: PacketServiceState (WwanPacketServiceStateDetached[0x4]) is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Attempt to query packet service
   Attempt OID_WWAN_PACKET_SERVICE query
   PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query packet service succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify PacketServiceState is valid
PASS: PacketServiceState (WwanPacketServiceStateDetached[0x4]) is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device

Test Summary: Win8MBN::TestPin::PinListQueryRadioOn

The test attempts a pin list query with the radio on.

Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded

Test Summary: Win8MBN::TestPin::PinListQueryRadioOff

The test attempts a pin list query with the radio off.

Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded

Test Summary: Win8MBN::TestPin::NoPinSupport

The test verifes a device that does not support PIN1.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is WwanPinModeNotSupported
NA: WwanPinTypePin1 is not WwanPinModeNotSupported

Test Summary: Win8MBN::TestPin::PinExSetEnableDisableWithValidPin

The test enables and disables PIN1 with a valid pin.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is not WwanPinModeNotSupported
PASS: WwanPinTypePin1 is not WwanPinModeNotSupported
Verify PIN1 parameter was provided
PASS: PIN1 (1111) parameter was provided
Verify WwanPinTypePin1 is WwanPinModeDisabled
PASS: WwanPinTypePin1 is WwanPinModeDisabled
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin ex succeeded
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null)) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeEnabled
PASS: NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeEnabled
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null)) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeDisabled
PASS: NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeDisabled

Test Summary: Win8MBN::TestPin::PinExSetDisableIncorrectPinWithValidLength

The test attempts to enable PIN1 with incorrect pin with valid length.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is not WwanPinModeNotSupported
PASS: WwanPinTypePin1 is not WwanPinModeNotSupported
Verify PIN1 parameter was provided
PASS: PIN1 (1111) parameter was provided
Verify WwanPinTypePin1 is WwanPinModeDisabled
PASS: WwanPinTypePin1 is WwanPinModeDisabled
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin ex succeeded
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null)) succeeded
Attempt to set WwanPinTypePin1 WwanPinOperationDisable with incorrect pin [pin:4321]
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
PASS: WWAN_STATUS == WWAN_STATUS_FAILURE
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null)) succeeded

Test Summary: Win8MBN::TestPin::PukEnableDisableThroughIncorrectPinExDisable

The test enables PUK1 by entering incorrect PIN1 multiple times and then disables PUK1.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is not WwanPinModeNotSupported
PASS: WwanPinTypePin1 is not WwanPinModeNotSupported
Verify PIN1 parameter was provided
PASS: PIN1 (1111) parameter was provided
Verify PUK1 parameter was provided
NA: PUK1 parameter was not provided

Test Summary: Win8MBN::TestPowerStates::SleepAndWake

The test connects, puts the machine into sleep mode, wakes the machine, and connects.

Verify machine processor is supported
PASS: Machine processor (0x0) is supported
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2667 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xdb
      PASS: Connection id of returned context state is 0xdb
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to put computer into Sleep mode for 0x3c seconds
PASS: Attempt to put computer into Sleep mode for 0x3c seconds, succeeded)
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n5662 ms
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n5788 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n31 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n3464 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0x5b
      PASS: Connection id of returned context state is 0x5b
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Verify TCP/IP shows interface as connected in 0x3a98 ms
PASS: TCP/IP shows interface as connected in 0x24bf ms
Attempt to remove non wwan default routes
PASS: Attempt to remove non wwan default routes, succeeded
Attempt to download web doc
PASS: Attempt to download web doc, succeeded
Attempt to restore non wwan default routes
PASS: Attempt to restore non wwan default routes, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n281 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x5b
PASS: Connection id of returned context state is 0x5b
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestPowerStates::HibernateAndWake

The test connects, puts the machine into hiberantion mode, wakes the machine, and connects.

Verify machine processor is supported
PASS: Machine processor (0x0) is supported
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2667 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xfa
      PASS: Connection id of returned context state is 0xfa
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to put computer into Hibernate mode for 0x3c seconds
PASS: Attempt to put computer into Hibernate mode for 0x3c seconds, succeeded)
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n140 ms
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n358 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n47 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n3588 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0x4e
      PASS: Connection id of returned context state is 0x4e
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Verify TCP/IP shows interface as connected in 0x3a98 ms
PASS: TCP/IP did not show interface as connected in 0x3a98 ms
Attempt to remove non wwan default routes
PASS: Attempt to remove non wwan default routes, succeeded
Attempt to download web doc
PASS: Attempt to download web doc, succeeded
Attempt to restore non wwan default routes
PASS: Attempt to restore non wwan default routes, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n249 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x4e
PASS: Connection id of returned context state is 0x4e
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestPreferredProvider::Query

The test queries preferred providers and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
NA: Device is not GSM

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredProvider

The test adds and removes a preferred provider.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
NA: Device is not GSM

Test Summary: Win8MBN::TestPreferredProvider::AddRemoveForbiddenProvider

The test adds and removes a forbidden provider.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
NA: Device is not GSM

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredForbiddenProvider

The test adds and removes both forbidden and forbidden providers.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
NA: Device is not GSM

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenRegistered

The test turns the hardware radio off and on when registered.

Verify device has hardware radio switch
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device has hardware radio switch
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to turn hardware radio off
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n35708 ms
PASS: Attempt to turn hardware radio off, succeeded
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to turn hardware radio on
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n3416 ms
PASS: Attempt to turn hardware radio on, succeeded
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenPacketServiceAttached

The test turns the hardware radio off and on when packet service attached.

Verify device has hardware radio switch
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device has hardware radio switch
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to turn hardware radio off
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n2636 ms
PASS: Attempt to turn hardware radio off, succeeded
Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to turn hardware radio on
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n2262 ms
PASS: Attempt to turn hardware radio on, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
      PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
      Performance Check:Verify unsolicited indication was received under 0n50000 ms
      PASS: Unsolicited indication was received in 0n514 ms
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenConnected

The test turns the hardware radio off and on when connected.

Verify device has hardware radio switch
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device has hardware radio switch
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n63 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xd8
      PASS: Connection id of returned context state is 0xd8
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to turn hardware radio off
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n2528 ms
PASS: Attempt to turn hardware radio off, succeeded
Wait for unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to turn hardware radio on
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n1654 ms
PASS: Attempt to turn hardware radio on, succeeded
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
         Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
         PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
         Performance Check:Verify unsolicited indication was received under 0n50000 ms
         PASS: Unsolicited indication was received in 0n31 ms
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n62 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x52
      PASS: Connection id of returned context state is 0x52
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x52
PASS: Connection id of returned context state is 0x52
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenRegistered

The test turns the software radio off and on when registered.

Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOff[0x0]
PASS: SwRadioState is WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n16 ms
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenPacketServiceAttached

The test turns the software radio off and on when packet service is attached.

Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOff[0x0]
PASS: SwRadioState is WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n16 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenConnected

The test turns the software radio off and on when connected.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n93 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xc
      PASS: Connection id of returned context state is 0xc
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n47 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOff[0x0]
PASS: SwRadioState is WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Wait for unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n16 ms
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n78 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xbc
      PASS: Connection id of returned context state is 0xbc
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xbc
PASS: Connection id of returned context state is 0xbc
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid

Test Summary: Win8MBN::TestReadyInfo::Query

The test queries ready info and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query ready info
   Attempt OID_WWAN_READY_INFO query
   PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
PASS: Attempt to query ready info succeeded
Verify indication length is equal to or greater than 0x80
PASS: Indication length is 0x80
Verify ReadyState is valid
PASS: ReadyState (0x1) is valid
Verify EmergencyMode is valid
PASS: EmergencyMode (0x0) is valid
Verify SubscriberId is NULL terminated
PASS: SubscriberId is NULL terminated
Verify SubscriberId contains only digits
PASS: SubscriberId (1234567890) contains only digits
Verify SimIccId is NULL terminated
PASS: SimIccId is NULL terminated
Verify SimIccId contains only digits
PASS: SimIccId () contains only digits
Verify SubscriberId is 10 digits in length for CDMA devices
PASS: SubscriberId length (0xa) is valid
Verify CdmaShortMsgSize is between WWAN_CDMA_SHORT_MSG_SIZE_UNKNOWN and WWAN_CDMA_SHORT_MSG_SIZE_MAX for CDMA devices
PASS: CdmaShortMsgSize (0xa0) is valid
Verify ElementType is WwanStructTN
PASS: ElementType is valid

Test Summary: Win8MBN::TestRegisterState::Query

The test queries register state and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query Register State
   Attempt OID_WWAN_REGISTER_STATE query
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query register state succeeded
Verify indication length is equal to or greater than 0xd4
PASS: Indication length (0xd4) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify RegisterState is valid
PASS: RegisterState (WwanRegisterStateHome[0x0]) is valid
Verify RegisterMode is valid
PASS: RegisterMode (WwanRegisterStateHome[0x0]) is valid
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12301) contains only digits
Verify ProviderId is 5 digits in length for CDMA devices
PASS: ProviderId length (0x5) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (12301) is populated
Verify WwanRegFlags is valid
PASS: WwanRegFlags (0x0) is valid

Test Summary: Win8MBN::TestRegisterState::RegisterAutomatic

The test attempts to register in automatic mode.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query home provider succeeded
Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
   Attempt OID_WWAN_REGISTER_STATE set
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n50000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
Verify register mode is WwanRegisterModeAutomatic
PASS: Register mode is WwanRegisterModeAutomatic
Verify register state is WwanRegisterStateHome, WwanRegisterStateRoaming, or WwanRegisterStatePartner
PASS: Register state is WwanRegisterStateHome

Test Summary: Win8MBN::TestRegisterState::RegisterManualToHomeProvider

The test attempts to register to the home provider in manual mode.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify device supports manual registration
NA: Device does not support manual registration
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded

Test Summary: Win8MBN::TestRemoval::RemovalWhenRegistered

The test registers and prompts the user to remove the device.

Verify device is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device is removable
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to remove the device
PASS: Attempt to remove the device, succeeded
Attempt to add the device
   Wait 0xea60 ms for device to enter WwanReadyStateInitialized
   PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
   Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
   PASS: WwanReadyStateInitialized occured in 0n16 ms
PASS: Attempt to add the device, succeeded
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
   PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
   Performance Check:Verify unsolicited indication was received under 0n50000 ms
   PASS: Unsolicited indication was received in 0n93 ms
PASS: Attempt to auto register, succeeded

Test Summary: Win8MBN::TestRemoval::RemovalWhenPacketSvcAttached

The test attaches the packet service and prompts the user to remove the device.

Verify device is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device is removable
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to remove the device
PASS: Attempt to remove the device, succeeded
Attempt to add the device
   Wait 0xea60 ms for device to enter WwanReadyStateInitialized
   PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
   Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
   PASS: WwanReadyStateInitialized occured in 0n0 ms
PASS: Attempt to add the device, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
   PASS: Attempt to auto register, succeeded
   Attempt to set packet service (WwanPacketServiceActionAttach)
      Attempt OID_WWAN_PACKET_SERVICE set
      PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded

Test Summary: Win8MBN::TestRemoval::RemovalWhenConnected

The test connects and prompts the user to remove the device.

Verify device is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device is removable
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n141 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x2f
      PASS: Connection id of returned context state is 0x2f
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to remove the device
PASS: Attempt to remove the device, succeeded
Attempt to add the device
   Wait 0xea60 ms for device to enter WwanReadyStateInitialized
   PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
   Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
   PASS: WwanReadyStateInitialized occured in 0n15 ms
PASS: Attempt to add the device, succeeded
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n94 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xb6
      PASS: Connection id of returned context state is 0xb6
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n32 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xb6
PASS: Connection id of returned context state is 0xb6
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestSelectiveSuspend::SelectiveSuspendConnected

The test block outbound IP traffic to verify the device enters selective suspend state. The test will then unblock outbound traffic and verify the device comes out of selective suspend state.

Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n32 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2668 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xb
      PASS: Connection id of returned context state is 0xb
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n1014 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xb
PASS: Connection id of returned context state is 0xb
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated
Verify NDIS Events
PASS: Number of NDIS Events (0x10c7), succeeded
Verify NDIS Selective Suspend Events
PASS: Verify NDIS Selective Suspend Events, succeeded

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestSignalState::Query

The test queries signal state and verifies values.

Attempt to query signal state
   Attempt OID_WWAN_SIGNAL_STATE query
   PASS: OID_WWAN_SIGNAL_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query signal state succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify RSSI is between 0 and 31 or WWAN_RSSI_UNKNOWN
PASS: RSSI (0x1e) is between 0 and 31 or WWAN_RSSI_UNKNOWN
Verify error rate is between 0 and 7 or WWAN_ERROR_RATE_UNKNOWN
PASS: Error rate (0x0) is between 0 and 7 or WWAN_ERROR_RATE_UNKNOWN
Verify RSSI interval is more than 5 seconds
PASS: RSSI interval (0x1e) is more than 5 seconds

Test Summary: Win8MBN::TestSms::SmsConfigQuery

The test queries sms config and verifies data members.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to query SMS configuration
   Attempt OID_WWAN_SMS_CONFIGURATION query
   PASS: OID_WWAN_SMS_CONFIGURATION succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query SMS configuration succeeded
Verify indication length is equal to or greater than 0x20
PASS: Indication length (0x20) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify SmsFormat is WwanSmsFormatCdma or WwanSmsFormatPdu
PASS: SmsFormat is WwanSmsFormatCdma[0x4]

Test Summary: Win8MBN::TestSms::SmsStatusQuery

The test queries sms status and verifies data members.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to query SMS status
   Attempt OID_WWAN_SMS_STATUS query
   PASS: OID_WWAN_SMS_STATUS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query SMS status succeeded
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid

Test Summary: Win8MBN::TestSms::SmsSendMessageToSelf

The test sends an SMS message to itself and verifies it receives the message.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n47 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded

Test Summary: Win8MBN::TestSms::SmsDeleteAllMessages

The test deletes all messages.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n16 ms
PASS: Attempt to send message to self, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded
Attempt to query SMS read (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list is 0x0
PASS: Number of messages in receive list (0x0) is 0x0

Test Summary: Win8MBN::TestSms::SmsReadAllMessages

The test reads all messages.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to query SMS read (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list of status WwanMsgStatusNew is 0x2
PASS: Number of messages (0x2) in receive list of status WwanMsgStatusNew (0x0) is 0x2
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded

Test Summary: Win8MBN::TestSms::SmsReadNewMessages

The test reads all new messages.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to query SMS read (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list of status WwanMsgStatusNew is 0x1
PASS: Number of messages (0x1) in receive list of status WwanMsgStatusNew (0x0) is 0x1
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to query SMS read (Flag:WwanSmsFlagNew Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list of status WwanMsgStatusNew is 0x1
PASS: Number of messages (0x1) in receive list of status WwanMsgStatusNew (0x0) is 0x1
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded

Test Summary: Win8MBN::TestVisibleProvider::RadioOff

The test queries visible providers while radio is off.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_VISIBLE_PROVIDERS
PASS: Device supports OID_WWAN_VISIBLE_PROVIDERS
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n16 ms
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_RADIO_POWER_OFF[0xc0040015]
   PASS: Status is WWAN_STATUS_RADIO_POWER_OFF[0xc0040015]
PASS: Attempt to query visible providers succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded

Test Summary: Win8MBN::TestVisibleProvider::Registered

The test queries visible providers while auto registered.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_VISIBLE_PROVIDERS
PASS: Device supports OID_WWAN_VISIBLE_PROVIDERS
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
PASS: Attempt to auto register, succeeded
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n15 ms
   Verify status
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query visible providers succeeded
Verify indication length is equal to or greater than 0x1
PASS: Indication length (0x60) is valid
Verify element type is WwanStructProvider2
PASS: Element type is WwanStructProvider2
Verify indication length is equal to or greater than 0x60
PASS: Indication length (0x60) is valid
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12301) contains only digits
Verify ProviderId is 5 digits in length for CDMA devices
PASS: ProviderId length (0x5) is valid
Verify ProviderState only uses WWAN_PROVIDER_STATE_HOME,WWAN_PROVIDER_STATE_FORBIDDEN,WWAN_PROVIDER_STATE_PREFERRED,WWAN_PROVIDER_STATE_VISIBLE, and\or WWAN_PROVIDER_STATE_REGISTERED
PASS: ProviderState (0x19) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (MS MBN) is populated
Device is CDMA, verify only the home provider is reported
PASS: Only the home provider is reported

Test Summary: Win8MBN::TestVisibleProvider::Connected

The test queries visible providers while connected.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_VISIBLE_PROVIDERS
PASS: Device supports OID_WWAN_VISIBLE_PROVIDERS
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x7f0000) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n125 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xbf
      PASS: Connection id of returned context state is 0xbf
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query visible providers succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n31 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xbf
PASS: Connection id of returned context state is 0xbf
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestWake::WakeMachineFromConnectedStandbyWithSmsMessage

The test will verify the machine supports InstantGo, put the machine into Connected Standby, and wait for SMS message.

Verify platform supports always on always connected
PASS: Platform supports always on always connected
Attempt to disable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD})
PASS: Attempt to disable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD}), succeeded
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded
Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
Performance Check:Verify unsolicited indication was received under 0n300000 ms
PASS: Unsolicited indication was received in 0n0 ms
Verify wait wake event was triggered
PASS: Wait wake event was triggered
Attempt to enable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD})
PASS: Attempt to enable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD}), succeeded


MBN WHLK Content for a GSM Device

The purpose of this document is to provide a comprehensive view of the MBN WHLK requirements, operations and expectations, by showing the summary log results of a successful test run.

How to read MBN Logs

The MBN operations are listed in chronological order. The beginning of an operation will be shown in black and the successful completion of an operation will be shown with a leading "PASS:". If an operation has sub operations, the entries will be indented and be between the beginning and end operation. If the operation fails in test, it will be shown with a leading "FAIL:".

Example

Attempt to read NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded

How to get a tracing from MBN Tests

The MBN Tests utilize Windows Software trace preprocessor (WPP). A trace can be obtained by using the following commands:

  1. tracelog.exe -b 64 -cir 10 -start MBNWHLK -ft 0 -guid #{d58c1268-b309-11d1-969e-0000f875a532} -flag 0x7fffffff -level 5 -f MBNWHLK.bin

  2. Execute Test

  3. tracelog.exe -stop MBNWHLK

  4. MBNWHLK.bin will then be available in the current directory

Using MBN Tests outside of WHLK

MBN Tests are built on Windows Test Authoring and Execution Framework (TAEF). The tests can be easily executed from the command line.

To view available MBN tests

te.exe <Test Dll> /list

To execute MBN tests

te.exe <Test Dll> /name:<Test Name> <Test Parameters>

Test Parameters

  • INTF - Specifies which device to target testing. The value can be either interface MAC or GUID. This parameter is optional, if not specified the tests will use any WWAN Interface on the machine.

  • PIN1 - Specifies the PIN1 associated with the device. This value is only required for the PIN tests and only if the device supports PIN1. If not specified the test will execute and fail if appropriate.

  • PUK1 - Specifies the PUK1 associated with the device. This value is only required for the PIN tests and only if the device supports PUK1. If not specified the test will execute and fail if appropriate. Be very careful about providing the PUK1 on a real device. If an incorrect PUK1 is provided or the device does not support PUK1 the device could be irreversibly locked.

  • WEBDOC8K - Specifies a web doc over 8K in size. This parameter is optional, if provided the test will use this URL rather than the default URL. The default URL is https://go.microsoft.com/fwlink/?linkid=867396

  • WEBDOC1024K - Specifies a web doc over 1024K in size. This parameter is optional, if provided the test will use this URL rather than the default URL. The default URL is https://go.microsoft.com/fwlink/?linkid=867397

  • DevPhoneNumber - Specifies the phone number of the device. This parameter is optional and used only by the SMS Tests. If the parameter is not specified the test will attempt to retrieve the phone number from the device.

Command Line Examples

te.exe Win8.MBN.GSM.TestConnect.dll /name:Win8::MBN::TestConnect::ConnectDisconnect
te.exe Win8.MBN.GSM.TestConnect.dll /name:Win8::MBN::TestConnect* /p:INTF=00-A0-D5-FF-FF-A9
te.exe Win8.MBN.GSM.TestConnect.dll /name:Win8::MBN::TestConnect* /p:INTF=00A0D5FFFFA9
te.exe Win8.MBN.GSM.TestPin.dll /name:Win8::MBN::TestPin* /p:INTF=00:A0:D5:FF:FF:A9 /p:PIN1=1234 /p:PUK1=12345678
te.exe Win8.MBN.GSM.TestSms.dll /name:Win8::MBN::TestSms* /p:DevPhoneNumber=4254437000
te.exe Win8.MBN.GSM.TestConnect.dll /p:WEBDOC8K=https://go.microsoft.com/fwlink/?linkid=867396

Mobile Broadband GSM Test List

Test Summary: Win8MBN::TestAuthChallenge::SetAuthChallenge

Test Summary: Win8MBN::TestClassDriver::VerifyClassDriver

Test Summary: Win8MBN::TestConnect::ConnectDisconnect

Test Summary: Win8MBN::TestConnect::ConnectAndTraffic

Test Summary: Win8MBN::TestConnect::ConnectWhenPacketServiceIsDetached

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

Test Summary: Win8MBN::TestDriverCaps::Query

Test Summary: Win8MBN::TestDeviceCaps::Query

Test Summary: Win8MBN::TestDeviceServices::Query

Test Summary: Win8MBN::TestDisableEnable::DisableEnableWhileIdle

Test Summary: Win8MBN::TestDisableEnable::ConnectDisableEnableConnect

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

Test Summary: Win8MBN::TestDriverCaps::Query

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

Test Summary: Win8MBN::TestHomeProvider::Query

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficFixed

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficIncrement

Test Summary: Win8MBN::TestMultiCarrier::SetHomeProvider

Test Summary: Win8MBN::TestPacketService::AttachDetach

Test Summary: Win8MBN::TestPin::PinListQueryRadioOn

Test Summary: Win8MBN::TestPin::PinListQueryRadioOff

Test Summary: Win8MBN::TestPin::NoPinSupport

Test Summary: Win8MBN::TestPin::PinExSetEnableDisableWithValidPin

Test Summary: Win8MBN::TestPin::PinExSetDisableIncorrectPinWithValidLength

Test Summary: Win8MBN::TestPin::PukEnableDisableThroughIncorrectPinExDisable

Test Summary: Win8MBN::TestPowerStates::SleepAndWake

Test Summary: Win8MBN::TestPowerStates::HibernateAndWake

Test Summary: Win8MBN::TestPreferredProvider::Query

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredProvider

Test Summary: Win8MBN::TestPreferredProvider::AddRemoveForbiddenProvider

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredForbiddenProvider

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenRegistered

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenPacketServiceAttached

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenConnected

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenRegistered

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenPacketServiceAttached

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenConnected

Test Summary: Win8MBN::TestReadyInfo::Query

Test Summary: Win8MBN::TestRegisterState::Query

Test Summary: Win8MBN::TestRegisterState::RegisterAutomatic

Test Summary: Win8MBN::TestRegisterState::RegisterManualToHomeProvider

Test Summary: Win8MBN::TestRemoval::RemovalWhenRegistered

Test Summary: Win8MBN::TestRemoval::RemovalWhenPacketSvcAttached

Test Summary: Win8MBN::TestRemoval::RemovalWhenConnected

Test Summary: Win8MBN::TestSelectiveSuspend::SelectiveSuspendConnected

Test Summary: Win8MBN::TestSetup::NDISSetup

Test Summary: Win8MBN::TestSignalState::Query

Test Summary: Win8MBN::TestSimBad::BadSim

Test Summary: Win8MBN::TestSimNotInserted::SimNotInserted

Test Summary: Win8MBN::TestSimRoaming::SimRoaming

Test Summary: Win8MBN::TestSms::SmsConfigQuery

Test Summary: Win8MBN::TestSms::SmsStatusQuery

Test Summary: Win8MBN::TestSms::SmsSendMessageToSelf

Test Summary: Win8MBN::TestSms::SmsDeleteAllMessages

Test Summary: Win8MBN::TestSms::SmsReadAllMessages

Test Summary: Win8MBN::TestSms::SmsReadNewMessages

Test Summary: Win8MBN::TestUssd::SetUssdRequest

Test Summary: Win8MBN::TestVisibleProvider::RadioOff

Test Summary: Win8MBN::TestVisibleProvider::Registered

Test Summary: Win8MBN::TestVisibleProvider::Connected

Test Summary: Win8MBN::TestWake::WakeMachineFromConnectedStandbyWithSmsMessage

Test Summary: Win8MBN::TestAuthChallenge::SetAuthChallenge

Test will perform a set auth challenge and verify an auth response is received

Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_AUTH_CHALLENGE
PASS: Device supports OID_WWAN_AUTH_CHALLENGE
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify device supports an auth type
PASS: Device supports an auth type
Attempt to query auth challenge auth sim
   Attempt OID_WWAN_AUTH_CHALLENGE query
   PASS: OID_WWAN_AUTH_CHALLENGE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
PASS: Attempt to query auth challenge auth sim, succeeded
Attempt to query auth challenge auth aka
   Attempt OID_WWAN_AUTH_CHALLENGE query
   PASS: OID_WWAN_AUTH_CHALLENGE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
PASS: Attempt to query auth challenge auth aka, succeeded
Attempt to query auth challenge auth prime
   Attempt OID_WWAN_AUTH_CHALLENGE query
   PASS: OID_WWAN_AUTH_CHALLENGE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
PASS: Attempt to query auth challenge auth aka prime, succeeded

Test Summary: Win8MBN::TestClassDriver::VerifyClassDriver

The test verifies a USB device uses class driver.

If device is usb, verify classdriver is implemented
   Attempt to query interface device info data
   PASS: Attempt to query interface device info data, succeeded
   Determine if device is using MB Class Driver
   PASS: Device is using class driver
PASS: Driver verified

Test Summary: Win8MBN::TestConnect::ConnectDisconnect

The test verifies the test can sucessfully connect and disconnect.

Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2699 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xa1
      PASS: Connection id of returned context state is 0xa1
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n280 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xa1
PASS: Connection id of returned context state is 0xa1
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestConnect::ConnectAndTraffic

The test connects to the home network and downloads a file from the Internet.

Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2824 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xaa
      PASS: Connection id of returned context state is 0xaa
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Verify TCP/IP shows interface as connected in 0x3a98 ms
PASS: TCP/IP shows interface as connected in 0xc30 ms
Attempt to remove non wwan default routes
PASS: Attempt to remove non wwan default routes, succeeded
Attempt to download web doc
PASS: Attempt to download web doc, succeeded
Attempt to restore non wwan default routes
PASS: Attempt to restore non wwan default routes, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n281 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xaa
PASS: Connection id of returned context state is 0xaa
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestConnect::ConnectWhenPacketServiceIsDetached

The test verifies connection fails with WWAN_STATUS_PACKET_SVC_DETACHED when packet serivce is detached.

Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n47 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify device does not support auto packet service attach
      PASS: Device does not support auto packet service attach
      Attempt to set packet service (WwanPacketServiceActionDetach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionDetach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_PACKET_SVC_DETACHED[0xc004000d]
         PASS: Status is WWAN_STATUS_PACKET_SVC_DETACHED[0xc004000d]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

The test queries physical medium and verifies the value.

Attempt OID_GEN_PHYSICAL_MEDIUM query
PASS: OID_GEN_PHYSICAL_MEDIUM succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_PHYSICAL_MEDIUM returned NdisPhysicalMediumWirelessWan
PASS: Ndis physical medium (NdisPhysicalMediumWirelessWan[0x8]) is valid

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

The test queries media supported and verifies the value.

Attempt OID_GEN_MEDIA_SUPPORTED query
PASS: OID_GEN_MEDIA_SUPPORTED succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_MEDIA_SUPPORTED returned NdisMediumWirelessWan
PASS: Ndis medium (NdisMediumWirelessWan[0x9]) is valid

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

The test queries supported oid and verifies the value.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify OID_GEN_PHYSICAL_MEDIUM is supported
PASS: OID_GEN_PHYSICAL_MEDIUM is supported
Verify OID_GEN_MEDIA_SUPPORTED is supported
PASS: OID_GEN_MEDIA_SUPPORTED is supported
Verify OID_GEN_SUPPORTED_LIST is supported
PASS: OID_GEN_SUPPORTED_LIST is supported
Verify OID_WWAN_DEVICE_CAPS is supported
PASS: OID_WWAN_DEVICE_CAPS is supported
Verify OID_WWAN_READY_INFO is supported
PASS: OID_WWAN_READY_INFO is supported
Verify OID_WWAN_REGISTER_STATE is supported
PASS: OID_WWAN_REGISTER_STATE is supported
Verify OID_WWAN_RADIO_STATE is supported
PASS: OID_WWAN_RADIO_STATE is supported
Verify OID_WWAN_PIN_LIST is supported
PASS: OID_WWAN_PIN_LIST is supported
Verify OID_WWAN_HOME_PROVIDER is supported
PASS: OID_WWAN_HOME_PROVIDER is supported
Verify OID_WWAN_PACKET_SERVICE is supported
PASS: OID_WWAN_PACKET_SERVICE is supported
Verify OID_WWAN_SIGNAL_STATE is supported
PASS: OID_WWAN_SIGNAL_STATE is supported
Verify OID_WWAN_CONNECT is supported
PASS: OID_WWAN_CONNECT is supported
Verify OID_WWAN_PROVISIONED_CONTEXTS is supported
PASS: OID_WWAN_PROVISIONED_CONTEXTS is supported
Verify OID_WWAN_SMS_CONFIGURATION is supported
PASS: OID_WWAN_SMS_CONFIGURATION is supported
Verify OID_WWAN_SMS_READ is supported
PASS: OID_WWAN_SMS_READ is supported
Verify OID_WWAN_SMS_SEND is supported
PASS: OID_WWAN_SMS_SEND is supported
Verify OID_WWAN_SMS_DELETE is supported
PASS: OID_WWAN_SMS_DELETE is supported
Verify OID_WWAN_VISIBLE_PROVIDERS is supported
PASS: OID_WWAN_VISIBLE_PROVIDERS is supported
Verify OID_WWAN_PIN_EX is supported
PASS: OID_WWAN_PIN_EX is supported

Test Summary: Win8MBN::TestDriverCaps::Query

The test queries driver caps and verifies data members.

Attempt to query driver capabilities
   Attempt OID_WWAN_DRIVER_CAPS query
   PASS: OID_WWAN_DRIVER_CAPS succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query driver capabilities succeeded
Verify indication length is equal to or greater than 0x10
PASS: Indication length is valid
Verify ulMajorVersion is valid
PASS: ulMajorVersion (0x2) is valid
Verify ulMinorVersion is valid
PASS: ulMinorVersion (0x0) is valid
Verify ulDriverCaps is valid
PASS: ulDriverCaps (0x0) is valid

Test Summary: Win8MBN::TestDeviceCaps::Query

The test queries device caps and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify indication length is equal to or greater than 0x160
PASS: Indication length (0x160) is valid
Header.Revision is NDIS_WWAN_DEVICE_CAPS_REVISION_2
PASS: Header.Revision is NDIS_WWAN_DEVICE_CAPS_REVISION_2
Verify uStatus is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify CellularClassListHeader.ElementType is WwanStructCellularClass
PASS: CellularClassListHeader.ElementType is WwanStructCellularClass
Verify CellularClassListHeader.ElementCount is less than WwanCellularClassMax
PASS: CellularClassListHeader.ElementCount (0x0) is less than WwanCellularClassMax
Verify WwanDeviceType is valid
PASS: WwanDeviceType is valid
Verify WwanCellularClass is valid
PASS: WwanCellularClass is valid
Verify WwanVoiceClass is valid
PASS: WwanVoiceClass is valid
Verify WwanSimClass is valid
PASS: WwanSimClass is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify CustomDataClass is NULL terminated
PASS: CustomDataClass is NULL terminated
Verify WwanCdmaBandClass are valid
PASS: WwanCdmaBandClass are valid for this device
Verify WwanGsmBandClass are valid
PASS: WwanBandClass are valid for this device
Verify CustomBandClass is NULL terminated
PASS: CustomBandClass is NULL terminated
Verify WwanSmsCaps are valid
PASS: WwanSmsCaps are valid for this device
Verify WwanControlCaps are valid
PASS: WwanControlCaps are valid for this device
Verify DeviceId is NULL terminated
PASS: DeviceId is NULL terminated
Verify Manufacturer is NULL Terminated
PASS: Manufacturer is NULL terminated
Verify Model is NULL terminated
PASS: Model is NULL terminated
Verify FirmwareInfo is NULL terminated
PASS: FirmwareInfo is NULL terminated
Verify MaxActivatedContexts > 0
PASS: MaxActivatedContexts is > 0

Test Summary: Win8MBN::TestDeviceServices::Query

The test queries device services and verifies data members.

Attempt to query enumerate device services
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICES query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICES succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query enumerate device services succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded
Attempt to query device service commands
   Attempt OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS query
   PASS: OID_WWAN_ENUMERATE_DEVICE_SERVICE_COMMANDS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device service commands succeeded

Test Summary: Win8MBN::TestDisableEnable::DisableEnableWhileIdle

The test disables and enables the device while idle.

Attempt to disable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5})
PASS: Attempt to disable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5}), succeeded
Attempt to enable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5})
PASS: Attempt to enable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5}), succeeded
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n16 ms
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded

Test Summary: Win8MBN::TestDisableEnable::ConnectDisableEnableConnect

The test connects, disables, enables, and connects the device.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
         Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
         PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
         Performance Check:Verify unsolicited indication was received under 0n50000 ms
         PASS: Unsolicited indication was received in 0n593 ms
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n110 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xc0
      PASS: Connection id of returned context state is 0xc0
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to disable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5})
PASS: Attempt to disable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5}), succeeded
Attempt to enable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5})
PASS: Attempt to enable interface ({59C278C9-108B-4E85-B3EE-A57751024ED5}), succeeded
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n187 ms
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n93 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xf7
      PASS: Connection id of returned context state is 0xf7
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xf7
PASS: Connection id of returned context state is 0xf7
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

The test queries physical medium and verifies the value.

Attempt OID_GEN_PHYSICAL_MEDIUM query
PASS: OID_GEN_PHYSICAL_MEDIUM succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_PHYSICAL_MEDIUM returned NdisPhysicalMediumWirelessWan
PASS: Ndis physical medium (NdisPhysicalMediumWirelessWan[0x8]) is valid

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

The test queries media supported and verifies the value.

Attempt OID_GEN_MEDIA_SUPPORTED query
PASS: OID_GEN_MEDIA_SUPPORTED succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_MEDIA_SUPPORTED returned NdisMediumWirelessWan
PASS: Ndis medium (NdisMediumWirelessWan[0x9]) is valid

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

The test queries supported oid and verifies the value.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify OID_GEN_PHYSICAL_MEDIUM is supported
PASS: OID_GEN_PHYSICAL_MEDIUM is supported
Verify OID_GEN_MEDIA_SUPPORTED is supported
PASS: OID_GEN_MEDIA_SUPPORTED is supported
Verify OID_GEN_SUPPORTED_LIST is supported
PASS: OID_GEN_SUPPORTED_LIST is supported
Verify OID_WWAN_DEVICE_CAPS is supported
PASS: OID_WWAN_DEVICE_CAPS is supported
Verify OID_WWAN_READY_INFO is supported
PASS: OID_WWAN_READY_INFO is supported
Verify OID_WWAN_REGISTER_STATE is supported
PASS: OID_WWAN_REGISTER_STATE is supported
Verify OID_WWAN_RADIO_STATE is supported
PASS: OID_WWAN_RADIO_STATE is supported
Verify OID_WWAN_PIN_LIST is supported
PASS: OID_WWAN_PIN_LIST is supported
Verify OID_WWAN_HOME_PROVIDER is supported
PASS: OID_WWAN_HOME_PROVIDER is supported
Verify OID_WWAN_PACKET_SERVICE is supported
PASS: OID_WWAN_PACKET_SERVICE is supported
Verify OID_WWAN_SIGNAL_STATE is supported
PASS: OID_WWAN_SIGNAL_STATE is supported
Verify OID_WWAN_CONNECT is supported
PASS: OID_WWAN_CONNECT is supported
Verify OID_WWAN_PROVISIONED_CONTEXTS is supported
PASS: OID_WWAN_PROVISIONED_CONTEXTS is supported
Verify OID_WWAN_SMS_CONFIGURATION is supported
PASS: OID_WWAN_SMS_CONFIGURATION is supported
Verify OID_WWAN_SMS_READ is supported
PASS: OID_WWAN_SMS_READ is supported
Verify OID_WWAN_SMS_SEND is supported
PASS: OID_WWAN_SMS_SEND is supported
Verify OID_WWAN_SMS_DELETE is supported
PASS: OID_WWAN_SMS_DELETE is supported
Verify OID_WWAN_VISIBLE_PROVIDERS is supported
PASS: OID_WWAN_VISIBLE_PROVIDERS is supported
Verify OID_WWAN_PIN_EX is supported
PASS: OID_WWAN_PIN_EX is supported

Test Summary: Win8MBN::TestDriverCaps::Query

The test queries driver caps and verifies data members.

Attempt to query driver capabilities
   Attempt OID_WWAN_DRIVER_CAPS query
   PASS: OID_WWAN_DRIVER_CAPS succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query driver capabilities succeeded
Verify indication length is equal to or greater than 0x10
PASS: Indication length is valid
Verify ulMajorVersion is valid
PASS: ulMajorVersion (0x2) is valid
Verify ulMinorVersion is valid
PASS: ulMinorVersion (0x0) is valid
Verify ulDriverCaps is valid
PASS: ulDriverCaps (0x0) is valid

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestGenOids::PhysicalMediumQuery

The test queries physical medium and verifies the value.

Attempt OID_GEN_PHYSICAL_MEDIUM query
PASS: OID_GEN_PHYSICAL_MEDIUM succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_PHYSICAL_MEDIUM returned NdisPhysicalMediumWirelessWan
PASS: Ndis physical medium (NdisPhysicalMediumWirelessWan[0x8]) is valid

Test Summary: Win8MBN::TestGenOids::MediaSupportedQuery

The test queries media supported and verifies the value.

Attempt OID_GEN_MEDIA_SUPPORTED query
PASS: OID_GEN_MEDIA_SUPPORTED succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify indication length is 0x4
PASS: Indication length is 0x4
Verify OID_GEN_MEDIA_SUPPORTED returned NdisMediumWirelessWan
PASS: Ndis medium (NdisMediumWirelessWan[0x9]) is valid

Test Summary: Win8MBN::TestGenOids::SupportedOidQueryWin8

The test queries supported oid and verifies the value.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Verify OID_GEN_PHYSICAL_MEDIUM is supported
PASS: OID_GEN_PHYSICAL_MEDIUM is supported
Verify OID_GEN_MEDIA_SUPPORTED is supported
PASS: OID_GEN_MEDIA_SUPPORTED is supported
Verify OID_GEN_SUPPORTED_LIST is supported
PASS: OID_GEN_SUPPORTED_LIST is supported
Verify OID_WWAN_DEVICE_CAPS is supported
PASS: OID_WWAN_DEVICE_CAPS is supported
Verify OID_WWAN_READY_INFO is supported
PASS: OID_WWAN_READY_INFO is supported
Verify OID_WWAN_REGISTER_STATE is supported
PASS: OID_WWAN_REGISTER_STATE is supported
Verify OID_WWAN_RADIO_STATE is supported
PASS: OID_WWAN_RADIO_STATE is supported
Verify OID_WWAN_PIN_LIST is supported
PASS: OID_WWAN_PIN_LIST is supported
Verify OID_WWAN_HOME_PROVIDER is supported
PASS: OID_WWAN_HOME_PROVIDER is supported
Verify OID_WWAN_PACKET_SERVICE is supported
PASS: OID_WWAN_PACKET_SERVICE is supported
Verify OID_WWAN_SIGNAL_STATE is supported
PASS: OID_WWAN_SIGNAL_STATE is supported
Verify OID_WWAN_CONNECT is supported
PASS: OID_WWAN_CONNECT is supported
Verify OID_WWAN_PROVISIONED_CONTEXTS is supported
PASS: OID_WWAN_PROVISIONED_CONTEXTS is supported
Verify OID_WWAN_SMS_CONFIGURATION is supported
PASS: OID_WWAN_SMS_CONFIGURATION is supported
Verify OID_WWAN_SMS_READ is supported
PASS: OID_WWAN_SMS_READ is supported
Verify OID_WWAN_SMS_SEND is supported
PASS: OID_WWAN_SMS_SEND is supported
Verify OID_WWAN_SMS_DELETE is supported
PASS: OID_WWAN_SMS_DELETE is supported
Verify OID_WWAN_VISIBLE_PROVIDERS is supported
PASS: OID_WWAN_VISIBLE_PROVIDERS is supported
Verify OID_WWAN_PIN_EX is supported
PASS: OID_WWAN_PIN_EX is supported

Test Summary: Win8MBN::TestHomeProvider::Query

The test queries home provider and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query home provider succeeded
Verify indication length is equal to or greater than 0x4c
PASS: Indication length (0x4c) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12301) contains only digits
Verify ProviderId is 5 or 6 digits in length for GSM devices
PASS: ProviderId length (0x5) is valid
Verify ProviderState only uses WWAN_PROVIDER_STATE_HOME,WWAN_PROVIDER_STATE_FORBIDDEN,WWAN_PROVIDER_STATE_PREFERRED,WWAN_PROVIDER_STATE_VISIBLE, and\or WWAN_PROVIDER_STATE_REGISTERED
PASS: ProviderState (0x1) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (MS MBN) is populated
Verify ProviderState has WWAN_PROVIDER_STATE_HOME set
PASS: ProviderState (0x1) has WWAN_PROVIDER_STATE_HOME set

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficFixed

The test connects to loopback and send receives traffic.

Attempt to query interface device info data
PASS: Attempt to query interface device info data, succeeded
Determine if device is using MB Class Driver
PASS: Device is using class driver
Attempt to set connect context WwanActivationCommandActivate loopback (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandActivate loopback (null) (null), succeeded
Verify activation state of returned context state is WwanActivationStateActivated
PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
Attempt to add IPv4 Address
PASS: Attempt to add Loopback IPv4 Address, succeeded
Attempt to add Loopback IPv4 Route
   Attempt to get address from interface
   PASS: Attempt to get address (10.10.10.1) from interface, succeeded
PASS: Attempt to add Loopback IPv4 Route, succeeded
Start sending data
PASS: Start sending data, success
Wait 0n60000 ms for data to be sent
PASS: Wait for data to be sent, success
Verify data loss is less than 5%
PASS: Data loss (0.000000%) is less than 5%
Verify bandwidth is greater than 100 Mbps
PASS: Bandwidth (290.773333) is more than 100 Mbps
Attempt to delete IPv4 Address
PASS: Attempt to delete Loopback IPv4 Address, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xf7
PASS: Connection id of returned context state is 0xf7
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestLoopBack::TestVerifyTrafficIncrement

The test connects to loopback and send receives traffic.

Attempt to query interface device info data
PASS: Attempt to query interface device info data, succeeded
Determine if device is using MB Class Driver
PASS: Device is using class driver
Attempt to set connect context WwanActivationCommandActivate loopback (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandActivate loopback (null) (null), succeeded
Verify activation state of returned context state is WwanActivationStateActivated
PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
Attempt to add IPv4 Address
PASS: Attempt to add Loopback IPv4 Address, succeeded
Attempt to add Loopback IPv4 Route
   Attempt to get address from interface
   PASS: Attempt to get address (10.10.10.1) from interface, succeeded
PASS: Attempt to add Loopback IPv4 Route, succeeded
Start sending data
PASS: Start sending data, success
Wait for data to be sent
PASS: Wait for data to be sent, success
Verify data loss is less than 5%
PASS: Data loss (1.980012%) is less than 5%
Attempt to delete IPv4 Address
PASS: Attempt to delete Loopback IPv4 Address, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xf7
PASS: Connection id of returned context state is 0xf7
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestMultiCarrier::SetHomeProvider

The test sets the home provider.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify WWAN_CTRL_CAPS_MODEL_MULTI_CARRIER is supported
NA: Device does not support WWAN_CTRL_CAPS_MODEL_MULTI_CARRIER

Test Summary: Win8MBN::TestPacketService::AttachDetach

The test attaches and detaches the packet service.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify PacketServiceState is valid
PASS: PacketServiceState (WwanPacketServiceStateAttached[0x2]) is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Attempt to query packet service
   Attempt OID_WWAN_PACKET_SERVICE query
   PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query packet service succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify PacketServiceState is valid
PASS: PacketServiceState (WwanPacketServiceStateAttached[0x2]) is valid
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device
Verify WwanDataClass are valid
PASS: WwanDataClass are valid for this device

Test Summary: Win8MBN::TestPin::PinListQueryRadioOn

The test attempts a pin list query with the radio on.

Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded

Test Summary: Win8MBN::TestPin::PinListQueryRadioOff

The test attempts a pin list query with the radio off.

Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded

Test Summary: Win8MBN::TestPin::NoPinSupport

The test verifes a device that does not support PIN1.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is WwanPinModeNotSupported
NA: WwanPinTypePin1 is not WwanPinModeNotSupported

Test Summary: Win8MBN::TestPin::PinExSetEnableDisableWithValidPin

The test enables and disables PIN1 with a valid pin.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is not WwanPinModeNotSupported
PASS: WwanPinTypePin1 is not WwanPinModeNotSupported
Verify PIN1 parameter was provided
PASS: PIN1 (1111) parameter was provided
Verify WwanPinTypePin1 is WwanPinModeDisabled
PASS: WwanPinTypePin1 is WwanPinModeDisabled
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin ex succeeded
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null)) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeEnabled
PASS: NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeEnabled
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null)) succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeDisabled
PASS: NDIS_WWAN_PIN_LIST has WwanPinTypePin1 as WwanPinModeDisabled

Test Summary: Win8MBN::TestPin::PinExSetDisableIncorrectPinWithValidLength

The test attempts to enable PIN1 with incorrect pin with valid length.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is not WwanPinModeNotSupported
PASS: WwanPinTypePin1 is not WwanPinModeNotSupported
Verify PIN1 parameter was provided
PASS: PIN1 (1111) parameter was provided
Verify WwanPinTypePin1 is WwanPinModeDisabled
PASS: WwanPinTypePin1 is WwanPinModeDisabled
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin ex succeeded
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null)) succeeded
Attempt to set WwanPinTypePin1 WwanPinOperationDisable with incorrect pin [pin:4321]
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
PASS: WWAN_STATUS == WWAN_STATUS_FAILURE
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null)) succeeded

Test Summary: Win8MBN::TestPin::PukEnableDisableThroughIncorrectPinExDisable

The test enables PUK1 by entering incorrect PIN1 multiple times and then disables PUK1.

Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded
Verify WwanPinTypePin1 is not WwanPinModeNotSupported
PASS: WwanPinTypePin1 is not WwanPinModeNotSupported
Verify PIN1 parameter was provided
PASS: PIN1 (1111) parameter was provided
Verify PUK1 parameter was provided
PASS: PUK1 (2222) parameter was provided
Verify WwanPinTypePin1 is WwanPinModeDisabled
PASS: WwanPinTypePin1 is WwanPinModeDisabled
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin ex succeeded
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationEnable Pin:1111 NewPin:(null)) succeeded
Attempt to set WwanPinTypePin1 WwanPinOperationDisable with incorrect pin [pin:4321]
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
PASS: WWAN_STATUS == WWAN_STATUS_FAILURE
Attempt to set WwanPinTypePin1 WwanPinOperationDisable with incorrect pin [pin:4321]
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
PASS: WWAN_STATUS == WWAN_STATUS_FAILURE
Verify attempts remaining decremented by 1
PASS: attempts remaining decremented by 1 [Attempts Remaining:0x1]
Attempt to set WwanPinTypePin1 WwanPinOperationDisable with incorrect pin [pin:4321]
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
PASS: WWAN_STATUS == WWAN_STATUS_FAILURE
Verify pin type is WwanPinTypePuk1
PASS: Pin type is WwanPinTypePuk1
Verify pin state is WwanPinStateEnter
PASS: Pin type is WwanPinStateEnter
Attempt to set pin ex (WwanPinTypePuk1 WwanPinOperationEnter Pin:2222 NewPin:1111)
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePuk1 WwanPinOperationEnter Pin:2222 NewPin:1111) succeeded
Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null))
   Attempt OID_WWAN_PIN_EX set
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set pin ex (WwanPinTypePin1 WwanPinOperationDisable Pin:1111 NewPin:(null)) succeeded
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin ex succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query pin list succeeded

Test Summary: Win8MBN::TestPowerStates::SleepAndWake

The test connects, puts the machine into sleep mode, wakes the machine, and connects.

Verify machine processor is supported
PASS: Machine processor (0x0) is supported
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2792 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xac
      PASS: Connection id of returned context state is 0xac
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to put computer into Sleep mode for 0x3c seconds
PASS: Attempt to put computer into Sleep mode for 0x3c seconds, succeeded)
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n5569 ms
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n32 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n4743 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n31 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n3681 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xb0
      PASS: Connection id of returned context state is 0xb0
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Verify TCP/IP shows interface as connected in 0x3a98 ms
PASS: TCP/IP shows interface as connected in 0x2174 ms
Attempt to remove non wwan default routes
PASS: Attempt to remove non wwan default routes, succeeded
Attempt to download web doc
PASS: Attempt to download web doc, succeeded
Attempt to restore non wwan default routes
PASS: Attempt to restore non wwan default routes, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n265 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xb0
PASS: Connection id of returned context state is 0xb0
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestPowerStates::HibernateAndWake

The test connects, puts the machine into hiberantion mode, wakes the machine, and connects.

Verify machine processor is supported
PASS: Machine processor (0x0) is supported
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2698 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0xcd
      PASS: Connection id of returned context state is 0xcd
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to put computer into Hibernate mode for 0x3c seconds
PASS: Attempt to put computer into Hibernate mode for 0x3c seconds, succeeded)
Wait 0xea60 ms for device to enter WwanReadyStateInitialized
PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
PASS: WwanReadyStateInitialized occured in 0n31 ms
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n1155 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n31 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n3572 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0x88
      PASS: Connection id of returned context state is 0x88
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Verify TCP/IP shows interface as connected in 0x3a98 ms
PASS: TCP/IP did not show interface as connected in 0x3a98 ms
Attempt to remove non wwan default routes
PASS: Attempt to remove non wwan default routes, succeeded
Attempt to download web doc
PASS: Attempt to download web doc, succeeded
Attempt to restore non wwan default routes
PASS: Attempt to restore non wwan default routes, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n592 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x88
PASS: Connection id of returned context state is 0x88
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestPreferredProvider::Query

The test queries preferred providers and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
PASS: Device is GSM
Verify OID_WWAN_PREFERRED_PROVIDERS is supported
   Attempt to query supported OIDs
      Attempt OID_GEN_SUPPORTED_LIST query
      PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
   PASS: Attempt to query supported OIDs succeeded
PASS: Device supports OID_WWAN_PREFERRED_PROVIDERS
Verify OID_WWAN_PREFERRED_PROVIDERS query is supported
   Attempt to query preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS query
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS query is supported
Verify indication length is equal to or greater than 0x98
PASS: Indication length (0xb0) is valid
Verify element type is WwanStructProvider2
PASS: Element type is WwanStructProvider2
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12303) contains only digits
Verify ProviderId is 5 or 6 digits in length for GSM devices
PASS: ProviderId length (0x5) is valid
Verify ProviderState only uses WWAN_PROVIDER_STATE_HOME,WWAN_PROVIDER_STATE_FORBIDDEN,WWAN_PROVIDER_STATE_PREFERRED,WWAN_PROVIDER_STATE_VISIBLE, and\or WWAN_PROVIDER_STATE_REGISTERED
PASS: ProviderState (0x4) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (MS MBN2) is populated
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12302) contains only digits
Verify ProviderId is 5 or 6 digits in length for GSM devices
PASS: ProviderId length (0x5) is valid
Verify ProviderState only uses WWAN_PROVIDER_STATE_HOME,WWAN_PROVIDER_STATE_FORBIDDEN,WWAN_PROVIDER_STATE_PREFERRED,WWAN_PROVIDER_STATE_VISIBLE, and\or WWAN_PROVIDER_STATE_REGISTERED
PASS: ProviderState (0x4) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (MS MBN) is populated

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredProvider

The test adds and removes a preferred provider.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
PASS: Device is GSM
Verify OID_WWAN_PREFERRED_PROVIDERS is supported
   Attempt to query supported OIDs
      Attempt OID_GEN_SUPPORTED_LIST query
      PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
   PASS: Attempt to query supported OIDs succeeded
PASS: Device supports OID_WWAN_PREFERRED_PROVIDERS
Verify OID_WWAN_PREFERRED_PROVIDERS query is supported
   Attempt to query preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS query
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS query is supported
Verify OID_WWAN_PREFERRED_PROVIDERS set is supported
   Attempt to set preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS set
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS set is supported
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status
   PASS: Status is WWAN_STATUS_READ_FAILURE[0xc0040017]
PASS: Attempt to query preferred providers succeeded
Verify OID_WWAN_PREFERRED_PROVIDERS set is supported
   Attempt to set preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS set
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS set is supported
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query preferred providers succeeded
Verify custom provider (12345) was added
PASS: Custom provider (12345) was added
Verify ProviderState is 0x4
PASS: ProviderState (0x4) is 0x4
Verify WwanDataClass is 0x3f
PASS: WwanDataClass (0x3f) is 0x3f
Attempt to set preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS set
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set preferred providers succeeded

Test Summary: Win8MBN::TestPreferredProvider::AddRemoveForbiddenProvider

The test adds and removes a forbidden provider.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
PASS: Device is GSM
Verify OID_WWAN_PREFERRED_PROVIDERS is supported
   Attempt to query supported OIDs
      Attempt OID_GEN_SUPPORTED_LIST query
      PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
   PASS: Attempt to query supported OIDs succeeded
PASS: Device supports OID_WWAN_PREFERRED_PROVIDERS
Verify OID_WWAN_PREFERRED_PROVIDERS query is supported
   Attempt to query preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS query
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS query is supported
Verify OID_WWAN_PREFERRED_PROVIDERS set is supported
   Attempt to set preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS set
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS set is supported
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_READ_FAILURE[0xc0040017]
PASS: Attempt to query preferred providers succeeded
Verify OID_WWAN_PREFERRED_PROVIDERS set is supported
   Attempt to set preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS set
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS set is supported
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query preferred providers succeeded
Verify custom provider (54321) was added
PASS: Custom provider (54321) was added
Verify ProviderState is 0x2
PASS: ProviderState (0x2) is 0x2
Verify WwanDataClass is 0x3f
PASS: WwanDataClass (0x3f) is 0x3f
Attempt to set preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS set
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set preferred providers succeeded

Test Summary: Win8MBN::TestPreferredProvider::AddRemovePreferredForbiddenProvider

The test adds and removes both forbidden and forbidden providers.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify the device is GSM
PASS: Device is GSM
Verify OID_WWAN_PREFERRED_PROVIDERS is supported
   Attempt to query supported OIDs
      Attempt OID_GEN_SUPPORTED_LIST query
      PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
   PASS: Attempt to query supported OIDs succeeded
PASS: Device supports OID_WWAN_PREFERRED_PROVIDERS
Verify OID_WWAN_PREFERRED_PROVIDERS query is supported
   Attempt to query preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS query
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS query is supported
Verify OID_WWAN_PREFERRED_PROVIDERS set is supported
   Attempt to set preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS set
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS set is supported
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status
   PASS: Status is WWAN_STATUS_READ_FAILURE[0xc0040017]
PASS: Attempt to query preferred providers succeeded
Verify OID_WWAN_PREFERRED_PROVIDERS set is supported
   Attempt to set preferred providers
      Attempt OID_WWAN_PREFERRED_PROVIDERS set
      PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query preferred providers succeeded
PASS: OID_WWAN_PREFERRED_PROVIDERS set is supported
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query preferred providers succeeded
Verify custom provider (12345) was added
PASS: Custom provider (12345) was added
Verify ProviderState is 0x4
PASS: ProviderState (0x4) is 0x4
Verify WwanDataClass is 0x3f
PASS: WwanDataClass (0x3f) is 0x3f
Verify custom provider (54321) was added
PASS: Custom provider (54321) was added
Verify ProviderState is 0x2
PASS: ProviderState (0x2) is 0x2
Verify WwanDataClass is 0x3f
PASS: WwanDataClass (0x3f) is 0x3f
Attempt to set preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS set
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set preferred providers succeeded

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenRegistered

The test turns the software radio off and on when registered.

Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOff[0x0]
PASS: SwRadioState is WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenPacketServiceAttached

The test turns the software radio off and on when packet service is attached.

Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOff[0x0]
PASS: SwRadioState is WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid

Test Summary: Win8MBN::TestRadioStateSw::TurnSwRadioOffOnWhenConnected

The test turns the software radio off and on when connected.

Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n109 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x79
      PASS: Connection id of returned context state is 0x79
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOff[0x0]
PASS: SwRadioState is WwanRadioOff[0x0]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOff[0x0]) is valid
Wait for unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n78 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xd6
      PASS: Connection id of returned context state is 0xd6
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xd6
PASS: Connection id of returned context state is 0xd6
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded
Verify indication shows correct state
PASS: SwRadioState is correct WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Verify SwRadioState is WwanRadioOn[0x1]
PASS: SwRadioState is WwanRadioOn[0x1]
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify HwRadioState
PASS: HwRadioState (WwanRadioOn[0x1]) is valid
Verify SwRadioState
PASS: SwRadioState (WwanRadioOn[0x1]) is valid

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenRegistered

The test turns the hardware radio off and on when registered.

Verify device has hardware radio switch
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device has hardware radio switch
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to turn hardware radio off
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n5428 ms
PASS: Attempt to turn hardware radio off, succeeded
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n16 ms
Attempt to turn hardware radio on
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n4851 ms
PASS: Attempt to turn hardware radio on, succeeded
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
   PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
   Performance Check:Verify unsolicited indication was received under 0n50000 ms
   PASS: Unsolicited indication was received in 0n31 ms
PASS: Attempt to auto register, succeeded

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenPacketServiceAttached

The test turns the hardware radio off and on when packet service attached.

Verify device has hardware radio switch
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device has hardware radio switch
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to turn hardware radio off
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n2184 ms
PASS: Attempt to turn hardware radio off, succeeded
Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateDetached) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to turn hardware radio on
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n1482 ms
PASS: Attempt to turn hardware radio on, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
      PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
      Performance Check:Verify unsolicited indication was received under 0n50000 ms
      PASS: Unsolicited indication was received in 0n671 ms
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded

Test Summary: Win8MBN::TestRadioStateHw::TurnHwRadioOffOnWhenConnected

The test turns the hardware radio off and on when connected.

Verify device has hardware radio switch
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device has hardware radio switch
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n94 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x91
      PASS: Connection id of returned context state is 0x91
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to turn hardware radio off
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n2776 ms
PASS: Attempt to turn hardware radio off, succeeded
Wait for unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication for 0x3a98 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_CONTEXT_STATE (WwanActivationStateDeactivated) indication
Performance Check:Verify unsolicited indication was received under 0n15000 ms
PASS: Unsolicited indication was received in 0n0 ms
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to turn hardware radio on
   Verify unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_RADIO_STATE indication was received
   Performance Check:Verify unsolicited indication was received under 0n60000 ms
   PASS: Unsolicited indication was received in 0n1529 ms
PASS: Attempt to turn hardware radio on, succeeded
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
         Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication for 0xc350 seconds
         PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateHome | WwanRegisterStatePartner | WwanRegisterStateRoaming) indication
         Performance Check:Verify unsolicited indication was received under 0n50000 ms
         PASS: Unsolicited indication was received in 0n702 ms
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n15 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n78 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xf6
      PASS: Connection id of returned context state is 0xf6
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xf6
PASS: Connection id of returned context state is 0xf6
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestReadyInfo::Query

The test queries ready info and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query ready info
   Attempt OID_WWAN_READY_INFO query
   PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
PASS: Attempt to query ready info succeeded
Verify indication length is equal to or greater than 0x80
PASS: Indication length is 0x80
Verify ReadyState is valid
PASS: ReadyState (0x1) is valid
Verify EmergencyMode is valid
PASS: EmergencyMode (0x0) is valid
Verify SubscriberId is NULL terminated
PASS: SubscriberId is NULL terminated
Verify SubscriberId contains only digits
PASS: SubscriberId (1234567890) contains only digits
Verify SimIccId is NULL terminated
PASS: SimIccId is NULL terminated
Verify SimIccId contains only digits
PASS: SimIccId (098765432109876) contains only digits
Verify SubscriberId is up to 15 digits in length for GSM devices
PASS: SubscriberId length (0xa) is valid
Verify SimIccId is between 15 to 20 digits in length for GSM devices
PASS: SimIccId length (0xf) is valid
Verify CdmaShortMsgSize is WWAN_CDMA_SHORT_MSG_SIZE_UNKNOWN for GSM devices
PASS: CdmaShortMsgSize (0x0) is valid
Verify ElementType is WwanStructTN
PASS: ElementType is valid

Test Summary: Win8MBN::TestRegisterState::Query

The test queries register state and verifies data members.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query Register State
   Attempt OID_WWAN_REGISTER_STATE query
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query register state succeeded
Verify indication length is equal to or greater than 0xd4
PASS: Indication length (0xd4) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify RegisterState is valid
PASS: RegisterState (WwanRegisterStateHome[0x0]) is valid
Verify RegisterMode is valid
PASS: RegisterMode (WwanRegisterStateHome[0x0]) is valid
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12301) contains only digits
Verify ProviderId is 5 or 6 digits in length for GSM devices
PASS: ProviderId length (0x5) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (12301) is populated
Verify WwanRegFlags is valid
PASS: WwanRegFlags (0x2) is valid

Test Summary: Win8MBN::TestRegisterState::RegisterAutomatic

The test attempts to register in automatic mode.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query home provider succeeded
Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
   Attempt OID_WWAN_REGISTER_STATE set
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n50000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
Verify register mode is WwanRegisterModeAutomatic
PASS: Register mode is WwanRegisterModeAutomatic
Verify register state is WwanRegisterStateHome, WwanRegisterStateRoaming, or WwanRegisterStatePartner
PASS: Register state is WwanRegisterStateHome

Test Summary: Win8MBN::TestRegisterState::RegisterManualToHomeProvider

The test attempts to register to the home provider in manual mode.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify device supports manual registration
PASS: Device supports manual registration
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query home provider succeeded
Attempt to set register state (action:WwanRegisterActionManual dataclass:0x3f)
   Attempt OID_WWAN_REGISTER_STATE set
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n50000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set register state (action:WwanRegisterActionManual dataclass:0x3f) succeeded
Verify register mode is WwanRegisterModeManual
PASS: Register mode is WwanRegisterModeManual
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded

Test Summary: Win8MBN::TestRemoval::RemovalWhenRegistered

The test registers and prompts the user to remove the device.

Verify device is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device is removable
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to remove the device
PASS: Attempt to remove the device, succeeded
Attempt to add the device
   Wait 0xea60 ms for device to enter WwanReadyStateInitialized
   PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
   Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
   PASS: WwanReadyStateInitialized occured in 0n15 ms
PASS: Attempt to add the device, succeeded
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded

Test Summary: Win8MBN::TestRemoval::RemovalWhenPacketSvcAttached

The test attaches the packet service and prompts the user to remove the device.

Verify device is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device is removable
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded
Attempt to remove the device
PASS: Attempt to remove the device, succeeded
Attempt to add the device
   Wait 0xea60 ms for device to enter WwanReadyStateInitialized
   PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
   Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
   PASS: WwanReadyStateInitialized occured in 0n0 ms
PASS: Attempt to add the device, succeeded
Attempt to packet service attach
   Attempt to auto register
      Attempt to query device capabilities
         Attempt OID_WWAN_DEVICE_CAPS query
         PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query device capabilities succeeded
      Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
         Attempt OID_WWAN_REGISTER_STATE set
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n50000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
   PASS: Attempt to auto register, succeeded
   Verify auto packet service attach
      Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
      PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
   PASS: Auto packet attach succeeded
   Verify packet service state is WwanPacketServiceStateAttached
   PASS: Packet service state is WwanPacketServiceStateAttached
PASS: Attempt to packet service attach, succeeded

Test Summary: Win8MBN::TestRemoval::RemovalWhenConnected

The test connects and prompts the user to remove the device.

Verify device is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: Device is removable
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n78 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xc2
      PASS: Connection id of returned context state is 0xc2
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to remove the device
PASS: Attempt to remove the device, succeeded
Attempt to add the device
   Wait 0xea60 ms for device to enter WwanReadyStateInitialized
   PASS: Wait for device to enter WwanReadyStateInitialized, succeeded
   Performance Check:Verify WwanReadyStateInitialized occured under 0n60000 ms
   PASS: WwanReadyStateInitialized occured in 0n0 ms
PASS: Attempt to add the device, succeeded
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n140 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0xde
      PASS: Connection id of returned context state is 0xde
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n31 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0xde
PASS: Connection id of returned context state is 0xde
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestSelectiveSuspend::SelectiveSuspendConnected

The test blocks outbound IP traffic to verify the device enters selective suspend state. The test will then unblock outbound traffic and verify the device comes out of selective suspend state.

Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n31 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x1f) succeeded
      PASS: Attempt to auto register, succeeded
      Attempt to set packet service (WwanPacketServiceActionAttach)
         Attempt OID_WWAN_PACKET_SERVICE set
         PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS
         PASS: Status is WWAN_STATUS_SUCCESS
      PASS: Attempt to set packet service (WwanPacketServiceActionAttach) succeeded
      Attempt to set connect context WwanActivationCommandActivate
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n2652 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate , succeeded
      Verify connection id of returned context state is 0x1e
      PASS: Connection id of returned context state is 0x1e
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to open engine handle
PASS: Attempt to open engine handle, succeeded
Attempt to add IPv4 filter
PASS: Attempt to add IPv4 filter, succeeded
Attempt to add IPv6 filter
PASS: Attempt to add IPv6 filter, succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n1201 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x1e
PASS: Connection id of returned context state is 0x1e
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated
Verify NDIS Events
PASS: Number of NDIS Events (0x128b), succeeded
Verify NDIS Selective Suspend Events
PASS: Verify NDIS Selective Suspend Events, succeeded

Test Summary: Win8MBN::TestSetup::NDISSetup

The test verifies the NDIS CoInstaller values.

Attempt to NDIS Coinstaller values
   Attempt to read IfType
   PASS: Attempt to read IfType, succeeded
   Attempt to read MediaType
   PASS: Attempt to read MediaType, succeeded
   Attempt to read PhysicalMediaType
   PASS: Attempt to read PhysicalMediaType, succeeded
   Attempt to read EnableDhcp
      Attempt to read UpperRange
      PASS: Attempt to read UpperRange, succeeded
      Attempt to read LowerRange
      PASS: Attempt to read LowerRange, succeeded
   PASS: Attempt to read EnableDhcp, succeeded
PASS: Attempt to read NDIS Coinstaller values, succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify MediaType is NdisMediumWirelessWan
PASS: MediaType is NdisMediumWirelessWan
Verify PhysicalMediaType is NdisPhysicalMediumWirelessWan
PASS: PhysicalMediaType is NdisPhysicalMediumWirelessWan
Verify EnableDhcp is 0
PASS: EnableDhcp is 0
Verify UpperRange contains flpp4
PASS: UpperRange (flpp4, flpp6) contains flpp4
Verify LowerRange is ppip
PASS: LowerRange is ppip

Test Summary: Win8MBN::TestSignalState::Query

The test queries signal state and verifies values.

Attempt to query signal state
   Attempt OID_WWAN_SIGNAL_STATE query
   PASS: OID_WWAN_SIGNAL_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query signal state succeeded
Verify indication length is equal to or greater than 0x18
PASS: Indication length (0x18) is valid
Verify RSSI is between 0 and 31 or WWAN_RSSI_UNKNOWN
PASS: RSSI (0x1e) is between 0 and 31 or WWAN_RSSI_UNKNOWN
Verify error rate is between 0 and 7 or WWAN_ERROR_RATE_UNKNOWN
PASS: Error rate (0x0) is between 0 and 7 or WWAN_ERROR_RATE_UNKNOWN
Verify RSSI interval is more than 5 seconds
PASS: RSSI interval (0x5) is more than 5 seconds

Test Summary: Win8MBN::TestSimBad::BadSim

The test verfies proper behavior when a bad SIM is inserted.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify device current cell class is GSM
PASS: Device current cell class is GSM
Verify SIM is removable
PASS: SIM is removable
Attempt to query ready info
   Attempt OID_WWAN_READY_INFO query
   PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
PASS: Attempt to query ready info succeeded
Verify ready state is WwanReadyStateBadSim
PASS: Ready state is WwanReadyStateBadSim
Attempt to query driver capabilities
   Attempt OID_WWAN_DRIVER_CAPS query
   PASS: OID_WWAN_DRIVER_CAPS succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query driver capabilities succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Attempt to query signal state
   Attempt OID_WWAN_SIGNAL_STATE query
   PASS: OID_WWAN_SIGNAL_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query signal state succeeded
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_BAD_SIM[0xc0040005]
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query pin ex succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_BAD_SIM[0xc0040005]
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query pin list succeeded
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_BAD_SIM[0xc0040005]
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query home provider succeeded
Attempt to query SMS configuration
   Attempt OID_WWAN_SMS_CONFIGURATION query
   PASS: OID_WWAN_SMS_CONFIGURATION succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_BAD_SIM[0xc0040005]
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query SMS configuration succeeded
Attempt to query SMS status
   Attempt OID_WWAN_SMS_STATUS query
   PASS: OID_WWAN_SMS_STATUS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_BAD_SIM[0xc0040005]
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query SMS status succeeded
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query visible providers succeeded
Attempt to query context state
   Attempt OID_WWAN_CONNECT query
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query context state succeeded
Attempt to query register state
   Attempt OID_WWAN_REGISTER_STATE query
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query register state succeeded
Attempt to query packet service
   Attempt OID_WWAN_PACKET_SERVICE query
   PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query packet service succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_BAD_SIM[0xc0040005]
PASS: Attempt to query preferred providers succeeded
Attempt to query provisioned contexts
   Attempt OID_WWAN_PROVISIONED_CONTEXTS query
   PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query provisioned contexts succeeded

Test Summary: Win8MBN::TestSimNotInserted::SimNotInserted

The test verfies proper behavior when no SIM is inserted.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Verify device current cell class is GSM
PASS: Device current cell class is GSM
Verify SIM is removable
PASS: SIM is removable
Attempt to query ready info
   Attempt OID_WWAN_READY_INFO query
   PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
PASS: Attempt to query ready info succeeded
Verify ready state is WwanReadyStateSimNotInserted
PASS: Ready state is WwanReadyStateSimNotInserted
Attempt to query driver capabilities
   Attempt OID_WWAN_DRIVER_CAPS query
   PASS: OID_WWAN_DRIVER_CAPS succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query driver capabilities succeeded
Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query radio state
   Attempt OID_WWAN_RADIO_STATE query
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query radio state succeeded
Attempt to query signal state
   Attempt OID_WWAN_SIGNAL_STATE query
   PASS: OID_WWAN_SIGNAL_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query signal state succeeded
Attempt to query pin ex
   Attempt OID_WWAN_PIN_EX query
   PASS: OID_WWAN_PIN_EX succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query pin ex succeeded
Attempt to query pin list
   Attempt OID_WWAN_PIN_LIST query
   PASS: OID_WWAN_PIN_LIST succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query pin list succeeded
Attempt to query home provider
   Attempt OID_WWAN_HOME_PROVIDER query
   PASS: OID_WWAN_HOME_PROVIDER succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query home provider succeeded
Attempt to query SMS configuration
   Attempt OID_WWAN_SMS_CONFIGURATION query
   PASS: OID_WWAN_SMS_CONFIGURATION succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query SMS configuration succeeded
Attempt to query SMS status
   Attempt OID_WWAN_SMS_STATUS query
   PASS: OID_WWAN_SMS_STATUS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query SMS status succeeded
Attempt to query context state
   Attempt OID_WWAN_CONNECT query
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query context state succeeded
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query visible providers succeeded
Attempt to query register state
   Attempt OID_WWAN_REGISTER_STATE query
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query register state succeeded
Attempt to query packet service
   Attempt OID_WWAN_PACKET_SERVICE query
   PASS: OID_WWAN_PACKET_SERVICE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query packet service succeeded
Attempt OID_GEN_SUPPORTED_LIST query
PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
Attempt to query preferred providers
   Attempt OID_WWAN_PREFERRED_PROVIDERS query
   PASS: OID_WWAN_PREFERRED_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query preferred providers succeeded
Attempt to query provisioned contexts
   Attempt OID_WWAN_PROVISIONED_CONTEXTS query
   PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status
   PASS: Status is WWAN_STATUS_SIM_NOT_INSERTED[0xc0040004]
PASS: Attempt to query provisioned contexts succeeded

Test Summary: Win8MBN::TestSimRoaming::SimRoaming

The test verfies proper behavior when a roaming SIM is inserted.

Verify SIM is removable
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: SIM is removable
Attempt to connect using provided context
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n16 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n0 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n780 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x33
      PASS: Connection id of returned context state is 0x33
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provided context succeeded
Attempt to query Register State
   Attempt OID_WWAN_REGISTER_STATE query
   PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query register state succeeded
Verify register state is WwanRegisterStatePartner or WwanRegisterStateRoaming
PASS: Register state is WwanRegisterStatePartner
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x33
PASS: Connection id of returned context state is 0x33
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestSms::SmsConfigQuery

The test queries sms config and verifies data members.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to query SMS configuration
   Attempt OID_WWAN_SMS_CONFIGURATION query
   PASS: OID_WWAN_SMS_CONFIGURATION succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query SMS configuration succeeded
Verify indication length is equal to or greater than 0x20
PASS: Indication length (0x20) is valid
Verify Status is valid
PASS: Status (WWAN_STATUS_SUCCESS[0x0]) is valid
Verify SmsFormat is WwanSmsFormatCdma or WwanSmsFormatPdu
PASS: SmsFormat is WwanSmsFormatPdu[0x0]

Test Summary: Win8MBN::TestSms::SmsStatusQuery

The test queries sms status and verifies data members.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to query SMS status
   Attempt OID_WWAN_SMS_STATUS query
   PASS: OID_WWAN_SMS_STATUS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query SMS status succeeded
Verify indication length is equal to or greater than 0x10
PASS: Indication length (0x10) is valid

Test Summary: Win8MBN::TestSms::SmsSendMessageToSelf

The test sends an SMS message to itself and verifies it receives the message.

Description: The test sends an SMS message to itself and verifies it receives the message.
Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n46 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded

Test Summary: Win8MBN::TestSms::SmsDeleteAllMessages

The test deletes all messages.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded
Attempt to query SMS read (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list is 0x0
PASS: Number of messages in receive list (0x0) is 0x0

Test Summary: Win8MBN::TestSms::SmsReadAllMessages

The test reads all messages.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n0 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to query SMS read (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list of status WwanMsgStatusNew is 0x2
PASS: Number of messages (0x2) in receive list of status WwanMsgStatusNew (0x0) is 0x2
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded

Test Summary: Win8MBN::TestSms::SmsReadNewMessages

The test reads all new messages.

Attempt to initialize test
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Verify phone number of device was provided as a parameter or can be obtained from ready info
      Attempt to query ready info
         Attempt OID_WWAN_READY_INFO query
         PASS: OID_WWAN_READY_INFO succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
      PASS: Attempt to query ready info succeeded
   PASS: Phone number of device (4255551212) was obtained
   Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
      Attempt OID_WWAN_SMS_DELETE set
      PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS delete succeeded
PASS: Attempt to initialize test, succeeded
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to query SMS read (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list of status WwanMsgStatusNew is 0x1
PASS: Number of messages (0x1) in receive list of status WwanMsgStatusNew (0x0) is 0x1
Attempt to send message to self
   Attempt to set SMS send
      Attempt OID_WWAN_SMS_SEND set
      PASS: OID_WWAN_SMS_SEND succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to set SMS send succeeded
   Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
   PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
   Performance Check:Verify unsolicited indication was received under 0n300000 ms
   PASS: Unsolicited indication was received in 0n0 ms
PASS: Attempt to send message to self, succeeded
Attempt to query SMS read (Flag:WwanSmsFlagNew Index:0x0)
   Attempt OID_WWAN_SMS_READ query
   PASS: OID_WWAN_SMS_READ succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify all indications are received under 0x3a98 seconds
   PASS: All indications are received under 0x3a98 seconds
PASS: Attempt to query SMS read, succeeded
Verify number of messages in receive list of status WwanMsgStatusNew is 0x1
PASS: Number of messages (0x1) in receive list of status WwanMsgStatusNew (0x0) is 0x1
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded

Test Summary: Win8MBN::TestUssd::SetUssdRequest

The test will attempt a USSD set operation and verify the USSD status indication.

Verify device supports OID_WWAN_USSD
   Attempt to query supported OIDs
      Attempt OID_GEN_SUPPORTED_LIST query
      PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
   PASS: Attempt to query supported OIDs succeeded
PASS: Device supports OID_WWAN_USSD
Verify device reports WWAN_CTRL_CAPS_USSD
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
PASS: device reports WWAN_CTRL_CAPS_USSD
Attempt to set ussd request
   Attempt OID_WWAN_USSD set
   PASS: OID_WWAN_USSD succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n2542 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set ussd request, succeeded

Test Summary: Win8MBN::TestVisibleProvider::RadioOff

The test queries visible providers while radio is off.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_VISIBLE_PROVIDERS
PASS: Device supports OID_WWAN_VISIBLE_PROVIDERS
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to set SwRadioState (WwanRadioOff[0x0])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOff[0x0]) succeeded
Wait for unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication for 0x7530 seconds
PASS: Succeeded to receive unsolicited NDIS_STATUS_WWAN_REGISTER_STATE (WwanRegisterStateDeregistered) indication
Performance Check:Verify unsolicited indication was received under 0n30000 ms
PASS: Unsolicited indication was received in 0n0 ms
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n15 ms
   Verify status is WWAN_STATUS_RADIO_POWER_OFF[0xc0040015]
   PASS: Status is WWAN_STATUS_RADIO_POWER_OFF[0xc0040015]
PASS: Attempt to query visible providers succeeded
Attempt to set SwRadioState (WwanRadioOn[0x1])
   Attempt OID_WWAN_RADIO_STATE set
   PASS: OID_WWAN_RADIO_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS
   PASS: Status is WWAN_STATUS_SUCCESS
PASS: Attempt to set SwRadioState (WwanRadioOn[0x1]) succeeded

Test Summary: Win8MBN::TestVisibleProvider::Registered

The test queries visible providers while auto registered.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_VISIBLE_PROVIDERS
PASS: Device supports OID_WWAN_VISIBLE_PROVIDERS
Attempt to auto register
   Attempt to query device capabilities
      Attempt OID_WWAN_DEVICE_CAPS query
      PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n16 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query device capabilities succeeded
   Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
      Attempt OID_WWAN_REGISTER_STATE set
      PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n50000 ms
      PASS: Indication was received in 0n15 ms
      Verify status is WWAN_STATUS_SUCCESS
      PASS: Status is WWAN_STATUS_SUCCESS
   PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
PASS: Attempt to auto register, succeeded
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n15 ms
   Verify status
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query visible providers succeeded
Verify indication length is equal to or greater than 0x1
PASS: Indication length (0x60) is valid
Verify element type is WwanStructProvider2
PASS: Element type is WwanStructProvider2
Verify indication length is equal to or greater than 0x60
PASS: Indication length (0x60) is valid
Verify ProviderId is NULL terminated
PASS: ProviderId is NULL terminated
Verify ProviderId contains only digits
PASS: ProviderId (12301) contains only digits
Verify ProviderId is 5 or 6 digits in length for GSM devices
PASS: ProviderId length (0x5) is valid
Verify ProviderState only uses WWAN_PROVIDER_STATE_HOME,WWAN_PROVIDER_STATE_FORBIDDEN,WWAN_PROVIDER_STATE_PREFERRED,WWAN_PROVIDER_STATE_VISIBLE, and\or WWAN_PROVIDER_STATE_REGISTERED
PASS: ProviderState (0x19) is valid
Verify ProviderName is NULL terminated
PASS: ProviderName is NULL terminated
Verify ProviderName is populated
PASS: ProviderName (MS MBN) is populated

Test Summary: Win8MBN::TestVisibleProvider::Connected

The test queries visible providers while connected.

Attempt to query device capabilities
   Attempt OID_WWAN_DEVICE_CAPS query
   PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n16 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query device capabilities succeeded
Attempt to query supported OIDs
   Attempt OID_GEN_SUPPORTED_LIST query
   PASS: OID_GEN_SUPPORTED_LIST succeeded, NTSTATUS(NDIS_STATUS_SUCCESS[0x0])
PASS: Attempt to query supported OIDs succeeded
Verify device supports OID_WWAN_VISIBLE_PROVIDERS
PASS: Device supports OID_WWAN_VISIBLE_PROVIDERS
Attempt to connect using provisioned context
   Attempt to query provisioned contexts
      Attempt OID_WWAN_PROVISIONED_CONTEXTS query
      PASS: OID_WWAN_PROVISIONED_CONTEXTS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
      Verify indication is received
      PASS: Indication was received
      Performance Check:Verify indication was received under 0n15000 ms
      PASS: Indication was received in 0n0 ms
      Verify status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Attempt to query provisioned contexts succeeded
   Attempt to find provisioned context of WwanContextTypeInternet
   PASS: Attempt to find provisioned context of WwanContextTypeInternet succeeded
   Attempt to connect to home provider
      Attempt to query Register State
         Attempt OID_WWAN_REGISTER_STATE query
         PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n15000 ms
         PASS: Indication was received in 0n16 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to query register state succeeded
      Attempt to auto register
         Attempt to query device capabilities
            Attempt OID_WWAN_DEVICE_CAPS query
            PASS: OID_WWAN_DEVICE_CAPS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n15000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS[0x0]
            PASS: Status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Attempt to query device capabilities succeeded
         Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f)
            Attempt OID_WWAN_REGISTER_STATE set
            PASS: OID_WWAN_REGISTER_STATE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
            Verify indication is received
            PASS: Indication was received
            Performance Check:Verify indication was received under 0n50000 ms
            PASS: Indication was received in 0n15 ms
            Verify status is WWAN_STATUS_SUCCESS
            PASS: Status is WWAN_STATUS_SUCCESS
         PASS: Attempt to set register state (action:WwanRegisterActionAutomatic dataclass:0x3f) succeeded
      PASS: Attempt to auto register, succeeded
      Verify auto packet service attach
         Wait for unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication for 0x3a98 seconds
         PASS: Received unsolicited NDIS_STATUS_WWAN_PACKET_SERVICE (WwanPacketServiceStateAttached) indication
      PASS: Auto packet attach succeeded
      Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password
         Attempt OID_WWAN_CONNECT set
         PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
         Verify indication is received
         PASS: Indication was received
         Performance Check:Verify indication was received under 0n30000 ms
         PASS: Indication was received in 0n140 ms
         Verify status is WWAN_STATUS_SUCCESS[0x0]
         PASS: Status is WWAN_STATUS_SUCCESS[0x0]
      PASS: Attempt to set connect context WwanActivationCommandActivate microsoft.com admin password, succeeded
      Verify connection id of returned context state is 0x80
      PASS: Connection id of returned context state is 0x80
      Verify activation state of returned context state is WwanActivationStateActivated
      PASS: Activation state (WwanActivationStateActivated) of returned context state is WwanActivationStateActivated
   PASS: Attempt to connect, succeeded
PASS: Attempt to connect using provisioned context succeeded
Attempt to query visible providers
   Attempt OID_WWAN_VISIBLE_PROVIDERS query
   PASS: OID_WWAN_VISIBLE_PROVIDERS succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n200000 ms
   PASS: Indication was received in 0n15 ms
   Verify status
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to query visible providers succeeded
Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null)
   Attempt OID_WWAN_CONNECT set
   PASS: OID_WWAN_CONNECT succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n30000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set connect context WwanActivationCommandDeactivate (null) (null) (null), succeeded
Verify connection id of returned context state is 0x80
PASS: Connection id of returned context state is 0x80
Verify activation state of returned context state is WwanActivationStateDeactivated
PASS: Activation state (WwanActivationStateDeactivated) of returned context state is WwanActivationStateDeactivated

Test Summary: Win8MBN::TestWake::WakeMachineFromConnectedStandbyWithSmsMessage

The test will verify the machine supports connected standby, put the machine into connected standby, and wait for SMS message.

Verify platform supports always on always connected
PASS: Platform supports always on always connected
Attempt to disable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD})
PASS: Attempt to disable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD}), succeeded
Attempt to set SMS delete (Flag:WwanSmsFlagAll Index:0x0)
   Attempt OID_WWAN_SMS_DELETE set
   PASS: OID_WWAN_SMS_DELETE succeeded, NTSTATUS (NDIS_STATUS_INDICATION_REQUIRED[0x40230001])
   Verify indication is received
   PASS: Indication was received
   Performance Check:Verify indication was received under 0n15000 ms
   PASS: Indication was received in 0n0 ms
   Verify status is WWAN_STATUS_SUCCESS[0x0]
   PASS: Status is WWAN_STATUS_SUCCESS[0x0]
PASS: Attempt to set SMS delete succeeded
Verify unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication is received
PASS: Unsolicited NDIS_STATUS_WWAN_SMS_STATUS indication was received
Performance Check:Verify unsolicited indication was received under 0n300000 ms
PASS: Unsolicited indication was received in 0n0 ms
Verify wait wake event was triggered
PASS: Wait wake event was triggered
Attempt to enable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD})
PASS: Attempt to enable interface ({34404430-9CE9-42E2-9086-F8EF87E6E9BD}), succeeded


Supported Network Hardware

The following is a list of supported wireless access point (AP) routers.

Manufacture | Model | Firmware | Hardware Rev
D-Link | DIR-601 | 1.02NA | A1
D-Link | DIR-657 | 1 | A1
D-Link | DIR-825 | 2.05NA | B1
D-Link | DIR-855 |  |
D-Link | DIR-655 |  |
Linksys | E2500 | 1.0.02 | N/A
Linksys | E1500 | 2.0.0.00 | N/A
Netgear | WNR2000v3 N300 | 1.1.1.58 | v3
Netgear | WNR1000v3 - N150 | 10.2.28_52.0.60NA | v3
NOTE

For Linksys E2500, D-Link Dir-855 and any dual band routers, you must disable the 5GHz radio.


WI-FI Direct Performance Scenario Tests

Design and Usage Instructions - Microsoft, 12/2011

Scenario Tests

The test uses the following selection variables to set up test combinations. Note that if any of these variables are not selected specifically, TE will loop through all the "un-tethered" possibilities in order.

Scenario Test Flow

The WFDScenarioTestDriver class is laid out as a series of test methods which run in order:

  • LoadSettings

    • Read in the command line parameters for this instance of the test

    • Load files/validate parameters/etc

  • PreSetup

    • Delete default GO profile and restart services (if necessary)

    • Create default GO profile (if necessary)

    • Set up ExtSTA port (disconnect/add profile)

  • PreConnectAP

    • Connects to test WLAN profile if (if necessary)

    • After L2 is established, does synchronous ping session for 30 seconds

  • RunScenario

    • Runs IWFDScenarioTest functions in order

      • Listener scenario

        • Initialize

        • RunListenerScenario

      • Connector scenario

        • Initialize

        • RunConnectorScenario

    • After L2 is established, WFD Client does ping session to GO's gateway address for 30 seconds

    • If scenario was Pre-AP-Connect, do concurrent ping session to AP as well

  • PostAPConnect

    • Connects to test WLAN profile (if necessary)

    • After L2 is established, WFD Client does ping session to GO's gateway address for 30 seconds

    • If scenario was Post-AP-Connect, WFD Client does concurrent session to GO as well

  • WaitForClientDisconnect

    • Post-WFD GO waits for disconnect notification from WFD client (signal that client is done with its ping session)

  • CalculatePerformance

    • Check the performance data stored earlier in the test

  • Cleanup

    • IWFDScenarioTest.Cleanup

    • Disconnect from AP

Code for this scenario flow is located in \wireless\wifidirect\tests\perfscenarios\scenariotest.cs

Required Test Parameters

TargetDeviceAddress

This is the device address of the other device in the PC to PC scenario. This variable is used to check against stack state after a WFD pairing has been established.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:TargetDeviceAddress=11:22:33:44:55:66

Optional Test Parameters

WaitForInput

Specifying this flag will force the LoadSettings function to wait for console input before continuing with the test. This is useful for manually running tests in a batch since there's no synchronization between tests.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:WaitForInput=true

DisablePerfCheck

Specifying this flag will skip both data transfer and connect perf checks in the CheckPerformance function. It will also skip tracking ping sessions.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:DisablePerfCheck=true

DisableDataPerf

Specifying this flag will skip data transfer checks in the CheckPerformance function. It will also skip tracking ping sessions. Connect performance checks will still happen.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:DisableDataPerf=true

Permutation Selection Parameters

Scenario

This defines which underlying Wi-Fi Direct scenario to use. This value should match across both PCs to ensure that the correct scenario is validated.

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:Scenario = 'Value' [and]…" ...

Possible Values

GONegotation - This value sets up the stack to do GO Negotiation over the Wi-Fi Direct protocol between 2 PCs during pairing. This will check if default GO profile is present, and if so, will delete the Default GO Profile registry key and reset wlansvc/other related services before continuing the test. Since the GO Negotiation is happening between 2 PCs with the same intent value, the outcome of the GO negotiation is unknown. Running GO negotiation tests twice back to back will ensure that both outcomes get exercised correctly.

Invitation - This value sets up the stack to do Invitation over the Wi-Fi Direct protocol between 2 PCs during pairing. This will check if default GO profile is present, and if not, will toggle autonomous GO on/off to create a default GO profile before continuing the test.

JoinExitingGO - This value sets up the stack to do a Join Existing GO scenario between 2 PCs during pairing. Note that due to the usage pattern for discoverability in WFDP2P/PeerFinder scenario layers (always sets discoverable), and the Pair API's preference for doing GO Negotiation before joining existing GO, this more specific setup is only possible using the WFDPlatform scenario layer.

LocalRole

This defines whether the local PC is the listener or the connector in the scenario test.

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:LocalRole = 'Value' [and]…" ...

Possible Values

Connector - This value will prepare the test to become a connector for a given PC-to-PC scenario. The actual steps for each scenario layer vary slightly, but basically boil down to the following:

  1. Loop Discovery for up to 45 seconds, until target listener machine is found.

  2. If found, pair to that device.

  3. Verify that connection was established successfully.

Listener - This value will prepare the test to become a listener for a given PC-to-PC scenario. The actual steps for each scenario layer vary slightly, but basically boil down to the following:

  1. Register for notifications about incoming connections.

  2. Wait for incoming connection for 2 minutes.

  3. If an incoming connection is received, accept that connection request.

  4. Verify that connection was established successfully.

ScenarioLayer

This defines the operating system layer at which the test will be run. It selects which implementation of IWFDScenarioTest to use when the RunScenario function is called.

Code for definition of IWFDScenarioTest is located in wireless\wifidirect\tests\PerfScenarios\ScenarioTest.cs

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:ScenarioLayer = 'Value' [and]…" ...

Possible Values

WFDPlatform

This value causes the test to use Wi-Fi Direct platform APIs to run a given scenario.

The implementation class for this scenario is WFDPlatformScenarioTest.

  • Code is located in wireless\wifidirect\tests\PerfScenarios\WFDPlatformScenarioTest.cs

The implementation class uses the interop helper WFDPlatformScenarioHelper class to call into the WFD Platform APIs from C#.

  • Code is located in common\sharedcomponents\sharedcomponents\WFDWrapper.cpp

WFDP2P

This value causes the test to use WFDP2P APIs to run a given scenario.

The implementation class for this scenario is WFDP2PScenarioTest.

  • Code is located in wireless\wifidirect\tests\PerfScenarios\WFDP2PScenarioTest.cs

The implementation class uses the interop helper WFDP2PScenarioHelper class to call into the WFDP2P APIs from C#.

  • Code is located in common\sharedcomponents\sharedcomponents\WFDWrapper.cpp

Unsupported WFD Scenarios

Due to 2-machine test limit, and usage pattern for WFDP2P/PeerFinder APIs, this scenario layer does not support JoinExistingGO scenario.

Required Test Parameters

APPID

This parameter specifies the PeerFinder Application Identifier to use. This is required to match across PCs or PeerFinder discovery will fail.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:APPID=SomeAppId

PeerFinder

This value causes the test to use the PeerFinder API set to run a given scenario.

The implementation class for this scenario is WFDPeerFinderScenarioTest.

  • Code is located in wireless\wifidirect\tests\PerfScenarios\WFDPeerFinderScenarioTest.cs

The implementation class uses the built-in WinRT APIs to run the actual scenario.

However, there was one work-around required to get these APIs to work in a non-Mosh setting. The implementation class uses the interop helper WFDPeerFinderScenarioHelper to call into the required work-around API.

  • Code is located in common\sharedcomponents\sharedcomponents\WFDWrapper.cpp

Unsupported WFD Scenarios

Due to 2-machine test limit, and usage pattern for WFDP2P/PeerFinder APIs, this scenario layer does not support JoinExistingGO scenario.

Required Test Parameters

APPID

This parameter specifies the PeerFinder Application Identifier to use. This is required to match across PCs or PeerFinder discovery will fail.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:APPID=SomeAppId

APConnectSetting

This defines the ordering/existence of an Infrastructure AP connection attempt within the scenario test, for the local machine.

It's important to note that the variable can be different across different PCs (PC1 connects before WFD, PC2 connects after WFD). This allows for a 3x3 matrix of test validation for APConnectSetting across 2 machines.

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:APConnectSetting = 'Value' [and]…" ...

Possible Values

NoAPConnection

No AP connection is attempted. This is the simplest combination of tests.

APConnectBeforeWFD

AP connection is attempted before Wi-Fi Direct scenario happens. Once L2 is established for the AP connection, baseline data performance data will be sampled.

After WFD is established, a new concurrent data sample will be taken as well.

Required Test Parameters

ChannelNumber

This specifies the expected channel number of the AP.

This will be verified after AP connectivity has been established.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:ChannelNumber=3

SSID and PSK

Using this pair of variables will create a manual connect, WPA2PSK, AES WLAN profile, which will temporarily be added to the WLAN profile store for the lifetime of the test.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:SSID=SomeSSID /p:PSK=SomePSK

ProfilePath

This variable can be provided in place of SSID and PSK.

Specifying it will load the file pointed to here

It will extract the SSID, Key, and key type from this profile, and generate a temporary profile with this information.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:ProfilePath=path\to\profile.xml

APConnectAfterWFD

AP connection is attempted after the Wi-Fi Direct scenario happens.

After the Post-WFD AP connection is established, a new concurrent data sample will be taken.

Required Test Parameters

ChannelNumber

This specifies the expected channel number of the AP.

This will be verified after AP connectivity has been established.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:ChannelNumber=3

SSID and PSK

Using this pair of variables will create a manual connect, WPA2PSK, AES WLAN profile, which will temporarily be added to the WLAN profile store for the lifetime of the test.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:SSID=SomeSSID /p:PSK=SomePSK

ProfilePath

This variable can be provided in place of SSID and PSK.

Specifying it will load the file pointed to here

It will extract the SSID, Key, and key type from this profile, and generate a temporary profile with this information.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:ProfilePath=path\to\profile.xml

Discovery Tests

Discovery Test Flow

Finder Device

The DiscoverStress class is laid out as a series of test methods that must be run in order:

  • LoadSettings

    • Read in command line parameters

  • SynchronizeDevices

    • Do discovery until all entries in the expected device list have been found in one shot (up to 30 seconds)

    • This is done so the test knows all devices are discoverable before collecting discovery success information

    • By the end, if all devices have been found, but never in one shot, the test will treat the devices as synchronized (but you can expect terrible results if not all devices can be found at the same time during the synchronization step)

  • DiscoverStress

    • Do back to back discoveries for 1 minute with the given discovery parameters, keeping track of results for each discovery

  • Calculate Performance

    • Analyze stored discovery information per device in the expected device list

    • Fail the test if there success rate is less than 95% for any single device in the expected device list

Target Device

There's also a helper test included for easily setting up listener devices for a certain amount of time.

  • Listener

    • Set Discoverable(true)

    • Sleep(listen time)

    • Set Discoverable(false)

Required Test Parameters

Expected Devices

This parameter is a semi-colon-delimited list of device addresses that are expected to be discovered. All of these devices must be found.

Usage

Te WFD.Perf.Scenario.Tests.dll … /p:ExpectedDevices=11:22:33:44:55:66

Te WFD.Perf.Scenario.Tests.dll … /p:ExpectedDevices=11:22:33:44:55:66;aa:bb:cc:dd:ee:ff;12:34:56:78:90:a0

Permutation Selection Parameters

DiscoverRole

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:DiscoverRole = 'Value' [and]…" ...

Possible Values

FinderDevice - This role will "do the finding". This value will discover continuously and calculate performance data.

TargetDevice - This role will "do the listening". It just sits there for a while then is turned off. This test doesn't require any additional permutation selection parameters.

DiscoverSpeed

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:DiscoverSpeed = 'Value' [and]…" ...

Possible Values

FastDiscovery - Discoveries are issued with a timeout of 1000ms.

BetaFastDiscovery - Discoveries are issued with a timeout of 2500ms.

StandardDiscovery - Discoveries are issued with a timeout of 10000ms.

DiscoverType

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:DiscoverType = 'Value' [and]…" ...

Possible Values

Wildcard - Discoveries are issued with no device filters.

Targeted - Discoveries are issued with one device filter per device entry.

DiscoverMode

Usage

Te WFD.Perf.Scenario.Tests.dll /select:"…[and] @Data:DiscoverMode = 'Value' [and]…" ...

Possible Values

NoPreference - If no preference is specified, the following is specified based on the DiscoverSpeed setting:

  • FastDiscovery - ScanOnly

  • BetaFastDiscovery - ScanOnly

  • StandardDiscovery - Auto

ScanOnly - Discoveries are issued with dot11_wfd_discover_type_scan_only.

FindOnly - Discoveries are issued with dot11_wfd_discover_type_find_only.

Auto - Discoveries are issued with dot11_wfd_discover_type_auto.

ScanSocialChannels - Discoveries are issued with dot11_wfd_discover_type_scan_social_channels.

Test Examples

Scenario Test

The following example will run the following across 1 listener and 1 connector PC:

  • Scenario: GO Negotiation

  • ScenarioLayer: WFD Platform

  • PC1 AP Connect Setting: APConnectBeforeWFD

  • PC2 AP Connect Setting: APConnectAfterWFD

Connector

Te WFD.Perf.Scenario.Tests.dll /select:"@Data:Scenario = 'GONegotiation' and @Data:LocalRole = 'Connector' and @Data:ScenarioLayer = 'WFDPlatform' and @Data:APConnectSetting = 'APConnectAfterWFD'" /p:TargetDeviceAddress=11:22:33:44:55:66 /p:SSID=APSSID1 /p:PSK=PSKForSSID1 /p:ChannelNumber=6

Listener

Te WFD.Perf.Scenario.Tests.dll /select:"@Data:Scenario = 'GONegotiation' and @Data:LocalRole = 'Connector' and @Data:ScenarioLayer = 'WFDPlatform' and @Data:APConnectSetting = 'APConnectAfterWFD'" /p:TargetDeviceAddress=66:44:22:11:22:33 /p:SSID=APSSID2 /p:PSK=PSKForSSID2 /p:ChannelNumber=3

Discovery Test

FinderDevice

Te WFD.Perf.Scenario.Tests.dll /select:"@Data:DiscoverRole = 'FinderDevice' and @Data:DiscoverSpeed = 'FastDiscovery' and @Data:DiscoverType = 'Wildcard' and @Data:DiscoverMode = 'NoPreference'" /p:ExpectedDevices=11:22:33:44:55:66;ab💿ef:gh🆎cd

TargetDevice

Te WFD.Perf.Scenario.Tests.dll /select:"@Data:DiscoverRole = 'TargetDevice'" /p:ListenTimeSeconds=200

Discovery Test Combination:

Discover Role | Discover Speed | Discover Type | Parameters
FinderDevice | FastDiscovery | Wildcard | List of Expected MACs
FinderDevice | FastDiscovery | Targeted | List of Expected MACs
FinderDevice | BetaFastDiscovery | Wildcard | List of Expected MACs
FinderDevice | BetaFastDiscovery | Targeted | List of Expected MACs
FinderDevice | StandardDiscovery | Wildcard | List of Expected MACs
FinderDevice | StandardDiscovery | Targeted | List of Expected MACs
TargetDevice | N/A | N/A | Listen Time

Perf Scenario Test Combination:

Scenario | ScenarioLayer | PC1_APConnectivity | PC2_APConnectivity | Scenario Result
GONegotiation | WFDPlatform | NoAPConnection | NoAPConnection |
GONegotiation | WFDPlatform | NoAPConnection | APConnectBeforeWFD |
GONegotiation | WFDPlatform | NoAPConnection | APConnectAfterWFD |
GONegotiation | WFDPlatform | APConnectBeforeWFD | NoAPConnection |
GONegotiation | WFDPlatform | APConnectBeforeWFD | APConnectBeforeWFD |
GONegotiation | WFDPlatform | APConnectBeforeWFD | APConnectAfterWFD |
GONegotiation | WFDPlatform | APConnectAfterWFD | NoAPConnection |
GONegotiation | WFDPlatform | APConnectAfterWFD | APConnectBeforeWFD |
GONegotiation | WFDPlatform | APConnectAfterWFD | APConnectAfterWFD |
Invitation | WFDPlatform | NoAPConnection | NoAPConnection |
Invitation | WFDPlatform | NoAPConnection | APConnectBeforeWFD |
Invitation | WFDPlatform | NoAPConnection | APConnectAfterWFD |
Invitation | WFDPlatform | APConnectBeforeWFD | NoAPConnection |
Invitation | WFDPlatform | APConnectBeforeWFD | APConnectBeforeWFD |
Invitation | WFDPlatform | APConnectBeforeWFD | APConnectAfterWFD |
Invitation | WFDPlatform | APConnectAfterWFD | NoAPConnection |
Invitation | WFDPlatform | APConnectAfterWFD | APConnectBeforeWFD |
Invitation | WFDPlatform | APConnectAfterWFD | APConnectAfterWFD |
JoinExistingGO | WFDPlatform | NoAPConnection | NoAPConnection |
JoinExistingGO | WFDPlatform | NoAPConnection | APConnectBeforeWFD |
JoinExistingGO | WFDPlatform | NoAPConnection | APConnectAfterWFD |
JoinExistingGO | WFDPlatform | APConnectBeforeWFD | NoAPConnection |
JoinExistingGO | WFDPlatform | APConnectBeforeWFD | APConnectBeforeWFD |
JoinExistingGO | WFDPlatform | APConnectBeforeWFD | APConnectAfterWFD |
JoinExistingGO | WFDPlatform | APConnectAfterWFD | NoAPConnection |
JoinExistingGO | WFDPlatform | APConnectAfterWFD | APConnectBeforeWFD |
JoinExistingGO | WFDPlatform | APConnectAfterWFD | APConnectAfterWFD |
GONegotiation | WFDP2P | NoAPConnection | NoAPConnection |
GONegotiation | WFDP2P | NoAPConnection | APConnectBeforeWFD |
GONegotiation | WFDP2P | NoAPConnection | APConnectAfterWFD |
GONegotiation | WFDP2P | APConnectBeforeWFD | NoAPConnection |
GONegotiation | WFDP2P | APConnectBeforeWFD | APConnectBeforeWFD |
GONegotiation | WFDP2P | APConnectBeforeWFD | APConnectAfterWFD |
GONegotiation | WFDP2P | APConnectAfterWFD | NoAPConnection |
GONegotiation | WFDP2P | APConnectAfterWFD | APConnectBeforeWFD |
GONegotiation | WFDP2P | APConnectAfterWFD | APConnectAfterWFD |
Invitation | WFDP2P | NoAPConnection | NoAPConnection |
Invitation | WFDP2P | NoAPConnection | APConnectBeforeWFD |
Invitation | WFDP2P | NoAPConnection | APConnectAfterWFD |
Invitation | WFDP2P | APConnectBeforeWFD | NoAPConnection |
Invitation | WFDP2P | APConnectBeforeWFD | APConnectBeforeWFD |
Invitation | WFDP2P | APConnectBeforeWFD | APConnectAfterWFD |
Invitation | WFDP2P | APConnectAfterWFD | NoAPConnection |
Invitation | WFDP2P | APConnectAfterWFD | APConnectBeforeWFD |
Invitation | WFDP2P | APConnectAfterWFD | APConnectAfterWFD |
GONegotiation | PeerFinder | NoAPConnection | NoAPConnection |
GONegotiation | PeerFinder | NoAPConnection | APConnectBeforeWFD |
GONegotiation | PeerFinder | NoAPConnection | APConnectAfterWFD |
GONegotiation | PeerFinder | APConnectBeforeWFD | NoAPConnection |
GONegotiation | PeerFinder | APConnectBeforeWFD | APConnectBeforeWFD |
GONegotiation | PeerFinder | APConnectBeforeWFD | APConnectAfterWFD |
GONegotiation | PeerFinder | APConnectAfterWFD | NoAPConnection |
GONegotiation | PeerFinder | APConnectAfterWFD | APConnectBeforeWFD |
GONegotiation | PeerFinder | APConnectAfterWFD | APConnectAfterWFD |
Invitation | PeerFinder | NoAPConnection | NoAPConnection |
Invitation | PeerFinder | NoAPConnection | APConnectBeforeWFD |
Invitation | PeerFinder | NoAPConnection | APConnectAfterWFD |
Invitation | PeerFinder | APConnectBeforeWFD | NoAPConnection |
Invitation | PeerFinder | APConnectBeforeWFD | APConnectBeforeWFD |
Invitation | PeerFinder | APConnectBeforeWFD | APConnectAfterWFD |
Invitation | PeerFinder | APConnectAfterWFD | NoAPConnection |
Invitation | PeerFinder | APConnectAfterWFD | APConnectBeforeWFD |
Invitation | PeerFinder | APConnectAfterWFD | APConnectAfterWFD |


Running Network Switch Certification Tests

This topic describes how to successfully run the Network Switch Certification tests.

Machine requirements for certification testing

Test topology

The diagram below describes the test topology that is used to perform the certification tests.

Listed below are the different roles of the machines that would be participating in the logo tests:

HLK controller: The HLK controller machine runs Windows Server 2012 R2 and coordinates certification testing.

HCK client: Also known as the SUT (system under test), this machine would run the latest version of the Windows Operating system and should be reachable on both switches on the management port.

The client is the main target of the tests and coordinates the end to end testing of the topology.

Switch A/B (DELL 4810): The switch that needs to be certified. In the topology, there are two instances of the switch that are connected to each other on a specific port.

Host machines: There are a total of four hosts, two connected to each of the switches. These machines mandatorily require 2 NICs each. One NIC is connected to the switch under test and the other NIC is connected to the Local Area Network which forms the backbone for the certification tests so that the controller is able to communicate to the hosts irrespective of the private network.

Listed below are the connections needed for the switch network:

Switch A connectivity:

  1. Switch A port 1 connected to Host 1 Nic1
  2. Switch A port 2 connected to Host 1 Nic2
  3. Switch A port 3 connected to Host 2 Nic1
  4. Switch A port 4 connected to Host 2 Nic2
  5. Switch A port 5 connected to Switch B port 5

Switch B connectivity:

  1. Switch B port 1 connected to Host 3 Nic1
  2. Switch B port 2 connected to Host 3 Nic2
  3. Switch B port 3 connected to Host 4 Nic1
  4. Switch B port 4 connected to Host 4 Nic2
  5. Switch B port 5 connected to Switch A port 5

Prerequisites

The following prerequisite steps are needed before executing the certification tests:

The host machines that are connected to the network switch need to be configured first before the certification tests can execute on the topology. The following settings need to be configured on the host machines:

  • Disable firewall on all of the host machines. The certification tests are designed to validate the functionality of the network switch, and additional firewall settings would prevent certain tests from being executed.

  • Remote scripts are executed on the host machines, so you must set the appropriate PowerShell script execution policy on the hosts:

    Set-ExecutionPolicy -ExecutionPolicy Unrestricted

  • Validate that the connectivity of the hosts to the switches are made and all of the MAC addresses of the hosts appear on both the network switches as per the connectivity requirement above.

  • Ensure that your switch supports the following MIBs:
    • BRIDGE-MIB
    • dot1dBasePortTable
    • dot1dTpFdbTable
    • IF-MIB
    • ifTable
  • Install the certificates on the network switch on the HLK client as described in the diagram above to ensure that a https session can be created with the network switch.
  • Ensure that all the hosts that are connected on the downlink of the network switch have the same administrative credentials setup.
  • Ensure that the same credentials are set up on both of the network switches.
  • Copy the Desired State Configuration Registration and the schema file from the network switch DSC package to the following locations in the HLK client machine:
    • Schema files: C:\Program Files\WindowsPowerShell\Configuration\Schema
    • Registration files: C:\Program Files\WindowsPowerShell\Configuration\Registration

Execution

  • Create a machine pool and move the HLK client machine to the machine pool.

  • Set the HLK client to the Ready state.

  • Create a new certification testing project from the UI

  • Select the HLK client under the System section from HLK UI

  • Click on the Tests tab and select Run Network Device Discovery Tests

  • Right click to execute the tests on the HLK client

  • Provide the mandatory parameter values to run the tests. The parameters are listed below:

    • SwitchManagementIPAddresses: The management IP addresses of the network switches that are part of the topology. This parameter is a comma separated list of IP addresses.
    • HostNames: The host names that are connected to the downlink port of the network switch in the topology. This parameter is a comma separated list of host names.
    • HostUserName: The domain/workgroup user name for the host that is connected to the network switch. The user needs to have Administrative privileges on the host. The same user name needs to be configured on all the hosts.
    • HostPassword: The password for the above mentioned host user name
    • SwitchUserName: The management user of the network switch
    • SwitchPassword: The password for the network switch specified above
    NOTE

    The same credentials need to be set across all the hosts connected on the downlink of the host. Similarly, same credentials need to be set on both the network switches as well.

![](images/ns-image7.png)

  • If there is a failure in the Discovery tests, you can look at the additional log files from the Results tab as indicated below:

  • After the Discovery test passes, return to the Selection tab in the HLK

  • Deselect the previously-selected host from the systems section

  • Select the device manager section, and you should be able to see a new node: Certification Target Network Topology. Select this node.

  • Select the Tests Tab in the HLK. You should see a list of applicable tests for network switches.

  • Select the tests one by one, provide the appropriate parameter values, and execute the tests


QosRemoteSettings

Test Summary

This test verifies that the DUT correctly accepts, and resolves remote QoS settings via DCBX.

This test requires two machines, with the "Support Device" on the Server machine (PEER) connected directly to the "Test Device" (DUT) on the Client machine.

Traces and Packet Capture

The following traces can be enabled before starting the test, if you would like to get more information:

  • NDIS traces to enable on the DUT machine if you want to see how the OS handles DCB & DCBX status indication, and QoS capabilities advertisements from the DUT.
    • 0x800000 is for QoS status indication traces 0x001000 is for QoS capability advertisement traces 0x000400 is for QoS OID request from the OS traces
netsh trace start provider={dd7a21e6-a651-46d4-b7c2-66543067b869} keywords=0x00801400 level=5 tracefile=ndis.etl
<start the NDIS test>
netsh trace stop
  • Run packet capture on the "Support Device" on PEER machine capture the LLDP DCBX packet sent out of the "Support Device".
    • Note that the test might reset the Support Device. Therefore, you might need to start/restart packet capture after the test has started.

Test Details

Each of the sub-tests does the following:

Configure local DCB on the DUT, including enable DCBX Willing on the DUT (NDIS_QOS_PARAMETERS_WILLING)
  • Expectation:
    • The DUT accepts the local DCB setting
    • The DUT generates an NDIS_STATUS_QOS_OPERATIONAL_PARAMETERS_CHANGE status indication if the local setting is different from its current local settings.
  • Trace info (if enabled as shown above)
    • Device QoS capability advertisements (to see this information, you'd need to restart the adapter prior to running the test, in order for the miniport to re-register QoS capabilities to the OS.)
      • ==>ndisMSetQosAttributes: …
      • <==ndisMSetQosAttributes: …, Status 0x0
    • On OID request to miniport
      • ==>ndisOidPreQosSetParameters: …
      • ==>ndisValidateQosParameters: …
      • <==ndisValidateQosParameters: …
      • <==ndisOidPreQosSetParameters: … Status 0 (Or some error traces in failure case)
    • On OS receiving NDIS_STATUS_QOS_OPERATIONAL_PARAMETERS_CHANGE
      • ==>ndisMIndicateQosParametersChange: … StatusCode: 400200a0
      • ==>ndisValidateQosParameters
      • <==ndisValidateQosParameters succeeded
      • <==ndisMIndicateQosParametersChange: … StatusCode: 400200a0
Craft an LLDP DCBX packet on the server machine, and send the packet out of the "Support Device" on the server machine.
  • Expectation:
    • The DUT receives the packet, since the "Support Device" is connected directly to the DUT.
    • The DUT resolves its local DCB settings with settings specified in the DCBX packet.
    • The DUT issues an NDIS_STATUS_QOS_REMOTE_PARAMETERS_CHANGE status indication with the resolved remote settings.
    • The OS subsequently issues an OID_QOS_PARAMETERS to the DUT to configure local DCB settings, based on the remote settings above.
    • The DUT accepts the local DCB setting.
    • The DUT generates an NDIS_STATUS_QOS_OPERATIONAL_PARAMETER_CHANGE status indication if the local setting is different from its current local settings.
  • Trace info (if enabled as shown above):
    • On sending DCBX message from PEER machine
      • Packet capture should show DCBX LLDP packets sent out of the Support Device
    • On OS receiving NDIS_STATUS_QOS_REMOTE_PARAMETERS_CHANGE
      • ==>ndisMIndicateQosParametersChange: … StatusCode: 400200a1
      • ==>ndisValidateQosParameters: …
      • <==ndisValidateQosParameters: …
      • <==ndisMIndicateQosParametersChange: … StatusCode: 400200a1
    • On OS issuing OID_QOS_PARAMETERS to the miniport for setting local DCB
      • Similar traces as above.
Query OID_QOS_REMOTE_PARAMETERS on the DUT to verify that the DUT has received the LLDP packet, and resolved the remote settings as expected.
  • Expectation:
    • The query returns the DCB settings specified in the LLDP DCBX packet that was sent by the "Support Device" to the DUT.
    • Note that the query will not reach the miniport. Instead, NDIS intercepts the query OID, and responds with the settings of the last NDIS_STATUS_QOS_REMOTE_PARAMETERS_CHANGE that it received from the DUT. Therefore, the DUT must have already generated a NDIS_STATUS_QOS_REMOTE_PARAMETERS_CHANGE when it received the LLDP DCBX packet.


Device.Portable

In this section

  • Device.Portable tests
  • Device.Portable additional documentation


Device.Portable tests

  • MTP Compliance Test - Core - Device Properties
  • MTP Compliance Test - Core - Miscellaneous
  • MTP Compliance Test - Core - Object Properties
  • MTP Compliance Test - Core - Operations
  • MTP Compliance Test - Core - Service Fundamentals
  • MTP Compliance Test - Core - Service Identification
  • MTP Compliance Test - Core - Service Miscellaneous
  • MTP Compliance Test - Core - Service Operations
  • MTP Compliance Test - Core - Transport
  • MTP Compliance Test - Requirements - Core
  • MTP Compliance Test - Requirements - Digital Camera
  • MTP Compliance Test - Requirements - Digital Video Camera
  • MTP Compliance Test - Requirements - Media Players
  • MTP Compliance Test - Requirements - Mobile Phone
  • WPD Compliance Tests - Commands
  • WPD Compliance Tests - Content
  • WPD Compliance Tests - Events (Manual)
  • WPD Compliance Tests - Model ID
  • WPD Compliance Tests - MultiSession
  • WPD Compliance Tests - Multi-Transport
  • WPD Compliance Tests - Property Management
  • WPD Compliance Tests - Services


MTP Compliance Test - Core - Device Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b5f7462-6648-4d64-b51a-df51888857e3

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.DevicePropertiesTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Miscellaneous

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e24cdda3-c9d0-424b-99dc-dfaca63bc992

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.MiscellaneousTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Object Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0d14727-00b9-4add-9f3f-5e2324444225

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.MTPObjectProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.ObjectPropertiesTest')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Operations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96b8599c-020c-4aee-92cb-d346b15262b1

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.MTPFunctionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.OperationsTest')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Service Fundamentals

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b000767-3663-45ec-943b-b62f9986b58e

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.CustomDeviceServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.ServiceFundamentalsTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Service Identification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca4c50d3-2645-4778-a026-1a0c0664192d

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.DeviceServices
  • Device.Portable.Core.CustomDeviceServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.MTPServiceIdentificationTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Service Miscellaneous

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1477cc0e-2531-4f4f-9c88-983e78f8cee9

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.DeviceServices
  • Device.Portable.Core.CustomDeviceServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.ServiceMiscellaneousTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Service Operations

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/868eb287-cc67-4244-98d3-8a3a7951fcbf

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.DeviceServices
  • Device.Portable.Core.CustomDeviceServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.ServiceOperationsTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Core - Transport

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0b8155a-d44a-40d1-abda-fd807944f4f4

This test validates compliance with the Windows implementation of the Media Transfer Protocol (MTP) and ensures that devices use the MTP class driver that is included with Windows.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.TransportUSB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select:"@TestClassification:Type='HCK' and NOT(@name='MtpTestMod.TransportTests')" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
DeviceProfile | MtpCamera, MtpMediaPlayer, MtpCellphone, MtpDigitalVideoCamera, MtpOther
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Requirements - Core

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2a9a4c7-1c1a-474d-8823-2f3e9dcfd297

This test validates that a device supports the core requirements that all MTP devices must support.

Test details
Specifications
  • Device.Portable.Core.MTP
  • Device.Portable.Core.MTPFunctionality
  • Device.Portable.Core.MTPObjectProperties
  • Device.Portable.Core.VideoCodec
  • Device.Portable.Core.AudioCodec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select(@name='@CapabilitiesTests*') /p "DeviceProfile=MtpCore.xml" | Runs the test.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>
MtpCore.xml | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Requirements - Digital Camera

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd07374b-60a2-44d3-bba0-98bfe0d9ce57

This device test validates compliance with Picture Transfer Protocol (PTP) and Media Transfer Protocol (MTP).

This test makes sure that devices support specific requirements for digital cameras. This test is directed at digital camera devices that use MTP. This test validates compliance with defined protocols based on requirements that are documented in the Windows Certification Program.

NOTE

This test does not cover the following items:

  • Digital rights management (DRM) validation

  • Devices that use proprietary (third-party) drivers that work with the Windows Portable Device (WPD) driver stack

Test details
Specifications
  • Device.Portable.DigitalCamera.MTP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

This test copies test content to the device for testing. If the device is read-only make sure the device has at least one file of each format type supported by the device.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

This automated test requires a PTP or MTP-compatible device and provides Pass/Fail results for each requirement.

This test is divided into the following functional categories:

  • Device Capabilities tests

  • Operations tests

  • Device Properties

  • Object Property tests

Each functional category contains child test cases, which test the subcomponents that fall under the corresponding category.

The test validates that the device supports the following operations:

  • OpenSession

  • CloseSession

  • GetDeviceInfo

  • GetStorageIDs

  • GetStorageInfo

  • GetNumObjects

  • GetObjectHandles

  • GetObjectInfo

  • GetObject

  • GetDevicePropDesc

  • GetDevicePropValue

The test validates that the following formats are supported:

  • Association

  • EXIF/JPEG

All other supported operations, device properties, and object properties are considered optional, and therefore will be validated according to implementation details defined in the Picture Transfer Protocol (PTP) for Digital Still Photography Devices, Version 1.0 (PIMA15740) and Media Transfer Protocol (MTP), Revision 1.0.

Command syntax

Command option | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select(@name='@CapabilitiesTests*') /p "DeviceProfile=MtpCamera.xml" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>
MtpCamera.xml | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Requirements - Digital Video Camera

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/afb2cb4d-8fa1-4bd5-a102-f8d964358e69

This device test validates compliance with the Picture Transfer Protocol (PTP) and Media Transfer Protocol (MTP).

This test makes sure that devices that use the MTP class driver comply with PTP and/or MTP implementation standards. This test is directed at digital video camera devices that use MTP. This test validates compliance with defined protocols based on requirements that are documented in the Windows Certification Program.

NOTE

This test does not cover the following items:

  • Digital rights management (DRM) validation

  • Devices that use proprietary (third-party) drivers that work with the Windows Portable Device (WPD) driver stack

Test details
Specifications
  • Device.Portable.DigitalVideoCamera.MTP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

This test copies test content to the device for testing. If the device is read-only, make sure the device has at least one file of each format type supported by the device.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

This test requires that a PTP or MTP-compatible device is installed using the MTP Class Driver. The test is fully automated with Pass/Fail results for each requirement.This test is divided into the following functional categories:

  • Device Capabilities tests

  • Operations tests

  • Object Property tests

Each functional category above contains child test cases, which test the subcomponents that fall under the corresponding category.

The test validates that the following operations are supported by the device:

  • OpenSession

  • CloseSession

  • GetDeviceInfo

  • GetStorageIDs

  • GetStorageInfo

  • GetNumObjects

  • GetObjectHandles

  • GetObjectInfo

  • GetObject

  • GetDevicePropDesc

  • GetDevicePropValue

All other supported operations, device properties, and object properties are considered optional and are therefore validated according to implementation details defined in the Picture Transfer Protocol (PTP) for Digital Still Photography Devices, Version 1.0 (PIMA15740) and Media Transfer Protocol (MTP), Revision 1.0. Please refer to the Certification Requirements for more information.

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select(@name='@CapabilitiesTests*') /p "DeviceProfile=MtpDigitalVideoCamera.xml" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>
MtpDigitalVideoCamera.xml | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Requirements - Media Players

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bbfe7dc4-8ccf-4d8d-b68e-5b6ccab11f0f

This test validates compliance with the Media Transfer Protocol (MTP), Revision 1.0.

This test makes sure that devices that use the MTP class driver comply with MTP implementation standards. This test is directed at portable media player devices that connect by using the MTP. This test validates compliance with defined protocols based on requirements that are documented in the Windows Certification Program.

NOTE

This test does not cover the following items:

  • Digital rights management (DRM) validation

  • Devices that use proprietary (third-party) drivers that work with the Windows Portable Device (WPD) driver stack

  • Devices that are not PTP or MTP-based

Test details
Specifications
  • Device.Portable.MediaPlayer.MTP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

The MTP device should be active and plugged in before commencing the test. The tool Mtpinfup.exe will update the driver for the attached MTP device to a signed test .inf file Mtptest.inf. Upon completion of the test, Mtpinfup.exe will update the driver back to the original in-box driver Wpdmtp.inf. If an optional capability is not supported by the device, the test will skip that test case.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

This test requires that a MTP-compatible device is installed. The test is fully automated with Pass/Fail results for each requirement.

This test is divided into the following functional categories:

  • Device Capabilities tests

  • Operations tests

  • Device Properties

  • Object Property tests

Each of the functional categories mentioned above contain child test cases, testing the sub components that fall under the corresponding category.

The test will validate that the following Operations are supported by the device:

  • OpenSession

  • CloseSession

  • GetDeviceInfo

  • GetStorageIDs

  • GetStorageInfo

  • GetObject

  • GetDevicePropDesc

  • GetDevicePropValue

  • SetDevicePropValue

  • DeleteObject

  • SendObject

  • GetNumObjects

  • GetObjectHandles

  • GetObjectInfo

  • SendObjectInfo

  • GetPartialObject

  • GetObjectPropsSupported

  • GetObjectPropDesc

  • GetObjectPropValue

  • SetObjectPropValue

  • GetObjectReferences

  • SetObjectReferences

The test validates that the following device properties are supported:

  • Synchronization Partner

  • Device Friendly Name

The test validates that the following formats are supported:

  • Undefined

  • Association

  • AbstractAudioAlbum

  • AbstractAudioVideoPlaylist

For AbstractAudioAlbum, the following properties are verified:

  • Genre

  • AlbumArtist

The test validates that the following Object Properties are supported for each supported format:

  1. StorageID

  2. ObjectFormat

  3. ProtectionStatus

  4. ObjectSize

  5. ObjectFileName

  6. ParentObject

  7. PersistentUniqueObjectIdentifier

  8. Name

  9. Non-Consumable

For supported Image formats, the test looks for these additional Object Properties:

  • Width

  • Height

For supported Video formats, the test looks for these additional Object Properties:

  • Width

  • Height

  • SampleRate

  • NumberOfChannels

  • ScanType

  • Audio WAVE CODEC

  • AudioBitRate

  • VideoFourCCCodec

  • VideoBitrate

  • Frames PerThousand Second

  • Encoding Profile

For supported Audio formats, the test looks for these additional Object Properties:

  • Artist

  • Track

  • AlbumName

  • AlbumArtist

  • SampleRate

  • NumberOfChannels

  • AudioBitRate

  • AudioWaveCodec

All other supported operations, device properties, and object properties are considered optional and therefore will be validated according to implementation details defined in the Picture Transfer Protocol (PTP) for Digital Still Photography Devices, Version 1.0 (PIMA15740) and Media Transfer Protocol (MTP), Revision 1.0.

Run time: | Test duration depends on the number of supported capabilities, formats, and operations. Run time can vary up to 2 hours.
Log file: | WTTTestLog.xml
System restart required: | No
Test category: | Portable Media Player
Program: | MtpTest.exe

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select(@name='@CapabilitiesTests*') /p "DeviceProfile=MtpMediaPlayer.xml" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>
MtpMediaPlayer.xml | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


MTP Compliance Test - Requirements - Mobile Phone

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f88f2297-fae4-492b-9fa4-63c526221754

This test validates compliance with the Media Transfer Protocol (MTP), Revision 1.0.

This suite of tests makes sure that devices that use the Windows MTP class driver comply by using the MTP implementation standards. This test is directed at mobile phone devices that connect by using the MTP protocol. This test validates compliance with defined protocols based on requirements that are documented in the Windows Certification Program.

NOTE

This test does not cover these items:

  • Digital rights management (DRM) validation

  • Devices that are not PTP or MTP-based

  • Devices that use proprietary (third-party) drivers that work with the Windows Portable Device (WPD) driver stack

Test details
Specifications
  • Device.Portable.MobilePhone.MTP
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

This test requires that a MTP-compatible device is installed. The test is fully automated with Pass/Fail results for each requirement.

This test is divided into the following functional categories:

  • Device Capabilities tests

  • Operations tests

  • Device Properties

  • Object Property tests

Each of the functional categories mentioned above contain child test cases, testing the sub components that fall under the corresponding category.

The test will validate that the following Operations are supported by the device:

  • OpenSession

  • CloseSession

  • GetDeviceInfo

  • GetStorageIDs

  • GetStorageInfo

  • GetObject

  • GetDevicePropDesc

  • GetDevicePropValue

  • SetDevicePropValue

  • DeleteObject

  • SendObject

  • GetNumObjects

  • GetObjectHandles

  • GetObjectInfo

  • SendObjectInfo

  • GetPartialObject

  • GetObjectPropsSupported

  • GetObjectPropDesc

  • GetObjectPropValue

  • SetObjectPropValue

  • GetObjectReferences

  • SetObjectReferences

The test validates that the following device properties are supported:

  • Synchronization Partner

  • Device Friendly Name

The test validates that the following formats are supported:

  • Undefined

  • Association

  • AbstractAudioAlbum

  • AbstractAudioVideoPlaylist

For AbstractAudioAlbum, the following properties are verified:

  • Genre

  • AlbumArtist

The test validates that the following Object Properties are supported for each supported format:

  1. StorageID

  2. ObjectFormat

  3. ProtectionStatus

  4. ObjectSize

  5. ObjectFileName

  6. ParentObject

  7. PersistentUniqueObjectIdentifier

  8. Name

  9. Non-Consumable

For supported Image formats, the test looks for these additional Object Properties:

  • Width

  • Height

For supported Video formats, the test looks for these additional Object Properties:

  • Width

  • Height

  • SampleRate

  • NumberOfChannels

  • ScanType

  • Audio WAVE CODEC

  • AudioBitRate

  • VideoFourCCCodec

  • VideoBitrate

  • Frames PerThousand Second

  • Encoding Profile

For supported Audio formats, the test looks for these additional Object Properties:

  • Artist

  • Track

  • AlbumName

  • AlbumArtist

  • SampleRate

  • NumberOfChannels

  • AudioBitRate

  • AudioWaveCodec

All other supported operations, device properties, and object properties are considered optional and therefore will be validated according to implementation details defined in the Picture Transfer Protocol (PTP) for Digital Still Photography Devices, Version 1.0 (PIMA15740) and Media Transfer Protocol (MTP), Revision 1.0.

Run time: | Test duration depends on the number of supported capabilities, formats, and operations. Run time can vary up to 2 hours.
Log file: | WTTTestLog.xml
System restart required: | No
Test category: | Cellular Handset
Program: | MtpTest.exe

Command syntax

Command | Description
te.exe /p:"BVT=TRUE" MtpTest.dll /select(@name='@CapabilitiesTests*') /p "DeviceProfile=MtpCellPhone.xml" | With no options, launches the GUI.

File list

File | Location
Mtptest.dll | <testbinroot>\mtp</p>
MtpCellPhone.xml | <testbinroot>\mtp</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
WpdTestDir |
TaefTestFile |
TaefParameters |
TestParameters |
TestSelect |


WPD Compliance Tests - Commands

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e27eed4c-feae-4367-a976-37262eb3a63a

This is an automated test.

Test details
Specifications
  • Device.Portable.Core.TransportBluetooth
  • Device.Portable.Core.TransportIP
  • Device.Portable.Core.TransportUSB
  • Device.Portable.Core.MediaSync
  • Device.Portable.Core.VideoCodec
  • Device.Portable.Core.AudioCodec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - Content

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92c55993-b6aa-4796-93e6-6d541df07ce4

This is an automated test.

Test details
Specifications
  • Device.Portable.Core.TransportBluetooth
  • Device.Portable.Core.TransportIP
  • Device.Portable.Core.TransportUSB
  • Device.Portable.Core.MediaSync
  • Device.Portable.Core.VideoCodec
  • Device.Portable.Core.AudioCodec
  • Device.Portable.Core.MTPStreams
  • Device.Portable.Core.MTPFunctionality
  • Device.Portable.Core.MTPObjectProperties
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - Events (Manual)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee54c07a-f20a-453b-b7b0-6d9c01c5ff0b

This test exercises the driver by using the Windows Portable Device (WPD) API and validates that the driver complies with the Windows Hardware Certification requirements.

This test verifies that a driver or device fulfills the Windows Hardware Certification requirements to work seamlessly with the WPD stack in a protocol-independent way.

Test details
Specifications
  • Device.Portable.Core.TransportBluetooth
  • Device.Portable.Core.TransportIP
  • Device.Portable.Core.TransportUSB
  • Device.Portable.Core.MediaSync
  • Device.Portable.Core.VideoCodec
  • Device.Portable.Core.AudioCodec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

NOTE

You may need additional hardware if the test device provides bus-specific support. To determine whether you need additional hardware, see the description for each bus-specific test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

This returns Pass or Fail. The test might return SKIP if the device does not support specific device services. To review test details, review the test log from HLK Studio.

Additional troubleshooting information:

  • The test supports verbose logging when in manual test case selection mode. When the application is running, go to Options, Logging Options, and click Destination: Window, Level: 10.

  • If no test cases are available from the tree for test-case selection, make sure that the device is plugged in.

More information

This test runs as a C++ application. When run outside of HLK Studio, there is a test case selection user interface and test suites can be defined using test profiles as is the case for the WLK. It provides a Pass/Fail for each requirement. The test validates the following scenarios and function categories for a WPD driver and the device that's connected to it.

The device or driver passes these common scenarios for content types and formats that it supports:

  • Object hierarchy enumeration

  • Object property retrieval

  • Object resource reads from device

  • Object resource writes to device

  • Object deletion

  • Power management

  • Device-generated or driver-generated events

The device or driver supports the following known function categories:

  • Required object properties and attributes

  • Resources and attributes

Function category requirements

Recommended:

  • WPD_FUNCTIONAL_CATEGORY_STORAGE

  • WPD_FUNCTIONAL_CATEGORY_DEVICE

  • WPD_FUNCTIONAL_CATEGORY_SMS

Optional:

  • WPD_FUNCTIONAL_CATEGORY_STILL_IMAGE_CAPTURE

  • WPD_FUNCTIONAL_CATEGORY_AUDIO_CAPTURE

Content type and format requirements

If a content type isn't supported, the format support won't be verified. There are no strict requirements on the format or content type, because this is typically an implementation detail for device firmware. The driver can report support for any format or content type, as long as it passes the functional scenario tests that use objects of formats that it supports, like transfer, deletion, and enumeration. These formats and content types can serve as a guideline:

  • Recommended content type: WPD_CONTENT_TYPE_AUDIO

  • Recommended formats:

    • WPD_OBJECT_FORMAT_WMA

    • WPD_OBJECT_FORMAT_MP3

  • Optional content type: WPD_CONTENT_TYPE_VIDEO

  • Recommended format: WPD_OBJECT_FORMAT_WMV

  • Optional content type: WPD_CONTENT_TYPE_IMAGE

  • Recommended formats:

    • WPD_OBJECT_FORMAT_BMP

    • WPD_OBJECT_FORMAT_EXIF

    • WPD_OBJECT_FORMAT_GIF

    • WPD_OBJECT_FORMAT_ICON

    • WPD_OBJECT_FORMAT_JFIF

    • WPD_OBJECT_FORMAT_JP2

    • WPD_OBJECT_FORMAT_JPX

    • WPD_OBJECT_FORMAT_PNG

    • WPD_OBJECT_FORMAT_TIFF

  • Optional content type: WPD_CONTENT_TYPE_DOCUMENT

  • Optional formats:

    • WPD_OBJECT_FORMAT_HTML

    • WPD_OBJECT_FORMAT_TEXT

Command syntax

Command option | Description
te.exe wpdcompliance.dll /select:"@name='Events' and @TestClassification:Type='HCK'" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WPDCompliance.dll | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\wdk</p>
test.mp3 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.wma | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.html | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.txt | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.bmp | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.GIF | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.ico | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jp2 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpg | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpx | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.png | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.tif | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.wmv | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
TestFile.avi | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
Devcon.exe | [OSBinRoot]\idw</p>
CalendarSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContactsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContentTransferApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
GeneralSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
HintsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
MetadataSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
NotesSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
RingtoneSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
StatusSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
TasksSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
WpdUploadFile.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - Model ID

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d76407a-0fe0-46db-ae66-a6aa14cf82e3

This test validates Windows Portable Device (WPD) scenarios at the WPD API level. Specifically, this test validates that the ModelID is implemented according to specification, if supported by the device.

NOTE

The Media Transfer Protocol (MTP) Device Services for Windows Specification defines implementation details for the ModelID. For more information, see MTP Device Services Extension Specification.

Test details
Specifications
  • Device.Portable.Core.ModelID
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

NOTE

You may need additional hardware if the test device provides bus-specific support. To determine whether you need additional hardware, see the description for each bus-specific test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

This test returns Pass/Fail. The test might return SKIP if the device does not support specific device services. To review test details, review the test log from Driver Test Manager (DTM) Studio.

When troubleshooting this test, note the following:

  • The test supports verbose logging when in manual test case selection mode. When the application is running, in Options > Logging Options, click Destination: Window, Level: 10.

  • If no test cases are available from the tree for test-case selection, make sure that the device is plugged in.

More information

This test verifies that the WPD_DEVICE_MODEL_UNIQUE_ID property on a device is:

  • Read-only.

  • A properly formed GUID.

Command syntax

Command option | Description
te.exe wpdcompliance.dll /select:"@name='TC_Dxp_ModelIdSupported' and @TestClassification:Type='HCK'" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WPDCompliance.dll | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\wdk</p>
test.mp3 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.wma | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.html | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.txt | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.bmp | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.GIF | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.ico | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jp2 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpg | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpx | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.png | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.tif | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.wmv | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
TestFile.avi | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
Devcon.exe | [OSBinRoot]\idw</p>
CalendarSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContactsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContentTransferApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
GeneralSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
HintsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
MetadataSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
NotesSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
RingtoneSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
StatusSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
TasksSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
WpdUploadFile.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - MultiSession

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44474539-5551-4f42-8e42-d3599888ca2f

This test verifies that portable devices that enable Media Transfer Protocol (MTP) MultiSession functionality support required object session operations as defined by the Media Transfer Protocol Specification, Revision 2.0.

Test details
Specifications
  • Device.Portable.Core.MTPMultiSession
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Command syntax

Command option | Description
te.exe wpdcompliance.dll /select:"@name='Wex::WPD::WpdComplianceTest::MultiSession*' and @TestClassification:Type='HCK'" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WPDCompliance.dll | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\wdk</p>
test.mp3 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.wma | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.html | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.txt | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.bmp | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.GIF | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.ico | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jp2 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpg | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpx | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.png | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.tif | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.wmv | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
TestFile.avi | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
Devcon.exe | [OSBinRoot]\idw</p>
CalendarSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContactsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContentTransferApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
GeneralSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
HintsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
MetadataSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
NotesSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
RingtoneSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
StatusSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
TasksSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
WpdUploadFile.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - Multi-Transport

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a25f89eb-4db6-42e5-b492-853be4308726

This automated test validates Windows Portable Device (WPD) scenarios at the WPD API level. Specifically, this test validates that a device supports a functional unique identifier (FUID).

Test details
Specifications
  • Device.Portable.Core.TransportBluetooth
  • Device.Portable.Core.TransportIP
  • Device.Portable.Core.TransportUSB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

NOTE

You may need additional hardware if the test device provides bus-specific support. To determine whether you need additional hardware, see the description for each bus-specific test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

This test returns Pass/Fail. The test might return SKIP if the device does not support specific device services. To review test details, review the test log from Driver Test Manager (DTM) Studio.

When troubleshooting this test, note the following:

  • This test supports verbose logging when in manual test case selection mode. When the application is running, in Options > Logging Options, click Destination: Window, Level: 10.

  • If no test cases are available from the tree for test-case selection, make sure that the device is plugged in.

More information

This test validates the WPD_DEVICE_FUNCTIONAL_UNIQUE_ID property on a device. This property enables devices to support simultaneous connectivity to a computer that is running Windows 7 or Windows 8 over multiple transports (like USB and Bluetooth). The Media Transfer Protocol (MTP) Device Services for Windows Specification defines implementation details for this property. For more information, see MTP Device Services Extension Specification.

The test runs against devices that support the WPD_DEVICE_FUNCTIONAL_UNIQUE_ID property and tries to read the value. If the property is writable, the test tries to set a value (GUID) and read it back. If the attempt is successful, the test logs PASS. If the property is writable and the test cannot set and then read the value, the test logs FAIL.

Command syntax

Command option | Description
te.exe wpdcompliance.dll /select:"@name='Wex::WPD::WpdComplianceTest::Multi_Transport*' and @TestClassification:Type='HCK'" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WPDCompliance.dll | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\wdk</p>
test.mp3 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.wma | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.html | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.txt | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.bmp | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.GIF | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.ico | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jp2 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpg | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpx | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.png | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.tif | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.wmv | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
TestFile.avi | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
Devcon.exe | [OSBinRoot]\idw</p>
CalendarSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContactsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContentTransferApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
GeneralSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
HintsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
MetadataSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
NotesSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
RingtoneSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
StatusSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
TasksSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
WpdUploadFile.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - Property Management

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/57e10170-7ec7-4e69-ae97-dcb9fe38c738

This is an automated test.

Test details
Specifications
  • Device.Portable.Core.MediaSync
  • Device.Portable.Core.VideoCodec
  • Device.Portable.Core.AudioCodec
  • Device.Portable.Core.MTPObjectProperties
  • Device.Portable.Core.MTPFunctionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


WPD Compliance Tests - Services

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4285ab36-895f-4b55-a6d5-6efa2e1fbf5c

This test is designed to validate Windows Portable Device (WPD) scenarios at the WPD API level. The supported scenarios and device services validated in this test are defined in the MTP Device Services for Windows specification. The MTP Device Services Extension specification defines the required interactions between the device and the MTP driver.

Test details
Specifications
  • Device.Portable.Core.DeviceServices
  • Device.Portable.Core.CustomDeviceServices
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Portable additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Device.Portable Testing Prerequisites.

NOTE

You may need additional hardware if the test device provides bus-specific support. To determine whether you need additional hardware, see the description for each bus-specific test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Portable Testing.

The test might return SKIP if the device does not support specific device services. To review test details, review the test log from Driver Test Manager (DTM) Studio.

When troubleshooting this test, note the following:

  • This test supports verbose logging when in manual test case selection mode. When the application is running, in Options > Logging Options, click Destination: Window, Level: 10.

  • If no test cases are available from the tree for test-case selection, make sure that the device is plugged in.

More information

The Media Transfer Protocol (MTP) Device Services for Windows Specification defines the supported scenarios and device services that this test validates. The MTP Device Services Extension Specification defines the required interactions between the device and the MTP driver. For more information, see MTP Device Services Extension Specification.

The compliance test maintains a configuration file for each service that the MTP Device Services for Windows Specification defines. Each configuration file defines the inherited services, properties, formats, format attributes, and format object properties for its corresponding service. Various test cases use the settings in the configuration file to validate whether each service that's supported by the device complies with Windows 7 or Windows 8. In addition to the test-case descriptions in this section, all strings (like service, format, and property names) are validated to be scriptable according to the MTP Device Services Extension Specification.

Device services are optional. For all services that the device supports, the WPD Compliance Test - ALL SERVICES test will run. This test case tries to validate the services that the device exposes against the definition in the MTP Device Services for Windows Specification. The test case reads the target services' definition from the configuration files that are packaged with the compliance test. The test case validates the actual service characteristics that are exposed from the device against these predefined settings.

Validating service static definitions

  1. Load the Service definition from configuration for target service

  2. Validate inheritance settings

    Get the expected inheritance setting (NoInheritance, Optional, Required, AtLeastOne)

    Get the actual service inherited services (IPortableDeviceServiceCapabilities::GetInheritedServices)

    IF no service inherited service but inheritance is expected

    Log error and exit

    ENDIFFOR each expected inherited Service (H)

    IF the service inherits H

    Save H's GUID to use for validation later

    ELSE

    IF H is required

    Log error and exit

    ENDIF

    ENDIF

    ENDFOR

  3. Validate service properties

    Generate list of expected supported properties

    Including inherited properties (queried by the actual inherited services saved above)

    FOR each expected property P

    IF the service does not supports P and P is required

    Log fatal error

    Continue FOR

    ENDIF

    Validate P's expected attributes (below) against the corresponding property

    WPD_PROPERTY_ATTRIBUTE_NAME

    WPD_PROPERTY_ATTRIBUTE_VARTYPE

    WPD_PROPERTY_ATTRIBUTE_CAN_WRITE

    WPD_PROPERTY_ATTRIBUTE_CAN_READ

    ENDFOR

  4. Validate supported formats

    Generate list of expected formats

    Including inherited formats (queried by the actual inherited services saved above)

    FOR each expected format F

    IF the service does not supports F and F is required

    Log fatal error

    Continue FOR

    ENDIF

    FOR each expected property P in F

    IF the service does not supports P and P is required

    Log fatal error

    Continue FOR

    ENDIF

    Validate P's expected attributes (below) against the corresponding property

    WPD_PROPERTY_ATTRIBUTE_NAME

    WPD_PROPERTY_ATTRIBUTE_VARTYPE

    WPD_PROPERTY_ATTRIBUTE_CAN_WRITE

    WPD_PROPERTY_ATTRIBUTE_CAN_READ

  5. Validate service supported methods

    Generate list of expected methods

    Including inherited methods (queried by the actual inherited services saved above)

    FOR each expected format M

    IF the service does not supports M and M is required

    Log fatal error

    Continue FOR

    ENDIF

    FOR each expected parameter P in M

    IF the service does not supports P and P is required

    Log fatal error

    Continue FOR

    ENDIF

    Validate P's expected attributes (below) against the corresponding property

    WPD_PARAMETER_ATTRIBUTE_NAME

    WPD_PARAMETER_ATTRIBUTE_VARTYPE

    WPD_PARAMETER_ATTRIBUTE_ORDER

    WPD_PARAMETER_ATTRIBUTE_USAGE

    WPD_PROPERTY_ATTRIBUTE_CAN_READ

Command syntax

Command option | Description
te.exe wpdcompliance.dll /select:"@name='Service' and @TestClassification:Type='HCK'" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WPDCompliance.dll | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\wdk</p>
test.mp3 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.wma | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Audio</p>
test.html | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.txt | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Document</p>
test.bmp | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.GIF | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.ico | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jp2 | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpg | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.jpx | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.png | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.tif | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Image</p>
test.wmv | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
TestFile.avi | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance\Content\Video</p>
Devcon.exe | [OSBinRoot]\idw</p>
CalendarSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContactsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
ContentTransferApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
GeneralSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
HintsSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
MetadataSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
NotesSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
RingtoneSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
StatusSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
TasksSvcApp.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>
WpdUploadFile.exe | [TestBinRoot]\NTTEST\MULTIMEDIATEST\wpd\WpdCompliance</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for net access


Device.Portable additional documentation

In this section

  • Device.Portable Testing Prerequisites
  • Troubleshooting Device.Portable Testing


Device.Portable Testing Prerequisites

Before you test a portable device by using the Windows Hardware Lab Kit (Windows HLK), review the following requirements:

Hardware requirements

  • System that supports USB 2.0 (at a minimum)

  • A USB cable for the device that you're testing

Software requirements

  • The latest Windows HLK filters or updates

  • A class driver provided by Microsoft

Other requirements

  • If you provide a custom INF with your device, you must run the HLK tests using the Windows class driver (you may not test using your custom INF).

  • Your device must install with the Microsoft Media Transfer Protocol class driver.

  • For Windows Vista and later, your device must appear under the Portable Devices category in Device Manager.

  • Devices that are read-only must include at least one sample of each format type supported by the device.

  • If the device supports removable media, the media must be added before testing.

  • Run the test with only one portable device connected at a time (this includes Mass Storage Class devices).

  • The battery on the device should be fully charged before testing is started.

Test computer configuration

To run portable device tests, you must know how to:

  • Switch a device to a computer connectivity mode before plugging it in.

  • Plug a device into a USB port of the computer and maintain the connectivity throughout the test.

  • Provide continuous power to the device throughout the test.

  • Troubleshoot device installation by checking if the device is installed successfully in Device Manager or by looking at the SetupAPI device installation logs.


Troubleshooting Device.Portable Testing

To troubleshoot issues that occur with Device.Portable tests, follow these steps:

  1. Review the following Windows Hardware Lab Kit (Windows HLK) topics:

    • Troubleshooting Windows HLK Test Failures

    • Device.Portable Testing Prerequisites

  2. Make sure that the device appears in Device Manager under Portable Devices.

  3. Some tests require that you log on to the computer as an Administrator. An Administrator account is needed if a test uses a test driver and then needs to revert to the original driver.

  4. Verify that you have installed the latest Windows HLK filters and kit updates. For more information, see Windows Hardware Lab Kit Filters.

  5. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  6. If you cannot obtain a successful test result, contact Windows HLK Support.

Related topics

Device.Portable Tests

Troubleshooting Windows HLK


Device.Storage

In this section

  • Device.Storage tests
  • Device.Storage additional documentation


Device.Storage tests

  • ALUA MPIO Test (LOGO)
  • BDE WLK Test
  • BDE WLK Test - OS Volume Only
  • Boot Test (LOGO)
  • Bus Reset Test
  • CiB Raid Controller Kit Tests
  • Converged Traffic Test
  • Crashdump Support Test (LOGO)
  • Disk Stress (LOGO)
  • Disk Verification (LOGO)
  • Drive enumeration on Cluster nodes (LOGO)
  • EHDD Test
  • Storage HBA Firmware Update
  • eMMC Compliance Test
  • Enclosure Disk Test (LOGO)
  • Enumeration Test (LOGO)
  • Flush Test
  • HBA API Test (LOGO)
  • Hybrid Cache Performance Test (LOGO)
  • Hybrid Direct Flash Access Test
  • Hybrid Information Cache Verification Test (LOGO)
  • Hybrid Information Command Test (LOGO)
  • Hybrid Information Log Verification Test (LOGO)
  • Hybrid Information Read-Write Test (LOGO)
  • Hybrid Power-Up In Standby Test
  • Hybrid Priority Zero Test
  • Hybrid Stress Test
  • Hybrid Superfetch Speed Test
  • Hybrid Tagged Performance Test (LOGO)
  • Hybrid Trim Performance Test (LOGO)
  • iSCSI Boot Firmware Table Test (LOGO)
  • iSCSI HBA Boot Test (LOGO)
  • iSCSI HBA Digest Test (Disk) (LOGO)
  • iSCSI HBA Mutual CHAP Test (LOGO)
  • iSCSI HBA Oneway CHAP Test (LOGO)
  • iSCSI HBA Persistent Login Test (LOGO)
  • iSCSI HBA Ping Test (LOGO)
  • iSCSI HBA RedirectionTest (LOGO)
  • iSCSI HBA WMI Test (LOGO)
  • iSCSI Target Digest Test (Disk) (LOGO)
  • iSCSI Target iSNS Test (LOGO)
  • iSCSI Target Mutual CHAP Test (LOGO)
  • iSCSI Target Oneway CHAP Test (LOGO)
  • iSCSI Target Ping Test (LOGO)
  • Lun Reset Test With Outstanding IO - All Disks
  • Lun Reset Test With Outstanding IO - Single Disk
  • Lun Reset Test Without Outstanding IO - All Disks
  • Lun Reset Test Without Outstanding IO - Single Disk
  • Multipath I-O Test (LOGO)
  • Multiport Disk Performance Test (LOGO)
  • NVMe Deallocate Performance Test (LOGO)
  • NVMe Deallocate Test (LOGO)
  • NVMe Device Capabilities Test (LOGO)
  • NVMe Interrupt Modes Test (LOGO)
  • NVMe IO Test (LOGO)
  • NVMe Queue Pause-Resume Test (LOGO)
  • NVMe Queue Utilization Test (LOGO)
  • NVMe SCSI Compliance Test (LOGO)
  • Offload Reset logo test
  • Offload scenario test (LOGO)
  • Offload SCSI Compliance Test (LOGO)
  • Optical Logo Test - BD-R
  • Optical Logo Test - BD-RE
  • Optical Logo Test - BD-ROM
  • Optical Logo Test - CD-R
  • Optical Logo Test - CD-ROM
  • Optical Logo Test - CD-RW
  • Optical Logo Test - Device
  • Optical Logo Test - DVD+R
  • Optical Logo Test - DVD+R Dual Layer
  • Optical Logo Test - DVD+RW
  • Optical Logo Test - DVD-R
  • Optical Logo Test - DVD-R Dual Layer Seq
  • Optical Logo Test - DVD-RAM
  • Optical Logo Test - DVD-ROM
  • Optical Logo Test - DVD-RW RO
  • PrivateCloudSimulator - Device.Storage.Controller.AzureStack
  • PrivateCloudSimulator - Device.Storage.Enclosure.AzureStack
  • PrivateCloudSimulator - Device.Storage.HD.AzureStack
  • Rotational Rate Test (LOGO)
  • SAS SSD SCSI Compliance Test (LOGO)
  • SAS SSD Trim Performance Test
  • SCSI Compliance Fuzz Test (LOGO)
  • SCSI Compliance Test 2.0 (LOGO)
  • SCSI Reliability Counters Test (LOGO)
  • SD Paging Tests
  • SDHC Compliance Test
  • SD-Ioctl Test
  • SES Test (LOGO)
  • Space creation on enclosure drives (LOGO)
  • Storage Firmware Update
  • Storage Imports Test (LOGO)
  • Storage Performance USB3
  • Storage Query Property (LOGO)
  • Thin Provisioning Performance Test - NTFS (LOGO)
  • Thin Provisioning Performance Test - RAW Disk (LOGO)
  • Thin Provisioning SCSI Compliance Test (LOGO)
  • Thin Provisioning Threshold and Resource Exhaustion Test (LOGO)
  • Trim Performance Test
  • Trim Zero-Range Test
  • USB 2.0 & 3.0 SCSI Compliance test (LOGO)
  • USB 2.0 & 3.0 SCSI Compliance test for UAS on EHCI (LOGO)
  • Windows Hyper-V NPIV Test 01 - Hba Status
  • Windows Hyper-V NPIV Test 02 - Create Port
  • Windows Hyper-V NPIV Test 03 - Create Invalid Port WWN
  • Windows Hyper-V NPIV Test 04 - Create Physical WWPN
  • Windows Hyper-V NPIV Test 05 - Create WWPN In Use
  • Windows Hyper-V NPIV Test 06 - Create And Remove Port
  • Windows Hyper-V NPIV Test 07 - Remove Bad Port
  • Windows Hyper-V NPIV Test 08 - Create And Remove Port Loop
  • Windows Hyper-V NPIV Test 09 - Create Max Number of Ports
  • Windows Hyper-V NPIV Test 10 - Rescan Port
  • Windows Hyper-V NPIV Test 11 - Rescan Port Stress
  • Windows Hyper-V NPIV Test 12 - Concurrent Same Port Creation
  • Windows Hyper-V NPIV Test 13 - Concurrent Port Creation
  • Windows Hyper-V NPIV Test 14 - Concurrent Port Removal
  • WindowsToGo Device Basics Test
  • WindowsToGo Device Boot Test
  • WindowsToGo Performance Assessment


ALUA MPIO Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/849bcee9-3305-4889-9645-8c4470f60d9c

This test verifies whether storage devices support the ALUA feature properly.

Asymmetric logical unit access (ALUA) occurs when the access characteristics of one port may differ from those of another port. Therefore, for storage devices with ALUA feature implemented, there may be at least two target port groups.

The test checks whether the device declares support to ALUA by checking the INQUIRY TPGS field before additional testing. If the TGPS field is not 0, then the storage devices at least support REPORT TARGET PORT GROUPS, and the Report Target Port Groups test will be done. If TPGS is 2 or 3, then the storage devices support both REPORT TARGET PORT GROUPS and explicit SET TARGET PORT GROUPS. In this case, the test will perform the Report Target Port Groups test and Set Target Port Groups test.

WARNING

This test depends on the SCSI Compliance Test 2.0 binary. Please make sure that LUN0 is the largest non-boot LUN before running the test.

Test details
Specifications
  • Device.Storage.Hd.Alua.Compliance
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Assigned by Create Storage Parameters.
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | operation option
Destructive | (0,1) 0=Passive, 1=Destructive


BDE WLK Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9f03fcea-f226-462d-8c7e-a439404ee9e4

This test verifies that Microsoft® BitLocker does not cause data corruption on hard disks that are included in in a data array.

Test details
Specifications
  • Device.Storage.Hd.RaidArray.BitLocker
  • Device.Storage.Controller.Boot.BitLocker
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites. This test requires 2 GB of unallocated disk space on the disk being tested.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

File list

File | Location
Bdewlktest.dll | <[osbinroot]>\nttest\basetest\ngscb</p>
Te.exe | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device path of disk to test EX: \\.\disk0


BDE WLK Test - OS Volume Only

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/759feb6c-fba7-4060-a241-9f6a81058bfd

This test verifies that Microsoft® Bitlocker does not cause data corruption on hard disks that are included in in a data array.

NOTE

This test is only applicable to the hard disk that is configured as the boot drive.

Test details
Specifications
  • Device.Storage.Controller.Boot.BitLocker
  • Device.Storage.Hd.RaidArray.BitLocker
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites. This test requires 2 GB of unallocated disk space on the disk being tested.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

File list

File | Location
Bdewlktest.dll | <[osbinroot]>\nttest\basetest\ngscb</p>
Te.exe | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>


Boot Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1660c636-710c-462a-9920-7557fd55d230

This test determines whether the test client is booting from a particular device and if the device is configured correctly.

Test details
Specifications
  • Device.Storage.Controller.Boot.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements for the type of storage controller that you are testing: Storage Adapter or Controller Testing Overview.

Before starting the test, you must ensure that the test adapter is the boot adapter in the system. This system does not need to be the only system in your machine pool. You can use a secondary system that does not meet the setup requirements for your certification program for this test, if necessary.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Ensure that Microsoft .NET Framework version 4.5 or later is installed on the system.

More information

If the logotype option is specified as system, the test will determine which device to use. If the logotype is specified as device, or none is given, the test accepts a device instance path, and it enumerates all of the device's children and finds disks that are equal to or below the device that is specified. The test then finds all of the volumes that span these disks. The test validates that the operating system is installed on one of these volumes and that the boot loader exists on one of the disks.

Command usage

Command | Description
boottest.exe /device "[WDKDeviceID]" | Runs the device test.
boottest.exe /logotype system | Runs the system test.

Command syntax

Command option | Description
BootTest | The command line options for the test are listed below.
/device | The instance path of the device to test.
/logotype | Optional parameter that specifies which certification program to test. Possible values are system and device. Default value: device
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
BootTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
StorageDevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test.
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.


Bus Reset Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3ce8c4d-ac53-4bd4-8b41-96ce681a77e3

This is an optional test that will execute repeated cycles on every disk. Each cycle will attempt to time out an IO request on every disk once by withholding the request from the miniport. This will trigger Storport to send a RESET_LUN at which point the test will either forward the held IO request to the miniport together with the RESET_LUN or complete the held IO request and forward only the RESET_LUN. The test comes in several flavors:

  • Lun Reset Test With Outstanding IO - All Disks - Forwards the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test With Outstanding IO - Single Disk - Forwards the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Lun Reset Test Without Outstanding IO - All Disks - Completes the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test Without Outstanding IO - Single Disk - Completes the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Bus Reset Test - Same as Lun Reset Test With Outstanding IO - All Disks but it will also fail the RESET_LUN command on purpose so that Storport will send a Bus Reset.

Test details
Specifications
  • Device.Storage.Controller.AzureStack.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

This test should be run on a nonboot storage controller. Running on a boot controller is possible, but requires at least one nonboot disk attached. This test will not execute on the boot disk. The expected result is for there to be no IOs stuck in the miniport after the RESET_LUNs and RESET_BUSs. Verification is done by restarting the machine after the test. To run this in a dual initiator setup, schedule this test on two machines connected to shared storage. Resets on one initiator should not adversely affect the other initiator. For Single Disk tests, double check that the two initiators are testing against the same physical disk in the shared storage.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting, use a debugger to verify that the test driver is loaded at boot during the test portion: StorPortShimLib: ShimInitialize called StorPortShimLib: Entering DriverAdd. CoreTestShim installed. Done with registry checks StorPortShimLib: Hooking driver: <storportminiportname>.sys

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device instance path of test device
LLU_LclAdminUsr | Administrator account to run test
LLU_NetAccessOnly | User to access test network share
WDKHardwareID | Hardware ID of test device
TestDuration | Test Duration in seconds
TestName | Test to run


CiB Raid Controller Kit Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a01570dd-632a-47f2-9223-10b43c258054

The tests help validate that a Continuously Available (CA) storage controller and drivers meet all applicable requirements. The tests conduct various end-to-end test scenarios by running I/O workloads, data integrity tests against the cluster during a planned or unplanned failover, and validates that the hardware platform under test meets CA hardware requirements.

Test details
Specifications
  • Device.Storage.Controller.Raid.ContinuousAvailability.ActiveMode
  • Device.Storage.Controller.Raid.ContinuousAvailability.FailoverClustering
  • Device.Storage.Controller.Raid.ContinuousAvailability.LunAccess
  • Device.Storage.Controller.Raid.ContinuousAvailability.RAID
  • Device.Storage.Controller.Raid.ContinuousAvailability.RecoveryProcessing
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 270
Category | Scenario
Timeout (in minutes) | 16200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements for the type of storage controller that you are testing: Storage Adapter or Controller Testing Overview.

Hardware requirements

The following network requirements on the cluster nodes and the test controller machine must be met:

  • A minimum of two 1-Gigabit Ethernet adapters plus a private network for cluster communications.

  • We recommend one 10Gigabit Ethernet adapter.

  • All cluster nodes must have IP addresses that are provided by DHCP.

  • DNS resolution for all cluster nodes and the test controller machine.

The following requirements on cluster nodes must be met:

  • The cluster nodes must meet the Failover Clustering hardware requirements for Windows Server 10.

  • The cluster nodes must meet the hardware requirements for Windows Server 10.

  • The cluster nodes must have approximately 100 GB of free space on the local hard drive.

The following requirements on the test controller machine must be met:

  • The test controller must meet the hardware requirements for Windows Server 10.

  • The test controller must have approximately 100 GB of free space on the local hard drive.

  • The test controller must have at least 32 GB of memory.

  • We recommend that the test controller have at least two quad core processors.

The following shared storage requirements for cluster nodes must be met:

  • Must have at least 22 shared LUNs.

  • Must have a minimum LUN size of 1 GB.

  • Must be using either RAID1, RAID5, RAID6, or RAID10.

  • All LUNs must be visible on all cluster nodes.

  • All LUNs must be initialized and formatted as NTFS volumes with appropriate drive letters.

Software requirements

The following Active Directory Domain Services requirements must be met:

  • All machines must be joined to the same domain.

  • You must have logged in as a member of the Domain Admins security group on the test controller machine.

The following operating system requirements must be met:

  • The test controller must be running Windows Server 10.

  • The cluster nodes must be running Windows Server 10.

  • Support for Clustered Windows Servers that use clustered RAID controllers must be enabled on each cluster node. For more information, see Enable Support for Clustered Windows Servers using clustered RAID controllers

To start the tests

  1. Open Windows HLK Studio.

  2. Create a project.

  3. In Device Manager, select your raid controller from the test pool.

  4. Right-click each selected target. Click Add new features, select Device.Storage.Controller.Raid.ContinuousAvailability, and then click OK.

  5. Click the Tests tab, select CiB Raid Controller Test, and click Run Selected. Assign TestController to the test controller machine.

  6. Assign the remaining node to the remaining machine.

  7. In the parameters, set the domain name, username, password, and cluster name.

    NOTE

    Cluster name cannot exceed 9 characters. If running the test multiple times, please use a different cluster name for each test run.

  8. Click OK to schedule the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

An error similar to "Cluster failure: test case ### failure" indicates that the cluster has not properly configured. Make sure that your shared disks are initialized and formatted as NTFS volumes to ensure a cluster can be formed and that no clusters or resource groups exist with the name specified in the cluster parameter.

If failures are found, you can review the logs to get additional details about the failures in HLK Studio under Results page:

  • CiB Raid Controller Kit Tests->Run Eval Quality tests->Logs->te.wtl
  • CiB Raid Controller Kit Tests->Run Raid Controller tests->Logs->te.wtl

More information

Parameters

Parameter name | Parameter description
CiBTestBin | test binary location
AutomatedOnly | Specify true if this test should not run any manual tests
ReplaceNodeNames.ps1 |
PATHTOXML |
CONFIGFILENAME | Name of the config XML file
NODE1 | The first node in the cluster
NODE2 | The second node in the cluster
Domain | The name of the domain to which the cluster nodes are joined
UserName | The user name of a user in the Domain Admins security group
Password | The password of the user in the Domain Admins security group
LOGFILE_INPUT |
LOGFILE_OUTPUT |
parse_whck.ps1 |
ClusterName | The name of the cluster to be created


Converged Traffic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0898976-334e-4c27-ba8a-ed084a841613

This test ensures that the test adapter supports concurrent network and disk input/output (I/O).

The Converged Traffic test runs the Disk Stress test against the storage array attached to the Fibre Channel over Ethernet (FCoE) adapter while simultaneously running NTttcp to stress network traffic through the same FCoE adapter. For additional NTttcp details, see How to Use NTttcp to Test Network Performance. For Disk Stress details, please see Disk Stress (LOGO).

Test details
Specifications
  • Device.Storage.Controller.Fcoe.Interoperability
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 480
Category | Scenario
Timeout (in minutes) | 28800
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Fibre Channel Over Ethernet Testing Prerequisites.

To schedule the Converged Traffic test in HLK Studio, after the test has been selected, you must first select a secondary machine to be the receiver of network I/O. The ReceiverIPAddress should correspond to an FCoE network port on the primary machine. It should also be reachable from the secondary test machine via a network port on the same FCoE adapter that has a storage array attached. Please ensure that the port that the test is using is not being blocked by a firewall.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

File list

File | Location
logtest.vbs | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
verify_ip_address.cmd | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
TestDuration | Duration of the entire test in seconds.
BlockSize | Block size of each transaction.
Scenarios | Scenarios to execute
Settings | Additional Settings
NTttcpReceiverIP | IP Address of the recevier (test target) machine
NTttcpIoSize | Length of buffer parameter
NTttcpQueueSize | Queue size
NTttcpPort | Port base parameter
NTttcpSessions | Number of sessions


Crashdump Support Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76232429-4aad-4afb-8825-5c78d93765eb

This test verifies that the storage miniport driver on Windows supports the creation of a memory dump file after a system stop error occurs.

Test details
Specifications
  • System.Fundamentals.StorageAndBoot.BootPerformance
  • Device.Storage.Controller.Boot.BasicFunction
  • System.Server.Base.ServerRequiredComponents
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Scenario
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation
  • System.Fundamentals additional documentation
  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup that is described in the test requirements for the kind of storage controller that you are testing. For more info, see Storage Adapter or Controller Testing Overview.

This test requires additional software and hardware:

  • Device to be tested

  • Hard drive with a minimum of 20 GB available on partition C:.

Before you run the test, you must also complete the following prerequisites:

  • If your test system has an Internet connection, no action needs to be taken.

    If your test system does not have an Internet connection, create a folder named C:\Symbols and download and install Windows operating system symbols. To do this, follow these steps:

    NOTE

    Symbols are needed to analyze the dump file. Failure to install symbols is the most common test setup problem that causes this test to fail. The version of the symbols must match the version of operating system that is installed on the test machine. Therefore, it must be downloaded external to the kit.

1.  On a machine that has an Internet connection, download the Windows Symbols packages. For more information, see [Download Windows Symbol Packages](http://msdn.microsoft.com/en-us/windows/hardware/gg463028.aspx).

2.  Copy the symbol files to the test machine to the **C:\\Symbols** folder. Because the symbols can be large, you only need to copy **ntkrnlmp.pdb** (for x64 or ARM) or **ntkrpamp.pdb** (for x86).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

  • The test logs error message "Failed to load the correct symbols"

    Upon reboot, the test examines the dump file for correctness. The test does this, just as a developer would, by using the kernel debugger kd (see Download and Install Debugging Tools for Windows). To analyze a dump file, the debugger needs access to symbols (see Symbol Files). This is a dictionary for the dump. They allow the debugger to analyze the contents of memory (or a crashdump file) into individual modules (executables, libraries, drivers, etc), functions within those modules, and data structures. As a general rule, if you cannot examine the dump file by using the kernel debugger, the test cannot pass.

    For the test to work properly, it needs to provide the debugger with symbols. When it does not have proper symbols, it will log warnings during the log failures during the first analysis phase of testing. The current mechanism for doing this is to download public symbol packages (see Download Windows Symbol Packages) and install them on the test machine before running the test. When symbols are not installed or do not match the operating system under test, the following message can appear in the test log:

    • (x) Failed to load the correct symbols.

    • (i) Please refer to WDK documentation on how to install operating system symbols.

    • (i) Your symbols might also be out of date, please update symbols by using the Microsoft Symbol Server.

    This message does not actually cause the test to fail because in some cases, the dump can still be analyzed with partially matching symbols. If the test continues and more test cases fail with messages such as Error retrieving addresses of ... or Unable to get..., it means that the debugger cannot analyze the dump because of missing symbols. One way to work around a symbol is to supplement the locally installed symbol packaged with symbols that are cached from an Internet symbol server. Follow these steps to cache the symbols locally:

    1. Ensure that you have already created a crashdump. The easiest way to do this is to run the test once and let it fail.

    2. Ensure that you have the debugging tools installed. Again the easiest way to do this is to run the test once. It will install the tools to C:\Debuggers.

    3. Open an elevated command prompt.

    4. Type the following command c:\Debuggers\kd -z c:\Windows\MEMORY.DMP -y SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols

    5. This loads the dump in the kernel debugger by using the remote symbol store at Microsoft and the local directory C:\Symbols as the downstream store to cache the symbols.

    6. Make sure that symbols can be found for operating system files such as NTOSKRNL and NTDLL. These files are necessary to analyze the dump. It is OK if errors appear loading symbols for other modules, such as third-party drivers.

    7. You should now have a prompt 0: kd>. At this prompt, type the command .reload /f. This command forces the debugger to load and cache all symbols for modules loaded in the dump.

    8. To exit the debugger, press Ctrl-B and then press Enter.

  • The test logs error message "Paging file size is too small for full dump purposes"

    In the case of a crash, there is no certainty of what parts of the operating system will still be functional. The network or file system drivers might have caused the crash; for example, preventing access to file system structures to create a dump file, or network to store the file remotely. The operating system handles this by using a file that it already knows exists (the pagefile) and writes directly to that file's logical block extents on disk. The dump process writes the contents of physical memory into the pagefile on the system disk (usually c:\pagefile.sys). The pagefile must be large enough to contain the dump. The largest dump is a complete dump, which requires the size of physical memory (for example, 4096) plus one extra megabyte to contain the header information. The test requires that the user configure the page file to an appropriate size before execution. If the page file size is insufficient, the test will log the following error during the initialization phase:

    • (i) Verifying paging file size.

    • (x) Paging file size is too small for full dump purposes.

    • (i) Paging file size: 330989568

    • (i) Physical memory size: 1073094656

    • (i) Please configure minimum paging file size to physical RAM size + 1MB.

  • I see the system stop error (blue screen), but the bugcheck code is not E2

    After some basic settings validation, the test will install a driver that is used to crash the system and reboot the system. After the reboot, the test changes the crash control settings (for full memory dump), deletes any old dump files, and crashes the system. At the point of the crash, the system will display a bugcheck screen (blue screen) with details of the nature of the crash. The type of bugcheck should be MANUALLY_INITIATED_CRASH (e2). If anything else appears here, it means that a second bugcheck occurred during the process of writing the dump file. This should be investigated by connecting a kernel debugger to the test client and debugging the storage adapter driver.

  • The test logs error message "Dump file is being used by another process. HRESULT: 0x80070020"

    After the dump file has been written, the test machine should automatically reboot. Upon boot after a crash, the operating system will detect the presence of dump information in the page file and begin the process of writing a dump. This process occurs asynchronously while the machine is booting and even after the user has logged in. During this process, you can view progress by checking the size of the dump file (C:\windows\memory.dmp) or viewing the process in task manager (werfault.exe). The test will often be running at the same time as this process, trying to access the same dump file. If this occurs, the following messages will appear in the log:

    • (i) Connecting to DumpFile: C:\Windows\MEMORY.DMP

    • (i) Dump file is being used by another process. HRESULT: 0x80070020

    • (i) Usually memory.dmp is still being written due to large RAM, retry after 5 minutes.

    The test should then retry accessing the file. If the error message code is different, or if it changes (for example, 0x80070002 : ERROR_FILE_NOT_FOUND), then it means that the file could not be written to disk. The first place to check for valuable debug information is the system event log. To view the event log click Start, click Run, and then type Compmgmt.msc. In the computer management window, select Computer Management\System Tools\Event Viewer\System. Browse through the list of events for an event that has the source BugCheck. The most common cause for a missing dump file is insufficient free space on the disk. The registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl\MachineCrash contains information about the last crash (before a reboot), including the partial dump file if one was created. This can be useful when trying to debug other missing dump issues.

More information

Crashdump is the mechanism in which the operating system calls the storage adapter driver to write the contents of the memory to a dump file after a system stop error. Due to the nature of a system stop error, the operating system cannot make any assumptions about the stability of the system. Therefore, very few system services are available to the storage drivers. The Crashdump Support Test verifies that the storage adapter driver can still operate under these constrained environments and perform the I/O to write to the dump successfully.

The Windows operating system allows three different types of memory dump files to be generated:

  • Full

  • Kernel

  • Mini

The test will test the Kernel and Mini dump file types. For further more about these dump file types, see Kernel-Mode Dump Files.

The test will complete the following sequence of operations:

  1. Install Debugging Tools for Windows to the %SystemDrive%\Debuggers directory and initialize the system.

  2. Install test driver to simulate crash.

  3. Set the pagefile size.

  4. Simulate system stop errors (bluescreen) with bugcheck code 0x000000E2.

  5. Reboot the system and automatically restart the test.

  6. Examine the previous crash by analyzing the memory dump file through the kernel debugger, and verify that the dump has been written correctly.

  7. Repeat steps 4 - 6 for each dump file type.

Command syntax

Command | Description
Crashdumptest.exe -c | Clear any past failures.
crashdumptest.exe -dtm -y [SymbolsDirectory] -ypass | Initialize the test.
crashdumptest.exe -autorun -y [SymbolsDirectory] -dtm" | Runs the test.

File list

Command option | Description
Crashdumptest.exe | [TestBinRoot]\nttest\driverstest\storage\wdk</p>
BugCheck.sys | [TestBinRoot]\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
DebuggerDirectory | Directory to install debuggers to.
SymbolsDirectory | Directory where symbols are already installed.
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
PagefileSize | Pagefile size in MB (supports mem+N format)


Disk Stress (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/738735f7-245a-4b39-9d81-20339ce31fd4

This test stresses disks on a computer by sending as much asynchronous I/O as the device can handle. The test should reach the bandwidth limit of the test device for the given test system configuration.

Test details
Specifications
  • Device.Storage.Controller.BasicFunction
  • Device.Storage.Hd.BasicFunction
  • Device.Storage.Optical.Features
  • Device.Storage.Hd.RemovableMedia.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Scenario
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the following test requirements:

  • Hard Disk Drive Testing Prerequisites

  • Optical Disk Drive Testing Prerequisites

If you are testing any drive that requires media or testing in system-mode on a computer that contains drives that require media, you must insert media into the drives. The media that is used must be formatted and contain data that occupies at least 50% of the media's capacity.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The test is passed the instance path of the target test device. It finds all hard disks and optical drives that are equal to or connected to the test device. The test will then go through the following scenarios on all of the found devices:

  • Sequential read

  • Sequential write

  • Sequential verify (write followed by read and comparison)

  • Random read

  • Random write

  • Random verify

The test is given a fixed run time and runs each scenario for a fraction of that time. In the case of six scenarios and a run time of 90 minutes, each scenario is run for 15 minutes. The test displays dialog boxes with the progress of the current scenario. Any write scenarios (including verify) are skipped for optical devices. The size of the individual data transfers is determined by a command-line parameter; the default size for the logo test is 32 KB.

The test tries to do raw writes, bypassing any file system that is mounted on the hard disk if it can. The test attempts raw writes if one of the following occurs:

  • The test can find a raw, unpartitioned disk.

  • The test can find a raw, unformatted volume.

  • The test can find a volume that it can dismount.

If none of the preceding situations are available, the test performs I/O through the file system. This action is more CPU intensive and might not give accurate bandwidth and latency measurements for the device. In the third situation (the test finds a volume that it can dismount), which is the most common mode that the test is run in, the test allocates a test file to use and writes only to the extents of that file. This situation ensures that the test never corrupts the file system of the device that it is testing.

The amount of space that the test uses is determined by the free space that is available on the test device. To ensure best device performance, you should delete any unnecessary files from the test device and should cleanly format or defragment the device before running the test. The test warns you if the target's fragmentation might influence the test results.

Even though this test does measure device performance, there is currently no test case in the Logo version of this test that passes or fails based on these measurements.

Command syntax

Command option | Description
DiskIo | Runs the test.
WARNING

For command line help for this test binary, type /h.

File list

File | Location
DiskIo.exe | <[testbinroot]>\nttest\driverstest\storage\wdk
StorageDevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk

Parameters

Parameter name | Parameter description
WDKDeviceID |
TestDuration | Duration of the entire test in seconds.
BlockSize | Block size of each transaction.
Scenarios | Scenarios to execute
Settings | Additional Settings


Disk Verification (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8f88b8a-ff9c-4cfb-9e95-6be2511e5510

This test verifies a disk by doing random raw writes and reads and comparing the results.

Test details
Specifications
  • Device.Storage.Controller.BasicFunction
  • Device.Storage.Hd.DataVerification.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 480
Category | Scenario
Timeout (in minutes) | 28800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The test is passed the instance path of the target test device. The test then finds all hard disks that are equal to or connected to the test device. It will then choose the best target for the test in the following order:

  1. RAW unpartitioned disk

  2. RAW unformatted volume

  3. Volume that can be dismounted

  4. Volume that cannot be dismounted

The test will run a random verify scenario on this target

The test is given a fixed run time of 72 hours. The test will display a dialog box with the current progress and bandwidth of the test. The size of the individual data transfers is determined by a command-line parameter; the default size for the logo test is 32 KB.

The test will try to do raw writes, bypassing any file system that is mounted on the hard disk if it can (as in cases 1, 2, and 3 in the preceding list).

The amount of space that the test uses is determined by the free space that is available on the test device. To ensure best device performance, you should delete unnecessary files off the test device and cleanly format or defragment the device before running the test. The test will warn you if the targets fragmentation might influence the test results.

Even though this test does measure device performance, there is currently no test case in the Logo version of this test that will pass or fail based on these measurements.

For more information about the DiskIO test application, see the "Disk Stress" topic.

This test always return Pass or Fail. To review test details, review the test log from the DTM Studio.

If this procedure does not provide a successful test result, submit the test log with device or system-specific details to the WLK Support alias.

Command syntax

Command | Description
DiskIo | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
DiskIo.exe | <[testbinroot]>\nttest\driverstest\storage\wdk
StorageDevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk

Parameters

Parameter name | Parameter description
WDKDeviceID |
Scenarios | Scenarios to run
TestDuration | Duration of the test in seconds
BlockSize | Block size of each transaction.
Settings | Additional Settings
IsUFD | If device is UFD(USB thumb drive, USB pen drive), set this parameter to 1. If device is USBHDD, set this value to 0
QueryStorage_bus_type | Storage bus type


Drive enumeration on Cluster nodes (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a7b3652d-a422-4d9c-a84d-845f660e0697

This test creates an enclosure-aware mirror space and verifies that files can be created on that.

Test details
Specifications
  • Device.Storage.Enclosure.DriveIdentification
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: SCSI Enclosure Services (SES) Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Errors from this test occur via issues identified in the log file and in bugchecks produced through stressing the driver under test.

More information

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Assigned by Create Storage Parameters.
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
EnclosureUniqueID |


EHDD Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d6e8e2e-d448-4ce7-80b6-735620affed1

This test verifies that an encrypted hard drive complies with Microsoft and Industry specifications.

Test details
Specifications
  • Device.Storage.Hd.Ehdd.Compliance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The EHDD device must be attached to the appropriate controller. The job will prepare the disk with the correct partition and formatting for the testing. The test is destructive and therefore the disk cannot be the boot disk. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this test has performance elements, outside activity may affect the results. The PSID for the drive is required to be entered at runtime as this value cannot be obtained programmatically.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

  • Check WTT Trace:

    • View Task Log of Execute EHDD Test.

    • Open the log file EHDDLogoTest.wtl.

    • Check for messages that may solve the issue.

  • Check and Replay TCG Command Trace:

    • All of the commands sent to the driver are logged in case of an error. When an error is encountered, the trace, since the previous revert, is saved with the .error extension in the folder where the test is run from.

    • Open in a text editor the FullCommandoutput#.txt.error with the highest number.

    • Look for the reason for the failure.

    • The SerializedCommands#.error file can be played back to reproduce the error observed.

    • Determine if this is a consistent repro by replaying the error file. EX: EhddLogoTest.exe /DeviceID "\\.\physicaldrive1" /PSID "G98D72LDPW2DF9HDN30HG0G30H409HG4" /Playback SerializedCommands1.error

  • Could not start logging for EhstorTCGDrvTrace:

    • If a previous run of the test gets interrupted prematurely, it is possible that the trace log will persist beyond the life of the binary.

    • You will see the following error:

      Executing "cmd.exe /c logman.exe start EhstorTcgDrvTrace -ets -p {aa3aa23b-bb6d-425a-b58c-1d7e37f5d02a} -ft 1 -rt -o perflog.etl"Command execution exited with code: -2144337737 Could not start logging for EhstorTcgDrvTrace

    • Open an elevated cmd window and right-click cmd.exe (C:\Windows\System32\cmd.exe) and choose Run as administrator.

    • Run logman -query -ets

    • Run logman -stop -ets EhstorTcgDrvTrace

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The job takes in the device instance ID of the device under test and the PSID of the device. The job converts the device instance ID to a physical drive number in order to run the testing on that device. The job partitions and formats the drive to get it into the configuration needed for testing. The EhddLogoTest will run through a series of test cases each mapped to items in the requirements. The test cases are self-contained and results from one test case should not affect other test cases as the drive is reverted and activated between each test case. The following is a list of tests cases:

  • ATA Identify

  • Band

  • Com Packet Size

  • Encryption Mode

  • Fixed ACL Mode

  • Fuzz

  • Key Length

  • Metadata

  • Modifiable Common Name

  • Opal Version

  • Query Silo

  • Range Crossing

  • Secret Protect

  • SID Disable

  • TCG Stack Reset

  • TPer Reset

  • Unauthenticated Erase

Each of these test cases can be run on the command line using the test in standalone mode for further testing or debugging. The Fuzz test case has an optional argument for the number of fuzz iterations when running the test standalone.

During testing, the commands being sent to the drive are logged and if an error occurs this log is saved both in plaintext (FullCommandoutput#.txt.error) and in a replay file (SerializedCommands#.error). The log is reset every time a revert occurs as the commands, since the last revert should be sufficient to repro the failure. The test can be initiated with the playback argument to replay the series of commands leading up to the failure.

Command syntax

Parameter | Description
EhddLogoTest | The binary for the test.
/DeviceID | The EHDD device drive letter. Example: /DeviceID \\.\PhysicalDrive1
/PSID | The PSID of the device. Example: /PSID VUTSRQPONMLKJIHGFEDCBA9876543210
/Seed | Seed value for generating random test data. Example: /Seed 1000
/RunTestCaseType | Runs only the specified category of test cases: device, profile, or scenario. Example: /RunTestCaseTypes device
/RunTestCase | Runs only the specified test case: ATAIdentify, Band, ComPacketSize, EncryptionMode, FixedACLMode, Fuzz, KeyLength, Metadata, ModifiableCommonName, OpalVersion, QuerySilo, RangeCrossing, SecretProtect, SIDDisable, TCGStackReset, TPerReset, or UnauthenticatedErase. Example: /RunTestCase Band
/FuzzIterations | Number of iterations to run the fuzz scenario. Only valid if running the fuzz scenario. Example: /FuzzIterations 1000
/SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
/Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
/Verbosity | Logging verbosity. Logging Verbosity Levels: Minimal, Default, or Verbose. Example: /Verbosity Verbose
/Playback | Playback a previously recorded command log file. Example: /Playback RecordedCommand.err
/Log | Log name Default value: LogoTest.wtl Example: /Log mytestlog.wtl
/cmdPerfTraceAnalysis | Run command performance analysis :Never, OnPassed, or Always. Example: /cmdPerfTraceAnalysis Always
/cmdPerfTraceLogFile | Performance output trace log commandText. Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl

Command usage

Command | Description
EhddLogoTest.exe /DeviceID "[DiskDeviceObjLink]" /PSID "[PSID]" | Runs the test for the specified device instance ID and PSID.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
EhddFuzzer.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddInterop.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
EhddTraceLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
Tcglibutil.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd
StorageDevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\ehdd

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
WDKDeviceID | Instance path of device to test.
DiskDeviceObjLink | Assigned by Create Storage Parameters.
PSID | The device's PSID
Destructive | (0,1) 0=Passive, 1=Destructive


Storage HBA Firmware Update

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/696520df-d0ad-4792-81e2-8b98c3fe5beb

This test updates the HBA firmware using the firmware image file.

Test details
Specifications
  • Device.Storage.Controller.FirmwareUpgrade.BasicFunction
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device to Test
DiskDeviceObjLink | Assigned by Create Storage Parameters
FirmwareImageFile | Path and name of the new firmware image file

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


eMMC Compliance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fdc03695-c935-4e82-875d-75c2af6d5c71

This test verifies the correct operation of a SD host controller by ensuring that the features described in the requirements are implemented by the host controller.

Test details
Specifications
  • Device.Storage.Hd.EMMC.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The test checks the current configuration of the eMMC disk and how it is attached to the system. It validates that the items described in the requirements are indeed implemented.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The logs are descriptive in what is being tested and where any failures occur. The first step in triaging failures should be to check the log file and determine which one of the requirement lines failed. The failure may also have more information about the root cause.

More information

The test will first do discovery on the SD host controllers and SD devices attached to the system to determine their capabilities. It will then specifically check the disk for the device specified to ensure that it conforms to the logo requirements. For each requirement item the device will be checked to see if it claims to support the features or modes required. Then if applicable, the device will be checked to ensure the operation of that feature is adequate. Failures will be logged for any error found.

Command usage

Command | Description
SoCBootTest.exe eMMCComplianceTest Device [StorageDriveLetter] | Run the eMMCComplianceTest scenario on the specified device.

Command syntax

Command option | Description
SoCBootTest | The binary that runs the test.
eMMCComplianceTest | Runs the eMMC Compliance test.
Device | Specifies the device to run the test against.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
autocom.dll | <[testbinroot]>\nttest\driverstest\storage</p>
autocomManaged.dll | <[testbinroot]>\nttest\driverstest\storage\managed</p>
bigfile.exe | <[testbinroot]>\nttest\driverstest\storage\disk</p>
DiskStress.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
MemoryChoke.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
MemoryStress.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
SoCBootTest.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot\SocBootTest</p>
SDHelper.dll | <[testbinroot]>\nttest\driverstest\storage\sd\Tools\SDHelper</p>
EtwProcessor.dll | <[taefbinroot]></p>
Wex.Common.dll | <[testbinroot]>\wextest\cue\testexecution\wlk</p>
Wex.Communication.dll | <[testbinroot]>\wextest\cue\testexecution</p>
ntlog.dll | <[testbinroot]>\nttest\commontest\ntlog</p>
ntlogger.ini | <[testbinroot]>\nttest\commontest\ntlog</p>
stresslog.dll | <[testbinroot]>\basetest\core_file_services\shared_libs</p>
fbslog.dll | <[testbinroot]>\basetest\core_file_services\shared_libs\fbslog</p>
rapidfile.exe | <[testbinroot]>\basetest\core_file_services\shared_tests\Wdk</p>

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
WDKDeviceID | Instance path of device to test.
DiskDeviceObjLink | Assigned by Create Storage Parameters.
Destructive | (0,1) 0=Passive, 1=Destructive


Enclosure Disk Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21dee34c-8eab-4c51-b4e2-3c8f41c508b8

This test verifies SCSI device compliance on Windows.

Test details
Specifications
  • Device.Storage.Hd.PortAssociation.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the prerequisites for the type of storage controller that you are testing: Hard Disk Drive Testing Prerequisites and SCSI Enclosure Services (SES) Device Testing Prerequisites.

To run this test you must set the DiskDeviceObjLink parameter. This parameter represents the physical path to the test device. Example: \\.\PhysicalDrive1

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

If a failure is observed in the Enclosure Disk Test (LOGO), then run scsicompliance.exe /device \\.\<Drive Number> /verbosity 4 /scenario PersistentResrvation /operation test (for example: scsicompliance.exe /device \\.\PhysicalDrive1 /verbosity 4 /scenario PersistentResrvation /operation test).

The most relevant log is scsicompliance.wtl.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Errors from this test occur via issues identified in the log file and in bug checks produced through stressing the driver under test.

More information

This test measures the SCSI device compliance on Windows. The goal is twofold - to ensure that SCSI devices supported on the Windows OS fully and completely adhere to the SCSI specifications set forth in SPC-4 and SES-3, as well as to allow us and our partners to fully respect and comply with these standards. Maintaining compliance will lead to a stronger and more reliable system overall.

For more information about these specifications, visit the Technical Committee T10 SCSI Storage Interfaces website.

The test sends the following commands to the device:

  • Receive Diagnostic Results: 0X0A pages

  • Inquiry: VPD 0x83 Page

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Assigned by Create Storage Parameters.
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId |
Options |
ScsiComplianceDevice | Device path
Destructive | (0,1) 0=Passive, 1=Destructive


Enumeration Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a5af370-4995-4355-a3dd-efc5d79728a5

This test verifies that all disks in the chassis must be able to be enumerated by all controllers in the chassis. If there are multiple ports into the chassis, then each port must enumerate the same number of disks.

Test details
Specifications
  • Device.Storage.Enclosure.DirectAccess
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements in Hard Disk Drive Testing Prerequisites and SCSI Enclosure Services (SES) Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Make sure that:

  • The test environment is set up so that two HBA ports are connected from the test computer to the Storage Target (Enclosure Device).

  • The disk you have selected in Selection tab of the HLK Studio is online.

The most relevant log is enumeratedrive.log.wtl.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The test is to check whether storage enclosure device exposed LUNs same for different ports. To do that, we assume, on storage enclosure device side, the LUNs have same configuration and each port from storage enclosure device will have same connections with HBA ports on server. The test enumerates all LUNs connected to each HBA on server side and compares them to check if LUNs connected to each HBA can be matched with each other. Here we require users make sure that each HBA port instance on server side will connect storage ports on storage device end.

Command syntax

Command | Description
Enumeratedrive.exe -lun [StorageDriveNumber] | Runs the test
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Enumeratedrive.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
StorageDriveNumber | The disk numbert EX: 1


Flush Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2dec1f67-b506-4434-8bdf-763147ad8f0b

This test leverages SNMP-controlled, programmable power strips to validate that the driver, controller, and underlying device honor the appropriate flush command by persisting data to the device.

It includes the following steps:

  • Write a known pattern directly to disk (by-passing the file system) and wait for writes to complete.

  • Send Flush command and wait for completion.

  • Immediately trigger sudden power loss.

  • On reboot, read back and verify that all data that was written to disk before the flush command.

  • Repeat cycle with a different write scenario (different size, pattern, location, etc.).

Test details
Specifications
  • Device.Storage.Controller.Flush.BasicFunction
  • Device.Storage.Hd.Flush.BasicFunction
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x86)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 480
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements for the type of storage controller that you are testing. See Storage Adapter or Controller Testing Overview for more information.

  • This test runs both on boot and non-boot controller compared to the older test which could only run on non-boot controller. This enables testing of both boot disks and data disks. For boot disk, the multithreaded scenarios are skipped, whereas for a data disk, all the scenarios are executed.

  • Setup required for the test: Connect a power distribution unit (PDU), controllable via SNMP, to the HLK test machine.

  • Power strip should have a valid IP address associated as the test uses both the IP address and the port to initiate sudden power loss.

  • Power strip can be connected locally/remotely to machine, please see power strip manual for configuration details.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Power-strip

The test supports providing OID value for SNMP connections for a PDU. The default OID is set as .1.3.6.1.4.1.318.1.1.12.3.3.1.1.4 as it is the one that is used by APC and it can be changed when providing parameters to the test based on the OID of the PDU. The only limit as of now is the ASN value as mentioned below. Other PDU models should have the same ASN value.

ImmediatePowerOn = 1

ImmediatePowerOff = 2

ImmediateReboot = 3

The test is known to support the APC and CPS PDUs with these ASN values and can be tested out with other PDUs as well that supports configuration mentioned as above. To run the test, you will need the IP address of the power-strip. Please refer to the power-strip user manual for information on how to discover the IP address.

Sudden Power Loss and BIOS setting

Test runs about 21 scenarios initiating sudden power loss each time. When power-strip port is programmed for power off and delayed power on, systems may not power ON automatically as this is a BIOS setting and is usually available on desktop machines. Example: On HP Compaq DC7800 machine, In BIOS under Advanced->Power-On Options, there is a field called "After Power Loss", set it to ON.

For uninterrupted and automated way of running flush test, set the BIOS setting to power ON machine automatically when power is plugged in.

Battery/Non-battery powered systems

Flush runs only on non-battery powered systems. If you are using a desktop machine, flush is applicable. If you are using a laptop machine (we assume battery is plugged in), flush is not applicable. Below are the options available for certifying devices against systems.

  • Certifying devices on desktop machines

    • See options for BIOS power setting above

  • Certifying devices on laptop machines

    • Select a laptop which has a BIOS power setting, remove battery and follow steps for running tests

    • Or, Put laptop motherboard in a desktop casing (i.e., just like a desktop machine) and follow steps for running tests

flush test setup diagram

More information

These scenarios send a flush command to the device as soon as all outstanding I/O complete for a given scenario. Power loss occurs immediately after the flush command completes. If any data from the scenario did not persist to disk, the test will fail. The logo test will run each of these 21 scenarios.

  1. Flush and Reboot after 512MB of Syncronous Sequential Writes

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

  2. Flush and Reboot after 512MB of Syncronous Random Writes

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

  3. Flush and Reboot after 512MB of Syncronous Striding Writes

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

  4. Flush and Reboot after 1GB of Asyncronous Sequential Writes via 4 threads

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

  5. Flush and Reboot after 1GB of Asyncronous Random Writes via 4 threads

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

  6. Flush and Reboot after 1GB of Asyncronous Striding Writes via 4 threads

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

  7. Flush and Reboot after 1.5GB of Asyncronous Random, Sequential, and Striding Writes via 6 threads

    • Small writes (512B - 4KB)

    • Large writes (768KB - 1MB)

    • Pseudorandom-sized writes (512B - 1MB)

Parameters

Parameter name | Parameter description
WDKDeviceID | Device to test
StorageDriveLetter | Assigned by Create Storage Parameters
IP | IP Address of Remote PDU
OID | OID of Remote PDU outlet
Outlet | Port of Remote PDU outlet
Community | Community of Remote PDU (e.g. private)
DiskDeviceObjLink | Assigned by Create Storage Parameters


HBA API Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6e6752b-2f93-49c3-af4d-78b6c304fe68

This test verifies the Microsoft Windows Management Instrumentation (WMI) interfaces that are implemented by a host bus adapter (HBA) driver for support of the Storage Networking Industry Association's Common HBA API.

NOTE

To qualify under the Windows Certification program, Fibre Channel and SAS Storport miniport drivers and SCSI miniport drivers must support the HBA API.

Test details
Specifications
  • Device.Storage.Controller.Fc.Interface
  • Device.Storage.Controller.Fcoe.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Fibre Channel Adapter Testing Prerequisites

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The HBA API test requires a Fibre Channel switch between the HBA and the storage devices that you are testing. The Fibre Channel switch must support the GIEL and GANXT specifications. Most switches that have been made in the past 10 years support these specifications.

The topology can any kind of fabric configuration, as long as a switch is present. For example, the simplest configuration is the following: [TestMachine]<-->[FibreChannelSwitch]<-->[FibreChannelStorageArray]

NOTE

The test uses a Microsoft Visual Basic script to query the HBAs WMI interfaces. For specific test cases, see the Assertions section. You can view the source of the test by opening the script file with a text editor.

The test first installs the schema for the HBA API on the computer and then starts the script.

Command syntax

Command | Description
mofcomp -N:root\wmi hbaapi.bmf | Installs the hbaapi.bmf file.
cscript hbatst.vbs "[WDKDeviceID]" | Specifies the device to be tested.

File list

File | Location
hbatst.vbs | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
hbaapi.bmf | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID of HBA to be tested.
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
WDKDriverName | Driver Name


Hybrid Cache Performance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a25c4467-7a7f-4eea-879f-270df84f3084

This test validates the performance of the cache by doing the following scenarios:

  • Sequential Read

  • Random Read (Queue Depth=1)

  • Random Read (Queue Depth=8)

  • Random Write (Queue Depth=1)

  • Random Write (Queue Depth=8)

  • Sequential Write

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Benchmark
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

This test does the following:

  1. Disables the cache.

  2. Enables the cache. This effectively should clear out the entire cache.

  3. Pin in data starting at offset 0 for a length of 4 GB with priority. This pin will be with reads. Additionally, after every GB the test waits until the hybrid log pages have stopped changing in a certain time frame. This is to allow the device to sync data into the cache so that the entire range gets pinned into the drive.

  4. Changes the priority of all future I/O to the drive to not have any priority.

  5. Start the speed test.

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
TargetPriority | Hybrid priority
Offset | LBA offset
Length | File length for the test
DeviceTag | Device tag
DeviceID | Drive number
IOOperation | Read or Write


Hybrid Direct Flash Access Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85b27711-7d23-48ba-a951-9ee5336921f3

This test checks the behavior of the disk drive when flash is being written to. This will ensure in low power scenarios the disk does not spend time spinning up the drive needlessly. The test does (for each priority): Spin down the disk using a STANDBY_IMMEDIATE command After waiting, check to make sure the disk is spun down. Write to the disk at priority Read the same data that was just written. Check power state to see that it's still spun down. Check to make sure none of the I/O appeared to incur a spinup (2 second I/O) This will loop and repeat the write, starting at 256 KB, increasing to 32 MB at 1 MB chunks over the same starting offset.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test.
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Information Cache Verification Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2759ddd-c50f-4ccf-b67c-07f8370f98e6

This test checks commands and I/O that will move data to or from the cache will actually perform what is expected. Hinted I/O should pin data into the cache.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Benchmark
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Hybridflt.sys must be installed for this test to work properly.

More information

The test should automatically turn the hybrid information on before checking the logs if it was not on already.

In general, the test will first create the baseline by doing the following:

  1. Turn off the cache.

  2. Turn on the cache.

  3. Create a baseline for random reads off the rotational media.

  4. Pin in data to the cache.

  5. Create a baseline for random reads off the cache

  6. Compare the two baselines to make sure they look reasonable

If this setup point fails, the test results are meaningless. It indicates that there were unexpected cache misses during the random reads off what is expected to be cache.

The test will do the following:

  • Do an operation on a region

  • Do a random read test on that region

  • Compare the results to the baselines

  • If the result is similar to the expected baseline, the test case will pass, else it will fail.

The test cleans the cache before test cases by turning the cache on and off.

You can use the Command Syntax section to execute a specific test case.

Command syntax

Command | Description
Hybriddrive.exe -drive <disk #> -scenario location | Runs the test.
-Drive <disk#> | The drive to be tested on. The behavior of boot drives or drives with a file system is not defined.
-Verbosity | The logging level for this test.
-? | Displays help.
-Scenario location | The scenario to run.
-case # | The test case to run.

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Information Command Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0c757e4-44aa-4de8-9c8b-1b05b96855a9

This test ensures that the following hybrid commands are working as defined in the requirements:

  • Change by LBA

  • Hybrid Control -Both threshold and disable/enable cache

  • Evict

  • Demote By Size

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Hybridflt.sys must be installed for this test to work properly.

More information

The test should automatically turn the hybrid information on before checking the logs if it was not on already.

This test relies on some behavior of hybrids that are not tested in this particular test or in some test cases. Ensure that tagged I/Os go to the cache and that dirty data thresholds are respected.

You can use the Command Syntax section to execute a specific test case.

Command syntax

Command | Description
Hybriddrive.exe -drive <disk #> -scenario logcommand | Runs the test.
-Drive <disk#> | The drive to be tested on. The behavior of boot drives or drives with a file system is not defined.
-Verbosity | The logging level for this test.
-? | Displays help.
-Scenario logcommand | The scenario to run.
-case # | The test case to run.

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Information Log Verification Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c14021b-4ccc-45f0-a180-8391355db962

This test ensures that certain bits are set in IDENTIFY DEVICE and the logs from READ LOGS.

The following are checked from IDENTIFY DEVICE:

  • Hybrid Information feature support

  • Hybrid Information feature enabled

  • Nominal Rotational rate

  • Trim Support

  • NCQ Queue Management

  • NCQ Send and Receive

The following are checked from the general purpose log:

  • NCQ Support

  • NCQ Non-Data Log Support

  • NCQ Send and Receive Log Support

  • Hybrid Information Log Support

The following command support is checked:

  • Change by LBA

  • Hybrid Control

  • Demote by Size

  • Evict

The following hybrid fields for the logs are checked:

  • Caching Medium Health Status

  • Dirty Low Threshold

  • Dirty High Threshold

  • Maximum Hybrid Priority Level

  • Max Priority Behavior

  • NVM size

  • Max Eviction Commands

  • Max Eviction Data Blocks

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Hybridflt.sys must be installed for the test to work properly.

More information

The test should automatically turn the hybrid information on before checking the logs, if it was not on already.

Use the Command Syntax section to execute a specific test case.

Command syntax

Command | Description
Hybriddrive.exe -drive <disk #> -scenario logverify | Runs the test.
-Drive <disk#> | The drive to be tested on. The behavior of boot drives or drives with a file system is not defined.
-Verbosity | The logging level for this test.
-? | Displays help.
-Scenario logverify | The scenario to run.
-case # | The test case to run.

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Information Read-Write Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b414edfd-980a-452e-9101-90fb1f629f5c

This test validates the behavior of reads and writes to the drive with priority. There are several test cases that the drive must pass:

  • Being able to read and write to each priority for most of the priority

  • Ensuring that the optimal write granularity is being properly reported in the hybrid log

  • Ensuring that priority updates are updated

  • Ensuring that the replacement policy in the cache is sensible

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Hybridflt.sys must be installed for this test to work properly.

More information

The test should automatically turn the hybrid information on before checking the logs if it was not on already.

This test relies on some behavior of hybrids that are not tested in this particular test or in some test cases. Ensure that dirty data thresholds are respected.

You can use the Command Syntax section to execute a specific test case.

Command syntax

Command | Description
Hybriddrive.exe -drive <disk #> -scenario logrw | Runs the test.
-Drive <disk#> | The drive to be tested on. The behavior of boot drives or drives with a file system is not defined.
-Verbosity | The logging level for this test.
-? | Displays help.
-Scenario logrw | The scenario to run.
-case # | The test case to run.

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Power-Up In Standby Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e973157d-da10-409e-9826-d350d6a14345

This test checks to make sure that the device supports power up in standby. The test will check the identify device page to verify that the Power up in standby feature is supported, and will turn power up in standby off and on to ensure that it is reporting the correct results. It will also check if an explicit spin-up if the feature is enabled is required. If the device sets that flag, this test will also fail.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Priority Zero Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c051aa90-0f8f-4f7e-bc6d-24d4804efa6b

This test checks to ensure that the drive's behavior at priority zero is correct. This will ensure that the OS can evict data properly from the drive. This is what the test does: o Read data at a fixed length at a random offset on the drive at priority o Write data at a fixed length at a different random offset on the drive at priority o Check the hybrid log to make sure the descriptor values are expected o Write to both regions at priority zero o Check the hybrid log to make sure there is nothing at non-zero priorities.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Stress Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06023d24-ce0f-4223-be97-278fd9c64441

This test executes a variety of hybrid commands with reads and writes, and ensures that the disk does not fail any command. It will also attempt to verify that data is not corrupted during the reads and writes. This test will need some amount of space on the system drive. This test can be considered an additional disk behavior verification tool.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
Duration | Duration of the test. The test will look at trace data afterwards, and verify the cache, so the actual duration will be longer. Format:x(h
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
Scenario | Scenario that test targets to.
StorageDriveNumber | Drive number of device to test
WDKDeviceID | Instance path of device to test


Hybrid Superfetch Speed Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/622bc530-a3b0-4657-82bc-2da1fced6ac4

This runs the superfetch speed test on the drive. It will setup a volume and proceed to run the test 10 times. This test will determine whether the drive will be suitable for Windows to use as a hybrid drive. If it is too slow, then it won't use the hybrid feature at all.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
Scenario | Scenario that test targets to.
StorageDriveNumber | Drive number of device to test
WDKDeviceID | Instance path of device to test


Hybrid Tagged Performance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2a7ee89-4562-41b4-a9fc-db13563f1d15

This test is testing for performance of I/O with priority. This is to satisfy the requirement that a read or write that has a priority assigned must not incur a latency penalty larger than 10% of an identical I/O without priority information.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Benchmark
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Hybridflt.sys must be installed for this test to work properly.

More information

The test should automatically turn the hybrid information on before checking the logs if it was not on already.

In general, the test will do the following:

  1. Generate a baseline for an I/O situation without priority

  2. Generate a baseline for an I/O situation without priority

  3. Compare against the baseline. If the average is more than 10% worse or if a single I/O is greater than 100 milliseconds, the test case will fail.

The scenarios that are run:

  1. Sequential 128k Read/Write from rotational media

  2. Sequential 128k Read/Write from cache

  3. Random 4k Read from rotational media

  4. Random 4k Read from cache

  5. Random 4k Write to rotational media

  6. Random 4k Write to cache

To ensure that the cache is in a clean state before running a specific scenario, the test will turn the cache off and on before running each test case.

Use the Command Syntax section to execute a specific test case.

Command syntax

Command | Description
Hybriddrive.exe -drive <disk #> -scenario tagperf | Runs the test.
-Drive <disk#> | The drive to be tested on. The behavior of boot drives or drives with a file system is not defined.
-Verbosity | The logging level for this test.
-? | Displays help.
-Scenario tagperf | The scenario to run.
-case # | The test case to run.

Parameters

Parameter name | Parameter description
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
Scenario | Scenario that test targets to.
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test


Hybrid Trim Performance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6643bc12-3850-493d-9805-977ac7118b5f

This test evaluates the performance of the Trim command for SATA drives that supports the Hybrid Information feature set.

Test details
Specifications
  • Device.Storage.Hd.Sata.HybridInformation.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Benchmark
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The drive must support the Trim command. The IDENTIFY DEVICE data word 169 bit 0 must set to one (see ACS-2 section 7.18.7.71). The test will send down Trim commands using DATA SET MANAGEMENT command.

Ensure that there is a separate drive available to be used as a logger drive. The test will automatically pick the logging drive. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this is a performance test, outside activity may affect the results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

  • Check WTT Trace

    • View Task Log of Run Trim Performance Test.

    • Open the log file TrimPerf.wtl.

    • Check for messages that may solve the issue.

    • Copy the .wtl log file. This is the WTT trace described in the WTT Trace section.

  • No metrics found

    • The test depends on Storport ETW tracing being enabled in order to get the command completion metrics. See the ETW Trace section for more information about enabling this tracing.

    • Ensure no other Storport ETW traces are currently logging. Only one Storport ETW trace can be active at a time.

  • If you get the error message "The test drive does not support trim", try the following:

    • Ensure that the SATA SSD's IDENTIFY DEVICE data word 169 bit 0 is set to one.

    • Try to send a Trim command via DATA SET MANAGEMENT.

    • Run the test again.

  • If the test failed because the read and write maximum latency exceeded 500 milliseconds, try the following:

    • Check the IO latency without Trim. Try to lower the latency below 500 milliseconds.

    • Check the IO latency with presence of Trim. Try to lower the latency below 500 milliseconds.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

This is simply a wrapper around the normal Trim Performance Test. The only difference is that every I/O the test sends down is with a priority. In addition, the test will only operate on the first couple of GB equal to the cache size of the device.

Test metrics

Command Metric

Trim

All TRIM commands must be completed in less than 500 milliseconds.

IO (with Trim sending at same time)

  • All read and write commands must be completed in less than 500 milliseconds.

  • 98.5% of the I/O commands must be completed in less than 100 milliseconds.

Use the following steps to manually reproduce this test:

  • Navigate to the following registry entry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI\Disk&Ven_[name of drive under test]\[device instance path]\Device Parameters

  • Right-click Storport, point to New, and then click DWORD (32-bit) Value.

  • Name the key EnableLogoETW and set the value to 1.

  • Unplug and then plug the drive under test into the system or reboot the system to enable the registry setting.

  • Copy the TrimPerf.exe, EtwProcessor.dll, Wex.Common.dll, and Wex.Communication.dll files locally.

  • Run the command.

Command syntax

Command | Description
TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType [DeviceType] /Scenario [Scenario] /DiskSize [DiskSize] /Cooldown [Cooldown] | Runs the test.

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test file share.
LLU_LclAdminUsr | User account for running the test.
StorageDriveNumber | Drive number of device to test
Verbosity | Verbosity of log output. 0 is least verbose, 4 is most verbose
DeviceTag | Device tag
DeviceID | Device number
IOOperation | Read or Write
DiskSize | Disk size
LogFile | Log file name


iSCSI Boot Firmware Table Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ee9439d-57ad-475b-ba5b-1bc4ecbf2c0a

This test verifies that the iSCSI Boot Firmware table is available and is valid.

The iSCSI Boot Firmware Table (iBFT) is a block of information residing in memory that contains different entries that are required by the iSCSI boot process.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.iSCSIBootComponent.FwTable
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see: Troubleshooting Device.Storage Testing.

More information

iSCSI Boot Firmware Table test (iBFTest) consists of two binaries. A user-mode binary (ibftestwrap.exe) and a kernel-mode binary (ibftest.sys). Both binaries are required for the test to run successfully.

  1. ibftestwrap.exe loads ibftest.sys into kernel mode.

  2. ibftest.sys checks if iBFT exists in memory.

  3. If iBFT exists in memory, ibftest.sys will get a copy of the table.

  4. ibftest.sys validates the table and returns results to ibftestwrap.exe.

  5. ibftestwrap.exe in turn provides a friendly log.

  6. The log contains either the table if it is available and valid or a detailed error information if the table is unavailable or invalid.

iBFTest ensures that the iBFT is present and available to the operating system for a consistent flow of the boot process. It also validates the various entries within the table and ensures that the table is intact. It ensures that all the information is compliant with the specification

To run the test, do the following:

  1. Copy iBFTest binaries: (Or make sure iBFTest is available within HLK Studio)

    1. Copy ibftestwrap.exe to test working directory.

    2. Copy ibftest.sys to test working directory.

  2. Run ibftestwrap.exe

Command syntax

Command option | Description
ibftest.exe |
NOTE

For command-line help for this test binary, type /h

File list

File | Location
Ibftest.exe | <[testbinroot]>\nttest\DriversTest\storage\wdk\ibftest</p>
Ibftest.sys | <[testbinroot]>\nttest\DriversTest\storage\wdk\ibftest</p>
Ibftestwrap.exe | <[testbinroot]>\nttest\DriversTest\storage\wdk\ibftest</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


iSCSI HBA Boot Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca7ad4d0-6950-4e2d-bdfe-b80c7873ba90

This test verifies that the host-bus adapter (HBA) properly reports the presence of a boot session to the Microsoft iSCSI initiator service.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

In addition, complete the following steps:

  1. Install the operating system on a target disk device.

  2. Run the test as an HLK Studio job from the Device Console window.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled.

This test is run in an iSCSI test environment.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive the following pop-up dialog box to input iSCSI configuration information and/or HBA information:

iscsi hba boot test (logo) ui

Follow these steps to enter the information:

  1. Type the target IQN, portal, and port information into Target Name, Target IP, and Target Port.

  2. Select the CHAP Type and type the user name and password into Target User, Target Secret and Initiator Secret, if Mutual is selected.

  3. If you select Mutual for CHAP Type, select the Supports Mutual Chap check-box.

  4. If there are multiple initiator IP addresses, enter the one used for the test in Initiator IP.

  5. If the test is for the iSCSI Target test, type the iSNS server IP address in the iSNS IP Address field, and type the NIC IP address into the NIC IP Address field.

  6. If the target support Digests, select the Supports Digests check-box.

  7. The iSNS server IP address and NIC IP address will not be used by the MPIO Test. But since the test environment is set up to run both MPIO test and iSCSI Target tests, fill out this field. The same iscsihctconfig.ini will be used for all on the same test environment.

  8. If the test is for the iSCSI HBA test, type the two NIC IP addresses into NIC IP Address and NIC IP Address 2. These fields are the same as those in WLK 1.6 used by the iSCSI HBA Redirection Test. Also, type the HBA port device instance path into HBA PnP ID. If the HBA port instance is configured to support digests, please select the Supports Digests check-box. If HBA port instance is configured to support boot, check the HBA Boot check-box.

  9. Click OK.

This information will be saved into the iscsihctconfig.ini file. There is a copy of the iscsihctconfig.ini file under [HLK Path]\JobsWorkingDir\. It enables users not to input the configuration information for every iSCSI test on same test environment, so the iSCSI UI will not pop up every time after the first input. To change the iSCSI configuration information, change the iscsihctconfig.ini file under [HLK Path]\JobsWorkingDir\ directly or delete it to cause the UI to pop up again.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see: Troubleshooting Device.Storage Testing.

If you experience issues during this test, complete the following steps:

  1. From the Windows HLK Manager, review the test job results log file for test failures.

  2. Check if the target has a drive letter.

  3. Verify the data entered in the configuration dialog (popup dialog box when the job is scheduled from device console).

More information

This test performs the following algorithm:

  1. Determines the current system boot drive.

  2. Retrieves the currently active iSCSI sessions on the system by using the ISCSI_SessionStaticInfo Microsoft Windows Management Instrumentation (WMI) class.

  3. For every active iSCSI session that is found:

    1. Checks the Type field of the session class to determine if it is a boot session.

    2. If the iSCSI session is a boot session, determines the drive letter that is associated with that session.

    3. If the associated drive letter matches the system boot drive letter, starts the system from the iSCSI device.

Command syntax

Command option | Description
Iscsi_boot_test.exe | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_boot_test.exe | <[testbinroot]>nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


iSCSI HBA Digest Test (Disk) (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca54f2b9-d56f-4ffa-ba43-b03b3e8806c8

This test verifies that the host-bus adapter (HBA) supports header and data digests as negotiated during the log on phase.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Development
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

Before starting the test, you must ensure that the test adapter is the boot adapter in the system. This system does not need to be the only system in your machine pool. You can use a secondary system that does not meet the setup requirements for certification program for this test, if necessary.

In addition, this test requires the following software and hardware:

  • iSCSI disk storage system or iSCSI bridge with disk storage system attached

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

This test returns Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

In addition:

  1. Look at the job results log file for test failures

  2. Verify the target has been formatted and assigned a drive letter.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

More information

The test performs the following algorithm:

  1. Prepares the system for iSCSI operations:

    1. If the target that is used for testing is already logged on, the session information is saved so the session can be restored later.

    2. The target disk device is added as a static iSCSI target.

  2. Perform iSCSI operations

    1. If the target that is used for testing is already logged on, the current session to the target is logged out

    2. The target is logged on by using the HBA that you are testing with header digests enabled.

    3. After logging on to the target, the test waits for all disk devices to be enumerated on the test system.

    4. The test will perform I/O read and write operations with the current target session.

    5. The test repeats the preceding steps with data digests only enabled and header and data digests enabled.

    6. The HBA under test must properly log on by using all three digest combinations with no I/O failures detected during I/O operations.

  3. Restore any previous iSCSI target sessions.

To run this test:

  1. Log on to the disk target and format the drive. The disk target should have a drive letter before you run the test.

  2. Run the test as DTM job from the Device Console window.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
Iscsi_digest.exe | Runs the test.
-hct [TestType] | The options that can be set are -target or -hba.
[TargetType] | This -disk parameter sets this option.
-setup or -login [DigestType] or -logout [DigestType] | Runs the test. This option values are header, data, or both.
-v [LogVerbosity] | Sets the test result logging level. This option sets the verbosity of the logging. There are three levels of output (0, 1, and 2) where 2 is the most verbose.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_digest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>
Logtest.vbs | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
TestType | hba or target
TargetType | tape or disk
LLU_LclAdminUsr | User account for running the test.
StorageDriveLetter | Drive letter of a volume on the target disk
WDKDeviceID | Device instance path to test
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI HBA Mutual CHAP Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/983dfea3-17ae-42e6-bb11-13b84cf5f3b4

This test verifies that the iSCSI initiator can use the Challenge Handshake Authentication Protocol (CHAP) authentication mechanism. The test verifies mutual CHAP.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

In addition, this test requires the following software and hardware:

  • 1 GB network adapter

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test returns Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

The test implements a simple test target and does not require a separate iSCSI target device. The test initiates a login to the test target specifying mutual CHAP. The target verifies that the initiator follows the CHAP protocol specifics detailed in the iSCSI specification. Different test variations will use different encodings (Base16 or Base64) for CHAP responses. In addition, the test returns both valid and invalid responses to the initiator's challenge in order to verify that the HBA properly authenticates the target and returns the appropriate status to the user.

To run this test:

  1. Run the test as an HLK Studio job.

  2. Fill the required data in the configuration UI that pops up when this job is scheduled.

Command syntax

Command | Description
iscsi_initchap.exe -mutual -hct -v [LogVerbosity] | Runs the test. The -v option controls the verbosity of the logging. There are three levels of output: 0, 1, and 2. 2 is the most verbose.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
iscsi_initchap.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI HBA Oneway CHAP Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85c50030-4ecd-412c-93d5-31b034d992c9

This test verifies that the iSCSI initiator can use the Challenge Handshake Authentication Protocol (CHAP) authentication mechanism. The test verifies a one-way CHAP.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

In addition, this test requires the following software and hardware:

  • 1 GB network adapter

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

More information

This test implements a simple test target and does not require a separate iSCSI target device. The test initiates a login to the test target specifying a one-way CHAP. The target verifies that the initiator follows the CHAP specifics that are detailed in the iSCSI specification. Different test variations will use different encodings (Base16 or Base64) for CHAP challenges. In addition, the test verifies that the HBA handles an authentication error correctly and returns the appropriate status to the user.

To run this test:

  1. Run the test as a DTM job.

  2. Fill the required data in the configuration UI that pops up when this job is scheduled.

Command syntax

Command | Description
iscsi_initchap.exe -oneway -hct -v [LogVerbosity] | Runs the test. The -v option controls the verbosity of the logging. There are three levels of output: 0, 1, and 2. 2 is the most verbose.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
iscsi_initchap.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI HBA Persistent Login Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/28885b09-7d61-431a-a376-dade735e5f6c

This test verifies the basic functionality of persistent logons and verifies that targets are logged on every time the operating system restarts.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Check if the target has a drive letter.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test always return Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

This test verifies that the Microsoft iSCSI initiator service is running on the system that you are testing. The test verifies that the host-bus adapter (HBA) driver properly returns the current list of registered persistent targets. The test attempts to add a disk target to the list of current persistent targets and then verifies that the target persists after the system restarts.

The test uses an additional application that is used to access the target after the system restarts. This test application, Hitdisk.exe, must be located in the working directory of the iSCSI Persistent test program.

To run this test:

  1. Log on to the disk target and format the drive. The disk target should have a drive letter before you run the test.

  2. Run the test from the Windows HLK Studio.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
Iscsi_plogin.exe -phase [1|2] -hct -wtt -volumearrival [VolumeArrivalTime] | Runs the test.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
Iscsi_plogin.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
VolumeArrivalTime | Time (in seconds) to wait for an iSCSI volume to appear after logging on
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


iSCSI HBA Ping Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee9806b5-8fd6-407e-9ea7-cb10cde15b3b

This test verifies that iSCSI initiators (HBA) can send and receive ping requests.

NOTE

There is no standard mechanism for initiating the sending of ICMP echo messages on an HBA. Therefore, manual interaction is required to complete this phase of the test.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test returns Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

This test operates in two phases:

  1. The first phase verifies that the HBA responds to ping requests by sending a ICMP echo packets to the HBA by using a network card in the test system.

  2. The second phase verifies the HBA can send ICMP echo packets to another address, which in this case is the network card in the test system.

To run this test:

  1. Run the test as a Driver Test Manager (DTM) job.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
Iscsi_pingtest.exe -initiator -hct | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_pingtest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI HBA RedirectionTest (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee64d1b0-f1ad-4219-83ad-53d529ba55b1

This test verifies that a host-bus adapter (HBA) properly handles the target device's capability to redirect the connection to a different IP address or port.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test always return Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

This test implements a simple iSCSI target. The test performs a logon to this target by using the HBA under test. The target, when it receives the first logon packet, will redirect the HBA to connect to the target by using a different location.

The test has three different variations that use different redirection mechanisms:

  1. Redirection to a new IP address

  2. Redirection to a new IP address and new port

  3. Redirection to the same IP address with a new port

To run this test:

  1. Run the test as a DTM job.

  2. Fill the required data in the configuration UI that pops up when this job is scheduled.

Command syntax

Command option | Description
Iscsi_redirect.exe -hct -v [LogVerbosity] | Runs the test. The -v option controls the verbosity of the logging. There are three levels of output: 0, 1, and 2. 2 is the most verbose. Default value: 1
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_redirect.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI HBA WMI Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82ab5665-a677-44b4-afe3-7111c0ce7740

This test verifies that an iSCSI host-bus adapter (HBA) driver implements the required Microsoft® Windows™ Management Instrumentation (WMI) interfaces. To qualify for the Windows Hardware Certification, iSCSI HBA drivers must support the WMI classes that are documented in the iSCSI Driver Development Kit (DDK) version 1.0.

Test details
Specifications
  • Device.Storage.Controller.Iscsi.Interface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI HBA Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test always return Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

The test enumerates all WMI classes that the HBA driver that you are testing exposes. The test verifies that there is an instance of each required class and logs a failure if a class is missing. In addition, for each class that is implemented, the test verifies the data items in the class contain valid values.

The required iSCSI initiator WMI classes include the following:

  • MSiSCSI_HBAInformation

  • MSiSCSI_InitiatorSessionInfo

  • MSiSCSI_PersistentLogins

  • MSiSCSI_TargetMappings

  • MSiSCSI_LUNMappingInformation

  • MSiSCSI_HBASessionConfig

  • MSiSCSI_PortalInfoClass

  • MSiSCSI_TCPIPConfig

  • MSiSCSI_NICConfig

  • MSiSCSI_BootConfiguration

  • MSiSCSI_SecurityCapabilities

  • MSiSCSI_DiscoveryConfig

  • MSiSCSI_RADIUSConfig

  • MSiSCSI_ConnectionStatistics

  • MSiSCSI_SessionStatistics

  • MSiSCSI_InitiatorLoginStatistics

  • MSiSCSI_InitiatorInstanceStatistics

  • MSiSCSI_MMIPSECStats

  • MSiSCSI_QMIPSECStats

  • MSiSCSI_NICPerformance

To run this test:

  1. Run the test as a Driver Test Manager (DTM) job.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
iscsiwmi.cmd | Runs the test.

File list

File | Location
iscsiwmi.cmd | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDriverName | Driver Name
WDKDeviceID | Device ID of iSCSI HBA


iSCSI Target Digest Test (Disk) (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6c3fba5-ba8b-42d4-802f-893d9ece70ca

This test verifies that an iSCSI disk storage system supports header and data digests as negotiated during the logon phase.

Test details
Specifications
  • Device.Storage.Hd.Iscsi.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 40
Category | Development
Timeout (in minutes) | 2400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

This test returns Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

In addition:

  1. Look at the job results log file for test failures

  2. Verify the target has been formatted and assigned a drive letter.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

More information

The test performs the following algorithm:

  1. Prepares the system for iSCSI operations:

    1. If the target that is used for testing is already logged on, the session information is saved so the session can be restored later.

    2. The target disk device is added as a static iSCSI target.

  2. Perform iSCSI operations

    1. If the target that is used for testing is already logged on, the current session to the target is logged out

    2. The target is logged on with header digests enabled.

    3. After logging on to the target, the test waits for all disk devices to be enumerated on the test system.

    4. The test will perform I/O read and write operations with the current target session.

    5. The test repeats the preceding steps with data digests only enabled and header and data digests enabled.

    6. The target that you are testing must permit logon by using all three digest combinations and no I/O failures can be detected during I/O operations

  3. Restore any previous iSCSI target sessions.

To run this test:

  1. Log on to the disk target and format the drive. The disk target should have a drive letter before you run the test.

  2. Run the test as DTM job from the Device Console window.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
iscsi_digest.exe -hct [TestType] [TargetType] -cleanup -v [LogVerbosity] | Runs the test.
-hct [TestType] | The options that can be set are -target or -hba.
[TargetType] | Runs the test against an iSCSI disc. The -disk parameter sets this option.
-setup or -login [DigestType] or -logout [DigestType] | Runs the test with the digest type option set. The digest type option values are header, data, or both.
-v [LogVerbosity] | Sets the test result logging level. This option sets the verbosity of the logging. There are three levels of output: 0, 1, and 2. 2 is the most verbose.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_digest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
TestType | -target or -hba
TargetType | -disk or -tape
LLU_LclAdminUsr | User account for running the test.
StorageDriveLetter | Drive letter of a volume on the target disk
WDKDeviceID | Instance path of device to test
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI Target iSNS Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec501820-424e-4415-81ed-6a62005ec451

This test verifies that target devices (for example, disk, tape, and media changer devices) can properly register with and be discovered by an Internet Storage Name Service (iSNS) server.

This test verifies that the Microsoft iSCSI initiator can log on to the device that you are testing by using the information that the target registers with the iSNS server. The test first clears all existing discovery information on the initiator and adds the iSNS server as the only discovery mechanism. The test then verifies that the device under test is found by using the iSNS server. The test then verifies it can log on to the target.

Test details
Specifications
  • Device.Storage.Hd.Iscsi.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

This test returns Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

To run this test:

  1. Before you run this test, you must register the device under test with the iSNS server.

  2. Run the test from the Windows HLK Studio.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

Command syntax

Command option | Description
Iscsi_targetisns.exe -hct -v [LogVerbosity] | Runs the test. The -v option controls the verbosity of the logging. There are three levels of output: 0, 1, and 2. 2 is the most verbose.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_targetisns.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI Target Mutual CHAP Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aaaef499-a81a-47c0-8ab4-1641201ece07

This test verifies that the target device (disk, tape, or optical storage device) can use the Challenge Handshake Authentication Protocol (CHAP) authentication mechanism.

Test details
Specifications
  • Device.Storage.Hd.Iscsi.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a pop-up dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test always return Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

The test uses multiple variations to verify that a target properly supports mutual CHAP. The first variation performs a logon similar to the user logging on through iSCSI Initiator Control Panel Applet. The rest of the variations perform logon outside of the Microsoft initiator by using the iSCSI protocol. Each variation challenges the target by using different challenge sizes with different encodings. The target is expected to calculate the proper response.

There are four different variations:

  1. Challenge size of 1 byte using hexadecimal encoding

  2. Challenge size of 1 byte using Base64 encoding

  3. Challenge size of 1024 bytes using hexadecimal encoding

  4. Challenge size of 1024 bytes using Base64 encoding

To run this test:

  1. Set up the initiator and the target with CHAP secrets.

  2. Run the test as a Driver Test Manager (DTM) job.

  3. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
iscsi_targetchap -mutual -hct | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_targetchap.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI Target Oneway CHAP Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05d68586-6fe7-4a2f-916a-ae6de6e1438d

This test verifies that the target device (disk, tape, or optical storage device) can use the Challenge Handshake Authentication Protocol (CHAP) authentication mechanism.

Test details
Specifications
  • Device.Storage.Hd.Iscsi.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test always return Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

The test uses multiple variations to verify that a target properly supports one-way CHAP. The first variation performs a logon similar to the user logging in through iSCSI Initiator Control Panel. The rest of the variations perform logon outside of the Microsoft initiator by using the iSCSI protocol. Each variation receives the challenge from the target and responds to the targets with a calculated response. The target is then expected to either continue with the iSCSI logon or return the appropriate status code, depending on the response received.

There are four different variations:

  1. Valid response is returned using hexadecimal encoding

  2. Valid response is returned using base64 encoding

  3. Invalid response is returned using hexadecimal encoding

  4. Invalid response is returned using base64 encoding

To run this test:

  1. Run the test as a Driver Test Manager (DTM) job.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled

Command syntax

Command option | Description
iscsi_targetchap -oneway -hct -v [LogVerbosity] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
iscsi_targetchap.exe | <[testbinroot]>\nttest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


iSCSI Target Ping Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a10563c7-73dc-4a1b-a002-a187f5696558

This test verifies that iSCSI targets can send and receive ping requests. Because there is no standard mechanism for initiating the sending of ICMP echo messages on a target, manual interaction is required to complete the test.

Test details
Specifications
  • Device.Storage.Hd.Iscsi.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: iSCSI Boot Component Testing Prerequisites.

If this is the first time you are running an iSCSI HBA test, iSCSI Target test, or MPIO test over iSCSI bus type on the HLK client, or if there is no iscsihctconfig.ini under [HLK Path]\JobsWorkingDir\ on the HLK client, you will receive a dialog box to input iSCSI configuration information and/or HBA information. For more information about this dialog box, see "Running the test" in iSCSI HBA Boot Test (LOGO).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition:

  1. Look at the job results log file for test failures.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled. For more information, go to iSCSI HBA Boot Test (LOGO).

This test returns Pass or Fail. To review test details, review the test log from the Windows HLK Manager.

More information

This test operates in two phases:

  1. The first phase verifies that iSCSI targets respond to ping requests by sending an ICMP echo packets to the target by using a network card in the test system.

  2. The second phase verifies the target can send ICMP echo packets to another address, which in this case is the network adapter in the test system.

    1. If you can do a ping operation from the storage management UI, skip to step 5. Otherwise, go to step 2.

    2. Telnet into the target: telnet <target portal address, e.g. 10.10.20.80>

    3. For the telnet console IP address, it may be different from the target portal address, but it should be another portal address of the same target, such as 10.10.20.82. You can check all the network interfaces or use the network monitor to send requests to find it.

    4. Change the PortalIPAddress under [Target1] in iscsihctconfig.ini to be the one received in step 3.

    5. Run the Ping Test on the test client and ping the initiator IP address from the telnet console or storage management UI.

To run this test:

  1. Run the test as a Driver Test Manager (DTM) job.

  2. Enter the required data in the configuration dialog box that appears when this job is scheduled.

Command syntax

Command option | Description
Iscsi_pingtest.exe -target -hct -v [LogVerbosity] | Runs the test. The -v option controls the verbosity of the logging. There are three levels of output (0, 1, and 2) where 2 is the most verbose.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Iscsi_pingtest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\iscsi</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
LogVerbosity | Vebosity of logging. There are three levels of output 0,1,2 where 2 is the most verbose.


Lun Reset Test With Outstanding IO - All Disks

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f42046f1-ebf4-49dd-9eba-6ee766727fa9

This is an optional test that will execute repeated cycles on every disk. Each cycle will attempt to time out an IO request on every disk once by withholding the request from the miniport. This will trigger Storport to send a RESET_LUN at which point the test will either forward the held IO request to the miniport together with the RESET_LUN or complete the held IO request and forward only the RESET_LUN. The test comes in several flavors:

  • Lun Reset Test With Outstanding IO - All Disks - Forwards the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test With Outstanding IO - Single Disk - Forwards the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Lun Reset Test Without Outstanding IO - All Disks - Completes the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test Without Outstanding IO - Single Disk - Completes the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Bus Reset Test - Same as Lun Reset Test With Outstanding IO - All Disks but it will also fail the RESET_LUN command on purpose so that Storport will send a Bus Reset.

Test details
Specifications
  • Device.Storage.Controller.AzureStack.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

This test should be run on a nonboot storage controller. Running on a boot controller is possible, but requires at least one nonboot disk attached. This test will not execute on the boot disk. The expected result is for there to be no IOs stuck in the miniport after the RESET_LUNs and RESET_BUSs. Verification is done by restarting the machine after the test. To run this in a dual initiator setup, schedule this test on two machines connected to shared storage. Resets on one initiator should not adversely affect the other initiator. For Single Disk tests, double check that the two initiators are testing against the same physical disk in the shared storage.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting, use a debugger to verify that the test driver is loaded at boot during the test portion: StorPortShimLib: ShimInitialize called StorPortShimLib: Entering DriverAdd. CoreTestShim installed. Done with registry checks StorPortShimLib: Hooking driver: <storportminiportname>.sys

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device instance path of test device
LLU_LclAdminUsr | Administrator account to run test
LLU_NetAccessOnly | User to access test network share
WDKHardwareID | Hardware ID of test device
TestDuration | Test Duration in seconds
TestName | Test to run


Lun Reset Test With Outstanding IO - Single Disk

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/063fba0b-7d4b-40b1-b0d2-ee3c75fb42a9

This is an optional test that will execute repeated cycles on every disk. Each cycle will attempt to time out an IO request on every disk once by withholding the request from the miniport. This will trigger Storport to send a RESET_LUN at which point the test will either forward the held IO request to the miniport together with the RESET_LUN or complete the held IO request and forward only the RESET_LUN. The test comes in several flavors:

  • Lun Reset Test With Outstanding IO - All Disks - Forwards the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test With Outstanding IO - Single Disk - Forwards the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Lun Reset Test Without Outstanding IO - All Disks - Completes the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test Without Outstanding IO - Single Disk - Completes the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Bus Reset Test - Same as Lun Reset Test With Outstanding IO - All Disks but it will also fail the RESET_LUN command on purpose so that Storport will send a Bus Reset.

Test details
Specifications
  • Device.Storage.Controller.AzureStack.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

This test should be run on a nonboot storage controller. Running on a boot controller is possible, but requires at least one nonboot disk attached. This test will not execute on the boot disk. The expected result is for there to be no IOs stuck in the miniport after the RESET_LUNs and RESET_BUSs. Verification is done by restarting the machine after the test. To run this in a dual initiator setup, schedule this test on two machines connected to shared storage. Resets on one initiator should not adversely affect the other initiator. For Single Disk tests, double check that the two initiators are testing against the same physical disk in the shared storage.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting, use a debugger to verify that the test driver is loaded at boot during the test portion: StorPortShimLib: ShimInitialize called StorPortShimLib: Entering DriverAdd. CoreTestShim installed. Done with registry checks StorPortShimLib: Hooking driver: <storportminiportname>.sys

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device instance path of test device
LLU_LclAdminUsr | Administrator account to run test
LLU_NetAccessOnly | User to access test network share
WDKHardwareID | Hardware ID of test device
TestDuration | Test Duration in seconds
TestName | Test to run


Lun Reset Test Without Outstanding IO - All Disks

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/050e8551-66d1-44fb-b7f9-7cc8a8142449

This is an optional test that will execute repeated cycles on every disk. Each cycle will attempt to time out an IO request on every disk once by withholding the request from the miniport. This will trigger Storport to send a RESET_LUN at which point the test will either forward the held IO request to the miniport together with the RESET_LUN or complete the held IO request and forward only the RESET_LUN. The test comes in several flavors:

  • Lun Reset Test With Outstanding IO - All Disks - Forwards the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test With Outstanding IO - Single Disk - Forwards the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Lun Reset Test Without Outstanding IO - All Disks - Completes the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test Without Outstanding IO - Single Disk - Completes the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Bus Reset Test - Same as Lun Reset Test With Outstanding IO - All Disks but it will also fail the RESET_LUN command on purpose so that Storport will send a Bus Reset.

Test details
Specifications
  • Device.Storage.Controller.AzureStack.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

This test should be run on a nonboot storage controller. Running on a boot controller is possible, but requires at least one nonboot disk attached. This test will not execute on the boot disk. The expected result is for there to be no IOs stuck in the miniport after the RESET_LUNs and RESET_BUSs. Verification is done by restarting the machine after the test. To run this in a dual initiator setup, schedule this test on two machines connected to shared storage. Resets on one initiator should not adversely affect the other initiator. For Single Disk tests, double check that the two initiators are testing against the same physical disk in the shared storage.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting, use a debugger to verify that the test driver is loaded at boot during the test portion: StorPortShimLib: ShimInitialize called StorPortShimLib: Entering DriverAdd. CoreTestShim installed. Done with registry checks StorPortShimLib: Hooking driver: <storportminiportname>.sys

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device instance path of test device
LLU_LclAdminUsr | Administrator account to run test
LLU_NetAccessOnly | User to access test network share
WDKHardwareID | Hardware ID of test device
TestDuration | Test Duration in seconds
TestName | Test to run


Lun Reset Test Without Outstanding IO - Single Disk

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7bd451a1-ca80-4d9b-8105-17c74cea72f0

This is an optional test that will execute repeated cycles on every disk. Each cycle will attempt to time out an IO request on every disk once by withholding the request from the miniport. This will trigger Storport to send a RESET_LUN at which point the test will either forward the held IO request to the miniport together with the RESET_LUN or complete the held IO request and forward only the RESET_LUN. The test comes in several flavors:

  • Lun Reset Test With Outstanding IO - All Disks - Forwards the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test With Outstanding IO - Single Disk - Forwards the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Lun Reset Test Without Outstanding IO - All Disks - Completes the held request and tests resets on all disks on the controller in parallel.
  • Lun Reset Test Without Outstanding IO - Single Disk - Completes the held request and tests resets on the first disk on the controller by PhysicalDrive number.
  • Bus Reset Test - Same as Lun Reset Test With Outstanding IO - All Disks but it will also fail the RESET_LUN command on purpose so that Storport will send a Bus Reset.

Test details
Specifications
  • Device.Storage.Controller.AzureStack.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

This test should be run on a nonboot storage controller. Running on a boot controller is possible, but requires at least one nonboot disk attached. This test will not execute on the boot disk. The expected result is for there to be no IOs stuck in the miniport after the RESET_LUNs and RESET_BUSs. Verification is done by restarting the machine after the test. To run this in a dual initiator setup, schedule this test on two machines connected to shared storage. Resets on one initiator should not adversely affect the other initiator. For Single Disk tests, double check that the two initiators are testing against the same physical disk in the shared storage.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting, use a debugger to verify that the test driver is loaded at boot during the test portion: StorPortShimLib: ShimInitialize called StorPortShimLib: Entering DriverAdd. CoreTestShim installed. Done with registry checks StorPortShimLib: Hooking driver: <storportminiportname>.sys

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device instance path of test device
LLU_LclAdminUsr | Administrator account to run test
LLU_NetAccessOnly | User to access test network share
WDKHardwareID | Hardware ID of test device
TestDuration | Test Duration in seconds
TestName | Test to run


Multipath I-O Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6db8917d-169a-4608-972a-796694edd8b9

This test provides multi-path I/O testing for the compatibility of a vendor's storage solution with Microsoft® driver solutions.

NOTE

The test is specifically designed to run on x64 processor architectures.

Test details
Specifications
  • Device.Storage.Hd.Mpio.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Development
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup for the type of Raid Storage array that you are testing. For more information see, Hardware-based RAID (Storage Array) Testing Overview.

In addition, this test requires the following software and hardware:

  • Hardware storage RAID array that uses either the Microsoft Device Specific Module (DSM) or a third-party DSM that interfaces to the Microsoft MPIO core architecture

  • Software components included with the DSM or hardware storage RAID array being tested.

  • Multi-Path I/O Setup

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For general storage troubleshooting information, see Troubleshooting Device.Storage Testing.

In addition, this test has the following known issues:

Issue

Details

The MPIO test environment for a non-iSCSI scenario may not be configured correctly.

When testing in a non-iSCSI MPIO test environment, the test requires the Host Bus Adapter (HBA) with at least two ports (or at least two HBAs, if the HBA just has one port) to be connected to the same iSCSI target. The following manual steps can verify that the test environment is set up properly:

  1. On the test computer, open Device Manager and click Show hidden devices. You will see some disks shown and each hidden disk is for one path.

  2. For each HBA port device node:

    1. Disable it by right-clicking each HBA port and then click Disable.

    2. Verify that the hidden disks are removed after disabling that port instance. If the hidden disks remain, the HBA port is not connected to the iSCSI target.

The test fails to get HBA device instance when installing filter.

Ensure that the DSM name in the registry key (INF file) is the same as the name specified in the DSM itself.

The test fails to get the iSCSI WMI information, when connected to the test storage device through both Fibre Channel and iSCSI when the test is running against the Fibre Channel.

We recommend that you not configure MPIO LUNs that are claimed by the same DSM over more than one bus type in the same test environment.

The test fails when paths are removed after the test runs the link bouncing and simultaneous bouncing test cases.

Please make sure that the HBA is running the latest driver (one that has passed Windows Logo Certification). When testing in a non-iSCSI test environment, the Multi-Path I/O test requires that the HBA driver successfully pass the Plug and Play Driver test. If the HBA cannot pass that test, please change to another certified HBA model of HBA and retest This issue may occur because MPIO paths require a long time to be recovered.

The test fails when run under an MPIO boot environment.

Do not run the test in a MPIO boot test environment.

The test fails to restore iSCSI sessions on the iSCSI target.

Within the MPIO test environment, if there are multiple ports (IP addresses) related to one iSCSI target, you need to make sure there are at least two iSCSI sessions connected through the IP address during the test. Although the Multi-Path I/O test permit user's to configure multiple port connections to an iSCSI target, at the same time for all iSCSI related tests, user can only associate one IP address during testing.

The test did not display the iSCSI UI

First, verify that the selected LUN bus type is iSCSI. If not, the Multi-Path I/O test will not display the iSCSI UI. Second, please check if the iscsihctconfig.ini file is present at the following path: [WLKClient]\JobsWorkingDir. If this file is present, delete it if you want to use the iSCSI UI to input the iSCSI configuration information manually.

The test failed or crashed.

If the Multi-Path I/O test failed to run, please make sure that the test environment is clean before rerunning the test. This issue may occur if your controller initially contained Windows Logo Kit 1.5 and you did not reinstall Windows before installing and using Windows Logokit 1.6 to complet your storage testing.If this occurred, reinstall Windows and restart your testing.

The test fails with IO operation errors

If the Multi-Path I/O test failed anf the log file contains IO operations errors, please verify that yourLUNs are online and initialized in the raw status before running the test. If the LUNs are online and initialized, , please try to copy or read a file from a LUN with some paths failed over.

If you intend to open a support incident, follow these steps to obtain information useful to Customer Support Services:

  1. Please provide your submission .cpk package. This .cpk package should not just include Multi-Path I/O test t log but include logs for the SCSI Compliance test and the ALUA MPIO test.

  2. Please capture screenshots of your test environment. If the operating system is Windows 2008 R2 or later, please capture the MPIO configuration Snapshot screen from the Control Panel. To view this, click Start>Control Panel>MPIO>Configuration Snapshot.

  3. If a crash happened, please create a dump file. Also rerun the following test in steps:

    1. Copy the test binaries binaries and files to the Windows HLK test computer, which include: mpiotest.exe, mpioinstallfiltr.exe, iscsiui.exe, devcon.exe, pnpfiltr.sys, pnpdtest.exe and the mpiotest_script_fvt.txt file.

    2. Open a command prompt window with Administrator privileges.

    3. Run one of the following commands:

      • If the bus type is iSCSI, then run the iscsui.exe tool and input information to create an iscsihctconfig.ini file.

      • If the bus type is non-iSCSI, then run the command: mpioinstallfiltr -d <DSM device instance path> (for example ROOT\MPIO\0001) -i and then restart the test computer. If this command crashes, copy all the log files from the command console using Notepad.

    4. Run the following command for test. Even if test crashes, you still can copy all log from command console to notepad.

      • Mpiotest.exe -d <DSM device instance path> (for example ROOT\MPIO\0001) -s [ScriptName] -logo -isiSCSI [T/F].

    5. If the bus type is non-iSCSI, then, from a command prompt, run the following command to uninstall the filter driver: mpioinstallfiltr -d <DSM device instance path>, (for example, ROOT\MPIO\0001) -c and restart the system boot machine.

More information

This test is applied for Device Specific Modules (DSM) only, either Microsoft DSM or a third party DSM.

The test includes the following basic test assertions, which are combined into four test cases:

  • Failover: Data transfer is not broken when some paths are broken but not all.

  • Failback: Data transfer works normally when some paths are restored from failover.

  • Link bounce: For an MPIO environment, all paths except for one path are broken. If that path is broken and recovers within 15 seconds, the data transfer is able to continue without error.

  • Simultaneous failover and failback, or "simultaneous bouncing": Data transfer is not broken when some paths fail over and other paths fail back simultaneously.

  • Load balance policy: Different policy can be set and data transfer can work correctly with it. For Round Robin Load Policy and Round Robin Load Policy with subset, the test checks whether efficiency is degraded.

The test components include a stand-alone test application, a fault injection filter driver, a test case configuration file, an iSCSI configuration file (if the path is created over an iSCSI session), and the Device Test Manager (DTM).

Customers of an enterprise storage solution rely heavily on the high availability of its components. In storage, high availability is often implemented by redundancy. Multi-path I/O (MPIO) is one such implementation for the fabric layer of an enterprise storage solution. Microsoft supports multi-path I/O with a multi-path driver (mpio.sys) and a Device Specific Module (msdsm.sys) that ship with Windows Advanced Server operating system in the Windows Vista timeframe.

The test provides multi-path I/O testing for the compatibility of a vendor's storage solution with Microsoft driver solutions. It focuses on the following areas:

  1. Path failover and recovery should not affect data transfer quality. One purpose of setting up an MPIO environment is to increase the reliability of data transferring. This test simulates several simple scenarios that would happen in the real world to break a path, and then checks whether the environment can transfer data normally.

  2. Data transfer efficiency should be improved, or at least not degraded, in an MPIO environment.

  3. Storage devices should work normally under all policies they declare to support.

NOTE

For a Device Specific Module (DSM) that supports vendor policy (policy value is 7), please make the vendor's policy the current policy before running this test.

To run this test

  1. The Windows Hardware Lab Kit (Windows HLK) starts the stand-alone test application, which retrieves the test cases to run.

  2. The Windows HLK retrieves the MPIO test environment information for further testing.

  3. If a path is not over iSCSI, the test loads the filter driver for a related HBA instance for further testing.

  4. If the path is over iSCSI, provide the iSCSI configuration information using one of the following ways:

    • Input the configuration data into the window pop-up on the test client, which creates the Iscsihctconfig.ini file under [WLK PATH]\JobsWorkingDir\Tasks\[WTTJOBNAME]\. For more information, go to iSCSI HBA Boot Test (LOGO).

      NOTE

      If your test environment includes multiple targets, please choose to input one target related information, including IQN, portal IP and port number. For IP address, if you have several IP addresses, please input the one used to connect that target. Please for MPIO test, you do not need to input HBA PnP ID.

      NOTE

      If your iSCSI environment support mutual chap, please check both Mutual radio box and Supports Mutual Chap check box.

-   The input iSCSI configuration information will be stored in the file of iscsihctconfig.ini. To save users time, we put a copy of this configuration file under \[WLKClient\]\\JobsWorkingDir\\ on test machine. Then users can rerun the test on same test client for same iSCSI storage target without inputting iSCSI configuration information again. Also, before testing, users can choose to create the Iscsihctconfig.ini file manually and put it under \[WLKClient\] \\JobsWorkingDir\\ on test machine, which contains the configuration data. Use the following format:

    ``` syntax
    [Targets] DiskTarget=Target [Target] TargetName=iqn.2001-05.com.equallogic:0-8a0906-7e2dd0401-fd1d03f67f74b96b-10-2411a0920-0 PortalPort=3260 PortalIPAddress=10.10.20.80 CHAPType=None
    ```

  1. Set the load balance policy, which declares support, simulates failover and failback scenarios, and performs testing. For a non-iSCSI test environment, simulate the link bouncing and simultaneous bouncing scenarios.

  2. Set the Round Robin policy for non-ALUA storage and ALUA storage to enable performance checking.

  3. The test tool logs to WTTLogger.

Command syntax

Command | Description
mpiotest.exe -d "[WDKDeviceID]" -s [ScriptName] -logo -isiSCSI [isiSCSI] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Devcon.exe | <[testbinroot]>\idw</p>
EDT_Disable_Support.vbs | <[testbinroot]>\nttest\DriversTest\storage\wdk\mpiotest</p>
EDT_Enable_Support.vbs | <[testbinroot]>nttest\DriversTest\storage\wdk\mpiotest</p>
Iscsiui.exe | <[testbinroot]>\nttest\DriversTest\storage\wdk\mpiotest</p>
Mpioinstallfiltr.exe | <[testbinroot]>\nttest\DriversTest\storage\wdk\mpiotest</p>
Mpiotest.exe | <[testbinroot]>\nttest\nttest\DriversTest\storage\wdk</p>
Mpiotest_script_fvt.txt | <[testbinroot]>\nttest\DriversTest\storage\wdk\mpiotest</p>
DevFund_PnPDTest_WLK.dll | <[testbinroot]></p>
Utility_Enable_Disable_DriverVerifier.dll | <[testbinroot]></p>
Utility_DeviceStatusCheck.wsc | <[testbinroot]></p>
Utility_DisableEDTSupport.wsc | <[testbinroot]></p>
Utility_EmptyTest.wsc | <[testbinroot]></p>
Utility_WdfRelatedVerification.wsc | <[testbinroot]></p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
ScriptName | Full test script
WDKDeviceID | Instance path of device to test
isiSCSI | Is storage bus type iSCSI (T/F)


Multiport Disk Performance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7981f22-f69c-4d3c-92df-41e8926a4fd8

This test verifies that drives must not provide different behavior or degraded performance for commands based on which port is used for command delivery.

Test details
Specifications
  • Device.Storage.Hd.MultipleAccess.MultiplePorts
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup for the type of Raid Storage array that you are testing. For more information see, Hard Disk Drive Testing Prerequisites and SCSI Enclosure Services (SES) Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

The most relevant logs for trouble shooting are diskIO.wtl and multiportperf.log.wtl.

Make sure that:

  • Your test environment is set up so that two HBA ports are connected from the Test Computer to the Storage Target (Enclosure Device).

  • You have selected the MPIO Pseudo-LUN in the Selection tab of HLK Studio.

  • The disk that you have selected in the Selection tab of the HLK Studio is online.

For general storage troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

This test checks that the performance of enclosure disks is not degraded through different ports. To do that, we assume on the enclosure device side that the LUNs have the same configuration, and each port from the storage array has the same connections with HBA ports on server. The test finds different disk instances for the same disk connected by different HBA ports. Then it collects read/write/verify sequential and random throughput performance data, and compares them among different disk instances. The test fails if there is 10% performance degradation.

Command syntax

Command option | Description
multiportperf.exe -lun [StorageDriveNumber] | Runs the test
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
multiportperf.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>
diskio.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>
storagedevices.dll | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
StorageDriveNumber | The disk numbert EX: 1
DiskDeviceObjLink |


NVMe Deallocate Performance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3d5d17a-a0af-4ef2-9d8f-7c30ecea6e1a

This test evaluates the performance of the Deallocate command for Non-Volatile Memory Express (NVMe) controller drives.

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Benchmark
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The test requires that an NVMe controller drive is connected. The drive must also satisfy the following requirements:

  • The drive should be a non-boot drive. The test is destructive. It will prepare the disk with correct partition and formatting for the testing.

  • The drive must support Deallocate (Trim/Unmap/Discard) command. The test will send down Deallocate commands using DATA SET MANAGEMENT Trim command.

  • Ensure that there is a separate drive available to be used as a logger drive. The test will automatically pick the logging drive. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this is a performance test, outside activity may affect the results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For more troubleshooting information, see Troubleshooting Device.Storage Testing.

  • Check WTT Trace

    • View Task Log of Run Trim Performance Test.

    • Open the log file TrimPerf.wtl.

    • Check for messages that may solve the issue.

    • Copy the .wtl log file. This is the WTT trace described in the WTT Trace section.

  • Check launched command results

    • Browse Job Logs of Trim Performance Test (LOGO).

    • Open the LaunchCommand.result.

    • If the error is related to launching a process, determine why logman or tracerpt failed.

  • No metrics found

    • The test depends on Storport ETW tracing being enabled in order to get the command completion metrics. See the ETW Trace section for more information about enabling this tracing.

    • Ensure no other Storport ETW traces are currently logging. Only one Storport ETW trace can be active at a time.

  • If you get the error message "The test drive does not support trim", try the following:

    • Check the NVMe drive to make sure the VPD B2h page's LBPU bit is set to one.

    • Try to send a Deallocate command via DATA SET MANAGEMENT's Trim command.

    • Run the test again.

  • If the test failed because the read and write maximum latency exceeded 500 milliseconds, try the following:

    • Check the IO latency without Deallocate. Try to lower the latency below 500 milliseconds.

    • Check the IO latency with presence of Deallocate. Try to lower the latency below 500 milliseconds.

  • If you want to debug the failure by running particular test cases, you may try the following command line options:

    • Display all the test cases with numbers: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType NVMe /Scenario Performance /PrintTestCaseName

    • Run particular test case by test case number: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType NVMe /Scenario Performance /Precondition F /TestCase [TestCaseNumber]

  • If you want to debug the failure by running particular pure Trim scenario, you may try the following command line options:

    • The binary has unit test options: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType NVMe /Scenario Performance /Precondition F /UnitTest T /RangeCount [NumberOfRangesPerDeallocateCommand] /SizeCount [SizeOfEachRange] /SizeUnit [Slab | Sector] /TrimCount [NumberOfTrims]

    • /RangeCount: The number of ranges per deallocate command

    • /SizeCount: The size of each range in /SizeUnit

    • /SizeUnit: The granularity of /SizeCount, options are Slab (optimal unmap granularity) and Sector (LBA).

    • /TrimCount: The number of deallocate commands sent in the test case.

  • If you want to debug the failure faster, try disable the preconditioning (fill up the drive to 90% full, takes long time) by adding /Precondition F parameter as follows:

    • TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType NVMe /Scenario Performance /DiskSize 0 /Cooldown 2 /Precondition F

More information

The test does the following:

Deallocate command

  • All deallocate commands should be completed in less than 500 milliseconds.

IO commands (withy deallocate sending at same time at different regions)

  • All read and write commands complete in less than 500 milliseconds.

  • 98.5% of I/O commands complete in less than 100 milliseconds.

Command syntax

Command | Description
TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LogDriveLetter]: /DeviceType [DeviceType] /Scenario [Scenario] /DiskSize [DiskSize] /Cooldown [Cooldown] |
Runs the test. |
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
TrimPerf.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
Etwprocessor.dll | <[taefbinroot]></p>
Wex.common.dll | <[taefbinroot]></p>
Wex.communication.dll | <[taefbinroot]></p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
Destructive | (0,1) 0=Passive, 1=Destructive
StorageDriveNumber | Storage drive number


NVMe Deallocate Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b840451f-39f8-4a4a-9aad-a3689e70f5e3

This test checks the spec compliance of the deallocate command on NVMe controller drives.

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The test requires that an NVMe controller drive is connected. The drive must also satisfy the following requirements:

  • The drive should be a non-boot drive. The test is destructive. It will prepare the disk with correct partition and formatting for the testing.

  • The drive must support Deallocate (Trim/Unmap/Discard) command. The test will send down Deallocate commands using DATA SET MANAGEMENT Trim command.

Ensure that there is a separate drive available to be used as a logger drive. The test will automatically pick the logging drive. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this is a performance test, outside activity may affect the results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

  • Check WTT Trace

    • View Task Log of Run Trim Performance Test.

    • Open the log file TrimPerf.wtl.

    • Check for messages that may solve the issue.

    • Copy the .wtl log file. This is the WTT trace described in the WTT Trace section.

  • Check launched command results

    • Browse Job Logs of Trim Performance Test (LOGO).

    • Open the LaunchCommand.result.

    • If the error is related to launching a process, determine why logman or tracerpt failed.

  • No metrics found

    • The test depends on Storport ETW tracing being enabled in order to get the command completion metrics. See the ETW Trace section for more information about enabling this tracing.

    • Ensure no other Storport ETW traces are currently logging. Only one Storport ETW trace can be active at a time.

  • If you get the error message "The test drive does not support trim/unmap/deallocate/discard", try the following:

    • Check the NVMe drive to make sure the VPD B2h page's LBPU bit is set to one.

    • Try to send a Deallocate command via DATA SET MANAGEMENT's Trim command.

    • Run the test again.

  • Test failed with "Mismatch" errors

    The test sends down Deallocate commands and verifies the content in the deallocated region. It checks the following three scenarios. If all of them failed, it reports an error.

    • Previous data: Deallocate command didn't do anything on that region.

    • All 0x00s: Deallocate command wrote all 0x00s to the region.

    • All 0xFFs: Deallocate command wrote all 0xFFs to the region.

    The test prints the location of one violation. When checking the violation offset, use the offset printed in the log file plus the byte offset of the violation.

    For example, in the log file it prints:

    Checking for previous data: Mismatch at byte X; Expected: 0x3D, Actual: 0xFF

    Trim validation check failed at offset Y, length Z

    Then the violation byte's offset is X + Y (in bytes).

  • Test failed with "reset event found"

    Deallocate commands shouldn't cause disk reset event. If such error happens, check the implementation of NVMe deallocate command.

  • If you want to debug the failure by running particular test cases, you may try the following command line options:

    • Display all the test cases with numbers: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType NVMe /Scenario Compliance /PrintTestCaseName

    • Run particular test case by test case number: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /Scenario Compliance /Precondition F /TestCase [TestCaseNumber]

  • If you want to debug the failure faster, try disable the preconditioning (fill up the drive to 90% full, takes long time) by adding /Precondition F parameter as follows:

    • TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType NVMe /Scenario Complaince /DiskSize 0 /Cooldown 2 /Precondition F

For more troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The test evaluates the following metrics:

Deallocate command

  • All Deallocate commands should write all 0x00, or all 0xFF, or previous data on the deallocated regions.

  • Deallocate commands should not raise disk reset events.

IO commands (with Deallocate sending simultaneously at different regions)

  • Deallocate commands should not affect the correctness of read/write operations.

Manual repro steps

  • Open Registry Editor and navigate to the following path: HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Enum-> SCSI -> Disk&Ven_[name of NVMe drive (not controller) under test] -> [device instance path] -> Device Parameters -> Storport

  • Right click Storport, click New, and then click DWORD (32-bit) Value.

  • Name the key as EnableLogoETW, and set the value to 1.

  • Plug the drive under test back into the system or reboot the machine to enable the registry key.

  • Copy the TrimPerf.exe, EtwProcessor.dll, Wex.Common.dll, and Wex.Communication.dll files to the local computer.

  • Run command line.

Command syntax

Command | Description
TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LogDriveLetter]: /DeviceType StorConsumer /Scenario Performance /DiskSize 0 /Cooldown 2 |
Runs the test. |
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
TrimPerf.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
Etwprocessor.dll | <[taefbinroot]></p>
Wex.common.dll | <[taefbinroot]></p>
Wex.communication.dll | <[taefbinroot]></p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
Destructive | (0,1) 0=Passive, 1=Destructive
StorageDriveNumber | Storage drive number


NVMe Device Capabilities Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0460eb9e-280c-4f2c-aa81-9f9b2977cf0f

This test will verify device's capabilities by reading various registers.

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails to find the drive letter of the device, try to restart the machine with device attached, format and mount NTFS volume and assign drive letter, reboot machine to confirm drive letter and drive number of device are recognizable in diskmgmt.msc and then schedule the test.

More information

Parameters

Parameter name | Parameter description
StorageDriveLetter | Storage Drive Letter
StorageDriveNumber | Storage Drive Number
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


NVMe Interrupt Modes Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/681ab7d0-a5ab-40d0-a67b-aea53b26795c

This test verifies the device's capability of operating in different interrupt mode by doing I/O. The following are the various interrupt modes exercised:

  • Random number of interrupts (Power of 2) in MSI-X/MSI mode

  • 1 MSI-X/MSI mode

  • Line Based interrupt mode

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails to find the drive letter of the device, try to restart the machine with device attached, format and mount NTFS volume and assign drive letter, reboot machine to confirm drive letter and drive number of device are recognizable in diskmgmt.msc and then schedule the test.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
StorageDriveLetter | Storage Drive Letter
StorageDriveNumber | Storage Drive Number
QueryPDOName | PDO of NVMe Controller


NVMe IO Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90f535f2-9cfe-49ee-9e4a-852ae6770b9a

This test verifies the device's IO capability by running below scenarios:

  • Block size variations

    • 512 bytes

    • 4 KB

    • 8 KB

    • 12 KB

    • 512 KB

    • 2 MB

  • SQ, CQ, Queue Size variations

  • I/O on random number of processors followed by all processors

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Development
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails to find the drive letter of the device, try to restart the machine with device attached, format and mount NTFS volume and assign drive letter, reboot machine to confirm drive letter and drive number of device are recognizable in diskmgmt.msc and then schedule the test.

More information

Command syntax

Command | Description
/DriveLetter | The drive letter of the device. You can get help by running nvmeshim /DriveLetter /? Example: D:
/DriveNumber | The drive number of the device. You can get help by running nvmeshim /DriveNumber /? Example: 1
/Duration | I/O duration in seconds. You can get help by running nvmeshim.exe /Duration /?
/Operation QueueManagement | Run QueueManagement scenarios.
/Verbosity | The level of logging verbosity. Larger values cause more verbose output.
/Scenario All | Run all scenarios in the specified operation.

File list

File | Location
nvmeshim.exe | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Enable.cmd | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
stornvme.sys | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.cat | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.man | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.inf | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.sys | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device Instance ID
StorageDriveLetter | Storage Drive Letter
StorageDriveNumber | Storage Drive Number
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
DiskDeviceObjLink | Assigned by Create Storage Parameters
DataBufferAlignment | Data buffer alignment to be used, Value ranges from 4 to 4092, specify 4096 for random buffer shift
DataBufferAlignment_Percent | Percent of time buffer shift to perform
ScenarioDuration | Duration of each scenaio
Scenarios | IO Scenarios
QueueDepth |
Settings | Additional settings


NVMe Queue Pause-Resume Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7451fbf3-6528-48eb-ade5-9e4b473505aa

This test verifies the device's capability of handling I/s in the event of pausing and resuming Submission Queue, Completion Queue, or both.

  • The test monitors for any reset events that may happen as a result of IOs timing out.

  • The maximum pause-resume of I/O is currently set to a low value of 4 seconds.

  • Time period of Pause-Resume of Queues could be uniform or random

  • Interval Time period between Pause-Resume of Queues could be uniform or random

  • Queue Depth chosen for IO scenarios could max out at value specified in certification requirements.

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 140
Category | Development
Timeout (in minutes) | 8400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails to find the drive letter of the device, try to restart the machine with device attached, format and mount NTFS volume and assign drive letter, reboot machine to confirm drive letter and drive number of device are recognizable in diskmgmt.msc and then schedule the test.

More information

Command syntax

Command | Description
/DriveLetter | The drive letter of the device. You can get help by running nvmeshim /DriveLetter /? Example: D:
/DriveNumber | The drive number of the device. You can get help by running nvmeshim /DriveNumber /? Example: 1
/Duration | I/O duration in seconds. You can get help by running nvmeshim.exe /Duration /?
/Operation PauseResume | Run PauseResume scenarios.
/Verbosity | The level of logging verbosity. Larger values cause more verbose output.
/Scenario All | Run all scenarios in the specified operation.
/Scenario NoPauseResume | Run scenarios which do not pause-resume queue
/Scenario PauseResumeSQ | Run scenarios which pause-resume SQ
/Scenario PauseResumeCQ | Run scenarios which pause-resume CQ
/Scenario PauseResumeAllQ | Run scenarios which pause-resume both SQ and CQ

File list

File | Location
nvmeshim.exe | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Enable.cmd | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
stornvme.sys | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.cat | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.man | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.inf | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.sys | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Storage Drive Letter
StorageDriveNumber | Storage Drive Number
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


NVMe Queue Utilization Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7117cbfe-37ab-4c47-821e-d7ca36295b19

This test measures the I/O Queue statistics of both Submission Queue and Completion Queue. There are 2 scenarios here:

  • Activate queues mapped to all processors

  • Activate queues mapped to random number of processors

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails to find the drive letter of the device, try to restart the machine with device attached, format and mount NTFS volume and assign drive letter, reboot machine to confirm drive letter and drive number of device are recognizable in diskmgmt.msc and then schedule the test.

More information

Command syntax

Command | Description
/DriveLetter | The drive letter of the device. You can get help by running nvmeshim /DriveLetter /? Example: D:
/DriveNumber | The drive number of the device. You can get help by running nvmeshim /DriveNumber /? Example: 1
/Duration | I/O duration in seconds. You can get help by running nvmeshim.exe /Duration /?
/Operation QueueUtilization | Run QueueUtilization scenarios.
/Verbosity | The level of logging verbosity. Larger values cause more verbose output.
/Scenario All | Run all scenarios in the specified operation.

File list

File | Location
nvmeshim.exe | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Enable.cmd | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
stornvme.sys | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.cat | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.man | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.inf | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>
Stornvmeshim.sys | <testbinroot>\NTTEST\driverstest\storage\wdk\nvme</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Storage Drive Letter
StorageDriveNumber | Storage Drive Number
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


NVMe SCSI Compliance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f98eed5-478b-42bc-8c17-ee49a2c63202

This test verifies the device and driver capabilities of SCSI-NVMe translation.

Test details
Specifications
  • Device.Storage.ControllerDrive.NVMe.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails to find the drive letter of the device, try to restart the machine with device attached, format and mount NTFS volume and assign drive letter, reboot machine to confirm drive letter and drive number of device are recognizable in diskmgmt.msc and then schedule the test.

More information

Here's a list of SCSI commands:

SCSI command | NVMe command translation | HLK policy
SCSIOP_REPORT_LUNS | Identify | M
SCSIOP_INQUIRY | Identify | M
SCSIOP_MODE_SENSE | Identify, get features | M
SCSIOP_MODE_SENSE10 | Identify, get features | M
SCSIOP_MODE_SELECT | No translation recommended | M
SCSIOP_MODE_SELECT10 | No translation recommended | M
SCSIOP_READ_CAPACITY | Identify | M
SCSIOP_READ_CAPACITY16 | Identify | M
SCSIOP_READ6 | Read | If-implemented
SCSIOP_READ | Read | M
SCSIOP_READ12 | Read | Not tested
SCSIOP_READ16 | Read | M
SCSIOP_WRITE6 | Write | If-implemented
SCSIOP_WRITE | Write | M
SCSIOP_WRITE12 | Write | Not tested
SCSIOP_WRITE16 | Write | M
SCSIOP_SYNCHRONIZE_CACHE | Flush | M
SCSIOP_SYNCHRONIZE_CACHE16 | Flush | Not tested
SCSIOP_WRITE_LONG | Write uncorrectable | Not tested
SCSIOP_WRITE_LONG16 | Write uncorrectable | Not tested
SCSIOP_UNMAP | Dataset management | M
SCSIOP_START_STOP_UNIT | Set features, get features | M
SCSIOP_SECURITY_PROTOCOL_IN | Security receive | If-implemented
SCSIOP_SECURITY_PROTOCOL_OUT | Security send | If-implemented
SCSIOP_COMPARE | Compare and write | Not tested
SCSIOP_FORMAT | Format NVM | Not tested
SCSIOP_LOG_SENSE | Get features, get log page | M
SCSIOP_REQUEST_SENSE | No translation recommended | If-implemented
SCSIOP_TEST_UNIT_READY | No translation recommended | M
SCSIOP_WRITE_DATA_BUFF | Firmware image download, firmware image activate | Not tested

The following shows a list of VPDs:

VPD | Page code | NVMe guidelines | HLK policy
Supported VPD pages | 0x0 | M | M
Serial number | 0x80 | M | M
Device identification | 0x83 | M | M
Extended inquiry | 0x86 | O | Not tested
Block device characteristics | 0x81 | M | M
Block limits | 0xB0 | Not recommended | M

The following shows a list of mode pages:

Mode page | Page code | NVMe guidelines | HLK policy
Supported mode pages | 0x3F | M | M
Caching | 0x8 | M | M
Control | 0xA | M | Not tested
Power condition | 0x1A | M | Not tested
Informational exceptions control | 0x1C | M | Not tested

The following shows a list of log pages:

Log page | Page code | NVMe guidelines | HLK policy
Supported log pages | 0x0 | M | M
Temperature | 0x0D | M | M
Information exceptions | 0x2F | M | M

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
ScsiComplianceDevice | Device path
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | operation option


Offload Reset logo test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c78a2cda-a174-4342-8c7a-271d4852946d

This test verifies the behavior of offload capable devices when offload-related commands are exercised. The test looks for any LUN, Target, or Bus reset on the device.

Test details
Specifications
  • Device.Storage.Hd.OffloadedDataTransfer.CopyOffload
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 50
Category | Scenario
Timeout (in minutes) | 3000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

Command syntax

Command option | Description
powershell -noexit .\StressReset.ps1 /drivenumber [StorageDriveNumber] /scenario "copyoffload" | Runs the test
/drivenumber | Physical drive number associated with the device.
/scenario | Scenario used for stress reset. Example: copyoffload
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
StressReset.ps1 | <[testbinroot]>\nttest\DriversTest\storage\wdk</p>
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device Instance ID
StorageDriveLetter | Storage Drive Letter
StorageDriveNumber | Storage Drive Number
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
DiskDeviceObjLink | Assigned by Create Storage Parameters


Offload scenario test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/563e161b-097e-4799-8dd5-1dc298987060

This test verifies behavior of offload capable devices when offload related commands are exercised. The test exercises Offload Reads and Offload Writes between LUNs of the same target (such as an adapter) and between LUNs of different adapters.

Test details
Specifications
  • Device.Storage.Hd.OffloadedDataTransfer.CopyOffload
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Attach the following to the HLK test machine: Storage adapter 1, LUNs 1 and 2 & Storage Adapter 2, LUN 3. LUNs 1, 2 and 3 should be a minimum of 21 GB in size.

Format and mount file system on LUNs 1, 2 and 3. When you schedule the test on the HLK controller, there is a run time parameter called "RemoteShareODXStorageDriveLetter". Provide the drive letter associated with LUN3 for the run-time parameter. For example, if LUNs 1, 2 and 3 have drive Letters X, Y and Z, type Z for the run-time parameter and schedule test.

When running the offload scenario test in conjunction with other storage tests, the drive configuration must be maintained for the tests in the same project.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The following Scenarios are exercised:

  • Copy Offload between LUNs from the same adapter

    • Single HBA push scenario

    • Single HBA pull scenario

  • Copy Offload between LUNs from different adapters

    • Multiple HBA push scenario

    • Multiple HBA pull scenario

Command syntax

Command | Description
Copyoffload.exe | The options for the test are listed below
/regression:[Scenarios] | Scenarios to run, scenarios are from 2 to 21, ranging in transfer sizes
/stp | Source test path
/dtp | Destination test path
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Copyoffload.exe | <[testbinroot]>\nttest\BASETEST\core_file_services\ntfs\copyoffload</p>
Scattermultithread.exe | <[testbinroot]>\nttest\BASETEST\core_file_services\ntfs\scattergather</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Storage Drive Letter
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
ODXStorageDriveLetter | Disk's ODX cousin
RemoteShareODXStorageDriveLetter | Disk's remote cousin
DiskDeviceObjLink | Assigned by Create Storage Parameters


Offload SCSI Compliance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3bbedc08-89f8-4100-87a3-7a4cf09dbd07

This test ensures that devices comply to Copy Offload related CDBs and VPDs. Offload related functionality is described in Specs 11-059, 11-078, 11-079 and 11-080 of the T10 Technical Committee. The test uses SCSI pass-through requests (IOCTL_SCSI_PASS_THROUGH) to construct and send SCSI command descriptor blocks (CDBs) to the device. The test evaluates the results of the commands to verify compliance.

Test details
Specifications
  • Device.Storage.Hd.OffloadedDataTransfer.CopyOffload
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The test writes the results to the log file Scsicompliance.wtl and Scsicompliance.wtl.txt. Errors from this test occur via issues identified in the log file and in bugchecks produced through stressing the driver under test.

During the test, if you are having trouble removing a LUN that is failing or are unable to create a LUN from the storage controller, follow these steps:

  1. Prior to running this test, verify that the storage device works properly. Open Diskmgmt.msc, select disk, and make sure you can put the device Online and Initialized.

  2. Restart the Windows HLK client computer.

  3. Select and rerun the Offload SCSI Compliance test. Do not run any test before it.

  4. If the test failed, run the individual failing command data blocks (cdbs) one at a time with the logging verbosity level set to 4 (the highest level of test logging). This will show what data was sent and what data was returned. We have seen previous instances where a test faisl after several cdbs were completed but pass standalone. If this occurs, there is a problem in the firmware or the test. There might have been a device reset leading to the device falling off the bus, resulting in subsequent commands to fail. To resolve this issue, follow these steps:

    1. Copy the test binary (Scsicompliance.exe) from the Windows HLK controller. This file is located here: \\controllername\tests\[processorarchitecture]\NTTEST\DriversTest\storage\wdk\

    2. Copy the wttlog.dll file from the Windows HLK controller. This file is located here: \\<controllername>\Tests\[processorarchitecture]\wtt

    3. Place both of these files on the test computer in a separate folder.

    4. From a command prompt, from the directory containing the test binary, type the following command: Scsicompliance.exe /device <deviceID> /verbosity 4 /operation test /scenario <scenario> /CDB <failingcdbname>

      WARNING

      deviceID and scenario values can be found by checking the repro line within the test log. The failingcdbname can be found by running the test binary with the /?option (scsicompliance.exe /?).

    5. Go back to the same directory and review the results to see if you can determine the reason for the test failure.

    6. If you need additional help, collect the txt and wtl logs and share the logs with Microsoft Customer Support Services.

More information

Command syntax

Command option | Description
Scsicompliance.exe | The options for the test are listed below
/device | The device which test is to run on. Example: /Device <physical device path>
/operation | The operation to run. Example: /Operation Test
/scenario | The feature to be tested for. Example: /Scenario CopyOffload
/verbosity | The level of logging verbosity. Larger values cause more verbose output. Example: /Verbosity 4
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
ScsiComplianceDevice | Device path
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | operation option


Optical Logo Test - BD-R

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84e5af35-b93b-4819-949e-e0825871a55e

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.BluRayWriter.Profiles
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 360
Category | Scenario
Timeout (in minutes) | 21600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - BD-RE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8b08003-5188-4e8e-aefe-5bc0caa31b26

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.BluRayWriter.Profiles
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1200
Category | Scenario
Timeout (in minutes) | 72000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - BD-ROM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3539fe65-627c-4ab8-8fd2-9d104b6aa41c

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.BluRayReader.Profiles
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - CD-R

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3509d85e-f761-408f-a9e3-15df56540fb3

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - CD-ROM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5bf4589-e628-443b-8307-4bee44b7c9c1

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - CD-RW

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebc88aa1-d92b-4f47-8b39-2eb6cf930b3f

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Scenario
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - Device

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f74601b6-ecfd-47cc-8b4f-d17d5a6a7b95

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD+R

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3b5b0a5-dc34-4786-9aae-750c77a2c7d4

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Scenario
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD+R Dual Layer

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6d74efa-ad54-4407-9430-9497b05b0b29

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 150
Category | Scenario
Timeout (in minutes) | 9000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD+RW

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc637afb-d205-4c6d-a934-a13f7da84309

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Scenario
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD-R

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2de525ac-a1f3-4f7b-aa58-61b18df31b05

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Scenario
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD-R Dual Layer Seq

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c6c2ee3c-8108-4fd3-8aa8-9f6f14d860f7

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Scenario
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD-RAM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7166ee0a-e550-4ece-bdfd-2e13cc41b56c

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 210
Category | Scenario
Timeout (in minutes) | 12600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD-ROM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85d5bc7f-47bc-49ab-8b84-f7a407197d51

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


Optical Logo Test - DVD-RW RO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61654809-c0f7-4a39-9d1e-e9e22d21f043

This test validates that the optical device complies with standards and meets the Windows optical drive requirements.

Test details
Specifications
  • Device.Storage.Optical.CdRawRecording
  • Device.Storage.Optical.CommandPerformance
  • Device.Storage.Optical.DriveDefinition
  • Device.Storage.Optical.Features
  • Device.Storage.Optical.Profiles
  • Device.Storage.Optical.RealTimeStreaming
  • Device.Storage.Optical.MmcVersion
  • Device.Storage.Optical.Sata.AsynchronousNotification
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Scenario
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Optical Disk Drive Testing Prerequisites.

The test shows a configuration dialog box to get the primary and secondary drive tray configuration. The user has to select the identical secondary drive from the drives list in the Writer Drive dialog box and should select the drive tray capabilities, whether it supports auto ejecting and auto loading the tray.

NOTE

The I/O intensive applications running on the test computer might interfere with the optical logo test performance measurement scenarios. Please make sure there are no other applications running on the test computer when the test is running.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The following are known issues regarding this test:

  • Bus reset test scenario disabled by default.

    By default, the test does not validate the proper device behavior upon bus reset.

    If bus reset happens, the drive is expected to reset itself properly, come back online, and should work as normal. Some defective drives do not reset themselves properly and will not work after the bus reset. This is not a proper implementation. When this specific test scenario is enabled, the command verification test cases (both device and profile test cases) send the commands with incorrect SRB data direction flag. This will typically stall the bus and eventually cause the port driver to reset the bus after a given timeout period.

    Most storage controllers do not support this test scenario properly. The incorrectly implemented storage controllers will not recover after the bus reset. If that happens, the test case might fail due to the storage controller even if the device was properly implemented. This test is not able to distinguish device failures from storage controller failures. So, testing this specific scenario is disabled by default. To enable testing this specific scenario, the test executable should be ran with the "RunDataDirectionFlagScenario" command-line option.

More information

The drive shall support the following commands:

  • Get Configuration (with no media)

  • Get Event Status Notification

  • Inquiry

  • Mechanism Status

  • Mode Sense

  • Prevent Allow Medium Removal

  • Request Sense

  • Start Stop Unit

  • Test Unit Ready

The drive shall support the following commands if they are mandatory for the features and profiles it supports.

  • Get Configuration (with media)

  • Get Performance

  • Read Buffer Capacity

  • Read Capacity

  • Read Disc Information

  • Read Format Capacities

  • Read Toc Pma Atip

  • Send Opc Information

  • Set CD Speed

  • Read10

The drive shall support the following scenarios if the commands associated with these scenarios are mandatory for the features and profiles it supports.

  • Event Status Notification

  • Write

    • Sequential mode

    • Packet mode

    • Restricted Overwrite

    • Multi Session support

  • Audio Media (Write Audio Tracks)

  • Blank

  • Unique drive serial number

  • Real-time streaming

  • Audio Media Gapless Raw Recording

Test cases are segregated into the following three groups:

  • Device test cases. The following commands verification test cases that are applicable for the device:

    • GET CONFIGURATION (WITH NO MEDIA)

    • GET EVENT STATUS NOTIFICATION

    • INQUIRY

    • MECHANISM STATUS

    • MODE SENSE

    • PREVENT ALLOW MEDIUM REMOVAL

    • REQUEST SENSE

    • START STOP UNIT

    • TEST UNIT READY

  • Profile test cases. The following commands verification test cases will be tested on all applicable profiles:

    • GET CONFIGURATION

    • GET PERFORMANCE

    • READ CAPACITY

    • READ BUFFER CAPACITY

    • READ DISC INFORMATION

    • READ FORMAT CAPACITIES

    • READ TOC PMA ATIP

    • SEND OPC INFORMATION

    • SET CD SPEED

    • READ10

  • Usage scenario test cases. The following scenarios are tested using the IMAPI burn engine interfaces:

    • EVENT STATUS NOTIFICATION

    • BLANK

    • WRITE/MULTISESSION

    • AUDIO MEDIA

    • WRITE DUAL LAYER MEDIA

    • DRIVE SERIAL NUMBER

    • READ ONLY DRIVE

    • REAL-TIME STREAMING

    • AUDIO MEDIA GAPLESS RAW RECORDING

This test includes the following test cases:

  • GET CONFIGURATION COMMAND (WITH NO MEDIA)

  • GET EVENT STATUS NOTIFICATION COMMAND

  • INQUIRY COMMAND

  • MECHANISM STATUS COMMAND

  • MODE SENSE COMMAND

  • PREVENT ALLOW MEDIUM REMOVAL COMMAND

  • REQUEST SENSE COMMAND

  • START STOP UNIT COMMANDS, EJECT & LOAD PERFORMANCE

  • TEST UNIT READY COMMAND

  • GET CONFIGURATION COMMAND

  • GET PERFORMANCE

  • READ CAPACITY COMMAND

  • READ BUFFER CAPACITY COMMAND

  • READ DISC INFORMATION COMMAND

  • READ FORMAT CAPACITIES COMMAND

  • READ TOC/PMA/ATIP COMMAND

  • SEND OPC INFORMATION COMMAND

  • SET CD SPEED COMMAND

  • READ10 COMMAND

  • EVENT NOTIFICATION

  • WRITE TESTS

  • AUDIO MEDIA (WRITE AUDIO TRACKS)

  • BLANK

  • WRITE DUAL LAYER MEDIA

  • READ ONLY DRIVE

  • DRIVE SERIAL NUMBER

  • REAL TIME STREAMING

  • WRITE SPEED MEASUREMENT

  • AUDIO MEDIA GAPLESS RAW RECORDING

GET CONFIGURATION command (with no media)

Description: This test is to ensure the drive responds to the GET CONFIGURATION command properly when there is no media in the tray.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Eject the tray by sending the START STOP UNIT command.

  2. Wait until the tray is open.

  3. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: allow software to probe support of command.

  4. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  5. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step 3. Purpose: allow software to retrieve the entire list of features supported by the drive.

  6. Check if the drive reports no current profile in the feature header. If the drive does not repro current profile as "no current profile" then fail the test case.

  7. Get the profile list feature descriptor in the response for the current profile bit set and Fail the test case if any of the profile descriptor has the current profile bit set to 1.

  8. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (not current).

  9. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case. Purpose: To make sure the device handles command with incorrect data direction.

  10. Inject the tray.

  11. Wait until the device comes to ready state

  12. Send the GET CONFIGURATION command with response data length of 16 bytes, RT=01b, Starting Feature Number=0003h (Removable Medium Feature). If the command fails print the sense key as appropriate and fail the test case. If the command succeeds:

    • Check if the "Eject" bit is set if the drive supports auto eject mechanism.

    • Check if the "Load" bit is set if the drive supports auto inject mechanism.

Result: The drive should respond to the GET CONFIGURATION command properly

GET EVENT STATUS NOTIFICATION command

Description: To validate if the drive supports the GET EVENT STATUS NOTIFICATION command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  2. If the command fails, fail the test case

  3. In the response check which events are supported

  4. [Optional] Send Get Event Status Notification Command with the data direction flag set to "to the device" and the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy),

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  5. If the command fails, fail the test case

  6. In the response check that Event Data Length is 0x6, NEA bit is cleared, Notification Class is non-zero and Supported Event Classes are identical to step 3. Otherwise fail the test case.

  7. Send Get Event Status Notification Command with the following values in the CDB.

    • Notification Class Request = 0x7E (Operational Change, Power Management, External Request, Media, Multi-Host, Device Busy).

    • Polled = 1

    • Allocation Length equal to the size of the response header (4 bytes)

  8. If the command fails, fail the test case.

Result: The drive should respond to the GET EVENT STATUS NOTIFICATION command properly.

INQUIRY command

Description: To validate if the drive supports the INQUIRY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command with allocation length equal 08h. Purpose: allow software to probe the required response buffer size.

  2. If the command succeeds, check the response for the additional length in the header. The additional length must be 32d or larger [MMC5r04 6.9.2].

  3. Send the INQUIRY command again with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds, ensure that response data fields match values specified in MMC5r04 table 320.

  5. Check that Vendor Identification, Product Identification and Product Revision Level are not null.

    • Purpose: Basic identification by software.

  6. Check if the following values match:

    • Device Type = 5

    • Device Type Qualifier = 0

    • Removable Media = 1

    • Response Data Format = 2

    • Hierarchy Support = 0

    • Normal ACA = 0

    • Protect = 0

    • Third Party Copy = 0

    • Target Port Group Support = 0

    • Access Controls Coordinator = 0

    • SCC Supported = 0

    • Addr16 = 0

    • Medium Changer = 0

    • Multi Port = 0

    • VS1 = 0

    • Enclosure Services = 0

    • BQue = 0

    • VS2 = 0

    • Command Queue = 0

    • Linked Commands = 0

    • Synchronous = 0

    • Wide16 = 0

  7. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 0

    • Allocation Length = 240

  8. Send the INQUIRY command with the following values in the CDB:

    • EVPD = 1

    • Allocation Length = 240

  9. If the command succeeds then compare the response from step 7 and step 8, if both are equal then fail the test case.

  10. Send the INQUIRY command for a random number of times between 10 and 25 with random allocation lengths. If the command fails then fail the test case.

  11. [Optional] Send the INQUIRY command with the data direction flag set to" to the device" and with the following values in the CDB

    • EVPD = 0

    • Allocation Length = 240

Result: The drive should respond to the INQUIRY command properly.

MECHANISM STATUS command

Description: To validate if the drive supports the MECHANISM STATUS command

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MECHANISM STATUS command with allocation length 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command

  2. Eject the Tray.

  3. Wait until the device return the sense data (Sense Key : 0x2, ASC: 0x3A, ASCQ: 0x02)

  4. Send the MECHANISM STATUS command with allocation length 8 bytes.

  5. Check that Door Open bit is 1b.

    • Purpose: Allow software to detect if door is open or closed (open).

  6. Inject the tray

  7. Wait until the device is ready

  8. Send the MECHANISM STATUS command with allocation length 8 bytes.

  9. Check that Door Open bit is 0b.

    • Purpose: Allow software to detect if door is open or closed (closed).

  10. Create an 8 byte buffer and fill it with random data.

  11. [Optional] Send the MECHANISM STATUS command with data direction flag set to "to the device" and with allocation length of 8 bytes. Pass the buffer from step 11 to the device.

Result: The drive should respond to the MECHANISM STATUS command properly

MODE SENSE command

Description: To validate if the drive supports the Mode Sense command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the MODE SENSE command with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

  2. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page length for each mode page data is equal to the value documented in MMC5.

  3. Validate the Mode page data for each reported page

  4. Send the Mode Sense command for each reported page with the following values in the CDB:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Allocation Length = Page Length reported by the drive in step 2

  5. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero.

    • Page code in the mode page header matches with the requested page code.

    • Page length in the mode page header is equal to the value document in MMC5.

  6. Send the Mode Sense command with allocation length 0xFFF0

  7. Check the following values in the response:

    • Block Descriptor Length in the mode parameters header is zero

    • Page code in the mode page header matches with the requested page code

  8. Send the Mode Sense command with allocation length 0x0A

  9. Check if the response matches byte by byte up to the response size (0x0A) with the response for allocation length equal to 0xFFF0.

  10. Send the Mode Sense command for a random number of times between 10 and 25 with random allocation lengths between 0x0A and 0xFFF0.

  11. Check if the response matches byte by byte up to the response size (random value between 0x0A and 0xFFF0) with the response for allocation length equal to 0xFFF0.

  12. [Optional] Send the MODE SENSE command with the data direction flag set to "to the device" and with the following values in the CDB to get all the supported Mode Pages:

    • Page Control = 0

    • Disable Block Descriptors = 1

    • Page Code = 0x3F

    • Allocation Length = 0x8000

Result: The drive should respond to the GET CONFIGURATION command properly

PREVENT ALLOW MEDIUM REMOVAL command

Description: To validate if the drive supports the PREVENT ALLOW MEDIUM REMOVAL command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the PREVENT ALLOW MEDIUM REMOVAL command with prevent bit set to 1 and Persistent bit set to 0. This would lock the drive. If the command fails print the sense key and fail the test case.

  2. Send the start stop unit command with LocEj bit set to 1 and Immediate bit set to 0 and Start bit set to zero. This will try to eject the disc. If the drive doesn't reject the command with sense data 0x05 0x53, 0x02 then it is a failure.

  3. Send the Test Unit ready command and ensure it succeeds.

  4. Ask the user to press the eject button to eject the media.

  5. Send the Test Unit ready command and ensure it still succeeds (door should not open).

  6. Send the Prevent Allow Medium Removal command with prevent bit set to 0 and Persistent bit set to 0. This would unlock the drive. If the command fails print the sense key and fail the test case.

  7. Ask the user to press the eject button to eject the media

  8. Wait for the device to open the door - Send the Test Unit ready command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  9. If the drive supports auto loading mechanism then inject the tray back into the drive otherwise ask the user to insert the tray back into the drive.

  10. Wait for the device to be ready

  11. [Optional] Send the PREVENT ALLOW MEDIUM REMOVAL command with the data direction flag set to the "to the device" and pass the random data in a random size buffer.

Result: The drive should respond to the PREVENT ALLOW MEDIUM REMOVAL command properly.

REQUEST SENSE command

Description: To validate if the drive supports the REQUEST SENSE command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the REQUEST SENSE command, with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

  2. If the command fails print the sense key and fail the test case.

  3. If the response code is 0x70 or 0x71 the test passes otherwise the test fails.

  4. [Optional] Send the REQUEST SENSE command, with the data direction flag set to "to the device" and with the descriptor bit set to zero and Allocation Length set to 252. The drive shall respond with the fixed format sense data.

Result: The drive should respond to the REQUEST SENSE command properly.

START STOP UNIT command, EJECT & LOAD PERFORMANCE

Description: To validate if the drive supports the START STOP UNIT command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the START STOP UNIT command with the following values in the CDB

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 0, LoadEject = 0, Start = 1, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 0, PowerConditions = 0

    • Immediate = 1, LoadEject = 0, Start = 1, PowerConditions = 0

  2. The command shall succeed for each of this combination.

  3. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray

    • Immediate = 1, LoadEject = 1, Start = 0, PowerConditions = 0

  4. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 5 seconds and retry until it fails with (02/3A/02). Timeout after 10 seconds.

  5. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 1, LoadEject = 1, Start = 1, PowerConditions = 0

  6. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive.

  7. Wait for the device to be ready - Send the TEST UNIT READY command, if the command fails with a sense key then wait for 1 second and retry until it succeeds. Timeout after 30 seconds. PREMIUM LOGO: Time out: 20 seconds.

  8. Send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  9. Wait for the device to open the door - Send the TEST UNIT READY command, if the command succeeds then wait for 1 second and retry until it fails with (02/3A/02). Timeout after 30 seconds.

  10. Ask user to remove the media

  11. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray:

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  12. Ensure the command fails with Not Ready / Medium not present / Tray closed (02/3A/01)

  13. If the drive supports ejecting the tray, then send the START STOP UNIT command with the following values in the CDB, to eject the tray:

    • Immediate = 0, LoadEject = 1, Start = 0, PowerConditions = 0

  14. Ask the user to place the media in the tray.

  15. If the drive doesn't support loading the tray then ask the user to insert the tray back into the drive and wait until the device is ready. If the drive supports loading the tray (auto inject), then send the START STOP UNIT command with the following values in the CDB, to inject the tray and wait until the device is ready.

    • Immediate = 0, LoadEject = 1, Start = 1, PowerConditions = 0

  16. [Optional] Send the START STOP UNIT command with data direction flag set to "to the device". Send random size buffer with random data and with the following values in the CDB.

    • Immediate = 0, LoadEject = 0, Start = 0, PowerConditions = 0

Result: The drive should respond to the START STOP UNIT command properly.

TEST UNIT READY command

Description: To validate if the drive supports the TEST UNIT READY command.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the TEST UNIT READY command.

  2. If the command fails print the sense key and fail the test case

  3. [Optional] Send the TEST UNIT READY command with data direction flag set to "to the device" and with random size buffer filled with random data.

Result: The drive should respond to the TEST UNIT READY command properly.

GET CONFIGURATION command

Description: To validate if the drive supports the GET CONFIGURATION command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command with response data length of 0 bytes (data sense unspecified). If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  2. Send the GET CONFIGURATION command with response data length of 4 bytes to get the feature header data length. If the command fails, print the sense key and fail the test case.

    • Purpose: allow software to probe support of command.

  3. Send the GET CONFIGURATION command with response data length of 8 bytes (to get the header), RT=00b, Starting Feature Number=0000h. If the command fails or if the Current Profile equals 00h, print the sense key as appropriate and fail the test case.

    • Purposes:

      • allow software to probe the required response buffer size.

      • allow software to probe current profile (a profile is current).

  4. If the command succeeds check the following in the response

    • Data length in the header is non zero and it is four byte aligned

    • Current profile number matches with media type loaded in the drive

  5. Send the GET CONFIGURATION command with response data length read at step 3, RT=00b, Starting Feature Number=0000h. Read the Current Profile, and then look for this profile code in the list of supported profiles. Ensure the current profile matches with the profile type of the inserted media. If the command fails or if the current profile is not reported current in the list of supported profiles, print the sense key as appropriate and fail the test case.

    • Purpose: Ensure consistency of the information reported by the drive.

  6. Send the GET CONFIGURATION command again with RT=00b and with the correct data length returned by the device in step3 if length fits 2 bytes. If length exceeds 2 bytes, send the command with maximum data length for 2 bytes.

    • Purpose: allow software to retrieve the entire list of features supported by the drive.

  7. If length exceeded 2 bytes, read the feature number for the last complete feature descriptor returned and issue additional GET CONFIGURATION command with RT=10b and with starting feature number equal to this feature number plus 1. Repeat operation until the data length returned in the feature header is equal or smaller to the allocated length. Concatenate the resulting feature descriptors for verification in step 10.

  8. For all commands succeeding at steps 3-6, check if the data length in the header of the response is multiple of 4 (4 byte aligned). Fail if it is not 4 byte aligned. Purpose: 4 bytes alignment is assumed by software.

  9. Additionally if the command(s) succeeded, check that each reported feature Version and Additional Length fields are equal or bigger than the respective values for the given feature in MMC-5 document. E.g.: Core Feature's version must be 0010b or higher and its additional length must be 8 or larger. Purpose: Ensure consistency of the information reported by the drive. If the removable medium feature is reported, the version number of it should be 1 as specified in GET CONFIGURATION command.

  10. Additionally if the command(s) succeeded, check that each mandatory feature for reported supported profile is reported.

    • Purpose: Ensure consistency of the meta-information reported by the drive.

  11. Send the GET CONFIGURATION command with response data length of 20 bytes, RT=01b, Starting Feature Number=0010h (Random Readable Feature). If the command fails or if the Random Readable Feature descriptor is not returned, print the sense key as appropriate and fail the test case. Purpose: allow software to probe specific feature currency (current).

  12. [Optional] Send the GET CONFIGURATION command with data direction flag set to "to the device" and with random size buffer filled with random data. The following values are set in the CDB:

    • Allocation Length = Size of the buffer, Starting Feature Number=0000h, RT=00b

Result: The drive should properly implement the GET CONFIGURATION command for the applicable media types.

GET PERFORMANCE command

Description: To validate if the drive supports the GET PERFORMANCE command for the reported profile.

Applicable Media: Any of the following media:

  • CD-R

  • CD-ROM

  • CD-RW

  • DVD+R

  • DVD+R Dual Layer

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • DVD-R

  • DVD-R Dual Layer Seq

  • DVD-ROM

  • BD-R

  • BD-RE

  • BD-ROM

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Write Speed Performance Descriptor bit is set. If this is not set then the drive doesn't support Write speed descriptors. Skip steps 6 to 11 which validate the write speed descriptors.

  2. Send the GET PERFORMANCE command with the following values in the CDB to get zero nominal read performance descriptors

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  3. If the command fails print the sense key and fail the test case

  4. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal read performance descriptor

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x10

  5. If the command fails print the sense key and fail the test case

  6. Send the GET PERFORMANCE command with the following values in the CDB to get one nominal write performance descriptor.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 1

    • Data Type = 0x14

  7. If the command fails print the sense key and fail the test case

  8. Send the GET PERFORMANCE command with the following values in the CDB to get data length for the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x14

  9. If the command fails print the sense key and fail the test case.

  10. Send the GET PERFORMANCE command with the following values in the CDB to get the list of write speed descriptors

    • Type = 3

    • Starting LBA = 1

    • Max Descriptors = 10

    • Data Type = 0x14

  11. If the command fails print the sense key and fail the test case.

  12. [Optional] Send the GET PERFORMANCE command with data direction flag set to "to the device" and with random size buffer filled with random data. Set with the following values in the CDB to get zero nominal read performance descriptors.

    • Type = 0

    • Starting LBA = 1

    • Max Descriptors = 0

    • Data Type = 0x10

  13. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the GET PERFORMANCE command for the applicable media types.

READ CAPACITY command

Description: To validate if the drive supports the READ CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the READ CAPACITY command.

  2. If the command fails print the sense key and fail the test case.

  3. If the Block length in bytes is not 2048 then fail the test case.

  4. [Optional] Send the READ CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data.

  5. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ CAPACITY command for the applicable media types.

READ BUFFER CAPACITY command

Description: To validate if the drive supports the READ BUFFER CAPACITY command for the reported profile.

Applicable Media: Any media supported by the device.

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Read Buffer Capacity Block (RBCB) bit is set. If this is not set then the drive doesn't support Read Buffer Capacity command. Skip the test case.

  2. Send the READ BUFFER CAPACITY command with block bit set to 0, and Allocation Length equal to the size of the Buffer Capacity Structure.

  3. If the command fails print the sense key and fail the test case.

  4. Repeat step 2 with Block bit set to 1.

  5. If the command fails print the sense key and fail the command.

  6. [Optional] Send the READ BUFFER CAPACITY command with data direction flag set to "to the device" and with random size buffer filled with random data and block bit set to zero.

  7. If the command fails print the sense key and fail the test case.

Result: The drive should properly implement the READ BUFFER CAPACITY command for the applicable media types.

READ DISC INFORMATION command

Description: To validate if the drive supports the READ DISC INFORMATION command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+R

  • DVD+RW

  • DVD-R

  • CD-R

  • CD-RW

Test Case Steps:

  1. Send the READ DISC INFORMATION command, with the allocation length of 2 to get the standard disc information size.

  2. If the command fails print the sense key and fail the test case.

  3. Get the disc information length from the response. If the length is less than the Standard Disc Information Block Size (34), then fail the test case.

  4. Send the READ DISC INFORMATION command, with the allocation length equal to the data length from step 3 plus 2.

  5. If the command fails print the sense key and fail the test case.

  6. [Optional] Send the READ DISC INFORMATION command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ DISC INFORMATION command for the applicable media types.

READ FORMAT CAPACITIES command

Description: To validate if the drive supports the READ FORMAT CAPACITIES command for the reported profile.

Applicable Media: Any of the following media:

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • DVD-RAM

  • CD-RW

Test Case Steps:

  1. Send the READ FORMAT CAPACITIES command with Allocation Length equal to 4 (Capacity List Header).

  2. If the command fails print the sense key and fail the test case.

  3. Get the Capacity List Length from the response

  4. Send the READ FORMAT CAPACITIES command with Allocation Length equal to Capacity List Length + 4 (size of the Capacity List Header).

  5. If the command fails print the sense key and fail the test case.

  6. Check the response if the capacity list length is multiple of 8.

  7. [Optional] Send the READ FORMAT CAPACITIES command with data direction flag set to "to the device" and with random size buffer filled with random data and Allocation length set to the size of the buffer.

Result: The drive should properly implement the READ FORMAT CAPACITIES command for the applicable media types.

READ TOC/PMA/ATIP command

Description: To validate if the drive supports the READ TOC/PMA/ATIP command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Send the READ TOC/PMA/ATIP command with the following values in the CDB.

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the READ TOC/PMA/ATIP command with data direction flag set to "to the device" and with buffer filled with random data and Allocation length set to the size of the buffer. Set the CDB with the following values:

    • Format = 0, MSF = 0, Track Session Number = 1, Allocation Length = 4

Result: The drive should properly implement the READ TOC/PMA/ATIP command for the applicable media types

SEND OPC INFORMATION command

Description: [This content isn't available yet.]

Applicable Media: Any of the following media:

  • DVD-RW Restricted Overwrite

  • DVD-R

  • CD-RW

  • CD-R

Test Case Steps:

  1. Send the SEND OPC INFORMATION command with DoOpc set to 1

  2. If the command fails print the sense key and fail the test case.

  3. [Optional] Send the SEND OPC INFORMATION command with DoOpc set to 1, data direction flag set to "to the device" and with random size buffer filled with random data. The Allocation length is set to the size of the buffer.

Result: The drive should properly implement the SEND OPC INFORMATION command for the applicable media types.

SET CD SPEED command

Description: To validate if the drive supports the SET CD SPEED command for the reported profile.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the GET CONFIGURATION command to the get the REAL TIME STREAMING feature. Check the response, if the Set CD Speed (SCS) bit is set. If this is not set then the drive doesn't support SET CD SPEED command. Skip the test case.

  2. Send the SET CD SPEED command, with the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000) If the command fails print the sense key and fail the test case

  3. [Optional] Send SET CD SPEED command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • RotationalControl = 0, ReadSpeed = 0xFFFF, WriteSpeed = (((4* 75 * 2352) + 500) / 1000)

Result: The drive should properly implement the SET CD SPEED command for the applicable media types.

READ10 command

Description: To validate if the drive supports the READ10 command for the reported profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

Test Case Steps:

  1. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes)

  2. Send READ TOC/PMA/ATIP command with Allocation Length equal the size of the READ TOC response header ( 4 bytes) + the Data Length from the Response Header from step 1.

  3. Check all the formatted Read TOC descriptors, if any of its control is set to 0x04

  4. If not found then fail the test case

  5. Otherwise get the track starting address from the formatted Toc track descriptor.

  6. Send the Read Capacity command with LBA field set to zero, to get the Block size.

  7. Send the Read Command with the Transfer Length set to zero and Starting LBA set to the LBA from step 5.

  8. Calculate the number of blocks to read

  9. If the LBA in the Read capacity response is less than the LBA from the step 5 then the number of blocks to read is set to 0

  10. If the LBA in the Read capacity response is greater than the LBA from the step 5 then set the number of blocks to read equal to difference between the LBA from the read capacity response and the LBA from step 5. If that value is greater than 50, set the number of blocks to read to 50.

  11. Set the Starting LBA in the read 10 CDB to the LBA from step 5

  12. Send the read10 command with transfer length set to 1

  13. Sleep for 10 milliseconds

  14. Increment the starting LBA in the read 10 CDB

  15. Repeat steps 12 to 14 until we read all the number of blocks.

  16. [Optional] Send the READ10 command with data direction flag set to "to the device" and with random size buffer filled with random data. Set the following values in the CDB.

    • TransferLength = 1, Starting LBA = Random LBA value in the LBA range of Number of LBAs from step 8 with starting LBA from the step 5

Result: The drive should properly implement the READ10 command for the applicable media types.

Event notification

Description: To validate if the device event notification are properly reported to the windows PNP.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. If BusType field of the drive's STORAGE_ADAPTER_DESCRIPTOR structure is set to BusTypeSata then send IOCTL_ATA_PASS_THROUGH with request for Identify Packet Device Information data. In the response check that bit 5 of word 78 (Asynchronous Notification feature is supported) and bit 5 of word 79 (Asynchronous Notification feature is enabled) are both set. Otherwise fail the test

  2. Register for Operational Change event.

  3. Check if the media is present.

  4. If the media is present, eject media.

  5. Wait for the MEDIA REMOVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

  6. Inject the media to the drive.

  7. Wait for the MEDIA ARRIVAL event. If the event is not generated within 60 seconds timeout then fail the test case.

Result: The drive should properly implement the event notifications.

Write tests

Description: Validates the write capabilities of the drive for the data content in the context of IMAPI. The device is tested with various write speeds reported by the drive. The test also validates the multisession capabilities of the device is applicable for the inserted media

Applicable Media: Any of the following media (depends on the drive operation):

  • Sequential writing:

    • CD-R

    • CD-RW

    • DVD+R

    • DVD-R

    • DVD-RAM

    • BD-R

    • BD-RE

  • Restricted overwrite:

    • DVD-RW

  • Packet mode:

    • DVD+RW

  • Multisession:

    • CD-R

    • CD-RW

    • DVD-R

    • DVD+R

    • BD-R

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  3. If the media is not blank and if it is one of the following rewriteable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  4. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data::get_SupportedWriteSpeedDescriptors.

  7. Randomize the order of the reported write speeds

  8. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 6.

  9. Create a random data size with the range of 10% of the available space on the media. Fill the buffer with random data.

  10. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  11. Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

  12. Write the data buffer from step 8 using IDiscFormat2Data::Write.

  13. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

  14. If the media is not DVD-RW, DVD+RW, DVD-RAM, BD-RE then:

    • Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

    • Check if the number of free sectors is less than the value from step 9 by the size of write data in step 8.

    • Get the next writable address using the API IDiscFormat2Data::get_NextWritableAddress.

    • Check next writable address is greater than the next writable address from step 10 by the size of the write data in step 8.

    • Read data from the disc and compare if it matches with the data written to the media in step 11.

  15. Get the last Track Information

  16. If the media is not DVD-RW then check if the Logical Track Size if greater than or equal to size of the data we wrote.

  17. Check if the Logical track number is correct.

  18. Get the Write parameters mode page.

  19. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  20. Read disc information and check if the number of session matches.

  21. If the media is not DVD-RW, DVD+RW and DVD-RAM then repeat steps 7 to 19 for each write speed. If the drive returned only one write speed then repeat steps 7 to 19 one more time to add one more session to the disc for validating the multisession capabilities.

Result: The drive should be capable of burning the data in the context of IMAPI.

AUDIO MEDIA (WRITE AUDIO TRACKS)

Description: Validate the write capabilities of the drive for the audio content in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. If the media is not blank and if it is CD-RW media type, then erase the media by sending the blank command with a minimal blank option.

  2. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  3. Lock the Media for Exclusive Access by calling DiscFormat2TrackAtOnce::PrepareMedia.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2TrackAtOnce::get_SupportedWriteSpeeds.

  5. Choose random number of audio tracks between 3 and 10.

  6. Randomize the order of the reported write speeds.

  7. Set the Write Speed by calling the API IDiscFormat2TrackAtOnce::SetWriteSpeed from step 1.

  8. Get the number of free blocks on the disc using the API IDiscFormat2Data::get_FreeSectorsOnMedia.

  9. Create audio data of random size from 1 minute audio data to 10 minute audio data. The size of the data should be a multiple of 2352.

  10. Add the audio data stream to the IDiscFormat2TrackAtOnce::AddAudioTrack.

  11. Get the last track Information

  12. Check if the Logical track size if greater than or equal to size of the audio track we wrote.

  13. Check if the Logical track number is correct

  14. Get the number of free sectors on the media by calling IDiscFormat2TrackAtOnce::FreeSectorsOnMedia.

  15. Check if the number of free sectors from step 14 is less than value from step 8 by the size of the audio track written to the media.

  16. Repeat steps 5 to 15 for the number audio tracks from step 5

  17. Get the Write parameters mode page

  18. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet

  19. Repeat steps 1 to 18 for each Write Speed.

  20. If the drive supports Auto eject-inject mechanism then eject and inject the media into the tray.

Result: The drive should be capable of burning the audio media in the context of IMAPI.

Blank

Description: Validates the format/blank capabilities of the drive in the context of IMAPI.

Applicable Media: Any of the following media:

  • CD-RW

  • DVD+RW

  • DVD-RW Restricted Overwrite

  • BD-RE

Test Case Steps:

  1. Check if the media is one of the following read write media type by calling the API IDiscFormat2Data::CurrentPhysicalMediaType

    • CD-RW

    • DVD-RW

    • DVD+RW

  2. If the media is not one of the read write media type then skip the test case.

  3. Check if the media is a blank media by calling the API IDiscFormat2Erase::MediaPhysicallyBlank.

  4. If the media is note blank, go to step 7.

  5. Create 25MB random data stream.

  6. Write the data stream to the disc using the API IDiscFormat2Data::Write.

  7. Check if the drive reports the media as non-blank media by calling the IDiscFormat2Data::get_CurrentMediaStatus API.

  8. If the drive still reports media as blank then fail the test case

  9. Implement Erase Event Handler DDiscFormat2EraseEvents::Update.

  10. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to false, so that it will do a minimal blank.

  11. Send the blank command using the IDiscFormat2Erase::EraseMedia API.

  12. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  13. Read disc information and check if the

    • Number of sessions reported is 1.

    • The first track in the last session is 1.

    • The last track in the last session is 1.

  14. Call the API IDiscFormat2Erase::put_FullErase and set the erase option to full blank. Repeat steps 9 to 14.

Result: The drive should be capable of formatting the media in the context of IMAPI.

Write Dual-layer media

Description: Validates the write capabilities of the for the dual layer media in the context of IMAPI. The device is tested with various write speeds reported by the drive.

Applicable Media: Any of the following media:

  • DVD+R DL

  • DVD-R DL

Test Case Steps:

  1. Ask the user to insert blank media.

  2. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank

  3. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Randomize the order of the reported write speeds

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with one of the write speeds from step 5.

  7. Create a random data stream of random size up to 50% of the available space on the media. Fill the buffer with random data

  8. Write the data buffer from step 7 using IDiscFormat2Data :: Write.

  9. If the drive supports auto eject-inject mechanism then eject and inject the media into the tray.

  10. Read data from the disc and compare if it matches with the data written to the media in step 9.

  11. Get the last Track Information.

  12. Check if the Logical Track Size if greater than or equal to size of the data we wrote.

  13. Check if the Logical track number is correct

  14. Get the Write parameters mode page.

  15. Check if the Track information reported by the drive is not Packet/Incremental if the Write parameters mode page reports as Fixed packet.

  16. Read disc information and check if the number of session matches.

  17. Repeat steps 8 to 16 with random data stream of random size up to 100% of the available space on the media.

    WARNING

    These last steps are to test if the drive is able to write the data on the dual layer properly.

Result: The drive should be capable of burning the data to both layers of the Dual Layer media in the context of IMAPI.

Read-only drive

Description: Test the read capability of a read only drive on a open (append able) and closed (finalized) disc.

WARNING

This test case requires a secondary writer drive for creating the test data disc for the corresponding test profile.

Applicable Media: Any of the following media:

  • CD-ROM

  • DVD-ROM

  • BD-ROM

Test Case Steps:

  1. Eject the writer drive tray.

  2. If the test profile is

    • CD-ROM ask the user to insert CD-R/CD-RW in the writer drive.

    • DVD-ROM ask the user to insert DVD+R/DVD-R/DVD+RW/DVD-RAM in the writer drive.

    • BD-ROM ask the user to insert BD-R/ BD-RE in the writer drive.

  3. Inject the writer drive tray.

  4. Get the list of Write Speed Descriptors by calling the API IDiscFormat2Data :: get_SupportedWriteSpeedDescriptors.

  5. Create a random data stream of random size up to 10% of the available space on the media. Fill the buffer with random data.

  6. Set the Write Speed by calling the API IDiscFormat2Data::SetWriteSpeed with the first write speed descriptor value from step 4.

  7. Write the data buffer from step 5 using IDiscFormat2Data::Write to the media in the writer drive.

  8. Eject the writer drive tray if it supports auto eject mechanism. Otherwise ask the user to press the eject button

  9. Eject the test drive tray if it supports auto eject mechanism eject the tray otherwise ask the user to press the eject button.

  10. Ask the use to remove the media from the writer drive and place it in the test drive.

  11. Inject the writer drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  12. Inject the test drive tray if it supports auto inject (loading the tray) mechanism. Otherwise ask the user to insert the tray into the drive.

  13. Read data from the test drive disc and compare if it matches with the data written to the media in step 7.

  14. Set the IDiscFormat2Data::ForceMediaToBeClosed to true and Repeat steps 1 to 13 to validate the test drive on a finalized disc.

Result: The drive should be capable of reading both the closed and open media.

Drive serial number

Description: Validates that the drive serial number returned by the test drive is in compliance with the MMC/Mt. Fuji specification standards.

WARNING

This test case requires two identical drives to validate if both drives return unique serial numbers. One primary test device and the other one is a secondary test drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Send the INQUIRY command to the primary test device with the allocation length equal 05h.

  2. If the command succeeds, get the additional length value from the response header.

  3. Send the INQUIRY command again to the primary device with allocation length set to 5 bytes more than the additional length from step 2.

  4. If the command succeeds get the Vendor Identification, Product Identification and Product Revision Level.

  5. Repeat the step 1 to 4 for the secondary drive and get the Vendor Identification, Product Identification and Product Revision Level.

  6. Compare the Vendor Identification, Product Identification and Product Revision Level values from step 4 and step 5. If they do not match then fail the test case.

    WARNING

    This is to make sure both the test drives are identical

  7. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor.

  8. Check the response if the feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code. Get the additional length.

  9. Send the GET CONFIGURATION command to the primary test drive to get the LOGICAL UNIT SERIAL NUMBER feature with allocation length equal to the size of the LOGICAL UNIT SERIAL NUMBER feature descriptor plus the required additional length reported in step 8.

  10. Check the following in the response:

    • The feature code matches with the LOGICAL UNIT SERIAL NUMBER feature code.

    • The reported serial number data is in ASCII.

    • Data is padded.

    • No data after padding.

  11. Repeat 7 to 9 for the secondary test device and get the drive serial number.

  12. Compare the drive serial numbers from step 10 and step 11. The drives are expected to return unique serial numbers. If both the serial numbers are equal then fail the test case.

Result: The drive should return a unique serial number and that number should be in compliance with the MMC/Mt. Fuji standards.

Real-time streaming

Description: Validates that the real-time streaming capabilities of the drive for the data content in the context of cdrom.sys driver. The device is tested with various read and write speeds reported by the drive.

Applicable Media: Any media supported by the device

Test Case Steps:

  1. Ask the user to insert media.

  2. If media is not writable or rewritable proceed to reading test at step 13.

  3. Call the API IDiscFormat2Data::get_CurrentMediaStatus to check if the media is blank.

  4. If the media is not blank and if it is one of the following rewritable media type, then erase the media by sending the blank command with a minimal blank option.

    • CD-RW

    • DVD-RW Sequential Recording

    • DVD-RW Restricted Overwrite

    • DVD+RW

    • DVD-RAM

    • BD-RE

  5. If the media is not a rewritable media then ask the user to insert the blank media. Retry this for 3 times, otherwise fail the test case.

  6. Send GET CONFIGURATION command with request for REAL TIME STREAMING feature. If it is not successful or Current bit is not set fail the test.

  7. If either Stream Writing (SW) bit or Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is not set then fail the test.

  8. Send GET PERFORMANCE command with request for Write Speed Descriptors and build and array of supported write speeds. If the command is not successful fail the test.

  9. Shuffle the write speed array.

  10. IF free media size is over 10% of its full capacity call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next write speed. Write random data up to 10% of full capacity and measure the speed (refer to the corresponding section in this document for measuring procedure description).

  11. Repeat step 10 as long as possible. If all write speeds are probed shuffle the speed array and set next write speed to the beginning.

  12. Send CLOSE TRACK SESSION commands to finalize the media

  13. If Write Speed Performance Descriptor (WSPD) bit of REAL TIME STREAMING feature response is set then send GET PERFORMANCE command with request for Write Speed Descriptors and build an array of supported read speeds otherwise send GET PERFORMANCE command with request for Performance data with Tolerance bits set to 10b (nominal) and for the read speeds select the lowest value of Start Performance and End Performance fields in the response. If either of the commands I not successful fail the test.

  14. Shuffle the read speed array.

  15. Set the read length to size of the first track on media.

  16. For each read speed call DeviceIoControl with IOCTL_CDROM_SET_SPEED and CDROM_SET_STREAMING structure supplied for the next read speed. Read the whole data recorded on media in chunks of 10% of media capacity (or at least 5 MB if media has less than 50 MB of data) and measure the speed of each chunk. If the actual speed of any chunk is below the requested speed for any of the chunks mark the test failed.

Result: The drive should be capable of operating in real-time streaming mode.

Write speed Measurement

The test queries the device and gets the supported write speeds for the test media. Then it will try to validate the write scenario for all the reported write speeds. The test expects the calculated write speeds for each write scenario is close to the write speed set to the drive. The test allows 10% tolerance for the measured write speed. The test validates the write speed as below.

The test writes data to the media and monitors the amount of data being written. It excludes the timing for the initial 10% written data the final 10% written data. It measures the timing only for the middle 80% data and calculates the speed for that data and adds 10% tolerance to that value. So, if 'x' is the calculated the speed for the middle 80% data then the final calculated speed is 1.1x. The test expects this value to be greater than or equal to the speed set to the drive before beginning the write.

The test excludes the initial 10% of data written timing to allow the drive to prepare for writing. The final 10% data timing is excluded to allow the drive to do the proper cleanup for the data written to the media.

Audio media gapless raw recordings

Description: Validates the write capabilities of the drive for the gapless raw audio content in the context of IMAPI

Applicable Media: Any of the following media:

  • CD-R

  • CD-RW

Test Case Steps:

  1. Check if the drive with media inserted supports gapless raw recording or not. If it's not supported, testing will fail.

  2. Check the sector types supported by test drive.

  3. For each sector type supported by test drive, complete steps 4 through 9

  4. Create the raw image.

  5. Set correct sector type and create the result stream for the raw image.

  6. Determine whether the raw image is gapless or not.

  7. Randomly choose a write speed and set it to be the burning speed. Set the requested sector type to be the one that has been set for the raw image. Write the stream of the raw image to the media and watch the progress. Calculate the speed of burning and print the throughput.

  8. Determine whether the writing is successful by checking each logical track information. Check if the track is audio track, if the track size is correct, and if the size of the last logical track number plus its start address is equal to the start address of the lead out of the disc. If any of the conditions returns false, testing will fail. Otherwise, it will pass.

  9. Do a raw reading for the media. For each track, check if the track is audio. If it's not, fail the testing, because the recording already ensured that the tracks are audio tracks. Calculate the start offset and end offset of the track. Do the reading for the track starting from the start offset and ending at the end offset of the track. If an error occurs during the reading process, fail the testing;

Result: The drive should be able to burn the gapless raw audio image in the context of IMAPI.

Command usage

Command | Description
OpticalLogoTest.exe /drive [StorageDriveLetter]:\ /log [log] [AdditionalParams] /profile [profile] /RunTestCaseTypes [RunTestCaseTypes] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Command syntax

Command option | Description
drive | Test optical device drive letter. Example: /drive e:\
adapter | path (used for adapter test). Example: /adapter &quot;PCI\VEN_8086&DEV_27DF&SUBSYS_01AD1028&REV_01\3&172E68DD&0&F9&quot;
PrimaryTestDrive | Test optical device drive letter. Example: /PrimaryTestDrive e:\
SecondaryTestDrive | Secondary optical test device drive letter. Example: /Secondary Test Drive f:\
WriterDrive | Drive letter of the Writer that needs to be used for testing read-only drives. Example: /WriterDrive f:\
PrimaryDriveTray | Primary optical device tray capabilities. Example: /PrimaryDriveTray SupportsEjectInject
SecondaryDriveTray | Secondary optical device tray capabilities. Example: /SecondaryDriveTray SupportsEjectInject
WriterDriveTray | Writer drive tray capabilities. Example: /WriterDriveTray SupportsEjectInject
profile | Run test cases specified profiles. Profile ID should be in decimal and comma separated without spaces. Example: /profile 9,10,16
seed | Seed value for generating random test data. Example: /seed 1000
RunTestCaseTypes | Runs only the category of test cases. Example: /RunTestCaseTypes device
RunTestCase | Runs only this test case. Example: /RunTestCase Inquiry
Automation | Run in automation mode using the robot to change the media. Example: /Automation
AutomationConfigFile | The configuration file used to specify bin location for media. Example: /AutomationConfigFile OpticalLogoTest.exe.config
Calibrate | Calibrate the robot used to change the media. Example: /Calibrate
logo | The level of certification requirements to test. Example: /logo basic or /logo premium
ReuseMedia | Reuse the non-blank media for testing. The test will not expect the media to be blank if the multisession is supported for that media. This option is for testing only. Not allowed for certification. Example: /ReuseMedia
SkipFullBlank | Skip the full blank scenario and test only minimal blank. Example: /SkipFullBlank
SkipManualTestCases | Skip test cases that needs manual interaction. Example: /SkipManualTestCases
RunDataDirectionFlagScenario | Validate the commands with an incorrect data direction flag. Example: /RunDataDirectionFlagScenario
Debugger | Prompts to attach debugger which gives time to allow the debugger to be attached before further executing the program. Example: /Debugger
Verbosity | Logging verbosity. Example: /Verbosity Verbose
log | Log file name Default value: OpticalLogoTest.wtl Example: /log mytestlog.wtl
EnableImapiv2Trace | Enable IMAPIv2 software trace. Example: /EnableImapiv2Trace
Imapiv2TraceGuidsFile | IMAPIv2 trace GUIDs file that has the entire list of component GUIDs for which the traces need to be logged Default value: imapiv2-guids.txt Example: /IMAPIv2TraceGuidsFile imapiv2-guids.txt
Imapiv2TraceLogFile | IMAPIv2 output trace log file. Default value: imapiv2-tracelog.etl Example: /IMAPIv2TraceLogFile imapiv2-tracelog.etl
cmdPerfTraceAnalysis | Run command performance analysis. Example: /cmdPerfTraceAnalysis Always
cmdPerfTraceGuidsFile | Performance trace GUIDs file that has the GUIDs of components that trace performance data Default value: perf-guids.txt Example: /cmdPerfTraceGuidsFile perf-guids.txt
cmdPerfTraceLogFile | Performance output trace log file Default value: perf-tracelog.etl Example: /cmdPerfTraceLogFile perf-tracelog.etl
cmdPerfTraceTmfFile | Performance trace format description file. Example: /cmdPerfTraceTmfFile perf-tracelog.tmf

File list

File | Location
ataportlogotrace.tmf | <[testbinroot]>\nttest\driverstest\storage\optical\setup\tracing</p>
autoloader.dll | <[testbinroot]>\nttest\driverstest\storage\optical\autoloader</p>
DataPacket.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DeviceTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
DiscManagerLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
microsoft.storage.imapi.dll | <[testbinroot]>\nttest\driverstest\storage\interop\imapi</p>
ModularTestCase.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalLogoTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestHarness.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
OpticalTestLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ProfileTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScenarioTestCases.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
ScsiLib.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
storageinteroputil.dll | <[testbinroot]>\nttest\driverstest\storage\interop\utils</p>
tracefmt.exe | <[osbinroot]>\idw</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
TraceLib.dll | <[osbinroot]>\nttest\driverstest\storage\wdk\optical\test</p>
tracelog.exe | <[osbinroot]>\idw</p>

Parameters

Parameter name | Parameter description
StorageDriveLetter | Test device drive letter
profile |
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test
log |
RunTestCaseTypes |
AdditionalParams |


PrivateCloudSimulator - Device.Storage.Controller.AzureStack

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4bb7c51-51f8-457c-8fa0-04df00b20de7

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodeBusResetAction StorageNodePortDisableAllAction StorageNodePortDisableSingleAction StorageRetireAndRepairAction StorageNodeRestartAction StorageNodeBugCheckAction ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath You will need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • Device.Storage.Controller.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |
IsCreateCluster | Enter $True to create a new cluster before running PCS
IsRemoveCluster | Enter $True to remove cluster after running PCS
IsConfigureHyperV | Enter $True to validate Hyper-V feature is installed, and create a virtual switch on all 10Gbps or faster NICs. This parameter is ignored when IsCreateCluster is $false


PrivateCloudSimulator - Device.Storage.Enclosure.AzureStack

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/545e67e8-bef0-4041-a897-88c32c1e9e80

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodeBusResetAction StorageRetireAndRepairAction StorageNodeRestartAction StorageNodeBugCheckAction ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • Device.Storage.Enclosure.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |
IsCreateCluster | Enter $True to create a new cluster before running PCS
IsRemoveCluster | Enter $True to remove cluster after running PCS
IsConfigureHyperV | Enter $True to validate Hyper-V feature is installed, and create a virtual switch on all 10Gbps or faster NICs. This parameter is ignored when IsCreateCluster is $false


PrivateCloudSimulator - Device.Storage.HD.AzureStack

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b88a5ee6-81f3-4491-b2c8-f40107dab0c5

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodePoolMove StorageNodeRestart StorageNodeBugcheck StorageNodeDiskFaultInjectionAction StorageNodeDiskReadTimeoutAction StorageNodeDiskWriteTimeoutAction StorageNodeDiskFlushFailureAction StorageNodeDiskTrimFailureAction StorageNodeBusResetAction StorageNodePortDisableAllAction StorageNodePortDisableSingleAction StorageNodeDiskReadDelayAction StorageNodeDiskReadMediumErrorAction StorageRetireAndRepairAction StorageNodeDiskFirmwareUpdateAction DisableNetworkAdapters ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • Device.Storage.HD.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |
IsCreateCluster | Enter $True to create a new cluster before running PCS
IsRemoveCluster | Enter $True to remove cluster after running PCS
IsConfigureHyperV | Enter $True to validate Hyper-V feature is installed, and create a virtual switch on all 10Gbps or faster NICs. This parameter is ignored when IsCreateCluster is $false
CreateOnePoolPerDiskModel | Enter $True to create multiple disk pool each with one type of disk model.
MaxVirtualDiskSize | Virtual Disk size in GB


Rotational Rate Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f629dae0-2e7c-4b36-a88d-a38d8f09a2dc

This test checks whether the selected hard drive reports its rotational rate value. All SATA, SAS, and NVMe drives should report rotational rate.

Test details
Specifications
  • Device.Storage.Hd.RotationalRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the test fails, you can check the log file by doing the following:

To check the log file

  1. In the Job Execution Status window of HLK Manager, click the failed job.

  2. In the Task Execution Status window, right-click Run test, and then click View Task Log.

  3. Open nrmtest.log.

If rotational rate is not reported by the disk, you can try one of the following:

  • If the disk is a SATA disk, ensure that the IDENTIFY DEVICE data word 217 is implemented correctly.

  • If the disk is a SAS or NVMe disk, ensure that the INQUIRY VPD 0xB1 page's MEDIUM ROTATION RATE field (byte 4 and 5) is implemented correctly.

  • If the disk has a bus type other than SATA, SAS, or NVMe, ensure that the bus type is reported correctly.

More information

The test shows up for all hard drives. It checks whether the rotational rate is reported correctly for SATA, SAS, and NVMe drives, and skips rotational rate checking for all other bus types. The following table summarizes the test metric.

SATA drives | IDENTIFY DEVICE data word 217.
SAS, NVMe drives | INQUIRY VPD 0xB1 page's MEDIUM ROTATION RATE field (byte 4 and 5).

Command syntax

Command | Description
nonrotatingmedia.exe -d [DiskDeviceObjLink] | Runs the test.

File list

File | Location
nonrotatingmedia.exe | <[TestBinRoot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test
DiskDeviceObjLink | Assigned by Create Storage Parameters
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


SAS SSD SCSI Compliance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9d74d3be-a6df-44d4-82b3-af4366cadd44

This test verifies INQUIRY, READ CAPACITY (16), and UNMAP (10) Small Computer System Interface (SCSI) commands sent to a Serial Attached SCSI (SAS) Solid State Drive (SSD).

Test details
Specifications
  • Device.Storage.Hd.Sas.ComplyWithIndustrySpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The test writes the results to the log files Scsicompliance.wtl and Scsicompliance.wtl.txt. You can use the results to determine:

  • If a device is compliant with the SCSI specification

  • The optional SCSI commands that are supported by a device

To pass, the SCSI device must support every mandatory command and must be fully compliant with those commands. Each command has a different threshold for pass or fail, and the expectations are specified explicitly in the test and in the log file.

Optional commands are also tested. If a device supports the optional commands and the commands are found to be non-compliant, the test fails. If the device does not support optional commands, the test passes.

More information

The test SCSI commands are as follows:

INQUIRY

For page code B0h:

  • Support INQUIRY B0h VPD page

  • PAGE LENGTH = 0x3C

  • MAXIMUM UNMAP LBA COUNT > 0

  • MAXIMUM UNMAP BLOCK DESCRIPTOR

  • COUNT > 0

For page code B1h:

  • Support INQUIRY B1h VPD page

  • PAGE LENGTH = 0x3C

  • MEDIUM ROTATION RATE = 1

For page code B2h:

  • Support INQUIRY B2h VPD page

  • If DP = 1, then PAGE LENGTH = 0x4

  • LBPU = 1

  • PROVISIONING TYPE = 0 or 1

READ CAPACITY (16)

  • Support READ CAPACITY (16)

  • LBPME = LBPME (VPD B2h page)

  • LBPRZ = LBPRZ (VPD B2h page)

UNMAP (10)

  • Support UNMAP (10)

Command syntax

Command | Description
Scsicompliance.exe /device [ScsiComplianceDevice] /verbosity [LoggingVerbosity] /scenario SasSsd /operation test | Runs the test.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
ScsiComplianceDevice | Device path
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | operation option


SAS SSD Trim Performance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b880199-1fbf-4aac-b6ef-f3d24a135c84

This test evaluates the performance of the Trim command for Serial Attached SCSI (SAS) Solid State Drive (SSD).

Test details
Specifications
  • Device.Storage.Hd.Sas.ComplyWithIndustrySpec
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Compatibility
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The test requires a SAS SSD device connected to a SAS controller. The drive must also satisfies the following requirements:

  • The drive should be a non-boot drive. The test is destructive. It will prepare the disk with correct partition and formatting for the testing.

  • The drive must support Trim command. The IDENTIFY DEVICE data word 169 bit 0 must set to one (see ACS-2 section 7.18.7.71). The test will send down Trim commands using DATA SET MANAGEMENT command.

  • Ensure that there is a separate drive available to be used as a logger drive. The test will automatically pick the logging drive. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this is a performance test, outside activity may affect the results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If you want to check the WTT trace, do the following:

  • View Child Job Results of Run Trim Performance Test.

  • View Job Logs of Run Trim Performance Test - Library.

  • Open the log file TrimPerf.wtl.

  • Check for messages that may solve the issue.

  • Copy the .wtl log file. This is the WTT trace described in the WTT Trace section.

If no metrics are found, try the following:

  • Enable Storport ETW tracing

  • Ensure that no other Storport ETW traces are currently logging. Only one Storport ETW trace can be active at a time.

If you get the error message "The test drive does not support trim.", try the following:

  • Ensure that the SAS SSD IDENTIFY DEVICE data word 169 bit 0 is set to one.

  • Try to send a Trim command via DATA SET MANAGEMENT.

  • Run the test again.

If the test failed because the read and write maximum latency exceeded 500 milliseconds, try the following:

  • Check the IO latency without Trim. Try to lower the latency below 500 milliseconds.

  • Check the IO latency with presence of Trim. Try to lower the latency below 500 milliseconds.

If you want to debug the failure by running particular test cases, you may try the following command line options:

  • Display all the test cases with numbers: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType SasSsd /PrintTestCaseName

  • Run particular test case by test case number: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType SasSsd /Precondition F /TestCase [TestCaseNumber]

If you want to debug the failure by running particular pure Trim scenario, you may try the following command line options:

  • The binary has unit test options: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType SasSsd /Precondition F /UnitTest T /RangeCount [NumberOfRangesPerTrim] /SizeCount [SizeOfEachRange] /SizeUnit [Slab | Sector] /TrimCount [NumberOfTrims]

  • /RangeCount: The number of ranges per Trim command

  • /SizeCount: The size of each range in /SizeUnit

  • /SizeUnit: The granularity of /SizeCount, it can be either slab (OPTIMAL UNMAP GRANULARITY) or sector

  • /TrimCount: The number of Trims sent in the test case.

If you want to debug the failure faster, try disable the preconditioning (fill up the drive to 90% full, takes long time) by adding /Precondition F parameter as follows:

  • TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType SasSsd /Scenario Performance /DiskSize 0 /Cooldown 2 /Precondition F

More information

The test commands are as follows:

Trim command

  • All trim commands should be completed in less than 500 milliseconds.

IO command (with Trim sending at same time)

  • All read and write commands complete in less than 500 milliseconds.

  • 98.5% of I/O commands complete in less than 100 milliseconds.

Command syntax

Command | Description
TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType [DeviceType] /Scenario [Scenario] /DiskSize [DiskSize] /Cooldown [Cooldown] | Runs the test.

File list

File | Location
trimperf.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
Etwprocessor.dll | <[taefbinroot]></p>
Wex.common.dll | <[taefbinroot]></p>
Wex.communication.dll | <[taefbinroot]></p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
Destructive | (0,1) 0=Passive, 1=Destructive
StorageDriveNumber | Storage drive number


SCSI Compliance Fuzz Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f42dc87-2019-4423-bacb-2ed09da96685

This automated verifies that Fibre Channel or Fibre Channel over Ethernet controllers work properly after a fuzz test.

Test details
Specifications
  • Device.Storage.Controller.Fc.Interface
  • Device.Storage.Controller.Fcoe.Interface
  • Device.Storage.Controller.Fcoe.Interoperability
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Compatibility
Timeout (in minutes) | 18000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Fibre Channel Adapter Testing Prerequisites or Fibre Channel Over Ethernet Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Before you run this test, if the test environment is an HBA Boot environment, make sure at least one non-boot LUN is connected to the HBA.

More information

The test sends the fuzzed commands to the device. The commands covered by test are the same as the SCSI Compliance Test 2.0 (LOGO).

Command syntax

Command | Description
fuzztest.exe /device "[DiskDeviceObjLink]" /scenario fuzz /operation test /seed 123456 /feature common | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Fuzztest.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>
strgenrt.dll | <[osbinroot]>\SecuTest\SecuTest</p>
SecuScript.dll | <[osbinroot]>\SecuTest\SecuTest</p>
FieldObjects.dll | <[osbinroot]>\SecuTest\SecuTest</p>
CoreLib.dll | <[osbinroot]>\SecuTest\SecuTest</p>

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
WDKDeviceID | Instance path of device to test
DiskDeviceObjLink | Assigned by Create Storage Parameters.
Destructive | (0,1) 0=Passive, 1=Destructive


SCSI Compliance Test 2.0 (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1f2fbbe-d5e4-439d-819a-dc100df0e9ba

This automated test verifies that a block storage device (RAID adapter or disk target) that is supported by the operating system fully complies with the Small Computer System Interface (SCSI) standards described in the SCSI-3 Primary Commands-3 (SPC-3) or later, and SCSI Block Commands-2 (SBC-2) or later specifications. To see these specifications, go to Technical Committee T10 SCSI Storage Interfaces.

Ensuring that the block device and the operating system maintain compliance with these standards results in a more robust and reliable system. Although some block devices might not be using a SCSI transport, the operating system communicates with them using SCSI commands (except for individual ATA disk drives that are not part of a RAID set).

The test uses SCSI pass-through requests (IOCTL_SCSI_PASS_THROUGH) to construct and send SCSI command descriptor blocks (CDBs) to the device. The test evaluates the results of the commands to verify compliance.

NOTE

If you are running this test as a part of a Storage RAID Hardware-based RAID (Storage Array) submission, and your storage array supports Multipath I/O (MPIO), you must configure your MPIO to use Fail-Over Only policy, and set the target storage disk to use the same active path for all MPIO-capable disks.

If you are running this test as a part of a Storage RAID Hardware-based RAID (Storage Array) submission, make sure that LUN0 is configured as the largest size non-boot LUN.

Test details
Specifications
  • Device.Storage.Hd.ScsiProtocol.SpcCompliance
  • Device.Storage.Controller.Raid.BasicFunction
  • Device.Storage.Hd.ScsiProtocol.ReferenceSpec
  • Device.Storage.Hd.ScsiProtocol.SamCompliance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements for the type of storage controller that you are testing. See Hard Disk Drive Testing Prerequisites for more information.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For general troubleshooting information, see Troubleshooting Device.Storage Testing.

Also, the test writes the results to the log files Scsicompliance.wtl and Scsicompliance.wtl.txt. You can use the results to determine:

  • If a device is compliant with the SCSI specification

  • The optional SCSI commands that are supported by a device

To pass, the SCSI device must support every mandatory command and must be fully compliant with those commands. Each command has a different threshold for pass or fail, and the expectations are specified explicitly in the test and in the log file.

Optional commands are also tested. If a device supports the optional commands and the commands are found to be non-compliant, the test fails. If the device does not support optional commands, the test passes.

NOTE

Errors from this test occur via issues identified in the log file and in stop errors produced through stressing the driver under test.

During the test, if you are having trouble removing a LUN that is failing or are unable to create a LUN from the storage controller, follow these steps:

  1. Prior to running this test, verify that the storage device works properly. Open diskmgmt.msc, select the disk, and make sure that you can put the device Online and Initialized.

  2. Restart the Windows HLK test computer.

  3. Select and rerun the SCSI Compliance Test 2.0. Do not run any test before it.

  4. Run the SCSI Compliance Test (not the SCSI Compliance Test 2.0 (LOGO)) on the same test client and same test storage device. If the test fails again, verify that the storage device is working properly. If the test fails during steps 3 and 4, run the individual failing command data blocks (cdbs) one at a time with the logging verbosity level set to 4 (the highest level of test logging). This will show what data was sent and what data was returned. A test can fail after several cdbs are completed but pass standalone. If this occurs, there is a problem in the firmware or the test.

If you have a device reset that results in the device falling off the bus and subsequent commands to fail, follow these steps:

  1. Copy the test binary (Scsicompliance.exe) from the Windows HLK controller. This file is located at \\controllername\tests\[processorarchitectureofyourclient]\NTTEST\DriversTest\storage\wdk\

  2. Copy the wttlog.dll file from the Windows HLK controller. This file is located at \\<controllername>\Tests\<processorarchitectureofyourclient >\wtt

  3. Place both of these files on the test computer in a separate folder.

  4. From a command prompt, from the directory containing the test binary, type the following command: Scsicompliance.exe /device <deviceID> /verbosity 4 /operation test /scenario <scenario> /CDB <failingcdbname>

    NOTE

    DeviceID and scenario values can be found by checking the repro line within the test log. The failingcdbname can be found by running the test binary with the /?option (scsicompliance.exe /?).

  5. Go back to the same directory and review the results to see if you can determine the reason for the test failure.

  6. If you need additional help, collect the txt and wtl logs and share the logs with Microsoft Customer Support.

If you are running this test against Windows Server 2003, make sure the disks or LUNs are not MPIO pseudo-LUNs. MPIO on Windows Server 2003 is not supported.

More information

The following commands are validated:

NOTE

For more information about Reference, visit the Technical Committee T10 SCSI Storage Interfaces website.

Command: Test Unit Ready

Title: TEST UNIT READY Basic Verification Test

Description: The TEST UNIT READY command provides a means to check if thelogical unit is ready. This is not a request for a self-test. If the logicalunit is able to accept an appropriate medium-access command without returningCHECK CONDITION status, this command shall return a GOOD status.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.33

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: This is a mandatory SPC-3/SPC-4 command.

Command: Request Sense

Title: REQUEST SENSE (6) Support Test

Description: Checking to see if Request Sense Command is supported and returns GOOD status.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.27

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: This command is mandatory in SPC-3/SPC-4 and is used by the initiator to retrieve error sense data for failed commands.

Title: REQUEST SENSE (6) RESPONSE CODE Test

Description: Verify that RESPONSE CODE is either 0x70 or 0x71 or 0x72 or 0x73

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.27

Expectation: RESPONSE CODE == 0x70 or RESPONSE CODE == 0x71 or RESPONSE CODE == 0x72 or RESPONSE CODE == 0x73

Title: REQUEST SENSE (6) Sense Data Length Test

Description: Verify that length of SENSE data is correct (data transferred matches data length reported by the command response).

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.27

Expectation: Additional Sense Length <= Sense data size - 8.

Command: Read 6

Title: READ (6) Basic Verification Test

Description: The device must return GOOD (0x0) SCSI status and the first two blocks of data correctly. This test sends two READ commands reading two different but overlapped blocks of data. Then, it compares the overlapped data. It returns true if the overlapped data is the same between the read operations (implying that the two commands read the same data correctly).

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.5

Expectation: ScsiStatus == 0x0.

Rationale: Some of the applications still use Read 6 and haven't transitioned into Read 10. Therefore we check if this command is implemented and proceed with testing.

Title: READ (6) Sequential Read Test

Description: The device must read 1000 sequential blocks of data correctly. This test sends the command 1000 times, reading 1024 bytes of data sequentially starting at a random block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.5

Expectation: All READ (6) commands succeed.

Title: READ (6) Random Read Test

Description: The device must read 1000 random blocks of data correctly. This test sends the command 1000 times, reading data at random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.5

Expectation: All READ (6) commands succeed.

Title: READ (6) Read-With-Disk-Cache-Cleared Test

Description: The device must return data correctly after clearing 12MB disk cache. This test first reads 12 MB sequential data for later verification. Then, it clears the disk cache by reading 12 MB random data. Finally, it reads the same 12 MB sequential data to see if the data is same as the one in first read.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.5

Expectation: The 12 MB data read after cache cleared is correct.

Command: Write 6

Title: WRITE (6) Basic Functionality Test

Description: The command writes one block of data to device correctly.This test compares the data we want to write and the one returned by the READ after the write operation. If the data is the same, this implies that the WRITE command writes the data to disk correctly.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.24

Expectation: ScsiStatus == 0x0.

Rationale: Some of the applications still use Write 6 and haven't transitioned into Write 10. Therefore we check if this command is implemented and proceed with testing.

Title: WRITE (6) Sequential Write Test

Description: The command writes 1000 sequential blocks of data correctly.This test sends the command 1000 times, writing data sequentially starting at a random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.24

Expectation: All WRITE (6) commands succeed.

Title: WRITE (6) Random Write Test

Description: The command writes 1000 random blocks of data correctly.This test sends the WRITE command 1000 times, writing data at random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.24

Expectation: All WRITE (6) commands succeed.

Title: WRITE (6) Write-With-Disk-Cache-Disabled Test

Description: The command writes 12 MB of data correctly with cache disabled.This test writes 12 MB of data to disk. Then, it reads the same 12 MB data that has just been written to verify that the data we just write are correct.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.24

Expectation: The 12 MB data are written correctly.

Title: WRITE (6) Write-With-Disk-Cache-Enabled Test

Description: The command writes 12 MB of data correctly with cache enabled.This test writes 12 MB of data to disk. Then, it sends a SYNCHRONIZE CACHE (10) command to synchronize the logical block address in cache with the ones in disk. Finally, it will read the same 12 MB data that has just been written to verify that the data we just write are correct.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.24

Expectation: The 12 MB data are written correctly.

Command: Inquiry

Title: INQUIRY Basic Verification Test

Description: The device must return GOOD (0x0) SCSI status and data of size smaller than or equal to 255 bytes in response to the INQUIRY command with ALLOCATION LENGTH field set to 255 (0xFF) bytes. The ALLOCATION LENGTH field specifies the maximum number of bytes that an application client has allocated for returned data.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: The device must return GOOD (0x0) SCSI status and data of size smaller than or equal to 255 bytes.

Title: INQUIRY Test for error when PAGE CODE field is nonzero and EVPD=0.

Description: Checking that an error is returned when PAGE CODE field isnonzero and EVPD=0. Checking that an error is returned when PAGE CODE field isnonzero and EVPD=0.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: ScsiStatus == 0x2, CHECK CONDITION. ScsiStatus == 0x2, CHECK CONDITION.

Title: INQUIRY Retrieving standard inquiry data.

Description: Checking if we can retrieve standard inquiry data. Checking if we can retrieve standard inquiry data.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: ScsiStatus == 0x0, GOOD.

Title: INQUIRY Checking size of standard inquiry data.

Description: Standard INQUIRY data shall contain at least 36 bytes.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: Data Transfer Length >= 36 bytes.

Title: INQUIRY Testing device type field

Description: Checking device type field to ensure it is a direct access device.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: Device Type == 0x0, Direct-access device.

Title: INQUIRY Testing peripheral qualifier field.

Description: Checking Peripheral Qualifier field.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: Peripheral qualifier field == 0

Title: INQUIRY VERSION Field Test

Description: The device must return a valid VERSION field of 0x4, 0x5 or 0x6

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: VERSION is 0x4 (SPC-2) or later for non-SCSI bus type and VERSION is 0x3 (SPC)or later for SCSI bus type.

Title: INQUIRY Checking RESPONSE DATA FORMAT.

Description: Checking that RESPONSE DATA FORMAT == 2.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: RESPONSE DATA FORMAT == 2.

Title: INQUIRY Checking additional length.

Description: Checking additional length field is correct.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: Additional Length field == Total Data size - 5

Title: INQUIRY Checking VENDOR IDENTIFICATION field.

Description: Checking that VENDOR IDENTIFICATION field contains valid ASCII.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: VENDOR IDENTIFICATION field contains valid ASCII.

Title: INQUIRY Checking PRODUCT IDENTIFICATION field.

Description: Checking that PRODUCT IDENTIFICATION field contains valid ASCII.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: PRODUCT IDENTIFICATION field contains valid ASCII.

Title: INQUIRY Checking PRODUCT REVISION LEVEL field.

Description: Checking that PRODUCT REVISION LEVEL field contains valid ASCII.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: PRODUCT REVISION LEVEL field contains valid ASCII.

Title: INQUIRY Command Support Data Test.

Description: The device must set the HiSup bit in the Standard Inquiry Data.

Reference: SCSI Architecture Model - 3 (SAM-3) Revision 14 (or later) specification Section 4.9.2

Expectation: HiSup bit is set in Standard Inquiry Data.

Title: INQUIRY Checking for Supported Vital Product Pages.

Description: Checking to see if Vital Product Pages are supported.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4.4

Expectation: List of Supported Vital Product Data Pages is returned.

Title: INQUIRY Testing access to each supported Vital Product Data Page.

Description: Attempting to access each supported Vital Product Data Page.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4.4

Expectation: Each supported page is accessible (up to 255 bytes).

Title: INQUIRY Attempting Unit Serial Number Page 0x80.

Description: Checking if Unit Serial Number Page 0x80 is supported, and is valid ASCII.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 7.6.10

Expectation: ScsiStatus == 0x0, and result is valid ASCII.

Title: INQUIRY Attempting Device identification Page 0x83.

Description: Checking if Device identification Page 0x83 is supported.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 7.6.3

Expectation: ScsiStatus == 0x0.

Title: INQUIRY Checking Identification Descriptors in VPD page 0x83.

Description: Checking that Identification Descriptors contain meaningful data.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 7.6.3

Expectation: All descriptors are compliant, and contain meaningful data.

Title: INQUIRY Checking Version Descriptors.

Description: Checking to see if Version Descriptors are compliant.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.4

Expectation: Version descriptors exist.

Command: Mode Select 6

Title: MODE SELECT (6) Basic Test

Description: Checking to see if a simple MODE SELECT command, with PF and SP == 0, passes

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: Our Storage stack uses Caching Mode Page to turn on/off the device caching. Therefore the ability to write to mode pages using Mode Select commands is required.

Title: MODE SELECT 6: MODE SENSE (6) Attempting to get Caching mode page.

Description: Checking to see if a simple MODE SENSE command on Page 0x08 will return GOOD status.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 6: MODE SENSE (6) Checking Parameters Savable (PS bit).

Description: Checking to see if Parameters Savable bit for the Caching Mode Page is 1.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: PS == 1.

Title: MODE SELECT 6: MODE SENSE (6) Checking Mode Parameter Header

Description: Verify that MediumType == 0 and BlockDescriptorLength == 0.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: MediumType == 0x0 and BlockDescriptorLength == 0x0

Title: MODE SELECT 6: MODE SENSE (6) Checking Caching Mode Page Length.

Description: Checking the Caching Mode Page is 20 bytes.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: cachePageLength == 20 bytes.

Title: MODE SELECT 6: MODE SENSE (6) Getting Changeable values.

Description: Saving away Changeable Values for Caching Mode Page

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 6: MODE SENSE (6) Getting default values.

Description: Saving away Default Values for Caching Mode Page.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT (6) Changing WCE.

Description: Applying MODE SELECT to WCE=0 for the device.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 6: MODE SENSE (6) Checking that WCE has been cleared.

Description: Checking that the previous MODE SELECT command actually changed the current mode parameters.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: WCE is clear.

Title: MODE SELECT 6: MODE SENSE (6) Checking that Saved Values have changed.

Description: Checking that the previous MODE SELECT command actually changed the saved mode parameters.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: Saved values have changed.

Title: MODE SELECT (6) setting WCE

Description: Applying MODE SELECT to set WCE.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 6: MODE SENSE (6) Checking that WCE has been set.

Description: Checking that the previous MODE SELECT command actually set WCE.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: Current values have been set.

Title: MODE SELECT (6) Attempting to restore original values.

Description: Testing MODE SELECT can return the Caching Mode Page values to their original values.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 6: MODE SENSE (6) Verifying values were restored.

Description: Checking that the values were restored in the Caching Mode Page.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.7

Expectation: Current values equal default values.

Command: Mode Sense 6

Title: MODE SENSE (6) Basic Test

Description: Checking to see if a simple MODE SENSE command on Page 0x3f will return GOOD status

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: Storage stack uses Caching Mode Page to turn on/off the device caching. Therefore the ability to read to mode pages using Mode Sense commands is required.

Title: MODE SENSE (6) Checking size of returned data.

Description: Checking that we receive a minimum amount of data (i.e. at least the MODE PARAMETER HEADER).

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Data Transfer Length >= 4 bytes

Title: MODE SENSE (6) Checking MODE PARAMETER HEADER

Description: Checking that the MODE PARAMETER HEADER length information is valid.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: ModeDataLength = Data Transfer Length - 1 = -1 bytes.

Title: MODE SENSE (6) Test DBD (disable block descriptors) bit.

Description: Testing to make sure that, when DBD bit is set, no block descriptors are returned.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Block Descriptor Length = 0

Title: MODE SENSE (6) Testing new data length when DBD bit is set.

Description: : Testing that new data length should equal old data length minus block descriptor length.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: New Data Length = Old Data Length

Title: MODE SENSE (6) Comparing MODE PAGE data before and after DBD bit is set

Description: Testing that page data is the same before and after DBD bit is set.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Page data will match

Title: MODE SENSE (6) Testing Page Control Field

Description: Testing different values of the Page control field, and enforcing the size of the data returned.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Data length for each value of PC is correct.

Title: MODE SENSE (6) Scanning All Mode Pages.

Description: Checking Mode Page 0x3f data to examine supported mode pages.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: To find supported mode pages: Information exception control mode page and Caching mode page.

Title: MODE SENSE (6) Ensuring mandatory mode pages are supported

Description: Checking that required mode pages are present in MODE PAGE 0x3f

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Caching and Informational Exception pages are supported, at a minimum.

Title: MODE SENSE (6) Checking Individual Mode Pages

Description: Testing to ensure we can access each individual mode page, and that the paremeters are correct

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Pages should be returned and the headers should be compliant

Title: MODE SENSE (6) Checking Informational Exception Mode Page

Description: Ensuring Informational Exception Mode Page is compliant

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Power Condition Mode Page is supported

Title: MODE SENSE (6) Checking Informational Exception Mode Page

Description: Ensuring Informational Exception Mode Page is compliant

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Power Condition Mode Page is supported

Title: MODE SENSE (6) Checking Power Condition Mode Page.

Description: Ensuring Power Condition Mode Page is compliant

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Informational Exception Mode Page is supported

Title: MODE SENSE (6) Checking Caching Mode Page.

Description: Ensuring Caching Mode Page is compliant.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Caching Mode Page is supported.

Title: MODE SENSE (6) Checking Device Specific Parameters

Description: This tests to see if the Device specific parameters are supported.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.9

Expectation: Nothing.

Command: Read Capacity 10

Title: READ CAPACITY (10) Basic Verification Test

Description: The device must return GOOD (0x0) SCSI status and 8 bytes of parameter data describing the capacity and medium format of the block device to the data-in buffer.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.10

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: This command is required for formatting operations and initialization.

Command: Read 10

Title: READ (10) Basic Functionality Test

Description: The command reads the first two blocks of data correctly.This test sends two READ commands reading two different but overlapped blocks of data. Then, it compares the overlapped data. It returns true if the overlapped data is the same between the read operations (implying that the two commands read the same data correctly).

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.6

Expectation: Scsi Status == 0x0.

Rationale: Used to Read data from device.

Title: READ (10) Sequential Read Test

Description: The command reads 1000 sequential blocks of data correctly.This test sends the command 1000 times, reading data sequentially starting at a random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.6

Expectation: All READ (10) commands succeed.

Title: READ (10) Random Read Test

Description: The command reads 1000 random blocks of data correctly.This test sends the command 1000 times, reading data at random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.6

Expectation: All READ (10) commands succeed.

Title: READ (10) Read-With-Disk-Cache-Cleared Test

Description: The command reads 12 MB of data correctly with disk cache cleared.This test first reads 12 MB sequential data for later verification. Then, it clears the disk cache by reading 12 MB random data. Finally, it reads the same 12 MB sequential data to see if the data is same as the one in first read.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.6

Expectation: The 12 MB data read after cache cleared is correct.

Command: Write 10

Title: WRITE (10) Basic Functionality Test

Description: The command writes one block of data to device correctly.This test compares the data we want to write and the one returned by the READ after the write operation. If the data is the same, this implies that the WRITE command writes the data to disk correctly.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.25

Expectation: ScsiStatus == 0x0.

Rationale: Used to write data to device.

Title: WRITE (10) Sequential Write Test

Description: The command writes 1000 sequential blocks of data correctly.This test sends the command 1000 times, writing data sequentially starting at a random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.25

Expectation: All WRITE (10) commands succeed.

Title: WRITE (10) Random Write Test

Description: The command writes 1000 random blocks of data correctly.This test sends the WRITE command 1000 times, writing data at random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.25

Expectation: All WRITE (10) commands succeed.

Title: WRITE (10) Write-With-Disk-Cache-Disabled Test

Description: The command writes 12 MB of data correctly with cache disabled.This test writes 12 MB of data to disk. Then, it reads the same 12 MB data that has just been written to verify that the data we just write are correct.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.25

Expectation: The 12 MB data are written correctly

Title: WRITE (10) Write-With-Disk-Cache-Enabled Test

Description: The command writes 12 MB of data correctly with cache enabled.This test writes 12 MB of data to disk. Then, it sends a SYNCHRONIZE CACHE (10) command to synchronize the logical block address in cache with the ones in disk. Finally, it will read the same 12 MB data that has just been written to verify that the data we just write are correct.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.25

Expectation: The 12 MB data are written correctly.

Title: WRITE (10) FUA Test

Description: The command writes data to disk correctly with cache and FUA (Force Unit Access) on.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.25.

Expectation: Data is written correctly to disk with FUA on. Checksums of all WRITE (10) are correct.

Title: VERIFY (10) Support Test

Description: Verify that the device supports the VERIFY (10) command. This test issues a simple VERIFY (10) command and checks whether the return code is 0x2 (meaning not supported).

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.28.

Expectation: Scsi Status is 0x0 (GOOD).

Title: VERIFY (10) Zero Length Test

Description: The test sends VERIFY (10) command with both LOGICAL BLOCK ADDRESS and VERIFICATION LENGTH set to 0. Based on the spec, VERIFICATION LENGTH field set to zero specifies that no logical blocks shall be verified. This condition shall not be considered as an error.

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.28.

Expectation: Scsi Status is 0x0 (GOOD).

Title: VERIFY (10) Random LBA Test

Description: The test sends VEIRFY (10) command with VERIFICATION LENGTH = 1 and randomized LOGICAL BLOCK ADDRESS (random between 0 and last LBA).

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.28.

Expectation: Scsi Status is 0x0 (GOOD).

Title: VERIFY (10) Exceed Capacity Test

Description: The test sends VEIRFY (10) command with VERIFICATION LENGTH = 2 and LOGICAL BLOCK ADDRESS set to the last LBA.

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.28.

Expectation: Scsi Status is 0x2 (CHECK CONDITION).

Command: Mode Select 10

Title: MODE SELECT (10) Basic Test

Description: Checking to see if a simple MODE SELECT command, with PF and SP == 0, passes

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: Mode Select 6 is mandatory and Mode Select 10 is Optional and would be tested if-implemented.

Title: MODE SELECT 10: MODE SENSE (10) Attempting to get Caching mode page.

Description: Checking to see if a simple MODE SENSE command on Page 0x08 will return GOOD status.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 10: MODE SENSE (10) Checking Parameters Savable (PS bit).

Description: Checking to see if Parameters Savable bit for the Caching Mode Page is 1.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: PS == 1.

Title: MODE SELECT 10: MODE SENSE (10) Checking Mode Parameter Header

Description: Verify that MediumType == 0 and BlockDescriptorLength == 0.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: MediumType == 0x0 and BlockDescriptorLength == 0x0

Title: MODE SELECT 10: MODE SENSE (10) Checking Caching Mode Page Length.

Description: Checking the Caching Mode Page is 20 bytes.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: cachePageLength == 20 bytes.

Title: MODE SELECT 10: MODE SENSE (10) Getting Changeable values.

Description: Saving away Changeable Values for Caching Mode Page

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 10: MODE SENSE (10) Getting default values.

Description: Saving away Default Values for Caching Mode Page.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI statu

Title: MODE SELECT (10) Changing WCE.

Description: Applying MODE SELECT to WCE=0 for the device.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 10: MODE SENSE (10) Checking that WCE has been cleared.

Description: Checking that the previous MODE SELECT command actually changed the current mode parameters.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: : WCE is clear.

Title: MODE SELECT 10: MODE SENSE (10) Checking that Saved Values have changed.

Description: Checking that the previous MODE SELECT command actually changed the saved mode parameters.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: Saved values have changed.

Title: MODE SELECT (10) setting WCE

Description: Applying MODE SELECT to set WCE.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 10: MODE SENSE (10) Checking that WCE has been set.

Description: Checking that the previous MODE SELECT command actually set WCE.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: Current values have been set.

Title: MODE SELECT (10) Attempting to restore original values.

Description: Testing MODE SELECT can return the Caching Mode Page values to their original values

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: The device must return GOOD (0x0) SCSI status

Title: MODE SELECT 10: MODE SENSE (10) Verifying values were restored.

Description: Checking that the values were restored in the Caching Mode Page.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.8

Expectation: Current values equal default values.

Command: Mode Sense 10

Title: MODE SENSE (10) Basic Test

Description: Checking to see if a simple MODE SENSE10 command on Page 0x3f will return GOOD status

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.10

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: Mode Sense 6 is mandatory and Mode Sense 10 is Optional and would be tested if-implemented.

Title: MODE SENSE (10) Checking size of returned data.

Description: Checking that we receive a minimum amount of data (i.e. at least the MODE PARAMETER HEADER).

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.10

Expectation: Data Transfer Length >= 8 bytes

Title: MODE SENSE (10) Checking MODE PARAMETER HEADER

Description: Checking that the MODE PARAMETER HEADER length information is valid.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.10

Expectation: ModeDataLength = Data Transfer Length - 2 = -2 bytes.

Title: MODE SENSE (10) Test DBD (disable block descriptors) bit.

Description: Testing to make sure that, when DBD bit is set, no block descriptors are returned.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.10

Expectation: Block Descriptor Length = 0

Title: MODE SENSE (10) Comparing MODE PAGE data before and after DBD bit is set

Description: Testing that page data is the same before and after DBD bit is set.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.10

Expectation: Page data will match

Title: MODE SENSE (10) Testing Page Control Field

Description: Testing different values of the Page control field, and enforcing the size of the data returned.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.10

Expectation: Data length for each value of PC is correct and PC=0 and PC=2 return good status.

Command: Read 16

Title: READ (16) Support Test

Description: Verify that the device supports the READ (16) command.This test issues a simple READ (16) command and checks whether the return code is 0x2 (meaning not supported).

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.8

Expectation: Scsi Status is 0x0.

Title: READ (16) Basic Functionality Test

Description: The command reads the first two blocks of data correctly.This test sends two READ commands reading two different but overlapped blocks of data. Then, it compares the overlapped data. It returns true if the overlapped data is the same between the read operations (implying that the two commands read the same data correctly).

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.8

Expectation: Scsi Status is 0x0.

Rationale: If device is 64-bit LBA, Read 16 is Mandatory to read entire disk. Else its if-implemented.

Title: READ (16) Sequential Read Test

Description: The device must read 1000 sequential blocks of data correctly. This test sends the command 1000 times, reading data sequentially starting at a random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.8

Expectation: All READ (16) commands succeed.

Title: READ (16) Random Read Test

Description: The command reads 1000 random blocks of data correctly.This test sends READ (16) command 1000 times, reading data at random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.8

Expectation: All READ (16) commands succeed.

Title: READ (16) Read-With-Disk-Cache-Cleared Test

Description: The command reads 12 MB of data correctly with disk cache cleared.This test first reads 12 MB sequential data for later verification. Then, it clears the disk cache by reading 12 MB random data. Finally, it reads the same 12 MB sequential data to see if the data is same as the one in first read.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.8

Expectation: The 12 MB data read after cache cleared is correct.

Command: Write 16

Title: WRITE (16) Support Test

Description: Verify that the device supports the command.This test issues a simple WRITE (16) command and checks whether the return code is 0x2 (Check Condition).

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.27

Expectation: ScsiStatus == 0x0.

Title: WRITE (16) Basic Functionality Test

Description: The command writes one block of data to device correctly.This test compares the data we want to write and the one returned by the READ after the write operation. If the data is the same, this implies that the WRITE command writes the data to disk correctly.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.27

Expectation: : ScsiStatus == 0x0.

Rationale: If device is 64-bit LBA, Write 16 is Mandatory to write entire disk. Else its if-implemented.

Title: WRITE (16) Sequential Write Test

Description: The command writes 1000 sequential blocks of data correctly.This test sends the command 1000 times, writing data sequentially starting at a random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.27

Expectation: All WRITE (16) commands succeed.

Title: WRITE (16) Random Write Test

Description: The command writes 1000 random blocks of data correctly.This test sends the WRITE command 1000 times, writing data at random logical block address.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.27

Expectation: All WRITE (16) commands succeed.

Title: WRITE (16) Write-With-Disk-Cache-Disabled Test

Description: The command writes 12 MB of data correctly with cache disabled.This test writes 12 MB of data to disk. Then, it reads the same 12 MB data that has just been written to verify that the data we just write are correct.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.27

Expectation: The 12 MB data are written correctly.

Title: WRITE (16) Write-With-Disk-Cache-Enabled Test

Description: The command writes 12 MB of data correctly with cache enabled.This test writes 12 MB of data to disk. Then, it sends a SYNCHRONIZE CACHE (10) command to synchronize the logical block address in cache with the ones in disk. Finally, it will read the same 12 MB data that has just been written to verify that the data we just write are correct.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.27

Expectation: The 12 MB data returned by the WRITEs is correct.

Title: VERIFY (16) Support Test

Description: Verify that the device supports the VERIFY (16) command. This test issues a simple VERIFY (16) command and checks whether the return code is 0x2 (meaning not supported).

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.30.

Expectation: Scsi Status is 0x0 (GOOD).

Title: VERIFY (16) Zero Length Test

Description: The test sends VERIFY (16) command with both LOGICAL BLOCK ADDRESS and VERIFICATION LENGTH set to 0. Based on the spec, VERIFICATION LENGTH field set to zero specifies that no logical blocks shall be verified. This condition shall not be considered as an error.

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.30.

Expectation: Scsi Status is 0x0 (GOOD).

Title: VERIFY (16) Random LBA Test

Description: The test sends VERIFY (16) command with VERIFICATION LENGTH = 1 and randomized LOGICAL BLOCK ADDRESS (random between 0 and last LBA).

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.30.

Expectation: Scsi Status is 0x0 (GOOD).

Title: VERIFY (16) Exceed Capacity Test

Description: The test sends VEIRFY (16) command with VERIFICATION LENGTH = 2 and LOGICAL BLOCK ADDRESS set to the last LBA.

Reference: SCSI Block Commands - 3 (SBC-3) Revision 27 (or published) specification Section 5.30.

Expectation: Scsi Status is 0x2 (CHECK CONDITION).

Command: Report LUNS

Title: REPORT LUNS Basic Verification Test

Description: Attempts to find the LUN 0 corresponding to D.U.T. and execute the REPORT LUNS command. This test will only send REPORT LUNS to LUN 0 at the current target address per SAM-3. This test will only issue a request with SELECT REPORT set to zero per SPC-3.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.21

Expectation: The device must return GOOD (0x0) SCSI status and data of size smaller than or equal to 255 bytes.

Rationale: Report LUNS is used to discover LUNs present on the device. It is Mandatory for UAS. BOT uses the GetMaxLun USB class-specific command instead. So this is optional for BOT devices. Although we check for implementation of this CDB and test this command if implemented.

Title: REPORT LUNS LUN0 Test

Description: This test will only send REPORT LUNS to LUN 0 at the current target address per SAM-3.This test will only issue a request with SELECT REPORT set to zero per SPC-3.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.21

Expectation: The device must return GOOD (0x0) SCSI status and data of size smaller than or equal to 255 bytes.

Title: REPORT LUNS Data valid Test

Description: This test will only send REPORT LUNS to LUN 0 at the current target address per SAM-3.This test will only issue a request with SELECT REPORT set to zero per SPC-3.

Reference: SCSI Primary Commands - 3 (SPC-3) Revision 23 (or published) specification Section 6.21

Expectation: Each reported LUN uses single level numbers restricted to <= 255.

Command: Read Capacity 16

Title: READ CAPACITY (16) Allocation length test

Description: The device must return GOOD (0x0) SCSI status even though allocation lengthis set to 0 value

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.11

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: This command is required for formatting operations and initialization.

Title: READ CAPACITY (16) Basic Verification Test

Description: The device must return GOOD (0x0) SCSI status and 8 bytes of parameter data describing the capacity and medium format of the block device to the data-in buffer.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.11

Expectation: The device must return GOOD (0x0) SCSI status

Title: READ CAPACITY (16) Capacity Test

Description: Send a READ CAPACITY command to check the reported block address. If the block address is greater than the READ CAPACITY 10 limit, ensure READ CAPACITY 10 block address is set to 0xFFFF_FFFF.

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.11

Expectation: For block addresses greater than READ CAPACITY 10 can describe, the READ CAPACITY 10 block address is set to 0xFFFF_FFFF.

Command: Start Stop Unit

Title: START STOP UNIT Basic Test 1

Description: Sending StartStopUnit with IMMED=0, LOEJ=0, START=0, spin down drive

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.17

Expectation: The device must return GOOD (0x0) SCSI status

Rationale: This command is required to ensure data integrity in the face of power state changes and disconnection from the bus.

Title: START STOP UNIT Basic Test 2

Description: Sending StartStopUnit with IMMED=0, LOEJ=0, START=1, spin up drive

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.17

Expectation: The device must return GOOD (0x0) SCSI status

Title: START STOP UNIT Basic Test 3

Description: Sending StartStopUnit with IMMED=1, LOEJ=0, START=0, spin down drive

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.17

Expectation: The device must return GOOD (0x0) SCSI status

Title: START STOP UNIT Basic Test 4

Description: Sending StartStopUnit with IMMED=1, LOEJ=0, START=1, spin up drive

Reference: SCSI Block Commands - 2 (SBC-2) Revision 16 (or published) specification Section 5.17

Expectation: The device must return GOOD (0x0) SCSI status

Command syntax

Command | Description
Scsicompliance.exe | The options for the test are listed below
/device | The device which test is to run on Example: /Device <physical device path>
/operation | The operation to run. Example: /Operation Test
/scenario | The feature to be tested for. Example: /Scenario Common
/verbosity | The level of logging verbosity. Larger values cause more verbose output. Example: /Verbosity 4
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\nttest</p>

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId |
Destructive | (0,1) 0=Passive, 1=Destructive


SCSI Reliability Counters Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4fe41e4-62b2-4c58-b131-8f2e51b0bbe3

Storage Spaces has three certification programs: one for drives, one for enclosures, and one for host bus adapters. The reliability counter requirements apply to drives. These reliability counter requirements are a result of OEM feedback that they are necessary to enable troubleshooting issues in the field, and a result of the product team supporting and troubleshooting deployments.

This test checks if drives return reliability data log pages.

Test details
Specifications
  • Device.Storage.Hd.Scsi.ReliabilityCounters.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

If you are testing any drive that requires media or testing in system-mode on a computer that contains drives that require media, you must insert media into the drives. The media that is used must be formatted and contain data that occupies at least 50% of the media's capacity.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

Basic reliability counter functionality for that implement SCSI command sets

All drives must provide valid data for the below log sense page (LOG SENSE 4Dh) parameters, per the SCSI Primary Commands 4 (SPC-4) and SCSI Block Commands 3 (SBC-3) specifications.

  • Start-Stop Cycle Counter (0Eh)

    • Manufacture Date (0001h)

  • Read Error Counter (03h)

    • Total (0002h)

    • Total Errors Corrected (0003h)

    • Total Uncorrected Errors (0006h)

  • Temperature (0Dh)

    • Temperature (0000h)

    • Reference Temperature (0001h)

  • Write Error Counter (02h)

    • Total (0002h)

    • Total Errors Corrected (0003h)

    • Total Uncorrected Errors (0006h)

  • Background Scan (15h)

    • Background Scan Status (0000h)

Drives that physically move recording media and/or read-write devices, such as hard disk drives, must provide valid data for the below log sense page (LOG SENSE 4Dh) parameters, per the SCSI Primary Commands 4 (SPC-4) specification.

  • Start-Stop Cycle Counter (0Eh)

    • Specified Cycle Count Over Device Lifetime (0003h)

    • Accumulated Start-Stop Cycles (0004h)

    • Specified Load-Unload Count Over Device Lifetime (0005h)

    • Accumulated Load-Unload Cycles (0006h)

Solid-state drives must provide valid data for the below log sense page (LOG SENSE 4Dh) parameter, per the SCSI Block Commands 3 (SBC-3) specification.

  • Solid State Media (11h)

    • Percentage Used Endurance Indicator (0001h)

Command syntax

Command option | Description
Scsicompliance.exe | Runs the tests with the specified options.
/device | Specifies the device to be tested. Example: \.\disk0
/scenario | Specifies the scenario test to be run. Example ReliabilityCounters
/verbosity | Logging detail. Levels are cumulative. 0 = Assertions and results. 1 = Details. 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
/operation | The operation ID. Example: test
/cdb | The CDB list.
/version | The version. 1 = SPC-2 and SBC1. 2= SPC3 and SBC2. 3 = SPC-4 and SBC3.

File list

File | Location
scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId |
Destructive | (0,1) 0=Passive, 1=Destructive


SD Paging Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/42a31f1c-25cd-469d-a287-8b9a843ba453

This test validates paging functionality by reading and writing a buffer of physical memory size under stress conditions.

Test details
Specifications
  • Device.Storage.Hd.EMMC.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Check the WTT Trace by performing the following steps:

  • View Task Log of Run SDBus Paging Test.

  • Open the log file SoCBootTest.wtl.

  • Check for messages that may solve the issue.

For additional troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

This test will enable paging with Driver Verifier's Force Pending I/O Requests and Low Resources Simulation set. This will test two things:

  • The ability of a driver to accomplish forward progression (failed allocations simulate that) and to ensure that the driver cannot page itself out.

  • Force Pending I/O Requests will attempt to page the entire driver, thus producing an immediate stop error if the driver cannot protect against that.

Command usage

Command | Description
SocBootTest.exe MemoryChokeIO | Runs the MemoryChokeIO scenario of the SoCBootTest.
SocBootTest.exe DiskStress | Runs the DiskStress scenario of the SoCBootTest.
SocBootTest.exe MemoryStress | Runs the MemoryStress scenario of the SoCBootTest.

Command syntax

Command option | Description
MemoryChokeIO | Runs MemoryChoke and BigFile in parallel.
DiskStress | Runs DiskStress.
MemoryStress | Runs MemoryStress.
NOTE

For command-line help for this test, type /?.

File list

File | Location
autocom.dll | <[testbinroot]>\nttest\driverstest\storage</p>
autocomManaged.dll | <[testbinroot]>\nttest\driverstest\storage\managed</p>
BigFile.exe | <[testbinroot]>\nttest\driverstest\storage\disk</p>
DiskStress.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
MemoryChoke.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
MemoryStress.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
SocBootTest.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot\SoCBootTest</p>
SDHelper.dll | <[testbinroot]>\nttest\driverstest\storage\sd\Tools\SDHelper</p>
etwprocessor.dll | <[taefbinroot]></p>
wex.common.dll | <[testbinroot]>\wextest\cue\testexecution\wlk</p>
wex.communication.dll | <[testbinroot]>\wextest\cue\testexecution</p>
ntlog.dll | <[osbinroot]>\NTTEST\commontest\ntlog</p>
ntlogger.ini | <[osbinroot]>\NTTEST\commontest\ntlog</p>
stresslog.dll | <[testbinroot]>\nttest\basetest\core_file_services\shared_libs</p>
fbslog.dll | <[testbinroot]>\nttest\basetest\core_file_services\shared_libs\fbslog</p>
rapidfile.exe | <[testbinroot]>\nttest\basetest\core_file_services\shared_tests\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.


SDHC Compliance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31b80afd-d448-4199-a14e-1afcf55ec293

This test verifies the correct operation of a SD host controller by ensuring that the features described in the requirements are implemented by the host controller.

Test details
Specifications
  • Device.Storage.Controller.SD.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Secure Digital Host Controller Storage Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The test will first do discovery on the SD host controllers and SD devices attached to the system to determine their capabilities. It will then specifically check the host controller for the device specified to ensure that it conforms to the certification requirements. For each requirement item, the device will be checked to see if it claims to support the features or modes required. Then if applicable, the device will be checked to ensure the operation of that feature is adequate. Failures will be logged for any error found.

Command usage

Command | Description
SoCBootTest.exe SDHCCompliance Device [StorageDriveLetter] | Run the SDHCCompliance scenario on the specified device.

Command syntax

Command option | Description
SDHCCompliance | Runs the SDHC Compliance test.
Device | Specifies the device to run the test against.
NOTE

For command-line help for this test, type /?.

File list

File | Location
autocom.dll | <[testbinroot]>\nttest\driverstest\storage</p>
autocomManaged.dll | <[testbinroot]>\nttest\driverstest\storage\managed</p>
BigFile.exe | <[testbinroot]>\nttest\driverstest\storage\disk</p>
DiskStress.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
MemoryChoke.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
MemoryStress.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot</p>
SocBootTest.exe | <[testbinroot]>\nttest\driverstest\storage\sd\SDBoot\SoCBootTest</p>
SDHelper.dll | <[testbinroot]>\nttest\driverstest\storage\sd\Tools\SDHelper</p>
etwprocessor.dll | <[taefbinroot]></p>
wex.common.dll | <[testbinroot]>\wextest\cue\testexecution\wlk</p>
wex.communication.dll | <[testbinroot]>\wextest\cue\testexecution</p>
ntlog.dll | <[osbinroot]>\NTTEST\commontest\ntlog</p>
ntlogger.ini | <[osbinroot]>\NTTEST\commontest\ntlog</p>
stresslog.dll | <[testbinroot]>\nttest\basetest\core_file_services\shared_libs</p>
fbslog.dll | <[testbinroot]>\nttest\basetest\core_file_services\shared_libs\fbslog</p>
rapidfile.exe | <[testbinroot]>\nttest\basetest\core_file_services\shared_tests\wdk</p>

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
WDKDeviceID | Instance path of device to test.
DiskDeviceObjLink | Assigned by Create Storage Parameters.
Destructive | (0,1) 0=Passive, 1=Destructive


SD-Ioctl Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b339365-bf86-4fc3-80f2-12b0a0283b3a

This test verifies that SD-specific IOCTL calls work from any user mode process as expected.

Test details
Specifications
  • Device.Storage.Controller.SD.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

The test expects that an SD card is inserted into the host controller and working before the test begins.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

The test sends several variations of IOCTLs to the disk and validates the response. In the case of an error sending the IOCTL or validating the response, the logs contain information about the errors. To check the WTT trace, perform the following steps:

  • View Task Log of Run SDIOCTL Test.

  • Open the log file sdioctltst.wtl.

  • Check for messages that may solve the issue.

For additional troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

The test will go through a series of IOCTLs and various parameters surrounding those IOCTLs. It will send them to the underlying disk and validate the response conforms to the requirements. Log information about which IOCTLs and the results are printed as tests cases in the log.

The following is a list of the IOCTLs that are covered in this file:

  1. IOCTL_DISK_MEDIA_REMOVAL

  2. IOCTL_DISK_GET_LENGTH_INFO

  3. IOCTL_DISK_IS_WRITABLE

  4. IOCTL_DISK_VERIFY

  5. IOCTL_STORAGE_CHECK_VERIFY

  6. IOCTL_STORAGE_CHECK_VERIFY2

  7. IOCTL_DISK_CHECK_VERIFY

  8. IOCTL_DISK_GET_CACHE_INFORMATION

  9. IOCTL_STORAGE_GET_HOTPLUG_INFO

  10. IOCTL_STORAGE_SET_HOTPLUG_INFO

  11. IOCTL_STORAGE_GET_DEVICE_NUMBER

  12. IOCTL_DISK_GET_DRIVE_GEOMETRY

  13. IOCTL_DISK_GET_DRIVE_GEOMETRY_EX

  14. IOCTL_STORAGE_GET_MEDIA_TYPES_EX

  15. IOCTL_STORAGE_QUERY_PROPERTY

  16. IOCTL_SCSI_GET_ADDRESS

  17. IOCTL_STORAGE_GET_MEDIA_SERIAL_NUMBER

  18. IOCTL_SFFDISK_QUERY_DEVICE_PROTOCOL

  19. IOCTL_SFFDISK_DEVICE_COMMAND

  20. IOCTL_SFFDISK_DEVICE_PASSWORD

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
WDKDeviceID | Instance path of device to test.


SES Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0641f37b-e994-4c02-a61c-82ef2c54e83f

This test verifies SCSI device compliance on Windows.

Test details
Specifications
  • Device.Storage.Enclosure.DriveIdentification
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements at Hard Disk Drive Testing Prerequisites and SCSI Enclosure Services (SES) Device Testing Prerequisites.

To run this test you must set the DiskDeviceObjLink parameter. This parameter represents the physical path to the test device, for example \\.\PhysicalDrive1. If testing an MPIO device, this should be the path to the Pseudo-LUN.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

If a failure is observed in the SES Tes, run scsicompliance.exe /device "<Device Instance ID>" /verbosity 4 /scenario SSP /operation test /SESDisk \\.\<Drive Number> (for example, scsicompliance.exe /device "SCSI\ENCLOSURE&VEN_LSI_CORP&PROD_SAS2X36\7&7B0A3DA&0&005600" /verbosity 4 /scenario SSP /operation test /SESDisk \\.\PhysicalDrive19)

Scsicompliance.exe can be found at <controller path> \Windows Kits\8.0\Hardware Certification Kit\Tests\<arch>\NTTEST\driverstest\storage\wdk\.

The most relevant log is scsicompliance.wtl.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Errors from this test occur via issues identified in the log file and in bug checks produced through stressing the driver under test.

More information

This test will focus on measuring the SCSI device compliance on Windows. The goal is twofold - to ensure that SCSI devices supported on the Windows operating system fully and completely adhere to the SCSI specifications set forth in SPC-4 and SES-3, as well as to allow us and our partners to fully respect and comply with these standards. Maintaining compliance will lead to a stronger and more reliable system overall.

NOTE

For more information about these specifications, visit the Technical Committee T10 SCSI Storage Interfaces website.

The test sends the following commands to the device:

  1. Receive Diagnostic Results: 0x00, 0X01, 0X02, 0X07, 0X0A pages.

  2. Send Diagnostic: 0x02 page.

  3. Inquiry: VPD 0x83 Page.

Command syntax

For more information about this test, please install the WDK documentation.

Command option Description

Scsicompliance.exe

Runs the test.

/SESDisk

Specifies the physical path to test device, ex: \.\PhysicalDrive1. If testing an MPIO device this should be the path to the Pseudo-LUN.

/device

Specifies the enclosure device to be tested.

/verbosity

Verbosity level

  • 0 = Shows errors and warnings in all modules plus test warnings.

  • 1 = Shows assertion details (default).

  • 2 = Shows logs of test tool framework.

  • 3 = Shows CDBs sent to device.

  • 4 = Shows data, and sense info returned.

/scenario

Specifies the test scenario.

/operation

Specifies the Test or Discovery test option.

/cdb

Specifies the CDB list.
NOTE

The command-line switches are used when running the test manually: For command-line help for this test binary, type /h.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Assigned by Create Storage Parameters.
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId |
Options |
ScsiComplianceDevice | Device path
Destructive | (0,1) 0=Passive, 1=Destructive


Space creation on enclosure drives (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa0d4f0a-82d9-4d81-ae00-102bf4a61a1b

This test creates an enclosure aware mirror space and verifies that files can be created on that.

Test details
Specifications
  • Device.Storage.Enclosure.DriveIdentification
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: SCSI Enclosure Services (SES) Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Errors from this test occur via issues identified in the log file and in bugchecks produced through stressing the driver under test.

More information

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Assigned by Create Storage Parameters.
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
EnclosureUniqueID | Assigned by create storage parameters


Storage Firmware Update

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ccac8651-e523-48b2-8f8d-4ead94a8fb61

This test validates the device support information for firmware update. And then updates the firmware using the firmware image file.

Test details
Specifications
  • Device.Storage.Hd.FirmwareUpgrade.BasicFunction
  • Device.Storage.Controller.Sas.TranslationLayer
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device to Test
DiskDeviceObjLink | Assigned by Create Storage Parameters
FirmwareImageFile | Path and name of the new firmware image file


Storage Imports Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c75585b2-a3e6-4db0-8847-f6023171d4b9

This test verifies that a storage adapter driver follows the proper miniport architecture for its bus type. The tool also validates that the driver does not import functions from outside the port driver.

Test details
Specifications
  • Device.Storage.Controller.MiniportDriverModel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Storage Adapter or Controller Testing Overview.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

This test is started against a particular device node that is identified by that device node's device instance path. The test queries the interface of that device node for the bus type (by using IOCTL_STORAGE_QUERY_PROPERTY: StorageAdapterDescriptor.) The test determines the driver for the device node by checking the Service property of the device node. The test then determines the type of miniport architecture of the driver and obtains a list of imported functions.

The miniport must match the architecture model that is required for the device's bus type.

Start this test against a device from the Device Console window in DTM. Device Console fills in the test's WDKDeviceID parameter with the instance path of the device that you select. The device that you select should be a storage adapter and should be configured on the test client, with storage attached.

Command syntax

Command option | Description
StorImports /device "[WDKDeviceID]" | Runs the test against a device instance that is currently installed on the computer.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
link.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\legacybinary</p>
mspdb80.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\legacybinary</p>
storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
StorImports.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device instance path of test device
LLU_NetAccessOnly | Credentials for test share access
LLU_LclAdminUsr | Credentials for test execution


Storage Performance USB3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/539bca7e-c42e-4ae8-980f-ca98e34a99ab

This test is a special variant of the Storage Performance CS test which verifies that a USB 3.0 storage device complies with the USB 3.0 Version 1.0 specification and that the device conforms to performance requirements. For more information about this test, see Storage Performance CS.

Test details
Specifications
  • Device.Storage.Hd.Usb3.Compliance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Removable Storage Testing Prerequisites. In addition, this test requires the following:

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing or the troubleshooting steps in Storage Performance CS.

More information

Command usage

Command | Description
StorPerf.exe /DriveLetter [StorageDriveLetter] /DeviceTag USB3_BOT_Data | Runs the USB testing on the specified drive. DeviceTag can also be USB3_UAS_DATA for UAS-capable drives.

Command syntax

Command option | Description
/DriveNumber <number> | Physical drive number of device under test. Example: /DriveNumber 0
/DriveLetter <letter> | Drive letter of device under test. Example: /DriveLetter C
/DeviceTag <value> | Identifies which TestcaseGroup or ComparisonGroup to select as the input from the configuration xml files. This parameter is case-sensitive and is used for indexing both the policy and comparison xml files. Example: /DeviceTag CS_Boot
/PolicyXML <value> | The policy xml file name. Defines all of the parameters for running the I/O workloads. If no option is given, the default file will be generated. Example: /PolicyXML CSPolicy.xml
/Compare <value> <value> | The two xml files to compare. These must have been generated from a previous run of this test. The "FinalTestCasesAggregated.xml" files should be used instead of the "AllTestCasesAggregated.xml" files since there is no guarantee that the number of iteration is the same for each test case. Example: /Compare FinalTestCasesAggregated_42f4.xml FinalTestCasesAggregated_a732.xml
/CompareXML <value> | The comparison xml file name. Defines all of the parameters for running the comparison. If no option is given, the default file will be generated. Example: /CompareXML CSCompare.xml
/PrintPolicy | Prints the policy table.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
StorPerf.exe | <[testbinroot]>\NTTest\driverstest\storage\wdk</p>
StorageAssessment.exe | <[testbinroot]>\NTTest\driverstest\storage\wdk\StorageAssessment</p>
StorageDevices.dll | <[testbinroot]>\NTTest\driverstest\storage\wdk</p>
StorageParameters.exe | <[testbinroot]>\NTTest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
DeviceID | Either DriveLetter or DriveNumber
DeviceTag |
WDKDeviceID | Instance path of device to test
QueryUAS | Query Gatherer for UAS detection
DiskDeviceObjLink | Assigned by Create Storage Parameters


Storage Query Property (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a2092b32-1f8c-46d8-bae1-767efbb2b142

This test verifies a storage adapter driver's implementation of IOCTL_STORAGE_QUERY_PROPERTY for both the StorageDeviceProperty and StorageAdapterProperty.

Test details
Specifications
  • Device.Storage.Controller.ClassCode
  • Device.Storage.Controller.InfFile
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Storage Adapter or Controller Testing Overview.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

Command syntax

Command option | Description
QueryProperty.exe /device "[WDKDeviceID]" /busType "[QueryStorage_bus_type]" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
QueryProperty.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
Storagedevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test
LLU_NetAccessOnly | Credentials to access test fileshare
LLU_LclAdminUsr | Credentials to logon to test client
WDKDriverName | Driver Name
QueryStorage_bus_type | Storage bus type


Thin Provisioning Performance Test - NTFS (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e127f5c0-6cf7-413b-8051-33eeee890782

This automated test evaluates the NTFS performance of the Unmap command for thin provisioning LUNs.

Test details
Specifications
  • Device.Storage.Hd.ThinProvisioning.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Benchmark
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The test requires a thin provisioned LUN device setup on the client machine. The LUN must satisfy the following requirements:

  • The drive should be a non-boot drive. The test is destructive. It will prepare the disk with correct partition and formatting for the test.

  • The drive must support UNMAP (10) command. The VPD B0h page's LBPU bit is set to 1. The test will send down Unmap commands by using the DATA SET MANAGEMENT's Trim command.

  • Make sure that there is a separate drive available to be used as a logger drive. The test will automatically pick the logging drive. It is important to minimize the amount of activity that occurs on the drive (outside of the logo test). Because this is a performance test, outside activity can affect the results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Error Description/Workaround

Test failed and went to check WTT Trace

How to check log files upon test failure:

  • View child job results of Run Trim Performance Test.

  • View job logs of Run Trim Performance Test - Library.

  • Open the log file TrimPerf.wtl and check for messages that might describe/resolve the problem.

  • Copy the .wtl log file. This is the WTT trace that is described in the WTT Trace section.

No metrics found

The test depends on Storport ETW tracing being enabled to get the command completion metrics.

Make sure that no other Storport ETW traces are currently logging. Only one Storport ETW trace can be active at a time.

Test failed with a "write protected" error

  • Make sure that the thin provisioned LUN is not write-protected.

  • Make sure that the thin provisioned LUN is always online while the test is running. "Write protected" usually means the LUN goes offline.

Test warns: "The test drive does not support trim".

  • Check the thin provisioned LUN to make sure VPD B0h page's LBPU bit is set to one (or run Thin Provisioning SCSI Compliance Test (LOGO) to verify the compliance of the LUN).

  • Try to send an Unmap command by using DATA SET MANAGEMENT's Trim command.

  • Run the test again.

Test warns: "Read/write max latency exceeds logo requirement of 500.0 ms".

The test sends IO together with Unmap when it measures the max IO latency. The virtual address of IO and Unmap are not interleaving.

More information

Test metrics

Command Test metrics

Unmap command

All Unmap commands shall be completed in less than 500ms.

IO command(with Unmap sending at the same time)

  • All Read/Write commands shall be completed in less than 500ms.

  • 98.5% of IO commands shall be completed in less than 100ms.

Currently this test only gives warnings if the thin provisioned LUN under test fails to meet the bar described in the preceding table. The test never fails on this, but you must make sure that the LUN supports UNMAP (10) command, and that the LUN never goes offline when the test is running.

To manually reproduce the test

  1. Open the Registry Editor and follow the path: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI\Disk&Ven_[name of drive under test]\[device instance path of the thin provisioned LUN]\Device Parameters\Storport

  2. Right click Storport, click New, and click DWORD (32-bit) Value.

  3. Name the key EnableLogoETW, and set the value to 1.

  4. Replug the drive under test or reboot the machine to enable the registry key.

  5. Copy TrimPerf.exe, EtwProcessor.dll, Wex.Common.dll, and Wex.Communication.dll files to the local drive.

  6. Run the test on a command line (see Command Syntax).

Command syntax

Command option | Description
TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType [DeviceType] /Scenario [Scenario] /DiskSize [DiskSize] /Cooldown [Cooldown] | Runs the test.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
TrimPerf.exe | <[<[testbinroot]>]> \nttest\driverstest\storage\wdk</strong>
EtwProcessor.dll | <[WHCK\TAEFBinRoot]></p>
Wex.Common.dll | <[WHCK\TAEFBinRoot]></p>
Wex.Communication.dll | <[WHCK\TAEFBinRoot]></p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
Destructive | (0,1) 0=Passive, 1=Destructive
StorageDriveNumber | Storage drive number
QueryStorage_bus_type | Storage bus type


Thin Provisioning Performance Test - RAW Disk (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90fe44c8-f457-4d0f-84cb-500eeaf17fb6

This test verifies that target devices that have a thin provisioning feature meet Windows requirements.

NOTE

This test applies to test that run against raw hard disks. Thin Provisioning Performance Test - RAW Disk (LOGO) collects performance data over raw disks.

Test details
Specifications
  • Device.Storage.Hd.ThinProvisioning.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Benchmark
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

In addition, before you run the test, please create a thin provisioned LUN and a full provisioned LUN and make sure both LUNs are online initialized raw disks. Set the threshold for thin provisioned LUN to be 70 percent.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Error | Description/Workaround
Thin provisioned LUN or full provisioned LUN throughput is 0.000000 | If the log file shows that thin provisioned LUN and/or full provisioned LUN read/write throughput is 0.000000, then the LUNs might be offline. Check the thin/full provisioned LUNs to make sure they are both online when the test runs.
Thin provisioned LUN throughput is less than 90% of full provisioned LUN | If the log file shows that the thin provisioned LUN read/write throughput is less than 90 percent of full provisioned LUN, check the thin provisioned LUN IO implementation. Thin provisioned LUN should have similar throughput as full provisioned LUN.
Failed to find certain system events | If the log file shows that the test failed to find certain events, check the implementation of threshold notification events and permanent resource exhaustion event in Plan and Deploy Thin Provisioning.
Test failed but logs have no failures | Make sure you are logging in the HLK client machine as Administrator while the test is running.

More information

The performance test runs a stress test to collect performance data. IO throughout performance of thin provisioned LUN should not be below 90% of IO throughput performance of a full provisioned LUN. Currently, if the test fails, the logo test does not fail.

Performance test needs to run DiskIO test over thin provisioned LUN and full provisioned LUN to collect the statistics data. It does sequential read/write/verify IO and random read/write/version IO operations for both LUNs. After each round of writing, the test unmaps or formats the LUNs. The test starts a process to run DiskIOV2.exe and parse the xml files to collect data. After each round of tests, the test checks to see if there is any system event for threshold notification hit.

The test also checks the system events to get threshold notification and performance resource exhaustion. The following events are checked:

Event ID | Information
144 | Threshold notification without additional information
145 | Threshold notification without specific information
146 | Threshold notification with used LUN capacity and available LUN capacity information
147 | Threshold notification with used LUN capacity and available pool capacity information
148 | Threshold notification with used pool capacity and available LUN capacity information
149 | Threshold notification with used pool capacity and available pool capacity information
150 | Permanent resource exhaustion event

This is a pass-only test. It will not give errors even if the disks (either thin provisioned LUN or full provisioned LUN) goes offline. The test only prints information to help you maintain the performance of a thin provisioned LUN.

Command syntax

Command option | Description
Thinprovision.exe /scenario performance /thindisk: [TPDiskDeviceObjLink] /fulldisk [FPDiskDeviceObjLink] /logo | Runs the test.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
DiskIO.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>
FillVolume.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk\thinprovision</p>
StorageDevices.dll | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk</p>
Thinprovision.exe | <[testbinroot]>\nttest\DRIVERSTEST\storage\wdk\thinprovision</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
TPDiskDeviceObjLink | The thin provisioned LUN
FPDiskDeviceObjLink | The full provisioned LUN
LLU_NetAccessOnly |
LLU_LclAdminUsr |
Destructive | (0,1) 0=Passive, 1=Destructive


Thin Provisioning SCSI Compliance Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6ca1543-aee5-4390-8f16-f3a5dd5d35e7

This test verifies that a storage array can properly support the thin provisioning feature.

Test details
Specifications
  • Device.Storage.Hd.ThinProvisioning.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Before you run the test, make sure that the thin provisioned LUN is online initialized raw dis. Set the threshold for thin provisioned LUN to be 70 percent.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

This test ocuses on measuring the SCSI device compliance in Windows. The goal is twofold - to ensure that SCSI devices supported on Windows fully and completely adhere to the SCSI specifications set forth in SPC-4 and SBC-3, and to allow Microsoft and Microsoft partners to fully respect and comply with these standards. Maintaining compliance leads to a stronger and more reliable overall system.

NOTE

For more information about these specifications, visit the Technical Committee T10 SCSI Storage Interfaces website.

The test sends the following commands to the device:

  1. Inquiry VPD 0xB0, 0xB2 pages

  2. Log Sense

  3. Get LBA Status

  4. Unmap

  5. Read Capacity 16 (not required)

SCSI commands

  • INQUIRY (see SPC-4 Section 6.6)

  • For page code B0h:

    • Support INQUIRY B0h VPD page command (status is GOOD)

    • PAGE LENGTH = 0x3C

    • MAXIMUM UNMAP LBA COUNT > 0

    • MAXIMUM UNMAP BLOCK DESCRIPTOR COUNT > 0

  • For page code B2h:

    • Support INQUIRY B2h VPD page command (status is GOOD)

    • If DP = 1, then PAGE LENGTH = 0x4

  • LOG SENSE (see SPC-4 Section 6.8)

    • Support LOG SENSE command (status is GOOD)

    • The log page's DS (Disable Save) bit is 1

    • The log page's SPF (Subpage Format) bit is 0

    • The log page's SUBPAGE CODE (byte 2) is 0

    • The log page's PAGE LENGTH is divisible by 12

    • Log parameter's FORMAT AND LINKING is 0x3

    • Log parameter's PARAMETER LENGTH = 0x8

    • Log parameter's PARAMETER CODE is between 0x1 and 0xFF

  • GET LBA STATUS (see SBC-3 Section 5.4)

    • Support GET LBA STATUS command (status is GOOD)

    • LBA status descriptor page length > 20

    • STARTING LOGICAL BLOCK ADDRESS + NUMBER OF LOGICAL BLOCKS < total number of LBAs

  • UNMAP (see SBC-3 Section 5.27)

    • Support UNMAP (10) command (status is GOOD)

    • After random WRITE (10) commands, sending down UNMAP, GET LBA STATUS should return some deallocated LBAs

    • Mapped resource should be reduced after sending down UNMAP command

  • READ CAPACITY (16) (see SBC-3 Section 5.16)

    This command is not required. Test gives warning only.

    • LBPME bit matches between READ CAPCITY (16) and INQUIRY B2h VPD page

    • LBPRZ bit matches between READ CAPCITY (16) and INQUIRY B2H VPD page

Command syntax

Command option | Description
Scsicompliance.exe /device [DeviceID] /verbosity [LoggingVerbosity e.g. 4] /scenario ThinProvision /operation [OperationId] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
TPDiskDeviceObjLink | Assigned by Create Storage Parameters.
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name.
ScsiComplianceDevice | Device path
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | operation option
Destructive | (0,1) 0=Passive, 1=Destructive


Thin Provisioning Threshold and Resource Exhaustion Test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac970c9b-8d76-4cd6-bc8a-3efdd8ec6fb7

This test verifies that target devices with thin provisioning feature meet Windows requirements.

Test details
Specifications
  • Device.Storage.Hd.ThinProvisioning.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Compatibility
Timeout (in minutes) | 18000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Before you run the test, please make sure the thin provisioned LUN to be online initialized raw dis. Also, you should set the threshold for the thin provisioned LUN to be 70 percent (default). If the threshold is fixed, you should specify that threshold when running the test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The end to end scenario test would do threshold and resource exhaustion test. The main approach is to properly trigger the threshold notification/permanent resource exhaustion and check the sense key. When threshold is hit, we will get the log page to calculate whether the value to be at least no less than the value set for threshold. For temporary resource exhaustion, we just make this scenario to be optional, since some storage device may handle this scenario decently not to return any sense key.

Command syntax

Command option | Description
Thinprovision.exe /scenario exhaustion /thindisk "[TPDiskDeviceObjLink]" /percent "[TPDiskThresholdPercent]" /logo | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Thinprovision.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\thinprovision</p>

Parameters

Parameter name | Parameter description
WDKDeviceID |
TPDiskDeviceObjLink | The thin provisioned LUN
LLU_NetAccessOnly |
LLU_LclAdminUsr |
Destructive | (0,1) 0=Passive, 1=Destructive
TPDiskThresholdPercent | The percentage of thin provisioned LUN


Trim Performance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1492035a-c515-472e-8cd1-2878d4fec369

This test evaluates the performance of the trim command.

Test details
Specifications
  • Device.Storage.Hd.Trim.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Benchmark
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

The device supporting trim must be attached to the appropriate controller. The job will prepare the disk with the correct partition and formatting for the testing. The test is destructive and therefore the disk cannot be the boot drive. Also, since the test logs large amounts of data, ensure that there is a separate drive available to be used as the logger drive. The test will automatically pick the logging drive. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this is a performance test, outside activity may affect the results. Additionally, preconditioning the drive by writing data to fill up the drive before starting the test may give more consistent results. This is dependent on the drives implementation and may not be advantageous to all drives.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

  • Check WTT Trace

    • View Task Log of Run Trim Performance Test.

    • Open the log file TrimPerf.wtl.

    • Check for messages that may solve the issue.

    • Copy the .wtl log file. This is the WTT trace described in the WTT Trace section.

  • Check launched command results

    • Browse Job Logs of Trim Performance Test (LOGO).

    • Open the LaunchCommand.result.

    • If the error is related to launching a process, determine why logman or tracerpt failed.

  • No metrics found

    • The test depends on Storport ETW tracing being enabled in order to get the command completion metrics. See the ETW Trace section for more information about enabling this tracing.

    • Ensure no other Storport ETW traces are currently logging. Only one Storport ETW trace can be active at a time.

  • If you get the error message "The test drive does not support trim", try the following:

    • Ensure that the SATA SSD's IDENTIFY DEVICE data word 169 bit 0 is set to one.

    • Try to send a Trim command via DATA SET MANAGEMENT.

    • Run the test again.

  • If the test failed because the read and write maximum latency exceeded 500 milliseconds, try the following:

    • Check the IO latency without Trim. Try to lower the latency below 500 milliseconds.

    • Check the IO latency with presence of Trim. Try to lower the latency below 500 milliseconds.

  • If you want to debug the failure by running particular test cases, you may try the following command line options:

    • Display all the test cases with numbers: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType StorConsumer /PrintTestCaseName

    • Run particular test case by test case number: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType StorConsumer /Precondition F /TestCase [TestCaseNumber]

  • If you want to debug the failure by running particular pure Trim scenario, you may try the following command line options:

    • The binary has unit test options: TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType StorConsumer /Precondition F /UnitTest T /RangeCount [NumberOfRangesPerTrim] /SizeCount [SizeOfEachRange] /SizeUnit Sector /TrimCount [NumberOfTrims]

    • /RangeCount: The number of ranges per Trim command

    • /SizeCount: The size of each range in /SizeUnit

    • /SizeUnit: The granularity of /SizeCount, for SATA SSD, the granularity is sector.

    • /TrimCount: The number of Trims sent in the test case.

  • If you want to debug the failure faster, try disable the preconditioning (fill up the drive to 90% full, takes long time) by adding /Precondition F parameter as follows:

    • TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LoggerDriveLetter]: /DeviceType StorConsumer /Scenario Performance /DiskSize 0 /Cooldown 2 /Precondition F

For more troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The job takes in the device instance ID of the device under test and converts the device instance ID to a physical drive number. The job partitions and formats the drive to get it into the configuration needed for testing. The test will run through a series of test cases each mapped to items in the requirements. The test cases are self-contained and are run sequentially. A list of test cases can be obtained by using the PrintTestCaseName command line option with the appropriate device specified. Each of these test cases can be run on the command line using the test in standalone mode for further testing or debugging.

The Trim Performance test stores a policy table defining for each type of device what performance tests are to be run and what the appropriate metrics should be. Once the appropriate items in the table are selected, the test will sequentially spawn threads defined in the table for that device. Each thread will execute according to the parameters specified in the table. Once the stop conditions for each of the threads has been satisfied, the threads will stop execution and the results will be parsed to generate the pass/fail logs.

The test generates large performance logs and in order to not affect the performance of the drive being tested, these logs are written to a separate drive. The drive is automatically chosen by the job, but can alternatively be specified on the command line

The test commands are as follows:

Trim command

All trim commands should be completed in less than 500 milliseconds.

IO command (with Trim sending at same time)

  • All read and write commands complete in less than 500 milliseconds.

  • 98.5% of I/O commands complete in less than 100 milliseconds.

Command syntax

Command option | Description
TrimPerf.exe /DriveNumber [StorageDriveNumber] /LogDriveLetter [LogDriveLetter]: /DeviceType StorConsumer /Scenario Performance /DiskSize 0 /Cooldown 2 |
Runs the test. |
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
TrimPerf.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
Etwprocessor.dll | <[taefbinroot]></p>
Wex.common.dll | <[taefbinroot]></p>
Wex.communication.dll | <[taefbinroot]></p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Instance path of device to test.
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
Destructive | (0,1) 0=Passive, 1=Destructive
StorageDriveNumber | Storage drive number
QueryStorage_bus_type | Storage bus type


Trim Zero-Range Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9481296-1c3d-423e-aeb1-55db6e843e22

This test verifies hard disk trim functionality if the device includes ATA non-NCQ Trim support.

Test details
Specifications
  • Device.Storage.Hd.ReadZeroOnTrimUnmap.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

Command syntax

Command option | Description
Te.exe flt.dll /p:Volume=[StorageDriveLetter]: /logFile:fileleveltrim.wtl /enablewttlogging | Runs the test
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Flt.dll | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
Te.exe | <[testbinroot]>\Testing\Runtimes\TAEF\x86</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | DeviceID of test device
StorageDriveLetter | DriveLetter to run test against
LLU_NetAccessOnly | LLU_NetAccessOnly
LLU_LclAdminUsr | LLU_LclAdminUsr
Destructive | (0,1) 0=Passive, 1=Destructive
DiskDeviceObjLink | Assigned by Create Storage Parameters.


USB 2.0 & 3.0 SCSI Compliance test (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e7b9290-e8ae-40fd-bd46-34c3a06f841c

This automated test verifies Small Computer System Interface (SCSI) Command Descriptor Blocks (CDBs) sent to the Universal Serial Bus (USB) device.

Test details
Specifications
  • Device.Storage.Hd.Usb3.Compliance
  • Device.Storage.Hd.Usb.Compatibility
  • Device.Storage.Hd.Uas.Compliance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

The test writes the results to the log file Scsicompliance.wtl and Scsicompliance.wtl.txt. Use the results to determine:

  • If a device is compliant with the SCSI specification.

  • The optional SCSI commands that are supported by a device.

To pass, the USB device must support every mandatory command and must be fully compliant with those commands. Each command has a different threshold for pass or fail, and the expectations are specified explicitly in the test and in the log file.

Optional commands are also tested. If a device supports the optional commands and the commands are found to be non-compliant, the test fails. If the device does not support optional commands, the test passes.

Optional commands are also tested. If a device supports the optional commands and the commands are found to be non-compliant, the test fails. If the device does not support optional commands, the test passes.

During the test, if you are having trouble removing a LUN that is failing or are unable to create a LUN from the storage controller, follow these steps:

  1. Prior to running this test, verify that the storage device works properly. Open Diskmgmt.msc and select disk. Make sure you can put the device Online and in initialized state.

  2. Restart the Windows HLK test computer.

  3. Select and rerun the USB SCSI Compliance Test. Do not run any test before it.

  4. If the test failed, run the individual failing command data blocks (cdbs) one at a time with the logging verbosity level set to 4 (the highest level of test logging). This will show what data was sent and what data was returned. We have seen previous instances where test fail after several cdbs were completed but pass standalone. If this occurs, there is a problem in the firmware or the test. There might have been a device reset leading to the device falling off the bus and resulting in subsequent commands to fail. To resolve this issue, follow these steps:

    1. Copy the test binary (Scsicompliance.exe) from the Windows HLK controller. This file is located here: \\controllername\tests\[processorarchitectureofyourclient]\NTTEST\DriversTest\storage\wdk\

    2. Copy the wttlog.dll file from the Windows HLK controller. This file is located here: \\<controllername>\Tests\<processorarchitectureofyourclient >\wtt

    3. Place both of these files on the test computer in a separate folder.

    4. From a command prompt, from the directory containing the test binary, type the following command: Scsicompliance.exe /device <deviceID> /verbosity 4 /operation test /scenario <scenario> /Version <version> /protocol <protocol> /CDB <failingcdbname>

      NOTE

      DeviceID, scenario, version and protocol values can be found by checking the repro line within the test log. The failingcdbname can be found by running the test binary with the /?option (scsicompliance.exe /?).

    5. Go back to the same directory and review the results to see if you can determine the reason for the test failure.

    6. If you need additional help, collect the txt and wtl logs and share the logs with Microsoft Customer Support Services.

More information

Command syntax

Command option | Description
Scsicompliance.exe | The options for the test are listed below.
/device | The device which test is to run on. Example: /Device <physical device path>
/operation | The operation to run. Example: /Operation Test
/scenario | The feature to be tested for. Example: /Scenario USBDisk
/version | Device's USB Version number. Example: /version 3
/protocol | Device's USB protocol. Example: /protocol UAS
/verbosity | The level of logging verbosity. Larger values cause more verbose output. Example: /Verbosity 4
NOTE

For command line help for this test binary, type /?.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name: Possible values: USBDisk, USBCardReader
Options | Options
ScsiComplianceDevice | Device path
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | Operation to run
Version | USB Version: Possible values: 2, 3
Protocol | USB Protocol: Possible values: BOT, UAS
QueryIsUsb3 |
QueryUAS |
QueryRMB |
Destructive | (0,1) 0=Passive, 1=Destructive
QueryUFDRotationalMedia | Queries gatherer to retrieve property
QueryWTGDevice | Queries gatherer to retrieve property
RM | Rotational media: 0 or 1


USB 2.0 & 3.0 SCSI Compliance test for UAS on EHCI (LOGO)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4bc4396c-7678-4920-b8b2-7e59d680244e

This test verifies Small Computer System Interface (SCSI) Command Descriptor Blocks (CDBs) sent to the Universal Serial Bus (USB) UAS device.

Test details
Specifications
  • Device.Storage.Hd.UasOnEHCI.BasicFunction
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hard Disk Drive Testing Prerequisites.

In addition this test requires a UAS device connected to a USB 2.0 Controller.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Also, the test writes the results to the log files Scsicompliance.wtl and Scsicompliance.wtl.txt. You can use the results to determine:

  • If a device is compliant with the SCSI specification

  • The optional SCSI commands that are supported by a device

To pass, the SCSI device must support every mandatory command and must be fully compliant with those commands. Each command has a different threshold for pass or fail, and the expectations are specified explicitly in the test and in the log file.

Optional commands are also tested. If a device supports the optional commands and the commands are found to be non-compliant, the test fails. If the device does not support optional commands, the test passes.

NOTE

Errors from this test occur via issues identified in the log file and in bugchecks produced through stressing the driver under test.

During the test, if you are having trouble removing a LUN that is failing or are unable to create a LUN from the storage controller, follow these steps:

  1. Prior to running this test, verify that the storage device works properly. Open diskmgmt.msc, select the disk, and make sure that you can put the device Online and in Initialized state.

  2. Restart the Windows HLK test computer.

  3. Select and rerun the SCSI Compliance Test 2.0. Do not run any test before it.

  4. Run the SCSI Compliance Test (not the SCSI Compliance Test 2.0 (LOGO)) on the same test client and same test storage device. If the test fails again, verify that the storage device is working properly.If the test fails during steps 3 and 4, run the individual failing command data blocks (cdbs) one at a time with the logging verbosity level set to 4 (the highest level of test logging). This will show what data was sent and what data was returned. A test can fail after several cdbs are completed but pass standalone. If this occurs, there is a problem in the firmware or the test.

If you have a device reset that results in the device falling off the bus and subsequent commands to fail, follow these steps:

  1. Copy the test binary (Scsicompliance.exe) from the Windows HLK controller. This file is located at \\controllername\tests\[processorarchitectureofyourclient]\NTTEST\DriversTest\storage\wdk\

  2. Copy the wttlog.dll file from the Windows HLK controller. This file is located at \\<controllername>\Tests\<processorarchitectureofyourclient>\wtt

  3. Place both of these files on the test computer in a separate folder.

  4. From a command prompt, from the directory containing the test binary, type the following command: Scsicompliance.exe /device <deviceID> /verbosity 4 /operation test /scenario <scenario> /CDB <failingcdbname>

    NOTE

    DeviceID and scenario values can be found by checking the repro line within the test log. The failingcdbname can be found by running the test binary with the /?option (scsicompliance.exe /?).

  5. Go back to the same directory and review the results to see if you can determine the reason for the test failure.

  6. If you need additional help, collect the txt and wtl logs and share the logs with Microsoft Customer Support.

More information

Run the test as an HLK Manager job.

Command syntax

Command option | Description
Scsicompliance.exe | The options for the test are listed below
/device | The device which test is to run on Example: /Device <physical device path>
/operation | The operation to runExample: /Operation Test
/scenario | The feature to be tested forExample: /Scenario Common
/version | Device's USB Version numberExample: /version 3
/protocol | Device's USB protocolExample: /protocol UAS
/verbosity | The level of logging verbosity. Larger values cause more verbose output.Example: /Verbosity 4
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
Scsicompliance.exe | <[testbinroot]>\nttest\driverstest\storage\wdk\nttest</p>

Parameters

Parameter name | Parameter description
DiskDeviceObjLink | Device path of disk to test EX: \\.\disk0
WDKDeviceID | Instance path of device to test
LoggingVerbosity | LoggingVerbosity: Detail of logging. Levels are cumulative. 0 = Assertions and results. 1 = Details (default). 2 = CDBs , data, and sense info. 3 = Debug and detailed Mode page information. 4 = Memory usage
ScenarioId | Scenario test name: Possible values: USBDisk, USBCardReader
Options | Options
ScsiComplianceDevice | Device path
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
OperationId | Operation to run
Version | USB Version: Possible values: 2, 3
Protocol | USB Protocol: Possible values: BOT, UAS
QueryIsUsb3 |
QueryUAS |
QueryRMB |
Destructive | (0,1) 0=Passive, 1=Destructive
QueryUFDRotationalMedia | Queries gatherer to retrieve property
QueryWTGDevice | Queries gatherer to retrieve property
RM | Rotational media: 0 or 1


Windows Hyper-V NPIV Test 01 - Hba Status

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75d7d270-c8df-4825-af3b-1b3d6691cc8c

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Hardware-based Raid Systems (Fibre Channel, SAS, SCSI, Serial ATA) Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.


Windows Hyper-V NPIV Test 02 - Create Port

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/848d96b4-7023-40bd-8120-3e5369096f4e

Verify that a Virtual Port can be created using valid parameters

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 03 - Create Invalid Port WWN

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c96bb9ae-86f4-4b2c-8fc7-a58d777835ea

Verify that a Virtual Port cannot be created with invalid WWPN

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 04 - Create Physical WWPN

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/54978e00-b079-4468-b531-28e30bc698f7

Verify a Virtual Port cannot be created conflicting with the physical port's WWPN

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 05 - Create WWPN In Use

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b896f3a4-e31b-4fd5-9456-36765b8eae60

Verify that the same WWPN cannot be created twice

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 06 - Create And Remove Port

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a56a3f04-b2b1-421c-9bd1-cbccd0bc994f

Verify that a virtual port may be created and then removed using valid parameters

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 07 - Remove Bad Port

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/296ac37d-33a2-454e-8420-8663a72e239e

Verify that a non-existant virtual port cannot be removed

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 08 - Create And Remove Port Loop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ebfc898-301f-4533-aa8b-c2bfbfcd8640

Verify that a valid virtual port may be created & removed, repeatedly

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 09 - Create Max Number of Ports

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d49ec959-2e3a-4aff-aa4b-b180b3c5b106

Verify that the max number of virtual ports (according to MSFC_FibrePortNPIVCapabilities) may be created successfully

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 10 - Rescan Port

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89bc1df7-24c2-4083-a739-6f54629b73d9

Create a virtual port, and ensure that rescans succeed. Also attempt to rescan nonexistant ports and check for failure.

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 11 - Rescan Port Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/899d5df9-cf5e-4deb-809c-cbad228a8661

Tests overlapped rescan operations on a virtual port

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 12 - Concurrent Same Port Creation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a83d2706-85be-49f3-a14a-1f0b3e750017

Ensures that the same virtual port cannot be created simultaneously from multiple WMI callers

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 13 - Concurrent Port Creation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5543b61-d0d3-414f-85c1-66b864e02062

Ensures that multiple valid virtual ports may be created simultaneously from multiple WMI callers

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


Windows Hyper-V NPIV Test 14 - Concurrent Port Removal

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23a66a28-89a8-4f98-a408-2aad81cf759a

Ensures that the same virtual port cannot be removed simultaneously from multiple WMI callers

Test details
Specifications
  • Device.Storage.Controller.Fc.Npiv.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation


WindowsToGo Device Basics Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/959e0dce-acfb-433f-a1bd-496dc9c7791d

This test validates that the USB storage device meets the basic requirements of the Windows To Go feature. USB storage devices that do not support Windows To Go do not need to run this test. This test checks that the device has the following:

  • Provides at least 20 GB of usable storage space.

  • Correctly implements a Microsoft OS Descriptor identifying itself as supporting Windows To Go.

  • Operates at SuperSpeed when plugged into a USB 3.0 port.

  • Reports itself as fixed drive and not a removable drive.

  • If a secondary function is implemented, that secondary function is a smart card reader.

  • Only Microsoft USB 3.0 and storage drivers are used.

  • Exposes its write cache to the operating system.

  • Device uses the Bulk Only Transport (BOT) protocol and does not implement the USB Attached SCSI (UAS) protocol.

  • Does not implement the IEEE1667 standard.

  • Only exposes a single LUN.

Test details
Specifications
  • Device.Storage.Hd.WindowsToGoCapableUSBDrive.WindowsToGoCapableUSBDrive
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Removable Storage Testing Prerequisites.

The device under test must be plugged into a USB 3.0 port to run this test. The machine running the test should have no other USB storage devices attached.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If the device test does not show up in HLK Studio, ensure that the Microsoft OS Descriptor Extended Property named WindowsBootCapable of type DWORD is set to 1. For more information about implementing Microsoft OS Descriptors with USB Devices, see Microsoft OS Descriptors.

If the device fails the ExposeWriteCache test case, ensure that the device exposes their write cache by implementing mode page 08. To implement this, do the following:

  • Implement MODE SENSE in compliance with SCSI Primary Commands 4 (SPC-4) rev 36e sections 6.13 and 6.14.

  • Implement MODE SELECT is in compliance with SCSI Primary Commands 4 (SPC-4) rev 36e sections 6.11 and 6.12.

  • Implement the caching mode page in compliance with SCSI Block Commands 3 (SBC-3) rev 33 section 6.4.5.

If the device fails the SuperSpeed test case, ensure that the device supports USB 3.0 and operate at SuperSpeed when plugged into a USB 3.0 port. Use the following to help troubleshoot this:

  • Ensure that the device is firmly connected to the USB 3.0 port.

  • The electrical properties of the device comply with section 6.8.3 of the USB 3.0 specification.

  • The device's USB 3.0 handshake must comply with section 10.16.2 of the USB 3.0 specification.

More information

File list

File | Location
Bootcapable.dll | <testbinroot>\pw_device_logo</p>

Parameters

Parameter name | Parameter description
CopyPathPWLogoDir |
LLU_LclAdminUsr |
LLU_NetAccessOnly |
TAEFSource |


WindowsToGo Device Boot Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19cf07d7-072b-4fba-b8c4-5104ad61b0a5

This test validates that the USB storage can be provisioned with a Windows image and the following requirements are met:

  • Boot into Windows from the device.

  • Operates at SuperSpeed when plugged into a USB 3.0 port.

  • Enter and resume from S3 sleep.

  • Enter and resume from S4 hibernate.

Test details
Specifications
  • Device.Storage.Hd.WindowsToGoCapableUSBDrive.WindowsToGoCapableUSBDrive
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Scenario
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Removable Storage Testing Prerequisites.

The hardware requirements are as follows:

  • The device under test must be plugged into a USB 3.0 port to run this test.

  • The computer running the test should have no other USB storage devices attached.

  • The computer running the test should be certified for Windows 8 or later.

The software requirements are as follows:

  • User must copy a valid Windows Image (WIM) file to the test computer. It must include any drivers needed to use the system's hardware.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If you cannot boot from the Windows To Go device, use the following to troubleshoot this issue:

  • Ensure that the Windows image does not include any 3rd party USB drivers.

  • Ensure that the system you are using to run this test has the latest firmware.

  • If boot was interrupted by an INACESSIBLE_BOOT_DEVICE stop error, the UFD likely became unresponsive after receiving a certain sequence of commands. Take a USB trace to determine what caused the UFD to become unresponsive.

  • If the system did not attempt to boot the Windows To Go drive, the UFD likely did not enumerate quickly enough for the system's firmware. Take a USB trace to determine what caused the system to abort its attempt to boot the UFD.

  • If you have taken these debugging steps and believe your device is behaving correctly, run the test again with a certified device and compare the results.

If the device cannot enter S3 sleep, your WIM file may not have the correct graphics drivers installed. Use the following steps to see what is blocking S3 sleep:

  • Provision a Windows To Go device with the same image you use and then boot from it.

  • Open a command prompt, and the run the following command: powercfg a

  • Note which device is blocking S3 sleep, add the appropriate driver to the WIM file, and run the test again.

If the computer lost state when resuming from S3 sleep or S4 hibernate, this could mean that the device lost power before all of the data in its cache could be written. Ensure that your device completely writes its cache to non-volatile storage before powering down.

If the computer resumes to the host operating system instead of the Windows To Go operating system from hibernation, the computer had a problem booting the Windows To Go device and the host computer was booted instead. Take a USB trace to determine what caused the computer to revert back to the host operating system.

If you receive Surprise Removal events during the test that were not caused from the Windows To Go device being unplugged and then plugged back in, the Windows To Go device may not be properly maintaining its link to the host operating system per the USB 3.0 specification or the Windows To Go device may not be properly saving all data to non-volatile memory when the system enters a sleep state. Take a USB trace to determine what caused the Surprise Removal events.

More information

File list

File | Location
boottest.dll | <testbinroot>\pw_device_logo</p>
bootcapable.dll | <testbinroot>\pw_device_logo</p>
Unattend.xml | <testbinroot>\pw_device_logo</p>
Powertst.exe | <osbinroot>\pwrtest</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
LLU_LclAdminUsr |
TestMode |
WimPath | Full path to a Windows Image file (WIM). Must be full Windows, not WinPE
WimIndex | Image within the WIM to use. Should match host computer architecture (x86/amd64)
TAEFSource |


WindowsToGo Performance Assessment

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd5144bd-09d5-4c7d-9e55-8036f57ae902

This test validates that the USB storage device meets the performance requirements of Windows To Go. USB storage devices that do not support Windows To Go do not need to run this test. This test checks the following performance requirements:

  • Random 4 KB Write IOPs >= 2000 (rotational drives exempt)

  • Random 4 KB Read IOPS >= 2000 (rotational drives exempt)

  • Sequential Write Speed >= 80MB/s

  • Sequential Read Speed >= 80MB/s

  • Max I/O Latency < 250 milliseconds

  • Maximum of 10 seconds sum-total of user-perceivable I/O latencies over any 1 hour period of a user-representative workload, where a user-perceivable I/O is defined as having a latency of at least 100 milliseconds

Test details
Specifications
  • Device.Storage.Hd.WindowsToGoCapableUSBDrive.WindowsToGoCapableUSBDrive
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Benchmark
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Storage additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Removable Storage Testing Prerequisites. In order for the device to indicate that it seeks Windows To Go certification it must implement the MS OS Descriptor extended property WindowsBootCapable per the WindowsToGoCapableUSBDrive requirement. If this descriptor is not set on the device then this test will not appear.

This test formats the device. Any data stored on it will be lost. Back up any important data before running the test.

NOTE

You must insert the USB drive into a USB 3.0 port to run this test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If you receive an error message saying "Not all of the metrics required were found in the logs", remove any unnecessary USB devices attached to the system, reboot, and then run the test again.

If a test case takes longer than 250 milliseconds, the device does not meet Windows To Go performance requirements. You can try to make the device faster and less prone to slow random access by using a different component or storage media.

The ReplyScenario test case files because too many IO operations had latencies in excess of 100 milliseconds. You can try to make the device faster and less prone to slow random access by using a different component or storage media.

More information

Command syntax

Command option | Description
StorageParameters.exe /device "[WDKDeviceID]" /outscript "[ParameterScript]" | Runs the test.

File list

File | Location
StorageParameters.exe | <testbinroot>\nttest\driverstest\storage\wdk</p>
StorageDevices.dll | <testbinroot>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
DeviceID | Either DriveLetter or DriveNumber
DeviceType | USB3_PW_SSD or USB3_PW_RT
Protocol | UAS or BOT
Usage | Data or Boot
WDKDeviceID | Instance path of device to test
QueryUAS | Query Gatherer for UAS detection
QueryUFDRotationalMedia | Query Gatherer for rotational media detection
Cooldown |
ParameterScript |
PolicyXml | Defines tests and pass/fail criteria
TAEFSource |


Device.Storage additional documentation

In this section

  • Removable Storage Testing Prerequisites
  • Hard Disk Drive Testing Prerequisites
  • Hardware-based RAID (Storage Array) Testing Overview
  • Hardware-based Raid Systems (Fibre Channel, SAS, SCSI, Serial ATA) Testing Prerequisites
  • Hardware-based RAID Systems (iSCSI) Testing Prerequisites
  • Optical Disk Drive Testing Prerequisites
  • SCSI Enclosure Services (SES) Device Testing Prerequisites
  • Secure Digital Host Controller Storage Testing Prerequisites
  • Storage Adapter or Controller Testing Overview
  • ATA/ATAPI Controller Testing Prerequisites
  • Fibre Channel Adapter Testing Prerequisites
  • Fibre Channel Over Ethernet Testing Prerequisites
  • iSCSI Boot Component Testing Prerequisites
  • iSCSI HBA Testing Prerequisites
  • SAS Controller Testing Prerequisites
  • SATA Controller Testing Prerequisites
  • SCSI Controller Testing Prerequisites
  • Troubleshooting Device.Storage Testing


Removable Storage Testing Prerequisites

This topic describes the tasks that you must complete before you test a removable storage device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Configuring the Test Computer.

Hardware Requirements

To test a removable storage device, you need the following hardware. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the description for each test that appears for the device in Windows HLK Studio.

  • 1 test computer that meets the Windows HLK requirements. In addition, this computer must include:

    • Logo-compliant Advanced Configuration and Power Interface (ACPI) BIOS, with ACPI enabled by default.

    • 1 host controller that has the appropriate bus interface for the test device.

      NOTE

      If the host controller isn't bootable, you also need 1 bootable bus controller (for example, a SCSI controller). If the host controller is bootable, you don't need an additional controller.

  • The removable storage device that you want to test.

  • 1 hard disk drive of the same bus type as the bootable controller for the test system, with at least 36 gigabytes (GB) of space.

  • 1 cable to connect the test device to the host controller.

  • 2 blank pieces of media, or the appropriate type for the test device, that are prepared for use.

  • If the device is connected through USB, 1 USB 2.0 high-speed hub.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your device, at least 1 computer in the pool must contain 4 processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that don't include a driver to test, like tests for a hard disk drive, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State, and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you can't use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. Virtualization products don't support the underlying functionality that's required to pass the tests that relate to multiple processor groups, device power management, device Peripheral Component Interconnect (PCI) functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

To test a removable storage device, you need this software:

  • The drivers for the test device

  • The latest Windows HLK filters or updates

Configuring the Test Computer

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Install the test device and any accessories.

  3. If you must install the manufacturer-supplied device driver on the test computer, do this now.

  4. If the test device is connected through a USB port, connect the USB 2.0 controller to the high-speed USB 2.0 hub, and then connect the test device to the downstream port of the high-speed USB 2.0 hub.

    NOTE

    Don't connect the USB test device directly to the root hub of the USB 2.0 controller.

  5. Place media in every port of the test device.

  6. Verify that the removable storage device functions correctly on the test computer.

  7. Install the Windows HLK client application on the test computer.

  8. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review the specific test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


Hard Disk Drive Testing Prerequisites

This topic describes the tasks that you must complete before you test a hard disk by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Configuring the Test Computer.

The tests that you must run depend on the capabilities of the hard disk that you want to test, its connection type (for example, an external USB-based hard drive), or how it's configured (as part of a RAID system or part of an IP-based storage solution).

The Windows HLK supports the testing of hard disks that have these connection types:

  • Fibre Channel

  • IEEE 1394

  • Parallel Advanced Technology Attachment (PATA)

  • PC Card

  • Serial Attached SCSI (SAS)

  • Serial Advanced Technology Attachment (SATA)

  • SCSI

  • USB

  • SD / EMMC

Hardware Requirements

The hardware that's required for testing a hard drive varies depending on the connection type. But, all tests for hard disks require 1 test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

NOTE

You might need additional hardware if the hard drive is part of a storage system. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your device, at least 1 computer in the pool must contain 4 processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that don't include a driver, like tests for a hard disk drive, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State, and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you can't use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. Virtualization products don't support the underlying functionality that's required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

The following sections provide additional hardware requirements for the test computer, based on the connection type.

General

For all configurations:

  • 1 disk drive with a minimum capacity of 6 GB used as the boot drive.

  • 1 CD-ROM drive (may be optional)

  • Network card, keyboard, mouse, display, power cable as needed

  • For each physical interface, please see the table below for additional hardware requirements.

Interface Hardware Equipment Description

Fibre Channel

  • 1 Fibre Channel controller

  • 2 identical Fibre Channel hard disk drives for the test devices

  • 1 Fibre Channel hub

  • Appropriate cables for connecting the drives

IEEE 1394

  • IEEE 1394 host controller

  • 1 IEEE 1394 hard disk drive (for the test device)

  • Appropriate cables for connecting the drives

PATA

If the connection type is PATA, you need this hardware:

  • 1 dual-channel ATA/ATAPI controller on the motherboard

  • 2 identical PATA hard disk drives (for the test devices)

  • Appropriate cables for connecting the drives

Note

ATA-66 and ATA-100 controllers require 80-conductor cables.

PC Card

  • 2 PC Card controllers

  • 2 PC Card hard disk drives for the test devices

  • Appropriate cables for connecting the drives

SAS

  • 2 dual-ported SAS controllers

  • 2 identical SAS hard disk drives for the test devices

  • Appropriate cables for connecting the drives

SATA

  • 1 SATA controller that has at least 2 channels

  • 2 SATA hard disk drives for the test devices

  • Appropriate cables for connecting the drives

SCSI

  • 1 SCSI adapter that has the appropriate bus interface for the test device, such as narrow, wide, or low voltage differential (LVD)

  • 2 identical SCSI hard disk drives for the test devices

  • Appropriate cables for connecting the drives

USB 2.0

  • A USB 2.0 host controller that's embedded on the system motherboard, or a USB 2.0 controller PCI adapter. The USB controller must be able to wake the system by using Advanced Configuration and Power Interface (ACPI) mechanisms.

  • 2 identical USB hard disk drives for the test devices

  • 1 USB 2.0 high-speed hub

  • Appropriate cables for connecting the drives

USB 3.0

  • A USB 3.0 host controller that's embedded on the system motherboard, or a USB 3.0 controller PCI adapter. The USB controller must be able to wake the system by using Advanced Configuration and Power Interface (ACPI) mechanisms.

  • A USB 2.0 host controller that's embedded on the system motherboard, or a USB 2.0 controller PCI adapter. The USB controller must be able to wake the system by using Advanced Configuration and Power Interface (ACPI) mechanisms.

  • 2 identical USB hard disk drives for the test devices

  • 1 USB 2.0 high-speed hub

  • Appropriate cables for connecting the drives

Software Requirements

To test a hard disk, you need this software:

  • The drivers for the hard disk controllers, if required

  • The latest Windows HLK filters or updates

Configuring the Test Computer

Before you begin testing the hard disk, you must configure the test computer and install the appropriate controller (if the test computer doesn't include this kind of controller). Then, you must complete the appropriate configuration steps, based on the type of hard disk that you're certifying.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review the specific test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).

To configure the test computer to test your Fibre Channel hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. If the test system doesn't have a SCSI adapter installed, install the SCSI adapter.

  3. Install 2 identical SCSI hard disk drives and 1 CD-ROM drive onto the SCSI bus.

  4. Install 1 Fibre Channel controller.

  5. Install 1 Fibre Channel hub on the Fibre Channel controller.

  6. Connect the Fibre Channel hard disk drives (test devices) to the Fibre Channel hub.

  7. Set the system BIOS to support the S3 state.

  8. Install the appropriate operating system on 1 of the SCSI hard disk drives.

  9. Install any manufacturer-supplied drivers that devices in the test system require, and then restart the system.

  10. Use the Windows Disk Management tool to delete all existing partitions on the Fibre Channel hard disk drives.

  11. Install the Windows HLK client application on the test computer.

  12. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your IEEE 1394 hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Install the ATA/ATAPI hard disk drive as a stand-alone Device 0 on the primary ATA/ATAPI channel by using a standard ATA/ATAPI cable.

  3. Install the ATA/ATAPI CD-ROM drive as a stand-alone Device 0 on the secondary ATA/ATAPI channel by using a standard ATA/ATAPI cable.

  4. If the IEEE 1394 controller isn't an embedded component, install 1 IEEE 1394 controller.

  5. By using an IEEE 1394 cable, install the IEEE 1394 hard disk drive (test device) as a stand-alone device on IEEE 1394 socket port 1 of the IEEE 1394 controller.

  6. Set the system BIOS to support the S3 state.

  7. Install the appropriate Windows operating system on the ATA/ATAPI hard disk drive.

  8. Install any manufacturer-supplied drivers that devices in the test system require.

  9. Remove any partitions on the test device, and then convert the test device to use the master boot record (MBR) partitioning style.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your PATA hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Install the hard disk drive (test device) as a stand-alone Device 0 on the primary ATA/ATAPI channel by using a standard ATA/ATAPI cable. This drive is called Drive 1.

  3. Install the CD-ROM drive by using a standard ATA/ATAPI cable.

    You can install the CD-ROM drive as Device 1 or Cable Select Device 1 on the primary ATA/ATAPI channel. Or, you can install the CD-ROM as Device 0, Device 1, Cable Select Device 0, or Cable Select Device 1 on the secondary ATA/ATAPI channel.

  4. Set the system BIOS to support the S3 state.

  5. Install the appropriate Windows operating system on Drive 1.

  6. Install any manufacturer-supplied drivers that devices in the test system require.

  7. With the test system turned off, install an identical hard disk drive by using a standard ATA/ATAPI cable.

    You can install this drive as Device 1 or Cable Select Device 1 on the primary ATA/ATAPI channel. Or, you can install this drive as Device 0, Device 1, Cable Select Device 0, or Cable Select Device 1 on the secondary ATA/ATAPI channel. This drive is called Drive 2.

  8. If you're testing a hybrid disk, install the disk on a secondary channel and make sure that the disk is a secondary disk.

  9. Remove any partitions on Drive 2, and then convert the drive to use the MBR partitioning style.

  10. Create three 4-GB NTFS-formatted partitions.

  11. Install the Windows HLK client application on the test computer.

  12. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your PC Card hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Install 1 PC Card hard disk drive (test device) on the PC Card channel of the test system.

  3. Install the PC Card network adapter on the second PC Card controller in the test system.

  4. Set the system BIOS to support the S3 state.

  5. Install the appropriate Windows operating system on the ATA/ATAPI hard disk in the test system.

  6. Install any manufacturer-supplied drivers that devices in the test system require.

  7. Remove any partitions on the test device, and then convert the test device to use the MBR partitioning style.

  8. Install the Windows HLK client application on the test computer.

  9. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your SAS hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. If the test system doesn't contain a SCSI adapter, install the SCSI adapter.

  3. Install a SCSI hard disk drive on the SCSI bus.

  4. Install the SCSI CD-ROM drive on the SCSI bus.

  5. Install 2 dual-ported SAS controllers

  6. Connect 1 SAS hard disk drive to the SAS port.

  7. Set the system BIOS to support the S3 state.

  8. Install the appropriate Windows operating system on the SCSI hard disk drive.

  9. Install any manufacturer-supplied drivers that devices in the test system require.

  10. Restart the test computer.

  11. By using the Windows Disk Management tool, delete all existing partitions on the SAS hard disk drives.

  12. Install the Windows HLK client application on the test computer.

  13. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your SATA hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Install the CD-ROM drive as Drive 0 on an ATA/ATAPI controller.

  3. Install a SATA controller and attach 2 SATA hard disks. These hard disks are called Drive 1 and Drive 2.

  4. Set the system BIOS to support the S3 state.

  5. Install the appropriate Windows operating system on Drive 1.

    During installation, delete any existing partitions on Drive 2 and create three 4-GB NTFS partitions.

  6. Install any manufacturer-supplied drivers that devices in the test system require.

  7. Install the Windows HLK client application on the test computer.

  8. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your SCSI hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Set the SCSI IDs on the hard disk drives (test devices) to the following:

    • Drive 1 = SCSI ID 0

    • Drive 2 = SCSI ID 1

  3. Install the hard disk drives (test devices) on the SCSI adapter.

  4. Set the SCSI ID on the SCSI CD-ROM drive to 6, and then physically install the SCSI CD-ROM drive on the SCSI adapter on a separate channel from the test devices.

  5. Set the system BIOS to support the S3 state.

  6. Install the appropriate Windows operating system on an NTFS-formatted volume on Drive 1.

  7. Install any manufacturer-supplied drivers that devices in the test system require.

  8. Remove any partitions on Drive 2, and then convert the test device to use the MBR partitioning style.

  9. Create three 4-GB NTFS-formatted partitions on Drive 2.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

To configure the test computer to test your USB hard disk

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. If the test system doesn't have an embedded USB 2.0 controller, install a USB 2.0 controller.

  3. Connect the USB 2.0 controller to the high-speed USB 2.0 hub.

  4. Connect the test device to the downstream port of the high-speed USB 2.0 hub.

    NOTE

    Don't connect the USB test device directly to the root hub of the USB 2.0 controller.

  5. Set the system BIOS to support the S3 state.

  6. Install the appropriate Windows operating system on hard disk drive.

  7. Install any manufacturer-supplied drivers that devices in the test system require.

  8. Remove any partitions on the test device, and then convert the test device to use the MBR partitioning style.

  9. Create three 4-GB partitions on the test device.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Feature-Based Configuration

If your device supports any of the feature(s) in this section, please update the associated configurations steps in addition to the general interface-based configuration steps in "Configuring the Test Computer." Minor modifications may be applicable depending on the specifics of your device form-factor.

Device.Storage.Hd.Ehdd

  • If testing as a boot device, the system must support UEFI 2.3.1 (with TCG OPAL 2.0 implementation).

  • A secondary non-boot device is still required to be installed for testing.

Device.Storage.Hd.Flush

  • This feature and testing requires an external programmable power strip.

  • See the Flush Test for more details.

Device.Storage.Hd.Sata.HybridInformation

  • The target test device cannot be a boot device.

  • The target test device should be a different product (e.g. Hardware ID) than the boot device.

  • Set system BIOS to boot from AHCI.

  • Start the system using Microsoft AHCI driver.

Device.Storage.Hd.Trim

  • The target test device cannot be a boot device.

  • The target test device should be a different product (e.g. Hardware ID) than the boot device.

  • Set system BIOS to boot from AHCI.

  • Start the system using Microsoft AHCI driver.

Device.Storage.Hd.Uas

  1. Install a USB 3.0 XHCI host controller in test system 1 ().

    NOTE

    Ff the host controller is already available as an embedded device on the system, skip this step.

  2. Attach target device 1 to system 1 into the 3.0 port.

  3. Attach target device 2 to system 2 into the 2.0 port. This step is necessary for testing cross XHCI and EHCI compatibility of UAS support on the test device.

  4. Upon completing the configuration on the two systems, run the following tests:

    • UAS device connected to XHCI port: Run full test suite.

    • UAS device connected to EHCI port: Run the following 3 tests.

      • Disk Stress for UAS on EHCI (LOGO)

      • UAS Stress Reset logo test for UAS on EHCI

      • USB 2.0 & 3.0 SCSI Compliance test for UAS on EHCI (LOGO)


Hardware-based RAID (Storage Array) Testing Overview

Before you begin to test your hardware-based RAID storage array by using the Windows Hardware Lab Kit (Windows HLK), you must review the prerequisites for the type of hardware array that you're testing. For more information, see the documentation that corresponds to the hardware array that you're testing:

  • Hardware-based RAID Systems (iSCSI) Testing Prerequisites

  • Hardware-based Raid Systems (Fibre Channel, SAS, SCSI, Serial ATA) Testing Prerequisites

Related topics

Device.Storage Tests


Hardware-based Raid Systems (Fibre Channel, SAS, SCSI, Serial ATA) Testing Prerequisites

This topic describes the tasks that you must complete before you test a hardware-based RAID storage array by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Configuring the Test Computer

The storage tests that you must run, the testing prerequisites, and the test setup vary depending on whether the RAID system is Internet SCSI (iSCSI) based or whether it uses another connection type: Fibre Channel, Serial Attached SCSI (SAS), SCSI, or Serial Advanced Technology Attachment (SATA).

Hardware Requirements

To test a hardware-based RAID array, you need the following hardware. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the description for each test that appears for the device in Windows HLK Studio.

NOTE

All hardware (except the test device, monitor, keyboard, mouse, and floppy disk drive) must be listed in the Windows Catalog.

  • 1 test computer that meets the Windows HLK requirements. For more information, see Windows HLK Prerequisites. In addition, this computer must include:

    • 1 logo-compliant Advanced Configuration and Power Interface (ACPI) BIOS, with ACPI enabled by default.

    • Dual-core or equivalent processor and a minimum of 2 gigabytes (GB) of memory for Windows client operating systems (for example, Windows 8, Windows 7, and Windows Vista).

    • Quad-core or equivalent processor and 6 GB of memory for Windows Server operating systems.

    An equivalent processor is any processor that appears to Windows as if it contains the specified number of CPUs. You can achieve this status through 1 or more physical microprocessors.

  • 1 test-specific type of RAID storage system: Fibre Channel, SAS, SCSI, or SATA RAID (for example, a SAS RAID storage system for a SAS system test). This device is the test device.

    WARNING

    The RAID system must be a single cabinet that consists of an array controller that's enclosed in an external subsystem with hard disk drives. Or it must be an external array controller that connects to a RAID JBOD. The RAID system can't consist of only a Peripheral Component Interconnect (PCI)-based controller and 1 RAID JBOD.

  • 1 PCI-based, test-specific type of host bus adapter (HBA). If the test system supports Microsoft® Multipath I/O (MPIO), 2 ports in the HBA or 2 identical HBAs (if each of them has only 1 port) must be connected to the same target device.

    NOTE

    The RAID system should support the PCI-based HBA that you select to test the RAID system. Any drivers that you use on the test system for this HBA must have a Windows logo, and the HBA model and firmware version must be included in the Windows Catalog.

  • 1 bootable ATA, SCSI, or SATA (only for testing SATA hardware-based RAID systems) hard disk drive, if the RAID system doesn't support boot. This drive must have a minimum capacity of 36 GB.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your device, at least 1 computer in the pool must contain 4 processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that don't include a driver to test, like tests for a hard disk drive, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State, and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you can't use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. Virtualization products don't support the underlying functionality that's required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

To test a hardware-based RAID array, you need this software:

  • Any drivers for the test hardware that aren't included with Windows.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

Configuring the Test Computer

To configure the test computer to test your Fibre Channel, SAS, SCSI, or SATA RAID array, follow these steps:

  1. Configure the RAID system by using the RAID system operator panel, by using the command-line tool, or by connecting another system to the RAID system and running the configuration tool. Specifically:

    1. Check that all RAID devices support only 1 RAID level: either RAID 5, RAID 1, or RAID 0.

      If your RAID system supports more than 1 RAID level, you must test all RAID levels that the device supports.

    2. Create three 40-GB RAID arrays on the RAID system. Configure the arrays according to this table:

      If the test device supports these RAID levels RAID level for RAID Array 1 RAID level for RAID Array 2 RAID level for RAID Array 3

      0 only

      0

      0

      0

      1 only

      1

      1

      1

      5 only

      5

      5

      5

      0 and 1 only

      1

      0

      1 or 0

      0, 1, and 10

      10

      1

      0

      0 and 5 only

      5

      5

      0

      1 and 5 only

      5

      5

      1

      0, 1, and 5

      5

      1

      0

      0, 1, 5, and 10

      5

      10

      1 or 0

  2. Turn off the test computer.

  3. Install 1 test-specific type of HBA. For example, if you're testing for a Fibre Channel system, install the Fibre Channel HBA.

  4. In the test system, connect the HBA to the RAID system by using the appropriate cables for the bus type (for example, SCSI, SATA, and so on).

    NOTE

    If the test RAID system supports more than 1 bus protocol, you must test and submit your device for Windows certification 1 time with each protocol that you want to have it qualified for.

  5. If the device supports MPIO, make sure that the HBA has at least 2 ports. If the HBA has only 1 port, install another HBA of the same model, and then connect it to the RAID system by using the appropriate cables for the bus.

  6. For a non-MPIO test environment, if both the HBA that you're using to test the RAID system and the RAID system itself support boot, follow these steps:

    1. Install any HBA or RAID system drivers, including multipath drivers that are required to connect to or manage the test device.

    2. Create a 36-GB NTFS file system partition on RAID Array 1, and then install the appropriate operating system on this partition.

      NOTE

      We recommend SAN-boot configuration, but it isn't required.

For an MPIO test environment, we don't recommend that you set up MPIO logical unit number (LUN) bootable. Instead, follow these steps:

1.  Install an alternate boot controller on the test system.

2.  Connect a hard disk drive to the alternate boot controller on the test system.

3.  Install any necessary drivers for the alternate boot controller.

4.  Install the appropriate operating system on a 36-GB NTFS partition on the hard disk drive.

5.  Install any HBA or RAID system drivers, including multipath drivers that are required to connect to or manage the peripheral devices.

  1. Click Start, and then click Run.

  2. Type diskmgmt.msc, and then press Enter.

    If the test operating system is Windows Vista or Windows Server 2008, and you're prompted to enter administrator credentials, enter the credentials.

  3. If the disks appear to be inactive, activate them by right-clicking the disk and then clicking Initialize Disk.

  4. Partition and format all disks:

    1. Right-click each disk, and then click Convert to Basic Disk if it is not basic already.

    2. Right-click each disk, and then click New Partition.

      NOTE

      Each partition should be a primary partition, should use all of the disk space, should use any drive letter, and should be formatted in NTFS.

      For a non-MPIO test environment, if the HBA that you're using to test the RAID system is bootable, and if the RAID system supports boot, RAID Array 1 should already have a 36-GB partition. Create a new NTFS partition by using the remaining space on this drive.

  5. Restart the operating system to update the size of the page file.

  6. Verify that the computer can read or write to the test RAID array.

  7. Install the Windows symbol files to the C:\Symbols directory. These are available from the Download Windows Symbol Packages webpage.

  8. Install the Windows HLK client application on the test computer.

  9. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

For all types of RAID arrays that you're testing, make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review the specific test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).

Feature-Based Configuration

If your device supports any of the feature(s) in this section, please update the associated configurations steps in addition to the general interface-based configuration steps in the "Configuring the Test Computer" section. Minor modifications may be applicable depending on the specifics of your device form-factor.

Device.Storage.Hd.Mpio

  • MPIO Test needs multiple ports connected to the same LUN. HBA needs to have multiple ports, or multiple one-port HBAs need to be set up.

  • For iSCSI test environment, it needs NIC card(s) or iSCSI HBA(s).

  • HBA firmware and drivers.

  • At least three LUNs.

  • Install MPIO feature by using Server Manager and install MS DSM or 3rd party DSM.

  • For iSCSI test environment, the users need to set up multiple iSCSI sessions for each pair of initiator IP address and target.

  • If device supports MPIO, then all of the three LUNs should be MPIO LUNs.

  • Configure the LUNs LBP policy to be Failover Only.

  • Configure the LUNs to be with partitions.

  • While creating submissions, select both DSM and the specific LUNs supporting specific features. You do not need to manually add the MPIO feature to the LUN.

Device.Storage.Hd.OffloadedDataTransfer

  • Test system has minimum 2 adapters with Adapter1 having 2 LUNs and Adapter2 having 1 LUN.

  • LUNs configured should be a minimum of 21 GB in size.

  • Single HBA Push Scenario & Single HBA Pull Scenario: Runs Offload Scenario test between Lun0 and Lun1.

  • Multiple HBA Push Scenario & Multiple HBA Pull Scenario: Runs Offload Scenario test between Lun0 and Lun2.

Device.Storage.Hd.RaidArray

Upon completion of hardware setup, and manually select this feature when going through the Windows HLK's target selection.

array feature selection

Device.Storage.Hd.ThinProvisioning

  • If the device supports thin provisioning, at least include one thin provisioned LUN and one full provisioned LUN. Thinly provisioned LUN needs to have a size no larger than 25 GB.

  • If the device supports thin provisioning, thin provisioning feature, threshold notification and persistent resource exhaustion, features need to be configured on the storage device end.

  • Configure the threshold notification to be set at 70% for thinly-provisioned LUN.

  • Enable permanent resource exhaustion feature on storage array.


Hardware-based RAID Systems (iSCSI) Testing Prerequisites

This topic describes the tasks that you must complete before you test an Internet SCSI (iSCSI) hardware-based RAID storage array by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Configuring the Test Computer.

Hardware Requirements

To test an iSCSI hardware-based RAID array, you need the following hardware. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the description for each test that appears for the device in Windows HLK Studio.

NOTE

All hardware (except the test device, monitor, keyboard, mouse, and floppy disk drive) must be listed in the Windows Catalog.

  • 1 test computer that meets the Windows HLK requirements. For more information, see Windows HLK Prerequisites. In addition, this computer must include:

    • 1 logo-compliant Advanced Configuration and Power Interface (ACPI) BIOS, with ACPI enabled by default.

    • Dual-core or equivalent processor and 4 gigabytes (GB) of memory for Windows client operating systems (for example, Windows 8, Windows 7, and Windows Vista).

    • Quad-core or equivalent processor and 6 GB of memory for Windows Server operating systems.

    An equivalent processor is any processor that appears to Windows as if it contains the specified number of CPUs. You can achieve this status through 1 or more physical microprocessors.

  • 1 iSCSI RAID storage system (the test device).

    NOTE

    The RAID system must be a single cabinet that consists of an array controller that's enclosed in an external subsystem with hard disk drives. Or it must be an external array controller that connects to a RAID JBOD. The RAID system can't consist of only a Peripheral Component Interconnect (PCI)-based controller and 1 RAID JBOD.

  • At least one 1-GB Ethernet network adapter or iSCSI host bus adapter (HBA).

  • One 1-GB Ethernet switch.

  • 1 bootable Advanced Technology Attachment (ATA) or SCSI hard disk drive that has a minimum capacity of 36 GB.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your device, at least 1 computer in the pool must contain 4 processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that don't include a driver to test, like tests for a hard disk drive, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State, and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you can't use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. Virtualization products don't support the underlying functionality that's required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

To test a hardware-based RAID array, you need this software:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The latest version of the Microsoft® iSCSI Software Initiator.

  • The latest version of Microsoft iSNS Server.

  • The Microsoft .NET Framework 1.1.

The iSCSI Software Initiator and the .NET Framework are available from the Microsoft Download Center.

Configuring the Test Computer

To configure the test computer to test your iSCSI RAID array, follow these steps:

  1. Install the Gigabit Ethernet network adapter or iSCSI HBA in the test computer.

  2. Connect the Gigabit Ethernet switch to a power supply.

    NOTE

    Don't connect the switch to any other network.

  3. Connect the Gigabit Ethernet network adapter or iSCSI HBA in the test computer to the switch.

  4. Connect the disk storage system to the switch.

  5. Install the appropriate Windows operating system on the test computer (onto an NTFS-formatted partition that has at least 36 GB on the hard disk drive), and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  6. If the test device supports Microsoft Multipath I/O (MPIO), install any multipath drivers and create connections and multiple sessions by selecting Enable Multi-Path I/O.

  7. Download and install the .NET Framework 1.1.

  8. Configure the target device to use one-way (target authenticates initiator) Challenge Handshake Authentication Protocol (CHAP).

    If your device supports mutual CHAP, also configure the device to use mutual CHAP.

    NOTE

    When you configure the device to use CHAP, you must provide a password that's 12 to 16 characters long. If you're configuring the device to use both one-way CHAP and mutual CHAP, you must provide different passwords for the target and the initiator.

  9. Log on to the target disk storage system with Persistent Login set.

    IMPORTANT

    You must log on to the iSCSI target device that's used for testing, or the tests won't work properly.

    For a multipath test environment, if multiple ports (IP addresses) relate to one storage target, you must make sure that at least 2 iSCSI sessions are connected through the IP address to during testing.

  10. Click Start, and then click Run.

  11. Type diskmgmt.msc, and then press Enter.

  12. Make sure that the test disks are set as basic disks.

  13. Create three NTFS-formatted partitions that are greater than 2 GB each and less than 4 GB each.

    A single logon should display all of these partitions.

  14. Install the iSNS software on the test system and configure the target to use the iSNS server.

  15. If your device supports digest and you must configure it, configure the test device to support digest.

  16. Bind your volumes in the Favorite Targets (Windows Vista) or Bound Volumes (Windows Server 2003) tab of iSCSI Initiator Properties.

  17. Verify that the computer can read or write to the test RAID array.

  18. Install the Windows HLK client application on the test computer.

  19. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review the specific test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).

Feature-Based Configuration

If your device supports any of the feature(s) in this section, please update the associated configurations steps in addition to the general interface-based configuration steps in the "Configuring the Test Computer" section. Minor modifications may be applicable depending on the specifics of your device form-factor.

See "Hardware-based Raid Systems (Fibre Channel, SAS, SCSI, Serial ATA) Testing Prerequisites" above for feature-based configuration. The features also apply to iSCSI Hardware RAID Array Systems.


Optical Disk Drive Testing Prerequisites

This topic describes the tasks that you must complete before you test an optical storage device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Configuring the Test Computer.

The optical storage device includes rewritable drives for CD, DVD, and Blu-ray media.

Hardware Requirements

To test an optical drive, you need the following hardware. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the description for each test that appears for the device in Windows HLK Studio.

  • 1 test computer that meets the Windows HLK requirements. For more information, see Windows HLK Prerequisites. In addition, this computer must have one of the following types of processors:

    • Dual-core or equivalent processor and 4 gigabytes (GB) of memory for Windows client operating systems (for example, Windows 8, Windows 7, and Windows Vista).

    • Quad-core or equivalent processor and 6 GB of memory for Windows Server operating systems.

    The test computer must contain one dual-channel Advanced Technology Attachment (ATA)/Advanced Technology Attachment Packet Interface (ATAPI) controller that's implemented on the motherboard. The test computer must also contain a logo-compliant Advanced Configuration and Power Interface (ACPI) BIOS, with ACPI enabled by default. For Windows 8, Windows 7, and Windows Vista, BIOS configuration and Serial Advanced Technology Attachment (SATA) controller support of SATA Advanced Host Controller Interface (AHCI) mode are required.

  • 2 identical optical disk drives for testing.

    NOTE

    If the optical disk drive that you're testing is read-only, you must connect a writer drive in addition to the two drives that you test.

  • 1 host controller of the same bus type as the optical storage device. The USB controller must be able to wake the system by using ACPI mechanisms.

  • Appropriate cables for connecting devices.

  • Blank media for each type of media that the test device supports.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your device, at least 1 computer in the pool must contain 4 processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that don't include a driver to test, like tests for a hard disk drive, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State, and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you can't use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. Virtualization products don't support the underlying functionality that's required to pass the tests that relate to multiple processor groups, device power management, device Peripheral Component Interconnect (PCI) functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

To test an optical storage device, you need this software:

  • The drivers for the test device

  • The latest Windows HLK filters or updates

Configuring the Test Computer

To configure the test computer for your test device, follow these steps:

  1. Turn off the test system, disconnect it from the power supply, and install a hard disk drive. Depending on the bus type of the test optical storage device, take one of these actions:

    • For ATA/ATAPI, install the hard disk drive as stand-alone Device 0 on the primary ATA/ATAPI channel.

    • For SCSI, set the SCSI ID on the SCSI hard disk drive to 0.

  2. If the host controller is not embedded on the system motherboard, install the host controller.

  3. Install the test optical storage devices in the test system by attaching them to the host controller. Depending on the bus type of the test optical storage device, take one of these actions:

    • For ATA/ATAPI, install the test device as Device 1 or Cable Select Device 1 on the primary ATA/ATAPI channel. Or install the test device as Device 0, Device 1, Cable Select Device 0, or Cable Select Device 1 on the secondary ATA/ATAPI channel.

    • For SCSI, set the SCSI ID on the test device to 6.

    • For USB, connect the test device to the downstream port of the high-speed USB 2.0 hub.

      NOTE

      Don't connect the USB test device directly to the root hub of the USB 2.0 controller.

  4. Turn on the test system and set the system BIOS to support the S3 state.

    NOTE

    All adapters are operated with BIOS enabled and external termination unless otherwise noted.

  5. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  6. If you must install the manufacturer-supplied device driver on the test computer, do this now.

  7. Verify that both optical storage devices function correctly on the test computer.

  8. Install the Windows HLK client application on the test computer.

  9. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review the specific test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


SCSI Enclosure Services (SES) Device Testing Prerequisites

This topic describes the tasks that you must complete before you test a SES device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements

  • Software Requirements

  • Configuring the Test Computer

Hardware Requirements

To test a SES device, you need following hardware:

  • SES device with at least two ports that can be used to connected to servers

  • Two identical Host Bus Adapters (HBAs), each with at least one port

  • Two cables, each connected to one HBA port and to the SCSI Enclosure Storage target device

  • Must be fully loaded with hard disk drives in the SES device that can be accessed via the SES device

  • The CiB (Cluster in a Box) Continuously Available test requires a cluster configuration

Software Requirements

To test a SES device, you need the following software:

  • Drivers for hardware devices, if required

  • The latest Windows HLK filters or updates

Configuring the Test Computer

To configure the test computer for your test device, follow these steps:

  1. Use an appropriate OS installation.

  2. Install HLK Controller and HLK Studio on the Test Server.

  3. Install HLK Client on computers where you intend to run the test.

  4. Select the SES device that you want to test.

  5. Select a disk device contained in the SES device.

  6. On the Test Computer, go to Disk Management to ensure that the disk you have selected in the HLK is online. You need a formatted volume on the disk you have selected to successfully pass all tests.

  7. Ensure that the test computer is in Ready state before you begin testing. If you do not change the machine status to Ready, the tests will not run. You cannot change the machine status to Ready while it is in the Default Pool. You need to move the machine to the new pool that you have created before you can do this.


Secure Digital Host Controller Storage Testing Prerequisites

This topic describes the tasks that you must complete before you test a Secure Digital host controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Configuring the Test Computer.

Hardware Requirements

To test a Secure Digital host controller, you need the following hardware. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the description for each test that appears for the device in Windows HLK Studio.

  • 1 test computer that meets the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • The Secure Digital host controller that you want to test.

  • 1 or more Secure Digital memory cards that comply with the requirements of the Windows Hardware Certification Program. You need a memory card for each port on the Secure Digital host controller.

    NOTE

    If the Secure Digital host controller supports High Speed mode, the memory card that you use must also be High Speed.

  • 1 USB 2.0 hub if the Secure Digital host controller supports USB.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your device, at least 1 computer in the pool must contain 4 processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that don't include a driver to test, like tests for a hard disk drive, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State, and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you can't use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. Virtualization products don't support the underlying functionality that's required to pass the tests that relate to multiple processor groups, device power management, device Peripheral Component Interconnect (PCI) functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

To test a Secure Digital host controller, you need this software:

  • The drivers for the test device

  • The latest Windows HLK filters or updates

Configuring the Test Computer

To configure the test computer for your test device, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network. The test network is the network that contains Windows HLK Studio and Windows HLK Controller.

  2. Install the test device and any accessories.

  3. If you must install the manufacturer-supplied device driver on the test computer, do this now.

  4. If the test device is connected through a USB port, connect the USB 2.0 controller to the high-speed USB 2.0 hub, and then connect the test device to the downstream port of the high-speed USB 2.0 hub.

    NOTE

    Don't connect the USB test device directly to the root hub of the USB 2.0 controller.

  5. Place Secure Digital memory cards in every port of the test controller.

  6. Verify that the removable Secure Digital host controller functions correctly on the test computer (specifically, that the test computer can detect the Secure Digital memory cards).

  7. Install the Windows HLK client application on the test computer.

  8. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires you to set parameters before you run it, a dialog box will appear for that test. For more information, review the specific test topic.

Some Windows HLK tests require user intervention. When you're running tests for a submission, it's a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting the completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


Storage Adapter or Controller Testing Overview

Before you test your storage adapter or controller by using the Windows Hardware Lab Kit (Windows HLK), you must review the prerequisites for the type of adapter that you are testing. The following topics list the prerequisites for different adapters and controllers:

  • ATA/ATAPI Controller Testing Prerequisites

  • Fibre Channel Adapter Testing Prerequisites

  • Fibre Channel Over Ethernet Testing Prerequisites

  • iSCSI Boot Component Testing Prerequisites

  • iSCSI HBA Testing Prerequisites

  • SAS Controller Testing Prerequisites

  • SATA Controller Testing Prerequisites

  • SCSI Controller Testing Prerequisites

Related topics

Device.Storage Tests


ATA/ATAPI Controller Testing Prerequisites

This section describes the tasks that you must complete before you test an ATA/ATAPI controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Hardware Requirements

The following hardware is required for testing an ATA/ATAPI controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and test controller, all hardware that is involved in the test must already have a logo.

  • One test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • If the ATA/ATAPI controller supports RAID, the following requirements apply:

    • Two identical ATA/ATAPI RAID controllers (the test devices), unless the test device is an integrated controller.

    • One ATA/ATAPI hard disk drive for each channel that the test device supports. If two controllers are required, twice as many hard disks are required. The hard disk drives must each have at least 40 gigabytes (GB).

    • One optical drive.

    • One PCI-to-PCI bridge adapter, unless any of the following conditions apply:

      • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

  • If the ATA/ATAPI controller supports RAID, the following requirements apply:

    • One ATA/ATAPI controller (the test device).

    • Two UDMA-capable ATA/ATAPI hard disk drives with at least 40 GB.

    • One DMA-capable optical recording drive that has a minimum speed of 8x.

    • One blank rewritable CD.

    • One ATA/ATAPI tape drive.

    • One blank tape cartridge.

  • If the test device does not support boot, one bootable controller and a hard disk drive that has a minimum of 36 GB are required.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required for testing an ATA/ATAPI controller:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The current release of the Windows Driver Kit (WDK).

Test Computer Configuration

There are three possible configurations for testing ATA/ATAPI controllers:

  • If the test device is an add-in controller that supports RAID, use the Add-in RAID controller test configuration.

  • If the test device is an integrated controller that supports RAID, use the Integrated RAID controller test configuration.

  • If the test device does not support RAID, use the Non-RAID controller test configuration.

Before you test an ATA/ATAPI controller in any of the three usage scenarios, make sure that the test computer is in the ready state. If a test requires parameters to be set before the test is run, a dialog box appears for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).

Add-in RAID controller test configuration

To configure the test computer to test an ATA/ATAPI controller in an add-in RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Install one test controller (Controller 1).

    3. Install a PCI-to-PCI bridge, unless one of the following items is true:

      • The controllers cannot fit into PCI bridge adapters. This may be true for integrated controllers or controllers that can fit only into specially designed slots.

      • The controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • The controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

    4. Install a second, duplicate test controller (Controller 2) in the PCI-to-PCI bridge card (or in the PCI bridge if the bridge card is not required).

    5. Attach the disks to the test devices according to the following table:

      Controller type Controller 1 Controller 2

      ATA RAID

      One ATA hard disk drive on each supported channel

      One ATA hard disk drive on each supported channel

    6. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test system.

  3. Set the system BIOS to support the S3 state.

  4. Create one 60-GB RAID array on Controller 1 and two 60-GB RAID arrays on Controller 2.

    The RAID array on Controller 1 is RAID Array 1, and the RAID arrays on Controller 2 are RAID Array 2 and RAID Array 3.

  5. Configure the RAID arrays according to the following table:

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2 RAID level for RAID Array 3

    0 only

    0

    0

    0

    1 only

    1

    1

    1

    5 only

    5

    5

    5

    0 and 1 only

    1

    9

    0

    0 and 5 only

    5

    9

    0

    1 and 5 only

    5

    1

    1

    0, 1, and 10

    10

    1

    0

    0, 1, and 5

    5

    1

    0

    0, 1, 10, and 5

    5

    10

    0

  6. Install the appropriate Microsoft Windows operating system to a 36-GB NTFS volume on RAID Array 1, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller.

  7. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  8. Start Windows on the test computer.

  9. Create three 4-GB partitions on RAID Array 2.

  10. If you are testing by using a client operating system, create a 4-GB NTFS spanned volume that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows:

    add-in raid array configuration diagram (client)

    If you are testing by using a server operating system, do the following:

    1. Create a software RAID 1 mirror from one of the NTFS partitions on RAID Array 2 to the unallocated space on RAID Array 1, as the following diagram shows.

    2. Create a 4-GB NTFS software RAID 5 array that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

      add-in raid array configuration diagram (server)

  11. To set the system page file and enable crashdump, follow these steps:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  12. Verify that the storage array is accessible from the test computer.

  13. Copy the Windows symbol files to %SystemDrive%\Symbols.

  14. Install the Windows HLK client application on the test computer.

  15. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Integrated RAID controller test configuration

To configure the test computer for testing of an ATA/ATAPI controller in an integrated RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Attach the disks to the integrated test controller (Controller 1) according to the following table:

      Controller type Controller 1

      ATA RAID

      One ATA hard disk drive on each supported channel

    3. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test system.

  3. Set the system BIOS to support the S3 state.

  4. Create two 60-GB RAID arrays on Controller 1.

    If the controller does not support a configuration that includes two arrays, use a non-RAID disk instead of Array 2 for these procedures. For SCSI, create a third 60-GB RAID array (using any supported RAID level).

    The RAID arrays on Controller 1 are RAID Array 1 and RAID Array 2.

  5. Configure the RAID arrays according to the following table.

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2

    0 only

    0

    0

    1 only

    1

    1

    5 only

    5

    5 or Non-RAID disk

    0 and 1 only

    1

    0

    0 and 5 only

    5

    0 or Non-RAID disk

    1 and 5 only

    5

    1or Non-RAID disk

    0, 1, and 10

    10

    1 or Non-RAID disk

    0, 1, and 5

    5

    0 or Non-RAID disk

    0, 1, 10, and 5

    5

    10 or Non-RAID disk

  6. Turn on the test computer install the appropriate Windows operating system, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  7. Install the appropriate Microsoft Windows operating system to a 36-GB NTFS volume on RAID Array 1, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install Windows to a separate hard disk drive on a bootable controller.

  8. If it is necessary, install any drivers that a manufacturer supplies that the devices in the test system require.

  9. Start Windows on the test computer.

  10. To set the system page file and enable crashdump, do the following:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  11. Verify that the storage array is accessible from the test computer.

  12. Copy the Windows symbol files to %SystemDrive%\Symbols.

  13. Install the Windows HLK client application on the test computer.

  14. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Non-RAID controller test configuration

To configure the test computer to test an ATA/ATAPI controller in a non-RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive if the test devices do not support boot.

    2. Install the test device (Controller 1).

    3. Attach the disks to the test devices according to the following table.

      Controller type Controller 1 Controller 2

      ATA/ATAPI controllers

      Primary Master: UDMA HDD (Disk 1)

      Primary Subordinate: Optical recorder

      Secondary Master: UDMA HDD (Disk 2)

      Secondary Subordinate: ATA/ATAPI tape drive

      N/A

    4. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test computer.

  3. Set the system BIOS to support the S3 state.

  4. Install the appropriate Microsoft Windows operating system onto disk 1. Use a newly created NTFS partition that has at least 36 GB of disk space. Then, configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  5. If you have to install a manufacturer-supplied device driver on the test computer, do this now.

  6. Create three 4-GB partitions on Disk 2.

  7. Use the following procedure to set the system page file and enable crashdump:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  8. Verify that the storage array is accessible from the test computer.

  9. Copy the Windows symbol files to %SystemDrive%\Symbols.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.


Fibre Channel Adapter Testing Prerequisites

Tests for driver certification include manual and automated test cases. All automated and manual tests must pass for certification.

This section describes the tasks that you must complete before you test a Fibre Channel storage controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

  • Manual test cases

  • Automated tests

Hardware Requirements

The following hardware is required for testing a Fibre Channel storage controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and test controller, all hardware involved in the test must already have a logo.

  • One test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • One Fibre Channel RAID storage subsystem that can support any one of the following: RAID-0, RAID-1, RAID-5, RAID-10, or RAID-6.

    WARNING

    Do not test by using a storage subsystem that connects via MPIO.

  • If the Fibre Channel adapter is not bootable, one ATA or SCSI controller.

  • If the Fibre Channel adapter is not bootable, one ATA or SCSI disk drive. The disk must have at least 18 GB of space.

  • One bootable floppy disk drive.

  • One floppy disk.

  • Two identical PCI-X or PCIe-based Fibre Channel adapters (the test devices).

  • Two (or three, if testing RAID-5) Fibre Channel hard disk drives or Fibre Channel JBOD.

  • One PCI-to-PCI bridge adapter.

  • One PCI-to-PCI bridge adapter, unless any of the following conditions apply:

    • The controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

    • The controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

    • You can put one of the controllers into a PCI bus slot that is already behind a PCI bridge.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required for testing a Fibre Channel storage controller:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The current release of the Windows Driver Kit (WDK)

Test Computer Configuration

To configure the test computer to test a Fibre Channel storage controller, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install one CD drive in the test system, if the system does not already contain one.

    2. Install one Fibre Channel adapter (Test Device 1).

    3. Connect the Fibre Channel adapter to the RAID system.

    4. If either of the following situations apply, connect two Fibre Channel hard disk drives or a Fibre Channel JBOD to the test device, and then skip to step G:

      • The Fibre Channel adapter test device is an integrated controller, there is only one of these controllers in the system, and an equivalent PCI adapter version of the device does not exist.

      • The Fibre Channel adapter is designed for and sold only in a host test system that accepts only a single version of the controller.

      NOTE

      Use three Fibre Channel hard disk drives for RAID-5 testing.

    5. Install a PCI-to-PCI bridge in a PCI slot in the test system.

      NOTE

      You can also use an existing slot behind a bridge.

    6. Install a secondary, identical Fibre Channel adapter (Test Device 2) in the PCI-to-PCI bridge card.

    7. Connect two Fibre Channel hard disk drives or a Fibre Channel JBOD to Test Device 2.

      NOTE

      Use three Fibre Channel hard disk drives for RAID-5 testing.

    8. Turn on the test computer.

    9. Configure the JBOD or disks as Array 2, according to the following list:

      • If the test device supports only one RAID level, configure the JBOD or disks by using that level. Otherwise, configure the JBOD or disks to the RAID levels that are specified in the following table.

        RAID levels that the test device supports Use RAID level

        0 and 1

        1

        0 and 5

        5

        1 and 5

        Either 1 or 5

        0, 1, and 5

        Either 1 or 5

    -   Array 2 must contain at least 60 GB of space.

10. Configure the RAID system as Array 1 according to the following list:

    -   If the RAID system supports only one RAID level, configure it by using that level. Otherwise, configure the RAID system according to the preceding table.

    -   Array 2 must contain at least 60 GB of space.

11. If the test Fibre Channel adapter is not bootable, install an ATA or SCSI hard disk drive and an alternate ATA or SCSI boot controller if they are not present.

  1. Turn on the test computer, install the appropriate Windows operating system, install all available Windows updates, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Install any HBA or RAID system drivers that are necessary to connect to or manage the peripheral devices.

  3. Do one of the following to install the operating system:

    • If the test Fibre Channel adapter is bootable, install the operating system on an NTFS, 364-GB partition on the RAID system.

    • Install the operating system on an NTFS-formatted, 36-GB partition on the ATA or SCSI hard disk drive that is connected to the alternate ATA or SCSI boot controller in the test system.

  4. Start the test system in the Microsoft Windows operating system.

  5. Use the Windows Disk Management utility to set up three 4 GB NTFS partitions on Array 1, as shown in the following diagram:

    add-in raid array configuration diagram (client)

  6. Use the Windows Disk Management utility to mirror one of the volumes created in step 6 to Array 2.

  7. To set the system page file and enable crashdump, follow these steps:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  8. Copy the Windows symbol files to %SystemDrive%\Symbols.

  9. Verify that Windows can access the Fibre Channel storage array.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


Fibre Channel Over Ethernet Testing Prerequisites

This section describes the tasks that you must complete before you test a Fibre Channel over Ethernet (FCoE) controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Hardware Requirements

The following hardware is required for testing an FCoE controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and the test controller, all hardware involved in the test must already have a logo.

  • Two test computers. The test computers must meet the Windows HLK requirements as described in Windows HLK Prerequisites. and the following operating system-specific requirements.

    • For testing on Windows 8, Windows 7, Windows Vista or Windows XP:

      • One dual-core or equivalent processor

      • 4 GB of memory

    • For testing on Windows Server 2012, Windows Server 2008 R2, Windows Server 2008, or Windows Server 2003:

      • One quad-core or equivalent processor

      • 6 GB of memory

  • Two identical PCI-X or PCIe-based dual-port FCoE adapters (the test devices). Four identical FCoE adapters are needed if the adapter is single-ported.

  • One FCF (FCoE switch) that supports 10G/E bandwidth for FCoE traffic. FCF is installed with four available FCoE ports/SFP+, and one FC port/SFP+.

  • Copper- or fibre-based FCoE cable and Fibre Channel cable for the above ports.

  • One Fibre Channel storage array system that can support any one of the following: RAID-0, RAID-1, RAID-5, RAID-10, or RAID-6.

  • If the FCoE adapter is not bootable, one on-board SATA or SAS controller.

  • If the FCoE adapter is not bootable, one SATA or SAS disk drive for operating system installation.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required to test a Fibre Channel storage controller:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • The current release of the Windows Driver Kit (WDK).

  • Windows symbol files. These are available from the Symbol Files website.

Test Computer Configuration

To configure the test computer to test a Fibre Channel storage controller, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. If the FCoE adapter is not bootable, configure an alternate SATA or SAS on-board boot controller, and then install a respective SATA or SAS hard disk drive if they are not present.

    2. Install one FCoE adapter in the first test system. (Install two FCoE adapters in the first computer if the computer has only one port.)

    3. Connect all ports of the FCoE adapter(s) to the FCF.

    4. Repeat step 2 through step 4 for the second FCoE adapter in the second test system. (Install two FCoE adapters in the second computer if the computer has only one port.)

    5. Connect the FCF to the storage array, as described in the following diagram:

      fibre chaneel over ethernet configuration diagram

    6. Create LUN and configure LUN mapping on the storage array system. The array must contain at least 120 GB of disk space for SAN boot configuration. The LUN mapping is only needed for the first test system. Complete this step according to the storage array vendor instructions.

    7. Configure the ports and zoning on the FCF. Complete this step according to the switch vendor instructions.

    8. Turn on the test systems.

  2. Turn on the test computer, install the appropriate Windows operating system, install all available Windows updates, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  3. Install any HBA or RAID system drivers that are necessary to connect to or manage the peripheral devices.

  4. Do one of the following to install the operating system:

    1. If the test FCoE adapter is bootable, install the operating system on an NTFS, 120 GB partition on the RAID system.

    2. Install the operating system on an NTFS-formatted 120 GB partition on the SATA or SAS hard disk drive that is connected to the alternate SATA or SAS boot controller in the test system.

    WARNING

    Do not follow this step when you test MPIO.

  5. Start the test system in the Microsoft Windows operating system.

  6. Configure MPIO for the first test system only:

    • Install the Windows MPIO feature through Server Manager.

    • Reboot the system.

    • Use the mpclaim.exe command line utility or edit the MPIO CPL (Control Panel) GUI interface to add the LUN ID to be claimed.

    • Restart the system.

  7. Complete the following procedure to set the system page file and enable crashdump:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  8. Copy the Windows symbol files to %SystemDrive%\Symbols.

  9. Verify that Windows can access the storage array over the FCoE adapter.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box appears for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


iSCSI Boot Component Testing Prerequisites

This section describes the tasks that you must complete before you test an iSCSi boot component device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Testing an iSCSI boot component verifies that a system supports using an iSCSI target as the startup disk. The iSCSI boot component can be part of the system BIOS, iSCSI host bus adapter (HBA), network card that has Extended BIOS, or network card that has a preboot execution environment (PXE) and iSCSI boot loader program to start the computer.

The iSCSI boot BIOS or loader program uses the Phoenix Int 13h BIOS interrupt call to allow the operating system to start as if there were a locally attached disk. Disk read and write operations through Phoenix Int 13h extensions are redirected through iSCSI to the remote disk. The iSCSI boot BIOS or loader program creates the iSCSI Boot Firmware table (iBFT) that contains the information that is needed for the Microsoft Windows operating system to continue loading after the operating system loader has completed and the Windows kernel has started.

The iSCSI boot component includes the following:

  • Pre-boot initiation code

  • An implementation of iBFT in firmware or BIOS

  • Crashdump support in new or existing drivers

Hardware Requirements

The following hardware is required for testing an iSCSI boot component. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

  • One test computer. The test computers must meet the Windows HLK requirements as described in Windows HLK Prerequisites and the following operating system-specific requirements:

    • For testing on Windows 8, Windows 7, Windows Vista or Windows XP:

      • One dual-core or equivalent processor

      • 4 GB of memory

    • For testing on Windows Server 2012, Windows Server 2008 R2, Windows Server 2008, or Windows Server 2003

      • One quad-core or equivalent processor

      • 6 GB of memory

  • Hardware and software that contain the iSCSI boot component in the server option ROM, NIC option ROM, firmware, or PXE implementation.

  • Two Gigabit Ethernet network adapters that have logos.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required to test an iSCSI boot component:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • The current release of the Windows Driver Kit (WDK).

  • Windows symbol files. These are available from the Symbol Files website.

  • Microsoft iSCSI Software Initiator 2.02Boot +.

  • A kernel-mode driver to read iBFT in firmware or BIOS (see Microsoft-iSCSI-Boot-Firmware-Table-Spec-v1.0.doc).

Test Computer Configuration

To configure the test computer to test an iSCSI boot component, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install the test device that supports iSCSI boot.

    2. Set up an iSCSI environment and record the IP addresses and target names of the devices.

  2. Turn on the test computer, install the appropriate Windows operating system, install all available Windows updates, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  3. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  4. Start the test system in the Microsoft Windows operating system.

  5. Verify that Windows can access the iSCSI boot device.

  6. Install the Windows HLK client application on the test computer.

  7. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will appear for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


iSCSI HBA Testing Prerequisites

This section describes the tasks that you must complete before you test an iSCSI host bus adapter (HBA) by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test computer configuration.

Hardware Requirements

You can run the iSCSI HBA tests in a single configuration. However, you can implement this configuration in one of two ways:

  • An iSCSI HBA, an iSCSI disk storage system, and an iSCSI tape medium changer

  • An iSCSI HBA, a bridge to another bus, a disk storage system, and an iSCSI tape medium changer

The following hardware is required for testing an iSCSI HBA adapter. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and the test controller, all hardware involved in the test must already have a logo.

  • One test computer. The test computer must meet the Windows HLK requirements as described in Windows HLK Prerequisites and the following operating system-specific requirements.

    • For testing on Windows 8, Windows 7, Windows Vista or Windows XP:

      • One dual-core or equivalent processor

      • 4 GB of memory

    • For testing on Windows Server 2012, Windows Server 2008 R2, Windows Server 2008, or Windows Server 2003:

      • One quad-core or equivalent processor

      • 6 GB of memory

  • One iSCSI HBA (the test device).

  • One combination tape drive and medium changer device. If you are testing without a bridge, this device must be an iSCSI device. If you are testing with a bridge, this device must be a device that connects through another bus.

  • Two disk storage systems. If you are testing without a bridge, these systems must be iSCSI disk storage systems. If you are testing with a bridge, these systems must be disk storage systems that connect through another bus.

    NOTE

    If the test device supports boot, you must have two disk targets. These targets can exist on the same disk storage device if they have different target names.

  • An iSCSI bridge, if you are testing in a configuration that has a bridge.

  • Three blank media cartridges for each drive on the medium changer device.

  • A monitor, keyboard, and mouse.

  • A boot-capable floppy disk drive, if your device supports boot.

  • Two (2) Gigabit Ethernet network adapters.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required to test an iSCSI HBA adapter:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The current release of the Windows Driver Kit (WDK)

Test computer configuration

To configure the test computer to test an iSCSI HBA adapter, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install the iSCSI controller in the test system.

    2. Connect both 1 GB network cards to the network.

    3. Connect the iSCSI controller to the test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

    4. If you are using an iSCSI bridge, connect the bridge to the network.

    5. Do one of the following:

      1. If you are using an iSCSI bridge, connect the disk storage system, combination tape, and medium changer to the bridge.

      2. If you are not using an iSCSI bridge, connect the disk storage system, combination tape, and medium changer to the network.

      The following diagram shows the test system configuration without a bridge.

      iscsi controller configuration diagram (no bridge)

      The following diagram shows the test system configuration with a bridge.

      iscsi controller configuration diagram (bridge)

  2. Turn on the test computer, install the appropriate Windows operating system, install all available Windows updates, and then configure the computer for your test network.

    If the iSCSI HBA supports boot, install the operating system on an iSCSI disk target that is different from the one that you will use for testing.

  3. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  4. Install the latest version of the iSCSI software initiator. This is available from the Microsoft Download Center.

  5. Use the iSCSI Control Panel to log on to all target devices. When you log on to the targets, select the Automatically restore this connection when the system boots check box.

    IMPORTANT

    You must log on to all iSCSI target devices that you use for testing. You must not log on to any other iSCSI target devices. Otherwise, the WLK tests do not work correctly.

  6. Use Disk Management to create three 4-GB NTFS volumes on the disk storage system that does not contain the operating system. Assign each volume a drive letter.

  7. Use the iSCSI Control Panel to bind all of the drive letters that were created in the previous step.

  8. Complete the following procedure to set the system page file and enable crashdump:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  9. Copy the Windows symbol files to %SystemDrive%\Symbols.

  10. Verify that Windows can access the storage using the iSCSi HBA.

  11. Install the Windows HLK client application on the test computer.

  12. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. Also, when you schedule any iSCSI HBA tests, set up the communication between the HBA (initiator) and the iSCSI targets. If a test requires parameters to be set before it is run, a dialog box will appear for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


SAS Controller Testing Prerequisites

This section describes the tasks that you must complete before you test an SAS controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Hardware Requirements

The following hardware is required for testing an SAS controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test displayed for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and test controller, all hardware that is involved in the test must already have a logo.

  • One test computer. The test computer must meet the Windows HLK requirements as described in Windows HLK Prerequisites. Additionally, the computer must meet the following operating system-specific requirements.

    • For testing on Windows 8, Windows 7, Windows Vista or Windows XP:

      • One dual-core or equivalent processor

      • 4 GB of memory

    • For testing on Windows Server 2012, Windows Server 2008 R2, Windows Server 2008, or Windows Server 2003:

      • One quad-core or equivalent processor

      • 6 GB of memory

  • Two identical SAS controllers (the test devices), unless the test device is an integrated controller.

  • One PCI-to-PCI bridge adapter, unless any of the following conditions apply:

    • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

    • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

    • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

  • If the test device is an add-in SAS RAID controller, one of the following items:

    • Two SAS JBODs. One JBOD must have at least three hard disk drives. The other JBOD must have six hard drives.

    • One SAS JBOD that includes at least six hard disk drives and three SAS hard disk drives.

    • One SAS JBOD that includes at least three hard disk drives and six SATA hard disk drives.

    • Three SAS hard disk drives and six SATA hard disk drives.

    • One SAS JBOD that has at least six hard disk drives

    • Six SAS hard disk drives

  • If the SCSI controller does not support RAID, all of the following items are required:

    • One SAS hard disk drive that is at least 40 GB

    • One SATA hard disk drive that is at least 40 GB

    • Two SAS edge expanders

    • One SAS fanout expander

  • One bootable controller and hard disk drive that has at least 36 GB if the test device does not support boot.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required for testing a SAS controller:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The current release of the Windows Driver Kit (WDK).

Test Computer Configuration

There are three possible configurations for testing SAS controllers:

  • If the test device is an add-in controller that supports RAID, use the Add-in RAID controller test configuration.

  • If the test device is an integrated controller that supports RAID, use the Integrated RAID controller test configuration.

  • If the test device does not support RAID, use the Non-RAID controller test configuration.

Before you test an SAS controller in any of the three usage scenarios, make sure that the test computer is in the ready state. If a test requires parameters to be set before the test is run, a dialog box appears for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Additionally, the automated Disk Verification test is a 72-hour test. We recommend that you run this test last or over the weekend, so that you can collect and analyze the results from other tests without waiting for this test to finish.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).

Add-in RAID controller test configuration

To configure the test computer to test an SAS controller in an add-in RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Install one test controller (Controller 1).

    3. Install a PCI-to-PCI bridge, unless one of the following items is true:

      • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

    4. Install a second, duplicate test controller (Controller 2) in the PCI-to-PCI bridge card (or in the PCI bridge if the bridge card is not required).

    5. Attach the disks to the test devices according to the following table:

      Controller type Controller 1 Controller 2

      SAS RAID

      One SAS JBOD or three SAS hard disk drives

      One SAS JBOD or six SATA hard disk drives that are connected by a fanout expander in between two edge expanders

    6. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test system.

  3. Set the system BIOS to support the S3 state.

  4. Create one 60-GB RAID array on Controller 1 and two 60-GB RAID arrays on Controller 2.

  5. Configure the RAID arrays according to the following table:

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2 RAID level for RAID Array 3

    0 only

    0

    0

    0

    1 only

    1

    1

    1

    5 only

    5

    5

    5

    0 and 1 only

    1

    9

    0

    0 and 5 only

    5

    9

    0

    1 and 5 only

    5

    1

    1

    0, 1, and 10

    10

    1

    0

    0, 1, and 5

    5

    1

    0

    0, 1, 10, and 5

    5

    10

    0

  6. Install the appropriate Windows operating system on disk 1 (using a newly created NTFS partition that has at least 36 GB of disk space), and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller.

  7. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  8. Start the test computer in the Windows operating system, and then use Disk Manager to create three 4-GB partitions on RAID Array 2.

  9. If you are testing by using a client operating system, create a 4-GB NTFS spanned volume that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

    add-in raid array configuration diagram (client)

    If you are testing by using a server operating system, do the following:

    1. Create a software RAID 1 mirror from one of the NTFS partitions on RAID Array 2 to the unallocated space on RAID Array 1

    2. Create a 4-GB NTFS software RAID 5 array that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

      add-in raid array configuration diagram (server)

  10. To set the system page file and enable crashdump, do the following:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  11. Verify that the storage array is accessible from the test computer.

  12. Copy the Windows symbol files to %SystemDrive%\Symbols.

  13. Install the Windows HLK client application on the test computer.

  14. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Integrated RAID controller test configuration

To configure the test computer for testing of an SAS controller in an integrated RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Attach the disks to the integrated test controller (Controller 1) according to the following table:

      Controller type Controller 1

      SAS RAID

      One SAS JBOD or six SAS hard disk drives

    3. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test system.

  3. Set the system BIOS to support the S3 state.

  4. Create two 60-GB RAID arrays on Controller 1.

    If the controller does not support a configuration that includes two arrays, use a non-RAID disk instead of Array 2 for these procedures. For SCSI, create a third 60-GB RAID array (using any supported RAID level).

    The RAID arrays on Controller 1 are RAID Array 1 and RAID Array 2.

  5. Configure the RAID arrays according to the following table:

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2

    0 only

    0

    0

    1 only

    1

    1

    5 only

    5

    5 or Non-RAID disk

    0 and 1 only

    1

    0

    0 and 5 only

    5

    0 or Non-RAID disk

    1 and 5 only

    5

    1or Non-RAID disk

    0, 1, and 10

    10

    1 or Non-RAID disk

    0, 1, and 5

    5

    0 or Non-RAID disk

    0, 1, 10, and 5

    5

    10 or Non-RAID disk

  6. Install the appropriate Microsoft Windows operating system to a 36-GB NTFS volume on RAID Array 1, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller.

  7. If it is necessary, install any drivers that a manufacturer supplies that the devices in the test system require.

  8. Start Windows on the test computer.

  9. To set the system page file and enable crashdump, do the following:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  10. Verify that the storage array is accessible from the test computer.

  11. Copy the Windows symbol files to %SystemDrive%\Symbols.

  12. Install the Windows HLK client application on the test computer.

  13. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Non-RAID controller test configuration

To configure the test computer to test an SAS controller in a non-RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive if the test devices do not support boot.

    2. Install the test device (Controller 1).

    3. For add-in SAS controllers, install a PCI-to-PCI bridge, unless you meet the following requirements:

      • The controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the controllers into a PCI bus slot that is already behind a PCI bridge.

    4. For add-in SAS controllers, install a second, duplicate test controller (Controller 2) in the PCI-to-PCI bridge card (or in the PCI bridge if the bridge card is not required).

    5. Attach the disks to the test devices according to the following table:

      Controller type Controller 1 Controller 2

      SAS add-in controllers

      SAS HDD (Disk 1)

      Edge expander, then Fanout expander, then Edge expander, then SATA HDD

      (Disk 2)

      SAS integrated controllers

      SAS HDD (Disk 1), and Fanout expander, then Edge expander, then SATA HDD

      (Disk 2)

      N/A

    SAS add-in controllers configuration diagram

    ![diagram of an add-in sas assembly](images/hck-win8-non-raid-config-add-in-sas.png)

    SAS integrated controllers configuration diagram

    ![diagram of an integrated sas assembly](images/hck-win8-non-raid-config-integrated-sas.png)

6.  Attach an optical drive to the system, if one is not already attached.

  1. Turn on the test computer, install the appropriate Windows operating system on disk 1 (using a newly created NTFS partition that has at least 36 GB of disk space), and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller.

  2. Set the system BIOS to support the S3 state.

  3. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  4. Create three 4-GB partitions on Disk 2.

  5. Use the following procedure to set the system page file and enable crashdump:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  6. Copy the Windows symbol files to %SystemDrive%\Symbols.

  7. Install the Windows HLK client application on the test computer.

  8. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.


SATA Controller Testing Prerequisites

This section describes the tasks that you must complete before you test a SATA controller by using the Windows Hardware Lab Kit (Windows HLK).

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Hardware Requirements

The following hardware is required to test an SATA controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and test controller, all hardware that is involved in the test must already have a logo.

  • One test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • If the SATA controller supports RAID, the following requirements apply:

    • Two identical SATA RAID controllers (the test devices), unless the test device is an integrated controller.

    • One SATA hard disk drive for each channel that the test device supports. If two controllers are required, twice as many hard disk drives are required. Each hard disk drive must be at least 40 gigabytes (GB).

    • One PCI-to-PCI bridge adapter, unless any of the following conditions apply:

      • The RAID controllers cannot fit into PCI bridge adapters. This can occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

    • One optical drive.

    • If the SATA controller does not support RAID, the following requirements apply:

      • One SATA controller (the test device)

      • Two SATA hard disk drives that are least 40 GB

    • One bootable controller and hard disk drive that is at least 36 GB, if the test device does not support boot.

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you cannot use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required to test a SATA controller:

  • The drivers for the test device.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The current release of the Windows Driver Kit (WDK).

Test Computer Configuration

There are three possible configurations for testing SATA controllers:

  • If the test device is an add-in controller that supports RAID, use the Add-in RAID controller test configuration.

  • If the test device is an integrated controller that supports RAID, use the Integrated RAID controller test configuration.

  • If the test device does not support RAID, use the Non-RAID controller test configuration.

Before you test a SATA controller in any of the three usage scenarios, make sure that the test computer is in the ready state. If a test requires parameters to be set before it is run, a dialog box appears for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Add-in RAID controller test configuration

To configure the test computer to test a SATA controller as-an add-in RAID controller, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Install one test controller (Controller 1).

    3. Install a PCI-to-PCI bridge, unless any of the following conditions apply:

      • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

    4. Install a second, duplicate test controller (Controller 2) in the PCI-to-PCI bridge card (or in the PCI bridge if the bridge card is not required).

    5. Attach the disks to the test devices according to the following table:

      Controller type Controller 1 Controller 2

      SATA RAID

      One SATA hard disk drive on each supported channel

      One SATA hard disk drive on each supported channel

    6. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test computer.

  3. Set the system BIOS to support the S3 state.

  4. Create one 60-GB RAID array on Controller 1 and two 60-GB RAID arrays on Controller 2. The RAID array on Controller 1 is RAID Array 1, and the RAID arrays on Controller 2 are RAID Array 2 and RAID Array 3.

  5. Configure the RAID arrays according to the following table:

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2 RAID level for RAID Array 3

    0 only

    0

    0

    0

    1 only

    1

    1

    1

    5 only

    5

    5

    5

    0 and 1 only

    1

    9

    0

    0 and 5 only

    5

    9

    0

    1 and 5 only

    5

    1

    1

    0, 1, and 10

    10

    1

    0

    0, 1, and 5

    5

    1

    0

    0, 1, 10, and 5

    5

    10

    0

  6. Install the appropriate Windows operating system on disk 1 using a newly created NTFS partition that has at least 36 GB of disk space, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller.

  7. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  8. Start Windows on the test computer.

  9. Create three 4-GB partitions on RAID Array 2.

  10. If you are testing by using a client operating system, create a 4-GB NTFS spanned volume that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

    4-gb ntfs spanned volume

    If you are testing by using a server operating system, do the following:

    • Create a software RAID 1 mirror from one of the NTFS partitions on RAID Array 2 to the unallocated space on RAID Array 1.

      Create a 4-GB NTFS software RAID 5 array that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

      ntfs software raid 0 array

  11. To set the system page file and enable crashdump, follow these steps:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  12. Verify that the storage array is accessible from the test computer.

  13. Copy the Windows symbol files to %SystemDrive%\Symbols.

  14. Install the Windows HLK client application on the test computer.

  15. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Integrated RAID controller test configuration

To configure the test computer to test a SATA controller in an integrated RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Attach the disks to the integrated test controller (Controller 1) according to the following table:

      Controller type Controller 1

      SATA RAID

      One SATA hard disk drive on each supported channel

    3. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test computer.

  3. Set the system BIOS to support the S3 state.

  4. Create two 60-GB RAID arrays on Controller 1.

    If the controller does not support a configuration that includes two arrays, use a non-RAID disk instead of Array 2 for these procedures.

    The RAID arrays on Controller 1 are RAID Array 1 and RAID Array 2.

  5. Configure the RAID arrays according to the following table.

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2

    0 only

    0

    0

    1 only

    1

    1

    5 only

    5

    5 or Non-RAID disk

    0 and 1 only

    1

    0

    0 and 5 only

    5

    0 or Non-RAID disk

    1 and 5 only

    5

    1or Non-RAID disk

    0, 1, and 10

    10

    1 or Non-RAID disk

    0, 1, and 5

    5

    0 or Non-RAID disk

    0, 1, 10, and 5

    5

    10 or Non-RAID disk

  6. Install the appropriate Microsoft Windows operating system to a 36-GB NTFS volume on RAID Array 1, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller. If the test controller is not bootable, install Windows to a separate hard disk drive on a bootable controller.

  7. If it is necessary, install any drivers that a manufacturer supplies that the devices in the test system require.

  8. Start Windows on the test computer.

  9. To set the system page file and enable crashdump, do the following:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  10. Verify that the storage array is accessible from the test computer.

  11. Copy the Windows symbol files to %SystemDrive%\Symbols.

  12. Install the Windows HLK client application on the test computer.

  13. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Non-RAID controller test configuration

To configure the test computer for testing of an SATA controller in a non-RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive if the test devices do not support boot.

    2. Install the test device (Controller 1).

    3. Attach the disks to the test devices according to the following table:

      Controller type Controller 1 Controller 2

      SATA controllers

      2 SATA hard disk drives (Disk 1 and 2)

      Optical drive

      N/A

    4. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test computer.

  3. Set the system BIOS to support the S3 state.

  4. Turn on the test computer install the appropriate Windows operating system on disk 1 (using a newly created NTFS partition with at least 36 GB of disk space), and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  5. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  6. Create three 4-GB partitions on Disk 2.

  7. Use the following procedure to set the system page file and enable crashdump:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  8. Verify that the storage array is accessible from the test computer.

  9. Copy the Windows symbol files to %SystemDrive%\Symbols.

  10. Install the Windows HLK client application on the test computer.

  11. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state that is unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


SCSI Controller Testing Prerequisites

This section describes the tasks that you must complete before you test an SCSI controller by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware Requirements.

  • Software Requirements.

  • Test Computer Configuration.

Hardware Requirements

The following hardware is required to test an ATA/ATAPI controller. You might need additional hardware if the test device offers other features. To determine whether additional hardware requirements apply, see the test description for each test that appears for the device in Windows HLK Studio.

NOTE

With the exception of the test computer and test controller, all hardware that is involved in the test must already have a logo.

  • One test computer. The test computer must meet the Windows HLK requirements. For more information, see Windows HLK Prerequisites.

  • Two identical SCSI controllers (the test devices), unless the test device is an integrated controller.

  • One PCI-to-PCI bridge adapter, unless any of the following conditions apply:

    • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

    • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

    • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

  • If the SCSI controller supports RAID, you must have all of the following:

    • One SCSI JBOD.

    • One additional SCSI JBOD or three SCSI hard disk drives, unless the test device is an integrated controller.

    • One optical drive.

  • If the SCSI controller does not support RAID, you must have all of the following:

    • Three identical SCSI hard disk drives that have Wide SCSI support, if the test device supports it. The hard disk drives must each have at least 40 gigabytes (GB).

    • Two SCSI CD drives that have a minimum speed of 8x.

    • One SCSI removable media drive.

    • One SCSI tape drive that has Wide SCSI support, if the test device supports it.

    • One blank tape cartridge.

  • One bootable controller and hard disk drive (36 GB minimum), if the test device does not support boot.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. If the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's rebalance, D3 state, and multiple processor groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required to test an SCSI controller:

  • The drivers for the test controllers.

  • The latest Windows HLK filters or updates.

  • Windows symbol files. These are available from the Symbol Files website.

  • The current release of the Windows Driver Kit (WDK).

Test Computer Configuration

There are three possible configurations for testing SCSI controllers:

  • If the test device is an add-in controller that supports RAID, use the Add-in RAID controller test configuration.

  • If the test device is an integrated controller that supports RAID, use the Integrated RAID controller test configuration.

  • If the test device does not support RAID, use the Non-RAID controller test configuration.

Before you test an SCSI controller in any of the three usage scenarios, make sure that the test computer is in the ready state. If a test requires parameters to be set before it is run, a dialog box appears for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When you run tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.

Add-in RAID controller test configuration

To configure the test computer to test an SCSI controller in an add-in RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Install one test controller (Controller 1).

    3. Install a PCI-to-PCI bridge, unless any of the following conditions apply:

      • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

    4. Install a second, duplicate test controller (Controller 2) into the PCI-to-PCI bridge card (or in the PCI bridge if the bridge card is not required).

    5. Attach the disks to the test devices according to the following table:

      Controller type Controller 1 Controller 2

      SCSI RAID

      One SCSI JBOD

      One SCSI JBOD

    6. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test computer.

  3. Set the system BIOS to support the S3 state.

  4. Create one 60-GB RAID array on Controller 1 and two 60-GB RAID arrays on Controller 2. The RAID array on Controller 1 is RAID Array 1, and the RAID arrays on Controller 2 are RAID Array 2 and RAID Array 3.

  5. Configure the RAID arrays according to the following table:

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2 RAID level for RAID Array 3

    0 only

    0

    0

    0

    1 only

    1

    1

    1

    5 only

    5

    5

    5

    0 and 1 only

    1

    9

    0

    0 and 5 only

    5

    9

    0

    1 and 5 only

    5

    1

    1

    0, 1, and 10

    10

    1

    0

    0, 1, and 5

    5

    1

    0

    0, 1, 10, and 5

    5

    10

    0

  6. Turn on the test computer, install the appropriate Windows operating system on disk 1 by using a newly created NTFS partition that has at least 36 GB of disk space, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install a separate hard disk drive on a bootable controller.

  7. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  8. Start Windows on the test computer.

  9. Create three 4-GB partitions on RAID Array 2.

  10. If you are testing by using a client operating system, create a 4-GB NTFS spanned volume that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

    add-in raid array configuration diagram (client)

    If you are testing by using a server operating system, do the following:

    1. Create a software RAID 1 mirror from one of the NTFS partitions on RAID Array 2 to the unallocated space on RAID Array 1

    2. Create a 4-GB NTFS software RAID 5 array that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

      add-in raid array configuration diagram (server)

  11. To set the system page file and enable crashdump, follow these steps:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  12. Verify that the storage array is accessible from the test computer.

  13. Copy the Windows symbol files to %SystemDrive%\Symbols.

  14. Install the Windows HLK client application on the test computer.

  15. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Integrated RAID controller test configuration

To configure the test computer to test an SCSI controller in an integrated RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive, if the test devices do not support boot.

    2. Attach the disks to the integrated test controller (Controller 1) according to the following table:

      Controller type Controller 1

      SCSI RAID

      One SCSI JBOD or three SCSI hard disk drives, and one SCSI optical drive (if supported)

    3. Attach an optical drive to the system, if one is not already attached.

  2. Turn on the test computer.

  3. Set the system BIOS to support the S3 state.

  4. Create two 60-GB RAID arrays on Controller 1.

    If the controller does not support a configuration that includes two arrays, use a non-RAID disk instead of Array 2 for these procedures. For SCSI, create a third 60-GB RAID array (using any supported RAID level).

    The RAID arrays on Controller 1 are RAID Array 1 and RAID Array 2.

  5. Configure the RAID arrays according to the following table:

    RAID levels that the test device supports RAID level for RAID Array 1 RAID level for RAID Array 2

    0 only

    0

    0

    1 only

    1

    1

    5 only

    5

    5 or Non-RAID disk

    0 and 1 only

    1

    0

    0 and 5 only

    5

    0 or Non-RAID disk

    1 and 5 only

    5

    1or Non-RAID disk

    0, 1, and 10

    10

    1 or Non-RAID disk

    0, 1, and 5

    5

    0 or Non-RAID disk

    0, 1, 10, and 5

    5

    10 or Non-RAID disk

  6. Install the appropriate Windows operating system, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.Windows HLK Studio and Windows HLK Controller. If the test controller is not bootable, install Windows to a separate hard disk drive on a bootable controller.

  7. If it is necessary, install any drivers that a manufacturer supplies that the devices in the test system require.

  8. Start Windows on the test computer.

  9. Use the Windows Disk Management utility to configure all of the disks to be dynamic.

  10. Create three 4-GB NTFS partitions on RAID Array 2.

  11. If you are testing by using a client operating system, create a 4-GB NTFS spanned volume that uses unallocated space on RAID Array 1, RAID Array 2, and Array 3 as the following diagram shows.

    integrated raid array configuration diagram (clien

    If you are testing by using a server operating system:

    1. Create a software RAID 1 mirror from one of the NTFS partitions on RAID Array 1 to the unallocated space on RAID Array 2, as the following diagram shows.

    2. Create a software NTFS RAID 5 array that uses unallocated space on RAID Array 1, RAID Array 2, and RAID Array 3, as the following diagram shows.

      integrated raid array configuration diagram (serve

  12. To set the system page file and enable crashdump, follow these steps:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  13. Verify that the storage array is accessible from the test computer.

  14. Copy the Windows symbol files to %SystemDrive%\Symbols.

  15. Install the Windows HLK client application on the test computer.

  16. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

Non-RAID controller test configuration

To configure the test computer to test an SCSI controller in a non-RAID configuration, follow these steps:

  1. When the test computer is turned off, complete the following assembly steps:

    1. Install a boot-capable controller (not the test device) and hard disk drive if the test devices do not support boot.

    2. Install the test device (Controller 1).

    3. Install a PCI-to-PCI bridge, unless any of the following conditions apply:

      • The RAID controllers cannot fit into PCI bridge adapters. This may occur if the controllers are integrated controllers or if the controllers can only fit into specially designed slots.

      • The RAID controller is designed and sold only for systems that cannot accept full height PCI-to-PCI bridge adapters, such as blade servers.

      • You can put one of the RAID controllers into a PCI bus slot that is already behind a PCI bridge.

    4. Install a second, duplicate test controller (Controller 2) in the PCI-to-PCI bridge card (or in the PCI bridge if the bridge card is not required).

    5. Attach the disks to the test devices according to the following table.

      Controller type Controller 1 Controller 2

      SCSI add-in controllers

      SCSI HDD (Disk 1)

      SCSI optical drive

      SCSI tape drive

      SCSI removable media drive

      SCSI HDD (Disk 2)

      SCSI optical drive

      SCSI integrated controllers

      Note

      See the SCSI add-in controllers configuration diagram below.

      SCSI HDD (Disk 1)

      SCSI optical drive

      SCSI tape drive

      SCSI removable media drive

      SCSI HDD (Disk 2)

      N/A

    For SCSI add-in controllers, configure the hardware as described in the following diagram:

    ![diagram of an add-in scsi assembly](images/hck-win8-non-raid-config-add-in-scsi.png)

    For SCSI integrated controllers, configure the hardware as described in the following diagram:

    ![diagram of an integrated scsi assembly](images/hck-win8-non-raid-config-integrated-scsi.png)

6.  Attach an optical drive to the system, if one is not already attached.

  1. Turn on the test computer.

  2. Set the system BIOS to support the S3 state.

  3. Install the appropriate Windows operating system, and then configure the computer for your test network. The test network is the network that contains the Windows HLK Studio and Windows HLK Controller.

  4. If you have to install the manufacturer-supplied device driver on the test computer, do this now.

  5. Create three 4-GB partitions on Disk 2.

  6. Use the following procedure to set the system page file and enable crashdump:

    1. Click the Start button, right-click My Computer, and then click Properties.

    2. Click the General tab, and then note the amount of RAM that the computer contains.

    3. Click the Advanced tab (or click Advanced system settings in the left pane for Windows Vista, Windows 7, Windows 8, Windows Server 2008, Windows Server 2008 R2 or Windows Server 2012), and then, in the Performance area, click Settings.

      NOTE

      If you are prompted to enter administrative credentials or allow the action, enter the credentials or allow the action.

    4. Click the Advanced tab, and then, in the Virtual Memory area, click Change.

    5. Select Custom Size, and then enter a number in the Initial size (MB) box that is larger than the size of RAM that you noted in step b.

    6. In the Maximum size (MB) text box, enter a maximum size value that is larger than the initial size that you entered in the Initial size (MB) box. (The maximum size is typically 1.5 to 2 times the initial size.)

    7. Click Set, and then click OK two times.

    8. Click OK, and then restart the computer to update the page file size.

  7. Verify that the storage array is accessible from the test computer.

  8. Copy the Windows symbol files to %SystemDrive%\Symbols.

  9. Install the Windows HLK client application on the test computer.

  10. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

WARNING

When testing storage devices, we strongly recommend that you complete all Device Fundamentals tests before starting storage tests. Storage tests will reconfigure your test device, leaving the device in a state unsuitable to support Device Fundamentals tests. The following configurations provide steps to create volume on the storage test device. This is important to complete the Device Fundamental part of testing (DevFund).


Troubleshooting Device.Storage Testing

To troubleshoot issues that occur with Device.Storage tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review one of these Windows Hardware Lab Kit (Windows HLK) topics, depending on the type of storage device or configuration:

    • Hard Disk Drive Testing Prerequisites

    • Hardware-based Raid Systems (Fibre Channel, SAS, SCSI, Serial ATA) Testing Prerequisites

    • Optical Disk Drive Testing Prerequisites

    • Removable Storage Testing Prerequisites

    • Secure Digital Host Controller Storage Testing Prerequisites

    • Storage Adapter or Controller Testing Overview

  3. Review the Windows HLK release notes for current test issues.

  4. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  5. If you observe any failures while running the tests in the Windows HLK, look at the test logs that were generated. For example, for the Enumeration Test, the most relevant log is enumeratedrive.log.wtl. To view this log, go to the Results tab in the HLK studio and expand Enumeration Test > Test Run Date and Time > Run Test > Logs > enumeratedrive.log.wtl.

  6. To debug more, rerun the test manually from the Command Prompt (cmd), while setting the verbosity level to 4. This allows the test to log more information, such as data buffer, CDB information, and sense code. Documentation for each test contains details about the binary that is related to a particular test along with the binary location.

Optical Storage Device

These are common issues with optical disk drive tests:

  • Some controllers that use Serial Advanced Technology Attachment (SATA) Advanced Host Controller Interface (AHCI) mode might cause the CDBs to time out. This time-out occurs most frequently in the Start Stop Unit test, where the CDB after test unit ready times out without any sense code being returned. To resolve the issue, try a different controller or configuration.

  • Some drives intermittently can't delete data from a disk. This issue might be caused by rewritable media that has been used too many times. Try to use new rewritable media.

For more information about how to troubleshoot a test, see the troubleshooting section of a specific test in Device.Storage Tests.

Hybrid Information Device

There are special steps that can be taken to reproduce a particular test case in a test, or if necessary, conduct a manual investigation of the device.

  1. Install hybridflt. These files(.inf, .sys, .cat) are found under the same folder as hybriddrive.exe

  2. Enable Storport Tracing

  3. Run hybriddrive.exe

Command | Description
Hybriddrive.exe -drive <disk #> -scenario <scenario> <additional options> | Runs the test.
-Drive <disk#> | The drive to be tested on. The behavior of boot drives or drives with a file system is not defined.
-Verbosity | The logging level for this test. Default value: 1
-? | Displays help.
-Scenario logrw | The scenario to run.
-case # | The test case to run.
-length #(k|m|g) | Specifies the length of the operation.
-offset #(k|m|g) | Specifies the offset of the operation from the start of the disk.
-tpriority #(|none) | Specifies the target priority of the operation. Specify none for no priority (this is different than a priority of 0).
-spriority # | Specifies the source priority of the operation.
-thigh # | Specifies the high threshold.
-tlow # | Specifies the low threshold.
-operation (r|w) | Specifies read or write.

Test scenarios:

  • Logverify

  • Logrw

  • Logcommand

  • Location

  • Tagperf

Manual operation:

  • Print

    • Prints out the current state of the disk.

  • Changelba

    • Sends down change lba by range command. Valid options for this command are length, offset, and tpriority.

  • Demote

    • Sends down demote by size command. Valid options for this command are length, tpriority, and spriority.

  • Off

    • Turns off the cache.

  • On

    • Turns on the cache.

  • Evict

    • Sends an evict command. Valid options for this command are length and offset.

  • Threshold

    • Sets the dirty threshold. Valid options for this command are thigh and tlow.

  • Movedata

    • Reads and writes data from the device. Valid options for this command are length, offset, tpriority, and operation. This will also set the priority for any future I/O.

  • Priority

    • Set the priority for future reads and writes. Valid options for this command are tpriority.
NOTE

Invalid parameters will be ignored.

Unspecified valid parameters are defaulted to a fixed value.

Removable Storage Device

These are common perfomance issues with removable storage devices.

For storage devices that have removable attributes, I/O queuing is disabled on a particular driver stack to ensure that data can be written as much as possible. However, the queueing is enabled on devices that are recognized as fixed disk. If I/O queuing is disabled, the next I/O request is made after waiting for each I/O request to complete. Therefore, it will have lower throughput than a fixed disk.

For more information about how to troubleshoot a test, see the troubleshooting section of a specific test in Device.Storage Tests.

Related topics

Device.Storage Tests

Troubleshooting Windows HLK


Device.Streaming

In this section

  • Device.Streaming tests
  • Device.Streaming additional documentation


Device.Streaming tests

  • Camera Driver Basic Perf Color Latency Test
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Log all profiles
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_BalancedVideoAndPhoto enum all
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, photo and preview
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, rec and preview
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto is supported, set first index
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto, enum all
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoConferencing enum all
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording enum all
  • Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording is supported, set first index
  • Camera Driver Device Test - MediaCapture - TestEnumerateVideoProfile
  • Camera Driver Device Test - MediaCapture - TestVideoProfileSupportedFlags
  • Camera Driver Device Test - MediaCapture - ValidatePowerlineFrequency
  • Camera Driver DirectShow Interfaces - IAMCameraControl
  • Camera Driver DirectShow Interfaces - IAMCameraControl
  • Camera Driver DirectShow Interfaces - IAMStreamConfig
  • Camera Driver DirectShow Interfaces - IAMStreamConfig
  • Camera Driver DirectShow Interfaces - IAMVideoCompression
  • Camera Driver DirectShow Interfaces - IAMVideoCompression
  • Camera Driver DirectShow Interfaces - IAMVideoControl
  • Camera Driver DirectShow Interfaces - IAMVideoControl
  • Camera Driver DirectShow Interfaces - IAMVideoProcAmp
  • Camera Driver DirectShow Interfaces - IAMVideoProcAmp
  • Camera Driver DirectShow Interfaces - IMediaControl
  • Camera Driver DirectShow Interfaces - IMediaControl
  • Camera Driver DirectShow Video Capture - Capture
  • Camera Driver DirectShow Video Capture - Capture
  • Camera Driver DirectShow Video Capture - Capture then Playback
  • Camera Driver DirectShow Video Capture - Capture then Playback
  • Camera Driver DirectShow Video Preview - Preview Video Capture Device
  • Camera Driver DirectShow Video Preview - Preview Video Capture Device
  • Camera Driver DirectShow Video Properties - Class Compliance or WDM Compliance
  • Camera Driver DirectShow Video Properties - Class Compliance or WDM Compliance
  • Camera Driver DirectShow Video Properties - Query Current Video Capture Device Properties
  • Camera Driver DirectShow Video Properties - Query Current Video Capture Device Properties
  • Camera Driver DirectShow Video Properties - VideoInfoHeader2 Data
  • Camera Driver DirectShow Video Properties - VideoInfoHeader2 Data
  • Camera Driver Registration, Metadata, and Dependency Test
  • Camera Driver System Test - MediaCapture - TestConcurrentRecordAndPhotoCapture
  • Camera Driver System Test - MediaCapture - TestEnumerateMediaEncodingProperties
  • Camera Driver System Test - MediaCapture - TestEnumerateVideoProfile
  • Camera Driver System Test - MediaCapture - TestMft0GetService
  • Camera Driver System Test - MediaCapture - TestPhotoCapture
  • Camera Driver System Test - MediaCapture - TestPreview
  • Camera Driver System Test - MediaCapture - TestVideoCapture
  • Camera Driver Test - Video Capture (Record) - Record 10 min Video from default Capture pin format to H264 file (Video Only)
  • Camera Driver Test - Video Capture (Record) - Record 30 seconds of 480p Video from Capture pin to H264 file (Video Only)
  • Camera Driver Test - Video Capture (Record) - Record video to a single H264 file from all formats advertised on the camera's default capture stream
  • Camera Driver Test - Video Capture (Record) - Record video to an H264 file from each format advertised on the on the camera's default capture stream
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture Bitmap Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture GIF Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture JPEG Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture JPEGXR Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture GIF Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Capture Bitmap Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Capture GIF Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Capture JPEG Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Capture JPEGXR Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture GIF Photo
  • Camera Driver Test - Photo Capture - Capture a BGRA8 image from the default type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a BGRA8 photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a BGRA8 photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a BGRA8 photo from the default type exposed by the preview pin
  • Camera Driver Test - Photo Capture - Capture a Bitmap photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a Bitmap photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a Bitmap photo from the default type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a Bitmap photo from the default type exposed by the preview pin
  • Camera Driver Test - Photo Capture - Capture a GIF photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a GIF photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a GIF photo from the default format advertised on the camera's preferred stream for photo
  • Camera Driver Test - Photo Capture - Capture a GIF photo from the default format advertised on the camera's preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a JPEG photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a JPEG photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a JPEG photo from the default format advertised on the camera's preferred stream for photo
  • Camera Driver Test - Photo Capture - Capture a JPEG photo from the default format advertised on the camera's preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a JPEG-XR photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a JPEG-XR photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a JPEGXR photo from the default type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a JPEGXR photo from the default type exposed by the preview pin
  • Camera Driver Test - Photo Capture - Capture a PNG photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture a PNG photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a PNG photo from the default type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture a PNG photo from the default type exposed by the preview pin
  • Camera Driver Test - Photo Capture - Capture an NV12 photo from each format exposed on the preferred stream for video preview
  • Camera Driver Test - Photo Capture - Capture an NV12 photo from each type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture an NV12 photo from the default type exposed by the photo pin
  • Camera Driver Test - Photo Capture - Capture an NV12 photo from the default type exposed by the preview pin
  • Camera Driver Test - Preview (Sample Grabber) for 20 minutes and Capture 127 JPEG images
  • Camera Driver Test - Preview (Sample Grabber), Capture Bitmap image from each image Stream type
  • Camera Driver Test - Preview (Sample Grabber), Capture GIF image from each image Stream type
  • Camera Driver Test - Preview (Sample Grabber), Capture JPEG image from each image Stream type
  • Camera Driver Test - Preview (Sample Grabber), Capture JPEGXR image from each image Stream type
  • Camera Driver Test - Preview for 20 minutes and Capture 127 JPEG images
  • Camera Driver Test - Preview, Capture Bitmap image from each image Stream type
  • Camera Driver Test - Preview, Capture GIF image from each image Stream type
  • Camera Driver Test - Preview, Capture JPEG image from each image Stream type
  • Camera Driver Test - Preview, Capture JPEGXR image from each image Stream type
  • Camera Driver Test - Record and Preview (Sample Grabber) for 30 minutes, Capture 55 photos
  • Camera Driver Test - Record and Preview (Sample Grabber) video for 30 minutes
  • Camera Driver Test - Record and Preview for 30 minutes, Capture 55 photos
  • Camera Driver Test - Record and Preview video for 30 minutes
  • Camera Driver Test - UVC Test 1
  • Camera Driver Test - UVC Test 2
  • Camera Driver Test - UVC Test 3
  • Camera Driver Test - Video Capture (Record) - Record 30 seconds of 720p Video from Capture pin to H264 file (Video Only)
  • Camera Driver Test - Video Preview (Sample Callback) - Stream video from all available format on the preview stream and dynamic format switching
  • Camera Driver Test - Video Preview (Sample Callback) - Stream video from each available format from the camera's preview stream
  • Camera Driver Test - Video Preview (Sample Callback) - Stream video from the default format on Camera preview stream
  • Camera Driver Test - Video Preview (View Finder) - Stream video from all available format on the preview stream and dynamic format switching
  • Camera Driver Test - Video Preview (View Finder) - Stream video from each available format from the camera's preview stream
  • Camera Driver Test - Video Preview (View Finder) - Stream video from the default format on Camera preview stream
  • Camera Driver Usage Indicator Manual Test
  • Face sensor validation tests
  • H263 Decoder HMFT Playback Test 1
  • H263 Decoder HMFT Playback Test 2
  • H263 Decoder HMFT Playback Test 3
  • H263 Decoder HMFT Playback Test 4
  • H264 Advanced Encode Test #1600
  • H264 Advanced Encode Test #1601
  • H264 Advanced Encode Test #1602
  • H264 Advanced Encode Test #1603
  • H264 Advanced Encode Test #1604
  • H264 Advanced Encode Test #1605
  • H264 Advanced Encode Test #1606
  • H264 Advanced Encode Test #1607
  • H264 Advanced Encode Test #1608
  • H264 Advanced Encode Test #1609
  • H264 Advanced Encode Test #801
  • H264 Advanced Encode Test #802
  • H264 Advanced Encode Test #803
  • H264 Basic Encode Test #1200
  • H264 Basic Encode Test #1201
  • H264 Basic Encode Test #1202
  • H264 Basic Encode Test #1203
  • H264 Basic Encode Test #1204
  • H264 Basic Encode Test #1205
  • H264 Basic Encode Test #1800
  • H264 Basic Encode Test #1801
  • H264 Basic Encode Test #1802
  • H264 Benchmark Test #851
  • H264 Benchmark Test #852
  • H264 Benchmark Test #853
  • H264 Encode Quality Miracast Test #1504
  • H264 Encode Quality Test #1500
  • H264 Encode Quality Test Test #1501
  • H264 Encode Quality Test Test #1502
  • H264 Encode Quality Test Test #1503
  • H264 Encoder - HMFT Transcode test 1
  • H264 Encoder - HMFT Transcode test 11
  • H264 Encoder - HMFT Transcode test 32
  • H264 HW-DRM CENC Test
  • H264 HW-DRM CENC Test
  • H264 HW-DRM Video 1
  • H264 HW-DRM Video 2
  • H264 HW-DRM Video 3
  • H264 HW-DRM Video 4
  • H264 HW-DRM Video 5
  • H264 HW-DRM Video 6
  • H264 HW-DRM Video 7
  • H264 Intermediate Encode Test #1400
  • H264 Intermediate Encode Test #1401
  • H264 Intermediate Encode Test #1402
  • H264 Intermediate Encode Test #1403
  • H264 Intermediate Encode Test #1404
  • H264 Miracast Encode Test #1300
  • H264 Miracast Encode Test #1301
  • H264 Miracast Encode Test #1302
  • H264 Miracast Encode Test #1303
  • H264 Miracast Encode Test #1304
  • H264 Miracast Encode Test #1305
  • H264 Miracast Encode Test #1306
  • H264 Miracast Encode Test #1307
  • H264 Playback Test 20
  • H264 SW-DRM Video 1
  • H264 SW-DRM Video 2
  • H264 SW-DRM Video 3
  • H264 SW-DRM Video 4
  • H264 SW-DRM Video 5
  • H264 SW-DRM Video 6
  • H264 SW-DRM Video 7
  • H264 fuzz test 1
  • H264 fuzz test 2
  • H264 fuzz test 3
  • H264 playback test 1
  • H264 playback test 10
  • H264 playback test 11
  • H264 playback test 12
  • H264 playback test 13
  • H264 playback test 14
  • H264 playback test 15
  • H264 playback test 16
  • H264 playback test 17
  • H264 playback test 2
  • H264 playback test 21
  • H264 playback test 22
  • H264 playback test 23
  • H264 playback test 24
  • H264 playback test 3
  • H264 playback test 4
  • H264 playback test 5
  • H264 playback test 6
  • H264 playback test 7
  • H264 playback test 8
  • H264 playback test 9
  • H265 Advanced Encode Test #1610
  • H265 Advanced Encode Test #1611
  • H265 Advanced Encode Test #1612
  • H265 Basic Encode Test #1206
  • H265 Basic Encode Test #1207
  • H265 Basic Encode Test #1208
  • H265 Basic Encode Test #1209
  • H265 Basic Encode Test #1210
  • H265 Basic Encode Test #1211
  • H265 Encode Quality Test #1505
  • H265 Encode Quality Test #1506
  • H265 Encode Quality Test #1507
  • H265 Encode Quality Test #1508
  • H265 Intermediate Encode Test #1410
  • H265 Intermediate Encode Test #1405
  • H265 Intermediate Encode Test #1406
  • H265 Intermediate Encode Test #1407
  • H265 Intermediate Encode Test #1408
  • H265 Intermediate Encode Test #1409
  • HEVC 10-Bit Playback Test 1
  • HEVC 10-Bit Playback Test 17
  • HEVC Encode Quality Miracast Test #1513
  • HEVC Fuzz Test 1
  • HEVC Fuzz Test 2
  • HEVC Fuzz Test 3
  • HEVC Fuzz Test 4
  • HEVC Fuzz Test 5
  • HEVC Fuzz Test 6
  • HEVC HW-DRM CENC Test
  • HEVC HW-DRM Video 1
  • HEVC HW-DRM Video 2
  • HEVC HW-DRM Video 3
  • HEVC HW-DRM Video 4
  • HEVC HW-DRM Video 5
  • HEVC HW-DRM Video 6
  • HEVC HW-DRM Video 7
  • HEVC HW-DRM Video 8
  • HEVC Playback Test 1
  • HEVC Playback Test 10
  • HEVC Playback Test 11
  • HEVC Playback Test 12
  • HEVC Playback Test 13
  • HEVC Playback Test 14
  • HEVC Playback Test 15
  • HEVC Playback Test 18
  • HEVC Playback Test 2
  • HEVC Playback Test 3
  • HEVC Playback Test 4
  • HEVC Playback Test 5
  • HEVC Playback Test 6
  • HEVC Playback Test 7
  • HEVC Playback Test 8
  • HEVC Playback Test 9
  • HEVC Playback test 20
  • HEVC Playback test 21
  • HEVC Playback test 22
  • HEVC Playback test 23
  • HEVC Playback test 24
  • HEVC Playback test 25
  • HEVC Playback test 26
  • HEVC Playback test 27
  • HEVC Playback test 28
  • HEVC Playback test 29
  • HEVC Playback test 30
  • HEVC Playback test 31
  • HEVC Playback test 32
  • HEVC Playback test 33
  • HEVC Playback test 34
  • HEVC Playback test 36
  • HEVC Playback test 37
  • HEVC Playback test 38
  • HEVC Playback test 39
  • HEVC Playback test 40
  • HEVC Playback test 41
  • HEVC Playback test 42
  • HEVC Playback test 43
  • HEVC Playback test 44
  • HEVC Playback test 45
  • HEVC Playback test 46
  • HEVC Playback test 47
  • HEVC Playback test 48
  • HEVC SW-DRM Video 1
  • HEVC SW-DRM Video 2
  • HEVC SW-DRM Video 3
  • HEVC SW-DRM Video 4
  • HEVC SW-DRM Video 5
  • HEVC SW-DRM Video 6
  • HEVC SW-DRM Video 7
  • HEVC SW-DRM Video 8
  • HW-DRM - Verify Codec Support Test
  • HW-DRM Video - Play protected content using hardware decryptor
  • MJPEG Decoder - H264 Encoder - HMFT Transcode test 10
  • MJPEG Decoder - HMFT compliance test 61
  • MJPEG Decoder - HMFT Playback test 150
  • MJPEG Decoder - HMFT Playback test 151
  • MJPEG Decoder - HMFT Playback test 152
  • MJPEG Decoder - HMFT Playback test 153
  • MJPEG Decoder - HMFT Playback test 154
  • MJPEG Decoder - HMFT Playback test 155
  • MJPEG Decoder - HMFT Playback test 156
  • MJPEG Decoder - HMFT Playback test 157
  • MJPEG Decoder - HMFT Playback test 432
  • MJPEG Decoder - HMFT Stress test 450
  • MJPEG Decoder HMFT Playback Test 1
  • MJPEG Decoder HMFT Playback Test 2
  • MJPEG Decoder HMFT Playback Test 3
  • MJPEG Decoder HMFT Playback Test 4
  • MJPEG Decoder HMFT Playback Test 5
  • MJPEG Decoder HMFT Playback Test 6
  • MJPEG Decoder HMFT Playback Test 7
  • MJPEG Decoder HMFT Playback Test 8
  • MJPEG Decoder HMFT Playback Test 9
  • MJPEG Encoder - HMFT compliance test 60
  • MPEG2 Playback Test 1
  • MPEG2 Playback Test 10
  • MPEG2 Playback Test 2
  • MPEG2 Playback Test 3
  • MPEG2 Playback Test 4
  • MPEG2 Playback Test 5
  • MPEG2 Playback Test 6
  • MPEG2 Playback Test 7
  • MPEG2 Playback Test 8
  • MPEG2 Playback Test 9
  • MPEG4 Decoder - H264 Encoder - HMFT Transcode test 3
  • MPEG4 Decoder - HMFT compliance test 13
  • MPEG4 Decoder - HMFT compliance test 14
  • MPEG4 Decoder - HMFT compliance test 15
  • MPEG4 Decoder - HMFT compliance test 16
  • MPEG4 Decoder - HMFT compliance test 17
  • MPEG4 Decoder - HMFT compliance test 18
  • MPEG4 Decoder HMFT Playback Test 1
  • MPEG4 Decoder HMFT Playback Test 2
  • MPEG4 Decoder HMFT Playback Test 3
  • MPEG4 Decoder HMFT Playback Test 4
  • MPEG4 Decoder HMFT Playback Test 5
  • MPEG4 Decoder HMFT Playback Test 6
  • MPEG4 Decoder HMFT Playback Test 7
  • MPEG4 Decoder HMFT Playback test 110
  • MPEG4 Decoder HMFT Playback test 111
  • MPEG4 Decoder HMFT Playback test 118
  • MPEG4 Decoder - HMFT Playback test 125
  • MPEG4 Decoder - HMFT Playback test 129
  • MPEG4 Decoder - HMFT Playback test 131
  • MPEG4 Decoder HMFT Playback test 421
  • MPEG4 Decoder HMFT Stress test 444
  • SW-DRM Video - Play protected content using software decryptor
  • Sensor Camera Driver Basic Capture Session - Preview Sink - All Mediatype
  • Sensor Camera Driver Basic Capture Session - Preview Sink - All Mediatype with Metadata
  • Sensor Camera Driver Registration, Metadata, and Dependency Test
  • VP8 Fuzz test test 1
  • VP8 Playback Test 5
  • VP8 Playback test 1
  • VP8 Playback test 2
  • VP8 Playback test 3
  • VP8 Playback test 4
  • VP9 10 bit Fuzz test 1
  • VP9 10 bit Fuzz test 2
  • VP9 10 bit playback test 1
  • VP9 10 bit playback test 2
  • VP9 Basic Encode Test #1212
  • VP9 Basic Encode Test #1213
  • VP9 Basic Encode Test #1214
  • VP9 Basic Encode Test #1215
  • VP9 Encode Quality Test #1509
  • VP9 Encode Quality Test #1510
  • VP9 Encode Quality Test #1511
  • VP9 Encode Quality Test #1512
  • VP9 Fuzz test 1
  • VP9 Fuzz test 2
  • VP9 Fuzz test 3

  • VP9 HW-DRM Video 1

  • VP9 Playback Test 1

  • VP9 Playback Test 10
  • VP9 Playback Test 2
  • VP9 Playback Test 3
  • VP9 Playback Test 4
  • VP9 Playback Test 5
  • VP9 Playback Test 6
  • VP9 Playback Test 7
  • VP9 Playback Test 8
  • VP9 Playback Test 9
  • VP9 SW-DRM Video 1
  • VideoProcessor - Tone mapped conversions - HDR to SDR, HDR to HDR
  • VideoProcessor - Tone mapper hue consistency - HDR to SDR, HDR to HDR
  • WMV fuzz test 1
  • WMV fuzz test 2
  • WMV fuzz test 3
  • WMV playback test 1
  • WMV playback test 10
  • WMV playback test 11
  • WMV playback test 12
  • WMV playback test 13
  • WMV playback test 14
  • WMV playback test 15
  • WMV playback test 16
  • WMV playback test 17
  • WMV playback test 18
  • WMV playback test 19
  • WMV playback test 2
  • WMV playback test 20
  • WMV playback test 21
  • WMV playback test 22
  • WMV playback test 3
  • WMV playback test 4
  • WMV playback test 5
  • WMV playback test 6
  • WMV playback test 7
  • WMV playback test 8
  • WMV playback test 9


Camera Driver Basic Perf Color Latency Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/922a4217-e0c5-4fe2-8ecf-a87391947cc0

This test verifies that the camera latency meets the recommended levels

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.Discretional.BasicPerf
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Log all profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62ec3a8d-6329-4077-babe-aeabaac5cc84

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_BalancedVideoAndPhoto enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9df00d12-b83f-43ca-a860-3f522847d71c

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d53d14a-0c5d-4980-8588-9fdadce624bb

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, photo and preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8f78d4a-b6c7-4ad1-b6a6-d9b53dc0cfdb

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, rec and preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eaeb28f5-55ae-4e77-968d-5f7af85c461a

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto is supported, set first index

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69e712d1-3256-4ef9-aecf-80436fe41e37

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto, enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1eb9979-f0c3-4e80-9b3a-e59ea2d260f2

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoConferencing enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c0f2bc9-64ec-4051-8b72-6dae8d561e05

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f679093-267b-4711-9e16-7027884f055d

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Device Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording is supported, set first index

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/762d18e5-63ca-4611-af55-857f3a218d59

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Profiles Collect DevPKey Profiles (Device Test)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40614ec7-9eba-4924-b20c-a348c8eeb470

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of DUT


Camera Driver Profiles Interface APIs (Device Test)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49eec4f1-6671-40eb-a002-5681fab9b85a

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of DUT


Camera Driver Device Test - MediaCapture - ValidatePowerlineFrequency

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ffc3ef72-df24-435c-8689-e23120ddeee5

This test validates the camera's Powerline Frequency (flicker) control

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
WDKDeviceID | Device id of DUT


Camera Driver DirectShow Interfaces - IAMCameraControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aa5178ce-be0f-439e-b332-fff35cf156e2

This test validates that the IAMCameraControl interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Interfaces - IAMCameraControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d44e575d-db67-4653-ad5e-06e17d0f48ec

This test validates that the IAMCameraControl interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Interfaces - IAMStreamConfig

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ffc824a-6cad-4084-8423-ea4b9b04a6b0

DirectShow Interfaces - IAMStreamConfig

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Interfaces - IAMStreamConfig

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed345387-129e-4732-8adc-d95692a2dd18

DirectShow Interfaces - IAMStreamConfig

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Interfaces - IAMVideoCompression

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b73b5dc-fbf6-48fc-b9da-eaf7e6aa9c2c

This test validates that the IAMVideoCompression interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Interfaces - IAMVideoCompression

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07c9f8c9-c2a1-4e1b-915d-796057e92387

This test validates that the IAMVideoCompression interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Interfaces - IAMVideoControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1e48daac-08f7-48d0-80b4-bc9087e2be3a

This test validates that the IAMVideoControl interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Interfaces - IAMVideoControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9ae60b9-02fb-4ec0-82d0-9e2e8d97620a

This test validates that the IAMVideoControl interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Interfaces - IAMVideoProcAmp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae36e3b1-c11f-4062-8957-afa070de0c36

This test validates that the IAMVideoProcAmp interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Interfaces - IAMVideoProcAmp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3664e8b0-f0f7-4e30-9b3c-7e2529a71be4

This test validates that the IAMVideoProcAmp interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Interfaces - IMediaControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38385daf-5afd-488a-bb4b-7cb45ad67616

This test validates that the IMediaControl interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Interfaces - IMediaControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80f8bf52-7fb3-40d8-b4c6-e56cf0f2bd39

This test validates that the IMediaControl interface has been implemented according to specification.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Video Capture - Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/758726ad-ca16-4238-be34-92e0b39b2b92

This test validates that the camera is able to capture to a file in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Video Capture - Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/28cf8676-a26a-4f77-9eed-bbad59473f99

This test validates that the camera is able to capture to a file in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Video Capture - Capture then Playback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9528128-5f2a-49f0-b594-d4ea68bdbea9

This test validates that the camera is able to capture to file and play back the result.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Video Capture - Capture then Playback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb1232e4-47cb-4eb8-8012-32736c045cc3

This test validates that the camera is able to capture to file and play back the result.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Video Preview - Preview Video Capture Device

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27522a17-d4e7-4d94-9640-0cd75cc5f1d2

This test validates that the camera is able to capture and preview to a render window in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Video Preview - Preview Video Capture Device

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2fb5623-0d38-45d3-ad24-1277c734723b

This test validates that the camera is able to capture and preview to a render window in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Video Properties - Class Compliance or WDM Compliance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb9072d8-6117-45af-98da-c7ddb83a85a1

This test validates Class compliance or WDM compliance in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Video Properties - Class Compliance or WDM Compliance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/780cbd15-7f05-407d-aace-2100452f4b91

This test validates Class compliance or WDM compliance in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Video Properties - Query Current Video Capture Device Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/65f9438a-12b4-42ae-aebd-6e639e97abce

This test validates that registration of device properties is correct for use in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Video Properties - Query Current Video Capture Device Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b4de9a4-63ad-47f8-9c29-ccf6c81ab467

This test validates that registration of device properties is correct for use in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver DirectShow Video Properties - VideoInfoHeader2 Data

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab808dec-4b96-405a-b0f8-d095d60e415e

This test checks that VideoInfoHeader2 Data is valid in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver DirectShow Video Properties - VideoInfoHeader2 Data

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/887912a1-2ded-40e2-bc10-d08c0adfc93c

This test checks that VideoInfoHeader2 Data is valid in DirectShow applications.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.DirectShow
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


Camera Driver Registration, Metadata, and Dependency Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e007e96e-fad3-48a9-84ff-4391fafc14a8

This test validates registration, metadata, and dependencies for a webcam.

Test details
Specifications
  • Device.Streaming.Camera.VideoCapture.KSCategoryRegistration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

More information

Command syntax

Command option | Description
WebcamBasics.exe -h "[WDKDeviceID]" | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WebcamBasics.exe | <testbinroot>\nttest\multimediatest\avcore\vidcap</p>

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - MediaCapture - TestConcurrentRecordAndPhotoCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45970750-3b20-4354-8694-073b5d5aaf46

This test exercises concurrent record and photo capture from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestEnumerateMediaEncodingProperties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1850fa5-6fc5-4e53-a69d-a8025dcfa7a8

Enumerate and log the media Encoding Properties on all PINs

Test details
Specifications
  • System.Client.Camera.Base.Device
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation
  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestEnumerateVideoProfile

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/479f4f89-cbdf-41f5-bb74-5bcfa7dd33d5

This test will check that all profile advertised are correct

Test details
Specifications
  • System.Client.Camera.Base.Device
  • Device.Streaming.Camera.Base.AVStreamClassInterfaceAndWDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation
  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestMft0GetService

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/051a79da-a7a5-4823-8507-20d3dba90e78

This test checks whether an MFT0 is present from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.Base.Device
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestPhotoCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d6f5b27-dd57-4274-a5f7-48261c04558f

This test validates basic photo capture functionality of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.Base.Device
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestPreview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/527d31cd-bd56-429e-ad1d-d05ce1bb3573

This test validates basic video preview (view finder) functionality of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.Base.Device
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestVideoCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bae2c575-fb0f-4e0e-9c27-e5126e1b34e8

This test validates basic video recording functionality of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.Base.Device
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation
  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver Test - Video Capture (Record) - Record 10 min Video from default Capture pin format to H264 file (Video Only)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3669325c-94d8-431f-a164-ebc946049d4f

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Capture (Record) - Record 30 seconds of 480p Video from Capture pin to H264 file (Video Only)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/029a1a23-1e1a-481a-b773-597bba653034

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Capture (Record) - Record video to a single H264 file from all formats advertised on the camera's default capture stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2cd2153-4568-47fc-a703-e9d72b4445da

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Capture (Record) - Record video to an H264 file from each format advertised on the on the camera's default capture stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c0698dc-4389-4b58-af0a-d834a395c3de

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture Bitmap Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45ea2523-4da4-4454-9c30-55beeff559c3

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture GIF Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/411fbfe1-4983-43b6-9713-d5e3a397af08

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture JPEG Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6049742b-7a7a-4d9b-b89b-8cc445541136

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Capture JPEGXR Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73e36925-e724-4c08-a947-acc99e4257ae

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture GIF Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4011057-5f49-4085-820d-4a68c4d54a2e

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Capture Bitmap Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/339df30e-3046-4bee-bdb2-5df477c1a957

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Capture GIF Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4b143137-b356-4caa-bb99-894e6da67169

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Capture JPEG Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8ee599e3-255e-4fe8-811f-9094737b9f5a

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Capture JPEGXR Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fba14855-284b-4ea5-8f5d-76dbf1b3191f

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture GIF Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3418266b-b60a-4721-819f-7292b2b11cc5

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a BGRA8 image from the default type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/279bab12-ebe0-4d7f-b726-9eb35a88a8f5

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a BGRA8 photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee93dc40-5fcf-4c97-a446-54e97b60b3bd

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a BGRA8 photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca6f048b-c491-46b0-9f28-9a936d6d76ed

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a BGRA8 photo from the default type exposed by the preview pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c21a98e1-8b3c-4d69-9bad-e7a8e3cfca05

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a Bitmap photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b8a5925e-6ad1-4f1f-b486-7f8bb538baa5

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a Bitmap photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/830ec3ab-2ba2-4ba4-b777-53048393a532

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a Bitmap photo from the default type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d83afbd-c063-4556-ba10-911f2be1c0a8

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a Bitmap photo from the default type exposed by the preview pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07917087-e9ac-4b0d-ba40-ba8aee33640e

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a GIF photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9314ed9-8fcd-4214-83bd-bedb3981bbf2

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a GIF photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f34c926e-c5b7-4bf8-8551-fc09c852da49

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a GIF photo from the default format advertised on the camera's preferred stream for photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/edc14276-fca2-430e-bf9a-4b65e84e8c24

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a GIF photo from the default format advertised on the camera's preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/606aa401-ab95-4d9c-96af-9e4254e6782f

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEG photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59665b4a-f7d1-4a23-89b5-88a8700416d1

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEG photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83b2d490-5b6f-4fed-8916-31764464ce2d

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEG photo from the default format advertised on the camera's preferred stream for photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bed9385c-fd22-4a93-a335-3a05b88c0649

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEG photo from the default format advertised on the camera's preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/677f92cf-16f3-4b45-af09-a59555cf254e

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEG-XR photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6f4b1e41-8757-44e1-a899-c2022c2b4765

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEG-XR photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/70de0c4b-6f15-4ea3-8f88-34055251264c

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEGXR photo from the default type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a2e0197-4bd6-49e7-a3ce-a40a1895b48d

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a JPEGXR photo from the default type exposed by the preview pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/acf9a81a-0e82-4367-b499-05c3ca07313a

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a PNG photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2132f6b2-8351-43f1-866b-3107de2b55c4

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a PNG photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a00339b-2d04-4d59-b74e-c814b2a0504e

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a PNG photo from the default type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3def9745-44ac-4e37-a606-a0cf1f385de3

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture a PNG photo from the default type exposed by the preview pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9779afdd-7f09-4b39-9742-6efab3e5950c

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture an NV12 photo from each format exposed on the preferred stream for video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72fb23b9-f3c6-4884-b28f-109aa34a170f

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture an NV12 photo from each type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/888888b8-3558-45b0-9499-5c7af1371626

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture an NV12 photo from the default type exposed by the photo pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37fe88bd-5f0b-4110-87f7-5c3084632c6b

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Photo Capture - Capture an NV12 photo from the default type exposed by the preview pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68dc47f0-1390-4965-9c91-fde4ad8877bc

These sets of tests validate cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Image Stream - \*

    Validates that the system is able to take photo from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_IMAGE.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber) for 20 minutes and Capture 127 JPEG images

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76cde0a8-9054-4c57-bbf2-7689e89a38e7

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber), Capture Bitmap image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4e3a383-467b-4e1e-9528-ca92d2366050

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber), Capture GIF image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9f352b5-f75e-490c-82df-34a6a397ada4

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber), Capture JPEG image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36e00f8b-7946-4cbc-990c-58965a900e3e

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber), Capture JPEGXR image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f39efee9-bdb3-4cba-ade0-9fe39aa26803

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview for 20 minutes and Capture 127 JPEG images

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76c56037-86b2-40dd-a126-abdd76bbddbb

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview, Capture Bitmap image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0cd74921-123f-4d17-8ae7-36a98c26b141

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview, Capture GIF image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d64b73c4-3ae7-4de2-b189-6eadb747c2e5

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview, Capture JPEG image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bab6ffeb-216a-46e7-9c19-28d92cdff68e

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview, Capture JPEGXR image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ed20c91-e05e-4821-8d7b-ce100839ac27

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Record and Preview (Sample Grabber) for 30 minutes, Capture 55 photos

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cca28f71-01da-4f5b-9848-3d8bbb6c19ba

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Record and Preview (Sample Grabber) video for 30 minutes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03bc7fc8-a75b-4ff0-b100-8cef71bc8304

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Record and Preview for 30 minutes, Capture 55 photos

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19cc94bc-745f-496c-96bf-67b88e13f4d6

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Record and Preview video for 30 minutes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e731ea0d-7e7b-44e6-8244-df1b7ece5b55

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - UVC Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3b3c230-ed2b-45e2-aa7f-0b0fb4278fc3

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.UVC.UVCDriver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - UVC Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1dbfb9f1-0740-4241-8ca3-1bdc312582bd

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.UVC.UVCDriver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - UVC Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6eac706-ccc4-4ddc-9feb-286ed87fc34e

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.UVC.UVCDriver
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Capture (Record) - Record 30 seconds of 720p Video from Capture pin to H264 file (Video Only)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e583f26a-c2fd-49ca-b037-4b94a9320553

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Preview (Sample Callback) - Stream video from all available format on the preview stream and dynamic format switching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/244a061e-7868-4c71-831a-df7811a31905

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Preview (Sample Callback) - Stream video from each available format from the camera's preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb5dd80f-fba9-4c0e-8d97-700e13dd894a

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Preview (Sample Callback) - Stream video from the default format on Camera preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/794c8db9-f801-4172-9297-4cab61208bb2

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Preview (View Finder) - Stream video from all available format on the preview stream and dynamic format switching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/761354f5-3217-427e-9499-90e69451611f

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Preview (View Finder) - Stream video from each available format from the camera's preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0983c6e9-ab64-487e-aa0f-aff2808ee703

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Video Preview (View Finder) - Stream video from the default format on Camera preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9a48caa-984a-46e9-b69a-9e54963a1474

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • Device.Streaming.Camera.Base.MediaFoundation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Usage Indicator Manual Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/32538457-8456-4f5e-995e-eed912435a13

This test validates that the camera indicates its streaming status properly. When a camera is streaming, the LED (or on screen indicator) should be on. When the Camera is not streaming, the LED/indicator should be off

Test details
Specifications
  • Device.Streaming.Camera.Base.UsageIndicator
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Face sensor validation tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5eac01f-7c30-4d17-8e7f-2d8d27125d96

Sensor tests for face authentication compatibility

Test details
Specifications
  • Device.Streaming.Camera.Sensor.FaceAuthMode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H263 Decoder HMFT Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/053cc98e-abcc-49fc-a127-a0ac6d725f8e

Playback and visual validation test: InputType H263 - H263 Basic Functionality Decodes H263 Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.H263.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H263 Decoder HMFT Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6a2b0ec-1237-4e65-8135-cbd942fae314

Playback and visual validation test: InputType H263 - H263 Basic Functionality Decodes H263 Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.H263.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H263 Decoder HMFT Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f182e8b6-5181-46e9-a644-95271a7dd699

Playback and visual validation test: InputType H263 - H263 Basic Functionality Decodes H263 Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.H263.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H263 Decoder HMFT Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7659e29-cadc-45be-8eb0-ae6b4ba8b803

Playback and visual validation test: InputType H263 - H263 Basic Functionality Decodes H263 Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.H263.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/710b19dc-e1c8-46de-83b8-8cac8bb33940

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Advanced Encode Test # 1600 - Dynamic Type Test - Change every frame

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/907964ef-94d9-4558-98eb-dcd1e9d1c18e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Advanced Encode Test # 1601 - Dynamic Type Test - Change every 30 frames

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66317c96-0fdd-44c2-96d9-278ecbddd439

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Slice Control (Mode 2) Test #1602

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07a43a8b-5905-4863-8262-99a0e4b102b1

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Slice Control (Mode 0) Test #1603

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5cfb3e0f-66dd-41f4-a73a-0c82608345bd

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 EncodeQP Test #1604

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb56f6b2-10f0-43a1-afc7-ff7d3d92d50e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Slice Control (Mode 1) + Static Temporal Layer + GOP Adjustment Test #1605

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d97027d-df1a-4287-be74-d199449beb2e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Dynamic Temporal Layer Test #1606

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e4fcd1f-cd97-4340-8a30-23d426172adb

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 LTR Test #1607

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d25e049a-c1f7-4419-9575-7819c0ffc318

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 LTR + Dynamic TL + Max Num ref Frame Test #1608

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ccc2d1c3-4d79-4132-9079-1c39a877abf7

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 LTR + Dynamic TL + Max Num ref Frame Test #1609

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45fa48a3-3555-4931-ae1e-fb4e29cd717b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Advanced Encode Test #801 - Dynamic changes on resolution, IDR, temporal layer count, and QP

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/297015fc-0032-47b0-8315-36f632b0338d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Advanced Encode Test #802 - Mark and use LTR syntax and semantic validation

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d67dd85d-9356-4450-a146-a8857587cce2

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Advanced Encode Test #803 - Four concurrent instances

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/892de4f9-aef3-4b3a-8c3c-c30c64357a7f

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1200 - 1080p encode using quality rate control, high profile, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89612a78-dfe0-4ccf-a70d-59f8e58e6349

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1201 - 720p encode using quality rate control, main profile, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad3ec879-dfa1-46b4-8dd1-49771720e3b8

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1202 - 240p encode using VBR rate control @ 500 kbps, base profile, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5640d477-8ffd-4a7c-9847-cc3510ddcae9

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1203 - 720p encode using CBR rate control @ 6 mbps, main profile, GOP 90

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c254fca-d728-4437-b8c2-f6b0f73935cb

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1204 - 480p encode using CBR rate control @ 1 mbps, main profile, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/908c39df-fab2-4123-9f6f-6d545f17552a

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1205 - Check GetParameterRange and GetParameterValues

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ace1fff-841b-48b4-8538-8031ffd18a68

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1800 - 480p encode using gradual intra refresh, Mode 0, high profile, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/520f5c47-f8db-4df2-b0f3-80c8fcd272a0

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1801 - 480p encode using gradual intra refresh, Mode 1, high profile, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d166faa4-9c59-4f2e-9efd-ea85c2c5095b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Basic Encode Test #1800 - 480p encode using gradual intra refresh, Mode 2, high profile, infinite GOP

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Benchmark Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d8b04ec3-53bc-49a7-aa4c-64ec930781b8

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Benchmark Test #851- Maximal and average encoding and decoding time for 1080p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Benchmark Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e55fea94-659c-419f-ba0c-3103fcb58029

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Benchmark Test #852 - Encoder memory usage and memory leak detection

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Benchmark Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76054fd0-d298-4d8e-80ce-3e27a862cf23

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Benchmark Test #851- Maximal and average encoding and decoding time for 1080p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Encode Quality Miracast Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/afeeeb96-c3e8-4454-80e2-3143d84cb717

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Encode Quality Miracast Test #1504 - RD Curve at 1080p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f796fc13-3d47-45c4-a886-f50592e32d8e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Encode Quality Test #1500 - RD Curve at 240p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Encode Quality Test Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d55f7db3-ceac-47b4-8391-0ef512958989

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Encode Quality Test #1501 - RD Curve at 480p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Encode Quality Test Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d6db826-40a1-4295-94bf-c04b02b9aae3

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Encode Quality Test #1502 - RD Curve at 720p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Encode Quality Test Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ba5723d-fba0-46f6-97f7-2fe49b76b232

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Encode Quality Test #1503 - RD Curve at 1080p

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Encoder - HMFT Transcode test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3442abd-426d-6a04-e0ed-73bf992c49ec

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HMFT Transcode Test: InputType H264, OutputType: H264 - H.264 Basic Functionality Transcodes source into H264 format

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Encoder - HMFT Transcode test 11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce180138-4862-a3c8-8b7e-f2961fdfa6d2

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

HMFT Transcode Test: InputType RGB24, OutputType: H264 - H.264 Basic Functionality Transcodes source into H264 format

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Encoder - HMFT Transcode test 32

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/775ce70f-4e09-91df-aef7-968a5120ffd5

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MI Transcode Test: InputType H264, OutputType: H264 - H.264 Basic Functionality Transcodes source into H264 format

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 HW-DRM CENC Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6bf5bf46-a1ba-4197-ad8f-148b4094ab4b

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.CENC.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM CBCS Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8edeeb30-d35e-49d2-b811-89b6dab2120b

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.CBCS.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c17c3ba6-b362-43d2-890e-82ce712e3e0c

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d362908a-440b-46b5-b48e-26e46e1bdd48

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/09ecb67d-67ba-46a5-8631-33fa7fb07b93

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44ac6b62-76be-4497-af62-68c4599470bc

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15abb649-51b4-4220-b636-7acb349a837a

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d8ea5a6-5d1d-46a1-afff-9d8948bd7e2e

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 HW-DRM Video 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a715fbd0-3976-4c0b-858f-ca13f10b0db7

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a15e50b8-2b77-48d7-81e0-c4b5af9bb18c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Intermediate Encode Test #1400 - 1080p encode using quality rate control, constrainedhigh profile, cabac, low latency, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8979b4b0-4276-4f9d-8527-bedf2f84484e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Intermediate Encode Test #1401 - 1080p encode using CBR @ 10 mbps, constrainedbase profile, low latency, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5553d6cb-5e83-4bc8-a747-0223701568fb

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Intermediate Encode Test #1402 - 720p encode using CBR rate control @ 5 mbps, constrainedhigh profile, cabac, low latency, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e762e8c5-cb72-4104-ab87-6a0b79f15337

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Intermediate Encode Test #1403 - 720p encode using vbr rate control @ 6 mbps, high profile, cabac, 2 b frames, GOP 90

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b967d9d4-c395-4dc1-9b25-893e0ca45020

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Intermediate Encode Test #1404 - 1080p encode using PeakVBR rate control @ 8 mbps, main profile, 1 b frame, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19f7a75e-eca5-4bfd-9825-7af10e0e9816

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1300 - Scenario Info Test 1

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3a66d256-d0d3-4e58-8122-dd0c867ee3d3

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1301 - Scenario Info Test 2

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33c95067-8600-4582-a5fa-8ef672c11e65

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1302 - Scenario Info Test 3

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16d7027e-a16b-4418-8f93-d0fba5eb09a6

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1303 - Scenario Info Test 4

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ee4bb81-30c1-4f03-8d44-2bce7904311b

H264 Miracast Encode Test #1304 - Low Power Test

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/156b8d3c-5a89-41ec-ba07-2f55724a8f0d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1305 - Intra Refresh Mode 1 Test

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8b308e3-c45b-4c56-a23e-98fbacd73c9d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1306 - Intra Refresh Mode 2 Test

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Miracast Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/56dbb594-5e22-4d66-b097-6cc81991ad7b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H264 Miracast Encode Test #1307 - ARGB32 Input Type Support Test

Test details
Specifications
  • Device.Streaming.HMFT.H264.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


H264 Playback Test 20

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72aebdd9-03d1-45e6-b469-2597901c3cfa

H264 Playback test 4k 3840x2160 8 bit content

Test details
Specifications
  • Device.Streaming.D3D11.H264.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 SW-DRM Video 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6513a576-27a2-41c4-bb73-683d1ffb4c84

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation


H264 SW-DRM Video 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37920ca0-5379-4be8-a34b-a79caaf86bb5

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation
  • Device.Graphics additional documentation


H264 SW-DRM Video 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/986bd7f9-27e2-45db-85a0-7205e17a9da1

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation
  • Device.Graphics additional documentation


H264 SW-DRM Video 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8fb7186e-25d5-45c2-815c-2feccdd37cfd

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation


H264 SW-DRM Video 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/64d9d3cd-3f3c-4168-b678-0de0bd3b8f46

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


H264 SW-DRM Video 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58dddffe-39e3-4d81-a3ad-6baa3adc677f

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation
  • Device.Graphics additional documentation


H264 SW-DRM Video 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0b82e9f-eb32-4936-bc1b-a7a712fd9aec

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation
  • Device.Graphics additional documentation


H264 fuzz test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/baca8d45-79d5-452e-9500-a489f08890bd

H264 Fuzz DXVA Test: InputType H264 - H.264 Fuzzing test

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 fuzz test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6e210c6-9221-43e9-8ff0-3769d8973c6d

H264 Fuzz DXVA Test: InputType H264 - H.264 Fuzzing test

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 fuzz test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d59a4978-5793-43e0-9624-f936a3aeb093

H264 Fuzz DXVA Test: InputType H264 - H.264 Fuzzing test

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f65b83cf-c93f-4ca0-9350-d7da08d2fb6e

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8510742a-6b4b-49ac-8060-11f72962289a

H264 Quality DXVA Test: InputType H264 - H264 Quality

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0d33017-cde8-4824-9a84-035a047c6471

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 12

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d406444e-5715-49f8-9341-69fd3d794528

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 13

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66ca8c65-079f-4bbd-ba54-b610dabdb2c3

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 14

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd2eb733-f09d-4578-841b-7fae0dd9abe9

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 15

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6bf0e86-ac8b-4eaa-bac6-aeae48bfa462

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 16

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27d87a32-5d50-4f76-a090-e9e06ffca127

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 17

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3953588-496f-4730-bb1a-8f884eee7816

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50e852df-4d20-430f-9f06-d4e5daa4edfe

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 21

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec700735-711b-4c48-99a1-4c12340862ff

H264 Quality DXVA Test: InputType H264 - H264 Quality

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 22

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f849c79-0764-4786-bb3b-3709526e1206

H264 Quality DXVA Test: InputType H264 - H264 Quality

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 23

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bad53a84-83bf-4e17-8b40-bda4f25b69ee

H264 Quality DXVA Test: InputType H264 - H264 Quality

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 24

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5467d430-b096-48a7-8bfd-265364d5d7f5

H264 Quality DXVA Test: InputType H264 - H264 Quality

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7331ab56-6423-4142-91a4-6617c8606aca

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6812632-406f-4517-9d79-43b9d36c0a83

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb7d4350-2860-4c0c-9a75-c7a8b80d7537

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a905b84-914b-44c0-869a-9d7014532b83

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/296d84c4-3be7-4415-b4a7-d0ebba8a49b3

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b878864-02b7-4131-94a9-d04d93fce812

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H264 playback test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe315e6c-22ec-4bef-9951-290f5fa6c109

Playback and visual validation test: InputType H264 - Verify DXVA Decoding for H.264

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


H265 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f55ee139-a0a3-4800-af6a-9bb72d379c62

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Advanced Encode Test # 1610 - Dynamic Type Test - Change every frame

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53ef43f9-75c8-4ce7-a535-c3a3a693f1e2

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Advanced Encode Test # 1611 - Dynamic Type Test - Change every 30 frames

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Advanced Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/174bce71-f8f9-481f-a78b-6c31effde459

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Slice Control (Mode 2) Test #1612

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd2f4d1c-6bdf-4c6e-8ac5-237389677d6f

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Basic Encode Test #1206 - 1080p encode using quality rate control, main profile, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8e4f219b-5376-43ba-ac34-815b13dc9065

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Basic Encode Test #1207 - 720p encode using quality rate control, main profile, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11de8b76-de09-4435-9177-f340e67dd180

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Basic Encode Test #1208 - 240p encode using VBR rate control @ 500 kbps, main profile, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/19f444ff-716f-4118-9345-b7d7b9fd48e7

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Basic Encode Test #1209 - 720p encode using CBR rate control @ 6 mbps, main profile, GOP 90

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4545f8c-fbde-4f3e-b72f-081ef1f18e16

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Basic Encode Test #1210 - 480p encode using CBR rate control @ 1 mbps, main profile, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dff8d9f9-3445-4b16-b68b-0eb103b1346f

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Basic Encode Test #1211 - Check GetParameterRange and GetParameterValues

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/942658d4-0367-4e76-8857-9283e5523867

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Encode Quality Test #1505 - RD Curve at 240p

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc72c2f1-432e-45c0-a48d-74ced5f8a33c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Encode Quality Test #1506 - RD Curve at 480p

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9f46e07-d697-41d1-a5ea-7997b982dacc

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Encode Quality Test #1507 - RD Curve at 720p

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/28b3ec3a-907d-46fe-b553-96bf706ea6a9

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Encode Quality Test #1508 - RD Curve at 1080p

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a33036e9-c03f-44b0-9955-b974c75c17aa

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Intermediate Encode Test #1405 - 1080p encode using quality rate control, main profile, low latency, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e752676-5add-408b-bae9-7803c4bed590

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Intermediate Encode Test #1406 - 1080p encode using CBR @ 10 mbps, main profile, low latency, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8adb450-6a13-4e91-b727-bd25caa33bd5

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Intermediate Encode Test #1407 - 720p encode using CBR rate control @ 5 mbps, main profile, low latency, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1cd36984-705f-4911-b280-1fc1fd13b187

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Intermediate Encode Test #1408 - 720p encode using vbr rate control @ 6 mbps, main profile, 2 b frames, GOP 90

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db94e2df-fa18-4e82-a573-dcb3e9483cdf

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

H265 Intermediate Encode Test #1409 - 1080p encode using PeakVBR rate control @ 8 mbps, main profile, 1 b frame, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


H265 Intermediate Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e3dd297-3fbd-40ff-aa89-ed4e241ea40a

H265 Intermediate Encode Test #1410 - 2160p HDR encode using PeakVBR rate control @ 18 mbps, main10 profile, 0 b frame, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.MAIN10.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC 10-Bit Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cfb67601-f2d9-4c4d-a64b-a94814327024

HEVC 10-Bit Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main10.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC 10-Bit Playback Test 17

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2cd42773-6c92-4e93-910c-23acb7c2d864

HEVC 10-Bit Playback and visual validation test 4k 4096x2160

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main10.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Encode Quality Miracast Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/42353243-3ae3-4779-9545-9dcf7d3daecb

HEVC Encode Quality Miracast Test #1513 - RD Curve at 1080p

Test details
Specifications
  • Device.Streaming.HMFT.HEVC.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC Fuzz Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e08ae813-cba2-48f7-b604-7ff219158ce7

HEVC Fuzz test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Fuzz Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b947278-2ed5-4cd1-957f-18f8b2b8ad39

HEVC Fuzz test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Fuzz Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7f570f6-1961-455d-9da7-7ab21225f7fd

HEVC Fuzz test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Fuzz Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ef171168-b5c6-4219-846c-2692e3c0f8c7

HEVC Fuzz test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Fuzz Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2e2f348-b7cc-4dff-8449-f17ee46a184d

HEVC Fuzz test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Fuzz Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e2727a2-1620-47a9-a011-97892c28b514

HEVC Fuzz test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC HW-DRM CENC Test

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.CENC.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10 April 2018 Update
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/da6dbc4c-9711-4b42-b82b-437073255d18

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92b58d3b-5f81-4ad3-b94b-70c515d028ed

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee8444da-b0b9-4391-af33-5a1670ccebee

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bcc3a0da-90d5-425b-9dd0-9e30f6a0d384

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d53cea0-588d-48d5-a224-cf374dc4090a

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f56587d-ac8c-49c8-a995-90604c6a5496

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1e755e8f-792b-4b39-b423-43fcb2de4a0f

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC HW-DRM Video 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11285efb-5215-4041-8ec2-2d2925ea0178

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.HWDRM.HEVC.Main10.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/32dfa90b-3b01-4bfd-aae1-a7cf3b1aa828

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9127fc2c-01ba-45b6-a533-26739f334f15

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/849d189a-d26e-4f36-b09e-548ea23d895b

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 12

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba041c22-9909-4f9f-8082-94881956df67

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 13

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c182959-8b97-4c4b-9d0b-01589673d6d9

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 14

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d6fabf7-77db-44b9-9edf-4d16bf3f815e

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 15

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a598c5be-b1ab-4e21-a1c8-4d767a5e4627

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 18

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/95aeed6b-642d-458a-9208-7d3b0de6fbb1

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8fd0b5f-8b7a-43e5-9b8b-37c7eb7f87d3

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f18c3bc5-8a0f-4824-badb-eb6043cb85aa

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/35bfa9d2-16b9-4c94-8335-a19b66b362cc

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1448c1d0-f822-4bf1-99b2-2a69cb90f068

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12867f1b-4d7e-4590-8049-73bc57afab89

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/43abc8ac-e2e3-440f-8d5b-a2503e3e5da5

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33b9c3ee-51a0-4679-ad22-6cca99588d46

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf86e1b7-ca79-49c4-8a12-c5adbb641b8f

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 20

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8855e8d3-a9fc-430e-81b9-c4b8532d7809

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 21

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/af24155b-8ee4-4aaf-a09b-b56497cc76a8

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 22

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e7406a51-e44c-4299-bd78-22b4d4c274a5

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 23

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/56354f71-5ca8-44e2-ab46-8eefe1350da0

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 24

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/badef7e7-2c5a-4aac-b54f-e090f92489c6

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 25

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0037b26d-3ba2-4dac-bb08-f8e35826a5f5

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 26

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac32f522-a0f9-4713-b1f8-80ee7a6c8a82

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 27

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f065e8e-9010-4afd-901c-2810d888680f

HEVC Playback and visual validation test - 32 bit test on 64 bit platform

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 28

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd22d729-34e8-496f-91e6-a6501e2c3456

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 29

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c6bfd44-ada7-4ef1-9775-676d6bb04baf

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 30

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87cad8c2-eeec-4625-b0a5-58ecc359bc6c

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 31

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a63d0a3e-d6ba-48c3-b27c-b0400b810904

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 32

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c70bd87a-de62-4f1a-8a15-64ce14c72dc7

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 33

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75b559bd-8a7e-4c18-ac3b-4214eb106921

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 34

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/485d4772-dd4c-4b6f-a59a-e6637d3db952

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 36

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0aec9b0-67c0-4f85-b418-e15b9d38703c

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 37

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2bc57aba-4797-4ebe-91cd-5166ae41b3de

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 38

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/48d30c5c-1e6e-4826-b483-a2e59b537bde

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 39

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88aebe17-53ef-43ce-885e-59afcb29ff89

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 40

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cb179f3-9be1-4a2a-ba51-e9745f0bc244

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 41

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1f5a673-277f-45b6-aa7c-75f292d2c824

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 42

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7cdc3648-ba36-4892-891f-2fc7d9d652bd

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 43

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49783236-dcbc-416f-ba3f-35a26c3cad8e

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 44

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4af2518-e973-415c-9856-6f0accfb5218

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 45

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ca1279eb-7dc0-4738-be22-45c51937e765

HEVC Playback and visual validation test

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 46

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84d25baf-308b-4751-b298-dfa72c8fc893

HEVC Playback and visual validation test UHD 3840x2160 multiple tiles

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback test 47

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e56d75f-c08a-4640-8164-66ca7d7081b3

HEVC Playback and visual validation test UHD 3840x2160 multiple tiles no sao cross tile

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC Playback Test 19

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/692752cd-04c7-4541-8043-dbe78bb3296b

HEVC Playback and visual validation test 4k 4096x2160 multiple tiles

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


HEVC SW-DRM Video 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7146d07a-f65d-48ec-b895-a0ecdc0cd502

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation


HEVC SW-DRM Video 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d121a25-5d59-47d0-9c4f-80c15e71b116

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation
  • Device.Graphics additional documentation


HEVC SW-DRM Video 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e5823c94-3d0a-44a7-b998-1d540225b243

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC SW-DRM Video 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a04a55be-aaee-464d-9a29-e8e2b40aa67a

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation


HEVC SW-DRM Video 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d4cbe76-e198-43de-ad99-499c159f71af

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC SW-DRM Video 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7dcaa252-1b60-4c0a-806b-d8fc0cc580f0

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation


HEVC SW-DRM Video 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/049a25ff-a6f5-4718-8e83-0098f6e3d27f

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HEVC SW-DRM Video 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d689bc83-b53a-48e4-a4a7-37c9d46a56c3

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE
  • An internet connection is required for all DRM tests.
  • The HEVC decoder pack is required for this test.

Test details
Specifications
  • Device.Streaming.D3D11.HEVC.Main10.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
InstallCodecPack | FullName of decoder package to check for/install
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HW-DRM - Verify Codec Support Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3aec72ff-855b-4bfa-a2f8-30d672a2576c

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
  • Device.Streaming.HWDRM.HEVC.Main.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


HW-DRM Video - Play protected content using hardware decryptor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c652d52-6b75-4bde-bf9c-6a1329cccce6

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

Test details
Specifications
  • Device.Streaming.HWDRM.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
Source | URI for the video content


MJPEG Decoder - H264 Encoder - HMFT Transcode test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebec2b2c-4352-d20b-9921-f2943976ea4b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Transcode Test: InputType MJPEG, OutputType: H264 - MJPEG Basic Functionality Transcode from MJPEG to H264

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT compliance test 61

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ebd0c70-4fda-de6f-eb2a-e5aae0ab2476

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MJPEG Decoder HMFT Compliance Test: InputType MJPEG - Verifies IMFTransform for MPJEG

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 150

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7668fbc4-48ef-d3a1-f015-51a84f7bbcf2

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 151

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25721676-47b8-588a-5502-ac97268db199

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 152

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47d5d48a-4573-7464-e5a1-e2a52de712ba

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 153

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d341bc9e-4dd5-a720-6510-868a40fa7b88

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 154

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed12a96d-479a-c0a6-38f1-11bcdea79705

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 155

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d80aa712-d7df-4956-9bb6-116bf89adf68

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 156

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78605cc5-a359-43b0-8c26-5bada5f25a13

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 157

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0f40b6f-34d1-4093-ad97-599aee1ef2e4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Playback test 432

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7dddcd93-b3bb-4529-bef0-f52bec8320c4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder - HMFT Stress test 450

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a789043f-ddd5-4c83-b4e3-b2fa059aeeaf

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MJPEG Decoder HMFT Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d0def68-42bf-42f3-947f-987936be9db5

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/104965fa-4173-4c88-952d-2364ca9bf808

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eca42df8-9294-4047-8b25-3a6b258418ca

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a8907de-cd82-49e8-b6b9-7fa432229f99

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/740ede5a-1f53-40e4-89ff-e9632fad9e5f

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d8e31fc-ae07-4831-948a-7fc07ca4c1c8

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc310ecd-ff77-4973-a899-ad38672e6f86

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/671f43c1-2faa-48f6-844c-adee22a25f8b

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Decoder HMFT Playback Test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/88dcf698-7b78-46ac-af7c-02e4e34f3eb4

Playback and visual validation test: InputType MJPEG - MJPEG Basic Functionality Decodes MJPEG Content using HMFT

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MJPEG Encoder - HMFT compliance test 60

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d576cdb-46b2-3cf8-2f67-2baaa01732b6

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MJPEG Encoder HMFT Compliance Test: InputType MJPEG - Verifies IMFTransform for MPJEG

Test details
Specifications
  • Device.Streaming.HMFT.MJPEG.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG2 Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/372ea33b-1ccd-47de-87a5-cb30ccfdc7d5

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59092530-d733-4145-af2b-4ba07bef0e4b

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a18a3dd-f743-46e5-ac7b-6e2cbe5e3284

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9b1c326-02cd-49c3-a2f1-317cb00729a6

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5696c03-3d15-4dd4-bc0d-b734f77a1ad5

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f017659-a4f4-49c1-a9dc-55a41687e17b

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c0ff257-04b3-4886-85b5-70aa91c8c922

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/130e3f67-3ea1-45df-82d9-9e70fd00f8d9

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/025e1924-565e-4d11-8800-7fdc537f9452

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG2 Playback Test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62835046-d9cd-4e85-8d71-f712ca2d6b98

Playback and visual validation test: InputType MPEG2

Test details
Specifications
  • Device.Streaming.D3D11.MPEG2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File
InstallCodecPack | FullName of decoder package to check for/install

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder - H264 Encoder - HMFT Transcode test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/741ab4c6-4896-c204-36c7-c69153199248

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Transcode Test: InputType MPEG4, OutputType: H264 - MPEG4 Basic Functionality Transcode from MPEG4 to H264

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT compliance test 13

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/119ff99e-41ea-6d22-291a-2f9157696e61

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG4 Decoder HMFT Compliance Test: InputType MPEG4 - Verifies IMFTransform for MPEG4 Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT compliance test 14

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c941d3e-d757-4150-a0a9-6fb407b223e4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG4 Decoder HMFT Compliance Test: InputType MPEG4 - Verifies IMFTransform for MPEG4 Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT compliance test 15

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59ddd4b8-1dd6-43e2-8345-4dd98e626156

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG4 Decoder HMFT Compliance Test: InputType MPEG4 - Verifies IMFTransform for MPEG4 Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT compliance test 16

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cde2dcd-b854-4b85-8153-725395102778

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG4 Decoder HMFT Compliance Test: InputType MPEG4 - Verifies IMFTransform for MPEG4 Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT compliance test 17

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b45a1eb8-4e9e-4116-8ecf-527d4d912b2e

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG4 Decoder HMFT Compliance Test: InputType MPEG4 - Verifies IMFTransform for MPEG4 Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT compliance test 18

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ea4494b-5c7c-4269-8817-3136ea7f5989

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

MPEG4 Decoder HMFT Compliance Test: InputType MPEG4 - Verifies IMFTransform for MPEG4 Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder HMFT Playback test 110

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/836b3e7f-9fb6-4e81-9f91-f03c80984b59

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder HMFT Playback test 111

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/881807ed-259d-4876-ac34-acfe940b1aff

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder HMFT Playback test 118

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bac2971a-4077-5d32-7783-1ca49be973b4

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT Playback test 125

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9a9b756-4b1d-b0b7-bc04-1a9f23b6154c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT Playback test 129

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce20b862-4317-c15f-5249-e686b1aeaa97

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder - HMFT Playback test 131

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31b80225-73fe-4b73-9c39-ab7630fcdc85

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder HMFT Playback test 421

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2f97766-bede-4e64-8e5f-905d6e20970b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder HMFT Stress test 444

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd88d958-ed0a-412d-b1c1-49441bf3c3f8

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Playback Test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific HMFT


MPEG4 Decoder HMFT Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8293c7bd-2be2-4169-9beb-a811729d4e99

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder HMFT Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/313a0daf-1dc7-4874-b868-9336a077c9ca

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder HMFT Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac750f7d-f766-4416-9aed-3d48ae999bbf

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder HMFT Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0e1262f-5528-4e72-af3b-68c121012250

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder HMFT Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e2057463-9aa6-4860-baea-d4f0822a67d3

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder HMFT Playback Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96da807f-5eef-420f-8807-929f02962fe8

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


MPEG4 Decoder HMFT Playback Test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc792b4a-a577-4493-b416-462ba3c810b3

Playback and visual validation test: InputType MPEG4 - MPEG4 Basic Functionality Decodes MPEG4 Content using HMFT Decoder

Test details
Specifications
  • Device.Streaming.HMFT.MPEG4.Decoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


SW-DRM Video - Play protected content using software decryptor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/598d80aa-cd07-428f-a26d-9f7a027e4c14

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

Test details
Specifications
  • Device.Streaming.D3D11.H264.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
Source | URI for the video content


Sensor Camera Driver Basic Capture Session - Preview Sink - All Mediatype

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17be6b7f-654f-43ac-aff9-ccbf6d7e607d

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • Device.Streaming.Camera.Sensor.FaceAuthMode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Basic Capture Session - Preview Sink - All Mediatype with Metadata

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/768d451f-f681-48a6-ab7b-2de610e805f4

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • Device.Streaming.Camera.Sensor.FaceAuthMode
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Registration, Metadata, and Dependency Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a09907c3-8922-41d6-808b-249f05a5db9b

This automated test verifies the physical location of the sensor camera and ensures that the camera and driver are compatible with Windows

Test details
Specifications
  • Device.Streaming.Camera.Sensor.KsCategoryRegistration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


VP8 Fuzz test test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebdf2b65-5251-461c-9beb-e3b74cb7e95b

VP8 Fuzz test 1

Test details
Specifications
  • Device.Streaming.D3D11.VP8.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP8 Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8b381fe7-5c5c-4187-9093-d2f8262bceda

VP8 Playback and visual validation test for 1920x1080p content

Test details
Specifications
  • Device.Streaming.D3D11.VP8.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP8 Playback test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7a01ccb-5e4e-4ea9-9000-a97fa2942cb0

VP8 Playback and visual validation test for 320x240p content

Test details
Specifications
  • Device.Streaming.D3D11.VP8.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP8 Playback test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb3b0fde-1b46-4417-a94c-73342d71dce2

VP8 Playback and visual validation test for 352x288p content

Test details
Specifications
  • Device.Streaming.D3D11.VP8.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP8 Playback test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bb82c382-235a-4e9c-bc92-b8ca93697276

VP8 Playback and visual validation test for 720x480i content

Test details
Specifications
  • Device.Streaming.D3D11.VP8.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP8 Playback test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f91af44-2da6-4d72-a024-77f497ebe7d3

VP8 Playback and visual validation test for 720x480p content

Test details
Specifications
  • Device.Streaming.D3D11.VP8.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 10 bit Fuzz test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/57bacaa1-4ab3-493f-a007-ed2c517de01e

VP9 10 bit Fuzz test 1

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 10 bit Fuzz test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e98f01c-2f0b-46c9-a65b-4136eaf35798

VP9 10 bit Fuzz test 2

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 10 bit playback test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/163b702a-7e62-4b9b-8ae9-4810116cb178

VP9 10 bit Playback and visual validation Test 1

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 10 bit playback test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58f74fd2-6489-48c5-a903-3f2f39967465

VP9 10 bit Playback and visual validation test 2

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d81afe79-cf57-43c1-997a-dedbd6f27ec2

VP9 Basic Encode Test #1212 - 240p encode using quality rate control, main profile, GOP 30

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder


VP9 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e174337-8f9e-4d30-93dc-e57f70c19c84

VP9 Basic Encode Test #1213 - 720p encode using quality rate control, main profile, GOP 60

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder


VP9 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e6af394f-87a8-451d-b6da-59bb47b16702

VP9 Basic Encode Test #1214 - 480p encode using peak VBR rate control @ 1 Mbps, main profile, Infinite GOP

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder


VP9 Basic Encode Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce22be7f-db25-489f-9ffc-91964240e4db

VP9 Basic Encode Test #1215 - 1080p encode using CBR rate control @ 8 mbps, main profile, GOP 90

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder


VP9 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/789c31d3-bea5-4660-a617-7b78a0d2d9ee

VP9 Encode Quality Test #1509 - RD Curve at 1080p

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


VP9 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ac7ccae-eed6-49d3-9cae-7176444ced33

VP9 Encode Quality Test #1510 - RD Curve at 480p

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


VP9 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc6b7509-7c2f-4ab0-ae70-bfd4313b657c

VP9 Encode Quality Test #1511 - RD Curve at 720p

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


VP9 Encode Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1eb2bfd-12d2-43c6-84cf-1ad57f5856c4

VP9 Encode Quality Test #1512 - RD Curve at 1080p

Test details
Specifications
  • Device.Streaming.HMFT.VP9.Encoding
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation

More information

Parameters

Parameter name | Parameter description
ContentSource | Path to source File
GUID | The GUID of the HMFT to test - {DETECT} should be used for certification, this can be overridden to test a specific encoder HMFT


VP9 Fuzz test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2fb4184f-e487-4aba-9918-02112f39c1e6

VP9 Fuzz test 1

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Fuzz test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e16181b-c66d-4a75-99ba-111eefd85a91

VP9 Fuzz test 2

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Fuzz test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f3916c6-b431-4f12-ab4d-a04f34221247

VP9 Fuzz test 3

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 HW-DRM Video 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/30e9d468-6432-4175-9521-4be58bc51f08

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.HWDRM.VP9.Profile2.10bit.CENC.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Streaming additional documentation


VP9 Playback Test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81640c3f-c00a-4673-b7b0-0614c400046e

VP9 Playback and visual validation test for 320x240p content

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/650f3acc-e06d-4f41-b938-d5433ec10314

VP9 Playback and visual validation test for 4096x2160 content with 4 row and 4 column tiles

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b75dd79-9399-48e4-a9f9-7f36ba66cbfd

VP9 Playback and visual validation test for 352x288p content

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/441d1f0b-78d8-4616-aa67-491013e9e7f4

VP9 Playback and visual validation test for 720x480p content

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be8aba4d-03ff-4c82-ab5f-2ca3d08db9ed

VP9 Playback and visual validation test for 720x480i content

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b5a1d7f-2ca3-48ef-bcb8-327f45f631cc

VP9 Playback and visual validation test for 1920x1080p content with 4 column tiles

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e956298-3b49-4425-aaa0-e488e9f986f1

VP9 Playback and visual validation test for 1920x1080p content with 4 row tiles

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2c623401-5b7b-48b9-94b1-80b4ebb03826

VP9 Playback and visual validation test for 31920x1080p content with 4 row and 4 column tiles

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a85f7fa6-1e1a-41b7-9206-9b7ccc74a136

VP9 Playback and visual validation test for 4096x2160 content

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 Playback Test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b13338b8-515e-4dbc-b695-1c24b2540c1f

VP9 Playback and visual validation test for 4096x2160 content with 4 row and 4 column tiles

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile0.4k.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VP9 SW-DRM Video 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8fe5156f-fe11-4271-9990-a7c8a0d4f512

Verifies if windows runtime app can play protected video content that requires Output Protection Management(OPM)

NOTE

An internet connection is required for all DRM tests.

Test details
Specifications
  • Device.Streaming.D3D11.VP9.Profile2.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | URI for the video content

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.Graphics additional documentation
  • System.Fundamentals additional documentation


VideoProcessor - Tone mapped conversions - HDR to SDR, HDR to HDR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3415eef0-d14b-4f87-b428-ca5459509fe1

This test validates the output of VideoProcessorBlt when performing tone mapping operations.

Test details
Specifications
  • Device.Streaming.D3D11.HighDynamicRange.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


VideoProcessor - Tone mapper hue consistency - HDR to SDR, HDR to HDR

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f702c94e-e956-4bb9-af0c-35c20786669b

This test validates the output of VideoProcessorBlt when performing tone mapping operations.

Test details
Specifications
  • Device.Streaming.D3D11.HighDynamicRange.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV fuzz test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3b9396d-5db1-4d73-a21f-653f0e0121b4

WMV Fuzz DXVA Test: InputType WMV - WMV/VC-1 Fuzzing Test

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV fuzz test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6926f8f-93aa-4de6-b2c5-5e2026445ec5

WMV Fuzz DXVA Test: InputType WMV - WMV/VC-1 Fuzzing Test

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV fuzz test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf4b76ad-85dc-4d3c-9e7f-f754db303bd3

WMV Fuzz DXVA Test: InputType WMV - WMV/VC-1 Fuzzing Test

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 1

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24492957-daae-4a9a-963c-e006f18bbe24

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 9

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5117ab5-a0d1-4182-a6cd-98308996df07

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 10

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eda2d406-8402-4a02-9311-baf1cca9ebf5

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 11

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf8ec84b-4d96-4cd3-837a-7107ff2745dd

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 12

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/259252e4-2ada-4da7-b395-a80435e10702

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 13

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/092b395a-ae1b-4f23-a0e4-fa1ca777299d

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 14

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c13a8810-3fba-4c9c-8f29-1f1f074e32c8

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 15

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61ea03d8-7d43-4ffb-8520-3056d6d11103

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 16

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce8b9e16-33e7-4f1c-bc9b-f1ba103517cd

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 17

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac457f15-7f34-4cf5-ac1e-0b0069463fae

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 18

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/960c00ae-2ce9-4554-84bb-046338251920

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f90f7135-0fc8-4886-b883-3a20ef5cd399

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 19

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66436ac4-0295-481a-9f91-80820a5908db

WMV Quality DXVA Test: InputType ASF - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 20

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2a3a2ee-1108-4011-bfbc-d4eca5d8884f

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 21

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c25c10a3-0848-486c-8891-c44b3bb78fe3

WMV Quality DXVA Test: InputType WMV - WMV Quality

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f475530-4c4b-4494-aa19-5f6b04847bb6

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 3

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f1b3f86-ae47-461e-8388-9bdc71513beb

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5faeacb8-cb2e-41a0-b950-3df46f0910e3

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1707bf7-ddd9-4c73-aa36-1ae5220966f3

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96cb9f15-4749-4f2a-9f25-ce77977bb486

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 7

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f86180ec-168c-4d15-a4d2-f163a9d58684

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


WMV playback test 8

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21808e48-bd27-423d-83e7-fbd1a788a74b

WMV Playback DXVA Test: InputType WMV - Verify DXVA Decoding for VC-1

Test details
Specifications
  • Device.Streaming.D3D11.VC1.Playback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Source | Path to source File

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - Device.Streaming additional documentation


Device.Streaming additional documentation

In this section

  • HMFT Testing Prerequisites
  • DXVA Testing Prerequisites
  • Webcam Testing Prerequisites
  • Troubleshooting Device.Streaming Testing


HMFT Testing Prerequisites

This section describes the tasks that you must complete before you test a Hardware Media Foundation Transform (HMFT)-compliant device by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements

  • Software requirements

  • Test computer configuration

An HMFT-compliant device is a video card or chipset that supports hardware-based encoding or decoding of digital content.

NOTE

If the video card is a not a stand-alone product (for example, a video chipset on a system board), these tests run as part of system certification.

Hardware requirements

The following hardware is required for testing an HMFT-compliant device:

  • A test computer.

    NOTE

    The test computer must meet the Windows HLK Prerequisites. It also must have at least 75 GB free on the drive used as the HLK working directory.

  • An HMFT-compliant video card (the test device), unless the HMFT feature is included in a video chipset on the system board.

You might need additional hardware if the test device includes audio, networking, or other features. To determine whether additional hardware requirements apply, see the description for each test that's identified for your video card or chipset in Windows HLK Studio.

Software requirements

The following software is required for testing an HMFT-compliant device:

  • The latest Windows HLK filters or updates.

  • Standard video files that are used during decoding or encoding tests.

    NOTE

    During installation of the Windows HLK, standard video files are downloaded to Windows HLK Studio.

Before running the HMFT encoding and decoding tests, you must download the Windows Hardware Lab Kit (HLK) Supplemental Test Content for HMFT Multimedia Tests from the Windows Dev Center. After downloading the supplemental test content, you must store this content in one of the following ways:

  • On the HLK controller, under the path %DTMBIN%..\Tests\HMFTContent, the default value for the ContentSource parameter must be used when scheduling the tests. This causes each test to copy over the input content that it requires only for that single test, and then delete the content after the test has completed. This is useful for computers with less than 75GB free space available.

  • In a different location than %DTMBIN%..\Tests\HMFTContent or on a network share accessible to the client computers. You must configure the ContentSource parameter to the location you copied the files to when scheduling the tests. This has the same behavior as the first item in this list, but allows you to specify where the content is located.

  • Copy the content locally on each client computer before running the tests. You must configure the ContentSource parameter to be the path to the content on the client computer. For example, if you use an external drive with letter d: and place the content in d:\HMFTContent, the ContentSource parameter must be configured to d:\HMFTContent. This will cause the test to use the local content and not copy each file for each test. This option requires at least 75 GB of free space on the client computers but will speed up the test run because the content will not have to be copied for each test.

    NOTE

    The ContentSource parameter is passed to all client computers that the tests are scheduled against so ensure that content location is identical on all client computers.

  • Copy the content locally on each client computer before running the tests and add the content location to the %PATH% environment variable. Leave the default value for the ContentSource parameter. This will cause the tests to behave similarly to the third item in this list. This option does not require that the content is in the same location on every client computer.

Test computer configuration

To configure the test computer for testing a HMFT-compliant device:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains Windows HLK Studio and Windows HLK Controller).

    NOTE

    If you are testing on Windows Server 2008 R2, Windows Server 2012, or Windows Server 2012 R2, you must install the Desktop Experience package. From a command prompt, type:

    Dism.exe /online /enable-feature /featurename:DesktopExperience /all

    If the computer does not restart, you must restart it manually.

  2. Install the manufacturer-supplied device driver, if necessary, on the test computer.

  3. For a stand-alone video card, install the card in the test computer.

  4. Install the Windows HLK client application on the test computer.

  5. By using Windows HLK Studio, create a computer pool and move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it's run, a dialog box is displayed for that test. Review the specific test topic for more information.

Manual Windows HLK tests require user intervention. When running tests for a submission, it's best to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of automated tests.


DXVA Testing Prerequisites

Supplemental Codec Packs

Starting with RS5 (Redstone 5) the HLK controller is now capable of deploying and installing codec packs. If your test machines include hardware which reports support for codecs that require a codec pack to be installed and your test machine images do not include these codec packs then you must place the codec packs on your controller. As of fall 2018 there are two codec packs that you may require (HEVC and MPEG2).

You can find the codec packs in the OEM inbox apps iso. (Available through EEAP)

The HLK controller is preprovisioned to contain placeholder appx packages at:

  • C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\CodecPacks\amd64\
  • C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\CodecPacks\arm\
  • C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\CodecPacks\arm64\
  • C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\CodecPacks\x86\

How to add codec packs on your HLK controller:

  1. Simply replace the appx in the directory for the architecture of your system under test.
  2. Run your tests. Your controller will automatically install the codec pack on systems under test.

For example, if you are only testing x64 systems and need to run the HEVC tests. Then simply replace the following placeholder appx with the appx package from the OEM inbox apps iso.

C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\CodecPacks\amd64\Microsoft.HEVCVideoExtension_8wekyb3d8bbwe.x64.appx

Internet Connection

Certain tests now require internet access. Specifcally:

  • DRM Tests - An internet connection is required for license acquisition.
  • Tests with supplemental codec packs - An internet connection is required for codec pack validation.


Webcam Testing Prerequisites

This section describes the tasks that you must complete before you test a webcam by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements

  • Software requirements

  • Test computer configuration

A webcam is a USB video device class that describes devices that can stream video.

NOTE

If the webcam isn't a stand-alone product (for example, an integrated webcam in a laptop or another mobile computer), these tests run as part of system certification.

Hardware requirements

The following hardware is required for testing a webcam:

  • A test computer that meets the Windows HLK Prerequisites.

  • The device under test (the webcam).

  • For internal webcams, a mirror to reflect a screen image back into the camera.

  • A speaker positioned close to the webcam's microphone.

You might need additional hardware (for example, a USB hub) to test some USB capabilities of the webcam. To find out if additional hardware requirements apply, see the description of each USB test that's identified for your webcam in Windows HLK Studio.

Software requirements

The following software is required for testing a webcam:

  • The driver for the webcam

  • The latest Windows HLK filters or updates

Test computer configuration

To configure the test computer for webcam testing:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains Windows HLK Studio and Windows HLK Controller).

  2. Install the manufacturer-supplied device driver, if necessary, on the test computer.

  3. Attach the webcam to the test computer (if external).

  4. Install the Windows HLK client application on the test computer.

  5. By using Windows HLK Studio, create a computer pool and move the test computer to that pool.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters before it is run, a dialog box appears for that test. Review the specific test topic for more information.

Manual Windows HLK tests require user intervention. It's best to run automated tests separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Troubleshooting Device.Streaming Testing

To troubleshoot issues that occur with Device.Streaming tests, follow these steps:

  1. Review the following Windows Hardware Lab Kit (Windows HLK) topics:

    • Troubleshooting Windows HLK Test Failures

    • HMFT Testing Prerequisites

    • Webcam Testing Prerequisites

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Specific information about HMFT testing

The Hardware Media Foundation Transform (HMFT) decoding and encoding tests require the following:

  • Supplemental Content for Windows HLK Tests for HMFT Multimedia Tests: Download and install the Supplemental Content for Windows HLK Tests for HMFT Multimedia Tests from the Windows Dev Center. For more information on installing and configuring the supplemental content, see HMFT Testing Prerequisites.

  • Standard content files included with the Windows HLK.

If the supplemental content is not available on the client computers, ensure that the ContentSource parameter is configuring correctly when the HMFT tests are run.

Troubleshooting Webcam video captures

Error | Description | Solution/Workaround
During setup, the test cannot find the Region of Interest (ROI). | The test looks for ROI markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run correctly. Failure to detect ROI can be caused by a poorly aimed camera or unusable video capture from the camera (for example, the room is too dark). | Reposition the camera according to test procedure and make sure that the camera provides a usable image under test lighting conditions.
During setup, the ROI does not fit in the camera view. | The test looks for ROI markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run correctly. Smaller field of view cameras (for example, rear facing cameras) might need to be positioned farther than 0.5 m from the test target to capture the required ROI. | Reposition the camera and confirm that the camera provides a usable image under test lighting conditions. To avoid inaccurate measurement of the field of view requirement, enter the new distance into the test application if you adjust the position.

Potential failure root causes and recommendations for improvement for webcam video captures

Image acuity

Spatial resolution

Spatial resolution is measured by using the modulus transfer function (spatial frequency response). Specifically, the metric MTF30 is used, which is the number of cycles/pixels by which a MTF=0.3 is achieved.

When the MTF30 is below 0.3, the image is too soft or fuzzy. Although this issue can be caused by poor quality optics, it is usually caused by poor image signal processing (image scaling, demosaicing, etc.). When the MTF30 is above 0.8, the image can be too aliased. This issue is often caused by poor quality image signal processing, especially scaling (for example, nearest neighbor interpolation instead of bi-cubic interpolation with anti-aliasing).

Focus range (depth of field)

The focus range requirement is for the camera to focus on objects at a distance of 0.3m to infinity, whether or not autofocus is used. The MTF30 spatial resolution metric determines the focus range. If this metric fails on a manual focus camera, a design issue might be the cause; for example, the theoretical depth of field is > 0.3m to infinity when focused on a target distance of 0.5m for notebooks/tablets, or to 0.7m for all-in-ones. If the target distance is correct, you might need to change the optics to achieve the correct depth of field.

If an autofocus lens is used and fails this metric, an issue in the autofocus algorithm is the most likely cause.

Noise

Spatial signal to noise ratio

Spatial noise measures the spatial variation in a single image by using a neutral gray (0.7 density) patch in the test chart. If this metric fails, it is most likely due to a poor quality sensor (insufficient sensitivity) or insufficient image de-noising. Image sensors should be selected that have a SNR10 (the lux level required to achieve an SNR=10 on a 0.7 density patch with no de-noising) of < 50 lux. Some level of image de-noising is acceptable, but should not significantly degrade the texture acutance. A method of measuring texture acutance (independent of Windows HLK) is provided in Lync Logo Video Capture specification (Rev G). For more information about the Lync Logo specifications, see USB peripherals and Lync PC test specifications.

Temporal signal to noise ratio

Temporal noise measures the temporal variation in two images by using a neutral gray (0.7 density) patch in the test chart. If this metric fails, it is most likely due to a poor quality sensor (insufficient sensitivity), poor automatic gain (AGC) and automatic exposure control (AEC), poor power-line frequency control, or insufficient image de-noising. An unstable AEC/AGC control can cause visible flickering. The power-line frequency control is used to detect 50/60 Hz lighting. Adjust the exposure; if this does not work well, flickering (using rolling flickering) is apparent in the video.

Color quality

Luminance for a neutral gray patch (0.7 density)

The automatic gain and exposure control should produce an image so that the neutral gray patch in the test chart has a luminance of 128 +/- 40 gray levels. If this fails and the luminance is < 88, it is due to either a poor AEC/AGC or an image sensor that has low sensitivity. In most cases, you can resolve the issue by tuning the AEC/AGC. If the luminance is > 168, an issue also exists with the AEC/AGC.

Color accuracy

The color accuracy is measured by using the max and mean ΔC₀₀ with respect to the known colors in the ColorChecker test chart. When this metric fails, it can be an issue with the white balancing or color uniformity, both of which can be improved by tuning the image signal processing.

Gamma

Gamma measures the nonlinear operation that is used to code luminance or tristimulus values in video or still images. When gamma is > 0.75, images can look too saturated; when gamma is < 0.4, images can look under-saturated. Both issues can be fixed by adjusting the gamma processing in the image signal processing.

Geometry

Vertical field of view

The vertical field of view requirement for user-facing cameras is ≥ 35INVALID USE OF SYMBOLS and for rear cameras it is ≥ 25INVALID USE OF SYMBOLS. When this test fails, it can be due to image cropping (not using the entire image sensor), which can be fixed in image signal processing. However, the problem is more likely due to the lens design. In this case, a new or modified lens is required.

Timing

Frame rate

The video frame rate must be ≥ 14 FPS in 20 lux of light and ≥ 29 FPS in 80 lux of light. If the frame rate is less than these requirements, you can usually fix it by tuning the automatic exposure and gain control.

Latency

Video latency measures the time for photons into the camera to photons out of the display. The video latency requirement is ≤ 80ms for MIPI cameras and ≤ 120ms for USB cameras; this failure is often due to low frame rates or image signal processing that uses one or more frame buffers. You can resolve both issues by improving the image signal processing of the camera.

Audio/video synchronization

Audio/video synchronization measures the time difference between captured audio and captured video. A failure of this metric is often caused by failure of video latency or audio latency. For more information, see Communications Audio Fidelity Test (System, Manual).

Time to capture and deliver first photo or video frame

The first video and photo frames must be captured within 500ms of starting the video or taking a photo. The most common reason for failing this requirement is slow automatic exposure and gain control convergence, which you can improve by tuning the AEC/AGC.

Time to deliver a photo in subsequent requests (steady state)

Subsequent photo images must be captured within 250ms (without flash) and 500ms (with flash). A common reason for failing this requirement is slow automatic exposure and gain control convergence, which you can improve by tuning the AEC/AGC.

Time to change resolutions (any media type)

The time to change resolutions (e.g. 720p to 360p) must be ≤ 250ms. A common reason for failing this requirement is slow automatic exposure and gain control convergence, which you can improve by tuning the AEC/AGC.

Time to switch cameras

The time to change cameras (for example, from the front camera to the rear camera) must be ≤ 750ms. A common reason for failing this requirement is slow automatic exposure and gain control convergence, which you can improve by tuning the AEC/AGC.

Glitch free/jitter

The video is glitch free if it has a maximum inter-frame time ≤ 133ms at 20 lux, max inter-frame time ≤ 66ms at 80 lux, and jitter ≤ 7ms (measured at the video renderer). The most common cause for failing both max inter-frame times and jitter is not achieving the target frame rates. For example, a 24 FPS video camera will fail both maximum inter-frame time and jitter requirements. In these cases, you should adjust the frame rate to target 15 FPS at 20 lux and 30 FPS at 80 lux.

Other

CPU usage

When the system is capturing and rendering video, the CPU usage must be ≤ 5%. A common cause of failure is when the CPU is used for image signal processing. All critical ISP should be offloaded to not use the CPU or optimized to use ≤ 5%.

Anti-flicker solution

Imaging in 50 or 60 Hz lighting with the wrong exposure (powerline frequency) mode can result in flicker that significantly degrades SNR. Manual power-line frequency control is required and tested for. The most common failure is not supporting manual power-line frequency control.

Related topics

Device.Streaming Tests

Troubleshooting Windows HLK


Device.TrustedPlatformModule

In this section

  • Device.TrustedPlatformModule tests


Device.TrustedPlatformModule tests

  • TPM - Auxiliary Test
  • TPM 2.0 - Clock Tests
  • TPM 2.0 - Clock Tests - (WoW64 for ARM64)
  • TPM 2.0 - Cryptographic Operations and RNG
  • TPM 2.0 - Cryptographic Operations and RNG - (WoW64 for ARM64)
  • TPM 2.0 - Functional
  • TPM 2.0 - Functional - (WoW64 for ARM64)
  • TPM 2.0 - Hardware Interface
  • TPM 2.0 - Hardware Interface - (WoW64 for ARM64)
  • TPM 2.0 - NV Storage, Policy, Error Handling and Attestation
  • TPM 2.0 - NV Storage, Policy, Error Handling and Attestation - (WoW64 for ARM64)
  • TPM 2.0 - Raw Mode Commands
  • TPM 2.0 - Raw Mode Commands - (WoW64 for ARM64)
  • TPM 2.0 - Reliability
  • TPM 2.0 - Reliability - (WoW64 for ARM64)
  • TPM 2.0 - Required Security Patches Tests
  • TPM 2.0 - Required Security Patches Tests - (WoW64 for ARM64)
  • TPM 2.0 - Self Test
  • TPM 2.0 - Self Test - (WoW64 for ARM64)
  • TPM 2.0 - Stress
  • TPM 2.0 - Stress - (WoW64 for ARM64)
  • TPM 2.0 EK Certificate Tests
  • TPM 2.0 Quality Test


TPM - Auxiliary Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f0f46d6-d0d9-44ab-85ef-4c44bba939ad

This test runs the TPM Auxiliary test.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Clock Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/74027550-10b3-46aa-975a-65e9d355ee2f

This manual test validates Trusted Platform Module (TPM) internal clock consistency.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations should include log files that have names such as tpm*.txt and console.txt, from the Documents folder.


TPM 2.0 - Clock Tests - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d07c1a49-9858-45c7-b919-6aca04f96080

This test runs the TPM 2.0 Hardware Interface Clock Tests - This test is a WoW64 for ARM64 version of test guid 74027550-10b3-46aa-975a-65e9d355ee2f

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Cryptographic Operations and RNG

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05c7c4ac-3e44-4083-ab2b-24fe117887db

This manual test validates cryptographic operations such as signing and hashing.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations should include log files that have names such as tpm*.txt and console.txt, from the Documents folder.


TPM 2.0 - Cryptographic Operations and RNG - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a45a32b-4078-4b51-8929-31939c48bc92

This test runs the TPM 2.0 Hardware Interface Cryptographic Operations Tests - This test is a WoW64 for ARM64 version of test guid 05c7c4ac-3e44-4083-ab2b-24fe117887db

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Functional

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ebd0f838-331d-4cc9-ba14-a9886d2c34dc

This manual test validates basic Trusted Platform Module (TPM) 2.0 operations such as encryption, decryption, key creation, and taking ownership.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations should include log files that have names such as tpm*.txt and console.txt, from the Documents folder.


TPM 2.0 - Functional - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/549981d6-1282-44c4-b5a3-120adcd63607

This test runs the TPM 2.0 Hardware Interface Functional Test - This test is a WoW64 for ARM64 version of test guid ebd0f838-331d-4cc9-ba14-a9886d2c34dc

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Hardware Interface

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e6f5a77-7350-4a21-99a8-aa475b9c1e09

This manual test verifies communication channels between Windows and Trusted Platform Module (TPM).

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 50
Category | Compatibility
Timeout (in minutes) | 100
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites..

This test has no additional test parameters.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - Hardware Interface - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b71b11ff-8b2c-42ce-a253-d9ce60c56f5b

This test runs the TPM 2.0 Hardware Interface Tests - This test is a WoW64 for ARM64 version of test guid 9e6f5a77-7350-4a21-99a8-aa475b9c1e09

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 50
Category | Compatibility
Timeout (in minutes) | 100
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - NV Storage, Policy, Error Handling and Attestation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33b2ec72-1085-448f-9192-1ceb8c8669ab

This manual test includes NV storage-related Trusted Platform Module (TPM) operations and TPM error handling.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites..

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - NV Storage, Policy, Error Handling and Attestation - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/678680f3-a062-4d14-bb9e-c3ced630400a

This test runs the TPM 2.0 Hardware Interface Policy Tests - This test is a WoW64 for ARM64 version of test guid 33b2ec72-1085-448f-9192-1ceb8c8669ab

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Raw Mode Commands

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/15f50ac3-500f-45b0-8704-6c1557881155

This manual test verifies Trusted Platform Module (TPM) operations with Raw mode-enabled, bypassing driver resource management

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - Raw Mode Commands - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c888e0e3-a7c5-4a21-87d9-67c1e5b5b38d

This test runs the TPM 2.0 Hardware Interface Raw Mode Commands Test - This test is a WoW64 for ARM64 version of test guid 15f50ac3-500f-45b0-8704-6c1557881155

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Reliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06274b7a-4d72-4667-a880-13dd9494f0ff

This manual test suite includes fuzz tests and negative tests to include uncommon user actions.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - Reliability - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a8b10126-bed2-4656-a530-48a101fb5a57

This test runs the TPM 2.0 Hardware Interface Reliability Tests - This test is a WoW64 for ARM64 version of test guid 06274b7a-4d72-4667-a880-13dd9494f0ff

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Required Security Patches Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2bdd98b-3dca-4d3b-8d3d-1bb9c614eb65

This manual test validates the presence of all mandatory security critical patches that are released for the 0.88 version implementation of Trusted Platform Module (TPM).

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 40
Category | Compatibility
Timeout (in minutes) | 80
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - Required Security Patches Tests - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bda2e8b-8fdf-48e5-9243-59eef97dd2a8

This test runs the TPM 2.0 Hardware Interface Required Security Patches Tests - This test is a WoW64 for ARM64 version of test guid b2bdd98b-3dca-4d3b-8d3d-1bb9c614eb65

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 40
Category | Compatibility
Timeout (in minutes) | 80
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Self Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec7a6d19-7083-47f0-877c-919c36189a8e

This manual test runs internal Trusted Platform Module (TPM) self-diagnostic tests.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - Self Test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a32e35ef-4cc7-4c3b-aa8e-00ebfef21f87

This test runs the TPM 2.0 Hardware Interface 'Self Test' Tests - This test is a WoW64 for ARM64 version of test guid ec7a6d19-7083-47f0-877c-919c36189a8e

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 - Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9f4ac09-da3f-4b90-b355-0dee50e2a193

This test performs stress tests on Trusted Platform Module (TPM) operations.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 - Stress - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f40f605-9858-44d0-b581-89a28ec0cded

This test runs the TPM 2.0 Hardware Interface Stress Tests - This test is a WoW64 for ARM64 version of test guid a9f4ac09-da3f-4b90-b355-0dee50e2a193

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.Features
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | false
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


TPM 2.0 EK Certificate Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f6a65aa0-803b-43aa-950c-ad5befc05bee

These tests test various aspects of the TPM EK Certificate.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.EKCert
  • System.Fundamentals.TPM20.TPM20
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


TPM 2.0 Quality Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71c5552f-dfb3-4b46-84a9-ae893331081b

This test runs the TPM 2.0 Quality Test.

Test details
Specifications
  • Device.TrustedPlatformModule.TPM20.MinimumPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Compatibility
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Filter.Driver

In this section

  • Filter.Driver tests
  • Filter.Driver additional documentation


Filter.Driver tests

  • Anonymous Pipe
  • Antivirus Installable File System Filter Test
  • AppContainers_Tests
  • File IO 2 Tests
  • HyperVisor Code Integrity Readiness Test
  • Installable File System Filter Test
  • IntegrityStream test
  • Mailslot Basic
  • Mapped File IO 2
  • Named Pipe Basic
  • Named Pipe Kernel Security
  • Named Pipe Reject Remote Clients
  • Named Pipe State
  • NDISTest 6.5 - LWF Logo test
  • Object ID test
  • Oplocks Test
  • Registry Callback Tests
  • ReparsePoints
  • Scrub Test
  • Syscache Test
  • TDI filters and LSPs are not allowed
  • TransitionTechnologies_Tests
  • Txfs2
  • WindowsFilteringPlatform_Tests
  • Winsock Core Functional Test


Anonymous Pipe

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45e98de1-b855-4405-9c23-f5e9f4ce70e7

This automated test verifies the functionality of anonymous pipes. It creates several pipe handles and uses multiple threads to read and write variable-size buffers via these anonymous pipes.

The test repeats this verification multiple times while varying the number of pipe handles and the number of threads. Additionally, this test creates a child instance of itself and provides an anonymous pipe handle to it. It then verifies that the anonymous pipe works with handle inheritance.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.NamedPipeAndMailSlots
  • Filter.Driver.AntiVirus.NamedPipeAndMailSlots
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites.

To run this test, follow these steps:

  1. Copy the test binaries that are listed in the File List section locally.

  2. Run Pipetest.exe without additional parameters.

  3. The expected Pass count is 14. Inspect the log file for the presence of +SEV error tags. If no instances of this tag are found, the test has passed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

This test does not accept any command-line parameters.

File list

File | Location
Pipetest.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\pipetest.exe
Ntlog.dll | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlog.dll
Ntlogger.ini | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlogger.ini

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy


Antivirus Installable File System Filter Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e84242de-56a9-4e6b-8f8c-ad3f7252cec7

This automated test verifies that the behavior in the file system stack is consistent with the typical behavior of a file system and the presence of an antivirus filter. For more information about file system behavior, see File System Behavior in the Microsoft Windows Environment.

For documentation about the test variations, see IFS Test in the MSDN® Library.

Test details
Specifications
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.AntiVirus.Functionality
  • Filter.Driver.AntiVirus.IcarDetection
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see Windows HLK Prerequisites.

This test requires the following software and hardware:

  • The filter driver to be tested, along with any supporting application suite

  • Extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions

Before you run the test, you must add the following partitions to the Windows environment.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
REFS | REFS | 10240mb | o:

The test when executed will run variations for each of the six partitions above.

All test cases return PASS or FAIL. Review the test results in the log file for specific details about failures.

Should there be a policy on the test system of locking out new accounts. The IFS test might return blocked" on the multiprocess variations if the local machine account 'ifstest' is locked out.

RunIFSTests-Virus.cmd contains references to environment variables that can be tweaked to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

The test creates a temporary local computer account (Ifstest). It also expects to have additional partitioned volumes.

Use a tool such as Minispy to see which I/O request packets (IRPs) are traveling on the file system stack. Compare passing (default Windows installations) with installations, including any failing driver.

More information

Command option | Description
IfsTest.exe | %DRIVE_ltr% /g Virus /n .\Ifstest-Local-NtfsResults.log /N 356789AB /T /p /m /E /j /r c: -d \Ntfs -a \datacoh.exe /u ifstest /U *rs53w52
-g <suitename> | Do not run <suitename>
/n <logname> | Create a long of name <logname>
/N | Specify NTLOG levels. If not included, then the GUI dialog box appears. This is useful in a batch mode run of the test NTLOG Levels 1 ABORT 2 SEV1 3 SEV2 4 SEV3 5 WARN 6 PASS 7 BLOCK 8 INFO 9 SYSTEM INFO A DEBUG INFO B TEST
/T | Enable trace of tests being done
/p | Enable pagefile testing in CreatePagingFileTest.
/m | Enable dirty bit testing in MountedDirtyTest
/E | Enable AllowExtendedDASDTest
/j | Enable support for tests involving the change journal.
/r <volumeletter> | Path to second volume required in certain tests.
-d <> | System Path to FSD device object in FileSystemDeviceOpenTest.
-a | Provide path to executable
/u | Username for test account
/U | Password for test account
/t <variation> | Execute only one named variation

File list

File | Location
ntlog.dll | [WTT\TestBinRoot]\NTTest\CommonTest\Ntlog</p>
ntlogger.ini | [WTT\TestBinRoot]\NTTest\CommonTest\Ntlog</p>
chg.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
chgfile.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
chgnotif.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
cleanupfiles.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
closedel.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
createkc.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
datacoh.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
decrypt.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
defrag.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
devctrl.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
dirinfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
dirpt.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
eainfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
encrypt.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
encryptvirus.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
enum.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
esecurit.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
estream.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fileinfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
filelock.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
forcedis.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fsctlgen.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fsctlvol.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
IFSCFG.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifsmsg.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest-av.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest-av_wdk.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstestcleanup.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest_storagelogo.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest_wdk.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ishell.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
linkpt.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
linktrak.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
mfile.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
mountpt.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
objectid.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
opcreatg.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
opcreatp.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
oplocks.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
quotas.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
readwr.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
reparspt.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ResetAutoLogon.vbs | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
restoresystem.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
seccache.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
securit.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
setupsystem.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
skel.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
sparse.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
virus.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
volinfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
writevirus.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
xchg.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
guidefile.dat | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
virusfile1.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
virusfile2.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
virusfile3.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
virusfile4.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
createwttlog.vbs | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
chgjourn.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fbslog.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\shared_libs\fbslog</p>
RunIFSTests-Virus.cmd | [WTT\TestBinRoot]\NTTest\basetest\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
WrapIFSTests-Virus.cmd | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
attachfilter.cmd | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the IFS Test Kit will run on.
CNTFS_DRIVE_LETTER | The drive letter for the compressed NTFS volume that the IFS Test Kit will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT16 volume that the IFS Test Kit will run on. This volume must be greated than 1 Gb. and less than 2 Gb.
FAT32_DRIVE_LETTER | The drive letter for the FAT32 volume that the IFS Test Kit will run on.
WDKDeviceID | This will receive the filter name.
WDKLogo | This will receive the /Logo flag
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
EXFAT_DRIVE_LETTER | The drive letter for the ExFat volume that the IFS Test Kit will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the IFS Test Kit will run on.
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


AppContainers_Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7bf87d0f-e328-4d69-855f-0a0efb469861

This automated test copies log files. It covers the following steps:

  1. Install 1 Sparta Miniport Interface

  2. Install SpartaEchoSvc

  3. Run App Container tests.

  4. Uninstall SpartaEchoSvc

  5. Uninstall Sparta Miniport Interface.

  6. Remove test binaries.

Test details
Specifications
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.SupportModernApplications
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see Windows Filtering Platform (WFP) Drivers Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows Filtering Platform (WFP) Driver Testing.


File IO 2 Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a1fb1fda-1fc1-41de-9626-bf88defeb746

This automated test verifies basic file I/O on the driver stack.

You can use the test to verify the following information:

  • The context in which the test or variation ran (for example, x86, file system, local/remote, language, build number)

  • Pass, fail, and variation count numbers

  • If failed, information that can help determine the cause of failure

The File IO 2 tests are based on TAEF:

  • To list the tests, run the following:

    te FileIOTestA.dll /list

  • To run all tests with priority zero (the highest priority, which is the default priority in RunFileIo2.cmd) on a particular test volume, run the following:

    TE.exe FileIOTestA.dll /select:@Priority=0  /p:Volume=%DRIVE_LETTER%

For more information about the behavior of file systems, see File System Behavior in the Microsoft Windows Environment.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Development
Timeout (in minutes) | 18000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions to the test computer.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
REFS | REFS | 10240mb | o:

RunFileIO.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For general troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

The test uses Ntlog for logging the test results. Any failure is logged with the Win32® GetLastError() code.

More information

Command syntax

Command option | Description
te FileIOTestA.dll /select:@Priority=0 /p:Volume=%DRIVE_LETTER% |

File list

File | Location
AttachFilter.cmd | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
IsREFSSupported.vbs | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
FioChild.exe | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
FioDetours.dll | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
FileIOTestA.dll | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
FileIOTestW.dll | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
ReadAsync.exe | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
WriteAsync.exe | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
RunFileIo2.cmd | [WTT\TestBinRoot]\base\fs\test\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
WrapFileIO2.cmd | [WTT\TestBinRoot]\base\fs\test\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the File IO 2 test will run on.
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the File IO 2 test will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT volume that the File IO 2 test will run on.
FAT32_DRIVE_LETTER | The drive letter for the FAT32 volume that the FileIO 2 test will run on.
EXFAT_DRIVE_LETTER | The drive letter for the ExFat volume that the File IO 2 test will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the File IO 2 test will run on.
RUN_MODE | Leave this on BVT.
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


Installable File System Filter Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14b230f3-7eee-437e-ab2f-375b200de6f3

This automated test verifies whether the behavior in the file system stack is consistent with the typical behavior of a file system. This is a regression test suite.

For more information about the behavior of file systems, see File System Behavior in the Microsoft Windows Environment.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

If you are running this test on Windows 8, it must be the Professional or Ultimate version of Windows 8; otherwise, the test may fail.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Use a system with 2 local disks. One disk is the boot disk with the system partition, while a completely separate disk is partitioned according to the test requirements.

For more information about requirements, see File System Testing Prerequisites.

Before you run the test, add the following partitions to the Windows environment.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
REFS | REFS | 10240mb | o:

If the test system includes a policy of locking out new accounts, this test might return Blocked on the multiprocess variations if the local computer account Ifstest is locked out. You can then use Account Manager to unlock the account and rerun the suite. RunIFStest.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

RunIFStest.cmd contains references to environment variables that can be changed to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

The test creates a temporary local computer account (Ifstest). It also expects to have additional partitioned volumes. Use a tool such as Minispy to see which I/O request packets (IRPs) are traveling on the file system stack. Compare passing (default Windows installations) with installations, including any failing driver. For documentation about the test variations, see IFS Test in the MSDN® Library.

For general troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. The test uses Ntlog for logging the test results. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command option | Description
IfsTest.exe | %DRIVE_ltr% -g Virus /n .\Ifstest-Local-NtfsResults.log /N 356789AB /T /p /m /E /j /r c: -d \Ntfs -a \datacoh.exe /u ifstest /U *rs53w52
-g <suitename> | Do not run <suitename>
/n <logname> | Create a long of name <logname>
/N | Specify NTLOG levels. If not included, then the GUI dialog box appears. This is useful in a batch mode run of the test NTLOG Levels 1 ABORT 2 SEV1 3 SEV2 4 SEV3 5 WARN 6 PASS 7 BLOCK 8 INFO 9 SYSTEM INFO A DEBUG INFO B TEST
/T | Enable trace of tests being done
/p | Enable pagefile testing in CreatePagingFileTest.
/m | Enable dirty bit testing in MountedDirtyTest
/E | Enable AllowExtendedDASDTest
/j | Enable support for tests involving the change journal.
/r <volumeletter> | Path to second volume required in certain tests.
-d <> | System Path to FSD device object in FileSystemDeviceOpenTest.
-a | Provide path to executable
/u | Username for test account
/U | Password for test account
/t <variation> | Execute only one named variation

File list

File | Location
ntlog.dll | [WTT\TestBinRoot]\NTTest\CommonTest\Ntlog</p>
ntlogger.ini | [WTT\TestBinRoot]\NTTest\CommonTest\Ntlog</p>
chg.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
chgfile.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
chgnotif.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
cleanupfiles.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
closedel.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
createkc.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
datacoh.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
decrypt.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
defrag.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
devctrl.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
dirinfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
dirpt.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
eainfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
encrypt.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
encryptvirus.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
enum.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
esecurit.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
estream.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fileinfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
filelock.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
forcedis.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fsctlgen.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
fsctlvol.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
IFSCFG.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifsmsg.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest-av.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest-av_wdk.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstestcleanup.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest_storagelogo.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ifstest_wdk.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ishell.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
linkpt.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
linktrak.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
mfile.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
mountpt.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
objectid.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
opcreatg.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
opcreatp.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
oplocks.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
quotas.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
readwr.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
reparspt.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
ResetAutoLogon.vbs | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
restoresystem.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
seccache.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
securit.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
setupsystem.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
skel.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
sparse.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
virus.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
volinfo.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
writevirus.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
xchg.exe | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
guidefile.dat | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT</p>
virusfile1.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
virusfile2.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
virusfile3.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
virusfile4.evf | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
createwttlog.vbs | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\IFS_TEST_KIT\virusfiles</p>
chgjourn.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\LFS_Automation\common</p>
fbslog.dll | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\shared_libs\fbslog</p>
RunIFSTests.cmd | [WTT\TestBinRoot]\NTTest\basetest\core_file_services\FilterManager\TestSuite\Scripts\FileSystems</p>
WrapIFSTests.cmd | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
attachfilter.cmd | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the IFS Test Kit will run on.
CNTFS_DRIVE_LETTER | The drive letter for the compressed NTFS volume that the IFS Test Kit will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT16 volume that the IFS Test Kit will run on. This volume must be greated than 1 Gb. and less than 2 Gb.
FAT32_DRIVE_LETTER | The drive letter for the FAT32 volume that the IFS Test Kit will run on.
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
EXFAT_DRIVE_LETTER | The drive letter for the ExFat volume that the IFS Test Kit will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the IFS Test Kit will run on.
DRIVER_UNDER_TEST |
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


IntegrityStream test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8cafdc98-1b7a-4b59-8ac7-ca660222777b

This automated test tests FSCTL_GET_INTEGRITY_INFORMATION and FSCTL_SET_INTEGRITY_INFORMATION.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites. In addition, add one partition to the Windows environment.

Label | File System | Size | Expected Drive Letter
REFS | REFS | 10240mb | o:

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For general troubleshooting information, see Troubleshooting File System Testing.

If you encounter any test failures, run with the option -l to have the test print additional information on variation failures. For example: IntegrityStream -p o: -l

If the problem does not reproduce, look for "Seed" in the log that has the failure and run: IntegrityStream -p o: -l -s <seed>

More information

Command syntax

Command option | Description
-p <drive> | Specify the drive letter of the REFS volume where test files will be created
-l | Show step-by-step information in the log
-v <variation number> | Run only this variation. Used for reproducing an issue. Find the variation number in the log where the failure originally appeared.
-s <seed> | Seed for random numbers. Used for reproducing the same values in a failed run. Find the seed in the log where the failure originally appeared.

File list

File | Location
[WTT\TestBinRoot]\NTTest\basetest\core_file_services\refs\integritystream.exe | \nttest</p>
[WTT\OSBinRoot]\NTTest\CommonTest\NTLog\ntlog.dll | [This content isn't available yet.]
[WTT\OSBinRoot]\NTTest\CommonTest\NTLog\ntlogger.ini | [This content isn't available yet.]
[WTT\TestBinRoot]\NTTest\basetest\core_file_services\shared_libs\stresslog.dll | [This content isn't available yet.]
[WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\IsREFSSupported.vbs | [This content isn't available yet.]
[WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\IsREFSSupported.vbs | [This content isn't available yet.]
[WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\IsREFSSupported.vbs | [This content isn't available yet.]

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


Mailslot Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1879df6-9f02-4ded-8e05-64279703d71b

The automated test verifies basic Mailslot File System (MSFS) functionality: creating and opening mailslots, reading and writing messages of various sizes, and closing mailslots. It also verifies the integrity of the messages that are passed via mailslots.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.NamedPipeAndMailSlots
  • Filter.Driver.AntiVirus.NamedPipeAndMailSlots
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites.

In addition, this test consists of a client binary (MailSlotClient.exe) and a server binary (MailSlotServer.exe). You should run these on the same computer.

To run this test, follow these steps:

  1. Copy the test binaries that are listed in the File List section locally.

  2. Start the server by running MailSlotServer.exe.

  3. Start the client on the same computer by running MailSlotClient.exe.

  4. The expected Pass count is 5. Inspect the log file for the presence of +SEV error tags. If you do not find any instances of this tag, the test has passed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

This test does not accept any command-line parameters.

File list

File | Location
Mailslotserver.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\MailSlotServer.exe
Mailslotclient.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\MailSlotClient.exe
Ntlog.dll | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlog.dll
Ntlogger.ini | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlogger.ini

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy


Mapped File IO 2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/750f58e6-a459-4b46-b3a5-4dc7978d8e22

This automated test verifies basic mapped file I/O on the driver stack.

NOTE

For more information about the behavior of file systems, see File System Behavior in the Microsoft Windows Environment.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions to the Windows environment.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
REFS | REFS | 10240mb | o:

RunFileIO.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test case details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

Command option | Description
te MappedIOTestA.dll /select:@Priority=0 /p:Volume=%DRIVE_LETTER% |

File list

File | Location
AttachFilter.cmd | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
IsREFSSupported.vbs | [WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
FioChild.exe | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
FioDetours.dll | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\FileIO2\
RunMappedFileIo2.cmd | [WTT\TestBinRoot]\base\fs\test\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
WrapMappedFileIO2.cmd | [WTT\TestBinRoot]\base\fs\test\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\
MappedIOTestA.dll | [WTT\TestBinRoot]\base\fs\test\Shared_Tests\MappedIO2\

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the Mapped File IO 2 test will run on.
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the Mapped File IO 2 test will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT volume that the Mapped File IO 2 test will run on.
FAT32_DRIVE_LETTER | The drive letter for the Fat32 volume that the Mapped File IO 2 test will run on.
EXFAT_DRIVE_LETTER | The drive letter for the ExFat volume that the Mapped File IO 2 test will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the Mapped File IO 2 test will run on.
LOGNAME_PREFIX | Name to prepend log name with
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


Named Pipe Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e0f2f69-abbb-47ac-a49b-e4e991f522a9

This automated test verifies the functionality of named pipes. It includes the following tests:

  • CreateNamedPipe tests

  • CallNamedPipe tests

  • TransactNamedPipe tests

  • TransactNamedPipe tests

  • WaitNamedPipe tests

  • Open Mode tests

  • Overlapped tests

  • Read/Write tests

  • Flush Pipe tests

This test consists of a client binary (Npclient.exe) and a server binary (Npserver.exe). You can run these on the same computer as the client image or on a separate computer.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.NamedPipeAndMailSlots
  • Filter.Driver.AntiVirus.NamedPipeAndMailSlots
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites.

To run this test, follow these steps:

  1. Copy the test binaries that are listed in the File List section locally.

  2. Start the server by using the following command: npserver.exe

  3. Start the client by using the following command: npclient.exe \\<%computername%>

    NOTE

    You can run the test with the server and client processes running on two different computers. In this case, specify the server host name in place of <%computername%>.

  4. The expected Pass count is variable, but it should be around 1,010. Inspect the log file for the presence of +SEV error tags. If you do not find any instances of this tag, the test has passed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

This test accepts a single parameter that indicates the server host name.

File list

File | Location
Npclient.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\npclient.exe
Npserver.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\npserver.exe
Namedpipe.ini | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\namedpipe.ini
Ntlog.dll | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlog.dll
Ntlogger.ini | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlogger.ini

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy


Named Pipe Kernel Security

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/097e27fe-f9c5-4065-af32-a11c104c3012

This automated test verifies that only kernel-mode requestors can invoke SCTL_PIPE_INTERNAL_TRANSCEIVE, because this command can read kernel memory.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.NamedPipeAndMailSlots
  • Filter.Driver.AntiVirus.NamedPipeAndMailSlots
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites.

To run this test, follow these steps:

  1. Copy the test binaries that are listed in the File List section locally.

  2. Run the following command: npfsregr.exe

  3. The expected Pass count is 1. Inspect the log file for the presence of +SEV error tags. If you do not find any instances of this tag, the test has passed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

This test does not accept command-line parameters.

File list

File | Location
Npfsregr.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\npfsregr.exe
Ntlog.dll | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlog.dll
Ntlogger.ini | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlogger.ini

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy


Named Pipe Reject Remote Clients

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3bcbd3f-3e9c-484a-a587-3c081cb28f7a

This automated test verifies that the GetNamedPipeInfo function returns the correct option when the named pipe is created with the PIPE_REJECT_REMOTE_CLIENTS option. For more information about PIPE_REJECT_REMOTE_CLIENTS, see CreateNamedPipe Function in the MSDN® Library.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.NamedPipeAndMailSlots
  • Filter.Driver.AntiVirus.NamedPipeAndMailSlots
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites.

To run this test, follow these steps:

  1. Copy the test binaries that are listed in the File List section locally.

  2. Start the test by using the following command without parameters: nprepro58297.exe

  3. The expected Pass count is 1. Inspect the log file for the presence of +SEV error tags. If you do not find any instances of this tag, the test has passed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

This test does not accept command-line parameters.

File list

File | Location
Nprepro58297.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\nprepro58297.exe
Ntlog.dll | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlog.dll
Ntlogger.ini | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlogger.ini

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy


Named Pipe State

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e9fd15a-7ffa-4caf-94eb-af2541ef2ede

This automated test validates the behavior of all named-pipe operations for each distinct state of a pipe instance.

The test evaluates the following states:

  • NO_INSTANCE. The instance does not exist.

  • SERVER_ONLY. The server side of the instance has been created.

  • CONNECTED. The client side has been created and connects to server.

  • CLIENT_DISCONNECTED. The client disconnects by closing its handle.

  • SERVER_DISCONNECTED. The server disconnects by using the DisconnectNamedPipe API.

The named-pipe operations that the test evaluates include the following:

  • Server CreateNP. Server calls CreateNamedPipe.

  • Server ConnectNP. Server calls ConnectNamedPipe.

  • Server DisconnectNP. Server calls DisconnectNamedPipe.

  • Server CloseHandle. Server calls CloseHandle.

  • Client CreateFile. Client calls CreateFile.

  • Client WaitNP. Client calls WaitNamedPipe.

  • Client CallNP. Client calls CallNamedPipe.

  • Client CloseHandle. Client calls CloseHandle.

  • Server Write. Server calls WriteFile.

  • Server Read. Server calls ReadFile.

  • Client Write. Client calls WriteFile.

  • Client Read. Client calls ReadFile.

The test selects each state in random order and calls each action in random order. If any action moves the pipe away from the current state, the test brings it back to the current state.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.NamedPipeAndMailSlots
  • Filter.Driver.AntiVirus.NamedPipeAndMailSlots
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

To run this test, follow these steps:

  1. Copy the test binaries that are listed in the File List section locally.

  2. Run the following command: npstate.exe regress

  3. The expected Pass count is 600. Inspect the log file for the presence of +SEV error tags. If you do not find any instances of this tag, the test has passed.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

This test accepts a single parameter that indicates the server host name.

File list

File | Location
Npstate.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\misc\npstate.exe
Ntlog.dll | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlog.dll
Ntlogger.ini | [WTT\OsBinRoot]\ddk_flat\DTM\tests\ntlog\ntlogger.ini

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy


NDISTest 6.5 - LWF Logo test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1931f4b3-18b0-4495-bb65-0d5088bea7af

This automated test targets LWF by validating that the all the requirements specified for the light weight filter driver are satisfied, and that they comply with NDIS specification on MSDN.

The test installs two of the NDISTest virtual miniports - "NDISTest 6.30 - CL - Default w/TCPIP", which would be used as the test and support adapters for running the LWF logo test. These virtual miniports are uninstalled in the cleanup phase of the test.

Windows 8 has a requirement that all NDIS LWF drivers are NDIS 6.30. This is validated by ConfigCheck test, which will fail the filter logo test if the Filter driver is not NDIS 6.30.

ConfigCheck test also validates that the Filter driver selected as the target, is actually bound to the test adapter, and an error is thrown if the filter is not bound to the test adapter.

It is also validated that the filter driver is able to process packets that are larger than miniport's MTU size.

This also runs a filter stress test which is designed to stress the datapath and PnP paths of NDIS filter drivers. The test will limit the test virtual miniport's receive descriptors such that a significant number of receive indications will happen with the receive resources flag. This test performs the following actions in a multi-threaded way:

  • Stress traffic from the support miniport directed to the test miniport

  • Stress traffic from the test miniport directed to the support miniport

  • Stop/start the test miniport (which triggers a pause and subsequent restart operations)

  • Test adapter indicating media disconnected/connected

  • Test adapter resetting

Finally, basic send and receive connectivity will be tested between the test/support adapters.

Test details
Specifications
  • Filter.Driver.Network.LWF.Base
  • Filter.Driver.Network.LWF.MTUSize
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, you need to manually install your filter driver on the test machine.

Follow these steps to run the test:

  1. Configure the HLK Server and HLK Client machines. Filter Logo tests need just the one client machine.

  2. Install the Light Weight Filter driver on the Client machine.

  3. Restart the Client machine.

  4. From the HLK Server, add the client on which the LWF is installed to a new machine pool, and change the machine status to 'Ready'.

  5. From HLK studio, create a new project under the Project tab in HLK Studio.

  6. In the Selection tab of the HLK studio, select the machine pool that was created in the previous steps from the dropdown.

  7. Select software device, and select the LightWeightFilter driver that was installed and needs to be tested (see the following figure).

    select filter driver

  8. Run all of the tests listed in the Tests tab against the filter driver.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

More information

Parameters

Parameter name | Parameter description
TestAdapter |
SupportAdapter |
TestScript |
queryFilterService | ServiceName of the filter selected as target


Object ID test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eba8e46b-d8de-45a9-bdaf-8107b6d0731c

This automated test checks the following collection of FSCTLs:

  • FSCTL_CREATE_OR_GET_OBJECT_ID

  • FSCTL_DELETE_OBJECT_ID

  • FSCTL_GET_OBJECT_ID

  • FSCTL_SET_OBJECT_ID

  • FSCTL_SET_OBJECT_ID_EXTENDED

NOTE

For more information about the behavior of file systems, see File System Behavior in the Microsoft Windows Environment.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions to the Windows environment.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
NOTE

RunObjectID.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test case details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

The test runs variations for each of the six partitions that were described in the Running the test section.

Command syntax

Command option | Description
oidtest %DRIVE_ltr% -l:ObjectID_BVT_CNTFS -B | Requires two drive letters and the -bvt parameter.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Oidtest.exe | <[testbinroot]>\NTTest\basetest\core_file_services\ntfs\oid</p>
RunObjectID.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
WrapObjectID.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
Ntlog.dll | <[testbinroot]>\NTTest\CommonTest\NTLog</p>
Ntlogger.ini | <[testbinroot]>\NTTest\CommonTest\NTLog</p>

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the Object ID test will run on.
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the Object ID test will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT volume that the Object ID test will run on.
FAT32_DRIVE_LETTER | The drive letter for the FAT32 volume that the Object ID test will run on.
EXFAT_DRIVE_LETTER | The drive letter for the ExFat volume that the Object ID test will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the Object ID test will run on.
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy


Oplocks Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3d717052-7804-4de7-b097-a5e30b6bb7e5

This automated test verifies the basic behavior of legacy opportunistic locks (oplocks) and enhanced oplocks. The legacy oplocks are Level2 (L2), Level1 (L1), Filter, and Batch. The enhanced oplocks are Read (R), Read-Write (RW), Read-Handle (RH), and Read-Write-Handle (RWH).

NOTE

For more information about the behavior of file systems (including oplocks), see File System Behavior in the Microsoft Windows Environment.

The test runs variations for each of the six partitions that are described in the Running the test section.

This test has the following variations:

  • Legacy_Acquire_Release. Acquire a legacy oplock and then release it.

  • Enhanced_Acquire_Release. Acquire an enhanced oplock and then release it.

  • Enhanced_Acquire_Release_Opkey. Acquire an enhanced oplock by using an oplock key.

  • Legacy_Break_L2. Break an L2 oplock with various file operations.

  • Enhanced_Break_R. Break an R oplock with various file operations.

  • Legacy_Break_L1. Break an L1 oplock with various file operations.

  • Enhanced_Break_RW. Break an RW oplock with various file operations.

  • Enhanced_Break_RH. Break an RH oplock with various file operations.

  • Legacy_Break_Batch. Break a Batch oplock with various file operations.

  • Enhanced_Break_RWH. Break an RWH oplock with various file operations.

  • EnhancedMultipleSharedOplocks. Acquire multiple enhanced oplocks on the same file.

  • EnhancedUpgradeOplocks. Upgrade an enhanced oplock.

  • EnhancedOplockBreakAckOtherHandle. Acknowledge an enhanced oplock break on another handle that opened via the same key.

  • EnhancedOplockStealthUpgrade. Acknowledge an oplock break and request an upgrade-level oplock.

  • AtomicOplocksVariation. Atomic open (open a handle by using CreatOptions=FILE_OPEN_REQUIRING_OPLOCK).

  • AtomicOplocksNonIntrusiveVariation. Atomic open when an oplock already exists on the file.

  • BreakingRHOplocks. Conduct special operations to break an RH oplock.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 540
Category | Development
Timeout (in minutes) | 32400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires the following extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
REFS | REFS | 10240mb | o:
NOTE

RunFileIO.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test case details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

To run this test, make sure that the computer has NTFS, CNTFS, FAT16, FAT32, ExFAT, and UDF volumes set up. Also, make sure that the drive letter for this volume is entered in the <filesystem>_DRIVE_LETTER parameters.

More information

Command syntax

Command option | Description
runkarr %DRIVE_1% %DRIVE_2% -bvt | Requires two drive letters and the appropriate bvt parameter.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Enhancedoplocks.exe | <[testbinroot]>\NTTest\BASETEST\core_file_services\Shared_Tests\Regression\Oplocks</p>
Opkey.inf | <[testbinroot]>\NTTest\BASETEST\core_file_services\FilterManager</p>
Opkey.sys | <[testbinroot]>\NTTest\BASETEST\core_file_services\FilterManager</p>
RunOplocks.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
WrapOplocks.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the Oplocks test will run on.
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the Oplocks test will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT volume that the Oplocks test will run on.
FAT32_DRIVE_LETTER | The drive letter for the Fat32 volume that the Oplocks test will run on.
EXFAT_DRIVE_LETTER | The drive letter for theExFat volume that the Oplocks test will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the Oplocks test will run on.
LLU_LclAdminUSer | LLU for Execute
LLU_NetAccessOnly | LLU for Copy
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


Registry Callback Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/087a285b-19a8-4581-a41f-56be931d8ea3

This automated test exercises basic test cases for a registry filter driver.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.FileSystem.RegistryAndProcess
  • Filter.Driver.AntiVirus.RegistryAndProcess
  • Filter.Driver.AntiVirus.MiniFilter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. For test failures, search for the term "+sev" in the log.

More information

This test includes the following test cases:

  • Altitude Conflict

  • CreateKey Block

  • CreateKey Bypass

  • CreateKey Override Access Denied

  • CreateKey Override Block

  • SetKeySecurity Bypass

  • Transacted CreateKey Bypass

  • Transacted CreateKey Bypass (No Commit)

  • Unregister Close Race

  • Save Restore Replace

To manually run each test case, use the following procedures.

To manually run the Altitude Conflict test case

  1. Register a callback at altitude 1000.

  2. Register another callback at the same altitude, and then verify that it fails.

  3. CreateKey the Monitor test.

  4. Register three of the same callbacks at altitudes 1000, 2000, and 3000. Set all three callbacks to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  5. Create a key, and then verify that it succeeds.

  6. Unregister the callbacks.

  7. Verify that each callback was invoked appropriately based on its altitude.

To manually run the CreateKey Block test case

  1. Register three of the same callbacks at altitudes 1000, 2000, and 3000.

  2. Set callbacks 1000 and 3000 to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  3. Set callback 2000 to "block" mode. This means that the callback will return an error status.

  4. Create a key, and then verify that it fails.

  5. Unregister the callbacks.

  6. Verify that each callback was invoked appropriately based on its altitude.

To manually run the CreateKey Bypass test case

  1. Register three of the same callbacks at altitudes 1000, 2000, and 3000.

  2. Set callbacks 1000 and 3000 to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  3. Set callback 2000 to "bypass" mode. This means that the callback will return an STATUS_CALLBACK_BYPASS and perform the operation on behalf of the registry.

  4. Create a key, and then verify that it succeeds.

  5. Unregister the callbacks.

  6. Verify that each callback was invoked appropriately based on its altitude.

To manually run the CreateKey Override Access Denied test case

  1. Create a key K1, and then set its discretionary access control list (DACL) to give read-only access.

  2. Create a key under K1. This should fail because of the read-only DACL.

  3. Register three of the same callbacks at altitudes 1000, 2000, and 3000. STATUS_CALLBACK_BYPASS.

  4. Set callbacks 1000 and 3000 to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  5. Set callback 2000 to "access denied bypass" mode. This means that the callback will perform the operation from user mode, not be blocked by the read-only DACL, and return.

  6. Create a key under K1, and then verify that it succeeds.

  7. Unregister the callbacks.

  8. Verify that each callback was invoked appropriately based on its altitude.

To manually run the CreateKey Override Block test case

  1. Register four of the same callbacks at altitudes 1000, 2000, 3000, and 4000.

  2. Set callbacks 1000 and 4000 to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  3. Set callback 2000 to "block" mode. This means that the callback will return STATUS_UNSUCCESSFUL.

  4. Set callback 3000 to "override failure" mode. This means that if the callback identifies STATUS_UNSUCCESSFUL in the post-operation callback, it will still perform the operation and return success.

  5. Create a key, and then verify that it succeeds.

  6. Unregister the callbacks.

  7. Verify that each callback was invoked appropriately based on its altitude.

To manually run the SetKeySecurity Bypass test case

  1. Register three of the same callbacks at altitudes 1000, 2000, and 3000.

  2. Set callbacks 1000 and 3000 to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  3. Set callback 2000 to "bypass" mode. This means that the callback will return STATUS_CALLBACK_BYPASS and perform the operation on behalf of the registry.

  4. Call RegSetKeySecurity to set the security descriptor of a key, and then verify that it succeeds.

  5. Unregister the callbacks.

  6. Verify that each callback was invoked appropriately based on its altitude.

To manually run the Transacted CreateKey Bypass test case

  1. Create a transaction T1.

  2. Create a key in the context of transaction T1.

  3. Verify that the key succeeds, and then delete it.

  4. Register three of the same callbacks at altitudes 1000, 2000, and 3000.

  5. Set callbacks 1000 and 3000 to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  6. Set callback 2000 to "bypass" mode. This means that the callback will return STATUS_CALLBACK_BYPASS and perform the operation on behalf of the registry.

  7. Create a key in the context of transaction T1, and then verify that it succeeds.

  8. Commit the transaction.

  9. Unregister the callbacks.

To manually run the Transacted CreateKey Bypass (No Commit) test case

  • Complete the same steps as in the Transacted CreateKey Bypass test case, but do not commit the transaction at the end.

To manually run the Unregister Close Race test case

  1. Start a thread that opens a test key, and then close the handle in a loop.

  2. In the original thread, register and unregister a callback 100 times.

  3. Signal the other thread to exit.

To manually run the Save Restore Replace test case

  1. Create a key under the software hive.

  2. Register a callback at altitude 1000 and set it to "monitor" mode. This means that the callback will do nothing but return STATUS_SUCCESS.

  3. Call RegSaveKey on the created key, and then verify that it succeeds.

  4. Call RegRestoreKey on the created key by using the hive file that RegSaveKey created, and then verify that it succeeds.

  5. Make a copy of the hive file.

  6. Load the original hive file under HKEY_LOCAL_MACHINE, and then verify that it succeeds.

  7. Call RegReplaceKey by using the copy of the hive file. This should fail with a sharing violation, but it will still trigger the callbacks for this operation.

  8. Unregister the callback, and then verify that it was invoked appropriately.

Command syntax

Command option | Description
RegCbTestctrl.exe -regr | Runs the test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
RegCbTestCtrl.exe | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\cm
RegCbTest.sys | [WTT\TestBinRoot]\NTTEST\BASETEST\kernel\cm
Ntlog.dll |

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for copy


ReparsePoints

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/20c21f21-de9b-4ef4-94a5-56fe4cfffb49

This automated test validates reparse points on the upper file system stack.

This test sets, deletes, and queries reparse points via FSCTLs. The test proceeds by setting different sizes of reparse data on files and directories.

The test also includes dismount testing with setting reparse points and invalid input. Specifically, the test includes the following:

  • FSCTL_SET_REPARSE_POINT

  • FSCTL_GET_REPARSE_POINT

  • FSCTL_DELETE_REPARSE_POINT

NOTE

For more information about the behavior of file systems, see File System Behavior in the Microsoft Windows Environment.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions to the Windows environment.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
REFS | REFS | 1,024 MB | o:
NOTE

RunReparsePoint.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

If you experience a test failure, run it with the option /V to have the test print additional information about variation failures (example: rp_regres %DRIVE_ltr% /V).

If you experience many failures, make sure that you are running on the correct type of file system. You can also check the file-system information about a volume to make sure that reparse points are supported. To do so, use the command fsutil fsinfo volumeinfo %DRIVE_ltr% and look for the output Supports Reparse Points.

More information

Command syntax

Command option | Description
Rp_regres %DRIVE_ltr% | Specifies the driver to test.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Rp_regres.exe | <[testbinroot]>\NTTest\basetest\core_file_services\ntfs</p>
Ntlog.dll | <[testbinroot]>\NTTest\CommonTest\Ntlog</p>
Ntlogger.ini | <[testbinroot]>\NTTest\CommonTest\Ntlog</p>
Stresslog.dll | <[testbinroot]>\NTTest\basetest\core_file_services\shared_libs</p>
RunReparsePoint.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
WrapReparsePoint.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
IsREFSSupported.vbs | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the Reparse Points test will run on.
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the Reparse Points test will run on.
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


Scrub Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b5581b0-4b2e-485e-978a-06d5aa30e3c2

This automated test tests FSCTL_REPAIR_COPIES, FSCTL_MARK_HANDLE(MARK_HANDLE_READ_COPIES) on single disk and propagation of attribute.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: File System Testing Prerequisites. In addition, add one partition to the Windows environment.

Label | File System | Size | Expected Drive Letter
REFS | REFS | 10240mb | o:
NTFS | NTFS | 2048mb | g:

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For general troubleshooting information, see Troubleshooting File System Testing.

If you encounter any test failures, run with the option -l to have the test print additional information on variation failures. For example, FsctlScrubTest -p o: -l

If the problem does not reproduce, look for "Seed" in the log that has the failure and run:FsctlScrubTest -p o: -l -s <seed>

More information

Command syntax

Command option | Description
-p <drive> | Specify the drive letter of the REFS volume where test files will be created
-l | Show step-by-step information in the log
-v <variation number> | Run only this variation. Used for reproducing an issue. Find the variation number in the log where the failure originally appeared.
-s <seed> | Seed for random numbers. Used for reproducing the same values in a failed run. Find the seed in the log where the failure originally appeared.

File list

File | Location
FsctlScrubTest.exe | WTT\TestBinRoot]\NTTest\basetest\core_file_services\refs\scrub\FsctlScrubTest.exe
ntlog.dll | WTT\OSBinRoot]\NTTest\CommonTest\NTLog\ntlog.dll
ntlogger.ini | WTT\OSBinRoot]\NTTest\CommonTest\NTLog\ntlogger.ini
stresslog.dll | WTT\TestBinRoot]\NTTest\basetest\core_file_services\shared_libs\stresslog.dll
IsREFSSupported.vbs | WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\IsREFSSupported.vbs
Wrap FsctlScrubTest.cmd | WTT\TestBinRoot]\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems\Wrap FsctlScrubTest.cmd

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the Object ID test will run on.
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


Syscache Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69f18ed7-7f1e-42d9-9c32-29ae98e38089

This is an automated test that writes to a file and verifies that the data written is read back correctly. It can detect corruptions caused by anything in the path from firmware, drivers, file system, memory, etc. It uses standard Win32 File System and memory management APIs to read and write data from the file. The test binary is readwrit.exe.

Syscache opens a file with a certain flag/attribute and writes to the file. Each chosen flag may span several runs on the file.

A run is defined as a set of the following sequence:

  • Create/open a file.

  • Truncate the filesize to 0.

  • Write to the file.

  • Close the file.

  • Reopen the file.

  • Read the file.

  • Verify file content.

  • Close the file.

There is a set of zero and non-zero regions in the file. Zero regions are areas in the file where no data was written. Non-zero regions are areas in the file where data was written. The pattern is a DWORD of the format RRPPPPPP. The top two bytes are the run number, and the next 3 bytes are the one's complement of the offset of this DWORD in the file.

The following attributes are used for writing a file:

Write Attribute | Explanation
FILE_ATTRIBUTE_NORMAL | See CreateFile() Documentation
FILE_FLAG_SEQUENTIAL_SCAN | See CreateFile() Documentation
FILE_FLAG_NO_BUFFERING | See CreateFile() Documentation
FILE_FLAG_NO_BUFFERING | See CreateFile() Documentation
FILE_FLAG_WRITE_THROUGH | See CreateFile() Documentation
FILE_ATTRIBUTE_TEMPORARY | See CreateFile() Documentation
NO_BUFFERING | WRITE_THROUGH | See CreateFile() Documentation
FILE_ATTRIBUTE_SPARSE_FILE | The file is set to sparse.
NORMAL APPEND_WRITE | Same as FILE_ATTRIBUTE_NORMAL; closes and reopening the file per write and appending the next region.
FILE_FLAG_SECTOR_CHUNKS | Same as FILE_FLAG_NO_BUFFERING, data is written one sector at a time.
FILE_MAP | Same as FILE_ATTRIBUTE_NORMAL, data is written via memory mapping.
FILE_FLAG_OVEREXTEND | Same as FILE_ATTRIBUTE_NORMAL, data is written via memory mapping.

The following attributes are used for reading from the file:

Read Attribute | Explanation
FILE_MAP | FILE_ATTRIBUTE_NORMAL, data is read via memory mapping
NO_BUFFERING | FILE_FLAG_NO_BUFFERING
NORMAL | FILE_ATTRIBUTE_NORMAL
RANDOM_ACCESS | FILE_FLAG_RANDOM_ACCESS
SEQUENTIAL_SCAN | FILE_FLAG_SEQUENTIAL_SCAN
TEMPORARY | FILE_FLAG_TEMPORARY
WRITE_THROUGH | FILE_FLAG_WRITE_THROUGH

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Development
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions to the test computer.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:
REFS | REFS | 10240mb | o:

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

When the test fails, the log contains all of the information you need to analyze the failure. Look for the following information to reproduce the error:

  • The "Write Attribute". Look up the table of write attributes to find how the data was written to the file.

  • The "Read Attribute". Look up the table of read attributes to find out how the data was read back from the file.

  • The offset at which the error occurred.

  • The region of the file in which the error occurred. The test typically writes entire region using a single write (with the exception of the FILE_FLAG_SECTOR_CHUNKS option).

To run this test, make sure that the computer has NTFS, CNTFS, FAT16, FAT32, ExFAT, and UDF volumes set up. Also, make sure that the drive letter for this volume is entered in the <filesystem>_DRIVE_LETTER parameters.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

Command option | Description
WrapSyscache.cmd [NTFS_DRIVE_LETTER] [CNTFS_DRIVE_LETTER] [FAT_DRIVE_LETTER] [FAT32_DRIVE_LETTER] [EXFAT_DRIVE_LETTER] [UDF_DRIVE_LETTER] [WTTRunWorkingDir] | Writes to a file and verifies that the data written is read back correctly
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
Ntlog.dll | <[osbinroot]>\nttest\CommonTest\NtLog</p>
Ntlogger.ini | <[osbinroot]>\nttest\CommonTest\NtLog</p>
Readwrit.exe | <[testbinroot]>\nttest\BASETEST\core_file_services\cachemgr</p>
RunSyscache.cmd | <[testbinroot]>\nttest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
Stresslog.dll | <[testbinroot]>\nttest\basetest\core_file_services\shared_libs</p>
WrapSyscache.cmd | <[testbinroot]>\nttest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>

Parameters

Parameter name | Parameter description
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the Syscache test will run on.
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the Syscache test will run on.
FAT_DRIVE_LETTER | The drive letter for the FAT volume that the Syscache test will run on.
FAT32_DRIVE_LETTER | The drive letter for the FAT volume that the Syscache test will run on.
EXFAT_DRIVE_LETTER | The drive letter for the ExFat volume that the Syscache test will run on.
UDF_DRIVE_LETTER | The drive letter for the UDF volume that the Syscache test will run on.
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
REFS_DRIVE_LETTER | The drive letter for the ReFS volume that the test will run on. Enter NONE if not >= Win8 Server.


TransitionTechnologies_Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92628629-82bb-4c60-9750-ce2842d2fd92

This manual test covers the following steps:

  1. Copy test binaries.

  2. Install 1 Sparta Miniport Interface.

  3. Run Teredo tests.

  4. Uninstall Sparta Miniport Interface.

  5. Remove test binaries.

Test details
Specifications
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportTeredo
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see Windows Filtering Platform (WFP) Drivers Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows Filtering Platform (WFP) Driver Testing.


Txfs2

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8bc35d1-8a28-4077-bb5f-24573e19efc8

This automated test evaluates the transactional capability of the NTFS file system (TxF). It contains scenarios that test simple transacted operations, such as creating and deleting a file, or committing and rolling back the transaction. It also tests more advanced features of TxF, such as savepoints, miniversion, and secondary resource managers (RMs).

This test runs on the volume where it is started, typically the system volume. For the test to work correctly, this volume must be an NTFS volume or a compressed NTFS volume.

NOTE

For more information about the behavior of file systems, see File System Behavior in the Microsoft Windows Environment.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.FileSystem.Functionality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires extra hard drive space for four simple 2,048-megabyte (MB) partitions and two simple 1,024-MB partitions.

Before you run the test, you must add the following partitions to the Windows environment.

Label | File system | Size | Expected drive letter
NTFS | NTFS | 2,048 MB | g:
CNTFS | NTFS (compressed) | 2,048 MB | i:
FAT | FAT16 | 1,024 MB | k:
FAT32 | FAT32 | 1,024 MB | l:
ExFAT | ExFAT | 2,048 MB | m:
UDF | UDF | 2,048 MB | n:

The test runs variations for each of these six partitions.

NOTE

RunTxf.cmd contains references to environment variables that you can change to allow for skipping of certain file systems.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

Command option | Description
Txfsreg --regression | Must be run on the target volume.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
TxfsReg.exe | <[testbinroot]>\NTTest\basetest\core_file_services\txf</p>
Ntlog.dll | <[testbinroot]>\NTTest\CommonTest\Ntlog</p>
Ntlogger.ini | <[testbinroot]>\NTTest\CommonTest\Ntlog</p>
Stresslog.dll | <[testbinroot]>\NTTest\basetest\core_file_services\shared_libs</p>
RunTxF.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>
WrapTxF.cmd | <[testbinroot]>\NTTest\BASETEST\Core_File_Services\FilterManager\TestSuite\Scripts\FileSystems</p>

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for execute
LLU_NetAccessOnly | LLU for copy
NTFS_DRIVE_LETTER | The drive letter for the NTFS volume that the TxF tests will run on.
CNTFS_DRIVE_LETTER | The drive letter for the Compressed NTFS volume that the TxF test will run on.


WindowsFilteringPlatform_Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9a199cc-29b0-4805-9362-a2e7da39810c

This manual test verifies basic Windows firewall functionality.

Test details
Specifications
  • Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.SupportReordering
  • Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.SupportRemoval
  • Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.SupportLiveMigration
  • Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.NoEgressModification
  • Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.InteropWithOtherExtensions
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportVirtualPrivateNetworking
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportRemoteDesktop
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportRemoteAssistance
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportPeerNameResolution
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportMobileBroadBand
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportMediaExtenderStreaming
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportInternetStreaming
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportICMPErrorMessages
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportFileAndPrinterSharing
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportBasicWebsiteBrowsing
  • Filter.Driver.WindowsFilteringPlatform.Scenario.SupportAutomaticUpdates
  • Filter.Driver.WindowsFilteringPlatform.Scenario.Support6to4
  • Filter.Driver.WindowsFilteringPlatform.NetworkingFundamental.SupportNameResolution
  • Filter.Driver.WindowsFilteringPlatform.NetworkingFundamental.SupportIPv6
  • Filter.Driver.WindowsFilteringPlatform.NetworkingFundamental.SupportIPv4
  • Filter.Driver.WindowsFilteringPlatform.NetworkingFundamental.SupportDynamicAddressing
  • Filter.Driver.WindowsFilteringPlatform.NetworkingFundamental.SupportAddressResolution
  • Filter.Driver.WindowsFilteringPlatform.Firewall.UseWindowsFilteringPlatform
  • Filter.Driver.WindowsFilteringPlatform.Firewall.SupportMACAddressExceptions
  • Filter.Driver.WindowsFilteringPlatform.Firewall.SupportApplicationExceptions
  • Filter.Driver.WindowsFilteringPlatform.Firewall.Support5TupleExceptions
  • Filter.Driver.WindowsFilteringPlatform.Firewall.NotOnlyPermitAllFilters
  • Filter.Driver.WindowsFilteringPlatform.Firewall.DisableWindowsFirewallProperly
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.Winsock
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.WFPObjectACLs
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.SupportPowerManagedStates
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.StreamInjection.NoStreamStarvation
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.PacketInjection.NoDeadlocks
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.NoTamperingWith3rdPartyObjects
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.NoAccessViolations
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.NetworkDiagnosticsFramework.HelperClass
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.FwpmSublayers.UseOwnOrBuiltIn
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.FwpmProviders.MaintainIdentifying
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.FwpmProviders.AssociateWithObjects
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.FwpmFilters.MaintainOneTerminating
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.ConnectionProxying.NoDeadlocks
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.SupportModernApplications
  • Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.CleanUninstall
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Scenario
Timeout (in minutes) | 10800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see Windows Filtering Platform (WFP) Drivers Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows Filtering Platform (WFP) Driver Testing.


Winsock Core Functional Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5cd6116-7289-483f-a699-d2121194245a

This automated test iterates through some of the core Winsock functionality against a loopback interface and verifies whether the Winsock API interface is correctly maintained.

All tests cover IPv4 and IPv6 sockets, which all bind to the loopback interface. Variations are as follows:

  • Socket Catalog. Enumerates the Winsock catalog, creates a socket for each returned protocolinfo structure (each protocol tuple), and binds it to the loopback interface.

  • OVERLAPPED IO. Creates both IPv4 and IPv6 TCP stream sockets, establishes a connection over loopback, and sends data between sockets via blocking send and overlapped receive calls. All data is verified as received.

  • TransmitFile variation. Verifies that TransmitFile correctly sends data and implements the TF_DISCONNECT flag for socket reuse for both IPv4 and IPv6 sockets. Creates a 260-byte temporary file and transmits over a TCP connection via TransmitFile. The listening socket uses AcceptEx to verify the connection and socket reuse.

  • ConditionalAccept. Verifies semantics of conditional accept over both IPv4 and IPv6 TCP stream sockets. Tests five connections: without a listener, returning CF_REJECT, returning CF_ACCEPT, returning CF_DEFER + CF_REJECT, and returning CF_DEFER + CF_ACCEPT.

  • Streams. Blocks send/receive over IPv4 and IPv6 TCP stream sockets. Defers calling acceptance with a zero listen backlog until the connection has finished.

  • Datagrams. Verifies sending and receiving of datagrams over IPv4 and IPv6 UDP sockets. Tests both sending datagrams via connect/send/receive and connectionless send to/receive from.

  • Select. Verifies READFDS notification on both IPv4 and IPv6 TCP sockets for indications of connection establishment, receiving data, and closure of the socket.

  • Bind. Verifies bind semantics for IPv4 and IPv6 TCP sockets: basic bind, SO_REUSEADDR binds, and SO_EXCLUSIVEADDRUSE binds.

  • ReadFile/WriteFile. Verifies whether overlapped ReadFile() and WriteFile() functions work correctly over both IPv4 and IPv6 TCP sockets.

  • Shutdown. Verifies shutdown() semantics on IPv4 and IPv6 TCP sockets by establishing a connection, posting a blocking receive, and verifying whether calling shutdown completes the receive with zero bytes received.

  • Addressing. Verifies the conversion of IPv4 and IPv6 addresses from h, decimal, and octal strings to the corresponding socket address structure values (WSAAddressToString and WSAStringToAddress).

  • Multicast. For IPv4 and IPv6, verifies the joining to multicast groups via IP_ADD_MEMBERSHIP and IPV6_ADD_MEMBERSHIP, sending and receiving data to the group, and leaving the group.

  • JoinLeaf. For IPv4 and IPv6, verifies the joining to multicast groups via WSAJoinLeaf, sending and receiving data to the group, and leaving the group.

  • AsyncSelect. For IPv4 and IPv6 TCP sockets, verifies that FD_CONNECT, FD_SEND, and FD_READ Windows messages are processed via WSAAsyncSelect. Also verifies whether FD_CONNECT is processed when a multicast socket completes WSAJoinLeaf.

  • IOCP. For IPv4 and IPv6 TCP sockets, makes overlapped receive calls in which the socket is associated with an I/O completion port. Also verifies whether the overlapped completions are processed and all data is received.

  • RAW socket. For IPv4 and IPv6, creates raw sockets, sending and receiving Internet Control Message Protocol (ICMP) messages via OVERLAPPED IO.

  • PnP. Verifies whether overlapped address change notification is signaled when non-loopback IP addresses are added to and removed from the first non-loopback.

For more information about the Winsock API, see Windows Sockets 2.

Test details
Specifications
  • Filter.Driver.FileSystem.MiniFilter
  • Filter.Driver.AntiVirus.MiniFilter
  • Filter.Driver.AntiVirus.Winsock
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Filter.Driver additional documentation

Running the test

For more information about requirements, see File System Testing Prerequisites.

In addition, this test requires the following software:

  • A filter driver to be tested along with any supporting application suite

  • At least one connected network interface that has a valid IPv4 and IPv6 address

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting File System Testing.

All test cases return Pass or Fail. To review test details, review the test log from Windows HLK Studio.

NOTE

Windows Firewall may open a message that suggests that the firewall may be blocking some features of the test. However, the firewall does not affect the test. You can safely ignore this message.

If this procedure does not provide a successful test result, submit the test log with device-specific or system-specific details to the Windows Hardware Lab Kit (HLK) Support alias.

More information

Command syntax

Command option | Description
Winsockfunctional -protocol ip -t "Winsock API\Current Protocols (IPv4/IPv6)\BVT" -wtt -r -dontdisable -ipsec -notrace | You must supply this core argument.
-lsponly | You must append this argument when an LSP is installed.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
WinsockFunctional.exe | <[testbinroot]>\NTTest\NetTest\Winsock\common</p>
WinsockFunctional.wtl | Detailed output log that contains the test results
Wsbvt.log | Summary output log of the test results
Bvterr.log | Summary output log of the test results
Fnshell.ini | Temporary .ini file that the test generates and uses

Parameters

Parameter name | Parameter description
LLU_LocalAdmin | LLU for execution
LLU_NetAccessOnly | LLU for Copy


Filter.Driver additional documentation

In this section

  • Antivirus Testing Prerequisites
  • Troubleshooting Antivirus Testing
  • Early Launch Antimalware Testing Prerequisites
  • Troubleshooting Early Launch Antimalware Testing
  • File System Testing Prerequisites
  • Troubleshooting File System Testing
  • Windows Filtering Platform (WFP) Drivers Testing Prerequisites
  • Troubleshooting Windows Filtering Platform (WFP) Driver Testing


Antivirus Testing Prerequisites

This section describes the tasks that you must complete before you test an antivirus driver by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software Requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for testing. You might need additional hardware if the test device provides bus-specific support. To determine whether additional hardware requirements apply, see the test description for each test.

  • One test computer that is running either the client or server version of Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1

  • Another computer that is running Windows Server 2008 R2 SP1

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your product, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the product that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software Requirements

The following software is required for testing:

  • The antivirus filter driver under test

    WARNING

    Make sure that you install the product on the test computer before you install the Windows HLK Client.

Test computer configuration

To configure the test system, follow these steps:

  1. Determine the letter assignment for each volume:

    NTFS

    g:

    CNTFS

    i:

    Fat16

    k:

    Fat32

    l:

    ExFat

    m:

    UDF

    n:

  2. On the client computer, make sure that the following volumes are present:

    • NTFS 2gb

    • ntfs compressed 2gb

    • fat16 1gb

    • Fat32 1gb

    • Exfat 1gb

    • UDF 2gb

  3. In the controller, modify the parameters on the jobs in the $\WDK Tests\Storage\Filesystems section to point to test volumes, as follows:

    • TxF2: Modify ntfs and cntfs to point to test volumes.

    • ReparsePoints: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Installable Filesystems filter test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Antivirus Installable Filesystems filter test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • File IO test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Mapped File IO test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Object ID test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Oplocks test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Syscache test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

  4. On the server, create a share that you name RDRTest.

  5. Modify the parameters in the $\WDK Tests\Leasing\SMB_OplockRDR test to point to the server name and share name.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Troubleshooting Antivirus Testing

To troubleshoot issues that occur with antivirus testing, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Related topics

Troubleshooting Windows HLK


Early Launch Antimalware Testing Prerequisites

This section describes the tasks that you must complete before you test your Early Launch Anti-Malware (ELAM) driver by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer Configuration.

The ELAM software feature provides a Microsoft-supported mechanism for antimalware software to start before all other third-party components. The system first initializes antimalware drivers and allows these drivers to control the initialization of boot drivers, so that the system does not initialize unknown boot drivers. After the boot process has initialized the boot drivers and access to persistent storage is available efficiently, existing antimalware software may continue to block malware from executing.

For more information, see Firmware and Boot Environment.

Hardware requirements

The following hardware is required for testing:

  • Two test computers. These test computers must meet the Windows HLK prerequisites and must be included in the same computer pool. For more information, see Windows HLK Prerequisites.
NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your product, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the product that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required for testing:

  • The driver that you are testing.

    WARNING

    Make sure that you install the product on the test computer before you install the Windows HLK Client.

  • The latest Windows HLK filters or updates.

Test computer Configuration

If you are testing unsigned kernel mode drivers, choose one of the following options:

  • Attach a kernel debugger. In this case, the system does not verify or enforce driver signatures. Therefore, any driver can load even if the driver does not have a verified certificate or the driver is unsigned.

  • Create a self-signed certificate by using the makecert.exe file. The certificate must contain the 1.3.6.1.5.5.7.3.3 (codesigning) and 1.3.6.1.4.1.311.61.4.1 (early-launch) EKUs. Afterwards, disable secure boot (if enabled) or enable Secure Boot debugging, and put your computer in test mode by using the bcdedit /set testsigning on command. Test mode means that the system validates the signature and verifies EKUs, but the system does not verify the certificate chain.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Troubleshooting Early Launch Antimalware Testing

To troubleshoot issues that occur with Early Launch Anti-Malware tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Related topics

Troubleshooting Windows HLK


File System Testing Prerequisites

This section describes the tasks that you must complete before you test an audio device by using the Windows Hardware Lab Kit (Windows HLK):

  • Review the hardware requirements.

  • Review the software requirements.

  • Configure the test computers.

Hardware requirements

The following hardware is required for File System testing.

  • One test computer running a supported operating system. This computer must include the following:

    • Windows keyboard

    • Two-button pointing device (this is optional if the test computer is a laptop with a touch pad or other input capability).

    • Color display monitor capable of at least 1024 by 768 resolution, 32-bits per pixel, 60 Hz

    • Persistent storage (typically a hard drive) with a minimum of 20 GB available.

    • A server running Windows 2008 R2 SP1 or later.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test your product, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the product that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required to run the File System tests:

  • The AV filter driver under test

    WARNING

    Make sure that you install the product on the test computer before you install the Windows HLK Client.

Test system configuration

To configure the test system, follow these steps:

  1. Determine the letter assignment for each volume:

    NTFS

    g:

    CNTFS

    i:

    Fat16

    k:

    Fat32

    l:

    ExFat

    m:

    UDF

    n:

  2. On the client computer, make sure that the following volumes are present:

    • NTFS 2gb

    • ntfs compressed 2gb

    • fat16 1gb

    • Fat32 1gb

    • Exfat 1gb

    • UDF 2gb

  3. In the controller, modify the parameters on the jobs in the $\WDK Tests\Storage\Filesystems section to point to test volumes, as follows:

    • TxF2: Modify ntfs and cntfs to point to test volumes.

    • ReparsePonts: Modify NTFS and CNTFS to point to test volumes

    • Installable Filesystems filter test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Antivirus Installable Filesystems filter test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • File IO test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Mapped File IO test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Object ID test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Oplocks test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

    • Syscache test: Modify ntfs, cntfs, fat, fat32, exfat, and udf to point to test volumes.

  4. On the server, create a share that you name RDRTest.

  5. Modify the parameters in the $\WDK Tests\Leasing\SMB_OplockRDR test to point to the server name and share name.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Troubleshooting File System Testing

To troubleshoot issues that occur with File System testing, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Related topics

Troubleshooting Windows HLK


Windows Filtering Platform (WFP) Drivers Testing Prerequisites

This topic describes the tasks that you must complete before you WFP drivers by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements.

  • Software requirements.

  • Test computer configuration.

Hardware requirements

The following hardware is required for network security software testing:

  • One test computer that meets the following requirements:

    • Meets the Windows HLK prerequisites. For more information, see Windows HLK Prerequisites.

    • Has at least one network interface card that is connected. Ideally, the network interface card is on a private network with the Controller's network interface.

    • Supports S1-S3 (Suspend) and S4 (Hibernate) power states.

    • Is not joined to a domain.

NOTE

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

NOTE

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)

Software requirements

The following software is required to run the SoftwareDevice.FilterDriver.WindowsFilteringPlatform tests:

  • Network security software to test which utilizes WFP Callouts.

    WARNING

    Make sure that you install the product on the test computer before you install the Windows HLK Client.

The testing process involves three tests. One test verifies basic firewall capabilities, one test verifies that app containers are not unnecessarily blocked, and the last test validates interoperability with Transition Technologies (currently targeted at Teredo). As part of the test process, the following fields are copied to the test computer. You must add appropriate values for these tests as described in the Test computer configuration section.

SoftwareDevice.FilterDriver.WindowsFilteringPlatform.WindowsFilteringPlatform_Tests

File name Origin or Removal Location Purpose

Callout.Sys

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32\Drivers</p>

This file is required for the callout functions that are used during the stream and injection tests.

DrInstall.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to install the Sparta Miniport Driver.

NTLog.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to log output for the test environment.

SpartaMini.Cat

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32\Drivers</p>

This file is required to install the Sparta Miniport Driver.

SpartaMini.Inf

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job

%WinDir%\System32\Drivers</p>

This file is required to install the Sparta Miniport Driver.

SpartaMini.Sys

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32\Drivers</p>

This file is required to install the Sparta Miniport Driver.

WFPLogo.Answer

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32</p>

This file is optional to partially automate the test process.

WFPLogo.Exe

Copied as part of the Network Security Software tests' "Basic Firewalls - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required for the tests to run.

WFPLogo.Info

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to determine how best to run the tests for the Windows Filtering Platform.

WFPLogo.NTLog

Created during test execution.

%WinDir%\System32</p>

This file is created at runtime to log whether each test passes or fails.

WFPLogo.Trace

Created during test execution.

%WinDir%\System32</p>

This file is created at runtime and is used to troubleshoot what WFP objects were added during the test run.

WFPLogoSetup.JS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Support "WFP - Remove Binaries" library job.

%WinDir%\System32</p>

This file is used to install and configure the Sparta Miniport.

SoftwareDevice.FilterDriver.WindowsFilteringPlatform.TransitionTechnologies_Tests

File name Origin or Removal Location Purpose

AutoSrv.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to run the tests that use the Sparta Miniport driver.

AutoSrvC.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to run the tests that use the Sparta Miniport driver.

DevCon.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

DrvInstall.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

InitAddress.VBS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required by Teredo_WLK.wsf to run the test scenarios.

InstallSpartaMini.Bat

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is used to install and uninstall the Sparta Miniport driver.

NetCapDrv6.Cat

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required by the Sparta Miniport driver to capture the network packets during the tests.

NetCapDrv6.Inf

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required by the Sparta Miniport driver to capture the network packets during the tests.

NetCapDrv6.Sys

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required by the Sparta Miniport driver to capture the network packets during the tests.

NetCapture.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required by the Sparta Miniport driver to capture the network packets during the tests.

NTLog.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to create output logs for the test environment.

SpartaCM.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

SpartaExtensions.MSI

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

SpartaMini.Cat

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

SpartaMini.Inf

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

SpartaMini.Sys

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to install the Sparta Miniport driver.

TestCore.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta</p>

This file is required to run the tests.

Common.VBS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta_Test\Common

This file is required by Teredo_WLK.wsf to run the test scenarios.

DNS.VBS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta_Test\DNS

This file is required by Teredo_WLK.wsf to run the test scenarios.

Teredo_WLK.WSF

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job

%SystemDrive%\Sparta_Test\Tunnel\Teredo</p>

This script file is used to run the transition technologies tests. This file is required by the job, " REQ - WFP-based products must support Teredo"

TeredoEmulator.VBS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta_Test\Tunnel\Teredo</p>

This file is required by Teredo_WLK.wsf to run the test scenarios.

TeredoPeer.VBS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta_Test\Tunnel\Teredo</p>

This file is required by Teredo_WLK.wsf to run the test scenarios.

Tunnel.VBS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.Scenarios.TransitionTechnologies.Support tests' "Transition Technologies - Remove Binaries" library job.

%SystemDrive%\Sparta_Test\Tunnel</p>

This file is required by Teredo_WLK.wsf to run the test scenarios.

Feature Requirements

The following table maps filter features and requirements.

Feature | Requirement
Applicable only for Firewalls | Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.FwpmFilters.MaintainOneTerminating Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.NetworkDiagnosticsFramework.HelperClass Filter.Driver.WindowsFilteringPlatform.Firewall.SupportMACAddressExceptions Filter.Driver.WindowsFilteringPlatform.Firewall.SupportMACFrameTypeExceptions Filter.Driver.WindowsFilteringPlatform.Firewall.Support5TupleExceptions.IPAddressExceptions Filter.Driver.WindowsFilteringPlatform.Firewall.Support5TupleExceptions.PortExceptions Filter.Driver.WindowsFilteringPlatform.Firewall.Support5TupleExceptions.ProtocolExceptions Filter.Driver.WindowsFilteringPlatform.Firewall.Support5TupleExceptions.ICMPExceptions Filter.Driver.WindowsFilteringPlatform.Firewall.SupportApplicationExceptions
Applicable only if doing packet injection | Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.PacketInjection.NoDeadlocks
Applicable only if doing stream injection | Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.StreamInjection.NoStreamStarvation
Applicable only if doing MAC layer filtering | Filter.Driver.WindowsFilteringPlatform.Scenario.SupportMobileBroadBand
Applicable only if doing filtering in the VSwitch | Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.InteropWithOtherExtensions Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.NoEgressModification Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.SupportLiveMigration Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.SupportRemoval Filter.Driver.WindowsFilteringPlatform.Scenario.vSwitch.SupportReordering

SoftwareDevice.FilterDriver.WindowsFilteringPlatform.AppContainers_Tests

File name

Origin or Removal

Location

Purpose

DrInstall.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to install the Sparta Miniport Driver.

NTLog.DLL

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to log output for the test environment.

SpartaMini.Cat

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32\Drivers</p>

This file is required to install the Sparta Miniport Driver.

SpartaMini.Inf

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32\Drivers</p>

This file is required to install the Sparta Miniport Driver.

SpartaMini.Sys

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32\Drivers</p>

This file is required to install the Sparta Miniport Driver.

HCK_NetISo_Tests.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to perform the tests.

SpartaEchoSvc.Exe

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to answer TCP/IP traffic generated by the test.

SpartaEchoSvcInstall.JS

Copied as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Copy Binaries" library job.

Removed as part of the SoftwareDevice.FilterDriver.WindowsFilteringPlatform.ArchitecturalDesign.AppContainers.Support "AppContainers - Remove Binaries" library job.

%WinDir%\System32</p>

This file is required to install the Sparta Echo Service.

Test computer configuration

To configure the test computer to test your WFP driver, follow these steps:

  1. Install the appropriate Windows operating system on the test computer, and then configure the computer for your test network (the network that contains the Windows HLK Studio and Windows HLK Controller.

  2. Install your WFP driver on the test computer.

  3. Install the Windows HLK client application on the test computer.

  4. Use Windows HLK Studio to create a computer pool, and then move the test computer to that pool.

IMPORTANT

You must set more configuration values for the individual WindowsFilteringPlatform tests before you can run the tests. See AppContainers_Tests and WindowsFilteringPlatform_Tests for more information.

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Some Windows HLK tests require user intervention. When running tests for a submission, it is a best practice to run the automated tests in a block separately from manual tests. This prevents a manual test from interrupting completion of an automated test.


Troubleshooting Windows Filtering Platform (WFP) Driver Testing

To troubleshoot issues that occur with Windows Filtering Platform (WFP) driver tests, follow these steps:

  1. Review Troubleshooting Windows HLK Test Failures.

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Related topics

Troubleshooting Windows HLK


System.Client

In this section

  • System.Client tests
  • System.Client additional documentation


System.Client tests

  • Accelerometer Dynamic Range Tests
  • Assessment - Boot Performance (Fast Startup)
  • Assessment - Boot Performance (Full Boot)
  • Assessment - Driver Verification
  • Assessment - Hibernate Performance
  • Assessment - Internet Explorer Security Software Impact
  • Assessment - Internet Explorer Startup Performance
  • Assessment - Memory Footprint
  • Assessment - Minifilter Diagnostic - Boot Performance (Fast Startup)
  • Assessment - Standby Performance
  • Assessment - Microsoft Store Apps Performance
  • Basic Capture Session - Photo Sink - Bitmap Bytestream
  • Basic Capture Session - Photo Sink - Bitmap Image
  • Basic Capture Session - Photo Sink - Bitmap Sample Callback
  • Basic Capture Session - Photo Sink - GIF Bytestream
  • Basic Capture Session - Photo Sink - GIF Image
  • Basic Capture Session - Photo Sink - GIF Sample Callback
  • Basic Capture Session - Photo Sink - JPEG Bytestream
  • Basic Capture Session - Photo Sink - JPEG Image
  • Basic Capture Session - Photo Sink - JPEG Sample Callback
  • Basic Capture Session - Photo Sink - TIFF Bytestream
  • Basic Capture Session - Photo Sink - TIFF Image
  • Basic Capture Session - Photo Sink - TIFF Sample Callback
  • Basic Capture Session - Preview Sink - I420 Sample Callback
  • Basic Capture Session - Preview Sink - NV12 Sample Callback
  • Basic Capture Session - Preview Sink - RBG32 HWND
  • Basic Capture Session - Preview Sink - RGB32 Sample Callback
  • Basic Capture Session - Preview Sink - YUY2 HWND
  • Basic Capture Session - Preview Sink - YUY2 Sample Callback
  • Basic Capture Session - Preview Sink - YV12 Sample Callback
  • Basic Capture Session - Record Sink - H264 Bytestream
  • Basic Capture Session - Record Sink - H264 Sample Callback
  • Basic Capture Session - Record Sink - H264 Video
  • Basic Capture Session - Record Sink - NV12 Bytestream
  • Basic Capture Session - Record Sink - NV12 Video
  • Basic Capture Session - Record Sink - WMV7 Bytestream
  • Basic Capture Session - Record Sink - WMV7 Sample Callback
  • Basic Capture Session - Record Sink - WMV7 Video
  • Basic Capture Session - Record Sink - WMV8 Sample Callback
  • Basic Capture Session - Record Sink - WMV8 Video
  • Basic Capture Session - Record Sink - WMV8 Video
  • Basic Capture Session - Record Sink - WMV9 Bytestream
  • Basic Capture Session - Record Sink - WMV9 SampleCallback
  • Basic Capture Session - Record Sink - WMV9 Video
  • Basic Capture Session - Record Sink - WVC1 Bytestream
  • Basic Capture Session - Record Sink - WVC1 Sample Callback
  • Basic Capture Session - Record Sink - WVC1 Video
  • Basic Capture Session - Record Sink - YUY2 Bytestream
  • Basic Capture Session - Record Sink - YUY2 Video
  • Bluetooth - 4LeSpecification (Development and Integration)
  • Bluetooth - 4LeSpecification (Reliability)
  • Bluetooth - ConnectedStandby1 (Bring Up)
  • Bluetooth - LE Supported States - Peripheral Role Support (Bring Up)
  • Bluetooth - LE Supported States - Scatternet Support (Bring Up)
  • Bluetooth - LEStateCombinations1 (Bring Up)
  • Bluetooth - LEWhiteList1 (Bring Up)
  • Bluetooth - NoBluetoothLEFilterDriver1 (Bring Up)
  • Bluetooth - NonUsbPerformance (Reliability)
  • Bluetooth - NonUsbScoSupport (Development and Integration)
  • Bluetooth - NonUsbUsesMicrosoftStack1 (Bring Up)
  • Bluetooth - OnOffStateControllableViaSoftware1 (Bring Up)
  • Bluetooth - OnOffStateControllableViaSoftware2 (Reliability)
  • Bluetooth - Optional - HciExtension1 (Bring Up)
  • Bluetooth - Optional - HciExtensions (Development and Integration)
  • Bluetooth - SimultaneousBrEdrAndLeTraffic (Development and Integration)
  • Bluetooth - SimultaneousBrEdrAndLeTraffic1 (Bring Up)
  • Bluetooth - SupportsBluetooth21AndEdr (Development and Integration)
  • Bluetooth - UsbScoDataTransportLayer (Development and Integration)
  • Brightness Test
  • Brightness2 Test
  • Camera Driver Basic Perf Color Latency Test
  • Camera Driver Controls System Test - ADVANCEDPHOTO - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - ADVANCEDPHOTO - Verify correct Pin
  • Camera Driver Controls System Test - ADVANCEDPHOTO - Verify Default setting
  • Camera Driver Controls System Test - ADVANCEDPHOTO - Verify defaults
  • Camera Driver Controls System Test - ADVANCEDPHOTO_AUTO - Verify Take Photo
  • Camera Driver Controls System Test - ADVANCEDPHOTO_AUTO - Verify Take Photo with record
  • Camera Driver Controls System Test - ADVANCEDPHOTO_FNF - Verify Take Photo
  • Camera Driver Controls System Test - ADVANCEDPHOTO_FNF - Verify Take Photo AUTO
  • Camera Driver Controls System Test - ADVANCEDPHOTO_FNF - Verify Take Photo with record
  • Camera Driver Controls System Test - ADVANCEDPHOTO_HDR - Verify Take Photo
  • Camera Driver Controls System Test - ADVANCEDPHOTO_HDR - Verify Take Photo AUTO
  • Camera Driver Controls System Test - ADVANCEDPHOTO_HDR - Verify Take Photo with record
  • Camera Driver Controls System Test - ADVANCEDPHOTO_ULTRALOWLIGHT - Verify Take Photo
  • Camera Driver Controls System Test - ADVANCEDPHOTO_ULTRALOWLIGHT - Verify Take Photo AUTO
  • Camera Driver Controls System Test - ADVANCEDPHOTO_ULTRALOWLIGHT - Verify Take Photo with Record
  • Camera Driver Controls System Test - CAMERA_PROFILES - Log all profiles
  • Camera Driver Controls System Test - CAMERA_PROFILES - Photo Sequence
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_BalancedVideoAndPhoto enum all
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, photo and preview
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, rec and preview
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto is supported, set first index
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto, enum all
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoConferencing enum all
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording enum all
  • Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording is supported, set first index
  • Camera Driver Controls System Test - CAMERAANGLEOFFSET - Check Default
  • Camera Driver Controls System Test - EVCOMPENSATION - Check Default
  • Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings
  • Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Previewing
  • Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - EXPOSUREMODE - Check Default
  • Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings
  • Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings while Previewing
  • Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Preview
  • Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - FACEDETECTION - Verify Default setting
  • Camera Driver Controls System Test - FIELDOFVIEW - Check Default
  • Camera Driver Controls System Test - FLASHMODE - Check Default
  • Camera Driver Controls System Test - FLASHMODE - Iterate through possible settings
  • Camera Driver Controls System Test - FLASHMODE TORCHMODE - scenario
  • Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Previewing
  • Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Previewing after start streaming for a few seconds
  • Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording after start streaming for a few seconds
  • Camera Driver Controls System Test - FOCUSPRIORITY - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - FOCUSPRIORITY - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - FOCUSSTATE - Verify Default setting - Record Video
  • Camera Driver Controls System Test - FOCUSSTATE - Verify Default setting - Take Photo
  • Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Preview
  • Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Recording
  • Camera Driver Controls System Test - HISTOGRAM - Verify correct Pin
  • Camera Driver Controls System Test - HISTOGRAM - Verify Default setting
  • Camera Driver Controls System Test - ISO - Check Default
  • Camera Driver Controls System Test - ISO - Iterate through possible settings
  • Camera Driver Controls System Test - OIS - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - OIS - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - OIS - Verify Default setting
  • Camera Driver Controls System Test - OPTIMIZATIONHINT - Check Default
  • Camera Driver Controls System Test - OPTIMIZATIONHINT - Iterate through possible settings
  • Camera Driver Controls System Test - Photo Frame Rate - check default rate
  • Camera Driver Controls System Test - Photo Max Frame Rate - Check default Frame Rate
  • Camera Driver Controls System Test - Photo Mode - verify mode change
  • Camera Driver Controls System Test - Photo Sequence - Asyncronously turn on and off PhotoSequence (return event)
  • Camera Driver Controls System Test - Photo Sequence - Asyncronously turn on burst mode (return event)
  • Camera Driver Controls System Test - Photo Sequence - Check Not supported on VIDEO_PREVIEW_Pin
  • Camera Driver Controls System Test - Photo Sequence - Check Not supported on Video_Record_Pin
  • Camera Driver Controls System Test - Photo Sequence - Max Past Frames
  • Camera Driver Controls System Test - Photo Sequence - One Past Frames
  • Camera Driver Controls System Test - Photo Sequence - Thumbnail
  • Camera Driver Controls System Test - Photo Sequence - Thumbnail All Thumbnail Size
  • Camera Driver Controls System Test - Photo Sequence - Zero Past Frames
  • Camera Driver Controls System Test - Photo Trigger Time - Check default phototriggertime
  • Camera Driver Controls System Test - PHOTOCONFIRMATION - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - PHOTOCONFIRMATION - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - PHOTOCONFIRMATION - Verify Default setting
  • Camera Driver Controls System Test - ROI - 3A Photo Capture
  • Camera Driver Controls System Test - ROI - Check Default
  • Camera Driver Controls System Test - ROI - Exposure
  • Camera Driver Controls System Test - ROI - Exposure and Whitebalance Photo Capture
  • Camera Driver Controls System Test - ROI - Exposure Photo Capture
  • Camera Driver Controls System Test - ROI - Exposure Valid Rects
  • Camera Driver Controls System Test - ROI - Focus
  • Camera Driver Controls System Test - ROI - Focus and Exposure Photo Capture
  • Camera Driver Controls System Test - ROI - Focus and Whitebalance Photo Capture
  • Camera Driver Controls System Test - ROI - Focus Photo Capture
  • Camera Driver Controls System Test - ROI - Focus Valid Rects
  • Camera Driver Controls System Test - ROI - Set Clear
  • Camera Driver Controls System Test - ROI - WhiteBalance
  • Camera Driver Controls System Test - ROI - Whitebalance Photo Capture
  • Camera Driver Controls System Test - ROI - WhiteBalance Valid Rects
  • Camera Driver Controls System Test - SCENEMODE - Get Default setting
  • Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings
  • Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - Torch Mode - Check Default
  • Camera Driver Controls System Test - Torch Mode - Iterate through possible settings
  • Camera Driver Controls System Test - VFR - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - VFR - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - VFR - Verify correct Pin
  • Camera Driver Controls System Test - VIDEOHDR - Set Video HDR auto using profiles
  • Camera Driver Controls System Test - VIDEOHDR - Verify correct Pin
  • Camera Driver Controls System Test - VIDEOHDR - Verify Default setting
  • Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn off Video HDR on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE
  • Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE
  • Camera Driver Controls System Test - VIDEOHDR - verify with profiles
  • Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Preview
  • Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify correct Pin
  • Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify Default setting
  • Camera Driver Controls System Test - VideoTemporalDenoising - Iterate through possible settings take Photo and Preview
  • Camera Driver Controls System Test - VideoTemporalDenoising - Iterate through possible settings while Recording and Preview
  • Camera Driver Controls System Test - VideoTemporalDenoising - Verify OFF capability is not the only one supported
  • Camera Driver Controls System Test - VideoTemporalDenoising - Verify OFF is supported if AUTO and ON capability are supported
  • Camera Driver Controls System Test - VideoTemporalDenoising - Verify OFF is supported if ON capability is supported
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Photo - Preview Video
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Photo - Record Video
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Photo - Take Photo
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Preview - Preview Video
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Preview - Record Video
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Preview - Take Photo
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Record - Preview Video
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Record - Record Video
  • Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Record - Take Photo
  • Camera Driver Controls System Test - WHITEBALANCEMODE - Check Default
  • Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings
  • Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Preview
  • Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Preview
  • Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Recording
  • Camera Driver Controls System Test - ZOOM - Verify Default setting
  • Camera Driver Controls Test - FLASHMODE - Manual validation of Camera flash
  • Camera Driver Performance Test - Measure Camera switching latency during video preview
  • Camera Driver Performance Test - Measure Camera switching latency during video recording
  • Camera Driver Performance Test - Measure media type switching latency on primary video preview stream
  • Camera Driver Performance Test - Measure media type switching latency on primary video record stream
  • Camera Driver Performance Test - Measure shot to shot latency of photo capture
  • Camera Driver Performance Test - Measure shot to shot latency of photo capture with flash
  • Camera Driver Performance Test - Measure time to begin previewing video
  • Camera Driver Performance Test - Measure time to begin recording video
  • Camera Driver Performance Test - Measure time to take first photo
  • Camera Driver Performance Test - Validate timestamps from primary video preview stream
  • Camera Driver Performance Test - Validate timestamps from primary video record stream
  • Camera Driver Performance Test - Validate video preview and video record stream timestamps
  • Camera Driver Performance Test - Validate video preview and video record timestamps at high resolution for photo
  • Camera Driver Performance Test - Validate video preview and video record timestamps at high resolution for photo and video record
  • Camera Driver Profiles Collect DevPKey Profiles
  • Camera Driver Profiles Collect OEM INF Profiles
  • Camera Driver Profiles Interface APIs
  • Camera Driver Profiles Validate Concurrency INF Parsing
  • Camera Driver Registration, Metadata, and Dependency System Test
  • Camera Driver Rotation Metadata System Test
  • Camera Driver System Test - MediaCapture - Camera intrinsics extension, frame
  • Camera Driver System Test - MediaCapture - Camera intrinsics extension, stream
  • Camera Driver System Test - MediaCapture - DMFT notification compatibility
  • Camera Driver System Test - MediaCapture - TestAll360StreamForSupportedMediaTypes
  • Camera Driver System Test - MediaCapture - TestCaptureStreamWithValidPreviewResolution
  • Camera Driver System Test - MediaCapture - TestCaptureWithAllSupportedMediaType
  • Camera Driver System Test - MediaCapture - TestCaptureWithAllSupportedMediaTypeWithPreview
  • Camera Driver System Test - MediaCapture - TestConcurrentRecordAndPhotoCapture
  • Camera Driver System Test - MediaCapture - TestConcurrentRecordAndPhotoSequenceCapture
  • Camera Driver System Test - MediaCapture - TestDualVideoDevicesInitialization
  • Camera Driver System Test - MediaCapture - TestEnumerateMediaEncodingProperties
  • Camera Driver System Test - MediaCapture - TestEnumerateMediaFrameSourceGroup
  • Camera Driver System Test - MediaCapture - TestEnumerateMediaFrameSourceGroupById
  • Camera Driver System Test - MediaCapture - TestEnumerateVideoDevices
  • Camera Driver System Test - MediaCapture - TestEnumerateVideoProfile
  • Camera Driver System Test - MediaCapture - TestExposureCompensationControl
  • Camera Driver System Test - MediaCapture - TestExposureCompensationControlUnsupported
  • Camera Driver System Test - MediaCapture - TestExposureControl
  • Camera Driver System Test - MediaCapture - TestExposureControlUnsupported
  • Camera Driver System Test - MediaCapture - TestExposureControlWithPhotoCapture
  • Camera Driver System Test - MediaCapture - TestFrameFlashControl
  • Camera Driver System Test - MediaCapture - TestFrameFlashControlWithValues
  • Camera Driver System Test - MediaCapture - TestFrameReader
  • Camera Driver System Test - MediaCapture - TestFrameReaderWithAllSupportedMediaFormats
  • Camera Driver System Test - MediaCapture - TestHLK5
  • Camera Driver System Test - MediaCapture - TestHLK6
  • Camera Driver System Test - MediaCapture - TestIsoSpeedControl
  • Camera Driver System Test - MediaCapture - TestLowLagPhotoCapture
  • Camera Driver System Test - MediaCapture - TestLowLagVideoCapture
  • Camera Driver System Test - MediaCapture - TestMediaCaptureScenarios
  • Camera Driver System Test - MediaCapture - TestMft0GetService
  • Camera Driver System Test - MediaCapture - TestMultiFrameReader
  • Camera Driver System Test - MediaCapture - TestPastPhotoLimit
  • Camera Driver System Test - MediaCapture - TestPhotoCapture
  • Camera Driver System Test - MediaCapture - TestPhotoSequenceCapture
  • Camera Driver System Test - MediaCapture - TestPreview
  • Camera Driver System Test - MediaCapture - TestValidateVariablePhotoSequenceFrameMetadata
  • Camera Driver System Test - MediaCapture - TestVariablePhotoSequenceCapture
  • Camera Driver System Test - MediaCapture - TestVideoCapture
  • Camera Driver System Test - MediaCapture - TestVideoCapture with highest available resolution
  • Camera Driver System Test - MediaCapture - TestVideoProfileWithValidPreviewResolution
  • Camera Driver System Test - MediaCapture - TestVPSMaxFrameCount
  • Camera Driver System Test - MediaCapture - TestWindowsHelloDeviceRequirement
  • Camera Driver System Test - MediaCapture - ValidateAdvanceIsoSpeedControlValues
  • Camera Driver System Test - MediaCapture - ValidateCameraBasicSettings
  • Camera Driver System Test - MediaCapture - ValidateCameraBasicSettingsError
  • Camera Driver System Test - MediaCapture - ValidateExposureCompensationValues
  • Camera Driver System Test - MediaCapture - ValidateFlashControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateFocusControlFocusSettings
  • Camera Driver System Test - MediaCapture - ValidateFocusControlSupportedPresets
  • Camera Driver System Test - MediaCapture - ValidateFocusControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateFocusControlUnsupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateFrameExposureCapabilities
  • Camera Driver System Test - MediaCapture - ValidateFrameExposureCompensationCapabilities
  • Camera Driver System Test - MediaCapture - ValidateFrameExposureCompensationValues
  • Camera Driver System Test - MediaCapture - ValidateFrameExposureControlValues
  • Camera Driver System Test - MediaCapture - ValidateFrameFocusCapabilities
  • Camera Driver System Test - MediaCapture - ValidateFrameFocusValues
  • Camera Driver System Test - MediaCapture - ValidateFrameIsoSpeedCapabilities
  • Camera Driver System Test - MediaCapture - ValidateFrameIsoSpeedValues
  • Camera Driver System Test - MediaCapture - ValidateFramePhotoConfirmationCapabilities
  • Camera Driver System Test - MediaCapture - ValidateIsoSpeedControlPresets
  • Camera Driver System Test - MediaCapture - ValidateIsoSpeedControlUnsupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateManualFocusValues
  • Camera Driver System Test - MediaCapture - ValidatePowerlineFrequency
  • Camera Driver System Test - MediaCapture - ValidatePrimaryUseControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateROIControlIllegalBounds
  • Camera Driver System Test - MediaCapture - ValidateROIControlLegalBounds
  • Camera Driver System Test - MediaCapture - ValidateROIControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateSceneModeControlPresets
  • Camera Driver System Test - MediaCapture - ValidateSceneModeControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateSceneModeControlUnsupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateTorchControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateTorchControlUnsupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateWhiteBalanceControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateWhiteBalanceControlUnsupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateWhiteBalanceControlValues
  • Camera Driver System Test - MediaCapture - ValidateZoomControlSupportedScenarios
  • Camera Driver System Test - MediaCapture - ValidateZoomDuringVideo
  • Camera Driver System Test - Profile Mix Mode Validation
  • Camera Driver System Test - Profile Validation
  • Camera Driver Test - MultiCamera MultiStream (Scenario) - Preview (Sample Grabber), Capture JPEG Photo
  • Camera Driver Test - MultiCamera MultiStream (Scenario) - Preview, Capture JPEG Photo
  • Camera Driver Test - MultiCamera Preview (Sample Grabber), Capture JPEG image from each image Stream type
  • Camera Driver Test - MultiCamera Preview (Sample Grabber), Record H.264 Video and AAC Audio
  • Camera Driver Test - MultiCamera Preview (Sample Grabber), Record H.264 Video and AAC Audio from each Capture Stream type
  • Camera Driver Test - MultiCamera Preview, Capture JPEG image from each image Stream type
  • Camera Driver Test - MultiCamera Preview, Record H.264 Video and AAC Audio
  • Camera Driver Test - MultiCamera Preview, Record H.264 Video and AAC Audio from each Capture Stream type
  • Camera Driver Test - MultiCamera Video Preview (Sample Callback) - Stream video from all available format on the preview stream and dynamic format switching
  • Camera Driver Test - MultiCamera Video Preview (Sample Callback) - Stream video from each available format from the camera's preview stream
  • Camera Driver Test - MultiCamera Video Preview (Sample Callback) - Stream video from the default format on Camera preview stream
  • Camera Driver Test - MultiCamera Video Preview (View Finder) - Stream video from all available format on the preview stream and dynamic format switching
  • Camera Driver Test - MultiCamera Video Preview (View Finder) - Stream video from each available format from the camera's preview stream
  • Camera Driver Test - MultiCamera Video Preview (View Finder) - Stream video from the default format on Camera preview stream
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture Bitmap Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture JPEG Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture JPEGXR Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture Bitmap Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture JPEG Photo
  • Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture JPEGXR Photo
  • Camera Driver Test - Preview (Sample Grabber), Record H.264 Video and AAC Audio
  • Camera Driver Test - Preview (Sample Grabber), Record H.264 Video and AAC Audio from each Capture Stream type
  • Camera Driver Test - Preview, Record H.264 Video and AAC Audio
  • Camera Driver Test - Preview, Record H.264 Video and AAC Audio from each Capture Stream type
  • Camera Driver Test - UVC Test 4
  • Camera Driver Test - UVC Test 5
  • Camera Driver Test - UVC Test 6
  • Camera Driver Usage Indicator Manual Test
  • Camera Sensor Quality Test - Evaluate Color Accuracy at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Color Accuracy at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Color Accuracy at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Color Accuracy at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Color Accuracy at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Color Accuracy at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate Gamma at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Gamma at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Gamma at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Gamma at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Gamma at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Gamma at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate Glitch Free video at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Glitch Free video at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Glitch Free video at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Glitch Free video at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Glitch Free video at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Glitch Free video at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate luminance at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate luminance at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate luminance at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate luminance at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate luminance at 640x480 Lux20
  • Camera Sensor Quality Test - Evaluate luminance at 640x480 Lux80
  • Camera Sensor Quality Test - Evaluate Spatial Resolution at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Spatial Resolution at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate Spatial SNR at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Spatial SNR at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Spatial SNR at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Spatial SNR at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Spatial SNR at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Spatial SNR at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate Temporal SNR at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Temporal SNR at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Temporal SNR at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Temporal SNR at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Temporal SNR at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Temporal SNR at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate Vertical Field of View at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate Vertical Field of View at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x480 and 80 lux
  • Camera Sensor Quality Test - Evaluate video frame rate at 1280x720 and 20 lux
  • Camera Sensor Quality Test - Evaluate video frame rate at 1280x720 and 80 lux
  • Camera Sensor Quality Test - Evaluate video frame rate at 640x360 and 20 lux
  • Camera Sensor Quality Test - Evaluate video frame rate at 640x360 and 80 lux
  • Camera Sensor Quality Test - Evaluate video frame rate at 640x480 and 20 lux
  • Camera Sensor Quality Test - Evaluate video frame rate at 640x480 and 80 lux
  • Camera Windows Hello Face Auth Profile Validation
  • Camera validation for DShow Bridge enablement
  • Clock Interrupt Test
  • Crashdump through Capsules, Firmware Support Test
  • DX10 Graphics Enforcement Test (System)
  • Glitchfree HD Video Playback on AC ( Manual on mobile systems )
  • Glitchfree HD Video Playback on Battery (DC) Power Source ( Manual on mobile systems )
  • Glitchfree Low-period Audio Capture test
  • Glitchfree Low-period Audio Capture test under stress
  • Glitchfree Low-period Audio Playback test
  • Glitchfree Low-period Audio Playback test under stress
  • Glitchfree Low-period Full-duplex Audio Playback & Capture test
  • Glitchfree Low-period Full-duplex Audio Playback & Capture test under stress
  • Gyrometer Dynamic Range Tests
  • KeDelayExecutionThread Test
  • Lamp Driver Color Intensity Test
  • Lamp Driver Enumeration Test
  • Lamp Driver On Off Test
  • Lamp Driver PnP Notification Test
  • Light Sensor Dynamic Range Tests
  • MR Validation Kit Uploader
  • Magnetometer Dynamic Range Tests
  • Manual Test - Boot to desktop with debugger connection KDCOM-Serial
  • Manual Test - Boot to desktop with no debugger connection
  • Manual Test - Crash Dump Creation
  • Manual Test - Device must have a unique flashing ID in ffutool -list
  • Manual Test - Device must have a unique flashing ID in ffutool -list - (WoW64 for ARM64)
  • Manual Test - Display turns on
  • Manual Test - Firmware flashing using eMMC SW download tool
  • Manual Test - IPoverUSB
  • Manual Test - IPoverUSB - (WoW64 for ARM64)
  • Manual Test - Keyboard works in UEFI
  • Manual Test - LAN Connectivity
  • Manual Test - Power ON Power OFF Shutdown Reboot
  • Manual Test - Remote User mode Debugging - Native
  • Manual Test - SOC Drivers Hal Extensions and Subsystem image loading
  • Manual Test - Test USB Keyboard and Mouse Functionality
  • Manual Test - The device can run on a fully charged battery power for at least 30 min
  • Manual Test - The device can run on a fully charged battery power for at least 30 min - (WoW64 for ARM64)
  • Manual Test - Tshell over KDNET
  • Manual Test - Tshell over KDNET - (WoW64 for ARM64)
  • Manual Test - User mode debugging
  • Manual Test - User mode debugging - (WoW64 for ARM64)
  • Manual Test - Verify Full OS Installation by Booting from USB Disk
  • Manual Test - Verify basic UEFI shell functionality
  • Manual Test - Verify basic UEFI shell functionality - (WoW64 for ARM64)
  • Manual Test - Verify data in single ATT sim configuration
  • Manual Test - Verify data in single ATT sim configuration - (WoW64 for ARM64)
  • Manual Test - Verify device boots to home screen with KDNet over USB
  • Manual Test - Verify device boots to home screen with KDNet over USB - (WoW64 for ARM64)
  • Manual Test - Verify device boots to home screen with KDUSB connection
  • Manual Test - Verify device boots to home screen with KDUSB connection - (WoW64 for ARM64)
  • Manual Test - Verify device is able to boot to home screen with no debugger connection
  • Manual Test - Verify device is able to boot to home screen with no debugger connection - (WoW64 for ARM64)
  • Manual Test - Verify eMMC is enumerated in mass storage mode
  • Manual Test - Verify eMMC is enumerated in mass storage mode
  • Manual Test - Verify eMMC is enumerated in mass storage mode - (WoW64 for ARM64)
  • Manual Test - Verify FFU image flashing using FFUTool
  • Manual Test - Verify FFU image flashing using FFUTool - (WoW64 for ARM64)
  • Manual Test - Verify graceful shutdown functionality
  • Manual Test - Verify graceful shutdown functionality - (WoW64 for ARM64)
  • Manual Test - Verify MO phone call in single ATT sim configuration
  • Manual Test - Verify MO phone call in single ATT sim configuration - (WoW64 for ARM64)
  • Manual Test - Verify MT phone call in single ATT sim configuration
  • Manual Test - Verify MT phone call in single ATT sim configuration - (WoW64 for ARM64)
  • Manual Test - Verify online Crashdump functionality
  • Manual Test - Verify online Crashdump functionality - (WoW64 for ARM64)
  • Manual Test - Verify OS Battery Charging
  • Manual Test - Verify OS Battery Charging - (WoW64 for ARM64)
  • Manual Test - Verify power on and power off
  • Manual Test - Verify power on and power off - (WoW64 for ARM64)
  • Manual Test - Verify SBL based offline Crashdump functionality triggered by long power button press
  • Manual Test - Verify SBL based offline Crashdump functionality triggered by long power button press - (WoW64 for ARM64)
  • Manual Test - Verify touch functionality
  • Manual Test - Verify touch functionality - (WoW64 for ARM64)
  • Manual Test - Verify UEFI battery charging
  • Manual Test - Verify UEFI battery charging - (WoW64 for ARM64)
  • Manual Test - Verify WLAN connectivity
  • Manual Test - Verify WLAN connectivity - (WoW64 for ARM64)
  • Manual Test - WLAN Connectivity
  • PenBufferingTest
  • PenContactAccuracyTest
  • PenCustomGesturesTest
  • PenDownLatencyTest
  • PenEdgeGutterTest
  • PenEraserTest
  • PenGhostReportingTest
  • PenHoverAccuracyTest
  • PenHoverRangeTest
  • PenHoverStationaryJitterTest
  • PenMoveLatencyTest
  • PenMovingJitterTest
  • PenPhysicalDimensionsTest
  • PenPressureLevelsTest
  • PenPressureMotionTest
  • PenResolutionTest
  • PenStationaryJitterTest
  • PenThirdPartyDriverTest
  • Profile Interrupt Test
  • QPC Validation Test
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Log all profiles
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Photo Sequence
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_BalancedVideoAndPhoto enum all
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, photo and preview
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, rec and preview
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto is supported, set first index
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto, enum all
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoConferencing enum all
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording enum all
  • Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording is supported, set first index
  • Sensor Camera Driver Controls System Test - CAMERAANGLEOFFSET - Check Default
  • Sensor Camera Driver Controls System Test - EVCOMPENSATION - Check Default
  • Sensor Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Previewing
  • Sensor Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - EXPOSUREMODE - Check Default
  • Sensor Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Default
  • Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Default for Preview
  • Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Enable
  • Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Enable for Preview
  • Sensor Camera Driver Controls System Test - Face Authentication - Background Subtraction Default for Preview
  • Sensor Camera Driver Controls System Test - Face Authentication - Background Subtraction Enable
  • Sensor Camera Driver Controls System Test - Face Authentication - Background Subtraction Enable for Preview
  • Sensor Camera Driver Controls System Test - Face Authentication - Invalid - Alt Frame Illum and Background Subtraction
  • Sensor Camera Driver Controls System Test - Face Authentication - Invalid - Alt Frame Illum and Background Subtraction for Preview
  • Sensor Camera Driver Controls System Test - Face Authentication Default
  • Sensor Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Preview
  • Sensor Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - FACEDETECTION - Verify Default setting
  • Sensor Camera Driver Controls System Test - FIELDOFVIEW - Check Default
  • Sensor Camera Driver Controls System Test - FLASHMODE - Check Default
  • Sensor Camera Driver Controls System Test - FLASHMODE TORCHMODE - scenario
  • Sensor Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Previewing
  • Sensor Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording after start streaming for a few seconds
  • Sensor Camera Driver Controls System Test - FOCUSPRIORITY - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - FOCUSPRIORITY - Verify correct Pin
  • Sensor Camera Driver Controls System Test - FOCUSSTATE - Verify Default setting - Record Video
  • Sensor Camera Driver Controls System Test - Face Authentication Default for Preview
  • Sensor Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Preview
  • Sensor Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Recording
  • Sensor Camera Driver Controls System Test - HISTOGRAM - Verify correct Pin
  • Sensor Camera Driver Controls System Test - HISTOGRAM - Verify Default setting
  • Sensor Camera Driver Controls System Test - ISO - Check Default
  • Sensor Camera Driver Controls System Test - OIS - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - OIS - Verify Default setting
  • Sensor Camera Driver Controls System Test - OPTIMIZATIONHINT - Check Default
  • Sensor Camera Driver Controls System Test - ROI - 3A Preview
  • Sensor Camera Driver Controls System Test - ROI - Check Default
  • Sensor Camera Driver Controls System Test - ROI - Exposure
  • Sensor Camera Driver Controls System Test - ROI - Exposure and Whitebalance Preview
  • Sensor Camera Driver Controls System Test - ROI - Exposure Preview
  • Sensor Camera Driver Controls System Test - ROI - Exposure Valid Rects
  • Sensor Camera Driver Controls System Test - ROI - Focus
  • Sensor Camera Driver Controls System Test - ROI - Focus and Exposure Preview
  • Sensor Camera Driver Controls System Test - ROI - Focus and Whitebalance Preview
  • Sensor Camera Driver Controls System Test - ROI - Focus Valid Rects
  • Sensor Camera Driver Controls System Test - ROI - Focus with preview
  • Sensor Camera Driver Controls System Test - ROI - Set Clear
  • Sensor Camera Driver Controls System Test - ROI - WhiteBalance
  • Sensor Camera Driver Controls System Test - ROI - Whitebalance Preview
  • Sensor Camera Driver Controls System Test - ROI - WhiteBalance Valid Rects
  • Sensor Camera Driver Controls System Test - SCENEMODE - Get Default setting
  • Sensor Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - Secure Mode - Verify correct Pin
  • Sensor Camera Driver Controls System Test - Secure Mode Default
  • Sensor Camera Driver Controls System Test - Secure Mode Secure Streaming
  • Sensor Camera Driver Controls System Test - Torch Mode - Check Default
  • Sensor Camera Driver Controls System Test - Torch Mode - Iterate through possible settings
  • Sensor Camera Driver Controls System Test - VFR - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - VFR - Verify correct Pin
  • Sensor Camera Driver Controls System Test - VIDEOHDR - Set Video HDR auto using profiles
  • Sensor Camera Driver Controls System Test - VIDEOHDR - Verify correct Pin
  • Sensor Camera Driver Controls System Test - VIDEOHDR - Verify Default setting
  • Sensor Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn off Video HDR on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE
  • Sensor Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE
  • Sensor Camera Driver Controls System Test - VIDEOHDR - verify with profiles
  • Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Preview
  • Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify correct Pin
  • Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify Default setting
  • Sensor Camera Driver Controls System Test - WHITEBALANCEMODE - Check Default
  • Sensor Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Preview
  • Sensor Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Preview
  • Sensor Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Recording
  • Sensor Camera Driver Controls System Test - ZOOM - Verify Default setting
  • Single Computer Display Object test
  • System - Partition Validation
  • System Transcode Faster Than Real Time on AC Power Source ( Manual on mobile devices )
  • System Transcode Faster Than Real Time on Battery (DC) Power Source ( Manual on mobile devices )
  • Test.Aliasing
  • Test.AllAreas
  • Test.AudioTouch
  • Test.Buffering
  • Test.Confidence
  • Test.ConvergeDivergeDiagonal
  • Test.DeviceButton
  • Test.DeviceClickPressure
  • Test.DeviceHeight
  • Test.DeviceType
  • Test.DeviceWidth
  • Test.ExternalButtons
  • Test.GhostReporting
  • Test.InputResolution
  • Test.LinearityDiagonal
  • Test.LinearityDiagonalMultiple
  • Test.MinMaxContacts
  • Test.PositionalAccuracy
  • Test.PositionalAccuracyManual
  • Test.PowerStateReliability
  • Test.Pressure
  • Test.PTPHQA
  • Test.ReportRate
  • Test.ReportRateMultiple
  • Test.RightClickReliability
  • Test.SelectiveReporting
  • Test.StaticValidation
  • Test.StationaryJitter
  • Test.StationaryJitterMultiple
  • Test.StepMotor
  • Test.ZHeight
  • UEFI GOP mode test
  • Verify Device Driver Is WDDM
  • Verify Graphics Device Count is one
  • Verify Post Device Supports Display And Render
  • WDDM CCD Test for verifying only one internal target active on GPU
  • Win6_4.MB.System.Data.TestClassDriver
  • Win6_4.MB.System.Data.TestConnect
  • Windows Client System Check For WDDM 1.1 Or Greater Display Driver Support
  • Windows Client System Check For WDDM 1.2 Display Driver Support
  • Windows Client System Check For WDDM 1.3 Display Driver Support
  • Windows Hid Validation Test (System)
  • Windows System Check For WDDM
  • Windows Touch Buffering Test (System)
  • Windows Touch Digitizer Jitter Test - Five Contacts (System)
  • Windows Touch Digitizer Jitter Test - One Contact (System)
  • Windows Touch Five Point Minimum Test (System)
  • Windows Touch Input Separation Test (System)
  • Windows Touch Noise Suppression Test (System)
  • Windows Touch Physical Input Position Test (System)
  • Windows Touch Reporting Rate Test - Five Contacts (System)
  • Windows Touch Reporting Rate Test - Maximum Contacts (System)
  • Windows Touch Reporting Rate Test - One Contact (System)
  • Windows Touch Resolution Test (System)
  • Windows Touch Response Latency (Down) Test (System)
  • Windows Touch Response Latency (Panning) Test (System)
  • Windows Touch Test (System)
  • Windows Touch Ux Test (System)
  • Wlan Test - Attempt a connection to a non-existent network
  • Wlan Test - Attempt a connection to a non-existent network - (WoW64 for ARM64)
  • Wlan Test - Check Hosted Network Capable
  • Wlan Test - Check Hosted Network Capable - (WoW64 for ARM64)
  • Wlan Test - Connect to a WPA2 PSK AES AP
  • Wlan Test - Connect to a WPA2 PSK AES AP - (WoW64 for ARM64)
  • Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle
  • Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle - (WoW64 for ARM64)
  • Wlan Test - Enable and Disable WFD Autonomous GO
  • Wlan Test - Enable and Disable WFD Autonomous GO - (WoW64 for ARM64)
  • Wlan Test - MAC Randomization test
  • Wlan Test - MAC Randomization test - (WoW64 for ARM64)
  • Wlan Test - Query All Reported Oids
  • Wlan Test - Query All Reported Oids - (WoW64 for ARM64)
  • Wlan Test - Query Interface Properties
  • Wlan Test - Query Interface Properties - (WoW64 for ARM64)
  • Wlan Test - Scan for Networks
  • Wlan Test - Scan for Networks - (WoW64 for ARM64)
  • Wlan Test - Toggle airplane mode
  • Wlan Test - Toggle airplane mode - (WoW64 for ARM64)
  • Wlan Test - Wlan Device Capabilities Check
  • Wlan Test - Wlan Device Capabilities Check - (WoW64 for ARM64)
  • Wlan Test - Wlan Device enumeration
  • Wlan Test - Wlan Device enumeration - (WoW64 for ARM64)
  • Wlan Test - Wlan Device Reset Check
  • Wlan Test - Wlan Device Reset Check - (WoW64 for ARM64)
  • WNGlitchfree HD Video Playback on AC ( Manual on mobile systems )
  • WNGlitchfree HD Video Playback on DC ( Manual on mobile systems )


Accelerometer Dynamic Range Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9840c16c-817e-4445-a2b0-901c2ada874d

Verifies that the dynamic range for Accelerometer data fields are withing range

Test details
Specifications
  • System.Client.Sensor.Accelerometer.DynamicRange
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


Assessment - Boot Performance (Fast Startup)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1408edb-a6f1-4f70-893f-0dddb24da463

Measures boot and shutdown times when using Fast Startup, and identifies components that might cause delays.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | true
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Boot Performance (Full Boot)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/74f3b6b4-0134-48b0-9832-26b45b088ffd

Measures the overall duration of full boot and shutdown.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | true
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Driver Verification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61f1b4af-c574-42a9-b631-6943c7e80185

Identifies issues with devices and drivers.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Hibernate Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8eda5941-6b2b-4206-9b7f-211be07762bb

Measures time to hibernate/resume, and identifies components that might cause delays.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Benchmark
Timeout (in minutes) | 150
Requires reboot | true
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Internet Explorer Security Software Impact

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5a6e5d48-6f6b-43f8-8f2e-fe02f6c2606e

The Internext Explorer Security Software impact assessment measures the primary performance attributes of Internet Explorer that are typically impacted by antimalware and other browser add-ins

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
Expected run time (in minutes) | 60
Category | Benchmark
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Internet Explorer Startup Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/db3cc4b3-b7fa-4cd4-aa0e-b5f8a7c9aab1

Measures the time to launch the Internet Explorer process, when the Internet Explorer process has already been loaded into memory. The process is loaded into memory to minimize storage I/O interference. The results help you understand the impact of third-party add-ins, such as toolbars and extensions.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 50
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Memory Footprint

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/250551bc-9688-4a01-8eed-ac0127cb9045

Measures overall system memory usage, focusing on driver allocations and dynamic allocations.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Benchmark
Timeout (in minutes) | 300
Requires reboot | true
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Minifilter Diagnostic - Boot Performance (Fast Startup)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0430cdc-d155-421b-9c0d-88472ae18d1e

Identifies performance issues with minifilter drivers during system boot.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
Expected run time (in minutes) | 120
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | true
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Standby Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/77768493-5d55-43d9-92f7-aa9a8da3a1c3

Measures time to standby/resume and identifies components that might cause delays.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Benchmark
Timeout (in minutes) | 150
Requires reboot | true
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Assessment - Microsoft Store Apps Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b6d9c6b-8c5b-4b14-b1a4-2e8d767185a5

Measures the launch time, suspend time and resource utilization of Microsoft Store apps.

Test details
Specifications
  • System.Client.CPU.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Benchmark
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Basic Capture Session - Photo Sink - Bitmap Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83491f1b-b043-4eb3-a330-1ca693beda2d

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - Bitmap Image

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90da47a3-b6bc-4133-83c4-48da5fd4a9d7

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - Bitmap Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c6a3ba9-fd0b-4b08-920e-e9af62691f6f

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - GIF Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4b787c55-6223-417a-8f8c-179397db683c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - GIF Image

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc7c949a-91f7-401f-9bf7-edc736f4a9c8

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - GIF Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8eeaa140-e0a2-419e-aff7-7dc8fe5f4522

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - JPEG Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f81e1e4-1068-4fa5-9ef4-051427b0b758

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - JPEG Image

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7086909e-c9f7-4f88-9109-cdae2a5367f3

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - JPEG Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5e76025-2776-4006-b52c-cc2ad0e6355b

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - TIFF Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a9e3bc8-94e8-4dc3-b494-0e2dc4032a11

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - TIFF Image

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/851f0138-2ae2-42d4-814f-d06b78bb3adc

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Photo Sink - TIFF Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa552ec8-e846-4998-aad3-cd97c9e53296

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - I420 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a35bd69-abb8-4fec-b6c7-5a7e3de64c57

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - NV12 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c8b753e-656b-469e-b9b6-73ec962c5771

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - RBG32 HWND

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cc83d49-f426-411e-81c7-c67f6e653761

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - RGB32 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2aec42a4-a975-4393-b77e-2bb8000e7900

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - YUY2 HWND

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d24baa5c-c8ab-4293-98d9-fe02ddc5525a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - YUY2 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc593234-c629-43b5-95dc-e43692cf3ee4

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Preview Sink - YV12 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81421a95-a494-4dcd-99cc-14cb51a436de

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - H264 Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2034d6bf-4775-4f9e-873b-584857498f21

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - H264 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7ac4450-3212-48c9-9e14-e99fc51fa68c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - H264 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0385cfa-acb1-4df6-812c-9c61b2ce9dca

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - NV12 Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ff1bb37-4ca8-4f03-8495-a0c16d13ad6a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - NV12 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/754d7664-3b6f-4627-9069-372f25a76944

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV7 Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e2de1802-67a5-48fd-9360-07cade48e1da

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV7 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79c578cd-f1b7-4ffe-913d-f4c002dfff67

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV7 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b637abcc-0172-4854-a2cd-f9068f55c4a9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV8 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5da91bdd-eb9c-4f98-95bf-e15fa03c0f86

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV8 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5e445e5-349b-4adc-960d-65fa0b7ab9f8

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV8 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d94548db-a1a1-4fde-a378-51461775afe0

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV9 Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2cceab0-edcc-403d-8e6b-6e0d2c711973

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV9 SampleCallback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad5160fb-ea05-4e9a-980e-302e9f827cdf

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WMV9 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97c2bed8-7b13-47fd-9229-3387d22dc7be

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WVC1 Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc01d999-6d64-4356-ad76-baee41c18b48

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WVC1 Sample Callback

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c6b1d35f-0af7-4987-b280-df4aa099d11b

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - WVC1 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/986cfb16-a75a-4bc4-b8d9-ddfa78554c46

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - YUY2 Bytestream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae4bcb66-8144-433e-9644-25528261af52

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Basic Capture Session - Record Sink - YUY2 Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d67eef84-6193-4848-a6e2-e66a14e10960

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Bluetooth - ConnectedStandby1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1113fc6f-0cdf-4a80-8fd6-300a1f14e908

Validates the presence of the Microsoft Windows Bluetooth stack for AOAC enabled systems.

Test details
Specifications
  • System.Client.BluetoothController.Base.CS
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Bluetooth - NonUsbUsesMicrosoftStack1 (Bring Up)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c3de351-87f1-44b3-bf15-a0de2ca1bfa2

Validates the presence of the Microsoft Windows Bluetooth stack for non USB Bluetooth controllers.

Test details
Specifications
  • System.Client.BluetoothController.NonUSB.NonUsbUsesMicrosoftsStack
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Brightness Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb3cc9d2-e8bf-4c51-b5a1-cd1d60a65689

This automated test verifies that a system's brightness control keys use standard Advanced Configuration and Power Interface (ACPI) events and methods.

Test details
Specifications
  • System.Client.BrightnessControls.BrightnessControlButtons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
MONITOR | Index of display output to target with test
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Camera Driver Basic Perf Color Latency Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08dc36ff-cc49-42ac-a4a3-34f222d83f73

This test verifies that the camera latency meets the recommended levels

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a17cd6c3-2f72-49c5-b59c-6358033e67a8

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9709f7c4-25cb-476c-9efe-35a7228934ac

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d4038c3-9ba9-4362-b471-4a1ccfbe2c8a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO - Verify defaults

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73d05b0b-3c9e-4ef7-95b6-749c97bb1dc2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_AUTO - Verify Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/837e8fa1-2890-4f70-ba04-4ec9ca923ece

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_AUTO - Verify Take Photo with record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8d7a590e-d169-465a-b3fe-93221ec32b19

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_FNF - Verify Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c421468b-851c-406e-9bc3-93bf7d89236f

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_FNF - Verify Take Photo AUTO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ea67118-0b4f-4dfa-8742-de1fedb12e6a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_FNF - Verify Take Photo with record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/add78bb2-238b-4c2e-9e6f-a1a36643a408

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_HDR - Verify Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3aaa73fd-98fa-4b36-be9e-1adc57757fe2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_HDR - Verify Take Photo AUTO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be84130c-4fa5-4070-9e87-83d451ef4e04

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_HDR - Verify Take Photo with record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cc09ac9-c438-4133-9eaf-c950c04753d5

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_ULTRALOWLIGHT - Verify Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0bbd51b-94f8-44ba-88a0-66c64411be48

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_ULTRALOWLIGHT - Verify Take Photo AUTO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5eccdfd7-7e48-4c9b-9edd-71fcd8964f0e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ADVANCEDPHOTO_ULTRALOWLIGHT - Verify Take Photo with Record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb8dd7ac-b21e-4099-ba98-705492576dfa

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Log all profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4a8497c7-2fad-4cdd-8d70-445a40d85aa2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Photo Sequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10b647cf-3239-4006-ad55-254504653ab4

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_BalancedVideoAndPhoto enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cec85384-0c6b-4d4e-aee4-bf49d8467910

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36214133-7de3-4fbf-b6a5-7e91dcc0372e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, photo and preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e87ca9e-ab1e-4072-8d60-6e8cb2765474

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, rec and preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e6c160c5-a59b-43ad-b05c-56fa8e01b3dc

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto is supported, set first index

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73f2ddb5-70a3-41e2-a9ed-ee6586ef04cc

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto, enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/72a21ab5-a93b-4caa-98db-7aeb97987bd0

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoConferencing enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ede4aaf9-7218-4e64-8348-cf1eb7c3006c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/651cd315-fbff-45da-8e56-766b34b483f1

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording is supported, set first index

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cbdc5f61-8e69-4c77-a404-a5272aa6cd63

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - CAMERAANGLEOFFSET - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fa8224d9-d14c-4f3b-81c4-025765dbc902

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EVCOMPENSATION - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/913f1278-5514-4092-9014-7e6ebc6efdce

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24b6f37f-88b5-480c-b0da-1f3e458727cc

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Previewing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24d1197f-5bf3-4177-b6f9-3d1d38e21f60

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/734d6e37-f8e4-4b92-921c-d310097b8542

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EXPOSUREMODE - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3165abe1-276f-42a2-ba63-3fa09863b2ea

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd30c0bb-0608-4b8d-b1ca-5dbb43201365

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings while Previewing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b8e6765-cdff-42f4-b816-61531a285fe9

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/afebb528-b079-41a5-9164-88480a7975bc

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f444590-f26e-4392-8e74-b5afdbfc42f2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e1161c35-7761-438e-8684-559efec9e73b

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FACEDETECTION - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/057ab4db-e5f4-4ada-bf58-ddf259fe7303

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FIELDOFVIEW - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd3d05d0-8fc9-4e8d-a044-9f852c54e775

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FLASHMODE - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cfefca57-f1c4-4a82-91d3-bfdca295d97f

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FLASHMODE - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e59d23a8-7210-415f-8321-3ea2ea0e4150

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FLASHMODE TORCHMODE - scenario

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5814b1d-dbb9-4def-94aa-a72704d2a7f7

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Previewing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9635d861-c75c-48af-9b6c-efa21064f8de

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Previewing after start streaming for a few seconds

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79fb2444-8aa4-42e8-ad04-28b338b1ff83

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17e6c886-c616-409f-ac1f-5fcf92b9ec4a

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording after start streaming for a few seconds

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82d40d69-93b1-45ae-aad0-f2ce53881a92

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSPRIORITY - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/52eeb141-5e7d-487f-8df0-6f8f9e7704c7

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSPRIORITY - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/516473b6-a3ee-47c5-93bf-8c8fec8e6247

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSSTATE - Verify Default setting - Record Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/482b01a8-55b8-4c93-8822-01cff3773cfa

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - FOCUSSTATE - Verify Default setting - Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1bb9a91b-758e-4494-985f-84667cea44f6

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/893ffec9-030e-4d49-a06e-3824656a774e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/997befce-0272-4449-bf79-0a271839520a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - HISTOGRAM - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f2a6f26-5b52-4563-821a-d6bf1f78cfcc

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - HISTOGRAM - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0175f437-4fff-4692-9537-c1627f7b8a8c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ISO - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/baeb81c1-977b-45f6-807b-e05221cfa4a0

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ISO - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5760846-610b-4ea7-9898-7fb59b33ded0

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - OIS - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/30bef893-dcf8-426e-b2f3-7318570c68f7

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - OIS - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc71f911-fac3-4a3a-9a9e-f9ddc2e37bde

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - OIS - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/22f9d4c0-d365-469f-b91a-683dac953d70

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - OPTIMIZATIONHINT - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/42048297-7e6b-4e11-8293-cb25a1bfbec6

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - OPTIMIZATIONHINT - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5b2b5a0-624d-41e9-8780-3b8c155c24e9

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Frame Rate - check default rate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f43c07c-77f6-4361-8977-3863e61d476c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Max Frame Rate - Check default Frame Rate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac98ec01-feb5-4410-85c3-aa89c073446c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Mode - verify mode change

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51e7b6b0-a478-4720-b4c2-a1f239209ee5

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Asyncronously turn on and off PhotoSequence (return event)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c2d99d7-9986-404a-a0b1-1527e2e3fdea

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Asyncronously turn on burst mode (return event)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a680770-f440-404e-bd42-d67d7d55ef53

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Check Not supported on VIDEO_PREVIEW_Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9e062c35-9a6d-4c5b-8760-61f2e97a49e6

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Check Not supported on Video_Record_Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3a9d1af9-f099-478b-a9ad-c07b476de879

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Max Past Frames

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3aab27f6-aa75-445b-b6ba-cb0fc6ce0c9c

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - One Past Frames

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b41a8b4-c90f-445f-8184-5252ab7ac8ed

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Thumbnail

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b37ad95-69ea-4f5c-a681-317aa82021a8

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Thumbnail All Thumbnail Size

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/277bfb17-ccd6-4c2e-b150-880ec8d3c4c9

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Sequence - Zero Past Frames

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/56e4cc41-c107-4acb-9575-ce897667f7cc

This test validates cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE; if it does not, you should skip this test.

NOTE

This is an optional control. If the driver does not support a control, you should not implement a control handler just to return an error. If a control handler is registered, the test expects the control to be fully functional.

If the driver implements the control handler, the following checks are run based on the definition of the controls by the camera topics document. (Note: Implementation of extended controls such as photo mode also requires the implementation of other extended controls; see Requirements and the camera topics document for details.)

  • Verifies default values (if appropriate).

  • Validates that a property is advertised on correct pin or filter level.

  • Enumerates possible control values while pins are streaming and not streaming.

  • Determines end-to-end functionality.

Startup latency is checked by the test measures by taking the delta between when the trigger was sent and when the sink received the first frame from the image pin. This is the PhotoSink_Time that is printed in the log if the test fails.

This test also validates photo frame rate by getting the value that the driver advertises on the get call of KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE. The test validates that the frame rate is within 10% of the advertised average frame rate. and that no frames are dropped during the photo sequence operation. Note that the min and max checks validate that a frame is no more than one-half of a frame early or late.

When KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE is set by the test, the driver should not exceed the frame rate that is passed in by the application. Note that this is a max frame rate, so the driver can do any frame rate that is lower than the one that is requested. Although when driver is queried for KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMAXFRAMERATE, it should report its new value.

This test also validates that KSPROPERTY_CAMERACONTROL_EXTENDED_PHOTOMODE is only advertised on the photo pin. If the driver receives a pin ID other than its photo pin. it should fail with ERROR_INVALID_PARAMETER.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Photo Trigger Time - Check default phototriggertime

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8bcc0784-499c-441a-bcaa-5d6b224d3665

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - PHOTOCONFIRMATION - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8a6c5490-74aa-4ca3-b049-78d91ac9c4a9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - PHOTOCONFIRMATION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff7b92a1-7a99-4859-95c3-8aaf5d2691e2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - PHOTOCONFIRMATION - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb1845ae-2c43-4c90-99ae-0282cd9e426e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - 3A Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb2bf696-58ce-4cd9-a033-dd391d8dd92d

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f709adbb-df35-4515-b05d-c7c1c317d6f1

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Exposure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9bb96fdf-a745-4a18-a56b-f7a5f8e724f5

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Exposure and Whitebalance Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/246e7177-3ed6-4c19-a0dd-f5ff891efe29

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Exposure Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d6dd284-8828-4a67-8829-11fb2b482eb5

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Exposure Valid Rects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f27db3ab-1d7e-4230-9b9f-69328a6c1f03

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Focus

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b62647c6-d7a0-41bc-9b56-ee5b01634f23

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Focus and Exposure Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/99dcd577-8614-4100-b29a-b705254eccb8

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Focus and Whitebalance Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4af673ee-0190-46c0-8f38-8b280423c92e

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Focus Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1e4fb10-c070-480a-a5fb-bfc97434cb0a

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Focus Valid Rects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3f12689-9e89-437e-9e64-b3ba429ee809

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Set Clear

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd34d81b-9b6f-40b6-a62b-f826e362c025

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - WhiteBalance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/55d601f2-fcdc-415c-bbd1-42a85af895b6

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - Whitebalance Photo Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0c24c88-182c-4be9-b2a7-20f77c784340

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ROI - WhiteBalance Valid Rects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bbf1ced7-a159-4b35-9094-1b6fd0872652

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - SCENEMODE - Get Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ca0e801-8b1e-4f5a-bee3-c2eaec6fd0fc

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2fa936e-8da5-4f5c-bf6a-b9f8fb53301e

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/756a4e31-28bc-4e76-96b2-5a4cc6e5f619

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de1d99d9-e432-4133-812c-862475e1d555

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Torch Mode - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/668ef264-a53c-4760-a91a-eac9788f8f6f

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - Torch Mode - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c70878a-806f-4142-af8c-6f1e5c2516de

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VFR - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0bc8285-b90a-4bd1-b1af-fca198bd8cc3

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VFR - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e678647f-2273-426c-b02b-b60912618460

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VFR - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/05418bba-8ae6-427b-a967-3fbe7b502beb

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOHDR - Set Video HDR auto using profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1d945fa5-ba18-4063-9005-63a7d7603e4a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOHDR - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b052136-414b-424c-8eb2-0e455525453a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOHDR - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e7046c0-58f7-409e-9d26-605dfa08b61a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn off Video HDR on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/138929cd-98b9-40fc-aa0b-709efee9a8d1

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b1d5aa10-b863-4857-a527-82016d978d47

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOHDR - verify with profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3bbeb881-56dd-4e92-a075-a6efcdf8d5ad

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b8d180cc-f7a5-4782-85e6-8979d254801b

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c1e1cd8f-fb76-4383-a483-7eb0265d2cba

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93d74e88-4dee-4ce9-8509-10440cc6b900

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b60e9eb4-21c8-473a-aa4f-43fe2be2fd33

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - VideoTemporalDenoising - Iterate through possible settings take Photo and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/250f798b-787d-4aff-b9ab-9dbcd3f9db77

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Controls System Test - VideoTemporalDenoising - Iterate through possible settings while Recording and Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2104ce4-f376-4d19-912b-5a02af3ff318

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Controls System Test - VideoTemporalDenoising - Verify OFF capability is not the only one supported

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc3d69c2-f75f-4a70-aea5-303482cb0bb2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Controls System Test - VideoTemporalDenoising - Verify OFF is supported if AUTO and ON capability are supported

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/acd4fc8b-f508-4bbd-a17a-f9b087679d53

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Controls System Test - VideoTemporalDenoising - Verify OFF is supported if ON capability is supported

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c3e4e9b-5699-45b1-a996-151d7ab02c00

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Photo - Preview Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0318579-a98e-4dda-8642-12ebeac42aec

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Photo - Record Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c48627c1-6860-4873-867d-09fc2c702087

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Photo - Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25dc6049-48be-4bb0-a495-c43e490a1e40

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Preview - Preview Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c500e308-eadc-4920-8887-dcbeaed50962

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Preview - Record Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c94de1d6-7726-48ca-bc03-7a6f393551f5

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Preview - Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/504d39b7-b30c-4d4f-8b47-655bf21317b3

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Record - Preview Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13f8b876-ecc7-49a2-9dd0-ab3dec274992

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Record - Record Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50303b3d-5f42-4479-b065-cd8fb0a3f9d6

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WARMSTART - Iterate through possible settings for Record - Take Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3741c07-a3a2-46c5-96d0-e9d257998054

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WHITEBALANCEMODE - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec457986-5462-4ea1-81c9-dc6e94f1a3db

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0b8e3ce-3513-4a65-914e-37e443228df1

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5984b315-4701-4c71-ac5c-b5b2263c7c32

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/479a541e-7961-45b6-8717-88f2181283d7

These set of tests validate cameras functionality if the driver supports KSPROPERTY_CAMERACONTROL_EXTENDED_*. If the driver does not support KSPROPERTY_CAMERACONTROL_EXTENDED_*, skip this test. This is an optional control.

If a driver does not support a control, do not implement a control handler. If a control handler is implemented, the registered test will expect the control to be fully functional.

If a driver implements a control handler, the following checks run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.

  • The test enumerates possible control values during the times that pins are streaming and not streaming.

  • Scenario tests are run on the control to determine the end-to-end functionality.

NOTE

Implementation of extended controls, such as photo mode, require that you implement additional extended controls.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c486ca1-1935-4206-a65f-4af9bc5ca88c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0303541-cc3f-4f49-8f09-7a5fed9e5a32

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls System Test - ZOOM - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d6d03480-9430-4797-a296-8b50daafbfa1

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Controls Test - FLASHMODE - Manual validation of Camera flash

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ed77db4-5e70-41d1-bc92-51db8ff5ad4c

This test validates that under the proper lighting conditions flash fires when it is expected to.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Performance Test - Measure Camera switching latency during video preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e96a3519-69ba-422d-ae5a-0580d65aee2f

This test will measure Camera switching latency during video preview

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure Camera switching latency during video recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b19d0d91-6005-4d1f-a584-e59f1ad68a97

This test will measure Camera switching latency during video recording

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure media type switching latency on primary video preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8b501dc-cb2d-42cb-aae1-ecd8c782c1db

This test will measure media type switching latency on primary video preview stream

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure media type switching latency on primary video record stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b7c4c3b-68bb-46af-8ae1-50d44fe0edf9

This test will measure media type switching latency on primary video record stream

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure shot to shot latency of photo capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/017fe7f4-5518-4a1f-9d53-bc709316f633

This test will measure shot to shot latency of photo capture

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure shot to shot latency of photo capture with flash

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/732c3e78-9d21-42ce-8b22-9261fd2cf2e4

This test will measure shot to shot latency of photo capture with flash

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure time to begin previewing video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76e9501d-2b63-4d40-889e-914179a631f4

This test will measure time to begin previewing video

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure time to begin recording video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9b1da5c-d9cc-4c22-9e7b-e1ccd2356621

This test will measure time to begin recording video

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Measure time to take first photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61ad5198-3e58-4be7-b4c4-ce5867699098

This test will measure time to take first photo

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Validate timestamps from primary video preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5327f1f-c574-4687-9ae1-0d89e1e5416c

This test will validate timestamps from primary video preview stream

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Validate timestamps from primary video record stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d4e5423-6cd4-4eb4-a9da-616ab99e46bf

This test will Validate timestamps from primary video record stream

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Validate video preview and video record stream timestamps

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d802e2ba-e13e-4b4b-9005-4dfd85d0b341

This test will validate video preview and video record stream timestamps

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Validate video preview and video record timestamps at high resolution for photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/edc05cd3-a594-4c99-b4e9-fa6db24bd8dd

This test will validate video preview and video record timestamps at high resolution for photo

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Performance Test - Validate video preview and video record timestamps at high resolution for photo and video record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1d04b91f-d8ac-4e0f-be81-29c297ca0d6a

This test will validate video preview and video record timestamps at high resolution for photo and video record

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Benchmark
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT


Camera Driver Profiles Collect DevPKey Profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a4defac8-d7f6-4dea-9206-c3b1494e4f9f

Test to validate that we can collect DevPKey Profiles. Gathers and validates the profile payload published by the camera driver through the KS API. Checks the schema of the payload and ensures that schema matches expected information for profile definitions. If test results in an invalid parameter error, it is likely that either a specific schema entry is missing or the value was not valid.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Profiles Collect OEM INF Profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc2890b7-bdc4-4a85-8fbb-2c0c6290b8cd

Test to validate we can collect profiles from OEM Inf. Gathers and validates the profile payload defined in the OEM INF file. Checks the schema of the payload and ensures that schema matches expected information for profile definitions. If test results in an invalid parameter error, it is likely that either a specific schema entry is missing or the value was not valid.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Profiles Interface APIs

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1528e77d-10d1-44b9-859e-c34c17664b18

Test to validate Profiles Interface APIs

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Profiles Validate Concurrency INF Parsing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/108d17c4-203e-4f25-abff-fa088427f974

Test to validate concurrency in INF parsing. Checks both the scehma and necessary registration requirements for support and concurrency profiles.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Registration, Metadata, and Dependency System Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24945562-7fc2-4d56-ba99-1d3439c7a06b

This automated test verifies the physical location of the camera and ensures that the system's webcam meets requirements.

Test details
Specifications
  • System.Client.Camera.Base.PhysicalLocation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites and Webcam Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device.Streaming Testing..

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Rotation Metadata System Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3298903-3772-45ae-85b8-16a395cc333c

This automated test verifies the physical rotation of the cameras

Test details
Specifications
  • System.Client.Camera.Base.PhysicalLocation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - MediaCapture - Camera intrinsics extension, frame

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8e6a020-a788-4a4c-9735-248cd75d3ac5

TBD

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
MFTrace | MFTrace Enablement for each Test Case
AllVideoDevices |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


Camera Driver System Test - MediaCapture - Camera intrinsics extension, stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/23aa8fca-c1c1-4eb1-9cb9-a0e2131e51c0

TBD

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
MFTrace | MFTrace Enablement for each Test Case
AllVideoDevices |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


Camera Driver System Test - MediaCapture - DMFT notification compatibility

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40131f31-e067-4e9a-b051-f81d5a0d21a9

TBD

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
MFTrace | MFTrace Enablement for each Test Case
AllVideoDevices |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver System Test - MediaCapture - TestAll360StreamForSupportedMediaTypes

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9707625d-7518-4e5d-a696-9a3ac530ba5e

The test validates the spherical properties on stream and media type attributes from a spherical camera if attached

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
MFTrace | MFTrace Enablement for each Test Case
AllVideoDevices |
VidDeviceCategory | Video device category [Color

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver System Test - MediaCapture - TestCaptureStreamWithValidPreviewResolution

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f6ee662-15db-44d3-b65d-b69fab96c72f

This test validates that for all capture stream formats (photo/video) there is a matching preview stream with same aspect ratio

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestCaptureWithAllSupportedMediaType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1dfa9c0-1258-4ba5-959a-dcf0cf807021

This test will Capture Preview samples on all exposed formats Capture Video only samples on all exposed formats Capture LowLagVideo only samples on all exposed formats Capture Photo on all exposed formats Capture LowLagPhoto on all exposed formats Capture LowLagPhotoSequence on all exposed formats Capture VariablePhotoSequence on all exposed forms

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestCaptureWithAllSupportedMediaTypeWithPreview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75bbef19-e644-42a2-bfd5-61c74bc1c838

This test will Capture Preview samples on all exposed formats while preview is running Capture Video only samples on all exposed formats while preview is running Capture LowLagVideo only samples on all exposed formats while preview is running Capture Photo on all exposed formats while preview is running Capture LowLagPhoto on all exposed formats while preview is running Capture LowLagPhotoSequence on all exposed formats while preview is running Capture VariablePhotoSequence on all exposed forms while preview is running

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Compatibility
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestConcurrentRecordAndPhotoSequenceCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97303e89-09c8-4d70-886a-197ef9b3af89

This test exercises concurrent record and photo sequence capture from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestDualVideoDevicesInitialization

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94ccfea6-7229-4305-94db-3bef452ddee5

This test validates camera initialization on all system devices

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - MediaCapture - TestEnumerateMediaFrameSourceGroup

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83d3dead-5484-494e-a077-87fa384067cc

The test validates the enumeration of the Frame Source Group

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
  • Device.Streaming.Camera.Base.Sharing.DeviceMFT
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - MediaCapture - TestEnumerateMediaFrameSourceGroupById

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ee7f8394-2062-4df9-a0fd-cf1159614f18

The test validates the enumeration of all capture devices has a corresponding Frame Source Group

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
  • Device.Streaming.Camera.Base.Sharing.DeviceMFT
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - MediaCapture - TestEnumerateVideoDevices

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96db5c21-5ba7-4f76-9a71-6f5e833ef5e6

This test will enumerate and list all the camera devices found on this system

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - MediaCapture - TestExposureCompensationControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0c5fbd85-de81-4815-9f4f-266d0ea3fb7c

This test validates the camera's Exposure (EV) Compensation control in supported settings and conditions. If supported, validates ability to get auto, min, max, step values; validates that value range is correct; ability to set auto and in-range values; cannot set out-of-range values.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestExposureCompensationControlUnsupported

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1f99917c-4a04-4cba-a663-c96e3aae5af2

This test validates the resilience of the camera's Exposure (EV) Compensation control in unsupported settings or error conditions. If EV control is not supported, validates that get/set value will return errors.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestExposureControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c480aee-ac2a-4893-9a74-3c317a05a2fe

This test validates the camera's exposure control in supported settings and conditions. If supported, validates ability to get auto, min, max, step values; that the value range (min, max, step) is correct; can set auto and in-range values; cannot set out-of-range values.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestExposureControlUnsupported

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/00fbdb71-43b8-4706-8ad9-6d07d5707fc0

This test validates the resilience of thecamera's Exposure control in unsupported settings or error conditions. If exposure control is not supported, validates that get auto value will return error, and set value will return error.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestExposureControlWithPhotoCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1b13091c-c00d-4903-9868-8897fbb1e0f1

This test validates that select values within the advertiesd range of Exposure control values exposed by the camera work properly. The test sets the exposure value then attempts to take a photo

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestFrameFlashControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e4b186d-e3b0-4532-a3a3-a58defd72824

This test validates the resilience of the camera's per frame Flash control against support/unsupported values

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestFrameFlashControlWithValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be534cb6-f69b-449d-a862-c81c253cf779

This test validates Flash values exposed by the camera via variable photo sequence capture (3 frame and 10 frame). In each case it will step through the flash range of values based on the number of frames captured.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestFrameReader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8f585df-7878-4b91-b293-6f52043adcb8

The test validates the basic streaming of Frame Readers

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
  • Device.Streaming.Camera.Base.Sharing.DeviceMFT
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestFrameReaderWithAllSupportedMediaFormats

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b3806cd-3c06-4564-bc51-33fed0d5b1a7

The test validates the basic streaming of Frame Reader from all supported media formats

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
  • Device.Streaming.Camera.Base.Sharing.DeviceMFT
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestHLK5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3876f18-fd85-442c-a683-5830560e34b0

TBD

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestHLK6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/968b7475-86cd-4c3f-80df-5d0f18dccc99

TBD

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestIsoSpeedControl

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b7af4c52-85a3-4e61-8063-71a527f18644

This test validates the camera's ISO Speed control in supported settings and conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - TestLowLagPhotoCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f24be950-4e54-4c5f-aa5b-6566a7ea25fc

This test validates Low latency (warm start) photo capture of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestLowLagVideoCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5b0f4370-0791-4edb-86b7-10be7dd2f548

This test validates basic lowlag video recording functionality of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestMediaCaptureScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7dae61d-6e6e-4ec5-a3c7-3f88f045ca91

This test exercises Valid and invalid sequence calls while validating low latency photo and record, photo sequence, and variable photo sequence from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestMultiFrameReader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31a1d1d3-f43f-42ad-a66b-7f81eec154de

The test validates that we can correlate Depth and RGB streams

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestPastPhotoLimit

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ff59e3d-5427-4d9e-9a57-f94ca0387bd6

This test validates that the advertised amount of past frames are received during photo sequence capture

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestPhotoSequenceCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/383a2959-317f-4542-addd-283c62b874fe

This test validates photo sequence functionality of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestValidateVariablePhotoSequenceFrameMetadata

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/098e7f58-81ec-44c4-8189-5703c548ad6b

This test validates variable photo sequence frame metadata from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestVariablePhotoSequenceCapture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1bf5c94-67f2-4d3e-8364-decad26a9ae9

This test validates basic variable photo sequence functionality of the camera from the MediaCapture API layer

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestVideoCapture with highest available resolution

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac96a18b-da6f-4039-b245-40b54fc5cce4

This test validates basic video recording functionality of the camera from the MediaCapture API layer and selects highest resolution

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
MFTrace | MFTrace Enablement for each Test Case
AllVideoDevices |
VidDeviceCategory | Video device category [Color

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


Camera Driver System Test - MediaCapture - TestVideoProfileWithValidPreviewResolution

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2d4eb17d-e573-4057-a522-21eaf99afeb3

Test for all capture streams there is a matching preview resolution with same aspect ratio in the same profile

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestVPSMaxFrameCount

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/204dab6f-44ce-4e71-983e-15b8ee32e4f2

This test will attempt to set maximum amount of frame settings on 20 frame variable photo sequence.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - TestWindowsHelloDeviceRequirement

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fbf1ae7c-12ed-4fd5-9f83-c7d092de594d

The test validates devices that supports FaceAuth Control confines to WindowsHellow device requirement

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |
VidDeviceCategory | Video device category [Color


Camera Driver System Test - MediaCapture - ValidateAdvanceIsoSpeedControlValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ae32e20-792f-4421-9097-834f61df1e33

This test validates that that select values within the advertiesd range of Advanced ISO Speed values within range exposed by the camera work properly. The test will attempt to take a photo after setting the ISO value.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateCameraBasicSettings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6a45157a-b4ad-4be0-b6a6-ddfafa8275b9

This test validates basic camera controls in supported settings and conditions

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateCameraBasicSettingsError

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0badd5d-d2dd-4a4b-92d4-c569cdca70bc

This test validates the reslience of basic camera controls in unsupported settings and error conditions

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateExposureCompensationValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7585abc6-35ab-4c72-8616-b98e878d5d8f

This test validates that values within the advertiesd range of Exposure (EV) Compensation control values exposed by the camera work properly. The test sets the EV value then attempts to take a photo

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFlashControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ea02708-e01b-43ee-8c7b-6c1f16710f9c

This test validates the camera's Flash control in supported settings and conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFocusControlFocusSettings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/340c223e-4134-4450-8466-1b4f2de1bba7

This test validates the preset settings exposed by the camera's Focus Control

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFocusControlSupportedPresets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44c3fe7a-2543-4ceb-8e22-1ceae458cc29

This test validates that all Focus control preset values exposed or permitted by the camera work properly. The test will attempt to take a photo after setting the Focal length preset value.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFocusControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6fb550fd-071b-408f-a591-60834ced7f04

This test validates the camera's Focus control in supported settings and conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFocusControlUnsupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82f6a51a-cb82-41e8-8fc1-ade98ab76ee8

This test validates the resilience of the camera's Focus Control in unsupported settings or error conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameExposureCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d618dbef-0412-4a7b-a3ea-902517710cbe

This test validates the camera's per frame Exposure capabilities

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameExposureCompensationCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ceeeede-7a5f-484f-be2a-468c3e1afa0e

This test validates the camera's per frame Exposure (EV) Compensation capabilities

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameExposureCompensationValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c127877-e162-42b2-9698-4e0d228fcfdb

This test validates Exposure (EV) Compensation values exposed by the camera via variable photo sequence capture (3 frame and 10 frame). In each case it will step through the exposed range of values based on the number of frames captured.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameExposureControlValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/694e9e80-edfb-492c-9430-11851b01d64f

This test validates Exposure values exposed by the camera via variable photo sequence capture (3 frame and 10 frame). In each case it will step through the exposed range of values based on the number of frames captured.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameFocusCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d5dfd52e-1d8a-437f-b6ab-56844f6fe9e5

This test validates the camera's per frame Focus capabilities

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameFocusValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/190a7351-760b-4916-be58-853277cd883a

This test validates Focus values exposed by the camera via variable photo sequence capture (3 frame and 10 frame). In each case it will step through the exposed range of values based on the number of frames captured.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameIsoSpeedCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f86a9d2a-8884-4be5-af4f-6500e4881beb

This test validates the camera's per frame Focus capabilities

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFrameIsoSpeedValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bfcf4a45-33fc-4ece-93ca-97dfacfa2b24

This test validates ISO Speed values exposed by the camera via variable photo sequence capture (3 frame and 10 frame). In each case it will step through the exposed range of values based on the number of frames captured.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateFramePhotoConfirmationCapabilities

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d72d76f3-581b-49cc-8f7d-5e5ebe07ae8b

This test validates the camera's per frame Photo Confirmation behavior

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateIsoSpeedControlPresets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75702255-68a1-465d-854d-0be68b498b0a

This test validates that all ISO Speed preset values exposed by the camera work properly. The test will attempt to take a photo after setting the ISO value.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateIsoSpeedControlUnsupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/52aaf722-b20f-481f-949e-f220958b9d6e

This test validates the resilience of the camera's ISO Speed control in unsupported settings or error conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateManualFocusValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1308d008-0b51-45f0-bc17-73557c294099

This test validates that select values within the advertiesd range of Focus values permitted by the camera work properly. The test will attempt to take a photo after setting the Focus value.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidatePowerlineFrequency

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ed5e52f5-86b2-4a92-bcf6-3534ceb93e52

This test validates the camera's Powerline Frequency (flicker) control

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidatePrimaryUseControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27277091-0dd3-46ea-9ecf-6dc47761a369

This test validates the camera's Primary Use (optimization hint) control in supported settings and conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateROIControlIllegalBounds

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8dd12f0b-dae3-475f-a1a7-71993c2e4348

This test validates the camera's ROI control with illegal bounds

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateROIControlLegalBounds

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd1ad931-b73f-4501-a368-2bf7ddac5dd9

This test validates the camera's ROI control with legal bounds

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateROIControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6c473aea-ed4f-4d03-aaa4-f8b71e067270

This test validates the camera's ROI control in supported settings and conditions. Ifr ROI is supported, validates that default values for ROI autoExposure, autofocus and autoWhiteBalanced enabled are False.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateSceneModeControlPresets

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c48c857-782d-44eb-b1a3-f486c94c184d

This test validates that all Scene Mode preset values exposed or permitted by the camera work properly. The test will attempt to take a photo after setting the Scene Mode.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateSceneModeControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e3d24f5-b4db-4dcc-b9d2-b70bf83d3dfa

This test validates the camera's Scene Mode control in supported settings and conditions. If supported, validates that supported scene mode preset list is not empty and that default scene mode value is auto.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateSceneModeControlUnsupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40f55466-f611-483f-b0dc-503069bca21c

This test validates the resilience of the camera's Scene Mode control in unsupported settings or error conditions. If not supported, validates that scene mode list is empty.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateTorchControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c81890f2-160c-408f-862a-7c589a08385c

This test validates the camera's Torch Mode control in supported settings and conditions. If torch is supported, validate that Enabled is set to False by default; power can be set to in-range values if supported; get/set of power returns error if power is not supported.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateTorchControlUnsupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/554a6223-f423-4e01-8192-86fbfb22eea5

This test validates the resilience of the camera's Torch Mode control in unsupported settings or error conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateWhiteBalanceControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33c1feb0-7919-45f4-92ef-f794cb27aaa3

This test validates the camera's White Balance control in supported settings and conditions. If WhiteBalance is supported, validates that default WhiteBalancePreset is Auto; ability to get min, max, step, range; ability to set advertised supported preset.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateWhiteBalanceControlUnsupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/552cb03e-e0b8-46ad-b723-29104d403971

This test validates the resilience of the camera's White Balance control in unsupported settings or error conditions

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateWhiteBalanceControlValues

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3afea56e-dc96-47a1-949b-0aeffc8e049a

This test validates that all White Balance values exposed or permitted by the camera work properly. The test will attempt to take a photo after setting the White balance value.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateZoomControlSupportedScenarios

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b51b6510-51bd-4cbf-9f5a-dab144dd8bc8

This test validates the camera's Zoom control in supported settings and conditions. If zoom is supported, validates that advertised min, max, step values are correct; zoom can be set with in-range values; zoom cannot be set with out-of-range values.

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - MediaCapture - ValidateZoomDuringVideo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eca25951-bc2d-40f5-b578-34fc3149d5fe

This test exercises the camera's Zoom control while streaming video

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllVideoDevices |


Camera Driver System Test - Profile Mix Mode Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2bf5c8ac-b1e9-4bdb-a5a7-8228c16e6d02

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver System Test - Profile Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38289fcf-f3c4-4d7e-9a7d-e35c169d4214

This automated test validates that profiles are correctly configured for consumption by Media Foundation APIs

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver Test - MultiCamera MultiStream (Scenario) - Preview (Sample Grabber), Capture JPEG Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbb067a4-3b53-413b-988c-46aadf4ef8ff

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera MultiStream (Scenario) - Preview, Capture JPEG Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b4ee5195-6225-4426-9b43-09eade1b3a87

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Preview (Sample Grabber), Capture JPEG image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2fa38fa-e7c1-4adf-b790-623247f50c5c

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Preview (Sample Grabber), Record H.264 Video and AAC Audio

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a86cbf6-206b-4565-8193-e2902a8aeac2

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Preview (Sample Grabber), Record H.264 Video and AAC Audio from each Capture Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cc7f4ae-fd23-489a-8ab5-96bc80b38f60

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Preview, Capture JPEG image from each image Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6d3d9e2-45f7-461d-bf1b-b91488de06b8

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Capture Stream - \*

    Validates that the system can record from MF_CAPTURE_ENGINE_PREFERRED_SOURCE_STREAM_FOR_VIDEO_RECORD.

This test captures from the preferred video recording pin by using the preferred mediatype exposed, and attempts to save to H.264 format.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Preview, Record H.264 Video and AAC Audio

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5301e59d-8b44-4ff7-9f65-620d3ad220c9

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Preview, Record H.264 Video and AAC Audio from each Capture Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cfca7177-1cea-46cc-990c-13b6806a9247

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 90
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Video Preview (Sample Callback) - Stream video from all available format on the preview stream and dynamic format switching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c32f6b26-5684-4c37-a302-a3fa982b84af

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Video Preview (Sample Callback) - Stream video from each available format from the camera's preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df3363b4-a8bd-4377-bb4e-2914076f80de

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Video Preview (Sample Callback) - Stream video from the default format on Camera preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c5173c35-d180-4b48-9b9b-3bc275b1a0de

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Video Preview (View Finder) - Stream video from all available format on the preview stream and dynamic format switching

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a066ce13-3c09-4993-9705-b907c6aa4640

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Video Preview (View Finder) - Stream video from each available format from the camera's preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81763afe-11c2-46f8-ba33-65a9c1c4d72c

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiCamera Video Preview (View Finder) - Stream video from the default format on Camera preview stream

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b174017d-c2fb-4fe3-a409-2b4e4b3ceb5a

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture Bitmap Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0be4ba4-dae5-46f7-8aa0-8b061b7526d3

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture JPEG Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f89e4135-9dd7-492c-ab9f-5e0d396f8434

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview (Sample Grabber), Record H.264 Video and AAC Audio, Capture JPEGXR Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6ae1141-c850-4f6a-b20a-2e1c0ec3e274

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture Bitmap Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ea3d121-5ce7-42f5-8205-afcd2f06a19d

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will use the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with BMP as the image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture JPEG Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4efe8360-eb8c-4d93-b5c7-c194681c4cc0

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - MultiStream (Scenario) - Preview, Record H.264 Video and AAC Audio, Capture JPEGXR Photo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53622377-903f-4d8a-8cb9-2b0b46989870

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEGXR as the image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber), Record H.264 Video and AAC Audio

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b84f608-5c63-4a72-b15d-80486afbdce5

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview (Sample Grabber), Record H.264 Video and AAC Audio from each Capture Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6e58d86-7fd6-4add-8ca1-dbcab7a446a6

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview, Record H.264 Video and AAC Audio

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb76bdd3-edc2-484b-9344-ac26c15a8a2c

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - Preview, Record H.264 Video and AAC Audio from each Capture Stream type

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0447fc6-7b9c-4186-a02f-c02bcde5d4e9

This set of tests validates cameras functionality with the MF and IMFCaptureEngine.

  • Camera Driver Basic Tests - \*

    Tests against a subset of camera media types and shorter duration of tests than functional or reliability.

  • Camera Driver Functional Tests - \*

    Tests against a larger set of media types and have longer duration of the test.

  • Camera Driver Reliability Tests - \*

    Tests against a larger set of media types and have longer duration of the test, and more complex scenarios.

  • *- Multi Stream - \*

    Validates that the system is able to take a photo, preview, and record.

This test will specifically set up a capture scenario that will preview and record simultaneously. It will user the preview pin to render an uncompressed mediatype and will use the record pin to save an H.264 video format and AAC audio format, and will also take a photo with JPEG as image format type.

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

Error Description/Workaround

0x8004005 : E_FAIL

The most often occurrence of this error code is during the verification of the Recorded file for Video or Photo. This will occur if the resulting file contains no data because it did not receive samples.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

0x80070102

This will occur when a Capture Asynchronous Operation has timed out. These include Initialize, Start Preview, Stop Preview, Start Record, Stop Record, Take Photo, and Change Mediatype. The test allows for 9-10 seconds for each operation before failing. Mediatype change can include pin tear down and bring up time.

Check that the device isn't waiting for future commands that prevent it from changing state. Ensure that all buffers are flushed out of the device on device reset commands.

0xC00D3704 : MF_E_HW_MFT_FAILED_START_STREAMING

This error occurs when the device cannot enter the run state.

Check that the device is able to transition through all states without failure, or that other pins aren't preventing the device from entering a state.

0xC00D4A44 : MF_E_SINK_NO_SAMPLES_PROCESSED

This error occurs during finalization of files, if no samples have been delivered.

Check to ensure the device is producing valid samples when it enters the run state. Valid includes that the sample is the right size, format, and time for when it was produced.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - UVC Test 4

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/84580945-5e9a-453e-9912-9267475a9bcc

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - UVC Test 5

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c190d0b-5a85-4b87-a149-4a0b41088669

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Test - UVC Test 6

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/96d8f72a-d0ac-466c-be83-a8d9ce176aa3

This test validates the selected camera (hw and driver) is compatible with Windows Media Foundation

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver Usage Indicator Manual Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/590dd080-a2bc-487a-a680-067facde6a44

This test validates that the camera indicates its streaming status properly. When a camera is streaming, the LED (or on screen indicator) should be on. When the Camera is not streaming, the LED/indicator should be off

Test details
Specifications
  • System.Client.Camera.Base.Device
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Color Accuracy at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0586ebe9-fd12-4a41-b201-4bea0e5d648f

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Color Accuracy at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2089524a-e053-43b2-a2d9-989a1a639bbf

This Test evaluates the Color Accuracy of the camera sensor at 1280x720 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Color Accuracy at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bcd9454b-a61e-4b55-a569-2e97fec95470

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Color Accuracy at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3816b62-a245-4489-bc22-7b40f793f425

This Test evaluates the camera sensor's color accuracy at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Color Accuracy at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/81c9533d-6e2e-46f2-88e9-9e4c2241803a

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Color Accuracy at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc1e86ab-fa71-4b62-b094-dda7150dea0e

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Gamma at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/59035d32-2cc4-4a11-b657-9fb8342b76c4

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Gamma at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f939e60b-3981-4956-973c-b74fffe3d38f

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Gamma at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/049ff61e-f270-4245-8d80-e4e56a3b97b2

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Gamma at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ca47b13-8876-4e60-9716-72e9793b67b4

This Test evaluates the gamma value of the camera sensor at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Gamma at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69388bca-f9d4-4697-95dd-b1344a01eef8

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Gamma at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7d421320-6fbb-4b06-ac0d-28a08e330477

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Glitch Free video at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b9e1feda-3c91-463b-bc52-dad9d98cc173

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Glitch Free video at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aa707828-aa14-4039-b38f-0b3c60618bf3

This Test evaluates the camera sensor's ability to stream glitch free video at 1280x720 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Glitch Free video at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bae0e234-aba7-4129-b46b-a2a6b6841dd6

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Glitch Free video at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d1bdd83a-7c14-4606-a04d-af531c7b7ced

This Test evaluates the camera sensor's ability to stream glitch free video at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Glitch Free video at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9c3f12e5-e616-4ec2-8f9e-2f5e822ef29c

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Glitch Free video at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b556b44b-c065-49e1-b1e4-3f2ae1e7174d

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate luminance at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf929fbd-1afd-42e0-bd73-c4215c237ed5

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate luminance at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4cd71ae-28ec-4f91-88f3-ad397af38da9

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate luminance at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ada4987-e26d-4d1b-a6c2-e7660cbe2e7d

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate luminance at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e15b0b2-2f04-400d-8d4e-e6a2316ab610

This Test evaluates the luminance value of the camera sensor at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate luminance at 640x480 Lux20

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5b322bd-a847-4534-b084-8fb17541e558

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate luminance at 640x480 Lux80

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a894548-b08c-46fd-ba07-55d2b4e68a12

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial Resolution at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/90b493f6-6be9-429d-b2ee-72aaa140d256

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial Resolution at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/886ca49e-cfe8-4df5-9475-9729d1604b3d

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3a4bd4f4-77d9-4fd5-88cb-d73ff6bad18b

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1359d44a-1aad-4f81-b4f8-d04753639a46

This Test evaluates the spatial resolution of the camera sensor at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5fad5d3a-aad7-4965-8bc1-4d54960eb1af

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial Resolution at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cbcd6560-b439-479f-9d8f-04fba38e52c8

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial SNR at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a881860-a56d-41e6-85fd-85ca980c9b7f

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial SNR at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b849843-4c51-44c1-83b5-60cb79884476

This Test evaluates the spatial signal to noise ratio of the camera sensor at 1280x720 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial SNR at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9d29aad8-c937-48f8-84c5-38ea8496966e

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial SNR at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe484dd1-9e98-4d6d-b934-6a553f9b725b

This Test evaluates the spatial signal to noise ratio of the camera sensor at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial SNR at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b6e396ec-ce5e-4d20-874b-4f9ec9612ee9

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Spatial SNR at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b630a70d-3083-44ad-856a-b51e990c8a23

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Temporal SNR at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/beba695d-5f82-4217-a557-375e38e0b5e1

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Temporal SNR at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a01251ac-2402-496a-bd70-1b6ad91a1bc7

This Test evaluates the Temporal signal to noise ratio of the camera sensor at 1280x720 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Temporal SNR at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/772caaa2-0594-451c-92ca-03053fd30d53

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Temporal SNR at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38a5c8cb-0e44-45ac-8b15-00edd051e14e

This Test evaluates the temporal signal to noise ratio of the camera sensor at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Temporal SNR at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df0dcae8-1cba-4a6e-bf76-ada494830aa1

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Temporal SNR at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f9a3aaf3-0333-4d5b-911a-c9bc498e163a

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Vertical Field of View at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/912e3ee6-ae4d-4482-a4cf-2e44bd11d70a

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Vertical Field of View at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ba14ce37-e23c-4261-aa56-d26ceed6d87d

This Test evaluates the camera sensor's vertical field of view at 1280x720 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a81f97d6-19d6-408a-9b0d-84064804a600

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a7ad3c3-b745-45e5-9bf8-15baf4f8dde4

This Test evaluates the camera sensor's vertical field of view at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4a73bf4-1f90-40f2-9373-e89440631b6e

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate Vertical Field of View at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3cc05e6-03a5-442d-b968-516fdabfa48f

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate video frame rate at 1280x720 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6edbf5e5-b75e-4e2e-a757-d44ba96ae483

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate video frame rate at 1280x720 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c35045cc-6921-4226-a6b5-fa91b3f22af6

This Test evaluates the camera sensor's quality by measuring the advertised vs effective frame rate at 1280x720 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate video frame rate at 640x360 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/de2b3842-d0f0-424c-9b7e-ef08484ae699

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate video frame rate at 640x360 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3340af6-f4a6-4a69-a395-87cfb5c78c43

This Test evaluates the camera sensor's quality by measuring the advertised vs effective frame rate at 640x360 and 80 lux.

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate video frame rate at 640x480 and 20 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0519434-d3f0-4c90-9221-5fce0a32fc18

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Sensor Quality Test - Evaluate video frame rate at 640x480 and 80 lux

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0283d56d-8190-4be1-94b9-24debb8aab3d

The Camera Sensor Quality test is an optional test for systems that include one or more built in cameras (for example: phones, laptops, tablets, all-in-one personal computers). This test verifies that the system is able to deliver a high quality real-time capture experience.

This test does not require a dedicated light room; it can be performed in a standard office environment by using the described test setup.

This test is implemented in the Windows Hardware Lab Kit (Windows HLK). The Windows HLK tests measure video streams and the quality of captured images from the device under test (DUT) during streaming video capture at various resolutions. Images of a specified poster, which includes both color and image clarity features, are captured under controlled lighting conditions.

The tests estimate key video quality metrics in the following areas:

  • Image acuity

  • Noise

  • Color quality

  • Geometry

  • Timing

Test details
Specifications
  • System.Client.Camera.VideoCapture.Discretional.SensorQuality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Webcam Testing Prerequisites.

Step-by-step instructions for setting up the test:

Watch the following video demonstration.

Video link

The following additional test equipment is required to run the video tests:

  1. Video test chart:

    • xRite ColorChecker chart. See Figure 1. Video Test Chart.

    • National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter anually.

    • Printout of the test chart (that is shown in REF _Ref311027164 \h Figure 1. Video Test Chart), on matte paper by using a high quality inkjet (for example, an HP Z2100). You can access and print this high resolution PDF test chart from: http://download.microsoft.com/download/8/0/0/80080840-64DC-4929-9B67-16B83E946C6B/HLK Video Test Chart.pdf.

      example test poster

    • After you print the test chart, mount the color checker and the light meter. The light meter sensor and display should both be mounted and in the field of view. This allows you to measure light levels at test time and to validate light levels by reading the display from captured images.

  2. Dimmable lights

    • Two impact light stands. Any type is acceptable as long as they allow for the positioning that is described in this topic.

    • Two light mounts that have reflectors; for example, an Impact 5" Reflector Floodlight Kit.

    • INSTEON Plug-In Lamp Dimmer Module. Any type is acceptable as long as it has two plugs so that you can control two lights simultaneously (with equal lighting), and the granularity of adjustment to achieve the target 80 & 20 lux (+/- 10%).

    • INSTEON Wireless Keypad RemoteLinc 2 (optional).

    • 3-to-1 extension cord. Any type is acceptable as long as it can connect to the Insteon dimmer module.

    • Two units Philips 424382 11-Watt A19 LED Light Bulb, Dimmable

    An example DUT and lighting configuration is shown in REF _Ref311027182 \h Figure 2. Video Test Setup. The lighting that is used in this example is A19 LED-lighting at 20 and 80 lux on the test target.

    video test setup

To run the video capture test

  1. Start the test by using the Windows HLK Studio Test Scheduler.

  2. Position the DUT as shown in REF _Ref311027182 \h Figure 2. Video Test Setup.

  3. Turn off all ambient lighting.

  4. The test prompts you to set the light level and test position:

    1. In light setting mode, the test automatically dims the screen to allow accurate measurement of the light level.

    2. Adjust the dimmer to get the required number of lux. An acceptable range is 18 to 22 and 72 to 88.

    3. Confirm the light level and exact distance from the camera to the target chart.

  5. If the system has both front and back cameras, repeat steps 2-4 for the second camera.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Streaming Testing.

Troubleshooting specific errors

Error Description/Workaround

Setup: test can't find Region of Interest (ROI)

The test looks for Region of Interest (ROI) markers (black and white circles) at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly. Failure to detect ROI might be due to a poorly aimed camera or unusable video capture from the camera (for example, too dark).

If preview window is not a usable video (for example, 100% gray image due to failed capture, or too dark), exit the test and verify the camera functionality with an independent camera application under test lighting conditions (for example, AMCap) before proceeding.

If the preview window provides a usable image that has clearly recognizable ROI markers, reposition the camera according to the test procedure conditions.

Setup: Region of Interest doesn't fit within field of view of camera

The test looks for ROI markers at known locations on the test. If the test cannot identify ROI markers, then the test cannot run properly.

You might need to position smaller field of view cameras (for example, rear facing cameras) farther than 0.5 m from the test target to capture the required ROI.Reposition the camera according to the test procedure and verify that the camera provides a usable image under test lighting conditions. To avoid an inaccurate measurement for the field of view requirement, enter the new distance into the test application.

Troubleshooting position problems

This section shows three examples of the most common camera positionining problems. To aid in troubleshooting these types of issues, Windows HLK saves a marked-up version of the image file (look for files that have "ROI" in the file name). The marked-up file includes small red, green and blue markers at key positions on the chart. Markers are as follows:

  • Green dot in the center of the four black and white circles.

  • Four red dots that mark the boundaries of each color square in the color chart.

  • Red and green dots in the center of the white and gray slanted edge chart. The red dot should cover the green dot (hiding it), or the two dots should be within five pixels of each other.

  • Four red dots that outline the region of interest for a horizontal MTF measurement. The slanted edge should be in this region at an approximate angle of seven degrees from the vertical direction.

  • Four blue dots that outline the region of interest for a vertical MTF measurement. The slanted edge should be in this region and at an approximate angle of seven degrees from the horizontal direction.

In Figure 3. Incorrect Position because of Keystoning, ROI markers do not form a rectangle because the camera is not perpendicular to the target.

In Figure 4. Position Not Level, position markers form a rectangle that is rotated relative to the field of view.

camera not level

Figure 5. Poor Centering, shows two or more image markers that are outside of the field of view.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Camera Driver System Test - Camera Windows Hello Face Auth Profile Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0d3fd797-3df1-4f01-acba-7c84e7348d3e

This automated test validates that face auth profile meets Hello requirements

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Camera Driver System Test - Camera validation for DShow Bridge enablement

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50aaa569-47db-431d-aaa3-9da0f78833c8

This automated test validates that all camera drivers always opt into DShow enablement

Test details
Specifications
  • System.Client.Camera.VideoCapture.VideoCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Clock Interrupt Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/189f5102-3622-4b4e-95dd-e3c7a5d24f9a

This test measures the clock interrupt resolution by enabling ETW tracing and processing that data in real-time. During the test, the clock interrupt resolution is manipulated to confirm that the HAL and underlying hardware are performing as expected at a variety of supported resolutions.

Test details
Specifications
  • System.Client.CPU.Compatibility
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 31
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Crashdump through Capsules, Firmware Support Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2ef58605-6938-4ea5-a48e-b74f1847ce63

Test details
Specifications
  • System.Client.IntegratedDesign.Global
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
BugcheckDriverPath |
CrashScriptsPath |
DumpUtilPath |
BugcheckDriverCtrlPath |
IdleCrashdumpTestPath |

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


DX10 Graphics Enforcement Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/635f797f-8dc2-41ac-8589-0ff6d6e77434

This automated test verifies that a system's display adapter or chipset supports DirectX 10.

Test details
Specifications
  • System.Client.Graphics.Windows7.MinimumDirectXLevel
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Glitchfree HD Video Playback on AC ( Manual on mobile systems )

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0ed5aa8-ef49-4fc9-99b6-753c857e4e2d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The manual test verifies that a mobile system on AC power mode is capable of playing protected and unprotected High-Definition content with no perceivable glitch during playback.

Test details
Specifications
  • System.Client.VideoPlayback.GlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

In addition, perform the following steps:

  1. Make sure that the Video and Music apps are installed on the system. You can get both apps from the Store.

  2. Make sure the .mp4 and .wmv extensions are registered to the Video app. To do this, right-click a sample file that has the appropriate extension, click Properties, click Open with, and select the Video app.

  3. Make sure the .m4a and .wma files are registered to the Music app. To do this, right-click a sample file that has the appropriate extension, click Properties, click Open with, and select the Music app.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

The HLK GlitchFree test plays back two video clips using the inbox Video application. The content is played back in Fullscreen while ETW logging is enabled in the background. After each scenario, the test post processes the ETW log and extracts metrics, which are used to determine whether the test passes or fails.

Pass/Fail Criteria & Metric Details

Glitch Metrics

  • Video Glitches - The Media Engine's Video renderer (SVR) detects when a frame is rendered late and it fires a video glitch event. The goal for this metric is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - VideoFrameGlitch - 23

  • Dropped Frames - The Media Engine fires frame drop events when the source drops a frame. When frames are dropped, the user experiences glitchy video. The goal is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - DroppedFrame - 18

  • DWM Schedule Glitches - The desktop window manager (DWM) fires a glitch event when DWM samples are rendered late. The goal for this metric is 0. The test starts tracking this event 500ms after the first PresentedFrame event (Task ID 19, Event ID 115). The test stops tracking this event 66ms after the last instance of PresentedFrame event (Task ID 19, Event ID 115). Provider and event details:

    • Microsoft-Windows-Dwm-Core

    • Channel - Microsoft-Windows-Dwm-Core/Diagnostic - 16

    • Level - win:Informational - 4

    • Task - SCHEDULE_GLITCH - 17

  • Audio Glitches - Audio glitches. Goal is 0.

    • Audio Engine Provider: a6a00efd-21f2-4a99-807e-9b3bf1d90285:0x000000000000ffff:0x3

    • ETW Classic event GUID: 2013DBB2-2F76-4B2C-950A-0C9DFAC62398

    • Event details:

      • Media: Audio Engine

      • AE Events

      • AE_GLITCH

Total Device Creation time: The total device creation time must not exceed 50ms. Total device creation time is defined as DeviceCreation + CreateVideoDecoder, where the definition of those two metrics are:

  • DeviceCreation = The latency between the following two events

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 20 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 21 (Version 0) Opcode - win:Stop - 2

  • CreateVideoDecoder = The latency between the first instance of the following two events:

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1722 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1723 (Version 0) Opcode - win:Stop - 2

Driver Metrics- The ISR/DPC duration and ISR/DPC Storm tests aim at ensuring that device drivers are well behaved. The goal is to ensure that time critical multimedia threads can run on a regular basis, with limited interruptions from ISR/DPCs.

  • ISR/DPC duration: This check is designed to validate that individual ISR/DPC duration does not exceed a 3ms threshold.

  • ISR/DPC Storm: A cumulative duration of every ISR/DPC within a 10ms window must not exceed 4ms.

GPU VSync Cadence: This case ensures that the GPU DPC VSync cadence follows a well behaved pattern. Fluctuations in GPU DPC Vysnc frequency, during media playback can result in glitches during media playback. The test criteria establishes that the cadence fluctuation should not exceed +/- 50% of the average VSync cadence window. For instance, in a 60 Hz monitor, the expected VSync DPC cadence is 16.666 ms; consequently the test will fail if any VSync DPC is fired within less that 8.3 ms from the previous one or later than 24.9 ms from the previous one. When the duration between two vsyncs is greater than 24.9ms, this often results in a perceivable video glitch. When the distance between two vsyncs is less than 8.3ms, this is often caused by the driver double firing vsyncs, or vsyncs that are a few microseconds (us) apart.

How to enable verbose ETW logging for analysis

To collect more verbose ETW logs, change the user-settable parameter 'DoFullLogging' to 'true' before running the tests.

How to preserve the ETW logs for analysis in case of failure

To preserve the ETW logs for failed test cases, change the user-settable parameter 'CopyLogsOnFailure' to 'true' before running the tests. This will also copy the ETW logs of failed test cases to the controller and be included as part of HLK package to be shared for investigation.

Using Media Experience Analyzer to analyze failed ETW logs

You can use Media Experience Analyzer (MXA) to analyze failed ETW logs. Download MXA from the following location:

  • http://www.microsoft.com/en-us/download/details.aspx?id=43105

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation
FrameCount | Minimum number of MF Events required during playback
MaxIsrDpcTime | Maximum ISR Dpc time in microseconds
MaxIsrDpcStorm | Maximum ISR Dpc Storm in microseconds
MaxIsrDpcLoop | Maximum ISR Dpc Loop time in microseconds
GlitchCount | Number of glitches acceptable during playback


Glitchfree HD Video Playback on Battery (DC) Power Source ( Manual on mobile systems )

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16747c8a-aa13-4c12-8d51-95d6f270c982

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The manual test verifies that a mobile system on DC power mode is capable of playing protected and unprotected High-Definition content with no perceivable glitch during playback.

Test details
Specifications
  • System.Client.VideoPlayback.GlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

This test requires manual intervention if the mobile system is plugged into an AC power source when the test starts.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

The HLK GlitchFree test plays back four video clips in a Media Engine-based test playback application. The content is played back in Fullscreen while ETW logging is enabled in the background. After each scenario, the test post processes the ETW log and extracts metrics, which are used to determine whether the test passes or fails.

Pass/Fail Criteria & Metric Details

Glitch Metrics

  • Video Glitches - The Media Engine's Video renderer (SVR) detects when a frame is rendered late and it fires a video glitch event. The goal for this metric is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - VideoFrameGlitch - 23

  • Dropped Frames - The Media Engine fires frame drop events when the source drops a frame. When frames are dropped, the user experiences glitchy video. The goal is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - DroppedFrame - 18

  • DWM Schedule Glitches - The desktop window manager (DWM) fires a glitch event when DWM samples are rendered late. The goal for this metric is 0. The test starts tracking this event 500ms after the first PresentedFrame event (Task ID 19, Event ID 115). The test stops tracking this event 66ms after the last instance of PresentedFrame event (Task ID 19, Event ID 115). Provider and event details:

    • Microsoft-Windows-Dwm-Core

    • Channel - Microsoft-Windows-Dwm-Core/Diagnostic - 16

    • Level - win:Informational - 4

    • Task - SCHEDULE_GLITCH - 17

  • Audio Glitches - Audio glitches. Goal is 0.

    • Audio Engine Provider: a6a00efd-21f2-4a99-807e-9b3bf1d90285:0x000000000000ffff:0x3

    • ETW Classic event GUID: 2013DBB2-2F76-4B2C-950A-0C9DFAC62398

    • Event details:

      • Media: Audio Engine

      • AE Events

      • AE_GLITCH

Total Device Creation time: The total device creation time must not exceed 50ms. Total device creation time is defined as DeviceCreation + CreateVideoDecoder, where the definition of those two metrics are:

  • DeviceCreation = The latency between the following two events

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 20 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 21 (Version 0) Opcode - win:Stop - 2

  • CreateVideoDecoder = The latency between the first instance of the following two events:

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1722 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1723 (Version 0) Opcode - win:Stop - 2

Driver Metrics- The ISR/DPC duration and ISR/DPC Storm tests aim at ensuring that device drivers are well behaved. The goal is to ensure that time critical multimedia threads can run on a regular basis, with limited interruptions from ISR/DPCs.

  • ISR/DPC duration: This check is designed to validate that individual ISR/DPC duration does not exceed a 3ms threshold.

  • ISR/DPC Storm: A cumulative duration of every ISR/DPC within a 10ms window must not exceed 4ms.

GPU VSync Cadence: This case ensures that the GPU DPC VSync cadence follows a well behaved pattern. Fluctuations in GPU DPC Vysnc frequency, during media playback can result in glitches during media playback. The test criteria establishes that the cadence fluctuation should not exceed +/- 50% of the average VSync cadence window. For instance, in a 60 Hz monitor, the expected VSync DPC cadence is 16.666 ms; consequently the test will fail if any VSync DPC is fired within less that 8.3 ms from the previous one or later than 24.9 ms from the previous one. When the duration between two vsyncs is greater than 24.9ms, this often results in a perceivable video glitch. When the distance between two vsyncs is less than 8.3ms, this is often caused by the driver double firing vsyncs, or vsyncs that are a few microseconds (us) apart.

How to enable verbose ETW logging for analysis

To collect more verbose ETW logs, change the user-settable parameter 'DoFullLogging' to 'true' before running the tests.

How to preserve the ETW logs for analysis in case of failure

To preserve the ETW logs for failed test cases, change the user-settable parameter 'CopyLogsOnFailure' to 'true' before running the tests. This will also copy the ETW logs of failed test cases to the controller and be included as part of HLK package to be shared for investigation.

Using Media Experience Analyzer to analyze failed ETW logs

You can use Media Experience Analyzer (MXA) to analyze failed ETW logs. Download MXA from the following location:

  • http://www.microsoft.com/en-us/download/details.aspx?id=43105

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation
FrameCount | Minimum number of MF Events required during playback
MaxIsrDpcTime | Maximum ISR Dpc time in microseconds
MaxIsrDpcStorm | Maximum ISR Dpc Storm in microseconds
MaxIsrDpcLoop | Maximum ISR Dpc Loop time in microseconds
GlitchCount | Number of glitches acceptable during playback


Glitchfree Low-period Audio Capture test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a7a2601-da72-4631-9571-bd2a6808e80f

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The test verifies that a system is capable of capturing Low-Period Audio with no glitches during recording.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation


Glitchfree Low-period Audio Capture test under stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5bebd66b-b5a2-4278-88df-5579b348860d

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The test verifies that a system is capable of capturing Low-Period Audio with no glitches during recording under stress.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation


Glitchfree Low-period Audio Playback test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b732c24d-5e3b-4cd2-9580-a9318e0f7b8c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The test verifies that a system is capable of playing Low-Period Audio with no glitches during playback.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation


Glitchfree Low-period Audio Playback test under stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c29249d6-86e7-4b98-85b0-3c106cf9630b

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The test verifies that a system is capable of playing Low-Period Audio with no glitches during playback under stress.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation


Glitchfree Low-period Full-duplex Audio Playback & Capture test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4c6d68cd-cd62-41b4-ae87-8709d2fe5046

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The test verifies that a system is capable of playing Low-Period Audio and capturing it with no glitches during playback & recording

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation


Glitchfree Low-period Full-duplex Audio Playback & Capture test under stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50acc73d-11f8-4d92-90ae-aa32a9658288

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The test verifies that a system is capable of playing Low-Period Audio and capturing it with no glitches during playback & recording under stress.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation


Gyrometer Dynamic Range Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c492f1fd-195c-470c-aae2-a349104fb7fc

Verifies that the dynamic range for Gyrometer data fields are withing range

Test details
Specifications
  • System.Client.Sensor.Gyrometer.DynamicRange
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


KeDelayExecutionThread Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc56cc14-e239-40ff-b026-bb2a98ef9b1e

This KDET test calls the KeDelayExecutionThread() API from an affinitized thread in kernel mode. Calls are made in a tight loop and matching KeQueryPerformanceCounter calls are captured and analyzed here to determine the accuracy of the delay.

Test details
Specifications
  • System.Client.CPU.Compatibility
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 31
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Lamp Driver Color Intensity Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/498dfbd2-db8a-4186-911c-f14532beeb0f

Iterates through the different intensities of color for the Lamp Driver

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Lamp Driver Enumeration Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87906536-c0c5-4211-8613-282502fbb096

Enumerates the Lamp Driver on the system

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Lamp Driver On Off Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4cb15173-b4ac-40d7-87a1-998c7a752efe

Iterates through the On Off states of the Lamp Driver

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Lamp Driver PnP Notification Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8a0b307-d4c1-4593-8f86-aec0b88d0c75

Detects pre-empting of the Lamp Driver by the Camera Flash controls

Test details
Specifications
  • System.Client.Camera.Base.CameraControls
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Light Sensor Dynamic Range Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e78757f-63cc-4aac-810d-a3d572da9c91

Verifies that the dynamic range for Light Sensor data fields are withing range

Test details
Specifications
  • System.Client.Sensor.AmbientLightSensor.DynamicRange
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


MR Validation Kit Uploader

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad7c54db-b8f2-4e77-9595-f8af98e462b0

This test scans the target system for existing MR Validation Kit logs and surfaces them to the HLK.

Test details
Specifications
  • System.Client.MixedReality.Base
Platforms
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Benchmark
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


Magnetometer Dynamic Range Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ef54857-c8b7-40f2-a3c5-ef74e0217d75

Verifies that the dynamic range for Magnetometer data fields are withing range

Test details
Specifications
  • System.Client.Sensor.Magnetometer.DynamicRange
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WDKDeviceID | Device id of DUT

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Client additional documentation


Manual Test - Boot to desktop with debugger connection KDCOM-Serial

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/13d556d2-b7da-4490-8c6d-a22e38f054f4

This is a manual test & it should be run outside HLK by following the manual instructions provided below. I. Hardware Prerequisites

  1. Device under test
  2. Debug board
  3. Debugger cable II. Software Prerequisites
  4. Firmware, full OS
  5. WinDBG III. Setting up the Test
  6. On device under test, flash firmware, install full OS
  7. Run Config_KDCOM.bat file to enable serial mode debugging or run the following commands from an administrative command prompt on the device under test: bcdedit -set {default} debug on bcdedit -set {default} dbgtransport kdcom.dll bcdedit /dbgsettings serial baudrate:115200 debugport:1 bcdedit /enum {dbgsettings}
  8. Connect the debug board to the pc using debugger cable (micro usb) IV. Running the Test
  9. Open WinDBG on debugger machine & open a serial kernel debugger session
  10. Boot up the device using power button
  11. Check debugger session for output from device while it boots
  12. The device boots to desktop V. Verification
  13. Verify that the device boots to desktop with debugger session running

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Boot to desktop with no debugger connection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/24a305fe-50a2-4891-850d-fb555705dc45

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                        II. Software Prerequisites
                                            1.  Firmware & full OS
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware & install full OS
                                        IV. Running the Test
                                            1.  Boot up the device using power button with no debugger connection
                                        V.  Verification
                                            1.  Verify that the device boots to desktop
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Crash Dump Creation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78c0470b-eb53-4b4d-aeb9-a49cf615bb9d

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                        II. Software Prerequisites
                                            1.  Firmware & full OS
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware & install full OS
                                        IV. Running the Test
                                            1.  Power up the device with a KD session
                                            2.  Break into the debugger manually
                                            3.  Run .crash command from debugger to trigger a kernel mode crash
                                            4.  System will crash & reboot
                                            5.  Open this file: %SystemRoot%\MEMORY.DMP in windbg
                                            6.  Verify that the memory.dmp file is valid and shows crash data for:
                                                    MANUALLY_INITIATED_CRASH (e2)
                                                    The user manually initiated this crash dump.
                                        V.  Verification
                                            1.  Verify that a full memory dump file gets generated for kernel mode crashes
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Device must have a unique flashing ID in ffutool -list

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80d4756c-3cdc-4c62-ab69-9e11ad9a85ce

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: This is a basic test to ensure that the device reports a unique id for flashing. 1. Ensure 2 phones are booted into flashing mode 2. Run ffutool.exe -list for each of them separately 3. Check the ID for each phone in the output of ffutool.exe -list 4. Ensure that the IDs for each phone are unique --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Device must have a unique flashing ID in ffutool -list - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5094aed0-4b9d-4bdc-9222-8cb24d4c8129

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: This is a basic test to ensure that the device reports a unique id for flashing. 1. Ensure 2 phones are booted into flashing mode 2. Run ffutool.exe -list for each of them separately 3. Check the ID for each phone in the output of ffutool.exe -list 4. Ensure that the IDs for each phone are unique --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 80d4756c-3cdc-4c62-ab69-9e11ad9a85ce

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Display turns on

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/df9de962-1b49-4b6e-8160-281ebb4a9556

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                        II. Software Prerequisites
                                            1.  Firmware, full OS
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware, install full OS
                                        IV. Running the Test
                                            1.  Boot up the device using power button
                                            2.  Let the device boot to desktop
                                            3.  Check on screen display
                                        V.  Verification
                                            1.  Verify that display is functional & usable
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Firmware flashing using eMMC SW download tool

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e0c9e2fe-d64d-4a52-a218-ed459e700184

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Applicable to 8998 MTP hardware only
                                        II. Software Prerequisites
                                            1.  Emmcdl.exe tool
                                        III.    Setting up the Test
                                            1.  Boot the device into Emergency Download mode (EDL)
                                                i. Either device has to have an empty EMMC (out of box or JTAG wiped)
                                                ii. Or use jumper # 6 in S4 on debug board to force device into EDL mode
                                                iii. Or enter EDL mode using UEFI menu at boot
                                                iv. There will be no indication that the device is on (dark display)
                                        IV. Running the test
                                            1.  Attach the device to host PC using a regular USB cable. The device should enumerate as Qualcomm HS - USB QDLoader endpoint on a COM port
                                            2.From an administrative command prompt, run the  following commands:
                                                emmcdl - p COMxx - f prog_ufs_firehose_8998_ddr.elf - memoryname ufs - x rawprogram0.xml
                                                emmcdl - p COMxx - f prog_ufs_firehose_8998_ddr.elf - memoryname ufs - x rawprogram1.xml
                                                emmcdl - p COMxx - f prog_ufs_firehose_8998_ddr.elf - memoryname ufs - x rawprogram2.xml
                                                emmcdl - p COMxx - f prog_ufs_firehose_8998_ddr.elf - memoryname ufs - x rawprogram3.xml
                                                emmcdl - p COMxx - f prog_ufs_firehose_8998_ddr.elf - memoryname ufs - x rawprogram4.xml
                                                emmcdl - p COMxx - f prog_ufs_firehose_8998_ddr.elf - memoryname ufs - x rawprogram5.xml
                                        V.Verification
                                            1.Flashing should complete successfully, all commands should exit with "Status: 0 The operation complete successfully"
                                        VI.Post Test
                                            1.Clear UEFI BS & RT variables
                                            2.Set Boot from USB to enabled in UEFI menu
                                            3.Enable USB Host mode from UEFI menu
                                      ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - IPoverUSB

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9f6c982b-3f43-495c-b69f-7ef5c2b3fe85

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: IP Over USB is a transport that can be used for TShell, Telnet, User Mode Debugger, and other engineering TCP based tools. 1. Make sure you have KDNet disabled in your phone (SelfHost images have the right configuration by default, Test images don't). To do this, boot the phone in mass storage mode and run "cfgdbg /D". 2. Verify you have the latest TShell and the latest engineering IP Over USB installed (both available in WP Blue Jumpstart) 3. Attach and unlock the phone (enter your PIN) 4. Open a connection to the device like this: open-device 127.0.0.1 (This assumes you have only one device attached to the PC, for using multiple devices at the same time with TShell you need WPCups.exe running and connect using the phone's GUID) 5. Run ipoverusbenum.exe. The Ipoverusbenum.exe output should look something like this: Partner: Container Id: FED9822C-003D-545E-9C24-D52DAF3321E9 Instance: USB\VID_045E&PID_F0CA&MI_01\6&F2A597C&0&0001 Name: RM-820|Nokia Lumia 920 Guid: 00000011-21E1-1653-0000-000000000000 Partner Services listening at ports: DebugOutput 8878 -> 127.0.0.1:8878 Debugger 8888 -> 127.0.0.1:8888 SocksProxy 1080 - SOCKS Telnet 1023 -> 127.0.0.1:23 VSDebugger 4016 -> 127.0.0.1:4016 WPCon 29817 -> 127.0.0.1:29817 WPConProtocol2 29820 -> 127.0.0.1:29820 WPConTCPPing 29819 -> 127.0.0.1:29819 WpPerfMon 8889 -> 127.0.0.1:8889 --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - IPoverUSB - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0eab2250-2e48-407b-9d20-756ae1a7ae28

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: IP Over USB is a transport that can be used for TShell, Telnet, User Mode Debugger, and other engineering TCP based tools. 1. Make sure you have KDNet disabled in your phone (SelfHost images have the right configuration by default, Test images don't). To do this, boot the phone in mass storage mode and run "cfgdbg /D". 2. Verify you have the latest TShell and the latest engineering IP Over USB installed (both available in WP Blue Jumpstart) 3. Attach and unlock the phone (enter your PIN) 4. Open a connection to the device like this: open-device 127.0.0.1 (This assumes you have only one device attached to the PC, for using multiple devices at the same time with TShell you need WPCups.exe running and connect using the phone's GUID) 5. Run ipoverusbenum.exe. The Ipoverusbenum.exe output should look something like this: Partner: Container Id: FED9822C-003D-545E-9C24-D52DAF3321E9 Instance: USB\VID_045E&PID_F0CA&MI_01\6&F2A597C&0&0001 Name: RM-820|Nokia Lumia 920 Guid: 00000011-21E1-1653-0000-000000000000 Partner Services listening at ports: DebugOutput 8878 -> 127.0.0.1:8878 Debugger 8888 -> 127.0.0.1:8888 SocksProxy 1080 - SOCKS Telnet 1023 -> 127.0.0.1:23 VSDebugger 4016 -> 127.0.0.1:4016 WPCon 29817 -> 127.0.0.1:29817 WPConProtocol2 29820 -> 127.0.0.1:29820 WPConTCPPing 29819 -> 127.0.0.1:29819 WpPerfMon 8889 -> 127.0.0.1:8889 --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 9f6c982b-3f43-495c-b69f-7ef5c2b3fe85

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Keyboard works in UEFI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3c23ef6b-828d-4b19-af02-5b7ad95a3519

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Applicable to 8998 MTP hardware only
                                            2.  USB hub
                                            3.  USB Keyboard
                                        II. Software Prerequisites
                                            1.  UEFI firmware files
                                        III.    Setting up the Test
                                            1.  In a powered down state, connect device to USB hub with USB keyboard
                                        IV. Running the Test
                                            1.  Press power button + volume up key on device to enter UEFI
                                            2.  Use the keyboard to navigate through the items in UEFI menu using up/down & enter keys
                                        V.  Verification
                                            1.  Verify that USB keyboard can be used in UEFI to select & modify UEFI variables
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - LAN Connectivity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8dfc7a7-e340-4011-b9a9-c2ab09c49cb0

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                            2.  USB Ethernet adapter with Ethernet cable
                                        II. Software Prerequisites
                                            1.  Firmware, full OS
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware, install full OS
                                            2.  Connect USB Ethernet adapter to USB hub connected to device
                                        IV. Running the Test
                                            1.  Boot up the device using power button
                                            2.  Let the device boot to desktop
                                            3.  Go to Start Menu\Settings\Network & Internet\Wi-Fi\Set Wi-Fi slider to Off
                                            4.  Check the network connectivity status icon in system tray for an active wired connection
                                            5.  Launch edge app & browse to www.msn.com
                                            6.  Open command prompt and ping www.msn.com
                                        V.  Verification
                                            1.  Network connection icon should show wired connection available
                                            2.  Edge should launch msn.com or ping responses should be successful
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Power ON Power OFF Shutdown Reboot

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/433a1382-6b2b-467b-91b5-e903774024ff

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                        II. Software Prerequisites
                                            1.  Firmware & full OS
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware & install full OS
                                        IV. Running the Test
                                            1.  Power up the device using power button
                                            2.  Verify that device boots to desktop
                                            3.  Shutdown the device 3 times using the following methods:
                                                a)  Start Menu\Power Button\Shut Down
                                                b)  Shutdown /s from an admin command prompt window
                                            4.  Verify that the device shuts down
                                            5.  Reboot the device 3 times using the following methods:
                                                a)  Start Menu\Power Button\Restart
                                                b)  Shutdown.exe /r /t 0 from an admin command prompt window
                                            c)  .reboot command from kernel debugger session
                                        V.  Verification
                                            1.  Verify that the device is able to power up, shutdown & reboot
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Remote User mode Debugging - Native

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ceda1f3-6ccb-4991-8892-b0bccaf9c275

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                            2.  USB-Ethernet (2.0) adapter
                                            3.  IP Network connectivity via Ethernet
                                        II. Software Prerequisites
                                            1.  Windows Desktop (x86/amd64) - with windbg installed
                                            2.  Firmware & full OS
                                            3.  mwdbgsrv.exe  - location of binary  <Kits_Root>\EnterpriseWDK_Dev14\Program Files\WindowsKits\10\MSPackages\Merged\arm64\fre\Microsoft.MS_MWDBGSRV.MSN.MainOS.cab
                                            4.  Extract and copy the standalone binary onto the desktop device into some temp directory
                                        III.Setting up the Test
                                            1.On device under test, flash firmware & install full OS
                                            2.Open Admin command prompt
                                            3.Run ipconfig.and note the ip - address of the Ethernet network card
                                            4.In Admin command prompt
                                                a)  Go to directory where mwdbgsrv.exe was installed
                                                b)  Run mwdbgsrv -t tcp:port=8888
                                        IV.Running the Test
                                            1.  On the Windows Desktop x86/amd64 machine run
                                            2.  windbg -premote tcp:server=<ip-address of DUT-ethernet adapter>, port=8888
                                            3.  windbg -premote tcp:server==<ip-address of DUT-ethernet adapter>, port=8888 c:\windows\system32\xcopy.exe(or any test executable)
                                        V.Verification
                                            1.  Windbg should come up
                                                a)  Navigate to File Menu
                                                b)  Select "Attach to Process"
                                                c)  You should see list of user-mode processes to attach to
                                                d)  Attach to some process
                                            2.  Windbg should come up and begin running user mode test-app and breaks on load

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - SOC Drivers Hal Extensions and Subsystem image loading

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c7ecd4fe-29bc-4fad-9779-078520bb7ebb

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                        II. Software Prerequisites
                                            1.  List of devnodes that failed from previous test pass
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware & install full OS
                                        IV. Running the Test
                                            1.  Power up the device with a KD session
                                            2.  Break into the debugger manually
                                            3.  Run !pnptriage and note the "Dumping dev-nodes with problems"
                                        V.  Verification
                                            1.  First eliminate all devnodes that failed with error 0xc0000490 (CM_PROB_FAILED_INSTALL). These should NOT be considered
                                            2.  Look at all other devnodes that failed
                                            3.  Test fails if
                                                a)  Devnode was not seen in previous BSP
                                                b)  Devnode not failure cannot be justified and/or is unknown
                                            4.  Record list of devnodes that failed for next/subsequent test pass
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Test USB Keyboard and Mouse Functionality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a90acbe-e5ab-4e23-b0ad-37a153e74334

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                            2.  USB hub
                                            3.  USB keyboard
                                            4.  USB Mouse
                                        II. Software Prerequisites
                                            1.  Firmware, full OS
                                        III.    Setting up the Test
                                            1.  Plugin a USB hub with USB keyboard & Mouse to the device under test
                                            2.  On device under test, flash firmware, install full OS
                                            3.  Plugin
                                            4.  Connect the debug board to the pc using debugger cable (micro usb)
                                        IV. Running the Test
                                            1.  Open WinDBG on debugger machine & open a serial kernel debugger session
                                            2.  Boot up the device using power button
                                            3.  Check debugger session for output from device while it boots
                                            4.  Let the device boot to desktop
                                        V.  Verification
                                            1.  Verify that USB keyboard & mouse is working in full OS
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - The device can run on a fully charged battery power for at least 30 min

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dde25b2c-e48c-4a41-a954-ee54b3e17f41

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: This is a basic test to ensure that there is no unexpected battery drain. 1. Insert a fully charged battery 2. The phone should be usable & remain booted for at least 30 minutes --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - The device can run on a fully charged battery power for at least 30 min - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4557e4d6-622b-4df7-b202-08c66bb68f32

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: This is a basic test to ensure that there is no unexpected battery drain. 1. Insert a fully charged battery 2. The phone should be usable & remain booted for at least 30 minutes --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid dde25b2c-e48c-4a41-a954-ee54b3e17f41

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Tshell over KDNET

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c29461da-08c4-4ddd-a22a-6b0b3b3eabd9

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: The Texus Shell (TShell) is a tool that allows users to interact with Windows Phone devices via a PowerShell command prompt or script. This includes running commands in the device command interpreter, copying files, executing processes, and attaching a debugger. This document does not cover installation of TShell. (It should have been installed as part of the HLK.) In order for TShell to connect to a physical device, the device needs to have an ethernet connection established which TShell can use to communicate with it. To boot an image on a physical device with an ethernet connection, you must set up a KDNet connection. To set up KDNet, ensure that the network your PC is on has an active DHCP server, and then: 1. Boot the device in mass storage mode. 2. Run 'cfgdbg /N:1.2.3.4' (replace 1.2.3.4 with the IP address of your PC) 3. Ensure Virtual Ethernet (virteth.exe) is running on your PC. 4. Reboot the device. 5. FFutool -skip 6. You should see some lines appear on the Virtual Ethernet console indicating that your device is connected. On the device, if you navigate to Settings/About, you will be able to see its IP address, allocated from the DHCP server. a. Note: If Virtual Ethernet crashes immediately, ensure that no more than one PC network interface has "Virtual Machine Network Services" enabled, and try running Virtual Ethernet again and reboot the device. Now you can run TShell commands. Once it has fully booted, use the open-device command to connect to it. PS C:\> open-device 10.xx.xx.xx Now, ensure that commands can be run: PS C:\> cmd-device dir C:\test Finally, close the connection. PS C:\> close-device --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Tshell over KDNET - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/97b3a80c-fe44-4984-979b-8594962df9be

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: The Texus Shell (TShell) is a tool that allows users to interact with Windows Phone devices via a PowerShell command prompt or script. This includes running commands in the device command interpreter, copying files, executing processes, and attaching a debugger. This document does not cover installation of TShell. (It should have been installed as part of the HLK.) In order for TShell to connect to a physical device, the device needs to have an ethernet connection established which TShell can use to communicate with it. To boot an image on a physical device with an ethernet connection, you must set up a KDNet connection. To set up KDNet, ensure that the network your PC is on has an active DHCP server, and then: 1. Boot the device in mass storage mode. 2. Run 'cfgdbg /N:1.2.3.4' (replace 1.2.3.4 with the IP address of your PC) 3. Ensure Virtual Ethernet (virteth.exe) is running on your PC. 4. Reboot the device. 5. FFutool -skip 6. You should see some lines appear on the Virtual Ethernet console indicating that your device is connected. On the device, if you navigate to Settings/About, you will be able to see its IP address, allocated from the DHCP server. a. Note: If Virtual Ethernet crashes immediately, ensure that no more than one PC network interface has "Virtual Machine Network Services" enabled, and try running Virtual Ethernet again and reboot the device. Now you can run TShell commands. Once it has fully booted, use the open-device command to connect to it. PS C:\> open-device 10.xx.xx.xx Now, ensure that commands can be run: PS C:\> cmd-device dir C:\test Finally, close the connection. PS C:\> close-device --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid c29461da-08c4-4ddd-a22a-6b0b3b3eabd9

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - User mode debugging

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36a632bb-d13b-44bd-b838-f7c3b97d5838

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Prerequisite: "Tshell over KDNET" works. Once you've verified basic TShell commands, do the following: 1. Run "debugd" 2. Windbg should pop up 3. Open random process 4. Try breaking in --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - User mode debugging - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/802e7570-c4e3-491b-83f8-6f82ba4751f2

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Prerequisite: "Tshell over KDNET" works. Once you've verified basic TShell commands, do the following: 1. Run "debugd" 2. Windbg should pop up 3. Open random process 4. Try breaking in --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 36a632bb-d13b-44bd-b838-f7c3b97d5838

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify Full OS Installation by Booting from USB Disk

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/75bb35cf-18e0-4912-b789-f90402313863

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Applicable to 8998 MTP hardware only
                                            2.  USB hub
                                            3.  USB flash drive
                                            4.  Keyboard, mouse & USB Ethernet adapter
                                        II. Software Prerequisites
                                            1.  Prepare USB flash drive with WinPE &  Full OS for installation
                                        III.    Setting up the Test
                                            1.  In a powered down state, connect device to USB hub with keyboard, mouse, USB flash drive and USB Ethernet
                                        IV. Running the Test
                                            1.  Press power button on device
                                            2.  Device will boot from USB flash drive
                                            3.  Device should boot into WinPE
                                            4.  Verify that the USB keyboard, mouse & display work in WinPE
                                            5.  Open a command prompt using Shift + F10 shortcut key from keyboard
                                            6.  Run disk part command
                                            7.  Run LIST VOL command
                                            8.  Identify the partition letter assigned for USB flash drive
                                            9.  Type exit to come out of disk part
                                            10. Type <Drive Letter>: to switch to USB flash drive
                                            11. Run TotalUpdate.bat file from USB flash drive partition
                                            12. Full OS imaging should complete
                                            13. Verify that the output of the bat file mentions imaging completed successfully.
                                            14. Run Configure_KDCOM.bat file from USB flash drive partition
                                            15. Verify that the commands complete successfully
                                            16. Close the command window and any other open window which will reboot the device
                                            17. After shutdown, remove the usb flash drive from usb hub and the device should start Full OS installation
                                            18. Verify that the device boots to desktop after completion of Full OS installation
                                        V.  Verification
                                            1.  USB peripherals work as expected in WinPE
                                            2.  Device is able to install and boot to Full OS from WinPE
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Verify basic UEFI shell functionality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbee905d-663f-423d-88ed-d31cab46bcdb

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Install serial comm application (for example putty.exe from http://www.putty.org) 2. Hook the device up to a serial debug connection. 3. Hold down '+' and Camera button to go to UEFI menu 4. Navigate to Select "Enter Shell" (9) using '-' button. 5. Connect to device using Putty.exe 6. From putty, run command "memmap" 7. Verify memory map output is shown in putty.exe as well as on phone screen. a. Memmap summary should be in following format though values will be different: Reserved : 27,622 Pages (113,139,712) LoaderCode: 213 Pages (872,448) LoaderData: 0 Pages (0) BS_Code : 362 Pages (1,482,752) BS_Data : 4,772 Pages (19,546,112) RT_Code : 40 Pages (163,840) RT_Data : 31 Pages (126,976) ACPI Recl : 10 Pages (40,960) ACPI NVS : 1 Pages (4,096) MMIO : 3 Pages (12,288) Available : 229,093 Pages (938,364,928) Total Memory: 1024 MB (1,073,754,112 Bytes) --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify basic UEFI shell functionality - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d54a7a57-dff7-46aa-a1f9-df7065b28b95

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Install serial comm application (for example putty.exe from http://www.putty.org) 2. Hook the device up to a serial debug connection. 3. Hold down '+' and Camera button to go to UEFI menu 4. Navigate to Select "Enter Shell" (9) using '-' button. 5. Connect to device using Putty.exe 6. From putty, run command "memmap" 7. Verify memory map output is shown in putty.exe as well as on phone screen. a. Memmap summary should be in following format though values will be different: Reserved : 27,622 Pages (113,139,712) LoaderCode: 213 Pages (872,448) LoaderData: 0 Pages (0) BS_Code : 362 Pages (1,482,752) BS_Data : 4,772 Pages (19,546,112) RT_Code : 40 Pages (163,840) RT_Data : 31 Pages (126,976) ACPI Recl : 10 Pages (40,960) ACPI NVS : 1 Pages (4,096) MMIO : 3 Pages (12,288) Available : 229,093 Pages (938,364,928) Total Memory: 1024 MB (1,073,754,112 Bytes) --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid dbee905d-663f-423d-88ed-d31cab46bcdb

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify data in single ATT sim configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/91934733-9b71-4163-be41-1d8674e796ba

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Open up www.bing.com and search for "penguins" --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify data in single ATT sim configuration - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f61380c-b53a-4dcc-926f-0ae57a539a1b

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Open up www.bing.com and search for "penguins" --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 91934733-9b71-4163-be41-1d8674e796ba

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify device boots to home screen with KDNet over USB

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8424cf29-e2b4-4060-bb90-4ea503ce704b

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. BcdEdit.exe or cfgdbg.bat batch file. Before: 1. Put device in mass storage mode Do: 1. Configure device for KDNet over USB debugging: If using cfgdbg.bat, run the following commands cfgdbg.bat /N <MountDrive> cfgdbg.bat /N:<HostIP> If using bcdedit, run the following commands to configure the device: bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -dbgsettings net HOSTIP:<host ip> PORT:50000 KEY:1.2.3.4 bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} debug on bcdedit /store <MountDrive>\ EFIESP\efi\Microsoft\Boot\BCD -set {default} dbgtransport kdnet.dll bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {dbgsettings} busparams 1 2. Start windbg on host machine and connect using port 50000 and key = 1.2.3.4 3. Start VirthEth.exe on the host machine 4. Boot device 5. Verify device is enumerated by VirtEth.exe 6. Verify debug spew appears in windbg 7. Verify device boots to tiles successfully --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify device boots to home screen with KDNet over USB - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac55d3ba-d115-4eac-9010-c56bb9923908

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. BcdEdit.exe or cfgdbg.bat batch file. Before: 1. Put device in mass storage mode Do: 1. Configure device for KDNet over USB debugging: If using cfgdbg.bat, run the following commands cfgdbg.bat /N <MountDrive> cfgdbg.bat /N:<HostIP> If using bcdedit, run the following commands to configure the device: bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -dbgsettings net HOSTIP:<host ip> PORT:50000 KEY:1.2.3.4 bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} debug on bcdedit /store <MountDrive>\ EFIESP\efi\Microsoft\Boot\BCD -set {default} dbgtransport kdnet.dll bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {dbgsettings} busparams 1 2. Start windbg on host machine and connect using port 50000 and key = 1.2.3.4 3. Start VirthEth.exe on the host machine 4. Boot device 5. Verify device is enumerated by VirtEth.exe 6. Verify debug spew appears in windbg 7. Verify device boots to tiles successfully --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 8424cf29-e2b4-4060-bb90-4ea503ce704b

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify device boots to home screen with KDUSB connection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fcc01ddb-869a-4a52-9a39-3fa808b59095

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. BcdEdit.exe or cfgdbg.bat batch file. Before: 1. Put device in mass storage mode Do: 1. Configure device for KDUSB debugging If using cfgdbg, run the following command: cfgdbg.bat /U If using bcdedit, run the following commands: bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -dbgsettings usb targetname:woatarget bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} debug on bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} dbgtransport kdusb.dll 2. Start windbg on host machine and connect with targetname as woatarget 3. Boot device 4. Verify debug spew appears in windbg 5. Verify device boots to tiles successfully --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify device boots to home screen with KDUSB connection - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/598bfa49-76ae-4604-9b3d-949ab0756f24

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. BcdEdit.exe or cfgdbg.bat batch file. Before: 1. Put device in mass storage mode Do: 1. Configure device for KDUSB debugging If using cfgdbg, run the following command: cfgdbg.bat /U If using bcdedit, run the following commands: bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -dbgsettings usb targetname:woatarget bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} debug on bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} dbgtransport kdusb.dll 2. Start windbg on host machine and connect with targetname as woatarget 3. Boot device 4. Verify debug spew appears in windbg 5. Verify device boots to tiles successfully --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid fcc01ddb-869a-4a52-9a39-3fa808b59095

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify device is able to boot to home screen with no debugger connection

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/078b76e4-bc1f-4264-85b8-bf3888a7c39c

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. BcdEdit.exe or cfgdbg.bat batch file. Before: 1. Put device in mass storage mode Do: 1. Disable debugging on the device If using cfgdbg, run the following command: cfgdbg.bat /D If using bcdedit, run the following command: bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} debug off 2. Boot device 3. Verify device boots to tiles successfully --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify device is able to boot to home screen with no debugger connection - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79e7ded6-7ed0-4b06-8eaa-9368b75ac6af

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. BcdEdit.exe or cfgdbg.bat batch file. Before: 1. Put device in mass storage mode Do: 1. Disable debugging on the device If using cfgdbg, run the following command: cfgdbg.bat /D If using bcdedit, run the following command: bcdedit /store <MountDrive>\EFIESP\efi\Microsoft\Boot\BCD -set {default} debug off 2. Boot device 3. Verify device boots to tiles successfully --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 078b76e4-bc1f-4264-85b8-bf3888a7c39c

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify eMMC is enumerated in mass storage mode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e48ac04-c2c7-4dcd-afba-c72e23dfb65e

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Make sure the device is powered off and all the DIP switches on the debug board are in the OFF position. Note that you do not need a debug board to put the device in MSM. 2. If you're using KDSERIAL, disconnect the serial cable or close WinDbg as it interferes with mass storage hotkeys. 3. Position the phone on the debug board and plug in power but do not press the power key on the device or the debug board. 4. Plug in the micro-USB cable into the USB2 portion of the USB3 port. This acts as a wake event for the device. 5. Press and hold the Vol+ and the Camera buttons down during UEFI boot. This should bring up UEFI BDS menu. 6. The device should reboot into mass storage mode and a new physical disk would appear in the disk manager (diskmgmt.msc). NOTE: Common mistake: Device would neither auto power on nor enter mass storage mode if the micro-USB cable is inserted into USB2 port. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify eMMC is enumerated in mass storage mode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/76b388f9-e01f-45b1-9e1b-2a517bb07de5

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Applicable to 8998 MTP hardware only
                                            2.  USB Type C cable
                                        II. Software Prerequisites
                                            1.  Flashed Device
                                        III.    Setting up the Test
                                            1.  Enter UEFI menu and disable USB Host mode
                                        IV. Running the Test
                                            1.  Connect device to a PC directly using USB C cable
                                            2.  Press power button + volume up key on device to enter UEFI
                                            3.  Use the volume up & volume down buttons to navigate through the items in UEFI menu
                                            4.  Select USB Mass Storage mode
                                            5.  Select Data Partition under LUN 0
                                            6.  Mount selected partition
                                            7.  Open explorer on PC and look for the new mounted partition
                                        V.  Verification
                                            1. Verify that EMMC UFC storage partition is visible after entering USB mass storage mode
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Manual Test - Verify eMMC is enumerated in mass storage mode - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ad6bc2c1-1944-43b1-b47e-6f554a9d609a

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Make sure the device is powered off and all the DIP switches on the debug board are in the OFF position. Note that you do not need a debug board to put the device in MSM. 2. If you're using KDSERIAL, disconnect the serial cable or close WinDbg as it interferes with mass storage hotkeys. 3. Position the phone on the debug board and plug in power but do not press the power key on the device or the debug board. 4. Plug in the micro-USB cable into the USB2 portion of the USB3 port. This acts as a wake event for the device. 5. Press and hold the Vol+ and the Camera buttons down during UEFI boot. This should bring up UEFI BDS menu. 6. The device should reboot into mass storage mode and a new physical disk would appear in the disk manager (diskmgmt.msc). NOTE: Common mistake: Device would neither auto power on nor enter mass storage mode if the micro-USB cable is inserted into USB2 port. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 3e48ac04-c2c7-4dcd-afba-c72e23dfb65e

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify FFU image flashing using FFUTool

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e7529cb-f8f4-4414-bccc-46ef28818568

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1.Software Prerequisites a.ffutool.exe 2.Setting up the Test a.From a powered down state, press the power button, release it, and immediately as the phone boots hold the Volume Up button.Wait until the phone displays a graphical image containing a lightning bolt and a gear. 3.Running the Test a.Connect the phone to the PC using a USB cable.If all is well, you should see a "QUALCOMM MSM DEVICE" device(or "WinUsb Device") in Device Manager. b.Open a command window with Administrator privileges. c.Run the following command from the directory where ffutool.exe is located.You should include the complete path to the location of the flash.ffu file that you want to install: ffutool.exe - flash \\< PATH_TO_FLASH.FFU_FILE >\flash.ffu d.Console output will indicate when flashing is complete. e.Verify: The device should automatically boot to the main OS. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify FFU image flashing using FFUTool - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ea034a6a-37d8-4940-a3a8-93e71f455f83

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1.Software Prerequisites a.ffutool.exe 2.Setting up the Test a.From a powered down state, press the power button, release it, and immediately as the phone boots hold the Volume Up button.Wait until the phone displays a graphical image containing a lightning bolt and a gear. 3.Running the Test a.Connect the phone to the PC using a USB cable.If all is well, you should see a "QUALCOMM MSM DEVICE" device(or "WinUsb Device") in Device Manager. b.Open a command window with Administrator privileges. c.Run the following command from the directory where ffutool.exe is located.You should include the complete path to the location of the flash.ffu file that you want to install: ffutool.exe - flash \\< PATH_TO_FLASH.FFU_FILE >\flash.ffu d.Console output will indicate when flashing is complete. e.Verify: The device should automatically boot to the main OS. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 7e7529cb-f8f4-4414-bccc-46ef28818568

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify graceful shutdown functionality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbeaa647-30fa-4601-812c-53a38df00ca3

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Open up TSHELL over KDNET (wiki) 2. Run "cmdd shutdown /r /t 0" 3. Hang? Bugcheck? That's a fail. The phone should reboot cleanly. Double check in debugger output. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify graceful shutdown functionality - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0628591-283f-40dd-85c0-c12551c778ab

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Open up TSHELL over KDNET (wiki) 2. Run "cmdd shutdown /r /t 0" 3. Hang? Bugcheck? That's a fail. The phone should reboot cleanly. Double check in debugger output. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid dbeaa647-30fa-4601-812c-53a38df00ca3

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify MO phone call in single ATT sim configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7109167-59a6-40c2-9b86-ad3fae0d4eb5

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Make a call FROM the phone. Make sure audio works both ways --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify MO phone call in single ATT sim configuration - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82015583-93a8-4d7a-8423-05bb084abc6f

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Make a call FROM the phone. Make sure audio works both ways --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid d7109167-59a6-40c2-9b86-ad3fae0d4eb5

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify MT phone call in single ATT sim configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f902f113-9203-40e7-9388-2979488bbf29

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Make a call TO the phone. Make sure audio works both ways --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify MT phone call in single ATT sim configuration - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/50c861f2-cb71-462e-8c9e-86b40a1f93fd

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Make a call TO the phone. Make sure audio works both ways --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid f902f113-9203-40e7-9388-2979488bbf29

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify online Crashdump functionality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e5b99b4-35d0-4d0a-85f6-3db3c399aacf

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Under windbg: 1. Run ".crash" 2. Make sure the dump is stored on emmc at location pointed to by HKLM\SYSTEM\controlset001\control\crashcontrol\dedicateddump 3. Get the dump from the device and open it with windbg. Make sure it is consistent. For debug if needed: 1. [HKEY_LOCAL_MACHINE\.System\ControlSet001\Control\Session Manager\Debug Print Filter]\DEFAULT = dword:ffffffff 2. [HKEY_LOCAL_MACHINE\.System\ControlSet001\Control\Session Manager\Debug Print Filter]\CRASHDUMP = dword:FFFFFFFF --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify online Crashdump functionality - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0f141f09-65f5-4dc0-ab4a-48805187d93a

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Under windbg: 1. Run ".crash" 2. Make sure the dump is stored on emmc at location pointed to by HKLM\SYSTEM\controlset001\control\crashcontrol\dedicateddump 3. Get the dump from the device and open it with windbg. Make sure it is consistent. For debug if needed: 1. [HKEY_LOCAL_MACHINE\.System\ControlSet001\Control\Session Manager\Debug Print Filter]\DEFAULT = dword:ffffffff 2. [HKEY_LOCAL_MACHINE\.System\ControlSet001\Control\Session Manager\Debug Print Filter]\CRASHDUMP = dword:FFFFFFFF --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 5e5b99b4-35d0-4d0a-85f6-3db3c399aacf

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify OS Battery Charging

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f17d53ef-7bd5-484c-960e-3db90e0d3570

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. Battery with copper tape attached 2. Multimeter Before: 1. Measure battery charge level using multimeter Do: 1. Make sure the phone is OFF AC power supply 2. Make sure the battery is somewhat depleted 3. Insert battery and attach multimeter to copper tape 4. Hook the phone to USB 5. Turn device on 6. When booted in OS, measure current a. If > noise/precision level PASS b. Otherwise FAIL After: 1. Measure battery charge level using multimeter 2. Compare with measurement taken before charging --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify OS Battery Charging - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a81dcf4-2040-46e7-883d-d6eac52e9986

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. Battery with copper tape attached 2. Multimeter Before: 1. Measure battery charge level using multimeter Do: 1. Make sure the phone is OFF AC power supply 2. Make sure the battery is somewhat depleted 3. Insert battery and attach multimeter to copper tape 4. Hook the phone to USB 5. Turn device on 6. When booted in OS, measure current a. If > noise/precision level PASS b. Otherwise FAIL After: 1. Measure battery charge level using multimeter 2. Compare with measurement taken before charging --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid f17d53ef-7bd5-484c-960e-3db90e0d3570

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify power on and power off

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/58a43457-bb28-466a-918b-f7570c54ff26

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: This is a basic test to ensure that the power button works. 1. Ensure the phone is OFF. 2. Boot the phone using the power button. Does it turn on? 3. Turn off the phone using the power button. Does it turn off? --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify power on and power off - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c68a5585-06e1-4ded-a90b-06c861b2491b

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: This is a basic test to ensure that the power button works. 1. Ensure the phone is OFF. 2. Boot the phone using the power button. Does it turn on? 3. Turn off the phone using the power button. Does it turn off? --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 58a43457-bb28-466a-918b-f7570c54ff26

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify SBL based offline Crashdump functionality triggered by long power button press

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/854d68fb-09d2-4696-8d47-ca282daa319d

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. This functionality is not supported by all SOC's. Check with SOC Vendor to ensure this is supported on SOC under test 2. Boot device to tiles 3. Press and hold power button for 10 seconds 4. Verify LED is blinking indicating device is collecting Offline crashdump 5. After collecting crashdump, device boots to tiles 6. Copy dump from the device and verify it is valid --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify SBL based offline Crashdump functionality triggered by long power button press - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/074b58d0-7d87-4cad-bfc6-4bbed7d47b76

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. This functionality is not supported by all SOC's. Check with SOC Vendor to ensure this is supported on SOC under test 2. Boot device to tiles 3. Press and hold power button for 10 seconds 4. Verify LED is blinking indicating device is collecting Offline crashdump 5. After collecting crashdump, device boots to tiles 6. Copy dump from the device and verify it is valid --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 854d68fb-09d2-4696-8d47-ca282daa319d

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify touch functionality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b40a6716-05c4-4969-83dc-b4efeb4fc686

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Complete Task 265240 [HLK Onboarding] Boot to Tile 2. Verify that basic touch functionalities work a. Swipe up and down b. Swipe left and right c. Tap to start an application d. Tap and hold tile on start screen e. Tap and hold text to select it f. Etc. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify touch functionality - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b30361fd-ebae-4693-ab0c-d25d654674ca

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: 1. Complete Task 265240 [HLK Onboarding] Boot to Tile 2. Verify that basic touch functionalities work a. Swipe up and down b. Swipe left and right c. Tap to start an application d. Tap and hold tile on start screen e. Tap and hold text to select it f. Etc. --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid b40a6716-05c4-4969-83dc-b4efeb4fc686

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify UEFI battery charging

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c324285-23fe-475d-a61d-b620908c007a

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. Battery with copper tape attached 2. Multimeter Before: 1. Measure battery charge level using multimeter Do: 1. Make sure the phone is OFF AC power supply 2. Make sure the battery is depleted 3. Insert battery and attach multimeter to copper tape 4. Hook the phone to USB 5. Turn device on 6. When in UEFI battery app (should see just a battery logo on screen) 7. Measure current a. If > noise/precision level PASS b. Otherwise FAIL After: 1. Measure battery charge level using multimeter 2. Compare with measurement taken before charging --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify UEFI battery charging - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc8073b2-0da4-48c4-b8d3-26a038db8185

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Need: 1. Battery with copper tape attached 2. Multimeter Before: 1. Measure battery charge level using multimeter Do: 1. Make sure the phone is OFF AC power supply 2. Make sure the battery is depleted 3. Insert battery and attach multimeter to copper tape 4. Hook the phone to USB 5. Turn device on 6. When in UEFI battery app (should see just a battery logo on screen) 7. Measure current a. If > noise/precision level PASS b. Otherwise FAIL After: 1. Measure battery charge level using multimeter 2. Compare with measurement taken before charging --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 1c324285-23fe-475d-a61d-b620908c007a

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify WLAN connectivity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/27e4579c-c427-417c-8707-035ba1111b48

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Make sure Settings->cellular->Data connection is turned off. 1. Ensure device MAC address is provisioned 2. Connect to an open network 3. Open up www.bing.com and search for "otters" 4. Verify search returns results --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - Verify WLAN connectivity - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8bf85575-e7c2-41a4-b730-0fce2e8de4b8

This is a manual test & it should be run outside HLK by following the manual instructions provided below. If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality. --------------------------------------------------------------------------------------------------------- Manual instructions to run this test: Make sure Settings->cellular->Data connection is turned off. 1. Ensure device MAC address is provisioned 2. Connect to an open network 3. Open up www.bing.com and search for "otters" 4. Verify search returns results --------------------------------------------------------------------------------------------------------- Note: This test is associated with an optional feature: System.Client.MobileHardware. It will not appear in the list of tests in HLK studio for a system target by default. Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps: 1] In HLK Studio, select system target 2] Right click on the selected system target 3] Click on Add\Modify Features 4] A Device Feature List window will open up 5] Scroll down to select the feature named: System.Client.MobileHardware 6] Click on the check box to enable this optional feature 7] This test will now appear in the list of applicable tests for the selected system target in HLK studio - This test is a WoW64 for ARM64 version of test guid 27e4579c-c427-417c-8707-035ba1111b48

Test details
Specifications
  • System.Client.MobileHardware.BasicFunctionality
Platforms
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Manual Test - WLAN Connectivity

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b567b628-7c13-4ae1-b057-52ed5a8de2a3

This is a manual test & it should be run outside HLK by following the manual instructions provided below.

If this test is run as an automated test from HLK studio/controller, the test will pass by default without testing any functionality.

                                        Manual instructions to run this test:
                                        I.  Hardware Prerequisites
                                            1.  Device under test
                                        II. Software Prerequisites
                                            1.  Firmware, full OS
                                        III.    Setting up the Test
                                            1.  On device under test, flash firmware, install full OS
                                            2.  Ensure that no USB Ethernet adapter is connected to the device
                                        IV. Running the Test
                                            1.  Boot up the device using power button
                                            2.  Go to Start Menu\Settings\Network & Internet\Wi-Fi\Set Wi-Fi slider to ON
                                            3.  Check network connectivity status icon in system tray for list of available WLAN networks
                                            4.  Connect to one of the available networks that you have access to
                                            5.  Launch edge app & browse to www.bing.com
                                            6.  Open command prompt and ping www.bing.com
                                        V.  Verification
                                            1.  Network connection icon should show wireless connection status after connecting
                                            2.  Edge should launch msn.com or ping responses should be successful
                                        ---------------------------------------------------------------------------------------------------------
                                        Note: This test is associated with an optional feature: System.Client.ARM64DesktopHardware. It will not appear in the list of tests in HLK studio for a system target by default.
                                        Optional: To enable it to show up in the list of tests for system target in HLK studio, run the following steps:
                                        1] In HLK Studio, select system target
                                        2] Right click on the selected system target
                                        3] Click on Add\Modify Features
                                        4] A Device Feature List window will open up
                                        5] Scroll down to select the feature named: System.Client.MobileHardware
                                        6] Click on the check box to enable this optional feature
                                        7] This test will now appear in the list of applicable tests for the selected system target in HLK studio

Test details
Specifications
  • System.Client.ARM64DesktopHardware.BasicFunctionality
Platforms
    Supported Releases
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 10
    Category | Development
    Timeout (in minutes) | 15
    Requires reboot | false
    Requires special configuration | false
    Type | manual

    Additional Documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Client additional documentation


Profile Interrupt Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/600e4810-7727-424d-8644-53cf52a21d5c

The profile interrupt test sets the profile interrupt resolution to severalunique values. The hardware is allowed to settle after each rate change. Thenthe test attempts to register a profile interrupt handler with the HAL. Thehandler takes a timestamp using KeQueryPerformanceCounter() each time it runs.Those timestamps are ultimately sent back to user-mode where they are analyzed.

Test details
Specifications
  • System.Client.CPU.Compatibility
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 31
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


QPC Validation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/87b381ca-e88c-406e-a99e-ceb1c4188fe1

Validates that QueryPerformanceCounter does not go backwards.

Test details
Specifications
  • System.Client.CPU.Compatibility
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Log all profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d0537b26-454e-4e7d-8975-e8f1618c0ba0

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Photo Sequence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8ee7c452-fd48-4fa1-b7b9-f63f3827fa15

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_BalancedVideoAndPhoto enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab69bfa0-0e78-41e0-bd02-4d832ed83462

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/28937973-becd-44ef-b3c3-9339b58423cd

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, photo and preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dd1a9a29-3d70-47a7-9b5b-f12baccdf4d9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_CUSTOM enum all, rec and preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6f26257e-75cc-4301-971e-cf27ae3bddf9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto is supported, set first index

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/092dea22-1995-46db-8e8f-189993ec6385

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_HighQualityPhoto, enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4d4808bf-926a-4385-a25c-5a6ce6300791

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoConferencing enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5398d830-edc6-4cb1-8a80-d679f8287946

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording enum all

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d0f37ef-efd4-4f8c-a9f4-f7e55f8c8f0e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERA_PROFILES - Verify KSCAMERAPROFILE_VideoRecording is supported, set first index

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fcaf4917-85e7-4bcb-8607-4f51ac956dd6

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - CAMERAANGLEOFFSET - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7f339b5-2f8c-4112-a136-e5ecee531a19

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - EVCOMPENSATION - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0f1e6bfe-4afa-45a4-a03c-4e3e0a85d000

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Previewing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/116a9095-568a-4eee-8bda-ae6ed5d8c894

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - EVCOMPENSATION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83f1e9a6-d4fd-4d94-8f8a-738da3c67150

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - EXPOSUREMODE - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/563cf17f-3c36-4cd4-9f80-51cbc50ec3ad

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - EXPOSUREMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cc06c458-e67f-4d51-a087-08ca9d009398

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Default for Video Record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/38be764d-19b5-4581-a403-5e7579e820f1

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Default for Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a97d09e-c52f-4f7c-8b8f-50565c8322f4

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Enable for Video Record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4e818810-29a6-4a66-8382-fab69b5e9e39

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Face Authentication - Alt Frame Illum Enable for Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/40c64621-a37d-4584-885b-9d29a9f279ca

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Face Authentication - Background Subtraction Default for Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/918e185e-6732-477a-a069-b7e28e698415

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Face Authentication - Background Subtraction Enable for Video Record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/92960f65-6556-4a35-a646-8da1f5c5e3ad

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Face Authentication - Background Subtraction Enable for Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/527c6477-3440-4227-89cd-56edfa2fbe90

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Face Authentication - Invalid - Alt Frame Illum and Background Subtraction for Video Record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6b03b850-7eb9-4392-b624-239a79a63799

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Face Authentication - Invalid - Alt Frame Illum and Background Subtraction for Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4398b360-2a0f-4277-9f24-f350fca8f62b

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Face Authentication Default for Video Record

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d3a62ec-e602-45f8-a316-68435973e427

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ecca7ad-aada-4c98-b153-c44ef48e00ae

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FACEDETECTION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31c48c8b-7058-4979-a1d0-d5d026ee2315

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FACEDETECTION - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a8fb1d2c-9701-4e26-b09a-61855d5c62bd

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FIELDOFVIEW - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/98e63022-4743-4d37-b590-f8affa893e53

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FLASHMODE - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/49fca524-09d5-41ca-b01e-aa4accbfe13e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FLASHMODE TORCHMODE - scenario

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/365bdc64-584f-4e54-8d3b-9305c17ef811

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Previewing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fc867f89-cdc1-492e-a9b1-33c93ac9a8a2

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1eec4920-0e5f-433f-b244-26d2e695a81c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FOCUSMODE - Iterate through possible settings while Recording after start streaming for a few seconds

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2539767d-2107-4a61-ab14-d15387dc573e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FOCUSPRIORITY - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2c656f6e-2daa-48a3-bde0-6df528f48c74

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FOCUSPRIORITY - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4f3e0afe-c46a-4dae-9515-a51383e40287

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - FOCUSSTATE - Verify Default setting - Record Video

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4a2baf2-c3d3-4b1a-9e85-6cd2da2efd09

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Face Authentication Default for Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d85d4a47-7780-4b51-be85-83f276f92114

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aa317505-fdfb-4bc4-8a7f-972e0e40468a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - HISTOGRAM - Turn on Histogram while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78de8b2d-5e6e-4ede-9f05-2418f0e57b04

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - HISTOGRAM - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1711f3d8-a565-45d9-b57e-decb63b65e4e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - HISTOGRAM - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/083ab189-994d-419e-9cd1-29c5e070ba10

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ISO - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f27ecf74-6a31-4209-9b75-81209dbc83ae

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - OIS - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/afbedcb7-00f1-4719-8624-c612a8f3e97c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - OIS - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9bb49813-3734-4e09-8b7b-b61f1ed476fc

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - OPTIMIZATIONHINT - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ff083e5-43d9-4900-bf57-ce2cdef7a34a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - 3A Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/80e5dbd8-ed94-4023-9e78-06fbdb86b673

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5afcdc04-6eaa-42ea-9a31-50976387ffd8

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Exposure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f9f382b-38b5-41bf-8195-fd1c0387fca4

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Exposure and Whitebalance Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4db8a08-910e-450a-b4b8-b2195187050a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Exposure Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bd320748-5af7-400d-a746-2a586668e00c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Exposure Valid Rects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aef20d3d-18cf-4b6c-8fe4-60e2c5b8e5c0

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Focus

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce843a7b-6795-4e4e-855c-32b59db6f8ef

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Focus and Exposure Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f4a5df2c-4605-43e5-a060-82c99f4d4c22

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Focus and Whitebalance Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8c52f2d2-ae76-4bdd-abe3-898e2cd55cd9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Focus Valid Rects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03271497-fc75-4514-944b-91fc6b38ca97

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Focus with preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8120977f-fa54-4ac7-b7e3-5df2c7bcfb64

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Set Clear

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9eee0058-e7df-44d7-9658-74ada98e37d9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - WhiteBalance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a74de7da-5e5e-4240-97f4-9cf76065e41f

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - Whitebalance Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e93aa614-cfba-46ca-8ca5-d376f8cfa635

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ROI - WhiteBalance Valid Rects

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/09e80100-d75d-4f71-a6a8-73cf6abc5419

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - SCENEMODE - Get Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61ee4c22-733f-455d-b1cb-44f36925349c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - SCENEMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6fd1b0ff-a6d6-4852-ab13-1975c5d4ead9

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Secure Mode - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a09f0a97-76e2-4ced-8c0e-77f4d8c8d79e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Secure Mode Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a80e2a2-dcac-4e0c-bf31-be17af225659

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Secure Mode Secure Streaming

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3b55b25-0267-4d43-b60d-14e8d4775952

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Sensor Camera Driver Controls System Test - Torch Mode - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69537706-9563-433e-93b3-d0a1df2a7c49

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - Torch Mode - Iterate through possible settings

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/02417c3d-afd6-490d-b239-6a5e08b68f9f

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VFR - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ea8b42e-e2fa-4bd4-a94f-851094b66710

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VFR - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eba1cf60-f8ac-46c2-9849-b42429d9c4ef

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOHDR - Set Video HDR auto using profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9055a9a6-7a90-490c-9a5c-a9d151475723

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOHDR - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0b49834-f1d7-440b-8c69-ae900335e33e

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOHDR - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68a80cc9-755f-4212-bc39-1f31e56de5d6

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn off Video HDR on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0456b77e-c089-46d8-ac4d-8ad4435e528c

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOHDR - Verify Fail to turn on Video HDR while streaming with with STATUS_INVALID_DEVICE_STATE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bca4408b-280e-45ec-a447-e499465677b5

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOHDR - verify with profiles

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/64d077fb-1d1b-48e9-af57-74347b6da665

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e51fe9f5-d1d2-4b77-b0a5-177eebae9e3a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c2f7172c-d658-4f4f-9943-f13171dcd774

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify correct Pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/876a97bc-1e9e-4d5b-9174-51806dd724d4

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - VIDEOSTABILIZATION - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cb7e841e-c41f-4f2d-9049-322e8dc9a83b

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - WHITEBALANCEMODE - Check Default

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ecc9a3ad-e7f8-4ba9-a301-cbaced3adc42

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/53daf9b2-24af-4476-ae8d-8311155b47fc

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - WHITEBALANCEMODE - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ffb482a-0035-4d66-91db-f9e2e29d665f

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Preview

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d590f9dc-4d82-4a62-bf2e-473bc0765c0a

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ZOOM - Iterate through possible settings while Recording

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2a3991f8-dff1-4fc3-a374-73ab847a3e7f

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Sensor Camera Driver Controls System Test - ZOOM - Verify Default setting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf577f4f-5e44-4afa-8dc0-3d354c421e66

Test to validate key user scenarios in the camera stack

Test details
Specifications
  • System.Client.Camera.SensorCapture.SensorCapture
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 25
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test validates camera functionality if the driver supports the extended control in the title. If the driver does not support this control, skip this test. This is an optional control. If the driver implements a control handle, the following checks will run (based on the definition of the controls):

  • The test verifies default values and validates that the appropriate property is advertised on the correct pin or filter level.
  • The test enumerates possible control values during the times that pins are streaming and not streaming.
  • Scenario tests are run on the control to validate end-to-end functionality.

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


Single Computer Display Object test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/686005ee-4d03-49c5-a1db-440235c06fc8

This test verifies that the computer is represented by only one display object.

Test details
Specifications
  • System.Client.PCContainer.PCAppearsAsSingleObject
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
LLU_NetAccessOnly | LLU_NAO
LLU_User | LLU_USER
QueryFormFactor | Form factor query

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


System - Partition Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26f8c4a1-73c8-4f27-9c55-6db84298e02c

This manual test verifies that the disk partitions on the Windows system meet the BitLocker Drive Encryption requirements. This test validates that the system provides a second hard disk drive (HDD) partition, separate from the operating system partition, that is formatted as NTFS and meets minimum size requirements. This test only applies to client operating systems.

This test validates that the recovery and OEM partitions are marked with the correct type and attributes so that these partitions won't be confused with user data volumes.

Test details
Specifications
  • System.Client.SystemPartition.DiskPartitioning
  • System.Client.SystemPartition.OEMPartition
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Scenario
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

In addition, this test requires that the test computer's hard drive has a minimum of two partitions:

  • Partition 1: For machines with Windows 7 and later versions, a minimum of 100MB configured as Active, System. For machines with Windows Vista, a minimum of 1.5GB configured as Active, System.

  • Partition 2: Minimum of 20 GB (or Windows 7 minimum requirement) configured as Boot, Page File, Crash Dump.

If a system has a partition that includes a bootable Windows Recovery Environment image file, the GPT partition must be of type PARTITION_MSFT_RECOVERY_GUID and include the GPT_ATTRIBUTE_PLATFORM_REQUIRED attribute. If this partition includes a recovery image used by Push Button Reset, the GPT partition must be of type PARTITION_BASIC_DATA_GUID and include the GPT_ATTRIBUTE_PLATFORM_REQUIRED attribute. Any partition that is not system or boot, and is intended to be used by the OEM to store recovery or other information, should include the GPT_ATTRIBUTE_PLATFORM_REQUIRED attribute.

If the system has a volume which is intended to hold user data, the test will prompt to confirm whether this volume is intended to be a user data volume.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

To troubleshoot a failed test, see Step 7: View test results and log files.

More information

Command syntax

Command option | Description
SSSystemPartitionValidation.exe | [This content isn't available yet.]
NOTE

For command-line help for this test binary, type /h

File list

File | Location
SSSystemPartitionValidation.exe | <[testbinroot]>\nttest\basetest\ngscb\spvlogo

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for copying binaries
LLU_LclAdmin | LLU for built in admin account


System Transcode Faster Than Real Time on AC Power Source ( Manual on mobile devices )

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b7614ff1-e149-4f45-8b16-e96e5a1deb47

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test verifies that a system is capable of transcoding video faster than real time on an AC power source. This test applies to desktop computers and mobile devices. This test is manual when the device under test is a mobile device.

Test details
Specifications
  • System.Client.MediaTranscode.SystemTranscodeFasterThanRealTime
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

How to enable verbose ETW logging for analysis

To collect more verbose ETW logs, change the user-settable parameter 'DoFullLogging' to 'true' before running the tests.

How to preserve the ETW logs for analysis in case of failure

To preserve the ETW logs for failed test cases, change the user-settable parameter 'CopyLogsOnFailure' to 'true' before running the tests. This will also copy the ETW logs of failed test cases to the controller and be included as part of HLK package to be shared for investigation.

Using Media Experience Analyzer to analyze failed ETW logs

You can use Media Experience Analyzer (MXA) to analyze failed ETW logs. Download MXA from the following location:

  • http://www.microsoft.com/en-us/download/details.aspx?id=43105

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation
EnforceEncoder | Enable flag to enforce hardware encoder


System Transcode Faster Than Real Time on Battery (DC) Power Source ( Manual on mobile devices )

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c343896c-fc2d-4c93-b285-c62110c4fcf9

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This manual test verifies that a mobile system is capable of transcoding video faster than real time on a battery (DC) power source.

Test details
Specifications
  • System.Client.MediaTranscode.SystemTranscodeFasterThanRealTime
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

If the mobile system is on AC power when you start the test, you'll need to switch the power source from AC to DC (battery).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

How to enable verbose ETW logging for analysis

To collect more verbose ETW logs, change the user-settable parameter 'DoFullLogging' to 'true' before running the tests.

How to preserve the ETW logs for analysis in case of failure

To preserve the ETW logs for failed test cases, change the user-settable parameter 'CopyLogsOnFailure' to 'true' before running the tests. This will also copy the ETW logs of failed test cases to the controller and be included as part of HLK package to be shared for investigation.

Using Media Experience Analyzer to analyze failed ETW logs

You can use Media Experience Analyzer (MXA) to analyze failed ETW logs. Download MXA from the following location:

  • http://www.microsoft.com/en-us/download/details.aspx?id=43105

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation
EnforceEncoder | Enable flag to enforce hardware encoder


Test.Aliasing

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/688ba9e3-9e8b-4431-a92c-4f6f6fe17d68

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.FingerSeparation
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.AllAreas

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7b5ccc7-ee1e-41bd-9b85-74eba6f5354c

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Accuracy
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.AudioTouch

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/07a6c0c4-1518-49e0-bf6e-29b62c25e753

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.Buffering

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ad165a1-413d-407b-b2ab-b20ca4847635

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Buffering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.Confidence

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cfa95205-c10b-4b5b-a411-7b7637ae737f

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.ConvergeDivergeDiagonal

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/507decc9-006a-420b-a232-960d9d5ef034

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.FingerSeparation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.DeviceButton

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/17cd14f8-bd3b-422e-8148-0ca39d8cd5a0

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Buttons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.DeviceClickPressure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0ed6bac6-61a1-4479-b4e7-304d049a7204

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Buttons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.DeviceHeight

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a061f294-a434-4ee3-916f-281b340d47b2

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Dimensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.DeviceType

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b43d82bf-68fd-4e5a-bde9-0745ad73b7c2

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.DeviceTypeReporting
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.DeviceWidth

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/434154ff-abe3-4c06-a599-c03017d36974

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Dimensions
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.ExternalButtons

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/89cddbfb-ad34-4bb7-b24f-56dddb50fe04

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Buttons
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.GhostReporting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/12e49f5c-1f24-46cd-b60f-5c753eff40d2

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.InputResolution

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/451cd5d7-d059-4450-9671-9d63e7a22249

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.InputResolution
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.LinearityDiagonal

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/31a781dc-4a08-4afe-a23f-dd0e2f756857

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.LinearityDiagonalMultiple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/783bac7b-047e-4d78-a033-ad962aa7a169

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.FingerSeparation
  • System.Client.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.MinMaxContacts

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f8fea26-a66f-44d2-ad66-f1def0580dda

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.MinMaxContacts
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.PositionalAccuracy

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c48c08c2-16f5-4039-9881-36a96a91608b

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Accuracy
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.PositionalAccuracyManual

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c9a29643-29b5-4ffd-b44e-8f5e166e91a2

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Accuracy
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.PowerStateReliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/29f1e670-7506-4634-8713-48ea5fbd836a

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Latency
  • System.Client.Digitizer.PrecisionTouchpad.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.Pressure

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0d251c7-bd14-4206-8124-9cb3d6e4f70e

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.PTPHQA

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33fe944c-3f0e-4c0d-961f-2cb9b664c6db

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.ReportRate

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2824477f-90b0-4c59-95c9-861a219c9a2c

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.ReportRate
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.ReportRateMultiple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51944883-7f26-40fb-9674-5ecffb634f35

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.ReportRate
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.RightClickReliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be58dd0e-61a0-40b0-9a9b-592d1172eb1c

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.SelectiveReporting

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9329943d-528d-4295-b8bd-c94b07b2dadc

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.SelectiveReporting
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.StaticValidation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/aa63581d-5af9-499c-8d7b-63242b100b9c

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.HIDCompliant
  • System.Client.Digitizer.PrecisionTouchpad.ThirdPartyDrivers
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.StationaryJitter

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/469ca938-1190-4865-92c7-8743a5bca558

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.StationaryJitterMultiple

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/93168995-3dfe-40dd-b2f8-7694ee8a344d

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.StepMotor

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3fce46e-e524-4d69-83e0-bc41f6d8d680

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Test.ZHeight

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b500d7c1-752c-4281-bdec-da172bdf2945

Test details
Specifications
  • System.Client.Digitizer.PrecisionTouchpad.ContactTipSwitchHeight
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


UEFI GOP mode test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6afc8979-df62-4d86-8f6a-99f05bbdc7f3

This automated test verifies that a system implements the Graphics Output Protocol (GOP) mode protocol in accordance with the Windows HLK requirements.

Test details
Specifications
  • System.Client.Firmware.UEFI.GOP.Display
  • System.Server.Firmware.UEFI.GOP.Display
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation
  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

The system should have Secure Boot turned off in order to run the pre-operating system application, or have a compatible feature for running Microsoft test-signed binaries.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Mode selection

  • Once UEFI has determined which display is enabled to display the pre-operating system screen, it must select the mode to apply based on the following logic:

    1. System with an Integrated display (laptop, all in one, tablet): The display must always be set to its native resolution and native timing.

    2. System without an Integrated display (desktop):

      1. UEFI must attempt to set the native resolution and timing of the display by obtaining it from the EDID.

      2. If that is not supported, UEFI must select an alternate mode that matches the same aspect ratio as the native resolution of the display.

      3. At the minimum, UEFI must set a mode of 1024 x 768.

      4. If the display device does not provide an EDID, UEFI must set a mode of 1024 x 768.

    3. The firmware must always use a 32 bit linear frame buffer to display the pre-operating system screen.

    4. PixelsPerScanLine must be equal to the HorizontalResolution.

    5. PixelFormat must be PixelBlueGreenRedReserved8BitPerColor. A physical frame buffer is required. PixelBltOnly is not supported.

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
SOURCE_PATH |
LLU_LclAdmin.DomUsr |


Verify Device Driver Is WDDM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fe14601e-d04c-4ad8-af8f-8fa09618a03d

This automated test verifies that all display adapters or chipsets in the system are using WDDM version 1.0 display drivers or greater.

Test details
Specifications
  • System.Client.Graphics.WDDM
  • System.Client.UMPC.Graphics.WDDM
  • System.Server.Graphics.WDDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation
  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


Verify Graphics Device Count is one

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f6a07b2c-36dc-495f-8068-fb16f9df8390

This is an automated test that verifies that the graphics device count is one.

Test details
Specifications
  • System.Fundamentals.Graphics.MultipleOperatingMode
  • System.Client.Graphics.SingleGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation
  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


Verify Post Device Supports Display And Render

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a635f1f2-5a43-4264-a667-ce6cd1a43338

This automated test verifies that system has a full graphics driver or device that is capable of display, rendering, and video.

Test details
Specifications
  • System.Client.Graphics.FullGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name of net user


WDDM CCD Test for verifying only one internal target active on GPU

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/352dea37-3acd-4af3-8ca5-aa7402f6f692

This automated queries all display devices and ensures that only one internal device is actively driving an output. Having two displays marked as internal is not supported.

Test details
Specifications
  • System.Client.Graphics.NoMoreThanOneInternalMonitor
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

In order for this test to complete successfully, the following must be true:

  • Windows must be able to drive any target from any source, although there may be constraints on which target may be driven in combination.

  • When Windows asks for the EDID, the driver must provide the most current EDID. If there's been an interruption (sleep/resume, PnP stop/start) in the drivers ability to detect connection state, the driver must re-query the display device.

  • For each DVI-I connector on the system, the graphics adapter or chipset driver must expose one target of type D3DKMDT_VOT_DVI and one target of type D3DKMDT_VOT_HD15.

  • The graphics adapter or chipset driver must not use D3DKMDT_VOT_OTHER as target type for any target type already defined in D3DKMDT_VIDEO_OUTPUT_TECHNOLOGY.

  • The graphics adapter or chipset driver must accurately report the result of the connection state request based on the display device being physically connected. If the driver doesn't have this information it must return STATUS_GRAPHICS_UNKNOWN_CHILD_STATUS when the operating system invokes the DXGKDDI_QUERY_CHILD_STATUS DDI. On systems with multiple GPUs, the laptop lid target must not be reported as 'connected' on more than one graphics adapter at any given time.

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user


Windows Client System Check For WDDM 1.2 Display Driver Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f6345e90-c03e-44be-ba7f-73c3e4699987

This test verifies that all display adapters/chipsets in the system are using display drivers that are WDDM 1.2 version or greater.

Test details
Specifications
  • System.Client.Graphics.WDDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Windows Client System Check For WDDM 1.3 Display Driver Support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0901fb0-ad91-4da6-a176-23b5742ee163

This test verifies that all display adapters/chipsets in the system are using display drivers that are WDDM 1.3 version or greater.

Test details
Specifications
  • System.Client.Graphics.WDDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Windows Hid Validation Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/64e7fab3-23ce-46fb-a654-be310d93d929

Test details
Specifications
  • System.Client.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Windows System Check For WDDM

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10b2bc42-88f2-4b60-b1d0-a5f43a49aa0f

This automated test verifies that all display adapters or chipsets in the system are using WDDM version 1.0 display drivers or greater.

This test document is applicable to three test jobs:

  • Windows Client System Check For WDDM 1.0 Display Driver Support

  • Windows Client System Check For WDDM 1.1 Display Driver Support

  • Windows Client System Check For WDDM 1.2 Display Driver Support

Test details
Specifications
  • System.Client.Graphics.WDDM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU Name for net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Windows Touch Buffering Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ce200bc-1b62-4ea5-b517-322480065d5c

Test details
Specifications
  • System.Client.Digitizer.Touch.Buffering
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation


Windows Touch Digitizer Jitter Test - Five Contacts (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4ab61b8a-1785-4e57-a18f-a7a928b6f302

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Digitizer Jitter Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.HIDCompliant
  • System.Client.Digitizer.Touch.Jitter
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Digitizer Jitter Test - One Contact (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a583fd82-085f-4899-9ffc-ee429597dac3

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Digitizer Jitter Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.Jitter
  • System.Client.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Compatibility
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Five Point Minimum Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25d4e130-b388-4488-8dc3-0e4b0a478775

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Five Point Minimum Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.HIDCompliant
  • System.Client.Digitizer.Touch.MinContactCount
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Input Separation Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d4464015-bb8a-44d4-8329-edd13cd539c6

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Input Separation Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.FingerSeparation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Noise Suppression Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/79c9bc55-29f4-4f1d-abb5-87364d3acc6d

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Noise Suppression Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Physical Input Position Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1a7083e8-663e-42b9-a632-5f0488025cb0

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Physical Input Position Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.Accuracy
  • System.Client.Digitizer.Touch.HIDCompliant
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Reporting Rate Test - Five Contacts (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ab9d761f-79a5-4b8e-8512-5e999eed51b0

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Reporting Rate Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Reporting Rate Test - Maximum Contacts (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f6fd08e9-26c2-4d80-b133-d8537fb986e3

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Reporting Rate Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Reporting Rate Test - One Contact (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e99181fd-e484-4bda-9374-97cdffcd6d4e

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Reporting Rate Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.ReportRate
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Resolution Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c02e149-9770-4824-af8b-5af46df79330

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Resolution Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.Resolution
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Response Latency (Down) Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/caa16fdf-eef6-40a6-bd80-f1079aa227bc

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Response Latency (Down) Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Response Latency (Panning) Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cdf03bba-1716-4ead-82c3-8bb6d3c6fc86

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see Windows Touch Response Latency (Panning) Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.Latency
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/85a694cc-231b-4bbd-9b52-65e7aa90d57d

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.CustomGestures
  • System.Client.Digitizer.Touch.HIDCompliant
  • System.Client.Digitizer.Touch.ThirdPartyDrivers
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Windows Touch Ux Test (System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f8bc40dc-158c-4c69-93d9-d72b60455234

NOTE

This is a system-specific implementation of an existing test. For more information on this manual test, see Windows Touch Ux Test.

Test details
Specifications
  • System.Client.Digitizer.Touch.Accuracy
  • System.Client.Digitizer.Touch.FingerSeparation
  • System.Client.Digitizer.Touch.Jitter
  • System.Client.Digitizer.Touch.ReportRate
  • System.Client.Digitizer.Touch.ContactReports
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing and Troubleshooting Device Digitizer Testing.


Wlan Test - Attempt a connection to a non-existent network

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ccbe843e-31dc-4b31-803e-18a4d21b8469

This automated test creates a wireless profile for a network that does not exist and tries to connect to the non-existent network.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test will do the following:

  1. Create a wireless profile for a network that does not exist.
  2. Instruct the wireless service to connect to the created profile The device/driver is expected to quickly fail since the network is not visible.
NOTE

Possible Failure Points:

  • If the connection start event is not seen within ten seconds, the test will fail.
  • If the associating message is not seen within eight seconds of connection start, the test will fail.
  • If the connection failure message is not seen within eight seconds of associating, the test will fail.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Attempt a connection to a non-existent network - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/32cc3c32-08a1-4e38-9eed-ad62f12eeb80

This automated test creates a wireless profile for a network that does not exist and tries to connect to the non-existent network.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test will do the following:

  1. Create a wireless profile for a network that does not exist.
  2. Instruct the wireless service to connect to the created profile The device/driver is expected to quickly fail since the network is not visible.
NOTE

Possible Failure Points:

  • If the connection start event is not seen within ten seconds, the test will fail.
  • If the associating message is not seen within eight seconds of connection start, the test will fail.
  • If the connection failure message is not seen within eight seconds of associating, the test will fail.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Check Hosted Network Capable

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc2222bd-b44f-45b0-aab7-03d022e4fe96

This automated test queries whether the device is "Hosted Network" capable. If it is it will attempt to start and stop the Hosted Network.

Test details
Specifications
  • System.Client.WLAN.HostedNetwork.WlanHostedNetwork
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  1. Check to see if Hosted Network is supported on the WLAN adapter
  2. Attempt to start the Hosted Network functionality
  3. Verify the Hosted Network successfully started
  4. Attempt to stop the Hosted Network

If any of the above items fail the test will fail.

NOTE

Hosted Network is an optional feature.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Check Hosted Network Capable - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/046935c4-7662-4342-842e-0c3b31ad99af

This automated test queries whether the device is "Hosted Network" capable. If it is it will attempt to start and stop the Hosted Network.

Test details
Specifications
  • System.Client.WLAN.HostedNetwork.WlanHostedNetwork
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  1. Check to see if Hosted Network is supported on the WLAN adapter
  2. Attempt to start the Hosted Network functionality
  3. Verify the Hosted Network successfully started
  4. Attempt to stop the Hosted Network

If any of the above items fail the test will fail.

NOTE

Hosted Network is an optional feature.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Connect to a WPA2 PSK AES AP

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cd739bc6-fc0e-403a-96a0-d6649fe6d374

Connect to a specified WPA2PSK AES network (Defaults: SSID=kitstestssid Passphrase=password)

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network


Wlan Test - Connect to a WPA2 PSK AES AP - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11305d2f-35d1-449e-9e3b-5f9b897c2607

Connect to a specified WPA2PSK AES network (Defaults: SSID=kitstestssid Passphrase=password) - This test is a WoW64 for ARM64 version of test guid cd739bc6-fc0e-403a-96a0-d6649fe6d374

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network


Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ec6e3701-5e69-48ad-bf4d-e3100c504b2c

Connect to a specified WPA2PSK AES network with sleep resume (Defaults: SSID=kitstestssid Passphrase=password SleepDurationInSec=20, SleepCycleIterations=2)

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
SleepDurationInSec | The amount of time in seconds the device will asleep
SleepCycleIterations | The number of sleep/wake cycles to do


Wlan Test - Connect to a WPA2 PSK AES AP with Sleep cycle - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a6f72491-07de-47e4-8701-b34a975a554c

Connect to a specified WPA2PSK AES network with sleep resume (Defaults: SSID=kitstestssid Passphrase=password SleepDurationInSec=20, SleepCycleIterations=2) - This test is a WoW64 for ARM64 version of test guid ec6e3701-5e69-48ad-bf4d-e3100c504b2c

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network
SleepDurationInSec | The amount of time in seconds the device will asleep
SleepCycleIterations | The number of sleep/wake cycles to do


Wlan Test - Enable and Disable WFD Autonomous GO

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7bb7c94-10cf-4275-83cf-2d1cfb8a2a1a

This automated test enables WifiDirect Autonomous GO, checks for the SSID being broadcast, and then disables Autonomous GO.

Test details
Specifications
  • System.Client.WLAN.WiFiDirect.WlanWiFiDirect
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Test will tell driver to enable Autonomous GO.
NOTE

Possible Failures:

NOTE

Test will fail if driver cannot return the WifiDirect capabilities.

NOTE

Test will fail if driver returns ConcurrentOperationSupported as false.

NOTE

Test will fail if it cannot retrieve a non-empty SSID.

NOTE

Test will fail if either start or stop of Autonomous GO fails.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Enable and Disable WFD Autonomous GO - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/35d12db3-45c6-47e0-aab4-6d1b2e22ab6d

This automated test enables WifiDirect Autonomous GO, checks for the SSID being broadcast, and then disables Autonomous GO.

Test details
Specifications
  • System.Client.WLAN.WiFiDirect.WlanWiFiDirect
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Test will tell driver to enable Autonomous GO.
NOTE

Possible Failures:

NOTE

Test will fail if driver cannot return the WifiDirect capabilities.

NOTE

Test will fail if driver returns ConcurrentOperationSupported as false.

NOTE

Test will fail if it cannot retrieve a non-empty SSID.

NOTE

Test will fail if either start or stop of Autonomous GO fails.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - MAC Randomization test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8ae23647-35b9-4535-9c5e-465281d4de61

This automated test checks to make sure the wlan device has properly implemented the MAC address randomization feature.

Test details
Specifications
  • System.Client.WLAN.SupportMACAddressRandomization.MACAddressRandomization
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented WLAN MAC Address Randomization. This test does the following:

  1. enables the mac randomization option
  2. connectes to a wpa2psk network
  3. disables the mac randomization option
  4. connectes to a wpa2psk network
NOTE

Possible Failure Points:

  • Adapter failed to set MAC Address randomization feature
  • Adapter failed to connect to wpa2psk network
  • Adapter failed to clear MAC Address randomization feature

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network


Wlan Test - MAC Randomization test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fb04abc8-5f4d-45a1-98c8-a837e167fd64

This automated test checks to make sure the wlan device has properly implemented the MAC address randomization feature.

Test details
Specifications
  • System.Client.WLAN.SupportMACAddressRandomization.MACAddressRandomization
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented WLAN MAC Address Randomization. This test does the following:

  1. enables the mac randomization option
  2. connectes to a wpa2psk network
  3. disables the mac randomization option
  4. connectes to a wpa2psk network
NOTE

Possible Failure Points:

  • Adapter failed to set MAC Address randomization feature
  • Adapter failed to connect to wpa2psk network
  • Adapter failed to clear MAC Address randomization feature

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing
WPA2_PSK_AES_SSID | SSID of a WPA2_PSK_AES network to connect to (MUST be WPA2 PSK AES)
WPA2_PSK_Password | Password for WPA2_PSK network


Wlan Test - Query All Reported Oids

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c557859a-9c07-4dbd-8851-1b752629222f

This automated test queries all reported oids.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. The test completes the following:

  1. Queries NDIS for all implemented OIDs that the driver returned during miniport initialization.
  2. Checks each for a valid return code
NOTE

Possible Failure Points:

  • The test will fail if any of the reported OIDs return invalid data or crashes the machine.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Query All Reported Oids - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4849e50f-5cd0-404b-9602-fd90ef2f49a9

This automated test queries all reported oids.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. The test completes the following:

  1. Queries NDIS for all implemented OIDs that the driver returned during miniport initialization.
  2. Checks each for a valid return code
NOTE

Possible Failure Points:

  • The test will fail if any of the reported OIDs return invalid data or crashes the machine.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Query Interface Properties

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f0f57674-f91c-4285-9e65-7a5abaa5a482

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test queries the device for the following properties:

  • IsMediaStreamingEnabled
  • IsBackgroundScanEnabled
  • IsSafeModeSupported
  • sSafeModeCertified
  • GetCurrentOperationMode
  • GetInterfaceState
  • sManagementFrameProtectionSupported
  • IsHostedNetworkCapable
  • enumerate all radios and radio states
  • IsAutoConfigEnabled
  • enumerate all support infrastructure cipher pairs
  • devices without Connected Standby must enumerate supported adhoc cipher pairs
  • GetBSSMode
  • GetCountryList
  • GetConnectionAttributes
  • GetRSSi
  • GetChannel

Any returned failure in the WLAN service API from the device these capabilities are queried will result in a failure in the test

NOTE

Possible Failure Points:

  • There are less than three infrastructure cipher pairs.
  • If DOT11_AUTH_ALGO_RSNA_PSK is not implemented.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Query Interface Properties - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b5abc8f4-d985-466d-97e2-031eda44cd88

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test queries the device for the following properties:

  • IsMediaStreamingEnabled
  • IsBackgroundScanEnabled
  • IsSafeModeSupported
  • sSafeModeCertified
  • GetCurrentOperationMode
  • GetInterfaceState
  • sManagementFrameProtectionSupported
  • IsHostedNetworkCapable
  • enumerate all radios and radio states
  • IsAutoConfigEnabled
  • enumerate all support infrastructure cipher pairs
  • devices without Connected Standby must enumerate supported adhoc cipher pairs
  • GetBSSMode
  • GetCountryList
  • GetConnectionAttributes
  • GetRSSi
  • GetChannel

Any returned failure in the WLAN service API from the device these capabilities are queried will result in a failure in the test

NOTE

Possible Failure Points:

  • There are less than three infrastructure cipher pairs.
  • If DOT11_AUTH_ALGO_RSNA_PSK is not implemented.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Scan for Networks

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d99b9f5b-0b2e-452c-8075-305f8f6f6c56

This automated test issues a scan request and enumerates networks after the scan.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test will do the following:

  1. Test will disable the device.
  2. Test will enable the device.
  3. Test will start a scan with the option to flush set to true.
  4. Test will enumerate available networks after a completed scan.
NOTE

Possible Failure Points:

  • Test will fail if there are no networks in the enumerated list.
  • Test will fail if scan complete event is not returned in less than six seconds.
  • Test will fail if a scan failure event is returned.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Scan for Networks - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9bb11845-6a1c-4bd4-8646-65e386ef50df

This automated test issues a scan request and enumerates networks after the scan.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test will do the following:

  1. Test will disable the device.
  2. Test will enable the device.
  3. Test will start a scan with the option to flush set to true.
  4. Test will enumerate available networks after a completed scan.
NOTE

Possible Failure Points:

  • Test will fail if there are no networks in the enumerated list.
  • Test will fail if scan complete event is not returned in less than six seconds.
  • Test will fail if a scan failure event is returned.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Toggle airplane mode

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ef5e9bb9-3bb5-46c3-bce6-f1542b06906b

This automated test toggles the radio states in the same way as the user interface airplane mode option.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. The test completes the following:

  1. Disables each radio that is reported to the operating system.
  2. Each radio must change state and report its updated state in less than ten seconds.
  3. Enables each radio that is reported to the operating system.
  4. Each radio must change state and report its update state in under ten seconds

The test allows for and can accommodate devices that change the state of all radios when only one radio is requested. The test will only fail if an exception is thrown when attempting any of the above tasks, or if radios do not change state within the time required

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Toggle airplane mode - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f248aee1-aada-44d2-8b8d-f03ffbeacef3

This automated test toggles the radio states in the same way as the user interface airplane mode option.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. The test completes the following:

  1. Disables each radio that is reported to the operating system.
  2. Each radio must change state and report its updated state in less than ten seconds.
  3. Enables each radio that is reported to the operating system.
  4. Each radio must change state and report its update state in under ten seconds

The test allows for and can accommodate devices that change the state of all radios when only one radio is requested. The test will only fail if an exception is thrown when attempting any of the above tasks, or if radios do not change state within the time required

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Wlan Device Capabilities Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f652c855-e7c6-424d-8361-773c422a2456

This automated test checks to make sure the WLAN device is properly reporting its capabilities to windows

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Queries the system for the adapter capabilities

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Wlan Device Capabilities Check - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d92acb18-4445-47cd-91fe-b05d60a6d036

This automated test checks to make sure the WLAN device is properly reporting its capabilities to windows

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter. This test does the following:

  • Queries the system for the adapter capabilities

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Wlan Device enumeration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/177cfb0e-1a09-4ec7-9053-02ca973415a0

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Wlan Device enumeration - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/564fb6dd-030b-48e8-9df7-42831dbacc6a

This automated test locates the device GUID for the device, enumerates the devices managed by the Windows WLAN service, ensures the device GUID appears in the list, and queries the device's WLAN_INTERFACE_STATE.

Test details
Specifications
  • System.Client.WLAN.BasicConnectivity.WlanBasicConnectivity
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Wlan Device Reset Check

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0e1d7d53-f0e3-4d28-9e5d-9ec28f3e04e9

This automated test checks to make sure the wlan device has properly implemented the reset recovery functionality

Test details
Specifications
  • System.Client.WLAN.HangDetectionAndRecovery.WlanHangDetectionAndRecovery
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented Wlan Hang Detection and Recovery. This test does the following:

  1. Initiate a hang in the adapter
  2. Verify the adatper was removed
  3. Verify the adapter was re-enumerated
NOTE

Possible Failure Points:

  • Adapter was not removed from the system
  • Adapter was not re-enumerated by the system

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


Wlan Test - Wlan Device Reset Check - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/665d8378-8865-40a1-839e-a50cf303919d

This automated test checks to make sure the wlan device has properly implemented the reset recovery functionality

Test details
Specifications
  • System.Client.WLAN.HangDetectionAndRecovery.WlanHangDetectionAndRecovery
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

This test is only valid on systems with a Wireless LAN adapter that has implemented Wlan Hang Detection and Recovery. This test does the following:

  1. Initiate a hang in the adapter
  2. Verify the adatper was removed
  3. Verify the adapter was re-enumerated
NOTE

Possible Failure Points:

  • Adapter was not removed from the system
  • Adapter was not re-enumerated by the system

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

More information

Parameters

Parameter name | Parameter description
EnableTracing | Enable Tracing


WNGlitchfree HD Video Playback on AC ( Manual on mobile systems )

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0933db65-5c40-42d9-874e-763724c9e464

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The manual test verifies that a mobile system on AC power mode is capable of playing protected and unprotected High-Definition content with no perceivable glitch during playback.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

In addition, perform the following steps:

  1. Make sure that the Video and Music apps are installed on the system. You can get both apps from the Store.

  2. Make sure the .mp4 and .wmv extensions are registered to the Video app. To do this, right-click a sample file that has the appropriate extension, click Properties, click Open with, and select the Video app.

  3. Make sure the .m4a and .wma files are registered to the Music app. To do this, right-click a sample file that has the appropriate extension, click Properties, click Open with, and select the Music app.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

The HLK GlitchFree test plays back two video clips using the inbox Video application. The content is played back in Fullscreen while ETW logging is enabled in the background. After each scenario, the test post processes the ETW log and extracts metrics, which are used to determine whether the test passes or fails.

Pass/Fail Criteria & Metric Details

Glitch Metrics

  • Video Glitches - The Media Engine's Video renderer (SVR) detects when a frame is rendered late and it fires a video glitch event. The goal for this metric is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - VideoFrameGlitch - 23

  • Dropped Frames - The Media Engine fires frame drop events when the source drops a frame. When frames are dropped, the user experiences glitchy video. The goal is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - DroppedFrame - 18

  • DWM Schedule Glitches - The desktop window manager (DWM) fires a glitch event when DWM samples are rendered late. The goal for this metric is 0. The test starts tracking this event 500ms after the first PresentedFrame event (Task ID 19, Event ID 115). The test stops tracking this event 66ms after the last instance of PresentedFrame event (Task ID 19, Event ID 115). Provider and event details:

    • Microsoft-Windows-Dwm-Core

    • Channel - Microsoft-Windows-Dwm-Core/Diagnostic - 16

    • Level - win:Informational - 4

    • Task - SCHEDULE_GLITCH - 17

  • Audio Glitches - Audio glitches. Goal is 0.

    • Audio Engine Provider: a6a00efd-21f2-4a99-807e-9b3bf1d90285:0x000000000000ffff:0x3

    • ETW Classic event GUID: 2013DBB2-2F76-4B2C-950A-0C9DFAC62398

    • Event details:

      • Media: Audio Engine

      • AE Events

      • AE_GLITCH

Total Device Creation time: The total device creation time must not exceed 50ms. Total device creation time is defined as DeviceCreation + CreateVideoDecoder, where the definition of those two metrics are:

  • DeviceCreation = The latency between the following two events

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 20 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 21 (Version 0) Opcode - win:Stop - 2

  • CreateVideoDecoder = The latency between the first instance of the following two events:

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1722 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1723 (Version 0) Opcode - win:Stop - 2

Driver Metrics- The ISR/DPC duration and ISR/DPC Storm tests aim at ensuring that device drivers are well behaved. The goal is to ensure that time critical multimedia threads can run on a regular basis, with limited interruptions from ISR/DPCs.

  • ISR/DPC duration: This check is designed to validate that individual ISR/DPC duration does not exceed a 3ms threshold.

  • ISR/DPC Storm: A cumulative duration of every ISR/DPC within a 10ms window must not exceed 4ms.

GPU VSync Cadence: This case ensures that the GPU DPC VSync cadence follows a well behaved pattern. Fluctuations in GPU DPC Vysnc frequency, during media playback can result in glitches during media playback. The test criteria establishes that the cadence fluctuation should not exceed +/- 50% of the average VSync cadence window. For instance, in a 60 Hz monitor, the expected VSync DPC cadence is 16.666 ms; consequently the test will fail if any VSync DPC is fired within less that 8.3 ms from the previous one or later than 24.9 ms from the previous one. When the duration between two vsyncs is greater than 24.9ms, this often results in a perceivable video glitch. When the distance between two vsyncs is less than 8.3ms, this is often caused by the driver double firing vsyncs, or vsyncs that are a few microseconds (us) apart.

How to enable verbose ETW logging for analysis

To collect more verbose ETW logs, change the user-settable parameter 'DoFullLogging' to 'true' before running the tests.

How to preserve the ETW logs for analysis in case of failure

To preserve the ETW logs for failed test cases, change the user-settable parameter 'CopyLogsOnFailure' to 'true' before running the tests. This will also copy the ETW logs of failed test cases to the controller and be included as part of HLK package to be shared for investigation.

Using Media Experience Analyzer to analyze failed ETW logs

You can use Media Experience Analyzer (MXA) to analyze failed ETW logs. Download MXA from the following location:

  • http://www.microsoft.com/en-us/download/details.aspx?id=43105

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation
FrameCount | Minimum number of MF Events required during playback
MaxIsrDpcTime | Maximum ISR Dpc time in microseconds
MaxIsrDpcStorm | Maximum ISR Dpc Storm in microseconds
MaxIsrDpcLoop | Maximum ISR Dpc Loop time in microseconds
GlitchCount | Number of glitches acceptable during playback


WNGlitchfree HD Video Playback on DC ( Manual on mobile systems )

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b1e19cc-c8db-4f60-a0cb-73a2432cd8ce

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

The manual test verifies that a mobile system on DC power mode is capable of playing protected and unprotected High-Definition content with no perceivable glitch during playback.

Test details
Specifications
  • System.Client.VideoPlayback.WNGlitchfreeHDVideoPlayback
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Scenario
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Client additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

In addition, perform the following steps:

  1. Make sure that the Video and Music apps are installed on the system. You can get both apps from the Store.

  2. Make sure the .mp4 and .wmv extensions are registered to the Video app. To do this, right-click a sample file that has the appropriate extension, click Properties, click Open with, and select the Video app.

  3. Make sure the .m4a and .wma files are registered to the Music app. To do this, right-click a sample file that has the appropriate extension, click Properties, click Open with, and select the Music app.

This test requires manual intervention if the mobile system is plugged into an AC power source when the test starts.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

The HLK GlitchFree test plays back two video clips using the inbox Video application. The content is played back in Fullscreen while ETW logging is enabled in the background. After each scenario, the test post processes the ETW log and extracts metrics, which are used to determine whether the test passes or fails.

Pass/Fail Criteria & Metric Details

Glitch Metrics

  • Video Glitches - The Media Engine's Video renderer (SVR) detects when a frame is rendered late and it fires a video glitch event. The goal for this metric is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - VideoFrameGlitch - 23

  • Dropped Frames - The Media Engine fires frame drop events when the source drops a frame. When frames are dropped, the user experiences glitchy video. The goal is 0. Provider and event details:

    • Microsoft-Windows-MediaEngine

    • Channel - MediaFoundationMediaEngine - 16

    • Level - win:Verbose - 5

    • Task - DroppedFrame - 18

  • DWM Schedule Glitches - The desktop window manager (DWM) fires a glitch event when DWM samples are rendered late. The goal for this metric is 0. The test starts tracking this event 500ms after the first PresentedFrame event (Task ID 19, Event ID 115). The test stops tracking this event 66ms after the last instance of PresentedFrame event (Task ID 19, Event ID 115). Provider and event details:

    • Microsoft-Windows-Dwm-Core

    • Channel - Microsoft-Windows-Dwm-Core/Diagnostic - 16

    • Level - win:Informational - 4

    • Task - SCHEDULE_GLITCH - 17

  • Audio Glitches - Audio glitches. Goal is 0.

    • Audio Engine Provider: a6a00efd-21f2-4a99-807e-9b3bf1d90285:0x000000000000ffff:0x3

    • ETW Classic event GUID: 2013DBB2-2F76-4B2C-950A-0C9DFAC62398

    • Event details:

      • Media: Audio Engine

      • AE Events

      • AE_GLITCH

Total Device Creation time: The total device creation time must not exceed 50ms. Total device creation time is defined as DeviceCreation + CreateVideoDecoder, where the definition of those two metrics are:

  • DeviceCreation = The latency between the following two events

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 20 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/PerfTiming - 18 > Level - win:LogAlways - 0 > Task - D3D11CoreCreateDevice - 8 > Event Id - 21 (Version 0) Opcode - win:Stop - 2

  • CreateVideoDecoder = The latency between the first instance of the following two events:

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1722 (Version 0) Opcode - win:Start - 1

    • Microsoft-Windows-Direct3D11 > Channel - Microsoft-Windows-Direct3D11/Logging - 17 > Level - win:LogAlways - 0 > Task - ID3D11VideoDevice_CreateVideoDecoder - 911 > Event Id - 1723 (Version 0) Opcode - win:Stop - 2

Driver Metrics- The ISR/DPC duration and ISR/DPC Storm tests aim at ensuring that device drivers are well behaved. The goal is to ensure that time critical multimedia threads can run on a regular basis, with limited interruptions from ISR/DPCs.

  • ISR/DPC duration: This check is designed to validate that individual ISR/DPC duration does not exceed a 3ms threshold.

  • ISR/DPC Storm: A cumulative duration of every ISR/DPC within a 10ms window must not exceed 4ms.

GPU VSync Cadence: This case ensures that the GPU DPC VSync cadence follows a well behaved pattern. Fluctuations in GPU DPC Vysnc frequency, during media playback can result in glitches during media playback. The test criteria establishes that the cadence fluctuation should not exceed +/- 50% of the average VSync cadence window. For instance, in a 60 Hz monitor, the expected VSync DPC cadence is 16.666 ms; consequently the test will fail if any VSync DPC is fired within less that 8.3 ms from the previous one or later than 24.9 ms from the previous one. When the duration between two vsyncs is greater than 24.9ms, this often results in a perceivable video glitch. When the distance between two vsyncs is less than 8.3ms, this is often caused by the driver double firing vsyncs, or vsyncs that are a few microseconds (us) apart.

How to enable verbose ETW logging for analysis

To collect more verbose ETW logs, change the user-settable parameter 'DoFullLogging' to 'true' before running the tests.

How to preserve the ETW logs for analysis in case of failure

To preserve the ETW logs for failed test cases, change the user-settable parameter 'CopyLogsOnFailure' to 'true' before running the tests. This will also copy the ETW logs of failed test cases to the controller and be included as part of HLK package to be shared for investigation.

Using Media Experience Analyzer to analyze failed ETW logs

You can use Media Experience Analyzer (MXA) to analyze failed ETW logs. Download MXA from the following location:

  • http://www.microsoft.com/en-us/download/details.aspx?id=43105

Parameters

Parameter name | Parameter description
TestCycles | Number of cycles to run the test for
DoFullLogging | Enable flag for full logging of ETW traces in case of failure, and re-run this test.
CopyLogsOnFailure | Enable flag to copy ETW log traces to subfolder 'ETWlogs' in case of failure, and re-run this test. This also copies the failure logs to hlkx package to be shared for investigation
FrameCount | Minimum number of MF Events required during playback
MaxIsrDpcTime | Maximum ISR Dpc time in microseconds
MaxIsrDpcStorm | Maximum ISR Dpc Storm in microseconds
MaxIsrDpcLoop | Maximum ISR Dpc Loop time in microseconds
GlitchCount | Number of glitches acceptable during playback


System.Client additional documentation

In this section

  • System Client Testing Prerequisites
  • Combined Radio Tests Prerequisites
  • Troubleshooting System Client Testing
  • Webcam BasicPerf System (Manual) Test: Best Practices
  • System Testing with Secure Boot


System Client Testing Prerequisites

This section describes the tasks that you must complete before you test a client system by using the Windows Hardware Lab Kit (Windows HLK):

  • Hardware requirements

  • Software requirements

  • Bluetooth System Requirements

  • Test computer configuration

Hardware requirements

To certify your client systems for Windows 8 and Windows 8.1, you'll need the following hardware in addition to the system that you're testing:

  • Another computer. Ideally, the second computer is already certified.

    NOTE

    If you're testing a computer with Bluetooth, the second computer must also have Bluetooth 4.0 or have a Bluetooth adapter installed.

  • An audio device (if the test system supports audio).

  • An audio loopback cable (if the test system supports audio).

  • An external speaker.

  • A network adapter.

  • Two USB flash drives.

  • One data CD.

  • One USB 3.0 hub for every exposed port.

  • Audio Precision Machine - Model System Two and connector cables.

  • A Bluetooth audio device (if the system supports Bluetooth).

  • A monitor with audio output (if the system has an external HDMI or DisplayPort port).

  • A Wi-Fi Access point (if the system supports Wi-Fi).

  • An Athena T0 test card.

  • Polycom CX100.

  • An audio microphone or another active source for audio capture.

  • A SIM with data provisioned (if the system supports mobile broadband).

  • A GPS signal (If the system has GPS).

  • A Windows To Go drive.

    You must pre-configure the Windows To Go drive with a valid Windows image (WIM) file to test the computer. It must include any drivers that are needed to use the system's hardware.

  • A mirror large enough to reflect a screen image back into the camera (if the system has a webcam).

  • USB SuperMutt.

  • A USB 3.0 device, such as a USB 3.0 storage device.

  • Debug cables that match the transport that supports debugging on the system being tested.

  • If you are testing a webcam, you will also need:

    • A video test chart:

      • An x-Rite ColorChecker chart.

      • A National Institute of Standards and Technology (NIST) calibrated lux meter (for example, INS DX-100). You should calibrate the lux meter annually.

      • A printout of the test chart on matte paper from a high quality inkjet (for example, an HP Z2100). You can get this high resolution PDF test chart here.

    • Dimmable lights:

      • Two Impact light stands.

      • Two light mounts that have reflectors. For example, an Impact 5" reflector floodlight kit.

      • An INSTEON plug-in lamp dimmer module.

      • An INSTEON wireless keypad RemoteLinc 2 (optional).

      • A 3-to-1 extension cord.

      • Two Philips 422154 12.5-Watt A19 LED dimmable light bulbs.

  • The device that you are testing must have an IPv6 address.

Software requirements

Preinstall any software as by your hardware manufacture, including any special device drivers.

Bluetooth System Requirements

When certifying a System with an integrated Bluetooth radio through the Windows HLK, all drivers and packages, including filter drivers, profile packs, and 3rd party drivers must be installed on the Primary machine if the system ships with these drivers.

The system must be tested in the shipping Windows configuration, and no changes to Bluetooth settings should be made unless the system ships with these settings.

The Bluetooth radio included with the system must have been previously certified through the Windows HLK. For more information, see Bluetooth Controller Testing Prerequisites.

Test computer configuration

Before running system tests, you must configure the test system and install the operating system. This section summarizes the related procedures.

IMPORTANT

Before you begin testing, make sure that you enable all of the devices in the test system and load all of the related drivers.

To assemble the test computer

  1. On the test system, install a network adapter.

  2. Connect the test system to a network hub.

  3. Connect the additional system to the network hub.

  4. Set the test system BIOS to support the S3 sleep state.

  5. On the test system, install the appropriate Microsoft Windows operating system.

  6. During this installation of the operating system, delete any existing partitions, and create a boot partition. Note, for Business Logo see note at bottom of page.

  7. During installation of the operating system, you must also add the test system to a domain or workgroup.

  8. Install any manufacturer-supplied drivers that devices in the test system require.

  9. On the test system, install the HLK client software from the test server.

  10. On the additional system, install the appropriate Windows operating system.

  11. During installation of the operating system, add the additional system to the same domain or workgroup that the test system belongs to.

  12. Install one serial loopback connector on the serial port of the test system.

To configure the test computer

  1. On each test computer, from the Control Panel, under Power Options, set the following options:

    • Turn off monitor set to Never.

    • System standby set to Never.

    • If there is a System hibernates set to Never.

    • In the Power Options Properties dialog box, click the Hibernate tab, and clear the Enable hibernation check box.

  2. Repeat step 1 on the additional system.

  3. Insert a valid data CD into the CD or DVD drive of the test system.

Once your test computers are configured, you are ready to begin testing. Refer to Step 4: Create a project.

Mobile Broadband Testing Requirements

The following figure provides an overview of the Mobile broadband LAN test setup.

mobile broadband testing configuration

Make sure that the test computer is in the ready state before you begin your testing. If a test requires parameters to be set before it is run, a dialog box will be displayed for that test. Review the specific test topic for more information.

Related topics

Combined Radio Tests Prerequisites

System.Client Tests


Combined Radio Tests Prerequisites

For all combined radio tests, you must first complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Set up Combined Radio Test Tool for GPS and Bluetooth

The GPS and Bluetooth combined radio tests are triggered by the presence of a GPS radio on the system that is being tested. If the system does not have a Bluetooth radio, it automatically passes this test. The instructions here are used for systems with both GPS and Bluetooth radios.

To complete this test, you must configure two computers. The computer that you are trying to certify is referred to as the Device under Test (DUT). The second computer is referred to as the Support Device under Test (SUT), and it requires a Bluetooth radio. The computers must be less than ten meters from each other, and are preferably separated by five meters or less.

The DUT and SUT computers must be connected to each other and to the Windows HLK Controller by using an Ethernet HUB that has DHCP support. The computers can use a built-in Ethernet port or a USB dongle for the connection. Figure 1 GPS Bluetooth Configuration shows this setup:

combined radio configuration

Figure 1 GPS Bluetooth Configuration

In Windows HLK Studio, from the Machine Set, Role drop-down list, select SUT. Select the checkbox next to the designated SUT computer from the displayed list of computers, and click OK.

Set up Combined Radio Test Tool for GPS and Wireless LAN

The GPS and Wireless LAN combined radio tests are initiated by the presence of a GPS radio on the system that is being tested. If the system does not have a Wireless LAN radio, it automatically passes this test. These instructions are used for systems that have both GPS and Wireless LAN radios.

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

To complete this test, you must configure two computers: a 2.4 GHz Wireless LAN Access Point or 5 GHz Access Point (depending on the test), or one dual band Access Point. The computer that you are trying to certify is referred to as the Device under Test (DUT). The second computer is referred to as the Support Device under Test (SUT). The computers must be less than ten meters from each other, and are preferably separated by five meters or less.

The DUT and SUT computers must be connected to each other and to the Windows HLK Controller by using an Ethernet HUB that has DHCP support. The computers can use a built-in Ethernet port or a USB dongle for the connection. The SUT computer must be connected to the access point by an Ethernet connection.

The Wireless LAN Access Point must be configured by using the following settings:

  1. Configure Physical AP to a non-social channel.

  2. If the physical AP supports both 2.4GHz and 5GHz, disable the radio that is not being used for the test.

  3. Set DTIM (Delivery Traffic Indication Message) on the AP to 1. For most routers, this setting is located on the Advance Properties tab.

  4. Set the 802.11 Authentication and Encryption settings to WPA2-PSK and AES.

Figure 2 GPS WLAN Configuration shows this setup:

combined radio gps wlan configuration

Figure 2 GPS WLAN Configuration

In Windows HLK Studio, from the Machine Set, Role drop-down list, select SUT. Select the checkbox next to the designated SUT computer from the displayed list of computers, and click OK.

Set up Combined Radio Test Tool for Wireless LAN and Bluetooth

The Wireless LAN and Bluetooth combined radio tests are initiated by the presence of a Bluetooth radio on the system that is being tested. If the system does not have a Wireless LAN radio, it automatically passes this test. These instructions are for systems that have both Bluetooth and Wireless LAN radios.

Before you run the test, complete the test setup as described in the test requirements: Wireless LAN (802.11) Testing Prerequisites.

To complete this test, you must configure two computers: a 2.4 GHz Wireless LAN Access Point or 5 GHz Access Point (depending on the test), or one dual band Access Point. The computer that you are trying to certify is referred to as the Device under Test (DUT). The second computer is referred to as the Support Device under Test (SUT). The computers must be less than ten meters from each other, and are preferably separated by five meters or less.

The DUT and SUT computers must be connected to each other and to the Windows HLK Controller by using an Ethernet HUB that has DHCP support. The computers can use a built-in Ethernet port or a USB dongle for the connection. The SUT computer must be connected to the access point by using an Ethernet connection.

The Wireless LAN Access Point must be configured by using the following settings:

  1. Configure the physical AP to a non-social channel.

  2. If the physical AP supports both 2.4GHz and 5GHz, disable the radio that is not being used for the test.

  3. Set DTIM (Delivery Traffic Indication Message) on the AP to 1. For most routers, this setting is located on the Advance Properties tab.

  4. Set the 802.11 Authentication and Encryption settings to WPA2-PSK and AES.

See Figure 2 GPS WLAN Configuration for an example of this setup.

In Windows HLK Studio, from the Machine Set, Role drop-down list, select SUT. Select the checkbox next to the designated SUT computer from the displayed list of computers, and click OK.

Set up Combined Radio Test Tool for Wireless LAN, Mobile Broadband and Bluetooth

The Wireless LAN, Mobile Broadband and Bluetooth combined radio tests are initiated by the presence of a Mobile Broadband radio on the system that is being tested. If the system does not have a Wireless LAN or Bluetooth radio, it automatically passes this test. These instructions are for systems that have Bluetooth, Mobile Broadband, and Wireless LAN radios.

Before you run the test, complete the test setup as described in the test requirements: Mobile Broadband Testing Prerequisites and Wireless LAN (802.11) Testing Prerequisites.

To complete this test, you must configure two computers: a 2.4 GHz Wireless LAN Access Point or 5 GHz Access Point (depending on the test), or one dual band Access Point. The computer that you are trying to certify is referred to as the Device under Test (DUT). The second computer is referred to as the Support Device under Test (SUT), and it requires a Bluetooth radio. The computers must be less than ten meters from each other, and are preferably separated by five meters or less.

The DUT and SUT computers must be connected to each other and to the Windows HLK Controller by an Ethernet HUB that has DHCP support. The computers can use a built-in Ethernet port or a USB dongle for the connection. The SUT computer must be connected to the access point by using an Ethernet connection.

The Wireless LAN Access Point must be configured by using the following settings:

  1. Configure the physical AP to a non-social channel.

  2. If the physical AP supports both 2.4GHz and 5GHz, disable radio that is not being used for the test.

  3. Set DTIM (Delivery Traffic Indication Message) on the AP to 1. For most routers, this setting is located on the Advance Properties tab.

  4. Set the 802.11 Authentication and Encryption settings to WPA2-PSK and AES.

See Figure 2 GPS WLAN Configuration for an example of this setup.

In Windows HLK Studio, from the Machine Set, Role drop-down list, select SUT. Select the checkbox next to the designated SUT computer from the displayed list of computers, and click OK.

Related topics

System.Client Tests


Troubleshooting System Client Testing

To troubleshoot issues that occur with System.Client tests, follow these steps:

  1. Review the following Windows Hardware Lab Kit (Windows HLK) topics:

    • Troubleshooting Windows HLK Test Failures

    • System Client Testing Prerequisites

  2. Review the Windows HLK release notes for current test issues.

  3. Verify that you have installed the latest Windows HLK filters and kit updates. For more information, see Windows Hardware Lab Kit Filters.

  4. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

  5. If you cannot obtain a successful test result, contact Windows HLK Support.

Related topics

Troubleshooting Windows HLK


Webcam BasicPerf System (Manual) Test Best Practices

Physical settings and external factors often influence the test results of the Webcam Basic Performance test. This article describes how to set up a test environment to avoid these influences and achieve the most accurate video capturing test results.

NOTE

The instructions in this article are specific to integrated webcams; however, you can apply many of the same best practices to testing non-integrated webcams if you modify the test set up. For system (integrated test), audio latency and AVsync are measured and enforced. Because this is not true for non-integrated webcams, a microphone is not required for non-integrated webcam tests.

Example test environment

In this article, a test environment is created that consists of a laptop computer that has a built-in webcam and a small mirror. A built-in webcam is typically located on the top side of the lid of the laptop computer. You can use a flexible arm or tripod to hold the mirror, as shown in the following picture (Figure 1. Example Test Environment). In this example, the computer keyboard is put under a board and the mirror is put close to the webcam. By angling both the computer screen and the mirror and adjusting the distance, you can avoid noise (reflection) from ambient room lighting.

NOTE

If you are testing a non-integrated webcam, the mirror is not necessary. In this case, you can point the camera directly at the computer screen.

example test setup

TIP

You can use a "helping hand" device to hold a mirror in place; simply replace the magnifying glass with a mirror, as shown in Figure 2. Helping Hand.

Reflection

When you set up your test environment, be aware that if the computer lid is facing up, the screen can pick up reflection from ceiling lights, as shown in Figure 3. Reflection on Computer Screen. This reflection can distort test results.

reflected light on computer screen

We recommend that you tilt the computer screen away from the ceiling to avoid light reflection, as shown in Figure 4. Tilted Computer Screen. If you are testing a non-integrated webcam, tilt the webcam away from the ceiling in the same way.

tilted computer screen

Brightness

Either too much or too little lighting can affect test results. Optimal brightness levels are hard to define because the optimal lighting level depends on the individual webcam. We recommend that you adjust the room brightness by using the Windows 8 camera application until you achieve a clear captured image, as shown in Figure 5. Clear Image.

Figure 6. Poor Image, shows a captured image that is distorted by too much reflected ambient light.

Image validation

Sometimes the way that an image appears on the screen differs from the actual captured image. You can confirm the validity of the captured image by visually inspecting the captured image quality. To do this, you must add a separate computer monitor to the test environment.

Some laptop computers have a built-in webcam on the back of the laptop lid. Figure 7. Rear Camera, shows a typical location of a rear camera on a computer laptop.

You can aim the rear camera at a separate computer screen to validate the image, as shown in Figure 8. Image Capture Validation. In this example, the captured image is the same as the image on the laptop computer screen, which confirms the validity of the captured image.

Summary of best practices

  • Position the angle and distance of the laptop webcam and the mirror to avoid ambient light reflection. You can use Windows 8 camera application to position the mirror.

  • Position the mirror so that it reflects just part of the screen: it is not necessary to reflect the entire screen for test purposes. For example, even if the image on the camera is 1/4 of the screen, the test can perform the necessary calculations.

  • The captured image should be composed of neutral colors such as black, gray, and white. Bright colors (such as red, green, and blue) and changing colors can become noise; you should avoid them.

  • Because the test also measures audio latency and AVsync for integrated webcams, set the default audio playback device to be the speakers and set the volume level to be great than 70%. Set the default recording device to be the microphone and set the volume level to be greater than 70%.

  • Validate that the captured image is the same as the viewed image.


System Testing with Secure Boot

In some cases, having Secure Boot enabled on a test computer can cause the HLK Client installation to fail. You should not see this failure on Windows RT devices, but might see them on non-Windows RT devices. Follow these steps to ensure proper installation:

For system tests and non-class driver device tests

  1. Disable Secure Boot protections.

    • For x86/x64, enter the BIOS configuration and disable Secure Boot.

    • For Windows RT, install the Windows Debug Policy; you don't need to disable Secure Boot.

      NOTE

      Only OEMs and Microsoft can perform this step.

  2. Install the Windows HLK Client software.

  3. Run the following applicable tests for the test platform:

    Test

    System Must include SuperSpeed Port

    USB 3.0 Hub Enumeration Stress

    USB 3.0 Insertion Test

    USB 3.0 Speed Switch Test

    USB 3.0 Suspend Test

    USB Controller Power State Test

    USB Controller Power State Test for System

    USB Descriptor Test

    USB Device Connection S3+S4

    USB Device Control Request Test

    USB Enumeration Stress

    USB Exposed Port Controller Test

    USB Exposed Port System Test

    USB Host Controller Enable Disable Test

    USB Hub Exposed Port Test

    USB Hub Selective Suspend Test

    USB Internal Device Idle

    USB MS OS Descriptor Test (xHCI)

    USB Selective Suspend Test (xHCI)

    USB Serial Number

    USB xHCI Compliance Suite (ARM)

    USB xHCI Register System test

    USB xHCI Register Test

    USB xHCI Runtime Power Management System Test

    USB xHCI Runtime Power Management Test

    USB xHCI Transfer Speed Test

    USB3 Termination

    USB-IF Certification Validation Test (Device)

    Debug Capability Test (Logo)

    xHCI Debug Capability Compliance (Logo)

    xHCI Debug Capability Device Compliance (Logo)

    GFXIntegration Power Management Test

    WDDM CCD Test for PersistentReset Monitor

    DMA Extension Test - UART DMA

    NPCTEST - Clock Interrupt Test

    PCI Hardware Compliance Test For a Single Device (PCIHCT)

    PCI Hardware Compliance Test For Systems

    UEFI Firmware Certification Test

    PPM Perf Logo Test

    WHEAHCT Logo

    Connected Standby IO Stress

    BitLocker Drive Encryption USB BIOS Logo Test

    TPM 2.0 Hardware Interface Test (Manual)

    TPM 2.0 TCG Physical Presence Interface 1.2 Test

    TPM 2.0 UEFI Preboot Interface Test

    TPM Revoke Attestation

    ACPI Logo Test

    Crypto Capabilities - UEFI Hash Provider

    Firmware Update test

    UEFI GOP Mode Test

  4. Enter the BIOS configuration, enable Secure Boot, and restore Secure Boot to the Default configuration. For Windows RT devices, remove the secure boot debug policy.

  5. Run the rest of the HLK tests.

  6. Enter the BIOS configuration and clear the Secure Boot configuration. This restores the system to Setup Mode by deleting PK and other keys.

    NOTE

    Support for clearing is required for x86/x64 and prohibited for production Windows RT devices.

  7. Run the Secure Boot Manual Logo Test.

For devices that use drivers on Windows RT

  1. Install the Windows HLK Client software.

  2. Run device tests for only your devices.

    NOTE

    System tests and tests that use drivers that are not signed by Microsoft will fail.


System.Fundamentals

In this section

  • System.Fundamentals tests
  • System.Fundamentals additional documentation


System.Fundamentals tests

  • ACPI Logo Test
  • AutoMemoryBenchmark
  • Battery Validation - Drain Test
  • Battery Validation - Drain Test Reset
  • BitLocker Drive Encryption USB BIOS Logo Test
  • BitLocker Tpm And Recovery Password tests for AOAC devices with Legacy PCR's
  • BitLocker Tpm And Recovery Password tests for AOAC devices with PCR[7]
  • BitLocker Tpm and Recovery Password tests for non-AOAC devices for Legacy PCRs
  • BitLocker Tpm and Recovery password tests for NONAOAC devices with PCR[7]
  • BitLocker Tpm+PIN+ USB and Recovery Password tests for NON ARM devices
  • Boot from USB (ARM)
  • Boot from USB (ServerOperating System)
  • Boot Test (SYSTEM)
  • Check PM Profile
  • Check SMBIOS Mapped Address Ranges
  • Check SMBIOS Mapped Address Tables
  • Check SMBIOS System Memory Tables
  • Check SMBIOS Table Numbers
  • Check SMBIOS Table Specific Requirements
  • Connected Standby IO Stress
  • CRASH - Display Stress 4-hour WDDM Profile (32bit)
  • CRASH - Display Stress 4-hour WDDM Profile (64bit)
  • Crashdump Support Test (LOGO)
  • Crypto Capabilities - Performance
  • Crypto Capabiltiies - Functionality
  • DE OOBE_EOW Sequence Tests
  • DE Perf Settings Test
  • Debug Capability Test (Logo)
  • Disk Stress (SYSTEM)
  • Display Mode Filter Check
  • Driver Firmware Configuration Test
  • DXGI HybridPresent
  • DXGI HybridPresent - PnPStop
  • DXGI HybridPresent (WoW64)
  • HW-DRM Video - Play protected content using hardware decryptor
  • Hardware Reserved Memory Test
  • HybridPowerManagement_AppIdle
  • HybridPowerManagement_AppIdleMonitorOff
  • HybridPowerManagement_AppRunning
  • HybridPowerManagement_AppRunningMonitorOff
  • HybridPowerManagement_NoApp
  • HybridPowerManagement_NoAppMonitorOff
  • INVDIMM Error Injection Test
  • INVDIMM _DSM Test
  • Lid Basic Requirement Test
  • Modern Standby Basic Requirement Test on AC-power Source
  • Modern Standby Basic Requirement Test on DC-power Source
  • Modern Standby Check Thermal Zones
  • Modern Standby Duration Test
  • Modern Standby Exit Latency Stress
  • Modern Standby Stress with Driver Verifier's Concurrency Stress
  • Modern Standby Wake on Voice Basic Test on AC-power Source
  • Modern Standby Wake on Voice Basic Test on DC-power Source
  • MultiPhaseResume
  • NVDIMM-N _DSM Stress Test
  • NVDIMM-N _DSM Test
  • NVDIMM-N Error Injection _DSM Test
  • NVDIMM-N Persistence Loss Test
  • Operate In Nano Server Test
  • Play protected content using hardware decryptor
  • Processor Power Management
  • Rapidfile Test (SYSTEM)
  • Reflash Device Connected via Proxy Client
  • Run Dxgkrnl Smasher MITM module
  • Runtime Power Focused Stress with Driver Verifier's Concurrency Stress
  • ScatterGather (SYSTEM)
  • Secure Boot Logo Test
  • Secure Boot Logo Test - (WoW64 for ARM64)
  • Secure Boot Manual Logo Test
  • Secure Boot Manual Logo Test - (WoW64 for ARM64)
  • Secure Boot Test - Customized Deployment Basic Test
  • SecurityGuard Test
  • Signed Driver Check (CheckLogo)
  • Storage Performance CS
  • Syscache (SYSTEM)
  • System - Embedded Signature Verification
  • System - PNP (disable and enable) with IO Before and After (Reliability)
  • System - Reboot Restart with IO During (Reliability)
  • System - Sleep with IO Before and After (Reliability SysFund)
  • System Audio - AC3 Test
  • System Audio - Audio Engine Core Test (UMACoreTest)
  • System Audio - Audio Engine Test (UMATest)
  • System Audio - Audio Logo Test
  • System Audio - Audio Logo Test - Phone
  • System Audio - Audio Logo Test - Glitch
  • System Audio - Class Driver Audio Logo Test - Desktop
  • System Audio - Device Power State Transition Test
  • System Audio - DRM Test
  • System Audio - Hardware Offload of Audio Processing Test
  • System Audio - KS Position Test
  • System Audio - KS Topology Test - Mobilecore
  • System Audio - KS Topology Test - WinBlue
  • System Audio - Lullaby Test
  • System Audio - Lullaby Test for Phone
  • System Audio - MediaCapture API Test - Test Audio Capture
  • System Audio - MFCaptureEngine API Test - Capture AAC Audio samples from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture AMR_NB Audio to a file from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture Audio to an AAC file from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture MP3 Audio samples from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture MP3 Audio to a file from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture PCM Audio samples from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture PCM Audio to a wav file from the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture WMA9 audio samples the default capture pin
  • System Audio - MFCaptureEngine API Test - Capture WMA9 Audio to an wma file from the default capture pin
  • System Audio - SysFX Test
  • System Audio - SysFX Test - Mobilecore
  • System Audio - UAA Test (Manual)
  • System Audio - Verify Audio EffectsDiscovery - Mobilecore
  • System Audio - Verify Audio EffectsDiscovery (Manual)
  • System Audio - Wave Test
  • System Audio - Wave Test - Threshold
  • System Network Device Power Requirements (NDISTest 6.5 - PM_Requirements)
  • TDI filters and LSPs are not allowed
  • TPM 2.0 - Supplemental test
  • TPM 2.0 Attestation Test
  • TPM 2.0 Core Provisioning Test
  • TPM 2.0 EK Certificate Tests
  • TPM 2.0 TCG Physical Presence Interface 1.3 Test
  • TPM 2.0 UEFI Preboot Interface Test
  • TPM 2.0 UEFI Preboot Interface Test - (WoW64 for ARM64)
  • TPM 2.0 Verify Existence and Device Requirements Test
  • TPM Based Virtual Smart Card Interface Test
  • TPM Platform Crypto Provider Key Storage Provider Test
  • UEFI Tpr Test
  • USB Controller Driver Test
  • USB Exposed Port System Test
  • USB Generic HID Test
  • USB Internal Device Idle Test - Compat
  • USB MUTT Firmware Update for Systems
  • USB Type-C ACPI Validation
  • USB Type-C Connection Exerciser Loop Test
  • USB xHCI Transfer Speed Test
  • USB3 Termination
  • Validate HAL Extension have no Imports
  • Verifies PS2 Devices have a unique Plug and Play ID
  • Verify Graphics Device Count is one
  • Verify HAL Extension serviceable
  • Verify System.Fundamentals.Security.VirtualizationSupport
  • Verify VESA and CEA required display modes
  • Watchdog Timer Test
  • WDDM PnPStopModeSwitch Test
  • WGF Feature Level 9.3 Support
  • WGF Feature Level 9.3 Support (WoW64)
  • WGF11 D3DSystemCheck - Hybrid
  • WGF11 D3DSystemCheck - Hybrid (WoW64)
  • WindowsToGo Boot Test
  • WindowsToGo UEFI USB Class Entry Test
  • xHCI Debug Capability Compliance (Logo)


ACPI Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0861b530-868e-427e-94d1-2068f2e92a9a

This test checks the system ACPI tables against a set of ACPI 5.0 requirements for general resource consistency (_CRS) and correct usages of _DIS/_STA methods. It also validates specific ACPI requirements for HIDI2C and five-button array devices, as well as those systems that support InstantGo. In addition, the test ensures proper ACPI definition of TPM 1.2/2.0 devices per Hardware Certification requirements.

Test details
Specifications
  • System.Fundamentals.Firmware.ACPI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


AutoMemoryBenchmark

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cdcc3607-ae2c-4e38-954b-fc6a2ef27e63

This test consists of multiple scenarios where a driver is evaluated for memory being consumed in the scenario. The benchmark aggregates results from different memory metrics to arrive to a final score for the scenario. This score is the key metric developer should optimize and the metric which is evaluated for Windows Hardware certification.

The memory benchmark is currently comprised of the following six scenarios:

  • Idle

  • Present

  • Textures

  • Buffers

  • Surfaces

  • Upload

For each of the rendering scenarios (all scenarios except Idle), the goals for the scenario are established such that:

  • 2MB allowed for OS overhead.

  • +2MB allowed for driver overhead per GPU in a link for x86 and x64 systems, +1MB per GPU in a link allowed for ARM systems. The number of linked GPUs on a system is determined and multiplied by the system-determined size per GPU to give the total driver overhead allowed.

  • +Size of surfaces explicitly created by application + 7.5% for alignment/padding in the case of non-power of 2 surfaces.

  • +4KB overhead per surface created on 32-bit systems, +8KB overhead per surface on 64-bit systems.

  • Except for the Present scenario, the rendering scenario targets are rounded to the next half-megabyte boundary.

Test details
Specifications
  • System.Fundamentals.Graphics.DisplayRender.Performance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Benchmark
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

A stack that does not go all the way to thread creation indicates that ETW is having a problem walking the stack when the event is fired. ETW will log a maximum of 96 stack frame, but that limit is rarely hit. Typically the problem is a driver compiled with FPO optimization causing the stack walk to end abruptly.

If you do not have a stack, ensure that you are running the benchmark with the -details option.

For additional troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

Command syntax

Command option | Description
AutoShell.exe Memorywlk.xml | Runs the test for WHLK
NOTE

For command line help for this test binary, type /h.

File list

File | Location
AutoShell.exe | [WTT\TestBinRoot]\nttest\windowstest\graphics\perfx2</em>
Memorywlk.xml | [WTT\TestBinRoot]\nttest\windowstest\graphics\perfx2</em>
Perl.exe | [WTT\OSBinRoot]\Perl\perl.exe
TestX.man | [WTT\TestBinRoot]\nttest\windowstest\graphics\perfx2</em>
setup.pl | [WTT\TestBinRoot]\nttest\windowstest\graphics\perfx2\MemoryBenchmark


Battery Validation - Drain Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/11c8b6c9-5aef-4da7-98ad-85cd0d9a821f

This test is available when 'Systems' option of the HLK Selection UI is selected.

Unlike most HLK tests, this test will have to be run four times (back to back) for proper test coverage. Each time when the test is run it will indicate what iteration its on, for example when the test is run for the first time it will print 'Iteration 1 of 4' in the log file. On the final iteration the test will print a message such as 'Iteration 4 of 4'.

In each iteration system is either expected to be charged or discharged, the log window will indicate if the system is on charge cycle or discharge cycle. If the test is on a charge cycle it will display a message 'Waiting for system to go on AC', and when the test is on discharge cycle it will display 'Waiting for system to go on DC', please plug in the charger and unplug the charger respectively. Note that log window may not be visible on all systems.

Also at the end of each test iteration the test indicates if that iteration was successful with message 'Test iteration passed' message. If the test iteration fails 'Test iteration failed' message will be printed in the log, next time when the test is run it will re-run the last iteration.

These are the four iterations of the test:

(1) System is put on DC and discharged.

(2) System is put on AC and recharged.

(3) System is put on DC and discharged.

(4) System is put on AC and recharged.

NOTE

If it is desired to re-start the test iteration, please run the 'Battery Validation - Drain Test Reset' test (only once), after that this test will commence from iteration one again.)

Test details
Specifications
  • System.Fundamentals.Battery.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1440
Category | Development
Timeout (in minutes) | 1440
Requires reboot | false
Requires special configuration | false
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.


Battery Validation - Drain Test Reset

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7fd149e0-0461-4678-9a6b-4fa026044e5b

Resets the "Battery Validation - Drain Test" and causes it to commence from the first iteration on the next run.

Test details
Specifications
  • System.Fundamentals.Battery.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


BitLocker Drive Encryption USB BIOS Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/39d176bc-059b-43aa-ae26-e530bdec23bf

This test determines whether USB flash devices support reading during the pre-operating system environment.

This test restarts the machine one time during the test and requires that a USB drive is plugged into system during the test.

Test details
Specifications
  • System.Fundamentals.TrustedPlatformModule.SupportSecureStartUpInPreOS
  • System.Fundamentals.USBBoot.SupportSecureStartUpInPreOS
  • System.Fundamentals.TrustedPlatformModule.TPMEnablesFullUseThroughSystemFirmware
  • System.Fundamentals.TrustedPlatformModule.Windows7SystemsTPM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

This test creates a file on the USB mass media and then reboots the computer to determine whether the file can be read during the bootmgr phase (pre-operating system environment).

NOTE

Secure Boot should be disabled before running this test.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

Review the test log

  1. Go to the Results page in Windows HLK Studio and open the Logs node.

  2. Click the BitLocker Device Encryption USB BIOS Logo Test node.

  3. Open the following logs:

    • Under Prep and USB Write Test: FveUSBPreTest.xml

    • Under Parse Result and Cleanup: FveUSBPostTest.xml

  4. At the end of each log file, the numbers of test cases that passed and failed are listed.

  5. If a test case failed, search the log file for Error File and Result=Fail for more information.


BitLocker Tpm+PIN+ USB and Recovery Password tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6db734d1-6bdc-4da5-87f9-51e0948e21b1

This manual test determines whether PCR [0, 2, 4, 11] are consistent across reboots. This test also tests whether PCRs change between booting with an USB and docking station plugged in, and booting without these devices

Test details
Specifications
  • System.Fundamentals.TrustedPlatformModule.TPMRequirements
  • System.Fundamentals.TPM20.TPM20
  • System.Fundamentals.TrustedPlatformModule.TPMEnablesFullUseThroughSystemFirmware
  • System.Fundamentals.TPM.CS.ConnectedStandby
  • System.Fundamentals.TPM.NonCS.NonConnectedStandby
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Secure boot should be enabled if it is supported by the platform.

This test prompts you to remove USB and docking station and later prompts you to insert these devices. This test adds a TPM+PIN protector on the operating system volume. The PIN is hardcoded to six zeroes. After the protector is added, this PIN is required to boot the system. You will be prompted to take note of this before each restart.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

If this test fails, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

  1. Make sure you can see fveapi.dll in %systemroot%\system32\.

  2. Check test output directly from command prompt when the test runs or open te.wtl in the HLK Manager.

  3. If a test script fails, check the BitLocker status:

    • Manage-bde -status [volume]

  4. Collect BitLocker event logs from event viewer at two locations:

    • Filter \Windows logs\System logs by event sources started with BitLocker

    • Applications and Services Logs\Microsoft\Windows\BitLocker-API\Management

  5. Run **tpm.msc ** to ensure that the TPM Status is ON and that ownership has been taken.

  6. Check TCG logs

    • Collect TCG log (*.txt).

    • Compare multiple copies of the TCG log and see whether PCR [0, 2, 4, 11] are consistent across reboot and hibernate.

NOTE

If the BitLocker WHLK test results in a recovery event, the BitLocker recovery key is 48-zeros (0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000).


Boot from USB (ARM)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b042c002-e71f-4674-a51b-ba05d9157c69

This test verifies that a computer can boot Windows from all exposed USB 2.x and 3.x ports. This is used for Windows 8 features such as Recovery and Portable Workspaces.

Test details
Specifications
  • System.Fundamentals.USBBoot.BootFromUSB
Platforms
    Supported Releases
    • Windows 10
    • Windows 10, version 1511
    • Windows 10, version 1607
    • Windows 10, version 1703
    • Windows 10, version 1709
    • Windows 10, version 1803
    • Next update to Windows 10
    Expected run time (in minutes) | 15
    Category | Scenario
    Timeout (in minutes) | 900
    Requires reboot | false
    Requires special configuration | true
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Fundamentals additional documentation

    Running the test

    Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites. In addition, insert a bootable USB storage device, at least 500MB in size or larger. If the test system has PC\AT firmware, configure it to boot from USB first.

    The test will do the following steps:

    1. Provision the USB Drive with Windows PE.

    2. Restart the host operating system and attempt to boot from the USB drive.

    3. Restart the system from the USB drive three times.

    4. Boot back into to host operating system and format the USB drive.

    NOTE

    You must insert the USB drive into a 3.0 port if there is one on the machine, otherwise the test will fail. Additionally, you must provide the supplemental content (a Windows PE image capable of booting on the ARM system).

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    For troubleshooting information, see Troubleshooting System Fundamentals Testing.

    This test will always return Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. The test will only fail if the system doesn't support creating firmware boot entries, boot from USB, or if the USB drive is not enumerated during warm reboot.

    More information

    Parameters

    Parameter name | Parameter description
CopyPathPWLogoDir |
LocalPWTestPath |
LLU_LclAdminUsr |
LLU_NetAccessOnly |
WIMSourceFile | Source WinPE image file path on the HCK server.


Boot from USB (ServerOperating System)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ff204b68-3edf-42fe-84f2-80beee690390

[This content isn't available yet.]

Test details
Specifications
  • System.Fundamentals.USBBoot.BootFromUSB
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, see WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

Command syntax

Command | Description
Host /beg | This command starts the test.
Host /end | This command completes the test.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
Host.exe | [CopyPathPWLogoDir]</p>
Ufd.exe | [CopyPathPWLogoDir]</p>
Winpe.wim | [OsBinRoot\media\en-us</p>
pwrtest.exe | [CopyPwrtestDir]</p>
S3Resume.vbs | [CopyPwrtestDir]</p>

Parameters

Parameter name | Parameter description
CopyPathPWLogoDir |
LocalPWTestPath |
LLU_LclAdminUsr |
LLU_NetAccessOnly |
CopyPwrtestDir |


Boot Test (SYSTEM)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b66d9ef-fac0-4215-814c-e98f5e6ed63c

This test determines whether the test client is booting from a particular device and if the device is configured correctly.

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see Boot Test (LOGO).

Test details
Specifications
  • System.Fundamentals.Firmware.Boot.SystemWithBootDeviceGreaterThan
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.


Check PM Profile

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c97fc6d3-9a05-4ad9-97d0-d598492e1b7d

This test checks the Preferred_PM_Profile in the FADT table is one of the following: Desktop (1), Mobile (2), Appliance PC, All In one (6), Tablet, or Tablet convertible (8).

Test details
Specifications
  • System.Fundamentals.PowerManagement.PowerProfile
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.


Check SMBIOS Mapped Address Ranges

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/746bad65-cf37-490b-a0fd-afe5623e282d

Test SMBIOS for compliance with the specification. The local machine's SMBIOS structure table is used unless a binary data file is provided. For more information on errors, please refer to the SMBIOS specification.

Test details
Specifications
  • System.Fundamentals.SMBIOS.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
V | Verbose output (recommended)
SVVP | Run in Server Virtualization Validation Program mode

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Check SMBIOS Mapped Address Tables

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f57712ed-3d2f-4cee-943e-6480ad234534

Test SMBIOS for compliance with the specification. The local machine's SMBIOS structure table is used unless a binary data file is provided. For more information on errors, please refer to the SMBIOS specification.

Test details
Specifications
  • System.Fundamentals.SMBIOS.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
V | Verbose output (recommended)
SVVP | Run in Server Virtualization Validation Program mode

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Check SMBIOS System Memory Tables

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bfa9369f-32c6-4d6f-8efd-8e27019fc17e

Test SMBIOS for compliance with the specification. The local machine's SMBIOS structure table is used unless a binary data file is provided. For more information on errors, please refer to the SMBIOS specification.

Test details
Specifications
  • System.Fundamentals.SMBIOS.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
V | Verbose output (recommended)
SVVP | Run in Server Virtualization Validation Program mode

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Check SMBIOS Table Numbers

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f1d4e2b2-43f9-4260-bcf5-2bdf6c1b659e

Test SMBIOS for compliance with the specification. The local machine's SMBIOS structure table is used unless a binary data file is provided. For more information on errors, please refer to the SMBIOS specification.

Test details
Specifications
  • System.Fundamentals.SMBIOS.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
V | Verbose output (recommended)
SVVP | Run in Server Virtualization Validation Program mode

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Check SMBIOS Table Specific Requirements

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/751627d6-dde1-47d9-81a4-057a2aa1a3be

Test SMBIOS for compliance with the specification. The local machine's SMBIOS structure table is used unless a binary data file is provided. For more information on errors, please refer to the SMBIOS specification.

Test details
Specifications
  • System.Fundamentals.SMBIOS.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
V | Verbose output (recommended)
SVVP | Run in Server Virtualization Validation Program mode

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Connected Standby IO Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9247100-a8e9-4620-a7ef-5ebd438c86a1

This test verifies that Connected Standby is functioning in the presence of IO events and that data corruptions do not occur across Connected Standby transitions.

Test details
Specifications
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 480
Category | Scenario
Timeout (in minutes) | 28800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Before running the test, ensure that the system is able to enter and exit Connected Standby reliably. The test will stress its Connected Standby support. Also, ensure that there is greater than 2GB of free space on the boot volume to ensure that RapidFile is able to write to the disk.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

If the Check Configuration section fails, look at the log from the "Run ParseTrace.exe" task to determine why it failed. It may be caused by the system not entering in Connected Standby in response to the test issuing that command.

If the test fails on the Long Haul section then you can look into the last wtl logs generated by SCSI Compliance, RapidFile, and the Connected Standby script to determine what the cause of the error was.

More information

The test consists of three parts: setup, check configuration, and long haul.

The setup part copies the files to the system, exempts processes from the DAM, and enables test signing. Failures in this section are straightforward and the cause can be determined by viewing the error codes returned from the task.

The check configuration part runs Connected Standby, RapidFile, and SCSI Compliance tests in parallel for a few minutes while tracing the disk activity and the power states of the devices. This is to ensure that the devices are entering the proper power states in response to the test. Most commonly, a failure will be seen in the "Run ParseTrace.exe" task which evaluates the results from the ETW traces and determines if the devices entered the proper states. Viewing the task log for this task should reveal the cause of failure.

If the first two parts passed, the test enters into the long haul part where the same three files are run in parallel as in the check configuration part, but this time without the ETW tracing. The tasks run for 8 hours and passes as long as the system is able to continue running for that time and data integrity is maintained.

Command syntax

Command option | Description
/Process | Process to run: ConnectedStandby, RapidFile, RapidFileVerify, or SCSICompliance.
/Duration | Duration to run the test (seconds).
/Device | Drive letter or physical drive number of device to test.
/Scenario | Scenario type to test: CheckConfiguration, Stress, LongHaul, or SelectiveSuspend. Default value: LongHaul
NOTE

For command line help for this test binary, type /h.

Command usage

Command | Description
cscript.exe ConnectedStandbyIOStress.wsf /Process:ConnectedStandby /Duration:[RunDurationSeconds] /Scenario:[Scenario] | Runs the Connected Standby test.
cscript.exe ConnectedStandbyIOStress.wsf /Process:RapidFile /Duration:[RunDurationSeconds] /Device:[StorageDriveLetter] /Scenario:[Scenario] | Runs the RapidFile test.
cscript.exe ConnectedStandbyIOStress.wsf /Process:SCSICompliance /Duration:[RunDurationSeconds] /Device:[StorageDriveNumber] /Scenario:[Scenario] | Runs the SCSI Compliance test.
NOTE

For command line help for this test binary, type /h.

File list

File | Location
ntlog.dll | <osbinroot>\nttest\commontest\ntlog</p>
ntlogger.ini | <osbinroot>\nttest\commontest\ntlog</p>
Damx.exe | <testbinroot>\cstools\dam</p>
Stresslog.dll | <testbinroot>\nttest\basetest\core_file_services\shared_libs</p>
Fbslog.dll | <testbinroot>\nttest\basetest\core_file_services\shared_libs\fbslog</p>
Rapidfile.exe | <testbinroot>\nttest\basetest\core_file_services\shared_tests\wdk
ParseTrace.exe | <testbinroot>\nttest\driverstest\storage\sd\lowpower</p>
ConnectedStandbyIOStress.wsf | <testbinroot>\nttest\driverstest\storage\wdk\connectedstandy</p>
Wttlog_obj.js | <testbinroot>\nttest\driverstest\storage\wdk</p>
Scsicompliance.exe | <testbinroot>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
DiskDeviceObjLink | Assigned by Create Storage Parameters.
StorageDriveLetter | Assigned by Create Storage Parameters.
StorageDriveNumber | Assigned by Create Storage Parameters.
Destructive | (0,1) 0=Passive, 1=Destructive


Crypto Capabilities - Performance

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4610a28e-67c9-47fe-a46e-b207fdc1c35a

The crypto performance test measures the performance of AES using CBC and ECB chaining modes on 32 kilobyte blocks. Crypto performance is measured through the Cryptographic Hardware Assist (CHAT) driver.

Test details
Specifications
  • System.Fundamentals.Firmware.CS.CryptoCapabilities
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

The system must be configured to use a third party cryptographic driver with the CHAT driver.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NAO | LLU_NetAccessOnly
WS_LocalTestBinRoot |
TestDataPath |
TestBinPath |
LocalTestPath |
HLKBinPath |
HLKDataPath |


Crypto Capabiltiies - Functionality

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06e660a6-5f77-4b57-a026-ad68417db4cf

The crypto functionality test verifies that crypto functionality works as expected on the target system. The test does a full general pass for crypto using all supported crypto algorithms and additional testing for AES providers using the Cryptographic Hardware Assist (CHAT) driver.

Test details
Specifications
  • System.Fundamentals.Firmware.CS.CryptoCapabilities
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

The system must be configured to use a third party cryptographic driver with the CHAT driver.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NAO | LLU_NetAccessOnly
WS_LocalTestBinRoot |
TestBinPath |
LocalTestPath |


DE OOBE_EOW Sequence Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dccadddb-5d0c-471f-a05c-2584ed8ef41b

This test verifies that Encryption On Write (EOW) of the volumes is started after completion of OOBE. It also tests if Device Encryption is not blocked by the OEM by setting registry key PreventDeviceEncryption.

Test details
Specifications
  • System.Fundamentals.TPM.CS.ConnectedStandby
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Secure boot should be enabled.

This test returns Pass or Fail.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

If this test fails, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

  1. Check test output directly from command prompt when the test runs or open te.wtl in the HLK Manager.

  2. If a test script fails, check the BitLocker status:

    • Manage-bde -status [volume]

  3. Collect BitLocker event logs from event viewer at two locations:

    • Filter \Windows logs\System logs by event sources started with BitLocker

    • Applications and Services Logs\Microsoft\Windows\BitLocker-API\Management

  4. Check TCG logs

    • Collect TCG log (*.txt).

    • Compare multiple copies of the TCG log and see whether PCR [7, 11] are consistent across reboot and hibernate.

    • Make sure WHLK tests with TPM in the name pass.


DE Perf Settings Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/707289ea-f51b-444f-aa49-c26eaa61780b

This test verifies correct registry settings that we recommend OEMs to set for optimal Device Encryption (DE) performance.

Test details
Specifications
  • System.Fundamentals.TPM.CS.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Benchmark
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Certification Kit (Windows HLK) Studio.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.


Debug Capability Test (Logo)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/83974a17-ec9f-4996-a0d6-5873bf1eb3ac

This test measures the ability of a test computer to support debug operations using an xHCI controller, EHCI controller, serial port, 1394 controller, or a network adapter. The test validates that at least one debug port is available.

Test details
Specifications
  • System.Fundamentals.DebugPort.SystemExposesDebugInterface
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

To complete this debug test, you must configure two computers. The computer that you are trying to certify is the System under Test (SUT). The second computer is the Host on which the Windows debugger will run. These computers must meet the Windows HLK prerequisites and must be included in the same computer pool. For more information, see Windows HLK Prerequisites. If the device being tested is an XHCI controller, an XHCI controller must be included in both computers. If the XHCI controller in the SUT has any user-accessible ports, the controller must have debug capability.

IMPORTANT

You must have a cable that is appropriate for the debug transport that is being verified.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from HLK Studio.

More information

Command syntax

In the Parameters window Transport field, enter one transport type (NET, 1394, USB, or Serial). Based on the transport you entered, you must provide the following additional parameters.

Transport type Required parameters Comments

NET

NetHostIP

You must specify a Host IP. If there's more than one controller on the SUT computer, you must specify a BusParams value. Enter Busparams as b.d.f where b, d, and f are the bus number, device number, and function displayed in the device's properties window in Device Manager.

1394

1394Channel

Default is 1. If there's more than one controller on the SUT computer, you must specify a BusParams value. Enter Busparam as b.d.f where b, d, and f are the bus number, device number, and function displayed in the device's properties window in Device Manager.

USB

UsbTargetName

Default is default. If there's more than one USB host controller on the SUT computer, you must specify a BusParams value. Enter Busparams as b.d.f where b, d, and f are the bus number, device number, and function number of the USB host controller that you are using for debugging. These numbers are displayed in the USB host controller's Properties window in Device Manager.

Important

If you are using an EHCI host controller on the SUT computer, the cable must be connected to Port 1 of the controller. You can use the UsbView tool to identify Port 1. USBView is included in the WDK.

Serial

Not required

Default values are sufficient. If necessary, adjust any serial parameter as needed (prefix Serial_).

Parameters

Parameter name | Parameter description
Transport | Valid values are: net, usb, 1394, or serial
NetHostIP | The IP address of the host machine
NetPort | Port number for kernel debugging. Port 50000 is recommended.
NetKey | The encryption key for kernel debugging. The default key is recommended.
BusParams | Ethernet,1394, USB: Used only when more than one controller is present in the system under test. Enter bus params as b.d.f where b, d, and f are the bus number, device number, and function displayed in the relevant device manager properties page.
SerialTargetPort | COM port number on the system under test
SerialHostPort | COM port number on the host machine
SerialBaudRate | BAUD rate for serial communications
UsbTargetName | Any string is acceptable. The default is recommended.
1394Channel | The common 1394 channel that will be used on both the host and system under test.


Disk Stress (SYSTEM)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/21f59bdf-7d7f-48df-96cd-a18a10ee08ac

This test stresses the disks on a computer by sending as much asynchronous I/O as the device can handle. The test should reach the bandwidth limit of the test device for the given test system configuration.

NOTE

This is a server-specific version of an existing test. For more information, please see Disk Stress (LOGO).

Test details
Specifications
  • System.Server.SystemStress.ServerStress
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Scenario
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation
  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the following test requirements:

  • System Server Testing Prerequisites

  • Test Server Configuration

  • Hard Disk Drive Testing Prerequisites

  • Optical Disk Drive Testing Prerequisites

If you are testing any drive that requires media or testing in system-mode on a computer, you must insert media into the drives. The media that is used must be formatted and contain data that occupies at least 50% of the media's capacity.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing and Troubleshooting System Server Testing.

More information

The test is passed the instance path of the target test device. It finds all hard disks and optical drives that are equal to or connected to the test device. The test will then go through the following scenarios on all of the found devices:

  • Sequential read

  • Sequential write

  • Sequential verify (write followed by read and comparison)

  • Random read

  • Random write

  • Random verify

The test is given a fixed run time and runs each scenario for a fraction of that time. In the case of six scenarios and a run time of 90 minutes, each scenario is run for 15 minutes. The test displays dialog boxes with the progress of the current scenario. Any write scenarios (including verify) are skipped for optical devices. The size of the individual data transfers is determined by a command-line parameter; the default size for the logo test is 32 KB.

The test tries to do raw writes, bypassing any file system that is mounted on the hard disk if it can. The test attempts raw writes if one of the following occurs:

  • The test can find a raw, unpartitioned disk.

  • The test can find a raw, unformatted volume.

  • The test can find a volume that it can dismount.

If none of the preceding situations are available, the test performs I/O through the file system. This action is more CPU intensive and might not give accurate bandwidth and latency measurements for the device. In the third situation (the test finds a volume that it can dismount), which is the most common mode that the test is run in, the test allocates a test file to use and writes only to the extents of that file. This situation ensures that the test never corrupts the file system of the device that it is testing.

The amount of space that the test uses is determined by the free space that is available on the test device. To ensure best device performance, you should delete any unnecessary files from the test device and should cleanly format or defragment the device before running the test. The test warns you if the target's fragmentation might influence the test results.

Even though this test does measure device performance, there is currently no test case in the Logo version of this test that passes or fails based on these measurements.

Command syntax

Command option | Description
DiskIo | Runs the test.
WARNING

For command line help for this test binary, type /h.

File list

File | Location
DiskIo.exe | <[testbinroot]>\nttest\driverstest\storage\wdk
StorageDevices.dll | <[testbinroot]>\nttest\driverstest\storage\wdk

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Net access LLU
LLU_LclAdminUsr | Admin LLU
TestDuration | Duration of the entire test.
BlockSize | Block size of each transaction.
Scenarios | Scenarios to execute
Settings | Additional Settings


Driver Firmware Configuration Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b058e1e-0578-4e78-a0fa-e826fd9d75ec

This test evaluates the devices and drivers on a system. After completion, the test outputs a log of devices and drivers that exist on the system.

The follow things must happen for the test to complete successfully:

  • The following SMBIOS fields must be populated: Manufacturer, Family, Product Name, BIOS Vendor, BIOS Version, System BIOS Major Release, System BIOS Minor Release, and Enclosure Type.

  • The INF fields for the drivers on the system must contain the basic required information (Hardware IDs, Manufacturer, Description, etc.)

  • BitLocker must be enabled.

Test details
Specifications
  • System.Fundamentals.smbios.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Scenario
Timeout (in minutes) | 600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LocalWorkingDir | Working directory
LocalFileDir | Working directory
UpdatedDriverSet | Local location where updated driver set is copied to
UpdatedDriverSetSource | Source location of updated driver set to use in the mixed states
MsAccountLocalUsername | Username of MS Account
MsAccountUsername | Online username of MS Account
MsAccountPassword | Password of MS Account
ToolsSource | Tools source on controller


DXGI HybridPresent

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5c36282e-517b-4e42-9ff6-ead7cf24d404

This test runs on Microsoft Supported Graphics Hybrid Configurations as if it is on the DList. The test runs a simple present scenario (present a frame) and does following validations:

  • Conformance of the displayed image

  • Validation of CrossAdapter surfaces (unless Vista BLT presentation model)

  • Validation of Presents (CrossAdapter present versus Regular present)

The test iterates on the following:

  • Presentation models - Blt, Flip, DirectFlip

  • Fullscreen vs. Windowed

  • Swapchain surface format

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Cross Adapter surface validation or Cross Adapter Present validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI HybridPresent - PnPStop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/47bb4b52-d473-45f3-bbb1-3b215288f8b2

This test runs on Microsoft Supported Graphics Hybrid Configurations as if they were on the DList. It runs a present scenario (that is, present for a period of time), while in parallel PnP Enabling and PnP Disabling IGPU, DGPU or both. It does following validations:

  • Conformance of the displayed image

  • Validation of Presents (CrossAdapter presents when both GPUs are enabled; Regular presents when one or both GPUs are disabled).

Tests iterate on following:

  • Presentation models - Blt, Flip, DirectFlip

  • Fullscreen versus Windowed

  • PnPDisable/PnPEnable scenario (stop iGPU, stop dGPU, stop both GPUs)

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description/Workaround
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. The image might be helpful in diagnosing the issue.
Cross Adapter Present validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information it gets from ETW events. The output might be helpful in diagnosing the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.
-TimeToExecute:<ms> | This value controls how long (in microseconds) each test case will run. Default value: 60000

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


DXGI HybridPresent (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7256f4e8-6440-4717-8089-0079efc1514b

This test runs on Microsoft Supported Graphics Hybrid Configurations as if it is on the DList. The test runs a simple present scenario (present a frame) and does following validations:

  • Conformance of the displayed image

  • Validation of CrossAdapter surfaces (unless Vista BLT presentation model)

  • Validation of Presents (CrossAdapter present versus Regular present)

The test iterates on the following:

  • Presentation models - Blt, Flip, DirectFlip

  • Fullscreen vs. Windowed

  • Swapchain surface format

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Cross Adapter surface validation or Cross Adapter Present validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


Hardware Reserved Memory Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bde9eb4f-96e8-4be7-9f7b-22c6169e09ad

This test checks the amount of memory that is reserved by the hardware (including drivers or firmware), and that is not available to Windows or user applications. Reducing hardware reserved memory provides an improved user experience and better overall system responsiveness due to greater availability of memory for user applications.

Test details
Specifications
  • System.Fundamentals.Firmware.HardwareMemoryReservation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.


HybridPowerManagement_AppIdle

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4441a200-d055-4cca-b81a-4f25093e3f72

Power management tests run on dGPU while analyzing Power-Management ETW events that are generated by DXGKrnl. For this test, an application is running on DGPU, but it is idle and nothing has been rendered for some time. The test performs following validations:

  • Validation of Power components - the test validates that all required power components are declared by the driver.

  • Validation of latency - the driver reports latency (time for a component to transition to another F-state). The test checks that this number matches the actual latency.

  • Validate Active/Idle state of the component - checks that power components are in expected Active/Idle state (based on the test scenario).

  • Validate DState - checks that DGPU is in expected D state (based on the test scenario).

  • Validate DGPU process - checks which processes have devices on DGPU. Anything other than the test itself will result in failure.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


HybridPowerManagement_AppIdleMonitorOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6cc38283-b4f1-48d9-99fe-e513c70d6c72

Power management tests run on dGPU while analyzing Power-Management ETW events that are generated by DXGKrnl. For this test, an application is running on DGPU, but it is idle and nothing has been rendered for some time. The monitor is turned OFF. The test performs following validations:

  • Validation of Power components - the test validates that all required power components are declared by the driver.

  • Validation of latency - the driver reports latency (time for a component to transition to another F-state). The test checks that this number matches the actual latency.

  • Validate Active/Idle state of the component - checks that power components are in expected Active/Idle state (based on the test scenario).

  • Validate DState - checks that DGPU is in expected D state (based on the test scenario).

  • Validate DGPU process - checks which processes have devices on DGPU. Anything other than the test itself will result in failure.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


HybridPowerManagement_AppRunning

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ec4db27-53b4-4aeb-a340-f892a2175e8a

Power management tests run on dGPU while analyzing Power-Management ETW events that are generated by DXGKrnl. For this test, an application is running on DGPU. The test performs following validations:

  • Validation of Power components - the test validates that all required power components are declared by the driver.

  • Validation of latency - the driver reports latency (time for a component to transition to another F-state). The test checks that this number matches the actual latency.

  • Validate Active/Idle state of the component - checks that power components are in expected Active/Idle state (based on the test scenario).

  • Validate DState - checks that DGPU is in expected D state (based on the test scenario).

  • Validate DGPU process - checks which processes have devices on DGPU. Anything other than the test itself will result in failure.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


HybridPowerManagement_AppRunningMonitorOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/73381a7e-9028-45e1-9eb4-f0b5478b0d22

Power management tests run on dGPU while analyzing Power-Management ETW events that are generated by DXGKrnl. For this test, an application is running on DGPU and the monitor is turned OFF. The test performs following validations:

  • Validation of Power components - the test validates that all required power components are declared by the driver.

  • Validation of latency - the driver reports latency (time for a component to transition to another F-state). The test checks that this number matches the actual latency.

  • Validate Active/Idle state of the component - checks that power components are in expected Active/Idle state (based on the test scenario).

  • Validate DState - checks that DGPU is in expected D state (based on the test scenario).

  • Validate DGPU process - checks which processes have devices on DGPU. Anything other than the test itself will result in failure.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


HybridPowerManagement_NoApp

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b425acb1-92e5-4c78-9b2a-f8c8a0929ec5

Power management tests run on dGPU while analyzing Power-Management ETW events that are generated by DXGKrnl. For this test, nothing is running on DGPU. The test performs following validations:

  • Validation of Power components - the test validates that all required power components are declared by the driver.

  • Validation of latency - the driver reports latency (time for a component to transition to another F-state). The test checks that this number matches the actual latency.

  • Validate Active/Idle state of the component - checks that power components are in expected Active/Idle state (based on the test scenario).

  • Validate DState - checks that DGPU is in expected D state (based on the test scenario).

  • Validate DGPU process - checks which processes have devices on DGPU. Anything other than the test itself will result in failure.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


HybridPowerManagement_NoAppMonitorOff

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eac00083-cfd8-4c2c-9258-b86c082770a1

Power management tests run on dGPU while analyzing Power-Management ETW events that are generated by DXGKrnl. For this test, nothing is running on DGPU and the monitor is turned OFF. The test performs following validations:

  • Validation of Power components - the test validates that all required power components are declared by the driver.

  • Validation of latency - the driver reports latency (time for a component to transition to another F-state). The test checks that this number matches the actual latency.

  • Validate Active/Idle state of the component - checks that power components are in expected Active/Idle state (based on the test scenario).

  • Validate DState - checks that DGPU is in expected D state (based on the test scenario).

  • Validate DGPU process - checks which processes have devices on DGPU. Anything other than the test itself will result in failure.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

Error | Description
Conformance issues | When the test detects a conformance issue, it saves an image in the test directory if the -saveBMP parameter is specified. You can view this image to help diagnose the issue.
Validation failures | To get more information about the failure, run the test under User Mode Debugger. The test will output the information that it gets from ETW events, to help diagnose the failure.

More information

Command syntax

Parameter | Description
-saveBMP | By using this parameter, the test saves presented images in BMP format to the test directory in case of conformance failure. This is useful for diagnosing conformance failures.
-whql | -featurelevel:<fl> | -whql results in device creation with highest support on a given adapter. -featurelevel:<fl> creates a device of requested feature level Default value: -wqhl for DX10+ drivers; -featurelevel:9.1 for DX9 drivers
-hybrid | This value forces application execution on dGPU as if it was on the DList.

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set


INVDIMM Error Injection Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b88b75d-367d-43b9-b2e2-9e85443e0473

Validates that the INVDIMM reports errors correctly. Error injection must be enabled for this test to run.

Test details
Specifications
  • System.Fundamentals.StorageClassMemory.INVDIMM.DSMCompliance
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


INVDIMM _DSM Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a0a943ae-015e-4816-89f7-07c2a2ba194e

Validates the _DSM functions specified in pmem.io

Test details
Specifications
  • System.Fundamentals.StorageClassMemory.INVDIMM.DSMCompliance
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Lid Basic Requirement Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fd01fb08-9a13-4147-b5df-122b7114c4d3

Lid Basic Requirement Test implements one test case: The test ask user to take action on lid switch For each test iteration, system measurements are taken to evaluate the lid open/close transition happen as expected or not.

Test details
Specifications
  • System.Fundamentals.PowerManagement.Lid
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
TestCycles | Number of test cycles
OptTeCmdlineParams | Optional command-line parameters for te.exe

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Modern Standby Basic Requirement Test on AC-power Source

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0c51f07-5b17-4b26-a7ce-bfc9e7611dac

Modern Standby Basic Requirement Test implements two test cases: - one test case exercises the DC-power source - the other test case exercises the AC-power source. The test uses a software-simulated battery to change power sources. The test causes the system to enter and exit Modern Standby by pressing a software power button. For each test iteration, system measurements are taken to evaluate the Modern Standby Platform Level characteristics such as: - presence of S0 Low Power Idle Transitions (defined per ACPI specification v5.0 or newer); - high percentage of time spent in Software and Hardware DRIPs (Deepest Runtime Idle Power State); - lower Divergence Delta between the Software DRIPs and the Hardware DRIPs; - reasonable Modern Standby Exit Latency.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.Quality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Development
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
DelayAfterPowerSourceChange | Delay time in milliseconds after each power source change
ModernStandbyDuration | Modern Standby duration in milliseconds
ModernStandbyExitLatencyThreshold | Modern Standby Exit Latency threshold in milliseconds.
ModernStandbySDripsThreshold | The Modern Standby Software DRIPS threshold time in [%].
ModernStandbyHDripsSDripsDelta | The acceptable divergence delta of percentage [%] between the Software DRIPS measured in [%] and the Hardware DRIPS measured in [%].
ModernStandbyDisconnectedModeFlag | An optional Disconnected Mode test flag.
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional command-line parameters for te.exe

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Modern Standby Basic Requirement Test on DC-power Source

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c0c51f07-5b17-4b26-a7ce-bfc9e7611ddc

Modern Standby Basic Requirement Test implements two test cases: - one test case exercises the DC-power source - the other test case exercises the AC-power source. The test uses a software-simulated battery to change power sources. The test causes the system to enter and exit Modern Standby by pressing a software power button. For each test iteration, system measurements are taken to evaluate the Modern Standby Platform Level characteristics such as: - presence of S0 Low Power Idle Transitions (defined per ACPI specification v5.0 or newer); - high percentage of time spent in Software and Hardware DRIPs (Deepest Runtime Idle Power State); - lower Divergence Delta between the Software DRIPs and the Hardware DRIPs; - reasonable Modern Standby Exit Latency.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.Battery.Quality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Development
Timeout (in minutes) | 180
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
DelayAfterPowerSourceChange | Delay time in milliseconds after each power source change
ModernStandbyDuration | Modern Standby duration in milliseconds
ModernStandbyExitLatencyThreshold | Modern Standby Exit Latency threshold in milliseconds.
ModernStandbySDripsThreshold | The Modern Standby Software DRIPS threshold time in [%].
ModernStandbyHDripsSDripsDelta | The acceptable divergence delta of percentage [%] between the Software DRIPS measured in [%] and the Hardware DRIPS measured in [%].
ModernStandbyDisconnectedModeFlag | An optional Disconnected Mode test flag.
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional command-line parameters for te.exe

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Modern Standby Check Thermal Zones

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b35c18fd-27e8-4f32-9cfd-46aa16c8b469

This automated test checks thermal zones on the system are in compliance with Windows requirements.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.FanOff
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Client Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Client Testing.

More information

Parameters

Parameter name | Parameter description
HasFan | User needs to specify whether the system under test has a fan


Modern Standby Duration Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/36463e42-7d6e-408e-933f-dbf56ea41e65

This test causes the system to enter and exit Connected Standby by pressing a software power button and measuring the battery capacity drained (in mWh or mAh) over a 16 hour period. The battery capacity drained (in mWh or mAh) must be less or equal to 5% of the battery design capacity.The test will reside in the Connected Standby state for a duration less than 16 hours to reduce test execution time. The resulting battery capacity drained will be scaled proportionally to 16 hours before evaluating against the 5% goal.NOTES:Systems that support Connected Standby MUST drain less than 5% of system battery capacity over an 16 hour idle period in the default shipping configuration.If a system that supports Connected Standby does not ship with a battery, this requirement does not apply.To run the test on a system that has a mobile broadband device, you must turn the mobile broadband radio off (by using the settings on the Wireless menu). The system must be connected to a wireless router. Run the test on a system connected to WiFi only.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.Battery.ModernStandbyDuration
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 330
Category | Development
Timeout (in minutes) | 330
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
CSDuration | Connected Standby duration in milliseconds
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional commandline parameters for te.exe


Modern Standby Exit Latency Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/26600683-c1c8-4b9c-8661-84141db17807

This test causes the system to enter and exit Connected Standby by pressing a software power button. It checks for high latency of exiting Connected Standby.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.Quality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
DQ | SDEL Device Query
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
IODuration | I/O duration in milliseconds
CSDuration | Connected Standby duration in milliseconds
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional commandline parameters for te.exe
DRIPSWatchdogActionBitmask | DRIPS watchdog action bitmask
DRIPSWatchdogTimeout | DRIPS watchdog timeout in seconds


Modern Standby Stress with Driver Verifier's Concurrency Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ae264d13-307b-452b-b5fc-4d9098ea22f1

This test causes the system to enter and exit Connected Standby by pressing a software power button. It also performs I/O on devices before entering Connected Standby.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.Quality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 300
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameter | Description
DQ | The SDEL device query.
TestCycles | The number of test cycles for this test.
DelayBetweenCycles | The delay time in milliseconds between each test cycle.
IODuration | The I/O duration in milliseconds.
CSDuration | The Connected Standby duration in milliseconds.
VerifierFlags | The Driver Verifier flags to enable.
TestTimeoutValue | The timeout value for the execution of te.exe.
OptTeCmdlineParams | The optional command line parameters for te.exe.

Command syntax

Command option | Description
TE.exe /inproc /enablewttlogging /appendwttlogging csstresscuzz.dll /p:DQ=[DQ] /p:TestCycles=[TestCycles] /p:DelayBetweenCycles=[DelayBetweenCycles] /p:IODuration=[IODuration] /p:CSDuration=[CSDuration] /p:VerifierFlags=[VerifierFlags] | Runs the Connected Standby Stress with Driver Verifier's Concurrency Stress (Logo) test job.
NOTE

For command-line help for this test binary, type /h.

Parameters

Parameter name | Parameter description
DQ | SDEL Device Query
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
IODuration | I/O duration in milliseconds
CSDuration | Connected Standby duration in milliseconds
VerifierFlags | Driver Verifier flags to enable
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional commandline parameters for te.exe
EnableDRIPSWatchdog | Enable DRIPS watchdog
DRIPSWatchdogActionBitmask | DRIPS watchdog action bitmask
DRIPSWatchdogTimeout | DRIPS watchdog timeout in seconds


Modern Standby Wake on Voice Basic Test on AC-power Source

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69df7cf2-6024-4eee-92ee-1506480614ee

Wake on Voice (Keyword) Basic Test implements two test cases: - one test case exercises the DC-power source - the other test case exercises the AC-power source. Software-simulated battery is used to change power sources. The test causes the system to enter and exit Modern Standby. Some system measurements are also taken to validation during the tests such as Modern Standby support, Software and Hardware DRIPS (Deepest Runtime Idle Power State), lower Divergence Delta between the Software DRIPS and the hardware DRIPS, Hardware Keyword spotting support, reasonable Modern Standby Exit Latency. NOTE: On Modern Standby system where the storage device containing the boot volume is not backed by a physical disk of Solid State Disk (SSD) media type or Storage Class Memory (SCM) media type, the Modern Standby Exit Latency is reported but the constraints on the measured latency value will not be enforced by this Modern Standby Basic Requirement Test.In the case where the storage device/solution reports a seek penalty or a rotational delay (thus indicating rotating media), the Modern Standby system will operate in a default Disconnected Mode.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.WakeOnVoice
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
DelayAfterPowerSourceChange | Delay time in milliseconds after each power source change
ModernStandbyDuration | Modern Standby duration in milliseconds
ModernStandbyExitLatencyThreshold | Modern Standby Exit Latency threshold in milliseconds.
ModernStandbySDripsThreshold | The Modern Standby Software DRIPS threshold time in [%].
ModernStandbyHDripsSDripsDelta | The acceptable divergence delta of percentage [%] between the Software DRIPS measured in [%] and the Hardware DRIPS measured in [%].
ModernStandbyDisconnectedModeFlag | An optional Disconnected Mode test flag.
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional command-line parameters for te.exe

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Modern Standby Wake on Voice Basic Test on DC-power Source

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/614ffb93-eced-45ab-bf7b-e09291a97fd2

Wake on Voice (Keyword) Basic Test implements two test cases: - one test case exercises the DC-power source - the other test case exercises the AC-power source. Software-simulated battery is used to change power sources. The test causes the system to enter and exit Modern Standby. Some system measurements are also taken to validation during the tests such as Modern Standby support, Software and Hardware DRIPS (Deepest Runtime Idle Power State), lower Divergence Delta between the Software DRIPS and the hardware DRIPS, Hardware Keyword spotting support, reasonable Modern Standby Exit Latency. NOTE: On Modern Standby system where the storage device containing the boot volume is not backed by a physical disk of Solid State Disk (SSD) media type or Storage Class Memory (SCM) media type, the Modern Standby Exit Latency is reported but the constraints on the measured latency value will not be enforced by this Modern Standby Basic Requirement Test.In the case where the storage device/solution reports a seek penalty or a rotational delay (thus indicating rotating media), the Modern Standby system will operate in a default Disconnected Mode.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.WakeOnVoice
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
DelayAfterPowerSourceChange | Delay time in milliseconds after each power source change
ModernStandbyDuration | Modern Standby duration in milliseconds
ModernStandbyExitLatencyThreshold | Modern Standby Exit Latency threshold in milliseconds.
ModernStandbySDripsThreshold | The Modern Standby Software DRIPS threshold time in [%].
ModernStandbyHDripsSDripsDelta | The acceptable divergence delta of percentage [%] between the Software DRIPS measured in [%] and the Hardware DRIPS measured in [%].
ModernStandbyDisconnectedModeFlag | An optional Disconnected Mode test flag.
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional command-line parameters for te.exe

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


MultiPhaseResume

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d581991b-3829-4c8b-91dd-c88d069152f6

The driver and hardware subsystems for the boot storage device must support multi-phase resume from hibernate. In order to do this, the system must be able to maintain the system's ability to identify definitively all of the memory needed on resume. This is not limited to, but should include that:

  • Any crashdump filters/minifilters that must support read

  • No WHEA pshed plugins are installed

  • Hypervisor is not enabled

Test details
Specifications
  • System.Fundamentals.PowerManagement.MultiPhaseResume
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.


NVDIMM-N _DSM Stress Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dbc0a18a-9b67-408e-a59c-8b0551f2b512

Stresses the _DSM functions, making sure that they return the same value every time they are called

Test details
Specifications
  • System.Fundamentals.StorageClassMemory.NVDIMMN.DSMCompliance
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Development
Timeout (in minutes) | 400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


NVDIMM-N _DSM Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/fbaa83f5-0c1f-4720-a7d7-05d51e6151a4

Validates the _DSM functions specified by the Microsoft _DSM Interface for Byte Addressable Energy Backed Function Class (Function Interface 1)

Test details
Specifications
  • System.Fundamentals.StorageClassMemory.NVDIMMN.DSMCompliance
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


NVDIMM-N Error Injection _DSM Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/663c2d58-adc9-4ab2-ba07-62f0041f3821

Validates the error injection _DSM functions specified by the Microsoft _DSM Interface for Byte Addressable Energy Backed Function Class (Function Interface 1). This test validates that the error injection methods produce the expected changes in the health-related _DSMs.

Test details
Specifications
  • System.Fundamentals.StorageClassMemory.NVDIMMN.DSMCompliance
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


NVDIMM-N Persistence Loss Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc4ba463-6934-409c-a3e3-ab86a7c7418a

Validates the driver's behavior when the NVDIMM-N loses the persistence guarantee, which is simulted via the error injection _DSMs.

Test details
Specifications
  • System.Fundamentals.StorageClassMemory.NVDIMMN.HealthNotificationSupport
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Processor Power Management

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/94d083ef-9bf5-4736-b9a4-e54495f0cff4

Check processor idle and performance state configuration.

Test details
Specifications
  • System.Fundamentals.PowerManagement.Processor
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Development
Timeout (in minutes) | 0
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Rapidfile Test (SYSTEM)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a5fd8f26-6ed8-4445-ba9c-3c2f72ff6ff9

This test runs through data integrity tests on the specified volume or file.

Test details
Specifications
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

The volume path must exist before running the test. If a file path is used, the test creates the file during write phase/step and expects the same file path during read/verify phase.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

This test accepts a lot of parameters related to the file system/IO behavior and a few of them are explained below:

I/O Operation

  1. Write This is the default operation performed on the device path provided in the command-line.

  2. Read/Verify Performs read when /V option is specified in the command-line. After a given read IO finishes, test would compare the read data against the expected data (based off the device path given at the command-line) and inform the user if read data doesn't match with the expected data (data corruption).

I/O Mode

  1. Synchronous When the /SYNC command-line option is specified, I/O requests done by the test on the given device path (file/volume) would be done synchronously. The test waits for the completion of an I/O before issuing another one. This is not the default option.

  2. Asynchronous When the /SYNC command-line option is not specified, I/O requests are performed in an asynchronous manner where the test issues a set of I/O requests without waiting for their completion. Completion of the respective I/O requests are tracked separately. This is the default mode used by the test.

File Size

User can specify a custom file size using the /Z command-line option. User can append one of the following to specify various sizes:

  1. K - For KB

  2. M - For MB

  3. G - For GB

  4. T - For TB

Pending I/O

When using asynchronous I/O mode, the user can specify maximum number of I/O requests to keep pending before waiting for the completion of issued I/O requests. This can be done using /R <number> command-line option. For example, /R 1K would mean that the test keeps issuing new I/O requests until 1000 non-completed I/Os.

File Flags

Test creates a file handle using FS APIs before starting the IOs on a given path. And user can create various IO patterns using following file flags:

  1. /FD - FILE_FLAG_DELETE_ON_CLOSE This option is an indication to the respective FS that once the last handle on the file closes, the given file must be deleted. The test supports this flag only during read/verify operation.

  2. /FS - FILE_FLAG_SEQUENTIAL_SCAN File system flag to optimize file caching. It shows that the access is intended to be sequential from beginning to the end. This flag has no effect if the respective file system doesn't support cached I/O.

  3. /FR - FILE_FLAG_RANDOM_ACCESS File system flag to optimize file caching. It shows that the access is intended to be random.

  4. /FW - FILE_FLAG_WRITE_THROUGH When used, write operations will not use any intermediate cache and would be served directly to the disk.

  5. /FU - FILE_FLAG_NO_BUFFERING When used, it is an instruction to the file system that the file or device is being opened with no system caching for data reads and writes.

Block Size

The test performs a given I/O with the provided block size. The default block size value is 64K. User can specify different block size using /B command line option.

For example, /B 1M means that user wants to perform single I/O of 1MB.

Debug Break

If user is running the test with the Windows Debugger attached to the system, the /D command-line option can be used to indicate the test to break into debugger (and in a way freeze the system in given state) when an expected error occurs in the test. The test would use this as a hint and breaks into debugger when an expected error is received during write and read/verify operation as well as when read data doesn't match with expected data during read/verify operation.

Command usage

Command | Description
rapidfile.exe test.dat /D /Z [FILE_SIZE] /R 16k | Async Write
rapidfile.exe test.dat /V /D /FD /Z [FILE_SIZE] /R 16k | Verify of Async Read
rapidfile.exe test.dat /D /Z [FILE_SIZE] /SYNC | Sync Write
rapidfile.exe test.dat /V /D /FD /Z [FILE_SIZE] /SYNC | Verify of Sync Read
rapidfile.exe test.dat /D /Z [FILE_SIZE] /FU /R 16K | Async Unbuffered Write
rapidfile.exe test.dat /FU /V /D /FD /Z [FILE_SIZE] /R 16K | Verify of Async Unbuffered Read
rapidfile.exe test.dat /D /Z [FILE_SIZE] /FR /R 16K | Random Access Async Write
rapidfile.exe test.dat /FR /V /D /FD /Z [FILE_SIZE] /R 16K | Verify of Random Access Async Read

Command syntax

Command option | Description
rapidfile.exe | The command line options for the test are listed below.
/? | Displays the help.
/PERF | Logs the results to the file system performance database/
/A | Append to existing file. Default value: Do not append
/B # | Block size. You can append k, m, g, or t. Default value: 64k
/C | Prints checksum. Also exits with checksum as return value.
/CM | Compress file with default compression format.
/D | Break into the debugger if an unexpected error happens.
/E # | Sleep for # milliseconds in between read/write issue.
/FD | FILE_FLAG_DELETE_ON_CLOSE (only valid with read/verify operation).
/FS | FILE_FLAG_SEQUENTIAL_SCAN
/FW | FILE_FLAG_WRITE_THROUGH
/FU | FILE_FLAG_NO_BUFFERING
/FR | FILE_FLAG_RANDOM_ACCESS
/H | Create disk or volume device handle instead of file handle.
/I | Use idle priority.
/L # | Log statistics every # of seconds. Default value: 60
/M # | Number of minutes to run the test. This will run write followed by read/verify operations.
/N | Uses a new handle for every I/O.
/NL | Don't log anything to the debugger.
/O | Overwrite existing file.
/P # | Pattern size. You can append k, m, g, or t. Default value: 4m
/R # | Maximum number of pending requests.
/RT # | Time out interval in milliseconds while retrying on error. Other formats are #s, #m, #h for seconds, minutes and hours respectively.
/S | Use simple pattern for I/O operation.
/SO | Starting offset for a disk or volume device.
/SP | Make the file sparse before writing to it.
/SYNC | Synchronously write to the file (/TC /R cannot be specified).
/TC # | Number of completer threads. Default value: 1 for create and 4 for verify
/TQ # | Number of queueing threads. Default value: 1
/V | Verify the file by reading it back. Default value: no verify
/X | Flush the file after creating.
/Z # | Size of the test file. You can append k, m, g, or t. Default value: 10m
/VDL # | Location to push VDL out to before starting to write (default == 0, -1 == FileSize).
/EOF # | Location to push EOF out to before starting to write(default == 0, -1 == FileSize).
NOTE

For command-line help for this test binary, type /?.

File list

File | Location
rapidfile.exe | <testbinroot>\NTTEST\Basetest\core_file_services\Shared_Tests\Wdk</p>
ntlog.dll | <osbinroot>\NTTest\CommonTest\NtLog</p>
ntlogger.ini | <osbinroot>\NTTest\CommonTest\NtLog</p>
dtresslog.dll | <testbinroot>\NTTest\basetest\core_file_services\shared_libs</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
FILE_SIZE |


Run Dxgkrnl Smasher MITM module

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2e97ccbf-018b-45e0-82f7-16bcf88669e1

This job runs the interception fuzzer.

Test details
Specifications
  • System.Fundamentals.Graphics.DisplayRender.StableAndFunctional
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 130
Category | Development
Timeout (in minutes) | 7800
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
LLU_NetAccessOnly | TEX OFFICIAL Windows LLU: Net Access Only on machine - contact texeng with questions
OSBinRoot | Base of the bins.
OSTestAutomation | Base of the scripts.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Runtime Power Focused Stress with Driver Verifier's Concurrency Stress

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dfa7f945-7b63-4693-a555-0f38f33c971c

This test performs I/O on different combinations of devices to alternate the devices between Active and Idle condition. Creating different combinations of devices being Active and Idle will help to ensure that the PEP logic is fully exercised.

Test details
Specifications
  • System.Fundamentals.PowerManagement.ModernStandby.Quality
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

Command syntax

Command option | Description
TE.exe /inproc /enablewttlogging /appendwttlogging rtpwrstresscuzz.dll /p:"TestCycles=[TestCycles]" /p:"DelayBetweenCycles=[DelayBetweenCycles]" /p:"IODuration=[IODuration]" /p:"VerifierFlags=[VerifierFlags]" /p:"TestTimeoutValue=[TestTimeoutValue]" /p:"OptTeCmdLineParams=[OptTeCmdLineParams]" | Runs the test.
NOTE

For command-line help for this test binary, type /h

File list

File | Location
Rtpwrstresscuzz.dll | [OSBinRoot]</p>
Te.exe | [TAEFBinRoot]</p>

Parameters

Parameter name | Parameter description
DQ | SDEL Device Query
TestCycles | Number of test cycles
DelayBetweenCycles | Delay time in milliseconds between each test cycle
IODuration | I/O duration in milliseconds
VerifierFlags | Driver Verifier flags to enable
TestTimeoutValue | Timeout value for the execution of te.exe
OptTeCmdlineParams | Optional commandline parameters for te.exe


ScatterGather (SYSTEM)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16fa551a-f868-480c-8a9e-ece2ceb03a49

This test validates file system I/O reliability scenarios, primarily asynchronously, utilizing the ReadFile/WriteFile/ReadFileScatter/WriteFileGather APIs. HLK tests exercises predefined automated regression variations.

Test details
Specifications
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Scenario
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Simultaneously performs I/O (both writes and read) in a multi-threaded fashion utilizing I/O completion ports to complete the I/O. It will start out by initially setting the EOF of the file and scheduling the I/O threads. While the file is being written, it performs online verification where it expects zero or offset computed value. Once the entire file has been written, it performs full verification of the file and will fail the test if zero or an unexpected value is encountered.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Supported test modes:

We expect most users to use predefined regression variations.

Default, Regression (predefined variations) and stress indicate certain types of failures, such as Virtual Alloc retries etc. For default mode, there is a flagsauto flag which manages most of the parameters if the user doesn't want to supply the parameters manually. In addition timer functionality is supported with default and stress modes. For regression mode, there is a pre-defined timer variation.

Supported read/write modes:

Read/Write mode:

  • RW( Read, Write)

  • RWG( Read, Write Gather)

  • RSW( Read Scatter, Write)

  • RSWG( Read Scatter, Write Gather)

  • RRW( Random Read, Write)

  • RRWG( Random Read, Write Gather)

  • RWR( Read, Random Write)

  • RSWR( Read Scatter, Random Write)

  • RRWR( Random Read, Random Write - Approx. 50% Scatter/Gather) -> Default

  • RRWR7( Random Read, Random Write - Approx. 30% Scatter/Gather)

  • RRWR3( Random Read, Random Write - Approx. 70% Scatter/Gather

Additionally, the test supports Reverse Read and Reverse Write.

I/O Throttle Mechanism:

Supports Upper & Lower threshold for controlled IO requests. Bypass mode is also possible which essentially blasts the system with I/O.

Data Pattern:

Simple Offset computed alphabetic value. For timer variation, there can be holes though.

Data Validation Modes:

Supports both online (simultaneous validation along with writes), fullcheck (which is after all write's completed), and offline verification modes. All these modes can be turned off/on. If online verification is turned off, essentially only writes are happening during the initial phase after which fullcheck will be performed.

Difference between Online and Full check is that full check is only done after all the writes are completed by single thread while online verification is done simultaneously during the writes and during, which it either expects zero or offset computed value, unlike fullcheck where it only excepts offset computed value.

Command usage

Command | Description
ScatterMultiThread.exe -default -rwmode:rw -iomode:sync | Perform Read Write IO in Sync mode with default file size.
ScatterMultiThread.exe -default -rwmode:RSWG -RR -RER:2 -TESTPATH:d:\Scatter -FILESIZE:500m | Perform full Scatter Gather, 500m file, in the testpath specified with random offset and reverse read.
ScatterMultiThread.exe -default -rwmode:RRWR -FILESIZE:2g -IODIFFUPPERTHRESHOLD:500 -IODIFFLOWERTHRESHOLD:100 | Perform 50% Scatter Gather IO 2GB file with I/O upper and lower threshold
ScatterMultiThread.exe -regression -regression:6 | Perform pre-defined regression variation 6.
ScatterMultiThread.exe -stress -RWMODE:rrwr -THREADS:2 -BS:100k | Perform scatter gather in stress mode with 2 reader and 2 writer threads with I/O block size of 100k/
ScatterMultiThread.exe -default -FILE:timer.dat -timer:19s -FILESIZE:5g -ONLINEVERIFY:FALSE | Timer mode ReadWrite Unbuffered I/O and no OnlineVerify mode.
ScatterMultiThread.exe -default -OFFLINEVERIFY -FILE:timer.dat -FULLCHECK:FALSE -ALLOWZERO4VERIFY | Offline verification of the above variation with fullcheck disabled and AllowZero4Verify mode.

Command syntax

Command option Description

ScatterMultiThread.exe

The command line options for the test are listed below.

-help or /?

Displays help.

-default

Runs the default variation with test parameters from the command-line.

-stress

Stress mode. Retries the memory allocation failures, etc.

-regression

Regression mode. Runs the predefined regression mode.

-testpath

Full path to the file.

Default value: CWD

-file

File in the testpath or full path to the file.

Default value: Scatter.dat

-filesize

File size in bytes. You can also append k, m, g, or t.

Default value: 1m

-threads

Number of exclusive reader and writer threads.

Default value: 2

-completionthreads

The number of completion threads.

Default value: Twice the number of processors

-rwmode

Read/write mode:

  • RW( Read, Write)

  • RWG( Read, Write Gather)

  • RSW( Read Scatter, Write)

  • RSWG( Read Scatter, Write Gather)

  • RRW( Random Read, Write)

  • RRWG( Random Read, Write Gather)

  • RWR( Read, Random Write)

  • RSWR( Read Scatter, Random Write)

  • RRWR( Random Read, Random Write - Approximately 50% Scatter/Gather) -> Default

  • RRWR7( Random Read, Random Write - Approximately 30% Scatter/Gather)

  • RRWR3( Random Read, Random Write - Approximately 70% Scatter/Gather

-iomode

sync or async

Default value: async

-flagsauto

TRUE or FALSE

Default value: TRUE

Note

Certain file flags are automatically managed based on the situations

-ffnb

TRUE or FALSE

Default value: FALSE

Note

FILE_FLAG_NO_BUFFERING will be automatically turned on in certain situations like Scatter/Gather.

-ffss

TRUE or FALSE

Default value: FALSE

Note

FILE_FLAG_SEQUENTIAL_SCAN will be automatically turned on in certain situations like serialized I/O.

-ffra

TRUE or FALSE

Default value: FALSE

Note

FILE_FLAG_RANDOM_ACCESS will be automatically turned on in certain situations like random I/O.

-ffwt

TRUE or FALSE

Default value: FALSE

Note

FILE_FLAG_WRITE_THROUGH will not be turned on automatically, unless manually specified.

Disable FLAGSAUTO flag for independent management of file flags and attributes.

FLAGSAUTO behavior will change depending on other parameters such as shared file handle or reverse I/O, etc.

The FFSS and FFRA flags have no effect if the file system does not support cached I/O and FFNB is not supported by the file system or specified.

FFSS and FFRA flags are mutually exclusive and cannot be combined as it's self-defeating.

-bs

Block Size in bytes. You can append k, m, g, t.

Default: 64k

-bypass

Bypasses the I/O Threshold wait. This can be either TRUE or FALSE.

Default value: FALSE

-nsegments

The segment array size for Scatter/Gather.

Default value: 16

Note

This option automatically gets corrected in certain situations for Scatter/Gather/

-totalsleep

The total sleep time for failed virtual allocation or I/O threshold scenarios.

Default value: 30 minutes

-sleepint

The loop sleep interval for failed virtual allocation scenarios

Default value: 2 minutes

-iodifferupperthreshold

The upper threshold for issuing I/O requests.

Default value: 1000

-iodifflowerthreshold

The lower threshold to resume I/O requested after I/O diff falls below this number.

Default value: 100

Note

This option is mutually exclusive with bypass mode and is ignored if bypass mode is on.

-wfw

The writer(WFW) flag waits for WriterThreads to be done before any read happens. This option can be either true or false.

Default value: FALSE

-rr

The random offset read (RR) option makes ReaderThreads starts at a random offset. This value can be either true or false.

Default value: TRUE

-rw

The random offset write (RW) option makes WriterThreads start at random offset. This value can be either true of false.

Default value: FALSE

-rer

The reverse read from starting offset. This value can be either 0, 1, or 2.

Default value: 2

-rew

The reverse write from starting offset. This value can be either 0, 1, or 2.

Default value: 0

Note

For RER and REW flags, 0 means no reversal, 1 means straight reversal, and 2 means random reversal (not applied always).

For RER and REW flags, full file I/O may not complete and the statistics and results reported might be inaccurate.

-timer

Timer mode (in seconds). You can append s, m, h.

Default value: 0

This performs I/O until the timer has expired.

-timerloop

The timer loop interval (in seconds). You can append s, m, h.

Default value: same as the timer option

Note

The timer option is only for issuing requests and the completion will still go through (no timer is applicable for completion).

-onlineverify

Verifies the contents of the file after issuing write requests in online mode.

Default value: TRUE

-offlineverify

Verifies the contents of the file in offline mode by rerunning the test again.

Default value: FALSE

-allowzero4verify

Allows a zero to be part of the full verify (OFFLINE or ONLINE).

Default value: FALSE

-onlyzero4verify

Allows a zero to be part of the full verify(OFFLINE or ONLINE).

Default value: FALSE

-sharedfh

Allows the same file handle to be used for all I/O.

Default value: FALSE

-regression

The regression variation. This value can be either - 1 - 10, or 1001(refers to all variations)

Default value: 0 (no regression)

-displayprogress

Display I/O progress (in seconds), You can append s, m, h,

Default value: 2m

-fullcheck

Full verification of the data after the online or offline verify.

Default value: true

-dbgcheck

Breaks into a kernel debugger on failure. This value can be either true or false.

Default value: true

-toleratesurpriseremove

Do not break into a kernel debugger on a SurpriseRemove failure. This value can be either true or false.

Default value: false

-toleraterepair

Do not break into a kernel debugger on a repair failure. This value can be either true or false.

Default value: false

-toleratefailio

Do not break into a kernel debugger on a FailIO failure. This value can be either true or false.

Default value: false

-exitonerror

Exit on a failure. This value can be either true or false.

Default value: False
NOTE

For command-line help for this test, type /?.

File list

File | Location
ScatterMultiThread.exe | <[testbinroot]>\NTTest\BASETEST\core_file_services\NTFS\ScatterGather</p>
ntlog.dll | <[osbinroot]>\NTTest\CommonTest\NtLog</p>
ntlogger.ini | <[osbinroot]>\NTTest\CommonTest\NtLog</p>
stresslog.dll | <[osbinroot]>\basetest\core_file_services\shared_libs</p>
fbslog.dll | <[osbinroot]>\basetest\core_file_services\shared_libs\fbslog</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
TEST_PATH |


Secure Boot Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45ea8a48-d845-4400-b4a4-a4aeb8af686e

This test verifies the out-of-box configuration and basic functionality of Secure Boot. Most of this test is automated, with the exception of dialog boxes that remind you of prerequisites for this test and the post-test step of turning Secure Boot off to run other tests.

Test details
Specifications
  • System.Fundamentals.Firmware.UEFISecureBoot
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Before you run the test, Secure Boot option should be in the default shipping (out-of-box) configuration, specifically:

  • Secure Boot option must be ON.

  • Microsoft Keys are in Key-Exchange key (KEK) and signature database (db).

  • No Microsoft test keys are allowed in the Public Key (PK), KEK or signature database.

  • DBX is shipped up-to-date out-of-the-box.

NOTE

The following commands must be run on the test system before running the Secure Boot tests.

reg add HKLM\System\CurrentControlSet\Services\iospy\StartOverride /v 0 /t REG_DWORD /d 3 /f
reg add HKLM\System\CurrentControlSet\Services\MSDMFilt\StartOverride /v 0 /t REG_DWORD /d 3 /f

This test requires that the system is imaged through the OEM manufacturing process (TPM should be cleared before OS is laid down and installed as part of the deployment). This test should only be run on systems that have gone through an OEM-style imaging process.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

NOTE

This test will fail unless a production signed OS is used and all the driver are signed.


Secure Boot Logo Test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0b952c79-8070-41cc-9d9b-6836342f242a

This test verifies that UEFI Secure Boot is properly configured for shipping to end-customers. - This test is a WoW64 for ARM64 version of test guid 45ea8a48-d845-4400-b4a4-a4aeb8af686e

Test details
Specifications
  • System.Fundamentals.Firmware.UEFISecureBoot
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Secure Boot Manual Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9741a26f-8249-48bd-8135-152eb3f87590

This test verifies the proper functioning of boot time image authentication and the proper authentication and operation of UEFI secure boot variable updates. This test should be performed two times by using two different configurations.

  • Configuration A - EFI USB is first in the boot order.

  • Configuration B - EFI USB is last in the boot order.

Test details
Specifications
  • System.Fundamentals.Firmware.UEFISecureBoot
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | manual

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

This test requires special firmware (debug firmware) on Windows W RT systems that allows you to clear secure boot keys and turn off secure boot. On non-Windows RT systems, a firmware menu should allow you to perform these actions.

Before you run the test:

  1. Clear all Secure Boot variables.

  2. Set the following registry entries:

reg add HKLM\System\CurrentControlSet\Services\iospy\StartOverride /v 0 /t REG_DWORD /d 3 /f
reg add HKLM\System\CurrentControlSet\Services\MSDMFilt\StartOverride /v 0 /t REG_DWORD /d 3 /f

  1. Make sure that you can set the system under test (SUT) to boot from the USB first. If you cannot make this setting, you must manually boot into the different USB sticks when you are instructed to do so.

  2. You must have two USB flash drives.

When it runs, the test installs UEFISecureBootManualTests.zip on the system under test (SUT). Review the README.TXT file in the zip file for further instructions.

The test operator must respond to the test prompts.

The following certificates are required if they aren't present on the machine:

  • KEK

  • UEFI CA

  • Windows Production

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.


Secure Boot Manual Logo Test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7650236c-e94a-461b-9f86-74ea2234646a

This test directs the user to execute the Manual Secure Boot tests and collects the result. - This test is a WoW64 for ARM64 version of test guid 9741a26f-8249-48bd-8135-152eb3f87590

Test details
Specifications
  • System.Fundamentals.Firmware.UEFISecureBoot
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | manual

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Secure Boot Test - Customized Deployment Basic Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c57b6bfd-d286-4740-9b32-aec211b01961

Verifies that systems in User Mode can be successfully set to Deployed Mode of Customized Deployment of Secure Boot (UEFI 2.5+).

Test details
Specifications
  • System.Fundamentals.Firmware.UEFISecureBoot
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic
NOTE

The following commands must be run on the test system before running the Secure Boot tests.

reg add HKLM\System\CurrentControlSet\Services\iospy\StartOverride /v 0 /t REG_DWORD /d 3 /f
reg add HKLM\System\CurrentControlSet\Services\MSDMFilt\StartOverride /v 0 /t REG_DWORD /d 3 /f

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


SecurityGuard Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/63478f0f-37c4-4a8f-ad66-c2712d6b1c2f

This test runs the DeviceGuard Test.

Test details
Specifications
  • System.Fundamentals.Security.SystemGuard
Platforms
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


Signed Driver Check (CheckLogo)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e9473e9-aa0f-4fbb-86c8-2d5d87003521

This test verifies that drivers that are submitted for certification have valid signature attributes. This test applies to both Windows client and Windows Server operating systems. Windows Server systems must have device drivers signed specifically for Windows Server, indicating they were tested in compliance with Windows Server. Device requirements and submitted successfully for Windows Server Device Certification.

Test details
Specifications
  • System.Fundamentals.SignedDrivers.DigitalSignature
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test verifies the following driver aspects:

Potential Cause of Failure | Failure Details | Failure Fix
Device problems | Indicates a device problem that prevents proper operation. | See Error Codes in Device Manager for information about specific error codes and how to address them.
Signature problems | Indicates critical certification-level problems (for example a test-signed driver) that are preventing compliance with certification requirements. | Contact the driver vendor to get a driver that is not test signed and is for this version of Windows, and then install the new driver.
Certification level problems | Indicates signature issues (for example, signed for an incorrect operating system) that prevent the driver from meeting certification requirements. | Contact the driver vendor for the correctly signed driver for the installed version of Windows, and install that driver.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for copying binaries
LLU_LclAdmin | LLU for built in admin account


Storage Performance CS

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/be2ca7a4-94b0-40cf-82cb-02d505ba4d7c

This test verifies that the performance of the storage device meets the performance requirements.

Test details
Specifications
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 240
Category | Benchmark
Timeout (in minutes) | 14400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

The storage device must be attached to the appropriate controller. The test is non-destructive so no files or partitions will be destroyed during testing. Files will, however, be written to the drive. It is important to minimize the amount of activity occurring on the drive outside of the logo test. Since this is a performance test, outside activity may affect the results.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

  • Check WTT Trace:

    • Go into the Child Job Results of RunJob - Storage Performance Library.

    • View Task Log of Run StorPerf.

    • Open the log file StorPerf.wtl.

    • Check for messages that may solve the issue.

  • Span Size Failure:

    • Error message: "The requested span size, 10737418240 bytes, is larger than the precondition file, 7195066368 bytes. Logo test invalidated."

    • If the requested span size is larger than the precondition file, an error will be logged, but the test will continue to run. The testzone.tmp file created is too small to sufficiently test the range required by the test.

    • More space must be made to create this file, or the file was too small and not properly deleted before beginning testing.

    • Currently, the minimum size of the preconditioning file required is 10Gb. 20% free space must also be left on the drive. The preconditioning phase writes a file that fills all free space leaving 20% of the total free space on the drive.

      Total Disk Size * 20% + 10GB < Free Space

  • Check individual test results:

    • Browse Job Logs of Storage Performance CS / Storage Performance USB3.

    • There are several types of files for each test case run inside of the test that are copied back to the controller for triage. These files contain more information than is available in the WTT logs.

    • The .result files are the console output of each process that is launched from this test.

    • The .xml files are generated by the workload that this tests launches. It is what is parsed to get the metrics.

    • The .csv file is the aggregate of all of the parsed data for every test case.

    • The .xls file is the same aggregate as the .csv file of the same name except that it has color-coded pass/fail along with what the expected metric bar value was.

    • The naming of the .result and .xml files uniquely identifies the test case run.

      • Scen = Scenario.

      • The long hexadecimal string identifies all of the parameters passed to the workload.

      • The three digit hexadecimal string is the thread id.

      • The last digits are the runs of this exact same test case on the same workload.

    • If an error occurs in the log, the first place to check is the .result file of the same name as the test case where the error occurred. When an error occurs in the workload, the .result file is copied into the .wtl log file for easier access to the content.

      If it is unable to open a handle to the disk, it may not have a partition on the drive, or may not be running as administrator.

    • If there is a discrepancy about the metric, the values are located in the .xml file

    • If there is a discrepancy about the variance or test case interactions, the .csv/.xls files show the results for all of the tests.

  • Issues with open ETW logs:

    • If the test is closed during execution, it is possible that an ETW log may remain active.

    • The easiest way to reset it is to restart the computer.

    • The logger can also be manually closed:

      • Open an elevated command prompt.

      • Run logman query -ets

      • Run logman stop -ets "Circular BitLocker Logger"

For more troubleshooting information, see Troubleshooting Device.Storage Testing.

More information

The job takes in the device instance ID of the device under test and converts the device instance ID to a physical drive number or drive letter depending on the scenario. If it is required by the scenario, the job partitions and formats the drive to get it into the configuration needed for testing. The test will run through a series of test cases each mapped to items in the requirements. The test cases are self-contained and are run sequentially. A list of test cases can be obtained by using the PrintPolicy command line option with the appropriate device specified. Each of these test cases can be run on the command-line using the test in standalone mode with a custom policy xml file using the PolicyXML command-line option for further testing or debugging.

The Storage Performance test stores a policy table defining for each type of device what performance tests are to be run and what the appropriate metrics should be. Once the appropriate items in the table are selected, the test will sequentially spawn instances of the specified workload, StorageAssessment, in this case, to test the items specified in the table for that device. Once StorageAssessment has finished doing its testing and created the results, Storage Performance test will parse those values and compare them with the bars defined in the logo requirements in order to print pass/fail logs.

The scenario to test is referenced by the DeviceTag flag on the command-line. This flag is a TestcaseGroup in the policy xml. The test has a few built in scenarios, but allows for custom scenarios, if desired.

A scenario is defined by an Order, Workload, Access, Operation, Operation Value, IO Size, Span Size, Runtime, Queue Depth, Precondition Percent and Precondition MB. Each scenario defined in the table will correspond to the workload being spawned once. Multiple of the same scenarios defined for one device will still only invoke one test case.

A metric is defined by its type and value. Intrinsic to the metric is its units and whether the bar is an upper limit or lower limit. Many metrics can be specified for each scenario which results in only one test case being invoked for that scenario.

For each entry in the table there is a variance criteria specified which defines the maximum variance allowed over the last set of runs before it will stop testing that test case. For many of the entries it is defined as a minimum of 5 runs, maximum of 30 runs, and the variance over the last 5 runs must be under 10% to continue testing. The test case will be rerun up to 30 times or until the variance requirement is satisfied. At that point, the metric will be evaluated according to the defined properties of the metric (minimum, maximum, mean, average, and so on) over the last set of runs.

Although Storage Performance test is not limited to one workload, the majority of the scenarios defined in the policy table use the StorageAssessment workload in order to generate the performance workload and metrics.

Command usage

Command | Description
StorPerf.exe /DriveLetter [StorageDriveLetter] /DeviceTag CS_Boot | Runs the CS testing on the specified drive. DeviceTag can also be CS_Boot_HS200 for HS200 capable drives.

Command syntax

Command option | Description
/DriveNumber <number> | Physical drive number of device under test. Example: /DriveNumber 0
/DriveLetter <letter> | Drive letter of device under test. Example: /DriveLetter C
/DeviceTag <value> | Identifies which TestcaseGroup or ComparisonGroup to select as the input from the configuration xml files. This parameter is case-sensitive and is used for indexing both the policy and comparison xml files. Example: /DeviceTag CS_Boot
/PolicyXML <value> | The policy xml file name. Defines all of the parameters for running the I/O workloads. If no option is given, the default file will be generated. Example: /PolicyXML CSPolicy.xml
/Compare <value> <value> | The two xml files to compare. These must have been generated from a previous run of this test. The "FinalTestCasesAggregated.xml" files should be used instead of the "AllTestCasesAggregated.xml" files since there is no guarantee that the number of iteration is the same for each test case. Example: /Compare FinalTestCasesAggregated_42f4.xml FinalTestCasesAggregated_a732.xml
/CompareXML <value> | The comparison xml file name. Defines all of the parameters for running the comparison. If no option is given, the default file will be generated. Example: /CompareXML CSCompare.xml
/PrintPolicy | Prints the policy table.
NOTE

For command-line help for this test binary, type /h.

File list

File | Location
StorPerf.exe | <[testbinroot]>\NTTest\driverstest\storage\wdk</p>
StorageAssessment.exe | <[testbinroot]>\NTTest\driverstest\storage\wdk\StorageAssessment</p>
ssdtest.dat | <[testbinroot]>\NTTest\driverstest\storage\wdk\StorageAssessment</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | User account for accessing test fileshare.
LLU_LclAdminUsr | User account for running the test.
WDKDeviceID | Instance path of device to test.
DeviceID | Either DriveLetter or DriveNumber
DeviceTag |
DiskDeviceObjLink | Assigned by Create Storage Parameters.
Destructive | (0,1) 0=Passive, 1=Destructive
QueryHS200 | Queries if any device supports HS200 mode


Syscache (SYSTEM)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2b74133e-dc3a-43a4-87e7-ddede85e8477

This is a data validation test that runs on the system volume. It writes to a file and verifies that the data written is read back correctly. It can detect corruptions caused by anything in the path from firmware, drivers, file system, memory, etc. It uses standard Win32 file system and memory management APIs to read and write data from the file.

Test details
Specifications
  • System.Fundamentals.StorageAndBoot.BootPerformance
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

When the test fails, the log contains all of the information you need to analyze the failure. Look for the following information to reproduce the error:

  • The "Write Attribute". Look up the table of write attributes to find how the data was written to the file.

  • The "Read Attribute". Look up the table of read attributes to find out how the data was read back from the file.

  • The offset at which the error occurred.

  • The region of the file in which the error occurred. The test typically writes entire region using a single write (with the exception of the FILE_FLAG_SECTOR_CHUNKS option, where it writes one sector at a time).

More information

Syscache opens a file with a certain flag/attribute and writes to the file. Each chosen flag may span several runs on the file.

A run is defined as a set of the following sequence:

  • Create/open a file.

  • Truncate the file size to 0.

  • Write to the file.

  • Close the file.

  • Open the file again.

  • Read the file.

  • Verify the contents of the file.

  • Close the file.

There is a set of zero and non-zero regions in the file. Zero regions are areas in the file where no data was written. Non-zero regions are areas in the file where data was written. The pattern is a DWORD of the format RRPPPPPP. The top two bytes are the run number, and the next 3 bytes are the one's complement of the offset of this DWORD in the file.

The following attributes are used for writing a file:

Write attribute | Explanation
FILE_ATTRIBUTE_NORMAL | See CreateFile function.
FILE_FLAG_SEQUENTIAL_SCAN | See CreateFile function.
FILE_FLAG_NO_BUFFERING | See CreateFile function.
FILE_FLAG_WRITE_THROUGH | See CreateFile function.
FILE_ATTRIBUTE_TEMPORARY | See CreateFile function.
NO_BUFFERING | WRITE_THROUGH | See CreateFile function.
FILE_ATTRIBUTE_SPARSE_FILE | The file is set to sparse.
NORMAL APPEND_WRITE | Same as FILE_ATTRIBUTE_NORMAL; closes and reopening the file per write and appending the next region.
FILE_FLAG_SECTOR_CHUNKS | Same as FILE_FLAG_NO_BUFFERING, data is written one sector at a time.
FILE_MAP | Same as FILE_ATTRIBUTE_NORMAL, data is written via memory mapping.
FILE_FLAG_OVEREXTEND | Same as FILE_ATTRIBUTE_NORMAL, data is written via memory mapping

The following attributes are used for reading from the file:

Read attribute | Explanation
FILE_MAP | FILE_ATTRIBUTE_NORMAL, data is read via memory mapping
NO_BUFFERING | FILE_FLAG_NO_BUFFERING
NORMAL | FILE_ATTRIBUTE_NORMAL
RANDOM_ACCESS | FILE_FLAG_RANDOM_ACCESS
SEQUENTIAL_SCAN | FILE_FLAG_SEQUENTIAL_SCAN
TEMPORARY | FILE_FLAG_TEMPORARY
WRITE_THROUGH | FILE_FLAG_WRITE_THROUGH

Command syntax

Command | Description
readwrit.exe -n 10 -d /logfile Syscache.log | Runs the test.

File list

File | Location
readwrit.exe | <[testbinroot]>\NTTest\BASETEST\core_file_services\cachemgr</p>
ntlog.dll | <[osbinroot]>\NTTest\CommonTest\NtLog</p>
ntlogger.ini | <[osbinroot]>\NTTest\CommonTest\NtLog</p>
stresslog.dll | <[testbinroot]>\NTTest\basetest\core_file_services\shared_libs</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |


System - Embedded Signature Verification

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/eb9bad1e-70b3-4f8d-a090-4ff15ee7b559

This test uses SignTool.exe to verify that all the boot start type drivers on system are embed-signed.

Test details
Specifications
  • System.Fundamentals.SignedDrivers.BootDriverEmbeddedSignature
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

If you see an error saying that a "<Driver name> is not a signed driver", you can use signtool.exe to get more information about the digital signature to better troubleshoot the issue. For example, you could run the following command to find out more about pci.sys: signtool.exe verify /pa /v C:\Windows\system32\drivers\pci.sys

More information

File list

File | Location
EmbeddedSignature.exe | [<testbinroot>]</p>
Signtool.exe | [<testbinroot>]</p>

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU for copying binaries
LLU_LclAdmin | LLU for built in admin account


System - PNP (disable and enable) with IO Before and After (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b2849bf1-3478-4fd7-a577-31001084e908

This test performs IO and basic PNP (disable/enable) on all devices of a system.

Test details
Specifications
  • System.Fundamentals.Reliability.SystemReliability
  • System.Fundamentals.SystemUSB.MustIncludeSuperSpeedPort
  • System.Fundamentals.SystemUSB.USBDevicesandHostControllersWorkAfterPowerCycle
  • System.Fundamentals.SystemUSB.XHCIControllerSaveState
  • System.Fundamentals.SystemUSB.XhciSupportsRuntimePowerManagement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ResumeDelay | Delay time in seconds after each sleep cycle
WDTFREMOTESYSTEM | Required ONLY if there is a wired NIC on the test system AND it does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of test cycles
IOPeriod | IO period in minutes


System - Reboot Restart with IO During (Reliability)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6d6ed5ec-1765-4569-a7ac-20ed7869d89a

This test reboots the system while performing IO on all devices before and after the reboot.

Test details
Specifications
  • System.Fundamentals.Reliability.SystemReliability
  • System.Fundamentals.SystemUSB.MustIncludeSuperSpeedPort
  • System.Fundamentals.SystemUSB.USBDevicesandHostControllersWorkAfterPowerCycle
  • System.Fundamentals.SystemUSB.XHCIControllerSaveState
  • System.Fundamentals.SystemUSB.XhciSupportsRuntimePowerManagement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
WDTFREMOTESYSTEM | Required ONLY if there is a wired NIC on the test system AND it does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of test cycles
IOPeriod | IO period in minutes

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


System - Sleep with IO Before and After (Reliability SysFund)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16ac817e-b042-4679-8027-c6c44d1ce29f

This test cycles the system through various sleep states and performs IO on devices before and after each sleep state cycle.

Test details
Specifications
  • System.Fundamentals.Reliability.SystemReliability
  • System.Fundamentals.SystemUSB.MustIncludeSuperSpeedPort
  • System.Fundamentals.SystemUSB.USBDevicesandHostControllersWorkAfterPowerCycle
  • System.Fundamentals.SystemUSB.XHCIControllerSaveState
  • System.Fundamentals.SystemUSB.XhciSupportsRuntimePowerManagement
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 180
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • Device.DevFund additional documentation
  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
DQ | A WDTF SDEL query that is used to identify the target device(s) - http://go.microsoft.com/fwlink/?LinkId=232678
Wpa2PskAesSsid | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide SSID of a WPA2 AES WiFi network that the test can use to test the WiFi adapter. The default is 'kitstestssid'.
Wpa2PskPassword | Required ONLY if DUT or one of its child devices is a WiFi adapter. Please provide password of the WPA2 AES WiFi network specified using the Wpa2PskAesSsid parameter. The default is 'password'.
ResumeDelay | Delay time in seconds after each sleep cycle
WDTFREMOTESYSTEM | Required ONLY if there is a wired NIC on the test system AND it does not have an IPv6 gateway address. If determined to be required, please provide an IPv6 address that the NIC can ping to test network I/O. Eg: fe80::78b6:810:9c12:46cd
MultiDeviceHardwareIdSdelQueryHardwareID | Multi Device SDEL
MultiDeviceInstanceIdSdelWDKDeviceID | Device id of DUT
DriverVerifierCustomizeConfiguration | Specifies that this test may want to automatically update Driver Verifier settings
TestCycles | Number of test cycles
IOPeriod | IO period in minutes


System Audio - AC3 Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16ace5c5-6eff-4169-beed-81f5cf75357a

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test verifies that audio devices that support the AC-3 format comply with the Hardware Certification requirements.

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see AC3 Test - Certification.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 4
Category | Development
Timeout (in minutes) | 240
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

See Troubleshooting System Fundamentals Testing

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Name of test profile


System Audio - Audio Engine Core Test (UMACoreTest)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5224db3e-3dba-4187-a5d7-2ba4af7655e3

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of the machine's LLU for copying files


System Audio - Audio Engine Test (UMATest)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4890393a-4a9a-46c1-9754-cec0d49d7a60

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of the machine's LLU for copying files


System Audio - Audio Logo Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/16a492f7-a503-4f7e-8c1d-6fd4370b9b65

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test validates test cases for audio devices on generic streaming of audio.

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see Audio Logo Test - Certification.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Name of test profile


System Audio - Audio Logo Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3d7507c-9051-4eac-be04-9276a6ccad53

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files


System Audio - Audio Logo Test - Glitch - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e0233fb-ab35-4a1b-9cce-badc6cbe9421

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Parameter: [WDKDeviceID] - set this parameter to device ID when scheduling from Job Explorer for private testing Please refer to WDK documentation for details about this test!

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Benchmark
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device ID string
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


System Audio - Class Driver Audio Logo Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66881523-0267-47f3-b462-2a54939df417

Please refer to WDK documentation for details about this test!

Test details
Specifications
  • System.Fundamentals.SystemAudio.3rdPartyDriver.UAA
  • System.Fundamentals.SystemAudio.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Name of test profile

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s): - System.Fundamentals additional documentation


System Audio - Device Power State Transition Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a9d71d49-ba51-4fbf-a0b2-3eb11b689565

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This is a system-specific implementation of an existing test. For more information on this test, see Device Power State Transition Test.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 6
Category | Development
Timeout (in minutes) | 360
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, seeAudio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExePath | Partial path of the test executable


System Audio - DRM Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cceab657-b901-4dc1-9ef5-c2729e5077a0

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This is a system-specific implementation of an existing test. For more information about this test, see DRM Test - Win8.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
Expected run time (in minutes) | 8
Category | Development
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files


System Audio - Hardware Offload of Audio Processing Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/08a7c6d7-fab0-4bd8-ae4f-75e53cce4509

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

[This content isn't available yet.]

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of the machine's LLU for copying files


System Audio - KS Position Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ce685f4e-fbbb-439d-b0b9-6346753b6e71

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test verifies that an audio device and driver accurately implement audio render position for stream synchronization.

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see KS Position Test.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

For troubleshooting information specific to audio tests, see Troubleshooting Audio Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable


System Audio - KS Topology Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e5964040-9ebe-4003-8ef3-5bd9966dcfbb

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Please refer to WDK documentation for details about this test!

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
  • System.Fundamentals.SystemAudio.MicrophoneLocation
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files


System Audio - KS Topology Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/faa8e915-5e6b-4489-9f66-e8889335dc1c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test validates audio devices to ensure that the topology filters revealed are within requirements.

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see KS Topology Test - Win8.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
  • System.Fundamentals.SystemAudio.MicrophoneLocation
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 12
Category | Development
Timeout (in minutes) | 720
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Name of test profile


System Audio - Lullaby Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03197dae-d7ac-4b0e-9fad-d4b35d998988

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test verifies that audio devices and the system are both responsive and functional within a certain amount of time after system sleep or hibernate.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestExePath | Partial path of the test executable
TestPro | Name of test profile


System Audio - Lullaby Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b1dd820-767c-4645-9c95-6a8f8ad3633c

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Scenario
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of the machine's LLU for copying files


System Audio - MediaCapture API Test - Test Audio Capture

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/cf9b3fb6-cbc1-4d88-836d-38a93ecbcc5c

This test validates that the selected system audio capture endpoint is compatible with Windows Media Foundation APIs (MediaCapture)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 100
Category | Compatibility
Timeout (in minutes) | 210
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run
AllAudioDevices |


System Audio - MFCaptureEngine API Test - Capture AAC Audio samples from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/688aa201-78d8-4891-b679-9f0deab7309f

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture AMR_NB Audio to a file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/893d09ad-31e6-4578-beaa-8723683b5868

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture Audio to an AAC file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d2509b63-d4ad-458c-bde2-586a93abbc08

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture MP3 Audio samples from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d50e1195-b476-42d1-96b8-1d2241cc1d38

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture MP3 Audio to a file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7aeb0bd6-35f3-4691-9f7d-b72bd59fbe31

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture PCM Audio samples from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/edac26c1-a23d-4e6e-b704-8d4328e64180

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture PCM Audio to a wav file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d7392d54-85bd-4b25-8f0a-223e35525d23

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7
Category | Scenario
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture WMA9 audio samples the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3abc5ba6-ade2-4586-8461-46963790593a

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - MFCaptureEngine API Test - Capture WMA9 Audio to an wma file from the default capture pin

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4eb3aa71-bd20-410e-b932-7ab81f811d8e

This test validates that the selected audio capture endpoint is compatible with Windows Media Foundation APIs (MFCaptureEngine)

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Scenario
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
WDKDeviceID | Device id of DUT
DriverVerifierExcludedFlags | Driver Verifier flags that may be manually excluded for the test run


System Audio - SysFX Test - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e3dab242-deb8-4248-8554-df3ea9d95f83

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This automated test verifies users have the ability to enable and disable system effects on an audio endpoint in the event it is malfunctioning or otherwise affecting the user experience.

This is a system-specific implementation of an existing test. For more information on this test, see SysFX Test.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
  • System.Fundamentals.SystemAudio.3rdPartyDriver.UAA
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestPro | Test Case Profile String


System Audio - SysFX Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b09fe373-d9b7-42b9-9a44-0a26ca0bab95

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Please refer to WDK documentation for details about this test!

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files


System Audio - UAA Test (Manual) - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d3b9db9c-193b-473c-9c6b-5b1c719fba31

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test validates that High Definition (HD) audio controller and codec hardware meet the requirements for the Microsoft HD Audio class driver. This test also validates that the system BIOS is correctly programming the pin configuration registers in the codec.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
  • System.Fundamentals.SystemAudio.SystemUsesHDAudioPinConfigs
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 8
Category | Development
Timeout (in minutes) | 480
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

This is a system-specific implementation of an existing test. For more information on this test, see UAA Test (Manual).

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files
TestExe | Name of test executable
TestExePath | Partial path of the test executable
TestPro | Name of test profile


System Audio - Verify Audio EffectsDiscovery

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/77c6aa27-bde0-433e-bceb-2441fde540b0

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU


System Audio - Verify Audio EffectsDiscovery (Manual) - Desktop

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/634e1f2a-de4f-4043-aa3c-ac43da164d11

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

  • Test1/Test2

    Use WinRT APIs to check for the existence of raw mode support on a capture or render audio device. To support raw mode, the driver must support the new DDI for audio signal processing modes.

  • Test3/Test4

    Check for effects that are turned on by default in capture or render device on raw or default streams. On raw streams, the only expected effects are endpoint mode effects such as speaker compensation or speaker protection. On render stream of the Communication category, no effects are expected other than endpoint effects. The presence of effects in the Other category can also fail the test.

  • Test 5/Test 6

    In this test, all effects are disabled and then raw and default streams are queried to ensure that no effects other than must-have effects are on in the pipeline. Must-have effects include endpoint effects that cannot or should not be turned off.

  • Manual tests:

    This test ensures that when each of the effects on the UI (Microsoft Store App UI, or Enhancements tab in Sound Control panel) is enabled, the effects list shows up correctly.

    If you are implementing effects for a modern system with the Microsoft Store App UI (Hardware Support App), you must expose its UI to the user to enable/disable audio effects. Ensure that UI is functioning correctly for each applicable device.

    If you are implementing a legacy system with enhancements reported in the Sound Control panel, the test will iterate through each render/capture device and show the initial list of default effects on raw and default streams. It then prompts you to enable the effects on the UI. You can enable the effects one at a time or all at once. You should pay attention to the list of effects displayed as they choose each option. This should be repeated for each device. After the tests are done, you should press Enter to proceed. You are asked if the list of effects displayed is accurate. You can select Y or N as answer.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Audio Testing.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | LLU


System Audio - Wave Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/facb4182-a34d-47b5-9a4d-16ae7758739a

IMPORTANT

This test requires supplemental content. You can find this content in the 'Windows HLK supplemental test content' section at the following location:

  • http://go.microsoft.com/fwlink/p/?LinkId=532718

This test validates that an audio device and driver within a system meet the basic requirements for capture and playback of pulse code modulation (PCM) data.

The test exercises simple combinations of capture and playback of PCM data by using the kernel-streaming (KS) interfaces.

This is a system-specific implementation of an existing test. For more information on this test, see Wave Test - Certification.

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 16
Category | Development
Timeout (in minutes) | 960
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements:Audio Device Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

For troubleshooting information specific to audio tests, see Troubleshooting Audio Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files


System Audio - Wave Test - Threshold

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/adb7b83a-87e2-4d49-aa04-bcd9379bed5b

Please refer to WDK documentation for details about this test!

Test details
Specifications
  • System.Fundamentals.SystemAudio.Audio
Platforms
  • Windows Server 2016 (x64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
Expected run time (in minutes) | 16
Category | Development
Timeout (in minutes) | 960
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly | Name of machine's LLU for copying files


System Network Device Power Requirements (NDISTest 6.5 - PM_Requirements)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5d638d50-fcfb-45c7-ac52-50f2b333bdc8

This test validates the system network device requirements.

Test details
Specifications
  • System.Fundamentals.Network.PowerRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: LAN Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting LAN Testing.

More information

Command syntax

Command | Description
[WTTRunWorkingDir]\ndistest.net\ndistest.exe /logo /auto /client /target:System /tc:NULL_RESOURCE /jobs:[TestScript] | Runs the test.
NOTE

For command-line help for this test binary, type /h.

Parameters

Parameter name | Parameter description
TestScript | comma separated list of test jobs to run


TPM 2.0 - Supplemental test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/146e350a-a7db-4665-afe7-ee25477ce2ee

This test checks for the correctness of the TCG logs with respect to the PCR measurements, and checks for unique SRK being generated across TPM clear.

Test details
Specifications
  • System.Fundamentals.TPM20.TPM20
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Windows HLK Test Failures.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder


TPM 2.0 Attestation Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1c842b31-3599-43e9-82d2-9e71c4b3205e

This test runs the TPM 2.0 Attestation Test.

Test details
Specifications
  • System.Fundamentals.TPM20.TPM20
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


TPM 2.0 Core Provisioning Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/965e5a8a-400a-4d97-9c6d-b10e867010cb

This test runs the TPM 2.0 Core Provisioning Test.

Test details
Specifications
  • System.Fundamentals.TPM20.TPM20
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Compatibility
Timeout (in minutes) | 45
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


TPM 2.0 TCG Physical Presence Interface 1.3 Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e9d37053-fdbb-4674-8fa5-84b5bc40908a

This test runs the TPM 2.0 Physical Presence Interface test.

Test details
Specifications
  • System.Fundamentals.TPM20.PlatformConfiguration
  • System.Fundamentals.TPM20.PlatformSpecifications
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


TPM 2.0 UEFI Preboot Interface Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9a9fcb0b-2b95-4360-9f06-7022e68a6c71

This manual test uses the TrEE UEFI protocol to test interaction with the TPM. The test fails if the system is PCAT and has a TPM 2.0. This test uses UEFI protocols to verify that a TPM is present to test the RNG command in pre-boot, to locate and verify that the TPM2 table tests the Platform Reset Attack Mitigation and UEFI interface, and checks that PCR values do not change when devices are enumerated. It also tests for the TPM extend performance in a preOS environment.

Test details
Specifications
  • System.Fundamentals.TPM20.PlatformConfiguration
  • System.Fundamentals.TPM20.PlatformSpecifications
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test requires secure boot debug policy to be installed on Windows RT devices and secure boot to be turned off on non-Windows RT devices.

This test has no additional test parameters.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio. To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided under the Troubleshooting section in TCG TPM Integration Test (Manual). Investigations also need log files with name like 'tpm*.txt' and console.txt from the 'Documents' folder

To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided in the TCG TPM Integration Test (Manual).


TPM 2.0 UEFI Preboot Interface Test - (WoW64 for ARM64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7a6acd5d-17d4-4699-a27d-7914c3fdf431

This test runs the TPM 2.0 UEFI Interface Test - This test is a WoW64 for ARM64 version of test guid 9a9fcb0b-2b95-4360-9f06-7022e68a6c71

Test details
Specifications
  • System.Fundamentals.TPM20.PlatformConfiguration
  • System.Fundamentals.TPM20.PlatformSpecifications
Platforms
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
ProcessorArchitecture | Processor architecture of device under test

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


TPM 2.0 Verify Existence and Device Requirements Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8ddefeef-88ca-4949-ac0c-6eb036a98200

This test verifies the existence of a TPM 2.0 and that it meets the device requirements.

Test details
Specifications
  • System.Fundamentals.TPM20Required.TPM20Required
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


TPM Based Virtual Smart Card Interface Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1543208e-6941-48f6-b5a1-118b5c385fa7

This test runs the TPM-based virtual smart card hardware certification tests. In the setup steps, the TPM is set to the Ready state and TPM_ResetLockValue is issued. This test covers the Pre-Setup phase, the Setup phase and the Execution phase. TPM Smart Card Provisioning and usage scenarios are tested.

Test details
Specifications
  • System.Fundamentals.TrustedPlatformModule.TPMRequirements
  • System.Fundamentals.TrustedPlatformModule.TPMComplieswithTCGTPMMainSpecification
  • System.Fundamentals.TPM20.TPM20
  • System.Fundamentals.TrustedPlatformModule.TPMEnablesFullUseThroughSystemFirmware
  • System.Fundamentals.TrustedPlatformModule.Windows7SystemsTPM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided in the TCG TPM Integration Test (Manual).


TPM 2.0 Platform Crypto Provider Key Storage Provider Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7c938be0-ff4a-44f9-916c-b578f027f0ca

This manual test disables auto provisioning of the Trusted Platform Module (TPM) and requests a TPM clear operation from firmware. After a restart, the Ownership is taken to proceed with the test. This test ensures that TPM works with TPM Key Storage Provider functionalities and checks for the presence of an EK certificate.

Test details
Specifications
  • System.Fundamentals.TPM20.TPM20
Platforms
  • Windows 10, client editions (ARM64)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (x86)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, review the prerequisites in TPM System Fundamentals Testing Prerequisites.

This test has no additional test parameters.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting the Windows HLK Environment.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

To provide more information for troubleshooting failures in this test, you can enable tracing of the TPM. Refer to the steps provided in the TCG TPM Integration Test (Manual).


UEFI Tpr Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/71dca651-1a3a-4139-a8da-95f10cc1fd87

This test validates the UEFI implementation of the TPR command. eDrives unlocked by the operating system will remain unlocked on system crashes causing a security vulnerability for all such drives as the operating system cannot lock the drive on the crash. UEFI systems must issue a TPR command to each eDrive on the system to ensure that the drive is locked before booting into an operating system.

For example, this test creates a band on all eDrives and sets the state of that band to temporarily unlocked before invoking a system crash. Upon restart, the test runs again and checks the state of the band to ensure that it is locked.

Test details
Specifications
  • System.Fundamentals.Firmware.TPR.UEFIEncryptedHDD
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 1200
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

This test is a system test and as such runs against all systems and not specific drives in the device testing. All systems with UEFI and an eDrive attached will see this test in list of tests to run. A UEFI system with more than one eDrive will be checked for compliance.

The test will configure the system before causing a manually initiated bug check and finally validating the state of the drive after the system has rebooted. This means that seeing a manually initiated stop error is expected.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For additional troubleshooting information, see Troubleshooting System Fundamentals Testing.

The test needs to create a new band on the eDrive for testing, which requires that there is free space available to create the partition and band. If the eDrive already has volumes on it, the test will attempt to shrink a volume and use the free space to do the testing. If an error is encountered when trying to prepare the drive before the manually initiated crash, the following steps can be taken:

  • This error may be seen in the test logs as a VDS failure.

  • Manually remove all volumes from data drives by performing diskpart clean on the disk.

  • If the disk contains the boot volume, shrink volumes to create at least 100 MB of free space on boot volumes before running the test. This can be accomplished by using Disk Management.

More information

The test is a system test and does all of its own device enumeration. The job first installs the bugcheck driver which allows the user-mode test application to force a system crash. During phase 1 of the test, the system is checked to ensure it is a UEFI system and has at least one eDrive connected. If the system does not meet these criteria the test is skipped and appears as a pass in the HLK studio and manager. For each eDrive enumerated on the system, a new 100MB band is created. If the drive already contains partitions such that there is not 100MB of free space, VDS is invoked to shrink the largest partition to create room for a new band. This means that the partitions on the drive must have been created in Windows and are not managed by a 3rd party TCG solution. Each of the new bands is set to the Temporary Unlock state before invoking the crashdump driver to cause a manually initiated system crash. When the system reboots the second part of the test runs to check that each of the bands is locked. Any unlocked bands cause the test to fail. The test bands are removed and the partitions extended if they were previously shrunk. Finally, the crashdump driver is removed from the system.

Command usage

Command | Description
UefiTprTest.exe phase1 | Run phase 1 of the test to prepare the drives before crashing the system.
UefiTprTest.exe phase2 | Run phase 2 of the test to check the state of the drives after the reboot.

Command syntax

Command option | Description
UefiTprTest.exe | The command-line options for the test are listed below.
Phase1 | Phase 1 prepares the drives for testing. This is needed to get the drives in the state they are needed before crashing the system.
Phase2 | Phase 2 does the validation of the drives and their state after crashing the system.
NOTE

For command line help for this test binary, type /?.

File list

File | Location
bugcheck.sys | <[testbinroot]>\nttest\driverstest\storage\wdk</p>
common.js | <[testbinroot]>\NTTEST\driverstest\storage\crashdump\scripts</p>
Crash.wsf | <[testbinroot]>\NTTEST\driverstest\storage\crashdump\scripts</p>
bugcheckdrvctrl.dll | <[testbinroot]>\nttest\driverstest\storage\wdk\crashtest</p>
bugcheckdrvctrl.tlb | <[testbinroot]>\nttest\driverstest\storage\wdk\crashtest</p>
UefiTprTest.exe | <[testbinroot]>\nttest\driverstest\storage\wdk</p>

Parameters

Parameter name | Parameter description
LLU_LclAdminUsr | User account for running the test.
LLU_NetAccessOnly | User account for accessing test fileshare.
StorageDriveLetter | Assigned by Create Storage Parameters.
StorageDriveNumber | Assigned by Create Storage Parameters.
DiskDeviceObjLink | Assigned by Create Storage Parameters.


USB Controller Driver Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3434a259-4ab2-4bd3-b684-64a43d01f742

This test verifies that all USB controllers on the system are using inbox Microsoft drivers.

Test details
Specifications
  • System.Fundamentals.SystemUSB.SystemExposesUSBPort
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


USB Exposed Port System Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5271c664-5f93-414e-93e7-31b394a552d4

This test validates the port mapping of all SuperSpeed capable connectors of the system.

Test details
Specifications
  • System.Fundamentals.SystemUSB.SuperSpeedCapableConnectorRequirements
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


USB Generic HID Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f7949ab5-dd13-4c74-876f-6d54ff85e213

Systems that support USB Human Interface Devices (HID) must be tested with Microsoft's USB HID driver stack installed and enabled with MUTT attached.

Test details
Specifications
  • System.Fundamentals.SystemUSB.TestedUsingMicrosoftUsbStack
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 5
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


USB Internal Device Idle Test - Compat

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/06e1e2d7-ac7c-4ded-82f7-9c6a31386880

This test validates all internal USB devices go to selective suspend.

Test details
Specifications
  • System.Fundamentals.USBDevice.SelectiveSuspend
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Development
Timeout (in minutes) | 2
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
ForceValidationAsAoac | Assume non-AOAC systems are AOAC capable so you can find power hungry devices. Does not affect AOAC capable machines.


USB MUTT Firmware Update for Systems

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5a4695e-52ca-42ab-bb38-a4c1ca939e21

This test updates all MUTT devices in the system to the latest firmware included in this kit.

Test details
Specifications
  • System.Fundamentals.SystemUSB.Discretional
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Development
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Usb Type-C ACPI Validation

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3c41a3f-b844-4c2d-b115-dad51a37f123

This test verifies that ACPI has been configured for a Type-C system.

Test details
Specifications
  • System.Fundamentals.SystemUSB.SystemExposesUSBPort
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
NumberOfUsbTypeCPorts | Set this to the number of USB Type-C ports on the system. Set it to 0 if there are no Type-C ports.


USB Type-C Connection Exerciser Loop Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3f047658-3c7c-45a8-a2d9-4561f07e45cc

This test verifies that Type-C system can switch between UFP/DFP or different types of UFP or DFP devices. This test is not required to be run for non Type-C systems.

Test details
Specifications
  • System.Fundamentals.SystemUSB.SystemExposesUSBPort
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Development
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
NumIterations | Number of iterations of USB Type-C Connection Exerciser Loop Test. Recommended: 100. For long running tests set to 10000.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


USB xHCI Transfer Speed Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4be72bcf-c293-4578-8400-b0cb2f091e16

Runs USB 3.0 xHCI transfer speed perf test on xHCI controllers.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBControllerTransferSpeed
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


USB3 Termination

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/02af7b0a-8859-414c-9061-bbf9c1b60c73

This test verifies that SuperSpeed termination remains on unless the operating system explicitly removes it.

Test details
Specifications
  • System.Fundamentals.SystemUSB.XHCIControllersMustHaveEmbeddedInfo
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 15
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Verifies PS2 Devices have a unique Plug and Play ID

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b8f8c28-c829-4a51-a1af-bb01a43dc048

This test verifies that PS2 devices have a unique Plug and Play ID.

Test details
Specifications
  • System.Fundamentals.Input.PS2UniqueHWID
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: WDTF System Fundamentals Testing Prerequisites.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Fundamentals Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.


Verify System.Fundamentals.Security.VirtualizationSupport

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5622e73a-c222-455c-a389-44b0bb5cd908

Test details
Specifications
  • System.Fundamentals.Security.VirtualizationBasedSecurity.VirtualizationSupport
Platforms
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
BinPath | Path to detectvp directory.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


Watchdog Timer Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3831da21-28a9-43c8-8815-853113c9265a

This Watchdog test determines if there is a hardware watchdog andoptionally causes system reset via the hardware watchdog timer.

Test details
Specifications
  • System.Fundamentals.WatchDogTimer.IfWatchDogTimerImplemented
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 31
Category | Development
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation


WGF11 D3DSystemCheck - Hybrid

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c4eadb10-7310-4655-ab50-e2430e3b6467

Validates that a hybrid system meets the required feature level and Discrete list (DList) requirements as documented in the hybrid spec: 1) Each adapter in the system must support at least Feature Level 11.0. 2) The DList must be queried in under 4ms and it's size must be under 200kB.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
WDKDeviceID | Device id of DUT


WGF11 D3DSystemCheck - Hybrid (WoW64)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/61cccc95-1d45-4d89-b5ea-4717a48a7605

Validates that a hybrid system meets the required feature level and Discrete list (DList) requirements as documented in the hybrid spec: 1) Each adapter in the system must support at least Feature Level 11.0. 2) The DList must be queried in under 4ms and it's size must be under 200kB.

Test details
Specifications
  • System.Fundamentals.Graphics.HybridGraphics.MultiGPU
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

More information

Parameters

Parameter name | Parameter description
MODIFIEDCMDLINE | Additional command line arguments for test executable
LLU_NetAccessOnly | LLU Name of net user
ConfigDisplayCommandLine | Custom Command Line for ConfigDisplay. Default: logo
TDRArgs | /get or /set
WDKDeviceID | Device id of DUT


WindowsToGo Boot Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/566141f1-512f-45a5-a5da-b2ef4c10327b

This test validates that the USB storage can be provisioned with a Windows image and the following requirements are met:

  • Boot into Windows from the device.

  • Operates at SuperSpeed when plugged into a USB 3.0 port.

  • Enter and resume from S3 sleep.

  • Enter and resume from S4 hibernate.

NOTE

This is a system-specific implementation of an existing test. For more information on this test, see WindowsToGo Device Boot Test.

Test details
Specifications
  • System.Fundamentals.USBBoot.BootFromUSB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 45
Category | Scenario
Timeout (in minutes) | 2700
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

The hardware requirements are as follows:

  • The device must be USB 3.0 and certified for Windows To Go.

  • The device under test must be plugged into a USB 3.0 port to run this test.

  • The computer running the test should have no other USB storage devices attached.

  • The computer running the test does not have an equal amount or more system memory than the WTG certified device (for example, if the system has 32Gb of RAM, you can't use a 32Gb WTG drive).

The software requirements are as follows:

  • User must copy a valid Windows Image (WIM) file to the test computer. It must include any drivers needed to use the system's hardware.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

If you cannot boot from the Windows To Go device, use the following to troubleshoot this issue:

  • Ensure that the Windows image does not include any 3rd party USB drivers.

  • Ensure that the system you are using to run this test has the latest firmware.

  • If boot was interrupted by an INACESSIBLE_BOOT_DEVICE stop error, the UFD likely became unresponsive after receiving a certain sequence of commands. Take a USB trace to determine what caused the UFD to become unresponsive.

  • If the system did not attempt to boot the Windows To Go drive, the UFD likely did not enumerate quickly enough for the system's firmware. Take a USB trace to determine what caused the system to abort its attempt to boot the UFD.

  • If you have taken these debugging steps and believe your device is behaving correctly, run the test again with a certified device and compare the results.

If the device cannot enter S3 sleep, your WIM image may not have the correct graphics drivers installed. Use the following steps to see what is blocking S3 sleep:

  • Provision a Windows To Go device with the same image you use with the test and then boot from it.

  • Open a command prompt, and the run the following command: powercfg a

  • Note which device is blocking S3 sleep, add the appropriate driver to the WIM file, and run the test again.

If the computer lost state when resuming from S3 sleep or S4 hibernate, this could mean that the computer lost power to the Windows To Go device before all of the data in its cache could be written.

If the computer resumes to the host operating system instead of the Windows To Go operating system from hibernation, the computer had a problem booting the Windows To Go device and the host computer was booted instead. Take a USB trace to determine what caused the computer to revert back to the host operating system.

If you receive Surprise Removal events during the test that were not caused from the Windows To Go device being unplugged and then plugged back in, the Windows To Go device may not be properly maintaining its link to the host operating system per the USB 3.0 specification or the Windows To Go device may not be properly saving all data to non-volatile memory when the system enters a sleep state. Take a USB trace to determine what caused the Surprise Removal events.

If the system successfully boots to the Windows To Go operating system, but appears to hang for an extended period of time, manually reboot the system. The following warning may be found in the Te.wtl log file for the 'Process Test Results' task:

Warning: Something prevented the system from entering sleep (S3) or Connected Standby. When booted from the WTG drive open a command prompt and run "powercfg -a" and note what component is listed as blocking S3 or Connected Standby. This is usually the result of missing graphics drivers. Add any missing drivers for your machine to the WIM file you're using for this test.

NOTE

If the logs show the test as passing after the manual reboot, it is acceptable to submit the results for certification with this warning in the logs.

More information

File list

File | Location
boottest.dll | <testbinroot>\pw_device_logo\boottest.dll
unattend.xml | <testbinroot>\pw_device_logo\unattend.xml
pwrtest.exe | <testbinroot>\pwrtest\pwrtest.exe

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
LLU_LclAdminUsr |
TestMode |
WimPath | Full path to a Windows Image file (WIM). Must be full Windows, not WinPE
WimIndex | Image within the WIM to use. Should match host computer architecture (x86/amd64)
TAEFSource |


WindowsToGo UEFI USB Class Entry Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1cbb1e92-cd9b-4c54-b34f-67b91d3527c4

This test creates a Windows To Go USB class entry in the UEFI firmware and reboots to validate the computer persists the boot entry and boot order.

Test details
Specifications
  • System.Fundamentals.USBBoot.BootFromUSB
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Development
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

The hardware requirements are as follows:

  • The computer must have UEFI firmware and be in UEFI mode while running the test.

  • The computer running the test must not have any other USB storage devices attached.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting Device.Storage Testing.

Ensure that the computer supports UEFI, is in UEFI mode, and that it has not been placed in legacy or BIOS mode.

If you have any USB devices connected, you should remove them.

If the computer ignored the request to remove the Windows To Go USB class entry, verify that the firmware accepts commands to remove USB entries.

If the Windows To Go USB class entry was created but not put at the top of the boot order, delete and recreate a USB entry to ensure you can programmatically create and specify the order of the entry.

If the computer ignores the request to create a Windows To Go USB class entry, verify that the firmware accepts commands to add USB entries.

If the Windows To Go boot entry did not persist a reboot, remove and recreate the USB class entry. Restart the computer and verify that the entry exists even without any USB devices attached to the computer.

If the Windows To Go boot entry did not stay at the top of the boot order, remove and recreate the USB class entry. Restart the computer and verify that the entry remains at the top of the boot order even without any USB devices attached to the computer.

More information

File list

File | Location
WTGUEFITests.dll | <testbinroot>\pw_system_logoWTGUEFITests.dll

Parameters

Parameter name | Parameter description
LLU_NetAccessOnly |
LLU_LclAdminUsr |
TAEFSource |


xHCI Debug Capability Compliance (Logo)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/bc39efad-a222-4054-b2ee-37714ddfbc1d

This test measures the ability of a test computer to support debug operations using an xHCI controller.

Test details
Specifications
  • System.Fundamentals.DebugPort.USB.SystemExposesDebugInterfaceUsb
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 15
Category | Development
Timeout (in minutes) | 900
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Fundamentals additional documentation

Running the test

To complete this debug test, you must configure two computers. The computer that you are trying to certify is the System under Test (SUT). The second computer is the Host on which the Windows debugger will run. These computers must meet the Windows HLK prerequisites and must be included in the same computer pool. For more information, see Windows HLK Prerequisites. If the device being tested is an XHCI controller, an XHCI controller must be included in both computers. If the XHCI controller in the SUT has any user-accessible ports, the controller must have debug capability.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

If the test will not run, enable file sharing on the host computer (second computer) and try again.

For troubleshooting information, see Troubleshooting Bus Controller Testing.

This test returns Pass or Fail. To review test details, review the test log from Windows Hardware Lab Kit (Windows HLK) Studio.

More information

Command syntax

In the Parameters window Transport field, enter USB. Provide the following additional parameters.

Transport type Required parameters Comments

USB

UsbTargetName

Default is default. If there's more than one USB host controller on the SUT computer, you must specify a BusParams value. Enter Busparams as b.d.f where b, d, and f are the bus number, device number, and function number of the USB host controller that you are using for debugging. These numbers are displayed in the USB host controller's Properties window in Device Manager.

Important

If you are using an EHCI host controller on the SUT computer, the debug cable must be connected to Port 1. You can use the UsbView tool to identify Port 1. USBView is included in the WDK.

Parameters

Parameter name | Parameter description
AccessiblePorts | Please enter zero or one for the number of externally accessible USB3 ports
BusParams | For a PCI-enumerated controller, please enter bus params as b.d.f where b, d, and f are the bus number, device number, and function displayed in the relevant device manager properties page. For an ACPI-enumerated controller, please enter a single integer.


System.Fundamentals additional documentation

In this section

  • Hardware Security Testability Specification
  • TPM System Fundamentals Testing Prerequisites
  • WDTF System Fundamentals Testing Prerequisites
  • Troubleshooting System Fundamentals Testing
  • TPM V2.0 Command and Signal Profile
  • Trusted Execution Environment ACPI Profile
  • Trusted Execution Environment EFI Protocol


Hardware Security Testability Specification

Introduction

HSTI protects against misconfiguration of security features on Windows devices. For customers, HSTI provides best effort assurance that the machine they have purchased is secure by default. For IHVs and IBVs, HSTI makes sure your security promises are kept. For OEMs and ODMs easily ensure that the systems you ship are configured securely out of the box and will stay secure, without having to develop proprietary solutions.

The results of HSTI tests will be consumed by Windows Compatibility Tests and can be used to verify that devices have been properly configured to enable supported security features. These tests may be used to identify unsecured engineering devices in the field, for example, engineering devices which may contain insecure test keys. The results of these tests may be used by the Windows OS to display a watermark (or similar indicator) on insecure devices.

NOTE

The platform is required to implement a hardware interface and share documentation and tools as specified in this topic.

Background

The reader is expected to know the fundamentals of UEFI and have an understanding of Secure Boot technologies including Section 27 "Security" of the UEFI specification and NIST SP 800-147.

This requirement has three aspects:

  • Platform independent interfaces for querying hardware and firmware security states
  • Design and optional code review of the above interface implementations
  • Sharing of documentation and tools

High Level Implementation

The Bitfield

The IHV defines a bitfield representing the testable security features of the platform. This bitfield fully covers all defineable bits available for the HSTI objects returned by any IHV, IBV or OEM HSTI tests. The IHV implementor has to design the definition of the bitfield and provide appropriate documentation in order for IBVs to correctly return the results of their HSTI tests.

SecurityFeaturesRequired

The SecurityFeaturesRequired field is only used in processing when a field in an IHV HSTI object and is the method by which the IHV defines the bitfield of required security features.

SecurityFeaturesImplemented

This is a bitfield of the security features implemented by the tests returning the HSTI object.

SecurityFeaturesVerified

This is a bitfield of the security features which have been verified by the tests returning the HSTI object.

Implementation Guidelines

The IHV will develop reference security designs for their platforms that comply with the Windows Compatibility Requirements. In addition, IHVs and IBVs will also implement programmatic tests that verify proper enablement of the reference security implementations and report the results via the Hardware Security Test Interface. These tests are delivered to OEMs & ODMs as compiled modules (not source) and should work without modification. If an OEM/ODM deviates from reference security designs, these test modules may report failures, and the OEM/ODM will need to contact Microsoft to review the modifications and implement an additional HSTI instance that reports these exceptions. OEMs should be able to leverage these security modules with no modification required by following the reference design and documentation. OEMs who wish to add additional security modules, or modify the behavior of any security module, must undergo a design review with Microsoft.

As part of their implementation of tests module implementors will include a struct. A prototype of this struct is included below in the "Prototype section". The IHV will define the meaning of each bit in the security reference checklist. The IHV will further define the meaning of each bit in the bitfields. Finally, the IHV includes a "Required" bitfield in the OEM struct, and for all requirements they are able to test programmatically they will set a bit in the "Implemented" bitfield.

IBVs and OEMs may set bits in the "Implemented" field if they have presented a design to progamatically check for the presence of the security features represented by those bits to Microsoft. If those tests pass they may set the "Verified" field in their respective structs.

The test modules for IHV, IBV and OEM shall be run if present. A true value set at a bit in the SecurityFeaturesEnabled field indicates a passing test result. If a test is not run, or does not pass, a value of 0 shall be set for the representative bit.

Result Processing Logic Example

This example is representative of the logic that will be used by the results processing. Implemented bitfields must follow the format that a 1 means implemented and a 0 means not implemented. If something is implemented it is required. Results bitfields must follow the format that a 0 means failed or test not present and a 1 means affirmatively passed only.

After all results have been calculated, the IHV Results bitfield will be NXORd with their Required bitfield. All non-IHV Results bitfields are ANDed with their respective Implemented bitfields. The resulting bitfields are all ORd together to get the overall results. A passing result of this operation will be a bitfield consisting of entirely 1s.

Deliverables and Ownership

Independent Hardware Vendors (IHVs) and Independent BIOS Vendors (IBVs)

Silicon Suppliers and IBVs who support Connected Standby systems must implement the platform independent interfaces for querying the respective hardware and firmware security states of their reference platforms. These implementations must be delivered as compiled modules. It is preferred that these modules be signed, and a signature check is performed when they are run. The purpose is to query the hardware and firmware designs & states to report proper security provisioning of the platform.

OEMs and ODMs

OEMs and ODMs must not modify or tamper with the HSTI tests which have been provided to them by vendors. OEMs and ODMs are required to guarantee that their systems will pass the HSTI tests as a component of the Windows Certification requirements:

Windows Hardware Certification Requirement - Windows 8.1 WHCR

  • System.Fundamentals.Firmware.UEFISecureBoot
  • System.Fundamentals.Firmware.CS.UEFISecureBoot.ConnectedStandby

Instead of modification, if an OEM requires a method to provide an alternate method to provide the same or better security, that OEM may provide additional security checks. OEM security checks must at least fully cover one IHV or IBV security test. Before use, OEMs must submit to a design review by Microsoft and are subject to the same Documentation and Tool disclosure requirements as other HSTI test providers. Upon approval from Microsoft, the OEM may include security tests which extend upon the IHV and IBV tests.

Note that OEM attestation is not required as part of the HSTI design. HSTI is not a list of requirements for OEMs, it is an interface to guarantee effective programmatic security testing of firmware, hardware and configuration parameters.

Security State Interfaces

The interfaces are built on the EFI Adapter Information Protocol defined in UEFI version 2.4.

Platform Security State Interface

Summary

Platform Security Information - Returns information about the platform's conformance with Windows Hardware Certification Requirement System.Fundamentals.Firmware.CS.UEFISecureBoot, System.Fundamentals.Firmware.CS.UEFISecureBoot.ConnectedStandby and System.Fundamentals.Firmware.CS.UEFISecureBoot.Provisioning.

Prototype

InformationType

#define ADAPTER_INFO_PLATFORM_SECURITY_GUID \
     {0x6be272c7, 0x1320, 0x4ccd, { 0x90, 0x17, 0xd4, 0x61, 0x2c, 0x01, 0x2b, 0x25 }}

#define PLATFORM_SECURITY_VERSION_VNEXTCS   0x00000003

#define PLATFORM_SECURITY_ROLE_PLATFORM_REFERENCE   0x00000001  // IHV
#define PLATFORM_SECURITY_ROLE_PLATFORM_IBV 0x00000002
#define PLATFORM_SECURITY_ROLE_IMPLEMENTOR_OEM 0x00000003
#define PLATFORM_SECURITY_ROLE_IMPLEMENTOR_ODM  0x00000004

Corresponding InformationBlock:

typedef struct {
    UINT32  Version,
    UINT32  Role,
    CHAR16  ImplementationID[256],
    UINT32  SecurityFeaturesSize,
    UINT8   SecurityFeaturesRequired[],     //Ignored for non-IHV
    UINT8   SecurityFeaturesImplemented[],
    UINT8   SecurityFeaturesVerified[],
    // CHAR16   ErrorString[];
} ADAPTER_INFO_PLATFORM_SECURITY;

Term | Description
Version | Return PLATFORM_SECURITY_VERSION_VNEXTCS
Role | The role of the publisher of this interface. Reference platform designers such as IHVs and IBVs are expected to return PLATFORM_SECURITY_ROLE_PLATFORM_REFERENCE and PLATFORM_SECURITY_ROLE_PLATFORM_IBV respectively. If the test modules from the designers are unable to fully verify all security features, then the platform implementers, OEMs and ODMs, will need to publish this interface with a role of Implementer.
ImplementationID | Human readable vendor, model, & version of this implementation. For example "SiliconVendorX Chip1234 v1" and "BIOSvendorY BIOSz v2".
SecurityFeaturesSize | The size in bytes of the SecurityFeaturesRequired and SecurityFeaturesEnabled arrays. The arrays must be the same size.
SecurityFeaturesRequired | IHV-defined bitfield corresponding to all security features which must be implemented to meet the security requirements defined by PLATFORM_SECURITY_VERSION Version. For example, 7 features may be required to be implemented to satisfy Version, a value of 0b01111111 might be reported.
SecurityFeaturesImplemented | Publisher-defined bitfield corresponding to all security features which have implemented programmatic tests in this module.
SecurityFeaturesVerified | Publisher-defined bitfield corresponding to all security features which have been verified implemented by this implementation.
ErrorString | A Null-terminated string, one failure per line (CR/LF terminated), with a unique identifier that the OEM/ODM can use to locate the documentation which will describe the steps to remediate the failure - a URL to the documentation is recommended. For example, "0x4827 JTAG not disabled http://somewhere.net/docs/remediate4827.html \r\n0x2744 Platform Secure Boot key not provisioned http://somewhere.net/docs/remediate2744.html"

Memory Management Considerations

For compatibility purposes between HSTI modules, implementors shall use AllocatePool() and not AllocatePages().

Design review of HSTI Implementation

Microsoft shall conduct preliminary design reviews of all test interface implementations. Examples of the questions that may be asked in a design review are provided in the HSTI Design Considerations section.

Optional Code Reviews

HSTI implementers may request code reviews performed by Microsoft. Code reviews may be provided based on the priority and availability of resources and are not guaranteed. Code reviews will take place subject to a Non Disclosure Agreement.

Documentation and Tools sharing

Silicon and firmware suppliers should make available to Microsoft all necessary security-related reference documentation and tools that they provide to OEMs. This documentation and tools should be made available no later than they are provided to Windows OEMs. This should include, but is not limited to, all documentation and tools related to fusing, installing and updating firmware, firmware and boot recovery, hardware diagnostics, firmware diagnostics, & boot diagnostics. This documentation and tools provided should be fully sufficient to perform HSTI checks in a lab environment.

HSTI Design Considerations

The following is an illustrative list of design considerations that an HSTI implementor must consider for their HSTI implementation. This is not a strict list of requirements, nor is it an exhaustive list of considerations. As an HSTI implementor you will be writing tests to validate the security features you have working towards as comprehensive coverage as possible. Before your design review with Microsoft we recommend you review this list for inspiration, and consider that Microsoft is likely to desire that if you implement these features you test them as extensively as possible.

Silicon Suppliers/Vendor (IHV) HSTI Checks

  1. Do you use RSA 2048 and SHA256 only (or similar crypto strength)
  2. Firmware Code must be present in protected storage
    1. Do you protect spiflash?
    2. Do you implement read-only till reset for eMMC partitions
    3. Do you support Signed Firmware Check - Firmware that is installed by OEM is either read-only or protected by secure firmware update process.
  3. Secure firmware update process
    1. Is secure firmware update process on by default with test keys? (RECOMMENDED)
    2. Do you check if test keys are used in production?
    3. Do you allow rollback to insecure firmware version? If yes then what is the protection mechanism? Do you clear TPM when rollback happens?
  4. Do you have backdoors to override SecureBoot
    1. Does your system support inline prompting to bypass Secureboot? If yes then is it disabled while SecureBoot is enabled?
    2. Do you have manufacturing backdoors? Do you check for them to be disabled while SecureBoot is enabled and always disabled in production system?
  5. [CS]Boot Integrity Support
    1. Do you support Boot Integrity and is it enabled by default?
    2. Platform uses on-die ROM or One-Time Programmable (OTP) memory for storing initial boot code and provides power-on reset logic to execute from on-die ROM or secure on-die SRAM.
  6. [CS]Protection from internal and external DMA
    1. Do you keep internal DMA on only for components required during boot? And is disabled for all other components.
    2. Do you keep external DMA on only for components required during boot? And is disabled for all other components.
    3. If firmware has an option to enable and disable DMA protection, shipping configuration must have DMA protection enabled by default
    4. What buses/devices (fuses, security engines, TZ, video, caches, IMEM, kernel memory) are capable of DMA access to different NV and volatile storage regions and how are they protected?
    5. Do you support MOR bit implementation
  7. Protection against external hardware debugger
    1. Do you support JTAG? Is JTAG OFF when SecureBoot is ON
    2. Do you provide manufacturing backdoor to disable JTAG protection? Do you check if this backdoor is not present in production systems?
    3. Do you clear TPM when JTAG is enabled?
    4. Do you support any other hardware debugger? And do the same checks for it.
  8. Have you provisioned per device unique secret correctly?
  9. What are the security fuses you have (vendor specific)
    1. SOC SecureBoot fuse
    2. Per-device-unique secrets such as endorsement or encypherment fuses
    3. JTAG fuses
    4. SOC Apps Processor SecureBoot fuse
    5. SOC MBA Processor SecureBoot fuse
    6. SOC Modern Processor SecureBoot fuse
    7. Any other SOC specific fuses for your platform

IBV HSTI Checks

  1. Do you use RSA 2048 and SHA256 only (or higher but not lower than this)
  2. Compatibility Support Modules (CSM)
    1. Do you provide option to enable CSM
    2. Do you check blocking of loading CSM when SecureBoot is enabled
    3. [CS]Do you check if CSM is not present on CS systems permanently
  3. Firmware Code must be present in protected storage
    1. Do you protect spiflash?
    2. Do you implement read-only till reset for eMMC partitions
    3. Do you support Signed Firmware Check - Firmware that is installed by OEM is either read-only or protected by secure firmware update process.
  4. Secure firmware update process
    1. Is secure firmware update process on by default with test keys?
    2. Do you check if test keys are used in production?
    3. Do you allow rollback to insecure firmware version? If yes then what is the protection mechanism? Do you clear TPM when rollback happens?
    4. Are test keys being used?
  5. Do you have backdoors to override SecureBoot
    1. Does your system support inline prompting to bypass Secureboot? If yes then is it disabled while SecureBoot is enabled?
    2. Do you have manufacturing backdoors? Do you check for them to be disabled while SecureBoot is enabled and always disabled in production system?
  6. [CS]Protection from internal and external DMA
    1. Do you keep internal DMA on only for components required during boot? And is disabled for all other components.
    2. Do you keep external DMA on only for components required during boot? And is disabled for all other components.
    3. If firmware has an option to enable and disable DMA protection, shipping configuration must have DMA protection enabled by default
    4. What buses/devices (fuses, security engines, TZ, video, caches, IMEM, kernel memory) are capable of DMA access to different NV and volatile storage regions and how are they protected?
    5. Do you support MOR bit implementation


TPM System Fundamentals Testing Prerequisites

This section describes the tasks that you must complete before you run Trusted Platform Module (TPM) system fundamentals tests by using the Windows Hardware Lab Kit (Windows HLK). These are settings that you must establish one time before running the TPM tests.

Before you run the TPM system fundamentals tests:

  1. Open Tpm.msc and check whether state is "TPM is ready for use". If it is not, clear the TPM from the TPM MMC console and then prepare the TPM. Make sure that TPM is enabled, active, and owned.

  2. Ensure SecureBoot configuration and Debug policy are set according to each test requirement. Open a command prompt that has administrative privileges. At the command prompt, open msinfo32 and check the following:

    • Secure boot State: ON (ON by default unless exclusively asked to set it to OFF)

    • PCR7 configuration: Bound or Binding possible

Software/Hardware Prerequisite: Firmware based TPM or Discrete TPM.

Related topics

System.Fundamentals Tests


WDTF System Fundamentals Testing Prerequisites

This section describes the tasks that you must complete before you test a client or server system using the Windows Hardware Lab Kit (Windows HLK). System Fundamentals is a collection of tests that apply to both client and server systems and must be run in addition to the system type you want to certify. Review the respective prerequisite topic for the system you are building.

  • For client systems, see System Client Testing Prerequisites

  • For server systems, see System Server Testing Prerequisites

General Requirements

Audio

  • Device has at least one render type endpoint connected (speakers, headphones, etc.)

BitLocker Drive Encryption

  • Disable fast boot in BIOS prior to running any BitLocker test.

CD ROM

  • Drive letter is assigned

  • Media is present in the device

  • Files are present on the media inserted

Disk

  • Disk has at least one associated volume

  • Drive letter is assigned

GPS devices

  • The device must be tested in a location where a GPS signal is available

LAN

  • Device has an IPv6 address

  • Device has an IPv6 default gateway address.

    NOTE

    If the network adapters do not have an IPv6 address, you should use the WDTFREMOTESYSTEM parameter to pass an IPv6 address that is valid on your network, such as the IPv6 address of the HLK controller.

  • Device's network operation status is IfOperStatusUp

WLAN/WiFi devices

  • The device must be tested in a location where a wireless access point is available

Smartcard readers

  • Device has Athena T0 test card inserted

Volume

  • Drive letter is assigned

  • Media is present in the device

USB Host Controller

  • A SuperSpeed HUB should be connected downstream of each exposed port, and at least one SuperMUTT must be connected to one of these hubs.

Related topics

System.Fundamentals Tests


Troubleshooting System Fundamentals Testing

To troubleshoot issues that occur with System.Fundamental tests, follow these steps:

  1. Review the following Windows Hardware Lab Kit (Windows HLK) topics:

    • Troubleshooting Windows HLK Test Failures

    • WDTF System Fundamentals Testing Prerequisites

  2. Review the Windows HLK release notes for current test issues.

  3. For a test failure, look for usable information in the Windows HLK Studio test log. If you find usable information, resolve the issue and rerun the test.

Related topics

Troubleshooting Windows HLK


TPM V2.0 Command and Signal Profile

This document specifies the TPM signaling interface supported by Windows 8 and lists TPM 2.0 commands that:

  1. Are used by Windows 8 and hence required to be implemented for Windows Hardware Certification;

  2. Are not used by Windows 8 but are recommended to implement for other reasons (e.g. TPM management, expected 3rd party app usage and OEM usage.); and

  3. Are not used by Windows 8 but are optional to implement.

No other signaling interface is supported but additional TPM 2.0 commands that are not used by Windows may be implemented in a TPM 2.0 device that is compliant with this specification. Please contact Microsoft for more information about vendor-specific command ranges.

Command and Signal Profile

Requirements

This profile requires that a TPM 2.0 implemented to support Windows 8:

  • Implements the TCG TPM 2.0 Library Specification including critical security patches (for compatibility with later version of the specification, please contact Microsoft. For certifying TPMs in 2015, requirement is to implement v0.99 along with required security patches. For information about the required security patches, please contact Microsoft.)

  • Is always active; i.e. no need for programmatic or user-driven activation.

  • Is provisioned with a primary seed for Endorsement and Storage.

Requirements Matrix

Signals and Indications | Included | Optional | Notes
_TPM_Init | X |  |
_TPM_Hash_Start |  | X |
_TPM_Hash_Data |  | X |
_TPM_Hash_End |  | X |
Commands | Included | Optional | Notes
Start Up Commands |  |  |
TPM2_Startup | X |  | Used by the firmware only
TPM2_Shutdown | X |  |
Testing Commands |  |  |
TPM2_SelfTest | X |  |
TPM2_IncrementalSelfTest |  | X |
TPM2_GetTestResult | X |  |
Session Commands |  |  |
TPM2_StartAuthSession | X |  |
TPM2_PolicyRestart | X |  |
Object Commands |  |  |
TPM2_Create | X |  |
TPM2_Load | X |  |
TPM2_LoadExternal |  | X | Recommended
TPM2_ReadPublic | X |  |
TPM2_ActivateCredential | X |  |
TPM2_MakeCredential |  | X | Recommended
TPM2_Unseal | X |  |
TPM2_ObjectChangeAuth | X |  |
Duplication Commands |  |  |
TPM2_Duplicate | X |  |
TPM2_Rewrap |  | X |
TPM2_Import | X |  |
Asymmetric Primitives |  |  |
TPM2_RSA_Encrypt |  | X |
TPM2_RSA_Decrypt | X |  |
TPM2_ECDH_KeyGen |  | X |
TPM2_ECDH_ZGen |  | X |
TPM2_ECC_Parameters |  | X |
Symmetric Primitives |  |  |
TPM2_EncryptDecrypt |  | X |
TPM2_Hash | X |  |
TPM2_HMAC |  | X |
Random Number Generator |  |  |
TPM2_GetRandom | X |  |
TPM2_StirRandom | X |  |
Hash/HMAC/Event Sequences |  |  |
TPM2_HMAC_Start |  | X |
TPM2_HashSequenceStart |  | X | Recommended
TPM2_SequenceUpdate |  | X | Recommended
TPM2_SequenceComplete |  | X | Recommended
TPM2_EventSequenceComplete |  | X | Recommended
Attestation Commands |  |  |
TPM2_Certify | X |  |
TPM2_CertifyCreation | X |  |
TPM2_Quote | X |  |
TPM2_GetSessionAuditDigest |  | X |
TPM2_GetCommandAuditDigest |  | X |
TPM2_GetTime |  | X |
Anonymous Attestation Commands |  |  |
TPM2_Commit |  | X |
Signature Verification Commands |  |  |
TPM2_VerifySignature |  | X | Recommended
TPM2_Sign | X |  |
Command Audit |  |  |
TPM2_SetCommandCodeAuditStatus |  | X |
Integrity Collection |  |  |
TPM2_PCR_Extend | X |  |
TPM2_PCR_Event | X |  |
TPM2_PCR_Read | X |  |
TPM2_PCR_Allocate |  | X |
TPM2_PCR_SetAuthPolicy |  | X |
TPM2_PCR_SetAuthValue |  | X |
TPM2_PCR_Reset | X |  |
Enhanced Authorization Commands |  |  |
TPM2_PolicySigned |  | X | Recommended
TPM2_PolicySecret | X |  |
TPM2_PolicyTicket |  | X | Recommended
TPM2_PolicyOR | X |  |
TPM2_PolicyPCR | X |  |
TPM2_PolicyLocality |  | X |
TPM2_PolicyNV | X |  |
TPM2_PolicyCounterTimer |  | X | Recommended
TPM2_PolicyCommandCode | X |  |
TPM2_PolicyPhysicalPresence |  | X |
TPM2_PolicyCpHash |  | X | Recommended
TPM2_PolicyNameHash |  | X | Recommended
TPM2_PolicyDuplicationSelect |  | X | Recommended
TPM2_PolicyAuthorize |  | X | Recommended
TPM2_PolicyAuthValue | X |  |
TPM2_PolicyPassword |  | X | Recommended
TPM2_PolicyGetDigest | X |  |
Hierarchy Commands |  |  |
TPM2_CreatePrimary | X |  |
TPM2_HierarchyControl | X |  |
TPM2_SetPrimaryPolicy |  | X |
TPM2_ChangePPS |  | X |
TPM2_ChangeEPS |  | X |
TPM2_Clear | X |  |
TPM2_ClearControl | X |  |
TPM2_HierarchyChangeAuth | X |  |
Dictionary Attack Functions |  |  |
TPM2_DictionaryAttackLockReset | X |  |
TPM2_DictionaryAttackParameters | X |  |
Miscellaneous Management Functions |  |  |
TPM2_PP_Commands |  | X |
TPM2_SetAlgorithmSet |  | X |
Field Upgrade |  |  |
TPM2_FieldUpgradeStart |  | X | Microsoft strongly recommends some update mechanism is provided
TPM2_FieldUpgradeData |  | X |
TPM2_FirmwareRead |  | X |
Context Management |  |  |
TPM2_ContextSave | X |  |
TPM2_ContextLoad | X |  |
TPM2_FlushContext | X |  |
TPM2_EvictControl | X |  |
Clocks and Timers |  |  |
TPM2_ReadClock | X |  | Used to read the boot counter
TPM2_ClockSet | X |  | Likely used by firmware only
TPM2_ClockRateAdjust |  | X |
Capability Commands |  |  |
TPM2_GetCapability | X |  |
TPM2_TestParms |  | X |
Non-volatile Storage |  |  |
TPM2_NV_DefineSpace | X |  |
TPM2_NV_UndefineSpace | X |  | Win 8 may use Clear instead
TPM2_NV_UndefineSpaceSpecial |  | X |
TPM2_NV_ReadPublic | X |  |
TPM2_NV_Write | X |  | Likely used by OEM only
TPM2_NV_Increment | X |  |
TPM2_NV_Extend |  | X |
TPM2_NV_SetBits |  | X |
TPM2_NV_WriteLock |  | X |
TPM2_NV_GlobalWriteLock |  | X |
TPM2_NV_Read | X |  |
TPM2_NV_ReadLock |  | X |
TPM2_NV_ChangeAuth | X |  |
TPM2_NV_Certify |  | X |


Trusted Execution Environment ACPI Profile

Licensing: Microsoft agrees to grant to you a no charge, royalty-free license to its Necessary Claims on reasonable and non-discriminatory terms solely to make, use, sell, offer for sale, import, or distribute any implementation of this specification. "Necessary Claims" are those claims of Microsoft-owned or Microsoft-controlled patents that are technically necessary to implement the required portions (which also include the required elements of optional portions) of this specification, where the functionality causing the infringement is described in detail and not merely referenced in this Specification.

1.0 Background

This specification defines the ACPI device object for a TPM 2.0 device and the control methods associated with the ACPI device object required for Windows 8. The control methods implement the equivalent of the TCG physical presence ACPI interface, the equivalent of the Platform Reset Attack Mitigation interface and optionally an ACPI method to send a command to the TPM 2.0 device.

An additional static ACPI table (TPM2) is used to define the mechanism for communicating between the TPM 2.0 device and the Windows 8 OS.

NOTE

Microsoft refers to the Trusted Computing Group's "TPM.Next" term as "TPM 2.0"

2.0 Requirements

This specification assumes a computing platform that supports ACPI-based communication as specified in [ACPI09] between an OS and a firmware environment.

3.0 Usage scenarios (for example only)

3.1 Sending a physical presence command

A typical usage scenario is as follows:

  1. Within the OS environment, an application detects the TPM 2.0 device is not fully provisioned for use for Windows 8. (An example of how this could happen is if a new OS image is installed after a previous OS image provisioned the TPM 2.0.)

  2. The application launches an OS wizard to ready the TPM 2.0 device for use.

  3. The wizard interacts with the computer administrator via UI and determines the administrator needs to clear the TPM 2.0 device to provision it because the TPM 2.0 device reset lockout authorization value is not available.

  4. To clear the TPM 2.0 device, the OS requests (by executing an ACPI control method for the TPM 2.0 device object) the firmware perform the operation to clear the TPM 2.0 device upon the next boot provided a physically present user confirms they approve of clearing the TPM 2.0 device.

  5. The OS restarts the platform.

  6. During the early portion of the boot process, the firmware recognizes the pending request from the OS to clear the TPM 2.0 device.

  7. The firmware presents a UI to a physically present user asking them to take some action to confirm clearing of the TPM 2.0 device.

  8. A physically present user confirms clearing of the TPM 2.0 device.

  9. The firmware clears the TPM 2.0 device using the platform hierarchy authorization.

  10. If necessary, to persist the clearing of the TPM 2.0 device, the platform is rebooted immediately.

  11. The OS boots.

  12. The OS queries (via an ACPI control method on the TPM 2.0 device) if the last OS request to clear the TPM 2.0 device was either (a) successful, (b) was not confirmed by the physically present user or (c) had some other error. In the following, we assume the TPM 2.0 device was cleared successfully.

  13. The TPM 2.0 device provisioning wizard within the OS performs additional commands to ready the device for use by Windows.

3.2 Requesting memory to be cleared on the next boot

This scenario illustrates how the memory clear feature of the system helps thwart attacks that harvest system memory for key material after the platform is unexpectedly restarted.

  1. From within the OS, an administrator on a system with a TPM 2.0 device turns on the BitLocker feature for the OS volume.

  2. The BitLocker feature calls the TPM 2.0 device ACPI control method to set the ClearMemory bit defined in the TCG Platform Reset Attack Mitigation Specification.

  3. The BitLocker feature encrypts the OS volume.

  4. The administrator leaves the system unattended with the screen locked.

  5. A malicious person steals the system while it is running.

  6. The malicious person inserts a USB stick and quickly removes the system battery and re-inserts it.

  7. The system starts booting when the battery is re-inserted.

  8. Because the ClearMemory bit was set previously the firmware clears the entire system memory before launching any code not provided by the platform manufacturer.

  9. The malicious person configures the firmware during boot to boot to the USB device even though the code on the USB device is not properly signed.

  10. The code on the USB device scans the system memory for the BitLocker Volume Master Key but it is not found.

    WARNING

    Steps 11 through 16 are similar to the earlier steps, but use the UEFI interface instead of ACPI

  11. The malicious person attempts to boot the system normally.

  12. Because BitLocker was enabled with the TPM key protector, this permits BootMgr to "unseal" the volume master key for the OS volume because the correct measurements are in the TPM 2.0 device when BootMgr runs.

  13. Boot proceeds to the OS logon screen.

  14. The malicious person again removes then re-inserts the battery and boots code from a USB device.

  15. Because the ClearMemory bit was set, the system firmware erases the entire system memory during boot.

  16. Even though code from the USB device scans the system memory, the OS volume encryption key is not in memory.

3.3 Issuing a command to the TPM 2.0 device

This example is not applicable for all system architectures.

  1. The Windows TPM 2.0 driver wants to issue a command to the TPM 2.0 device.

  2. The Windows TPM 2.0 driver writes the command to execute to the physical address read from the ACPI-defined Control Area earlier during the Windows TPM 2.0 driver initialization.

  3. The Windows TPM 2.0 driver executes the ACPI control method to execute a TPM 2.0 command.

  4. The Windows TPM 2.0 driver polls the registers in the control area until they indicate the TPM command has completed.

  5. The Windows TPM driver reads the command response from the physical address read from the ACPI-defined Control Area earlier during Windows TPM driver initialization.

4.0 General ACPI Requirements for the TPM 2.0 System and Device

4.1 Power considerations

ACPI D1/D2

The TPM 2.0 device MAY support ACPI D1 and/or ACPI D2 but MUST behave as if it was in power state ACPI D0 while in D1 or D2.

ACPI S3 (Sleep)

The TPM 2.0 MAY support S3 but entry into and exit from the S3 low power state for the device MUST be controlled by the system/platform manufacturer.

The OS (or other software running in the OS environment) MUST NOT be able to place the TPM 2.0 device in S3 or cause the TPM 2.0 device to exit from S3. For example, if the TPM 2.0 device is on a bus, the OS MUST NOT be able to power down the bus causing the TPM 2.0 device to enter S3.

The Windows 8 TPM driver will attempt to issue a TPM2_Shutdown command prior to entering S3 (sleep).

If a hardware platform does support S3 and the TPM does not retain its state while the system is in S3, the platform MUST issue the necessary TPM2_Init and TPM2_Startup(TPM_SU_STATE) commands during S3 resume. It is possible the OS may not have completed the TPM2_Shutdown command prior to entry into S3. This could cause the return result of TPM2_Startup(TPM_SU_STATE) to return an error. The system firmware that resumes from S3 MUST deal with a TPM2_Startup error appropriately. For example, by either disabling access to the TPM via hardware, issuing a TPM2_Startup(TPM_SU_CLEAR) command and configuring the device securely by taking actions like extending a separator with an error digest (0x01) into PCRs 0 through 7 and locking NV indices.

The system MUST account for time elapsed during S3 by decrementing TPM dictionary attack failure count (TPM_PT_LOCKOUT_COUNTER) for the time the system was in S3 per the lockout interval (TPM_PT_LOCKOUT_INTERVAL). This may require a platform implementation to provide standby voltage to retain TPM clock and/or state during S3 or a platform could also securely provide information regarding how much time elapsed while the system was in a low power state so the TPM can reliably updates its authorization failure count for its dictionary attack logic.

Low Power States for Connected Standby Systems

Windows 8 does not perform any additional actions associated with the TPM upon entry and exit from low power states for Connected Standby systems. The platform MUST performing any actions needed for the TPM to behave as though it was in D0 whenever the system enters and exits from low power states for Connected Standby systems. This MAY require a platform implementation to provide standby voltage to power the TPM clock and/or retain state. Alternatively, a platform MAY need to securely provide information regarding how much time elapsed while the system was in a low power state to the TPM, so the TPM can reliably updates its authorization failure count for its dictionary attack logic.

System Off

The system SHOULD securely account for time elapsed during full shutdown by decrementing TPM dictionary attack failure count (TPM_PT_LOCKOUT_COUNTER) for the time the system was in S5 per the lockout interval (TPM_PT_LOCKOUT_INTERVAL).

4.2 ACPI tables

A system with a TPM 2.0 device MUST provide a device object table with a hardware device ID and an OS vendor specific static table (TPM2) as described below.

Both the TPM2 table and the TPM 2.0 device object MUST be persistent once the platform is shipped to a customer. (E.g. Firmware options MUST NOT permit hiding of the TPM2 table or the TPM 2.0 device object.) An exception is if a system is shipped with a non-default option to provide TPM 1.2 functionality instead of TPM 2.0 functionality (i.e. for compatibility with older operating systems like Windows 7.) In this situation the TPM2 table and the TPM 2.0 device object MAY be removed via a BIOS configuration option and enumeration of a TPM 1.2 performed. Note: A Connected Standby System for Windows 8 is required to ship, by default, with a TPM 2.0 visible to the operating system. Please contact Microsoft for technical guidance about switching between a TPM 2.0 and TPM 1.2 on a hardware platform.

4.3 TPM 2.0 Device Object ACPI Table

4.3.1 Bus Hierarchy

The Device Object table MUST be under the DSDT table in the ACPI namespace.The TPM 2.0 Device Object MUST be located under the system bus at "root\_SB".

4.3.2 Hardware Identifier

The actual plug and play hardware identifier (e.g. _HID) for the TPM 2.0 device object MUST be "MSFT0101"or the device MUST have a compatible ID of "MSFT0101" and the _HID could be vendor specific.

4.3.3 Resource Descriptors

The ACPI TPM 2.0 Device Object MUST claim all resources used by the TPM 2.0 device.

4.3.4 Control Methods

4.3.4.1 Platform Reset Attack Mitigation

The system MUST implement all ACPI and UEFI related parts of [TCG08] for UEFI. The device object MUST implement the control method interface defined in [TCG08], section 6. The interface is required even if the platform unconditionally clears memory on every boot. The clearing of memory MUST NOT be conditional on the TPM 2.0 device state (in contrast [TCG08] does not requiring clearing of memory if the TPM 1.2 is not owned). Also, sections 3, 5 of [TCG08] MUST be implemented. The _DSM query function MUST be implemented (function index 0) per the ACPI specification. (Note: There is a mistake in the ACPI 4.0 specification about the return value for the _DSM method. The return value of the _DSM method should be a buffer containing 0x03.) The implementation MUST auto-detect an orderly OS shutdown and clear the ClearMemory bit on such events.

Special note for UEFI based ARM systems with a TPM 2.0: On UEFI based ARM systems with a TPM 2.0, Windows 8 will unconditionally request memory be cleared using the UEFI interface on every boot. Implementing the ACPI interface is still required, but the interface MAY be implemented to not change the state of the ClearMemory or DisableAutoDetect flags. (Note: Microsoft recommends the ACPI interface be implemented per the TCG specification so calling the ACPI interface does change the state of ClearMemory or DisableAutoDetect.)

4.3.4.2 Physical Presence Interface

The system MUST implement the specification defined in [TCG11] per the additional notes below:

  1. The use of TPM in the TCG specification should be equated with the TPM 2.0 device.

  2. The control methods defined in section 2 MUST be implemented with the following restrictions:

    1. The _DSM query function MUST be implemented (function index 0) per the ACPI specification. (Note: There is a mistake in the ACPI 4.0 specification about the return value for the _DSM method. The return value of the _DSM method should be a buffer containing 0x01FF.)

    2. The implementation MUST return a value of "2: Reboot" for "Get Platform-Specific Action to Transition to Pre-OS Environment." PPI operations MUST occur for a transition of a restart and SHOULD occur for a shutdown transition.

    3. Implementation of the following control methods is optional: "Submit TPM Operation Request to Pre-OS Environment" (may return "2: General Failure") and "Submit preferred user language" (may return "3: Not implemented").

  3. The requirements in section 3 MUST be implemented with the following revisions:

    1. The BIOS does not need to provide persistent storage for the NoPPIProvision flag because the operations it authorizes are not relevant for the TPM 2.0 device state.

    2. Table 2 is revised as follows:

      Table 1: revised PPI table 2

      OperationValue

      Operation Name

      TPM Stat

      BIOS TPM Mgmt Flags

      Mandatory versus Optional

      When Physical Presence Confirmation is Required

      May need additional boot cycle

      0

      No Operation

      M

      1-4

      No Operation

      M

      5

      TPM2_ClearControl(NO) +

      TPM2_Clear

      X

      M

      NoPPIClear is FALSE

      X

      6-11

      No Operation

      M

      12-13

      No Operation

      O

      14

      TPM2_ClearControl(NO) +

      TPM2_Clear

      X

      M

      NoPPIClear is FALSE

      X

      15-16

      No Operation

      M

      17

      SetNoPPIClear_False

      X

      O1

      18

      SetNoPPIClear_True

      X

      O1

      Always

      19-20

      No Operation

      O2

      21-22

      TPM2_ClearControl(NO) +

      TPM2_Clear

      X

      M

      NoPPIClear is FALSE

      X

      23 - 127

      Reserved

      >=128

      Vendor Specific

      X

      X

      O

      X
      IMPORTANT

      For SetNoPPIClear_False: if the BIOS implements the items marked "O1" or "O2" it must implement them as a set. For the No Operation that follows SetNoPPIClear_True, the BIOS must not implement operations 19 and 20 if it does not implement operation 12.

    3. Table 3 is revised as follows:

      Operation

      Value

      Operation

      Name

      TPM commands sent by BIOS and other BIOS actions to perform the operation

      0

      No Operation

      No operation

      1-4, 6-13, 15-16, 19-20

      No Operation

      No operation. However, the operation number MUST be remembered and the result if queried from the OS it MUST return success.

      5, 14, 21, 22

      Clear

      TPM2_ClearControl(NO) +

      TPM2_Clear

      <PLATFORM RESET>* [*If necessary to persist the TPM changes from TPM2_CLEAR. Microsoft anticipates on most systems this is unnecessary.]

      17

      SetNoPPIClear_False

      (Require physical presence for clear.)

      This operation does not change TPM state.

      Clears the BIOS TPM Management Flag NoPPIClear to FALSE.

      18

      SetNoPPIClear_True

      (Do not require physical presence confirmation for clear.)

      This operation does not change TPM state.

      Sets the BIOS TPM Management Flag NoPPIClear to TRUE.

      23 - 127

      Reserved

      Reserved, do not implement or use

      >=128

      Vendor Specific

      TPM commands mapping to vendor specific operation

  4. The spirit of section 4 MUST be maintained to obtain confirmation from a physically present user when it is required to perform an operation but the actual mechanism does not need to be key presses. The keys or other mechanism to affirm consent are up to the platform manufacturer.

    Op

    Value

    Operation

    Name

    Confirmation

    Text

    5, 14, 21, and 22

    Clear

    A configuration change was requested to clear this computer's TPM (Trusted Platform Module)

    WARNING: Clearing erases information stored on the TPM. You will lose all created keys and access to data encrypted by these keys.

    Press <CAK> to clear the TPM

    Press <RK> to reject this change request and continue

    18

    SetNoPPIClear_True

    A configuration change was requested to allow the Operating System to clear the computer's TPM (Trusted Platform Module) without asking for user confirmation in the future.

    NOTE: This action does not clear the TPM, but by approving this configuration change, future actions to clear the TPM will not require user confirmation.

    WARNING: Clearing erases information stored on the TPM. You will lose all created keys and access to data encrypted by these keys.

    Press <CAK> to approve future Operating System requests to clear the TPM

    Press <RK> to reject this change request and continue

  5. Section 5 is informative.

  6. Connected Standby systems MAY hardcode NoPPIClear to TRUE and not implement operations 17 and 18. This means they do not need to implement any confirmation dialogs for physical presence actions because no physical presence operations will require user confirmation.

  7. The firmware MUST leave the storage and endorsement hierarchies enabled when it passes control to initial program loader code like the Windows Boot Manager.

4.3.4.3 Optional ACPI Start Method

Note: Some platforms MAY implement this optional ACPI method to permit the OS to request the firmware to execute or cancel a TPM 2.0 command. The use of the ACPI Start method is determined by the StartMethod field of the static ACPI table (see Section 4.4.)If the StartMethod field of the static ACPI table indicates the use of this method, the ACPI Start method MUST be implemented.The ACPI functions defined herein shall reside in the _DSM control method object. [Note: This is not a control method in the TPM2 ACPI table.] The _DSM method defined herein MUST be implemented as follows:

UUID | Revision | Function | Description
6bbf6cab-5463-4714-b7cd-f0203c0368d4 | 0 | 0 | As described in [ACPI09], Section 9.14.1.
 | 0 | 1 | Start

Function Start

Input Arguments:

Arg0 (Buffer): UUID = 6bbf6cab-5463-4714-b7cd-f0203c0368d4
Arg1 (Integer): Revision ID = 0
Arg2 (Integer): Function Index = 1
Arg3 (Package): Arguments = Empty Package

Return Value:

Type: Integer

Description of the Return Value:

0: Success

1: General Failure

Functional Behavior:

This function tells the system to review the status registers in the TPM 2.0 device control area and take the appropriate action to execute or cancel TPM 2.0 command.

The function is non-blocking. The call will return immediately. (Do not attempt to perform command execution from within the ACPI method. AML calls need to be short.)When Return Value 0 is returned, the submitted command was accepted and will be executed by the firmware or cancelled if the Cancel field is already set. Whenever possible the system should return a TPM response instead of a General Failure from this call. For example, a command cannot be processed now, a Response buffer of TPM2_RC_RETRY could be written and the START field could be CLEARed. If the command was cancelled because the Cancel field was set, this method may write a TPM2_RC_Cancelled return code in the Response buffer, clear the Start field and return a value of 0. Alternatively, if the Cancel field is set the method may return a value of 0 and the TPM 2.0 device may later complete or cancel the command per the requirements for cancelling a command.

When Return Value 1 is returned, the firmware is unable to read or act upon the request. Other than the return value, the request is equivalent to a NO-OP. Examples are (a) a bad OS driver requests execution of additional commands before a prior command completed, (b) the control area is not in physical memory [perhaps due to memory corruption], or (c) the command or response physical addresses do not exist. A return value of 1 may cause the Windows TPM 2.0 driver may stop using the TPM 2.0 device until the next full system boot (this excludes hibernation/resume cycles).

Note: Once command execution starts, this method is not called a second time if the OS chooses the cancel the currently executing command. (However it is possible the control method may be called initially for a command while the cancel field is set.)

4.4 TPM2 Static ACPI Table

An ACPI table named "TPM2" listed in the "RSDT" ACPI table describes the platform's TPM 2.0 hardware interface. The Windows TPM 2.0 driver uses this table to determine the manner in which it is to communicate with the TPM 2.0 device. The parameters in the ACPI table required to support this interface are illustrated in the table below.

Table 3: TPM2 ACPI table layout

Field

Byte Length

Byte Offset

Description

Header

Signature

4

00h

'TPM2'. Signature for the TPM 2.0 device Hardware Interface Table

Length

4

04h

The length of the table, in bytes, including the header, starting from offset 0. This field is used to record the size of the entire table.

Revision

1

08h

Revision of this table including the data and structure referenced by it. If any structure referenced by this changed (e.g., Control Area), this revision MUST change. Value 03h.

Checksum

1

09h

The entire table, including the checksum field, MUST add to zero to be considered valid.

OEM ID

6

0Ah

OEM ID per ACPI specification. An OEM-supplied string that identifies the OEM (this may be the chipset vendor).

OEM Table ID

8

10h

The OEM Table ID is the manufacturer model ID (assigned by the OEM identified by "OEM ID"; may be the chipset vendor).

OEM Revision

4

18h

OEM revision for the given OEM Table ID. Per ACPI, "[an] OEM-supplied revision number. Larger numbers are assumed to be newer revisions."

Creator ID

4

1Ch

Vendor ID of utility that created the table. For the tables containing Definition Blocks, this is the ID of the ASL Compiler.

Creator Revision

4

20h

Revision of utility that created the table. For the tables containing Definition Blocks, this is the revision of the ASL Compiler.

Flags

4

24h

Reserved

MUST always be zero

Address of Control Area

8

28h

Physical address of the Control Area. May be either in TPM 2.0 device memory or in memory reserved by the system during boot. The TPM 2.0 driver retains knowledge of this address throughout a boot cycle including hibernation and resume cycles. If the system does not use the Control Area this value MUST be all zeros.

Start Method

4

30h

The start method selector determines which mechanism the Windows TPM 2.0 driver uses to communicate TPM 2.0 commands to the device and to notify the TPM 2.0 device that a command is available for processing. This field may contain one of the following values:

Value | Description
0 | Reserved.
1 | Reserved (Vendor specific)
2 | Uses the ACPI Start method.
3-5 6 | Reserved (Vendor specific) Reserved for the Memory mapped I/O Interface (TIS 1.2+Cancel). This option is not Windows 8 Hardware Certification compliant. Use of this option requires an approved Windows 8 WHLK contingency request for logo certification. Please contact Microsoft for details.
7 8 | Uses the Command Response Buffer Interface. Uses the Command Response Buffer Interface with ACPI Start method.
… | Reserved.

Platform Specific Parameters

variable

34h

The content of the platform specific parameters is determined by the start mechanism used by this system's TPM 2.0 device interface. This field contains values that may be used to initiate command processing. This information may be vendor specific. For Start Method values of 2 or 6 the field is not used and the Byte Length is zero.

4.4.1 Control Area Contents

The Control Area structure contains status fields as well as other control bits/fields and one or more addresses. The Control Area contains the physical address of the command buffer and the physical address of the response buffer.

Not all TPM 2.0 interface implementations use the Control Area, for example a Start Method value of 6 does not use the Control Area and the information in this section is not applicable for the platform.

The control area MUST be in ACPI AddressRangeReserved memory.

The Control Area structure is shown in the table below and unless specified otherwise all accesses to the control area are done in the little endian format.

Table 4: Control Area layout

Field | Byte Length | Offset | Description
Status fields |  |  | TPM 2.0 status fields
Reserved | 4 | 00h | Reserved. (MUST be zero.)
Error | 4 | 04h | SET by the TPM 2.0 to indicate an error condition
Cancel | 4 | 08h | SET by the DRIVER to abort command processing
Start | 4 | 0Ch | SET by the DRIVER to indicate that a command is available for processing.
Interrupt Control | 8 | 10h | Reserved. (MUST be zero.)
Command Size | 4 | 18h | Size of the Command buffer
Command | 8 | 1Ch | This field contains the physical address of the command buffer. Note that the actual command buffer (not the physical address of command buffer) is in big-endian format as mandated by TCG.
Response Size | 4 | 24h | Size of the Response Buffer
Response | 8 | 28h | This field contains the physical address of the response buffer. Note that the actual response buffer (not the physical address of response buffer) is in big-endian format as mandated by TCG.

The TPM 2.0 driver reads the following information once during the initialization of the operating system:

  1. The physical address of the control area

  2. The size of the command buffer

  3. The physical location of the command buffer

  4. The size of the response buffer

  5. The physical location of the response buffer

For systems that use the control area (i.e. the Start Method value does not equal 6) and support hibernation and resume, the five values above MUST remain constant across hibernation and resume cycles.

4.4.1.1 Error

The TPM 2.0 device may SET this status. It may only write this status when Start is SET. Immediately after the TPM 2.0 device SETs this status, it CLEARs the Start value. The Windows TPM 2.0 driver will not read the Error field unless the Start field is CLEAR.

A SET value of the Error field is treated as generic error of the TPM 2.0 device or its hardware interface. Any SET value results in the cancellation of the current command. The command MUST be rolled back, so the TPM 2.0 device is left in a consistent state.

For a device with an ACPI Start method, this field should only be used for errors for which a response code cannot be provided. An example is: the response buffer is not in physical memory. The Windows TPM 2.0 driver may stop using the TPM 2.0 device when this field is SET.

The initial value for this field after ExitBootServices MUST reflect whether the device works or not.

4.4.1.2 Cancel

The Windows TPM 2.0 driver may SET this field to request that TPM 2.0 device processing of current command be terminated. The Windows TPM 2.0 driver does not invoke the Start method to initiate processing of the cancel request.

When Cancel is SET by the Windows TPM 2.0 driver and the TPM 2.0 device is processing a command, the TPM 2.0 device will stop processing the current command at the earliest convenient point. For most commands, it is expected that the TPM 2.0 device will complete the command and provide a normal response. For commands that are long running (e.g., RSA key generation), the TPM 2.0 device may exit with TPM_RC_CANCELLED. The TPM 2.0 device has to either complete or cancel the command within 90 seconds. (Generally most TPM 2.0 commands should complete in less than 500 ms, except RSA key generation commands which may take longer and command cancelling should occur within 200 ms)

The Windows TPM 2.0 driver may CLEAR this value when the Start field is CLEAR. The initial value for this field after ExitBootServices MUST be CLEAR.

4.4.1.3 Start

The Windows TPM 2.0 driver may SET this status to indicate that a new command has been placed in the Command buffer. The Windows TPM 2.0 driver may invoke the Start method to initiate processing of the command. The TPM 2.0 device will CLEAR this status when it completes processing a command.

The Windows TPM 2.0 driver may CLEAR this status when Start method invocation failed.

The initial value for this field after ExitBootServices MUST be CLEAR.

4.4.1.4 Command

This is the physical address to which the Windows TPM 2.0 driver will write the command to execute. The Windows TPM 2.0 driver will never write a command larger than "Command Size".

The Windows TPM 2.0 driver MUST NOT write to this memory area unless the Start field is CLEAR. Note that the address is specified in little-endian format in the control area but the actual command buffer is in big-endian format as mandated by TCG.

4.4.1.5 Response

This is the physical address from which the Windows TPM 2.0 driver will read command responses. The Windows TPM 2.0 driver will never read a response larger than "Response Size".

The Windows TPM 2.0 driver will only read a response after the Start field changed from SET to CLEAR and Error is CLEAR. Note that the address is specified in little-endian format in the control area but the actual response buffer is in big-endian format as mandated by TCG.

4.5 Control Area Interface Definition

For hardware platforms that use the Control Area as the TPM 2.0 interface, this section and the information in section 4.4 describes the TPM 2.0 driver interaction with the hardware. An example of a system that uses the Control Area is a system with a Start Method value of 2 in the TPM2 table.

4.5.1 State Combinations

Table 5 describes the expected behavior for changes made by the Windows TPM 2.0 driver. Please note that only some combinations are allowed. Only the allowed combinations and changes are documented. All other combinations are invalid. Field changes without action by the Windows TPM 2.0 driver means the TPM 2.0 device or the ACPI Start method changed the fields.

States marked with '0' indicate that this field is CLEAR. States marked with '1' indicate that this field is SET. States marked with '?' indicate that the value of this field might be either CLEAR or SET. The status fields are abbreviated with: 'ERR' - Error, 'CCL' - Cancel, and 'STR' - Start. A field can be written either by the Windows TPM 2.0 driver or the TPM 2.0 device interface, which is detailed in the action column.

|---

Present State

---|

|---

Field Written

---|

|---

Next State

---|

Action Taken by TPM 2.0 device interface

#

ERR

CCL

STR

ERR

CCL

STR

ERR

CCL

STR

1

0

1

0

-

0

-

0

0

0

The Windows TPM 2.0 driver CLEARs the Cancel value to prepare the Control Area for the next command. The Windows TPM 2.0 driver may CLEAR the Cancel value only when START is CLEAR.

(The TPM 2.0 device MUST NOT write to the Cancel field.)

2

0

0

0

-

-

1

0

0

1

The Windows TPM 2.0 driver SETs the Start value to indicate that a command is present in the Command area.

The Windows TPM 2.0 driver may call the ACPI Start method to initiate the execution of the command. Upon completion of the ACPI Start method, the TPM 2.0 device MUST complete commands and CLEAR the Start field within 90 seconds. Exceeding the time limit may cause the Windows TPM 2.0 driver to assume the TPM 2.0 device is hung.

3

0

?

1

-

-

0

0

?

0

The TPM 2.0 device CLEARs the Start field when it finishes processing the command or cancels the command.

If the command was canceled, a response with return code TPM_RC_CANCELLED is placed into the response buffer and Start is CLEARed.

The Windows TPM 2.0 driver may read the response buffer while the Start field is CLEAR. The Windows TPM 2.0 driver MUST NOT read the response buffer while the Start field is SET.

4

0

0

1

-

1

-

0

1

1

The Windows TPM 2.0 driver SETs Cancel to indicate the TPM 2.0 device to cancel the current command. Generally, long running commands should be canceled at the next convenient point. Short running commands may be completed. Specifically, the TPM 2.0 device MUST CLEAR the Start field within 90 seconds after the Cancel field is SET. (A good performance target is 200ms instead of 90 seconds.) Note: It is possible the Cancel field may be set when the ACPI Start method is called because one thread within the OS may SET the Cancel field before another thread invokes the ACPI Start Method.

5

0

?

1

1

-

-

1

?

1

The TPM 2.0 device indicates an error condition in the device. The state of the TPM 2.0 device is as if the command execution never started. The Windows TPM 2.0 driver treats this value as a generic failure of the TPM 2.0 device and cancels the processing of the command.

6

1

?

1

-

-

0

1

?

0

The TPM 2.0 device CLEARs the Start field immediately after SETting the Error field.

The Windows TPM 2.0 driver only inspects the Error field when the Start field is CLEAR or if command execution or cancelling does not occur within the required time window. The Windows TPM 2.0 driver may stop using the TPM 2.0 device when the Error field is SET.

4.5.2 State diagram when using ACPI Start method

This state diagram is for informative purposes only. The normative description of behavior is the text in previous sections. If there are missing or ambiguous state transitions please consult the text above.

tpm 2.0 device states when using acpi start method

Figure 1: TPM 2.0 device states when using ACPI Start method

NOTE

(a) Please note that multiple concurrent threads can interact with the Control Area concurrently. For example: one thread could initiate a command by setting the Start field and then issuing the Start method. Another thread can set the Cancel field in parallel. Hence, the possibility to have the Cancel field set after setting the Start field, but before issuing the Start method. (b) A Windows TPM 2.0 driver may react to error conditions differently than depicted. It might, for instance, transition into an error state when a timeout hits.

4.5.3 State diagram without an ACPI Start method

This state diagram is for informative purposes only. The normative description of behavior is the text in previous sections. If there are state transitions are missing or ambiguous please consult the text above.

tpm 2.0 device states without acpi start method

Figure 2: TPM 2.0 device states without ACPI Start method

4.6 Memory Mapped I/O Interface

For hardware platforms that use the Memory Mapped I/O Interface, this section and the information in section 4.4 describes the TPM 2.0 driver interaction with the hardware. An example of a system that uses the memory mapped I/O interface is a system with a Start Method value of 6 in the TPM2 table.

4.6.1 TCG TPM Interface Specification Requirements

The system MUST comply with the TPM 1.2 hardware interface requirements in [TCG12] for the following sections:

Section 9.1: TPM Locality Levels

Section 9.2: Locality Uses

Section 9.3: Locality Usage per a Register

Section 10: TPM Register Space

Section 11: System Interaction and Flows

Except: All of section 11.2.4 Failure Mode

Except section 11.2.5: Command Duration, normative item 2

Except All of section 11.2.6: Timeouts

Except All of section 11.2.8: Self Test and Early Platform Initialization

Except All of section 11.2.9: Input Buffer Size

Except section 11.2.10: Errors, normative items 2c and 3.

Section 13: TPM Hardware Protocol

For future draft specifications of [TCG12] please contact Microsoft.

4.6.2 Support for cancelling a command

Windows requires the TPM 2.0 device to permit cancelling of a TPM 2.0 command using the memory mapped I/O interface by exhibiting the behavior described below.

The previously unused bit 24 of the STS Register is defined as write only and referred to as commandCancel.

A write of '1' to commandCancel during the command execution phase MAY cancel the currently executing command and a response MUST be returned. The response indicates if the command was cancelled (no TPM 2.0 state change, but a cancel response code TPM_RC_CANCELLED is returned) or completed (a regular TPM 2.0 response is returned indicating the result of the command). Writes to the commandCancel register when the TPM is not in the command execution state MUST be ignored.

4.6.3 Additional Requirements

  1. All TPM commands MUST complete within a maximum of 90 seconds.

  2. If the TPM 2.0 driver requests to cancel a command, it must complete or cancel within 90 seconds.

  3. The following TIMEOUT values MUST be implemented: TIMEOUT_A = 1 second, TIMEOUT_B = 2 seconds, TIMEOUT_C = 1 second, TIMEOUT_D = 1 second.

  4. The minimum input buffer size MUST be 0x500 (or larger).

5.0 References

[ACPI09] | "Advanced Configuration and Power Interface Specification," Version 4.0, June 16, 2009.
[TCG08] | Trusted Computing Group, "TCG Platform Reset Attack Mitigation Specification," Version 1.0, May 15, 2008.
[TCG11] | Trusted Computing Group, "TCG Physical Presence Interface Specification," Version 1.20, Feb. 10, 2011.
[TCG12] | Trusted Computing Group, "PC Client Work Group PC Client Specific TPM Interface Specification (TIS) Version 1.21, Revision 1.00.


Trusted Execution Environment EFI Protocol

Licensing: Microsoft agrees to grant to you a no charge, royalty-free license to its Necessary Claims on reasonable and non-discriminatory terms solely to make, use, sell, offer for sale, import, or distribute any implementation of this specification. "Necessary Claims" are those claims of Microsoft-owned or Microsoft-controlled patents that are technically necessary to implement the required portions (which also include the required elements of optional portions) of this specification, where the functionality causing the infringement is described in detail and not merely referenced in this Specification.

1.0 Introduction

This document specifies an EFI protocol for interacting with a Trusted Execution Environment (TrEE), implementing TPM 2.0 functionality per a subset of a Trusted Computing Group (TCG) Trusted Platform Module 2.0 Library specification. This document also specifies platform firmware measurement requirements. The EFI protocol defined herein leverages to a large degree [TCG06a] and [TCG06b].

2.0 Data Structures and Acronyms

2.1 Data Structures

As in [TCG06a], all data values SHALL be represented in Little-Endian format. Strings SHALL be represented as an array of ASCII bytes with the left-most character placed in the lowest memory location.

2.2 Acronyms and Conventions

(For acronyms not defined herein, see [TCG06a])

TrEETrusted Execution Environment

Use of the terms "MUST" and "SHALL" in this document are to be interpreted in accordance with [RFC2119].

3.0 EFI TrEE Protocol

This section provides a detailed description of the EFI_TREE_PROTOCOL and the EFI_TREE_SERVICE_BINDING_PROTOCOL. The EFI TrEE Protocol is used to communicate with a TrEE.

3.1 TrEE EFI Service Binding Protocol

This section defines the TrEE EFI service binding protocol.

Summary - The EFI TrEE Service Binding Protocol is used to locate TrEE devices that are supported by an EFI TrEE Protocol driver and to create and destroy EFI TrEE protocol child driver instances that can use the underlying TrEE device.

GUID - #define EFI_TREE_SERVICE_BINDING_PROTOCOL_GUID \ {0x4cf01d0a, 0xc48c, 0x4271, 0xa2, 0x2a, 0xad, 0x8e, 0x55, 0x97,\ 0x81, 0x88}

DescriptionAn application (or driver) that requires TrEE services can use one of the protocol handler services, such as BS->LocateHandleBuffer(), to search for devices that publish an EFI TrEE Service Binding Protocol. Each device with a published the EFI TrEE Service Binding Protocol supports the EFI TrEE Protocol and may be available for use.

After a successful call to the EFI_TREE_SERVICE_BINDING_PROTOCOL.CreateChild() function, the child EFI TrEE Protocol driver instance is ready for use.

Before an EFI application or driver terminates execution, every successful call to the EFI_TREE_SERVICE_BINDING_PROTOCOL.CreateChild() function must be matched with a call to the EFI_TREE_SERVICE_BINDING_PROTOCOL.DestroyChild() function.

3.2 TrEE EFI Protocol

Summary - The EFI TrEE protocol is used to communicate with a TrEE - to send commands to a TrEE, use it for trusted execution operations and to provide access to the firmware log of measurements extended in the TrEE. The protocol maintains an Event Log of measurements recorded in the TrEE with a format identical to the TCG 1.2 TCG Event Log (see [TCG06b]); referred to as the TrEE Event Log Format TCG 1.2 Event Log in this specification. Implementers may create additional Event Logs with other formats, but this version of the protocol does not define a way to retrieve them.

GUID - #define EFI_TREE_PROTOCOL_GUID \ {0x607f766c, 0x7455, 0x42be, 0x93, 0x0b, 0xe4, 0xd7, 0x6d, 0xb2,\ 0x72, 0x0f}

Protocol Interface Structure -

typedef struct _EFI_TREE_PROTOCOL {
  EFI_TREE_GET_CAPABILITYGetCapability;
  EFI_TREE_GET_EVENT_LOGGetEventLog;
  EFI_TREE_HASH_LOG_EXTEND_EVENTHashLogExtendEvent;
  EFI_TREE_SUBMIT_COMMANDSubmitCommand;
} EFI_TREE_PROTOCOL;

Parameters

GetCapability | This service provides information about the TrEE and firmware capabilities
GetEventLog | Get a pointer to a firmware event log
HashLogExtendEvent | This service will cause the EFI TrEE driver to extend an event and (optionally) write the event to the TrEE log.
SubmitCommand | This service submits a command directly to the TrEE.

Description - The EFI_TREE_PROTOCOL abstracts TrEE activity. This protocol instance provides a Boot Service and is instantiated as a Boot Service Driver.

Boot Service Drivers are terminated when ExitBootServices ( ) is called and all memory resources consumed by the Boot Services Drivers are released for use in the operating system environment.

This Boot Service must create an EVT_SIGNAL_EXIT_BOOT_SERVICES event. This event will be notified by the system when ExitBootServices ( ) is invoked.

EVT_SIGNAL_EXIT_BOOT_SERVICES is a synchronous event used to ensure that certain activities occur following a call to a specific interface function; in this case, that is the cleanup that needs to be done in response to the ExitBootServices ( ) function. ExitBootServices ( ) cannot clean up on behalf of drivers that have been loaded into the system. The drivers have to do that for themselves by creating an event whose type is EVT_SIGNAL_EXIT_BOOT_SERVICES and whose notification function is a function within the driver itself. Then, when ExitBootServices ( ) has finished its cleanup, it signals the event type EVT_SIGNAL_EXIT_BOOT_SERVICES.

For implementation details about how a Boot Service instantiated as an EFI Driver creates this required EVT_SIGNAL_EXIT_BOOT_SERVICES event, see Section 6.1 of [UEFI12].

3.3 EFI_TREE_PROTOCOL.GetCapability

The EFI_TREE_PROTOCOL GetCapability function call provides protocol capability information and state information about the TrEE.

Prototype

typedef
EFI_STATUS
(EFIAPI *EFI_TREE_GET_CAPABILITY) (
  IN EFI_TREE_PROTOCOL      *This,
  IN OUT TREE_BOOT_SERVICE_CAPABILITY*ProtocolCapability,
);

Parameters

This | Indicates the calling context.
ProtocolCapability | The caller allocates memory for a TREE_BOOT_SERVICE_CAPABILITY structure and sets the size field to the size of the structure allocated. The callee fills in the fields with the EFI protocol capability information and the current TrEE state information up to the number of fields which fit within the size of the structure passed in.

Related Definitions

typedef struct _TREE_VERSION {
  UINT8 Major;
  UINT8 Minor;
} TREE_VERSION;
typedef UINT64 EFI_PHYSICAL_ADDRESS;
typedef UINT32 TREE_EVENT_LOG_BITMAP;
typedef UINT32 TREE_EVENT_LOG_FORMAT;
#define TREE_EVENT_LOG_FORMAT_TCG_1_2 0x00000001
typedef struct _TREE_BOOT_SERVICE_CAPABILITY {
  UINT8 Size;
  TREE_VERSION StructureVersion;
  TREE_VERSION ProtocolVersion;
  UINT32 HashAlgorithmBitmap;
  TREE_EVENT_LOG_BITMAPSupportedEventLogs;
  BOOLEAN TrEEPresentFlag;
  UINT16MaxCommandSize;
  UINT16MaxResponseSize;
  UINT32ManufacturerID;
} TREE_BOOT_SERVICE_CAPABILITY;

#define TREE_BOOT_HASH_ALG_SHA1       0x00000001
#define TREE_BOOT_HASH_ALG_SHA256     0x00000002
#define TREE_BOOT_HASH_ALG_SHA384     0x00000004
#define TREE_BOOT_HASH_ALG_SHA512     0x00000008

Size | Allocated size of the structure passed in
StructureVersion | Version of the TREE_BOOT_SERVICE_CAPABILITY structure itself. For this version of the protocol, the Major version shall be set to 1 and the Minor version shall be set to 0.
ProtocolVersion | Version of the TrEE protocol. For this version of the protocol, the Major version shall be set to 1 and the Minor version shall be set to 0.
HashAlgorithmBitMap | Supported hash algorithms
SupportedEventLogs | Bitmap of supported event log formats (see above)
TrEEPresentFlag | False = TrEE not present
MaxCommandSize | Max size (in bytes) of a command that can be sent to the TrEE
MaxResponseSize | Max size (in bytes) of a response that can be provided by the TrEE
ManufacturerID | 4-byte Vendor ID (see [TCG07], "TPM Capabilities Vendor ID" section)

Description

The EFI_TREE_PROTOCOL Get Capability function call provides EFI protocol version and capability information as well as state information about the TrEE. The caller must set the Size field of the TREE_BOOT_SERVICE_CAPABILITY structure allocated. It is expected future versions of this function call may add additional fields to the structure. The Size value passed in will enable the function to only populate fields the caller allocated memory for. For example:

ProtocolCapability.Size = sizeof(TREE_BOOT_SERVICE_CAPABILITY);

For this version of the specification:

  1. If the This or the ProtocolCapability parameters are NULL, the functional call will return EFI_INVALID_PARAMETER.

  2. If the input ProtocolCapability.Size < sizeof(TREE_BOOT_SERVICE_CAPABILITY) the function will set ProtocolCapability.Size equal to sizeof(TREE_BOOT_SERVICE_CAPABILITY) as defined in this specification and will return the error code EFI_BUFFER_TOO_SMALL, the values of the remaining fields will be undefined.

  3. The following return values MUST be set:

    ProtocolCapability.StructureVersion.Major = 1

    ProtocolCapability.StructureVersion.Minor = 0

    ProtocolCapability.ProtocolVersion.Major = 1

    ProtocolCapability.ProtocolVersion.Minor = 0

  4. If the platform does not have a TrEE then the following values MUST be returned:

    ProtocolCapability.SupportedEventLogs = 0

    ProtocolCapability.HashAlgorithmBitmap = 0

    ProtocolCapability.TrEEPresentFlag = FALSE

    ProtocolCapability.MaxCommandSize = 0

    ProtocolCapability.MaxResponseSize = 0

    ProtocolCapability.ManufacturerID = 0

  5. The minimum MaxCommandSize and MaxResponseSize MUST be 0x500 (or greater) for Windows.

Status Codes Returned

EFI_SUCCESS | Operation completed successfully.
EFI_DEVICE_ERROR | The command was unsuccessful. The ProtocolCapability variable will not be populated.
EFI_INVALID_PARAMETER | One or more of the parameters are incorrect. The ProtocolCapability variable will not be populated.
EFI_BUFFER_TOO_SMALL | The ProtocolCapability variable is too small to hold the full response. It will be partially populated (required Size field will be set).

3.4 EFI_TREE_PROTOCOL.GetEventLog

The EFI_TREE_PROTOCOL Get Event Log function call allows a caller to retrieve the address of a given event log and its last entry.

Prototype

typedef
EFI_STATUS
(EFIAPI *EFI_TREE_GET_EVENT_LOG) (
  IN  EFI_TREE_PROTOCOL      *This,
  IN  TREE_EVENT_LOG_FORMATEventLogFormat,
  OUT EFI_PHYSICAL_ADDRESS*EventLogLocation,
  OUT EFI_PHYSICAL_ADDRESS*EventLogLastEntry,
  OUT BOOLEAN*EventLogTruncated
);

Parameters

EventLogFormat | The type of the event log for which the information is requested.
EventLogLocation | A pointer to the memory address of the event log.
EventLogLastEntry | If the Event Log contains more than one entry, this is a pointer to the address of the start of the last entry in the event log in memory. For information about what values are returned in this parameter in the special cases of an empty Event Log or an Event Log with only one entry, see the Description section below.
EventLogTruncated | If the Event Log is missing at least one entry because an event would have exceeded the area allocated for events, this value is set to TRUE. Otherwise, the value will be FALSE and the Event Log will be complete.

Description

The firmware manages an Event Log of the measurements recorded in the TrEE during the boot process. During the boot process, before UEFI platform initialization, an entry is made in the Event Log for each measurement extended in the TrEE. In the UEFI environment, each time a call is made to HashLogExtendEvent to extend a measurement in the TrEE, an event is generally recorded in the Event Log containing the extended measurement. If the area allocated by firmware for the Event Log was too small to hold all events added, the function call indicates the Event Log was truncated and has missing entries. This version of the specification only requires an Event Log of SHA1 measurements to be maintained. Future versions of this specification may maintain additional Event Logs supporting different hash algorithms.

The Event Log area returned by this function is released when ExitBootServices ( ) is called. Callers of this method MUST not access the area after ExitBootServices ( ) has been called.For this version of the specification:

  1. If EventLogFormat does not equal TREE_EVENT_LOG_FORMAT_TCG_1_2, the function call MUST return EFI_INVALID_PARAMETER.

  2. If no TrEE is present the function MUST set the following values and return EFI_SUCCESS:

    1. EventLogLocation = NULL

    2. EventLogLastEntry = NULL

    3. EventLogTruncated = FALSE

  3. The EventLogLocation value MUST be set to the start of the specified event log format in memory

  4. If the specified event log:

    1. does not contain any events then EventLogLastEntry MUST be set to 0

    2. contains exactly one entry then EventLogLastEntry MUST be set to the same value as EventLogLocation

    3. contains more than one event then EventLogLastEntry MUST be set to the start address of the last event of the specified Event Log

  5. If a prior call to EFI_TREE_PROTOCOL.HashLogExtendEvent returned EFI_VOLUME_FULL then EventLogTruncated MUST be set to TRUE, otherwise it MUST be set to FALSE.

Status Codes Returned

EFI_SUCCESS | Operation completed successfully.
EFI_INVALID_PARAMETER | One or more of the parameters are incorrect (e.g. asking for an event log whose format is not supported).

3.5 EFI_TREE_PROTOCOL.HashLogExtendEvent

The EFI_TREE_PROTOCOL HashLogExtendEvent function call provides callers with an opportunity to extend and optionally log events without requiring knowledge of actual TPM commands.The extend operation will occur even if this function cannot create an event log entry (e.g. due to the event log being full).

Prototype

typedef
EFI_STATUS
(EFIAPI * EFI_TREE_HASH_LOG_EXTEND_EVENT) (
  IN EFI_TREE_PROTOCOL*This,
  IN UINT64Flags,
  IN EFI_PHYSICAL_ADDRESSDataToHash,
  IN UINT64DataToHashLen,
  IN TrEE_EVENT*Event,
);

Parameters

This | Indicates the calling context.
Flags | Bitmap providing additional information (see below).
DataToHash | Physical address of the start of the data buffer to be
hashed. |
DataToHashLen | The length in bytes of the buffer referenced by DataToHash.
Event | Pointer to data buffer containing information about the event.

Related Definitions

#pragma pack(1)
typedef struct _TrEE_EVENT {
  UINT32Size;
  TrEE_EVENT_HEADERHeader;
  UINT8Event[ANYSIZE_ARRAY];
} TrEE_EVENT;
typedef struct _TrEE_EVENT_HEADER {
  UINT32HeaderSize;
  UINT16HeaderVersion;
  TrEE_PCRINDEXPCRIndex;
  TrEE_EVENTTYPEEventType;
} TrEE_EVENT_HEADER;
#pragma pack()
typedef UINT32 TrEE_PCRINDEX;
typedef UINT32 TrEE_EVENTTYPE;

Size | Total size of the event including the Size component, the header and the Event data.
HeaderSize | Size of the event header itself (sizeof(TrEE_EVENT_HEADER)).
HeaderVersion | Header version. For this version of this specification, the value shall be 1.
PCRIndex | Index of the PCR that shall be extended (0 - 23).
EventType | Type of the event that shall be extended (and optionally logged).

Flag Values

The Flags variable is a bitmap providing additional data as follows:

#define TREE_EXTEND_ONLY 0x0000000000000001

This bit is shall be set when an event shall be extended but not logged.

#define PE_COFF_IMAGE 0x0000000000000010

This bit shall be set when the intent is to measure a PE/COFF image.

Description

The EFI_TREE_PROTOCOL Hash Log Extend Event function call calculates the measurement of a data buffer (possibly containing a PE/COFF binary image) and causes the TrEE driver to extend the measurement. In addition, the service optionally creates an event log entry and appends it to the Event Log for each event log format supported by the service. The service allows a caller to make use of the TrEE without knowing anything about specific TrEE commands.

The use of this function to measure PE/COFF images must be done before relocations have been applied to the image. Note: Use caution using this method to measure PE/COFF images. Generally implementations that load PE/COFF images strip important data during the load process from the image and may change the image section alignment in memory. The net result is calculating the hash of an in-memory image does not match the actual measurement for the image as properly calculated when it is loaded from storage media.

Upon invocation, the function shall perform the following actions:

  1. If any of the parameters This, DataToHash, or Event are NULL, the function MUST return EFI_INVALID_PARAMETER.

  2. If the Event.Size is less than Event.Header.HeaderSize + sizeof(UINT32), the function MUST return EFI_INVALID_PARAMETER.

  3. If the Event.Header.PCRIndex is not 0 through 23, inclusive, the function MUST return EFI_INVALID_PARAMETER.

  4. If the Flags bitmap has the PE_COFF_IMAGE bit SET but the PE/COFF image is corrupt or not understood the function MUST return EFI_UNSUPPORTED.

  5. The function allows any value for the Event.Header.EventType parameter.

  6. The function MUST calculate the digest (measurement) of the data starting at DataToHash with a length of DataToHashLen. When the PE_COFF_IMAGE bit is set, the function MUST calculate the measurement of the PE/COFF image in accordance with "Measuring a PE/COFF image" in Appendix A below.

  7. The function MUST successfully send the TPM2_PCR_Extend command to the TrEE to extend the PCR indicated by Event.Header.PCRIndex with the measurement digest. If the command cannot be sent successfully, the function must return EFI_DEVICE_ERROR. If the firmware supports more algorithms than SHA1 it may calculate digests using other algorithms and extend them too.

  8. If a previous call to this function returned EFI_VOLUME_FULL and the TREE_EXTEND_ONLY bit is set in the Flags parameter, the function MUST return EFI_VOLUME_FULL. (No attempt is made to add the event log entry to the event log(s).)

  9. The function MUST build a TCG Event Log entry as follows: (Note: The TCG_PCR_EVENT structure is defined in [TCG06b] and shall be considered byte-aligned.)

    1. TCG_PCR_EVENT.PCRIndex = Event.Header.PCRIndex

    2. TCG_PCR_EVENT.EventType = Event.Header.EventType

    3. TCG_PCR_EVENT.Digest = <the SHA1 measurement digest calculated above>

    4. TCG_PCR_EVENT.EventSize = Event.Size - sizeof(UINT32) - Event.Header.HeaderSize

    5. TCG_PCR_EVENT.Event = Event.Event (Note: this is a memory copy of EventSize bytes)

  10. The function MAY build similar event log entries for other supported Event Log formats.

  11. If the TCG_PCR_EVENT Event Log entry created above does not fit in the area allocated for the TrEE Event Log Format TCG 1.2 Event Log, the function MUST return EFI_VOLUME_FULL.

  12. If the firmware supports additional Event Log formats and any of the events created for those event logs would exceed the area allocated for the Event Log, the function MUST return EFI_VOLUME_FULL.

  13. The function MUST append the events created to their corresponding event logs and the service MUST update its internal pointer to the start of the last event for each Event Log.

Status Codes Returned.

EFI_SUCCESS | Operation completed successfully.
EFI_DEVICE_ERROR | The command was unsuccessful.
EFI_VOLUME_FULL | The extend operation occurred, but the event could not be written to one or more event logs.
EFI_INVALID_PARAMETER | One or more of the parameters are incorrect.
EFI_UNSUPPORTED | The PE/COFF image type is not supported.

3.6 EFI_TREE_PROTOCOL.SubmitCommand

This service enables the sending of commands to the TrEE.

Prototype

typedef
EFI_STATUS
(EFIAPI *EFI_TREE_SUBMIT_COMMAND) (
  IN EFI_TREE_PROTOCOL*This,
  IN UINT32InputParameterBlockSize,
  IN UINT8*InputParameterBlock,
  IN UINT32OutputParameterBlockSize,
  IN UINT8*OutputParameterBlock
);

Parameters

This | Indicates the calling context.
InputParameterBlockSize | Size of the TrEE input parameter block.
InputParameterBlock | Pointer to the TrEE input parameter block.
OutputParameterBlockSize | Size of the TrEE output parameter block.
OutputParameterBlock | Pointer to the TrEE output parameter block.

Description

The EFI_TREE_PROTOCOL Submit Command function call provides a pass-through capability from the caller to the system's TrEE.

The caller is responsible for building the command byte-stream to be sent to the TrEE and is also responsible for interpreting the resulting byte-stream returned by the TrEE. The TrEE in and out operands for each TrEE command are defined elsewhere.

Note that the returned status codes reflect the outcome of the function invocation and not the success (or failure) of the underlying TrEE command.

The TPM 2.0 MUST not return TPM2_RC_RETRY prior to the completion of the call to ExitBootServices(). (The reason for this requirement is the return code would block the boot process until the TPM command could be compeleted.)

The TPM 2.0 MUST have access to its persistent storage prior to the call to ExitBootServices completing. If TPM 2.0 implementation MAY not have access to persistent storage after the call to ExitBootServices, please contact Microsoft for additional requirements.

Status Codes Returned

EFI_SUCCESS | The command byte stream was successfully sent to the device and a response was successfully received.
EFI_DEVICE_ERROR | The command was not successfully sent to the device or a response was not successfully received from the device.
EFI_INVALID_PARAMETER | One or more of the parameters are incorrect.
EFI_BUFFER_TOO_SMALL | The output parameter block is too small.

References

[MSFT08] | Microsoft Corporation, "Windows Authenticode Portable Executable Signature Format," Version 1.0, March 21, 2008.
[RFC2119] | Bradner, S., "Keywords for Use in RFCs to Indicate Requirement Levels," IETF RFC 2119, March 1997.
[TCG06a] | Trusted Computing Group, "TCG EFI Protocol," Version 1.20 Revision 1.00, June 9, 2006.
[TCG06b] | Trusted Computing Group, "TCG EFI Platform Specification," Version 1.20 Revision 1.0, June 7, 2006.
[TCG07] | Trusted Computing Group, "TCG Vendor ID Registry," Version 1.0, Revision 0.1, August 31, 2007.
[UEFI12] | UEFI, "Unified Extensible Firmware Interface Specification," Version 2.3.1 Errata C,
June 2012. |

Appendix A: Static Root of Trust Measurements

IMPORTANT

Appendix A implementation of PCR[7] measurements is mandatory for InstantGo systems.

At a high level, firmware is responsible for measuring the following components during boot:

  • Platform firmware that contains or measures the UEFI Boot Services and UEFI Runtime Services

  • Security relevant variables associated with platform firmware

  • UEFI drivers or boot applications loaded separately

  • Variables associated with separately loaded UEFI Drivers or UEFI Boot applications

The above measurements are defined by the TCG EFI Platform specification [TCG06b] Sections 5.1 - 5.5 and are not referred to further herein. Measurements into PCR[1] and PCR[3] are optional depending on platform configuration.

For Windows, PCR[7] is used to reflect the UEFI 2.3.1 Secure Boot policy. This policy relies on the firmware authenticating all boot components launched prior to the UEFI environment and the UEFI platform initialization code (or earlier firmware code) invariantly recording the Secure Boot policy information into PCR[7].

Platform firmware adhering to the policy must therefore measure the following values into PCR[7]:

  1. The contents of the PK variable

  2. The contents of the KEK variable

  3. The contents of the EFI_IMAGE_SECURITY_DATABASE variable

  4. The contents of the EFI_IMAGE_SECURITY_DATABASE1 variable

  5. Entries in the EFI_IMAGE_SECURITY_DATABASE that are used to validate EFI Drivers or EFI Boot Applications in the boot path

  6. The contents of the SecureBoot variable

Because of the above, UEFI variables PK, KEK, EFI_IMAGE_SECURITY_DATABASE, EFI_IMAGE_SECURITY_DATABASE1 and SecureBoot SHALL NOT be measured into PCR[3].

In addition, if the platform provides a firmware debugger which may be launched prior to the UEFI environment, it MUST record this fact in PCR[7]. Likewise, if the platform provides a debugger for the UEFI environment, launch of the debugger MUST be recorded in PCR[7].

Implementation Note

The UEFI LoadImage function MUST record measurements in PCR[2] or PCR[4] per events described in [TCG06b] and also PCR[7] per events described in the section "Measuring UEFI Configuration into PCR[7]" below. To determine whether an image measurement applies to PCR[2] or PCR[4], LoadImage MUST examine the Subsystem field in the PE/COFF image. The values IMAGE_SUBSYSTEM_EFI_BOOT_SERVICE_DRIVER, IMAGE_SUBSYSTEM_EFI_RUNTIME_DRIVER and IMAGE_SUBSYSTEM_EFI_ROM correspond to PCR[2]. The value IMAGE_SUBSYSTEM_EFI_APPLICATION corresponds to PCR[4]. If the loaded image is some other type, it MUST be recorded in PCR[4]. Images that LoadImage fails to load due to (a) signature verification failure or (b) because the image does not comply with currently enforced UEFI 2.3.1 Secure Boot policy do not need to be measured in a PCR.

****Related Definitions

#define EV_EFI_VARIABLE_DRIVER_CONFIG \
                                  0x80000001 /* Defined in [TCG06b] */
#define EV_EFI_ACTION             0x80000007 /* Defined in [TCG06b] */
#define EV_EFI_VARIABLE_AUTHORITY 0x800000E0

This specification requires a modified TCG structure definition for EFI_VARIABLE_DATA.  The revised structure is:
typedef struct {
  EFI_GUIDVariableName;
  UINT64        UnicodeNameLength;    // The TCG Defintion used UINTN
  UINT64        VariableDataLength;   // The TCG Defintion used UINTN
  CHAR16       UnicodeName[1];
  INT8         VariableData[1];
} EFI_VARIABLE_DATA;

Measuring a PE/COFF Image

When measuring a PE/COFF image, the EventType shall be as defined in [TCG06b] (for example, when measuring an EFI Boot Application, the EventType shall be EV_EFI_BOOT_SERVICES_APPLICATION) and the Event value shall be the value of the EFI_IMAGE_LOAD_EVENT structure defined in [TCG06b].

The HashLogExtendEvent service MUST hash the PE/COFF image in accordance with the procedure specified in "Calculating the PE Image Hash" section of [MSFT08].

Measuring UEFI Configuration into PCR[7]

For all EFI variable value events, the EventType shall be EV_EFI_VARIABLE_DRIVER_CONFIG defined above and the Event value shall be the value of the EFI_VARIABLE_DATA structure defined above in this specification (this structure shall be considered byte-aligned). The measurement digest shall be the SHA-1 hash of the event data which is the EFI_VARIABLE_DATA structure. (Note: This is a different digest than the one specified by [TCG06b].) The EFI_VARIABLE_DATA.UnicodeNameLength value is the number of CHAR16 characters (not the number of bytes). The EFI_VARIABLE_DATA.UnicodeName contents MUST NOT include a null terminator. If reading the EFI variable returns EFI_NOT_FOUND, the EFI_VARIABLE_DATA.VariableDataLength field MUST be set to zero and EFI_VARIABLE_DATA.VariableData field will have a size of zero.

  1. If the platform provides a firmware debugger mode which may be used prior to the UEFI environment or if the platform provides a debugger for the UEFI environment, then the platform SHALL extend an EV_EFI_ACTION event as specified in [TCG06b] into PCR[7] before allowing use of the debugger. The event string shall be "UEFI Debug Mode". Further, the platform MUST create a TCG Event Log entry as follows:

    1. TCG_PCR_EVENT.PCRIndex = 7

    2. TCG_PCR_EVENT.EventType = EV_EFI_ACTION

    3. TCG_PCR_EVENT.Digest = <the SHA-1 digest of the string value "UEFI Debug Mode" without the terminating NULL character>

    4. TCG_PCR_EVENT.EventSize = strlen("UEFI Debug Mode")

    5. TCG_PCR_EVENT.Event = "UEFI Debug Mode"

    The platform MAY build similar event log entries for other supported Event Log formats.

  2. Before executing any code not cryptographically authenticated as being provided by the Platform Manufacturer, the Platform Manufacturer firmware MUST measure the following values in the order listed using the EV_EFI_VARIABLE_DRIVER_CONFIG event type to PCR[7]:

    1. SecureBoot variable value

    2. The PK variable value

    3. The KEK variable value

    4. The EFI_IMAGE_SECURITY_DATABASE_GUID/EFI_IMAGE_SECURITY_DATABASE variable value

    5. The EFI_IMAGE_SECURITY_DATABASE_GUID/EFI_IMAGE_SECURITY_DATABASE1 variable value

  3. If the platform supports changing any of the following UEFI policy variables after they are initially measured in PCR[7] and before ExitBootServices ( ) has completed without unconditionally restarting the platform, it MUST measure the variable again immediately upon change. Additionally the normal update process for setting any of the UEFI variables below MUST occur before the initial measurement in PCR[7] or after the call to ExitBootServices() has completed.

    1. SecureBoot variable value

    2. The PK variable value

    3. The KEK variable value

    4. The EFI_IMAGE_SECURITY_DATABASE_GUID/EFI_IMAGE_SECURITY_DATABASE variable value

    5. The EFI_IMAGE_SECURITY_DATABASE_GUID/EFI_IMAGE_SECURITY_DATABASE1 variable value

  4. The system SHALL measure the EV_SEPARATOR event in PCR[7]. (This occurs at the same time the separator is measured to PCR[0] through PCR[7].)

  5. Before launching an EFI Driver or an EFI Boot Application (and regardless of whether the launch is due to the EFI Boot Manager picking an image from the DriverOrder or BootOrder UEFI variables or an already launched image calling the UEFI LoadImage() function), the UEFI firmware SHALL measure the entry in the EFI_IMAGE_SECURITY_DATABASE_GUID/EFI_IMAGE_SECURITY_DATABASE variable that was used to validate the EFI image into PCR[7]. The measurement SHALL occur in conjunction with image load. For this event, the EventType shall be EV_EFI_VARIABLE_AUTHORITY and the Event value shall be the value of the EFI_VARIABLE_DATA structure (the structure is defined above in this specification with a different definition than the TCG specification). The EFI_VARIABLE_DATA.VariableData value shall be the EFI_SIGNATURE_DATA value from the EFI_SIGNATURE_LIST that contained the authority that was used to validate the image and the EFI_VARIABLE_DATA.VariableName shall be set to EFI_IMAGE_SECURITY_DATABASE_GUID. The EFI_VARIABLE_DATA.UnicodeName shall be set to the value of EFI_IMAGE_SECURITY_DATABASE. The value shall not include the terminating NULL character.

  6. Before launching any additional EFI Drivers or EFI Boot Applications, the UEFI firmware SHALL check if the entry in the EFI_IMAGE_SECURITY_DATABASE_GUID/EFI_IMAGE_SECURITY_DATABASE variable which validates the EFI image has previously been measured with the EV_EFI_VARIABLE_AUTHORITY event type in PCR[7]. If it has not been, it MUST be measured as described in the previous step. If it has been measured previously, it MUST NOT be measured again.

NOTE

A measurement example for PCR[7] measurements is available upon request from Microsoft.


System.Fundamentals.Security

In this section

  • System.Fundamentals.Security tests


System.Fundamentals.Security tests

  • Credential Guard - Compliance Test
  • Credential Guard - Enable and Reboot Test
  • Device Guard - Compliance Test
  • Device Guard - Enable and Reboot Test


Credential Guard - Compliance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5f2515bf-5e2b-4b94-94e2-0b60d04e699c

This test checks if the current system is Credential Guard compliant

Test details
Specifications
  • System.Fundamentals.Security.DGCG.CredentialGuard
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


Credential Guard - Enable and Reboot Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1969030e-8b7e-464c-b268-98ee1fccf7c2

Verifies that the computer system is compatible with the Windows Credential Guard feature by enabling it

Test details
Specifications
  • System.Fundamentals.Security.DGCG.CredentialGuard
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


Device Guard - Compliance Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/10c242b6-49f6-491d-876c-c39b22b36abc

Verifies that the computer system is compliant with the Windows Device Guard feature

Test details
Specifications
  • System.Fundamentals.Security.DGCG.DeviceGuard
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 10
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


Device Guard - Enable and Reboot Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f084118-dadd-42a5-9744-1a2ac1389e9f

Verifies that the computer system is compatible with the Windows Device Guard feature by enabling it

Test details
Specifications
  • System.Fundamentals.Security.DGCG.DeviceGuard
Platforms
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 20
Category | Compatibility
Timeout (in minutes) | 60
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


System.Fundamentals.SystemUSB

In this section

  • System.Fundamentals.SystemUSB tests


System.Fundamentals.SystemUSB tests

  • UCSI Connector One Identification [Type-C MUTT]
  • UCSI Connector Reset command [Type-C MUTT]
  • UCSI Get Connector Status - Battery Charging Status Change [Type-C MUTT]
  • UCSI Get Connector Status - Error [Type-C MUTT]
  • UCSI Get Connector Status - External Supply Change [Type-C MUTT]
  • UCSI Get Connector Status - Fail connector reset in dead battery condition [Type-C MUTT]
  • UCSI Get Connector Status - Negotiated Power Level Change [Type-C MUTT]
  • UCSI Get Connector Status - PD Reset Complete [Type-C MUTT]
  • UCSI Get Connector Status - Supported Connector Alternate Modes Change [Type-C MUTT]
  • UCSI Get Connector Status - Supported Provider Capabilities Change [Type-C MUTT]
  • UCSI Get Connector Status command - USB device detection [Type-C MUTT]
  • UCSI Power Direction Role command - Accept swap [Type-C MUTT]
  • UCSI Power Direction Role command - No connection [Type-C MUTT]
  • UCSI Power Direction Role command - Reject swap [Type-C MUTT]
  • UCSI Power Direction Role command - Reset on PPM-Reset [Type-C MUTT]
  • UCSI Power Direction Role command - Reset on disconnect [Type-C MUTT]
  • UCSI Power Direction Role command [Type-C MUTT]
  • UCSI USB Operation Mode command - DFP to DFP connection [Type-C MUTT]
  • UCSI USB Operation Mode command - DFP to UFP connection [Type-C MUTT]
  • UCSI USB Operation Mode command - DRP to DFP connection [Type-C MUTT]
  • UCSI USB Operation Mode command - DRP to UFP connection [Type-C MUTT]
  • UCSI USB Operation Mode command - PPM-Reset clears DFP Operation Mode [Type-C MUTT]
  • UCSI USB Operation Mode command - PPM-Reset clears UFP Operation Mode [Type-C MUTT]
  • UCSI USB Operation Mode command - UFP to DFP connection [Type-C MUTT]
  • UCSI USB Operation Mode command - UFP to UFP connection [Type-C MUTT]
  • UCSI USB Operation Role command - Accept swap [Type-C MUTT]
  • UCSI USB Operation Role command - No connection [Type-C MUTT]
  • UCSI USB Operation Role command - Reject swap [Type-C MUTT]
  • UCSI USB Operation Role command - Reset on PPM-Reset [Type-C MUTT]
  • UCSI USB Operation Role command - Reset on disconnect [Type-C MUTT]
  • UCSI USB Operation Role command [Type-C MUTT]
  • UCSI commands - Get Alternate Modes, SOP [Type-C MUTT]
  • UCSI commands - Get Alternate Modes, SOP-DoublePrime [Type-C MUTT]
  • UCSI commands - Get Alternate Modes, SOP-Prime [Type-C MUTT]
  • UCSI commands - Get Alternate Modes, connector [Type-C MUTT]
  • UCSI commands - Get Cable Property [Type-C MUTT]
  • UCSI commands - Get Capability [Type-C MUTT]
  • UCSI commands - Get Connector Alternate Modes Supported [Type-C MUTT]
  • UCSI commands - Get Connector Capability [Type-C MUTT]
  • UCSI commands - Get Connector Status [Type-C MUTT]
  • UCSI commands - Get Connector Status, Request Data Object [Type-C MUTT]
  • UCSI commands - Get Current Connector Alternate Mode [Type-C MUTT]
  • UCSI commands - Get PDOs, Advertised Capabilities [Type-C MUTT]
  • UCSI commands - Get PDOs, Current Supported Source Capabilities [Type-C MUTT]
  • UCSI commands - Get PDOs, Maximum Supported Source Capabilities [Type-C MUTT]
  • UCSI commands - Get PDOs, Sink Capabilities [Type-C MUTT]
  • UCSI commands - Get PDOs, partner Sink Capabilities [Type-C MUTT]
  • UCSI commands - Get PDOs, partner Source Capabilities [Type-C MUTT]
  • UCSI commands - PPM-Reset [Type-C MUTT]
  • UCSI commands - Set Notification Enable [Type-C MUTT]
  • UCSI commands - Unsupported command [Type-C MUTT]
  • USB Basic Charging
  • USB Basic Charging (One-Port)
  • USB Charging Assessment
  • USB Type-C MUTT Basic Charging Test
  • USB Type-C UCM Data Role Swap
  • USB Type-C UCM Data Role Swap (One-Port)
  • USB Type-C UCM Power Role Swap
  • USB Type-C UCM Power Role Swap (One-Port)
  • USB Type-C UCSI Data Role Swap
  • USB Type-C UCSI Power Role Swap


UCSI Connector One Identification \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ffa4608-b488-494f-a8d5-7aea6a28bcf3

Identifies the physical USB-C connector on the system that corresponds to connector number one in UCSI.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
WaitTimeInMinutes | For tests that require manual intervention, this is the amount of time in minutes the test will wait to see the event that is expected to occur in response to the requested manual action.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Connector Reset command \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/44723264-0d92-46a1-878f-9c21df0d019d

Verifies that the system supports the UCSI Connector Reset command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - Battery Charging Status Change \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/dc0dbe87-3202-4aa4-aa66-3256ca0c4f61

Verifies that the system reports a 'Battery Charging Status Change' notification in response to different types of chargers being connected.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - Error \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/781eacc1-c4bf-49f0-b546-068e22bdcea0

Verifies that the system reports an 'Error' notification in response to an error being detected on a connector.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
WaitTimeInMinutes | For tests that require manual intervention, this is the amount of time in minutes the test will wait to see the event that is expected to occur in response to the requested manual action.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - External Supply Change \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/70b8e509-5bc1-415e-9483-b6e6db6d438d

Verifies that the system reports an 'External Supply Change' notification in response to a charger being connected.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
ExternalSupplyChangeNotification | Set to False if the SUT cannot trigger the External Supply Change notification.
WaitTimeInMinutes | For tests that require manual intervention, this is the amount of time in minutes the test will wait to see the event that is expected to occur in response to the requested manual action.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - Fail connector reset in dead battery condition \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/4fb6549b-f5aa-4c34-be1f-d1ab264a7b60

Verifies that a connector reset performed on a connector that powered up the system from a dead-battery condition fails.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - Negotiated Power Level Change \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a32aaf5a-2277-4894-964e-fd3409719fb0

Verifies that the system reports a 'Negotiated Power Level Change' notification in response to the negotiated Power Delivery contract changing.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
NegotiatedPowerLevelChangeNotification | Set to False if the SUT cannot trigger the Negotiated Power Level Change notification.
WaitTimeInMinutes | For tests that require manual intervention, this is the amount of time in minutes the test will wait to see the event that is expected to occur in response to the requested manual action.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - PD Reset Complete \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/82d9d144-76fa-45c0-8bbc-9b8194d22344

Verifies that the system reports a 'PD Reset Complete' notification in response to receiving a Power Delivery Hard Reset on a connector.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
PDResetCompleteNotification | Set to False if the SUT cannot trigger the PD Reset Complete notification.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - Supported Connector Alternate Modes Change \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d85c0a3d-42b9-450e-a39b-b889d8ea91d4

Verifies that the system reports a 'Supported CAM Change' notification in response to a change in the set of alternate modes supported on a connector.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
SupportedCAMChangeNotification | Set to False if the SUT cannot trigger the Supported CAM Change notification.
WaitTimeInMinutes | For tests that require manual intervention, this is the amount of time in minutes the test will wait to see the event that is expected to occur in response to the requested manual action.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status - Supported Provider Capabilities Change \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c3e032c0-35a8-427c-a8ee-6f23582e19ca

Verifies that the system reports a 'Supported Provider Capabilities Change' notification in response to the power provider's source capabilities changing.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | manual

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
SupportedProviderCapabilitiesChangeNotification | Set to False if the SUT cannot trigger the Supported Provider Capabilities Change notification.
WaitTimeInMinutes | For tests that require manual intervention, this is the amount of time in minutes the test will wait to see the event that is expected to occur in response to the requested manual action.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Get Connector Status command - USB device detection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/51c34e25-cdda-41a7-9abd-e8b67badd9cc

Verifies that the system can detect a USB device.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Power Direction Role command - Accept swap \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8891f20e-6904-4981-a042-493beb87fae2

Verifies that the system accepts power role swaps from the partner when instructed to do so using the UCSI Set Power Direction Role command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Power Direction Role command - No connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7e5fcf7f-ff50-4232-b3b0-fef1c6094a4c

Verifies that the UCSI Set Power Direction Role command fails if a partner is not currently attached.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Power Direction Role command - Reject swap \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/583303dc-f4fc-4731-b743-e9535b19a4f5

Verifies that the system rejects power role swaps from the partner when instructed to do so using the UCSI Set Power Direction Role command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Power Direction Role command - Reset on PPM-Reset \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a448f494-36d3-4105-8488-68619b121424

Verifies that the power role requested using the UCSI Set Power Direction Role command is reset on performing a PPM-Reset.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Power Direction Role command - Reset on disconnect \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a3fe9515-614f-4eab-ada6-a0be74819a00

Verifies that the power role requested using the UCSI Set Power Direction Role command persists only for the duration of the current connection.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI Power Direction Role command \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/ac1a4c15-11f7-4e03-b4eb-c808de54376d

Verifies that the system supports the UCSI Set Power Direction Role command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - DFP to DFP connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/762ca008-b155-4061-91d4-349eddcc103f

Sets the UCSI USB Operation Mode of the system to DFP and the partner to DFP and confirms that a connection cannot be established.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - DFP to UFP connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3ceb366f-3bff-4e66-a21f-fed7876f622b

Sets the UCSI USB Operation Mode of the system to DFP and the partner to UFP and confirms that a connection is established.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - DRP to DFP connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/d72ed492-3102-4469-969f-051ef96a62fb

Sets the UCSI USB Operation Mode of the system to DRP and the partner to DFP and confirms that a connection is established.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - DRP to UFP connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/154a95f2-6118-4fb9-a6b7-feab8402413a

Sets the UCSI USB Operation Mode of the system to DRP and the partner to UFP and confirms that a connection is established.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - PPM-Reset clears DFP Operation Mode \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b767150e-c7ca-4951-9de4-fe9476d5629d

Verifies that performing a UCSI PPM-Reset resets the USB Operation Mode to DRP if it was previously set to DFP.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - PPM-Reset clears UFP Operation Mode \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3fc3ec0e-a282-4abb-a1dd-a81c4890d94a

Verifies that performing a UCSI PPM-Reset resets the USB Operation Mode to DRP if it was previously set to UFP.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - UFP to DFP connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/86002cb6-76ee-41e3-9f72-e94b39920fa8

Sets the UCSI USB Operation Mode of the system to UFP and the partner to DFP and confirms that a connection is established.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Mode command - UFP to UFP connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/69dae8c5-d108-48c7-a60e-f903783a8cfc

Sets the UCSI USB Operation Mode of the system to UFP and the partner to UFP and confirms that a connection cannot be established.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Role command - Accept swap \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/32d6b43a-ea27-459d-9f6c-e0fc51459543

Verifies that the system accepts data role swaps from the partner when instructed to do so using the UCSI Set USB Operation Role command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Role command - No connection \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/28fb956b-a410-4452-93d9-f35682470ca4

Verifies that the UCSI Set USB Operation Role command fails if a partner is not currently attached.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Role command - Reject swap \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9dfe32f1-a8f8-4035-8237-f704f410944b

Verifies that the system rejects data role swaps from the partner when instructed to do so using the UCSI Set USB Operation Role command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Role command - Reset on PPM-Reset \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6ed2a259-0c01-4e91-9281-72cb3c93c3b0

Verifies that the data role requested using the UCSI Set USB Operation Role command is reset on performing a PPM-Reset.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Role command - Reset on disconnect \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/14c75a87-f278-46ae-b7df-cdbea5eaf9ce

Verifies that the data role requested using the UCSI Set USB Operation Role command persists only for the duration of the current connection.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI USB Operation Role command \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/62189419-97f1-4ed4-9b55-921a359b7fbe

Verifies that the system supports the UCSI Set USB Operation Role command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.
UcsiConnectorNumber | UCSI connector that the Type-C MUTT device is connected to.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Alternate Modes, SOP \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f5d6baed-54b5-40a1-b925-ad0f7893a32e

Verifies that the system supports the UCSI Get Alternate Modes command, with 'Recipient' as 'SOP'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Alternate Modes, SOP-DoublePrime \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3e9f96e9-919a-444a-81f5-d2ed2e900bc0

Verifies that the system supports the UCSI Get Alternate Modes command, with 'Recipient' as 'SOP-DoublePrime'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Alternate Modes, SOP-Prime \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a58a05e0-4460-40f7-b1af-a7c47522895b

Verifies that the system supports the UCSI Get Alternate Modes command, with 'Recipient' as 'SOP-Prime'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Alternate Modes, connector \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/c8c08332-c4da-4110-8288-d94f19e1fdd8

Verifies that the system supports the UCSI Get Alternate Modes command, with 'Recipient' as 'Connector'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Cable Property \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7774415d-0e0e-4589-ac87-9d470c0ef9d6

Verifies that the system supports the UCSI Get Cable Property command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Capability \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e8683010-43bb-4c5e-be15-2102fc049e8c

Verifies that the system supports the UCSI Get Capability command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Connector Alternate Modes Supported \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1e1e4acd-db00-4031-80f3-05d546795679

Verifies that the system supports the UCSI Get Connector Alternate Modes Supported command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Connector Capability \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/a41b270d-7a4e-414a-ae5c-7e6342dc0420

Verifies that the system supports the UCSI Get Connector Capability command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Connector Status \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/25e9528f-504f-4657-854a-33831be9ff00

Verifies that the system supports the UCSI Get Connector Status command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Connector Status, Request Data Object \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/1ad8fec4-d9d8-4ca1-b44d-5754767746be

Verifies that the system supports the UCSI Get Connector Status command, for retrieving the Power Delivery Request Data Object.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get Current Connector Alternate Mode \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/096cbfef-0b57-4539-a7fd-4e5cedddd081

Verifies that the system supports the UCSI Get Current Connector Alternate Mode command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get PDOs, Advertised Capabilities \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0ce85bc-3212-4104-8211-9d85fe6fe4bd

Verifies that the system supports the UCSI Get PDOs command, with 'Source Capabilities Type' as 'Advertised Capabilities'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get PDOs, Current Supported Source Capabilities \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5e614b96-4195-4a3c-be16-2804e3a57142

Verifies that the system supports the UCSI Get PDOs command, with 'Source Capabilities Type' as 'Current Supported Source Capabilities'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get PDOs, Maximum Supported Source Capabilities \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e522a621-7377-4f99-8576-f02b67149ae3

Verifies that the system supports the UCSI Get PDOs command, with 'Source Capabilities Type' as 'Maximum Supported Source Capabilities'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get PDOs, Sink Capabilities \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/5239b6a7-11c1-47a0-a8cb-82431217b2cc

Verifies that the system supports the UCSI Get PDOs command, for retrieving the system's Sink Capabilities.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get PDOs, partner Sink Capabilities \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/65041602-b494-4e04-99c1-fa38d6a953a3

Verifies that the system supports the UCSI Get PDOs command, for retrieving the partner's Sink Capabilities.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Get PDOs, partner Source Capabilities \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f06f8b6f-982a-4c6e-87e6-05f7a6044a18

Verifies that the system supports the UCSI Get PDOs command, for retrieving the partner's Source Capabilities.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - PPM-Reset \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/e888a679-034d-41a3-bc30-bf2a9bcabf78

Verifies that the system supports the UCSI PPM-Reset command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Set Notification Enable \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/124b2704-1502-46c8-80de-2950a15ade7b

Verifies that the system supports the UCSI Set Notification Enable command.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


UCSI commands - Unsupported command \Type-C MUTT\

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/95fb0c93-165b-4d42-93e7-425e7f88e45f

Verifies that the system fails a UCSI command that it does not recognize, and sets the 'Not Supported Indicator'.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
  • Windows Server 2016 (x64)
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Compatibility
Timeout (in minutes) | 10
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
WaitTimeMultiplier | For tests that require the Type-C MUTT, this is a multiplier of the generic wait times that the test will wait for the Type-C MUTT to be enumerated. In general, the default times should be sufficient, but some platforms require additional time.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


USB Basic Charging

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7f445d97-75e5-4a47-bbe2-dd191228ef44

This test performs basic validation of USB charging.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCCharging
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

More information

Parameters

Parameter name | Parameter description
Iterations | Number of iterations to perform.


USB Basic Charging (One-Port)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/2f0b012f-18f8-4a65-8c27-929b87de6211

This test performs basic validation of USB charging.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCCharging
Platforms
  • Windows 10, mobile edition (ARM)
  • Windows 10, mobile edition (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

More information

Parameters

Parameter name | Parameter description
xmlFileName | Name of xml file describing test content.


USB Charging Assessment

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6f850c14-ef5a-4a80-9c42-43321b4adef0

This test performs detailed assessment of USB charging.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCCharging
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

More information

Parameters

Parameter name | Parameter description
Iterations | Number of iterations to perform.
ChargerOnPort1 | Type of charger on port 1 (J2) of the USB Connection Exerciser: None, Usb2Pc, Usb3Pc, Dcp, TypeC, TypeCPd, NonCompliant
PdVoltageOnPort1 | PD Voltage expected on port 1 (J2) of the USB Connection Exerciser (If Applicable)
TypeCCurrentOnPort1 | Current supplied by charger on port 1 (J2) of the USB Connection Exerciser (Type-C & PD only)
ChargerOnPort2 | Type of charger on port 2 (J3) of the USB Connection Exerciser: None, Usb2Pc, Usb3Pc, Dcp, TypeC, TypeCPd, NonCompliant
PdVoltageOnPort2 | PD Voltage expected on port 2 (J3) of the USB Connection Exerciser (If Applicable)
TypeCCurrentOnPort2 | Current supplied by charger on port 2 (J3) of the USB Connection Exerciser (Type-C & PD only)
ChargerOnPort3 | Type of charger on port 3 (J6) of the USB Connection Exerciser: None, Usb2Pc, Usb3Pc, Dcp, NonCompliant


USB Type-C MUTT Basic Charging Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37a09471-7919-4324-9a86-4566d1465bfa

This test performs assessment of USB charging using the Type-C MUTT.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCCharging
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

More Information

Parameters

Parameter Name | Parameter Description
MinimumWattageToTest | Minimum charger wattage to emulate during the test.
MaximumWattageToTest | Maximum charger wattage to emulate during the test, max 100 W.
MinimumWattageRequired | Minimum charger wattage at which system can charge normally.
WaitTimeSeconds | Wait time in seconds for charger contract to be complete.

Additional Documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):


USB Type-C UCM Data Role Swap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7532aea0-19fe-4e27-a933-f709fe8ba97b

This test performs a data role swap between two connected USB Type-C dual-role connectors on a system with UCM.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

For information on setting up an environment to run USB Type-C system tests, see the following blog post on MSDN:

  • https://aka.ms/usbctestsetup

More information

Parameters

Parameter name | Parameter description
SwapsToPerform | Number of data role swaps to perform. The minimum is 2.
ValidateUsbFn | If ValidateUsbFn = true, the test will validate function stack behavior


USB Type-C UCM Data Role Swap (One-Port)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/01c94f2d-0370-47c2-a038-be6a97083f5b

This test performs a data role swap between two connected USB Type-C dual-role connectors on a system with UCM.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCM
Platforms
  • Windows 10, mobile edition (ARM64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

For information on setting up an environment to run USB Type-C system tests, see the following blog post on MSDN:

  • https://aka.ms/usbctestsetup

More information

Parameters

Parameter name | Parameter description
xmlFileName | Name of xml file describing test content.


USB Type-C UCM Power Role Swap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/409b09a8-718b-4537-ada2-95c59a1df830

This test performs a power role swap between two connected USB Type-C dual-role connectors on a system with UCM.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCM
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

For information on setting up an environment to run USB Type-C system tests, see the following blog post on MSDN:

  • https://aka.ms/usbctestsetup

More information

Parameters

Parameter name | Parameter description
SwapsToPerform | Number of power role swaps to perform. The minimum is 2.


USB Type-C UCM Power Role Swap (One-Port)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/0f96665d-4b9c-41e9-9c57-f980b260c7f5

This test performs a power role swap between two connected USB Type-C dual-role connectors on a system with UCM.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCM
Platforms
  • Windows 10, mobile edition (ARM64)
  • Windows 10, mobile edition (ARM)
Supported Releases
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 30
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

For information on setting up an environment to run USB Type-C system tests, see the following blog post on MSDN:

  • https://aka.ms/usbctestsetup

More information

Parameters

Parameter name | Parameter description
xmlFileName | Name of xml file describing test content.


USB Type-C UCSI Data Role Swap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/78235e16-41d4-42a5-884a-f9dd08ed34c1

This test performs a data role swap between two connected USB Type-C UCSI dual-role ports.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

For information on setting up an environment to run USB Type-C system tests, see the following blog post on MSDN:

  • https://aka.ms/usbctestsetup

More information

Parameters

Parameter name | Parameter description
SwapsToPerform | Number of data role swaps to perform. The minimum is 2 so that both host and function mode are tested.
ValidateUsbFn | If ValidateUsbFn = true, the test will validate function stack behavior


USB Type-C UCSI Power Role Swap

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/41ce1085-aa0d-4feb-886c-2468c2ebb7d6

This test performs a power role swap between two connected USB Type-C UCSI dual-role ports.

Test details
Specifications
  • System.Fundamentals.SystemUSB.USBC.USBTypeCUCSI.USBTypeCUCSI
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows 10, client editions (ARM64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 3
Category | Development
Timeout (in minutes) | 20
Requires reboot | false
Requires special configuration | true
Type | automatic

Running the test

For information on setting up an environment to run USB Type-C system tests, see the following blog post on MSDN:

  • https://aka.ms/usbctestsetup

More information

Parameters

Parameter name | Parameter description
SwapsToPerform | Number of power role swaps to perform. The minimum is 2 so that both provider and consumer are tested.


System.Server

In this section

  • System.Server tests
  • System.Server additional documentation


System.Server tests

  • Assurance AQ
  • Block Storage SMAPI Test
  • CiB Cluster Evaluation Tests
  • Crashdump Support Test (LOGO)
  • Disk Stress (SYSTEM)
  • File Storage SMAPI Test
  • IPMI
  • IPMIReliability
  • LoadGen Server Stress - Run First - Set Machine Policies
  • LoadGen Server Stress - Run Last - Reset Machine Policies
  • LoadGen Server Stress - Start Test for Fault Tolerant Server
  • LoadGen Server Stress - Start Test for Server
  • NDISTest 6.5 - [1 Machine] - SRIOVBasicVerification
  • NDISTest 6.5 - [1 Machine] - SRIOVVMSwitchStress
  • NDISTest 6.5 - [2 Machine] - IOVVMQBasicVerification
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingDevice
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingFailover
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingOIDs
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingPFRemoval
  • NDISTest 6.5 - [2 Machine] - SRIOVTestingRegistry
  • Redfish Basic Tests
  • Remote Replication SMAPI Test
  • Run Network Switch Device Discovery
  • SecureBootUEFI
  • SecureBootUEFIOverPXE
  • UEFI GOP mode test
  • Verify Device Driver Is WDDM
  • Verify IOMMU presence and configuration
  • Verify processor virtualization support
  • Verify virtualized environment
  • WHEAHCT Logo


Assurance AQ

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/37887a00-ce82-40cd-b54e-d26c4aaaba76

This test verifies the system is capable of running the Assurance scenario. For systems shipped with Assurance AQ the TCG Physical Presence Interface Specification BIOS TPM Management Flags NoPPIClear and NoPPIProvision must be set to TRUE by default. There must be a mechanism in UEFI to confirm the settings of these variables and change them. This requirement is in place to allow for total remote management of TPMs out of the box without additional configuration.

Test details
Specifications
  • System.Server.Assurance.EnhancedPlatformIntegrityProtectionForCloudServices
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1
Category | Compatibility
Timeout (in minutes) | 1
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation


Block Storage SMAPI Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/696f32e7-d3ee-41b2-a1f6-9d6047503f86

This automated test verifies block storage management on a Storage Area Network (SAN) device. It does this by testing Storage Management API (SMAPI) connectivity from the SAN device (iSCSI target) to the HLK client computer (iSCSI initiator) through a storage provider.

Test details
Specifications
  • System.Server.StorageManageability.Smapi.FileStorage.BasicFunction
  • System.Server.StorageManageability.Smapi.BlockStorage.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before running the test, you'll need the following:

  • Hardware
    • A SAN array (and its provider) connected as an iSCSI target with the HLK client computer acting as the iSCSI initiator.
    • Ethernet connectivity between the SAN array/provider and the host (HLK client computer).
  • Software
    • The Windows Standards-Based Storage Management feature. If this package is not installed, the test will automatically install it. The HLK client computer requires internet connectivity for the package to be installed.
    • The Microsoft iSCSI Initiator Service (MSiSCSI). This service comes preinstalled on the Windows operating system. If for any reason this is not installed, install it manually. The test will automatically start the MSiSCSI service if it is not running.

For this test, you must configure a SAN array connected as an iSCSI target to an iSCSI initiator (which is the HLK client computer in this case). The HLK client computer must have the Microsoft iSCSI Initiator Service installed. This service is preinstalled on a Windows operating system. If this service is not running, the test will automatically start the service.

These SAN arrays are not directly connected to host. They connect to the host through a storage provider. A storage provider can provide connectivity to one or more storage arrays.

The test requires a set of parameters to be passed before running the test. These parameters are specific to the SAN array and how it is connected to the host. The following section provides parameter details.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

A value of 0 indicates that the test was successful. A value of 1 indicates that the test failed. The HLK controller will capture this return code, and will show whether the HLK job passed or failed.

Review the test log files saved at TestDestFolder referenced in the parameter list on the HLK client computer, and fix the setup issue that is causing the test to fail.

More information

Parameters

Parameter name | Parameter description
ProviderName | Name of the provider
ProvisioningType | Provisioning Type
Username | Provider User Name
Password | Provider Password
Netname | Provider URI
Port | Port Number
StorageSubsystem | Name of Storage Subsytem
TargetPortalIP | TargetPortal IP Address
StoragePool | Storage Pool
HostName | Host name of windows server
TestDestFolder | Test Destination Folder


CiB Cluster Evaluation Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6fa11e57-ec0a-45d4-921b-d47cf62f6c27

The tests are the first part of the Cluster in A Box (CiB) Continuous Available (CA) validation tests which help validate CiB product meet the CA hardware requirements.

The tests perform the tasks below:

  • Validate hardware for Failover Cluster
  • Create Failover Cluster
  • Setup CA File Server with SMB and NFS shares
  • Setup CA iSCSI Target Server with iSCSI virtual disks
  • Perform basic failover action and IO tests

Test details
Specifications
  • System.Server.Cluster.Core.ClusterInABox
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 90
Category | Scenario
Timeout (in minutes) | 5400
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Hardware requirements

CiB product (up to 64 nodes) and one extra machine as test controller are required to run the test.

The following requirements on CiB nodes must be met:

  • The CiB nodes must meet the hardware requirements for Windows Server 10.
  • The CiB nodes must meet the Failover Clustering hardware requirements for Windows Server 10
  • The CiB nodes must have approximately 100 GB of free space on the local hard drive.

The following requirements on the test controller machine must be met:

  • The test controller must meet the hardware requirements for Windows Server 10.
  • At least 100 GB of free space on the local hard drive.
  • At least 32 GB of memory.
  • We recommend one 10 Gigabit Ethernet adapter.
  • At least two quad core processors.

The following shared storage requirements for CiB nodes must be met:

  • At least 22 shared LUNs (minimal 1GB each, recommend 100 GB or more each).
  • All shared LUNs are visible to all CiB nodes.
  • All shared LUNs have been initialized and formatted as NTFS volumes with appropriate drive letters.

Software requirements

  • All machines must be running Windows Server 10.
  • All machines must be joined to the same domain.
  • All machines must have IP addresses that are provided by DHCP
  • DNS resolution for all machines

LMS Workaround

In order for HLK Controller to schedule the tests on the test machines (CiB nodes and Test Controller), an HLK job needs to be run on all test machines manually via HLK Manager before running the tests. This is a one-time workaround and just need to be done once after HLK client is installed on all machines.

Steps:

Make sure HLK client has been installed on all CiB nodes and Test Controller machine. Machines has been moved to a machine pool for CiB testing and are in Ready status.

  1. Open HLK Manager by pressing the Windows key and typing HLK Manager
  2. Open Job Explorer by going to Menu->Explorers->Job Explorer

  3. Go to $\System\Configuration\, and find the job named Windows Logo Kit- Prepare client for submission

    NOTE

    Press F5 if the job is not showing up

  4. Right click the job and then click Schedule…

  5. Under the Jobs tab, Set the WDKSubmissionId parameter to Client Prepared

    Under the Machines tab, find the machine pool for CiB testing, select all CiB nodes and the Test Controller machine, and then click Create Schedule

  6. Monitor the job running status

    Open Menu->Explorers->Job Monitor. Navigate to the machine pool created for CiB testing

    Wait for the job to complete on all machines.

  7. Open HLK Studio, go to Configuration, and right click the CiB machine pool. Note the Crash Dump Copy Back Setting value (in this example it's been set to Disable).

  8. On each of the machines run below command from an elevated command prompt to set the same Crash Dump setting as noted in step 7 (replace Disable in the command if setting is different).

    WTTCmd.exe /ConfigReg /Add /Value:"WHCK\CrashDumpClientSetting" /Data:"Disable"

To start the tests, follow these steps:

  1. Open HLK Studio
  2. Create a project
  3. Go to the Selection page, and select the Test Controller machine under the systems tab

  4. Right-click the selected target, click Add new features, select System.Server.Cluster.Core, and then click OK

  5. Go to the Tests page, select CiB Cluster Evaluation Tests, and then click Run Selected.

  6. Select all CiB nodes for ClusterNode role.

    Set appropriate parameter values for Domain, UserName, Password and ClusterName.

    NOTE

    ClusterName cannot exceed 9 characters. If running the test multiple times, please use a different value for the cluster name each time

Click **OK** to schedule the test.

![](images/cib-image8.png)

  1. Go to the Results page to check the test status and results.

  2. Create a package file for CiB Cluster Evaluation tests

    Go to the Package page, click Create Package, and then click OK.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

An error similar to Cluster failure: test case ### failure indicates that the cluster has not been properly configured. Make sure that your shared disks are initialized and formatted as NTFS volumes to ensure a cluster can be formed and that no clusters or resource groups exist with the name specified in the cluster parameter.

If failures are found, you can review the logs to get additional details about the failures in HLK Studio under the Results page:

  • CiB Cluster Evaluation Tests->Run Eval Quality tests->Logs->te.wtl

To view the cluster hardware validation reports, right-click the test, and select Additional Files

More information

Parameters

Parameter name | Parameter description
CiBTestBin | test binary location
ReplaceNodeNames.ps1 |
PATHTOXML |
CONFIGFILENAME | Name of the config XML file
Domain | The name of the domain to which the cluster nodes are joined
UserName | The user name of a user in the Domain Admins security group
Password | The password of the user in the Domain Admins security group
ClusterName | The name of the cluster to be created
NodeList |
Reboot-Nodes.ps1 |
Create-ClusterDataGatherer.ps1 |


File Storage SMAPI Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/478fe5ef-5f3d-49cd-a971-b6bdbe03e12c

This automated test verifies file storage management on a Network Attached Storage (NAS) device. It does this by testing Storage Management API (SMAPI) connectivity from the NAS device to the HLK client computer through an SMI-S storage provider.

Test details
Specifications
  • System.Server.StorageManageability.Smapi.FileStorage.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before running the test, you'll need the following:

  • Hardware
    • A Network Attached Storage (NAS) array and its provider.
    • Ethernet connectivity between the NAS array/provider and the host (HLK client computer).
  • Software
    • The Windows Standards-Based Storage Management feature. If this package is not installed, the test will automatically install it. The HLK client computer requires internet connectivity for the package to be installed.

For this test, you must configure a NAS array that has network connectivity to the HLK client computer.

These NAS arrays are not directly connected to a host. They connect to the host through a storage provider. A storage provider can provide connectivity to one of more storage arrays.

The test requires a set of parameters to be passed before running the test. These parameters are specific to the NAS array and how it is connected to the host.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

A value of 0 indicates that the test was successful. A value of 1 indicates that the test failed. The HLK controller will capture this return code, and will show whether the HLK job passed or failed.

Review the test log files saved at TestDestFolder referenced in the parameter list on the HLK client computer, and fix the setup issue that is causing the test to fail.

More information

Parameters

Parameter name | Parameter description
ProviderName | Name of the provider
ProviderType | Type of the provider
ProviderUserName | Provider User Name
ProviderPassword | Provider Password
NetName | Provider URI
Port | Port Number
PoolName | Name of pool
ArrayName | Name of array
OutputCSVFile | Output CSV File name
objectPrefix | Object Prefix
VolumeSize | Volume size in bytes
DomainUserName | Domain User Name
AlternateDomainUserName | Alternate Domain user name
TestDestFolder | Test Destination Folder


IPMI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/402a5324-7e16-428f-9d5d-3e6cf24fb2bd

This automated test validates various features of a baseboard management controller (BMC) with the Intelligent Platform Management Interface (IPMI) protocol.

Test details
Specifications
  • System.Server.AzureStack.BMC.Base
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

The following hardware is required to test IPMI functionality.

  • A server running the HLK controller and a test computer to act as the HLK proxy. Refer to Windows HLK prerequisites for more details.
  • A System under Test (SUT) server. You must configure the server's baseboard management controller (BMC) with IP address settings, and enable the BMC to allow remote management using IPMI.
  • You must connect all computers to the same physical network. Note that the SUT server must have its BMC interface connected to the network.

The following diagram shows how to configure your hardware for IPMI reliability testing.

hardware configuration for ipmi reliability testing

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Error 1: Initialization failed

An error occurred while preparing to run the test.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 2: Error Get

Retrieving BMC information failed more than 5% of the tests.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 4: Error GetLog

Retrieving the BMC log entries failed more than 5% of the tests.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 8: Error Restart

Restarting the remote device failed more than 5% of the tests.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 16: Error SetBootConfiguration

Failed to set one-time boot source.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 32: Error Stop

Failed to shut down the remote server.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 64: Error Start

Failed to start the remote server.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

Error 128: Error Restart

Failed to restart the remote server.

Workaround: Refer to the Test-IPMI.log file to get detailed error information.

More information

Parameters

Parameter name | Parameter description
TargetAddress | Name or IP address of the BMC interface
Username | BMC administrator name
Password | BMC administrator password


IPMIReliability

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9188ae9b-bc2d-439c-b26d-67ffa8b1c7b7

This automated test validates the reliability of the baseboard management controller (BMC).

Test details
Specifications
  • System.Server.AzureStack.BMC.Reliability
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

The following hardware is required to test BMC reliability.

  • A server running the HLK controller and a test computer to act as the HLK proxy. Refer to Windows HLK prerequisites for more details.
  • A System under Test (SUT) server. You must configure the server's baseboard management controller (BMC) with IP address settings, and enable the BMC to allow remote management using IPMI.
  • You must connect all computers to the same physical network. Note that the SUT server must have its BMC interface connected to the network.

The following diagram shows how to configure your hardware for BMC reliability testing.

hardware configuration for bmc reliability testing

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Error 1: Initialization failed

An error occurred while preparing to run the test.

Workaround: Refer to the Test-IPMIReliability.log file to get detailed error information.

Error 2: Error Get

Retrieving BMC information failed more than 5% of the tests.

Workaround: Refer to the Test-IPMIReliability.log file to get detailed error information.

Error 4: Error GetLog

Retrieving the BMC log entries failed more than 5% of the tests.

Workaround: Refer to the Test-IPMIReliability.log file to get detailed error information.

Error 8: Error Restart

Restarting the remote device failed more than 5% of the tests.

Workaround: Refer to the Test-IPMIReliability.log file to get detailed error information.

More information

Parameters

Parameter name | Parameter description
TargetAddress | Name or IP address of the BMC interface
Username | BMC administrator name
Password | BMC administrator password
ExecutionTime | : Number of minutes to run the test (default = 60)


LoadGen Server Stress - Run First - Set Machine Policies

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/318d804e-aa8f-4ffb-8ce2-963cea2f1a40

This automated test sets the machine policies required by the test on the test computers in the machine pool. In addition, the test job configures auto-logon to Local Logical User Domain Admin Local Admin (LLU_DALA) on the master client and then reboots the computer.

WARNING

This test must be run first before running any other server test.

This test initiates the following actions:

  1. RunJob - Set the policies on the system under test (SUT)

  2. Enable AutoLogon on SUT

  3. Setup LLU_DALA on SUT

  4. RunJob - Machine Config on SUT

  5. Reboot SUT

  6. Enable AutoLogon on MC

  7. Setup LLU_DALA on MC

  8. RunJob - Set the policies on MC

  9. RunJob - Machine Config on MC

  10. Reboot MC

  11. Record SCs to dimension on MC

  12. RunJob - Machine Config on SC

  13. Reboot SC

    1. Check if domain name required parameter value is provided

    2. Check if user name required parameter value is provided

    3. Check if password required parameter value is provided

  14. Enable NT Boot Log on SUT

  15. Disable Processor Group Awareness on SUT

Test details
Specifications
  • System.Server.SystemStress.ServerStress
  • System.Server.FaultTolerant.Core
  • System.Server.SVVP.SVVP
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

Create HLK Project with SUT

  1. Open HLK Studio
  2. Navigate to the Project tab and click the Create Project link
  3. Enter a project name and hit Enter
  4. Navigate to the Selection tab
  5. Select the machine pool containing the SUT
  6. Select systems
  7. Select the SUT

Schedule LoadGen Server Stress - Run First - Set Machine Policies

  1. Navigate to the Tests tab
  2. Select LoadGen Server Stress - Run First - Set Machine Policies
  3. Click the Run Selected link
  4. In the Schedule dialog, enter parameters and map machines to roles:
    1. Enter the Domain name, user name, and password of the account that will be used to run test. This account should be a domain account and have administrative privileges on the SUT, MC, and SC.
    2. Use the Role dropdown to select machines for the MC and SC roles (SUT will be prepopulated)
  5. Click OK to schedule the test

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Server Testing.

More information

Parameters

Parameter name | Parameter description
DomainName_LLU | Name of the Domain which test machines joined in
UserName_LLU | Name of Domain user which has admin previledge on all test machines
Password_LLU | Password of the Domain user
StressClients |


LoadGen Server Stress - Run Last - Reset Machine Policies

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8cb4f87c-d2a4-4d90-92a7-edd016ccdeac

This automated test resets the machine policies that are used by the test on the test computers in the machine pool.

NOTE

This test should be run after all other tests are finished.

This test job completes the following actions:

  1. RunJob - ReSet the policies on SUT

  2. Reset AutoLogon on SUT

  3. Reboot SUT

  4. Reset AutoLogon on MC

  5. RunJob - ReSet the policies on MC

  6. Reboot MC

  7. Remove stressclients dimension on MC

Test details
Specifications
  • System.Server.SystemStress.ServerStress
  • System.Server.FaultTolerant.Core
  • System.Server.SVVP.SVVP
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 30
Category | Scenario
Timeout (in minutes) | 1800
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration. This test should be run after all other tests are finished.

  1. Navigate to the Tests tab
  2. Select LoadGen Server Stress - Run Last - Reset Machine Policies
  3. Click the Run Selected link
  4. In the Schedule dialog, map machines to roles
    • Use the Role dropdown to select machines for the MC and SC roles (SUT will be prepopulated)
  5. Click OK to schedule the test

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Server Testing.


LoadGen Server Stress - Start Test for Fault Tolerant Server

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f3f9116b-6722-4e36-9dd5-d621e4be1daa

This automated test measures the stress load on a fault tolerant server. This test does the following:

  1. Copies test files to the Master Client.

  2. Runs the test on the Master Client.

  3. Copies the test logs after the test finishes.

Test details
Specifications
  • System.Server.FaultTolerant.Core
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1440
Category | Scenario
Timeout (in minutes) | 86400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before you run the test:

  1. Verify the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

  2. Run LoadGen Server Stress - Run First - Set Machine Policies first, to setup the correct machine policy settings.

  3. From HLK Studio, select and run the test:

    1. Navigate to the Selection tab
    2. Right-click on the SUT and select Add/Modify Features
    3. In the features dialog, select System.Server.FaultTolerant and click OK
    4. Navigate to the Tests tab
    5. Select LoadGen Server Stress - Start Test for Fault Tolerant Server
    6. Click the Run Selected link
    7. In the Schedule dialog, map machines to roles
      1. Enter the folder path for OEMDLLLocation
      2. Use the Role dropdown to select machine for the MC role (SUT will be prepopulated)
    8. Click OK to schedule the test

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Server Testing.

More information

Parameters

Parameter name | Parameter description
KitTestBinRoot |
FolderToCopy |
KitName |
WDKLogo |
ExtraParams |
KitOSBinRoot |
OEMDLLLocation | Location of the vendor-provided OEMDLL.DLL for MMTest.exe
LLU_NetAccessOnly |


LoadGen Server Stress - Start Test for Server

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e9adb95-fca5-4e15-a255-bc96c0d12aa9

This automated test measures the stress load on a server. This test does the following:

  1. Copies test files to the Master Client.

  2. Runs the test on the Master Client.

  3. Copies the test logs after the test finishes.

Test details
Specifications
  • System.Server.SystemStress.ServerStress
  • System.Server.SVVP.SVVP
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 1440
Category | Scenario
Timeout (in minutes) | 86400
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

LoadGen test can be used to stress a Windows Server. This server could be a physical server or a virtual machine. If physical server has more than 64 logical processors or has more than 1 TB memory, LoadGen should run against the physical server directly. Otherwise, follow the steps below to create a Hyper-V virtual machine as LoadGen stress target.

  • On the SUT, install Hyper-V role
  • Create a Windows Server 2016 virtual machine with the maximum allowed logical processors, memory, network, and storage that the SUT can support
  • This virtual machine needs to join to the test domain and has HLK client installed

Run the following job to prepare the virtual machine:

  1. Open HLK Manager
  2. In the Explorers menu, click Job Monitor
  3. In Job Explorer, press CTRL+Q to open the query pane, and search for jobs where Name Equals LoadGen Config SUT
  4. In the Results pane, note the Job ID for the matching job.
  5. In the Explorers menu, click Job Monitor.
  6. In Job Monitor, navigate to the machine pool that contains the SUT, MC, SCs, and virtual machine, and highlight the virtual machine.
  7. Right-click the machine selection and click Schedule by Job ID.
  8. In the prompt area, enter the Job ID from step 4, and then click OK.
  9. In the Schedule Jobs window, enter the Domain name, user name, and password of the account that will be used to run test. This account should be a domain account and have administrative privileges on the SUT, MC, SC, and virtual machine.
  10. In the toolbar, click Create Schedule.
  11. Wait for the job to run and the selected machine to return to the Ready state

Before you run the test:

  1. Verify the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

  2. Run LoadGen Server Stress - Run First - Set Machine Policies first, to setup the correct machine policy settings.

  3. From Windows Hardware Lab Kit (Windows HLK) Studio, select and run the test:

    1. Navigate to the Tests tab
    2. Select LoadGen Server Stress - Start Test for Server
    3. Click the Run Selected link
    4. In the Schedule dialog, enter parameters, and map machines to roles:
      • If a Hyper-V virtual machine is created, enter the name of virtual machine as StressTarget. Otherwise, use the default value which is [SUT].
      • Use the Role dropdown to select machine for the MC role (SUT will be prepopulated)
    5. Click OK to schedule the test

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Review Server log file (srvlog.xml) for errors. Search for "error" entries. If you receive the following error for Windows Server 2008 R2:

Main::RunMain:: Test Check Spsrv stopped and did not pass required pass percentage (100) (Error=0x80004005)

Close Windows HLK Studio. Change the system under test (SUT) computer name to 14 characters or less. Reboot the SUT. Open Windows HLK Studio and re-run this test.

If you receive the following error for Windows Server 2012 R2:

Main::RunMain:: Test Check Spsrv stopped and did not pass required pass percentage (100) (Error=0x80004005)

Close Windows HLK Studio. Change the SUT computer name to 15 characters or less. Reboot the SUT. Open Windows HLK Studio and re-run this test.

For additional troubleshooting information, see Troubleshooting System Server Testing.

More information

Parameters

Parameter name | Parameter description
KitTestBinRoot |
FolderToCopy |
KitName |
WDKLogo |
ExtraParams |
KitOSBinRoot |
StressTarget | If certify a physical system running Hyper-V, enter the name of the VM running on that physical system. Otherwise, don't change the default value.


Redfish Basic Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/66856ef9-be4b-4aea-9d3b-71a89214c30e

This manual test verifies server hardware out-of-band management capability using the Distributed Management Task Force (DMTF) Redfish standard and Windows PowerShell.

Test details
Specifications
  • System.Server.BMC.Redfish.Basic
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 5
Category | Scenario
Timeout (in minutes) | 300
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

NOTE

The target Redfish server that is going through the certification process must be on the same network as the Windows-based computer where the client-side tests will run.

The tests require two computers:

  • Redfish client - A Windows-based computer selected in HLK Studio. The HLK job runs on this computer after the job is manually scheduled. The HLK job starts a Windows PowerShell process that loads the Pester test framework. The test framework then runs the actual test file, Pester.Redfish.HLK.Tests.ps1.
  • Redfish server - A remote Redfish-compatible device that these tests verify. You must specify the IP address and credential information of this device as parameters when you schedule a test on the Redfish client.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Error: The Execute Task with Commandline cmd /c powershell.exe -c ... Failed with ExitCode N

The task exited with an exit code other than the ExpectedTaskExitCode. This may cause the task to fail if it is set to Fail On Exit Code.

The exit code of the Windows PowerShell process indicates the number of test failures. For a successful test run, ExpectedTaskExitCode is set to 0. A non-zero value (for example, "Failed with ExitCode 3") indicates the corresponding number of failed tests.

Workaround:

  1. Identify what tests failed by using either of the following methods:

    • Review the log file RedfishTestRunLog.xml.
    • Manually run the tests again in a Windows PowerShell console on the Redfish client computer.

  2. Debug the failed tests by using Windows PowerShell ISE on the Redfish client computer.

More information

NOTE

When scheduling these tests, you must always specify values for the RedfishUri, RedfishUserName, and RedfishPassword parameters. The tests will fail if the default values are not replaced.

The TestDestFolder, RedfishMetadataUri, and AdditionalData parameters do not need to be changed for the tests to succeed.

Manually run the tests in a Windows PowerShell console

Note that the test files are located on the Redfish client computer in a folder specified by the [TestDestFolder] parameter. By default, this is [SYSTEMDRIVE]\RedfishLogo.

  1. Ensure that the Redfish.Device.Config.json file (in the folder specified by the [TestDestFolder] parameter) has the correct information about the Redfish server. If this file is missing, run the following Windows PowerShell command to generate the file. In the command, replace the parameter values with what is used by the Redfish server.

    PS C:\Users\Administrator> C:\RedfishLogo\CreateRedfishDeviceConfig.ps1 -RedfishUri 'https://10.20.30.40' -RedfishUserName 'root' -RedfishPassword 'testpass'

  2. Load the Pester Windows PowerShell module. This is a Windows PowerShell-based test harness.

    Import-Module Pester -Force

  3. Run the tests.

    PS C:\Users\Administrator> C:\RedfishLogo\Pester.Redfish.HLK.Tests.ps1

    The failed tests will be highlighted in red.

Debug the failed tests in Windows PowerShell ISE

Note that the test files are located on the Redfish client computer in a folder specified by the [TestDestFolder] parameter. By default, this is [SYSTEMDRIVE]\RedfishLogo.

  1. Start Windows PowerShell ISE from the Start menu.

  2. Ensure that the Redfish.Device.Config.json file has correct information about the Redfish server. If this file is missing, run the following Windows PowerShell command to generate the file. In the command, replace the parameter values with what is used by the Redfish server.

    PS C:\Users\Administrator> C:\RedfishLogo\CreateRedfishDeviceConfig.ps1 -RedfishUri 'https://10.20.30.40' -RedfishUserName 'root' -RedfishPassword 'testpass'

  3. Load the Pester Windows PowerShell module in the Windows PowerShell ISE command window. This is a Windows PowerShell-based test harness.

    Import-Module Pester -Force

  4. In Windows PowerShell ISE, open the test file (press Ctrl + O) [TestDestFolder]\Pester.Redfish.HLK.Tests.ps1.

  5. Find the code for the failing test. Individual tests are marked by the It keyword (for example, It "Verify that service meets Redfish Authentication requirements for different resources.")
  6. Set a breakpoint in the failing test. To do this, put the cursor on the first line of the test, and then press F9 (Toggle Breakpoint).
  7. Press F5 (Run Script) to run the tests. The test run should stop on the breakpoint that you set in the previous step.
  8. Use commands from the Debug menu to step through the code and investigate errors. See How to Debug Scripts in Windows PowerShell ISE on MSDN.

Parameters

Parameter name | Parameter description
TestDestFolder | Folder where test content will be deployed on the client machine.
RedfishUri | Uri of Redfish service
RedfishMetadataUri | Uri of Redfish service metadata
RedfishUserName | User that has access to Redfish service
RedfishPassword | Password of user that has access to Redfish service
AdditionaData | Any additional data that needs to be passed to tests


Remote Replication SMAPI Test

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/9090e2e9-5f60-48ca-a2a3-77a4f2ffcb7c

This automated test verifies remote replication between Storage Area Network (SAN) arrays.

Test details
Specifications
  • System.Server.StorageManageability.Smapi.BlockStorage.RemoteReplication.BasicFunction
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before running the test, you'll need the following:

  • Hardware
    • SAN arrays that support the SAN replication feature. One array acts as the primary site array, and the other as the recovery site array. The arrays can be managed by a single provider, or by two providers.
    • Ethernet or Fibre Channel connectivity between the SAN arrays/providers and the host (HLK client computer).
  • Software
    • The Windows Standards-Based Storage Management feature. If this package is not installed, the test will automatically install it. The HLK client computer requires internet connectivity for the package to be installed.

For this test, you must configure SAN arrays that have network connectivity to the HLK client computer.

These SAN arrays are not directly connected to the host. They connect to the host through a storage provider. A storage provider can provide connectivity to one or more arrays.

The SAN arrays should have the SAN remote replication feature capability. Ideally, there should be one array that performs the primary site role, and another array that performs the recovery site role.

There are two possible setup configurations for remote replication:

  1. The primary and recovery site arrays are managed by a single storage provider.
  2. The primary and recovery site arrays are managed by two storage providers, with each array connected to its primary site provider or recovery site provider.

This test requires a set of parameters to be passed before running the test. These parameters are specific to the SAN array and how it is connected to the host. As mentioned, there are two possible setup configurations. Provide the test parameters accordingly. The following section provides parameter details.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

A value of 0 indicates that the test was successful. A value of 1 indicates that the test failed. The HLK controller will capture this return code, and will show whether the HLK job passed or failed.

Review the test log files saved at TestDestFolder referenced in the parameter list on the HLK client computer, and fix the setup issue that is causing the test to fail.

More information

Parameters

Parameter name | Parameter description
PrimaryProviderName | Primary provider name
PrimaryProviderURI | Primary Provider URI
PrimaryProviderUsername | Primary Provider username
PrimaryProviderPassword | Primary Provider Password
PrimaryArrayName | Primary Array Name
PrimaryPoolName | Primary Pool Name
PrimaryRGPrefix | Primary RG Prefix
PrimaryLUNPrefix | Primary LUN Prefix
RecoveryProviderName | Recovery Provider Name
RecoveryProviderURI | Recovery Provider URI
RecoveryProviderUsername | Recovery Provider Username
RecoveryProviderPassword | Recovery Provider Password
RecoveryArrayName | Recovery Array Name
RecoveryPoolName | Recovery Pool Name
RecoveryRGPrefix | Recovery RG Prefix
RecoveryLUNPrefix | Recovery LUN Prefix
TestDestFolder | Test Destination Folder
Manufacturer | Manufacturer name


Run Network Switch Device Discovery

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/33a3be21-b5e7-4b3a-952c-dfcbcde54147

Test details
Specifications
  • System.Server.NetworkSwitch.NetworkSwitchDiscovery
Platforms
  • Windows 10, client editions (x86)
  • Windows 10, client editions (x64)
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Scenario
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

More information

Parameters

Parameter name | Parameter description
LLU_LclAdminUser | LLU for Execute
LLU_NetAccessOnly | LLU for Copy
SwitchManagementIPAddresses | A Comma Seperated List of Management IP Addresses of Network Switches in the Topology
HostNames | A Comma Seperated List of Host Names that are participating in the Topology
HostUserName | The UserName to Access the Host Machines
HostPassword | The Password to connect to the Host Machines
SwitchUserName | The UserName to Access the Network Switches
SwitchPassword | The Password to connect to the Network Switches


SecureBootUEFI

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/908e4447-31e4-49c7-a6a8-486558006d0e

This automated test validates whether a test computer was booted in Secure Boot mode.

Test details
Specifications
  • System.Server.AzureStack.Security.SecureBootUEFIOverPXE
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

The test computer's BIOS settings must be configured as follows:

  • Boot mode: UEFI
  • Secure Boot: Enabled

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

Error 1: UEFI is enabled, but Secure Boot is disabled

Secure Boot is not enabled in the BIOS settings, or is not supported.

Workaround: Configure the BIOS settings to enable Secure Boot.

Error 2: UEFI is disabled

The system is configured to boot in Legacy BIOS mode.

Workaround: Configure the BIOS settings to set the boot mode to UEFI.


SecureBootUEFIOverPXE

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b0ea1e01-f036-4a87-9b8d-bae338e56086

This manual test validates whether a test computer is capable of booting from the network in Secure Boot mode.

Test details
Specifications
  • System.Server.AzureStack.Security.SecureBootUEFIOverPXE
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Hardware requirements

The following hardware is required for testing Secure Boot over PXE:

  • A server that is running HLK controller and a test computer to act as the HLK proxy. Refer to Windows HLK prerequisites for more details.

  • A System under Test (SUT) server that meets the following requirements.

    • You must configure the server according to the SecureBootUEFI test, and the server must pass the test.
    • The server must have a network adapter installed that is capable of PXE boot.
    • You must configure the server's BIOS settings to allow boot from the network using the network adapter.

  • One or two servers on the network to run DHCP and Windows Deployment Services (WDS).

  • You must connect all computers to the same physical network.

The following diagram shows how to configure your hardware for Secure Boot over PXE testing.

hardware configuration for secure boot over pxe

Software requirements

The following software is required for testing Secure Boot over PXE.

  • The latest version of Windows HLK.
  • Windows Server 2016 installation media or ISO file.

Test execution

  1. Ensure that DHCP server is running on the DHCP-WDS server (or a separate DHCP server) and has an active DHCP scope for the network with available IP addresses.
  2. Ensure that Windows Deployment Services (WDS) is installed on the DHCP-WDS server (or a separate WDS server).

  3. On the WDS server, do the following:

    1. Open the Windows Deployment Services console. Expand Servers > Server Name. Right-click Boot Images, and then click Add Boot Image.
    2. In the Add Image Wizard, browse to the location of the Windows Server installation media in X:\sources\boot.wim, where X is the drive letter of the DVD or mounted ISO image. Accept all default values.
    3. Right-click the WDS server, and then click Properties.
    4. On the PXE Response tab, click Respond to all client computers (known and unknown).
    5. On the Boot tab, click Always continue PXE boot under both Known clients and Unknown clients.
    6. On the DHCP tab, if the DHCP server is installed on the same computer, select both check boxes.

  4. Restart the System under Test (SUT) computer and force it to boot from PXE. Typically, you can press F12 during the POST stage of server boot. However, this may differ depending on the hardware manufacturer.

  5. Monitor the progress on the client computer. A successful boot should display a Windows Setup screen with a Windows Deployment Services message.

    windows setup screen showing a windows deployment services message, indicating a successful boot

  6. Press Shift+F10 to display the command prompt, and then type the following command:

    reg query HKLM\System\CurrentControlSet\Control\SecureBoot\State

    The registry value UEFISecureBootEnabled will be displayed. The expected value data is 0x1.

  7. When you get the positive test results, you can run the HLK test against the HLK proxy (HLK client) test computer. You will be prompted to manually confirm that the test completed successfully.

More information

Parameters

Parameter name | Parameter description
HasVerified | Enter YES if you have verified the scenario


Verify IOMMU presence and configuration

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3b880cc8-516d-4ab4-9d7f-88b558bf4420

This test does the following validation:

  1. Ensures that at least one IOMMU device is present on the system
  2. Performs basic validation of the IOMMU ACPI tables (DMAR/IVRS) looking for simple inconsistencies and/or divergence from the IOMMU specs
  3. Performs basic validation to ensure that there are no inconsistencies in how IOMMUs are reported in the MADT table vs. in the DMAR/IVRS tables

Test details
Specifications
  • System.Server.Virtualization.ProcessorVirtualizationAssist
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Server Testing.

More information

Parameters

Parameter name | Parameter description
BinPath | Path to detectvp directory.


Verify processor virtualization support

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f89a7089-85a5-4d32-94f8-60765f266351

This test does the following validation:

  1. All processors in the system support one of the below virtualization hardware assist technologies:
    • Intel VT technology
    • AMD-V technology
  2. All processors in the system support one of the below SLAT technologies:
    • Intel EPT
    • AMD NPT

Test details
Specifications
  • System.Server.Virtualization.ProcessorVirtualizationAssist
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For troubleshooting information, see Troubleshooting System Server Testing.

More information

Parameters

Parameter name | Parameter description
BinPath | Path to detectvp directory.


Verify virtualized environment

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/306abec2-7be3-4acb-8a00-88bdb770a693

This automated test verifies that Windows is running in a virtual environment.

Test details
Specifications
  • System.Server.SVVP.SVVP
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 2
Category | Compatibility
Timeout (in minutes) | 120
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Server additional documentation

Running the test

Before you run the test, complete the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

Troubleshooting

For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

For general server troubleshooting information, see Troubleshooting System Server Testing.

More information

Parameters

Parameter name | Parameter description
BinPath | Path to detectvm.


WHEAHCT Logo

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/3bdbdbc2-7165-445f-82f5-c413cb480e77

This automated test determines whether a server platform delivers the minimum set of resources that are required to enable Windows Hardware Error Architecture Hardware Compliance Test (WHEAHCT). It is a tool provided by the WHEA feature team to certify OEMs or ODMs platform support for WHEA, a Windows Reliability Availability and Serviceability feature.

This test can run on x64- and Itanium-based platforms running firmware compliant with the Windows Hardware Error Architecture Platform Design Guide. The system must be running a version of Windows Server 2008 R2 or later version of the Windows Server operating system. On IA64, a PSHED plug-in test driver (plugin.sys), which is supplied with the test tool, must be installed on the system. The driver is needed to inject machine check errors into the system.

NOTE

The test injects a fatal error from the platform to the operating system. The operating system reacts to this fatal hardware error as if it is a real error. Because fatal hardware errors result in blue screen errors with Stop code 0x00000124, the fatal error part of the test will produce a system crash and result in a blue screen and reboot. If configured correctly, see the note below.

NOTE

Automatic reboot after a system crash is a configurable behavior of the operating system. For correct execution of the test, the operating system must be configured to perform either a kernel dump or a minidump and reboot automatically. You can confirm these settings using the Control Panel System and Security System Advanced system settings Startup and recovery.

Test details
Specifications
  • System.Server.WHEA.Core
Platforms
    Supported Releases
    Expected run time (in minutes) | 30
    Category
    Timeout (in minutes) | 1800
    Requires reboot | false
    Requires special configuration | false
    Type | automatic

    Additional documentation

    Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

    • System.Server additional documentation

    Running the test

    Before you run the test, complete the test setup as described in the test requirements: System Server Testing Prerequisites and Test Server Configuration.

    Troubleshooting

    For generic troubleshooting of HLK test failures, see Troubleshooting Windows HLK Test Failures.

    For troubleshooting information, see Troubleshooting System Server Testing.

    More information

    Parameters

    Parameter name | Parameter description
LLU_NetAccessOnly |
SourcePath |
LLU_LclAdmin.DomUsr |


System.Server additional documentation

In this section

  • Server Testing Overview
  • Windows Server testing using WLK 1.6, HLK 2.0, and HLK 2.1
  • System Server Testing Prerequisites
  • Test Server Configuration
  • LoadGen SC LMS Workaround
  • Troubleshooting System Server Testing


Server Testing Overview

Windows Server testing is primarily stress-oriented testing that include client/server I/O, network stress, CPU consumption, and memory consumption. The specific tests you must run depends on the features that you implement on the server.

This section only describes System.Server tests. A complete Windows Server Certification requires several tests that are comprised of System.Client, System.Fundamentals and System.Server tests. Windows Hardware Lab Kit (Windows HLK) Studio detects all features on a server.

General server stress testing

Several kinds of stress tests get run against a server, including basic system functionality, system stress and shutdown/restart tests. LoadGen is a test tool that generates load on a system under test (SUT). LoadGen is started on the master client and can use multiple stress client computers to generate network load on the SUT.

System functionality tests

The system functionality tests are individual tests of the capabilities of the system. Some tests are run for every system, and some tests only run if the capability exists in the system.

System stress test

The System Stress Test consists of several server scenario workloads that operate from the user level address space that is applied to the system to exercise the system hardware, system-specific devices and drivers, network and storage adapters and drivers, and any filter drivers that might be part of the system configuration, such as multipath storage drivers, storage or file system filter drivers, or intermediate layer network drivers.

The workloads applied are

  • SQL I/O Simulation

  • Local Storage I/O

  • Disk Stress with Verification

  • Client-Server Storage I/O

  • Winsock Network Traffic

These workloads automatically scale to the number of network and storage adapters in the system that have connected clients or storage devices, respectively. For example, if the test discovers one network adapter and one storage adapter (together with the necessary connected clients or storage devices, respectively), the test creates workload processes for that number of adapters to provide the stress workload. If the system has multiple network and storage adapters, test processes are created for each of those adapters, drivers, and connected resources (clients or storage devices) to provide the same relative stress workload. Additionally, the network and storage adapters and their respective resources do not need to be the same type. For example, Gigabit Ethernet and 10 Gigabit Ethernet adapters can be tested at the same time, as long as network clients are connected to both devices. Similarly, Fibre Channel and iSCSI storage adapters can be tested at the same time, as long as the appropriate storage media is attached. Any HBA units that are attached to the SUT must be connected to the appropriate type of storage media.

The system test achieves the same relative amount of stress on the system, regardless of the number or type of processors, amount of memory, or the number of network and storage adapters in the system. The test detects the number of processors/cores in the system, as well as the amount of memory in the system. The test then creates as many processor-specific and memory-specific stress processes as are needed to achieve a predetermined level of processor and memory utilization and will terminate those processes if the utilization level exceeds the predetermined level of stress. Therefore, the level of utilization for those resources is always commensurate with the capabilities of the system. A system that supports only a few processors/cores and an appropriate amount of memory for the system has the same relative levels of stress as a larger system with more processors/cores and a greater amount of memory.

Shutdown/Restart Test

The server test also includes a shutdown and restart test. This test signals the system to shut down and restart. The test records the event log information related to shutting down and restarting the system, such as vetoes that prevent shutdown, the startup event, and any driver errors that are received after restarting the system. This test makes sure that all device drivers in the system comply with system shutdown, do not veto, and cleanly restart in the system without conflicting with other drivers. For more information, see I/O Completion Cancellation Guidelines.

There are 3 specific tests:

  • LoadGen Server Stress - Run First - Set Machine Policies (run time < 30 minutes)

  • LoadGen Server Stress - Run First - Start Test for Server (run time = 24 hours)

  • LoadGen Server Stress - Run Last - Reset Machine Policies (run time < 30 minutes)

You must schedule the LoadGen Server Stress - Run First - Set Machine Policies" job before you run the "LoadGen Server Stress - Start Test for Server" job. You must schedule the "LoadGen Server Stress - Run Last - Reset Machine Policies" job after the Start Test for Server job has finished.You must schedule the Run First and Run Last jobs only one time for each submission, but you must schedule and run the Start Test job multiple times until it passes. You must also schedule the Run Last - Reset Machine Policies job if you are going to schedule other different jobs in the same machine pool.

Server virtualization validation program (SVVP) testing

Two kinds of virtualization tests are run against a server, including virtual machine functionality tests and SVVP System functionality tests. The system can be a standalone server or a virtual machine. LoadGen is started on the master client and can use multiple stress client computers to generate network load on the system under test.

Virtual machine functionality tests

The functionality tests are individual tests of the capabilities of the product's virtual machine implementation.

SVVP System functionality tests

The SVVP System functionality tests validate the functionality of the following aspects and components of the virtual machine:

  • Virtual PCI I/O

  • Virtual SMBIOS

  • Virtual Timers

  • Virtual ACPI and PNP functions

  • The correct operation of the storage capabilities of the virtual machine

  • The appropriate signing by Microsoft of all the drivers included

  • Virtualization products correctly expose to the instance of the running operating system, the fact that the operating system is running in a virtual environment.

Additional features testing

Server systems might have additional functionality beyond that which is required for Windows Server Certification. The additional features for which a system can test and qualify are as follows:

These additional feature tests are in the Windows HLK test harness together with the tests that are listed for systems. Vendors whose systems can meet the requirements for these additional features must select and run the required tests. The Fault Tolerant tests exercise and confirm the ability of a fault-tolerant system hardware, devices, and drivers to have a hardware failure and continue to operate without impacting clients that are connected to the server over on the network. The Enhanced Power Management tests validate that the systems supports the CPUID feature flag, processor p-states, and other functionality needed for Windows Serverto manage the power of the system.

For more information, see the "Power Supply, Metering, and Budgeting Interface" section in the ACPI 4.0 or later specification and "Processor Power Management in Windows Vista and Windows Server.

Note that a system can support none, some or all of the above features, such as both enhanced power management. For a vendor to validate that the system meets the requirements for one or more additional features, one or more of the additional feature tests must be selected and run. Those results are then submitted together with the results of the Server Certification tests. The additional feature test results cannot be submitted separately from Server Certification test results.

Run time for these additional feature tests varies, depending on the selected tests. If the Server Certification test is selected only, testing takes approximately two days, with the Loadgen test taking one day to run and the remaining tests using the remaining time.Additionally, if the system being tested includes audio, video or other devices and drivers, those will be exercised and increase test time.

Minimum required server test

The following is a minimum list of tests that you must run on all servers. For minimum test listed under System.Client or System.Fundamentals, you must review the appropriate prerequisite section for each test.

Required Server Test | Test Category
ACPI Logo Test | System.Fundamentals
Boot Test (SYSTEM) | System.Fundamentals
Debug Capability Test (Logo) | System.Fundamentals
Disk Stress (SYSTEM) | System.Server
Hal timer tests (HCT) | System.Fundamentals
NX Test | System.Fundamentals
PCI Hardware Compliance Test For Systems | System.Fundamentals
Secure Boot Logo Test | System.Fundamentals
Secure Boot Manual Logo Test | System.Fundamentals
Signed Driver Check (CheckLogo) | System.Fundamentals
SMBIOS HCT | System.Fundamentals
System - PNP (disable and enable) with IO Before and After (Certification) | System.Fundamentals
System - Sleep and PNP (disable and enable) with IO Before and After (Certification) | System.Fundamentals
System - Sleep with IO Before and After (Certification) | System.Fundamentals
USB Boot test (SYSTEM) | System.Fundamentals
USB Exposed Port System Test | System.Fundamentals
USB xHCI Register System test | System.Fundamentals
USB3 Termination | System.Fundamentals
Verify virtualized environment | System.Server
Verify processor virtualization support | System.Server
WHEAHCT Logo | System.Server
Win8 LoadGen Server Stress - Run First - Set Machine Policies | System.Server
Win8 LoadGen Server Stress - Run Last - Reset Machine Policies | System.Server
Win8 LoadGen Server Stress - Start Test for Server | System.Server

Related topics

System.Server Testing


Windows Server testing using WLK 1.6, HLK 2.0, and HLK 2.1

The following information defines which certification kit (WLK 1.6, HLK 2.0, HLK 2.1) are applicable to Windows Server 2012 R2 and earlier.

IMPORTANT

Please forward to those in your organization who could benefit from this information, particularly your certification and/or test teams.

Windows Server certification using WLK 1.6, HLK 2.0, and HLK 2.1 Definition

WLK 1.6 was released in conjunction with Windows 7 and Windows 2008. This kit supports:

  • Windows Server 2008 R2 x64 Device, Driver and System Certification

  • Windows Server 2008 R2 ia64 Device and Driver Certification

  • Windows Server 2008 x86, x64 and ia64 Device and Driver Certification

  • Windows Server 2003 x86, x64 and ia64 Device and Driver Certification

HLK 2.0 was released in conjunction with Windows 8 and Windows Server 2012. This kit supports:

  • Windows Server 2012 x64 Device, Driver and System Certification

  • Windows Server 2008 R2 x64 Device, Driver and System Certification

  • Windows Server 2008 x86 and x64 Driver Signature only, no Logo

  • Windows Server 2003 x86 and x64 Driver Signature only, no Logo

HLK 2.1 was released in conjunction with Windows 8.1 and Windows Server 2012 R2. This kit supports:

  • Windows Server 2012 R2 x64 Device, Driver and System Certification

  • Windows Server 2012 x64 Device and Driver Certification

  • Windows Server 2008 R2 x64 Device, Driver and System Certification

Newer versions of the certification kit will also be released alongside future Windows and Windows Server operating system releases.

Approximately 90 days after the release of Windows 8.1 and Windows Server 2012 R2, the current HLK 2.0 will be retired and no further submissions will be accepted using that kit. To test Windows Server OS releases spanning from 2003 to 2012 R2, you must use both the WLK 1.6 and the HLK 2.1.

The use of WLK 1.6 and HLK 2.1 is necessary because:

  • Prior to Windows Server 2012 R2, HLK 2.0 could be used to obtain driver signatures for Windows Server 2008 and 2003. However, device and driver vendors were requested to also use WLK 1.6 for testing of those drivers prior to submission for signature. It was never Microsoft's intent to offer signature for drivers that were not tested adequately as this is not in the best interest of our mutual customers.

  • HLK 2.1 for Windows 8.1/2012 R2 will not provide driver signatures for Windows Server 2008 and Windows Server 2003 as driver testing is now required (not just encouraged) due to experience with Server drivers that were only signed and not adequately tested.

  • The infrastructure to support testing and submission for Windows Server 2008 (including x86 and IA64) remains in WLK 1.6 and the submission portal, as is the case today.

In addition, WLK 1.6 will remain available until further notice to support:

  • Windows Server 2003 and 2008 device driver submissions for all processor architectures (x86,x64, Itanium).

  • Windows Server 2008 R2 device driver submissions for Itanium processor architecture.

  • SysDev (Hardware Dashboard) will continue to accept these WLK 1.6 submissions until further notice.

The following table summarizes kit support for Windows Server certification:

certification kit support matrix

"Up-Level" and "Down-Level" Certification Status Grant

Unless called out specifically, certification is required for all devices and drivers to obtain separately the logo for Windows Server 2012 R2, Windows Server 2012, Windows Server 2008 R2 and Windows Server 2008.

"up-level" and "down-level" certification status g

Systems and selected Device types specified above that are successfully certified against Windows Server 2012 R2 will earn "Down-Level" certification status for Windows Server 2012.

Imaging device types specified above that are successfully certified against Windows Server 2012 will be granted "Up-Level" certification status for Windows Server 2012 R2.

Contact

For further inquiries, please contact AskWSHC@microsoft.com.


System Server Testing Prerequisites

This section describes the tasks that you must complete before you test a device by using the Windows Hardware Lab Kit (Windows HLK):

Hardware requirements

The following hardware is required for Windows Server System testing. Additional hardware may be required if the test device provides bus-specific support. See the test description for each bus-specific test to determine if there are additional hardware requirements.

Component | Requirement
Processor | Server System Certification testing requires that the Server Under Test be populated w/ the maximum number of processors the system supports.
Memory | Server System Certification testing requires that the Server Under Test be populated w/ the maximum amount of memory the system supports for the fastest clock speed supported by the system.
Disk space | Minimum: 10 GB Recommended: 40 GB or greater Note Computers with more than 16 GB of RAM will require more disk space for paging, hibernation, and dump files
Drive | DVD-ROM drive

Infrastructure Requirement and Setup for the Server Stress Test

The Server Stress test requires all test machines to be in a network with a domain controller. The machines themselves must be joined to that domain and have a domain user account created. The reliability of the network is critical to the stress test, if your network is not reliable or setup improperly, the test will either fail or won't start. Make sure the test environment is on a stable and reliable network. Use dynamic IP addressing for all machines. All systems used in testing, such as DHCP, DNS, or Active Directory Domain Controller, must be the latest version and service pack of the operating system.

Server System under Test (SUT) Requirements

  • Physical machine (see previous table)

  • Maximum number of processors that the SUT supports.

  • The maximum memory capacity that the SUT supports.

  • At least one Gigabit network adapter, or additional network adapters, being used for testing.

  • One hard disk drive to be used for installing the operating system. This hard disk drive should have two partitions. Partition 1 should have at least 1.5 GB, and less than 5 GB, of space that is configured as Active, System. Partition 2 should have at least 40 GB of space (or the Windows Server minimum requirement) that is configured as Boot, Page File, Crash Dump.

  • One Gigabit Ethernet network hub.

  • SUT computer name must be 154 characters or less.

Client System Requirements

The system failure of even a single client will cause the entire test to fail. To minimize the likelihood of client system failures, use the following criteria to help you choose computers and other hardware for this test:

  • Make sure that your computers have resources that exceed the minimum CPU and RAM requirements for the version of Windows Server that is being tested on the SUT and installed on the stress client systems.

  • Make sure that all NICs and device drivers have already been Certified for the Windows Server that is being tested. The bandwidth of the NICs in the client computers must be equal to the bandwidth of the NIC in the SUT.

  • Plug all client computers into UPS power protection units.

  • Connect all client computers with high quality cabling, routers, and switches.

  • Use highly redundant storage and memory components: For example, ECC or better memory protection, MPIO Duplexing for storage, RAID hard disks, Teaming for NICs etc.

Software requirements

The following software is required to run the Windows Server System tests:

  • Use Windows Server Datacenter to enable all the processors and exercise all possible features in the system being tested (SUT). This applies for Certification testing or for any possible additional feature tests such as those for Fault Tolerance or Enhanced Power Management.

  • Use the Windows Server that is being tested for the master client and the stress client systems

  • Any drivers that are not shipped with Windows Server.

  • The optional Windows Server BitLocker Drive Encryption component must be installed on the server if it is supported by the vendor pre-installed.

WARNING

The System Tests topic provides more information about the system requirements for the BitLocker Drive Encryption tests.

Tester knowledge requirements

To run the Windows Server System tests, you must know how to perform the following tasks:

  • Create, format, and remove partitions on a hard disk drive.

  • Set power management options.

  • Install and configure a network.

  • Install the operating system from the product DVD.

  • Download a service pack for an operating system.

  • Install the Active Directory Domain Services Role.

  • Create a domain.

  • Set up the systems to be used in testing at the BIOS/FW/UEFI level.

Test server configuration

To certify your product for use on servers, the test computer must support four processors and a minimum of 1 GB of RAM. These system capabilities are required to test the Rebalance, D3 State, and Multiple Processor Group functionality of the device and driver. You do not need a computer that actually has more than 64 processors to test your device. Additionally, the server system(s) being used for device or driver testing must have Server Core installed prior to testing. For more information see Windows Server Installation Options.

If you use a pool of test computers to test devices, at least one computer in the pool must contain four processors and a minimum of 1 GB of RAM. Additionally, that computer must contain the device and the driver that you want to test. As long as the driver is the same on all the computers in the pool, the system creates a schedule to run against all test computers.

For tests that do not include a driver to test, such as hard disk drive tests, the Windows HLK scheduler constrains the tests that validate the device's and driver's Rebalance, D3 State and Multiple Processor Groups functionality to run on the default test computer. You must manually configure this computer to have multiple processor groups. The default computer is the first test computer in the list. Test personnel must make sure that the first test computer in the list meets the minimum hardware requirements.

Except for para-virtualization drivers (as defined by the WHCP Policies and Processes document), you may not use any form of virtualization when you test physical devices and their associated drivers for server certification or signature. All virtualization products do not support the underlying functionality that is required to pass the tests that relate to multiple processor groups, device power management, device PCI functionality, and other tests.

NOTE

Multiple Processor Groups Setting You must set the value for the processor group size for Hardware Lab Kit testing of Windows Server 2008 R2 and later device drivers for certification. This is done by running bcdedit in an elevated command prompt window, using the /set option.

The commands for adding the group settings and restarting are as follows:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

The commands for removing the group settings and rebooting are as follows:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f
NOTE

Code Integrity Setting

The Virtualization Based Security feature (VBS) of Windows Server 2016 must be enabled using Server Manager first.

Once that has occurred, the following Registry key must be created and set:

HKLM\System\CurrentControlSet\Control\DeviceGuard
HypervisorEnforcedCodeIntegrity:REG_DWORD
0 or 1 (disabled, enabled)


Test Server Configuration

Test system configuration

This article assumes that you have already setup the network domain controller and installed the Windows HLK controller and Windows HLK Studio on a machine, and that the Windows HLK controller and Windows HLK Studio are on the network.

The Server test requires the following system configuration tasks to prepare the test system for server testing. The machines setup for the Server Stress test consists of:

  • One server under test" (SUT). This is the computer that you are certifying.

    WARNING

    The SUT computer name must be 15 characters or less.

  • One x64 client machine that will act as the Remote Test Host (MC). The master client system must be listed in the Windows Server Catalog. Please note the following restrictions for the MC, Stress Client (SC), and SUT:

    • An MC, SC or SUT cannot be a domain controller for the test systems.

    • An MC, SC or SUT cannot host HLK Studio.

    • An MC, SC or SUT cannot be the HLK Controller for the systems that are used for testing.

  • Eight (8) x64 client machines that act as the SC systems. LoadGen supports up to 64 SC machines, but eight is usually sufficient.

  • Do not use "MC" or "SC" or "SUT" or any derivatives in the machine names, as this will cause the test to fail.

IMPORTANT

Because some systems might be set to shipping configuration, they might not have all their devices enabled or their drivers loaded. Before testing, make sure that all devices in the system are enabled and that all drivers related to those devices are loaded per the testing requirements.

Storage and Operating System Installation

  1. All machines are connected to the network via gigabit or faster HUB or switch with high speed CAT6 or faster cables.

  2. Install Datacenter SKU operating system on the SUT.

  3. Install Standard Server SKU operating system on the MC and SC's.

  4. All machines have NTFS format on all disks.

  5. Format the hard disk drive to have at least one partition with 20 GB of free disk space after the operating system has been installed. This disk should be configured as Boot, Page File, Crash Dump.

  6. Install the optional BitLocker Drive Encryption component on the server if it is supported pre-installed by the OEM.

Systems Settings for SUT, MC and SCs

  1. Join each machine to the same Domain using the domain user account you created and use dynamic IP addressing.

  2. Logon to each machine using the created domain user account.

  3. Use the following procedure to configure the power options on the SUT master client and the SC Clients:

    1. Open Control Panel and click Power Options.

    2. Click the Change plan settings link next to the active plan.

    3. Click the Change advanced power settings link on the next page to open the Power Options dialog.

    4. Expand Hard disk tree and change Turn off hard disk after setting to "Never" (0 minutes).

    5. Expand Display tree and change Turn off display after setting to "Never" (0 minutes).

    6. From the Turn off monitor list, select Never.

    7. From the Turn off hard disks list, select Never (0).

    8. If there is a System standby list, select Never.

    9. If there is a System hibernates list, select Never.

    10. If there is a Hibernation tab, clear the Enable hibernation check box.

  4. Each machine (MC, SC, SUT) will need at least one gigabit Network Interface Card (NIC) to connect to the network. If a machine has more than one NIC, make sure they are also connected to the HUB.

  5. IPv4 and IPv6 must both be enabled on the system being tested, the master client, and all clients connected to the system.

WARNING

A network interface adapter that is not connected to a network generates an error, causing the test to fail. Note that network adapters that are used for iSCSI connectivity to storage do not need to be connected to client systems.

Begin server testing

  1. Setup an HLK environment as described in the Windows HLK Getting Started.

  2. In Step 2: Install HLK Client on Test Computer(s), add each computer (MC, SC, and SUT) to your HLK environment.

  3. In Step 6: Select & Run Tests, run LoadGen Server Stress - Run First - Set Machine Policies Test.

    IMPORTANT

    You must run this test to set the correct machine policy settings on all devices.

  4. When Step 3 completes, select and run other tests as appropriate.

  5. When all tests pass, run LoadGen Server Stress - Run Last - Reset Machine Policies Test to reset the machines.

Related topics

System.Server Testing


LoadGen SC LMS Workaround

Due to a limitation in the HLK scheduling engine, the following steps must be applied to each test machine before any multi-machine tests like LoadGen can be scheduled on them.

Run Hardware Lab Kit - Prepare client for submission job on every machine in the machine pool.

  1. Open HLK Manager.
  2. On the Explorers menu, click Job Explorer.
  3. In Job Explorer, press CTRL+Q to open the query pane, and search for jobs where Name Equals Windows Logo Kit- Prepare client for submission.
  4. In the Results pane, note the Job ID for the matching job.
  5. On the Explorers menu, click Job Monitor.
  6. In Job Monitor, navigate to the machine pool that contains the SUT, MC, and SCs that will be used, and highlight all target machines. Make sure to select all stress clients.
  7. Right-click the machine selection and click Schedule by Job ID.
  8. In the prompt area, enter the Job ID from step 4, and then click OK.
  9. In the Schedule Jobs window, in the Local Parameters pane, set the WdkSubmissionId parameter equal to Client Prepared.
  10. In the toolbar, click Create Schedule.
  11. Wait for the job to run and all of the selected machines to return to the Ready state.

Get Crash Dump Copy Back Setting for the machine pool

  1. In HLK Studio, choose the Configuration option.
  2. Select a machine pool
  3. Right click on the machine pool
  4. Your crash dump setting could be one of the following options:
    • Disable
    • Full
    • Kernel
    • Mini

Run Enable Crash Dump Collection job on every machine in the machine pool

  1. Open HLK Manager.
  2. On the Explorers menu, click Job Explorer.
  3. In Job Explorer, press CTRL+Q to open the query pane, and search for jobs where Name Equals Enable Crash Dump Collection.
    1. Right click the job and click Edit
    2. In the edit window, switch from Details tab to Parameters tab
    3. Check the ScheduleDisplay checkbox for CrashDumpClientSetting parameter and press CTRL+S to save the change
    4. In the Results pane, note the Job ID for the matching job.
    5. On the Explorers menu, click Job Monitor.
    6. In Job Monitor, navigate to the machine pool that contains the SUT, MC, and SCs that will be used, and highlight all target machines. Make sure to select all stress clients.
    7. Right-click the machine selection and click Schedule by Job ID.
    8. In the prompt area, enter the Job ID from step 4, and then click OK.
    9. In the Schedule Jobs window, in the Local Parameters pane, set the CrashDumpClientSetting parameter equal to the Crash Dump Copy Back setting for the machine pool. The possible values are Disable, Full, Kernel, or Mini.
    10. In the toolbar, click Create Schedule.
    11. Wait for the job to run and all of the selected machines to return to the Ready state.


Troubleshooting System Server Testing

To troubleshoot issues that occur with the Windows Hardware Lab Kit (Windows HLK) System.Server tests, follow the steps that are described in this article.

In this article:

  • General system server troubleshooting

  • Troubleshooting failed system server tests

  • Server stress tests

  • Using virtual machines (VMs) in the test environment

General system server troubleshooting

  1. Review the following topics for help in server testing:

    • The Windows HLK topics that are specific to the device, driver or system test.

    • Server Testing Overview

    • System Server Testing Prerequisites

    • Test Server Configuration

    • LoadGen Server Stress - Run First - Set Machine Policies

    • LoadGen Server Stress - Start Test for Server

    • LoadGen Server Stress - Run Last - Reset Machine Policies

    • Troubleshooting Windows HLK.

  2. For server device and driver testing, make sure that the system under test (SUT) is configured as follows:

    • The correct version of Windows is installed.

    • The Server Core option is installed.

    • The SUT has a minimum of four cores\logical processors.

    • The SUT has a minimum of 6 GB of RAM installed.

    • For storage device testing, you might need two device instances that have storage drives if the storage device is a boot device.

  3. If you get an error that Windows HLK Studio could not add targets to the project, reselect the target, close Windows HLK Studio and then restart Windows HLK Studio. The error means that the data is not refreshed.

  4. The Sysparse process directly runs the gatherer DLLs. A second process, Asset Configuration Manager Engine (ACME), watches for hardware changes and alerts the system if one or more hardware changes occur. ACME waits until a timeout occurs or for frequent hardware change reports to stop before it initiates the subscribed gatherers.

    Some tests cause hardware changes throughout the test run. This causes Sysparse to run regularly. Sysparse can consume large amounts of memory, which is caused by the gatherers that are running and collecting data. Sysparse should not interfere with testing because in most cases, the tests do not verify performance.

  5. Make sure that the system upon which the Windows HLK Controller is installed has adequate hardware capabilities to meet the test demands. See Windows HLK Prerequisites for a description of these hardware requirements. As the number of devices and systems that are being tested increases, you might need to add more processors, memory, or storage.

Troubleshooting failed system server tests

If a test fails, follow these steps:

  1. If the failure occurs within minutes of the test startup, it usually means something was not configured properly. Reconfirm the test environment set up.

  2. If the test ran, there should be a log file called Srvlog.xml in the Windows HLK Controller. Follow these steps:

    1. In Windows HLK Studio, open Job Monitor.

    2. Browse to the machine pool of the scheduled test.

    3. In the Job Execution Status pane, select Loadgen Server Stress - Start Test for Server.

    4. In the Task Execution Status pane, right-click RunJob -Launch Server Logo Kit and select Child Job Result.

    5. Return to the Job Execution Status pane and select Launch Server Logo Kit.

    6. In the Task Execution Status pane, right click Start LogGen task and select View Task Log. The log is parsed from the original Loadgen log and contains only errors and passes.

    7. To retrieve the original Loadgen text log, repeat steps 1-5 and then click right-click Launch Server Logo Kit and select Browse Job Logs. This opens the log share on the Windows HLK Controller; the Loadgen log file srv.log is in the share.

    8. Drag and drop the srv.log file into Notepad.

    9. In Notepad, scroll to the bottom of the file.

    10. From the bottom up, search for the string "Error -". The text in the same line will describe the failure. You might have to search several times to find the cause of the failure. The information in log file provides only a high level indicator of what failed.

Loadgen requests more clients

If existing clients cannot generate enough stress against the SUT, Loadgen asks for more stress clients (SCs). This feature is intended to accommodate large servers, and the possibility of some SCs failing in the middle of a run. In general, you should start with eight SCs. The stress level should stabilize in the first three to four hours of the test. If more clients are needed, you will generally see the pop-up in the master controller (MC) in that time frame. You will have sixty minutes to add a new client or the test will terminate and fail.

NOTE

You cannot add more machines to a machine pool after a submission has started. If you start the test by using less than eight clients, make sure that you have additional clients in the machine pool before you start to test.

If Loadgen asks for more clients after four hours of testing, it probably means that something has failed. One or more of the existing clients dropped out, network connectivity issues have occurred, or another issue is preventing the SUT from sensing the required 40% utilization load. This can be an issue of the NIC driver in combination with the network speed, or the driver's implementation of performance monitor counters upon which the Loadgen MC depends.

In this case, try the following troubleshooting steps:

  1. To rule out a transient hardware failure in the NIC, use a different NIC that is the same model and manufacturer.

  2. Use a different model NIC from the same manufacturer, but which uses the same driver.

  3. Use a NIC and driver from a different manufacturer driver.

  4. If one or more NICs are installed directly on to the system board, go into the hardware system setup and disable the NIC at that level so that Windows does not detect it; then use a different device and driver for the testing.

  5. If multiple NICs are installed directly on to the system board, and you cannot install an additional device into a PCI Express slot, go into the hardware system setup and disable all but one of the NICs so that Windows does not detect them.

NOTE

Each detected NIC must be stressed during the test. This requires that each NIC has SCs on a separate physical network segment.

Switches that have advanced features built in to them can interfere with the test in various ways. For example:

  • A switch can have the capability to slow down the ports in the switch if it detects dropped packets or other errors on one port. If a 10GigE NIC on the SUT is intended to receive the traffic that would result from all ports being slowed down to 1 GigE, the Loadgen test cannot reach the requisite 40% network bandwidth utilization level that is needed to pass the test.

  • A switch can route traffic or segment the network in response to rules and logic that internal to the switch (such as load balancing, redundancy, quality of service (QoS), mirroring, duplex versus. simplex operation, adaptive or intelligent bridging, port prioritization, or MAC filtering), that can impact the network bandwidth utilization level on a NIC.

Error=0x80004005

If you receive the following error: Main::RunMain:: Test Check, Spsrv stopped and did not pass required pass percentage (100) (Error=0x80004005). In this case, perform the following steps:

  1. Close the Windows HLK Studio.

  2. Change the SUT computer name to 15 characters or less.

  3. Reboot the SUT.

  4. Open Windows HLK Studio and re-run the LoadGen Server Stress - Start Test for Server test.

Server stress tests

When you perform server stress tests, make sure that the network infrastructure that connects the SUT to the SCs and the MC can perform at the level of the network interface card (NIC) in the SUT. If an SUT has one or more 10GigE NICs, the SCs and the network infrastructure must meet that level of performance.

Make sure that the network infrastructure that connects the DHCP, DNS, Active Directory, Windows HLK Controller, Windows HLK Studio, SUT, SCs and MC is operating correctly. All systems must communicate with each other by using a host name or IP address. This can be confirmed by using a simple ping test.

Make sure that the DHCP, DNS and Active Directory Server(s) are functioning correctly. There should be no stale DNS records. The DHCP server should be authorized to operate on the network, the configuration must be correct, the DHCP scopes must be correct, there should be no incorrect multi-homing, and there should be no errors in the DHCP system event log. The Active Directory domain controller should report no errors and the time service must be synchronized across all systems.

Using virtual machines (VMs) in the test environment

There are no known issues by the DHCP, DNS, AD, and other systems being in a VM. Issues can occur by having SCs running in a VM. These issues are typically related to network bandwidth load generation. To avoid problems, make sure the following configuration is set up:

  • Each SC VM must have a dedicated physical NIC to place load on the network connected to the SUT NIC.

  • At a minimum, you must have physical NICs that are affinitized to the SC VMs that are capable of at least two times the maximum bandwidth of the SUT NIC.

  • Make sure that the physical system(s) that are used for SC VMs is not overstressed by high levels of CPU utilization, and that there is adequate physical memory for all VMs.

Related topics

System.Server Testing


System.Solutions

In this section

  • System.Solutions tests
  • System.Solutions additional documentation


System.Solutions tests

  • PrivateCloudSimulator - System.Solutions.AzureStack (MAX)
  • PrivateCloudSimulator - System.Solutions.AzureStack (MIN)
  • PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MAX)
  • PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MIN)
  • PrivateCloudSimulator Compute-Basic
  • PrivateCloudSimulator Fabric-Disaggregated
  • PrivateCloudSimulator Fabric-HyperConverged
  • S2D - Basic Verification Tests
  • S2D - Prepare Machines for Tests
  • S2D - Remove Cluster
  • S2D - Setup Storage Cluster
  • S2D - Stress Tests


PrivateCloudSimulator - System.Solutions.AzureStack (MAX)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/153e42a4-877c-4dc9-a788-2242db98c628

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodePoolMove StorageNodeRestart StorageNodeBugcheck StorageNodeDiskFaultInjectionAction StorageNodeDiskReadTimeoutAction StorageNodeDiskWriteTimeoutAction StorageNodeDiskFlushFailureAction StorageNodeDiskTrimFailureAction StorageNodeBusResetAction StorageNodePortDisableAllAction StorageNodePortDisableSingleAction StorageNodeDiskReadDelayAction StorageNodeDiskReadMediumErrorAction StorageRetireAndRepairAction StorageNodeDiskFirmwareUpdateAction DisableNetworkAdapters ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • System.Solutions.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |


PrivateCloudSimulator - System.Solutions.AzureStack (MIN)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/03e1c88a-6d4c-4019-91c9-5bf272440a5c

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodePoolMove StorageNodeRestart StorageNodeBugcheck StorageNodeDiskFaultInjectionAction StorageNodeDiskReadTimeoutAction StorageNodeDiskWriteTimeoutAction StorageNodeDiskFlushFailureAction StorageNodeDiskTrimFailureAction StorageNodeBusResetAction StorageNodePortDisableAllAction StorageNodePortDisableSingleAction StorageNodeDiskReadDelayAction StorageNodeDiskReadMediumErrorAction StorageRetireAndRepairAction StorageNodeDiskFirmwareUpdateAction DisableNetworkAdapters ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • System.Solutions.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |


PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MAX)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7b1a59ca-c97a-4e6e-a09b-d63a2b93ffd8

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodePoolMove StorageNodeRestart StorageNodeBugcheck StorageNodeDiskFaultInjectionAction StorageNodeDiskReadTimeoutAction StorageNodeDiskWriteTimeoutAction StorageNodeDiskFlushFailureAction StorageNodeDiskTrimFailureAction StorageNodeBusResetAction StorageNodePortDisableAllAction StorageNodePortDisableSingleAction StorageNodeDiskReadDelayAction StorageNodeDiskReadMediumErrorAction StorageRetireAndRepairAction StorageNodeDiskFirmwareUpdateAction DisableNetworkAdapters ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • System.Solutions.StorageSpacesDirect.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |
IsCreateCluster |
IsRemoveCluster |


PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MIN)

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/6e757c1d-eef8-4d11-9a4c-c7e9a06140f0

This job executes Device.Storage.Controller.AzureStack profile which has compute and storage actions on hyperconverged solutions Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction StorageNodePoolMove ClusterCSVMoveAction StorageNodePoolMove StorageNodeRestart StorageNodeBugcheck StorageNodeDiskFaultInjectionAction StorageNodeDiskReadTimeoutAction StorageNodeDiskWriteTimeoutAction StorageNodeDiskFlushFailureAction StorageNodeDiskTrimFailureAction StorageNodeBusResetAction StorageNodePortDisableAllAction StorageNodePortDisableSingleAction StorageNodeDiskReadDelayAction StorageNodeDiskReadMediumErrorAction StorageRetireAndRepairAction StorageNodeDiskFirmwareUpdateAction DisableNetworkAdapters ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • System.Solutions.StorageSpacesDirect.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours
DriverVerifierSettingsString | Space separated string describing the settings for Driver Verifier to use in format: FLAGS DRIVER.SYS [DRIVER2.SYS] [...]
system_Template | System template for Proxy Client
DriverVerifierCustomizeConfiguration | Identify this test to have customized Driver Verifier Settings. Disables DV reboot if set to TRUE.
InstallStorageShim |
IsCreateCluster |
IsRemoveCluster |


PrivateCloudSimulator Compute-Basic

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b3323e0a-3a01-47f3-bf1c-39e18c6e07d6

This job executes Compute-Basic profile which has compute actions Number of VMs Created = 10 per compute node Size: 80% ~2GB and 20% ~4GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction ComputeNodeRestartAction --------------------------------------------- Parameters -------------------------------------------- StorageCluster If you are running in disaggregated configuration, then you must pass in StorageCluster value StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • System.Solutions.PrivateCloudSimulator.Core
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours


PrivateCloudSimulator Fabric-Disaggregated

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/f2071901-74db-49ca-9f5e-487c692dd325

This job executes Fabric-Disaggregated profile which has compute actions. Number of VMs Created = 20 per compute node Size: 80% ~1GB and 20% ~2GB Compute Cluster VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin ComputeNodeRestartAction ClusterCSVMoveAction ComputeNodeBugCheckAction Storage Clsuter StorageNodeBugcheckAction StorageNodeFileServerMoveAction StorageNodePoolMoveAction StorageNodeRestartAction DisableNetworkAdapters --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given.

Test details
Specifications
  • System.Solutions.PrivateCloudSimulator.Core
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours


PrivateCloudSimulator Fabric-HyperConverged

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/b57eb26d-fc60-414d-ba1c-6f796a661e90

This job executes Fabric-HyperConverged profile which has compute actions. Number of VMs Created = 25 per compute node Size: 80% ~1GB and 20% ~2GB VMSnapshotAction VMLiveMigrationAction VMStateChangeAction VMStartWorkloadAction VMGuestRestartAction VMGuestFullPowerCycleAction VMStorageMigrationAction ComputeNodeEvacuationAction ComputeNodeEvictAction NodeJoinActioin ComputeNodeRestartAction ClusterCSVMoveAction ComputeNodeBugCheckAction --------------------------------------------- Parameters -------------------------------------------- StoragePath By default, you don't need to enter comma seperated storage paths. Job will use all the shares when StorageCluster name is given, or use all the available cluster shared volumes from ComputeCluster.

Test details
Specifications
  • System.Solutions.PrivateCloudSimulator.Core
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 7200
Category | Scenario
Timeout (in minutes) | 432000
Requires reboot | false
Requires special configuration | false
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
DomainName | Domain name
UserName | User name who is admin on all machines under test
Password | Password
ComputeCluster | Name of compute cluster name
StorageCluster | Name of storage cluster (optional)
StoragePath | Name of storage paths (optional, comma seperated)
ProfileName | Name of PCS profile True
SqlServerName | Name of SQL server (optional)
BaseVhdFileFullName | Base vhd file full name under PCS\BaseVHDX folder
MaxVmCountPerComputeNode | Max number of VM creations per compute node. Set 0 to use default number from profile
VmNamePrefix | Prefix for PCS created VMs
VmSwitchName | VM network switch name
LocalTestBinRoot | Path of PCS root folder
FreeDriveLetter | a free drive letter on the machine
DurationInHrs | PCS run duration in hours


S2D - Basic Verification Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/68fd59d3-afe9-4a68-8c9d-ed2c69f6a070

Requirements: First run job "S2D - Prepare Machines for Tests", then "S2D - Setup Storage Cluster" (if S2D not already configured) on the cluster nodes and test controller. The BVT performs two types of tests: - Moving the CSV on top of Storage Spaces Direct between nodes while performing random write IO, and verifying that IO is uninterrupted and CSV does not fail. - Bringing down a node by stopping cluster service, killing cluster service, evict node, graceful machine restart, and non-graceful machine restart (with each action targeting a random node). Test also performs random write IO targeting the appropriate CSV during node failures and verifies that IO does not fail.

Test details
Specifications
  • System.Solutions.CloudStorage.S2D
  • System.Solutions.StorageSpacesDirect.BVTandStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 120
Category | Scenario
Timeout (in minutes) | 7200
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
ClusterName | name of storage cluster to target tests
LogFileSSUFailure | File name for test log of SSU failure tests
LogFileCSVMove | File name for test log of CSV move tests


S2D - Prepare Machines for Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/7ece6cf0-845b-48a6-827b-62a17c149033

Prepares machines to run storage cluster reliability tests. Requires at least 1 test controller marked with machine dimension "FS\MachineRole" as TC, and at least 2 nodes marked with machine dimension "FS\MachineRole" as NODE. Subsequent jobs may require more nodes.

Test details
Specifications
  • System.Solutions.CloudStorage.S2D
  • System.Solutions.StorageSpacesDirect.BVTandStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
Domain | domain of user used for test execution
UserName | username of user used for test execution
Password | password of user used for test execution
TCTestBinDir | Test bin dir on TC; the name of the dir must match name passed to targetBinRoot in the setup script (or its default)
NodeList |


S2D - Remove Cluster

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/45a08797-523e-4637-ab40-6ecc6f0dd3ee

Requirements: First run job "S2D - Prepare Machines for Tests" Removes a cluster and clears all disks. NOTE: Any and all cluster configuration as well as data stored on clustered storage and shares (including S2D) WILL BE LOST. If this job fails, look in the output directory for Remove-S2DCluster.log for details on the failure.

Test details
Specifications
  • System.Solutions.CloudStorage.S2D
  • System.Solutions.StorageSpacesDirect.BVTandStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
ClusterName | Name of cluster to be removed
NodeList | List of node names, separated by commas


S2D - Setup Storage Cluster

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8fd56385-268b-48c8-a81f-9118cfb5bf5a

Requirements: First run job "S2D - Prepare Machines for Tests" Sets up a storage cluster with Storage Spaces Direct (S2D) enabled, and performs basic storage and spaces configuration. This will provision one storage pool using all eligible disks in the cluster, one virtual disk, and add it to Cluster Shared Volumes (CSV). Only works *without* cluster already created, and no storage pool and space created. To reconfigure an existing cluster using this job, first remove all virtual disks, storage pools, and cluster roles, then remove the cluster, before running this job. Or run job "S2D - Remove cluster" to peform the same cleanup. If this job fails, look in the output directory for Configure-S2DCluster.log for details on the failure.

Test details
Specifications
  • System.Solutions.CloudStorage.S2D
  • System.Solutions.StorageSpacesDirect.BVTandStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
ClusterName | name of cluster to be created
NodeList | List of node names, separated by commas
S2DBusTypes | Specify custom S2D bustypes flags for testing purposes only
ClusterStaticIP | Optional, only set if you need static IP for the cluster name


S2D - Stress Tests

NOTE

You can find the latest version of this test documentation online at https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/8f88f147-d747-4695-87cf-07990361d18f

Requirements: First run job "S2D - Prepare Machines for Tests", then "S2D - Setup Storage Cluster" (if S2D not already configured) on the cluster nodes and test controller. The stress tests cause repeated and random node failures (by stopping or killing cluster service), potentially causing multiple nodes to fail if tolerated by the given configuration. During node failures, the test performs multiple IO streams from multiple nodes targeting the appropriate CSV (with each stream performing sequential/random read/write with read data verification). The test can run for a user-specified amount of time, up to 24 hours.

Test details
Specifications
  • System.Solutions.CloudStorage.S2D
  • System.Solutions.StorageSpacesDirect.BVTandStress
  • Device.Storage.Controller.AzureStack.CloudStress
  • Device.Storage.HD.AzureStack.CloudStress
Platforms
  • Windows Server 2016 (x64)
Supported Releases
  • Windows 10
  • Windows 10, version 1511
  • Windows 10, version 1607
  • Windows 10, version 1703
  • Windows 10, version 1709
  • Windows 10, version 1803
  • Next update to Windows 10
Expected run time (in minutes) | 60
Category | Scenario
Timeout (in minutes) | 3600
Requires reboot | false
Requires special configuration | true
Type | automatic

Additional documentation

Tests in this feature area might have additional documentation, including prerequisites, setup, and troubleshooting information, that can be found in the following topic(s):

  • System.Solutions additional documentation

More information

Parameters

Parameter name | Parameter description
ClusterName | Name of storage cluster to be tested
LogFileStressTest | File name for test log of stress tests
TestRunTime | Core run time, in seconds; setup/cleanup will take additional time.


System.Solutions additional documentation

In this section

  • Private Cloud Simulator for Windows Server 2016
  • Partner Guide to WSSD Certification
  • Run cluster tests for Storage Spaces Direct (S2D) in the Windows HLK


Private Cloud Simulator for Windows Server 2016

Introduction

The current industry trend is for private cloud solutions to comprise tightly integrated software and hardware components in order to deliver a resilient private cloud with high performance. Issues in any of the components (software, hardware, drivers, firmware, and so forth) can compromise the solution and undermine the promises made regarding a Service Level Agreement (SLA) for the private cloud.

Some of these issues are surfaced only under a high-stress, cloud-scale deployment, and are potentially hard to find using traditional standalone, component-focused tests. The Private Cloud Simulator is a cloud validation test suite that enables you to validate your component in a cloud scenario and identify these types of issues.

Target Audience

The target audience for this document are those working towards validating their hardware for Windows Server 2016 Logo, Microsoft Azure Stack (MAS) solutions and Windows Server Software Defined (WSSD) datacenter offerings (that offer SDDC Standard, SDDC Premium Additional Qualifiers on the Windows Server Catalog).

Component Type | Windows Server 2016 Logo | WSSD (SDDC Standard/Premium) | Azure Stack
Network Interface Cards (NICs) | Yes | Yes | Yes
SAS HBA | No | Yes | Yes
Hard Disk Drives (HDD): SAS, SATA | No | Yes | Yes
Solid State Drives (SSD): SAS, SATA | No | Yes | Yes
NVMe devices | No | Yes | Yes
SCSI Enclosures | No | Yes | Yes
Solutions | Not Applicable | Yes | Yes

In the future this guidance is expected to expand to cover the following device classes:

  • iSCSI, FCOE, and Fiber Channel HBAs
  • Storage Arrays

Supporting Documents

  1. Failover-Clustering
  2. Windows Server 2016 Storage Spaces Direct cluster
  3. Microsoft Azure Stack Logo Requirements released via Connect to Microsoft partners

Test Overview

Private Cloud Simulator (PCS) simulates a live datacenter/private cloud by creating VM workloads, simulating data center operations (load balancing, software/hardware maintenance), and injecting compute/storage faults (unplanned hardware/software failure). PCS uses a Microsoft SQL Server database to record test and solution data during the run. It then presents a report that includes operation pass/fail rates and logs whihch provide the capability to correlate data for pass/fail determination and failure diagnosis (as applicable).

Topology

Figure 1 shows the topology for a PCS lab environment with the following elements:

  • An Active Directory domain controller/DNS/DHCP server for the test domain.
  • A dedicated HLK controller machine.
  • A dedicated PCS controller machine.
  • A minimum 3-node (maximum nodes: 64) compute cluster, which hosts Hyper-V virtual machines.

overall pcs topology

Execution Flow

PCS execution proceeds through the stages below. All stages after the PCS kickoff [Stage (2)] are fully automated and need no user intervention.

  1. Setup PCS lab topology
    1. In this stage, the lab setup necessary for a succesful PCS run should be complete.
    2. Section (2) discusses details on setting up the common lab infrastructure
    3. Section (3) discusses the specific setups necessary for different types of devices/solutions.
  2. Kickoff PCS using HLK Studio
    1. This stage kicks off the PCS execution process.
    2. Section (3) discusses the HLK job(s) to be used to kick off PCS for different types of devices/solutions.
  3. Initialize PCS Controller (automated)
    1. In this stage, the PCS execution engine sets up a SQL server and IIS on the PCS controller machine
    2. It also copies content (e.g. evaluation OS VHD files) to enable VM creation in the next stage
  4. Create VMs (automated)
    1. This stage sees the PCS engine start creating VMs on each node of the cluster
    2. VM creation stops when the target number of VMs/node has been reached.
    3. This step is a part of PCS setup phase. Test run duration timer kicks in post this stage.
  5. Run Actions (automated)
    1. Now, PCS initiates various types of actions (VM, Cluster, Storage, Network) on each node of the cluster.
    2. Actions run in parallel and co-ordinate among themselves to exercise the device (storage, network) and the solution through the private cloud/datacenter lifecycle
    3. Actions run periodically and stop once the target execution time (defined by the profile/job) of the test has been reached.
    4. Test execution time is defined per profile and can vary based on the profile you are running. Test execution timer kicks in after all the VMs are created.
    5. The steps in each action and the corresponding result of each step is stored in the SQL server.
  6. Analyze Results (automated)
    1. The Run Analyzer engine uses results stored on the SQL server to decide the result of the run based on the success rate of each action, the absence of unexpected crashes on the cluster node.
    2. This result stored in the HLK logging format for use by HLK Studio.
  7. Cleanup Run (automated)
    • In this stage, VMs created in stage (4) are cleaned up and the cluster is restored to a clean state (as possible).
  8. Report result in HLK Studio (automated)
    1. In this stage, the HLK studio reports the result of the PCS run.
    2. The result can be packaged into an HLKX file for submission to Microsoft.

Common Lab Infrastructure Setup

In this section, we will discuss the lab environment that will be common for all PCS execution.

Topology

The figure below shows the common topology for a PCS lab environment with the following elements:

  1. An Active Directory (AD) domain controller and DNS/DHCP servers for the test domain.
  2. A dedicated HLK controller
  3. A dedicated PCS controller

All the above machines (AD Controller, HLK Controller, PCS Controller) can be VMs and must be joined to the same test domain.

User Credentials

  • All PCS tests need to be run as the same user in the 'Domain Admins' group for the test domain.
  • Use the same user with Domain Admin credentials to install the HLK controller.

common topology for a pcs lab environment

Active Directory Functional Level

You can find information about Active Directory at the following URL: https://msdn.microsoft.com/library/bb727067.aspx

PCS needs the AD DS domain and forest functional level to be Windows Server 2012 or higher.

HLK Controller

This controller can be a VM or a physical machine.

System Requirements

Minimum system requirements are as shown in the table below.

Resource | Minimum requirement
CPU (or vCPU) | 4 cores
Memory | 12 GB RAM
Available disk space | 200 GB
Operating system | Windows Server 2016 Datacenter
Active Directory domain | Join it to the test domain

Setup

Hardware Lab Kit

  1. Follow the Windows HLK Getting Started guide to download and install HLK controller software.
  2. Download PCSFiles.vhd (Supplemental content for Windows HLK Private Cloud Simulator (PCS) Tests) from the HLK website.

  3. Copy the PCSFiles.vhd file to the Tests\amd64 test folder on the HLK Controller. The following path is the default path for an HLK installation:

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\amd64

IOMeter

  1. IOMeter is a workload that must be installed on the HLK controller.
  2. Download the i386 Windows version of IOMeter release dated 2006.07.27 from the IOMeter website.
  3. Run the setup (or unzip the package) to unpack the files.

  4. Copy IOMeter.exe, Dynamo.exe to Tests \amd64\pcs\GuestScenarioManager\IOMeter folder on the HLK controller.

    Example:

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\amd64\pcs\GuestScenarioManager\IOMeter

PCS Controller

This controller must be a Generation v2 VM or a physical machine.

System Requirements

Minimum system requirements are as shown in the table below.

Resource | Minimum requirement
CPU (or vCPU) | 4 cores
Memory | 12 GB RAM
Free space on the boot drive | 200 GB
Operating system | Windows Server 2016 Datacenter
Active Directory domain | Join it to the test domain

Setup

  1. Disable Secure Boot and BitLocker on the PCS controller. This is needed because PCS enables TestSigning boot configuration on the controller. If you are using Generation 2 Hyper-V VM as PCS controller, stop the VM to disable Secure Boot in the VM's settings.
  2. Install the HLK Client using the Windows HLK Getting Started guide and open the requisite ports.

  3. Install .NET Framework 3.5 (not included by default in Windows Server 2016).

    1. Generic Installation Instructions can be found at the following locations:
      • https://msdn.microsoft.com/library/hh506443
      • https://msdn.microsoft.com/library/windows/desktop/hh848079

    2. For builds released via Microsoft Connect, see details below:

      • Mount the ISO supplied with the build and find the file:

        • microsoft-windows-netfx3-ondemand-package.cab

        in the <Mounted ISO>\sources\sxs folder

      • Copy the file to a local folder on the PCS controller

      • Install the package by executing this command line using admin privileges

        Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:<Local Folder> /LimitAccess

        or

        PS> Add-WindowsFeature Net-Framework-Features -IncludeAllSubFeature

  4. During test execution, the features (including all sub-features) below will be installed on the PCS controller:

    1. Web Server

      PS> Add-WindowsFeature Web-WebServer -IncludeAllSubFeature

    2. Failover Clustering feature and sub features. Management tools

      PS> Add-WindowsFeature Failover-Clustering -IncludeAllSubFeature -IncludeManagementTools

    3. Remote Server Administration for Hyper-V tools

      PS> Add-WindowsFeature RSAT-Hyper-V-Tools -IncludeAllSubFeature

Setup and Run PCS tests from Windows HLK

This section discusses how to find an appropriate PCS test for your device/solution, configure the lab, and kickoff PCS execution.

  • You need to use the same domain admin user account to setup lab and run tests.
  • You need to install "1607 HLK Update for WS16 (NIC, HDD, SERVER), WSSD (ALL) & AZURE STACK (ALL) Certification" to update your HLK controller and clients. This package is available at Microsoft Connect site for download.
  • "Secure Boot State" must be OFF on all nodes and PCS controller.

PCS Test Selection

The PCS execution framework is used to certify multiple categories of devices and solutions. The table below, maps the device to the appropriate PCS test.

Target Certification/Validation Program PCS Test Job Name in HLK NIC (10GbE) Windows Server 2016 Logo PrivateCloudSimulator - Device.Network.LAN.10GbOrGreater SDDC - Standard SDDC - Premium PrivateCloudSimulator - Device.Network.LAN.AzureStack AzureStack SAS HBA SDDC - Standard PrivateCloudSimulator - Device.Storage.Controller.AzureStack SDDC - Premium AzureStack Disk (HDD/SSD/NVMe) SDDC - Standard PrivateCloudSimulator - Device.Storage.HD.AzureStack SDDC - Premium AzureStack Complete end-to-end solution SDDC - Standard PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MIN)

PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MAX)

SDDC - Premium AzureStack PrivateCloudSimulator - System.Solutions.AzureStack (MIN)

PrivateCloudSimulator - System.Solutions.AzureStack (MAX)

PCS actions simulate planned and unplanned activity. PCS tests are summarized below:

  • PrivateCloudSimulator - Device.Network.LAN.10GbOrGreater

    This test contains a set of actions, that specifically target the network adapter device along with VM and compute cluster actions.

  • PrivateCloudSimulator - Device.Network.LAN.AzureStack

    This test contains an extended set of actions, that verify network adapter support for the new 'Software Defined Networking' feature in Windows Server 2016, along with VM and compute cluster actions.

  • PrivateCloudSimulator - Device.Storage.Controller.AzureStack

    This test contains an extended set of actions, that specifically target the Storage Controller, along with VM and compute cluster actions.

  • PrivateCloudSimulator - Device.Storage.Enclosure.AzureStack

    This test contains an extended set of actions, that specifically target the JBOD enclosure, along with VM, compute cluster and storage cluster actions.

  • PrivateCloudSimulator - Device.Storage.HD.AzureStack

    This test contains an extended set of actions, that specifically target the disk, along with VM and compute cluster actions.

  • PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MIN)/(MAX)

    This test contains an extended set of actions, that target the entire solution built on an hyper-converged storage spaces direct cluster. The (MIN) test should be run on a cluster with the minimum number of supported nodes for the solution. The (MAX) test should be run on a cluster with the maximum number of supported nodes for the solution.

  • PrivateCloudSimulator - System.Solutions.AzureStack (MIN)/(MAX)

    This test contains an extended set of actions, that target the entire AzureStack solution. The (MIN) test should be run on a cluster with the minimum number of supported nodes for the solution. The (MAX) test should be run on a cluster with the maximum number of supported nodes for the solution.

Execute PCS Tests

PrivateCloudSimulator - Device.Network.LAN.10GbOrGreater

System Requirements

Component Being certified | NIC
Setup Type | Hyper-converged setup with S2D storage. Note An SDDC certified HBA is required.
(Minimum) Number of Server Nodes | 3 - all identical
Server Spec | CPU: 16 physcial cores (e.g. 2 socket with 8 cores), Memory: 128 GB, 64 GB free space on boot drive
Storage - Overall | 4 TB free space per node on HDD, 800 GB free space per node on SSD
SSD | Minimum of 1 SSD per node
HDD | Minimum of 2 HDD per node
Network Card | NIC being certified
Switch | Switch supporting all NIC features

Setup

  1. Follow the Windows HLK Getting Started guide to install HLK client software on all cluster nodes
  2. Follow the Windows Server 2016 Storage Spaces Direct cluster guide to deploy a cluster
  3. All nodes must be connected to the same physical switches.
  4. 10GbE or better networking bitrate must be used. Create a virtual swith with the same name on each node.
  5. Virtual machines, created by PCS, connect to the virtual switch to send network traffic between them. These VMs get IP address via DHCP. Make sure your DHCP server assigns valid IP addresses to these VMs. If DHCP server is not available or fails, VMs would use Automatic Private IP Addressing (APIPA) to self-configure an IP address and subnet. Each VM must have a valid IP address to send network traffic between VMs.

Execute

  • Open HLK Studio
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the network adapter device
  • Select device manager

  • Select the device

    hlk showing 10gborgreater test with device selected

  • Right-click on the selected device and select Add/Modify Features

    hlk showing 10gborgreater test with add/modify features context menu

  • In the features dialog, select Device.Network.LAN.10GbOrGreater and click OK. For most NIC cards (with speeds 10GbE or higher) this feature will have been selected automatically.

  • Navigate to the Tests tab
  • Select PrivateCloudSimulator - Device.Network.LAN.10GbOrGreater
  • Click Run Selected

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's domain name
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: Name of compute cluster

      • StoragePath: Default value is "". It uses all the available CSVs from compute cluster. You can use different path by entering comma separated paths.

        Example: "C:\ClusterStorage\Volume1,C:\ClusterStorage\Volume2"

      • VmSwitchName: Name of virtual switch on all nodes

    • Map machines to roles

      • PrimaryNode: This is the node with the selected device
      • Test Controller: Select PCS test controller machine
      • OtherNodes: Select other cluster nodes
  • Click OK to schedule the test
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Actions

The table below lists the actions that are included in this test.

Target object Action Description Virtual machine VmCloneAction Creates a new VM. VmLiveMigrationAction Live-migrates the VM to another cluster node. VmSnapshotAction Takes a snapshot of the VM. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmStartWorkloadAction Starts a user-simulated workload. VmGuestFullPowerCycleAction Power-cycles the VM. Compute node ComputeNodeRestartAction Restart a compute node. ComputeNodeBugcheckAction Bugcheck one node of the compute cluster.

Duration

  • PCS Actions (listed above) will run for 24 hours.
  • The complete run may take around 48-72 hours (including time for setup and cleanup)

PrivateCloudSimulator - Device.Network.LAN.AzureStack

System Requirements

Component Being certified | NIC (with RDMA)
Setup Type | Hyper-converged setup with S2D storage Note An SDDC certified HBA is required.
(Minimum) Number of Server Nodes | 3 - all identical
Server Spec | CPU: 16 physcial cores (e.g. 2 socket with 8 cores), Memory: 128 GB, 64 GB free space on boot drive
Storage - Overall | 4 TB free space per node on HDD, 800 GB free space per node on SSD
SSD | Minimum of 1 SSD per node
HDD | Minimum of 2 HDD per node
Network Card | (RDMA) NIC being certified
Switch | Switch supporting all NIC features (including RDMA)

Setup

  • Follow the Windows HLK Getting Started guide to install HLK client software on all cluster nodes
  • Follow the Windows Server 2016 Storage Spaces Direct cluster guide to deploy a cluster
  • 10GbE or better networking bitrate is required for the NICs under test. Each server should have two identical 10gb or greater NICs.
  • All the nodes must be able to communicate with the PCS-Controller at all times through a management interface. For this purpose, each server should have one additional NIC for management interface, which does not need to meet strict bitrate requirements.
  • If RDMA capable NICs are used, the physical switch must meet the associated RDMA requirements.
  • Make sure that RDMA is setup on all nodes and reflects when queried through Get-SMBClientNetworkInterface & Get-SMBServerNetworkInterface.

  • Make sure that every node contains a teaming enabled virtual switch with the same name.

    Example: New-VMSwitch -Name SdnSwitch -NetAdapterName "SLOT 2,SLOT 2 2" -AllowManagementOS -EnableEmbeddedTeaming

  • Live Migration settings (Failover Cluster Manager->Networks->Live Migration Settings) must be set appropriately to use storage network for live migrations.

PCS will create virtual machines and send traffic between them using the virtual switch created. The vNic (virtual nic) of the PCS virtual machines are assigned IP address from the IP address space passed in as the AddressPrefixes parameter.

PCS-Controller should be built as a Gen2-VM and have 2 network interfaces, one for the management network and the other for SDN (PA address space) topology. The interface for SDN topology will be assigned an IP address from the IP address space passed in as the AddressPrefixes parameter.

software-defined networking with s2d

Execute

  • Open HLK Studio
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the network adapter device
  • Select device manager

  • Select the device

    It should be OK to select any relevant NIC device (does not matter which member of the virtual switch team) on any of the compute nodes that is targeted for certification.

    hlk studio showing device.network.lan test with device selected

  • Right-click on the selected device and select Add/Modify Features

  • In the features dialog, select Device.Network.LAN.AzureStack and click OK.

  • Navigate to the Tests tab
  • Select PrivateCloudSimulator - Device.Network.LAN.AzureStack
  • Click Run Selected

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's fully qualified domain name (FQDN).
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: compute cluster name

      • VmSwitchName: Name of virtual switch to be used for SDN.

        Example: SdnSwitch.

      • AdapterNames: Comma separated list of adapter names that are part of the vmSwitch. Use the format '"Slot 2, Slot 2 2"' for multiple adapters. Names must be derived from Get-NetAdapter cmdlet.

      • VLan: Vlan ID set on vmSwitch. Only required if your physical switch is configured for Vlan. Enter '0' to indicate that there is no Vlan tagging.
      • AddressPrefixes: The IP address range to be used by Tenant VMs and Hosts. These addresses will be used for SDN datacenter management.
      • ClientAddressPrefix: The IP address range used by Client VMs.
      • RDMAEnabled: Enter 1 if NIC supports RDMA
      • SetEnabled: Enter 1 if NIC supports Switch Embedded Teaming
      • HnvEnabled: Enter 1 if NIC supports Hyper-V Network Virtualization
      • TaskOffloadEnabled: Enter 1 if NIC supports Encapsulate Task Offload
      • TestControllerNetAdapterName: Adapter name on PCS-Controller that can be assigned a static IP in the AddressPrefixes range to communicate with SDN Network Controller virtual machines.
      • IsCreateCluster: Enter true if you want the test to create cluster and enable S2D.
      • IsRemoveCluster: Enter true if you want to cleanup cluster and S2D configuration when exiting test

    • Map machines to roles

      • PrimaryNode: This is the node with the selected device, automatically selected by HLK.
      • Test Controller: Select PCS test controller machine
      • OtherNodes: Select other cluster nodes
  • Click OK to schedule the test
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Cleanup

Use the C:\Pcs\ReRunPcsCleanup.cmd script on the PCS-Controller for cleaning up state of the setup if the test abruptly ends. It is very important that stale VMs & SDN infrastructure is cleaned up before starting a new run.

Please make sure the following items are cleaned up before starting a new run:

  • Clustered VM roles (FailoverClusterManager->Cluster->Roles)
  • All the VMs created by PCS

  • vNics created by PCS/SDN

    powershell showing vnic that needs to be cleaned up

  • Storage/CSV-volumes on the cluster do not have any entries pertaining to PCS (C:\ClusterStorage\Volume1\PCS).

Actions

The table below lists the actions that are included in this test.

Type Action Name Description Traffic NetRunEastWestCrossSubnetTrafficAction Run traffic between two Tenant Vms in same VNetwork, but different Vsubnets NetRunEastWestSameSubnetTrafficAction Run traffic between two Tenant Vms in same Vsubnet NetLoadBalancerEastWestInterTenantTrafficAction Run traffic between load balanced tenants and another Vm in a different App Tier. Simulates load balanced traffic amongst frontent application (website) Vms. NetLoadBalancerEastWestIntraTenantTrafficAction Run traffic between load balanced tenants and a Vm in the same App Teir. Simulates load balanced traffic from backend application (DB) to frontent application (website). NetLoadBalancerInboundTrafficAction Run traffic from outside the Tenant network to a load balanced Vms (website). NetLoadBalancerNorthSouthTrafficAction Run traffic from inside the Tenant network to a load balanced Vms. NetLoadBalancerOutboundTrafficAction Run traffic from load balancedVms inside the Tenant network to a Vm outside. NetAddInboundVipToLoadBalancerAction Creates Virtual Ips for Tenant VMs dynamically, mainly for other traffic actions to use. Virtual machine VmLiveMigrationAction Live-migrates the VM to another cluster node. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmGuestFullPowerCycleAction Power-cycles the VM.

Duration

  • PCS Actions (listed above) will run for 24 hours.
  • The complete run may take around 48-72 hours (including time for setup and cleanup).

PrivateCloudSimulator - Device.Storage.HD.AzureStack

System Requirements

Solid State Drives

When certifying SSD's for use in Azure Stack the following is the minimum required hardware test harness that must be running a Windows Server 2016 Storage Spaces Direct cluster.

Component Being certified | SSD
Setup Type | Hyper-converged setup with S2D storage Note An SDDC certified HBA is required.
(Minimum) Number of Server Nodes | 4 - all identical
Server Spec | CPU: 16 physical cores (e.g. 2 socket with 8 cores), Memory: 128 GB, 64 GB free space on boot drive
Storage - Overall | 4 TB free space per node on SSD
SSD | Total SSD storage capacity on each node = 4 TB. Minimum of 2 SSD per node, but more may be needed to meet the 4 TB free space requirement and have enough spare disks for repair test case. To certify multiple SSD disk families in the same setup concurrently (aka with a single PCS run), you need 1 SSD of each family on each of the 4 nodes in the same enclosure slot.
HDD | None
Network Card | 10 GbE NIC with WS2016 Compatible certification/WS2012 R2 certification
Switch | 10 GbE Switch supporting all NIC features

Hard Disk Drives

When certifying HDD's for use in Azure Stack the following is the minimum required hardware test harness that must be running a Windows Server 2016 Storage Spaces Direct cluster.

Component Being certified | HDD
Setup Type | Hyper-converged setup with S2D storage Note An SDDC certified HBA is required.
(Minimum) Number of Server Nodes | 4 - all identical
Server Spec | CPU: 16 physical cores (e.g. 2 socket with 8 cores), Memory: 128 GB, 64 GB free space on boot drive
Storage - Overall | 4 TB free space per node on HDD
SSD | None
HDD | Total HDD storage capacity on each node = 4 TB. Minimum of 2 HDD per node, but more may be needed to meet the 4 TB free space requirement and have enough spare disks for repair test case. To certify multiple HDD disk families in the same setup concurrently (aka with a single PCS run), you need 1 HDD of each family on each of the 4 nodes in the same enclosure slot.
Network Card | 10 GbE NIC with WS2016 Certification
Switch | 10 GbE Switch supporting all NIC features

Setup

  • Follow the Windows HLK Getting Started guide to install HLK client software on all cluster nodes
  • Follow the Windows Server 2016 Storage Spaces Direct cluster guide to deploy a cluster

Execute

  • Open HLK Studio
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the disk device
  • Select device manager

  • Select the disk device that needs to be certified.

    hlk studio showing device.storage.hd test with device selected

  • Right-click on the selected device and select Add/Modify Features

    hlk studio showing device.storage.hd test with add/modify features context menu

  • In the features dialog, select Device.Storage.HD.AzureStack and click OK.

    hlk studio showing device.storage.hd.azurestack feature selected

  • Navigate to the Tests tab

  • Select PrivateCloudSimulator - Device.Storage.HD.AzureStack

  • Click Run Selected

    hlk studio showing device.storage.hd tests

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's fully qualified domain name (FQDN).
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: compute cluster name

      • This location(s) will be on the disk device under test. Default value is "". It uses all the available CSVs from compute cluster. You can use different path by entering comma separated paths.

        Example: "C:\ClusterStorage\Volume1,C:\ClusterStorage\Volume2"

    • Map machines to roles

      • PrimaryNode: This is the node with the selected device
      • Test Controller: Select PCS test controller machine
      • OtherNodes: Select other cluster nodes

      hlk studio showing test parameters and roles

  • Click OK to schedule the test.
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Actions

The profile defines the actions to execute to validate the disk drives for Microsoft AzureStack. The table below lists the actions that are included in this profile.

Target object Action Description Virtual machine VmCloneAction Creates a new VM. VmLiveMigrationAction Live-migrates the VM to another cluster node. VmSnapshotAction Takes a snapshot of the VM. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmStartWorkloadAction Starts a user-simulated workload. VmGuestFullPowerCycleAction Power-cycles the VM. Compute node ClusterCSVMoveAction Move the CSV disks to the best available node. Storage node StorageNodePoolMove Moves a storage pool (created in Storage Spaces) to a different owner node in the storage cluster. StorageNodeRestart Restarts a node in the storage cluster. StorageNodeBugcheck Bug checks one node of the storage cluster. StorageNodeDiskReadTimeoutAction This action goes through disks that tolerate errors (not readonly, clustered, no simple spaces) and waits for read IO. Once an IO is intercepted, it will cause the IO to timeout. If a single timeout is detected on any disk, the action is considered successful. StorageNodeDiskWriteTimeoutAction This action goes through disks that tolerate errors (not readonly, clustered, no simple spaces) and waits for write IO. Once an IO is intercepted, it will cause the IO to timeout. If a single timeout is detected on any disk, the action is considered successful. StorageNodeBusResetAction This action attempts to inject a bus reset to any of the physical disks backing the pool. First, a timeout to a read or write IO is attempted, if that is successful then the corresponding abort, reset LUN, and reset target commands are failed. If any of these succeed then a bus reset will be triggered. If any disk issues a bus reset, the action is then considered successful. StorageNodeUpdateStorageProviderCacheAction Calls update-storageprovidercache command in powershell

Duration

  • PCS Actions (listed above) will run for 48 hours.
  • The complete run may take an additional 24-36 hours (including time for setup and cleanup).

PrivateCloudSimulator - Device.Storage.Controller.AzureStack

System Requirements

When certifying SAS HBA's for use in Azure Stack the following is the minimum required hardware test harness that must be running a Windows Server 2016 Storage Spaces Direct cluster.

Component Being certified | SAS HBA (for S2D)
Setup Type | Hyper-converged setup with S2D storage. HBA under test has to be separate from the Boot HBA
(Minimum) Number of Server Nodes | 3 - all identical
Server Spec | CPU: 16 physical cores (e.g. 2 socket with 8 cores), Memory: 128 GB, 64 GB free space on boot drive
Storage - Overall | 4 TB free space per node on HDD, 800 GB free space per node on SSD
SSD | Minimum of 1 SSD per node
HDD | Minimum of 2 HDD per node
Network Card | 10 GbE NIC with WS2016 Certification
Switch | 10GbE Switch supporting all NIC features

Setup

  • Follow the Windows HLK Getting Started guide to install HLK client software on all cluster nodes
  • Follow the Windows Server 2016 Storage Spaces Direct cluster guide to deploy a cluster

Execute

  • Open HLK Studio
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the disk device
  • Select device manager

  • Select the disk device that needs to be certified.

    hlk studio with lsi adapter storage device selected

  • Right-click on the selected device and select Add/Modify Features

    hlk studio showing add/modify features context menu

  • In the features dialog, select Device.Storage.Controller.AzureStack and click OK.

    hlk studio showing features dialog

  • Navigate to the Tests tab

  • Select PrivateCloudSimulator - Device.Storage.Controller.AzureStack

  • Click Run Selected

    hlk studio showing azurestack test

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's fully qualified domain name (FQDN).
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: Name of compute cluster name

      • StoragePath: This location(s) will be on the disk connected to the storage controller under test.

        Default value is "". It uses all the available CSVs from compute cluster. You can use different path by entering comma separated paths.

        Example: "C:\ClusterStorage\Volume1,C:\ClusterStorage\Volume2"

    • Map machines to roles

      • PrimaryNode: This is the node with the selected device
      • Test Controller: Select PCS test controller machine

      • OtherNodes: Select other cluster nodes

        hlk studio showing parameters and roles dialog.

  • Click OK to schedule the test.
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Actions

The profile defines the actions to execute to validate the disk drives for Microsoft AzureStack. The table below lists the actions that are included in this profile.

Target object Action Description Virtual machine VmCloneAction Creates a new VM. VmLiveMigrationAction Live-migrates the VM to another cluster node. VmSnapshotAction Takes a snapshot of the VM. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmStartWorkloadAction Starts a user-simulated workload. VmGuestFullPowerCycleAction Power-cycles the VM. Compute node ClusterCSVMoveAction Move the CSV disks to the best available node. StorageNodePoolMove Moves a storage pool (created in Storage Spaces) to a different owner node in the storage cluster. StorageNodeBusResetAction This action attempts to inject a bus reset to any of the physical disks backing the pool. First, a timeout to a read or write IO is attempted, if that is successful then the corresponding abort, reset LUN, and reset target commands are failed. If any of these succeed then a bus reset will be triggered. If any disk issues a bus reset, the action is then considered successful. StorageNodePortDisableAllAction This action disables all the storage controllers in the node. All of the SCSI controllers are disabled, if one is successfully disabled then the action is considered passed. After the specified time, all of the controllers are then re-enabled.

This action is disabled for boot controllers

Duration

  • PCS Actions (listed above) will run for 48 hours.
  • The complete run may take an additional 24-36 hours (including time for setup and cleanup).

PrivateCloudSimulator - Device.Storage.Enclosure.AzureStack

System Requirements

Component Being certified | Enclosure
Setup Type | Hyper-converged setup with S2D storage. HBA under test has to be separate from the Boot HBA
(Minimum) Number of Server Nodes | 3 - all identical
Server Spec | CPU: 16 physical cores (e.g. 2 socket with 8 cores), Memory: 128 GB, 64 GB free space on boot drive
Storage - Overall | 4 TB free space per node on HDD, 800 GB free space per node on SSD
SSD | Minimum of 1 SSD per node
HDD | Minimum of 2 HDD per node
Network Card | 10 GbE NIC with WS2016 Certification
Switch | 10GbE Switch supporting all NIC features

Setup

  • Follow the Windows HLK Getting Started guide to install HLK client software on all cluster nodes
  • Follow the Windows Server 2016 Storage Spaces Direct cluster guide to deploy a cluster

Execute

  • Open HLK Studio
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the disk device
  • Select device manager

  • Select the disk device that needs to be certified.

    hlk studio showing selected storage enclosure device.

  • Right-click on the selected device and select Add/Modify Features

    hlk studio showing add/modify features context menu

  • In the features dialog, select Device.Storage.Enclosure.AzureStack and click OK.

    hlk studio showing features dialog

  • Navigate to the Tests tab

  • Select PrivateCloudSimulator - Device.Storage.Enclosure.AzureStack

  • Click Run Selected

    hlk studio showing azurestack test

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's fully qualified domain name (FQDN).
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: Name of compute cluster name

      • StoragePath: This location(s) will be on the disk connected to the storage controller under test.

        Default value is "". It uses all the available CSVs from compute cluster. You can use different path by entering comma separated paths.

        Example: "C:\ClusterStorage\Volume1,C:\ClusterStorage\Volume2"

    • Map machines to roles

      • PrimaryNode: This is the node with the selected device
      • Test Controller: Select PCS test controller machine

      • OtherNodes: Select other cluster nodes

        hlk studio showing parameters and roles dialog.

  • Click OK to schedule the test.
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Actions

The profile defines the actions to execute to validate the disk drives for Microsoft AzureStack. The table below lists the actions that are included in this profile.

Target object Action Description Virtual machine VmCloneAction Creates a new VM. VmLiveMigrationAction Live-migrates the VM to another cluster node. VmSnapshotAction Takes a snapshot of the VM. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmStartWorkloadAction Starts a user-simulated workload. VmGuestFullPowerCycleAction Power-cycles the VM. Compute node ClusterCSVMoveAction Move the CSV disks to the best available node. Storage node StorageNodePoolMove Moves a storage pool (created in Storage Spaces) to a different owner node in the storage cluster. StorageNodeBusResetAction This action attempts to inject a bus reset to any of the physical disks backing the pool. First, a timeout to a read or write IO is attempted, if that is successful then the corresponding abort, reset LUN, and reset target commands are failed. If any of these succeed then a bus reset will be triggered. If any disk issues a bus reset, the action is then considered successful. StorageRetireAndRepairAction This action retires a disk from a pool and starts repair. If spaces doesn't get healthy, the action fails. The action randomly picks a pool and tries to retire a disk in the pool. If the disk is set as readonly, or it is a simple space or is used for cluster purposes (i.e. quorum resource) then the action is skipped

Duration

  • PCS Actions (listed above) will run for 48 hours.
  • The complete run may take an additional 24-36 hours (including time for setup and cleanup).

PrivateCloudSimulator - System.Solutions.StorageSpacesDirect

Setup

  • Setup your solution with the cluster deployment toolset supplied for WSSD program.
  • Minimum Configuration
    • This config contains the minimum of cluster nodes, slowest supported processor, least memory and lowest storage capacity supported by the solution family.
    • Please use the PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MIN) job to validate this setup
  • Maximum Configuration
    • This config contains the maximum of cluster nodes and the maximum storage supported by the solution family.
    • Processor and memory should be equal or higher than the lowest supported value for the solution, but need not be the maximum possible supported value. The processor and memory values should be representative of the most common skus for the solution.
    • Please use the PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MAX) job to validate this setup

Execute

  • Open HLK Studio
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the system under test and PCS controller machine.

  • Select systems on the left panel and then select the PCS test controller (NOTE: Not the machine that needs to be certified).

    hlk studio showing systems tab with pcs test controller selected

  • Right-click on the selected device and select Add/Modify Features

    hlk studio showing add/modify features dialog

  • In the features dialog, select System.Solution.StorageSpacesDirect and click OK

    hlk studio showing features dialog with storagespacesdirect selected

  • Navigate to the Tests tab

  • Select PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MAX) or PrivateCloudSimulator - System.Solutions.StorageSpacesDirect (MIN) (based on the solution size you are testing)

  • Click Run Selected

    hlk studio showing storage spaces direct tests

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's fully qualified domain name (FQDN).
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: Name of compute cluster name

      • StoragePath: This location(s) will be on the disk device under test. Default value is "". It uses all the available CSVs from compute cluster. You can use different path by entering comma separated paths.

        Example: "C:\ClusterStorage\Volume1,C:\ClusterStorage\Volume2"

    • Map machines to roles

      • Test Controller: Select PCS test controller machine

        hlk studio showing parameters and roles dialog

  • Click OK to schedule the test.
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Actions

The profile defines the actions to execute to validate the disk drives for Microsoft AzureStack. The table below lists the actions that are included in this profile.

Target object Action Description Virtual machine VmCloneAction Creates a new VM. VmLiveMigrationAction Live-migrates the VM to another cluster node. VmSnapshotAction Takes a snapshot of the VM. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmStartWorkloadAction Starts a user-simulated workload. VmGuestFullPowerCycleAction Power-cycles the VM. Compute node ComputeNodeEvacuation Drains all resources from one cluster node. ClusterCSVMoveAction Move the CSV disks to the best available node. StorageNodePoolMove Moves a storage pool (created in Storage Spaces) to a different owner node in the storage cluster. StorageNodeRestart Restarts a node in the storage cluster. StorageNodeBugcheck Bug checks one node of the storage cluster. StorageNodeDiskReadTimeoutAction This action goes through disks that tolerate errors (not read-only, clustered, no simple spaces) and waits for read IO. Once an IO is intercepted, it will cause the IO to timeout. If a single timeout is detected on any disk, the action is considered successful. This action is invoked on storage nodes every 15 minutes. StorageNodeDiskWriteTimeoutAction This action goes through disks that tolerate errors (not read-only, clustered, no simple spaces) and waits for write IO. Once an IO is intercepted, it will cause the IO to timeout. If a single timeout is detected on any disk, the action is considered successful. This action is invoked on storage nodes every 15 minutes. StorageNodeBusResetAction This action attempts to inject a bus reset to any of the physical disks backing the pool. First, a timeout to a read or write IO is attempted, if that is successful then the corresponding abort, reset LUN, and reset target commands are failed. If any of these succeed then a bus reset will be triggered. If any disk issues a bus reset, the action is then considered successful. StorageNodePortDisableAllAction This action disables all the storage controllers in the node. All of the SCSI controllers are disabled, if one is successfully disabled then the action is considered passed. After the specified time, all of the controllers are then re-enabled. StorageRetireAndRepairAction This action retires a disk from a pool and starts repair. If spaces doesn't get healthy, the action fails. The action randomly picks a pool and tries to retire a disk in the pool. If the disk is set as readonly, or it is a simple space or is used for cluster purposes (i.e. quorum resource) then the action is skipped DisableNetworkAdapters Disables one of the network adapter that carries the storage traffic. StorageNodeNetworkDisconnectAction Disables one of the network adapters that carries the storage traffic. StorageNodeDiskIoTimeoutOnceAction Times out a single read or write across the storage node. This does not time out the retry attempt for this IO, so the disk will not go unresponsive. StorageNodeUpdateStorageProviderCacheAction Calls update-storageprovidercache command in PowerShell.

Duration

  • PCS Actions (listed above) will run for 96 hours.
  • The complete run may take an additional 24-36 hours (including time for setup and cleanup).

PrivateCloudSimulator - System.Solutions.AzureStack

System Requirements

Setup

  • Setup your solution with the cluster deployment toolset supplied for AzureStack program.
  • Minimum Configuration
    • This config contains the minimum of cluster nodes, slowest processor, least memory and lowest storage capacity supported by the solution family.
    • Please use the PrivateCloudSimulator - System.Solutions.AzureStack (MIN) job to validate this setup
  • Maximum Configuration
    • This config contains the maximum of cluster nodes and the maximum storage supported by the solution family.
    • Processor and memory should be equal or higher than the lowest supported value for the solution, but need not be the maximum possible supported value. The processor and memory values should be representative of the most common skus for the solution.
    • Please use the PrivateCloudSimulator - System.Solutions. AzureStack (MAX) job to validate this setup

Execute

  • Open HLK Studio
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Follow the Windows HLK Getting Started guide to create a machine pool
  • Navigate to the Project tab and click Create Project
  • Enter a project name and press Enter
  • Navigate to the Selection tab
  • Select the machine pool containing the system under test

  • Select systems on the left panel and then select the PCS test controller (NOTE: Not the machine that needs to be certified).

    hlk studio with pcs test controller selected

  • Right-click on the selected device and select Add/Modify Features

    hlk studio with add/modify features context menu

  • In the features dialog, select System.Solution.AzureStack and click OK

    hlk studio showing features dialog

  • Navigate to the Tests tab

  • Select PrivateCloudSimulator - System.Solutions.AzureStack

  • Click Run Selected link

    hlk studio showing tests tab with azurestack test selected

  • In the Schedule dialog,

    • Enter values for the required test parameters

      • DomainName: Test user's fully qualified domain name (FQDN).
      • UserName: Test user's user name
      • Password: Test user's password
      • ComputeCluster: Name of compute cluster name

      • StoragePath: This location(s) will be on the disk device under test. Default value is "". It uses all the available CSVs from compute cluster. You can use different path by entering comma separated paths.

        Example: "C:\ClusterStorage\Volume1,C:\ClusterStorage\Volume2"

    • Map machines to roles

      • Test Controller: Select PCS test controller machine

        hlk studio showing parameters and roles dialog

  • Click OK to schedule the test.
  • Please refer to View PCS report in real-time through SQL Server Reporting Services to view the real-time results for the test run.

Actions

The profile defines the actions to execute to validate the storage Enclosure for Microsoft AzureStack. The table below lists the actions that are included in this profile.

Target object Action Description Virtual machine VmCloneAction Creates a new VM. VmLiveMigrationAction Live-migrates the VM to another cluster node. VmSnapshotAction Takes a snapshot of the VM. VmStateChangeAction Changes the VM state (for example, to Paused). VmStorageMigrationAction Migrates VM storage (the VHD(s)) between cluster nodes. VmGuestRestartAction Restarts the VM. VmStartWorkloadAction Starts a user-simulated workload. VmGuestFullPowerCycleAction Power-cycles the VM. Compute node ComputeNodeEvacuation Drains all resources from one cluster node. ClusterCSVMoveAction Move the CSV disks to the best available node. Storage Node StorageNodePoolMove Moves a storage pool (created in Storage Spaces) to a different owner node in the storage cluster. StorageNodeRestart Restarts a node in the storage cluster. StorageNodeBugcheck Bug checks one node of the storage cluster. StorageNodeDiskReadTimeoutAction This action goes through disks that tolerate errors (not read-only, clustered, no simple spaces) and waits for read IO. Once an IO is intercepted, it will cause the IO to timeout. If a single timeout is detected on any disk, the action is considered successful. This action is invoked on storage nodes every 15 minutes. StorageNodeDiskWriteTimeoutAction This action goes through disks that tolerate errors (not read-only, clustered, no simple spaces) and waits for write IO. Once an IO is intercepted, it will cause the IO to timeout. If a single timeout is detected on any disk, the action is considered successful. This action is invoked on storage nodes every 15 minutes. StorageNodeBusResetAction This action attempts to inject a bus reset to any of the physical disks backing the pool. First, a timeout to a read or write IO is attempted, if that is successful then the corresponding abort, reset LUN, and reset target commands are failed. If any of these succeed then a bus reset will be triggered. If any disk issues a bus reset, the action is then considered successful. StorageNodePortDisableAllAction This action disables all the storage controllers in the node. All of the SCSI controllers are disabled, if one is successfully disabled then the action is considered passed. After the specified time, all of the controllers are then re-enabled. StorageRetireAndRepairAction This action retires a disk from a pool and starts repair. If spaces doesn't get healthy, the action fails. The action randomly picks a pool and tries to retire a disk in the pool. If the disk is set as readonly, or it is a simple space or is used for cluster purposes (i.e. quorum resource) then the action is skipped DisableNetworkAdapters Disables one of the network adapter that carries the storage traffic. StorageNodeNetworkDisconnectAction Disables one of the network adapters that carries the storage traffic. StorageNodeDiskIoTimeoutOnceAction Times out a single read or write across the storage node. This does not time out the retry attempt for this IO, so the disk will not go unresponsive. StorageNodeUpdateStorageProviderCacheAction Calls update-storageprovidercache command in PowerShell.

Duration

  • PCS Actions (listed above) will run for 96 hours.
  • The complete run may take an additional 24-36 hours (including time for setup and cleanup)

Analyze test results

While a PCS test pass is running, you can view and analyze data in real-time through SQL Server Reporting Services. After the test pass completes, you can get additional information in the logs generated by the PCS.

View PCS report in real-time through SQL Server Reporting Services

While PCS operations are running, reports are saved in a SQL database on the PCS Controller. Each report lists all operations that were performed, their pass percentages, and all resources that were acquired and released during the test. A new database is created for each test run to enable you to review data from previous test runs at any time.

To view the report, follow these steps:

  1. By default, Internet Explorer Enhanced Security Configuration is enabled on Windows Server 2016. You need to disable it to view the report.

    Open Server Manager => Local Server => Click IE Enhanced Security Configuration to turn it off for administrators and users.

  2. Open IE from HLK controller and visit http://PcsControllerMachineName/Reports.

    If you open IE from PCS controller, you need to open IE with administrator privilege.

    pcs reporting page in internet explorer

  3. Click PCS Reports => PCSRuns.

  4. Each PCS run is identified by a unique Pass Run ID.

    ie reporting showing pass run ids

  5. Click a Pass Run ID (for example, click f44b3f88-3dbf-476e-9294-9d479ca0a369) to open a report from the PCS run.

    The data in these reports is live. While a test runs, you can monitor the progress of a test run in real-time.

    • An overview of all resources (VMs and hosts) that participated in the test run.
    • All actions that were performed on each resource. The Pass and Fail columns report the number of actions that passed and failed.

    ie reporting showing run information

  6. In the Overall Operation Information table, you can click links in the Action/Pass/Fail column to open detail pages, which give you more information about the action's results. For example, if you clicked the failure number 9 by the VMLiveMigrationAction entry, you would see the summary shown in the following illustration.

    ie reporting showing vmlivemigrationaction

    The first entry above provides the following information:

    • Failure ID: When we encounter a failure in PCS, we generalize the Failure Message and generate a unique Hash for it. In above example the Failure ID is 97c12afd-23a8-3982-e304-a5dc6793950d

    • Failure Hash: Generalized failure message.

      In the example above, the failure hash is the following:

      Virtual Machine <VIRTUAL MACHINE> live migration failed at progress <PERCENTAGE> (migration state: Migrating)

      Error: Virtual machine migration operation for '<VIRTUAL MACHINE>' failed at migration destination '<COMPUTE NODE>'. (Virtual machine ID <GUID>)

      Failed to receive data for a Virtual Machine migration: This operation returned because the timeout period expired. (0x800705B4).

    • Count Current Run: The count of actions of a particular type that failed with this particular error message during this run. In the above example, VMLiveMigrationAction was run 3 times.

    • Count All Runs: A count of actions that failed because of this particular failure across all PCS runs. For the VMLiveMigrationAction, this count was 3.
    • PCS Runs Affected: Tells how many runs have been affected by this failure. For VMLiveMigrationAction, only 1 PCS run was affected.

  7. To look further into the error - you can click a failure ID on that screen to drill down to a global history of the failure type across all PCS runs. For example, click 97c12afd-23a8-3982-e304-a5dc6793950d to display the following. The page lists all failed operations, grouped by failure type, which has the effect of highlighting key features that you might need to investigate.

    ie reporting showing failing actions by cause

  8. If you click the Action ID, you can drill down farther to see an Action Log Report. Errors are shown in red; Warnings are shown in yellow.

    ie reporting showing action log report

Troubleshoot a PCS run from the PCS Controller

There are multiple stages in PCS Execution Flow. If PCS failed at Setup, Execute, or Cleanup stage, you can browse job logs by right click the job name => click Browse Job Logs. The log file names are PCS-E2Elaunch_Setup.log, PCSE2Elaunch_Execute.log, and PCS-E2Elaunch_Cleanup.log. Log files contain information about failures.

pcs controller showing task execution status

When a PCS job fails, you can rerun Setup/Execute/Cleanup stage directly from PCS controller. This method is useful to for troubleshooting problems in these stages.

  • Open elevated command prompt
  • Run ReRunPcsSetup.cmd, ReRunPcsExecute.cmd, or ReRunPcsCleanup.cmd script

Logs and Diagnose

PCS has three main stages: Setup, Execute, and Cleanup. HLK PCS job uses PCS-E2Elaunch.ps1 script to launch these three stages. Their log file names are called PCS-E2ELaunch_Setup.log, PCS-E2ELaunch_Execute.log and PCSE2ELaunch_Cleanup.log.

When a PCS run has completed, PCS Run Analyzer analyzes logs and reports. The run succeeded when the following criteria are met, with the analyzed report saved as AnalyzerLog.log.

  • All PCS actions has 90% pass rate
  • No unexpected crash of any cluster node, except the ones initiated by PCS for testing purpose

The AnalyzerLog.log looks similar to the figure below:

A zip file (PcsLog-DateTime.zip) is created at the end of PCS Cleanup phase. This file contains all the logs and is copied to the HLK PCS job result folder when a test fails.

  • ClusterLog subfolder: contains cluster log files
  • Events subfolder: contains event files
  • MHTML subfolder: contains SQL summary page and failed actions.
  • PCSEventData subfolder: contains workload logs
  • ClusterName-PRE.mht.html/ClusterName-POST.mht.html file: cluster validation test is run before and after PCS execute stage to verify the cluster healthy status

You can run the following script from PCS controller to generate a ZIP file that contains required logs. This method is useful when HLK Studio canceled the job before PCS Cleanup phase has finished.

Syntax

PS > C:\pcs\PCS-E2ELaunch.ps1 -DomainName <string> -UserName <string> -Password <string> -ComputeCluster <string> [-StorageCluster <string>] -CollectLog

Parameters

  • DomainName: Test user's fully qualified domain name (FQDN).
  • UserName: Test user's user name
  • Password: Test user's password
  • ComputeCluster: Name of compute cluster name
  • StorageCluster: optional, Name of storage cluster name. Don't specify this parameter if Computer and Storage clusters are the same.
  • CollectLog: Required

While PCS is running, you can run the following cmdlets on PCS controller to generate a report that lists unexpected bugchecks from all nodes.

Syntax

PS > Import-Module .\PrivateCloudSimulator-Manager.psm1

PS > Get-PCSReport

The above cmdlet generates a HTM file containing the report.

Customize Action Logs

A PCS run has a RunId. A PCS action has an action ID. When a PCS action fails, PCS removes the variant (i.e. VM name) from the failure message and generates a unique hash value for it. Similar failures have same unique hash value. PCS then groups them together in SQL report site.

PCS uses .NET Trace Listeners to collect test results. These listeners are defined in Microsoft.PrivateCloudSimulator.exe.config.

  • SQLOnline: This listener logs the results into SQL database.
  • AnalyticalLogGather: This listener collects extra information when an action is failed.

When a particular action fails or a particular hash value is seen, you can configure AnalyticalLogGather listener to collect event logs, cluster logs, or call a script. This is defined in ActionFailureReactionPolicy.xml.

In ActionFailureReactionPolicy.xml, PCS supports two types of triggers and three types of reactions. Using this XML, you can define rules like "when trigger X is seen, take reactions Y and Z". Most actions would have NodeScope set to ReservedOnly and MaxLevel set to 3 (Critical, Error, and Warning events).

Trigger:

Type | Data
ActionFail | ActionFullName
KnownFailure | FailureHash

Reaction:

Type | Data
ETWCollection | Channel, NodeScope, StorageLocation, MaxLevel
ClusterLogCollection | UseLocalTime, NodeScope, StorageLocation, MaxTimeDuration (optional)
CustomPS | ScriptFullPath, NodeScope, Argument

Valid NodeScope values are the following:

  • AllNodes
  • ComputeOnly
  • StorageOnly
  • EdgeOnly
  • NCOnly
  • ReservedOnly

Valid MaxLevel values are the following:

  • 0 (logs at all levels)
  • 1 (Critical)
  • 2 (Error)
  • 3 (Warning)
  • 4 (Information)
  • 5 (Verbose)

Examples:

<Trigger>
  <Type>ActionFail</Type>
  <Data Name="ActionFullName" Value="Microsoft.HyperV.Test.Stress.PrivateCloud.ComputeNode.Action.StorageNodeRestartAction">
  </Data>
  <ReactionMatchList>
    <!-- Details of Reaction are Defined Below and are referenced using the ID attribute-->
    <MatchingReaction ID ="1"></MatchingReaction>
    <MatchingReaction ID ="2"></MatchingReaction>
  </ReactionMatchList>
</Trigger>49
<Reaction ID="1">
  <Type>ETWCollection</Type>
  <Data Name="Channel" Value="Microsoft-Windows-Hyper-V-VMMS-Analytic"></Data>
  <Data Name="NodeScope" Value="ReservedOnly"></Data>
  <Data Name="StorageLocation" Value="C:\PCS\PCSEventData\%NODE%\%ActionId%\EventLogs"></Data>
  <Data Name="MaxLevel" Value="3"></Data>
</Reaction>

Action log files are saved to 'FORENSICLOGLOCATION' folder on PCS controller. By default, it is C:\PCS\PCSEventData.

For each failed action, the following information is collected from the reserved node(s). This log location can be seen in the action's SQL report page.

  • %MachineName%\%RunId%\ClusterLogs\%ActionId%
  • %MachineName%\%RunId%\EventLogs\%ActionId%
  • %MachineName%\%RunId%\CustomResponse\%ActionId%

Logs collected for each area

The following event and logs are collected in the PcsLog zip file.

Cluster area

Cluster logs for compute and storage clusters are collected. The following events from cluster and compute cluster are collected:

Microsoft-Windows-FailoverClustering-ClusBflt/Management Microsoft-Windows-FailoverClustering-ClusBflt/Operational Microsoft-Windows-FailoverClustering-Clusport/Operational Microsoft-Windows-FailoverClustering-CsvFs/Operational Microsoft-Windows-FailoverClustering-Manager/Admin Microsoft-Windows-FailoverClustering-Manager/Diagnostic Microsoft-Windows-FailoverClustering-Manager/Tracing Microsoft-Windows-FailoverClustering-NetFt/Operational Microsoft-Windows-FailoverClustering-WMIProvider/Admin Microsoft-Windows-FailoverClustering/Diagnostic Microsoft-Windows-FailoverClustering/DiagnosticVerbose Microsoft-Windows-FailoverClustering/Operational

File server

The following events from storage cluster are collected:

Microsoft-Windows-SmbClient/Connectivity Microsoft-Windows-SMBClient/Operational Microsoft-Windows-SmbClient/Security Microsoft-Windows-SMBDirect/Admin Microsoft-Windows-SMBServer/Audit Microsoft-Windows-SMBServer/Connectivity Microsoft-Windows-SMBServer/Operational Microsoft-Windows-SMBServer/Security Microsoft-Windows-SMBWitnessClient/Admin Microsoft-Windows-SMBWitnessClient/Informational Microsoft-Windows-SMBWitnessServer/Admin

Hyper-V

Some Hyper-V channels are not enabled by default. There is an option to enable/disable them during PCS setup phase.

The following events from compute cluster are collected. The default mode for Analytic events is 'do not overwrite events', and the size of log file is changed to 1GB.

Microsoft-Windows-Hyper-V-Config-Analytic Microsoft-Windows-Hyper-V-Config-Admin Microsoft-Windows-Hyper-V-High-Availability-Admin Microsoft-Windows-Hyper-V-High-Availability-Analytic Microsoft-Windows-Hyper-V-Hypervisor-Admin Microsoft-Windows-Hyper-V-Hypervisor-Analytic Microsoft-Windows-Hyper-V-Hypervisor-Operational Microsoft-Windows-Hyper-V-VMMS-Analytic Microsoft-Windows-Hyper-V-VMMS-Admin Microsoft-Windows-Hyper-V-Worker-Analytic Microsoft-Windows-Hyper-V-Worker-Admin Microsoft-Windows-Hyper-V-Worker-VDev-Analytic Microsoft-Windows-Hyper-V-SynthStor-Admin

Storage

The following Storage Space events from compute or storage clusters are collected:

System CoreTestShim-Operational Microsoft-Windows-StorageSpaces-Driver-Operational Microsoft-Windows-StorageSpaces-Driver-Diagnostic Microsoft-Windows-Storage-Storport-Operational

Network

The following SDN events from compute cluster are collected:

System Microsoft-Windows-Hyper-V-VmSwitch-Operational

Create VMs that use differencing disks

PCS by default uses the provided guest OS VHD to create VMs that have fixed disks by default. To create VMs that have differencing disks instead, set the UseDiffDisks value to true, as highlighted below:

PrivateCloudSimulator.xml file:

privatecloudsimulator.xml file with usediffdisks highlighted

Define actions for PCS to run

You can define and schedule your own actions for PCS to perform. Below shows a typical action definition in the PrivateCloudSimulator.xml file.

  • The value highlighted in yellow is the test name. This is the same test name that shows up on the report.
  • The Interval field sets the frequency with which the action runs. Use the format hh:mm:ss. For example, the value 02:00:00 repeats the action every 2 hours.
  • The StartUpNumber field defines the number of instances of that action to initiate on each node of the compute cluster.

privatecloudsimulator.xml file with actions defined

FAQ

Where are HLK Studio and PCS controller installed?

They are installed on additional machines that are not part of the cluster nodes.

overall pcs topology

Do we need to install the HLK Client on cluster nodes?

You need to install HLK Client on cluster nodes and on the PCS controller as well.

What additional configuration is needed to run firmware update action for disks?

StorageNodeiskFirmwareRolloutAction depends on the following:

  1. XML File - FirmwareRolloutSettings.xml

  2. The firmware files

    • XML File: Please create a file named FirmwareRolloutSettings.xml and copy it to C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\amd64\PCS\StorageBin on the HLK controller.

      The file should have the following format.

      <?xml version="1.0"?>
<Data>
  <Table Id="Settings">
    <ParameterTypes>
      <ParameterType Name="Manufacturer">String</ParameterType>
      <ParameterType Name="Model">String</ParameterType>
      <ParameterType Name="TargetFirmwareVersion">String</ParameterType>
      <ParameterType Name="TargetFirmwarePath">String</ParameterType>
      <ParameterType Name="server">String</ParameterType>
    </ParameterTypes>
    <Row>
      <Parameter Name="Manufacturer">Manufacturer</Parameter>
      <Parameter Name="Model">Model</Parameter>
      <Parameter Name="TargetFirmwareVersion">Version1</Parameter>
      <Parameter Name="TargetFirmwarePath">\\%HLKControllerName%\tests\amd64\PCS\StorageBin\V1.bin</Parameter>
      <Parameter Name="BackupTargetFirmwareVersion">Version2</Parameter>
      <Parameter Name="BackupTargetFirmwarePath">\\%HLKControllerName%\tests\amd64\PCS\StorageBin\V2.bin</Parameter>
      <Parameter Name="server">ServerNameWillBeUpdatedByTestAutomatically</Parameter>
    </Row>
  </Table>
</Data>

    • Copy the firmware files to a location/share on the HLK controller. This location should be accessible by the PCS controller and the cluster nodes.

      This location will be the TargetFirmwarePath in the XML above (e.g. \\%HLKControllerName%\tests\amd64\PCS\StorageBin)

The small boot disk of cluster node has very little free space due to a large pagefile.

By default, Windows sets the page file max size to the amount of system memory. It s located at C:\pagefile.sys by default. Make sure your boot drive has enough free disk space on each cluster node. Otherwise, you should change the pagefile settings to reduce the size of it or move it to another drive.

You can run the following command to change the pagefile size. You'll need to then restart the machine.

Example: set the size to 10240MB

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v PagingFiles /t REG_MULTI_SZ /d "C:\pagefile.sys 10240 10240" /f

What is the PCS support alias?

Please send email to pvsha@microsoft.com for any queries related to PCS or WSSD, AzureStack hardware certification.

Troubleshooting Failures

The issues seen or resulting from a PCS certification run has been observed to not be related to PCS itself many times, as the PCS is a reliability test suite and touches a number of OS and third party components - HyperV, Clustering, Storage, Networking etc. to name a few.

The below are put together as a basic guide to help narrow down some of the issues:

  • Run cluster validation and check report for errors.
  • On the failover cluster manager, check whether all the nodes+vDisk+Pool are in healthy condition. If they are not, it is fine to invest time on checking the logs/debugging before calling upon MSFT.
  • Open Hyper-V manager and make sure the VMs and vSwitches get enumerated (also possible by running Get-VM or Get-VMSwitch).
  • Make sure you are able create a vSwitch outside of PCS tests on one/all of the compute nodes.
  • Make sure you can create a Win2012R2 VM on one/all of the nodes and can attach a vmNetworkAdapter it to a vSwitch.
  • Look for dump files generated due to bugchecks by running "dir /s *.dmp" from the %systemdrive% on the compute nodes.
  • Possible usage of LiveKD to look at kernel modules/threads that are stuck, if you do not have kernel debugger attached.
  • Check if compute nodes' license is active, as Eval version license get reset every 180 days.

Appendix: Software Defined Datacenter (SDDC) Additional Qualifiers (AQs)

All server systems and components used in Windows Server 2016 WSSD offers must be certified for the Windows Server 2016 logo and meet the Windows Server 2016 Software-Defined Data Center (SDDC) additional qualifiers (AQs). The required HLK Feature names are listed in the table below.

Component Required HLK Features Software-Defined Data Center (SDDC) Standard AQ Software-Defined Data Center (SDDC) Premium and Azure Stack AQ NIC Device.Network.LAN.10GbOrGreater

Device.Network.LAN.VMQ

Device.Network.LAN.RSS

Device.Network.LAN.LargeSendOffload

Device.Network.LAN.ChecksumOffload

Device.Network.LAN.Base

Device.Network.LAN.VXLAN

Device.Network.LAN.VMMQ

Device.Network.LAN.MTUSize Required if using Encap offloads

Device.Network.LAN.KRDMA

Device.Network.LAN.GRE

Device.Network.LAN.DCB Required if using RoCE RDMA

Device.Network.LAN.AzureStack

SAS HBA Device.Storage.Controller

Device.Storage.Controller.Flush

Device.Storage.Controller.PassThroughSupport

Device.Storage.Controller.Sas

Device.Storage.Controller.AzureStack

NVMe Storage Devices Device.Storage.ControllerDrive.NVMe

Device.Storage.Hd.AzureStack

HDD (SAS) Device.Storage.Hd

Device.Storage.Hd.DataVerification

Device.Storage.Hd.Flush

Device.Storage.Hd.PortAssociation

Device.Storage.Hd.Sas

Device.Storage.Hd.Scsi.ReliabilityCounters

Device.Storage.Hd.AzureStack

Device.Storage.Hd.FirmwareUpgrade

HDD (SAS) Device.Storage.Hd.Sata

Device.Storage.Hd

Device.Storage.Hd.DataVerification

Device.Storage.Hd.Flush

Device.Storage.Hd.PortAssociation

Device.Storage.Hd.AzureStack

Device.Storage.Hd.FirmwareUpgrade

SSD (SAS) Device.Storage.Hd

Device.Storage.Hd.DataVerification

Device.Storage.Hd.PortAssociation

Device.Storage.Hd.Sas

Device.Storage.Hd.AzureStack

Device.Storage.Hd.FirmwareUpgrade

Server System.Fundamentals.Firmware

System.Server.Virtualization

System.Server.AzureStack.Security

System.Server.Assurance

System.Server.AzureStack.BMC


Partner Guide to WSSD Certification

Introduction

Windows Server 2016 offers a range of competitive and differentiated capabilities to enable lower-cost, cloud scale Software-Defined Datacenter (SDDC) scenarios. The goal of the Windows Server Software-Defined (WSSD) program is to ensure that customers have a seamless deployment and steady-state operational experience on validated hardware. To that end, the WSSD program will provide guidance around four distinct technical stages:

  • Design: Reference architecture for configuration selection, design principles, and best practices
  • Validate: Additional SDDC tests to ensure components and systems meet WSSD requirements
  • Deploy: Initial deployment guidance with experience guides and scripts for automation
  • Operate: Experience guides for steady-state operational management using System Center Virtual Machine Manager (VMM) and System Center Operations Manager (OM)

This topic focuses on the guidance required to complete WSSD Certification as part of the Validate stage above.

Audience

This topic is for WSSD Solution Vendors and OEMs and is not intended to provide specific guidance for IHVs or those doing individual component-level certification (i.e. SDDC AQs).

Overview of Windows Server software-defined offerings

WSSD provides three offerings:

  1. Hyper-converged Infrastructure (HCI) Standard - Combines compute and storage in the same cluster of server nodes to provide a highly-virtualized solution that's easy to deploy, manage, and scale. This deployment option simplifies IT infrastructure since customers no longer need traditional IT silos of compute, shared storage (SAN/NAS), and networking. It's best suited for small to mid-sized IT environment running virtualized (Hyper-V) workloads.
  2. Converged Software-Defined Storage (SDS) - Provides a lower cost, enterprise-grade, shared storage alternative to traditional SAN/NAS. Built using a cluster of server nodes, it's easy to deploy, manage, and scale out to build storage capacity as customer's needs grow over time. On one hand, its simplicity and low cost would appeal to small/mid-sized IT environments, it's scale, flexibility, and cloud-scale traits would benefit large service providers and enterprise IT. Any workloads that are compatible with SMB storage are a good fit for this offer.
  3. Hyper-converged Infrastructure (HCI) Premium - Provides a comprehensive software-defined "datacenter in a box". Building on the same foundation as HCI-Standard, these offers add Software-Defined Networking (SDN) and Assurance to the stack. These offerings provide the perfect building blocks for customers - typically a large enterprise, service provider or hoster - that want to build on premise SDDC that emulates large public clouds like Azure. While SDN provides the benefit to deploy, provision and manage networking services at scale, Assurance provides essential tenant isolation and services for running a secure on-premises multi-tenant cloud.


Run cluster tests for Storage Spaces Direct (S2D) in the Windows HLK

Abstract

This document contains instructions for partners and original equipment manufacturers (OEMs) about how to use tests included in the Windows Hardware Lab Kit (HLK, formerly HCK) to validate specific hardware configurations for basic functionality and reliability for Storage Spaces Direct (S2D).

IMPORTANT

Instructions in this document are for testing purposes only. They are not intended for end users or to configure systems for production use.

Prerequisites

  1. Hardware configuration must meet S2D requirements, and it must have first passed all cluster validation tests, including new tests added for S2D.
  2. You must download, install, and configure the latest Windows HLK that supports the most recent Windows Server Technical Preview. Familiarity with the Windows HLK is recommended. To download and learn more about the Windows HLK, see Windows Hardware Lab Kit.
    1. First, install the HLK Controller (HLKC) and HLK Studio on a test server. Do not install it on a cluster node. The administrator will use this server to run tests and manage other machines. The HLKC can be used to manage multiple clusters concurrently, so an existing HLKC that has already been configured with another cluster can be used.
    2. Next, install HLK clients on:
      • All servers that are intended to be used as storage cluster nodes (the number of nodes, also described in separate S2D requirements, should be at least four), and
      • A server that is not part of the cluster as the test controller (TC). This is where the tests will be run.
  3. All machines used for testing (including the HLK controller) should be joined to the same domain, and have a common domain user who has administrator privileges on all of the machines. Credentials for this user will be supplied to the test framework to run tests under. The user's password may be transmitted and stored as clear text.
  4. All cluster nodes must have DHCP enabled on all connected network interfaces, with DHCP configured on the networks they are connected to.

Setup

Configure the HLK

For detailed instructions about how to install the HLK, see the HLK user's guide for detailed instructions. After you have installed and configured the HLK on all of your machines, create a machine pool and project:

  1. In HLK Studio on the HLKC, create a new machine pool with a name that can easily identify the cluster later, such as the cluster name you will be using (this document uses "Cluster"). Add the TC and all of the cluster nodes to the machine pool. Make sure that the machines are in the Ready status.
    1. Open HLK Studio, select Start, and then All Apps > Windows Kits > HLK Studio.
    2. Select Configuration in the upper-right corner.
      1. Right-click $(Root), and then select Create Machine Pool, and specify a name. (This document uses "Cluster.")
      2. Move your machines to the new pool. HLK Studio currently does not support multiple-selections, so you must move the machines one at a time.
      3. Select all of the machines in the pool, and then right-click, and select Change Machine Status > Ready. The machines will first change to the Initializing state.
      4. Ensure that the machines reach the Ready state. HLK Studio does not refresh the displayed state automatically. Wait a few seconds, and then select the Default machine pool. Return to the cluster machine pool to refresh the machine status. After all of the machines are in the Ready state, continue to create a project.
  2. Create a new project with the same name.
    1. If you are in the Configuration view, click Back (it looks like a left arrow) to the left of the title "Configuration" to return to the main view.
    2. In the Project tab, select Create project.
    3. Specify "S2D" as the project name. Using this exact name is not required, but doing so makes it easier to identify the project.

Prepare the machines to run tests

This step deploys the required test binaries and drivers to the cluster nodes and test controller so that you can run S2D tests. This test job needs to be run only once per cluster, even if you run actual S2D tests multiple times. This job will restart the machines.

IMPORTANT

Before running this test job, ensure that both secure boot and BitLocker are disabled on all machines used for testing. If you are using a virtual machine for the test controller, you may need to manually disable secure boot and BitLocker, as they may be enabled by default.

Do the following in HLK Studio:

  1. In the Project tab, double-click on the project you previously created (if it's not selected already). The project name will be displayed as the view title after you select it.

  2. Click the Selection tab.

    1. Select the machine pool you previously created that contains the cluster and test controller.

    2. Select Systems on the left, and then check the first cluster node that appears in the list.

      Make sure that only one node is selected and that you do not accidentally select the test controller.

    3. Right-click on the selected machine, and then select Add/Modify Features.

    4. In the dialog box that opens, select the System.Solutions.StorageSpacesDirect feature from the Device Feature List, and then select OK.

  3. In the Tests tab, select the test S2D - Prepare Machines for Tests, and then select Run Selected. run selected machines

  4. Specify the required parameters.
    1. For the parameters Domain, UserName, and Password, enter the appropriate information for a domain user who has administrator access to all of the machines in the machine pool.
    2. In the Role drop-down list, PrimaryNode should be selected. In the list of machines, confirm that the node you selected in the Selections tab is checked. In addition:
      1. Select TestController in the Role drop-down list, and then select the test controller from the list of machines.
      2. Select OtherNodes in the Role drop-down list, and then select the remaining nodes in the cluster.
      3. Make sure all of the machines are selected before you continue.

  5. Select OK to run the job. This prepares the machines.

    prepare the machines

  6. A progress bar will appear at the bottom of the HLK Studio window. When the process finishes, a green check mark will appear in the Status column for the test job. If the status displays a red "X" instead, then the test job failed. See Troubleshooting for more information.

This process takes about 10 minutes to run. It can take longer if your machines take more than five minutes to restart.

Create a cluster, storage pool, and virtual disk

After you prepare machines for tests, S2D also needs to be configured before you can run related tests. The following job will create cluster, enable S2D, and configure a pool and space.

IMPORTANT

This job will succeed only if no existing cluster, storage pool, or virtual disk has already been created. Before you run this job, first remove all virtual disks, storage pools, and cluster roles. Also remove the cluster itself. If you have already created a cluster, enabled S2D, and configured and validated the pool and spaces, skip this step and proceed to running the tests.

  1. In the Tests tab in HLK Studio, select test S2D - Setup Storage Cluster and Run Selected, and then specify the required parameters and roles.
    1. For the parameter ClusterName, enter the name of the cluster you want to create as its value. (You will need to provide the same cluster name for later tests.)
    2. You can also enter an IP address in the ClusterStaticIP field if a static IP address is assigned to your cluster. Otherwise, leave this parameter blank. The address will be assigned to the cluster name.
    3. Leave other parameters blank unless you are instructed otherwise.
    4. In the Role drop-down list, PrimaryNode should be selected. In the list of machines, confirm that the node you selected in the Selections tab is checked. In addition:
      1. Select TestController in the Role drop-down list, and then select the test controller from the list of machines.
      2. Select OtherNodes in the Role drop-down list, and then select the other nodes in the cluster in the list of machines.
      3. Make sure all of the machines are selected before you continue.

  2. Select OK to run the job. This creates a cluster and sets up S2D.

    run s2d job

  3. A progress bar will appear at the bottom of the HLK Studio window. When the process finishes, a green check mark will appear in the Status column for the test job. If the status displays a red "X" instead, then the test job failed. See Troubleshooting for more information.

This job takes approximately 15 minutes to complete. It can take longer if your machines take more than five minutes to restart, or if you have a large number of disks.

Run tests

Running basic verification tests (BVT)

The BVT performs two types of tests:

  • One test type moves the cluster shared volumes (CSVs) on top of Storage Spaces Direct between nodes while it performs random write I/O. It also verifies that I/O is uninterrupted and that the CSVs do not fail.
  • The other test type brings down a node by stopping cluster service, killing cluster service, evicting node, restarting machines gracefully, and restarting machines ungracefully. (Each action targets a random node.) It also performs random write I/O that targets the appropriate CSV during node failures and verifies that I/O does not fail.

To run these tests in the HLK:

  1. In the Tests tab, select the test S2D - Basic Verification Tests and Run Selected, and then enter the required parameters:
    1. For the parameter ClusterName, enter the name of your cluster. It should be the same name that you provided earlier to set up the cluster.
    2. Do not change or fill in other parameters unless you are instructed otherwise.
    3. In the Role drop-down list, PrimaryNode should be selected. In the list of machines below it, confirm that the node you selected in the Selections tab is checked. In addition:
      1. Select TestController in the Role drop-down list, and then select the test controller from the list of machines.
      2. Select OtherNodes in the Role drop-down list, and then select the remaining nodes in the cluster.
      3. Make sure all of the machines are selected before you continue.

  2. Select OK to start the job. This runs the BVTs.

  3. A progress bar will appear at the bottom of the HLK Studio window. When the process finishes, a green check mark will appear in the Status column for the test job. If the status displays a red "X" instead, then the test job failed. See Troubleshooting for more information.

This job typically takes 30 to 60 minutes to run. For preview releases, the expected pass rate for the BVTs is at least 80 percent.

Running stress tests

Stress tests cause repeated and random node failures (by stopping or killing cluster service). They can potentially cause multiple nodes to fail if that is tolerated by the configuration. During node failures, the test performs multiple I/O streams from multiple nodes that target the appropriate CSV. (Each stream performs sequential/random read/write with read data verification.)

To run these tests:

  1. In the Tests tab in HLK Studio, select the test S2D - Stress Tests and Run Selected, and then enter the required parameters:
    1. For the parameter ClusterName, enter the name of your cluster. It should be the same name that you provided earlier to set up the cluster.
    2. Do not change or fill in other parameters unless you are instructed otherwise.
    3. In the Role drop-down list, PrimaryNode should be selected. In the list of machines below it, confirm that the node that you selected in the Selections tab is checked. In addition:
      1. Select TestController in the Role drop-down list, and then select the test controller from the list of machines.
      2. Select OtherNodes in the Role drop-down list, and then select the remaining nodes in the cluster.
      3. Make sure all of the machines are selected before you continue.

  2. Select OK to run the job. This runs the stress tests.

    run stress tests

  3. A progress bar will appear at the bottom of the HLK Studio window. When the process finishes, a green check mark will appear in the Status column for the test job. If the status displays a red "X" instead, then the test job failed. See Troubleshooting for more information.

For preview releases, the expected pass rate for the stress tests is at least 60 percent. This test job typically takes 45 minutes to an hour to run with default parameters. However, after it passes once with default parameters, we recommend that you run it again with a longer run time by providing a larger value for TestRunTime. (This specifies the core run time in seconds; the job typically runs 15 to 30 minutes longer than this due to test setup and cleanup.) This job supports a run time of up to 24 hours.

Troubleshooting

If a job or test fails, you can check the appropriate logs to discover why it failed. If you need to, you can forward the logs to the appropriate people to help with the investigation. These documents reference each run of a job as a result.

Get test logs

  1. Select the Results tab in HLK Studio while you are in the same S2D project where the tests ran.
  2. Expand the test that you are troubleshooting by selecting the triangle to the left of the test name.
  3. If you have run the test multiple times, multiple results will appear. Each result will display a timestamp and identify the machine where it was run. Right-click on the result you are troubleshooting, and then select Additional Files > Show All. This will open a window in File Explorer that contains the test logs and related logs. show all test logs

  4. The file names of test logs start with "TST-." If multiple test tasks have been run in the test job, there may be multiple test log files. For instance, the BVT may have one test task that performs move CSV and another that performs storage scale unit (SSU) failures. (Due to direct-attached storage topology, each node and its storage is considered one SSU.) The variation name is in the file name (along with Calabria, a code name for Storage Spaces Direct).

    test log file names

  5. If there are multiple test log files, to quickly see which task had failed, first expand the result so that its tasks appear. You can then look for tasks that display a red "X." test failure

In the preceding example, the icons for the tasks indicate that Verify IO with CSV move failed (it shows a red "X" only). They also indicate that Verify IO with SSU Failure was not run and was instead skipped (it shows a red X over curved arrows) due to the previous failure.

After you open a test log file in a text editor, search for "SEV2" to see if the test failed, and if so, why. In the following example, you can see that the space is not in a healthy state after a rack recovery. For additional details on this failure, see Common known issues.

1940.1404 2015/01/09-16:36:14.867 [INFO] 0 : [TST]Space ID: 19CFCDFCC19EB54AAA780436B2B1D859 Pool ID: 5D12DF6A5D4DB444AA3407AFA5749578 Friendly Name: TestSpace Is Manual Attach? Yes Is Clustered? Yes Resiliency Type: 2 Provisioning Type: 2 Number of copies: 3 Number of columns: 1 Fault tolerance: 2 Health: 1 (Warning) State: 11 (InService/Regenerating) Attached on node: RR1FSC2623N05-1 Visible on nodes: RR1FSC2623N05-1 RR1FSC2623N05-2 RR1FSC2623N28-1 RR1FSC2623N28-2 Drives used by this space: [base\cluster\testsrc\common\storagewrapper\swvirtualdisk.cpp@66: ctsw::SWVirtualDisk::QuerySpInfo()] [orchestrator.cpp@192]

Error: 1940.1404 2015/01/09-16:36:14.867 [ SEV2] 0 : [TST]Status=-2147418113(8000FFFFH) 'CalabriaBVT::VerifyIOWithRackFailure' - Unexpected behavior: Space is not in healthy state after rack recovery. [base\cluster\testsrc\calabria\calabriabvt\calabriabvt.cpp@1359 CalabriaBVT::VerifyIOWithRackFailure()] [calabriabvt.cpp@1379]

1940.1404 2015/01/09-16:36:14.867 [INFO] 0 : [TST] Message for error 2147549183 (0x8000ffff): Catastrophic failure [wttlog.cpp@1237]

Error: TAEF: 'TerminateOnFirstFailure' set - ignoring all following tests and attempting to terminate gracefully.

EndGroup: CalabriaBVT::VerifyIOWithRackFailure [Failed]

Error: 1940.1404 2015/01/09-16:36:14.867 [SEV2] 0 : [TST]Status=-2147418113(8000FFFFH) 'CalabriaBVT::VerifyIOWithRackFailure' - Unexpected behavior: Space is not in healthy state after rack recovery. [base\cluster\testsrc\calabria\calabriabvt\calabriabvt.cpp@1359 CalabriaBVT::VerifyIOWithRackFailure()] [calabriabvt.cpp@1379]

Sample output from stress tests for this issue:

1148.035C 2015/01/12-14:41:10.489 [INFO] 0 : [TST]Waiting for all spaces to become healthy. Space 19CFCDFCC19EB54AAA780436B2B1D859 state is InService/Regenerating [calabriastress.cpp@938]

Error: 1148.035C 2015/01/12-14:41:10.489 [SEV2] 0 : [TST]Status=258(102H) Fail validation: Not all spaces reached healthy state within timeout of 1200000 ms. May continue waiting until wait timeout. [calabriastress.cpp@962]

1148.035C 2015/01/12-14:41:10.505 [INFO] 0 : [TST] Message for error 258 (0x102): The wait operation timed out. [wttlog.cpp@1237]

Get cluster and storage diagnostic logs

To get the cluster and storage diagnostic logs for a failed result:

  1. Expand the failed result so its test tasks are showing.

  2. Right-click on the task RunJob-Generate cluster and storage diagnostic logs, and then select Task Logs > Show All. This opens a window in File Explorer that contains the cluster and storage diagnostic logs. These logs can provide additional details on why the test failed.

    show task logs

Send logs to Microsoft for test failure analysis

If you need to send logs to Microsoft for help in test failure analysis, please see the Package the results section for steps to create the .HLKX result package. This package will contain relevant logs generated and gathered by tests, and will help in analysis of failures.

Common known issues

The most common cause of test failures is due to one or more spaces taking too long to regenerate data (in a state of service/regeneration for too long) after a node or nodes were brought down and recovered. Uneven storage performance can cause regeneration to exceed timeout and cause tests to fail. If you see this issue frequently, your configuration may have performance bottlenecks. If this is the case, we recommend that you check your storage, network performance, and remote direct memory access (RDMA).

Sample output from BVT for this issue:

1940.1404 2015/01/09-16:36:14.867 [INFO] 0 : [TST]Space ID: 19CFCDFCC19EB54AAA780436B2B1D859 Pool ID: 5D12DF6A5D4DB444AA3407AFA5749578 Friendly Name: TestSpace Is Manual Attach? Yes Is Clustered? Yes Resiliency Type: 2 Provisioning Type: 2 Number of copies: 3 Number of columns: 1 Fault tolerance: 2 Health: 1 (Warning) State: 11 (InService/Regenerating) Attached on node: RR1FSC2623N05-1 Visible on nodes: RR1FSC2623N05-1 RR1FSC2623N05-2 RR1FSC2623N28-1 RR1FSC2623N28-2 Drives used by this space: [base\cluster\testsrc\common\storagewrapper\swvirtualdisk.cpp@66: ctsw::SWVirtualDisk::QuerySpInfo()] [orchestrator.cpp@192]

Error: 1940.1404 2015/01/09-16:36:14.867 [SEV2] 0 : [TST]Status=-2147418113(8000FFFFH) 'CalabriaBVT::VerifyIOWithRackFailure' - Unexpected behavior: Space is not in healthy state after rack recovery. [base\cluster\testsrc\calabria\calabriabvt\calabriabvt.cpp@1359 CalabriaBVT::VerifyIOWithRackFailure()] [calabriabvt.cpp@1379]

Sample output from stress tests for this issue:

1148.035C 2015/01/12-14:41:10.489 [INFO] 0 : [TST]Waiting for all spaces to become healthy. Space 19CFCDFCC19EB54AAA780436B2B1D859 state is InService/Regenerating [calabriastress.cpp@938]

Error: 1148.035C 2015/01/12-14:41:10.489 [SEV2] 0 : [TST]Status=258(102H) Fail validation: Not all spaces reached healthy state within timeout of 1200000 ms. May continue waiting until wait timeout. [calabriastress.cpp@962]

1148.035C 2015/01/12-14:41:10.505 [INFO] 0 : [TST] Message for error 258 (0x102): The wait operation timed out. [wttlog.cpp@1237]

Package the results

After all of the tests have completed successfully, and while you are still in the same project in HLK Studio, select the Package tab, and then Create Package in the lower-right corner. When you are prompted for Signing Options, select Do not sign. Save the results to a file. This file needs to be included in any S2D certification submission.

Terms

Term | Description
BVT | Basic verification tests.
CSV | Cluster shared volumes.
DAS | Direct-attached storage.
HCK | (Windows) Hardware Certification Kit, the previous kit for certification testing.
HLK | (Windows) Hardware Lab Kit, a test framework used to help validate hardware configurations for Windows. It is also used to run the tests described in this topic.
HLKC | HLK Controller, the server that the administrator uses to run tests and manage other machines. This must not be part of the cluster.
TC | Test controller, the server that some tests are run on to target the cluster. This must not be part of the cluster.
S2D | Storage Spaces Direct.

Additional resources

Windows Hardware Lab Kit


HLK Developer Guide

Microsoft provides an API for partners that want to automate testing using the HLK.


HLK API Overview

You can use the Windows Hardware Lab Kit (Windows HLK) API to automate any parts of the certification test process. The API exposes all functionality of Windows HLK Studio, so you can use both Windows HLK Studio and automation in your certification test workflow.

The Windows HLK API supports any Microsoft® .NET Framework 4.0 (and later) programming language (for example, C# and Windows PowerShell). This document provides a detailed description of the Windows HLK API.

NOTE

HLK Studio uses the HLK APIs described here. You cannot run scripts or applications that access the HLK APIs and simultaneously interact with HLK Studio. Before interacting with HLK Studio, make sure your scripts and/or applications are no longer running.

Related topics

HLK Studio


HLK API Prerequisites

You must install HLK Studio before you can use the HLK object model. The Windows HLK Prerequisites also apply.


HLK API Glossary

This section provides definitions of commonly used words or terms in the Windows Hardware Lab Kit (Windows HLK) API.

c

certification content

Certification content is the set of tests to run for each requirement (that is, the collection of tests, test binaries, media files, and anything else that's associated with a test) for certification.

d

device ID

The device ID is a string value that uniquely identifies a device on a specific computer.

f

feature

A feature is a property, interface, or implementation of a target.

For devices, a feature can be, for example, a device that's connected via USB, or one that has a kernel-mode driver, or one that exposes a network interface.

For systems, a feature can be the number and type of processors, whether it has Bluetooth connectivity, or whether it supports suspended states.

feature set

A feature set is the collection of features that a specific target exposes.

h

hardware ID

The hardware ID is a collection of string values that should provide the information to verify whether a driver should be loaded for a device.

l

logical machine set

A logical machine set (LMS) is a collection of computers where each computer is assigned a specific role. You use an LMS when you're scheduling a job that runs across several computers.

p

platform

A platform is represented by the OSPlatform class. OSPlatform defines the specific operating system and architecture of a computer, and whether a computer is a client or server.

product

A product consists of all the targets that you include in a certification submission.

t

target

A target is a device, driver (or filter driver), system, or object that you can query for properties by using the Windows HLK API. The Target class represents a single target. The TargetFamily class represents a group of test targets.

Each target is unique to the computer that it's on. It's assumed that the target will persist on its computer between reboots.

A typical certification submission has multiple targets that use instances of hardware from several platforms.

target data

The TargetData class is a dynamic representation of what's available on a computer, and it can't be tested. TargetData elements can change as hardware is added or removed from the test computer, or in response to system events, power management, load conditions, and other conditions.

TargetData is enumerated by the computer under test. TargetData can change as hardware is added or removed from the test computer.

You select a TargetData object to test, and that object is passed to the TargetFamiley.CreateTarget(TargetData) method to create a Target object.

target ID

The target ID is a string key that identifies a target on a computer. If the target is a DevNode, the target ID can be the device instance ID. For an application, the target ID can be a .msi GUID.

test set

A test set consists of one or more tests.


HLK Object Hierarchy

The Windows Hardware Lab Kit (Windows HLK) uses all the features of the object model, although the GUI hides many of the details.

The following illustration shows the object model hierarchy for the Microsoft.Windows.Kits.Hardware.ObjectModel namespace.

NOTE

This illustration doesn't include every object in the Microsoft.Windows.Kits.Hardware.ObjectModel namespace.

windows hlk object model hierarchy


Device Family

A DeviceFamily object is a collection of hardware IDs that are cached in the data store under a common name. DeviceFamily is useful for treating a large number of devices that have different hardware IDs as one device to test in parallel. For example, a video-card manufacturer might have 100 different video cards (with different hardware IDs) that all have essentially the same functionality.

NOTE

Hardware IDs that are added to a DeviceFamily must match the hardware IDs that Windows reports for a device.


Targets

Any object that you can test by using the Windows Hardware Lab Kit (Windows HLK) is a target. Most devices have several hardware ID components (that is, targets) that must be tested. You can query any target for its properties. Targets can be any of these:

  • Devices (for example, a mouse or keyboard)

  • Systems (that is, a computer that you test as a unit)

  • Filter drivers (for example, antivirus drivers)

A typical certification submission has multiple targets that use hardware on several platforms.

A test target can provide data about how to run a test by dynamically resolving test parameters based on target data. So if a test must identify a device ID, that device ID can be resolved and specified when you schedule a test.

Each target has an associated .xml file. This data file is the collection of all applicable gatherer data for that target. It's used for detecting features, running tests, and reporting.

You can specify some tests to run on one target in a TargetFamily object. Other tests must run on each target in a TargetFamily.


Target Families

A TargetFamily is a collection of targets on different computers where:

  • Each target's hardware ID matches an entry in the DeviceFamily.

  • The parent computer is in a common ProductInstance.

For example, if you're testing a mouse on several computers, a TargetFamily can represent all the common hardware IDs for a device node (devnode), one on each computer. You can use this representation to run many parallel tests on hardware collections.

It's important to note the difference between TargetFamily and ProductInstance. ProductInstance is a collection of dissimilar targets that are sold in one box to a customer. TargetFamily is a collection of hardware that (for testing) can be treated identically.

Not all the features that are found on one instance of a Target in a TargetFamily are available on all instances of targets within that TargetFamily.

The TargetFamiley.GetTests() method gets a list of all the tests that are required for a TargetFamily, but not all the features that are found on a Target will be found on all targets. For this reason, the TargetFamily.GetFeatures() method returns a list of all features that are found on any Target.


Target Data

Both the Target object and the TargetData object represent an instance of a test target on a computer. Both are based on Sysparse data for the computer. However, TargetData is a dynamic representation of what's available on a computer at a particular time. TargetData elements can appear or disappear in response to system events, power management, load conditions, and other conditions.

After you select a TargetData object for testing, its data is copied to the Target list and a new object is created.

The read-only Target.XmlData property is used both for parameter resolution and feature detection. It contains the raw correlator data that has been returned for a device, and it's used for feature detection and parameter resolution during testing.

The required Target.Name property is a string that's used to identify the target to the user.


Adding a Target to a Product Instance

Use the ProductInstance.AddTarget() method to add a target directly to a ProductInstance object. These are the required steps for adding a target:

adding a target to a productinstance


Features and Requirements

A feature can be a property (for example, a kernel mode device driver), a bus, an interface, or capability (for example, a device that prints) of a target. Feature objects contain a list of requirements that are children of the Feature. Use the TargetType property to determine whether a feature applies toward a specific target.

A requirement (for example, "all PCI devices must do x") maps to only one feature. Tests are mapped against requirements, so if a feature is found, you must run all the corresponding tests for its requirements.

A feature can apply to only a subset of operating system versions or platforms. For example, a requirement might apply to only Windows 7 x86, or to it might apply to Windows 8 (x86) and Windows 8 (x64) (but not Windows Server 2012).


ProductType

The ProductType object represents a type of product (for example, a printer or a scanner), and is a collection of Feature objects. For example, ProductType for a basic printer might require only the "device.prints" feature, but ProductType for a business printer might require "device.prints" and "device.prints-2-sided" features. ProductType is mostly used for reporting and categorizing a submission, and it has no bearing on test selection or other processing.

ProductType is determined at the product instance level. For example, if ProductType for a small business printer requires both "device.prints" and "device.scanner" features, a product instance that has one Target object of type printer and another Target object of type scanner is allowed

The product taxonomy is a means of categorizing product types into well-known groups and is provided by the Windows Certification Program team.


Tests

Tests map to one or more requirements and are assigned to a specific target (as shown in the following illustration). You can use this mapping to determine which tests are required for each certification submission that you create.

Each test has a pass/fail status, which is the aggregate of all the test results.

When you schedule a test, the outcome (that is, a TestResult object) is instantiated.

Test result status is tracked in the following ways:

  • If a test has any passing result, it's marked as Passed, and the total passing count is incremented.

  • If a test is both running and waiting to run, it's marked as Running, and the running count is incremented.

  • If a test has a failed result, it's marked as Failed, and the total failed count is incremented.

  • If a test has not yet run or has been canceled, it's marked as NotRun, and the NotRun count is incremented.

The TotalCount property represents the number of all the tests that are passing, failing, and not yet run. If a test has previous Running/InQueue results, the results are deleted when a new test starts.

A TestResult object is a test outcome. It's instantiated when a test is scheduled. TestResult includes information such as start/end time, pass/fail count, logs, and task results. You can schedule a test to run multiple times, and each test pass has its own result.

Related topics

Distributing Tests

Scheduling Tests

Machine Sets

Setting Test Parameters

Running Tests

Exporting Test Results


Distributing Tests

You can run a test on all the targets in a TargetFamily, or you can run a test on a subset of TargetFamily targets.

Note that there is no hierarchical relationship from TargetFamily to Target to tests. If you try to create such a hierarchy, all your distributable tests and their results will be duplicated. Also, the Target.GetTestResults() method might return results from the wrong target.

Here's an example test distribution:

System tests are also distributable. The hardware Id for systems is always [SYSTEM].


Scheduling Tests

Use the Test.QueueTest() method to put all your tests in a queue that will run on client computers.

If a test is associated with more than one target (and therefore more than one computer), the test is scheduled so that it runs on the first available computer. Scheduling is limited to computers that are in the correct machine pool at the time of scheduling and are in a ready or running state. If a computer isn't ready at the time of scheduling, the test won't run on that computer.

You can't schedule a test if no computers are found, and you can't add computers that are later available.


Machine Sets

A MachineSet object is a collection of machine roles, and a machine role is a collection of computers that run the same test binaries. You must create a valid MachineSet to allocate and assign computers for any test that requires multiple computers.

Although most tests in the Windows Hardware Lab Kit (Windows HLK) run on a single computer, some tests require multiple computers. For example, a network test might target a network adapter on one computer, and a second computer might act as a network message receiver. In this example scenario, each computer runs different (but coordinated) binaries for one test.

For the preceding scenario, the machine set has two roles, and each role has one computer.

In a more complex scenario (for example, testing server load stress), you might have one target computer, 10 client computers that make simultaneous requests on the target computer, and one test coordinator computer to synchronize clients and record results.

MachineRole

A MachineRole object is a list of computers that perform a specific test role. Use the AddMachine() method to add a computer to a role. AddMachine() returns an error if you add a computer that isn't in the correct machine pool or if the maximum number of computers is exceeded.

This example shows how to display the role for each computer in a MachineSet object:

Machine secondaryMachine = GetSecondaryMachine();
Test test = GetTest();

MachineSet machineSet = test.GetMachineRole();

foreach (MachineRole role in machineSet.Roles)
{
    Console.WriteLine("Role : " + role.Name);
    Console.WriteLine("Min : {0} Max : {1}" + role.Minimum, role.Maximum);
    Console.WriteLine("isPrimary {0}", role.Primary);

    Console.WriteLine("Allocated machines: ");
    foreach (Machine machine in role.GetMachines())
    {
        Console.WriteLine("\t" + machine.Name);
    }
}

If you want to add a secondary machine to Roles[1], you can use this:

machineSet.Roles[1].AddMachine(secondaryMachine);
if (machineSet.Validate())
{
Test.QueueTest(machineSet);
}


Setting Test Parameters

Use the SetParameter() method to set parameters for the current instance of a Test or as the default value for subsequent test runs.

You can also use SetParameter() to find all instances of the same name for all of a target's tests. For example, you could find every parameter with the name TargetIPAddress in a large group of tests.

Here's an example of how to set a Test parameter:

Test myTest = SomeClass.GetTest();
myTest.SetParameter("TargetIpAddress", "1.2.3.4", ParameterSetAsDefault.ApplyToAllTargets);

When you use the ParameterSetAsDefault.ApplyToAllTargets() method, all tests that are associated with the current target are searched, and all parameters that have the same parameter name are set via the supplied values. This parameter setting doesn't span targets within a target family.


Running Tests

Use the QueueTest() method to run all tests that are children of this object.

When you call QueueTest(), the Windows Hardware Lab Kit (Windows HLK) verifies these items:

  • The target is present.

  • The target computer is running the correct operating system.

  • The computer is in the correct machine pool and hasn't moved.

  • The target computer is in the "ready" or "running" state.

If any of the preceding checks fail, a ScheduleException occurs.

If the instance of QueueTest() is used for a test that takes a logical machine set and no logical machine set is used to schedule, a ScheduleException occurs. Similarly, if the logical machine set that is used is incompatible with the one that's required for a test, a ScheduleConstraintException occurs.


Exporting Test Results

Use the Export(string outputLocation) method to export a result that can be run standalone to the specified location on the local file system. Before calling Export(), check the value of CanExport to determine whether the test result can be exported.

When you call Export(), the Windows Hardware Lab Kit (Windows HLK) verifies these items:

  • A machine is still associated with the test result. If the machine association with the test result has been removed, the result may not be exportable.
  • Tests must have been executed and completed with a passed, failed, or cancelled status.
  • The test run must successfully return infrastructure logs from the client system. These files are necessary to export the test.
  • Only single machine tests can be exported. Tests that require multiple machines to execute are not exportable.
  • Tests must be run using the HLK desktop client. Test runs on OneCore or Proxy Mobile Client systems are not exportable.
  • Tests tagged as non-exportable due to known infrastructure issues or other reasons are not exportable.

If any of the preceding checks fail, a TestException is thrown. The CanExport method automatically verifies these items without throwing an exception and can be used to filter out non-exportable test results.

The output directory specified by the outputLocation parameter will be created if it doesn't exist. Under the directory specified by outputLocation, two directories and one file will be created:

  • The infrastructure directory contains an installer with an executable called setup(architecture).exe, where architecture is the architecture of the machine on which the test was originally run. Running setup(architecture).exe installs the components required to run the standalone test on a target system.
  • The test directory contains a batch file plus the binaries required to run the test. Copying the directory to the target system and running the run.cmd file from an elevated command prompt from within the directory containing run.cmd starts standalone test execution of the test on the target system. The directory must not contain any spaces, as this will cause some tests to fail.
  • Readme1st.txt contains instructions and notes on how to run the infrastructure installer and the test.

Exporting different tests to the same directory will succeed as long as the same test is not exported to the directory twice. The Infrastructure and readme1st directories will simply be overwritten if they already exist.

For more information, including how to export a failed HLK job from within the HLK, see Exporting a Failed HLK Job.

Related topics

IRunExport Interface


Working with Projects

This topic describes the classes that you use to work with projects.

ProjectManager Class

The ProjectManager class represents a connection to a server and provides access to all data. Other classes (for example, filters, instances of the MachinePool class, and instances of the Requirement class) can be accessed or enumerated through ProjectManager.

The ProjectManager class is abstract. To create a ProjectManager instance, you invoke a child class. Each instance is a connection to a specific data set.

One implementation of ProjectManager accesses a Windows Hardware Lab Kit (Windows HLK) controller computer. Another ProjectManager implementation accesses a submission package. In both cases, you use the same methods, and automation code that's written for one instance should work without modification for the other instance.

To connect to a Windows HLK controller, you can use this code:

using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;
ProjectManager manager = new DatabaseProjectManager(controllerName);

To connect to a submission package, you can use this code:

using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;
ProjectManager manager = new PackageProjectManager(pathToSubmissionPackage);

Project Class

Each instance of the Project class represents a certification submission you send to Microsoft. It contains platform information like operating system, architecture, and edition. You use classes from the Microsoft.Windows.Kits.Hardware.ObjectModel.Submission namespace to combine projects from different systems into submissions.

You can create a project property (that is, a named value), set or update a project property, or delete a project property. You can't create duplicate property names.

You can create, rename, or delete a project. If you delete a project, all subordinate objects, including results, are deleted. You can't create duplicate project names.

ProjectInfo Class

Each instance of the Project class has a collection of associated properties.

You can use the ProjectInfo class to include supplemental project information. (For example, you can create a "manufacturer" property). You can also set, update, or delete a ProjectInfo property. You can't create duplicate property names.


ProductInstance

The ProductInstance class is a specific example of a product on a specific OSPlatform. Note that you can test multiple versions of a product type on multiple computers. However, each platform (that is, the combination of operating system and architecture) must be tested individually, in parallel with the other instances. Unlike the DeviceFamily and TargetFamily classes, ProductInstance is a collection of dissimilar devices, whereas TargetFamily is a collection of essentially identical devices.

Using the example of a printer, there would be a separate ProductInstance class for each printer for every OSPlatform. Each ProductInstance class might have a printer Target or TargetFamily class as a child, in addition to a scanner target and a memory card reader target.

Each ProductInstance class is named. The Name value must be unique to each project. Unlike a project, you can't rename a ProductInstance class. Each ProductInstance class is associated with a specific MachinePool. This MachinePool can be shared with other ProductInstance classes.

ProductInstance has several FindTargetFrom\* methods. Each method searches across computers in a machine pool and returns TargetData for each target that meets the filter criteria. The caller must verify that all the targets that it meant to return are returned.

TargetData is an abstract target (that is, it's what can be tested). Target is what you test. You select a TargetData object by using one of the FindTarget\* methods, and then call CreateTarget() to promote that TargetData to a Target class for testing.


Machines and Machine Pools

The Machine class represents a computer that can be used for testing and that contains devices to be tested. Computer properties represent Windows Test Technology (WTT) dimensions. Dimensions can be added, removed, or reset based on the underlying WTT behavior.

The Machine.Status property indicates whether a computer is available for testing and if it's currently running tests.

The MachinePool class represents a logical grouping of zero or more computers, and it represents WTT ResourcePool objects that WTT uses natively for scheduling and testing. Machine pools are hierarchical (that is, a machine pool can have child machine pools). A machine pool doesn't represent any physical computers.

NOTE

The ProductInstance.MachinePool property is null for product instances loaded via Package Manager (.

These common machine pools are in every controller:

  • Root ($), which contains all other machine pools. The root doesn't contain individual computers, it can't run jobs, and it has no special properties. Use the RootPool property to access the root machine pool.

  • System, which contains all controller components and is hidden. System is a reserved name.

  • Default, which newly detected computers are automatically added to. Computers in machine pools that are marked for deletion are moved to the default machine pool. Computers in the default machine pool can't be used or change status.

When you delete a machine pool, the deletion operates recursively. All computers in the affected pool are moved to the default pool. Deleting a machine pool doesn't affect results or logs. When you delete a computer, all corresponding test results and history are deleted, and logs are orphaned.


Filtering

Filtering is post-processing of failed task results that match predefined filter criteria and override "fail" task result status to "pass". You can then submit a package for certification for various targets.

A filter represents a set of constraints that you can use to reduce a set of task results. When a task result fails, the log nodes in the selected filters are matched against the task result logs. The fail/pass count for the task results are adjusted based on the number of test cases that are filtered in the log.

A filter is uniquely identified by its filter number and version. Filter status and expiration date indicate whether a filter is active or expired. The title gives a brief description about the filter. Issue description and resolution give more details about the issue and its resolution.

These are the types of filters:

  • Errata, for handling test failures that are due to bugs in test content, operating system, or Windows Hardware Lab Kit (Windows HLK) infrastructure.

  • Contingency, to grant exceptions for specific hardware failures.

  • Auto triage, for troubleshooting the causes of failures. Unlike the errata and contingency filters, the auto triage filters don't change the task results from fail to pass.

Applying Filters

You can apply filters to a project that has failed task results. Before you apply a filter, make sure that you have updated the controller with the latest filters from Windows Quality Online Services (Winqual). If there are matching filters on the controller for a failed task result, the task result is filtered. However, a task result can be partially filtered (that is, the number of filtered failures is less than the total number of failures in the task result).

string projectName = "existing project";
string controllerName = args[0];

// first, connect to the server
ProjectManager manager = new DatabaseProjectManager(controllerName);

// load the project that has failing task results
Project project = manager.GetProject(projectName);

// instantiate the filter engine for the database project manager
DatabaseFilterEngine filterEngine = new DatabaseFilterEngine(manager);

// apply filters to the project; will try to find matching filters for
// the failing task results in the project
// it's a synchronous (or blocking) call, and depending on the size of
// the log files and the number of task results to be filtered in the
// project, the Filter method might take a while
filterEngine.Filter(project);

// retrieve the filters that were applied to the project
ReadOnlyCollection<IFilter> appliedFilters = project.GetAppliedFilters();
Console.Out.WriteLine("{0} filters were applied for project {1}",
 appliedFilters.Count, projectName);

Downloading the latest filters

You can download the latest filters from the following location:

  • Windows Hardware Lab Kit Filters


Logging

The Windows Hardware Lab Kit (Windows HLK) API logs all events to a "Windows Hardware Certification Kit" event log (in Applications and Services Logs) in Event Viewer.


Handling Exceptions

Error reporting occurs exclusively through the exception classes.

Exception class | Description
ConnectionException | Base class for Microsoft® SQL Server® or network connection errors. A ConnectionException class can also occur from logon or permission issues.
DataIntegrityException | Representation of data integrity errors.
MachineException | Representation of computer-specific errors.
ProductInstanceException |
ScheduleException |
ProjectException | Base class for all logo manager exceptions.
ProjectManagerException | Base class for all Windows Hardware Lab Kit (Windows HLK) API exceptions.
RequirementException | Representation of exceptions that are related to requirements.
ScheduleException | Base class for all Windows HLK Studio exceptions.
TargetException | Class that contains constructors that are used to initialize TargetException objects.
TestException | Representation of exceptions that are related to certification tests.


Creating a Submission Package

NOTE

We highly encourage you to include driver symbols as part of package creation. Including symbols enables Microsoft to triage and root cause issues related to your driver.

A submission package contains all of the results, logs, and data from a project. A submission package can also contain drivers, symbols, and supplemental material that are required for certification. The submission package can then be accessed through the same set of Certification Manager APIs.

The steps to create a submission package are:

  1. Create an instance of a PackageWriter class and specify the project to use.

  2. Add any necessary driver packages.

  3. Add any supplemental content.

  4. Set a notification callback (if desired) by using the PackageWriter.SetProgressActionHandler() method.

  5. Call the PackageWriter.Save() method, which saves all project and test information and logs to a compressed .wlkx package file. The Save() method also has an override to take an X.509 signing certificate as a parameter.

If you include a driver package, you specify a directory that contains all of the files and/or symbols in the AddDriver() method. Each driver package is associated with one or more targets in a project. From this mapping, Microsoft can identify which operating systems and architectures your driver has been tested against.

Each driver package has a list of locales (available with the ProjectManager.GetLocaleList() method). Every target and locale combination should have only one driver associated with it.


HLK API Samples

This section describes sample code that you can use to access the Windows Hardware Lab Kit (Windows HLK) API.

In this section:

Topic | Details
Hello World | This sample is a basic introduction to how to create a project, run tests, and create a package.
List Projects | This sample lists all projects in a controller and prints basic information about each.
Target Families | This sample shows how to create target families and run tests against them.
Advanced scheduling | These samples demonstrate advanced scheduling scenarios.
Creating a Package | This sample describes the steps of creating a package from a project.
Diagnostic Bugcheck Summary | This sample shows how to retrieve and display a diagnostic bugcheck summary for a test that fails during a system crash.
Exporting a Test Result | This sample shows how to export a failed test result so that it can be run on a machine outside of the full HLK environment.
Extracting Log Files from a Package | This sample shows you how to extract log files from a package.
Filtering | This sample shows how to apply filters to a project and retrieve filters from a project.
Finding missing tests | This sample shows how to find tests that are missing from a package.
Machine Pool Growth | This sample uses the Machine Pool Growth feature to add and automatically redistribute tests to targets after a test has been scheduled.
Machines in use | This sample shows how to retrieve the names of machines on which tests are currently running.
Manage Machine State | This sample shows how to manage machine stated.
Mobile Reflash Before a Test Run | This sample shows how to flash an OS image onto a mobile device as part of a test run.
Multi-Device Tests | This sample shows how to run multi-device tests.
Project Definition File schema | This sample defines the format of the Project Definition File.
Schedule Information | This sample shows the usage of the DistributionOption enumeration and the new test metadata flags.
Schedule test by Development Phase | This sample demonstrates a few ways to schedule tests.
Test Collection File schema | This sample defines the format of the Test Collection File.

Resource Files

The samples in this section require the following resource files. Install the HLK to obtain these files. To use the DLLs in your Visual Studio project, click Project, click Add Reference, and then click Browse to navigate to each file.

  • microsoft.windows.kits.hardware.logging.dll

  • microsoft.windows.kits.hardware.objectmodel.dbconnection.dll

  • microsoft.windows.kits.hardware.objectmodel.dll

  • microsoft.windows.kits.hardware.objectmodel.submission.dll

  • Microsoft.WTT.Diagnostics.dll

  • WTTOMBase.dll

  • WTTOMDimension.dll

  • WTTOMFeature.dll

  • WTTOMIdentity.dll

  • WTTOMJobs.dll

  • WTTOMParameter.dll

  • WTTOMResource.dll

  • WTTOMSQLProvider.dll


Hello World

This sample shows how to create a project, run tests, and create a package for submission.

C#

//-----------------------------------------------------------------------
// <copyright file="HelloWorld.cs" company="Microsoft">
//    Copyright © Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

namespace Samples
{
    using System.Collections.ObjectModel;
    using System.Linq;
    using System.Threading;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;

    public class HelloWorld
    {
        public static void Main(string[] args)
        {
            string projectName = "my new project";
            string operatingSystemType = "Windows 7 x64";
            string controllerName = args[0];

            // first, connect to the server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            //---------------
            // computer and machine pool management
            //---------------
            // now, create a machine pool
            MachinePool rootPool = manager.GetRootMachinePool();
            MachinePool testPool;

            testPool = manager.GetRootMachinePool().GetChildPools().Where(x => x.Name == "TestPool").FirstOrDefault();
            if (testPool == null)
            {
                testPool = manager.GetRootMachinePool().CreateChildPool("TestPool");
            }

            // the next line enumerates all the computers in the default pool
            // where the operating system type of the computer is "Windows 7 x64"
            // note that this uses the LINQ Where extension
            foreach (Machine machine in rootPool.DefaultPool.GetMachines().Where(x => x.OSPlatform.Description == operatingSystemType))
            {
                // each of these computers is then moved into the test pool
                rootPool.DefaultPool.MoveMachineTo(machine, testPool);
            }

            // now, make sure that the computers are in a ready state
            foreach (Machine machine in testPool.GetMachines())
            {
                machine.SetMachineStatus(MachineStatus.Ready, -1);
            }

            //---------------
            // creating a project
            //---------------
            Project project = manager.CreateProject(projectName);

            OSPlatform platform = testPool.GetMachines().First().OSPlatform;
            ProductInstance pi = project.CreateProductInstance(platform.Name, testPool, platform);

            // this is the hardware ID that corresponds to most keyboards, which all systems seem to have
            ReadOnlyCollection < TargetData > data = pi.FindTargetFromId(@"HID_DEVICE_SYSTEM_KEYBOARD");

            // the findTargetXXX methods return a list of potential targets
            // for now, just use the first one that's found
            pi.CreateTarget(data.First());

            //---------------
            // running tests
            //---------------
            // this will schedule all tests that are associated with this project
            project.QueueTest();

            // at this point, all jobs should be scheduled to run
            // poll to wait to see whether anything is still running
            while (project.Info.Status == ProjectStatus.Running)
            {
                // sleep for 1 minute
                Thread.Sleep(60 * 1000);
            }

            //---------------
            // wrapping up results
            //---------------
            // create wrap-up package
            Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageWriter package = new PackageWriter(project);

            // note: the .wlkx extension is added automatically
            package.Save(project.Name);
        }
    }
}

PowerShell

$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

Clear-Host

write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file HelloWorld.ps1"

$connectFileName = $env:WTTSTDIO + "connect.xml"
Write-Host Opening connection file $connectFileName
$connectFile = [xml](Get-Content $connectFileName)

$ControllerName = $connectFile.Connection.GetAttribute("Server")
$DatabaseName = $connectFile.Connection.GetAttribute("Source")

$Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, $DatabaseName

$RootPool = $Manager.GetRootMachinePool();
$TestPool = $Manager.GetRootMachinePool().CreateChildPool("TestPool");

$RootPool.DefaultPool.GetMachines() |
    Where { $_.Status -EQ "NotReady" } |
    foreach {  $_.Pool =  $TestPool  }

# Now set these machines into the ready state
$TestPool.GetMachines() |
    foreach { $_.SetmachineStatus([Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::Ready, -1) }

#-----------
# Creating a project
#-----------
$Project = $manager.CreateProject("My New Powershell Project")

$OSPlatform = $TestPool.GetMachines()[0].OSPlatform
$ProductInstance = $Project.CreateProductInstance("My Product Instance",
                                                 $TestPool,
                                                 $OSPlatform)

#this is the hardware id that corresponds to MOST keyboards, which all systems seem to have.
$data = $ProductInstance.FindTargetFromId("HID_DEVICE_SYSTEM_KEYBOARD")

# the findTargetXXX api's return a list of potential targets,
# for now, just use the first one found
$ProductInstance.CreateTarget($data[0])

#---------------
# Running tests
#---------------
# this will schedule all tests associated with this project
$Project.QueueTest()

# At this point, all jobs should be scheduled to run
# poll to wait to see if anything is still running
while ($Project.Info.Status -eq [Microsoft.Windows.Kits.Hardware.ObjectModel.TestResultStatus]::Running)
{
# sleep for 1 minute
    [Thread]::Sleep(60 * 1000)
}

#---------------
# wrapping up results
#---------------
# create wrap-up package
$Package = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageWriter -args $Project

# NOTE: the .HLKX extension is NOT added automatically
$projectSaveFile = [IO.Path]::ChangeExtension($Project.Name, "HLKX")
$Package.Save($projectSaveFile)


List Projects

These samples list all projects in a controller and print basic information about each project.

C#

//-----------------------------------------------------------------------
// <copyright file="ListProjects.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

namespace Samples
{
    using System;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    class ListProjects
    {
        public static void Main(string[] args)
        {
            string controllerName = args[0];

            // first, connect to the server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // list all projects
            Console.WriteLine("Listing all projects");
            foreach (string name in manager.GetProjectNames())
            {
                Console.WriteLine("Project {0}", name);
            }

            // list all projects, and get the basic status of each
            Console.WriteLine("\nGetting all project status");
            foreach (ProjectInfo info in manager.GetProjectInfoList())
            {
                Console.WriteLine("Project {0}", info.Name);
                Console.WriteLine("\t status : {0}", info.Status);
                Console.WriteLine("\t not run: {0}", info.NotRunCount);
                Console.WriteLine("\t passed : {0}", info.PassedCount);
                Console.WriteLine("\t Failed : {0}", info.FailedCount);
                Console.WriteLine("\t Running: {0}", info.RunningCount);
            }

            // list all the tests for each project
            Console.WriteLine("\nGetting all projects and their tests");
            foreach (string name in manager.GetProjectNames())
            {
                Project project = manager.GetProject(name);

                Console.WriteLine("Project name : {0}, status: {1}", project.Name, project.Info.Status);

                foreach (ProductInstance pi in project.GetProductInstances())
                {
                    Console.WriteLine("Product Instance : {0}, Machine Pool : {1}, Platform type : {2}", pi.Name, pi.MachinePool.Name, pi.OSPlatform.Description);

                    foreach (Target target in pi.GetTargets())
                    {
                        Console.WriteLine("Target Name : {0}", target.Name);

                        foreach (Test test in target.GetTests())
                        {
                            Console.WriteLine("\tTest : {0}, status : {1}", test.Name, test.Status);
                        }
                    }
                }
            }

        }
    }
}

PowerShell

. ..\Initialization.ps1

write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file ListProjects.ps1 "
write-host "or to connect to a package file "
write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file ListProjects.ps1 <<PackageFileName>>"

$PackageName = $args[0]

# we need to connect to the Server
if ($PackageName -eq $null -OR $PackageName -eq "")
{
    # create the default manager
    $Manager = initialize
}
else
{
    write-host connecting to the package $PackageName
    # need to call into the init function to load the DLLS
    # assign to unused to prevent the default manager from writing to the console
    $Unused = initialize

    # now load from a package
    $Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageManager -Args $PackageName
}

$RootPool = $Manager.GetRootMachinePool();

# first get a list of all projects
write "All project names on this controller"
$Manager.GetProjectNames()

# List all projects, and get the basic status of each
$Manager.GetProjectInfoList() | foreach {
    write-host "Name   : " $_.Name
    write-host "`tStatus : " $_.Status
    write-host "`tNotRun : " $_.NotRunCount.ToString()
    write-host "`tPassed : " $_.PassedCount
    write-host "`tFailed : " $_.FailedCount
    write-host "`tRunning: " $_.RunningCount
    }

# Listing all of the Tests for each project
$Manager.GetProjectNames() | foreach {
    $Project = $Manager.GetProject($_)

    write-host "Project Name  : " $Project.Name  -ForegroundColor DarkCyan
    write-host "`tProject Status: " $Project.Info.Status

    # Listing all of the product instances
    $Project.GetProductInstances() | foreach {
        write-host "Product Instance : " $_.Name  -ForegroundColor DarkCyan
        write-host "`tMachine pool : " $_.MachinePool.Name
        write-host "`tOS Platform : " $_.OSPlatform.Description

        $_.GetTargetFamilies() | foreach {

            write-host "Target Family : " $_.Family.Name -ForegroundColor DarkCyan

            # get target data
            $_.GetTargets() | foreach {
                write-host "Target : " $_.Name  -ForegroundColor DarkCyan
                write-host "`tType : " $_.TargetType
                write-host "`tKey   : " $_.Key

                # there is more infomation if this is a device type
                $DeviceData =  $_ -AS [Microsoft.Windows.Kits.Hardware.ObjectModel.IDeviceTargetData]
                if ($DeviceData -ne $null)
                {
                    write-host "`tManufacturer : " $DeviceData.Manufacturer
                    write-host "`tVendorId : " $DeviceData.VendorId
                    write-host "`tDeviceClass : " $DeviceData.DeviceClass
                    write-host "`tInBox : " $DeviceData.AllInboxDrivers
                    write-host "`tDriver : "
                    $DeviceData.Drivers
                    write-host "`tDriverHash : "
                    $DeviceData.DriverHash
                }

                # there is more infomation if this is a System type
                $SystemData = $_ -AS [Microsoft.Windows.Kits.Hardware.ObjectModel.ISystemTargetData]
                if ($SystemData -ne $null)
                {
                    write-host "`tManufacturer : " $SystemData.Manufacturer
                    write-host "`tModel : " $SystemData.Model
                }

                # there is more infomation if this is a System type
                $FilterData = $_ -AS [Microsoft.Windows.Kits.Hardware.ObjectModel.IFilterTargetData]
                if ($FilterData -ne $null)
                {
                    write-host "`tManufacturer : " $FilterData.Manufacturer
                    write-host "`tVersion : " $FilterData.Version
                    write-host "`tAllInbox : " $FilterData.AllInboxDrivers
                }

                write-host "`tFeatures : "
                $_.GetFeatures() | foreach {
                    write-host "`t`t" $_.FullName

                    $_.GetRequirements() | foreach {
                        write-host "`t`t`tRequirement: " $_.FullName
                    }
                }
            }

            # now list all of the tests for this family
            write-host "Tests:"
            $_.GetTests() | foreach {
                write-host "`t" $_.Name -NoNewline
                if ($_.GetTestTargets().Count -ne 1)
                    { write-host " - shared" }
                else
                    { write-host " -  not shared" }
            }
        }
    }
}


Target Families

These samples show how to create target families and run tests against them.

C#

//-----------------------------------------------------------------------
// <copyright file="AdvancedTargetFamily.cs" company="Microsoft">
//    Copyright © Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

namespace Samples
{
    using System.Collections.Generic;
    using System.Linq;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    public class AdvancedTargetFamily
    {
        public static void Main(string[] args)
        {
            string projectName = "my new project";
            string controllerName = args[0];

            // first, connect to the server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            //---------------
            // machine and machine pool management
            //---------------
            // now, create a machine pool
            MachinePool rootPool = manager.GetRootMachinePool();
            MachinePool testPool = manager.GetRootMachinePool().CreateChildPool("TestPool");

            // find all the computers in the default pool, and move them into the test pool
            foreach (Machine machine in rootPool.DefaultPool.GetMachines())
            {
                rootPool.DefaultPool.MoveMachineTo(machine, testPool);
            }

            // now, make sure that the computers are in a ready state
            foreach (Machine machine in testPool.GetMachines())
            {
                machine.SetMachineStatus(MachineStatus.Ready, -1);
            }

            // create a device family
            string[] HardwareIds = { @"HID\VID_045E&PID_006A&REV_1717&Col01", @"HID\VID_045E&PID_006A&Col01", @"HID_DEVICE_SYSTEM_MOUSE" };
            DeviceFamily mouseDeviceFamily = manager.CreateDeviceFamily("My Device Family", HardwareIds);

            //---------------
            // creating a project
            //---------------
            Project project = manager.CreateProject(projectName);

            // now you have a group of computers in your test pool
            // you must figure out what distinct list of OSPlatfoms are in there
            HashSet<OSPlatform> platformList = new HashSet<OSPlatform>();
            foreach (Machine machine in testPool.GetMachines())
            {
                if (platformList.Contains(machine.OSPlatform) == false)
                {
                    platformList.Add(machine.OSPlatform);
                }
            }

            //---------------
            // creating a product instance, one for each OSType
            //---------------
            foreach (OSPlatform platform in platformList)
            {
                ProductInstance pi = project.CreateProductInstance("Product instance for " + platform.Description, testPool, platform);
                TargetFamily targetFamily = pi.CreateTargetFamily(mouseDeviceFamily);

                // next, enumerate all the devices in the system that use one of the hardware IDs in the device family
                foreach (TargetData data in pi.FindTargetFromDeviceFamily(mouseDeviceFamily))
                {
                    // check this first, to see if this can be added
                    if (targetFamily.IsValidTarget(data))
                    {
                        targetFamily.CreateTarget(data);
                    }
                }

                // start running these tests now
                pi.QueueTest();
            }

            //-----------------
            // some time passes, and no more computers are available to run these tests
            // so now you must add more computers to the pool
            //-----------------
            foreach (Machine machine in testPool.DefaultPool.GetMachines())
            {
                // filter out any computer where the OSPlatform is not already part of the project
                if (platformList.Contains(machine.OSPlatform))
                {
                    rootPool.DefaultPool.MoveMachineTo(machine, testPool);
                    machine.SetMachineStatus(MachineStatus.Ready, -1);

                    // get the target family again
                    ProductInstance pi = project.GetProductInstances().Where(x => x.OSPlatform == machine.OSPlatform).First();
                    TargetFamily targetFamily = pi.GetTargetFamilies().Where(x => x.Family == mouseDeviceFamily).First();

                    foreach (TargetData data in pi.FindTargetFromDeviceFamily(mouseDeviceFamily))
                    {
                        if (targetFamily.IsValidTarget(data))
                        {
                            targetFamily.CreateTarget(data);
                        }
                    }
                }
            }

            // now, reschedule any job that hasn't run yet
            foreach (Test test in project.GetTests().Where(x => (x.Status == TestResultStatus.InQueue) || (x.Status == TestResultStatus.NotRun)))
            {
                foreach (TestResult result in test.GetTestResults().Where(x => x.Status == TestResultStatus.InQueue))
                {
                    result.Cancel();
                }

                // this will reschedule the tests on the new hardware/targets, as needed
                test.QueueTest();
            }
        }
    }
}

Windows PowerShell

$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.Kits.Hardware.objectmodel.dbconnection.dll")

Clear-Host

write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file TargetFamily.ps1 <<ControllerMachineName>> "

$ControllerName = $args[0]
if ($ControllerName -eq $null -OR $ControllerName -eq "")
{
    write-host "Need to supply the controller Name as a parameter to this script"
    return
}
else
{
    write-host connecting to the controller $ControllerName
}

# connect to the controller
$Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, HLKJobs

$RootPool = $Manager.GetRootMachinePool()
$DefaultPool = $RootPool.DefaultPool

# create the pool
$TestPool = $RootPool.CreateChildPool("TestPool")

# find all the computers in the default pool, and move them into the test pool
$DefaultPool.GetMachines() | foreach {
    write-host $_.Name
    $DefaultPool.MoveMachineTo($_, $TestPool)
    }

# now, make sure that the computers are in a ready state
$TestPool.GetMachines() | foreach { $_.SetMachineStatus([Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::Ready, 1) }

# create a device family
[string[]]$HardwareIds = "HID\VID_045E&PID_006A&REV_1717&Col01", "HID\VID_045E&PID_006A&Col01", "HID_DEVICE_SYSTEM_MOUSE"
$DeviceFamily = $Manager.CreateDeviceFamily("My Device Family", $HardwareIds)

# create a project
$Project = $Manager.CreateProject("My Device Family Project {0}" -f [DateTime]::Now.ToString())

# create a product instance by using the operating system platform of the first computer that you find
$ProductInstance = $Project.CreateProductInstance("My Product Instance", $TestPool, $TestPool.GetMachines()[0].OSPlatform)

# create a target family by using the device family that you created earlier
$TargetFamily = $ProductInstance.CreateTargetFamily($DeviceFamily)

#find all the devices in this machine pool that are in this device family
$ProductInstance.FindTargetFromDeviceFamily($DeviceFamily) | foreach {
    "attempting to add target $_.Name on machine $_.Machine.Name to TargetFamily"
# and add those to the target family

# check this first, to make sure that this can be added to the target family
    if ($TargetFamily.IsValidTarget($_)) {
        $TargetFamily.CreateTarget($_)
        }
    }

#schedule all tests
$Project.GetTests() | foreach {
    "test {0} is {1}" -f  $_.Name, $_.ScheduleOptions.ToString()
    Write-Host "running test {0} " -f $_.Name
    $_.QueueTest();
    }


Advanced scheduling

These samples demonstrate various scheduling scenarios.

C#

//-----------------------------------------------------------------------
// <copyright file="AdvancedScheduling.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

[assembly: System.CLSCompliant(true)]
namespace Microsoft.Windows.Kits.Samples
{
    using System.Linq;
    using System.Threading;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    public class AdvancedScheduling
    {
        private AdvancedScheduling()
        {
        }

        public static void Main(string[] args)
        {
            string projectName = "my new project";
            string controllerName = args[0];

            // first we need to connect to the Server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // next we need to load our project
            Project project = manager.GetProject(projectName);

            // this will schedule any jobs which have already run, and have failed
            foreach (Test test in project.GetTests().Where(x => x.Status == TestResultStatus.Failed))
            {
                test.QueueTest();
            }

            // wait some time
            Thread.Sleep(5 * 60 * 1000 /* 5 minutes */);

            // cancel all test which have not started yet
            foreach (Test test in project.GetTests().Where(x => x.Status == TestResultStatus.InQueue))
            {
                // tests are definitions, each instance of the QueueTests creates a result.
                // so to cancel a test, you need to cancel it's instance, aka the result
                foreach (TestResult result in test.GetTestResults().Where(x => x.Status == TestResultStatus.InQueue))
                {
                    result.Cancel();
                }
            }
        }
    }
}

PowerShell

. ..\Initialization.ps1

Clear-Host
$Manager = Initialize

# create the project name
$now = [System.DateTime]::Now
$ProjectName = "My new Advanced scheduling project $now"

$RootPool = $Manager.GetRootMachinePool()
$DefaultPool = $RootPool.DefaultPool

# create the pool
$TestPool = $RootPool.GetChildPools() | Where {$_.Name -eq "TestPool" }[0]
if ($TestPool -eq $null)
{
    $TestPool = $RootPool.CreateChildPool("TestPool")
}

# move all machines in the default pool
$DefaultPool.GetMachines() | foreach {
    write-host $_.Name
    $DefaultPool.MoveMachineTo($_, $TestPool)
    }

#reset all machines
$TestPool.GetMachines() | foreach { $_.SetMachineStatus([Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::Ready, 1) }

#-----------
# Creating a project
#-----------
$Project = $manager.CreateProject($ProjectName)
Write-Host "created a project named : "$Project.Name

$OSPlatform = $TestPool.GetMachines()[0].OSPlatform
$ProductInstance = $Project.CreateProductInstance("My Product Instance",
                                                 $TestPool,
                                                 $OSPlatform)

# this will find all systems in the test pool, and return those as a list of system test targets
$data = $ProductInstance.FindTargetFromSystem()

# for now, just use the first one found
Write-Host "Createing a target for " $data[0].Name
$Target = $ProductInstance.CreateTarget($data[0])
write-Host Successfully created a Target for $Target.Name that has $Target.GetTests().Count tests

# Find a specific test
#
# this test is named
$TestName = "Debug Capability Test (Logo)"

$Test = $Target.GetTests() | where { $_.Name -eq $TestName }[0]

Write-Host "Verifying $($Test.Name) requires multiple machines: " $Test.ScheduleOptions.HasFlag( [Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::RequiresMultipleMachines );

# List the parameters for this test
$Test.GetParameters().Values | foreach {
    Write-Host
    Write-Host Name         : $_.Name
    Write-Host Description  : $_.Description
    Write-Host Visible      : $_.Visible
    Write-Host DefaultValue : $_.DefaultValue
    Write-Host ActualValue  : $_.ActualValue
    }

# for purposes of demonstration, this job has a parameter to indicate which debug transport (bus) to use
# set this to USB

$Test.SetParameter("Transport", "usb", [Microsoft.Windows.Kits.Hardware.ObjectModel.ParameterSetAsDefault]::DoNotSetAsDefault)
$Test.SetParameter("UsbTargetName", "someDevice", [Microsoft.Windows.Kits.Hardware.ObjectModel.ParameterSetAsDefault]::DoNotSetAsDefault)

Write-Host Displaying paramters again, to show that theyve been set
$Test.GetParameters().Values | foreach {
    Write-Host
    Write-Host Name         : $_.Name
    Write-Host Description  : $_.Description
    Write-Host Visible      : $_.Visible
    Write-Host DefaultValue : $_.DefaultValue
    Write-Host ActualValue  : $_.ActualValue
    }

# to run this test, we'd be expected to set this up against 2 machines,
# so new need to find another machine to use
$SecondMachine =  $TestPool.GetMachines() | Where { $_ -ne $Target.Machine }

$MachineSet = $Test.GetMachineRole();

#write each of these roles to the console
$MachineSet.Roles | foreach {
    $_
    Write-Host Machines currently in this role:  $_.GetMachines().Count
    Write-Host
    }

# I know that the primary role is already filled by the machine under test.
# and that adding a machine to that role will result in a failure

Write-Host this should return a failure
$MachineSet.Roles[0].AddMachine($SecondMachine)

# however adding this machine to a secondary role should succeed
Write-Host this should Succeed
$MachineSet.Roles[1].AddMachine($SecondMachine)

# Now that the machine set has been created,
# we can schedule this test
$test.QueueTest($MachineSet);


Creating a Package

The following code samples show how to:

C#

  • Create a submission package from a project

  • Sign a package using a digital signature stored in a pfx file

Windows PowerShell

  • Create a submission package from a project

  • Sign a package using a digital signature stored in a pfx file

  • Determine for what operating systems a driver passes the signing checks

  • Verify a digital certificate

C#

Create a submission package from a project

This sample shows how to create a submission package from a project.

//-----------------------------------------------------------------------
// <copyright file="CreateAPackage.cs" company="Microsoft">
//    Copyright © Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

namespace Samples
{
    using System;
    using System.Collections.ObjectModel;
    using System.Linq;
    using System.Collections.Generic;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;
    using System.Collections.Specialized;

    public class CreateAPackage
    {
        public static void Main(string[] args)
        {
            Console.WriteLine("Usage: CreateAPackage.exe [ControllerMachineName] [ProjectName] [PathToDrivers] [SaveFileName]");

            if (args.Length != 4)
            {
                Console.WriteLine("Controller Name, Project Name, Path-to-drivers and SaveFile all need to be supplied as an argument.");
                return;
            }

            // first, connect to the controller
            string controllerName = args[0];
            Console.WriteLine("Connecting to controller : {0}", controllerName);
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // next, load the project
            string projectName = args[1];
            Console.WriteLine("Opening project : {0}", projectName);
            Project project;
            try
            {
                project = manager.GetProject(projectName);
            }
            catch (ProjectManagerException e)
            {
                Console.WriteLine("could not open project {0} \nError : {1}",
                    projectName,
                    e.Message);
                return;
            }

            string driverPath = args[2];
            Console.WriteLine("adding drivers found at {0}", driverPath);

            string saveFileName = args[3];
            Console.WriteLine("saving package to {0}", saveFileName);

            // the steps to create a package are:
            // 1) create a LogoPackageWriter
            // 2) add drivers
            // 3) [optional] add supplemental content
            // 4) save to disk

            PackageWriter packageWriter = new PackageWriter(project);

            // packaging can be somewhat slow because it may have a lot of files to read, so compress and write
            // the packaging information does have an alerting mechanism
            // this will also be alerted for events when processing drivers
            packageWriter.SetProgressActionHandler(SubmissionCreationProgressHandler);

            // the AddDriver method has this definition
            //  public bool AddDriver(
            //        string pathToDriver,
            //        string pathToSymbols,
            //        ReadOnlyCollection<Target> targets,
            //        ReadOnlyCollection<string> locales,
            //        out StringCollection errorMessages,
            //        out StringCollection warningMessages)
            // the path to symbols is optional and can be null

            // each driver package can be associated with one or more targets, and can be from targets in different product instances
            // the possible locales can be retrieved from LogoManager.GetLocaleList()
            // when adding a driver, the driver package is validated that it will be signalable, and additional checks will be performed
            // this means that if this task fails, errorMessages and warningMessages will be filled out to provide information about any
            // problems that are encountered

            // for simplicity, add one driver package as received from the command line,
            // and associate that with all of the targets in the project
            List<Target> targetList = new List<Target>();
            foreach (ProductInstance pi in project.GetProductInstances())
            {
                targetList.AddRange(pi.GetTargets());
            }

            // also for simplicity, use the first 3 locales returned by GetLocaleList
            List<string> localeList = new List<string>();
            localeList.Add(ProjectManager.GetLocaleList()[0]);
            localeList.Add(ProjectManager.GetLocaleList()[1]);
            localeList.Add(ProjectManager.GetLocaleList()[2]);

            StringCollection errorMessages;
            StringCollection warningMessages;

            // call this method
            if (packageWriter.AddDriver(driverPath, null, targetList.AsReadOnly(), localeList.AsReadOnly(), out errorMessages, out warningMessages) == false)
            {
                Console.WriteLine("Add driver failed to add this driver found at : {0}", driverPath);
                foreach (string message in errorMessages)
                {
                    Console.WriteLine("Error: {0}", message);
                }
            }

            // warnings might not cause the method to fail, but may still be present
            if (warningMessages.Count != 0)
            {
                Console.WriteLine("Add driver found warnings in the package found at : {0}", driverPath);
                foreach (string message in warningMessages)
                {
                    Console.WriteLine("Warning: {0}", message);
                }
            }

            // and now call the save as
            // this save as does the bulk of the work
            packageWriter.Save(saveFileName);

            // now that you're finished writing the package, dispose of it to make sure that the file handle is closed
            packageWriter.Dispose();
        }

        public static void SubmissionCreationProgressHandler(PackageProgressInfo info)
        {
            Console.WriteLine("Package progress {0} of {1} : {2}", info.Current, info.Maximum, info.Message);
        }
    }
}

Sign a package using a digital signature stored in a pfx file

This sample shows how to sign a package using a digital signature stored in a pfx file.

namespace HLK
{
    using System;
    using System.Security.Cryptography.X509Certificates;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;

    class Program
    {
        static void Main(string[] args)
        {
            string packageFile = args[0];
            string pfxFile = args[1];

            Console.WriteLine("Enter the password for the pfx file:");

            string password = Console.ReadLine();

            X509Certificate certificate = new X509Certificate(pfxFile, password);

            PackageManager.Sign(packageFile, certificate);
        }
    }
}

PowerShell

Create a submission package from a project

This sample shows how to create a submission package from a project.

$ObjectModel  = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.Kits.Hardware.objectmodel.dll")
$DbConnection = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.Kits.Hardware.objectmodel.dbconnection.dll")
$Submission   = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.Kits.Hardware.objectmodel.submission.dll")
$Submission   = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.Kits.Hardware.objectmodel.submission.package.dll")

    write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file CreateAPackage.ps1 [ControllerMachineName] [ProjectName] [PathToDrivers] [SaveFileName]"

    if ($args.count -ne 4)
    {
        write-host "error: need to provide the controller name, name of the project to package, path to drivers, and save file location "
        return
    }

    $ControllerName = $args[0]
    $projectName = $args[1];
    $driverPath = $args[2];
    $saveFileName = $args[3];

# we need to connect to the Server

    if ($ControllerName -eq $null -OR $ControllerName -eq "")
    {
        write-host "Need to supply the controller Name as a parameter to this script"
        return
    }

    if ($projectName -eq $null -OR $projectName -eq "")
    {
        write-host "Need to supply the Project Name as a parameter to this script"
        return
    }

    Write-host "connecting to controller : $ControllerName"
    $Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, HLKJobs

# next load the project
    write-host "Opening project :$projectName"
    $project = $Manager.GetProject($projectName)
    if ($project -eq $null)
    {
        write-host "unable to load project `n" $error.ToString()
    }

    write-host "adding drivers found at $driverPath"

    write-host "saving package to $saveFileName"

# the steps needed to create a package are:
# 1) create a LogoPackageWriter
# 2) add drivers
# 3) [optional] add supplemental content
# 4) save to disk

    $packageWriter = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageWriter -Args $project

# the AddDriver method has this definition.
#  public bool AddDriver(
#        string pathToDriver,
#        string pathToSymbols,
#        ReadOnlyCollection<Target> targets,
#        ReadOnlyCollection<string> locales,
#        out StringCollection errorMessages,
#        out StringCollection warningMessages)
# the path to symbols are optional, and can be null

# each driver package can be associated with one or more targets, and can be from targets in different product instances.
# the possible locales can be retrieved from LogoManager.GetLocaleList()
# when adding a driver, the driver package is validated that it will be signal-able, and additional checks will be performed
# this means that if this task fails, the errorMessages and warningMessages will be filled out to provide information about any
# problems encountered

# for simplicity, we are going to add one driver package that we received from the command line,
# and associate that with all of the targets in the project
    $targetList = New-Object "System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.Target]"

    $Project.GetProductInstances() | foreach {
        $targetlist.AddRange($_.GetTargets())
        }

# also for simplicity, we are going to use the first 3 locales returned by the GetLocaleList.
    $localeList = New-Object "System.Collections.Generic.List``1[System.string]"
    $localeList.Add([Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManager]::GetLocaleList()[0])
    $localeList.Add([Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManager]::GetLocaleList()[1])
    $localeList.Add([Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManager]::GetLocaleList()[2])

    $errorMessages = New-Object "System.Collections.Specialized.StringCollection"
    $warningMessages = New-Object "System.Collections.Specialized.StringCollection"

# go ahead and call this API
    if ($packageWriter.AddDriver($driverPath, [System.Management.Automation.Language.NullString]::Value, $targetList.AsReadOnly(), $localeList.AsReadOnly(), [ref] $errorMessages, [ref] $warningMessages) -eq $false)
    {
        Write-Host "Add driver failed to add this driver found at : $driverPath"
        foreach ($msg in $errorMessages)
        {
            Write-Host "Error: $msg"
        }
    }

# warnings might not cause the method to fail, but may still be present
    if ($warningMessages.Count -ne 0)
    {
        Write-Host "Add driver found warnings in the package found at : $driverPath"
        foreach ($msg in $warningMessages)
        {
            Write-Host "Warning: $msg"
        }
    }

# Since packaging can be somewhat slow, as it may have a lot of files to read, compress and write
# the packaging information does have an alerting mechanism
#  This is not implemented in the PowerShell example, but it is implemented in the C# version
# packageWriter.SetProgressActionHandler(SubmissionCreationProgressHandler);

# and now call the save as
# this save as does the bulk of the work
    $packageWriter.Save($saveFileName);

# now that we're done with writing the package, dispose it to make sure the file handle is closed
    $packageWriter.Dispose();

Sign a package using a digital signature stored in a pfx file

This sample shows how to sign a package using a digital signature stored in a pfx file.

# Load DLLs.
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

    Write-Host "Usage: %SystemRoot%\System32\WindowsPowershell\v1.0\powershell.exe -file sign_package.ps1 <<Full Path To Package>> <<Full Path to PFX>>"

# The package to sign.
    $packageFile = $args[0]

# The pfx file to use.
    $pfxfile = $args[1]

# The password for the pfx file.
    $pfxpassword = Read-host "Please enter the password for the pfx file" -AsSecureString

# Load the certificate.
    $cert = new-object -typename System.Security.Cryptography.X509Certificates.X509Certificate($pfxfile, $pfxpassword)

# Sign the package.
    [Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageManager]::Sign($packageFile, $cert)
NOTE

When signing some (large) packages using PowerShell, you might see an exception such as "Unable to determine the identity of domain". When this exception occurs, please use the managed API (see http://msdn.microsoft.com/en-us/library/windows/hardware/jj123504.aspx#BKMK_CS_SignPackage) as a work-around."

Determine for what operating systems a driver passes the signing checks

This sample shows how to determine for what operating systems a driver passes the signing checks.

# Load DLLs.
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

    Write-Host "Usage: %SystemRoot%\System32\WindowsPowershell\v1.0\powershell.exe -file check_downlevel_os.ps1 <<Full Path To Package>>"

# The package file.
    $packageFile = $args[0]

# Create a package manager.
    $Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageManager -Args $packageFile

    $Manager.GetProjectNames() | foreach {
        Write-Host Examining Project $_
        $Project = $Manager.GetProject($_)
        $Project.GetProductInstances() | foreach {
            $_.GetTargetFamilies() | foreach {
                $_.GetTargets() | foreach {
                    Write-Host Examining Target $_.Name
                    $_.GetDrivers() | foreach {
                        Write-Host Driver is signable for the following platforms
                        Write-Host $_.SignabilityResults
                    }
                }
            }
        }
    }

# Clean up.
    $Manager.Dispose()

Verify a digital certificate

This sample shows how to verify a digital certificate.

# Load DLLs.
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

    Write-Host "Usage: %SystemRoot%\System32\WindowsPowershell\v1.0\powershell.exe -file verify_certificate.ps1 <<Full Path To Package>>"

# The package file.
    $packageFile = $args[0]

# Create a package manager.
    $Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageManager -Args $packageFile

# Write out the certificate object.
    Write-host $Manager.Certificate

# Clean Up.
    $Manager.Dispose()


Diagnostic Bugcheck Summary

This sample shows how to retrieve and display a diagnostic bugcheck summary for a test that fails during a system crash.

NOTE

This feature is available only for Desktop client and server machines.

C#

//-----------------------------------------------------------------------
// <copyright file="DiagnosticSummary.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.ObjectModel;
    using System.Linq;
    using System.Threading;
    using System.Xml;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;
    using Microsoft.Windows.Kits.Hardware.DiagnosticSummary;

    public static class DiagnosticSummary
    {
        static ProjectManager ConnectToLocalServer()
        {
            XmlDocument doc = new XmlDocument();
            doc.Load(Environment.ExpandEnvironmentVariables(@"%WTTSTDIO%\\connect.xml"));
            XmlNode root = doc.SelectSingleNode("/Connection");
            string controllerName = root.Attributes["Server"].Value;
            string databaseName = root.Attributes["Source"].Value;

            DatabaseProjectManager manager = new DatabaseProjectManager(controllerName, databaseName);
            Console.WriteLine("Connected to database {0} on controller {1}", databaseName, controllerName);

            return manager;
        }

        public static void Main(string[] args)
        {
            try
            {
                // Note: Diagnostic Bugcheck Summary is only supported on Desktop based HLK Clients (Device Under Tests)
                string projectName = "TestProjectWithBugcheck";
                if (args.Length == 1)
                {
                    projectName = args[0];
                }

                ProjectManager manager = ConnectToLocalServer();

                // Find and load the project object
                Project project = manager.GetProject(projectName);
                if (project != null)
                {
                    Console.WriteLine("Loaded project: {0}", projectName);
                    foreach (var productInstance in project.GetProductInstances())
                    {
                        foreach (var targetFamily in productInstance.GetTargetFamilies())
                        {
                            foreach (var testResult in targetFamily.GetTestResults())
                            {
                                // Get diagnostic summary for the test result
                                DiagnosticSummaryLog diagnosticSummary = testResult.GetDiagnosticSummaryLog();
                                if (diagnosticSummary != null && diagnosticSummary.BugcheckSummary != null)
                                {
                                    // Display bugcheck summary if available
                                    Console.WriteLine(" Bugcheck summary for Test: {0}", testResult.Test.Name);
                                    Console.WriteLine("    Details - {0}", diagnosticSummary.BugcheckSummary.ToString());
                                }
                            }
                        }
                    }
                }
            }
            catch (ProjectException e)
            {
                System.Console.WriteLine(e);
            }
        }
    }
}

PowerShell

Param
(
    [Parameter(Mandatory=$true, Position=0, HelpMessage="HLK Controller name. Mandatory parameter.")]
    [string]$ControllerName,

    [Parameter(Mandatory=$true, Position=1, HelpMessage="HLK Project name. Mandatory parameter.")]
    [string]$ProjectName
)

function Initialize()
{
#Pre-load all binaries from the studio directory
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.Package.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.DiagnosticSummary.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.Logging.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.TraceLoggingSupport.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Diagnostics.Tracing.EventSource.dll")
}

Clear-Host

Write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file DiagnosticSummary.ps1 <<ControllerName>> <<ProjectName>>"

#Diagnostic Bugcheck Summary is only supported on Desktop based HLK Clients (Device Under Tests)
Initialize
$ProjectManager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName

#Try loading given project
$Project = $ProjectManager.GetProject($ProjectName)
if ($Project -ne $null)
{
    "Loaded project: {0}" -f $ProjectName
    foreach ($ProductInstance in $Project.GetProductInstances())
    {
        foreach ($TargetFamily in $ProductInstance.GetTargetFamilies())
        {
            foreach ($TestResult in $TargetFamily.GetTestResults())
            {
#Get diagnostic summary for the test result
                $DiagnosticSummary = $TestResult.GetDiagnosticSummaryLog()
                if (($DiagnosticSummary -ne $null) -and ($DiagnosticSummary.BugcheckSummary -ne $null))
                {
#Display bugcheck summary if available
                    "   Bugcheck summary for Test: {0}" -f $TestResult.Test.Name
                    "      Details - {0}" -f $DiagnosticSummary.BugcheckSummary.ToString()
                }
            }
        }
    }
}
else
{
    Write-Host "Could not find project {0}" -f $ProjectName
}


Exporting a Test Result

This sample shows how to export a test so that it can be run on a machine outside of the full HLK environment.

C#

//-----------------------------------------------------------------------
// <copyright file="ExportResultsSample.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------
[assembly: System.CLSCompliant(true)]

namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.Generic;
    using System.Globalization;
    using System.IO;
    using System.Linq;
    using System.Reflection;
    using System.Xml;

    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// This sample uses the Machine Pool Growth feature to add and automatically redistribute tests to targets after
    /// a test has been scheduled.
    /// See the ShowUsage() method for setup details.
    /// </summary>
    static class ResultExportSample
    {
        static void ShowUsage()
        {
            Console.WriteLine("{0} <Project name> \"<Output directory name>\"", System.Reflection.Assembly.GetExecutingAssembly().GetName());
            Console.WriteLine("Before running this sample:");
            Console.WriteLine(" 1. Create a project and run several tests -- these should be single machine tests");
            Console.WriteLine(" 2. Run this tool on a system running HLK Studio, passing in the project name and the directory to output the standalone executable version of the test as parameters in that order");
        }

        /// <summary>
        /// Connects to the DBConnection HLK Manager.
        /// </summary>
        /// <returns></returns>
        static ProjectManager ConnectToLocalServer()
        {
            XmlDocument doc = new XmlDocument();
            doc.Load(Environment.ExpandEnvironmentVariables(@"%WTTSTDIO%\\connect.xml"));
            XmlNode root = doc.SelectSingleNode("/Connection");
            string controllerName = root.Attributes["Server"].Value;
            string databaseName = root.Attributes["Source"].Value;

            DatabaseProjectManager manager = new DatabaseProjectManager(controllerName, databaseName);
            Console.WriteLine("Connected to database {0} on controller {1}", databaseName, controllerName);

            return manager;
        }

        /// <summary>
        /// Main entry point.
        /// </summary>
        /// <param name="args">
        /// The command line arguments for the application.
        /// The first argument is the controller name to connect to.
        /// The second argument is the project to redistribute tests for newly added targets.
        /// </param>
        /// <exception cref="ArgumentException">Thrown if two arguments are not specified.</exception>
        static void Main(string[] args)
        {
            if (args.Length != 2)
            {
                ShowUsage();
                throw new ArgumentException("Incorrect number of arguments", "args");
            }

            try
            {
                string runningProject = args[0];
                string outputDirectory = args[1];

                if (!Directory.Exists(outputDirectory))
                {
                    Directory.CreateDirectory(outputDirectory);
                }

                // get a server name
                ProjectManager manager = ConnectToLocalServer();
                Project project = manager.GetProject(runningProject);

                // iterate through all tests in project
                foreach (Test test in project.GetTests())
                {
                    // iterate through test results in project
                    foreach (TestResult testResult in test.GetTestResults())
                    {
                        IRunExport exportable = testResult as IRunExport;

                        // either non-database test result or tagged as non-exportable
                        if (exportable == null || !exportable.CanExport)
                        {
                            Console.WriteLine("Test result for {0} is not exportable", test.Name);
                        }
                        else
                        {
                            // pre conditions satisifed, try exporting test to specified directory
                            try
                            {
                                Console.WriteLine("Exporting test {0}", test.Name);
                                exportable.Export(outputDirectory);
                                Console.WriteLine("Successfully exported test {0}", test.Name);
                                break;
                            }
                            catch (Exception exception)
                            {
                                Console.WriteLine("Failed to export test {0}:{1}{2}", test.Name, Environment.NewLine, exception);
                            }
                        }
                    }
                }
            }
            catch (Exception exception)
            {
                Console.WriteLine("Failed to export tests: {0}", exception);
            }
        }
    }
}

PowerShell

# ExportResults.ps1
# Usage:
#  powershell.exe (path)\ExportResults.ps1 [-projectName] <string> [-exportLocation] <string> [<CommonParameters>]

[CmdletBinding()]
Param
(
    [Parameter(Mandatory=$true)]
    [System.String] $projectName,
    [Parameter(Mandatory=$true)]
    [System.String] $exportLocation
)

# Load controller information
$connectFileName = $env:WTTSTDIO + "connect.xml"

Write-Host Opening connection file $connectFileName

$connectFile = [xml](Get-Content $connectFileName)
$controllerName = $connectFile.Connection.GetAttribute("Server")
$databaseName = $connectFile.Connection.GetAttribute("Source")

# Load object model assemblies
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.kits.hardware.sqmwrapper.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "microsoft.windows.kits.hardware.logging.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.export.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.DiagnosticSummary.dll")

# create resolver for hlk assemblies so config section in exporter loads
$OnAssemblyResolve = [System.ResolveEventHandler]{
  param($sender, $resolveArgs)

  $file = [System.IO.Path]::Combine($env:wttstdio, $resolveArgs.Name + ".dll");

  if( [System.IO.File]::Exists($file))
  {
     try
     {
        return [Reflection.Assembly]::LoadFrom( $file);
     }
     catch
     {
        return $null;
     }
  }

  return $null;
}

# Add resolve handler
[System.AppDomain]::CurrentDomain.add_AssemblyResolve($OnAssemblyResolve)

# Connect to HLK controller
$manager =  new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $controllerName, $databaseName

# Get the specified project
$project = $manager.GetProject($projectName);

if($project -eq $null)
{
    Write-Host "Could not find project $projectName";
}
else
{
# create output directory if it doesn't exist
    if( -not (Test-Path $exportLocation) )
    {
        new-item -path $exportLocation -ItemType directory
    }

# Get all tests in the project - for each test get all test results that are exportable and call export
    $project.GetTests() |
        %{$_.GetTestResults() | ?{ $_.CanExport} } |
            %{
                try
                {
                    Write-Host
                    Write-Host "Exporting test '$($_.Test.Name)'"
                    $_.Export($exportLocation)
                    Write-host "Export Complete"
                }
                catch
                {
                    Write-Host "Export Failed:"
                    Write-Host $_
                }
            }
}

[System.AppDomain]::CurrentDomain.remove_AssemblyResolve($OnAssemblyResolve)


Extracting Log Files from a Package

The following code sample shows you how to extract log files from a package.

C#

//-----------------------------------------------------------------------
// <copyright file="PackageLogExtractor.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

[assembly: System.CLSCompliant(true)]
namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.ObjectModel;
    using System.IO;
    using System.Linq;
    using System.Collections.Generic;
    using System.Xml;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;

    internal static class ProgramSettings
    {
        internal static string PackagesDir = null;
        internal static string PackageFile = null;
        internal static bool ExtractLogs = false;
        internal static string LogsDir = null;
        internal static TextWriter Log = null;
        internal static string LogFile = null;
        internal static List<string> DevelopmentPhases = null;
    }

    internal static class Constants
    {
        internal const string PackageExt = ".hlkx";
        internal const string DefaultLogName = "PackageAnalysisLog.txt";
    }

    public class PackageLogExtractor
    {
        static void Main(string[] args)
        {
            if (false == ParseArgs(args))
            {
                ShowUsage();
                return;
            }
            PackageAnalyze(); // all the command line work.

            if (ProgramSettings.Log != null)
            {
                ProgramSettings.Log.Dispose();
            }
        }
        static void ShowUsage()
        {
            string usage = "";

            usage += Environment.NewLine + "PackageLogExtractor.exe [/PackagesDir=<path>]" +
                     Environment.NewLine + "                   [/PackageFile=<path>]" +
                     Environment.NewLine + "                   [/ExtractLogsTo=<path>]" +
                     Environment.NewLine + "                   [/LogFile=<path>]" +
                     Environment.NewLine + "                   [/PhaseFilters=<Level1,Level2,...>]" +
                     Environment.NewLine +
                     Environment.NewLine + "Any parameter in [] is optional." +
                     Environment.NewLine + "Atleast /PackagesDir or /PackageFile must be specified" +
                     Environment.NewLine +
                     Environment.NewLine + "PackageLogExtractor.exe /PackageFile=[FullPathwithHCKFILE.hlkx] /LogFile=[FullPathwithLogFileName]" +
                     Environment.NewLine +
                     Environment.NewLine + "Parameter Descriptions:" +
                     Environment.NewLine + "======================================================================" +
                     Environment.NewLine +
                     Environment.NewLine + "PackagesDir:   Directory to recursively search for package files." +
                     Environment.NewLine +
                     Environment.NewLine + "PackageFile:   Path to single package file to process" +
                     Environment.NewLine +
                     Environment.NewLine + "ExtractLogsTo: Path to directory where extracted logs will be stored" +
                     Environment.NewLine +
                     Environment.NewLine + "LogFile:       Path to file where to write the logging output to." +
                     Environment.NewLine +
                     Environment.NewLine + "PhaseFilters:    A CSV list of HLK Development Phases. Any combination of the following is supported: " +
                     Environment.NewLine + "                        BringUp, DevelopmentAndIntegration, Manufacturing, Reliability, Support, TuningAndValidation." +
                     Environment.NewLine + "                        Default is all phases." +
                     Environment.NewLine +
                     Environment.NewLine;
            //*** Need to update that

            Console.WriteLine(usage);

        }

        static bool ParseArgs(string[] args)
        {

            if ((args.Length == 0) || (args[0].Contains("?")))
            {
                return false;
            }

            foreach (string arg in args)
            {
                if (arg.StartsWith("/PackagesDir=", StringComparison.OrdinalIgnoreCase))
                {
                    ProgramSettings.PackagesDir = Path.GetFullPath(arg.Substring("/PackagesDir=".Length));
                }
                else if (arg.StartsWith("/PackageFile=", StringComparison.OrdinalIgnoreCase))
                {
                    ProgramSettings.PackageFile = Path.GetFullPath(arg.Substring("/PackageFile=".Length));
                }
                else if (arg.StartsWith("/ExtractLogsTo=", StringComparison.OrdinalIgnoreCase))
                {
                    ProgramSettings.LogsDir = Path.GetFullPath(arg.Substring("/ExtractLogsTo=".Length));
                    ProgramSettings.ExtractLogs = true;
                }
                else if (arg.StartsWith("/LogFile=", StringComparison.OrdinalIgnoreCase))
                {
                    string logFile = Path.GetFullPath(arg.Substring("/LogFile=".Length));

                    if (!Directory.Exists(Path.GetDirectoryName(logFile)))
                    {
                        Directory.CreateDirectory(Path.GetDirectoryName(logFile));
                    }
                    ProgramSettings.LogFile = logFile;
                    if (false == string.IsNullOrWhiteSpace(ProgramSettings.LogFile))
                    {
                        try
                        {
                            ProgramSettings.Log = new StreamWriter(ProgramSettings.LogFile);
                        }
                        catch (Exception e)
                        {
                            Console.WriteLine(e.ToString());
                        }
                    }

                }
                else if (arg.StartsWith("/PhaseFilters=", StringComparison.OrdinalIgnoreCase))
                {
                    ProgramSettings.DevelopmentPhases =
                        new List<String>(arg.Substring("/PhaseFilters=".Length).ToUpperInvariant().Split(','));
                }
                else
                {
                    Console.WriteLine("Unrecognized parameter: " + arg);
                    return false;
                }
            }
            return true;
        }

        private static void WriteMessage(string message, params object[] args)
        {
            if (ProgramSettings.Log != null)
            {
                if (args.Length > 0)
                {
                    ProgramSettings.Log.WriteLine(message, args);
                }
                else
                {
                    ProgramSettings.Log.WriteLine(message);
                }
            }
            else
            {
                Console.WriteLine(message, args);
            }
        }

        ///
        /// <summary>
        /// The Parse engine.
        /// </summary>
        ///
        public static void PackageAnalyze()
        {
            string[] packageFiles;
            PackageManager manager = null;
            List<DevelopmentPhase> developmentPhases = null;

            //
            // Check development phases
            //
            if (null == ProgramSettings.DevelopmentPhases)
            {
                var phases = (DevelopmentPhase[])Enum.GetValues(typeof(DevelopmentPhase));
                developmentPhases = new List<DevelopmentPhase>(phases);
            }
            else if (0 != ProgramSettings.DevelopmentPhases.Count)
            {
                developmentPhases = new List<DevelopmentPhase>();

                Func<string, string, bool> PhasesMatch = (left, right) => {
                    return string.Equals(left, right, StringComparison.OrdinalIgnoreCase);
                };

                foreach (string phase in ProgramSettings.DevelopmentPhases)
                {
                    if (PhasesMatch("BringUp", phase))
                    {
                        developmentPhases.Add(DevelopmentPhase.BringUp);
                    }
                    else if (PhasesMatch("DevelopmentAndIntegration", phase))
                    {
                        developmentPhases.Add(DevelopmentPhase.DevelopmentAndIntegration);
                    }
                    else if (PhasesMatch("Manufacturing", phase))
                    {
                        developmentPhases.Add(DevelopmentPhase.Manufacturing);
                    }
                    else if (PhasesMatch("Reliability", phase))
                    {
                        developmentPhases.Add(DevelopmentPhase.Reliability);
                    }
                    else if (PhasesMatch("Support", phase))
                    {
                        developmentPhases.Add(DevelopmentPhase.Support);
                    }
                    else if (PhasesMatch("TuningAndValidation", phase))
                    {
                        developmentPhases.Add(DevelopmentPhase.TuningAndValidation);
                    }
                    else
                    {
                        Console.WriteLine(
                            string.Format(
                            "Invalid category level supplied {0}. \nAborting filtering and using all category levels.",
                            phase));

                        //
                        // Just stomp on it with a new one.
                        //
                        var phases = (DevelopmentPhase[])Enum.GetValues(typeof(DevelopmentPhase));
                        developmentPhases = new List<DevelopmentPhase>(phases);
                    }
                }
            }
            if (string.IsNullOrEmpty(ProgramSettings.PackageFile) == false)
            {
                packageFiles = new string[] { ProgramSettings.PackageFile };
            }
            else
            {
                //*** Same extension?
                packageFiles = Directory.GetFiles(ProgramSettings.PackagesDir, "*.hlkx", SearchOption.AllDirectories);
            }

            if (packageFiles.Count() == 0)
            {
                Console.WriteLine("No files in the specified directory");
            }
            else
            {
                foreach (var file in packageFiles)
                {
                    try
                    {
                        ProcessFile(manager, file, developmentPhases);
                    }
                    catch (Exception e)
                    {
                        WriteMessage(e.ToString());
                        Console.WriteLine(e);
                    }
                    finally
                    {
                        if (manager != null)
                        {
                            manager.Dispose();
                        }
                        manager = null;
                    }

                    if (ProgramSettings.Log != null)
                    {
                        ProgramSettings.Log.Flush();
                    }
                }
            }
        }

        static void ProcessFile(ProjectManager manager, string file, List<DevelopmentPhase> developmentPhases)
        {
            WriteMessage("Process package {0}.", file);
            manager = new PackageManager(file);

            List<Project> packageProjects = new List<Project>();
            ReadOnlyCollection<string> projectNames = manager.GetProjectNames();

            foreach (var projectName in projectNames)
            {
                WriteMessage("Validating project: " + projectName);

                bool packageHasResults = false;
                ProjectInfo info = manager.GetProjectInfo(projectName);

                //
                // There wasn't anything run, so no files are going to exist.
                // The OM is going to choke if you try to extract the log files later
                // on.
                //
                if (info.TotalCount == 0)
                {
                    WriteMessage("No results.");
                    continue;
                }
                else
                {
                    WriteMessage(
                        string.Format(
                        ("Results count: \n\t" +
                        "Pass - {0} Fail - {1} Running - {2} NotRun - {3} Total - {4}"),
                        info.PassedCount,
                        info.FailedCount,
                        info.RunningCount,
                        info.NotRunCount,
                        info.TotalCount));

                    packageHasResults = true;
                }

                if (packageHasResults)
                {
                    var project = manager.GetProject(projectName);
                    packageProjects.Add(project);

                    //
                    // Create a list of tests which satisfy filtering condition
                    //
                    IList<Test> testList = project.GetTests().SelectMany((t => t.DevelopmentPhases.Join(developmentPhases, p => p, d => d, (p, d) => t))).ToList();

                    //
                    // Report only tests which have results > 0.
                    //
                    foreach (Test test in testList.Where(t => (t.GetTestResults().Count > 0)))
                    {
                        ProcessTest(test, project.Name);
                    }
                }
            }
        }

        static void ProcessTest(Test test, string projectName)
        {
            int resultCounter = 1;

            foreach (var result in test.GetTestResults())
            {
                WriteMessage("=============================================");
                string testTargetDevice = string.Join("; ", from a in test.GetTestTargets()
                                                            select a.Name);

                WriteMessage("Test         : " + test.Name);
                WriteMessage("Target       : " + testTargetDevice);
                WriteMessage("RunTime (min): " + System.Math.Round((result.CompletionTime - result.StartTime).TotalMinutes));

                string logsDir = ProgramSettings.LogsDir;

                if (false == string.IsNullOrWhiteSpace(ProgramSettings.LogsDir))
                {
                    logsDir = Path.Combine(ProgramSettings.LogsDir, projectName, test.Name, "Result" + resultCounter.ToString(), test.GetTestTargets().First().Name);

                    foreach (var log in result.GetLogs().Where(x => x.LogType == LogType.TestRun))
                    {
                        log.WriteLogTo(Path.Combine(logsDir, "JobLogs", log.Name));
                    }
                    foreach (var log in result.GetLogs().Where(x => x.LogType == LogType.Gatherer))
                    {
                        log.WriteLogTo(Path.Combine(logsDir, "GathererLogs", log.Name));
                    }
                    foreach (var target in test.GetTestTargets())
                    {
                        string targetXmlDir = Path.Combine(logsDir, @"..\", "TargetXml");
                        if (!Directory.Exists(targetXmlDir))
                        {
                            try
                            {
                                Directory.CreateDirectory(targetXmlDir);
                            }
                            catch (Exception e)
                            {
                                Console.WriteLine("Directory creation failed", e.ToString());

                            }
                        }
                        string fileName = target.Name.Replace(" ", "_") + "_" + target.Machine.Name + ".xml";
                        File.WriteAllText(Path.Combine(targetXmlDir, fileName), target.XmlData);
                    }
                    ProcessResult(result.GetTasks(), Path.Combine(logsDir, "TaskLogs"), test);
                }
                else
                {
                    ProcessResult(result.GetTasks(), null, test);
                }
                WriteMessage("=============================================");
                resultCounter++;
            }
        }

        /// <summary>
        /// The primary result processing engine.  Extracts log files for test tasks, validates results should
        /// be reported for the task based on the WTT Task configuration extracted from the WTT infrastructure
        /// log(s) and stored in the WTTTaskLogData list.
        ///
        /// This is a recursive method as a particular task can have many child tasks.
        /// </summary>
        /// <param name="taskToProcess">
        /// The HLK Task to process results for.
        /// </param>
        /// <param name="baseLogsDir">
        /// Root log directory for the WTT Log files.
        /// </param>
        /// <param name="test">
        /// The root HLK Test Object.
        /// </param>
        /// <param name="mergedWttLog">
        /// Instance of the WTT Log we're pushing context in and out of
        /// </param>
        /// <param name="indentLevel">
        /// For output purposes, indentation of the task information presented in the console window.
        /// </param>
        static void ProcessResult(IEnumerable<Task> tasksToProcess, string baseLogsDir, Test test, int indentLevel = 1)
        {
            List<Task> tasks = tasksToProcess.OrderBy(x => x.TestResult.StartTime).ToList();

            if (tasks.Count == 0)
            {
                return;
            }

            string msgIndent = new string('\t', indentLevel - 1);
            foreach (var task in tasks)
            {
                if (string.IsNullOrWhiteSpace(baseLogsDir))
                {
                    if (task.TaskType.Equals("RunJob", StringComparison.OrdinalIgnoreCase))  // recurse
                    {
                        ProcessResult(task.GetChildTasks(), null, test, indentLevel + 1);
                    }
                }
                else
                {
                    string taskLogsDir = Path.Combine(baseLogsDir, task.Stage, task.Name);

                    if (task.TaskType.Equals("RunJob", StringComparison.OrdinalIgnoreCase))  // recurse
                    {
                        taskLogsDir = Path.Combine(baseLogsDir, task.Stage, "RunJob-" + task.Name);
                        ProcessResult(task.GetChildTasks(), taskLogsDir, test, indentLevel + 1);
                    }
                    else
                    {
                        foreach (var log in task.GetLogFiles())
                        {
                            log.WriteLogTo(Path.Combine(taskLogsDir, log.Name));
                        }
                    }
                }
            }
        }

    }
}


Filtering

These code samples show how to apply filters to a project and retrieve filters from a project.

C#

// ------------------------------------------------------------------------------------------------
// <copyright file="Filtering.cs" company="Microsoft">
//   Copyright © Microsoft Corporation. All rights reserved.
// </copyright>
// ------------------------------------------------------------------------------------------------

[assembly: System.CLSCompliant(true)]

namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.ObjectModel;

    using Microsoft.Windows.Kits.Hardware.FilterEngine;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// Sample for using a Target Family
    /// </summary>
    public class Filtering
    {
        /// <summary>
        /// Prevents a default instance of the <see cref="Filtering"/> class from being created.
        /// </summary>
        private Filtering()
        {
        }

        /// <summary>
        /// Entry point method for the sample application
        /// </summary>
        /// <param name="args">standard parameter arguments</param>
        public static void Main(string[] args)
        {
            /*
             * On-demand filtering. Using the filter engine API, apply filters to a project with failures (task results with Failed status).
             * For a project that doesn't have any failures, project.GetAppliedFilters() will return an empty collection.
             * For a project that was filtered, project.GetAppliedFilters() should return the filters that were applied to the project.
             */
            string controllerName = args[0];

            FilterLargeProject(controllerName);
            FilterSmallProject(controllerName);
        }

/// <summary>
/// Filters a small project
/// </summary>
/// <param name="controllerName">Controller name</param>
        private static void FilterSmallProject(string controllerName)
{
string projectName = "existing small project";
            // first we need to connect to the Server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // load the project that has failing task results
            Project project = manager.GetProject(projectName);

            // instantiate filter engine for the database project manager
            DatabaseFilterEngine filterEngine = new DatabaseFilterEngine(manager);

            // apply filters to the project. Will try to find matching filters for the failing task results in the project.
            // It is synchronous (or blocking) call, and depending on the size of the log files and the number of task results to be filtered in the project, the Filter method could take a while.
            filterEngine.Filter(project);

            // retrieve the filters that were applied to the project.
            ReadOnlyCollection<IFilter> appliedFilters = project.GetAppliedFilters();
            Console.Out.WriteLine("{0} filters were applied for project {1}", appliedFilters.Count, projectName);
}

        /// <summary>
        /// Filters a large project with greater than 1000 test results
        /// </summary>
        /// <param name="controllerName">Controller name</param>
private static void FilterLargeProject(string controllerName)
{
string projectName = "existing large project";

            // first we need to connect to the Server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // instantiate filter engine for the database project manager
            DatabaseFilterEngine filterEngine = new DatabaseFilterEngine(manager);

            // load the project that has failing task results
            Project project = manager.GetProject(projectName);
            foreach (ProductInstance productInstance in project.GetProductInstances())
            {
                foreach (TargetFamily targetFamily in productInstance.GetTargetFamilies())
                {
                    foreach (TestResult testResult in targetFamily.GetTestResults())
                    {
                        // apply filters to the test result. Will try to find matching filters for the failing task results in the project.
                        // It is synchronous (or blocking) call, and depending on the size of the log files and the number of task results to be filtered in the project, the Filter method could take a while.
                        filterEngine.Filter(testResult);
                    }
                }
            }
}
    }
}

Windows PowerShell - Large Project

# NOTE: Filters can be applied only to projects on the controller. Filtering against a project in a submission package is not supported.

# load object model dll's
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$DbConnection = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$Submission = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")
$FilterEngineDll = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.FilterEngine.dll")

write-host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file Filtering.ps1 [ControllerMachineName] [ProjectName]"
write-host "\tNOTE: Filters can be applied only to projects on the controller. Filtering against a project in a submission package is not supported."

if ($args.count -ne 2)
{
   write-host "error: need to provide the controller name and name of the project to filter"
   return
}

$controllerName = $args[0]
$projectName = $args[1]

write-host "Connecting to the controller: $controllerName"
$Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $controllerName, "HLKJobs"

#initialize filter engine for the database project manager
$filterEngine = new-object -typename Microsoft.Windows.Kits.Hardware.FilterEngine.DatabaseFilterEngine -Args $Manager;

# next, load the project that needs to be filtered
write-host "Opening project :$projectName"
$project = $Manager.GetProject($projectName)
if ($project -eq $null)
{
   write-host "unable to load project `n" $error.ToString()
}

foreach ($productInstance in $project.GetProductInstances())
{
   foreach ($targetFamily in $productInstance.GetTargetFamilies())
   {
      foreach ($testResult in $targetFamily.GetTestResults())
      {
#Reload the project in HLK Studio after running the script.
#apply filters to the test result. Will try to find matching filters for the failing task results in the project.
#It is synchronous (or blocking) call, and depending on the size of the log files and the number of task results to be filtered in the project, the Filter method could take a while.
# For very large projects, if you know the InstanceId for the testResult that you would like to filter, you can enumerate and find that testResult (by InstanceId) and apply filters only to that testResult.
         $result = $filterEngine.Filter($testResult)
      }
   }
}

Windows PowerShell - Small Project

# NOTE: Filters can be applied only to projects on the controller. Filtering against a project in a submission package is not supported.

# load object model dll's
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$DbConnection = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$Submission = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")
$FilterEngineDll = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.FilterEngine.dll")

write-host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file Filtering.ps1 [ControllerMachineName] [ProjectName]"
write-host "NOTE: Filters can be applied only to projects on the controller. Filtering against a project in a submission package is not supported."

if ($args.count -ne 2)
{
   write-host "error: need to provide the controller name and name of the project to filter"
   return
}

$controllerName = $args[0]
$projectName = $args[1]

write-host "Connecting to the controller: $controllerName"
$Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $controllerName, "HLKJobs"

#initialize filter engine for the database project manager
$filterEngine = new-object -typename Microsoft.Windows.Kits.Hardware.FilterEngine.DatabaseFilterEngine -Args $Manager;

# next, load the project that needs to be filtered
write-host "Opening project :$projectName"
$project = $Manager.GetProject($projectName)
if ($project -eq $null)
{
   write-host "unable to load project `n" $error.ToString()
}

# apply filter to the project. Reload the project in HLK Studio after running the script.
$result = $filterEngine.Filter($project)


Finding missing tests

This sample shows how to find tests that are missing from a package. The sample is divided into four files:

  • Program.cs: main program file
  • PlaylistDL.cs: class used to represent a playlist file for downlevel operating systems
  • PlaylistHelper.cs: helper class used for deserialization of downlevel playlists
  • PlaylistDL.xsd: schema that is used to validate the output playlist XML file. Place this file next to your executable.

Program.cs

//--------------------------------------------------------------------------------------------------------------------
// <copyright file="Program.cs" company="Microsoft">
//    Copyright (c) Microsoft. All rights reserved.
// </copyright>
//--------------------------------------------------------------------------------------------------------------------

namespace Sample.MissingTest
{
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Collections.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.Submission;

    /// <summary>
    /// Find missing tests in a package
    /// </summary>
    public class Program
    {
        static string playlistRS1;
        static string playlistRS2;
        static bool bShowPassingResults = false;

        /// <summary>
        /// Entry point for the sample
        /// <param name="args"></param>
        /// </summary>
        public static void Main(string[] args)
        {
            int missingTestCount = 0;
            if (args.Length != 4)
            {
                Console.WriteLine("Invalid Parameters!");
                Console.WriteLine("Usage:");
                Console.WriteLine("Sample.MissingTest.exe <path to hlkx package> <path to RS1 playlist> <path to RS2 playlist> <True or False for showing pass results>");
                return;
            }

            playlistRS1 = args[1];
            playlistRS2 = args[2];
            if (String.Compare("true", args[3], true) == 0)
            {
                bShowPassingResults = true;
            }
            missingTestCount = FindMissingResults(args[0]);

        }

        /// <summary>
        /// Uses the given <see cref="PlaylistDL"/> to find tests for each <see cref="Target"/> in the the given list
        /// of <see cref="ProductInstance"/> objects that should be present but are not.
        /// </summary>
        /// <param name="packagePath">Path to the package.</param>
        /// <param name="playlistPath">Path to the playlist to be applied</param>
        /// <returns>
        /// Count of missing tests for a given package/>.
        /// </returns>
        private static int FindMissingResults(string packagePath)
        {
            int missingTestCount = 0;

            PackageManager manager = new PackageManager(packagePath);

            Console.WriteLine("Package version : " + manager.PackageVersion);

            foreach (ProjectInfo projectInfo in manager.GetProjectInfoList())
            {
                Console.WriteLine("Project name : " + projectInfo.Name);

                if (!string.IsNullOrEmpty(projectInfo.Name))
                {
                    Project project = manager.GetProject(projectInfo.Name);

                    foreach (ProductInstance pi in project.GetProductInstances())
                    {
                        missingTestCount = 0;
                        Console.WriteLine();
                        Console.WriteLine("\r\nTest results for package: {0}, OS: {1}, Controller Veriosn:{2}\r\n", manager.FileName, pi.OSPlatform.Name, pi.Project.ProjectManager.Version.Build);

                        ReadOnlyCollection<Target> currentPiTargets = pi.GetTargets();
                        if (pi.GetPlaylists().Count() == 0)
                        {
                            Console.WriteLine("Using playlist: {0} for validation", playlistRS1);
                            Console.WriteLine();

                            PlaylistDL playlistDL = PlaylistHelper.DeserializePlaylistDL(playlistRS1);
                            Dictionary<Target, List<PlaylistTestDL>> missingTests = PlaylistHelper.GetMissingTests(playlistDL, pi);
                            Console.WriteLine("Missing Tests:");
                            missingTests.ToList().ForEach(item => Console.WriteLine("{0}:{1}", item.Value[0].Name, item.Value[0].Id));
                            Console.WriteLine();
                            missingTestCount = missingTests.Count();

                            List<Test> projectTotalTestList = PlaylistHelper.GetTestsFromProjectThatMatchPlaylistDL(playlistDL, pi);
                            // List results for tests in playlist matching to currently loaded project
                            GetTestDetails(projectTotalTestList, currentPiTargets, false);
                        }
                        else
                        {
                            Console.WriteLine("Using playlist: {0} for validation", playlistRS2);
                            Console.WriteLine();

                            // Get all the tests for current project from playlist
                            PlaylistManager playlistlManger = new PlaylistManager(project);
                            Playlist playlist = PlaylistManager.DeserializePlaylist(playlistRS2);
                            List<Test> projectTotalTestList = playlistlManger.GetTestsFromProjectThatMatchPlaylist(playlist);
                            missingTestCount = GetTestDetails(projectTotalTestList, currentPiTargets);
                        }

                        Console.WriteLine();
                        Console.WriteLine("Missing Tests = {0}", missingTestCount);
                    }
                }
            }

            return missingTestCount;
        }

        private static int GetTestDetails(List<Test> projectTotalTestList, ReadOnlyCollection<Target> targets, bool bRS2 = true)
        {
            int missingTestCount = 0;
            List<Test> missingTests = new List<Test>();
            List<Test> testResults = new List<Test>();
            projectTotalTestList.ForEach(
                                item =>
                                {
                                    var testTargets = item.GetTestTargets();
                                    bool targetResult = !testTargets.Except(targets).Any();
                                    if (item.GetTestResults().Count == 0 && bRS2 && targetResult)
                                    {
                                        missingTests.Add(item);
                                        missingTestCount++;
                                    }
                                    else if (targetResult)
                                    {
                                        testResults.Add(item);
                                    }
                                });

            if (bRS2)
            {
                Console.WriteLine("Missing Tests:");
                missingTests.ForEach(item => Console.WriteLine("{0}:{1}", item.Name, item.Id));
                Console.WriteLine();
            }

            Console.WriteLine("Test Results:");
            testResults.ForEach(
                    item =>
                    {
                        var allResults = item.GetTestResults().OrderByDescending(r => r.CompletionTime);
                        var passedResult = allResults.Where(test => test.Status == TestResultStatus.Passed).Count();
                        var failledResult = allResults.Where(test => test.Status == TestResultStatus.Failed).Count();
                        var canceledResult = allResults.Where(test => test.Status == TestResultStatus.Canceled).Count();
                        var notRun = allResults.Where(test => test.Status == TestResultStatus.NotRun).Count();
                        if (passedResult == 0 || failledResult > 0 || canceledResult > 0 || notRun > 0)
                        {
                            Console.WriteLine("{0}:{1} - Passed Test:{2}, Failed Test:{3}, Canceled Test:{4}, Not Run:{5} ", item.Name, item.Id, passedResult, failledResult, canceledResult, notRun);
                        }
                        else
                        {
                            if (bShowPassingResults)
                            {
                                Console.WriteLine("{0}:{1} - Passed Test:{2}, Failed Test:{3}, Canceled Test:{4}, Not Run:{5} ", item.Name, item.Id, passedResult, failledResult, canceledResult, notRun);
                            }
                        }
                    });

            return missingTestCount;
        }
    }
}

PlaylistDL.cs

//--------------------------------------------------------------------------------------------------------------------
// <copyright file="PlaylistDL.cs" company="Microsoft">
//    Copyright (c) Microsoft. All rights reserved.
// </copyright>
//--------------------------------------------------------------------------------------------------------------------

namespace Sample.MissingTest
{
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    using System.Threading.Tasks;
    using System.Xml.Serialization;

    /// <summary>
    /// Represents a Playlist file as a .NET Class
    /// </summary>
    [System.CodeDom.Compiler.GeneratedCodeAttribute("xsd", "4.0.30319.33440")]
    [System.SerializableAttribute]
    [System.Diagnostics.DebuggerStepThroughAttribute]
    [System.ComponentModel.DesignerCategoryAttribute("code")]
    [System.Xml.Serialization.XmlTypeAttribute(TypeName = "Playlist", Namespace = "http://schemas.microsoft.com/hlk/playlist/2014")]
    [System.Xml.Serialization.XmlRootAttribute(ElementName = "Playlist", Namespace = "http://schemas.microsoft.com/hlk/playlist/2014", IsNullable = false)]
    public partial class PlaylistDL
    {
        /// <summary>
        /// Playlist's list of tests
        /// </summary>
        private PlaylistTestDL[] testSetField;

        /// <summary>
        /// Playlist Id
        /// </summary>
        private string idField;

        /// <summary>
        /// Playlist version
        /// </summary>
        private string versionField;

        /// <summary>
        /// Playlist name
        /// </summary>
        private string nameField;

        /// <summary>
        /// Gets or sets the list of <see cref="PlaylistTestDL"/>s.
        /// </summary>
        [System.Xml.Serialization.XmlElementAttribute("Test")]
        public PlaylistTestDL[] TestSet
        {
            get
            {
                return this.testSetField;
            }

            set
            {
                this.testSetField = value;
            }
        }

        /// <summary>
        /// Gets or sets the Playlist Id
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Id
        {
            get
            {
                return this.idField;
            }

            set
            {
                this.idField = value;
            }
        }

        /// <summary>
        /// Gets or sets the Playlist Version
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Version
        {
            get
            {
                return this.versionField;
            }

            set
            {
                this.versionField = value;
            }
        }

        /// <summary>
        /// Gets or sets the Playlist Version
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Name
        {
            get
            {
                return this.nameField;
            }

            set
            {
                this.nameField = value;
            }
        }
    }

    /// <summary>
    /// Represents a test element inside of a Playlist file.
    /// </summary>
    [System.CodeDom.Compiler.GeneratedCodeAttribute("xsd", "4.0.30319.33440")]
    [System.SerializableAttribute]
    [System.Diagnostics.DebuggerStepThroughAttribute]
    [System.ComponentModel.DesignerCategoryAttribute("code")]
    [System.Xml.Serialization.XmlTypeAttribute(TypeName = "Test", Namespace = "http://schemas.microsoft.com/hlk/playlist/2014")]
    public partial class PlaylistTestDL
    {
        /// <summary>
        /// Test's list of features
        /// </summary>
        private PlaylistFeature[] featureSetField;

        /// <summary>
        /// Test's list of platforms
        /// </summary>
        private PlaylistOSPlatform[] osPlatformSetField;

        /// <summary>
        /// Test Id
        /// </summary>
        private string idField;

        /// <summary>
        /// Test name
        /// </summary>
        private string nameField;

        /// <summary>
        /// Test version
        /// </summary>
        private string versionField;

        /// <summary>
        /// Gets or sets the test Id
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Id
        {
            get
            {
                return this.idField;
            }

            set
            {
                this.idField = value;
            }
        }

        /// <summary>
        /// Gets or sets the test name
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Name
        {
            get
            {
                return this.nameField;
            }

            set
            {
                this.nameField = value;
            }
        }

        /// <summary>
        /// Gets or sets the test version
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Version
        {
            get
            {
                return this.versionField;
            }

            set
            {
                this.versionField = value;
            }
        }

        /// <summary>
        /// Gets or sets the list of <see cref="PlaylistFeature"/> objects.
        /// </summary>
        [System.Xml.Serialization.XmlElementAttribute("Feature")]
        public PlaylistFeature[] FeatureSet
        {
            get
            {
                return this.featureSetField;
            }

            set
            {
                this.featureSetField = value;
            }
        }

        /// <summary>
        /// Gets or sets the list of <see cref="PlaylistOSPlatform"/> objects.
        /// </summary>
        [System.Xml.Serialization.XmlElementAttribute("OSPlatform")]
        public PlaylistOSPlatform[] OSPlatformSet
        {
            get
            {
                return this.osPlatformSetField;
            }

            set
            {
                this.osPlatformSetField = value;
            }
        }
    }

    /// <summary>
    /// Represents a Feature element inside of a Test element.
    /// </summary>
    [System.SerializableAttribute]
    [System.Diagnostics.DebuggerStepThroughAttribute]
    [System.ComponentModel.DesignerCategoryAttribute("code")]
    [System.Xml.Serialization.XmlTypeAttribute(TypeName = "Feature", Namespace = "http://schemas.microsoft.com/hlk/playlist/2014")]
    public partial class PlaylistFeature
    {
        /// <summary>
        /// Feature name
        /// </summary>
        private string nameField;

        /// <summary>
        /// Gets or sets the Feature name
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Name
        {
            get
            {
                return this.nameField;
            }

            set
            {
                this.nameField = value;
            }
        }
    }

    /// <summary>
    /// Represents an OS Platform element inside of a Test.
    /// </summary>
    [System.SerializableAttribute]
    [System.Diagnostics.DebuggerStepThroughAttribute]
    [System.ComponentModel.DesignerCategoryAttribute("code")]
    [System.Xml.Serialization.XmlTypeAttribute(TypeName = "OSPlatform", Namespace = "http://schemas.microsoft.com/hlk/playlist/2014")]
    public partial class PlaylistOSPlatform
    {
        /// <summary>
        /// OS Platform name
        /// </summary>
        private string nameField;

        /// <summary>
        /// Gets or sets the OS Platform name
        /// </summary>
        [System.Xml.Serialization.XmlAttributeAttribute]
        public string Name
        {
            get
            {
                return this.nameField;
            }

            set
            {
                this.nameField = value;
            }
        }
    }
}

PlaylistHelper.cs

//--------------------------------------------------------------------------------------------------------------------
// <copyright file="PlaylistHelper.cs" company="Microsoft">
//    Copyright (c) Microsoft. All rights reserved.
// </copyright>
//--------------------------------------------------------------------------------------------------------------------

namespace Sample.MissingTest
{
    using System;
    using System.Collections.Generic;
    using System.Globalization;
    using System.IO;
    using System.Linq;
    using System.Xml;
    using System.Xml.Schema;
    using System.Xml.Serialization;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;

    /// <summary>
    /// Class containing helper methods for finding missing tests for
    /// down level (RS1/TH2) OSes
    /// </summary>
    public class PlaylistHelper
    {
        /// <summary>
        /// Playlist file extension
        /// </summary>
        private const string PlaylistFileExtension = ".xml";

        /// <summary>
        /// Uses the given <see cref="PlaylistDL"/> to find tests for each <see cref="Target"/> in the the given list
        /// of <see cref="ProductInstance"/> objects that should be present but are not.
        /// </summary>
        /// <param name="playlistDL">The <see cref="PlaylistDL"/> for which missing tests will be found.</param>
        /// <param name="pi">The <see cref="ProductInstance"/> objects to check in.</param>
        /// <returns>
        /// A dictionary containing a list of missing tests for each <see cref="Target"/> in the <paramref name="pis"/>.
        /// </returns>
        /// <remarks>
        /// Tests are determined to be missing if they have features that match the features of a Target, but the Test
        /// itself does not exist for the Target.
        /// This functionality should only be used in conjunction with official Playlist files for the Compact program.
        /// </remarks>
        internal static Dictionary<Target, List<PlaylistTestDL>> GetMissingTests(PlaylistDL playlistDL, ProductInstance pi)
        {
            if (playlistDL == null)
            {
                throw new ArgumentNullException("playlist");
            }

            if (pi == null)
            {
                throw new ArgumentNullException("pi");
            }

            Dictionary<Target, List<PlaylistTestDL>> missingTestsDL = new Dictionary<Target, List<PlaylistTestDL>>();

            string productInstancePlatformName = pi.OSPlatform.Name;

            foreach (TargetFamily tf in pi.GetTargetFamilies())
            {
                if (tf.GetTargets().Count < 1)
                {
                    continue;
                }

                List<Test> targetFamilyTests = tf.GetTests().ToList();
                List<Feature> targetFamilyFeatures = new List<Feature>(tf.GetFeatures());
                List<PlaylistTestDL> targetFamilyMissingTestsDL = new List<PlaylistTestDL>();

                foreach (PlaylistTestDL playlistTestDL in playlistDL.TestSet)
                {
                    if (FeaturesMatch(targetFamilyFeatures, playlistTestDL) &&
                        OSPlatformsMatch(productInstancePlatformName, playlistTestDL))
                    {
                        if (!targetFamilyTests.Exists(test => test.Id.Equals(playlistTestDL.Id, StringComparison.OrdinalIgnoreCase)))
                        {
                            targetFamilyMissingTestsDL.Add(playlistTestDL);
                        }
                    }
                }

                if (targetFamilyMissingTestsDL.Count > 0)
                {
                    // since all Targets in a TargetFamily should be equivalent, just return the first one
                    missingTestsDL.Add(tf.GetTargets().FirstOrDefault(), targetFamilyMissingTestsDL);
                }
            }

            return missingTestsDL;
        }

        /// <summary>
        /// Deserializes a playlist file into a <see cref="PlaylistDL"/> object
        /// </summary>
        /// <param name="playlistImportPath">full path to the playlist file</param>
        /// <returns>a <see cref="PlaylistDL"/> created from the given file.</returns>
        /// <exception cref="ArgumentNullException">When the given path is null.</exception>
        /// <exception cref="ArgumentException">When the given path is empty or has invalid characters.</exception>
        /// <exception cref="PlaylistException">When the given Playlist file does not conform to the schema.</exception>
        internal static PlaylistDL DeserializePlaylistDL(string playlistImportPath)
        {
            if (playlistImportPath == null)
            {
                throw new ArgumentNullException("playlistImportPath");
            }

            playlistImportPath = GetCleanFilePath(playlistImportPath);

            if (!File.Exists(playlistImportPath))
            {
                string message = string.Format(CultureInfo.InvariantCulture, "Playlist file could not be found: '{0}'.", playlistImportPath);
                throw new PlaylistException(message);
            }

            try
            {
                ValidateSchema(playlistImportPath);
            }
            catch (XmlException xmlException)
            {
                string message = string.Format(
                    CultureInfo.InvariantCulture,
                    "The Playlist file '{0}' has malformed XML contents.\n{1}",
                    playlistImportPath,
                    xmlException.Message);
                throw new PlaylistException(message, xmlException);
            }
            catch (PlaylistException playlistException)
            {
                string exMessage = playlistException.InnerException != null ? playlistException.InnerException.Message : string.Empty;
                string message = string.Format(CultureInfo.InvariantCulture, "Playlist file '{0}' has an incorrect format: '{1}'.", playlistImportPath, exMessage);
                throw new PlaylistException(message, playlistException);
            }

            PlaylistDL playlistDL = new PlaylistDL();
            XmlSerializer serializer = new XmlSerializer(typeof(PlaylistDL));

            try
            {
                using (FileStream fs = File.Open(playlistImportPath, FileMode.Open, FileAccess.Read, FileShare.Read))
                {
                    playlistDL = (PlaylistDL)serializer.Deserialize(fs);
                }
            }
            catch (Exception ex)
            {
                if (ex is IOException || ex is UnauthorizedAccessException)
                {
                    string message = string.Format(
                        CultureInfo.InvariantCulture,
                        "Could not open the Playlist file '{0}': {1}",
                        playlistImportPath,
                        ex.Message);
                    throw new PlaylistException(message, ex);
                }

                throw;
            }

            if (playlistDL.TestSet == null)
            {
                string message = string.Format(
                    CultureInfo.InvariantCulture,
                    "The Playlist file '{0}' does not contain any tests.",
                    playlistImportPath);
                throw new PlaylistException(message);
            }

            // check that the Guids are correctly formed
            foreach (PlaylistTestDL playlistTestDL in playlistDL.TestSet)
            {
                try
                {
                    Guid guid = new Guid(playlistDL.Id);
                }
                catch (FormatException badGuidException)
                {
                    string message = string.Format(CultureInfo.InvariantCulture, "A Playlist Test has an invalid Id: '{0}'.", playlistDL.Id);
                    throw new PlaylistException(message, badGuidException);
                }
            }

            return playlistDL;
        }

        /// <summary>
        /// Determines whether any of the given <see cref="Feature"/> objects match the features for the given <see cref="PlaylistTest"/>.
        /// </summary>
        /// <param name="features">list of <see cref="Feature"/> objects</param>
        /// <param name="playlistTestDL">test from a playlist that contains features to check against <paramref name="features"/></param>
        /// <returns>whether <paramref name="features"/> and <paramref name="playlistTestDL"/> have any features in common</returns>
        private static bool FeaturesMatch(List<Feature> features, PlaylistTestDL playlistTestDL)
        {
            if (features == null)
            {
                return false;
            }

            if (playlistTestDL == null)
            {
                return false;
            }

            if (playlistTestDL.FeatureSet == null)
            {
                return false;
            }

            if (features.Count == 0)
            {
                return false;
            }

            foreach (PlaylistFeature feature in playlistTestDL.FeatureSet)
            {
                if (features.Exists(feat => feat.FullName.Equals(feature.Name, StringComparison.OrdinalIgnoreCase)))
                {
                    return true;
                }
            }

            return false;
        }

        /// <summary>
        /// Determines whether the given <see cref="OSPlatform"/> name matches any of the OSPlatforms for the given <see cref="PlaylistTest"/>.
        /// </summary>
        /// <param name="osPlatformName">platform name to check for</param>
        /// <param name="playlistTestDL">test from a playlist that contains OS platforms to check against <paramref name="osPlatformName"/></param>
        /// <returns>whether <paramref name="osPlatformName"/> and <paramref name="playlistTestDL"/> have any OS Platforms in common</returns>
        private static bool OSPlatformsMatch(string osPlatformName, PlaylistTestDL playlistTestDL)
        {
            if (osPlatformName == null)
            {
                return false;
            }

            if (playlistTestDL == null)
            {
                return false;
            }

            if (playlistTestDL.OSPlatformSet == null)
            {
                return false;
            }

            if (playlistTestDL.OSPlatformSet.Length == 0)
            {
                return false;
            }

            if (playlistTestDL.OSPlatformSet.Any(platform => osPlatformName.Equals(platform.Name, StringComparison.OrdinalIgnoreCase)))
            {
                return true;
            }

            return false;
        }

        /// <summary>
        /// Validates the given Playlist file against the Playlist schema
        /// </summary>
        /// <param name="filePath">full path to the Playlist file</param>
        /// <exception cref="XmlException">If the file's XML is not well-formed XML.</exception>
        private static void ValidateSchema(string filePath)
        {
            XmlReaderSettings readerSettings = new XmlReaderSettings();
            readerSettings.Schemas.Add("http://schemas.microsoft.com/hlk/playlist/2014", "PlaylistDL.xsd");
            readerSettings.ValidationType = ValidationType.Schema;

            XmlReader xmlReader = XmlReader.Create(filePath, readerSettings);
            XmlDocument document = new XmlDocument();
            document.Load(xmlReader);

            ValidationEventHandler eventHandler = new ValidationEventHandler(PlaylistSchemaValidationEventHandler);
            document.Validate(eventHandler);
        }

        /// <summary>
        /// Handles the case where a Playlist schema validation has failed.
        /// </summary>
        /// <param name="sender">the object this handler was called from</param>
        /// <param name="e">the validation information</param>
        /// <exception cref="PlaylistException">throws whenever this method is called</exception>
        private static void PlaylistSchemaValidationEventHandler(object sender, ValidationEventArgs e)
        {
            throw new PlaylistException("The playlist's contents do not match the Playlist schema.", e.Exception);
        }

        /// <summary>
        /// Performs checks and actions on the given <paramref name="filePath"/> string:
        /// 1) Checks that the file name does not contain any invalid characters
        /// 2) Checks that the file path does not contain any invalid characters
        /// 3) Expands environment variables before returning a guaranteed clean path.
        /// </summary>
        /// <param name="filePath">path string to check/clean</param>
        /// <exception cref="ArgumentException">
        /// The given <paramref name="filePath"/> is empty or fails one of the above checks.
        /// </exception>
        /// <returns>a checked/cleaned file path string with environment variables expanded</returns>
        private static string GetCleanFilePath(string filePath)
        {
            // Ensure that the playlist path is not null.
            if (filePath == null)
            {
                throw new ArgumentNullException("filePath");
            }

            if (string.IsNullOrEmpty(filePath))
            {
                throw new ArgumentException("Parameter filePath is empty.", "filePath");
            }

            // Ensure that the file name provided does not contain invalid file name characters.
            if (Path.GetFileName(filePath).IndexOfAny(Path.GetInvalidFileNameChars()) != -1)
            {
                ArgumentException exception = new ArgumentException("filePath contains invalid file name characters");
                throw exception;
            }

            // Ensure that the path provided does not contain invalid path characters
            if (Path.GetFullPath(filePath).IndexOfAny(Path.GetInvalidPathChars()) != -1)
            {
                ArgumentException exception = new ArgumentException("filePath contains invalid path characters");
                throw exception;
            }

            if (!Path.GetExtension(filePath).Equals(PlaylistFileExtension, StringComparison.OrdinalIgnoreCase))
            {
                string msg = string.Format(
                    CultureInfo.InvariantCulture,
                    "filePath contains an invalid extension: '{0}'.",
                    Path.GetExtension(filePath));
                ArgumentException exception = new ArgumentException(msg);
                throw exception;
            }

            string expandedPlaylistName = Environment.ExpandEnvironmentVariables(filePath);

            return expandedPlaylistName;
        }
    }
}

PlaylistDL.xsd

<?xml version="1.0" encoding="utf-8"?>
<xs:schema
  elementFormDefault="qualified"
  xmlns:xs="http://www.w3.org/2001/XMLSchema"
  xmlns="http://schemas.microsoft.com/hlk/playlist/2014"
  targetNamespace="http://schemas.microsoft.com/hlk/playlist/2014">
  <xs:simpleType name="Guid">
    <xs:annotation>
      <xs:documentation>
        The 'guid' type requires a 32 digit hyphen separated string, with digits in groups of 8-4-4-4-12 in that order.
        The correct format: 00000000-0000-0000-0000-000000000000.
        Each digit must be a hex value.
      </xs:documentation>
    </xs:annotation>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}"/>
    </xs:restriction>
  </xs:simpleType>
  <xs:simpleType name="Version">
    <xs:annotation>
      <xs:documentation>
        The 'version' type requires a 'Major.Minor' format composed of integers.
        For example, '3.15', or '15.1'.
        Both Major and Minor may have up to 4 characters. E.g. 9999.9999
      </xs:documentation>
    </xs:annotation>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{1,4}\.[0-9]{1,4}"/>
    </xs:restriction>
  </xs:simpleType>
  <xs:simpleType name="FeatureName">
    <xs:annotation>
      <xs:documentation>
        A FeatureName type consists of strings separated by periods.
        There should be no spaces in the FeatureName.
        The max length for FeatureName is 150 characters.
      </xs:documentation>
    </xs:annotation>
    <xs:restriction base="xs:string">
      <xs:pattern value="^([a-zA-Z0-9]+\.?)+[^\. ]$"/>
      <xs:maxLength value="150"/>
    </xs:restriction>
  </xs:simpleType>
  <xs:element name="Playlist">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="Test" minOccurs="0" maxOccurs="unbounded">
          <xs:complexType>
            <xs:sequence>
              <xs:element name="Feature" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <xs:attribute name="Name" type="FeatureName" use="required"/>
                </xs:complexType>
              </xs:element>
              <xs:element name="OSPlatform" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <xs:attribute name="Name" type="xs:string" use="required"/>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="Id" type="Guid" use="required"/>
            <xs:attribute name="Name" type="xs:string"/>
            <xs:attribute name="Version" type="Version"/>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
      <xs:attribute name="Id" type="Guid" use="required"/>
      <xs:attribute name="Name" type="xs:string"/>
      <xs:attribute name="Version" type="Version" />
    </xs:complexType>
  </xs:element>
</xs:schema>


Machine Pool Growth

This sample uses the Machine Pool Growth feature to add and automatically redistribute tests to targets after a test has been scheduled.

Before running this sample, you must do the following:

  1. Set up two systems running the same CPU family and operating system with the same target or sets of targets on both (e.g. same Hardware IDs).

  2. Create a project on one system, add the target(s) and queue up lots of tests.

  3. Move the second to the same machine pool (using HLK Studio or programmatically) as the first system and run the sample.

C#

//-----------------------------------------------------------------------
// <copyright file="MachinePoolGrowthSample.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------
[assembly: System.CLSCompliant(true)]

namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.Generic;
    using System.Linq;

    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// This sample for using the Machine Pool Growth feature to add and automatically redistribute tests to targets after
    /// a test has been scheduled.
    ///
    /// Before running this sample,
    /// 1. Set up two systems running the same CPU family and operating system with the same target or sets of targets on both (e.g. same Hardware Ids).
    /// 2. Create a project on one system, add the target(s) and queue up lots of tests.
    /// 3. Move the second to the same machine pool (using HLK Studio or programmatically) as the first system and run the sample.
    /// </summary>
    class MachinePoolGrowthSample
    {
        /// <summary>
        /// Main entry point.
        /// </summary>
        /// <param name="args">
        /// The command line arguments for the application.
        /// The first argument is the controller name to connect to.
        /// The second argument is the project to redistribute tests for newly added targets.
        /// </param>
        /// <exception cref="ArgumentException">Thrown if two arguments are not specified.</exception>
        static void Main(string[] args)
        {
            if (args.Length != 2)
            {
                throw new ArgumentException("args");
            }

            string serverName = args[0];
            string runningProject = args[1];

            // get a server name
            ProjectManager manager = new DatabaseProjectManager(serverName);
            Project project = manager.GetProject( runningProject );

            List<Target> addedTargets = new List<Target>();

            // walk through each product instance...
            foreach (ProductInstance instance in project.GetProductInstances())
            {
                // get any matching targets from machines in the same pool that are not a part of the current target set
                Console.WriteLine("Looking for any targets in Machine Pool {0}{1} that contain similar targets", instance.MachinePool.Path, instance.MachinePool.Name);

                // loop through product instance's target family
                foreach (TargetFamily targetFamily in instance.GetTargetFamilies())
                {
                    // loop through any targets compatible with the current target family
                    foreach( TargetData targetData in instance.FindTargetFromDeviceFamily(targetFamily.Family) )
                    {
                        if (targetFamily.IsValidTarget(targetData))
                        {
                            // create target and add it to the added target set if we can.
                            addedTargets.Add(targetFamily.CreateTarget(targetData));
                        }
                    }
                }
            }

            // nothing to do if there are no targets compatible with the specified project that have not already been added.
            if (addedTargets.Count == 0)
            {
                Console.WriteLine("No targets were added to the project, no tests to redistribute.");
                return;
            }

            IList<TestResult> cancelFailedResults;
            IList<TestResult> cancelledResults;
            IList<TestResult> reScheduledResults;
            IList<Test> rescheduleFailedTests;

            // do test redistribution across newly added targets
            Target.RedistributeScheduledTests(addedTargets, out cancelFailedResults, out cancelledResults, out reScheduledResults, out rescheduleFailedTests);

            // print out results that were successfully rescheduled.
            if (reScheduledResults.Count > 0)
            {
                Console.WriteLine("Test results which were successfully rescheduled:");
                foreach (TestResult result in reScheduledResults)
                {
                    LogTestResultData(result);
                }
            }

            // print out tests that could not be successfully rescheduled.
            if (rescheduleFailedTests.Count > 0)
            {
                Console.WriteLine("The following tests could not be rescheduled:");
                foreach (Test test in rescheduleFailedTests)
                {
                    Console.WriteLine("Test '{0}' for device {1}'", test.Name, test.GetTestTargets()[0].TargetFamily.Family.Name);
                }
            }

            // print out tests that could not be cancelled, if any
            if (cancelFailedResults.Count > 0)
            {
                Console.WriteLine("Test results which could not be cancelled:");
                foreach (TestResult result in cancelFailedResults)
                {
                    LogTestResultData(result);
                }
            }

            // print out results that were successfuly cancelled.
            if (cancelledResults.Count > 0)
            {
                Console.WriteLine("Test results which weres successfully cancelled:");
                foreach (TestResult result in cancelledResults)
                {
                    LogTestResultData(result);
                }
            }
        }

        /// <summary>
        /// Dump out information about the result that was cancelled/rescheduled/failed to reschedule.
        /// </summary>
        /// <param name="result">The result object to dump name/info for.</param>
        static void LogTestResultData(TestResult result)
        {
            List<Test> tests = new List<Test>();

            // Note: Calling IsMultiDevice and GetAllTests on results that have not run or are not capable of running in MultiDevice mode
            //       will work, but checking if the test is capable of running in MultiDevice mode can make the code run a bit quicker.
            if (result.Test.ScheduleOptions.HasFlag(DistributionOption.ConsolidateScheduleAcrossTargets) && result.IsMultiDevice)
            {
                Console.WriteLine("Test {0} for multiple targets running as a Multi-Device test:", result.Test.Name);

                // Get all targets for all tests that were rolled up into the result for MultiDevice tests
                foreach (Test test in result.GetAllTests())
                {
                    Console.WriteLine("  {0}", test.GetTestTargets()[0].TargetFamily.Family.Name);
                }
            }
            else
            {
                // For non-multidevice results, there will always be only one test associated with the results and can result.Test.
                Console.WriteLine("Test {0} for target {1}", result.Test.Name, result.Test.GetTestTargets()[0].TargetFamily.Family.Name);
            }
        }
    }
}

PowerShell

Clear-Host;

$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

# Dump out information about a test result
Function LogTestResultData( $testResult )
{
    if( ( ($testResult.Test.ScheduleOptions -band [Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::ConsolidateScheduleAcrossTargets ) -eq [Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::ConsolidateScheduleAcrossTargets ) -and $testResult.IsMultiDevice )
    {
        Write-Host "Test $($testResult.Test.Name) for multiple targets running as a Multi-Device test";

        foreach( $test in $testResult.GetAllTests() )
        {
            Write-Host "  $($test.GetTestTargets()[0].TargetFamily.Family.Name)";
        }
    }
    else
    {
        Write-Host "Test $($testResult.Test.Name) for target $($testResult.Test.GetTestTargets()[0].TargetFamily.Family.Name)";
    }
}

$connectFileName = $env:WTTSTDIO + "connect.xml"
Write-Host Opening connection file $connectFileName
$connectFile = [xml](Get-Content $connectFileName)

$ControllerName = $connectFile.Connection.GetAttribute("Server")
$DatabaseName = $connectFile.Connection.GetAttribute("Source")

$Manager =  new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, $DatabaseName

$addedTargetList = New-Object -TypeName  System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.Target];

#Load Project
$Project = $Manager.GetProject("Test");

foreach($productInstance in $Project.GetProductInstances())
{
    $currentPool = $productInstance.MachinePool;
    Write-Host "Looking for any targets in $($currentPool.Path)$($CurrentPool.Name) that are compatible with the current project"

    foreach ($targetFamily in $productInstance.GetTargetFamilies())
    {
        foreach($targetData in  $productInstance.FindTargetFromDeviceFamily($targetFamily.Family))
        {
            if($targetFamily.IsValidTarget($targetData))
            {
                $addedTargetList.Add($targetFamily.CreateTarget($targetData));
            }
        }
    }
}

# no targets to expand project to -- nothing to do
if($addedTargetList.Count -eq 0 )
{
    Write-Host "No compatible targets were found, returning";
    return;
}

foreach($addedTarget in $addedTargetList)
{
    Write-Host "Added target $($addedTarget.Name) on machine $($addedTarget.Machine.Name)"
}

$cancelFailedResults= New-Object -TypeName  System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.TestResult];
$cancelledResults= New-Object -TypeName  System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.TestResult];
$rescheduledResults= New-Object -TypeName  System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.TestResult];
$rescheduleFailedTests= New-Object -TypeName  System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.Test];

[Microsoft.Windows.Kits.Hardware.ObjectModel.Target]::RedistributeScheduledTests($addedTargetList, [ref]$cancelFailedResults, [ref]$cancelledResults, [ref]$reScheduledResults, [ref]$rescheduleFailedTests);

# display test results which were rescheduled using machine pool growth
if($rescheduledResults.Count -gt 0 )
{
    Write-Host
    Write-Host "Test results which were successfully rescheduled:";

    foreach($rescheduledResult in $rescheduledResults)
    {
        LogTestResultData( $rescheduledResult );
    }
}

# display tests that could not be rescheduled
if( $rescheduleFailedTests.Count -gt 0 )
{
    Write-Host
    Write-Host "The following tests could not be rescheduled:";

    foreach( $test in $rescheduleFailedTests )
    {
        Write-Host "Test $($test.Name) for device $($test.GetTestTargets()[0].TargetFamily.Family)";
    }
}

# display tests that were successfully cancelled after it was rescheduled
if($cancelledResults.Count -gt 0 )
{
    Write-Host
    Write-Host "Test results which were successfully cancelled";

    foreach($cancelledResult in $cancelledResults)
    {
        LogTestResultData( $cancelledResult );
    }
}

# display tests that could not be cancelled after it was rescheduled
if($cancelFailedResults.Count -gt 0 )
{
    Write-Host
    Write-Host "Test results which could not be cancelled:";

    foreach($cancelFailedResult in $cancelFailedResults)
    {
        LogTestResultData( $cancelFailedResult );
    }
}


Machines in use

This sample shows how to retrieve the names of machines on which tests are currently running.

PowerShell

. ..\Initialization.ps1

write-Host "Usage: %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -file MachinesInUse.ps1 <<ProjectName>>"

$Manager = Initialize

$ProjectName = $Args[0]
Write-Host Getting Project named : $ProjectName
$Project = $Manager.GetProject($ProjectName)

$Project.GetProductInstances() | foreach {
    $_.GetTargetFamilies() | foreach {
# get all of the running tests
        $_.GetTests() | where {$_.Status -eq [Microsoft.Windows.Kits.Hardware.ObjectModel.TestResultStatus]::InQueue } | foreach {

# this is a test
            $Test = $_
            Write-Host Test is running or queued : $_.Name
# it should have children, see where they are running on

            $Results = $_.GetTestResults()

#Running tests
            $Results | where {$_.Status -eq [Microsoft.Windows.Kits.Hardware.ObjectModel.TestResultStatus]::InQueue} | foreach {
                Write-Host test is waiting
                $Test.GetTestTargets() | foreach { Write-Host `tMachine: $_.Machine.Name $_.Name $_.Machine.Status }
            }

            $Results | where {$_.Status -eq [Microsoft.Windows.Kits.Hardware.ObjectModel.TestResultStatus]::Running} | foreach {
                Write-Host test is Running
                $_.Machine.Name
            }
        }
    }
}


Manage Machine State

The following code sample shows how to manage machine stated.

C#

// ------------------------------------------------------------------------------------------------
// <copyright file="MachineStateManagement.cs" company="Microsoft">
//   Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
// ------------------------------------------------------------------------------------------------

//[assembly: System.CLSCompliant(true)]

namespace Microsoft.Windows.Kits.Samples
{
    using System;

    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// Sample code for getting test roll-up by content level
    /// </summary>
    public class MachineStateManagement
    {
        /// <summary>
        /// Prevents a default instance of the <see cref="MachineStateManagement"/> class from being created.
        /// </summary>
        private MachineStateManagement()
        {
        }

        /// <summary>
        /// Entry point method for the machine state management sample application
        /// </summary>
        /// <param name="args">standard parameter arguments</param>
        public static void Main(string[] args)
        {
            string controllerName;
            string projectName;
            if (args.Length == 2)
            {
                controllerName = args[0];
                projectName = args[1];
            }
            else
            {
                Console.WriteLine("Usage:\tMachineStateManagement.exe [ControllerMachineName] [ProjectName]");
                return;
            }

            // first we need to connect to the controller
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // let's first get the root machine pool; root pool is represented as '$'
            MachinePool rootMachinePool = manager.GetRootMachinePool();

            // now let's get child pools for the root pool; root pool will also contain 'Default Pool'
            // Note: By default, new client machines are added to the 'Default Pool'; For running tests, we have to create a new machine pool (say, TestPool) and move client machines from 'Default Pool' to 'TestPool'
            foreach (MachinePool machinePool in rootMachinePool.GetChildPools())
            {
                if (machinePool.Equals(machinePool.DefaultPool))
                {
                    // Skip - can't change status of a machine in the 'Default Pool' or root pool ('$').
                    // Note: To skip any machine operations for root pool, when you're not sure whether the current machine pools is a root pool or not, then you can do an additional check for:  machinePool.Equals(machinePool.RootPool)
                    continue;
                }

                foreach (Machine machine in machinePool.GetMachines())
                {
                    if (machine.Status == MachineStatus.NotReady)
                    {
                        // timeout is set to 30 seconds
                        Console.WriteLine("Changing machine '{0}' status to 'Ready'", machine.Name);
                        if (machine.SetMachineStatus(MachineStatus.Ready, 30000))
                        {
                            Console.WriteLine("Machine '{0}' was successfully set to Ready state", machine.Name);
                        }
                    }
                }
            }

            // If you're only interested in the machine pool for a specific project, you can also do this:
            // load the project
            Project project = manager.GetProject(projectName);

            // enumerate the machine pools in the product instances for the current project
            foreach (ProductInstance productInstance in project.GetProductInstances())
            {
                MachinePool machinePool = productInstance.MachinePool;

                if (machinePool == null ||
                    machinePool.Equals(machinePool.RootPool) ||
                    machinePool.Equals(machinePool.DefaultPool))
                {
                    // Skip - can't change status of a machine in the 'Default Pool' or root pool ('$')
                    continue;
                }

                // this code snippet is same as in the above example. It's added here again for clarity
                foreach (Machine machine in machinePool.GetMachines())
                {
                    if (machine.Status == MachineStatus.NotReady)
                    {
                        // timeout is set to 30 seconds
                        Console.WriteLine("Changing machine '{0}' status to 'Ready'", machine.Name);
                        if (machine.SetMachineStatus(MachineStatus.Ready, 30000))
                        {
                            Console.WriteLine("Machine '{0}' was successfully set to Ready state", machine.Name);
                        }
                    }
                }
            }
        }
    }
}

Windows PowerShell

. ..\Initialization.ps1

Clear-Host
$Manager = Initialize

#let's first get the root machine pool; root pool is represented as '$'
$rootMachinePool = $Manager.GetRootMachinePool()

$ReadyStatus = [Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::Ready
$NotReadyStatus = [Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::NotReady

#now let's get child pools for the root pool; root pool will also contain 'Default Pool'
#Note: By default, new client machines are added to the 'Default Pool'; For running tests, we have to create a new machine pool (say, TestPool) and move client machines from 'Default Pool' to 'TestPool'
foreach ($machinePool in $rootMachinePool.GetChildPools())
{
if ($machinePool.Equals($machinePool.DefaultPool))
{
# Skip - can't change status of a machine in the 'Default Pool' or root pool ('$').
# Note: To skip any machine operations for root pool, when you're not sure whether the current machine pools is a root pool or not, then you can do an additional check for:  $machinePool.Equals($machinePool.RootPool)
continue;
}

foreach ($machine in $machinePool.GetMachines())
{
if ($machine.Status -eq $NotReadyStatus)
{
#timeout is set to 30 seconds
Write-Host ("Changing machine '{0}' status to 'Ready'" -f $machine.Name)
if($machine.SetMachineStatus($ReadyStatus, 30000))
{
Write-Host ("Machine '{0}' was successfully set to Ready state" -f $machine.Name)
}
}
}
}

#If you're only interested in the machine pool for a specific project, you can also do this:
#load Project
$Project = $Manager.GetProject("TestProject")

#enumerate the machine pools in the product instances for the current project
foreach ($productInstance in $Project.GetProductInstances())
{
$machinePool = $productInstance.MachinePool

if (($machinePool -eq $null) -or
$machinePool.Equals($machinePool.RootPool) -or
$machinePool.Equals($machinePool.DefaultPool))
{
#Skip - can't change status of a machine in the 'Default Pool' or root pool ('$')
continue;
}

#this code snippet is same as in the above example. It's added here again for clarity
foreach ($machine in $machinePool.GetMachines())
{
if ($machine.Status -eq $NotReadyStatus)
{
#timeout is set to 30 seconds
Write-Host ("Changing machine '{0}' status to 'Ready'" -f $machine.Name)
if($machine.SetMachineStatus($ReadyStatus, 30000))
{
Write-Host ("Machine '{0}' was successfully set to Ready state" -f $machine.Name)
}
}
}
}


Mobile Reflash Before a Test Run

This sample shows how to flash an OS image onto a mobile device as part of a test run.

NOTE

This feature is supported only on mobile devices.

C#

//-----------------------------------------------------------------------
// <copyright file="MobileReflashBeforeTestRun.cs" company="Microsoft">
//    Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
//-----------------------------------------------------------------------

using System.Globalization;

[assembly: System.CLSCompliant(true)]

namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Xml;
    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// Sample for using a Target Family
    /// </summary>
    public static class MobileReflashBeforeTestRun
    {
        static ProjectManager ConnectToLocalServer()
        {
            // Note: Flashing an OS image during test scheduling is only supported for Mobile Devices
            // Note: And before running any tests on mobile devices, you would have to onboard the device to the controller
            XmlDocument doc = new XmlDocument();
            doc.Load(Environment.ExpandEnvironmentVariables(@"%WTTSTDIO%\\connect.xml"));
            XmlNode root = doc.SelectSingleNode("/Connection");
            string controllerName = root.Attributes["Server"].Value;
            string databaseName = root.Attributes["Source"].Value;

            DatabaseProjectManager manager = new DatabaseProjectManager(controllerName, databaseName);
            Console.WriteLine("Connected to database {0} on controller {1}", databaseName, controllerName);

            return manager;
        }

        /// <summary>
        /// main entry point
        /// </summary>
        /// <param name="args">standard parameter arguments</param>
        public static void Main(string[] args)
        {
            // first we need to connect to the Server
            ProjectManager manager = ConnectToLocalServer();

            //---------------
            // Machine and Machine pool management
            //---------------
            // now we need to create a machine pool
            const string poolName = "MobileTest";
            MachinePool rootPool = manager.GetRootMachinePool();
            MachinePool testPool = rootPool.GetChildPools().FirstOrDefault(x => x.Name == poolName) ?? rootPool.CreateChildPool(poolName);

            // Move all machines to the test pool and set them to ready state
            foreach (Machine machine in rootPool.DefaultPool.GetMachines())
            {
                // We're assuming all devices in the default pool are Mobile devices.
                rootPool.DefaultPool.MoveMachineTo(machine, testPool);
            }

            Machine testMachine = testPool.GetMachines().FirstOrDefault();
            if (testMachine == null)
            {
                throw new Exception("Could not find any machine to schedule tests.");
            }

            foreach (Machine machine in testPool.GetMachines())
            {
                machine.SetMachineStatus(MachineStatus.Ready, (long)TimeSpan.FromMinutes(1).TotalMilliseconds);
            }

            // create a device family. In production code, please check whether the device family or the hardware id exists already
            string[] hardwareIds = { @"ADCM\QCOM242E" };
            DeviceFamily deviceFamily = manager.CreateDeviceFamily(@"ADCM\QCOM242E", hardwareIds);

            // Create a test project
            Project project = manager.CreateProject(string.Format(CultureInfo.InvariantCulture, "My Device Family Project {0}", DateTime.Now));

            //---------------
            // create a product instance
            //---------------
            ProductInstance productInstance = project.CreateProductInstance("My Product instance", testPool, testMachine.OSPlatform);
            TargetFamily targetFamily = productInstance.CreateTargetFamily(deviceFamily);

            // next we enumerate all of the devices in the system that use one of the hardware IDs in the device family
            foreach (TargetData data in productInstance.FindTargetFromDeviceFamily(deviceFamily))
            {
                // check this first, to see if this can be added
                if (targetFamily.IsValidTarget(data))
                {
                    targetFamily.CreateTarget(data);
                }
            }

            string testName = "DF - Sleep with IO Before and After (Bring Up)";

            Test sampleTest = targetFamily.GetTests().FirstOrDefault(test => test.Name.Equals(testName, StringComparison.OrdinalIgnoreCase));
            if (sampleTest == null)
            {
                throw new Exception(string.Format(CultureInfo.InvariantCulture, "Failed to schedule mobile test. Could not find test '{0}'.", testName));
            }

            TemplateParameters templateParameters = sampleTest.GetDefaultTemplateParameters();

            // Flash image file should be copied to the below path
            templateParameters[TemplateParameter.ImagePath] = string.Format(CultureInfo.InvariantCulture, @"\\{0}\HLKInstall\ProxyTools\Images\flash_lab.ffu", ((DatabaseProjectManager)manager).ControllerName);
            templateParameters[TemplateParameter.ForceReflash] = "1";

            // run test after flashing a new OS image on the mobile device
            sampleTest.QueueTest(templateParameters);
        }
    }
}

PowerShell

#Note: Flashing an OS image during test scheduling is only supported for Mobile Devices

. "$PSScriptRoot\Initialization.ps1"

$ErrorActionPreference = "Stop"

Clear-Host
$Manager = Initialize

# create the project name
$now = [System.DateTime]::Now
$ProjectName = "ProxyTest $now"

$RootPool = $Manager.GetRootMachinePool()
$DefaultPool = $RootPool.DefaultPool

# create the pool
$TestPool = $RootPool.GetChildPools() | Where {$_.Name -eq "MobileTest" }[0]
if ($TestPool -eq $null)
{
    $TestPool = $RootPool.CreateChildPool("MobileTest")
}

#reset all machines
$TestPool.GetMachines() | foreach { $_.SetMachineStatus([Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::Ready, 1) }

#-----------
# Creating a project
#-----------
$Project = $manager.CreateProject($ProjectName)
Write-Host "created a project named : "$Project.Name

$OSPlatform = $TestPool.GetMachines()[0].OSPlatform
$ProductInstance = $Project.CreateProductInstance("My Product Instance",
                                                 $TestPool,
                                                 $OSPlatform)

# Get device family
$DeviceFamily = $Manager.GetDeviceFamilies() | Where-Object {$_.Name -eq "ADCM\QCOM242E"}
$TargetFamily = $ProductInstance.CreateTargetFamily($DeviceFamily)

foreach($targetData in $ProductInstance.FindTargetFromDeviceFamily($DeviceFamily))
{
    if($TargetFamily.IsValidTarget($targetData))
    {
        $TargetInfo = $TargetFamily.CreateTarget($targetData)
        Write-Host Successfully created a target for $TargetInfo.Name
    }
}

Write-Host Total tests for target family $TargetFamily.GetTests().Count

# Find a specific test
$TestName = "DF - Sleep with IO Before and After (Bring Up)"

$Test = $TargetFamily.GetTests() | where { $_.Name -eq $TestName }

if ($Test -eq $null)
{
    Write-Host "Could not find test $TestName"

    Write-Host "Deleting project..."
    $Manager.DeleteProject($ProjectName)

    exit -1
}

Write-Host "Successfully found test $Test.Name"

#get Proxy template parameters
$TemplateParameters = $Test.GetDefaultTemplateParameters()

#set Proxy template parameters
$ControllerName = $Manager.ControllerName
$TemplateParameters["ImagePath"] = "\\$ControllerName\HLKInstall\ProxyTools\Images\flash_lab.ffu"
$TemplateParameters["ForceReflash"] = "1"

#run test on mobile device
$Test.QueueTest($TemplateParameters)


Multi-Device Tests

This sample code show illustrates running multi-device tests.

NOTE

The method returns the base target for multi-device tests (that is the base test device into which additional tests were consolidated). The TestResults.GetAllTests() method should return the list of tests that were actually run together; from that list, you can derive the actual targets against which the test ran.

C#

// ------------------------------------------------------------------------------------------------
// <copyright file="MultiDeviceScheduling.cs" company="Microsoft">
//   Copyright (c) Microsoft Corporation. All rights reserved.
// </copyright>
// ------------------------------------------------------------------------------------------------
[assembly: System.CLSCompliant(true)]

namespace Microsoft.Windows.Kits.Samples.MultiDevice
{
    using System;
    using System.Collections.Generic;
    using System.Collections.ObjectModel;
    using System.Linq;

    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// Sample code for running multi-device tests
    /// </summary>
    public static class MultiDeviceScheduling
    {
        /// <summary>
        /// Entry point method for the sample application
        /// </summary>
        /// <param name="args">standard parameter arguments</param>
        public static void Main(string[] args)
        {
            string controllerName;
            string projectName;

            if (args.Length == 2)
            {
                controllerName = args[0];
                projectName = args[1];
            }
            else
            {
                Console.WriteLine("Usage:\tScheduleTestsByContentLevel.exe [ControllerMachineName] [ProjectName]");
                return;
            }

            // get all content levels
            ContentLevelType[] levels = (ContentLevelType[])Enum.GetValues(typeof(ContentLevelType));

            // first we need to connect to the Server
            ProjectManager manager = new DatabaseProjectManager(controllerName);

            // load the project
            Project project = manager.GetProject(projectName);

            // get tests that can be run without user intervention
            List<Test> tests = project.GetTests(levels).Where(test => test.ScheduleOptions.HasFlag(DistributionOption.RequiresMultipleMachines) && !test.RequiresSupplementalContent && !test.RequiresSpecialConfiguration && test.TestType == TestType.Automated).ToList();

            // get current count of tests
            int originalTestCount = tests.Count;

            // create scheduling groups
            List<List<Test>> testGroups = Test.FilterMultiDeviceTestGroups(tests);

            // after call, tests that cannot be consolidated are removed from the list.
            int removedTests = tests.Count - originalTestCount;

            // if the count of tests removed from the list is zero, there were no multidevice tests in the list.
            if (removedTests == 0)
            {
                Console.WriteLine("No tests were found that could be consolidated.");
                MultiDeviceScheduling.PrintNoMultiDeviceReasonsMessage();
                return;
            }

            if (testGroups.All(testGroup => 0 == testGroup.Count))
            {
                Console.WriteLine("Multidevice tests were found, but no tests could be consolidated.");
                MultiDeviceScheduling.PrintNoMultiDeviceReasonsMessage();
                return;
            }

            // otherwise start scheduling multidevice tests with consolidation where possible.
            Console.WriteLine("{0} MultiDevice tests will be consolidated into {1} tests runs.", removedTests, testGroups.Count);

            List<TestResult> multiDeviceResults = new List<TestResult>();
            // schedule multidevice tests (if any)
            foreach (List<Test> testGroup in testGroups)
            {
                Console.WriteLine("Consolidating {0} instances of test {1} with the following devices:", testGroup.Count, testGroup[0].Name);
                testGroup.ForEach(testGroupItem => Console.WriteLine(testGroupItem.GetTestTargets()[0].TargetFamily.Family.Name));

                multiDeviceResults.AddRange(testGroup[0].QueueTest(testGroup.GetRange(1, testGroup.Count - 1)));
            }

            // schedule the rest of the tests
            foreach (Test test in tests)
            {
                test.QueueTest();
            }

            // performance optimization
            Console.WriteLine("The following tests were scheduled to test multiple devices as one test instance as a performance optimization");
            foreach (TestResult multiDeviceResult in multiDeviceResults)
            {
                if (multiDeviceResult.IsMultiDevice)
                {
                    Console.WriteLine( "The following instances of the test '{0}' were consolidated into one scheduling unit:", multiDeviceResult.Test.Name);

                    foreach (Test test in multiDeviceResult.GetAllTests())
                    {
                        Console.WriteLine("  Instance {0} for target family {0}", test.InstanceId, test.GetTestTargets()[0].TargetFamily.Family.Name);
                    }
                }
            }
        }

        /// <summary>
        /// Print error messages with possible reasons why tests could not be consolidated
        /// </summary>
        private static void PrintNoMultiDeviceReasonsMessage()
        {
            Console.WriteLine("Please verify that:");
            Console.WriteLine(" 1. The submission is a device or driver submission and contains two different target families on the same machine");
            Console.WriteLine(" 2. Both targets run the same multidevice test in the submission (e.g. Test.ScheduleOptions == DistributionOption.ConsolidateScheduleAcrossTargets");
            Console.WriteLine(" 3. Machines that contain both targets are in the ready state");
        }
    }
}

PowerShell

Clear-Host;

    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
    $ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

    $connectFileName = $env:WTTSTDIO + "connect.xml"
    Write-Host Opening connection file $connectFileName
    $connectFile = [xml](Get-Content $connectFileName)

    $ControllerName = $connectFile.Connection.GetAttribute("Server")
    $DatabaseName = $connectFile.Connection.GetAttribute("Source")

$Manager =  new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, $DatabaseName

$TestResultList = New-Object -TypeName  System.Collections.Generic.List``1[Microsoft.Windows.Kits.Hardware.ObjectModel.TestResult];

#Load Project
$Project = $Manager.GetProject("Test");

#Get tests
$tests = $Project.GetTests()| where { $_.ScheduleOptions.HasFlag([Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::ScheduleOnAnyTarget)};

#Get test count
$originalTestCount = $tests.Count;

#Create scheduling groups$test
$testGroups = [Microsoft.Windows.Kits.Hardware.ObjectModel.Test]::FilterMultiDeviceTestGroups($tests);

# get number of tests run will be consolidated into
$consolidatedCount = $testGroups.Count;

Write-Output "MultiDevice tests will be consolidated into $consolidatedCount test runs."

foreach( $testGroup in $testGroups )
{
    $baseTest = [Microsoft.Windows.Kits.Hardware.ObjectModel.Test]$testGroup[0];
    $TestResultList.AddRange($baseTest.QueueTest( $testGroup.GetRange(1, $testGroup.Count - 1 )));
}

Write-Output "The following tests were scheduled using Multi-device scheduling optimizations"

foreach( $testResult in $TestResultList)
{
    $testName = $testResult.Test.Name;

    # not all tests get may get consolidated if additional tests/targets to run with are not available at the time tests are scheduled.
    if( $testResult.IsMultiDevice )
    {
        Write-Output ""
        Write-Output "Multiple instances for $testName were consolidated into a single run as a performance optimization";

        # get all tests in the list if it&#39;s a multidevice test
        $consolidatedTests = $testResult.GetAllTests();

        # dump information about how the result was scheduled.
        foreach($consolidatedTest in $consolidatedTests)
        {
            # print which instance of the test was scheduled and what targets are running together in a single instance.
            $testInstance = $consolidatedTest.InstanceId;
            $targetFamily = $consolidatedTest.GetTestTargets()[0].TargetFamily.Family.Name;
            Write-Output "Instance $testInstance for target $targetFamily";
        }
    }
    else
    {
        $testName = $testResult.Test.Name;
        $targetFamily = $consolidatedTest.GetTestTargets()[0].TargetFamily.Family.Name;
        Write-Output "Test $testName testing device $targetFamily was scheduled singly"
    }
}


Project Definition File schema

The format for the Project Definition File is described below:

Schema definition

<?xml version="1.0" encoding="UTF-8"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<xsd:attribute name="User" type="xsd:string"/>
<xsd:attribute name="Controller" type="xsd:string"/>
<xsd:attribute name="Timeout" type="xsd:nonNegativeInteger"/>
<xsd:attribute name="Database" type="xsd:string"/>
<xsd:attribute name="Name" type="xsd:string"/>
<xsd:attribute name="TestCollectionReadLocation" type="xsd:string"/>
<xsd:attribute name="TestCollectionStatusLocation" type="xsd:string"/>
<xsd:attribute name="OsPlatform" type="xsd:string"/>
<xsd:attribute name="MachinePool" type="xsd:string"/>
<xsd:attribute name="TargetType">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:pattern value="((S|s)(Y|y)(S|s)(T|t)(E|e)(M|m))|((D|d)(E|e)(V|v)(I|i)(C|c)(E|e))|((T|t)(A|a)(R|r)(G|g)(E|e)(T|t)(C|c)(O|o)(L|l)(L|l)(E|e)(C|c)(T|t)(I|i)(O|o)(N|n))"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:attribute>
<xsd:attribute name="Id" type="xsd:string"/>
<xsd:attribute name="Role">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:pattern value="((S|s)(U|u)(T|t))|((C|c)(L|l)(I|i)(E|e)(N|n)(T|t))"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:attribute>
<xsd:attribute name="Path" type="xsd:string"/>
<xsd:element name="ProjectDefinitionData">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Project" minOccurs="1"  maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="User" use="optional"/>
<xsd:attribute ref="Controller" use="required"/>
<xsd:attribute ref="Timeout" use="optional" default="120"/>
<xsd:attribute ref="Database" use="optional" default="HLKJobs"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Project">
<xsd:complexType>
<xsd:sequence>
                        <xsd:element ref="SchedulerType" minOccurs="0" maxOccurs="1"/>
<xsd:element ref="MultiDeviceTestGroup" minOccurs="0" maxOccurs="1"/>
<xsd:element ref="TestStatusToSkip" minOccurs="0" maxOccurs="1"/>
<xsd:element ref="Product" minOccurs="1" maxOccurs="unbounded"/>
<xsd:element ref="Packages" minOccurs="1" maxOccurs="1"/>
</xsd:sequence>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="TestCollectionReadLocation" use="optional"/>
<xsd:attribute ref="TestCollectionStatusLocation" use="optional"/>
</xsd:complexType>
</xsd:element>
                <xsd:element name="SchedulerType">
                                <xsd:simpleType>
                                                <xsd:restriction base="xsd:NMTOKEN">
                                                                <xsd:pattern value="((A|a)(D|d)(A|a)(P|p)(T|t)(I|i)(V|v)(E|e)(O|o)(R|r)(D|d)(E|e)(R|r)(O|o)(P|p)(T|t)(I|i)(M|m)(I|i)(Z|z)(E|e)(D|d))|((A|a)(D|d)(A|a)(P|p)(T|t)(I|i)(V|v)(E|e)(R|r)(E|e)(S|s)(O|o)(U|u)(R|r)(C|c)(E|e)(O|o)(P|p)(T|t)(I|i)(M|m)(I|i)(Z|z)(E|e)(D|d))"/>
                                                </xsd:restriction>
                                </xsd:simpleType>
                </xsd:element>
<xsd:element name="MultiDeviceTestGroup" type="xsd:boolean"/>
<xsd:element name="TestStatusToSkip">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:pattern value="((P|p)(A|a)(S|s)(S|s))|((F|f)(A|a)(I|i)(L|l))|((N|n)(O|o)(D|d)(A|a)(T|t)(A|a))"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:element>
<xsd:element name="Product">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Family" minOccurs="1" maxOccurs="unbounded"/>
<xsd:element ref="Machine" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="OsPlatform" use="required"/>
<xsd:attribute ref="MachinePool" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Family">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="Target" minOccurs="1" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="Name" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Target">
<xsd:complexType>
<xsd:attribute ref="TargetType" use="required"/>
<xsd:attribute ref="Id" use="required"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Machine">
<xsd:complexType>
<xsd:attribute ref="Name" use="required"/>
<xsd:attribute ref="Role" use="optional"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="Packages" type="xsd:string"/>
</xsd:schema>


Schedule Information

This sample shows the usage of the DistributionOption enumeration and associated test metadata flags.

C#

namespace Microsoft.Windows.Kits.Samples
{
    using System;
    using System.Collections.Generic;
    using System.Linq;

    using Microsoft.Windows.Kits.Hardware.ObjectModel;
    using Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection;

    /// <summary>
    /// Sample for changes for new usage of test's Distribution options and new test metadata flags.
    /// </summary>
    class UpdatedScheduleInformationSample
    {
        /// <summary>
        /// Main entry point.
        /// </summary>
        /// <param name="args">
        /// The command line arguments for the application.
        /// The first argument is the controller name to connect to.
        /// The second argument is the project to redistribute tests for newly added targets.
        /// </param>
        /// <exception cref="ArgumentException">Thrown if two arguments are not specified.</exception>
        static void Main(string[] args)
        {
            if (args.Length != 2)
            {
                throw new ArgumentException("args");
            }

            string serverName = args[0];
            string runningProject = args[1];

            // get a server name
            ProjectManager manager = new DatabaseProjectManager(serverName);
            Project project = manager.GetProject(runningProject);

            // just the first 50 tests.
            foreach (Test test in project.GetTests().Take(50))
            {
                Console.WriteLine();
                Console.WriteLine("Distribution options for {0}:", test.Name);

//                these commented out expressions are no longer valid and will not return the correct values.
//
//                bool incorrectMultiMachineTestValue = test.ScheduleOptions == DistributionOption.RequiresMultipleMachines;
//                bool incorrectNonDistributableTestValue = test.ScheduleOptions == DistributionOption.ScheduleOnAnyTarget;
//                bool incorrectDistributableTestValue = test.ScheduleOptions == DistributionOption.ScheduleOnAnyTarget;
//                bool incorrectMultiDeviceTestValue = test.ScheduleOptions == DistributionOption.ConsolidateScheduleAcrossTargets;

                // using bitwise comparison is faster, especially for large sets of tests
                bool multiMachineTest = (test.ScheduleOptions | DistributionOption.RequiresMultipleMachines) == DistributionOption.RequiresMultipleMachines;
                bool nonDistributableTest = (test.ScheduleOptions | DistributionOption.ScheduleOnAllTargets) == DistributionOption.ScheduleOnAllTargets;

                // using HasFlag is cleaner but can be slower
                bool distributableTest = test.ScheduleOptions.HasFlag(DistributionOption.ScheduleOnAnyTarget);
                bool multiDeviceCapableTest = test.ScheduleOptions.HasFlag(DistributionOption.ConsolidateScheduleAcrossTargets);

                bool manualTest = test.TestType == TestType.Manual;

                // print out values for each test.
                Console.WriteLine("Test information for {0}", test.Name);
                Console.WriteLine(" Requires supplemental content to be downloaded and installed : {0}", test.RequiresSupplementalContent);
                Console.WriteLine(" Configuration steps on client required before running        : {0}", test.RequiresSpecialConfiguration);
                Console.WriteLine(" Requires manual input                                        : {0}", manualTest);
                Console.WriteLine(" Requires multimachine configuration to run test              : {0}", multiMachineTest);
                Console.WriteLine(" Must run on each instance of a target in a target family     : {0}", nonDistributableTest);
                Console.WriteLine(" Can run on any instance of a target in a target family       : {0}", distributableTest);
                Console.WriteLine(" Can run multiple tests/targets at once in one test run       : {0}", multiDeviceCapableTest);
            }
        }
    }
}

PowerShell

Clear-Host;

$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

$connectFileName = $env:WTTSTDIO + "connect.xml"
Write-Host Opening connection file $connectFileName
$connectFile = [xml](Get-Content $connectFileName)

$ControllerName = $connectFile.Connection.GetAttribute("Server")
$DatabaseName = $connectFile.Connection.GetAttribute("Source")

$Manager =  new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, $DatabaseName

#Load Project
$Project = $Manager.GetProject("Test");

foreach( $test in $Project.GetTests())
{
    $multiMachineTest = $test.ScheduleOptions.HasFlag([Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::RequiresMultipleMachines);
    $nonDistributableTest = $test.ScheduleOptions.HasFlag([Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::ScheduleOnAllTargets);
    $distributableTest = $test.ScheduleOptions.HasFlag([Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::ScheduleOnAnyTarget);
    $multiDeviceCapableTest = $test.ScheduleOptions.HasFlag([Microsoft.Windows.Kits.Hardware.ObjectModel.DistributionOption]::ConsolidateScheduleAcrossTargets);

    $manualTest = $test.TestType -eq ([Microsoft.Windows.Kits.Hardware.ObjectModel.TestType]::Manual);

    Write-Host;
    Write-Host "Test information for $($test.Name)";
    Write-Host " Requires supplemental content to be downloaded and installed    : $($test.RequiresSupplementalContent)";
    Write-Host " Configuration steps on client required before running           : $($test.RequiresSpecialConfiguration)" ;
    Write-Host " Requires manual input                                           : $manualTest" ;
    Write-Host " Requires multimachine configuration to run test                 : $multiMachineTest";
    Write-Host " Must run on each instance of a target in a target family to pass: $nonDistributableTest";
    Write-Host " Can run on any instance of a target in a target family to pass  : $distributableTest";
    Write-Host " Can run multiple tests/targets at once in one test run          : $multiDeviceCapableTest";
}


Schedule test by Development Phase

This sample demonstrates a few ways to schedule tests.

PowerShell

Clear-Host
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.dbconnection.dll")
$ObjectModel = [Reflection.Assembly]::LoadFrom($env:WTTSTDIO + "Microsoft.Windows.Kits.Hardware.objectmodel.submission.dll")

$connectFileName = $env:WTTSTDIO + "connect.xml"
Write-Host Opening connection file $connectFileName
$connectFile = [xml](Get-Content $connectFileName)

$ControllerName = $connectFile.Connection.GetAttribute("Server")
$DatabaseName = $connectFile.Connection.GetAttribute("Source")

$Manager = new-object -typename Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager -Args $ControllerName, $DatabaseName

#Load Project
$Project = $Manager.GetProject("TestProject")

#let's define enumerations for all development phases
$TuningAndValidation = [Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]::TuningAndValidation
$BringUp = [Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]::BringUp
$DevelopmentAndIntegration = [Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]::DevelopmentAndIntegration
$Reliability = [Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]::Reliability
$Manufacturing = [Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]::Manufacturing
$Support = [Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]::Support

#Project test summary for each development phasent))

$Tests = $Project.GetTests()

Write-Host ("Test summary for project {0}" -f $Project.Name)
Write-Host ("   TuningAndValidation tests: {0}" -f ($Tests | where { $_.DevelopmentPhases.Contains($TuningAndValidation)}).Length)
Write-Host ("   BringUp tests: {0}" -f ($Tests | where { $_.DevelopmentPhases.Contains($BringUp)}).Length)
Write-Host ("   DevelopmentAndIntegration tests: {0}" -f ($Tests | where { $_.DevelopmentPhases.Contains($DevelopmentAndIntegration)}).Length)
Write-Host ("   Reliability tests: {0}" -f ($Tests | where { $_.DevelopmentPhases.Contains($Reliability)}).Length)
Write-Host ("   Manufacturing tests: {0}" -f ($Tests | where { $_.DevelopmentPhases.Contains($Manufacturing)}).Length)
Write-Host ("   Support tests: {0}" -f ($Tests | where { $_.DevelopmentPhases.Contains($Support)}).Length)
Write-Host ("   Total tests: {0}" -f ($Tests.Count))

#schedule all Reliability tests in the project
$DevelopmentPhases = New-Object "System.Collections.Generic.List[Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]"
$DevelopmentPhases.Add($Reliability)
foreach($Test in $Project.GetTests() | where { $_.DevelopmentPhases.Contains($Reliability)})
{
    Write-Host ("Scheduling 'Reliability' test: {0}" -f $Test.Name)

    $Test.QueueTest()
}

#schedule all BringUp tests in the project
$DevelopmentPhases = New-Object "System.Collections.Generic.List[Microsoft.Windows.Kits.Hardware.ObjectModel.DevelopmentPhase]"
$DevelopmentPhases.Add($BringUp)
foreach($Test in $Project.GetTests() | where { $_.DevelopmentPhases.Contains($BringUp)})
{
    Write-Host ("Scheduling 'BringUp' test: {0}" -f $Test.Name)
    $Test.QueueTest()
}

# Sample code for creating a new project and scheduling BringUp tests
# create the project name
$now = [System.DateTime]::Now
$ProjectName = "SampleDevelopmentPhasesTestProject $now"

$RootPool = $Manager.GetRootMachinePool()
$DefaultPool = $RootPool.DefaultPool

# create the pool
$TestPool = $RootPool.GetChildPools() | Where {$_.Name -eq "TestPool" }[0]
if ($TestPool -eq $null)
{
    $TestPool = $RootPool.CreateChildPool("TestPool")
}

# move all machines in the default pool
$DefaultPool.GetMachines() | foreach {
    write-host $_.Name
    $DefaultPool.MoveMachineTo($_, $TestPool)
    }

#reset all machines
$TestPool.GetMachines() | foreach { $_.SetMachineStatus([Microsoft.Windows.Kits.Hardware.ObjectModel.MachineStatus]::Ready, 1) }

#-----------
# Creating a project
#-----------
$Project = $manager.CreateProject($ProjectName)
Write-Host "created a project named : "$Project.Name

$OSPlatform = $TestPool.GetMachines()[0].OSPlatform
$ProductInstance = $Project.CreateProductInstance("My Product Instance",
                                                 $TestPool,
                                                 $OSPlatform)

# this will find all systems in the test pool, and return those as a list of system test targets
$data = $ProductInstance.FindTargetFromSystem()

# for now, just use the first one found
Write-Host "Creating a target for " $data[0].Name
$Target = $ProductInstance.CreateTarget($data[0])
write-Host Successfully created a Target for $Target.Name that has $Target.GetTests().Count tests

# Schedule "BringUp" test - i.e., tests that is marked as "BringUp" for Development Phases
# Get the first "BringUp" test and schedule it
$Test = $Target.GetTests() | where { $_.DevelopmentPhases.Contains($BringUp)}[0]
$Test.QueueTest()


Test Collection File schema

The Test Collection File schema is described below.

Test Collection File definition

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<xsd:attribute name="Guid" type="xsd:string"/>
<xsd:attribute name="Name" type="xsd:string"/>
<xsd:attribute name="TargetType">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:enumeration value="System"/>
<xsd:enumeration value="Device"/>
<xsd:enumeration value="Filter"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:attribute>
<xsd:attribute name="TargetName" type="xsd:string"/>
<xsd:attribute name="TestPassIdentifier" type="xsd:string"/>
<xsd:attribute name="TargetId" type="xsd:string"/>
<xsd:attribute name="HlkBuildVersion" type="xsd:string"/>
<xsd:attribute name="OsPlatform" type="xsd:string"/>
<xsd:attribute name="FeatureDetected" type="xsd:string"/>
<xsd:attribute name="StartTime" type="xsd:dateTime"/>
<xsd:attribute name="SourcePath" type="xsd:string"/>
<xsd:attribute name="Status">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:enumeration value="Pass"/>
<xsd:enumeration value="Fail"/>
<xsd:enumeration value="Nodata"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:attribute>
<xsd:attribute name="FiltersAppliedCount" type="xsd:nonNegativeInteger"/>
<xsd:attribute name="InstanceId" type="xsd:string"/>
<xsd:element name="ArrayOfTestCollectionRecord">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="TestCollectionRecord" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
</xsd:complexType>
</xsd:element>
<xsd:element name="TestCollectionRecord">
<xsd:complexType>
<xsd:sequence>
<xsd:element ref="ContentLevelSet" minOccurs="0" maxOccurs="unbounded"/>
<xsd:element ref="ScheduleOptionSet" minOccurs="0" maxOccurs="unbounded"/>
<xsd:element ref="FeatureMapped" minOccurs="0"/>
<xsd:element ref="Result" minOccurs="0" maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute ref="Guid"/>
<xsd:attribute ref="Name"/>
<xsd:attribute ref="TargetType"/>
<xsd:attribute ref="TargetName"/>
<xsd:attribute ref="TestPassIdentifier"/>
<xsd:attribute ref="TargetId"/>
<xsd:attribute ref="HlkBuildVersion"/>
<xsd:attribute ref="OsPlatform"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="ContentLevelSet">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:enumeration value="Basic"/>
<xsd:enumeration value="Functional"/>
<xsd:enumeration value="Reliability"/>
<xsd:enumeration value="Certification"/>
<xsd:enumeration value="Experiences"/>
<xsd:enumeration value="Optional"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:element>
<xsd:element name="ScheduleOptionSet">
<xsd:simpleType>
<xsd:restriction base="xsd:NMTOKEN">
<xsd:enumeration value="Manual"/>
<xsd:enumeration value="Distributable"/>
<xsd:enumeration value="MultipleDevices"/>
<xsd:enumeration value="MultipleMachines"/>
<xsd:enumeration value="SpecialConfiguration"/>
</xsd:restriction>
</xsd:simpleType>
</xsd:element>
<xsd:element name="FeatureMapped" type="xsd:string"/>
<xsd:element name="Result">
<xsd:complexType>
<xsd:simpleContent>
<xsd:extension base="xsd:string">
<xsd:attribute ref="FeatureDetected"/>
<xsd:attribute ref="StartTime"/>
<xsd:attribute ref="SourcePath"/>
<xsd:attribute ref="Status"/>
<xsd:attribute ref="FiltersAppliedCount"/>
<xsd:attribute ref="InstanceId"/>
</xsd:extension>
</xsd:simpleContent>
</xsd:complexType>
</xsd:element>
</xsd:schema>


HLK API Reference

In this section

  • Microsoft.Windows.Kits.Hardware.DiagnosticSummary
  • Microsoft.Windows.Kits.Hardware.ObjectModel
  • Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection Namespace
  • Microsoft.Windows.Kits.Hardware.ObjectModel.Submission Namespace
  • Microsoft.Windows.Kits.Hardware.UI.Views Namespace


Microsoft.Windows.Kits.Hardware.DiagnosticSummary

  • BugcheckSummary Class

  • DiagnosticSummaryLog Class


BugcheckSummary Class

This class represents a bugcheck summary event that occurred during a test run.

Namespace: Microsoft.Windows.Kits.Hardware.DiagnosticSummary

Assembly: Microsoft.Windows.Kits.Hardware.DiagnosticSummary

Syntax

C#

public class BugcheckSummary

Inheritance Hierarchy

System.Object

      **Microsoft.Windows.Kits.Hardware.DiagnosticSummary.BugcheckSummary**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

BugcheckSummary Members

BugcheckSummary Methods


BugcheckSummary Members

Public Properties

Name | Type | Description
Code | string | The code for the bugcheck summary event.
Description | string | The description for the bugcheck summary event.
DumpFilePath | string | The crash dump file path on the client machine.
EventLogDescription | string | The description for the bugcheck summary event.
FormattedCodeAndParameters | string | A formatted string containing the bugcheck code and parameters for the bugcheck summary event.
Name | string | The name of the bugcheck summary event.
ParameterDescription | string | Parameter description for the bugcheck summary event.
Parameters | List<string> | A list of parameter values for the bugcheck summary event. Typically, there are four parameters.
ReportId | string | The ReportId for the bugcheck summary event.
TimeCreated | DateTime | The timestamp at which the bugcheck summary event was created.

Related topics

BugcheckSummary Class

BugcheckSummary Methods


BugcheckSummary Methods

Public Methods

Name | Description
ToString | Returns a string representation of the bugcheck summary event.

Related topics

BugcheckSummary Class

BugcheckSummary Members


ToString Method

This method returns a string representation of the bugcheck summary event.

Namespace: Microsoft.Windows.Kits.Hardware.DiagnosticSummary

Assembly: Microsoft.Windows.Kits.Hardware.DiagnosticSummary

Usage

C#

BugcheckSummary bugcheckSummary;

string strBugcheckSummary = bugcheckSummary.ToString();

Syntax

C#

public override string ToString()

Return Value

Returns string, a string representation of the bugcheck summary event.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DiagnosticSummaryLog Class

Represents a diagnostic or failure summary for a test result.

NOTE

Currently, the summary only contains information for kernel mode crashes.

Namespace: Microsoft.Windows.Kits.Hardware.DiagnosticSummary

Assembly: Microsoft.Windows.Kits.Hardware.DiagnosticSummary

Syntax

C#

public class DiagnosticSummaryLog

Inheritance Hierarchy

System.Object

      **Microsoft.Windows.Kits.Hardware.DiagnosticSummary.DiagnosticSummaryLog**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

DiagnosticSummaryLog Members


DiagnosticSummaryLog Members

Public Properties

Name | Type | Description
BugcheckSummary | BugcheckSummary | The summary for a kernel mode bugcheck event during a test run.
ClientMachineName | string | The client machine name where the test ran.

Related topics

DiagnosticSummaryLog Class


Microsoft.Windows.Kits.Hardware.ObjectModel

In this section

  • AssessmentData Class
  • ConnectionType Enumeration
  • CpuArchitecture Enumeration
  • DataIntegrityException Class
  • DevelopmentPhase Enumeration
  • DeviceFamily Class
  • DistributionOption Enumeration
  • Driver Class
  • ExecutionState Enumeration
  • Feature Class
  • FilterConstraintMatchType Enumeration
  • FilterConstraintType Enumeration
  • FilterStatus Enumeration
  • FilterType Enumeration
  • HardwareIdException Class
  • IConsolidateRunTests Interface
  • IDeviceCollectionTargetData Interface
  • IDeviceTargetData Interface
  • IFilter Interface
  • IFilterConstraint Interface
  • IFilterConstraintEvaluator Interface
  • IFilterLogNode Interface
  • IFilterResult Interface
  • IFilterTargetData Interface
  • INotifyProjectChanged Interface
  • InUseTargetData Struct
  • IParameterResolver Interface
  • IParameterResolverManager Interface
  • IProxyRunTests Interface
  • IRunExport Interface
  • IRunTests Interface
  • ISystemTargetData Interface
  • ITargetInformation Interface
  • LogType Enumeration
  • Machine Class
  • MachineException Class
  • MachinePool Class
  • MachinePoolCrashDumpCopyBackSetting Enumeration
  • MachineProperty Class
  • MachinePropertyType Enumeration
  • MachineRole Class
  • MachineSet Class
  • MachineStatus Enumeration
  • NotificationBase Class
  • OSPlatform Class
  • ParameterSetAsDefault Enumeration
  • Playlist Class
  • PlaylistException Class
  • PlaylistFeature Class
  • PlaylistInfo Class
  • PlaylistManager Class
  • PlaylistOSPlatform Class
  • PlaylistTest Class
  • ProductInstance Class
  • ProductInstanceException Class
  • ProductType Class
  • Project Class
  • ProjectException Class
  • ProjectFilterResultsDictionary Class
  • ProjectInfo Class
  • ProjectManager Class
  • ProjectManagerException Class
  • ProjectStatus Enumeration
  • ProjectSummary Class
  • Requirement Class
  • RequirementDescriptionData Class
  • RequirementException Class
  • RoleConstraint Structure
  • ScheduleException Class
  • Target Class
  • TargetData Class
  • TargetDriversType Enumeration
  • TargetException Class
  • TargetFamily Class
  • TargetType Enumeration
  • Task Class
  • TemplateParameter Enumeration
  • TemplateParameters Class
  • Test Class
  • TestClassification Enumeration
  • TestDefinition Class
  • TestException Class
  • TestLog Class
  • TestParameter Class
  • TestResult Class
  • TestResultStatus Enumeration
  • TestType Enumeration
  • UpdateType Enumeration


AssessmentData Class

This class represents the assessment data.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As AssessmentData

Syntax

Visual Basic

<DataContractAttribute> _

Public Class AssessmentData

C#

[DataContractAttribute]

public class AssessmentData

Inheritance Hierarchy

System.Object

Microsoft.Windows.Kits.Hardware.ObjectModel.AssessmentData

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


AssessmentData Members

The following tables list the members exposed by the AssessmentData Class.

Public Properties

Name | Description
AssessmentData.Name Property | This property represents the name of the assessment data.
AssessmentData.Unit Property | This property represents the unit that this data is measured in.
AssessmentData.Value Property | This property represents the value for the unit.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


AssessmentData Methods

The following tables describe the methods exposed by the AssessmentData Class:

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


AssessmentData Properties

The following table lists the properties exposed by the AssessmentData class.

Public Properties

Name | Description
AssessmentData.Name Property | This property represents the name of the assessment data.
AssessmentData.Unit Property | This property represents the unit that this data is measured in.
AssessmentData.Value Property | This property represents the value for the unit.


AssessmentData.Name Property

This property represents the name of the assessment data.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As AssessmentData

Dim value As String

Syntax

Visual Basic

Dim instance As AssessmentData

Dim value As String

C#

[DataContractAttribute]

public class AssessmentData

Inheritance Hierarchy

System.Object

** Microsoft.Windows.Kits.Hardware.ObjectModel.AssessmentData**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


AssessmentData.Unit Property

This property represents the unit that this data is measured in.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As AssessmentData

Dim value As String

value = instance.Unit

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public Overridable ReadOnly Property Unit As String

C#

[IgnoreDataMemberAttribute]

public virtual string Unit { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


AssessmentData.Value Property

This property represents the value for the unit.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As AssessmentData

Dim value As String

value = instance.Value

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public Overridable ReadOnly Property Value As String

C#

[IgnoreDataMemberAttribute]

public virtual string Value { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ConnectionType Enumeration

This class contains the enumeration values that describe the connection type or the Logo manager type.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ConnectionType

Syntax

Visual Basic

Public Enumeration ConnectionType

C#

public enum ConnectionType

Members

Member Name | Description
Database | This enum represents the connection type use to connect to the controller's database.
SubmissionPackage | This enum identifies the connection type as being use to connect to a new submission package.
UpdatePackage | This enum identifies the connection type as being used to update an existing package.
PartialPackage | This is a partial package. Once a package is marked as a partial package, it will always be a partial package; even if merged with a non-partial package. Such packages are not acceptable for submissions.


CpuArchitecture Enumeration

This class contains enumeration values that define the architecture that a test or submission package is applicable to.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As CpuArchitecture

Syntax

Visual Basic

Public Enumeration CpuArchitecture

C#

public enum CpuArchitecture

Members

Member Name | Description
Arm | This enum value identifies the architecture as ARM.
IA64 | This enum value identifies the architecture as Intel ia64 (Itanium 64-bit).
X64 | This enum value identifies the architecture as 64-bit.
X86 | This enum value identifies the architecture as 32-bit.
Arm64 | This enum value identifies the architecture as ARM64.

Remarks

See the Win32 documentation for SYSTEM_INFO.wProcessorArchitecture.


DataIntegrityException Class

This exception class is defined to represent exceptions related to DataIntegrity.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As DataIntegrityException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class DataIntegrityException

           `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public ref class DataIntegrityException : public ProjectManagerException

Inheritance Hierarchy

System.Object

System.Exception

** Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DataIntegrityException Members

This class is a base class for all logo manager exceptions.

The following tables list the members exposed by the DataIntegrityException type.

Public Constructors

Name | Description
DataIntegrityException | Overloaded. [This content is not available in this preliminary release.]

Protected Constructors

Name | Description
DataIntegrityException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException |
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


DataIntegrityException Constructor

Overload List

Name | Description
DataIntegrityException () | This constructor initializes a new instance of the DataIntegrityException class.
DataIntegrityException (String) | This constructor initializes a new instance of the DataIntegrityException class.
DataIntegrityException (String, Exception) | This constructor initializes a new instance of the DataIntegrityException class.


DataIntegrityException Constructor ()

This constructor initializes a new instance of the DataIntegrityException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New DataIntegrityException

Syntax

Visual Basic

Public Sub New

C#

public DataIntegrityException ()

Remarks

The default constructor initializes any fields to their default values.


DataIntegrityException Constructor (String)

This constructor initializes a new instance of the DataIntegrityException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New DataIntegrityException(message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public DataIntegrityException (

      `string message`

)


DataIntegrityException Constructor (String, Exception)

This constructor initializes a new instance of the DataIntegrityException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New DataIntegrityException(message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String, _`

      `except As Exception _`

)

C#

public DataIntegrityException (

      `string message,`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception

except

 An exception object.


DataIntegrityException Methods

This class is a base class for all logo manager exceptions.

The following table lists the methods exposed by the DataIntegrityException type.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException |
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


DataIntegrityException Properties

This class is a base class for all logo manager exceptions.

The following tables list the members exposed by the DataIntegrityException type.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


DataIntegrityException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


DevelopmentPhase Enumeration

This enumeration represents the development phase for the test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public enum DevelopmentPhase

Members

Member Name | Description
TuningAndValidation | Tuning and Validation test.
BringUp | Bring Up test.
DevelopmentAndIntegration | Bring Up test.
Reliability | Reliability test.
Manufacturing | Manufacturing test.
Support | Support test.


DeviceFamily Class

This class represents a group of Targets that correspond to WLP POLICY-0004.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As DeviceFamily

Syntax

Visual Basic

Public MustInherit Class DeviceFamily

C#

public abstract class DeviceFamily

Inheritance Hierarchy

System.Object

Microsoft.Windows.Kits.Hardware.ObjectModel.DeviceFamily

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceFamily Members

This class represents a group of Targets that correspond to WLP POLICY-0004.

The following tables list the members exposed by the DeviceFamily type.

Public Properties

Name | Description
DeviceFamily.HardwareIds Property | This property represents a collection of hardware IDs used to identify the test targets in this device family.
DeviceFamily.Name Property | This property represents the name of this DeviceFamily object.

Public Methods

Name | Description
DeviceFamily.AddHardwareId Method | This method adds a new hardware Id to this DeviceFamily object.
Equals | (Inherited from Object)
DeviceFamily.FindDeviceFamilyFromId Method | This method retrieves a device family for the given hardware Id.
DeviceFamily.GetDeviceFamilyFromId Method | This method retrieves a device family for the given hardware ID.
GetHashCode | (Inherited from Object)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


DeviceFamily Methods

DeviceFamily methods are described in the following tables.

Public Methods

Name | Description
DeviceFamily.AddHardwareId Method | This method adds a new hardware ID to this DeviceFamily object.
Equals | (Inherited from Object)
DeviceFamily.FindDeviceFamilyFromId Method | This method retrieves a device family for the given hardware ID.
DeviceFamily.GetDeviceFamilyFromId Method | This method retrieves a device family for the given hardware ID.
GetHashCode | Overridden.
GetType | (Inherited from Object)
ToString | (Inherited from Object)
DeviceFamily.RenameHardwareId Method | This method renames an existing hardware ID in the device family.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


DeviceFamily.AddHardwareId Method

This method adds a new hardware ID to this DeviceFamily object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As DeviceFamily

Dim hardwareIdToAdd As String

instance.AddHardwareId(hardwareIdToAdd)

Syntax

Visual Basic

Public MustOverride Sub AddHardwareId ( _

      `hardwareIdToAdd As String _`

)

C#

public abstract void AddHardwareId (

      `string hardwareIdToAdd`

)

Parameters

hardwareIdToAdd

 The hardware ID to add to the device family hardware ID list.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceFamily.FindDeviceFamilyFromId Method

This method retrieves a device family for the given hardware ID.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim idToFind As String

Dim manager As ProjectManager

Dim returnValue As DeviceFamily

returnValue = DeviceFamily.FindDeviceFamilyFromId(idToFind, manager)

Syntax

Visual Basic

Public Shared Function FindDeviceFamilyFromId ( _

      `idToFind As String, _`

      `manager As ProjectManager _`

) As DeviceFamily

C#

public static DeviceFamily FindDeviceFamilyFromId (

      `string idToFind,`

      `ProjectManager manager`

)

Parameters

idToFind

 The hardware ID to use to compare against.

manager

 The logoManager object against which to perform the search.

Return Value

Returns DeviceFamily.

Remarks

An exception occurs when the idToFind parameter or the manager parameter is null or the idToFind parameter is blank.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceFamily.GetDeviceFamilyFromId Method

This method gets a device family for the given hardware ID.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim idToFind As String

Dim manager As ProjectManager

Dim returnValue As DeviceFamily

returnValue = DeviceFamily.GetDeviceFamilyFromId(idToFind, manager)

Syntax

Visual Basic

Public Shared Function FindDeviceFamilyFromId ( _

      `idToFind As String, _`

      `manager As ProjectManager _`

) As DeviceFamily

C#

public static DeviceFamily FindDeviceFamilyFromId (

      `string idToFind,`

      `ProjectManager manager`

)

Parameters

idToFind

 The hardware ID to use to compare against.

manager

 The logoManager object against which to perform the search.

Return Value

Returns DeviceFamily, which is the DeviceFamily object, or null if no DeviceFamily object is associated with the idToFind parameter.

Remarks

This function throws an exception if the correct device family could not be found. This can occur under the following conditions:

  • The idToFind parameter or the manager parameter is null

  • The idToFind parameter is blank.

  • The idToFind parameter is not associated with a DeviceFamily object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceFamily.GetHashCode Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As DeviceFamily

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number representing the DeviceFamily hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RenameHardwareId Method

This method renames an existing hardware ID in this DeviceFamily object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract void RenameHardwareId(string hardwareIdToRename, string newName)

Parameters

hardwareIdToRename

The existing hardware ID to rename.

newName

The new name for the existing hardware ID.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceFamily Properties

This class is a base class for all logo manager exceptions.

The following tables list the members exposed by the DataIntegrityException type.

Public Properties

Name | Description
DeviceFamily.HardwareIds Property | This property represents a collection of hardware IDs used to identify the test targets in this device family.
DeviceFamily.Name Property | This property represents the name of this DeviceFamily object.


DeviceFamily.HardwareIds Property

This property represents a collection of hardware IDs used to identify the test targets in this device family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As DeviceFamily

Dim value As ReadOnlyCollection(Of String)

value = instance.HardwareIds

Syntax

Visual Basic

Public MustOverride ReadOnly Property HardwareIds As ReadOnlyCollection(Of String)

C#

public abstract ReadOnlyCollection<string> HardwareIds { get; }

Property Value

Returns Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceFamily.Name Property

This property represents the name of this DeviceFamily object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As DeviceFamily

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public MustOverride ReadOnly Property Name As String

C#

public abstract string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DistributionOption Enumeration

This class contains an enumeration that defines the options available for scheduling a test job.

NOTE

These enumeration values are now used as flags that can be combined and retrieved by using bitwise operations.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Enumeration DistributionOption

C#

public enum DistributionOption

Members

Member Name | Description
RequiresMultipleMachines | This value defines a test job as being required to run on multiple machines (test computers)
ScheduleOnAllTargets | This value defines a test job as being required to be run against each and every target in a device family.
ScheduleOnAnyTarget | This value defines a test job as being able to be run on any target in the device family.
ConsolidateScheduleAcrossTargets | This value defines a test job that can consolidate parameters across multiple targets across compatible tests.


Driver Class

This class represents a driver package for certification submission with a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Driver

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class Driver

C#

[DataContractAttribute]

public abstract class Driver

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Driver**

    **Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageDriver**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Driver Members

The following tables list the members exposed by the Driver type.

Public Properties

Name | Description
Id | Retrieves the driver identifier.
Locales | This property the locales that this driver package supports.
OriginalDriverPath | Represents or sets the original driver path.
ReplacesDriverId | Retrieves the unique identifier that this driver replaces.
SignabilityResults | Retrieves a collection of Signability results.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetTargets | Retrieves the targets that are associated with this driver.
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Driver Methods

The following table lists the methods exposed by the Driver type.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetTargets | Retrieves the targets that are associated with this driver.
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Driver.GetTargets Method

Retrieves the targets that are associated with this driver.

Syntax

Visual Basic

Public Overridable Function GetTargets() As IEnumerable(Of Target)

C#

public virtual IEnumerable<Target> GetTargets()

Return Value

The targets that are associated with the driver.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Driver Properties

The following table lists the properties exposed by the Driver class.

Public Properties

Name | Description
Id | Retrieves the driver identifier.
Locales | This property the locales that this driver package supports.
OriginalDriverPath | Represents or sets the original driver path.
ReplacesDriverId | Retrieves the unique identifier that this driver replaces.
SignabilityResults | Retrieves a collection of Signability results.


Driver.Id Property

Retrieves the driver identifier.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

<IgnoreDataMember> _

Property Id As String

C#

[IgnoreDataMember]

public string Id { get; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Driver.Locales Property

This property represents the locales that this driver package supports.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Driver

Dim value As ReadOnlyCollection(Of String)

value = instance.Locales

Syntax

Visual Basic

Public Overridable Property Locales As ReadOnlyCollection(Of String)

C#

public virtual ReadOnlyCollection<string> Locales { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Driver.OriginalDriverPath Property

Represents the original driver path.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

<IgnoreDataMember> _

Property OriginalDriverPath As String

C#

[IgnoreDataMember]

public string OriginalDriverPath { get; set; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Driver.ReplacesDriverId Property

Represents the unique identifier that this driver replaces.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Driver

Dim value As String

value = instance.ReplacesDriverId

Syntax

Visual Basic

<IgnoreDataMember> _

Property ReplacesDriverId As String

C#

[IgnoreDataMember]

public string ReplacesDriverId { get; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Driver.SignabilityResults Property

Represents a collection of Signability results.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

<IgnoreDataMember> _

Public ReadOnly Property SignabilityResults As ReadOnlyCollection(Of String)

C#

[IgnoreDataMember]

public ReadOnlyCollection<string> SignabilityResults { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ExecutionState Enumeration

The state of a test.

Members

Name | Description
InQueue | This is waiting to be run.
NotRunning | This is not running.
Running | This is running on a client machine.


Feature Class

This class represents a feature that a device supports. For example, USB support is an example of a feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Syntax

Visual Basic

<SerializableAttribute> _

Public MustInherit Class Feature

C#

[SerializableAttribute]

public abstract class Feature

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Feature**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

Features are related to Product Types and Requirements. Features can be mapped to different Product Types. Requirements can be mapped to only one Feature.


Feature Members

The following tables list the members exposed by the Feature type.

Public Properties

Name | Description
GetRequirements | Gets a collection of requirements associated with this feature.
Feature.Description Property | This property represents the description of this feature.
Feature.FullName Property | This property represents the full name and path of this feature.
Feature.ManuallyAdded Property | This property represents a value indicating whether this feature was manually added.
Feature.Name Property | This property represents the feature name.
Feature.Query Property | This property represents the query used to determine the contents of this feature.
Feature.TargetType Property | This property represents the root type of the Feature object.

Public Methods

Name | Description
Equals | Overrides the Equals function to provide value equality functionality for this object.
GetHashCode | Serves as a hash function for this feature.
GetRequirements | This method retrieves the requirements associated with this feature.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Feature Methods

Public Methods

Name | Description
Equals | Overrides the Equals function to provide value equality functionality for this object.
GetHashCode | Serves as a hash function for this feature.
GetRequirements | This method retrieves the requirements associated with this feature.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Feature.Equals Method

Overload List

Name | Description
Equals Method (Feature) | Overloads the Equals function to provide value equality functionality for this object.
Equals Method (object) | Overrides the Equals function to provide value equality functionality for this object.


Feature.Equals Method (Feature)

This function overloads the Equals function to provide value equality functionality for this object.

Syntax

C#

public bool Equals (

      `Feature other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature.Equals Method (object)

This function overrides the Equals function to provide value equality functionality for this object.

Syntax

C#

public override bool Equals (

      `object other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature.GetHashCode Method

Serves as a hash function for this feature.

Syntax

C#

public override int GetHashCode ()

Return Value

Returns the hash code for the feature.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature.GetRequirements Method

This method retrieves the requirements associated with this Feature.

Usage

Visual Basic

Dim instance As Feature

Dim returnValue As ReadOnlyCollection(Of Requirement)

returnValue = instance.GetRequirements

Syntax

Visual Basic

Public MustOverride Function GetRequirements As ReadOnlyCollection(Of Requirement)

C#

public abstract ReadOnlyCollection<Requirement> GetRequirements ()

Return Value

Returns ReadOnlyCollection, which is a read-only collection of requirements.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature Properties

Public Properties

Name | Description
GetRequirements | Gets a collection of requirements associated with this feature.
Feature.Description Property | This property represents the description of this feature.
Feature.FullName Property | This property represents the full name and path of this feature.
Feature.ManuallyAdded Property | This property represents a value indicating whether this feature was manually added.
Feature.Name Property | This property represents the feature name.
Feature.Query Property | This property represents the query used to determine the contents of this feature.
Feature.TargetType Property | This property represents the root type of the Feature object.


Feature.Description Property

This property represents the description of a Feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Dim value As String

value = instance.Description

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Description As String

C#

[DataMemberAttribute]

public string Description { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

The data can be in HTML format.


Feature.FullName Property

This property represents the full name and path of this feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Dim value As String

value = instance.FullName

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property FullName As String

C#

[DataMemberAttribute]

public string FullName { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature.ManuallyAdded Property

This property represents a value indicating whether a Feature was manually added.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Dim value As Boolean

value = instance.ManuallyAdded

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ManuallyAdded As Boolean

C#

[DataMemberAttribute]

public string ManuallyAdded { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature.Name Property

This property represents the name of a Feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Dim value As String

value = instance.Name

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Name As String

C#

[DataMemberAttribute]

public string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Feature.Query Property

Represents the query used to determine the contents of a Feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Dim value As String

value = instance.Query

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Query As String

C#

[DataMemberAttribute]

public string Query { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

The query is used for automatic detection of Features and Requirements. This query is run against all the target data for a particular machine. If there are any results, the Feature is present on the Machine.


Feature.TargetType Property

Represents the root type of a Feature object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Feature

Dim value As TargetType

value = instance. TargetType

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property TargetType As TargetType

C#

[DataMemberAttribute]

public TargetType TargetType { get; }

Property Value

Returns a TargetType enum.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


FilterConstraintMatchType Enumeration

Filter constraint match type.

Members

Member name | Description
Contains | Matches if the constraint value contains the match value.
Equals | Matches the entire constraint value.
StartsWith | Matches if the constraint value starts with the match value.


FilterConstraintType Enumeration

This class contains an enumeration that denotes the type of a HCK filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As FilterConstraintType

Syntax

Visual Basic

Public Enumeration FilterConstraintType

C#

public enum FilterConstraintType

Members

Member Name | Description
Gatherer | This enum value indicates that a filter acts as an advanced constraint to filter against gatherer data.
Submission | This enum value indicates that a filter constraint acts as a submission constraint.
Target | This enum value indicates that a filter constraint acts as an advanced constraint to filter against target under test (XmlData).


FilterStatus Enumeration

This class contains enumeration value that denotes the status of a HCK filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As FilterStatus

Syntax

Visual Basic

Public Enumeration FilterStatus

C#

public enum FilterStatus

Members

Member Name | Description
Active | This enum identifies a filter as being active. When in the active state, a filter will be applied during filter processing against matching test results.
Inactive | This enum identifies a filter as being active. When a filter is inactive the filter will not be applied during filter processing for matching test results.
Test | This enum identifies a filter as a test filter.


FilterType Enumeration

This class contains an enumeration that defines the HCK filter type.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As FilterType

Syntax

Visual Basic

Public Enumeration FilterType

C#

public enum FilterType

Members

Member Name | Description
AutoTriage | This enum identifies a filer as being of type Auto Triage. In this case, the filter provides additional troubleshooting information that can be viewed by the tester. This type of filer does not change the status of the test result. For a failed test result, the test must be rerun until it returns a pass.
Contingency | This enum identifies a filer as being of type Contingency. A contingency is granted to Microsoft partners due to partial hardware or driver implementation issues and once applied it enables failed results to be submitted as if the tests passed.
Errata | This enum identifies a filer as being of type Errata. This type of filter is applied to tests that fail due to known test issues, and enables failed results to be submitted as if the tests passed.


HardwareIdException Class

This exception class is defined to handle target-specific errors.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[SerializableAttribute]

public class HardwareIdException : ProjectManagerException

Inheritance Hierarchy

System.Object

 **System.Exception**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

                  **Microsoft.Windows.Kits.Hardware.ObjectModel.HardwareIdException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

HardwareIdException Members


HardwareIdException Members

The following table lists the members exposed by the HardwareIdException type.

Public Constructors

Name | Description
HardwareIdException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from ProjectManagerException)
HelpLink | (Inherited from ProjectManagerException)
InnerException | (Inherited from ProjectManagerException)
Message | (Inherited from ProjectManagerException)
Source | (Inherited from ProjectManagerException)
StackTrace | (Inherited from ProjectManagerException)
TargetSite | (Inherited from ProjectManagerException)

Protected Properties

Name | Description
HResult | (Inherited from ProjectManagerException)

Public Methods

Name | Description
Equals | (Inherited from ProjectManagerException)
GetBaseException | (Inherited from ProjectManagerException)
GetHashCode | (Inherited from ProjectManagerException)
GetObjectData | (Inherited from ProjectManagerException)
GetType | (Inherited from ProjectManagerException)
ToString | (Inherited from ProjectManagerException)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from ProjectManagerException)

Protected Events

Name | Description
SerializeObjectState | (Inherited from ProjectManagerException)


IConsolidateRunTests Interface

This interface represents functionality that an object that can be run as a consolidated unit needs to implement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Interface IConsolidateRunTests

C#

public interface IConsolidateRunTests


IConsolidateRunTests Methods

Overload List

Name | Description
IConsolidateRunTests.QueueTest (IList) | This method schedules all the tests for execution.
IConsolidateRunTests.QueueTest (IEnumerable<Machine>) | This method schedules the test for execution on a specific subset of machines.


IConsolidateRunTests.QueueTest (IList) Method

This method schedules all the tests for execution.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Function QueueTest(ByVal testList As IEnumerable(Of Test)) As IList(Of TestResult)

C#

      `IList<TestResult> QueueTest(IEnumerable<Test> testList);`

)

Parameters

testList

A list of tests to consolidate with the current test.

Return Value

A list of results for the tests that were scheduled.

Remarks

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately and the method returns. The function will leave some tests scheduled, and some that are incomplete. The list returned identifies the tests that were scheduled.

This is not supported when the project is connected to a package.

Exception

System.NotSupportedException thrown when attempting to schedule tests when the data source connection is Submission or Update package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IConsolidateRunTests.QueueTest (IEnumerable Machine ) Method

This method schedules the test for execution on a specific subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Function QueueTest(ByVal testList As IEnumerable(Of Test), ByVal machineList As IEnumerable(Of Machine)) As IList(Of TestResult)

C#

      `IList<TestResult> QueueTest(IEnumerable<Test> testList, IEnumerable<Machine> machineList);`

)

Parameters

testList

A list of tests to consolidate with the current test.

machinelist

List of machines that can run the test.

Return Value

A list of results for the tests that were scheduled.

Remarks

This is useful to specify a subset of possible machines. For example in the case where manual tests would prefer to run on specific machines

This is not supported when the project is connected to a package.

Exception

ScheduleException thrown when there is a failure submitting a test to the scheduler.

NotSupportedException thrown when attempting to queue tests when the data source connection is Submission or Update package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceCollectionTargetData Interface

This class provides an interface that can return DeviceCollection object information (basically the same information as displayed from the Devices and Printers page).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Syntax

Visual Basic

Public Interface IDeviceCollectionTargetData

C#

public interface IDeviceCollectionTargetData

Remarks

Device Collections are logical containers for hardware devices (multifunction printers are an example).


IDeviceCollectionTargetData Members

The following tables list the members exposed by the IDeviceCollectionTargetData type.

Public Properties

Name | Description
IDeviceCollectionTargetData.Category Property | This property represents the Category value of the DeviceCollection object.
IDeviceCollectionTargetData.ContainerId Property | This property represents the container ID value of the DeviceCollection object.
IDeviceCollectionTargetData.FriendlyName Property | This property represents the friendly name of the DeviceCollection object.
IDeviceCollectionTargetData.Manufacturer Property | This property represents the manufacturer name of the DeviceCollection object.
IDeviceCollectionTargetData.Model Property | This property represents the model name of the DeviceCollection object.
IDeviceCollectionTargetData.ModelId Property | This property represents the model ID value of the DeviceCollection object. The modelID value uniquely identifies a test target.
IDeviceCollectionTargetData.Name Property | This property represents the name of the DeviceCollection object.


IDeviceCollectionTargetData Properties

Public Properties

Name | Description
IDeviceCollectionTargetData.Category Property | This property represents the Category value of the DeviceCollection object.
IDeviceCollectionTargetData.ContainerId Property | This property represents the container ID value of the DeviceCollection object.
IDeviceCollectionTargetData.FriendlyName Property | This property represents the friendly name of the DeviceCollection object.
IDeviceCollectionTargetData.Manufacturer Property | This property represents the manufacturer name of the DeviceCollection object.
IDeviceCollectionTargetData.Model Property | This property represents the model name of the DeviceCollection object.
IDeviceCollectionTargetData.ModelId Property | This property represents the model ID value of the DeviceCollection object. The modelID value uniquely identifies a test target.
IDeviceCollectionTargetData.Name Property | This property represents the name of the DeviceCollection object.


IDeviceCollectionTargetData.Category Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.Category

Syntax

Visual Basic

ReadOnly Property Category As String

C#

string Category { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceCollectionTargetData.ContainerId Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.ContainerId

Syntax

Visual Basic

ReadOnly Property ContainerId As String

C#

string ContainerId { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceCollectionTargetData.FriendlyName Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.FriendlyName

Syntax

Visual Basic

ReadOnly Property FriendlyName As String

C#

string FriendlyName { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceCollectionTargetData.Manufacturer Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.Manufacturer

Syntax

Visual Basic

ReadOnly Property Manufacturer As String

C#

string Manufacturer { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

Returns null if a manufacturer cannot be found.


IDeviceCollectionTargetData.Model Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.Model

Syntax

Visual Basic

ReadOnly Property Category As String

C#

string Model { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceCollectionTargetData.ModelId Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.ModelId

Syntax

Visual Basic

ReadOnly Property ModelId As String

C#

string ModelId { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceCollectionTargetData.Name Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceCollectionTargetData

Dim value As String

value = instance.Name

Syntax

Visual Basic

ReadOnly Property Name As String

C#

string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData Interface

This class extracts information from a test target or a TargetData object for a device.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Syntax

Visual Basic

Public Interface IDeviceTargetData

C#

public interface IDeviceTargetData


IDeviceTargetData Members

The following tables list the members exposed by the IDeviceCollectionTargetData type.

Public Properties

Name | Description
IDeviceTargetData.AllInboxDrivers Property | This property represents a value indicating whether all of the drivers associated with this deviceTarget object are signed.
IDeviceTargetData.ContainerId Property | This property represents the container ID value for a deviceTarget object.
IDeviceTargetData.DeviceClass Property | This property represents the device class for a deviceTarget object.
IDeviceTargetData.DriverHash Property | This property represents all of the driver's hash values for a deviceTarget object.
IDeviceTargetData.Drivers Property | This property represents all of the drivers for this device that can be identified for this deviceTarget object.
IDeviceTargetData.HardwareId Property | This property represents the hardware IDs for a deviceTarget object.
IDeviceTargetData.InstanceId Property | This property represents the Instance ID value of a deviceTarget object.
IDeviceTargetData.IsHiddenDevice Property | This property represents a value indicating whether this should be hidden from the user by default for a deviceTarget object.
IDeviceTargetData.Manufacturer Property | This property represents the name of the manufacturer of a deviceTarget object.
IDeviceTargetData.Name Property | This property represents the device name for a deviceTarget object.
IDeviceTargetData.VendorId Property | This property represents the vendor ID value for a deviceTarget object. The vendor ID value is unique for each vendor.


IDeviceTargetData Properties

Public Properties

Name | Description
IDeviceTargetData.AllInboxDrivers Property | This property represents a value indicating whether all of the drivers associated with this deviceTarget object are signed.
IDeviceTargetData.ContainerId Property | This property represents the container ID value for a deviceTarget object.
IDeviceTargetData.DeviceClass Property | This property represents the device class for a deviceTarget object.
IDeviceTargetData.DriverHash Property | This property represents all of the driver's hash values for a deviceTarget object.
IDeviceTargetData.Drivers Property | This property represents all of the drivers for this device that can be identified for this deviceTarget object.
IDeviceTargetData.HardwareId Property | This property represents the hardware IDs for a deviceTarget object.
IDeviceTargetData.InstanceId Property | This property represents the Instance ID value of a deviceTarget object.
IDeviceTargetData.IsHiddenDevice Property | This property represents a value indicating whether this should be hidden from the user by default for a deviceTarget object.
IDeviceTargetData.Manufacturer Property | This property represents the name of the manufacturer of a deviceTarget object.
IDeviceTargetData.Name Property | This property represents the device name for a deviceTarget object.
IDeviceTargetData.VendorId Property | This property represents the vendor ID value for a deviceTarget object. The vendor ID value is unique for each vendor.


IDeviceTargetData.AllInboxDrivers Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As TargetDriversType

value = instance. AllInboxDrivers

Syntax

Visual Basic

ReadOnly Property AllInboxDrivers As TargetDriversType

C#

TargetDriversType AllInboxDrivers { get; }

Property Value

Returns TargetDriversType.

Remarks

Only if all drivers associated with the target are signed, the result is InboxDrivers.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.ContainerId Property

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As String

value = instance.ContainerId

Syntax

Visual Basic

ReadOnly Property ContainerId As String

C#

string ContainerId { get; }

Property Value

Returns String.

Remarks

Returns null if the device is not part of a container.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.DeviceClass Property

This property represents the device class for a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As String

value = instance.DeviceClass

Syntax

Visual Basic

ReadOnly Property DeviceClass As String

C#

string DeviceClass { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.DriverHash Property

This property represents all of the driver's hash values for a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As ReadOnlyCollection(Of String)

value = instance.DriverHash

Syntax

Visual Basic

ReadOnly Property DriverHash As ReadOnlyCollection(Of String)

C#

ReadOnlyCollection<string> DriverHash { get; }

Property Value

Returns ReadOnlyCollection.

Remarks

Upper and lower filter drivers may also be included.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.Drivers Property

This property represents all of the drivers for this device that can be identified for this deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As ReadOnlyCollection(Of String)

value = instance.Drivers

Syntax

Visual Basic

ReadOnly Property Drivers As ReadOnlyCollection(Of String)

C#

ReadOnlyCollection<string> Drivers { get; }

Property Value

Returns ReadOnlyCollection.

Remarks

Upper and lower filter drivers may also be included.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.HardwareId Property

This property represents the hardware IDs for a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As ReadOnlyCollection(Of String)

value = instance.HardwareId

Syntax

Visual Basic

ReadOnly Property HardwareId As ReadOnlyCollection(Of String)

C#

ReadOnlyCollection<string> HardwareId { get; }

Property Value

Returns ReadOnlyCollection.

Remarks

Hardware IDs are returned in a particular order. The order is determined by the OS on the machine where the target is found. The strong matched hardware ID is first in the collection and the last hardware ID is the weakest matching hardware ID.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.InstanceId Property

This property represents the Instance ID value of a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As String

value = instance.InstanceId

Syntax

Visual Basic

ReadOnly Property InstanceId As String

C#

string InstanceId { get; }

Property Value

Returns String.

Remarks

The instance ID is the device ID combined with any instance specific additional data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

The instance ID is comprised of a combination of device ID and any instance-specific additions.


IDeviceTargetData.IsHiddenDevice Property

This property represents a value indicating whether this should be hidden from the user by default for a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As Boolean

value = instance.IsHiddenDevice

Syntax

Visual Basic

ReadOnly Property IsHiddenDevice As Boolean

C#

bool IsHiddenDevice { get; }

Property Value

true if the test target should be hidden from testers; otherwise, false.

Remarks

The devices that are marked hidden are typically devices that are not commonly certified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.Manufacturer Property

This property represents the name of the manufacturer of a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As String

value = instance.Manufacturer

Syntax

Visual Basic

ReadOnly Property Manufacturer As String

C#

string Manufacturer { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

Returns null if a manufacturer cannot be found.


IDeviceTargetData.Name Property

This property represents the device name for a deviceTarget object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As String

value = instance.Name

Syntax

Visual Basic

ReadOnly Property Name As String

C#

string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IDeviceTargetData.VendorId Property

This property represents the vendor ID value for a deviceTarget object. The vendor ID value is unique for each vendor.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IDeviceTargetData

Dim value As String

value = instance.VendorId

Syntax

Visual Basic

ReadOnly Property VendorId As String

C#

string VendorId { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

Returns null if a Vendor ID cannot be found.


IFilter Interface

This class represents a filter that's applied against a test result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Syntax

Visual Basic

Public Interface IFilter

C#

public interface IFilter


IFilter Members

The following tables list the members exposed by the IFilter type.

Public Properties

Name | Description
IFilter.Constraints Property | This property represents the filter constraints for the filter.
IFilter.ExpirationDate Property | This property represents the expiration date for the filter.
IFilter.FilterNumber Property | This property represents the filter ID number. The Filter ID number uniquely identifies a filter within the HCK.
IFilter.FilterNumber Property | This property determines whether the logs are required for this filter to be applicable.
IFilter.IsResultRequired Property | This property represents determines whether the results are required for this filter to be applicable.
IssueDescription | This property represents the issue description for the filter.
IssueResolution | This property represents the issue resolution for the filter.
LastModifiedDate | This property represents the last modified date for the filter.
LogNodes | This property represents the filter log nodes for the filter.
ShouldFilterAllZeros | This property determines whether the filter should be applied if the pass and fail count are both zero.
ShouldFilterNotRuns | This property determines whether the filter should be applied for not run task results.
Status | This property represents the status for the filter.
TestCommandLine | This property represents the command line for the test being filtered.
Title | This property represents the filter title value (string).
Type | This property represents the filter type for the given filter.
Version | This property represents the version for the filter.

Public Methods

Name | Description
IFilter.IsApplicable Method | This method determines whether the filter is applicable for the given taskResult.


IFilter Methods

Public Methods

Name | Description
IFilter.IsApplicable Method | This method determines whether the filter is applicable for the given taskResult.


IFilter.IsApplicable Method

This method determines whether the filter is applicable for the given taskResult.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim constraintEvaluator As IFilterConstraintEvaluator

Dim returnValue As Boolean

returnValue = instance.IsApplicable(constraintEvaluator)

Syntax

Visual Basic

Function IsApplicable ( _

      `constraintEvaluator As IFilterConstraintEvaluator _`

) As Boolean

C#

bool IsApplicable (

      `IFilterConstraintEvaluator constraintEvaluator`

)

Parameters

constraintEvaluator

 The filter constraint evaluator.

Return Value

true if the filter is applicable; othwerwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter Properties

Public Properties

Name | Description
IFilter.Constraints Property | This property represents the filter constraints for the filter.
IFilter.ExpirationDate Property | This property represents the expiration date for the filter.
IFilter.FilterNumber Property | This property represents the filter ID number. The Filter ID number uniquely identifies a filter within the HCK.
IFilter.FilterNumber Property | This property determines whether the logs are required for this filter to be applicable.
IFilter.IsResultRequired Property | This property represents determines whether the results are required for this filter to be applicable.
IssueDescription | This property represents the issue description for the filter.
IssueResolution | This property represents the issue resolution for the filter.
LastModifiedDate | This property represents the last modified date for the filter.
LogNodes | This property represents the filter log nodes for the filter.
ShouldFilterAllZeros | This property determines whether the filter should be applied if the pass and fail count are both zero.
ShouldFilterNotRuns | This property determines whether the filter should be applied for not run task results.
Status | This property represents the status for the filter.
TestCommandLine | This property represents the command line for the test being filtered.
Title | This property represents the filter title value (string).
Type | This property represents the filter type for the given filter.
Version | This property represents the version for the filter.


IFilter.Constraints Property

This property represents the filter constraints for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As ReadOnlyCollection(Of IFilterConstraint)

value = instance.Constraints

Syntax

Visual Basic

ReadOnly Property Constraints As ReadOnlyCollection(Of IFilterConstraint)

C#

ReadOnlyCollection<IFilterConstraint> Constraints { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.ExpirationDate Property

This property represents the expiration date for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Nullable(Of DateTime)

value = instance. ExpirationDate

Syntax

Visual Basic

ReadOnly Property ExpirationDate As Nullable(Of DateTime)

C#

Nullable<DateTime> ExpirationDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.FilterNumber Property

This property represents the filter ID number. The Filter ID number uniquely identifies a filter within the HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Integer

value = instance.FilterNumber

Syntax

Visual Basic

ReadOnly Property FilterNumber As Integer

C#

int FilterNumber { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.IsLogRequired Property

This property determines whether the logs are required for this filter to be applicable.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Boolean

value = instance.IsLogRequired

Syntax

Visual Basic

ReadOnly Property IsLogRequired As Boolean

C#

bool IsLogRequired { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.IsResultRequired Property

This property represents whether the results are required for this filter to be applicable.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Boolean

value = instance.IsResultRequired

Syntax

Visual Basic

ReadOnly Property IsResultRequired As Boolean

C#

bool IsResultRequired { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.IssueDescription Property

This property represents the issue description for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As String

value = instance.IssueDescription

Syntax

Visual Basic

ReadOnly Property IsResultRequired IssueDescription As String

C#

string IssueDescription { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.IssueResolution Property

This property represents the issue resolution for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As String

value = instance.IssueResolution

Syntax

Visual Basic

ReadOnly Property IssueResolution As String

C#

string IssueResolution { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.LastModifiedDate Property

This property represents the last modified date for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As DateTime

value = instance.LastModifiedDate

Syntax

Visual Basic

ReadOnly Property LastModifiedDate As DateTime

C#

DateTime LastModifiedDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.LogNodes Property

This property represents the filter log nodes for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As ReadOnlyCollection(Of IFilterLogNode)

value = instance.LogNodes

Syntax

Visual Basic

ReadOnly Property LogNodes As ReadOnlyCollection(Of IFilterLogNode)

C#

ReadOnlyCollection<IFilterLogNode> LogNodes { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.ShouldFilterAllZeros Property

This property determines whether the filter should be applied if the pass and fail count are both zero.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Boolean

value = instance.ShouldFilterAllZeros

Syntax

Visual Basic

ReadOnly Property ShouldFilterAllZeros As Boolean

C#

bool ShouldFilterAllZeros { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.ShouldFilterNotRuns Property

This property determines whether the filter should be applied for not run task results.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Boolean

value = instance.ShouldFilterNotRuns

Syntax

Visual Basic

ReadOnly Property ShouldFilterNotRuns As Boolean

C#

bool ShouldFilterNotRuns { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.Status Property

This property represents the status for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As FilterStatus

value = instance.Status

Syntax

Visual Basic

ReadOnly Property Status As FilterStatus

C#

FilterStatus Status { get; }

Property Value

Returns FilterStatus.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.TestCommandLine Property

This property represents the command line for the test being filtered.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As String

value = instance.TestCommandLine

Syntax

Visual Basic

ReadOnly Property TestCommandLine As String

C#

string TestCommandLine { get; }

Property Value

Returns String.

Remarks

Used for case-insensitive matching (equals or starts with) of the test command line.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.Title Property

This property represents the filter title value (string).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As String

value = instance.Title

Syntax

Visual Basic

ReadOnly Property Title As String

C#

string Title { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.Type Property

This property represents the filter type for the given filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As FilterType

value = instance.Type

Syntax

Visual Basic

ReadOnly Property Type As FilterType

C#

FilterType Type { get; }

Property Value

Returns FilterType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilter.Version Property

This property represents the version for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilter

Dim value As Integer

value = instance.Version

Syntax

Visual Basic

ReadOnly Property Version As Integer

C#

int Version { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterConstraint Interface

This class represents a filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraint

Syntax

Visual Basic

Public Interface IFilterConstraint

C#

public interface IFilterConstraint


IFilterConstraint Members

The following tables list the members exposed by the IFilterConstraint type.

Public Properties

Name | Description
Filter | This property represents the associated filter for this constraint.
GathererLocation | This property represents the type of filter constraint.
Query | This property represents the XPath query for the target and gatherer filter constraints (also known as the JSON query for the submission filter constraint).
Type | This property represents the type of filter constraint.


IFilterConstraint Properties

Public Properties

Name | Description
Filter | This property represents the associated filter for this constraint.
GathererLocation | This property represents the type of filter constraint.
Query | This property represents the XPath query for the target and gatherer filter constraints (also known as the JSON query for the submission filter constraint).
Type | This property represents the type of filter constraint.


IFilterConstraint.Filter Property

This property represents the associated filter for this constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraint

Dim value As IFilter

value = instance.Filter

Syntax

Visual Basic

ReadOnly Property Filter As IFilter

C#

IFilter Filter { get; }

Property Value

Returns IFilter.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterConstraint.GathererLocation Property

This property represents the type of filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraint

Dim value As String

value = instance.GathererLocation

Syntax

Visual Basic

ReadOnly Property GathererLocation As String

C#

string GathererLocation { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterConstraint.Query Property

This property represents the XPath query for the target and gatherer filter constraints (also known as the JSON query for the submission filter constraint).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraint

Dim value As String

value = instance.Query

Syntax

Visual Basic

ReadOnly Property Query As String

C#

string Query { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterConstraint.Type Property

This property represents the type of filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraint

Dim value As FilterConstraintType

value = instance.Type

Syntax

Visual Basic

ReadOnly Property Type As FilterConstraintType

C#

FilterConstraintType Type { get; }

Property Value

Returns FilterConstraintType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterConstraintEvaluator Interface

This class contains a method that evaluates a filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraintEvaluator

Syntax

Visual Basic

Public Interface IFilterConstraintEvaluator

C#

public interface IFilterConstraintEvaluator


IFilterConstraintEvaluator Members

The following tables list the members exposed by the IFilterConstraintEvaluator type.

Public Properties

Name | Description
IsMatch | This method evaluates a filter constraint and returns true if the constraint matches.


IFilterConstraintEvaluator Methods

Public Properties

Name | Description
IsMatch | This method evaluates a filter constraint and returns true if the constraint matches.


IFilterConstraintEvaluator.IsMatch Method

This method evaluates a filter constraint and returns true if the constraint matches.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterConstraintEvaluator

Dim constraint As IFilterConstraint

Dim returnValue As Boolean

returnValue = instance.IsMatch(constraint)

Syntax

Visual Basic

Function IsMatch ( _

      `constraint As IFilterConstraint _`

) As Boolean

C#

bool IsMatch (

      `IFilterConstraint constraint`

)

Parameters

constraint

 The filter constraint to match.

Return Value

true if the constraint matches; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode Interface

This class represents a log node for a filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Syntax

Visual Basic

Public Interface IFilterLogNode

C#

public interface IFilterLogNode


IFilterLogNode Members

The following tables list the members exposed by the IFilterConstraint type.

Public Properties

Name | Description
Attribute | This property represents the attribute for the filter log node.
ChildNodes | This property represents the child nodes for the filter log node.
EndTag | This property represents the XPath query for the target and gatherer filter constraints (also known as the JSON query for the submission filter constraint).
Filter | This property represents the associated filter for this filter log node.
IsMatchOnce | This property represents whether the log node should be matched only once.
Parent | This property represents the parent node for this filter log node.
Regex | This property represents the regex for the filter log node.
RequireAllClear | This property represents whether the filter log node requires all clear.
StartTag | This property represents the XML start tag for the filter log node.


IFilterLogNode Properties


IFilterLogNode.Attribute Property

This property represents the attribute for the filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As String

value = instance. Attribute

Syntax

Visual Basic

ReadOnly Property Attribute As String

C#

string Attribute { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.ChildNodes Property

This property represents the child nodes for the filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As ReadOnlyCollection(Of IFilterLogNode)

value = instance.ChildNodes

Syntax

Visual Basic

ReadOnly Property ChildNodes As ReadOnlyCollection(Of IFilterLogNode)

C#

ReadOnlyCollection<IFilterLogNode> ChildNodes { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.EndTag Property

This property represents the child nodes for the filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As String

value = instance.EndTag

Syntax

Visual Basic

ReadOnly Property EndTag As String

C#

string EndTag { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.Filter Property

This property represents the associated filter for this filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As IFilter

value = instance.Filter

Syntax

Visual Basic

ReadOnly Property Filter As IFilter

C#

IFilter Filter { get; }

Property Value

Returns IFilter.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.IsMatchOnce Property

Represents whether a log node should be matched only once.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As Boolean

value = instance.IsMatchOnce

Syntax

Visual Basic

ReadOnly Property IsMatchOnce As Boolean

C#

bool IsMatchOnce { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.Parent Property

Represents the parent node for this filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As IFilterLogNode

value = instance.Parent

Syntax

Visual Basic

ReadOnly Property Parent As IFilterLogNode

C#

IFilterLogNode Parent { get; }

Property Value

Returns IFilterLogNode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.Regex Property

Represents a regular expression for a filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As String

value = instance.Regex

Syntax

Visual Basic

ReadOnly Property Regex As String

C#

string Regex { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.RequireAllClear Property

Represents whether a filter log node requires all clear.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As Boolean

value = instance.RequireAllClear

Syntax

Visual Basic

ReadOnly Property RequireAllClear As Boolean

C#

bool RequireAllClear { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterLogNode.StartTag Property

Represents the XML start tag for a filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterLogNode

Dim value As String

value = instance.StartTag

Syntax

Visual Basic

ReadOnly Property StartTag As String

C#

string StartTag { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult Interface

Represents a filter result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Syntax

Visual Basic

Public Interface IFilterResult

C#

public interface IFilterResult

Related topics

IFilterResult Members


IFilterResult Members

The following tables list the members exposed by the IFilterConstraint type.

Public Properties

Name | Description
AppliedCount | This property represents the number of times the filtered was applied.
EndTime | This property represents the end time when this filter was processed.
ErrorCount | This property represents the filtered error count.
Exception | This property represents the exception for the filter result
FailCount | This property represents the filtered fail count.
Filter | This property represents the filter ID number for the applied filter. The Filter ID number uniquely identifies a filter.
FilterExpirationDate | This property represents the expiration date for the applied filter.
FilterNumber | This property represents the filter ID number for the applied filter. The Filter ID number uniquely identifies a filter.
FilterType | This property represents the type of the filter.
FilterVersion | This property represents the version for the applied filter.
IsAllZeros | This property indicates whether the applied filter was an AllZeros filter.
LogFilePath | This property represents the log file path for the filter result.
NotRunCount | This property represents the filtered not run count.
StartTime | This property represents the processing start time when this filter was applied.
TaskResultFilterHistory | This property represents the associated filter history for the task result that was filtered.
TotalCount | This property represents the total count for the filter.

Public Methods

Name | Description
UpdateAppliedCount | Updates the applied count for the filter result.


IFilterResult Methods

Public Methods

Name | Description
UpdateAppliedCount | Updates the applied count for the filter result.


IFilterResult.UpdateAppliedCount Method

Overload List

Name | Description
IFilterResult.UpdateAppliedCount () | This method updates the applied count for the filter result.
IFilterResult.UpdateAppliedCount (Boolean) | This method updates the applied count for the filter result.


IFilterResult.UpdateAppliedCount Method ()

This method updates the applied count for the filter result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

instance.UpdateAppliedCount

Syntax

Visual Basic

Sub UpdateAppliedCount

C#

void UpdateAppliedCount ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.UpdateAppliedCount Method (Boolean)

This method updates the applied count for the filter result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim isAllZeros As Boolean

instance.UpdateAppliedCount(isAllZeros)

Syntax

Visual Basic

Sub UpdateAppliedCount ( _

      `isAllZeros As Boolean _`

)

C#

void UpdateAppliedCount (

      `bool isAllZeros`

)

Parameters

isAllZeros

 A flag that determines whether the filter result should be updated with isAllZeros.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult Properties

Insert introduction here.

Public Properties

Name | Description
AppliedCount | This property represents the number of times the filtered was applied.
EndTime | This property represents the end time when this filter was processed.
ErrorCount | This property represents the filtered error count.
Exception | This property represents the exception for the filter result
FailCount | This property represents the filtered fail count.
Filter | This property represents the filter ID number for the applied filter. The Filter ID number uniquely identifies a filter.
FilterExpirationDate | This property represents the expiration date for the applied filter.
FilterNumber | This property represents the filter ID number for the applied filter. The Filter ID number uniquely identifies a filter.
FilterType | This property represents the type of the filter.
FilterVersion | This property represents the version for the applied filter.
IsAllZeros | This property indicates whether the applied filter was an AllZeros filter.
LogFilePath | This property represents the log file path for the filter result.
NotRunCount | This property represents the filtered not run count.
StartTime | This property represents the processing start time when this filter was applied.
TotalCount | This property represents the total count for the filter.


IFilterResult.AppliedCount Property

This property represents the attribute for the filter log node.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Integer

value = instance.AppliedCount

instance.AppliedCount = value

Syntax

Visual Basic

Property AppliedCount As Integer

C#

int AppliedCount { get; set; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.EndTime Property

This property represents the end time when this filter was processed.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Nullable(Of DateTime)

value = instance.EndTime

instance.EndTime = value

Syntax

Visual Basic

Property EndTime As Nullable(Of DateTime)

C#

Nullable<DateTime> EndTime { get; set; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.ErrorCount Property

This property represents the filtered error count.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Integer

value = instance.ErrorCount

instance.ErrorCount = value

Syntax

Visual Basic

Property ErrorCount As Integer

C#

int ErrorCount { get; set; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.Exception Property

This property represents the exception for the filter result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As ProjectManagerException

value = instance.Exception

Syntax

Visual Basic

ReadOnly Property Exception As ProjectManagerException

C#

ProjectManagerException Exception { get; }

Property Value

Returns ProjectManagerException.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.FailCount Property

This property represents the filtered fail count.


IFilterResult.Filter Property

This property represents the filter ID number for the applied filter. The Filter ID number uniquely identifies a filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As IFilter

value = instance.Filter

Syntax

Visual Basic

ReadOnly Property Filter As IFilter

C#

IFilter Filter { get; }

Property Value

Returns IFilter Interface.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.FilterExpirationDate Property

This property represents the expiration date for the applied filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Nullable(Of DateTime)

value = instance.FilterExpirationDate

Syntax

Visual Basic

ReadOnly Property FilterExpirationDate As Nullable(Of DateTime)

C#

Nullable<DateTime> FilterExpirationDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.FilterNumber Property

This property represents the filter ID number for the applied filter. The Filter ID number uniquely identifies a filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Integer

value = instance.FilterNumber

Syntax

Visual Basic

ReadOnly Property FilterNumber As Integer

C#

int FilterNumber { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.FilterType Property

This property represents the type of the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As FilterType

value = instance.FilterType

Syntax

Visual Basic

ReadOnly Property FilterType As FilterType

C#

FilterType FilterType { get; }

Property Value

Returns FilterType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.FilterVersion Property

This property represents the version for the applied filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Integer

value = instance.FilterVersion

Syntax

Visual Basic

ReadOnly Property FilterType As Integer

C#

int FilterVersion { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.IsAllZeros Property

This property indicates whether the applied filter was an AllZeros filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Boolean

value = instance.IsAllZeros

Syntax

Visual Basic

ReadOnly Property IsAllZeros As Boolean

C#

bool IsAllZeros { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.LogFilePath Property

This property represents the log file path for the filter result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As String

value = instance.LogFilePath

Syntax

Visual Basic

ReadOnly Property LogFilePath As String

C#

string LogFilePath { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.NotRunCount Property

This property represents the filtered not run count.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Integer

value = instance.NotRunCount

instance.NotRunCount = value

Syntax

Visual Basic

Property NotRunCount As Integer

C#

int NotRunCount { get; set; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.StartTime Property

This property represents the processing start time when this filter was applied.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As DateTime

value = instance.StartTime

Syntax

Visual Basic

ReadOnly Property StartTime As DateTime

C#

DateTime StartTime { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterResult.TotalCount Property

This property represents the total count for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterResult

Dim value As Integer

value = instance.TotalCount

instance.TotalCount = value

Syntax

Visual Basic

Property TotalCount As Integer

C#

int TotalCount { get; set; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterTargetData Interface

This class provides an interface to return specific information about filters applied to a test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterTargetData

Syntax

Visual Basic

Public Interface IFilterTargetData

C#

public interface IFilterTargetData

Related topics

IFilterResult Members


IFilterTargetData Members

The following tables list the members exposed by the IFilterTargetData type.

Public Properties

Name | Description
AllInboxDrivers | This property indicates whether all of the drivers associated with this device are signed.
Manufacturer | This property represents the manufacturer of the device driver.
Version | This property represents the file version of the driver.


IFilterTargetData Properties

The following table lists the properties exposed by the IFilterTargetData type.

Public Properties

Name | Description
AllInboxDrivers | This property indicates whether all of the drivers associated with this device are signed.
DriverHash | This property represents a collection of identified driver hashes.
Drivers | This property represents a collection of identified drivers.
Manufacturer | This property represents the manufacturer of the device driver.
Version | This property represents the file version of the driver.


IFilterTargetData.AllInboxDrivers Property

This property indicates whether all of the drivers associated with this device are signed.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterTargetData

Dim value As TargetDriversType

value = instance.AllInboxDrivers

Syntax

Visual Basic

ReadOnly Property AllInboxDrivers As TargetDriversType

C#

TargetDriversType AllInboxDrivers { get; }

Property Value

Returns TargetDriversType.

Remarks

If all drivers associated with the target are signed, the result is InboxDrivers.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DriverHash Property

This property represents a collection of identified driver hashes.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

ReadOnlyCollection<string> DriverHash { get; }

Remarks

Upper and lower filter drivers may also be included.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Drivers Property

This property represents a collection of identified drivers.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

ReadOnlyCollection<string> Drivers { get; }

Remarks

Upper and lower filter drivers may also be included.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterTargetData.Manufacturer Property

This property represents the manufacturer of the device driver.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterTargetData

Dim value As String

value = instance.Manufacturer

Syntax

Visual Basic

ReadOnly Property Manufacturer As String

C#

string Manufacturer { get; }

Property Value

Returns String.

Remarks

Returns null if a manufacturer cannot be found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IFilterTargetData.Version Property

This property represents the file version of the driver.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IFilterTargetData

Dim value As String

value = instance.Version

Syntax

Visual Basic

ReadOnly Property Version As String

C#

string Version { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


INotifyProjectChanged Interface

This interface is for all classes that can have update events.


InUseTargetData Struct

Struct used to create a table of all targets and their owning project for the targets on this machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public struct InUseTargetData

Inheritance Hierarchy

System.ValueType

 **Microsoft.Windows.Kits.Hardware.ObjectModel.InUseTargetData**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

InUseTargetData Properties


InUseTargetData Properties

Public Properties

Name | Type | Description
ProductInstance | string | ProductInstance OS platform name
Project | string | Project name
TargetKey | string | Target key
TargetName | string | Target name

Related topics

InUseTargetData Struct


IParameterResolver Interface

This class provides an interface to enable external overrides to parameter resolution.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IParameterResolver

Syntax

Visual Basic

Public Interface IParameterResolver

C#

public interface IParameterResolver

Related topics

IFilterResult Members


IParameterResolver Members

The following tables list the members exposed by the IFilterTargetData type.

Public Methods

Name | Description
ResolveParameter | This method is called by the scheduler to resolve a parameter that should be resolved externally.


IParameterResolver Methods

The following tables list the methods exposed by the IFilterTargetData type.

Public Methods

Name | Description
IParameterResolver.ResolveParameter Method | This method is called by the scheduler to resolve a parameter that should be resolved externally.


IParameterResolver.ResolveParameter Method

This method is called by the scheduler to resolve a parameter that should be resolved externally.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IParameterResolver

Dim inValue As String

Dim outValue As String

Dim returnValue As Boolean

returnValue = instance.ResolveParameter(inValue, outValue)

Syntax

Visual Basic

Function ResolveParameter ( _

      `inValue As String, _`

      `ByRef outValue As String _`

) As Boolean

C#

bool ResolveParameter (

      `string inValue,`

      `ref string outValue`

)

Parameters

inValue

 The resolver value to replace.

outValue

 The new value of the parameter. If the method returns **true**, this will be the new value.

Return Value

Returns Boolean, which has a value of true if the parameter SHOULD be resolved, or returns false if the parameter should not be resolved.

Remarks

This method will return true if the identifier was found indicating that this resolver was responsible for this parameter it does not ensure that any parameter value was actually found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IParameterResolverManager Interface

This class contains a ordered list of parameters for each resolver.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IParameterResolverManager

Syntax

Visual Basic

Public Interface IParameterResolverManager

C#

public interface IParameterResolverManager

Related topics

IFilterResult Members


IParameterResolverManager Members

The following tables list the members exposed by the IParameterResolverManager type.

Public Methods

Name | Description
AddNewResolver | This method adds a new Resolver interface to this collection.
ResolveParameter | This method resolve the parameter string.


IParameterResolverManager.AddNewResolver Method

This method adds a new Resolver interface to this collection.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IParameterResolverManager

Dim resolver As IParameterResolver

instance.AddNewResolver(resolver)

Syntax

Visual Basic

Sub AddNewResolver ( _

      `resolver As IParameterResolver _`

)

C#

void AddNewResolver (

      `IParameterResolver resolver`

)

Parameters

resolver

 The instance of a resolver application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IParameterResolverManager.ResolveParameter Method

This method resolves the parameter string.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IParameterResolverManager

Dim inputValue As String

Dim returnValue As String

returnValue = instance.ResolveParameter(inputValue)

Syntax

Visual Basic

Function ResolveParameter ( _

      `inputValue As String _`

) As String

C#

string ResolveParameter (

      `string inputValue`

)

Parameters

inputValue

 The input string to search for.

Return Value

Returns String, which is the final result of the parameter resolution process.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IProxyRunTests Interface

Represents functionality that each schedulable object needs to implement for running tests on a Proxy Client.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public interface IProxyRunTests


IProxyRunTests.QueueTest Method

Overload List

Name | Description
QueueTest (TemplateParameters) | This method schedules all the tests for execution.
QueueTest (MachineSet, TemplateParameters) | This method schedules all the tests for execution on a specified MachineSet.
QueueTest (IEnumerable<Test>, IEnumerable<Machine>, TemplateParameters) | This method schedules the test for execution on a specific subset of machines.


IProxyRunTests.QueueTest Method (TemplateParameters)

This method schedules all the tests for execution.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

IList<TestResult> QueueTest (

      `TemplateParameters templateParameters`

)

Parameters

templateParameters

Template parameters to use for running tests on a Proxy Client.

Return Value

IList<TestResult>

A list of results for the tests that were scheduled.

Remarks

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately and the method returns. The function will leave some tests scheduled, and some that are incomplete. The list returned identifies the tests that were scheduled.

This is not supported when the project is connected to a package.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IProxyRunTests.QueueTest Method (MachineSet, TemplateParameters)

This method schedules all the tests for execution on a specified MachineSet.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

IList<TestResult> QueueTest (

      `MachineSet logicalMachineSet,`

      `TemplateParameters templateParameters`

)

Parameters

logicalMachineSet

Machine set to run the tests.

templateParameters

Template parameters to use for running tests on a Proxy Client.

Return Value

IList<TestResult>

A list of results for the tests that were scheduled.

Remarks

The machine associated with the target (that was selected) is automatically added to the set.

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately and an exception is thrown. As a result, some tests could have been scheduled.

This is not supported when the project is connected to a package.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IProxyRunTests.QueueTest Method (IEnumerable Test , IEnumerable Machine , TemplateParameters)

This method schedules the test for execution on a specific subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

IList<TestResult> QueueTest (

      `IEnumerable<Test> testList,`

      `IEnumerable<Machine> machineList,`

      `TemplateParameters templateParameters`

)

Parameters

testList

A list of tests to consolidate with the current test.

machineList

List of machines that can run the test.

templateParameters

Template parameters to use for running tests on a Proxy Client.

Return Value

IList<TestResult>

A list of results for the tests that were scheduled.

Remarks

This is useful to specify a subset of possible machines. For example in the case where manual tests would prefer to run on specific machines.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunExport Interface

This interface contains methods to export a standalone executable version of the current object to a specified location.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public interface IRunExport

Related topics

IRunExport Members

IRunExport Methods


IRunExport Members

Public Properties

Name | Type | Description
CanExport | bool | Read-only. Retrieves whether the object is exportable.

Related topics

IRunExport Interface

IRunExport Methods


IRunExport Methods

Public Methods

Name | Description
Export | Exports a standalone version of the current object to the specified location.

Related topics

IRunExport Interface

IRunExport Members


Export Method

This method exports a standalone version of the current object to the specified location.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

void Export(string outputLocation)

Parameters

Name | Type | Description
outputLocation | string | The output location where the executable package is written.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

IRunExport Interface

IRunExport Members

IRunExport Methods


IRunTests Interface

This class provides an interface that represents the contract that each schedulable object must implement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IRunTests

Syntax

Visual Basic

Public Interface IRunTests

C#

public interface IRunTests

Remarks

This is mainly used to allow scheduling of tests from various objects. Currently the following objects implement this interface:

  • Project

  • ProductInstance

  • TargetFamily

  • Test


IRunTests Members

The following tables list the members exposed by the IRunTests type.

Public Methods

Name | Description
AddTests | For the TestDefinitions given, add new test instances. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
GetTests | This method retrieves all tests needed for this node.
QueueTest | This method schedules all the tests for execution.
RemoveTests | For the TestDefinitions given, this method removes existing test instances. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.


IRunTests Methods

The following tables list the methods exposed by the IRunTests type.

Public Methods

Name | Description
AddTests | For the TestDefinitions given, add new test instances. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
GetTests | This method retrieves all tests needed for this node.
QueueTest | This method schedules all the tests for execution.
RemoveTests | For the TestDefinitions given, this method removes existing test instances. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.


IRunTests.AddTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Overload List

Name | Description
AddTests Method (IEnumerable{TestDefinition}) | For the TestDefinitions given, add new test instances.
AddTests Method (IEnumerable{TestDefinition}, bool) | For the TestDefinitions given, add new test instances.


IRunTests.AddTests Method (IEnumerable TestDefinition )

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

For the TestDefinitions given, add new test instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

void AddTests (

      `IEnumerable<TestDefinition> testList`

)

Parameters

testList

 The list of tests to add.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunTests.AddTests Method (IEnumerable TestDefinition , bool)

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

For the TestDefinitions given, add new test instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

void AddTests (

      `IEnumerable<TestDefinition> testList,`

      `bool featureDetectionEnabled`

)

Parameters

testList

 The list of tests to add.

featureDetectionEnabled

 Sets whether there must be a feature mapping between the tests being created and the targets they are being added to.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunTests.GetTests Method ()

This method retrieves all tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IRunTests

Dim returnValue As IList(Of Test)

returnValue = instance.GetTests

Syntax

Visual Basic

Function GetTests As IList(Of Test)

C#

IList<Test> GetTests ()

Return Value

A collection of all of the tests.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunTests.QueueTest Method

Overload List

Name | Description
IRunTests.QueueTest () | This method schedules this object for execution.
IRunTests.QueueTest (MachineSet) | This method schedules this object to be run. The machine under test (test computer) is always part of the machine set. This method is only for additional machines in a machine set.
IRunTests.QueueTest Method (IEnumerable{Machine}) | This method schedules the test for execution on a specific subset of machines.


IRunTests.QueueTest Method ()

This method schedules this object for execution.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IRunTests

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest

Syntax

Visual Basic

Function QueueTest As IList(Of TestResult)

C#

IList<TestResult> QueueTest ()

Return Value

Returns IList, which is a list of results for the tests that were scheduled.

Remarks

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately and the method returns. The function will leave some tests scheduled, and some that are incomplete. The list returned identifies the tests that were scheduled.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunTests.QueueTest Method (MachineSet)

This method schedules this object to be run. The machine under test (test computer) is always part of the machine set. This method is only for additional machines in a machine set.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As IRunTests

Dim logicalMachineSet As MachineSet

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest(logicalMachineSet)

Syntax

Visual Basic

Function QueueTest ( _

      `logicalMachineSet As MachineSet _`

) As IList(Of TestResult)

C#

IList<TestResult> QueueTest (

      `MachineSet logicalMachineSet`

)

Parameters

logicalMachineSet

 The list of machines to run this on.

Return Value

Returns IList, which is a list of results for the tests that were scheduled.

Remarks

The machine associated with the target that was selected is automatically added to the set.

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately, and an exception is thrown. As a result, some tests could have been scheduled.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunTests.QueueTest Method (IEnumerable Machine )

This method schedules the test for execution on a specific subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Function QueueTest( _

      `ByVal machineList As IEnumerable(Of Machine) _`

) As IList(Of TestResult)

C#

IList<TestResult> QueueTest (

      `IEnumerable<Machine> machineList`

)

Parameters

machineList

 The list of machines on which to run the test.

Return Value

Returns IList, which is a list of results for the tests that were scheduled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IRunTests.RemoveTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

For the TestDefinitions given, this method removes existing test instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

void RemoveTests (

      `IEnumerable<TestDefinition> testList`

)

Parameters

testList

 The list of tests to remove.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ISystemTargetData Interface

Extracts information from a test target or TargetData object for a system.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ISystemTargetData

Syntax

Visual Basic

Public Interface ISystemTargetData

C#

public interface ISystemTargetData


ISystemTargetData Members

The following tables list the members exposed by the ISystemTargetData type.

Public Properties

Name | Description
Manufacturer | This property represents the manufacturer of the test target (test device).
Model | This property represents the model name of the test target (test device).


ISystemTargetData Properties

The following tables list the properties exposed by the ISystemTargetData type.

Public Properties

Name | Description
Manufacturer | This property represents the manufacturer of the test target (test device).
Model | This property represents the model name of the test target (test device).


ISystemTargetData.Manufacturer Property

This property represents the manufacturer of the test target (test device).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ISystemTargetData

Dim value As String

value = instance.Manufacturer

Syntax

Visual Basic

ReadOnly Property Manufacturer As String

C#

string Manufacturer { get; }

Return Value

Returns String.

Remarks

Returns null if a manufacturer cannot be found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ISystemTargetData.Model Property

This property represents the model name of the test target (test device).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ISystemTargetData

Dim value As String

value = instance.Model

Syntax

Visual Basic

ReadOnly Property Model As String

C#

string Model { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ITargetInformation Interface

This class provides an interface to uniformly extract target and target data information.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ITargetInformation

Syntax

Visual Basic

Public Interface ITargetInformation

C#

public interface ITargetInformation


ITargetInformation Members

The following tables list the members exposed by the ITargetInformation type.

Public Properties

Name | Description
Key | This property represents the specific identifier for this target, on this machine.
Machine | This property represents the machine which this target was found on.
TargetType | This property represents the type of the test target. A test target can be a individual device, software (for example, a filter driver) or a system.
XmlData | Gets the target information in the raw XML format.


ITargetInformation Properties

The following tables list the members exposed by the ITargetInformation type.

Public Properties

Name | Description
Key | This property represents the specific identifier for this target, on this machine.
Machine | This property represents the machine which this target was found on.
TargetType | This property represents the type of the test target. A test target can be a individual device, software (for example, a filter driver) or a system.
XmlData | Gets the target information in the raw XML format.


ITargetInformation.Key Property

This property represents the specific identifier for this target, on this machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ITargetInformation

Dim value As String

value = instance.Key

Syntax

Visual Basic

ReadOnly Property Key As String

C#

string Key { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ITargetInformation.Machine Property

This property represents the machine which this target was found on.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ITargetInformation

Dim value As Machine

value = instance.Machine

Syntax

Visual Basic

ReadOnly Property Machine As Machine

C#

Machine Machine { get; }

Property Value

Returns Machine.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ITargetInformation.TargetType Property

This property represents the type of the test target. A test target can be an individual device, software (for example, a filter driver) or a system.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ITargetInformation

Dim value As TargetType

value = instance.TargetType

Syntax

Visual Basic

ReadOnly Property TargetType As TargetType

C#

TargetType TargetType { get; }

Return Value

Returns TargetType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ITargetInformation.XmlData Property

This property gets the target information in the raw XML format.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ITargetInformation

Dim value As String

value = instance.XmlData

Syntax

Visual Basic

ReadOnly Property XmlData As String

C#

string XmlData { get; }

Return Value

Returns String.

Remarks

The XML data is collected using sysparse and is collected on the client machine. The data is gathered from many sources by the Client software and returned to the controller (stored in XML format).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


LogType Enumeration

This is an enumeration that defines the type of log files and therefore the type of information it contains.

Usage

Visual Basic

Dim instance As LogType

Syntax

Visual Basic

Public Enumeration LogType

C#

public enum LogType

Members

Member name | Description
Diagnostic | This enum value identifies a log file as containing diagnostic information.
Gatherer | This enum value identifies a log file as containing gatherer-specific information; specifically, details about the hardware state of the test computer.
Server | This enum value identifies a log file as containing server-specific information. Specifically, information generated by the test infrastructure on the server.
Task | This enum value indicates that a log file contains information specific to a task.
Test | This enum value indicates that a log file contains information specific to a test task. Specifically, details generated by a test, but not specific to any individual task.
TestRun | This enum value indicates that a log file contains information specific to a test run. Specifically, information generated by the test infrastructure on the test client (test computer).


Machine Class

This class represents an abstract resource that a logo test can be scheduled to run against. Each machine (test computer) belongs to one and only one machine pool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class Machine

C#

[DataContractAttribute]

public abstract class Machine

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.Machine**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

When the client software is originally installed on a machine, a Machine object is created and automatically appears in the default pool. Machine objects that are newly created are in a 'Not Ready' state, they need to be set to 'Ready' state before tests can be scheduled.

Any Machine in the reserved <seealso cref="T:Microsoft.Windows.Kits.Hardware.ObjectModel.MachinePool"/> cannot run tests. These machines will need to be moved into a MachinePool that is not a reserved pool.


Machine Members

The following table lists the members exposed by the Machine type.

Protected Constructors

Name | Description
Machine | Overloaded.

Public Properties

Name | Description
EstimatedRuntime | This property represents the estimated runtime remaining for all tests which will be run against this machine (test computer).
Id | This property represents the unique ID value of the machine.
LastHeartbeat | This property represents the last heartbeat time.
Name | This property represents the name of the machine.
OSPlatform | This property represents the operating system name, CPU type, and so on of this machine.
Pool | This property represents the reference of the parent pool for this machine.
Status | This property represents the state of the machine.
UniqueIdentifier | Gets the unique identifier.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetFullPropertyByName | This method retrieves the value of a particular dimension value.
GetHashCode | (Inherited from Object)
GetMachineProperties | This method retrieves all of the machine properties for this machine.
GetPropertyByName | This method retrieves the value of a particular dimension value.
GetTargetsInUse | Gets a summary of all of the targets from all of the projects that are still in use by the machine.
GetTestTargets | Gets a collection of test targets.
GetType | (Inherited from Object)
RemoveProperty | This method removes and deletes property (dimension) by name from this machine.
SetMachineStatus | This method sets the machine status. This is a blocking call and will wait until the machine status is set or the timeout has elapsed. A good default value is 10 min (600000 milliseconds).
SetProperty | This method creates a new, or updates an existing property value for a machine.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Machine Constructor

Overload List

Name | Description
Machine () |


Machine Constructor ()

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New Machine

Syntax

Visual Basic

Protected Sub New

C#

Protected Sub New

Remarks

The default constructor initializes any fields to their default values.


Machine Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetFullPropertyByName | This method retrieves the value of a particular dimension value.
GetHashCode | (Inherited from Object)
GetMachineProperties | This method retrieves all of the machine properties for this machine.
GetPropertyByName | This method retrieves the value of a particular dimension value.
GetTargetsInUse | This method retrieves a summary of all of the targets from all of the projects which are still in use by this machine.
GetTestTargets | Overloaded.
GetType | (Inherited from Object)
RemoveProperty | This method removes a property (dimension) by name from this machine.
SetMachineStatus | This method sets the machine status. This is a blocking call and will wait until the machine status is set or the timeout has elapsed. A good default value is 10 min (600000 milliseconds).
SetProperty | This method creates a new, or updates an existing property value for a machine.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Machine.GetFullPropertyByName Method

This method retrieves the value of a particular dimension value.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim propertyName As String

Dim returnValue As MachineProperty

returnValue = instance.GetFullPropertyByName(propertyName)

Syntax

Visual Basic

Public MustOverride Function GetFullPropertyByName ( _

      `propertyName As String _`

) As MachineProperty

C#

public abstract MachineProperty GetFullPropertyByName (

      `string propertyName`

)

Parameters

propertyName

 The name of the property to get.

Return Value

Returns MachineProperty, which is the particular Machine property (dimensions).

Remarks

An exception is thrown when:

  • The propertyName parameter is null.

  • The propertyName parameter is empty.

  • The propertyName cannot be found.

    Machine Properties are also referred to as Dimensions.

    This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.GetMachineProperties Method

This method retrieves all of the machine properties for this machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim returnValue As ReadOnlyCollection(Of MachineProperty)

returnValue = instance.GetMachineProperties

Syntax

Visual Basic

Public MustOverride Function GetMachineProperties As ReadOnlyCollection(Of MachineProperty)

C#

public abstract ReadOnlyCollection<MachineProperty> GetMachineProperties ()

Return Value

Returns ReadOnlyCollection, which is a read-only list of machine properties.

Remarks

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.GetPropertyByName Method

This method retrieves a particular dimension value.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim propertyName As String

Dim returnValue As String

returnValue = instance.GetPropertyByName(propertyName)

Syntax

Visual Basic

Public MustOverride Function GetPropertyByName ( _

      `propertyName As String _`

) As String

C#

public abstract string GetPropertyByName (

      `string propertyName`

)

Parameters

propertyName

 The name of the property to get.

Return Value

Returns String, which is the particular Machine property (dimension) for this machine.

Remarks

Machine Properties are also referred to as Dimensions.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.GetTargetsInUse Method

This method retrieves a summary of all of the targets from all of the projects which are still in use by this machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Overridable Function GetTargetsInUse() As ReadOnlyCollection(Of InUseTargetData)

C#

public virtual ReadOnlyCollection<InUseTargetData> GetTargetsInUse()

Return Value

This method returns a list of all targets that need to be deleted.

Remarks

Before deleting this machine, all targets returned by this method must first be deleted.

This method returns a structure that indicates targets by name, but it does not open each project and load each target to get this information.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.GetTestTargets Method

Overload List

Name | Description
Machine.GetTestTargets () | This method retrieves a read-only list of test targets associated with this machine.
Machine.GetTestTargets (TargetType) | This method retrieves a read-only list of test targets associated with this machine (test computer).


Machine.GetTestTargets Method ()

This method retrieves a read-only list of test targets associated with this machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.GetTestTargets

Syntax

Visual Basic

Public MustOverride Function GetTestTargets As ReadOnlyCollection(Of TargetData)

C#

public abstract ReadOnlyCollection<TargetData> GetTestTargets ()

Return Value

Returns ReadOnlyCollection, which is a collection to test targets.

Remarks

All test targets associated with this machine are returned; the collection does not filter out targets based on any loaded projects.

In order to identify targets as a part of a loaded project, look at the ProductInstance.Targets property from the Project object.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.GetTestTargets Method (TargetType)

Retrieves a read-only list of test targets associated with a machine (test computer).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim type As TargetType

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.GetTestTargets(type)

Syntax

Visual Basic

Public MustOverride Function GetTestTargets ( _

      `type As TargetType _`

) As ReadOnlyCollection(Of TargetData)

C#

public abstract ReadOnlyCollection<TargetData> GetTestTargets (

      `TargetType type`

)

Parameters

type

 The type of test target to search for.

Return Value

Returns ReadOnlyCollection, which is a collection to test targets.

Remarks

All test targets associated with this machine and match the type provided are returned; the collection does not filter out targets based on any loaded projects.

In order to identify targets as a part of a loaded project, look at the ProductInstance.Targets property from the Project object.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.RemoveProperty Method

This method removes a property (dimension) by name from this machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim nameOfPropertyToRemove As String

instance.RemoveProperty(nameOfPropertyToRemove)

Syntax

Visual Basic

Public MustOverride Sub RemoveProperty ( _

      `nameOfPropertyToRemove As String _`

)

C#

public abstract void RemoveProperty (

      `string nameOfPropertyToRemove`

)

Parameters

nameOfPropertyToRemove

 The name of the property to remove.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

This is not supported when the project is connected to a package.


Machine.SetMachineStatus Method

This method sets the machine status. This is a blocking call and will wait until the machine status is set or the timeout has elapsed. A good default value is 10 min (600000 milliseconds).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim status As MachineStatus

Dim millisecondsTimeout As Long

Dim returnValue As Boolean

returnValue = instance.SetMachineStatus(status, millisecondsTimeout)

Syntax

Visual Basic

Public MustOverride Function SetMachineStatus ( _

      `status As MachineStatus, _`

      `millisecondsTimeout As Long _`

) As Boolean

C#

public abstract bool SetMachineStatus (

      `MachineStatus status,`

      `long millisecondsTimeout`

)

Parameters

status

 The machine status to be set.

millisecondsTimeout

 The number of milliseconds to wait before this method returns. This value can be -1 (indicating an infinite wait time) or a positive number.

Return Value

true if the machine value is set,or false if the timeout value was reached.

Remarks

An exception occurs if:

  • status is not valid.

  • The value of millisecondsTimeout is less than -1.

    This is a blocking call and will wait until the machine status is set or the timeout has elapsed. A good default value is 10 min (600000 milliseconds). To specify infinite time, set the timeout to -1.

    This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.SetProperty Method

This method creates a new, or updates an existing property value for a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim nameOfPropertyToSet As String

Dim valueOfPropertyToSet As String

Dim returnValue As String

returnValue = instance.SetProperty(nameOfPropertyToSet, valueOfPropertyToSet)

Syntax

Visual Basic

Public MustOverride Function SetProperty ( _

      `nameOfPropertyToSet As String, _`

      `valueOfPropertyToSet As String _`

) As String

C#

public abstract string SetProperty (

      `string nameOfPropertyToSet,`

      `string valueOfPropertyToSet`

)

Parameters

nameOfPropertyToSet

 The name of the property to create or set.

valueOfPropertyToSet

 The value to set the property to.

Return Value

Returns String, which is the value of the property that has been set.

Remarks

An exception occurs if:

  • The source utility "UI" is not found.status is not valid.

  • The nameOfPropertyToSet parameter or the valueOfPropertyToSet parameter is null.

  • The nameOfPropertyToSet parameter or the valueOfPropertyToSet parameter is empty.

    This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine Properties

Public Properties

Name | Description
EstimatedRuntime | This property represents the estimated runtime remaining for all tests which will be run against this machine (test computer).
Id | This property represents the unique ID value of the machine.
LastHeartbeat | This property represents the last heartbeat time.
Name | This property represents the name of the machine.
OSEdition | This property represents the OS edition of the machine.
OSPlatform | This property represents the operating system name, CPU type, and so on of this machine.
Pool | This property represents the reference of the parent pool for this machine.
Status | This property represents the state of the machine.
UniqueIdentifier | This property represents a unique identifer for the machine

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


Machine.EstimatedRuntime Property

This property represents the estimated runtime remaining for all tests which will be run against this machine (test computer).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As TimeSpan

value = instance.EstimatedRuntime

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property EstimatedRuntime As TimeSpan

C#

[IgnoreDataMemberAttribute]

public abstract TimeSpan EstimatedRuntime { get; }

Property Value

Returns TimeSpan.

Remarks

This is not supported when the Project Manager is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.Id Property

Represents the unique ID value of a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As String

value = instance.Id

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property Id As String

C#

[IgnoreDataMemberAttribute]

public abstract string Id { get; }

Property Value

Returns String.

Remarks

The ID value is different for a machine when connected to a database and the same machine when connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.LastHeartbeat Property

Represents the last heartbeat time.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As DateTime

value = instance.LastHeartbeat

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property LastHeartbeat As DateTime

C#

[IgnoreDataMemberAttribute]

public abstract DateTime LastHeartbeat { get; }

Property Value

Returns DateTime.

Remarks

This will update the heartbeat and invoke a general refresh of the device.

This is not supported when the Project Manager is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.Name Property

Represents a machine name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As String

value = instance.Name

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property Name As String

C#

[IgnoreDataMemberAttribute]

public abstract string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSEdition Property

Represents the operating system edition of a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract string OSEdition { get; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.OSPlatform Property

Represents the operating system name, CPU type, and so on of a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As OSPlatform

value = instance.OSPlatform

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property OSPlatform As OSPlatform

C#

[IgnoreDataMemberAttribute]

public abstract OSPlatform OSPlatform{ get; }

Property Value

Returns OSPlatform.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.Pool Property

Represents the reference of the parent pool for a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As MachinePool

value = instance.Pool

instance.Pool = value

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride Property Pool As MachinePool

C#

[IgnoreDataMemberAttribute]

public abstract MachinePool Pool { get; set; }

Property Value

Returns MachinePool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.Status Property

Represents the state of a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Machine

Dim value As MachineStatus

value = instance.Status

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property Status As MachineStatus

C#

[IgnoreDataMemberAttribute]

public abstract MachineStatus Status { get; }

Property Value

Returns MachineStatus.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Machine.UniqueIdentifier Property

Gets the unique identifier.


MachinePoolConfigurationSetting Enumeration

This enumeration represents the configuration setting for a MachinePool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Enum MachinePoolConfigurationSetting

C#

public enum MachinePoolConfigurationSetting

Members

Member Name | Description
CollectMiniCrashDump | Configures machines in the pool to collect mini dump
CollectFullCrashDump | Configures machines in the pool to collect full crash dump


MachineException Class

This exception class is defined to handle machine-specific errors. Every time a non-expected occurrence happens, a MachineException is thrown to add more details related to the machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class MachineException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class MachineException : ProjectManagerException

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.MachineException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineException Members

The following table lists the members exposed by the Machine type.

Public Constructors

Name | Description
MachineException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


MachineException Constructor

Overload List

Name | Description
MachineException Constructor () | This constructor initializes a new instance of the MachineException class.
MachineException Constructor (String) | This constructor initializes a new instance of the MachineException class.
MachineException Constructor (String, Exception) | This constructor initializes a new instance of the MachineException class.


MachineException Constructor ()

This constructor initializes a new instance of the MachineException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New MachineException

Syntax

Visual Basic

Public Sub New

C#

public MachineException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineException Constructor (String)

This constructor initializes a new instance of the MachineException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New MachineException(message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

protected MachineException (

      `string message`

)

Parameters

message

 The Exception message (string).


MachineException Constructor (String, Exception)

This constructor initializes a new instance of the MachineException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New MachineException(message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

      `except As Exception _`

)

C#

public MachineException (

      `string message`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An exception object.


MachineException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


MachineException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


MachinePool Class

This class represents an abstract pool of machines that are grouped together based on a user intention. It exposes functionality that enables machines to be regrouped among different machine pools and manage the resource pool hierarchy.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Syntax

Visual Basic

Public MustInherit Class MachinePool

C#

public abstract class MachinePool

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.MachinePool**

Remarks

There are certain reserved or special Machine Pools that have specific purposes:

  1. Default Pool - any machine that has the Client side software installed initially appears in this pool. Tests cannot be executed on any machine in this pool.

  2. $ (Root Pool) - is the root machine pool. The root pool can be accessed through the ProjectManager object. Machines cannot be added or moved to this pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool Members

This class represents an abstract pool of machines that are grouped together based on a user intention. It exposes functionality that enables machines to be regrouped among different machine pools and manage the resource pool hierarchy.

Protected Constructors

Name | Description
MachinePool | Overloaded.

Public Properties

Name | Description
DefaultPool | This property represents the default pool.
Executable | This property represents a value indicating whether this pool can be used to run tests.
Name | This property represents the name of this machine pool.
Path | This property represents the machine pool path.
RootPool | This property represents a value indicating whether this pool can be used to run tests.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
CreateChildPool | This method creates a child machine pool.
DeleteChildPool | This method deletes a child machine pool that doesn't contain any machines in it.
DeleteMachine | This method deletes the named machine for this machine pool. The machine to be deleted must be a child machine of this pool. Using the MachinePool.DeleteMachine method is NOT recommended because it may leave the deleted machine in an unusable state.
Equals | Overloaded. Overridden.
GetChildPools | This method retrieves the enumerable list of child machine pools for this machine pool.
GetHashCode | Overridden. This method retrieves (creates) the hash code for a MachinePool object.
GetMachines | This method retrieves the enumerable list of machines contained by this machine pool.
GetType | (Inherited from Object)
MoveMachineTo | This method moves a machine from one machine pool to another. Moving resource to the root pool will cause an exception.
Equality | This method acts as an Equality operator. The method always returns false if either operand is null; otherwise, returns true or false.
Inequality | This method acts as an Inequality operator. The method always returns false if either operand is null; otherwise, returns true or false.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Enumeration

Name | Description
CrashDumpConfigurationSettingName | Dimension name for crash dump setting


MachinePool Constructor

Overload List

Name | Description
MachineException Constructor () | This constructor initializes a new instance of the MachinePool class.


MachinePool Constructor ()

This constructor initializes a new instance of the MachinePool class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New MachinePool

Syntax

Visual Basic

Public Sub New

C#

public MachinePool ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool Methods

Public Methods

Name | Description
CreateChildPool | This method creates a child machine pool.
DeleteChildPool | This method deletes a child machine pool that doesn't contain any machines in it.
DeleteMachine | This method deletes the named machine for this machine pool. The machine to be deleted must be a child machine of this pool. Using the DeleteMachine method is NOT recommended because it may leave the deleted machine in an unusable state.
Equals | Overloaded. Overridden.
GetChildPools | This method retrieves the enumerable list of child machine pools for this machine pool.
GetConfiguration | Retrieves the crash dump configuration for all machines in the machine pool.
GetHashCode | Overridden. This method retrieves (creates) the hash code for a MachinePool object.
GetMachines | This method retrieves the enumerable list of machines contained by this machine pool.
GetType | (Inherited from Object)
MoveMachineTo | This method moves a machine from one machine pool to another. Moving resource to the root pool will cause an exception.
Equality | This method acts as an Equality operator. The method always returns false if either operand is null; otherwise, returns true or false.
Inequality | This method acts as an Inequality operator. The method always returns false if either operand is null; otherwise, returns true or false.
ToString | (Inherited from Object)
SetConfiguration Method | Sets the crash dump configuration for all machines in the machine pool.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachinePool.CreateChildPool Method

This method creates a child machine pool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim name As String

Dim returnValue As MachinePool

returnValue = instance.CreateChildPool(name)

Syntax

Visual Basic

Public MustOverride Function CreateChildPool ( _

      `name As String _`

) As MachinePool

C#

public abstract MachinePool CreateChildPool (

      `string name`

)

Parameters

name

 The name of the pool to add to this machine pool.

Return Value

Returns MachinePool, which is the name of the machine pool that was added.

Remarks

The child Machine Pool name must not match another existing Machine Pool name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.DeleteChildPool Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim name As String

Dim returnValue As MachinePool

returnValue = instance.CreateChildPool(name)

Syntax

Visual Basic

Public MustOverride Function CreateChildPool ( _

      `name As String _`

) As MachinePool

C#

public abstract MachinePool CreateChildPool (

      `string name`

)

Parameters

name

 The name of the pool to add to this machine pool.

Return Value

Returns MachinePool, which is the name of the machine pool that was added.

Remarks

Any machines that are in this pool are moved to the default pool. This will not remove any results. However, any tests that are still outstanding will be canceled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.DeleteMachine Method

This method delete the named machine for this machine pool. The machine to be deleted must be a child machine of this pool.

WARNING

Using the MachinePool.DeleteMachine method is NOT recommended because it may leave the deleted machine in an unusable state.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim nameOfMachineToDelete As String

instance.DeleteMachine(nameOfMachineToDelete)

Syntax

Visual Basic

Public MustOverride Sub DeleteMachine ( _

      `nameOfMachineToDelete As String _`

)

C#

public abstract void DeleteMachine (

      `string nameOfMachineToDelete`

)

Parameters

nameOfMachineToDelete

 The name of the machine to delete from this machine pool.

Remarks

This will delete any test results that are associated with this machine.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Equals Method

Overload List

Name | Description
MachinePool.Equals (Object) | This method compares two MachinePool instances.
MachinePool.Equals (MachinePool) | This method compares two MachinePool instances.

Subsection Heading

Insert subsection body here.


MachinePool.Equals Method (Object)

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **MachinePool** object.

Return Value

Returns Boolean, which has a value of true if the two OSPlatforms are equal, or a value of false if they are different.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Equals Method (MachinePool)

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim otherMachinePool As MachinePool

Dim returnValue As Boolean

returnValue = instance.Equals(otherMachinePool)

Syntax

Visual Basic

Public Function Equals ( _

      `otherMachinePool As MachinePool _`

) As Boolean

C#

public bool Equals (

      `MachinePool otherMachinePool`

)

Parameters

otherMachinePool

Return Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.GetChildPools Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim returnValue As ReadOnlyCollection(Of MachinePool)

returnValue = instance.GetChildPools

Syntax

Visual Basic

Public MustOverride Function GetChildPools As ReadOnlyCollection(Of MachinePool)

C#

public abstract ReadOnlyCollection<MachinePool> GetChildPools ()

Return Value

Returns ReadOnlyCollection, which is the collection of child pools.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


GetConfiguration Method

Retrieves the crash dump configuration for all machines in the machine pool. The dump setting should be retrieved across all machines in the immediate pool. The setting is not retrieved from machines in child pools.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract void GetConfiguration(out MachinePoolCrashDumpCopyBackSetting configurationSetting);

Parameters

configurationSetting (out)

MachinePoolCrashDumpCopyBackSetting value that holds the retrieved configuration setting.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.GetHashCode Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number which is the MachineSet hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.GetMachines Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim returnValue As ReadOnlyCollection(Of Machine)

returnValue = instance.GetMachines

Syntax

Visual Basic

Public MustOverride Function GetMachines As ReadOnlyCollection(Of Machine)

C#

public abstract ReadOnlyCollection<Machine> GetMachines ()

Return Value

Returns ReadOnlyCollection, which is a collection of machines (test computers) in this machine pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.MoveMachineTo Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim machine As Machine

Dim otherPool As MachinePool

instance.MoveMachineTo(machine, otherPool)

Syntax

Visual Basic

Public MustOverride Sub MoveMachineTo ( _

      `machine As Machine, _`

      `otherPool As MachinePool _`

)

C#

public abstract void MoveMachineTo (

      `Machine machine,`

      `MachinePool otherPool`

)

Parameters

machine

      A machine to move from this pool.

otherPool

      The destination pool to move the machine to.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Equality Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As MachinePool

Dim second As MachinePool

Dim returnValue As Boolean

returnValue = (first = second)

Syntax

Visual Basic

Public Shared Operator = ( _

      `first As MachinePool, _`

      `second As MachinePool _`

) As Boolean

C#

public static bool operator == (

      `MachinePool first,`

      `MachinePool second`

)

Parameters

first

      The first value to compare against.

second

      The second value to compare against.

Return Value

true if the objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Inequality Method

This method acts as an Inequality operator. The method always returns false if either operand is null; otherwise, returns true or false.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As MachinePool

Dim second As MachinePool

Dim returnValue As Boolean

returnValue = (first <> second)

Syntax

Visual Basic

Public Shared Operator <> ( _

      `first As MachinePool, _`

      `second As MachinePool _`

) As Boolean

C#

public static bool operator != (

      `MachinePool first,`

      `MachinePool second`

)

Parameters

first

      The first value to compare against.

second

      The second value to compare against.

Return Value

true if the objects are not equal, or false if the objects are the same or if either object is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.SetConfiguration Method

Sets the crash dump configuration for all machines in the machine pool. The dump setting should be set across all machines in the immediate pool. The setting is not set on machines in child pools.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract void SetConfiguration(MachinePoolCrashDumpCopyBackSetting configurationSetting);

Parameters

configurationSetting

MachinePoolCrashDumpCopyBackSetting value that defines the configuration setting.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool Properties

Public Properties

Name | Description
DefaultPool | This property represents the default pool.
Executable | This property represents a value indicating whether this pool can be used to run tests.
Name | This property represents the name of this machine pool.
Path | This property represents the machine pool path.
RootPool | This property represents a value indicating whether this pool can be used to run tests.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


MachinePool.DefaultPool Property

This property represents the default pool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim value As MachinePool

value = instance.DefaultPool

Syntax

Visual Basic

Public MustOverride ReadOnly Property DefaultPool As MachinePool

C#

public abstract MachinePool DefaultPool { get; }

Return Value

Returns MachinePool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Executable Property

This property represents a value indicating whether this pool can be used to run tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim value As Boolean

value = instance.Executable

Syntax

Visual Basic

Public MustOverride ReadOnly Property Executable As Boolean

C#

public abstract bool Executable { get; }

Return Value

Returns Boolean.

Remarks

Tests cannot be scheduled on a machine that resides in certain reserved Machine Pools. This value indicates if tests can be run on any machines in this machine pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Name Property

This property represents the name of this Machine Pool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic

Public MustOverride Property Name As String

C#

public abstract string Name { get; set; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.Path Property

This property represents the machine pool path.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim value As String

value = instance.Path

Syntax

Visual Basic

Public MustOverride ReadOnly Property Path As String

C#

public abstract string Path { get; }

Property Value

Returns String.

Remarks

The path of a Machine Pool includes all the Machine Pools from the root pool to the current pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePool.RootPool Property

This property represents a value indicating whether this pool can be used to run tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePool

Dim value As MachinePool

value = instance.RootPool

Syntax

Visual Basic

Public MustOverride ReadOnly Property RootPool As MachinePool

C#

public abstract MachinePool RootPool { get; }

Property Value

Returns MachinePool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


CrashDumpConfigurationSettingName Enumeration

Dimension name for crash dump setting.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Const CrashDumpConfigurationSettingName As String = "WHCK\CrashDumpControllerSetting"

C#

public const string CrashDumpConfigurationSettingName = "WHCK\\CrashDumpControllerSetting";


MachinePoolCrashDumpCopyBackSetting Enumeration

Represents the crash dump type setting for a MachinePool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public enum MachinePoolCrashDumpCopyBackSetting

Members

Member Name | Description
Unknown | The setting is non-uniform across the machine pool. This requires the user to explicitly choose a setting.
Disable | Crash dump copy back is disabled.
Full | Machines in the pool will write out and copy back a full crash dump.
Kernel | Machines in the pool will write out and copy back only the kernel crash dump.
Mini | Machines in the pool will write out and copy back only the mini dump.


MachineProperty Class

Represents a property or attribute or dimension of a machine.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineProperty

Syntax

Visual Basic

Public Class MachineProperty

C#

public class MachineProperty

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.MachineProperty**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineProperty Members

The following tables list the members exposed by the MachineProperty type.

Public Properties

Name | Description
Name | This parameter the name of this MachineProperty object.
PropertyType | This property represents an internal value for the type of this MachineProperty object.
Value | This parameter represents the Value of this MachineProperty object.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineProperty Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineProperty Properties

Public Properties

Name | Description
Name | This parameter the name of this MachineProperty object.
PropertyType | This property represents an internal value for the type of this MachineProperty object.
Value | This parameter represents the Value of this MachineProperty object.


MachineProperty.Name Property

This property represents the name of this machine property.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineProperty

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public ReadOnly Property Name As String

C#

public string Name { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineProperty.PropertyType Property

This property represents an internal value for the type of this MachineProperty object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineProperty

Dim value As MachinePropertyType

value = instance.PropertyType

Syntax

Visual Basic

Public ReadOnly Property PropertyType As MachinePropertyType

C#

public MachinePropertyType PropertyType { get; }

Return Value

Returns MachinePropertyType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineProperty.Value Property

This parameter represents the Value of this MachineProperty object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineProperty

Dim value As String

value = instance.Value

Syntax

Visual Basic

Public ReadOnly Property Value As String

C#

public string Value { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachinePropertyType Enumeration

A flag value that indicates whether this machine property is a settable property, or a Non-settable query (for example, ProcessorSpeed).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachinePropertyType

Syntax

Visual Basic

Public Enumeration MachinePropertyType

C#

public enum MachinePropertyType

Members

Member Name | Description
Query | This Machine Property is a query against the machine itself, and is not settable or configurable.
Settable | This flag indicates that a machine property is settable.


MachineRole Class

Represents a specific role used in a logical machine set.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Syntax

Visual Basic

Public Class MachineRole

C#

public class MachineRole

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.MachineRole**

Remarks

MachineRole is used in a logical machine set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole Members

The following table lists the members exposed by the Machine type.

Public Properties

Name | Description
Constraints | This property represents the constraints needed for this role.
Maximum | This property represents the maximum number of machines needed for this role.
Minimum | This property represents the minimum number of machines needed for this role.
Name | This property represents the Name of this role.
Primary | This property represents a value indicating whether this is the primary role.
Set | This property represents the Machine set that contains this role.

Public Methods

Name | Description
AddMachine | This method adds a machine (test computer) to this role.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. This method retrieves (creates) a hash code for a MachineRole object.
GetMachines | This method retrieves all of the machines assigned to this role.
GetType | (Inherited from Object)
IsValidMachine | This method determines if the machine is appropriate for this role.
IsValidRole | This method checks to see if the other machine role is sufficient to enable this machine role.
Equality | This method acts as an Equality operator which always returns a value of False if either operand is null, otherwise returns True or False.
Inequality | This method acts as an Inequality operator which always returns a value of False if either operand is null, otherwise returns True or False.
ToString | (Inherited from Object)
RemoveMachine | This method removes a machine from the machine role.
Validate | This method validates that this machine role is correct and complete.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineRole Methods

Public Methods

Name | Description
AddMachine | This method adds a machine (test computer) to this role.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. This method retrieves (creates) a hash code for a MachineRole object.
GetMachines | This method retrieves all of the machines assigned to this role.
GetType | (Inherited from Object)
IsValidMachine | This method determines if the machine is appropriate for this role.
IsValidRole | This method checks to see if the other machine role is sufficient to enable this machine role.
Equality | This method acts as an Equality operator which always returns a value of False if either operand is null, otherwise returns True or False.
Inequality | This method acts as an Inequality operator which always returns a value of False if either operand is null, otherwise returns True or False.
ToString | (Inherited from Object)
RemoveMachine | This method removes a machine from the machine role.
Validate | This method validates that this machine role is correct and complete.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineRole.AddMachine Method

This method adds a machine (test computer) to this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim machineToAdd As Machine

instance.AddMachine(machineToAdd)

Syntax

Visual Basic

Public Sub AddMachine ( _

      `machineToAdd As Machine _`

)

C#

public void AddMachine (

      `Machine machineToAdd`

)

Parameters

machineToAdd

 The machine (test computer) to add to this role.

Remarks

An exception is thrown when the machine is not valid for this role, but only if the parameter throwOnError is true. The following are the cases where the machine would not be appropriate:

  • Machine is from a different Machine Pool.

  • Machine has already been added.

  • Maximum number of Machines for the role has been reached.

  • The Machine has a dimension value that is out of the expected range.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Equals Method

Overload List

Name | Description
MachineRole.Equals (Object) | This method compares two MachineRole instances.
MachineRole.Equals (MachineRole) | This method compares two MachineRole instances.


MachineRole.Equals Method (Object)

This method compares two MachineRole instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **MachineRole** object.

Return Value

Returns Boolean, which has a value of true if the two objects are equal, or a value of false if they are different.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Equals Method (MachineRole)

This method compares two MachineRole instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim otherMachineRole As MachineRole

Dim returnValue As Boolean

returnValue = instance.Equals(otherMachineRole)

Syntax

Visual Basic

Public Function Equals ( _

      `otherMachineRole As MachineRole _`

) As Boolean

C#

public bool Equals (

      `MachineRole otherMachineRole`

)

Parameters

otherMachineRole

 The **MachineRole** object to compare against this **MachineRole** object.

Return Value

Returns Boolean, which has a value of true if the two objects are equal, or a value of false if they are different.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.GetHashCode Method

This method retrieves (creates) a hash code for a MachineRole object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number which is the MachineRole hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.GetMachines Method

This method retrieves all of the machines assigned to this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim returnValue As ReadOnlyCollection(Of Machine)

returnValue = instance.GetMachines

Syntax

Visual Basic

Public Function GetMachines As ReadOnlyCollection(Of Machine)

C#

public ReadOnlyCollection<Machine> GetMachines ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.IsValidMachine Method

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim machineToAdd As Machine

Dim throwOnError As Boolean

Dim returnValue As Boolean

returnValue = instance.IsValidMachine(machineToAdd, throwOnError)

Syntax

Visual Basic

Public Function IsValidMachine ( _

      `machineToAdd As Machine, _`

      `throwOnError As Boolean _`

) As Boolean

C#

public bool IsValidMachine (

      `Machine machineToAdd,`

      `bool throwOnError`

)

Parameters

machineToAdd

      The machine (test computer) to test against.

throwOnError

      A flag determining if this function should throw exceptions.

Return Value

true if the machine (test computer) is appropriate for this machine role; otherwise, false.

Remarks

An exception is thrown when the machineToAdd parameter represents a test computer that is not valid for this role, but only if the throwOnError flag is set to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.IsValidRole Method

This method checks to see if the other machine role is sufficient to enable this machine role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim otherMachineRole As MachineRole

Dim returnValue As Boolean

returnValue = instance.IsValidRole(otherMachineRole)

Syntax

Visual Basic

Public Function IsValidRole ( _

      `otherMachineRole As MachineRole _`

) As Boolean

C#

public bool IsValidRole (

      `MachineRole otherMachineRole`

)

Parameters

otherMachineRole

      The **MachineRole** object to compare against this **MachineRole** object.

Return Value

true if the two objects being compared are the same; otherwise, false.

Remarks

An exception is thrown when the otherMachineRole parameter is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.RemoveMachine Method

This method removes a machine (test computer) from the machine role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim machineToRemove As Machine

instance.RemoveMachine(machineToRemove)

Syntax

Visual Basic

Public Sub RemoveMachine(ByVal machineToRemove As Machine)
    If (machineToRemove <> Nothing) Then
        If (Me.machines.Contains(machineToRemove)) Then
            Me.machines.Remove(machineToRemove)
            Return
        Else
            Throw ScheduleException.BuildException("MachineRole::RemoveMachine() - Instance of Machine does not exist in the machine list.")
        End If
    Else
        Throw New ArgumentNullException("machineToRemove")
    End If
End Sub

C#

public void RemoveMachine(Machine machineToRemove)
{
    if (machineToRemove != null)
    {
        if (this.machines.Contains(machineToRemove))
        {
            this.machines.Remove(machineToRemove);
            return;
        }
        else
        {
            throw ScheduleException.BuildException("MachineRole::RemoveMachine() - Instance of Machine does not exist in the machine list.");
        }
    }
    else
    {
        throw new ArgumentNullException("machineToRemove");
    }
}

Parameters

machineToRemove

 The machine (test computer) to remove.

Remarks

An exception is thrown if

  • The machineToRemove parameter is null.

  • The machineToRemove does not exist in the current machine list.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Validate Method

This method validates that this machine role is correct and complete.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim returnValue As Boolean

returnValue = instance.Validate

Syntax

Visual Basic

Public Function Validate As Boolean

C#

public bool Validate ()

Return Value

true if this machine role is complete and correct; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Equality Method

This method acts as an Equality operator which always returns a value of False if either operand is null, otherwise returns True or False.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As MachineRole

Dim second As MachineRole

Dim returnValue As Boolean

returnValue = (first = second)

Syntax

Visual Basic

Public Shared Operator = ( _

      `first As MachineRole, _`

      `second As MachineRole _`

) As Boolean

C#

public static bool operator == (

      `MachineRole first,`

      `MachineRole second`

)

Parameters

first

      The first value to compare against.

second

      The second value to compare against.

Return Value

true if the objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Inequality Method

This method acts as an Inequality operator. The method always returns false if either operand is null; otherwise, returns true or false.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As MachineRole

Dim second As MachineRole

Dim returnValue As Boolean

returnValue = (first <> second)

Syntax

Visual Basic

Public Shared Operator <> ( _

      `first As MachineRole, _`

      `second As MachineRole _`

) As Boolean

C#

public static bool operator != (

      `MachineRole first,`

      `MachineRole second`

)

Parameters

first

      The first value to compare against.

second

      The second value to compare against.

Return Value

true if the objects are not equal, or false if the objects are the same or if either object is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole Properties

Public Properties

Name | Description
Constraints | This property represents the constraints needed for this role.
Maximum | This property represents the maximum number of machines needed for this role.
Minimum | This property represents the minimum number of machines needed for this role.
Name | This property represents the Name of this role.
Primary | This property represents a value indicating whether this is the primary role.
Set | This property represents the Machine set that contains this role.
Test | This property represents the test associated with this role.


MachineRole.Constraints Property

This property represents the Constraints needed for this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim value As ReadOnlyCollection(Of RoleConstraint)

value = instance.Constraints

Syntax

Visual Basic

Public ReadOnly Property Constraints As ReadOnlyCollection(Of RoleConstraint)

C#

public ReadOnlyCollection<RoleConstraint> Constraints { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Maximum Property

This property represents the maximum number of machines needed for this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim value As Integer

value = instance.Maximum

Syntax

Visual Basic

Public ReadOnly Property Maximum As Integer

C#

public int Maximum { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Minimum Property

This property represents the minimum number of machines needed for this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim value As Integer

value = instance.Minimum

Syntax

Visual Basic

Public ReadOnly Property Minimum As Integer

C#

public int Minimum { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Name Property

This property represents the name of this machine role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public ReadOnly Property Name As String

C#

public string Name { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Primary Property

This property represents a value indicating whether this is the primary role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim value As Boolean

value = instance.Primary

Syntax

Visual Basic

Public ReadOnly Property Primary As Boolean

C#

public bool Primary { get; }

Return Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineRole.Set Property

This property represents the machine set that contains this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineRole

Dim value As MachineSet

value = instance.Set

Syntax

Visual Basic

Public Property Set As MachineSet

C#

public MachineSet Set { get; }

Property Value

Returns MachineSet.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test Property

This property represents the test associated with this role.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public Test Test { get; }

Property Value

Returns Test.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet Class

This class defines a list of machines (test computers) and their roles in a machine set.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Syntax

Visual Basic

Public Class MachineSet

C#

public class MachineSet

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.MachineSet**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet Members

The following table lists the members exposed by the MachineSet type.

Public Properties

Name | Description
Roles | This property represents the list of roles for this machine set.

Public Methods

Name | Description
ApplyMachineDimensions | This method applies the machine roles dimension to all of the machines in the roles.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. This method creates a unique hash code for a MachineSet object.
GetType | (Inherited from Object)
IsValid | This method checks to see if the MachineSet is sufficient to enable this machine set.
Equality | This method provides an Equality operator between two MachineSet objects.
Inequality | This method provides an Inequality operator between two MachineSet objects.
ToString | (Inherited from Object)
Validate | This method checks to see if the MachineRole classes have been filled out correctly for a MachineSet object.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineSet Methods

Public Methods

Name | Description
ApplyMachineDimensions | This method applies the machine roles dimension to all of the machines in the roles.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. This method creates a unique hash code for a MachineSet object.
GetType | (Inherited from Object)
IsValid | This method checks to see if the MachineSet is sufficient to enable this machine set.
Equality | This method provides an Equality operator between two MachineSet objects.
Inequality | This method provides an Inequality operator between two MachineSet objects.
ToString | (Inherited from Object)
Validate | This method checks to see if the MachineRole classes have been filled out correctly for a MachineSet object.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


MachineSet.ApplyMachineDimensions Method

This method applies the machine roles dimension to all of the machines in the roles.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

instance.ApplyMachineDimensions

Syntax

Visual Basic

Public Sub ApplyMachineDimensions

C#

public void ApplyMachineDimensions ()

Remarks

This method will first call the Validate() method. If Validate() fails, this will throw an exception and then it will attempt to set the machine dimensions for these roles.

An exception is thrown when there are validation errors.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.Equals Method

Overload List

Name | Description
MachineSet.Equals (Object) | This method compares two MachineSet instances.
MachineSet.Equals (MachineSet) | This method compares two MachineSet instances.


MachineSet.Equals Method (Object)

This method compares two MachineSet instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **MachineSet** object.

Return Value

true if the two objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.Equals Method (MachineSet)

This method compares two MachineSet instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Dim otherMachineSet As MachineSet

Dim returnValue As Boolean

returnValue = instance.Equals(otherMachineSet)

Syntax

Visual Basic

Public Function Equals ( _

      `otherMachineSet As MachineSet _`

) As Boolean

C#

public bool Equals (

      `MachineSet otherMachineSet`

)

Parameters

otherMachineSet

 The **MachineSet** object to compare against.

Return Value

true if the two objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.GetHashCode Method

This method creates a hash code for a MachineSet object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is the MachineSet hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.IsValid Method

This method checks to see if the specified MachineSet is sufficient to enable this machine set.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Dim otherMachineSet As MachineSet

Dim returnValue As Boolean

returnValue = instance.IsValid(otherMachineSet)

Syntax

Visual Basic

Public Function IsValid ( _

      `otherMachineSet As MachineSet _`

) As Boolean

C#

public bool IsValid (

      `MachineSet otherMachineSet`

)

Parameters

otherMachineSet

      The **MachineSet** object to compare against this **MachineSet** object.

Return Value

true if the two objects being compared are the same; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.Equality Method

This method provides an Equality operator between two MachineSet objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As MachineSet

Dim second As MachineSet

Dim returnValue As Boolean

returnValue = (first = second)

Syntax

Visual Basic

Public Shared Operator = ( _

      `first As MachineSet, _`

      `second As MachineSet _`

) As Boolean

C#

public static bool operator == (

      `MachineSet first,`

      `MachineSet second`

)

Parameters

first

 The first **MachineSet** object to compare against.

second

 The second **MachineSet** object to compare against.

Return Value

true if the MachineSet objects are identical; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.Inequality Method

This method provides an Inequality operator between two MachineSet objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As MachineSet

Dim second As MachineSet

Dim returnValue As Boolean

returnValue = (first <> second)

Syntax

Visual Basic

Public Shared Operator <> ( _

      `first As MachineSet, _`

      `second As MachineSet _`

) As Boolean

C#

public static bool operator != (

      `MachineSet first,`

      `MachineSet second`

)

Parameters

first

      The first **MachineSet** object to compare against.

second

      The second **MachineSet** object to compare against.

Return Value

true if the objects are not equal, or false if the objects are the same or if either object is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet.Validate Method

This method checks to see if the MachineRole instances have been filled out correctly for a MachineSet object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Dim returnValue As Boolean

returnValue = instance.Validate

Syntax

Visual Basic

Public Function Validate As Boolean

C#

public bool Validate ()

Return Value

true if the MachineRole instances are complete and correct; otherwise, false.

Remarks

This function can throw an exception if validation fails.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineSet Properties

Public Properties

Name | Description
Roles | This property represents the list of roles for a machine set.


MachineSet.Roles Property

This property represents the list of roles for this machine set.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineSet

Dim value As ReadOnlyCollection(Of MachineRole)

value = instance.Roles

Syntax

Visual Basic

Public ReadOnly Property Roles As ReadOnlyCollection(Of MachineRole)

C#

public ReadOnlyCollection<MachineRole> Roles { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


MachineStatus Enumeration

This enumeration represents the states that a machine can be in at any point in time.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As MachineStatus

Syntax

Visual Basic

Public Enumeration MachineStatus

C#

public enum MachineStatus

Members

Member Name | Description
Initializing | This enum value describes the state of the test computer as initializing.
NotReady | This enum value describes the state of the test computer as "not ready". You cannot run tests on a test computer that is in this state.
Ready | This enum value describes the state of the test computer as "ready".
Running | This enum value describes the state of the test computer as "in the running state" (that is, a test is running).


NotificationBase Class

[This content is not available in this preliminary release.]

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.NotificationBase**

Derived Classes

Class | Description
Machine Class | This class represents an abstract resource that a logo test can be scheduled to run against.
MachinePool Class | This class represents an abstract pool of machines that are grouped together based on a user intention.
ProductInstance Class | This class represents a piece of hardware that has been detected on a test computer and identified by set of targets.
Project Class | This class represents a Project object which is created in the database for each project the user initiates.
Target Class | This class represents a single test target that can be detected on a system (a piece of hardware, a driver, and so on).
TargetFamily Class | This class represents a group of test targets that correspond to WLP POLICY-0004.
Task Class | This class represents the individual tasks that are run as part of certification tests.
Test Class | This abstract class represents a certification test.
TestResult Class | This class represents information that is obtained as a result of running a certification test.


NotificationBase Members

The following tables list the members exposed by the NotificationBase type.

Protected Properties

Name | Description
LockObject |

Public Methods

Name | Description
Equals | This function provides value equality functionality for this object.
GetHashCode | Provides a hash code for the project object.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


NotificationBase Methods

Public Methods

Name | Description
Equals | This function provides value equality functionality for this object.
GetHashCode | Provides a hash code for the project object.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


NotificationBase.Equals Method

Overload List

Name | Description
Equals (NotificationBase) | This function provides value equality functionality for this object.
Equals (object) | Overrides the Equals function to provide value equality functionality for this object.


NotificationBase.Equals Method (object)

This function overrides the Equals function to provide value equality functionality for this object.

Syntax

C#

public override bool Equals (

      `object other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


NotificationBase.Equals Method (NotificationBase)

This function provides value equality functionality for this object.

Syntax

C#

public bool Equals (

      `NotificationBase other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


NotificationBase.GetHashCode Method

Provides a hash code for the project object.

Syntax

C#

public override int GetHashCode ()

Return Value

Returns a unique integer that represents the project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


NotificationBase Properties

Protected Properties

Name | Description
LockObject |


NotificationBase.LockObject Property

This property represents the object that is used for locking.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Protected ReadOnly Property LockObject As Object

C#

protected object LockObject { get; }

Return Value

Returns Object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform Class

This class represents the operating system architecture and platform information.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Syntax

Visual Basic

<DataContractAttribute> _

Public Class OSPlatform

C#

[DataContractAttribute]

public class OSPlatform

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.OSPlatform**

Remarks

OS Platform is a combination of the architecture and the Operating System SKU.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform Members

The following table lists the members exposed by the OSPlatform type.

Public Properties

Name | Description
Architecture | This property represents the CPU architecture (for example, x86, x64, or ARM).
Code | This property represents the Portal ID for this platform.
Description | This property represents the description for this platform.
MajorVersion | This property represents the major version of this platform.
MinorVersion | This property represents the minor version of this platform.
Name | This property represents the name of the platform (for example, Windows 7).

Public Methods

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. This method creates a unique hash code for a MachineSet object.
GetType | (Inherited from Object)
Equality | This method provides an Equality operator between two MachineSet objects.
Inequality | This method provides an Inequality operator between two MachineSet objects.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


OSPlatform Methods

Public Methods

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. This method creates a unique hash code for a MachineSet object.
GetType | (Inherited from Object)
Equality | This method provides an Equality operator between two MachineSet objects.
Inequality | This method provides an Inequality operator between two MachineSet objects.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


OSPlatform.Equals Method

Overload List

Name | Description
OSPlatform.Equals (Object) | This method compares two OSPlatform instances.
OSPlatform.Equals (MachineSet) | This method compares two OSPlatform instances.


OSPlatform.Equals Method (Object)

This method compares two OSPlatform instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **OSPlatform** object.

Return Value

true if the two objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.Equals Method (OSPlatform)

This method compares two OSPlatform instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim otherPlatform As OSPlatform

Dim returnValue As Boolean

returnValue = instance.Equals(otherPlatform)

Syntax

Visual Basic

Public Function Equals ( _

      `otherPlatform As OSPlatform _`

) As Boolean

C#

public bool Equals (

      `OSPlatform otherPlatform`

)

Parameters

otherMachineSet

 The **OSPlatform** object to compare against.

Return Value

true if the two objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.GetHashCode Method

This method creates a hash code for an OSPlatform object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is the OSPlatform hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.Equality Method

This method provides an Equality operator between two OSPlatform objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As OSPlatform

Dim second As OSPlatform

Dim returnValue As Boolean

returnValue = (first = second)

Syntax

Visual Basic

Public Shared Operator = ( _

      `first As OSPlatform, _`

      `second As OSPlatform _`

) As Boolean

C#

public static bool operator == (

      `OSPlatform first,`

      `OSPlatform second`

)

Parameters

first

 The first **OSPlatform** object to compare against.

second

 The second **OSPlatform** object to compare against.

Return Value

true if the OSPlatform objects are identical; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.Inequality Method

This method provides an Inequality operator between two OSPlatform objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As OSPlatform

Dim second As OSPlatform

Dim returnValue As Boolean

returnValue = (first <> second)

Syntax

Visual Basic

Public Shared Operator <> ( _

      `first As OSPlatform, _`

      `second As OSPlatform _`

) As Boolean

C#

public static bool operator != (

      `OSPlatform first,`

      `OSPlatform second`

)

Parameters

first

      The first **OSPlatform** object to compare against.

second

      The second **OSPlatform** object to compare against.

Return Value

true if the objects are not equal, or false if the objects are the same or if either object is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform Properties

Public Properties

Name | Description
Architecture | This property represents the CPU architecture (for example, x86, x64, or ARM).
Code | This property represents the Portal ID for this platform.
CorePackageComposition | This property represents the core package composition for this platform.
Description | This property represents the description for this platform.
MajorVersion | This property represents the major version of this platform.
MinorVersion | This property represents the minor version of this platform.
Name | This property represents the name of the platform (for example, Windows 7).
Release | This property represents the release ID for this platform.


OSPlatform.Architecture Property

This property represents the CPU architecture (for example, x86, x64, or ARM).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim value As CpuArchitecture

value = instance.Architecture

instance.Architecture = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Architecture As CpuArchitecture

C#

[DataMemberAttribute]

public CpuArchitecture Architecture { get; protected set; }

Return Value

Returns CpuArchitecture.

Remarks

See SYSTEM_INFO.wProcessorArchitecture in Win32 documentation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.Code Property

This property represents the Portal ID for this platform.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim value As String

value = instance.Code

instance.Code = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Code As String

C#

[DataMemberAttribute]

public string Code { get; protected set; }

Return Value

Returns String.

Remarks

Code is an identifier used by submission processing.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


CorePackageComposition Property

This property represents the core package composition for this platform.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public string CorePackageComposition { get; }

Return Value

Returns string.

Remarks

CorePackageComposition can be null if the platform is a legacy platform.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.Description Property

This property represents the description for this platform.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim value As String

value = instance.Description

instance.Description = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Description As String

C#

[DataMemberAttribute]

public string Description { get; protected set; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.MajorVersion Property

This property represents the major version of this platform.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim value As Integer

value = instance.MajorVersion

instance.MajorVersion = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property MajorVersion As Integer

C#

[DataMemberAttribute]

public int MajorVersion { get; protected set; }

Return Value

Returns Int32.

Remarks

See OSVERSIONINFOEX.dwMajorVersion in Win32 documentation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.MinorVersion Property

This property represents the minor version of this platform.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim value As Integer

value = instance.MinorVersion

instance.MinorVersion= value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property MinorVersion As Integer

C#

[DataMemberAttribute]

public int MinorVersion { get; protected set; }

Return Value

Returns Int32.

Remarks

See OSVERSIONINFOEX.dwMinorVersion in Win32 documentation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatform.Name Property

This property represents the name of the platform (for example, Windows 7).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As OSPlatform

Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Name As String

C#

[DataMemberAttribute]

public string Name { get; protected set; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Release Property

This property represents the release ID for this platform.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public string Release { get; }

Return Value

Returns string.

Remarks

Release can be null if the platform is a legacy platform.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ParameterSetAsDefault Enumeration

This is used as a flag to determine if a test run parameter should be set as a default for future test runs.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ParameterSetAsDefault

Syntax

Visual Basic

Public Enumeration ParameterSetAsDefault

C#

public enum ParameterSetAsDefault

Members

Member Name | Description
DoNotSetAsDefault | This value represents a test run parameter that will only be implemented for a specific test run. The test run parameter will not be set as the default value for future test runs.
SetAsDefault | This value represents a test run parameter set as a default for future test runs.


Playlist Class

Represents a Playlist file as a .NET Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[Serializable]

public class Playlist

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.Playlist**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Playlist Members

The following tables list the members exposed by the Playlist Class.

Public Properties

Name | Description
Id | The Playlist Id.
Name | The Playlist Name.
TestSet | The list of PlaylistTests.
Version | The Playlist Version.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Playlist Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Playlist Properties

Public Properties

Name | Description
Id | The Playlist Id.
Name | The Playlist Name.
TestSet | The list of PlaylistTests.
Version | The Playlist Version.


Playlist.Id Property

The Playlist Id.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlAttribute]

public string Id

Property Value

Gets or sets the Playlist Id.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Playlist.Name Property

The Playlist Name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public string Name

Property Value

Gets or sets the Playlist Name.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Playlist.TestSet Property

The list of PlaylistTests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlElement("Test")]

public PlaylistTest[] TestSet

Property Value

Gets or sets the list of PlaylistTests.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Playlist.Version Property

The Playlist Version.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlAttribute]

public string Version

Property Value

Gets or sets the Playlist Version.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistException Class

This exception class is defined to handle playlist specific errors.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[Serializable]

public class PlaylistException

Inheritance Hierarchy

System.Exception

 **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.PlaylistException**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistException Members

.

The following tables list the members exposed by the PlaylistException Class.

Public Constructors

Name | Description
PlaylistException Constructor | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException |
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


PlaylistException Constructor

Overload List

Name | Description
PlaylistException Constructor (string) | Initializes a new instance of the PlaylistException Class.
PlaylistException Constructor (string, Exception) | Initializes a new instance of the PlaylistException Class.
PlaylistException Constructor (SerializationInfo, StreamingContext) | Initializes a new instance of the PlaylistException Class.


PlaylistException Constructor (string)

Initializes a new instance of the PlaylistException Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PlaylistException (

      `string message`

)

Parameters

message

A string that represents the exception message.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistException Constructor (string, Exception)

Initializes a new instance of the PlaylistException Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PlaylistException (

      `string message,`

      `Exception except`

)

Parameters

message

A string that represents the exception message.

except

An exception object.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PlaylistException Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PlaylistException (

      `SerializationInfo serialInfo,`

      ` StreamingContext streamCont`

)

Parameters

serialInfo

A SerializationInfo object.

streamCont

A StreamingContext object.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistFeature Class

Represents a test element inside of a Playlist file.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[Serializable]

public class PlaylistFeature

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.PlaylistFeature**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistFeature Members

The following tables list the members exposed by the PlaylistFeature Class.

Public Properties

Name | Description
Name | The Feature name.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PlaylistFeature.Name Property

The Feature name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlAttribute]

public string Name

Property Value

Gets or sets the Feature name.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistInfo Class

Represents information for a playlist

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public class PlaylistInfo

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

PlaylistInfo Members


PlaylistInfo Members

Public Properties

Name | Description
Id | Playlist ID
Name | Playlist name
Version | Playlist version

Public Methods

Name | Description
Equals(object) | Determines whether two playlist info objects are equal.
Equals(PlaylistInfo) | Determines whether two playlist info objects are equal.
GetHashCode | Returns the hash code for this object.


PlaylistManager Class

Class that manages all Playlist interactions with a particular Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public class PlaylistManager

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.PlaylistManager**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager Members

The following tables list the members exposed by the PlaylistManager Class.

Public Constructor

Name | Description
PlaylistManager | Initializes a new instance of the PlaylistManager Class.)

Public Methods

Name | Description
CreatePlaylist | Creates a Playlist file from this PlaylistManager's Project instance.
DeserializePlaylist | Deserializes a playlist file into a Playlist object.
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetMissingTests | Uses the given Playlist to find tests for each Target in the current PlaylistManager's Project that should be present but are not. Warning This method is being deprecated.
GetTestsFromProjectThatMatchPlaylist | Retrieves the test from the current PlaylistManager's Project that match those in the Playlist.
GetTestsInProjectNotInPlaylist | Finds the tests that are in the PlaylistManager's Project but not in the given Playlist. Warning This method is being deprecated.
GetType | (Inherited from Object)
IsPlaylistLoaded | Returns whether this PlaylistManager's Project has a playlist applied.
LoadPlaylist | Loads the tests from a Playlist into this PlaylistManager's Project.
ToString | (Inherited from Object)
UnloadPlaylist | Unloads the current playlist from this Project.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PlaylistManager Constructor

This constructor initializes a new instance of the PlaylistManager Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PlaylistManager(

      `Project project`

)

Parameters

project

The Project to support with playlist functionality


PlaylistManager Methods

Public Methods

Name | Description
CreatePlaylist | Creates a Playlist file from this PlaylistManager's Project instance.
DeserializePlaylist | Deserializes a playlist file into a Playlist object.
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetMissingTests | Uses the given Playlist to find tests for each Target in the current PlaylistManager's Project that should be present but are not. Warning This method is being deprecated.
GetTestsFromProjectThatMatchPlaylist | Retrieves the test from the current PlaylistManager's Project that match those in the Playlist.
GetTestsInProjectNotInPlaylist | Finds the tests that are in the PlaylistManager's Project but not in the given Playlist. Warning This method is being deprecated.
GetType | (Inherited from Object)
IsPlaylistLoaded | Returns whether this PlaylistManager's Project has a playlist applied.
LoadPlaylist | Loads the tests from a Playlist into this PlaylistManager's Project.
ToString | (Inherited from Object)
UnloadPlaylist | Unloads the current playlist from this Project.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PlaylistManager.CreatePlaylist Method

Creates a Playlist file from this PlaylistManager's Project instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public void CreatePlaylist (

      `string playlistPath`

)

Parameters

playlistPath

 Full path to the file to create.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager.DeserializePlaylist Method

Deserializes a playlist file into a Playlist object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static Playlist DeserializePlaylist (

      `string playlistImportPath`

)

Parameters

playlistImportPath

 Full path to the playlist file

Return Value

Playlist

When the given Playlist file cannot be found a System.IO.FileNotFoundException is returned. When the given path is empty or has invalid characters, a System.ArgumentException is returned. When the given Playlist file does not conform to the schema, a PlaylistException is returned.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager.GetMissingTests Method

WARNING

This method is being deprecated.

Uses the given Playlist to find tests for each Target in the current PlaylistManager's Project that should be present but are not.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public Dictionary<Target, List<PlaylistTest>> GetMissingTests (

      `Playlist playlist`

)

Parameters

playlist

The Playlist for which missing tests will be found.

Return Value

Dictionary<Target, List<PlaylistTest>>

A dictionary containing a list of missing tests for each Target in the PlaylistManager's Project.

Remarks

Tests are determined to be missing if they have features that match the features of a Target, but the Test itself does not exist for the Target. This functionality should only be used in conjunction with official Playlist files for the Compat program.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager.GetTestsFromProjectThatMatchPlaylist Method

Retrieves the test from the current PlaylistManager's Project that match those in the Playlist.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public List<Test> GetTestsFromProjectThatMatchPlaylist (

      `Playlist playlist`

)

Parameters

playlist

Contains the list of tests that will be searched for in the Project

Return Value

List<Test>

The list of tests from the current PlaylistManager's Project that match the tests in the Playlist.

Remarks

For a test to be retrieved from the PlaylistManager's Project, the same test must be present in the playlist and that test must have a matching Feature with a Target in the PlaylistManager's Project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager.GetTestsInProjectNotInPlaylist Method

WARNING

This method is being deprecated.

Finds the tests that are in the PlaylistManager's Project but not in the given Playlist.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public List<Test> GetTestsInProjectNotInPlaylist (

      `string playlistPath`

)

Parameters

playlistPath

Path to the playlist file.

Return Value

List<Test>

List of tests in thePlaylistManager's Project but not the Playlist.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


IsPlaylistLoaded Method

[Some information relates to pre-released product which may be substantially modified before it's commercially released. Microsoft makes no warranties, express or implied, with respect to the information provided here.]

Returns whether this PlaylistManager's Project has a playlist applied.

It is recommended to call this method before calling LoadPlaylist(string) or UnloadPlaylist.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public bool IsPlaylistLoaded()

Return Value

true if a playlist has been loaded. Otherwise, false.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager.LoadPlaylist Method

Overload List

Name | Description
LoadPlaylist Method (string) | Loads the tests from a Playlist into this PlaylistManager's Project.
LoadPlaylist Method (string, bool, bool) | Loads the tests from a Playlist into this PlaylistManager's Project. Warning This overload is being deprecated. The additional parameter options are no longer supported. Please use LoadPlaylist(string playlistPath)


PlaylistManager.LoadPlaylist Method (string)

Loads the tests from a Playlist into this PlaylistManager's Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public List<Guid> LoadPlaylist (

      `string playlistPath`

)

Parameters

playlistPath

Full path to Playlist file. The path does not have to be cleaned/validated before passing to this method.

Return Value

List<Guid>

Guids for tests that could not be added because they could not be found.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistManager.LoadPlaylist Method (string, bool, bool)

WARNING

This overload is being deprecated. The additional parameter options are no longer supported. Please use LoadPlaylist(string playlistPath).

Loads the tests from a Playlist into this PlaylistManager's Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public List<Guid> LoadPlaylist (

      `string playlistPath`

      `bool removeExistingTestsNotInPlaylist`

      `bool disableFeatureDetection`

)

Parameters

playlistPath

Full path to Playlist file. The path does not have to be cleaned/validated before passing to this method.

removeExistingTestsNotInPlaylist

Specifies whether tests not in the Playlist but in the PlaylistManager's Project should be removed before loading the Playlist. If false, the tests from the Playlist will be added to the PlaylistManager's Project existing test list. If true, all tests in the PlaylistManager's Project that are not in the Playlist will be removed. All tests that are in both the Project and the Playlist will be left as-is, meaning previous results will persist. All tests that are only in the Playlist will be added as new tests to the Project.

disableFeatureDetection

Specifies whether feature detection should occur when adding the PlaylistTests. If true, every test in the Playlist will be added regardless of whether feature detection finds any relevant targets.

Return Value

List<Guid>

Guids for tests that could not be added because they could not be found.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


UnloadPlaylist Method

Unloads the current playlist from this Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public void UnloadPlaylist ()

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistOSPlatform Class

Class that represents an OS Platform element inside of a Test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public class PlaylistOSPlatform

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.PlaylistOSPlatform**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Related topics

PlaylistOSPlatform Properties


PlaylistOSPlatform Properties

Public Properties

Name | Type | Description
Name | string | OS platform name

Related topics

PlaylistOSPlatform Class


PlaylistTest Class

Represents a test element inside of a Playlist file.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[Serializable]

public class PlaylistTest

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.PlaylistTest**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistTest Members

The following tables list the members exposed by the PlaylistTest Class.

Public Properties

Name | Description
FeatureSet | The list of PlaylistFeature objects.
Id | The test Id.
Name | The test name.
Version | The test version.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PlaylistTest Properties

Public Properties

Name | Description
FeatureSet | The list of PlaylistFeature objects.
Id | The test Id.
Name | The test name.
OSPlatformSet | The list of associated PlaylistOSPlatform objects.
Version | The test version.


PlaylistTest.FeatureSet Property

The list of PlaylistFeature objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlElement("Feature")]

public PlaylistFeature[] FeatureSet

Property Value

Gets or sets the list of PlaylistFeature objects.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistTest.Id Property

The test Id.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlAttribute]

public string Id

Property Value

Gets or sets the test Id.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistTest.Name Property

The test name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlAttribute]

public string Name

Property Value

Gets or sets the test name.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


OSPlatformSet Property

The list of associated PlaylistOSPlatform objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PlaylistOSPlatform[] OSPlatformSet

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PlaylistTest.Version Property

The test version.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[XmlAttribute]

public string Version

Property Value

Gets or sets the test version.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance Class

This class represents a piece of hardware that has been detected on a test computer and identified by set of targets.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class ProductInstance

      `Implements IRunTests`

C#

[DataContractAttribute]

public abstract class ProductInstance : IRunTests

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.NotificationBase**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProductInstance**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance Members

The following table lists the members exposed by the ProductInstance Class.

Public Properties

Name | Description
IsValid | Indicates whether or not this Product Instance is valid.
MachinePool | This property represents the machine (the test computer) that this product instance has been detected on.
Name | This property represents the product name for this ProductInstance object.
OSPlatform | This property represents the platform (operating system plus the architecture value) for this ProductInstance object.
Project | This property represents the reference to the Project object containing this product instance.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
AddTests | Adds the given Tests to this Product Instance. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
CanCreateTarget | This method determines if a target can be created from TargetData object provided. The target is not added to the product instance.
CreateTarget | This method creates a target from TargetData, and adds it to this product instance. Warning This functionality is being deprecated.
CreateTargetFamily | This method creates and adds a target family to the existing product instance, using the supplied DeviceFamily.
DeleteTarget | Overloaded.
DeleteTargetFamily | This method deletes a target family.
Equals | (Inherited from Object)
FindTargetFromContainer | This method creates a list of targets containing the specific container ID. There are two special container Ids to consider. The first is the system containerId (00000000-0000-0000-ffff-ffffffffffff). If this is passed in, then the method will return a list with just a single "system" target. The second is a zero-decorated GUID (00000000-0000-0000-0000-000000000000). This is an invalid GUID.
FindTargetFromDeviceFamily | This method finds a list of target data that matches the family specified.
FindTargetFromId | Overloaded.
FindTargetFromSystem | Overloaded.
GetFeatures | This method retrieves a collection of features detected for this product instance.
GetHashCode | (Inherited from Object)
GetMachines | This method retrieves all of the machines in a Product Instance. Machines are associated with Product Instances via their test targets. To add or remove a machine, you must add or remove the associated test target.
GetPlaylists | Gets the applied playlists for this ProductInstance.
GetProductTypes | This method attempts to detect product types this product instance belongs to.
GetTargetFamilies | This method retrieves an enumerable list of TargetFamilies that expose the product to the system.
GetTargets | This method retrieves an enumerable list of targets that expose the product to the system.
GetTests | This method retrieves all tests needed for this node.
GetType | (Inherited from Object)
QueueTest | Overloaded.
RemoveTests | Removes the given Tests from the ProductInstance. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetCommonParameters | This method sets all of the parameters with a given name to the same value for all child jobs.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProductInstance Methods

The following table lists the methods exposed by the ProductInstance Class.

Public Methods

Name | Description
AddTests | Adds the given Tests to this Product Instance. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
CanCreateTarget | This method determines if a target can be created from TargetData object provided. The target is not added to the product instance.
CreateTarget | This method creates a target from TargetData, and adds it to this product instance. Warning This functionality is being deprecated.
CreateTargetFamily | This method creates and adds a target family to the existing product instance, using the supplied DeviceFamily.
DeleteTarget | Overloaded.
DeleteTargetFamily | This method deletes a target family.
Equals | (Inherited from Object)
FindTargetFromContainer | This method creates a list of targets containing the specific container ID. There are two special container Ids to consider. The first is the system containerId (00000000-0000-0000-ffff-ffffffffffff). If this is passed in, then the method will return a list with just a single "system" target. The second is a zero-decorated GUID (00000000-0000-0000-0000-000000000000). This is an invalid GUID.
FindTargetFromDeviceFamily | This method finds a list of target data that matches the family specified.
FindTargetFromId | Overloaded.
FindTargetFromSystem | Overloaded.
GetFeatures | This method retrieves a collection of features detected for this product instance.
GetHashCode | (Inherited from Object)
GetMachines | This method retrieves all of the machines in a Product Instance. Machines are associated with Product Instances via their test targets. To add or remove a machine, you must add or remove the associated test target.
GetPlaylists | Gets the applied playlists for this ProductInstance.
GetProductTypes | This method attempts to detect product types this product instance belongs to.
GetTargetFamilies | This method retrieves an enumerable list of TargetFamilies that expose the product to the system.
GetTargets | This method retrieves an enumerable list of targets that expose the product to the system.
GetTests | This method retrieves all tests needed for this node.
GetType | (Inherited from Object)
QueueTest | Overloaded.
RemoveTests | Removes the given Tests from the ProductInstance. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetCommonParameters | This method sets all of the parameters with a given name to the same value for all child jobs.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProductInstance.AddTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Overload List

AddTests Method (IEnumerable<TestDefinition>) | Adds the given Tests to this Product Instance.
AddTests Method (IEnumerable<TestDefinition>, bool) | Adds the given Tests to this Product Instance.


ProductInstance.AddTests Method (IEnumerable TestDefinition )

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Adds the given Tests to this Product Instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be added

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.AddTests Method (IEnumerable TestDefinition , bool)

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Adds the given Tests to this Product Instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests,`

      `bool disableFeatureDetection`

)

Parameters

tests

The tests to be added

disableFeatureDetection

Flag that causes all the tests to be added to Targets regardless of feature detection.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.CanCreateTarget Method

This method determines if a target can be created from TargetData object provided. The target is not added to the product instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim data As TargetData

Dim returnValue As Boolean

returnValue = instance.CanCreateTarget(data)

Syntax

Visual Basic

Public Function CanCreateTarget ( _

      `data As TargetData _`

) As Boolean

C#

public bool CanCreateTarget (

      `TargetData data`

)

Parameters

data

 The **TargetData** to use to create the target

Return Value

true if the target can be created; otherwise, false.

Remarks

This method only validates that a target can be created. To add a target use the CreateTarget method.

If data is null an exception is thrown.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.CreateTarget Method

WARNING

This functionality is being deprecated.

Overload List

CreateTarget Method (TargetData) | This method creates a target from TargetData, and adds it to this product instance. Calls the overload method and creates the Target without adding tests.
CreateTarget Method (TargetData, bool) | This method creates a target from TargetData, and adds it to this product instance.


ProductInstance.CreateTarget Method (TargetData)

WARNING

This functionality is being deprecated.

This method creates a target from TargetData, and adds it to this product instance.

Calls the overload method and creates the Target without adding tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public Target CreateTarget (

      `TargetData data`

)

Parameters

data

 The [TargetData](targetdata-class.md) to use to create the target.

Return Value

The new Target object that was created.

Remarks

Any target has to be a child of a TargetFamily. Any hardware IDs found in the target data will be used to find a TargetFamily. If no TargetFamily is found that contains one of the hardware IDs, a new TargetFamily is created. In the case that a TargetException is thrown due to the refresh failing, verify the database connection is valid and that the target device has not been removed and is still present on the system if connected to a database project; if the hardware/driver is present and available, additionally waiting for a few minutes for the data to become available and/or rebooting the client system, then retrying this call may resolve the issue.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.CreateTarget Method (TargetData, bool)

WARNING

This functionality is being deprecated.

This method creates a target from TargetData, and adds it to this product instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public Target CreateTarget (

      `TargetData data,`

      `bool createWithoutAddingTests`

)

Parameters

data

The TargetData to use to create the target.

createWithoutAddingTests

Specifies if the Target should be created without adding Tests.

Return Value

The new Target object that was created.

Remarks

Any target has to be a child of a TargetFamily. Any hardware IDs found in the target data will be used to find a TargetFamily. If no TargetFamily is found that contains one of the hardware IDs, a new TargetFamily is created. In the case that a TargetException is thrown due to the refresh failing, verify the database connection is valid and that the target device has not been removed and is still present on the system if connected to a database project; if the hardware/driver is present and available, additionally waiting for a few minutes for the data to become available and/or rebooting the client system, then retrying this call may resolve the issue.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.CreateTargetFamily Method

This method creates and adds a target family to the existing product instance, using the supplied DeviceFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim deviceFamily As DeviceFamily

Dim returnValue As TargetFamily

returnValue = instance.CreateTargetFamily(deviceFamily)

Syntax

Visual Basic

Public MustOverride Function CreateTargetFamily ( _

      `deviceFamily As DeviceFamily _`

) As TargetFamily

C#

public abstract TargetFamily CreateTargetFamily (

      `DeviceFamily deviceFamily`

)

Parameters

deviceFamily

 The device family to use to create the **TargetFamily**.

Return Value

Returns TargetFamily, which is an initialized TargetFamily object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.DeleteTarget Method

Overload List

ProductInstance.DeleteTarget (String) | This method deletes a targetTableEntry by name/id.
ProductInstance.DeleteTarget (String, Machine) | This method deletes a targetTableEntry by name/id.
ProductInstance.DeleteTarget (Target) | This method enables the removal of a test target from this product instance.


ProductInstance.DeleteTarget Method (String)

This method deletes a targetTableEntry by name/id.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim targetIdToDelete As String

instance.DeleteTarget(targetIdToDelete)

Syntax

Visual Basic

Public Sub DeleteTarget ( _

      `targetIdToDelete As String _`

)

C#

public void DeleteTarget (

      `string targetIdToDelete`

)

Parameters

targetIdToDelete

 The name or id of the targetTableEntry to delete.

Remarks

An exception is thrown when:

  • The targetIdToDelete parameter is null or empty.

  • The ProductInstance could not be found or was deleted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.DeleteTarget Method (String, Machine)

This method deletes a targetTableEntry by name/id.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim targetIdToDelete As String

Dim machine As Machine

instance.DeleteTarget(targetIdToDelete, machine)

Syntax

Visual Basic

Public Sub DeleteTarget ( _

      `targetIdToDelete As String _`

      `machine As Machine _`

)

C#

public void DeleteTarget (

      `string targetIdToDelete`

      `Machine machine`

)

Parameters

targetIdToDelete

 The name or id of the targetTableEntry to delete.

machine

 The machine which contains this test target.

Remarks

An exception is thrown when:

  • The targetIdToDelete parameter is null or empty.

  • The ProductInstance could not be found or was deleted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.DeleteTarget Method (Target)

This method enables the removal of a test target from this product instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim target As Target

instance.DeleteTarget(target)

Syntax

Visual Basic

Public Sub DeleteTarget ( _

      `target As Target _`

)

C#

public void DeleteTarget (

      `Target target`

)

Parameters

target

 The ID value of the test target to be removed from this product instance.

Remarks

An exception is thrown if target is null:

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.DeleteTargetFamily Method

This method deletes a target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim familyToDelete As TargetFamily

instance.DeleteTargetFamily(familyToDelete)

Syntax

Visual Basic

Public MustOverride Sub DeleteTargetFamily ( _

      `familyToDelete As TargetFamily _`

)

C#

public abstract void DeleteTargetFamily (

      `TargetFamily familyToDelete`

)

Parameters

familyToDelete

 The **TargetFamily** to delete.

Remarks

An exception occurs if familyToDelete is null or not valid, or if an internal storage problem exists (for example, the controller cannot be reached).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.FindTargetFromContainer Method

This method creates a list of targets containing the specific container ID. There are two special containerIds to consider. The first is the system containerId(00000000-0000-0000-ffff-ffffffffffff). If this is passed in, then the method returns a list with just a single "system" target. The second is a zero-decorated GUID (00000000-0000-0000-0000-000000000000). This is an invalid GUID.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim containerId As Guid

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.FindTargetFromContainer(containerId)

Syntax

Visual Basic

Public Function FindTargetFromContainer ( _

      `containerId As Guid _`

) As ReadOnlyCollection(Of TargetData)

C#

public ReadOnlyCollection<TargetData> FindTargetFromContainer (

      `Guid containerId`

)

Parameters

containerId

 The GUID of containerId for (most likely) a device.

Return Value

Returns ReadOnlyCollection, which is a list of test targets with <paramref name="containerId"/>. If no test targets (devices) contains a container ID of <paramref name="containerId"/> then an empty list is returned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.FindTargetFromDeviceFamily Method

This method finds a list of target data that matches the specified family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim family As DeviceFamily

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.FindTargetFromDeviceFamily(family)

Syntax

Visual Basic

Public Function FindTargetFromDeviceFamily ( _

      `family As DeviceFamily _`

) As ReadOnlyCollection(Of TargetData)

C#

public ReadOnlyCollection<TargetData> FindTargetFromDeviceFamily (

      `DeviceFamily family`

)

Parameters

family

 The family to use to find device matches.

Return Value

Returns ReadOnlyCollection, which is a list of target data objects.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.FindTargetFromId Method

Overload List

ProductInstance.FindTargetFromId (String) | This method returns an appropriate target type based on information associated with <paramref name="targetId"/>.
ProductInstance.FindTargetFromId (String, Machine) | This method returns an appropriate target type based on information associated with <paramref name="targetId"/>.


ProductInstance.FindTargetFromId Method (String)

This method returns an appropriate target type based on information associated with <paramref name="targetId"/>.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim targetId As String

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.FindTargetFromId(targetId)

Syntax

Visual Basic

Public Function FindTargetFromId ( _

      `targetId As String _`

) As ReadOnlyCollection(Of TargetData)

C#

public ReadOnlyCollection<TargetData> FindTargetFromId (

      `string targetId`

)

Parameters

targetId

 The ID value that identifies the test target. This can be found in the SysParse data.

Return Value

Returns ReadOnlyCollection. If <paramref name="targetId"/> is not found on the machine (test computer) associated with the product instance, null is returned. Otherwise, an instance of the test target is returned.

Remarks

An exception occurs if targetId is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.FindTargetFromId Method (String, Machine)

This method returns an appropriate target type based on information associated with <paramref name="targetId"/>.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim targetId As String

Dim machine As Machine

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.FindTargetFromId(targetId, machine)

Syntax

Visual Basic

Public Function FindTargetFromId ( _

      `targetId As String, _`

      `machine As Machine _`

) As ReadOnlyCollection(Of TargetData)

C#

public ReadOnlyCollection<TargetData> FindTargetFromId (

      `string targetId`

      `Machine machine`

)

Parameters

targetId

 The ID that identifies the target. This can be found in the SysParse data.

machine

 The test computer to look for the ID value on.

Return Value

Returns ReadOnlyCollection. If <paramref name="targetId"/> is not found on the machine (test computer) associated with the product instance, null is returned. Otherwise, an instance of the test target is returned.

Remarks

An exception is thrown when the targetIdToDelete parameter is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.FindTargetFromSystem Method

Overload List

ProductInstance.FindTargetFromSystem () | This method creates a system target using all machines in the current pool.
ProductInstance.FindTargetFromSystem (Machine) | This method creates a system target from the specified machine.


ProductInstance.FindTargetFromSystem Method ()

This method returns an appropriate target type based on information associated with <paramref name="targetId"/>.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As ReadOnlyCollection(Of TargetData)

returnValue = instance.FindTargetFromSystem

Syntax

Visual Basic

Public Function FindTargetFromSystem As ReadOnlyCollection(Of TargetData)

C#

public ReadOnlyCollection<TargetData> FindTargetFromSystem ()

Return Value

Returns ReadOnlyCollection, which is an instance of a system target based on the machine associated with the product instance.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.FindTargetFromSystem Method (Machine)

This method creates a system target from the specified machine

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim machine As Machine

Dim returnValue As TargetData

returnValue = instance.FindTargetFromSystem(machine)

Syntax

Visual Basic

Public Function FindTargetFromSystem ( _

      `machine As Machine _`

) As TargetData

C#

public TargetData FindTargetFromSystem (

      `Machine machine`

)

Parameters

machine

 The machine to add as a system.

Return Value

Returns TargetData, which is an instance of a system target based on the machine associated with the product instance.

Remarks

An exception occurs if targetId is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.GetFeatures Method

This method retrieves a collection of features detected for this product instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As ReadOnlyCollection(Of Feature)

returnValue = instance.GetFeatures

Syntax

Visual Basic

Public Function GetFeatures As ReadOnlyCollection(Of Feature)

C#

public ReadOnlyCollection<Feature> GetFeatures ()

Return Value

Returns ReadOnlyCollection, which is a collection of features for this product instance.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.GetMachines Method

This method retrieves all of the machines in a Product Instance. Machines are associated with Product Instances via their test targets. To add or remove a machine, you must add or remove the associated test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As IEnumerable(Of Machine)

returnValue = instance.GetMachines

Syntax

Visual Basic

Public Function GetMachines As IEnumerable(Of Machine)

C#

public IEnumerable<Machine> GetMachines ()

Return Value

Returns IEnumerable, which is a read-only list of machines (test computers).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


GetPlaylists Method

Gets the applied playlists for this ProductInstance.

For ProductInstance objects connected to an HLK Controller database, there will be only one Playlist. When connected to a ProductInstance from a package, there may be multiple due to merging.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract ReadOnlyCollection<PlaylistInfo> GetPlaylists();

Return Value

Returns ReadOnlyCollection<PlaylistInfo>, which is a read-only list of playlist info objects.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.GetProductTypes Method

This method attempts to detect product types this product instance belongs to.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As ReadOnlyCollection(Of ProductType)

returnValue = instance.GetProductTypes

Syntax

Visual Basic

Public Overridable Function GetProductTypes As ReadOnlyCollection(Of ProductType)

C#

public virtual ReadOnlyCollection<ProductType> GetProductTypes ()

Return Value

Returns ReadOnlyCollection, which is a list() of product types.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.GetTargetFamilies Method

This method retrieves an enumerable list of TargetFamilies that expose the product to the system.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As ReadOnlyCollection(Of TargetFamily)

returnValue = instance.GetTargetFamilies

Syntax

Visual Basic

Public MustOverride Function GetTargetFamilies As ReadOnlyCollection(Of TargetFamily)

C#

public abstract ReadOnlyCollection<TargetFamily> GetTargetFamilies ()

Return Value

Returns ReadOnlyCollection, which is a collection of DeviceFamily objects.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.GetTargets Method

This method retrieves an enumerable list of targets that expose the product to the system.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As ReadOnlyCollection(Of Target)

returnValue = instance.GetTargets

Syntax

Visual Basic

Public Function GetTargets As ReadOnlyCollection(Of Target)

C#

public ReadOnlyCollection<Target> GetTargets ()

Return Value

Returns ReadOnlyCollection, which is a collection of test targets.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.GetTests Method ()

Retrieves all tests for this ProductInstance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual IList<Test> GetTests ()

Return Value

The collection of all tests for this ProductInstance.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.QueueTest Method

Overload List

ProductInstance.QueueTest () | This method schedules this object to be run.
ProductInstance.QueueTest (MachineSet) | This method schedules this object to run. The machine under test (the test computer) is always part of the machine set. This method is only for additional machines (test computers).


ProductInstance.QueueTest Method ()

This method schedules this object to be run.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest

Syntax

Visual Basic

Public Overridable Function QueueTest As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest ()

Return Value

Returns IList, which is a list of results for the jobs that were scheduled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.QueueTest Method (MachineSet)

This method schedules this object to run. The machine under test (the test computer) is always part of the machine set. This method is only for additional machines (test computers).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim logicalMachineSet As MachineSet

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest(logicalMachineSet)

Syntax

Visual Basic

Public Overridable Function QueueTest ( _

      `logicalMachineSet As MachineSet _`

) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest (

      `MachineSet logicalMachineSet`

)

Parameters

logicalMachineSet

 The list of machines to run this on.

Return Value

Returns IList, which is a list of results for the jobs that were scheduled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.QueueTest Method (IEnumerable Machine )

This method schedules the test for execution on a specific subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim logicalMachineSet As MachineSet

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest(logicalMachineSet)

Syntax

Visual Basic

Public Overridable Function QueueTest(ByVal machineList As IEnumerable(Of Machine)) As IList(Of TestResult)
    Dim testResults As List(Of TestResult) = New List(Of TestResult)()
    For Each targetFamily As TargetFamily In Me.GetTargetFamilies()
        testResults.AddRange(targetFamily.QueueTest(machineList))
    NextReturn testResults.AsReadOnly()
End Function

C#

public virtual IList<TestResult> QueueTest(IEnumerable<Machine> machineList)
{
    List<TestResult> testResults = new List<TestResult>();
    foreach (TargetFamily targetFamily in this.GetTargetFamilies())
    {
        testResults.AddRange(targetFamily.QueueTest(machineList));
    }
    return testResults.AsReadOnly();
}

Parameters

machineList

 List of machines that can run the test.

Return Value

A list of results for the tests that were scheduled.

Remarks

This is useful to specify a subset of possible machines. For example in the case where manual tests would prefer to run on specific machines.

An exception is thrown if:

  • A failure submitting a test to the scheduler.

  • Attempting to queue tests when the data source connection is Submission or Update package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.RemoveTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Removes the given Tests from the ProductInstance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void RemoveTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to remove.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.SetCommonParameters Method

This method sets all of the parameters with a given name to the same value for all child jobs

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim parameterName As String

Dim parameterValue As String

instance.SetCommonParameters(parameterName, parameterValue)

Syntax

Visual Basic

Public Sub SetCommonParameters ( _

      `parameterName As String, _`

      `parameterValue As String _`

)

C#

public void SetCommonParameters (

      `string parameterName,`

      `string parameterValue`

)

Parameters

parameterName

 The name of the parameter to set.

parameterValue

 The value to set the parameter to set it to.

Remarks

An exception occurs if the parameterName or parameterValue value is null, not valid, or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance Properties

Public Properties

Name | Description
IsValid | Indicates whether or not this Product Instance is valid.
MachinePool | This property represents the machine (the test computer) that this product instance has been detected on.
Name | This property represents the product name for this ProductInstance object.
OSPlatform | This property represents the platform (operating system plus the architecture value) for this ProductInstance object.
Project | This property represents the reference to the Project object containing this product instance.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


ProductInstance.IsValid Property

Gets a value indicating whether or not this Product Instance is valid.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim value As Boolean

value = instance.IsValid

C#

ProductInstance instance;

bool value;

value = instance.IsValid;

Syntax

Visual Basic

Public ReadOnly Property IsValid As Boolean

C#

public bool IsValid { get; }

Return Value

Returns bool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.MachinePool Property

This property represents the machine (the test computer) that this product instance has been detected on.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim value As MachinePool

value = instance.MachinePool

Syntax

Visual Basic

Public Property MachinePool As MachinePool

C#

public MachinePool MachinePool { get; }

Return Value

Returns MachinePool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.Name Property

This property represents the product name for this ProductInstance object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public MustOverride ReadOnly Property Name As String

C#

public abstract string Name { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.OSPlatform Property

This property represents the platform (operating system plus the architecture value) for this ProductInstance object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim value As OSPlatform

value = instance.OSPlatform

Syntax

Visual Basic

<DataMemberAttribute> _

Public Overridable Property OSPlatform As OSPlatform

C#

[DataMemberAttribute]

public virtual OSPlatform OSPlatform { get; }

Return Value

Returns OSPlatform.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstance.Project Property

This property represents the reference to the project object containing this product instance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstance

Dim value As Project

value = instance.Project

Syntax

Visual Basic

Public Property Project As Project

C#

public Project Project { get; }

Return Value

Returns Project.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstanceException Class

This exception class is defined to handle target-specific errors. Every time a non-expected occurrence happens, a ProductInstanceException is thrown to add more details related to the target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductInstanceException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class ProductInstanceException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class ProductInstanceException : ProjectManagerException

Inheritance Hierarchy

System.Object

 **System.Exception**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

                **Microsoft.Windows.Kits.Hardware.ObjectModel.ProductInstanceException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstanceException Members

The following table lists the members exposed by the OSPlatform type.

Public Constructor

Name | Description
ProductInstanceException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


ProductInstanceException Constructor

Overload List

ProductInstanceException () | This constructor initializes a new instance of the ProductInstanceException class.
ProductInstanceException (String) | This constructor initializes a new instance of the ProductInstanceException class.
ProductInstanceException (String, Exception) | This constructor initializes a new instance of the ProductInstanceException class.


ProductInstanceException Constructor ()

This constructor initializes a new instance of the ProductInstanceException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New ProductInstanceException

Syntax

Visual Basic

Public Sub New

C#

public ProductInstanceException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductInstanceException Constructor (String)

This constructor initializes a new instance of the ProductInstanceException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New ProductInstanceException (message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public ProductInstanceException (

      `string message`

)

Parameters

message

 The exception message (string).


ProductInstanceException Constructor (String, Exception)

This constructor initializes a new instance of the ProductInstanceException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New ProductInstanceException (message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

      `except As Exception _`

)

C#

public ProductInstanceException (

      `string message`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An exception object.


ProductInstanceException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProductInstanceException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


ProductInstanceException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


ProductType Class

This class represents a type of a product (for example, a printer, a scanner, and so on).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductType

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class ProductType

C#

[DataContractAttribute]

public abstract class ProductType

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.ProductType**

Remarks

A product type consists of a group of features.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductType Members

Public Properties

Name | Description
Description | This property represents the description of the product type.
Name | This property represents the name of the product type.

Public Methods

Name | Description
Equals | Overloaded. Overridden.
GetFeatures | This method retrieves the enumerated list of features stored in m_Features.
GetHashCode | Overridden. Returns the hash code for the current ProductType object.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProductType Methods

Public Methods

Name | Description
Equals | Overloaded. Overridden.
GetFeatures | This method retrieves the enumerated list of features stored in m_Features.
GetHashCode | Overridden. Returns the hash code for the current ProductType object.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProductType.Equals Method

Overload List

Name | Description
Equals Method (ProductType) | Overloads the Equals function to provide value equality functionality for this object.
Equals Method (object) | Overrides the Equals function to provide value equality functionality for this object.


ProductType.Equals Method (ProductType)

This function overloads the Equals function to provide value equality functionality for this object.

Syntax

C#

public override bool Equals (

      `ProductType other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductType.Equals Method (object)

This function overrides the Equals function to provide value equality functionality for this object.

Syntax

C#

public override bool Equals (

      `object other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductType.GetFeatures Method

This method retrieves the enumerated list of features stored in m_Features.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductType

Dim returnValue As ReadOnlyCollection(Of Feature)

returnValue = instance.GetFeatures

Syntax

Visual Basic

Public MustOverride Function GetFeatures As ReadOnlyCollection(Of Feature)

C#

public abstract ReadOnlyCollection<Feature> GetFeatures ()

Return Value

Returns ReadOnlyCollection, which is a collection of features for a product type..

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductType.GetHashCode Method

Returns the hash code for the current ProductType object.

Syntax

C#

public override int GetHashCode ()

Return Value

Returns an integer hash code.

Remarks

Product Types read from a Package will have different hash codes compared with ones read from the database.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductType Properties

Public Properties

Name | Description
Description | This property represents the description of the product type.
Name | This property represents the name of the product type.


ProductType.Description Property

This property represents the description of a ProductType.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductType

Dim value As String

value = instance.Description

Syntax

Visual Basic

Public MustOverride ReadOnly Property Description As String

C#

public abstract string Description { get; }

Property Value

Returns String.

Remarks

The data can be in HTML format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProductType.Name Property

This property represents the name of a ProductType.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProductType

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public MustOverride ReadOnly Property Name As String

C#

public abstract string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project Class

This class represents a Project object which is created in the database for each project the user initiates. It is effectively handles a set of product instances that users will be running logo tests for. In addition to that, there is metadata stored along with each Project object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class Project

      `Implements IRunTests`

C#

[DataContractAttribute]

public abstract class Project : IRunTests

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.NotificationBase**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.Project**

Remarks

Projects are the highest level objects in the hierarchy of data and objects used to represent certification. There are a number of layers of objects between the project and the test results and logs.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project Members

The following table lists the members exposed by the Machine type.

Public Fields

OpenedByTag

This is the value of the string used to indicate the current opener.

Public Properties

Name | Description
CreationTime | This property represents the creation DateTime for this Project object. You cannot change this value.
Info | This property represents the project information.
ModifiedTime | This property represents the DateTime that this project was last modified (for example, when targets are created/removed or tests are scheduled). ModifiedTime is not updated when tests are completed.
Name | This property represents the name of this Project object.
ProjectManager | This property represents the parent Windows HCK Studio object.
ServiceLog | This property represents the service log associated with this project.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
AddTests | Adds the given Tests to this Project. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
CanCreateProductInstance | This method validates that a child product instance object can be created but does not add the product instance. This method does not create a ProductInstance. A call to CreateProductInstance needs to be called to actually create the ProductInstance.
CreateProductInstance | This method creates a child ProductInstance object.
DeleteProductInstance | This method deletes a ProductInstance.
DeleteProperty | This method deletes an instance of a names property.
Equals | (Inherited from Object)
GetAllPossibleTests | Gets all of the tests that could potentially be added to this Project. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
GetAppliedFilters | This method retrieves a list of filters applied for this submission project.
GetHashCode | (Inherited from Object)
GetProductInstances | This method retrieves a list of product instances.
GetProperties | This method retrieves, a Dictionary object with all of the project properties.
GetTests | This method retrieves all tests needed for this node.
GetType | (Inherited from Object)
QueueTest | Overloaded.
RemoveTests | Removes the given Tests from the Project. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetProperty | This method updates or creates a new property value.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Project Fields

Insert introduction here.

Public Fields

Name | Description
OpenedByTag | This is the value of the string used to indicate the current opener.


Project.OpenedByTag Field

This is the value of the string used to indicate the current opener.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim value As String

value = Project.OpenedByTag

Syntax

Visual Basic

Public Const OpenedByTag As String

C#

public const string OpenedByTag

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project Methods

Public Methods

Name | Description
AddTests | Adds the given Tests to this Project. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
CanCreateProductInstance | This method validates that a child product instance object can be created but does not add the product instance. This method does not create a ProductInstance. A call to CreateProductInstance needs to be called to actually create the ProductInstance.
CreateProductInstance | This method creates a child ProductInstance object.
DeleteProductInstance | This method deletes a ProductInstance.
DeleteProperty | This method deletes an instance of a names property.
Equals | (Inherited from Object)
GetAllPossibleTests | Gets all of the tests that could potentially be added to this Project. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
GetAppliedFilters | This method retrieves a list of filters applied for this submission project.
GetHashCode | (Inherited from Object)
GetProductInstances | This method retrieves a list of product instances.
GetProperties | This method retrieves, a Dictionary object with all of the project properties.
GetTests | This method retrieves all tests needed for this node.
GetType | (Inherited from Object)
QueueTest | Overloaded.
RemoveTests | Removes the given Tests from the Project. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetProperty | This method updates or creates a new property value.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Project.AddTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Overload List

AddTests Method (IEnumerable<TestDefinition>) | Adds the given Tests to this Project.
AddTests Method (IEnumerable<TestDefinition>, bool) | Adds the given Tests to this Project.


Project.AddTests Method (IEnumerable TestDefinition )

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Adds the given Tests to this Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be added

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.AddTests Method (IEnumerable TestDefinition , bool)

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Adds the given Tests to this Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests,`

      `bool disableFeatureDetection`

)

Parameters

tests

The tests to be added

disableFeatureDetection

Flag that causes all the tests to be added to Targets regardless of feature detection.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.CanCreateProductInstance Method

This method validates that a child product instance object can be created but does not add the product instance. This function does not create a ProductInstance. You must call the CreateProductInstance method to create a ProductInstance.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim productInstanceName As String

Dim pool As MachinePool

Dim platform As OSPlatform

Dim returnValue As Boolean

returnValue = instance.CanCreateProductInstance(productInstanceName, pool, platform)

Syntax

Visual Basic

Public MustOverride Function CanCreateProductInstance ( _

      `productInstanceName As String, _`

      `pool As MachinePool, _`

      `platform As OSPlatform _`

) As Boolean

C#

public abstract bool CanCreateProductInstance (

      `string productInstanceName,`

      `MachinePool pool,`

      `OSPlatform platform`

)

Parameters

productInstanceName

 The name of the **ProductInstance** object.

pool

 The machine pool to use for this **ProductInstance**.

platform

 The operating system platform (operating system architecture plus the product SKU) to use for this platform instance.

Remarks

An error occurs if productInstanceName or pool is null, or if productInstanceName is empty.

This method does not create a ProductInstance. You must call CreateProductInstance to create the Product Instance.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.CreateProductInstance Method

This method creates a child ProductInstance object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim productInstanceName As String

Dim pool As MachinePool

Dim platform As OSPlatform

Dim returnValue As ProductInstance

returnValue = instance.CreateProductInstance(productInstanceName, pool, platform)

Syntax

Visual Basic

Public MustOverride Function CreateProductInstance ( _

      `productInstanceName As String, _`

      `pool As MachinePool, _`

      `platform As OSPlatform _`

) As ProductInstance

C#

public abstract ProductInstance CreateProductInstance (

      `string productInstanceName,`

      `MachinePool pool,`

      `OSPlatform platform`

)

Parameters

productInstanceName

 The name of the **ProductInstance** object.

pool

 The machine pool to use for this **ProductInstance**.

platform

 The operating system platform (operating system architecture plus the product SKU) to use for this platform instance.

Return Value

Returns a new ProductInstance object.

Remarks

An error occurs if productInstanceName is null or empty.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.DeleteProductInstance Method

This method deletes ProductInstance object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim nameOfProductInstanceToDelete As String

instance.DeleteProductInstance(nameOfProductInstanceToDelete)

Syntax

Visual Basic

Public MustOverride Sub DeleteProductInstance ( _

      `nameOfProductInstanceToDelete As String _`

)

C#

public abstract void DeleteProductInstance (

      `string nameOfProductInstanceToDelete`

)

Parameters

nameOfProductInstanceToDelete

 The name of the **ProductInstance** object to delete.

Remarks

An error occurs if nameOfProductInstanceToDelete is null or empty.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.DeleteProperty Method

This method deletes an instance of a Name property.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim nameOfPropertyToDelete As String

instance.DeleteProperty(nameOfPropertyToDelete)

Syntax

Visual Basic

Public MustOverride Sub DeleteProperty ( _

      `nameOfPropertyToDelete As String _`

)

C#

public abstract void DeleteProperty (

      `string nameOfPropertyToDelete`

)

Parameters

nameOfPropertyToDelete

      The name of the property to delete.

Remarks

An exception occurs if nameOfPropertyToDelete is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.GetAllPossibleTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Gets all of the tests that could potentially be added to this Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract List<TestDefinition> GetAllPossibleTests()

Return Value

A list of TestDefinition objects that are applicable to this Project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.GetAppliedFilters Method

This method retrieves a list of filters applied for this submission project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim returnValue As ReadOnlyCollection(Of IFilter)

returnValue = instance.GetAppliedFilters

Syntax

Visual Basic

Public Function GetAppliedFilters As ReadOnlyCollection(Of IFilter)

C#

public ReadOnlyCollection<IFilter> GetAppliedFilters ()

Return Value

Returns ReadOnlyCollection, which is a collection of filters.

Remarks

An exception occurs when the method fails to retrieve the filters.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.GetProductInstances Method

This method retrieves a list of ProductInstance objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim returnValue As ReadOnlyCollection(Of ProductInstance)

returnValue = instance.GetProductInstances

Syntax

Visual Basic

Public MustOverride Function GetProductInstances As ReadOnlyCollection(Of ProductInstance)

C#

public abstract ReadOnlyCollection<ProductInstance> GetProductInstances ()

Return Value

Returns ReadOnlyCollection, which is a collection of ProductInstance objects.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.GetProperties Method

This method retrieves a Dictionary object with all of the project properties

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim returnValue As Dictionary(Of String, String)

returnValue = instance.GetProperties

Syntax

Visual Basic

Public MustOverride Function GetProperties As Dictionary(Of String, String)

C#

public abstract Dictionary<string,string> GetProperties ()

Return Value

Returns a Dictionary object of project properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.GetTests () Method

Retrieves all tests for this project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Overridable Function GetTests() As IList(Of Test)
    Dim tests As List(Of Test) = New List(Of Test)()
    For Each productInstance As ProductInstance In Me.GetProductInstances()
        tests.AddRange(productInstance.GetTests())
    NextReturn tests
End Function

C#

public virtual IList<Test> GetTests()
{
    List<Test> tests = new List<Test>();
    foreach (ProductInstance productInstance in this.GetProductInstances())
    {
        tests.AddRange(productInstance.GetTests());
    }
    return tests;
}

Return Value

A collection of all tests for this project.

Remarks

For backwards compatibility with HCK 2.0, returns tests that are tagged with Certification content level. To get tests for other content levels, use the overloaded method that takes a collection of ContentLevelType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.QueueTest Method

Overload List

Name | Description
QueueTest Method () | This method schedules a test.
QueueTest Method (MachineSet) | This method schedules this object for testing. The machine under test (the test computer) is always part of the machine set; this is only for additional test computers.
QueueTest Method (IEnumerable<Machine>) | This method schedules the test for execution on a specific subset of machines.


Project.QueueTest Method ()

This method schedules a test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest

Syntax

Visual Basic

Public Overridable Function QueueTest As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest ()

Return Value

Returns IList, which is a list of results for the tests that were scheduled.

Remarks

This method is not supported when the project is connected to a package

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.QueueTest Method (MachineSet)

This method schedules a test. This method schedules this object for to be run. The machine under test (the test computer) is always part of the machine set, this is only for additional test computers.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim logicalMachineSet As MachineSet

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest(logicalMachineSet)

Syntax

Visual Basic

Public Overridable Function QueueTest ( _

      `logicalMachineSet As MachineSet _`

) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest (

      `logicalMachineSet As MachineSet _`

)

Parameters

logicalMachineSet

      The list of machines to run this on.

Return Value

Returns IList.

Remarks

The machine associated with the target (that was selected) is automatically added to the set.

QueueTest attempts to schedule all of the tests in the current or child objects. If a failure occurs, the scheduling is stopped immediately, and an exception is thrown. As a result, some of the tests might have been scheduled.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.QueueTest Method (IEnumerable Machine )

This method schedules the test for execution on a specific subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual IList<TestResult> QueueTest (

      `IEnumerable<Machine> machineList`

)

Parameters

machineList

List of machines that can run the test.

Remarks

This is useful to specify a subset of possible machines. For example in the case where manual tests would prefer to run on specific machines.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.RemoveTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Removes the given Tests from the Project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void RemoveTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be removed from the Project.

Remarks

Removes the tests from all Product Instances and Target Families in the Project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.SetProperty Method

This method updates or creates a new property value.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim nameOfProperty As String

Dim propertyValue As String

Dim returnValue As String

returnValue = instance.SetProperty(nameOfProperty, propertyValue)

Syntax

Visual Basic

Public MustOverride Function SetProperty ( _

      `nameOfProperty As String, _`

      `propertyValue As String _`

) As String

C#

public abstract string SetProperty (

      `string nameOfProperty,`

      `string propertyValue`

)

Parameters

nameOfProperty

 The name of the property to update or create.

propertyValue

 The machine pool to use for this **ProductInstance**.

Return Value

Returns String, which is the string value of the new value of the property that was set.

Remarks

An error occurs if nameOfProperty is null or empty, or if propertyValue is null.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project Properties

Public Properties

Name | Description
CreationTime | This property retrieves the project creation time.
Info | This property retrieves project information.
ModifiedTime | This property retrieves the last time that the project was modified.
Name | This property gets or sets the project name.
ProjectManager | This property gets the ProjectManager object that is used to load the project.
ServiceLog | This property retrieves the service log that is associated with this project.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


Project.CreationTime Property

This property retrieves the project creation time.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim value As DateTime = instance.CreationTime

C#

Project instance;

DateTime value = instance.CreationTime;

Syntax

Visual Basic

Public MustOverride ReadOnly Property CreationTime As DateTime

C#

public abstract DateTime CreationTime { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.Info Property

This property retrieves project information.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim value As ProjectInfo

value = instance.Info

C#

Project instance;

ProjectInfo value;

value = instance.Info;

Syntax

Visual Basic

Property Info As ProjectInfo

Public MustOverride Get

Friend MustOverride Set(ByVal value As ProjectInfo)

End Property

C#

public abstract ProjectInfo Info { get; internal set; }

Property Value

Returns ProjectInfo.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.ModifiedTime Property

This property retrieves the last time that the project was modified.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim value As DateTime = instance.ModifiedTime

C#

Project instance;

DateTime value = instance.ModifiedTime;

Syntax

Visual Basic

Property ModifiedTime As DateTime

Public MustOverride Get

Friend MustOverride Set(ByVal value As DateTime)

End Property

C#

public abstract DateTime ModifiedTime { get; internal set; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.Name Property

This property gets or sets the project name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim value As String = instance.Name

C#

Project instance;

string value = instance.Name;

Syntax

Visual Basic

Public MustOverride Property Name As String

C#

public abstract string Name { get; set; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.ProjectManager Property

This property gets the ProjectManager object that is used to load the project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim value As ProjectManager = instance.ProjectManager

C#

Project instance;

ProjectManager value = instance.ProjectManager;

Syntax

Visual Basic

Property ProjectManager As ProjectManager

C#

public ProjectManager ProjectManager { get; set; }

Property Value

Returns ProjectManager.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Project.ServiceLog Property

This property retrieves the service log that is associated with this project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Project

Dim value As TestLog = instance.ServiceLog

C#

Project instance;

TestLog value = instance.ServiceLog;

Syntax

Visual Basic

Property ServiceLog As TestLog

Public Overridable Get

End Property

C#

public virtual TestLog ServiceLog { get; }

Property Value

Returns TestLog.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectException Class

This class is a base class for all logo manager exceptions.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class ProjectException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class ProjectException: ProjectManagerException

Inheritance Hierarchy

System.Object

 **System.Exception**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

           **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectException**                     **Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectException Members

The following table lists the members exposed by the ProjectException type.

Public Constructor

Name | Description
ProjectException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


ProjectException Constructor

Overload List

ProjectException () | This constructor initializes a new instance of the ProjectException class.
ProjectException (String) | This constructor initializes a new instance of the ProjectException class.
ProjectException (String, Exception) | This constructor initializes a new instance of the ProjectException class.


ProjectException Constructor ()

This constructor initializes a new instance of the ProjectException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New ProjectException

Syntax

Visual Basic

Public Sub New

C#

public ProjectException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectException Constructor (String)

This constructor initializes a new instance of the ProjectException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New ProjectException(message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public ProjectException (

      `string message`

)

Parameters

message

 A string that represents the message for the exception.


ProjectException Constructor (String, Exception)

This constructor initializes a new instance of the ProjectException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New ProjectException (message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String, _`

      `except As Exception _`

)

C#

public ProjectException (

      `string message,`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An **Exception** object.


ProjectException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProjectException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


ProjectException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


ProjectFilterResultsDictionary Class

This class represents a collection of filter results for the test results in a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectFilterResultsDictionary

Syntax

Visual Basic

<SerializableAttribute> _

Public Class ProjectFilterResultsDictionaryPublic Class ProjectFilterResultsDictionary

      `Inherits Dictionary(Of TestResult, ReadOnlyCollection(Of IFilterResult))`

C#

[SerializableAttribute]

public class ProjectFilterResultsDictionary : Dictionary<TestResult,ReadOnlyCollection<IFilterResult>>

Inheritance Hierarchy

System.Object

 **System.Collections.Generic.Dictionary**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectFilterResultsDictionary**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectFilterResultsDictionary Members

The following table lists the members exposed by the ProjectException type.

Public Constructor

Name | Description
ProjectFilterResultsDictionary | Overloaded.

Public Properties

Name | Description
Comparer | (Inherited from Dictionary)
Count | (Inherited from Dictionary)
Item | (Inherited from Dictionary)
Keys | (Inherited from Dictionary)
Values | (Inherited from Dictionary)

Public Methods

Name | Description
Add | (Inherited from Dictionary)
Clear | (Inherited from Dictionary)
ContainsKey | (Inherited from Dictionary)
ContainsValue | (Inherited from Dictionary)
Equals | (Inherited from Object)
GetEnumerator | (Inherited from Dictionary)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Dictionary)
GetType | (Inherited from Object)
OnDeserialization | (Inherited from Dictionary)
Remove | (Inherited from Dictionary)
ToString | (Inherited from Object)
TryGetValue | (Inherited from Dictionary)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProjectFilterResultsDictionary Constructor

Overload List

Name | Description
ProjectFilterResultsDictionary () |
ProjectFilterResultsDictionary (IEqualityComparer) |
ProjectFilterResultsDictionary (Int32) |
ProjectFilterResultsDictionary (Int32, IEqualityComparer) |


ProjectFilterResultsDictionary Constructor ()

This constructor initializes a new instance of the ProjectFilterResults class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New ProjectFilterResultsDictionary

Syntax

Visual Basic

Public Sub New

C#

public ProjectFilterResultsDictionary ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectFilterResultsDictionary Constructor (IEqualityComparer)

This constructor initializes a new instance of the ProjectFilterResultsDictionary class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim comparer As IEqualityComparer(Of TestResult)

Dim instance As New ProjectFilterResultsDictionary(comparer)

Syntax

Visual Basic

Public Sub New ( _

      `comparer As IEqualityComparer(Of TestResult) _`

)

C#

public ProjectFilterResultsDictionary (

      `IEqualityComparer<TestResult> comparer`

)

Parameters

comparer

 The **System.Collections.Generic.IEqualityComparer** implementation to use when comparing keys, or **null** to use the default EqualityComparer for the type of the key.


ProjectFilterResultsDictionary Constructor (Int32)

This constructor initializes a new instance of the ProjectFilterResultsDictionary class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim capacity As Integer

Dim instance As New ProjectFilterResultsDictionary(capacity)

Syntax

Visual Basic

Public Sub New ( _

      `capacity As Integer _`

)

C#

public ProjectFilterResultsDictionary (

      `int capacity`

)

Parameters

capacity

 The initial number of elements that the dictionary can contain.


ProjectFilterResultsDictionary Constructor (Int32, IEqualityComparer)

This constructor initializes a new instance of the ProjectFilterResultsDictionary class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim capacity As Integer

Dim comparer As IEqualityComparer(Of TestResult)

Dim instance As New ProjectFilterResultsDictionary(capacity, comparer)

Syntax

Visual Basic

Public Sub New ( _

      `capacity As Integer, _`

      `comparer As IEqualityComparer(Of TestResult) _`

)

C#

public ProjectFilterResultsDictionary (

      `int capacity,`

      `IEqualityComparer<TestResult> comparer`

)

Parameters

capacity

 The initial number of elements that the dictionary can contain.

comparer

 The **System.Collections.Generic.IEqualityComparer** implementation to use when comparing keys, or **null** to use the default EqualityComparer for the type of the key.


ProjectFilterResultsDictionary Methods

Public Methods

Name | Description
Add | (Inherited from Dictionary)
Clear | (Inherited from Dictionary)
ContainsKey | (Inherited from Dictionary)
ContainsValue | (Inherited from Dictionary)
Equals | (Inherited from Object)
GetEnumerator | (Inherited from Dictionary)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Dictionary)
GetType | (Inherited from Object)
OnDeserialization | (Inherited from Dictionary)
Remove | (Inherited from Dictionary)
ToString | (Inherited from Object)
TryGetValue | (Inherited from Dictionary)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProjectFilterResultsDictionary Properties

Public Properties

Name | Description
Comparer | (Inherited from Dictionary)
Count | (Inherited from Dictionary)
Item | (Inherited from Dictionary)
Keys | (Inherited from Dictionary)
Values | (Inherited from Dictionary)


ProjectInfo Class

This class represents general information about a Project object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Syntax

Visual Basic

<DataContractAttribute> _

Public Class ProjectInfo

C#

[DataContractAttribute]

public class ProjectInfo

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectInfo**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo Members

The following table lists the members exposed by the ProjectInfo type.

Public Properties

Name | Description
ChangedDate | This property represents the last time that this project was opened.
FailedCount | This property represents the number of failed certification tests for a project.
Name | This property represents the name of this project.
NotRunCount | This property represents the number of certification tests that haven't been run.
PassedCount | This property represents the number of passed certification tests for a project.
RunningCount | This property represents the number of tests that are running for a project.
Status | This property represents the execution status for this project object.
TotalCount | This property represents the total number of tests associated with a project.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProjectInfo Methods

The following table lists the methods exposed by the ProjectInfo type.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


ProjectInfo Properties

Public Properties

Name | Description
ChangedDate | This property represents the last time that this project was opened.
FailedCount | This property represents the number of failed certification tests for a project.
Name | This property represents the name of this project.
NotRunCount | This property represents the number of certification tests that haven't been run.
PassedCount | This property represents the number of passed certification tests for a project.
RollupSummaryByContentLevels | This property represents test roll-up summary for the project grouped by each test content level.
RunningCount | This property represents the number of tests that are running for a project.
Status | This property represents the execution status for this project object.
TotalCount | This property represents the total number of tests associated with a project.


ProjectInfo.ChangedDate Property

This property represents the last time that this project was opened.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As DateTime

value = instance.ChangedDate

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ChangedDate As DateTime

C#

[DataMemberAttribute]

public DateTime ChangedDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.FailedCount Property

This property represents the number of failed certification tests for a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As Integer

value = instance.FailedCount

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property FailedCount As DateTime

C#

[DataMemberAttribute]

public int FailedCount { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.Name Property

This property represents the name of this project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As String

value = instance.Name

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Name As String

C#

[DataMemberAttribute]

public string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.NotRunCount Property

This property represents the number of certification tests that haven't been run.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As Integer

value = instance.NotRunCount

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property NotRunCount As Integer

C#

[DataMemberAttribute]

public int NotRunCount { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.PassedCount Property

This property represents the number of passed certification tests for a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As Integer

value = instance.PassedCount

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property PassedCount As Integer

C#

[DataMemberAttribute]

public int PassedCount { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.RunningCount Property

This property represents the number of tests that are running for a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As Integer

value = instance.RunningCount

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property RunningCount As Integer

C#

[DataMemberAttribute]

public int RunningCount { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.Status Property

This property represents the execution status for this project object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As ProjectStatus

value = instance.Status

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Status As ProjectStatus

C#

[DataMemberAttribute]

public ProjectStatus Status { get; }

Property Value

Returns ProjectStatus.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectInfo.TotalCount Property

This property represents the total number of tests associated with a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectInfo

Dim value As Integer

value = instance.TotalCount

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property TotalCount As Integer

C#

[DataMemberAttribute]

public int TotalCount { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager Class

This class provides an interface to connect to a project packager or a running database and controller.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Syntax

Visual Basic

Public MustInherit Class ProjectManager

      `Implements IDisposable`

C#

public abstract class ProjectManager : IDisposable

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManager**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageManager**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager Members

The following table lists the members exposed by the ProjectManager type.

Public Properties

Name | Description
ConnectionType | This property represents the connection type for this ILogoManager
Version | This property represents the major version of the Windows HCK Controller.
VersionString | This property represents the version of the Windows HCK Controller and its content.

Public Methods

Name | Description
CreateDeviceFamily | This method creates a new device family with the given name.
CreateProject | This method creates a new project.
DeleteDeviceFamily | This method deletes a device family by name.
DeleteProject | This method deletes a project.
Dispose | Overloaded.
Equals | (Inherited from Object)
GetDeviceFamilies | This method retrieves the list of available DeviceFamily objects.
GetFeatures | This method retrieves the list of feature registered.
GetFilters | This method retrieves the list of filters that are available.
GetHashCode | (Inherited from Object)
GetLocaleList | This method retrieves the list of possible test locales.
GetPlatforms |
GetProductTypes | This method retrieves the collection of registered product types.
GetProject | This method retrieves a project and returns its object.
GetProjectInfoList | This method retrieves a list of ProjectInfo objects. This does not open each of the projects.
GetProjectNames | This method retrieves a list of names of the projects.
GetProjectSummary |
GetRequirements | This method retrieves a list of requirements registered.
GetRootMachinePool | This method retrieves the root machine pool.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)


ProjectManager Methods

Public Methods

Name | Description
CreateDeviceFamily | This method creates a new device family with the given name.
CreateProject | This method creates a new project.
DeleteDeviceFamily | This method deletes a device family by name.
DeleteProject | This method deletes a project.
Dispose | Overloaded.
Equals | (Inherited from Object)
GetDeviceFamilies | This method retrieves the list of available DeviceFamily objects.
GetFeatures | This method retrieves the list of feature registered.
GetFilters | This method retrieves the list of filters that are available.
GetHashCode | (Inherited from Object)
GetLocaleList | This method retrieves the list of possible test locales.
GetPlatforms |
GetProductTypes | This method retrieves the collection of registered product types.
GetProject | This method retrieves a project and returns its object.
GetProjectInfoList | This method retrieves a list of ProjectInfo objects. This does not open each of the projects.
GetProjectNames | This method retrieves a list of names of the projects.
GetProjectSummary |
GetRequirements | This method retrieves a list of requirements registered.
GetRootMachinePool | This method retrieves the root machine pool.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)


ProjectManager.CreateDeviceFamily Method

This method creates a new device family with the given name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim name As String

Dim familyIds As IEnumerable(Of String)

Dim returnValue As DeviceFamily

returnValue = instance.CreateDeviceFamily(name, familyIds)

Syntax

Visual Basic

Public MustOverride Function CreateDeviceFamily ( _

      `name As String, _`

      `familyIds As IEnumerable(Of String) _`

      `platform As OSPlatform _`

) As DeviceFamily

C#

public abstract DeviceFamily CreateDeviceFamily (

      `string name,`

      `IEnumerable<string> familyIds`

)

Parameters

name

 The name to create the device family with.

familyIds

 The Ids to use when creating the device family.

Return Value

Returns a DeviceFamily Class

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.CreateProject Method

This method creates a new project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim projectName As String

returnValue As Project

returnValue = instance.CreateProject(projectName)

Syntax

Visual Basic

Public MustOverride Function CreateProject ( _

      `projectName As String, _`

) As Project

C#

public abstract Project CreateProject (

      `string projectName`

)

Parameters

projectName

 The name of the project to create.

Return Value

Returns Project Class.

Remarks

projectName is not case sensitive.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.DeleteDeviceFamily Method

This method deletes a device family by name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim name As String

instance.DeleteDeviceFamily(name)

Syntax

Visual Basic

Public MustOverride Sub DeleteDeviceFamily ( _

      `name As String _`

)

C#

public abstract void DeleteDeviceFamily (

      `string name`

)

Parameters

name

 The name of the device family to delete..

Remarks

An error occurs if the device family cannot be located or is in use.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.DeleteProject Method

This method deletes a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim projectNameToDelete As String

instance.DeleteProject(projectNameToDelete)

Syntax

Visual Basic

Public MustOverride Sub DeleteProject ( _

      `projectNameToDelete As String _`

)

C#

public abstract void DeleteProject (

      `string projectNameToDelete`

)

Parameters

projectNameToDelete

      The name of the project to delete.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.Dispose Method

[This content is not available in this preliminary release.]

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


ProjectManager.Dispose Method ()

This method implements the IDisposable interface.

Usage

Visual Basic

Dim instance As ProjectManager

instance.Dispose

Syntax

Visual Basic

Public Sub Dispose

C#

public void Dispose ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.Dispose Method (Boolean)

This method implements the IDisposable interface.

Usage

Visual Basic

Dim disposing As Boolean

Me.Dispose(disposing)

Syntax

Visual Basic

Protected Overridable Sub Dispose ( _

      `disposing As Boolean _`

)

C#

public void Dispose ()

      `bool disposing`

)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.Finalize Method

This method finalizes an instance of the ProjectManager class.

Usage

Visual Basic

Me.Finalize

Syntax

Visual Basic

Protected Overrides Sub Finalize

C#

~ProjectManager()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetDeviceFamilies Method

This method retrieves the list of available DeviceFamilies.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of DeviceFamily)

returnValue = instance.GetDeviceFamilies

Syntax

Visual Basic

Public MustOverride Function GetDeviceFamilies As ReadOnlyCollection(Of DeviceFamily)

C#

public abstract ReadOnlyCollection<DeviceFamily> GetDeviceFamilies ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetFeatures Method

This method retrieves the list of feature registered.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of Feature)

returnValue = instance.GetFeatures

Syntax

Visual Basic

Public MustOverride Function GetFeatures As ReadOnlyCollection(Of Feature)

C#

public abstract ReadOnlyCollection<Feature> GetFeatures ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetFilters Method

This method retrieves the list of filters that are available.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of IFilter)

returnValue = instance.GetFilters

Syntax

Visual Basic

Public MustOverride Function GetFilters As ReadOnlyCollection(Of IFilter)

C#

public abstract ReadOnlyCollection<IFilter> GetFilters ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetLocaleList Method

This method retrieves the list of possible test locales.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of String)

returnValue = instance.GetLocaleList

Syntax

Visual Basic

Public Function GetLocaleList As ReadOnlyCollection(Of String)

C#

public ReadOnlyCollection<string> GetLocaleList ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetPlatforms Method

This method retrieves the list of known platforms.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of OSPlatform)

returnValue = instance.GetPlatforms

Syntax

Visual Basic

Public MustOverride Function GetPlatforms() As ReadOnlyCollection(Of OSPlatform)

C#

public abstract ReadOnlyCollection<OSPlatform> GetPlatforms();

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetProductTypes Method

This method retrieves the collection of registered product types.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of ProductType)

returnValue = instance.GetProductTypes

Syntax

Visual Basic

Public MustOverride Function GetProductTypes As ReadOnlyCollection(Of ProductType)

C#

public abstract ReadOnlyCollection<ProductType> GetProductTypes ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetProject Method

This method retrieves a Project and returns its object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim projectName As String

Dim returnValue As Project

returnValue = instance.GetProject(projectName)

Syntax

Visual Basic

Public MustOverride Function GetProject ( _

      `projectName As String _`

) As Project

C#

public abstract Project GetProject (

      `string projectName`

)

Parameters

projectName

 The name of the Project to open.

Return Value

Returns Project Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetProjectInfo Method

This method retrieves information for a specific project. This does not open the project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public MustOverride Function GetProjectInfo(ByVal projectName As String) As ProjectInfo

C#

public abstract ProjectInfo GetProjectInfo(string projectName);

Return Value

Returns ProjectInfo.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetProjectInfoList Method

This method retrieves a list of Project Info classes. This does not open each of the Projects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of ProjectInfo)

returnValue = instance.GetProjectInfoList

Syntax

Visual Basic

Public MustOverride Function GetProjectInfoList As ReadOnlyCollection(Of ProjectInfo)

C#

public abstract ReadOnlyCollection<ProjectInfo> GetProjectInfoList ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetProjectNames Method

This method retrieves a list of names of the projects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of String)

returnValue = instance.GetProjectNames

Syntax

Visual Basic

Public MustOverride Function GetProjectNames As ReadOnlyCollection(Of String)

C#

public abstract ReadOnlyCollection<string> GetProjectNames ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetProjectSummary Method

This method retrieves a list of project summaries.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of ProjectSummary)

returnValue = instance.GetProjectSummary

Syntax

Visual Basic

Public MustOverride Function GetProjectSummary() As ReadOnlyCollection(Of ProjectSummary)

C#

public abstract ReadOnlyCollection<ProjectSummary> GetProjectSummary();

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetRequirements Method

This method retrieves a list of requirements registered.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of Requirement)

returnValue = instance.GetRequirements

Syntax

Visual Basic

Public MustOverride Function GetRequirements As ReadOnlyCollection(Of Requirement)

C#

public abstract ReadOnlyCollection<Requirement> GetRequirements ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.GetRootMachinePool Method

This method retrieves the root machine pool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As MachinePool

returnValue = instance.GetRootMachinePool

Syntax

Visual Basic

Public MustOverride Function GetRootMachinePool As MachinePool

C#

public abstract MachinePool GetRootMachinePool ()

Return Value

Returns MachinePool Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager Properties

Public Properties

Name | Description
ConnectionType | This property represents the connection type for this ILogoManager
Version | This property represents the major version of the Windows HCK Controller.
VersionString | This property represents the version of the Windows HCK Controller and its content.


ProjectManager.ConnectionType Property

This property represents the connection type for this ILogoManger

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim value As ConnectionType

value = instance.ConnectionType

Syntax

Visual Basic

Public MustOverride ReadOnly Property ConnectionType As ConnectionType

C#

public abstract ConnectionType ConnectionType { get; }

Return Value

Returns ConnectionType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.Version Property

This property represents the major version of the Windows HCK Controller.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim value As Version

value = instance.Version

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Version As Version

C#

[DataMemberAttribute]

public Version Version { get; }

Return Value

Returns Version.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManager.VersionString Property

This property represents the major version of the Windows HCK Controller.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManager

Dim value As String

value = instance.VersionString

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public ReadOnly Property VersionString As String

C#

[IgnoreDataMemberAttribute]

public string VersionString { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManagerException Class

This class is a base class for all certification manager exceptions.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectManagerException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class ProjectManagerException

      `Implements Exception`

C#

[SerializableAttribute]

public class ProjectManagerException : Exception

Inheritance Hierarchy

System.Object

 **System.Exception**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

Derived Classes

Class | Description
DataIntegrityException Class |
MachineException Class |
ProductInstanceException Class |
RequirementException Class |
ScheduleException Class |
TargetException Class |
TestException Class |

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManagerException Members

The following table lists the members exposed by the ProjectManagerException type.

Public Constructors

Name | Description
ProjectManagerException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


ProjectManagerException Constructor

Overload List

Name | Description
ProjectManagerException () | This constructor initializes a new instance of the ProjectManagerException class.
ProjectManagerException (String) | This constructor initializes a new instance of the ProjectManagerException class.
ProjectManagerException (String, Exception) | This constructor initializes a new instance of the ProjectManagerException class.

Subsection Heading

Insert subsection body here.


ProjectManagerException Constructor ()

This constructor initializes a new instance of the ProjectManagerException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New ProjectManagerException

Syntax

Visual Basic

Public Sub New

C#

public ProjectManagerException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectManagerException Constructor (String)

This constructor initializes a new instance of the ProjectManagerException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New ProjectManagerException (message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public ProjectManagerException (

      `string message`

)

Parameters

message

 The exception message (string).


ProjectManagerException Constructor (String, Exception)

This constructor initializes a new instance of the ProjectManagerException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New ProjectManagerException (message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

      `except As Exception _`

)

C#

public ProjectManagerException (

      `string message`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An exception object.


ProjectManagerException Methods

[This content is not available in this preliminary release.]

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


ProjectManagerException Properties

[This content is not available in this preliminary release.]

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


ProjectManagerException Events

[This content is not available in this preliminary release.]

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


ProjectStatus Enumeration

The values that define the status of a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Public Enumeration ProjectStatus

Syntax

Visual Basic

Public Enumeration ParameterSetAsDefault

C#

public enum ProjectStatus

Members

Member Name | Description
NotRunning | This value represents the project status. If there are no tests running for this project, the status is NotRunning.
Passing | This value represents the project status A project is passing, if all of the tests needed have passed, and there are no tests that are still running.
Running | This value represents the project status. A project is running if there is at least one related test that is in a running state.


ProjectSummary Class

This class provides summary information for a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectSummary

Syntax

Visual Basic

Public Class ProjectManager

C#

public class ProjectSummary

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectSummary**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary Members

The following table lists the members exposed by the ProjectSummary type.

Public Constructors

Name | Description
ProjectSummary Constructor (String, DateTime, String) | This constructor initializes a new instance of the ProjectSummary class.

Public Properties

Name | Description
ChangedDate | Retrieves the date of the project.
InstanceId | Retrieves the unique identifier for this project.
Name | Retrieves the name of the project.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
Equality | This method provides an Equality operator between two ProjectSummary objects.
Inequality | This method provides an Inequality operator between two ProjectSummary objects.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)


ProjectSummary Constructor

This table lists the constructors for the ProjectSummary object.

Overload List

Name | Description
ProjectSummary Constructor (String, DateTime, String) | This constructor initializes a new instance of the ProjectSummary class.


ProjectSummary Constructor (String, DateTime, String)

This constructor initializes a new instance of the ProjectSummary class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Sub New ( _

      `ByVal name As String _`

      `ByVal modified As DateTime _`

      `ByVal id As String _`

)

C#

public ProjectSummary (

      `string name, `

      `DateTime modified,`

      `string id`

)

Parameters

name

 The name of the project.

modified

 The date of the last modification to the project.

id

 The unique identifier for this project.


ProjectSummary Methods

[This content is not available in this preliminary release.]

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
Equality | This method provides an Equality operator between two ProjectSummary objects.
Inequality | This method provides an Inequality operator between two ProjectSummary objects.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)


ProjectSummary.Equals Method

This method compares two ProjectSummary instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectSummary

Dim otherProjectSummary As ProjectSummary

Dim returnValue As Boolean

returnValue = instance.Equals(otherProjectSummary)

Syntax

Visual Basic

Public Function Equals ( _

      `otherProjectSummary As ProjectSummary _`

) As Boolean

C#

public bool Equals (

      `ProjectSummary otherProjectSummary`

)

Parameters

otherProjectSummary

 The **ProjectSummary** object to compare against this **ProjectSummary** object.

Return Value

Returns Boolean, which has a value of true if the two objects are equal, or a value of false if they are different.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary.GetHashCode Method

This method returns a hash code for a ProjectSummary object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ProjectSummary

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number representing this object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary.Equality Method

This method provides an Equality operator between two ProjectSummary objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As ProjectSummary

Dim second As ProjectSummary

Dim returnValue As Boolean

returnValue = (first = second)

Syntax

Visual Basic

Public Shared Operator = ( _

      `first As ProjectSummary, _`

      `second As ProjectSummary _`

) As Boolean

C#

public static bool operator == (

      `ProjectSummary first,`

      `ProjectSummary second`

)

Parameters

first

 The first **ProjectSummary** object to compare against.

second

 The second **ProjectSummary** object to compare against.

Return Value

true if the ProjectSummary objects are identical; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary.Inequality Method

This method provides an Inequality operator between two ProjectSummary objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As ProjectSummary

Dim second As ProjectSummary

Dim returnValue As Boolean

returnValue = (first <> second)

Syntax

Visual Basic

Public Shared Operator <> ( _

      `first As ProjectSummary, _`

      `second As ProjectSummary _`

) As Boolean

C#

public static bool operator != (

      `ProjectSummary first,`

      `ProjectSummary second`

)

Parameters

first

      The first **ProjectSummary** object to compare against.

second

      The second **ProjectSummary** object to compare against.

Return Value

true if the objects are not equal, or false if the objects are the same or if either object is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary Properties

This table lists the properties of the ProjectSummary class.

Public Properties

Name | Description
ChangedDate | Retrieves the date of the project.
InstanceId | Retrieves the unique identifier for this project.
Name | Retrieves the name of the project.


ProjectSummary.ChangedDate Property

Retrieves the date of the project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Property ChangedDate As DateTime

C#

public DateTime Name { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary.InstanceId Property

Retrieves the unique identifier for this project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Property InstanceId As String

C#

public string InstanceId { get; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ProjectSummary.Name Property

Retrieves the name of the project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Property Name As String

C#

public string Name { get; }

Property Value

Returns string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement Class

This class represents a single certification requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Syntax

Visual Basic

Public MustInherit Class Requirement

C#

public abstract class Requirement

Remarks

Requirements are the published device or system requirements that are defined for certification.

Requirements map to features and can also be associated with a test.

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.Requirement**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement Members

The following table lists the members exposed by the RequirementDescriptionData type.

Public Properties

Name | Description
ConfidenceLevel | This property represents the ConfidenceLevel description for a requirement.
DisclosureStatus | This property represents the DisclosureStatus value for a requirement.
EnforcementDate | This property represents the requirement EnforcementDate.
Feature | This property represents the requirement Feature.
FullName | This property represents the requirement FullName.
Name | This property represents the requirement name.
RequirementStatus | This property represents the requirement status.
SupportedPlatforms | This property represents all of the platforms that this requirement supports.

Public Methods

Name | Description
Equals | Provides value equality functionality for this object.
GetDescriptionData | This method returns a description of the requirementTableEntry given the specified language.
GetHashCode | Serves as a hash function for this object.
GetType | (Inherited from Object)
HasTheName | This method checks if this requirement has a given name.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Requirement Methods

Public Methods

Name | Description
Equals | Provides value equality functionality for this object.
GetDescriptionData | This method returns a description of the requirementTableEntry given the specified language.
GetHashCode | Serves as a hash function for this object.
GetType | (Inherited from Object)
HasTheName | This method checks if this requirement has a given name.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Requirement.Equals Method

Overload List

Name | Description
Equals Method (Requirement) | Overloads the Equals function to provide value equality functionality for this object.
Equals Method (object) | Overrides the Equals function to provide value equality functionality for this object.


Requirement.Equals Method (Requirement other)

This function overloads the Equals function to provide value equality functionality for this object.

Syntax

C#

public override bool Equals (

      `Requirement other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.Equals Method (object other)

This function overrides the Equals function to provide value equality functionality for this object.

Syntax

C#

public override bool Equals (

      `object other`

)

Parameters

other

The object to compare.

Return Value

Returns true if the objects are the same.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.GetDescriptionData Method

This method returns a description of the requirementTableEntry given the specified language.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim language As String

Dim returnValue As RequirementDescriptionData

returnValue = instance.GetDescriptionData(language)

Syntax

Visual Basic

Public MustOverride Function GetDescriptionData ( _

      `language As String _`

) As RequirementDescriptionData

C#

public abstract RequirementDescriptionData GetDescriptionData (

      `string language`

)

Parameters

language

 The language for the description data requested.

Return Value

Returns RequirementDescriptionData Class, which is a DescriptionData class in the supplied language.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.GetHashCode Method

Serves as a hash function for this object.

Syntax

C#

public override int GetHashCode ()

Return Value

Returns the hash code.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.HasTheName Method

This method checks if this requirement has a given name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim name As String

Dim returnValue As Boolean

returnValue = instance.HasTheName(name)

Syntax

Visual Basic

Public Function HasTheName ( _

      `name As String _`

) As Boolean

C#

public bool HasTheName (

      `string name`

)

Parameters

name

 Name to check this requirement for.

Return Value

true if the specified name matches this requirement's name; otherwise, false.

Remarks

The string comparison is not case sensitive.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement Properties

[This content is not available in this preliminary release.]

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


Requirement.ConfidenceLevel Property

This property represents the ConfidenceLevel description for a requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As String

value = instance.ConfidenceLevel

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ConfidenceLevel As String

C#

[DataMemberAttribute]

public string ConfidenceLevel { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.DisclosureStatus Property

This property represents the DisclosureStatus value for a requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As String

value = instance.DisclosureStatus

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property DisclosureStatus As String

C#

[DataMemberAttribute]

public string DisclosureStatus { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.EnforcementDate Property

This property represents the requirement EnforcementDate.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As String

value = instance.EnforcementDate

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property EnforcementDate As String

C#

[DataMemberAttribute]

public string EnforcementDate { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.Feature Property

This property represents the requirement Feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As Feature

value = instance.Feature

Syntax

Visual Basic

<DataMemberAttribute> _

Public MustOverride ReadOnly Property Feature As Feature

C#

[DataMemberAttribute]

public abstract Feature Feature { get; }

Property Value

Returns Feature Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.FullName Property

This property represents the requirement FullName.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As String

value = instance.FullName

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property FullName As String

C#

[DataMemberAttribute]

public string FullName { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.Name Property

This property represents the requirement name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As String

value = instance.Name

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Name As String

C#

[DataMemberAttribute]

public string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.RequirementStatus Property

This property represents the requirement Status.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As String

value = instance.RequirementStatus

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property RequirementStatus As String

C#

[DataMemberAttribute]

public string RequirementStatus { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Requirement.SupportedPlatforms Property

This property represents all of the Platforms that this requirement supports.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Requirement

Dim value As ReadOnlyCollection(Of OSPlatform)

value = instance.SupportedPlatforms

Syntax

Visual Basic

Public MustOverride ReadOnly Property SupportedPlatforms As ReadOnlyCollection(Of OSPlatform)

C#

public abstract ReadOnlyCollection<OSPlatform> SupportedPlatforms { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData Class

This class provides access to the RMS description data.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Syntax

Visual Basic

Public MustInherit Class RequirementDescriptionData

C#

public abstract class RequirementDescriptionData

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.RequirementDescriptionData**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData Members

The following table lists the members exposed by the RequirementDescriptionData type.

Public Properties

Name | Description
BusinessJustification | This property represents the Business justification text for this requirement.
Description | This property represents the description text for this requirement.
Exceptions | This property represents the exceptions text for this requirement.
Language | This property represents the language for this requirement.
Scenarios | This property represents the scenarios text for this requirement.
SuccessMetric | This property represents the SuccessMetric text for this requirement.
Title | This property represents the Title text for this requirement.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


RequirementDescriptionData Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


RequirementDescriptionData Properties

Public Properties

Name | Description
BusinessJustification | This property represents the Business justification text for this requirement.
Description | This property represents the description text for this requirement.
Exceptions | This property represents the exceptions text for this requirement.
Language | This property represents the language for this requirement.
Scenarios | This property represents the scenarios text for this requirement.
SuccessMetric | This property represents the SuccessMetric text for this requirement.
Title | This property represents the Title text for this requirement.


RequirementDescriptionData.BusinessJustification Property

This property represents the Business justification text for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.BusinessJustification

instance.BusinessJustification = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property BusinessJustification As String

C#

[DataMemberAttribute]

public string BusinessJustification { get; protected set; }

Property Value

Returns String.

Remarks

The data can be in HTML format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData.Description Property

This property represents the description text for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.Description

instance.Description = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Description As String

C#

[DataMemberAttribute]

public string Description { get; protected set; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Remarks

The data can be in HTML format.


RequirementDescriptionData.Exceptions Property

This property represents the exceptions text for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.Exceptions

instance.Exceptions = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Exceptions As String

C#

[DataMemberAttribute]

public string Exceptions { get; protected set; }

Return Value

Returns String.

Remarks

The data can be in HTML format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData.Language Property

This property represents the language for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.Language

instance.Language = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Language As String

C#

[DataMemberAttribute]

public string Language { get; protected set; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData.Scenarios Property

This property represents the scenarios text for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.Scenarios

instance.Scenarios = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Scenarios As String

C#

[DataMemberAttribute]

public string Scenarios { get; protected set; }

Return Value

Returns String.

Remarks

The data can be in HTML format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData.SuccessMetric Property

This property represents the SuccessMetric text for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.SuccessMetric

instance.SuccessMetric = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property SuccessMetric As String

C#

[DataMemberAttribute]

public string SuccessMetric { get; protected set; }

Return Value

Returns String.

Remarks

The data can be in HTML format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementDescriptionData.Title Property

This property represents the title text for this requirement.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementDescriptionData

Dim value As String

value = instance.Title

instance.Title = value

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Title As String

C#

[DataMemberAttribute]

public string Title { get; protected set; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementException Class

This class is defined to represent exceptions related to requirements.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RequirementException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class RequirementException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class RequirementException: ProjectManagerException

Inheritance Hierarchy

System.Object

 [ProjectManagerException Class](projectmanagerexception-class.md)

      **Microsoft.Windows.Kits.Hardware.ObjectModel.RequirementException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementException Members

The following table lists the members exposed by the RequirementException type.

Public Constructors

Name | Description
RequirementException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


RequirementException Constructor

Overload List

Name | Description
RequirementException () | This constructor initializes a new instance of the RequirementException class.
RequirementException (String) | This constructor initializes a new instance of the RequirementException class.
RequirementException (String, Exception) | This constructor initializes a new instance of the RequirementException class.


RequirementException Constructor ()

This constructor initializes a new instance of the RequirementException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New RequirementException

Syntax

Visual Basic

Public Sub New

C#

public RequirementException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementException Constructor (String)

This constructor initializes a new instance of the RequirementException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New RequirementException(message)

Syntax

Visual Basic

Public Sub New

      `message As String _`

)

C#

Public RequirementException (

      `string message`

)

Parameters

message

 A string that represents the message for the exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementException Constructor (String, Exception)

This constructor initializes a new instance of the RequirementException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New RequirementException(message, except)

Syntax

Visual Basic

Public Sub New

      `message As String _`

      `except As Exception _`

)

C#

Public RequirementException (

      `string message`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An exception object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RequirementException Methods

The following tables list the methods exposed by the RequirementException type.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


RequirementException Properties

The following tables list the properties exposed by the RequirementException type.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


RequirementException Events

The following table lists the events exposed by the RequirementException type.

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


RoleConstraint Structure

This class defines a constraint on a test dimension.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RoleConstraint

Syntax

Visual Basic

Public Structure RoleConstraint

C#

public struct RoleConstraint

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RoleConstraint Members

Public Properties

Name | Description
DimensionName | This property represents the name of the dimension.
DimensionValues | This property represents a list of values that can be part of this constraint.

Public Methods

Name | Description
Equals | Overridden. This method acts as an Equality operator. The method returns True or False depending on whether the objects being compared are the same.
GetHashCode | Overridden. This method returns a hash value for this class instance..
GetType | (Inherited from Object)
Equality | This method acts as an Equality operator. The method returns False if either operand is null, otherwise returns True or False depending on the parameter values.
Inequality | This method acts as an InEquality operator. It returns false if either operand is null.
ToString | (Inherited from ValueType)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


RoleConstraint Methods

Public Methods

Name | Description
Equals | Overridden. This method acts as an Equality operator. The method returns True or False depending on whether the objects being compared are the same.
GetHashCode | Overridden. This method returns a hash value for this class instance..
GetType | (Inherited from Object)
Equality | This method acts as an Equality operator. The method returns False if either operand is null, otherwise returns True or False depending on the parameter values.
Inequality | This method acts as an InEquality operator. It returns false if either operand is null.
ToString | (Inherited from ValueType)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


RoleConstraint.Equals Method

This method acts as an Equality operator. The method returns True or False depending on whether the objects being compared are the same.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RoleConstraint

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **RoleConstraint** object.

Return Value

true if the two objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RoleConstraint.GetHashCode Method

This method returns a hash code for a RoleConstraint object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RoleConstraint

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number representing this object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RoleConstraint.Equality Method

This method acts as an Equality operator. The method returns False if either operand is null, otherwise returns True or False depending on the parameter values.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As RoleConstraint

Dim second As RoleConstraint

Dim returnValue As Boolean

returnValue = (first = second)

Syntax

Visual Basic

Public Shared Operator = ( _

      `first As As RoleConstraint, _`

      `second As RoleConstraint _`

) As Boolean

C#

public static bool operator == (

 `RoleConstraint first,`

 `RoleConstraint second`

)

Parameters

first

      The first value to compare against.

second

      The second value to compare against.

Return Value

true if the objects are equal; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RoleConstraint.Inequality Method

This method acts as an InEquality operator. It returns false if either operand is null.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim first As RoleConstraint

Dim second As RoleConstraint

Dim returnValue As Boolean

returnValue = (first <> second)

Syntax

Visual Basic

Public Shared Operator <> ( _

 `first As RoleConstraint, _`

 `second As RoleConstraint _`

) As Boolean

C#

public static bool operator != (

      `RoleConstraint first,`

      `RoleConstraint second`

)

Parameters

first

      The first value to compare against.

second

      The second value to compare against.

Return Value

true if the objects are not equal, or false if the objects are the same or if either object is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RoleConstraint Properties

Public Properties

Name | Description
DimensionName | This property represents the name of the dimension.
DimensionValues | This property represents a list of values that can be part of this constraint.


RoleConstraint.DimensionName Property

This property represents the name of the dimension.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RoleConstraint

Dim value As String

value = instance.DimensionName

Syntax

Visual Basic

Public ReadOnly Property DimensionName As String

C#

public string DimensionName { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RoleConstraint.DimensionValues Property

This property represents a list of values that can be part of this constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As RoleConstraint

Dim value As IEnumerable(Of String)

value = instance.DimensionValues

Syntax

Visual Basic

Public ReadOnly Property DimensionValues As IEnumerable(Of String)

C#

public IEnumerable<string> DimensionValues { get; }

Property Value

Returns IEnumerable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ScheduleException Class

This class is a base class for all Windows HCK Studio exceptions.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As ScheduleException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class ScheduleException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class ScheduleException: ProjectManagerException

Inheritance Hierarchy

System.Object

 **System.Exception**

      [ProjectManagerException Class](projectmanagerexception-class.md)

                **Microsoft.Windows.Kits.Hardware.ObjectModel.ScheduleException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ScheduleException Members

The following table lists the members exposed by the ScheduleException type.

Public Constructors

Name | Description
ScheduleException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


ScheduleException Constructor

Overload List

Name | Description
MachineException Constructor () | This constructor initializes a new instance of the ScheduleException class.
MachineException Constructor (String) | This constructor initializes a new instance of the ScheduleException class.
MachineException Constructor (String, Exception) | This constructor initializes a new instance of the ScheduleException class.


ScheduleException Constructor ()

This constructor initializes a new instance of the ScheduleException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New ScheduleException

Syntax

Visual Basic

Public Sub New

C#

public ScheduleException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ScheduleException Constructor (String)

This constructor initializes a new instance of the ScheduleException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New ScheduleException(message)

Syntax

Visual Basic

Public Sub New

      `message As String _`

)

C#

Public ScheduleException (

      `string message`

)

Parameters

message

 A string that represents the message for the exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ScheduleException Constructor (String, Exception)

This constructor initializes a new instance of the ScheduleException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New ScheduleException(message, except)

Syntax

Visual Basic

Public Sub New

      `message As String _`

      `except As Exception _`

)

C#

Public ScheduleException (

      `string message`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An exception object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ScheduleException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)


ScheduleException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


ScheduleException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


Target Class

This class represents a single test target that can be detected on a system (a piece of hardware, a driver, and so on).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class Target

      `Implements ITargetInformation`

C#

[DataContractAttribute]

public abstract class Target : ITargetInformation

Remarks

A Target contains information that is in XML format. Features have an XPATH query that can return specific nodes from the XML data. All Feature objects in the system are detected for the Target. Since a Feature object is associated with Requirement objects which are associated with Test objects, you can generate a test list.

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.Target**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageTarget**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target Members

This class represents an abstract pool of machines that are grouped together based on a user intention. It exposes functionality that enables machines to be regrouped among different machine pools and manage the resource pool hierarchy.

Public Properties

Name | Description
DriverStatus | This property represents the driver status of the test target.
IsTargetReady | This property represents the value indicating whether the test target is currently ready to run tests (specifically, the test computer is in the "ready" state).
Key | This property represents the string that uniquely identifies this test target. In case of a device, for example, this would be the hardware ID.
Machine | This property represents the machine (test computer) that this test target was detected on.
Name | This property represents the name of the test target to display to the users.
TargetFamily | This property represents the product instance that this test target is associated with.
TargetType | This property represents the type of this test target.
XmlData | This property represents the sysparse data associated with this test target.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase Class)

Public Methods

Name | Description
AddFeature | This method adds a Feature.
Equals | Overloaded. Overridden.
GetDrivers | Gets a list of drivers.
GetFeatures | This method retrieves the list of features that is associated with the Target.
GetHashCode | (Inherited from Object)
GetTestResults | Gets a read-only collection of test results for tests for this Target.
GetTests | Gets all tests for this Target.
GetType | (Inherited from Object)
RedistributeScheduledTests | Method to redistribute tests across targets which have been added to a project.
RemoveFeature | Overloaded.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Target Methods

Public Methods

Name | Description
AddFeature | This method adds a Feature.
Equals | Overloaded. Overridden.
GetDrivers | Gets a list of drivers.
GetFeatures | This method retrieves the list of features that is associated with the Target.
GetHashCode | (Inherited from Object)
GetTestResults | Gets a read-only collection of test results for tests for this Target.
GetTests | Gets all tests for this Target.
GetType | (Inherited from Object)
RedistributeScheduledTests | Method to redistribute tests across targets which have been added to a project.
RemoveFeature | Overloaded.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Target.AddFeature Method

This method adds a Feature.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract void AddFeature (

      `Feature feature`

)

Parameters

feature

The feature to add to the test target.

Remarks

When features are added using this method, the features were not automatically detected. Using this method will introduce all the tests associated with the feature to the target and those tests will have to run and pass. Since the feature was not detected, there is a chance that the added tests may fail.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.GetDrivers Method

Gets a list of drivers.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract IEnumerable<Driver> GetDrivers()

Return Value

Returns a list of drivers associated with this target.

Remarks

This function will return drivers only when connected to a package. If not connected to a package, an empty list is returned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.GetFeatures Method

This method retrieves the list of features that is associated with the Target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Overridable Function GetFeatures() As ReadOnlyCollection(Of Feature)

C#

public virtual ReadOnlyCollection<Feature> GetFeatures()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.GetTestResults Method

Gets a read-only collection of test results for tests for this Target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual ReadOnlyCollection<TestResult> GetTests()

Return Value

Returns a read-only collection of TestResult objects.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.GetTests Method

Gets all tests for this Target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual List<Test> GetTests()

Return Value

Returns a Test Collection of all of the tests.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.RedistributeScheduledTests Method

Method to redistribute tests across targets which have been added to a project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static void RedistributeScheduledTests (

      `IEnumerable<Target> newTargets,`

      `out IList<TestResult> cancelFailedResults,`

      `out IList<TestResult> cancelledResults,`

      `out IList<TestResult> scheduledResults,`

      `out IList<Test> rescheduleFailedTests`

)

Parameters

newTargets

List of targets to redistribute test across.

cancelFailedResults

List of results that failed to be cancelled before a reschedule.

cancelledResults

List of results that were cancelled and then rescheduled.

scheduledResults

List of newly scheduled results that replaced the results that a cancel was attempted on regardless of success.

rescheduleFailedTests

List of tests that failed to be rescheduled.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.RemoveFeature Method

Overload List

Name | Description
Target.RemoveFeature (Feature) | This method removes a manually added RMS feature from a test target.
Target.RemoveFeature (String) | This method removes a manually added RMS feature from a test target.


Target.RemoveFeature Method (Feature)

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim feature As Feature

instance.RemoveFeature(feature)

Syntax

Visual Basic

Public MustOverride Sub RemoveFeature ( _

      `feature As Feature _`

)

C#

Public abstract void RemoveFeature (

      `Feature feature`

)

Parameters

feature

 The feature to remove.

Remarks

An exception is thrown when the feature to remove was not manually added, or is not present.

Only features that are added by using the AddFeature method can be deleted.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.RemoveFeature Method (String)

This method removes a manually added RMS feature from a test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim featureName As Feature

instance.RemoveFeature(featureName)

Syntax

Visual Basic

Public MustOverride Sub RemoveFeature ( _

      `featureName As String _`

)

C#

Public abstract void RemoveFeature (

      `string featureName`

)

Parameters

featureName

 The name of the feature to remove.

Remarks

An exception is thrown when the feature to remove was not manually added, or is not present.

Only features that are added by using the AddFeature method can be deleted.

This method is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target Properties

[This content is not available in this preliminary release.]

Public Properties

Name | Description
DriverStatus | This property represents the driver status of the test target.
IsTargetReady | This property represents the value indicating whether the test target is currently ready to run tests (specifically, the test computer is in the "ready" state).
Key | This property represents the string that uniquely identifies this test target. In case of a device, for example, this would be the hardware ID.
Machine | This property represents the machine (test computer) that this test target was detected on.
Name | This property represents the name of the test target to display to the users.
TargetFamily | This property represents the product instance that this test target is associated with.
TargetType | This property represents the type of this test target.
XmlData | This property represents the sysparse data associated with this test target.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase Class)


Target.DriverStatus Property

This property represents the driver status of the test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As TargetDriversType

value = instance.DriverStatus

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property DriverStatus As TargetDriversType

C#

[DataMemberAttribute]

public TargetDriversType DriverStatus { get; }

Return Value

Returns TargetDriversType Enumeration.

Remarks

The status provides information on the driver that is associated with the target. The value is estimated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.IsTargetReady Property

This property represents the value indicating whether the test target is currently ready to run tests (specifically, the test computer is in the "ready" state).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As Boolean

value = instance.IsTargetReady

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property IsTargetReady As Boolean

C#

[IgnoreDataMemberAttribute]

public abstract bool IsTargetReady { get; }

Return Value

Returns Boolean.

Remarks

Readiness is determined by the following checks.

  • The machine associated with the target is in ready state.

  • The machine associated with the target has a recent heartbeat (registered with the controller).

  • The machine associated with the target is in the correct machine pool (pool specified with the product instance).

If the returned value is false, Tests for this target cannot be scheduled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.Key Property

This property represents the string that uniquely identifies this test target. In case of a device, for example, this would be the hardware ID.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As String

value = instance.Key

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Key As String

C#

[DataMemberAttribute]

public string Key { get; }

Return Value

Returns String.

Remarks

In the case of a device, for example, the key is the hardware id.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.Machine Property

This property represents the machine (test computer) that this test target was detected on.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As Machine

value = instance.Machine

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Machine As Machine

C#

[DataMemberAttribute]

public Machine Machine { get; }

Return Value

Returns Machine Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.Name Property

This property represents the name of the test target to display to the users.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As String

value = instance.Name

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Name As String

C#

[DataMemberAttribute]

public string Name { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.TargetFamily Property

This property represents the product instance that this test target is associated with.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As TargetFamily

value = instance.TargetFamily

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public Property TargetFamily As TargetFamily

C#

[IgnoreDataMemberAttribute]

public TargetFamily TargetFamily { get; }

Return Value

Returns TargetFamily Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.TargetType Property

This property represents the type of this test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As TargetType

value = instance.TargetType

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property TargetType As TargetType

C#

[DataMemberAttribute]

public TargetType TargetType { get; }

Return Value

Returns TargetType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Target.XmlData Property

This property represents the sysparse data associated with this test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Target

Dim value As String

value = instance.XmlData

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property XmlData As String

C#

[DataMemberAttribute]

public string XmlData { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData Class

This class offers an interface to the data store backing the target data.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Syntax

Visual Basic

Public MustInherit Class TargetData

      `Implements ITargetInformation`

C#

public abstract class TargetData : ITargetInformation

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.TargetData**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData Members

This class represents an abstract pool of machines that are grouped together based on a user intention. It exposes functionality that enables machines to be regrouped among different machine pools and manage the resource pool hierarchy.

Public Properties

Name | Description
AllInboxDrivers |
Description |
Key |
Machine |
Name |
TargetType |
XmlData |

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TargetData Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TargetData Properties

Public Properties

Name | Description
AllInboxDrivers | This property represents the driver status for this test target.
Description | This property represents the test target description.
Key | This property represents the unique key of the test target.
Machine | This property represents the machine (test computer) that the target is in, or connected to.
Name | This property represents the target name.
TargetType | This property represents the type of the test target.
XmlData | This property represents the raw XML data representing the target.


TargetData.AllInboxDrivers Property

This property represents the driver status for this test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As TargetDriversType

value = instance.AllInboxDrivers

Syntax

Visual Basic

Public MustOverride ReadOnly Property AllInboxDrivers As TargetDriversType

C#

public abstract TargetDriversType AllInboxDrivers { get; }

Property Value

Returns TargetDriversType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData.Description Property

This property represents the test target description.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As String

value = instance.Description

Syntax

Visual Basic

Public MustOverride ReadOnly Property Description As String

C#

public abstract string Description { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData.Key Property

This property represents the unique key of the test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As String

value = instance.Key

Syntax

Visual Basic

Public MustOverride ReadOnly Property Key As String

C#

public abstract string Key { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData.Machine Property

This property represents the machine (test computer) that the target is in, or connected to.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As Machine

value = instance.Machine

Syntax

Visual Basic

Public MustOverride ReadOnly Property Machine As Machine

C#

public abstract Machine Machine { get; }

Property Value

Returns Machine Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData.Name Property

This property represents the target name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public MustOverride ReadOnly Property Name As String

C#

public abstract string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData.TargetType Property

This property represents the type of the test target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As TargetType

value = instance.TargetType

Syntax

Visual Basic

Public MustOverride ReadOnly Property TargetType As TargetType

C#

public abstract TargetType TargetType { get; }

Property Value

Returns TargetType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetData.XmlData Property

This property represents the raw XML data representing the target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetData

Dim value As String

value = instance.XmlData

Syntax

Visual Basic

Public MustOverride ReadOnly Property XmlData As String

C#

public abstract string XmlData { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetDriversType Enumeration

This enumeration defines the target driver settings values.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetDriversType

Syntax

Visual Basic

Public Enumeration TargetDriversType

C#

public enum TargetDriversType

Members

Member name | Description
InboxDrivers | This enum value identifies a TargetDriverType as an inbox driver. Specifically, the test target uses only inbox or system drivers.
NoDriversRequired | This enum value indicates that a driver is not needed for a specific device on a test target. This is usually for a system or network-attached device.
ProvidedDrivers | This enum value identifies a TargetDriverType as vernodr-provided driver. The test target uses drivers that must be provided prior to testing.
InboxDriversOverridden | This enum value identifies a TargetDriverType as inbox or system drivers, but has been overridden.


TargetException Class

This class contains constructors used to initialize TargetException objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class TargetException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class TargetException: ProjectManagerException

Inheritance Hierarchy

System.Object

 **System.Exception**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException**

                **Microsoft.Windows.Kits.Hardware.ObjectModel.TargetException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetException Members

The following table lists the members exposed by the ProjectManagerException type.

Public Constructors

Name | Description
TargetException | Overloaded. This constructor initializes a new instance of the TargetException class.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


TargetException Constructor

Overload List

TargetException () | This constructor initializes a new instance of the TargetException class.
TargetException (String) | This constructor initializes a new instance of the TargetException class.
TargetException (String, Exception) | This constructor initializes a new instance of the TargetException class.


TargetException Constructor ()

This constructor initializes a new instance of the TargetException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New TargetException

Syntax

Visual Basic

Public Sub New

C#

public TargetException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetException Constructor (String)

This constructor initializes a new instance of the TargetException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New TargetException(message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public TargetException (

      `string message`

)

Parameters

message

 A string that represents the message for the exception.


TargetException Constructor (String, Exception)

This constructor initializes a new instance of the TargetException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New TargetException (message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String, _`

      `except As Exception _`

)

C#

public TargetException (

      `string message,`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An **Exception** object.


TargetException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | Overridden.
MemberwiseClone | (Inherited from Object)


TargetException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


TargetException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


TargetFamily Class

This class represents a group of test targets that correspond to WLP POLICY-0004.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class TargetFamily

C#

[DataContractAttribute]

public abstract class TargetFamily

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.TargetFamily**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily Members

The following table lists the members exposed by the TargetFamily Class.

Public Properties

Name | Description
Family |
IsValid |
ProductInstance |

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
AddTests | Adds the given Tests to this TargetFamily. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
CreateTarget | Creates a target from a TargetData object, and adds it to a target family. Warning Some overloads of this method are being deprecated. Please use CreateTarget(IEnumerable<TargetData>).
DeleteTarget | This method deletes a test target from a target family.
Equals | (Inherited from Object)
GetFeatures | This method retrieves a list of features for this TargetFamily.
GetHashCode | (Inherited from Object)
GetTargets | This method retrieves a list of test targets that have been assigned to this Device Family.
GetTestResults | This method retrieves a list of results for this TargetFamily.
GetTests | This method retrieves a list of all of the tests needed for this TargetFamily.
GetType | (Inherited from Object)
IsValidTarget | Checks to see if the TargetData can be a member of this target family.
QueueTest | Overloaded.
SetCommonParameters | This method sets all of the parameters with a given name to the same value for all child jobs.
TargetsAreValidInSameTargetFamily | This method checks to see if the two TargetData objects can be members of the same target family.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TargetFamily Methods

Public Methods

Name | Description
AddTests | Adds the given Tests to this TargetFamily. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
CreateTarget | Creates a target from a TargetData object, and adds it to a target family. Warning Some overloads of this method are being deprecated. Please use CreateTarget(IEnumerable<TargetData>).
DeleteTarget | This method deletes a test target from a target family.
Equals | (Inherited from Object)
GetFeatures | This method retrieves a list of features for this TargetFamily.
GetHashCode | (Inherited from Object)
GetTargets | This method retrieves a list of test targets that have been assigned to this Device Family.
GetTestResults | This method retrieves a list of results for this TargetFamily.
GetTests | This method retrieves a list of all of the tests needed for this TargetFamily.
GetType | (Inherited from Object)
IsValidTarget | Checks to see if the TargetData can be a member of this target family.
QueueTest | Overloaded.
RemoveTests | Removes the given Tests from this TargetFamily. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetCommonParameters | This method sets all of the parameters with a given name to the same value for all child jobs.
TargetsAreValidInSameTargetFamily | This method checks to see if the two TargetData objects can be members of the same target family.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Public Properties

Name | Description
Family | This property represents the DeviceFamily object associated with this TargetFamily.
IsValid |
ProductInstance | This property represents the ProductInstance parent object of this TargetFamily.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


TargetFamily.AddTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Overload List

Name | Description
AddTests Method (IEnumerable<TestDefinition>) | Adds the given Tests to this TargetFamily.
AddTests Method (IEnumerable<TestDefinition>, bool) | Adds the given Tests to this TargetFamily.


TargetFamily.AddTests Method (IEnumerable TestDefinition )

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Adds the given Tests to this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be added.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.AddTests Method (IEnumerable TestDefinition , bool)

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Adds the given Tests to this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests,`

      `bool disableFeatureDetection`

)

Parameters

tests

The tests to be added.

disableFeatureDetection

Flag that causes all the tests to be added to Targets regardless of feature detection.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.CreateTarget Method

Overload List

Name | Description
CreateTarget Method (TargetData) | This method creates a target from a TargetData object, and adds it to a target family.
CreateTarget Method (TargetData, bool) | This method creates a target from a TargetData object, and adds it to a target family. Warning This method is being deprecated. Please use CreateTarget(IEnumerable<TargetData>) instead.
CreateTarget Method (IEnumerable<TargetData>) | This method creates a target from a TargetData object, and adds it to a target family.
CreateTarget Method (IEnumerable<TargetData>, bool) | Creates multiple targets from a collection of TargetData, and adds it to the target family. Warning This method is being deprecated. Please use CreateTarget(IEnumerable<TargetData>) instead.


TargetFamily.CreateTarget Method (TargetData)

This method creates a target from a TargetData object, and adds it to a target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim target As TargetData

Dim returnValue As Target

returnValue = instance.CreateTarget(target)

Syntax

Visual Basic

Public MustOverride Function CreateTarget ( _

      `target As TargetData _`

) As Target

C#

public abstract Target CreateTarget (

      `TargetData target`

)

Parameters

target

 Target data to create a target from.

Return Value

Returns Target Class, which is the name of the target that was created.

Remarks

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.CreateTarget Method (TargetData, bool)

WARNING

This method is being deprecated. Please use CreateTarget(IEnumerable<TargetData>) instead.

Creates a target from a Target data, and adds it to the target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract Target CreateTarget (

      `TargetData target,`

      ` bool createWithoutAddingTests`

)

Parameters

target

Target data to create a target.

createWithoutAddingTests

A flag to create the Target without adding any Tests.

Return Value

Returns the Target object that was created.

Remarks

This is not supported when the project is connected to a package.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.CreateTarget Method (IEnumerable)

This method creates a target from a TargetData object, and adds it to a target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim targets As IEnumerable(Of TargetData)

instance.CreateTarget(targets)

Syntax

Visual Basic

Public Sub CreateTarget ( _

      `targets As IEnumerable(Of TargetData) _`

)

C#

public void CreateTarget (

      `IEnumerable<TargetData> targets`

)

Parameters

targets

 The list of test targets to which to add the contents of the [TargetData Class](targetdata-class.md) object.

Remarks

This is not an atomic operation. If an exception is thrown while adding the targets, it is possible that only a subset of the targets was added.

Targets are added in the order provided in the collection.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.CreateTarget Method (IEnumerable TargetData , bool)

WARNING

This method is being deprecated. Please use CreateTarget(IEnumerable<TargetData>) instead.

Creates multiple targets from a collection of TargetData, and adds it to the target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void CreateTarget (

      `IEnumerable<TargetData> targets, `

      ` bool createWithoutAddingTests`

)

Parameters

targets

Collection of TargetData objects.

createWithoutAddingTests

A flag to create the Target without adding any Tests.

Remarks

This is not an atomic operation - if an exception is thrown while adding the targets, it is possible that only a subset of the targets was added. Typically the targets that were added before the exception. The targets are added in the order provided in the collection.

This is not supported when the project is connected to a package.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.DeleteTarget Method

This method deletes a test target from a target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim targetToDelete As Target

instance.DeleteTarget(targetToDelete)

Syntax

Visual Basic

Public MustOverride Sub DeleteTarget ( _

      `targetToDelete As Target _`

)

C#

public abstract void DeleteTarget (

      `Target targetToDelete`

)

Parameters

targetToDelete

 The test target to delete.

Remarks

All results associated with the target are also deleted.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.GetFeatures Method

This method retrieves a list of features for this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim returnValue As ReadOnlyCollection(Of Feature)

returnValue = instance.GetFeatures

Syntax

Visual Basic

Public MustOverride Function GetFeatures As ReadOnlyCollection(Of Feature)

C#

public abstract ReadOnlyCollection<Feature> GetFeatures ()

Return Value

Returns ReadOnlyCollection, which is the collection of features.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.GetTargets Method

This method retrieves a list of test targets that have been assigned to this Device Family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim returnValue As ReadOnlyCollection(Of Target)

returnValue = instance.GetTargets

Syntax

Visual Basic

Public MustOverride Function GetTargets As ReadOnlyCollection(Of Target)

C#

public abstract ReadOnlyCollection<Target> GetTargets ()

Return Value

Returns ReadOnlyCollection, which is a read-only collection of test targets for this target family.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.GetTestResults Method

Gets a read-only collection of test results for tests in this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual ReadOnlyCollection<TestResult> GetTestResults ()

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.GetTests Method

Gets all tests for this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual IList<Test> GetTests()

Return Value

Returns a Test Collection of all of the tests..

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.IsValidTarget Method

Overload List

Name | Description
TargetFamily.IsValidTarget (TargetData) | Checks to see if the TargetData can be a member of this target family.
TargetFamily.IsValidTarget (TargetData, StringBuilder) | Checks to see if the TargetData can be a member of this target family.


TargetFamily.IsValidTarget Method (TargetData)

This method determines whether the specified TargetData can be a member of this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Function IsValidTarget ( _

      `target As TargetData _`

) As Boolean

C#

public bool IsValidTarget (

      `TargetData target`

)

Parameters

target

 Target data to examine.

Return Value

Returns bool.

Remarks

The following conditions determine validity.

  1. The Machine of the target is in the same machine pool as the ProductInstance.

  2. The Machine of the target has the same OS Platform as the ProductInstance (parent) object.

  3. All targets having common manufacturer/VID/Ven.

  4. All targets having common driver hash (of all drivers associated with this device, including any upper and lower filters).

  5. All targets having a common INF hash.

  6. All targets having the same bus/enumerator type.

  7. All targets having the same class/subclass.

  8. If DX capable, same DX major version.

  9. All targets are on unique machines not already part of the TargetFamily. Note that different targets under a product instance are supported on one machine.

  10. All targets must be in the running state.

  11. Each machine associated with the Target family is running the same version of the OSPlatform as the product instance.

If any of the checks fail, the method returns false.

This specifically allows different Device ID, PID (Product Id) or "Dev" and different sub vendor or implementer Ids.

If the comparison fails, this method populates the event log with additional data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.IsValidTarget Method (TargetData, StringBuilder)

This method determines whether the specified TargetData can be a member of this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Function IsValidTarget ( _

      `target As TargetData, _`

      `stringBuilder As StringBuilder _`

) As Boolean

C#

public bool IsValidTarget (

      `TargetData target,`

      `StringBuilder stringBuilder`

)

Parameters

target

 Target data to examine.

stringBuilder

 String builder that contains information on any checks that fail.

Return Value

Returns true if the target can be a member of the target family; otherwise, false.

Remarks

The following conditions determine validity.

  1. The Machine of the target is in the same machine pool as the ProductInstance.

  2. The Machine of the target has the same OS Platform as the ProductInstance (parent) object.

  3. All targets having common manufacturer/VID/Ven.

  4. All targets having common driver hash (of all drivers associated with this device, including any upper and lower filters).

  5. All targets having a common INF hash.

  6. All targets having the same bus/enumerator type.

  7. All targets having the same class/subclass.

  8. If DX capable, same DX major version.

  9. All targets are on unique machines not already part of the TargetFamily. Note that different targets under a product instance are supported on one machine.

  10. All targets must be in the running state.

  11. Each machine associated with the Target family is running the same version of the OSPlatform as the product instance.

If any of the checks fail, the method returns false.

This specifically allows different Device ID, PID (Product Id) or "Dev" and different sub vendor or implementer Ids.

If the comparison fails, this method populates the event log with additional data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.QueueTest Method

Overload List

Name | Description
TargetFamily.QueueTest () | This method schedules this object to run.
TargetFamily.QueueTest (MachineSet) | This method schedules a test to be run against a target family. The test computer is always part of the machine set (this is only for additional test computers).
TargetFamily.QueueTest(IEnumerable<Machine>) | This method schedules the test for execution on a specific subset of machines.


TargetFamily.QueueTest Method ()

This method schedules this object to run.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest

Syntax

Visual Basic

Public Overridable Function QueueTest As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest ()

Return Value

Returns IList, which is a list of results for the jobs that were scheduled.

Remarks

QueueTest attempts to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately and the method returns. The function will leave some tests scheduled and some that are incomplete. The returned list identifies the tests that were scheduled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.QueueTest Method (MachineSet)

This method schedules a test to be run against a target family. The test computer is always part of the machine set, this is only for additional test computers.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim logicalMachineSet As MachineSet

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest(logicalMachineSet)

Syntax

Visual Basic

Public Overridable Function QueueTest ( _

      `logicalMachineSet As MachineSet _`

) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest (

      `MachineSet logicalMachineSet`

)

Parameters

logicalMachineSet

 The list of test computers on which a test should run.

Return Value

Returns IList, which is a list of results for the jobs that were scheduled.

Remarks

The machine associated with the selected target is automatically added to the set.

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediatelyand an exception is thrown. As a result, some tests could be scheduled, while others are not.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.QueueTest Method (IEnumerable Machine )

This method schedules a test to be run against a specified subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Overridable Function QueueTest ( _

      `machineList As IEnumerable(Of Machine)) _`

) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest (

      `IEnumerable<Machine> machineList`

)

Parameters

machineList

 The list of test computers on which a test should run.

Return Value

Returns IList, which is a list of results for the jobs that were scheduled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


RemoveTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Removes the given Tests from this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void RemoveTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be removed.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.SetCommonParameters Method

This method sets all of the parameters with a given name to the same value for all child jobs.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim parameterName As String

Dim parameterValue As String

instance.SetCommonParameters(parameterName, parameterValue)

Syntax

Visual Basic

Public Sub SetCommonParameters ( _

      `parameterName As String, _`

      `parameterValue As String, _`

)

C#

public void SetCommonParameters (

      `string parameterName,`

      `string parameterValue,`

)

Parameters

parameterName

 The name (string) of the parameter to set.

parameterValue

 The value to set the parameter to.

Remarks

Setting a parameter value to empty is supported.

Setting a value to null is not supported.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamliy.TargetsAreValidInSameTargetFamily Method

Overload List

Name | Description
TargetsAreValidInSameTargetFamily Method (TargetData, TargetData, ProjectManager) | This method checks to see if the two TargetData objects can be members of the same target family.
TargetsAreValidInSameTargetFamily Method (TargetData, TargetData, ProjectManager, StringBuilder) | This method checks to see if the two TargetData objects can be members of the same target family.


TargetFamily.TargetsAreValidInSameTargetFamily Method (TargetData, TargetData, ProjectManager)

Checks to see if the two TargetData objects can be members of the same target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static bool TargetsAreValidInSameTargetFamily (

      `TargetData firstTarget,`

      `TargetData secondTarget,`

      `ProjectManager manager`

)

Parameters

firstTarget

First instance of TargetData to compare.

secondTarget

Second instance of TargetData to compare.

manager

Instance of ProjectManager.

Return Value

Returns true if these two targets are similar enough to be in the same target family; otherwise it returns false.

Remarks

There are a number of checks done:

  • The Machine of the targets are in the same machine pool.

  • The Machine of the targets have the same OS Platform.

  • Both targets are the same target type.

  • Both targets have common manufacturer/VID/Ven.

  • Both targets have common driver hash (of all drivers associated with this device, including any upper and lower filters).

  • Both targets have a common INF hash.

  • Both targets have the same bus/enumerator type.

  • Both targets have the same class/subclass.

  • If DX capable, same DX major version.

  • All targets are on unique machines.

If any of the checks fail, the method returns false.

NOTE

This specifically allows different Device ID, PID (Product Id) or "Dev" and different sub vendor or implementer Ids.

NOTE

This function populates the event log with additional data if the comparison has failed.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.TargetsAreValidInSameTargetFamily Method (TargetData, TargetData, ProjectManager, StringBuilder)

Checks to see if the two TargetData objects can be members of the same target family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static bool TargetsAreValidInSameTargetFamily (

      `TargetData firstTarget,`

      `TargetData secondTarget,`

      `ProjectManager manager,`

      `StringBuilder builder`

)

Parameters

firstTarget

First instance of TargetData to compare.

secondTarget

Second instance of TargetData to compare.

manager

Instance of ProjectManager.

builder

String builder that will contain information on any checks that fail.

Return Value

Returns true if these two targets are similar enough to be in the same target family; otherwise it returns false.

Remarks

There are a number of checks done:

  • The Machine of the targets are in the same machine pool.

  • The Machine of the targets have the same OS Platform.

  • Both targets are the same target type.

  • Both targets have common manufacturer/VID/Ven.

  • Both targets have common driver hash (of all drivers associated with this device, including any upper and lower filters).

  • Both targets have a common INF hash.

  • Both targets have the same bus/enumerator type.

  • Both targets have the same class/subclass.

  • If DX capable, same DX major version.

  • All targets are on unique machines.

If any of the checks fail, the method returns false.

NOTE

This specifically allows different Device ID, PID (Product Id) or "Dev" and different sub vendor or implementer Ids.

NOTE

This function populates the event log with additional data if the comparison has failed.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily Properties

Public Properties

Name | Description
Family | This property represents the DeviceFamily object associated with this TargetFamily.
GroupID | This property represents a unique Id associated with this TargetFamily.
IsValid | This property indicates whether this target family is valid.
ProductInstance | This property represents the ProductInstance parent object of this TargetFamily.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


TargetFamily.Family Property

This property represents the DeviceFamily object associated with this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim value As DeviceFamily

value = instance.Family

Syntax

Visual Basic

Public Property Family As DeviceFamily

C#

public DeviceFamily Family { get; }

Property Value

Returns DeviceFamily Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


GroupID Properties

This property represents a unique Id associated with this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Property GroupId As Integer

C#

public int GroupId

Property Value

Returns DeviceFamily Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.IsValid Property

This property indicates whether this target family is valid.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim value As Boolean

value = instance.IsValid

Syntax

Visual Basic

Public ReadOnly Property IsValid As Boolean

C#

public bool IsValid { get; }

Property Value

Returns bool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetFamily.ProductInstance Property

This property represents the ProductInstance Class parent object of this TargetFamily.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetFamily

Dim value As ProductInstance

value = instance.ProductInstance

Syntax

Visual Basic

Public Property ProductInstance As ProductInstance

C#

public ProductInstance ProductInstance { get; }

Property Value

Returns ProductInstance Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TargetType Enumeration

This is the list of all available test target types. Certification tests runs against a device, software (for example, a filter driver) or a computer.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TargetType

Syntax

Visual Basic

Public Enumeration TargetType

C#

public enum TargetType

Members

Member name | Description
Device | This identifies a test target as a hardware device.
Filter | This specifies that a test target is a filter driver or a driver without hardware to which it is associated.
System | This defines a test target as a system (also referred to as a test computer).
TargetCollection | This target represents a device collection or association to a test target (test computer).


Task Class

This class represents the individual tasks that are run as part of certification tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class Task

C#

[DataContractAttribute]

public abstract class Task

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.Task**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageTask**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task Members

The following table lists the members exposed by the Task Class.

Public Properties

Name | Description
AreFiltersApplied | This property indicates whether filters have been applied for this result.
AssessmentScores | This property represents a collection of assessment scores for this task.
Name | This property represents the name of the task.
Stage | This property represents the stage of the task.
Status | This property represents the status of this task.
TaskErrorMessage | This property represents a message about any errors reported by this task.
TaskType | This property represents the type of this task.
TestResult | This property represents the parent TestResult object for this task.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetAppliedFilters | This method retrieves the filters applied for this task result.
GetChildTasks | This method retrieves a collection of child tasks.
GetHashCode | (Inherited from Object)
GetLogFiles | This method retrieves the log files associated with a test task.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Task Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetAppliedFilters | This method retrieves the filters applied for this task result.
GetChildTasks | This method retrieves a collection of child tasks.
GetHashCode | (Inherited from Object)
GetLogFiles | This method retrieves the log files associated with a test task.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Task.GetAppliedFilters Method

This method retrieves the filters applied for this task result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim returnValue As ReadOnlyCollection(Of IFilter)

returnValue = instance.GetAppliedFilters

Syntax

Visual Basic

Public MustOverride Function GetAppliedFilters As ReadOnlyCollection(Of IFilter)

C#

public abstract ReadOnlyCollection<IFilter> GetAppliedFilters ()

Return Value

Returns ReadOnlyCollection, which is a read-only collection of filters applied to a test task.

Remarks

If the task does not have a TaskResult or the TaskResult status is Not Complete, this method returns an empty collection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.GetChildTasks Method

This method retrieves a collection of child tasks.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim returnValue As ReadOnlyCollection(Of Task)

returnValue = instance.GetChildTasks

Syntax

Visual Basic

Public MustOverride Function GetChildTasks As ReadOnlyCollection(Of Task)

C#

public abstract ReadOnlyCollection<Task> GetChildTasks ()

Return Value

Returns ReadOnlyCollection, which is a collection of child tasks.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.GetLogFiles Method

This method retrieves the log files associated with a test task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim returnValue As ReadOnlyCollection(Of TestLog)

returnValue = instance.GetLogFiles

Syntax

Visual Basic

Public MustOverride Function GetLogFiles As ReadOnlyCollection(Of TestLog)

C#

public abstract ReadOnlyCollection<TestLog> GetLogFiles ()

Return Value

Returns ReadOnlyCollection, which is a collection of log files.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task Properties

Public Properties

Name | Description
AreFiltersApplied | This property indicates whether filters have been applied for this result.
AssessmentScores | This property represents a collection of assessment scores for this task.
Name | This property represents the name of the task.
Stage | This property represents the stage of the task.
Status | This property represents the status of this task.
TaskErrorMessage | This property represents a message about any errors reported by this task.
TaskType | This property represents the type of this task.
TestResult | This property represents the parent TestResult object for this task.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


Task.AreFiltersApplied Property

This property indicates whether filters have been applied for this result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As Boolean

value = instance.AreFiltersApplied

Syntax

Visual Basic

Public Overridable ReadOnly Property AreFiltersApplied As Boolean

C#

public virtual bool AreFiltersApplied

Property Value

Returns bool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.AssessmentScores Property

This property represents a collection of assessment scores for this task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As ReadOnlyCollection(Of AssessmentData)

value = instance.AssessmentScores

Syntax

Visual Basic

Public MustOverride ReadOnly Property AssessmentScores As ReadOnlyCollection(Of AssessmentData)

C#

public abstract ReadOnlyCollection<AssessmentData> AssessmentScores { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.Name Property

This property represents the name of the task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As String

value = instance.Name

Syntax

Visual Basic

Public MustOverride ReadOnly Property Name As String

C#

public abstract string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.Stage Property

This property represents the stage of the task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As String

value = instance.Stage

Syntax

Visual Basic

Public MustOverride ReadOnly Property Stage As String

C#

public abstract string Stage { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.Status Property

This property represents the status of a task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As TestResultStatus

value = instance.Status

Syntax

Visual Basic

Public MustOverride ReadOnly Property Status As TestResultStatus

C#

public abstract TestResultStatus Status { get; }

Property Value

Returns TestResultStatus Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.TaskErrorMessage Property

This property represents a message about any errors reported by this task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As String

value = instance.TaskErrorMessage

Syntax

Visual Basic

Public MustOverride ReadOnly Property TaskErrorMessage As String

C#

public abstract string TaskErrorMessage { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.TaskType Property

This property represents the type of this task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As String

value = instance.TaskType

Syntax

Visual Basic

Public MustOverride ReadOnly Property TaskType As String

C#

public abstract string TaskType { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Task.TestResult Property

This property represents the parent TestResult object for this task.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Task

Dim value As TestResult

value = instance.TestResult

Syntax

Visual Basic

Public MustOverride ReadOnly Property TestResult As TestResult

C#

public abstract TestResult TestResult { get; }

Property Value

Returns TestResult.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TemplateParameter Enumeration

Template parameter option for running tests on a Proxy Client.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public enum TemplateParameter

Members

Member name | Description
ImagePath | Relative Image Path of the FFU or WIM file for flashing a new OS image on the Device Under Test.
TestPackages | Test packages to deploy on the Device Under Test.
ForceReflash | Flag to flash a new OS image on the Device Under Test.
MobileDebuggerPort | Port number to which the Device Under Test will route KD traffic.
ReflashOnFailure | Reflash the Device Under Test after a failure.


TemplateParameters Class

Property bag that represents the template parameter options for running tests on a Proxy Client.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public class TemplateParameters : Dictionary<TemplateParameter, string>

Inheritance Hierarchy

System.Object

 **System.Collections.GenericDictionary&lt;TKey,TValue&gt;**

  **Microsoft.Windows.Kits.Hardware.ObjectModel.TemplateParameters**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test Class

This abstract class represents a certification test. It defines the common behavior and properties every certification test is expected to expose.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Test

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class Test

      `Implements IRunTests`

C#

[DataContractAttribute]

public abstract class Test : IRunTests

Remarks

Some tests require additional information to run. These tests are called parameters. You can set default values for parameters as well as specific values for individual runs. APIs to set these parameters are also available.

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.Test**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test Members

The following table lists the members exposed by the Test Class.

Public Properties

Name | Description
AreFiltersApplied | Gets a value indicating whether filters have been applied for this result.
ExecutionState | Indicates whether there is an instance of this test that is queued, waiting to be run, or not running.
InstanceId | Gets the instance Id.
ManuallyAdded | Gets whether the test was added separate from the feature detection process.
Status | Gets the status of the test.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
AddTests | This method should not be called. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
DeleteTestResult | This method deletes a specific result.
Equals | (Inherited from Object)
FilterMultiDeviceTestGroups | This method removes tests from a list of tests that can be consolidated and returns the consolidated groupings of tests that are compatible.
GetDefaultTemplateParameters | Gets the template parameters with default value.
GetHashCode | (Inherited from Object)
GetMachineRole | This method returns a logical Machine Set.
GetParameters | This method retrieves a dictionary collection of test parameters, sorted by parameter name.
GetRequirements | This method retrieves the enumerable list of certification requirements that this test verifies.
GetSupportedPlatforms | This method returns a enumerable list of the architectures supported by this certification test.
GetTestResults | This method retrieves the list of the test results generated during runs of this certification test.
GetTests | This method retrieves a test list.
GetTestTargets | This method retrieves a list of possible test targets for this test.
GetType | (Inherited from Object)
QueueTest | Overloaded.
RemoveTests | This method should not be called. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetParameter | Overloaded.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Test Methods

Public Methods

Name | Description
AddTests | This method should not be called. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
DeleteTestResult | This method deletes a specific result.
Equals | (Inherited from Object)
FilterMultiDeviceTestGroups | This method removes tests from a list of tests that can be consolidated and returns the consolidated groupings of tests that are compatible.
GetDefaultTemplateParameters | Gets the template parameters with default value.
GetHashCode | (Inherited from Object)
GetMachineRole | This method returns a logical Machine Set.
GetParameters | This method retrieves a dictionary collection of test parameters, sorted by parameter name.
GetRequirements | This method retrieves the enumerable list of certification requirements that this test verifies.
GetSupportedPlatforms | This method returns a enumerable list of the architectures supported by this certification test.
GetTestResults | This method retrieves the list of the test results generated during runs of this certification test.
GetTests | This method retrieves a test list.
GetTestTargets | This method retrieves a list of possible test targets for this test.
GetType | (Inherited from Object)
QueueTest | Overloaded.
RemoveTests | This method should not be called. Warning This functionality is being deprecated. Please use playlists to create custom test pass lists.
SetParameter | Overloaded.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


Test.AddTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

Overload List

Name | Description
AddTests Method (IEnumerable<TestDefinition>) | This method should not be called.
AddTests Method (IEnumerable<TestDefinition>, bool) | This method should not be called.


Test.AddTests Method (IEnumerable TestDefinition )

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

This method should not be called.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be added.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.AddTests Method (IEnumerable TestDefinition , bool)

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

This method should not be called.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void AddTests (

      `IEnumerable<TestDefinition> tests`

      `bool featureDetectionEnabled`

)

Parameters

tests

The tests to be added.

featureDetectionEnabled

Whether the tests should be added with feature detection or not.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.DeleteTestResult Method

This method deletes a specific result.

Syntax

Visual Basic

Public Overridable Sub DeleteTestResult(ByVal resultToRemove As TestResult)

C#

public virtual void DeleteTestResult(TestResult resultToRemove)

Parameters

resultToRemove

 Result to be removed

Remarks

Exception thrown if:

  • Result is null.

  • Result is invalid or the wrong type.

  • Result is not a result from this test.

  • Result could not be deleted from the database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.FilterMultiDeviceTestGroups Method

This method removes tests from a list of tests that can be consolidated and returns the consolidated groupings of tests that are compatible.

Syntax

Visual Basic

Public Shared Function FilterMultiDeviceTestGroups(ByVal tests As List(Of Test)) As List(Of List(Of Test))

C#

public static List<List<Test>> FilterMultiDeviceTestGroups(List<Test> tests)

Parameters

tests

 A list of tests to be filtered for multi-device tests.

Returns

A list test groupings which can be consolidated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetDefaultTemplateParameters Method

Gets the template parameters with default value.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual TemplateParameters GetDefaultTemplateParameters ()

Return Value

Returns a collection of template parameters used when scheduling test on a Proxy client.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetMachineRole Method

This method returns a logical Machine Set.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As MachineSet

returnValue = instance.GetMachineRole

Syntax

Visual Basic

Public MustOverride Function GetMachineRole As MachineSet

C#

public abstract MachineSet GetMachineRole ()

Return Value

Returns the MachineSet needed by this Test. Null is returned if the test does not use MachineRoles.

Remarks

Most tests do not have machine roles which will return NULL.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetParameters Method

This method retrieves a dictionary collection of test parameters, sorted by parameter name.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As Dictionary(Of String, TestParameter)

returnValue = instance.GetParameters

Syntax

Visual Basic

Public MustOverride Function GetParameters As Dictionary(Of String, TestParameter)

C#

public abstract Dictionary<string,TestParameter> GetParameters ()

Return Value

Returns Dictionary, which is a dictionary of TestParameter Class objects used when scheduling this test.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetRequirements Method

This method retrieves the enumerable list of certification requirements that this test verifies.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As ReadOnlyCollection(Of Requirement)

returnValue = instance.GetRequirements

Syntax

Visual Basic

Public MustOverride Function GetRequirements As ReadOnlyCollection(Of Requirement)

C#

public abstract ReadOnlyCollection<Requirement> GetRequirements ()

Return Value

Returns ReadOnlyCollection, which is a collection of requirements that this test can validate.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetSupportedPlatforms Method

This method returns a enumerable list of the architectures supported by this certification test.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As ReadOnlyCollection(Of OSPlatform)

returnValue = instance.GetSupportedPlatforms

Syntax

Visual Basic

Public MustOverride Function GetSupportedPlatforms As ReadOnlyCollection(Of OSPlatform)

C#

public abstract ReadOnlyCollection<OSPlatform> GetSupportedPlatforms ()

Return Value

Returns ReadOnlyCollection, which is a collection of platforms on which this test can be run.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetTestResults Method

This method retrieves the list of the test results generated during runs of this certification test.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As ReadOnlyCollection(Of TestResult)

returnValue = instance.GetTestResults

Syntax

Visual Basic

Public MustOverride Function GetTestResults As ReadOnlyCollection(Of TestResult)

C#

public abstract ReadOnlyCollection<TestResult> GetTestResults ()

Return Value

Returns ReadOnlyCollection, which is a collection of results for the test.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetTests Method

This method retrieves a test list.

Syntax

C#

public virtual IList<Test> GetTests()

Return Value

Returns a Test Collection of all of the tests.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.GetTestTargets Method

This method retrieves a list of possible test targets for this test.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As ReadOnlyCollection(Of Target)

returnValue = instance.GetTestTargets

Syntax

Visual Basic

Public MustOverride Function GetTestTargets As ReadOnlyCollection(Of Target)

C#

public abstract ReadOnlyCollection<Target> GetTestTargets ()

Return Value

Returns ReadOnlyCollection, which is a read-only list of test targets.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method

Overload List

Name | Description
QueueTest Method () | This method schedules this object for execution
QueueTest Method (MachineSet) | This method schedules this object for execution.
QueueTest Method (TemplateParameters) | This method schedules all the tests for execution.
QueueTest Method (IEnumerable<Test>) | This method schedules tests to be run and consolidating the test run with additional compatible tests that are flagged to run as a set as an optimization.
QueueTest Method (IEnumerable<Machine>) | This method schedules this object for execution.
QueueTest Method (MachineSet, TemplateParameters) | This method schedules all the tests for execution on a specified MachineSet.
QueueTest Method (IEnumerable<Test>, IEnumerable<Machine>) | This method schedules tests to be run on a specified set of machines and consolidating the test run with additional compatible tests that are flagged to run as a set as an optimization.
QueueTest Method (IEnumerable<Test>, IEnumerable<Machine>, TemplateParameters) | This method schedules the test for execution on a specific subset of machines.


Test.QueueTest Method ()

This method schedules this object for execution.

Usage

Visual Basic

Dim instance As Test

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest

Syntax

Visual Basic

Public Overridable Function QueueTest As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest ()

Return Value

Returns IList, which is a list of results for the jobs that were scheduled.

TIP

If you use the QueueTest method to add a computer to a test queue and that computer configuration subsequently changes, QueueTest can throw an exception. If an exception occurs, immediately retry QueueTest.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (MachineSet)

This method schedules this object for execution.

Usage

Visual Basic

Dim instance As Test

Dim logicalMachineSet As MachineSet

Dim returnValue As IList(Of TestResult)

returnValue = instance.QueueTest(logicalMachineSet)

Syntax

Visual Basic

Public Overridable Function QueueTest ( _

      `logicalMachineSet As MachineSet _`

) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest (

      `MachineSet logicalMachineSet`

)

Parameters

logicalMachineSet

 A list of machines to run this on.

Return Value

Returns IList, a list of results for the jobs that were scheduled. The test computer is always part of the machine set, this is only for additional test computers, required in multi-machine tests.

TIP

If you use the QueueTest method to add a computer to a test queue and that computer configuration subsequently changes, QueueTest can throw an exception. If an exception occurs, immediately retry QueueTest.

Remarks

The machine associated with the selected target is automatically added to the set.

QueueTest attempts to schedule the current test. If there is a failure, the scheduling of tests is stopped immediately and an exception is thrown. As a result, some tests might still be scheduled.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (TemplateParameters)

This method schedules all the tests for execution.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual IList<TestResult> QueueTest (

      `TemplateParameters templateParameters`

)

Parameters

templateParameters

Template parameters to use for running tests on a Proxy Client.

Return Value

A list of results for the tests that were scheduled.

Remarks

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately.

This is not supported when the project is connected to a package.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (IEnumerable Test ) Method

This method schedules tests to be run and consolidating the test run with additional compatible tests that are flagged to run as a set as an optimization

Syntax

Visual Basic

Public Overridable Function QueueTest(ByVal testList As IEnumerable(Of Test)) As IList(Of TestResult)

C#

This method schedules tests to be run and consolidating the test run with additional compatible tests that are flagged to run as a set as an optimization

Parameters

testList

 The list of tests to consolidate the test run with.

Return Value

Returns IList, a list of results for the jobs that were scheduled.

Remarks

An exception is thrown if:

  • The ScheduleOptions member of the test is not ConsolidateScheduleAcrossTargets.

  • The tests differ by their Id fields and are therefore not the same test running against different targets.

  • The tests validate different product instances.

  • All of the tests cannot run on a least one machine.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (IEnumerable Machine ) Method

This method schedules this object for execution.

Syntax

Visual Basic

Public Overridable Function QueueTest( _

      `machineList As IEnumerable(Of Machine) _`

) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest(

      `IEnumerable<Machine> machineList`

)

Parameters

machineList

 A list of machines to run this on.

Return Value

Returns IList, a list of results for the jobs that were scheduled. The test computer is always part of the machine set, this is only for additional test computers, required in multi-machine tests.

TIP

If you use the QueueTest method to add a computer to a test queue and that computer configuration subsequently changes, QueueTest can throw an exception. If an exception occurs, immediately retry QueueTest.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (MachineSet, TemplateParameters)

This method schedules all the tests for execution on a specified MachineSet.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual IList<TestResult> QueueTest (

      `MachineSet logicalMachineSet,`

      `TemplateParameters templateParameters`

)

Parameters

logicalMachineSet

Machine set to run the tests.

templateParameters

Template parameters to use for running tests on a Proxy Client.

Return Value

A list of results for the tests that were scheduled.

Remarks

A list of results for the tests that were scheduled.

The machine associated with the target (that was selected) is automatically added to the set.

QueueTest will attempt to schedule all of the tests in the current or child objects. If there is a failure, the scheduling of tests is stopped immediately and an exception is thrown. As a result, some tests could have been scheduled.

This is not supported when the project is connected to a package.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (Test, Machine) Method

This method schedules tests to be run on a specified set of machines and consolidating the test run with additional compatible tests that are flagged to run as a set as an optimization.

Syntax

Visual Basic

Public Overridable Function QueueTest(ByVal testList As IEnumerable(Of Test), ByVal machineList As IEnumerable(Of Machine)) As IList(Of TestResult)

C#

public virtual IList<TestResult> QueueTest(IEnumerable<Test> testList, IEnumerable<Machine> machineList)

Parameters

testList

 The list of tests to consolidate the test run with.

machineList

 A list of machines to run this on.

Return Value

Returns IList, a list of results for the jobs that were scheduled.

Remarks

An exception is thrown if:

  • The ScheduleOptions member of the test is not ConsolidateScheduleAcrossTargets.

  • The tests differ by their Id fields and are therefore not the same test running against different targets.

  • The tests validate different product instances.

  • All of the tests cannot run on a least one machine.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.QueueTest Method (IEnumerable Test , IEnumerable Machine , TemplateParameters)

This method schedules the test for execution on a specific subset of machines.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual IList<TestResult> QueueTest (

      `IEnumerable<Test> testList,`

      `IEnumerable<Machine> machineList,`

      `TemplateParameters templateParameters`

)

Parameters

testList

A list of tests to consolidate with the current test.

MachineSet

List of machines that can run the test.

templateParameters

Template parameters to use for running tests on a Proxy Client.

Return Value

A list of results for the tests that were scheduled.

Remarks

This is useful to specify a subset of possible machines. For example in the case where manual tests would prefer to run on specific machines.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.RemoveTests Method

WARNING

This functionality is being deprecated. Please use playlists to create custom test pass lists.

This method should not be called.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void RemoveTests (

      `IEnumerable<TestDefinition> tests`

)

Parameters

tests

The tests to be removed.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.SetParameter Method

Overload List

Name | Description
Test.SetParameter (Target, String, String, ParameterSetAsDefault) | This method updates a job parameter.
Test.SetParameter (String, String, ParameterSetAsDefault) | This method updates a job parameter.This will set the parameter for all applicable targets for this job


Test.SetParameter Method (Target, String, String, ParameterSetAsDefault)

This method updates a job parameter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Test

Dim target As Target

Dim parameterName As String

Dim parameterValue As String

Dim setAsDefault As ParameterSetAsDefault

Dim returnValue As String

returnValue = instance.SetParameter(target, parameterName, parameterValue, setAsDefault)

Syntax

Visual Basic

Public MustOverride Function SetParameter ( _

      `target As Target, _`

      `parameterName As String, _`

      `parameterValue As String, _`

      `setAsDefault As ParameterSetAsDefault _`

) As String

C#

public abstract string SetParameter (

      `Target target,`

      `string parameterName,`

      `string parameterValue,`

      `ParameterSetAsDefault setAsDefault`

)

Parameters

target

      The test target (test computer) to use to set this parameter.

parameterName

      The name of the test parameter to set.

parameterValue

      The new value to set the test parameter to.

setAsDefault

      This value indicates that the test parameter is set as the default for all future job runs.

Return Value

Returns String, which is the updated value for the parameter.

Remarks

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.SetParameter Method (String, String, ParameterSetAsDefault)

This method updates a job parameter. This will set the parameter for all applicable targets for this job

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As Test

Dim parameterName As String

Dim parameterValue As String

Dim setAsDefault As ParameterSetAsDefault

Dim returnValue As String

returnValue = instance.SetParameter(parameterName, parameterValue, setAsDefault)

Syntax

Visual Basic

Public MustOverride Function SetParameter ( _

      `parameterName As String, _`

      `parameterValue As String, _`

      `setAsDefault As ParameterSetAsDefault _`

) As String

C#

public abstract string SetParameter (

      `string parameterName,`

      `string parameterValue,`

      `ParameterSetAsDefault setAsDefault`

)

Parameters

parameterName

      The name of the test parameter to set.

parameterValue

      The new value to set the test parameter to.

setAsDefault

      This value indicates that the test parameter is set as the default for all future job runs.

Return Value

Returns String, which is the updated value for the parameter.

Remarks

All targets where this property can be set are updated.

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test Properties

Public Properties

Name | Description
AreFiltersApplied | Gets a value indicating whether filters have been applied for this result.
ExecutionState | Indicates whether there is an instance of this test that is queued, waiting to be run, or not running.
InstanceId | Gets the instance Id.
ManuallyAdded | Gets whether the test was added separate from the feature detection process.
Status | Gets the status of the test.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


Test.AreFiltersApplied Property

Gets a value indicating whether filters have been applied for this result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual bool AreFiltersApplied

Property Value

Returns a value indicating whether filters have been applied for this result.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.ExecutionState Property

Indicates whether there is an instance of this test that is queued, waiting to be run, or not running.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual ExecutionState ExecutionState

Property Value

Returns an ExecutionState Enumeration.

Remarks

If there is an instance of this test running, and another in the queue, this will return ExecutionState.Running.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.InstanceId Property

Gets the instance Id.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract string InstanceId { get; }

Property Value

Returns the InstanceId.

Remarks

A test may be needed for every target in a target family. This instance ID is unique across all instances of tests (applied to many targets).

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.ManuallyAdded Property

Gets whether the test was added separate from the feature detection process.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract bool ManuallyAdded

Property Value

Returns a value which indicates whether the test was added separate from the feature detection process.

Remarks

If tests are being manually added by the user to a Project, Product Instance, etc., the feature detection process will run and determine whether or not the test being manually added is relevant for the specific target/target family. If it is not, and the user has chosen to add the test anyways, then this property will be set to true.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Test.Status Property

Gets the status of the test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract TestResultStatus Status

Property Value

Returns a TestResultStatus Enumeration.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestClassification Enumeration

This enumeration represents the test classification for the test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public enum TestClassification

Members

Member Name | Description
Compatibility | Compatibility test.
Development | Development test.
Scenario | Scenario test.
Benchmark | Benchmark test.
DeviceOperation | Device operations tests, such as flash or power on/off the device.


TestDefinition Class

A class that contains the properties for a test that are static across instances. This class can be used to facilitate the filtering of tests, as well as add or remove particular tests to and from projects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[DataContractAttribute]

public abstract class TestDefinition

Inheritance Hierarchy

System.Object

 **Microsoft.Windows.Kits.Hardware.ObjectModel.NotificationBase**

      **Microsoft.Windows.Kits.Hardware.ObjectModel.TestDefinition**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition Members

The following tables list the members exposed by the TestDefinition class.

Public Properties

Name | Description
Description | The description.
DevelopmentPhases | The DevelopmentPhases that this test is suggested to be used for.
EstimatedRuntime | The estimated time to run the test.
Id | Id is a unique identification that distinguishes this test among other tests and is consistent across all installations.
IsAssessmenty | Specifies if the test is an Assessment test.
MaximumDevices | The maximum number of tests that can be consolidated for multi-device tests.
Name | The name.
RequiresSpecialConfiguration | Indicates whether the test requires a special configuration step on the target machine to run correctly.
RequiresSupplementalContent | Indicates whether the test requires supplemental content for the test to run correctly.
ScheduleOptions | The Schedule options.
TestClassification | The TestClassificationfor this test.
TestType | The TestType.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestDefinition Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestDefinition Properties

Public Properties

Name | Description
Description | The description.
DevelopmentPhases | The DevelopmentPhases that this test is suggested to be used for.
EstimatedRuntime | The estimated time to run the test.
Id | Id is a unique identification that distinguishes this test among other tests and is consistent across all installations.
IsAssessmenty | Specifies if the test is an Assessment test.
MaximumDevices | The maximum number of tests that can be consolidated for multi-device tests.
Name | The name.
RequiresSpecialConfiguration | Indicates whether the test requires a special configuration step on the target machine to run correctly.
RequiresSupplementalContent | Indicates whether the test requires supplemental content for the test to run correctly.
ScheduleOptions | The Schedule options.
TestClassification | The TestClassification for this test.
TestType | The TestType.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


TestDefinition.Description Property

The description.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract string Description

Property Value

Returns the description.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.DevelopmentPhases Property

The DevelopmentPhases that this test is suggested to be used for.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract List<DevelopmentPhase> DevelopmentPhase

Property Value

Returns the DevelopmentPhases that this test is suggested to be used for.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.EstimatedRuntime Property

The estimated time to run the test.

This is an estimate. Due to variations on the client, the actual time can vary.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract TimeSpan EstimatedRuntime

Property Value

Returns the estimated time to run the test.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.Id Property

Id is a unique identification that distinguishes this test among other tests and is consistent across all installations.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract string Id

Property Value

Returns Id for the test.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.IsAssessment Property

Specifies if the test is an Assessment test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

abstract bool IsAssessment

Property Value

Returns whether the test is an Assessment test.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.MaximumDevices Property

The maximum number of tests that can be consolidated for multi-device tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract int MaximumDevices

Property Value

Returns the maximum number of tests that can be consolidated for multi-device tests.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.Name Property

The name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract string Name

Property Value

Returns the name.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.RequiresSpecialConfiguration Property

Indicates whether the test requires a special configuration step on the target machine to run correctly.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract bool RequiresSpecialConfiguration

Property Value

Returns a value indicating whether the test requires a special configuration step on the target machine to run correctly.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.RequiresSupplementalContent Property

Indicates whether the test requires supplemental content for the test to run correctly.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract bool RequiresSupplementalContent

Property Value

Returns a value indicating whether the test requires supplemental content for the test to run correctly.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.ScheduleOptions Property

The Schedule options.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract DistributionOption ScheduleOptions

Property Value

Returns the Schedule options.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.TestClassification Property

The TestClassification for this test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract TestClassification TestClassification

Property Value

Returns the TestClassification for this test.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestDefinition.TestType Property

The TestType.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract TestType TestType

Property Value

Returns the TestType.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestException Class

This class contains constructors that initialize various test exceptions. This exception class is defined to represent exceptions related to certification tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class TestException

      `Inherits ProjectManagerException`

C#

[SerializableAttribute]

public class TestException : ProjectManagerException

Inheritance Hierarchy

System.Object

Microsoft.Windows.Kits.Hardware.ObjectModel.ProjectManagerException

  **Microsoft.Windows.Kits.Hardware.ObjectModel.TestException**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestException Members

The following table lists the members exposed by the TestLog type.

Public Constructors

Name | Description
TestException | Overloaded.

Protected Constructors

Name | Description
TestException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)
TestId | The TestId that this Exception was thrown for.

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


TestException Constructor

Overload List

Name | Description
TestException () | This constructor initializes a new instance of the TestException class.
TestException (String) | This constructor initializes a new instance of the TestException class.
TestException (String, Exception) | This constructor initializes a new instance of the TestException class.


TestException Constructor ()

Initializes a new instance of the TestException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New TestException

Syntax

Visual Basic

Protected Sub New

C#

public TestException ()

Remarks

The default constructor initializes any fields to their default values.


TestException Constructor (String)

This constructor initializes a new instance of the MachineException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New TestException (message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public TestException (

      `string message`

)

Parameters

message

 A string that comprises the exception message.


TestException Constructor (String, Exception)

This constructor initializes a new instance of the TestException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim except As Exception

Dim instance As New TestException (message, except)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

      `except As Exception _`

)

C#

public TestException (

      `string message`

      `Exception except`

)

Parameters

message

 A string that represents the message for the exception.

except

 An exception object.


TestException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)
TestId | The TestId that this Exception was thrown for.

Protected Properties

Name | Description
HResult | (Inherited from Exception)


TestException.TestID Property

The TestId that this Exception was thrown for..

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public string TestId

Property Value

Gets the Test Id that this Exception was thrown for.

Remarks

This field may not always be set. Check for null after getting.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


TestLog Class

This class contains methods and properties applicable to test logs.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestLog

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class TestLog

C#

[DataContractAttribute]

public abstract class TestLog

Remarks

Log files can be generated from a test or from infrastructure processes.

Inheritance Hierarchy

System.Object

Microsoft.Windows.Kits.Hardware.ObjectModel.TestLog

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestLog Members

The following table lists the members exposed by the TestLog type.

Public Properties

Name | Description
LogType | This property represents the type of log file.
Name | This property represents the name of the log file.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReadLog | This method reads a log file from disk to a given IO stream.
ToString | (Inherited from Object)
WriteLogTo | This method writes a log file to a specific file location on disk.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestLog Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReadLog | This method reads a log file from disk to a given IO stream.
ToString | (Inherited from Object)
WriteLogTo | This method writes a log file to a specific file location on disk.

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestLog.ReadLog Method

This method reads a log file from disk to a given IO stream

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestLog

Dim returnValue As Stream

returnValue = instance.ReadLog

Syntax

Visual Basic

Public MustOverride Function ReadLog As Stream

C#

public abstract Stream ReadLog ()

Return Value

Returns Stream.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestLog.WriteLogTo Method

This method writes a log file to a specific file location on disk.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestLog

Dim destination As String

instance.WriteLogTo(destination)

Syntax

Visual Basic

Public MustOverride Sub WriteLogTo ( _

      `destination As String _`

)

C#

public abstract void WriteLogTo (

      `string destination`

)

Parameters

destination

 A string value that describes the destination (file path and file name) to write the log to.

Remarks

An exception occurs if destination is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestLog Properties

[This content is not available in this preliminary release.]

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


TestLog.LogType Property

This property represents the machine (test computer) on which this test ran.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestLog

Dim value As LogType

value = instance.LogType

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property LogType As LogType

C#

[DataMemberAttribute]

public LogType LogType { get; }

Property Value

Returns LogType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestLog.Name Property

This property represents the name of the log file.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestLog

Dim value As String

value = instance.Name

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Name As String

C#

[DataMemberAttribute]

public string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter Class

This parameter is used when scheduling and running a test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestParameter

Syntax

Visual Basic

<DataContractAttribute> _

Public Class TestParameter

C#

[DataContractAttribute]

public class TestParameter

Remarks

TestParameter is used when scheduling and running a test.

Inheritance Hierarchy

System.Object

Microsoft.Windows.Kits.Hardware.ObjectModel.TestParameter

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter Members

The following table lists the members exposed by the TestResult type.

Public Properties

Name | Description
ActualValue | This property represents the current value of a test parameter.
DefaultValue | This property represents the default value of a test parameter.
Name | This property (as a string) represent the test parameter name.
Prompt | This property stores a string that is displayed to an end user in a prompt during a test run.
Visible | This property (Boolean) controls whether a test parameter is visible to the end user.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestParameter Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestParameter.IsSame Method

This method indicates whether the current instance and a specified TestParameter object are the same parameter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

Visual Basic

Public Function IsSame(ByVal other As TestParameter) As Boolean

C#

public bool IsSame(TestParameter other)

Return Value

Returns true if the two objects are equal; otherwise, false.

Remarks

When running multiple tests simultaneously, this function indicates if one parameter value can be applied to any of the other parameters in that same test list.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter Properties

Public Properties

Name | Description
ActualValue | This property represents the current value of a test parameter.
DefaultValue | This property represents the default value of a test parameter.
Name | This property (as a string) represent the test parameter name.
Prompt | This property stores a string that is displayed to an end user in a prompt during a test run.
Visible | This property (Boolean) controls whether a test parameter is visible to the end user.


TestParameter.ActualValue Property

This property represents the current value of a test parameter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestParameter

Dim value As String

value = instance.ActualValue

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public Property ActualValue As String

C#

[IgnoreDataMemberAttribute]

public string ActualValue { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter.DefaultValue Property

This property represents the default value of a test parameter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestParameter

Dim value As String

value = instance.DefaultValue

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public ReadOnly Property DefaultValue As String

C#

[IgnoreDataMemberAttribute]

public string DefaultValue { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter.Description Property

This property represents the test parameter description.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestParameter

Dim value As String

value = instance.Description

Syntax

Visual Basic

<IgnoreDataMember> _

Public ReadOnly Property Description As String

C#

[IgnoreDataMember]

public string Description { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter.Name Property

This property (as a string) represent the test parameter name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestParameter

Dim value As String

value = instance.Name

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public ReadOnly Property Name As String

C#

[IgnoreDataMemberAttribute]

public string Name { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestParameter.Visible Property

This property (Boolean) controls whether a test parameter is visible to the end user.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestParameter

Dim value As Boolean

value = instance.Visible

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public ReadOnly Property Visible As Boolean

C#

[IgnoreDataMemberAttribute]

public bool Visible { get; }

Property Value

Returns Boolean.

Remarks

The Visible property is the most commonly modified parameter.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult Class

This class represents information that is obtained as a result of running a certification test. This information contains details about the test, how it completed, when it completed, and so on.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Syntax

Visual Basic

<DataContractAttribute> _

Public MustInherit Class TestResult

C#

[DataContractAttribute]

public abstract class TestResult

Inheritance Hierarchy

System.Object

Microsoft.Windows.Kits.Hardware.ObjectModel.TestResult

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult Members

The following table lists the members exposed by the TestResult Class.

Public Properties

Name | Description
AreFiltersApplied | Indicates whether filters have been applied for this result.
CompletionTime | This property represents the time when the corresponding certification test completed.
HasBugchecked | Indicates whether a bugcheck occurred on the client machine during the test run.
InstanceId | This property represents the instance ID value of the test result.
IsMultiDevice | Indicates whether the test ran as a MultiDevice test.
Machine | This property represents the machine (test computer) on which this test ran.
ScheduleTime | This property represents the time when the corresponding logo test was first scheduled.
StartTime | This property represents the time when the corresponding certification test was started and this result was generated.
Status | This property represents the status of this certification test result.
Target | This property represents the test target that this test result was obtained from.
Test | This property represents the certification test object this result is generated for.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)

Public Methods

Name | Description
Cancel | This method cancels a job that is scheduled.
Equals | (Inherited from Object)
GetAllTests | Returns all tests consolidated for multi-device tests.
GetAppliedFilters | This method retrieves the filters applied for this test result.
GetHashCode | (Inherited from Object)
GetLogs | This method retrieves all of the logs associated with this test result.
GetParameters | This method retrieves the parameters that were applied to a test when it was run.
GetTasks | This method retrieves the tasks associated with this test.
GetType | (Inherited from Object)
Refresh | Refresh the current status of the result.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestResult Methods

Public Methods

Name | Description
Cancel | This method cancels a job that is scheduled.
Equals | (Inherited from Object)
GetAllTests | Returns all tests consolidated for multi-device tests.
GetAppliedFilters | This method retrieves the filters applied for this test result.
GetDiagnosticSummaryLog | This method retrieves an instance of the diagnostic summary object for the test run, if one is available.
GetHashCode | (Inherited from Object)
GetLogs | This method retrieves all of the logs associated with this test result.
GetParameters | This method retrieves the parameters that were applied to a test when it was run.
GetTasks | This method retrieves the tasks associated with this test.
GetType | (Inherited from Object)
Refresh | Refresh the current status of the result.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


TestResult.Cancel Method

This method cancels a test that is scheduled.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

instance.Cancel

Syntax

Visual Basic

Public MustOverride Sub Cancel

C#

public abstract void Cancel ()

Remarks

This is not supported when the project is connected to a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.GetAllTests Method

Returns all tests consolidated for multi-device tests.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual ReadOnlyCollection<Test> GetAllTests()

Return Value

ReadOnlyCollection<Test>

Returns all tests consolidated for multi-device tests.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.GetAppliedFilters Method

This method retrieves the filters applied for this test result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim returnValue As ReadOnlyCollection(Of IFilter)

returnValue = instance.GetAppliedFilters

Syntax

Visual Basic

Public MustOverride Function GetAppliedFilters As ReadOnlyCollection(Of IFilter)

C#

public abstract ReadOnlyCollection<IFilter> GetAppliedFilters ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


GetDiagnosticSummaryLog Method

This method retrieves an instance of the diagnostic summary object for the test run, if one is available.

A diagnostic summary log is copied to the controller only after the test run is complete (the test could pass or fail).

The diagnostic summary log captures any bugcheck(s) that occur during the test run.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel

Usage

For sample usage, see the Diagnostic Bugcheck Summary sample.

Syntax

C#

public DiagnosticSummaryLog GetDiagnosticSummaryLog()

Return Value

Returns DiagnosticSummaryLog, an object representation of a diagnostic summary log, if one is available. Otherwise, returns null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.GetLogs Method

This method retrieves all of the logs associated with this test result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim returnValue As ReadOnlyCollection(Of TestLog)

returnValue = instance.GetLogs

Syntax

Visual Basic

Public MustOverride Function GetLogs As ReadOnlyCollection(Of TestLog)

C#

public abstract ReadOnlyCollection<TestLog> GetLogs ()

Return Value

Returns ReadOnlyCollection, which is a read-only list of all of the logs associated with this test result.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.GetParameters Method

This method retrieves the parameters that were applied to a test when it was run.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim returnValue As ReadOnlyCollection(Of TestParameter))

returnValue = instance.GetParameters

Syntax

Visual Basic

Public MustOverride Function GetParameters As ReadOnlyCollection(Of TestParameter)

C#

public abstract ReadOnlyCollection<TestParameter> GetParameters ()

Return Value

Returns ReadOnlyCollection, which is a collection of parameters used for this test instance.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.GetTasks Method

This method retrieves the tasks associated with this test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim returnValue As ReadOnlyCollection(Of Task)

returnValue = instance.GetTasks

Syntax

Visual Basic

Public MustOverride Function GetTasks As ReadOnlyCollection(Of Task)

C#

public abstract ReadOnlyCollection<Task> GetTasks ()

Return Value

Returns ReadOnlyCollection, which is a collection of tasks for a test.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.Refresh Method

Refresh the current status of the result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual void Refresh ()

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult Properties

Public Properties

Name | Description
AreFiltersApplied | Indicates whether filters have been applied for this result.
CompletionTime | This property represents the time when the corresponding certification test completed.
HasBugchecked | Indicates whether a bugcheck occurred on the client machine during the test run.
InstanceId | This property represents the instance ID value of the test result.
IsMultiDevice | Indicates whether the test ran as a MultiDevice test.
Machine | This property represents the machine (test computer) on which this test ran.
ScheduleTime | This property represents the time when the corresponding logo test was first scheduled.
StartTime | This property represents the time when the corresponding certification test was started and this result was generated.
Status | This property represents the status of this certification test result.
Target | This property represents the test target that this test result was obtained from.
Test | This property represents the certification test object this result is generated for.

Protected Properties

Name | Description
LockObject | (Inherited from NotificationBase)


TestResult.AreFiltersApplied Property

Indicates whether filters have been applied for this result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual bool AreFiltersApplied

Property Value

Returns a value indicating whether filters have been applied for this result.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.CompletionTime Property

This property represents the time when the corresponding certification test completed.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As DateTime

value = instance.CompletionTime

Syntax

Visual Basic

Public MustOverride ReadOnly Property CompletionTime As DateTime

C#

public abstract DateTime CompletionTime { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


HasBugchecked Property

Indicates whether a bugcheck occurred on the client machine during the test run.

NOTE

Bugchecks aren't necessarily caused by tests. Additional triage of the crash dump file is required to determine what caused the bugcheck. For example, while running WiFi tests, a display driver might cause a bugcheck.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual bool HasBugchecked { get; internal set; }

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.InstanceId Property

An identifier to uniquely identify the instance of the Result

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public abstract string InstanceId { get; }

Property Value

Returns the Id to uniquely identify the instance of the Result.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.IsMultiDevice Property

Indicates whether the test ran as a MultiDevice test.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public virtual bool IsMultiDevice

Property Value

Returns a value indicating whether the test ran as a MultiDevice test.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.Machine Property

This property represents the machine (test computer) on which this test ran.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As Machine

value = instance.Machine

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public MustOverride ReadOnly Property Machine As Machine

C#

[IgnoreDataMemberAttribute]

public abstract Machine Machine { get; }

Property Value

Returns Machine Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.ScheduleTime Property

This property represents the time when the corresponding logo test was first scheduled.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As DateTime

value = instance.ScheduleTime

Syntax

Visual Basic

Public MustOverride ReadOnly Property ScheduleTime As DateTime

C#

public abstract DateTime ScheduleTime { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.StartTime Property

This property represents the time when the corresponding certification test was started and this result was generated.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As DateTime

value = instance.StartTime

Syntax

Visual Basic

Public MustOverride ReadOnly Property StartTime As DateTime

C#

public abstract DateTime StartTime { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.Status Property

This property represents the status of this certification test result.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As TestResultStatus

value = instance.Status

Syntax

Visual Basic

Public MustOverride ReadOnly Property Status As TestResultStatus

C#

public abstract TestResultStatus Status { get; }

Property Value

Returns TestResultStatus.

NOTE

TestResult.Status does not return Queued (if a test is scheduled or running it returns Running).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.Target Property

This property represents the test target that this test result was obtained from.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As Target

value = instance.Target

Syntax

Visual Basic

Public MustOverride ReadOnly Property Target As Target

C#

public abstract Target Target { get; }

Property Value

Returns Target.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResult.Test Property

This property represents the certification test object this result is generated for.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResult

Dim value As Test

value = instance.Test

Syntax

Visual Basic

Public MustOverride ReadOnly Property Test As Test

C#

public abstract Test Test { get; }

Property Value

Returns Test, which is the test computer on which this test was run.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


TestResultStatus Enumeration

This enumeration represents the list of status that every certification test can be in within the HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestResultStatus

Syntax

Visual Basic

Public Enumeration TestResultStatus

C#

public enum TestResultStatus

Members

Member name | Description
Canceled | This enum value describes a test as being in "Cancelled" state.
Failed | This enum value describes a test as being in the "Failed" state.
InQueue | This enum value describes a test as being in the "In queue" state.
NotRun | This enum value describes a test as being in the "Not run" state.
Passed | This enum value describes a test as having complete testing successfully (Passed).
Running | This enum value describes a test as being in the "running state.


TestType Enumeration

This enumeration represents types of tests that can exist in the HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As TestType

Syntax

Visual Basic

Public Enumeration TestType

C#

public enum TestType

Members

Member name | Description
Automated | This enum represents tests that require no manual input (referred to automated tests).
Configuration | This enum represents tests denoted as configuration jobs( jobs which perform configuration actions, but do not involve any test actions). This type of test has been deprecated, do not use.
Library | This enum represents library tests. This type of test has been deprecated, do not use.
Manual | This enum represents tests that require manual input (referred to as manual tests).


UpdateType Enumeration

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Members

Member name | Description
Add | This enum represents something was added, usually as a child object.
NoChange | This enum represents no changes detected.
Other | This enum represents
Remove | This enum represents something was removed, usually as a child object.
Status | This enum represents the status of the sender has changed.
Update | This enum represents the sender needs to be updated.


Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection Namespace

In this section

  • DatabaseProjectManager Class

  • DeviceOperations Class


DatabaseProjectManager Class

This class is a container for all submissions in DTM. The main purpose is to store all the submission packages and allow operations on each project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Syntax

Visual Basic

Public Class DatabaseProjectManager

      `Inherits ProjectManager`

C#

public class DatabaseProjectManager : ProjectManager

Inheritance Hierarchy

System.Object

 [ProjectManager Class](projectmanager-class.md)

      **Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DatabaseProjectManager**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager Members

The following tables list the members exposed by the DatabaseProjectManager Class.

Protected Constructors

Name | Description
DatabaseProjectManager | Overloaded.

Public Properties

Name | Description
ConnectionType | Overridden. This property represents the underlying database connection type.
ControllerName | The name of the controller.
Version | This property represents the major version of the Windows HCK Controller. (Inherited from ProjectManager Class)
VersionString | This property represents the version of the Windows HCK Controller and its content. (Inherited from ProjectManager Class)

Public Methods

Name | Description
CreateDeviceFamily | Overridden. This method creates a new device family with the given name.
CreateProject | Overridden. This method creates a new Project and adds it to the project collection.
DeleteDeviceFamily | Overridden. This method deletes a named Device Family.
.DeleteProject | Overridden. This method deletes a named project.
Dispose | This method implements the IDisposable interface. (Inherited from ProjectManager Class)
Equals | (Inherited from Object)
GetDeviceFamilies | Overridden. This method retrieves a list of available DeviceFamilies.
GetFeatures | Overridden. This method features all of the features stored in the Windows HCK.
GetFilters | Overridden. This method returns all the filters installed in the system.
GetHashCode | (Inherited from Object)
GetNetBiosName | Converts a FQDN name to a NetBIOS name.
GetPlatforms | Overridden.
GetProductTypes | Overridden.
GetProject | Overridden. This method loads an existing project into the collection.
GetProjectInfo | Gets the ProjectInfo Class for a specific project.
GetProjectInfoList | Overridden. This method retrieves a list of project information.
GetProjectNames | Overridden. This method retrieves a list of project names.
GetProjectSummary | Overridden.
GetRequirements | Overridden. This method retrieves the list of requirements in the Windows HCK.
GetRootMachinePool | Overridden. This method retrieves the root machine pool.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Dispose | Overridden. This method implements the IDisposable interface.
Finalize | This method finalizes an instance of the ProjectManager class. (Inherited from ProjectManager Class)
MemberwiseClone | (Inherited from Object)


DatabaseProjectManager Constructor

Overload List

Name | Description
DatabaseProjectManager (String) | This constructor initializes a new instance of the DatabaseProjectManager class. You should cast this back to the ILogoManager interface, this will prevent issues later when porting to a different implementation of this interface. The DataStore name is the NetBIOS name of the server parameter.
DatabaseProjectManager (String, String) | This constructor initializes a new instance of the DatabaseProjectManager class. You should cast this back to the ILogoManager interface, this will prevent issues later when porting to a different implementation of this interface. The DataStore name is the NetBIOS name of the server parameter.


DatabaseProjectManager Constructor (String)

This constructor initializes a new instance of the DatabaseProjectManager class. You should cast this back to the ILogoManager interface, this will prevent issues later when porting to a different implementation of this interface. The DataStore name is the NetBIOS name of the server parameter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim server As String

Dim instance As New DatabaseProjectManager(server)

Syntax

Visual Basic

Public Sub New ( _

      `server As String _`

)

C#

public DatabaseProjectManager (

      `string server`

)

Parameters

server

 The name of the server to connect to.

Remarks

An exception is thrown if server is null or empty, or if the database connection fails (for example, if the controller is unavailable).


DatabaseProjectManager Constructor (String, String)

This constructor initializes a new instance of the DatabaseProjectManager class. You should cast this back to the ILogoManager interface, this will prevent issues later when porting to a different implementation of this interface. The DataStore name is the NetBIOS name of the server parameter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim server As String

Dim database As String

Dim instance As New DatabaseProjectManager(server, database)

Syntax

Visual Basic

Public Sub New ( _

      `server As String _`

      `database As String _`

)

C#

public DatabaseProjectManager (

      `string server`

      `string database`

)

Parameters

server

 The name of the server to connect to.

database

 The name of the database to connect to.

Remarks

An exception is thrown if server is null or empty, or if the database connection fails (for example, if the controller is unavailable).


DatabaseProjectManager Methods

Public Methods

Name | Description
CreateDeviceFamily | Overridden. This method creates a new device family with the given name.
CreateProject | Overridden. This method creates a new Project and adds it to the project collection.
DeleteDeviceFamily | Overridden. This method deletes a named Device Family.
.DeleteProject | Overridden. This method deletes a named project.
Dispose | This method implements the IDisposable interface. (Inherited from ProjectManager Class)
Equals | (Inherited from Object)
GetDeviceFamilies | Overridden. This method retrieves a list of available DeviceFamilies.
GetFeatures | Overridden. This method features all of the features stored in the Windows HCK.
GetFilters | Overridden. This method returns all the filters installed in the system.
GetHashCode | (Inherited from Object)
GetNetBiosName | Converts a FQDN name to a NetBIOS name.
GetPlatforms | Overridden.
GetProductTypes | Overridden.
GetProject | Overridden. This method loads an existing project into the collection.
GetProjectInfo | Gets the ProjectInfo Class for a specific project.
GetProjectInfoList | Overridden. This method retrieves a list of project information.
GetProjectNames | Overridden. This method retrieves a list of project names.
GetProjectSummary | Overridden.
GetRequirements | Overridden. This method retrieves the list of requirements in the Windows HCK.
GetRootMachinePool | Overridden. This method retrieves the root machine pool.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Dispose | Overridden. This method implements the IDisposable interface.
Finalize | This method finalizes an instance of the ProjectManager class. (Inherited from ProjectManager Class)
MemberwiseClone | (Inherited from Object)


DatabaseProjectManager.CreateDeviceFamily Method

This method creates a new device family with the given name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim name As String

Dim familyIds As IEnumerable(Of String)

Dim returnValue As DeviceFamily

returnValue = instance.CreateDeviceFamily(name, familyIds)

Syntax

Visual Basic

Public Overrides Function CreateDeviceFamily ( _

      `name As String, _`

      `familyIds As IEnumerable(Of String) _`

) As DeviceFamily

C#

public override DeviceFamily CreateDeviceFamily (

      `string name,`

      `IEnumerable<string> familyIds`

)

Parameters

name

 The name to create the device family with.

familyIds

 The ID values to use when creating the new device family.

Return Value

Returns DeviceFamily Class.

Remarks

An exception occurs when the familyIds parameter is null, empty, or invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.CreateProject Method

This method creates a new Project object and adds it to the project collection.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim projectName As String

Dim returnValue As Project

returnValue = instance.CreateProject(projectName)

Syntax

Visual Basic

Public Overrides Function CreateProject ( _

      `projectName As String, _`

) As Project

C#

public override Project CreateProject (

      `string projectName,`

)

Parameters

projectName

 The name to be associated with the project. The name is case-insensitive.

Return Value

Returns Project Class.

Remarks

An exception occurs when the projectName parameter is null, empty, or there is a failure while creating the Project object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.DeleteDeviceFamily Method

This method deletes a named Device Family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim name As String

instance.DeleteDeviceFamily(name)

Syntax

Visual Basic

Public Overrides Sub DeleteDeviceFamily ( _

      `name As String, _`

)

C#

public override void DeleteDeviceFamily (

      `string name`

)

Parameters

name

 The name of the device family to delete.

Remarks

An exception occurs when the name parameter is null, empty, or the device family cannot be removed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.DeleteProject Method

This method deletes a named project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim projectNameToDelete As String

instance.DeleteProject(projectNameToDelete)

Syntax

Visual Basic

Public Overrides Sub DeleteProject ( _

      `projectNameToDelete As String _`

)

C#

public override void DeleteProject (

      `string projectNameToDelete`

)

Parameters

projectNameToDelete

 The name of the project to delete.

Remarks

An exception occurs when the projectNameToDelete parameter is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.Dispose Method

This method implements the IDisposable interface.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim disposing As Boolean

Me.Dispose(disposing)

Syntax

Visual Basic

Protected Overrides Sub Dispose ( _

      `disposing As Boolean _`

)

C#

protected override void Dispose (

      `bool disposing`

)

Parameters

disposing

 A Boolean value to indicate if this is being removed.

Remarks

An exception occurs when the projectNameToDelete parameter is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetDeviceFamilies Method

This method retrieves a list of available DeviceFamilies.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of DeviceFamily)

returnValue = instance.GetDeviceFamilies

Syntax

Visual Basic

Public Overrides Function GetDeviceFamilies As ReadOnlyCollection(Of DeviceFamily)

C#

public override ReadOnlyCollection<DeviceFamily> GetDeviceFamilies ()

Return Value

Returns ReadOnlyCollection, which is a read-only list of DeviceFamily names.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetFeatures Method

This method returns all of the features stored in the Windows HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of Feature)

returnValue = instance.GetFeatures

Syntax

Visual Basic

Public Overrides Function GetFeatures As ReadOnlyCollection(Of Feature)

C#

public override ReadOnlyCollection<Feature> GetFeatures ()

Return Value

Returns ReadOnlyCollection, which is a list of known features.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetFilters Method

This method returns all of the filters stored in the Windows HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of IFilter)

returnValue = instance.GetFilters

Syntax

Visual Basic

Public Overrides Function GetFilters As ReadOnlyCollection(Of IFilter)

C#

public override ReadOnlyCollection<IFilter> GetFilters ()

Return Value

Returns ReadOnlyCollection, which is a list of filter objects.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetNetBiosName Method

Converts a FQDN name to a NetBIOS name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static string GetNetBiosName (

      `string server`

)

Parameters

server

The FQDN name to convert.

Return Value

Returns the first section that should be a NetBIOS name.

Remarks

If a NetBIOS name is passed in, it will be returned unaltered.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetPlatforms Method

[This content is not available in this preliminary release.]

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetProductTypes Method

This method returns all of the product types stored in the Windows HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of ProductType)

returnValue = instance.GetProductTypes

Syntax

Visual Basic

Public Overrides Function GetProductTypes As ReadOnlyCollection(Of ProductType)

C#

public override ReadOnlyCollection<ProductType> GetProductTypes ()

Return Value

Returns ReadOnlyCollection, which is a list of product types.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetProject Method

This method loads an existing project into the collection.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim projectName As String

Dim returnValue As Project

returnValue = instance.GetProject(projectName)

Syntax

Visual Basic

Public Overrides Function GetProject ( _

      `projectName As String _`

) As Project

C#

public override Project GetProject (

      `string projectName`

)

Parameters

projectName

 The case-insensitive name of the project to load.

Return Value

Returns Project Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetProjectInfo Method

Gets the ProjectInfo Class for a specific project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public override ProjectInfo GetProjectInfo (

      `string projectName`

)

Parameters

projectName

Case-insensitive name of project to load.

Return Value

Returns a ProjectInfo Class for the requested project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetProjectInfoList Method

This method retrieves a list of project information.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of ProjectInfo)

returnValue = instance.GetProjectInfoList

Syntax

Visual Basic

Public Overrides Function GetProjectInfoList As ReadOnlyCollection(Of ProjectInfo)

C#

public override ReadOnlyCollection<ProjectInfo> GetProjectInfoList ()

Return Value

Returns ReadOnlyCollection, which is a list a of project information.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetProjectNames Method

This method retrieves a list of project names.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of String)

returnValue = instance.GetProjectNames

Syntax

Visual Basic

Public Overrides Function GetProjectNames As ReadOnlyCollection(Of String)

C#

public override ReadOnlyCollection<string> GetProjectNames ()

Return Value

Returns ReadOnlyCollection, which is a list a of project names used for submissions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetProjectSummary Method

This method retrieves the list of requirements in the Windows HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of Requirement)

returnValue = instance.GetRequirements

Syntax

Visual Basic

Public Overrides Function GetRequirements As ReadOnlyCollection(Of Requirement)

C#

public override ReadOnlyCollection<Requirement> GetRequirements ()

Return Value

Returns ReadOnlyCollection, which is a list a of known requirements.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetRequirements Method

This method retrieves the list of requirements in the Windows HCK.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As ReadOnlyCollection(Of Requirement)

returnValue = instance.GetRequirements

Syntax

Visual Basic

Public Overrides Function GetRequirements As ReadOnlyCollection(Of Requirement)

C#

public override ReadOnlyCollection<Requirement> GetRequirements ()

Return Value

Returns ReadOnlyCollection, which is a list of known requirements.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager.GetRootMachinePool Method

This method retrieves the root machine pool.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim returnValue As MachinePool

returnValue = instance.GetRootMachinePool

Syntax

Visual Basic

Public Overrides Function GetRootMachinePool As MachinePool

C#

public override MachinePool GetRootMachinePool ()

Return Value

Returns MachinePool Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DatabaseProjectManager Properties

Public Properties

Name | Description
ConnectionType | Overridden. This property represents the underlying database connection type.
ControllerName | The name of the controller.
Version | This property represents the major version of the Windows HCK Controller. (Inherited from ProjectManager Class)
VersionString | This property represents the version of the Windows HCK Controller and its content. (Inherited from ProjectManager Class)


DatabaseProjectManager.ConnectionType Property

This property represents the underlying database connection type.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Usage

Visual Basic

Dim instance As DatabaseProjectManager

Dim value As ConnectionType

value = instance.ConnectionType

Syntax

Visual Basic

Public Overrides ReadOnly Property ConnectionType As ConnectionType

C#

public override ConnectionType ConnectionType { get; }

Return Value

Returns ConnectionType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


ControllerName Property

The name of the controller.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Syntax

C#

public string ControllerName { get; set; }

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceOperations Class

This class encapsulates different DeviceOperations API, implemented as HLK Jobs.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Syntax

C#

public class DeviceOperations

Inheritance Hierarchy

System.Object

      **Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.DeviceOperations**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


DeviceOperations Members

The following tables list the members exposed by the DeviceOperations Class.

Public Constructors

Name | Description
DeviceOperations | Initializes a new instance of the DeviceOperations Class.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ProxyClientSystemReflash | Schedules re-flash on phone devices connected via proxy client.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


DeviceOperations Constructor

Initializes a new instance of the DeviceOperations Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection (in Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection)

Syntax

C#

public DeviceOperations (

      `Target target`

)

Parameters

target

Database Connection target that belongs to the system which DeviceOperation function will be performed on.


DeviceOperations Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ProxyClientSystemReflash | Schedules re-flash on phone devices connected via proxy client.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


DeviceOperations.ProxyClientSystemReflash Method

Schedules re-flash on phone devices connected via proxy client.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public TestResult ProxyClientSystemReflash (

      `string flashImagePath,`

      `out bool isScheduled`

)

Parameters

flashImagePath

Absolute Path of the flash image path.

isScheduled

Marks the Re-flash Job is scheduled successfully.

Return Value

If isScheduled==true, a TestResult object is returned. If "isScheduled"==false, then null is returned.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Microsoft.Windows.Kits.Hardware.ObjectModel.Submission Namespace

In this section

  • PackageException Class

  • PackageFilter Class

  • PackageFilterConstraint Class

  • PackageFilterLogNode Class

  • PackageManager Class

  • PackageProgressInfo Class

  • PackageWriter Class


PackageException Class

This class includes constructors that initialize a package exception object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageException

Syntax

Visual Basic

<SerializableAttribute> _

Public Class PackageException

           `Inherits ProjectException`

C#

[SerializableAttribute]

public class PackageException : ProjectException

Inheritance Hierarchy

System.Object

System.Exception

   [ProjectManagerException Class](projectmanagerexception-class.md)           [ProjectException Class](projectexception-class.md)              Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageException Members

The following table lists the members exposed by the PackageException type.

Public Constructors

Name | Description
PackageException | Overloaded.

Protected Constructors

Name | Description
PackageException | Overloaded.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


PackageException Constructor

Overload List

Name | Description
PackageException () | This constructor initializes a new instance of the PackageException class.
PackageException (SerializationInfo, StreamingContext) | This constructor initializes a new instance of the PackageException class.
PackageException (String) | This constructor initializes a new instance of the PackageException class.
PackageException (String, Exception) | This constructor initializes a new instance of the PackageException class.


PackageException Constructor ()

This constructor initializes a new instance of the PackageException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim instance As New PackageException

Syntax

Visual Basic

Public Sub New

C#

public PackageException ()

Remarks

The default constructor initializes any fields to their default values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageException Constructor (SerializationInfo, StreamingContext)

This constructor initializes a new instance of the PackageException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim info As SerializationInfo

Dim context As StreamingContext

Dim instance As New PackageException(info, context)

Syntax

Visual Basic

Public Sub New ( _

      `info As SerializationInfo, _`

      `context As StreamingContext _`

)

C#

protected PackageException (

      `SerializationInfo info`

      `StreamingContext context`

)

Parameters

info

 The serialization info.

context

 The streaming context.


PackageException Constructor (String)

This constructor initializes a new instance of the PackageException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim message As String

Dim instance As New PackageException(message)

Syntax

Visual Basic

Public Sub New ( _

      `message As String _`

)

C#

public PackageException (

      `string message`

)

Parameters

message

 A string that represents the message for the exception.


PackageException Constructor (String, Exception)

This constructor initializes a new instance of the PackageException class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim message As String

Dim inner As Exception

Dim instance As New PackageException(message, inner)

Syntax

Visual Basic

Public Sub New ( _

      `message As String, _`

      `inner As Exception _`

)

C#

public PackageException (

      `string message,`

      `Exception inner`

)

Parameters

message

 The exception message.

inner

 The inner exception.


PackageException Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageException Properties

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)


PackageException Events

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


PackageFilter Class

This class represents a submission package filter that's applied for a TaskResult.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Syntax

Visual Basic

<KnownTypeAttribute(GetType(PackageFilterLogNode))> _

<KnownTypeAttribute(GetType(PackageFilterConstraint))> _

<DataContractAttribute> _

Public Class PackageFilter

           `Implements IFilter`

C#

[KnownTypeAttribute(typeof(PackageFilterLogNode))]

[KnownTypeAttribute(typeof(PackageFilterConstraint))]

[DataContractAttribute]

public class PackageFilter : IFilter

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageFilter**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter Members

The following table lists the members exposed by the PackageFilter type.

Public Properties

Name | Description
Constraints | This property represents the filter constraints for the filter.
ExpirationDate | This property represents the expiration date for the filter.
FilterNumber | This property represents the filter ID number.
IsLogRequired | This property represents a value indicating whether the logs are required for this filter to be applicable.
IsResultRequired | This property represents a value indicating whether the results are required for this filter to be applicable.
IssueDescription | This property represents the issue description for the filter.
IssueResolution | This property represents the issue resolution for the filter.
LastModifiedDate | This property represents the last modified date for the filter.
LogNodes | This property represents the filter log nodes for the filter.
ShouldFilterAllZeros | This property represents a value indicating whether the filter should be applied for not run task results.
ShouldFilterNotRuns | This property represents a value indicating whether the filter should be applied for not run task results.
Status | This property represents the status for the filter.
TestCommandLine | This property represents the CommandLine for the test being filtered.
Title | This property represents the filter title.
Type | This property represents the filter type for the given filter.
Version | This property represents the version for the filter.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
IsApplicable |
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageFilter Methods

Public Methods

Name | Description
Equals | Overloaded.
GetHashCode | Overridden. This method serves as a hash function for a particular type.
GetType | (Inherited from Object)
IsApplicable | This method determines whether the filter is applicable for the given task result.
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageFilter.Equals Method

Overload List

PackageFilter.Equals (IFilter) | Determines whether the specified PackageFilter is equal to the current PackageFilter.
PackageFilter.Equals (Object) | Determines whether the specified Object is equal to the current Object.


PackageFilter.Equals Method (IFilter)

This method compares two PackageFilter instances.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim other As IFilter

Dim returnValue As Boolean

returnValue = instance.Equals(other)

Syntax

Visual Basic

Public Function Equals ( _

      `other As IFilter _`

) As Boolean

C#

public bool Equals (

      `IFilter other`

)

Parameters

other

 The **PackageFilter** to compare.

Return Value

true if the two objects are equal; otherwise, false.

Thread Saftey

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.Equals Method (Object)

This method compares the specified object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **PackageFilter** object.

Return Value

true if the two objects are equal; otherwise, false.

Thread Saftey

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.GetHashCode Method

This method serves as a hash function for a particular type.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number which is the PackageFilter hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.IsApplicable Method

This method determines whether the filter is applicable for the given taskResult.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim constraintEvaluator As IFilterConstraintEvaluator

Dim returnValue As Boolean

returnValue = instance.IsApplicable(constraintEvaluator)

Syntax

Visual Basic

Public Function IsApplicable ( _

      `constraintEvaluator As IFilterConstraintEvaluator`

) As Boolean

C#

public bool IsApplicable (

      `IFilterConstraintEvaluator constraintEvaluator`

)

Parameters

constraintEvaluator

 The filter constraint evaluator.

Return Value

true if applicable; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter Properties

Public Properties

Name | Description
Constraints | This property represents the filter constraints for the filter.
ExpirationDate | This property represents the expiration date for the filter.
FilterNumber | This property represents the filter ID number.
IsLogRequired | This property represents a value indicating whether the logs are required for this filter to be applicable.
IsResultRequired | This property represents a value indicating whether the results are required for this filter to be applicable.
IssueDescription | This property represents the issue description for the filter.
IssueResolution | This property represents the issue resolution for the filter.
LastModifiedDate | This property represents the last modified date for the filter.
LogNodes | This property represents the filter log nodes for the filter.
ShouldFilterAllZeros | This property represents a value indicating whether the filter should be applied for not run task results.
ShouldFilterNotRuns | This property represents a value indicating whether the filter should be applied for not run task results.
Status | This property represents the status for the filter.
TestCommandLine | This property represents the CommandLine for the test being filtered.
Title | This property represents the filter title.
Type | This property represents the filter type for the given filter.
Version | This property represents the version for the filter.


PackageFilter.Constraints Property

This property represents the filter constraints for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As ReadOnlyCollection(Of IFilterConstraint)

returnValue = instance.Constraints

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Constraints As ReadOnlyCollection(Of IFilterConstraint)

C#

[DataMemberAttribute]

public ReadOnlyCollection<IFilterConstraint> Constraints { get; }

)

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.ExpirationDate Property

This property represents the expiration date for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Nullable(Of DateTime)

value = instance.ExpirationDate

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ExpirationDate As Nullable(Of DateTime)

C#

[DataMemberAttribute]

public Nullable<DateTime> ExpirationDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.FilterNumber Property

This property represents the expiration date for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Nullable(Of DateTime)

value = instance.ExpirationDate

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ExpirationDate As Nullable(Of DateTime)

C#

[DataMemberAttribute]

public Nullable<DateTime> ExpirationDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.IsLogRequired Property

This property represents a value indicating whether the logs are required for this filter to be applicable.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Boolean

value = instance.IsLogRequired

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property IsLogRequired As Boolean

C#

[DataMemberAttribute]

public bool IsLogRequired { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.IsResultRequired Property

This property represents a value indicating whether the results are required for this filter to be applicable.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Boolean

value = instance.IsResultRequired

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property IsResultRequired As Boolean

C#

[DataMemberAttribute]

public bool IsResultRequired { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.IssueDescription Property

This property represents the issue description for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As String

value = instance.IssueDescription

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property IssueDescription As Boolean

C#

[DataMemberAttribute]

public string IssueDescription { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.IssueResolution Property

This property represents the issue resolution for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As String

value = instance.IssueResolution

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property IssueResolution As String

C#

[DataMemberAttribute]

public string IssueResolution { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.LastModifiedDate Property

This property represents the last modified date for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As DateTime

value = instance.LastModifiedDate

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property LastModifiedDate As DateTime

C#

[DataMemberAttribute]

public DateTime LastModifiedDate { get; }

Property Value

Returns DateTime.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.LogNodes Property

This property represents the filter log nodes for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As ReadOnlyCollection(Of IFilterLogNode)

value = instance.LogNodes

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property LogNodes As ReadOnlyCollection(Of IFilterLogNode)

C#

[DataMemberAttribute]

public ReadOnlyCollection<IFilterLogNode> LogNodes { get; }

Property Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.ShouldFilterAllZeros Property

This property represents a value indicating whether the filter should be applied if the pass and fail count are both zero.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Boolean

value = instance.ShouldFilterAllZeros

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ShouldFilterAllZeros As Boolean

C#

[DataMemberAttribute]

public bool ShouldFilterAllZeros { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.ShouldFilterNotRuns Property

This property represents a value indicating whether the filter should be applied for not run task results.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Boolean

value = instance.ShouldFilterNotRuns

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property ShouldFilterNotRuns As Boolean

C#

[DataMemberAttribute]

public bool ShouldFilterNotRuns { get; }

Property Value

Returns Boolean.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.Status Property

This property represents the status for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As FilterStatus

value = instance.Status

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Status As FilterStatus

C#

[DataMemberAttribute]

public FilterStatus Status { get; }

Property Value

Returns FilterStatus Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.TestCommandLine Property

This property represents the CommandLine for the test being filtered.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As String

value = instance.TestCommandLine

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property TestCommandLine As String

C#

[DataMemberAttribute]

public string TestCommandLine { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.Title Property

This property represents the filter title.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As String

value = instance.Title

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Title As String

C#

[DataMemberAttribute]

public string Title { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.Type Property

This property represents the filter type for the given filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As FilterType

value = instance.Type

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Type As FilterType

C#

[DataMemberAttribute]

public FilterType Type { get; }

Property Value

Returns FilterType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilter.Version Property

This property represents the version for the filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilter

Dim value As Integer

value = instance.Version

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Version As Integer

C#

[DataMemberAttribute]

public int Version { get; }

Property Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint Class

This class represents a filter constraint for the package filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Syntax

Visual Basic

<DataContractAttribute> _

Public Class PackageFilterConstraint

           `Implements IFilterConstraint`

C#

[DataContractAttribute]

public class PackageFilterConstraint : IFilterConstraint

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageFilterConstraint**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint Members

The following table lists the members exposed by the PackageFilterConstraint type.

Public Properties

Name | Description
Filter |
GathererLocation |
Query |
Type |

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageFilterConstraint Methods

Public Methods

Name | Description
Equals | Overloaded.
GetHashCode | Overridden. This method serves as a hash function for a particular package filter type.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageFilterConstraint.Equals Method

Overload List

PackageFilterConstraint.Equals (PackageFilterConstraint) | Determines whether the specified PackageFilterConstraint is equal to the current PackageFilterConstraint.
PackageFilterConstraint.Equals (Object) | Determines whether the specified Object is equal to the current Object.


PackageFilterConstraint.Equals Method (PackageFilterConstraint)

This method compares two PackageFilterConstraint objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim other As PackageFilterConstraint

Dim returnValue As Boolean

returnValue = instance.Equals(other)

Syntax

Visual Basic

Public Function Equals ( _

      `other As PackageFilterConstraint _`

) As Boolean

C#

public bool Equals (

      `PackageFilterConstraint other`

)

Parameters

other

 The **PackageFilterConstraint** to compare.

Return Value

true if the two objects are equal; otherwise, false.

Thread Saftey

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint.Equals Method (Object)

This method determines whether the specified object is equal to the current object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **PackageFilter** object.

Return Value

true if the two objects are equal; otherwise, false.

Thread Saftey

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint.GetHashCode Method

This method serves as a hash function for a particular package filter type.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number which is the PackageFilterConstraint hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint Properties

Public Properties

Name | Description
Filter | This property represents the associated filter for this constraint.
GathererLocation | This property represents the type of filter constraint.
Query | This property represents the XPath value for the filter constraint.
Type | This property represents the different types of filter constraints.


PackageFilterConstraint.Filter Property

This property represents the associated filter for this constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim value As As IFilter

value = instance.Filter

Syntax

Visual Basic

<IgnoreDataMemberAttribute> _

Public Property Filter As IFilter

C#

[IgnoreDataMemberAttribute]

public IFilter Filter { get; }

Property Value

Returns IFilter Interface.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint.GathererLocation Property

This property represents the type of filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim value As String

value = instance.GathererLocation

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property GathererLocation As String

C#

[DataMemberAttribute]

public string GathererLocation { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint.Query Property

This property represents the XPath value for the filter constraint.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim value As String

value = instance.Query

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Query As String

C#

[DataMemberAttribute]

public string Query { get; }

Property Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterConstraint.Type Property

This property represents the different types of filter constraints.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterConstraint

Dim value As FilterConstraintType

value = instance.Type

Syntax

Visual Basic

<DataMemberAttribute> _

Public Property Type As FilterConstraintType

C#

[DataMemberAttribute]

public FilterConstraintType Type { get; }

Property Value

Returns FilterConstraintType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterLogNode Class

This class represents a log node for the package filter.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterLogNode

Syntax

Visual Basic

<DataContractAttribute> _

Public Class PackageFilterLogNode

           `Implements IFilterLogNode`

C#

[DataContractAttribute]

public class PackageFilterConstraint : IFilterLogNode

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageFilterLogNode**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterLogNode Members

The following table lists the members exposed by the PackageFilterConstraint type.

Public Properties

Name | Description
Attribute | This property represents the attribute for the filter log node.
ChildNodes | This property represents the child nodes for the filter log node.
EndTag | This property represents the XML end tag for the filter log node.
Filter | This property represents the associated filter for this filter log node.
IsMatchOnce | This property represents a value indicating whether the log node should be matched only once.
Parent | This property represents the parent node for this filter log node.
Regex | This property represents the regex for the filter log node.
RequireAllClear | This property represents a value indicating whether the filter log node requires all clear.
StartTag | This property represents the XML start tag for the filter log node.

Public Methods

Name | Description
Equals | Overloaded.
GetHashCode | Overridden. This method serves as a hash function for a particular type.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageFilterLogNode Methods

Public Methods

Name | Description
Equals | Overloaded.
GetHashCode | Overridden. This method serves as a hash function for a particular type.
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageFilterLogNode.Equals Method

Overload List

PackageFilterLogNode.Equals (PackageFilterLogNode) | Determines whether the specified PackageFilterLogNode is equal to the current PackageFilterLogNode.
PackageFilterLogNode.Equals (Object) | Determines whether the specified Object is equal to the current Object.


PackageFilterLogNode.Equals Method (PackageFilterLogNode)

This method compares two PackageFilterLogNode objects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterLogNode

Dim other As PackageFilterLogNode

Dim returnValue As Boolean

returnValue = instance.Equals(other)

Syntax

Visual Basic

Public Function Equals ( _

      `other As PackageFilterLogNode _`

) As Boolean

C#

public bool Equals (

      `PackageFilterLogNode other`

)

Parameters

other

 The **PackageFilterConstraint** to compare.

Return Value

true if the two objects are equal; otherwise, false.

Thread Saftey

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterLogNode.Equals Method (Object)

This method determines whether the specified object is equal to the current object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterLogNode

Dim obj As Object

Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic

Public Overrides Function Equals ( _

      `obj As Object _`

) As Boolean

C#

public override bool Equals (

      `Object obj`

)

Parameters

obj

 An object to compare against this **PackageFilter** object.

Return Value

true if the two objects are equal; otherwise, false.

Thread Saftey

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterLogNode.GetHashCode Method

This method serves as a hash function for a particular package filter type.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageFilterLogNode

Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic

Public Overrides Function GetHashCode As Integer

C#

public override int GetHashCode ()

Return Value

Returns Int32, which is a unique number which is the PackageFilterConstraint hash code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageFilterLogNode Properties

Public Properties

Name | Description
Attribute | This property represents the attribute for the filter log node.
ChildNodes | This property represents the child nodes for the filter log node.
EndTag | This property represents the XML end tag for the filter log node.
Filter | This property represents the associated filter for this filter log node.
IsMatchOnce | This property represents a value indicating whether the log node should be matched only once.
Parent | This property represents the parent node for this filter log node.
Regex | This property represents the regex for the filter log node.
RequireAllClear | This property represents a value indicating whether the filter log node requires all clear.
StartTag | This property represents the XML start tag for the filter log node.


PackageManager Class

This class include methods that handle opening a certification package and presenting the contents to the Windows Hardware Certification Kit (Windows HCK) object model.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Syntax

Visual Basic

Public Class PackageManager

           `Implements ProjectManager`

           `Implements IDisposable`

C#

public class PackageManager : ProjectManager, IDisposable

Inheritance Hierarchy

System.Object

ProjectManager Class

**Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageManager**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager Members

The following table lists the members exposed by the PackageManager Class.

Public Constructors

Name | Description
PackageManager(String) | Overloaded.

Public Fields

Name | Description
PackageVersionString | The version (string) for the package version that this PackageManager can open.
WinBlueVersion | Specifies the version for packages created for WinBlue.
Win8Version | Specifies the version for packages created for Win8 (HCK 2.0).
WinThresholdAndRedstoneVersion | Specifies the version for packages created for Windows 10.
PackageDownlevelVersions | A list of downlevel versions that packages can target.

Public Properties

Name | Description
Certificate | This property represents the certificate used to sign a submission package. This property will be null if the package is not signed.
ConnectionType | Overridden. This property represents the connection type for this submission package.
FileName | This property represents the filename of the submission package that was opened.
PackageVersion | This property represents the package version that this instance of PackageManager is able to read.
Version | This property represents the major version of the Windows HCK Controller. (Inherited from ProjectManager Class)
VersionString | This property represents the version of the Windows HCK Controller and its content. (Inherited from ProjectManager Class)

Protected Properties

Name | Description
IsDisposed | This property represents a value indicating whether this object has already freed its resources. (Inherited from ProjectManager Class)

Public Methods

Public Methods

Name | Description
CreateDeviceFamily | Overridden. This method creates a new device family to use.
CreateProject | Overridden. This method creates a new project within the submission package.
DeleteDeviceFamily | Overridden. This method deletes a device family.
DeleteProject | Overridden. This method deletes a project from the submission package.
Equals | (Inherited from Object)
ExtractDriverPackages | This method extracts all the driver packages linked with a submission package.
ExtractSupplementalFiles | This method extracts all the "supplemental files" linked with a submission package.
GetDeviceFamilies | Overridden. This method retrieves a list of all of the device families used in this submission package.
GetFeatures | Overridden. This method retrieves the features found within the submission package.
GetFilters | Overridden. This method retrieves the filters present in the submission package. Getting filters from a package is not supported.
GetHashCode | (Inherited from Object)
GetPlatforms | Gets a collection of all platforms.
GetProductTypes | Overridden. This method retrieves the product types found within the package.
GetProject | Overridden. This method retrieves a Submission from the package that matches projectName.
GetProjectInfo | Gets the ProjectInfo Class for a specific project.
GetProjectInfoList | Overridden. This method retrieves a list containing one ProjectInfo object per Project found in the submission package.
GetProjectNames | Overridden. This method retrieves a list of names for projects stored in this package.
GetProjectSummary | Gets a collection of ProjectSummary objects for all the projects.
GetRequirements | Overridden. This method retrieves the requirements found within the submission package.
GetRootMachinePool | Overridden. This method retrieves the root machine pool for this package.
GetType | (Inherited from Object)
Sign | Sign an existing package.
ToString | (Inherited from Object)
VerifySignature | This method is no longer valid. Use IOpcFactory and CreateDigitalSignatureManager to detect signatures.

Protected Methods

Name | Description
Dispose | This method implements the IDisposable interface. (Inherited from ProjectManager Class)
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageManager Fields

Public Fields

Name | Description
PackageVersionString | The version (string) for the package version that this PackageManager can open.
WinBlueVersion | Specifies the version for packages created for WinBlue.
Win8Version | Specifies the version for packages created for Win8 (HCK 2.0).
WinThresholdAndRedstoneVersion | Specifies the version for packages created for Windows 10.
PackageDownlevelVersions | A list of downlevel versions that packages can target.


PackageDownlevelVersions Field

A list of downlevel versions that packages can target.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Syntax

C#

public readonly List<string> PackageDownlevelVersions

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.PackageVersionString Field

The version (string) for the package version that this PackageManager may open.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim value As String

value = PackageManager.PackageVersionString

Syntax

Visual Basic

Public Const PackageVersionString As String

C#

public const string PackageVersionString

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.WinBlueVersion Field

Specifies the version for packages created for WinBlue.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Syntax

C#

public const string WinBlueVersion

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


WinThresholdAndRedstoneVersion Field

Specifies the version for packages created for Windows 10.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Syntax

C#

public const string WinThresholdAndRedstoneVersion

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.Win8Version Field

Specifies the version for packages created for Win8 (HCK 2.0).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Syntax

C#

public const string Win8Version

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager Constructor

Public Constructors

Name | Description
PackageManager(String) | This constructor initializes a new instance of the PackageManager class.


PackageManager Constructor (String)

This constructor initializes a new instance of the PackageManager class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Usage

Visual Basic

Dim packagePath As String

Dim instance As New PackageManager(packagePath)

Syntax

Visual Basic

Public Sub New ( _

      `packagePath As String _`

)

C#

public PackageException (

      `string packagePath`

)

Parameters

packagePath

 The path to the package file that this instance manages.

Remarks

An exception is thrown if packagePath is null or invalid, or if there is more than one relationship.


PackageManager Methods

Public Methods

Name | Description
CreateDeviceFamily | Overridden. This method creates a new device family to use.
CreateProject | Overridden. This method creates a new project within the submission package.
DeleteDeviceFamily | Overridden. This method deletes a device family.
DeleteProject | Overridden. This method deletes a project from the submission package.
Equals | (Inherited from Object)
ExtractDriverPackages | This method extracts all the driver packages linked with a submission package.
ExtractSupplementalFiles | This method extracts all the "supplemental files" linked with a submission package.
GetDeviceFamilies | Overridden. This method retrieves a list of all of the device families used in this submission package.
GetFeatures | Overridden. This method retrieves the features found within the submission package.
GetFilters | Overridden. This method retrieves the filters present in the submission package. Getting filters from a package is not supported.
GetHashCode | (Inherited from Object)
GetPlatforms | Gets a collection of all platforms.
GetProductTypes | Overridden. This method retrieves the product types found within the package.
GetProject | Overridden. This method retrieves a Submission from the package that matches projectName.
GetProjectInfo | Gets the ProjectInfo Class for a specific project.
GetProjectInfoList | Overridden. This method retrieves a list containing one ProjectInfo object per Project found in the submission package.
GetProjectNames | Overridden. This method retrieves a list of names for projects stored in this package.
GetProjectSummary | Gets a collection of ProjectSummary objects for all the projects.
GetRequirements | Overridden. This method retrieves the requirements found within the submission package.
GetRootMachinePool | Overridden. This method retrieves the root machine pool for this package.
GetType | (Inherited from Object)
Sign | Sign an existing package.
ToString | (Inherited from Object)
VerifySignature | This method is no longer valid. Use IOpcFactory and CreateDigitalSignatureManager to detect signatures.

Protected Methods

Name | Description
Dispose | This method implements the IDisposable interface. (Inherited from ProjectManager Class)
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageManager.CreateDeviceFamily Method

This method creates a new device family with the given name.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim name As String

Dim familyIds As IEnumerable(Of String)

Dim returnValue As DeviceFamily

returnValue = instance.CreateDeviceFamily(name, familyIds)

Syntax

Visual Basic

Public Overrides Function CreateDeviceFamily ( _

      `name As String, _`

      `familyIds As IEnumerable(Of String) _`

) As DeviceFamily

C#

public override DeviceFamily CreateDeviceFamily (

      `string name,`

      `IEnumerable<string> familyIds`

)

Parameters

name

 The name to create the device family with.

familyIds

 The list of ID values to use for the device family.

Return Value

Returns a DeviceFamily Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.CreateProject Method

This method creates a new project in a submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim projectName As String

returnValue As Project

returnValue = instance.CreateProject(projectName)

Syntax

Visual Basic

Public Overrides Function CreateProject ( _

      `projectName As String, _`

) As Project

C#

public override Project CreateProject (

      `string projectName`

)

Parameters

projectName

 The name of the project to create.

Return Value

Returns Project Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.DeleteDeviceFamily Method

This method deletes a device family.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim name As String

instance.DeleteDeviceFamily(name)

Syntax

Visual Basic

Public Overrides Sub DeleteDeviceFamily ( _

      `name As String _`

)

C#

public override void DeleteDeviceFamily (

      `string name`

)

Parameters

name

 The name of the device family to delete.

Remarks

A NotSupported exception is always thrown when this functionality is not supported by a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.DeleteProject Method

This method deletes a project from the submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim projectNameToDelete As String

instance.DeleteProject(projectNameToDelete)

Syntax

Visual Basic

Public Overrides Sub DeleteProject ( _

      `projectNameToDelete As String _`

)

C#

public override void DeleteProject (

      `string projectNameToDelete`

)

Parameters

projectNameToDelete

      The name of the project to delete.

Remarks

An exception is thrown if the method attempts to delete a project from a package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.Dispose Method

This method disposes this instance of the PackageManager object.

Usage

Visual Basic

Dim disposing As Boolean

Me.Dispose(disposing)

Syntax

Visual Basic

Protected Overrides Sub Dispose ( _

      `disposing As Boolean _`

)

C#

public override void Dispose ()

      `bool disposing`

)

Parameters

disposing

 Dispose of unmanaged resources.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.ExtractDriverPackages Method

This method extracts all the driver packages linked with a submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim path As String

instance.ExtractDriverPackages(path)

Syntax

Visual Basic

Public Sub ExtractDriverPackages ( _

      `path As String, _`

)

C#

public void ExtractDriverPackages (

      `string path`

)

Parameters

path

 The path under which the driver packages are to be extracted.

Remarks

An exception is thrown if path is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.ExtractSupplementalFiles Method

This method extracts all the "supplemental files" linked with a submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim path As String

instance.ExtractSupplementalFiles(path)

Syntax

Visual Basic

Public Sub ExtractSupplementalFiles ( _

      `path As String _`

)

C#

public void ExtractSupplementalFiles (

      `string path`

)

Parameters

path

 The path under which the supplemental files are to be extracted.

Remarks

An exception is thrown if path is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetDeviceFamilies Method

This method retrieves a list of all of the device families used in this submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As ReadOnlyCollection(Of DeviceFamily)

returnValue = instance.GetDeviceFamilies

Syntax

Visual Basic

Public Overrides Function GetDeviceFamilies As ReadOnlyCollection(Of DeviceFamily)

C#

public override ReadOnlyCollection<DeviceFamily> GetDeviceFamilies ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetFeatures Method

This method retrieves the features found within the submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As ProjectManager

Dim returnValue As ReadOnlyCollection(Of Feature)

returnValue = instance.GetFeatures

Syntax

Visual Basic

Public Overrides Function GetFeatures As ReadOnlyCollection(Of Feature)

C#

public override ReadOnlyCollection<Feature> GetFeatures ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetFilters Method

This method retrieves the filters present in the submission package. Getting filters from a package is not supported.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As ReadOnlyCollection(Of IFilter)

returnValue = instance.GetFilters

Syntax

Visual Basic

Public Overrides Function GetFilters As ReadOnlyCollection(Of IFilter)

C#

public override ReadOnlyCollection<IFilter> GetFilters ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetPlatforms Method

Gets a collection of all platforms.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public override ReadOnlyCollection<OSPlatform> GetPlatforms()

Return Value

Returns an empty collection; the Project Manager object is not connected to a Database.

Remarks

Getting OS Platform objects is supported only when the Project Manager object is connected to a Database.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetProductTypes Method

This method retrieves the product types found within the package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As ReadOnlyCollection(Of ProductType)

returnValue = instance.GetProductTypes

Syntax

Visual Basic

Public Overrides Function GetProductTypes As ReadOnlyCollection(Of ProductType)

C#

public override ReadOnlyCollection<ProductType> GetProductTypes ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetProject Method

This method retrieves a Submission from the package that matches projectName.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim projectName As String

Dim returnValue As Project

returnValue = instance.GetProject(projectName)

Syntax

Visual Basic

Public Overrides Function GetProject ( _

      `projectName As String _`

) As Project

C#

public override Project GetProject (

      `string projectName`

)

Parameters

projectName

 The name to uniquely identify the submission.

Return Value

Returns Project Class.

Remarks

An exception occurs if projectName is null or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetProjectInfo Method

Gets the ProjectInfo Class for a specific project.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public override ProjectInfo GetProjectInfo (

      `string projectName`

)

Parameters

projectName

Case-insensitive name of project to load.

Return Value

Returns a ProjectInfo Class for the requested project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetProjectInfoList Method

This method retrieves a list containing one ProjectInfo Class object per Project found in the submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As ReadOnlyCollection(Of ProjectInfo)

returnValue = instance.GetProjectInfoList

Syntax

Visual Basic

Public Overrides Function GetProjectInfoList As ReadOnlyCollection(Of ProjectInfo)

C#

public override ReadOnlyCollection<ProjectInfo> GetProjectInfoList ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetProjectNames Method

This method retrieves a list of names for projects stored in this package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As ReadOnlyCollection(Of String)

returnValue = instance.GetProjectNames

Syntax

Visual Basic

Public Overrides Function GetProjectNames As ReadOnlyCollection(Of String)

C#

public override ReadOnlyCollection<string> GetProjectNames ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetProjectSummary Method

Gets a collection of ProjectSummary objects for all the projects.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public override ReadOnlyCollection<ProjectSummary> GetProjectSummary()

Return Value

Returns a read-only collection of ProjectSummary objects.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetRequirements Method

This method retrieves the requirements found within the submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As ReadOnlyCollection(Of Requirement)

returnValue = instance.GetRequirements

Syntax

Visual Basic

Public Overrides Function GetRequirements As ReadOnlyCollection(Of Requirement)

C#

public override ReadOnlyCollection<Requirement> GetRequirements ()

Return Value

Returns ReadOnlyCollection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.GetRootMachinePool Method

This method retrieves the root machine pool for this package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim returnValue As MachinePool

returnValue = instance.GetRootMachinePool

Syntax

Visual Basic

Public Overrides Function GetRootMachinePool As MachinePool

C#

public override MachinePool GetRootMachinePool ()

Return Value

Returns MachinePool Class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.Sign Method

Overload List

Name | Description
Sign Method (String, X509Certificate) | Sign an existing package.
Sign Method (String, X509Certificate, String) | Sign an existing package.


PackageManager.Sign Method (String, X509Certificate)

Sign an existing package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static void Sign (

      `string sourcePackage,`

      `X509Certificate certificate`

)

Parameters

sourcePackage

File name (including path) to the package file.

certificate

The certificate used for signing.

Remarks

The package specified is signed and replaced. This is equivalent to invoking the Sign(String, X509Certificate, String) Method.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.Sign Method (String, X509Certificate, String)

Sign an existing package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static void Sign (

      `string sourcePackage,`

      `X509Certificate certificate,`

      `string outputPackage`

)

Parameters

sourcePackage

File name (including path) to the package file.

certificate

The certificate used for signing.

certificate

File name (including path) to the signed package.

Remarks

If the sourcePackage and outputPackage parameters are the same the package will be replaced.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.VerifySignature Method

This method is no longer valid. Use IOpcFactory and CreateDigitalSignatureManager to detect signatures.


PackageManager Properties

[This content is not available in this preliminary release.]

Public Properties

Name | Description
Certificate | This property represents the certificate used to sign a submission package. This property will be null if the package is not signed.
ConnectionType | Overridden. This property represents the connection type for this submission package.
FileName | This property represents the filename of the submission package that was opened.
PackageVersion | This property represents the package version that this instance of PackageManager is able to read.
Version | This property represents the major version of the Windows HCK Controller. (Inherited from ProjectManager Class)
VersionString | This property represents the version of the Windows HCK Controller and its content. (Inherited from ProjectManager Class)

Protected Properties

Name | Description
IsDisposed | This property represents a value indicating whether this object has already freed its resources. (Inherited from ProjectManager Class)


PackageManager.Certificate Property

This property represents the certificate used to sign a submission package. This property is null if the package is not signed.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim value As X509Certificate

value = instance.Certificate

Syntax

Visual Basic

Public ReadOnly Property Certificate As X509Certificate

C#

public X509Certificate Certificate { get; }

Return Value

Returns X509Certificate.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.ConnectionType Property

This property represents the connection type for this submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim value As ConnectionType

value = instance.ConnectionType

Syntax

Visual Basic

Public Overrides ReadOnly Property ConnectionType As ConnectionType

C#

public override ConnectionType ConnectionType { get; }

Return Value

Returns ConnectionType Enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.FileName Property

This property represents the filename of the submission package that was opened.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim value As String

value = instance.FileName

Syntax

Visual Basic

Public Property FileName As String

C#

public string FileName { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageManager.PackageVersion Property

This property represents the package version that this instance of PackageManager is able to read.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageManager

Dim value As Version

value = instance.PackageVersion

Syntax

Visual Basic

Public ReadOnly Property PackageVersion As Version

C#

public Version PackageVersion { get; }

Return Value

Returns Version.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageProgressInfo Class

This class creates a new instance of the type PackageProgressEventArgs.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageProgressInfo

Syntax

Visual Basic

Public Class PackageProgressInfo

C#

public class PackageProgressInfo

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageProgressInfo**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageProgressInfo Members

The following table lists the members exposed by the PackageProgressInfo type.

Public Properties

Name | Description
Current | This property (number) represents the current object being processed.
Maximum | This property (number) represents the maximum number of objects to process.
Message | This property is a string that represents the current object.

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageProgressInfo Methods

Public Methods

Name | Description
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageProgressInfo Properties

Public Properties

Name | Description
Current | This property (number) represents the current object being processed.
Maximum | This property (number) represents the maximum number of objects to process.
Message | This property is a string that represents the current object.


PackageProgressInfo.Current Property

This property (number) represents the current object being processed.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageProgressInfo

Dim value As Integer

value = instance.Current

Syntax

Visual Basic

Public Property Current As Integer

C#

public int Current { get; }

Return Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageProgressInfo.Maximum Property

This property (number) represents the maximum number of objects to process.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageProgressInfo

Dim value As Integer

value = instance.Maximum

Syntax

Visual Basic

Public Property Maximum As Integer

C#

public int Maximum { get; }

Return Value

Returns Int32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageProgressInfo.Message Property

This property is a string that represents the current object.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageProgressInfo

Dim value As String

value = instance.Message

Syntax

Visual Basic

Public Property Message As String

C#

public string Message { get; }

Return Value

Returns String.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter Class

This PackageWriter class creates or updates submission packages.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Syntax

Visual Basic

Public Class PackageWriter

      `Implements IDisposable`

C#

public class PackageWriter : IDisposable

Inheritance Hierarchy

System.Object

**Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageWriter**

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter Members

The following table lists the members exposed by the PackageWriter Class.

Public Constructors

PackageWriter

Overloaded.

Public Properties

Name | Description
PackageVersion | This property represents the version of the package that this instance of PackageWriter will create.

Public Methods

Name | Description
AddDriver | This method adds driver files to the submission package and checks the driver files for driver signability. This method can only be used for submission packages. It cannot be used for update packages. The signability tests are done when drivers are added to the package. If the signability tests fail the driver is not added to the package. Down level operating system signability tests are automatically run. Errors from these signability results will not prevent submission creation (will not cause a false return value).The error messages for down level operating system signability runs will be captured and returned as warnings.
AddReplacementDriver | This method replaces a driver in the submission package. This method can only be used for update packages.
AddSupplementalFiles | This method adds all of the files in a specified directory to a submission package. This method can be used for both submission packages and update packages.
Dispose | Overloaded.
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
Merge | This method merges a project into an existing package. This method can only be used for existing submission packages.
Save | Overloaded. This class contains methods used to save a submission package.
SavePartialPackage | Overloaded.
SetProgressActionHandler | This method sets an action handler that is used to send out submission progress updates. This method can be used for both submission packages and update packages.
ToString | (Inherited from Object)
TargetFamiliesAreDeepMergeCompatible | Checks if two target families are similar enough for deep merging.
ValidateMerge | Checks the provided project for errors that would occur while merging with the current package.

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageWriter Constructor

Overload List

Name | Description
PackageWriter (Project) | This constructor initializes a new instance of the PackageWriter class. This constructor is used for creating a new submission package. This constructor cannot be used to create an Update Package (for DUA).
PackageWriter (String) | This constructor initializes a new instance of the PackageWriter class.


PackageWriter Constructor (Project)

This constructor initializes a new instance of the PackageWriter class. This constructor is used for creating a new submission package. This constructor cannot be used to create an Update Package (for DUA).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim packagePath As Project

Dim instance As New PackageWriter(project)

Syntax

Visual Basic

Public Sub New ( _

      `project As Project _`

)

C#

public PackageWriter (

      `Project project`

)

Parameters

project

 The name of the project for which a package object is created.


PackageWriter Constructor (Project, ConnectionType)

[This content is not available in this preliminary release.]


PackageWriter Methods

Public Methods

Name | Description
AddDriver | This method adds driver files to the submission package and checks the driver files for driver signability. This method can only be used for submission packages. It cannot be used for update packages. The signability tests are done when drivers are added to the package. If the signability tests fail the driver is not added to the package. Down level operating system signability tests are automatically run. Errors from these signability results will not prevent submission creation (will not cause a false return value).The error messages for down level operating system signability runs will be captured and returned as warnings.
AddReplacementDriver | This method replaces a driver in the submission package. This method can only be used for update packages.
AddSupplementalFiles | This method adds all of the files in a specified directory to a submission package. This method can be used for both submission packages and update packages.
Dispose | Overloaded.
Equals | (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
Merge | This method merges a project into an existing package. This method can only be used for existing submission packages.
Save | Overloaded. This class contains methods used to save a submission package.
SavePartialPackage | Overloaded.
SetProgressActionHandler | This method sets an action handler that is used to send out submission progress updates. This method can be used for both submission packages and update packages.
ToString | (Inherited from Object)
TargetFamiliesAreDeepMergeCompatible | Checks if two target families are similar enough for deep merging.
ValidateMerge | Checks the provided project for errors that would occur while merging with the current package.

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)


PackageWriter.AddDriver Method

This method replaces a driver for an Update Package and checks the driver files for driver signability. The signability tests are done when drivers are added to the package. If the signability tests fail the driver is not added to the package. Down level OS signability tests are automatically run. Errors from these signability results will not prevent submission creation (will not cause a false return value). The error messages for down level operating system signability runs will be captured and returned as warnings.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Dim pathToDriver As String

Dim pathToSymbols As String

Dim targets As ReadOnlyCollection(Of Target)

Dim locales As ReadOnlyCollection(Of String)

Dim errorMessages As StringCollection

Dim warningMessages As StringCollection

Dim returnValue As Boolean

returnValue = instance.AddDriver(pathToDriver, pathToSymbols, targets, locales, errorMessages, warningMessages)

Syntax

Visual Basic

Public Function AddDriver ( _

      `pathToDriver As String, _`

      `pathToSymbols As String, _`

      `targets As ReadOnlyCollection(Of Target), _`

      `locales As ReadOnlyCollection(Of String), _`

      `<OutAttribute> ByRef errorMessages As StringCollection, _`

      `<OutAttribute> ByRef warningMessages As StringCollection _`

) As Boolean

C#

public bool AddDriver (

      `string pathToDriver,`

      `string pathToSymbols,`

      `ReadOnlyCollection<Target> targets,`

      `ReadOnlyCollection<string> locales,`

      `out StringCollection errorMessages,`

      `out StringCollection warningMessages`

)

Parameters

pathToDriver

 The path to the driver files. All files in this directory and all subdirectories will be packaged.

pathToSymbols

 The path to the symbol files for this driver. This parameter is optional.

targets

 The set of supported test targets for this driver.

locales

 The set of supported locales for this driver.

errorMessages

 A reference to a string collection that contains all the error messages for the submission package.

warningMessages

 A reference to a string collection that contains all the warning messages for the submission package

Return Value

true if the signability tests passed and the driver was added to the package; otherwise, false.

Remarks

An exception is thrown when:

  • The pathToDriver paramter, the targets parameter or the locales parameter is null.

  • The pathToDrivers parameter is empty or there are no targets or locales values in the parameter lists or the targets specified do not exist in the project.

  • The directory does not exist for the pathToDriver parameter or the pathToSymbol parameter.

  • The PackageWriter object has already been disposed.

  • The method calls an invalid connection type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.AddReplacementDriver Method

This method adds driver files to the submission package and checks the driver files for driver signability. This method can only be used for submission packages. It cannot be used for update packages. The signability tests are done when drivers are added to the package. If the signability tests fail the driver is not added to the package. Down level operating system signability tests are automatically run. Errors from these signability results will not prevent submission creation (will not cause a false return value). The error messages for down level operating system signability runs will be captured and returned as warnings.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Dim pathToNewDriver As String

Dim replacesDriverId As String

Dim errorMessages As StringCollection

Dim warningMessages As StringCollection

Dim returnValue As Boolean

returnValue = instance.AddReplacementDriver(pathToNewDriver, replacesDriverId, errorMessages, warningMessages)

Syntax

Visual Basic

Public Function AddReplacementDriver ( _

      `pathToNewDriver As String, _`

      `replacesDriverId As String, _`

      `<OutAttribute> ByRef errorMessages As StringCollection, _`

      `<OutAttribute> ByRef warningMessages As StringCollection _`

) As Boolean

C#

public bool AddReplacementDriver (

      `string pathToNewDriver,`

      `string replacesDriverId,`

      `out StringCollection errorMessages,`

      `out StringCollection warningMessages`

)

Parameters

pathToNewDriver

 The path to the driver files. All files in this directory and all subdirectories (and their files) will be packaged.

replacesDriverId

 The GUID of the driver that this replaces.

errorMessages

 Reference to a string collection that will contain all the error messages.

warningMessages

 Reference to a string collection that will contain all the warning messages.

Return Value

true if the new driver files passed signability; otherwise, false.

Remarks

An exception is thrown when:

  • The pathToDriver paramteror replacesDriverIdis parameter is null.

  • The pathToDriver parameter or replacesDriverId parameter is invalid or if the GUID for replacesDriverId was not found.

  • The PackageWriter object has already been disposed.

  • The method calls an invalid connection type.

  • The directory does not exist for the pathToDriver parameter.

  • The method called for an invalid connection type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.AddSupplementalFiles Method

This method adds supplemental files to the submission package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Syntax

C#

public void AddSupplementalFiles (

      `string pathToSupplementalFiles`

)

Parameters

pathToSupplementalFiles

 The path to the supplemental files. All files in this directory and all subdirectories (and their files) will be packaged.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Dispose Method

Overload List

Name | Description
PackageWriter.Dispose () | This method disposes the PackageWriter class. The method closes the submission package file and cleans up any temporary files created during package creation.
PackageWriter.Dispose (Boolean) | This method disposes this instance of the PackageWriter class.


PackageWriter.Dispose Method ()

This method disposes the PackageWriter class. The method closes the submission package file and cleans up any temporary files created during package creation.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

instance.Dispose

Syntax

Visual Basic

Public Sub Dispose

C#

public void Dispose ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Dispose Method (Boolean)

This method disposes this instance of the PackageWriter class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim disposing As Boolean

Me.Dispose(disposing)

Syntax

Visual Basic

Protected Overrides Sub Dispose ( _

      `disposing As Boolean _`

)

C#

protected override void Dispose (

      `bool disposing`

)

Parameters

disposing

 This parameter controls the disposal of unmanaged resources.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Merge Method

This method merges a project into an existing package. This method can only be used for existing submission packages.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

project As Project

Dim errors As StringCollection

Dim returnValue As Boolean

returnValue = instance.Merge(project, errors)

Syntax

Visual Basic

Public Function Merge ( _

      `project As Project, _`

      `<OutAttribute> ByRef errors As StringCollection _`

) As Boolean

C#

public bool Merge (

      `Project project,`

      `out StringCollection errors`

)

Parameters

project

 The project to merge into the submission package being created.

errors

 Reference to a string collection that returns error messages for merging a project.

Return Value

true if the project was successfully merged into the package; otherwise, false.

Remarks

An exception is thrown when:

  • The PackageWriter object has already been disposed.

  • The project parameter is null.

  • The connection type of the project is not a submission package.

  • There are problems with merging the project or if the PackageWriter object is for a DUA package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Save Method

Overload List

Save Method (String) | This method saves a submission package to disk.
Save Method (String, X509Certificate) | This method saves a package and digitally signs it using an X509-compliant certificate. This method can be used for both submission packages and update submission packages.
Save Method (string, List<TargetFamily>) | Creates an HCK package only containing data in the given target families.
Save Method (string, List<TargetFamily>, X509Certificate) | Creates and signs an HCK package only containing data in the given target familes.


PackageWriter.Save Method (String)

This method saves a submission package to disk.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Dim packageFile As String

instance.Save(packageFile)

Syntax

Visual Basic

Public Sub Save ( _

      `packageFile As String _`

)

C#

public void Save (

      `string packageFile`

)

Parameters

packageFile

 The file name (including the path) specifying where to write the package.

Remarks

This method throws an exception when:

  • The packageFile parameter is null.

  • The packageFile parameter is invalid.

  • The PackageWriter object has already been disposed.

  • There is an IO exception when the package is being closed.

  • The targets that are mapped to a driver are not found in the projects.

  • The package does not have at least one product instance.

  • There is a problem creating a directory and copying the package to that directory.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Save Method (String, X509Certificate)

This method saves a package and digitally signs it using an X509-compliant certificate. This method can be used for both submission packages and update submission packages.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Dim packageFile As String

Dim certificate As X509Certificate

instance.Save(packageFile, certificate)

Syntax

Visual Basic

Public Sub Save ( _

      `packageFile As String, _`

      `certificate As X509Certificate`

)

C#

public void Save (

      `string packageFile,`

      `X509Certificate certificate`

)

Parameters

packageFile

 The full file name specifying where to write the signed package.

certificate

 The certificate to use for signing the package.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Save Method (string, List TargetFamily )

Creates an HCK package only containing data in the given target families.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public void Save (

      `string packageFile,`

      `List<TargetFamily> targetFamilyList`

)

Parameters

packageFile

Name of file to where the package will be saved.

targetFamilyList

List of target families to save.

Remarks

This function can be used for Submission Packages and Update Packages.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.Save Method (string, List TargetFamily , X509Certificate)

Creates and signs an HCK package only containing data in the given target familes.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public void Save (

      `string packageFile,`

      `List<TargetFamily> targetFamilyList,`

      `X509Certificate certificate`

)

Parameters

packageFile

Name of file to where the package will be saved.

targetFamilyList

List of target families to save.

certificate

The certificate to use for signing.

Remarks

This function can be used for Submission Packages and Update Packages.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.SavePartialPackage Method

Overload List

SavePartialPackage Method (string, List<Test>) | Creates a debug HCK package only containing data in the given test(s).
SavePartialPackage Method (string, List<TestResult>) | Creates a debug HCK package only containing data in the given result(s).


PackageWriter.SavePartialPackage Method (string, List Test )

Creates a debug HCK package only containing data in the given test(s).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public void SavePartialPackage (

      `string packageFile,`

      `List<Test> testList`

)

Parameters

packageFile

Name of file to where the package will be saved.

testList

List of tests to save.

Remarks

This function cannot be used for Submission Packages and Update Packages.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.SavePartialPackage Method (string, List TestResult )

Creates a debug HCK package only containing data in the given result(s).

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public void SavePartialPackage (

      `string packageFile,`

      `List<TestResult> resultList`

)

Parameters

packageFile

Name of file to where the package will be saved.

resultList

List of results to save.

Remarks

This function cannot be used for Submission Packages and Update Packages.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.SetProgressActionHandler Method

This method sets an action handler that is used to send out submission progress updates. This method can be used for both submission packages and update packages.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Dim actionHandler As Action(Of PackageProgressInfo)

instance.SetProgressActionHandler(actionHandler)

Syntax

Visual Basic

Public Sub SetProgressActionHandler ( _

      `actionHandler As Action(Of PackageProgressInfo) _`

)

C#

public void SetProgressActionHandler (

      `Action<PackageProgressInfo> actionHandler`

)

Parameters

actionHandler

 The name of the handler to call.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.TargetFamiliesAreDeepMergeCompatible Method

Checks if two target families are similar enough for deep merging.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public static bool TargetFamiliesAreDeepMergeCompatible (

      `TargetFamily firstTargetFamily,`

      `TargetFamily secondTargetFamily`

)

Parameters

firstTargetFamily

First instance of TargetFamily for deep merge comparison.

secondTargetFamily

Second instance of TargetFamily for deep merge comparison.

Return Value

Returns true if the targets' families are similar enough; otherwise it returns false.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter.ValidateMerge Method

Checks the provided project for errors that would occur while merging with the current package.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public IEnumerable<string> ValidateMerge (

Project project,

out StringCollection errorList,

out StringCollection warningList

)

Parameters

project

The specified project to merge.

errorList

A list that contains any error messages that were output during validation.

warningList

A list that contains any warning messages that were output during validation.

Return Value

Returns a collection of error messages if the merge is not supported. If the merge is supported then an empty collection is returned.

Remarks

This method does not merge the project. Use Merge to merge the project.

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageWriter Properties

Public Properties

Name | Description
PackageVersion | This property represents the version of the package that this instance of PackageWriter will create.


PackageWriter.PackageVersion Property

This property represents the version of the package that this instance of PackageWriter will create.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel.Submission (in Microsoft.Windows.Kits.Hardware.ObjectModel.Submission)

Usage

Visual Basic

Dim instance As PackageWriter

Dim value As Version

value = instance.PackageVersion

Syntax

Visual Basic

Public ReadOnly Property PackageVersion As Version

C#

public Version PackageVersion { get; }

Return Value

Returns Version.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


Microsoft.Windows.Kits.Hardware.UI.Views Namespace

In this section

  • PackageDBReaderException Class


PackageDBReaderException Class

This class is a base class for all PackageDBReader exceptions.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

[Serializable]

public class PackageDBReaderException : Exception

Inheritance Hierarchy

System.Object

 **System.Exception**

      **Microsoft.Windows.Kits.Hardware.UI.Views.PackageDBReaderException**

Thread Safety

Any public static members of this type are thread safe. Any instance members are not guaranteed to be thread safe.


PackageDBReaderException Members

The following table lists the members exposed by the PackageDBReaderException Class.

Public Constructors

Name | Description
PackageDBReaderException Constructor (string) | Initializes a new instance of the PackageDBReaderException Class.
PackageDBReaderException Constructor (string, Exception) | Initializes a new instance of the PackageDBReaderException Class.

Protected Constructors

Name | Description
PackageDBReaderException Constructor (SerializationInfo, StreamingContext) | Initializes a new instance of the PackageDBReaderException Class.

Public Properties

Name | Description
Data | (Inherited from Exception)
HelpLink | (Inherited from Exception)
InnerException | (Inherited from Exception)
Message | (Inherited from Exception)
Source | (Inherited from Exception)
StackTrace | (Inherited from Exception)
TargetSite | (Inherited from Exception)

Protected Properties

Name | Description
HResult | (Inherited from Exception)

Public Methods

Name | Description
Equals | (Inherited from Object)
GetBaseException | (Inherited from Exception)
GetHashCode | (Inherited from Object)
GetObjectData | (Inherited from Exception)
GetType | (Inherited from Exception)
ToString | (Inherited from Exception)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

Protected Events

Name | Description
SerializeObjectState | (Inherited from Exception)


PackageDBReaderException Constructor

Public Constructors

Name | Description
PackageDBReaderException Constructor (string) | Initializes a new instance of the PackageDBReaderException Class.
PackageDBReaderException Constructor (string, Exception) | Initializes a new instance of the PackageDBReaderException Class.

Protected Constructors

Name | Description
PackageDBReaderException Constructor (SerializationInfo, StreamingContext) | Initializes a new instance of the PackageDBReaderException Class.


PackageDBReaderException Constructor (string)

Initializes a new instance of the PackageDBReaderException Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PackageDBReaderException (

      `string message`

)

Parameters

message

A string that represents the message for the exception.


PackageDBReaderException Constructor (string, Exception)

Initializes a new instance of the PackageDBReaderException Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

public PackageDBReaderException (

      `string message,`

      `Exception except`

)

Parameters

message

A string that represents the message for the exception.

except

An exception object.


PackageDBReaderException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PackageDBReaderException Class.

Namespace: Microsoft.Windows.Kits.Hardware.ObjectModel

Assembly: Microsoft.Windows.Kits.Hardware.ObjectModel (in Microsoft.Windows.Kits.Hardware.ObjectModel)

Syntax

C#

protected PackageDBReaderException (

      `SerializationInfo serialInfo,`

      `StreamingContext streamCont`

)

Parameters

serialInfo

A SerialInfo object.

streamCont

A Streaming Context Object.